Welcome

LinkOne WebView

API Reference

3.30

June 2023

Overview

The LinkOne team is pleased to announce the general availability of LinkOne WebView 3.30.

WebView exposes .Net development libraries with a documented API to enable you to 'plug in' and synchronize data with your existing systems to provide real time data relevant to the LinkOne part you are currently viewing.

Do you need assistance getting started? The Getting Started Guide, and the Technical Reference Guide are installed to webserver (generally http://localhost/LinkOne/Documentation). If you need further guidance, help answering your tough technical questions, or would like to provide feedback and suggests for the API, be sure to visit the Enterprise Software Online Customer Community (OCC). The OCC is an excellent source of information and provides the opportunity for our partners to meet and discuss LinkOne with our other partners.

For the latest information about LinkOne, upgrades, documentation and tips, please visit our web site.
Copyright (c) 2023 Hitachi Energy. All rights reserved. No portion of this document may be copied, distributed, disassembled or sold without written permission from Hitachi Energy.


Namespaces
Send Feedback

Namespaces

Namespace | Description
Mincom.LinkOne.Adapter | Contains classes used to define the Content Management System service interface and data types.
Mincom.LinkOne.Collections | The Mincom.LinkOne.Collections namespace contains classes that define the behaviour for collections of objects in the LinkOne framework. It also provides some helper classes for performing common operations on sets of data.
Mincom.LinkOne.Common | The Mincom.LinkOne.Common namespace contains classes that provide functionality common to the LinkOne framework.
Mincom.LinkOne.Common.Collections.LockFree |
Mincom.LinkOne.Content.Layout | The Mincom.LinkOne.Content.Layout namespace contains classes that read LinkOne layouts.
Mincom.LinkOne.Content.Searching | The Mincom.LinkOne.Content.Searching namespace contains classes that save LinkOne search results.
Mincom.LinkOne.Content.SelectionList | The Mincom.LinkOne.Content.SelectionList namespace contains classes that read and save LinkOne selection lists.
Mincom.LinkOne.Dom | The Mincom.LinkOne.Dom namespace contains classes and interfaces that represent the LinkOne Document Object Model (DOM). The LinkOne DOM encapsulates the structure of a LinkOne Book as objects that may be accessed via any .Net compatible programming language.
Mincom.LinkOne.Dom.Attributes | The Mincom.LinkOne.Dom.Attributes namespace contains classes that provide access to LinkOne attributes.
Mincom.LinkOne.Dom.EmbeddedObjects | The Mincom.LinkOne.Dom.EmbeddedObjects namespace contains classes that provide access to objects embedded in LinkOne content.
Mincom.LinkOne.Dom.Filtering | The Mincom.LinkOne.Dom.Filtering namespace contains classes that provide functionality for filtering LinkOne content.
Mincom.LinkOne.Dom.Layouts | The Mincom.LinkOne.Dom.Layouts namespace contains classes that provide read/write access to LinkOne layouts.
Mincom.LinkOne.Dom.Licensing | The Mincom.LinkOne.Dom.Licensing namespace contains classes that identify the various LinkOne licenses.
Mincom.LinkOne.Dom.Notes | The Mincom.LinkOne.Dom.Notes namespace contains classes that provide read/write access to LinkOne notes.
Mincom.LinkOne.Dom.Notes.DrawingElements | The Mincom.LinkOne.Dom.Notes.DrawingElements namespace contains classes that describe the drawn elements in a redline note.
Mincom.LinkOne.Dom.Searching | The Mincom.LinkOne.Dom.Searching namespace contains classes that provide searching functionality.
Mincom.LinkOne.Dom.SelectionList | The Mincom.LinkOne.Dom.SelectionList namespace contains classes that provide read/write access to LinkOne selection lists. Generally this is used to exchange parts information with other applications.
Mincom.LinkOne.Dom.Zones | The Mincom.LinkOne.Dom.Zones namespaces contains classes and interfaces for reading zoning data embedded in LinkOne graphical content.
Mincom.LinkOne.Exceptions | The Mincom.LinkOne.Exceptions namespace contains exception classes thrown in LinkOne.
Mincom.LinkOne.Provider | The Mincom.LinkOne.Provider namespace contains classes that provide book reading and writing for LinkOne book content.
Mincom.LinkOne.Provider.Persist | The Mincom.LinkOne.Provider.Persist namespace contains classes that provide persistence management.
Mincom.LinkOne.WebView.Printer.EmfToPdf |
Mincom.LinkOne.WebView.WebServer.Cache |
Mincom.LinkOne.WebView.WebServer.Configuration | The Mincom.LinkOne.WebView.WebServer.Configuration namespace supplies classes that describe how selection lists behave, such as what fields are mapped when adding parts, and where the user interface originate from.
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient |
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities |
Mincom.LinkOne.WebView.WebServer.Exceptions | The Mincom.LinkOne.WebView.WebServer.Exceptions namespace supplies exceptions that are explicit to LinkOne WebView.
Mincom.LinkOne.WebView.WebServer.Handlers |
Mincom.LinkOne.WebView.WebServer.Html | The Mincom.LinkOne.WebView.WebServer.Html namespace supplies classes that implement custom ASP.Net custom controls that are used to build the LinkOne WebView user interface. Each class may be referenced in an aspx page as <LinkOne:class>.
Mincom.LinkOne.WebView.WebServer.Modules |
Mincom.LinkOne.WebView.WebServer.Notifications |
Mincom.LinkOne.WebView.WebServer.Security | The Mincom.LinkOne.WebView.WebServer.Security namespace supplies classes that control what each user can access.
Mincom.LinkOne.WebView.WebServer.Services | The Mincom.LinkOne.WebView.WebServer.Services namespace supplies classes that provide services for accessing and modifying state information on the LinkOne WebView web server.
Mincom.LinkOne.WebView.WebServer.WebServices | The Mincom.LinkOne.WebView.WebServer.WebServices namespace supplies classes that provide web services for accessing and modifying state information on the LinkOne WebView web server.
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts | The Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts namespace supplies classes that are used as data containers in web services.
Mincom.LinkOne.WebView.WebServer.WebServices.Translators |

Send comments on this topic to CustomerCare.ES@abb.com

© 2022 Hitachi Energy. All rights reserved.


Mincom.LinkOne.Adapter Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.Adapter Namespace
Send Feedback
Contains classes used to define the Content Management System service interface and data types.

Classes

Class | Description
CmsProviderException |
ContentAdapterBase |
ContentAdapterFactory | Wraps System.IO calls encapsulating I/O related exceptions in an [!:Mincom.LinkOne.Exceptions.IOException].
DocumentList | Represents a list of documents retrieved from the Cms service.
DocumentReference | Represents a reference to a document stored on a content management system (CMS) server.
Tracing | Trace switch for the assembly.
Utility | Contains common utility functions for implementing the ICmsService interface.

Interfaces

Interface | Description
ICmsService | Defines interface to implement when creating a Provider for connecting to a 3rd Party Content Management System (CMS).
IContentAdapter |

Enumerations

Enumeration | Description
DocumentType | The known set of document types.

Remarks

The client allows users to see documents relating to the current context. These documents are maintained in a Content Management System. Communication with the CMS is established through the ICmsService. Any CMS can be integrated by implementing this interface and configuring the Application to communiate with this service.

By default, LinkOne provides integration with Microsoft SharePoint 2010. Users of other systems must implement their own CMS Web Service.


CmsProviderException Class

[image]

LinkOne WebView API
CmsProviderException Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public class CmsProviderException : Exception
Visual Basic (Declaration)
Public Class CmsProviderException _
    Inherits Exception
Visual C++
public ref class CmsProviderException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
Mincom.LinkOne.Adapter..::.CmsProviderException

See Also

CmsProviderException Members
Mincom.LinkOne.Adapter Namespace


CmsProviderException Members

[image] [image]

LinkOne WebView API
CmsProviderException Members
CmsProviderException Class Constructors Methods Fields Properties See Also Send Feedback

The CmsProviderException type exposes the following members.

Constructors

Name | Description
CmsProviderException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

Name | Description
defaultExceptionMessage |
KeyCmsExceptionMessageResourceName |

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CmsProviderException Class
Mincom.LinkOne.Adapter Namespace


CmsProviderException Constructor

[image] [image]

LinkOne WebView API
CmsProviderException Constructor
CmsProviderException Class See Also Send Feedback

Overload List

Name | Description
CmsProviderException(Exception) | Initializes a new instance of the CmsProviderException class
CmsProviderException(Exception, String) | Initializes a new instance of the CmsProviderException class

See Also

CmsProviderException Class
CmsProviderException Members
Mincom.LinkOne.Adapter Namespace


CmsProviderException Constructor (Exception)

[image]

LinkOne WebView API
CmsProviderException Constructor (Exception)
CmsProviderException Class See Also Send Feedback
Initializes a new instance of the CmsProviderException class

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public CmsProviderException(
    Exception ThrownException
)
Visual Basic (Declaration)
Public Sub New ( _
    ThrownException As Exception _
)
Visual C++
public:
CmsProviderException(
    Exception^ ThrownException
)

Parameters

ThrownException
Type: System..::.Exception

See Also

CmsProviderException Class
CmsProviderException Overload
Mincom.LinkOne.Adapter Namespace


CmsProviderException Constructor (Exception, String)

[image]

LinkOne WebView API
CmsProviderException Constructor (Exception, String)
CmsProviderException Class See Also Send Feedback
Initializes a new instance of the CmsProviderException class

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public CmsProviderException(
    Exception ThrownException,
    string LanguageCode
)
Visual Basic (Declaration)
Public Sub New ( _
    ThrownException As Exception, _
    LanguageCode As String _
)
Visual C++
public:
CmsProviderException(
    Exception^ ThrownException,
    String^ LanguageCode
)

Parameters

ThrownException
Type: System..::.Exception
LanguageCode
Type: System..::.String

See Also

CmsProviderException Class
CmsProviderException Overload
Mincom.LinkOne.Adapter Namespace


CmsProviderException Fields

[image] [image]

LinkOne WebView API
CmsProviderException Fields
CmsProviderException Class See Also Send Feedback

The CmsProviderException type exposes the following members.

Fields

Name | Description
defaultExceptionMessage |
KeyCmsExceptionMessageResourceName |

See Also

CmsProviderException Class
Mincom.LinkOne.Adapter Namespace


defaultExceptionMessage Field

[image]

LinkOne WebView API
CmsProviderException..::.defaultExceptionMessage Field
CmsProviderException Class See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
protected const string defaultExceptionMessage
Visual Basic (Declaration)
Protected Const defaultExceptionMessage As String
Visual C++
protected:
literal String^ defaultExceptionMessage

See Also

CmsProviderException Class
Mincom.LinkOne.Adapter Namespace


KeyCmsExceptionMessageResourceName Field

[image]

LinkOne WebView API
CmsProviderException..::.KeyCmsExceptionMessageResourceName Field
CmsProviderException Class See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
protected const string KeyCmsExceptionMessageResourceName
Visual Basic (Declaration)
Protected Const KeyCmsExceptionMessageResourceName As String
Visual C++
protected:
literal String^ KeyCmsExceptionMessageResourceName

See Also

CmsProviderException Class
Mincom.LinkOne.Adapter Namespace


CmsProviderException Methods

[image] [image]

LinkOne WebView API
CmsProviderException Methods
CmsProviderException Class See Also Send Feedback

The CmsProviderException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

CmsProviderException Class
Mincom.LinkOne.Adapter Namespace


CmsProviderException Properties

[image] [image]

LinkOne WebView API
CmsProviderException Properties
CmsProviderException Class See Also Send Feedback

The CmsProviderException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CmsProviderException Class
Mincom.LinkOne.Adapter Namespace


ContentAdapterBase Class

[image]

LinkOne WebView API
ContentAdapterBase Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
[SerializableAttribute]
public abstract class ContentAdapterBase : IContentAdapter
Visual Basic (Declaration)
<SerializableAttribute> _
Public MustInherit Class ContentAdapterBase _
    Implements IContentAdapter
Visual C++
[SerializableAttribute]
public ref class ContentAdapterBase abstract : IContentAdapter

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Adapter..::.ContentAdapterBase

See Also

ContentAdapterBase Members
Mincom.LinkOne.Adapter Namespace


ContentAdapterBase Members

[image] [image]

LinkOne WebView API
ContentAdapterBase Members
ContentAdapterBase Class Constructors Methods Properties See Also Send Feedback

The ContentAdapterBase type exposes the following members.

Constructors

Name | Description
ContentAdapterBase | Initializes a new instance of the ContentAdapterBase class

Methods

Name | Description
ChangeExtension | Wrapper for ChangeExtension(String, String).
Combine | Combines two path strings.
CopyFile | Overloaded.
Create | Wrapper for Create(String, Int32, FileOptions).
CreateDirectory | Wrapper for CreateDirectory(String).
CreateStreamReader | Overloaded.
CreateStreamWriter | Overloaded.
DeleteDirectory | Overloaded.
DeleteFile | Overloaded.
DirectoryExists | Wrapper for Exists(String).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FileExists | Wrapper for Exists(String).
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetAttributes | Wrapper for GetAttributes(String).
GetDirectories | Wrapper for GetDirectories(String).
GetDirectoryAccessControl | Wrapper for GetAccessControl(String).
GetDirectoryName | Wrapper for GetDirectoryName(String).
GetDocument |
GetDocuments |
GetFileAccessControl | Wrapper for GetAccessControl(String).
GetFileLength | Gets the length of the file.
GetFileName | Wrapper for GetFiles(String, String, SearchOption).
GetFiles | Overloaded.
GetFullPath | Wrapper for GetFullPath(String).
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLastWriteTime | Wrapper for GetLastWriteTime(String).
GetLastWriteTimeUtc | Wrapper for GetLastWriteTimeUtc(String).
GetPathRoot |
GetTempFileName | Creates a uniquely named, zero-byte temporary file on disk and returns the full path of that file.
GetTempPath | Wrapper for GetTempPath()()().
GetType | Gets the type of the current instance. (Inherited from Object.)
LastWriteTime |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveFile | Overloaded.
Open | Overloaded.
OpenRead | Overloaded.
ReadAllBytes | Overloaded.
ReadAllText | Overloaded.
ReadLine | Wrapper for ReadLine()()().
ReadToEnd | Wrapper for ReadToEnd()()().
Seek | Wrapper for Seek(Int64, SeekOrigin).
SetAttributes | Wrapper for SetAttributes(String, FileAttributes).
SetLastWriteTime | Overloaded.
SetLastWriteTimeUtc | Overloaded.
SetLength | Wrapper for SetLength(Int64).
ToString | Returns a string that represents the current object. (Inherited from Object.)
ValidateTimeStamp | Ensures that the timestamp for the given path is valid.
Write | Wrapper for Write(String).
WriteAllBytes | Overloaded.
WriteAllText | Overloaded.
WriteLine | Wrapper for WriteLine(String).

Properties

Name | Description
MinimumFileDateTime |
Provider |

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


ContentAdapterBase Constructor

[image]

LinkOne WebView API
ContentAdapterBase Constructor
ContentAdapterBase Class See Also Send Feedback
Initializes a new instance of the ContentAdapterBase class

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public ContentAdapterBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ContentAdapterBase()

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


ContentAdapterBase Methods

[image] [image]

LinkOne WebView API
ContentAdapterBase Methods
ContentAdapterBase Class See Also Send Feedback

The ContentAdapterBase type exposes the following members.

Methods

Name | Description
ChangeExtension | Wrapper for ChangeExtension(String, String).
Combine | Combines two path strings.
CopyFile | Overloaded.
Create | Wrapper for Create(String, Int32, FileOptions).
CreateDirectory | Wrapper for CreateDirectory(String).
CreateStreamReader | Overloaded.
CreateStreamWriter | Overloaded.
DeleteDirectory | Overloaded.
DeleteFile | Overloaded.
DirectoryExists | Wrapper for Exists(String).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FileExists | Wrapper for Exists(String).
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetAttributes | Wrapper for GetAttributes(String).
GetDirectories | Wrapper for GetDirectories(String).
GetDirectoryAccessControl | Wrapper for GetAccessControl(String).
GetDirectoryName | Wrapper for GetDirectoryName(String).
GetDocument |
GetDocuments |
GetFileAccessControl | Wrapper for GetAccessControl(String).
GetFileLength | Gets the length of the file.
GetFileName | Wrapper for GetFiles(String, String, SearchOption).
GetFiles | Overloaded.
GetFullPath | Wrapper for GetFullPath(String).
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLastWriteTime | Wrapper for GetLastWriteTime(String).
GetLastWriteTimeUtc | Wrapper for GetLastWriteTimeUtc(String).
GetPathRoot |
GetTempFileName | Creates a uniquely named, zero-byte temporary file on disk and returns the full path of that file.
GetTempPath | Wrapper for GetTempPath()()().
GetType | Gets the type of the current instance. (Inherited from Object.)
LastWriteTime |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveFile | Overloaded.
Open | Overloaded.
OpenRead | Overloaded.
ReadAllBytes | Overloaded.
ReadAllText | Overloaded.
ReadLine | Wrapper for ReadLine()()().
ReadToEnd | Wrapper for ReadToEnd()()().
Seek | Wrapper for Seek(Int64, SeekOrigin).
SetAttributes | Wrapper for SetAttributes(String, FileAttributes).
SetLastWriteTime | Overloaded.
SetLastWriteTimeUtc | Overloaded.
SetLength | Wrapper for SetLength(Int64).
ToString | Returns a string that represents the current object. (Inherited from Object.)
ValidateTimeStamp | Ensures that the timestamp for the given path is valid.
Write | Wrapper for Write(String).
WriteAllBytes | Overloaded.
WriteAllText | Overloaded.
WriteLine | Wrapper for WriteLine(String).

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


ChangeExtension Method

[image]

LinkOne WebView API
ContentAdapterBase..::.ChangeExtension Method
ContentAdapterBase Class See Also Send Feedback
Wrapper for ChangeExtension(String, String).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual string ChangeExtension(
    string path,
    string extension
)
Visual Basic (Declaration)
Public Overridable Function ChangeExtension ( _
    path As String, _
    extension As String _
) As String
Visual C++
public:
virtual String^ ChangeExtension(
    String^ path,
    String^ extension
)

Parameters

path
Type: System..::.String
The path to change the extension for.
extension
Type: System..::.String
The extension to change the path to.

Return Value

The path with the changed extension.

Implements

IContentAdapter..::.ChangeExtension(String, String)

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


Combine Method

[image]

LinkOne WebView API
ContentAdapterBase..::.Combine Method
ContentAdapterBase Class See Also Send Feedback
Combines two path strings.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual string Combine(
    string path1,
    string path2
)
Visual Basic (Declaration)
Public Overridable Function Combine ( _
    path1 As String, _
    path2 As String _
) As String
Visual C++
public:
virtual String^ Combine(
    String^ path1,
    String^ path2
)

Parameters

path1
Type: System..::.String
The first path.
path2
Type: System..::.String
The second path.

Return Value

Implements

IContentAdapter..::.Combine(String, String)

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


CopyFile Method

[image] [image]

LinkOne WebView API
ContentAdapterBase..::.CopyFile Method
ContentAdapterBase Class See Also Send Feedback

Overload List

Name | Description
CopyFile(String, String, Boolean) | Wrapper for Copy(String, String, Boolean).
CopyFile(String, String, Boolean, Int32) | Wrapper for Copy(String, String, Boolean).

See Also

ContentAdapterBase Class
ContentAdapterBase Members
Mincom.LinkOne.Adapter Namespace


CopyFile Method (String, String, Boolean)

[image]

LinkOne WebView API
ContentAdapterBase..::.CopyFile Method (String, String, Boolean)
ContentAdapterBase Class See Also Send Feedback
Wrapper for Copy(String, String, Boolean).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual void CopyFile(
    string sourceFileName,
    string destinationFileName,
    bool overwrite
)
Visual Basic (Declaration)
Public Overridable Sub CopyFile ( _
    sourceFileName As String, _
    destinationFileName As String, _
    overwrite As Boolean _
)
Visual C++
public:
virtual void CopyFile(
    String^ sourceFileName,
    String^ destinationFileName,
    bool overwrite
)

Parameters

sourceFileName
Type: System..::.String
destinationFileName
Type: System..::.String
overwrite
Type: System..::.Boolean

Implements

IContentAdapter..::.CopyFile(String, String, Boolean)

Exceptions

Exception | Condition
[!:Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
CopyFile Overload
Mincom.LinkOne.Adapter Namespace


CopyFile Method (String, String, Boolean, Int32)

[image]

LinkOne WebView API
ContentAdapterBase..::.CopyFile Method (String, String, Boolean, Int32)
ContentAdapterBase Class See Also Send Feedback
Wrapper for Copy(String, String, Boolean).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual void CopyFile(
    string sourceFileName,
    string destinationFileName,
    bool overwrite,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Overridable Sub CopyFile ( _
    sourceFileName As String, _
    destinationFileName As String, _
    overwrite As Boolean, _
    retryMilliseconds As Integer _
)
Visual C++
public:
virtual void CopyFile(
    String^ sourceFileName,
    String^ destinationFileName,
    bool overwrite,
    int retryMilliseconds
)

Parameters

sourceFileName
Type: System..::.String
Name of the source file to copy.
destinationFileName
Type: System..::.String
Name of the destination file to copy to.
overwrite
Type: System..::.Boolean
if set to true overwrite the destination file.
retryMilliseconds
Type: System..::.Int32
The number of milliseconds to retry if the desination file is locked.

Implements

IContentAdapter..::.CopyFile(String, String, Boolean, Int32)

Exceptions

Exception | Condition
[!:Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
CopyFile Overload
Mincom.LinkOne.Adapter Namespace


Create Method

[image]

LinkOne WebView API
ContentAdapterBase..::.Create Method
ContentAdapterBase Class See Also Send Feedback
Wrapper for Create(String, Int32, FileOptions).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual Stream Create(
    string path,
    int bufferSize,
    FileOptions fileOptions
)
Visual Basic (Declaration)
Public Overridable Function Create ( _
    path As String, _
    bufferSize As Integer, _
    fileOptions As FileOptions _
) As Stream
Visual C++
public:
virtual Stream^ Create(
    String^ path,
    int bufferSize,
    FileOptions fileOptions
)

Parameters

path
Type: System..::.String
The path.
bufferSize
Type: System..::.Int32
Size of the buffer.
fileOptions
Type: System.IO..::.FileOptions
The file options.

Return Value

The created File Stream

Implements

IContentAdapter..::.Create(String, Int32, FileOptions)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


CreateDirectory Method

[image]

LinkOne WebView API
ContentAdapterBase..::.CreateDirectory Method
ContentAdapterBase Class See Also Send Feedback
Wrapper for CreateDirectory(String).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual DirectoryInfo CreateDirectory(
    string path
)
Visual Basic (Declaration)
Public Overridable Function CreateDirectory ( _
    path As String _
) As DirectoryInfo
Visual C++
public:
virtual DirectoryInfo^ CreateDirectory(
    String^ path
)

Parameters

path
Type: System..::.String

Implements

IContentAdapter..::.CreateDirectory(String)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


CreateStreamReader Method

[image] [image]

LinkOne WebView API
ContentAdapterBase..::.CreateStreamReader Method
ContentAdapterBase Class See Also Send Feedback

Overload List

Name | Description
CreateStreamReader(Stream) | Wrapper for StreamReader(Stream).
CreateStreamReader(Stream, Boolean) | Wrapper for StreamReader(Stream, Boolean).
CreateStreamReader(Stream, Encoding) | Wrapper for StreamReader(Stream, Encoding).

See Also

ContentAdapterBase Class
ContentAdapterBase Members
Mincom.LinkOne.Adapter Namespace


CreateStreamReader Method (Stream)

[image]

LinkOne WebView API
ContentAdapterBase..::.CreateStreamReader Method (Stream)
ContentAdapterBase Class See Also Send Feedback
Wrapper for StreamReader(Stream).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual StreamReader CreateStreamReader(
    Stream stream
)
Visual Basic (Declaration)
Public Overridable Function CreateStreamReader ( _
    stream As Stream _
) As StreamReader
Visual C++
public:
virtual StreamReader^ CreateStreamReader(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream

Implements

IContentAdapter..::.CreateStreamReader(Stream)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
CreateStreamReader Overload
Mincom.LinkOne.Adapter Namespace


CreateStreamReader Method (Stream, Boolean)

[image]

LinkOne WebView API
ContentAdapterBase..::.CreateStreamReader Method (Stream, Boolean)
ContentAdapterBase Class See Also Send Feedback
Wrapper for StreamReader(Stream, Boolean).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual StreamReader CreateStreamReader(
    Stream stream,
    bool detectEncodingFromByteOrderMarks
)
Visual Basic (Declaration)
Public Overridable Function CreateStreamReader ( _
    stream As Stream, _
    detectEncodingFromByteOrderMarks As Boolean _
) As StreamReader
Visual C++
public:
virtual StreamReader^ CreateStreamReader(
    Stream^ stream,
    bool detectEncodingFromByteOrderMarks
)

Parameters

stream
Type: System.IO..::.Stream
detectEncodingFromByteOrderMarks
Type: System..::.Boolean

Implements

IContentAdapter..::.CreateStreamReader(Stream, Boolean)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
CreateStreamReader Overload
Mincom.LinkOne.Adapter Namespace


CreateStreamReader Method (Stream, Encoding)

[image]

LinkOne WebView API
ContentAdapterBase..::.CreateStreamReader Method (Stream, Encoding)
ContentAdapterBase Class See Also Send Feedback
Wrapper for StreamReader(Stream, Encoding).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual StreamReader CreateStreamReader(
    Stream stream,
    Encoding encoding
)
Visual Basic (Declaration)
Public Overridable Function CreateStreamReader ( _
    stream As Stream, _
    encoding As Encoding _
) As StreamReader
Visual C++
public:
virtual StreamReader^ CreateStreamReader(
    Stream^ stream,
    Encoding^ encoding
)

Parameters

stream
Type: System.IO..::.Stream
encoding
Type: System.Text..::.Encoding

Implements

IContentAdapter..::.CreateStreamReader(Stream, Encoding)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
CreateStreamReader Overload
Mincom.LinkOne.Adapter Namespace


CreateStreamWriter Method

[image] [image]

LinkOne WebView API
ContentAdapterBase..::.CreateStreamWriter Method
ContentAdapterBase Class See Also Send Feedback

Overload List

Name | Description
CreateStreamWriter(Stream) | Wrapper for StreamWriter(Stream).
CreateStreamWriter(Stream, Encoding) | Wrapper for StreamWriter(Stream, Encoding).

See Also

ContentAdapterBase Class
ContentAdapterBase Members
Mincom.LinkOne.Adapter Namespace


CreateStreamWriter Method (Stream)

[image]

LinkOne WebView API
ContentAdapterBase..::.CreateStreamWriter Method (Stream)
ContentAdapterBase Class See Also Send Feedback
Wrapper for StreamWriter(Stream).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual StreamWriter CreateStreamWriter(
    Stream stream
)
Visual Basic (Declaration)
Public Overridable Function CreateStreamWriter ( _
    stream As Stream _
) As StreamWriter
Visual C++
public:
virtual StreamWriter^ CreateStreamWriter(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream

Implements

IContentAdapter..::.CreateStreamWriter(Stream)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
CreateStreamWriter Overload
Mincom.LinkOne.Adapter Namespace


CreateStreamWriter Method (Stream, Encoding)

[image]

LinkOne WebView API
ContentAdapterBase..::.CreateStreamWriter Method (Stream, Encoding)
ContentAdapterBase Class See Also Send Feedback
Wrapper for StreamWriter(Stream, Encoding).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual StreamWriter CreateStreamWriter(
    Stream stream,
    Encoding encoding
)
Visual Basic (Declaration)
Public Overridable Function CreateStreamWriter ( _
    stream As Stream, _
    encoding As Encoding _
) As StreamWriter
Visual C++
public:
virtual StreamWriter^ CreateStreamWriter(
    Stream^ stream,
    Encoding^ encoding
)

Parameters

stream
Type: System.IO..::.Stream
encoding
Type: System.Text..::.Encoding

Implements

IContentAdapter..::.CreateStreamWriter(Stream, Encoding)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
CreateStreamWriter Overload
Mincom.LinkOne.Adapter Namespace


DeleteDirectory Method

[image] [image]

LinkOne WebView API
ContentAdapterBase..::.DeleteDirectory Method
ContentAdapterBase Class See Also Send Feedback

Overload List

Name | Description
DeleteDirectory(String, Boolean) | Wrapper for Delete(String, Boolean).
DeleteDirectory(String, Boolean, Int32) | Wrapper for Delete(String, Boolean).

See Also

ContentAdapterBase Class
ContentAdapterBase Members
Mincom.LinkOne.Adapter Namespace


DeleteDirectory Method (String, Boolean)

[image]

LinkOne WebView API
ContentAdapterBase..::.DeleteDirectory Method (String, Boolean)
ContentAdapterBase Class See Also Send Feedback
Wrapper for Delete(String, Boolean).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual void DeleteDirectory(
    string path,
    bool recursive
)
Visual Basic (Declaration)
Public Overridable Sub DeleteDirectory ( _
    path As String, _
    recursive As Boolean _
)
Visual C++
public:
virtual void DeleteDirectory(
    String^ path,
    bool recursive
)

Parameters

path
Type: System..::.String
recursive
Type: System..::.Boolean

Implements

IContentAdapter..::.DeleteDirectory(String, Boolean)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
DeleteDirectory Overload
Mincom.LinkOne.Adapter Namespace


DeleteDirectory Method (String, Boolean, Int32)

[image]

LinkOne WebView API
ContentAdapterBase..::.DeleteDirectory Method (String, Boolean, Int32)
ContentAdapterBase Class See Also Send Feedback
Wrapper for Delete(String, Boolean).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual void DeleteDirectory(
    string path,
    bool recursive,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Overridable Sub DeleteDirectory ( _
    path As String, _
    recursive As Boolean, _
    retryMilliseconds As Integer _
)
Visual C++
public:
virtual void DeleteDirectory(
    String^ path,
    bool recursive,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
The path to delete.
recursive
Type: System..::.Boolean
if set to true remove all subfolders.
retryMilliseconds
Type: System..::.Int32
The number of milliseconds to retry for if the directory is locked.

Implements

IContentAdapter..::.DeleteDirectory(String, Boolean, Int32)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
DeleteDirectory Overload
Mincom.LinkOne.Adapter Namespace


DeleteFile Method

[image] [image]

LinkOne WebView API
ContentAdapterBase..::.DeleteFile Method
ContentAdapterBase Class See Also Send Feedback

Overload List

Name | Description
DeleteFile(String) | Wrapper for Delete(String).
DeleteFile(String, Int32) | Wrapper for Delete(String).

See Also

ContentAdapterBase Class
ContentAdapterBase Members
Mincom.LinkOne.Adapter Namespace


DeleteFile Method (String)

[image]

LinkOne WebView API
ContentAdapterBase..::.DeleteFile Method (String)
ContentAdapterBase Class See Also Send Feedback
Wrapper for Delete(String).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual void DeleteFile(
    string path
)
Visual Basic (Declaration)
Public Overridable Sub DeleteFile ( _
    path As String _
)
Visual C++
public:
virtual void DeleteFile(
    String^ path
)

Parameters

path
Type: System..::.String
The name of the file to be deleted.

Implements

IContentAdapter..::.DeleteFile(String)

See Also

ContentAdapterBase Class
DeleteFile Overload
Mincom.LinkOne.Adapter Namespace


DeleteFile Method (String, Int32)

[image]

LinkOne WebView API
ContentAdapterBase..::.DeleteFile Method (String, Int32)
ContentAdapterBase Class See Also Send Feedback
Wrapper for Delete(String).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual void DeleteFile(
    string path,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Overridable Sub DeleteFile ( _
    path As String, _
    retryMilliseconds As Integer _
)
Visual C++
public:
virtual void DeleteFile(
    String^ path,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
The name of the file to be deleted.
retryMilliseconds
Type: System..::.Int32
The milliseconds to retry for to delete the file, if it is locked.

Implements

IContentAdapter..::.DeleteFile(String, Int32)

See Also

ContentAdapterBase Class
DeleteFile Overload
Mincom.LinkOne.Adapter Namespace


DirectoryExists Method

[image]

LinkOne WebView API
ContentAdapterBase..::.DirectoryExists Method
ContentAdapterBase Class See Also Send Feedback
Wrapper for Exists(String).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual bool DirectoryExists(
    string path
)
Visual Basic (Declaration)
Public Overridable Function DirectoryExists ( _
    path As String _
) As Boolean
Visual C++
public:
virtual bool DirectoryExists(
    String^ path
)

Parameters

path
Type: System..::.String
The directory to check.

Return Value

True if the directory exists, false otherwise.

Implements

IContentAdapter..::.DirectoryExists(String)

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


FileExists Method

[image]

LinkOne WebView API
ContentAdapterBase..::.FileExists Method
ContentAdapterBase Class See Also Send Feedback
Wrapper for Exists(String).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual bool FileExists(
    string path
)
Visual Basic (Declaration)
Public Overridable Function FileExists ( _
    path As String _
) As Boolean
Visual C++
public:
virtual bool FileExists(
    String^ path
)

Parameters

path
Type: System..::.String
The file to check.

Return Value

True if the file exists, false otherwise.

Implements

IContentAdapter..::.FileExists(String)

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


GetAttributes Method

[image]

LinkOne WebView API
ContentAdapterBase..::.GetAttributes Method
ContentAdapterBase Class See Also Send Feedback
Wrapper for GetAttributes(String).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual FileAttributes GetAttributes(
    string path
)
Visual Basic (Declaration)
Public Overridable Function GetAttributes ( _
    path As String _
) As FileAttributes
Visual C++
public:
virtual FileAttributes GetAttributes(
    String^ path
)

Parameters

path
Type: System..::.String

Implements

IContentAdapter..::.GetAttributes(String)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


GetDirectories Method

[image]

LinkOne WebView API
ContentAdapterBase..::.GetDirectories Method
ContentAdapterBase Class See Also Send Feedback
Wrapper for GetDirectories(String).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual string[] GetDirectories(
    string directory
)
Visual Basic (Declaration)
Public Overridable Function GetDirectories ( _
    directory As String _
) As String()
Visual C++
public:
virtual array<String^>^ GetDirectories(
    String^ directory
)

Parameters

directory
Type: System..::.String

Implements

IContentAdapter..::.GetDirectories(String)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


GetDirectoryAccessControl Method

[image]

LinkOne WebView API
ContentAdapterBase..::.GetDirectoryAccessControl Method
ContentAdapterBase Class See Also Send Feedback
Wrapper for GetAccessControl(String).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual DirectorySecurity GetDirectoryAccessControl(
    string path
)
Visual Basic (Declaration)
Public Overridable Function GetDirectoryAccessControl ( _
    path As String _
) As DirectorySecurity
Visual C++
public:
virtual DirectorySecurity^ GetDirectoryAccessControl(
    String^ path
)

Parameters

path
Type: System..::.String

Implements

IContentAdapter..::.GetDirectoryAccessControl(String)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


GetDirectoryName Method

[image]

LinkOne WebView API
ContentAdapterBase..::.GetDirectoryName Method
ContentAdapterBase Class See Also Send Feedback
Wrapper for GetDirectoryName(String).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual string GetDirectoryName(
    string path
)
Visual Basic (Declaration)
Public Overridable Function GetDirectoryName ( _
    path As String _
) As String
Visual C++
public:
virtual String^ GetDirectoryName(
    String^ path
)

Parameters

path
Type: System..::.String

Implements

IContentAdapter..::.GetDirectoryName(String)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


GetDocument Method

[image]

LinkOne WebView API
ContentAdapterBase..::.GetDocument Method
ContentAdapterBase Class See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual byte[] GetDocument(
    string referencePath,
    out DocumentReference documentRef
)
Visual Basic (Declaration)
Public Overridable Function GetDocument ( _
    referencePath As String, _
    <OutAttribute> ByRef documentRef As DocumentReference _
) As Byte()
Visual C++
public:
virtual array<unsigned char>^ GetDocument(
    String^ referencePath,
    [OutAttribute] DocumentReference^% documentRef
)

Parameters

referencePath
Type: System..::.String
documentRef
Type: Mincom.LinkOne.Adapter..::.DocumentReference %

Implements

IContentAdapter..::.GetDocument(String, DocumentReference%)

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


GetDocuments Method

[image]

LinkOne WebView API
ContentAdapterBase..::.GetDocuments Method
ContentAdapterBase Class See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual DocumentList GetDocuments(
    string referencePath,
    string paginationMarker,
    int count,
    string languageCode
)
Visual Basic (Declaration)
Public Overridable Function GetDocuments ( _
    referencePath As String, _
    paginationMarker As String, _
    count As Integer, _
    languageCode As String _
) As DocumentList
Visual C++
public:
virtual DocumentList^ GetDocuments(
    String^ referencePath,
    String^ paginationMarker,
    int count,
    String^ languageCode
)

Parameters

referencePath
Type: System..::.String
paginationMarker
Type: System..::.String
count
Type: System..::.Int32
languageCode
Type: System..::.String

Implements

IContentAdapter..::.GetDocuments(String, String, Int32, String)

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


GetFileAccessControl Method

[image]

LinkOne WebView API
ContentAdapterBase..::.GetFileAccessControl Method
ContentAdapterBase Class See Also Send Feedback
Wrapper for GetAccessControl(String).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual FileSecurity GetFileAccessControl(
    string path
)
Visual Basic (Declaration)
Public Overridable Function GetFileAccessControl ( _
    path As String _
) As FileSecurity
Visual C++
public:
virtual FileSecurity^ GetFileAccessControl(
    String^ path
)

Parameters

path
Type: System..::.String

Implements

IContentAdapter..::.GetFileAccessControl(String)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


GetFileLength Method

[image]

LinkOne WebView API
ContentAdapterBase..::.GetFileLength Method
ContentAdapterBase Class See Also Send Feedback
Gets the length of the file.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual long GetFileLength(
    string path
)
Visual Basic (Declaration)
Public Overridable Function GetFileLength ( _
    path As String _
) As Long
Visual C++
public:
virtual long long GetFileLength(
    String^ path
)

Parameters

path
Type: System..::.String
The path.

Return Value

The length of the file

Implements

IContentAdapter..::.GetFileLength(String)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


GetFileName Method

[image]

LinkOne WebView API
ContentAdapterBase..::.GetFileName Method
ContentAdapterBase Class See Also Send Feedback
Wrapper for GetFiles(String, String, SearchOption).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual string GetFileName(
    string path
)
Visual Basic (Declaration)
Public Overridable Function GetFileName ( _
    path As String _
) As String
Visual C++
public:
virtual String^ GetFileName(
    String^ path
)

Parameters

path
Type: System..::.String

Implements

IContentAdapter..::.GetFileName(String)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


GetFiles Method

[image] [image]

LinkOne WebView API
ContentAdapterBase..::.GetFiles Method
ContentAdapterBase Class See Also Send Feedback

Overload List

Name | Description
GetFiles(String) | Wrapper for GetFiles(String).
GetFiles(String, String) | Wrapper for GetFiles(String, String).
GetFiles(String, String, SearchOption) | Wrapper for GetFiles(String, String, SearchOption).

See Also

ContentAdapterBase Class
ContentAdapterBase Members
Mincom.LinkOne.Adapter Namespace


GetFiles Method (String)

[image]

LinkOne WebView API
ContentAdapterBase..::.GetFiles Method (String)
ContentAdapterBase Class See Also Send Feedback
Wrapper for GetFiles(String).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual string[] GetFiles(
    string path
)
Visual Basic (Declaration)
Public Overridable Function GetFiles ( _
    path As String _
) As String()
Visual C++
public:
virtual array<String^>^ GetFiles(
    String^ path
)

Parameters

path
Type: System..::.String

Implements

IContentAdapter..::.GetFiles(String)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
GetFiles Overload
Mincom.LinkOne.Adapter Namespace


GetFiles Method (String, String)

[image]

LinkOne WebView API
ContentAdapterBase..::.GetFiles Method (String, String)
ContentAdapterBase Class See Also Send Feedback
Wrapper for GetFiles(String, String).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual string[] GetFiles(
    string path,
    string searchPattern
)
Visual Basic (Declaration)
Public Overridable Function GetFiles ( _
    path As String, _
    searchPattern As String _
) As String()
Visual C++
public:
virtual array<String^>^ GetFiles(
    String^ path,
    String^ searchPattern
)

Parameters

path
Type: System..::.String
searchPattern
Type: System..::.String

Implements

IContentAdapter..::.GetFiles(String, String)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
GetFiles Overload
Mincom.LinkOne.Adapter Namespace


GetFiles Method (String, String, SearchOption)

[image]

LinkOne WebView API
ContentAdapterBase..::.GetFiles Method (String, String, SearchOption)
ContentAdapterBase Class See Also Send Feedback
Wrapper for GetFiles(String, String, SearchOption).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual string[] GetFiles(
    string path,
    string searchPattern,
    SearchOption searchOption
)
Visual Basic (Declaration)
Public Overridable Function GetFiles ( _
    path As String, _
    searchPattern As String, _
    searchOption As SearchOption _
) As String()
Visual C++
public:
virtual array<String^>^ GetFiles(
    String^ path,
    String^ searchPattern,
    SearchOption searchOption
)

Parameters

path
Type: System..::.String
searchPattern
Type: System..::.String
searchOption
Type: System.IO..::.SearchOption

Implements

IContentAdapter..::.GetFiles(String, String, SearchOption)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
GetFiles Overload
Mincom.LinkOne.Adapter Namespace


GetFullPath Method

[image]

LinkOne WebView API
ContentAdapterBase..::.GetFullPath Method
ContentAdapterBase Class See Also Send Feedback
Wrapper for GetFullPath(String).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual string GetFullPath(
    string path
)
Visual Basic (Declaration)
Public Overridable Function GetFullPath ( _
    path As String _
) As String
Visual C++
public:
virtual String^ GetFullPath(
    String^ path
)

Parameters

path
Type: System..::.String

Implements

IContentAdapter..::.GetFullPath(String)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


GetLastWriteTime Method

[image]

LinkOne WebView API
ContentAdapterBase..::.GetLastWriteTime Method
ContentAdapterBase Class See Also Send Feedback
Wrapper for GetLastWriteTime(String).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual DateTime GetLastWriteTime(
    string path
)
Visual Basic (Declaration)
Public Overridable Function GetLastWriteTime ( _
    path As String _
) As DateTime
Visual C++
public:
virtual DateTime GetLastWriteTime(
    String^ path
)

Parameters

path
Type: System..::.String

Implements

IContentAdapter..::.GetLastWriteTime(String)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


GetLastWriteTimeUtc Method

[image]

LinkOne WebView API
ContentAdapterBase..::.GetLastWriteTimeUtc Method
ContentAdapterBase Class See Also Send Feedback
Wrapper for GetLastWriteTimeUtc(String).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual DateTime GetLastWriteTimeUtc(
    string path
)
Visual Basic (Declaration)
Public Overridable Function GetLastWriteTimeUtc ( _
    path As String _
) As DateTime
Visual C++
public:
virtual DateTime GetLastWriteTimeUtc(
    String^ path
)

Parameters

path
Type: System..::.String

Implements

IContentAdapter..::.GetLastWriteTimeUtc(String)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


GetPathRoot Method

[image]

LinkOne WebView API
ContentAdapterBase..::.GetPathRoot Method
ContentAdapterBase Class See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual string GetPathRoot(
    string path
)
Visual Basic (Declaration)
Public Overridable Function GetPathRoot ( _
    path As String _
) As String
Visual C++
public:
virtual String^ GetPathRoot(
    String^ path
)

Parameters

path
Type: System..::.String

Implements

IContentAdapter..::.GetPathRoot(String)

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


GetTempFileName Method

[image]

LinkOne WebView API
ContentAdapterBase..::.GetTempFileName Method
ContentAdapterBase Class See Also Send Feedback
Creates a uniquely named, zero-byte temporary file on disk and returns the full path of that file.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual string GetTempFileName()
Visual Basic (Declaration)
Public Overridable Function GetTempFileName As String
Visual C++
public:
virtual String^ GetTempFileName()

Return Value

A uniquely named, zero-byte temporary file on disk.

Implements

IContentAdapter..::.GetTempFileName()()()

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


GetTempPath Method

[image]

LinkOne WebView API
ContentAdapterBase..::.GetTempPath Method
ContentAdapterBase Class See Also Send Feedback
Wrapper for GetTempPath()()().

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual string GetTempPath()
Visual Basic (Declaration)
Public Overridable Function GetTempPath As String
Visual C++
public:
virtual String^ GetTempPath()

Return Value

The path to the current system's temporary folder.

Implements

IContentAdapter..::.GetTempPath()()()

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


LastWriteTime Method

[image]

LinkOne WebView API
ContentAdapterBase..::.LastWriteTime Method
ContentAdapterBase Class See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual DateTime LastWriteTime(
    string referencePath
)
Visual Basic (Declaration)
Public Overridable Function LastWriteTime ( _
    referencePath As String _
) As DateTime
Visual C++
public:
virtual DateTime LastWriteTime(
    String^ referencePath
)

Parameters

referencePath
Type: System..::.String

Implements

IContentAdapter..::.LastWriteTime(String)

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


MoveFile Method

[image] [image]

LinkOne WebView API
ContentAdapterBase..::.MoveFile Method
ContentAdapterBase Class See Also Send Feedback

Overload List

Name | Description
MoveFile(String, String) | Wrapper for Move(String, String).
MoveFile(String, String, Int32) | Wrapper for Move(String, String).

See Also

ContentAdapterBase Class
ContentAdapterBase Members
Mincom.LinkOne.Adapter Namespace


MoveFile Method (String, String)

[image]

LinkOne WebView API
ContentAdapterBase..::.MoveFile Method (String, String)
ContentAdapterBase Class See Also Send Feedback
Wrapper for Move(String, String).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual void MoveFile(
    string source,
    string target
)
Visual Basic (Declaration)
Public Overridable Sub MoveFile ( _
    source As String, _
    target As String _
)
Visual C++
public:
virtual void MoveFile(
    String^ source,
    String^ target
)

Parameters

source
Type: System..::.String
The name of the file to be moved.
target
Type: System..::.String
The target file name.

Implements

IContentAdapter..::.MoveFile(String, String)

See Also

ContentAdapterBase Class
MoveFile Overload
Mincom.LinkOne.Adapter Namespace


MoveFile Method (String, String, Int32)

[image]

LinkOne WebView API
ContentAdapterBase..::.MoveFile Method (String, String, Int32)
ContentAdapterBase Class See Also Send Feedback
Wrapper for Move(String, String).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual void MoveFile(
    string source,
    string target,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Overridable Sub MoveFile ( _
    source As String, _
    target As String, _
    retryMilliseconds As Integer _
)
Visual C++
public:
virtual void MoveFile(
    String^ source,
    String^ target,
    int retryMilliseconds
)

Parameters

source
Type: System..::.String
The name of the file to be moved.
target
Type: System..::.String
The target file name.
retryMilliseconds
Type: System..::.Int32
The number of milliseconds to retry moving the file, if the source or target is locked.

Implements

IContentAdapter..::.MoveFile(String, String, Int32)

See Also

ContentAdapterBase Class
MoveFile Overload
Mincom.LinkOne.Adapter Namespace


Open Method

[image] [image]

LinkOne WebView API
ContentAdapterBase..::.Open Method
ContentAdapterBase Class See Also Send Feedback

Overload List

Name | Description
Open(String, FileMode) | Wrapper for Open(String, FileMode).
Open(String, FileMode, Int32) | Wrapper for Open(String, FileMode, FileAccess, FileShare).
Open(String, FileMode, FileAccess, FileShare) | Wrapper for Open(String, FileMode, FileAccess, FileShare).
Open(String, FileMode, FileAccess, FileShare, Int32) | Wrapper for Open(String, FileMode, FileAccess, FileShare).
Open(String, FileMode, FileAccess, FileShare, Int32, FileOptions, Int32) | Wrapper for FileStream(String, FileMode, FileAccess, FileShare, Int32, FileOptions) constructor.

See Also

ContentAdapterBase Class
ContentAdapterBase Members
Mincom.LinkOne.Adapter Namespace


Open Method (String, FileMode)

[image]

LinkOne WebView API
ContentAdapterBase..::.Open Method (String, FileMode)
ContentAdapterBase Class See Also Send Feedback
Wrapper for Open(String, FileMode).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual FileStream Open(
    string path,
    FileMode mode
)
Visual Basic (Declaration)
Public Overridable Function Open ( _
    path As String, _
    mode As FileMode _
) As FileStream
Visual C++
public:
virtual FileStream^ Open(
    String^ path,
    FileMode mode
)

Parameters

path
Type: System..::.String
mode
Type: System.IO..::.FileMode

Implements

IContentAdapter..::.Open(String, FileMode)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
Open Overload
Mincom.LinkOne.Adapter Namespace


Open Method (String, FileMode, Int32)

[image]

LinkOne WebView API
ContentAdapterBase..::.Open Method (String, FileMode, Int32)
ContentAdapterBase Class See Also Send Feedback
Wrapper for Open(String, FileMode, FileAccess, FileShare).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual FileStream Open(
    string path,
    FileMode mode,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Overridable Function Open ( _
    path As String, _
    mode As FileMode, _
    retryMilliseconds As Integer _
) As FileStream
Visual C++
public:
virtual FileStream^ Open(
    String^ path,
    FileMode mode,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
The path.
mode
Type: System.IO..::.FileMode
The mode.
retryMilliseconds
Type: System..::.Int32
The number of milliseconds to retry for to open the file if it is locked by another process.

Return Value

The File Stream, or null if none could be opened

Implements

IContentAdapter..::.Open(String, FileMode, Int32)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
Open Overload
Mincom.LinkOne.Adapter Namespace


Open Method (String, FileMode, FileAccess, FileShare)

[image]

LinkOne WebView API
ContentAdapterBase..::.Open Method (String, FileMode, FileAccess, FileShare)
ContentAdapterBase Class See Also Send Feedback
Wrapper for Open(String, FileMode, FileAccess, FileShare).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual FileStream Open(
    string path,
    FileMode mode,
    FileAccess access,
    FileShare share
)
Visual Basic (Declaration)
Public Overridable Function Open ( _
    path As String, _
    mode As FileMode, _
    access As FileAccess, _
    share As FileShare _
) As FileStream
Visual C++
public:
virtual FileStream^ Open(
    String^ path,
    FileMode mode,
    FileAccess access,
    FileShare share
)

Parameters

path
Type: System..::.String
mode
Type: System.IO..::.FileMode
access
Type: System.IO..::.FileAccess
share
Type: System.IO..::.FileShare

Implements

IContentAdapter..::.Open(String, FileMode, FileAccess, FileShare)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
Open Overload
Mincom.LinkOne.Adapter Namespace


Open Method (String, FileMode, FileAccess, FileShare, Int32)

[image]

LinkOne WebView API
ContentAdapterBase..::.Open Method (String, FileMode, FileAccess, FileShare, Int32)
ContentAdapterBase Class See Also Send Feedback
Wrapper for Open(String, FileMode, FileAccess, FileShare).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual FileStream Open(
    string path,
    FileMode mode,
    FileAccess access,
    FileShare share,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Overridable Function Open ( _
    path As String, _
    mode As FileMode, _
    access As FileAccess, _
    share As FileShare, _
    retryMilliseconds As Integer _
) As FileStream
Visual C++
public:
virtual FileStream^ Open(
    String^ path,
    FileMode mode,
    FileAccess access,
    FileShare share,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
The path to open.
mode
Type: System.IO..::.FileMode
The mode to open with.
access
Type: System.IO..::.FileAccess
The access to be granted.
share
Type: System.IO..::.FileShare
The share.
retryMilliseconds
Type: System..::.Int32
The number of milliseconds to retry for to open the file if it is locked by another process.

Return Value

The File Stream, or null if none could be opened

Implements

IContentAdapter..::.Open(String, FileMode, FileAccess, FileShare, Int32)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
Open Overload
Mincom.LinkOne.Adapter Namespace


Open Method (String, FileMode, FileAccess, FileShare, Int32, FileOptions, Int32)

[image]

LinkOne WebView API
ContentAdapterBase..::.Open Method (String, FileMode, FileAccess, FileShare, Int32, FileOptions, Int32)
ContentAdapterBase Class See Also Send Feedback
Wrapper for FileStream(String, FileMode, FileAccess, FileShare, Int32, FileOptions) constructor.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual FileStream Open(
    string path,
    FileMode mode,
    FileAccess access,
    FileShare share,
    int bufferSize,
    FileOptions options,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Overridable Function Open ( _
    path As String, _
    mode As FileMode, _
    access As FileAccess, _
    share As FileShare, _
    bufferSize As Integer, _
    options As FileOptions, _
    retryMilliseconds As Integer _
) As FileStream
Visual C++
public:
virtual FileStream^ Open(
    String^ path,
    FileMode mode,
    FileAccess access,
    FileShare share,
    int bufferSize,
    FileOptions options,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
The path to open.
mode
Type: System.IO..::.FileMode
The mode to open with.
access
Type: System.IO..::.FileAccess
The access to be granted.
share
Type: System.IO..::.FileShare
The share.
bufferSize
Type: System..::.Int32
A positive Int32 value greater than 0 indicating the buffer size. For bufferSize values between one and eight, the actual buffer size is set to eight bytes.
options
Type: System.IO..::.FileOptions
A FileOptions value that specifies additional file options.
retryMilliseconds
Type: System..::.Int32
The number of milliseconds to retry for to open the file if it is locked by another process.

Return Value

The File Stream, or null if none could be opened

Implements

IContentAdapter..::.Open(String, FileMode, FileAccess, FileShare, Int32, FileOptions, Int32)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
Open Overload
Mincom.LinkOne.Adapter Namespace


OpenRead Method

[image] [image]

LinkOne WebView API
ContentAdapterBase..::.OpenRead Method
ContentAdapterBase Class See Also Send Feedback

Overload List

Name | Description
OpenRead(String) | Wrapper for Open(String, FileMode, FileAccess, FileShare).
OpenRead(String, Int32) | Wrapper for Open(String, FileMode, FileAccess, FileShare).

See Also

ContentAdapterBase Class
ContentAdapterBase Members
Mincom.LinkOne.Adapter Namespace


OpenRead Method (String)

[image]

LinkOne WebView API
ContentAdapterBase..::.OpenRead Method (String)
ContentAdapterBase Class See Also Send Feedback
Wrapper for Open(String, FileMode, FileAccess, FileShare).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual FileStream OpenRead(
    string path
)
Visual Basic (Declaration)
Public Overridable Function OpenRead ( _
    path As String _
) As FileStream
Visual C++
public:
virtual FileStream^ OpenRead(
    String^ path
)

Parameters

path
Type: System..::.String

Implements

IContentAdapter..::.OpenRead(String)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
OpenRead Overload
Mincom.LinkOne.Adapter Namespace


OpenRead Method (String, Int32)

[image]

LinkOne WebView API
ContentAdapterBase..::.OpenRead Method (String, Int32)
ContentAdapterBase Class See Also Send Feedback
Wrapper for Open(String, FileMode, FileAccess, FileShare).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual FileStream OpenRead(
    string path,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Overridable Function OpenRead ( _
    path As String, _
    retryMilliseconds As Integer _
) As FileStream
Visual C++
public:
virtual FileStream^ OpenRead(
    String^ path,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
The path.
retryMilliseconds
Type: System..::.Int32
The number of milliseconds to retry for to open the file if it is locked by another process.

Return Value

The File Stream, or null if none could be opened

Implements

IContentAdapter..::.OpenRead(String, Int32)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
OpenRead Overload
Mincom.LinkOne.Adapter Namespace


ReadAllBytes Method

[image] [image]

LinkOne WebView API
ContentAdapterBase..::.ReadAllBytes Method
ContentAdapterBase Class See Also Send Feedback

Overload List

Name | Description
ReadAllBytes(String) | Wrapper for ReadAllBytes(String).
ReadAllBytes(String, Int32) | Wrapper for ReadAllBytes(String).

See Also

ContentAdapterBase Class
ContentAdapterBase Members
Mincom.LinkOne.Adapter Namespace


ReadAllBytes Method (String)

[image]

LinkOne WebView API
ContentAdapterBase..::.ReadAllBytes Method (String)
ContentAdapterBase Class See Also Send Feedback
Wrapper for ReadAllBytes(String).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual byte[] ReadAllBytes(
    string path
)
Visual Basic (Declaration)
Public Overridable Function ReadAllBytes ( _
    path As String _
) As Byte()
Visual C++
public:
virtual array<unsigned char>^ ReadAllBytes(
    String^ path
)

Parameters

path
Type: System..::.String

Implements

IContentAdapter..::.ReadAllBytes(String)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
ReadAllBytes Overload
Mincom.LinkOne.Adapter Namespace


ReadAllBytes Method (String, Int32)

[image]

LinkOne WebView API
ContentAdapterBase..::.ReadAllBytes Method (String, Int32)
ContentAdapterBase Class See Also Send Feedback
Wrapper for ReadAllBytes(String).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual byte[] ReadAllBytes(
    string path,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Overridable Function ReadAllBytes ( _
    path As String, _
    retryMilliseconds As Integer _
) As Byte()
Visual C++
public:
virtual array<unsigned char>^ ReadAllBytes(
    String^ path,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
The path to read from.
retryMilliseconds
Type: System..::.Int32
The number of milliseconds to retry for, if the file is locked.

Return Value

The read bytes, or null if none read.

Implements

IContentAdapter..::.ReadAllBytes(String, Int32)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
ReadAllBytes Overload
Mincom.LinkOne.Adapter Namespace


ReadAllText Method

[image] [image]

LinkOne WebView API
ContentAdapterBase..::.ReadAllText Method
ContentAdapterBase Class See Also Send Feedback

Overload List

Name | Description
ReadAllText(String) | Wrapper for ReadAllText(String).
ReadAllText(String, Int32) | Wrapper for ReadAllText(String).
ReadAllText(String, Encoding) | Wrapper for ReadAllText(String, Encoding).
ReadAllText(String, Encoding, Int32) | Wrapper for ReadAllText(String, Encoding).

See Also

ContentAdapterBase Class
ContentAdapterBase Members
Mincom.LinkOne.Adapter Namespace


ReadAllText Method (String)

[image]

LinkOne WebView API
ContentAdapterBase..::.ReadAllText Method (String)
ContentAdapterBase Class See Also Send Feedback
Wrapper for ReadAllText(String).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual string ReadAllText(
    string path
)
Visual Basic (Declaration)
Public Overridable Function ReadAllText ( _
    path As String _
) As String
Visual C++
public:
virtual String^ ReadAllText(
    String^ path
)

Parameters

path
Type: System..::.String
The path to read.

Return Value

The read text, or null if no text

Implements

IContentAdapter..::.ReadAllText(String)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurs.

See Also

ContentAdapterBase Class
ReadAllText Overload
Mincom.LinkOne.Adapter Namespace


ReadAllText Method (String, Int32)

[image]

LinkOne WebView API
ContentAdapterBase..::.ReadAllText Method (String, Int32)
ContentAdapterBase Class See Also Send Feedback
Wrapper for ReadAllText(String).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual string ReadAllText(
    string path,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Overridable Function ReadAllText ( _
    path As String, _
    retryMilliseconds As Integer _
) As String
Visual C++
public:
virtual String^ ReadAllText(
    String^ path,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
The path to read.
retryMilliseconds
Type: System..::.Int32
The number milliseconds to retry reading for, if the file is locked.

Return Value

The read text, or null if no text

Implements

IContentAdapter..::.ReadAllText(String, Int32)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurs.

See Also

ContentAdapterBase Class
ReadAllText Overload
Mincom.LinkOne.Adapter Namespace


ReadAllText Method (String, Encoding)

[image]

LinkOne WebView API
ContentAdapterBase..::.ReadAllText Method (String, Encoding)
ContentAdapterBase Class See Also Send Feedback
Wrapper for ReadAllText(String, Encoding).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual string ReadAllText(
    string path,
    Encoding encoding
)
Visual Basic (Declaration)
Public Overridable Function ReadAllText ( _
    path As String, _
    encoding As Encoding _
) As String
Visual C++
public:
virtual String^ ReadAllText(
    String^ path,
    Encoding^ encoding
)

Parameters

path
Type: System..::.String
encoding
Type: System.Text..::.Encoding

Implements

IContentAdapter..::.ReadAllText(String, Encoding)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurs.

See Also

ContentAdapterBase Class
ReadAllText Overload
Mincom.LinkOne.Adapter Namespace


ReadAllText Method (String, Encoding, Int32)

[image]

LinkOne WebView API
ContentAdapterBase..::.ReadAllText Method (String, Encoding, Int32)
ContentAdapterBase Class See Also Send Feedback
Wrapper for ReadAllText(String, Encoding).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual string ReadAllText(
    string path,
    Encoding encoding,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Overridable Function ReadAllText ( _
    path As String, _
    encoding As Encoding, _
    retryMilliseconds As Integer _
) As String
Visual C++
public:
virtual String^ ReadAllText(
    String^ path,
    Encoding^ encoding,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
The path to read.
encoding
Type: System.Text..::.Encoding
The encoding to read with.
retryMilliseconds
Type: System..::.Int32
The number milliseconds to retry reading for, if the file is locked.

Return Value

The read text, or null if no text

Implements

IContentAdapter..::.ReadAllText(String, Encoding, Int32)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurs.

See Also

ContentAdapterBase Class
ReadAllText Overload
Mincom.LinkOne.Adapter Namespace


ReadLine Method

[image]

LinkOne WebView API
ContentAdapterBase..::.ReadLine Method
ContentAdapterBase Class See Also Send Feedback
Wrapper for ReadLine()()().

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual string ReadLine(
    TextReader reader
)
Visual Basic (Declaration)
Public Overridable Function ReadLine ( _
    reader As TextReader _
) As String
Visual C++
public:
virtual String^ ReadLine(
    TextReader^ reader
)

Parameters

reader
Type: System.IO..::.TextReader

Implements

IContentAdapter..::.ReadLine(TextReader)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


ReadToEnd Method

[image]

LinkOne WebView API
ContentAdapterBase..::.ReadToEnd Method
ContentAdapterBase Class See Also Send Feedback
Wrapper for ReadToEnd()()().

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual string ReadToEnd(
    TextReader reader
)
Visual Basic (Declaration)
Public Overridable Function ReadToEnd ( _
    reader As TextReader _
) As String
Visual C++
public:
virtual String^ ReadToEnd(
    TextReader^ reader
)

Parameters

reader
Type: System.IO..::.TextReader

Implements

IContentAdapter..::.ReadToEnd(TextReader)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


Seek Method

[image]

LinkOne WebView API
ContentAdapterBase..::.Seek Method
ContentAdapterBase Class See Also Send Feedback
Wrapper for Seek(Int64, SeekOrigin).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual long Seek(
    Stream stream,
    long offset,
    SeekOrigin origin
)
Visual Basic (Declaration)
Public Overridable Function Seek ( _
    stream As Stream, _
    offset As Long, _
    origin As SeekOrigin _
) As Long
Visual C++
public:
virtual long long Seek(
    Stream^ stream,
    long long offset,
    SeekOrigin origin
)

Parameters

stream
Type: System.IO..::.Stream
offset
Type: System..::.Int64
origin
Type: System.IO..::.SeekOrigin

Implements

IContentAdapter..::.Seek(Stream, Int64, SeekOrigin)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


SetAttributes Method

[image]

LinkOne WebView API
ContentAdapterBase..::.SetAttributes Method
ContentAdapterBase Class See Also Send Feedback
Wrapper for SetAttributes(String, FileAttributes).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual void SetAttributes(
    string path,
    FileAttributes fileAttributes
)
Visual Basic (Declaration)
Public Overridable Sub SetAttributes ( _
    path As String, _
    fileAttributes As FileAttributes _
)
Visual C++
public:
virtual void SetAttributes(
    String^ path,
    FileAttributes fileAttributes
)

Parameters

path
Type: System..::.String
fileAttributes
Type: System.IO..::.FileAttributes

Implements

IContentAdapter..::.SetAttributes(String, FileAttributes)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


SetLastWriteTime Method

[image] [image]

LinkOne WebView API
ContentAdapterBase..::.SetLastWriteTime Method
ContentAdapterBase Class See Also Send Feedback

Overload List

Name | Description
SetLastWriteTime(String, DateTime) | Wrapper for SetLastWriteTime(String, DateTime).
SetLastWriteTime(String, DateTime, Int32) | Wrapper for SetLastWriteTime(String, DateTime).

See Also

ContentAdapterBase Class
ContentAdapterBase Members
Mincom.LinkOne.Adapter Namespace


SetLastWriteTime Method (String, DateTime)

[image]

LinkOne WebView API
ContentAdapterBase..::.SetLastWriteTime Method (String, DateTime)
ContentAdapterBase Class See Also Send Feedback
Wrapper for SetLastWriteTime(String, DateTime).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual void SetLastWriteTime(
    string fileName,
    DateTime dateTime
)
Visual Basic (Declaration)
Public Overridable Sub SetLastWriteTime ( _
    fileName As String, _
    dateTime As DateTime _
)
Visual C++
public:
virtual void SetLastWriteTime(
    String^ fileName,
    DateTime dateTime
)

Parameters

fileName
Type: System..::.String
dateTime
Type: System..::.DateTime

Implements

IContentAdapter..::.SetLastWriteTime(String, DateTime)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
SetLastWriteTime Overload
Mincom.LinkOne.Adapter Namespace


SetLastWriteTime Method (String, DateTime, Int32)

[image]

LinkOne WebView API
ContentAdapterBase..::.SetLastWriteTime Method (String, DateTime, Int32)
ContentAdapterBase Class See Also Send Feedback
Wrapper for SetLastWriteTime(String, DateTime).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual void SetLastWriteTime(
    string fileName,
    DateTime dateTime,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Overridable Sub SetLastWriteTime ( _
    fileName As String, _
    dateTime As DateTime, _
    retryMilliseconds As Integer _
)
Visual C++
public:
virtual void SetLastWriteTime(
    String^ fileName,
    DateTime dateTime,
    int retryMilliseconds
)

Parameters

fileName
Type: System..::.String
Name of the file to set the time on.
dateTime
Type: System..::.DateTime
The time stamp to set.
retryMilliseconds
Type: System..::.Int32
The number of milliseconds to retry for, incase the file is locked.

Implements

IContentAdapter..::.SetLastWriteTime(String, DateTime, Int32)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
SetLastWriteTime Overload
Mincom.LinkOne.Adapter Namespace


SetLastWriteTimeUtc Method

[image] [image]

LinkOne WebView API
ContentAdapterBase..::.SetLastWriteTimeUtc Method
ContentAdapterBase Class See Also Send Feedback

Overload List

Name | Description
SetLastWriteTimeUtc(String, DateTime) | Wrapper for SetLastWriteTimeUtc(String, DateTime).
SetLastWriteTimeUtc(String, DateTime, Int32) | Wrapper for SetLastWriteTimeUtc(String, DateTime).

See Also

ContentAdapterBase Class
ContentAdapterBase Members
Mincom.LinkOne.Adapter Namespace


SetLastWriteTimeUtc Method (String, DateTime)

[image]

LinkOne WebView API
ContentAdapterBase..::.SetLastWriteTimeUtc Method (String, DateTime)
ContentAdapterBase Class See Also Send Feedback
Wrapper for SetLastWriteTimeUtc(String, DateTime).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual void SetLastWriteTimeUtc(
    string path,
    DateTime dateTime
)
Visual Basic (Declaration)
Public Overridable Sub SetLastWriteTimeUtc ( _
    path As String, _
    dateTime As DateTime _
)
Visual C++
public:
virtual void SetLastWriteTimeUtc(
    String^ path,
    DateTime dateTime
)

Parameters

path
Type: System..::.String
dateTime
Type: System..::.DateTime

Implements

IContentAdapter..::.SetLastWriteTimeUtc(String, DateTime)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
SetLastWriteTimeUtc Overload
Mincom.LinkOne.Adapter Namespace


SetLastWriteTimeUtc Method (String, DateTime, Int32)

[image]

LinkOne WebView API
ContentAdapterBase..::.SetLastWriteTimeUtc Method (String, DateTime, Int32)
ContentAdapterBase Class See Also Send Feedback
Wrapper for SetLastWriteTimeUtc(String, DateTime).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual void SetLastWriteTimeUtc(
    string path,
    DateTime dateTime,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Overridable Sub SetLastWriteTimeUtc ( _
    path As String, _
    dateTime As DateTime, _
    retryMilliseconds As Integer _
)
Visual C++
public:
virtual void SetLastWriteTimeUtc(
    String^ path,
    DateTime dateTime,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
The path the path to set the write time on.
dateTime
Type: System..::.DateTime
The timestamp to set.
retryMilliseconds
Type: System..::.Int32
The number of milliseconds to retry for, incase the file is locked.

Implements

IContentAdapter..::.SetLastWriteTimeUtc(String, DateTime, Int32)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
SetLastWriteTimeUtc Overload
Mincom.LinkOne.Adapter Namespace


SetLength Method

[image]

LinkOne WebView API
ContentAdapterBase..::.SetLength Method
ContentAdapterBase Class See Also Send Feedback
Wrapper for SetLength(Int64).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual void SetLength(
    Stream stream,
    long value
)
Visual Basic (Declaration)
Public Overridable Sub SetLength ( _
    stream As Stream, _
    value As Long _
)
Visual C++
public:
virtual void SetLength(
    Stream^ stream,
    long long value
)

Parameters

stream
Type: System.IO..::.Stream
value
Type: System..::.Int64

Implements

IContentAdapter..::.SetLength(Stream, Int64)

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


ValidateTimeStamp Method

[image]

LinkOne WebView API
ContentAdapterBase..::.ValidateTimeStamp Method
ContentAdapterBase Class See Also Send Feedback
Ensures that the timestamp for the given path is valid.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual bool ValidateTimeStamp(
    string path
)
Visual Basic (Declaration)
Public Overridable Function ValidateTimeStamp ( _
    path As String _
) As Boolean
Visual C++
public:
virtual bool ValidateTimeStamp(
    String^ path
)

Parameters

path
Type: System..::.String
Path to validate the timestamp for.

Return Value

False if the path does not exists.

Implements

IContentAdapter..::.ValidateTimeStamp(String)

Remarks

For network paths, NTFS sometimes caches the timestamp. This function attempts to open the path ensuring the timestamp is up to date.

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred. This does not include if the file does not exists.

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


Write Method

[image]

LinkOne WebView API
ContentAdapterBase..::.Write Method
ContentAdapterBase Class See Also Send Feedback
Wrapper for Write(String).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual void Write(
    TextWriter writer,
    string contents
)
Visual Basic (Declaration)
Public Overridable Sub Write ( _
    writer As TextWriter, _
    contents As String _
)
Visual C++
public:
virtual void Write(
    TextWriter^ writer,
    String^ contents
)

Parameters

writer
Type: System.IO..::.TextWriter
contents
Type: System..::.String

Implements

IContentAdapter..::.Write(TextWriter, String)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


WriteAllBytes Method

[image] [image]

LinkOne WebView API
ContentAdapterBase..::.WriteAllBytes Method
ContentAdapterBase Class See Also Send Feedback

Overload List

Name | Description
WriteAllBytes(String, array<Byte>[]()[]) | Wrapper for WriteAllBytes(String, array<Byte>[]()[]).
WriteAllBytes(String, array<Byte>[]()[], Nullable<(Of <(DateTime>)>), Int32) | Wrapper for WriteAllBytes(String, array<Byte>[]()[]).

See Also

ContentAdapterBase Class
ContentAdapterBase Members
Mincom.LinkOne.Adapter Namespace


WriteAllBytes Method (String, Byte[])

[image]

LinkOne WebView API
ContentAdapterBase..::.WriteAllBytes Method (String, array<Byte>[]()[])
ContentAdapterBase Class See Also Send Feedback
Wrapper for WriteAllBytes(String, array<Byte>[]()[]).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual void WriteAllBytes(
    string path,
    byte[] bytes
)
Visual Basic (Declaration)
Public Overridable Sub WriteAllBytes ( _
    path As String, _
    bytes As Byte() _
)
Visual C++
public:
virtual void WriteAllBytes(
    String^ path,
    array<unsigned char>^ bytes
)

Parameters

path
Type: System..::.String
bytes
Type: array< System..::.Byte >[]()[]

Implements

IContentAdapter..::.WriteAllBytes(String, array<Byte>[]()[])

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
WriteAllBytes Overload
Mincom.LinkOne.Adapter Namespace


WriteAllBytes Method (String, Byte[], Nullable(DateTime), Int32)

[image]

LinkOne WebView API
ContentAdapterBase..::.WriteAllBytes Method (String, array<Byte>[]()[], Nullable<(Of <(DateTime>)>), Int32)
ContentAdapterBase Class See Also Send Feedback
Wrapper for WriteAllBytes(String, array<Byte>[]()[]).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual void WriteAllBytes(
    string path,
    byte[] bytes,
    Nullable<DateTime> lastModifiedTime,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Overridable Sub WriteAllBytes ( _
    path As String, _
    bytes As Byte(), _
    lastModifiedTime As Nullable(Of DateTime), _
    retryMilliseconds As Integer _
)
Visual C++
public:
virtual void WriteAllBytes(
    String^ path,
    array<unsigned char>^ bytes,
    Nullable<DateTime> lastModifiedTime,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
The path to write to.
bytes
Type: array< System..::.Byte >[]()[]
The bytes to write.
lastModifiedTime
Type: System..::.Nullable<(Of <(DateTime>)>)
any last-write time to stamp the file with.
retryMilliseconds
Type: System..::.Int32
The number of milliseconds to retry writing the file for if it is locked.

Implements

IContentAdapter..::.WriteAllBytes(String, array<Byte>[]()[], Nullable<(Of <(DateTime>)>), Int32)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
WriteAllBytes Overload
Mincom.LinkOne.Adapter Namespace


WriteAllText Method

[image] [image]

LinkOne WebView API
ContentAdapterBase..::.WriteAllText Method
ContentAdapterBase Class See Also Send Feedback

Overload List

Name | Description
WriteAllText(String, String, Encoding) | Wrapper for WriteAllText(String, String, Encoding).
WriteAllText(String, String, Encoding, Int32) | Wrapper for WriteAllText(String, String, Encoding).

See Also

ContentAdapterBase Class
ContentAdapterBase Members
Mincom.LinkOne.Adapter Namespace


WriteAllText Method (String, String, Encoding)

[image]

LinkOne WebView API
ContentAdapterBase..::.WriteAllText Method (String, String, Encoding)
ContentAdapterBase Class See Also Send Feedback
Wrapper for WriteAllText(String, String, Encoding).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual void WriteAllText(
    string path,
    string contents,
    Encoding encoding
)
Visual Basic (Declaration)
Public Overridable Sub WriteAllText ( _
    path As String, _
    contents As String, _
    encoding As Encoding _
)
Visual C++
public:
virtual void WriteAllText(
    String^ path,
    String^ contents,
    Encoding^ encoding
)

Parameters

path
Type: System..::.String
contents
Type: System..::.String
encoding
Type: System.Text..::.Encoding

Implements

IContentAdapter..::.WriteAllText(String, String, Encoding)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
WriteAllText Overload
Mincom.LinkOne.Adapter Namespace


WriteAllText Method (String, String, Encoding, Int32)

[image]

LinkOne WebView API
ContentAdapterBase..::.WriteAllText Method (String, String, Encoding, Int32)
ContentAdapterBase Class See Also Send Feedback
Wrapper for WriteAllText(String, String, Encoding).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual void WriteAllText(
    string path,
    string contents,
    Encoding encoding,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Overridable Sub WriteAllText ( _
    path As String, _
    contents As String, _
    encoding As Encoding, _
    retryMilliseconds As Integer _
)
Visual C++
public:
virtual void WriteAllText(
    String^ path,
    String^ contents,
    Encoding^ encoding,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
The path to write to.
contents
Type: System..::.String
The contents to write.
encoding
Type: System.Text..::.Encoding
The encoding to use.
retryMilliseconds
Type: System..::.Int32
The number of milliseconds to retry writing for if the file is locked.

Implements

IContentAdapter..::.WriteAllText(String, String, Encoding, Int32)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
WriteAllText Overload
Mincom.LinkOne.Adapter Namespace


WriteLine Method

[image]

LinkOne WebView API
ContentAdapterBase..::.WriteLine Method
ContentAdapterBase Class See Also Send Feedback
Wrapper for WriteLine(String).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public virtual void WriteLine(
    TextWriter writer,
    string contents
)
Visual Basic (Declaration)
Public Overridable Sub WriteLine ( _
    writer As TextWriter, _
    contents As String _
)
Visual C++
public:
virtual void WriteLine(
    TextWriter^ writer,
    String^ contents
)

Parameters

writer
Type: System.IO..::.TextWriter
contents
Type: System..::.String

Implements

IContentAdapter..::.WriteLine(TextWriter, String)

Exceptions

Exception | Condition
[!:Mincom.LinkOne.Exceptions.IOException] | An I/O error occurred.

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


ContentAdapterBase Properties

[image] [image]

LinkOne WebView API
ContentAdapterBase Properties
ContentAdapterBase Class See Also Send Feedback

The ContentAdapterBase type exposes the following members.

Properties

Name | Description
MinimumFileDateTime |
Provider |

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


MinimumFileDateTime Property

[image]

LinkOne WebView API
ContentAdapterBase..::.MinimumFileDateTime Property
ContentAdapterBase Class See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public DateTime MinimumFileDateTime { get; }
Visual Basic (Declaration)
Public ReadOnly Property MinimumFileDateTime As DateTime
Visual C++
public:
virtual property DateTime MinimumFileDateTime {
    DateTime get () sealed;
}

Implements

IContentAdapter..::.MinimumFileDateTime

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


Provider Property

[image]

LinkOne WebView API
ContentAdapterBase..::.Provider Property
ContentAdapterBase Class See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
protected ICmsService Provider { get; }
Visual Basic (Declaration)
Protected ReadOnly Property Provider As ICmsService
Visual C++
protected:
property ICmsService^ Provider {
    ICmsService^ get ();
}

See Also

ContentAdapterBase Class
Mincom.LinkOne.Adapter Namespace


ContentAdapterFactory Class

[image]

LinkOne WebView API
ContentAdapterFactory Class
Members See Also Send Feedback
Wraps System.IO calls encapsulating I/O related exceptions in an [!:Mincom.LinkOne.Exceptions.IOException].

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
[SerializableAttribute]
public static class ContentAdapterFactory
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class ContentAdapterFactory
Visual C++
[SerializableAttribute]
public ref class ContentAdapterFactory abstract sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Adapter..::.ContentAdapterFactory

See Also

ContentAdapterFactory Members
Mincom.LinkOne.Adapter Namespace


ContentAdapterFactory Members

[image] [image]

LinkOne WebView API
ContentAdapterFactory Members
ContentAdapterFactory Class Methods Fields See Also Send Feedback

The ContentAdapterFactory type exposes the following members.

Methods

Name | Description
GetAdapter |

Fields

Name | Description
MinimumFileDateTime | The miminum acceptable NTFS File Time.

See Also

ContentAdapterFactory Class
Mincom.LinkOne.Adapter Namespace


ContentAdapterFactory Fields

[image] [image]

LinkOne WebView API
ContentAdapterFactory Fields
ContentAdapterFactory Class See Also Send Feedback

The ContentAdapterFactory type exposes the following members.

Fields

Name | Description
MinimumFileDateTime | The miminum acceptable NTFS File Time.

See Also

ContentAdapterFactory Class
Mincom.LinkOne.Adapter Namespace


MinimumFileDateTime Field

[image]

LinkOne WebView API
ContentAdapterFactory..::.MinimumFileDateTime Field
ContentAdapterFactory Class See Also Send Feedback
The miminum acceptable NTFS File Time.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public static readonly DateTime MinimumFileDateTime
Visual Basic (Declaration)
Public Shared ReadOnly MinimumFileDateTime As DateTime
Visual C++
public:
static initonly DateTime MinimumFileDateTime

See Also

ContentAdapterFactory Class
Mincom.LinkOne.Adapter Namespace


ContentAdapterFactory Methods

[image] [image]

LinkOne WebView API
ContentAdapterFactory Methods
ContentAdapterFactory Class See Also Send Feedback

The ContentAdapterFactory type exposes the following members.

Methods

Name | Description
GetAdapter |

See Also

ContentAdapterFactory Class
Mincom.LinkOne.Adapter Namespace


GetAdapter Method

[image]

LinkOne WebView API
ContentAdapterFactory..::.GetAdapter Method
ContentAdapterFactory Class See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public static IContentAdapter GetAdapter(
    string path
)
Visual Basic (Declaration)
Public Shared Function GetAdapter ( _
    path As String _
) As IContentAdapter
Visual C++
public:
static IContentAdapter^ GetAdapter(
    String^ path
)

Parameters

path
Type: System..::.String

See Also

ContentAdapterFactory Class
Mincom.LinkOne.Adapter Namespace


DocumentList Class

[image]

LinkOne WebView API
DocumentList Class
Members See Also Send Feedback
Represents a list of documents retrieved from the Cms service.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public class DocumentList
Visual Basic (Declaration)
Public Class DocumentList
Visual C++
public ref class DocumentList

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Adapter..::.DocumentList

See Also

DocumentList Members
Mincom.LinkOne.Adapter Namespace


DocumentList Members

[image] [image]

LinkOne WebView API
DocumentList Members
DocumentList Class Constructors Methods Properties See Also Send Feedback

The DocumentList type exposes the following members.

Constructors

Name | Description
DocumentList | Initializes a new instance of the DocumentList class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Documents | Collection of requested documents. May be empty (but not null).
Paged | True if the request was paged and there are more documents.
PaginationMarker | Internal value used for server side pagination. Should never be modified by client code.

See Also

DocumentList Class
Mincom.LinkOne.Adapter Namespace


DocumentList Constructor

[image]

LinkOne WebView API
DocumentList Constructor
DocumentList Class See Also Send Feedback
Initializes a new instance of the DocumentList class

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public DocumentList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentList()

See Also

DocumentList Class
Mincom.LinkOne.Adapter Namespace


DocumentList Methods

[image] [image]

LinkOne WebView API
DocumentList Methods
DocumentList Class See Also Send Feedback

The DocumentList type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentList Class
Mincom.LinkOne.Adapter Namespace


DocumentList Properties

[image] [image]

LinkOne WebView API
DocumentList Properties
DocumentList Class See Also Send Feedback

The DocumentList type exposes the following members.

Properties

Name | Description
Documents | Collection of requested documents. May be empty (but not null).
Paged | True if the request was paged and there are more documents.
PaginationMarker | Internal value used for server side pagination. Should never be modified by client code.

See Also

DocumentList Class
Mincom.LinkOne.Adapter Namespace


Documents Property

[image]

LinkOne WebView API
DocumentList..::.Documents Property
DocumentList Class See Also Send Feedback
Collection of requested documents. May be empty (but not null).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public DocumentReference[] Documents { get; set; }
Visual Basic (Declaration)
Public Property Documents As DocumentReference()
Visual C++
public:
property array<DocumentReference^>^ Documents {
    array<DocumentReference^>^ get ();
    void set (array<DocumentReference^>^ value);
}

See Also

DocumentList Class
Mincom.LinkOne.Adapter Namespace


Paged Property

[image]

LinkOne WebView API
DocumentList..::.Paged Property
DocumentList Class See Also Send Feedback
True if the request was paged and there are more documents.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public bool Paged { get; set; }
Visual Basic (Declaration)
Public Property Paged As Boolean
Visual C++
public:
property bool Paged {
    bool get ();
    void set (bool value);
}

Remarks

This is always false when the last page of documents is retrieved.

See Also

DocumentList Class
Mincom.LinkOne.Adapter Namespace


PaginationMarker Property

[image]

LinkOne WebView API
DocumentList..::.PaginationMarker Property
DocumentList Class See Also Send Feedback
Internal value used for server side pagination. Should never be modified by client code.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public string PaginationMarker { get; set; }
Visual Basic (Declaration)
Public Property PaginationMarker As String
Visual C++
public:
property String^ PaginationMarker {
    String^ get ();
    void set (String^ value);
}

Remarks

Document queries usually return a sub set of the total number of available documents. This is a marker value identifying where in the complete document the current sub-set appears. This value is used in subsequent document queries to retrieve from the end of the current sub-set.

An empty value is returned only if there are no more results. This equates to a null pagination marker. In this case Paged should be false.

See Also

DocumentList Class
Mincom.LinkOne.Adapter Namespace


DocumentReference Class

[image]

LinkOne WebView API
DocumentReference Class
Members See Also Send Feedback
Represents a reference to a document stored on a content management system (CMS) server.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public class DocumentReference
Visual Basic (Declaration)
Public Class DocumentReference
Visual C++
public ref class DocumentReference

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Adapter..::.DocumentReference

See Also

DocumentReference Members
Mincom.LinkOne.Adapter Namespace


DocumentReference Members

[image] [image]

LinkOne WebView API
DocumentReference Members
DocumentReference Class Constructors Methods Properties See Also Send Feedback

The DocumentReference type exposes the following members.

Constructors

Name | Description
DocumentReference | Initializes a new instance of the DocumentReference class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
ContentType | Identifies the content type.
DisplayName | The display name for the document.
FileUri | The Uri used to access the document.
ID | The document ID. It is unique within the context of a document set.
LastModified | Identifies when the file was modified.
Type | Identifies the document type.
Uri | The Uri used to access the document.

See Also

DocumentReference Class
Mincom.LinkOne.Adapter Namespace


DocumentReference Constructor

[image]

LinkOne WebView API
DocumentReference Constructor
DocumentReference Class See Also Send Feedback
Initializes a new instance of the DocumentReference class

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public DocumentReference()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentReference()

See Also

DocumentReference Class
Mincom.LinkOne.Adapter Namespace


DocumentReference Methods

[image] [image]

LinkOne WebView API
DocumentReference Methods
DocumentReference Class See Also Send Feedback

The DocumentReference type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentReference Class
Mincom.LinkOne.Adapter Namespace


DocumentReference Properties

[image] [image]

LinkOne WebView API
DocumentReference Properties
DocumentReference Class See Also Send Feedback

The DocumentReference type exposes the following members.

Properties

Name | Description
ContentType | Identifies the content type.
DisplayName | The display name for the document.
FileUri | The Uri used to access the document.
ID | The document ID. It is unique within the context of a document set.
LastModified | Identifies when the file was modified.
Type | Identifies the document type.
Uri | The Uri used to access the document.

See Also

DocumentReference Class
Mincom.LinkOne.Adapter Namespace


ContentType Property

[image]

LinkOne WebView API
DocumentReference..::.ContentType Property
DocumentReference Class See Also Send Feedback
Identifies the content type.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public string ContentType { get; set; }
Visual Basic (Declaration)
Public Property ContentType As String
Visual C++
public:
property String^ ContentType {
    String^ get ();
    void set (String^ value);
}

See Also

DocumentReference Class
Mincom.LinkOne.Adapter Namespace


DisplayName Property

[image]

LinkOne WebView API
DocumentReference..::.DisplayName Property
DocumentReference Class See Also Send Feedback
The display name for the document.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public string DisplayName { get; set; }
Visual Basic (Declaration)
Public Property DisplayName As String
Visual C++
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}

See Also

DocumentReference Class
Mincom.LinkOne.Adapter Namespace


FileUri Property

[image]

LinkOne WebView API
DocumentReference..::.FileUri Property
DocumentReference Class See Also Send Feedback
The Uri used to access the document.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public string FileUri { get; set; }
Visual Basic (Declaration)
Public Property FileUri As String
Visual C++
public:
property String^ FileUri {
    String^ get ();
    void set (String^ value);
}

See Also

DocumentReference Class
Mincom.LinkOne.Adapter Namespace


ID Property

[image]

LinkOne WebView API
DocumentReference..::.ID Property
DocumentReference Class See Also Send Feedback
The document ID. It is unique within the context of a document set.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public string ID { get; set; }
Visual Basic (Declaration)
Public Property ID As String
Visual C++
public:
property String^ ID {
    String^ get ();
    void set (String^ value);
}

See Also

DocumentReference Class
Mincom.LinkOne.Adapter Namespace


LastModified Property

[image]

LinkOne WebView API
DocumentReference..::.LastModified Property
DocumentReference Class See Also Send Feedback
Identifies when the file was modified.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public DateTime LastModified { get; set; }
Visual Basic (Declaration)
Public Property LastModified As DateTime
Visual C++
public:
property DateTime LastModified {
    DateTime get ();
    void set (DateTime value);
}

See Also

DocumentReference Class
Mincom.LinkOne.Adapter Namespace


Type Property

[image]

LinkOne WebView API
DocumentReference..::.Type Property
DocumentReference Class See Also Send Feedback
Identifies the document type.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public DocumentType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As DocumentType
Visual C++
public:
property DocumentType Type {
    DocumentType get ();
    void set (DocumentType value);
}

See Also

DocumentReference Class
Mincom.LinkOne.Adapter Namespace


Uri Property

[image]

LinkOne WebView API
DocumentReference..::.Uri Property
DocumentReference Class See Also Send Feedback
The Uri used to access the document.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public string Uri { get; set; }
Visual Basic (Declaration)
Public Property Uri As String
Visual C++
public:
property String^ Uri {
    String^ get ();
    void set (String^ value);
}

See Also

DocumentReference Class
Mincom.LinkOne.Adapter Namespace


DocumentType Enumeration

[image]

LinkOne WebView API
DocumentType Enumeration
See Also Send Feedback
The known set of document types.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public enum DocumentType
Visual Basic (Declaration)
Public Enumeration DocumentType
Visual C++
public enum class DocumentType

Members

Member name | Description
Unknown | Specific type is not known.
PlainText | A plain text document.
Image | An graphic/image file.
WordProcessor | A word processor document (e.g., MS Word).
Spreadsheet | A spreadsheet (e.g., MS Excel).
Presentation | A presentation (e.g., MS Powerpoint).
Pdf | A Pdf document.
RightHemisphere | A Right Hemisphere 3D Viewer.

See Also

Mincom.LinkOne.Adapter Namespace


ICmsService Interface

[image]

LinkOne WebView API
ICmsService Interface
Members See Also Send Feedback
Defines interface to implement when creating a Provider for connecting to a 3rd Party Content Management System (CMS).

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public interface ICmsService
Visual Basic (Declaration)
Public Interface ICmsService
Visual C++
public interface class ICmsService

Remarks

The integration uses the interaction as an abstraction layer between the client and the CMS server. It must implement all interface methods.

Content Management System integration is limited to displaying links to documents in the CMS that relate to the current viewing context. There are three levels to the current context: Publisher, Book and Page. A request for documents is issued at each scope. New requests are issued only for the scopes that change.

See Also

ICmsService Members
Mincom.LinkOne.Adapter Namespace


ICmsService Members

[image] [image]

LinkOne WebView API
ICmsService Members
ICmsService Interface Methods See Also Send Feedback

The ICmsService type exposes the following members.

Methods

Name | Description
GetDocument | Retrieves the bytes for a document from the Content Mangement System.
GetDocuments | Requests documents from the Content Mangement System relating to the given scope. This is the primary communication method between the client and the CMS server.
LastWriteTime | Gets the last write time for a document from the Content Mangement System.

See Also

ICmsService Interface
Mincom.LinkOne.Adapter Namespace


ICmsService Methods

[image] [image]

LinkOne WebView API
ICmsService Methods
ICmsService Interface See Also Send Feedback

The ICmsService type exposes the following members.

Methods

Name | Description
GetDocument | Retrieves the bytes for a document from the Content Mangement System.
GetDocuments | Requests documents from the Content Mangement System relating to the given scope. This is the primary communication method between the client and the CMS server.
LastWriteTime | Gets the last write time for a document from the Content Mangement System.

See Also

ICmsService Interface
Mincom.LinkOne.Adapter Namespace


GetDocument Method

[image]

LinkOne WebView API
ICmsService..::.GetDocument Method
ICmsService Interface See Also Send Feedback
Retrieves the bytes for a document from the Content Mangement System.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
byte[] GetDocument(
    string referencePath,
    out DocumentReference documentRef
)
Visual Basic (Declaration)
Function GetDocument ( _
    referencePath As String, _
    <OutAttribute> ByRef documentRef As DocumentReference _
) As Byte()
Visual C++
array<unsigned char>^ GetDocument(
    String^ referencePath,
    [OutAttribute] DocumentReference^% documentRef
)

Parameters

referencePath
Type: System..::.String
Identifies the context for which to retrieve documents.
documentRef
Type: Mincom.LinkOne.Adapter..::.DocumentReference %

Return Value

A byte array of the document.

See Also

ICmsService Interface
Mincom.LinkOne.Adapter Namespace


GetDocuments Method

[image]

LinkOne WebView API
ICmsService..::.GetDocuments Method
ICmsService Interface See Also Send Feedback
Requests documents from the Content Mangement System relating to the given scope. This is the primary communication method between the client and the CMS server.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
DocumentList GetDocuments(
    string referencePath,
    string paginationMarker,
    int count,
    string languageCode
)
Visual Basic (Declaration)
Function GetDocuments ( _
    referencePath As String, _
    paginationMarker As String, _
    count As Integer, _
    languageCode As String _
) As DocumentList
Visual C++
DocumentList^ GetDocuments(
    String^ referencePath,
    String^ paginationMarker,
    int count,
    String^ languageCode
)

Parameters

referencePath
Type: System..::.String
Identifies the context for which to retrieve documents. See remarks for further details.
paginationMarker
Type: System..::.String
A pagination marker used when retrieving multiple pages of documents. See remarks.
count
Type: System..::.Int32
The maximum number of documents to retrieve. See remarks.
languageCode
Type: System..::.String

Return Value

A list of documents for the referencePath. This may be empty (but not null). The DocumentList also identifies whether there are more documents to retrieve (see Paged) and a marker to pass as paginationMarker to retrieve the next page.

Remarks

This method must retrieve documents relevant to the given referencePath. The referencePath is of the form: PublisherCode[.BookCode[.PageReference]] where the square brackets denote optional components. The book code and page reference are both optional components, however, a valid book code must be specified in order to specific a page reference. The intepretation of the referencePath is left to the implementing code. The Utility class may be used to help interpret this parameter.

The count parameter identifies the maximum number of documents to retrieve on this call. The paginationMarker is used when the count value is insufficient for the number of documents available. The range of valid values for paginationMarker is implementation dependent. The argument will empty when requesting the first "page" of documents. If there are more pages of documents, the implementation must set the PaginationMarker of the return value. This will be passed on a subsequence call to this method to retrieve the next page.

See Also

ICmsService Interface
Mincom.LinkOne.Adapter Namespace


LastWriteTime Method

[image]

LinkOne WebView API
ICmsService..::.LastWriteTime Method
ICmsService Interface See Also Send Feedback
Gets the last write time for a document from the Content Mangement System.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
DateTime LastWriteTime(
    string referencePath
)
Visual Basic (Declaration)
Function LastWriteTime ( _
    referencePath As String _
) As DateTime
Visual C++
DateTime LastWriteTime(
    String^ referencePath
)

Parameters

referencePath
Type: System..::.String
Identifies the context for which to retrieve documents.

See Also

ICmsService Interface
Mincom.LinkOne.Adapter Namespace


IContentAdapter Interface

[image]

LinkOne WebView API
IContentAdapter Interface
Members See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public interface IContentAdapter
Visual Basic (Declaration)
Public Interface IContentAdapter
Visual C++
public interface class IContentAdapter

See Also

IContentAdapter Members
Mincom.LinkOne.Adapter Namespace


IContentAdapter Members

[image] [image]

LinkOne WebView API
IContentAdapter Members
IContentAdapter Interface Methods Properties See Also Send Feedback

The IContentAdapter type exposes the following members.

Methods

Name | Description
ChangeExtension |
Combine |
CopyFile | Overloaded.
Create |
CreateDirectory |
CreateStreamReader | Overloaded.
CreateStreamWriter | Overloaded.
DeleteDirectory | Overloaded.
DeleteFile | Overloaded.
DirectoryExists |
FileExists |
GetAttributes |
GetDirectories |
GetDirectoryAccessControl |
GetDirectoryName |
GetDocument |
GetDocuments |
GetFileAccessControl |
GetFileLength |
GetFileName |
GetFiles | Overloaded.
GetFullPath |
GetLastWriteTime |
GetLastWriteTimeUtc |
GetPathRoot |
GetTempFileName |
GetTempPath |
LastWriteTime |
MoveFile | Overloaded.
Open | Overloaded.
OpenRead | Overloaded.
ReadAllBytes | Overloaded.
ReadAllText | Overloaded.
ReadLine |
ReadToEnd |
Seek |
SetAttributes |
SetLastWriteTime | Overloaded.
SetLastWriteTimeUtc | Overloaded.
SetLength |
ValidateTimeStamp |
Write |
WriteAllBytes | Overloaded.
WriteAllText | Overloaded.
WriteLine |

Properties

Name | Description
MinimumFileDateTime |

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


IContentAdapter Methods

[image] [image]

LinkOne WebView API
IContentAdapter Methods
IContentAdapter Interface See Also Send Feedback

The IContentAdapter type exposes the following members.

Methods

Name | Description
ChangeExtension |
Combine |
CopyFile | Overloaded.
Create |
CreateDirectory |
CreateStreamReader | Overloaded.
CreateStreamWriter | Overloaded.
DeleteDirectory | Overloaded.
DeleteFile | Overloaded.
DirectoryExists |
FileExists |
GetAttributes |
GetDirectories |
GetDirectoryAccessControl |
GetDirectoryName |
GetDocument |
GetDocuments |
GetFileAccessControl |
GetFileLength |
GetFileName |
GetFiles | Overloaded.
GetFullPath |
GetLastWriteTime |
GetLastWriteTimeUtc |
GetPathRoot |
GetTempFileName |
GetTempPath |
LastWriteTime |
MoveFile | Overloaded.
Open | Overloaded.
OpenRead | Overloaded.
ReadAllBytes | Overloaded.
ReadAllText | Overloaded.
ReadLine |
ReadToEnd |
Seek |
SetAttributes |
SetLastWriteTime | Overloaded.
SetLastWriteTimeUtc | Overloaded.
SetLength |
ValidateTimeStamp |
Write |
WriteAllBytes | Overloaded.
WriteAllText | Overloaded.
WriteLine |

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


ChangeExtension Method

[image]

LinkOne WebView API
IContentAdapter..::.ChangeExtension Method
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
string ChangeExtension(
    string path,
    string extension
)
Visual Basic (Declaration)
Function ChangeExtension ( _
    path As String, _
    extension As String _
) As String
Visual C++
String^ ChangeExtension(
    String^ path,
    String^ extension
)

Parameters

path
Type: System..::.String
extension
Type: System..::.String

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


Combine Method

[image]

LinkOne WebView API
IContentAdapter..::.Combine Method
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
string Combine(
    string path1,
    string path2
)
Visual Basic (Declaration)
Function Combine ( _
    path1 As String, _
    path2 As String _
) As String
Visual C++
String^ Combine(
    String^ path1,
    String^ path2
)

Parameters

path1
Type: System..::.String
path2
Type: System..::.String

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


CopyFile Method

[image] [image]

LinkOne WebView API
IContentAdapter..::.CopyFile Method
IContentAdapter Interface See Also Send Feedback

Overload List

Name | Description
CopyFile(String, String, Boolean) |
CopyFile(String, String, Boolean, Int32) |

See Also

IContentAdapter Interface
IContentAdapter Members
Mincom.LinkOne.Adapter Namespace


CopyFile Method (String, String, Boolean)

[image]

LinkOne WebView API
IContentAdapter..::.CopyFile Method (String, String, Boolean)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
void CopyFile(
    string sourceFileName,
    string destinationFileName,
    bool overwrite
)
Visual Basic (Declaration)
Sub CopyFile ( _
    sourceFileName As String, _
    destinationFileName As String, _
    overwrite As Boolean _
)
Visual C++
void CopyFile(
    String^ sourceFileName,
    String^ destinationFileName,
    bool overwrite
)

Parameters

sourceFileName
Type: System..::.String
destinationFileName
Type: System..::.String
overwrite
Type: System..::.Boolean

See Also

IContentAdapter Interface
CopyFile Overload
Mincom.LinkOne.Adapter Namespace


CopyFile Method (String, String, Boolean, Int32)

[image]

LinkOne WebView API
IContentAdapter..::.CopyFile Method (String, String, Boolean, Int32)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
void CopyFile(
    string sourceFileName,
    string destinationFileName,
    bool overwrite,
    int retryMilliseconds
)
Visual Basic (Declaration)
Sub CopyFile ( _
    sourceFileName As String, _
    destinationFileName As String, _
    overwrite As Boolean, _
    retryMilliseconds As Integer _
)
Visual C++
void CopyFile(
    String^ sourceFileName,
    String^ destinationFileName,
    bool overwrite,
    int retryMilliseconds
)

Parameters

sourceFileName
Type: System..::.String
destinationFileName
Type: System..::.String
overwrite
Type: System..::.Boolean
retryMilliseconds
Type: System..::.Int32

See Also

IContentAdapter Interface
CopyFile Overload
Mincom.LinkOne.Adapter Namespace


Create Method

[image]

LinkOne WebView API
IContentAdapter..::.Create Method
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
Stream Create(
    string path,
    int bufferSize,
    FileOptions fileOptions
)
Visual Basic (Declaration)
Function Create ( _
    path As String, _
    bufferSize As Integer, _
    fileOptions As FileOptions _
) As Stream
Visual C++
Stream^ Create(
    String^ path,
    int bufferSize,
    FileOptions fileOptions
)

Parameters

path
Type: System..::.String
bufferSize
Type: System..::.Int32
fileOptions
Type: System.IO..::.FileOptions

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


CreateDirectory Method

[image]

LinkOne WebView API
IContentAdapter..::.CreateDirectory Method
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
DirectoryInfo CreateDirectory(
    string path
)
Visual Basic (Declaration)
Function CreateDirectory ( _
    path As String _
) As DirectoryInfo
Visual C++
DirectoryInfo^ CreateDirectory(
    String^ path
)

Parameters

path
Type: System..::.String

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


CreateStreamReader Method

[image] [image]

LinkOne WebView API
IContentAdapter..::.CreateStreamReader Method
IContentAdapter Interface See Also Send Feedback

Overload List

Name | Description
CreateStreamReader(Stream) |
CreateStreamReader(Stream, Boolean) |
CreateStreamReader(Stream, Encoding) |

See Also

IContentAdapter Interface
IContentAdapter Members
Mincom.LinkOne.Adapter Namespace


CreateStreamReader Method (Stream)

[image]

LinkOne WebView API
IContentAdapter..::.CreateStreamReader Method (Stream)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
StreamReader CreateStreamReader(
    Stream stream
)
Visual Basic (Declaration)
Function CreateStreamReader ( _
    stream As Stream _
) As StreamReader
Visual C++
StreamReader^ CreateStreamReader(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream

See Also

IContentAdapter Interface
CreateStreamReader Overload
Mincom.LinkOne.Adapter Namespace


CreateStreamReader Method (Stream, Boolean)

[image]

LinkOne WebView API
IContentAdapter..::.CreateStreamReader Method (Stream, Boolean)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
StreamReader CreateStreamReader(
    Stream stream,
    bool detectEncodingFromByteOrderMarks
)
Visual Basic (Declaration)
Function CreateStreamReader ( _
    stream As Stream, _
    detectEncodingFromByteOrderMarks As Boolean _
) As StreamReader
Visual C++
StreamReader^ CreateStreamReader(
    Stream^ stream,
    bool detectEncodingFromByteOrderMarks
)

Parameters

stream
Type: System.IO..::.Stream
detectEncodingFromByteOrderMarks
Type: System..::.Boolean

See Also

IContentAdapter Interface
CreateStreamReader Overload
Mincom.LinkOne.Adapter Namespace


CreateStreamReader Method (Stream, Encoding)

[image]

LinkOne WebView API
IContentAdapter..::.CreateStreamReader Method (Stream, Encoding)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
StreamReader CreateStreamReader(
    Stream stream,
    Encoding encoding
)
Visual Basic (Declaration)
Function CreateStreamReader ( _
    stream As Stream, _
    encoding As Encoding _
) As StreamReader
Visual C++
StreamReader^ CreateStreamReader(
    Stream^ stream,
    Encoding^ encoding
)

Parameters

stream
Type: System.IO..::.Stream
encoding
Type: System.Text..::.Encoding

See Also

IContentAdapter Interface
CreateStreamReader Overload
Mincom.LinkOne.Adapter Namespace


CreateStreamWriter Method

[image] [image]

LinkOne WebView API
IContentAdapter..::.CreateStreamWriter Method
IContentAdapter Interface See Also Send Feedback

Overload List

Name | Description
CreateStreamWriter(Stream) |
CreateStreamWriter(Stream, Encoding) |

See Also

IContentAdapter Interface
IContentAdapter Members
Mincom.LinkOne.Adapter Namespace


CreateStreamWriter Method (Stream)

[image]

LinkOne WebView API
IContentAdapter..::.CreateStreamWriter Method (Stream)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
StreamWriter CreateStreamWriter(
    Stream stream
)
Visual Basic (Declaration)
Function CreateStreamWriter ( _
    stream As Stream _
) As StreamWriter
Visual C++
StreamWriter^ CreateStreamWriter(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream

See Also

IContentAdapter Interface
CreateStreamWriter Overload
Mincom.LinkOne.Adapter Namespace


CreateStreamWriter Method (Stream, Encoding)

[image]

LinkOne WebView API
IContentAdapter..::.CreateStreamWriter Method (Stream, Encoding)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
StreamWriter CreateStreamWriter(
    Stream stream,
    Encoding encoding
)
Visual Basic (Declaration)
Function CreateStreamWriter ( _
    stream As Stream, _
    encoding As Encoding _
) As StreamWriter
Visual C++
StreamWriter^ CreateStreamWriter(
    Stream^ stream,
    Encoding^ encoding
)

Parameters

stream
Type: System.IO..::.Stream
encoding
Type: System.Text..::.Encoding

See Also

IContentAdapter Interface
CreateStreamWriter Overload
Mincom.LinkOne.Adapter Namespace


DeleteDirectory Method

[image] [image]

LinkOne WebView API
IContentAdapter..::.DeleteDirectory Method
IContentAdapter Interface See Also Send Feedback

Overload List

Name | Description
DeleteDirectory(String, Boolean) |
DeleteDirectory(String, Boolean, Int32) |

See Also

IContentAdapter Interface
IContentAdapter Members
Mincom.LinkOne.Adapter Namespace


DeleteDirectory Method (String, Boolean)

[image]

LinkOne WebView API
IContentAdapter..::.DeleteDirectory Method (String, Boolean)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
void DeleteDirectory(
    string path,
    bool recursive
)
Visual Basic (Declaration)
Sub DeleteDirectory ( _
    path As String, _
    recursive As Boolean _
)
Visual C++
void DeleteDirectory(
    String^ path,
    bool recursive
)

Parameters

path
Type: System..::.String
recursive
Type: System..::.Boolean

See Also

IContentAdapter Interface
DeleteDirectory Overload
Mincom.LinkOne.Adapter Namespace


DeleteDirectory Method (String, Boolean, Int32)

[image]

LinkOne WebView API
IContentAdapter..::.DeleteDirectory Method (String, Boolean, Int32)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
void DeleteDirectory(
    string path,
    bool recursive,
    int retryMilliseconds
)
Visual Basic (Declaration)
Sub DeleteDirectory ( _
    path As String, _
    recursive As Boolean, _
    retryMilliseconds As Integer _
)
Visual C++
void DeleteDirectory(
    String^ path,
    bool recursive,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
recursive
Type: System..::.Boolean
retryMilliseconds
Type: System..::.Int32

See Also

IContentAdapter Interface
DeleteDirectory Overload
Mincom.LinkOne.Adapter Namespace


DeleteFile Method

[image] [image]

LinkOne WebView API
IContentAdapter..::.DeleteFile Method
IContentAdapter Interface See Also Send Feedback

Overload List

Name | Description
DeleteFile(String) |
DeleteFile(String, Int32) |

See Also

IContentAdapter Interface
IContentAdapter Members
Mincom.LinkOne.Adapter Namespace


DeleteFile Method (String)

[image]

LinkOne WebView API
IContentAdapter..::.DeleteFile Method (String)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
void DeleteFile(
    string path
)
Visual Basic (Declaration)
Sub DeleteFile ( _
    path As String _
)
Visual C++
void DeleteFile(
    String^ path
)

Parameters

path
Type: System..::.String

See Also

IContentAdapter Interface
DeleteFile Overload
Mincom.LinkOne.Adapter Namespace


DeleteFile Method (String, Int32)

[image]

LinkOne WebView API
IContentAdapter..::.DeleteFile Method (String, Int32)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
void DeleteFile(
    string path,
    int retryMilliseconds
)
Visual Basic (Declaration)
Sub DeleteFile ( _
    path As String, _
    retryMilliseconds As Integer _
)
Visual C++
void DeleteFile(
    String^ path,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
retryMilliseconds
Type: System..::.Int32

See Also

IContentAdapter Interface
DeleteFile Overload
Mincom.LinkOne.Adapter Namespace


DirectoryExists Method

[image]

LinkOne WebView API
IContentAdapter..::.DirectoryExists Method
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
bool DirectoryExists(
    string path
)
Visual Basic (Declaration)
Function DirectoryExists ( _
    path As String _
) As Boolean
Visual C++
bool DirectoryExists(
    String^ path
)

Parameters

path
Type: System..::.String

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


FileExists Method

[image]

LinkOne WebView API
IContentAdapter..::.FileExists Method
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
bool FileExists(
    string path
)
Visual Basic (Declaration)
Function FileExists ( _
    path As String _
) As Boolean
Visual C++
bool FileExists(
    String^ path
)

Parameters

path
Type: System..::.String

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


GetAttributes Method

[image]

LinkOne WebView API
IContentAdapter..::.GetAttributes Method
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
FileAttributes GetAttributes(
    string path
)
Visual Basic (Declaration)
Function GetAttributes ( _
    path As String _
) As FileAttributes
Visual C++
FileAttributes GetAttributes(
    String^ path
)

Parameters

path
Type: System..::.String

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


GetDirectories Method

[image]

LinkOne WebView API
IContentAdapter..::.GetDirectories Method
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
string[] GetDirectories(
    string directory
)
Visual Basic (Declaration)
Function GetDirectories ( _
    directory As String _
) As String()
Visual C++
array<String^>^ GetDirectories(
    String^ directory
)

Parameters

directory
Type: System..::.String

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


GetDirectoryAccessControl Method

[image]

LinkOne WebView API
IContentAdapter..::.GetDirectoryAccessControl Method
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
DirectorySecurity GetDirectoryAccessControl(
    string path
)
Visual Basic (Declaration)
Function GetDirectoryAccessControl ( _
    path As String _
) As DirectorySecurity
Visual C++
DirectorySecurity^ GetDirectoryAccessControl(
    String^ path
)

Parameters

path
Type: System..::.String

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


GetDirectoryName Method

[image]

LinkOne WebView API
IContentAdapter..::.GetDirectoryName Method
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
string GetDirectoryName(
    string path
)
Visual Basic (Declaration)
Function GetDirectoryName ( _
    path As String _
) As String
Visual C++
String^ GetDirectoryName(
    String^ path
)

Parameters

path
Type: System..::.String

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


GetDocument Method

[image]

LinkOne WebView API
IContentAdapter..::.GetDocument Method
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
byte[] GetDocument(
    string referencePath,
    out DocumentReference documentRef
)
Visual Basic (Declaration)
Function GetDocument ( _
    referencePath As String, _
    <OutAttribute> ByRef documentRef As DocumentReference _
) As Byte()
Visual C++
array<unsigned char>^ GetDocument(
    String^ referencePath,
    [OutAttribute] DocumentReference^% documentRef
)

Parameters

referencePath
Type: System..::.String
documentRef
Type: Mincom.LinkOne.Adapter..::.DocumentReference %

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


GetDocuments Method

[image]

LinkOne WebView API
IContentAdapter..::.GetDocuments Method
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
DocumentList GetDocuments(
    string referencePath,
    string paginationMarker,
    int count,
    string languageCode
)
Visual Basic (Declaration)
Function GetDocuments ( _
    referencePath As String, _
    paginationMarker As String, _
    count As Integer, _
    languageCode As String _
) As DocumentList
Visual C++
DocumentList^ GetDocuments(
    String^ referencePath,
    String^ paginationMarker,
    int count,
    String^ languageCode
)

Parameters

referencePath
Type: System..::.String
paginationMarker
Type: System..::.String
count
Type: System..::.Int32
languageCode
Type: System..::.String

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


GetFileAccessControl Method

[image]

LinkOne WebView API
IContentAdapter..::.GetFileAccessControl Method
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
FileSecurity GetFileAccessControl(
    string path
)
Visual Basic (Declaration)
Function GetFileAccessControl ( _
    path As String _
) As FileSecurity
Visual C++
FileSecurity^ GetFileAccessControl(
    String^ path
)

Parameters

path
Type: System..::.String

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


GetFileLength Method

[image]

LinkOne WebView API
IContentAdapter..::.GetFileLength Method
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
long GetFileLength(
    string path
)
Visual Basic (Declaration)
Function GetFileLength ( _
    path As String _
) As Long
Visual C++
long long GetFileLength(
    String^ path
)

Parameters

path
Type: System..::.String

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


GetFileName Method

[image]

LinkOne WebView API
IContentAdapter..::.GetFileName Method
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
string GetFileName(
    string path
)
Visual Basic (Declaration)
Function GetFileName ( _
    path As String _
) As String
Visual C++
String^ GetFileName(
    String^ path
)

Parameters

path
Type: System..::.String

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


GetFiles Method

[image] [image]

LinkOne WebView API
IContentAdapter..::.GetFiles Method
IContentAdapter Interface See Also Send Feedback

Overload List

Name | Description
GetFiles(String) |
GetFiles(String, String) |
GetFiles(String, String, SearchOption) |

See Also

IContentAdapter Interface
IContentAdapter Members
Mincom.LinkOne.Adapter Namespace


GetFiles Method (String)

[image]

LinkOne WebView API
IContentAdapter..::.GetFiles Method (String)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
string[] GetFiles(
    string path
)
Visual Basic (Declaration)
Function GetFiles ( _
    path As String _
) As String()
Visual C++
array<String^>^ GetFiles(
    String^ path
)

Parameters

path
Type: System..::.String

See Also

IContentAdapter Interface
GetFiles Overload
Mincom.LinkOne.Adapter Namespace


GetFiles Method (String, String)

[image]

LinkOne WebView API
IContentAdapter..::.GetFiles Method (String, String)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
string[] GetFiles(
    string path,
    string searchPattern
)
Visual Basic (Declaration)
Function GetFiles ( _
    path As String, _
    searchPattern As String _
) As String()
Visual C++
array<String^>^ GetFiles(
    String^ path,
    String^ searchPattern
)

Parameters

path
Type: System..::.String
searchPattern
Type: System..::.String

See Also

IContentAdapter Interface
GetFiles Overload
Mincom.LinkOne.Adapter Namespace


GetFiles Method (String, String, SearchOption)

[image]

LinkOne WebView API
IContentAdapter..::.GetFiles Method (String, String, SearchOption)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
string[] GetFiles(
    string path,
    string searchPattern,
    SearchOption searchOption
)
Visual Basic (Declaration)
Function GetFiles ( _
    path As String, _
    searchPattern As String, _
    searchOption As SearchOption _
) As String()
Visual C++
array<String^>^ GetFiles(
    String^ path,
    String^ searchPattern,
    SearchOption searchOption
)

Parameters

path
Type: System..::.String
searchPattern
Type: System..::.String
searchOption
Type: System.IO..::.SearchOption

See Also

IContentAdapter Interface
GetFiles Overload
Mincom.LinkOne.Adapter Namespace


GetFullPath Method

[image]

LinkOne WebView API
IContentAdapter..::.GetFullPath Method
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
string GetFullPath(
    string path
)
Visual Basic (Declaration)
Function GetFullPath ( _
    path As String _
) As String
Visual C++
String^ GetFullPath(
    String^ path
)

Parameters

path
Type: System..::.String

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


GetLastWriteTime Method

[image]

LinkOne WebView API
IContentAdapter..::.GetLastWriteTime Method
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
DateTime GetLastWriteTime(
    string path
)
Visual Basic (Declaration)
Function GetLastWriteTime ( _
    path As String _
) As DateTime
Visual C++
DateTime GetLastWriteTime(
    String^ path
)

Parameters

path
Type: System..::.String

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


GetLastWriteTimeUtc Method

[image]

LinkOne WebView API
IContentAdapter..::.GetLastWriteTimeUtc Method
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
DateTime GetLastWriteTimeUtc(
    string path
)
Visual Basic (Declaration)
Function GetLastWriteTimeUtc ( _
    path As String _
) As DateTime
Visual C++
DateTime GetLastWriteTimeUtc(
    String^ path
)

Parameters

path
Type: System..::.String

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


GetPathRoot Method

[image]

LinkOne WebView API
IContentAdapter..::.GetPathRoot Method
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
string GetPathRoot(
    string path
)
Visual Basic (Declaration)
Function GetPathRoot ( _
    path As String _
) As String
Visual C++
String^ GetPathRoot(
    String^ path
)

Parameters

path
Type: System..::.String

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


GetTempFileName Method

[image]

LinkOne WebView API
IContentAdapter..::.GetTempFileName Method
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
string GetTempFileName()
Visual Basic (Declaration)
Function GetTempFileName As String
Visual C++
String^ GetTempFileName()

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


GetTempPath Method

[image]

LinkOne WebView API
IContentAdapter..::.GetTempPath Method
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
string GetTempPath()
Visual Basic (Declaration)
Function GetTempPath As String
Visual C++
String^ GetTempPath()

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


LastWriteTime Method

[image]

LinkOne WebView API
IContentAdapter..::.LastWriteTime Method
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
DateTime LastWriteTime(
    string referencePath
)
Visual Basic (Declaration)
Function LastWriteTime ( _
    referencePath As String _
) As DateTime
Visual C++
DateTime LastWriteTime(
    String^ referencePath
)

Parameters

referencePath
Type: System..::.String

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


MoveFile Method

[image] [image]

LinkOne WebView API
IContentAdapter..::.MoveFile Method
IContentAdapter Interface See Also Send Feedback

Overload List

Name | Description
MoveFile(String, String) |
MoveFile(String, String, Int32) |

See Also

IContentAdapter Interface
IContentAdapter Members
Mincom.LinkOne.Adapter Namespace


MoveFile Method (String, String)

[image]

LinkOne WebView API
IContentAdapter..::.MoveFile Method (String, String)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
void MoveFile(
    string source,
    string target
)
Visual Basic (Declaration)
Sub MoveFile ( _
    source As String, _
    target As String _
)
Visual C++
void MoveFile(
    String^ source,
    String^ target
)

Parameters

source
Type: System..::.String
target
Type: System..::.String

See Also

IContentAdapter Interface
MoveFile Overload
Mincom.LinkOne.Adapter Namespace


MoveFile Method (String, String, Int32)

[image]

LinkOne WebView API
IContentAdapter..::.MoveFile Method (String, String, Int32)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
void MoveFile(
    string source,
    string target,
    int retryMilliseconds
)
Visual Basic (Declaration)
Sub MoveFile ( _
    source As String, _
    target As String, _
    retryMilliseconds As Integer _
)
Visual C++
void MoveFile(
    String^ source,
    String^ target,
    int retryMilliseconds
)

Parameters

source
Type: System..::.String
target
Type: System..::.String
retryMilliseconds
Type: System..::.Int32

See Also

IContentAdapter Interface
MoveFile Overload
Mincom.LinkOne.Adapter Namespace


Open Method

[image] [image]

LinkOne WebView API
IContentAdapter..::.Open Method
IContentAdapter Interface See Also Send Feedback

Overload List

Name | Description
Open(String, FileMode) |
Open(String, FileMode, Int32) |
Open(String, FileMode, FileAccess, FileShare) |
Open(String, FileMode, FileAccess, FileShare, Int32) |
Open(String, FileMode, FileAccess, FileShare, Int32, FileOptions, Int32) |

See Also

IContentAdapter Interface
IContentAdapter Members
Mincom.LinkOne.Adapter Namespace


Open Method (String, FileMode)

[image]

LinkOne WebView API
IContentAdapter..::.Open Method (String, FileMode)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
FileStream Open(
    string path,
    FileMode mode
)
Visual Basic (Declaration)
Function Open ( _
    path As String, _
    mode As FileMode _
) As FileStream
Visual C++
FileStream^ Open(
    String^ path,
    FileMode mode
)

Parameters

path
Type: System..::.String
mode
Type: System.IO..::.FileMode

See Also

IContentAdapter Interface
Open Overload
Mincom.LinkOne.Adapter Namespace


Open Method (String, FileMode, Int32)

[image]

LinkOne WebView API
IContentAdapter..::.Open Method (String, FileMode, Int32)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
FileStream Open(
    string path,
    FileMode mode,
    int retryMilliseconds
)
Visual Basic (Declaration)
Function Open ( _
    path As String, _
    mode As FileMode, _
    retryMilliseconds As Integer _
) As FileStream
Visual C++
FileStream^ Open(
    String^ path,
    FileMode mode,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
mode
Type: System.IO..::.FileMode
retryMilliseconds
Type: System..::.Int32

See Also

IContentAdapter Interface
Open Overload
Mincom.LinkOne.Adapter Namespace


Open Method (String, FileMode, FileAccess, FileShare)

[image]

LinkOne WebView API
IContentAdapter..::.Open Method (String, FileMode, FileAccess, FileShare)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
FileStream Open(
    string path,
    FileMode mode,
    FileAccess access,
    FileShare share
)
Visual Basic (Declaration)
Function Open ( _
    path As String, _
    mode As FileMode, _
    access As FileAccess, _
    share As FileShare _
) As FileStream
Visual C++
FileStream^ Open(
    String^ path,
    FileMode mode,
    FileAccess access,
    FileShare share
)

Parameters

path
Type: System..::.String
mode
Type: System.IO..::.FileMode
access
Type: System.IO..::.FileAccess
share
Type: System.IO..::.FileShare

See Also

IContentAdapter Interface
Open Overload
Mincom.LinkOne.Adapter Namespace


Open Method (String, FileMode, FileAccess, FileShare, Int32)

[image]

LinkOne WebView API
IContentAdapter..::.Open Method (String, FileMode, FileAccess, FileShare, Int32)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
FileStream Open(
    string path,
    FileMode mode,
    FileAccess access,
    FileShare share,
    int retryMilliseconds
)
Visual Basic (Declaration)
Function Open ( _
    path As String, _
    mode As FileMode, _
    access As FileAccess, _
    share As FileShare, _
    retryMilliseconds As Integer _
) As FileStream
Visual C++
FileStream^ Open(
    String^ path,
    FileMode mode,
    FileAccess access,
    FileShare share,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
mode
Type: System.IO..::.FileMode
access
Type: System.IO..::.FileAccess
share
Type: System.IO..::.FileShare
retryMilliseconds
Type: System..::.Int32

See Also

IContentAdapter Interface
Open Overload
Mincom.LinkOne.Adapter Namespace


Open Method (String, FileMode, FileAccess, FileShare, Int32, FileOptions, Int32)

[image]

LinkOne WebView API
IContentAdapter..::.Open Method (String, FileMode, FileAccess, FileShare, Int32, FileOptions, Int32)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
FileStream Open(
    string path,
    FileMode mode,
    FileAccess access,
    FileShare share,
    int bufferSize,
    FileOptions options,
    int retryMilliseconds
)
Visual Basic (Declaration)
Function Open ( _
    path As String, _
    mode As FileMode, _
    access As FileAccess, _
    share As FileShare, _
    bufferSize As Integer, _
    options As FileOptions, _
    retryMilliseconds As Integer _
) As FileStream
Visual C++
FileStream^ Open(
    String^ path,
    FileMode mode,
    FileAccess access,
    FileShare share,
    int bufferSize,
    FileOptions options,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
mode
Type: System.IO..::.FileMode
access
Type: System.IO..::.FileAccess
share
Type: System.IO..::.FileShare
bufferSize
Type: System..::.Int32
options
Type: System.IO..::.FileOptions
retryMilliseconds
Type: System..::.Int32

See Also

IContentAdapter Interface
Open Overload
Mincom.LinkOne.Adapter Namespace


OpenRead Method

[image] [image]

LinkOne WebView API
IContentAdapter..::.OpenRead Method
IContentAdapter Interface See Also Send Feedback

Overload List

Name | Description
OpenRead(String) |
OpenRead(String, Int32) |

See Also

IContentAdapter Interface
IContentAdapter Members
Mincom.LinkOne.Adapter Namespace


OpenRead Method (String)

[image]

LinkOne WebView API
IContentAdapter..::.OpenRead Method (String)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
FileStream OpenRead(
    string path
)
Visual Basic (Declaration)
Function OpenRead ( _
    path As String _
) As FileStream
Visual C++
FileStream^ OpenRead(
    String^ path
)

Parameters

path
Type: System..::.String

See Also

IContentAdapter Interface
OpenRead Overload
Mincom.LinkOne.Adapter Namespace


OpenRead Method (String, Int32)

[image]

LinkOne WebView API
IContentAdapter..::.OpenRead Method (String, Int32)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
FileStream OpenRead(
    string path,
    int retryMilliseconds
)
Visual Basic (Declaration)
Function OpenRead ( _
    path As String, _
    retryMilliseconds As Integer _
) As FileStream
Visual C++
FileStream^ OpenRead(
    String^ path,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
retryMilliseconds
Type: System..::.Int32

See Also

IContentAdapter Interface
OpenRead Overload
Mincom.LinkOne.Adapter Namespace


ReadAllBytes Method

[image] [image]

LinkOne WebView API
IContentAdapter..::.ReadAllBytes Method
IContentAdapter Interface See Also Send Feedback

Overload List

Name | Description
ReadAllBytes(String) |
ReadAllBytes(String, Int32) |

See Also

IContentAdapter Interface
IContentAdapter Members
Mincom.LinkOne.Adapter Namespace


ReadAllBytes Method (String)

[image]

LinkOne WebView API
IContentAdapter..::.ReadAllBytes Method (String)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
byte[] ReadAllBytes(
    string path
)
Visual Basic (Declaration)
Function ReadAllBytes ( _
    path As String _
) As Byte()
Visual C++
array<unsigned char>^ ReadAllBytes(
    String^ path
)

Parameters

path
Type: System..::.String

See Also

IContentAdapter Interface
ReadAllBytes Overload
Mincom.LinkOne.Adapter Namespace


ReadAllBytes Method (String, Int32)

[image]

LinkOne WebView API
IContentAdapter..::.ReadAllBytes Method (String, Int32)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
byte[] ReadAllBytes(
    string path,
    int retryMilliseconds
)
Visual Basic (Declaration)
Function ReadAllBytes ( _
    path As String, _
    retryMilliseconds As Integer _
) As Byte()
Visual C++
array<unsigned char>^ ReadAllBytes(
    String^ path,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
retryMilliseconds
Type: System..::.Int32

See Also

IContentAdapter Interface
ReadAllBytes Overload
Mincom.LinkOne.Adapter Namespace


ReadAllText Method

[image] [image]

LinkOne WebView API
IContentAdapter..::.ReadAllText Method
IContentAdapter Interface See Also Send Feedback

Overload List

Name | Description
ReadAllText(String) |
ReadAllText(String, Int32) |
ReadAllText(String, Encoding) |
ReadAllText(String, Encoding, Int32) |

See Also

IContentAdapter Interface
IContentAdapter Members
Mincom.LinkOne.Adapter Namespace


ReadAllText Method (String)

[image]

LinkOne WebView API
IContentAdapter..::.ReadAllText Method (String)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
string ReadAllText(
    string path
)
Visual Basic (Declaration)
Function ReadAllText ( _
    path As String _
) As String
Visual C++
String^ ReadAllText(
    String^ path
)

Parameters

path
Type: System..::.String

See Also

IContentAdapter Interface
ReadAllText Overload
Mincom.LinkOne.Adapter Namespace


ReadAllText Method (String, Int32)

[image]

LinkOne WebView API
IContentAdapter..::.ReadAllText Method (String, Int32)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
string ReadAllText(
    string path,
    int retryMilliseconds
)
Visual Basic (Declaration)
Function ReadAllText ( _
    path As String, _
    retryMilliseconds As Integer _
) As String
Visual C++
String^ ReadAllText(
    String^ path,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
retryMilliseconds
Type: System..::.Int32

See Also

IContentAdapter Interface
ReadAllText Overload
Mincom.LinkOne.Adapter Namespace


ReadAllText Method (String, Encoding)

[image]

LinkOne WebView API
IContentAdapter..::.ReadAllText Method (String, Encoding)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
string ReadAllText(
    string path,
    Encoding encoding
)
Visual Basic (Declaration)
Function ReadAllText ( _
    path As String, _
    encoding As Encoding _
) As String
Visual C++
String^ ReadAllText(
    String^ path,
    Encoding^ encoding
)

Parameters

path
Type: System..::.String
encoding
Type: System.Text..::.Encoding

See Also

IContentAdapter Interface
ReadAllText Overload
Mincom.LinkOne.Adapter Namespace


ReadAllText Method (String, Encoding, Int32)

[image]

LinkOne WebView API
IContentAdapter..::.ReadAllText Method (String, Encoding, Int32)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
string ReadAllText(
    string path,
    Encoding encoding,
    int retryMilliseconds
)
Visual Basic (Declaration)
Function ReadAllText ( _
    path As String, _
    encoding As Encoding, _
    retryMilliseconds As Integer _
) As String
Visual C++
String^ ReadAllText(
    String^ path,
    Encoding^ encoding,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
encoding
Type: System.Text..::.Encoding
retryMilliseconds
Type: System..::.Int32

See Also

IContentAdapter Interface
ReadAllText Overload
Mincom.LinkOne.Adapter Namespace


ReadLine Method

[image]

LinkOne WebView API
IContentAdapter..::.ReadLine Method
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
string ReadLine(
    TextReader reader
)
Visual Basic (Declaration)
Function ReadLine ( _
    reader As TextReader _
) As String
Visual C++
String^ ReadLine(
    TextReader^ reader
)

Parameters

reader
Type: System.IO..::.TextReader

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


ReadToEnd Method

[image]

LinkOne WebView API
IContentAdapter..::.ReadToEnd Method
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
string ReadToEnd(
    TextReader reader
)
Visual Basic (Declaration)
Function ReadToEnd ( _
    reader As TextReader _
) As String
Visual C++
String^ ReadToEnd(
    TextReader^ reader
)

Parameters

reader
Type: System.IO..::.TextReader

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


Seek Method

[image]

LinkOne WebView API
IContentAdapter..::.Seek Method
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
long Seek(
    Stream stream,
    long offset,
    SeekOrigin origin
)
Visual Basic (Declaration)
Function Seek ( _
    stream As Stream, _
    offset As Long, _
    origin As SeekOrigin _
) As Long
Visual C++
long long Seek(
    Stream^ stream,
    long long offset,
    SeekOrigin origin
)

Parameters

stream
Type: System.IO..::.Stream
offset
Type: System..::.Int64
origin
Type: System.IO..::.SeekOrigin

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


SetAttributes Method

[image]

LinkOne WebView API
IContentAdapter..::.SetAttributes Method
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
void SetAttributes(
    string path,
    FileAttributes fileAttributes
)
Visual Basic (Declaration)
Sub SetAttributes ( _
    path As String, _
    fileAttributes As FileAttributes _
)
Visual C++
void SetAttributes(
    String^ path,
    FileAttributes fileAttributes
)

Parameters

path
Type: System..::.String
fileAttributes
Type: System.IO..::.FileAttributes

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


SetLastWriteTime Method

[image] [image]

LinkOne WebView API
IContentAdapter..::.SetLastWriteTime Method
IContentAdapter Interface See Also Send Feedback

Overload List

Name | Description
SetLastWriteTime(String, DateTime) |
SetLastWriteTime(String, DateTime, Int32) |

See Also

IContentAdapter Interface
IContentAdapter Members
Mincom.LinkOne.Adapter Namespace


SetLastWriteTime Method (String, DateTime)

[image]

LinkOne WebView API
IContentAdapter..::.SetLastWriteTime Method (String, DateTime)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
void SetLastWriteTime(
    string fileName,
    DateTime dateTime
)
Visual Basic (Declaration)
Sub SetLastWriteTime ( _
    fileName As String, _
    dateTime As DateTime _
)
Visual C++
void SetLastWriteTime(
    String^ fileName,
    DateTime dateTime
)

Parameters

fileName
Type: System..::.String
dateTime
Type: System..::.DateTime

See Also

IContentAdapter Interface
SetLastWriteTime Overload
Mincom.LinkOne.Adapter Namespace


SetLastWriteTime Method (String, DateTime, Int32)

[image]

LinkOne WebView API
IContentAdapter..::.SetLastWriteTime Method (String, DateTime, Int32)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
void SetLastWriteTime(
    string fileName,
    DateTime dateTime,
    int retryMilliseconds
)
Visual Basic (Declaration)
Sub SetLastWriteTime ( _
    fileName As String, _
    dateTime As DateTime, _
    retryMilliseconds As Integer _
)
Visual C++
void SetLastWriteTime(
    String^ fileName,
    DateTime dateTime,
    int retryMilliseconds
)

Parameters

fileName
Type: System..::.String
dateTime
Type: System..::.DateTime
retryMilliseconds
Type: System..::.Int32

See Also

IContentAdapter Interface
SetLastWriteTime Overload
Mincom.LinkOne.Adapter Namespace


SetLastWriteTimeUtc Method

[image] [image]

LinkOne WebView API
IContentAdapter..::.SetLastWriteTimeUtc Method
IContentAdapter Interface See Also Send Feedback

Overload List

Name | Description
SetLastWriteTimeUtc(String, DateTime) |
SetLastWriteTimeUtc(String, DateTime, Int32) |

See Also

IContentAdapter Interface
IContentAdapter Members
Mincom.LinkOne.Adapter Namespace


SetLastWriteTimeUtc Method (String, DateTime)

[image]

LinkOne WebView API
IContentAdapter..::.SetLastWriteTimeUtc Method (String, DateTime)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
void SetLastWriteTimeUtc(
    string path,
    DateTime dateTime
)
Visual Basic (Declaration)
Sub SetLastWriteTimeUtc ( _
    path As String, _
    dateTime As DateTime _
)
Visual C++
void SetLastWriteTimeUtc(
    String^ path,
    DateTime dateTime
)

Parameters

path
Type: System..::.String
dateTime
Type: System..::.DateTime

See Also

IContentAdapter Interface
SetLastWriteTimeUtc Overload
Mincom.LinkOne.Adapter Namespace


SetLastWriteTimeUtc Method (String, DateTime, Int32)

[image]

LinkOne WebView API
IContentAdapter..::.SetLastWriteTimeUtc Method (String, DateTime, Int32)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
void SetLastWriteTimeUtc(
    string path,
    DateTime dateTime,
    int retryMilliseconds
)
Visual Basic (Declaration)
Sub SetLastWriteTimeUtc ( _
    path As String, _
    dateTime As DateTime, _
    retryMilliseconds As Integer _
)
Visual C++
void SetLastWriteTimeUtc(
    String^ path,
    DateTime dateTime,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
dateTime
Type: System..::.DateTime
retryMilliseconds
Type: System..::.Int32

See Also

IContentAdapter Interface
SetLastWriteTimeUtc Overload
Mincom.LinkOne.Adapter Namespace


SetLength Method

[image]

LinkOne WebView API
IContentAdapter..::.SetLength Method
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
void SetLength(
    Stream stream,
    long value
)
Visual Basic (Declaration)
Sub SetLength ( _
    stream As Stream, _
    value As Long _
)
Visual C++
void SetLength(
    Stream^ stream,
    long long value
)

Parameters

stream
Type: System.IO..::.Stream
value
Type: System..::.Int64

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


ValidateTimeStamp Method

[image]

LinkOne WebView API
IContentAdapter..::.ValidateTimeStamp Method
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
bool ValidateTimeStamp(
    string path
)
Visual Basic (Declaration)
Function ValidateTimeStamp ( _
    path As String _
) As Boolean
Visual C++
bool ValidateTimeStamp(
    String^ path
)

Parameters

path
Type: System..::.String

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


Write Method

[image]

LinkOne WebView API
IContentAdapter..::.Write Method
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
void Write(
    TextWriter writer,
    string contents
)
Visual Basic (Declaration)
Sub Write ( _
    writer As TextWriter, _
    contents As String _
)
Visual C++
void Write(
    TextWriter^ writer,
    String^ contents
)

Parameters

writer
Type: System.IO..::.TextWriter
contents
Type: System..::.String

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


WriteAllBytes Method

[image] [image]

LinkOne WebView API
IContentAdapter..::.WriteAllBytes Method
IContentAdapter Interface See Also Send Feedback

Overload List

Name | Description
WriteAllBytes(String, array<Byte>[]()[]) |
WriteAllBytes(String, array<Byte>[]()[], Nullable<(Of <(DateTime>)>), Int32) |

See Also

IContentAdapter Interface
IContentAdapter Members
Mincom.LinkOne.Adapter Namespace


WriteAllBytes Method (String, Byte[])

[image]

LinkOne WebView API
IContentAdapter..::.WriteAllBytes Method (String, array<Byte>[]()[])
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
void WriteAllBytes(
    string path,
    byte[] bytes
)
Visual Basic (Declaration)
Sub WriteAllBytes ( _
    path As String, _
    bytes As Byte() _
)
Visual C++
void WriteAllBytes(
    String^ path,
    array<unsigned char>^ bytes
)

Parameters

path
Type: System..::.String
bytes
Type: array< System..::.Byte >[]()[]

See Also

IContentAdapter Interface
WriteAllBytes Overload
Mincom.LinkOne.Adapter Namespace


WriteAllBytes Method (String, Byte[], Nullable(DateTime), Int32)

[image]

LinkOne WebView API
IContentAdapter..::.WriteAllBytes Method (String, array<Byte>[]()[], Nullable<(Of <(DateTime>)>), Int32)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
void WriteAllBytes(
    string path,
    byte[] bytes,
    Nullable<DateTime> lastModifiedTime,
    int retryMilliseconds
)
Visual Basic (Declaration)
Sub WriteAllBytes ( _
    path As String, _
    bytes As Byte(), _
    lastModifiedTime As Nullable(Of DateTime), _
    retryMilliseconds As Integer _
)
Visual C++
void WriteAllBytes(
    String^ path,
    array<unsigned char>^ bytes,
    Nullable<DateTime> lastModifiedTime,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
bytes
Type: array< System..::.Byte >[]()[]
lastModifiedTime
Type: System..::.Nullable<(Of <(DateTime>)>)
retryMilliseconds
Type: System..::.Int32

See Also

IContentAdapter Interface
WriteAllBytes Overload
Mincom.LinkOne.Adapter Namespace


WriteAllText Method

[image] [image]

LinkOne WebView API
IContentAdapter..::.WriteAllText Method
IContentAdapter Interface See Also Send Feedback

Overload List

Name | Description
WriteAllText(String, String, Encoding) |
WriteAllText(String, String, Encoding, Int32) |

See Also

IContentAdapter Interface
IContentAdapter Members
Mincom.LinkOne.Adapter Namespace


WriteAllText Method (String, String, Encoding)

[image]

LinkOne WebView API
IContentAdapter..::.WriteAllText Method (String, String, Encoding)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
void WriteAllText(
    string path,
    string contents,
    Encoding encoding
)
Visual Basic (Declaration)
Sub WriteAllText ( _
    path As String, _
    contents As String, _
    encoding As Encoding _
)
Visual C++
void WriteAllText(
    String^ path,
    String^ contents,
    Encoding^ encoding
)

Parameters

path
Type: System..::.String
contents
Type: System..::.String
encoding
Type: System.Text..::.Encoding

See Also

IContentAdapter Interface
WriteAllText Overload
Mincom.LinkOne.Adapter Namespace


WriteAllText Method (String, String, Encoding, Int32)

[image]

LinkOne WebView API
IContentAdapter..::.WriteAllText Method (String, String, Encoding, Int32)
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
void WriteAllText(
    string path,
    string contents,
    Encoding encoding,
    int retryMilliseconds
)
Visual Basic (Declaration)
Sub WriteAllText ( _
    path As String, _
    contents As String, _
    encoding As Encoding, _
    retryMilliseconds As Integer _
)
Visual C++
void WriteAllText(
    String^ path,
    String^ contents,
    Encoding^ encoding,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
contents
Type: System..::.String
encoding
Type: System.Text..::.Encoding
retryMilliseconds
Type: System..::.Int32

See Also

IContentAdapter Interface
WriteAllText Overload
Mincom.LinkOne.Adapter Namespace


WriteLine Method

[image]

LinkOne WebView API
IContentAdapter..::.WriteLine Method
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
void WriteLine(
    TextWriter writer,
    string contents
)
Visual Basic (Declaration)
Sub WriteLine ( _
    writer As TextWriter, _
    contents As String _
)
Visual C++
void WriteLine(
    TextWriter^ writer,
    String^ contents
)

Parameters

writer
Type: System.IO..::.TextWriter
contents
Type: System..::.String

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


IContentAdapter Properties

[image] [image]

LinkOne WebView API
IContentAdapter Properties
IContentAdapter Interface See Also Send Feedback

The IContentAdapter type exposes the following members.

Properties

Name | Description
MinimumFileDateTime |

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


MinimumFileDateTime Property

[image]

LinkOne WebView API
IContentAdapter..::.MinimumFileDateTime Property
IContentAdapter Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
DateTime MinimumFileDateTime { get; }
Visual Basic (Declaration)
ReadOnly Property MinimumFileDateTime As DateTime
Visual C++
property DateTime MinimumFileDateTime {
    DateTime get ();
}

See Also

IContentAdapter Interface
Mincom.LinkOne.Adapter Namespace


Tracing Class

[image]

LinkOne WebView API
Tracing Class
Members See Also Send Feedback
Trace switch for the assembly.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public static class Tracing
Visual Basic (Declaration)
Public NotInheritable Class Tracing
Visual C++
public ref class Tracing abstract sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Adapter..::.Tracing

See Also

Tracing Members
Mincom.LinkOne.Adapter Namespace


Tracing Members

[image] [image]

LinkOne WebView API
Tracing Members
Tracing Class Fields See Also Send Feedback

The Tracing type exposes the following members.

Fields

Name | Description
TraceSwitch | Trace switch for the assembly.

See Also

Tracing Class
Mincom.LinkOne.Adapter Namespace


Tracing Fields

[image] [image]

LinkOne WebView API
Tracing Fields
Tracing Class See Also Send Feedback

The Tracing type exposes the following members.

Fields

Name | Description
TraceSwitch | Trace switch for the assembly.

See Also

Tracing Class
Mincom.LinkOne.Adapter Namespace


TraceSwitch Field

[image]

LinkOne WebView API
Tracing..::.TraceSwitch Field
Tracing Class See Also Send Feedback
Trace switch for the assembly.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public static readonly TraceSwitch TraceSwitch
Visual Basic (Declaration)
Public Shared ReadOnly TraceSwitch As TraceSwitch
Visual C++
public:
static initonly TraceSwitch^ TraceSwitch

Remarks

Enable by:
CopyC#
<configuration>
    <system.diagnostics>
        <switches>
            <add name="Mincom.LinkOne.Adapter" value="Info"/>
        <switches/>
    <system.diagnostics/>
<configuration/>

See Also

Tracing Class
Mincom.LinkOne.Adapter Namespace


Utility Class

[image]

LinkOne WebView API
Utility Class
Members See Also Send Feedback
Contains common utility functions for implementing the ICmsService interface.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public class Utility
Visual Basic (Declaration)
Public Class Utility
Visual C++
public ref class Utility

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Adapter..::.Utility

See Also

Utility Members
Mincom.LinkOne.Adapter Namespace


Utility Members

[image] [image]

LinkOne WebView API
Utility Members
Utility Class Constructors Methods Fields See Also Send Feedback

The Utility type exposes the following members.

Constructors

Name | Description
Utility | Initializes a new instance of the Utility class

Methods

Name | Description
DecodeReferencePath | Overloaded.
EncodeReferencePath | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
EncodingDelimiter | The character used to separate entries for encoding/decoding reference paths.
ServiceNamespace | Identifies the namespace containing ICmsService, not its implementations.

See Also

Utility Class
Mincom.LinkOne.Adapter Namespace


Utility Constructor

[image]

LinkOne WebView API
Utility Constructor
Utility Class See Also Send Feedback
Initializes a new instance of the Utility class

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public Utility()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Utility()

See Also

Utility Class
Mincom.LinkOne.Adapter Namespace


Utility Fields

[image] [image]

LinkOne WebView API
Utility Fields
Utility Class See Also Send Feedback

The Utility type exposes the following members.

Fields

Name | Description
EncodingDelimiter | The character used to separate entries for encoding/decoding reference paths.
ServiceNamespace | Identifies the namespace containing ICmsService, not its implementations.

See Also

Utility Class
Mincom.LinkOne.Adapter Namespace


EncodingDelimiter Field

[image]

LinkOne WebView API
Utility..::.EncodingDelimiter Field
Utility Class See Also Send Feedback
The character used to separate entries for encoding/decoding reference paths.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public const char EncodingDelimiter
Visual Basic (Declaration)
Public Const EncodingDelimiter As Char
Visual C++
public:
literal wchar_t EncodingDelimiter

See Also

Utility Class
Mincom.LinkOne.Adapter Namespace


ServiceNamespace Field

[image]

LinkOne WebView API
Utility..::.ServiceNamespace Field
Utility Class See Also Send Feedback
Identifies the namespace containing ICmsService, not its implementations.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public const string ServiceNamespace
Visual Basic (Declaration)
Public Const ServiceNamespace As String
Visual C++
public:
literal String^ ServiceNamespace

Remarks

Used with .Net attributes. Should not otherwise be required.

See Also

Utility Class
Mincom.LinkOne.Adapter Namespace


Utility Methods

[image] [image]

LinkOne WebView API
Utility Methods
Utility Class See Also Send Feedback

The Utility type exposes the following members.

Methods

Name | Description
DecodeReferencePath | Overloaded.
EncodeReferencePath | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Utility Class
Mincom.LinkOne.Adapter Namespace


DecodeReferencePath Method

[image] [image]

LinkOne WebView API
Utility..::.DecodeReferencePath Method
Utility Class See Also Send Feedback

Overload List

Name | Description
DecodeReferencePath(String, String%) | Extracts the publisher code from a reference path used in requests made to the ICmsService.
DecodeReferencePath(String, String%, String%) | Extracts the publisher code and book code from a reference path used in requests made to the ICmsService.
DecodeReferencePath(String, String%, String%, String%) | Decodes a reference path used in ICmsService requests into a publisher code, book code and page reference.

See Also

Utility Class
Utility Members
Mincom.LinkOne.Adapter Namespace


DecodeReferencePath Method (String, String)

[image]

LinkOne WebView API
Utility..::.DecodeReferencePath Method (String, String%)
Utility Class See Also Send Feedback
Extracts the publisher code from a reference path used in requests made to the ICmsService.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public static void DecodeReferencePath(
    string referencePath,
    out string publisherCode
)
Visual Basic (Declaration)
Public Shared Sub DecodeReferencePath ( _
    referencePath As String, _
    <OutAttribute> ByRef publisherCode As String _
)
Visual C++
public:
static void DecodeReferencePath(
    String^ referencePath,
    [OutAttribute] String^% publisherCode
)

Parameters

referencePath
Type: System..::.String
The reference path given to the ICmsService. See DecodeReferencePath(String, String%, String%, String%) for details of the expected format.
publisherCode
Type: System..::.String %
The extracted publisher code available here after calling this method.

See Also

Utility Class
DecodeReferencePath Overload
Mincom.LinkOne.Adapter Namespace
Utility..::.DecodeReferencePath(String, String%, String%, String%)


DecodeReferencePath Method (String, String, String)

[image]

LinkOne WebView API
Utility..::.DecodeReferencePath Method (String, String%, String%)
Utility Class See Also Send Feedback
Extracts the publisher code and book code from a reference path used in requests made to the ICmsService.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public static void DecodeReferencePath(
    string referencePath,
    out string publisherCode,
    out string bookCode
)
Visual Basic (Declaration)
Public Shared Sub DecodeReferencePath ( _
    referencePath As String, _
    <OutAttribute> ByRef publisherCode As String, _
    <OutAttribute> ByRef bookCode As String _
)
Visual C++
public:
static void DecodeReferencePath(
    String^ referencePath,
    [OutAttribute] String^% publisherCode,
    [OutAttribute] String^% bookCode
)

Parameters

referencePath
Type: System..::.String
The reference path given to the ICmsService. See DecodeReferencePath(String, String%, String%, String%) for details of the expected format.
publisherCode
Type: System..::.String %
The extracted publisher code available here after calling this method.
bookCode
Type: System..::.String %
The extracted book code available here after calling this method.

See Also

Utility Class
DecodeReferencePath Overload
Mincom.LinkOne.Adapter Namespace
Utility..::.DecodeReferencePath(String, String%, String%, String%)


DecodeReferencePath Method (String, String, String, String)

[image]

LinkOne WebView API
Utility..::.DecodeReferencePath Method (String, String%, String%, String%)
Utility Class See Also Send Feedback
Decodes a reference path used in ICmsService requests into a publisher code, book code and page reference.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public static void DecodeReferencePath(
    string referencePath,
    out string publisherCode,
    out string bookCode,
    out string pageReference
)
Visual Basic (Declaration)
Public Shared Sub DecodeReferencePath ( _
    referencePath As String, _
    <OutAttribute> ByRef publisherCode As String, _
    <OutAttribute> ByRef bookCode As String, _
    <OutAttribute> ByRef pageReference As String _
)
Visual C++
public:
static void DecodeReferencePath(
    String^ referencePath,
    [OutAttribute] String^% publisherCode,
    [OutAttribute] String^% bookCode,
    [OutAttribute] String^% pageReference
)

Parameters

referencePath
Type: System..::.String
The reference path given to the ICmsService. See remarks.
publisherCode
Type: System..::.String %
The extracted publisher code available here after calling this method.
bookCode
Type: System..::.String %
The extracted book code available here after calling this method.
pageReference
Type: System..::.String %
The extracted page reference available here after calling this method.

Remarks

The referencePath is expected to be in the following format: "PublisherCode.BookCode.PageReference" (without quotes). The book code and publisher code components are optional. However, a book code must be specified before a page reference can be specified.

The publisherCode will only be null or empty if referencePath is also null or empty. The bookCode will be null if no book code can be extract. Similarly, the pageReference will only be null if a page reference cannot be extracted.

Note: The [!:pageReference] may actually contain the '.' character, whereas neither the publisherCode, not the bookCode may. This is consistent with LinkOne restrictions on these values. However, no error checking is performed on decoded values.

See Also

Utility Class
DecodeReferencePath Overload
Mincom.LinkOne.Adapter Namespace
Utility..::.DecodeReferencePath(String, String%, String%, String%)


EncodeReferencePath Method

[image] [image]

LinkOne WebView API
Utility..::.EncodeReferencePath Method
Utility Class See Also Send Feedback

Overload List

Name | Description
EncodeReferencePath(String) | Encodes a reference path with just the publisher code.
EncodeReferencePath(String, String) | Encodes a reference path using the given publisher and book codes.
EncodeReferencePath(String, String, String) | Encodes a reference path using the given publisher and book codes.

See Also

Utility Class
Utility Members
Mincom.LinkOne.Adapter Namespace


EncodeReferencePath Method (String)

[image]

LinkOne WebView API
Utility..::.EncodeReferencePath Method (String)
Utility Class See Also Send Feedback
Encodes a reference path with just the publisher code.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public static string EncodeReferencePath(
    string publisherCode
)
Visual Basic (Declaration)
Public Shared Function EncodeReferencePath ( _
    publisherCode As String _
) As String
Visual C++
public:
static String^ EncodeReferencePath(
    String^ publisherCode
)

Parameters

publisherCode
Type: System..::.String
The publisher code. Should not be null or empty, but this is not enforced.

Return Value

A string exactly matching publisherCode.

See Also

Utility Class
EncodeReferencePath Overload
Mincom.LinkOne.Adapter Namespace


EncodeReferencePath Method (String, String)

[image]

LinkOne WebView API
Utility..::.EncodeReferencePath Method (String, String)
Utility Class See Also Send Feedback
Encodes a reference path using the given publisher and book codes.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public static string EncodeReferencePath(
    string publisherCode,
    string bookCode
)
Visual Basic (Declaration)
Public Shared Function EncodeReferencePath ( _
    publisherCode As String, _
    bookCode As String _
) As String
Visual C++
public:
static String^ EncodeReferencePath(
    String^ publisherCode,
    String^ bookCode
)

Parameters

publisherCode
Type: System..::.String
The publisher code. Should not be null or empty, but this is not enforced.
bookCode
Type: System..::.String
The book code. Should not be null or empty, but this is not enforced.

Return Value

A string formated: "<publisherCode>.<bookCode>" provided neither is null or empty.

See Also

Utility Class
EncodeReferencePath Overload
Mincom.LinkOne.Adapter Namespace


EncodeReferencePath Method (String, String, String)

[image]

LinkOne WebView API
Utility..::.EncodeReferencePath Method (String, String, String)
Utility Class See Also Send Feedback
Encodes a reference path using the given publisher and book codes.

Namespace: Mincom.LinkOne.Adapter
Assembly: Mincom.LinkOne.Adapter (in Mincom.LinkOne.Adapter.dll) Version: 3.58.5361.0

Syntax

C#
public static string EncodeReferencePath(
    string publisherCode,
    string bookCode,
    string pageReference
)
Visual Basic (Declaration)
Public Shared Function EncodeReferencePath ( _
    publisherCode As String, _
    bookCode As String, _
    pageReference As String _
) As String
Visual C++
public:
static String^ EncodeReferencePath(
    String^ publisherCode,
    String^ bookCode,
    String^ pageReference
)

Parameters

publisherCode
Type: System..::.String
The publisher code to encode.
bookCode
Type: System..::.String
The book code to encode.
pageReference
Type: System..::.String
The page reference to encode.

Return Value

A string encoded with the given details. See remarks.

Remarks

Encoding follows the rules oulined below.
Conditions | Result
All parameters not null and not empty | "<publisherCode>.<bookCode>.<pageReference>"
Only pageReference is null or is empty | "<publisherCode>.<bookCode>"
Only publisherCode is not null and not empty | "<publisherCode>"
Other | Indeterminate. This is not valid and not explictly handled.

See Also

Utility Class
EncodeReferencePath Overload
Mincom.LinkOne.Adapter Namespace


Mincom.LinkOne.Collections Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.Collections Namespace
Send Feedback
The Mincom.LinkOne.Collections namespace contains classes that define the behaviour for collections of objects in the LinkOne framework. It also provides some helper classes for performing common operations on sets of data.

Interfaces

Interface | Description
IKeyedCollection<(Of <(TKey, TItem>)>) | Represents a collection of objects whose keys are embedded in the values.
IReadOnlyCollection<(Of <(T>)>) | Defines a simple read-only collection of objects.
IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>) | Represents a read-only collection of objects whose keys are embedded in the values.
IReadOnlyList<(Of <(T>)>) | Extends IReadOnlyCollection by providing access to objects by index.


IKeyedCollection(TKey, TItem) Interface

[image]

LinkOne WebView API
IKeyedCollection<(Of <(TKey, TItem>)>) Interface
Members See Also Send Feedback
Represents a collection of objects whose keys are embedded in the values.

Namespace: Mincom.LinkOne.Collections
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IKeyedCollection<TKey, TItem> : ICollection<TItem>,
    IEnumerable<TItem>, IEnumerable
Visual Basic (Declaration)
Public Interface IKeyedCollection(Of TKey, TItem) _
    Implements ICollection(Of TItem), IEnumerable(Of TItem),  _
    IEnumerable
Visual C++
generic<typename TKey, typename TItem>
public interface class IKeyedCollection : ICollection<TItem>,
    IEnumerable<TItem>, IEnumerable

Type Parameters

TKey
The type of the item key.
TItem
The type of items contained.

Remarks

The primary criteria for choosing to implement this interface is whether you can provide efficient retrieval of objects via the key.

See Also

IKeyedCollection<(Of <(TKey, TItem>)>) Members
Mincom.LinkOne.Collections Namespace


IKeyedCollection(TKey, TItem) Members

[image] [image]

LinkOne WebView API
IKeyedCollection<(Of <(TKey, TItem>)>) Members
IKeyedCollection<(Of <(TKey, TItem>)>) Interface Methods Properties See Also Send Feedback

The IKeyedCollection<(Of <(TKey, TItem>)>) type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( TItem >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( TItem >)>).)
Contains | Overloaded.
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( TItem >)>).)
GetEnumerator | Overloaded.
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( TItem >)>).)

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( TItem >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( TItem >)>).)
Item | Gets or sets the item with the specified key.

See Also

IKeyedCollection<(Of <(TKey, TItem>)>) Interface
Mincom.LinkOne.Collections Namespace


IKeyedCollection(TKey, TItem) Methods

[image] [image]

LinkOne WebView API
IKeyedCollection<(Of <(TKey, TItem>)>) Methods
IKeyedCollection<(Of <(TKey, TItem>)>) Interface See Also Send Feedback

The IKeyedCollection<(Of <(TKey, TItem>)>) type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( TItem >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( TItem >)>).)
Contains | Overloaded.
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( TItem >)>).)
GetEnumerator | Overloaded.
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( TItem >)>).)

See Also

IKeyedCollection<(Of <(TKey, TItem>)>) Interface
Mincom.LinkOne.Collections Namespace


Contains Method

[image] [image]

LinkOne WebView API
IKeyedCollection<(Of <(TKey, TItem>)>)..::.Contains Method
IKeyedCollection<(Of <(TKey, TItem>)>) Interface See Also Send Feedback

Overload List

Name | Description
Contains(T) | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from ICollection<(Of <( TItem >)>).)
Contains(TKey) | Determines whether an element with the given key is in the collection.

See Also

IKeyedCollection<(Of <(TKey, TItem>)>) Interface
IKeyedCollection<(Of <(TKey, TItem>)>) Members
Mincom.LinkOne.Collections Namespace


Contains Method (TKey)

[image]

LinkOne WebView API
IKeyedCollection<(Of <(TKey, TItem>)>)..::.Contains Method (TKey)
IKeyedCollection<(Of <(TKey, TItem>)>) Interface See Also Send Feedback
Determines whether an element with the given key is in the collection.

Namespace: Mincom.LinkOne.Collections
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool Contains(
    TKey key
)
Visual Basic (Declaration)
Function Contains ( _
    key As TKey _
) As Boolean
Visual C++
bool Contains(
    TKey key
)

Parameters

key
Type: TKey
The key of the item to search for.

Return Value

true if an object with the given key is found in the collection, otherwise, false.

See Also

IKeyedCollection<(Of <(TKey, TItem>)>) Interface
Contains Overload
Mincom.LinkOne.Collections Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
IKeyedCollection<(Of <(TKey, TItem>)>)..::.GetEnumerator Method
IKeyedCollection<(Of <(TKey, TItem>)>) Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( TItem >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IKeyedCollection<(Of <(TKey, TItem>)>) Interface
IKeyedCollection<(Of <(TKey, TItem>)>) Members
Mincom.LinkOne.Collections Namespace


IKeyedCollection(TKey, TItem) Properties

[image] [image]

LinkOne WebView API
IKeyedCollection<(Of <(TKey, TItem>)>) Properties
IKeyedCollection<(Of <(TKey, TItem>)>) Interface See Also Send Feedback

The IKeyedCollection<(Of <(TKey, TItem>)>) type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( TItem >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( TItem >)>).)
Item | Gets or sets the item with the specified key.

See Also

IKeyedCollection<(Of <(TKey, TItem>)>) Interface
Mincom.LinkOne.Collections Namespace


Item Property

[image]

LinkOne WebView API
IKeyedCollection<(Of <(TKey, TItem>)>)..::.Item Property
IKeyedCollection<(Of <(TKey, TItem>)>) Interface See Also Send Feedback
Gets or sets the item with the specified key.

Namespace: Mincom.LinkOne.Collections
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
TItem this[
    TKey key
] { get; set; }
Visual Basic (Declaration)
Default Property Item ( _
    key As TKey _
) As TItem
Visual C++
property TItem default[TKey key] {
    TItem get (TKey key);
    void set (TKey key, TItem value);
}

Parameters

key
Type: TKey

Exceptions

Exception | Condition
System..::.ArgumentException | The key is not valid for the object.
System..::.NotSupportedException | The collection is read-only, see ICollection.

See Also

IKeyedCollection<(Of <(TKey, TItem>)>) Interface
Mincom.LinkOne.Collections Namespace


IReadOnlyCollection(T) Interface

[image]

LinkOne WebView API
IReadOnlyCollection<(Of <(T>)>) Interface
Members See Also Send Feedback
Defines a simple read-only collection of objects.

Namespace: Mincom.LinkOne.Collections
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IReadOnlyCollection<T> : IEnumerable<T>,
    IEnumerable
Visual Basic (Declaration)
Public Interface IReadOnlyCollection(Of T) _
    Implements IEnumerable(Of T), IEnumerable
Visual C++
generic<typename T>
public interface class IReadOnlyCollection : IEnumerable<T>,
    IEnumerable

Type Parameters

T
The type of the items contained.

See Also

IReadOnlyCollection<(Of <(T>)>) Members
Mincom.LinkOne.Collections Namespace


IReadOnlyCollection(T) Members

[image] [image]

LinkOne WebView API
IReadOnlyCollection<(Of <(T>)>) Members
IReadOnlyCollection<(Of <(T>)>) Interface Methods Properties See Also Send Feedback

The IReadOnlyCollection<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection.
GetEnumerator | Overloaded.

Properties

Name | Description
Count | Gets the number of elements in the collection.

See Also

IReadOnlyCollection<(Of <(T>)>) Interface
Mincom.LinkOne.Collections Namespace


IReadOnlyCollection(T) Methods

[image] [image]

LinkOne WebView API
IReadOnlyCollection<(Of <(T>)>) Methods
IReadOnlyCollection<(Of <(T>)>) Interface See Also Send Feedback

The IReadOnlyCollection<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection.
GetEnumerator | Overloaded.

See Also

IReadOnlyCollection<(Of <(T>)>) Interface
Mincom.LinkOne.Collections Namespace


Contains Method

[image]

LinkOne WebView API
IReadOnlyCollection<(Of <(T>)>)..::.Contains Method
IReadOnlyCollection<(Of <(T>)>) Interface See Also Send Feedback
Determines whether an element is in the collection.

Namespace: Mincom.LinkOne.Collections
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool Contains(
    T item
)
Visual Basic (Declaration)
Function Contains ( _
    item As T _
) As Boolean
Visual C++
bool Contains(
    T item
)

Parameters

item
Type: T
The item to search for.

Return Value

true if found in the collection, otherwise, false.

See Also

IReadOnlyCollection<(Of <(T>)>) Interface
Mincom.LinkOne.Collections Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
IReadOnlyCollection<(Of <(T>)>)..::.GetEnumerator Method
IReadOnlyCollection<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( T >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IReadOnlyCollection<(Of <(T>)>) Interface
IReadOnlyCollection<(Of <(T>)>) Members
Mincom.LinkOne.Collections Namespace


IReadOnlyCollection(T) Properties

[image] [image]

LinkOne WebView API
IReadOnlyCollection<(Of <(T>)>) Properties
IReadOnlyCollection<(Of <(T>)>) Interface See Also Send Feedback

The IReadOnlyCollection<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection.

See Also

IReadOnlyCollection<(Of <(T>)>) Interface
Mincom.LinkOne.Collections Namespace


Count Property

[image]

LinkOne WebView API
IReadOnlyCollection<(Of <(T>)>)..::.Count Property
IReadOnlyCollection<(Of <(T>)>) Interface See Also Send Feedback
Gets the number of elements in the collection.

Namespace: Mincom.LinkOne.Collections
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int Count { get; }
Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual C++
property int Count {
    int get ();
}

See Also

IReadOnlyCollection<(Of <(T>)>) Interface
Mincom.LinkOne.Collections Namespace


IReadOnlyKeyedCollection(TKey, TItem) Interface

[image]

LinkOne WebView API
IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>) Interface
Members See Also Send Feedback
Represents a read-only collection of objects whose keys are embedded in the values.

Namespace: Mincom.LinkOne.Collections
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IReadOnlyKeyedCollection<TKey, TItem> : IReadOnlyCollection<TItem>,
    IEnumerable<TItem>, IEnumerable
Visual Basic (Declaration)
Public Interface IReadOnlyKeyedCollection(Of TKey, TItem) _
    Implements IReadOnlyCollection(Of TItem), IEnumerable(Of TItem),  _
    IEnumerable
Visual C++
generic<typename TKey, typename TItem>
public interface class IReadOnlyKeyedCollection : IReadOnlyCollection<TItem>,
    IEnumerable<TItem>, IEnumerable

Type Parameters

TKey
The type of the item key.
TItem
The type of items contained.

Remarks

The primary criteria for choosing to implement this interface is whether you can provide efficient retrieval of items via the key.

See Also

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>) Members
Mincom.LinkOne.Collections Namespace


IReadOnlyKeyedCollection(TKey, TItem) Members

[image] [image]

LinkOne WebView API
IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>) Members
IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>) Interface Methods Properties See Also Send Feedback

The IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>) type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
GetEnumerator | Overloaded.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item with the specified key.

See Also

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>) Interface
Mincom.LinkOne.Collections Namespace


IReadOnlyKeyedCollection(TKey, TItem) Methods

[image] [image]

LinkOne WebView API
IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>) Methods
IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>) Interface See Also Send Feedback

Methods

Name | Description
Contains | Overloaded.
GetEnumerator | Overloaded.

See Also

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>) Interface
Mincom.LinkOne.Collections Namespace


Contains Method

[image] [image]

LinkOne WebView API
IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Contains Method
IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>) Interface See Also Send Feedback

Overload List

Name | Description
Contains(T) | Determines whether an element is in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Contains(TKey) | Determines whether an element with the given key is in the collection.

See Also

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>) Interface
IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>) Members
Mincom.LinkOne.Collections Namespace


Contains Method (TKey)

[image]

LinkOne WebView API
IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Contains Method (TKey)
IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>) Interface See Also Send Feedback
Determines whether an element with the given key is in the collection.

Namespace: Mincom.LinkOne.Collections
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool Contains(
    TKey key
)
Visual Basic (Declaration)
Function Contains ( _
    key As TKey _
) As Boolean
Visual C++
bool Contains(
    TKey key
)

Parameters

key
Type: TKey
The key of the item to search for.

Return Value

true if an item with the given key is found in the collection, otherwise, false.

See Also

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>) Interface
Contains Overload
Mincom.LinkOne.Collections Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.GetEnumerator Method
IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>) Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( TItem >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>) Interface
IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>) Members
Mincom.LinkOne.Collections Namespace


IReadOnlyKeyedCollection(TKey, TItem) Properties

[image] [image]

LinkOne WebView API
IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>) Properties
IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>) Interface See Also Send Feedback

The IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>) type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item with the specified key.

See Also

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>) Interface
Mincom.LinkOne.Collections Namespace


Item Property

[image]

LinkOne WebView API
IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Item Property
IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>) Interface See Also Send Feedback
Gets the item with the specified key.

Namespace: Mincom.LinkOne.Collections
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
TItem this[
    TKey key
] { get; }
Visual Basic (Declaration)
ReadOnly Default Property Item ( _
    key As TKey _
) As TItem
Visual C++
property TItem default[TKey key] {
    TItem get (TKey key);
}

Parameters

key
Type: TKey

See Also

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>) Interface
Mincom.LinkOne.Collections Namespace


IReadOnlyList(T) Interface

[image]

LinkOne WebView API
IReadOnlyList<(Of <(T>)>) Interface
Members See Also Send Feedback
Extends IReadOnlyCollection by providing access to objects by index.

Namespace: Mincom.LinkOne.Collections
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IReadOnlyList<T> : IReadOnlyCollection<T>,
    IEnumerable<T>, IEnumerable
Visual Basic (Declaration)
Public Interface IReadOnlyList(Of T) _
    Implements IReadOnlyCollection(Of T), IEnumerable(Of T),  _
    IEnumerable
Visual C++
generic<typename T>
public interface class IReadOnlyList : IReadOnlyCollection<T>,
    IEnumerable<T>, IEnumerable

Type Parameters

T
The type of items contained.

See Also

IReadOnlyList<(Of <(T>)>) Members
Mincom.LinkOne.Collections Namespace


IReadOnlyList(T) Members

[image] [image]

LinkOne WebView API
IReadOnlyList<(Of <(T>)>) Members
IReadOnlyList<(Of <(T>)>) Interface Methods Properties See Also Send Feedback

The IReadOnlyList<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
GetEnumerator | Overloaded.
IndexOf | Searches the collection and returns the zero-based index of the first occurrence of the given item.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item at the specified index.

See Also

IReadOnlyList<(Of <(T>)>) Interface
Mincom.LinkOne.Collections Namespace


IReadOnlyList(T) Methods

[image] [image]

LinkOne WebView API
IReadOnlyList<(Of <(T>)>) Methods
IReadOnlyList<(Of <(T>)>) Interface See Also Send Feedback

The IReadOnlyList<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
GetEnumerator | Overloaded.
IndexOf | Searches the collection and returns the zero-based index of the first occurrence of the given item.

See Also

IReadOnlyList<(Of <(T>)>) Interface
Mincom.LinkOne.Collections Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
IReadOnlyList<(Of <(T>)>)..::.GetEnumerator Method
IReadOnlyList<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( T >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IReadOnlyList<(Of <(T>)>) Interface
IReadOnlyList<(Of <(T>)>) Members
Mincom.LinkOne.Collections Namespace


IndexOf Method

[image]

LinkOne WebView API
IReadOnlyList<(Of <(T>)>)..::.IndexOf Method
IReadOnlyList<(Of <(T>)>) Interface See Also Send Feedback
Searches the collection and returns the zero-based index of the first occurrence of the given item.

Namespace: Mincom.LinkOne.Collections
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int IndexOf(
    T item
)
Visual Basic (Declaration)
Function IndexOf ( _
    item As T _
) As Integer
Visual C++
int IndexOf(
    T item
)

Parameters

item
Type: T
The item to search for.

Return Value

The index of the item in the collection, if found; otherwise, false.

See Also

IReadOnlyList<(Of <(T>)>) Interface
Mincom.LinkOne.Collections Namespace


IReadOnlyList(T) Properties

[image] [image]

LinkOne WebView API
IReadOnlyList<(Of <(T>)>) Properties
IReadOnlyList<(Of <(T>)>) Interface See Also Send Feedback

The IReadOnlyList<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item at the specified index.

See Also

IReadOnlyList<(Of <(T>)>) Interface
Mincom.LinkOne.Collections Namespace


Item Property

[image]

LinkOne WebView API
IReadOnlyList<(Of <(T>)>)..::.Item Property
IReadOnlyList<(Of <(T>)>) Interface See Also Send Feedback
Gets the item at the specified index.

Namespace: Mincom.LinkOne.Collections
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
T this[
    int index
] { get; }
Visual Basic (Declaration)
ReadOnly Default Property Item ( _
    index As Integer _
) As T
Visual C++
property T default[int index] {
    T get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

IReadOnlyList<(Of <(T>)>) Interface
Mincom.LinkOne.Collections Namespace


Mincom.LinkOne.Common Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.Common Namespace
Send Feedback
The Mincom.LinkOne.Common namespace contains classes that provide functionality common to the LinkOne framework.

Classes

Class | Description
Configuration |
DebugEntryExit |
ExceptionLogger | A helper class for logging exception messages in a standardised fashion.
Installer | The installer class is used during installation to install/uninstall features required by the assembly.
Logging | Provides logging facilites.
SafeIO | Wraps System.IO calls encapsulating I/O related exceptions in an IOException.
StrongNameIdentity | This class contains constants relating to the LinkOne Strong Name
Tracing | Provides tracing facilities.
Translator | Class to translate given controls and components using external translation files.


Configuration Class

[image]

LinkOne WebView API
Configuration Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static class Configuration
Visual Basic (Declaration)
Public NotInheritable Class Configuration
Visual C++
public ref class Configuration abstract sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Common..::.Configuration

See Also

Configuration Members
Mincom.LinkOne.Common Namespace


Configuration Members

[image] [image]

LinkOne WebView API
Configuration Members
Configuration Class Methods See Also Send Feedback

The Configuration type exposes the following members.

Methods

Name | Description
GetApplicationData<(Of <(T>)>) | Gets a specific application data.

See Also

Configuration Class
Mincom.LinkOne.Common Namespace


Configuration Methods

[image] [image]

LinkOne WebView API
Configuration Methods
Configuration Class See Also Send Feedback

The Configuration type exposes the following members.

Methods

Name | Description
GetApplicationData<(Of <(T>)>) | Gets a specific application data.

See Also

Configuration Class
Mincom.LinkOne.Common Namespace


GetApplicationData(T) Method

[image]

LinkOne WebView API
Configuration..::.GetApplicationData<(Of <(T>)>) Method
Configuration Class See Also Send Feedback
Gets a specific application data.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static T GetApplicationData<T>(
    string name,
    T defaultValue
)
Visual Basic (Declaration)
Public Shared Function GetApplicationData(Of T) ( _
    name As String, _
    defaultValue As T _
) As T
Visual C++
public:
generic<typename T>
static T GetApplicationData(
    String^ name,
    T defaultValue
)

Parameters

name
Type: System..::.String
The name of the application data to get.
defaultValue
Type: T
The default data value.

Type Parameters

T
The type of the application data.

Return Value

The application data.

See Also

Configuration Class
Mincom.LinkOne.Common Namespace


DebugEntryExit Class

[image]

LinkOne WebView API
DebugEntryExit Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public class DebugEntryExit : IDisposable
Visual Basic (Declaration)
Public Class DebugEntryExit _
    Implements IDisposable
Visual C++
public ref class DebugEntryExit : IDisposable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Common..::.DebugEntryExit

See Also

DebugEntryExit Members
Mincom.LinkOne.Common Namespace


DebugEntryExit Members

[image] [image]

LinkOne WebView API
DebugEntryExit Members
DebugEntryExit Class Constructors Methods See Also Send Feedback

The DebugEntryExit type exposes the following members.

Constructors

Name | Description
DebugEntryExit | Overloaded.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Overrides Object..::.Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TraceMessage |

See Also

DebugEntryExit Class
Mincom.LinkOne.Common Namespace


DebugEntryExit Constructor

[image] [image]

LinkOne WebView API
DebugEntryExit Constructor
DebugEntryExit Class See Also Send Feedback

Overload List

Name | Description
DebugEntryExit()()() | Initializes a new instance of the DebugEntryExit class
DebugEntryExit(String) | Initializes a new instance of the DebugEntryExit class

See Also

DebugEntryExit Class
DebugEntryExit Members
Mincom.LinkOne.Common Namespace


DebugEntryExit Constructor

[image]

LinkOne WebView API
DebugEntryExit Constructor
DebugEntryExit Class See Also Send Feedback
Initializes a new instance of the DebugEntryExit class

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public DebugEntryExit()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DebugEntryExit()

See Also

DebugEntryExit Class
DebugEntryExit Overload
Mincom.LinkOne.Common Namespace


DebugEntryExit Constructor (String)

[image]

LinkOne WebView API
DebugEntryExit Constructor (String)
DebugEntryExit Class See Also Send Feedback
Initializes a new instance of the DebugEntryExit class

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public DebugEntryExit(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
DebugEntryExit(
    String^ message
)

Parameters

message
Type: System..::.String

See Also

DebugEntryExit Class
DebugEntryExit Overload
Mincom.LinkOne.Common Namespace


DebugEntryExit Methods

[image] [image]

LinkOne WebView API
DebugEntryExit Methods
DebugEntryExit Class See Also Send Feedback

The DebugEntryExit type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Overrides Object..::.Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TraceMessage |

See Also

DebugEntryExit Class
Mincom.LinkOne.Common Namespace


Dispose Method

[image]

LinkOne WebView API
DebugEntryExit..::.Dispose Method
DebugEntryExit Class See Also Send Feedback

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

DebugEntryExit Class
Mincom.LinkOne.Common Namespace


Finalize Method

[image]

LinkOne WebView API
DebugEntryExit..::.Finalize Method
DebugEntryExit Class See Also Send Feedback

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
protected override void Finalize()
Visual Basic (Declaration)
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

DebugEntryExit Class
Mincom.LinkOne.Common Namespace


TraceMessage Method

[image]

LinkOne WebView API
DebugEntryExit..::.TraceMessage Method
DebugEntryExit Class See Also Send Feedback

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public void TraceMessage(
    string message,
    params Object[] parameters
)
Visual Basic (Declaration)
Public Sub TraceMessage ( _
    message As String, _
    ParamArray parameters As Object() _
)
Visual C++
public:
void TraceMessage(
    String^ message,
    ... array<Object^>^ parameters
)

Parameters

message
Type: System..::.String
parameters
Type: array< System..::.Object >[]()[]

See Also

DebugEntryExit Class
Mincom.LinkOne.Common Namespace


ExceptionLogger Class

[image]

LinkOne WebView API
ExceptionLogger Class
Members See Also Send Feedback
A helper class for logging exception messages in a standardised fashion.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static class ExceptionLogger
Visual Basic (Declaration)
Public NotInheritable Class ExceptionLogger
Visual C++
public ref class ExceptionLogger abstract sealed

Remarks

This class supports logging of the exception itself, recursing in inner exceptions and logging a stack trace. Log output is controlled by the provided log and stack trace target parameters. The user can either use one of the provided targets, or a custom target.

Exected usage is primarily for debug builds to log sufficient exception details. However, it can be used for general exception reporting if used judiciously (for security reasons).

The log output follows the following pattern, making multiple calls to the log target (one for each item): Exception.MessageThe message of for the passed exception. Exception.InnerException.MessageIteratively logged inner exceptions, shallowest to deepest until null. Exception.StackTraceThe StackTrace for the passed exception.

Note: inner exceptions are only logged in debug builds to avoid exposing too many details in released builds.

The log methods should be exposed as extention methods once this library is migrated to .Net 3.5 or higher.

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Common..::.ExceptionLogger

See Also

ExceptionLogger Members
Mincom.LinkOne.Common Namespace


ExceptionLogger Members

[image] [image]

LinkOne WebView API
ExceptionLogger Members
ExceptionLogger Class Methods Properties See Also Send Feedback

The ExceptionLogger type exposes the following members.

Methods

Name | Description
Log | Overloaded.

Properties

Name | Description
DebugTarget | A log target that uses System.Diagnostics.Debug.WriteLine(string). Empty in release builds.
EventLogTarget | A log target that uses [!:Logging.LogApplicationEvent(string, params object[])] to log to the system event log.
TraceTarget | A log target that uses System.Diagnostics.Trace.WriteLine(string).

See Also

ExceptionLogger Class
Mincom.LinkOne.Common Namespace


ExceptionLogger Methods

[image] [image]

LinkOne WebView API
ExceptionLogger Methods
ExceptionLogger Class See Also Send Feedback

Methods

Name | Description
Log | Overloaded.

See Also

ExceptionLogger Class
Mincom.LinkOne.Common Namespace


Log Method

[image] [image]

LinkOne WebView API
ExceptionLogger..::.Log Method
ExceptionLogger Class See Also Send Feedback

Overload List

Name | Description
Log(Exception) | Log an exception using the TraceTarget for exception messages and DebugTarget for stack traces (empty in release).
Log(Exception, Action<(Of <(String>)>)) | Log an exception using the messageTarget for exception messages and stack trace.
Log(Exception, Action<(Of <(String>)>), Action<(Of <(String>)>)) | Log an exception using the given message and stack trace log target.

See Also

ExceptionLogger Class
ExceptionLogger Members
Mincom.LinkOne.Common Namespace


Log Method (Exception)

[image]

LinkOne WebView API
ExceptionLogger..::.Log Method (Exception)
ExceptionLogger Class See Also Send Feedback
Log an exception using the TraceTarget for exception messages and DebugTarget for stack traces (empty in release).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void Log(
    Exception exception
)
Visual Basic (Declaration)
Public Shared Sub Log ( _
    exception As Exception _
)
Visual C++
public:
static void Log(
    Exception^ exception
)

Parameters

exception
Type: System..::.Exception
The exception to log the details of.

See Also

ExceptionLogger Class
Log Overload
Mincom.LinkOne.Common Namespace


Log Method (Exception, Action(String))

[image]

LinkOne WebView API
ExceptionLogger..::.Log Method (Exception, Action<(Of <(String>)>))
ExceptionLogger Class See Also Send Feedback
Log an exception using the messageTarget for exception messages and stack trace.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void Log(
    Exception exception,
    Action<string> logTarget
)
Visual Basic (Declaration)
Public Shared Sub Log ( _
    exception As Exception, _
    logTarget As Action(Of String) _
)
Visual C++
public:
static void Log(
    Exception^ exception,
    Action<String^>^ logTarget
)

Parameters

exception
Type: System..::.Exception
The exception to log the details of.
logTarget
Type: System..::.Action<(Of <(String>)>)
Log target to use for the exception message(s) and stack trace.

See Also

ExceptionLogger Class
Log Overload
Mincom.LinkOne.Common Namespace


Log Method (Exception, Action(String), Action(String))

[image]

LinkOne WebView API
ExceptionLogger..::.Log Method (Exception, Action<(Of <(String>)>), Action<(Of <(String>)>))
ExceptionLogger Class See Also Send Feedback
Log an exception using the given message and stack trace log target.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void Log(
    Exception exception,
    Action<string> messageTarget,
    Action<string> stackTraceTarget
)
Visual Basic (Declaration)
Public Shared Sub Log ( _
    exception As Exception, _
    messageTarget As Action(Of String), _
    stackTraceTarget As Action(Of String) _
)
Visual C++
public:
static void Log(
    Exception^ exception,
    Action<String^>^ messageTarget,
    Action<String^>^ stackTraceTarget
)

Parameters

exception
Type: System..::.Exception
The exception to log the details of.
messageTarget
Type: System..::.Action<(Of <(String>)>)
Log target to use for the exception message(s).
stackTraceTarget
Type: System..::.Action<(Of <(String>)>)
Log target to use for the exception stack trace.

See Also

ExceptionLogger Class
Log Overload
Mincom.LinkOne.Common Namespace


ExceptionLogger Properties

[image] [image]

LinkOne WebView API
ExceptionLogger Properties
ExceptionLogger Class See Also Send Feedback

The ExceptionLogger type exposes the following members.

Properties

Name | Description
DebugTarget | A log target that uses System.Diagnostics.Debug.WriteLine(string). Empty in release builds.
EventLogTarget | A log target that uses [!:Logging.LogApplicationEvent(string, params object[])] to log to the system event log.
TraceTarget | A log target that uses System.Diagnostics.Trace.WriteLine(string).

See Also

ExceptionLogger Class
Mincom.LinkOne.Common Namespace


DebugTarget Property

[image]

LinkOne WebView API
ExceptionLogger..::.DebugTarget Property
ExceptionLogger Class See Also Send Feedback
A log target that uses System.Diagnostics.Debug.WriteLine(string). Empty in release builds.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static Action<string> DebugTarget { get; private set; }
Visual Basic (Declaration)
Public Shared Property DebugTarget As Action(Of String)
Visual C++
public:
static property Action<String^>^ DebugTarget {
    Action<String^>^ get ();
    void set (Action<String^>^ value);
}

See Also

ExceptionLogger Class
Mincom.LinkOne.Common Namespace


EventLogTarget Property

[image]

LinkOne WebView API
ExceptionLogger..::.EventLogTarget Property
ExceptionLogger Class See Also Send Feedback
A log target that uses [!:Logging.LogApplicationEvent(string, params object[])] to log to the system event log.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static Action<string> EventLogTarget { get; private set; }
Visual Basic (Declaration)
Public Shared Property EventLogTarget As Action(Of String)
Visual C++
public:
static property Action<String^>^ EventLogTarget {
    Action<String^>^ get ();
    void set (Action<String^>^ value);
}

See Also

ExceptionLogger Class
Mincom.LinkOne.Common Namespace


TraceTarget Property

[image]

LinkOne WebView API
ExceptionLogger..::.TraceTarget Property
ExceptionLogger Class See Also Send Feedback
A log target that uses System.Diagnostics.Trace.WriteLine(string).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static Action<string> TraceTarget { get; private set; }
Visual Basic (Declaration)
Public Shared Property TraceTarget As Action(Of String)
Visual C++
public:
static property Action<String^>^ TraceTarget {
    Action<String^>^ get ();
    void set (Action<String^>^ value);
}

See Also

ExceptionLogger Class
Mincom.LinkOne.Common Namespace


Installer Class

[image]

LinkOne WebView API
Installer Class
Members See Also Send Feedback
The installer class is used during installation to install/uninstall features required by the assembly.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public sealed class Installer : Installer
Visual Basic (Declaration)
Public NotInheritable Class Installer _
    Inherits Installer
Visual C++
public ref class Installer sealed : public Installer

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Configuration.Install..::.Installer
Mincom.LinkOne.Common..::.Installer

See Also

Installer Members
Mincom.LinkOne.Common Namespace


Installer Members

[image] [image]

LinkOne WebView API
Installer Members
Installer Class Constructors Methods Properties Events See Also Send Feedback

The Installer type exposes the following members.

Constructors

Name | Description
Installer | Constructor, to add or remove event log support.

Methods

Name | Description
Commit | When overridden in a derived class, completes the install transaction. (Inherited from Installer.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Install | When overridden in a derived class, performs the installation. (Inherited from Installer.)
MemberwiseClone | Overloaded.
OnAfterInstall | Raises the AfterInstall event. (Inherited from Installer.)
OnAfterRollback | Raises the AfterRollback event. (Inherited from Installer.)
OnAfterUninstall | Raises the AfterUninstall event. (Inherited from Installer.)
OnBeforeInstall | Raises the BeforeInstall event. (Inherited from Installer.)
OnBeforeRollback | Raises the BeforeRollback event. (Inherited from Installer.)
OnBeforeUninstall | Raises the BeforeUninstall event. (Inherited from Installer.)
OnCommitted | Raises the Committed event. (Inherited from Installer.)
OnCommitting | Raises the Committing event. (Inherited from Installer.)
Rollback | When overridden in a derived class, restores the pre-installation state of the computer. (Inherited from Installer.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Uninstall | When overridden in a derived class, removes an installation. (Inherited from Installer.)

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Context | Gets or sets information about the current installation. (Inherited from Installer.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
HelpText | Gets help information about the installer. (Overrides Installer..::.HelpText.)
Installers | Gets the collection of installers that this installer contains. (Inherited from Installer.)
Parent | Gets or sets the installer containing the collection that this installer belongs to. (Inherited from Installer.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

Name | Description
AfterInstall | Occurs after the Install(IDictionary) methods of all the installers in the Installers property have run. (Inherited from Installer.)
AfterRollback | Occurs after the installations of all the installers in the Installers property are rolled back. (Inherited from Installer.)
AfterUninstall | Occurs after all the installers in the Installers property perform their uninstallation operations. (Inherited from Installer.)
BeforeInstall | Occurs before the Install(IDictionary) method of each installer in the installer collection has run. (Inherited from Installer.)
BeforeRollback | Occurs before the installers in the Installers property are rolled back. (Inherited from Installer.)
BeforeUninstall | Occurs before the installers in the Installers property perform their uninstall operations. (Inherited from Installer.)
Committed | Occurs after all the installers in the Installers property have committed their installations. (Inherited from Installer.)
Committing | Occurs before the installers in the Installers property committ their installations. (Inherited from Installer.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

Installer Class
Mincom.LinkOne.Common Namespace


Installer Constructor

[image]

LinkOne WebView API
Installer Constructor
Installer Class See Also Send Feedback
Constructor, to add or remove event log support.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public Installer()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Installer()

See Also

Installer Class
Mincom.LinkOne.Common Namespace


Installer Methods

[image] [image]

LinkOne WebView API
Installer Methods
Installer Class See Also Send Feedback

The Installer type exposes the following members.

Methods

Name | Description
Commit | When overridden in a derived class, completes the install transaction. (Inherited from Installer.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Install | When overridden in a derived class, performs the installation. (Inherited from Installer.)
MemberwiseClone | Overloaded.
OnAfterInstall | Raises the AfterInstall event. (Inherited from Installer.)
OnAfterRollback | Raises the AfterRollback event. (Inherited from Installer.)
OnAfterUninstall | Raises the AfterUninstall event. (Inherited from Installer.)
OnBeforeInstall | Raises the BeforeInstall event. (Inherited from Installer.)
OnBeforeRollback | Raises the BeforeRollback event. (Inherited from Installer.)
OnBeforeUninstall | Raises the BeforeUninstall event. (Inherited from Installer.)
OnCommitted | Raises the Committed event. (Inherited from Installer.)
OnCommitting | Raises the Committing event. (Inherited from Installer.)
Rollback | When overridden in a derived class, restores the pre-installation state of the computer. (Inherited from Installer.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Uninstall | When overridden in a derived class, removes an installation. (Inherited from Installer.)

See Also

Installer Class
Mincom.LinkOne.Common Namespace


Dispose Method

[image] [image]

LinkOne WebView API
Installer..::.Dispose Method
Installer Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

Installer Class
Installer Members
Mincom.LinkOne.Common Namespace


MemberwiseClone Method

[image] [image]

LinkOne WebView API
Installer..::.MemberwiseClone Method
Installer Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

Installer Class
Installer Members
Mincom.LinkOne.Common Namespace


Installer Properties

[image] [image]

LinkOne WebView API
Installer Properties
Installer Class See Also Send Feedback

The Installer type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Context | Gets or sets information about the current installation. (Inherited from Installer.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
HelpText | Gets help information about the installer. (Overrides Installer..::.HelpText.)
Installers | Gets the collection of installers that this installer contains. (Inherited from Installer.)
Parent | Gets or sets the installer containing the collection that this installer belongs to. (Inherited from Installer.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

Installer Class
Mincom.LinkOne.Common Namespace


HelpText Property

[image]

LinkOne WebView API
Installer..::.HelpText Property
Installer Class See Also Send Feedback
Gets help information about the installer.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public override string HelpText { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property HelpText As String
Visual C++
public:
virtual property String^ HelpText {
    String^ get () override;
}

See Also

Installer Class
Mincom.LinkOne.Common Namespace


Installer Events

[image] [image]

LinkOne WebView API
Installer Events
Installer Class See Also Send Feedback

The Installer type exposes the following members.

Events

Name | Description
AfterInstall | Occurs after the Install(IDictionary) methods of all the installers in the Installers property have run. (Inherited from Installer.)
AfterRollback | Occurs after the installations of all the installers in the Installers property are rolled back. (Inherited from Installer.)
AfterUninstall | Occurs after all the installers in the Installers property perform their uninstallation operations. (Inherited from Installer.)
BeforeInstall | Occurs before the Install(IDictionary) method of each installer in the installer collection has run. (Inherited from Installer.)
BeforeRollback | Occurs before the installers in the Installers property are rolled back. (Inherited from Installer.)
BeforeUninstall | Occurs before the installers in the Installers property perform their uninstall operations. (Inherited from Installer.)
Committed | Occurs after all the installers in the Installers property have committed their installations. (Inherited from Installer.)
Committing | Occurs before the installers in the Installers property committ their installations. (Inherited from Installer.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

Installer Class
Mincom.LinkOne.Common Namespace


Logging Class

[image]

LinkOne WebView API
Logging Class
Members See Also Send Feedback
Provides logging facilites.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static class Logging
Visual Basic (Declaration)
Public NotInheritable Class Logging
Visual C++
public ref class Logging abstract sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Common..::.Logging

See Also

Logging Members
Mincom.LinkOne.Common Namespace


Logging Members

[image] [image]

LinkOne WebView API
Logging Members
Logging Class Methods See Also Send Feedback

Methods

Name | Description
LogApplicationEvent | Overloaded.

See Also

Logging Class
Mincom.LinkOne.Common Namespace


Logging Methods

[image] [image]

LinkOne WebView API
Logging Methods
Logging Class See Also Send Feedback

Methods

Name | Description
LogApplicationEvent | Overloaded.

See Also

Logging Class
Mincom.LinkOne.Common Namespace


LogApplicationEvent Method

[image] [image]

LinkOne WebView API
Logging..::.LogApplicationEvent Method
Logging Class See Also Send Feedback

Overload List

Name | Description
LogApplicationEvent(String, array<Object>[]()[]) | Logs a formatted Information message to the Application event log.
LogApplicationEvent(EventLogEntryType, String, array<Object>[]()[]) | Logs a formatted message to the Application event log.

See Also

Logging Class
Logging Members
Mincom.LinkOne.Common Namespace


LogApplicationEvent Method (String, Object[])

[image]

LinkOne WebView API
Logging..::.LogApplicationEvent Method (String, array<Object>[]()[])
Logging Class See Also Send Feedback
Logs a formatted Information message to the Application event log.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void LogApplicationEvent(
    string format,
    params Object[] args
)
Visual Basic (Declaration)
Public Shared Sub LogApplicationEvent ( _
    format As String, _
    ParamArray args As Object() _
)
Visual C++
public:
static void LogApplicationEvent(
    String^ format,
    ... array<Object^>^ args
)

Parameters

format
Type: System..::.String
The message format to log.
args
Type: array< System..::.Object >[]()[]
The arguments to the formatted message.

See Also

Logging Class
LogApplicationEvent Overload
Mincom.LinkOne.Common Namespace


LogApplicationEvent Method (EventLogEntryType, String, Object[])

[image]

LinkOne WebView API
Logging..::.LogApplicationEvent Method (EventLogEntryType, String, array<Object>[]()[])
Logging Class See Also Send Feedback
Logs a formatted message to the Application event log.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void LogApplicationEvent(
    EventLogEntryType eventLogEntryType,
    string format,
    params Object[] args
)
Visual Basic (Declaration)
Public Shared Sub LogApplicationEvent ( _
    eventLogEntryType As EventLogEntryType, _
    format As String, _
    ParamArray args As Object() _
)
Visual C++
public:
static void LogApplicationEvent(
    EventLogEntryType eventLogEntryType,
    String^ format,
    ... array<Object^>^ args
)

Parameters

eventLogEntryType
Type: System.Diagnostics..::.EventLogEntryType
The type of event to log.
format
Type: System..::.String
The message format to log.
args
Type: array< System..::.Object >[]()[]
The arguments to the formatted message.

See Also

Logging Class
LogApplicationEvent Overload
Mincom.LinkOne.Common Namespace


SafeIO Class

[image]

LinkOne WebView API
SafeIO Class
Members See Also Send Feedback
Wraps System.IO calls encapsulating I/O related exceptions in an IOException.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static class SafeIO
Visual Basic (Declaration)
Public NotInheritable Class SafeIO
Visual C++
public ref class SafeIO abstract sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Common..::.SafeIO

See Also

SafeIO Members
Mincom.LinkOne.Common Namespace


SafeIO Members

[image] [image]

LinkOne WebView API
SafeIO Members
SafeIO Class Methods Fields See Also Send Feedback

The SafeIO type exposes the following members.

Methods

Name | Description
ChangeExtension | Wrapper for ChangeExtension(String, String).
Combine | Combines two path strings.
CopyAllFiles | Overloaded.
CopyFile | Overloaded.
Create | Wrapper for Create(String, Int32, FileOptions).
CreateDirectory | Wrapper for CreateDirectory(String).
CreateStreamReader | Overloaded.
CreateStreamWriter | Overloaded.
DeleteAllFiles | Overloaded.
DeleteDirectory | Overloaded.
DeleteFile | Overloaded.
DirectoryExists | Wrapper for Exists(String).
FileExists | Wrapper for Exists(String).
GetAttributes | Wrapper for GetAttributes(String).
GetDirectories | Wrapper for GetDirectories(String).
GetDirectoryAccessControl | Wrapper for GetAccessControl(String).
GetDirectoryName | Wrapper for GetDirectoryName(String).
GetFileAccessControl | Wrapper for GetAccessControl(String).
GetFileLength | Gets the length of the file.
GetFileName | Wrapper for GetFiles(String, String, SearchOption).
GetFiles | Overloaded.
GetFullPath | Wrapper for GetFullPath(String).
GetLastWriteTime | Wrapper for GetLastWriteTime(String).
GetLastWriteTimeUtc | Wrapper for GetLastWriteTimeUtc(String).
GetTempFileName | Creates a uniquely named, zero-byte temporary file on disk and returns the full path of that file.
GetTempPath | Wrapper for GetTempPath()()().
MoveFile | Overloaded.
Open | Overloaded.
OpenRead | Overloaded.
ReadAllBytes | Overloaded.
ReadAllText | Overloaded.
ReadLine | Wrapper for ReadLine()()().
ReadToEnd | Wrapper for ReadToEnd()()().
Seek | Wrapper for Seek(Int64, SeekOrigin).
SetAttributes | Wrapper for SetAttributes(String, FileAttributes).
SetLastWriteTime | Overloaded.
SetLastWriteTimeUtc | Overloaded.
SetLength | Wrapper for SetLength(Int64).
ValidateTimeStamp | Ensures that the timestamp for the given path is valid.
Write | Wrapper for Write(String).
WriteAllBytes | Overloaded.
WriteAllText | Overloaded.
WriteLine | Wrapper for WriteLine(String).

Fields

Name | Description
MinimumFileDateTime | The miminum acceptable NTFS File Time.

See Also

SafeIO Class
Mincom.LinkOne.Common Namespace


SafeIO Fields

[image] [image]

LinkOne WebView API
SafeIO Fields
SafeIO Class See Also Send Feedback

The SafeIO type exposes the following members.

Fields

Name | Description
MinimumFileDateTime | The miminum acceptable NTFS File Time.

See Also

SafeIO Class
Mincom.LinkOne.Common Namespace


MinimumFileDateTime Field

[image]

LinkOne WebView API
SafeIO..::.MinimumFileDateTime Field
SafeIO Class See Also Send Feedback
The miminum acceptable NTFS File Time.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static readonly DateTime MinimumFileDateTime
Visual Basic (Declaration)
Public Shared ReadOnly MinimumFileDateTime As DateTime
Visual C++
public:
static initonly DateTime MinimumFileDateTime

See Also

SafeIO Class
Mincom.LinkOne.Common Namespace


SafeIO Methods

[image] [image]

LinkOne WebView API
SafeIO Methods
SafeIO Class See Also Send Feedback

The SafeIO type exposes the following members.

Methods

Name | Description
ChangeExtension | Wrapper for ChangeExtension(String, String).
Combine | Combines two path strings.
CopyAllFiles | Overloaded.
CopyFile | Overloaded.
Create | Wrapper for Create(String, Int32, FileOptions).
CreateDirectory | Wrapper for CreateDirectory(String).
CreateStreamReader | Overloaded.
CreateStreamWriter | Overloaded.
DeleteAllFiles | Overloaded.
DeleteDirectory | Overloaded.
DeleteFile | Overloaded.
DirectoryExists | Wrapper for Exists(String).
FileExists | Wrapper for Exists(String).
GetAttributes | Wrapper for GetAttributes(String).
GetDirectories | Wrapper for GetDirectories(String).
GetDirectoryAccessControl | Wrapper for GetAccessControl(String).
GetDirectoryName | Wrapper for GetDirectoryName(String).
GetFileAccessControl | Wrapper for GetAccessControl(String).
GetFileLength | Gets the length of the file.
GetFileName | Wrapper for GetFiles(String, String, SearchOption).
GetFiles | Overloaded.
GetFullPath | Wrapper for GetFullPath(String).
GetLastWriteTime | Wrapper for GetLastWriteTime(String).
GetLastWriteTimeUtc | Wrapper for GetLastWriteTimeUtc(String).
GetTempFileName | Creates a uniquely named, zero-byte temporary file on disk and returns the full path of that file.
GetTempPath | Wrapper for GetTempPath()()().
MoveFile | Overloaded.
Open | Overloaded.
OpenRead | Overloaded.
ReadAllBytes | Overloaded.
ReadAllText | Overloaded.
ReadLine | Wrapper for ReadLine()()().
ReadToEnd | Wrapper for ReadToEnd()()().
Seek | Wrapper for Seek(Int64, SeekOrigin).
SetAttributes | Wrapper for SetAttributes(String, FileAttributes).
SetLastWriteTime | Overloaded.
SetLastWriteTimeUtc | Overloaded.
SetLength | Wrapper for SetLength(Int64).
ValidateTimeStamp | Ensures that the timestamp for the given path is valid.
Write | Wrapper for Write(String).
WriteAllBytes | Overloaded.
WriteAllText | Overloaded.
WriteLine | Wrapper for WriteLine(String).

See Also

SafeIO Class
Mincom.LinkOne.Common Namespace


ChangeExtension Method

[image]

LinkOne WebView API
SafeIO..::.ChangeExtension Method
SafeIO Class See Also Send Feedback
Wrapper for ChangeExtension(String, String).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static string ChangeExtension(
    string path,
    string extension
)
Visual Basic (Declaration)
Public Shared Function ChangeExtension ( _
    path As String, _
    extension As String _
) As String
Visual C++
public:
static String^ ChangeExtension(
    String^ path,
    String^ extension
)

Parameters

path
Type: System..::.String
The path to change the extension for.
extension
Type: System..::.String
The extension to change the path to.

Return Value

The path with the changed extension.

See Also

SafeIO Class
Mincom.LinkOne.Common Namespace


Combine Method

[image]

LinkOne WebView API
SafeIO..::.Combine Method
SafeIO Class See Also Send Feedback
Combines two path strings.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static string Combine(
    string path1,
    string path2
)
Visual Basic (Declaration)
Public Shared Function Combine ( _
    path1 As String, _
    path2 As String _
) As String
Visual C++
public:
static String^ Combine(
    String^ path1,
    String^ path2
)

Parameters

path1
Type: System..::.String
The first path.
path2
Type: System..::.String
The second path.

Return Value

See Also

SafeIO Class
Mincom.LinkOne.Common Namespace


CopyAllFiles Method

[image] [image]

LinkOne WebView API
SafeIO..::.CopyAllFiles Method
SafeIO Class See Also Send Feedback

Overload List

Name | Description
CopyAllFiles(String, String, Boolean) | Wrapper for Copy(String, String, Boolean).
CopyAllFiles(String, String, Boolean, Int32) | Wrapper for Copy(String, String, Boolean).

See Also

SafeIO Class
SafeIO Members
Mincom.LinkOne.Common Namespace


CopyAllFiles Method (String, String, Boolean)

[image]

LinkOne WebView API
SafeIO..::.CopyAllFiles Method (String, String, Boolean)
SafeIO Class See Also Send Feedback
Wrapper for Copy(String, String, Boolean).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void CopyAllFiles(
    string sourceDirName,
    string destinationDirName,
    bool overwrite
)
Visual Basic (Declaration)
Public Shared Sub CopyAllFiles ( _
    sourceDirName As String, _
    destinationDirName As String, _
    overwrite As Boolean _
)
Visual C++
public:
static void CopyAllFiles(
    String^ sourceDirName,
    String^ destinationDirName,
    bool overwrite
)

Parameters

sourceDirName
Type: System..::.String
Name of the source directory containing the files to copy.
destinationDirName
Type: System..::.String
Name of the destination directory containing the files to copy to.
overwrite
Type: System..::.Boolean
if set to true overwrite the destination file/s.

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
CopyAllFiles Overload
Mincom.LinkOne.Common Namespace


CopyAllFiles Method (String, String, Boolean, Int32)

[image]

LinkOne WebView API
SafeIO..::.CopyAllFiles Method (String, String, Boolean, Int32)
SafeIO Class See Also Send Feedback
Wrapper for Copy(String, String, Boolean).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void CopyAllFiles(
    string sourceDirName,
    string destinationDirName,
    bool overwrite,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Shared Sub CopyAllFiles ( _
    sourceDirName As String, _
    destinationDirName As String, _
    overwrite As Boolean, _
    retryMilliseconds As Integer _
)
Visual C++
public:
static void CopyAllFiles(
    String^ sourceDirName,
    String^ destinationDirName,
    bool overwrite,
    int retryMilliseconds
)

Parameters

sourceDirName
Type: System..::.String
Name of the source directory containing the files to copy.
destinationDirName
Type: System..::.String
Name of the destination directory containing the files to copy to.
overwrite
Type: System..::.Boolean
if set to true overwrite the destination file/s.
retryMilliseconds
Type: System..::.Int32
The number of milliseconds to retry if the desination file is locked.

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
CopyAllFiles Overload
Mincom.LinkOne.Common Namespace


CopyFile Method

[image] [image]

LinkOne WebView API
SafeIO..::.CopyFile Method
SafeIO Class See Also Send Feedback

Overload List

Name | Description
CopyFile(String, String, Boolean) | Wrapper for Copy(String, String, Boolean).
CopyFile(String, String, Boolean, Int32) | Wrapper for Copy(String, String, Boolean).

See Also

SafeIO Class
SafeIO Members
Mincom.LinkOne.Common Namespace


CopyFile Method (String, String, Boolean)

[image]

LinkOne WebView API
SafeIO..::.CopyFile Method (String, String, Boolean)
SafeIO Class See Also Send Feedback
Wrapper for Copy(String, String, Boolean).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void CopyFile(
    string sourceFileName,
    string destinationFileName,
    bool overwrite
)
Visual Basic (Declaration)
Public Shared Sub CopyFile ( _
    sourceFileName As String, _
    destinationFileName As String, _
    overwrite As Boolean _
)
Visual C++
public:
static void CopyFile(
    String^ sourceFileName,
    String^ destinationFileName,
    bool overwrite
)

Parameters

sourceFileName
Type: System..::.String
Name of the source file to copy.
destinationFileName
Type: System..::.String
Name of the destination file to copy to.
overwrite
Type: System..::.Boolean
if set to true overwrite the destination file.

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
CopyFile Overload
Mincom.LinkOne.Common Namespace


CopyFile Method (String, String, Boolean, Int32)

[image]

LinkOne WebView API
SafeIO..::.CopyFile Method (String, String, Boolean, Int32)
SafeIO Class See Also Send Feedback
Wrapper for Copy(String, String, Boolean).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void CopyFile(
    string sourceFileName,
    string destinationFileName,
    bool overwrite,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Shared Sub CopyFile ( _
    sourceFileName As String, _
    destinationFileName As String, _
    overwrite As Boolean, _
    retryMilliseconds As Integer _
)
Visual C++
public:
static void CopyFile(
    String^ sourceFileName,
    String^ destinationFileName,
    bool overwrite,
    int retryMilliseconds
)

Parameters

sourceFileName
Type: System..::.String
Name of the source file to copy.
destinationFileName
Type: System..::.String
Name of the destination file to copy to.
overwrite
Type: System..::.Boolean
if set to true overwrite the destination file.
retryMilliseconds
Type: System..::.Int32
The number of milliseconds to retry if the desination file is locked.

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
CopyFile Overload
Mincom.LinkOne.Common Namespace


Create Method

[image]

LinkOne WebView API
SafeIO..::.Create Method
SafeIO Class See Also Send Feedback
Wrapper for Create(String, Int32, FileOptions).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static Stream Create(
    string path,
    int bufferSize,
    FileOptions fileOptions
)
Visual Basic (Declaration)
Public Shared Function Create ( _
    path As String, _
    bufferSize As Integer, _
    fileOptions As FileOptions _
) As Stream
Visual C++
public:
static Stream^ Create(
    String^ path,
    int bufferSize,
    FileOptions fileOptions
)

Parameters

path
Type: System..::.String
The path.
bufferSize
Type: System..::.Int32
Size of the buffer.
fileOptions
Type: System.IO..::.FileOptions
The file options.

Return Value

The created File Stream

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
Mincom.LinkOne.Common Namespace


CreateDirectory Method

[image]

LinkOne WebView API
SafeIO..::.CreateDirectory Method
SafeIO Class See Also Send Feedback
Wrapper for CreateDirectory(String).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static DirectoryInfo CreateDirectory(
    string path
)
Visual Basic (Declaration)
Public Shared Function CreateDirectory ( _
    path As String _
) As DirectoryInfo
Visual C++
public:
static DirectoryInfo^ CreateDirectory(
    String^ path
)

Parameters

path
Type: System..::.String

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
Mincom.LinkOne.Common Namespace


CreateStreamReader Method

[image] [image]

LinkOne WebView API
SafeIO..::.CreateStreamReader Method
SafeIO Class See Also Send Feedback

Overload List

Name | Description
CreateStreamReader(Stream) | Wrapper for StreamReader(Stream).
CreateStreamReader(Stream, Boolean) | Wrapper for StreamReader(Stream, Boolean).
CreateStreamReader(Stream, Encoding) | Wrapper for StreamReader(Stream, Encoding).

See Also

SafeIO Class
SafeIO Members
Mincom.LinkOne.Common Namespace


CreateStreamReader Method (Stream)

[image]

LinkOne WebView API
SafeIO..::.CreateStreamReader Method (Stream)
SafeIO Class See Also Send Feedback
Wrapper for StreamReader(Stream).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static StreamReader CreateStreamReader(
    Stream stream
)
Visual Basic (Declaration)
Public Shared Function CreateStreamReader ( _
    stream As Stream _
) As StreamReader
Visual C++
public:
static StreamReader^ CreateStreamReader(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
CreateStreamReader Overload
Mincom.LinkOne.Common Namespace


CreateStreamReader Method (Stream, Boolean)

[image]

LinkOne WebView API
SafeIO..::.CreateStreamReader Method (Stream, Boolean)
SafeIO Class See Also Send Feedback
Wrapper for StreamReader(Stream, Boolean).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static StreamReader CreateStreamReader(
    Stream stream,
    bool detectEncodingFromByteOrderMarks
)
Visual Basic (Declaration)
Public Shared Function CreateStreamReader ( _
    stream As Stream, _
    detectEncodingFromByteOrderMarks As Boolean _
) As StreamReader
Visual C++
public:
static StreamReader^ CreateStreamReader(
    Stream^ stream,
    bool detectEncodingFromByteOrderMarks
)

Parameters

stream
Type: System.IO..::.Stream
detectEncodingFromByteOrderMarks
Type: System..::.Boolean

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
CreateStreamReader Overload
Mincom.LinkOne.Common Namespace


CreateStreamReader Method (Stream, Encoding)

[image]

LinkOne WebView API
SafeIO..::.CreateStreamReader Method (Stream, Encoding)
SafeIO Class See Also Send Feedback
Wrapper for StreamReader(Stream, Encoding).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static StreamReader CreateStreamReader(
    Stream stream,
    Encoding encoding
)
Visual Basic (Declaration)
Public Shared Function CreateStreamReader ( _
    stream As Stream, _
    encoding As Encoding _
) As StreamReader
Visual C++
public:
static StreamReader^ CreateStreamReader(
    Stream^ stream,
    Encoding^ encoding
)

Parameters

stream
Type: System.IO..::.Stream
encoding
Type: System.Text..::.Encoding

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
CreateStreamReader Overload
Mincom.LinkOne.Common Namespace


CreateStreamWriter Method

[image] [image]

LinkOne WebView API
SafeIO..::.CreateStreamWriter Method
SafeIO Class See Also Send Feedback

Overload List

Name | Description
CreateStreamWriter(Stream) | Wrapper for StreamWriter(Stream).
CreateStreamWriter(Stream, Encoding) | Wrapper for StreamWriter(Stream, Encoding).

See Also

SafeIO Class
SafeIO Members
Mincom.LinkOne.Common Namespace


CreateStreamWriter Method (Stream)

[image]

LinkOne WebView API
SafeIO..::.CreateStreamWriter Method (Stream)
SafeIO Class See Also Send Feedback
Wrapper for StreamWriter(Stream).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static StreamWriter CreateStreamWriter(
    Stream stream
)
Visual Basic (Declaration)
Public Shared Function CreateStreamWriter ( _
    stream As Stream _
) As StreamWriter
Visual C++
public:
static StreamWriter^ CreateStreamWriter(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
CreateStreamWriter Overload
Mincom.LinkOne.Common Namespace


CreateStreamWriter Method (Stream, Encoding)

[image]

LinkOne WebView API
SafeIO..::.CreateStreamWriter Method (Stream, Encoding)
SafeIO Class See Also Send Feedback
Wrapper for StreamWriter(Stream, Encoding).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static StreamWriter CreateStreamWriter(
    Stream stream,
    Encoding encoding
)
Visual Basic (Declaration)
Public Shared Function CreateStreamWriter ( _
    stream As Stream, _
    encoding As Encoding _
) As StreamWriter
Visual C++
public:
static StreamWriter^ CreateStreamWriter(
    Stream^ stream,
    Encoding^ encoding
)

Parameters

stream
Type: System.IO..::.Stream
encoding
Type: System.Text..::.Encoding

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
CreateStreamWriter Overload
Mincom.LinkOne.Common Namespace


DeleteAllFiles Method

[image] [image]

LinkOne WebView API
SafeIO..::.DeleteAllFiles Method
SafeIO Class See Also Send Feedback

Overload List

Name | Description
DeleteAllFiles(String) | Wrapper for Delete(String).
DeleteAllFiles(String, Int32) | Wrapper for Delete(String).

See Also

SafeIO Class
SafeIO Members
Mincom.LinkOne.Common Namespace


DeleteAllFiles Method (String)

[image]

LinkOne WebView API
SafeIO..::.DeleteAllFiles Method (String)
SafeIO Class See Also Send Feedback
Wrapper for Delete(String).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void DeleteAllFiles(
    string path
)
Visual Basic (Declaration)
Public Shared Sub DeleteAllFiles ( _
    path As String _
)
Visual C++
public:
static void DeleteAllFiles(
    String^ path
)

Parameters

path
Type: System..::.String
The name of the directory containing the files to be deleted.

See Also

SafeIO Class
DeleteAllFiles Overload
Mincom.LinkOne.Common Namespace


DeleteAllFiles Method (String, Int32)

[image]

LinkOne WebView API
SafeIO..::.DeleteAllFiles Method (String, Int32)
SafeIO Class See Also Send Feedback
Wrapper for Delete(String).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void DeleteAllFiles(
    string path,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Shared Sub DeleteAllFiles ( _
    path As String, _
    retryMilliseconds As Integer _
)
Visual C++
public:
static void DeleteAllFiles(
    String^ path,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
The name of the directory containing the files to be deleted.
retryMilliseconds
Type: System..::.Int32
The milliseconds to retry for to delete the file, if it is locked.

See Also

SafeIO Class
DeleteAllFiles Overload
Mincom.LinkOne.Common Namespace


DeleteDirectory Method

[image] [image]

LinkOne WebView API
SafeIO..::.DeleteDirectory Method
SafeIO Class See Also Send Feedback

Overload List

Name | Description
DeleteDirectory(String, Boolean) | Wrapper for Delete(String, Boolean).
DeleteDirectory(String, Boolean, Int32) | Wrapper for Delete(String, Boolean).

See Also

SafeIO Class
SafeIO Members
Mincom.LinkOne.Common Namespace


DeleteDirectory Method (String, Boolean)

[image]

LinkOne WebView API
SafeIO..::.DeleteDirectory Method (String, Boolean)
SafeIO Class See Also Send Feedback
Wrapper for Delete(String, Boolean).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void DeleteDirectory(
    string path,
    bool recursive
)
Visual Basic (Declaration)
Public Shared Sub DeleteDirectory ( _
    path As String, _
    recursive As Boolean _
)
Visual C++
public:
static void DeleteDirectory(
    String^ path,
    bool recursive
)

Parameters

path
Type: System..::.String
recursive
Type: System..::.Boolean

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
DeleteDirectory Overload
Mincom.LinkOne.Common Namespace


DeleteDirectory Method (String, Boolean, Int32)

[image]

LinkOne WebView API
SafeIO..::.DeleteDirectory Method (String, Boolean, Int32)
SafeIO Class See Also Send Feedback
Wrapper for Delete(String, Boolean).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void DeleteDirectory(
    string path,
    bool recursive,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Shared Sub DeleteDirectory ( _
    path As String, _
    recursive As Boolean, _
    retryMilliseconds As Integer _
)
Visual C++
public:
static void DeleteDirectory(
    String^ path,
    bool recursive,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
The path to delete.
recursive
Type: System..::.Boolean
if set to true remove all subfolders.
retryMilliseconds
Type: System..::.Int32
The number of milliseconds to retry for if the directory is locked.

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
DeleteDirectory Overload
Mincom.LinkOne.Common Namespace


DeleteFile Method

[image] [image]

LinkOne WebView API
SafeIO..::.DeleteFile Method
SafeIO Class See Also Send Feedback

Overload List

Name | Description
DeleteFile(String) | Wrapper for Delete(String).
DeleteFile(String, Int32) | Wrapper for Delete(String).

See Also

SafeIO Class
SafeIO Members
Mincom.LinkOne.Common Namespace


DeleteFile Method (String)

[image]

LinkOne WebView API
SafeIO..::.DeleteFile Method (String)
SafeIO Class See Also Send Feedback
Wrapper for Delete(String).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void DeleteFile(
    string path
)
Visual Basic (Declaration)
Public Shared Sub DeleteFile ( _
    path As String _
)
Visual C++
public:
static void DeleteFile(
    String^ path
)

Parameters

path
Type: System..::.String
The name of the file to be deleted.

See Also

SafeIO Class
DeleteFile Overload
Mincom.LinkOne.Common Namespace


DeleteFile Method (String, Int32)

[image]

LinkOne WebView API
SafeIO..::.DeleteFile Method (String, Int32)
SafeIO Class See Also Send Feedback
Wrapper for Delete(String).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void DeleteFile(
    string path,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Shared Sub DeleteFile ( _
    path As String, _
    retryMilliseconds As Integer _
)
Visual C++
public:
static void DeleteFile(
    String^ path,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
The name of the file to be deleted.
retryMilliseconds
Type: System..::.Int32
The milliseconds to retry for to delete the file, if it is locked.

See Also

SafeIO Class
DeleteFile Overload
Mincom.LinkOne.Common Namespace


DirectoryExists Method

[image]

LinkOne WebView API
SafeIO..::.DirectoryExists Method
SafeIO Class See Also Send Feedback
Wrapper for Exists(String).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static bool DirectoryExists(
    string path
)
Visual Basic (Declaration)
Public Shared Function DirectoryExists ( _
    path As String _
) As Boolean
Visual C++
public:
static bool DirectoryExists(
    String^ path
)

Parameters

path
Type: System..::.String
The directory to check.

Return Value

True if the directory exists, false otherwise.

See Also

SafeIO Class
Mincom.LinkOne.Common Namespace


FileExists Method

[image]

LinkOne WebView API
SafeIO..::.FileExists Method
SafeIO Class See Also Send Feedback
Wrapper for Exists(String).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static bool FileExists(
    string path
)
Visual Basic (Declaration)
Public Shared Function FileExists ( _
    path As String _
) As Boolean
Visual C++
public:
static bool FileExists(
    String^ path
)

Parameters

path
Type: System..::.String
The file to check.

Return Value

True if the file exists, false otherwise.

See Also

SafeIO Class
Mincom.LinkOne.Common Namespace


GetAttributes Method

[image]

LinkOne WebView API
SafeIO..::.GetAttributes Method
SafeIO Class See Also Send Feedback
Wrapper for GetAttributes(String).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static FileAttributes GetAttributes(
    string path
)
Visual Basic (Declaration)
Public Shared Function GetAttributes ( _
    path As String _
) As FileAttributes
Visual C++
public:
static FileAttributes GetAttributes(
    String^ path
)

Parameters

path
Type: System..::.String

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
Mincom.LinkOne.Common Namespace


GetDirectories Method

[image]

LinkOne WebView API
SafeIO..::.GetDirectories Method
SafeIO Class See Also Send Feedback
Wrapper for GetDirectories(String).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static string[] GetDirectories(
    string directory
)
Visual Basic (Declaration)
Public Shared Function GetDirectories ( _
    directory As String _
) As String()
Visual C++
public:
static array<String^>^ GetDirectories(
    String^ directory
)

Parameters

directory
Type: System..::.String

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
Mincom.LinkOne.Common Namespace


GetDirectoryAccessControl Method

[image]

LinkOne WebView API
SafeIO..::.GetDirectoryAccessControl Method
SafeIO Class See Also Send Feedback
Wrapper for GetAccessControl(String).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static DirectorySecurity GetDirectoryAccessControl(
    string path
)
Visual Basic (Declaration)
Public Shared Function GetDirectoryAccessControl ( _
    path As String _
) As DirectorySecurity
Visual C++
public:
static DirectorySecurity^ GetDirectoryAccessControl(
    String^ path
)

Parameters

path
Type: System..::.String

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
Mincom.LinkOne.Common Namespace


GetDirectoryName Method

[image]

LinkOne WebView API
SafeIO..::.GetDirectoryName Method
SafeIO Class See Also Send Feedback
Wrapper for GetDirectoryName(String).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static string GetDirectoryName(
    string path
)
Visual Basic (Declaration)
Public Shared Function GetDirectoryName ( _
    path As String _
) As String
Visual C++
public:
static String^ GetDirectoryName(
    String^ path
)

Parameters

path
Type: System..::.String

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
Mincom.LinkOne.Common Namespace


GetFileAccessControl Method

[image]

LinkOne WebView API
SafeIO..::.GetFileAccessControl Method
SafeIO Class See Also Send Feedback
Wrapper for GetAccessControl(String).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static FileSecurity GetFileAccessControl(
    string path
)
Visual Basic (Declaration)
Public Shared Function GetFileAccessControl ( _
    path As String _
) As FileSecurity
Visual C++
public:
static FileSecurity^ GetFileAccessControl(
    String^ path
)

Parameters

path
Type: System..::.String

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
Mincom.LinkOne.Common Namespace


GetFileLength Method

[image]

LinkOne WebView API
SafeIO..::.GetFileLength Method
SafeIO Class See Also Send Feedback
Gets the length of the file.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static long GetFileLength(
    string path
)
Visual Basic (Declaration)
Public Shared Function GetFileLength ( _
    path As String _
) As Long
Visual C++
public:
static long long GetFileLength(
    String^ path
)

Parameters

path
Type: System..::.String
The path.

Return Value

The length of the file

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
Mincom.LinkOne.Common Namespace


GetFileName Method

[image]

LinkOne WebView API
SafeIO..::.GetFileName Method
SafeIO Class See Also Send Feedback
Wrapper for GetFiles(String, String, SearchOption).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static string GetFileName(
    string path
)
Visual Basic (Declaration)
Public Shared Function GetFileName ( _
    path As String _
) As String
Visual C++
public:
static String^ GetFileName(
    String^ path
)

Parameters

path
Type: System..::.String

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
Mincom.LinkOne.Common Namespace


GetFiles Method

[image] [image]

LinkOne WebView API
SafeIO..::.GetFiles Method
SafeIO Class See Also Send Feedback

Overload List

Name | Description
GetFiles(String) | Wrapper for GetFiles(String).
GetFiles(String, String) | Wrapper for GetFiles(String, String).
GetFiles(String, String, SearchOption) | Wrapper for GetFiles(String, String, SearchOption).

See Also

SafeIO Class
SafeIO Members
Mincom.LinkOne.Common Namespace


GetFiles Method (String)

[image]

LinkOne WebView API
SafeIO..::.GetFiles Method (String)
SafeIO Class See Also Send Feedback
Wrapper for GetFiles(String).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static string[] GetFiles(
    string path
)
Visual Basic (Declaration)
Public Shared Function GetFiles ( _
    path As String _
) As String()
Visual C++
public:
static array<String^>^ GetFiles(
    String^ path
)

Parameters

path
Type: System..::.String

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
GetFiles Overload
Mincom.LinkOne.Common Namespace


GetFiles Method (String, String)

[image]

LinkOne WebView API
SafeIO..::.GetFiles Method (String, String)
SafeIO Class See Also Send Feedback
Wrapper for GetFiles(String, String).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static string[] GetFiles(
    string path,
    string searchPattern
)
Visual Basic (Declaration)
Public Shared Function GetFiles ( _
    path As String, _
    searchPattern As String _
) As String()
Visual C++
public:
static array<String^>^ GetFiles(
    String^ path,
    String^ searchPattern
)

Parameters

path
Type: System..::.String
searchPattern
Type: System..::.String

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
GetFiles Overload
Mincom.LinkOne.Common Namespace


GetFiles Method (String, String, SearchOption)

[image]

LinkOne WebView API
SafeIO..::.GetFiles Method (String, String, SearchOption)
SafeIO Class See Also Send Feedback
Wrapper for GetFiles(String, String, SearchOption).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static string[] GetFiles(
    string path,
    string searchPattern,
    SearchOption searchOption
)
Visual Basic (Declaration)
Public Shared Function GetFiles ( _
    path As String, _
    searchPattern As String, _
    searchOption As SearchOption _
) As String()
Visual C++
public:
static array<String^>^ GetFiles(
    String^ path,
    String^ searchPattern,
    SearchOption searchOption
)

Parameters

path
Type: System..::.String
searchPattern
Type: System..::.String
searchOption
Type: System.IO..::.SearchOption

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
GetFiles Overload
Mincom.LinkOne.Common Namespace


GetFullPath Method

[image]

LinkOne WebView API
SafeIO..::.GetFullPath Method
SafeIO Class See Also Send Feedback
Wrapper for GetFullPath(String).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static string GetFullPath(
    string path
)
Visual Basic (Declaration)
Public Shared Function GetFullPath ( _
    path As String _
) As String
Visual C++
public:
static String^ GetFullPath(
    String^ path
)

Parameters

path
Type: System..::.String

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
Mincom.LinkOne.Common Namespace


GetLastWriteTime Method

[image]

LinkOne WebView API
SafeIO..::.GetLastWriteTime Method
SafeIO Class See Also Send Feedback
Wrapper for GetLastWriteTime(String).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static DateTime GetLastWriteTime(
    string path
)
Visual Basic (Declaration)
Public Shared Function GetLastWriteTime ( _
    path As String _
) As DateTime
Visual C++
public:
static DateTime GetLastWriteTime(
    String^ path
)

Parameters

path
Type: System..::.String

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
Mincom.LinkOne.Common Namespace


GetLastWriteTimeUtc Method

[image]

LinkOne WebView API
SafeIO..::.GetLastWriteTimeUtc Method
SafeIO Class See Also Send Feedback
Wrapper for GetLastWriteTimeUtc(String).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static DateTime GetLastWriteTimeUtc(
    string path
)
Visual Basic (Declaration)
Public Shared Function GetLastWriteTimeUtc ( _
    path As String _
) As DateTime
Visual C++
public:
static DateTime GetLastWriteTimeUtc(
    String^ path
)

Parameters

path
Type: System..::.String

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
Mincom.LinkOne.Common Namespace


GetTempFileName Method

[image]

LinkOne WebView API
SafeIO..::.GetTempFileName Method
SafeIO Class See Also Send Feedback
Creates a uniquely named, zero-byte temporary file on disk and returns the full path of that file.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static string GetTempFileName()
Visual Basic (Declaration)
Public Shared Function GetTempFileName As String
Visual C++
public:
static String^ GetTempFileName()

Return Value

A uniquely named, zero-byte temporary file on disk.

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
Mincom.LinkOne.Common Namespace


GetTempPath Method

[image]

LinkOne WebView API
SafeIO..::.GetTempPath Method
SafeIO Class See Also Send Feedback
Wrapper for GetTempPath()()().

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static string GetTempPath()
Visual Basic (Declaration)
Public Shared Function GetTempPath As String
Visual C++
public:
static String^ GetTempPath()

Return Value

The path to the current system's temporary folder.

See Also

SafeIO Class
Mincom.LinkOne.Common Namespace


MoveFile Method

[image] [image]

LinkOne WebView API
SafeIO..::.MoveFile Method
SafeIO Class See Also Send Feedback

Overload List

Name | Description
MoveFile(String, String) | Wrapper for Move(String, String).
MoveFile(String, String, Int32) | Wrapper for Move(String, String).

See Also

SafeIO Class
SafeIO Members
Mincom.LinkOne.Common Namespace


MoveFile Method (String, String)

[image]

LinkOne WebView API
SafeIO..::.MoveFile Method (String, String)
SafeIO Class See Also Send Feedback
Wrapper for Move(String, String).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void MoveFile(
    string source,
    string target
)
Visual Basic (Declaration)
Public Shared Sub MoveFile ( _
    source As String, _
    target As String _
)
Visual C++
public:
static void MoveFile(
    String^ source,
    String^ target
)

Parameters

source
Type: System..::.String
The name of the file to be moved.
target
Type: System..::.String
The target file name.

See Also

SafeIO Class
MoveFile Overload
Mincom.LinkOne.Common Namespace


MoveFile Method (String, String, Int32)

[image]

LinkOne WebView API
SafeIO..::.MoveFile Method (String, String, Int32)
SafeIO Class See Also Send Feedback
Wrapper for Move(String, String).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void MoveFile(
    string source,
    string target,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Shared Sub MoveFile ( _
    source As String, _
    target As String, _
    retryMilliseconds As Integer _
)
Visual C++
public:
static void MoveFile(
    String^ source,
    String^ target,
    int retryMilliseconds
)

Parameters

source
Type: System..::.String
The name of the file to be moved.
target
Type: System..::.String
The target file name.
retryMilliseconds
Type: System..::.Int32
The number of milliseconds to retry moving the file, if the source or target is locked.

See Also

SafeIO Class
MoveFile Overload
Mincom.LinkOne.Common Namespace


Open Method

[image] [image]

LinkOne WebView API
SafeIO..::.Open Method
SafeIO Class See Also Send Feedback

Overload List

Name | Description
Open(String, FileMode) | Wrapper for Open(String, FileMode).
Open(String, FileMode, Int32) | Wrapper for Open(String, FileMode, FileAccess, FileShare).
Open(String, FileMode, FileAccess, FileShare) | Wrapper for Open(String, FileMode, FileAccess, FileShare).
Open(String, FileMode, FileAccess, FileShare, Int32) | Wrapper for Open(String, FileMode, FileAccess, FileShare).
Open(String, FileMode, FileAccess, FileShare, Int32, FileOptions, Int32) | Wrapper for FileStream(String, FileMode, FileAccess, FileShare, Int32, FileOptions) constructor.

See Also

SafeIO Class
SafeIO Members
Mincom.LinkOne.Common Namespace


Open Method (String, FileMode)

[image]

LinkOne WebView API
SafeIO..::.Open Method (String, FileMode)
SafeIO Class See Also Send Feedback
Wrapper for Open(String, FileMode).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static FileStream Open(
    string path,
    FileMode mode
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    path As String, _
    mode As FileMode _
) As FileStream
Visual C++
public:
static FileStream^ Open(
    String^ path,
    FileMode mode
)

Parameters

path
Type: System..::.String
mode
Type: System.IO..::.FileMode

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
Open Overload
Mincom.LinkOne.Common Namespace


Open Method (String, FileMode, Int32)

[image]

LinkOne WebView API
SafeIO..::.Open Method (String, FileMode, Int32)
SafeIO Class See Also Send Feedback
Wrapper for Open(String, FileMode, FileAccess, FileShare).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static FileStream Open(
    string path,
    FileMode mode,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    path As String, _
    mode As FileMode, _
    retryMilliseconds As Integer _
) As FileStream
Visual C++
public:
static FileStream^ Open(
    String^ path,
    FileMode mode,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
The path.
mode
Type: System.IO..::.FileMode
The mode.
retryMilliseconds
Type: System..::.Int32
The number of milliseconds to retry for to open the file if it is locked by another process.

Return Value

The File Stream, or null if none could be opened

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
Open Overload
Mincom.LinkOne.Common Namespace


Open Method (String, FileMode, FileAccess, FileShare)

[image]

LinkOne WebView API
SafeIO..::.Open Method (String, FileMode, FileAccess, FileShare)
SafeIO Class See Also Send Feedback
Wrapper for Open(String, FileMode, FileAccess, FileShare).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static FileStream Open(
    string path,
    FileMode mode,
    FileAccess access,
    FileShare share
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    path As String, _
    mode As FileMode, _
    access As FileAccess, _
    share As FileShare _
) As FileStream
Visual C++
public:
static FileStream^ Open(
    String^ path,
    FileMode mode,
    FileAccess access,
    FileShare share
)

Parameters

path
Type: System..::.String
mode
Type: System.IO..::.FileMode
access
Type: System.IO..::.FileAccess
share
Type: System.IO..::.FileShare

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
Open Overload
Mincom.LinkOne.Common Namespace


Open Method (String, FileMode, FileAccess, FileShare, Int32)

[image]

LinkOne WebView API
SafeIO..::.Open Method (String, FileMode, FileAccess, FileShare, Int32)
SafeIO Class See Also Send Feedback
Wrapper for Open(String, FileMode, FileAccess, FileShare).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static FileStream Open(
    string path,
    FileMode mode,
    FileAccess access,
    FileShare share,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    path As String, _
    mode As FileMode, _
    access As FileAccess, _
    share As FileShare, _
    retryMilliseconds As Integer _
) As FileStream
Visual C++
public:
static FileStream^ Open(
    String^ path,
    FileMode mode,
    FileAccess access,
    FileShare share,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
The path to open.
mode
Type: System.IO..::.FileMode
The mode to open with.
access
Type: System.IO..::.FileAccess
The access to be granted.
share
Type: System.IO..::.FileShare
The share.
retryMilliseconds
Type: System..::.Int32
The number of milliseconds to retry for to open the file if it is locked by another process.

Return Value

The File Stream, or null if none could be opened

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
Open Overload
Mincom.LinkOne.Common Namespace


Open Method (String, FileMode, FileAccess, FileShare, Int32, FileOptions, Int32)

[image]

LinkOne WebView API
SafeIO..::.Open Method (String, FileMode, FileAccess, FileShare, Int32, FileOptions, Int32)
SafeIO Class See Also Send Feedback
Wrapper for FileStream(String, FileMode, FileAccess, FileShare, Int32, FileOptions) constructor.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static FileStream Open(
    string path,
    FileMode mode,
    FileAccess access,
    FileShare share,
    int bufferSize,
    FileOptions options,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    path As String, _
    mode As FileMode, _
    access As FileAccess, _
    share As FileShare, _
    bufferSize As Integer, _
    options As FileOptions, _
    retryMilliseconds As Integer _
) As FileStream
Visual C++
public:
static FileStream^ Open(
    String^ path,
    FileMode mode,
    FileAccess access,
    FileShare share,
    int bufferSize,
    FileOptions options,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
The path to open.
mode
Type: System.IO..::.FileMode
The mode to open with.
access
Type: System.IO..::.FileAccess
The access to be granted.
share
Type: System.IO..::.FileShare
The share.
bufferSize
Type: System..::.Int32
A positive Int32 value greater than 0 indicating the buffer size. For bufferSize values between one and eight, the actual buffer size is set to eight bytes.
options
Type: System.IO..::.FileOptions
A FileOptions value that specifies additional file options.
retryMilliseconds
Type: System..::.Int32
The number of milliseconds to retry for to open the file if it is locked by another process.

Return Value

The File Stream, or null if none could be opened

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
Open Overload
Mincom.LinkOne.Common Namespace


OpenRead Method

[image] [image]

LinkOne WebView API
SafeIO..::.OpenRead Method
SafeIO Class See Also Send Feedback

Overload List

Name | Description
OpenRead(String) | Wrapper for Open(String, FileMode, FileAccess, FileShare).
OpenRead(String, Int32) | Wrapper for Open(String, FileMode, FileAccess, FileShare).

See Also

SafeIO Class
SafeIO Members
Mincom.LinkOne.Common Namespace


OpenRead Method (String)

[image]

LinkOne WebView API
SafeIO..::.OpenRead Method (String)
SafeIO Class See Also Send Feedback
Wrapper for Open(String, FileMode, FileAccess, FileShare).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static FileStream OpenRead(
    string path
)
Visual Basic (Declaration)
Public Shared Function OpenRead ( _
    path As String _
) As FileStream
Visual C++
public:
static FileStream^ OpenRead(
    String^ path
)

Parameters

path
Type: System..::.String

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
OpenRead Overload
Mincom.LinkOne.Common Namespace


OpenRead Method (String, Int32)

[image]

LinkOne WebView API
SafeIO..::.OpenRead Method (String, Int32)
SafeIO Class See Also Send Feedback
Wrapper for Open(String, FileMode, FileAccess, FileShare).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static FileStream OpenRead(
    string path,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Shared Function OpenRead ( _
    path As String, _
    retryMilliseconds As Integer _
) As FileStream
Visual C++
public:
static FileStream^ OpenRead(
    String^ path,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
The path.
retryMilliseconds
Type: System..::.Int32
The number of milliseconds to retry for to open the file if it is locked by another process.

Return Value

The File Stream, or null if none could be opened

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
OpenRead Overload
Mincom.LinkOne.Common Namespace


ReadAllBytes Method

[image] [image]

LinkOne WebView API
SafeIO..::.ReadAllBytes Method
SafeIO Class See Also Send Feedback

Overload List

Name | Description
ReadAllBytes(String) | Wrapper for ReadAllBytes(String).
ReadAllBytes(String, Int32) | Wrapper for ReadAllBytes(String).

See Also

SafeIO Class
SafeIO Members
Mincom.LinkOne.Common Namespace


ReadAllBytes Method (String)

[image]

LinkOne WebView API
SafeIO..::.ReadAllBytes Method (String)
SafeIO Class See Also Send Feedback
Wrapper for ReadAllBytes(String).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static byte[] ReadAllBytes(
    string path
)
Visual Basic (Declaration)
Public Shared Function ReadAllBytes ( _
    path As String _
) As Byte()
Visual C++
public:
static array<unsigned char>^ ReadAllBytes(
    String^ path
)

Parameters

path
Type: System..::.String

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
ReadAllBytes Overload
Mincom.LinkOne.Common Namespace


ReadAllBytes Method (String, Int32)

[image]

LinkOne WebView API
SafeIO..::.ReadAllBytes Method (String, Int32)
SafeIO Class See Also Send Feedback
Wrapper for ReadAllBytes(String).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static byte[] ReadAllBytes(
    string path,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Shared Function ReadAllBytes ( _
    path As String, _
    retryMilliseconds As Integer _
) As Byte()
Visual C++
public:
static array<unsigned char>^ ReadAllBytes(
    String^ path,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
The path to read from.
retryMilliseconds
Type: System..::.Int32
The number of milliseconds to retry for, if the file is locked.

Return Value

The read bytes, or null if none read.

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
ReadAllBytes Overload
Mincom.LinkOne.Common Namespace


ReadAllText Method

[image] [image]

LinkOne WebView API
SafeIO..::.ReadAllText Method
SafeIO Class See Also Send Feedback

Overload List

Name | Description
ReadAllText(String) | Wrapper for ReadAllText(String).
ReadAllText(String, Int32) | Wrapper for ReadAllText(String).
ReadAllText(String, Encoding) | Wrapper for ReadAllText(String, Encoding).
ReadAllText(String, Encoding, Int32) | Wrapper for ReadAllText(String, Encoding).

See Also

SafeIO Class
SafeIO Members
Mincom.LinkOne.Common Namespace


ReadAllText Method (String)

[image]

LinkOne WebView API
SafeIO..::.ReadAllText Method (String)
SafeIO Class See Also Send Feedback
Wrapper for ReadAllText(String).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static string ReadAllText(
    string path
)
Visual Basic (Declaration)
Public Shared Function ReadAllText ( _
    path As String _
) As String
Visual C++
public:
static String^ ReadAllText(
    String^ path
)

Parameters

path
Type: System..::.String
The path to read.

Return Value

The read text, or null if no text

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurs.

See Also

SafeIO Class
ReadAllText Overload
Mincom.LinkOne.Common Namespace


ReadAllText Method (String, Int32)

[image]

LinkOne WebView API
SafeIO..::.ReadAllText Method (String, Int32)
SafeIO Class See Also Send Feedback
Wrapper for ReadAllText(String).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static string ReadAllText(
    string path,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Shared Function ReadAllText ( _
    path As String, _
    retryMilliseconds As Integer _
) As String
Visual C++
public:
static String^ ReadAllText(
    String^ path,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
The path to read.
retryMilliseconds
Type: System..::.Int32
The number milliseconds to retry reading for, if the file is locked.

Return Value

The read text, or null if no text

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurs.

See Also

SafeIO Class
ReadAllText Overload
Mincom.LinkOne.Common Namespace


ReadAllText Method (String, Encoding)

[image]

LinkOne WebView API
SafeIO..::.ReadAllText Method (String, Encoding)
SafeIO Class See Also Send Feedback
Wrapper for ReadAllText(String, Encoding).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static string ReadAllText(
    string path,
    Encoding encoding
)
Visual Basic (Declaration)
Public Shared Function ReadAllText ( _
    path As String, _
    encoding As Encoding _
) As String
Visual C++
public:
static String^ ReadAllText(
    String^ path,
    Encoding^ encoding
)

Parameters

path
Type: System..::.String
encoding
Type: System.Text..::.Encoding

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurs.

See Also

SafeIO Class
ReadAllText Overload
Mincom.LinkOne.Common Namespace


ReadAllText Method (String, Encoding, Int32)

[image]

LinkOne WebView API
SafeIO..::.ReadAllText Method (String, Encoding, Int32)
SafeIO Class See Also Send Feedback
Wrapper for ReadAllText(String, Encoding).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static string ReadAllText(
    string path,
    Encoding encoding,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Shared Function ReadAllText ( _
    path As String, _
    encoding As Encoding, _
    retryMilliseconds As Integer _
) As String
Visual C++
public:
static String^ ReadAllText(
    String^ path,
    Encoding^ encoding,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
The path to read.
encoding
Type: System.Text..::.Encoding
The encoding to read with.
retryMilliseconds
Type: System..::.Int32
The number milliseconds to retry reading for, if the file is locked.

Return Value

The read text, or null if no text

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurs.

See Also

SafeIO Class
ReadAllText Overload
Mincom.LinkOne.Common Namespace


ReadLine Method

[image]

LinkOne WebView API
SafeIO..::.ReadLine Method
SafeIO Class See Also Send Feedback
Wrapper for ReadLine()()().

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static string ReadLine(
    TextReader reader
)
Visual Basic (Declaration)
Public Shared Function ReadLine ( _
    reader As TextReader _
) As String
Visual C++
public:
static String^ ReadLine(
    TextReader^ reader
)

Parameters

reader
Type: System.IO..::.TextReader

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
Mincom.LinkOne.Common Namespace


ReadToEnd Method

[image]

LinkOne WebView API
SafeIO..::.ReadToEnd Method
SafeIO Class See Also Send Feedback
Wrapper for ReadToEnd()()().

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static string ReadToEnd(
    TextReader reader
)
Visual Basic (Declaration)
Public Shared Function ReadToEnd ( _
    reader As TextReader _
) As String
Visual C++
public:
static String^ ReadToEnd(
    TextReader^ reader
)

Parameters

reader
Type: System.IO..::.TextReader

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
Mincom.LinkOne.Common Namespace


Seek Method

[image]

LinkOne WebView API
SafeIO..::.Seek Method
SafeIO Class See Also Send Feedback
Wrapper for Seek(Int64, SeekOrigin).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static long Seek(
    Stream stream,
    long offset,
    SeekOrigin origin
)
Visual Basic (Declaration)
Public Shared Function Seek ( _
    stream As Stream, _
    offset As Long, _
    origin As SeekOrigin _
) As Long
Visual C++
public:
static long long Seek(
    Stream^ stream,
    long long offset,
    SeekOrigin origin
)

Parameters

stream
Type: System.IO..::.Stream
offset
Type: System..::.Int64
origin
Type: System.IO..::.SeekOrigin

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
Mincom.LinkOne.Common Namespace


SetAttributes Method

[image]

LinkOne WebView API
SafeIO..::.SetAttributes Method
SafeIO Class See Also Send Feedback
Wrapper for SetAttributes(String, FileAttributes).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void SetAttributes(
    string path,
    FileAttributes fileAttributes
)
Visual Basic (Declaration)
Public Shared Sub SetAttributes ( _
    path As String, _
    fileAttributes As FileAttributes _
)
Visual C++
public:
static void SetAttributes(
    String^ path,
    FileAttributes fileAttributes
)

Parameters

path
Type: System..::.String
fileAttributes
Type: System.IO..::.FileAttributes

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
Mincom.LinkOne.Common Namespace


SetLastWriteTime Method

[image] [image]

LinkOne WebView API
SafeIO..::.SetLastWriteTime Method
SafeIO Class See Also Send Feedback

Overload List

Name | Description
SetLastWriteTime(String, DateTime) | Wrapper for SetLastWriteTime(String, DateTime).
SetLastWriteTime(String, DateTime, Int32) | Wrapper for SetLastWriteTime(String, DateTime).

See Also

SafeIO Class
SafeIO Members
Mincom.LinkOne.Common Namespace


SetLastWriteTime Method (String, DateTime)

[image]

LinkOne WebView API
SafeIO..::.SetLastWriteTime Method (String, DateTime)
SafeIO Class See Also Send Feedback
Wrapper for SetLastWriteTime(String, DateTime).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void SetLastWriteTime(
    string fileName,
    DateTime dateTime
)
Visual Basic (Declaration)
Public Shared Sub SetLastWriteTime ( _
    fileName As String, _
    dateTime As DateTime _
)
Visual C++
public:
static void SetLastWriteTime(
    String^ fileName,
    DateTime dateTime
)

Parameters

fileName
Type: System..::.String
dateTime
Type: System..::.DateTime

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
SetLastWriteTime Overload
Mincom.LinkOne.Common Namespace


SetLastWriteTime Method (String, DateTime, Int32)

[image]

LinkOne WebView API
SafeIO..::.SetLastWriteTime Method (String, DateTime, Int32)
SafeIO Class See Also Send Feedback
Wrapper for SetLastWriteTime(String, DateTime).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void SetLastWriteTime(
    string fileName,
    DateTime dateTime,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Shared Sub SetLastWriteTime ( _
    fileName As String, _
    dateTime As DateTime, _
    retryMilliseconds As Integer _
)
Visual C++
public:
static void SetLastWriteTime(
    String^ fileName,
    DateTime dateTime,
    int retryMilliseconds
)

Parameters

fileName
Type: System..::.String
Name of the file to set the time on.
dateTime
Type: System..::.DateTime
The time stamp to set.
retryMilliseconds
Type: System..::.Int32
The number of milliseconds to retry for, incase the file is locked.

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
SetLastWriteTime Overload
Mincom.LinkOne.Common Namespace


SetLastWriteTimeUtc Method

[image] [image]

LinkOne WebView API
SafeIO..::.SetLastWriteTimeUtc Method
SafeIO Class See Also Send Feedback

Overload List

Name | Description
SetLastWriteTimeUtc(String, DateTime) | Wrapper for SetLastWriteTimeUtc(String, DateTime).
SetLastWriteTimeUtc(String, DateTime, Int32) | Wrapper for SetLastWriteTimeUtc(String, DateTime).

See Also

SafeIO Class
SafeIO Members
Mincom.LinkOne.Common Namespace


SetLastWriteTimeUtc Method (String, DateTime)

[image]

LinkOne WebView API
SafeIO..::.SetLastWriteTimeUtc Method (String, DateTime)
SafeIO Class See Also Send Feedback
Wrapper for SetLastWriteTimeUtc(String, DateTime).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void SetLastWriteTimeUtc(
    string path,
    DateTime dateTime
)
Visual Basic (Declaration)
Public Shared Sub SetLastWriteTimeUtc ( _
    path As String, _
    dateTime As DateTime _
)
Visual C++
public:
static void SetLastWriteTimeUtc(
    String^ path,
    DateTime dateTime
)

Parameters

path
Type: System..::.String
dateTime
Type: System..::.DateTime

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
SetLastWriteTimeUtc Overload
Mincom.LinkOne.Common Namespace


SetLastWriteTimeUtc Method (String, DateTime, Int32)

[image]

LinkOne WebView API
SafeIO..::.SetLastWriteTimeUtc Method (String, DateTime, Int32)
SafeIO Class See Also Send Feedback
Wrapper for SetLastWriteTimeUtc(String, DateTime).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void SetLastWriteTimeUtc(
    string path,
    DateTime dateTime,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Shared Sub SetLastWriteTimeUtc ( _
    path As String, _
    dateTime As DateTime, _
    retryMilliseconds As Integer _
)
Visual C++
public:
static void SetLastWriteTimeUtc(
    String^ path,
    DateTime dateTime,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
The path the path to set the write time on.
dateTime
Type: System..::.DateTime
The timestamp to set.
retryMilliseconds
Type: System..::.Int32
The number of milliseconds to retry for, incase the file is locked.

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
SetLastWriteTimeUtc Overload
Mincom.LinkOne.Common Namespace


SetLength Method

[image]

LinkOne WebView API
SafeIO..::.SetLength Method
SafeIO Class See Also Send Feedback
Wrapper for SetLength(Int64).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void SetLength(
    Stream stream,
    long value
)
Visual Basic (Declaration)
Public Shared Sub SetLength ( _
    stream As Stream, _
    value As Long _
)
Visual C++
public:
static void SetLength(
    Stream^ stream,
    long long value
)

Parameters

stream
Type: System.IO..::.Stream
value
Type: System..::.Int64

See Also

SafeIO Class
Mincom.LinkOne.Common Namespace


ValidateTimeStamp Method

[image]

LinkOne WebView API
SafeIO..::.ValidateTimeStamp Method
SafeIO Class See Also Send Feedback
Ensures that the timestamp for the given path is valid.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static bool ValidateTimeStamp(
    string path
)
Visual Basic (Declaration)
Public Shared Function ValidateTimeStamp ( _
    path As String _
) As Boolean
Visual C++
public:
static bool ValidateTimeStamp(
    String^ path
)

Parameters

path
Type: System..::.String
Path to validate the timestamp for.

Return Value

False if the path does not exists.

Remarks

For network paths, NTFS sometimes caches the timestamp. This function attempts to open the path ensuring the timestamp is up to date.

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred. This does not include if the file does not exists.

See Also

SafeIO Class
Mincom.LinkOne.Common Namespace


Write Method

[image]

LinkOne WebView API
SafeIO..::.Write Method
SafeIO Class See Also Send Feedback
Wrapper for Write(String).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void Write(
    TextWriter writer,
    string contents
)
Visual Basic (Declaration)
Public Shared Sub Write ( _
    writer As TextWriter, _
    contents As String _
)
Visual C++
public:
static void Write(
    TextWriter^ writer,
    String^ contents
)

Parameters

writer
Type: System.IO..::.TextWriter
contents
Type: System..::.String

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
Mincom.LinkOne.Common Namespace


WriteAllBytes Method

[image] [image]

LinkOne WebView API
SafeIO..::.WriteAllBytes Method
SafeIO Class See Also Send Feedback

Overload List

Name | Description
WriteAllBytes(String, array<Byte>[]()[]) | Wrapper for WriteAllBytes(String, array<Byte>[]()[]).
WriteAllBytes(String, array<Byte>[]()[], Nullable<(Of <(DateTime>)>), Int32) | Wrapper for WriteAllBytes(String, array<Byte>[]()[]).

See Also

SafeIO Class
SafeIO Members
Mincom.LinkOne.Common Namespace


WriteAllBytes Method (String, Byte[])

[image]

LinkOne WebView API
SafeIO..::.WriteAllBytes Method (String, array<Byte>[]()[])
SafeIO Class See Also Send Feedback
Wrapper for WriteAllBytes(String, array<Byte>[]()[]).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void WriteAllBytes(
    string path,
    byte[] bytes
)
Visual Basic (Declaration)
Public Shared Sub WriteAllBytes ( _
    path As String, _
    bytes As Byte() _
)
Visual C++
public:
static void WriteAllBytes(
    String^ path,
    array<unsigned char>^ bytes
)

Parameters

path
Type: System..::.String
bytes
Type: array< System..::.Byte >[]()[]

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
WriteAllBytes Overload
Mincom.LinkOne.Common Namespace


WriteAllBytes Method (String, Byte[], Nullable(DateTime), Int32)

[image]

LinkOne WebView API
SafeIO..::.WriteAllBytes Method (String, array<Byte>[]()[], Nullable<(Of <(DateTime>)>), Int32)
SafeIO Class See Also Send Feedback
Wrapper for WriteAllBytes(String, array<Byte>[]()[]).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void WriteAllBytes(
    string path,
    byte[] bytes,
    Nullable<DateTime> lastModifiedTime,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Shared Sub WriteAllBytes ( _
    path As String, _
    bytes As Byte(), _
    lastModifiedTime As Nullable(Of DateTime), _
    retryMilliseconds As Integer _
)
Visual C++
public:
static void WriteAllBytes(
    String^ path,
    array<unsigned char>^ bytes,
    Nullable<DateTime> lastModifiedTime,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
The path to write to.
bytes
Type: array< System..::.Byte >[]()[]
The bytes to write.
lastModifiedTime
Type: System..::.Nullable<(Of <(DateTime>)>)
any last-write time to stamp the file with.
retryMilliseconds
Type: System..::.Int32
The number of milliseconds to retry writing the file for if it is locked.

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
WriteAllBytes Overload
Mincom.LinkOne.Common Namespace


WriteAllText Method

[image] [image]

LinkOne WebView API
SafeIO..::.WriteAllText Method
SafeIO Class See Also Send Feedback

Overload List

Name | Description
WriteAllText(String, String, Encoding) | Wrapper for WriteAllText(String, String, Encoding).
WriteAllText(String, String, Encoding, Int32) | Wrapper for WriteAllText(String, String, Encoding).

See Also

SafeIO Class
SafeIO Members
Mincom.LinkOne.Common Namespace


WriteAllText Method (String, String, Encoding)

[image]

LinkOne WebView API
SafeIO..::.WriteAllText Method (String, String, Encoding)
SafeIO Class See Also Send Feedback
Wrapper for WriteAllText(String, String, Encoding).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void WriteAllText(
    string path,
    string contents,
    Encoding encoding
)
Visual Basic (Declaration)
Public Shared Sub WriteAllText ( _
    path As String, _
    contents As String, _
    encoding As Encoding _
)
Visual C++
public:
static void WriteAllText(
    String^ path,
    String^ contents,
    Encoding^ encoding
)

Parameters

path
Type: System..::.String
contents
Type: System..::.String
encoding
Type: System.Text..::.Encoding

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
WriteAllText Overload
Mincom.LinkOne.Common Namespace


WriteAllText Method (String, String, Encoding, Int32)

[image]

LinkOne WebView API
SafeIO..::.WriteAllText Method (String, String, Encoding, Int32)
SafeIO Class See Also Send Feedback
Wrapper for WriteAllText(String, String, Encoding).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void WriteAllText(
    string path,
    string contents,
    Encoding encoding,
    int retryMilliseconds
)
Visual Basic (Declaration)
Public Shared Sub WriteAllText ( _
    path As String, _
    contents As String, _
    encoding As Encoding, _
    retryMilliseconds As Integer _
)
Visual C++
public:
static void WriteAllText(
    String^ path,
    String^ contents,
    Encoding^ encoding,
    int retryMilliseconds
)

Parameters

path
Type: System..::.String
The path to write to.
contents
Type: System..::.String
The contents to write.
encoding
Type: System.Text..::.Encoding
The encoding to use.
retryMilliseconds
Type: System..::.Int32
The number of milliseconds to retry writing for if the file is locked.

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
WriteAllText Overload
Mincom.LinkOne.Common Namespace


WriteLine Method

[image]

LinkOne WebView API
SafeIO..::.WriteLine Method
SafeIO Class See Also Send Feedback
Wrapper for WriteLine(String).

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void WriteLine(
    TextWriter writer,
    string contents
)
Visual Basic (Declaration)
Public Shared Sub WriteLine ( _
    writer As TextWriter, _
    contents As String _
)
Visual C++
public:
static void WriteLine(
    TextWriter^ writer,
    String^ contents
)

Parameters

writer
Type: System.IO..::.TextWriter
contents
Type: System..::.String

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurred.

See Also

SafeIO Class
Mincom.LinkOne.Common Namespace


StrongNameIdentity Class

[image]

LinkOne WebView API
StrongNameIdentity Class
Members See Also Send Feedback
This class contains constants relating to the LinkOne Strong Name

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static class StrongNameIdentity
Visual Basic (Declaration)
Public NotInheritable Class StrongNameIdentity
Visual C++
public ref class StrongNameIdentity abstract sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Common..::.StrongNameIdentity

See Also

StrongNameIdentity Members
Mincom.LinkOne.Common Namespace


StrongNameIdentity Members

[image] [image]

LinkOne WebView API
StrongNameIdentity Members
StrongNameIdentity Class Fields Properties See Also Send Feedback

The StrongNameIdentity type exposes the following members.

Fields

Name | Description
PublicKey | Gets the public key.

Properties

Name | Description
PublicKeyBlob | Gets the public key BLOB.

See Also

StrongNameIdentity Class
Mincom.LinkOne.Common Namespace


StrongNameIdentity Fields

[image] [image]

LinkOne WebView API
StrongNameIdentity Fields
StrongNameIdentity Class See Also Send Feedback

The StrongNameIdentity type exposes the following members.

Fields

Name | Description
PublicKey | Gets the public key.

See Also

StrongNameIdentity Class
Mincom.LinkOne.Common Namespace


PublicKey Field

[image]

LinkOne WebView API
StrongNameIdentity..::.PublicKey Field
StrongNameIdentity Class See Also Send Feedback
Gets the public key.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public const string PublicKey
Visual Basic (Declaration)
Public Const PublicKey As String
Visual C++
public:
literal String^ PublicKey

See Also

StrongNameIdentity Class
Mincom.LinkOne.Common Namespace


StrongNameIdentity Properties

[image] [image]

LinkOne WebView API
StrongNameIdentity Properties
StrongNameIdentity Class See Also Send Feedback

The StrongNameIdentity type exposes the following members.

Properties

Name | Description
PublicKeyBlob | Gets the public key BLOB.

See Also

StrongNameIdentity Class
Mincom.LinkOne.Common Namespace


PublicKeyBlob Property

[image]

LinkOne WebView API
StrongNameIdentity..::.PublicKeyBlob Property
StrongNameIdentity Class See Also Send Feedback
Gets the public key BLOB.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static StrongNamePublicKeyBlob PublicKeyBlob { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PublicKeyBlob As StrongNamePublicKeyBlob
Visual C++
public:
static property StrongNamePublicKeyBlob^ PublicKeyBlob {
    StrongNamePublicKeyBlob^ get ();
}

See Also

StrongNameIdentity Class
Mincom.LinkOne.Common Namespace


Tracing Class

[image]

LinkOne WebView API
Tracing Class
Members See Also Send Feedback
Provides tracing facilities.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static class Tracing
Visual Basic (Declaration)
Public NotInheritable Class Tracing
Visual C++
public ref class Tracing abstract sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Common..::.Tracing

See Also

Tracing Members
Mincom.LinkOne.Common Namespace


Tracing Members

[image] [image]

LinkOne WebView API
Tracing Members
Tracing Class Methods See Also Send Feedback

The Tracing type exposes the following members.

Methods

Name | Description
TraceCall | Writes the given format string preceded by the caller details.
TraceDump |
TraceDumpLines |
TraceError | Overloaded.

See Also

Tracing Class
Mincom.LinkOne.Common Namespace


Tracing Methods

[image] [image]

LinkOne WebView API
Tracing Methods
Tracing Class See Also Send Feedback

The Tracing type exposes the following members.

Methods

Name | Description
TraceCall | Writes the given format string preceded by the caller details.
TraceDump |
TraceDumpLines |
TraceError | Overloaded.

See Also

Tracing Class
Mincom.LinkOne.Common Namespace


TraceCall Method

[image]

LinkOne WebView API
Tracing..::.TraceCall Method
Tracing Class See Also Send Feedback
Writes the given format string preceded by the caller details.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void TraceCall(
    TraceLevel traceLevel,
    string format,
    params Object[] args
)
Visual Basic (Declaration)
Public Shared Sub TraceCall ( _
    traceLevel As TraceLevel, _
    format As String, _
    ParamArray args As Object() _
)
Visual C++
public:
static void TraceCall(
    TraceLevel traceLevel,
    String^ format,
    ... array<Object^>^ args
)

Parameters

traceLevel
Type: System.Diagnostics..::.TraceLevel
The trace level.
format
Type: System..::.String
The formating for the output
args
Type: array< System..::.Object >[]()[]
The arguments for the format.

Remarks

The resulting trace entry includes the callers method name, followed by a ':', followed by the formatted argument.

Examples

The following example logs the method arguments:
CopyC#
namespace MyProject
{
    public class MyClass
    {
        public void MyLog( string arg )
        {
            Tracing.Trace( TraceLevel.Info, "arg={0}", 123 );
        }
    }
}
 The trace output produced is:
CopyC#
MyProject.MyClass.MyLog(string) : arg=123

See Also

Tracing Class
Mincom.LinkOne.Common Namespace


TraceDump Method

[image]

LinkOne WebView API
Tracing..::.TraceDump Method
Tracing Class See Also Send Feedback

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void TraceDump(
    byte[] dumpData,
    int length
)
Visual Basic (Declaration)
Public Shared Sub TraceDump ( _
    dumpData As Byte(), _
    length As Integer _
)
Visual C++
public:
static void TraceDump(
    array<unsigned char>^ dumpData,
    int length
)

Parameters

dumpData
Type: array< System..::.Byte >[]()[]
length
Type: System..::.Int32

See Also

Tracing Class
Mincom.LinkOne.Common Namespace


TraceDumpLines Method

[image]

LinkOne WebView API
Tracing..::.TraceDumpLines Method
Tracing Class See Also Send Feedback

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static StringBuilder TraceDumpLines(
    byte[] dumpData,
    int length,
    string sTime
)
Visual Basic (Declaration)
Public Shared Function TraceDumpLines ( _
    dumpData As Byte(), _
    length As Integer, _
    sTime As String _
) As StringBuilder
Visual C++
public:
static StringBuilder^ TraceDumpLines(
    array<unsigned char>^ dumpData,
    int length,
    String^ sTime
)

Parameters

dumpData
Type: array< System..::.Byte >[]()[]
length
Type: System..::.Int32
sTime
Type: System..::.String

See Also

Tracing Class
Mincom.LinkOne.Common Namespace


TraceError Method

[image] [image]

LinkOne WebView API
Tracing..::.TraceError Method
Tracing Class See Also Send Feedback

Overload List

Name | Description
TraceError(Exception) | Writes the given exception preceded by the caller stack.
TraceError(TraceSwitch, Exception) | Writes the given exception preceded by the caller stack if the switch has enabled error tracing

See Also

Tracing Class
Tracing Members
Mincom.LinkOne.Common Namespace


TraceError Method (Exception)

[image]

LinkOne WebView API
Tracing..::.TraceError Method (Exception)
Tracing Class See Also Send Feedback
Writes the given exception preceded by the caller stack.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void TraceError(
    Exception exception
)
Visual Basic (Declaration)
Public Shared Sub TraceError ( _
    exception As Exception _
)
Visual C++
public:
static void TraceError(
    Exception^ exception
)

Parameters

exception
Type: System..::.Exception
The exception to trace.

See Also

Tracing Class
TraceError Overload
Mincom.LinkOne.Common Namespace


TraceError Method (TraceSwitch, Exception)

[image]

LinkOne WebView API
Tracing..::.TraceError Method (TraceSwitch, Exception)
Tracing Class See Also Send Feedback
Writes the given exception preceded by the caller stack if the switch has enabled error tracing

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static void TraceError(
    TraceSwitch traceSwitch,
    Exception exception
)
Visual Basic (Declaration)
Public Shared Sub TraceError ( _
    traceSwitch As TraceSwitch, _
    exception As Exception _
)
Visual C++
public:
static void TraceError(
    TraceSwitch^ traceSwitch,
    Exception^ exception
)

Parameters

traceSwitch
Type: System.Diagnostics..::.TraceSwitch
The trace switch to test if error tracing is allowed.
exception
Type: System..::.Exception
The exception to trace.

See Also

Tracing Class
TraceError Overload
Mincom.LinkOne.Common Namespace


Translator Class

[image]

LinkOne WebView API
Translator Class
Members See Also Send Feedback
Class to translate given controls and components using external translation files.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public class Translator
Visual Basic (Declaration)
Public Class Translator
Visual C++
public ref class Translator

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Common..::.Translator

See Also

Translator Members
Mincom.LinkOne.Common Namespace


Translator Members

[image] [image]

LinkOne WebView API
Translator Members
Translator Class Constructors Methods Properties See Also Send Feedback

The Translator type exposes the following members.

Constructors

Name | Description
Translator | Initializes a new instance of the Translator class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TranslateCommonResource | Overloaded.
TranslateProperty | Translates the property.

Properties

Name | Description
Dictionary | Gets the dictionary of available translations.
Enabled | Gets or sets a value indicating whether this Translator is enabled.
Extract | Gets or sets a value indicating whether this Translator is to extract translations.
ExtractDictionary | Gets the dictionary of extracted translations.

See Also

Translator Class
Mincom.LinkOne.Common Namespace


Translator Constructor

[image]

LinkOne WebView API
Translator Constructor
Translator Class See Also Send Feedback
Initializes a new instance of the Translator class.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
protected Translator()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
Translator()

See Also

Translator Class
Mincom.LinkOne.Common Namespace


Translator Methods

[image] [image]

LinkOne WebView API
Translator Methods
Translator Class See Also Send Feedback

The Translator type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TranslateCommonResource | Overloaded.
TranslateProperty | Translates the property.

See Also

Translator Class
Mincom.LinkOne.Common Namespace


TranslateCommonResource Method

[image] [image]

LinkOne WebView API
Translator..::.TranslateCommonResource Method
Translator Class See Also Send Feedback

Overload List

Name | Description
TranslateCommonResource(String, String) | Translates the resource in the Common assembly.
TranslateCommonResource(String, String, String) | Translates the resource in the Common assembly.

See Also

Translator Class
Translator Members
Mincom.LinkOne.Common Namespace


TranslateCommonResource Method (String, String)

[image]

LinkOne WebView API
Translator..::.TranslateCommonResource Method (String, String)
Translator Class See Also Send Feedback
Translates the resource in the Common assembly.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static string TranslateCommonResource(
    string resourceName,
    string defaultTranslation
)
Visual Basic (Declaration)
Public Shared Function TranslateCommonResource ( _
    resourceName As String, _
    defaultTranslation As String _
) As String
Visual C++
public:
static String^ TranslateCommonResource(
    String^ resourceName,
    String^ defaultTranslation
)

Parameters

resourceName
Type: System..::.String
Name of the resource.
defaultTranslation
Type: System..::.String
The default translation.

Return Value

The translated property or the default translation if no translation exists.

See Also

Translator Class
TranslateCommonResource Overload
Mincom.LinkOne.Common Namespace


TranslateCommonResource Method (String, String, String)

[image]

LinkOne WebView API
Translator..::.TranslateCommonResource Method (String, String, String)
Translator Class See Also Send Feedback
Translates the resource in the Common assembly.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static string TranslateCommonResource(
    string LanguageName,
    string resourceName,
    string defaultTranslation
)
Visual Basic (Declaration)
Public Shared Function TranslateCommonResource ( _
    LanguageName As String, _
    resourceName As String, _
    defaultTranslation As String _
) As String
Visual C++
public:
static String^ TranslateCommonResource(
    String^ LanguageName,
    String^ resourceName,
    String^ defaultTranslation
)

Parameters

LanguageName
Type: System..::.String
resourceName
Type: System..::.String
Name of the resource.
defaultTranslation
Type: System..::.String
The default translation.

Return Value

The translated property or the default translation if no translation exists.

See Also

Translator Class
TranslateCommonResource Overload
Mincom.LinkOne.Common Namespace


TranslateProperty Method

[image]

LinkOne WebView API
Translator..::.TranslateProperty Method
Translator Class See Also Send Feedback
Translates the property.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static string TranslateProperty(
    string resourceName,
    string defaultTranslation
)
Visual Basic (Declaration)
Public Shared Function TranslateProperty ( _
    resourceName As String, _
    defaultTranslation As String _
) As String
Visual C++
public:
static String^ TranslateProperty(
    String^ resourceName,
    String^ defaultTranslation
)

Parameters

resourceName
Type: System..::.String
Name of the resource.
defaultTranslation
Type: System..::.String
The default translation.

Return Value

The translated property or the default translation if no translation exists.

See Also

Translator Class
Mincom.LinkOne.Common Namespace


Translator Properties

[image] [image]

LinkOne WebView API
Translator Properties
Translator Class See Also Send Feedback

The Translator type exposes the following members.

Properties

Name | Description
Dictionary | Gets the dictionary of available translations.
Enabled | Gets or sets a value indicating whether this Translator is enabled.
Extract | Gets or sets a value indicating whether this Translator is to extract translations.
ExtractDictionary | Gets the dictionary of extracted translations.

See Also

Translator Class
Mincom.LinkOne.Common Namespace


Dictionary Property

[image]

LinkOne WebView API
Translator..::.Dictionary Property
Translator Class See Also Send Feedback
Gets the dictionary of available translations.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static IDictionary<string, string> Dictionary { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Dictionary As IDictionary(Of String, String)
Visual C++
public:
static property IDictionary<String^, String^>^ Dictionary {
    IDictionary<String^, String^>^ get ();
}

See Also

Translator Class
Mincom.LinkOne.Common Namespace


Enabled Property

[image]

LinkOne WebView API
Translator..::.Enabled Property
Translator Class See Also Send Feedback
Gets or sets a value indicating whether this Translator is enabled.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static bool Enabled { get; set; }
Visual Basic (Declaration)
Public Shared Property Enabled As Boolean
Visual C++
public:
static property bool Enabled {
    bool get ();
    void set (bool value);
}

Field Value

true if enabled; otherwise, false.

See Also

Translator Class
Mincom.LinkOne.Common Namespace


Extract Property

[image]

LinkOne WebView API
Translator..::.Extract Property
Translator Class See Also Send Feedback
Gets or sets a value indicating whether this Translator is to extract translations.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static bool Extract { get; set; }
Visual Basic (Declaration)
Public Shared Property Extract As Boolean
Visual C++
public:
static property bool Extract {
    bool get ();
    void set (bool value);
}

Field Value

true if extracting; otherwise, false.

See Also

Translator Class
Mincom.LinkOne.Common Namespace


ExtractDictionary Property

[image]

LinkOne WebView API
Translator..::.ExtractDictionary Property
Translator Class See Also Send Feedback
Gets the dictionary of extracted translations.

Namespace: Mincom.LinkOne.Common
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static IDictionary<string, string> ExtractDictionary { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ExtractDictionary As IDictionary(Of String, String)
Visual C++
public:
static property IDictionary<String^, String^>^ ExtractDictionary {
    IDictionary<String^, String^>^ get ();
}

See Also

Translator Class
Mincom.LinkOne.Common Namespace


Mincom.LinkOne.Common.Collections.LockFree Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.Common.Collections.LockFree Namespace
Send Feedback

Classes

Class | Description
LockFreeQueue<(Of <(T>)>) | A threadsafe, lock free queue.
LockFreeStack<(Of <(T>)>) | A threadsafe, lock free stack.
Sync | Lock free synchronisation helper. Provides compare-and-swap (CAS) semantics.


LockFreeQueue(T) Class

[image]

LinkOne WebView API
LockFreeQueue<(Of <(T>)>) Class
Members See Also Send Feedback
A threadsafe, lock free queue.

Namespace: Mincom.LinkOne.Common.Collections.LockFree
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public class LockFreeQueue<T>
Visual Basic (Declaration)
Public Class LockFreeQueue(Of T)
Visual C++
generic<typename T>
public ref class LockFreeQueue

Type Parameters

T
The data type contained in the queue.

Remarks

This code has been taken from http://www.codeproject.com/KB/cpp/lockfreeq.aspx. The original code from http://www.boyet.com/Articles/LockfreeQueue.html proved flawed.

This class provides a thread safe FIFO queue which does not use locking techniques. The result is much faster data access.

This class relies on CLR handle management to avoid the ABA problem. See the linked article above for an explanation of how/why.

For more information about lock free programming techniques, start at http://en.wikipedia.org/wiki/Non-blocking_algorithm.

Note: lock free priority queues are most easily implemented using a limited set of contiguous priority values. The priority structure then contains a single lock free queue at each priority value. That is, it forms an array of lock free queues.

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Common.Collections.LockFree..::.LockFreeQueue<(Of <(T>)>)

See Also

LockFreeQueue<(Of <(T>)>) Members
Mincom.LinkOne.Common.Collections.LockFree Namespace


LockFreeQueue(T) Members

[image] [image]

LinkOne WebView API
LockFreeQueue<(Of <(T>)>) Members
LockFreeQueue<(Of <(T>)>) Class Constructors Methods See Also Send Feedback

The LockFreeQueue<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
LockFreeQueue<(Of <(T>)>) | Creates an empty queue.

Methods

Name | Description
Dequeue | Pops the item from the head of the queue.
Enqueue | Pushes an item onto the tail of the queue. May already be in the queue. Threadsafe.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LockFreeQueue<(Of <(T>)>) Class
Mincom.LinkOne.Common.Collections.LockFree Namespace


LockFreeQueue(T) Constructor

[image]

LinkOne WebView API
LockFreeQueue<(Of <(T>)>) Constructor
LockFreeQueue<(Of <(T>)>) Class See Also Send Feedback
Creates an empty queue.

Namespace: Mincom.LinkOne.Common.Collections.LockFree
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public LockFreeQueue()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LockFreeQueue()

See Also

LockFreeQueue<(Of <(T>)>) Class
Mincom.LinkOne.Common.Collections.LockFree Namespace


LockFreeQueue(T) Methods

[image] [image]

LinkOne WebView API
LockFreeQueue<(Of <(T>)>) Methods
LockFreeQueue<(Of <(T>)>) Class See Also Send Feedback

The LockFreeQueue<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Dequeue | Pops the item from the head of the queue.
Enqueue | Pushes an item onto the tail of the queue. May already be in the queue. Threadsafe.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LockFreeQueue<(Of <(T>)>) Class
Mincom.LinkOne.Common.Collections.LockFree Namespace


Dequeue Method

[image]

LinkOne WebView API
LockFreeQueue<(Of <(T>)>)..::.Dequeue Method
LockFreeQueue<(Of <(T>)>) Class See Also Send Feedback
Pops the item from the head of the queue.

Namespace: Mincom.LinkOne.Common.Collections.LockFree
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public bool Dequeue(
    ref T item
)
Visual Basic (Declaration)
Public Function Dequeue ( _
    ByRef item As T _
) As Boolean
Visual C++
public:
bool Dequeue(
    T% item
)

Parameters

item
Type: T %
The item that was at the head of the queue. Unchanged if queue is empty.

Return Value

True if there was an item to pop, false if empty.

See Also

LockFreeQueue<(Of <(T>)>) Class
Mincom.LinkOne.Common.Collections.LockFree Namespace


Enqueue Method

[image]

LinkOne WebView API
LockFreeQueue<(Of <(T>)>)..::.Enqueue Method
LockFreeQueue<(Of <(T>)>) Class See Also Send Feedback
Pushes an item onto the tail of the queue. May already be in the queue. Threadsafe.

Namespace: Mincom.LinkOne.Common.Collections.LockFree
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public void Enqueue(
    T item
)
Visual Basic (Declaration)
Public Sub Enqueue ( _
    item As T _
)
Visual C++
public:
void Enqueue(
    T item
)

Parameters

item
Type: T
The data to push.

See Also

LockFreeQueue<(Of <(T>)>) Class
Mincom.LinkOne.Common.Collections.LockFree Namespace


LockFreeStack(T) Class

[image]

LinkOne WebView API
LockFreeStack<(Of <(T>)>) Class
Members See Also Send Feedback
A threadsafe, lock free stack.

Namespace: Mincom.LinkOne.Common.Collections.LockFree
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public class LockFreeStack<T>
Visual Basic (Declaration)
Public Class LockFreeStack(Of T)
Visual C++
generic<typename T>
public ref class LockFreeStack

Type Parameters

T
The data type contained in the queue.

Remarks

This code has been taken from http://www.boyet.com/Articles/LockfreeStack.html.

This class provides a thread safe FILO stack which does not use locking techniques. The result is much faster data access.

For more information about lock free programming techniques, start at http://en.wikipedia.org/wiki/Non-blocking_algorithm.

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Common.Collections.LockFree..::.LockFreeStack<(Of <(T>)>)

See Also

LockFreeStack<(Of <(T>)>) Members
Mincom.LinkOne.Common.Collections.LockFree Namespace


LockFreeStack(T) Members

[image] [image]

LinkOne WebView API
LockFreeStack<(Of <(T>)>) Members
LockFreeStack<(Of <(T>)>) Class Constructors Methods See Also Send Feedback

The LockFreeStack<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
LockFreeStack<(Of <(T>)>) | Creates an empty stack.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Pop | Pops the item on the top of the stack.
Push | Pushes a new item onto the stack. May already be on the stack. Threadsafe.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LockFreeStack<(Of <(T>)>) Class
Mincom.LinkOne.Common.Collections.LockFree Namespace


LockFreeStack(T) Constructor

[image]

LinkOne WebView API
LockFreeStack<(Of <(T>)>) Constructor
LockFreeStack<(Of <(T>)>) Class See Also Send Feedback
Creates an empty stack.

Namespace: Mincom.LinkOne.Common.Collections.LockFree
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public LockFreeStack()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LockFreeStack()

See Also

LockFreeStack<(Of <(T>)>) Class
Mincom.LinkOne.Common.Collections.LockFree Namespace


LockFreeStack(T) Methods

[image] [image]

LinkOne WebView API
LockFreeStack<(Of <(T>)>) Methods
LockFreeStack<(Of <(T>)>) Class See Also Send Feedback

The LockFreeStack<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Pop | Pops the item on the top of the stack.
Push | Pushes a new item onto the stack. May already be on the stack. Threadsafe.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LockFreeStack<(Of <(T>)>) Class
Mincom.LinkOne.Common.Collections.LockFree Namespace


Pop Method

[image]

LinkOne WebView API
LockFreeStack<(Of <(T>)>)..::.Pop Method
LockFreeStack<(Of <(T>)>) Class See Also Send Feedback
Pops the item on the top of the stack.

Namespace: Mincom.LinkOne.Common.Collections.LockFree
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public bool Pop(
    ref T item
)
Visual Basic (Declaration)
Public Function Pop ( _
    ByRef item As T _
) As Boolean
Visual C++
public:
bool Pop(
    T% item
)

Parameters

item
Type: T %
The item that was on top of the stack. Unchaged if stack is empty.

Return Value

True if there was an item to pop, false if empty.

See Also

LockFreeStack<(Of <(T>)>) Class
Mincom.LinkOne.Common.Collections.LockFree Namespace


Push Method

[image]

LinkOne WebView API
LockFreeStack<(Of <(T>)>)..::.Push Method
LockFreeStack<(Of <(T>)>) Class See Also Send Feedback
Pushes a new item onto the stack. May already be on the stack. Threadsafe.

Namespace: Mincom.LinkOne.Common.Collections.LockFree
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public void Push(
    T item
)
Visual Basic (Declaration)
Public Sub Push ( _
    item As T _
)
Visual C++
public:
void Push(
    T item
)

Parameters

item
Type: T
Data to push.

See Also

LockFreeStack<(Of <(T>)>) Class
Mincom.LinkOne.Common.Collections.LockFree Namespace


Sync Class

[image]

LinkOne WebView API
Sync Class
Members See Also Send Feedback
Lock free synchronisation helper. Provides compare-and-swap (CAS) semantics.

Namespace: Mincom.LinkOne.Common.Collections.LockFree
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static class Sync
Visual Basic (Declaration)
Public NotInheritable Class Sync
Visual C++
public ref class Sync abstract sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Common.Collections.LockFree..::.Sync

See Also

Sync Members
Mincom.LinkOne.Common.Collections.LockFree Namespace


Sync Members

[image] [image]

LinkOne WebView API
Sync Members
Sync Class Methods See Also Send Feedback

The Sync type exposes the following members.

Methods

Name | Description
CAS<(Of <(T>)>) | Attempts an atomic compare and swap (CAS) operation.

See Also

Sync Class
Mincom.LinkOne.Common.Collections.LockFree Namespace


Sync Methods

[image] [image]

LinkOne WebView API
Sync Methods
Sync Class See Also Send Feedback

The Sync type exposes the following members.

Methods

Name | Description
CAS<(Of <(T>)>) | Attempts an atomic compare and swap (CAS) operation.

See Also

Sync Class
Mincom.LinkOne.Common.Collections.LockFree Namespace


CAS(T) Method

[image]

LinkOne WebView API
Sync..::.CAS<(Of <(T>)>) Method
Sync Class See Also Send Feedback
Attempts an atomic compare and swap (CAS) operation.

Namespace: Mincom.LinkOne.Common.Collections.LockFree
Assembly: Mincom.LinkOne.Common (in Mincom.LinkOne.Common.dll) Version: 3.58.5361.0

Syntax

C#
public static bool CAS<T>(
    ref T location,
    T comparand,
    T newValue
)
where T : class
Visual Basic (Declaration)
Public Shared Function CAS(Of T As Class) ( _
    ByRef location As T, _
    comparand As T, _
    newValue As T _
) As Boolean
Visual C++
public:
generic<typename T>
where T : ref class
static bool CAS(
    T% location,
    T comparand,
    T newValue
)

Parameters

location
Type: T %
The target variable to swap into. That is, this is the variable to modify.
comparand
Type: T
The expected value of location. Data remains unchanged if [!:location] is not equal to comparand.
newValue
Type: T
The new value to write to location.

Type Parameters

T
The type to be swapped.

Return Value

True if newValue has been written to location.

Remarks

A compare and swap operation is an atom (therefore, threadsafe) operation. It attempts to a new value write to a variable, but only succeeds if the current values matches the expected value.

In this case location is only modified if its value is currently equal to comparand.

This function uses Interlocked.CompareExchange() to implement CAS semantics.

See Also

Sync Class
Mincom.LinkOne.Common.Collections.LockFree Namespace


Mincom.LinkOne.Content.Layout Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.Content.Layout Namespace
Send Feedback
The Mincom.LinkOne.Content.Layout namespace contains classes that read LinkOne layouts.

Classes

Class | Description
LayoutReader | Represents a Layout reader that parses a layout definition.
PreferredLayoutXmlReader |
PreferredLayoutXmlWriter |


LayoutReader Class

[image]

LinkOne WebView API
LayoutReader Class
Members See Also Send Feedback
Represents a Layout reader that parses a layout definition.

Namespace: Mincom.LinkOne.Content.Layout
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public sealed class LayoutReader
Visual Basic (Declaration)
Public NotInheritable Class LayoutReader
Visual C++
public ref class LayoutReader sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Content.Layout..::.LayoutReader

See Also

LayoutReader Members
Mincom.LinkOne.Content.Layout Namespace


LayoutReader Members

[image] [image]

LinkOne WebView API
LayoutReader Members
LayoutReader Class Constructors Methods Properties See Also Send Feedback

The LayoutReader type exposes the following members.

Constructors

Name | Description
LayoutReader | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Errors | Gets the list of errors detected while parsing the layout.
Layout | Gets the SelectionList object or the currently read in data.

See Also

LayoutReader Class
Mincom.LinkOne.Content.Layout Namespace


LayoutReader Constructor

[image] [image]

LinkOne WebView API
LayoutReader Constructor
LayoutReader Class See Also Send Feedback

Overload List

Name | Description
LayoutReader(String) | Constructor.
LayoutReader(String, Encoding) | Constructor.
LayoutReader(String, String, String, String) | Constructor.

See Also

LayoutReader Class
LayoutReader Members
Mincom.LinkOne.Content.Layout Namespace


LayoutReader Constructor (String)

[image]

LinkOne WebView API
LayoutReader Constructor (String)
LayoutReader Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Content.Layout
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public LayoutReader(
    string layout
)
Visual Basic (Declaration)
Public Sub New ( _
    layout As String _
)
Visual C++
public:
LayoutReader(
    String^ layout
)

Parameters

layout
Type: System..::.String
The layout definition to parse.

See Also

LayoutReader Class
LayoutReader Overload
Mincom.LinkOne.Content.Layout Namespace


LayoutReader Constructor (String, Encoding)

[image]

LinkOne WebView API
LayoutReader Constructor (String, Encoding)
LayoutReader Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Content.Layout
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public LayoutReader(
    string fileName,
    Encoding encoding
)
Visual Basic (Declaration)
Public Sub New ( _
    fileName As String, _
    encoding As Encoding _
)
Visual C++
public:
LayoutReader(
    String^ fileName,
    Encoding^ encoding
)

Parameters

fileName
Type: System..::.String
The file name of the format definition file.
encoding
Type: System.Text..::.Encoding
The encoding of the file.

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurs.

See Also

LayoutReader Class
LayoutReader Overload
Mincom.LinkOne.Content.Layout Namespace


LayoutReader Constructor (String, String, String, String)

[image]

LinkOne WebView API
LayoutReader Constructor (String, String, String, String)
LayoutReader Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Content.Layout
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public LayoutReader(
    string layout,
    string id,
    string description,
    string languageCode
)
Visual Basic (Declaration)
Public Sub New ( _
    layout As String, _
    id As String, _
    description As String, _
    languageCode As String _
)
Visual C++
public:
LayoutReader(
    String^ layout,
    String^ id,
    String^ description,
    String^ languageCode
)

Parameters

layout
Type: System..::.String
The layout definition.
id
Type: System..::.String
The overriding layout id.
description
Type: System..::.String
The overriding layout description
languageCode
Type: System..::.String
The overriding layout language.

See Also

LayoutReader Class
LayoutReader Overload
Mincom.LinkOne.Content.Layout Namespace


LayoutReader Methods

[image] [image]

LinkOne WebView API
LayoutReader Methods
LayoutReader Class See Also Send Feedback

The LayoutReader type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LayoutReader Class
Mincom.LinkOne.Content.Layout Namespace


LayoutReader Properties

[image] [image]

LinkOne WebView API
LayoutReader Properties
LayoutReader Class See Also Send Feedback

The LayoutReader type exposes the following members.

Properties

Name | Description
Errors | Gets the list of errors detected while parsing the layout.
Layout | Gets the SelectionList object or the currently read in data.

See Also

LayoutReader Class
Mincom.LinkOne.Content.Layout Namespace


Errors Property

[image]

LinkOne WebView API
LayoutReader..::.Errors Property
LayoutReader Class See Also Send Feedback
Gets the list of errors detected while parsing the layout.

Namespace: Mincom.LinkOne.Content.Layout
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public IEnumerable<BaseException> Errors { get; }
Visual Basic (Declaration)
Public ReadOnly Property Errors As IEnumerable(Of BaseException)
Visual C++
public:
virtual property IEnumerable<BaseException^>^ Errors {
    IEnumerable<BaseException^>^ get () sealed;
}

See Also

LayoutReader Class
Mincom.LinkOne.Content.Layout Namespace


Layout Property

[image]

LinkOne WebView API
LayoutReader..::.Layout Property
LayoutReader Class See Also Send Feedback
Gets the SelectionList object or the currently read in data.

Namespace: Mincom.LinkOne.Content.Layout
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public Layout Layout { get; }
Visual Basic (Declaration)
Public ReadOnly Property Layout As Layout
Visual C++
public:
property Layout^ Layout {
    Layout^ get ();
}

See Also

LayoutReader Class
Mincom.LinkOne.Content.Layout Namespace


PreferredLayoutXmlReader Class

[image]

LinkOne WebView API
PreferredLayoutXmlReader Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.Content.Layout
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public sealed class PreferredLayoutXmlReader
Visual Basic (Declaration)
Public NotInheritable Class PreferredLayoutXmlReader
Visual C++
public ref class PreferredLayoutXmlReader sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Content.Layout..::.PreferredLayoutXmlReader

See Also

PreferredLayoutXmlReader Members
Mincom.LinkOne.Content.Layout Namespace


PreferredLayoutXmlReader Members

[image] [image]

LinkOne WebView API
PreferredLayoutXmlReader Members
PreferredLayoutXmlReader Class Constructors Methods Properties See Also Send Feedback

The PreferredLayoutXmlReader type exposes the following members.

Constructors

Name | Description
PreferredLayoutXmlReader | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
PreferredCollection |

See Also

PreferredLayoutXmlReader Class
Mincom.LinkOne.Content.Layout Namespace


PreferredLayoutXmlReader Constructor

[image] [image]

LinkOne WebView API
PreferredLayoutXmlReader Constructor
PreferredLayoutXmlReader Class See Also Send Feedback

Overload List

Name | Description
PreferredLayoutXmlReader(String) | Initializes a new instance of the PreferredLayoutXmlReader class
PreferredLayoutXmlReader(String, IPreferredCollection) | Initializes a new instance of the PreferredLayoutXmlReader class

See Also

PreferredLayoutXmlReader Class
PreferredLayoutXmlReader Members
Mincom.LinkOne.Content.Layout Namespace


PreferredLayoutXmlReader Constructor (String)

[image]

LinkOne WebView API
PreferredLayoutXmlReader Constructor (String)
PreferredLayoutXmlReader Class See Also Send Feedback
Initializes a new instance of the PreferredLayoutXmlReader class

Namespace: Mincom.LinkOne.Content.Layout
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public PreferredLayoutXmlReader(
    string collection
)
Visual Basic (Declaration)
Public Sub New ( _
    collection As String _
)
Visual C++
public:
PreferredLayoutXmlReader(
    String^ collection
)

Parameters

collection
Type: System..::.String

See Also

PreferredLayoutXmlReader Class
PreferredLayoutXmlReader Overload
Mincom.LinkOne.Content.Layout Namespace


PreferredLayoutXmlReader Constructor (String, IPreferredCollection)

[image]

LinkOne WebView API
PreferredLayoutXmlReader Constructor (String, IPreferredCollection)
PreferredLayoutXmlReader Class See Also Send Feedback
Initializes a new instance of the PreferredLayoutXmlReader class

Namespace: Mincom.LinkOne.Content.Layout
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public PreferredLayoutXmlReader(
    string collection,
    IPreferredCollection preferredCollection
)
Visual Basic (Declaration)
Public Sub New ( _
    collection As String, _
    preferredCollection As IPreferredCollection _
)
Visual C++
public:
PreferredLayoutXmlReader(
    String^ collection,
    IPreferredCollection^ preferredCollection
)

Parameters

collection
Type: System..::.String
preferredCollection
Type: Mincom.LinkOne.Dom.Layouts..::.IPreferredCollection

See Also

PreferredLayoutXmlReader Class
PreferredLayoutXmlReader Overload
Mincom.LinkOne.Content.Layout Namespace


PreferredLayoutXmlReader Methods

[image] [image]

LinkOne WebView API
PreferredLayoutXmlReader Methods
PreferredLayoutXmlReader Class See Also Send Feedback

The PreferredLayoutXmlReader type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PreferredLayoutXmlReader Class
Mincom.LinkOne.Content.Layout Namespace


PreferredLayoutXmlReader Properties

[image] [image]

LinkOne WebView API
PreferredLayoutXmlReader Properties
PreferredLayoutXmlReader Class See Also Send Feedback

The PreferredLayoutXmlReader type exposes the following members.

Properties

Name | Description
PreferredCollection |

See Also

PreferredLayoutXmlReader Class
Mincom.LinkOne.Content.Layout Namespace


PreferredCollection Property

[image]

LinkOne WebView API
PreferredLayoutXmlReader..::.PreferredCollection Property
PreferredLayoutXmlReader Class See Also Send Feedback

Namespace: Mincom.LinkOne.Content.Layout
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public IPreferredCollection PreferredCollection { get; }
Visual Basic (Declaration)
Public ReadOnly Property PreferredCollection As IPreferredCollection
Visual C++
public:
property IPreferredCollection^ PreferredCollection {
    IPreferredCollection^ get ();
}

See Also

PreferredLayoutXmlReader Class
Mincom.LinkOne.Content.Layout Namespace


PreferredLayoutXmlWriter Class

[image]

LinkOne WebView API
PreferredLayoutXmlWriter Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.Content.Layout
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public sealed class PreferredLayoutXmlWriter
Visual Basic (Declaration)
Public NotInheritable Class PreferredLayoutXmlWriter
Visual C++
public ref class PreferredLayoutXmlWriter sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Content.Layout..::.PreferredLayoutXmlWriter

See Also

PreferredLayoutXmlWriter Members
Mincom.LinkOne.Content.Layout Namespace


PreferredLayoutXmlWriter Members

[image] [image]

LinkOne WebView API
PreferredLayoutXmlWriter Members
PreferredLayoutXmlWriter Class Constructors Methods Properties See Also Send Feedback

The PreferredLayoutXmlWriter type exposes the following members.

Constructors

Name | Description
PreferredLayoutXmlWriter | Initializes a new instance of the PreferredLayoutXmlWriter class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Data |

See Also

PreferredLayoutXmlWriter Class
Mincom.LinkOne.Content.Layout Namespace


PreferredLayoutXmlWriter Constructor

[image]

LinkOne WebView API
PreferredLayoutXmlWriter Constructor
PreferredLayoutXmlWriter Class See Also Send Feedback
Initializes a new instance of the PreferredLayoutXmlWriter class

Namespace: Mincom.LinkOne.Content.Layout
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public PreferredLayoutXmlWriter(
    IPreferredCollection preferredLayoutCollection
)
Visual Basic (Declaration)
Public Sub New ( _
    preferredLayoutCollection As IPreferredCollection _
)
Visual C++
public:
PreferredLayoutXmlWriter(
    IPreferredCollection^ preferredLayoutCollection
)

Parameters

preferredLayoutCollection
Type: Mincom.LinkOne.Dom.Layouts..::.IPreferredCollection

See Also

PreferredLayoutXmlWriter Class
Mincom.LinkOne.Content.Layout Namespace


PreferredLayoutXmlWriter Methods

[image] [image]

LinkOne WebView API
PreferredLayoutXmlWriter Methods
PreferredLayoutXmlWriter Class See Also Send Feedback

The PreferredLayoutXmlWriter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PreferredLayoutXmlWriter Class
Mincom.LinkOne.Content.Layout Namespace


PreferredLayoutXmlWriter Properties

[image] [image]

LinkOne WebView API
PreferredLayoutXmlWriter Properties
PreferredLayoutXmlWriter Class See Also Send Feedback

The PreferredLayoutXmlWriter type exposes the following members.

Properties

Name | Description
Data |

See Also

PreferredLayoutXmlWriter Class
Mincom.LinkOne.Content.Layout Namespace


Data Property

[image]

LinkOne WebView API
PreferredLayoutXmlWriter..::.Data Property
PreferredLayoutXmlWriter Class See Also Send Feedback

Namespace: Mincom.LinkOne.Content.Layout
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public string Data { get; }
Visual Basic (Declaration)
Public ReadOnly Property Data As String
Visual C++
public:
property String^ Data {
    String^ get ();
}

See Also

PreferredLayoutXmlWriter Class
Mincom.LinkOne.Content.Layout Namespace


Mincom.LinkOne.Content.Searching Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.Content.Searching Namespace
Send Feedback
The Mincom.LinkOne.Content.Searching namespace contains classes that save LinkOne search results.

Classes

Class | Description
SearchResultCollectionWriter | Class to write a search results collection.


SearchResultCollectionWriter Class

[image]

LinkOne WebView API
SearchResultCollectionWriter Class
Members See Also Send Feedback
Class to write a search results collection.

Namespace: Mincom.LinkOne.Content.Searching
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public sealed class SearchResultCollectionWriter
Visual Basic (Declaration)
Public NotInheritable Class SearchResultCollectionWriter
Visual C++
public ref class SearchResultCollectionWriter sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Content.Searching..::.SearchResultCollectionWriter

See Also

SearchResultCollectionWriter Members
Mincom.LinkOne.Content.Searching Namespace


SearchResultCollectionWriter Members

[image] [image]

LinkOne WebView API
SearchResultCollectionWriter Members
SearchResultCollectionWriter Class Constructors Methods Properties See Also Send Feedback

The SearchResultCollectionWriter type exposes the following members.

Constructors

Name | Description
SearchResultCollectionWriter | Initializes a new instance of the SearchResultCollectionWriter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Data | Gets the Csv representation of the search results.

See Also

SearchResultCollectionWriter Class
Mincom.LinkOne.Content.Searching Namespace


SearchResultCollectionWriter Constructor

[image]

LinkOne WebView API
SearchResultCollectionWriter Constructor
SearchResultCollectionWriter Class See Also Send Feedback
Initializes a new instance of the SearchResultCollectionWriter class.

Namespace: Mincom.LinkOne.Content.Searching
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public SearchResultCollectionWriter(
    SearchResultCollection searchResults,
    SearchResult criteria,
    SearchResultScope scope,
    bool includeLocations
)
Visual Basic (Declaration)
Public Sub New ( _
    searchResults As SearchResultCollection, _
    criteria As SearchResult, _
    scope As SearchResultScope, _
    includeLocations As Boolean _
)
Visual C++
public:
SearchResultCollectionWriter(
    SearchResultCollection^ searchResults,
    SearchResult^ criteria,
    SearchResultScope scope,
    bool includeLocations
)

Parameters

searchResults
Type: Mincom.LinkOne.Dom.Searching..::.SearchResultCollection
The complete collection of search results.
criteria
Type: Mincom.LinkOne.Dom.Searching..::.SearchResult
The criteria.
scope
Type: Mincom.LinkOne.Dom.Searching..::.SearchResultScope
The scope.
includeLocations
Type: System..::.Boolean
if set to true result location infomration will be written.

Exceptions

Exception | Condition
System..::.ArgumentNullException | searchResults or criteria is null.

See Also

SearchResultCollectionWriter Class
Mincom.LinkOne.Content.Searching Namespace


SearchResultCollectionWriter Methods

[image] [image]

LinkOne WebView API
SearchResultCollectionWriter Methods
SearchResultCollectionWriter Class See Also Send Feedback

The SearchResultCollectionWriter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SearchResultCollectionWriter Class
Mincom.LinkOne.Content.Searching Namespace


SearchResultCollectionWriter Properties

[image] [image]

LinkOne WebView API
SearchResultCollectionWriter Properties
SearchResultCollectionWriter Class See Also Send Feedback

The SearchResultCollectionWriter type exposes the following members.

Properties

Name | Description
Data | Gets the Csv representation of the search results.

See Also

SearchResultCollectionWriter Class
Mincom.LinkOne.Content.Searching Namespace


Data Property

[image]

LinkOne WebView API
SearchResultCollectionWriter..::.Data Property
SearchResultCollectionWriter Class See Also Send Feedback
Gets the Csv representation of the search results.

Namespace: Mincom.LinkOne.Content.Searching
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public string Data { get; }
Visual Basic (Declaration)
Public ReadOnly Property Data As String
Visual C++
public:
property String^ Data {
    String^ get ();
}

See Also

SearchResultCollectionWriter Class
Mincom.LinkOne.Content.Searching Namespace


Mincom.LinkOne.Content.SelectionList Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.Content.SelectionList Namespace
Send Feedback
The Mincom.LinkOne.Content.SelectionList namespace contains classes that read and save LinkOne selection lists.

Classes

Class | Description
SelectionListCsvWriter | Represents a SelectionList writer that generates a CSV representation of a selection list.
SelectionListReader | Represents a SelectionList reader that parses a selection list definition.
SelectionListTabWriter | Represents a SelectionList writer that generates a Tab representation of a selection list.
SelectionListTaggedWriter | Represents a SelectionList writer that generates a Tagged representation of a selection list.
SelectionListWriter | Represents a SelectionList writer that generates a string representation of a selection list.
SelectionListXmlReader | Represents a SelectionList reader that parses an XML selection list definition.
SelectionListXmlWriter | Represents a SelectionList writer that generates an XML representation of a selection list.


SelectionListCsvWriter Class

[image]

LinkOne WebView API
SelectionListCsvWriter Class
Members See Also Send Feedback
Represents a SelectionList writer that generates a CSV representation of a selection list.

Namespace: Mincom.LinkOne.Content.SelectionList
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public sealed class SelectionListCsvWriter
Visual Basic (Declaration)
Public NotInheritable Class SelectionListCsvWriter
Visual C++
public ref class SelectionListCsvWriter sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Content.SelectionList..::.SelectionListCsvWriter

See Also

SelectionListCsvWriter Members
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListCsvWriter Members

[image] [image]

LinkOne WebView API
SelectionListCsvWriter Members
SelectionListCsvWriter Class Constructors Methods Properties See Also Send Feedback

The SelectionListCsvWriter type exposes the following members.

Constructors

Name | Description
SelectionListCsvWriter | Constructor.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
ColumnHeadings |
Data | Gets the csv representation of the selection list.
WriteHeader |

See Also

SelectionListCsvWriter Class
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListCsvWriter Constructor

[image]

LinkOne WebView API
SelectionListCsvWriter Constructor
SelectionListCsvWriter Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Content.SelectionList
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public SelectionListCsvWriter(
    SelectionList selectionList
)
Visual Basic (Declaration)
Public Sub New ( _
    selectionList As SelectionList _
)
Visual C++
public:
SelectionListCsvWriter(
    SelectionList^ selectionList
)

Parameters

selectionList
Type: Mincom.LinkOne.Dom.SelectionList..::.SelectionList
The selection list definition to write.

See Also

SelectionListCsvWriter Class
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListCsvWriter Methods

[image] [image]

LinkOne WebView API
SelectionListCsvWriter Methods
SelectionListCsvWriter Class See Also Send Feedback

The SelectionListCsvWriter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SelectionListCsvWriter Class
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListCsvWriter Properties

[image] [image]

LinkOne WebView API
SelectionListCsvWriter Properties
SelectionListCsvWriter Class See Also Send Feedback

The SelectionListCsvWriter type exposes the following members.

Properties

Name | Description
ColumnHeadings |
Data | Gets the csv representation of the selection list.
WriteHeader |

See Also

SelectionListCsvWriter Class
Mincom.LinkOne.Content.SelectionList Namespace


ColumnHeadings Property

[image]

LinkOne WebView API
SelectionListCsvWriter..::.ColumnHeadings Property
SelectionListCsvWriter Class See Also Send Feedback

Namespace: Mincom.LinkOne.Content.SelectionList
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public List<string> ColumnHeadings { get; set; }
Visual Basic (Declaration)
Public Property ColumnHeadings As List(Of String)
Visual C++
public:
property List<String^>^ ColumnHeadings {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

See Also

SelectionListCsvWriter Class
Mincom.LinkOne.Content.SelectionList Namespace


Data Property

[image]

LinkOne WebView API
SelectionListCsvWriter..::.Data Property
SelectionListCsvWriter Class See Also Send Feedback
Gets the csv representation of the selection list.

Namespace: Mincom.LinkOne.Content.SelectionList
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public string Data { get; }
Visual Basic (Declaration)
Public ReadOnly Property Data As String
Visual C++
public:
property String^ Data {
    String^ get ();
}

See Also

SelectionListCsvWriter Class
Mincom.LinkOne.Content.SelectionList Namespace


WriteHeader Property

[image]

LinkOne WebView API
SelectionListCsvWriter..::.WriteHeader Property
SelectionListCsvWriter Class See Also Send Feedback

Namespace: Mincom.LinkOne.Content.SelectionList
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public bool WriteHeader { get; set; }
Visual Basic (Declaration)
Public Property WriteHeader As Boolean
Visual C++
public:
property bool WriteHeader {
    bool get ();
    void set (bool value);
}

See Also

SelectionListCsvWriter Class
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListReader Class

[image]

LinkOne WebView API
SelectionListReader Class
Members See Also Send Feedback
Represents a SelectionList reader that parses a selection list definition.

Namespace: Mincom.LinkOne.Content.SelectionList
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public sealed class SelectionListReader
Visual Basic (Declaration)
Public NotInheritable Class SelectionListReader
Visual C++
public ref class SelectionListReader sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Content.SelectionList..::.SelectionListReader

See Also

SelectionListReader Members
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListReader Members

[image] [image]

LinkOne WebView API
SelectionListReader Members
SelectionListReader Class Constructors Methods Properties See Also Send Feedback

The SelectionListReader type exposes the following members.

Constructors

Name | Description
SelectionListReader | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
SelectionList | Gets the SelectionList object or the currently read in data.

See Also

SelectionListReader Class
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListReader Constructor

[image] [image]

LinkOne WebView API
SelectionListReader Constructor
SelectionListReader Class See Also Send Feedback

Overload List

Name | Description
SelectionListReader(String) | Constructor.
SelectionListReader(String, Encoding) | Constructor.

See Also

SelectionListReader Class
SelectionListReader Members
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListReader Constructor (String)

[image]

LinkOne WebView API
SelectionListReader Constructor (String)
SelectionListReader Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Content.SelectionList
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public SelectionListReader(
    string selection
)
Visual Basic (Declaration)
Public Sub New ( _
    selection As String _
)
Visual C++
public:
SelectionListReader(
    String^ selection
)

Parameters

selection
Type: System..::.String
The selection list definition to parse.

See Also

SelectionListReader Class
SelectionListReader Overload
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListReader Constructor (String, Encoding)

[image]

LinkOne WebView API
SelectionListReader Constructor (String, Encoding)
SelectionListReader Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Content.SelectionList
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public SelectionListReader(
    string fileName,
    Encoding encoding
)
Visual Basic (Declaration)
Public Sub New ( _
    fileName As String, _
    encoding As Encoding _
)
Visual C++
public:
SelectionListReader(
    String^ fileName,
    Encoding^ encoding
)

Parameters

fileName
Type: System..::.String
The filename of the selection list.
encoding
Type: System.Text..::.Encoding
The encoding of the file.

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurs.

See Also

SelectionListReader Class
SelectionListReader Overload
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListReader Methods

[image] [image]

LinkOne WebView API
SelectionListReader Methods
SelectionListReader Class See Also Send Feedback

The SelectionListReader type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SelectionListReader Class
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListReader Properties

[image] [image]

LinkOne WebView API
SelectionListReader Properties
SelectionListReader Class See Also Send Feedback

The SelectionListReader type exposes the following members.

Properties

Name | Description
SelectionList | Gets the SelectionList object or the currently read in data.

See Also

SelectionListReader Class
Mincom.LinkOne.Content.SelectionList Namespace


SelectionList Property

[image]

LinkOne WebView API
SelectionListReader..::.SelectionList Property
SelectionListReader Class See Also Send Feedback
Gets the SelectionList object or the currently read in data.

Namespace: Mincom.LinkOne.Content.SelectionList
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public SelectionList SelectionList { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectionList As SelectionList
Visual C++
public:
property SelectionList^ SelectionList {
    SelectionList^ get ();
}

See Also

SelectionListReader Class
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListTabWriter Class

[image]

LinkOne WebView API
SelectionListTabWriter Class
Members See Also Send Feedback
Represents a SelectionList writer that generates a Tab representation of a selection list.

Namespace: Mincom.LinkOne.Content.SelectionList
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public sealed class SelectionListTabWriter
Visual Basic (Declaration)
Public NotInheritable Class SelectionListTabWriter
Visual C++
public ref class SelectionListTabWriter sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Content.SelectionList..::.SelectionListTabWriter

See Also

SelectionListTabWriter Members
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListTabWriter Members

[image] [image]

LinkOne WebView API
SelectionListTabWriter Members
SelectionListTabWriter Class Constructors Methods Properties See Also Send Feedback

The SelectionListTabWriter type exposes the following members.

Constructors

Name | Description
SelectionListTabWriter | Constructor.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Data | Gets the tab format representation of the selection list.

See Also

SelectionListTabWriter Class
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListTabWriter Constructor

[image]

LinkOne WebView API
SelectionListTabWriter Constructor
SelectionListTabWriter Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Content.SelectionList
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public SelectionListTabWriter(
    SelectionList selectionList
)
Visual Basic (Declaration)
Public Sub New ( _
    selectionList As SelectionList _
)
Visual C++
public:
SelectionListTabWriter(
    SelectionList^ selectionList
)

Parameters

selectionList
Type: Mincom.LinkOne.Dom.SelectionList..::.SelectionList
The selection list definition to write.

See Also

SelectionListTabWriter Class
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListTabWriter Methods

[image] [image]

LinkOne WebView API
SelectionListTabWriter Methods
SelectionListTabWriter Class See Also Send Feedback

The SelectionListTabWriter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SelectionListTabWriter Class
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListTabWriter Properties

[image] [image]

LinkOne WebView API
SelectionListTabWriter Properties
SelectionListTabWriter Class See Also Send Feedback

The SelectionListTabWriter type exposes the following members.

Properties

Name | Description
Data | Gets the tab format representation of the selection list.

See Also

SelectionListTabWriter Class
Mincom.LinkOne.Content.SelectionList Namespace


Data Property

[image]

LinkOne WebView API
SelectionListTabWriter..::.Data Property
SelectionListTabWriter Class See Also Send Feedback
Gets the tab format representation of the selection list.

Namespace: Mincom.LinkOne.Content.SelectionList
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public string Data { get; }
Visual Basic (Declaration)
Public ReadOnly Property Data As String
Visual C++
public:
property String^ Data {
    String^ get ();
}

See Also

SelectionListTabWriter Class
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListTaggedWriter Class

[image]

LinkOne WebView API
SelectionListTaggedWriter Class
Members See Also Send Feedback
Represents a SelectionList writer that generates a Tagged representation of a selection list.

Namespace: Mincom.LinkOne.Content.SelectionList
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public sealed class SelectionListTaggedWriter
Visual Basic (Declaration)
Public NotInheritable Class SelectionListTaggedWriter
Visual C++
public ref class SelectionListTaggedWriter sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Content.SelectionList..::.SelectionListTaggedWriter

See Also

SelectionListTaggedWriter Members
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListTaggedWriter Members

[image] [image]

LinkOne WebView API
SelectionListTaggedWriter Members
SelectionListTaggedWriter Class Constructors Methods Properties See Also Send Feedback

The SelectionListTaggedWriter type exposes the following members.

Constructors

Name | Description
SelectionListTaggedWriter | Constructor.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Data | Gets the Tagged format representation of the selection list.

See Also

SelectionListTaggedWriter Class
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListTaggedWriter Constructor

[image]

LinkOne WebView API
SelectionListTaggedWriter Constructor
SelectionListTaggedWriter Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Content.SelectionList
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public SelectionListTaggedWriter(
    SelectionList selectionList
)
Visual Basic (Declaration)
Public Sub New ( _
    selectionList As SelectionList _
)
Visual C++
public:
SelectionListTaggedWriter(
    SelectionList^ selectionList
)

Parameters

selectionList
Type: Mincom.LinkOne.Dom.SelectionList..::.SelectionList
The selection list definition to write.

See Also

SelectionListTaggedWriter Class
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListTaggedWriter Methods

[image] [image]

LinkOne WebView API
SelectionListTaggedWriter Methods
SelectionListTaggedWriter Class See Also Send Feedback

The SelectionListTaggedWriter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SelectionListTaggedWriter Class
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListTaggedWriter Properties

[image] [image]

LinkOne WebView API
SelectionListTaggedWriter Properties
SelectionListTaggedWriter Class See Also Send Feedback

The SelectionListTaggedWriter type exposes the following members.

Properties

Name | Description
Data | Gets the Tagged format representation of the selection list.

See Also

SelectionListTaggedWriter Class
Mincom.LinkOne.Content.SelectionList Namespace


Data Property

[image]

LinkOne WebView API
SelectionListTaggedWriter..::.Data Property
SelectionListTaggedWriter Class See Also Send Feedback
Gets the Tagged format representation of the selection list.

Namespace: Mincom.LinkOne.Content.SelectionList
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public string Data { get; }
Visual Basic (Declaration)
Public ReadOnly Property Data As String
Visual C++
public:
property String^ Data {
    String^ get ();
}

See Also

SelectionListTaggedWriter Class
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListWriter Class

[image]

LinkOne WebView API
SelectionListWriter Class
Members See Also Send Feedback
Represents a SelectionList writer that generates a string representation of a selection list.

Namespace: Mincom.LinkOne.Content.SelectionList
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public sealed class SelectionListWriter
Visual Basic (Declaration)
Public NotInheritable Class SelectionListWriter
Visual C++
public ref class SelectionListWriter sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Content.SelectionList..::.SelectionListWriter

See Also

SelectionListWriter Members
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListWriter Members

[image] [image]

LinkOne WebView API
SelectionListWriter Members
SelectionListWriter Class Constructors Methods Properties See Also Send Feedback

The SelectionListWriter type exposes the following members.

Constructors

Name | Description
SelectionListWriter | Constructor.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Csv | Gets the csv representation of the selection list.

See Also

SelectionListWriter Class
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListWriter Constructor

[image]

LinkOne WebView API
SelectionListWriter Constructor
SelectionListWriter Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Content.SelectionList
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public SelectionListWriter(
    SelectionList selectionList
)
Visual Basic (Declaration)
Public Sub New ( _
    selectionList As SelectionList _
)
Visual C++
public:
SelectionListWriter(
    SelectionList^ selectionList
)

Parameters

selectionList
Type: Mincom.LinkOne.Dom.SelectionList..::.SelectionList
The selection list definition to write.

See Also

SelectionListWriter Class
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListWriter Methods

[image] [image]

LinkOne WebView API
SelectionListWriter Methods
SelectionListWriter Class See Also Send Feedback

The SelectionListWriter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SelectionListWriter Class
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListWriter Properties

[image] [image]

LinkOne WebView API
SelectionListWriter Properties
SelectionListWriter Class See Also Send Feedback

The SelectionListWriter type exposes the following members.

Properties

Name | Description
Csv | Gets the csv representation of the selection list.

See Also

SelectionListWriter Class
Mincom.LinkOne.Content.SelectionList Namespace


Csv Property

[image]

LinkOne WebView API
SelectionListWriter..::.Csv Property
SelectionListWriter Class See Also Send Feedback
Gets the csv representation of the selection list.

Namespace: Mincom.LinkOne.Content.SelectionList
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public string Csv { get; }
Visual Basic (Declaration)
Public ReadOnly Property Csv As String
Visual C++
public:
property String^ Csv {
    String^ get ();
}

Remarks

This will generate a Csv string of the current state of the selection list given in the constructor.

See Also

SelectionListWriter Class
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListXmlReader Class

[image]

LinkOne WebView API
SelectionListXmlReader Class
Members See Also Send Feedback
Represents a SelectionList reader that parses an XML selection list definition.

Namespace: Mincom.LinkOne.Content.SelectionList
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public sealed class SelectionListXmlReader
Visual Basic (Declaration)
Public NotInheritable Class SelectionListXmlReader
Visual C++
public ref class SelectionListXmlReader sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Content.SelectionList..::.SelectionListXmlReader

See Also

SelectionListXmlReader Members
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListXmlReader Members

[image] [image]

LinkOne WebView API
SelectionListXmlReader Members
SelectionListXmlReader Class Constructors Methods Properties See Also Send Feedback

The SelectionListXmlReader type exposes the following members.

Constructors

Name | Description
SelectionListXmlReader | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
SelectionList | Gets the SelectionList object or the currently read in data.

See Also

SelectionListXmlReader Class
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListXmlReader Constructor

[image] [image]

LinkOne WebView API
SelectionListXmlReader Constructor
SelectionListXmlReader Class See Also Send Feedback

Overload List

Name | Description
SelectionListXmlReader(String) | Initializes a new instance of the SelectionListXmlReader class.
SelectionListXmlReader(String, ISelectionList) | Constructor.

See Also

SelectionListXmlReader Class
SelectionListXmlReader Members
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListXmlReader Constructor (String)

[image]

LinkOne WebView API
SelectionListXmlReader Constructor (String)
SelectionListXmlReader Class See Also Send Feedback
Initializes a new instance of the SelectionListXmlReader class.

Namespace: Mincom.LinkOne.Content.SelectionList
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public SelectionListXmlReader(
    string selection
)
Visual Basic (Declaration)
Public Sub New ( _
    selection As String _
)
Visual C++
public:
SelectionListXmlReader(
    String^ selection
)

Parameters

selection
Type: System..::.String
The selection list XML to parse.

See Also

SelectionListXmlReader Class
SelectionListXmlReader Overload
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListXmlReader Constructor (String, ISelectionList)

[image]

LinkOne WebView API
SelectionListXmlReader Constructor (String, ISelectionList)
SelectionListXmlReader Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Content.SelectionList
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public SelectionListXmlReader(
    string selection,
    ISelectionList selectionList
)
Visual Basic (Declaration)
Public Sub New ( _
    selection As String, _
    selectionList As ISelectionList _
)
Visual C++
public:
SelectionListXmlReader(
    String^ selection,
    ISelectionList^ selectionList
)

Parameters

selection
Type: System..::.String
The selection list XML to parse.
selectionList
Type: Mincom.LinkOne.Dom.SelectionList..::.ISelectionList
The selection list to populate.

See Also

SelectionListXmlReader Class
SelectionListXmlReader Overload
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListXmlReader Methods

[image] [image]

LinkOne WebView API
SelectionListXmlReader Methods
SelectionListXmlReader Class See Also Send Feedback

The SelectionListXmlReader type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SelectionListXmlReader Class
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListXmlReader Properties

[image] [image]

LinkOne WebView API
SelectionListXmlReader Properties
SelectionListXmlReader Class See Also Send Feedback

The SelectionListXmlReader type exposes the following members.

Properties

Name | Description
SelectionList | Gets the SelectionList object or the currently read in data.

See Also

SelectionListXmlReader Class
Mincom.LinkOne.Content.SelectionList Namespace


SelectionList Property

[image]

LinkOne WebView API
SelectionListXmlReader..::.SelectionList Property
SelectionListXmlReader Class See Also Send Feedback
Gets the SelectionList object or the currently read in data.

Namespace: Mincom.LinkOne.Content.SelectionList
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public ISelectionList SelectionList { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectionList As ISelectionList
Visual C++
public:
property ISelectionList^ SelectionList {
    ISelectionList^ get ();
}

See Also

SelectionListXmlReader Class
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListXmlWriter Class

[image]

LinkOne WebView API
SelectionListXmlWriter Class
Members See Also Send Feedback
Represents a SelectionList writer that generates an XML representation of a selection list.

Namespace: Mincom.LinkOne.Content.SelectionList
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public sealed class SelectionListXmlWriter
Visual Basic (Declaration)
Public NotInheritable Class SelectionListXmlWriter
Visual C++
public ref class SelectionListXmlWriter sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Content.SelectionList..::.SelectionListXmlWriter

See Also

SelectionListXmlWriter Members
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListXmlWriter Members

[image] [image]

LinkOne WebView API
SelectionListXmlWriter Members
SelectionListXmlWriter Class Constructors Methods Properties See Also Send Feedback

The SelectionListXmlWriter type exposes the following members.

Constructors

Name | Description
SelectionListXmlWriter | Constructor.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Data | Gets the csv representation of the selection list.

See Also

SelectionListXmlWriter Class
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListXmlWriter Constructor

[image]

LinkOne WebView API
SelectionListXmlWriter Constructor
SelectionListXmlWriter Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Content.SelectionList
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public SelectionListXmlWriter(
    ISelectionList selectionList
)
Visual Basic (Declaration)
Public Sub New ( _
    selectionList As ISelectionList _
)
Visual C++
public:
SelectionListXmlWriter(
    ISelectionList^ selectionList
)

Parameters

selectionList
Type: Mincom.LinkOne.Dom.SelectionList..::.ISelectionList
The selection list definition to write.

See Also

SelectionListXmlWriter Class
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListXmlWriter Methods

[image] [image]

LinkOne WebView API
SelectionListXmlWriter Methods
SelectionListXmlWriter Class See Also Send Feedback

The SelectionListXmlWriter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SelectionListXmlWriter Class
Mincom.LinkOne.Content.SelectionList Namespace


SelectionListXmlWriter Properties

[image] [image]

LinkOne WebView API
SelectionListXmlWriter Properties
SelectionListXmlWriter Class See Also Send Feedback

The SelectionListXmlWriter type exposes the following members.

Properties

Name | Description
Data | Gets the csv representation of the selection list.

See Also

SelectionListXmlWriter Class
Mincom.LinkOne.Content.SelectionList Namespace


Data Property

[image]

LinkOne WebView API
SelectionListXmlWriter..::.Data Property
SelectionListXmlWriter Class See Also Send Feedback
Gets the csv representation of the selection list.

Namespace: Mincom.LinkOne.Content.SelectionList
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
public string Data { get; }
Visual Basic (Declaration)
Public ReadOnly Property Data As String
Visual C++
public:
property String^ Data {
    String^ get ();
}

See Also

SelectionListXmlWriter Class
Mincom.LinkOne.Content.SelectionList Namespace


Mincom.LinkOne.Dom Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.Dom Namespace
Send Feedback
The Mincom.LinkOne.Dom namespace contains classes and interfaces that represent the LinkOne Document Object Model (DOM). The LinkOne DOM encapsulates the structure of a LinkOne Book as objects that may be accessed via any .Net compatible programming language.

Classes

Class | Description
Book | A LinkOne Book.
BookCategory | Represent a category of Publisher Book objects.
BookCategoryCollection | Represents a collection of BookCategory objects keyed on, and sorted by CategoryCode.
BookCollection | Represents a collection of Book objects keyed on, and sorted by book code.
Catalog | Represents the hierarchy of books within a publisher.
Entry | An entry record in a LinkOne parts list.
EntryCollection | Represents a collection of Entry objects.
ExceptionCollection | Represents a collection of BaseException objects that can be accessed by index.
Field | A generic data field.
FieldCollection | Represents a collection of fields, indexed by Name.
GetValueEventArgs | Provides data for the GetValue event.
Graphic | Represents an "Additional Graphic" that has been included in a LinkOne Book.
Library | The Library object is the root point of contact for access to the LinkOne book library.
LibraryBookCollection | Represents a collection of Book objects sorted by publisher code then book code.
Manifest | The Manifest class.
ManifestEntry | The ManifestEntry class.
Overlay | An overlay graphic on a LinkOne picture.
OverlayCollection | Represents a collection of Overlay objects that can be accessed by index.
Page | A page of a LinkOne Book.
PageCollection | Represents a collection of Page objects that can be accessed by index, or page reference.
PersistIdentity | Identifies the wanted item during an IPersistProver.Read() call.
Picture | A picture on a LinkOne page.
PictureCollection | Represents a collection of Picture objects that can be accessed by index, and location.
PictureResource | Represents a Dom Picture resource.
PredefinedBookFieldNames | Predefined book fields.
PredefinedBookValueNames | Predefined book values.
PredefinedEntryFieldNames | Predefined entry fields.
PredefinedLibraryValueNames | The library predefined values.
PredefinedPageFieldNames | The predefined page fields.
PredefinedPictureFieldNames | The predefined picture fields.
Publisher | Represents a LinkOne publisher of Book objects.
PublisherCollection | Represents a collection of Publisher objects sorted by publisher code.
ReadOnlyList<(Of <(T>)>) | Provides the base class for a read-only list.
ReadOnlyTranslationCollection | Represents a read-only collection of translations, that can be individually accessed by either index, or key, LanguageCode.
Resource | The Resource class wraps raw binary data for persistance.
Toc | Represents a LinkOne Table of Contents.
TocEntry | Represents an entry in a LinkOne book table of contents.
TocEntryCollection | A collection of TocEntry objects.
Tracing | Trace switch for the assembly.
Translation | Represents a translation of a description.
TranslationCollection | Represents a collection of translations, that can be individually accessed by either index, or key, LanguageCode.
Utility | Handy routines.
ValueCollection | LinkOne value provider, implements IValueCollection.

Interfaces

Interface | Description
IBook | A LinkOne Book.
IBookCategory | Represents a category of books for a publisher.
IBookCategoryCollection | Represents a collection of categories, indexed by CategoryCode.
IBookCollection | Represents a collection of books, indexed by BookCode.
ICatalog | Represents the hierarchy of books for a publisher.
IConfigurationManager | Implemented by a class that provides configuration management for LinkOne objects.
IEntry | An entry record in a LinkOne parts list.
IEntryCollection | Represents a collection of entries, that can be individually accessed by either index, or key, TagNumber.
IExceptionCollection | Represents a collection of BaseException objects that can be accessed by index.
IField | A generic data field.
IFieldCollection | Represents a collection of fields, indexed by Name.
ILibrary | The Library object is the root point of contact for access to the LinkOne book library.
INotifyChanged | Notifies clients that the object has changed.
IPage | Represents a page in a LinkOne book.
IPageCollection | Represents a collection of pages that can be individually accessed by either index, or key, Reference.
IPersist | Implemented by classes that have state to persist between sessions.
IPersistIdentity | Identifies the wanted item during an IPersistProver.Read() call.
IPersistProvider | Implemented by classes that provide object persistance.
IPicture | A picture on a LinkOne page.
IPictureCollection | Represents a collection of pictures that can be individually accessed by index.
IPrincipal | Implemented by classes that identify a user.
IPrincipal2 | Implemented by classes that identify a user.
IPrincipal3 |
IPublisher | Represents a publisher of LinkOne books.
IPublisherCollection | Represents a collection of publishers, indexed by PublisherCode.
IToc | Represents the table of contents for a LinkOne book.
ITocEntry | Gets a table of contents entry.
ITocEntryCollection | Represents a collection of entries in the table of contents hierarchy. A toc entry is retrieved by index.
ITranslation | Represents a translation of a description.
ITranslationCollection | Represents a collection of translations, that can be individually accessed by either index, or key, LanguageCode.
IValueCollection | Provides a method for retrieving values from LinkOne. See PredefinedLibraryValueNames and PredefinedBookValueNames for a list of supported values.

Delegates

Delegate | Description
GetValueEventHandler | Represents the method that will handle the read value event.

Enumerations

Enumeration | Description
BookType | Describes the origin of the book.
ManifestEntryActionType | The manifest entry actions.
ManifestTargetImageType | The enumeration of Manifest File Action Type.
PageType | Describes the content of the page.
TocOrder | Permissable ordering for the table of contents.


Book Class

[image]

LinkOne WebView API
Book Class
Members See Also Send Feedback
A LinkOne Book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class Book : IPersist, IBook,
    IDisposable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class Book _
    Implements IPersist, IBook, IDisposable
Visual C++
[SerializableAttribute]
public ref class Book sealed : IPersist,
    IBook, IDisposable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.Book

See Also

Book Members
Mincom.LinkOne.Dom Namespace


Book Members

[image] [image]

LinkOne WebView API
Book Members
Book Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The Book type exposes the following members.

Constructors

Name | Description
Book | Initializes a new instance of the Book class

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetAboutPublisherLocationForLanguage | Gets the location for the about publisher file.
GetField | Returns the value of the wanted field.
GetGraphic | Gets the wanted graphic resource.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPage | Gets the wanted page.
GetType | Gets the type of the current instance. (Inherited from Object.)
IsMissingPage | Determines whether the page reference does not exist in the book, either as an accessible page or as a page removed via an option filter.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatedPages | Gets all related pages for the given group id.
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
Attributes | Gets the collection of attributes for the book.
BookCode | Gets the book code for the book.
BookDescription | Gets the book description for the book.
BookDescriptionTranslations | Gets the book description translations.
BookType | Gets the type of the book.
Categories | Gets the note categories visible to the book, publisher and library.
CategoryCodes | Gets the list of book category codes associated with the book.
ConfiguredObjectIdentifier | Gets the object identifier that was used if the book was opened through the configuration manager.
ContractorName | Gets the contractor name attribute for the book.
EntryFieldDefinitions | Gets the list of custom entry field definitions for thebook.
Errors | Gets the collection of errors found while reading the book.
Fields | Gets the collection of fields for the book.
Filters | Gets the collection of filters that have been applied to this book.
IncludedPages | Gets the collection of included page references.
InternalBookCode | Gets the internal book code for the book.
InternalBookDescription | Gets the internal book description for the book.
InternalPublisherCode | Gets the internal publisher code for the book.
InternalPublisherDescription | Gets the internal publisher description for the book.
IsDraft | Returns true if the book is a draft book. False otherwise.
IsEvaluation | Returns true if the book is an evauation book. False otherwise.
IsExpired | Returns true if the book has expired. False otherwise.
Library | Gets the owning library of the book.
Licenses | Gets the collection of licenses that have been applied to this book.
Location | Gets the book location.
MasterBookCode | Gets the master book code for the book.
Notes | Gets the notes visible to the book, publisher and library.
OptionDefinitions | Gets the collection of option definitions for the book.
Pages | Gets the collection of pages for the book.
PrintLayouts | Gets the collection of layouts included in this book that can be used on the printer.
PublishedDate | Gets the date the book was published.
PublisherCode | Gets the publisher code for the book.
PublisherDescription | Gets the publisher description for the book.
ScreenLayouts | Gets the collection of layouts included in this book that can be used on the screen.
SearchEntryMap | Gets the SearchEntryMap.
SearchPageMap | Gets the SearchPageMap.
SearchSets | Gets the collection of search sets included in this book.
SearchWordMap | Gets the SearchWordMap.
SerialNumber | Gets the serial or sequence number for the book.
StylesheetFullPath |
Toc | Gets the table of contents for the book.
Values | Gets the values visible to the book.

Explicit Interface Implementations

Name | Description
IBook..::.Attributes |
IBook..::.BookDescriptionTranslations |
IBook..::.Categories |
IBook..::.Fields |
IBook..::.Filters |
IBook..::.GetField |
IBook..::.Library |
IBook..::.Licenses |
IBook..::.Notes |
IBook..::.OptionDefinitions |
IBook..::.Pages |
IBook..::.PrintLayouts |
IBook..::.ScreenLayouts |
IBook..::.SearchSets |
IBook..::.Toc |
IBook..::.Values |

See Also

Book Class
Mincom.LinkOne.Dom Namespace


Book Constructor

[image]

LinkOne WebView API
Book Constructor
Book Class See Also Send Feedback
Initializes a new instance of the Book class

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Book(
    IDomReader domReader,
    bool ignoreLangFilter
)
Visual Basic (Declaration)
Public Sub New ( _
    domReader As IDomReader, _
    ignoreLangFilter As Boolean _
)
Visual C++
public:
Book(
    IDomReader^ domReader,
    bool ignoreLangFilter
)

Parameters

domReader
Type: IDomReader
ignoreLangFilter
Type: System..::.Boolean

See Also

Book Class
Mincom.LinkOne.Dom Namespace


Book Methods

[image] [image]

LinkOne WebView API
Book Methods
Book Class See Also Send Feedback

The Book type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetAboutPublisherLocationForLanguage | Gets the location for the about publisher file.
GetField | Returns the value of the wanted field.
GetGraphic | Gets the wanted graphic resource.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPage | Gets the wanted page.
GetType | Gets the type of the current instance. (Inherited from Object.)
IsMissingPage | Determines whether the page reference does not exist in the book, either as an accessible page or as a page removed via an option filter.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatedPages | Gets all related pages for the given group id.
ToString | (Overrides Object..::.ToString()()().)

Explicit Interface Implementations

Name | Description
IBook..::.GetField |

See Also

Book Class
Mincom.LinkOne.Dom Namespace


Dispose Method

[image]

LinkOne WebView API
Book..::.Dispose Method
Book Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

Book Class
Mincom.LinkOne.Dom Namespace


GetAboutPublisherLocationForLanguage Method

[image]

LinkOne WebView API
Book..::.GetAboutPublisherLocationForLanguage Method
Book Class See Also Send Feedback
Gets the location for the about publisher file.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string GetAboutPublisherLocationForLanguage(
    string languageCode
)
Visual Basic (Declaration)
Public Function GetAboutPublisherLocationForLanguage ( _
    languageCode As String _
) As String
Visual C++
public:
String^ GetAboutPublisherLocationForLanguage(
    String^ languageCode
)

Parameters

languageCode
Type: System..::.String
The language code.

Return Value

Remarks

Precedence order for publisher help file is:
<publisher_directory>\<lc>-MAN.chm
<publisher_directory>\<lc>-MAN.hlp
<publisher_directory>\<publisher code>.chm
<publisher_directory>\<publisher code>.hlp
<publisher_directory>\MAN.chm
<publisher_directory>\MAN.hlp
<bin_directory>\<lc>-MAN.chm
<bin_directory>\<lc>-MAN.hlp
<bin_directory>\<publisher code>.chm
<bin_directory>\<publisher code>.hlp
<bin_directory>\MAN.chm
<bin_directory>\MAN.hlp

See Also

Book Class
Mincom.LinkOne.Dom Namespace


GetField Method

[image]

LinkOne WebView API
Book..::.GetField Method
Book Class See Also Send Feedback
Returns the value of the wanted field.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string GetField(
    string name
)
Visual Basic (Declaration)
Public Function GetField ( _
    name As String _
) As String
Visual C++
public:
String^ GetField(
    String^ name
)

Parameters

name
Type: System..::.String
Name of the wanted field.

Return Value

The value of the wanted field, or blank if not found.

See Also

Book Class
Mincom.LinkOne.Dom Namespace


GetGraphic Method

[image]

LinkOne WebView API
Book..::.GetGraphic Method
Book Class See Also Send Feedback
Gets the wanted graphic resource.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Resource GetGraphic(
    string graphicReference
)
Visual Basic (Declaration)
Public Function GetGraphic ( _
    graphicReference As String _
) As Resource
Visual C++
public:
Resource^ GetGraphic(
    String^ graphicReference
)

Parameters

graphicReference
Type: System..::.String
Relative path to the additional graphic.

Return Value

The wanted additional graphic resource, or null if the graphic was not found.

See Also

Book Class
Mincom.LinkOne.Dom Namespace


GetPage Method

[image]

LinkOne WebView API
Book..::.GetPage Method
Book Class See Also Send Feedback
Gets the wanted page.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Page GetPage(
    string pageReference
)
Visual Basic (Declaration)
Public Function GetPage ( _
    pageReference As String _
) As Page
Visual C++
public:
Page^ GetPage(
    String^ pageReference
)

Parameters

pageReference
Type: System..::.String
Page reference of the wanted page.

Return Value

The filtered Page object, or null if the page was not found.

See Also

Book Class
Mincom.LinkOne.Dom Namespace


IBook.GetField Method

[image]

LinkOne WebView API
Book..::.IBook..::.GetField Method
Book Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string IBook.GetField(
    string name
)
Visual Basic (Declaration)
Private Function GetField ( _
    name As String _
) As String Implements IBook.GetField
Visual C++
private:
virtual String^ GetField(
    String^ name
) sealed = IBook::GetField

Parameters

name
Type: System..::.String

Implements

IBook..::.GetField(String)

See Also

Book Class
Mincom.LinkOne.Dom Namespace


IsMissingPage Method

[image]

LinkOne WebView API
Book..::.IsMissingPage Method
Book Class See Also Send Feedback
Determines whether the page reference does not exist in the book, either as an accessible page or as a page removed via an option filter.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsMissingPage(
    string pageReference
)
Visual Basic (Declaration)
Public Function IsMissingPage ( _
    pageReference As String _
) As Boolean
Visual C++
public:
bool IsMissingPage(
    String^ pageReference
)

Parameters

pageReference
Type: System..::.String
The page reference to search for.

Return Value

true if the page reference does not exist in the book; otherwise, false.

See Also

Book Class
Mincom.LinkOne.Dom Namespace


RelatedPages Method

[image]

LinkOne WebView API
Book..::.RelatedPages Method
Book Class See Also Send Feedback
Gets all related pages for the given group id.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PageCollection RelatedPages(
    string groupId
)
Visual Basic (Declaration)
Public Function RelatedPages ( _
    groupId As String _
) As PageCollection
Visual C++
public:
PageCollection^ RelatedPages(
    String^ groupId
)

Parameters

groupId
Type: System..::.String
The group id of the page, .

Return Value

The related pages.

See Also

Book Class
Mincom.LinkOne.Dom Namespace
Page..::.GroupId


ToString Method

[image]

LinkOne WebView API
Book..::.ToString Method
Book Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

Book Class
Mincom.LinkOne.Dom Namespace


Book Properties

[image] [image]

LinkOne WebView API
Book Properties
Book Class See Also Send Feedback

The Book type exposes the following members.

Properties

Name | Description
Attributes | Gets the collection of attributes for the book.
BookCode | Gets the book code for the book.
BookDescription | Gets the book description for the book.
BookDescriptionTranslations | Gets the book description translations.
BookType | Gets the type of the book.
Categories | Gets the note categories visible to the book, publisher and library.
CategoryCodes | Gets the list of book category codes associated with the book.
ConfiguredObjectIdentifier | Gets the object identifier that was used if the book was opened through the configuration manager.
ContractorName | Gets the contractor name attribute for the book.
EntryFieldDefinitions | Gets the list of custom entry field definitions for thebook.
Errors | Gets the collection of errors found while reading the book.
Fields | Gets the collection of fields for the book.
Filters | Gets the collection of filters that have been applied to this book.
IncludedPages | Gets the collection of included page references.
InternalBookCode | Gets the internal book code for the book.
InternalBookDescription | Gets the internal book description for the book.
InternalPublisherCode | Gets the internal publisher code for the book.
InternalPublisherDescription | Gets the internal publisher description for the book.
IsDraft | Returns true if the book is a draft book. False otherwise.
IsEvaluation | Returns true if the book is an evauation book. False otherwise.
IsExpired | Returns true if the book has expired. False otherwise.
Library | Gets the owning library of the book.
Licenses | Gets the collection of licenses that have been applied to this book.
Location | Gets the book location.
MasterBookCode | Gets the master book code for the book.
Notes | Gets the notes visible to the book, publisher and library.
OptionDefinitions | Gets the collection of option definitions for the book.
Pages | Gets the collection of pages for the book.
PrintLayouts | Gets the collection of layouts included in this book that can be used on the printer.
PublishedDate | Gets the date the book was published.
PublisherCode | Gets the publisher code for the book.
PublisherDescription | Gets the publisher description for the book.
ScreenLayouts | Gets the collection of layouts included in this book that can be used on the screen.
SearchEntryMap | Gets the SearchEntryMap.
SearchPageMap | Gets the SearchPageMap.
SearchSets | Gets the collection of search sets included in this book.
SearchWordMap | Gets the SearchWordMap.
SerialNumber | Gets the serial or sequence number for the book.
StylesheetFullPath |
Toc | Gets the table of contents for the book.
Values | Gets the values visible to the book.

Explicit Interface Implementations

Name | Description
IBook..::.Attributes |
IBook..::.BookDescriptionTranslations |
IBook..::.Categories |
IBook..::.Fields |
IBook..::.Filters |
IBook..::.Library |
IBook..::.Licenses |
IBook..::.Notes |
IBook..::.OptionDefinitions |
IBook..::.Pages |
IBook..::.PrintLayouts |
IBook..::.ScreenLayouts |
IBook..::.SearchSets |
IBook..::.Toc |
IBook..::.Values |

See Also

Book Class
Mincom.LinkOne.Dom Namespace


Attributes Property

[image]

LinkOne WebView API
Book..::.Attributes Property
Book Class See Also Send Feedback
Gets the collection of attributes for the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookAttributeCollection Attributes { get; }
Visual Basic (Declaration)
Public ReadOnly Property Attributes As BookAttributeCollection
Visual C++
public:
property BookAttributeCollection^ Attributes {
    BookAttributeCollection^ get ();
}

Return Value

Returns the BookAttributeDictionary that contain the attributes.

See Also

Book Class
Mincom.LinkOne.Dom Namespace


BookCode Property

[image]

LinkOne WebView API
Book..::.BookCode Property
Book Class See Also Send Feedback
Gets the book code for the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string BookCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property BookCode As String
Visual C++
public:
virtual property String^ BookCode {
    String^ get () sealed;
}

Return Value

The book code of the book as a string.

Implements

IBook..::.BookCode

See Also

Book Class
Mincom.LinkOne.Dom Namespace


BookDescription Property

[image]

LinkOne WebView API
Book..::.BookDescription Property
Book Class See Also Send Feedback
Gets the book description for the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string BookDescription { get; }
Visual Basic (Declaration)
Public ReadOnly Property BookDescription As String
Visual C++
public:
virtual property String^ BookDescription {
    String^ get () sealed;
}

Return Value

A description of the book as a string.

Implements

IBook..::.BookDescription

See Also

Book Class
Mincom.LinkOne.Dom Namespace


BookDescriptionTranslations Property

[image]

LinkOne WebView API
Book..::.BookDescriptionTranslations Property
Book Class See Also Send Feedback
Gets the book description translations.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ReadOnlyTranslationCollection BookDescriptionTranslations { get; }
Visual Basic (Declaration)
Public ReadOnly Property BookDescriptionTranslations As ReadOnlyTranslationCollection
Visual C++
public:
property ReadOnlyTranslationCollection^ BookDescriptionTranslations {
    ReadOnlyTranslationCollection^ get ();
}

See Also

Book Class
Mincom.LinkOne.Dom Namespace


BookType Property

[image]

LinkOne WebView API
Book..::.BookType Property
Book Class See Also Send Feedback
Gets the type of the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookType BookType { get; }
Visual Basic (Declaration)
Public ReadOnly Property BookType As BookType
Visual C++
public:
property BookType BookType {
    BookType get ();
}

Return Value

Returns the book type as a BookType.

See Also

Book Class
Mincom.LinkOne.Dom Namespace


Categories Property

[image]

LinkOne WebView API
Book..::.Categories Property
Book Class See Also Send Feedback
Gets the note categories visible to the book, publisher and library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public CategoryCollection Categories { get; }
Visual Basic (Declaration)
Public ReadOnly Property Categories As CategoryCollection
Visual C++
public:
property CategoryCollection^ Categories {
    CategoryCollection^ get ();
}

See Also

Book Class
Mincom.LinkOne.Dom Namespace


CategoryCodes Property

[image]

LinkOne WebView API
Book..::.CategoryCodes Property
Book Class See Also Send Feedback
Gets the list of book category codes associated with the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IList<string> CategoryCodes { get; }
Visual Basic (Declaration)
Public ReadOnly Property CategoryCodes As IList(Of String)
Visual C++
public:
virtual property IList<String^>^ CategoryCodes {
    IList<String^>^ get () sealed;
}

Return Value

The list of category codes associated with the book.

Implements

IBook..::.CategoryCodes

See Also

Book Class
Mincom.LinkOne.Dom Namespace


ConfiguredObjectIdentifier Property

[image]

LinkOne WebView API
Book..::.ConfiguredObjectIdentifier Property
Book Class See Also Send Feedback
Gets the object identifier that was used if the book was opened through the configuration manager.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string ConfiguredObjectIdentifier { get; internal set; }
Visual Basic (Declaration)
Public Property ConfiguredObjectIdentifier As String
Visual C++
public:
property String^ ConfiguredObjectIdentifier {
    String^ get ();
    void set (String^ value);
}

See Also

Book Class
Mincom.LinkOne.Dom Namespace


ContractorName Property

[image]

LinkOne WebView API
Book..::.ContractorName Property
Book Class See Also Send Feedback
Gets the contractor name attribute for the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string ContractorName { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContractorName As String
Visual C++
public:
property String^ ContractorName {
    String^ get ();
}

See Also

Book Class
Mincom.LinkOne.Dom Namespace


EntryFieldDefinitions Property

[image]

LinkOne WebView API
Book..::.EntryFieldDefinitions Property
Book Class See Also Send Feedback
Gets the list of custom entry field definitions for thebook.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IList<string> EntryFieldDefinitions { get; }
Visual Basic (Declaration)
Public ReadOnly Property EntryFieldDefinitions As IList(Of String)
Visual C++
public:
virtual property IList<String^>^ EntryFieldDefinitions {
    IList<String^>^ get () sealed;
}

Field Value

The read only list of custom entry field fefinitions.

Return Value

Returns the read only list of custom entry field defintions for the current book..

Implements

IBook..::.EntryFieldDefinitions

See Also

Book Class
Mincom.LinkOne.Dom Namespace


Errors Property

[image]

LinkOne WebView API
Book..::.Errors Property
Book Class See Also Send Feedback
Gets the collection of errors found while reading the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ExceptionCollection Errors { get; }
Visual Basic (Declaration)
Public ReadOnly Property Errors As ExceptionCollection
Visual C++
public:
property ExceptionCollection^ Errors {
    ExceptionCollection^ get ();
}

See Also

Book Class
Mincom.LinkOne.Dom Namespace


Fields Property

[image]

LinkOne WebView API
Book..::.Fields Property
Book Class See Also Send Feedback
Gets the collection of fields for the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public FieldCollection Fields { get; }
Visual Basic (Declaration)
Public ReadOnly Property Fields As FieldCollection
Visual C++
public:
property FieldCollection^ Fields {
    FieldCollection^ get ();
}

Field Value

The FieldCollection that contains the fields.

Return Value

Returns the collection of fields associated with a book as a FieldCollection object.

See Also

Book Class
Mincom.LinkOne.Dom Namespace


Filters Property

[image]

LinkOne WebView API
Book..::.Filters Property
Book Class See Also Send Feedback
Gets the collection of filters that have been applied to this book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ReadOnlyFilterCollection Filters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Filters As ReadOnlyFilterCollection
Visual C++
public:
property ReadOnlyFilterCollection^ Filters {
    ReadOnlyFilterCollection^ get ();
}

See Also

Book Class
Mincom.LinkOne.Dom Namespace


IBook.Attributes Property

[image]

LinkOne WebView API
Book..::.IBook..::.Attributes Property
Book Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IAttributeCollection IBook.Attributes { get; }
Visual Basic (Declaration)
Private ReadOnly Property Attributes As IAttributeCollection
    Implements IBook.Attributes
Visual C++
private:
virtual property IAttributeCollection^ Attributes {
    IAttributeCollection^ get () sealed = IBook::Attributes::get;
}

Implements

IBook..::.Attributes

See Also

Book Class
Mincom.LinkOne.Dom Namespace


IBook.BookDescriptionTranslations Property

[image]

LinkOne WebView API
Book..::.IBook..::.BookDescriptionTranslations Property
Book Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ITranslationCollection IBook.BookDescriptionTranslations { get; }
Visual Basic (Declaration)
Private ReadOnly Property BookDescriptionTranslations As ITranslationCollection
    Implements IBook.BookDescriptionTranslations
Visual C++
private:
virtual property ITranslationCollection^ BookDescriptionTranslations {
    ITranslationCollection^ get () sealed = IBook::BookDescriptionTranslations::get;
}

Implements

IBook..::.BookDescriptionTranslations

See Also

Book Class
Mincom.LinkOne.Dom Namespace


IBook.Categories Property

[image]

LinkOne WebView API
Book..::.IBook..::.Categories Property
Book Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ICategoryCollection IBook.Categories { get; }
Visual Basic (Declaration)
Private ReadOnly Property Categories As ICategoryCollection
    Implements IBook.Categories
Visual C++
private:
virtual property ICategoryCollection^ Categories {
    ICategoryCollection^ get () sealed = IBook::Categories::get;
}

Implements

IBook..::.Categories

See Also

Book Class
Mincom.LinkOne.Dom Namespace


IBook.Fields Property

[image]

LinkOne WebView API
Book..::.IBook..::.Fields Property
Book Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IFieldCollection IBook.Fields { get; }
Visual Basic (Declaration)
Private ReadOnly Property Fields As IFieldCollection
    Implements IBook.Fields
Visual C++
private:
virtual property IFieldCollection^ Fields {
    IFieldCollection^ get () sealed = IBook::Fields::get;
}

Implements

IBook..::.Fields

See Also

Book Class
Mincom.LinkOne.Dom Namespace


IBook.Filters Property

[image]

LinkOne WebView API
Book..::.IBook..::.Filters Property
Book Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IFilterCollection IBook.Filters { get; }
Visual Basic (Declaration)
Private ReadOnly Property Filters As IFilterCollection
    Implements IBook.Filters
Visual C++
private:
virtual property IFilterCollection^ Filters {
    IFilterCollection^ get () sealed = IBook::Filters::get;
}

Implements

IBook..::.Filters

See Also

Book Class
Mincom.LinkOne.Dom Namespace


IBook.Library Property

[image]

LinkOne WebView API
Book..::.IBook..::.Library Property
Book Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ILibrary IBook.Library { get; }
Visual Basic (Declaration)
Private ReadOnly Property Library As ILibrary
    Implements IBook.Library
Visual C++
private:
virtual property ILibrary^ Library {
    ILibrary^ get () sealed = IBook::Library::get;
}

Implements

IBook..::.Library

See Also

Book Class
Mincom.LinkOne.Dom Namespace


IBook.Licenses Property

[image]

LinkOne WebView API
Book..::.IBook..::.Licenses Property
Book Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IList<string> IBook.Licenses { get; }
Visual Basic (Declaration)
Private ReadOnly Property Licenses As IList(Of String)
    Implements IBook.Licenses
Visual C++
private:
virtual property IList<String^>^ Licenses {
    IList<String^>^ get () sealed = IBook::Licenses::get;
}

Implements

IBook..::.Licenses

See Also

Book Class
Mincom.LinkOne.Dom Namespace


IBook.Notes Property

[image]

LinkOne WebView API
Book..::.IBook..::.Notes Property
Book Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
INoteCollection IBook.Notes { get; }
Visual Basic (Declaration)
Private ReadOnly Property Notes As INoteCollection
    Implements IBook.Notes
Visual C++
private:
virtual property INoteCollection^ Notes {
    INoteCollection^ get () sealed = IBook::Notes::get;
}

Implements

IBook..::.Notes

See Also

Book Class
Mincom.LinkOne.Dom Namespace


IBook.OptionDefinitions Property

[image]

LinkOne WebView API
Book..::.IBook..::.OptionDefinitions Property
Book Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IOptionDefinitionCollection IBook.OptionDefinitions { get; }
Visual Basic (Declaration)
Private ReadOnly Property OptionDefinitions As IOptionDefinitionCollection
    Implements IBook.OptionDefinitions
Visual C++
private:
virtual property IOptionDefinitionCollection^ OptionDefinitions {
    IOptionDefinitionCollection^ get () sealed = IBook::OptionDefinitions::get;
}

Implements

IBook..::.OptionDefinitions

See Also

Book Class
Mincom.LinkOne.Dom Namespace


IBook.Pages Property

[image]

LinkOne WebView API
Book..::.IBook..::.Pages Property
Book Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPageCollection IBook.Pages { get; }
Visual Basic (Declaration)
Private ReadOnly Property Pages As IPageCollection
    Implements IBook.Pages
Visual C++
private:
virtual property IPageCollection^ Pages {
    IPageCollection^ get () sealed = IBook::Pages::get;
}

Implements

IBook..::.Pages

See Also

Book Class
Mincom.LinkOne.Dom Namespace


IBook.PrintLayouts Property

[image]

LinkOne WebView API
Book..::.IBook..::.PrintLayouts Property
Book Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ILayoutCollection IBook.PrintLayouts { get; }
Visual Basic (Declaration)
Private ReadOnly Property PrintLayouts As ILayoutCollection
    Implements IBook.PrintLayouts
Visual C++
private:
virtual property ILayoutCollection^ PrintLayouts {
    ILayoutCollection^ get () sealed = IBook::PrintLayouts::get;
}

Implements

IBook..::.PrintLayouts

See Also

Book Class
Mincom.LinkOne.Dom Namespace


IBook.ScreenLayouts Property

[image]

LinkOne WebView API
Book..::.IBook..::.ScreenLayouts Property
Book Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ILayoutCollection IBook.ScreenLayouts { get; }
Visual Basic (Declaration)
Private ReadOnly Property ScreenLayouts As ILayoutCollection
    Implements IBook.ScreenLayouts
Visual C++
private:
virtual property ILayoutCollection^ ScreenLayouts {
    ILayoutCollection^ get () sealed = IBook::ScreenLayouts::get;
}

Implements

IBook..::.ScreenLayouts

See Also

Book Class
Mincom.LinkOne.Dom Namespace


IBook.SearchSets Property

[image]

LinkOne WebView API
Book..::.IBook..::.SearchSets Property
Book Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ISearchSetCollection IBook.SearchSets { get; }
Visual Basic (Declaration)
Private ReadOnly Property SearchSets As ISearchSetCollection
    Implements IBook.SearchSets
Visual C++
private:
virtual property ISearchSetCollection^ SearchSets {
    ISearchSetCollection^ get () sealed = IBook::SearchSets::get;
}

Implements

IBook..::.SearchSets

See Also

Book Class
Mincom.LinkOne.Dom Namespace


IBook.Toc Property

[image]

LinkOne WebView API
Book..::.IBook..::.Toc Property
Book Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IToc IBook.Toc { get; }
Visual Basic (Declaration)
Private ReadOnly Property Toc As IToc
    Implements IBook.Toc
Visual C++
private:
virtual property IToc^ Toc {
    IToc^ get () sealed = IBook::Toc::get;
}

Implements

IBook..::.Toc

See Also

Book Class
Mincom.LinkOne.Dom Namespace


IBook.Values Property

[image]

LinkOne WebView API
Book..::.IBook..::.Values Property
Book Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IValueCollection IBook.Values { get; }
Visual Basic (Declaration)
Private ReadOnly Property Values As IValueCollection
    Implements IBook.Values
Visual C++
private:
virtual property IValueCollection^ Values {
    IValueCollection^ get () sealed = IBook::Values::get;
}

Implements

IBook..::.Values

See Also

Book Class
Mincom.LinkOne.Dom Namespace


IncludedPages Property

[image]

LinkOne WebView API
Book..::.IncludedPages Property
Book Class See Also Send Feedback
Gets the collection of included page references.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ICollection<string> IncludedPages { get; }
Visual Basic (Declaration)
Public ReadOnly Property IncludedPages As ICollection(Of String)
Visual C++
public:
property ICollection<String^>^ IncludedPages {
    ICollection<String^>^ get ();
}

Return Value

Returns the collection of included page references for a derived book.

See Also

Book Class
Mincom.LinkOne.Dom Namespace


InternalBookCode Property

[image]

LinkOne WebView API
Book..::.InternalBookCode Property
Book Class See Also Send Feedback
Gets the internal book code for the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string InternalBookCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property InternalBookCode As String
Visual C++
public:
virtual property String^ InternalBookCode {
    String^ get () sealed;
}

Return Value

The internal book code of the book as a string.

Implements

IBook..::.InternalBookCode

See Also

Book Class
Mincom.LinkOne.Dom Namespace


InternalBookDescription Property

[image]

LinkOne WebView API
Book..::.InternalBookDescription Property
Book Class See Also Send Feedback
Gets the internal book description for the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string InternalBookDescription { get; }
Visual Basic (Declaration)
Public ReadOnly Property InternalBookDescription As String
Visual C++
public:
virtual property String^ InternalBookDescription {
    String^ get () sealed;
}

Return Value

A description of the internal book as a string.

Implements

IBook..::.InternalBookDescription

See Also

Book Class
Mincom.LinkOne.Dom Namespace


InternalPublisherCode Property

[image]

LinkOne WebView API
Book..::.InternalPublisherCode Property
Book Class See Also Send Feedback
Gets the internal publisher code for the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string InternalPublisherCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property InternalPublisherCode As String
Visual C++
public:
virtual property String^ InternalPublisherCode {
    String^ get () sealed;
}

Return Value

The internal publisher code of the book.

Implements

IBook..::.InternalPublisherCode

See Also

Book Class
Mincom.LinkOne.Dom Namespace


InternalPublisherDescription Property

[image]

LinkOne WebView API
Book..::.InternalPublisherDescription Property
Book Class See Also Send Feedback
Gets the internal publisher description for the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string InternalPublisherDescription { get; }
Visual Basic (Declaration)
Public ReadOnly Property InternalPublisherDescription As String
Visual C++
public:
virtual property String^ InternalPublisherDescription {
    String^ get () sealed;
}

Return Value

A description of the internal publisher of type string.

Implements

IBook..::.InternalPublisherDescription

See Also

Book Class
Mincom.LinkOne.Dom Namespace


IsDraft Property

[image]

LinkOne WebView API
Book..::.IsDraft Property
Book Class See Also Send Feedback
Returns true if the book is a draft book. False otherwise.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsDraft { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsDraft As Boolean
Visual C++
public:
virtual property bool IsDraft {
    bool get () sealed;
}

Implements

IBook..::.IsDraft

See Also

Book Class
Mincom.LinkOne.Dom Namespace


IsEvaluation Property

[image]

LinkOne WebView API
Book..::.IsEvaluation Property
Book Class See Also Send Feedback
Returns true if the book is an evauation book. False otherwise.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsEvaluation { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsEvaluation As Boolean
Visual C++
public:
property bool IsEvaluation {
    bool get ();
}

See Also

Book Class
Mincom.LinkOne.Dom Namespace


IsExpired Property

[image]

LinkOne WebView API
Book..::.IsExpired Property
Book Class See Also Send Feedback
Returns true if the book has expired. False otherwise.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsExpired { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsExpired As Boolean
Visual C++
public:
property bool IsExpired {
    bool get ();
}

See Also

Book Class
Mincom.LinkOne.Dom Namespace


Library Property

[image]

LinkOne WebView API
Book..::.Library Property
Book Class See Also Send Feedback
Gets the owning library of the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Library Library { get; internal set; }
Visual Basic (Declaration)
Public Property Library As Library
Visual C++
public:
property Library^ Library {
    Library^ get ();
    void set (Library^ value);
}

Return Value

Get method returns owning library of type Library, Set returns void

See Also

Book Class
Mincom.LinkOne.Dom Namespace


Licenses Property

[image]

LinkOne WebView API
Book..::.Licenses Property
Book Class See Also Send Feedback
Gets the collection of licenses that have been applied to this book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ReadOnlyLinkOneLicenseCollection Licenses { get; }
Visual Basic (Declaration)
Public ReadOnly Property Licenses As ReadOnlyLinkOneLicenseCollection
Visual C++
public:
property ReadOnlyLinkOneLicenseCollection^ Licenses {
    ReadOnlyLinkOneLicenseCollection^ get ();
}

Return Value

The license collection applied to the particlar book as a LicenseCollection object.

Remarks

To add or remove licenses for a book, see Library and Licenses.

See Also

Book Class
Mincom.LinkOne.Dom Namespace


Location Property

[image]

LinkOne WebView API
Book..::.Location Property
Book Class See Also Send Feedback
Gets the book location.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Location { get; }
Visual Basic (Declaration)
Public ReadOnly Property Location As String
Visual C++
public:
property String^ Location {
    String^ get ();
}

See Also

Book Class
Mincom.LinkOne.Dom Namespace


MasterBookCode Property

[image]

LinkOne WebView API
Book..::.MasterBookCode Property
Book Class See Also Send Feedback
Gets the master book code for the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string MasterBookCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property MasterBookCode As String
Visual C++
public:
property String^ MasterBookCode {
    String^ get ();
}

Return Value

The book code of the master book as a string.

Remarks

This property is only present on derived books, and Aliasalias books.

See Also

Book Class
Mincom.LinkOne.Dom Namespace


Notes Property

[image]

LinkOne WebView API
Book..::.Notes Property
Book Class See Also Send Feedback
Gets the notes visible to the book, publisher and library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public NoteCollection Notes { get; }
Visual Basic (Declaration)
Public ReadOnly Property Notes As NoteCollection
Visual C++
public:
property NoteCollection^ Notes {
    NoteCollection^ get ();
}

See Also

Book Class
Mincom.LinkOne.Dom Namespace


OptionDefinitions Property

[image]

LinkOne WebView API
Book..::.OptionDefinitions Property
Book Class See Also Send Feedback
Gets the collection of option definitions for the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public OptionDefinitionCollection OptionDefinitions { get; }
Visual Basic (Declaration)
Public ReadOnly Property OptionDefinitions As OptionDefinitionCollection
Visual C++
public:
property OptionDefinitionCollection^ OptionDefinitions {
    OptionDefinitionCollection^ get ();
}

Return Value

The OptionDefinitionCollection that contains the option definitions.

See Also

Book Class
Mincom.LinkOne.Dom Namespace


Pages Property

[image]

LinkOne WebView API
Book..::.Pages Property
Book Class See Also Send Feedback
Gets the collection of pages for the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PageCollection Pages { get; }
Visual Basic (Declaration)
Public ReadOnly Property Pages As PageCollection
Visual C++
public:
property PageCollection^ Pages {
    PageCollection^ get ();
}

Return Value

Returns the PageCollection that contains the Pages.

See Also

Book Class
Mincom.LinkOne.Dom Namespace


PrintLayouts Property

[image]

LinkOne WebView API
Book..::.PrintLayouts Property
Book Class See Also Send Feedback
Gets the collection of layouts included in this book that can be used on the printer.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LayoutCollection PrintLayouts { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrintLayouts As LayoutCollection
Visual C++
public:
property LayoutCollection^ PrintLayouts {
    LayoutCollection^ get ();
}

Return Value

Returns the layout collection associated with the book, as a LayoutCollection object.

See Also

Book Class
Mincom.LinkOne.Dom Namespace


PublishedDate Property

[image]

LinkOne WebView API
Book..::.PublishedDate Property
Book Class See Also Send Feedback
Gets the date the book was published.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public DateTime PublishedDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublishedDate As DateTime
Visual C++
public:
virtual property DateTime PublishedDate {
    DateTime get () sealed;
}

Implements

IBook..::.PublishedDate

See Also

Book Class
Mincom.LinkOne.Dom Namespace


PublisherCode Property

[image]

LinkOne WebView API
Book..::.PublisherCode Property
Book Class See Also Send Feedback
Gets the publisher code for the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PublisherCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublisherCode As String
Visual C++
public:
virtual property String^ PublisherCode {
    String^ get () sealed;
}

Return Value

The publisher code of the book.

Implements

IBook..::.PublisherCode

See Also

Book Class
Mincom.LinkOne.Dom Namespace


PublisherDescription Property

[image]

LinkOne WebView API
Book..::.PublisherDescription Property
Book Class See Also Send Feedback
Gets the publisher description for the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PublisherDescription { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublisherDescription As String
Visual C++
public:
virtual property String^ PublisherDescription {
    String^ get () sealed;
}

Return Value

A description of the publisher of type string.

Implements

IBook..::.PublisherDescription

See Also

Book Class
Mincom.LinkOne.Dom Namespace


ScreenLayouts Property

[image]

LinkOne WebView API
Book..::.ScreenLayouts Property
Book Class See Also Send Feedback
Gets the collection of layouts included in this book that can be used on the screen.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LayoutCollection ScreenLayouts { get; }
Visual Basic (Declaration)
Public ReadOnly Property ScreenLayouts As LayoutCollection
Visual C++
public:
property LayoutCollection^ ScreenLayouts {
    LayoutCollection^ get ();
}

Return Value

Returns the layout collection associated with the book, as a LayoutCollection object.

See Also

Book Class
Mincom.LinkOne.Dom Namespace


SearchEntryMap Property

[image]

LinkOne WebView API
Book..::.SearchEntryMap Property
Book Class See Also Send Feedback
Gets the SearchEntryMap.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchEntryMap SearchEntryMap { get; }
Visual Basic (Declaration)
Public ReadOnly Property SearchEntryMap As SearchEntryMap
Visual C++
public:
property SearchEntryMap^ SearchEntryMap {
    SearchEntryMap^ get ();
}

Return Value

A SearchEntryMap containing all entry maps.

See Also

Book Class
Mincom.LinkOne.Dom Namespace


SearchPageMap Property

[image]

LinkOne WebView API
Book..::.SearchPageMap Property
Book Class See Also Send Feedback
Gets the SearchPageMap.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchPageMap SearchPageMap { get; }
Visual Basic (Declaration)
Public ReadOnly Property SearchPageMap As SearchPageMap
Visual C++
public:
property SearchPageMap^ SearchPageMap {
    SearchPageMap^ get ();
}

Return Value

A SearchPageMap containing all page maps.

See Also

Book Class
Mincom.LinkOne.Dom Namespace


SearchSets Property

[image]

LinkOne WebView API
Book..::.SearchSets Property
Book Class See Also Send Feedback
Gets the collection of search sets included in this book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchSetCollection SearchSets { get; }
Visual Basic (Declaration)
Public ReadOnly Property SearchSets As SearchSetCollection
Visual C++
public:
property SearchSetCollection^ SearchSets {
    SearchSetCollection^ get ();
}

Return Value

Returns the collection of search sets included in this book, as a SearchSetCollection.

See Also

Book Class
Mincom.LinkOne.Dom Namespace


SearchWordMap Property

[image]

LinkOne WebView API
Book..::.SearchWordMap Property
Book Class See Also Send Feedback
Gets the SearchWordMap.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchWordMap SearchWordMap { get; }
Visual Basic (Declaration)
Public ReadOnly Property SearchWordMap As SearchWordMap
Visual C++
public:
property SearchWordMap^ SearchWordMap {
    SearchWordMap^ get ();
}

Return Value

A SearchWordMap containing all words in embedded documents.

See Also

Book Class
Mincom.LinkOne.Dom Namespace


SerialNumber Property

[image]

LinkOne WebView API
Book..::.SerialNumber Property
Book Class See Also Send Feedback
Gets the serial or sequence number for the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string SerialNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property SerialNumber As String
Visual C++
public:
property String^ SerialNumber {
    String^ get ();
}

See Also

Book Class
Mincom.LinkOne.Dom Namespace


StylesheetFullPath Property

[image]

LinkOne WebView API
Book..::.StylesheetFullPath Property
Book Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string StylesheetFullPath { get; private set; }
Visual Basic (Declaration)
Public Property StylesheetFullPath As String
Visual C++
public:
virtual property String^ StylesheetFullPath {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IBook..::.StylesheetFullPath

See Also

Book Class
Mincom.LinkOne.Dom Namespace


Toc Property

[image]

LinkOne WebView API
Book..::.Toc Property
Book Class See Also Send Feedback
Gets the table of contents for the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Toc Toc { get; }
Visual Basic (Declaration)
Public ReadOnly Property Toc As Toc
Visual C++
public:
property Toc^ Toc {
    Toc^ get ();
}

Return Value

The Toc that represents the Table of Contents for the book.

See Also

Book Class
Mincom.LinkOne.Dom Namespace


Values Property

[image]

LinkOne WebView API
Book..::.Values Property
Book Class See Also Send Feedback
Gets the values visible to the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ValueCollection Values { get; }
Visual Basic (Declaration)
Public ReadOnly Property Values As ValueCollection
Visual C++
public:
property ValueCollection^ Values {
    ValueCollection^ get ();
}

See Also

Book Class
Mincom.LinkOne.Dom Namespace


BookCategory Class

[image]

LinkOne WebView API
BookCategory Class
Members See Also Send Feedback
Represent a category of Publisher Book objects.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class BookCategory : Catalog,
    IBookCategory, ICatalog
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class BookCategory _
    Inherits Catalog _
    Implements IBookCategory, ICatalog
Visual C++
[SerializableAttribute]
public ref class BookCategory sealed : public Catalog,
    IBookCategory, ICatalog

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.Catalog
Mincom.LinkOne.Dom..::.BookCategory

See Also

BookCategory Members
Mincom.LinkOne.Dom Namespace


BookCategory Members

[image] [image]

LinkOne WebView API
BookCategory Members
BookCategory Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The BookCategory type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
BookCategories | Gets the collection of categories under this catalog. (Inherited from Catalog.)
Books | Gets the collection of books under the catalog. (Inherited from Catalog.)
CategoryCode | Gets the category code.
CategoryDescription | Gets the category description.
CategoryDescriptionTranslations | Gets the category description translations.

Explicit Interface Implementations

Name | Description
ICatalog..::.Books | (Inherited from Catalog.)
ICatalog..::.Categories | (Inherited from Catalog.)
IBookCategory..::.CategoryDescriptionTranslations |

See Also

BookCategory Class
Mincom.LinkOne.Dom Namespace


BookCategory Methods

[image] [image]

LinkOne WebView API
BookCategory Methods
BookCategory Class See Also Send Feedback

The BookCategory type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BookCategory Class
Mincom.LinkOne.Dom Namespace


BookCategory Properties

[image] [image]

LinkOne WebView API
BookCategory Properties
BookCategory Class See Also Send Feedback

The BookCategory type exposes the following members.

Properties

Name | Description
BookCategories | Gets the collection of categories under this catalog. (Inherited from Catalog.)
Books | Gets the collection of books under the catalog. (Inherited from Catalog.)
CategoryCode | Gets the category code.
CategoryDescription | Gets the category description.
CategoryDescriptionTranslations | Gets the category description translations.

Explicit Interface Implementations

Name | Description
ICatalog..::.Books | (Inherited from Catalog.)
ICatalog..::.Categories | (Inherited from Catalog.)
IBookCategory..::.CategoryDescriptionTranslations |

See Also

BookCategory Class
Mincom.LinkOne.Dom Namespace


CategoryCode Property

[image]

LinkOne WebView API
BookCategory..::.CategoryCode Property
BookCategory Class See Also Send Feedback
Gets the category code.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string CategoryCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property CategoryCode As String
Visual C++
public:
virtual property String^ CategoryCode {
    String^ get () sealed;
}

Implements

IBookCategory..::.CategoryCode

See Also

BookCategory Class
Mincom.LinkOne.Dom Namespace


CategoryDescription Property

[image]

LinkOne WebView API
BookCategory..::.CategoryDescription Property
BookCategory Class See Also Send Feedback
Gets the category description.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string CategoryDescription { get; }
Visual Basic (Declaration)
Public ReadOnly Property CategoryDescription As String
Visual C++
public:
virtual property String^ CategoryDescription {
    String^ get () sealed;
}

Implements

IBookCategory..::.CategoryDescription

See Also

BookCategory Class
Mincom.LinkOne.Dom Namespace


CategoryDescriptionTranslations Property

[image]

LinkOne WebView API
BookCategory..::.CategoryDescriptionTranslations Property
BookCategory Class See Also Send Feedback
Gets the category description translations.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ReadOnlyTranslationCollection CategoryDescriptionTranslations { get; }
Visual Basic (Declaration)
Public ReadOnly Property CategoryDescriptionTranslations As ReadOnlyTranslationCollection
Visual C++
public:
property ReadOnlyTranslationCollection^ CategoryDescriptionTranslations {
    ReadOnlyTranslationCollection^ get ();
}

See Also

BookCategory Class
Mincom.LinkOne.Dom Namespace


IBookCategory.CategoryDescriptionTranslations Property

[image]

LinkOne WebView API
BookCategory..::.IBookCategory..::.CategoryDescriptionTranslations Property
BookCategory Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ITranslationCollection IBookCategory.CategoryDescriptionTranslations { get; }
Visual Basic (Declaration)
Private ReadOnly Property CategoryDescriptionTranslations As ITranslationCollection
    Implements IBookCategory.CategoryDescriptionTranslations
Visual C++
private:
virtual property ITranslationCollection^ CategoryDescriptionTranslations {
    ITranslationCollection^ get () sealed = IBookCategory::CategoryDescriptionTranslations::get;
}

Implements

IBookCategory..::.CategoryDescriptionTranslations

See Also

BookCategory Class
Mincom.LinkOne.Dom Namespace


BookCategoryCollection Class

[image]

LinkOne WebView API
BookCategoryCollection Class
Members See Also Send Feedback
Represents a collection of BookCategory objects keyed on, and sorted by CategoryCode.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class BookCategoryCollection : IReadOnlyKeyedCollection<string, BookCategory>,
    IReadOnlyCollection<BookCategory>, IEnumerable<BookCategory>, IBookCategoryCollection,
    IReadOnlyKeyedCollection<string, IBookCategory>, IReadOnlyCollection<IBookCategory>, IEnumerable<IBookCategory>,
    IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class BookCategoryCollection _
    Implements IReadOnlyKeyedCollection(Of String, BookCategory),  _
    IReadOnlyCollection(Of BookCategory), IEnumerable(Of BookCategory), IBookCategoryCollection,  _
    IReadOnlyKeyedCollection(Of String, IBookCategory), IReadOnlyCollection(Of IBookCategory),  _
    IEnumerable(Of IBookCategory), IEnumerable
Visual C++
[SerializableAttribute]
public ref class BookCategoryCollection sealed : IReadOnlyKeyedCollection<String^, BookCategory^>,
    IReadOnlyCollection<BookCategory^>, IEnumerable<BookCategory^>, IBookCategoryCollection,
    IReadOnlyKeyedCollection<String^, IBookCategory^>, IReadOnlyCollection<IBookCategory^>,
    IEnumerable<IBookCategory^>, IEnumerable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.BookCategoryCollection

See Also

BookCategoryCollection Members
Mincom.LinkOne.Dom Namespace


BookCategoryCollection Members

[image] [image]

LinkOne WebView API
BookCategoryCollection Members
BookCategoryCollection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The BookCategoryCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSortedForLanguage | Returns the collection sorted by the translations for the given language.
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements in the collection.
Item | Returns the category for the given category code, if found, otherwise, null.

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(IBookCategory>)>)..::.Contains |
IEnumerable<(Of <(IBookCategory>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.
IReadOnlyKeyedCollection<(Of <(String, IBookCategory>)>)..::.Item |

See Also

BookCategoryCollection Class
Mincom.LinkOne.Dom Namespace


BookCategoryCollection Methods

[image] [image]

LinkOne WebView API
BookCategoryCollection Methods
BookCategoryCollection Class See Also Send Feedback

The BookCategoryCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSortedForLanguage | Returns the collection sorted by the translations for the given language.
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(IBookCategory>)>)..::.Contains |
IEnumerable<(Of <(IBookCategory>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.

See Also

BookCategoryCollection Class
Mincom.LinkOne.Dom Namespace


IEnumerable(IBookCategory).GetEnumerator Method

[image]

LinkOne WebView API
BookCategoryCollection..::.IEnumerable<(Of <(IBookCategory>)>)..::.GetEnumerator Method
BookCategoryCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator<IBookCategory> IEnumerable<IBookCategory>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of IBookCategory)
    Implements IEnumerable(Of IBookCategory).GetEnumerator
Visual C++
private:
virtual IEnumerator<IBookCategory^>^ GetEnumerator() sealed = IEnumerable<IBookCategory^>::GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

BookCategoryCollection Class
Mincom.LinkOne.Dom Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
BookCategoryCollection..::.IEnumerable..::.GetEnumerator Method
BookCategoryCollection Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

BookCategoryCollection Class
Mincom.LinkOne.Dom Namespace


Contains Method

[image] [image]

LinkOne WebView API
BookCategoryCollection..::.Contains Method
BookCategoryCollection Class See Also Send Feedback

Overload List

Name | Description
Contains(BookCategory) | Searches the collection and returns the zero-based index of the first occurence of the given category object.
Contains(String) | Gets whether this collection contains a BookCategory with the given category code.

See Also

BookCategoryCollection Class
BookCategoryCollection Members
Mincom.LinkOne.Dom Namespace


Contains Method (BookCategory)

[image]

LinkOne WebView API
BookCategoryCollection..::.Contains Method (BookCategory)
BookCategoryCollection Class See Also Send Feedback
Searches the collection and returns the zero-based index of the first occurence of the given category object.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    BookCategory item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As BookCategory _
) As Boolean
Visual C++
public:
virtual bool Contains(
    BookCategory^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Dom..::.BookCategory
The category object to search for.

Return Value

The zero-based index of the category object in the collection, if found; otherwise, -1.

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Contains(T)

See Also

BookCategoryCollection Class
Contains Overload
Mincom.LinkOne.Dom Namespace


Contains Method (String)

[image]

LinkOne WebView API
BookCategoryCollection..::.Contains Method (String)
BookCategoryCollection Class See Also Send Feedback
Gets whether this collection contains a BookCategory with the given category code.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    string key
)
Visual Basic (Declaration)
Public Function Contains ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ key
) sealed

Parameters

key
Type: System..::.String
The code of the category.

Return Value

true if the collection contains a BookCategory with the given category code; otherwise, false.

Implements

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Contains(TKey)
IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Contains(TKey)

See Also

BookCategoryCollection Class
Contains Overload
Mincom.LinkOne.Dom Namespace


GetEnumerator Method

[image]

LinkOne WebView API
BookCategoryCollection..::.GetEnumerator Method
BookCategoryCollection Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IEnumerator<BookCategory> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of BookCategory)
Visual C++
public:
virtual IEnumerator<BookCategory^>^ GetEnumerator() sealed

Return Value

A IEnumerator<(Of <(T>)>) that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

BookCategoryCollection Class
Mincom.LinkOne.Dom Namespace


GetSortedForLanguage Method

[image]

LinkOne WebView API
BookCategoryCollection..::.GetSortedForLanguage Method
BookCategoryCollection Class See Also Send Feedback
Returns the collection sorted by the translations for the given language.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IEnumerable<BookCategory> GetSortedForLanguage(
    string languageCode
)
Visual Basic (Declaration)
Public Function GetSortedForLanguage ( _
    languageCode As String _
) As IEnumerable(Of BookCategory)
Visual C++
public:
IEnumerable<BookCategory^>^ GetSortedForLanguage(
    String^ languageCode
)

Parameters

languageCode
Type: System..::.String
The language code to sort by.

Return Value

The collection sorted by the translations for the given language.

See Also

BookCategoryCollection Class
Mincom.LinkOne.Dom Namespace


IReadOnlyCollection(IBookCategory).Contains Method

[image]

LinkOne WebView API
BookCategoryCollection..::.IReadOnlyCollection<(Of <(IBookCategory>)>)..::.Contains Method
BookCategoryCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IReadOnlyCollection<IBookCategory>.Contains(
    IBookCategory domObject
)
Visual Basic (Declaration)
Private Function Contains ( _
    domObject As IBookCategory _
) As Boolean Implements IReadOnlyCollection(Of IBookCategory).Contains
Visual C++
private:
virtual bool Contains(
    IBookCategory^ domObject
) sealed = IReadOnlyCollection<IBookCategory^>::Contains

Parameters

domObject
Type: Mincom.LinkOne.Dom..::.IBookCategory

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Contains(T)

See Also

BookCategoryCollection Class
Mincom.LinkOne.Dom Namespace


BookCategoryCollection Properties

[image] [image]

LinkOne WebView API
BookCategoryCollection Properties
BookCategoryCollection Class See Also Send Feedback

The BookCategoryCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection.
Item | Returns the category for the given category code, if found, otherwise, null.

Explicit Interface Implementations

Name | Description
IReadOnlyKeyedCollection<(Of <(String, IBookCategory>)>)..::.Item |

See Also

BookCategoryCollection Class
Mincom.LinkOne.Dom Namespace


Count Property

[image]

LinkOne WebView API
BookCategoryCollection..::.Count Property
BookCategoryCollection Class See Also Send Feedback
Gets the number of elements in the collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Count
IReadOnlyCollection<(Of <(T>)>)..::.Count

See Also

BookCategoryCollection Class
Mincom.LinkOne.Dom Namespace


IReadOnlyKeyedCollection(String, IBookCategory).Item Property

[image]

LinkOne WebView API
BookCategoryCollection..::.IReadOnlyKeyedCollection<(Of <(String, IBookCategory>)>)..::.Item Property
BookCategoryCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IBookCategory IReadOnlyKeyedCollection<string, IBookCategory>.Item[
    string domObjectKey
] { get; }
Visual Basic (Declaration)
Private ReadOnly Property Item ( _
    domObjectKey As String _
) As IBookCategory Implements IReadOnlyKeyedCollection(Of String, IBookCategory).Item
Visual C++
private:
virtual property IBookCategory^ Item[String^ domObjectKey] {
    IBookCategory^ get (String^ domObjectKey) sealed = IReadOnlyKeyedCollection<String^, IBookCategory^>::Item::get;
}

Parameters

domObjectKey
Type: System..::.String

Implements

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Item[([(TKey])])

See Also

BookCategoryCollection Class
Mincom.LinkOne.Dom Namespace


Item Property

[image]

LinkOne WebView API
BookCategoryCollection..::.Item Property
BookCategoryCollection Class See Also Send Feedback
Returns the category for the given category code, if found, otherwise, null.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookCategory this[
    string key
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    key As String _
) As BookCategory
Visual C++
public:
virtual property BookCategory^ default[String^ key] {
    BookCategory^ get (String^ key) sealed;
}

Parameters

key
Type: System..::.String
The category code for the category.

Implements

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Item[([(TKey])])

See Also

BookCategoryCollection Class
Mincom.LinkOne.Dom Namespace


BookCollection Class

[image]

LinkOne WebView API
BookCollection Class
Members See Also Send Feedback
Represents a collection of Book objects keyed on, and sorted by book code.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class BookCollection : IReadOnlyKeyedCollection<string, Book>,
    IReadOnlyCollection<Book>, IEnumerable<Book>, IBookCollection,
    IReadOnlyKeyedCollection<string, IBook>, IReadOnlyCollection<IBook>, IEnumerable<IBook>,
    IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class BookCollection _
    Implements IReadOnlyKeyedCollection(Of String, Book),  _
    IReadOnlyCollection(Of Book), IEnumerable(Of Book), IBookCollection,  _
    IReadOnlyKeyedCollection(Of String, IBook), IReadOnlyCollection(Of IBook),  _
    IEnumerable(Of IBook), IEnumerable
Visual C++
[SerializableAttribute]
public ref class BookCollection sealed : IReadOnlyKeyedCollection<String^, Book^>,
    IReadOnlyCollection<Book^>, IEnumerable<Book^>, IBookCollection,
    IReadOnlyKeyedCollection<String^, IBook^>, IReadOnlyCollection<IBook^>,
    IEnumerable<IBook^>, IEnumerable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.BookCollection

See Also

BookCollection Members
Mincom.LinkOne.Dom Namespace


BookCollection Members

[image] [image]

LinkOne WebView API
BookCollection Members
BookCollection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The BookCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSortedForLanguage | Returns the collection sorted by the translations for the given language.
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements in the collection.
Item | Gets the Book with the given book code.

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(IBook>)>)..::.Contains |
IEnumerable<(Of <(IBook>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.
IReadOnlyKeyedCollection<(Of <(String, IBook>)>)..::.Item |

See Also

BookCollection Class
Mincom.LinkOne.Dom Namespace


BookCollection Methods

[image] [image]

LinkOne WebView API
BookCollection Methods
BookCollection Class See Also Send Feedback

The BookCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSortedForLanguage | Returns the collection sorted by the translations for the given language.
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(IBook>)>)..::.Contains |
IEnumerable<(Of <(IBook>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.

See Also

BookCollection Class
Mincom.LinkOne.Dom Namespace


IEnumerable(IBook).GetEnumerator Method

[image]

LinkOne WebView API
BookCollection..::.IEnumerable<(Of <(IBook>)>)..::.GetEnumerator Method
BookCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator<IBook> IEnumerable<IBook>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of IBook)
    Implements IEnumerable(Of IBook).GetEnumerator
Visual C++
private:
virtual IEnumerator<IBook^>^ GetEnumerator() sealed = IEnumerable<IBook^>::GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

BookCollection Class
Mincom.LinkOne.Dom Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
BookCollection..::.IEnumerable..::.GetEnumerator Method
BookCollection Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

BookCollection Class
Mincom.LinkOne.Dom Namespace


Contains Method

[image] [image]

LinkOne WebView API
BookCollection..::.Contains Method
BookCollection Class See Also Send Feedback

Overload List

Name | Description
Contains(Book) | Determines whether the given Book is in the BookCollection.
Contains(String) | Determines whether there is an Book in the BookCollection with the given book code.

See Also

BookCollection Class
BookCollection Members
Mincom.LinkOne.Dom Namespace


Contains Method (Book)

[image]

LinkOne WebView API
BookCollection..::.Contains Method (Book)
BookCollection Class See Also Send Feedback
Determines whether the given Book is in the BookCollection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    Book item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As Book _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Book^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Dom..::.Book
The book to search for.

Return Value

true if found in the collection, otherwise, false.

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Contains(T)

See Also

BookCollection Class
Contains Overload
Mincom.LinkOne.Dom Namespace


Contains Method (String)

[image]

LinkOne WebView API
BookCollection..::.Contains Method (String)
BookCollection Class See Also Send Feedback
Determines whether there is an Book in the BookCollection with the given book code.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    string key
)
Visual Basic (Declaration)
Public Function Contains ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ key
) sealed

Parameters

key
Type: System..::.String
The code of the book to search for.

Return Value

true if there is a Book with the given book code, otherwise, false.

Implements

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Contains(TKey)
IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Contains(TKey)

See Also

BookCollection Class
Contains Overload
Mincom.LinkOne.Dom Namespace


GetEnumerator Method

[image]

LinkOne WebView API
BookCollection..::.GetEnumerator Method
BookCollection Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IEnumerator<Book> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of Book)
Visual C++
public:
virtual IEnumerator<Book^>^ GetEnumerator() sealed

Return Value

A IEnumerator<(Of <(T>)>) that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

BookCollection Class
Mincom.LinkOne.Dom Namespace


GetSortedForLanguage Method

[image]

LinkOne WebView API
BookCollection..::.GetSortedForLanguage Method
BookCollection Class See Also Send Feedback
Returns the collection sorted by the translations for the given language.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IEnumerable<Book> GetSortedForLanguage(
    string languageCode,
    bool includeHidden
)
Visual Basic (Declaration)
Public Function GetSortedForLanguage ( _
    languageCode As String, _
    includeHidden As Boolean _
) As IEnumerable(Of Book)
Visual C++
public:
IEnumerable<Book^>^ GetSortedForLanguage(
    String^ languageCode,
    bool includeHidden
)

Parameters

languageCode
Type: System..::.String
The language code to sort by.
includeHidden
Type: System..::.Boolean
Use true to include hidden publishers.

Return Value

The collection sorted by the translations for the given language.

See Also

BookCollection Class
Mincom.LinkOne.Dom Namespace


IReadOnlyCollection(IBook).Contains Method

[image]

LinkOne WebView API
BookCollection..::.IReadOnlyCollection<(Of <(IBook>)>)..::.Contains Method
BookCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IReadOnlyCollection<IBook>.Contains(
    IBook domObject
)
Visual Basic (Declaration)
Private Function Contains ( _
    domObject As IBook _
) As Boolean Implements IReadOnlyCollection(Of IBook).Contains
Visual C++
private:
virtual bool Contains(
    IBook^ domObject
) sealed = IReadOnlyCollection<IBook^>::Contains

Parameters

domObject
Type: Mincom.LinkOne.Dom..::.IBook

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Contains(T)

See Also

BookCollection Class
Mincom.LinkOne.Dom Namespace


BookCollection Properties

[image] [image]

LinkOne WebView API
BookCollection Properties
BookCollection Class See Also Send Feedback

The BookCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection.
Item | Gets the Book with the given book code.

Explicit Interface Implementations

Name | Description
IReadOnlyKeyedCollection<(Of <(String, IBook>)>)..::.Item |

See Also

BookCollection Class
Mincom.LinkOne.Dom Namespace


Count Property

[image]

LinkOne WebView API
BookCollection..::.Count Property
BookCollection Class See Also Send Feedback
Gets the number of elements in the collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Count
IReadOnlyCollection<(Of <(T>)>)..::.Count

See Also

BookCollection Class
Mincom.LinkOne.Dom Namespace


IReadOnlyKeyedCollection(String, IBook).Item Property

[image]

LinkOne WebView API
BookCollection..::.IReadOnlyKeyedCollection<(Of <(String, IBook>)>)..::.Item Property
BookCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IBook IReadOnlyKeyedCollection<string, IBook>.Item[
    string domObjectKey
] { get; }
Visual Basic (Declaration)
Private ReadOnly Property Item ( _
    domObjectKey As String _
) As IBook Implements IReadOnlyKeyedCollection(Of String, IBook).Item
Visual C++
private:
virtual property IBook^ Item[String^ domObjectKey] {
    IBook^ get (String^ domObjectKey) sealed = IReadOnlyKeyedCollection<String^, IBook^>::Item::get;
}

Parameters

domObjectKey
Type: System..::.String

Implements

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Item[([(TKey])])

See Also

BookCollection Class
Mincom.LinkOne.Dom Namespace


Item Property

[image]

LinkOne WebView API
BookCollection..::.Item Property
BookCollection Class See Also Send Feedback
Gets the Book with the given book code.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Book this[
    string key
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    key As String _
) As Book
Visual C++
public:
virtual property Book^ default[String^ key] {
    Book^ get (String^ key) sealed;
}

Parameters

key
Type: System..::.String
The code of the book to retrieve.

Return Value

The Book with the given book code, if found; otherwise, null.

Implements

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Item[([(TKey])])

See Also

BookCollection Class
Mincom.LinkOne.Dom Namespace


BookType Enumeration

[image]

LinkOne WebView API
BookType Enumeration
See Also Send Feedback
Describes the origin of the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum BookType
Visual Basic (Declaration)
Public Enumeration BookType
Visual C++
public enum class BookType

Members

Member name | Description
Standard | The book is a standard book.
Derived | The book is derived from another book. It includes a list of pages from the another book to reference.
Alias | The book is an alias to another book.

See Also

Mincom.LinkOne.Dom Namespace


Catalog Class

[image]

LinkOne WebView API
Catalog Class
Members See Also Send Feedback
Represents the hierarchy of books within a publisher.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public class Catalog : ICatalog
Visual Basic (Declaration)
Public Class Catalog _
    Implements ICatalog
Visual C++
public ref class Catalog : ICatalog

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.Catalog
Mincom.LinkOne.Dom..::.BookCategory

See Also

Catalog Members
Mincom.LinkOne.Dom Namespace


Catalog Members

[image] [image]

LinkOne WebView API
Catalog Members
Catalog Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The Catalog type exposes the following members.

Constructors

Name | Description
Catalog | Initializes a new instance of the Catalog class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
BookCategories | Gets the collection of categories under this catalog.
Books | Gets the collection of books under the catalog.

Explicit Interface Implementations

Name | Description
ICatalog..::.Books |
ICatalog..::.Categories |

See Also

Catalog Class
Mincom.LinkOne.Dom Namespace


Catalog Constructor

[image]

LinkOne WebView API
Catalog Constructor
Catalog Class See Also Send Feedback
Initializes a new instance of the Catalog class.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected internal Catalog()
Visual Basic (Declaration)
Protected Friend Sub New
Visual C++
protected public:
Catalog()

See Also

Catalog Class
Mincom.LinkOne.Dom Namespace


Catalog Methods

[image] [image]

LinkOne WebView API
Catalog Methods
Catalog Class See Also Send Feedback

The Catalog type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Catalog Class
Mincom.LinkOne.Dom Namespace


Catalog Properties

[image] [image]

LinkOne WebView API
Catalog Properties
Catalog Class See Also Send Feedback

The Catalog type exposes the following members.

Properties

Name | Description
BookCategories | Gets the collection of categories under this catalog.
Books | Gets the collection of books under the catalog.

Explicit Interface Implementations

Name | Description
ICatalog..::.Books |
ICatalog..::.Categories |

See Also

Catalog Class
Mincom.LinkOne.Dom Namespace


BookCategories Property

[image]

LinkOne WebView API
Catalog..::.BookCategories Property
Catalog Class See Also Send Feedback
Gets the collection of categories under this catalog.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public virtual BookCategoryCollection BookCategories { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property BookCategories As BookCategoryCollection
Visual C++
public:
virtual property BookCategoryCollection^ BookCategories {
    BookCategoryCollection^ get ();
}

See Also

Catalog Class
Mincom.LinkOne.Dom Namespace


Books Property

[image]

LinkOne WebView API
Catalog..::.Books Property
Catalog Class See Also Send Feedback
Gets the collection of books under the catalog.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public virtual BookCollection Books { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Books As BookCollection
Visual C++
public:
virtual property BookCollection^ Books {
    BookCollection^ get ();
}

See Also

Catalog Class
Mincom.LinkOne.Dom Namespace


ICatalog.Books Property

[image]

LinkOne WebView API
Catalog..::.ICatalog..::.Books Property
Catalog Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IBookCollection ICatalog.Books { get; }
Visual Basic (Declaration)
Private ReadOnly Property Books As IBookCollection
    Implements ICatalog.Books
Visual C++
private:
virtual property IBookCollection^ Books {
    IBookCollection^ get () sealed = ICatalog::Books::get;
}

Implements

ICatalog..::.Books

See Also

Catalog Class
Mincom.LinkOne.Dom Namespace


ICatalog.Categories Property

[image]

LinkOne WebView API
Catalog..::.ICatalog..::.Categories Property
Catalog Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IBookCategoryCollection ICatalog.Categories { get; }
Visual Basic (Declaration)
Private ReadOnly Property Categories As IBookCategoryCollection
    Implements ICatalog.Categories
Visual C++
private:
virtual property IBookCategoryCollection^ Categories {
    IBookCategoryCollection^ get () sealed = ICatalog::Categories::get;
}

Implements

ICatalog..::.Categories

See Also

Catalog Class
Mincom.LinkOne.Dom Namespace


Entry Class

[image]

LinkOne WebView API
Entry Class
Members See Also Send Feedback
An entry record in a LinkOne parts list.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class Entry : IEntry,
    IFilterable, IDisposable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class Entry _
    Implements IEntry, IFilterable, IDisposable
Visual C++
[SerializableAttribute]
public ref class Entry sealed : IEntry,
    IFilterable, IDisposable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.Entry

See Also

Entry Members
Mincom.LinkOne.Dom Namespace


Entry Members

[image] [image]

LinkOne WebView API
Entry Members
Entry Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The Entry type exposes the following members.

Constructors

Name | Description
Entry | Initialises a new instance of the Entry class from a Reader object.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetField | Returns the value of the wanted field.
GetFieldAsVisible | Returns the visible value of the wanted field.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ResolveLinkPageReference | Resolves the LinkPageReference for this entry, allowing for the possibility that pages have been filtered and for the LEAVE_DANGLING_REFERENCES attribute.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
InvalidTagNumber | Invalid tag number.
MaximumTagNumber | The largest allowed tag number.

Properties

Name | Description
AlternateCode | Gets the alternate code for this entry.
Description | Gets the description for this entry.
DisplayQuantity | Gets the Quantity for this entry formatted using the special quantity attributes associated with the current book.
Fields | Gets the collection of fields for this entry.
Format | Gets the Layout Format for this entry.
IsComment | Gets true if the entry is a comment.
IsLink | Gets true if the entry has a cross reference link.
IsSelected |
IsValidLink | Gets true if the entry has a valid cross reference link.
ItemId | Gets the item id for this entry.
LevelIndent | Gets the assembly indent level.
LinkBookCode | Gets the link book code for this entry.
LinkItemId | Gets the link item id for this entry.
LinkObjectIdentifier | Gets the Linked object identifier that may be associated with this entry if a configuration manager is installed.
LinkPageReference | Gets or sets the link page reference for this entry.
LinkPublisherCode | Gets the link publisher code for this entry.
Options | Gets the collection of options for this entry.
Page | Gets the page that contains this entry.
ParentTagNumber | Gets the parent tag number, if parented, otherwise, -1.
PartNumber | Gets the part number for this entry.
Quantity | Gets the quantity for this entry.
TagNumber | Gets the unique tag number for this entry.
Units | Gets the units for this entry.
Values | Gets the collection of values visible for this entry.
Weight | Gets the weight for this entry.

Explicit Interface Implementations

Name | Description
IEntry..::.Fields |
IEntry..::.GetField |
IFilterable..::.Options |
IEntry..::.Page |
IEntry..::.Values |

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


Entry Constructor

[image]

LinkOne WebView API
Entry Constructor
Entry Class See Also Send Feedback
Initialises a new instance of the Entry class from a Reader object.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Entry(
    IDomReader domReader
)
Visual Basic (Declaration)
Public Sub New ( _
    domReader As IDomReader _
)
Visual C++
public:
Entry(
    IDomReader^ domReader
)

Parameters

domReader
Type: IDomReader
The Reader providing the data to populate this object.

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


Entry Fields

[image] [image]

LinkOne WebView API
Entry Fields
Entry Class See Also Send Feedback

The Entry type exposes the following members.

Fields

Name | Description
InvalidTagNumber | Invalid tag number.
MaximumTagNumber | The largest allowed tag number.

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


InvalidTagNumber Field

[image]

LinkOne WebView API
Entry..::.InvalidTagNumber Field
Entry Class See Also Send Feedback
Invalid tag number.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const int InvalidTagNumber
Visual Basic (Declaration)
Public Const InvalidTagNumber As Integer
Visual C++
public:
literal int InvalidTagNumber

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


MaximumTagNumber Field

[image]

LinkOne WebView API
Entry..::.MaximumTagNumber Field
Entry Class See Also Send Feedback
The largest allowed tag number.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const int MaximumTagNumber
Visual Basic (Declaration)
Public Const MaximumTagNumber As Integer
Visual C++
public:
literal int MaximumTagNumber

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


Entry Methods

[image] [image]

LinkOne WebView API
Entry Methods
Entry Class See Also Send Feedback

The Entry type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetField | Returns the value of the wanted field.
GetFieldAsVisible | Returns the visible value of the wanted field.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ResolveLinkPageReference | Resolves the LinkPageReference for this entry, allowing for the possibility that pages have been filtered and for the LEAVE_DANGLING_REFERENCES attribute.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEntry..::.GetField |

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


Dispose Method

[image]

LinkOne WebView API
Entry..::.Dispose Method
Entry Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


GetField Method

[image]

LinkOne WebView API
Entry..::.GetField Method
Entry Class See Also Send Feedback
Returns the value of the wanted field.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string GetField(
    string name
)
Visual Basic (Declaration)
Public Function GetField ( _
    name As String _
) As String
Visual C++
public:
String^ GetField(
    String^ name
)

Parameters

name
Type: System..::.String
Name of the wanted field.

Return Value

The value of the wanted field, or blank if not found.

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.LicenseLockException | The field is locked and requires a key.

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


GetFieldAsVisible Method

[image]

LinkOne WebView API
Entry..::.GetFieldAsVisible Method
Entry Class See Also Send Feedback
Returns the visible value of the wanted field.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string GetFieldAsVisible(
    string name
)
Visual Basic (Declaration)
Public Function GetFieldAsVisible ( _
    name As String _
) As String
Visual C++
public:
String^ GetFieldAsVisible(
    String^ name
)

Parameters

name
Type: System..::.String
Name of the wanted field.

Return Value

The visible value of the wanted field, or blank if not found.

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


IEntry.GetField Method

[image]

LinkOne WebView API
Entry..::.IEntry..::.GetField Method
Entry Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string IEntry.GetField(
    string name
)
Visual Basic (Declaration)
Private Function GetField ( _
    name As String _
) As String Implements IEntry.GetField
Visual C++
private:
virtual String^ GetField(
    String^ name
) sealed = IEntry::GetField

Parameters

name
Type: System..::.String

Implements

IEntry..::.GetField(String)

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


ResolveLinkPageReference Method

[image]

LinkOne WebView API
Entry..::.ResolveLinkPageReference Method
Entry Class See Also Send Feedback
Resolves the LinkPageReference for this entry, allowing for the possibility that pages have been filtered and for the LEAVE_DANGLING_REFERENCES attribute.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string ResolveLinkPageReference(
    Page page
)
Visual Basic (Declaration)
Public Function ResolveLinkPageReference ( _
    page As Page _
) As String
Visual C++
public:
String^ ResolveLinkPageReference(
    Page^ page
)

Parameters

page
Type: Mincom.LinkOne.Dom..::.Page
The page to resolve for.

Return Value

The resolved page reference.

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


Entry Properties

[image] [image]

LinkOne WebView API
Entry Properties
Entry Class See Also Send Feedback

The Entry type exposes the following members.

Properties

Name | Description
AlternateCode | Gets the alternate code for this entry.
Description | Gets the description for this entry.
DisplayQuantity | Gets the Quantity for this entry formatted using the special quantity attributes associated with the current book.
Fields | Gets the collection of fields for this entry.
Format | Gets the Layout Format for this entry.
IsComment | Gets true if the entry is a comment.
IsLink | Gets true if the entry has a cross reference link.
IsSelected |
IsValidLink | Gets true if the entry has a valid cross reference link.
ItemId | Gets the item id for this entry.
LevelIndent | Gets the assembly indent level.
LinkBookCode | Gets the link book code for this entry.
LinkItemId | Gets the link item id for this entry.
LinkObjectIdentifier | Gets the Linked object identifier that may be associated with this entry if a configuration manager is installed.
LinkPageReference | Gets or sets the link page reference for this entry.
LinkPublisherCode | Gets the link publisher code for this entry.
Options | Gets the collection of options for this entry.
Page | Gets the page that contains this entry.
ParentTagNumber | Gets the parent tag number, if parented, otherwise, -1.
PartNumber | Gets the part number for this entry.
Quantity | Gets the quantity for this entry.
TagNumber | Gets the unique tag number for this entry.
Units | Gets the units for this entry.
Values | Gets the collection of values visible for this entry.
Weight | Gets the weight for this entry.

Explicit Interface Implementations

Name | Description
IEntry..::.Fields |
IFilterable..::.Options |
IEntry..::.Page |
IEntry..::.Values |

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


AlternateCode Property

[image]

LinkOne WebView API
Entry..::.AlternateCode Property
Entry Class See Also Send Feedback
Gets the alternate code for this entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string AlternateCode { get; internal set; }
Visual Basic (Declaration)
Public Property AlternateCode As String
Visual C++
public:
virtual property String^ AlternateCode {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IEntry..::.AlternateCode

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


Description Property

[image]

LinkOne WebView API
Entry..::.Description Property
Entry Class See Also Send Feedback
Gets the description for this entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
virtual property String^ Description {
    String^ get () sealed;
}

Implements

IEntry..::.Description

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


DisplayQuantity Property

[image]

LinkOne WebView API
Entry..::.DisplayQuantity Property
Entry Class See Also Send Feedback
Gets the Quantity for this entry formatted using the special quantity attributes associated with the current book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string DisplayQuantity { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayQuantity As String
Visual C++
public:
property String^ DisplayQuantity {
    String^ get ();
}

Return Value

The quantity for this entry formatted according to the special quantity attributes of the book.

Remarks

Special quantity attributes that may be associated with a book include:
  • SPECIAL_QUANTITY_STRING_x Specifies the text to be displayed when the quantity contains one of the special quantity codes 'A'-'Z' or 'a'-'z'
  • UNKNOWN_QUANTITY_STRING Specifies the text to be displayed when the quantity contains the '?' character.
  • EMPTY_QUANTITY_STRING Specifies the text to be displayed when the quantity is an empty string.
An NullException is thrown if the entry is not associated with a book.

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


Fields Property

[image]

LinkOne WebView API
Entry..::.Fields Property
Entry Class See Also Send Feedback
Gets the collection of fields for this entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public FieldCollection Fields { get; }
Visual Basic (Declaration)
Public ReadOnly Property Fields As FieldCollection
Visual C++
public:
property FieldCollection^ Fields {
    FieldCollection^ get ();
}

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


Format Property

[image]

LinkOne WebView API
Entry..::.Format Property
Entry Class See Also Send Feedback
Gets the Layout Format for this entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Format { get; }
Visual Basic (Declaration)
Public ReadOnly Property Format As String
Visual C++
public:
property String^ Format {
    String^ get ();
}

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


IEntry.Fields Property

[image]

LinkOne WebView API
Entry..::.IEntry..::.Fields Property
Entry Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IFieldCollection IEntry.Fields { get; }
Visual Basic (Declaration)
Private ReadOnly Property Fields As IFieldCollection
    Implements IEntry.Fields
Visual C++
private:
virtual property IFieldCollection^ Fields {
    IFieldCollection^ get () sealed = IEntry::Fields::get;
}

Implements

IEntry..::.Fields

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


IEntry.Page Property

[image]

LinkOne WebView API
Entry..::.IEntry..::.Page Property
Entry Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPage IEntry.Page { get; }
Visual Basic (Declaration)
Private ReadOnly Property Page As IPage
    Implements IEntry.Page
Visual C++
private:
virtual property IPage^ Page {
    IPage^ get () sealed = IEntry::Page::get;
}

Implements

IEntry..::.Page

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


IEntry.Values Property

[image]

LinkOne WebView API
Entry..::.IEntry..::.Values Property
Entry Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IValueCollection IEntry.Values { get; }
Visual Basic (Declaration)
Private ReadOnly Property Values As IValueCollection
    Implements IEntry.Values
Visual C++
private:
virtual property IValueCollection^ Values {
    IValueCollection^ get () sealed = IEntry::Values::get;
}

Implements

IEntry..::.Values

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


IFilterable.Options Property

[image]

LinkOne WebView API
Entry..::.IFilterable..::.Options Property
Entry Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IOptionCollection IFilterable.Options { get; }
Visual Basic (Declaration)
Private ReadOnly Property Options As IOptionCollection
    Implements IFilterable.Options
Visual C++
private:
virtual property IOptionCollection^ Options {
    IOptionCollection^ get () sealed = IFilterable::Options::get;
}

Implements

IFilterable..::.Options

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


IsComment Property

[image]

LinkOne WebView API
Entry..::.IsComment Property
Entry Class See Also Send Feedback
Gets true if the entry is a comment.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsComment { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsComment As Boolean
Visual C++
public:
property bool IsComment {
    bool get ();
}

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


IsLink Property

[image]

LinkOne WebView API
Entry..::.IsLink Property
Entry Class See Also Send Feedback
Gets true if the entry has a cross reference link.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsLink { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsLink As Boolean
Visual C++
public:
property bool IsLink {
    bool get ();
}

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


IsSelected Property

[image]

LinkOne WebView API
Entry..::.IsSelected Property
Entry Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic (Declaration)
Public Property IsSelected As Boolean
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


IsValidLink Property

[image]

LinkOne WebView API
Entry..::.IsValidLink Property
Entry Class See Also Send Feedback
Gets true if the entry has a valid cross reference link.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsValidLink { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsValidLink As Boolean
Visual C++
public:
property bool IsValidLink {
    bool get ();
}

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


ItemId Property

[image]

LinkOne WebView API
Entry..::.ItemId Property
Entry Class See Also Send Feedback
Gets the item id for this entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string ItemId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemId As String
Visual C++
public:
virtual property String^ ItemId {
    String^ get () sealed;
}

Implements

IEntry..::.ItemId

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


LevelIndent Property

[image]

LinkOne WebView API
Entry..::.LevelIndent Property
Entry Class See Also Send Feedback
Gets the assembly indent level.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int LevelIndent { get; }
Visual Basic (Declaration)
Public ReadOnly Property LevelIndent As Integer
Visual C++
public:
property int LevelIndent {
    int get ();
}

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


LinkBookCode Property

[image]

LinkOne WebView API
Entry..::.LinkBookCode Property
Entry Class See Also Send Feedback
Gets the link book code for this entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string LinkBookCode { get; internal set; }
Visual Basic (Declaration)
Public Property LinkBookCode As String
Visual C++
public:
virtual property String^ LinkBookCode {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IEntry..::.LinkBookCode

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


LinkItemId Property

[image]

LinkOne WebView API
Entry..::.LinkItemId Property
Entry Class See Also Send Feedback
Gets the link item id for this entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string LinkItemId { get; }
Visual Basic (Declaration)
Public ReadOnly Property LinkItemId As String
Visual C++
public:
virtual property String^ LinkItemId {
    String^ get () sealed;
}

Implements

IEntry..::.LinkItemId

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


LinkObjectIdentifier Property

[image]

LinkOne WebView API
Entry..::.LinkObjectIdentifier Property
Entry Class See Also Send Feedback
Gets the Linked object identifier that may be associated with this entry if a configuration manager is installed.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string LinkObjectIdentifier { get; }
Visual Basic (Declaration)
Public ReadOnly Property LinkObjectIdentifier As String
Visual C++
public:
virtual property String^ LinkObjectIdentifier {
    String^ get () sealed;
}

Implements

IEntry..::.LinkObjectIdentifier

Remarks

If no configuration manager is installed, LinkedObjectIdentifier will be null.

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


LinkPageReference Property

[image]

LinkOne WebView API
Entry..::.LinkPageReference Property
Entry Class See Also Send Feedback
Gets or sets the link page reference for this entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string LinkPageReference { get; internal set; }
Visual Basic (Declaration)
Public Property LinkPageReference As String
Visual C++
public:
virtual property String^ LinkPageReference {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IEntry..::.LinkPageReference

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


LinkPublisherCode Property

[image]

LinkOne WebView API
Entry..::.LinkPublisherCode Property
Entry Class See Also Send Feedback
Gets the link publisher code for this entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string LinkPublisherCode { get; internal set; }
Visual Basic (Declaration)
Public Property LinkPublisherCode As String
Visual C++
public:
virtual property String^ LinkPublisherCode {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IEntry..::.LinkPublisherCode

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


Options Property

[image]

LinkOne WebView API
Entry..::.Options Property
Entry Class See Also Send Feedback
Gets the collection of options for this entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public OptionCollection Options { get; }
Visual Basic (Declaration)
Public ReadOnly Property Options As OptionCollection
Visual C++
public:
property OptionCollection^ Options {
    OptionCollection^ get ();
}

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


Page Property

[image]

LinkOne WebView API
Entry..::.Page Property
Entry Class See Also Send Feedback
Gets the page that contains this entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Page Page { get; internal set; }
Visual Basic (Declaration)
Public Property Page As Page
Visual C++
public:
property Page^ Page {
    Page^ get ();
    void set (Page^ value);
}

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


ParentTagNumber Property

[image]

LinkOne WebView API
Entry..::.ParentTagNumber Property
Entry Class See Also Send Feedback
Gets the parent tag number, if parented, otherwise, -1.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int ParentTagNumber { get; internal set; }
Visual Basic (Declaration)
Public Property ParentTagNumber As Integer
Visual C++
public:
virtual property int ParentTagNumber {
    int get () sealed;
    void set (int value) sealed;
}

Implements

IEntry..::.ParentTagNumber

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


PartNumber Property

[image]

LinkOne WebView API
Entry..::.PartNumber Property
Entry Class See Also Send Feedback
Gets the part number for this entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PartNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property PartNumber As String
Visual C++
public:
virtual property String^ PartNumber {
    String^ get () sealed;
}

Implements

IEntry..::.PartNumber

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


Quantity Property

[image]

LinkOne WebView API
Entry..::.Quantity Property
Entry Class See Also Send Feedback
Gets the quantity for this entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Quantity { get; internal set; }
Visual Basic (Declaration)
Public Property Quantity As String
Visual C++
public:
virtual property String^ Quantity {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IEntry..::.Quantity

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


TagNumber Property

[image]

LinkOne WebView API
Entry..::.TagNumber Property
Entry Class See Also Send Feedback
Gets the unique tag number for this entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int TagNumber { get; internal set; }
Visual Basic (Declaration)
Public Property TagNumber As Integer
Visual C++
public:
virtual property int TagNumber {
    int get () sealed;
    void set (int value) sealed;
}

Implements

IEntry..::.TagNumber

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


Units Property

[image]

LinkOne WebView API
Entry..::.Units Property
Entry Class See Also Send Feedback
Gets the units for this entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Units { get; }
Visual Basic (Declaration)
Public ReadOnly Property Units As String
Visual C++
public:
virtual property String^ Units {
    String^ get () sealed;
}

Implements

IEntry..::.Units

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


Values Property

[image]

LinkOne WebView API
Entry..::.Values Property
Entry Class See Also Send Feedback
Gets the collection of values visible for this entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ValueCollection Values { get; }
Visual Basic (Declaration)
Public ReadOnly Property Values As ValueCollection
Visual C++
public:
property ValueCollection^ Values {
    ValueCollection^ get ();
}

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


Weight Property

[image]

LinkOne WebView API
Entry..::.Weight Property
Entry Class See Also Send Feedback
Gets the weight for this entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Weight { get; }
Visual Basic (Declaration)
Public ReadOnly Property Weight As String
Visual C++
public:
virtual property String^ Weight {
    String^ get () sealed;
}

Implements

IEntry..::.Weight

See Also

Entry Class
Mincom.LinkOne.Dom Namespace


EntryCollection Class

[image]

LinkOne WebView API
EntryCollection Class
Members See Also Send Feedback
Represents a collection of Entry objects.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class EntryCollection : IReadOnlyKeyedCollection<int, Entry>,
    IReadOnlyList<Entry>, IReadOnlyCollection<Entry>, IEnumerable<Entry>,
    IEntryCollection, IReadOnlyKeyedCollection<int, IEntry>, IReadOnlyList<IEntry>,
    IReadOnlyCollection<IEntry>, IEnumerable<IEntry>, IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class EntryCollection _
    Implements IReadOnlyKeyedCollection(Of Integer, Entry), IReadOnlyList(Of Entry),  _
    IReadOnlyCollection(Of Entry), IEnumerable(Of Entry), IEntryCollection,  _
    IReadOnlyKeyedCollection(Of Integer, IEntry), IReadOnlyList(Of IEntry),  _
    IReadOnlyCollection(Of IEntry), IEnumerable(Of IEntry), IEnumerable
Visual C++
[SerializableAttribute]
public ref class EntryCollection sealed : IReadOnlyKeyedCollection<int, Entry^>,
    IReadOnlyList<Entry^>, IReadOnlyCollection<Entry^>, IEnumerable<Entry^>,
    IEntryCollection, IReadOnlyKeyedCollection<int, IEntry^>, IReadOnlyList<IEntry^>,
    IReadOnlyCollection<IEntry^>, IEnumerable<IEntry^>, IEnumerable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.EntryCollection

See Also

EntryCollection Members
Mincom.LinkOne.Dom Namespace


EntryCollection Members

[image] [image]

LinkOne WebView API
EntryCollection Members
EntryCollection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The EntryCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of entry objects in the collection.
Item | Overloaded.

Explicit Interface Implementations

Name | Description
Mincom#LinkOne#Collections#IReadOnlyKeyedCollection{TKey@TItem}#Item |
Mincom#LinkOne#Collections#IReadOnlyList{T}#Item |
IReadOnlyCollection<(Of <(IEntry>)>)..::.Contains |
IEnumerable<(Of <(IEntry>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.
IReadOnlyList<(Of <(IEntry>)>)..::.IndexOf |
IEntryCollection..::.Item |

See Also

EntryCollection Class
Mincom.LinkOne.Dom Namespace


EntryCollection Methods

[image] [image]

LinkOne WebView API
EntryCollection Methods
EntryCollection Class See Also Send Feedback

The EntryCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(IEntry>)>)..::.Contains |
IEnumerable<(Of <(IEntry>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.
IReadOnlyList<(Of <(IEntry>)>)..::.IndexOf |

See Also

EntryCollection Class
Mincom.LinkOne.Dom Namespace


IEnumerable(IEntry).GetEnumerator Method

[image]

LinkOne WebView API
EntryCollection..::.IEnumerable<(Of <(IEntry>)>)..::.GetEnumerator Method
EntryCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator<IEntry> IEnumerable<IEntry>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of IEntry)
    Implements IEnumerable(Of IEntry).GetEnumerator
Visual C++
private:
virtual IEnumerator<IEntry^>^ GetEnumerator() sealed = IEnumerable<IEntry^>::GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

EntryCollection Class
Mincom.LinkOne.Dom Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
EntryCollection..::.IEnumerable..::.GetEnumerator Method
EntryCollection Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

EntryCollection Class
Mincom.LinkOne.Dom Namespace


Contains Method

[image] [image]

LinkOne WebView API
EntryCollection..::.Contains Method
EntryCollection Class See Also Send Feedback

Overload List

Name | Description
Contains(Entry) | Determines whether the entry is in the collection.
Contains(Int32) | Determines whether the EntryCollection contains an entry with the specified tag number.

See Also

EntryCollection Class
EntryCollection Members
Mincom.LinkOne.Dom Namespace


Contains Method (Entry)

[image]

LinkOne WebView API
EntryCollection..::.Contains Method (Entry)
EntryCollection Class See Also Send Feedback
Determines whether the entry is in the collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    Entry item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As Entry _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Entry^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Dom..::.Entry
The entry to search for.

Return Value

true if found in the collection, otherwise, false.

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Contains(T)

See Also

EntryCollection Class
Contains Overload
Mincom.LinkOne.Dom Namespace


Contains Method (Int32)

[image]

LinkOne WebView API
EntryCollection..::.Contains Method (Int32)
EntryCollection Class See Also Send Feedback
Determines whether the EntryCollection contains an entry with the specified tag number.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    int key
)
Visual Basic (Declaration)
Public Function Contains ( _
    key As Integer _
) As Boolean
Visual C++
public:
virtual bool Contains(
    int key
) sealed

Parameters

key
Type: System..::.Int32
The tag number.

Return Value

true if the EntryCollection contains an entry with the specified tag number; otherwise, false.

Implements

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Contains(TKey)
IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Contains(TKey)

See Also

EntryCollection Class
Contains Overload
Mincom.LinkOne.Dom Namespace


GetEnumerator Method

[image]

LinkOne WebView API
EntryCollection..::.GetEnumerator Method
EntryCollection Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IEnumerator<Entry> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of Entry)
Visual C++
public:
virtual IEnumerator<Entry^>^ GetEnumerator() sealed

Return Value

A IEnumerator<(Of <(T>)>) that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

EntryCollection Class
Mincom.LinkOne.Dom Namespace


IndexOf Method

[image] [image]

LinkOne WebView API
EntryCollection..::.IndexOf Method
EntryCollection Class See Also Send Feedback

Overload List

Name | Description
IndexOf(Entry) | Searches the collection and returns the zero-based index of the entry.
IndexOf(Int32) | Searches the collection and returns the zero-based index of the first occurence of an entry with the given tag number.

See Also

EntryCollection Class
EntryCollection Members
Mincom.LinkOne.Dom Namespace


IndexOf Method (Entry)

[image]

LinkOne WebView API
EntryCollection..::.IndexOf Method (Entry)
EntryCollection Class See Also Send Feedback
Searches the collection and returns the zero-based index of the entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int IndexOf(
    Entry item
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    item As Entry _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Entry^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Dom..::.Entry
The entry to search for.

Return Value

The zero-based index of the entry in the collection, if found; otherwise, -1.

Implements

IReadOnlyList<(Of <(T>)>)..::.IndexOf(T)

See Also

EntryCollection Class
IndexOf Overload
Mincom.LinkOne.Dom Namespace


IndexOf Method (Int32)

[image]

LinkOne WebView API
EntryCollection..::.IndexOf Method (Int32)
EntryCollection Class See Also Send Feedback
Searches the collection and returns the zero-based index of the first occurence of an entry with the given tag number.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int IndexOf(
    int tagNumber
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    tagNumber As Integer _
) As Integer
Visual C++
public:
int IndexOf(
    int tagNumber
)

Parameters

tagNumber
Type: System..::.Int32
The tag number of the entry to search for.

Return Value

The zero-based index of the entry in the collection, if found; otherwise, -1.

See Also

EntryCollection Class
IndexOf Overload
Mincom.LinkOne.Dom Namespace


IReadOnlyCollection(IEntry).Contains Method

[image]

LinkOne WebView API
EntryCollection..::.IReadOnlyCollection<(Of <(IEntry>)>)..::.Contains Method
EntryCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IReadOnlyCollection<IEntry>.Contains(
    IEntry domObject
)
Visual Basic (Declaration)
Private Function Contains ( _
    domObject As IEntry _
) As Boolean Implements IReadOnlyCollection(Of IEntry).Contains
Visual C++
private:
virtual bool Contains(
    IEntry^ domObject
) sealed = IReadOnlyCollection<IEntry^>::Contains

Parameters

domObject
Type: Mincom.LinkOne.Dom..::.IEntry

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Contains(T)

See Also

EntryCollection Class
Mincom.LinkOne.Dom Namespace


IReadOnlyList(IEntry).IndexOf Method

[image]

LinkOne WebView API
EntryCollection..::.IReadOnlyList<(Of <(IEntry>)>)..::.IndexOf Method
EntryCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int IReadOnlyList<IEntry>.IndexOf(
    IEntry domObject
)
Visual Basic (Declaration)
Private Function IndexOf ( _
    domObject As IEntry _
) As Integer Implements IReadOnlyList(Of IEntry).IndexOf
Visual C++
private:
virtual int IndexOf(
    IEntry^ domObject
) sealed = IReadOnlyList<IEntry^>::IndexOf

Parameters

domObject
Type: Mincom.LinkOne.Dom..::.IEntry

Implements

IReadOnlyList<(Of <(T>)>)..::.IndexOf(T)

See Also

EntryCollection Class
Mincom.LinkOne.Dom Namespace


EntryCollection Properties

[image] [image]

LinkOne WebView API
EntryCollection Properties
EntryCollection Class See Also Send Feedback

The EntryCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of entry objects in the collection.
Item | Overloaded.

Explicit Interface Implementations

Name | Description
Mincom#LinkOne#Collections#IReadOnlyKeyedCollection{TKey@TItem}#Item |
Mincom#LinkOne#Collections#IReadOnlyList{T}#Item |
IEntryCollection..::.Item |

See Also

EntryCollection Class
Mincom.LinkOne.Dom Namespace


Count Property

[image]

LinkOne WebView API
EntryCollection..::.Count Property
EntryCollection Class See Also Send Feedback
Gets the number of entry objects in the collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Count
IReadOnlyCollection<(Of <(T>)>)..::.Count

See Also

EntryCollection Class
Mincom.LinkOne.Dom Namespace


IEntryCollection.Item Property

[image]

LinkOne WebView API
EntryCollection..::.IEntryCollection..::.Item Property
EntryCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEntry IEntryCollection.Item[
    string itemId
] { get; }
Visual Basic (Declaration)
Private ReadOnly Property Item ( _
    itemId As String _
) As IEntry Implements IEntryCollection.Item
Visual C++
private:
virtual property IEntry^ Item[String^ itemId] {
    IEntry^ get (String^ itemId) sealed = IEntryCollection::Item::get;
}

Parameters

itemId
Type: System..::.String

Implements

IEntryCollection..::.Item[([(String])])

See Also

EntryCollection Class
Mincom.LinkOne.Dom Namespace


Item Property

[image] [image]

LinkOne WebView API
EntryCollection..::.Item Property
EntryCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Gets the Entry with the specified tag number.
Item[([(String])]) | Gets the first Entry in the collection with matching ItemId (case-insensitive). The item id.

See Also

EntryCollection Class
EntryCollection Members
Mincom.LinkOne.Dom Namespace


Item Property (Int32)

[image]

LinkOne WebView API
EntryCollection..::.Item Property (Int32)
EntryCollection Class See Also Send Feedback
Gets the Entry with the specified tag number.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Entry this[
    int tagNumber
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    tagNumber As Integer _
) As Entry
Visual C++
public:
property Entry^ default[int tagNumber] {
    Entry^ get (int tagNumber);
}

Parameters

tagNumber
Type: System..::.Int32
The unique identifier for the entry, see TagNumber.

Return Value

The entry identified by the tag number.

Remarks

Caution: Do not confuse this property with a positional index accessor, this retrieves entries by TagNumber.

Exceptions

Exception | Condition
System.Collections.Generic..::.KeyNotFoundException | No entry with the given tag number exists.

See Also

EntryCollection Class
Item Overload
Mincom.LinkOne.Dom Namespace


Item Property (String)

[image]

LinkOne WebView API
EntryCollection..::.Item Property (String)
EntryCollection Class See Also Send Feedback
Gets the first Entry in the collection with matching ItemId (case-insensitive). The item id.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Entry this[
    string itemId
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    itemId As String _
) As Entry
Visual C++
public:
property Entry^ default[String^ itemId] {
    Entry^ get (String^ itemId);
}

Parameters

itemId
Type: System..::.String

See Also

EntryCollection Class
Item Overload
Mincom.LinkOne.Dom Namespace


ExceptionCollection Class

[image]

LinkOne WebView API
ExceptionCollection Class
Members See Also Send Feedback
Represents a collection of BaseException objects that can be accessed by index.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class ExceptionCollection : ReadOnlyList<BaseException>,
    IExceptionCollection, IReadOnlyList<BaseException>, IReadOnlyCollection<BaseException>,
    IEnumerable<BaseException>, IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class ExceptionCollection _
    Inherits ReadOnlyList(Of BaseException) _
    Implements IExceptionCollection, IReadOnlyList(Of BaseException),  _
    IReadOnlyCollection(Of BaseException), IEnumerable(Of BaseException), IEnumerable
Visual C++
[SerializableAttribute]
public ref class ExceptionCollection sealed : public ReadOnlyList<BaseException^>,
    IExceptionCollection, IReadOnlyList<BaseException^>, IReadOnlyCollection<BaseException^>,
    IEnumerable<BaseException^>, IEnumerable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.ReadOnlyList <(Of <( BaseException >)>)
Mincom.LinkOne.Dom..::.ExceptionCollection

See Also

ExceptionCollection Members
Mincom.LinkOne.Dom Namespace


ExceptionCollection Members

[image] [image]

LinkOne WebView API
ExceptionCollection Members
ExceptionCollection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The ExceptionCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given object. (Inherited from ReadOnlyList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
InnerList | Gets the inner list. (Inherited from ReadOnlyList<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from ReadOnlyList<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(T>)>).)

See Also

ExceptionCollection Class
Mincom.LinkOne.Dom Namespace


ExceptionCollection Methods

[image] [image]

LinkOne WebView API
ExceptionCollection Methods
ExceptionCollection Class See Also Send Feedback

The ExceptionCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given object. (Inherited from ReadOnlyList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(T>)>).)

See Also

ExceptionCollection Class
Mincom.LinkOne.Dom Namespace


ExceptionCollection Properties

[image] [image]

LinkOne WebView API
ExceptionCollection Properties
ExceptionCollection Class See Also Send Feedback

The ExceptionCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
InnerList | Gets the inner list. (Inherited from ReadOnlyList<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from ReadOnlyList<(Of <(T>)>).)

See Also

ExceptionCollection Class
Mincom.LinkOne.Dom Namespace


Field Class

[image]

LinkOne WebView API
Field Class
Members See Also Send Feedback
A generic data field.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class Field : IField
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class Field _
    Implements IField
Visual C++
[SerializableAttribute]
public ref class Field sealed : IField

Remarks

Fields in a LinkOne book are name-value pairs that may be associated with an entry, a parts list or a book.

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.Field

See Also

Field Members
Mincom.LinkOne.Dom Namespace


Field Members

[image] [image]

LinkOne WebView API
Field Members
Field Class Constructors Methods Properties See Also Send Feedback

The Field type exposes the following members.

Constructors

Name | Description
Field | Initialises a new instance of the Field class from a Reader object.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Name | Gets the field name.
Value | Gets or sets the field value.

See Also

Field Class
Mincom.LinkOne.Dom Namespace


Field Constructor

[image]

LinkOne WebView API
Field Constructor
Field Class See Also Send Feedback
Initialises a new instance of the Field class from a Reader object.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Field(
    IDomReader domReader
)
Visual Basic (Declaration)
Public Sub New ( _
    domReader As IDomReader _
)
Visual C++
public:
Field(
    IDomReader^ domReader
)

Parameters

domReader
Type: IDomReader
The Reader providing the data to populate this object.

See Also

Field Class
Mincom.LinkOne.Dom Namespace


Field Methods

[image] [image]

LinkOne WebView API
Field Methods
Field Class See Also Send Feedback

The Field type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Field Class
Mincom.LinkOne.Dom Namespace


Field Properties

[image] [image]

LinkOne WebView API
Field Properties
Field Class See Also Send Feedback

The Field type exposes the following members.

Properties

Name | Description
Name | Gets the field name.
Value | Gets or sets the field value.

See Also

Field Class
Mincom.LinkOne.Dom Namespace


Name Property

[image]

LinkOne WebView API
Field..::.Name Property
Field Class See Also Send Feedback
Gets the field name.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
}

Implements

IField..::.Name

See Also

Field Class
Mincom.LinkOne.Dom Namespace


Value Property

[image]

LinkOne WebView API
Field..::.Value Property
Field Class See Also Send Feedback
Gets or sets the field value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As String
Visual C++
public:
virtual property String^ Value {
    String^ get () sealed;
}

Implements

IField..::.Value

See Also

Field Class
Mincom.LinkOne.Dom Namespace


FieldCollection Class

[image]

LinkOne WebView API
FieldCollection Class
Members See Also Send Feedback
Represents a collection of fields, indexed by Name.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class FieldCollection : IFieldCollection,
    IReadOnlyKeyedCollection<string, IField>, IReadOnlyCollection<IField>, IEnumerable<IField>,
    IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class FieldCollection _
    Implements IFieldCollection, IReadOnlyKeyedCollection(Of String, IField),  _
    IReadOnlyCollection(Of IField), IEnumerable(Of IField), IEnumerable
Visual C++
[SerializableAttribute]
public ref class FieldCollection sealed : IFieldCollection,
    IReadOnlyKeyedCollection<String^, IField^>, IReadOnlyCollection<IField^>,
    IEnumerable<IField^>, IEnumerable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.FieldCollection

See Also

FieldCollection Members
Mincom.LinkOne.Dom Namespace


FieldCollection Members

[image] [image]

LinkOne WebView API
FieldCollection Members
FieldCollection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The FieldCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetFieldText | Gets the value of the field with the specified name from the collecion.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements in the collection.
Item | Gets the field with the given name.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.

See Also

FieldCollection Class
Mincom.LinkOne.Dom Namespace


FieldCollection Methods

[image] [image]

LinkOne WebView API
FieldCollection Methods
FieldCollection Class See Also Send Feedback

The FieldCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetFieldText | Gets the value of the field with the specified name from the collecion.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.

See Also

FieldCollection Class
Mincom.LinkOne.Dom Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
FieldCollection..::.IEnumerable..::.GetEnumerator Method
FieldCollection Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

FieldCollection Class
Mincom.LinkOne.Dom Namespace


Contains Method

[image] [image]

LinkOne WebView API
FieldCollection..::.Contains Method
FieldCollection Class See Also Send Feedback

Overload List

Name | Description
Contains(IField) | Determines whether a field is in the collection.
Contains(String) | Determines whether the collection contains the specified Field.

See Also

FieldCollection Class
FieldCollection Members
Mincom.LinkOne.Dom Namespace


Contains Method (IField)

[image]

LinkOne WebView API
FieldCollection..::.Contains Method (IField)
FieldCollection Class See Also Send Feedback
Determines whether a field is in the collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    IField item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As IField _
) As Boolean
Visual C++
public:
virtual bool Contains(
    IField^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Dom..::.IField
The field object to search for.

Return Value

true if found in the collection, otherwise, false.

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Contains(T)

See Also

FieldCollection Class
Contains Overload
Mincom.LinkOne.Dom Namespace


Contains Method (String)

[image]

LinkOne WebView API
FieldCollection..::.Contains Method (String)
FieldCollection Class See Also Send Feedback
Determines whether the collection contains the specified Field.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    string key
)
Visual Basic (Declaration)
Public Function Contains ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ key
) sealed

Parameters

key
Type: System..::.String
Name of the field.

Return Value

true if the collection contains the specified value; otherwise, false.

Implements

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Contains(TKey)

See Also

FieldCollection Class
Contains Overload
Mincom.LinkOne.Dom Namespace


GetEnumerator Method

[image]

LinkOne WebView API
FieldCollection..::.GetEnumerator Method
FieldCollection Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IEnumerator<IField> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of IField)
Visual C++
public:
virtual IEnumerator<IField^>^ GetEnumerator() sealed

Return Value

A IEnumerator<(Of <(T>)>) that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

FieldCollection Class
Mincom.LinkOne.Dom Namespace


GetFieldText Method

[image]

LinkOne WebView API
FieldCollection..::.GetFieldText Method
FieldCollection Class See Also Send Feedback
Gets the value of the field with the specified name from the collecion.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string GetFieldText(
    string fieldName
)
Visual Basic (Declaration)
Public Function GetFieldText ( _
    fieldName As String _
) As String
Visual C++
public:
String^ GetFieldText(
    String^ fieldName
)

Parameters

fieldName
Type: System..::.String
The field name to get.

Return Value

The field value or an empty string if no field is found.

See Also

FieldCollection Class
Mincom.LinkOne.Dom Namespace


FieldCollection Properties

[image] [image]

LinkOne WebView API
FieldCollection Properties
FieldCollection Class See Also Send Feedback

The FieldCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection.
Item | Gets the field with the given name.

See Also

FieldCollection Class
Mincom.LinkOne.Dom Namespace


Count Property

[image]

LinkOne WebView API
FieldCollection..::.Count Property
FieldCollection Class See Also Send Feedback
Gets the number of elements in the collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Count

See Also

FieldCollection Class
Mincom.LinkOne.Dom Namespace


Item Property

[image]

LinkOne WebView API
FieldCollection..::.Item Property
FieldCollection Class See Also Send Feedback
Gets the field with the given name.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IField this[
    string key
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    key As String _
) As IField
Visual C++
public:
virtual property IField^ default[String^ key] {
    IField^ get (String^ key) sealed;
}

Parameters

key
Type: System..::.String
The name of the Field to get.

Return Value

The field, or null if no field is found.

Implements

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Item[([(TKey])])

See Also

FieldCollection Class
Mincom.LinkOne.Dom Namespace


GetValueEventArgs Class

[image]

LinkOne WebView API
GetValueEventArgs Class
Members See Also Send Feedback
Provides data for the GetValue event.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public sealed class GetValueEventArgs : EventArgs
Visual Basic (Declaration)
Public NotInheritable Class GetValueEventArgs _
    Inherits EventArgs
Visual C++
public ref class GetValueEventArgs sealed : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Mincom.LinkOne.Dom..::.GetValueEventArgs

See Also

GetValueEventArgs Members
Mincom.LinkOne.Dom Namespace


GetValueEventArgs Members

[image] [image]

LinkOne WebView API
GetValueEventArgs Members
GetValueEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetValueEventArgs type exposes the following members.

Constructors

Name | Description
GetValueEventArgs | Constructor.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Book | Gets the book requesting the value.
Entry | Gets the entry requesting the value.
Handled | Gets or sets true if the value has been read.
Name | Gets the name of the value being read.
Page | Gets the page requesting the value.
Value | Gets or sets the value being read.

See Also

GetValueEventArgs Class
Mincom.LinkOne.Dom Namespace


GetValueEventArgs Constructor

[image]

LinkOne WebView API
GetValueEventArgs Constructor
GetValueEventArgs Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public GetValueEventArgs(
    string name,
    IBook book,
    IPage page,
    IEntry entry
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    book As IBook, _
    page As IPage, _
    entry As IEntry _
)
Visual C++
public:
GetValueEventArgs(
    String^ name,
    IBook^ book,
    IPage^ page,
    IEntry^ entry
)

Parameters

name
Type: System..::.String
The name of the value being read.
book
Type: Mincom.LinkOne.Dom..::.IBook
The book requesting the value.
page
Type: Mincom.LinkOne.Dom..::.IPage
The page requesting the value.
entry
Type: Mincom.LinkOne.Dom..::.IEntry
The entry requesting the value.

See Also

GetValueEventArgs Class
Mincom.LinkOne.Dom Namespace


GetValueEventArgs Methods

[image] [image]

LinkOne WebView API
GetValueEventArgs Methods
GetValueEventArgs Class See Also Send Feedback

The GetValueEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

GetValueEventArgs Class
Mincom.LinkOne.Dom Namespace


GetValueEventArgs Properties

[image] [image]

LinkOne WebView API
GetValueEventArgs Properties
GetValueEventArgs Class See Also Send Feedback

The GetValueEventArgs type exposes the following members.

Properties

Name | Description
Book | Gets the book requesting the value.
Entry | Gets the entry requesting the value.
Handled | Gets or sets true if the value has been read.
Name | Gets the name of the value being read.
Page | Gets the page requesting the value.
Value | Gets or sets the value being read.

See Also

GetValueEventArgs Class
Mincom.LinkOne.Dom Namespace


Book Property

[image]

LinkOne WebView API
GetValueEventArgs..::.Book Property
GetValueEventArgs Class See Also Send Feedback
Gets the book requesting the value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IBook Book { get; }
Visual Basic (Declaration)
Public ReadOnly Property Book As IBook
Visual C++
public:
property IBook^ Book {
    IBook^ get ();
}

See Also

GetValueEventArgs Class
Mincom.LinkOne.Dom Namespace


Entry Property

[image]

LinkOne WebView API
GetValueEventArgs..::.Entry Property
GetValueEventArgs Class See Also Send Feedback
Gets the entry requesting the value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IEntry Entry { get; }
Visual Basic (Declaration)
Public ReadOnly Property Entry As IEntry
Visual C++
public:
property IEntry^ Entry {
    IEntry^ get ();
}

See Also

GetValueEventArgs Class
Mincom.LinkOne.Dom Namespace


Handled Property

[image]

LinkOne WebView API
GetValueEventArgs..::.Handled Property
GetValueEventArgs Class See Also Send Feedback
Gets or sets true if the value has been read.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Handled { get; set; }
Visual Basic (Declaration)
Public Property Handled As Boolean
Visual C++
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

See Also

GetValueEventArgs Class
Mincom.LinkOne.Dom Namespace


Name Property

[image]

LinkOne WebView API
GetValueEventArgs..::.Name Property
GetValueEventArgs Class See Also Send Feedback
Gets the name of the value being read.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

GetValueEventArgs Class
Mincom.LinkOne.Dom Namespace


Page Property

[image]

LinkOne WebView API
GetValueEventArgs..::.Page Property
GetValueEventArgs Class See Also Send Feedback
Gets the page requesting the value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IPage Page { get; }
Visual Basic (Declaration)
Public ReadOnly Property Page As IPage
Visual C++
public:
property IPage^ Page {
    IPage^ get ();
}

See Also

GetValueEventArgs Class
Mincom.LinkOne.Dom Namespace


Value Property

[image]

LinkOne WebView API
GetValueEventArgs..::.Value Property
GetValueEventArgs Class See Also Send Feedback
Gets or sets the value being read.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

GetValueEventArgs Class
Mincom.LinkOne.Dom Namespace


GetValueEventHandler Delegate

[image]

LinkOne WebView API
GetValueEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the read value event.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public delegate void GetValueEventHandler(
    Object sender,
    GetValueEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub GetValueEventHandler ( _
    sender As Object, _
    e As GetValueEventArgs _
)
Visual C++
public delegate void GetValueEventHandler(
    Object^ sender,
    GetValueEventArgs^ e
)

Parameters

sender
Type: System..::.Object
e
Type: Mincom.LinkOne.Dom..::.GetValueEventArgs

See Also

Mincom.LinkOne.Dom Namespace


Graphic Class

[image]

LinkOne WebView API
Graphic Class
Members See Also Send Feedback
Represents an "Additional Graphic" that has been included in a LinkOne Book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public sealed class Graphic : IPersist
Visual Basic (Declaration)
Public NotInheritable Class Graphic _
    Implements IPersist
Visual C++
public ref class Graphic sealed : IPersist

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.Graphic

See Also

Graphic Members
Mincom.LinkOne.Dom Namespace


Graphic Members

[image] [image]

LinkOne WebView API
Graphic Members
Graphic Class Constructors Methods Properties See Also Send Feedback

The Graphic type exposes the following members.

Constructors

Name | Description
Graphic | Initializes a new instance of the Graphic class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Resource | Get the graphic's resource containing the binary JPG/PNG image.

See Also

Graphic Class
Mincom.LinkOne.Dom Namespace


Graphic Constructor

[image]

LinkOne WebView API
Graphic Constructor
Graphic Class See Also Send Feedback
Initializes a new instance of the Graphic class

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Graphic()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Graphic()

See Also

Graphic Class
Mincom.LinkOne.Dom Namespace


Graphic Methods

[image] [image]

LinkOne WebView API
Graphic Methods
Graphic Class See Also Send Feedback

The Graphic type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Graphic Class
Mincom.LinkOne.Dom Namespace


Graphic Properties

[image] [image]

LinkOne WebView API
Graphic Properties
Graphic Class See Also Send Feedback

The Graphic type exposes the following members.

Properties

Name | Description
Resource | Get the graphic's resource containing the binary JPG/PNG image.

See Also

Graphic Class
Mincom.LinkOne.Dom Namespace


Resource Property

[image]

LinkOne WebView API
Graphic..::.Resource Property
Graphic Class See Also Send Feedback
Get the graphic's resource containing the binary JPG/PNG image.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Resource Resource { get; }
Visual Basic (Declaration)
Public ReadOnly Property Resource As Resource
Visual C++
public:
property Resource^ Resource {
    Resource^ get ();
}

See Also

Graphic Class
Mincom.LinkOne.Dom Namespace


IBook Interface

[image]

LinkOne WebView API
IBook Interface
Members See Also Send Feedback
A LinkOne Book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IBook
Visual Basic (Declaration)
Public Interface IBook
Visual C++
public interface class IBook

See Also

IBook Members
Mincom.LinkOne.Dom Namespace


IBook Members

[image] [image]

LinkOne WebView API
IBook Members
IBook Interface Methods Properties See Also Send Feedback

The IBook type exposes the following members.

Methods

Name | Description
GetField | Returns the value of the wanted field.

Properties

Name | Description
Attributes | Gets the attributes for the book.
BookCode | Gets the book code of the book.
BookDescription | Gets the book description.
BookDescriptionTranslations | Gets the book description translations.
Categories | Gets the note categories visible to the book, publisher and library.
CategoryCodes | Gets the category codes associated with the book.
EntryFieldDefinitions | Gets the custom entry field definitions associated with the book.
Fields | Gets the publisher defined fields associated with the book.
Filters | Gets the filters that have been applied to the book.
InternalBookCode | Gets the internal book code of the book.
InternalBookDescription | Gets the internal book description.
InternalPublisherCode | Gets the internal publisher code.
InternalPublisherDescription | Gets the internal publisher description.
IsDraft | Gets a value indicating whether the book was published as a draft.
Library | Gets the owning library of the book.
Licenses | Gets the licenses that are in affect for this book.
Notes | Gets the notes visible to the book, publisher and library.
OptionDefinitions | Gets the option definitions.
Pages | Gets the pages.
PrintLayouts | Gets the layouts included in this book that can be used for printing.
PublishedDate | Gets the published date.
PublisherCode | Gets the publisher code.
PublisherDescription | Gets the publisher description.
ScreenLayouts | Gets the layouts included in this book that can be used on the screen.
SearchSets | Gets the search sets for the book.
StylesheetFullPath |
Toc | Gets the table of contents for the book.
Values | Gets the values that are visible to the book.

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


IBook Methods

[image] [image]

LinkOne WebView API
IBook Methods
IBook Interface See Also Send Feedback

The IBook type exposes the following members.

Methods

Name | Description
GetField | Returns the value of the wanted field.

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


GetField Method

[image]

LinkOne WebView API
IBook..::.GetField Method
IBook Interface See Also Send Feedback
Returns the value of the wanted field.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string GetField(
    string name
)
Visual Basic (Declaration)
Function GetField ( _
    name As String _
) As String
Visual C++
String^ GetField(
    String^ name
)

Parameters

name
Type: System..::.String
Name of the wanted field.

Return Value

The value of the wanted field, or blank if not found.

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


IBook Properties

[image] [image]

LinkOne WebView API
IBook Properties
IBook Interface See Also Send Feedback

The IBook type exposes the following members.

Properties

Name | Description
Attributes | Gets the attributes for the book.
BookCode | Gets the book code of the book.
BookDescription | Gets the book description.
BookDescriptionTranslations | Gets the book description translations.
Categories | Gets the note categories visible to the book, publisher and library.
CategoryCodes | Gets the category codes associated with the book.
EntryFieldDefinitions | Gets the custom entry field definitions associated with the book.
Fields | Gets the publisher defined fields associated with the book.
Filters | Gets the filters that have been applied to the book.
InternalBookCode | Gets the internal book code of the book.
InternalBookDescription | Gets the internal book description.
InternalPublisherCode | Gets the internal publisher code.
InternalPublisherDescription | Gets the internal publisher description.
IsDraft | Gets a value indicating whether the book was published as a draft.
Library | Gets the owning library of the book.
Licenses | Gets the licenses that are in affect for this book.
Notes | Gets the notes visible to the book, publisher and library.
OptionDefinitions | Gets the option definitions.
Pages | Gets the pages.
PrintLayouts | Gets the layouts included in this book that can be used for printing.
PublishedDate | Gets the published date.
PublisherCode | Gets the publisher code.
PublisherDescription | Gets the publisher description.
ScreenLayouts | Gets the layouts included in this book that can be used on the screen.
SearchSets | Gets the search sets for the book.
StylesheetFullPath |
Toc | Gets the table of contents for the book.
Values | Gets the values that are visible to the book.

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


Attributes Property

[image]

LinkOne WebView API
IBook..::.Attributes Property
IBook Interface See Also Send Feedback
Gets the attributes for the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IAttributeCollection Attributes { get; }
Visual Basic (Declaration)
ReadOnly Property Attributes As IAttributeCollection
Visual C++
property IAttributeCollection^ Attributes {
    IAttributeCollection^ get ();
}

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


BookCode Property

[image]

LinkOne WebView API
IBook..::.BookCode Property
IBook Interface See Also Send Feedback
Gets the book code of the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string BookCode { get; }
Visual Basic (Declaration)
ReadOnly Property BookCode As String
Visual C++
property String^ BookCode {
    String^ get ();
}

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


BookDescription Property

[image]

LinkOne WebView API
IBook..::.BookDescription Property
IBook Interface See Also Send Feedback
Gets the book description.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string BookDescription { get; }
Visual Basic (Declaration)
ReadOnly Property BookDescription As String
Visual C++
property String^ BookDescription {
    String^ get ();
}

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


BookDescriptionTranslations Property

[image]

LinkOne WebView API
IBook..::.BookDescriptionTranslations Property
IBook Interface See Also Send Feedback
Gets the book description translations.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ITranslationCollection BookDescriptionTranslations { get; }
Visual Basic (Declaration)
ReadOnly Property BookDescriptionTranslations As ITranslationCollection
Visual C++
property ITranslationCollection^ BookDescriptionTranslations {
    ITranslationCollection^ get ();
}

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


Categories Property

[image]

LinkOne WebView API
IBook..::.Categories Property
IBook Interface See Also Send Feedback
Gets the note categories visible to the book, publisher and library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ICategoryCollection Categories { get; }
Visual Basic (Declaration)
ReadOnly Property Categories As ICategoryCollection
Visual C++
property ICategoryCollection^ Categories {
    ICategoryCollection^ get ();
}

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


CategoryCodes Property

[image]

LinkOne WebView API
IBook..::.CategoryCodes Property
IBook Interface See Also Send Feedback
Gets the category codes associated with the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IList<string> CategoryCodes { get; }
Visual Basic (Declaration)
ReadOnly Property CategoryCodes As IList(Of String)
Visual C++
property IList<String^>^ CategoryCodes {
    IList<String^>^ get ();
}

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


EntryFieldDefinitions Property

[image]

LinkOne WebView API
IBook..::.EntryFieldDefinitions Property
IBook Interface See Also Send Feedback
Gets the custom entry field definitions associated with the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IList<string> EntryFieldDefinitions { get; }
Visual Basic (Declaration)
ReadOnly Property EntryFieldDefinitions As IList(Of String)
Visual C++
property IList<String^>^ EntryFieldDefinitions {
    IList<String^>^ get ();
}

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


Fields Property

[image]

LinkOne WebView API
IBook..::.Fields Property
IBook Interface See Also Send Feedback
Gets the publisher defined fields associated with the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IFieldCollection Fields { get; }
Visual Basic (Declaration)
ReadOnly Property Fields As IFieldCollection
Visual C++
property IFieldCollection^ Fields {
    IFieldCollection^ get ();
}

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


Filters Property

[image]

LinkOne WebView API
IBook..::.Filters Property
IBook Interface See Also Send Feedback
Gets the filters that have been applied to the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IFilterCollection Filters { get; }
Visual Basic (Declaration)
ReadOnly Property Filters As IFilterCollection
Visual C++
property IFilterCollection^ Filters {
    IFilterCollection^ get ();
}

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


InternalBookCode Property

[image]

LinkOne WebView API
IBook..::.InternalBookCode Property
IBook Interface See Also Send Feedback
Gets the internal book code of the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string InternalBookCode { get; }
Visual Basic (Declaration)
ReadOnly Property InternalBookCode As String
Visual C++
property String^ InternalBookCode {
    String^ get ();
}

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


InternalBookDescription Property

[image]

LinkOne WebView API
IBook..::.InternalBookDescription Property
IBook Interface See Also Send Feedback
Gets the internal book description.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string InternalBookDescription { get; }
Visual Basic (Declaration)
ReadOnly Property InternalBookDescription As String
Visual C++
property String^ InternalBookDescription {
    String^ get ();
}

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


InternalPublisherCode Property

[image]

LinkOne WebView API
IBook..::.InternalPublisherCode Property
IBook Interface See Also Send Feedback
Gets the internal publisher code.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string InternalPublisherCode { get; }
Visual Basic (Declaration)
ReadOnly Property InternalPublisherCode As String
Visual C++
property String^ InternalPublisherCode {
    String^ get ();
}

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


InternalPublisherDescription Property

[image]

LinkOne WebView API
IBook..::.InternalPublisherDescription Property
IBook Interface See Also Send Feedback
Gets the internal publisher description.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string InternalPublisherDescription { get; }
Visual Basic (Declaration)
ReadOnly Property InternalPublisherDescription As String
Visual C++
property String^ InternalPublisherDescription {
    String^ get ();
}

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


IsDraft Property

[image]

LinkOne WebView API
IBook..::.IsDraft Property
IBook Interface See Also Send Feedback
Gets a value indicating whether the book was published as a draft.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IsDraft { get; }
Visual Basic (Declaration)
ReadOnly Property IsDraft As Boolean
Visual C++
property bool IsDraft {
    bool get ();
}

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


Library Property

[image]

LinkOne WebView API
IBook..::.Library Property
IBook Interface See Also Send Feedback
Gets the owning library of the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ILibrary Library { get; }
Visual Basic (Declaration)
ReadOnly Property Library As ILibrary
Visual C++
property ILibrary^ Library {
    ILibrary^ get ();
}

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


Licenses Property

[image]

LinkOne WebView API
IBook..::.Licenses Property
IBook Interface See Also Send Feedback
Gets the licenses that are in affect for this book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IList<string> Licenses { get; }
Visual Basic (Declaration)
ReadOnly Property Licenses As IList(Of String)
Visual C++
property IList<String^>^ Licenses {
    IList<String^>^ get ();
}

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


Notes Property

[image]

LinkOne WebView API
IBook..::.Notes Property
IBook Interface See Also Send Feedback
Gets the notes visible to the book, publisher and library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
INoteCollection Notes { get; }
Visual Basic (Declaration)
ReadOnly Property Notes As INoteCollection
Visual C++
property INoteCollection^ Notes {
    INoteCollection^ get ();
}

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


OptionDefinitions Property

[image]

LinkOne WebView API
IBook..::.OptionDefinitions Property
IBook Interface See Also Send Feedback
Gets the option definitions.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IOptionDefinitionCollection OptionDefinitions { get; }
Visual Basic (Declaration)
ReadOnly Property OptionDefinitions As IOptionDefinitionCollection
Visual C++
property IOptionDefinitionCollection^ OptionDefinitions {
    IOptionDefinitionCollection^ get ();
}

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


Pages Property

[image]

LinkOne WebView API
IBook..::.Pages Property
IBook Interface See Also Send Feedback
Gets the pages.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPageCollection Pages { get; }
Visual Basic (Declaration)
ReadOnly Property Pages As IPageCollection
Visual C++
property IPageCollection^ Pages {
    IPageCollection^ get ();
}

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


PrintLayouts Property

[image]

LinkOne WebView API
IBook..::.PrintLayouts Property
IBook Interface See Also Send Feedback
Gets the layouts included in this book that can be used for printing.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ILayoutCollection PrintLayouts { get; }
Visual Basic (Declaration)
ReadOnly Property PrintLayouts As ILayoutCollection
Visual C++
property ILayoutCollection^ PrintLayouts {
    ILayoutCollection^ get ();
}

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


PublishedDate Property

[image]

LinkOne WebView API
IBook..::.PublishedDate Property
IBook Interface See Also Send Feedback
Gets the published date.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
DateTime PublishedDate { get; }
Visual Basic (Declaration)
ReadOnly Property PublishedDate As DateTime
Visual C++
property DateTime PublishedDate {
    DateTime get ();
}

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


PublisherCode Property

[image]

LinkOne WebView API
IBook..::.PublisherCode Property
IBook Interface See Also Send Feedback
Gets the publisher code.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string PublisherCode { get; }
Visual Basic (Declaration)
ReadOnly Property PublisherCode As String
Visual C++
property String^ PublisherCode {
    String^ get ();
}

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


PublisherDescription Property

[image]

LinkOne WebView API
IBook..::.PublisherDescription Property
IBook Interface See Also Send Feedback
Gets the publisher description.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string PublisherDescription { get; }
Visual Basic (Declaration)
ReadOnly Property PublisherDescription As String
Visual C++
property String^ PublisherDescription {
    String^ get ();
}

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


ScreenLayouts Property

[image]

LinkOne WebView API
IBook..::.ScreenLayouts Property
IBook Interface See Also Send Feedback
Gets the layouts included in this book that can be used on the screen.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ILayoutCollection ScreenLayouts { get; }
Visual Basic (Declaration)
ReadOnly Property ScreenLayouts As ILayoutCollection
Visual C++
property ILayoutCollection^ ScreenLayouts {
    ILayoutCollection^ get ();
}

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


SearchSets Property

[image]

LinkOne WebView API
IBook..::.SearchSets Property
IBook Interface See Also Send Feedback
Gets the search sets for the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ISearchSetCollection SearchSets { get; }
Visual Basic (Declaration)
ReadOnly Property SearchSets As ISearchSetCollection
Visual C++
property ISearchSetCollection^ SearchSets {
    ISearchSetCollection^ get ();
}

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


StylesheetFullPath Property

[image]

LinkOne WebView API
IBook..::.StylesheetFullPath Property
IBook Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string StylesheetFullPath { get; }
Visual Basic (Declaration)
ReadOnly Property StylesheetFullPath As String
Visual C++
property String^ StylesheetFullPath {
    String^ get ();
}

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


Toc Property

[image]

LinkOne WebView API
IBook..::.Toc Property
IBook Interface See Also Send Feedback
Gets the table of contents for the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IToc Toc { get; }
Visual Basic (Declaration)
ReadOnly Property Toc As IToc
Visual C++
property IToc^ Toc {
    IToc^ get ();
}

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


Values Property

[image]

LinkOne WebView API
IBook..::.Values Property
IBook Interface See Also Send Feedback
Gets the values that are visible to the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IValueCollection Values { get; }
Visual Basic (Declaration)
ReadOnly Property Values As IValueCollection
Visual C++
property IValueCollection^ Values {
    IValueCollection^ get ();
}

See Also

IBook Interface
Mincom.LinkOne.Dom Namespace


IBookCategory Interface

[image]

LinkOne WebView API
IBookCategory Interface
Members See Also Send Feedback
Represents a category of books for a publisher.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IBookCategory : ICatalog
Visual Basic (Declaration)
Public Interface IBookCategory _
    Implements ICatalog
Visual C++
public interface class IBookCategory : ICatalog

See Also

IBookCategory Members
Mincom.LinkOne.Dom Namespace


IBookCategory Members

[image] [image]

LinkOne WebView API
IBookCategory Members
IBookCategory Interface Properties See Also Send Feedback

The IBookCategory type exposes the following members.

Properties

Name | Description
Books | Gets the books in the catalog. (Inherited from ICatalog.)
Categories | Gets the categories in the catalog. (Inherited from ICatalog.)
CategoryCode | Gets the category code.
CategoryDescription | Gets the category description.
CategoryDescriptionTranslations | Gets the category description translations.

See Also

IBookCategory Interface
Mincom.LinkOne.Dom Namespace


IBookCategory Properties

[image] [image]

LinkOne WebView API
IBookCategory Properties
IBookCategory Interface See Also Send Feedback

The IBookCategory type exposes the following members.

Properties

Name | Description
Books | Gets the books in the catalog. (Inherited from ICatalog.)
Categories | Gets the categories in the catalog. (Inherited from ICatalog.)
CategoryCode | Gets the category code.
CategoryDescription | Gets the category description.
CategoryDescriptionTranslations | Gets the category description translations.

See Also

IBookCategory Interface
Mincom.LinkOne.Dom Namespace


CategoryCode Property

[image]

LinkOne WebView API
IBookCategory..::.CategoryCode Property
IBookCategory Interface See Also Send Feedback
Gets the category code.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string CategoryCode { get; }
Visual Basic (Declaration)
ReadOnly Property CategoryCode As String
Visual C++
property String^ CategoryCode {
    String^ get ();
}

See Also

IBookCategory Interface
Mincom.LinkOne.Dom Namespace


CategoryDescription Property

[image]

LinkOne WebView API
IBookCategory..::.CategoryDescription Property
IBookCategory Interface See Also Send Feedback
Gets the category description.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string CategoryDescription { get; }
Visual Basic (Declaration)
ReadOnly Property CategoryDescription As String
Visual C++
property String^ CategoryDescription {
    String^ get ();
}

See Also

IBookCategory Interface
Mincom.LinkOne.Dom Namespace


CategoryDescriptionTranslations Property

[image]

LinkOne WebView API
IBookCategory..::.CategoryDescriptionTranslations Property
IBookCategory Interface See Also Send Feedback
Gets the category description translations.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ITranslationCollection CategoryDescriptionTranslations { get; }
Visual Basic (Declaration)
ReadOnly Property CategoryDescriptionTranslations As ITranslationCollection
Visual C++
property ITranslationCollection^ CategoryDescriptionTranslations {
    ITranslationCollection^ get ();
}

See Also

IBookCategory Interface
Mincom.LinkOne.Dom Namespace


IBookCategoryCollection Interface

[image]

LinkOne WebView API
IBookCategoryCollection Interface
Members See Also Send Feedback
Represents a collection of categories, indexed by CategoryCode.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IBookCategoryCollection : IReadOnlyKeyedCollection<string, IBookCategory>,
    IReadOnlyCollection<IBookCategory>, IEnumerable<IBookCategory>, IEnumerable
Visual Basic (Declaration)
Public Interface IBookCategoryCollection _
    Implements IReadOnlyKeyedCollection(Of String, IBookCategory),  _
    IReadOnlyCollection(Of IBookCategory), IEnumerable(Of IBookCategory), IEnumerable
Visual C++
public interface class IBookCategoryCollection : IReadOnlyKeyedCollection<String^, IBookCategory^>,
    IReadOnlyCollection<IBookCategory^>, IEnumerable<IBookCategory^>, IEnumerable

See Also

IBookCategoryCollection Members
Mincom.LinkOne.Dom Namespace


IBookCategoryCollection Members

[image] [image]

LinkOne WebView API
IBookCategoryCollection Members
IBookCategoryCollection Interface Methods Properties See Also Send Feedback

The IBookCategoryCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
GetEnumerator | Overloaded.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item with the specified key. (Inherited from IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>).)

See Also

IBookCategoryCollection Interface
Mincom.LinkOne.Dom Namespace


IBookCategoryCollection Methods

[image] [image]

LinkOne WebView API
IBookCategoryCollection Methods
IBookCategoryCollection Interface See Also Send Feedback

Methods

Name | Description
Contains | Overloaded.
GetEnumerator | Overloaded.

See Also

IBookCategoryCollection Interface
Mincom.LinkOne.Dom Namespace


Contains Method

[image] [image]

LinkOne WebView API
IBookCategoryCollection..::.Contains Method
IBookCategoryCollection Interface See Also Send Feedback

Overload List

Name | Description
Contains(T) | Determines whether an element is in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Contains(TKey) | Determines whether an element with the given key is in the collection. (Inherited from IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>).)

See Also

IBookCategoryCollection Interface
IBookCategoryCollection Members
Mincom.LinkOne.Dom Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
IBookCategoryCollection..::.GetEnumerator Method
IBookCategoryCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( IBookCategory >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IBookCategoryCollection Interface
IBookCategoryCollection Members
Mincom.LinkOne.Dom Namespace


IBookCategoryCollection Properties

[image] [image]

LinkOne WebView API
IBookCategoryCollection Properties
IBookCategoryCollection Interface See Also Send Feedback

The IBookCategoryCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item with the specified key. (Inherited from IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>).)

See Also

IBookCategoryCollection Interface
Mincom.LinkOne.Dom Namespace


IBookCollection Interface

[image]

LinkOne WebView API
IBookCollection Interface
Members See Also Send Feedback
Represents a collection of books, indexed by BookCode.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IBookCollection : IReadOnlyKeyedCollection<string, IBook>,
    IReadOnlyCollection<IBook>, IEnumerable<IBook>, IEnumerable
Visual Basic (Declaration)
Public Interface IBookCollection _
    Implements IReadOnlyKeyedCollection(Of String, IBook),  _
    IReadOnlyCollection(Of IBook), IEnumerable(Of IBook), IEnumerable
Visual C++
public interface class IBookCollection : IReadOnlyKeyedCollection<String^, IBook^>,
    IReadOnlyCollection<IBook^>, IEnumerable<IBook^>, IEnumerable

See Also

IBookCollection Members
Mincom.LinkOne.Dom Namespace


IBookCollection Members

[image] [image]

LinkOne WebView API
IBookCollection Members
IBookCollection Interface Methods Properties See Also Send Feedback

The IBookCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
GetEnumerator | Overloaded.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item with the specified key. (Inherited from IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>).)

See Also

IBookCollection Interface
Mincom.LinkOne.Dom Namespace


IBookCollection Methods

[image] [image]

LinkOne WebView API
IBookCollection Methods
IBookCollection Interface See Also Send Feedback

Methods

Name | Description
Contains | Overloaded.
GetEnumerator | Overloaded.

See Also

IBookCollection Interface
Mincom.LinkOne.Dom Namespace


Contains Method

[image] [image]

LinkOne WebView API
IBookCollection..::.Contains Method
IBookCollection Interface See Also Send Feedback

Overload List

Name | Description
Contains(T) | Determines whether an element is in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Contains(TKey) | Determines whether an element with the given key is in the collection. (Inherited from IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>).)

See Also

IBookCollection Interface
IBookCollection Members
Mincom.LinkOne.Dom Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
IBookCollection..::.GetEnumerator Method
IBookCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( IBook >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IBookCollection Interface
IBookCollection Members
Mincom.LinkOne.Dom Namespace


IBookCollection Properties

[image] [image]

LinkOne WebView API
IBookCollection Properties
IBookCollection Interface See Also Send Feedback

The IBookCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item with the specified key. (Inherited from IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>).)

See Also

IBookCollection Interface
Mincom.LinkOne.Dom Namespace


ICatalog Interface

[image]

LinkOne WebView API
ICatalog Interface
Members See Also Send Feedback
Represents the hierarchy of books for a publisher.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ICatalog
Visual Basic (Declaration)
Public Interface ICatalog
Visual C++
public interface class ICatalog

See Also

ICatalog Members
Mincom.LinkOne.Dom Namespace


ICatalog Members

[image] [image]

LinkOne WebView API
ICatalog Members
ICatalog Interface Properties See Also Send Feedback

The ICatalog type exposes the following members.

Properties

Name | Description
Books | Gets the books in the catalog.
Categories | Gets the categories in the catalog.

See Also

ICatalog Interface
Mincom.LinkOne.Dom Namespace


ICatalog Properties

[image] [image]

LinkOne WebView API
ICatalog Properties
ICatalog Interface See Also Send Feedback

The ICatalog type exposes the following members.

Properties

Name | Description
Books | Gets the books in the catalog.
Categories | Gets the categories in the catalog.

See Also

ICatalog Interface
Mincom.LinkOne.Dom Namespace


Books Property

[image]

LinkOne WebView API
ICatalog..::.Books Property
ICatalog Interface See Also Send Feedback
Gets the books in the catalog.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IBookCollection Books { get; }
Visual Basic (Declaration)
ReadOnly Property Books As IBookCollection
Visual C++
property IBookCollection^ Books {
    IBookCollection^ get ();
}

See Also

ICatalog Interface
Mincom.LinkOne.Dom Namespace


Categories Property

[image]

LinkOne WebView API
ICatalog..::.Categories Property
ICatalog Interface See Also Send Feedback
Gets the categories in the catalog.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IBookCategoryCollection Categories { get; }
Visual Basic (Declaration)
ReadOnly Property Categories As IBookCategoryCollection
Visual C++
property IBookCategoryCollection^ Categories {
    IBookCategoryCollection^ get ();
}

See Also

ICatalog Interface
Mincom.LinkOne.Dom Namespace


IConfigurationManager Interface

[image]

LinkOne WebView API
IConfigurationManager Interface
Members See Also Send Feedback
Implemented by a class that provides configuration management for LinkOne objects.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IConfigurationManager
Visual Basic (Declaration)
Public Interface IConfigurationManager
Visual C++
public interface class IConfigurationManager

Remarks

This interface is used by LinkOne to allow books to be opened by a simple object identifier, where an object identifier may represent an equipment code for example. LinkOne will then call this interface to resolve the object identifier to a specific LinkOne book.
The interface is also used to dynamically update links within a book. LinkOne will call this interface to resolve the link for each item within a book.

See Also

IConfigurationManager Members
Mincom.LinkOne.Dom Namespace


IConfigurationManager Members

[image] [image]

LinkOne WebView API
IConfigurationManager Members
IConfigurationManager Interface Methods See Also Send Feedback

The IConfigurationManager type exposes the following members.

Methods

Name | Description
ResolveLink | Resolves a link to an object from the given item, page, and object.
ResolveObject | Resolves the given object identifier into a specific LinkOne book or page with optional filters.
ResolveSlot | Locates a component link object identifier that is installed at a particular slot link. This function is used to dynamically substitute cross reference links within a LinkOne book. A slot represents a unique location in a book, identified by page reference/item id. LinkOne will call this function the first time any of the Entry.LinkOnePublisherCode, Entry.LinkBookCode or Entry.LinkPageReference properties are accessed.

See Also

IConfigurationManager Interface
Mincom.LinkOne.Dom Namespace


IConfigurationManager Methods

[image] [image]

LinkOne WebView API
IConfigurationManager Methods
IConfigurationManager Interface See Also Send Feedback

The IConfigurationManager type exposes the following members.

Methods

Name | Description
ResolveLink | Resolves a link to an object from the given item, page, and object.
ResolveObject | Resolves the given object identifier into a specific LinkOne book or page with optional filters.
ResolveSlot | Locates a component link object identifier that is installed at a particular slot link. This function is used to dynamically substitute cross reference links within a LinkOne book. A slot represents a unique location in a book, identified by page reference/item id. LinkOne will call this function the first time any of the Entry.LinkOnePublisherCode, Entry.LinkBookCode or Entry.LinkPageReference properties are accessed.

See Also

IConfigurationManager Interface
Mincom.LinkOne.Dom Namespace


ResolveLink Method

[image]

LinkOne WebView API
IConfigurationManager..::.ResolveLink Method
IConfigurationManager Interface See Also Send Feedback
Resolves a link to an object from the given item, page, and object.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ResolveLink(
    string objectIdentifier,
    string pageReference,
    string itemIdentifier,
    out string linkObjectIdentifier
)
Visual Basic (Declaration)
Function ResolveLink ( _
    objectIdentifier As String, _
    pageReference As String, _
    itemIdentifier As String, _
    <OutAttribute> ByRef linkObjectIdentifier As String _
) As Boolean
Visual C++
bool ResolveLink(
    String^ objectIdentifier,
    String^ pageReference,
    String^ itemIdentifier,
    [OutAttribute] String^% linkObjectIdentifier
)

Parameters

objectIdentifier
Type: System..::.String
The identifier of the object the item to resolve belongs to.
pageReference
Type: System..::.String
The reference of the page the item to resolve belongs to.
itemIdentifier
Type: System..::.String
The item to resolve the link for.
linkObjectIdentifier
Type: System..::.String %
The object identifier of the link that exists for the given item.

Return Value

true if a link was resolved from the given item; otherwise false.

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.ConfigurationManagerBusyException | The configuration manager is already busy processing a request.

See Also

IConfigurationManager Interface
Mincom.LinkOne.Dom Namespace


ResolveObject Method

[image]

LinkOne WebView API
IConfigurationManager..::.ResolveObject Method
IConfigurationManager Interface See Also Send Feedback
Resolves the given object identifier into a specific LinkOne book or page with optional filters.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ResolveObject(
    string objectIdentifier,
    bool includeFilters,
    out string publisherCode,
    out string bookCode,
    out string pageReference,
    out NameValueCollection filters
)
Visual Basic (Declaration)
Function ResolveObject ( _
    objectIdentifier As String, _
    includeFilters As Boolean, _
    <OutAttribute> ByRef publisherCode As String, _
    <OutAttribute> ByRef bookCode As String, _
    <OutAttribute> ByRef pageReference As String, _
    <OutAttribute> ByRef filters As NameValueCollection _
) As Boolean
Visual C++
bool ResolveObject(
    String^ objectIdentifier,
    bool includeFilters,
    [OutAttribute] String^% publisherCode,
    [OutAttribute] String^% bookCode,
    [OutAttribute] String^% pageReference,
    [OutAttribute] NameValueCollection^% filters
)

Parameters

objectIdentifier
Type: System..::.String
The object identifier to resolve.
includeFilters
Type: System..::.Boolean
true to resolve any options filters.
publisherCode
Type: System..::.String %
The resolved publisher code of the object identifier.
bookCode
Type: System..::.String %
The resolved book code of the object identifier.
pageReference
Type: System..::.String %
The resolved page reference of the object identifier, or null or an empty string if there is no specific page.
filters
Type: System.Collections.Specialized..::.NameValueCollection %
The resolved option filters of the object identifier, or null or an empty collection if there is no option filters.

Return Value

true if a book was resolved from the given object identifier; otherwise false.

Remarks

The returned filters is a NameValueCollection where the NameValueCollection key represents the filter name and the the NameValueCollection value represents the filter value.

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.ConfigurationManagerBusyException | The configuration manager is already busy processing a request.

See Also

IConfigurationManager Interface
Mincom.LinkOne.Dom Namespace


ResolveSlot Method

[image]

LinkOne WebView API
IConfigurationManager..::.ResolveSlot Method
IConfigurationManager Interface See Also Send Feedback
Locates a component link object identifier that is installed at a particular slot link. This function is used to dynamically substitute cross reference links within a LinkOne book. A slot represents a unique location in a book, identified by page reference/item id. LinkOne will call this function the first time any of the Entry.LinkOnePublisherCode, Entry.LinkBookCode or Entry.LinkPageReference properties are accessed.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ResolveSlot(
    string objectIdentifier,
    string slotIdentifier,
    out string linkObjectIdentifier
)
Visual Basic (Declaration)
Function ResolveSlot ( _
    objectIdentifier As String, _
    slotIdentifier As String, _
    <OutAttribute> ByRef linkObjectIdentifier As String _
) As Boolean
Visual C++
bool ResolveSlot(
    String^ objectIdentifier,
    String^ slotIdentifier,
    [OutAttribute] String^% linkObjectIdentifier
)

Parameters

objectIdentifier
Type: System..::.String
The identifier of the object the component belongs to.
slotIdentifier
Type: System..::.String
The slot at which the component is installed.
linkObjectIdentifier
Type: System..::.String %
The component linke object identifier located at the specified slot link.

Return Value

true if a component link object identifier was found at the specified slot; otherwise false.

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.ConfigurationManagerBusyException | The configuration manager is already busy processing a request.

See Also

IConfigurationManager Interface
Mincom.LinkOne.Dom Namespace


IEntry Interface

[image]

LinkOne WebView API
IEntry Interface
Members See Also Send Feedback
An entry record in a LinkOne parts list.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IEntry : IFilterable
Visual Basic (Declaration)
Public Interface IEntry _
    Implements IFilterable
Visual C++
public interface class IEntry : IFilterable

See Also

IEntry Members
Mincom.LinkOne.Dom Namespace


IEntry Members

[image] [image]

LinkOne WebView API
IEntry Members
IEntry Interface Methods Properties See Also Send Feedback

The IEntry type exposes the following members.

Methods

Name | Description
GetField | Gets the value of the wanted field.

Properties

Name | Description
AlternateCode | Gets the alternate code field of the entry.
Description | Gets the description field of the entry.
Fields | Gets the publisher defined fields associated with the entry.
ItemId | Gets the item id field of the entry.
LinkBookCode | Gets the link book code.
LinkItemId | Gets the link item id.
LinkObjectIdentifier | Gets the link object identifier.
LinkPageReference | Gets the link page reference.
LinkPublisherCode | Gets the link publisher code.
Options | Gets the options associated with this object. (Inherited from IFilterable.)
Page | Gets the page for the entry.
ParentTagNumber | Gets the parent tag number, if parented, otherwise, -1.
PartNumber | Gets the part number field of the entry.
Quantity | Gets the quantity field of the entry.
TagNumber | Gets the unique tag number of this entry;
Units | Gets the units field of the entry.
Values | Gets the values that are visible to the page.
Weight | Gets the weight field of the entry.

See Also

IEntry Interface
Mincom.LinkOne.Dom Namespace


IEntry Methods

[image] [image]

LinkOne WebView API
IEntry Methods
IEntry Interface See Also Send Feedback

The IEntry type exposes the following members.

Methods

Name | Description
GetField | Gets the value of the wanted field.

See Also

IEntry Interface
Mincom.LinkOne.Dom Namespace


GetField Method

[image]

LinkOne WebView API
IEntry..::.GetField Method
IEntry Interface See Also Send Feedback
Gets the value of the wanted field.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string GetField(
    string name
)
Visual Basic (Declaration)
Function GetField ( _
    name As String _
) As String
Visual C++
String^ GetField(
    String^ name
)

Parameters

name
Type: System..::.String
Name of the wanted field.

Return Value

The value of the wanted field, or blank if not found.

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.LicenseLockException | The field is locked and requires a key.

See Also

IEntry Interface
Mincom.LinkOne.Dom Namespace


IEntry Properties

[image] [image]

LinkOne WebView API
IEntry Properties
IEntry Interface See Also Send Feedback

The IEntry type exposes the following members.

Properties

Name | Description
AlternateCode | Gets the alternate code field of the entry.
Description | Gets the description field of the entry.
Fields | Gets the publisher defined fields associated with the entry.
ItemId | Gets the item id field of the entry.
LinkBookCode | Gets the link book code.
LinkItemId | Gets the link item id.
LinkObjectIdentifier | Gets the link object identifier.
LinkPageReference | Gets the link page reference.
LinkPublisherCode | Gets the link publisher code.
Options | Gets the options associated with this object. (Inherited from IFilterable.)
Page | Gets the page for the entry.
ParentTagNumber | Gets the parent tag number, if parented, otherwise, -1.
PartNumber | Gets the part number field of the entry.
Quantity | Gets the quantity field of the entry.
TagNumber | Gets the unique tag number of this entry;
Units | Gets the units field of the entry.
Values | Gets the values that are visible to the page.
Weight | Gets the weight field of the entry.

See Also

IEntry Interface
Mincom.LinkOne.Dom Namespace


AlternateCode Property

[image]

LinkOne WebView API
IEntry..::.AlternateCode Property
IEntry Interface See Also Send Feedback
Gets the alternate code field of the entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string AlternateCode { get; }
Visual Basic (Declaration)
ReadOnly Property AlternateCode As String
Visual C++
property String^ AlternateCode {
    String^ get ();
}

See Also

IEntry Interface
Mincom.LinkOne.Dom Namespace


Description Property

[image]

LinkOne WebView API
IEntry..::.Description Property
IEntry Interface See Also Send Feedback
Gets the description field of the entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Description { get; }
Visual Basic (Declaration)
ReadOnly Property Description As String
Visual C++
property String^ Description {
    String^ get ();
}

See Also

IEntry Interface
Mincom.LinkOne.Dom Namespace


Fields Property

[image]

LinkOne WebView API
IEntry..::.Fields Property
IEntry Interface See Also Send Feedback
Gets the publisher defined fields associated with the entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IFieldCollection Fields { get; }
Visual Basic (Declaration)
ReadOnly Property Fields As IFieldCollection
Visual C++
property IFieldCollection^ Fields {
    IFieldCollection^ get ();
}

See Also

IEntry Interface
Mincom.LinkOne.Dom Namespace


ItemId Property

[image]

LinkOne WebView API
IEntry..::.ItemId Property
IEntry Interface See Also Send Feedback
Gets the item id field of the entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string ItemId { get; }
Visual Basic (Declaration)
ReadOnly Property ItemId As String
Visual C++
property String^ ItemId {
    String^ get ();
}

See Also

IEntry Interface
Mincom.LinkOne.Dom Namespace


LinkBookCode Property

[image]

LinkOne WebView API
IEntry..::.LinkBookCode Property
IEntry Interface See Also Send Feedback
Gets the link book code.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string LinkBookCode { get; }
Visual Basic (Declaration)
ReadOnly Property LinkBookCode As String
Visual C++
property String^ LinkBookCode {
    String^ get ();
}

See Also

IEntry Interface
Mincom.LinkOne.Dom Namespace


LinkItemId Property

[image]

LinkOne WebView API
IEntry..::.LinkItemId Property
IEntry Interface See Also Send Feedback
Gets the link item id.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string LinkItemId { get; }
Visual Basic (Declaration)
ReadOnly Property LinkItemId As String
Visual C++
property String^ LinkItemId {
    String^ get ();
}

See Also

IEntry Interface
Mincom.LinkOne.Dom Namespace


LinkObjectIdentifier Property

[image]

LinkOne WebView API
IEntry..::.LinkObjectIdentifier Property
IEntry Interface See Also Send Feedback
Gets the link object identifier.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string LinkObjectIdentifier { get; }
Visual Basic (Declaration)
ReadOnly Property LinkObjectIdentifier As String
Visual C++
property String^ LinkObjectIdentifier {
    String^ get ();
}

See Also

IEntry Interface
Mincom.LinkOne.Dom Namespace


LinkPageReference Property

[image]

LinkOne WebView API
IEntry..::.LinkPageReference Property
IEntry Interface See Also Send Feedback
Gets the link page reference.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string LinkPageReference { get; }
Visual Basic (Declaration)
ReadOnly Property LinkPageReference As String
Visual C++
property String^ LinkPageReference {
    String^ get ();
}

See Also

IEntry Interface
Mincom.LinkOne.Dom Namespace


LinkPublisherCode Property

[image]

LinkOne WebView API
IEntry..::.LinkPublisherCode Property
IEntry Interface See Also Send Feedback
Gets the link publisher code.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string LinkPublisherCode { get; }
Visual Basic (Declaration)
ReadOnly Property LinkPublisherCode As String
Visual C++
property String^ LinkPublisherCode {
    String^ get ();
}

See Also

IEntry Interface
Mincom.LinkOne.Dom Namespace


Page Property

[image]

LinkOne WebView API
IEntry..::.Page Property
IEntry Interface See Also Send Feedback
Gets the page for the entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPage Page { get; }
Visual Basic (Declaration)
ReadOnly Property Page As IPage
Visual C++
property IPage^ Page {
    IPage^ get ();
}

See Also

IEntry Interface
Mincom.LinkOne.Dom Namespace


ParentTagNumber Property

[image]

LinkOne WebView API
IEntry..::.ParentTagNumber Property
IEntry Interface See Also Send Feedback
Gets the parent tag number, if parented, otherwise, -1.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int ParentTagNumber { get; }
Visual Basic (Declaration)
ReadOnly Property ParentTagNumber As Integer
Visual C++
property int ParentTagNumber {
    int get ();
}

See Also

IEntry Interface
Mincom.LinkOne.Dom Namespace


PartNumber Property

[image]

LinkOne WebView API
IEntry..::.PartNumber Property
IEntry Interface See Also Send Feedback
Gets the part number field of the entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string PartNumber { get; }
Visual Basic (Declaration)
ReadOnly Property PartNumber As String
Visual C++
property String^ PartNumber {
    String^ get ();
}

See Also

IEntry Interface
Mincom.LinkOne.Dom Namespace


Quantity Property

[image]

LinkOne WebView API
IEntry..::.Quantity Property
IEntry Interface See Also Send Feedback
Gets the quantity field of the entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Quantity { get; }
Visual Basic (Declaration)
ReadOnly Property Quantity As String
Visual C++
property String^ Quantity {
    String^ get ();
}

See Also

IEntry Interface
Mincom.LinkOne.Dom Namespace


TagNumber Property

[image]

LinkOne WebView API
IEntry..::.TagNumber Property
IEntry Interface See Also Send Feedback
Gets the unique tag number of this entry;

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int TagNumber { get; }
Visual Basic (Declaration)
ReadOnly Property TagNumber As Integer
Visual C++
property int TagNumber {
    int get ();
}

See Also

IEntry Interface
Mincom.LinkOne.Dom Namespace


Units Property

[image]

LinkOne WebView API
IEntry..::.Units Property
IEntry Interface See Also Send Feedback
Gets the units field of the entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Units { get; }
Visual Basic (Declaration)
ReadOnly Property Units As String
Visual C++
property String^ Units {
    String^ get ();
}

See Also

IEntry Interface
Mincom.LinkOne.Dom Namespace


Values Property

[image]

LinkOne WebView API
IEntry..::.Values Property
IEntry Interface See Also Send Feedback
Gets the values that are visible to the page.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IValueCollection Values { get; }
Visual Basic (Declaration)
ReadOnly Property Values As IValueCollection
Visual C++
property IValueCollection^ Values {
    IValueCollection^ get ();
}

See Also

IEntry Interface
Mincom.LinkOne.Dom Namespace


Weight Property

[image]

LinkOne WebView API
IEntry..::.Weight Property
IEntry Interface See Also Send Feedback
Gets the weight field of the entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Weight { get; }
Visual Basic (Declaration)
ReadOnly Property Weight As String
Visual C++
property String^ Weight {
    String^ get ();
}

See Also

IEntry Interface
Mincom.LinkOne.Dom Namespace


IEntryCollection Interface

[image]

LinkOne WebView API
IEntryCollection Interface
Members See Also Send Feedback
Represents a collection of entries, that can be individually accessed by either index, or key, TagNumber.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IEntryCollection : IReadOnlyKeyedCollection<int, IEntry>,
    IReadOnlyList<IEntry>, IReadOnlyCollection<IEntry>, IEnumerable<IEntry>,
    IEnumerable
Visual Basic (Declaration)
Public Interface IEntryCollection _
    Implements IReadOnlyKeyedCollection(Of Integer, IEntry), IReadOnlyList(Of IEntry),  _
    IReadOnlyCollection(Of IEntry), IEnumerable(Of IEntry), IEnumerable
Visual C++
public interface class IEntryCollection : IReadOnlyKeyedCollection<int, IEntry^>,
    IReadOnlyList<IEntry^>, IReadOnlyCollection<IEntry^>, IEnumerable<IEntry^>,
    IEnumerable

See Also

IEntryCollection Members
Mincom.LinkOne.Dom Namespace


IEntryCollection Members

[image] [image]

LinkOne WebView API
IEntryCollection Members
IEntryCollection Interface Methods Properties See Also Send Feedback

The IEntryCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
GetEnumerator | Overloaded.
IndexOf | Searches the collection and returns the zero-based index of the first occurrence of the given item. (Inherited from IReadOnlyList<(Of <(T>)>).)

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Overloaded.

See Also

IEntryCollection Interface
Mincom.LinkOne.Dom Namespace


IEntryCollection Methods

[image] [image]

LinkOne WebView API
IEntryCollection Methods
IEntryCollection Interface See Also Send Feedback

The IEntryCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
GetEnumerator | Overloaded.
IndexOf | Searches the collection and returns the zero-based index of the first occurrence of the given item. (Inherited from IReadOnlyList<(Of <(T>)>).)

See Also

IEntryCollection Interface
Mincom.LinkOne.Dom Namespace


Contains Method

[image] [image]

LinkOne WebView API
IEntryCollection..::.Contains Method
IEntryCollection Interface See Also Send Feedback

Overload List

Name | Description
Contains(T) | Determines whether an element is in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Contains(TKey) | Determines whether an element with the given key is in the collection. (Inherited from IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>).)

See Also

IEntryCollection Interface
IEntryCollection Members
Mincom.LinkOne.Dom Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
IEntryCollection..::.GetEnumerator Method
IEntryCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( IEntry >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IEntryCollection Interface
IEntryCollection Members
Mincom.LinkOne.Dom Namespace


IEntryCollection Properties

[image] [image]

LinkOne WebView API
IEntryCollection Properties
IEntryCollection Interface See Also Send Feedback

The IEntryCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Overloaded.

See Also

IEntryCollection Interface
Mincom.LinkOne.Dom Namespace


Item Property

[image] [image]

LinkOne WebView API
IEntryCollection..::.Item Property
IEntryCollection Interface See Also Send Feedback

Overload List

Name | Description
Item[([(TKey])]) | Gets the item with the specified key. (Inherited from IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>).)
Item[([(Int32])]) | Gets the item at the specified index. (Inherited from IReadOnlyList<(Of <(T>)>).)
Item[([(String])]) | Gets the first IEntry in the collection with matching ItemId (case-insensitive).

See Also

IEntryCollection Interface
IEntryCollection Members
Mincom.LinkOne.Dom Namespace


Item Property (String)

[image]

LinkOne WebView API
IEntryCollection..::.Item Property (String)
IEntryCollection Interface See Also Send Feedback
Gets the first IEntry in the collection with matching ItemId (case-insensitive).

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEntry this[
    string itemId
] { get; }
Visual Basic (Declaration)
ReadOnly Default Property Item ( _
    itemId As String _
) As IEntry
Visual C++
property IEntry^ default[String^ itemId] {
    IEntry^ get (String^ itemId);
}

Parameters

itemId
Type: System..::.String
The item id.

See Also

IEntryCollection Interface
Item Overload
Mincom.LinkOne.Dom Namespace


IExceptionCollection Interface

[image]

LinkOne WebView API
IExceptionCollection Interface
Members See Also Send Feedback
Represents a collection of BaseException objects that can be accessed by index.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IExceptionCollection : IReadOnlyList<BaseException>,
    IReadOnlyCollection<BaseException>, IEnumerable<BaseException>, IEnumerable
Visual Basic (Declaration)
Public Interface IExceptionCollection _
    Implements IReadOnlyList(Of BaseException), IReadOnlyCollection(Of BaseException),  _
    IEnumerable(Of BaseException), IEnumerable
Visual C++
public interface class IExceptionCollection : IReadOnlyList<BaseException^>,
    IReadOnlyCollection<BaseException^>, IEnumerable<BaseException^>, IEnumerable

See Also

IExceptionCollection Members
Mincom.LinkOne.Dom Namespace


IExceptionCollection Members

[image] [image]

LinkOne WebView API
IExceptionCollection Members
IExceptionCollection Interface Methods Properties See Also Send Feedback

The IExceptionCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
GetEnumerator | Overloaded.
IndexOf | Searches the collection and returns the zero-based index of the first occurrence of the given item. (Inherited from IReadOnlyList<(Of <(T>)>).)

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from IReadOnlyList<(Of <(T>)>).)

See Also

IExceptionCollection Interface
Mincom.LinkOne.Dom Namespace


IExceptionCollection Methods

[image] [image]

LinkOne WebView API
IExceptionCollection Methods
IExceptionCollection Interface See Also Send Feedback

The IExceptionCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
GetEnumerator | Overloaded.
IndexOf | Searches the collection and returns the zero-based index of the first occurrence of the given item. (Inherited from IReadOnlyList<(Of <(T>)>).)

See Also

IExceptionCollection Interface
Mincom.LinkOne.Dom Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
IExceptionCollection..::.GetEnumerator Method
IExceptionCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( BaseException >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IExceptionCollection Interface
IExceptionCollection Members
Mincom.LinkOne.Dom Namespace


IExceptionCollection Properties

[image] [image]

LinkOne WebView API
IExceptionCollection Properties
IExceptionCollection Interface See Also Send Feedback

The IExceptionCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from IReadOnlyList<(Of <(T>)>).)

See Also

IExceptionCollection Interface
Mincom.LinkOne.Dom Namespace


IField Interface

[image]

LinkOne WebView API
IField Interface
Members See Also Send Feedback
A generic data field.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IField
Visual Basic (Declaration)
Public Interface IField
Visual C++
public interface class IField

Remarks

Fields in a LinkOne book are name-value pairs that may be associated with an entry, a parts list or a book.

See Also

IField Members
Mincom.LinkOne.Dom Namespace


IField Members

[image] [image]

LinkOne WebView API
IField Members
IField Interface Properties See Also Send Feedback

The IField type exposes the following members.

Properties

Name | Description
Name | Gets the name of the field.
Value | Gets the value of the field.

See Also

IField Interface
Mincom.LinkOne.Dom Namespace


IField Properties

[image] [image]

LinkOne WebView API
IField Properties
IField Interface See Also Send Feedback

The IField type exposes the following members.

Properties

Name | Description
Name | Gets the name of the field.
Value | Gets the value of the field.

See Also

IField Interface
Mincom.LinkOne.Dom Namespace


Name Property

[image]

LinkOne WebView API
IField..::.Name Property
IField Interface See Also Send Feedback
Gets the name of the field.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IField Interface
Mincom.LinkOne.Dom Namespace


Value Property

[image]

LinkOne WebView API
IField..::.Value Property
IField Interface See Also Send Feedback
Gets the value of the field.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Value { get; }
Visual Basic (Declaration)
ReadOnly Property Value As String
Visual C++
property String^ Value {
    String^ get ();
}

See Also

IField Interface
Mincom.LinkOne.Dom Namespace


IFieldCollection Interface

[image]

LinkOne WebView API
IFieldCollection Interface
Members See Also Send Feedback
Represents a collection of fields, indexed by Name.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IFieldCollection : IReadOnlyKeyedCollection<string, IField>,
    IReadOnlyCollection<IField>, IEnumerable<IField>, IEnumerable
Visual Basic (Declaration)
Public Interface IFieldCollection _
    Implements IReadOnlyKeyedCollection(Of String, IField),  _
    IReadOnlyCollection(Of IField), IEnumerable(Of IField), IEnumerable
Visual C++
public interface class IFieldCollection : IReadOnlyKeyedCollection<String^, IField^>,
    IReadOnlyCollection<IField^>, IEnumerable<IField^>, IEnumerable

See Also

IFieldCollection Members
Mincom.LinkOne.Dom Namespace


IFieldCollection Members

[image] [image]

LinkOne WebView API
IFieldCollection Members
IFieldCollection Interface Methods Properties See Also Send Feedback

The IFieldCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
GetEnumerator | Overloaded.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item with the specified key. (Inherited from IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>).)

See Also

IFieldCollection Interface
Mincom.LinkOne.Dom Namespace


IFieldCollection Methods

[image] [image]

LinkOne WebView API
IFieldCollection Methods
IFieldCollection Interface See Also Send Feedback

Methods

Name | Description
Contains | Overloaded.
GetEnumerator | Overloaded.

See Also

IFieldCollection Interface
Mincom.LinkOne.Dom Namespace


Contains Method

[image] [image]

LinkOne WebView API
IFieldCollection..::.Contains Method
IFieldCollection Interface See Also Send Feedback

Overload List

Name | Description
Contains(T) | Determines whether an element is in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Contains(TKey) | Determines whether an element with the given key is in the collection. (Inherited from IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>).)

See Also

IFieldCollection Interface
IFieldCollection Members
Mincom.LinkOne.Dom Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
IFieldCollection..::.GetEnumerator Method
IFieldCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( IField >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IFieldCollection Interface
IFieldCollection Members
Mincom.LinkOne.Dom Namespace


IFieldCollection Properties

[image] [image]

LinkOne WebView API
IFieldCollection Properties
IFieldCollection Interface See Also Send Feedback

The IFieldCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item with the specified key. (Inherited from IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>).)

See Also

IFieldCollection Interface
Mincom.LinkOne.Dom Namespace


ILibrary Interface

[image]

LinkOne WebView API
ILibrary Interface
Members See Also Send Feedback
The Library object is the root point of contact for access to the LinkOne book library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ILibrary
Visual Basic (Declaration)
Public Interface ILibrary
Visual C++
public interface class ILibrary

See Also

ILibrary Members
Mincom.LinkOne.Dom Namespace


ILibrary Members

[image] [image]

LinkOne WebView API
ILibrary Members
ILibrary Interface Methods Properties Events See Also Send Feedback

The ILibrary type exposes the following members.

Methods

Name | Description
Write | Writes the specified object to persistent storage.

Properties

Name | Description
Categories | Gets the categories associated with the library.
LanguageCode | Gets the ISO-639 compliant language code of the content.
Licenses | Gets the licenses in affect for the library.
Notes | Gets the notes associated with the library.
Publishers | Gets the publishers found in the library.
TemporaryFilters | Gets the temporary filters applied to the library.
Values | Gets the values visible to the library.

Events

Name | Description
GetValue | Occurs when the library requires an external value.

See Also

ILibrary Interface
Mincom.LinkOne.Dom Namespace


ILibrary Methods

[image] [image]

LinkOne WebView API
ILibrary Methods
ILibrary Interface See Also Send Feedback

The ILibrary type exposes the following members.

Methods

Name | Description
Write | Writes the specified object to persistent storage.

See Also

ILibrary Interface
Mincom.LinkOne.Dom Namespace


Write Method

[image]

LinkOne WebView API
ILibrary..::.Write Method
ILibrary Interface See Also Send Feedback
Writes the specified object to persistent storage.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPersist Write(
    IPersist persist
)
Visual Basic (Declaration)
Function Write ( _
    persist As IPersist _
) As IPersist
Visual C++
IPersist^ Write(
    IPersist^ persist
)

Parameters

persist
Type: Mincom.LinkOne.Dom..::.IPersist
The object to persist.

See Also

ILibrary Interface
Mincom.LinkOne.Dom Namespace


ILibrary Properties

[image] [image]

LinkOne WebView API
ILibrary Properties
ILibrary Interface See Also Send Feedback

The ILibrary type exposes the following members.

Properties

Name | Description
Categories | Gets the categories associated with the library.
LanguageCode | Gets the ISO-639 compliant language code of the content.
Licenses | Gets the licenses in affect for the library.
Notes | Gets the notes associated with the library.
Publishers | Gets the publishers found in the library.
TemporaryFilters | Gets the temporary filters applied to the library.
Values | Gets the values visible to the library.

See Also

ILibrary Interface
Mincom.LinkOne.Dom Namespace


Categories Property

[image]

LinkOne WebView API
ILibrary..::.Categories Property
ILibrary Interface See Also Send Feedback
Gets the categories associated with the library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ICategoryCollection Categories { get; }
Visual Basic (Declaration)
ReadOnly Property Categories As ICategoryCollection
Visual C++
property ICategoryCollection^ Categories {
    ICategoryCollection^ get ();
}

See Also

ILibrary Interface
Mincom.LinkOne.Dom Namespace


LanguageCode Property

[image]

LinkOne WebView API
ILibrary..::.LanguageCode Property
ILibrary Interface See Also Send Feedback
Gets the ISO-639 compliant language code of the content.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string LanguageCode { get; }
Visual Basic (Declaration)
ReadOnly Property LanguageCode As String
Visual C++
property String^ LanguageCode {
    String^ get ();
}

See Also

ILibrary Interface
Mincom.LinkOne.Dom Namespace


Licenses Property

[image]

LinkOne WebView API
ILibrary..::.Licenses Property
ILibrary Interface See Also Send Feedback
Gets the licenses in affect for the library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IList<string> Licenses { get; }
Visual Basic (Declaration)
ReadOnly Property Licenses As IList(Of String)
Visual C++
property IList<String^>^ Licenses {
    IList<String^>^ get ();
}

See Also

ILibrary Interface
Mincom.LinkOne.Dom Namespace


Notes Property

[image]

LinkOne WebView API
ILibrary..::.Notes Property
ILibrary Interface See Also Send Feedback
Gets the notes associated with the library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
INoteCollection Notes { get; }
Visual Basic (Declaration)
ReadOnly Property Notes As INoteCollection
Visual C++
property INoteCollection^ Notes {
    INoteCollection^ get ();
}

See Also

ILibrary Interface
Mincom.LinkOne.Dom Namespace


Publishers Property

[image]

LinkOne WebView API
ILibrary..::.Publishers Property
ILibrary Interface See Also Send Feedback
Gets the publishers found in the library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPublisherCollection Publishers { get; }
Visual Basic (Declaration)
ReadOnly Property Publishers As IPublisherCollection
Visual C++
property IPublisherCollection^ Publishers {
    IPublisherCollection^ get ();
}

See Also

ILibrary Interface
Mincom.LinkOne.Dom Namespace


TemporaryFilters Property

[image]

LinkOne WebView API
ILibrary..::.TemporaryFilters Property
ILibrary Interface See Also Send Feedback
Gets the temporary filters applied to the library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IFilterCollection TemporaryFilters { get; }
Visual Basic (Declaration)
ReadOnly Property TemporaryFilters As IFilterCollection
Visual C++
property IFilterCollection^ TemporaryFilters {
    IFilterCollection^ get ();
}

See Also

ILibrary Interface
Mincom.LinkOne.Dom Namespace


Values Property

[image]

LinkOne WebView API
ILibrary..::.Values Property
ILibrary Interface See Also Send Feedback
Gets the values visible to the library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IValueCollection Values { get; }
Visual Basic (Declaration)
ReadOnly Property Values As IValueCollection
Visual C++
property IValueCollection^ Values {
    IValueCollection^ get ();
}

See Also

ILibrary Interface
Mincom.LinkOne.Dom Namespace


ILibrary Events

[image] [image]

LinkOne WebView API
ILibrary Events
ILibrary Interface See Also Send Feedback

The ILibrary type exposes the following members.

Events

Name | Description
GetValue | Occurs when the library requires an external value.

See Also

ILibrary Interface
Mincom.LinkOne.Dom Namespace


GetValue Event

[image]

LinkOne WebView API
ILibrary..::.GetValue Event
ILibrary Interface See Also Send Feedback
Occurs when the library requires an external value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
event GetValueEventHandler GetValue
Visual Basic (Declaration)
Event GetValue As GetValueEventHandler
Visual C++
 event GetValueEventHandler^ GetValue {
    void add (GetValueEventHandler^ value);
    void remove (GetValueEventHandler^ value);
}

See Also

ILibrary Interface
Mincom.LinkOne.Dom Namespace


INotifyChanged Interface

[image]

LinkOne WebView API
INotifyChanged Interface
Members See Also Send Feedback
Notifies clients that the object has changed.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface INotifyChanged
Visual Basic (Declaration)
Public Interface INotifyChanged
Visual C++
public interface class INotifyChanged

See Also

INotifyChanged Members
Mincom.LinkOne.Dom Namespace


INotifyChanged Members

[image] [image]

LinkOne WebView API
INotifyChanged Members
INotifyChanged Interface Events See Also Send Feedback

The INotifyChanged type exposes the following members.

Events

Name | Description
Changed | Occurs when a property value changes.

See Also

INotifyChanged Interface
Mincom.LinkOne.Dom Namespace


INotifyChanged Events

[image] [image]

LinkOne WebView API
INotifyChanged Events
INotifyChanged Interface See Also Send Feedback

The INotifyChanged type exposes the following members.

Events

Name | Description
Changed | Occurs when a property value changes.

See Also

INotifyChanged Interface
Mincom.LinkOne.Dom Namespace


Changed Event

[image]

LinkOne WebView API
INotifyChanged..::.Changed Event
INotifyChanged Interface See Also Send Feedback
Occurs when a property value changes.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
event EventHandler Changed
Visual Basic (Declaration)
Event Changed As EventHandler
Visual C++
 event EventHandler^ Changed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

INotifyChanged Interface
Mincom.LinkOne.Dom Namespace


IPage Interface

[image]

LinkOne WebView API
IPage Interface
Members See Also Send Feedback
Represents a page in a LinkOne book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IPage : IFilterable
Visual Basic (Declaration)
Public Interface IPage _
    Implements IFilterable
Visual C++
public interface class IPage : IFilterable

See Also

IPage Members
Mincom.LinkOne.Dom Namespace


IPage Members

[image] [image]

LinkOne WebView API
IPage Members
IPage Interface Methods Properties See Also Send Feedback

The IPage type exposes the following members.

Methods

Name | Description
GetField | Returns the value of the wanted field.

Properties

Name | Description
Attributes | Gets the attributes associated with this page.
Book | Gets the book that owns the page.
ChildPages | Gets the child pages of the page.
DataObject | Gets the data object associated with this page.
Entries | Gets the entries associated with this page.
Fields | Gets the publisher defined fields associated with this page.
GroupId | Gets the group id of the page.
Notes | Gets the notes visible to the page, book, publisher and library.
Number | Gets the page number.
Options | Gets the options associated with this object. (Inherited from IFilterable.)
ParentPages | Gets the parent pages of the page.
Pictures | Gets the pictures associated with this page.
Reference | Gets the page reference.
Title | Gets the page title.
Type | Gets the page type.
Values | Gets the values visible to the page, book, publisher and library.

See Also

IPage Interface
Mincom.LinkOne.Dom Namespace


IPage Methods

[image] [image]

LinkOne WebView API
IPage Methods
IPage Interface See Also Send Feedback

The IPage type exposes the following members.

Methods

Name | Description
GetField | Returns the value of the wanted field.

See Also

IPage Interface
Mincom.LinkOne.Dom Namespace


GetField Method

[image]

LinkOne WebView API
IPage..::.GetField Method
IPage Interface See Also Send Feedback
Returns the value of the wanted field.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string GetField(
    string name
)
Visual Basic (Declaration)
Function GetField ( _
    name As String _
) As String
Visual C++
String^ GetField(
    String^ name
)

Parameters

name
Type: System..::.String
Name of the wanted field.

Return Value

The value of the wanted field, or blank if not found.

See Also

IPage Interface
Mincom.LinkOne.Dom Namespace


IPage Properties

[image] [image]

LinkOne WebView API
IPage Properties
IPage Interface See Also Send Feedback

The IPage type exposes the following members.

Properties

Name | Description
Attributes | Gets the attributes associated with this page.
Book | Gets the book that owns the page.
ChildPages | Gets the child pages of the page.
DataObject | Gets the data object associated with this page.
Entries | Gets the entries associated with this page.
Fields | Gets the publisher defined fields associated with this page.
GroupId | Gets the group id of the page.
Notes | Gets the notes visible to the page, book, publisher and library.
Number | Gets the page number.
Options | Gets the options associated with this object. (Inherited from IFilterable.)
ParentPages | Gets the parent pages of the page.
Pictures | Gets the pictures associated with this page.
Reference | Gets the page reference.
Title | Gets the page title.
Type | Gets the page type.
Values | Gets the values visible to the page, book, publisher and library.

See Also

IPage Interface
Mincom.LinkOne.Dom Namespace


Attributes Property

[image]

LinkOne WebView API
IPage..::.Attributes Property
IPage Interface See Also Send Feedback
Gets the attributes associated with this page.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IAttributeCollection Attributes { get; }
Visual Basic (Declaration)
ReadOnly Property Attributes As IAttributeCollection
Visual C++
property IAttributeCollection^ Attributes {
    IAttributeCollection^ get ();
}

See Also

IPage Interface
Mincom.LinkOne.Dom Namespace


Book Property

[image]

LinkOne WebView API
IPage..::.Book Property
IPage Interface See Also Send Feedback
Gets the book that owns the page.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IBook Book { get; }
Visual Basic (Declaration)
ReadOnly Property Book As IBook
Visual C++
property IBook^ Book {
    IBook^ get ();
}

See Also

IPage Interface
Mincom.LinkOne.Dom Namespace


ChildPages Property

[image]

LinkOne WebView API
IPage..::.ChildPages Property
IPage Interface See Also Send Feedback
Gets the child pages of the page.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPageCollection ChildPages { get; }
Visual Basic (Declaration)
ReadOnly Property ChildPages As IPageCollection
Visual C++
property IPageCollection^ ChildPages {
    IPageCollection^ get ();
}

See Also

IPage Interface
Mincom.LinkOne.Dom Namespace


DataObject Property

[image]

LinkOne WebView API
IPage..::.DataObject Property
IPage Interface See Also Send Feedback
Gets the data object associated with this page.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDataObject DataObject { get; }
Visual Basic (Declaration)
ReadOnly Property DataObject As IDataObject
Visual C++
property IDataObject^ DataObject {
    IDataObject^ get ();
}

See Also

IPage Interface
Mincom.LinkOne.Dom Namespace


Entries Property

[image]

LinkOne WebView API
IPage..::.Entries Property
IPage Interface See Also Send Feedback
Gets the entries associated with this page.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEntryCollection Entries { get; }
Visual Basic (Declaration)
ReadOnly Property Entries As IEntryCollection
Visual C++
property IEntryCollection^ Entries {
    IEntryCollection^ get ();
}

See Also

IPage Interface
Mincom.LinkOne.Dom Namespace


Fields Property

[image]

LinkOne WebView API
IPage..::.Fields Property
IPage Interface See Also Send Feedback
Gets the publisher defined fields associated with this page.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IFieldCollection Fields { get; }
Visual Basic (Declaration)
ReadOnly Property Fields As IFieldCollection
Visual C++
property IFieldCollection^ Fields {
    IFieldCollection^ get ();
}

See Also

IPage Interface
Mincom.LinkOne.Dom Namespace


GroupId Property

[image]

LinkOne WebView API
IPage..::.GroupId Property
IPage Interface See Also Send Feedback
Gets the group id of the page.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string GroupId { get; }
Visual Basic (Declaration)
ReadOnly Property GroupId As String
Visual C++
property String^ GroupId {
    String^ get ();
}

See Also

IPage Interface
Mincom.LinkOne.Dom Namespace


Notes Property

[image]

LinkOne WebView API
IPage..::.Notes Property
IPage Interface See Also Send Feedback
Gets the notes visible to the page, book, publisher and library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
INoteCollection Notes { get; }
Visual Basic (Declaration)
ReadOnly Property Notes As INoteCollection
Visual C++
property INoteCollection^ Notes {
    INoteCollection^ get ();
}

Field Value

The notes.

See Also

IPage Interface
Mincom.LinkOne.Dom Namespace


Number Property

[image]

LinkOne WebView API
IPage..::.Number Property
IPage Interface See Also Send Feedback
Gets the page number.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Number { get; }
Visual Basic (Declaration)
ReadOnly Property Number As String
Visual C++
property String^ Number {
    String^ get ();
}

See Also

IPage Interface
Mincom.LinkOne.Dom Namespace


ParentPages Property

[image]

LinkOne WebView API
IPage..::.ParentPages Property
IPage Interface See Also Send Feedback
Gets the parent pages of the page.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPageCollection ParentPages { get; }
Visual Basic (Declaration)
ReadOnly Property ParentPages As IPageCollection
Visual C++
property IPageCollection^ ParentPages {
    IPageCollection^ get ();
}

See Also

IPage Interface
Mincom.LinkOne.Dom Namespace


Pictures Property

[image]

LinkOne WebView API
IPage..::.Pictures Property
IPage Interface See Also Send Feedback
Gets the pictures associated with this page.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPictureCollection Pictures { get; }
Visual Basic (Declaration)
ReadOnly Property Pictures As IPictureCollection
Visual C++
property IPictureCollection^ Pictures {
    IPictureCollection^ get ();
}

See Also

IPage Interface
Mincom.LinkOne.Dom Namespace


Reference Property

[image]

LinkOne WebView API
IPage..::.Reference Property
IPage Interface See Also Send Feedback
Gets the page reference.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Reference { get; }
Visual Basic (Declaration)
ReadOnly Property Reference As String
Visual C++
property String^ Reference {
    String^ get ();
}

Field Value

The reference.

See Also

IPage Interface
Mincom.LinkOne.Dom Namespace


Title Property

[image]

LinkOne WebView API
IPage..::.Title Property
IPage Interface See Also Send Feedback
Gets the page title.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Title { get; }
Visual Basic (Declaration)
ReadOnly Property Title As String
Visual C++
property String^ Title {
    String^ get ();
}

See Also

IPage Interface
Mincom.LinkOne.Dom Namespace


Type Property

[image]

LinkOne WebView API
IPage..::.Type Property
IPage Interface See Also Send Feedback
Gets the page type.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
PageType Type { get; }
Visual Basic (Declaration)
ReadOnly Property Type As PageType
Visual C++
property PageType Type {
    PageType get ();
}

See Also

IPage Interface
Mincom.LinkOne.Dom Namespace


Values Property

[image]

LinkOne WebView API
IPage..::.Values Property
IPage Interface See Also Send Feedback
Gets the values visible to the page, book, publisher and library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IValueCollection Values { get; }
Visual Basic (Declaration)
ReadOnly Property Values As IValueCollection
Visual C++
property IValueCollection^ Values {
    IValueCollection^ get ();
}

See Also

IPage Interface
Mincom.LinkOne.Dom Namespace


IPageCollection Interface

[image]

LinkOne WebView API
IPageCollection Interface
Members See Also Send Feedback
Represents a collection of pages that can be individually accessed by either index, or key, Reference.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IPageCollection : IReadOnlyKeyedCollection<string, IPage>,
    IReadOnlyList<IPage>, IReadOnlyCollection<IPage>, IEnumerable<IPage>,
    IEnumerable
Visual Basic (Declaration)
Public Interface IPageCollection _
    Implements IReadOnlyKeyedCollection(Of String, IPage),  _
    IReadOnlyList(Of IPage), IReadOnlyCollection(Of IPage), IEnumerable(Of IPage),  _
    IEnumerable
Visual C++
public interface class IPageCollection : IReadOnlyKeyedCollection<String^, IPage^>,
    IReadOnlyList<IPage^>, IReadOnlyCollection<IPage^>, IEnumerable<IPage^>,
    IEnumerable

See Also

IPageCollection Members
Mincom.LinkOne.Dom Namespace


IPageCollection Members

[image] [image]

LinkOne WebView API
IPageCollection Members
IPageCollection Interface Methods Properties See Also Send Feedback

The IPageCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
GetEnumerator | Overloaded.
IndexOf | Searches the collection and returns the zero-based index of the first occurrence of the given item. (Inherited from IReadOnlyList<(Of <(T>)>).)

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Overloaded.

See Also

IPageCollection Interface
Mincom.LinkOne.Dom Namespace


IPageCollection Methods

[image] [image]

LinkOne WebView API
IPageCollection Methods
IPageCollection Interface See Also Send Feedback

The IPageCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
GetEnumerator | Overloaded.
IndexOf | Searches the collection and returns the zero-based index of the first occurrence of the given item. (Inherited from IReadOnlyList<(Of <(T>)>).)

See Also

IPageCollection Interface
Mincom.LinkOne.Dom Namespace


Contains Method

[image] [image]

LinkOne WebView API
IPageCollection..::.Contains Method
IPageCollection Interface See Also Send Feedback

Overload List

Name | Description
Contains(T) | Determines whether an element is in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Contains(TKey) | Determines whether an element with the given key is in the collection. (Inherited from IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>).)

See Also

IPageCollection Interface
IPageCollection Members
Mincom.LinkOne.Dom Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
IPageCollection..::.GetEnumerator Method
IPageCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( IPage >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IPageCollection Interface
IPageCollection Members
Mincom.LinkOne.Dom Namespace


IPageCollection Properties

[image] [image]

LinkOne WebView API
IPageCollection Properties
IPageCollection Interface See Also Send Feedback

The IPageCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Overloaded.

See Also

IPageCollection Interface
Mincom.LinkOne.Dom Namespace


Item Property

[image] [image]

LinkOne WebView API
IPageCollection..::.Item Property
IPageCollection Interface See Also Send Feedback

Overload List

Name | Description
Item[([(TKey])]) | Gets the item with the specified key. (Inherited from IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>).)
Item[([(Int32])]) | Gets the item at the specified index. (Inherited from IReadOnlyList<(Of <(T>)>).)

See Also

IPageCollection Interface
IPageCollection Members
Mincom.LinkOne.Dom Namespace


IPersist Interface

[image]

LinkOne WebView API
IPersist Interface
See Also Send Feedback
Implemented by classes that have state to persist between sessions.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IPersist
Visual Basic (Declaration)
Public Interface IPersist
Visual C++
public interface class IPersist

See Also

Mincom.LinkOne.Dom Namespace


IPersistIdentity Interface

[image]

LinkOne WebView API
IPersistIdentity Interface
Members See Also Send Feedback
Identifies the wanted item during an IPersistProver.Read() call.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IPersistIdentity
Visual Basic (Declaration)
Public Interface IPersistIdentity
Visual C++
public interface class IPersistIdentity

See Also

IPersistIdentity Members
Mincom.LinkOne.Dom Namespace


IPersistIdentity Members

[image] [image]

LinkOne WebView API
IPersistIdentity Members
IPersistIdentity Interface Properties See Also Send Feedback

The IPersistIdentity type exposes the following members.

Properties

Name | Description
BookCode | Gets the book code.
FieldName | Gets the field name.
FieldType | Gets the field type.
Filters | Gets the filters to apply.
ItemId | Gets the note item id.
Location | Gets the location.
MasterBookCode | Gets the master book code.
NoteAccess | Gets the note access;
NoteId | Gets the note Id.
PageReference | Gets the page reference.
PictureNumber | Gets the note picture number.
PictureReference | Gets the picture reference.
Principal | Gets the principal.
PublisherCode | Gets the publisher code.
ResourceReference | Gets the resource reference.
Type | Gets the type of the persist object.

See Also

IPersistIdentity Interface
Mincom.LinkOne.Dom Namespace


IPersistIdentity Properties

[image] [image]

LinkOne WebView API
IPersistIdentity Properties
IPersistIdentity Interface See Also Send Feedback

The IPersistIdentity type exposes the following members.

Properties

Name | Description
BookCode | Gets the book code.
FieldName | Gets the field name.
FieldType | Gets the field type.
Filters | Gets the filters to apply.
ItemId | Gets the note item id.
Location | Gets the location.
MasterBookCode | Gets the master book code.
NoteAccess | Gets the note access;
NoteId | Gets the note Id.
PageReference | Gets the page reference.
PictureNumber | Gets the note picture number.
PictureReference | Gets the picture reference.
Principal | Gets the principal.
PublisherCode | Gets the publisher code.
ResourceReference | Gets the resource reference.
Type | Gets the type of the persist object.

See Also

IPersistIdentity Interface
Mincom.LinkOne.Dom Namespace


BookCode Property

[image]

LinkOne WebView API
IPersistIdentity..::.BookCode Property
IPersistIdentity Interface See Also Send Feedback
Gets the book code.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string BookCode { get; }
Visual Basic (Declaration)
ReadOnly Property BookCode As String
Visual C++
property String^ BookCode {
    String^ get ();
}

See Also

IPersistIdentity Interface
Mincom.LinkOne.Dom Namespace


FieldName Property

[image]

LinkOne WebView API
IPersistIdentity..::.FieldName Property
IPersistIdentity Interface See Also Send Feedback
Gets the field name.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string FieldName { get; }
Visual Basic (Declaration)
ReadOnly Property FieldName As String
Visual C++
property String^ FieldName {
    String^ get ();
}

See Also

IPersistIdentity Interface
Mincom.LinkOne.Dom Namespace


FieldType Property

[image]

LinkOne WebView API
IPersistIdentity..::.FieldType Property
IPersistIdentity Interface See Also Send Feedback
Gets the field type.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
SearchFieldType FieldType { get; }
Visual Basic (Declaration)
ReadOnly Property FieldType As SearchFieldType
Visual C++
property SearchFieldType FieldType {
    SearchFieldType get ();
}

See Also

IPersistIdentity Interface
Mincom.LinkOne.Dom Namespace


Filters Property

[image]

LinkOne WebView API
IPersistIdentity..::.Filters Property
IPersistIdentity Interface See Also Send Feedback
Gets the filters to apply.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IFilterCollection Filters { get; }
Visual Basic (Declaration)
ReadOnly Property Filters As IFilterCollection
Visual C++
property IFilterCollection^ Filters {
    IFilterCollection^ get ();
}

See Also

IPersistIdentity Interface
Mincom.LinkOne.Dom Namespace


ItemId Property

[image]

LinkOne WebView API
IPersistIdentity..::.ItemId Property
IPersistIdentity Interface See Also Send Feedback
Gets the note item id.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string ItemId { get; }
Visual Basic (Declaration)
ReadOnly Property ItemId As String
Visual C++
property String^ ItemId {
    String^ get ();
}

See Also

IPersistIdentity Interface
Mincom.LinkOne.Dom Namespace


Location Property

[image]

LinkOne WebView API
IPersistIdentity..::.Location Property
IPersistIdentity Interface See Also Send Feedback
Gets the location.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Location { get; }
Visual Basic (Declaration)
ReadOnly Property Location As String
Visual C++
property String^ Location {
    String^ get ();
}

See Also

IPersistIdentity Interface
Mincom.LinkOne.Dom Namespace


MasterBookCode Property

[image]

LinkOne WebView API
IPersistIdentity..::.MasterBookCode Property
IPersistIdentity Interface See Also Send Feedback
Gets the master book code.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string MasterBookCode { get; }
Visual Basic (Declaration)
ReadOnly Property MasterBookCode As String
Visual C++
property String^ MasterBookCode {
    String^ get ();
}

See Also

IPersistIdentity Interface
Mincom.LinkOne.Dom Namespace


NoteAccess Property

[image]

LinkOne WebView API
IPersistIdentity..::.NoteAccess Property
IPersistIdentity Interface See Also Send Feedback
Gets the note access;

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
Access NoteAccess { get; }
Visual Basic (Declaration)
ReadOnly Property NoteAccess As Access
Visual C++
property Access NoteAccess {
    Access get ();
}

See Also

IPersistIdentity Interface
Mincom.LinkOne.Dom Namespace


NoteId Property

[image]

LinkOne WebView API
IPersistIdentity..::.NoteId Property
IPersistIdentity Interface See Also Send Feedback
Gets the note Id.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int NoteId { get; }
Visual Basic (Declaration)
ReadOnly Property NoteId As Integer
Visual C++
property int NoteId {
    int get ();
}

See Also

IPersistIdentity Interface
Mincom.LinkOne.Dom Namespace


PageReference Property

[image]

LinkOne WebView API
IPersistIdentity..::.PageReference Property
IPersistIdentity Interface See Also Send Feedback
Gets the page reference.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string PageReference { get; }
Visual Basic (Declaration)
ReadOnly Property PageReference As String
Visual C++
property String^ PageReference {
    String^ get ();
}

See Also

IPersistIdentity Interface
Mincom.LinkOne.Dom Namespace


PictureNumber Property

[image]

LinkOne WebView API
IPersistIdentity..::.PictureNumber Property
IPersistIdentity Interface See Also Send Feedback
Gets the note picture number.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int PictureNumber { get; }
Visual Basic (Declaration)
ReadOnly Property PictureNumber As Integer
Visual C++
property int PictureNumber {
    int get ();
}

See Also

IPersistIdentity Interface
Mincom.LinkOne.Dom Namespace


PictureReference Property

[image]

LinkOne WebView API
IPersistIdentity..::.PictureReference Property
IPersistIdentity Interface See Also Send Feedback
Gets the picture reference.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string PictureReference { get; }
Visual Basic (Declaration)
ReadOnly Property PictureReference As String
Visual C++
property String^ PictureReference {
    String^ get ();
}

See Also

IPersistIdentity Interface
Mincom.LinkOne.Dom Namespace


Principal Property

[image]

LinkOne WebView API
IPersistIdentity..::.Principal Property
IPersistIdentity Interface See Also Send Feedback
Gets the principal.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPrincipal Principal { get; }
Visual Basic (Declaration)
ReadOnly Property Principal As IPrincipal
Visual C++
property IPrincipal^ Principal {
    IPrincipal^ get ();
}

See Also

IPersistIdentity Interface
Mincom.LinkOne.Dom Namespace


PublisherCode Property

[image]

LinkOne WebView API
IPersistIdentity..::.PublisherCode Property
IPersistIdentity Interface See Also Send Feedback
Gets the publisher code.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string PublisherCode { get; }
Visual Basic (Declaration)
ReadOnly Property PublisherCode As String
Visual C++
property String^ PublisherCode {
    String^ get ();
}

See Also

IPersistIdentity Interface
Mincom.LinkOne.Dom Namespace


ResourceReference Property

[image]

LinkOne WebView API
IPersistIdentity..::.ResourceReference Property
IPersistIdentity Interface See Also Send Feedback
Gets the resource reference.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string ResourceReference { get; }
Visual Basic (Declaration)
ReadOnly Property ResourceReference As String
Visual C++
property String^ ResourceReference {
    String^ get ();
}

See Also

IPersistIdentity Interface
Mincom.LinkOne.Dom Namespace


Type Property

[image]

LinkOne WebView API
IPersistIdentity..::.Type Property
IPersistIdentity Interface See Also Send Feedback
Gets the type of the persist object.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
Type Type { get; }
Visual Basic (Declaration)
ReadOnly Property Type As Type
Visual C++
property Type^ Type {
    Type^ get ();
}

See Also

IPersistIdentity Interface
Mincom.LinkOne.Dom Namespace


IPersistProvider Interface

[image]

LinkOne WebView API
IPersistProvider Interface
Members See Also Send Feedback
Implemented by classes that provide object persistance.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IPersistProvider
Visual Basic (Declaration)
Public Interface IPersistProvider
Visual C++
public interface class IPersistProvider

See Also

IPersistProvider Members
Mincom.LinkOne.Dom Namespace


IPersistProvider Members

[image] [image]

LinkOne WebView API
IPersistProvider Members
IPersistProvider Interface Methods See Also Send Feedback

The IPersistProvider type exposes the following members.

Methods

Name | Description
Read | Read the wanted object from storage.
ReadIgnoreLangOption |
Refresh | Refresh the wanted object into storage.
Write | Write the given object to storage.

See Also

IPersistProvider Interface
Mincom.LinkOne.Dom Namespace


IPersistProvider Methods

[image] [image]

LinkOne WebView API
IPersistProvider Methods
IPersistProvider Interface See Also Send Feedback

The IPersistProvider type exposes the following members.

Methods

Name | Description
Read | Read the wanted object from storage.
ReadIgnoreLangOption |
Refresh | Refresh the wanted object into storage.
Write | Write the given object to storage.

See Also

IPersistProvider Interface
Mincom.LinkOne.Dom Namespace


Read Method

[image]

LinkOne WebView API
IPersistProvider..::.Read Method
IPersistProvider Interface See Also Send Feedback
Read the wanted object from storage.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPersist Read(
    IPersistIdentity identity
)
Visual Basic (Declaration)
Function Read ( _
    identity As IPersistIdentity _
) As IPersist
Visual C++
IPersist^ Read(
    IPersistIdentity^ identity
)

Parameters

identity
Type: Mincom.LinkOne.Dom..::.IPersistIdentity
Identifies the object to read.

Return Value

The wanted object identified by identity.

See Also

IPersistProvider Interface
Mincom.LinkOne.Dom Namespace


ReadIgnoreLangOption Method

[image]

LinkOne WebView API
IPersistProvider..::.ReadIgnoreLangOption Method
IPersistProvider Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPersist ReadIgnoreLangOption(
    IPersistIdentity identity
)
Visual Basic (Declaration)
Function ReadIgnoreLangOption ( _
    identity As IPersistIdentity _
) As IPersist
Visual C++
IPersist^ ReadIgnoreLangOption(
    IPersistIdentity^ identity
)

Parameters

identity
Type: Mincom.LinkOne.Dom..::.IPersistIdentity

See Also

IPersistProvider Interface
Mincom.LinkOne.Dom Namespace


Refresh Method

[image]

LinkOne WebView API
IPersistProvider..::.Refresh Method
IPersistProvider Interface See Also Send Feedback
Refresh the wanted object into storage.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPersist Refresh(
    IPersistIdentity identity
)
Visual Basic (Declaration)
Function Refresh ( _
    identity As IPersistIdentity _
) As IPersist
Visual C++
IPersist^ Refresh(
    IPersistIdentity^ identity
)

Parameters

identity
Type: Mincom.LinkOne.Dom..::.IPersistIdentity
Identifies the object to read.

Return Value

The wanted object identified by identity.

See Also

IPersistProvider Interface
Mincom.LinkOne.Dom Namespace


Write Method

[image]

LinkOne WebView API
IPersistProvider..::.Write Method
IPersistProvider Interface See Also Send Feedback
Write the given object to storage.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPersist Write(
    IPrincipal principal,
    IPersist element
)
Visual Basic (Declaration)
Function Write ( _
    principal As IPrincipal, _
    element As IPersist _
) As IPersist
Visual C++
IPersist^ Write(
    IPrincipal^ principal,
    IPersist^ element
)

Parameters

principal
Type: Mincom.LinkOne.Dom..::.IPrincipal
The owner of the object.
element
Type: Mincom.LinkOne.Dom..::.IPersist
The object to persist.

Return Value

The object, possibly changed during the write, or possibly null. This depends on the object being written.

See Also

IPersistProvider Interface
Mincom.LinkOne.Dom Namespace


IPicture Interface

[image]

LinkOne WebView API
IPicture Interface
Members See Also Send Feedback
A picture on a LinkOne page.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IPicture : IFilterable
Visual Basic (Declaration)
Public Interface IPicture _
    Implements IFilterable
Visual C++
public interface class IPicture : IFilterable

See Also

IPicture Members
Mincom.LinkOne.Dom Namespace


IPicture Members

[image] [image]

LinkOne WebView API
IPicture Members
IPicture Interface Methods Properties See Also Send Feedback

The IPicture type exposes the following members.

Methods

Name | Description
GetField | Returns the value of the wanted field.

Properties

Name | Description
Data | Gets the raw data for the image, whithout overlays applied
Fields | Gets the publisher defined fields associated with the picture.
Height | Gets the original height of the picture.
Image | Gets the image.
IsRaster | Gets a value indicating whether the picture is a raster.
IsVector | Gets a value indicating whether the picture is a vector.
MimeType | Gets the MIME type of the picture.
Number | Gets the picture number.
Options | Gets the options associated with this object. (Inherited from IFilterable.)
Page | Gets the page for the picture.
PictureHeight | Gets the physical height of the picture.
PictureLeft | Gets the left offset of the physical picture within the original picture area.
PictureTop | Gets the top offset of the physical picture within the original picture area.
PictureWidth | Gets the physical width of the picture.
Scale | Gets the picture defalt scale.
Title | Gets the picture title.
Values | Gets the values visible to the picture.
Width | Gets the original width of the picture.

See Also

IPicture Interface
Mincom.LinkOne.Dom Namespace


IPicture Methods

[image] [image]

LinkOne WebView API
IPicture Methods
IPicture Interface See Also Send Feedback

The IPicture type exposes the following members.

Methods

Name | Description
GetField | Returns the value of the wanted field.

See Also

IPicture Interface
Mincom.LinkOne.Dom Namespace


GetField Method

[image]

LinkOne WebView API
IPicture..::.GetField Method
IPicture Interface See Also Send Feedback
Returns the value of the wanted field.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string GetField(
    string name
)
Visual Basic (Declaration)
Function GetField ( _
    name As String _
) As String
Visual C++
String^ GetField(
    String^ name
)

Parameters

name
Type: System..::.String
Name of the wanted field.

Return Value

The value of the wanted field, or blank if not found..

See Also

IPicture Interface
Mincom.LinkOne.Dom Namespace


IPicture Properties

[image] [image]

LinkOne WebView API
IPicture Properties
IPicture Interface See Also Send Feedback

The IPicture type exposes the following members.

Properties

Name | Description
Data | Gets the raw data for the image, whithout overlays applied
Fields | Gets the publisher defined fields associated with the picture.
Height | Gets the original height of the picture.
Image | Gets the image.
IsRaster | Gets a value indicating whether the picture is a raster.
IsVector | Gets a value indicating whether the picture is a vector.
MimeType | Gets the MIME type of the picture.
Number | Gets the picture number.
Options | Gets the options associated with this object. (Inherited from IFilterable.)
Page | Gets the page for the picture.
PictureHeight | Gets the physical height of the picture.
PictureLeft | Gets the left offset of the physical picture within the original picture area.
PictureTop | Gets the top offset of the physical picture within the original picture area.
PictureWidth | Gets the physical width of the picture.
Scale | Gets the picture defalt scale.
Title | Gets the picture title.
Values | Gets the values visible to the picture.
Width | Gets the original width of the picture.

See Also

IPicture Interface
Mincom.LinkOne.Dom Namespace


Data Property

[image]

LinkOne WebView API
IPicture..::.Data Property
IPicture Interface See Also Send Feedback
Gets the raw data for the image, whithout overlays applied

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
byte[] Data { get; }
Visual Basic (Declaration)
ReadOnly Property Data As Byte()
Visual C++
property array<unsigned char>^ Data {
    array<unsigned char>^ get ();
}

See Also

IPicture Interface
Mincom.LinkOne.Dom Namespace


Fields Property

[image]

LinkOne WebView API
IPicture..::.Fields Property
IPicture Interface See Also Send Feedback
Gets the publisher defined fields associated with the picture.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IFieldCollection Fields { get; }
Visual Basic (Declaration)
ReadOnly Property Fields As IFieldCollection
Visual C++
property IFieldCollection^ Fields {
    IFieldCollection^ get ();
}

See Also

IPicture Interface
Mincom.LinkOne.Dom Namespace


Height Property

[image]

LinkOne WebView API
IPicture..::.Height Property
IPicture Interface See Also Send Feedback
Gets the original height of the picture.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int Height { get; }
Visual Basic (Declaration)
ReadOnly Property Height As Integer
Visual C++
property int Height {
    int get ();
}

See Also

IPicture Interface
Mincom.LinkOne.Dom Namespace


Image Property

[image]

LinkOne WebView API
IPicture..::.Image Property
IPicture Interface See Also Send Feedback
Gets the image.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
Image Image { get; }
Visual Basic (Declaration)
ReadOnly Property Image As Image
Visual C++
property Image^ Image {
    Image^ get ();
}

See Also

IPicture Interface
Mincom.LinkOne.Dom Namespace


IsRaster Property

[image]

LinkOne WebView API
IPicture..::.IsRaster Property
IPicture Interface See Also Send Feedback
Gets a value indicating whether the picture is a raster.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IsRaster { get; }
Visual Basic (Declaration)
ReadOnly Property IsRaster As Boolean
Visual C++
property bool IsRaster {
    bool get ();
}

See Also

IPicture Interface
Mincom.LinkOne.Dom Namespace


IsVector Property

[image]

LinkOne WebView API
IPicture..::.IsVector Property
IPicture Interface See Also Send Feedback
Gets a value indicating whether the picture is a vector.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IsVector { get; }
Visual Basic (Declaration)
ReadOnly Property IsVector As Boolean
Visual C++
property bool IsVector {
    bool get ();
}

See Also

IPicture Interface
Mincom.LinkOne.Dom Namespace


MimeType Property

[image]

LinkOne WebView API
IPicture..::.MimeType Property
IPicture Interface See Also Send Feedback
Gets the MIME type of the picture.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string MimeType { get; }
Visual Basic (Declaration)
ReadOnly Property MimeType As String
Visual C++
property String^ MimeType {
    String^ get ();
}

See Also

IPicture Interface
Mincom.LinkOne.Dom Namespace


Number Property

[image]

LinkOne WebView API
IPicture..::.Number Property
IPicture Interface See Also Send Feedback
Gets the picture number.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int Number { get; }
Visual Basic (Declaration)
ReadOnly Property Number As Integer
Visual C++
property int Number {
    int get ();
}

See Also

IPicture Interface
Mincom.LinkOne.Dom Namespace


Page Property

[image]

LinkOne WebView API
IPicture..::.Page Property
IPicture Interface See Also Send Feedback
Gets the page for the picture.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPage Page { get; }
Visual Basic (Declaration)
ReadOnly Property Page As IPage
Visual C++
property IPage^ Page {
    IPage^ get ();
}

See Also

IPicture Interface
Mincom.LinkOne.Dom Namespace


PictureHeight Property

[image]

LinkOne WebView API
IPicture..::.PictureHeight Property
IPicture Interface See Also Send Feedback
Gets the physical height of the picture.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int PictureHeight { get; }
Visual Basic (Declaration)
ReadOnly Property PictureHeight As Integer
Visual C++
property int PictureHeight {
    int get ();
}

See Also

IPicture Interface
Mincom.LinkOne.Dom Namespace


PictureLeft Property

[image]

LinkOne WebView API
IPicture..::.PictureLeft Property
IPicture Interface See Also Send Feedback
Gets the left offset of the physical picture within the original picture area.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int PictureLeft { get; }
Visual Basic (Declaration)
ReadOnly Property PictureLeft As Integer
Visual C++
property int PictureLeft {
    int get ();
}

See Also

IPicture Interface
Mincom.LinkOne.Dom Namespace


PictureTop Property

[image]

LinkOne WebView API
IPicture..::.PictureTop Property
IPicture Interface See Also Send Feedback
Gets the top offset of the physical picture within the original picture area.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int PictureTop { get; }
Visual Basic (Declaration)
ReadOnly Property PictureTop As Integer
Visual C++
property int PictureTop {
    int get ();
}

See Also

IPicture Interface
Mincom.LinkOne.Dom Namespace


PictureWidth Property

[image]

LinkOne WebView API
IPicture..::.PictureWidth Property
IPicture Interface See Also Send Feedback
Gets the physical width of the picture.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int PictureWidth { get; }
Visual Basic (Declaration)
ReadOnly Property PictureWidth As Integer
Visual C++
property int PictureWidth {
    int get ();
}

See Also

IPicture Interface
Mincom.LinkOne.Dom Namespace


Scale Property

[image]

LinkOne WebView API
IPicture..::.Scale Property
IPicture Interface See Also Send Feedback
Gets the picture defalt scale.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
double Scale { get; }
Visual Basic (Declaration)
ReadOnly Property Scale As Double
Visual C++
property double Scale {
    double get ();
}

Remarks

The pictures default scale runs from 0.125 to 800.000 in increments of 0.125 with fit to screen equal to 0.

See Also

IPicture Interface
Mincom.LinkOne.Dom Namespace


Title Property

[image]

LinkOne WebView API
IPicture..::.Title Property
IPicture Interface See Also Send Feedback
Gets the picture title.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Title { get; }
Visual Basic (Declaration)
ReadOnly Property Title As String
Visual C++
property String^ Title {
    String^ get ();
}

See Also

IPicture Interface
Mincom.LinkOne.Dom Namespace


Values Property

[image]

LinkOne WebView API
IPicture..::.Values Property
IPicture Interface See Also Send Feedback
Gets the values visible to the picture.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IValueCollection Values { get; }
Visual Basic (Declaration)
ReadOnly Property Values As IValueCollection
Visual C++
property IValueCollection^ Values {
    IValueCollection^ get ();
}

See Also

IPicture Interface
Mincom.LinkOne.Dom Namespace


Width Property

[image]

LinkOne WebView API
IPicture..::.Width Property
IPicture Interface See Also Send Feedback
Gets the original width of the picture.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int Width { get; }
Visual Basic (Declaration)
ReadOnly Property Width As Integer
Visual C++
property int Width {
    int get ();
}

See Also

IPicture Interface
Mincom.LinkOne.Dom Namespace


IPictureCollection Interface

[image]

LinkOne WebView API
IPictureCollection Interface
Members See Also Send Feedback
Represents a collection of pictures that can be individually accessed by index.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IPictureCollection : IReadOnlyList<IPicture>,
    IReadOnlyCollection<IPicture>, IEnumerable<IPicture>, IEnumerable
Visual Basic (Declaration)
Public Interface IPictureCollection _
    Implements IReadOnlyList(Of IPicture), IReadOnlyCollection(Of IPicture),  _
    IEnumerable(Of IPicture), IEnumerable
Visual C++
public interface class IPictureCollection : IReadOnlyList<IPicture^>,
    IReadOnlyCollection<IPicture^>, IEnumerable<IPicture^>, IEnumerable

See Also

IPictureCollection Members
Mincom.LinkOne.Dom Namespace


IPictureCollection Members

[image] [image]

LinkOne WebView API
IPictureCollection Members
IPictureCollection Interface Methods Properties See Also Send Feedback

The IPictureCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
GetEnumerator | Overloaded.
IndexOf | Searches the collection and returns the zero-based index of the first occurrence of the given item. (Inherited from IReadOnlyList<(Of <(T>)>).)

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from IReadOnlyList<(Of <(T>)>).)

See Also

IPictureCollection Interface
Mincom.LinkOne.Dom Namespace


IPictureCollection Methods

[image] [image]

LinkOne WebView API
IPictureCollection Methods
IPictureCollection Interface See Also Send Feedback

The IPictureCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
GetEnumerator | Overloaded.
IndexOf | Searches the collection and returns the zero-based index of the first occurrence of the given item. (Inherited from IReadOnlyList<(Of <(T>)>).)

See Also

IPictureCollection Interface
Mincom.LinkOne.Dom Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
IPictureCollection..::.GetEnumerator Method
IPictureCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( IPicture >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IPictureCollection Interface
IPictureCollection Members
Mincom.LinkOne.Dom Namespace


IPictureCollection Properties

[image] [image]

LinkOne WebView API
IPictureCollection Properties
IPictureCollection Interface See Also Send Feedback

The IPictureCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from IReadOnlyList<(Of <(T>)>).)

See Also

IPictureCollection Interface
Mincom.LinkOne.Dom Namespace


IPrincipal Interface

[image]

LinkOne WebView API
IPrincipal Interface
Members See Also Send Feedback
Implemented by classes that identify a user.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IPrincipal
Visual Basic (Declaration)
Public Interface IPrincipal
Visual C++
public interface class IPrincipal

See Also

IPrincipal Members
Mincom.LinkOne.Dom Namespace


IPrincipal Members

[image] [image]

LinkOne WebView API
IPrincipal Members
IPrincipal Interface Methods Properties See Also Send Feedback

The IPrincipal type exposes the following members.

Methods

Name | Description
CanAccessBook | Returns true if the wanted book can be access by the user.
CanAccessCategory | Returns true if the wanted category can be accessed by the user.
CanAccessNote | Returns true if the wanted note can be accessed by the user.
IsPolicyAllowed | Returns true if the wanted policy is granted to the user.

Properties

Name | Description
CacheKey | Gets a value that can be used as a caching key that identifies objects that can be shared between principals.
Licenses | Gets the licenses for the user.
Security | Gets the provider associated with providing security for the user.
UserId | Gets the principal user id.

See Also

IPrincipal Interface
Mincom.LinkOne.Dom Namespace


IPrincipal Methods

[image] [image]

LinkOne WebView API
IPrincipal Methods
IPrincipal Interface See Also Send Feedback

The IPrincipal type exposes the following members.

Methods

Name | Description
CanAccessBook | Returns true if the wanted book can be access by the user.
CanAccessCategory | Returns true if the wanted category can be accessed by the user.
CanAccessNote | Returns true if the wanted note can be accessed by the user.
IsPolicyAllowed | Returns true if the wanted policy is granted to the user.

See Also

IPrincipal Interface
Mincom.LinkOne.Dom Namespace


CanAccessBook Method

[image]

LinkOne WebView API
IPrincipal..::.CanAccessBook Method
IPrincipal Interface See Also Send Feedback
Returns true if the wanted book can be access by the user.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool CanAccessBook(
    string publisherCode,
    string bookCode,
    IList<string> categories
)
Visual Basic (Declaration)
Function CanAccessBook ( _
    publisherCode As String, _
    bookCode As String, _
    categories As IList(Of String) _
) As Boolean
Visual C++
bool CanAccessBook(
    String^ publisherCode,
    String^ bookCode,
    IList<String^>^ categories
)

Parameters

publisherCode
Type: System..::.String
The publisher code of the book to test.
bookCode
Type: System..::.String
The book code of the book to test.
categories
Type: System.Collections.Generic..::.IList<(Of <(String>)>)
The category codes of the book to test.

Return Value

True if the wanted book can be access by the user.

See Also

IPrincipal Interface
Mincom.LinkOne.Dom Namespace


CanAccessCategory Method

[image]

LinkOne WebView API
IPrincipal..::.CanAccessCategory Method
IPrincipal Interface See Also Send Feedback
Returns true if the wanted category can be accessed by the user.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool CanAccessCategory(
    ICategory category
)
Visual Basic (Declaration)
Function CanAccessCategory ( _
    category As ICategory _
) As Boolean
Visual C++
bool CanAccessCategory(
    ICategory^ category
)

Parameters

category
Type: Mincom.LinkOne.Dom.Notes..::.ICategory
The category to test.

Return Value

True if the wanted category can be accessed by the user.

See Also

IPrincipal Interface
Mincom.LinkOne.Dom Namespace


CanAccessNote Method

[image]

LinkOne WebView API
IPrincipal..::.CanAccessNote Method
IPrincipal Interface See Also Send Feedback
Returns true if the wanted note can be accessed by the user.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool CanAccessNote(
    INote note
)
Visual Basic (Declaration)
Function CanAccessNote ( _
    note As INote _
) As Boolean
Visual C++
bool CanAccessNote(
    INote^ note
)

Parameters

note
Type: Mincom.LinkOne.Dom.Notes..::.INote
The note to test.

Return Value

True if the wanted note can be accessed by the user.

See Also

IPrincipal Interface
Mincom.LinkOne.Dom Namespace


IsPolicyAllowed Method

[image]

LinkOne WebView API
IPrincipal..::.IsPolicyAllowed Method
IPrincipal Interface See Also Send Feedback
Returns true if the wanted policy is granted to the user.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IsPolicyAllowed(
    string policy
)
Visual Basic (Declaration)
Function IsPolicyAllowed ( _
    policy As String _
) As Boolean
Visual C++
bool IsPolicyAllowed(
    String^ policy
)

Parameters

policy
Type: System..::.String
The policy to test.

Return Value

True if the wanted policy is granted to the user.

See Also

IPrincipal Interface
Mincom.LinkOne.Dom Namespace


IPrincipal Properties

[image] [image]

LinkOne WebView API
IPrincipal Properties
IPrincipal Interface See Also Send Feedback

The IPrincipal type exposes the following members.

Properties

Name | Description
CacheKey | Gets a value that can be used as a caching key that identifies objects that can be shared between principals.
Licenses | Gets the licenses for the user.
Security | Gets the provider associated with providing security for the user.
UserId | Gets the principal user id.

See Also

IPrincipal Interface
Mincom.LinkOne.Dom Namespace


CacheKey Property

[image]

LinkOne WebView API
IPrincipal..::.CacheKey Property
IPrincipal Interface See Also Send Feedback
Gets a value that can be used as a caching key that identifies objects that can be shared between principals.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string CacheKey { get; }
Visual Basic (Declaration)
ReadOnly Property CacheKey As String
Visual C++
property String^ CacheKey {
    String^ get ();
}

See Also

IPrincipal Interface
Mincom.LinkOne.Dom Namespace


Licenses Property

[image]

LinkOne WebView API
IPrincipal..::.Licenses Property
IPrincipal Interface See Also Send Feedback
Gets the licenses for the user.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IList<string> Licenses { get; }
Visual Basic (Declaration)
ReadOnly Property Licenses As IList(Of String)
Visual C++
property IList<String^>^ Licenses {
    IList<String^>^ get ();
}

See Also

IPrincipal Interface
Mincom.LinkOne.Dom Namespace


Security Property

[image]

LinkOne WebView API
IPrincipal..::.Security Property
IPrincipal Interface See Also Send Feedback
Gets the provider associated with providing security for the user.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
Object Security { get; }
Visual Basic (Declaration)
ReadOnly Property Security As Object
Visual C++
property Object^ Security {
    Object^ get ();
}

See Also

IPrincipal Interface
Mincom.LinkOne.Dom Namespace


UserId Property

[image]

LinkOne WebView API
IPrincipal..::.UserId Property
IPrincipal Interface See Also Send Feedback
Gets the principal user id.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string UserId { get; }
Visual Basic (Declaration)
ReadOnly Property UserId As String
Visual C++
property String^ UserId {
    String^ get ();
}

See Also

IPrincipal Interface
Mincom.LinkOne.Dom Namespace


IPrincipal2 Interface

[image]

LinkOne WebView API
IPrincipal2 Interface
Members See Also Send Feedback
Implemented by classes that identify a user.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IPrincipal2 : IPrincipal
Visual Basic (Declaration)
Public Interface IPrincipal2 _
    Implements IPrincipal
Visual C++
public interface class IPrincipal2 : IPrincipal

See Also

IPrincipal2 Members
Mincom.LinkOne.Dom Namespace


IPrincipal2 Members

[image] [image]

LinkOne WebView API
IPrincipal2 Members
IPrincipal2 Interface Methods Properties See Also Send Feedback

The IPrincipal2 type exposes the following members.

Methods

Name | Description
CanAccessBook | Returns true if the wanted book can be access by the user. (Inherited from IPrincipal.)
CanAccessCategory | Returns true if the wanted category can be accessed by the user. (Inherited from IPrincipal.)
CanAccessNote | Returns true if the wanted note can be accessed by the user. (Inherited from IPrincipal.)
IsPolicyAllowed | Returns true if the wanted policy is granted to the user. (Inherited from IPrincipal.)

Properties

Name | Description
CacheKey | Gets a value that can be used as a caching key that identifies objects that can be shared between principals. (Inherited from IPrincipal.)
Licenses | Gets the licenses for the user. (Inherited from IPrincipal.)
PrivateNotesDirectory | Gets or sets the users private notes directory.
PublicNotesDirectory | Gets or sets the users public notes directory.
Security | Gets the provider associated with providing security for the user. (Inherited from IPrincipal.)
UserId | Gets the principal user id. (Inherited from IPrincipal.)

See Also

IPrincipal2 Interface
Mincom.LinkOne.Dom Namespace


IPrincipal2 Methods

[image] [image]

LinkOne WebView API
IPrincipal2 Methods
IPrincipal2 Interface See Also Send Feedback

The IPrincipal2 type exposes the following members.

Methods

Name | Description
CanAccessBook | Returns true if the wanted book can be access by the user. (Inherited from IPrincipal.)
CanAccessCategory | Returns true if the wanted category can be accessed by the user. (Inherited from IPrincipal.)
CanAccessNote | Returns true if the wanted note can be accessed by the user. (Inherited from IPrincipal.)
IsPolicyAllowed | Returns true if the wanted policy is granted to the user. (Inherited from IPrincipal.)

See Also

IPrincipal2 Interface
Mincom.LinkOne.Dom Namespace


IPrincipal2 Properties

[image] [image]

LinkOne WebView API
IPrincipal2 Properties
IPrincipal2 Interface See Also Send Feedback

The IPrincipal2 type exposes the following members.

Properties

Name | Description
CacheKey | Gets a value that can be used as a caching key that identifies objects that can be shared between principals. (Inherited from IPrincipal.)
Licenses | Gets the licenses for the user. (Inherited from IPrincipal.)
PrivateNotesDirectory | Gets or sets the users private notes directory.
PublicNotesDirectory | Gets or sets the users public notes directory.
Security | Gets the provider associated with providing security for the user. (Inherited from IPrincipal.)
UserId | Gets the principal user id. (Inherited from IPrincipal.)

See Also

IPrincipal2 Interface
Mincom.LinkOne.Dom Namespace


PrivateNotesDirectory Property

[image]

LinkOne WebView API
IPrincipal2..::.PrivateNotesDirectory Property
IPrincipal2 Interface See Also Send Feedback
Gets or sets the users private notes directory.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string PrivateNotesDirectory { get; }
Visual Basic (Declaration)
ReadOnly Property PrivateNotesDirectory As String
Visual C++
property String^ PrivateNotesDirectory {
    String^ get ();
}

See Also

IPrincipal2 Interface
Mincom.LinkOne.Dom Namespace


PublicNotesDirectory Property

[image]

LinkOne WebView API
IPrincipal2..::.PublicNotesDirectory Property
IPrincipal2 Interface See Also Send Feedback
Gets or sets the users public notes directory.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string PublicNotesDirectory { get; }
Visual Basic (Declaration)
ReadOnly Property PublicNotesDirectory As String
Visual C++
property String^ PublicNotesDirectory {
    String^ get ();
}

See Also

IPrincipal2 Interface
Mincom.LinkOne.Dom Namespace


IPrincipal3 Interface

[image]

LinkOne WebView API
IPrincipal3 Interface
Members See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IPrincipal3 : IPrincipal2,
    IPrincipal
Visual Basic (Declaration)
Public Interface IPrincipal3 _
    Implements IPrincipal2, IPrincipal
Visual C++
public interface class IPrincipal3 : IPrincipal2,
    IPrincipal

See Also

IPrincipal3 Members
Mincom.LinkOne.Dom Namespace


IPrincipal3 Members

[image] [image]

LinkOne WebView API
IPrincipal3 Members
IPrincipal3 Interface Methods Properties See Also Send Feedback

The IPrincipal3 type exposes the following members.

Methods

Name | Description
CanAccessBook | Returns true if the wanted book can be access by the user. (Inherited from IPrincipal.)
CanAccessCategory | Returns true if the wanted category can be accessed by the user. (Inherited from IPrincipal.)
CanAccessNote | Returns true if the wanted note can be accessed by the user. (Inherited from IPrincipal.)
DrawPrintingOverLay |
IsPolicyAllowed | Returns true if the wanted policy is granted to the user. (Inherited from IPrincipal.)

Properties

Name | Description
CacheKey | Gets a value that can be used as a caching key that identifies objects that can be shared between principals. (Inherited from IPrincipal.)
Licenses | Gets the licenses for the user. (Inherited from IPrincipal.)
PrivateNotesDirectory | Gets or sets the users private notes directory. (Inherited from IPrincipal2.)
PublicNotesDirectory | Gets or sets the users public notes directory. (Inherited from IPrincipal2.)
Security | Gets the provider associated with providing security for the user. (Inherited from IPrincipal.)
UserId | Gets the principal user id. (Inherited from IPrincipal.)

See Also

IPrincipal3 Interface
Mincom.LinkOne.Dom Namespace


IPrincipal3 Methods

[image] [image]

LinkOne WebView API
IPrincipal3 Methods
IPrincipal3 Interface See Also Send Feedback

The IPrincipal3 type exposes the following members.

Methods

Name | Description
CanAccessBook | Returns true if the wanted book can be access by the user. (Inherited from IPrincipal.)
CanAccessCategory | Returns true if the wanted category can be accessed by the user. (Inherited from IPrincipal.)
CanAccessNote | Returns true if the wanted note can be accessed by the user. (Inherited from IPrincipal.)
DrawPrintingOverLay |
IsPolicyAllowed | Returns true if the wanted policy is granted to the user. (Inherited from IPrincipal.)

See Also

IPrincipal3 Interface
Mincom.LinkOne.Dom Namespace


DrawPrintingOverLay Method

[image]

LinkOne WebView API
IPrincipal3..::.DrawPrintingOverLay Method
IPrincipal3 Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void DrawPrintingOverLay(
    Graphics graphics
)
Visual Basic (Declaration)
Sub DrawPrintingOverLay ( _
    graphics As Graphics _
)
Visual C++
void DrawPrintingOverLay(
    Graphics^ graphics
)

Parameters

graphics
Type: System.Drawing..::.Graphics

See Also

IPrincipal3 Interface
Mincom.LinkOne.Dom Namespace


IPrincipal3 Properties

[image] [image]

LinkOne WebView API
IPrincipal3 Properties
IPrincipal3 Interface See Also Send Feedback

The IPrincipal3 type exposes the following members.

Properties

Name | Description
CacheKey | Gets a value that can be used as a caching key that identifies objects that can be shared between principals. (Inherited from IPrincipal.)
Licenses | Gets the licenses for the user. (Inherited from IPrincipal.)
PrivateNotesDirectory | Gets or sets the users private notes directory. (Inherited from IPrincipal2.)
PublicNotesDirectory | Gets or sets the users public notes directory. (Inherited from IPrincipal2.)
Security | Gets the provider associated with providing security for the user. (Inherited from IPrincipal.)
UserId | Gets the principal user id. (Inherited from IPrincipal.)

See Also

IPrincipal3 Interface
Mincom.LinkOne.Dom Namespace


IPublisher Interface

[image]

LinkOne WebView API
IPublisher Interface
Members See Also Send Feedback
Represents a publisher of LinkOne books.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IPublisher
Visual Basic (Declaration)
Public Interface IPublisher
Visual C++
public interface class IPublisher

See Also

IPublisher Members
Mincom.LinkOne.Dom Namespace


IPublisher Members

[image] [image]

LinkOne WebView API
IPublisher Members
IPublisher Interface Properties See Also Send Feedback

The IPublisher type exposes the following members.

Properties

Name | Description
Books | Gets the books published by the publisher.
Catalog | Gets a catalog of books by category for the publisher.
Categories | Gets the note categories visible to the publisher and library.
Library | Gets the library for the publisher.
Notes | Gets the notes visible to the publisher and library.
PublisherCode | Gets the publisher code.
PublisherDescription | Gets the publisher description.
PublisherDescriptionTranslations | Gets the publisher description translations.

See Also

IPublisher Interface
Mincom.LinkOne.Dom Namespace


IPublisher Properties

[image] [image]

LinkOne WebView API
IPublisher Properties
IPublisher Interface See Also Send Feedback

The IPublisher type exposes the following members.

Properties

Name | Description
Books | Gets the books published by the publisher.
Catalog | Gets a catalog of books by category for the publisher.
Categories | Gets the note categories visible to the publisher and library.
Library | Gets the library for the publisher.
Notes | Gets the notes visible to the publisher and library.
PublisherCode | Gets the publisher code.
PublisherDescription | Gets the publisher description.
PublisherDescriptionTranslations | Gets the publisher description translations.

See Also

IPublisher Interface
Mincom.LinkOne.Dom Namespace


Books Property

[image]

LinkOne WebView API
IPublisher..::.Books Property
IPublisher Interface See Also Send Feedback
Gets the books published by the publisher.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IBookCollection Books { get; }
Visual Basic (Declaration)
ReadOnly Property Books As IBookCollection
Visual C++
property IBookCollection^ Books {
    IBookCollection^ get ();
}

See Also

IPublisher Interface
Mincom.LinkOne.Dom Namespace


Catalog Property

[image]

LinkOne WebView API
IPublisher..::.Catalog Property
IPublisher Interface See Also Send Feedback
Gets a catalog of books by category for the publisher.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ICatalog Catalog { get; }
Visual Basic (Declaration)
ReadOnly Property Catalog As ICatalog
Visual C++
property ICatalog^ Catalog {
    ICatalog^ get ();
}

See Also

IPublisher Interface
Mincom.LinkOne.Dom Namespace


Categories Property

[image]

LinkOne WebView API
IPublisher..::.Categories Property
IPublisher Interface See Also Send Feedback
Gets the note categories visible to the publisher and library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ICategoryCollection Categories { get; }
Visual Basic (Declaration)
ReadOnly Property Categories As ICategoryCollection
Visual C++
property ICategoryCollection^ Categories {
    ICategoryCollection^ get ();
}

See Also

IPublisher Interface
Mincom.LinkOne.Dom Namespace


Library Property

[image]

LinkOne WebView API
IPublisher..::.Library Property
IPublisher Interface See Also Send Feedback
Gets the library for the publisher.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ILibrary Library { get; }
Visual Basic (Declaration)
ReadOnly Property Library As ILibrary
Visual C++
property ILibrary^ Library {
    ILibrary^ get ();
}

See Also

IPublisher Interface
Mincom.LinkOne.Dom Namespace


Notes Property

[image]

LinkOne WebView API
IPublisher..::.Notes Property
IPublisher Interface See Also Send Feedback
Gets the notes visible to the publisher and library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
INoteCollection Notes { get; }
Visual Basic (Declaration)
ReadOnly Property Notes As INoteCollection
Visual C++
property INoteCollection^ Notes {
    INoteCollection^ get ();
}

See Also

IPublisher Interface
Mincom.LinkOne.Dom Namespace


PublisherCode Property

[image]

LinkOne WebView API
IPublisher..::.PublisherCode Property
IPublisher Interface See Also Send Feedback
Gets the publisher code.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string PublisherCode { get; }
Visual Basic (Declaration)
ReadOnly Property PublisherCode As String
Visual C++
property String^ PublisherCode {
    String^ get ();
}

See Also

IPublisher Interface
Mincom.LinkOne.Dom Namespace


PublisherDescription Property

[image]

LinkOne WebView API
IPublisher..::.PublisherDescription Property
IPublisher Interface See Also Send Feedback
Gets the publisher description.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string PublisherDescription { get; }
Visual Basic (Declaration)
ReadOnly Property PublisherDescription As String
Visual C++
property String^ PublisherDescription {
    String^ get ();
}

See Also

IPublisher Interface
Mincom.LinkOne.Dom Namespace


PublisherDescriptionTranslations Property

[image]

LinkOne WebView API
IPublisher..::.PublisherDescriptionTranslations Property
IPublisher Interface See Also Send Feedback
Gets the publisher description translations.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ITranslationCollection PublisherDescriptionTranslations { get; }
Visual Basic (Declaration)
ReadOnly Property PublisherDescriptionTranslations As ITranslationCollection
Visual C++
property ITranslationCollection^ PublisherDescriptionTranslations {
    ITranslationCollection^ get ();
}

See Also

IPublisher Interface
Mincom.LinkOne.Dom Namespace


IPublisherCollection Interface

[image]

LinkOne WebView API
IPublisherCollection Interface
Members See Also Send Feedback
Represents a collection of publishers, indexed by PublisherCode.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IPublisherCollection : IReadOnlyKeyedCollection<string, IPublisher>,
    IReadOnlyCollection<IPublisher>, IEnumerable<IPublisher>, IEnumerable
Visual Basic (Declaration)
Public Interface IPublisherCollection _
    Implements IReadOnlyKeyedCollection(Of String, IPublisher),  _
    IReadOnlyCollection(Of IPublisher), IEnumerable(Of IPublisher), IEnumerable
Visual C++
public interface class IPublisherCollection : IReadOnlyKeyedCollection<String^, IPublisher^>,
    IReadOnlyCollection<IPublisher^>, IEnumerable<IPublisher^>, IEnumerable

See Also

IPublisherCollection Members
Mincom.LinkOne.Dom Namespace


IPublisherCollection Members

[image] [image]

LinkOne WebView API
IPublisherCollection Members
IPublisherCollection Interface Methods Properties See Also Send Feedback

The IPublisherCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
GetEnumerator | Overloaded.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item with the specified key. (Inherited from IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>).)

See Also

IPublisherCollection Interface
Mincom.LinkOne.Dom Namespace


IPublisherCollection Methods

[image] [image]

LinkOne WebView API
IPublisherCollection Methods
IPublisherCollection Interface See Also Send Feedback

Methods

Name | Description
Contains | Overloaded.
GetEnumerator | Overloaded.

See Also

IPublisherCollection Interface
Mincom.LinkOne.Dom Namespace


Contains Method

[image] [image]

LinkOne WebView API
IPublisherCollection..::.Contains Method
IPublisherCollection Interface See Also Send Feedback

Overload List

Name | Description
Contains(T) | Determines whether an element is in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Contains(TKey) | Determines whether an element with the given key is in the collection. (Inherited from IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>).)

See Also

IPublisherCollection Interface
IPublisherCollection Members
Mincom.LinkOne.Dom Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
IPublisherCollection..::.GetEnumerator Method
IPublisherCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( IPublisher >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IPublisherCollection Interface
IPublisherCollection Members
Mincom.LinkOne.Dom Namespace


IPublisherCollection Properties

[image] [image]

LinkOne WebView API
IPublisherCollection Properties
IPublisherCollection Interface See Also Send Feedback

The IPublisherCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item with the specified key. (Inherited from IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>).)

See Also

IPublisherCollection Interface
Mincom.LinkOne.Dom Namespace


IToc Interface

[image]

LinkOne WebView API
IToc Interface
Members See Also Send Feedback
Represents the table of contents for a LinkOne book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IToc
Visual Basic (Declaration)
Public Interface IToc
Visual C++
public interface class IToc

See Also

IToc Members
Mincom.LinkOne.Dom Namespace


IToc Members

[image] [image]

LinkOne WebView API
IToc Members
IToc Interface Methods Properties See Also Send Feedback

The IToc type exposes the following members.

Methods

Name | Description
GetEntry | Gets an IToc entry based on the given TOC entry tag.
GetPage | Gets the page matching the given page reference.

Properties

Name | Description
Entries | Gets the root entries.

See Also

IToc Interface
Mincom.LinkOne.Dom Namespace


IToc Methods

[image] [image]

LinkOne WebView API
IToc Methods
IToc Interface See Also Send Feedback

The IToc type exposes the following members.

Methods

Name | Description
GetEntry | Gets an IToc entry based on the given TOC entry tag.
GetPage | Gets the page matching the given page reference.

See Also

IToc Interface
Mincom.LinkOne.Dom Namespace


GetEntry Method

[image]

LinkOne WebView API
IToc..::.GetEntry Method
IToc Interface See Also Send Feedback
Gets an IToc entry based on the given TOC entry tag.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ITocEntry GetEntry(
    string tocEntryTag
)
Visual Basic (Declaration)
Function GetEntry ( _
    tocEntryTag As String _
) As ITocEntry
Visual C++
ITocEntry^ GetEntry(
    String^ tocEntryTag
)

Parameters

tocEntryTag
Type: System..::.String
The tag of interest. May be null/empty to retrieve the root entry.

Return Value

An ITocEntry or null if the tag is not matched.

Remarks

The root entry may not have an associated IPage object.

See Also

IToc Interface
Mincom.LinkOne.Dom Namespace


GetPage Method

[image]

LinkOne WebView API
IToc..::.GetPage Method
IToc Interface See Also Send Feedback
Gets the page matching the given page reference.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPage GetPage(
    string pageReference
)
Visual Basic (Declaration)
Function GetPage ( _
    pageReference As String _
) As IPage
Visual C++
IPage^ GetPage(
    String^ pageReference
)

Parameters

pageReference
Type: System..::.String
The page reference.

Return Value

The referenced page, or null if there is no such page.

See Also

IToc Interface
Mincom.LinkOne.Dom Namespace


IToc Properties

[image] [image]

LinkOne WebView API
IToc Properties
IToc Interface See Also Send Feedback

The IToc type exposes the following members.

Properties

Name | Description
Entries | Gets the root entries.

See Also

IToc Interface
Mincom.LinkOne.Dom Namespace


Entries Property

[image]

LinkOne WebView API
IToc..::.Entries Property
IToc Interface See Also Send Feedback
Gets the root entries.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ITocEntryCollection Entries { get; }
Visual Basic (Declaration)
ReadOnly Property Entries As ITocEntryCollection
Visual C++
property ITocEntryCollection^ Entries {
    ITocEntryCollection^ get ();
}

See Also

IToc Interface
Mincom.LinkOne.Dom Namespace


ITocEntry Interface

[image]

LinkOne WebView API
ITocEntry Interface
Members See Also Send Feedback
Gets a table of contents entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ITocEntry
Visual Basic (Declaration)
Public Interface ITocEntry
Visual C++
public interface class ITocEntry

See Also

ITocEntry Members
Mincom.LinkOne.Dom Namespace


ITocEntry Members

[image] [image]

LinkOne WebView API
ITocEntry Members
ITocEntry Interface Properties See Also Send Feedback

The ITocEntry type exposes the following members.

Properties

Name | Description
ChildEntries | Gets the child toc entries.
Page | Gets the page that is represented by the toc entry.

See Also

ITocEntry Interface
Mincom.LinkOne.Dom Namespace


ITocEntry Properties

[image] [image]

LinkOne WebView API
ITocEntry Properties
ITocEntry Interface See Also Send Feedback

The ITocEntry type exposes the following members.

Properties

Name | Description
ChildEntries | Gets the child toc entries.
Page | Gets the page that is represented by the toc entry.

See Also

ITocEntry Interface
Mincom.LinkOne.Dom Namespace


ChildEntries Property

[image]

LinkOne WebView API
ITocEntry..::.ChildEntries Property
ITocEntry Interface See Also Send Feedback
Gets the child toc entries.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ITocEntryCollection ChildEntries { get; }
Visual Basic (Declaration)
ReadOnly Property ChildEntries As ITocEntryCollection
Visual C++
property ITocEntryCollection^ ChildEntries {
    ITocEntryCollection^ get ();
}

See Also

ITocEntry Interface
Mincom.LinkOne.Dom Namespace


Page Property

[image]

LinkOne WebView API
ITocEntry..::.Page Property
ITocEntry Interface See Also Send Feedback
Gets the page that is represented by the toc entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPage Page { get; }
Visual Basic (Declaration)
ReadOnly Property Page As IPage
Visual C++
property IPage^ Page {
    IPage^ get ();
}

See Also

ITocEntry Interface
Mincom.LinkOne.Dom Namespace


ITocEntryCollection Interface

[image]

LinkOne WebView API
ITocEntryCollection Interface
Members See Also Send Feedback
Represents a collection of entries in the table of contents hierarchy. A toc entry is retrieved by index.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ITocEntryCollection : IReadOnlyList<ITocEntry>,
    IReadOnlyCollection<ITocEntry>, IEnumerable<ITocEntry>, IEnumerable
Visual Basic (Declaration)
Public Interface ITocEntryCollection _
    Implements IReadOnlyList(Of ITocEntry), IReadOnlyCollection(Of ITocEntry),  _
    IEnumerable(Of ITocEntry), IEnumerable
Visual C++
public interface class ITocEntryCollection : IReadOnlyList<ITocEntry^>,
    IReadOnlyCollection<ITocEntry^>, IEnumerable<ITocEntry^>, IEnumerable

See Also

ITocEntryCollection Members
Mincom.LinkOne.Dom Namespace


ITocEntryCollection Members

[image] [image]

LinkOne WebView API
ITocEntryCollection Members
ITocEntryCollection Interface Methods Properties See Also Send Feedback

The ITocEntryCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
GetEnumerator | Overloaded.
IndexOf | Searches the collection and returns the zero-based index of the first occurrence of the given item. (Inherited from IReadOnlyList<(Of <(T>)>).)

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from IReadOnlyList<(Of <(T>)>).)

See Also

ITocEntryCollection Interface
Mincom.LinkOne.Dom Namespace


ITocEntryCollection Methods

[image] [image]

LinkOne WebView API
ITocEntryCollection Methods
ITocEntryCollection Interface See Also Send Feedback

The ITocEntryCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
GetEnumerator | Overloaded.
IndexOf | Searches the collection and returns the zero-based index of the first occurrence of the given item. (Inherited from IReadOnlyList<(Of <(T>)>).)

See Also

ITocEntryCollection Interface
Mincom.LinkOne.Dom Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
ITocEntryCollection..::.GetEnumerator Method
ITocEntryCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( ITocEntry >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

ITocEntryCollection Interface
ITocEntryCollection Members
Mincom.LinkOne.Dom Namespace


ITocEntryCollection Properties

[image] [image]

LinkOne WebView API
ITocEntryCollection Properties
ITocEntryCollection Interface See Also Send Feedback

The ITocEntryCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from IReadOnlyList<(Of <(T>)>).)

See Also

ITocEntryCollection Interface
Mincom.LinkOne.Dom Namespace


ITranslation Interface

[image]

LinkOne WebView API
ITranslation Interface
Members See Also Send Feedback
Represents a translation of a description.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ITranslation
Visual Basic (Declaration)
Public Interface ITranslation
Visual C++
public interface class ITranslation

See Also

ITranslation Members
Mincom.LinkOne.Dom Namespace


ITranslation Members

[image] [image]

LinkOne WebView API
ITranslation Members
ITranslation Interface Properties See Also Send Feedback

The ITranslation type exposes the following members.

Properties

Name | Description
LanguageCode | Gets the ISO-639 compliant language code of the translation.
TranslatedValue | Gets the translated value.

See Also

ITranslation Interface
Mincom.LinkOne.Dom Namespace


ITranslation Properties

[image] [image]

LinkOne WebView API
ITranslation Properties
ITranslation Interface See Also Send Feedback

The ITranslation type exposes the following members.

Properties

Name | Description
LanguageCode | Gets the ISO-639 compliant language code of the translation.
TranslatedValue | Gets the translated value.

See Also

ITranslation Interface
Mincom.LinkOne.Dom Namespace


LanguageCode Property

[image]

LinkOne WebView API
ITranslation..::.LanguageCode Property
ITranslation Interface See Also Send Feedback
Gets the ISO-639 compliant language code of the translation.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string LanguageCode { get; }
Visual Basic (Declaration)
ReadOnly Property LanguageCode As String
Visual C++
property String^ LanguageCode {
    String^ get ();
}

See Also

ITranslation Interface
Mincom.LinkOne.Dom Namespace


TranslatedValue Property

[image]

LinkOne WebView API
ITranslation..::.TranslatedValue Property
ITranslation Interface See Also Send Feedback
Gets the translated value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string TranslatedValue { get; }
Visual Basic (Declaration)
ReadOnly Property TranslatedValue As String
Visual C++
property String^ TranslatedValue {
    String^ get ();
}

See Also

ITranslation Interface
Mincom.LinkOne.Dom Namespace


ITranslationCollection Interface

[image]

LinkOne WebView API
ITranslationCollection Interface
Members See Also Send Feedback
Represents a collection of translations, that can be individually accessed by either index, or key, LanguageCode.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ITranslationCollection : IKeyedCollection<string, ITranslation>,
    ICollection<ITranslation>, IEnumerable<ITranslation>, IEnumerable
Visual Basic (Declaration)
Public Interface ITranslationCollection _
    Implements IKeyedCollection(Of String, ITranslation),  _
    ICollection(Of ITranslation), IEnumerable(Of ITranslation), IEnumerable
Visual C++
public interface class ITranslationCollection : IKeyedCollection<String^, ITranslation^>,
    ICollection<ITranslation^>, IEnumerable<ITranslation^>, IEnumerable

See Also

ITranslationCollection Members
Mincom.LinkOne.Dom Namespace


ITranslationCollection Members

[image] [image]

LinkOne WebView API
ITranslationCollection Members
ITranslationCollection Interface Methods Properties See Also Send Feedback

The ITranslationCollection type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ITranslation >)>).)
Contains | Overloaded.
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( ITranslation >)>).)
GetEnumerator | Overloaded.
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ITranslation >)>).)

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ITranslation >)>).)
DefaultTranslatedValue | Gets or sets the default translation.
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( ITranslation >)>).)
Item | Gets or sets the item with the specified key. (Inherited from IKeyedCollection<(Of <(TKey, TItem>)>).)

See Also

ITranslationCollection Interface
Mincom.LinkOne.Dom Namespace


ITranslationCollection Methods

[image] [image]

LinkOne WebView API
ITranslationCollection Methods
ITranslationCollection Interface See Also Send Feedback

The ITranslationCollection type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ITranslation >)>).)
Contains | Overloaded.
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( ITranslation >)>).)
GetEnumerator | Overloaded.
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ITranslation >)>).)

See Also

ITranslationCollection Interface
Mincom.LinkOne.Dom Namespace


Add Method

[image] [image]

LinkOne WebView API
ITranslationCollection..::.Add Method
ITranslationCollection Interface See Also Send Feedback

Overload List

Name | Description
Add(T) | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ITranslation >)>).)
Add(String, String) | Adds a translation for the specified language code.

See Also

ITranslationCollection Interface
ITranslationCollection Members
Mincom.LinkOne.Dom Namespace


Add Method (String, String)

[image]

LinkOne WebView API
ITranslationCollection..::.Add Method (String, String)
ITranslationCollection Interface See Also Send Feedback
Adds a translation for the specified language code.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void Add(
    string languageCode,
    string translation
)
Visual Basic (Declaration)
Sub Add ( _
    languageCode As String, _
    translation As String _
)
Visual C++
void Add(
    String^ languageCode,
    String^ translation
)

Parameters

languageCode
Type: System..::.String
The ISO-639 compliant language code.
translation
Type: System..::.String
The translation for the supplied language code.

Exceptions

Exception | Condition
System..::.NotSupportedException | The ITranslationCollection is read-only.

See Also

ITranslationCollection Interface
Add Overload
Mincom.LinkOne.Dom Namespace


Contains Method

[image] [image]

LinkOne WebView API
ITranslationCollection..::.Contains Method
ITranslationCollection Interface See Also Send Feedback

Overload List

Name | Description
Contains(TKey) | Determines whether an element with the given key is in the collection. (Inherited from IKeyedCollection<(Of <(TKey, TItem>)>).)
Contains(T) | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from ICollection<(Of <( ITranslation >)>).)

See Also

ITranslationCollection Interface
ITranslationCollection Members
Mincom.LinkOne.Dom Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
ITranslationCollection..::.GetEnumerator Method
ITranslationCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( ITranslation >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

ITranslationCollection Interface
ITranslationCollection Members
Mincom.LinkOne.Dom Namespace


ITranslationCollection Properties

[image] [image]

LinkOne WebView API
ITranslationCollection Properties
ITranslationCollection Interface See Also Send Feedback

The ITranslationCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ITranslation >)>).)
DefaultTranslatedValue | Gets or sets the default translation.
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( ITranslation >)>).)
Item | Gets or sets the item with the specified key. (Inherited from IKeyedCollection<(Of <(TKey, TItem>)>).)

See Also

ITranslationCollection Interface
Mincom.LinkOne.Dom Namespace


DefaultTranslatedValue Property

[image]

LinkOne WebView API
ITranslationCollection..::.DefaultTranslatedValue Property
ITranslationCollection Interface See Also Send Feedback
Gets or sets the default translation.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string DefaultTranslatedValue { get; set; }
Visual Basic (Declaration)
Property DefaultTranslatedValue As String
Visual C++
property String^ DefaultTranslatedValue {
    String^ get ();
    void set (String^ value);
}

Remarks

This is the value to return when a specific language resource is not requested, or there is no translation for the wanted language.

See Also

ITranslationCollection Interface
Mincom.LinkOne.Dom Namespace


IValueCollection Interface

[image]

LinkOne WebView API
IValueCollection Interface
Members See Also Send Feedback
Provides a method for retrieving values from LinkOne. See PredefinedLibraryValueNames and PredefinedBookValueNames for a list of supported values.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IValueCollection
Visual Basic (Declaration)
Public Interface IValueCollection
Visual C++
public interface class IValueCollection

See Also

IValueCollection Members
Mincom.LinkOne.Dom Namespace


IValueCollection Members

[image] [image]

LinkOne WebView API
IValueCollection Members
IValueCollection Interface Properties See Also Send Feedback

The IValueCollection type exposes the following members.

Properties

Name | Description
Item | Gets the value of the specified value field, if it is in scope; otherwise, the default value.

See Also

IValueCollection Interface
Mincom.LinkOne.Dom Namespace


IValueCollection Properties

[image] [image]

LinkOne WebView API
IValueCollection Properties
IValueCollection Interface See Also Send Feedback

The IValueCollection type exposes the following members.

Properties

Name | Description
Item | Gets the value of the specified value field, if it is in scope; otherwise, the default value.

See Also

IValueCollection Interface
Mincom.LinkOne.Dom Namespace


Item Property

[image]

LinkOne WebView API
IValueCollection..::.Item Property
IValueCollection Interface See Also Send Feedback
Gets the value of the specified value field, if it is in scope; otherwise, the default value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string this[
    string valueField
] { get; }
Visual Basic (Declaration)
ReadOnly Default Property Item ( _
    valueField As String _
) As String
Visual C++
property String^ default[String^ valueField] {
    String^ get (String^ valueField);
}

Parameters

valueField
Type: System..::.String

See Also

IValueCollection Interface
Mincom.LinkOne.Dom Namespace


Library Class

[image]

LinkOne WebView API
Library Class
Members See Also Send Feedback
The Library object is the root point of contact for access to the LinkOne book library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class Library : IPersist,
    ILibrary, IDisposable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class Library _
    Implements IPersist, ILibrary, IDisposable
Visual C++
[SerializableAttribute]
public ref class Library sealed : IPersist,
    ILibrary, IDisposable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.Library

See Also

Library Members
Mincom.LinkOne.Dom Namespace


Library Members

[image] [image]

LinkOne WebView API
Library Members
Library Class Constructors Methods Properties Events Explicit Interface Implementations See Also Send Feedback

The Library type exposes the following members.

Constructors

Name | Description
Library | Overloaded.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBook | Returns the book with the given publisher code and book code, or null if not found.
GetBookIgnoreLangOption |
GetConfiguredBook | Gets a book using codes that are determined using the ConfigurationManager.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRefreshedBook | Returns the book with the given publisher code and book code, or null if not found, after clearing it from cache and rereading the source
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Write | Generic writer for IPersist objects.

Properties

Name | Description
Books | Gets the collection of all books in the library.
Categories | Gets the note categories visible to the library.
ConfigurationManager | Gets or sets the IConfigurationManager associated with the library.
LanguageCode | Gets the preferred language code for the library.
Licenses | Gets a read-only collection of licenses applied to the library.
Notes | Gets the notes visible to the library.
Principal | Gets the principal using the Library.
Provider | Gets the persistance provider.
Publishers | Gets the collection of publishers found in the library.
TemporaryFilters | Gets a read-only collection of temporary filters applied to the library.
Values | Gets the values visible to library.

Events

Name | Description
GetValue | Fires when the library requires an external value.

Explicit Interface Implementations

Name | Description
ILibrary..::.Categories |
ILibrary..::.Licenses |
ILibrary..::.Notes |
ILibrary..::.Publishers |
ILibrary..::.TemporaryFilters |
ILibrary..::.Values |

See Also

Library Class
Mincom.LinkOne.Dom Namespace


Library Constructor

[image] [image]

LinkOne WebView API
Library Constructor
Library Class See Also Send Feedback

Overload List

Name | Description
Library(IDomReader) | Initialises a new instance of the Library class using the supplied IDomReader.
Library(IPrincipal, IPersistProvider) | Initialises a new instance of the Library class.
Library(IPrincipal, IPersistProvider, String) | Initialises a new instance of the Library class.
Library(IPrincipal, IPersistProvider, String, FilterCollection) | Initialises a new instance of the Library class using the supplied IDomReader.

See Also

Library Class
Library Members
Mincom.LinkOne.Dom Namespace


Library Constructor ()

[image]

LinkOne WebView API
Library Constructor ()
Library Class See Also Send Feedback
Initialises a new instance of the Library class using the supplied IDomReader.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Library(
    IDomReader domReader
)
Visual Basic (Declaration)
Public Sub New ( _
    domReader As IDomReader _
)
Visual C++
public:
Library(
    IDomReader^ domReader
)

Parameters

domReader
Type: IDomReader
The IDomReader to initialize the library (must be signed by Mincom).

See Also

Library Class
Library Overload
Mincom.LinkOne.Dom Namespace


Library Constructor (IPrincipal, IPersistProvider)

[image]

LinkOne WebView API
Library Constructor (IPrincipal, IPersistProvider)
Library Class See Also Send Feedback
Initialises a new instance of the Library class.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Library(
    IPrincipal principal,
    IPersistProvider provider
)
Visual Basic (Declaration)
Public Sub New ( _
    principal As IPrincipal, _
    provider As IPersistProvider _
)
Visual C++
public:
Library(
    IPrincipal^ principal,
    IPersistProvider^ provider
)

Parameters

principal
Type: Mincom.LinkOne.Dom..::.IPrincipal
The user of the library.
provider
Type: Mincom.LinkOne.Dom..::.IPersistProvider
The IPersistProvider to provide storage facilities for the library.

See Also

Library Class
Library Overload
Mincom.LinkOne.Dom Namespace


Library Constructor (IPrincipal, IPersistProvider, String)

[image]

LinkOne WebView API
Library Constructor (IPrincipal, IPersistProvider, String)
Library Class See Also Send Feedback
Initialises a new instance of the Library class.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Library(
    IPrincipal principal,
    IPersistProvider provider,
    string languageCode
)
Visual Basic (Declaration)
Public Sub New ( _
    principal As IPrincipal, _
    provider As IPersistProvider, _
    languageCode As String _
)
Visual C++
public:
Library(
    IPrincipal^ principal,
    IPersistProvider^ provider,
    String^ languageCode
)

Parameters

principal
Type: Mincom.LinkOne.Dom..::.IPrincipal
The user of the library.
provider
Type: Mincom.LinkOne.Dom..::.IPersistProvider
The IPersistProvider to provide storage facilities for the library.
languageCode
Type: System..::.String
The preferred language code for this library.

See Also

Library Class
Library Overload
Mincom.LinkOne.Dom Namespace


Library Constructor (IPrincipal, IPersistProvider, String, FilterCollection)

[image]

LinkOne WebView API
Library Constructor (IPrincipal, IPersistProvider, String, FilterCollection)
Library Class See Also Send Feedback
Initialises a new instance of the Library class using the supplied IDomReader.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Library(
    IPrincipal principal,
    IPersistProvider provider,
    string languageCode,
    FilterCollection temporaryFilters
)
Visual Basic (Declaration)
Public Sub New ( _
    principal As IPrincipal, _
    provider As IPersistProvider, _
    languageCode As String, _
    temporaryFilters As FilterCollection _
)
Visual C++
public:
Library(
    IPrincipal^ principal,
    IPersistProvider^ provider,
    String^ languageCode,
    FilterCollection^ temporaryFilters
)

Parameters

principal
Type: Mincom.LinkOne.Dom..::.IPrincipal
The user of the library.
provider
Type: Mincom.LinkOne.Dom..::.IPersistProvider
The IPersistProvider to provide storage facilities for the library.
languageCode
Type: System..::.String
The preferred language code for this library.
temporaryFilters
Type: Mincom.LinkOne.Dom.Filtering..::.FilterCollection
The temporary filters for the library.

See Also

Library Class
Library Overload
Mincom.LinkOne.Dom Namespace


Library Methods

[image] [image]

LinkOne WebView API
Library Methods
Library Class See Also Send Feedback

The Library type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBook | Returns the book with the given publisher code and book code, or null if not found.
GetBookIgnoreLangOption |
GetConfiguredBook | Gets a book using codes that are determined using the ConfigurationManager.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRefreshedBook | Returns the book with the given publisher code and book code, or null if not found, after clearing it from cache and rereading the source
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Write | Generic writer for IPersist objects.

See Also

Library Class
Mincom.LinkOne.Dom Namespace


Dispose Method

[image]

LinkOne WebView API
Library..::.Dispose Method
Library Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

Library Class
Mincom.LinkOne.Dom Namespace


GetBook Method

[image]

LinkOne WebView API
Library..::.GetBook Method
Library Class See Also Send Feedback
Returns the book with the given publisher code and book code, or null if not found.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Book GetBook(
    string publisherCode,
    string bookCode
)
Visual Basic (Declaration)
Public Function GetBook ( _
    publisherCode As String, _
    bookCode As String _
) As Book
Visual C++
public:
Book^ GetBook(
    String^ publisherCode,
    String^ bookCode
)

Parameters

publisherCode
Type: System..::.String
The publisher code for the book.
bookCode
Type: System..::.String
The book code for the book.

Return Value

The book with the given publisher code and book code.

See Also

Library Class
Mincom.LinkOne.Dom Namespace


GetBookIgnoreLangOption Method

[image]

LinkOne WebView API
Library..::.GetBookIgnoreLangOption Method
Library Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Book GetBookIgnoreLangOption(
    string publisherCode,
    string bookCode
)
Visual Basic (Declaration)
Public Function GetBookIgnoreLangOption ( _
    publisherCode As String, _
    bookCode As String _
) As Book
Visual C++
public:
Book^ GetBookIgnoreLangOption(
    String^ publisherCode,
    String^ bookCode
)

Parameters

publisherCode
Type: System..::.String
bookCode
Type: System..::.String

See Also

Library Class
Mincom.LinkOne.Dom Namespace


GetConfiguredBook Method

[image]

LinkOne WebView API
Library..::.GetConfiguredBook Method
Library Class See Also Send Feedback
Gets a book using codes that are determined using the ConfigurationManager.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Book GetConfiguredBook(
    string objectIdentifier,
    string slotIdentifier,
    bool genericOptionFiltersOnly,
    out string publisherCode,
    out string bookCode,
    out string pageReference
)
Visual Basic (Declaration)
Public Function GetConfiguredBook ( _
    objectIdentifier As String, _
    slotIdentifier As String, _
    genericOptionFiltersOnly As Boolean, _
    <OutAttribute> ByRef publisherCode As String, _
    <OutAttribute> ByRef bookCode As String, _
    <OutAttribute> ByRef pageReference As String _
) As Book
Visual C++
public:
Book^ GetConfiguredBook(
    String^ objectIdentifier,
    String^ slotIdentifier,
    bool genericOptionFiltersOnly,
    [OutAttribute] String^% publisherCode,
    [OutAttribute] String^% bookCode,
    [OutAttribute] String^% pageReference
)

Parameters

objectIdentifier
Type: System..::.String
A code that has meaning to the configuration manager to identify the book.
slotIdentifier
Type: System..::.String
A code that has meaning to the configuration manager to identify a slot. If non-null and not empty, the slot code will be used to resolve a component installed at the slot via IConfigurationManager.TryResolveSlot. If a component link object identifier is found, the Book that is returned will be the target of the slot.
genericOptionFiltersOnly
Type: System..::.Boolean
true to not use any filters from the configuration manager.
publisherCode
Type: System..::.String %
The publisher code of the resolved book.
bookCode
Type: System..::.String %
The book code of the resolved book.
pageReference
Type: System..::.String %
The specific page reference if one is associated with the objectIdentifier, otherwise null.

Return Value

A Book object, or null if no book is found.

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.MissingConfigurationManagerException | Thrown when there is no ConfigurationManager assigned.
Mincom.LinkOne.Exceptions..::.ConfiguredObjectNotFoundException | Thrown when the given object identifier did not resolve to a book.

See Also

Library Class
Mincom.LinkOne.Dom Namespace


GetRefreshedBook Method

[image]

LinkOne WebView API
Library..::.GetRefreshedBook Method
Library Class See Also Send Feedback
Returns the book with the given publisher code and book code, or null if not found, after clearing it from cache and rereading the source

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Book GetRefreshedBook(
    string publisherCode,
    string bookCode
)
Visual Basic (Declaration)
Public Function GetRefreshedBook ( _
    publisherCode As String, _
    bookCode As String _
) As Book
Visual C++
public:
Book^ GetRefreshedBook(
    String^ publisherCode,
    String^ bookCode
)

Parameters

publisherCode
Type: System..::.String
The publisher code for the book.
bookCode
Type: System..::.String
The book code for the book.

Return Value

The book with the given publisher code and book code.

See Also

Library Class
Mincom.LinkOne.Dom Namespace


Write Method

[image]

LinkOne WebView API
Library..::.Write Method
Library Class See Also Send Feedback
Generic writer for IPersist objects.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IPersist Write(
    IPersist persist
)
Visual Basic (Declaration)
Public Function Write ( _
    persist As IPersist _
) As IPersist
Visual C++
public:
virtual IPersist^ Write(
    IPersist^ persist
) sealed

Parameters

persist
Type: Mincom.LinkOne.Dom..::.IPersist
The object to write.

Return Value

The object written.

Implements

ILibrary..::.Write(IPersist)

See Also

Library Class
Mincom.LinkOne.Dom Namespace


Library Properties

[image] [image]

LinkOne WebView API
Library Properties
Library Class See Also Send Feedback

The Library type exposes the following members.

Properties

Name | Description
Books | Gets the collection of all books in the library.
Categories | Gets the note categories visible to the library.
ConfigurationManager | Gets or sets the IConfigurationManager associated with the library.
LanguageCode | Gets the preferred language code for the library.
Licenses | Gets a read-only collection of licenses applied to the library.
Notes | Gets the notes visible to the library.
Principal | Gets the principal using the Library.
Provider | Gets the persistance provider.
Publishers | Gets the collection of publishers found in the library.
TemporaryFilters | Gets a read-only collection of temporary filters applied to the library.
Values | Gets the values visible to library.

Explicit Interface Implementations

Name | Description
ILibrary..::.Categories |
ILibrary..::.Licenses |
ILibrary..::.Notes |
ILibrary..::.Publishers |
ILibrary..::.TemporaryFilters |
ILibrary..::.Values |

See Also

Library Class
Mincom.LinkOne.Dom Namespace


Books Property

[image]

LinkOne WebView API
Library..::.Books Property
Library Class See Also Send Feedback
Gets the collection of all books in the library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LibraryBookCollection Books { get; }
Visual Basic (Declaration)
Public ReadOnly Property Books As LibraryBookCollection
Visual C++
public:
property LibraryBookCollection^ Books {
    LibraryBookCollection^ get ();
}

See Also

Library Class
Mincom.LinkOne.Dom Namespace


Categories Property

[image]

LinkOne WebView API
Library..::.Categories Property
Library Class See Also Send Feedback
Gets the note categories visible to the library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public CategoryCollection Categories { get; }
Visual Basic (Declaration)
Public ReadOnly Property Categories As CategoryCollection
Visual C++
public:
property CategoryCollection^ Categories {
    CategoryCollection^ get ();
}

See Also

Library Class
Mincom.LinkOne.Dom Namespace


ConfigurationManager Property

[image]

LinkOne WebView API
Library..::.ConfigurationManager Property
Library Class See Also Send Feedback
Gets or sets the IConfigurationManager associated with the library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IConfigurationManager ConfigurationManager { get; set; }
Visual Basic (Declaration)
Public Property ConfigurationManager As IConfigurationManager
Visual C++
public:
property IConfigurationManager^ ConfigurationManager {
    IConfigurationManager^ get ();
    void set (IConfigurationManager^ value);
}

See Also

Library Class
Mincom.LinkOne.Dom Namespace


ILibrary.Categories Property

[image]

LinkOne WebView API
Library..::.ILibrary..::.Categories Property
Library Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ICategoryCollection ILibrary.Categories { get; }
Visual Basic (Declaration)
Private ReadOnly Property Categories As ICategoryCollection
    Implements ILibrary.Categories
Visual C++
private:
virtual property ICategoryCollection^ Categories {
    ICategoryCollection^ get () sealed = ILibrary::Categories::get;
}

Implements

ILibrary..::.Categories

See Also

Library Class
Mincom.LinkOne.Dom Namespace


ILibrary.Licenses Property

[image]

LinkOne WebView API
Library..::.ILibrary..::.Licenses Property
Library Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IList<string> ILibrary.Licenses { get; }
Visual Basic (Declaration)
Private ReadOnly Property Licenses As IList(Of String)
    Implements ILibrary.Licenses
Visual C++
private:
virtual property IList<String^>^ Licenses {
    IList<String^>^ get () sealed = ILibrary::Licenses::get;
}

Implements

ILibrary..::.Licenses

See Also

Library Class
Mincom.LinkOne.Dom Namespace


ILibrary.Notes Property

[image]

LinkOne WebView API
Library..::.ILibrary..::.Notes Property
Library Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
INoteCollection ILibrary.Notes { get; }
Visual Basic (Declaration)
Private ReadOnly Property Notes As INoteCollection
    Implements ILibrary.Notes
Visual C++
private:
virtual property INoteCollection^ Notes {
    INoteCollection^ get () sealed = ILibrary::Notes::get;
}

Implements

ILibrary..::.Notes

See Also

Library Class
Mincom.LinkOne.Dom Namespace


ILibrary.Publishers Property

[image]

LinkOne WebView API
Library..::.ILibrary..::.Publishers Property
Library Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPublisherCollection ILibrary.Publishers { get; }
Visual Basic (Declaration)
Private ReadOnly Property Publishers As IPublisherCollection
    Implements ILibrary.Publishers
Visual C++
private:
virtual property IPublisherCollection^ Publishers {
    IPublisherCollection^ get () sealed = ILibrary::Publishers::get;
}

Implements

ILibrary..::.Publishers

See Also

Library Class
Mincom.LinkOne.Dom Namespace


ILibrary.TemporaryFilters Property

[image]

LinkOne WebView API
Library..::.ILibrary..::.TemporaryFilters Property
Library Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IFilterCollection ILibrary.TemporaryFilters { get; }
Visual Basic (Declaration)
Private ReadOnly Property TemporaryFilters As IFilterCollection
    Implements ILibrary.TemporaryFilters
Visual C++
private:
virtual property IFilterCollection^ TemporaryFilters {
    IFilterCollection^ get () sealed = ILibrary::TemporaryFilters::get;
}

Implements

ILibrary..::.TemporaryFilters

See Also

Library Class
Mincom.LinkOne.Dom Namespace


ILibrary.Values Property

[image]

LinkOne WebView API
Library..::.ILibrary..::.Values Property
Library Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IValueCollection ILibrary.Values { get; }
Visual Basic (Declaration)
Private ReadOnly Property Values As IValueCollection
    Implements ILibrary.Values
Visual C++
private:
virtual property IValueCollection^ Values {
    IValueCollection^ get () sealed = ILibrary::Values::get;
}

Implements

ILibrary..::.Values

See Also

Library Class
Mincom.LinkOne.Dom Namespace


LanguageCode Property

[image]

LinkOne WebView API
Library..::.LanguageCode Property
Library Class See Also Send Feedback
Gets the preferred language code for the library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string LanguageCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property LanguageCode As String
Visual C++
public:
virtual property String^ LanguageCode {
    String^ get () sealed;
}

Implements

ILibrary..::.LanguageCode

See Also

Library Class
Mincom.LinkOne.Dom Namespace


Licenses Property

[image]

LinkOne WebView API
Library..::.Licenses Property
Library Class See Also Send Feedback
Gets a read-only collection of licenses applied to the library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IList<string> Licenses { get; }
Visual Basic (Declaration)
Public ReadOnly Property Licenses As IList(Of String)
Visual C++
public:
property IList<String^>^ Licenses {
    IList<String^>^ get ();
}

See Also

Library Class
Mincom.LinkOne.Dom Namespace


Notes Property

[image]

LinkOne WebView API
Library..::.Notes Property
Library Class See Also Send Feedback
Gets the notes visible to the library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public NoteCollection Notes { get; }
Visual Basic (Declaration)
Public ReadOnly Property Notes As NoteCollection
Visual C++
public:
property NoteCollection^ Notes {
    NoteCollection^ get ();
}

See Also

Library Class
Mincom.LinkOne.Dom Namespace


Principal Property

[image]

LinkOne WebView API
Library..::.Principal Property
Library Class See Also Send Feedback
Gets the principal using the Library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IPrincipal Principal { get; }
Visual Basic (Declaration)
Public ReadOnly Property Principal As IPrincipal
Visual C++
public:
property IPrincipal^ Principal {
    IPrincipal^ get ();
}

See Also

Library Class
Mincom.LinkOne.Dom Namespace


Provider Property

[image]

LinkOne WebView API
Library..::.Provider Property
Library Class See Also Send Feedback
Gets the persistance provider.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IPersistProvider Provider { get; }
Visual Basic (Declaration)
Public ReadOnly Property Provider As IPersistProvider
Visual C++
public:
property IPersistProvider^ Provider {
    IPersistProvider^ get ();
}

See Also

Library Class
Mincom.LinkOne.Dom Namespace


Publishers Property

[image]

LinkOne WebView API
Library..::.Publishers Property
Library Class See Also Send Feedback
Gets the collection of publishers found in the library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PublisherCollection Publishers { get; }
Visual Basic (Declaration)
Public ReadOnly Property Publishers As PublisherCollection
Visual C++
public:
property PublisherCollection^ Publishers {
    PublisherCollection^ get ();
}

See Also

Library Class
Mincom.LinkOne.Dom Namespace


TemporaryFilters Property

[image]

LinkOne WebView API
Library..::.TemporaryFilters Property
Library Class See Also Send Feedback
Gets a read-only collection of temporary filters applied to the library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ReadOnlyFilterCollection TemporaryFilters { get; }
Visual Basic (Declaration)
Public ReadOnly Property TemporaryFilters As ReadOnlyFilterCollection
Visual C++
public:
property ReadOnlyFilterCollection^ TemporaryFilters {
    ReadOnlyFilterCollection^ get ();
}

See Also

Library Class
Mincom.LinkOne.Dom Namespace


Values Property

[image]

LinkOne WebView API
Library..::.Values Property
Library Class See Also Send Feedback
Gets the values visible to library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ValueCollection Values { get; }
Visual Basic (Declaration)
Public ReadOnly Property Values As ValueCollection
Visual C++
public:
property ValueCollection^ Values {
    ValueCollection^ get ();
}

See Also

Library Class
Mincom.LinkOne.Dom Namespace


Library Events

[image] [image]

LinkOne WebView API
Library Events
Library Class See Also Send Feedback

The Library type exposes the following members.

Events

Name | Description
GetValue | Fires when the library requires an external value.

See Also

Library Class
Mincom.LinkOne.Dom Namespace


GetValue Event

[image]

LinkOne WebView API
Library..::.GetValue Event
Library Class See Also Send Feedback
Fires when the library requires an external value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public event GetValueEventHandler GetValue
Visual Basic (Declaration)
Public Event GetValue As GetValueEventHandler
Visual C++
public:
virtual  event GetValueEventHandler^ GetValue {
    void add (GetValueEventHandler^ value);
    void remove (GetValueEventHandler^ value);
}

Implements

ILibrary..::.GetValue

See Also

Library Class
Mincom.LinkOne.Dom Namespace


LibraryBookCollection Class

[image]

LinkOne WebView API
LibraryBookCollection Class
Members See Also Send Feedback
Represents a collection of Book objects sorted by publisher code then book code.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public sealed class LibraryBookCollection : IReadOnlyCollection<Book>,
    IEnumerable<Book>, IEnumerable
Visual Basic (Declaration)
Public NotInheritable Class LibraryBookCollection _
    Implements IReadOnlyCollection(Of Book), IEnumerable(Of Book),  _
    IEnumerable
Visual C++
public ref class LibraryBookCollection sealed : IReadOnlyCollection<Book^>,
    IEnumerable<Book^>, IEnumerable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.LibraryBookCollection

See Also

LibraryBookCollection Members
Mincom.LinkOne.Dom Namespace


LibraryBookCollection Members

[image] [image]

LinkOne WebView API
LibraryBookCollection Members
LibraryBookCollection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The LibraryBookCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an book is in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements in the collection.
Item | Gets the book with the given publisher code and book code, or null if not found.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.

See Also

LibraryBookCollection Class
Mincom.LinkOne.Dom Namespace


LibraryBookCollection Methods

[image] [image]

LinkOne WebView API
LibraryBookCollection Methods
LibraryBookCollection Class See Also Send Feedback

The LibraryBookCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an book is in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.

See Also

LibraryBookCollection Class
Mincom.LinkOne.Dom Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
LibraryBookCollection..::.IEnumerable..::.GetEnumerator Method
LibraryBookCollection Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

LibraryBookCollection Class
Mincom.LinkOne.Dom Namespace


Contains Method

[image]

LinkOne WebView API
LibraryBookCollection..::.Contains Method
LibraryBookCollection Class See Also Send Feedback
Determines whether an book is in the collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    Book item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As Book _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Book^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Dom..::.Book
The book object to search for.

Return Value

true if found in the collection, otherwise, false.

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Contains(T)

See Also

LibraryBookCollection Class
Mincom.LinkOne.Dom Namespace


GetEnumerator Method

[image]

LinkOne WebView API
LibraryBookCollection..::.GetEnumerator Method
LibraryBookCollection Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IEnumerator<Book> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of Book)
Visual C++
public:
virtual IEnumerator<Book^>^ GetEnumerator() sealed

Return Value

A IEnumerator<(Of <(T>)>) that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

LibraryBookCollection Class
Mincom.LinkOne.Dom Namespace


LibraryBookCollection Properties

[image] [image]

LinkOne WebView API
LibraryBookCollection Properties
LibraryBookCollection Class See Also Send Feedback

The LibraryBookCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection.
Item | Gets the book with the given publisher code and book code, or null if not found.

See Also

LibraryBookCollection Class
Mincom.LinkOne.Dom Namespace


Count Property

[image]

LinkOne WebView API
LibraryBookCollection..::.Count Property
LibraryBookCollection Class See Also Send Feedback
Gets the number of elements in the collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Count

See Also

LibraryBookCollection Class
Mincom.LinkOne.Dom Namespace


Item Property

[image]

LinkOne WebView API
LibraryBookCollection..::.Item Property
LibraryBookCollection Class See Also Send Feedback
Gets the book with the given publisher code and book code, or null if not found.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Book this[
    string publisherCode,
    string bookCode
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    publisherCode As String, _
    bookCode As String _
) As Book
Visual C++
public:
property Book^ default[String^ publisherCode, String^ bookCode] {
    Book^ get (String^ publisherCode, String^ bookCode);
}

Parameters

publisherCode
Type: System..::.String
The publisher code for the book.
bookCode
Type: System..::.String
The book code for the book.

See Also

LibraryBookCollection Class
Mincom.LinkOne.Dom Namespace


Manifest Class

[image]

LinkOne WebView API
Manifest Class
Members See Also Send Feedback
The Manifest class.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class Manifest : IPersist
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class Manifest _
    Implements IPersist
Visual C++
[SerializableAttribute]
public ref class Manifest sealed : IPersist

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.Manifest

See Also

Manifest Members
Mincom.LinkOne.Dom Namespace


Manifest Members

[image] [image]

LinkOne WebView API
Manifest Members
Manifest Class Constructors Methods Properties See Also Send Feedback

The Manifest type exposes the following members.

Constructors

Name | Description
Manifest | Overloaded.

Methods

Name | Description
Clone | Gets a clone of the this.
Difference | Returns a new Manifest containing the differences between the given one and this one.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
BookCode | Gets the book code for the manifest.
CodePage | Gets the code page setting for manifest.
ImageQuality | Gets the image quality setting for the manifest.
ManifestEntries | Gets the collection of manifest entries.
MaxImageHeight | Gets the maximum image height setting for the manifest.
MaxImageSize | Gets the maximum image file size setting for the manifest.
MaxImageWidth | Gets the maximum image width setting for the manifest.
PublisherCode | Gets the publisher code for the manifest.
RasterisationHeight | Gets the rasterisation height setting for the manifest.
RasterisationWidth | Gets the rasterisation width setting for the manifest.
TargetImageType | Gets the target image type setting for the manifest.

See Also

Manifest Class
Mincom.LinkOne.Dom Namespace


Manifest Constructor

[image] [image]

LinkOne WebView API
Manifest Constructor
Manifest Class See Also Send Feedback

Overload List

Name | Description
Manifest()()() | Constructs a Manifest.
Manifest(String, String) | Constructs a Manifest with the given publisher and book code.

See Also

Manifest Class
Manifest Members
Mincom.LinkOne.Dom Namespace


Manifest Constructor

[image]

LinkOne WebView API
Manifest Constructor
Manifest Class See Also Send Feedback
Constructs a Manifest.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Manifest()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Manifest()

See Also

Manifest Class
Manifest Overload
Mincom.LinkOne.Dom Namespace


Manifest Constructor (String, String)

[image]

LinkOne WebView API
Manifest Constructor (String, String)
Manifest Class See Also Send Feedback
Constructs a Manifest with the given publisher and book code.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Manifest(
    string publisherCode,
    string bookCode
)
Visual Basic (Declaration)
Public Sub New ( _
    publisherCode As String, _
    bookCode As String _
)
Visual C++
public:
Manifest(
    String^ publisherCode,
    String^ bookCode
)

Parameters

publisherCode
Type: System..::.String
The publisher code of the manifest.
bookCode
Type: System..::.String
The book code of the manifest.

See Also

Manifest Class
Manifest Overload
Mincom.LinkOne.Dom Namespace


Manifest Methods

[image] [image]

LinkOne WebView API
Manifest Methods
Manifest Class See Also Send Feedback

The Manifest type exposes the following members.

Methods

Name | Description
Clone | Gets a clone of the this.
Difference | Returns a new Manifest containing the differences between the given one and this one.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Manifest Class
Mincom.LinkOne.Dom Namespace


Clone Method

[image]

LinkOne WebView API
Manifest..::.Clone Method
Manifest Class See Also Send Feedback
Gets a clone of the this.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IPersist Clone()
Visual Basic (Declaration)
Public Function Clone As IPersist
Visual C++
public:
IPersist^ Clone()

Return Value

An cloned instance of this.

See Also

Manifest Class
Mincom.LinkOne.Dom Namespace


Difference Method

[image]

LinkOne WebView API
Manifest..::.Difference Method
Manifest Class See Also Send Feedback
Returns a new Manifest containing the differences between the given one and this one.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Manifest Difference(
    Manifest manifest
)
Visual Basic (Declaration)
Public Function Difference ( _
    manifest As Manifest _
) As Manifest
Visual C++
public:
Manifest^ Difference(
    Manifest^ manifest
)

Parameters

manifest
Type: Mincom.LinkOne.Dom..::.Manifest
The difference object to compare to.

Return Value

A new Manifest containing the diferences.

See Also

Manifest Class
Mincom.LinkOne.Dom Namespace


Manifest Properties

[image] [image]

LinkOne WebView API
Manifest Properties
Manifest Class See Also Send Feedback

The Manifest type exposes the following members.

Properties

Name | Description
BookCode | Gets the book code for the manifest.
CodePage | Gets the code page setting for manifest.
ImageQuality | Gets the image quality setting for the manifest.
ManifestEntries | Gets the collection of manifest entries.
MaxImageHeight | Gets the maximum image height setting for the manifest.
MaxImageSize | Gets the maximum image file size setting for the manifest.
MaxImageWidth | Gets the maximum image width setting for the manifest.
PublisherCode | Gets the publisher code for the manifest.
RasterisationHeight | Gets the rasterisation height setting for the manifest.
RasterisationWidth | Gets the rasterisation width setting for the manifest.
TargetImageType | Gets the target image type setting for the manifest.

See Also

Manifest Class
Mincom.LinkOne.Dom Namespace


BookCode Property

[image]

LinkOne WebView API
Manifest..::.BookCode Property
Manifest Class See Also Send Feedback
Gets the book code for the manifest.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string BookCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property BookCode As String
Visual C++
public:
property String^ BookCode {
    String^ get ();
}

Field Value

The book code of the manifest.

See Also

Manifest Class
Mincom.LinkOne.Dom Namespace


CodePage Property

[image]

LinkOne WebView API
Manifest..::.CodePage Property
Manifest Class See Also Send Feedback
Gets the code page setting for manifest.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int CodePage { get; internal set; }
Visual Basic (Declaration)
Public Property CodePage As Integer
Visual C++
public:
property int CodePage {
    int get ();
    void set (int value);
}

See Also

Manifest Class
Mincom.LinkOne.Dom Namespace


ImageQuality Property

[image]

LinkOne WebView API
Manifest..::.ImageQuality Property
Manifest Class See Also Send Feedback
Gets the image quality setting for the manifest.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int ImageQuality { get; internal set; }
Visual Basic (Declaration)
Public Property ImageQuality As Integer
Visual C++
public:
property int ImageQuality {
    int get ();
    void set (int value);
}

See Also

Manifest Class
Mincom.LinkOne.Dom Namespace


ManifestEntries Property

[image]

LinkOne WebView API
Manifest..::.ManifestEntries Property
Manifest Class See Also Send Feedback
Gets the collection of manifest entries.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Hashtable ManifestEntries { get; }
Visual Basic (Declaration)
Public ReadOnly Property ManifestEntries As Hashtable
Visual C++
public:
property Hashtable^ ManifestEntries {
    Hashtable^ get ();
}

See Also

Manifest Class
Mincom.LinkOne.Dom Namespace


MaxImageHeight Property

[image]

LinkOne WebView API
Manifest..::.MaxImageHeight Property
Manifest Class See Also Send Feedback
Gets the maximum image height setting for the manifest.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int MaxImageHeight { get; internal set; }
Visual Basic (Declaration)
Public Property MaxImageHeight As Integer
Visual C++
public:
property int MaxImageHeight {
    int get ();
    void set (int value);
}

See Also

Manifest Class
Mincom.LinkOne.Dom Namespace


MaxImageSize Property

[image]

LinkOne WebView API
Manifest..::.MaxImageSize Property
Manifest Class See Also Send Feedback
Gets the maximum image file size setting for the manifest.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int MaxImageSize { get; internal set; }
Visual Basic (Declaration)
Public Property MaxImageSize As Integer
Visual C++
public:
property int MaxImageSize {
    int get ();
    void set (int value);
}

See Also

Manifest Class
Mincom.LinkOne.Dom Namespace


MaxImageWidth Property

[image]

LinkOne WebView API
Manifest..::.MaxImageWidth Property
Manifest Class See Also Send Feedback
Gets the maximum image width setting for the manifest.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int MaxImageWidth { get; internal set; }
Visual Basic (Declaration)
Public Property MaxImageWidth As Integer
Visual C++
public:
property int MaxImageWidth {
    int get ();
    void set (int value);
}

See Also

Manifest Class
Mincom.LinkOne.Dom Namespace


PublisherCode Property

[image]

LinkOne WebView API
Manifest..::.PublisherCode Property
Manifest Class See Also Send Feedback
Gets the publisher code for the manifest.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PublisherCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublisherCode As String
Visual C++
public:
property String^ PublisherCode {
    String^ get ();
}

Field Value

The publisher code of the manifest.

See Also

Manifest Class
Mincom.LinkOne.Dom Namespace


RasterisationHeight Property

[image]

LinkOne WebView API
Manifest..::.RasterisationHeight Property
Manifest Class See Also Send Feedback
Gets the rasterisation height setting for the manifest.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int RasterisationHeight { get; internal set; }
Visual Basic (Declaration)
Public Property RasterisationHeight As Integer
Visual C++
public:
property int RasterisationHeight {
    int get ();
    void set (int value);
}

See Also

Manifest Class
Mincom.LinkOne.Dom Namespace


RasterisationWidth Property

[image]

LinkOne WebView API
Manifest..::.RasterisationWidth Property
Manifest Class See Also Send Feedback
Gets the rasterisation width setting for the manifest.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int RasterisationWidth { get; internal set; }
Visual Basic (Declaration)
Public Property RasterisationWidth As Integer
Visual C++
public:
property int RasterisationWidth {
    int get ();
    void set (int value);
}

See Also

Manifest Class
Mincom.LinkOne.Dom Namespace


TargetImageType Property

[image]

LinkOne WebView API
Manifest..::.TargetImageType Property
Manifest Class See Also Send Feedback
Gets the target image type setting for the manifest.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ManifestTargetImageType TargetImageType { get; internal set; }
Visual Basic (Declaration)
Public Property TargetImageType As ManifestTargetImageType
Visual C++
public:
property ManifestTargetImageType TargetImageType {
    ManifestTargetImageType get ();
    void set (ManifestTargetImageType value);
}

See Also

Manifest Class
Mincom.LinkOne.Dom Namespace


ManifestEntry Class

[image]

LinkOne WebView API
ManifestEntry Class
Members See Also Send Feedback
The ManifestEntry class.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class ManifestEntry : IPersist
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class ManifestEntry _
    Implements IPersist
Visual C++
[SerializableAttribute]
public ref class ManifestEntry sealed : IPersist

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.ManifestEntry

See Also

ManifestEntry Members
Mincom.LinkOne.Dom Namespace


ManifestEntry Members

[image] [image]

LinkOne WebView API
ManifestEntry Members
ManifestEntry Class Constructors Methods Properties See Also Send Feedback

The ManifestEntry type exposes the following members.

Constructors

Name | Description
ManifestEntry | Constructs a ManifestEntry.

Methods

Name | Description
Clone | Gets a clone of the this.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Action | Gets or sets the action to be performed on the manifest entry.
Length | Gets the length of the manifest entry.
Name | Gets the name of this manifest entry.
Position | Gets the position of the manifest entry.
Timestamp | Gets the integer timestamp of the manifest entry.

See Also

ManifestEntry Class
Mincom.LinkOne.Dom Namespace


ManifestEntry Constructor

[image]

LinkOne WebView API
ManifestEntry Constructor
ManifestEntry Class See Also Send Feedback
Constructs a ManifestEntry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ManifestEntry()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ManifestEntry()

See Also

ManifestEntry Class
Mincom.LinkOne.Dom Namespace


ManifestEntry Methods

[image] [image]

LinkOne WebView API
ManifestEntry Methods
ManifestEntry Class See Also Send Feedback

The ManifestEntry type exposes the following members.

Methods

Name | Description
Clone | Gets a clone of the this.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ManifestEntry Class
Mincom.LinkOne.Dom Namespace


Clone Method

[image]

LinkOne WebView API
ManifestEntry..::.Clone Method
ManifestEntry Class See Also Send Feedback
Gets a clone of the this.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IPersist Clone()
Visual Basic (Declaration)
Public Function Clone As IPersist
Visual C++
public:
IPersist^ Clone()

Return Value

An cloned instance of this.

See Also

ManifestEntry Class
Mincom.LinkOne.Dom Namespace


ManifestEntry Properties

[image] [image]

LinkOne WebView API
ManifestEntry Properties
ManifestEntry Class See Also Send Feedback

The ManifestEntry type exposes the following members.

Properties

Name | Description
Action | Gets or sets the action to be performed on the manifest entry.
Length | Gets the length of the manifest entry.
Name | Gets the name of this manifest entry.
Position | Gets the position of the manifest entry.
Timestamp | Gets the integer timestamp of the manifest entry.

See Also

ManifestEntry Class
Mincom.LinkOne.Dom Namespace


Action Property

[image]

LinkOne WebView API
ManifestEntry..::.Action Property
ManifestEntry Class See Also Send Feedback
Gets or sets the action to be performed on the manifest entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ManifestEntryActionType Action { get; set; }
Visual Basic (Declaration)
Public Property Action As ManifestEntryActionType
Visual C++
public:
property ManifestEntryActionType Action {
    ManifestEntryActionType get ();
    void set (ManifestEntryActionType value);
}

Field Value

The action to be performed on the manifest entry.

See Also

ManifestEntry Class
Mincom.LinkOne.Dom Namespace


Length Property

[image]

LinkOne WebView API
ManifestEntry..::.Length Property
ManifestEntry Class See Also Send Feedback
Gets the length of the manifest entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Length { get; internal set; }
Visual Basic (Declaration)
Public Property Length As Integer
Visual C++
public:
property int Length {
    int get ();
    void set (int value);
}

Field Value

The length of the manifest entry.

See Also

ManifestEntry Class
Mincom.LinkOne.Dom Namespace


Name Property

[image]

LinkOne WebView API
ManifestEntry..::.Name Property
ManifestEntry Class See Also Send Feedback
Gets the name of this manifest entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Name { get; internal set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the manifest entry.

See Also

ManifestEntry Class
Mincom.LinkOne.Dom Namespace


Position Property

[image]

LinkOne WebView API
ManifestEntry..::.Position Property
ManifestEntry Class See Also Send Feedback
Gets the position of the manifest entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Position { get; internal set; }
Visual Basic (Declaration)
Public Property Position As Integer
Visual C++
public:
property int Position {
    int get ();
    void set (int value);
}

Field Value

The position of the manifest entry.

See Also

ManifestEntry Class
Mincom.LinkOne.Dom Namespace


Timestamp Property

[image]

LinkOne WebView API
ManifestEntry..::.Timestamp Property
ManifestEntry Class See Also Send Feedback
Gets the integer timestamp of the manifest entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Timestamp { get; internal set; }
Visual Basic (Declaration)
Public Property Timestamp As Integer
Visual C++
public:
property int Timestamp {
    int get ();
    void set (int value);
}

Field Value

The integer timestamp of the manifest entry.

See Also

ManifestEntry Class
Mincom.LinkOne.Dom Namespace


ManifestEntryActionType Enumeration

[image]

LinkOne WebView API
ManifestEntryActionType Enumeration
See Also Send Feedback
The manifest entry actions.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum ManifestEntryActionType
Visual Basic (Declaration)
Public Enumeration ManifestEntryActionType
Visual C++
public enum class ManifestEntryActionType

Members

Member name | Description
None | There is no ManifestEntryActionType
Add | ManifestEntryActionType is set to Add
Delete | ManifestEntryActionType is set to Delete
Update | ManifestEntryActionType is set to Update

See Also

Mincom.LinkOne.Dom Namespace


ManifestTargetImageType Enumeration

[image]

LinkOne WebView API
ManifestTargetImageType Enumeration
See Also Send Feedback
The enumeration of Manifest File Action Type.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum ManifestTargetImageType
Visual Basic (Declaration)
Public Enumeration ManifestTargetImageType
Visual C++
public enum class ManifestTargetImageType

Members

Member name | Description
Any | Target image type is Any image type.
Jpg | Target image type is compressed using the Joint Photographic Experts Group (jpg/jpeg) compression technique.
Png | Target image type is a Portable Network Graphic (png).
None | There is no target image type.

See Also

Mincom.LinkOne.Dom Namespace


Overlay Class

[image]

LinkOne WebView API
Overlay Class
Members See Also Send Feedback
An overlay graphic on a LinkOne picture.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class Overlay : IFilterable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class Overlay _
    Implements IFilterable
Visual C++
[SerializableAttribute]
public ref class Overlay sealed : IFilterable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.Overlay

See Also

Overlay Members
Mincom.LinkOne.Dom Namespace


Overlay Members

[image] [image]

LinkOne WebView API
Overlay Members
Overlay Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The Overlay type exposes the following members.

Constructors

Name | Description
Overlay | Initializes a new instance of the Overlay class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
UnspecifiedNumber | Unspecified overlay number.

Properties

Name | Description
Height | Gets the height of the overlay.
Left | Gets the left offset of the overlay measured from the picture edge.
Location | Gets the location of the overlay in the book.
Number | Gets the overlay number in the collection of overlays for the picture.
Options | Gets the options associated with this object.
Page | Gets the page associated with this picture.
PublishedDate | Gets the published date.
Resource | Gets the binary resource that is the overlay.
Top | Gets the top offset of the overlay measured from the picture edge.
Width | Gets the width of the overlay.

Explicit Interface Implementations

Name | Description
IFilterable..::.Options | The set of OVERLAYOPTION's associated with this drawing.

See Also

Overlay Class
Mincom.LinkOne.Dom Namespace


Overlay Constructor

[image]

LinkOne WebView API
Overlay Constructor
Overlay Class See Also Send Feedback
Initializes a new instance of the Overlay class.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Overlay(
    IDomReader domReader
)
Visual Basic (Declaration)
Public Sub New ( _
    domReader As IDomReader _
)
Visual C++
public:
Overlay(
    IDomReader^ domReader
)

Parameters

domReader
Type: IDomReader
The overlay reader object providing the initialisation data.

See Also

Overlay Class
Mincom.LinkOne.Dom Namespace


Overlay Fields

[image] [image]

LinkOne WebView API
Overlay Fields
Overlay Class See Also Send Feedback

The Overlay type exposes the following members.

Fields

Name | Description
UnspecifiedNumber | Unspecified overlay number.

See Also

Overlay Class
Mincom.LinkOne.Dom Namespace


UnspecifiedNumber Field

[image]

LinkOne WebView API
Overlay..::.UnspecifiedNumber Field
Overlay Class See Also Send Feedback
Unspecified overlay number.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const int UnspecifiedNumber
Visual Basic (Declaration)
Public Const UnspecifiedNumber As Integer
Visual C++
public:
literal int UnspecifiedNumber

See Also

Overlay Class
Mincom.LinkOne.Dom Namespace


Overlay Methods

[image] [image]

LinkOne WebView API
Overlay Methods
Overlay Class See Also Send Feedback

The Overlay type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Overlay Class
Mincom.LinkOne.Dom Namespace


Overlay Properties

[image] [image]

LinkOne WebView API
Overlay Properties
Overlay Class See Also Send Feedback

The Overlay type exposes the following members.

Properties

Name | Description
Height | Gets the height of the overlay.
Left | Gets the left offset of the overlay measured from the picture edge.
Location | Gets the location of the overlay in the book.
Number | Gets the overlay number in the collection of overlays for the picture.
Options | Gets the options associated with this object.
Page | Gets the page associated with this picture.
PublishedDate | Gets the published date.
Resource | Gets the binary resource that is the overlay.
Top | Gets the top offset of the overlay measured from the picture edge.
Width | Gets the width of the overlay.

Explicit Interface Implementations

Name | Description
IFilterable..::.Options | The set of OVERLAYOPTION's associated with this drawing.

See Also

Overlay Class
Mincom.LinkOne.Dom Namespace


Height Property

[image]

LinkOne WebView API
Overlay..::.Height Property
Overlay Class See Also Send Feedback
Gets the height of the overlay.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Height { get; }
Visual Basic (Declaration)
Public ReadOnly Property Height As Integer
Visual C++
public:
property int Height {
    int get ();
}

See Also

Overlay Class
Mincom.LinkOne.Dom Namespace


IFilterable.Options Property

[image]

LinkOne WebView API
Overlay..::.IFilterable..::.Options Property
Overlay Class See Also Send Feedback
The set of OVERLAYOPTION's associated with this drawing.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IOptionCollection IFilterable.Options { get; }
Visual Basic (Declaration)
Private ReadOnly Property Options As IOptionCollection
    Implements IFilterable.Options
Visual C++
private:
virtual property IOptionCollection^ Options {
    IOptionCollection^ get () sealed = IFilterable::Options::get;
}

Implements

IFilterable..::.Options

See Also

Overlay Class
Mincom.LinkOne.Dom Namespace


Left Property

[image]

LinkOne WebView API
Overlay..::.Left Property
Overlay Class See Also Send Feedback
Gets the left offset of the overlay measured from the picture edge.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Left { get; }
Visual Basic (Declaration)
Public ReadOnly Property Left As Integer
Visual C++
public:
property int Left {
    int get ();
}

See Also

Overlay Class
Mincom.LinkOne.Dom Namespace


Location Property

[image]

LinkOne WebView API
Overlay..::.Location Property
Overlay Class See Also Send Feedback
Gets the location of the overlay in the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Location { get; }
Visual Basic (Declaration)
Public ReadOnly Property Location As String
Visual C++
public:
property String^ Location {
    String^ get ();
}

See Also

Overlay Class
Mincom.LinkOne.Dom Namespace


Number Property

[image]

LinkOne WebView API
Overlay..::.Number Property
Overlay Class See Also Send Feedback
Gets the overlay number in the collection of overlays for the picture.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Number { get; }
Visual Basic (Declaration)
Public ReadOnly Property Number As Integer
Visual C++
public:
property int Number {
    int get ();
}

See Also

Overlay Class
Mincom.LinkOne.Dom Namespace


Options Property

[image]

LinkOne WebView API
Overlay..::.Options Property
Overlay Class See Also Send Feedback
Gets the options associated with this object.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public OptionCollection Options { get; }
Visual Basic (Declaration)
Public ReadOnly Property Options As OptionCollection
Visual C++
public:
property OptionCollection^ Options {
    OptionCollection^ get ();
}

See Also

Overlay Class
Mincom.LinkOne.Dom Namespace


Page Property

[image]

LinkOne WebView API
Overlay..::.Page Property
Overlay Class See Also Send Feedback
Gets the page associated with this picture.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Page Page { get; internal set; }
Visual Basic (Declaration)
Public Property Page As Page
Visual C++
public:
property Page^ Page {
    Page^ get ();
    void set (Page^ value);
}

See Also

Overlay Class
Mincom.LinkOne.Dom Namespace


PublishedDate Property

[image]

LinkOne WebView API
Overlay..::.PublishedDate Property
Overlay Class See Also Send Feedback
Gets the published date.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public DateTime PublishedDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublishedDate As DateTime
Visual C++
public:
property DateTime PublishedDate {
    DateTime get ();
}

See Also

Overlay Class
Mincom.LinkOne.Dom Namespace


Resource Property

[image]

LinkOne WebView API
Overlay..::.Resource Property
Overlay Class See Also Send Feedback
Gets the binary resource that is the overlay.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Resource Resource { get; }
Visual Basic (Declaration)
Public ReadOnly Property Resource As Resource
Visual C++
public:
property Resource^ Resource {
    Resource^ get ();
}

See Also

Overlay Class
Mincom.LinkOne.Dom Namespace


Top Property

[image]

LinkOne WebView API
Overlay..::.Top Property
Overlay Class See Also Send Feedback
Gets the top offset of the overlay measured from the picture edge.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Top { get; }
Visual Basic (Declaration)
Public ReadOnly Property Top As Integer
Visual C++
public:
property int Top {
    int get ();
}

See Also

Overlay Class
Mincom.LinkOne.Dom Namespace


Width Property

[image]

LinkOne WebView API
Overlay..::.Width Property
Overlay Class See Also Send Feedback
Gets the width of the overlay.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Width { get; }
Visual Basic (Declaration)
Public ReadOnly Property Width As Integer
Visual C++
public:
property int Width {
    int get ();
}

See Also

Overlay Class
Mincom.LinkOne.Dom Namespace


OverlayCollection Class

[image]

LinkOne WebView API
OverlayCollection Class
Members See Also Send Feedback
Represents a collection of Overlay objects that can be accessed by index.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class OverlayCollection : ReadOnlyList<Overlay>
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class OverlayCollection _
    Inherits ReadOnlyList(Of Overlay)
Visual C++
[SerializableAttribute]
public ref class OverlayCollection sealed : public ReadOnlyList<Overlay^>

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.ReadOnlyList <(Of <( Overlay >)>)
Mincom.LinkOne.Dom..::.OverlayCollection

See Also

OverlayCollection Members
Mincom.LinkOne.Dom Namespace


OverlayCollection Members

[image] [image]

LinkOne WebView API
OverlayCollection Members
OverlayCollection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The OverlayCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given object. (Inherited from ReadOnlyList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
InnerList | Gets the inner list. (Inherited from ReadOnlyList<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from ReadOnlyList<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(T>)>).)

See Also

OverlayCollection Class
Mincom.LinkOne.Dom Namespace


OverlayCollection Methods

[image] [image]

LinkOne WebView API
OverlayCollection Methods
OverlayCollection Class See Also Send Feedback

The OverlayCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given object. (Inherited from ReadOnlyList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(T>)>).)

See Also

OverlayCollection Class
Mincom.LinkOne.Dom Namespace


OverlayCollection Properties

[image] [image]

LinkOne WebView API
OverlayCollection Properties
OverlayCollection Class See Also Send Feedback

The OverlayCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
InnerList | Gets the inner list. (Inherited from ReadOnlyList<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from ReadOnlyList<(Of <(T>)>).)

See Also

OverlayCollection Class
Mincom.LinkOne.Dom Namespace


Page Class

[image]

LinkOne WebView API
Page Class
Members See Also Send Feedback
A page of a LinkOne Book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class Page : IPersist, IPage,
    IFilterable, IDisposable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class Page _
    Implements IPersist, IPage, IFilterable, IDisposable
Visual C++
[SerializableAttribute]
public ref class Page sealed : IPersist,
    IPage, IFilterable, IDisposable

Remarks

The Page class uses a lazy load implementation which makes page information available only when it is required. By default, only the header information, such as the page Reference or Title are available in an instance of a page object. When page body information such as the fields or entries of a page are required, then the Page class automatically loads the information on request.

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.Page

See Also

Page Members
Mincom.LinkOne.Dom Namespace


Page Members

[image] [image]

LinkOne WebView API
Page Members
Page Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The Page type exposes the following members.

Constructors

Name | Description
Page | Initializes a new instance of the Page class.

Methods

Name | Description
ApplyFilters | Applies the filters to the filterable objects owned by the page.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
FindEntry | Gets the entry from the page that matches the item id and search result.
GetField | Returns the value of the wanted field.
GetFieldAsVisible | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetResource | Gets the wanted resource.
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PreferredTitle | Get the preferred title for this page, as specified in the supplied layout. If the layout is null, or no preferred title is specified, then the default page title will be returned.
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
Attributes | Gets the attributes associated with the page.
Book | Gets the book associated with this page.
ChildPages | Gets the collection of child pages.
DataObject | Gets the data object associated with the page.
Entries | Gets the entries collection associated with the page.
ExplicitNumber | Gets or sets the page number that has been explicitly set for this page.
Fields | Gets the publisher defined fields associated with the page.
GroupId | Gets or sets the Group Id that the page is associated with.
Location | Gets or sets the location where the page data is stored.
Notes | Gets the notes visible to the page, book, publisher and library.
Number | Gets the page number.
Options | Gets the options collection associated with the page.
Ordinal | Gets the 1-based sequential number of the page.
ParentPages | Gets the collection of parent pages.
Pictures | Gets the pictures collection associated with the page.
PublishedDate | Gets the published date.
Reference | Gets the page reference.
Title | Gets the page title.
Type | Gets the page type.
Values | Gets the values visible to the page, book, publisher and library.

Explicit Interface Implementations

Name | Description
IPage..::.Attributes |
IPage..::.Book |
IPage..::.ChildPages |
IPage..::.DataObject |
IPage..::.Entries |
IPage..::.Fields |
IPage..::.GetField |
IPage..::.Notes |
IFilterable..::.Options |
IPage..::.ParentPages |
IPage..::.Pictures |
IPage..::.Values |

See Also

Page Class
Mincom.LinkOne.Dom Namespace


Page Constructor

[image]

LinkOne WebView API
Page Constructor
Page Class See Also Send Feedback
Initializes a new instance of the Page class.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Page(
    IDomReader domReader
)
Visual Basic (Declaration)
Public Sub New ( _
    domReader As IDomReader _
)
Visual C++
public:
Page(
    IDomReader^ domReader
)

Parameters

domReader
Type: IDomReader
The IDomReader to construct the page. The domReader must be signed by Mincom.

See Also

Page Class
Mincom.LinkOne.Dom Namespace


Page Methods

[image] [image]

LinkOne WebView API
Page Methods
Page Class See Also Send Feedback

The Page type exposes the following members.

Methods

Name | Description
ApplyFilters | Applies the filters to the filterable objects owned by the page.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
FindEntry | Gets the entry from the page that matches the item id and search result.
GetField | Returns the value of the wanted field.
GetFieldAsVisible | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetResource | Gets the wanted resource.
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PreferredTitle | Get the preferred title for this page, as specified in the supplied layout. If the layout is null, or no preferred title is specified, then the default page title will be returned.
ToString | (Overrides Object..::.ToString()()().)

Explicit Interface Implementations

Name | Description
IPage..::.GetField |

See Also

Page Class
Mincom.LinkOne.Dom Namespace


ApplyFilters Method

[image]

LinkOne WebView API
Page..::.ApplyFilters Method
Page Class See Also Send Feedback
Applies the filters to the filterable objects owned by the page.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void ApplyFilters(
    IFilterCollection filters,
    OptionDefinitionCollection optionDefinitions,
    bool allowConsolidation
)
Visual Basic (Declaration)
Public Sub ApplyFilters ( _
    filters As IFilterCollection, _
    optionDefinitions As OptionDefinitionCollection, _
    allowConsolidation As Boolean _
)
Visual C++
public:
void ApplyFilters(
    IFilterCollection^ filters,
    OptionDefinitionCollection^ optionDefinitions,
    bool allowConsolidation
)

Parameters

filters
Type: Mincom.LinkOne.Dom.Filtering..::.IFilterCollection
optionDefinitions
Type: Mincom.LinkOne.Dom.Filtering..::.OptionDefinitionCollection
allowConsolidation
Type: System..::.Boolean

See Also

Page Class
Mincom.LinkOne.Dom Namespace


Dispose Method

[image]

LinkOne WebView API
Page..::.Dispose Method
Page Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

Page Class
Mincom.LinkOne.Dom Namespace


FindEntry Method

[image]

LinkOne WebView API
Page..::.FindEntry Method
Page Class See Also Send Feedback
Gets the entry from the page that matches the item id and search result.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Entry FindEntry(
    string itemId,
    KeyValuePair<string, string>[] matches
)
Visual Basic (Declaration)
Public Function FindEntry ( _
    itemId As String, _
    matches As KeyValuePair(Of String, String)() _
) As Entry
Visual C++
public:
Entry^ FindEntry(
    String^ itemId,
    array<KeyValuePair<String^, String^>>^ matches
)

Parameters

itemId
Type: System..::.String
The item id of the entry
matches
Type: array< System.Collections.Generic..::.KeyValuePair<(Of <(String, String>)>) >[]()[]
An array of key value pairs, where the key is the field name, and the value is the string to match.

Return Value

An Entry if a match is found; otherwise, null.

Remarks

Special field processing as specified by each field's search index is applied to the entry field.

Exceptions

Exception | Condition
System..::.ArgumentNullException | matches is null.

See Also

Page Class
Mincom.LinkOne.Dom Namespace


GetField Method

[image]

LinkOne WebView API
Page..::.GetField Method
Page Class See Also Send Feedback
Returns the value of the wanted field.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string GetField(
    string name
)
Visual Basic (Declaration)
Public Function GetField ( _
    name As String _
) As String
Visual C++
public:
String^ GetField(
    String^ name
)

Parameters

name
Type: System..::.String
Name of the wanted field.

Return Value

The value of the wanted field, or blank if not found.

See Also

Page Class
Mincom.LinkOne.Dom Namespace


GetFieldAsVisible Method

[image] [image]

LinkOne WebView API
Page..::.GetFieldAsVisible Method
Page Class See Also Send Feedback

Overload List

Name | Description
GetFieldAsVisible(String) | Returns the visible value of the wanted field.
GetFieldAsVisible(String, String) | Returns the visible value of the wanted field.

See Also

Page Class
Page Members
Mincom.LinkOne.Dom Namespace


GetFieldAsVisible Method (String)

[image]

LinkOne WebView API
Page..::.GetFieldAsVisible Method (String)
Page Class See Also Send Feedback
Returns the visible value of the wanted field.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string GetFieldAsVisible(
    string name
)
Visual Basic (Declaration)
Public Function GetFieldAsVisible ( _
    name As String _
) As String
Visual C++
public:
String^ GetFieldAsVisible(
    String^ name
)

Parameters

name
Type: System..::.String
Name of the wanted field.

Return Value

The visible value of the wanted field, or blank if not found.

See Also

Page Class
GetFieldAsVisible Overload
Mincom.LinkOne.Dom Namespace


GetFieldAsVisible Method (String, String)

[image]

LinkOne WebView API
Page..::.GetFieldAsVisible Method (String, String)
Page Class See Also Send Feedback
Returns the visible value of the wanted field.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string GetFieldAsVisible(
    string name,
    string preferredListTitle
)
Visual Basic (Declaration)
Public Function GetFieldAsVisible ( _
    name As String, _
    preferredListTitle As String _
) As String
Visual C++
public:
String^ GetFieldAsVisible(
    String^ name,
    String^ preferredListTitle
)

Parameters

name
Type: System..::.String
Name of the wanted field.
preferredListTitle
Type: System..::.String
The preferred list title list field or blank.

Return Value

The visible value of the wanted field, or blank if not found.

See Also

Page Class
GetFieldAsVisible Overload
Mincom.LinkOne.Dom Namespace


GetResource Method

[image]

LinkOne WebView API
Page..::.GetResource Method
Page Class See Also Send Feedback
Gets the wanted resource.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Resource GetResource(
    string resourceReference
)
Visual Basic (Declaration)
Public Function GetResource ( _
    resourceReference As String _
) As Resource
Visual C++
public:
Resource^ GetResource(
    String^ resourceReference
)

Parameters

resourceReference
Type: System..::.String
Reference of the wanted resource.

Return Value

The wanted resource, or null if the resource was not found.

See Also

Page Class
Mincom.LinkOne.Dom Namespace


IPage.GetField Method

[image]

LinkOne WebView API
Page..::.IPage..::.GetField Method
Page Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string IPage.GetField(
    string name
)
Visual Basic (Declaration)
Private Function GetField ( _
    name As String _
) As String Implements IPage.GetField
Visual C++
private:
virtual String^ GetField(
    String^ name
) sealed = IPage::GetField

Parameters

name
Type: System..::.String

Implements

IPage..::.GetField(String)

See Also

Page Class
Mincom.LinkOne.Dom Namespace


PreferredTitle Method

[image]

LinkOne WebView API
Page..::.PreferredTitle Method
Page Class See Also Send Feedback
Get the preferred title for this page, as specified in the supplied layout. If the layout is null, or no preferred title is specified, then the default page title will be returned.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PreferredTitle(
    string preferredListTitle
)
Visual Basic (Declaration)
Public Function PreferredTitle ( _
    preferredListTitle As String _
) As String
Visual C++
public:
String^ PreferredTitle(
    String^ preferredListTitle
)

Parameters

preferredListTitle
Type: System..::.String
The preferred list title.

Return Value

The preferred title for this page.

See Also

Page Class
Mincom.LinkOne.Dom Namespace


ToString Method

[image]

LinkOne WebView API
Page..::.ToString Method
Page Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

Page Class
Mincom.LinkOne.Dom Namespace


Page Properties

[image] [image]

LinkOne WebView API
Page Properties
Page Class See Also Send Feedback

The Page type exposes the following members.

Properties

Name | Description
Attributes | Gets the attributes associated with the page.
Book | Gets the book associated with this page.
ChildPages | Gets the collection of child pages.
DataObject | Gets the data object associated with the page.
Entries | Gets the entries collection associated with the page.
ExplicitNumber | Gets or sets the page number that has been explicitly set for this page.
Fields | Gets the publisher defined fields associated with the page.
GroupId | Gets or sets the Group Id that the page is associated with.
Location | Gets or sets the location where the page data is stored.
Notes | Gets the notes visible to the page, book, publisher and library.
Number | Gets the page number.
Options | Gets the options collection associated with the page.
Ordinal | Gets the 1-based sequential number of the page.
ParentPages | Gets the collection of parent pages.
Pictures | Gets the pictures collection associated with the page.
PublishedDate | Gets the published date.
Reference | Gets the page reference.
Title | Gets the page title.
Type | Gets the page type.
Values | Gets the values visible to the page, book, publisher and library.

Explicit Interface Implementations

Name | Description
IPage..::.Attributes |
IPage..::.Book |
IPage..::.ChildPages |
IPage..::.DataObject |
IPage..::.Entries |
IPage..::.Fields |
IPage..::.Notes |
IFilterable..::.Options |
IPage..::.ParentPages |
IPage..::.Pictures |
IPage..::.Values |

See Also

Page Class
Mincom.LinkOne.Dom Namespace


Attributes Property

[image]

LinkOne WebView API
Page..::.Attributes Property
Page Class See Also Send Feedback
Gets the attributes associated with the page.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PageAttributeCollection Attributes { get; }
Visual Basic (Declaration)
Public ReadOnly Property Attributes As PageAttributeCollection
Visual C++
public:
property PageAttributeCollection^ Attributes {
    PageAttributeCollection^ get ();
}

See Also

Page Class
Mincom.LinkOne.Dom Namespace


Book Property

[image]

LinkOne WebView API
Page..::.Book Property
Page Class See Also Send Feedback
Gets the book associated with this page.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Book Book { get; internal set; }
Visual Basic (Declaration)
Public Property Book As Book
Visual C++
public:
property Book^ Book {
    Book^ get ();
    void set (Book^ value);
}

See Also

Page Class
Mincom.LinkOne.Dom Namespace


ChildPages Property

[image]

LinkOne WebView API
Page..::.ChildPages Property
Page Class See Also Send Feedback
Gets the collection of child pages.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PageCollection ChildPages { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChildPages As PageCollection
Visual C++
public:
property PageCollection^ ChildPages {
    PageCollection^ get ();
}

See Also

Page Class
Mincom.LinkOne.Dom Namespace


DataObject Property

[image]

LinkOne WebView API
Page..::.DataObject Property
Page Class See Also Send Feedback
Gets the data object associated with the page.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public DataObject DataObject { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataObject As DataObject
Visual C++
public:
property DataObject^ DataObject {
    DataObject^ get ();
}

See Also

Page Class
Mincom.LinkOne.Dom Namespace


Entries Property

[image]

LinkOne WebView API
Page..::.Entries Property
Page Class See Also Send Feedback
Gets the entries collection associated with the page.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public EntryCollection Entries { get; }
Visual Basic (Declaration)
Public ReadOnly Property Entries As EntryCollection
Visual C++
public:
property EntryCollection^ Entries {
    EntryCollection^ get ();
}

See Also

Page Class
Mincom.LinkOne.Dom Namespace


ExplicitNumber Property

[image]

LinkOne WebView API
Page..::.ExplicitNumber Property
Page Class See Also Send Feedback
Gets or sets the page number that has been explicitly set for this page.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string ExplicitNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExplicitNumber As String
Visual C++
public:
property String^ ExplicitNumber {
    String^ get ();
}

See Also

Page Class
Mincom.LinkOne.Dom Namespace


Fields Property

[image]

LinkOne WebView API
Page..::.Fields Property
Page Class See Also Send Feedback
Gets the publisher defined fields associated with the page.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public FieldCollection Fields { get; }
Visual Basic (Declaration)
Public ReadOnly Property Fields As FieldCollection
Visual C++
public:
property FieldCollection^ Fields {
    FieldCollection^ get ();
}

See Also

Page Class
Mincom.LinkOne.Dom Namespace


GroupId Property

[image]

LinkOne WebView API
Page..::.GroupId Property
Page Class See Also Send Feedback
Gets or sets the Group Id that the page is associated with.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string GroupId { get; }
Visual Basic (Declaration)
Public ReadOnly Property GroupId As String
Visual C++
public:
virtual property String^ GroupId {
    String^ get () sealed;
}

Implements

IPage..::.GroupId

See Also

Page Class
Mincom.LinkOne.Dom Namespace


IFilterable.Options Property

[image]

LinkOne WebView API
Page..::.IFilterable..::.Options Property
Page Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IOptionCollection IFilterable.Options { get; }
Visual Basic (Declaration)
Private ReadOnly Property Options As IOptionCollection
    Implements IFilterable.Options
Visual C++
private:
virtual property IOptionCollection^ Options {
    IOptionCollection^ get () sealed = IFilterable::Options::get;
}

Implements

IFilterable..::.Options

See Also

Page Class
Mincom.LinkOne.Dom Namespace


IPage.Attributes Property

[image]

LinkOne WebView API
Page..::.IPage..::.Attributes Property
Page Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IAttributeCollection IPage.Attributes { get; }
Visual Basic (Declaration)
Private ReadOnly Property Attributes As IAttributeCollection
    Implements IPage.Attributes
Visual C++
private:
virtual property IAttributeCollection^ Attributes {
    IAttributeCollection^ get () sealed = IPage::Attributes::get;
}

Implements

IPage..::.Attributes

See Also

Page Class
Mincom.LinkOne.Dom Namespace


IPage.Book Property

[image]

LinkOne WebView API
Page..::.IPage..::.Book Property
Page Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IBook IPage.Book { get; }
Visual Basic (Declaration)
Private ReadOnly Property Book As IBook
    Implements IPage.Book
Visual C++
private:
virtual property IBook^ Book {
    IBook^ get () sealed = IPage::Book::get;
}

Implements

IPage..::.Book

See Also

Page Class
Mincom.LinkOne.Dom Namespace


IPage.ChildPages Property

[image]

LinkOne WebView API
Page..::.IPage..::.ChildPages Property
Page Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPageCollection IPage.ChildPages { get; }
Visual Basic (Declaration)
Private ReadOnly Property ChildPages As IPageCollection
    Implements IPage.ChildPages
Visual C++
private:
virtual property IPageCollection^ ChildPages {
    IPageCollection^ get () sealed = IPage::ChildPages::get;
}

Implements

IPage..::.ChildPages

See Also

Page Class
Mincom.LinkOne.Dom Namespace


IPage.DataObject Property

[image]

LinkOne WebView API
Page..::.IPage..::.DataObject Property
Page Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDataObject IPage.DataObject { get; }
Visual Basic (Declaration)
Private ReadOnly Property DataObject As IDataObject
    Implements IPage.DataObject
Visual C++
private:
virtual property IDataObject^ DataObject {
    IDataObject^ get () sealed = IPage::DataObject::get;
}

Implements

IPage..::.DataObject

See Also

Page Class
Mincom.LinkOne.Dom Namespace


IPage.Entries Property

[image]

LinkOne WebView API
Page..::.IPage..::.Entries Property
Page Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEntryCollection IPage.Entries { get; }
Visual Basic (Declaration)
Private ReadOnly Property Entries As IEntryCollection
    Implements IPage.Entries
Visual C++
private:
virtual property IEntryCollection^ Entries {
    IEntryCollection^ get () sealed = IPage::Entries::get;
}

Implements

IPage..::.Entries

See Also

Page Class
Mincom.LinkOne.Dom Namespace


IPage.Fields Property

[image]

LinkOne WebView API
Page..::.IPage..::.Fields Property
Page Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IFieldCollection IPage.Fields { get; }
Visual Basic (Declaration)
Private ReadOnly Property Fields As IFieldCollection
    Implements IPage.Fields
Visual C++
private:
virtual property IFieldCollection^ Fields {
    IFieldCollection^ get () sealed = IPage::Fields::get;
}

Implements

IPage..::.Fields

See Also

Page Class
Mincom.LinkOne.Dom Namespace


IPage.Notes Property

[image]

LinkOne WebView API
Page..::.IPage..::.Notes Property
Page Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
INoteCollection IPage.Notes { get; }
Visual Basic (Declaration)
Private ReadOnly Property Notes As INoteCollection
    Implements IPage.Notes
Visual C++
private:
virtual property INoteCollection^ Notes {
    INoteCollection^ get () sealed = IPage::Notes::get;
}

Implements

IPage..::.Notes

See Also

Page Class
Mincom.LinkOne.Dom Namespace


IPage.ParentPages Property

[image]

LinkOne WebView API
Page..::.IPage..::.ParentPages Property
Page Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPageCollection IPage.ParentPages { get; }
Visual Basic (Declaration)
Private ReadOnly Property ParentPages As IPageCollection
    Implements IPage.ParentPages
Visual C++
private:
virtual property IPageCollection^ ParentPages {
    IPageCollection^ get () sealed = IPage::ParentPages::get;
}

Implements

IPage..::.ParentPages

See Also

Page Class
Mincom.LinkOne.Dom Namespace


IPage.Pictures Property

[image]

LinkOne WebView API
Page..::.IPage..::.Pictures Property
Page Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPictureCollection IPage.Pictures { get; }
Visual Basic (Declaration)
Private ReadOnly Property Pictures As IPictureCollection
    Implements IPage.Pictures
Visual C++
private:
virtual property IPictureCollection^ Pictures {
    IPictureCollection^ get () sealed = IPage::Pictures::get;
}

Implements

IPage..::.Pictures

See Also

Page Class
Mincom.LinkOne.Dom Namespace


IPage.Values Property

[image]

LinkOne WebView API
Page..::.IPage..::.Values Property
Page Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IValueCollection IPage.Values { get; }
Visual Basic (Declaration)
Private ReadOnly Property Values As IValueCollection
    Implements IPage.Values
Visual C++
private:
virtual property IValueCollection^ Values {
    IValueCollection^ get () sealed = IPage::Values::get;
}

Implements

IPage..::.Values

See Also

Page Class
Mincom.LinkOne.Dom Namespace


Location Property

[image]

LinkOne WebView API
Page..::.Location Property
Page Class See Also Send Feedback
Gets or sets the location where the page data is stored.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Location { get; }
Visual Basic (Declaration)
Public ReadOnly Property Location As String
Visual C++
public:
property String^ Location {
    String^ get ();
}

See Also

Page Class
Mincom.LinkOne.Dom Namespace


Notes Property

[image]

LinkOne WebView API
Page..::.Notes Property
Page Class See Also Send Feedback
Gets the notes visible to the page, book, publisher and library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public NoteCollection Notes { get; }
Visual Basic (Declaration)
Public ReadOnly Property Notes As NoteCollection
Visual C++
public:
property NoteCollection^ Notes {
    NoteCollection^ get ();
}

See Also

Page Class
Mincom.LinkOne.Dom Namespace


Number Property

[image]

LinkOne WebView API
Page..::.Number Property
Page Class See Also Send Feedback
Gets the page number.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Number { get; }
Visual Basic (Declaration)
Public ReadOnly Property Number As String
Visual C++
public:
virtual property String^ Number {
    String^ get () sealed;
}

Implements

IPage..::.Number

See Also

Page Class
Mincom.LinkOne.Dom Namespace


Options Property

[image]

LinkOne WebView API
Page..::.Options Property
Page Class See Also Send Feedback
Gets the options collection associated with the page.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public OptionCollection Options { get; }
Visual Basic (Declaration)
Public ReadOnly Property Options As OptionCollection
Visual C++
public:
property OptionCollection^ Options {
    OptionCollection^ get ();
}

See Also

Page Class
Mincom.LinkOne.Dom Namespace


Ordinal Property

[image]

LinkOne WebView API
Page..::.Ordinal Property
Page Class See Also Send Feedback
Gets the 1-based sequential number of the page.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Ordinal { get; internal set; }
Visual Basic (Declaration)
Public Property Ordinal As Integer
Visual C++
public:
property int Ordinal {
    int get ();
    void set (int value);
}

See Also

Page Class
Mincom.LinkOne.Dom Namespace


ParentPages Property

[image]

LinkOne WebView API
Page..::.ParentPages Property
Page Class See Also Send Feedback
Gets the collection of parent pages.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PageCollection ParentPages { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParentPages As PageCollection
Visual C++
public:
property PageCollection^ ParentPages {
    PageCollection^ get ();
}

See Also

Page Class
Mincom.LinkOne.Dom Namespace


Pictures Property

[image]

LinkOne WebView API
Page..::.Pictures Property
Page Class See Also Send Feedback
Gets the pictures collection associated with the page.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PictureCollection Pictures { get; }
Visual Basic (Declaration)
Public ReadOnly Property Pictures As PictureCollection
Visual C++
public:
property PictureCollection^ Pictures {
    PictureCollection^ get ();
}

See Also

Page Class
Mincom.LinkOne.Dom Namespace


PublishedDate Property

[image]

LinkOne WebView API
Page..::.PublishedDate Property
Page Class See Also Send Feedback
Gets the published date.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public DateTime PublishedDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublishedDate As DateTime
Visual C++
public:
property DateTime PublishedDate {
    DateTime get ();
}

See Also

Page Class
Mincom.LinkOne.Dom Namespace


Reference Property

[image]

LinkOne WebView API
Page..::.Reference Property
Page Class See Also Send Feedback
Gets the page reference.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Reference { get; }
Visual Basic (Declaration)
Public ReadOnly Property Reference As String
Visual C++
public:
virtual property String^ Reference {
    String^ get () sealed;
}

Implements

IPage..::.Reference

See Also

Page Class
Mincom.LinkOne.Dom Namespace


Title Property

[image]

LinkOne WebView API
Page..::.Title Property
Page Class See Also Send Feedback
Gets the page title.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Title { get; }
Visual Basic (Declaration)
Public ReadOnly Property Title As String
Visual C++
public:
virtual property String^ Title {
    String^ get () sealed;
}

Implements

IPage..::.Title

See Also

Page Class
Mincom.LinkOne.Dom Namespace


Type Property

[image]

LinkOne WebView API
Page..::.Type Property
Page Class See Also Send Feedback
Gets the page type.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PageType Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As PageType
Visual C++
public:
virtual property PageType Type {
    PageType get () sealed;
}

Implements

IPage..::.Type

See Also

Page Class
Mincom.LinkOne.Dom Namespace


Values Property

[image]

LinkOne WebView API
Page..::.Values Property
Page Class See Also Send Feedback
Gets the values visible to the page, book, publisher and library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ValueCollection Values { get; }
Visual Basic (Declaration)
Public ReadOnly Property Values As ValueCollection
Visual C++
public:
property ValueCollection^ Values {
    ValueCollection^ get ();
}

See Also

Page Class
Mincom.LinkOne.Dom Namespace


PageCollection Class

[image]

LinkOne WebView API
PageCollection Class
Members See Also Send Feedback
Represents a collection of Page objects that can be accessed by index, or page reference.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class PageCollection : IReadOnlyKeyedCollection<string, Page>,
    IReadOnlyList<Page>, IReadOnlyCollection<Page>, IEnumerable<Page>,
    IPageCollection, IReadOnlyKeyedCollection<string, IPage>, IReadOnlyList<IPage>,
    IReadOnlyCollection<IPage>, IEnumerable<IPage>, IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class PageCollection _
    Implements IReadOnlyKeyedCollection(Of String, Page),  _
    IReadOnlyList(Of Page), IReadOnlyCollection(Of Page), IEnumerable(Of Page),  _
    IPageCollection, IReadOnlyKeyedCollection(Of String, IPage), IReadOnlyList(Of IPage),  _
    IReadOnlyCollection(Of IPage), IEnumerable(Of IPage), IEnumerable
Visual C++
[SerializableAttribute]
public ref class PageCollection sealed : IReadOnlyKeyedCollection<String^, Page^>,
    IReadOnlyList<Page^>, IReadOnlyCollection<Page^>, IEnumerable<Page^>,
    IPageCollection, IReadOnlyKeyedCollection<String^, IPage^>, IReadOnlyList<IPage^>,
    IReadOnlyCollection<IPage^>, IEnumerable<IPage^>, IEnumerable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.PageCollection

See Also

PageCollection Members
Mincom.LinkOne.Dom Namespace


PageCollection Members

[image] [image]

LinkOne WebView API
PageCollection Members
PageCollection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The PageCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
CopyTo | Copies the entire PageCollection to a compatible one-dimensional array, starting at the specified index.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given page object.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements in the collection.
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(IPage>)>)..::.Contains |
IEnumerable<(Of <(IPage>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.
IReadOnlyList<(Of <(IPage>)>)..::.IndexOf |
IReadOnlyKeyedCollection<(Of <(String, IPage>)>)..::.Item |
IReadOnlyList<(Of <(IPage>)>)..::.Item |

See Also

PageCollection Class
Mincom.LinkOne.Dom Namespace


PageCollection Methods

[image] [image]

LinkOne WebView API
PageCollection Methods
PageCollection Class See Also Send Feedback

The PageCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
CopyTo | Copies the entire PageCollection to a compatible one-dimensional array, starting at the specified index.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given page object.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(IPage>)>)..::.Contains |
IEnumerable<(Of <(IPage>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.
IReadOnlyList<(Of <(IPage>)>)..::.IndexOf |

See Also

PageCollection Class
Mincom.LinkOne.Dom Namespace


IEnumerable(IPage).GetEnumerator Method

[image]

LinkOne WebView API
PageCollection..::.IEnumerable<(Of <(IPage>)>)..::.GetEnumerator Method
PageCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator<IPage> IEnumerable<IPage>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of IPage)
    Implements IEnumerable(Of IPage).GetEnumerator
Visual C++
private:
virtual IEnumerator<IPage^>^ GetEnumerator() sealed = IEnumerable<IPage^>::GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

PageCollection Class
Mincom.LinkOne.Dom Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
PageCollection..::.IEnumerable..::.GetEnumerator Method
PageCollection Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

PageCollection Class
Mincom.LinkOne.Dom Namespace


Contains Method

[image] [image]

LinkOne WebView API
PageCollection..::.Contains Method
PageCollection Class See Also Send Feedback

Overload List

Name | Description
Contains(Page) | Determines whether a page is in the collection.
Contains(String) | Determines whether there is a page in the collection with the given reference.

See Also

PageCollection Class
PageCollection Members
Mincom.LinkOne.Dom Namespace


Contains Method (Page)

[image]

LinkOne WebView API
PageCollection..::.Contains Method (Page)
PageCollection Class See Also Send Feedback
Determines whether a page is in the collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    Page item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As Page _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Page^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Dom..::.Page
The page object to search for.

Return Value

true if found in the collection, otherwise, false.

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Contains(T)

See Also

PageCollection Class
Contains Overload
Mincom.LinkOne.Dom Namespace


Contains Method (String)

[image]

LinkOne WebView API
PageCollection..::.Contains Method (String)
PageCollection Class See Also Send Feedback
Determines whether there is a page in the collection with the given reference.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    string key
)
Visual Basic (Declaration)
Public Function Contains ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ key
) sealed

Parameters

key
Type: System..::.String
The reference of the page to find.

Return Value

true if a page is found; otherwise, false.

Implements

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Contains(TKey)
IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Contains(TKey)

See Also

PageCollection Class
Contains Overload
Mincom.LinkOne.Dom Namespace


CopyTo Method

[image]

LinkOne WebView API
PageCollection..::.CopyTo Method
PageCollection Class See Also Send Feedback
Copies the entire PageCollection to a compatible one-dimensional array, starting at the specified index.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void CopyTo(
    Page[] pages,
    int arrayIndex
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    pages As Page(), _
    arrayIndex As Integer _
)
Visual C++
public:
void CopyTo(
    array<Page^>^ pages,
    int arrayIndex
)

Parameters

pages
Type: array< Mincom.LinkOne.Dom..::.Page >[]()[]
The destination array of pages.
arrayIndex
Type: System..::.Int32
The index to start inserting.

See Also

PageCollection Class
Mincom.LinkOne.Dom Namespace


GetEnumerator Method

[image]

LinkOne WebView API
PageCollection..::.GetEnumerator Method
PageCollection Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IEnumerator<Page> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of Page)
Visual C++
public:
virtual IEnumerator<Page^>^ GetEnumerator() sealed

Return Value

A IEnumerator<(Of <(T>)>) that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

PageCollection Class
Mincom.LinkOne.Dom Namespace


IndexOf Method

[image]

LinkOne WebView API
PageCollection..::.IndexOf Method
PageCollection Class See Also Send Feedback
Searches the collection and returns the zero-based index of the first occurence of the given page object.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int IndexOf(
    Page item
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    item As Page _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Page^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Dom..::.Page
The page object to search for.

Return Value

The zero-based index of the page object in the collection, if found; otherwise, -1.

Implements

IReadOnlyList<(Of <(T>)>)..::.IndexOf(T)

See Also

PageCollection Class
Mincom.LinkOne.Dom Namespace


IReadOnlyCollection(IPage).Contains Method

[image]

LinkOne WebView API
PageCollection..::.IReadOnlyCollection<(Of <(IPage>)>)..::.Contains Method
PageCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IReadOnlyCollection<IPage>.Contains(
    IPage domObject
)
Visual Basic (Declaration)
Private Function Contains ( _
    domObject As IPage _
) As Boolean Implements IReadOnlyCollection(Of IPage).Contains
Visual C++
private:
virtual bool Contains(
    IPage^ domObject
) sealed = IReadOnlyCollection<IPage^>::Contains

Parameters

domObject
Type: Mincom.LinkOne.Dom..::.IPage

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Contains(T)

See Also

PageCollection Class
Mincom.LinkOne.Dom Namespace


IReadOnlyList(IPage).IndexOf Method

[image]

LinkOne WebView API
PageCollection..::.IReadOnlyList<(Of <(IPage>)>)..::.IndexOf Method
PageCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int IReadOnlyList<IPage>.IndexOf(
    IPage domObject
)
Visual Basic (Declaration)
Private Function IndexOf ( _
    domObject As IPage _
) As Integer Implements IReadOnlyList(Of IPage).IndexOf
Visual C++
private:
virtual int IndexOf(
    IPage^ domObject
) sealed = IReadOnlyList<IPage^>::IndexOf

Parameters

domObject
Type: Mincom.LinkOne.Dom..::.IPage

Implements

IReadOnlyList<(Of <(T>)>)..::.IndexOf(T)

See Also

PageCollection Class
Mincom.LinkOne.Dom Namespace


PageCollection Properties

[image] [image]

LinkOne WebView API
PageCollection Properties
PageCollection Class See Also Send Feedback

The PageCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection.
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IReadOnlyKeyedCollection<(Of <(String, IPage>)>)..::.Item |
IReadOnlyList<(Of <(IPage>)>)..::.Item |

See Also

PageCollection Class
Mincom.LinkOne.Dom Namespace


Count Property

[image]

LinkOne WebView API
PageCollection..::.Count Property
PageCollection Class See Also Send Feedback
Gets the number of elements in the collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Count
IReadOnlyCollection<(Of <(T>)>)..::.Count

See Also

PageCollection Class
Mincom.LinkOne.Dom Namespace


IReadOnlyKeyedCollection(String, IPage).Item Property

[image]

LinkOne WebView API
PageCollection..::.IReadOnlyKeyedCollection<(Of <(String, IPage>)>)..::.Item Property
PageCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPage IReadOnlyKeyedCollection<string, IPage>.Item[
    string domObjectKey
] { get; }
Visual Basic (Declaration)
Private ReadOnly Property Item ( _
    domObjectKey As String _
) As IPage Implements IReadOnlyKeyedCollection(Of String, IPage).Item
Visual C++
private:
virtual property IPage^ Item[String^ domObjectKey] {
    IPage^ get (String^ domObjectKey) sealed = IReadOnlyKeyedCollection<String^, IPage^>::Item::get;
}

Parameters

domObjectKey
Type: System..::.String

Implements

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Item[([(TKey])])

See Also

PageCollection Class
Mincom.LinkOne.Dom Namespace


IReadOnlyList(IPage).Item Property

[image]

LinkOne WebView API
PageCollection..::.IReadOnlyList<(Of <(IPage>)>)..::.Item Property
PageCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPage IReadOnlyList<IPage>.Item[
    int index
] { get; }
Visual Basic (Declaration)
Private ReadOnly Property Item ( _
    index As Integer _
) As IPage Implements IReadOnlyList(Of IPage).Item
Visual C++
private:
virtual property IPage^ Item[int index] {
    IPage^ get (int index) sealed = IReadOnlyList<IPage^>::Item::get;
}

Parameters

index
Type: System..::.Int32

Implements

IReadOnlyList<(Of <(T>)>)..::.Item[([(Int32])])

See Also

PageCollection Class
Mincom.LinkOne.Dom Namespace


Item Property

[image] [image]

LinkOne WebView API
PageCollection..::.Item Property
PageCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Gets the Page at the specified index.
Item[([(String])]) | Gets the page with the given reference.

See Also

PageCollection Class
PageCollection Members
Mincom.LinkOne.Dom Namespace


Item Property (Int32)

[image]

LinkOne WebView API
PageCollection..::.Item Property (Int32)
PageCollection Class See Also Send Feedback
Gets the Page at the specified index.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Page this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Page
Visual C++
public:
virtual property Page^ default[int index] {
    Page^ get (int index) sealed;
}

Parameters

index
Type: System..::.Int32

Implements

IReadOnlyList<(Of <(T>)>)..::.Item[([(Int32])])

See Also

PageCollection Class
Item Overload
Mincom.LinkOne.Dom Namespace


Item Property (String)

[image]

LinkOne WebView API
PageCollection..::.Item Property (String)
PageCollection Class See Also Send Feedback
Gets the page with the given reference.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Page this[
    string key
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    key As String _
) As Page
Visual C++
public:
virtual property Page^ default[String^ key] {
    Page^ get (String^ key) sealed;
}

Parameters

key
Type: System..::.String
The reference of the page to get.

Return Value

The page with the specified reference, if found; otherwise, null.

Implements

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Item[([(TKey])])

See Also

PageCollection Class
Item Overload
Mincom.LinkOne.Dom Namespace


PageType Enumeration

[image]

LinkOne WebView API
PageType Enumeration
See Also Send Feedback
Describes the content of the page.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum PageType
Visual Basic (Declaration)
Public Enumeration PageType
Visual C++
public enum class PageType

Members

Member name | Description
Empty | The page is empty.
PartsList | The page contains a parts list.
EmbeddedFile | The page contains an embedded file.

See Also

Mincom.LinkOne.Dom Namespace


PersistIdentity Class

[image]

LinkOne WebView API
PersistIdentity Class
Members See Also Send Feedback
Identifies the wanted item during an IPersistProver.Read() call.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class PersistIdentity : IPersistIdentity
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class PersistIdentity _
    Implements IPersistIdentity
Visual C++
[SerializableAttribute]
public ref class PersistIdentity sealed : IPersistIdentity

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.PersistIdentity

See Also

PersistIdentity Members
Mincom.LinkOne.Dom Namespace


PersistIdentity Members

[image] [image]

LinkOne WebView API
PersistIdentity Members
PersistIdentity Class Methods Properties See Also Send Feedback

The PersistIdentity type exposes the following members.

Methods

Name | Description
Book | Helper function to create a PersistIdentity identifying a book.
Categories | Overloaded.
Equals | Tests whether the specified object is a PersistIdentity class and is equivalent to this object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. Returns a hash code for this object. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the type of the current instance. (Inherited from Object.)
Library | Helper function to create a PersistIdentity identifying a library.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Note | Helper function to create a PersistIdentity identifying a note.
Notes | Overloaded.
Page | Helper function to create a PersistIdentity identifying a page.
Publisher | Helper function to create a PersistIdentity identifying a publisher.
Resource | Overloaded.
SearchFieldMap | Overloaded.
ToString | Converts the identity to a string. (Overrides Object..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two PersistIdentity objects are equivalent.
Inequality | Tests whether two PersistIdentity objects are different.

Properties

Name | Description
BookCode | Gets the book code.
FieldName | Gets the field name.
FieldType | Gets the field type.
Filters | Gets the filters to apply.
ItemId | Gets the note item id.
Location | Gets the location.
MasterBookCode | Gets the master book code.
NoteAccess | Gets the note access;
NoteId | Gets the note Id.
PageReference | Gets the page reference.
PictureNumber | Gets the note picture number.
PictureReference | Gets the picture reference.
Principal | Gets the principal.
PublisherCode | Gets the publisher code.
ResourceReference | Gets the resource reference.
Type | Gets the type of the persist object.

See Also

PersistIdentity Class
Mincom.LinkOne.Dom Namespace


PersistIdentity Methods

[image] [image]

LinkOne WebView API
PersistIdentity Methods
PersistIdentity Class See Also Send Feedback

The PersistIdentity type exposes the following members.

Methods

Name | Description
Book | Helper function to create a PersistIdentity identifying a book.
Categories | Overloaded.
Equals | Tests whether the specified object is a PersistIdentity class and is equivalent to this object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. Returns a hash code for this object. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the type of the current instance. (Inherited from Object.)
Library | Helper function to create a PersistIdentity identifying a library.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Note | Helper function to create a PersistIdentity identifying a note.
Notes | Overloaded.
Page | Helper function to create a PersistIdentity identifying a page.
Publisher | Helper function to create a PersistIdentity identifying a publisher.
Resource | Overloaded.
SearchFieldMap | Overloaded.
ToString | Converts the identity to a string. (Overrides Object..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two PersistIdentity objects are equivalent.
Inequality | Tests whether two PersistIdentity objects are different.

See Also

PersistIdentity Class
Mincom.LinkOne.Dom Namespace


Book Method

[image]

LinkOne WebView API
PersistIdentity..::.Book Method
PersistIdentity Class See Also Send Feedback
Helper function to create a PersistIdentity identifying a book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static PersistIdentity Book(
    IPrincipal principal,
    string publisherCode,
    string bookCode
)
Visual Basic (Declaration)
Public Shared Function Book ( _
    principal As IPrincipal, _
    publisherCode As String, _
    bookCode As String _
) As PersistIdentity
Visual C++
public:
static PersistIdentity^ Book(
    IPrincipal^ principal,
    String^ publisherCode,
    String^ bookCode
)

Parameters

principal
Type: Mincom.LinkOne.Dom..::.IPrincipal
The principal.
publisherCode
Type: System..::.String
Publisher code of wanted book.
bookCode
Type: System..::.String
Book code of wanted book.

Return Value

A PersistIdentiy object identifying the required object.

See Also

PersistIdentity Class
Mincom.LinkOne.Dom Namespace


Categories Method

[image] [image]

LinkOne WebView API
PersistIdentity..::.Categories Method
PersistIdentity Class See Also Send Feedback

Overload List

Name | Description
Categories(IPrincipal, String, String) | Helper function to create a PersistIdentity identifying a note category collection.
Categories(IPrincipal, String, String, Access) | Helper function to create a PersistIdentity identifying a note category collection.

See Also

PersistIdentity Class
PersistIdentity Members
Mincom.LinkOne.Dom Namespace


Categories Method (IPrincipal, String, String)

[image]

LinkOne WebView API
PersistIdentity..::.Categories Method (IPrincipal, String, String)
PersistIdentity Class See Also Send Feedback
Helper function to create a PersistIdentity identifying a note category collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static PersistIdentity Categories(
    IPrincipal principal,
    string publisherCode,
    string bookCode
)
Visual Basic (Declaration)
Public Shared Function Categories ( _
    principal As IPrincipal, _
    publisherCode As String, _
    bookCode As String _
) As PersistIdentity
Visual C++
public:
static PersistIdentity^ Categories(
    IPrincipal^ principal,
    String^ publisherCode,
    String^ bookCode
)

Parameters

principal
Type: Mincom.LinkOne.Dom..::.IPrincipal
The principal.
publisherCode
Type: System..::.String
Publisher code for retrieving supplied categories.
bookCode
Type: System..::.String
Book code for retrieving supplied note categories.

Return Value

A PersistIdentity object identifying the required object.

See Also

PersistIdentity Class
Categories Overload
Mincom.LinkOne.Dom Namespace


Categories Method (IPrincipal, String, String, Access)

[image]

LinkOne WebView API
PersistIdentity..::.Categories Method (IPrincipal, String, String, Access)
PersistIdentity Class See Also Send Feedback
Helper function to create a PersistIdentity identifying a note category collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static PersistIdentity Categories(
    IPrincipal principal,
    string publisherCode,
    string bookCode,
    Access noteAccess
)
Visual Basic (Declaration)
Public Shared Function Categories ( _
    principal As IPrincipal, _
    publisherCode As String, _
    bookCode As String, _
    noteAccess As Access _
) As PersistIdentity
Visual C++
public:
static PersistIdentity^ Categories(
    IPrincipal^ principal,
    String^ publisherCode,
    String^ bookCode,
    Access noteAccess
)

Parameters

principal
Type: Mincom.LinkOne.Dom..::.IPrincipal
The principal.
publisherCode
Type: System..::.String
Publisher code for retrieving supplied note categories.
bookCode
Type: System..::.String
Book code for retrieving supplied note categories.
noteAccess
Type: Mincom.LinkOne.Dom.Notes..::.Access
The type of accees of the required note categories.

Return Value

A PersistIdentity object identifying the required object.

See Also

PersistIdentity Class
Categories Overload
Mincom.LinkOne.Dom Namespace


Equality Operator

[image]

LinkOne WebView API
PersistIdentity..::.Equality Operator
PersistIdentity Class See Also Send Feedback
Tests whether two PersistIdentity objects are equivalent.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static bool operator ==(
    PersistIdentity left,
    PersistIdentity right
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    left As PersistIdentity, _
    right As PersistIdentity _
) As Boolean
Visual C++
public:
static bool operator ==(
    PersistIdentity^ left,
    PersistIdentity^ right
)

Parameters

left
Type: Mincom.LinkOne.Dom..::.PersistIdentity
The PersistIdentity to the left of the equality operator.
right
Type: Mincom.LinkOne.Dom..::.PersistIdentity
The PersistIdentity to the right of the equality operator.

Return Value

The operator returns true if the two PersistIdentityobjects are equal; otherwise false.

See Also

PersistIdentity Class
Mincom.LinkOne.Dom Namespace


Equals Method

[image]

LinkOne WebView API
PersistIdentity..::.Equals Method
PersistIdentity Class See Also Send Feedback
Tests whether the specified object is a PersistIdentity class and is equivalent to this object.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The object to test.

Return Value

This method returns true if obj is a PersistIdentity class and equivalent to this object; otherwise, false.

See Also

PersistIdentity Class
Mincom.LinkOne.Dom Namespace


GetHashCode Method

[image]

LinkOne WebView API
PersistIdentity..::.GetHashCode Method
PersistIdentity Class See Also Send Feedback
Overridden. Returns a hash code for this object.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

An integer has code.

See Also

PersistIdentity Class
Mincom.LinkOne.Dom Namespace


Inequality Operator

[image]

LinkOne WebView API
PersistIdentity..::.Inequality Operator
PersistIdentity Class See Also Send Feedback
Tests whether two PersistIdentity objects are different.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static bool operator !=(
    PersistIdentity left,
    PersistIdentity right
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    left As PersistIdentity, _
    right As PersistIdentity _
) As Boolean
Visual C++
public:
static bool operator !=(
    PersistIdentity^ left,
    PersistIdentity^ right
)

Parameters

left
Type: Mincom.LinkOne.Dom..::.PersistIdentity
The PersistIdentity to the left of the inequality operator.
right
Type: Mincom.LinkOne.Dom..::.PersistIdentity
The PersistIdentity to the right of the equality operator.

Return Value

The operator returns true if the two PersistIdentityobjects are different; otherwise false.

See Also

PersistIdentity Class
Mincom.LinkOne.Dom Namespace


Library Method

[image]

LinkOne WebView API
PersistIdentity..::.Library Method
PersistIdentity Class See Also Send Feedback
Helper function to create a PersistIdentity identifying a library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static PersistIdentity Library(
    IPrincipal principal
)
Visual Basic (Declaration)
Public Shared Function Library ( _
    principal As IPrincipal _
) As PersistIdentity
Visual C++
public:
static PersistIdentity^ Library(
    IPrincipal^ principal
)

Parameters

principal
Type: Mincom.LinkOne.Dom..::.IPrincipal
The principal.

Return Value

A PersistIdentiy object identifying the required object.

See Also

PersistIdentity Class
Mincom.LinkOne.Dom Namespace


Note Method

[image]

LinkOne WebView API
PersistIdentity..::.Note Method
PersistIdentity Class See Also Send Feedback
Helper function to create a PersistIdentity identifying a note.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static PersistIdentity Note(
    IPrincipal principal,
    int noteId
)
Visual Basic (Declaration)
Public Shared Function Note ( _
    principal As IPrincipal, _
    noteId As Integer _
) As PersistIdentity
Visual C++
public:
static PersistIdentity^ Note(
    IPrincipal^ principal,
    int noteId
)

Parameters

principal
Type: Mincom.LinkOne.Dom..::.IPrincipal
The principal.
noteId
Type: System..::.Int32
Note Id of wanted note.

Return Value

A PersistIdentiy object identifying the required object.

See Also

PersistIdentity Class
Mincom.LinkOne.Dom Namespace


Notes Method

[image] [image]

LinkOne WebView API
PersistIdentity..::.Notes Method
PersistIdentity Class See Also Send Feedback

Overload List

Name | Description
Notes(IPrincipal, String, String, String, String) | Helper function to create a PersistIdentity identifying a note collection.
Notes(IPrincipal, String, String, String, String, String, Int32, Access) | Helper function to create a PersistIdentity identifying a note collection.

See Also

PersistIdentity Class
PersistIdentity Members
Mincom.LinkOne.Dom Namespace


Notes Method (IPrincipal, String, String, String, String)

[image]

LinkOne WebView API
PersistIdentity..::.Notes Method (IPrincipal, String, String, String, String)
PersistIdentity Class See Also Send Feedback
Helper function to create a PersistIdentity identifying a note collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static PersistIdentity Notes(
    IPrincipal principal,
    string publisherCode,
    string bookCode,
    string masterBookCode,
    string pageReference
)
Visual Basic (Declaration)
Public Shared Function Notes ( _
    principal As IPrincipal, _
    publisherCode As String, _
    bookCode As String, _
    masterBookCode As String, _
    pageReference As String _
) As PersistIdentity
Visual C++
public:
static PersistIdentity^ Notes(
    IPrincipal^ principal,
    String^ publisherCode,
    String^ bookCode,
    String^ masterBookCode,
    String^ pageReference
)

Parameters

principal
Type: Mincom.LinkOne.Dom..::.IPrincipal
The principal.
publisherCode
Type: System..::.String
Publisher code of wanted notes.
bookCode
Type: System..::.String
Book code of wanted notes.
masterBookCode
Type: System..::.String
Master Book code of wanted notes.
pageReference
Type: System..::.String
Page reference of wanted notes.

Return Value

A PersistIdentiy object identifying the required object.

See Also

PersistIdentity Class
Notes Overload
Mincom.LinkOne.Dom Namespace


Notes Method (IPrincipal, String, String, String, String, String, Int32, Access)

[image]

LinkOne WebView API
PersistIdentity..::.Notes Method (IPrincipal, String, String, String, String, String, Int32, Access)
PersistIdentity Class See Also Send Feedback
Helper function to create a PersistIdentity identifying a note collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static PersistIdentity Notes(
    IPrincipal principal,
    string publisherCode,
    string bookCode,
    string masterBookCode,
    string pageReference,
    string itemId,
    int pictureNumber,
    Access noteAccess
)
Visual Basic (Declaration)
Public Shared Function Notes ( _
    principal As IPrincipal, _
    publisherCode As String, _
    bookCode As String, _
    masterBookCode As String, _
    pageReference As String, _
    itemId As String, _
    pictureNumber As Integer, _
    noteAccess As Access _
) As PersistIdentity
Visual C++
public:
static PersistIdentity^ Notes(
    IPrincipal^ principal,
    String^ publisherCode,
    String^ bookCode,
    String^ masterBookCode,
    String^ pageReference,
    String^ itemId,
    int pictureNumber,
    Access noteAccess
)

Parameters

principal
Type: Mincom.LinkOne.Dom..::.IPrincipal
The principal.
publisherCode
Type: System..::.String
The publisher code of the required notes.
bookCode
Type: System..::.String
The book code of the required notes.
masterBookCode
Type: System..::.String
Master Book code of wanted notes.
pageReference
Type: System..::.String
The page reference of the required notes.
itemId
Type: System..::.String
The item id of the required notes.
pictureNumber
Type: System..::.Int32
The picture number.
noteAccess
Type: Mincom.LinkOne.Dom.Notes..::.Access
The type of note accees ot the required notes.

Return Value

A PersistIdentiy object identifying the required object.

See Also

PersistIdentity Class
Notes Overload
Mincom.LinkOne.Dom Namespace


Page Method

[image]

LinkOne WebView API
PersistIdentity..::.Page Method
PersistIdentity Class See Also Send Feedback
Helper function to create a PersistIdentity identifying a page.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static PersistIdentity Page(
    IPrincipal principal,
    string publisherCode,
    string bookCode,
    string pageReference
)
Visual Basic (Declaration)
Public Shared Function Page ( _
    principal As IPrincipal, _
    publisherCode As String, _
    bookCode As String, _
    pageReference As String _
) As PersistIdentity
Visual C++
public:
static PersistIdentity^ Page(
    IPrincipal^ principal,
    String^ publisherCode,
    String^ bookCode,
    String^ pageReference
)

Parameters

principal
Type: Mincom.LinkOne.Dom..::.IPrincipal
The principal.
publisherCode
Type: System..::.String
Publisher code of wanted page.
bookCode
Type: System..::.String
Book code of wanted page.
pageReference
Type: System..::.String
Page reference of wanted page.

Return Value

A PersistIdentiy object identifying the required object.

See Also

PersistIdentity Class
Mincom.LinkOne.Dom Namespace


Publisher Method

[image]

LinkOne WebView API
PersistIdentity..::.Publisher Method
PersistIdentity Class See Also Send Feedback
Helper function to create a PersistIdentity identifying a publisher.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static PersistIdentity Publisher(
    IPrincipal principal,
    string publisherCode
)
Visual Basic (Declaration)
Public Shared Function Publisher ( _
    principal As IPrincipal, _
    publisherCode As String _
) As PersistIdentity
Visual C++
public:
static PersistIdentity^ Publisher(
    IPrincipal^ principal,
    String^ publisherCode
)

Parameters

principal
Type: Mincom.LinkOne.Dom..::.IPrincipal
The principal.
publisherCode
Type: System..::.String
Publisher code of wanted library.

Return Value

A PersistIdentiy object identifying the required object.

See Also

PersistIdentity Class
Mincom.LinkOne.Dom Namespace


Resource Method

[image] [image]

LinkOne WebView API
PersistIdentity..::.Resource Method
PersistIdentity Class See Also Send Feedback

Overload List

Name | Description
Resource(IPrincipal, String, String, String) | Helper function to create a PersistIdentity identifying a book resource.
Resource(IPrincipal, String, String, String, String) | Helper function to create a PersistIdentity identifying a resource.

See Also

PersistIdentity Class
PersistIdentity Members
Mincom.LinkOne.Dom Namespace


Resource Method (IPrincipal, String, String, String)

[image]

LinkOne WebView API
PersistIdentity..::.Resource Method (IPrincipal, String, String, String)
PersistIdentity Class See Also Send Feedback
Helper function to create a PersistIdentity identifying a book resource.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static PersistIdentity Resource(
    IPrincipal principal,
    string publisherCode,
    string bookCode,
    string pictureReference
)
Visual Basic (Declaration)
Public Shared Function Resource ( _
    principal As IPrincipal, _
    publisherCode As String, _
    bookCode As String, _
    pictureReference As String _
) As PersistIdentity
Visual C++
public:
static PersistIdentity^ Resource(
    IPrincipal^ principal,
    String^ publisherCode,
    String^ bookCode,
    String^ pictureReference
)

Parameters

principal
Type: Mincom.LinkOne.Dom..::.IPrincipal
The principal.
publisherCode
Type: System..::.String
The publisher code of the required graphic.
bookCode
Type: System..::.String
The book code of the required graphic.
pictureReference
Type: System..::.String
The reference code of the required graphic.

Return Value

A PersistIdentiy object identifying the required object.

See Also

PersistIdentity Class
Resource Overload
Mincom.LinkOne.Dom Namespace


Resource Method (IPrincipal, String, String, String, String)

[image]

LinkOne WebView API
PersistIdentity..::.Resource Method (IPrincipal, String, String, String, String)
PersistIdentity Class See Also Send Feedback
Helper function to create a PersistIdentity identifying a resource.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static PersistIdentity Resource(
    IPrincipal principal,
    string publisherCode,
    string bookCode,
    string pageReference,
    string resourceReference
)
Visual Basic (Declaration)
Public Shared Function Resource ( _
    principal As IPrincipal, _
    publisherCode As String, _
    bookCode As String, _
    pageReference As String, _
    resourceReference As String _
) As PersistIdentity
Visual C++
public:
static PersistIdentity^ Resource(
    IPrincipal^ principal,
    String^ publisherCode,
    String^ bookCode,
    String^ pageReference,
    String^ resourceReference
)

Parameters

principal
Type: Mincom.LinkOne.Dom..::.IPrincipal
The principal.
publisherCode
Type: System..::.String
Publisher code of wanted resource.
bookCode
Type: System..::.String
Book code of wanted resource.
pageReference
Type: System..::.String
Page reference of wanted resource.
resourceReference
Type: System..::.String
Resource reference of wanted resource.

Return Value

A PersistIdentiy object identifying the required object.

See Also

PersistIdentity Class
Resource Overload
Mincom.LinkOne.Dom Namespace


SearchFieldMap Method

[image] [image]

LinkOne WebView API
PersistIdentity..::.SearchFieldMap Method
PersistIdentity Class See Also Send Feedback

Overload List

Name | Description
SearchFieldMap(IPrincipal, String, String, String) | Helper function to create a PersistIdentity identifying an field map.
SearchFieldMap(IPrincipal, String, String, String, SearchFieldType) | Helper function to create a PersistIdentity identifying an field map.

See Also

PersistIdentity Class
PersistIdentity Members
Mincom.LinkOne.Dom Namespace


SearchFieldMap Method (IPrincipal, String, String, String)

[image]

LinkOne WebView API
PersistIdentity..::.SearchFieldMap Method (IPrincipal, String, String, String)
PersistIdentity Class See Also Send Feedback
Helper function to create a PersistIdentity identifying an field map.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static PersistIdentity SearchFieldMap(
    IPrincipal principal,
    string publisherCode,
    string bookCode,
    string location
)
Visual Basic (Declaration)
Public Shared Function SearchFieldMap ( _
    principal As IPrincipal, _
    publisherCode As String, _
    bookCode As String, _
    location As String _
) As PersistIdentity
Visual C++
public:
static PersistIdentity^ SearchFieldMap(
    IPrincipal^ principal,
    String^ publisherCode,
    String^ bookCode,
    String^ location
)

Parameters

principal
Type: Mincom.LinkOne.Dom..::.IPrincipal
The principal.
publisherCode
Type: System..::.String
Publisher code of wanted field map.
bookCode
Type: System..::.String
Book code of wanted field map.
location
Type: System..::.String
Field location of wanted field map.

Return Value

A PersistIdentiy object identifying the required object.

See Also

PersistIdentity Class
SearchFieldMap Overload
Mincom.LinkOne.Dom Namespace


SearchFieldMap Method (IPrincipal, String, String, String, SearchFieldType)

[image]

LinkOne WebView API
PersistIdentity..::.SearchFieldMap Method (IPrincipal, String, String, String, SearchFieldType)
PersistIdentity Class See Also Send Feedback
Helper function to create a PersistIdentity identifying an field map.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static PersistIdentity SearchFieldMap(
    IPrincipal principal,
    string publisherCode,
    string bookCode,
    string fieldName,
    SearchFieldType fieldType
)
Visual Basic (Declaration)
Public Shared Function SearchFieldMap ( _
    principal As IPrincipal, _
    publisherCode As String, _
    bookCode As String, _
    fieldName As String, _
    fieldType As SearchFieldType _
) As PersistIdentity
Visual C++
public:
static PersistIdentity^ SearchFieldMap(
    IPrincipal^ principal,
    String^ publisherCode,
    String^ bookCode,
    String^ fieldName,
    SearchFieldType fieldType
)

Parameters

principal
Type: Mincom.LinkOne.Dom..::.IPrincipal
The principal.
publisherCode
Type: System..::.String
Publisher code of wanted field map.
bookCode
Type: System..::.String
Book code of wanted field map.
fieldName
Type: System..::.String
Field name of wanted field map.
fieldType
Type: Mincom.LinkOne.Dom.Searching..::.SearchFieldType
Field type of wanted field map.

Return Value

A PersistIdentiy object identifying the required object.

See Also

PersistIdentity Class
SearchFieldMap Overload
Mincom.LinkOne.Dom Namespace


ToString Method

[image]

LinkOne WebView API
PersistIdentity..::.ToString Method
PersistIdentity Class See Also Send Feedback
Converts the identity to a string.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A string identifying the identity.

See Also

PersistIdentity Class
Mincom.LinkOne.Dom Namespace


PersistIdentity Properties

[image] [image]

LinkOne WebView API
PersistIdentity Properties
PersistIdentity Class See Also Send Feedback

The PersistIdentity type exposes the following members.

Properties

Name | Description
BookCode | Gets the book code.
FieldName | Gets the field name.
FieldType | Gets the field type.
Filters | Gets the filters to apply.
ItemId | Gets the note item id.
Location | Gets the location.
MasterBookCode | Gets the master book code.
NoteAccess | Gets the note access;
NoteId | Gets the note Id.
PageReference | Gets the page reference.
PictureNumber | Gets the note picture number.
PictureReference | Gets the picture reference.
Principal | Gets the principal.
PublisherCode | Gets the publisher code.
ResourceReference | Gets the resource reference.
Type | Gets the type of the persist object.

See Also

PersistIdentity Class
Mincom.LinkOne.Dom Namespace


BookCode Property

[image]

LinkOne WebView API
PersistIdentity..::.BookCode Property
PersistIdentity Class See Also Send Feedback
Gets the book code.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string BookCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property BookCode As String
Visual C++
public:
virtual property String^ BookCode {
    String^ get () sealed;
}

Implements

IPersistIdentity..::.BookCode

See Also

PersistIdentity Class
Mincom.LinkOne.Dom Namespace


FieldName Property

[image]

LinkOne WebView API
PersistIdentity..::.FieldName Property
PersistIdentity Class See Also Send Feedback
Gets the field name.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string FieldName { get; }
Visual Basic (Declaration)
Public ReadOnly Property FieldName As String
Visual C++
public:
virtual property String^ FieldName {
    String^ get () sealed;
}

Implements

IPersistIdentity..::.FieldName

See Also

PersistIdentity Class
Mincom.LinkOne.Dom Namespace


FieldType Property

[image]

LinkOne WebView API
PersistIdentity..::.FieldType Property
PersistIdentity Class See Also Send Feedback
Gets the field type.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchFieldType FieldType { get; }
Visual Basic (Declaration)
Public ReadOnly Property FieldType As SearchFieldType
Visual C++
public:
virtual property SearchFieldType FieldType {
    SearchFieldType get () sealed;
}

Implements

IPersistIdentity..::.FieldType

See Also

PersistIdentity Class
Mincom.LinkOne.Dom Namespace


Filters Property

[image]

LinkOne WebView API
PersistIdentity..::.Filters Property
PersistIdentity Class See Also Send Feedback
Gets the filters to apply.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IFilterCollection Filters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Filters As IFilterCollection
Visual C++
public:
virtual property IFilterCollection^ Filters {
    IFilterCollection^ get () sealed;
}

Implements

IPersistIdentity..::.Filters

See Also

PersistIdentity Class
Mincom.LinkOne.Dom Namespace


ItemId Property

[image]

LinkOne WebView API
PersistIdentity..::.ItemId Property
PersistIdentity Class See Also Send Feedback
Gets the note item id.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string ItemId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemId As String
Visual C++
public:
virtual property String^ ItemId {
    String^ get () sealed;
}

Implements

IPersistIdentity..::.ItemId

See Also

PersistIdentity Class
Mincom.LinkOne.Dom Namespace


Location Property

[image]

LinkOne WebView API
PersistIdentity..::.Location Property
PersistIdentity Class See Also Send Feedback
Gets the location.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Location { get; }
Visual Basic (Declaration)
Public ReadOnly Property Location As String
Visual C++
public:
virtual property String^ Location {
    String^ get () sealed;
}

Implements

IPersistIdentity..::.Location

See Also

PersistIdentity Class
Mincom.LinkOne.Dom Namespace


MasterBookCode Property

[image]

LinkOne WebView API
PersistIdentity..::.MasterBookCode Property
PersistIdentity Class See Also Send Feedback
Gets the master book code.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string MasterBookCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property MasterBookCode As String
Visual C++
public:
virtual property String^ MasterBookCode {
    String^ get () sealed;
}

Implements

IPersistIdentity..::.MasterBookCode

See Also

PersistIdentity Class
Mincom.LinkOne.Dom Namespace


NoteAccess Property

[image]

LinkOne WebView API
PersistIdentity..::.NoteAccess Property
PersistIdentity Class See Also Send Feedback
Gets the note access;

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Access NoteAccess { get; }
Visual Basic (Declaration)
Public ReadOnly Property NoteAccess As Access
Visual C++
public:
virtual property Access NoteAccess {
    Access get () sealed;
}

Implements

IPersistIdentity..::.NoteAccess

See Also

PersistIdentity Class
Mincom.LinkOne.Dom Namespace


NoteId Property

[image]

LinkOne WebView API
PersistIdentity..::.NoteId Property
PersistIdentity Class See Also Send Feedback
Gets the note Id.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int NoteId { get; }
Visual Basic (Declaration)
Public ReadOnly Property NoteId As Integer
Visual C++
public:
virtual property int NoteId {
    int get () sealed;
}

Implements

IPersistIdentity..::.NoteId

See Also

PersistIdentity Class
Mincom.LinkOne.Dom Namespace


PageReference Property

[image]

LinkOne WebView API
PersistIdentity..::.PageReference Property
PersistIdentity Class See Also Send Feedback
Gets the page reference.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PageReference { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageReference As String
Visual C++
public:
virtual property String^ PageReference {
    String^ get () sealed;
}

Implements

IPersistIdentity..::.PageReference

See Also

PersistIdentity Class
Mincom.LinkOne.Dom Namespace


PictureNumber Property

[image]

LinkOne WebView API
PersistIdentity..::.PictureNumber Property
PersistIdentity Class See Also Send Feedback
Gets the note picture number.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int PictureNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property PictureNumber As Integer
Visual C++
public:
virtual property int PictureNumber {
    int get () sealed;
}

Implements

IPersistIdentity..::.PictureNumber

See Also

PersistIdentity Class
Mincom.LinkOne.Dom Namespace


PictureReference Property

[image]

LinkOne WebView API
PersistIdentity..::.PictureReference Property
PersistIdentity Class See Also Send Feedback
Gets the picture reference.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PictureReference { get; }
Visual Basic (Declaration)
Public ReadOnly Property PictureReference As String
Visual C++
public:
virtual property String^ PictureReference {
    String^ get () sealed;
}

Implements

IPersistIdentity..::.PictureReference

See Also

PersistIdentity Class
Mincom.LinkOne.Dom Namespace


Principal Property

[image]

LinkOne WebView API
PersistIdentity..::.Principal Property
PersistIdentity Class See Also Send Feedback
Gets the principal.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IPrincipal Principal { get; }
Visual Basic (Declaration)
Public ReadOnly Property Principal As IPrincipal
Visual C++
public:
virtual property IPrincipal^ Principal {
    IPrincipal^ get () sealed;
}

Implements

IPersistIdentity..::.Principal

See Also

PersistIdentity Class
Mincom.LinkOne.Dom Namespace


PublisherCode Property

[image]

LinkOne WebView API
PersistIdentity..::.PublisherCode Property
PersistIdentity Class See Also Send Feedback
Gets the publisher code.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PublisherCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublisherCode As String
Visual C++
public:
virtual property String^ PublisherCode {
    String^ get () sealed;
}

Implements

IPersistIdentity..::.PublisherCode

See Also

PersistIdentity Class
Mincom.LinkOne.Dom Namespace


ResourceReference Property

[image]

LinkOne WebView API
PersistIdentity..::.ResourceReference Property
PersistIdentity Class See Also Send Feedback
Gets the resource reference.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string ResourceReference { get; }
Visual Basic (Declaration)
Public ReadOnly Property ResourceReference As String
Visual C++
public:
virtual property String^ ResourceReference {
    String^ get () sealed;
}

Implements

IPersistIdentity..::.ResourceReference

See Also

PersistIdentity Class
Mincom.LinkOne.Dom Namespace


Type Property

[image]

LinkOne WebView API
PersistIdentity..::.Type Property
PersistIdentity Class See Also Send Feedback
Gets the type of the persist object.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Type Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As Type
Visual C++
public:
virtual property Type^ Type {
    Type^ get () sealed;
}

Implements

IPersistIdentity..::.Type

See Also

PersistIdentity Class
Mincom.LinkOne.Dom Namespace


Picture Class

[image]

LinkOne WebView API
Picture Class
Members See Also Send Feedback
A picture on a LinkOne page.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class Picture : IPersist,
    IPicture, IFilterable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class Picture _
    Implements IPersist, IPicture, IFilterable
Visual C++
[SerializableAttribute]
public ref class Picture sealed : IPersist,
    IPicture, IFilterable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.Picture

See Also

Picture Members
Mincom.LinkOne.Dom Namespace


Picture Members

[image] [image]

LinkOne WebView API
Picture Members
Picture Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The Picture type exposes the following members.

Constructors

Name | Description
Picture | Initializes a new instance of the Picture class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetField | Returns the value of the wanted field.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Data | Gets the raw data for the image, whithout overlays applied
Fields | Gets the publisher defined fields associated with the picture.
Height | Gets the original picture height.
Image | Gets an Image drawn using current picture data, or null if there is no data.
IsRaster | Gets a value indicating whether the picture is a raster.
IsVector | Gets true if Resource is a vector picture.
Location | Gets the picture location in the book.
MimeType | Gets the resource mime type.
Number | Gets the picture number in the picture collection.
Options | The set of PICTUREOPTION's associated with this picture.
Overlays | Gets the collection of Overlay objects.
Page | Gets the page associated with this picture.
PictureHeight | Gets the physical picture height.
PictureLeft | Gets the left offset of the physical picture within the original picture area.
PictureTop | Gets the top offset of the physical picture within the original picture area.
PictureWidth | Gets the physical picture width.
PublishedDate | Gets the published date.
Resource | Gets the binary resource that is the picture.
Scale | Gets the picture defalt scale.
Title | Gets the picture title.
UnfilteredOverlayCount | Gets the unfiltered overlay count.
Values | Gets the values visible to the picture.
Width | Gets the original picture width.
ZoneItems | Gets the collection of ZoneItem objects.

Explicit Interface Implementations

Name | Description
IPicture..::.Fields |
IPicture..::.GetField |
IFilterable..::.Options |
IPicture..::.Page |
IPicture..::.Values |

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


Picture Constructor

[image]

LinkOne WebView API
Picture Constructor
Picture Class See Also Send Feedback
Initializes a new instance of the Picture class.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Picture(
    IDomReader domReader
)
Visual Basic (Declaration)
Public Sub New ( _
    domReader As IDomReader _
)
Visual C++
public:
Picture(
    IDomReader^ domReader
)

Parameters

domReader
Type: IDomReader
The picture reader object providing the initialisation data.

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


Picture Methods

[image] [image]

LinkOne WebView API
Picture Methods
Picture Class See Also Send Feedback

The Picture type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetField | Returns the value of the wanted field.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IPicture..::.GetField |

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


GetField Method

[image]

LinkOne WebView API
Picture..::.GetField Method
Picture Class See Also Send Feedback
Returns the value of the wanted field.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string GetField(
    string name
)
Visual Basic (Declaration)
Public Function GetField ( _
    name As String _
) As String
Visual C++
public:
String^ GetField(
    String^ name
)

Parameters

name
Type: System..::.String
Name of the wanted field.

Return Value

The value of the wanted field, or blank if not found..

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


IPicture.GetField Method

[image]

LinkOne WebView API
Picture..::.IPicture..::.GetField Method
Picture Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string IPicture.GetField(
    string name
)
Visual Basic (Declaration)
Private Function GetField ( _
    name As String _
) As String Implements IPicture.GetField
Visual C++
private:
virtual String^ GetField(
    String^ name
) sealed = IPicture::GetField

Parameters

name
Type: System..::.String

Implements

IPicture..::.GetField(String)

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


Picture Properties

[image] [image]

LinkOne WebView API
Picture Properties
Picture Class See Also Send Feedback

The Picture type exposes the following members.

Properties

Name | Description
Data | Gets the raw data for the image, whithout overlays applied
Fields | Gets the publisher defined fields associated with the picture.
Height | Gets the original picture height.
Image | Gets an Image drawn using current picture data, or null if there is no data.
IsRaster | Gets a value indicating whether the picture is a raster.
IsVector | Gets true if Resource is a vector picture.
Location | Gets the picture location in the book.
MimeType | Gets the resource mime type.
Number | Gets the picture number in the picture collection.
Options | The set of PICTUREOPTION's associated with this picture.
Overlays | Gets the collection of Overlay objects.
Page | Gets the page associated with this picture.
PictureHeight | Gets the physical picture height.
PictureLeft | Gets the left offset of the physical picture within the original picture area.
PictureTop | Gets the top offset of the physical picture within the original picture area.
PictureWidth | Gets the physical picture width.
PublishedDate | Gets the published date.
Resource | Gets the binary resource that is the picture.
Scale | Gets the picture defalt scale.
Title | Gets the picture title.
UnfilteredOverlayCount | Gets the unfiltered overlay count.
Values | Gets the values visible to the picture.
Width | Gets the original picture width.
ZoneItems | Gets the collection of ZoneItem objects.

Explicit Interface Implementations

Name | Description
IPicture..::.Fields |
IFilterable..::.Options |
IPicture..::.Page |
IPicture..::.Values |

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


Data Property

[image]

LinkOne WebView API
Picture..::.Data Property
Picture Class See Also Send Feedback
Gets the raw data for the image, whithout overlays applied

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public byte[] Data { get; }
Visual Basic (Declaration)
Public ReadOnly Property Data As Byte()
Visual C++
public:
virtual property array<unsigned char>^ Data {
    array<unsigned char>^ get () sealed;
}

Implements

IPicture..::.Data

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


Fields Property

[image]

LinkOne WebView API
Picture..::.Fields Property
Picture Class See Also Send Feedback
Gets the publisher defined fields associated with the picture.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public FieldCollection Fields { get; }
Visual Basic (Declaration)
Public ReadOnly Property Fields As FieldCollection
Visual C++
public:
property FieldCollection^ Fields {
    FieldCollection^ get ();
}

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


Height Property

[image]

LinkOne WebView API
Picture..::.Height Property
Picture Class See Also Send Feedback
Gets the original picture height.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Height { get; }
Visual Basic (Declaration)
Public ReadOnly Property Height As Integer
Visual C++
public:
virtual property int Height {
    int get () sealed;
}

Implements

IPicture..::.Height

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


IFilterable.Options Property

[image]

LinkOne WebView API
Picture..::.IFilterable..::.Options Property
Picture Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IOptionCollection IFilterable.Options { get; }
Visual Basic (Declaration)
Private ReadOnly Property Options As IOptionCollection
    Implements IFilterable.Options
Visual C++
private:
virtual property IOptionCollection^ Options {
    IOptionCollection^ get () sealed = IFilterable::Options::get;
}

Implements

IFilterable..::.Options

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


Image Property

[image]

LinkOne WebView API
Picture..::.Image Property
Picture Class See Also Send Feedback
Gets an Image drawn using current picture data, or null if there is no data.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Image Image { get; }
Visual Basic (Declaration)
Public ReadOnly Property Image As Image
Visual C++
public:
virtual property Image^ Image {
    Image^ get () sealed;
}

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


IPicture.Fields Property

[image]

LinkOne WebView API
Picture..::.IPicture..::.Fields Property
Picture Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IFieldCollection IPicture.Fields { get; }
Visual Basic (Declaration)
Private ReadOnly Property Fields As IFieldCollection
    Implements IPicture.Fields
Visual C++
private:
virtual property IFieldCollection^ Fields {
    IFieldCollection^ get () sealed = IPicture::Fields::get;
}

Implements

IPicture..::.Fields

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


IPicture.Page Property

[image]

LinkOne WebView API
Picture..::.IPicture..::.Page Property
Picture Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPage IPicture.Page { get; }
Visual Basic (Declaration)
Private ReadOnly Property Page As IPage
    Implements IPicture.Page
Visual C++
private:
virtual property IPage^ Page {
    IPage^ get () sealed = IPicture::Page::get;
}

Implements

IPicture..::.Page

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


IPicture.Values Property

[image]

LinkOne WebView API
Picture..::.IPicture..::.Values Property
Picture Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IValueCollection IPicture.Values { get; }
Visual Basic (Declaration)
Private ReadOnly Property Values As IValueCollection
    Implements IPicture.Values
Visual C++
private:
virtual property IValueCollection^ Values {
    IValueCollection^ get () sealed = IPicture::Values::get;
}

Implements

IPicture..::.Values

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


IsRaster Property

[image]

LinkOne WebView API
Picture..::.IsRaster Property
Picture Class See Also Send Feedback
Gets a value indicating whether the picture is a raster.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsRaster { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsRaster As Boolean
Visual C++
public:
virtual property bool IsRaster {
    bool get () sealed;
}

Implements

IPicture..::.IsRaster

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


IsVector Property

[image]

LinkOne WebView API
Picture..::.IsVector Property
Picture Class See Also Send Feedback
Gets true if Resource is a vector picture.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsVector { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsVector As Boolean
Visual C++
public:
virtual property bool IsVector {
    bool get () sealed;
}

Implements

IPicture..::.IsVector

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


Location Property

[image]

LinkOne WebView API
Picture..::.Location Property
Picture Class See Also Send Feedback
Gets the picture location in the book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Location { get; }
Visual Basic (Declaration)
Public ReadOnly Property Location As String
Visual C++
public:
property String^ Location {
    String^ get ();
}

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


MimeType Property

[image]

LinkOne WebView API
Picture..::.MimeType Property
Picture Class See Also Send Feedback
Gets the resource mime type.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string MimeType { get; }
Visual Basic (Declaration)
Public ReadOnly Property MimeType As String
Visual C++
public:
virtual property String^ MimeType {
    String^ get () sealed;
}

Implements

IPicture..::.MimeType

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


Number Property

[image]

LinkOne WebView API
Picture..::.Number Property
Picture Class See Also Send Feedback
Gets the picture number in the picture collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Number { get; }
Visual Basic (Declaration)
Public ReadOnly Property Number As Integer
Visual C++
public:
virtual property int Number {
    int get () sealed;
}

Implements

IPicture..::.Number

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


Options Property

[image]

LinkOne WebView API
Picture..::.Options Property
Picture Class See Also Send Feedback
The set of PICTUREOPTION's associated with this picture.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public OptionCollection Options { get; }
Visual Basic (Declaration)
Public ReadOnly Property Options As OptionCollection
Visual C++
public:
property OptionCollection^ Options {
    OptionCollection^ get ();
}

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


Overlays Property

[image]

LinkOne WebView API
Picture..::.Overlays Property
Picture Class See Also Send Feedback
Gets the collection of Overlay objects.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public OverlayCollection Overlays { get; }
Visual Basic (Declaration)
Public ReadOnly Property Overlays As OverlayCollection
Visual C++
public:
property OverlayCollection^ Overlays {
    OverlayCollection^ get ();
}

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


Page Property

[image]

LinkOne WebView API
Picture..::.Page Property
Picture Class See Also Send Feedback
Gets the page associated with this picture.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Page Page { get; internal set; }
Visual Basic (Declaration)
Public Property Page As Page
Visual C++
public:
property Page^ Page {
    Page^ get ();
    void set (Page^ value);
}

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


PictureHeight Property

[image]

LinkOne WebView API
Picture..::.PictureHeight Property
Picture Class See Also Send Feedback
Gets the physical picture height.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int PictureHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property PictureHeight As Integer
Visual C++
public:
virtual property int PictureHeight {
    int get () sealed;
}

Implements

IPicture..::.PictureHeight

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


PictureLeft Property

[image]

LinkOne WebView API
Picture..::.PictureLeft Property
Picture Class See Also Send Feedback
Gets the left offset of the physical picture within the original picture area.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int PictureLeft { get; }
Visual Basic (Declaration)
Public ReadOnly Property PictureLeft As Integer
Visual C++
public:
virtual property int PictureLeft {
    int get () sealed;
}

Implements

IPicture..::.PictureLeft

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


PictureTop Property

[image]

LinkOne WebView API
Picture..::.PictureTop Property
Picture Class See Also Send Feedback
Gets the top offset of the physical picture within the original picture area.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int PictureTop { get; }
Visual Basic (Declaration)
Public ReadOnly Property PictureTop As Integer
Visual C++
public:
virtual property int PictureTop {
    int get () sealed;
}

Implements

IPicture..::.PictureTop

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


PictureWidth Property

[image]

LinkOne WebView API
Picture..::.PictureWidth Property
Picture Class See Also Send Feedback
Gets the physical picture width.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int PictureWidth { get; }
Visual Basic (Declaration)
Public ReadOnly Property PictureWidth As Integer
Visual C++
public:
virtual property int PictureWidth {
    int get () sealed;
}

Implements

IPicture..::.PictureWidth

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


PublishedDate Property

[image]

LinkOne WebView API
Picture..::.PublishedDate Property
Picture Class See Also Send Feedback
Gets the published date.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public DateTime PublishedDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublishedDate As DateTime
Visual C++
public:
property DateTime PublishedDate {
    DateTime get ();
}

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


Resource Property

[image]

LinkOne WebView API
Picture..::.Resource Property
Picture Class See Also Send Feedback
Gets the binary resource that is the picture.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Resource Resource { get; }
Visual Basic (Declaration)
Public ReadOnly Property Resource As Resource
Visual C++
public:
property Resource^ Resource {
    Resource^ get ();
}

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


Scale Property

[image]

LinkOne WebView API
Picture..::.Scale Property
Picture Class See Also Send Feedback
Gets the picture defalt scale.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public double Scale { get; }
Visual Basic (Declaration)
Public ReadOnly Property Scale As Double
Visual C++
public:
virtual property double Scale {
    double get () sealed;
}

Implements

IPicture..::.Scale

Remarks

The pictures default scale runs from 0.125 to 800.000 in increments of 0.125 with fit to screen equal to 0.

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


Title Property

[image]

LinkOne WebView API
Picture..::.Title Property
Picture Class See Also Send Feedback
Gets the picture title.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Title { get; }
Visual Basic (Declaration)
Public ReadOnly Property Title As String
Visual C++
public:
virtual property String^ Title {
    String^ get () sealed;
}

Implements

IPicture..::.Title

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


UnfilteredOverlayCount Property

[image]

LinkOne WebView API
Picture..::.UnfilteredOverlayCount Property
Picture Class See Also Send Feedback
Gets the unfiltered overlay count.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int UnfilteredOverlayCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property UnfilteredOverlayCount As Integer
Visual C++
public:
property int UnfilteredOverlayCount {
    int get ();
}

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


Values Property

[image]

LinkOne WebView API
Picture..::.Values Property
Picture Class See Also Send Feedback
Gets the values visible to the picture.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ValueCollection Values { get; }
Visual Basic (Declaration)
Public ReadOnly Property Values As ValueCollection
Visual C++
public:
property ValueCollection^ Values {
    ValueCollection^ get ();
}

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


Width Property

[image]

LinkOne WebView API
Picture..::.Width Property
Picture Class See Also Send Feedback
Gets the original picture width.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Width { get; }
Visual Basic (Declaration)
Public ReadOnly Property Width As Integer
Visual C++
public:
virtual property int Width {
    int get () sealed;
}

Implements

IPicture..::.Width

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


ZoneItems Property

[image]

LinkOne WebView API
Picture..::.ZoneItems Property
Picture Class See Also Send Feedback
Gets the collection of ZoneItem objects.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ZoneItemCollection ZoneItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property ZoneItems As ZoneItemCollection
Visual C++
public:
property ZoneItemCollection^ ZoneItems {
    ZoneItemCollection^ get ();
}

See Also

Picture Class
Mincom.LinkOne.Dom Namespace


PictureCollection Class

[image]

LinkOne WebView API
PictureCollection Class
Members See Also Send Feedback
Represents a collection of Picture objects that can be accessed by index, and location.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class PictureCollection : ReadOnlyList<Picture>,
    IPictureCollection, IReadOnlyList<IPicture>, IReadOnlyCollection<IPicture>,
    IEnumerable<IPicture>, IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class PictureCollection _
    Inherits ReadOnlyList(Of Picture) _
    Implements IPictureCollection, IReadOnlyList(Of IPicture),  _
    IReadOnlyCollection(Of IPicture), IEnumerable(Of IPicture), IEnumerable
Visual C++
[SerializableAttribute]
public ref class PictureCollection sealed : public ReadOnlyList<Picture^>,
    IPictureCollection, IReadOnlyList<IPicture^>, IReadOnlyCollection<IPicture^>,
    IEnumerable<IPicture^>, IEnumerable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.ReadOnlyList <(Of <( Picture >)>)
Mincom.LinkOne.Dom..::.PictureCollection

See Also

PictureCollection Members
Mincom.LinkOne.Dom Namespace


PictureCollection Members

[image] [image]

LinkOne WebView API
PictureCollection Members
PictureCollection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The PictureCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPicture | Gets the item with the given number.
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given object. (Inherited from ReadOnlyList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
InnerList | Gets the inner list. (Inherited from ReadOnlyList<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(IPicture>)>)..::.Contains |
IEnumerable<(Of <(IPicture>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
IReadOnlyList<(Of <(IPicture>)>)..::.IndexOf |
IReadOnlyList<(Of <(IPicture>)>)..::.Item |

See Also

PictureCollection Class
Mincom.LinkOne.Dom Namespace


PictureCollection Methods

[image] [image]

LinkOne WebView API
PictureCollection Methods
PictureCollection Class See Also Send Feedback

The PictureCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPicture | Gets the item with the given number.
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given object. (Inherited from ReadOnlyList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(IPicture>)>)..::.Contains |
IEnumerable<(Of <(IPicture>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
IReadOnlyList<(Of <(IPicture>)>)..::.IndexOf |

See Also

PictureCollection Class
Mincom.LinkOne.Dom Namespace


IEnumerable(IPicture).GetEnumerator Method

[image]

LinkOne WebView API
PictureCollection..::.IEnumerable<(Of <(IPicture>)>)..::.GetEnumerator Method
PictureCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator<IPicture> IEnumerable<IPicture>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of IPicture)
    Implements IEnumerable(Of IPicture).GetEnumerator
Visual C++
private:
virtual IEnumerator<IPicture^>^ GetEnumerator() sealed = IEnumerable<IPicture^>::GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

PictureCollection Class
Mincom.LinkOne.Dom Namespace


GetPicture Method

[image]

LinkOne WebView API
PictureCollection..::.GetPicture Method
PictureCollection Class See Also Send Feedback
Gets the item with the given number.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Picture GetPicture(
    int number
)
Visual Basic (Declaration)
Public Function GetPicture ( _
    number As Integer _
) As Picture
Visual C++
public:
Picture^ GetPicture(
    int number
)

Parameters

number
Type: System..::.Int32
The number of the picture to get.

Return Value

The object in the PictureCollection if it is in range; otherwise, null.

See Also

PictureCollection Class
Mincom.LinkOne.Dom Namespace


IReadOnlyCollection(IPicture).Contains Method

[image]

LinkOne WebView API
PictureCollection..::.IReadOnlyCollection<(Of <(IPicture>)>)..::.Contains Method
PictureCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IReadOnlyCollection<IPicture>.Contains(
    IPicture domObject
)
Visual Basic (Declaration)
Private Function Contains ( _
    domObject As IPicture _
) As Boolean Implements IReadOnlyCollection(Of IPicture).Contains
Visual C++
private:
virtual bool Contains(
    IPicture^ domObject
) sealed = IReadOnlyCollection<IPicture^>::Contains

Parameters

domObject
Type: Mincom.LinkOne.Dom..::.IPicture

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Contains(T)

See Also

PictureCollection Class
Mincom.LinkOne.Dom Namespace


IReadOnlyList(IPicture).IndexOf Method

[image]

LinkOne WebView API
PictureCollection..::.IReadOnlyList<(Of <(IPicture>)>)..::.IndexOf Method
PictureCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int IReadOnlyList<IPicture>.IndexOf(
    IPicture domObject
)
Visual Basic (Declaration)
Private Function IndexOf ( _
    domObject As IPicture _
) As Integer Implements IReadOnlyList(Of IPicture).IndexOf
Visual C++
private:
virtual int IndexOf(
    IPicture^ domObject
) sealed = IReadOnlyList<IPicture^>::IndexOf

Parameters

domObject
Type: Mincom.LinkOne.Dom..::.IPicture

Implements

IReadOnlyList<(Of <(T>)>)..::.IndexOf(T)

See Also

PictureCollection Class
Mincom.LinkOne.Dom Namespace


PictureCollection Properties

[image] [image]

LinkOne WebView API
PictureCollection Properties
PictureCollection Class See Also Send Feedback

The PictureCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
InnerList | Gets the inner list. (Inherited from ReadOnlyList<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IReadOnlyList<(Of <(IPicture>)>)..::.Item |

See Also

PictureCollection Class
Mincom.LinkOne.Dom Namespace


IReadOnlyList(IPicture).Item Property

[image]

LinkOne WebView API
PictureCollection..::.IReadOnlyList<(Of <(IPicture>)>)..::.Item Property
PictureCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPicture IReadOnlyList<IPicture>.Item[
    int index
] { get; }
Visual Basic (Declaration)
Private ReadOnly Property Item ( _
    index As Integer _
) As IPicture Implements IReadOnlyList(Of IPicture).Item
Visual C++
private:
virtual property IPicture^ Item[int index] {
    IPicture^ get (int index) sealed = IReadOnlyList<IPicture^>::Item::get;
}

Parameters

index
Type: System..::.Int32

Implements

IReadOnlyList<(Of <(T>)>)..::.Item[([(Int32])])

See Also

PictureCollection Class
Mincom.LinkOne.Dom Namespace


Item Property

[image] [image]

LinkOne WebView API
PictureCollection..::.Item Property
PictureCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Gets the item at the given index. This is the safe version of the items accessor, it does not throw an exception if the index is out of bounds, instead, it returns null.
Item[([(String])]) | Gets the Picture for the given location, if found; otherwise, null.

See Also

PictureCollection Class
PictureCollection Members
Mincom.LinkOne.Dom Namespace


Item Property (Int32)

[image]

LinkOne WebView API
PictureCollection..::.Item Property (Int32)
PictureCollection Class See Also Send Feedback
Gets the item at the given index. This is the safe version of the items accessor, it does not throw an exception if the index is out of bounds, instead, it returns null.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Picture this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Picture
Visual C++
public:
property Picture^ default[int index] {
    Picture^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

PictureCollection Class
Item Overload
Mincom.LinkOne.Dom Namespace


Item Property (String)

[image]

LinkOne WebView API
PictureCollection..::.Item Property (String)
PictureCollection Class See Also Send Feedback
Gets the Picture for the given location, if found; otherwise, null.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Picture this[
    string location
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    location As String _
) As Picture
Visual C++
public:
property Picture^ default[String^ location] {
    Picture^ get (String^ location);
}

Parameters

location
Type: System..::.String

See Also

PictureCollection Class
Item Overload
Mincom.LinkOne.Dom Namespace


PictureResource Class

[image]

LinkOne WebView API
PictureResource Class
Members See Also Send Feedback
Represents a Dom Picture resource.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public sealed class PictureResource : IPersist
Visual Basic (Declaration)
Public NotInheritable Class PictureResource _
    Implements IPersist
Visual C++
public ref class PictureResource sealed : IPersist

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.PictureResource

See Also

PictureResource Members
Mincom.LinkOne.Dom Namespace


PictureResource Members

[image] [image]

LinkOne WebView API
PictureResource Members
PictureResource Class Constructors Methods Properties See Also Send Feedback

The PictureResource type exposes the following members.

Constructors

Name | Description
PictureResource | Initializes a new instance of the PictureResource class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
IsRaster | Gets a value indicating whether this picture is a raster.
IsVector | Gets a value indicating whether this picture is a vector.
PictureHeight | Gets the height of the picture.
PictureLeft | Gets the picture left.
PictureTop | Gets the picture top.
PictureWidth | Gets the width of the picture.
Resource | Gets the picture resource.

See Also

PictureResource Class
Mincom.LinkOne.Dom Namespace


PictureResource Constructor

[image]

LinkOne WebView API
PictureResource Constructor
PictureResource Class See Also Send Feedback
Initializes a new instance of the PictureResource class.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PictureResource(
    IDomReader domReader
)
Visual Basic (Declaration)
Public Sub New ( _
    domReader As IDomReader _
)
Visual C++
public:
PictureResource(
    IDomReader^ domReader
)

Parameters

domReader
Type: IDomReader
The DOM reader to build the picture resource from.

See Also

PictureResource Class
Mincom.LinkOne.Dom Namespace


PictureResource Methods

[image] [image]

LinkOne WebView API
PictureResource Methods
PictureResource Class See Also Send Feedback

The PictureResource type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PictureResource Class
Mincom.LinkOne.Dom Namespace


PictureResource Properties

[image] [image]

LinkOne WebView API
PictureResource Properties
PictureResource Class See Also Send Feedback

The PictureResource type exposes the following members.

Properties

Name | Description
IsRaster | Gets a value indicating whether this picture is a raster.
IsVector | Gets a value indicating whether this picture is a vector.
PictureHeight | Gets the height of the picture.
PictureLeft | Gets the picture left.
PictureTop | Gets the picture top.
PictureWidth | Gets the width of the picture.
Resource | Gets the picture resource.

See Also

PictureResource Class
Mincom.LinkOne.Dom Namespace


IsRaster Property

[image]

LinkOne WebView API
PictureResource..::.IsRaster Property
PictureResource Class See Also Send Feedback
Gets a value indicating whether this picture is a raster.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsRaster { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsRaster As Boolean
Visual C++
public:
property bool IsRaster {
    bool get ();
}

See Also

PictureResource Class
Mincom.LinkOne.Dom Namespace


IsVector Property

[image]

LinkOne WebView API
PictureResource..::.IsVector Property
PictureResource Class See Also Send Feedback
Gets a value indicating whether this picture is a vector.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsVector { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsVector As Boolean
Visual C++
public:
property bool IsVector {
    bool get ();
}

See Also

PictureResource Class
Mincom.LinkOne.Dom Namespace


PictureHeight Property

[image]

LinkOne WebView API
PictureResource..::.PictureHeight Property
PictureResource Class See Also Send Feedback
Gets the height of the picture.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int PictureHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property PictureHeight As Integer
Visual C++
public:
property int PictureHeight {
    int get ();
}

See Also

PictureResource Class
Mincom.LinkOne.Dom Namespace


PictureLeft Property

[image]

LinkOne WebView API
PictureResource..::.PictureLeft Property
PictureResource Class See Also Send Feedback
Gets the picture left.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int PictureLeft { get; }
Visual Basic (Declaration)
Public ReadOnly Property PictureLeft As Integer
Visual C++
public:
property int PictureLeft {
    int get ();
}

See Also

PictureResource Class
Mincom.LinkOne.Dom Namespace


PictureTop Property

[image]

LinkOne WebView API
PictureResource..::.PictureTop Property
PictureResource Class See Also Send Feedback
Gets the picture top.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int PictureTop { get; }
Visual Basic (Declaration)
Public ReadOnly Property PictureTop As Integer
Visual C++
public:
property int PictureTop {
    int get ();
}

See Also

PictureResource Class
Mincom.LinkOne.Dom Namespace


PictureWidth Property

[image]

LinkOne WebView API
PictureResource..::.PictureWidth Property
PictureResource Class See Also Send Feedback
Gets the width of the picture.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int PictureWidth { get; }
Visual Basic (Declaration)
Public ReadOnly Property PictureWidth As Integer
Visual C++
public:
property int PictureWidth {
    int get ();
}

See Also

PictureResource Class
Mincom.LinkOne.Dom Namespace


Resource Property

[image]

LinkOne WebView API
PictureResource..::.Resource Property
PictureResource Class See Also Send Feedback
Gets the picture resource.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Resource Resource { get; }
Visual Basic (Declaration)
Public ReadOnly Property Resource As Resource
Visual C++
public:
property Resource^ Resource {
    Resource^ get ();
}

See Also

PictureResource Class
Mincom.LinkOne.Dom Namespace


PredefinedBookFieldNames Class

[image]

LinkOne WebView API
PredefinedBookFieldNames Class
Members See Also Send Feedback
Predefined book fields.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static class PredefinedBookFieldNames
Visual Basic (Declaration)
Public NotInheritable Class PredefinedBookFieldNames
Visual C++
public ref class PredefinedBookFieldNames abstract sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.PredefinedBookFieldNames

See Also

PredefinedBookFieldNames Members
Mincom.LinkOne.Dom Namespace


PredefinedBookFieldNames Members

[image] [image]

LinkOne WebView API
PredefinedBookFieldNames Members
PredefinedBookFieldNames Class Fields Properties See Also Send Feedback

The PredefinedBookFieldNames type exposes the following members.

Fields

Name | Description
Book | Book.
Publisher | Publisher.
PublisherDescription | Publisher description.
Title | Title.

Properties

Name | Description
List | The list of field names (read-only).

See Also

PredefinedBookFieldNames Class
Mincom.LinkOne.Dom Namespace


PredefinedBookFieldNames Fields

[image] [image]

LinkOne WebView API
PredefinedBookFieldNames Fields
PredefinedBookFieldNames Class See Also Send Feedback

The PredefinedBookFieldNames type exposes the following members.

Fields

Name | Description
Book | Book.
Publisher | Publisher.
PublisherDescription | Publisher description.
Title | Title.

See Also

PredefinedBookFieldNames Class
Mincom.LinkOne.Dom Namespace


Book Field

[image]

LinkOne WebView API
PredefinedBookFieldNames..::.Book Field
PredefinedBookFieldNames Class See Also Send Feedback
Book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string Book
Visual Basic (Declaration)
Public Const Book As String
Visual C++
public:
literal String^ Book

See Also

PredefinedBookFieldNames Class
Mincom.LinkOne.Dom Namespace


Publisher Field

[image]

LinkOne WebView API
PredefinedBookFieldNames..::.Publisher Field
PredefinedBookFieldNames Class See Also Send Feedback
Publisher.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string Publisher
Visual Basic (Declaration)
Public Const Publisher As String
Visual C++
public:
literal String^ Publisher

See Also

PredefinedBookFieldNames Class
Mincom.LinkOne.Dom Namespace


PublisherDescription Field

[image]

LinkOne WebView API
PredefinedBookFieldNames..::.PublisherDescription Field
PredefinedBookFieldNames Class See Also Send Feedback
Publisher description.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string PublisherDescription
Visual Basic (Declaration)
Public Const PublisherDescription As String
Visual C++
public:
literal String^ PublisherDescription

See Also

PredefinedBookFieldNames Class
Mincom.LinkOne.Dom Namespace


Title Field

[image]

LinkOne WebView API
PredefinedBookFieldNames..::.Title Field
PredefinedBookFieldNames Class See Also Send Feedback
Title.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string Title
Visual Basic (Declaration)
Public Const Title As String
Visual C++
public:
literal String^ Title

See Also

PredefinedBookFieldNames Class
Mincom.LinkOne.Dom Namespace


PredefinedBookFieldNames Properties

[image] [image]

LinkOne WebView API
PredefinedBookFieldNames Properties
PredefinedBookFieldNames Class See Also Send Feedback

The PredefinedBookFieldNames type exposes the following members.

Properties

Name | Description
List | The list of field names (read-only).

See Also

PredefinedBookFieldNames Class
Mincom.LinkOne.Dom Namespace


List Property

[image]

LinkOne WebView API
PredefinedBookFieldNames..::.List Property
PredefinedBookFieldNames Class See Also Send Feedback
The list of field names (read-only).

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static IList<string> List { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property List As IList(Of String)
Visual C++
public:
static property IList<String^>^ List {
    IList<String^>^ get ();
}

See Also

PredefinedBookFieldNames Class
Mincom.LinkOne.Dom Namespace


PredefinedBookValueNames Class

[image]

LinkOne WebView API
PredefinedBookValueNames Class
Members See Also Send Feedback
Predefined book values.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static class PredefinedBookValueNames
Visual Basic (Declaration)
Public NotInheritable Class PredefinedBookValueNames
Visual C++
public ref class PredefinedBookValueNames abstract sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.PredefinedBookValueNames

See Also

PredefinedBookValueNames Members
Mincom.LinkOne.Dom Namespace


PredefinedBookValueNames Members

[image] [image]

LinkOne WebView API
PredefinedBookValueNames Members
PredefinedBookValueNames Class Fields Properties See Also Send Feedback

The PredefinedBookValueNames type exposes the following members.

Fields

Name | Description
Book | Book
BookLocation | Book location
BookSheetNumber | Book sheet number
BookSheetNumberZero | Book sheet number zero
BookTitle | Book title
Class | Class
ConfigurationServer | Configuration server
Date | Date
FileName | File name
GtiCache | Gti cache
GtiFileName | Gti file name
ItemId | Item id
LinkOneDirectory | LinkOne dDirectory
LinkOneVersion | LinkOne version
ListSheetNumber | List sheet number
ListSheetNumberZero | List sheet number zero
ListTitle | List title
Object | Object
OptionFilters | Option filters
Page | Page
PartDescription | Part description
PartNumber | Part number
PictureSheetNumber | Picture sheet number
PictureSheetNumberZero | Picture sheet number zero
PictureTitle | Picture title
PrintSheetNumber | Print sheet number
PrintSheetNumberZero | Print sheet number zero
Publisher | Publisher
Reference | Reference
SelectionListPath | Selection ist path
Time | Time
View | View
VisibleItem | Visible item
VisiblePage | Visible page
VisibleReference | Visible reference

Properties

Name Description
List
The list of feld names (read-only).

Examples

CopyC#
// Prints out all the predefined book value names
foreach ( string bookValueName in PredefinedBookValueNames.List )
{
    Console.WriteLine( bookValueName );
}

// Prints the book title using the BOOK_TITLE value
IBook book = Library.Publishers[ "SpaceCo" ].Books[ "Spaceship" ];
string bookValue = book.Values[ PredefinedBookValueNames.BookTitle ];
Console.WriteLine( bookValue );

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


PredefinedBookValueNames Fields

[image] [image]

LinkOne WebView API
PredefinedBookValueNames Fields
PredefinedBookValueNames Class See Also Send Feedback

The PredefinedBookValueNames type exposes the following members.

Fields

Name | Description
Book | Book
BookLocation | Book location
BookSheetNumber | Book sheet number
BookSheetNumberZero | Book sheet number zero
BookTitle | Book title
Class | Class
ConfigurationServer | Configuration server
Date | Date
FileName | File name
GtiCache | Gti cache
GtiFileName | Gti file name
ItemId | Item id
LinkOneDirectory | LinkOne dDirectory
LinkOneVersion | LinkOne version
ListSheetNumber | List sheet number
ListSheetNumberZero | List sheet number zero
ListTitle | List title
Object | Object
OptionFilters | Option filters
Page | Page
PartDescription | Part description
PartNumber | Part number
PictureSheetNumber | Picture sheet number
PictureSheetNumberZero | Picture sheet number zero
PictureTitle | Picture title
PrintSheetNumber | Print sheet number
PrintSheetNumberZero | Print sheet number zero
Publisher | Publisher
Reference | Reference
SelectionListPath | Selection ist path
Time | Time
View | View
VisibleItem | Visible item
VisiblePage | Visible page
VisibleReference | Visible reference

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


Book Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.Book Field
PredefinedBookValueNames Class See Also Send Feedback
Book

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string Book
Visual Basic (Declaration)
Public Const Book As String
Visual C++
public:
literal String^ Book

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


BookLocation Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.BookLocation Field
PredefinedBookValueNames Class See Also Send Feedback
Book location

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string BookLocation
Visual Basic (Declaration)
Public Const BookLocation As String
Visual C++
public:
literal String^ BookLocation

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


BookSheetNumber Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.BookSheetNumber Field
PredefinedBookValueNames Class See Also Send Feedback
Book sheet number

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string BookSheetNumber
Visual Basic (Declaration)
Public Const BookSheetNumber As String
Visual C++
public:
literal String^ BookSheetNumber

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


BookSheetNumberZero Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.BookSheetNumberZero Field
PredefinedBookValueNames Class See Also Send Feedback
Book sheet number zero

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string BookSheetNumberZero
Visual Basic (Declaration)
Public Const BookSheetNumberZero As String
Visual C++
public:
literal String^ BookSheetNumberZero

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


BookTitle Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.BookTitle Field
PredefinedBookValueNames Class See Also Send Feedback
Book title

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string BookTitle
Visual Basic (Declaration)
Public Const BookTitle As String
Visual C++
public:
literal String^ BookTitle

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


Class Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.Class Field
PredefinedBookValueNames Class See Also Send Feedback
Class

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string Class
Visual Basic (Declaration)
Public Const Class As String
Visual C++
public:
literal String^ Class

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


ConfigurationServer Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.ConfigurationServer Field
PredefinedBookValueNames Class See Also Send Feedback
Configuration server

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string ConfigurationServer
Visual Basic (Declaration)
Public Const ConfigurationServer As String
Visual C++
public:
literal String^ ConfigurationServer

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


Date Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.Date Field
PredefinedBookValueNames Class See Also Send Feedback
Date

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string Date
Visual Basic (Declaration)
Public Const Date As String
Visual C++
public:
literal String^ Date

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


FileName Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.FileName Field
PredefinedBookValueNames Class See Also Send Feedback
File name

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string FileName
Visual Basic (Declaration)
Public Const FileName As String
Visual C++
public:
literal String^ FileName

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


GtiCache Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.GtiCache Field
PredefinedBookValueNames Class See Also Send Feedback
Gti cache

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string GtiCache
Visual Basic (Declaration)
Public Const GtiCache As String
Visual C++
public:
literal String^ GtiCache

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


GtiFileName Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.GtiFileName Field
PredefinedBookValueNames Class See Also Send Feedback
Gti file name

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string GtiFileName
Visual Basic (Declaration)
Public Const GtiFileName As String
Visual C++
public:
literal String^ GtiFileName

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


ItemId Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.ItemId Field
PredefinedBookValueNames Class See Also Send Feedback
Item id

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string ItemId
Visual Basic (Declaration)
Public Const ItemId As String
Visual C++
public:
literal String^ ItemId

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


LinkOneDirectory Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.LinkOneDirectory Field
PredefinedBookValueNames Class See Also Send Feedback
LinkOne dDirectory

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string LinkOneDirectory
Visual Basic (Declaration)
Public Const LinkOneDirectory As String
Visual C++
public:
literal String^ LinkOneDirectory

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


LinkOneVersion Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.LinkOneVersion Field
PredefinedBookValueNames Class See Also Send Feedback
LinkOne version

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string LinkOneVersion
Visual Basic (Declaration)
Public Const LinkOneVersion As String
Visual C++
public:
literal String^ LinkOneVersion

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


ListSheetNumber Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.ListSheetNumber Field
PredefinedBookValueNames Class See Also Send Feedback
List sheet number

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string ListSheetNumber
Visual Basic (Declaration)
Public Const ListSheetNumber As String
Visual C++
public:
literal String^ ListSheetNumber

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


ListSheetNumberZero Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.ListSheetNumberZero Field
PredefinedBookValueNames Class See Also Send Feedback
List sheet number zero

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string ListSheetNumberZero
Visual Basic (Declaration)
Public Const ListSheetNumberZero As String
Visual C++
public:
literal String^ ListSheetNumberZero

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


ListTitle Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.ListTitle Field
PredefinedBookValueNames Class See Also Send Feedback
List title

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string ListTitle
Visual Basic (Declaration)
Public Const ListTitle As String
Visual C++
public:
literal String^ ListTitle

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


Object Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.Object Field
PredefinedBookValueNames Class See Also Send Feedback
Object

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string Object
Visual Basic (Declaration)
Public Const Object As String
Visual C++
public:
literal String^ Object

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


OptionFilters Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.OptionFilters Field
PredefinedBookValueNames Class See Also Send Feedback
Option filters

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string OptionFilters
Visual Basic (Declaration)
Public Const OptionFilters As String
Visual C++
public:
literal String^ OptionFilters

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


Page Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.Page Field
PredefinedBookValueNames Class See Also Send Feedback
Page

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string Page
Visual Basic (Declaration)
Public Const Page As String
Visual C++
public:
literal String^ Page

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


PartDescription Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.PartDescription Field
PredefinedBookValueNames Class See Also Send Feedback
Part description

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string PartDescription
Visual Basic (Declaration)
Public Const PartDescription As String
Visual C++
public:
literal String^ PartDescription

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


PartNumber Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.PartNumber Field
PredefinedBookValueNames Class See Also Send Feedback
Part number

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string PartNumber
Visual Basic (Declaration)
Public Const PartNumber As String
Visual C++
public:
literal String^ PartNumber

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


PictureSheetNumber Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.PictureSheetNumber Field
PredefinedBookValueNames Class See Also Send Feedback
Picture sheet number

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string PictureSheetNumber
Visual Basic (Declaration)
Public Const PictureSheetNumber As String
Visual C++
public:
literal String^ PictureSheetNumber

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


PictureSheetNumberZero Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.PictureSheetNumberZero Field
PredefinedBookValueNames Class See Also Send Feedback
Picture sheet number zero

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string PictureSheetNumberZero
Visual Basic (Declaration)
Public Const PictureSheetNumberZero As String
Visual C++
public:
literal String^ PictureSheetNumberZero

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


PictureTitle Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.PictureTitle Field
PredefinedBookValueNames Class See Also Send Feedback
Picture title

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string PictureTitle
Visual Basic (Declaration)
Public Const PictureTitle As String
Visual C++
public:
literal String^ PictureTitle

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


PrintSheetNumber Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.PrintSheetNumber Field
PredefinedBookValueNames Class See Also Send Feedback
Print sheet number

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string PrintSheetNumber
Visual Basic (Declaration)
Public Const PrintSheetNumber As String
Visual C++
public:
literal String^ PrintSheetNumber

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


PrintSheetNumberZero Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.PrintSheetNumberZero Field
PredefinedBookValueNames Class See Also Send Feedback
Print sheet number zero

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string PrintSheetNumberZero
Visual Basic (Declaration)
Public Const PrintSheetNumberZero As String
Visual C++
public:
literal String^ PrintSheetNumberZero

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


Publisher Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.Publisher Field
PredefinedBookValueNames Class See Also Send Feedback
Publisher

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string Publisher
Visual Basic (Declaration)
Public Const Publisher As String
Visual C++
public:
literal String^ Publisher

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


Reference Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.Reference Field
PredefinedBookValueNames Class See Also Send Feedback
Reference

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string Reference
Visual Basic (Declaration)
Public Const Reference As String
Visual C++
public:
literal String^ Reference

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


SelectionListPath Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.SelectionListPath Field
PredefinedBookValueNames Class See Also Send Feedback
Selection ist path

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string SelectionListPath
Visual Basic (Declaration)
Public Const SelectionListPath As String
Visual C++
public:
literal String^ SelectionListPath

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


Time Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.Time Field
PredefinedBookValueNames Class See Also Send Feedback
Time

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string Time
Visual Basic (Declaration)
Public Const Time As String
Visual C++
public:
literal String^ Time

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


View Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.View Field
PredefinedBookValueNames Class See Also Send Feedback
View

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string View
Visual Basic (Declaration)
Public Const View As String
Visual C++
public:
literal String^ View

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


VisibleItem Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.VisibleItem Field
PredefinedBookValueNames Class See Also Send Feedback
Visible item

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string VisibleItem
Visual Basic (Declaration)
Public Const VisibleItem As String
Visual C++
public:
literal String^ VisibleItem

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


VisiblePage Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.VisiblePage Field
PredefinedBookValueNames Class See Also Send Feedback
Visible page

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string VisiblePage
Visual Basic (Declaration)
Public Const VisiblePage As String
Visual C++
public:
literal String^ VisiblePage

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


VisibleReference Field

[image]

LinkOne WebView API
PredefinedBookValueNames..::.VisibleReference Field
PredefinedBookValueNames Class See Also Send Feedback
Visible reference

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string VisibleReference
Visual Basic (Declaration)
Public Const VisibleReference As String
Visual C++
public:
literal String^ VisibleReference

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


PredefinedBookValueNames Properties

[image] [image]

LinkOne WebView API
PredefinedBookValueNames Properties
PredefinedBookValueNames Class See Also Send Feedback

The PredefinedBookValueNames type exposes the following members.

Properties

Name Description
List
The list of feld names (read-only).

Examples

CopyC#
// Prints out all the predefined book value names
foreach ( string bookValueName in PredefinedBookValueNames.List )
{
    Console.WriteLine( bookValueName );
}

// Prints the book title using the BOOK_TITLE value
IBook book = Library.Publishers[ "SpaceCo" ].Books[ "Spaceship" ];
string bookValue = book.Values[ PredefinedBookValueNames.BookTitle ];
Console.WriteLine( bookValue );

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


List Property

[image]

LinkOne WebView API
PredefinedBookValueNames..::.List Property
PredefinedBookValueNames Class See Also Send Feedback
The list of feld names (read-only).

Examples

CopyC#
// Prints out all the predefined book value names
foreach ( string bookValueName in PredefinedBookValueNames.List )
{
    Console.WriteLine( bookValueName );
}

// Prints the book title using the BOOK_TITLE value
IBook book = Library.Publishers[ "SpaceCo" ].Books[ "Spaceship" ];
string bookValue = book.Values[ PredefinedBookValueNames.BookTitle ];
Console.WriteLine( bookValue );

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static IList<string> List { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property List As IList(Of String)
Visual C++
public:
static property IList<String^>^ List {
    IList<String^>^ get ();
}

See Also

PredefinedBookValueNames Class
Mincom.LinkOne.Dom Namespace


PredefinedEntryFieldNames Class

[image]

LinkOne WebView API
PredefinedEntryFieldNames Class
Members See Also Send Feedback
Predefined entry fields.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static class PredefinedEntryFieldNames
Visual Basic (Declaration)
Public NotInheritable Class PredefinedEntryFieldNames
Visual C++
public ref class PredefinedEntryFieldNames abstract sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.PredefinedEntryFieldNames

See Also

PredefinedEntryFieldNames Members
Mincom.LinkOne.Dom Namespace


PredefinedEntryFieldNames Members

[image] [image]

LinkOne WebView API
PredefinedEntryFieldNames Members
PredefinedEntryFieldNames Class Fields Properties See Also Send Feedback

The PredefinedEntryFieldNames type exposes the following members.

Fields

Name | Description
Alternative | Alternative.
Description | Description.
ItemID | Item id.
LinkBook | Link book.
LinkIcon | Link icon.
LinkItem | Link item.
LinkPageNo | Link page number.
LinkPublisher | Link publisher.
LinkReference | Link reference.
NoteIcon |
Options | Options.
PartNumber | Part number.
Quantity | Quantity.
SelectionIcon | Selection icon.
Units | Units.
Weight | Weight.

Properties

Name | Description
List | The list of field names (read-only).

See Also

PredefinedEntryFieldNames Class
Mincom.LinkOne.Dom Namespace


PredefinedEntryFieldNames Fields

[image] [image]

LinkOne WebView API
PredefinedEntryFieldNames Fields
PredefinedEntryFieldNames Class See Also Send Feedback

The PredefinedEntryFieldNames type exposes the following members.

Fields

Name | Description
Alternative | Alternative.
Description | Description.
ItemID | Item id.
LinkBook | Link book.
LinkIcon | Link icon.
LinkItem | Link item.
LinkPageNo | Link page number.
LinkPublisher | Link publisher.
LinkReference | Link reference.
NoteIcon |
Options | Options.
PartNumber | Part number.
Quantity | Quantity.
SelectionIcon | Selection icon.
Units | Units.
Weight | Weight.

See Also

PredefinedEntryFieldNames Class
Mincom.LinkOne.Dom Namespace


Alternative Field

[image]

LinkOne WebView API
PredefinedEntryFieldNames..::.Alternative Field
PredefinedEntryFieldNames Class See Also Send Feedback
Alternative.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string Alternative
Visual Basic (Declaration)
Public Const Alternative As String
Visual C++
public:
literal String^ Alternative

See Also

PredefinedEntryFieldNames Class
Mincom.LinkOne.Dom Namespace


Description Field

[image]

LinkOne WebView API
PredefinedEntryFieldNames..::.Description Field
PredefinedEntryFieldNames Class See Also Send Feedback
Description.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string Description
Visual Basic (Declaration)
Public Const Description As String
Visual C++
public:
literal String^ Description

See Also

PredefinedEntryFieldNames Class
Mincom.LinkOne.Dom Namespace


ItemID Field

[image]

LinkOne WebView API
PredefinedEntryFieldNames..::.ItemID Field
PredefinedEntryFieldNames Class See Also Send Feedback
Item id.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string ItemID
Visual Basic (Declaration)
Public Const ItemID As String
Visual C++
public:
literal String^ ItemID

See Also

PredefinedEntryFieldNames Class
Mincom.LinkOne.Dom Namespace


LinkBook Field

[image]

LinkOne WebView API
PredefinedEntryFieldNames..::.LinkBook Field
PredefinedEntryFieldNames Class See Also Send Feedback
Link book.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string LinkBook
Visual Basic (Declaration)
Public Const LinkBook As String
Visual C++
public:
literal String^ LinkBook

See Also

PredefinedEntryFieldNames Class
Mincom.LinkOne.Dom Namespace


LinkIcon Field

[image]

LinkOne WebView API
PredefinedEntryFieldNames..::.LinkIcon Field
PredefinedEntryFieldNames Class See Also Send Feedback
Link icon.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string LinkIcon
Visual Basic (Declaration)
Public Const LinkIcon As String
Visual C++
public:
literal String^ LinkIcon

See Also

PredefinedEntryFieldNames Class
Mincom.LinkOne.Dom Namespace


LinkItem Field

[image]

LinkOne WebView API
PredefinedEntryFieldNames..::.LinkItem Field
PredefinedEntryFieldNames Class See Also Send Feedback
Link item.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string LinkItem
Visual Basic (Declaration)
Public Const LinkItem As String
Visual C++
public:
literal String^ LinkItem

See Also

PredefinedEntryFieldNames Class
Mincom.LinkOne.Dom Namespace


LinkPageNo Field

[image]

LinkOne WebView API
PredefinedEntryFieldNames..::.LinkPageNo Field
PredefinedEntryFieldNames Class See Also Send Feedback
Link page number.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string LinkPageNo
Visual Basic (Declaration)
Public Const LinkPageNo As String
Visual C++
public:
literal String^ LinkPageNo

See Also

PredefinedEntryFieldNames Class
Mincom.LinkOne.Dom Namespace


LinkPublisher Field

[image]

LinkOne WebView API
PredefinedEntryFieldNames..::.LinkPublisher Field
PredefinedEntryFieldNames Class See Also Send Feedback
Link publisher.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string LinkPublisher
Visual Basic (Declaration)
Public Const LinkPublisher As String
Visual C++
public:
literal String^ LinkPublisher

See Also

PredefinedEntryFieldNames Class
Mincom.LinkOne.Dom Namespace


LinkReference Field

[image]

LinkOne WebView API
PredefinedEntryFieldNames..::.LinkReference Field
PredefinedEntryFieldNames Class See Also Send Feedback
Link reference.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string LinkReference
Visual Basic (Declaration)
Public Const LinkReference As String
Visual C++
public:
literal String^ LinkReference

See Also

PredefinedEntryFieldNames Class
Mincom.LinkOne.Dom Namespace


NoteIcon Field

[image]

LinkOne WebView API
PredefinedEntryFieldNames..::.NoteIcon Field
PredefinedEntryFieldNames Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string NoteIcon
Visual Basic (Declaration)
Public Const NoteIcon As String
Visual C++
public:
literal String^ NoteIcon

See Also

PredefinedEntryFieldNames Class
Mincom.LinkOne.Dom Namespace


Options Field

[image]

LinkOne WebView API
PredefinedEntryFieldNames..::.Options Field
PredefinedEntryFieldNames Class See Also Send Feedback
Options.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string Options
Visual Basic (Declaration)
Public Const Options As String
Visual C++
public:
literal String^ Options

See Also

PredefinedEntryFieldNames Class
Mincom.LinkOne.Dom Namespace


PartNumber Field

[image]

LinkOne WebView API
PredefinedEntryFieldNames..::.PartNumber Field
PredefinedEntryFieldNames Class See Also Send Feedback
Part number.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string PartNumber
Visual Basic (Declaration)
Public Const PartNumber As String
Visual C++
public:
literal String^ PartNumber

See Also

PredefinedEntryFieldNames Class
Mincom.LinkOne.Dom Namespace


Quantity Field

[image]

LinkOne WebView API
PredefinedEntryFieldNames..::.Quantity Field
PredefinedEntryFieldNames Class See Also Send Feedback
Quantity.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string Quantity
Visual Basic (Declaration)
Public Const Quantity As String
Visual C++
public:
literal String^ Quantity

See Also

PredefinedEntryFieldNames Class
Mincom.LinkOne.Dom Namespace


SelectionIcon Field

[image]

LinkOne WebView API
PredefinedEntryFieldNames..::.SelectionIcon Field
PredefinedEntryFieldNames Class See Also Send Feedback
Selection icon.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string SelectionIcon
Visual Basic (Declaration)
Public Const SelectionIcon As String
Visual C++
public:
literal String^ SelectionIcon

See Also

PredefinedEntryFieldNames Class
Mincom.LinkOne.Dom Namespace


Units Field

[image]

LinkOne WebView API
PredefinedEntryFieldNames..::.Units Field
PredefinedEntryFieldNames Class See Also Send Feedback
Units.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string Units
Visual Basic (Declaration)
Public Const Units As String
Visual C++
public:
literal String^ Units

See Also

PredefinedEntryFieldNames Class
Mincom.LinkOne.Dom Namespace


Weight Field

[image]

LinkOne WebView API
PredefinedEntryFieldNames..::.Weight Field
PredefinedEntryFieldNames Class See Also Send Feedback
Weight.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string Weight
Visual Basic (Declaration)
Public Const Weight As String
Visual C++
public:
literal String^ Weight

See Also

PredefinedEntryFieldNames Class
Mincom.LinkOne.Dom Namespace


PredefinedEntryFieldNames Properties

[image] [image]

LinkOne WebView API
PredefinedEntryFieldNames Properties
PredefinedEntryFieldNames Class See Also Send Feedback

The PredefinedEntryFieldNames type exposes the following members.

Properties

Name | Description
List | The list of field names (read-only).

See Also

PredefinedEntryFieldNames Class
Mincom.LinkOne.Dom Namespace


List Property

[image]

LinkOne WebView API
PredefinedEntryFieldNames..::.List Property
PredefinedEntryFieldNames Class See Also Send Feedback
The list of field names (read-only).

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static IList<string> List { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property List As IList(Of String)
Visual C++
public:
static property IList<String^>^ List {
    IList<String^>^ get ();
}

See Also

PredefinedEntryFieldNames Class
Mincom.LinkOne.Dom Namespace


PredefinedLibraryValueNames Class

[image]

LinkOne WebView API
PredefinedLibraryValueNames Class
Members See Also Send Feedback
The library predefined values.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static class PredefinedLibraryValueNames
Visual Basic (Declaration)
Public NotInheritable Class PredefinedLibraryValueNames
Visual C++
public ref class PredefinedLibraryValueNames abstract sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.PredefinedLibraryValueNames

See Also

PredefinedLibraryValueNames Members
Mincom.LinkOne.Dom Namespace


PredefinedLibraryValueNames Members

[image] [image]

LinkOne WebView API
PredefinedLibraryValueNames Members
PredefinedLibraryValueNames Class Fields Properties See Also Send Feedback

The PredefinedLibraryValueNames type exposes the following members.

Fields

Name | Description
Attention | "ATTENTION" value.
Book | "BOOK" value.
BookLocation | "BOOKLOCN" value.
BookSheetNumber | "BOOK_SHEETNO" value.
BookSheetNumberZero | "BOOK_SHEETNO_0" value.
BookTitle | "BOOK_TITLE" value.
Class | "CLASS" value.
ConfigurationServer | "CONFIG_SERVER" value.
Date | "DATE" value.
FileName | "FILENAME" value.
GtiCache | "GTI_CACHE" value.
GtiFileName | "GTI_FILENAME" value.
ItemId | "ITEM" value.
LinkOneDirectory | "L1DIR" value.
LinkOneVersion | "L1_VERSION" value.
ListSheetNumber | "LIST_SHEETNO" value.
ListSheetNumberZero | "LIST_SHEETNO_0" value.
ListTitle | "LIST_TITLE" value.
Object | "OBJECT" value.
OptionFilters | "OPTION_FILTERS" value.
Page | "PAGE" value.
PartDescription | "PARTDESCR" value.
PartNumber | "PARTNO" value.
PictureSheetNumber | "PIC_SHEETNO" value.
PictureSheetNumberZero | "PIC_SHEETNO_0" value.
PictureTitle | "PICTURE_TITLE" value.
PrintSheetNumber | "PRINT_SHEETNO" value.
PrintSheetNumberZero | "PRINT_SHEETNO_0" value.
Publisher | "PUB" value.
Reference | "REF" value.
SelectionListPath | "SEL_PATH" value.
Selections | "SELECTIONS" value.
SelectionsAndAttention | "SEL&ATTN" value.
SelFile | "SELFILE" value
SelFileFiltered | "SELFILE_FILTERED" value.
Time | "TIME" value.
View | "VIEW".
VisibleItem | "VISIBLEITEM" value.
VisiblePage | "VISIBLEPAGE" value.
VisibleReference | "VISIBLEREF" value.

Properties

Name | Description
List | The list of feld names (read-only).

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


PredefinedLibraryValueNames Fields

[image] [image]

LinkOne WebView API
PredefinedLibraryValueNames Fields
PredefinedLibraryValueNames Class See Also Send Feedback

The PredefinedLibraryValueNames type exposes the following members.

Fields

Name | Description
Attention | "ATTENTION" value.
Book | "BOOK" value.
BookLocation | "BOOKLOCN" value.
BookSheetNumber | "BOOK_SHEETNO" value.
BookSheetNumberZero | "BOOK_SHEETNO_0" value.
BookTitle | "BOOK_TITLE" value.
Class | "CLASS" value.
ConfigurationServer | "CONFIG_SERVER" value.
Date | "DATE" value.
FileName | "FILENAME" value.
GtiCache | "GTI_CACHE" value.
GtiFileName | "GTI_FILENAME" value.
ItemId | "ITEM" value.
LinkOneDirectory | "L1DIR" value.
LinkOneVersion | "L1_VERSION" value.
ListSheetNumber | "LIST_SHEETNO" value.
ListSheetNumberZero | "LIST_SHEETNO_0" value.
ListTitle | "LIST_TITLE" value.
Object | "OBJECT" value.
OptionFilters | "OPTION_FILTERS" value.
Page | "PAGE" value.
PartDescription | "PARTDESCR" value.
PartNumber | "PARTNO" value.
PictureSheetNumber | "PIC_SHEETNO" value.
PictureSheetNumberZero | "PIC_SHEETNO_0" value.
PictureTitle | "PICTURE_TITLE" value.
PrintSheetNumber | "PRINT_SHEETNO" value.
PrintSheetNumberZero | "PRINT_SHEETNO_0" value.
Publisher | "PUB" value.
Reference | "REF" value.
SelectionListPath | "SEL_PATH" value.
Selections | "SELECTIONS" value.
SelectionsAndAttention | "SEL&ATTN" value.
SelFile | "SELFILE" value
SelFileFiltered | "SELFILE_FILTERED" value.
Time | "TIME" value.
View | "VIEW".
VisibleItem | "VISIBLEITEM" value.
VisiblePage | "VISIBLEPAGE" value.
VisibleReference | "VISIBLEREF" value.

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


Attention Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.Attention Field
PredefinedLibraryValueNames Class See Also Send Feedback
"ATTENTION" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string Attention
Visual Basic (Declaration)
Public Const Attention As String
Visual C++
public:
literal String^ Attention

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


Book Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.Book Field
PredefinedLibraryValueNames Class See Also Send Feedback
"BOOK" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string Book
Visual Basic (Declaration)
Public Const Book As String
Visual C++
public:
literal String^ Book

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


BookLocation Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.BookLocation Field
PredefinedLibraryValueNames Class See Also Send Feedback
"BOOKLOCN" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string BookLocation
Visual Basic (Declaration)
Public Const BookLocation As String
Visual C++
public:
literal String^ BookLocation

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


BookSheetNumber Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.BookSheetNumber Field
PredefinedLibraryValueNames Class See Also Send Feedback
"BOOK_SHEETNO" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string BookSheetNumber
Visual Basic (Declaration)
Public Const BookSheetNumber As String
Visual C++
public:
literal String^ BookSheetNumber

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


BookSheetNumberZero Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.BookSheetNumberZero Field
PredefinedLibraryValueNames Class See Also Send Feedback
"BOOK_SHEETNO_0" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string BookSheetNumberZero
Visual Basic (Declaration)
Public Const BookSheetNumberZero As String
Visual C++
public:
literal String^ BookSheetNumberZero

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


BookTitle Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.BookTitle Field
PredefinedLibraryValueNames Class See Also Send Feedback
"BOOK_TITLE" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string BookTitle
Visual Basic (Declaration)
Public Const BookTitle As String
Visual C++
public:
literal String^ BookTitle

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


Class Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.Class Field
PredefinedLibraryValueNames Class See Also Send Feedback
"CLASS" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string Class
Visual Basic (Declaration)
Public Const Class As String
Visual C++
public:
literal String^ Class

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


ConfigurationServer Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.ConfigurationServer Field
PredefinedLibraryValueNames Class See Also Send Feedback
"CONFIG_SERVER" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string ConfigurationServer
Visual Basic (Declaration)
Public Const ConfigurationServer As String
Visual C++
public:
literal String^ ConfigurationServer

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


Date Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.Date Field
PredefinedLibraryValueNames Class See Also Send Feedback
"DATE" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string Date
Visual Basic (Declaration)
Public Const Date As String
Visual C++
public:
literal String^ Date

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


FileName Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.FileName Field
PredefinedLibraryValueNames Class See Also Send Feedback
"FILENAME" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string FileName
Visual Basic (Declaration)
Public Const FileName As String
Visual C++
public:
literal String^ FileName

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


GtiCache Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.GtiCache Field
PredefinedLibraryValueNames Class See Also Send Feedback
"GTI_CACHE" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string GtiCache
Visual Basic (Declaration)
Public Const GtiCache As String
Visual C++
public:
literal String^ GtiCache

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


GtiFileName Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.GtiFileName Field
PredefinedLibraryValueNames Class See Also Send Feedback
"GTI_FILENAME" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string GtiFileName
Visual Basic (Declaration)
Public Const GtiFileName As String
Visual C++
public:
literal String^ GtiFileName

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


ItemId Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.ItemId Field
PredefinedLibraryValueNames Class See Also Send Feedback
"ITEM" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string ItemId
Visual Basic (Declaration)
Public Const ItemId As String
Visual C++
public:
literal String^ ItemId

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


LinkOneDirectory Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.LinkOneDirectory Field
PredefinedLibraryValueNames Class See Also Send Feedback
"L1DIR" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string LinkOneDirectory
Visual Basic (Declaration)
Public Const LinkOneDirectory As String
Visual C++
public:
literal String^ LinkOneDirectory

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


LinkOneVersion Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.LinkOneVersion Field
PredefinedLibraryValueNames Class See Also Send Feedback
"L1_VERSION" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string LinkOneVersion
Visual Basic (Declaration)
Public Const LinkOneVersion As String
Visual C++
public:
literal String^ LinkOneVersion

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


ListSheetNumber Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.ListSheetNumber Field
PredefinedLibraryValueNames Class See Also Send Feedback
"LIST_SHEETNO" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string ListSheetNumber
Visual Basic (Declaration)
Public Const ListSheetNumber As String
Visual C++
public:
literal String^ ListSheetNumber

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


ListSheetNumberZero Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.ListSheetNumberZero Field
PredefinedLibraryValueNames Class See Also Send Feedback
"LIST_SHEETNO_0" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string ListSheetNumberZero
Visual Basic (Declaration)
Public Const ListSheetNumberZero As String
Visual C++
public:
literal String^ ListSheetNumberZero

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


ListTitle Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.ListTitle Field
PredefinedLibraryValueNames Class See Also Send Feedback
"LIST_TITLE" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string ListTitle
Visual Basic (Declaration)
Public Const ListTitle As String
Visual C++
public:
literal String^ ListTitle

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


Object Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.Object Field
PredefinedLibraryValueNames Class See Also Send Feedback
"OBJECT" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string Object
Visual Basic (Declaration)
Public Const Object As String
Visual C++
public:
literal String^ Object

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


OptionFilters Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.OptionFilters Field
PredefinedLibraryValueNames Class See Also Send Feedback
"OPTION_FILTERS" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string OptionFilters
Visual Basic (Declaration)
Public Const OptionFilters As String
Visual C++
public:
literal String^ OptionFilters

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


Page Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.Page Field
PredefinedLibraryValueNames Class See Also Send Feedback
"PAGE" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string Page
Visual Basic (Declaration)
Public Const Page As String
Visual C++
public:
literal String^ Page

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


PartDescription Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.PartDescription Field
PredefinedLibraryValueNames Class See Also Send Feedback
"PARTDESCR" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string PartDescription
Visual Basic (Declaration)
Public Const PartDescription As String
Visual C++
public:
literal String^ PartDescription

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


PartNumber Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.PartNumber Field
PredefinedLibraryValueNames Class See Also Send Feedback
"PARTNO" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string PartNumber
Visual Basic (Declaration)
Public Const PartNumber As String
Visual C++
public:
literal String^ PartNumber

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


PictureSheetNumber Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.PictureSheetNumber Field
PredefinedLibraryValueNames Class See Also Send Feedback
"PIC_SHEETNO" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string PictureSheetNumber
Visual Basic (Declaration)
Public Const PictureSheetNumber As String
Visual C++
public:
literal String^ PictureSheetNumber

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


PictureSheetNumberZero Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.PictureSheetNumberZero Field
PredefinedLibraryValueNames Class See Also Send Feedback
"PIC_SHEETNO_0" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string PictureSheetNumberZero
Visual Basic (Declaration)
Public Const PictureSheetNumberZero As String
Visual C++
public:
literal String^ PictureSheetNumberZero

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


PictureTitle Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.PictureTitle Field
PredefinedLibraryValueNames Class See Also Send Feedback
"PICTURE_TITLE" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string PictureTitle
Visual Basic (Declaration)
Public Const PictureTitle As String
Visual C++
public:
literal String^ PictureTitle

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


PrintSheetNumber Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.PrintSheetNumber Field
PredefinedLibraryValueNames Class See Also Send Feedback
"PRINT_SHEETNO" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string PrintSheetNumber
Visual Basic (Declaration)
Public Const PrintSheetNumber As String
Visual C++
public:
literal String^ PrintSheetNumber

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


PrintSheetNumberZero Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.PrintSheetNumberZero Field
PredefinedLibraryValueNames Class See Also Send Feedback
"PRINT_SHEETNO_0" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string PrintSheetNumberZero
Visual Basic (Declaration)
Public Const PrintSheetNumberZero As String
Visual C++
public:
literal String^ PrintSheetNumberZero

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


Publisher Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.Publisher Field
PredefinedLibraryValueNames Class See Also Send Feedback
"PUB" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string Publisher
Visual Basic (Declaration)
Public Const Publisher As String
Visual C++
public:
literal String^ Publisher

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


Reference Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.Reference Field
PredefinedLibraryValueNames Class See Also Send Feedback
"REF" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string Reference
Visual Basic (Declaration)
Public Const Reference As String
Visual C++
public:
literal String^ Reference

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


SelectionListPath Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.SelectionListPath Field
PredefinedLibraryValueNames Class See Also Send Feedback
"SEL_PATH" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string SelectionListPath
Visual Basic (Declaration)
Public Const SelectionListPath As String
Visual C++
public:
literal String^ SelectionListPath

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


Selections Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.Selections Field
PredefinedLibraryValueNames Class See Also Send Feedback
"SELECTIONS" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string Selections
Visual Basic (Declaration)
Public Const Selections As String
Visual C++
public:
literal String^ Selections

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


SelectionsAndAttention Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.SelectionsAndAttention Field
PredefinedLibraryValueNames Class See Also Send Feedback
"SEL&ATTN" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string SelectionsAndAttention
Visual Basic (Declaration)
Public Const SelectionsAndAttention As String
Visual C++
public:
literal String^ SelectionsAndAttention

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


SelFile Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.SelFile Field
PredefinedLibraryValueNames Class See Also Send Feedback
"SELFILE" value

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string SelFile
Visual Basic (Declaration)
Public Const SelFile As String
Visual C++
public:
literal String^ SelFile

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


SelFileFiltered Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.SelFileFiltered Field
PredefinedLibraryValueNames Class See Also Send Feedback
"SELFILE_FILTERED" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string SelFileFiltered
Visual Basic (Declaration)
Public Const SelFileFiltered As String
Visual C++
public:
literal String^ SelFileFiltered

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


Time Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.Time Field
PredefinedLibraryValueNames Class See Also Send Feedback
"TIME" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string Time
Visual Basic (Declaration)
Public Const Time As String
Visual C++
public:
literal String^ Time

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


View Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.View Field
PredefinedLibraryValueNames Class See Also Send Feedback
"VIEW".

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string View
Visual Basic (Declaration)
Public Const View As String
Visual C++
public:
literal String^ View

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


VisibleItem Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.VisibleItem Field
PredefinedLibraryValueNames Class See Also Send Feedback
"VISIBLEITEM" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string VisibleItem
Visual Basic (Declaration)
Public Const VisibleItem As String
Visual C++
public:
literal String^ VisibleItem

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


VisiblePage Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.VisiblePage Field
PredefinedLibraryValueNames Class See Also Send Feedback
"VISIBLEPAGE" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string VisiblePage
Visual Basic (Declaration)
Public Const VisiblePage As String
Visual C++
public:
literal String^ VisiblePage

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


VisibleReference Field

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.VisibleReference Field
PredefinedLibraryValueNames Class See Also Send Feedback
"VISIBLEREF" value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string VisibleReference
Visual Basic (Declaration)
Public Const VisibleReference As String
Visual C++
public:
literal String^ VisibleReference

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


PredefinedLibraryValueNames Properties

[image] [image]

LinkOne WebView API
PredefinedLibraryValueNames Properties
PredefinedLibraryValueNames Class See Also Send Feedback

The PredefinedLibraryValueNames type exposes the following members.

Properties

Name | Description
List | The list of feld names (read-only).

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


List Property

[image]

LinkOne WebView API
PredefinedLibraryValueNames..::.List Property
PredefinedLibraryValueNames Class See Also Send Feedback
The list of feld names (read-only).

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static IList<string> List { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property List As IList(Of String)
Visual C++
public:
static property IList<String^>^ List {
    IList<String^>^ get ();
}

See Also

PredefinedLibraryValueNames Class
Mincom.LinkOne.Dom Namespace


PredefinedPageFieldNames Class

[image]

LinkOne WebView API
PredefinedPageFieldNames Class
Members See Also Send Feedback
The predefined page fields.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static class PredefinedPageFieldNames
Visual Basic (Declaration)
Public NotInheritable Class PredefinedPageFieldNames
Visual C++
public ref class PredefinedPageFieldNames abstract sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.PredefinedPageFieldNames

See Also

PredefinedPageFieldNames Members
Mincom.LinkOne.Dom Namespace


PredefinedPageFieldNames Members

[image] [image]

LinkOne WebView API
PredefinedPageFieldNames Members
PredefinedPageFieldNames Class Fields Properties See Also Send Feedback

The PredefinedPageFieldNames type exposes the following members.

Fields

Name | Description
PageNumber | Page number.
PageReference | Page reference.
Title | Title.

Properties

Name | Description
List | The list of field names (read-only).

See Also

PredefinedPageFieldNames Class
Mincom.LinkOne.Dom Namespace


PredefinedPageFieldNames Fields

[image] [image]

LinkOne WebView API
PredefinedPageFieldNames Fields
PredefinedPageFieldNames Class See Also Send Feedback

The PredefinedPageFieldNames type exposes the following members.

Fields

Name | Description
PageNumber | Page number.
PageReference | Page reference.
Title | Title.

See Also

PredefinedPageFieldNames Class
Mincom.LinkOne.Dom Namespace


PageNumber Field

[image]

LinkOne WebView API
PredefinedPageFieldNames..::.PageNumber Field
PredefinedPageFieldNames Class See Also Send Feedback
Page number.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string PageNumber
Visual Basic (Declaration)
Public Const PageNumber As String
Visual C++
public:
literal String^ PageNumber

See Also

PredefinedPageFieldNames Class
Mincom.LinkOne.Dom Namespace


PageReference Field

[image]

LinkOne WebView API
PredefinedPageFieldNames..::.PageReference Field
PredefinedPageFieldNames Class See Also Send Feedback
Page reference.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string PageReference
Visual Basic (Declaration)
Public Const PageReference As String
Visual C++
public:
literal String^ PageReference

See Also

PredefinedPageFieldNames Class
Mincom.LinkOne.Dom Namespace


Title Field

[image]

LinkOne WebView API
PredefinedPageFieldNames..::.Title Field
PredefinedPageFieldNames Class See Also Send Feedback
Title.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string Title
Visual Basic (Declaration)
Public Const Title As String
Visual C++
public:
literal String^ Title

See Also

PredefinedPageFieldNames Class
Mincom.LinkOne.Dom Namespace


PredefinedPageFieldNames Properties

[image] [image]

LinkOne WebView API
PredefinedPageFieldNames Properties
PredefinedPageFieldNames Class See Also Send Feedback

The PredefinedPageFieldNames type exposes the following members.

Properties

Name | Description
List | The list of field names (read-only).

See Also

PredefinedPageFieldNames Class
Mincom.LinkOne.Dom Namespace


List Property

[image]

LinkOne WebView API
PredefinedPageFieldNames..::.List Property
PredefinedPageFieldNames Class See Also Send Feedback
The list of field names (read-only).

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static IList<string> List { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property List As IList(Of String)
Visual C++
public:
static property IList<String^>^ List {
    IList<String^>^ get ();
}

See Also

PredefinedPageFieldNames Class
Mincom.LinkOne.Dom Namespace


PredefinedPictureFieldNames Class

[image]

LinkOne WebView API
PredefinedPictureFieldNames Class
Members See Also Send Feedback
The predefined picture fields.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static class PredefinedPictureFieldNames
Visual Basic (Declaration)
Public NotInheritable Class PredefinedPictureFieldNames
Visual C++
public ref class PredefinedPictureFieldNames abstract sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.PredefinedPictureFieldNames

See Also

PredefinedPictureFieldNames Members
Mincom.LinkOne.Dom Namespace


PredefinedPictureFieldNames Members

[image] [image]

LinkOne WebView API
PredefinedPictureFieldNames Members
PredefinedPictureFieldNames Class Fields Properties See Also Send Feedback

The PredefinedPictureFieldNames type exposes the following members.

Fields

Name | Description
PictureNumber | Picture number.
Title | Title field.

Properties

Name | Description
List | The list of field names (read-only).

See Also

PredefinedPictureFieldNames Class
Mincom.LinkOne.Dom Namespace


PredefinedPictureFieldNames Fields

[image] [image]

LinkOne WebView API
PredefinedPictureFieldNames Fields
PredefinedPictureFieldNames Class See Also Send Feedback

The PredefinedPictureFieldNames type exposes the following members.

Fields

Name | Description
PictureNumber | Picture number.
Title | Title field.

See Also

PredefinedPictureFieldNames Class
Mincom.LinkOne.Dom Namespace


PictureNumber Field

[image]

LinkOne WebView API
PredefinedPictureFieldNames..::.PictureNumber Field
PredefinedPictureFieldNames Class See Also Send Feedback
Picture number.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string PictureNumber
Visual Basic (Declaration)
Public Const PictureNumber As String
Visual C++
public:
literal String^ PictureNumber

See Also

PredefinedPictureFieldNames Class
Mincom.LinkOne.Dom Namespace


Title Field

[image]

LinkOne WebView API
PredefinedPictureFieldNames..::.Title Field
PredefinedPictureFieldNames Class See Also Send Feedback
Title field.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string Title
Visual Basic (Declaration)
Public Const Title As String
Visual C++
public:
literal String^ Title

See Also

PredefinedPictureFieldNames Class
Mincom.LinkOne.Dom Namespace


PredefinedPictureFieldNames Properties

[image] [image]

LinkOne WebView API
PredefinedPictureFieldNames Properties
PredefinedPictureFieldNames Class See Also Send Feedback

The PredefinedPictureFieldNames type exposes the following members.

Properties

Name | Description
List | The list of field names (read-only).

See Also

PredefinedPictureFieldNames Class
Mincom.LinkOne.Dom Namespace


List Property

[image]

LinkOne WebView API
PredefinedPictureFieldNames..::.List Property
PredefinedPictureFieldNames Class See Also Send Feedback
The list of field names (read-only).

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static IList<string> List { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property List As IList(Of String)
Visual C++
public:
static property IList<String^>^ List {
    IList<String^>^ get ();
}

See Also

PredefinedPictureFieldNames Class
Mincom.LinkOne.Dom Namespace


Publisher Class

[image]

LinkOne WebView API
Publisher Class
Members See Also Send Feedback
Represents a LinkOne publisher of Book objects.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class Publisher : IPersist,
    IPublisher, IDisposable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class Publisher _
    Implements IPersist, IPublisher, IDisposable
Visual C++
[SerializableAttribute]
public ref class Publisher sealed : IPersist,
    IPublisher, IDisposable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.Publisher

See Also

Publisher Members
Mincom.LinkOne.Dom Namespace


Publisher Members

[image] [image]

LinkOne WebView API
Publisher Members
Publisher Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The Publisher type exposes the following members.

Constructors

Name | Description
Publisher | Initialises a new instance of the Publisher class using the supplied IDomReader.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Books | Gets a collection of all books from this publisher.
Catalog | Gets a collection of all books from this publisher organised by their category.
Categories | Gets the note categories visible to the publisher and library.
Library | Gets the library.
Notes | Gets the notes visible to the publisher and library.
PublisherCode | Gets the publisher code.
PublisherDescription | Gets the publisher description.
PublisherDescriptionTranslations | Gets the publisher description translations.

Explicit Interface Implementations

Name | Description
IPublisher..::.Books |
IPublisher..::.Catalog |
IPublisher..::.Categories |
IPublisher..::.Library |
IPublisher..::.Notes |
IPublisher..::.PublisherDescriptionTranslations |

See Also

Publisher Class
Mincom.LinkOne.Dom Namespace


Publisher Constructor

[image]

LinkOne WebView API
Publisher Constructor
Publisher Class See Also Send Feedback
Initialises a new instance of the Publisher class using the supplied IDomReader.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Publisher(
    IDomReader domReader
)
Visual Basic (Declaration)
Public Sub New ( _
    domReader As IDomReader _
)
Visual C++
public:
Publisher(
    IDomReader^ domReader
)

Parameters

domReader
Type: IDomReader
The IDomReader to initialize the publisher must be signed by Mincom

See Also

Publisher Class
Mincom.LinkOne.Dom Namespace


Publisher Methods

[image] [image]

LinkOne WebView API
Publisher Methods
Publisher Class See Also Send Feedback

The Publisher type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Publisher Class
Mincom.LinkOne.Dom Namespace


Dispose Method

[image]

LinkOne WebView API
Publisher..::.Dispose Method
Publisher Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

Publisher Class
Mincom.LinkOne.Dom Namespace


Publisher Properties

[image] [image]

LinkOne WebView API
Publisher Properties
Publisher Class See Also Send Feedback

The Publisher type exposes the following members.

Properties

Name | Description
Books | Gets a collection of all books from this publisher.
Catalog | Gets a collection of all books from this publisher organised by their category.
Categories | Gets the note categories visible to the publisher and library.
Library | Gets the library.
Notes | Gets the notes visible to the publisher and library.
PublisherCode | Gets the publisher code.
PublisherDescription | Gets the publisher description.
PublisherDescriptionTranslations | Gets the publisher description translations.

Explicit Interface Implementations

Name | Description
IPublisher..::.Books |
IPublisher..::.Catalog |
IPublisher..::.Categories |
IPublisher..::.Library |
IPublisher..::.Notes |
IPublisher..::.PublisherDescriptionTranslations |

See Also

Publisher Class
Mincom.LinkOne.Dom Namespace


Books Property

[image]

LinkOne WebView API
Publisher..::.Books Property
Publisher Class See Also Send Feedback
Gets a collection of all books from this publisher.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookCollection Books { get; }
Visual Basic (Declaration)
Public ReadOnly Property Books As BookCollection
Visual C++
public:
property BookCollection^ Books {
    BookCollection^ get ();
}

See Also

Publisher Class
Mincom.LinkOne.Dom Namespace


Catalog Property

[image]

LinkOne WebView API
Publisher..::.Catalog Property
Publisher Class See Also Send Feedback
Gets a collection of all books from this publisher organised by their category.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Catalog Catalog { get; }
Visual Basic (Declaration)
Public ReadOnly Property Catalog As Catalog
Visual C++
public:
property Catalog^ Catalog {
    Catalog^ get ();
}

See Also

Publisher Class
Mincom.LinkOne.Dom Namespace


Categories Property

[image]

LinkOne WebView API
Publisher..::.Categories Property
Publisher Class See Also Send Feedback
Gets the note categories visible to the publisher and library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public CategoryCollection Categories { get; }
Visual Basic (Declaration)
Public ReadOnly Property Categories As CategoryCollection
Visual C++
public:
property CategoryCollection^ Categories {
    CategoryCollection^ get ();
}

See Also

Publisher Class
Mincom.LinkOne.Dom Namespace


IPublisher.Books Property

[image]

LinkOne WebView API
Publisher..::.IPublisher..::.Books Property
Publisher Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IBookCollection IPublisher.Books { get; }
Visual Basic (Declaration)
Private ReadOnly Property Books As IBookCollection
    Implements IPublisher.Books
Visual C++
private:
virtual property IBookCollection^ Books {
    IBookCollection^ get () sealed = IPublisher::Books::get;
}

Implements

IPublisher..::.Books

See Also

Publisher Class
Mincom.LinkOne.Dom Namespace


IPublisher.Catalog Property

[image]

LinkOne WebView API
Publisher..::.IPublisher..::.Catalog Property
Publisher Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ICatalog IPublisher.Catalog { get; }
Visual Basic (Declaration)
Private ReadOnly Property Catalog As ICatalog
    Implements IPublisher.Catalog
Visual C++
private:
virtual property ICatalog^ Catalog {
    ICatalog^ get () sealed = IPublisher::Catalog::get;
}

Implements

IPublisher..::.Catalog

See Also

Publisher Class
Mincom.LinkOne.Dom Namespace


IPublisher.Categories Property

[image]

LinkOne WebView API
Publisher..::.IPublisher..::.Categories Property
Publisher Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ICategoryCollection IPublisher.Categories { get; }
Visual Basic (Declaration)
Private ReadOnly Property Categories As ICategoryCollection
    Implements IPublisher.Categories
Visual C++
private:
virtual property ICategoryCollection^ Categories {
    ICategoryCollection^ get () sealed = IPublisher::Categories::get;
}

Implements

IPublisher..::.Categories

See Also

Publisher Class
Mincom.LinkOne.Dom Namespace


IPublisher.Library Property

[image]

LinkOne WebView API
Publisher..::.IPublisher..::.Library Property
Publisher Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ILibrary IPublisher.Library { get; }
Visual Basic (Declaration)
Private ReadOnly Property Library As ILibrary
    Implements IPublisher.Library
Visual C++
private:
virtual property ILibrary^ Library {
    ILibrary^ get () sealed = IPublisher::Library::get;
}

Implements

IPublisher..::.Library

See Also

Publisher Class
Mincom.LinkOne.Dom Namespace


IPublisher.Notes Property

[image]

LinkOne WebView API
Publisher..::.IPublisher..::.Notes Property
Publisher Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
INoteCollection IPublisher.Notes { get; }
Visual Basic (Declaration)
Private ReadOnly Property Notes As INoteCollection
    Implements IPublisher.Notes
Visual C++
private:
virtual property INoteCollection^ Notes {
    INoteCollection^ get () sealed = IPublisher::Notes::get;
}

Implements

IPublisher..::.Notes

See Also

Publisher Class
Mincom.LinkOne.Dom Namespace


IPublisher.PublisherDescriptionTranslations Property

[image]

LinkOne WebView API
Publisher..::.IPublisher..::.PublisherDescriptionTranslations Property
Publisher Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ITranslationCollection IPublisher.PublisherDescriptionTranslations { get; }
Visual Basic (Declaration)
Private ReadOnly Property PublisherDescriptionTranslations As ITranslationCollection
    Implements IPublisher.PublisherDescriptionTranslations
Visual C++
private:
virtual property ITranslationCollection^ PublisherDescriptionTranslations {
    ITranslationCollection^ get () sealed = IPublisher::PublisherDescriptionTranslations::get;
}

Implements

IPublisher..::.PublisherDescriptionTranslations

See Also

Publisher Class
Mincom.LinkOne.Dom Namespace


Library Property

[image]

LinkOne WebView API
Publisher..::.Library Property
Publisher Class See Also Send Feedback
Gets the library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Library Library { get; internal set; }
Visual Basic (Declaration)
Public Property Library As Library
Visual C++
public:
property Library^ Library {
    Library^ get ();
    void set (Library^ value);
}

See Also

Publisher Class
Mincom.LinkOne.Dom Namespace


Notes Property

[image]

LinkOne WebView API
Publisher..::.Notes Property
Publisher Class See Also Send Feedback
Gets the notes visible to the publisher and library.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public NoteCollection Notes { get; }
Visual Basic (Declaration)
Public ReadOnly Property Notes As NoteCollection
Visual C++
public:
property NoteCollection^ Notes {
    NoteCollection^ get ();
}

See Also

Publisher Class
Mincom.LinkOne.Dom Namespace


PublisherCode Property

[image]

LinkOne WebView API
Publisher..::.PublisherCode Property
Publisher Class See Also Send Feedback
Gets the publisher code.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PublisherCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublisherCode As String
Visual C++
public:
virtual property String^ PublisherCode {
    String^ get () sealed;
}

Implements

IPublisher..::.PublisherCode

See Also

Publisher Class
Mincom.LinkOne.Dom Namespace


PublisherDescription Property

[image]

LinkOne WebView API
Publisher..::.PublisherDescription Property
Publisher Class See Also Send Feedback
Gets the publisher description.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PublisherDescription { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublisherDescription As String
Visual C++
public:
virtual property String^ PublisherDescription {
    String^ get () sealed;
}

Implements

IPublisher..::.PublisherDescription

See Also

Publisher Class
Mincom.LinkOne.Dom Namespace


PublisherDescriptionTranslations Property

[image]

LinkOne WebView API
Publisher..::.PublisherDescriptionTranslations Property
Publisher Class See Also Send Feedback
Gets the publisher description translations.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ReadOnlyTranslationCollection PublisherDescriptionTranslations { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublisherDescriptionTranslations As ReadOnlyTranslationCollection
Visual C++
public:
property ReadOnlyTranslationCollection^ PublisherDescriptionTranslations {
    ReadOnlyTranslationCollection^ get ();
}

See Also

Publisher Class
Mincom.LinkOne.Dom Namespace


PublisherCollection Class

[image]

LinkOne WebView API
PublisherCollection Class
Members See Also Send Feedback
Represents a collection of Publisher objects sorted by publisher code.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class PublisherCollection : IReadOnlyKeyedCollection<string, Publisher>,
    IReadOnlyCollection<Publisher>, IEnumerable<Publisher>, IPublisherCollection,
    IReadOnlyKeyedCollection<string, IPublisher>, IReadOnlyCollection<IPublisher>, IEnumerable<IPublisher>,
    IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class PublisherCollection _
    Implements IReadOnlyKeyedCollection(Of String, Publisher),  _
    IReadOnlyCollection(Of Publisher), IEnumerable(Of Publisher), IPublisherCollection,  _
    IReadOnlyKeyedCollection(Of String, IPublisher), IReadOnlyCollection(Of IPublisher),  _
    IEnumerable(Of IPublisher), IEnumerable
Visual C++
[SerializableAttribute]
public ref class PublisherCollection sealed : IReadOnlyKeyedCollection<String^, Publisher^>,
    IReadOnlyCollection<Publisher^>, IEnumerable<Publisher^>, IPublisherCollection,
    IReadOnlyKeyedCollection<String^, IPublisher^>, IReadOnlyCollection<IPublisher^>,
    IEnumerable<IPublisher^>, IEnumerable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.PublisherCollection

See Also

PublisherCollection Members
Mincom.LinkOne.Dom Namespace


PublisherCollection Members

[image] [image]

LinkOne WebView API
PublisherCollection Members
PublisherCollection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The PublisherCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSortedForLanguage | Returns the collection sorted by the translations for the given language.
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements in the collection.
Item | Gets the publisher.

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(IPublisher>)>)..::.Contains |
IEnumerable<(Of <(IPublisher>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.
IReadOnlyKeyedCollection<(Of <(String, IPublisher>)>)..::.Item |

See Also

PublisherCollection Class
Mincom.LinkOne.Dom Namespace


PublisherCollection Methods

[image] [image]

LinkOne WebView API
PublisherCollection Methods
PublisherCollection Class See Also Send Feedback

The PublisherCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSortedForLanguage | Returns the collection sorted by the translations for the given language.
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(IPublisher>)>)..::.Contains |
IEnumerable<(Of <(IPublisher>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.

See Also

PublisherCollection Class
Mincom.LinkOne.Dom Namespace


IEnumerable(IPublisher).GetEnumerator Method

[image]

LinkOne WebView API
PublisherCollection..::.IEnumerable<(Of <(IPublisher>)>)..::.GetEnumerator Method
PublisherCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator<IPublisher> IEnumerable<IPublisher>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of IPublisher)
    Implements IEnumerable(Of IPublisher).GetEnumerator
Visual C++
private:
virtual IEnumerator<IPublisher^>^ GetEnumerator() sealed = IEnumerable<IPublisher^>::GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

PublisherCollection Class
Mincom.LinkOne.Dom Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
PublisherCollection..::.IEnumerable..::.GetEnumerator Method
PublisherCollection Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

PublisherCollection Class
Mincom.LinkOne.Dom Namespace


Contains Method

[image] [image]

LinkOne WebView API
PublisherCollection..::.Contains Method
PublisherCollection Class See Also Send Feedback

Overload List

Name | Description
Contains(Publisher) | Determines whether the collection contains the specified publisher.
Contains(String) | Determines whether the collection contains the specified publisher.

See Also

PublisherCollection Class
PublisherCollection Members
Mincom.LinkOne.Dom Namespace


Contains Method (Publisher)

[image]

LinkOne WebView API
PublisherCollection..::.Contains Method (Publisher)
PublisherCollection Class See Also Send Feedback
Determines whether the collection contains the specified publisher.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    Publisher item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As Publisher _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Publisher^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Dom..::.Publisher
The publisher.

Return Value

true if the collection contains the publisher; otherwise, false.

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Contains(T)

See Also

PublisherCollection Class
Contains Overload
Mincom.LinkOne.Dom Namespace


Contains Method (String)

[image]

LinkOne WebView API
PublisherCollection..::.Contains Method (String)
PublisherCollection Class See Also Send Feedback
Determines whether the collection contains the specified publisher.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    string key
)
Visual Basic (Declaration)
Public Function Contains ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ key
) sealed

Parameters

key
Type: System..::.String
The publisher code for the publisher.

Return Value

true if the collection contains the publisher; otherwise, false.

Implements

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Contains(TKey)
IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Contains(TKey)

See Also

PublisherCollection Class
Contains Overload
Mincom.LinkOne.Dom Namespace


GetEnumerator Method

[image]

LinkOne WebView API
PublisherCollection..::.GetEnumerator Method
PublisherCollection Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IEnumerator<Publisher> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of Publisher)
Visual C++
public:
virtual IEnumerator<Publisher^>^ GetEnumerator() sealed

Return Value

A IEnumerator<(Of <(T>)>) that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

PublisherCollection Class
Mincom.LinkOne.Dom Namespace


GetSortedForLanguage Method

[image]

LinkOne WebView API
PublisherCollection..::.GetSortedForLanguage Method
PublisherCollection Class See Also Send Feedback
Returns the collection sorted by the translations for the given language.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IEnumerable<Publisher> GetSortedForLanguage(
    string languageCode,
    bool includeHidden
)
Visual Basic (Declaration)
Public Function GetSortedForLanguage ( _
    languageCode As String, _
    includeHidden As Boolean _
) As IEnumerable(Of Publisher)
Visual C++
public:
IEnumerable<Publisher^>^ GetSortedForLanguage(
    String^ languageCode,
    bool includeHidden
)

Parameters

languageCode
Type: System..::.String
The language code to sort by.
includeHidden
Type: System..::.Boolean
Use true to include hidden publishers.

Return Value

The collection sorted by the translations for the given language.

See Also

PublisherCollection Class
Mincom.LinkOne.Dom Namespace


IReadOnlyCollection(IPublisher).Contains Method

[image]

LinkOne WebView API
PublisherCollection..::.IReadOnlyCollection<(Of <(IPublisher>)>)..::.Contains Method
PublisherCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IReadOnlyCollection<IPublisher>.Contains(
    IPublisher domObject
)
Visual Basic (Declaration)
Private Function Contains ( _
    domObject As IPublisher _
) As Boolean Implements IReadOnlyCollection(Of IPublisher).Contains
Visual C++
private:
virtual bool Contains(
    IPublisher^ domObject
) sealed = IReadOnlyCollection<IPublisher^>::Contains

Parameters

domObject
Type: Mincom.LinkOne.Dom..::.IPublisher

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Contains(T)

See Also

PublisherCollection Class
Mincom.LinkOne.Dom Namespace


PublisherCollection Properties

[image] [image]

LinkOne WebView API
PublisherCollection Properties
PublisherCollection Class See Also Send Feedback

The PublisherCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection.
Item | Gets the publisher.

Explicit Interface Implementations

Name | Description
IReadOnlyKeyedCollection<(Of <(String, IPublisher>)>)..::.Item |

See Also

PublisherCollection Class
Mincom.LinkOne.Dom Namespace


Count Property

[image]

LinkOne WebView API
PublisherCollection..::.Count Property
PublisherCollection Class See Also Send Feedback
Gets the number of elements in the collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Count
IReadOnlyCollection<(Of <(T>)>)..::.Count

See Also

PublisherCollection Class
Mincom.LinkOne.Dom Namespace


IReadOnlyKeyedCollection(String, IPublisher).Item Property

[image]

LinkOne WebView API
PublisherCollection..::.IReadOnlyKeyedCollection<(Of <(String, IPublisher>)>)..::.Item Property
PublisherCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPublisher IReadOnlyKeyedCollection<string, IPublisher>.Item[
    string domObjectKey
] { get; }
Visual Basic (Declaration)
Private ReadOnly Property Item ( _
    domObjectKey As String _
) As IPublisher Implements IReadOnlyKeyedCollection(Of String, IPublisher).Item
Visual C++
private:
virtual property IPublisher^ Item[String^ domObjectKey] {
    IPublisher^ get (String^ domObjectKey) sealed = IReadOnlyKeyedCollection<String^, IPublisher^>::Item::get;
}

Parameters

domObjectKey
Type: System..::.String

Implements

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Item[([(TKey])])

See Also

PublisherCollection Class
Mincom.LinkOne.Dom Namespace


Item Property

[image]

LinkOne WebView API
PublisherCollection..::.Item Property
PublisherCollection Class See Also Send Feedback
Gets the publisher.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Publisher this[
    string key
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    key As String _
) As Publisher
Visual C++
public:
virtual property Publisher^ default[String^ key] {
    Publisher^ get (String^ key) sealed;
}

Parameters

key
Type: System..::.String
The publisher code for the publisher.

Return Value

The publisher, if found; otherwise, null.

Implements

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Item[([(TKey])])

See Also

PublisherCollection Class
Mincom.LinkOne.Dom Namespace


ReadOnlyList(T) Class

[image]

LinkOne WebView API
ReadOnlyList<(Of <(T>)>) Class
Members See Also Send Feedback
Provides the base class for a read-only list.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public class ReadOnlyList<T> : IReadOnlyList<T>,
    IReadOnlyCollection<T>, IEnumerable<T>, IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ReadOnlyList(Of T) _
    Implements IReadOnlyList(Of T), IReadOnlyCollection(Of T),  _
    IEnumerable(Of T), IEnumerable
Visual C++
[SerializableAttribute]
generic<typename T>
public ref class ReadOnlyList : IReadOnlyList<T>,
    IReadOnlyCollection<T>, IEnumerable<T>, IEnumerable

Type Parameters

T
The type of the objects contained.

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.ReadOnlyList<(Of <(T>)>)
Mincom.LinkOne.Dom.EmbeddedObjects..::.EmbeddedObjectCollection
Mincom.LinkOne.Dom..::.ExceptionCollection
Mincom.LinkOne.Dom.Filtering..::.OptionCollection
Mincom.LinkOne.Dom..::.OverlayCollection
Mincom.LinkOne.Dom..::.PictureCollection
Mincom.LinkOne.Dom.Searching..::.SearchFieldCollection
Mincom.LinkOne.Dom.Searching..::.SearchKeyCollection
Mincom.LinkOne.Dom.Searching..::.SearchResultCollection
Mincom.LinkOne.Dom.Searching..::.SearchSetCollection
Mincom.LinkOne.Dom..::.TocEntryCollection
Mincom.LinkOne.Dom.Zones..::.PointCollection
Mincom.LinkOne.Dom.Zones..::.ZoneCollection

See Also

ReadOnlyList<(Of <(T>)>) Members
Mincom.LinkOne.Dom Namespace


ReadOnlyList(T) Members

[image] [image]

LinkOne WebView API
ReadOnlyList<(Of <(T>)>) Members
ReadOnlyList<(Of <(T>)>) Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ReadOnlyList<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
ReadOnlyList<(Of <(T>)>) | Overloaded.

Methods

Name | Description
Contains | Determines whether an element is in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given object.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements in the collection.
InnerList | Gets the inner list.
Item | Gets the item at the specified index.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.

See Also

ReadOnlyList<(Of <(T>)>) Class
Mincom.LinkOne.Dom Namespace


ReadOnlyList(T) Constructor

[image] [image]

LinkOne WebView API
ReadOnlyList<(Of <(T>)>) Constructor
ReadOnlyList<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
ReadOnlyList<(Of <(T>)>)()()() | Initializes a new instance of the ReadOnlyList<(Of <(T>)>) class.
ReadOnlyList<(Of <(T>)>)(IEnumerable<(Of <(T>)>)) | Initializes a new instance of the ReadOnlyList<(Of <(T>)>) class.
ReadOnlyList<(Of <(T>)>)(Int32) | Initializes a new instance of the ReadOnlyList<(Of <(T>)>) class.

See Also

ReadOnlyList<(Of <(T>)>) Class
ReadOnlyList<(Of <(T>)>) Members
Mincom.LinkOne.Dom Namespace


ReadOnlyList(T) Constructor

[image]

LinkOne WebView API
ReadOnlyList<(Of <(T>)>) Constructor
ReadOnlyList<(Of <(T>)>) Class See Also Send Feedback
Initializes a new instance of the ReadOnlyList<(Of <(T>)>) class.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ReadOnlyList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReadOnlyList()

See Also

ReadOnlyList<(Of <(T>)>) Class
ReadOnlyList<(Of <(T>)>) Overload
Mincom.LinkOne.Dom Namespace


ReadOnlyList(T) Constructor (IEnumerable(T))

[image]

LinkOne WebView API
ReadOnlyList<(Of <(T>)>) Constructor (IEnumerable<(Of <(T>)>))
ReadOnlyList<(Of <(T>)>) Class See Also Send Feedback
Initializes a new instance of the ReadOnlyList<(Of <(T>)>) class.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ReadOnlyList(
    IEnumerable<T> collection
)
Visual Basic (Declaration)
Public Sub New ( _
    collection As IEnumerable(Of T) _
)
Visual C++
public:
ReadOnlyList(
    IEnumerable<T>^ collection
)

Parameters

collection
Type: System.Collections.Generic..::.IEnumerable<(Of <( T >)>)
The collection whose elements are copied to this ReadOnlyList<(Of <(T>)>).

See Also

ReadOnlyList<(Of <(T>)>) Class
ReadOnlyList<(Of <(T>)>) Overload
Mincom.LinkOne.Dom Namespace


ReadOnlyList(T) Constructor (Int32)

[image]

LinkOne WebView API
ReadOnlyList<(Of <(T>)>) Constructor (Int32)
ReadOnlyList<(Of <(T>)>) Class See Also Send Feedback
Initializes a new instance of the ReadOnlyList<(Of <(T>)>) class.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ReadOnlyList(
    int capacity
)
Visual Basic (Declaration)
Public Sub New ( _
    capacity As Integer _
)
Visual C++
public:
ReadOnlyList(
    int capacity
)

Parameters

capacity
Type: System..::.Int32
The number of elements that the ReadOnlyList<(Of <(T>)>) can initially store.

See Also

ReadOnlyList<(Of <(T>)>) Class
ReadOnlyList<(Of <(T>)>) Overload
Mincom.LinkOne.Dom Namespace


ReadOnlyList(T) Methods

[image] [image]

LinkOne WebView API
ReadOnlyList<(Of <(T>)>) Methods
ReadOnlyList<(Of <(T>)>) Class See Also Send Feedback

The ReadOnlyList<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given object.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.

See Also

ReadOnlyList<(Of <(T>)>) Class
Mincom.LinkOne.Dom Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
ReadOnlyList<(Of <(T>)>)..::.IEnumerable..::.GetEnumerator Method
ReadOnlyList<(Of <(T>)>) Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ReadOnlyList<(Of <(T>)>) Class
Mincom.LinkOne.Dom Namespace


Contains Method

[image]

LinkOne WebView API
ReadOnlyList<(Of <(T>)>)..::.Contains Method
ReadOnlyList<(Of <(T>)>) Class See Also Send Feedback
Determines whether an element is in the collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    T item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As T _
) As Boolean
Visual C++
public:
virtual bool Contains(
    T item
) sealed

Parameters

item
Type: T
The object to search for.

Return Value

true if found in the collection, otherwise, false.

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Contains(T)

See Also

ReadOnlyList<(Of <(T>)>) Class
Mincom.LinkOne.Dom Namespace


GetEnumerator Method

[image]

LinkOne WebView API
ReadOnlyList<(Of <(T>)>)..::.GetEnumerator Method
ReadOnlyList<(Of <(T>)>) Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IEnumerator<T> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of T)
Visual C++
public:
virtual IEnumerator<T>^ GetEnumerator() sealed

Return Value

A IEnumerator<(Of <(T>)>) that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

ReadOnlyList<(Of <(T>)>) Class
Mincom.LinkOne.Dom Namespace


IndexOf Method

[image]

LinkOne WebView API
ReadOnlyList<(Of <(T>)>)..::.IndexOf Method
ReadOnlyList<(Of <(T>)>) Class See Also Send Feedback
Searches the collection and returns the zero-based index of the first occurence of the given object.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int IndexOf(
    T item
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    item As T _
) As Integer
Visual C++
public:
virtual int IndexOf(
    T item
) sealed

Parameters

item
Type: T
The object to search for.

Return Value

The zero-based index of the object in the collection, if found; otherwise, -1.

Implements

IReadOnlyList<(Of <(T>)>)..::.IndexOf(T)

See Also

ReadOnlyList<(Of <(T>)>) Class
Mincom.LinkOne.Dom Namespace


ReadOnlyList(T) Properties

[image] [image]

LinkOne WebView API
ReadOnlyList<(Of <(T>)>) Properties
ReadOnlyList<(Of <(T>)>) Class See Also Send Feedback

The ReadOnlyList<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection.
InnerList | Gets the inner list.
Item | Gets the item at the specified index.

See Also

ReadOnlyList<(Of <(T>)>) Class
Mincom.LinkOne.Dom Namespace


Count Property

[image]

LinkOne WebView API
ReadOnlyList<(Of <(T>)>)..::.Count Property
ReadOnlyList<(Of <(T>)>) Class See Also Send Feedback
Gets the number of elements in the collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Count

See Also

ReadOnlyList<(Of <(T>)>) Class
Mincom.LinkOne.Dom Namespace


InnerList Property

[image]

LinkOne WebView API
ReadOnlyList<(Of <(T>)>)..::.InnerList Property
ReadOnlyList<(Of <(T>)>) Class See Also Send Feedback
Gets the inner list.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected List<T> InnerList { get; }
Visual Basic (Declaration)
Protected ReadOnly Property InnerList As List(Of T)
Visual C++
protected:
property List<T>^ InnerList {
    List<T>^ get ();
}

See Also

ReadOnlyList<(Of <(T>)>) Class
Mincom.LinkOne.Dom Namespace


Item Property

[image]

LinkOne WebView API
ReadOnlyList<(Of <(T>)>)..::.Item Property
ReadOnlyList<(Of <(T>)>) Class See Also Send Feedback
Gets the item at the specified index.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public T this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As T
Visual C++
public:
virtual property T default[int index] {
    T get (int index) sealed;
}

Parameters

index
Type: System..::.Int32

Field Value

Implements

IReadOnlyList<(Of <(T>)>)..::.Item[([(Int32])])

See Also

ReadOnlyList<(Of <(T>)>) Class
Mincom.LinkOne.Dom Namespace


ReadOnlyTranslationCollection Class

[image]

LinkOne WebView API
ReadOnlyTranslationCollection Class
Members See Also Send Feedback
Represents a read-only collection of translations, that can be individually accessed by either index, or key, LanguageCode.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class ReadOnlyTranslationCollection : ITranslationCollection,
    IKeyedCollection<string, ITranslation>, ICollection<ITranslation>, IEnumerable<ITranslation>,
    IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class ReadOnlyTranslationCollection _
    Implements ITranslationCollection, IKeyedCollection(Of String, ITranslation),  _
    ICollection(Of ITranslation), IEnumerable(Of ITranslation), IEnumerable
Visual C++
[SerializableAttribute]
public ref class ReadOnlyTranslationCollection sealed : ITranslationCollection,
    IKeyedCollection<String^, ITranslation^>, ICollection<ITranslation^>,
    IEnumerable<ITranslation^>, IEnumerable

Remarks

If changes are made to the underlying TranslationCollection, the ReadOnlyTranslationCollection reflects those changes.

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.ReadOnlyTranslationCollection

See Also

ReadOnlyTranslationCollection Members
Mincom.LinkOne.Dom Namespace


ReadOnlyTranslationCollection Members

[image] [image]

LinkOne WebView API
ReadOnlyTranslationCollection Members
ReadOnlyTranslationCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ReadOnlyTranslationCollection type exposes the following members.

Constructors

Name | Description
ReadOnlyTranslationCollection | Initializes a new instance of the ReadOnlyTranslationCollection class.

Methods

Name | Description
Contains | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements in the collection.
DefaultTranslatedValue | Gets the default translation.
IsReadOnly | Gets a value indicating whether the ITranslationCollection is read-only.
Item | Gets the translation for the given language code, if it exists; otherwise, the translation with no language code, or the default translation.

Explicit Interface Implementations

Name | Description
ITranslationCollection..::.Add | Adds a translation for the specified language code.
ICollection<(Of <(ITranslation>)>)..::.Add |
ICollection<(Of <(ITranslation>)>)..::.Clear |
ICollection<(Of <(ITranslation>)>)..::.CopyTo |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.
IKeyedCollection<(Of <(String, ITranslation>)>)..::.Item |
ICollection<(Of <(ITranslation>)>)..::.Remove |

See Also

ReadOnlyTranslationCollection Class
Mincom.LinkOne.Dom Namespace


ReadOnlyTranslationCollection Constructor

[image]

LinkOne WebView API
ReadOnlyTranslationCollection Constructor
ReadOnlyTranslationCollection Class See Also Send Feedback
Initializes a new instance of the ReadOnlyTranslationCollection class.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ReadOnlyTranslationCollection(
    TranslationCollection translations
)
Visual Basic (Declaration)
Public Sub New ( _
    translations As TranslationCollection _
)
Visual C++
public:
ReadOnlyTranslationCollection(
    TranslationCollection^ translations
)

Parameters

translations
Type: Mincom.LinkOne.Dom..::.TranslationCollection
The translations to wrap.

See Also

ReadOnlyTranslationCollection Class
Mincom.LinkOne.Dom Namespace


ReadOnlyTranslationCollection Methods

[image] [image]

LinkOne WebView API
ReadOnlyTranslationCollection Methods
ReadOnlyTranslationCollection Class See Also Send Feedback

The ReadOnlyTranslationCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ITranslationCollection..::.Add | Adds a translation for the specified language code.
ICollection<(Of <(ITranslation>)>)..::.Add |
ICollection<(Of <(ITranslation>)>)..::.Clear |
ICollection<(Of <(ITranslation>)>)..::.CopyTo |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.
ICollection<(Of <(ITranslation>)>)..::.Remove |

See Also

ReadOnlyTranslationCollection Class
Mincom.LinkOne.Dom Namespace


ICollection(ITranslation).Add Method

[image]

LinkOne WebView API
ReadOnlyTranslationCollection..::.ICollection<(Of <(ITranslation>)>)..::.Add Method
ReadOnlyTranslationCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<ITranslation>.Add(
    ITranslation translation
)
Visual Basic (Declaration)
Private Sub Add ( _
    translation As ITranslation _
) Implements ICollection(Of ITranslation).Add
Visual C++
private:
virtual void Add(
    ITranslation^ translation
) sealed = ICollection<ITranslation^>::Add

Parameters

translation
Type: Mincom.LinkOne.Dom..::.ITranslation

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

ReadOnlyTranslationCollection Class
Mincom.LinkOne.Dom Namespace


ICollection(ITranslation).Clear Method

[image]

LinkOne WebView API
ReadOnlyTranslationCollection..::.ICollection<(Of <(ITranslation>)>)..::.Clear Method
ReadOnlyTranslationCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<ITranslation>.Clear()
Visual Basic (Declaration)
Private Sub Clear Implements ICollection(Of ITranslation).Clear
Visual C++
private:
virtual void Clear() sealed = ICollection<ITranslation^>::Clear

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

See Also

ReadOnlyTranslationCollection Class
Mincom.LinkOne.Dom Namespace


ICollection(ITranslation).CopyTo Method

[image]

LinkOne WebView API
ReadOnlyTranslationCollection..::.ICollection<(Of <(ITranslation>)>)..::.CopyTo Method
ReadOnlyTranslationCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<ITranslation>.CopyTo(
    ITranslation[] array,
    int arrayIndex
)
Visual Basic (Declaration)
Private Sub CopyTo ( _
    array As ITranslation(), _
    arrayIndex As Integer _
) Implements ICollection(Of ITranslation).CopyTo
Visual C++
private:
virtual void CopyTo(
    array<ITranslation^>^ array,
    int arrayIndex
) sealed = ICollection<ITranslation^>::CopyTo

Parameters

array
Type: array< Mincom.LinkOne.Dom..::.ITranslation >[]()[]
arrayIndex
Type: System..::.Int32

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

ReadOnlyTranslationCollection Class
Mincom.LinkOne.Dom Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
ReadOnlyTranslationCollection..::.IEnumerable..::.GetEnumerator Method
ReadOnlyTranslationCollection Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ReadOnlyTranslationCollection Class
Mincom.LinkOne.Dom Namespace


ICollection(ITranslation).Remove Method

[image]

LinkOne WebView API
ReadOnlyTranslationCollection..::.ICollection<(Of <(ITranslation>)>)..::.Remove Method
ReadOnlyTranslationCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<ITranslation>.Remove(
    ITranslation translation
)
Visual Basic (Declaration)
Private Function Remove ( _
    translation As ITranslation _
) As Boolean Implements ICollection(Of ITranslation).Remove
Visual C++
private:
virtual bool Remove(
    ITranslation^ translation
) sealed = ICollection<ITranslation^>::Remove

Parameters

translation
Type: Mincom.LinkOne.Dom..::.ITranslation

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

ReadOnlyTranslationCollection Class
Mincom.LinkOne.Dom Namespace


Contains Method

[image] [image]

LinkOne WebView API
ReadOnlyTranslationCollection..::.Contains Method
ReadOnlyTranslationCollection Class See Also Send Feedback

Overload List

Name | Description
Contains(ITranslation) | Determines whether an translation is in the collection.
Contains(String) | Determines whether an translation is in the collection.

See Also

ReadOnlyTranslationCollection Class
ReadOnlyTranslationCollection Members
Mincom.LinkOne.Dom Namespace


Contains Method (ITranslation)

[image]

LinkOne WebView API
ReadOnlyTranslationCollection..::.Contains Method (ITranslation)
ReadOnlyTranslationCollection Class See Also Send Feedback
Determines whether an translation is in the collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    ITranslation item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As ITranslation _
) As Boolean
Visual C++
public:
virtual bool Contains(
    ITranslation^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Dom..::.ITranslation
The translation object to search for.

Return Value

true if found in the collection, otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

ReadOnlyTranslationCollection Class
Contains Overload
Mincom.LinkOne.Dom Namespace


Contains Method (String)

[image]

LinkOne WebView API
ReadOnlyTranslationCollection..::.Contains Method (String)
ReadOnlyTranslationCollection Class See Also Send Feedback
Determines whether an translation is in the collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    string key
)
Visual Basic (Declaration)
Public Function Contains ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ key
) sealed

Parameters

key
Type: System..::.String
The translation object to search for.

Return Value

true if found in the collection, otherwise, false.

Implements

IKeyedCollection<(Of <(TKey, TItem>)>)..::.Contains(TKey)

See Also

ReadOnlyTranslationCollection Class
Contains Overload
Mincom.LinkOne.Dom Namespace


GetEnumerator Method

[image]

LinkOne WebView API
ReadOnlyTranslationCollection..::.GetEnumerator Method
ReadOnlyTranslationCollection Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IEnumerator<ITranslation> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of ITranslation)
Visual C++
public:
virtual IEnumerator<ITranslation^>^ GetEnumerator() sealed

Return Value

A IEnumerator<(Of <(T>)>) that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

ReadOnlyTranslationCollection Class
Mincom.LinkOne.Dom Namespace


ITranslationCollection.Add Method

[image]

LinkOne WebView API
ReadOnlyTranslationCollection..::.ITranslationCollection..::.Add Method
ReadOnlyTranslationCollection Class See Also Send Feedback
Adds a translation for the specified language code.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ITranslationCollection.Add(
    string languageCode,
    string translation
)
Visual Basic (Declaration)
Private Sub Add ( _
    languageCode As String, _
    translation As String _
) Implements ITranslationCollection.Add
Visual C++
private:
virtual void Add(
    String^ languageCode,
    String^ translation
) sealed = ITranslationCollection::Add

Parameters

languageCode
Type: System..::.String
The ISO-639 compliant language code.
translation
Type: System..::.String
The translation for the supplied language code.

Implements

ITranslationCollection..::.Add(String, String)

Exceptions

Exception | Condition
System..::.NotSupportedException | Always thrown, if the property is set.

See Also

ReadOnlyTranslationCollection Class
Mincom.LinkOne.Dom Namespace


ReadOnlyTranslationCollection Properties

[image] [image]

LinkOne WebView API
ReadOnlyTranslationCollection Properties
ReadOnlyTranslationCollection Class See Also Send Feedback

The ReadOnlyTranslationCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection.
DefaultTranslatedValue | Gets the default translation.
IsReadOnly | Gets a value indicating whether the ITranslationCollection is read-only.
Item | Gets the translation for the given language code, if it exists; otherwise, the translation with no language code, or the default translation.

Explicit Interface Implementations

Name | Description
IKeyedCollection<(Of <(String, ITranslation>)>)..::.Item |

See Also

ReadOnlyTranslationCollection Class
Mincom.LinkOne.Dom Namespace


Count Property

[image]

LinkOne WebView API
ReadOnlyTranslationCollection..::.Count Property
ReadOnlyTranslationCollection Class See Also Send Feedback
Gets the number of elements in the collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

ReadOnlyTranslationCollection Class
Mincom.LinkOne.Dom Namespace


DefaultTranslatedValue Property

[image]

LinkOne WebView API
ReadOnlyTranslationCollection..::.DefaultTranslatedValue Property
ReadOnlyTranslationCollection Class See Also Send Feedback
Gets the default translation.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string DefaultTranslatedValue { get; set; }
Visual Basic (Declaration)
Public Property DefaultTranslatedValue As String
Visual C++
public:
virtual property String^ DefaultTranslatedValue {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Field Value

Implements

ITranslationCollection..::.DefaultTranslatedValue

Remarks

This is the value to return when a specific language resource is not requested, or there is no translation for the wanted language.

Exceptions

Exception | Condition
System..::.NotSupportedException | Always thrown, if the property is set.

See Also

ReadOnlyTranslationCollection Class
Mincom.LinkOne.Dom Namespace


IKeyedCollection(String, ITranslation).Item Property

[image]

LinkOne WebView API
ReadOnlyTranslationCollection..::.IKeyedCollection<(Of <(String, ITranslation>)>)..::.Item Property
ReadOnlyTranslationCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ITranslation IKeyedCollection<string, ITranslation>.Item[
    string languageCode
] { get; set; }
Visual Basic (Declaration)
Private Property Item ( _
    languageCode As String _
) As ITranslation Implements IKeyedCollection(Of String, ITranslation).Item
Visual C++
private:
virtual property ITranslation^ Item[String^ languageCode] {
    ITranslation^ get (String^ languageCode) sealed = IKeyedCollection<String^, ITranslation^>::Item::get;
    void set (String^ languageCode, ITranslation^ value) sealed = IKeyedCollection<String^, ITranslation^>::Item::set;
}

Parameters

languageCode
Type: System..::.String

Implements

IKeyedCollection<(Of <(TKey, TItem>)>)..::.Item[([(TKey])])

See Also

ReadOnlyTranslationCollection Class
Mincom.LinkOne.Dom Namespace


IsReadOnly Property

[image]

LinkOne WebView API
ReadOnlyTranslationCollection..::.IsReadOnly Property
ReadOnlyTranslationCollection Class See Also Send Feedback
Gets a value indicating whether the ITranslationCollection is read-only.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Return Value

Always returns true, this is a read-only wrapper for TranslationCollection.

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

ReadOnlyTranslationCollection Class
Mincom.LinkOne.Dom Namespace


Item Property

[image]

LinkOne WebView API
ReadOnlyTranslationCollection..::.Item Property
ReadOnlyTranslationCollection Class See Also Send Feedback
Gets the translation for the given language code, if it exists; otherwise, the translation with no language code, or the default translation.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string this[
    string languageCode
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    languageCode As String _
) As String
Visual C++
public:
property String^ default[String^ languageCode] {
    String^ get (String^ languageCode);
}

Parameters

languageCode
Type: System..::.String
The language code of the translation.

Return Value

The translation for the given language code, or the translation with no language, or the default translation.

Exceptions

Exception | Condition
System..::.NotSupportedException | Always thrown, if the property is set.

See Also

ReadOnlyTranslationCollection Class
Mincom.LinkOne.Dom Namespace


Resource Class

[image]

LinkOne WebView API
Resource Class
Members See Also Send Feedback
The Resource class wraps raw binary data for persistance.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class Resource : IPersist
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class Resource _
    Implements IPersist
Visual C++
[SerializableAttribute]
public ref class Resource sealed : IPersist

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.Resource

See Also

Resource Members
Mincom.LinkOne.Dom Namespace


Resource Members

[image] [image]

LinkOne WebView API
Resource Members
Resource Class Constructors Methods Properties See Also Send Feedback

The Resource type exposes the following members.

Constructors

Name | Description
Resource | Constructs a new Dom Resource object from a DomReader object.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
Data | Gets the resource as a byte [] ArrayList.
MimeType | Gets the resource mime type.
PublishedDate | Gets the published date.

See Also

Resource Class
Mincom.LinkOne.Dom Namespace


Resource Constructor

[image]

LinkOne WebView API
Resource Constructor
Resource Class See Also Send Feedback
Constructs a new Dom Resource object from a DomReader object.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Resource(
    IDomReader domReader
)
Visual Basic (Declaration)
Public Sub New ( _
    domReader As IDomReader _
)
Visual C++
public:
Resource(
    IDomReader^ domReader
)

Parameters

domReader
Type: IDomReader
The resource reader object providing the initialisation data.

See Also

Resource Class
Mincom.LinkOne.Dom Namespace


Resource Methods

[image] [image]

LinkOne WebView API
Resource Methods
Resource Class See Also Send Feedback

The Resource type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

See Also

Resource Class
Mincom.LinkOne.Dom Namespace


ToString Method

[image]

LinkOne WebView API
Resource..::.ToString Method
Resource Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

Resource Class
Mincom.LinkOne.Dom Namespace


Resource Properties

[image] [image]

LinkOne WebView API
Resource Properties
Resource Class See Also Send Feedback

The Resource type exposes the following members.

Properties

Name | Description
Data | Gets the resource as a byte [] ArrayList.
MimeType | Gets the resource mime type.
PublishedDate | Gets the published date.

See Also

Resource Class
Mincom.LinkOne.Dom Namespace


Data Property

[image]

LinkOne WebView API
Resource..::.Data Property
Resource Class See Also Send Feedback
Gets the resource as a byte [] ArrayList.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public byte[] Data { get; internal set; }
Visual Basic (Declaration)
Public Property Data As Byte()
Visual C++
public:
property array<unsigned char>^ Data {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

Resource Class
Mincom.LinkOne.Dom Namespace


MimeType Property

[image]

LinkOne WebView API
Resource..::.MimeType Property
Resource Class See Also Send Feedback
Gets the resource mime type.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string MimeType { get; }
Visual Basic (Declaration)
Public ReadOnly Property MimeType As String
Visual C++
public:
property String^ MimeType {
    String^ get ();
}

See Also

Resource Class
Mincom.LinkOne.Dom Namespace


PublishedDate Property

[image]

LinkOne WebView API
Resource..::.PublishedDate Property
Resource Class See Also Send Feedback
Gets the published date.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public DateTime PublishedDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublishedDate As DateTime
Visual C++
public:
property DateTime PublishedDate {
    DateTime get ();
}

See Also

Resource Class
Mincom.LinkOne.Dom Namespace


Toc Class

[image]

LinkOne WebView API
Toc Class
Members See Also Send Feedback
Represents a LinkOne Table of Contents.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class Toc : IToc
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class Toc _
    Implements IToc
Visual C++
[SerializableAttribute]
public ref class Toc sealed : IToc

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.Toc

See Also

Toc Members
Mincom.LinkOne.Dom Namespace


Toc Members

[image] [image]

LinkOne WebView API
Toc Members
Toc Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The Toc type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetChildEntries | Gets the collection of entries that are child entries of the TocEntry with the given tag.
GetEntry | Implements GetEntry(String).
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetNextPage | Gets the next page of a given page.
GetPage | Gets the page matching the given page reference.
GetParentPages | Gets the collection of pages that are parent pages of a given page.
GetPreviousPage | Gets the previous page of a given page.
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Entries | Gets the collection of entries that are topmost in the Toc.
HideReferences | Gets a value indicating whether references should be shown.
OpeningPage | Gets the page to open first in the Toc.
Order | Gets or sets the order of the entries in the Toc.

Explicit Interface Implementations

Name | Description
IToc..::.Entries |

See Also

Toc Class
Mincom.LinkOne.Dom Namespace


Toc Methods

[image] [image]

LinkOne WebView API
Toc Methods
Toc Class See Also Send Feedback

The Toc type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetChildEntries | Gets the collection of entries that are child entries of the TocEntry with the given tag.
GetEntry | Implements GetEntry(String).
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetNextPage | Gets the next page of a given page.
GetPage | Gets the page matching the given page reference.
GetParentPages | Gets the collection of pages that are parent pages of a given page.
GetPreviousPage | Gets the previous page of a given page.
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Toc Class
Mincom.LinkOne.Dom Namespace


GetChildEntries Method

[image]

LinkOne WebView API
Toc..::.GetChildEntries Method
Toc Class See Also Send Feedback
Gets the collection of entries that are child entries of the TocEntry with the given tag.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public TocEntryCollection GetChildEntries(
    string tocEntryTag
)
Visual Basic (Declaration)
Public Function GetChildEntries ( _
    tocEntryTag As String _
) As TocEntryCollection
Visual C++
public:
TocEntryCollection^ GetChildEntries(
    String^ tocEntryTag
)

Parameters

tocEntryTag
Type: System..::.String

See Also

Toc Class
Mincom.LinkOne.Dom Namespace


GetEntry Method

[image]

LinkOne WebView API
Toc..::.GetEntry Method
Toc Class See Also Send Feedback
Implements GetEntry(String).

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ITocEntry GetEntry(
    string tocEntryTag
)
Visual Basic (Declaration)
Public Function GetEntry ( _
    tocEntryTag As String _
) As ITocEntry
Visual C++
public:
virtual ITocEntry^ GetEntry(
    String^ tocEntryTag
) sealed

Parameters

tocEntryTag
Type: System..::.String
The tag of interest. May be null/empty to retrieve the root entry.

Return Value

An ITocEntry or null if the tag is not matched.

Implements

IToc..::.GetEntry(String)

See Also

Toc Class
Mincom.LinkOne.Dom Namespace


GetNextPage Method

[image]

LinkOne WebView API
Toc..::.GetNextPage Method
Toc Class See Also Send Feedback
Gets the next page of a given page.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Page GetNextPage(
    string pageRef
)
Visual Basic (Declaration)
Public Function GetNextPage ( _
    pageRef As String _
) As Page
Visual C++
public:
Page^ GetNextPage(
    String^ pageRef
)

Parameters

pageRef
Type: System..::.String
The reference of the page.

Return Value

The next page.

See Also

Toc Class
Mincom.LinkOne.Dom Namespace


GetPage Method

[image]

LinkOne WebView API
Toc..::.GetPage Method
Toc Class See Also Send Feedback
Gets the page matching the given page reference.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IPage GetPage(
    string pageReference
)
Visual Basic (Declaration)
Public Function GetPage ( _
    pageReference As String _
) As IPage
Visual C++
public:
virtual IPage^ GetPage(
    String^ pageReference
) sealed

Parameters

pageReference
Type: System..::.String
The page reference.

Return Value

The referenced page, or null if there is no such page.

Implements

IToc..::.GetPage(String)

See Also

Toc Class
Mincom.LinkOne.Dom Namespace


GetParentPages Method

[image]

LinkOne WebView API
Toc..::.GetParentPages Method
Toc Class See Also Send Feedback
Gets the collection of pages that are parent pages of a given page.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PageCollection GetParentPages(
    string pageReference
)
Visual Basic (Declaration)
Public Function GetParentPages ( _
    pageReference As String _
) As PageCollection
Visual C++
public:
PageCollection^ GetParentPages(
    String^ pageReference
)

Parameters

pageReference
Type: System..::.String
The page reference.

Return Value

The collection of possible parent pages.

See Also

Toc Class
Mincom.LinkOne.Dom Namespace


GetPreviousPage Method

[image]

LinkOne WebView API
Toc..::.GetPreviousPage Method
Toc Class See Also Send Feedback
Gets the previous page of a given page.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Page GetPreviousPage(
    string pageRef
)
Visual Basic (Declaration)
Public Function GetPreviousPage ( _
    pageRef As String _
) As Page
Visual C++
public:
Page^ GetPreviousPage(
    String^ pageRef
)

Parameters

pageRef
Type: System..::.String
The reference of the page.

Return Value

The previous page.

See Also

Toc Class
Mincom.LinkOne.Dom Namespace


Toc Properties

[image] [image]

LinkOne WebView API
Toc Properties
Toc Class See Also Send Feedback

The Toc type exposes the following members.

Properties

Name | Description
Entries | Gets the collection of entries that are topmost in the Toc.
HideReferences | Gets a value indicating whether references should be shown.
OpeningPage | Gets the page to open first in the Toc.
Order | Gets or sets the order of the entries in the Toc.

Explicit Interface Implementations

Name | Description
IToc..::.Entries |

See Also

Toc Class
Mincom.LinkOne.Dom Namespace


Entries Property

[image]

LinkOne WebView API
Toc..::.Entries Property
Toc Class See Also Send Feedback
Gets the collection of entries that are topmost in the Toc.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public TocEntryCollection Entries { get; }
Visual Basic (Declaration)
Public ReadOnly Property Entries As TocEntryCollection
Visual C++
public:
property TocEntryCollection^ Entries {
    TocEntryCollection^ get ();
}

See Also

Toc Class
Mincom.LinkOne.Dom Namespace


HideReferences Property

[image]

LinkOne WebView API
Toc..::.HideReferences Property
Toc Class See Also Send Feedback
Gets a value indicating whether references should be shown.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool HideReferences { get; }
Visual Basic (Declaration)
Public ReadOnly Property HideReferences As Boolean
Visual C++
public:
property bool HideReferences {
    bool get ();
}

See Also

Toc Class
Mincom.LinkOne.Dom Namespace


IToc.Entries Property

[image]

LinkOne WebView API
Toc..::.IToc..::.Entries Property
Toc Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ITocEntryCollection IToc.Entries { get; }
Visual Basic (Declaration)
Private ReadOnly Property Entries As ITocEntryCollection
    Implements IToc.Entries
Visual C++
private:
virtual property ITocEntryCollection^ Entries {
    ITocEntryCollection^ get () sealed = IToc::Entries::get;
}

Implements

IToc..::.Entries

See Also

Toc Class
Mincom.LinkOne.Dom Namespace


OpeningPage Property

[image]

LinkOne WebView API
Toc..::.OpeningPage Property
Toc Class See Also Send Feedback
Gets the page to open first in the Toc.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Page OpeningPage { get; }
Visual Basic (Declaration)
Public ReadOnly Property OpeningPage As Page
Visual C++
public:
property Page^ OpeningPage {
    Page^ get ();
}

See Also

Toc Class
Mincom.LinkOne.Dom Namespace


Order Property

[image]

LinkOne WebView API
Toc..::.Order Property
Toc Class See Also Send Feedback
Gets or sets the order of the entries in the Toc.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public TocOrder Order { get; set; }
Visual Basic (Declaration)
Public Property Order As TocOrder
Visual C++
public:
property TocOrder Order {
    TocOrder get ();
    void set (TocOrder value);
}

See Also

Toc Class
Mincom.LinkOne.Dom Namespace


TocEntry Class

[image]

LinkOne WebView API
TocEntry Class
Members See Also Send Feedback
Represents an entry in a LinkOne book table of contents.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class TocEntry : ITocEntry
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class TocEntry _
    Implements ITocEntry
Visual C++
[SerializableAttribute]
public ref class TocEntry sealed : ITocEntry

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.TocEntry

See Also

TocEntry Members
Mincom.LinkOne.Dom Namespace


TocEntry Members

[image] [image]

LinkOne WebView API
TocEntry Members
TocEntry Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The TocEntry type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
ChildEntries | Gets the child entries for this entry.
HasChildren | Indicates whether this entry has child entries.
IsBroken | Indicates if this entry is broken from the preceding entry in the Toc.
IsCircular | Indicates whether this entry exists up the current hierarchy in the Toc.
IsShadow | Indicates whether this entry is a shadow of another entry in the Toc.
Page | Gets the page that this TocEntry represents.
Tag | Gets a tag that uniquely identifies this entry within the Toc.

Explicit Interface Implementations

Name | Description
ITocEntry..::.ChildEntries |
ITocEntry..::.Page |

See Also

TocEntry Class
Mincom.LinkOne.Dom Namespace


TocEntry Methods

[image] [image]

LinkOne WebView API
TocEntry Methods
TocEntry Class See Also Send Feedback

The TocEntry type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TocEntry Class
Mincom.LinkOne.Dom Namespace


TocEntry Properties

[image] [image]

LinkOne WebView API
TocEntry Properties
TocEntry Class See Also Send Feedback

The TocEntry type exposes the following members.

Properties

Name | Description
ChildEntries | Gets the child entries for this entry.
HasChildren | Indicates whether this entry has child entries.
IsBroken | Indicates if this entry is broken from the preceding entry in the Toc.
IsCircular | Indicates whether this entry exists up the current hierarchy in the Toc.
IsShadow | Indicates whether this entry is a shadow of another entry in the Toc.
Page | Gets the page that this TocEntry represents.
Tag | Gets a tag that uniquely identifies this entry within the Toc.

Explicit Interface Implementations

Name | Description
ITocEntry..::.ChildEntries |
ITocEntry..::.Page |

See Also

TocEntry Class
Mincom.LinkOne.Dom Namespace


ChildEntries Property

[image]

LinkOne WebView API
TocEntry..::.ChildEntries Property
TocEntry Class See Also Send Feedback
Gets the child entries for this entry.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public TocEntryCollection ChildEntries { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChildEntries As TocEntryCollection
Visual C++
public:
property TocEntryCollection^ ChildEntries {
    TocEntryCollection^ get ();
}

See Also

TocEntry Class
Mincom.LinkOne.Dom Namespace


HasChildren Property

[image]

LinkOne WebView API
TocEntry..::.HasChildren Property
TocEntry Class See Also Send Feedback
Indicates whether this entry has child entries.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool HasChildren { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasChildren As Boolean
Visual C++
public:
property bool HasChildren {
    bool get ();
}

See Also

TocEntry Class
Mincom.LinkOne.Dom Namespace


IsBroken Property

[image]

LinkOne WebView API
TocEntry..::.IsBroken Property
TocEntry Class See Also Send Feedback
Indicates if this entry is broken from the preceding entry in the Toc.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsBroken { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsBroken As Boolean
Visual C++
public:
property bool IsBroken {
    bool get ();
}

See Also

TocEntry Class
Mincom.LinkOne.Dom Namespace


IsCircular Property

[image]

LinkOne WebView API
TocEntry..::.IsCircular Property
TocEntry Class See Also Send Feedback
Indicates whether this entry exists up the current hierarchy in the Toc.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsCircular { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsCircular As Boolean
Visual C++
public:
property bool IsCircular {
    bool get ();
}

See Also

TocEntry Class
Mincom.LinkOne.Dom Namespace


IsShadow Property

[image]

LinkOne WebView API
TocEntry..::.IsShadow Property
TocEntry Class See Also Send Feedback
Indicates whether this entry is a shadow of another entry in the Toc.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsShadow { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsShadow As Boolean
Visual C++
public:
property bool IsShadow {
    bool get ();
}

See Also

TocEntry Class
Mincom.LinkOne.Dom Namespace


ITocEntry.ChildEntries Property

[image]

LinkOne WebView API
TocEntry..::.ITocEntry..::.ChildEntries Property
TocEntry Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ITocEntryCollection ITocEntry.ChildEntries { get; }
Visual Basic (Declaration)
Private ReadOnly Property ChildEntries As ITocEntryCollection
    Implements ITocEntry.ChildEntries
Visual C++
private:
virtual property ITocEntryCollection^ ChildEntries {
    ITocEntryCollection^ get () sealed = ITocEntry::ChildEntries::get;
}

Implements

ITocEntry..::.ChildEntries

See Also

TocEntry Class
Mincom.LinkOne.Dom Namespace


ITocEntry.Page Property

[image]

LinkOne WebView API
TocEntry..::.ITocEntry..::.Page Property
TocEntry Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPage ITocEntry.Page { get; }
Visual Basic (Declaration)
Private ReadOnly Property Page As IPage
    Implements ITocEntry.Page
Visual C++
private:
virtual property IPage^ Page {
    IPage^ get () sealed = ITocEntry::Page::get;
}

Implements

ITocEntry..::.Page

See Also

TocEntry Class
Mincom.LinkOne.Dom Namespace


Page Property

[image]

LinkOne WebView API
TocEntry..::.Page Property
TocEntry Class See Also Send Feedback
Gets the page that this TocEntry represents.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Page Page { get; }
Visual Basic (Declaration)
Public ReadOnly Property Page As Page
Visual C++
public:
property Page^ Page {
    Page^ get ();
}

See Also

TocEntry Class
Mincom.LinkOne.Dom Namespace


Tag Property

[image]

LinkOne WebView API
TocEntry..::.Tag Property
TocEntry Class See Also Send Feedback
Gets a tag that uniquely identifies this entry within the Toc.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Tag { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tag As String
Visual C++
public:
property String^ Tag {
    String^ get ();
}

See Also

TocEntry Class
Mincom.LinkOne.Dom Namespace


TocEntryCollection Class

[image]

LinkOne WebView API
TocEntryCollection Class
Members See Also Send Feedback
A collection of TocEntry objects.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class TocEntryCollection : ReadOnlyList<TocEntry>,
    ITocEntryCollection, IReadOnlyList<ITocEntry>, IReadOnlyCollection<ITocEntry>,
    IEnumerable<ITocEntry>, IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class TocEntryCollection _
    Inherits ReadOnlyList(Of TocEntry) _
    Implements ITocEntryCollection, IReadOnlyList(Of ITocEntry),  _
    IReadOnlyCollection(Of ITocEntry), IEnumerable(Of ITocEntry), IEnumerable
Visual C++
[SerializableAttribute]
public ref class TocEntryCollection sealed : public ReadOnlyList<TocEntry^>,
    ITocEntryCollection, IReadOnlyList<ITocEntry^>, IReadOnlyCollection<ITocEntry^>,
    IEnumerable<ITocEntry^>, IEnumerable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.ReadOnlyList <(Of <( TocEntry >)>)
Mincom.LinkOne.Dom..::.TocEntryCollection

See Also

TocEntryCollection Members
Mincom.LinkOne.Dom Namespace


TocEntryCollection Members

[image] [image]

LinkOne WebView API
TocEntryCollection Members
TocEntryCollection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The TocEntryCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given object. (Inherited from ReadOnlyList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
InnerList | Gets the inner list. (Inherited from ReadOnlyList<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from ReadOnlyList<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(ITocEntry>)>)..::.Contains |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
IEnumerable<(Of <(ITocEntry>)>)..::.GetEnumerator |
IReadOnlyList<(Of <(ITocEntry>)>)..::.IndexOf |
IReadOnlyList<(Of <(ITocEntry>)>)..::.Item |

See Also

TocEntryCollection Class
Mincom.LinkOne.Dom Namespace


TocEntryCollection Methods

[image] [image]

LinkOne WebView API
TocEntryCollection Methods
TocEntryCollection Class See Also Send Feedback

The TocEntryCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given object. (Inherited from ReadOnlyList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(ITocEntry>)>)..::.Contains |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
IEnumerable<(Of <(ITocEntry>)>)..::.GetEnumerator |
IReadOnlyList<(Of <(ITocEntry>)>)..::.IndexOf |

See Also

TocEntryCollection Class
Mincom.LinkOne.Dom Namespace


IEnumerable(ITocEntry).GetEnumerator Method

[image]

LinkOne WebView API
TocEntryCollection..::.IEnumerable<(Of <(ITocEntry>)>)..::.GetEnumerator Method
TocEntryCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator<ITocEntry> IEnumerable<ITocEntry>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of ITocEntry)
    Implements IEnumerable(Of ITocEntry).GetEnumerator
Visual C++
private:
virtual IEnumerator<ITocEntry^>^ GetEnumerator() sealed = IEnumerable<ITocEntry^>::GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

TocEntryCollection Class
Mincom.LinkOne.Dom Namespace


IReadOnlyCollection(ITocEntry).Contains Method

[image]

LinkOne WebView API
TocEntryCollection..::.IReadOnlyCollection<(Of <(ITocEntry>)>)..::.Contains Method
TocEntryCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IReadOnlyCollection<ITocEntry>.Contains(
    ITocEntry domObject
)
Visual Basic (Declaration)
Private Function Contains ( _
    domObject As ITocEntry _
) As Boolean Implements IReadOnlyCollection(Of ITocEntry).Contains
Visual C++
private:
virtual bool Contains(
    ITocEntry^ domObject
) sealed = IReadOnlyCollection<ITocEntry^>::Contains

Parameters

domObject
Type: Mincom.LinkOne.Dom..::.ITocEntry

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Contains(T)

See Also

TocEntryCollection Class
Mincom.LinkOne.Dom Namespace


IReadOnlyList(ITocEntry).IndexOf Method

[image]

LinkOne WebView API
TocEntryCollection..::.IReadOnlyList<(Of <(ITocEntry>)>)..::.IndexOf Method
TocEntryCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int IReadOnlyList<ITocEntry>.IndexOf(
    ITocEntry domObject
)
Visual Basic (Declaration)
Private Function IndexOf ( _
    domObject As ITocEntry _
) As Integer Implements IReadOnlyList(Of ITocEntry).IndexOf
Visual C++
private:
virtual int IndexOf(
    ITocEntry^ domObject
) sealed = IReadOnlyList<ITocEntry^>::IndexOf

Parameters

domObject
Type: Mincom.LinkOne.Dom..::.ITocEntry

Implements

IReadOnlyList<(Of <(T>)>)..::.IndexOf(T)

See Also

TocEntryCollection Class
Mincom.LinkOne.Dom Namespace


TocEntryCollection Properties

[image] [image]

LinkOne WebView API
TocEntryCollection Properties
TocEntryCollection Class See Also Send Feedback

The TocEntryCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
InnerList | Gets the inner list. (Inherited from ReadOnlyList<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from ReadOnlyList<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IReadOnlyList<(Of <(ITocEntry>)>)..::.Item |

See Also

TocEntryCollection Class
Mincom.LinkOne.Dom Namespace


IReadOnlyList(ITocEntry).Item Property

[image]

LinkOne WebView API
TocEntryCollection..::.IReadOnlyList<(Of <(ITocEntry>)>)..::.Item Property
TocEntryCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ITocEntry IReadOnlyList<ITocEntry>.Item[
    int index
] { get; }
Visual Basic (Declaration)
Private ReadOnly Property Item ( _
    index As Integer _
) As ITocEntry Implements IReadOnlyList(Of ITocEntry).Item
Visual C++
private:
virtual property ITocEntry^ Item[int index] {
    ITocEntry^ get (int index) sealed = IReadOnlyList<ITocEntry^>::Item::get;
}

Parameters

index
Type: System..::.Int32

Implements

IReadOnlyList<(Of <(T>)>)..::.Item[([(Int32])])

See Also

TocEntryCollection Class
Mincom.LinkOne.Dom Namespace


TocOrder Enumeration

[image]

LinkOne WebView API
TocOrder Enumeration
See Also Send Feedback
Permissable ordering for the table of contents.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum TocOrder
Visual Basic (Declaration)
Public Enumeration TocOrder
Visual C++
public enum class TocOrder

Members

Member name | Description
PageOrder | Page ordered listing, using hierarchy where possible.
Hierarchy | Hierarchical listing, based on item links from pages to other pages.

See Also

Mincom.LinkOne.Dom Namespace


Tracing Class

[image]

LinkOne WebView API
Tracing Class
Members See Also Send Feedback
Trace switch for the assembly.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static class Tracing
Visual Basic (Declaration)
Public NotInheritable Class Tracing
Visual C++
public ref class Tracing abstract sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.Tracing

See Also

Tracing Members
Mincom.LinkOne.Dom Namespace


Tracing Members

[image] [image]

LinkOne WebView API
Tracing Members
Tracing Class Fields See Also Send Feedback

The Tracing type exposes the following members.

Fields

Name | Description
TraceSwitch | Trace switch for the assembly.

See Also

Tracing Class
Mincom.LinkOne.Dom Namespace


Tracing Fields

[image] [image]

LinkOne WebView API
Tracing Fields
Tracing Class See Also Send Feedback

The Tracing type exposes the following members.

Fields

Name | Description
TraceSwitch | Trace switch for the assembly.

See Also

Tracing Class
Mincom.LinkOne.Dom Namespace


TraceSwitch Field

[image]

LinkOne WebView API
Tracing..::.TraceSwitch Field
Tracing Class See Also Send Feedback
Trace switch for the assembly.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static readonly TraceSwitch TraceSwitch
Visual Basic (Declaration)
Public Shared ReadOnly TraceSwitch As TraceSwitch
Visual C++
public:
static initonly TraceSwitch^ TraceSwitch

Remarks

Enable by:
CopyC#
<configuration>
    <system.diagnostics>
        <switches>
            <add name="Mincom.LinkOne.Dom" value="Info"/>
        <switches/>
    <system.diagnostics/>
<configuration/>

See Also

Tracing Class
Mincom.LinkOne.Dom Namespace


Translation Class

[image]

LinkOne WebView API
Translation Class
Members See Also Send Feedback
Represents a translation of a description.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class Translation : ITranslation
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class Translation _
    Implements ITranslation
Visual C++
[SerializableAttribute]
public ref class Translation sealed : ITranslation

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.Translation

See Also

Translation Members
Mincom.LinkOne.Dom Namespace


Translation Members

[image] [image]

LinkOne WebView API
Translation Members
Translation Class Methods Properties See Also Send Feedback

The Translation type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
LanguageCode | Gets the language code for this translation.
TranslatedValue | Gets the translation.

See Also

Translation Class
Mincom.LinkOne.Dom Namespace


Translation Methods

[image] [image]

LinkOne WebView API
Translation Methods
Translation Class See Also Send Feedback

The Translation type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Translation Class
Mincom.LinkOne.Dom Namespace


Translation Properties

[image] [image]

LinkOne WebView API
Translation Properties
Translation Class See Also Send Feedback

The Translation type exposes the following members.

Properties

Name | Description
LanguageCode | Gets the language code for this translation.
TranslatedValue | Gets the translation.

See Also

Translation Class
Mincom.LinkOne.Dom Namespace


LanguageCode Property

[image]

LinkOne WebView API
Translation..::.LanguageCode Property
Translation Class See Also Send Feedback
Gets the language code for this translation.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string LanguageCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property LanguageCode As String
Visual C++
public:
virtual property String^ LanguageCode {
    String^ get () sealed;
}

Implements

ITranslation..::.LanguageCode

See Also

Translation Class
Mincom.LinkOne.Dom Namespace


TranslatedValue Property

[image]

LinkOne WebView API
Translation..::.TranslatedValue Property
Translation Class See Also Send Feedback
Gets the translation.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string TranslatedValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property TranslatedValue As String
Visual C++
public:
virtual property String^ TranslatedValue {
    String^ get () sealed;
}

Implements

ITranslation..::.TranslatedValue

See Also

Translation Class
Mincom.LinkOne.Dom Namespace


TranslationCollection Class

[image]

LinkOne WebView API
TranslationCollection Class
Members See Also Send Feedback
Represents a collection of translations, that can be individually accessed by either index, or key, LanguageCode.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class TranslationCollection : ITranslationCollection,
    IKeyedCollection<string, ITranslation>, ICollection<ITranslation>, IEnumerable<ITranslation>,
    IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class TranslationCollection _
    Implements ITranslationCollection, IKeyedCollection(Of String, ITranslation),  _
    ICollection(Of ITranslation), IEnumerable(Of ITranslation), IEnumerable
Visual C++
[SerializableAttribute]
public ref class TranslationCollection sealed : ITranslationCollection,
    IKeyedCollection<String^, ITranslation^>, ICollection<ITranslation^>,
    IEnumerable<ITranslation^>, IEnumerable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.TranslationCollection

See Also

TranslationCollection Members
Mincom.LinkOne.Dom Namespace


TranslationCollection Members

[image] [image]

LinkOne WebView API
TranslationCollection Members
TranslationCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The TranslationCollection type exposes the following members.

Constructors

Name | Description
TranslationCollection | Overloaded.

Methods

Name | Description
Add | Overloaded.
Clear | Removes all items from the ITranslationCollection.
Contains | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Merge | Merges the specified translations.
Remove | Removes the first occurrence of an ITranslation object from the ITranslationCollection.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements in the collection.
DefaultTranslatedValue | Gets the default translation.
IsReadOnly | Gets a value indicating whether the ITranslationCollection is read-only.
Item | Get or sets the translation for the given language code, or the translation with no language, or the default translation.

Explicit Interface Implementations

Name | Description
ICollection<(Of <(ITranslation>)>)..::.CopyTo |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.
IKeyedCollection<(Of <(String, ITranslation>)>)..::.Item |

See Also

TranslationCollection Class
Mincom.LinkOne.Dom Namespace


TranslationCollection Constructor

[image] [image]

LinkOne WebView API
TranslationCollection Constructor
TranslationCollection Class See Also Send Feedback

Overload List

Name | Description
TranslationCollection(TranslationCollection) | Initializes a new instance of the TranslationCollection class based upon the supplied collection.
TranslationCollection(String) | Initializes a new instance of the TranslationCollection class.
TranslationCollection(String, TranslationCollection) | Initializes a new instance of the TranslationCollection class.

See Also

TranslationCollection Class
TranslationCollection Members
Mincom.LinkOne.Dom Namespace


TranslationCollection Constructor (TranslationCollection)

[image]

LinkOne WebView API
TranslationCollection Constructor (TranslationCollection)
TranslationCollection Class See Also Send Feedback
Initializes a new instance of the TranslationCollection class based upon the supplied collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public TranslationCollection(
    TranslationCollection translations
)
Visual Basic (Declaration)
Public Sub New ( _
    translations As TranslationCollection _
)
Visual C++
public:
TranslationCollection(
    TranslationCollection^ translations
)

Parameters

translations
Type: Mincom.LinkOne.Dom..::.TranslationCollection
The collection to copy.

Remarks

Items in the supplied collection will be copied to the new collection.

See Also

TranslationCollection Class
TranslationCollection Overload
Mincom.LinkOne.Dom Namespace


TranslationCollection Constructor (String)

[image]

LinkOne WebView API
TranslationCollection Constructor (String)
TranslationCollection Class See Also Send Feedback
Initializes a new instance of the TranslationCollection class.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public TranslationCollection(
    string defaultTranslatedValue
)
Visual Basic (Declaration)
Public Sub New ( _
    defaultTranslatedValue As String _
)
Visual C++
public:
TranslationCollection(
    String^ defaultTranslatedValue
)

Parameters

defaultTranslatedValue
Type: System..::.String
The default translation.

See Also

TranslationCollection Class
TranslationCollection Overload
Mincom.LinkOne.Dom Namespace


TranslationCollection Constructor (String, TranslationCollection)

[image]

LinkOne WebView API
TranslationCollection Constructor (String, TranslationCollection)
TranslationCollection Class See Also Send Feedback
Initializes a new instance of the TranslationCollection class.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public TranslationCollection(
    string defaultTranslatedValue,
    TranslationCollection translations
)
Visual Basic (Declaration)
Public Sub New ( _
    defaultTranslatedValue As String, _
    translations As TranslationCollection _
)
Visual C++
public:
TranslationCollection(
    String^ defaultTranslatedValue,
    TranslationCollection^ translations
)

Parameters

defaultTranslatedValue
Type: System..::.String
The default translation.
translations
Type: Mincom.LinkOne.Dom..::.TranslationCollection
The translations.

See Also

TranslationCollection Class
TranslationCollection Overload
Mincom.LinkOne.Dom Namespace


TranslationCollection Methods

[image] [image]

LinkOne WebView API
TranslationCollection Methods
TranslationCollection Class See Also Send Feedback

The TranslationCollection type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | Removes all items from the ITranslationCollection.
Contains | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Merge | Merges the specified translations.
Remove | Removes the first occurrence of an ITranslation object from the ITranslationCollection.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ICollection<(Of <(ITranslation>)>)..::.CopyTo |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.

See Also

TranslationCollection Class
Mincom.LinkOne.Dom Namespace


ICollection(ITranslation).CopyTo Method

[image]

LinkOne WebView API
TranslationCollection..::.ICollection<(Of <(ITranslation>)>)..::.CopyTo Method
TranslationCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<ITranslation>.CopyTo(
    ITranslation[] array,
    int arrayIndex
)
Visual Basic (Declaration)
Private Sub CopyTo ( _
    array As ITranslation(), _
    arrayIndex As Integer _
) Implements ICollection(Of ITranslation).CopyTo
Visual C++
private:
virtual void CopyTo(
    array<ITranslation^>^ array,
    int arrayIndex
) sealed = ICollection<ITranslation^>::CopyTo

Parameters

array
Type: array< Mincom.LinkOne.Dom..::.ITranslation >[]()[]
arrayIndex
Type: System..::.Int32

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

TranslationCollection Class
Mincom.LinkOne.Dom Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
TranslationCollection..::.IEnumerable..::.GetEnumerator Method
TranslationCollection Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

TranslationCollection Class
Mincom.LinkOne.Dom Namespace


Add Method

[image] [image]

LinkOne WebView API
TranslationCollection..::.Add Method
TranslationCollection Class See Also Send Feedback

Overload List

Name | Description
Add(ITranslation) | Adds the specified translation.
Add(String, String) | Adds a translation for the specified language code.

See Also

TranslationCollection Class
TranslationCollection Members
Mincom.LinkOne.Dom Namespace


Add Method (ITranslation)

[image]

LinkOne WebView API
TranslationCollection..::.Add Method (ITranslation)
TranslationCollection Class See Also Send Feedback
Adds the specified translation.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Add(
    ITranslation item
)
Visual Basic (Declaration)
Public Sub Add ( _
    item As ITranslation _
)
Visual C++
public:
virtual void Add(
    ITranslation^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Dom..::.ITranslation
The translation.

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

TranslationCollection Class
Add Overload
Mincom.LinkOne.Dom Namespace


Add Method (String, String)

[image]

LinkOne WebView API
TranslationCollection..::.Add Method (String, String)
TranslationCollection Class See Also Send Feedback
Adds a translation for the specified language code.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Add(
    string languageCode,
    string translation
)
Visual Basic (Declaration)
Public Sub Add ( _
    languageCode As String, _
    translation As String _
)
Visual C++
public:
virtual void Add(
    String^ languageCode,
    String^ translation
) sealed

Parameters

languageCode
Type: System..::.String
The ISO-639 compliant language code.
translation
Type: System..::.String
The translation for the supplied language code.

Implements

ITranslationCollection..::.Add(String, String)

See Also

TranslationCollection Class
Add Overload
Mincom.LinkOne.Dom Namespace


Clear Method

[image]

LinkOne WebView API
TranslationCollection..::.Clear Method
TranslationCollection Class See Also Send Feedback
Removes all items from the ITranslationCollection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
virtual void Clear() sealed

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

Exceptions

Exception | Condition
System..::.NotSupportedException | The ITranslationCollection is read-only.

See Also

TranslationCollection Class
Mincom.LinkOne.Dom Namespace


Contains Method

[image] [image]

LinkOne WebView API
TranslationCollection..::.Contains Method
TranslationCollection Class See Also Send Feedback

Overload List

Name | Description
Contains(ITranslation) | Determines whether an translation is in the collection.
Contains(String) | Gets wether the collection contains a translation for the specified language.

See Also

TranslationCollection Class
TranslationCollection Members
Mincom.LinkOne.Dom Namespace


Contains Method (ITranslation)

[image]

LinkOne WebView API
TranslationCollection..::.Contains Method (ITranslation)
TranslationCollection Class See Also Send Feedback
Determines whether an translation is in the collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    ITranslation item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As ITranslation _
) As Boolean
Visual C++
public:
virtual bool Contains(
    ITranslation^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Dom..::.ITranslation
The translation object to search for.

Return Value

true if found in the collection, otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

TranslationCollection Class
Contains Overload
Mincom.LinkOne.Dom Namespace


Contains Method (String)

[image]

LinkOne WebView API
TranslationCollection..::.Contains Method (String)
TranslationCollection Class See Also Send Feedback
Gets wether the collection contains a translation for the specified language.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    string key
)
Visual Basic (Declaration)
Public Function Contains ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ key
) sealed

Parameters

key
Type: System..::.String
The langage code of the language to check.

Return Value

True if the collection contains a translation for the specified language, false otherwise.

Implements

IKeyedCollection<(Of <(TKey, TItem>)>)..::.Contains(TKey)

See Also

TranslationCollection Class
Contains Overload
Mincom.LinkOne.Dom Namespace


GetEnumerator Method

[image]

LinkOne WebView API
TranslationCollection..::.GetEnumerator Method
TranslationCollection Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IEnumerator<ITranslation> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of ITranslation)
Visual C++
public:
virtual IEnumerator<ITranslation^>^ GetEnumerator() sealed

Return Value

A IEnumerator<(Of <(T>)>) that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

TranslationCollection Class
Mincom.LinkOne.Dom Namespace


Merge Method

[image]

LinkOne WebView API
TranslationCollection..::.Merge Method
TranslationCollection Class See Also Send Feedback
Merges the specified translations.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Merge(
    TranslationCollection translations
)
Visual Basic (Declaration)
Public Sub Merge ( _
    translations As TranslationCollection _
)
Visual C++
public:
void Merge(
    TranslationCollection^ translations
)

Parameters

translations
Type: Mincom.LinkOne.Dom..::.TranslationCollection
The translations to merge.

Remarks

Existing translations take precedence. To replace a translation, Item[([(String])])

See Also

TranslationCollection Class
Mincom.LinkOne.Dom Namespace


Remove Method

[image]

LinkOne WebView API
TranslationCollection..::.Remove Method
TranslationCollection Class See Also Send Feedback
Removes the first occurrence of an ITranslation object from the ITranslationCollection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Remove(
    ITranslation item
)
Visual Basic (Declaration)
Public Function Remove ( _
    item As ITranslation _
) As Boolean
Visual C++
public:
virtual bool Remove(
    ITranslation^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Dom..::.ITranslation
The object to remove from the ITranslationCollection.

Return Value

true if item was successfully removed from the ITranslationCollection; otherwise, false. This method also returns false if item is not found in the original ITranslationCollection.

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

Exceptions

Exception | Condition
System..::.ArgumentNullException | translation is null.

See Also

TranslationCollection Class
Mincom.LinkOne.Dom Namespace


TranslationCollection Properties

[image] [image]

LinkOne WebView API
TranslationCollection Properties
TranslationCollection Class See Also Send Feedback

The TranslationCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection.
DefaultTranslatedValue | Gets the default translation.
IsReadOnly | Gets a value indicating whether the ITranslationCollection is read-only.
Item | Get or sets the translation for the given language code, or the translation with no language, or the default translation.

Explicit Interface Implementations

Name | Description
IKeyedCollection<(Of <(String, ITranslation>)>)..::.Item |

See Also

TranslationCollection Class
Mincom.LinkOne.Dom Namespace


Count Property

[image]

LinkOne WebView API
TranslationCollection..::.Count Property
TranslationCollection Class See Also Send Feedback
Gets the number of elements in the collection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

TranslationCollection Class
Mincom.LinkOne.Dom Namespace


DefaultTranslatedValue Property

[image]

LinkOne WebView API
TranslationCollection..::.DefaultTranslatedValue Property
TranslationCollection Class See Also Send Feedback
Gets the default translation.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string DefaultTranslatedValue { get; set; }
Visual Basic (Declaration)
Public Property DefaultTranslatedValue As String
Visual C++
public:
virtual property String^ DefaultTranslatedValue {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Field Value

Implements

ITranslationCollection..::.DefaultTranslatedValue

Remarks

This is the value to return when a specific language resource is not requested, or there is no translation for the wanted language.

See Also

TranslationCollection Class
Mincom.LinkOne.Dom Namespace


IKeyedCollection(String, ITranslation).Item Property

[image]

LinkOne WebView API
TranslationCollection..::.IKeyedCollection<(Of <(String, ITranslation>)>)..::.Item Property
TranslationCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ITranslation IKeyedCollection<string, ITranslation>.Item[
    string languageCode
] { get; set; }
Visual Basic (Declaration)
Private Property Item ( _
    languageCode As String _
) As ITranslation Implements IKeyedCollection(Of String, ITranslation).Item
Visual C++
private:
virtual property ITranslation^ Item[String^ languageCode] {
    ITranslation^ get (String^ languageCode) sealed = IKeyedCollection<String^, ITranslation^>::Item::get;
    void set (String^ languageCode, ITranslation^ value) sealed = IKeyedCollection<String^, ITranslation^>::Item::set;
}

Parameters

languageCode
Type: System..::.String

Implements

IKeyedCollection<(Of <(TKey, TItem>)>)..::.Item[([(TKey])])

See Also

TranslationCollection Class
Mincom.LinkOne.Dom Namespace


IsReadOnly Property

[image]

LinkOne WebView API
TranslationCollection..::.IsReadOnly Property
TranslationCollection Class See Also Send Feedback
Gets a value indicating whether the ITranslationCollection is read-only.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Field Value

Return Value

The TranslationCollection implementation of ITranslationCollection always returns false.

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

TranslationCollection Class
Mincom.LinkOne.Dom Namespace


Item Property

[image]

LinkOne WebView API
TranslationCollection..::.Item Property
TranslationCollection Class See Also Send Feedback
Get or sets the translation for the given language code, or the translation with no language, or the default translation.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string this[
    string languageCode
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    languageCode As String _
) As String
Visual C++
public:
property String^ default[String^ languageCode] {
    String^ get (String^ languageCode);
    void set (String^ languageCode, String^ value);
}

Parameters

languageCode
Type: System..::.String
The language code for the translation.

Return Value

The translation for the given language code, or the translation with no language, or the default translation.

See Also

TranslationCollection Class
Mincom.LinkOne.Dom Namespace


Utility Class

[image]

LinkOne WebView API
Utility Class
Members See Also Send Feedback
Handy routines.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static class Utility
Visual Basic (Declaration)
Public NotInheritable Class Utility
Visual C++
public ref class Utility abstract sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.Utility

See Also

Utility Members
Mincom.LinkOne.Dom Namespace


Utility Members

[image] [image]

LinkOne WebView API
Utility Members
Utility Class Methods See Also Send Feedback

The Utility type exposes the following members.

Methods

Name | Description
AlphanumericCompare | Does an alphanumeric ordinal compare of the specified strings.
DeepClone | Creates a deep copy of the object.

See Also

Utility Class
Mincom.LinkOne.Dom Namespace


Utility Methods

[image] [image]

LinkOne WebView API
Utility Methods
Utility Class See Also Send Feedback

The Utility type exposes the following members.

Methods

Name | Description
AlphanumericCompare | Does an alphanumeric ordinal compare of the specified strings.
DeepClone | Creates a deep copy of the object.

See Also

Utility Class
Mincom.LinkOne.Dom Namespace


AlphanumericCompare Method

[image]

LinkOne WebView API
Utility..::.AlphanumericCompare Method
Utility Class See Also Send Feedback
Does an alphanumeric ordinal compare of the specified strings.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static int AlphanumericCompare(
    string x,
    string y,
    bool ignoreCase
)
Visual Basic (Declaration)
Public Shared Function AlphanumericCompare ( _
    x As String, _
    y As String, _
    ignoreCase As Boolean _
) As Integer
Visual C++
public:
static int AlphanumericCompare(
    String^ x,
    String^ y,
    bool ignoreCase
)

Parameters

x
Type: System..::.String
The first string.
y
Type: System..::.String
The second string.
ignoreCase
Type: System..::.Boolean
true to ignore the string case.

Return Value

<0 if first is less than second, or >0 if first is greater than second, or 0 if equal.

Remarks

The sorter's main purpose is put meaning onto numerics.
This is a correct order: 1-1, 1-9, 1-10.
This is not a correct order: 1-1, 1-10, 1-9. ///

See Also

Utility Class
Mincom.LinkOne.Dom Namespace


DeepClone Method

[image]

LinkOne WebView API
Utility..::.DeepClone Method
Utility Class See Also Send Feedback
Creates a deep copy of the object.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static Object DeepClone(
    Object itemToClone
)
Visual Basic (Declaration)
Public Shared Function DeepClone ( _
    itemToClone As Object _
) As Object
Visual C++
public:
static Object^ DeepClone(
    Object^ itemToClone
)

Parameters

itemToClone
Type: System..::.Object
The object item to copy.

Return Value

A new object which is a deep copy of the object passed in.

See Also

Utility Class
Mincom.LinkOne.Dom Namespace


ValueCollection Class

[image]

LinkOne WebView API
ValueCollection Class
Members See Also Send Feedback
LinkOne value provider, implements IValueCollection.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public sealed class ValueCollection : IValueCollection
Visual Basic (Declaration)
Public NotInheritable Class ValueCollection _
    Implements IValueCollection
Visual C++
public ref class ValueCollection sealed : IValueCollection

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.ValueCollection

See Also

ValueCollection Members
Mincom.LinkOne.Dom Namespace


ValueCollection Members

[image] [image]

LinkOne WebView API
ValueCollection Members
ValueCollection Class Methods Properties See Also Send Feedback

The ValueCollection type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Item | Gets the value of the specified field, if it is in scope; otherwise, the default value.

See Also

ValueCollection Class
Mincom.LinkOne.Dom Namespace


ValueCollection Methods

[image] [image]

LinkOne WebView API
ValueCollection Methods
ValueCollection Class See Also Send Feedback

The ValueCollection type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ValueCollection Class
Mincom.LinkOne.Dom Namespace


ValueCollection Properties

[image] [image]

LinkOne WebView API
ValueCollection Properties
ValueCollection Class See Also Send Feedback

The ValueCollection type exposes the following members.

Properties

Name | Description
Item | Gets the value of the specified field, if it is in scope; otherwise, the default value.

See Also

ValueCollection Class
Mincom.LinkOne.Dom Namespace


Item Property

[image]

LinkOne WebView API
ValueCollection..::.Item Property
ValueCollection Class See Also Send Feedback
Gets the value of the specified field, if it is in scope; otherwise, the default value.

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string this[
    string valueField
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    valueField As String _
) As String
Visual C++
public:
virtual property String^ default[String^ valueField] {
    String^ get (String^ valueField) sealed;
}

Parameters

valueField
Type: System..::.String
The name of the value to get.

Implements

IValueCollection..::.Item[([(String])])

See Also

ValueCollection Class
Mincom.LinkOne.Dom Namespace


Mincom.LinkOne.Dom.Attributes Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.Dom.Attributes Namespace
Send Feedback
The Mincom.LinkOne.Dom.Attributes namespace contains classes that provide access to LinkOne attributes.

Classes

Class | Description
Attribute | Represents an attribute in a LinkOne book.
AttributeCollection | Represents the attributes defined for a LinkOne book, indexed by Name.
BookAttributeCollection | Represents the attributes that have been applied to a LinkOne book.
PageAttributeCollection | Represents the collection of attributes that have been applied to a single page.
PredefinedAttributeNames | Predefined attributes for a LinkOne book.

Interfaces

Interface | Description
IAttribute | Represents a LinkOne book attribute.
IAttributeCollection | Represents the attributes defined for a LinkOne book, indexed by Name. See remarks.

Enumerations

Enumeration | Description
LeaveDanglingReferenceOption | The enumeration of the LEAVE_DANGLING_REFERENCES attribute.
PrintOrderOption | Type of print order.
PrintTemplateOption | Type of print option.
SaveSearchLevelOption | Types of save search levels available.
TemplateOption | Types of template names available.


Attribute Class

[image]

LinkOne WebView API
Attribute Class
Members See Also Send Feedback
Represents an attribute in a LinkOne book.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public class Attribute : IAttribute
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class Attribute _
    Implements IAttribute
Visual C++
[SerializableAttribute]
public ref class Attribute : IAttribute

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Attributes..::.Attribute

See Also

Attribute Members
Mincom.LinkOne.Dom.Attributes Namespace


Attribute Members

[image] [image]

LinkOne WebView API
Attribute Members
Attribute Class Constructors Methods Properties See Also Send Feedback

The Attribute type exposes the following members.

Constructors

Name | Description
Attribute | Initializes a new instance of the Attribute class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Name | Gets the name of the attribute.
Value | Gets the value of the attribute.
Values | Gets the values of the attribute.

See Also

Attribute Class
Mincom.LinkOne.Dom.Attributes Namespace


Attribute Constructor

[image]

LinkOne WebView API
Attribute Constructor
Attribute Class See Also Send Feedback
Initializes a new instance of the Attribute class.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Attribute(
    IDomReader domReader
)
Visual Basic (Declaration)
Public Sub New ( _
    domReader As IDomReader _
)
Visual C++
public:
Attribute(
    IDomReader^ domReader
)

Parameters

domReader
Type: IDomReader
The DOM reader.

See Also

Attribute Class
Mincom.LinkOne.Dom.Attributes Namespace


Attribute Methods

[image] [image]

LinkOne WebView API
Attribute Methods
Attribute Class See Also Send Feedback

The Attribute type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Attribute Class
Mincom.LinkOne.Dom.Attributes Namespace


Attribute Properties

[image] [image]

LinkOne WebView API
Attribute Properties
Attribute Class See Also Send Feedback

The Attribute type exposes the following members.

Properties

Name | Description
Name | Gets the name of the attribute.
Value | Gets the value of the attribute.
Values | Gets the values of the attribute.

See Also

Attribute Class
Mincom.LinkOne.Dom.Attributes Namespace


Name Property

[image]

LinkOne WebView API
Attribute..::.Name Property
Attribute Class See Also Send Feedback
Gets the name of the attribute.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Name { get; private set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IAttribute..::.Name

See Also

Attribute Class
Mincom.LinkOne.Dom.Attributes Namespace


Value Property

[image]

LinkOne WebView API
Attribute..::.Value Property
Attribute Class See Also Send Feedback
Gets the value of the attribute.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Value { get; private set; }
Visual Basic (Declaration)
Public Property Value As String
Visual C++
public:
virtual property String^ Value {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Field Value

Implements

IAttribute..::.Value

See Also

Attribute Class
Mincom.LinkOne.Dom.Attributes Namespace


Values Property

[image]

LinkOne WebView API
Attribute..::.Values Property
Attribute Class See Also Send Feedback
Gets the values of the attribute.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IList<string> Values { get; }
Visual Basic (Declaration)
Public ReadOnly Property Values As IList(Of String)
Visual C++
public:
property IList<String^>^ Values {
    IList<String^>^ get ();
}

Remarks

The values if this attribute is composed of more than 1 value, otherwise, an empty collection. Use Value which returns a string reprsentation of the value.

See Also

Attribute Class
Mincom.LinkOne.Dom.Attributes Namespace


AttributeCollection Class

[image]

LinkOne WebView API
AttributeCollection Class
Members See Also Send Feedback
Represents the attributes defined for a LinkOne book, indexed by Name.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public abstract class AttributeCollection : IAttributeCollection,
    IReadOnlyKeyedCollection<string, IAttribute>, IReadOnlyCollection<IAttribute>, IEnumerable<IAttribute>,
    IReadOnlyKeyedCollection<string, Attribute>, IReadOnlyCollection<Attribute>, IEnumerable<Attribute>,
    IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public MustInherit Class AttributeCollection _
    Implements IAttributeCollection, IReadOnlyKeyedCollection(Of String, IAttribute),  _
    IReadOnlyCollection(Of IAttribute), IEnumerable(Of IAttribute), IReadOnlyKeyedCollection(Of String, Attribute),  _
    IReadOnlyCollection(Of Attribute), IEnumerable(Of Attribute), IEnumerable
Visual C++
[SerializableAttribute]
public ref class AttributeCollection abstract : IAttributeCollection,
    IReadOnlyKeyedCollection<String^, IAttribute^>, IReadOnlyCollection<IAttribute^>,
    IEnumerable<IAttribute^>, IReadOnlyKeyedCollection<String^, Attribute^>,
    IReadOnlyCollection<Attribute^>, IEnumerable<Attribute^>, IEnumerable

Remarks

Attributes are grouped by name, that is, if an attribute is specified more than once, the values are appended.

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Attributes..::.AttributeCollection
Mincom.LinkOne.Dom.Attributes..::.BookAttributeCollection
Mincom.LinkOne.Dom.Attributes..::.PageAttributeCollection

See Also

AttributeCollection Members
Mincom.LinkOne.Dom.Attributes Namespace


AttributeCollection Members

[image] [image]

LinkOne WebView API
AttributeCollection Members
AttributeCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The AttributeCollection type exposes the following members.

Constructors

Name | Description
AttributeCollection | Overloaded.

Methods

Name | Description
Contains | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetAttribute | Gets the attribute with the specified name.
GetAttributeString | Overloaded.
GetAttributeStrings | Gets the attribute strings.
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
AutoSelectView | Gets true when the AUTO_SELECT_VIEW attribute is true, otherwise false.
BlankSheetFooterFormat | Gets the named format for the blank page footer.
BlankSheetHeaderFormat | Gets the named format for the blank page header.
CalloutTooltipFormat | Gets the named format for the callout tooltip
ColumnHeadingsFormat | Gets the name of the column heading format to use for the page list column heading.
Count | Gets the number of elements in the collection.
DisplayBlankFooter | Gets the DisplayBlankFooter setting of the page.
DisplayBlankHeader | Gets the DisplayBlankHeader setting of the page.
DisplayColumnHeadings | Gets the DisplayColumnHeadings setting of the page.
DisplayListFooter | Gets the DisplayListFooter setting of the page.
DisplayListHeader | Gets the DisplayListHeader setting of the page.
DisplayPictureFooter | Gets the DisplayPicFooter setting of the page.
DisplayPictureHeader | Gets the DisplayPicHeader setting of the page.
EmptyStringCollection | Gets an empty string collection that cannot be modified.
EvenListFooterFormat | Gets the named format for the book layout string attribute EVEN_LIST_FOOTER_FORMAT
EvenListHeaderFormat | Gets the named format for the book layout string attribute EVEN_LIST_HEADER_FORMAT
EvenPictureFooterFormat | Gets the named format for the book layout string attribute EVEN_PIC_FOOTER_FORMAT
EvenPictureHeaderFormat | Gets the named format for the book layout string attribute EVEN_PIC_HEADER_FORMAT
FirstListFooterFormat | Gets the named format for the book layout string attribute FIRST_LIST_FOOTER_FORMAT
FirstListHeaderFormat | Gets the named format for the book layout string attribute FIRST_LIST_HEADER_FORMAT
FirstPictureFooterFormat | Gets the named format for the book layout string attribute FIRST_PIC_FOOTER_FORMAT
FirstPictureHeaderFormat | Gets the named format for the book layout string attribute FIRST_PIC_HEADER_FORMAT
FooterFormat | Gets the named format for the book layout string attribute FOOTER_FORMAT
HeaderFormat | Gets the named format for the book layout string attribute HEADER_FORMAT
InitialFooterFormat | Gets the named format for the book layout string attribute INITIAL_FOOTER_FORMAT
InitialHeaderFormat | Gets the named format for the book layout string attribute INITIAL_HEADER_FORMAT
InitialLeftFooterFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_FOOTER_FORMAT
InitialLeftHeaderFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_HEADER_FORMAT
InitialLeftListFooterFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_LIST_FOOTER_FORMAT
InitialLeftListHeaderFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_LIST_HEADER_FORMAT
InitialLeftPictureFooterFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_PIC_FOOTER_FORMAT
InitialLeftPictureHeaderFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_PIC_HEADER_FORMAT
InitialListFooterFormat | Gets the named format for the book layout string attribute INITIAL_LIST_FOOTER_FORMAT
InitialListHeaderFormat | Gets the named format for the book layout string attribute INITIAL_LIST_HEADER_FORMAT
InitialPictureFooterFormat | Gets the named format for the book layout string attribute INITIAL_PIC_FOOTER_FORMAT
InitialPictureHeaderFormat | Gets the named format for the book layout string attribute INITIAL_PIC_HEADER_FORMAT
InitialRightFooterFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_FOOTER_FORMAT
InitialRightHeaderFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_HEADER_FORMAT
InitialRightListFooterFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_LIST_FOOTER_FORMAT
InitialRightListHeaderFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_LIST_HEADER_FORMAT
InitialRightPictureFooterFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_PIC_FOOTER_FORMAT
InitialRightPictureHeaderFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_PIC_HEADER_FORMAT
InnerDictionary | Gets the underlying backing store for the dictionary.
Item | Gets the attribute with the given name.
LeaveDanglingReferences | Gets the LEAVE_DANGLING_REFERENCES attribute.
LeftFooterFormat | Gets the named format for the book layout string attribute LEFT_FOOTER_FORMAT
LeftHeaderFormat | Gets the named format for the book layout string attribute LEFT_HEADER_FORMAT
LeftListFooterFormat | Gets the named format for the book layout string attribute LEFT_LIST_FOOTER_FORMAT
LeftListHeaderFormat | Gets the named format for the book layout string attribute LEFT_LIST_HEADER_FORMAT
LeftPictureFooterFormat | Gets the named format for the book layout string attribute LEFT_PIC_FOOTER_FORMAT
LeftPictureHeaderFormat | Gets the named format for the book layout string attribute LEFT_PIC_HEADER_FORMAT
LimitEntriesPrinted | Returns the maximum number of rows to print per sheet.
ListFooterFormat | Gets the named format for the book layout string attribute LIST_FOOTER_FORMAT
ListHeaderFormat | Gets the named format for the book layout string attribute LIST_HEADER_FORMAT
ListSheetFacing | Gets the LIST_SHEETFACING value associated with this book or page.
OddListFooterFormat | Gets the named format for the book layout string attribute ODD_LIST_FOOTER_FORMAT
OddListHeaderFormat | Gets the named format for the book layout string attribute ODD_LIST_HEADER_FORMAT
OddPictureFooterFormat | Gets the named format for the book layout string attribute ODD_PIC_FOOTER_FORMAT
OddPictureHeaderFormat | Gets the named format for the book layout string attribute ODD_PIC_HEADER_FORMAT
PictureFooterFormat | Gets the named format for the book layout string attribute PIC_FOOTER_FORMAT
PictureHeaderFormat | Gets the named format for the book layout string attribute PIC_HEADER_FORMAT
PictureSheetFacing | Gets the PIC_SHEETFACING value associated with this book or page.
PrintOrder | Gets the PRINT_ORDER value associated with this book or page.
PrintTemplate | Gets the PRINT_TEMPLATE value associated with this book.
RepeatSheet | Gets the REPEAT_SHEET value associated with this book or page.
RightFooterFormat | Gets the named format for the book layout string attribute RIGHT_FOOTER_FORMAT
RightHeaderFormat | Gets the named format for the book layout string attribute RIGHT_HEADER_FORMAT
RightListFooterFormat | Gets the named format for the book layout string attribute RIGHT_LIST_FOOTER_FORMAT
RightListHeaderFormat | Gets the named format for the book layout string attribute RIGHT_LIST_HEADER_FORMAT
RightPictureFooterFormat | Gets the named format for the book layout string attribute RIGHT_PIC_FOOTER_FORMAT
RightPictureHeaderFormat | Gets the named format for the book layout string attribute RIGHT_PIC_HEADER_FORMAT
SelectQuantityFitted | Gets true when the SELECT_QTY_FITTED attribute is true, otherwise false.
SheetFacing | Gets the SHEETFACING value associated with this book or page.
Template | Gets the name of the Template format.

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(IAttribute>)>)..::.Contains |
IEnumerable<(Of <(IAttribute>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.
IReadOnlyKeyedCollection<(Of <(String, IAttribute>)>)..::.Item |

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


AttributeCollection Constructor

[image] [image]

LinkOne WebView API
AttributeCollection Constructor
AttributeCollection Class See Also Send Feedback

Overload List

Name | Description
AttributeCollection()()() | Initializes a new instance of the AttributeCollection class.
AttributeCollection(IEnumerable<(Of <(Attribute>)>)) | Initializes a new instance of the AttributeCollection class.

See Also

AttributeCollection Class
AttributeCollection Members
Mincom.LinkOne.Dom.Attributes Namespace


AttributeCollection Constructor

[image]

LinkOne WebView API
AttributeCollection Constructor
AttributeCollection Class See Also Send Feedback
Initializes a new instance of the AttributeCollection class.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected AttributeCollection()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
AttributeCollection()

See Also

AttributeCollection Class
AttributeCollection Overload
Mincom.LinkOne.Dom.Attributes Namespace


AttributeCollection Constructor (IEnumerable(Attribute))

[image]

LinkOne WebView API
AttributeCollection Constructor (IEnumerable<(Of <(Attribute>)>))
AttributeCollection Class See Also Send Feedback
Initializes a new instance of the AttributeCollection class.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected AttributeCollection(
    IEnumerable<Attribute> attributes
)
Visual Basic (Declaration)
Protected Sub New ( _
    attributes As IEnumerable(Of Attribute) _
)
Visual C++
protected:
AttributeCollection(
    IEnumerable<Attribute^>^ attributes
)

Parameters

attributes
Type: System.Collections.Generic..::.IEnumerable<(Of <( Attribute >)>)
The attributes.

See Also

AttributeCollection Class
AttributeCollection Overload
Mincom.LinkOne.Dom.Attributes Namespace


AttributeCollection Methods

[image] [image]

LinkOne WebView API
AttributeCollection Methods
AttributeCollection Class See Also Send Feedback

The AttributeCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetAttribute | Gets the attribute with the specified name.
GetAttributeString | Overloaded.
GetAttributeStrings | Gets the attribute strings.
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(IAttribute>)>)..::.Contains |
IEnumerable<(Of <(IAttribute>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


IEnumerable(IAttribute).GetEnumerator Method

[image]

LinkOne WebView API
AttributeCollection..::.IEnumerable<(Of <(IAttribute>)>)..::.GetEnumerator Method
AttributeCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator<IAttribute> IEnumerable<IAttribute>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of IAttribute)
    Implements IEnumerable(Of IAttribute).GetEnumerator
Visual C++
private:
virtual IEnumerator<IAttribute^>^ GetEnumerator() sealed = IEnumerable<IAttribute^>::GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
AttributeCollection..::.IEnumerable..::.GetEnumerator Method
AttributeCollection Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


Contains Method

[image] [image]

LinkOne WebView API
AttributeCollection..::.Contains Method
AttributeCollection Class See Also Send Feedback

Overload List

Name | Description
Contains(Attribute) | Determines whether an attribute is in the collection.
Contains(String) | Gets whether this collection contains an Attribute with the given name.

See Also

AttributeCollection Class
AttributeCollection Members
Mincom.LinkOne.Dom.Attributes Namespace


Contains Method (Attribute)

[image]

LinkOne WebView API
AttributeCollection..::.Contains Method (Attribute)
AttributeCollection Class See Also Send Feedback
Determines whether an attribute is in the collection.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    Attribute item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As Attribute _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Attribute^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Dom.Attributes..::.Attribute
The attribute object to search for.

Return Value

true if found in the collection, otherwise, false.

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Contains(T)

See Also

AttributeCollection Class
Contains Overload
Mincom.LinkOne.Dom.Attributes Namespace


Contains Method (String)

[image]

LinkOne WebView API
AttributeCollection..::.Contains Method (String)
AttributeCollection Class See Also Send Feedback
Gets whether this collection contains an Attribute with the given name.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    string key
)
Visual Basic (Declaration)
Public Function Contains ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ key
) sealed

Parameters

key
Type: System..::.String
The name of the attribute.

Return Value

True if the collection contains an Attribute with the given name, otherwise, false.

Implements

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Contains(TKey)
IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Contains(TKey)

See Also

AttributeCollection Class
Contains Overload
Mincom.LinkOne.Dom.Attributes Namespace


GetAttribute Method

[image]

LinkOne WebView API
AttributeCollection..::.GetAttribute Method
AttributeCollection Class See Also Send Feedback
Gets the attribute with the specified name.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected abstract Attribute GetAttribute(
    string name
)
Visual Basic (Declaration)
Protected MustOverride Function GetAttribute ( _
    name As String _
) As Attribute
Visual C++
protected:
virtual Attribute^ GetAttribute(
    String^ name
) abstract

Parameters

name
Type: System..::.String

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


GetAttributeString Method

[image] [image]

LinkOne WebView API
AttributeCollection..::.GetAttributeString Method
AttributeCollection Class See Also Send Feedback

Overload List

Name | Description
GetAttributeString(String) | Gets the value of the attribute with the given name.
GetAttributeString(String, String) | Gets the value of the attribute with the given name.

See Also

AttributeCollection Class
AttributeCollection Members
Mincom.LinkOne.Dom.Attributes Namespace


GetAttributeString Method (String)

[image]

LinkOne WebView API
AttributeCollection..::.GetAttributeString Method (String)
AttributeCollection Class See Also Send Feedback
Gets the value of the attribute with the given name.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected string GetAttributeString(
    string name
)
Visual Basic (Declaration)
Protected Function GetAttributeString ( _
    name As String _
) As String
Visual C++
protected:
String^ GetAttributeString(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the attribute.

Return Value

The value of the wanted attribute, if present and not null; otherwise, the default value.

See Also

AttributeCollection Class
GetAttributeString Overload
Mincom.LinkOne.Dom.Attributes Namespace


GetAttributeString Method (String, String)

[image]

LinkOne WebView API
AttributeCollection..::.GetAttributeString Method (String, String)
AttributeCollection Class See Also Send Feedback
Gets the value of the attribute with the given name.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected string GetAttributeString(
    string name,
    string defaultValue
)
Visual Basic (Declaration)
Protected Function GetAttributeString ( _
    name As String, _
    defaultValue As String _
) As String
Visual C++
protected:
String^ GetAttributeString(
    String^ name,
    String^ defaultValue
)

Parameters

name
Type: System..::.String
The name of the attribute.
defaultValue
Type: System..::.String
The default value to use if the attribute is not present, or the value is null.

Return Value

The value of the wanted attribute, if present and not null; otherwise, the default value.

See Also

AttributeCollection Class
GetAttributeString Overload
Mincom.LinkOne.Dom.Attributes Namespace


GetAttributeStrings Method

[image]

LinkOne WebView API
AttributeCollection..::.GetAttributeStrings Method
AttributeCollection Class See Also Send Feedback
Gets the attribute strings.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected IList<string> GetAttributeStrings(
    string name
)
Visual Basic (Declaration)
Protected Function GetAttributeStrings ( _
    name As String _
) As IList(Of String)
Visual C++
protected:
IList<String^>^ GetAttributeStrings(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the attribute.

Return Value

The values of the attribute.

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


GetEnumerator Method

[image]

LinkOne WebView API
AttributeCollection..::.GetEnumerator Method
AttributeCollection Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IEnumerator<Attribute> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of Attribute)
Visual C++
public:
virtual IEnumerator<Attribute^>^ GetEnumerator() sealed

Return Value

A IEnumerator<(Of <(T>)>) that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


IReadOnlyCollection(IAttribute).Contains Method

[image]

LinkOne WebView API
AttributeCollection..::.IReadOnlyCollection<(Of <(IAttribute>)>)..::.Contains Method
AttributeCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IReadOnlyCollection<IAttribute>.Contains(
    IAttribute attribute
)
Visual Basic (Declaration)
Private Function Contains ( _
    attribute As IAttribute _
) As Boolean Implements IReadOnlyCollection(Of IAttribute).Contains
Visual C++
private:
virtual bool Contains(
    IAttribute^ attribute
) sealed = IReadOnlyCollection<IAttribute^>::Contains

Parameters

attribute
Type: Mincom.LinkOne.Dom.Attributes..::.IAttribute

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Contains(T)

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


AttributeCollection Properties

[image] [image]

LinkOne WebView API
AttributeCollection Properties
AttributeCollection Class See Also Send Feedback

The AttributeCollection type exposes the following members.

Properties

Name | Description
AutoSelectView | Gets true when the AUTO_SELECT_VIEW attribute is true, otherwise false.
BlankSheetFooterFormat | Gets the named format for the blank page footer.
BlankSheetHeaderFormat | Gets the named format for the blank page header.
CalloutTooltipFormat | Gets the named format for the callout tooltip
ColumnHeadingsFormat | Gets the name of the column heading format to use for the page list column heading.
Count | Gets the number of elements in the collection.
DisplayBlankFooter | Gets the DisplayBlankFooter setting of the page.
DisplayBlankHeader | Gets the DisplayBlankHeader setting of the page.
DisplayColumnHeadings | Gets the DisplayColumnHeadings setting of the page.
DisplayListFooter | Gets the DisplayListFooter setting of the page.
DisplayListHeader | Gets the DisplayListHeader setting of the page.
DisplayPictureFooter | Gets the DisplayPicFooter setting of the page.
DisplayPictureHeader | Gets the DisplayPicHeader setting of the page.
EmptyStringCollection | Gets an empty string collection that cannot be modified.
EvenListFooterFormat | Gets the named format for the book layout string attribute EVEN_LIST_FOOTER_FORMAT
EvenListHeaderFormat | Gets the named format for the book layout string attribute EVEN_LIST_HEADER_FORMAT
EvenPictureFooterFormat | Gets the named format for the book layout string attribute EVEN_PIC_FOOTER_FORMAT
EvenPictureHeaderFormat | Gets the named format for the book layout string attribute EVEN_PIC_HEADER_FORMAT
FirstListFooterFormat | Gets the named format for the book layout string attribute FIRST_LIST_FOOTER_FORMAT
FirstListHeaderFormat | Gets the named format for the book layout string attribute FIRST_LIST_HEADER_FORMAT
FirstPictureFooterFormat | Gets the named format for the book layout string attribute FIRST_PIC_FOOTER_FORMAT
FirstPictureHeaderFormat | Gets the named format for the book layout string attribute FIRST_PIC_HEADER_FORMAT
FooterFormat | Gets the named format for the book layout string attribute FOOTER_FORMAT
HeaderFormat | Gets the named format for the book layout string attribute HEADER_FORMAT
InitialFooterFormat | Gets the named format for the book layout string attribute INITIAL_FOOTER_FORMAT
InitialHeaderFormat | Gets the named format for the book layout string attribute INITIAL_HEADER_FORMAT
InitialLeftFooterFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_FOOTER_FORMAT
InitialLeftHeaderFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_HEADER_FORMAT
InitialLeftListFooterFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_LIST_FOOTER_FORMAT
InitialLeftListHeaderFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_LIST_HEADER_FORMAT
InitialLeftPictureFooterFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_PIC_FOOTER_FORMAT
InitialLeftPictureHeaderFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_PIC_HEADER_FORMAT
InitialListFooterFormat | Gets the named format for the book layout string attribute INITIAL_LIST_FOOTER_FORMAT
InitialListHeaderFormat | Gets the named format for the book layout string attribute INITIAL_LIST_HEADER_FORMAT
InitialPictureFooterFormat | Gets the named format for the book layout string attribute INITIAL_PIC_FOOTER_FORMAT
InitialPictureHeaderFormat | Gets the named format for the book layout string attribute INITIAL_PIC_HEADER_FORMAT
InitialRightFooterFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_FOOTER_FORMAT
InitialRightHeaderFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_HEADER_FORMAT
InitialRightListFooterFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_LIST_FOOTER_FORMAT
InitialRightListHeaderFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_LIST_HEADER_FORMAT
InitialRightPictureFooterFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_PIC_FOOTER_FORMAT
InitialRightPictureHeaderFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_PIC_HEADER_FORMAT
InnerDictionary | Gets the underlying backing store for the dictionary.
Item | Gets the attribute with the given name.
LeaveDanglingReferences | Gets the LEAVE_DANGLING_REFERENCES attribute.
LeftFooterFormat | Gets the named format for the book layout string attribute LEFT_FOOTER_FORMAT
LeftHeaderFormat | Gets the named format for the book layout string attribute LEFT_HEADER_FORMAT
LeftListFooterFormat | Gets the named format for the book layout string attribute LEFT_LIST_FOOTER_FORMAT
LeftListHeaderFormat | Gets the named format for the book layout string attribute LEFT_LIST_HEADER_FORMAT
LeftPictureFooterFormat | Gets the named format for the book layout string attribute LEFT_PIC_FOOTER_FORMAT
LeftPictureHeaderFormat | Gets the named format for the book layout string attribute LEFT_PIC_HEADER_FORMAT
LimitEntriesPrinted | Returns the maximum number of rows to print per sheet.
ListFooterFormat | Gets the named format for the book layout string attribute LIST_FOOTER_FORMAT
ListHeaderFormat | Gets the named format for the book layout string attribute LIST_HEADER_FORMAT
ListSheetFacing | Gets the LIST_SHEETFACING value associated with this book or page.
OddListFooterFormat | Gets the named format for the book layout string attribute ODD_LIST_FOOTER_FORMAT
OddListHeaderFormat | Gets the named format for the book layout string attribute ODD_LIST_HEADER_FORMAT
OddPictureFooterFormat | Gets the named format for the book layout string attribute ODD_PIC_FOOTER_FORMAT
OddPictureHeaderFormat | Gets the named format for the book layout string attribute ODD_PIC_HEADER_FORMAT
PictureFooterFormat | Gets the named format for the book layout string attribute PIC_FOOTER_FORMAT
PictureHeaderFormat | Gets the named format for the book layout string attribute PIC_HEADER_FORMAT
PictureSheetFacing | Gets the PIC_SHEETFACING value associated with this book or page.
PrintOrder | Gets the PRINT_ORDER value associated with this book or page.
PrintTemplate | Gets the PRINT_TEMPLATE value associated with this book.
RepeatSheet | Gets the REPEAT_SHEET value associated with this book or page.
RightFooterFormat | Gets the named format for the book layout string attribute RIGHT_FOOTER_FORMAT
RightHeaderFormat | Gets the named format for the book layout string attribute RIGHT_HEADER_FORMAT
RightListFooterFormat | Gets the named format for the book layout string attribute RIGHT_LIST_FOOTER_FORMAT
RightListHeaderFormat | Gets the named format for the book layout string attribute RIGHT_LIST_HEADER_FORMAT
RightPictureFooterFormat | Gets the named format for the book layout string attribute RIGHT_PIC_FOOTER_FORMAT
RightPictureHeaderFormat | Gets the named format for the book layout string attribute RIGHT_PIC_HEADER_FORMAT
SelectQuantityFitted | Gets true when the SELECT_QTY_FITTED attribute is true, otherwise false.
SheetFacing | Gets the SHEETFACING value associated with this book or page.
Template | Gets the name of the Template format.

Explicit Interface Implementations

Name | Description
IReadOnlyKeyedCollection<(Of <(String, IAttribute>)>)..::.Item |

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


AutoSelectView Property

[image]

LinkOne WebView API
AttributeCollection..::.AutoSelectView Property
AttributeCollection Class See Also Send Feedback
Gets true when the AUTO_SELECT_VIEW attribute is true, otherwise false.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool AutoSelectView { get; }
Visual Basic (Declaration)
Public ReadOnly Property AutoSelectView As Boolean
Visual C++
public:
property bool AutoSelectView {
    bool get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


BlankSheetFooterFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.BlankSheetFooterFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the blank page footer.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string BlankSheetFooterFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property BlankSheetFooterFormat As String
Visual C++
public:
property String^ BlankSheetFooterFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


BlankSheetHeaderFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.BlankSheetHeaderFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the blank page header.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string BlankSheetHeaderFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property BlankSheetHeaderFormat As String
Visual C++
public:
property String^ BlankSheetHeaderFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


CalloutTooltipFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.CalloutTooltipFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the callout tooltip

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string CalloutTooltipFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property CalloutTooltipFormat As String
Visual C++
public:
property String^ CalloutTooltipFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


ColumnHeadingsFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.ColumnHeadingsFormat Property
AttributeCollection Class See Also Send Feedback
Gets the name of the column heading format to use for the page list column heading.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public virtual string ColumnHeadingsFormat { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property ColumnHeadingsFormat As String
Visual C++
public:
virtual property String^ ColumnHeadingsFormat {
    String^ get ();
}

Field Value

The name of the format that is to be used to display the column headings above the parts list on the page.

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


Count Property

[image]

LinkOne WebView API
AttributeCollection..::.Count Property
AttributeCollection Class See Also Send Feedback
Gets the number of elements in the collection.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Count
IReadOnlyCollection<(Of <(T>)>)..::.Count

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


DisplayBlankFooter Property

[image]

LinkOne WebView API
AttributeCollection..::.DisplayBlankFooter Property
AttributeCollection Class See Also Send Feedback
Gets the DisplayBlankFooter setting of the page.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool DisplayBlankFooter { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayBlankFooter As Boolean
Visual C++
public:
property bool DisplayBlankFooter {
    bool get ();
}

Field Value

A true or false value indicating if the page footer should be printed on a blank page.

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


DisplayBlankHeader Property

[image]

LinkOne WebView API
AttributeCollection..::.DisplayBlankHeader Property
AttributeCollection Class See Also Send Feedback
Gets the DisplayBlankHeader setting of the page.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool DisplayBlankHeader { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayBlankHeader As Boolean
Visual C++
public:
property bool DisplayBlankHeader {
    bool get ();
}

Field Value

A true or false value indicating if the page header should be printed on a blank page.

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


DisplayColumnHeadings Property

[image]

LinkOne WebView API
AttributeCollection..::.DisplayColumnHeadings Property
AttributeCollection Class See Also Send Feedback
Gets the DisplayColumnHeadings setting of the page.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool DisplayColumnHeadings { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayColumnHeadings As Boolean
Visual C++
public:
property bool DisplayColumnHeadings {
    bool get ();
}

Field Value

A true or false value indicating if the column headings should be displayed on the page.

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


DisplayListFooter Property

[image]

LinkOne WebView API
AttributeCollection..::.DisplayListFooter Property
AttributeCollection Class See Also Send Feedback
Gets the DisplayListFooter setting of the page.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool DisplayListFooter { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayListFooter As Boolean
Visual C++
public:
property bool DisplayListFooter {
    bool get ();
}

Field Value

A true or false value indicating if the list footer should be displayed on the page.

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


DisplayListHeader Property

[image]

LinkOne WebView API
AttributeCollection..::.DisplayListHeader Property
AttributeCollection Class See Also Send Feedback
Gets the DisplayListHeader setting of the page.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool DisplayListHeader { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayListHeader As Boolean
Visual C++
public:
property bool DisplayListHeader {
    bool get ();
}

Field Value

A true or false value indicating if the list header should be displayed on the page.

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


DisplayPictureFooter Property

[image]

LinkOne WebView API
AttributeCollection..::.DisplayPictureFooter Property
AttributeCollection Class See Also Send Feedback
Gets the DisplayPicFooter setting of the page.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool DisplayPictureFooter { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayPictureFooter As Boolean
Visual C++
public:
property bool DisplayPictureFooter {
    bool get ();
}

Field Value

A true or false value indicating if the picture footer should be displayed on the page.

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


DisplayPictureHeader Property

[image]

LinkOne WebView API
AttributeCollection..::.DisplayPictureHeader Property
AttributeCollection Class See Also Send Feedback
Gets the DisplayPicHeader setting of the page.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool DisplayPictureHeader { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayPictureHeader As Boolean
Visual C++
public:
property bool DisplayPictureHeader {
    bool get ();
}

Field Value

A true or false value indicating if the picture header should be displayed on the page.

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


EmptyStringCollection Property

[image]

LinkOne WebView API
AttributeCollection..::.EmptyStringCollection Property
AttributeCollection Class See Also Send Feedback
Gets an empty string collection that cannot be modified.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected static IList<string> EmptyStringCollection { get; }
Visual Basic (Declaration)
Protected Shared ReadOnly Property EmptyStringCollection As IList(Of String)
Visual C++
protected:
static property IList<String^>^ EmptyStringCollection {
    IList<String^>^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


EvenListFooterFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.EvenListFooterFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute EVEN_LIST_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string EvenListFooterFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property EvenListFooterFormat As String
Visual C++
public:
property String^ EvenListFooterFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


EvenListHeaderFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.EvenListHeaderFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute EVEN_LIST_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string EvenListHeaderFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property EvenListHeaderFormat As String
Visual C++
public:
property String^ EvenListHeaderFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


EvenPictureFooterFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.EvenPictureFooterFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute EVEN_PIC_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string EvenPictureFooterFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property EvenPictureFooterFormat As String
Visual C++
public:
property String^ EvenPictureFooterFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


EvenPictureHeaderFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.EvenPictureHeaderFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute EVEN_PIC_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string EvenPictureHeaderFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property EvenPictureHeaderFormat As String
Visual C++
public:
property String^ EvenPictureHeaderFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


FirstListFooterFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.FirstListFooterFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute FIRST_LIST_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string FirstListFooterFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property FirstListFooterFormat As String
Visual C++
public:
property String^ FirstListFooterFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


FirstListHeaderFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.FirstListHeaderFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute FIRST_LIST_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string FirstListHeaderFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property FirstListHeaderFormat As String
Visual C++
public:
property String^ FirstListHeaderFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


FirstPictureFooterFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.FirstPictureFooterFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute FIRST_PIC_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string FirstPictureFooterFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property FirstPictureFooterFormat As String
Visual C++
public:
property String^ FirstPictureFooterFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


FirstPictureHeaderFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.FirstPictureHeaderFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute FIRST_PIC_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string FirstPictureHeaderFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property FirstPictureHeaderFormat As String
Visual C++
public:
property String^ FirstPictureHeaderFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


FooterFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.FooterFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string FooterFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property FooterFormat As String
Visual C++
public:
property String^ FooterFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


HeaderFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.HeaderFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string HeaderFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderFormat As String
Visual C++
public:
property String^ HeaderFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialFooterFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.InitialFooterFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute INITIAL_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string InitialFooterFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property InitialFooterFormat As String
Visual C++
public:
property String^ InitialFooterFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialHeaderFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.InitialHeaderFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute INITIAL_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string InitialHeaderFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property InitialHeaderFormat As String
Visual C++
public:
property String^ InitialHeaderFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialLeftFooterFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.InitialLeftFooterFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute INITIAL_LEFT_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string InitialLeftFooterFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property InitialLeftFooterFormat As String
Visual C++
public:
property String^ InitialLeftFooterFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialLeftHeaderFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.InitialLeftHeaderFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute INITIAL_LEFT_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string InitialLeftHeaderFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property InitialLeftHeaderFormat As String
Visual C++
public:
property String^ InitialLeftHeaderFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialLeftListFooterFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.InitialLeftListFooterFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute INITIAL_LEFT_LIST_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string InitialLeftListFooterFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property InitialLeftListFooterFormat As String
Visual C++
public:
property String^ InitialLeftListFooterFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialLeftListHeaderFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.InitialLeftListHeaderFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute INITIAL_LEFT_LIST_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string InitialLeftListHeaderFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property InitialLeftListHeaderFormat As String
Visual C++
public:
property String^ InitialLeftListHeaderFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialLeftPictureFooterFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.InitialLeftPictureFooterFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute INITIAL_LEFT_PIC_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string InitialLeftPictureFooterFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property InitialLeftPictureFooterFormat As String
Visual C++
public:
property String^ InitialLeftPictureFooterFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialLeftPictureHeaderFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.InitialLeftPictureHeaderFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute INITIAL_LEFT_PIC_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string InitialLeftPictureHeaderFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property InitialLeftPictureHeaderFormat As String
Visual C++
public:
property String^ InitialLeftPictureHeaderFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialListFooterFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.InitialListFooterFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute INITIAL_LIST_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string InitialListFooterFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property InitialListFooterFormat As String
Visual C++
public:
property String^ InitialListFooterFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialListHeaderFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.InitialListHeaderFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute INITIAL_LIST_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string InitialListHeaderFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property InitialListHeaderFormat As String
Visual C++
public:
property String^ InitialListHeaderFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialPictureFooterFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.InitialPictureFooterFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute INITIAL_PIC_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string InitialPictureFooterFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property InitialPictureFooterFormat As String
Visual C++
public:
property String^ InitialPictureFooterFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialPictureHeaderFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.InitialPictureHeaderFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute INITIAL_PIC_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string InitialPictureHeaderFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property InitialPictureHeaderFormat As String
Visual C++
public:
property String^ InitialPictureHeaderFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialRightFooterFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.InitialRightFooterFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute INITIAL_RIGHT_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string InitialRightFooterFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property InitialRightFooterFormat As String
Visual C++
public:
property String^ InitialRightFooterFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialRightHeaderFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.InitialRightHeaderFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute INITIAL_RIGHT_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string InitialRightHeaderFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property InitialRightHeaderFormat As String
Visual C++
public:
property String^ InitialRightHeaderFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialRightListFooterFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.InitialRightListFooterFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute INITIAL_RIGHT_LIST_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string InitialRightListFooterFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property InitialRightListFooterFormat As String
Visual C++
public:
property String^ InitialRightListFooterFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialRightListHeaderFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.InitialRightListHeaderFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute INITIAL_RIGHT_LIST_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string InitialRightListHeaderFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property InitialRightListHeaderFormat As String
Visual C++
public:
property String^ InitialRightListHeaderFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialRightPictureFooterFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.InitialRightPictureFooterFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute INITIAL_RIGHT_PIC_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string InitialRightPictureFooterFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property InitialRightPictureFooterFormat As String
Visual C++
public:
property String^ InitialRightPictureFooterFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialRightPictureHeaderFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.InitialRightPictureHeaderFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute INITIAL_RIGHT_PIC_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string InitialRightPictureHeaderFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property InitialRightPictureHeaderFormat As String
Visual C++
public:
property String^ InitialRightPictureHeaderFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


InnerDictionary Property

[image]

LinkOne WebView API
AttributeCollection..::.InnerDictionary Property
AttributeCollection Class See Also Send Feedback
Gets the underlying backing store for the dictionary.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected Dictionary<string, Attribute> InnerDictionary { get; }
Visual Basic (Declaration)
Protected ReadOnly Property InnerDictionary As Dictionary(Of String, Attribute)
Visual C++
protected:
property Dictionary<String^, Attribute^>^ InnerDictionary {
    Dictionary<String^, Attribute^>^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


IReadOnlyKeyedCollection(String, IAttribute).Item Property

[image]

LinkOne WebView API
AttributeCollection..::.IReadOnlyKeyedCollection<(Of <(String, IAttribute>)>)..::.Item Property
AttributeCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IAttribute IReadOnlyKeyedCollection<string, IAttribute>.Item[
    string name
] { get; }
Visual Basic (Declaration)
Private ReadOnly Property Item ( _
    name As String _
) As IAttribute Implements IReadOnlyKeyedCollection(Of String, IAttribute).Item
Visual C++
private:
virtual property IAttribute^ Item[String^ name] {
    IAttribute^ get (String^ name) sealed = IReadOnlyKeyedCollection<String^, IAttribute^>::Item::get;
}

Parameters

name
Type: System..::.String

Implements

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Item[([(TKey])])

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


Item Property

[image]

LinkOne WebView API
AttributeCollection..::.Item Property
AttributeCollection Class See Also Send Feedback
Gets the attribute with the given name.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Attribute this[
    string key
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    key As String _
) As Attribute
Visual C++
public:
virtual property Attribute^ default[String^ key] {
    Attribute^ get (String^ key) sealed;
}

Parameters

key
Type: System..::.String
The name of the attribute.

Return Value

The Attribute with the given name, if found; otherwise, null.

Implements

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Item[([(TKey])])

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


LeaveDanglingReferences Property

[image]

LinkOne WebView API
AttributeCollection..::.LeaveDanglingReferences Property
AttributeCollection Class See Also Send Feedback
Gets the LEAVE_DANGLING_REFERENCES attribute.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LeaveDanglingReferenceOption LeaveDanglingReferences { get; }
Visual Basic (Declaration)
Public ReadOnly Property LeaveDanglingReferences As LeaveDanglingReferenceOption
Visual C++
public:
property LeaveDanglingReferenceOption LeaveDanglingReferences {
    LeaveDanglingReferenceOption get ();
}

Field Value

This attribute can be defined in the page as ALWAYS, GROUP or NEVER. Returns GROUP if none specified.

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


LeftFooterFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.LeftFooterFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute LEFT_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string LeftFooterFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property LeftFooterFormat As String
Visual C++
public:
property String^ LeftFooterFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


LeftHeaderFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.LeftHeaderFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute LEFT_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string LeftHeaderFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property LeftHeaderFormat As String
Visual C++
public:
property String^ LeftHeaderFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


LeftListFooterFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.LeftListFooterFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute LEFT_LIST_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string LeftListFooterFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property LeftListFooterFormat As String
Visual C++
public:
property String^ LeftListFooterFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


LeftListHeaderFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.LeftListHeaderFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute LEFT_LIST_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string LeftListHeaderFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property LeftListHeaderFormat As String
Visual C++
public:
property String^ LeftListHeaderFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


LeftPictureFooterFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.LeftPictureFooterFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute LEFT_PIC_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string LeftPictureFooterFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property LeftPictureFooterFormat As String
Visual C++
public:
property String^ LeftPictureFooterFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


LeftPictureHeaderFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.LeftPictureHeaderFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute LEFT_PIC_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string LeftPictureHeaderFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property LeftPictureHeaderFormat As String
Visual C++
public:
property String^ LeftPictureHeaderFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


LimitEntriesPrinted Property

[image]

LinkOne WebView API
AttributeCollection..::.LimitEntriesPrinted Property
AttributeCollection Class See Also Send Feedback
Returns the maximum number of rows to print per sheet.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int LimitEntriesPrinted { get; }
Visual Basic (Declaration)
Public ReadOnly Property LimitEntriesPrinted As Integer
Visual C++
public:
property int LimitEntriesPrinted {
    int get ();
}

Remarks

Zero or negative numbers indicate to fit as many as possible. Defaults to -1 to indicate no limit.

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


ListFooterFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.ListFooterFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute LIST_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string ListFooterFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property ListFooterFormat As String
Visual C++
public:
property String^ ListFooterFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


ListHeaderFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.ListHeaderFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute LIST_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string ListHeaderFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property ListHeaderFormat As String
Visual C++
public:
property String^ ListHeaderFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


ListSheetFacing Property

[image]

LinkOne WebView API
AttributeCollection..::.ListSheetFacing Property
AttributeCollection Class See Also Send Feedback
Gets the LIST_SHEETFACING value associated with this book or page.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LayoutFacing ListSheetFacing { get; }
Visual Basic (Declaration)
Public ReadOnly Property ListSheetFacing As LayoutFacing
Visual C++
public:
property LayoutFacing ListSheetFacing {
    LayoutFacing get ();
}

Return Value

The SHEETFACING option that should be used with the book or page.

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


OddListFooterFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.OddListFooterFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute ODD_LIST_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string OddListFooterFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property OddListFooterFormat As String
Visual C++
public:
property String^ OddListFooterFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


OddListHeaderFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.OddListHeaderFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute ODD_LIST_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string OddListHeaderFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property OddListHeaderFormat As String
Visual C++
public:
property String^ OddListHeaderFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


OddPictureFooterFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.OddPictureFooterFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute ODD_PIC_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string OddPictureFooterFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property OddPictureFooterFormat As String
Visual C++
public:
property String^ OddPictureFooterFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


OddPictureHeaderFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.OddPictureHeaderFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute ODD_PIC_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string OddPictureHeaderFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property OddPictureHeaderFormat As String
Visual C++
public:
property String^ OddPictureHeaderFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


PictureFooterFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.PictureFooterFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute PIC_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PictureFooterFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property PictureFooterFormat As String
Visual C++
public:
property String^ PictureFooterFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


PictureHeaderFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.PictureHeaderFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute PIC_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PictureHeaderFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property PictureHeaderFormat As String
Visual C++
public:
property String^ PictureHeaderFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


PictureSheetFacing Property

[image]

LinkOne WebView API
AttributeCollection..::.PictureSheetFacing Property
AttributeCollection Class See Also Send Feedback
Gets the PIC_SHEETFACING value associated with this book or page.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LayoutFacing PictureSheetFacing { get; }
Visual Basic (Declaration)
Public ReadOnly Property PictureSheetFacing As LayoutFacing
Visual C++
public:
property LayoutFacing PictureSheetFacing {
    LayoutFacing get ();
}

Return Value

The SHEETFACING option that should be used with the book or page.

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


PrintOrder Property

[image]

LinkOne WebView API
AttributeCollection..::.PrintOrder Property
AttributeCollection Class See Also Send Feedback
Gets the PRINT_ORDER value associated with this book or page.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PrintOrderOption PrintOrder { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrintOrder As PrintOrderOption
Visual C++
public:
property PrintOrderOption PrintOrder {
    PrintOrderOption get ();
}

Return Value

The PRINT_ORDER option that should be used with the book or page.

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


PrintTemplate Property

[image]

LinkOne WebView API
AttributeCollection..::.PrintTemplate Property
AttributeCollection Class See Also Send Feedback
Gets the PRINT_TEMPLATE value associated with this book.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PrintTemplateOption PrintTemplate { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrintTemplate As PrintTemplateOption
Visual C++
public:
property PrintTemplateOption PrintTemplate {
    PrintTemplateOption get ();
}

Return Value

The PRINT_TEMPLATE option that should be used with the book.

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


RepeatSheet Property

[image]

LinkOne WebView API
AttributeCollection..::.RepeatSheet Property
AttributeCollection Class See Also Send Feedback
Gets the REPEAT_SHEET value associated with this book or page.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LayoutRepeatSheetCode RepeatSheet { get; }
Visual Basic (Declaration)
Public ReadOnly Property RepeatSheet As LayoutRepeatSheetCode
Visual C++
public:
property LayoutRepeatSheetCode RepeatSheet {
    LayoutRepeatSheetCode get ();
}

Return Value

The REPEAT_SHEET option that should be used with the book or page.

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


RightFooterFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.RightFooterFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute RIGHT_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string RightFooterFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property RightFooterFormat As String
Visual C++
public:
property String^ RightFooterFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


RightHeaderFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.RightHeaderFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute RIGHT_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string RightHeaderFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property RightHeaderFormat As String
Visual C++
public:
property String^ RightHeaderFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


RightListFooterFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.RightListFooterFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute RIGHT_LIST_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string RightListFooterFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property RightListFooterFormat As String
Visual C++
public:
property String^ RightListFooterFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


RightListHeaderFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.RightListHeaderFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute RIGHT_LIST_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string RightListHeaderFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property RightListHeaderFormat As String
Visual C++
public:
property String^ RightListHeaderFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


RightPictureFooterFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.RightPictureFooterFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute RIGHT_PIC_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string RightPictureFooterFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property RightPictureFooterFormat As String
Visual C++
public:
property String^ RightPictureFooterFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


RightPictureHeaderFormat Property

[image]

LinkOne WebView API
AttributeCollection..::.RightPictureHeaderFormat Property
AttributeCollection Class See Also Send Feedback
Gets the named format for the book layout string attribute RIGHT_PIC_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string RightPictureHeaderFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property RightPictureHeaderFormat As String
Visual C++
public:
property String^ RightPictureHeaderFormat {
    String^ get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


SelectQuantityFitted Property

[image]

LinkOne WebView API
AttributeCollection..::.SelectQuantityFitted Property
AttributeCollection Class See Also Send Feedback
Gets true when the SELECT_QTY_FITTED attribute is true, otherwise false.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool SelectQuantityFitted { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectQuantityFitted As Boolean
Visual C++
public:
property bool SelectQuantityFitted {
    bool get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


SheetFacing Property

[image]

LinkOne WebView API
AttributeCollection..::.SheetFacing Property
AttributeCollection Class See Also Send Feedback
Gets the SHEETFACING value associated with this book or page.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LayoutFacing SheetFacing { get; }
Visual Basic (Declaration)
Public ReadOnly Property SheetFacing As LayoutFacing
Visual C++
public:
property LayoutFacing SheetFacing {
    LayoutFacing get ();
}

Return Value

The SHEETFACING option that should be used with the book or page.

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


Template Property

[image]

LinkOne WebView API
AttributeCollection..::.Template Property
AttributeCollection Class See Also Send Feedback
Gets the name of the Template format.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public TemplateOption Template { get; }
Visual Basic (Declaration)
Public ReadOnly Property Template As TemplateOption
Visual C++
public:
property TemplateOption Template {
    TemplateOption get ();
}

See Also

AttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


BookAttributeCollection Class

[image]

LinkOne WebView API
BookAttributeCollection Class
Members See Also Send Feedback
Represents the attributes that have been applied to a LinkOne book.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class BookAttributeCollection : AttributeCollection
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class BookAttributeCollection _
    Inherits AttributeCollection
Visual C++
[SerializableAttribute]
public ref class BookAttributeCollection sealed : public AttributeCollection

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Attributes..::.AttributeCollection
Mincom.LinkOne.Dom.Attributes..::.BookAttributeCollection

See Also

BookAttributeCollection Members
Mincom.LinkOne.Dom.Attributes Namespace


BookAttributeCollection Members

[image] [image]

LinkOne WebView API
BookAttributeCollection Members
BookAttributeCollection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The BookAttributeCollection type exposes the following members.

Methods

Name | Description
AboutThisBook | Gets the collection of ABOUT_THIS_BOOK attributes for the given language code associated with this book. The language code can either be a valid ISO language code, or a blank string for the default behaviour.
Contains | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetAttribute | Gets the attribute with the specified name. (Inherited from AttributeCollection.)
GetAttributeString | Overloaded.
GetAttributeStrings | Gets the attribute strings. (Inherited from AttributeCollection.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from AttributeCollection.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SpecialQuantityString | Gets the SPECIAL_QUANTITY_STRING attribute value.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
AllowBookPrinting | Gets true if the ALLOW_BOOK_PRINTING attribute value is true or unlocked.
AllowConsolidation | Gets true if the ALLOW_CONSOLIDATION attribute value is true or not present.
AutoSelectView | Gets true when the AUTO_SELECT_VIEW attribute is true, otherwise false. (Inherited from AttributeCollection.)
BlankSheetFooterFormat | Gets the named format for the blank page footer. (Inherited from AttributeCollection.)
BlankSheetHeaderFormat | Gets the named format for the blank page header. (Inherited from AttributeCollection.)
BookCaption | Gets the BOOK_CAPTION attribute value or an empty string if none exists.
BookLock | Gets the BOOK_LOCK attribute value or an empty string if none exists.
BuildMode | Gets the BUILD_MODE attribute value.
CalloutTooltipFormat | Gets the named format for the callout tooltip (Inherited from AttributeCollection.)
ClosestPrecedingParent | Gets true if the CLOSEST_PRECEEDING_PARENT attribute value is true.
ColumnHeadingsFormat | Gets the name of the column heading format to use for the page list column heading. (Inherited from AttributeCollection.)
ContractorName | Gets the CONTRACTOR_NAME attribute value or an empty string if none exists.
Count | Gets the number of elements in the collection. (Inherited from AttributeCollection.)
DefaultPrintLayout | Gets the DEFAULT_PRINT_LAYOUT attribute value.
DefaultSaveSearchLevel | Gets the DEFAULT_SAVE_SEARCH_LEVEL attribute value.
DefaultScreenLayout | Gets the DEFAULT_SCREEN_LAYOUT attribute value.
DefaultSearchSet | Gets the DEFAULT_SEARCH_SET attribute value.
DisplayBlankFooter | Gets the DisplayBlankFooter setting of the page. (Inherited from AttributeCollection.)
DisplayBlankHeader | Gets the DisplayBlankHeader setting of the page. (Inherited from AttributeCollection.)
DisplayColumnHeadings | Gets the DisplayColumnHeadings setting of the page. (Inherited from AttributeCollection.)
DisplayListFooter | Gets the DisplayListFooter setting of the page. (Inherited from AttributeCollection.)
DisplayListHeader | Gets the DisplayListHeader setting of the page. (Inherited from AttributeCollection.)
DisplayPictureFooter | Gets the DisplayPicFooter setting of the page. (Inherited from AttributeCollection.)
DisplayPictureHeader | Gets the DisplayPicHeader setting of the page. (Inherited from AttributeCollection.)
EmptyQuantityString | Gets the EMPTY_QUANTITY_STRING attribute value.
EvenListFooterFormat | Gets the named format for the book layout string attribute EVEN_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
EvenListHeaderFormat | Gets the named format for the book layout string attribute EVEN_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
EvenPictureFooterFormat | Gets the named format for the book layout string attribute EVEN_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
EvenPictureHeaderFormat | Gets the named format for the book layout string attribute EVEN_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
ExpirationDate | Gets the EXPIRATION_DATE attribute value as a date.
ExplicitPageNumbers | Gets true if the EXPLICIT_PAGE_NUMBERS attribute value is true.
FirstListFooterFormat | Gets the named format for the book layout string attribute FIRST_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
FirstListHeaderFormat | Gets the named format for the book layout string attribute FIRST_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
FirstPictureFooterFormat | Gets the named format for the book layout string attribute FIRST_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
FirstPictureHeaderFormat | Gets the named format for the book layout string attribute FIRST_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
FooterFormat | Gets the named format for the book layout string attribute FOOTER_FORMAT (Inherited from AttributeCollection.)
HeaderFormat | Gets the named format for the book layout string attribute HEADER_FORMAT (Inherited from AttributeCollection.)
HideReferences | Gets true if the HIDE_REFERENCES attribute value is true.
InitialFooterFormat | Gets the named format for the book layout string attribute INITIAL_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialHeaderFormat | Gets the named format for the book layout string attribute INITIAL_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialLeftFooterFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialLeftHeaderFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialLeftListFooterFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialLeftListHeaderFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialLeftPictureFooterFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialLeftPictureHeaderFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialListFooterFormat | Gets the named format for the book layout string attribute INITIAL_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialListHeaderFormat | Gets the named format for the book layout string attribute INITIAL_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialPictureFooterFormat | Gets the named format for the book layout string attribute INITIAL_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialPictureHeaderFormat | Gets the named format for the book layout string attribute INITIAL_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialRightFooterFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialRightHeaderFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialRightListFooterFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialRightListHeaderFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialRightPictureFooterFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialRightPictureHeaderFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
InnerDictionary | Gets the underlying backing store for the dictionary. (Inherited from AttributeCollection.)
InvalidateOrphans | Gets true if the INVALIDATE_ORPHANS attribute value is true.
InvalidationDate | Gets the INVALIDATION_DATE attribute value as a date.
Item | Gets the attribute with the given name. (Inherited from AttributeCollection.)
LeaveDanglingReferences | Gets the LEAVE_DANGLING_REFERENCES attribute. (Inherited from AttributeCollection.)
LeftFooterFormat | Gets the named format for the book layout string attribute LEFT_FOOTER_FORMAT (Inherited from AttributeCollection.)
LeftHeaderFormat | Gets the named format for the book layout string attribute LEFT_HEADER_FORMAT (Inherited from AttributeCollection.)
LeftListFooterFormat | Gets the named format for the book layout string attribute LEFT_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
LeftListHeaderFormat | Gets the named format for the book layout string attribute LEFT_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
LeftPictureFooterFormat | Gets the named format for the book layout string attribute LEFT_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
LeftPictureHeaderFormat | Gets the named format for the book layout string attribute LEFT_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
LimitEntriesPrinted | Returns the maximum number of rows to print per sheet. (Inherited from AttributeCollection.)
ListFooterFormat | Gets the named format for the book layout string attribute LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
ListHeaderFormat | Gets the named format for the book layout string attribute LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
ListSheetFacing | Gets the LIST_SHEETFACING value associated with this book or page. (Inherited from AttributeCollection.)
NoUserLayoutsAllowed | Gets true if the NO_USER_LAYOUTS_ALLOWED attribute value is true.
OddListFooterFormat | Gets the named format for the book layout string attribute ODD_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
OddListHeaderFormat | Gets the named format for the book layout string attribute ODD_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
OddPictureFooterFormat | Gets the named format for the book layout string attribute ODD_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
OddPictureHeaderFormat | Gets the named format for the book layout string attribute ODD_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
OrdinalPageNumbers | Gets true if the ORDINAL_PAGE_NUMBERS attribute value is true.
PictureFooterFormat | Gets the named format for the book layout string attribute PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
PictureHeaderFormat | Gets the named format for the book layout string attribute PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
PictureSheetFacing | Gets the PIC_SHEETFACING value associated with this book or page. (Inherited from AttributeCollection.)
PrintOrder | Gets the PRINT_ORDER value associated with this book or page. (Inherited from AttributeCollection.)
PrintTemplate | Gets the PRINT_TEMPLATE value associated with this book. (Inherited from AttributeCollection.)
RepeatSheet | Gets the REPEAT_SHEET value associated with this book or page. (Inherited from AttributeCollection.)
ReviewExpirationDate |
RightFooterFormat | Gets the named format for the book layout string attribute RIGHT_FOOTER_FORMAT (Inherited from AttributeCollection.)
RightHeaderFormat | Gets the named format for the book layout string attribute RIGHT_HEADER_FORMAT (Inherited from AttributeCollection.)
RightListFooterFormat | Gets the named format for the book layout string attribute RIGHT_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
RightListHeaderFormat | Gets the named format for the book layout string attribute RIGHT_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
RightPictureFooterFormat | Gets the named format for the book layout string attribute RIGHT_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
RightPictureHeaderFormat | Gets the named format for the book layout string attribute RIGHT_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
SaveSearchLevel | Gets the save search level option.
SecurityLocks | Gets the collection of SECURITY_LOCK attribute values.
SelectQuantityFitted | Gets true when the SELECT_QTY_FITTED attribute is true, otherwise false. (Inherited from AttributeCollection.)
SerialNumber | Gets the SERIAL_NO attribute value or an empty string if none exists.
SheetFacing | Gets the SHEETFACING value associated with this book or page. (Inherited from AttributeCollection.)
ShowOptionNames | Gets true if the SHOW_OPTION_NAMES attribute value is not present or true.
Template | Gets the name of the Template format. (Inherited from AttributeCollection.)
UnknownQuantityString | Gets the UNKNOWN_QUANTITY_STRING attribute value.

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(IAttribute>)>)..::.Contains | (Inherited from AttributeCollection.)
IEnumerable<(Of <(IAttribute>)>)..::.GetEnumerator | (Inherited from AttributeCollection.)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from AttributeCollection.)
IReadOnlyKeyedCollection<(Of <(String, IAttribute>)>)..::.Item | (Inherited from AttributeCollection.)

See Also

BookAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


BookAttributeCollection Methods

[image] [image]

LinkOne WebView API
BookAttributeCollection Methods
BookAttributeCollection Class See Also Send Feedback

The BookAttributeCollection type exposes the following members.

Methods

Name | Description
AboutThisBook | Gets the collection of ABOUT_THIS_BOOK attributes for the given language code associated with this book. The language code can either be a valid ISO language code, or a blank string for the default behaviour.
Contains | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetAttribute | Gets the attribute with the specified name. (Inherited from AttributeCollection.)
GetAttributeString | Overloaded.
GetAttributeStrings | Gets the attribute strings. (Inherited from AttributeCollection.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from AttributeCollection.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SpecialQuantityString | Gets the SPECIAL_QUANTITY_STRING attribute value.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(IAttribute>)>)..::.Contains | (Inherited from AttributeCollection.)
IEnumerable<(Of <(IAttribute>)>)..::.GetEnumerator | (Inherited from AttributeCollection.)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from AttributeCollection.)

See Also

BookAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


AboutThisBook Method

[image]

LinkOne WebView API
BookAttributeCollection..::.AboutThisBook Method
BookAttributeCollection Class See Also Send Feedback
Gets the collection of ABOUT_THIS_BOOK attributes for the given language code associated with this book. The language code can either be a valid ISO language code, or a blank string for the default behaviour.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IList<string> AboutThisBook(
    string languageCode
)
Visual Basic (Declaration)
Public Function AboutThisBook ( _
    languageCode As String _
) As IList(Of String)
Visual C++
public:
IList<String^>^ AboutThisBook(
    String^ languageCode
)

Parameters

languageCode
Type: System..::.String
The language code to retrieve the ABOUT_THIS_BOOK attributes for.

Return Value

Returns the ABOUT_THIS_BOOK attributes as a StringCollection for the given language code and book.

See Also

BookAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


Contains Method

[image] [image]

LinkOne WebView API
BookAttributeCollection..::.Contains Method
BookAttributeCollection Class See Also Send Feedback

Overload List

Name | Description
Contains(Attribute) | Determines whether an attribute is in the collection. (Inherited from AttributeCollection.)
Contains(String) | Gets whether this collection contains an Attribute with the given name. (Inherited from AttributeCollection.)

See Also

BookAttributeCollection Class
BookAttributeCollection Members
Mincom.LinkOne.Dom.Attributes Namespace


GetAttributeString Method

[image] [image]

LinkOne WebView API
BookAttributeCollection..::.GetAttributeString Method
BookAttributeCollection Class See Also Send Feedback

Overload List

Name | Description
GetAttributeString(String) | Gets the value of the attribute with the given name. (Inherited from AttributeCollection.)
GetAttributeString(String, String) | Gets the value of the attribute with the given name. (Inherited from AttributeCollection.)

See Also

BookAttributeCollection Class
BookAttributeCollection Members
Mincom.LinkOne.Dom.Attributes Namespace


SpecialQuantityString Method

[image]

LinkOne WebView API
BookAttributeCollection..::.SpecialQuantityString Method
BookAttributeCollection Class See Also Send Feedback
Gets the SPECIAL_QUANTITY_STRING attribute value.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string SpecialQuantityString(
    string name
)
Visual Basic (Declaration)
Public Function SpecialQuantityString ( _
    name As String _
) As String
Visual C++
public:
String^ SpecialQuantityString(
    String^ name
)

Parameters

name
Type: System..::.String
The actual name of the attribute.

Return Value

The special quantity string of the book if the attribute is defined in the book. Otherwise an empty string.

See Also

BookAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


BookAttributeCollection Properties

[image] [image]

LinkOne WebView API
BookAttributeCollection Properties
BookAttributeCollection Class See Also Send Feedback

The BookAttributeCollection type exposes the following members.

Properties

Name | Description
AllowBookPrinting | Gets true if the ALLOW_BOOK_PRINTING attribute value is true or unlocked.
AllowConsolidation | Gets true if the ALLOW_CONSOLIDATION attribute value is true or not present.
AutoSelectView | Gets true when the AUTO_SELECT_VIEW attribute is true, otherwise false. (Inherited from AttributeCollection.)
BlankSheetFooterFormat | Gets the named format for the blank page footer. (Inherited from AttributeCollection.)
BlankSheetHeaderFormat | Gets the named format for the blank page header. (Inherited from AttributeCollection.)
BookCaption | Gets the BOOK_CAPTION attribute value or an empty string if none exists.
BookLock | Gets the BOOK_LOCK attribute value or an empty string if none exists.
BuildMode | Gets the BUILD_MODE attribute value.
CalloutTooltipFormat | Gets the named format for the callout tooltip (Inherited from AttributeCollection.)
ClosestPrecedingParent | Gets true if the CLOSEST_PRECEEDING_PARENT attribute value is true.
ColumnHeadingsFormat | Gets the name of the column heading format to use for the page list column heading. (Inherited from AttributeCollection.)
ContractorName | Gets the CONTRACTOR_NAME attribute value or an empty string if none exists.
Count | Gets the number of elements in the collection. (Inherited from AttributeCollection.)
DefaultPrintLayout | Gets the DEFAULT_PRINT_LAYOUT attribute value.
DefaultSaveSearchLevel | Gets the DEFAULT_SAVE_SEARCH_LEVEL attribute value.
DefaultScreenLayout | Gets the DEFAULT_SCREEN_LAYOUT attribute value.
DefaultSearchSet | Gets the DEFAULT_SEARCH_SET attribute value.
DisplayBlankFooter | Gets the DisplayBlankFooter setting of the page. (Inherited from AttributeCollection.)
DisplayBlankHeader | Gets the DisplayBlankHeader setting of the page. (Inherited from AttributeCollection.)
DisplayColumnHeadings | Gets the DisplayColumnHeadings setting of the page. (Inherited from AttributeCollection.)
DisplayListFooter | Gets the DisplayListFooter setting of the page. (Inherited from AttributeCollection.)
DisplayListHeader | Gets the DisplayListHeader setting of the page. (Inherited from AttributeCollection.)
DisplayPictureFooter | Gets the DisplayPicFooter setting of the page. (Inherited from AttributeCollection.)
DisplayPictureHeader | Gets the DisplayPicHeader setting of the page. (Inherited from AttributeCollection.)
EmptyQuantityString | Gets the EMPTY_QUANTITY_STRING attribute value.
EvenListFooterFormat | Gets the named format for the book layout string attribute EVEN_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
EvenListHeaderFormat | Gets the named format for the book layout string attribute EVEN_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
EvenPictureFooterFormat | Gets the named format for the book layout string attribute EVEN_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
EvenPictureHeaderFormat | Gets the named format for the book layout string attribute EVEN_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
ExpirationDate | Gets the EXPIRATION_DATE attribute value as a date.
ExplicitPageNumbers | Gets true if the EXPLICIT_PAGE_NUMBERS attribute value is true.
FirstListFooterFormat | Gets the named format for the book layout string attribute FIRST_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
FirstListHeaderFormat | Gets the named format for the book layout string attribute FIRST_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
FirstPictureFooterFormat | Gets the named format for the book layout string attribute FIRST_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
FirstPictureHeaderFormat | Gets the named format for the book layout string attribute FIRST_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
FooterFormat | Gets the named format for the book layout string attribute FOOTER_FORMAT (Inherited from AttributeCollection.)
HeaderFormat | Gets the named format for the book layout string attribute HEADER_FORMAT (Inherited from AttributeCollection.)
HideReferences | Gets true if the HIDE_REFERENCES attribute value is true.
InitialFooterFormat | Gets the named format for the book layout string attribute INITIAL_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialHeaderFormat | Gets the named format for the book layout string attribute INITIAL_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialLeftFooterFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialLeftHeaderFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialLeftListFooterFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialLeftListHeaderFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialLeftPictureFooterFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialLeftPictureHeaderFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialListFooterFormat | Gets the named format for the book layout string attribute INITIAL_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialListHeaderFormat | Gets the named format for the book layout string attribute INITIAL_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialPictureFooterFormat | Gets the named format for the book layout string attribute INITIAL_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialPictureHeaderFormat | Gets the named format for the book layout string attribute INITIAL_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialRightFooterFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialRightHeaderFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialRightListFooterFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialRightListHeaderFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialRightPictureFooterFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialRightPictureHeaderFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
InnerDictionary | Gets the underlying backing store for the dictionary. (Inherited from AttributeCollection.)
InvalidateOrphans | Gets true if the INVALIDATE_ORPHANS attribute value is true.
InvalidationDate | Gets the INVALIDATION_DATE attribute value as a date.
Item | Gets the attribute with the given name. (Inherited from AttributeCollection.)
LeaveDanglingReferences | Gets the LEAVE_DANGLING_REFERENCES attribute. (Inherited from AttributeCollection.)
LeftFooterFormat | Gets the named format for the book layout string attribute LEFT_FOOTER_FORMAT (Inherited from AttributeCollection.)
LeftHeaderFormat | Gets the named format for the book layout string attribute LEFT_HEADER_FORMAT (Inherited from AttributeCollection.)
LeftListFooterFormat | Gets the named format for the book layout string attribute LEFT_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
LeftListHeaderFormat | Gets the named format for the book layout string attribute LEFT_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
LeftPictureFooterFormat | Gets the named format for the book layout string attribute LEFT_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
LeftPictureHeaderFormat | Gets the named format for the book layout string attribute LEFT_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
LimitEntriesPrinted | Returns the maximum number of rows to print per sheet. (Inherited from AttributeCollection.)
ListFooterFormat | Gets the named format for the book layout string attribute LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
ListHeaderFormat | Gets the named format for the book layout string attribute LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
ListSheetFacing | Gets the LIST_SHEETFACING value associated with this book or page. (Inherited from AttributeCollection.)
NoUserLayoutsAllowed | Gets true if the NO_USER_LAYOUTS_ALLOWED attribute value is true.
OddListFooterFormat | Gets the named format for the book layout string attribute ODD_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
OddListHeaderFormat | Gets the named format for the book layout string attribute ODD_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
OddPictureFooterFormat | Gets the named format for the book layout string attribute ODD_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
OddPictureHeaderFormat | Gets the named format for the book layout string attribute ODD_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
OrdinalPageNumbers | Gets true if the ORDINAL_PAGE_NUMBERS attribute value is true.
PictureFooterFormat | Gets the named format for the book layout string attribute PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
PictureHeaderFormat | Gets the named format for the book layout string attribute PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
PictureSheetFacing | Gets the PIC_SHEETFACING value associated with this book or page. (Inherited from AttributeCollection.)
PrintOrder | Gets the PRINT_ORDER value associated with this book or page. (Inherited from AttributeCollection.)
PrintTemplate | Gets the PRINT_TEMPLATE value associated with this book. (Inherited from AttributeCollection.)
RepeatSheet | Gets the REPEAT_SHEET value associated with this book or page. (Inherited from AttributeCollection.)
ReviewExpirationDate |
RightFooterFormat | Gets the named format for the book layout string attribute RIGHT_FOOTER_FORMAT (Inherited from AttributeCollection.)
RightHeaderFormat | Gets the named format for the book layout string attribute RIGHT_HEADER_FORMAT (Inherited from AttributeCollection.)
RightListFooterFormat | Gets the named format for the book layout string attribute RIGHT_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
RightListHeaderFormat | Gets the named format for the book layout string attribute RIGHT_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
RightPictureFooterFormat | Gets the named format for the book layout string attribute RIGHT_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
RightPictureHeaderFormat | Gets the named format for the book layout string attribute RIGHT_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
SaveSearchLevel | Gets the save search level option.
SecurityLocks | Gets the collection of SECURITY_LOCK attribute values.
SelectQuantityFitted | Gets true when the SELECT_QTY_FITTED attribute is true, otherwise false. (Inherited from AttributeCollection.)
SerialNumber | Gets the SERIAL_NO attribute value or an empty string if none exists.
SheetFacing | Gets the SHEETFACING value associated with this book or page. (Inherited from AttributeCollection.)
ShowOptionNames | Gets true if the SHOW_OPTION_NAMES attribute value is not present or true.
Template | Gets the name of the Template format. (Inherited from AttributeCollection.)
UnknownQuantityString | Gets the UNKNOWN_QUANTITY_STRING attribute value.

Explicit Interface Implementations

Name | Description
IReadOnlyKeyedCollection<(Of <(String, IAttribute>)>)..::.Item | (Inherited from AttributeCollection.)

See Also

BookAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


AllowBookPrinting Property

[image]

LinkOne WebView API
BookAttributeCollection..::.AllowBookPrinting Property
BookAttributeCollection Class See Also Send Feedback
Gets true if the ALLOW_BOOK_PRINTING attribute value is true or unlocked.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool AllowBookPrinting { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllowBookPrinting As Boolean
Visual C++
public:
property bool AllowBookPrinting {
    bool get ();
}

Return Value

true if the ALLOW_BOOK_PRINTING attribute value is true or unlocked.

See Also

BookAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


AllowConsolidation Property

[image]

LinkOne WebView API
BookAttributeCollection..::.AllowConsolidation Property
BookAttributeCollection Class See Also Send Feedback
Gets true if the ALLOW_CONSOLIDATION attribute value is true or not present.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool AllowConsolidation { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllowConsolidation As Boolean
Visual C++
public:
property bool AllowConsolidation {
    bool get ();
}

Return Value

true if ALLOW_CONSOLIDATION attribute value is true.

See Also

BookAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


BookCaption Property

[image]

LinkOne WebView API
BookAttributeCollection..::.BookCaption Property
BookAttributeCollection Class See Also Send Feedback
Gets the BOOK_CAPTION attribute value or an empty string if none exists.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string BookCaption { get; }
Visual Basic (Declaration)
Public ReadOnly Property BookCaption As String
Visual C++
public:
property String^ BookCaption {
    String^ get ();
}

Return Value

The BOOK_CAPTION attribute value or an empty string if none exists.

See Also

BookAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


BookLock Property

[image]

LinkOne WebView API
BookAttributeCollection..::.BookLock Property
BookAttributeCollection Class See Also Send Feedback
Gets the BOOK_LOCK attribute value or an empty string if none exists.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string BookLock { get; }
Visual Basic (Declaration)
Public ReadOnly Property BookLock As String
Visual C++
public:
property String^ BookLock {
    String^ get ();
}

Return Value

The BOOK_LOCK attribute value or an empty string if none exists.

See Also

BookAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


BuildMode Property

[image]

LinkOne WebView API
BookAttributeCollection..::.BuildMode Property
BookAttributeCollection Class See Also Send Feedback
Gets the BUILD_MODE attribute value.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string BuildMode { get; }
Visual Basic (Declaration)
Public ReadOnly Property BuildMode As String
Visual C++
public:
property String^ BuildMode {
    String^ get ();
}

Return Value

The BUILD_MODE attribute value.

See Also

BookAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


ClosestPrecedingParent Property

[image]

LinkOne WebView API
BookAttributeCollection..::.ClosestPrecedingParent Property
BookAttributeCollection Class See Also Send Feedback
Gets true if the CLOSEST_PRECEEDING_PARENT attribute value is true.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool ClosestPrecedingParent { get; }
Visual Basic (Declaration)
Public ReadOnly Property ClosestPrecedingParent As Boolean
Visual C++
public:
property bool ClosestPrecedingParent {
    bool get ();
}

Return Value

true of the CLOSEST_PRECEEDING_PARENT attribute value is true.

See Also

BookAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


ContractorName Property

[image]

LinkOne WebView API
BookAttributeCollection..::.ContractorName Property
BookAttributeCollection Class See Also Send Feedback
Gets the CONTRACTOR_NAME attribute value or an empty string if none exists.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string ContractorName { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContractorName As String
Visual C++
public:
property String^ ContractorName {
    String^ get ();
}

Return Value

The CONTRACTOR_NAME attribute value or an empty string if none exists.

See Also

BookAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


DefaultPrintLayout Property

[image]

LinkOne WebView API
BookAttributeCollection..::.DefaultPrintLayout Property
BookAttributeCollection Class See Also Send Feedback
Gets the DEFAULT_PRINT_LAYOUT attribute value.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string DefaultPrintLayout { get; }
Visual Basic (Declaration)
Public ReadOnly Property DefaultPrintLayout As String
Visual C++
public:
property String^ DefaultPrintLayout {
    String^ get ();
}

Return Value

The default print layout specified for the book if the attribute is defined in the book. Otherwise an empty string.

See Also

BookAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


DefaultSaveSearchLevel Property

[image]

LinkOne WebView API
BookAttributeCollection..::.DefaultSaveSearchLevel Property
BookAttributeCollection Class See Also Send Feedback
Gets the DEFAULT_SAVE_SEARCH_LEVEL attribute value.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SaveSearchLevelOption DefaultSaveSearchLevel { get; }
Visual Basic (Declaration)
Public ReadOnly Property DefaultSaveSearchLevel As SaveSearchLevelOption
Visual C++
public:
property SaveSearchLevelOption DefaultSaveSearchLevel {
    SaveSearchLevelOption get ();
}

Return Value

The DEFAULT_SAVE_SEARCH_LEVEL attribute value.

See Also

BookAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


DefaultScreenLayout Property

[image]

LinkOne WebView API
BookAttributeCollection..::.DefaultScreenLayout Property
BookAttributeCollection Class See Also Send Feedback
Gets the DEFAULT_SCREEN_LAYOUT attribute value.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string DefaultScreenLayout { get; }
Visual Basic (Declaration)
Public ReadOnly Property DefaultScreenLayout As String
Visual C++
public:
property String^ DefaultScreenLayout {
    String^ get ();
}

Return Value

The default screen layout specified for the book if the attribute is defined in the book. Otherwise an empty string.

See Also

BookAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


DefaultSearchSet Property

[image]

LinkOne WebView API
BookAttributeCollection..::.DefaultSearchSet Property
BookAttributeCollection Class See Also Send Feedback
Gets the DEFAULT_SEARCH_SET attribute value.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string DefaultSearchSet { get; }
Visual Basic (Declaration)
Public ReadOnly Property DefaultSearchSet As String
Visual C++
public:
property String^ DefaultSearchSet {
    String^ get ();
}

Return Value

The default search set specified for the book if the attribute is defined in the book. Otherwise the name of the predefined search set.

See Also

BookAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


EmptyQuantityString Property

[image]

LinkOne WebView API
BookAttributeCollection..::.EmptyQuantityString Property
BookAttributeCollection Class See Also Send Feedback
Gets the EMPTY_QUANTITY_STRING attribute value.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string EmptyQuantityString { get; }
Visual Basic (Declaration)
Public ReadOnly Property EmptyQuantityString As String
Visual C++
public:
property String^ EmptyQuantityString {
    String^ get ();
}

Return Value

The empty quantity string of the book if the attribute is defined in the book. Otherwise an empty string.

See Also

BookAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


ExpirationDate Property

[image]

LinkOne WebView API
BookAttributeCollection..::.ExpirationDate Property
BookAttributeCollection Class See Also Send Feedback
Gets the EXPIRATION_DATE attribute value as a date.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public DateTime ExpirationDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExpirationDate As DateTime
Visual C++
public:
property DateTime ExpirationDate {
    DateTime get ();
}

Return Value

The expiration date attribute as a date

Remarks

The date after which an expiration warning is given to the user, but the book can still be opened.

See Also

BookAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


ExplicitPageNumbers Property

[image]

LinkOne WebView API
BookAttributeCollection..::.ExplicitPageNumbers Property
BookAttributeCollection Class See Also Send Feedback
Gets true if the EXPLICIT_PAGE_NUMBERS attribute value is true.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool ExplicitPageNumbers { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExplicitPageNumbers As Boolean
Visual C++
public:
property bool ExplicitPageNumbers {
    bool get ();
}

Return Value

true if the EXPLICIT_PAGE_NUMBERS attribute value is true.

See Also

BookAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


HideReferences Property

[image]

LinkOne WebView API
BookAttributeCollection..::.HideReferences Property
BookAttributeCollection Class See Also Send Feedback
Gets true if the HIDE_REFERENCES attribute value is true.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool HideReferences { get; }
Visual Basic (Declaration)
Public ReadOnly Property HideReferences As Boolean
Visual C++
public:
property bool HideReferences {
    bool get ();
}

Return Value

true if HIDE_REFERENCES attribute value is true.

See Also

BookAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


InvalidateOrphans Property

[image]

LinkOne WebView API
BookAttributeCollection..::.InvalidateOrphans Property
BookAttributeCollection Class See Also Send Feedback
Gets true if the INVALIDATE_ORPHANS attribute value is true.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool InvalidateOrphans { get; }
Visual Basic (Declaration)
Public ReadOnly Property InvalidateOrphans As Boolean
Visual C++
public:
property bool InvalidateOrphans {
    bool get ();
}

Return Value

true if the INVALIDATE_ORPHANS attribute value is true.

See Also

BookAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


InvalidationDate Property

[image]

LinkOne WebView API
BookAttributeCollection..::.InvalidationDate Property
BookAttributeCollection Class See Also Send Feedback
Gets the INVALIDATION_DATE attribute value as a date.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public DateTime InvalidationDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property InvalidationDate As DateTime
Visual C++
public:
property DateTime InvalidationDate {
    DateTime get ();
}

Return Value

The drop-dead date of a book.

Remarks

The date after which the book cannot be opened.

See Also

BookAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


NoUserLayoutsAllowed Property

[image]

LinkOne WebView API
BookAttributeCollection..::.NoUserLayoutsAllowed Property
BookAttributeCollection Class See Also Send Feedback
Gets true if the NO_USER_LAYOUTS_ALLOWED attribute value is true.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool NoUserLayoutsAllowed { get; }
Visual Basic (Declaration)
Public ReadOnly Property NoUserLayoutsAllowed As Boolean
Visual C++
public:
property bool NoUserLayoutsAllowed {
    bool get ();
}

Return Value

true if NO_USER_LAYOUTS_ALLOWED attribute value is true.

See Also

BookAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


OrdinalPageNumbers Property

[image]

LinkOne WebView API
BookAttributeCollection..::.OrdinalPageNumbers Property
BookAttributeCollection Class See Also Send Feedback
Gets true if the ORDINAL_PAGE_NUMBERS attribute value is true.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool OrdinalPageNumbers { get; }
Visual Basic (Declaration)
Public ReadOnly Property OrdinalPageNumbers As Boolean
Visual C++
public:
property bool OrdinalPageNumbers {
    bool get ();
}

Return Value

true if the ORDINAL_PAGE_NUMBERS attribute value is true.

See Also

BookAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


ReviewExpirationDate Property

[image]

LinkOne WebView API
BookAttributeCollection..::.ReviewExpirationDate Property
BookAttributeCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public DateTime ReviewExpirationDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReviewExpirationDate As DateTime
Visual C++
public:
property DateTime ReviewExpirationDate {
    DateTime get ();
}

See Also

BookAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


SaveSearchLevel Property

[image]

LinkOne WebView API
BookAttributeCollection..::.SaveSearchLevel Property
BookAttributeCollection Class See Also Send Feedback
Gets the save search level option.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SaveSearchLevelOption SaveSearchLevel { get; }
Visual Basic (Declaration)
Public ReadOnly Property SaveSearchLevel As SaveSearchLevelOption
Visual C++
public:
property SaveSearchLevelOption SaveSearchLevel {
    SaveSearchLevelOption get ();
}

See Also

BookAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


SecurityLocks Property

[image]

LinkOne WebView API
BookAttributeCollection..::.SecurityLocks Property
BookAttributeCollection Class See Also Send Feedback
Gets the collection of SECURITY_LOCK attribute values.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IList<string> SecurityLocks { get; }
Visual Basic (Declaration)
Public ReadOnly Property SecurityLocks As IList(Of String)
Visual C++
public:
property IList<String^>^ SecurityLocks {
    IList<String^>^ get ();
}

Return Value

The collection of SECURITY_LOCK attribute values.

See Also

BookAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


SerialNumber Property

[image]

LinkOne WebView API
BookAttributeCollection..::.SerialNumber Property
BookAttributeCollection Class See Also Send Feedback
Gets the SERIAL_NO attribute value or an empty string if none exists.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string SerialNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property SerialNumber As String
Visual C++
public:
property String^ SerialNumber {
    String^ get ();
}

Return Value

The SERIAL_NO attribute value or an empty string if none exists.

See Also

BookAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


ShowOptionNames Property

[image]

LinkOne WebView API
BookAttributeCollection..::.ShowOptionNames Property
BookAttributeCollection Class See Also Send Feedback
Gets true if the SHOW_OPTION_NAMES attribute value is not present or true.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool ShowOptionNames { get; }
Visual Basic (Declaration)
Public ReadOnly Property ShowOptionNames As Boolean
Visual C++
public:
property bool ShowOptionNames {
    bool get ();
}

Return Value

true if the SHOW_OPTION_NAMES attribute value is not present or true.

See Also

BookAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


UnknownQuantityString Property

[image]

LinkOne WebView API
BookAttributeCollection..::.UnknownQuantityString Property
BookAttributeCollection Class See Also Send Feedback
Gets the UNKNOWN_QUANTITY_STRING attribute value.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string UnknownQuantityString { get; }
Visual Basic (Declaration)
Public ReadOnly Property UnknownQuantityString As String
Visual C++
public:
property String^ UnknownQuantityString {
    String^ get ();
}

Return Value

The unknown quantity string of the book if the attribute is defined in the book. Otherwise null.

See Also

BookAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


IAttribute Interface

[image]

LinkOne WebView API
IAttribute Interface
Members See Also Send Feedback
Represents a LinkOne book attribute.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IAttribute
Visual Basic (Declaration)
Public Interface IAttribute
Visual C++
public interface class IAttribute

See Also

IAttribute Members
Mincom.LinkOne.Dom.Attributes Namespace


IAttribute Members

[image] [image]

LinkOne WebView API
IAttribute Members
IAttribute Interface Properties See Also Send Feedback

The IAttribute type exposes the following members.

Properties

Name | Description
Name | Gets the name of the attribute.
Value | Gets the value of the attribute.

See Also

IAttribute Interface
Mincom.LinkOne.Dom.Attributes Namespace


IAttribute Properties

[image] [image]

LinkOne WebView API
IAttribute Properties
IAttribute Interface See Also Send Feedback

The IAttribute type exposes the following members.

Properties

Name | Description
Name | Gets the name of the attribute.
Value | Gets the value of the attribute.

See Also

IAttribute Interface
Mincom.LinkOne.Dom.Attributes Namespace


Name Property

[image]

LinkOne WebView API
IAttribute..::.Name Property
IAttribute Interface See Also Send Feedback
Gets the name of the attribute.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IAttribute Interface
Mincom.LinkOne.Dom.Attributes Namespace


Value Property

[image]

LinkOne WebView API
IAttribute..::.Value Property
IAttribute Interface See Also Send Feedback
Gets the value of the attribute.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Value { get; }
Visual Basic (Declaration)
ReadOnly Property Value As String
Visual C++
property String^ Value {
    String^ get ();
}

See Also

IAttribute Interface
Mincom.LinkOne.Dom.Attributes Namespace


IAttributeCollection Interface

[image]

LinkOne WebView API
IAttributeCollection Interface
Members See Also Send Feedback
Represents the attributes defined for a LinkOne book, indexed by Name. See remarks.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IAttributeCollection : IReadOnlyKeyedCollection<string, IAttribute>,
    IReadOnlyCollection<IAttribute>, IEnumerable<IAttribute>, IEnumerable
Visual Basic (Declaration)
Public Interface IAttributeCollection _
    Implements IReadOnlyKeyedCollection(Of String, IAttribute),  _
    IReadOnlyCollection(Of IAttribute), IEnumerable(Of IAttribute), IEnumerable
Visual C++
public interface class IAttributeCollection : IReadOnlyKeyedCollection<String^, IAttribute^>,
    IReadOnlyCollection<IAttribute^>, IEnumerable<IAttribute^>, IEnumerable

Remarks

Attribute names are normalized to uppercase strings when stored. You should call see ToUpperInvariant()()() when retrieving a value, or use PredefinedAttributeNames members for predefined attribute lookups. An exception to the rule is the special quantity string. It is valid to specify a-z and A-Z characters, for the last character. To lookup a special quantity string, use the helper method SpecialQuantityString(String).

See Also

IAttributeCollection Members
Mincom.LinkOne.Dom.Attributes Namespace
Mincom.LinkOne.Dom.Attributes..::.PredefinedAttributeNames


IAttributeCollection Members

[image] [image]

LinkOne WebView API
IAttributeCollection Members
IAttributeCollection Interface Methods Properties See Also Send Feedback

The IAttributeCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
GetEnumerator | Overloaded.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item with the specified key. (Inherited from IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>).)

See Also

IAttributeCollection Interface
Mincom.LinkOne.Dom.Attributes Namespace


IAttributeCollection Methods

[image] [image]

LinkOne WebView API
IAttributeCollection Methods
IAttributeCollection Interface See Also Send Feedback

Methods

Name | Description
Contains | Overloaded.
GetEnumerator | Overloaded.

See Also

IAttributeCollection Interface
Mincom.LinkOne.Dom.Attributes Namespace


Contains Method

[image] [image]

LinkOne WebView API
IAttributeCollection..::.Contains Method
IAttributeCollection Interface See Also Send Feedback

Overload List

Name | Description
Contains(T) | Determines whether an element is in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Contains(TKey) | Determines whether an element with the given key is in the collection. (Inherited from IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>).)

See Also

IAttributeCollection Interface
IAttributeCollection Members
Mincom.LinkOne.Dom.Attributes Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
IAttributeCollection..::.GetEnumerator Method
IAttributeCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( IAttribute >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IAttributeCollection Interface
IAttributeCollection Members
Mincom.LinkOne.Dom.Attributes Namespace


IAttributeCollection Properties

[image] [image]

LinkOne WebView API
IAttributeCollection Properties
IAttributeCollection Interface See Also Send Feedback

The IAttributeCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item with the specified key. (Inherited from IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>).)

See Also

IAttributeCollection Interface
Mincom.LinkOne.Dom.Attributes Namespace


LeaveDanglingReferenceOption Enumeration

[image]

LinkOne WebView API
LeaveDanglingReferenceOption Enumeration
See Also Send Feedback
The enumeration of the LEAVE_DANGLING_REFERENCES attribute.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum LeaveDanglingReferenceOption
Visual Basic (Declaration)
Public Enumeration LeaveDanglingReferenceOption
Visual C++
public enum class LeaveDanglingReferenceOption

Members

Member name | Description
Always | ALWAYS means the entries and links are untouched.
Group | GROUP is the default value for this attribute.
Never | NEVER means the entry is always removed unless it contains a part number.

Remarks

This controls what happens to parts list entries that have a Link Reference to a page that is invalid (ie has currently been filtered out of the book).

See Also

Mincom.LinkOne.Dom.Attributes Namespace


PageAttributeCollection Class

[image]

LinkOne WebView API
PageAttributeCollection Class
Members See Also Send Feedback
Represents the collection of attributes that have been applied to a single page.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class PageAttributeCollection : AttributeCollection
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class PageAttributeCollection _
    Inherits AttributeCollection
Visual C++
[SerializableAttribute]
public ref class PageAttributeCollection sealed : public AttributeCollection

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Attributes..::.AttributeCollection
Mincom.LinkOne.Dom.Attributes..::.PageAttributeCollection

See Also

PageAttributeCollection Members
Mincom.LinkOne.Dom.Attributes Namespace


PageAttributeCollection Members

[image] [image]

LinkOne WebView API
PageAttributeCollection Members
PageAttributeCollection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The PageAttributeCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetAttribute | Gets the attribute with the specified name. (Inherited from AttributeCollection.)
GetAttributeString | Overloaded.
GetAttributeStrings | Gets the attribute strings. (Inherited from AttributeCollection.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from AttributeCollection.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
AllowSaveDocument | Gets true if the current document can be extracted from the page and saved.
AllowSaveGraphic | Gets true if the current document can be extracted from the page and saved.
AutoSelectView | Gets true when the AUTO_SELECT_VIEW attribute is true, otherwise false. (Inherited from AttributeCollection.)
BlankSheetFooterFormat | Gets the named format for the blank page footer. (Inherited from AttributeCollection.)
BlankSheetHeaderFormat | Gets the named format for the blank page header. (Inherited from AttributeCollection.)
CalloutTooltipFormat | Gets the named format for the callout tooltip (Inherited from AttributeCollection.)
ColumnHeadingsFormat | Gets the name of the column heading format to use for the page list column heading. (Inherited from AttributeCollection.)
Count | Gets the number of elements in the collection. (Inherited from AttributeCollection.)
DisplayBlankFooter | Gets the DisplayBlankFooter setting of the page. (Inherited from AttributeCollection.)
DisplayBlankHeader | Gets the DisplayBlankHeader setting of the page. (Inherited from AttributeCollection.)
DisplayColumnHeadings | Gets the DisplayColumnHeadings setting of the page. (Inherited from AttributeCollection.)
DisplayListFooter | Gets the DisplayListFooter setting of the page. (Inherited from AttributeCollection.)
DisplayListHeader | Gets the DisplayListHeader setting of the page. (Inherited from AttributeCollection.)
DisplayPictureFooter | Gets the DisplayPicFooter setting of the page. (Inherited from AttributeCollection.)
DisplayPictureHeader | Gets the DisplayPicHeader setting of the page. (Inherited from AttributeCollection.)
EvenListFooterFormat | Gets the named format for the book layout string attribute EVEN_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
EvenListHeaderFormat | Gets the named format for the book layout string attribute EVEN_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
EvenPictureFooterFormat | Gets the named format for the book layout string attribute EVEN_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
EvenPictureHeaderFormat | Gets the named format for the book layout string attribute EVEN_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
FirstListFooterFormat | Gets the named format for the book layout string attribute FIRST_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
FirstListHeaderFormat | Gets the named format for the book layout string attribute FIRST_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
FirstPictureFooterFormat | Gets the named format for the book layout string attribute FIRST_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
FirstPictureHeaderFormat | Gets the named format for the book layout string attribute FIRST_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
FooterFormat | Gets the named format for the book layout string attribute FOOTER_FORMAT (Inherited from AttributeCollection.)
HeaderFormat | Gets the named format for the book layout string attribute HEADER_FORMAT (Inherited from AttributeCollection.)
HtmlFile | Gets true if this page contains the HTML_FILE attribute.
InitialFooterFormat | Gets the named format for the book layout string attribute INITIAL_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialHeaderFormat | Gets the named format for the book layout string attribute INITIAL_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialLeftFooterFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialLeftHeaderFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialLeftListFooterFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialLeftListHeaderFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialLeftPictureFooterFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialLeftPictureHeaderFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialListFooterFormat | Gets the named format for the book layout string attribute INITIAL_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialListHeaderFormat | Gets the named format for the book layout string attribute INITIAL_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialPictureFooterFormat | Gets the named format for the book layout string attribute INITIAL_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialPictureHeaderFormat | Gets the named format for the book layout string attribute INITIAL_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialRightFooterFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialRightHeaderFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialRightListFooterFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialRightListHeaderFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialRightPictureFooterFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialRightPictureHeaderFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
InnerDictionary | Gets the underlying backing store for the dictionary. (Inherited from AttributeCollection.)
Item | Gets the attribute with the given name. (Inherited from AttributeCollection.)
LeaveDanglingReferences | Gets the LEAVE_DANGLING_REFERENCES attribute. (Inherited from AttributeCollection.)
LeftFooterFormat | Gets the named format for the book layout string attribute LEFT_FOOTER_FORMAT (Inherited from AttributeCollection.)
LeftHeaderFormat | Gets the named format for the book layout string attribute LEFT_HEADER_FORMAT (Inherited from AttributeCollection.)
LeftListFooterFormat | Gets the named format for the book layout string attribute LEFT_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
LeftListHeaderFormat | Gets the named format for the book layout string attribute LEFT_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
LeftPictureFooterFormat | Gets the named format for the book layout string attribute LEFT_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
LeftPictureHeaderFormat | Gets the named format for the book layout string attribute LEFT_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
LimitEntriesPrinted | Returns the maximum number of rows to print per sheet. (Inherited from AttributeCollection.)
ListFooterFormat | Gets the named format for the book layout string attribute LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
ListHeaderFormat | Gets the named format for the book layout string attribute LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
ListSheetFacing | Gets the LIST_SHEETFACING value associated with this book or page. (Inherited from AttributeCollection.)
OddListFooterFormat | Gets the named format for the book layout string attribute ODD_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
OddListHeaderFormat | Gets the named format for the book layout string attribute ODD_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
OddPictureFooterFormat | Gets the named format for the book layout string attribute ODD_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
OddPictureHeaderFormat | Gets the named format for the book layout string attribute ODD_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
PictureFooterFormat | Gets the named format for the book layout string attribute PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
PictureHeaderFormat | Gets the named format for the book layout string attribute PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
PictureSheetFacing | Gets the PIC_SHEETFACING value associated with this book or page. (Inherited from AttributeCollection.)
PrintOrder | Gets the PRINT_ORDER value associated with this book or page. (Inherited from AttributeCollection.)
PrintTemplate | Gets the PRINT_TEMPLATE value associated with this book. (Inherited from AttributeCollection.)
RepeatSheet | Gets the REPEAT_SHEET value associated with this book or page. (Inherited from AttributeCollection.)
RightFooterFormat | Gets the named format for the book layout string attribute RIGHT_FOOTER_FORMAT (Inherited from AttributeCollection.)
RightHeaderFormat | Gets the named format for the book layout string attribute RIGHT_HEADER_FORMAT (Inherited from AttributeCollection.)
RightListFooterFormat | Gets the named format for the book layout string attribute RIGHT_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
RightListHeaderFormat | Gets the named format for the book layout string attribute RIGHT_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
RightPictureFooterFormat | Gets the named format for the book layout string attribute RIGHT_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
RightPictureHeaderFormat | Gets the named format for the book layout string attribute RIGHT_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
SecurityLocks | Gets the collection of SECURITY_LOCK attributes associated with the page.
SelectQuantityFitted | Gets true when the SELECT_QTY_FITTED attribute is true, otherwise false. (Inherited from AttributeCollection.)
SheetFacing | Gets the SHEETFACING value associated with this book or page. (Inherited from AttributeCollection.)
Template | Gets the name of the Template format. (Inherited from AttributeCollection.)

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(IAttribute>)>)..::.Contains | (Inherited from AttributeCollection.)
IEnumerable<(Of <(IAttribute>)>)..::.GetEnumerator | (Inherited from AttributeCollection.)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from AttributeCollection.)
IReadOnlyKeyedCollection<(Of <(String, IAttribute>)>)..::.Item | (Inherited from AttributeCollection.)

See Also

PageAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


PageAttributeCollection Methods

[image] [image]

LinkOne WebView API
PageAttributeCollection Methods
PageAttributeCollection Class See Also Send Feedback

The PageAttributeCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetAttribute | Gets the attribute with the specified name. (Inherited from AttributeCollection.)
GetAttributeString | Overloaded.
GetAttributeStrings | Gets the attribute strings. (Inherited from AttributeCollection.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from AttributeCollection.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(IAttribute>)>)..::.Contains | (Inherited from AttributeCollection.)
IEnumerable<(Of <(IAttribute>)>)..::.GetEnumerator | (Inherited from AttributeCollection.)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from AttributeCollection.)

See Also

PageAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


Contains Method

[image] [image]

LinkOne WebView API
PageAttributeCollection..::.Contains Method
PageAttributeCollection Class See Also Send Feedback

Overload List

Name | Description
Contains(Attribute) | Determines whether an attribute is in the collection. (Inherited from AttributeCollection.)
Contains(String) | Gets whether this collection contains an Attribute with the given name. (Inherited from AttributeCollection.)

See Also

PageAttributeCollection Class
PageAttributeCollection Members
Mincom.LinkOne.Dom.Attributes Namespace


GetAttributeString Method

[image] [image]

LinkOne WebView API
PageAttributeCollection..::.GetAttributeString Method
PageAttributeCollection Class See Also Send Feedback

Overload List

Name | Description
GetAttributeString(String) | Gets the value of the attribute with the given name. (Inherited from AttributeCollection.)
GetAttributeString(String, String) | Gets the value of the attribute with the given name. (Inherited from AttributeCollection.)

See Also

PageAttributeCollection Class
PageAttributeCollection Members
Mincom.LinkOne.Dom.Attributes Namespace


PageAttributeCollection Properties

[image] [image]

LinkOne WebView API
PageAttributeCollection Properties
PageAttributeCollection Class See Also Send Feedback

The PageAttributeCollection type exposes the following members.

Properties

Name | Description
AllowSaveDocument | Gets true if the current document can be extracted from the page and saved.
AllowSaveGraphic | Gets true if the current document can be extracted from the page and saved.
AutoSelectView | Gets true when the AUTO_SELECT_VIEW attribute is true, otherwise false. (Inherited from AttributeCollection.)
BlankSheetFooterFormat | Gets the named format for the blank page footer. (Inherited from AttributeCollection.)
BlankSheetHeaderFormat | Gets the named format for the blank page header. (Inherited from AttributeCollection.)
CalloutTooltipFormat | Gets the named format for the callout tooltip (Inherited from AttributeCollection.)
ColumnHeadingsFormat | Gets the name of the column heading format to use for the page list column heading. (Inherited from AttributeCollection.)
Count | Gets the number of elements in the collection. (Inherited from AttributeCollection.)
DisplayBlankFooter | Gets the DisplayBlankFooter setting of the page. (Inherited from AttributeCollection.)
DisplayBlankHeader | Gets the DisplayBlankHeader setting of the page. (Inherited from AttributeCollection.)
DisplayColumnHeadings | Gets the DisplayColumnHeadings setting of the page. (Inherited from AttributeCollection.)
DisplayListFooter | Gets the DisplayListFooter setting of the page. (Inherited from AttributeCollection.)
DisplayListHeader | Gets the DisplayListHeader setting of the page. (Inherited from AttributeCollection.)
DisplayPictureFooter | Gets the DisplayPicFooter setting of the page. (Inherited from AttributeCollection.)
DisplayPictureHeader | Gets the DisplayPicHeader setting of the page. (Inherited from AttributeCollection.)
EvenListFooterFormat | Gets the named format for the book layout string attribute EVEN_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
EvenListHeaderFormat | Gets the named format for the book layout string attribute EVEN_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
EvenPictureFooterFormat | Gets the named format for the book layout string attribute EVEN_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
EvenPictureHeaderFormat | Gets the named format for the book layout string attribute EVEN_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
FirstListFooterFormat | Gets the named format for the book layout string attribute FIRST_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
FirstListHeaderFormat | Gets the named format for the book layout string attribute FIRST_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
FirstPictureFooterFormat | Gets the named format for the book layout string attribute FIRST_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
FirstPictureHeaderFormat | Gets the named format for the book layout string attribute FIRST_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
FooterFormat | Gets the named format for the book layout string attribute FOOTER_FORMAT (Inherited from AttributeCollection.)
HeaderFormat | Gets the named format for the book layout string attribute HEADER_FORMAT (Inherited from AttributeCollection.)
HtmlFile | Gets true if this page contains the HTML_FILE attribute.
InitialFooterFormat | Gets the named format for the book layout string attribute INITIAL_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialHeaderFormat | Gets the named format for the book layout string attribute INITIAL_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialLeftFooterFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialLeftHeaderFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialLeftListFooterFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialLeftListHeaderFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialLeftPictureFooterFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialLeftPictureHeaderFormat | Gets the named format for the book layout string attribute INITIAL_LEFT_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialListFooterFormat | Gets the named format for the book layout string attribute INITIAL_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialListHeaderFormat | Gets the named format for the book layout string attribute INITIAL_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialPictureFooterFormat | Gets the named format for the book layout string attribute INITIAL_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialPictureHeaderFormat | Gets the named format for the book layout string attribute INITIAL_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialRightFooterFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialRightHeaderFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialRightListFooterFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialRightListHeaderFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
InitialRightPictureFooterFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
InitialRightPictureHeaderFormat | Gets the named format for the book layout string attribute INITIAL_RIGHT_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
InnerDictionary | Gets the underlying backing store for the dictionary. (Inherited from AttributeCollection.)
Item | Gets the attribute with the given name. (Inherited from AttributeCollection.)
LeaveDanglingReferences | Gets the LEAVE_DANGLING_REFERENCES attribute. (Inherited from AttributeCollection.)
LeftFooterFormat | Gets the named format for the book layout string attribute LEFT_FOOTER_FORMAT (Inherited from AttributeCollection.)
LeftHeaderFormat | Gets the named format for the book layout string attribute LEFT_HEADER_FORMAT (Inherited from AttributeCollection.)
LeftListFooterFormat | Gets the named format for the book layout string attribute LEFT_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
LeftListHeaderFormat | Gets the named format for the book layout string attribute LEFT_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
LeftPictureFooterFormat | Gets the named format for the book layout string attribute LEFT_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
LeftPictureHeaderFormat | Gets the named format for the book layout string attribute LEFT_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
LimitEntriesPrinted | Returns the maximum number of rows to print per sheet. (Inherited from AttributeCollection.)
ListFooterFormat | Gets the named format for the book layout string attribute LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
ListHeaderFormat | Gets the named format for the book layout string attribute LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
ListSheetFacing | Gets the LIST_SHEETFACING value associated with this book or page. (Inherited from AttributeCollection.)
OddListFooterFormat | Gets the named format for the book layout string attribute ODD_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
OddListHeaderFormat | Gets the named format for the book layout string attribute ODD_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
OddPictureFooterFormat | Gets the named format for the book layout string attribute ODD_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
OddPictureHeaderFormat | Gets the named format for the book layout string attribute ODD_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
PictureFooterFormat | Gets the named format for the book layout string attribute PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
PictureHeaderFormat | Gets the named format for the book layout string attribute PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
PictureSheetFacing | Gets the PIC_SHEETFACING value associated with this book or page. (Inherited from AttributeCollection.)
PrintOrder | Gets the PRINT_ORDER value associated with this book or page. (Inherited from AttributeCollection.)
PrintTemplate | Gets the PRINT_TEMPLATE value associated with this book. (Inherited from AttributeCollection.)
RepeatSheet | Gets the REPEAT_SHEET value associated with this book or page. (Inherited from AttributeCollection.)
RightFooterFormat | Gets the named format for the book layout string attribute RIGHT_FOOTER_FORMAT (Inherited from AttributeCollection.)
RightHeaderFormat | Gets the named format for the book layout string attribute RIGHT_HEADER_FORMAT (Inherited from AttributeCollection.)
RightListFooterFormat | Gets the named format for the book layout string attribute RIGHT_LIST_FOOTER_FORMAT (Inherited from AttributeCollection.)
RightListHeaderFormat | Gets the named format for the book layout string attribute RIGHT_LIST_HEADER_FORMAT (Inherited from AttributeCollection.)
RightPictureFooterFormat | Gets the named format for the book layout string attribute RIGHT_PIC_FOOTER_FORMAT (Inherited from AttributeCollection.)
RightPictureHeaderFormat | Gets the named format for the book layout string attribute RIGHT_PIC_HEADER_FORMAT (Inherited from AttributeCollection.)
SecurityLocks | Gets the collection of SECURITY_LOCK attributes associated with the page.
SelectQuantityFitted | Gets true when the SELECT_QTY_FITTED attribute is true, otherwise false. (Inherited from AttributeCollection.)
SheetFacing | Gets the SHEETFACING value associated with this book or page. (Inherited from AttributeCollection.)
Template | Gets the name of the Template format. (Inherited from AttributeCollection.)

Explicit Interface Implementations

Name | Description
IReadOnlyKeyedCollection<(Of <(String, IAttribute>)>)..::.Item | (Inherited from AttributeCollection.)

See Also

PageAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


AllowSaveDocument Property

[image]

LinkOne WebView API
PageAttributeCollection..::.AllowSaveDocument Property
PageAttributeCollection Class See Also Send Feedback
Gets true if the current document can be extracted from the page and saved.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool AllowSaveDocument { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllowSaveDocument As Boolean
Visual C++
public:
property bool AllowSaveDocument {
    bool get ();
}

Remarks

True is returned if ALLOW_SAVE_DOCUMENT is true, or a number for which the user posesses a security key that can unlock it.

See Also

PageAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


AllowSaveGraphic Property

[image]

LinkOne WebView API
PageAttributeCollection..::.AllowSaveGraphic Property
PageAttributeCollection Class See Also Send Feedback
Gets true if the current document can be extracted from the page and saved.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool AllowSaveGraphic { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllowSaveGraphic As Boolean
Visual C++
public:
property bool AllowSaveGraphic {
    bool get ();
}

Remarks

True is returned if ALLOW_SAVE_GRAPHIC is true, or a number for which the user posesses a security key that can unlock it.

See Also

PageAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


HtmlFile Property

[image]

LinkOne WebView API
PageAttributeCollection..::.HtmlFile Property
PageAttributeCollection Class See Also Send Feedback
Gets true if this page contains the HTML_FILE attribute.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool HtmlFile { get; }
Visual Basic (Declaration)
Public ReadOnly Property HtmlFile As Boolean
Visual C++
public:
property bool HtmlFile {
    bool get ();
}

See Also

PageAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


SecurityLocks Property

[image]

LinkOne WebView API
PageAttributeCollection..::.SecurityLocks Property
PageAttributeCollection Class See Also Send Feedback
Gets the collection of SECURITY_LOCK attributes associated with the page.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IList<string> SecurityLocks { get; }
Visual Basic (Declaration)
Public ReadOnly Property SecurityLocks As IList(Of String)
Visual C++
public:
property IList<String^>^ SecurityLocks {
    IList<String^>^ get ();
}

See Also

PageAttributeCollection Class
Mincom.LinkOne.Dom.Attributes Namespace


PredefinedAttributeNames Class

[image]

LinkOne WebView API
PredefinedAttributeNames Class
Members See Also Send Feedback
Predefined attributes for a LinkOne book.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static class PredefinedAttributeNames
Visual Basic (Declaration)
Public NotInheritable Class PredefinedAttributeNames
Visual C++
public ref class PredefinedAttributeNames abstract sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Attributes..::.PredefinedAttributeNames

See Also

PredefinedAttributeNames Members
Mincom.LinkOne.Dom.Attributes Namespace


PredefinedAttributeNames Members

[image] [image]

LinkOne WebView API
PredefinedAttributeNames Members
PredefinedAttributeNames Class Methods Fields See Also Send Feedback

The PredefinedAttributeNames type exposes the following members.

Methods

Name | Description
AboutThisBook | Represents ABOUT_THIS_BOOK.
SpecialQuantityString | Represents SPECIAL_QUANTITY_STRING_.

Fields

Name | Description
AllowBookPrinting | Represents ALLOW_BOOK_PRINTING.
AllowConsolidation | Represents ALLOW_CONSOLIDATION.
AllowSaveDocument | Represents ALLOW_SAVE_DOCUMENT
AllowSaveGraphic | Represents ALLOW_SAVE_GRAPHIC
AutoSelectView | Represents AUTO_SELECT_VIEW.
BlankSheetFooterFormat | Represents BLANK_SHEET_FOOTER_FORMAT.
BlankSheetHeaderFormat | Represents BLANK_SHEET_HEADER_FORMAT.
BookCaption | Represents BOOK_CAPTION
BookLock | Represents BOOK_LOCK.
BuildMode | Represents BUILD_MODE.
CalloutTooltipFormat | Represents CALLOUT_TOOLTIP_FORMAT.
ClosestPrecedingParent | Represents CLOSEST_PRECEEDING_PARENT.
ColumnHeadingsFormat | Represents COLUMN_HEADINGS_FORMAT.
ContractorName | Represents CONTRACTOR_NAME.
DefaultPrintLayout | Represents DEFAULT_PRINT_LAYOUT.
DefaultSaveSearchLevel | Represents DEFAULT_SAVE_SEARCH_LEVEL
DefaultScreenLayout | Represents DEFAULT_SCREEN_LAYOUT.
DefaultSearchSet | Represents DEFAULT_SEARCH_SET.
EmptyQuantityString | Represents EMPTY_QUANTITY_STRING.
EvenListFooterFormat | Represents EVEN_LIST_FOOTER_FORMAT
EvenListHeaderFormat | Represents EVEN_LIST_HEADER_FORMAT
EvenPictureFooterFormat | Represents EVEN_PIC_FOOTER_FORMAT
EvenPictureHeaderFormat | Represents EVEN_PIC_HEADER_FORMAT
ExpirationDate | Represents EXPIRATION_DATE.
ExplicitPageNumbers | Represents EXPLICIT_PAGE_NUMBERS.
FirstListFooterFormat | Represents FIRST_LIST_FOOTER_FORMAT
FirstListHeaderFormat | Represents FIRST_LIST_HEADER_FORMAT
FirstPictureFooterFormat | Represents FIRST_PIC_FOOTER_FORMAT
FirstPictureHeaderFormat | Represents FIRST_PIC_HEADER_FORMAT
FooterFormat | Represents FOOTER_FORMAT
HeaderFormat | Represents HEADER_FORMAT
HideReferences | Represents HIDE_REFERENCES.
HtmlFile | Represents HTML_FILE.
InitialFooterFormat | Represents INITIAL_FOOTER_FORMAT
InitialHeaderFormat | Represents INITIAL_HEADER_FORMAT
InitialLeftFooterFormat | Represents INITIAL_LEFT_FOOTER_FORMAT
InitialLeftHeaderFormat | Represents INITIAL_LEFT_HEADER_FORMAT
InitialLeftListFooterFormat | Represents INITIAL_LEFT_LIST_FOOTER_FORMAT
InitialLeftListHeaderFormat | Represents INITIAL_LEFT_LIST_HEADER_FORMAT
InitialLeftPictureFooterFormat | Represents INITIAL_LEFT_PIC_FOOTER_FORMAT
InitialLeftPictureHeaderFormat | Represents INITIAL_LEFT_PIC_HEADER_FORMAT
InitialListFooterFormat | Represents INITIAL_LIST_FOOTER_FORMAT
InitialListHeaderFormat | Represents INITIAL_LIST_HEADER_FORMAT
InitialPictureFooterFormat | Represents INITIAL_PIC_FOOTER_FORMAT
InitialPictureHeaderFormat | Represents INITIAL_PIC_HEADER_FORMAT
InitialRightFooterFormat | Represents INITIAL_RIGHT_FOOTER_FORMAT
InitialRightHeaderFormat | Represents INITIAL_RIGHT_HEADER_FORMAT
InitialRightListFooterFormat | Represents INITIAL_RIGHT_LIST_FOOTER_FORMAT
InitialRightListHeaderFormat | Represents INITIAL_RIGHT_LIST_HEADER_FORMAT
InitialRightPictureFooterFormat | Represents INITIAL_RIGHT_PIC_FOOTER_FORMAT
InitialRightPictureHeaderFormat | Represents INITIAL_RIGHT_PIC_HEADER_FORMAT
InvalidateOrphans | Represents INVALIDATE_ORPHANS.
LeaveDanglingReferences | Represents LEAVE_DANGLING_REFERENCES.
LeftFooterFormat | Represents LEFT_FOOTER_FORMAT
LeftHeaderFormat | Represents LEFT_HEADER_FORMAT
LeftListFooterFormat | Represents LEFT_LIST_FOOTER_FORMAT
LeftListHeaderFormat | Represents LEFT_LIST_HEADER_FORMAT
LeftPictureFooterFormat | Represents LEFT_PIC_FOOTER_FORMAT
LeftPictureHeaderFormat | Represents LEFT_PIC_HEADER_FORMAT
LimitEntriesPrinted | Represents LIMIT_ENTRIES_PRINTED
ListFooterFormat | Represents LIST_FOOTER_FORMAT
ListHeaderFormat | Represents LIST_HEADER_FORMAT
ListSheetFacing | Represents LIST_SHEETFACING
NoBlankSheetFooter | Represents NO_SHEET_BLANK_FOOTER.
NoBlankSheetHeader | Represents NO_SHEET_BLANK_HEADER.
NoColumnHeadings | Represents NO_COLUMN_HEADINGS.
NoFooter | Represents NO_FOOTER, which means is the same as NO_LIST_FOOTER and NO_PIC_FOOTER
NoHeader | Represents NO_HEADER, which means is the same as NO_LIST_HEADER and NO_PIC_HEADER
NoListFooter | Represents NO_LIST_FOOTER.
NoListHeader | Represents NO_LIST_HEADER.
NoPictureFooter | Represents NO_PIC_FOOTER.
NoPictureHeader | Represents NO_PIC_HEADER.
NoUserLayoutsAllowed | Represents NO_USER_LAYOUTS_ALLOWED.
OddListFooterFormat | Represents ODD_LIST_FOOTER_FORMAT
OddListHeaderFormat | Represents ODD_LIST_HEADER_FORMAT
OddPictureFooterFormat | Represents ODD_PIC_FOOTER_FORMAT
OddPictureHeaderFormat | Represents ODD_PIC_HEADER_FORMAT
OrdinalPageNumbers | Represents ORDINAL_PAGE_NUMBERS.
PictureFooterFormat | Represents PIC_FOOTER_FORMAT
PictureHeaderFormat | Represents PIC_HEADER_FORMAT
PictureSheetFacing | Represents PIC_SHEETFACING
PrintOrder | Represents PRINT_ORDER.
PrintTemplate | Represents PRINT_TEMPLATE
RepeatSheet | Represents REPEAT_SHEET.
ReviewExpirationDate |
RightFooterFormat | Represents RIGHT_FOOTER_FORMAT
RightHeaderFormat | Represents RIGHT_HEADER_FORMAT
RightListFooterFormat | Represents RIGHT_LIST_FOOTER_FORMAT
RightListHeaderFormat | Represents RIGHT_LIST_HEADER_FORMAT
RightPictureFooterFormat | Represents RIGHT_PIC_FOOTER_FORMAT
RightPictureHeaderFormat | Represents RIGHT_PIC_HEADER_FORMAT
SaveAllInAllBooks | Represents SAVE_ALL_IN_ALL_BOOKS
SaveAllInBook | Represents SAVE_ALL_IN_BOOK
SaveSelectedEntry | Represents SAVE_SELECTED_ENTRY
SecurityLock | Represents SECURITY_LOCK.
SelectQuantityFitted | Represents SELECT_QTY_FITTED.
SerialNumber | Represents SERIAL_NO.
SheetFacing | Represents SHEETFACING
ShowOptionNames | Represents SHOW_OPTION_NAMES.
Template | Represents TEMPLATE
UnknownQuantityString | Represents UNKNOWN_QUANTITY_STRING.

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


PredefinedAttributeNames Fields

[image] [image]

LinkOne WebView API
PredefinedAttributeNames Fields
PredefinedAttributeNames Class See Also Send Feedback

The PredefinedAttributeNames type exposes the following members.

Fields

Name | Description
AllowBookPrinting | Represents ALLOW_BOOK_PRINTING.
AllowConsolidation | Represents ALLOW_CONSOLIDATION.
AllowSaveDocument | Represents ALLOW_SAVE_DOCUMENT
AllowSaveGraphic | Represents ALLOW_SAVE_GRAPHIC
AutoSelectView | Represents AUTO_SELECT_VIEW.
BlankSheetFooterFormat | Represents BLANK_SHEET_FOOTER_FORMAT.
BlankSheetHeaderFormat | Represents BLANK_SHEET_HEADER_FORMAT.
BookCaption | Represents BOOK_CAPTION
BookLock | Represents BOOK_LOCK.
BuildMode | Represents BUILD_MODE.
CalloutTooltipFormat | Represents CALLOUT_TOOLTIP_FORMAT.
ClosestPrecedingParent | Represents CLOSEST_PRECEEDING_PARENT.
ColumnHeadingsFormat | Represents COLUMN_HEADINGS_FORMAT.
ContractorName | Represents CONTRACTOR_NAME.
DefaultPrintLayout | Represents DEFAULT_PRINT_LAYOUT.
DefaultSaveSearchLevel | Represents DEFAULT_SAVE_SEARCH_LEVEL
DefaultScreenLayout | Represents DEFAULT_SCREEN_LAYOUT.
DefaultSearchSet | Represents DEFAULT_SEARCH_SET.
EmptyQuantityString | Represents EMPTY_QUANTITY_STRING.
EvenListFooterFormat | Represents EVEN_LIST_FOOTER_FORMAT
EvenListHeaderFormat | Represents EVEN_LIST_HEADER_FORMAT
EvenPictureFooterFormat | Represents EVEN_PIC_FOOTER_FORMAT
EvenPictureHeaderFormat | Represents EVEN_PIC_HEADER_FORMAT
ExpirationDate | Represents EXPIRATION_DATE.
ExplicitPageNumbers | Represents EXPLICIT_PAGE_NUMBERS.
FirstListFooterFormat | Represents FIRST_LIST_FOOTER_FORMAT
FirstListHeaderFormat | Represents FIRST_LIST_HEADER_FORMAT
FirstPictureFooterFormat | Represents FIRST_PIC_FOOTER_FORMAT
FirstPictureHeaderFormat | Represents FIRST_PIC_HEADER_FORMAT
FooterFormat | Represents FOOTER_FORMAT
HeaderFormat | Represents HEADER_FORMAT
HideReferences | Represents HIDE_REFERENCES.
HtmlFile | Represents HTML_FILE.
InitialFooterFormat | Represents INITIAL_FOOTER_FORMAT
InitialHeaderFormat | Represents INITIAL_HEADER_FORMAT
InitialLeftFooterFormat | Represents INITIAL_LEFT_FOOTER_FORMAT
InitialLeftHeaderFormat | Represents INITIAL_LEFT_HEADER_FORMAT
InitialLeftListFooterFormat | Represents INITIAL_LEFT_LIST_FOOTER_FORMAT
InitialLeftListHeaderFormat | Represents INITIAL_LEFT_LIST_HEADER_FORMAT
InitialLeftPictureFooterFormat | Represents INITIAL_LEFT_PIC_FOOTER_FORMAT
InitialLeftPictureHeaderFormat | Represents INITIAL_LEFT_PIC_HEADER_FORMAT
InitialListFooterFormat | Represents INITIAL_LIST_FOOTER_FORMAT
InitialListHeaderFormat | Represents INITIAL_LIST_HEADER_FORMAT
InitialPictureFooterFormat | Represents INITIAL_PIC_FOOTER_FORMAT
InitialPictureHeaderFormat | Represents INITIAL_PIC_HEADER_FORMAT
InitialRightFooterFormat | Represents INITIAL_RIGHT_FOOTER_FORMAT
InitialRightHeaderFormat | Represents INITIAL_RIGHT_HEADER_FORMAT
InitialRightListFooterFormat | Represents INITIAL_RIGHT_LIST_FOOTER_FORMAT
InitialRightListHeaderFormat | Represents INITIAL_RIGHT_LIST_HEADER_FORMAT
InitialRightPictureFooterFormat | Represents INITIAL_RIGHT_PIC_FOOTER_FORMAT
InitialRightPictureHeaderFormat | Represents INITIAL_RIGHT_PIC_HEADER_FORMAT
InvalidateOrphans | Represents INVALIDATE_ORPHANS.
LeaveDanglingReferences | Represents LEAVE_DANGLING_REFERENCES.
LeftFooterFormat | Represents LEFT_FOOTER_FORMAT
LeftHeaderFormat | Represents LEFT_HEADER_FORMAT
LeftListFooterFormat | Represents LEFT_LIST_FOOTER_FORMAT
LeftListHeaderFormat | Represents LEFT_LIST_HEADER_FORMAT
LeftPictureFooterFormat | Represents LEFT_PIC_FOOTER_FORMAT
LeftPictureHeaderFormat | Represents LEFT_PIC_HEADER_FORMAT
LimitEntriesPrinted | Represents LIMIT_ENTRIES_PRINTED
ListFooterFormat | Represents LIST_FOOTER_FORMAT
ListHeaderFormat | Represents LIST_HEADER_FORMAT
ListSheetFacing | Represents LIST_SHEETFACING
NoBlankSheetFooter | Represents NO_SHEET_BLANK_FOOTER.
NoBlankSheetHeader | Represents NO_SHEET_BLANK_HEADER.
NoColumnHeadings | Represents NO_COLUMN_HEADINGS.
NoFooter | Represents NO_FOOTER, which means is the same as NO_LIST_FOOTER and NO_PIC_FOOTER
NoHeader | Represents NO_HEADER, which means is the same as NO_LIST_HEADER and NO_PIC_HEADER
NoListFooter | Represents NO_LIST_FOOTER.
NoListHeader | Represents NO_LIST_HEADER.
NoPictureFooter | Represents NO_PIC_FOOTER.
NoPictureHeader | Represents NO_PIC_HEADER.
NoUserLayoutsAllowed | Represents NO_USER_LAYOUTS_ALLOWED.
OddListFooterFormat | Represents ODD_LIST_FOOTER_FORMAT
OddListHeaderFormat | Represents ODD_LIST_HEADER_FORMAT
OddPictureFooterFormat | Represents ODD_PIC_FOOTER_FORMAT
OddPictureHeaderFormat | Represents ODD_PIC_HEADER_FORMAT
OrdinalPageNumbers | Represents ORDINAL_PAGE_NUMBERS.
PictureFooterFormat | Represents PIC_FOOTER_FORMAT
PictureHeaderFormat | Represents PIC_HEADER_FORMAT
PictureSheetFacing | Represents PIC_SHEETFACING
PrintOrder | Represents PRINT_ORDER.
PrintTemplate | Represents PRINT_TEMPLATE
RepeatSheet | Represents REPEAT_SHEET.
ReviewExpirationDate |
RightFooterFormat | Represents RIGHT_FOOTER_FORMAT
RightHeaderFormat | Represents RIGHT_HEADER_FORMAT
RightListFooterFormat | Represents RIGHT_LIST_FOOTER_FORMAT
RightListHeaderFormat | Represents RIGHT_LIST_HEADER_FORMAT
RightPictureFooterFormat | Represents RIGHT_PIC_FOOTER_FORMAT
RightPictureHeaderFormat | Represents RIGHT_PIC_HEADER_FORMAT
SaveAllInAllBooks | Represents SAVE_ALL_IN_ALL_BOOKS
SaveAllInBook | Represents SAVE_ALL_IN_BOOK
SaveSelectedEntry | Represents SAVE_SELECTED_ENTRY
SecurityLock | Represents SECURITY_LOCK.
SelectQuantityFitted | Represents SELECT_QTY_FITTED.
SerialNumber | Represents SERIAL_NO.
SheetFacing | Represents SHEETFACING
ShowOptionNames | Represents SHOW_OPTION_NAMES.
Template | Represents TEMPLATE
UnknownQuantityString | Represents UNKNOWN_QUANTITY_STRING.

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


AllowBookPrinting Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.AllowBookPrinting Field
PredefinedAttributeNames Class See Also Send Feedback
Represents ALLOW_BOOK_PRINTING.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string AllowBookPrinting
Visual Basic (Declaration)
Public Const AllowBookPrinting As String
Visual C++
public:
literal String^ AllowBookPrinting

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


AllowConsolidation Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.AllowConsolidation Field
PredefinedAttributeNames Class See Also Send Feedback
Represents ALLOW_CONSOLIDATION.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string AllowConsolidation
Visual Basic (Declaration)
Public Const AllowConsolidation As String
Visual C++
public:
literal String^ AllowConsolidation

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


AllowSaveDocument Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.AllowSaveDocument Field
PredefinedAttributeNames Class See Also Send Feedback
Represents ALLOW_SAVE_DOCUMENT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string AllowSaveDocument
Visual Basic (Declaration)
Public Const AllowSaveDocument As String
Visual C++
public:
literal String^ AllowSaveDocument

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


AllowSaveGraphic Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.AllowSaveGraphic Field
PredefinedAttributeNames Class See Also Send Feedback
Represents ALLOW_SAVE_GRAPHIC

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string AllowSaveGraphic
Visual Basic (Declaration)
Public Const AllowSaveGraphic As String
Visual C++
public:
literal String^ AllowSaveGraphic

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


AutoSelectView Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.AutoSelectView Field
PredefinedAttributeNames Class See Also Send Feedback
Represents AUTO_SELECT_VIEW.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string AutoSelectView
Visual Basic (Declaration)
Public Const AutoSelectView As String
Visual C++
public:
literal String^ AutoSelectView

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


BlankSheetFooterFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.BlankSheetFooterFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents BLANK_SHEET_FOOTER_FORMAT.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string BlankSheetFooterFormat
Visual Basic (Declaration)
Public Const BlankSheetFooterFormat As String
Visual C++
public:
literal String^ BlankSheetFooterFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


BlankSheetHeaderFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.BlankSheetHeaderFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents BLANK_SHEET_HEADER_FORMAT.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string BlankSheetHeaderFormat
Visual Basic (Declaration)
Public Const BlankSheetHeaderFormat As String
Visual C++
public:
literal String^ BlankSheetHeaderFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


BookCaption Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.BookCaption Field
PredefinedAttributeNames Class See Also Send Feedback
Represents BOOK_CAPTION

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string BookCaption
Visual Basic (Declaration)
Public Const BookCaption As String
Visual C++
public:
literal String^ BookCaption

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


BookLock Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.BookLock Field
PredefinedAttributeNames Class See Also Send Feedback
Represents BOOK_LOCK.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string BookLock
Visual Basic (Declaration)
Public Const BookLock As String
Visual C++
public:
literal String^ BookLock

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


BuildMode Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.BuildMode Field
PredefinedAttributeNames Class See Also Send Feedback
Represents BUILD_MODE.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string BuildMode
Visual Basic (Declaration)
Public Const BuildMode As String
Visual C++
public:
literal String^ BuildMode

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


CalloutTooltipFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.CalloutTooltipFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents CALLOUT_TOOLTIP_FORMAT.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string CalloutTooltipFormat
Visual Basic (Declaration)
Public Const CalloutTooltipFormat As String
Visual C++
public:
literal String^ CalloutTooltipFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


ClosestPrecedingParent Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.ClosestPrecedingParent Field
PredefinedAttributeNames Class See Also Send Feedback
Represents CLOSEST_PRECEEDING_PARENT.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string ClosestPrecedingParent
Visual Basic (Declaration)
Public Const ClosestPrecedingParent As String
Visual C++
public:
literal String^ ClosestPrecedingParent

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


ColumnHeadingsFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.ColumnHeadingsFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents COLUMN_HEADINGS_FORMAT.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string ColumnHeadingsFormat
Visual Basic (Declaration)
Public Const ColumnHeadingsFormat As String
Visual C++
public:
literal String^ ColumnHeadingsFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


ContractorName Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.ContractorName Field
PredefinedAttributeNames Class See Also Send Feedback
Represents CONTRACTOR_NAME.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string ContractorName
Visual Basic (Declaration)
Public Const ContractorName As String
Visual C++
public:
literal String^ ContractorName

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


DefaultPrintLayout Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.DefaultPrintLayout Field
PredefinedAttributeNames Class See Also Send Feedback
Represents DEFAULT_PRINT_LAYOUT.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string DefaultPrintLayout
Visual Basic (Declaration)
Public Const DefaultPrintLayout As String
Visual C++
public:
literal String^ DefaultPrintLayout

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


DefaultSaveSearchLevel Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.DefaultSaveSearchLevel Field
PredefinedAttributeNames Class See Also Send Feedback
Represents DEFAULT_SAVE_SEARCH_LEVEL

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string DefaultSaveSearchLevel
Visual Basic (Declaration)
Public Const DefaultSaveSearchLevel As String
Visual C++
public:
literal String^ DefaultSaveSearchLevel

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


DefaultScreenLayout Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.DefaultScreenLayout Field
PredefinedAttributeNames Class See Also Send Feedback
Represents DEFAULT_SCREEN_LAYOUT.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string DefaultScreenLayout
Visual Basic (Declaration)
Public Const DefaultScreenLayout As String
Visual C++
public:
literal String^ DefaultScreenLayout

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


DefaultSearchSet Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.DefaultSearchSet Field
PredefinedAttributeNames Class See Also Send Feedback
Represents DEFAULT_SEARCH_SET.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string DefaultSearchSet
Visual Basic (Declaration)
Public Const DefaultSearchSet As String
Visual C++
public:
literal String^ DefaultSearchSet

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


EmptyQuantityString Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.EmptyQuantityString Field
PredefinedAttributeNames Class See Also Send Feedback
Represents EMPTY_QUANTITY_STRING.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string EmptyQuantityString
Visual Basic (Declaration)
Public Const EmptyQuantityString As String
Visual C++
public:
literal String^ EmptyQuantityString

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


EvenListFooterFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.EvenListFooterFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents EVEN_LIST_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string EvenListFooterFormat
Visual Basic (Declaration)
Public Const EvenListFooterFormat As String
Visual C++
public:
literal String^ EvenListFooterFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


EvenListHeaderFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.EvenListHeaderFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents EVEN_LIST_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string EvenListHeaderFormat
Visual Basic (Declaration)
Public Const EvenListHeaderFormat As String
Visual C++
public:
literal String^ EvenListHeaderFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


EvenPictureFooterFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.EvenPictureFooterFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents EVEN_PIC_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string EvenPictureFooterFormat
Visual Basic (Declaration)
Public Const EvenPictureFooterFormat As String
Visual C++
public:
literal String^ EvenPictureFooterFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


EvenPictureHeaderFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.EvenPictureHeaderFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents EVEN_PIC_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string EvenPictureHeaderFormat
Visual Basic (Declaration)
Public Const EvenPictureHeaderFormat As String
Visual C++
public:
literal String^ EvenPictureHeaderFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


ExpirationDate Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.ExpirationDate Field
PredefinedAttributeNames Class See Also Send Feedback
Represents EXPIRATION_DATE.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string ExpirationDate
Visual Basic (Declaration)
Public Const ExpirationDate As String
Visual C++
public:
literal String^ ExpirationDate

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


ExplicitPageNumbers Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.ExplicitPageNumbers Field
PredefinedAttributeNames Class See Also Send Feedback
Represents EXPLICIT_PAGE_NUMBERS.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string ExplicitPageNumbers
Visual Basic (Declaration)
Public Const ExplicitPageNumbers As String
Visual C++
public:
literal String^ ExplicitPageNumbers

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


FirstListFooterFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.FirstListFooterFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents FIRST_LIST_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string FirstListFooterFormat
Visual Basic (Declaration)
Public Const FirstListFooterFormat As String
Visual C++
public:
literal String^ FirstListFooterFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


FirstListHeaderFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.FirstListHeaderFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents FIRST_LIST_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string FirstListHeaderFormat
Visual Basic (Declaration)
Public Const FirstListHeaderFormat As String
Visual C++
public:
literal String^ FirstListHeaderFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


FirstPictureFooterFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.FirstPictureFooterFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents FIRST_PIC_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string FirstPictureFooterFormat
Visual Basic (Declaration)
Public Const FirstPictureFooterFormat As String
Visual C++
public:
literal String^ FirstPictureFooterFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


FirstPictureHeaderFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.FirstPictureHeaderFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents FIRST_PIC_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string FirstPictureHeaderFormat
Visual Basic (Declaration)
Public Const FirstPictureHeaderFormat As String
Visual C++
public:
literal String^ FirstPictureHeaderFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


FooterFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.FooterFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string FooterFormat
Visual Basic (Declaration)
Public Const FooterFormat As String
Visual C++
public:
literal String^ FooterFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


HeaderFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.HeaderFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string HeaderFormat
Visual Basic (Declaration)
Public Const HeaderFormat As String
Visual C++
public:
literal String^ HeaderFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


HideReferences Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.HideReferences Field
PredefinedAttributeNames Class See Also Send Feedback
Represents HIDE_REFERENCES.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string HideReferences
Visual Basic (Declaration)
Public Const HideReferences As String
Visual C++
public:
literal String^ HideReferences

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


HtmlFile Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.HtmlFile Field
PredefinedAttributeNames Class See Also Send Feedback
Represents HTML_FILE.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string HtmlFile
Visual Basic (Declaration)
Public Const HtmlFile As String
Visual C++
public:
literal String^ HtmlFile

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialFooterFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.InitialFooterFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents INITIAL_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string InitialFooterFormat
Visual Basic (Declaration)
Public Const InitialFooterFormat As String
Visual C++
public:
literal String^ InitialFooterFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialHeaderFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.InitialHeaderFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents INITIAL_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string InitialHeaderFormat
Visual Basic (Declaration)
Public Const InitialHeaderFormat As String
Visual C++
public:
literal String^ InitialHeaderFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialLeftFooterFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.InitialLeftFooterFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents INITIAL_LEFT_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string InitialLeftFooterFormat
Visual Basic (Declaration)
Public Const InitialLeftFooterFormat As String
Visual C++
public:
literal String^ InitialLeftFooterFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialLeftHeaderFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.InitialLeftHeaderFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents INITIAL_LEFT_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string InitialLeftHeaderFormat
Visual Basic (Declaration)
Public Const InitialLeftHeaderFormat As String
Visual C++
public:
literal String^ InitialLeftHeaderFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialLeftListFooterFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.InitialLeftListFooterFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents INITIAL_LEFT_LIST_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string InitialLeftListFooterFormat
Visual Basic (Declaration)
Public Const InitialLeftListFooterFormat As String
Visual C++
public:
literal String^ InitialLeftListFooterFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialLeftListHeaderFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.InitialLeftListHeaderFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents INITIAL_LEFT_LIST_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string InitialLeftListHeaderFormat
Visual Basic (Declaration)
Public Const InitialLeftListHeaderFormat As String
Visual C++
public:
literal String^ InitialLeftListHeaderFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialLeftPictureFooterFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.InitialLeftPictureFooterFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents INITIAL_LEFT_PIC_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string InitialLeftPictureFooterFormat
Visual Basic (Declaration)
Public Const InitialLeftPictureFooterFormat As String
Visual C++
public:
literal String^ InitialLeftPictureFooterFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialLeftPictureHeaderFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.InitialLeftPictureHeaderFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents INITIAL_LEFT_PIC_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string InitialLeftPictureHeaderFormat
Visual Basic (Declaration)
Public Const InitialLeftPictureHeaderFormat As String
Visual C++
public:
literal String^ InitialLeftPictureHeaderFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialListFooterFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.InitialListFooterFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents INITIAL_LIST_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string InitialListFooterFormat
Visual Basic (Declaration)
Public Const InitialListFooterFormat As String
Visual C++
public:
literal String^ InitialListFooterFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialListHeaderFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.InitialListHeaderFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents INITIAL_LIST_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string InitialListHeaderFormat
Visual Basic (Declaration)
Public Const InitialListHeaderFormat As String
Visual C++
public:
literal String^ InitialListHeaderFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialPictureFooterFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.InitialPictureFooterFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents INITIAL_PIC_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string InitialPictureFooterFormat
Visual Basic (Declaration)
Public Const InitialPictureFooterFormat As String
Visual C++
public:
literal String^ InitialPictureFooterFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialPictureHeaderFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.InitialPictureHeaderFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents INITIAL_PIC_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string InitialPictureHeaderFormat
Visual Basic (Declaration)
Public Const InitialPictureHeaderFormat As String
Visual C++
public:
literal String^ InitialPictureHeaderFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialRightFooterFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.InitialRightFooterFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents INITIAL_RIGHT_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string InitialRightFooterFormat
Visual Basic (Declaration)
Public Const InitialRightFooterFormat As String
Visual C++
public:
literal String^ InitialRightFooterFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialRightHeaderFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.InitialRightHeaderFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents INITIAL_RIGHT_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string InitialRightHeaderFormat
Visual Basic (Declaration)
Public Const InitialRightHeaderFormat As String
Visual C++
public:
literal String^ InitialRightHeaderFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialRightListFooterFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.InitialRightListFooterFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents INITIAL_RIGHT_LIST_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string InitialRightListFooterFormat
Visual Basic (Declaration)
Public Const InitialRightListFooterFormat As String
Visual C++
public:
literal String^ InitialRightListFooterFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialRightListHeaderFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.InitialRightListHeaderFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents INITIAL_RIGHT_LIST_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string InitialRightListHeaderFormat
Visual Basic (Declaration)
Public Const InitialRightListHeaderFormat As String
Visual C++
public:
literal String^ InitialRightListHeaderFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialRightPictureFooterFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.InitialRightPictureFooterFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents INITIAL_RIGHT_PIC_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string InitialRightPictureFooterFormat
Visual Basic (Declaration)
Public Const InitialRightPictureFooterFormat As String
Visual C++
public:
literal String^ InitialRightPictureFooterFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


InitialRightPictureHeaderFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.InitialRightPictureHeaderFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents INITIAL_RIGHT_PIC_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string InitialRightPictureHeaderFormat
Visual Basic (Declaration)
Public Const InitialRightPictureHeaderFormat As String
Visual C++
public:
literal String^ InitialRightPictureHeaderFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


InvalidateOrphans Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.InvalidateOrphans Field
PredefinedAttributeNames Class See Also Send Feedback
Represents INVALIDATE_ORPHANS.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string InvalidateOrphans
Visual Basic (Declaration)
Public Const InvalidateOrphans As String
Visual C++
public:
literal String^ InvalidateOrphans

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


LeaveDanglingReferences Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.LeaveDanglingReferences Field
PredefinedAttributeNames Class See Also Send Feedback
Represents LEAVE_DANGLING_REFERENCES.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string LeaveDanglingReferences
Visual Basic (Declaration)
Public Const LeaveDanglingReferences As String
Visual C++
public:
literal String^ LeaveDanglingReferences

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


LeftFooterFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.LeftFooterFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents LEFT_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string LeftFooterFormat
Visual Basic (Declaration)
Public Const LeftFooterFormat As String
Visual C++
public:
literal String^ LeftFooterFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


LeftHeaderFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.LeftHeaderFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents LEFT_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string LeftHeaderFormat
Visual Basic (Declaration)
Public Const LeftHeaderFormat As String
Visual C++
public:
literal String^ LeftHeaderFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


LeftListFooterFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.LeftListFooterFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents LEFT_LIST_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string LeftListFooterFormat
Visual Basic (Declaration)
Public Const LeftListFooterFormat As String
Visual C++
public:
literal String^ LeftListFooterFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


LeftListHeaderFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.LeftListHeaderFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents LEFT_LIST_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string LeftListHeaderFormat
Visual Basic (Declaration)
Public Const LeftListHeaderFormat As String
Visual C++
public:
literal String^ LeftListHeaderFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


LeftPictureFooterFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.LeftPictureFooterFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents LEFT_PIC_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string LeftPictureFooterFormat
Visual Basic (Declaration)
Public Const LeftPictureFooterFormat As String
Visual C++
public:
literal String^ LeftPictureFooterFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


LeftPictureHeaderFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.LeftPictureHeaderFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents LEFT_PIC_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string LeftPictureHeaderFormat
Visual Basic (Declaration)
Public Const LeftPictureHeaderFormat As String
Visual C++
public:
literal String^ LeftPictureHeaderFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


LimitEntriesPrinted Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.LimitEntriesPrinted Field
PredefinedAttributeNames Class See Also Send Feedback
Represents LIMIT_ENTRIES_PRINTED

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string LimitEntriesPrinted
Visual Basic (Declaration)
Public Const LimitEntriesPrinted As String
Visual C++
public:
literal String^ LimitEntriesPrinted

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


ListFooterFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.ListFooterFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents LIST_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string ListFooterFormat
Visual Basic (Declaration)
Public Const ListFooterFormat As String
Visual C++
public:
literal String^ ListFooterFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


ListHeaderFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.ListHeaderFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents LIST_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string ListHeaderFormat
Visual Basic (Declaration)
Public Const ListHeaderFormat As String
Visual C++
public:
literal String^ ListHeaderFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


ListSheetFacing Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.ListSheetFacing Field
PredefinedAttributeNames Class See Also Send Feedback
Represents LIST_SHEETFACING

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string ListSheetFacing
Visual Basic (Declaration)
Public Const ListSheetFacing As String
Visual C++
public:
literal String^ ListSheetFacing

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


NoBlankSheetFooter Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.NoBlankSheetFooter Field
PredefinedAttributeNames Class See Also Send Feedback
Represents NO_SHEET_BLANK_FOOTER.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string NoBlankSheetFooter
Visual Basic (Declaration)
Public Const NoBlankSheetFooter As String
Visual C++
public:
literal String^ NoBlankSheetFooter

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


NoBlankSheetHeader Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.NoBlankSheetHeader Field
PredefinedAttributeNames Class See Also Send Feedback
Represents NO_SHEET_BLANK_HEADER.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string NoBlankSheetHeader
Visual Basic (Declaration)
Public Const NoBlankSheetHeader As String
Visual C++
public:
literal String^ NoBlankSheetHeader

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


NoColumnHeadings Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.NoColumnHeadings Field
PredefinedAttributeNames Class See Also Send Feedback
Represents NO_COLUMN_HEADINGS.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string NoColumnHeadings
Visual Basic (Declaration)
Public Const NoColumnHeadings As String
Visual C++
public:
literal String^ NoColumnHeadings

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


NoFooter Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.NoFooter Field
PredefinedAttributeNames Class See Also Send Feedback
Represents NO_FOOTER, which means is the same as NO_LIST_FOOTER and NO_PIC_FOOTER

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string NoFooter
Visual Basic (Declaration)
Public Const NoFooter As String
Visual C++
public:
literal String^ NoFooter

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


NoHeader Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.NoHeader Field
PredefinedAttributeNames Class See Also Send Feedback
Represents NO_HEADER, which means is the same as NO_LIST_HEADER and NO_PIC_HEADER

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string NoHeader
Visual Basic (Declaration)
Public Const NoHeader As String
Visual C++
public:
literal String^ NoHeader

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


NoListFooter Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.NoListFooter Field
PredefinedAttributeNames Class See Also Send Feedback
Represents NO_LIST_FOOTER.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string NoListFooter
Visual Basic (Declaration)
Public Const NoListFooter As String
Visual C++
public:
literal String^ NoListFooter

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


NoListHeader Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.NoListHeader Field
PredefinedAttributeNames Class See Also Send Feedback
Represents NO_LIST_HEADER.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string NoListHeader
Visual Basic (Declaration)
Public Const NoListHeader As String
Visual C++
public:
literal String^ NoListHeader

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


NoPictureFooter Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.NoPictureFooter Field
PredefinedAttributeNames Class See Also Send Feedback
Represents NO_PIC_FOOTER.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string NoPictureFooter
Visual Basic (Declaration)
Public Const NoPictureFooter As String
Visual C++
public:
literal String^ NoPictureFooter

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


NoPictureHeader Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.NoPictureHeader Field
PredefinedAttributeNames Class See Also Send Feedback
Represents NO_PIC_HEADER.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string NoPictureHeader
Visual Basic (Declaration)
Public Const NoPictureHeader As String
Visual C++
public:
literal String^ NoPictureHeader

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


NoUserLayoutsAllowed Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.NoUserLayoutsAllowed Field
PredefinedAttributeNames Class See Also Send Feedback
Represents NO_USER_LAYOUTS_ALLOWED.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string NoUserLayoutsAllowed
Visual Basic (Declaration)
Public Const NoUserLayoutsAllowed As String
Visual C++
public:
literal String^ NoUserLayoutsAllowed

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


OddListFooterFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.OddListFooterFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents ODD_LIST_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string OddListFooterFormat
Visual Basic (Declaration)
Public Const OddListFooterFormat As String
Visual C++
public:
literal String^ OddListFooterFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


OddListHeaderFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.OddListHeaderFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents ODD_LIST_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string OddListHeaderFormat
Visual Basic (Declaration)
Public Const OddListHeaderFormat As String
Visual C++
public:
literal String^ OddListHeaderFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


OddPictureFooterFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.OddPictureFooterFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents ODD_PIC_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string OddPictureFooterFormat
Visual Basic (Declaration)
Public Const OddPictureFooterFormat As String
Visual C++
public:
literal String^ OddPictureFooterFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


OddPictureHeaderFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.OddPictureHeaderFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents ODD_PIC_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string OddPictureHeaderFormat
Visual Basic (Declaration)
Public Const OddPictureHeaderFormat As String
Visual C++
public:
literal String^ OddPictureHeaderFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


OrdinalPageNumbers Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.OrdinalPageNumbers Field
PredefinedAttributeNames Class See Also Send Feedback
Represents ORDINAL_PAGE_NUMBERS.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string OrdinalPageNumbers
Visual Basic (Declaration)
Public Const OrdinalPageNumbers As String
Visual C++
public:
literal String^ OrdinalPageNumbers

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


PictureFooterFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.PictureFooterFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents PIC_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string PictureFooterFormat
Visual Basic (Declaration)
Public Const PictureFooterFormat As String
Visual C++
public:
literal String^ PictureFooterFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


PictureHeaderFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.PictureHeaderFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents PIC_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string PictureHeaderFormat
Visual Basic (Declaration)
Public Const PictureHeaderFormat As String
Visual C++
public:
literal String^ PictureHeaderFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


PictureSheetFacing Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.PictureSheetFacing Field
PredefinedAttributeNames Class See Also Send Feedback
Represents PIC_SHEETFACING

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string PictureSheetFacing
Visual Basic (Declaration)
Public Const PictureSheetFacing As String
Visual C++
public:
literal String^ PictureSheetFacing

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


PrintOrder Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.PrintOrder Field
PredefinedAttributeNames Class See Also Send Feedback
Represents PRINT_ORDER.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string PrintOrder
Visual Basic (Declaration)
Public Const PrintOrder As String
Visual C++
public:
literal String^ PrintOrder

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


PrintTemplate Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.PrintTemplate Field
PredefinedAttributeNames Class See Also Send Feedback
Represents PRINT_TEMPLATE

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string PrintTemplate
Visual Basic (Declaration)
Public Const PrintTemplate As String
Visual C++
public:
literal String^ PrintTemplate

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


RepeatSheet Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.RepeatSheet Field
PredefinedAttributeNames Class See Also Send Feedback
Represents REPEAT_SHEET.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string RepeatSheet
Visual Basic (Declaration)
Public Const RepeatSheet As String
Visual C++
public:
literal String^ RepeatSheet

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


ReviewExpirationDate Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.ReviewExpirationDate Field
PredefinedAttributeNames Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string ReviewExpirationDate
Visual Basic (Declaration)
Public Const ReviewExpirationDate As String
Visual C++
public:
literal String^ ReviewExpirationDate

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


RightFooterFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.RightFooterFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents RIGHT_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string RightFooterFormat
Visual Basic (Declaration)
Public Const RightFooterFormat As String
Visual C++
public:
literal String^ RightFooterFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


RightHeaderFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.RightHeaderFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents RIGHT_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string RightHeaderFormat
Visual Basic (Declaration)
Public Const RightHeaderFormat As String
Visual C++
public:
literal String^ RightHeaderFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


RightListFooterFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.RightListFooterFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents RIGHT_LIST_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string RightListFooterFormat
Visual Basic (Declaration)
Public Const RightListFooterFormat As String
Visual C++
public:
literal String^ RightListFooterFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


RightListHeaderFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.RightListHeaderFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents RIGHT_LIST_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string RightListHeaderFormat
Visual Basic (Declaration)
Public Const RightListHeaderFormat As String
Visual C++
public:
literal String^ RightListHeaderFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


RightPictureFooterFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.RightPictureFooterFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents RIGHT_PIC_FOOTER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string RightPictureFooterFormat
Visual Basic (Declaration)
Public Const RightPictureFooterFormat As String
Visual C++
public:
literal String^ RightPictureFooterFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


RightPictureHeaderFormat Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.RightPictureHeaderFormat Field
PredefinedAttributeNames Class See Also Send Feedback
Represents RIGHT_PIC_HEADER_FORMAT

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string RightPictureHeaderFormat
Visual Basic (Declaration)
Public Const RightPictureHeaderFormat As String
Visual C++
public:
literal String^ RightPictureHeaderFormat

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


SaveAllInAllBooks Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.SaveAllInAllBooks Field
PredefinedAttributeNames Class See Also Send Feedback
Represents SAVE_ALL_IN_ALL_BOOKS

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string SaveAllInAllBooks
Visual Basic (Declaration)
Public Const SaveAllInAllBooks As String
Visual C++
public:
literal String^ SaveAllInAllBooks

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


SaveAllInBook Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.SaveAllInBook Field
PredefinedAttributeNames Class See Also Send Feedback
Represents SAVE_ALL_IN_BOOK

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string SaveAllInBook
Visual Basic (Declaration)
Public Const SaveAllInBook As String
Visual C++
public:
literal String^ SaveAllInBook

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


SaveSelectedEntry Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.SaveSelectedEntry Field
PredefinedAttributeNames Class See Also Send Feedback
Represents SAVE_SELECTED_ENTRY

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string SaveSelectedEntry
Visual Basic (Declaration)
Public Const SaveSelectedEntry As String
Visual C++
public:
literal String^ SaveSelectedEntry

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


SecurityLock Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.SecurityLock Field
PredefinedAttributeNames Class See Also Send Feedback
Represents SECURITY_LOCK.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string SecurityLock
Visual Basic (Declaration)
Public Const SecurityLock As String
Visual C++
public:
literal String^ SecurityLock

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


SelectQuantityFitted Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.SelectQuantityFitted Field
PredefinedAttributeNames Class See Also Send Feedback
Represents SELECT_QTY_FITTED.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string SelectQuantityFitted
Visual Basic (Declaration)
Public Const SelectQuantityFitted As String
Visual C++
public:
literal String^ SelectQuantityFitted

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


SerialNumber Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.SerialNumber Field
PredefinedAttributeNames Class See Also Send Feedback
Represents SERIAL_NO.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string SerialNumber
Visual Basic (Declaration)
Public Const SerialNumber As String
Visual C++
public:
literal String^ SerialNumber

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


SheetFacing Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.SheetFacing Field
PredefinedAttributeNames Class See Also Send Feedback
Represents SHEETFACING

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string SheetFacing
Visual Basic (Declaration)
Public Const SheetFacing As String
Visual C++
public:
literal String^ SheetFacing

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


ShowOptionNames Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.ShowOptionNames Field
PredefinedAttributeNames Class See Also Send Feedback
Represents SHOW_OPTION_NAMES.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string ShowOptionNames
Visual Basic (Declaration)
Public Const ShowOptionNames As String
Visual C++
public:
literal String^ ShowOptionNames

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


Template Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.Template Field
PredefinedAttributeNames Class See Also Send Feedback
Represents TEMPLATE

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string Template
Visual Basic (Declaration)
Public Const Template As String
Visual C++
public:
literal String^ Template

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


UnknownQuantityString Field

[image]

LinkOne WebView API
PredefinedAttributeNames..::.UnknownQuantityString Field
PredefinedAttributeNames Class See Also Send Feedback
Represents UNKNOWN_QUANTITY_STRING.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string UnknownQuantityString
Visual Basic (Declaration)
Public Const UnknownQuantityString As String
Visual C++
public:
literal String^ UnknownQuantityString

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


PredefinedAttributeNames Methods

[image] [image]

LinkOne WebView API
PredefinedAttributeNames Methods
PredefinedAttributeNames Class See Also Send Feedback

The PredefinedAttributeNames type exposes the following members.

Methods

Name | Description
AboutThisBook | Represents ABOUT_THIS_BOOK.
SpecialQuantityString | Represents SPECIAL_QUANTITY_STRING_.

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


AboutThisBook Method

[image]

LinkOne WebView API
PredefinedAttributeNames..::.AboutThisBook Method
PredefinedAttributeNames Class See Also Send Feedback
Represents ABOUT_THIS_BOOK.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static string AboutThisBook(
    string languageCode
)
Visual Basic (Declaration)
Public Shared Function AboutThisBook ( _
    languageCode As String _
) As String
Visual C++
public:
static String^ AboutThisBook(
    String^ languageCode
)

Parameters

languageCode
Type: System..::.String

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


SpecialQuantityString Method

[image]

LinkOne WebView API
PredefinedAttributeNames..::.SpecialQuantityString Method
PredefinedAttributeNames Class See Also Send Feedback
Represents SPECIAL_QUANTITY_STRING_.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static string SpecialQuantityString(
    string quantityCharacter
)
Visual Basic (Declaration)
Public Shared Function SpecialQuantityString ( _
    quantityCharacter As String _
) As String
Visual C++
public:
static String^ SpecialQuantityString(
    String^ quantityCharacter
)

Parameters

quantityCharacter
Type: System..::.String

See Also

PredefinedAttributeNames Class
Mincom.LinkOne.Dom.Attributes Namespace


PrintOrderOption Enumeration

[image]

LinkOne WebView API
PrintOrderOption Enumeration
See Also Send Feedback
Type of print order.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum PrintOrderOption
Visual Basic (Declaration)
Public Enumeration PrintOrderOption
Visual C++
public enum class PrintOrderOption

Members

Member name | Description
UseDefault | Uses the default print order.
AllPicturesFirst | Print all the pictures first.
AllPartsFirst | Print all the parts first.
InterleavedPicturesFirst | Print one picture sheet, followed by one parts sheet, and repeat until both exhausted, using blank sheets where needed.
InterleavedPartsFirst | Print one parts sheet, followed by one pucture sheet, and repeat until both exhausted, using blank sheets where needed.

See Also

Mincom.LinkOne.Dom.Attributes Namespace


PrintTemplateOption Enumeration

[image]

LinkOne WebView API
PrintTemplateOption Enumeration
See Also Send Feedback
Type of print option.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum PrintTemplateOption
Visual Basic (Declaration)
Public Enumeration PrintTemplateOption
Visual C++
public enum class PrintTemplateOption

Members

Member name | Description
SplitFixed | Print the picture and list on the same page.
SplitVariable | Print the picture and list on the same page.
Separate | Print the picture and list on seperate pages.
NoList | Print the picture only.

See Also

Mincom.LinkOne.Dom.Attributes Namespace


SaveSearchLevelOption Enumeration

[image]

LinkOne WebView API
SaveSearchLevelOption Enumeration
See Also Send Feedback
Types of save search levels available.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum SaveSearchLevelOption
Visual Basic (Declaration)
Public Enumeration SaveSearchLevelOption
Visual C++
public enum class SaveSearchLevelOption

Members

Member name | Description
SaveSelectedEntry | Users can on;ly save information for single book searches, for the currently selected item in the searches results 'hit list'. In Multi-book searches they cannot save anything.
SaveAllInBook | Allows the user to save all found information for the searched book. This works in both single-book and multi-book searches if a specific book is chosen from the results list. This enables the export of the complete parts index from a single book.
SaveAllInAllBooks | Allows the user to save all search results, both in single and in multi-book searches. This enables the export of the complete parts index from a set of books.
Disabled | Users cannot save any data for any search.

See Also

Mincom.LinkOne.Dom.Attributes Namespace


TemplateOption Enumeration

[image]

LinkOne WebView API
TemplateOption Enumeration
See Also Send Feedback
Types of template names available.

Namespace: Mincom.LinkOne.Dom.Attributes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum TemplateOption
Visual Basic (Declaration)
Public Enumeration TemplateOption
Visual C++
public enum class TemplateOption

Members

Member name | Description
PicturesAndParts | Picture and parts shown.
PartsOnly | Parts shown only.
PicturesOnly | Picture shown only.
None | No template name option provided.

See Also

Mincom.LinkOne.Dom.Attributes Namespace


Mincom.LinkOne.Dom.EmbeddedObjects Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.Dom.EmbeddedObjects Namespace
Send Feedback
The Mincom.LinkOne.Dom.EmbeddedObjects namespace contains classes that provide access to objects embedded in LinkOne content.

Classes

Class | Description
DataObject | An embedded file within a Page.
EmbeddedFile | A file embedded within a page of a Book.
EmbeddedObjectCollection | Represents a collection of embedded objects that can be individually accessed by index.
EmbeddedUrlFilter | An Embedded URL Filter.
EmbeddedWebLogOn | Represents an Embedded Web Log On resource.
EmbeddedWebsiteLink | A website link embedded within a page of the book Book.

Interfaces

Interface | Description
IDataObject | A container for embedded objects.
IEmbeddedObject | Represents an embedded object.
IEmbeddedObjectCollection | Represents a collection of embedded objects that can be individually accessed by index.


DataObject Class

[image]

LinkOne WebView API
DataObject Class
Members See Also Send Feedback
An embedded file within a Page.

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class DataObject : IDataObject
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class DataObject _
    Implements IDataObject
Visual C++
[SerializableAttribute]
public ref class DataObject sealed : IDataObject

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.EmbeddedObjects..::.DataObject

See Also

DataObject Members
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


DataObject Members

[image] [image]

LinkOne WebView API
DataObject Members
DataObject Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The DataObject type exposes the following members.

Constructors

Name | Description
DataObject | Initializes a new instance of the DataObject class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IsClickedLinkAllowed | Determines whether the given url can be navigated to.
IsUrlAllowed | Determines whether the url matches any of the listed url filters in the DataObject.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
EmbeddedObjects | Gets the collection of embedded objects.
MasterFile | Gets the master file of the object.

Explicit Interface Implementations

Name | Description
IDataObject..::.EmbeddedObjects |
IDataObject..::.MasterFile |

See Also

DataObject Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


DataObject Constructor

[image]

LinkOne WebView API
DataObject Constructor
DataObject Class See Also Send Feedback
Initializes a new instance of the DataObject class.

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public DataObject(
    IDomReader domReader
)
Visual Basic (Declaration)
Public Sub New ( _
    domReader As IDomReader _
)
Visual C++
public:
DataObject(
    IDomReader^ domReader
)

Parameters

domReader
Type: IDomReader
The DOM reader to initialize from.

See Also

DataObject Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


DataObject Methods

[image] [image]

LinkOne WebView API
DataObject Methods
DataObject Class See Also Send Feedback

The DataObject type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IsClickedLinkAllowed | Determines whether the given url can be navigated to.
IsUrlAllowed | Determines whether the url matches any of the listed url filters in the DataObject.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DataObject Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


IsClickedLinkAllowed Method

[image]

LinkOne WebView API
DataObject..::.IsClickedLinkAllowed Method
DataObject Class See Also Send Feedback
Determines whether the given url can be navigated to.

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsClickedLinkAllowed(
    Uri url
)
Visual Basic (Declaration)
Public Function IsClickedLinkAllowed ( _
    url As Uri _
) As Boolean
Visual C++
public:
bool IsClickedLinkAllowed(
    Uri^ url
)

Parameters

url
Type: System..::.Uri
The target address.

Return Value

true if access is allowed; otherwise, false.

Remarks

This is determined by comparing the target address with the list of URL filters present in the page.

See Also

DataObject Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


IsUrlAllowed Method

[image]

LinkOne WebView API
DataObject..::.IsUrlAllowed Method
DataObject Class See Also Send Feedback
Determines whether the url matches any of the listed url filters in the DataObject.

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsUrlAllowed(
    Uri url
)
Visual Basic (Declaration)
Public Function IsUrlAllowed ( _
    url As Uri _
) As Boolean
Visual C++
public:
bool IsUrlAllowed(
    Uri^ url
)

Parameters

url
Type: System..::.Uri
The target url.

Return Value

true if the match is found; otherwise, false.

See Also

DataObject Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


DataObject Properties

[image] [image]

LinkOne WebView API
DataObject Properties
DataObject Class See Also Send Feedback

The DataObject type exposes the following members.

Properties

Name | Description
EmbeddedObjects | Gets the collection of embedded objects.
MasterFile | Gets the master file of the object.

Explicit Interface Implementations

Name | Description
IDataObject..::.EmbeddedObjects |
IDataObject..::.MasterFile |

See Also

DataObject Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


EmbeddedObjects Property

[image]

LinkOne WebView API
DataObject..::.EmbeddedObjects Property
DataObject Class See Also Send Feedback
Gets the collection of embedded objects.

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public EmbeddedObjectCollection EmbeddedObjects { get; }
Visual Basic (Declaration)
Public ReadOnly Property EmbeddedObjects As EmbeddedObjectCollection
Visual C++
public:
property EmbeddedObjectCollection^ EmbeddedObjects {
    EmbeddedObjectCollection^ get ();
}

See Also

DataObject Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


IDataObject.EmbeddedObjects Property

[image]

LinkOne WebView API
DataObject..::.IDataObject..::.EmbeddedObjects Property
DataObject Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEmbeddedObjectCollection IDataObject.EmbeddedObjects { get; }
Visual Basic (Declaration)
Private ReadOnly Property EmbeddedObjects As IEmbeddedObjectCollection
    Implements IDataObject.EmbeddedObjects
Visual C++
private:
virtual property IEmbeddedObjectCollection^ EmbeddedObjects {
    IEmbeddedObjectCollection^ get () sealed = IDataObject::EmbeddedObjects::get;
}

Implements

IDataObject..::.EmbeddedObjects

See Also

DataObject Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


IDataObject.MasterFile Property

[image]

LinkOne WebView API
DataObject..::.IDataObject..::.MasterFile Property
DataObject Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEmbeddedObject IDataObject.MasterFile { get; }
Visual Basic (Declaration)
Private ReadOnly Property MasterFile As IEmbeddedObject
    Implements IDataObject.MasterFile
Visual C++
private:
virtual property IEmbeddedObject^ MasterFile {
    IEmbeddedObject^ get () sealed = IDataObject::MasterFile::get;
}

Implements

IDataObject..::.MasterFile

See Also

DataObject Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


MasterFile Property

[image]

LinkOne WebView API
DataObject..::.MasterFile Property
DataObject Class See Also Send Feedback
Gets the master file of the object.

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public EmbeddedFile MasterFile { get; }
Visual Basic (Declaration)
Public ReadOnly Property MasterFile As EmbeddedFile
Visual C++
public:
property EmbeddedFile^ MasterFile {
    EmbeddedFile^ get ();
}

See Also

DataObject Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


EmbeddedFile Class

[image]

LinkOne WebView API
EmbeddedFile Class
Members See Also Send Feedback
A file embedded within a page of a Book.

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class EmbeddedFile : IEmbeddedObject
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class EmbeddedFile _
    Implements IEmbeddedObject
Visual C++
[SerializableAttribute]
public ref class EmbeddedFile sealed : IEmbeddedObject

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.EmbeddedObjects..::.EmbeddedFile

See Also

EmbeddedFile Members
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


EmbeddedFile Members

[image] [image]

LinkOne WebView API
EmbeddedFile Members
EmbeddedFile Class Constructors Methods Properties See Also Send Feedback

The EmbeddedFile type exposes the following members.

Constructors

Name | Description
EmbeddedFile | Construct an EmbeddedFile from an IDomReader

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NormalizeFilePath | Embedded files may be referenced via a Windows path, with the "\" separator or as a URL with the "/" separator. Because the embedded file path is used to locate the file (in a database), we need to ensure that all separator characters in the path are consistent.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
EmbeddedFileName | Get or sets the name of the embedded file.
Name | Gets or sets the name of the original source file.
Type | See Type for more information.

See Also

EmbeddedFile Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


EmbeddedFile Constructor

[image]

LinkOne WebView API
EmbeddedFile Constructor
EmbeddedFile Class See Also Send Feedback
Construct an EmbeddedFile from an IDomReader

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public EmbeddedFile(
    IDomReader domReader
)
Visual Basic (Declaration)
Public Sub New ( _
    domReader As IDomReader _
)
Visual C++
public:
EmbeddedFile(
    IDomReader^ domReader
)

Parameters

domReader
Type: IDomReader

See Also

EmbeddedFile Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


EmbeddedFile Methods

[image] [image]

LinkOne WebView API
EmbeddedFile Methods
EmbeddedFile Class See Also Send Feedback

The EmbeddedFile type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NormalizeFilePath | Embedded files may be referenced via a Windows path, with the "\" separator or as a URL with the "/" separator. Because the embedded file path is used to locate the file (in a database), we need to ensure that all separator characters in the path are consistent.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EmbeddedFile Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


NormalizeFilePath Method

[image]

LinkOne WebView API
EmbeddedFile..::.NormalizeFilePath Method
EmbeddedFile Class See Also Send Feedback
Embedded files may be referenced via a Windows path, with the "\" separator or as a URL with the "/" separator. Because the embedded file path is used to locate the file (in a database), we need to ensure that all separator characters in the path are consistent.

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static string NormalizeFilePath(
    string embeddedFilePath
)
Visual Basic (Declaration)
Public Shared Function NormalizeFilePath ( _
    embeddedFilePath As String _
) As String
Visual C++
public:
static String^ NormalizeFilePath(
    String^ embeddedFilePath
)

Parameters

embeddedFilePath
Type: System..::.String
The embedded file path to normalize.

Return Value

A file path with all \ replaced by /

See Also

EmbeddedFile Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


EmbeddedFile Properties

[image] [image]

LinkOne WebView API
EmbeddedFile Properties
EmbeddedFile Class See Also Send Feedback

The EmbeddedFile type exposes the following members.

Properties

Name | Description
EmbeddedFileName | Get or sets the name of the embedded file.
Name | Gets or sets the name of the original source file.
Type | See Type for more information.

See Also

EmbeddedFile Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


EmbeddedFileName Property

[image]

LinkOne WebView API
EmbeddedFile..::.EmbeddedFileName Property
EmbeddedFile Class See Also Send Feedback
Get or sets the name of the embedded file.

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string EmbeddedFileName { get; }
Visual Basic (Declaration)
Public ReadOnly Property EmbeddedFileName As String
Visual C++
public:
property String^ EmbeddedFileName {
    String^ get ();
}

See Also

EmbeddedFile Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


Name Property

[image]

LinkOne WebView API
EmbeddedFile..::.Name Property
EmbeddedFile Class See Also Send Feedback
Gets or sets the name of the original source file.

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

EmbeddedFile Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


Type Property

[image]

LinkOne WebView API
EmbeddedFile..::.Type Property
EmbeddedFile Class See Also Send Feedback
See Type for more information.

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As String
Visual C++
public:
virtual property String^ Type {
    String^ get () sealed;
}

Implements

IEmbeddedObject..::.Type

See Also

EmbeddedFile Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


EmbeddedObjectCollection Class

[image]

LinkOne WebView API
EmbeddedObjectCollection Class
Members See Also Send Feedback
Represents a collection of embedded objects that can be individually accessed by index.

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class EmbeddedObjectCollection : ReadOnlyList<IEmbeddedObject>,
    IEmbeddedObjectCollection, IReadOnlyList<IEmbeddedObject>, IReadOnlyCollection<IEmbeddedObject>,
    IEnumerable<IEmbeddedObject>, IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class EmbeddedObjectCollection _
    Inherits ReadOnlyList(Of IEmbeddedObject) _
    Implements IEmbeddedObjectCollection, IReadOnlyList(Of IEmbeddedObject),  _
    IReadOnlyCollection(Of IEmbeddedObject), IEnumerable(Of IEmbeddedObject), IEnumerable
Visual C++
[SerializableAttribute]
public ref class EmbeddedObjectCollection sealed : public ReadOnlyList<IEmbeddedObject^>,
    IEmbeddedObjectCollection, IReadOnlyList<IEmbeddedObject^>, IReadOnlyCollection<IEmbeddedObject^>,
    IEnumerable<IEmbeddedObject^>, IEnumerable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.ReadOnlyList <(Of <( IEmbeddedObject >)>)
Mincom.LinkOne.Dom.EmbeddedObjects..::.EmbeddedObjectCollection

See Also

EmbeddedObjectCollection Members
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


EmbeddedObjectCollection Members

[image] [image]

LinkOne WebView API
EmbeddedObjectCollection Members
EmbeddedObjectCollection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The EmbeddedObjectCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given object. (Inherited from ReadOnlyList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
InnerList | Gets the inner list. (Inherited from ReadOnlyList<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from ReadOnlyList<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(T>)>).)

See Also

EmbeddedObjectCollection Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


EmbeddedObjectCollection Methods

[image] [image]

LinkOne WebView API
EmbeddedObjectCollection Methods
EmbeddedObjectCollection Class See Also Send Feedback

The EmbeddedObjectCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given object. (Inherited from ReadOnlyList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(T>)>).)

See Also

EmbeddedObjectCollection Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


EmbeddedObjectCollection Properties

[image] [image]

LinkOne WebView API
EmbeddedObjectCollection Properties
EmbeddedObjectCollection Class See Also Send Feedback

The EmbeddedObjectCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
InnerList | Gets the inner list. (Inherited from ReadOnlyList<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from ReadOnlyList<(Of <(T>)>).)

See Also

EmbeddedObjectCollection Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


EmbeddedUrlFilter Class

[image]

LinkOne WebView API
EmbeddedUrlFilter Class
Members See Also Send Feedback
An Embedded URL Filter.

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class EmbeddedUrlFilter : IEmbeddedObject
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class EmbeddedUrlFilter _
    Implements IEmbeddedObject
Visual C++
[SerializableAttribute]
public ref class EmbeddedUrlFilter sealed : IEmbeddedObject

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.EmbeddedObjects..::.EmbeddedUrlFilter

See Also

EmbeddedUrlFilter Members
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


EmbeddedUrlFilter Members

[image] [image]

LinkOne WebView API
EmbeddedUrlFilter Members
EmbeddedUrlFilter Class Constructors Methods Properties See Also Send Feedback

The EmbeddedUrlFilter type exposes the following members.

Constructors

Name | Description
EmbeddedUrlFilter | Construct an EmbeddedUrlFilter from an IDomReader

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Type | See Type for more information.
Url | Gets or sets the URL of the filter.

See Also

EmbeddedUrlFilter Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


EmbeddedUrlFilter Constructor

[image]

LinkOne WebView API
EmbeddedUrlFilter Constructor
EmbeddedUrlFilter Class See Also Send Feedback
Construct an EmbeddedUrlFilter from an IDomReader

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public EmbeddedUrlFilter(
    IDomReader domReader
)
Visual Basic (Declaration)
Public Sub New ( _
    domReader As IDomReader _
)
Visual C++
public:
EmbeddedUrlFilter(
    IDomReader^ domReader
)

Parameters

domReader
Type: IDomReader

See Also

EmbeddedUrlFilter Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


EmbeddedUrlFilter Methods

[image] [image]

LinkOne WebView API
EmbeddedUrlFilter Methods
EmbeddedUrlFilter Class See Also Send Feedback

The EmbeddedUrlFilter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EmbeddedUrlFilter Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


EmbeddedUrlFilter Properties

[image] [image]

LinkOne WebView API
EmbeddedUrlFilter Properties
EmbeddedUrlFilter Class See Also Send Feedback

The EmbeddedUrlFilter type exposes the following members.

Properties

Name | Description
Type | See Type for more information.
Url | Gets or sets the URL of the filter.

See Also

EmbeddedUrlFilter Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


Type Property

[image]

LinkOne WebView API
EmbeddedUrlFilter..::.Type Property
EmbeddedUrlFilter Class See Also Send Feedback
See Type for more information.

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As String
Visual C++
public:
virtual property String^ Type {
    String^ get () sealed;
}

Implements

IEmbeddedObject..::.Type

See Also

EmbeddedUrlFilter Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


Url Property

[image]

LinkOne WebView API
EmbeddedUrlFilter..::.Url Property
EmbeddedUrlFilter Class See Also Send Feedback
Gets or sets the URL of the filter.

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Url { get; }
Visual Basic (Declaration)
Public ReadOnly Property Url As String
Visual C++
public:
property String^ Url {
    String^ get ();
}

See Also

EmbeddedUrlFilter Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


EmbeddedWebLogOn Class

[image]

LinkOne WebView API
EmbeddedWebLogOn Class
Members See Also Send Feedback
Represents an Embedded Web Log On resource.

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class EmbeddedWebLogOn : IEmbeddedObject
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class EmbeddedWebLogOn _
    Implements IEmbeddedObject
Visual C++
[SerializableAttribute]
public ref class EmbeddedWebLogOn sealed : IEmbeddedObject

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.EmbeddedObjects..::.EmbeddedWebLogOn

See Also

EmbeddedWebLogOn Members
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


EmbeddedWebLogOn Members

[image] [image]

LinkOne WebView API
EmbeddedWebLogOn Members
EmbeddedWebLogOn Class Constructors Methods Properties See Also Send Feedback

The EmbeddedWebLogOn type exposes the following members.

Constructors

Name | Description
EmbeddedWebLogOn | Constructor.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Type | Get the Type.
Url | Gets the Url of the log on.

See Also

EmbeddedWebLogOn Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


EmbeddedWebLogOn Constructor

[image]

LinkOne WebView API
EmbeddedWebLogOn Constructor
EmbeddedWebLogOn Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public EmbeddedWebLogOn(
    IDomReader domReader
)
Visual Basic (Declaration)
Public Sub New ( _
    domReader As IDomReader _
)
Visual C++
public:
EmbeddedWebLogOn(
    IDomReader^ domReader
)

Parameters

domReader
Type: IDomReader

See Also

EmbeddedWebLogOn Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


EmbeddedWebLogOn Methods

[image] [image]

LinkOne WebView API
EmbeddedWebLogOn Methods
EmbeddedWebLogOn Class See Also Send Feedback

The EmbeddedWebLogOn type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EmbeddedWebLogOn Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


EmbeddedWebLogOn Properties

[image] [image]

LinkOne WebView API
EmbeddedWebLogOn Properties
EmbeddedWebLogOn Class See Also Send Feedback

The EmbeddedWebLogOn type exposes the following members.

Properties

Name | Description
Type | Get the Type.
Url | Gets the Url of the log on.

See Also

EmbeddedWebLogOn Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


Type Property

[image]

LinkOne WebView API
EmbeddedWebLogOn..::.Type Property
EmbeddedWebLogOn Class See Also Send Feedback
Get the Type.

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As String
Visual C++
public:
virtual property String^ Type {
    String^ get () sealed;
}

Implements

IEmbeddedObject..::.Type

See Also

EmbeddedWebLogOn Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


Url Property

[image]

LinkOne WebView API
EmbeddedWebLogOn..::.Url Property
EmbeddedWebLogOn Class See Also Send Feedback
Gets the Url of the log on.

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Url { get; }
Visual Basic (Declaration)
Public ReadOnly Property Url As String
Visual C++
public:
property String^ Url {
    String^ get ();
}

See Also

EmbeddedWebLogOn Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


EmbeddedWebsiteLink Class

[image]

LinkOne WebView API
EmbeddedWebsiteLink Class
Members See Also Send Feedback
A website link embedded within a page of the book Book.

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class EmbeddedWebsiteLink : IEmbeddedObject
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class EmbeddedWebsiteLink _
    Implements IEmbeddedObject
Visual C++
[SerializableAttribute]
public ref class EmbeddedWebsiteLink sealed : IEmbeddedObject

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.EmbeddedObjects..::.EmbeddedWebsiteLink

See Also

EmbeddedWebsiteLink Members
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


EmbeddedWebsiteLink Members

[image] [image]

LinkOne WebView API
EmbeddedWebsiteLink Members
EmbeddedWebsiteLink Class Constructors Methods Properties See Also Send Feedback

The EmbeddedWebsiteLink type exposes the following members.

Constructors

Name | Description
EmbeddedWebsiteLink | Construct an EmbeddedWebsiteLink from an IDomReader

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Type | See Type for more information.
Url | Gets the URL of the website.

See Also

EmbeddedWebsiteLink Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


EmbeddedWebsiteLink Constructor

[image]

LinkOne WebView API
EmbeddedWebsiteLink Constructor
EmbeddedWebsiteLink Class See Also Send Feedback
Construct an EmbeddedWebsiteLink from an IDomReader

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public EmbeddedWebsiteLink(
    IDomReader domReader
)
Visual Basic (Declaration)
Public Sub New ( _
    domReader As IDomReader _
)
Visual C++
public:
EmbeddedWebsiteLink(
    IDomReader^ domReader
)

Parameters

domReader
Type: IDomReader

See Also

EmbeddedWebsiteLink Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


EmbeddedWebsiteLink Methods

[image] [image]

LinkOne WebView API
EmbeddedWebsiteLink Methods
EmbeddedWebsiteLink Class See Also Send Feedback

The EmbeddedWebsiteLink type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EmbeddedWebsiteLink Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


EmbeddedWebsiteLink Properties

[image] [image]

LinkOne WebView API
EmbeddedWebsiteLink Properties
EmbeddedWebsiteLink Class See Also Send Feedback

The EmbeddedWebsiteLink type exposes the following members.

Properties

Name | Description
Type | See Type for more information.
Url | Gets the URL of the website.

See Also

EmbeddedWebsiteLink Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


Type Property

[image]

LinkOne WebView API
EmbeddedWebsiteLink..::.Type Property
EmbeddedWebsiteLink Class See Also Send Feedback
See Type for more information.

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As String
Visual C++
public:
virtual property String^ Type {
    String^ get () sealed;
}

Implements

IEmbeddedObject..::.Type

See Also

EmbeddedWebsiteLink Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


Url Property

[image]

LinkOne WebView API
EmbeddedWebsiteLink..::.Url Property
EmbeddedWebsiteLink Class See Also Send Feedback
Gets the URL of the website.

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Url { get; }
Visual Basic (Declaration)
Public ReadOnly Property Url As String
Visual C++
public:
property String^ Url {
    String^ get ();
}

See Also

EmbeddedWebsiteLink Class
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


IDataObject Interface

[image]

LinkOne WebView API
IDataObject Interface
Members See Also Send Feedback
A container for embedded objects.

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IDataObject
Visual Basic (Declaration)
Public Interface IDataObject
Visual C++
public interface class IDataObject

See Also

IDataObject Members
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


IDataObject Members

[image] [image]

LinkOne WebView API
IDataObject Members
IDataObject Interface Properties See Also Send Feedback

The IDataObject type exposes the following members.

Properties

Name | Description
EmbeddedObjects | Gets the embedded objects.
MasterFile | Gets the master file.

See Also

IDataObject Interface
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


IDataObject Properties

[image] [image]

LinkOne WebView API
IDataObject Properties
IDataObject Interface See Also Send Feedback

The IDataObject type exposes the following members.

Properties

Name | Description
EmbeddedObjects | Gets the embedded objects.
MasterFile | Gets the master file.

See Also

IDataObject Interface
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


EmbeddedObjects Property

[image]

LinkOne WebView API
IDataObject..::.EmbeddedObjects Property
IDataObject Interface See Also Send Feedback
Gets the embedded objects.

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEmbeddedObjectCollection EmbeddedObjects { get; }
Visual Basic (Declaration)
ReadOnly Property EmbeddedObjects As IEmbeddedObjectCollection
Visual C++
property IEmbeddedObjectCollection^ EmbeddedObjects {
    IEmbeddedObjectCollection^ get ();
}

See Also

IDataObject Interface
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


MasterFile Property

[image]

LinkOne WebView API
IDataObject..::.MasterFile Property
IDataObject Interface See Also Send Feedback
Gets the master file.

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEmbeddedObject MasterFile { get; }
Visual Basic (Declaration)
ReadOnly Property MasterFile As IEmbeddedObject
Visual C++
property IEmbeddedObject^ MasterFile {
    IEmbeddedObject^ get ();
}

See Also

IDataObject Interface
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


IEmbeddedObject Interface

[image]

LinkOne WebView API
IEmbeddedObject Interface
Members See Also Send Feedback
Represents an embedded object.

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IEmbeddedObject
Visual Basic (Declaration)
Public Interface IEmbeddedObject
Visual C++
public interface class IEmbeddedObject

See Also

IEmbeddedObject Members
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


IEmbeddedObject Members

[image] [image]

LinkOne WebView API
IEmbeddedObject Members
IEmbeddedObject Interface Properties See Also Send Feedback

The IEmbeddedObject type exposes the following members.

Properties

Name | Description
Type | Gets a value that describes what the embedded object is.

See Also

IEmbeddedObject Interface
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


IEmbeddedObject Properties

[image] [image]

LinkOne WebView API
IEmbeddedObject Properties
IEmbeddedObject Interface See Also Send Feedback

The IEmbeddedObject type exposes the following members.

Properties

Name | Description
Type | Gets a value that describes what the embedded object is.

See Also

IEmbeddedObject Interface
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


Type Property

[image]

LinkOne WebView API
IEmbeddedObject..::.Type Property
IEmbeddedObject Interface See Also Send Feedback
Gets a value that describes what the embedded object is.

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Type { get; }
Visual Basic (Declaration)
ReadOnly Property Type As String
Visual C++
property String^ Type {
    String^ get ();
}

See Also

IEmbeddedObject Interface
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


IEmbeddedObjectCollection Interface

[image]

LinkOne WebView API
IEmbeddedObjectCollection Interface
Members See Also Send Feedback
Represents a collection of embedded objects that can be individually accessed by index.

Namespace: Mincom.LinkOne.Dom.EmbeddedObjects
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IEmbeddedObjectCollection : IReadOnlyList<IEmbeddedObject>,
    IReadOnlyCollection<IEmbeddedObject>, IEnumerable<IEmbeddedObject>, IEnumerable
Visual Basic (Declaration)
Public Interface IEmbeddedObjectCollection _
    Implements IReadOnlyList(Of IEmbeddedObject), IReadOnlyCollection(Of IEmbeddedObject),  _
    IEnumerable(Of IEmbeddedObject), IEnumerable
Visual C++
public interface class IEmbeddedObjectCollection : IReadOnlyList<IEmbeddedObject^>,
    IReadOnlyCollection<IEmbeddedObject^>, IEnumerable<IEmbeddedObject^>, IEnumerable

See Also

IEmbeddedObjectCollection Members
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


IEmbeddedObjectCollection Members

[image] [image]

LinkOne WebView API
IEmbeddedObjectCollection Members
IEmbeddedObjectCollection Interface Methods Properties See Also Send Feedback

The IEmbeddedObjectCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
GetEnumerator | Overloaded.
IndexOf | Searches the collection and returns the zero-based index of the first occurrence of the given item. (Inherited from IReadOnlyList<(Of <(T>)>).)

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from IReadOnlyList<(Of <(T>)>).)

See Also

IEmbeddedObjectCollection Interface
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


IEmbeddedObjectCollection Methods

[image] [image]

LinkOne WebView API
IEmbeddedObjectCollection Methods
IEmbeddedObjectCollection Interface See Also Send Feedback

The IEmbeddedObjectCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
GetEnumerator | Overloaded.
IndexOf | Searches the collection and returns the zero-based index of the first occurrence of the given item. (Inherited from IReadOnlyList<(Of <(T>)>).)

See Also

IEmbeddedObjectCollection Interface
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
IEmbeddedObjectCollection..::.GetEnumerator Method
IEmbeddedObjectCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( IEmbeddedObject >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IEmbeddedObjectCollection Interface
IEmbeddedObjectCollection Members
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


IEmbeddedObjectCollection Properties

[image] [image]

LinkOne WebView API
IEmbeddedObjectCollection Properties
IEmbeddedObjectCollection Interface See Also Send Feedback

The IEmbeddedObjectCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from IReadOnlyList<(Of <(T>)>).)

See Also

IEmbeddedObjectCollection Interface
Mincom.LinkOne.Dom.EmbeddedObjects Namespace


Mincom.LinkOne.Dom.Filtering Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.Dom.Filtering Namespace
Send Feedback
The Mincom.LinkOne.Dom.Filtering namespace contains classes that provide functionality for filtering LinkOne content.

Classes

Class | Description
Filter | An Filter value for an Option.
FilterCollection | Represents filters for a LinkOne book, indexed by Name.
Option | Defines the abstract base class for a LinkOne option.
OptionCollection | Represents options associated with content that can be filtered. Options can be individually accessed by index.
OptionDefinition | The base class for a LinkOne Option Definition.
OptionDefinitionCollection | Represents a collection of OptionDefinition objects keyed on Code.
RangeOption | Represents a LinkOne Range Option.
RangeOptionDefinition | Represents the Option Definition for a LinkOne Range Option.
ReadOnlyFilterCollection | Represents a collection of filters that cannot be modified.
SelectOption | Represents a LinkOne Select Option.
SelectOptionDefinition | Represents the Option Definition for a LinkOne Select option.
SwitchOption | Represents a LinkOne Switch Option.
SwitchOptionDefinition | Represents the Option Definition for a LinkOne Select option.

Interfaces

Interface | Description
IFilter | A filter for matching options.
IFilterable | Implemented by classes that can be filtered via an option filter.
IFilterCollection | Represents filters for a LinkOne book, indexed by Name.
IOption | Represents an option that can be used to filter content in a LinkOne book.
IOptionCollection | Represents options associated with content that can be filtered. Options can be individually accessed by index.
IOptionDefinition | Defines a value for an option.
IOptionDefinitionCollection | Represents the allowed values for an option, indexed by Code.

Enumerations

Enumeration | Description
FilterAccess | The visibility of a filter.
FilterScope | Specifies the scope of a filter.
FilterType | The enumeration of types of IFilter.


Filter Class

[image]

LinkOne WebView API
Filter Class
Members See Also Send Feedback
An Filter value for an Option.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class Filter : IFilter
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class Filter _
    Implements IFilter
Visual C++
[SerializableAttribute]
public ref class Filter sealed : IFilter

Remarks

Option values may be temporary or permanent.

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Filtering..::.Filter

See Also

Filter Members
Mincom.LinkOne.Dom.Filtering Namespace


Filter Members

[image] [image]

LinkOne WebView API
Filter Members
Filter Class Constructors Methods Properties See Also Send Feedback

The Filter type exposes the following members.

Constructors

Name | Description
Filter | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overriden. Returns a string representation of the filter. (Overrides Object..::.ToString()()().)

Properties

Name | Description
Access | Gets the filter access.
Name | Gets the option filter name.
Scope | Gets the filter scope.
Type | Gets the filter type.
Value | Gets and sets the filter value.

See Also

Filter Class
Mincom.LinkOne.Dom.Filtering Namespace


Filter Constructor

[image] [image]

LinkOne WebView API
Filter Constructor
Filter Class See Also Send Feedback

Overload List

Name | Description
Filter(IOptionValueReader) | Initialises a new instance of the Filter class from a Reader object.
Filter(String) | Initializes a new instance of the Filter class.
Filter(String, String, FilterType, FilterScope, FilterAccess) | Initializes a new instance of the Filter class.

See Also

Filter Class
Filter Members
Mincom.LinkOne.Dom.Filtering Namespace


Filter Constructor ()

[image]

LinkOne WebView API
Filter Constructor ()
Filter Class See Also Send Feedback
Initialises a new instance of the Filter class from a Reader object.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Filter(
    IOptionValueReader domReader
)
Visual Basic (Declaration)
Public Sub New ( _
    domReader As IOptionValueReader _
)
Visual C++
public:
Filter(
    IOptionValueReader^ domReader
)

Parameters

domReader
Type: IOptionValueReader
The Reader providing the data to populate this object.

See Also

Filter Class
Filter Overload
Mincom.LinkOne.Dom.Filtering Namespace


Filter Constructor (String)

[image]

LinkOne WebView API
Filter Constructor (String)
Filter Class See Also Send Feedback
Initializes a new instance of the Filter class.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Filter(
    string filter
)
Visual Basic (Declaration)
Public Sub New ( _
    filter As String _
)
Visual C++
public:
Filter(
    String^ filter
)

Parameters

filter
Type: System..::.String
A string representation of a filter generated from ToString().

See Also

Filter Class
Filter Overload
Mincom.LinkOne.Dom.Filtering Namespace


Filter Constructor (String, String, FilterType, FilterScope, FilterAccess)

[image]

LinkOne WebView API
Filter Constructor (String, String, FilterType, FilterScope, FilterAccess)
Filter Class See Also Send Feedback
Initializes a new instance of the Filter class.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Filter(
    string name,
    string value,
    FilterType type,
    FilterScope scope,
    FilterAccess access
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    value As String, _
    type As FilterType, _
    scope As FilterScope, _
    access As FilterAccess _
)
Visual C++
public:
Filter(
    String^ name,
    String^ value,
    FilterType type,
    FilterScope scope,
    FilterAccess access
)

Parameters

name
Type: System..::.String
The Name for the Filter
value
Type: System..::.String
The Value for the Filter
type
Type: Mincom.LinkOne.Dom.Filtering..::.FilterType
The Type of the Filter
scope
Type: Mincom.LinkOne.Dom.Filtering..::.FilterScope
The Scope of the Filter
access
Type: Mincom.LinkOne.Dom.Filtering..::.FilterAccess
The Access of the Filter

See Also

Filter Class
Filter Overload
Mincom.LinkOne.Dom.Filtering Namespace


Filter Methods

[image] [image]

LinkOne WebView API
Filter Methods
Filter Class See Also Send Feedback

The Filter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overriden. Returns a string representation of the filter. (Overrides Object..::.ToString()()().)

See Also

Filter Class
Mincom.LinkOne.Dom.Filtering Namespace


ToString Method

[image]

LinkOne WebView API
Filter..::.ToString Method
Filter Class See Also Send Feedback
Overriden. Returns a string representation of the filter.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A string representation of the filter.

Remarks

The format is in FilterName:FilterValue:FilterType:FilterScope:FilterAccess

See Also

Filter Class
Mincom.LinkOne.Dom.Filtering Namespace


Filter Properties

[image] [image]

LinkOne WebView API
Filter Properties
Filter Class See Also Send Feedback

The Filter type exposes the following members.

Properties

Name | Description
Access | Gets the filter access.
Name | Gets the option filter name.
Scope | Gets the filter scope.
Type | Gets the filter type.
Value | Gets and sets the filter value.

See Also

Filter Class
Mincom.LinkOne.Dom.Filtering Namespace


Access Property

[image]

LinkOne WebView API
Filter..::.Access Property
Filter Class See Also Send Feedback
Gets the filter access.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public FilterAccess Access { get; }
Visual Basic (Declaration)
Public ReadOnly Property Access As FilterAccess
Visual C++
public:
virtual property FilterAccess Access {
    FilterAccess get () sealed;
}

Field Value

The access of the filter.

Implements

IFilter..::.Access

See Also

Filter Class
Mincom.LinkOne.Dom.Filtering Namespace


Name Property

[image]

LinkOne WebView API
Filter..::.Name Property
Filter Class See Also Send Feedback
Gets the option filter name.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
}

Implements

IFilter..::.Name

See Also

Filter Class
Mincom.LinkOne.Dom.Filtering Namespace


Scope Property

[image]

LinkOne WebView API
Filter..::.Scope Property
Filter Class See Also Send Feedback
Gets the filter scope.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public FilterScope Scope { get; }
Visual Basic (Declaration)
Public ReadOnly Property Scope As FilterScope
Visual C++
public:
virtual property FilterScope Scope {
    FilterScope get () sealed;
}

Field Value

The scope of the filter.

Implements

IFilter..::.Scope

See Also

Filter Class
Mincom.LinkOne.Dom.Filtering Namespace


Type Property

[image]

LinkOne WebView API
Filter..::.Type Property
Filter Class See Also Send Feedback
Gets the filter type.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public FilterType Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As FilterType
Visual C++
public:
virtual property FilterType Type {
    FilterType get () sealed;
}

Field Value

The type of the filter.

Implements

IFilter..::.Type

See Also

Filter Class
Mincom.LinkOne.Dom.Filtering Namespace


Value Property

[image]

LinkOne WebView API
Filter..::.Value Property
Filter Class See Also Send Feedback
Gets and sets the filter value.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String
Visual C++
public:
virtual property String^ Value {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IFilter..::.Value

See Also

Filter Class
Mincom.LinkOne.Dom.Filtering Namespace


FilterAccess Enumeration

[image]

LinkOne WebView API
FilterAccess Enumeration
See Also Send Feedback
The visibility of a filter.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum FilterAccess
Visual Basic (Declaration)
Public Enumeration FilterAccess
Visual C++
public enum class FilterAccess

Members

Member name | Description
Public | This is a public filter.
Private | This is a private filter.

See Also

Mincom.LinkOne.Dom.Filtering Namespace


FilterCollection Class

[image]

LinkOne WebView API
FilterCollection Class
Members See Also Send Feedback
Represents filters for a LinkOne book, indexed by Name.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class FilterCollection : KeyedLiveCollection<string, Filter>,
    IFilterCollection, IKeyedCollection<string, IFilter>, ICollection<IFilter>,
    IEnumerable<IFilter>, IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class FilterCollection _
    Inherits KeyedLiveCollection(Of String, Filter) _
    Implements IFilterCollection, IKeyedCollection(Of String, IFilter),  _
    ICollection(Of IFilter), IEnumerable(Of IFilter), IEnumerable
Visual C++
[SerializableAttribute]
public ref class FilterCollection sealed : public KeyedLiveCollection<String^, Filter^>,
    IFilterCollection, IKeyedCollection<String^, IFilter^>, ICollection<IFilter^>,
    IEnumerable<IFilter^>, IEnumerable

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection<(Of <( Filter >)>)
LiveCollection<(Of <( Filter >)>)
KeyedLiveCollection<(Of <(String, Filter >)>)
Mincom.LinkOne.Dom.Filtering..::.FilterCollection

See Also

FilterCollection Members
Mincom.LinkOne.Dom.Filtering Namespace


FilterCollection Members

[image] [image]

LinkOne WebView API
FilterCollection Members
FilterCollection Class Constructors Methods Properties Events Explicit Interface Implementations See Also Send Feedback

The FilterCollection type exposes the following members.

Constructors

Name | Description
FilterCollection | Overloaded.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Filter >)>).)
AsReadOnly | Gets a read-only wrapper for this FilterCollection.
BeginUpdate | Suppresses all Changed events until EndUpdate(Boolean) is called.
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Filter >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Filter >)>).)
Contains | Overloaded.
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( Filter >)>).)
Create | Adds a filter with the specified attributes.
EndUpdate | Re-enables Changed events, and also fires the Changed event if changes have occurred since BeginUpdate()()() was called.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Filter >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Filter >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Filter >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Filter >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Merge | Merges another IFilterCollection into this collection.
Remove | Overloaded.
RemoveAll | Removes all filters from the collection that are of the specified FilterType.
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Filter >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Filter >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( Filter >)>).)
ToString | Overriden. Returns a string representation of the collection. (Overrides Object..::.ToString()()().)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Filter >)>).)
IsUpdating | Gets true between BeginUpdate()()() and EndUpdate(Boolean) methods.
Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( Filter >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Filter >)>).)
LanguageOption | Gets the language code, if set, otherwise, Empty()()(). Sets the current language option.
ShowSupersededEntries | Gets or sets true to show superseded entries.
SpecificQuery | Gets or sets true if the specific query option has been set.

Events

Name | Description
Changed | Occurs when the object has changed.

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds an item to the IList. (Inherited from Collection<(Of <( Filter >)>).)
ICollection<(Of <(IFilter>)>)..::.Add |
ICollection<(Of <(IFilter>)>)..::.Clear |
IList..::.Contains | Determines whether the IList contains a specific value. (Inherited from Collection<(Of <( Filter >)>).)
IKeyedCollection<(Of <(String, IFilter>)>)..::.Contains |
ICollection<(Of <(IFilter>)>)..::.Contains |
ICollection..::.CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection<(Of <( Filter >)>).)
ICollection<(Of <(IFilter>)>)..::.CopyTo |
ICollection<(Of <(IFilter>)>)..::.Count |
IEnumerable<(Of <(IFilter>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator |
IList..::.IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection<(Of <( Filter >)>).)
IList..::.Insert | Inserts an item into the IList at the specified index. (Inherited from Collection<(Of <( Filter >)>).)
IList..::.IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection<(Of <( Filter >)>).)
IsReadOnly | Overloaded.
IList..::.IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection<(Of <( Filter >)>).)
ICollection..::.IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection<(Of <( Filter >)>).)
IList..::.Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( Filter >)>).)
IKeyedCollection<(Of <(String, IFilter>)>)..::.Item |
IList..::.Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection<(Of <( Filter >)>).)
ICollection<(Of <(IFilter>)>)..::.Remove |
ICollection..::.SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection<(Of <( Filter >)>).)

See Also

FilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


FilterCollection Constructor

[image] [image]

LinkOne WebView API
FilterCollection Constructor
FilterCollection Class See Also Send Feedback

Overload List

Name | Description
FilterCollection()()() | Initializes a new instance of the FilterCollection class.
FilterCollection(NoteCollection) | Initializes a new instance of the FilterCollection class.
FilterCollection(String) | Initializes a new instance of the FilterCollection class.
FilterCollection(NameValueCollection, FilterType, FilterScope, FilterAccess) | Initializes a new instance of the FilterCollection class.

See Also

FilterCollection Class
FilterCollection Members
Mincom.LinkOne.Dom.Filtering Namespace


FilterCollection Constructor

[image]

LinkOne WebView API
FilterCollection Constructor
FilterCollection Class See Also Send Feedback
Initializes a new instance of the FilterCollection class.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public FilterCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FilterCollection()

See Also

FilterCollection Class
FilterCollection Overload
Mincom.LinkOne.Dom.Filtering Namespace


FilterCollection Constructor (NoteCollection)

[image]

LinkOne WebView API
FilterCollection Constructor (NoteCollection)
FilterCollection Class See Also Send Feedback
Initializes a new instance of the FilterCollection class.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public FilterCollection(
    NoteCollection notes
)
Visual Basic (Declaration)
Public Sub New ( _
    notes As NoteCollection _
)
Visual C++
public:
FilterCollection(
    NoteCollection^ notes
)

Parameters

notes
Type: Mincom.LinkOne.Dom.Notes..::.NoteCollection
The notes to populate the collection with.

Remarks

Only FilterNote notes are added.

See Also

FilterCollection Class
FilterCollection Overload
Mincom.LinkOne.Dom.Filtering Namespace


FilterCollection Constructor (String)

[image]

LinkOne WebView API
FilterCollection Constructor (String)
FilterCollection Class See Also Send Feedback
Initializes a new instance of the FilterCollection class.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public FilterCollection(
    string filters
)
Visual Basic (Declaration)
Public Sub New ( _
    filters As String _
)
Visual C++
public:
FilterCollection(
    String^ filters
)

Parameters

filters
Type: System..::.String
A string representation of a FilterCollection generated from ToString()()().

See Also

FilterCollection Class
FilterCollection Overload
Mincom.LinkOne.Dom.Filtering Namespace


FilterCollection Constructor (NameValueCollection, FilterType, FilterScope, FilterAccess)

[image]

LinkOne WebView API
FilterCollection Constructor (NameValueCollection, FilterType, FilterScope, FilterAccess)
FilterCollection Class See Also Send Feedback
Initializes a new instance of the FilterCollection class.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public FilterCollection(
    NameValueCollection filters,
    FilterType filterType,
    FilterScope filterScope,
    FilterAccess filterAccess
)
Visual Basic (Declaration)
Public Sub New ( _
    filters As NameValueCollection, _
    filterType As FilterType, _
    filterScope As FilterScope, _
    filterAccess As FilterAccess _
)
Visual C++
public:
FilterCollection(
    NameValueCollection^ filters,
    FilterType filterType,
    FilterScope filterScope,
    FilterAccess filterAccess
)

Parameters

filters
Type: System.Collections.Specialized..::.NameValueCollection
A NameValueCollection containing a list of filters.
filterType
Type: Mincom.LinkOne.Dom.Filtering..::.FilterType
The Type of all filters to add.
filterScope
Type: Mincom.LinkOne.Dom.Filtering..::.FilterScope
The scope of all filters to add.
filterAccess
Type: Mincom.LinkOne.Dom.Filtering..::.FilterAccess
The access of all filters to add.

See Also

FilterCollection Class
FilterCollection Overload
Mincom.LinkOne.Dom.Filtering Namespace


FilterCollection Methods

[image] [image]

LinkOne WebView API
FilterCollection Methods
FilterCollection Class See Also Send Feedback

The FilterCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Filter >)>).)
AsReadOnly | Gets a read-only wrapper for this FilterCollection.
BeginUpdate | Suppresses all Changed events until EndUpdate(Boolean) is called.
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Filter >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Filter >)>).)
Contains | Overloaded.
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( Filter >)>).)
Create | Adds a filter with the specified attributes.
EndUpdate | Re-enables Changed events, and also fires the Changed event if changes have occurred since BeginUpdate()()() was called.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Filter >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Filter >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Filter >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Filter >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Merge | Merges another IFilterCollection into this collection.
Remove | Overloaded.
RemoveAll | Removes all filters from the collection that are of the specified FilterType.
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Filter >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Filter >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( Filter >)>).)
ToString | Overriden. Returns a string representation of the collection. (Overrides Object..::.ToString()()().)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds an item to the IList. (Inherited from Collection<(Of <( Filter >)>).)
ICollection<(Of <(IFilter>)>)..::.Add |
ICollection<(Of <(IFilter>)>)..::.Clear |
IList..::.Contains | Determines whether the IList contains a specific value. (Inherited from Collection<(Of <( Filter >)>).)
IKeyedCollection<(Of <(String, IFilter>)>)..::.Contains |
ICollection<(Of <(IFilter>)>)..::.Contains |
ICollection..::.CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection<(Of <( Filter >)>).)
ICollection<(Of <(IFilter>)>)..::.CopyTo |
IEnumerable<(Of <(IFilter>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator |
IList..::.IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection<(Of <( Filter >)>).)
IList..::.Insert | Inserts an item into the IList at the specified index. (Inherited from Collection<(Of <( Filter >)>).)
IList..::.Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection<(Of <( Filter >)>).)
ICollection<(Of <(IFilter>)>)..::.Remove |

See Also

FilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


ICollection(IFilter).Add Method

[image]

LinkOne WebView API
FilterCollection..::.ICollection<(Of <(IFilter>)>)..::.Add Method
FilterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<IFilter>.Add(
    IFilter filter
)
Visual Basic (Declaration)
Private Sub Add ( _
    filter As IFilter _
) Implements ICollection(Of IFilter).Add
Visual C++
private:
virtual void Add(
    IFilter^ filter
) sealed = ICollection<IFilter^>::Add

Parameters

filter
Type: Mincom.LinkOne.Dom.Filtering..::.IFilter

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

FilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


ICollection(IFilter).Clear Method

[image]

LinkOne WebView API
FilterCollection..::.ICollection<(Of <(IFilter>)>)..::.Clear Method
FilterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<IFilter>.Clear()
Visual Basic (Declaration)
Private Sub Clear Implements ICollection(Of IFilter).Clear
Visual C++
private:
virtual void Clear() sealed = ICollection<IFilter^>::Clear

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

See Also

FilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


ICollection(IFilter).Contains Method

[image]

LinkOne WebView API
FilterCollection..::.ICollection<(Of <(IFilter>)>)..::.Contains Method
FilterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<IFilter>.Contains(
    IFilter filter
)
Visual Basic (Declaration)
Private Function Contains ( _
    filter As IFilter _
) As Boolean Implements ICollection(Of IFilter).Contains
Visual C++
private:
virtual bool Contains(
    IFilter^ filter
) sealed = ICollection<IFilter^>::Contains

Parameters

filter
Type: Mincom.LinkOne.Dom.Filtering..::.IFilter

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

FilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


ICollection(IFilter).CopyTo Method

[image]

LinkOne WebView API
FilterCollection..::.ICollection<(Of <(IFilter>)>)..::.CopyTo Method
FilterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<IFilter>.CopyTo(
    IFilter[] array,
    int arrayIndex
)
Visual Basic (Declaration)
Private Sub CopyTo ( _
    array As IFilter(), _
    arrayIndex As Integer _
) Implements ICollection(Of IFilter).CopyTo
Visual C++
private:
virtual void CopyTo(
    array<IFilter^>^ array,
    int arrayIndex
) sealed = ICollection<IFilter^>::CopyTo

Parameters

array
Type: array< Mincom.LinkOne.Dom.Filtering..::.IFilter >[]()[]
arrayIndex
Type: System..::.Int32

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

FilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


IEnumerable(IFilter).GetEnumerator Method

[image]

LinkOne WebView API
FilterCollection..::.IEnumerable<(Of <(IFilter>)>)..::.GetEnumerator Method
FilterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator<IFilter> IEnumerable<IFilter>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of IFilter)
    Implements IEnumerable(Of IFilter).GetEnumerator
Visual C++
private:
virtual IEnumerator<IFilter^>^ GetEnumerator() sealed = IEnumerable<IFilter^>::GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

FilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
FilterCollection..::.IEnumerable..::.GetEnumerator Method
FilterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Implements

IEnumerable..::.GetEnumerator()()()

See Also

FilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


ICollection(IFilter).Remove Method

[image]

LinkOne WebView API
FilterCollection..::.ICollection<(Of <(IFilter>)>)..::.Remove Method
FilterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<IFilter>.Remove(
    IFilter filter
)
Visual Basic (Declaration)
Private Function Remove ( _
    filter As IFilter _
) As Boolean Implements ICollection(Of IFilter).Remove
Visual C++
private:
virtual bool Remove(
    IFilter^ filter
) sealed = ICollection<IFilter^>::Remove

Parameters

filter
Type: Mincom.LinkOne.Dom.Filtering..::.IFilter

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

FilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


AsReadOnly Method

[image]

LinkOne WebView API
FilterCollection..::.AsReadOnly Method
FilterCollection Class See Also Send Feedback
Gets a read-only wrapper for this FilterCollection.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ReadOnlyFilterCollection AsReadOnly()
Visual Basic (Declaration)
Public Function AsReadOnly As ReadOnlyFilterCollection
Visual C++
public:
ReadOnlyFilterCollection^ AsReadOnly()

Return Value

An ReadOnlyFilterCollection that wraps the FilterCollection.

See Also

FilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


BeginUpdate Method

[image]

LinkOne WebView API
FilterCollection..::.BeginUpdate Method
FilterCollection Class See Also Send Feedback
Suppresses all Changed events until EndUpdate(Boolean) is called.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void BeginUpdate()
Visual Basic (Declaration)
Public Sub BeginUpdate
Visual C++
public:
void BeginUpdate()

See Also

FilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


Contains Method

[image] [image]

LinkOne WebView API
FilterCollection..::.Contains Method
FilterCollection Class See Also Send Feedback

Overload List

Name | Description
Contains(T) | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Filter >)>).)
Contains(FilterType) | Determines whether there are any filters of the given FilterType.

See Also

FilterCollection Class
FilterCollection Members
Mincom.LinkOne.Dom.Filtering Namespace


Contains Method (FilterType)

[image]

LinkOne WebView API
FilterCollection..::.Contains Method (FilterType)
FilterCollection Class See Also Send Feedback
Determines whether there are any filters of the given FilterType.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    FilterType filterType
)
Visual Basic (Declaration)
Public Function Contains ( _
    filterType As FilterType _
) As Boolean
Visual C++
public:
bool Contains(
    FilterType filterType
)

Parameters

filterType
Type: Mincom.LinkOne.Dom.Filtering..::.FilterType
Type of the filter.

Return Value

True if there are any filters of the given; otherwise, false.

See Also

FilterCollection Class
Contains Overload
Mincom.LinkOne.Dom.Filtering Namespace


Create Method

[image]

LinkOne WebView API
FilterCollection..::.Create Method
FilterCollection Class See Also Send Feedback
Adds a filter with the specified attributes.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IFilter Create(
    string name,
    string value,
    FilterType type,
    FilterScope scope,
    FilterAccess access
)
Visual Basic (Declaration)
Public Function Create ( _
    name As String, _
    value As String, _
    type As FilterType, _
    scope As FilterScope, _
    access As FilterAccess _
) As IFilter
Visual C++
public:
virtual IFilter^ Create(
    String^ name,
    String^ value,
    FilterType type,
    FilterScope scope,
    FilterAccess access
) sealed

Parameters

name
Type: System..::.String
The name.
value
Type: System..::.String
The value.
type
Type: Mincom.LinkOne.Dom.Filtering..::.FilterType
The type.
scope
Type: Mincom.LinkOne.Dom.Filtering..::.FilterScope
The scope.
access
Type: Mincom.LinkOne.Dom.Filtering..::.FilterAccess
The access.

Return Value

A new IFilter with the specified attributes.

Implements

IFilterCollection..::.Create(String, String, FilterType, FilterScope, FilterAccess)

See Also

FilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


EndUpdate Method

[image]

LinkOne WebView API
FilterCollection..::.EndUpdate Method
FilterCollection Class See Also Send Feedback
Re-enables Changed events, and also fires the Changed event if changes have occurred since BeginUpdate()()() was called.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void EndUpdate(
    bool notifyChanged
)
Visual Basic (Declaration)
Public Sub EndUpdate ( _
    notifyChanged As Boolean _
)
Visual C++
public:
void EndUpdate(
    bool notifyChanged
)

Parameters

notifyChanged
Type: System..::.Boolean
true to fire the Changed event if there have been changes since BeginUpdate()()().

See Also

FilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


IKeyedCollection(String, IFilter).Contains Method

[image]

LinkOne WebView API
FilterCollection..::.IKeyedCollection<(Of <(String, IFilter>)>)..::.Contains Method
FilterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IKeyedCollection<string, IFilter>.Contains(
    string filterName
)
Visual Basic (Declaration)
Private Function Contains ( _
    filterName As String _
) As Boolean Implements IKeyedCollection(Of String, IFilter).Contains
Visual C++
private:
virtual bool Contains(
    String^ filterName
) sealed = IKeyedCollection<String^, IFilter^>::Contains

Parameters

filterName
Type: System..::.String

Implements

IKeyedCollection<(Of <(TKey, TItem>)>)..::.Contains(TKey)

See Also

FilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


Merge Method

[image]

LinkOne WebView API
FilterCollection..::.Merge Method
FilterCollection Class See Also Send Feedback
Merges another IFilterCollection into this collection.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Merge(
    IFilterCollection filters
)
Visual Basic (Declaration)
Public Sub Merge ( _
    filters As IFilterCollection _
)
Visual C++
public:
void Merge(
    IFilterCollection^ filters
)

Parameters

filters
Type: Mincom.LinkOne.Dom.Filtering..::.IFilterCollection
The extra filters to merge.

Remarks

The precedence of a filter is as follows (listed highest to lowest):
- predefined
- fixed
- temporary
- permanent book private
- permanent book public
- permanent publisher private
- permanent publisher public
- permanent global private
- permanent global public
- supplied

See Also

FilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


Remove Method

[image] [image]

LinkOne WebView API
FilterCollection..::.Remove Method
FilterCollection Class See Also Send Feedback

Overload List

Name | Description
Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Filter >)>).)
Remove(String) | Removes the specified filter name.

See Also

FilterCollection Class
FilterCollection Members
Mincom.LinkOne.Dom.Filtering Namespace


Remove Method (String)

[image]

LinkOne WebView API
FilterCollection..::.Remove Method (String)
FilterCollection Class See Also Send Feedback
Removes the specified filter name.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Remove(
    string filterName
)
Visual Basic (Declaration)
Public Function Remove ( _
    filterName As String _
) As Boolean
Visual C++
public:
bool Remove(
    String^ filterName
)

Parameters

filterName
Type: System..::.String
Name of the filter.

Return Value

A value indicating whether the filter was removed.

See Also

FilterCollection Class
Remove Overload
Mincom.LinkOne.Dom.Filtering Namespace


RemoveAll Method

[image]

LinkOne WebView API
FilterCollection..::.RemoveAll Method
FilterCollection Class See Also Send Feedback
Removes all filters from the collection that are of the specified FilterType.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void RemoveAll(
    FilterType filterType
)
Visual Basic (Declaration)
Public Sub RemoveAll ( _
    filterType As FilterType _
)
Visual C++
public:
void RemoveAll(
    FilterType filterType
)

Parameters

filterType
Type: Mincom.LinkOne.Dom.Filtering..::.FilterType
Type type of filter to remove.

See Also

FilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


ToString Method

[image]

LinkOne WebView API
FilterCollection..::.ToString Method
FilterCollection Class See Also Send Feedback
Overriden. Returns a string representation of the collection.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A string representation of the collection.

Remarks

The format is in Filter1,Filter2,...

See Also

FilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


FilterCollection Properties

[image] [image]

LinkOne WebView API
FilterCollection Properties
FilterCollection Class See Also Send Feedback

The FilterCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Filter >)>).)
IsUpdating | Gets true between BeginUpdate()()() and EndUpdate(Boolean) methods.
Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( Filter >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Filter >)>).)
LanguageOption | Gets the language code, if set, otherwise, Empty()()(). Sets the current language option.
ShowSupersededEntries | Gets or sets true to show superseded entries.
SpecificQuery | Gets or sets true if the specific query option has been set.

Explicit Interface Implementations

Name | Description
ICollection<(Of <(IFilter>)>)..::.Count |
IList..::.IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection<(Of <( Filter >)>).)
IsReadOnly | Overloaded.
IList..::.IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection<(Of <( Filter >)>).)
ICollection..::.IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection<(Of <( Filter >)>).)
IList..::.Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( Filter >)>).)
IKeyedCollection<(Of <(String, IFilter>)>)..::.Item |
ICollection..::.SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection<(Of <( Filter >)>).)

See Also

FilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


ICollection(IFilter).Count Property

[image]

LinkOne WebView API
FilterCollection..::.ICollection<(Of <(IFilter>)>)..::.Count Property
FilterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int ICollection<IFilter>.Count { get; }
Visual Basic (Declaration)
Private ReadOnly Property Count As Integer
    Implements ICollection(Of IFilter).Count
Visual C++
private:
virtual property int Count {
    int get () sealed = ICollection<IFilter^>::Count::get;
}

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

FilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


IKeyedCollection(String, IFilter).Item Property

[image]

LinkOne WebView API
FilterCollection..::.IKeyedCollection<(Of <(String, IFilter>)>)..::.Item Property
FilterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IFilter IKeyedCollection<string, IFilter>.Item[
    string filterName
] { get; set; }
Visual Basic (Declaration)
Private Property Item ( _
    filterName As String _
) As IFilter Implements IKeyedCollection(Of String, IFilter).Item
Visual C++
private:
virtual property IFilter^ Item[String^ filterName] {
    IFilter^ get (String^ filterName) sealed = IKeyedCollection<String^, IFilter^>::Item::get;
    void set (String^ filterName, IFilter^ value) sealed = IKeyedCollection<String^, IFilter^>::Item::set;
}

Parameters

filterName
Type: System..::.String

Implements

IKeyedCollection<(Of <(TKey, TItem>)>)..::.Item[([(TKey])])

See Also

FilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


IsReadOnly Property

[image] [image]

LinkOne WebView API
FilterCollection..::.IsReadOnly Property
FilterCollection Class See Also Send Feedback

Overload List

Name | Description
System#Collections#Generic#ICollection{T}#IsReadOnly()()() | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from Collection<(Of <( Filter >)>).)
ICollection<(Of <(IFilter>)>)..::.IsReadOnly |

See Also

FilterCollection Class
FilterCollection Members
Mincom.LinkOne.Dom.Filtering Namespace


ICollection(IFilter).IsReadOnly Property

[image]

LinkOne WebView API
FilterCollection..::.ICollection<(Of <(IFilter>)>)..::.IsReadOnly Property
FilterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<IFilter>.IsReadOnly { get; }
Visual Basic (Declaration)
Private ReadOnly Property IsReadOnly As Boolean
    Implements ICollection(Of IFilter).IsReadOnly
Visual C++
private:
virtual property bool IsReadOnly {
    bool get () sealed = ICollection<IFilter^>::IsReadOnly::get;
}

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

FilterCollection Class
FilterCollection Overload
Mincom.LinkOne.Dom.Filtering Namespace


IsUpdating Property

[image]

LinkOne WebView API
FilterCollection..::.IsUpdating Property
FilterCollection Class See Also Send Feedback
Gets true between BeginUpdate()()() and EndUpdate(Boolean) methods.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsUpdating { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsUpdating As Boolean
Visual C++
public:
property bool IsUpdating {
    bool get ();
}

See Also

FilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


LanguageOption Property

[image]

LinkOne WebView API
FilterCollection..::.LanguageOption Property
FilterCollection Class See Also Send Feedback
Gets the language code, if set, otherwise, Empty()()().
Sets the current language option.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string LanguageOption { get; set; }
Visual Basic (Declaration)
Public Property LanguageOption As String
Visual C++
public:
property String^ LanguageOption {
    String^ get ();
    void set (String^ value);
}

Remarks

Setting the property results in a Predefined Private Book filter named "LANG" being set in the collection.

See Also

FilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


ShowSupersededEntries Property

[image]

LinkOne WebView API
FilterCollection..::.ShowSupersededEntries Property
FilterCollection Class See Also Send Feedback
Gets or sets true to show superseded entries.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool ShowSupersededEntries { get; set; }
Visual Basic (Declaration)
Public Property ShowSupersededEntries As Boolean
Visual C++
public:
property bool ShowSupersededEntries {
    bool get ();
    void set (bool value);
}

Remarks

Setting the property to true results in a Predefined Private Book filter named "S" and valued ON being set in the collection.

See Also

FilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


SpecificQuery Property

[image]

LinkOne WebView API
FilterCollection..::.SpecificQuery Property
FilterCollection Class See Also Send Feedback
Gets or sets true if the specific query option has been set.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool SpecificQuery { get; set; }
Visual Basic (Declaration)
Public Property SpecificQuery As Boolean
Visual C++
public:
property bool SpecificQuery {
    bool get ();
    void set (bool value);
}

Remarks

Setting the property to true results in a Predefined Private Book filter named "SQ" and valued ON being set in the collection.

See Also

FilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


FilterCollection Events

[image] [image]

LinkOne WebView API
FilterCollection Events
FilterCollection Class See Also Send Feedback

The FilterCollection type exposes the following members.

Events

Name | Description
Changed | Occurs when the object has changed.

See Also

FilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


Changed Event

[image]

LinkOne WebView API
FilterCollection..::.Changed Event
FilterCollection Class See Also Send Feedback
Occurs when the object has changed.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public event EventHandler Changed
Visual Basic (Declaration)
Public Event Changed As EventHandler
Visual C++
public:
 event EventHandler^ Changed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

FilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


FilterScope Enumeration

[image]

LinkOne WebView API
FilterScope Enumeration
See Also Send Feedback
Specifies the scope of a filter.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum FilterScope
Visual Basic (Declaration)
Public Enumeration FilterScope
Visual C++
public enum class FilterScope

Members

Member name | Description
Global | The filter is globally accessible.
Publisher | The filter is associated with a specific publisher.
Book | The filter is associated with a specific book.

See Also

Mincom.LinkOne.Dom.Filtering Namespace


FilterType Enumeration

[image]

LinkOne WebView API
FilterType Enumeration
See Also Send Feedback
The enumeration of types of IFilter.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum FilterType
Visual Basic (Declaration)
Public Enumeration FilterType
Visual C++
public enum class FilterType

Members

Member name | Description
Temporary | The filter is only temporary, which is the default.
Permanent | The filter is set permanently.
Supplied | The filter is predefined in the book.
Fixed | The filter is predefined in the book and fixed to stop changes.
PreDefined | The filter is defined in the session.

See Also

Mincom.LinkOne.Dom.Filtering Namespace


IFilter Interface

[image]

LinkOne WebView API
IFilter Interface
Members See Also Send Feedback
A filter for matching options.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IFilter
Visual Basic (Declaration)
Public Interface IFilter
Visual C++
public interface class IFilter

See Also

IFilter Members
Mincom.LinkOne.Dom.Filtering Namespace


IFilter Members

[image] [image]

LinkOne WebView API
IFilter Members
IFilter Interface Properties See Also Send Feedback

The IFilter type exposes the following members.

Properties

Name | Description
Access | Gets the access of the filter.
Name | Gets the name of the filter.
Scope | Gets the scope of the filter.
Type | Gets the type of the filter.
Value | Gets or sets the value of the filter.

See Also

IFilter Interface
Mincom.LinkOne.Dom.Filtering Namespace


IFilter Properties

[image] [image]

LinkOne WebView API
IFilter Properties
IFilter Interface See Also Send Feedback

The IFilter type exposes the following members.

Properties

Name | Description
Access | Gets the access of the filter.
Name | Gets the name of the filter.
Scope | Gets the scope of the filter.
Type | Gets the type of the filter.
Value | Gets or sets the value of the filter.

See Also

IFilter Interface
Mincom.LinkOne.Dom.Filtering Namespace


Access Property

[image]

LinkOne WebView API
IFilter..::.Access Property
IFilter Interface See Also Send Feedback
Gets the access of the filter.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
FilterAccess Access { get; }
Visual Basic (Declaration)
ReadOnly Property Access As FilterAccess
Visual C++
property FilterAccess Access {
    FilterAccess get ();
}

See Also

IFilter Interface
Mincom.LinkOne.Dom.Filtering Namespace


Name Property

[image]

LinkOne WebView API
IFilter..::.Name Property
IFilter Interface See Also Send Feedback
Gets the name of the filter.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IFilter Interface
Mincom.LinkOne.Dom.Filtering Namespace


Scope Property

[image]

LinkOne WebView API
IFilter..::.Scope Property
IFilter Interface See Also Send Feedback
Gets the scope of the filter.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
FilterScope Scope { get; }
Visual Basic (Declaration)
ReadOnly Property Scope As FilterScope
Visual C++
property FilterScope Scope {
    FilterScope get ();
}

See Also

IFilter Interface
Mincom.LinkOne.Dom.Filtering Namespace


Type Property

[image]

LinkOne WebView API
IFilter..::.Type Property
IFilter Interface See Also Send Feedback
Gets the type of the filter.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
FilterType Type { get; }
Visual Basic (Declaration)
ReadOnly Property Type As FilterType
Visual C++
property FilterType Type {
    FilterType get ();
}

See Also

IFilter Interface
Mincom.LinkOne.Dom.Filtering Namespace


Value Property

[image]

LinkOne WebView API
IFilter..::.Value Property
IFilter Interface See Also Send Feedback
Gets or sets the value of the filter.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Value { get; set; }
Visual Basic (Declaration)
Property Value As String
Visual C++
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

IFilter Interface
Mincom.LinkOne.Dom.Filtering Namespace


IFilterable Interface

[image]

LinkOne WebView API
IFilterable Interface
Members See Also Send Feedback
Implemented by classes that can be filtered via an option filter.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IFilterable
Visual Basic (Declaration)
Public Interface IFilterable
Visual C++
public interface class IFilterable

See Also

IFilterable Members
Mincom.LinkOne.Dom.Filtering Namespace


IFilterable Members

[image] [image]

LinkOne WebView API
IFilterable Members
IFilterable Interface Properties See Also Send Feedback

The IFilterable type exposes the following members.

Properties

Name | Description
Options | Gets the options associated with this object.

See Also

IFilterable Interface
Mincom.LinkOne.Dom.Filtering Namespace


IFilterable Properties

[image] [image]

LinkOne WebView API
IFilterable Properties
IFilterable Interface See Also Send Feedback

The IFilterable type exposes the following members.

Properties

Name | Description
Options | Gets the options associated with this object.

See Also

IFilterable Interface
Mincom.LinkOne.Dom.Filtering Namespace


Options Property

[image]

LinkOne WebView API
IFilterable..::.Options Property
IFilterable Interface See Also Send Feedback
Gets the options associated with this object.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IOptionCollection Options { get; }
Visual Basic (Declaration)
ReadOnly Property Options As IOptionCollection
Visual C++
property IOptionCollection^ Options {
    IOptionCollection^ get ();
}

See Also

IFilterable Interface
Mincom.LinkOne.Dom.Filtering Namespace


IFilterCollection Interface

[image]

LinkOne WebView API
IFilterCollection Interface
Members See Also Send Feedback
Represents filters for a LinkOne book, indexed by Name.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IFilterCollection : IKeyedCollection<string, IFilter>,
    ICollection<IFilter>, IEnumerable<IFilter>, IEnumerable
Visual Basic (Declaration)
Public Interface IFilterCollection _
    Implements IKeyedCollection(Of String, IFilter),  _
    ICollection(Of IFilter), IEnumerable(Of IFilter), IEnumerable
Visual C++
public interface class IFilterCollection : IKeyedCollection<String^, IFilter^>,
    ICollection<IFilter^>, IEnumerable<IFilter^>, IEnumerable

See Also

IFilterCollection Members
Mincom.LinkOne.Dom.Filtering Namespace


IFilterCollection Members

[image] [image]

LinkOne WebView API
IFilterCollection Members
IFilterCollection Interface Methods Properties See Also Send Feedback

The IFilterCollection type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IFilter >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IFilter >)>).)
Contains | Overloaded.
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( IFilter >)>).)
Create | Creates a new filter object with the specified attributes.
GetEnumerator | Overloaded.
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IFilter >)>).)

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IFilter >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( IFilter >)>).)
Item | Gets or sets the item with the specified key. (Inherited from IKeyedCollection<(Of <(TKey, TItem>)>).)

See Also

IFilterCollection Interface
Mincom.LinkOne.Dom.Filtering Namespace


IFilterCollection Methods

[image] [image]

LinkOne WebView API
IFilterCollection Methods
IFilterCollection Interface See Also Send Feedback

The IFilterCollection type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IFilter >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IFilter >)>).)
Contains | Overloaded.
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( IFilter >)>).)
Create | Creates a new filter object with the specified attributes.
GetEnumerator | Overloaded.
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IFilter >)>).)

See Also

IFilterCollection Interface
Mincom.LinkOne.Dom.Filtering Namespace


Contains Method

[image] [image]

LinkOne WebView API
IFilterCollection..::.Contains Method
IFilterCollection Interface See Also Send Feedback

Overload List

Name | Description
Contains(TKey) | Determines whether an element with the given key is in the collection. (Inherited from IKeyedCollection<(Of <(TKey, TItem>)>).)
Contains(T) | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from ICollection<(Of <( IFilter >)>).)

See Also

IFilterCollection Interface
IFilterCollection Members
Mincom.LinkOne.Dom.Filtering Namespace


Create Method

[image]

LinkOne WebView API
IFilterCollection..::.Create Method
IFilterCollection Interface See Also Send Feedback
Creates a new filter object with the specified attributes.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IFilter Create(
    string name,
    string value,
    FilterType type,
    FilterScope scope,
    FilterAccess access
)
Visual Basic (Declaration)
Function Create ( _
    name As String, _
    value As String, _
    type As FilterType, _
    scope As FilterScope, _
    access As FilterAccess _
) As IFilter
Visual C++
IFilter^ Create(
    String^ name,
    String^ value,
    FilterType type,
    FilterScope scope,
    FilterAccess access
)

Parameters

name
Type: System..::.String
The name.
value
Type: System..::.String
The value.
type
Type: Mincom.LinkOne.Dom.Filtering..::.FilterType
The type.
scope
Type: Mincom.LinkOne.Dom.Filtering..::.FilterScope
The scope.
access
Type: Mincom.LinkOne.Dom.Filtering..::.FilterAccess
The access.

Return Value

A new IFilter with the specified attributes.

See Also

IFilterCollection Interface
Mincom.LinkOne.Dom.Filtering Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
IFilterCollection..::.GetEnumerator Method
IFilterCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( IFilter >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IFilterCollection Interface
IFilterCollection Members
Mincom.LinkOne.Dom.Filtering Namespace


IFilterCollection Properties

[image] [image]

LinkOne WebView API
IFilterCollection Properties
IFilterCollection Interface See Also Send Feedback

The IFilterCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IFilter >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( IFilter >)>).)
Item | Gets or sets the item with the specified key. (Inherited from IKeyedCollection<(Of <(TKey, TItem>)>).)

See Also

IFilterCollection Interface
Mincom.LinkOne.Dom.Filtering Namespace


IOption Interface

[image]

LinkOne WebView API
IOption Interface
Members See Also Send Feedback
Represents an option that can be used to filter content in a LinkOne book.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IOption
Visual Basic (Declaration)
Public Interface IOption
Visual C++
public interface class IOption

See Also

IOption Members
Mincom.LinkOne.Dom.Filtering Namespace


IOption Members

[image] [image]

LinkOne WebView API
IOption Members
IOption Interface Properties See Also Send Feedback

The IOption type exposes the following members.

Properties

Name | Description
Name | Gets the name of the option.
Value | Gets the value of the option.

See Also

IOption Interface
Mincom.LinkOne.Dom.Filtering Namespace


IOption Properties

[image] [image]

LinkOne WebView API
IOption Properties
IOption Interface See Also Send Feedback

The IOption type exposes the following members.

Properties

Name | Description
Name | Gets the name of the option.
Value | Gets the value of the option.

See Also

IOption Interface
Mincom.LinkOne.Dom.Filtering Namespace


Name Property

[image]

LinkOne WebView API
IOption..::.Name Property
IOption Interface See Also Send Feedback
Gets the name of the option.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IOption Interface
Mincom.LinkOne.Dom.Filtering Namespace


Value Property

[image]

LinkOne WebView API
IOption..::.Value Property
IOption Interface See Also Send Feedback
Gets the value of the option.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Value { get; }
Visual Basic (Declaration)
ReadOnly Property Value As String
Visual C++
property String^ Value {
    String^ get ();
}

See Also

IOption Interface
Mincom.LinkOne.Dom.Filtering Namespace


IOptionCollection Interface

[image]

LinkOne WebView API
IOptionCollection Interface
Members See Also Send Feedback
Represents options associated with content that can be filtered. Options can be individually accessed by index.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IOptionCollection : IReadOnlyList<IOption>,
    IReadOnlyCollection<IOption>, IEnumerable<IOption>, IEnumerable
Visual Basic (Declaration)
Public Interface IOptionCollection _
    Implements IReadOnlyList(Of IOption), IReadOnlyCollection(Of IOption),  _
    IEnumerable(Of IOption), IEnumerable
Visual C++
public interface class IOptionCollection : IReadOnlyList<IOption^>,
    IReadOnlyCollection<IOption^>, IEnumerable<IOption^>, IEnumerable

See Also

IOptionCollection Members
Mincom.LinkOne.Dom.Filtering Namespace


IOptionCollection Members

[image] [image]

LinkOne WebView API
IOptionCollection Members
IOptionCollection Interface Methods Properties See Also Send Feedback

The IOptionCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
GetEnumerator | Overloaded.
IndexOf | Searches the collection and returns the zero-based index of the first occurrence of the given item. (Inherited from IReadOnlyList<(Of <(T>)>).)

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from IReadOnlyList<(Of <(T>)>).)

See Also

IOptionCollection Interface
Mincom.LinkOne.Dom.Filtering Namespace


IOptionCollection Methods

[image] [image]

LinkOne WebView API
IOptionCollection Methods
IOptionCollection Interface See Also Send Feedback

The IOptionCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
GetEnumerator | Overloaded.
IndexOf | Searches the collection and returns the zero-based index of the first occurrence of the given item. (Inherited from IReadOnlyList<(Of <(T>)>).)

See Also

IOptionCollection Interface
Mincom.LinkOne.Dom.Filtering Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
IOptionCollection..::.GetEnumerator Method
IOptionCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( IOption >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IOptionCollection Interface
IOptionCollection Members
Mincom.LinkOne.Dom.Filtering Namespace


IOptionCollection Properties

[image] [image]

LinkOne WebView API
IOptionCollection Properties
IOptionCollection Interface See Also Send Feedback

The IOptionCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from IReadOnlyList<(Of <(T>)>).)

See Also

IOptionCollection Interface
Mincom.LinkOne.Dom.Filtering Namespace


IOptionDefinition Interface

[image]

LinkOne WebView API
IOptionDefinition Interface
Members See Also Send Feedback
Defines a value for an option.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IOptionDefinition
Visual Basic (Declaration)
Public Interface IOptionDefinition
Visual C++
public interface class IOptionDefinition

See Also

IOptionDefinition Members
Mincom.LinkOne.Dom.Filtering Namespace


IOptionDefinition Members

[image] [image]

LinkOne WebView API
IOptionDefinition Members
IOptionDefinition Interface Properties See Also Send Feedback

The IOptionDefinition type exposes the following members.

Properties

Name | Description
Code | Gets the unique code of the option definition.
Description | Gets the description of the option definition.

See Also

IOptionDefinition Interface
Mincom.LinkOne.Dom.Filtering Namespace


IOptionDefinition Properties

[image] [image]

LinkOne WebView API
IOptionDefinition Properties
IOptionDefinition Interface See Also Send Feedback

The IOptionDefinition type exposes the following members.

Properties

Name | Description
Code | Gets the unique code of the option definition.
Description | Gets the description of the option definition.

See Also

IOptionDefinition Interface
Mincom.LinkOne.Dom.Filtering Namespace


Code Property

[image]

LinkOne WebView API
IOptionDefinition..::.Code Property
IOptionDefinition Interface See Also Send Feedback
Gets the unique code of the option definition.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Code { get; }
Visual Basic (Declaration)
ReadOnly Property Code As String
Visual C++
property String^ Code {
    String^ get ();
}

See Also

IOptionDefinition Interface
Mincom.LinkOne.Dom.Filtering Namespace


Description Property

[image]

LinkOne WebView API
IOptionDefinition..::.Description Property
IOptionDefinition Interface See Also Send Feedback
Gets the description of the option definition.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Description { get; }
Visual Basic (Declaration)
ReadOnly Property Description As String
Visual C++
property String^ Description {
    String^ get ();
}

See Also

IOptionDefinition Interface
Mincom.LinkOne.Dom.Filtering Namespace


IOptionDefinitionCollection Interface

[image]

LinkOne WebView API
IOptionDefinitionCollection Interface
Members See Also Send Feedback
Represents the allowed values for an option, indexed by Code.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IOptionDefinitionCollection : IReadOnlyKeyedCollection<string, IOptionDefinition>,
    IReadOnlyCollection<IOptionDefinition>, IEnumerable<IOptionDefinition>, IEnumerable
Visual Basic (Declaration)
Public Interface IOptionDefinitionCollection _
    Implements IReadOnlyKeyedCollection(Of String, IOptionDefinition),  _
    IReadOnlyCollection(Of IOptionDefinition), IEnumerable(Of IOptionDefinition), IEnumerable
Visual C++
public interface class IOptionDefinitionCollection : IReadOnlyKeyedCollection<String^, IOptionDefinition^>,
    IReadOnlyCollection<IOptionDefinition^>, IEnumerable<IOptionDefinition^>, IEnumerable

See Also

IOptionDefinitionCollection Members
Mincom.LinkOne.Dom.Filtering Namespace


IOptionDefinitionCollection Members

[image] [image]

LinkOne WebView API
IOptionDefinitionCollection Members
IOptionDefinitionCollection Interface Methods Properties See Also Send Feedback

The IOptionDefinitionCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
GetEnumerator | Overloaded.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item with the specified key. (Inherited from IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>).)

See Also

IOptionDefinitionCollection Interface
Mincom.LinkOne.Dom.Filtering Namespace


IOptionDefinitionCollection Methods

[image] [image]

LinkOne WebView API
IOptionDefinitionCollection Methods
IOptionDefinitionCollection Interface See Also Send Feedback

Methods

Name | Description
Contains | Overloaded.
GetEnumerator | Overloaded.

See Also

IOptionDefinitionCollection Interface
Mincom.LinkOne.Dom.Filtering Namespace


Contains Method

[image] [image]

LinkOne WebView API
IOptionDefinitionCollection..::.Contains Method
IOptionDefinitionCollection Interface See Also Send Feedback

Overload List

Name | Description
Contains(T) | Determines whether an element is in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Contains(TKey) | Determines whether an element with the given key is in the collection. (Inherited from IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>).)

See Also

IOptionDefinitionCollection Interface
IOptionDefinitionCollection Members
Mincom.LinkOne.Dom.Filtering Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
IOptionDefinitionCollection..::.GetEnumerator Method
IOptionDefinitionCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( IOptionDefinition >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IOptionDefinitionCollection Interface
IOptionDefinitionCollection Members
Mincom.LinkOne.Dom.Filtering Namespace


IOptionDefinitionCollection Properties

[image] [image]

LinkOne WebView API
IOptionDefinitionCollection Properties
IOptionDefinitionCollection Interface See Also Send Feedback

The IOptionDefinitionCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item with the specified key. (Inherited from IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>).)

See Also

IOptionDefinitionCollection Interface
Mincom.LinkOne.Dom.Filtering Namespace


Option Class

[image]

LinkOne WebView API
Option Class
Members See Also Send Feedback
Defines the abstract base class for a LinkOne option.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public abstract class Option : IOption
Visual Basic (Declaration)
<SerializableAttribute> _
Public MustInherit Class Option _
    Implements IOption
Visual C++
[SerializableAttribute]
public ref class Option abstract : IOption

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Filtering..::.Option
Mincom.LinkOne.Dom.Filtering..::.RangeOption
Mincom.LinkOne.Dom.Filtering..::.SelectOption
Mincom.LinkOne.Dom.Filtering..::.SwitchOption

See Also

Option Members
Mincom.LinkOne.Dom.Filtering Namespace


Option Members

[image] [image]

LinkOne WebView API
Option Members
Option Class Methods Properties See Also Send Feedback

The Option type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Name | The name of the option.
Value | Gets the value of the option.

See Also

Option Class
Mincom.LinkOne.Dom.Filtering Namespace


Option Methods

[image] [image]

LinkOne WebView API
Option Methods
Option Class See Also Send Feedback

The Option type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Option Class
Mincom.LinkOne.Dom.Filtering Namespace


Option Properties

[image] [image]

LinkOne WebView API
Option Properties
Option Class See Also Send Feedback

The Option type exposes the following members.

Properties

Name | Description
Name | The name of the option.
Value | Gets the value of the option.

See Also

Option Class
Mincom.LinkOne.Dom.Filtering Namespace


Name Property

[image]

LinkOne WebView API
Option..::.Name Property
Option Class See Also Send Feedback
The name of the option.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Name { get; protected set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IOption..::.Name

See Also

Option Class
Mincom.LinkOne.Dom.Filtering Namespace


Value Property

[image]

LinkOne WebView API
Option..::.Value Property
Option Class See Also Send Feedback
Gets the value of the option.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public abstract string Value { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property Value As String
Visual C++
public:
virtual property String^ Value {
    String^ get () abstract;
}

Implements

IOption..::.Value

See Also

Option Class
Mincom.LinkOne.Dom.Filtering Namespace


OptionCollection Class

[image]

LinkOne WebView API
OptionCollection Class
Members See Also Send Feedback
Represents options associated with content that can be filtered. Options can be individually accessed by index.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class OptionCollection : ReadOnlyList<Option>,
    IOptionCollection, IReadOnlyList<IOption>, IReadOnlyCollection<IOption>,
    IEnumerable<IOption>, IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class OptionCollection _
    Inherits ReadOnlyList(Of Option) _
    Implements IOptionCollection, IReadOnlyList(Of IOption),  _
    IReadOnlyCollection(Of IOption), IEnumerable(Of IOption), IEnumerable
Visual C++
[SerializableAttribute]
public ref class OptionCollection sealed : public ReadOnlyList<Option^>,
    IOptionCollection, IReadOnlyList<IOption^>, IReadOnlyCollection<IOption^>,
    IEnumerable<IOption^>, IEnumerable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.ReadOnlyList <(Of <( Option >)>)
Mincom.LinkOne.Dom.Filtering..::.OptionCollection

See Also

OptionCollection Members
Mincom.LinkOne.Dom.Filtering Namespace


OptionCollection Members

[image] [image]

LinkOne WebView API
OptionCollection Members
OptionCollection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The OptionCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given object. (Inherited from ReadOnlyList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overloaded.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
InnerList | Gets the inner list. (Inherited from ReadOnlyList<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from ReadOnlyList<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(IOption>)>)..::.Contains |
IReadOnlyCollection<(Of <(IOption>)>)..::.Count |
IEnumerable<(Of <(IOption>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator |
IReadOnlyList<(Of <(IOption>)>)..::.IndexOf |
IReadOnlyList<(Of <(IOption>)>)..::.Item |

See Also

OptionCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


OptionCollection Methods

[image] [image]

LinkOne WebView API
OptionCollection Methods
OptionCollection Class See Also Send Feedback

The OptionCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given object. (Inherited from ReadOnlyList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overloaded.

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(IOption>)>)..::.Contains |
IEnumerable<(Of <(IOption>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator |
IReadOnlyList<(Of <(IOption>)>)..::.IndexOf |

See Also

OptionCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


IEnumerable(IOption).GetEnumerator Method

[image]

LinkOne WebView API
OptionCollection..::.IEnumerable<(Of <(IOption>)>)..::.GetEnumerator Method
OptionCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator<IOption> IEnumerable<IOption>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of IOption)
    Implements IEnumerable(Of IOption).GetEnumerator
Visual C++
private:
virtual IEnumerator<IOption^>^ GetEnumerator() sealed = IEnumerable<IOption^>::GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

OptionCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
OptionCollection..::.IEnumerable..::.GetEnumerator Method
OptionCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Implements

IEnumerable..::.GetEnumerator()()()

See Also

OptionCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


IReadOnlyCollection(IOption).Contains Method

[image]

LinkOne WebView API
OptionCollection..::.IReadOnlyCollection<(Of <(IOption>)>)..::.Contains Method
OptionCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IReadOnlyCollection<IOption>.Contains(
    IOption option
)
Visual Basic (Declaration)
Private Function Contains ( _
    option As IOption _
) As Boolean Implements IReadOnlyCollection(Of IOption).Contains
Visual C++
private:
virtual bool Contains(
    IOption^ option
) sealed = IReadOnlyCollection<IOption^>::Contains

Parameters

option
Type: Mincom.LinkOne.Dom.Filtering..::.IOption

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Contains(T)

See Also

OptionCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


IReadOnlyList(IOption).IndexOf Method

[image]

LinkOne WebView API
OptionCollection..::.IReadOnlyList<(Of <(IOption>)>)..::.IndexOf Method
OptionCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int IReadOnlyList<IOption>.IndexOf(
    IOption option
)
Visual Basic (Declaration)
Private Function IndexOf ( _
    option As IOption _
) As Integer Implements IReadOnlyList(Of IOption).IndexOf
Visual C++
private:
virtual int IndexOf(
    IOption^ option
) sealed = IReadOnlyList<IOption^>::IndexOf

Parameters

option
Type: Mincom.LinkOne.Dom.Filtering..::.IOption

Implements

IReadOnlyList<(Of <(T>)>)..::.IndexOf(T)

See Also

OptionCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


ToString Method

[image] [image]

LinkOne WebView API
OptionCollection..::.ToString Method
OptionCollection Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns a string that represents the current object. (Inherited from Object.)
ToString(Boolean) | Gets a String representation of the OptionCollection.

See Also

OptionCollection Class
OptionCollection Members
Mincom.LinkOne.Dom.Filtering Namespace


ToString Method (Boolean)

[image]

LinkOne WebView API
OptionCollection..::.ToString Method (Boolean)
OptionCollection Class See Also Send Feedback
Gets a String representation of the OptionCollection.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string ToString(
    bool showOptionNames
)
Visual Basic (Declaration)
Public Function ToString ( _
    showOptionNames As Boolean _
) As String
Visual C++
public:
String^ ToString(
    bool showOptionNames
)

Parameters

showOptionNames
Type: System..::.Boolean
true if the option names should be included in the returned string; otherwise, false.

Return Value

A string representation of the options seperated by ','.

See Also

OptionCollection Class
ToString Overload
Mincom.LinkOne.Dom.Filtering Namespace


OptionCollection Properties

[image] [image]

LinkOne WebView API
OptionCollection Properties
OptionCollection Class See Also Send Feedback

The OptionCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
InnerList | Gets the inner list. (Inherited from ReadOnlyList<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from ReadOnlyList<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(IOption>)>)..::.Count |
IReadOnlyList<(Of <(IOption>)>)..::.Item |

See Also

OptionCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


IReadOnlyCollection(IOption).Count Property

[image]

LinkOne WebView API
OptionCollection..::.IReadOnlyCollection<(Of <(IOption>)>)..::.Count Property
OptionCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int IReadOnlyCollection<IOption>.Count { get; }
Visual Basic (Declaration)
Private ReadOnly Property Count As Integer
    Implements IReadOnlyCollection(Of IOption).Count
Visual C++
private:
virtual property int Count {
    int get () sealed = IReadOnlyCollection<IOption^>::Count::get;
}

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Count

See Also

OptionCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


IReadOnlyList(IOption).Item Property

[image]

LinkOne WebView API
OptionCollection..::.IReadOnlyList<(Of <(IOption>)>)..::.Item Property
OptionCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IOption IReadOnlyList<IOption>.Item[
    int index
] { get; }
Visual Basic (Declaration)
Private ReadOnly Property Item ( _
    index As Integer _
) As IOption Implements IReadOnlyList(Of IOption).Item
Visual C++
private:
virtual property IOption^ Item[int index] {
    IOption^ get (int index) sealed = IReadOnlyList<IOption^>::Item::get;
}

Parameters

index
Type: System..::.Int32

Implements

IReadOnlyList<(Of <(T>)>)..::.Item[([(Int32])])

See Also

OptionCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


OptionDefinition Class

[image]

LinkOne WebView API
OptionDefinition Class
Members See Also Send Feedback
The base class for a LinkOne Option Definition.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public abstract class OptionDefinition : IOptionDefinition
Visual Basic (Declaration)
<SerializableAttribute> _
Public MustInherit Class OptionDefinition _
    Implements IOptionDefinition
Visual C++
[SerializableAttribute]
public ref class OptionDefinition abstract : IOptionDefinition

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Filtering..::.OptionDefinition
Mincom.LinkOne.Dom.Filtering..::.RangeOptionDefinition
Mincom.LinkOne.Dom.Filtering..::.SelectOptionDefinition
Mincom.LinkOne.Dom.Filtering..::.SwitchOptionDefinition

See Also

OptionDefinition Members
Mincom.LinkOne.Dom.Filtering Namespace


OptionDefinition Members

[image] [image]

LinkOne WebView API
OptionDefinition Members
OptionDefinition Class Methods Properties See Also Send Feedback

The OptionDefinition type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Code | Gets the option definition code.
Description | Gets the option definition description.

See Also

OptionDefinition Class
Mincom.LinkOne.Dom.Filtering Namespace


OptionDefinition Methods

[image] [image]

LinkOne WebView API
OptionDefinition Methods
OptionDefinition Class See Also Send Feedback

The OptionDefinition type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

OptionDefinition Class
Mincom.LinkOne.Dom.Filtering Namespace


OptionDefinition Properties

[image] [image]

LinkOne WebView API
OptionDefinition Properties
OptionDefinition Class See Also Send Feedback

The OptionDefinition type exposes the following members.

Properties

Name | Description
Code | Gets the option definition code.
Description | Gets the option definition description.

See Also

OptionDefinition Class
Mincom.LinkOne.Dom.Filtering Namespace


Code Property

[image]

LinkOne WebView API
OptionDefinition..::.Code Property
OptionDefinition Class See Also Send Feedback
Gets the option definition code.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Code { get; protected set; }
Visual Basic (Declaration)
Public Property Code As String
Visual C++
public:
virtual property String^ Code {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IOptionDefinition..::.Code

See Also

OptionDefinition Class
Mincom.LinkOne.Dom.Filtering Namespace


Description Property

[image]

LinkOne WebView API
OptionDefinition..::.Description Property
OptionDefinition Class See Also Send Feedback
Gets the option definition description.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Description { get; protected set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
virtual property String^ Description {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IOptionDefinition..::.Description

See Also

OptionDefinition Class
Mincom.LinkOne.Dom.Filtering Namespace


OptionDefinitionCollection Class

[image]

LinkOne WebView API
OptionDefinitionCollection Class
Members See Also Send Feedback
Represents a collection of OptionDefinition objects keyed on Code.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class OptionDefinitionCollection : IReadOnlyKeyedCollection<string, OptionDefinition>,
    IReadOnlyCollection<OptionDefinition>, IEnumerable<OptionDefinition>, IOptionDefinitionCollection,
    IReadOnlyKeyedCollection<string, IOptionDefinition>, IReadOnlyCollection<IOptionDefinition>, IEnumerable<IOptionDefinition>,
    IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class OptionDefinitionCollection _
    Implements IReadOnlyKeyedCollection(Of String, OptionDefinition),  _
    IReadOnlyCollection(Of OptionDefinition), IEnumerable(Of OptionDefinition), IOptionDefinitionCollection,  _
    IReadOnlyKeyedCollection(Of String, IOptionDefinition), IReadOnlyCollection(Of IOptionDefinition),  _
    IEnumerable(Of IOptionDefinition), IEnumerable
Visual C++
[SerializableAttribute]
public ref class OptionDefinitionCollection sealed : IReadOnlyKeyedCollection<String^, OptionDefinition^>,
    IReadOnlyCollection<OptionDefinition^>, IEnumerable<OptionDefinition^>, IOptionDefinitionCollection,
    IReadOnlyKeyedCollection<String^, IOptionDefinition^>, IReadOnlyCollection<IOptionDefinition^>,
    IEnumerable<IOptionDefinition^>, IEnumerable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Filtering..::.OptionDefinitionCollection

See Also

OptionDefinitionCollection Members
Mincom.LinkOne.Dom.Filtering Namespace


OptionDefinitionCollection Members

[image] [image]

LinkOne WebView API
OptionDefinitionCollection Members
OptionDefinitionCollection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The OptionDefinitionCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements in the collection.
Item | Gets the OptionDefinition with a matching code (case insensitive), or returns null if there is no match.
PredefinedOptions | Gets the collection of predefined options definitions.

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(IOptionDefinition>)>)..::.Contains |
IReadOnlyKeyedCollection<(Of <(String, IOptionDefinition>)>)..::.Contains |
IReadOnlyCollection<(Of <(IOptionDefinition>)>)..::.Count |
IEnumerable<(Of <(IOptionDefinition>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.
IReadOnlyKeyedCollection<(Of <(String, IOptionDefinition>)>)..::.Item |

See Also

OptionDefinitionCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


OptionDefinitionCollection Methods

[image] [image]

LinkOne WebView API
OptionDefinitionCollection Methods
OptionDefinitionCollection Class See Also Send Feedback

The OptionDefinitionCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(IOptionDefinition>)>)..::.Contains |
IReadOnlyKeyedCollection<(Of <(String, IOptionDefinition>)>)..::.Contains |
IEnumerable<(Of <(IOptionDefinition>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.

See Also

OptionDefinitionCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


IEnumerable(IOptionDefinition).GetEnumerator Method

[image]

LinkOne WebView API
OptionDefinitionCollection..::.IEnumerable<(Of <(IOptionDefinition>)>)..::.GetEnumerator Method
OptionDefinitionCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator<IOptionDefinition> IEnumerable<IOptionDefinition>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of IOptionDefinition)
    Implements IEnumerable(Of IOptionDefinition).GetEnumerator
Visual C++
private:
virtual IEnumerator<IOptionDefinition^>^ GetEnumerator() sealed = IEnumerable<IOptionDefinition^>::GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

OptionDefinitionCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
OptionDefinitionCollection..::.IEnumerable..::.GetEnumerator Method
OptionDefinitionCollection Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

OptionDefinitionCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


Contains Method

[image] [image]

LinkOne WebView API
OptionDefinitionCollection..::.Contains Method
OptionDefinitionCollection Class See Also Send Feedback

Overload List

Name | Description
Contains(OptionDefinition) | Determines whether an option definition is in the collection.
Contains(String) | Determines whether the OptionDefinitionCollection contains an OptionDefinition with the given code.

See Also

OptionDefinitionCollection Class
OptionDefinitionCollection Members
Mincom.LinkOne.Dom.Filtering Namespace


Contains Method (OptionDefinition)

[image]

LinkOne WebView API
OptionDefinitionCollection..::.Contains Method (OptionDefinition)
OptionDefinitionCollection Class See Also Send Feedback
Determines whether an option definition is in the collection.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    OptionDefinition item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As OptionDefinition _
) As Boolean
Visual C++
public:
virtual bool Contains(
    OptionDefinition^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Dom.Filtering..::.OptionDefinition
The option definition to search for.

Return Value

true if found in the collection, otherwise, false.

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Contains(T)

See Also

OptionDefinitionCollection Class
Contains Overload
Mincom.LinkOne.Dom.Filtering Namespace


Contains Method (String)

[image]

LinkOne WebView API
OptionDefinitionCollection..::.Contains Method (String)
OptionDefinitionCollection Class See Also Send Feedback
Determines whether the OptionDefinitionCollection contains an OptionDefinition with the given code.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    string key
)
Visual Basic (Declaration)
Public Function Contains ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ key
) sealed

Parameters

key
Type: System..::.String
The option definition code.

Return Value

true if the OptionDefinitionCollection contains an OptionDefinition with the given code; otherwise, false.

Implements

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Contains(TKey)

See Also

OptionDefinitionCollection Class
Contains Overload
Mincom.LinkOne.Dom.Filtering Namespace


GetEnumerator Method

[image]

LinkOne WebView API
OptionDefinitionCollection..::.GetEnumerator Method
OptionDefinitionCollection Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IEnumerator<OptionDefinition> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of OptionDefinition)
Visual C++
public:
virtual IEnumerator<OptionDefinition^>^ GetEnumerator() sealed

Return Value

A IEnumerator<(Of <(T>)>) that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

OptionDefinitionCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


IReadOnlyCollection(IOptionDefinition).Contains Method

[image]

LinkOne WebView API
OptionDefinitionCollection..::.IReadOnlyCollection<(Of <(IOptionDefinition>)>)..::.Contains Method
OptionDefinitionCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IReadOnlyCollection<IOptionDefinition>.Contains(
    IOptionDefinition optionDefinition
)
Visual Basic (Declaration)
Private Function Contains ( _
    optionDefinition As IOptionDefinition _
) As Boolean Implements IReadOnlyCollection(Of IOptionDefinition).Contains
Visual C++
private:
virtual bool Contains(
    IOptionDefinition^ optionDefinition
) sealed = IReadOnlyCollection<IOptionDefinition^>::Contains

Parameters

optionDefinition
Type: Mincom.LinkOne.Dom.Filtering..::.IOptionDefinition

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Contains(T)

See Also

OptionDefinitionCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


IReadOnlyKeyedCollection(String, IOptionDefinition).Contains Method

[image]

LinkOne WebView API
OptionDefinitionCollection..::.IReadOnlyKeyedCollection<(Of <(String, IOptionDefinition>)>)..::.Contains Method
OptionDefinitionCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IReadOnlyKeyedCollection<string, IOptionDefinition>.Contains(
    string code
)
Visual Basic (Declaration)
Private Function Contains ( _
    code As String _
) As Boolean Implements IReadOnlyKeyedCollection(Of String, IOptionDefinition).Contains
Visual C++
private:
virtual bool Contains(
    String^ code
) sealed = IReadOnlyKeyedCollection<String^, IOptionDefinition^>::Contains

Parameters

code
Type: System..::.String

Implements

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Contains(TKey)

See Also

OptionDefinitionCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


OptionDefinitionCollection Properties

[image] [image]

LinkOne WebView API
OptionDefinitionCollection Properties
OptionDefinitionCollection Class See Also Send Feedback

The OptionDefinitionCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection.
Item | Gets the OptionDefinition with a matching code (case insensitive), or returns null if there is no match.
PredefinedOptions | Gets the collection of predefined options definitions.

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(IOptionDefinition>)>)..::.Count |
IReadOnlyKeyedCollection<(Of <(String, IOptionDefinition>)>)..::.Item |

See Also

OptionDefinitionCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


Count Property

[image]

LinkOne WebView API
OptionDefinitionCollection..::.Count Property
OptionDefinitionCollection Class See Also Send Feedback
Gets the number of elements in the collection.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Count

See Also

OptionDefinitionCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


IReadOnlyCollection(IOptionDefinition).Count Property

[image]

LinkOne WebView API
OptionDefinitionCollection..::.IReadOnlyCollection<(Of <(IOptionDefinition>)>)..::.Count Property
OptionDefinitionCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int IReadOnlyCollection<IOptionDefinition>.Count { get; }
Visual Basic (Declaration)
Private ReadOnly Property Count As Integer
    Implements IReadOnlyCollection(Of IOptionDefinition).Count
Visual C++
private:
virtual property int Count {
    int get () sealed = IReadOnlyCollection<IOptionDefinition^>::Count::get;
}

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Count

See Also

OptionDefinitionCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


IReadOnlyKeyedCollection(String, IOptionDefinition).Item Property

[image]

LinkOne WebView API
OptionDefinitionCollection..::.IReadOnlyKeyedCollection<(Of <(String, IOptionDefinition>)>)..::.Item Property
OptionDefinitionCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IOptionDefinition IReadOnlyKeyedCollection<string, IOptionDefinition>.Item[
    string code
] { get; }
Visual Basic (Declaration)
Private ReadOnly Property Item ( _
    code As String _
) As IOptionDefinition Implements IReadOnlyKeyedCollection(Of String, IOptionDefinition).Item
Visual C++
private:
virtual property IOptionDefinition^ Item[String^ code] {
    IOptionDefinition^ get (String^ code) sealed = IReadOnlyKeyedCollection<String^, IOptionDefinition^>::Item::get;
}

Parameters

code
Type: System..::.String

Implements

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Item[([(TKey])])

See Also

OptionDefinitionCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


Item Property

[image]

LinkOne WebView API
OptionDefinitionCollection..::.Item Property
OptionDefinitionCollection Class See Also Send Feedback
Gets the OptionDefinition with a matching code (case insensitive), or returns null if there is no match.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public OptionDefinition this[
    string key
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    key As String _
) As OptionDefinition
Visual C++
public:
virtual property OptionDefinition^ default[String^ key] {
    OptionDefinition^ get (String^ key) sealed;
}

Parameters

key
Type: System..::.String

Implements

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Item[([(TKey])])

See Also

OptionDefinitionCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


PredefinedOptions Property

[image]

LinkOne WebView API
OptionDefinitionCollection..::.PredefinedOptions Property
OptionDefinitionCollection Class See Also Send Feedback
Gets the collection of predefined options definitions.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static OptionDefinitionCollection PredefinedOptions { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PredefinedOptions As OptionDefinitionCollection
Visual C++
public:
static property OptionDefinitionCollection^ PredefinedOptions {
    OptionDefinitionCollection^ get ();
}

Remarks

LinkOne defines a number of standard option codes, which include SN, PSN, S, SQ, and LANG. Of these, S, SQ and LANG are special predefined options whose value cannot be changed.

See Also

OptionDefinitionCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


RangeOption Class

[image]

LinkOne WebView API
RangeOption Class
Members See Also Send Feedback
Represents a LinkOne Range Option.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class RangeOption : Option
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class RangeOption _
    Inherits Option
Visual C++
[SerializableAttribute]
public ref class RangeOption sealed : public Option

Remarks

A range option causes information to be filtered out of a LinkOne book if the option value falls outside of the specified lower and upper limit. A blank lower limit specifies that the range starts at the minimum possible value. A blank upper limit specifies that the range extends to the maximum possible value.

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Filtering..::.Option
Mincom.LinkOne.Dom.Filtering..::.RangeOption

See Also

RangeOption Members
Mincom.LinkOne.Dom.Filtering Namespace


RangeOption Members

[image] [image]

LinkOne WebView API
RangeOption Members
RangeOption Class Constructors Methods Properties See Also Send Feedback

The RangeOption type exposes the following members.

Constructors

Name | Description
RangeOption | Initializes a new instance of the RangeOption class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Lower | Gets or sets the lower value.
Name | The name of the option. (Inherited from Option.)
Upper | Gets or sets the upper value.
Value | Gets the value of the option. (Overrides Option..::.Value.)

See Also

RangeOption Class
Mincom.LinkOne.Dom.Filtering Namespace


RangeOption Constructor

[image]

LinkOne WebView API
RangeOption Constructor
RangeOption Class See Also Send Feedback
Initializes a new instance of the RangeOption class.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public RangeOption(
    IDomReader domReader
)
Visual Basic (Declaration)
Public Sub New ( _
    domReader As IDomReader _
)
Visual C++
public:
RangeOption(
    IDomReader^ domReader
)

Parameters

domReader
Type: IDomReader
The DOM reader.

See Also

RangeOption Class
Mincom.LinkOne.Dom.Filtering Namespace


RangeOption Methods

[image] [image]

LinkOne WebView API
RangeOption Methods
RangeOption Class See Also Send Feedback

The RangeOption type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RangeOption Class
Mincom.LinkOne.Dom.Filtering Namespace


RangeOption Properties

[image] [image]

LinkOne WebView API
RangeOption Properties
RangeOption Class See Also Send Feedback

The RangeOption type exposes the following members.

Properties

Name | Description
Lower | Gets or sets the lower value.
Name | The name of the option. (Inherited from Option.)
Upper | Gets or sets the upper value.
Value | Gets the value of the option. (Overrides Option..::.Value.)

See Also

RangeOption Class
Mincom.LinkOne.Dom.Filtering Namespace


Lower Property

[image]

LinkOne WebView API
RangeOption..::.Lower Property
RangeOption Class See Also Send Feedback
Gets or sets the lower value.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Lower { get; }
Visual Basic (Declaration)
Public ReadOnly Property Lower As String
Visual C++
public:
property String^ Lower {
    String^ get ();
}

See Also

RangeOption Class
Mincom.LinkOne.Dom.Filtering Namespace


Upper Property

[image]

LinkOne WebView API
RangeOption..::.Upper Property
RangeOption Class See Also Send Feedback
Gets or sets the upper value.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Upper { get; }
Visual Basic (Declaration)
Public ReadOnly Property Upper As String
Visual C++
public:
property String^ Upper {
    String^ get ();
}

See Also

RangeOption Class
Mincom.LinkOne.Dom.Filtering Namespace


Value Property

[image]

LinkOne WebView API
RangeOption..::.Value Property
RangeOption Class See Also Send Feedback
Gets the value of the option.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string Value { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Value As String
Visual C++
public:
virtual property String^ Value {
    String^ get () override;
}

Implements

IOption..::.Value

See Also

RangeOption Class
Mincom.LinkOne.Dom.Filtering Namespace


RangeOptionDefinition Class

[image]

LinkOne WebView API
RangeOptionDefinition Class
Members See Also Send Feedback
Represents the Option Definition for a LinkOne Range Option.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class RangeOptionDefinition : OptionDefinition
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class RangeOptionDefinition _
    Inherits OptionDefinition
Visual C++
[SerializableAttribute]
public ref class RangeOptionDefinition sealed : public OptionDefinition

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Filtering..::.OptionDefinition
Mincom.LinkOne.Dom.Filtering..::.RangeOptionDefinition

See Also

RangeOptionDefinition Members
Mincom.LinkOne.Dom.Filtering Namespace


RangeOptionDefinition Members

[image] [image]

LinkOne WebView API
RangeOptionDefinition Members
RangeOptionDefinition Class Constructors Methods Properties See Also Send Feedback

The RangeOptionDefinition type exposes the following members.

Constructors

Name | Description
RangeOptionDefinition | Initialises a new instance of the RangeOptionDefinition class from a Reader object.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Code | Gets the option definition code. (Inherited from OptionDefinition.)
Description | Gets the option definition description. (Inherited from OptionDefinition.)

See Also

RangeOptionDefinition Class
Mincom.LinkOne.Dom.Filtering Namespace


RangeOptionDefinition Constructor

[image]

LinkOne WebView API
RangeOptionDefinition Constructor
RangeOptionDefinition Class See Also Send Feedback
Initialises a new instance of the RangeOptionDefinition class from a Reader object.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public RangeOptionDefinition(
    IDomReader domReader
)
Visual Basic (Declaration)
Public Sub New ( _
    domReader As IDomReader _
)
Visual C++
public:
RangeOptionDefinition(
    IDomReader^ domReader
)

Parameters

domReader
Type: IDomReader
The Reader providing the data to populate this object.

See Also

RangeOptionDefinition Class
Mincom.LinkOne.Dom.Filtering Namespace


RangeOptionDefinition Methods

[image] [image]

LinkOne WebView API
RangeOptionDefinition Methods
RangeOptionDefinition Class See Also Send Feedback

The RangeOptionDefinition type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RangeOptionDefinition Class
Mincom.LinkOne.Dom.Filtering Namespace


RangeOptionDefinition Properties

[image] [image]

LinkOne WebView API
RangeOptionDefinition Properties
RangeOptionDefinition Class See Also Send Feedback

The RangeOptionDefinition type exposes the following members.

Properties

Name | Description
Code | Gets the option definition code. (Inherited from OptionDefinition.)
Description | Gets the option definition description. (Inherited from OptionDefinition.)

See Also

RangeOptionDefinition Class
Mincom.LinkOne.Dom.Filtering Namespace


ReadOnlyFilterCollection Class

[image]

LinkOne WebView API
ReadOnlyFilterCollection Class
Members See Also Send Feedback
Represents a collection of filters that cannot be modified.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class ReadOnlyFilterCollection : ReadOnlyCollection<Filter>,
    IFilterCollection, IKeyedCollection<string, IFilter>, ICollection<IFilter>,
    IEnumerable<IFilter>, IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class ReadOnlyFilterCollection _
    Inherits ReadOnlyCollection(Of Filter) _
    Implements IFilterCollection, IKeyedCollection(Of String, IFilter),  _
    ICollection(Of IFilter), IEnumerable(Of IFilter), IEnumerable
Visual C++
[SerializableAttribute]
public ref class ReadOnlyFilterCollection sealed : public ReadOnlyCollection<Filter^>,
    IFilterCollection, IKeyedCollection<String^, IFilter^>, ICollection<IFilter^>,
    IEnumerable<IFilter^>, IEnumerable

Remarks

If changes are made to the underlying FilterCollection, the ReadOnlyFilterCollection reflects those changes.

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.ReadOnlyCollection<(Of <( Filter >)>)
Mincom.LinkOne.Dom.Filtering..::.ReadOnlyFilterCollection

See Also

ReadOnlyFilterCollection Members
Mincom.LinkOne.Dom.Filtering Namespace


ReadOnlyFilterCollection Members

[image] [image]

LinkOne WebView API
ReadOnlyFilterCollection Members
ReadOnlyFilterCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ReadOnlyFilterCollection type exposes the following members.

Constructors

Name | Description
ReadOnlyFilterCollection | Initializes a new instance of the ReadOnlyFilterCollection class.

Methods

Name | Description
Contains | Overloaded.
CopyTo | Copies the entire ReadOnlyCollection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection<(Of <(T>)>). (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection<(Of <(T>)>). (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overriden. Returns a string representation of the collection. (Overrides Object..::.ToString()()().)

Properties

Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection<(Of <(T>)>) instance. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
Item | Overloaded.
Items | Returns the IList<(Of <(T>)>) that the ReadOnlyCollection<(Of <(T>)>) wraps. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
LanguageOption | See LanguageOption for more information.
ShowSupersededEntries | Gets or sets true to show superseded entries.
SpecificQuery | See SpecificQuery for more information.

Explicit Interface Implementations

Name | Description
Add | Overloaded.
IList..::.Add | Adds an item to the IList. This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
Clear | Overloaded.
IList..::.Clear | Removes all items from the IList. This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
IList..::.Contains | Determines whether the IList contains a specific value. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
IKeyedCollection<(Of <(String, IFilter>)>)..::.Contains |
ICollection<(Of <(IFilter>)>)..::.Contains |
ICollection..::.CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
ICollection<(Of <(IFilter>)>)..::.CopyTo |
ICollection<(Of <(IFilter>)>)..::.Count |
IFilterCollection..::.Create | Creates a filter with the specified attributes.
IEnumerable<(Of <(IFilter>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator |
IList..::.IndexOf | Determines the index of a specific item in the IList. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
System#Collections#Generic#IList{T}#Insert | Inserts an item to the IList<(Of <(T>)>) at the specified index. This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
IList..::.Insert | Inserts an item to the IList at the specified index. This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
IList..::.IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
IsReadOnly | Overloaded.
IList..::.IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
ICollection..::.IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
System#Collections#Generic#IList{T}#Item | Gets or sets the element at the specified index. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
IList..::.Item | Gets or sets the element at the specified index. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
IKeyedCollection<(Of <(String, IFilter>)>)..::.Item |
Remove | Overloaded.
IList..::.Remove | Removes the first occurrence of a specific object from the IList. This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
System#Collections#Generic#IList{T}#RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index. This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
IList..::.RemoveAt | Removes the IList item at the specified index. This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
ICollection..::.SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)

See Also

ReadOnlyFilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


ReadOnlyFilterCollection Constructor

[image]

LinkOne WebView API
ReadOnlyFilterCollection Constructor
ReadOnlyFilterCollection Class See Also Send Feedback
Initializes a new instance of the ReadOnlyFilterCollection class.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ReadOnlyFilterCollection(
    FilterCollection filters
)
Visual Basic (Declaration)
Public Sub New ( _
    filters As FilterCollection _
)
Visual C++
public:
ReadOnlyFilterCollection(
    FilterCollection^ filters
)

Parameters

filters
Type: Mincom.LinkOne.Dom.Filtering..::.FilterCollection
The filters to wrap.

See Also

ReadOnlyFilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


ReadOnlyFilterCollection Methods

[image] [image]

LinkOne WebView API
ReadOnlyFilterCollection Methods
ReadOnlyFilterCollection Class See Also Send Feedback

The ReadOnlyFilterCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
CopyTo | Copies the entire ReadOnlyCollection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection<(Of <(T>)>). (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection<(Of <(T>)>). (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overriden. Returns a string representation of the collection. (Overrides Object..::.ToString()()().)

Explicit Interface Implementations

Name | Description
Add | Overloaded.
IList..::.Add | Adds an item to the IList. This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
Clear | Overloaded.
IList..::.Clear | Removes all items from the IList. This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
IList..::.Contains | Determines whether the IList contains a specific value. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
IKeyedCollection<(Of <(String, IFilter>)>)..::.Contains |
ICollection<(Of <(IFilter>)>)..::.Contains |
ICollection..::.CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
ICollection<(Of <(IFilter>)>)..::.CopyTo |
IFilterCollection..::.Create | Creates a filter with the specified attributes.
IEnumerable<(Of <(IFilter>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator |
IList..::.IndexOf | Determines the index of a specific item in the IList. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
System#Collections#Generic#IList{T}#Insert | Inserts an item to the IList<(Of <(T>)>) at the specified index. This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
IList..::.Insert | Inserts an item to the IList at the specified index. This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
Remove | Overloaded.
IList..::.Remove | Removes the first occurrence of a specific object from the IList. This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
System#Collections#Generic#IList{T}#RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index. This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
IList..::.RemoveAt | Removes the IList item at the specified index. This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)

See Also

ReadOnlyFilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


ICollection(IFilter).Contains Method

[image]

LinkOne WebView API
ReadOnlyFilterCollection..::.ICollection<(Of <(IFilter>)>)..::.Contains Method
ReadOnlyFilterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<IFilter>.Contains(
    IFilter filter
)
Visual Basic (Declaration)
Private Function Contains ( _
    filter As IFilter _
) As Boolean Implements ICollection(Of IFilter).Contains
Visual C++
private:
virtual bool Contains(
    IFilter^ filter
) sealed = ICollection<IFilter^>::Contains

Parameters

filter
Type: Mincom.LinkOne.Dom.Filtering..::.IFilter

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

ReadOnlyFilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


ICollection(IFilter).CopyTo Method

[image]

LinkOne WebView API
ReadOnlyFilterCollection..::.ICollection<(Of <(IFilter>)>)..::.CopyTo Method
ReadOnlyFilterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<IFilter>.CopyTo(
    IFilter[] array,
    int arrayIndex
)
Visual Basic (Declaration)
Private Sub CopyTo ( _
    array As IFilter(), _
    arrayIndex As Integer _
) Implements ICollection(Of IFilter).CopyTo
Visual C++
private:
virtual void CopyTo(
    array<IFilter^>^ array,
    int arrayIndex
) sealed = ICollection<IFilter^>::CopyTo

Parameters

array
Type: array< Mincom.LinkOne.Dom.Filtering..::.IFilter >[]()[]
arrayIndex
Type: System..::.Int32

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

ReadOnlyFilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


IEnumerable(IFilter).GetEnumerator Method

[image]

LinkOne WebView API
ReadOnlyFilterCollection..::.IEnumerable<(Of <(IFilter>)>)..::.GetEnumerator Method
ReadOnlyFilterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator<IFilter> IEnumerable<IFilter>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of IFilter)
    Implements IEnumerable(Of IFilter).GetEnumerator
Visual C++
private:
virtual IEnumerator<IFilter^>^ GetEnumerator() sealed = IEnumerable<IFilter^>::GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

ReadOnlyFilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
ReadOnlyFilterCollection..::.IEnumerable..::.GetEnumerator Method
ReadOnlyFilterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ReadOnlyFilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


Add Method

[image] [image]

LinkOne WebView API
ReadOnlyFilterCollection..::.Add Method
ReadOnlyFilterCollection Class See Also Send Feedback

Overload List

Name | Description
System#Collections#Generic#ICollection{T}#Add(UTP) | Adds an item to the ICollection<(Of <(T>)>). This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
ICollection<(Of <(IFilter>)>)..::.Add(IFilter) |

See Also

ReadOnlyFilterCollection Class
ReadOnlyFilterCollection Members
Mincom.LinkOne.Dom.Filtering Namespace


ICollection(IFilter).Add Method (IFilter)

[image]

LinkOne WebView API
ReadOnlyFilterCollection..::.ICollection<(Of <(IFilter>)>)..::.Add Method (IFilter)
ReadOnlyFilterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<IFilter>.Add(
    IFilter filter
)
Visual Basic (Declaration)
Private Sub Add ( _
    filter As IFilter _
) Implements ICollection(Of IFilter).Add
Visual C++
private:
virtual void Add(
    IFilter^ filter
) sealed = ICollection<IFilter^>::Add

Parameters

filter
Type: Mincom.LinkOne.Dom.Filtering..::.IFilter

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

ReadOnlyFilterCollection Class
ReadOnlyFilterCollection Overload
Mincom.LinkOne.Dom.Filtering Namespace


Clear Method

[image] [image]

LinkOne WebView API
ReadOnlyFilterCollection..::.Clear Method
ReadOnlyFilterCollection Class See Also Send Feedback

Overload List

Name | Description
System#Collections#Generic#ICollection{T}#Clear()()() | Removes all items from the ICollection<(Of <(T>)>). This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
ICollection<(Of <(IFilter>)>)..::.Clear()()() |

See Also

ReadOnlyFilterCollection Class
ReadOnlyFilterCollection Members
Mincom.LinkOne.Dom.Filtering Namespace


ICollection(IFilter).Clear Method

[image]

LinkOne WebView API
ReadOnlyFilterCollection..::.ICollection<(Of <(IFilter>)>)..::.Clear Method
ReadOnlyFilterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<IFilter>.Clear()
Visual Basic (Declaration)
Private Sub Clear Implements ICollection(Of IFilter).Clear
Visual C++
private:
virtual void Clear() sealed = ICollection<IFilter^>::Clear

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

See Also

ReadOnlyFilterCollection Class
ReadOnlyFilterCollection Overload
Mincom.LinkOne.Dom.Filtering Namespace


Contains Method

[image] [image]

LinkOne WebView API
ReadOnlyFilterCollection..::.Contains Method
ReadOnlyFilterCollection Class See Also Send Feedback

Overload List

Name | Description
Contains(T) | Determines whether an element is in the ReadOnlyCollection<(Of <(T>)>). (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
Contains(FilterType) | Determines whether a filter of the given FilterType.
Contains(String) | Determines whether an filter is in the collection.

See Also

ReadOnlyFilterCollection Class
ReadOnlyFilterCollection Members
Mincom.LinkOne.Dom.Filtering Namespace


Contains Method (FilterType)

[image]

LinkOne WebView API
ReadOnlyFilterCollection..::.Contains Method (FilterType)
ReadOnlyFilterCollection Class See Also Send Feedback
Determines whether a filter of the given FilterType.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    FilterType filterType
)
Visual Basic (Declaration)
Public Function Contains ( _
    filterType As FilterType _
) As Boolean
Visual C++
public:
bool Contains(
    FilterType filterType
)

Parameters

filterType
Type: Mincom.LinkOne.Dom.Filtering..::.FilterType
Tye type of filters to search for.

Return Value

true if found in the collection, otherwise, false.

See Also

ReadOnlyFilterCollection Class
Contains Overload
Mincom.LinkOne.Dom.Filtering Namespace


Contains Method (String)

[image]

LinkOne WebView API
ReadOnlyFilterCollection..::.Contains Method (String)
ReadOnlyFilterCollection Class See Also Send Feedback
Determines whether an filter is in the collection.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    string name
)
Visual Basic (Declaration)
Public Function Contains ( _
    name As String _
) As Boolean
Visual C++
public:
bool Contains(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the filter to search for.

Return Value

true if found in the collection, otherwise, false.

See Also

ReadOnlyFilterCollection Class
Contains Overload
Mincom.LinkOne.Dom.Filtering Namespace


IFilterCollection.Create Method

[image]

LinkOne WebView API
ReadOnlyFilterCollection..::.IFilterCollection..::.Create Method
ReadOnlyFilterCollection Class See Also Send Feedback
Creates a filter with the specified attributes.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IFilter IFilterCollection.Create(
    string name,
    string value,
    FilterType type,
    FilterScope scope,
    FilterAccess access
)
Visual Basic (Declaration)
Private Function Create ( _
    name As String, _
    value As String, _
    type As FilterType, _
    scope As FilterScope, _
    access As FilterAccess _
) As IFilter Implements IFilterCollection.Create
Visual C++
private:
virtual IFilter^ Create(
    String^ name,
    String^ value,
    FilterType type,
    FilterScope scope,
    FilterAccess access
) sealed = IFilterCollection::Create

Parameters

name
Type: System..::.String
The name.
value
Type: System..::.String
The value.
type
Type: Mincom.LinkOne.Dom.Filtering..::.FilterType
The type.
scope
Type: Mincom.LinkOne.Dom.Filtering..::.FilterScope
The scope.
access
Type: Mincom.LinkOne.Dom.Filtering..::.FilterAccess
The access.

Return Value

A new IFilter with the specified attributes.

Implements

IFilterCollection..::.Create(String, String, FilterType, FilterScope, FilterAccess)

See Also

ReadOnlyFilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


IKeyedCollection(String, IFilter).Contains Method

[image]

LinkOne WebView API
ReadOnlyFilterCollection..::.IKeyedCollection<(Of <(String, IFilter>)>)..::.Contains Method
ReadOnlyFilterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IKeyedCollection<string, IFilter>.Contains(
    string filterName
)
Visual Basic (Declaration)
Private Function Contains ( _
    filterName As String _
) As Boolean Implements IKeyedCollection(Of String, IFilter).Contains
Visual C++
private:
virtual bool Contains(
    String^ filterName
) sealed = IKeyedCollection<String^, IFilter^>::Contains

Parameters

filterName
Type: System..::.String

Implements

IKeyedCollection<(Of <(TKey, TItem>)>)..::.Contains(TKey)

See Also

ReadOnlyFilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


Remove Method

[image] [image]

LinkOne WebView API
ReadOnlyFilterCollection..::.Remove Method
ReadOnlyFilterCollection Class See Also Send Feedback

Overload List

Name | Description
System#Collections#Generic#ICollection{T}#Remove(UTP) | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
ICollection<(Of <(IFilter>)>)..::.Remove(IFilter) |

See Also

ReadOnlyFilterCollection Class
ReadOnlyFilterCollection Members
Mincom.LinkOne.Dom.Filtering Namespace


ICollection(IFilter).Remove Method (IFilter)

[image]

LinkOne WebView API
ReadOnlyFilterCollection..::.ICollection<(Of <(IFilter>)>)..::.Remove Method (IFilter)
ReadOnlyFilterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<IFilter>.Remove(
    IFilter filter
)
Visual Basic (Declaration)
Private Function Remove ( _
    filter As IFilter _
) As Boolean Implements ICollection(Of IFilter).Remove
Visual C++
private:
virtual bool Remove(
    IFilter^ filter
) sealed = ICollection<IFilter^>::Remove

Parameters

filter
Type: Mincom.LinkOne.Dom.Filtering..::.IFilter

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

ReadOnlyFilterCollection Class
ReadOnlyFilterCollection Overload
Mincom.LinkOne.Dom.Filtering Namespace


ToString Method

[image]

LinkOne WebView API
ReadOnlyFilterCollection..::.ToString Method
ReadOnlyFilterCollection Class See Also Send Feedback
Overriden. Returns a string representation of the collection.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A string representation of the collection.

Remarks

The format is in Filter1,Filter2,...

See Also

ReadOnlyFilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


ReadOnlyFilterCollection Properties

[image] [image]

LinkOne WebView API
ReadOnlyFilterCollection Properties
ReadOnlyFilterCollection Class See Also Send Feedback

The ReadOnlyFilterCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection<(Of <(T>)>) instance. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
Item | Overloaded.
Items | Returns the IList<(Of <(T>)>) that the ReadOnlyCollection<(Of <(T>)>) wraps. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
LanguageOption | See LanguageOption for more information.
ShowSupersededEntries | Gets or sets true to show superseded entries.
SpecificQuery | See SpecificQuery for more information.

Explicit Interface Implementations

Name | Description
ICollection<(Of <(IFilter>)>)..::.Count |
IList..::.IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
IsReadOnly | Overloaded.
IList..::.IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
ICollection..::.IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
System#Collections#Generic#IList{T}#Item | Gets or sets the element at the specified index. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
IList..::.Item | Gets or sets the element at the specified index. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
IKeyedCollection<(Of <(String, IFilter>)>)..::.Item |
ICollection..::.SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)

See Also

ReadOnlyFilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


ICollection(IFilter).Count Property

[image]

LinkOne WebView API
ReadOnlyFilterCollection..::.ICollection<(Of <(IFilter>)>)..::.Count Property
ReadOnlyFilterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int ICollection<IFilter>.Count { get; }
Visual Basic (Declaration)
Private ReadOnly Property Count As Integer
    Implements ICollection(Of IFilter).Count
Visual C++
private:
virtual property int Count {
    int get () sealed = ICollection<IFilter^>::Count::get;
}

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

ReadOnlyFilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


IKeyedCollection(String, IFilter).Item Property

[image]

LinkOne WebView API
ReadOnlyFilterCollection..::.IKeyedCollection<(Of <(String, IFilter>)>)..::.Item Property
ReadOnlyFilterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IFilter IKeyedCollection<string, IFilter>.Item[
    string filterName
] { get; set; }
Visual Basic (Declaration)
Private Property Item ( _
    filterName As String _
) As IFilter Implements IKeyedCollection(Of String, IFilter).Item
Visual C++
private:
virtual property IFilter^ Item[String^ filterName] {
    IFilter^ get (String^ filterName) sealed = IKeyedCollection<String^, IFilter^>::Item::get;
    void set (String^ filterName, IFilter^ value) sealed = IKeyedCollection<String^, IFilter^>::Item::set;
}

Parameters

filterName
Type: System..::.String

Implements

IKeyedCollection<(Of <(TKey, TItem>)>)..::.Item[([(TKey])])

See Also

ReadOnlyFilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


IsReadOnly Property

[image] [image]

LinkOne WebView API
ReadOnlyFilterCollection..::.IsReadOnly Property
ReadOnlyFilterCollection Class See Also Send Feedback

Overload List

Name | Description
System#Collections#Generic#ICollection{T}#IsReadOnly()()() | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
ICollection<(Of <(IFilter>)>)..::.IsReadOnly |

See Also

ReadOnlyFilterCollection Class
ReadOnlyFilterCollection Members
Mincom.LinkOne.Dom.Filtering Namespace


ICollection(IFilter).IsReadOnly Property

[image]

LinkOne WebView API
ReadOnlyFilterCollection..::.ICollection<(Of <(IFilter>)>)..::.IsReadOnly Property
ReadOnlyFilterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<IFilter>.IsReadOnly { get; }
Visual Basic (Declaration)
Private ReadOnly Property IsReadOnly As Boolean
    Implements ICollection(Of IFilter).IsReadOnly
Visual C++
private:
virtual property bool IsReadOnly {
    bool get () sealed = ICollection<IFilter^>::IsReadOnly::get;
}

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

ReadOnlyFilterCollection Class
ReadOnlyFilterCollection Overload
Mincom.LinkOne.Dom.Filtering Namespace


Item Property

[image] [image]

LinkOne WebView API
ReadOnlyFilterCollection..::.Item Property
ReadOnlyFilterCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Gets the element at the specified index. (Inherited from ReadOnlyCollection<(Of <( Filter >)>).)
Item[([(String])]) | Gets the Filter with the specified name.

See Also

ReadOnlyFilterCollection Class
ReadOnlyFilterCollection Members
Mincom.LinkOne.Dom.Filtering Namespace


Item Property (String)

[image]

LinkOne WebView API
ReadOnlyFilterCollection..::.Item Property (String)
ReadOnlyFilterCollection Class See Also Send Feedback
Gets the Filter with the specified name.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IFilter this[
    string name
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    name As String _
) As IFilter
Visual C++
public:
property IFilter^ default[String^ name] {
    IFilter^ get (String^ name);
    void set (String^ name, IFilter^ value);
}

Parameters

name
Type: System..::.String

Exceptions

Exception | Condition
System..::.NotSupportedException | Always thrown, if the property is set.

See Also

ReadOnlyFilterCollection Class
Item Overload
Mincom.LinkOne.Dom.Filtering Namespace


LanguageOption Property

[image]

LinkOne WebView API
ReadOnlyFilterCollection..::.LanguageOption Property
ReadOnlyFilterCollection Class See Also Send Feedback
See LanguageOption for more information.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string LanguageOption { get; }
Visual Basic (Declaration)
Public ReadOnly Property LanguageOption As String
Visual C++
public:
property String^ LanguageOption {
    String^ get ();
}

See Also

ReadOnlyFilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


ShowSupersededEntries Property

[image]

LinkOne WebView API
ReadOnlyFilterCollection..::.ShowSupersededEntries Property
ReadOnlyFilterCollection Class See Also Send Feedback
Gets or sets true to show superseded entries.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool ShowSupersededEntries { get; }
Visual Basic (Declaration)
Public ReadOnly Property ShowSupersededEntries As Boolean
Visual C++
public:
property bool ShowSupersededEntries {
    bool get ();
}

Remarks

Setting the property to true results in a Predefined Private Book filter named "S" and valued ON being set in the collection.

See Also

ReadOnlyFilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


SpecificQuery Property

[image]

LinkOne WebView API
ReadOnlyFilterCollection..::.SpecificQuery Property
ReadOnlyFilterCollection Class See Also Send Feedback
See SpecificQuery for more information.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool SpecificQuery { get; }
Visual Basic (Declaration)
Public ReadOnly Property SpecificQuery As Boolean
Visual C++
public:
property bool SpecificQuery {
    bool get ();
}

See Also

ReadOnlyFilterCollection Class
Mincom.LinkOne.Dom.Filtering Namespace


SelectOption Class

[image]

LinkOne WebView API
SelectOption Class
Members See Also Send Feedback
Represents a LinkOne Select Option.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class SelectOption : Option
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class SelectOption _
    Inherits Option
Visual C++
[SerializableAttribute]
public ref class SelectOption sealed : public Option

Remarks

A select option causes information to be filtered out of a LinkOne book if the option value does not match the nominated select value.

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Filtering..::.Option
Mincom.LinkOne.Dom.Filtering..::.SelectOption

See Also

SelectOption Members
Mincom.LinkOne.Dom.Filtering Namespace


SelectOption Members

[image] [image]

LinkOne WebView API
SelectOption Members
SelectOption Class Constructors Methods Properties See Also Send Feedback

The SelectOption type exposes the following members.

Constructors

Name | Description
SelectOption | Initializes a new instance of the SelectOption class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Name | The name of the option. (Inherited from Option.)
Value | Gets the value of the option. (Overrides Option..::.Value.)
Values | Gets or sets the values of the select option. This property does not validate that the supplied value is a legal value according to the corresponding SelectOptionDefinition.

See Also

SelectOption Class
Mincom.LinkOne.Dom.Filtering Namespace


SelectOption Constructor

[image]

LinkOne WebView API
SelectOption Constructor
SelectOption Class See Also Send Feedback
Initializes a new instance of the SelectOption class.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SelectOption(
    IDomReader domReader
)
Visual Basic (Declaration)
Public Sub New ( _
    domReader As IDomReader _
)
Visual C++
public:
SelectOption(
    IDomReader^ domReader
)

Parameters

domReader
Type: IDomReader
The DOM reader.

See Also

SelectOption Class
Mincom.LinkOne.Dom.Filtering Namespace


SelectOption Methods

[image] [image]

LinkOne WebView API
SelectOption Methods
SelectOption Class See Also Send Feedback

The SelectOption type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SelectOption Class
Mincom.LinkOne.Dom.Filtering Namespace


SelectOption Properties

[image] [image]

LinkOne WebView API
SelectOption Properties
SelectOption Class See Also Send Feedback

The SelectOption type exposes the following members.

Properties

Name | Description
Name | The name of the option. (Inherited from Option.)
Value | Gets the value of the option. (Overrides Option..::.Value.)
Values | Gets or sets the values of the select option. This property does not validate that the supplied value is a legal value according to the corresponding SelectOptionDefinition.

See Also

SelectOption Class
Mincom.LinkOne.Dom.Filtering Namespace


Value Property

[image]

LinkOne WebView API
SelectOption..::.Value Property
SelectOption Class See Also Send Feedback
Gets the value of the option.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string Value { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Value As String
Visual C++
public:
virtual property String^ Value {
    String^ get () override;
}

Implements

IOption..::.Value

See Also

SelectOption Class
Mincom.LinkOne.Dom.Filtering Namespace


Values Property

[image]

LinkOne WebView API
SelectOption..::.Values Property
SelectOption Class See Also Send Feedback
Gets or sets the values of the select option. This property does not validate that the supplied value is a legal value according to the corresponding SelectOptionDefinition.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public List<string> Values { get; }
Visual Basic (Declaration)
Public ReadOnly Property Values As List(Of String)
Visual C++
public:
property List<String^>^ Values {
    List<String^>^ get ();
}

See Also

SelectOption Class
Mincom.LinkOne.Dom.Filtering Namespace


SelectOptionDefinition Class

[image]

LinkOne WebView API
SelectOptionDefinition Class
Members See Also Send Feedback
Represents the Option Definition for a LinkOne Select option.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class SelectOptionDefinition : OptionDefinition
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class SelectOptionDefinition _
    Inherits OptionDefinition
Visual C++
[SerializableAttribute]
public ref class SelectOptionDefinition sealed : public OptionDefinition

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Filtering..::.OptionDefinition
Mincom.LinkOne.Dom.Filtering..::.SelectOptionDefinition

See Also

SelectOptionDefinition Members
Mincom.LinkOne.Dom.Filtering Namespace


SelectOptionDefinition Members

[image] [image]

LinkOne WebView API
SelectOptionDefinition Members
SelectOptionDefinition Class Constructors Methods Properties See Also Send Feedback

The SelectOptionDefinition type exposes the following members.

Constructors

Name | Description
SelectOptionDefinition | Initialises a new instance of the SelectOptionDefinition class from a Reader object.

Methods

Name | Description
ContainsSelectValue | Returns true if the SelectionOptionDefinition contains a definition for the specified SelectOption value.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Code | Gets the option definition code. (Inherited from OptionDefinition.)
Description | Gets the option definition description. (Inherited from OptionDefinition.)
SelectValues | Returns an enumerator that enumerates through the list of valid SelectOption values.

See Also

SelectOptionDefinition Class
Mincom.LinkOne.Dom.Filtering Namespace


SelectOptionDefinition Constructor

[image]

LinkOne WebView API
SelectOptionDefinition Constructor
SelectOptionDefinition Class See Also Send Feedback
Initialises a new instance of the SelectOptionDefinition class from a Reader object.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SelectOptionDefinition(
    IOptionDefinitionReader domReader
)
Visual Basic (Declaration)
Public Sub New ( _
    domReader As IOptionDefinitionReader _
)
Visual C++
public:
SelectOptionDefinition(
    IOptionDefinitionReader^ domReader
)

Parameters

domReader
Type: IOptionDefinitionReader
The Reader providing the data to populate this object.

See Also

SelectOptionDefinition Class
Mincom.LinkOne.Dom.Filtering Namespace


SelectOptionDefinition Methods

[image] [image]

LinkOne WebView API
SelectOptionDefinition Methods
SelectOptionDefinition Class See Also Send Feedback

The SelectOptionDefinition type exposes the following members.

Methods

Name | Description
ContainsSelectValue | Returns true if the SelectionOptionDefinition contains a definition for the specified SelectOption value.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SelectOptionDefinition Class
Mincom.LinkOne.Dom.Filtering Namespace


ContainsSelectValue Method

[image]

LinkOne WebView API
SelectOptionDefinition..::.ContainsSelectValue Method
SelectOptionDefinition Class See Also Send Feedback
Returns true if the SelectionOptionDefinition contains a definition for the specified SelectOption value.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool ContainsSelectValue(
    string value
)
Visual Basic (Declaration)
Public Function ContainsSelectValue ( _
    value As String _
) As Boolean
Visual C++
public:
bool ContainsSelectValue(
    String^ value
)

Parameters

value
Type: System..::.String

See Also

SelectOptionDefinition Class
Mincom.LinkOne.Dom.Filtering Namespace


SelectOptionDefinition Properties

[image] [image]

LinkOne WebView API
SelectOptionDefinition Properties
SelectOptionDefinition Class See Also Send Feedback

The SelectOptionDefinition type exposes the following members.

Properties

Name | Description
Code | Gets the option definition code. (Inherited from OptionDefinition.)
Description | Gets the option definition description. (Inherited from OptionDefinition.)
SelectValues | Returns an enumerator that enumerates through the list of valid SelectOption values.

See Also

SelectOptionDefinition Class
Mincom.LinkOne.Dom.Filtering Namespace


SelectValues Property

[image]

LinkOne WebView API
SelectOptionDefinition..::.SelectValues Property
SelectOptionDefinition Class See Also Send Feedback
Returns an enumerator that enumerates through the list of valid SelectOption values.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IList<string> SelectValues { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectValues As IList(Of String)
Visual C++
public:
property IList<String^>^ SelectValues {
    IList<String^>^ get ();
}

See Also

SelectOptionDefinition Class
Mincom.LinkOne.Dom.Filtering Namespace


SwitchOption Class

[image]

LinkOne WebView API
SwitchOption Class
Members See Also Send Feedback
Represents a LinkOne Switch Option.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class SwitchOption : Option
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class SwitchOption _
    Inherits Option
Visual C++
[SerializableAttribute]
public ref class SwitchOption sealed : public Option

Remarks

A switch option may have the string value "ON" or "OFF". A switch option causes information to be filtered out of a LinkOne book if the option value does not match the nominated switch value.

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Filtering..::.Option
Mincom.LinkOne.Dom.Filtering..::.SwitchOption

See Also

SwitchOption Members
Mincom.LinkOne.Dom.Filtering Namespace


SwitchOption Members

[image] [image]

LinkOne WebView API
SwitchOption Members
SwitchOption Class Constructors Methods Properties See Also Send Feedback

The SwitchOption type exposes the following members.

Constructors

Name | Description
SwitchOption | Initializes a new instance of the SwitchOption class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Name | The name of the option. (Inherited from Option.)
Value | Gets the value of the option. (Overrides Option..::.Value.)

See Also

SwitchOption Class
Mincom.LinkOne.Dom.Filtering Namespace


SwitchOption Constructor

[image]

LinkOne WebView API
SwitchOption Constructor
SwitchOption Class See Also Send Feedback
Initializes a new instance of the SwitchOption class.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SwitchOption(
    IDomReader domReader
)
Visual Basic (Declaration)
Public Sub New ( _
    domReader As IDomReader _
)
Visual C++
public:
SwitchOption(
    IDomReader^ domReader
)

Parameters

domReader
Type: IDomReader
The Reader providing the data to populate this object.

See Also

SwitchOption Class
Mincom.LinkOne.Dom.Filtering Namespace


SwitchOption Methods

[image] [image]

LinkOne WebView API
SwitchOption Methods
SwitchOption Class See Also Send Feedback

The SwitchOption type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SwitchOption Class
Mincom.LinkOne.Dom.Filtering Namespace


SwitchOption Properties

[image] [image]

LinkOne WebView API
SwitchOption Properties
SwitchOption Class See Also Send Feedback

The SwitchOption type exposes the following members.

Properties

Name | Description
Name | The name of the option. (Inherited from Option.)
Value | Gets the value of the option. (Overrides Option..::.Value.)

See Also

SwitchOption Class
Mincom.LinkOne.Dom.Filtering Namespace


Value Property

[image]

LinkOne WebView API
SwitchOption..::.Value Property
SwitchOption Class See Also Send Feedback
Gets the value of the option.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string Value { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Value As String
Visual C++
public:
virtual property String^ Value {
    String^ get () override;
}

Implements

IOption..::.Value

See Also

SwitchOption Class
Mincom.LinkOne.Dom.Filtering Namespace


SwitchOptionDefinition Class

[image]

LinkOne WebView API
SwitchOptionDefinition Class
Members See Also Send Feedback
Represents the Option Definition for a LinkOne Select option.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class SwitchOptionDefinition : OptionDefinition
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class SwitchOptionDefinition _
    Inherits OptionDefinition
Visual C++
[SerializableAttribute]
public ref class SwitchOptionDefinition sealed : public OptionDefinition

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Filtering..::.OptionDefinition
Mincom.LinkOne.Dom.Filtering..::.SwitchOptionDefinition

See Also

SwitchOptionDefinition Members
Mincom.LinkOne.Dom.Filtering Namespace


SwitchOptionDefinition Members

[image] [image]

LinkOne WebView API
SwitchOptionDefinition Members
SwitchOptionDefinition Class Constructors Methods Properties See Also Send Feedback

The SwitchOptionDefinition type exposes the following members.

Constructors

Name | Description
SwitchOptionDefinition | Initialises a new instance of the RangeOptionDefinition class from a Reader object.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Code | Gets the option definition code. (Inherited from OptionDefinition.)
Description | Gets the option definition description. (Inherited from OptionDefinition.)

See Also

SwitchOptionDefinition Class
Mincom.LinkOne.Dom.Filtering Namespace


SwitchOptionDefinition Constructor

[image]

LinkOne WebView API
SwitchOptionDefinition Constructor
SwitchOptionDefinition Class See Also Send Feedback
Initialises a new instance of the RangeOptionDefinition class from a Reader object.

Namespace: Mincom.LinkOne.Dom.Filtering
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SwitchOptionDefinition(
    IOptionDefinitionReader domReader
)
Visual Basic (Declaration)
Public Sub New ( _
    domReader As IOptionDefinitionReader _
)
Visual C++
public:
SwitchOptionDefinition(
    IOptionDefinitionReader^ domReader
)

Parameters

domReader
Type: IOptionDefinitionReader
The Reader providing the data to populate this object.

See Also

SwitchOptionDefinition Class
Mincom.LinkOne.Dom.Filtering Namespace


SwitchOptionDefinition Methods

[image] [image]

LinkOne WebView API
SwitchOptionDefinition Methods
SwitchOptionDefinition Class See Also Send Feedback

The SwitchOptionDefinition type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SwitchOptionDefinition Class
Mincom.LinkOne.Dom.Filtering Namespace


SwitchOptionDefinition Properties

[image] [image]

LinkOne WebView API
SwitchOptionDefinition Properties
SwitchOptionDefinition Class See Also Send Feedback

The SwitchOptionDefinition type exposes the following members.

Properties

Name | Description
Code | Gets the option definition code. (Inherited from OptionDefinition.)
Description | Gets the option definition description. (Inherited from OptionDefinition.)

See Also

SwitchOptionDefinition Class
Mincom.LinkOne.Dom.Filtering Namespace


Mincom.LinkOne.Dom.Layouts Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.Dom.Layouts Namespace
Send Feedback
The Mincom.LinkOne.Dom.Layouts namespace contains classes that provide read/write access to LinkOne layouts.

Classes

Class | Description
BookField | Represents a book field in a layout cell.
BorderAttributes | Attributes that specify which borders are to be drawn.
Cell | Represents a cell in a layout table row.
Dimension | Represents a length (or size) value in a layout.
EntryField | Represents a parts list entry field in a layout cell.
FontAttributes | Specifies text font attributes.
Format | Represents a format in a layout. Formats consist of a layout table, and optional column headings.
FormatCollection | Represents a collection of Format objects that can be accessed by index.
Heading | Represents the column headings for a format. Column headings are just a layout table.
Layout | A LinkOne Layout, defines the format of the parts list for screen and printing.
LayoutCollection | Represents a collection of Layout objects that can be accessed by index.
LayoutTable | Represents a table (such as a format, column headings, embedded tables, etc) in a layout. A layout table consists of a collection of rows.
ListField | Represents a parts list field in a layout cell.
LiteralText | Represents a constant text field in a layout cell.
Margins | Describe the border margins for a layout object.
Picture | Represents a picture in a layout cell.
PictureField | Represents a picture field in a layout cell.
Preferred |
PreferredCollection |
Row | Represents a row in a layout table. Layout table rows consist of cells.
RuleAttributes | Attributes that specify which rules are to be drawn.
Table | Represents an embedded table in a layout cell.
TextFormat | Encapsulates the components of a format string.
ValueNote | Represents a value note in a layout cell.

Interfaces

Interface | Description
IBookField | Represents a book field in a layout cell.
IBorderAttributes | Attributes that specify which borders are to be drawn.
ICell | Represents a cell in a layout table row.
ICellContents | Represents the contents of a layout cell.
IDimension | Represents a length (or size) value in a layout.
IEntryField | Represents a parts list entry field in a layout cell.
IFontAttributes | Specifies text font attributes.
IFormat | Represents a format in a layout. Formats consist of a layout table, and optional column headings.
IFormatCollection | Represents a collection of IFormat objects that can be accessed by index.
IHeading | Represents the column headings for a format. Column headings are just a layout table.
ILayout | A LinkOne Layout, defines the format of the parts list for screen and printing.
ILayoutCollection | Represents a collection of ILayout objects that can be accessed by index.
ILayoutTable | Represents a table (such as a format, column headings, embedded tables, etc) in a layout. A layout table consists of a collection of rows.
IListField | Represents a parts list field in a layout cell.
ILiteralText | Represents a constant text field in a layout cell.
IMargins | Describe the border margins for a layout object.
IPicture | Represents a picture in a layout cell.
IPictureField | Represents a picture field in a layout cell.
IPreferred |
IPreferredCollection |
IRow | Represents a row in a layout table. Layout table rows consist of cells.
IRuleAttributes | Attributes that specify which rules are to be drawn.
ITable | Represents a table in a layout cell.
ITextFormat | Encapsulates the components of a format string.
IValueNote | Represents a value note in a layout cell.

Enumerations

Enumeration | Description
DimensionUnit | Allowable values for length dimensions.
HorizontalAlignment | Allowed values for horizontal text alignment.
LayoutFacing | Values for specifying which side sheet are facing.
LayoutPageOrderCode | Values for specifying the page order of a printed sheet.
LayoutRepeatSheetCode | Values for specifying how blank sheets are used when page order is interleaved.
LayoutSourceType | The source of the layout.
LayoutType | Values for the type of layout to use.
Pitch | Values for specifying whether cell text is fixed or variable pitch.
SheetFacing | Represents the side of the sheet the layout is for.
TextFormatSpecifier | Specifies formatting for numeric fields.
VerticalAlignment | Allowed values for vertical text alignment.
Weight | Values for specifying the font weight.


BookField Class

[image]

LinkOne WebView API
BookField Class
Members See Also Send Feedback
Represents a book field in a layout cell.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class BookField : IBookField,
    ICellContents
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class BookField _
    Implements IBookField, ICellContents
Visual C++
[SerializableAttribute]
public ref class BookField sealed : IBookField,
    ICellContents

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Layouts..::.BookField

See Also

BookField Members
Mincom.LinkOne.Dom.Layouts Namespace


BookField Members

[image] [image]

LinkOne WebView API
BookField Members
BookField Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The BookField type exposes the following members.

Constructors

Name | Description
BookField | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Name | The name of the book field.

Explicit Interface Implementations

Name | Description
IBookField..::.Name |

See Also

BookField Class
Mincom.LinkOne.Dom.Layouts Namespace


BookField Constructor

[image] [image]

LinkOne WebView API
BookField Constructor
BookField Class See Also Send Feedback

Overload List

Name | Description
BookField()()() | Initializes a new instance of the BookField class.
BookField(String) | Initializes a new instance of the BookField class.

See Also

BookField Class
BookField Members
Mincom.LinkOne.Dom.Layouts Namespace


BookField Constructor

[image]

LinkOne WebView API
BookField Constructor
BookField Class See Also Send Feedback
Initializes a new instance of the BookField class.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookField()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BookField()

See Also

BookField Class
BookField Overload
Mincom.LinkOne.Dom.Layouts Namespace


BookField Constructor (String)

[image]

LinkOne WebView API
BookField Constructor (String)
BookField Class See Also Send Feedback
Initializes a new instance of the BookField class.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookField(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)
Visual C++
public:
BookField(
    String^ name
)

Parameters

name
Type: System..::.String
The name fo the book field.

See Also

BookField Class
BookField Overload
Mincom.LinkOne.Dom.Layouts Namespace


BookField Methods

[image] [image]

LinkOne WebView API
BookField Methods
BookField Class See Also Send Feedback

The BookField type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BookField Class
Mincom.LinkOne.Dom.Layouts Namespace


BookField Properties

[image] [image]

LinkOne WebView API
BookField Properties
BookField Class See Also Send Feedback

The BookField type exposes the following members.

Properties

Name | Description
Name | The name of the book field.

Explicit Interface Implementations

Name | Description
IBookField..::.Name |

See Also

BookField Class
Mincom.LinkOne.Dom.Layouts Namespace


IBookField.Name Property

[image]

LinkOne WebView API
BookField..::.IBookField..::.Name Property
BookField Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string IBookField.Name { get; set; }
Visual Basic (Declaration)
Private Property Name As String Implements IBookField.Name
Visual C++
private:
virtual property String^ Name {
    String^ get () sealed = IBookField::Name::get;
    void set (String^ value) sealed = IBookField::Name::set;
}

Implements

IBookField..::.Name

See Also

BookField Class
Mincom.LinkOne.Dom.Layouts Namespace


Name Property

[image]

LinkOne WebView API
BookField..::.Name Property
BookField Class See Also Send Feedback
The name of the book field.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The book field name.

See Also

BookField Class
Mincom.LinkOne.Dom.Layouts Namespace


BorderAttributes Class

[image]

LinkOne WebView API
BorderAttributes Class
Members See Also Send Feedback
Attributes that specify which borders are to be drawn.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public class BorderAttributes : IBorderAttributes
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class BorderAttributes _
    Implements IBorderAttributes
Visual C++
[SerializableAttribute]
public ref class BorderAttributes : IBorderAttributes

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Layouts..::.BorderAttributes

See Also

BorderAttributes Members
Mincom.LinkOne.Dom.Layouts Namespace


BorderAttributes Members

[image] [image]

LinkOne WebView API
BorderAttributes Members
BorderAttributes Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The BorderAttributes type exposes the following members.

Constructors

Name | Description
BorderAttributes | Initializes a new instance of the BorderAttributes class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Border | Gets or sets the borders dimensions.
Bottom | Gets or sets the Bottom border dimension.
Left | Gets or sets the Left border dimension.
Right | Gets or sets the Right border dimension.
Top | Gets or sets the Top border dimension.

Explicit Interface Implementations

Name | Description
IBorderAttributes..::.Border |
IBorderAttributes..::.Bottom |
IBorderAttributes..::.Left |
IBorderAttributes..::.Right |
IBorderAttributes..::.Top |

See Also

BorderAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


BorderAttributes Constructor

[image]

LinkOne WebView API
BorderAttributes Constructor
BorderAttributes Class See Also Send Feedback
Initializes a new instance of the BorderAttributes class

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BorderAttributes()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BorderAttributes()

See Also

BorderAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


BorderAttributes Methods

[image] [image]

LinkOne WebView API
BorderAttributes Methods
BorderAttributes Class See Also Send Feedback

The BorderAttributes type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BorderAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


BorderAttributes Properties

[image] [image]

LinkOne WebView API
BorderAttributes Properties
BorderAttributes Class See Also Send Feedback

The BorderAttributes type exposes the following members.

Properties

Name | Description
Border | Gets or sets the borders dimensions.
Bottom | Gets or sets the Bottom border dimension.
Left | Gets or sets the Left border dimension.
Right | Gets or sets the Right border dimension.
Top | Gets or sets the Top border dimension.

Explicit Interface Implementations

Name | Description
IBorderAttributes..::.Border |
IBorderAttributes..::.Bottom |
IBorderAttributes..::.Left |
IBorderAttributes..::.Right |
IBorderAttributes..::.Top |

See Also

BorderAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


Border Property

[image]

LinkOne WebView API
BorderAttributes..::.Border Property
BorderAttributes Class See Also Send Feedback
Gets or sets the borders dimensions.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Dimension Border { get; set; }
Visual Basic (Declaration)
Public Property Border As Dimension
Visual C++
public:
property Dimension^ Border {
    Dimension^ get ();
    void set (Dimension^ value);
}

See Also

BorderAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


Bottom Property

[image]

LinkOne WebView API
BorderAttributes..::.Bottom Property
BorderAttributes Class See Also Send Feedback
Gets or sets the Bottom border dimension.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Dimension Bottom { get; set; }
Visual Basic (Declaration)
Public Property Bottom As Dimension
Visual C++
public:
property Dimension^ Bottom {
    Dimension^ get ();
    void set (Dimension^ value);
}

See Also

BorderAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


IBorderAttributes.Border Property

[image]

LinkOne WebView API
BorderAttributes..::.IBorderAttributes..::.Border Property
BorderAttributes Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension IBorderAttributes.Border { get; set; }
Visual Basic (Declaration)
Private Property Border As IDimension Implements IBorderAttributes.Border
Visual C++
private:
virtual property IDimension^ Border {
    IDimension^ get () sealed = IBorderAttributes::Border::get;
    void set (IDimension^ value) sealed = IBorderAttributes::Border::set;
}

Implements

IBorderAttributes..::.Border

See Also

BorderAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


IBorderAttributes.Bottom Property

[image]

LinkOne WebView API
BorderAttributes..::.IBorderAttributes..::.Bottom Property
BorderAttributes Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension IBorderAttributes.Bottom { get; set; }
Visual Basic (Declaration)
Private Property Bottom As IDimension Implements IBorderAttributes.Bottom
Visual C++
private:
virtual property IDimension^ Bottom {
    IDimension^ get () sealed = IBorderAttributes::Bottom::get;
    void set (IDimension^ value) sealed = IBorderAttributes::Bottom::set;
}

Implements

IBorderAttributes..::.Bottom

See Also

BorderAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


IBorderAttributes.Left Property

[image]

LinkOne WebView API
BorderAttributes..::.IBorderAttributes..::.Left Property
BorderAttributes Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension IBorderAttributes.Left { get; set; }
Visual Basic (Declaration)
Private Property Left As IDimension Implements IBorderAttributes.Left
Visual C++
private:
virtual property IDimension^ Left {
    IDimension^ get () sealed = IBorderAttributes::Left::get;
    void set (IDimension^ value) sealed = IBorderAttributes::Left::set;
}

Implements

IBorderAttributes..::.Left

See Also

BorderAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


IBorderAttributes.Right Property

[image]

LinkOne WebView API
BorderAttributes..::.IBorderAttributes..::.Right Property
BorderAttributes Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension IBorderAttributes.Right { get; set; }
Visual Basic (Declaration)
Private Property Right As IDimension Implements IBorderAttributes.Right
Visual C++
private:
virtual property IDimension^ Right {
    IDimension^ get () sealed = IBorderAttributes::Right::get;
    void set (IDimension^ value) sealed = IBorderAttributes::Right::set;
}

Implements

IBorderAttributes..::.Right

See Also

BorderAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


IBorderAttributes.Top Property

[image]

LinkOne WebView API
BorderAttributes..::.IBorderAttributes..::.Top Property
BorderAttributes Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension IBorderAttributes.Top { get; set; }
Visual Basic (Declaration)
Private Property Top As IDimension Implements IBorderAttributes.Top
Visual C++
private:
virtual property IDimension^ Top {
    IDimension^ get () sealed = IBorderAttributes::Top::get;
    void set (IDimension^ value) sealed = IBorderAttributes::Top::set;
}

Implements

IBorderAttributes..::.Top

See Also

BorderAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


Left Property

[image]

LinkOne WebView API
BorderAttributes..::.Left Property
BorderAttributes Class See Also Send Feedback
Gets or sets the Left border dimension.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Dimension Left { get; set; }
Visual Basic (Declaration)
Public Property Left As Dimension
Visual C++
public:
property Dimension^ Left {
    Dimension^ get ();
    void set (Dimension^ value);
}

See Also

BorderAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


Right Property

[image]

LinkOne WebView API
BorderAttributes..::.Right Property
BorderAttributes Class See Also Send Feedback
Gets or sets the Right border dimension.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Dimension Right { get; set; }
Visual Basic (Declaration)
Public Property Right As Dimension
Visual C++
public:
property Dimension^ Right {
    Dimension^ get ();
    void set (Dimension^ value);
}

See Also

BorderAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


Top Property

[image]

LinkOne WebView API
BorderAttributes..::.Top Property
BorderAttributes Class See Also Send Feedback
Gets or sets the Top border dimension.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Dimension Top { get; set; }
Visual Basic (Declaration)
Public Property Top As Dimension
Visual C++
public:
property Dimension^ Top {
    Dimension^ get ();
    void set (Dimension^ value);
}

See Also

BorderAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


Cell Class

[image]

LinkOne WebView API
Cell Class
Members See Also Send Feedback
Represents a cell in a layout table row.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public class Cell : ICell
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class Cell _
    Implements ICell
Visual C++
[SerializableAttribute]
public ref class Cell : ICell

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Layouts..::.Cell

See Also

Cell Members
Mincom.LinkOne.Dom.Layouts Namespace


Cell Members

[image] [image]

LinkOne WebView API
Cell Members
Cell Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The Cell type exposes the following members.

Constructors

Name | Description
Cell | Initializes a new instance of the Cell class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Alignment | Gets or sets the cell horizontal alignment property
Blank | Gets or sets the cell blank property
Border | Gets cell border attribute
ColGap | Gets or sets the cell col gap
ColSpan | Gets or sets the cell col span
ColumnCollapse | Gets or sets the column collapse property of the cell
Contents | Gets or sets the cell contents
DecimalAlign | Gets or sets the character used for decimal aligning the cell contents.
Expand | Gets or sets the cell expand property
FirstOnly | Gets or sets the cell first only property
FixedWidth | Gets or sets the cell fixed width property
Font | Gets the cell font attribute
Indent | Gets or sets the cell indent property
LevelIndentString | Gets or sets the level indent string (for assemblies).
MaxLines | Gets or sets the cell maxlines property
MaxWidth | Gets or sets the cell maximum width property
MinWidth | Gets or sets the cell minimum width property
RowSpan | Gets or sets the cell row span
Rules | Gets the cell rule attribute
TextFormat | Gets or sets the text format.
VAlignment | Gets or sets the cell vertical alignment property
Wrap | Gets or sets the cell wrap property

Explicit Interface Implementations

Name | Description
ICell..::.Border |
ICell..::.ColGap |
ICell..::.FixedWidth |
ICell..::.Font |
ICell..::.Indent |
ICell..::.MaxWidth |
ICell..::.MinWidth |
ICell..::.Rules |
ICell..::.TextFormat |
ICell..::.Wrap |

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


Cell Constructor

[image]

LinkOne WebView API
Cell Constructor
Cell Class See Also Send Feedback
Initializes a new instance of the Cell class

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Cell()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Cell()

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


Cell Methods

[image] [image]

LinkOne WebView API
Cell Methods
Cell Class See Also Send Feedback

The Cell type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


Cell Properties

[image] [image]

LinkOne WebView API
Cell Properties
Cell Class See Also Send Feedback

The Cell type exposes the following members.

Properties

Name | Description
Alignment | Gets or sets the cell horizontal alignment property
Blank | Gets or sets the cell blank property
Border | Gets cell border attribute
ColGap | Gets or sets the cell col gap
ColSpan | Gets or sets the cell col span
ColumnCollapse | Gets or sets the column collapse property of the cell
Contents | Gets or sets the cell contents
DecimalAlign | Gets or sets the character used for decimal aligning the cell contents.
Expand | Gets or sets the cell expand property
FirstOnly | Gets or sets the cell first only property
FixedWidth | Gets or sets the cell fixed width property
Font | Gets the cell font attribute
Indent | Gets or sets the cell indent property
LevelIndentString | Gets or sets the level indent string (for assemblies).
MaxLines | Gets or sets the cell maxlines property
MaxWidth | Gets or sets the cell maximum width property
MinWidth | Gets or sets the cell minimum width property
RowSpan | Gets or sets the cell row span
Rules | Gets the cell rule attribute
TextFormat | Gets or sets the text format.
VAlignment | Gets or sets the cell vertical alignment property
Wrap | Gets or sets the cell wrap property

Explicit Interface Implementations

Name | Description
ICell..::.Border |
ICell..::.ColGap |
ICell..::.FixedWidth |
ICell..::.Font |
ICell..::.Indent |
ICell..::.MaxWidth |
ICell..::.MinWidth |
ICell..::.Rules |
ICell..::.TextFormat |
ICell..::.Wrap |

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


Alignment Property

[image]

LinkOne WebView API
Cell..::.Alignment Property
Cell Class See Also Send Feedback
Gets or sets the cell horizontal alignment property

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public HorizontalAlignment Alignment { get; set; }
Visual Basic (Declaration)
Public Property Alignment As HorizontalAlignment
Visual C++
public:
virtual property HorizontalAlignment Alignment {
    HorizontalAlignment get () sealed;
    void set (HorizontalAlignment value) sealed;
}

Implements

ICell..::.Alignment

Remarks

Aligns the contents of the cell to the specified edge of the cell.

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


Blank Property

[image]

LinkOne WebView API
Cell..::.Blank Property
Cell Class See Also Send Feedback
Gets or sets the cell blank property

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Blank { get; set; }
Visual Basic (Declaration)
Public Property Blank As Boolean
Visual C++
public:
virtual property bool Blank {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

ICell..::.Blank

Remarks

Forces the cell to be displayed as blank.

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


Border Property

[image]

LinkOne WebView API
Cell..::.Border Property
Cell Class See Also Send Feedback
Gets cell border attribute

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BorderAttributes Border { get; }
Visual Basic (Declaration)
Public ReadOnly Property Border As BorderAttributes
Visual C++
public:
property BorderAttributes^ Border {
    BorderAttributes^ get ();
}

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


ColGap Property

[image]

LinkOne WebView API
Cell..::.ColGap Property
Cell Class See Also Send Feedback
Gets or sets the cell col gap

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Dimension ColGap { get; set; }
Visual Basic (Declaration)
Public Property ColGap As Dimension
Visual C++
public:
property Dimension^ ColGap {
    Dimension^ get ();
    void set (Dimension^ value);
}

Remarks

Attribute will allocate additional space to the left and right of a cell. Half of the specified colgap is placed to the left of the cell and half to the right. The additional space will be inside any borders or rules that the cell has.

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


ColSpan Property

[image]

LinkOne WebView API
Cell..::.ColSpan Property
Cell Class See Also Send Feedback
Gets or sets the cell col span

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int ColSpan { get; set; }
Visual Basic (Declaration)
Public Property ColSpan As Integer
Visual C++
public:
virtual property int ColSpan {
    int get () sealed;
    void set (int value) sealed;
}

Implements

ICell..::.ColSpan

Remarks

Causes the cell to span the specified number of columns in the table.

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


ColumnCollapse Property

[image]

LinkOne WebView API
Cell..::.ColumnCollapse Property
Cell Class See Also Send Feedback
Gets or sets the column collapse property of the cell

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool ColumnCollapse { get; set; }
Visual Basic (Declaration)
Public Property ColumnCollapse As Boolean
Visual C++
public:
virtual property bool ColumnCollapse {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

ICell..::.ColumnCollapse

Remarks

If all cells in a column are blank the column will automatically collapse to 0 width and not be visible. If ColumnCollapse is false on any cell in a column the column will be prevented from collapsing.

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


Contents Property

[image]

LinkOne WebView API
Cell..::.Contents Property
Cell Class See Also Send Feedback
Gets or sets the cell contents

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ICellContents Contents { get; set; }
Visual Basic (Declaration)
Public Property Contents As ICellContents
Visual C++
public:
virtual property ICellContents^ Contents {
    ICellContents^ get () sealed;
    void set (ICellContents^ value) sealed;
}

Implements

ICell..::.Contents

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


DecimalAlign Property

[image]

LinkOne WebView API
Cell..::.DecimalAlign Property
Cell Class See Also Send Feedback
Gets or sets the character used for decimal aligning the cell contents.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string DecimalAlign { get; set; }
Visual Basic (Declaration)
Public Property DecimalAlign As String
Visual C++
public:
virtual property String^ DecimalAlign {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ICell..::.DecimalAlign

Remarks

Used in parts list entry formats. The cell contents are aligned with all other occurences of the same cell in the parts list. If null, then no aligning takes place, if an empty string then aligning takes place at the first non-numeric character, otherwise aligning takes place at the first occurrance of the first character in the string.

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


Expand Property

[image]

LinkOne WebView API
Cell..::.Expand Property
Cell Class See Also Send Feedback
Gets or sets the cell expand property

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Expand { get; set; }
Visual Basic (Declaration)
Public Property Expand As Boolean
Visual C++
public:
virtual property bool Expand {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

ICell..::.Expand

Remarks

If the width of the area in which the cell is being displayed is wider than the maximum amount that the cells needs, then the cell will be stretched to fill the entire width.

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


FirstOnly Property

[image]

LinkOne WebView API
Cell..::.FirstOnly Property
Cell Class See Also Send Feedback
Gets or sets the cell first only property

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool FirstOnly { get; set; }
Visual Basic (Declaration)
Public Property FirstOnly As Boolean
Visual C++
public:
virtual property bool FirstOnly {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

ICell..::.FirstOnly

Remarks

Cells with this attribute are displayed as blank except when being displayed in the first parts list entry on a particular printed page. If a parts list spreads across several sheets when printed, a cell will only be visible in the first entry on each sheet.

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


FixedWidth Property

[image]

LinkOne WebView API
Cell..::.FixedWidth Property
Cell Class See Also Send Feedback
Gets or sets the cell fixed width property

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Dimension FixedWidth { get; set; }
Visual Basic (Declaration)
Public Property FixedWidth As Dimension
Visual C++
public:
property Dimension^ FixedWidth {
    Dimension^ get ();
    void set (Dimension^ value);
}

Remarks

Specifies how wide the cell will be. The cell cannot be narrower than this width but it may get stretched wider if forced to by wider cells in the same column.

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


Font Property

[image]

LinkOne WebView API
Cell..::.Font Property
Cell Class See Also Send Feedback
Gets the cell font attribute

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public FontAttributes Font { get; }
Visual Basic (Declaration)
Public ReadOnly Property Font As FontAttributes
Visual C++
public:
property FontAttributes^ Font {
    FontAttributes^ get ();
}

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


ICell.Border Property

[image]

LinkOne WebView API
Cell..::.ICell..::.Border Property
Cell Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IBorderAttributes ICell.Border { get; }
Visual Basic (Declaration)
Private ReadOnly Property Border As IBorderAttributes
    Implements ICell.Border
Visual C++
private:
virtual property IBorderAttributes^ Border {
    IBorderAttributes^ get () sealed = ICell::Border::get;
}

Implements

ICell..::.Border

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


ICell.ColGap Property

[image]

LinkOne WebView API
Cell..::.ICell..::.ColGap Property
Cell Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension ICell.ColGap { get; set; }
Visual Basic (Declaration)
Private Property ColGap As IDimension Implements ICell.ColGap
Visual C++
private:
virtual property IDimension^ ColGap {
    IDimension^ get () sealed = ICell::ColGap::get;
    void set (IDimension^ value) sealed = ICell::ColGap::set;
}

Implements

ICell..::.ColGap

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


ICell.FixedWidth Property

[image]

LinkOne WebView API
Cell..::.ICell..::.FixedWidth Property
Cell Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension ICell.FixedWidth { get; set; }
Visual Basic (Declaration)
Private Property FixedWidth As IDimension
    Implements ICell.FixedWidth
Visual C++
private:
virtual property IDimension^ FixedWidth {
    IDimension^ get () sealed = ICell::FixedWidth::get;
    void set (IDimension^ value) sealed = ICell::FixedWidth::set;
}

Implements

ICell..::.FixedWidth

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


ICell.Font Property

[image]

LinkOne WebView API
Cell..::.ICell..::.Font Property
Cell Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IFontAttributes ICell.Font { get; }
Visual Basic (Declaration)
Private ReadOnly Property Font As IFontAttributes
    Implements ICell.Font
Visual C++
private:
virtual property IFontAttributes^ Font {
    IFontAttributes^ get () sealed = ICell::Font::get;
}

Implements

ICell..::.Font

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


ICell.Indent Property

[image]

LinkOne WebView API
Cell..::.ICell..::.Indent Property
Cell Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension ICell.Indent { get; set; }
Visual Basic (Declaration)
Private Property Indent As IDimension Implements ICell.Indent
Visual C++
private:
virtual property IDimension^ Indent {
    IDimension^ get () sealed = ICell::Indent::get;
    void set (IDimension^ value) sealed = ICell::Indent::set;
}

Implements

ICell..::.Indent

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


ICell.MaxWidth Property

[image]

LinkOne WebView API
Cell..::.ICell..::.MaxWidth Property
Cell Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension ICell.MaxWidth { get; set; }
Visual Basic (Declaration)
Private Property MaxWidth As IDimension
    Implements ICell.MaxWidth
Visual C++
private:
virtual property IDimension^ MaxWidth {
    IDimension^ get () sealed = ICell::MaxWidth::get;
    void set (IDimension^ value) sealed = ICell::MaxWidth::set;
}

Implements

ICell..::.MaxWidth

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


ICell.MinWidth Property

[image]

LinkOne WebView API
Cell..::.ICell..::.MinWidth Property
Cell Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension ICell.MinWidth { get; set; }
Visual Basic (Declaration)
Private Property MinWidth As IDimension
    Implements ICell.MinWidth
Visual C++
private:
virtual property IDimension^ MinWidth {
    IDimension^ get () sealed = ICell::MinWidth::get;
    void set (IDimension^ value) sealed = ICell::MinWidth::set;
}

Implements

ICell..::.MinWidth

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


ICell.Rules Property

[image]

LinkOne WebView API
Cell..::.ICell..::.Rules Property
Cell Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IRuleAttributes ICell.Rules { get; }
Visual Basic (Declaration)
Private ReadOnly Property Rules As IRuleAttributes
    Implements ICell.Rules
Visual C++
private:
virtual property IRuleAttributes^ Rules {
    IRuleAttributes^ get () sealed = ICell::Rules::get;
}

Implements

ICell..::.Rules

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


ICell.TextFormat Property

[image]

LinkOne WebView API
Cell..::.ICell..::.TextFormat Property
Cell Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ITextFormat ICell.TextFormat { get; set; }
Visual Basic (Declaration)
Private Property TextFormat As ITextFormat
    Implements ICell.TextFormat
Visual C++
private:
virtual property ITextFormat^ TextFormat {
    ITextFormat^ get () sealed = ICell::TextFormat::get;
    void set (ITextFormat^ value) sealed = ICell::TextFormat::set;
}

Implements

ICell..::.TextFormat

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


ICell.Wrap Property

[image]

LinkOne WebView API
Cell..::.ICell..::.Wrap Property
Cell Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension ICell.Wrap { get; set; }
Visual Basic (Declaration)
Private Property Wrap As IDimension Implements ICell.Wrap
Visual C++
private:
virtual property IDimension^ Wrap {
    IDimension^ get () sealed = ICell::Wrap::get;
    void set (IDimension^ value) sealed = ICell::Wrap::set;
}

Implements

ICell..::.Wrap

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


Indent Property

[image]

LinkOne WebView API
Cell..::.Indent Property
Cell Class See Also Send Feedback
Gets or sets the cell indent property

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Dimension Indent { get; set; }
Visual Basic (Declaration)
Public Property Indent As Dimension
Visual C++
public:
property Dimension^ Indent {
    Dimension^ get ();
    void set (Dimension^ value);
}

Remarks

Indents the first line of the text in the cell by the specified amount. If a negative number is used, it will produce a hanging indent (i.e. the first line will appear not indented but the remaining lines in the cell will.

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


LevelIndentString Property

[image]

LinkOne WebView API
Cell..::.LevelIndentString Property
Cell Class See Also Send Feedback
Gets or sets the level indent string (for assemblies).

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string LevelIndentString { get; set; }
Visual Basic (Declaration)
Public Property LevelIndentString As String
Visual C++
public:
virtual property String^ LevelIndentString {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ICell..::.LevelIndentString

Remarks

This property will cause test in the cell to be indended and preceded by the specified string, repeated once for each assembly level that the entry has.

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


MaxLines Property

[image]

LinkOne WebView API
Cell..::.MaxLines Property
Cell Class See Also Send Feedback
Gets or sets the cell maxlines property

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int MaxLines { get; set; }
Visual Basic (Declaration)
Public Property MaxLines As Integer
Visual C++
public:
virtual property int MaxLines {
    int get () sealed;
    void set (int value) sealed;
}

Implements

ICell..::.MaxLines

Remarks

Applies to text cells that also have the WRAP attribute. The cell can wrap to nomore than the specific number of lines.

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


MaxWidth Property

[image]

LinkOne WebView API
Cell..::.MaxWidth Property
Cell Class See Also Send Feedback
Gets or sets the cell maximum width property

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Dimension MaxWidth { get; set; }
Visual Basic (Declaration)
Public Property MaxWidth As Dimension
Visual C++
public:
property Dimension^ MaxWidth {
    Dimension^ get ();
    void set (Dimension^ value);
}

Remarks

Specifies the maximun width that the cell is allowed to have. The cell will not be wider than this unless forced to by wider cell in the same column. The cell may become narrower than the specified width.

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


MinWidth Property

[image]

LinkOne WebView API
Cell..::.MinWidth Property
Cell Class See Also Send Feedback
Gets or sets the cell minimum width property

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Dimension MinWidth { get; set; }
Visual Basic (Declaration)
Public Property MinWidth As Dimension
Visual C++
public:
property Dimension^ MinWidth {
    Dimension^ get ();
    void set (Dimension^ value);
}

Remarks

Specifies the minimun width that the cell is allowed to have. The cell will not be narrower than this. The cell may become wider than the specified width.

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


RowSpan Property

[image]

LinkOne WebView API
Cell..::.RowSpan Property
Cell Class See Also Send Feedback
Gets or sets the cell row span

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int RowSpan { get; set; }
Visual Basic (Declaration)
Public Property RowSpan As Integer
Visual C++
public:
virtual property int RowSpan {
    int get () sealed;
    void set (int value) sealed;
}

Implements

ICell..::.RowSpan

Remarks

Causes the cell to span the specified number of rows in the table.

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


Rules Property

[image]

LinkOne WebView API
Cell..::.Rules Property
Cell Class See Also Send Feedback
Gets the cell rule attribute

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public RuleAttributes Rules { get; }
Visual Basic (Declaration)
Public ReadOnly Property Rules As RuleAttributes
Visual C++
public:
property RuleAttributes^ Rules {
    RuleAttributes^ get ();
}

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


TextFormat Property

[image]

LinkOne WebView API
Cell..::.TextFormat Property
Cell Class See Also Send Feedback
Gets or sets the text format.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public TextFormat TextFormat { get; set; }
Visual Basic (Declaration)
Public Property TextFormat As TextFormat
Visual C++
public:
property TextFormat^ TextFormat {
    TextFormat^ get ();
    void set (TextFormat^ value);
}

Remarks

Value can be null if no formatting is specified.

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


VAlignment Property

[image]

LinkOne WebView API
Cell..::.VAlignment Property
Cell Class See Also Send Feedback
Gets or sets the cell vertical alignment property

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public VerticalAlignment VAlignment { get; set; }
Visual Basic (Declaration)
Public Property VAlignment As VerticalAlignment
Visual C++
public:
virtual property VerticalAlignment VAlignment {
    VerticalAlignment get () sealed;
    void set (VerticalAlignment value) sealed;
}

Implements

ICell..::.VAlignment

Remarks

Aligns the contents of the cell to the specifed edge of the cell.

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


Wrap Property

[image]

LinkOne WebView API
Cell..::.Wrap Property
Cell Class See Also Send Feedback
Gets or sets the cell wrap property

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Dimension Wrap { get; set; }
Visual Basic (Declaration)
Public Property Wrap As Dimension
Visual C++
public:
property Dimension^ Wrap {
    Dimension^ get ();
    void set (Dimension^ value);
}

Remarks

Indicates that the text can be wrapped onto multiple lines if it will not fit in the width available to the cell. The text is split at word breaks only. Will be null if no wrapping is allowed.

See Also

Cell Class
Mincom.LinkOne.Dom.Layouts Namespace


Dimension Class

[image]

LinkOne WebView API
Dimension Class
Members See Also Send Feedback
Represents a length (or size) value in a layout.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public class Dimension : IDimension
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class Dimension _
    Implements IDimension
Visual C++
[SerializableAttribute]
public ref class Dimension : IDimension

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Layouts..::.Dimension

See Also

Dimension Members
Mincom.LinkOne.Dom.Layouts Namespace


Dimension Members

[image] [image]

LinkOne WebView API
Dimension Members
Dimension Class Constructors Methods Properties See Also Send Feedback

The Dimension type exposes the following members.

Constructors

Name | Description
Dimension | Constructs a dimension object given a size and the units.

Methods

Name | Description
Clear | Clears the dimension.
Equals | Overridden. Tests whether the specified object is a Dimension class and is equivalent to this Dimension class. (Overrides Object..::.Equals(Object).)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. Returns a hash code for this Dimension instance. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToCssString | Returns the Cascading Style Sheet represention of the dimension units.
ToString | Returns a string representation of the dimension instance. (Overrides Object..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two Dimension objects are equivalent.
Inequality | Tests whether two Dimension objects are different.

Properties

Name | Description
Size | Gets or sets the length of the dimension.
Units | Gets or sets the unit of the dimentsion.

See Also

Dimension Class
Mincom.LinkOne.Dom.Layouts Namespace


Dimension Constructor

[image]

LinkOne WebView API
Dimension Constructor
Dimension Class See Also Send Feedback
Constructs a dimension object given a size and the units.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Dimension(
    float size,
    DimensionUnit units
)
Visual Basic (Declaration)
Public Sub New ( _
    size As Single, _
    units As DimensionUnit _
)
Visual C++
public:
Dimension(
    float size,
    DimensionUnit units
)

Parameters

size
Type: System..::.Single
The size of the dimension.
units
Type: Mincom.LinkOne.Dom.Layouts..::.DimensionUnit
The dimension unit.

See Also

Dimension Class
Mincom.LinkOne.Dom.Layouts Namespace


Dimension Methods

[image] [image]

LinkOne WebView API
Dimension Methods
Dimension Class See Also Send Feedback

The Dimension type exposes the following members.

Methods

Name | Description
Clear | Clears the dimension.
Equals | Overridden. Tests whether the specified object is a Dimension class and is equivalent to this Dimension class. (Overrides Object..::.Equals(Object).)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. Returns a hash code for this Dimension instance. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToCssString | Returns the Cascading Style Sheet represention of the dimension units.
ToString | Returns a string representation of the dimension instance. (Overrides Object..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two Dimension objects are equivalent.
Inequality | Tests whether two Dimension objects are different.

See Also

Dimension Class
Mincom.LinkOne.Dom.Layouts Namespace


Clear Method

[image]

LinkOne WebView API
Dimension..::.Clear Method
Dimension Class See Also Send Feedback
Clears the dimension.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
void Clear()

Remarks

The Clear method resets the size of the dimension to 0, and the unit to Pixels.

See Also

Dimension Class
Mincom.LinkOne.Dom.Layouts Namespace


Equality Operator

[image]

LinkOne WebView API
Dimension..::.Equality Operator
Dimension Class See Also Send Feedback
Tests whether two Dimension objects are equivalent.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static bool operator ==(
    Dimension dim1,
    Dimension dim2
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    dim1 As Dimension, _
    dim2 As Dimension _
) As Boolean
Visual C++
public:
static bool operator ==(
    Dimension^ dim1,
    Dimension^ dim2
)

Parameters

dim1
Type: Mincom.LinkOne.Dom.Layouts..::.Dimension
The Dimension to the left of the equality operator.
dim2
Type: Mincom.LinkOne.Dom.Layouts..::.Dimension
The Dimension to the right of the equality operator.

Return Value

The operator returns true if the two Dimensionobjects are equal; otherwise false.

See Also

Dimension Class
Mincom.LinkOne.Dom.Layouts Namespace


Equals Method

[image]

LinkOne WebView API
Dimension..::.Equals Method
Dimension Class See Also Send Feedback
Overridden. Tests whether the specified object is a Dimension class and is equivalent to this Dimension class.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The object to test.

Return Value

This method returns true if obj is a Dimension class equivalent to this Dimension class; otherwise, false.

See Also

Dimension Class
Mincom.LinkOne.Dom.Layouts Namespace


GetHashCode Method

[image]

LinkOne WebView API
Dimension..::.GetHashCode Method
Dimension Class See Also Send Feedback
Overridden. Returns a hash code for this Dimension instance.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

An integer has code.

See Also

Dimension Class
Mincom.LinkOne.Dom.Layouts Namespace


Inequality Operator

[image]

LinkOne WebView API
Dimension..::.Inequality Operator
Dimension Class See Also Send Feedback
Tests whether two Dimension objects are different.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static bool operator !=(
    Dimension dim1,
    Dimension dim2
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    dim1 As Dimension, _
    dim2 As Dimension _
) As Boolean
Visual C++
public:
static bool operator !=(
    Dimension^ dim1,
    Dimension^ dim2
)

Parameters

dim1
Type: Mincom.LinkOne.Dom.Layouts..::.Dimension
The Dimension to the left of the inequality operator.
dim2
Type: Mincom.LinkOne.Dom.Layouts..::.Dimension
The Dimension to the right of the equality operator.

Return Value

The operator returns true if the two Dimensionobjects are different; otherwise false.

See Also

Dimension Class
Mincom.LinkOne.Dom.Layouts Namespace


ToCssString Method

[image]

LinkOne WebView API
Dimension..::.ToCssString Method
Dimension Class See Also Send Feedback
Returns the Cascading Style Sheet represention of the dimension units.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string ToCssString()
Visual Basic (Declaration)
Public Function ToCssString As String
Visual C++
public:
String^ ToCssString()

Return Value

The dimension units in CSS form.

See Also

Dimension Class
Mincom.LinkOne.Dom.Layouts Namespace


ToString Method

[image]

LinkOne WebView API
Dimension..::.ToString Method
Dimension Class See Also Send Feedback
Returns a string representation of the dimension instance.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The LinkOne representation of the dimension.

See Also

Dimension Class
Mincom.LinkOne.Dom.Layouts Namespace


Dimension Properties

[image] [image]

LinkOne WebView API
Dimension Properties
Dimension Class See Also Send Feedback

The Dimension type exposes the following members.

Properties

Name | Description
Size | Gets or sets the length of the dimension.
Units | Gets or sets the unit of the dimentsion.

See Also

Dimension Class
Mincom.LinkOne.Dom.Layouts Namespace


Size Property

[image]

LinkOne WebView API
Dimension..::.Size Property
Dimension Class See Also Send Feedback
Gets or sets the length of the dimension.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public float Size { get; set; }
Visual Basic (Declaration)
Public Property Size As Single
Visual C++
public:
virtual property float Size {
    float get () sealed;
    void set (float value) sealed;
}

Field Value

The length specified by the dimension.

Implements

IDimension..::.Size

See Also

Dimension Class
Mincom.LinkOne.Dom.Layouts Namespace


Units Property

[image]

LinkOne WebView API
Dimension..::.Units Property
Dimension Class See Also Send Feedback
Gets or sets the unit of the dimentsion.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public DimensionUnit Units { get; set; }
Visual Basic (Declaration)
Public Property Units As DimensionUnit
Visual C++
public:
virtual property DimensionUnit Units {
    DimensionUnit get () sealed;
    void set (DimensionUnit value) sealed;
}

Field Value

The unit of the dimension.

Implements

IDimension..::.Units

See Also

Dimension Class
Mincom.LinkOne.Dom.Layouts Namespace


DimensionUnit Enumeration

[image]

LinkOne WebView API
DimensionUnit Enumeration
See Also Send Feedback
Allowable values for length dimensions.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum DimensionUnit
Visual Basic (Declaration)
Public Enumeration DimensionUnit
Visual C++
public enum class DimensionUnit

Members

Member name | Description
Pixels | The dimension units are in pixels.
CharacterWidths | The dimension units are in character widths.
Percentage | The dimension value is a percentage of a length.
Inches | The dimension units are in inches.
Millimeters | The dimension units are in millimeters.
Points | The dimension units are in typographic points.

See Also

Mincom.LinkOne.Dom.Layouts Namespace


EntryField Class

[image]

LinkOne WebView API
EntryField Class
Members See Also Send Feedback
Represents a parts list entry field in a layout cell.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public class EntryField : IEntryField, ICellContents
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class EntryField _
    Implements IEntryField, ICellContents
Visual C++
[SerializableAttribute]
public ref class EntryField : IEntryField,
    ICellContents

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Layouts..::.EntryField

See Also

EntryField Members
Mincom.LinkOne.Dom.Layouts Namespace


EntryField Members

[image] [image]

LinkOne WebView API
EntryField Members
EntryField Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The EntryField type exposes the following members.

Constructors

Name | Description
EntryField | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
IsLinkIcon | Gets true if the cell is a link icon field.
IsNoteIcon | Gets true if the cell is a note icon field.
IsSelectionIcon | Gets true if the cell is a selection icon field.
Name | Gets or sets the name of the entry field.

Explicit Interface Implementations

Name | Description
IEntryField..::.IsLinkIcon |
IEntryField..::.IsNoteIcon |
IEntryField..::.IsSelectionIcon |
IEntryField..::.Name |

See Also

EntryField Class
Mincom.LinkOne.Dom.Layouts Namespace


EntryField Constructor

[image] [image]

LinkOne WebView API
EntryField Constructor
EntryField Class See Also Send Feedback

Overload List

Name | Description
EntryField()()() | Initializes a new instance of the EntryField class.
EntryField(String) | Initializes a new instance of the EntryField class.

See Also

EntryField Class
EntryField Members
Mincom.LinkOne.Dom.Layouts Namespace


EntryField Constructor

[image]

LinkOne WebView API
EntryField Constructor
EntryField Class See Also Send Feedback
Initializes a new instance of the EntryField class.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public EntryField()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EntryField()

See Also

EntryField Class
EntryField Overload
Mincom.LinkOne.Dom.Layouts Namespace


EntryField Constructor (String)

[image]

LinkOne WebView API
EntryField Constructor (String)
EntryField Class See Also Send Feedback
Initializes a new instance of the EntryField class.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public EntryField(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)
Visual C++
public:
EntryField(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the entry field.

See Also

EntryField Class
EntryField Overload
Mincom.LinkOne.Dom.Layouts Namespace


EntryField Methods

[image] [image]

LinkOne WebView API
EntryField Methods
EntryField Class See Also Send Feedback

The EntryField type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EntryField Class
Mincom.LinkOne.Dom.Layouts Namespace


EntryField Properties

[image] [image]

LinkOne WebView API
EntryField Properties
EntryField Class See Also Send Feedback

The EntryField type exposes the following members.

Properties

Name | Description
IsLinkIcon | Gets true if the cell is a link icon field.
IsNoteIcon | Gets true if the cell is a note icon field.
IsSelectionIcon | Gets true if the cell is a selection icon field.
Name | Gets or sets the name of the entry field.

Explicit Interface Implementations

Name | Description
IEntryField..::.IsLinkIcon |
IEntryField..::.IsNoteIcon |
IEntryField..::.IsSelectionIcon |
IEntryField..::.Name |

See Also

EntryField Class
Mincom.LinkOne.Dom.Layouts Namespace


IEntryField.IsLinkIcon Property

[image]

LinkOne WebView API
EntryField..::.IEntryField..::.IsLinkIcon Property
EntryField Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IEntryField.IsLinkIcon { get; }
Visual Basic (Declaration)
Private ReadOnly Property IsLinkIcon As Boolean
    Implements IEntryField.IsLinkIcon
Visual C++
private:
virtual property bool IsLinkIcon {
    bool get () sealed = IEntryField::IsLinkIcon::get;
}

Implements

IEntryField..::.IsLinkIcon

See Also

EntryField Class
Mincom.LinkOne.Dom.Layouts Namespace


IEntryField.IsNoteIcon Property

[image]

LinkOne WebView API
EntryField..::.IEntryField..::.IsNoteIcon Property
EntryField Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IEntryField.IsNoteIcon { get; }
Visual Basic (Declaration)
Private ReadOnly Property IsNoteIcon As Boolean
    Implements IEntryField.IsNoteIcon
Visual C++
private:
virtual property bool IsNoteIcon {
    bool get () sealed = IEntryField::IsNoteIcon::get;
}

Implements

IEntryField..::.IsNoteIcon

See Also

EntryField Class
Mincom.LinkOne.Dom.Layouts Namespace


IEntryField.IsSelectionIcon Property

[image]

LinkOne WebView API
EntryField..::.IEntryField..::.IsSelectionIcon Property
EntryField Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IEntryField.IsSelectionIcon { get; }
Visual Basic (Declaration)
Private ReadOnly Property IsSelectionIcon As Boolean
    Implements IEntryField.IsSelectionIcon
Visual C++
private:
virtual property bool IsSelectionIcon {
    bool get () sealed = IEntryField::IsSelectionIcon::get;
}

Implements

IEntryField..::.IsSelectionIcon

See Also

EntryField Class
Mincom.LinkOne.Dom.Layouts Namespace


IEntryField.Name Property

[image]

LinkOne WebView API
EntryField..::.IEntryField..::.Name Property
EntryField Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string IEntryField.Name { get; set; }
Visual Basic (Declaration)
Private Property Name As String Implements IEntryField.Name
Visual C++
private:
virtual property String^ Name {
    String^ get () sealed = IEntryField::Name::get;
    void set (String^ value) sealed = IEntryField::Name::set;
}

Implements

IEntryField..::.Name

See Also

EntryField Class
Mincom.LinkOne.Dom.Layouts Namespace


IsLinkIcon Property

[image]

LinkOne WebView API
EntryField..::.IsLinkIcon Property
EntryField Class See Also Send Feedback
Gets true if the cell is a link icon field.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsLinkIcon { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsLinkIcon As Boolean
Visual C++
public:
property bool IsLinkIcon {
    bool get ();
}

See Also

EntryField Class
Mincom.LinkOne.Dom.Layouts Namespace


IsNoteIcon Property

[image]

LinkOne WebView API
EntryField..::.IsNoteIcon Property
EntryField Class See Also Send Feedback
Gets true if the cell is a note icon field.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsNoteIcon { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsNoteIcon As Boolean
Visual C++
public:
property bool IsNoteIcon {
    bool get ();
}

See Also

EntryField Class
Mincom.LinkOne.Dom.Layouts Namespace


IsSelectionIcon Property

[image]

LinkOne WebView API
EntryField..::.IsSelectionIcon Property
EntryField Class See Also Send Feedback
Gets true if the cell is a selection icon field.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsSelectionIcon { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSelectionIcon As Boolean
Visual C++
public:
property bool IsSelectionIcon {
    bool get ();
}

See Also

EntryField Class
Mincom.LinkOne.Dom.Layouts Namespace


Name Property

[image]

LinkOne WebView API
EntryField..::.Name Property
EntryField Class See Also Send Feedback
Gets or sets the name of the entry field.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The entry field name.

See Also

EntryField Class
Mincom.LinkOne.Dom.Layouts Namespace


FontAttributes Class

[image]

LinkOne WebView API
FontAttributes Class
Members See Also Send Feedback
Specifies text font attributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public class FontAttributes : IFontAttributes
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class FontAttributes _
    Implements IFontAttributes
Visual C++
[SerializableAttribute]
public ref class FontAttributes : IFontAttributes

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Layouts..::.FontAttributes

See Also

FontAttributes Members
Mincom.LinkOne.Dom.Layouts Namespace


FontAttributes Members

[image] [image]

LinkOne WebView API
FontAttributes Members
FontAttributes Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The FontAttributes type exposes the following members.

Constructors

Name | Description
FontAttributes | Initializes a new instance of the FontAttributes class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
CharacterSet | Gets or sets the CharacterSet of the FontAttributes.
Family | Gets or sets the Font family of the FontAttributes.
Height | Gets or sets the Height Dimension of the FontAttributes.
Italic | Gets or sets the Italic property of the FontAttributes.
Name | Gets or sets the Name property of the FontAttributes.
Pitch | Gets or sets the Pitch property of the FontAttributes.
Strikeout | Gets or sets the Strikeout property of the FontAttributes.
Underline | Gets or sets the Underline property of the FontAttributes.
Weight | Gets or sets the Weight property of the FontAttributes.
Width | Gets or sets the Width property of the FontAttributes.

Explicit Interface Implementations

Name | Description
IFontAttributes..::.Height |
IFontAttributes..::.Width |

See Also

FontAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


FontAttributes Constructor

[image]

LinkOne WebView API
FontAttributes Constructor
FontAttributes Class See Also Send Feedback
Initializes a new instance of the FontAttributes class

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public FontAttributes()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FontAttributes()

See Also

FontAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


FontAttributes Methods

[image] [image]

LinkOne WebView API
FontAttributes Methods
FontAttributes Class See Also Send Feedback

The FontAttributes type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FontAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


FontAttributes Properties

[image] [image]

LinkOne WebView API
FontAttributes Properties
FontAttributes Class See Also Send Feedback

The FontAttributes type exposes the following members.

Properties

Name | Description
CharacterSet | Gets or sets the CharacterSet of the FontAttributes.
Family | Gets or sets the Font family of the FontAttributes.
Height | Gets or sets the Height Dimension of the FontAttributes.
Italic | Gets or sets the Italic property of the FontAttributes.
Name | Gets or sets the Name property of the FontAttributes.
Pitch | Gets or sets the Pitch property of the FontAttributes.
Strikeout | Gets or sets the Strikeout property of the FontAttributes.
Underline | Gets or sets the Underline property of the FontAttributes.
Weight | Gets or sets the Weight property of the FontAttributes.
Width | Gets or sets the Width property of the FontAttributes.

Explicit Interface Implementations

Name | Description
IFontAttributes..::.Height |
IFontAttributes..::.Width |

See Also

FontAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


CharacterSet Property

[image]

LinkOne WebView API
FontAttributes..::.CharacterSet Property
FontAttributes Class See Also Send Feedback
Gets or sets the CharacterSet of the FontAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string CharacterSet { get; set; }
Visual Basic (Declaration)
Public Property CharacterSet As String
Visual C++
public:
virtual property String^ CharacterSet {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IFontAttributes..::.CharacterSet

See Also

FontAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


Family Property

[image]

LinkOne WebView API
FontAttributes..::.Family Property
FontAttributes Class See Also Send Feedback
Gets or sets the Font family of the FontAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Family { get; set; }
Visual Basic (Declaration)
Public Property Family As String
Visual C++
public:
virtual property String^ Family {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IFontAttributes..::.Family

See Also

FontAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


Height Property

[image]

LinkOne WebView API
FontAttributes..::.Height Property
FontAttributes Class See Also Send Feedback
Gets or sets the Height Dimension of the FontAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Dimension Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Dimension
Visual C++
public:
property Dimension^ Height {
    Dimension^ get ();
    void set (Dimension^ value);
}

See Also

FontAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


IFontAttributes.Height Property

[image]

LinkOne WebView API
FontAttributes..::.IFontAttributes..::.Height Property
FontAttributes Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension IFontAttributes.Height { get; set; }
Visual Basic (Declaration)
Private Property Height As IDimension Implements IFontAttributes.Height
Visual C++
private:
virtual property IDimension^ Height {
    IDimension^ get () sealed = IFontAttributes::Height::get;
    void set (IDimension^ value) sealed = IFontAttributes::Height::set;
}

Implements

IFontAttributes..::.Height

See Also

FontAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


IFontAttributes.Width Property

[image]

LinkOne WebView API
FontAttributes..::.IFontAttributes..::.Width Property
FontAttributes Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension IFontAttributes.Width { get; set; }
Visual Basic (Declaration)
Private Property Width As IDimension Implements IFontAttributes.Width
Visual C++
private:
virtual property IDimension^ Width {
    IDimension^ get () sealed = IFontAttributes::Width::get;
    void set (IDimension^ value) sealed = IFontAttributes::Width::set;
}

Implements

IFontAttributes..::.Width

See Also

FontAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


Italic Property

[image]

LinkOne WebView API
FontAttributes..::.Italic Property
FontAttributes Class See Also Send Feedback
Gets or sets the Italic property of the FontAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Italic { get; set; }
Visual Basic (Declaration)
Public Property Italic As Boolean
Visual C++
public:
virtual property bool Italic {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IFontAttributes..::.Italic

See Also

FontAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


Name Property

[image]

LinkOne WebView API
FontAttributes..::.Name Property
FontAttributes Class See Also Send Feedback
Gets or sets the Name property of the FontAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IFontAttributes..::.Name

See Also

FontAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


Pitch Property

[image]

LinkOne WebView API
FontAttributes..::.Pitch Property
FontAttributes Class See Also Send Feedback
Gets or sets the Pitch property of the FontAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Pitch Pitch { get; set; }
Visual Basic (Declaration)
Public Property Pitch As Pitch
Visual C++
public:
virtual property Pitch Pitch {
    Pitch get () sealed;
    void set (Pitch value) sealed;
}

Implements

IFontAttributes..::.Pitch

See Also

FontAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


Strikeout Property

[image]

LinkOne WebView API
FontAttributes..::.Strikeout Property
FontAttributes Class See Also Send Feedback
Gets or sets the Strikeout property of the FontAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Strikeout { get; set; }
Visual Basic (Declaration)
Public Property Strikeout As Boolean
Visual C++
public:
virtual property bool Strikeout {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IFontAttributes..::.Strikeout

See Also

FontAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


Underline Property

[image]

LinkOne WebView API
FontAttributes..::.Underline Property
FontAttributes Class See Also Send Feedback
Gets or sets the Underline property of the FontAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Underline { get; set; }
Visual Basic (Declaration)
Public Property Underline As Boolean
Visual C++
public:
virtual property bool Underline {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IFontAttributes..::.Underline

See Also

FontAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


Weight Property

[image]

LinkOne WebView API
FontAttributes..::.Weight Property
FontAttributes Class See Also Send Feedback
Gets or sets the Weight property of the FontAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Weight Weight { get; set; }
Visual Basic (Declaration)
Public Property Weight As Weight
Visual C++
public:
virtual property Weight Weight {
    Weight get () sealed;
    void set (Weight value) sealed;
}

Implements

IFontAttributes..::.Weight

See Also

FontAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


Width Property

[image]

LinkOne WebView API
FontAttributes..::.Width Property
FontAttributes Class See Also Send Feedback
Gets or sets the Width property of the FontAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Dimension Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Dimension
Visual C++
public:
property Dimension^ Width {
    Dimension^ get ();
    void set (Dimension^ value);
}

See Also

FontAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


Format Class

[image]

LinkOne WebView API
Format Class
Members See Also Send Feedback
Represents a format in a layout. Formats consist of a layout table, and optional column headings.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public class Format : LayoutTable, IFormat,
    ILayoutTable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class Format _
    Inherits LayoutTable _
    Implements IFormat, ILayoutTable
Visual C++
[SerializableAttribute]
public ref class Format : public LayoutTable,
    IFormat, ILayoutTable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Layouts..::.LayoutTable
Mincom.LinkOne.Dom.Layouts..::.Format

See Also

Format Members
Mincom.LinkOne.Dom.Layouts Namespace


Format Members

[image] [image]

LinkOne WebView API
Format Members
Format Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The Format type exposes the following members.

Constructors

Name | Description
Format | Creates a new instance of a Format.

Methods

Name | Description
CreateDefaultNoteIconColumn | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RemoveDefaultNoteIconColumn | Removes the default item note column from the format (if present), .
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Border | Gets or sets the Border attributes of the FormatAttributes.
ClassName | Gets or sets the ClassName of the FormatAttributes.
Description | Gets or sets the Description of the Format.
EntryGap | Gets or sets the EntryGap dimension of the FormatAttributes.
FormatExpand | Gets or sets the FormatExpand property of the TableFormat. (Inherited from LayoutTable.)
Heading | The optional column headings for the format.
HideRepeatItemIDs | Gets or sets the HideRepeatItemIDs property of the FormatAttributes.
Name | Gets or sets the Name of the FormatAttributes.
Rows | The collection of rows in the table. (Inherited from LayoutTable.)
ShowDefaultNoteIconColumn | Gets or sets whether or not to show the default note icon column

Explicit Interface Implementations

Name | Description
IFormat..::.DefaultItemNoteColumn |
IFormat..::.EntryGap |
ILayoutTable..::.FormatExpand | (Inherited from LayoutTable.)
IFormat..::.Heading |
ILayoutTable..::.Rows | (Inherited from LayoutTable.)

See Also

Format Class
Mincom.LinkOne.Dom.Layouts Namespace


Format Constructor

[image]

LinkOne WebView API
Format Constructor
Format Class See Also Send Feedback
Creates a new instance of a Format.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Format()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Format()

See Also

Format Class
Mincom.LinkOne.Dom.Layouts Namespace


Format Methods

[image] [image]

LinkOne WebView API
Format Methods
Format Class See Also Send Feedback

The Format type exposes the following members.

Methods

Name | Description
CreateDefaultNoteIconColumn | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RemoveDefaultNoteIconColumn | Removes the default item note column from the format (if present), .
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Format Class
Mincom.LinkOne.Dom.Layouts Namespace


CreateDefaultNoteIconColumn Method

[image] [image]

LinkOne WebView API
Format..::.CreateDefaultNoteIconColumn Method
Format Class See Also Send Feedback

Overload List

Name | Description
CreateDefaultNoteIconColumn()()() | Creates the default item note column in the format, .
CreateDefaultNoteIconColumn(Int32) |

See Also

Format Class
Format Members
Mincom.LinkOne.Dom.Layouts Namespace


CreateDefaultNoteIconColumn Method

[image]

LinkOne WebView API
Format..::.CreateDefaultNoteIconColumn Method
Format Class See Also Send Feedback
Creates the default item note column in the format, .

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void CreateDefaultNoteIconColumn()
Visual Basic (Declaration)
Public Sub CreateDefaultNoteIconColumn
Visual C++
public:
void CreateDefaultNoteIconColumn()

See Also

Format Class
CreateDefaultNoteIconColumn Overload
Mincom.LinkOne.Dom.Layouts Namespace
Format..::.ShowDefaultNoteIconColumn


CreateDefaultNoteIconColumn Method (Int32)

[image]

LinkOne WebView API
Format..::.CreateDefaultNoteIconColumn Method (Int32)
Format Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void CreateDefaultNoteIconColumn(
    int width
)
Visual Basic (Declaration)
Public Sub CreateDefaultNoteIconColumn ( _
    width As Integer _
)
Visual C++
public:
void CreateDefaultNoteIconColumn(
    int width
)

Parameters

width
Type: System..::.Int32

See Also

Format Class
CreateDefaultNoteIconColumn Overload
Mincom.LinkOne.Dom.Layouts Namespace


RemoveDefaultNoteIconColumn Method

[image]

LinkOne WebView API
Format..::.RemoveDefaultNoteIconColumn Method
Format Class See Also Send Feedback
Removes the default item note column from the format (if present), .

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void RemoveDefaultNoteIconColumn()
Visual Basic (Declaration)
Public Sub RemoveDefaultNoteIconColumn
Visual C++
public:
void RemoveDefaultNoteIconColumn()

See Also

Format Class
Mincom.LinkOne.Dom.Layouts Namespace
Format..::.ShowDefaultNoteIconColumn


Format Properties

[image] [image]

LinkOne WebView API
Format Properties
Format Class See Also Send Feedback

The Format type exposes the following members.

Properties

Name | Description
Border | Gets or sets the Border attributes of the FormatAttributes.
ClassName | Gets or sets the ClassName of the FormatAttributes.
Description | Gets or sets the Description of the Format.
EntryGap | Gets or sets the EntryGap dimension of the FormatAttributes.
FormatExpand | Gets or sets the FormatExpand property of the TableFormat. (Inherited from LayoutTable.)
Heading | The optional column headings for the format.
HideRepeatItemIDs | Gets or sets the HideRepeatItemIDs property of the FormatAttributes.
Name | Gets or sets the Name of the FormatAttributes.
Rows | The collection of rows in the table. (Inherited from LayoutTable.)
ShowDefaultNoteIconColumn | Gets or sets whether or not to show the default note icon column

Explicit Interface Implementations

Name | Description
IFormat..::.DefaultItemNoteColumn |
IFormat..::.EntryGap |
ILayoutTable..::.FormatExpand | (Inherited from LayoutTable.)
IFormat..::.Heading |
ILayoutTable..::.Rows | (Inherited from LayoutTable.)

See Also

Format Class
Mincom.LinkOne.Dom.Layouts Namespace


Border Property

[image]

LinkOne WebView API
Format..::.Border Property
Format Class See Also Send Feedback
Gets or sets the Border attributes of the FormatAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BorderAttributes Border { get; }
Visual Basic (Declaration)
Public ReadOnly Property Border As BorderAttributes
Visual C++
public:
property BorderAttributes^ Border {
    BorderAttributes^ get ();
}

See Also

Format Class
Mincom.LinkOne.Dom.Layouts Namespace


ClassName Property

[image]

LinkOne WebView API
Format..::.ClassName Property
Format Class See Also Send Feedback
Gets or sets the ClassName of the FormatAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string ClassName { get; set; }
Visual Basic (Declaration)
Public Property ClassName As String
Visual C++
public:
virtual property String^ ClassName {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IFormat..::.ClassName

See Also

Format Class
Mincom.LinkOne.Dom.Layouts Namespace


Description Property

[image]

LinkOne WebView API
Format..::.Description Property
Format Class See Also Send Feedback
Gets or sets the Description of the Format.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
virtual property String^ Description {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IFormat..::.Description

See Also

Format Class
Mincom.LinkOne.Dom.Layouts Namespace


EntryGap Property

[image]

LinkOne WebView API
Format..::.EntryGap Property
Format Class See Also Send Feedback
Gets or sets the EntryGap dimension of the FormatAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Dimension EntryGap { get; set; }
Visual Basic (Declaration)
Public Property EntryGap As Dimension
Visual C++
public:
property Dimension^ EntryGap {
    Dimension^ get ();
    void set (Dimension^ value);
}

See Also

Format Class
Mincom.LinkOne.Dom.Layouts Namespace


Heading Property

[image]

LinkOne WebView API
Format..::.Heading Property
Format Class See Also Send Feedback
The optional column headings for the format.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Heading Heading { get; }
Visual Basic (Declaration)
Public ReadOnly Property Heading As Heading
Visual C++
public:
property Heading^ Heading {
    Heading^ get ();
}

Field Value

The heading of the format.

See Also

Format Class
Mincom.LinkOne.Dom.Layouts Namespace


HideRepeatItemIDs Property

[image]

LinkOne WebView API
Format..::.HideRepeatItemIDs Property
Format Class See Also Send Feedback
Gets or sets the HideRepeatItemIDs property of the FormatAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool HideRepeatItemIDs { get; set; }
Visual Basic (Declaration)
Public Property HideRepeatItemIDs As Boolean
Visual C++
public:
virtual property bool HideRepeatItemIDs {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IFormat..::.HideRepeatItemIDs

See Also

Format Class
Mincom.LinkOne.Dom.Layouts Namespace


IFormat.DefaultItemNoteColumn Property

[image]

LinkOne WebView API
Format..::.IFormat..::.DefaultItemNoteColumn Property
Format Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IFormat.DefaultItemNoteColumn { get; set; }
Visual Basic (Declaration)
Private Property DefaultItemNoteColumn As Boolean
    Implements IFormat.DefaultItemNoteColumn
Visual C++
private:
virtual property bool DefaultItemNoteColumn {
    bool get () sealed = IFormat::DefaultItemNoteColumn::get;
    void set (bool value) sealed = IFormat::DefaultItemNoteColumn::set;
}

Implements

IFormat..::.DefaultItemNoteColumn

See Also

Format Class
Mincom.LinkOne.Dom.Layouts Namespace


IFormat.EntryGap Property

[image]

LinkOne WebView API
Format..::.IFormat..::.EntryGap Property
Format Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension IFormat.EntryGap { get; set; }
Visual Basic (Declaration)
Private Property EntryGap As IDimension
    Implements IFormat.EntryGap
Visual C++
private:
virtual property IDimension^ EntryGap {
    IDimension^ get () sealed = IFormat::EntryGap::get;
    void set (IDimension^ value) sealed = IFormat::EntryGap::set;
}

Implements

IFormat..::.EntryGap

See Also

Format Class
Mincom.LinkOne.Dom.Layouts Namespace


IFormat.Heading Property

[image]

LinkOne WebView API
Format..::.IFormat..::.Heading Property
Format Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IHeading IFormat.Heading { get; }
Visual Basic (Declaration)
Private ReadOnly Property Heading As IHeading
    Implements IFormat.Heading
Visual C++
private:
virtual property IHeading^ Heading {
    IHeading^ get () sealed = IFormat::Heading::get;
}

Implements

IFormat..::.Heading

See Also

Format Class
Mincom.LinkOne.Dom.Layouts Namespace


Name Property

[image]

LinkOne WebView API
Format..::.Name Property
Format Class See Also Send Feedback
Gets or sets the Name of the FormatAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IFormat..::.Name

See Also

Format Class
Mincom.LinkOne.Dom.Layouts Namespace


ShowDefaultNoteIconColumn Property

[image]

LinkOne WebView API
Format..::.ShowDefaultNoteIconColumn Property
Format Class See Also Send Feedback
Gets or sets whether or not to show the default note icon column

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool ShowDefaultNoteIconColumn { get; set; }
Visual Basic (Declaration)
Public Property ShowDefaultNoteIconColumn As Boolean
Visual C++
public:
virtual property bool ShowDefaultNoteIconColumn {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IFormat..::.ShowDefaultNoteIconColumn

See Also

Format Class
Mincom.LinkOne.Dom.Layouts Namespace


FormatCollection Class

[image]

LinkOne WebView API
FormatCollection Class
Members See Also Send Feedback
Represents a collection of Format objects that can be accessed by index.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class FormatCollection : Collection<Format>,
    IReadOnlyList<Format>, IReadOnlyCollection<Format>, IEnumerable<Format>,
    IFormatCollection, ICollection<IFormat>, IEnumerable<IFormat>,
    IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class FormatCollection _
    Inherits Collection(Of Format) _
    Implements IReadOnlyList(Of Format), IReadOnlyCollection(Of Format),  _
    IEnumerable(Of Format), IFormatCollection, ICollection(Of IFormat),  _
    IEnumerable(Of IFormat), IEnumerable
Visual C++
[SerializableAttribute]
public ref class FormatCollection sealed : public Collection<Format^>,
    IReadOnlyList<Format^>, IReadOnlyCollection<Format^>, IEnumerable<Format^>,
    IFormatCollection, ICollection<IFormat^>, IEnumerable<IFormat^>,
    IEnumerable

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection<(Of <( Format >)>)
Mincom.LinkOne.Dom.Layouts..::.FormatCollection

See Also

FormatCollection Members
Mincom.LinkOne.Dom.Layouts Namespace


FormatCollection Members

[image] [image]

LinkOne WebView API
FormatCollection Members
FormatCollection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The FormatCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Format >)>).)
AddRange | Adds the items of the specified collection to the end of the LayoutCollection.
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Format >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Format >)>).)
Contains | Overloaded.
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( Format >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Format >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Format >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Format >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Format >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Format >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Format >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Format >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( Format >)>).)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Format >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Format >)>).)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds an item to the IList. (Inherited from Collection<(Of <( Format >)>).)
ICollection<(Of <(IFormat>)>)..::.Add |
IList..::.Contains | Determines whether the IList contains a specific value. (Inherited from Collection<(Of <( Format >)>).)
ICollection<(Of <(IFormat>)>)..::.Contains |
ICollection..::.CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection<(Of <( Format >)>).)
ICollection<(Of <(IFormat>)>)..::.CopyTo |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection<(Of <( Format >)>).)
IEnumerable<(Of <(IFormat>)>)..::.GetEnumerator |
IList..::.IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection<(Of <( Format >)>).)
IList..::.Insert | Inserts an item into the IList at the specified index. (Inherited from Collection<(Of <( Format >)>).)
IList..::.IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection<(Of <( Format >)>).)
IsReadOnly | Overloaded.
IList..::.IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection<(Of <( Format >)>).)
ICollection..::.IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection<(Of <( Format >)>).)
IList..::.Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( Format >)>).)
IFormatCollection..::.Item |
IList..::.Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection<(Of <( Format >)>).)
ICollection<(Of <(IFormat>)>)..::.Remove |
ICollection..::.SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection<(Of <( Format >)>).)

See Also

FormatCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


FormatCollection Methods

[image] [image]

LinkOne WebView API
FormatCollection Methods
FormatCollection Class See Also Send Feedback

The FormatCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Format >)>).)
AddRange | Adds the items of the specified collection to the end of the LayoutCollection.
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Format >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Format >)>).)
Contains | Overloaded.
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( Format >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Format >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Format >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Format >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Format >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Format >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Format >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Format >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( Format >)>).)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds an item to the IList. (Inherited from Collection<(Of <( Format >)>).)
ICollection<(Of <(IFormat>)>)..::.Add |
IList..::.Contains | Determines whether the IList contains a specific value. (Inherited from Collection<(Of <( Format >)>).)
ICollection<(Of <(IFormat>)>)..::.Contains |
ICollection..::.CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection<(Of <( Format >)>).)
ICollection<(Of <(IFormat>)>)..::.CopyTo |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection<(Of <( Format >)>).)
IEnumerable<(Of <(IFormat>)>)..::.GetEnumerator |
IList..::.IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection<(Of <( Format >)>).)
IList..::.Insert | Inserts an item into the IList at the specified index. (Inherited from Collection<(Of <( Format >)>).)
IList..::.Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection<(Of <( Format >)>).)
ICollection<(Of <(IFormat>)>)..::.Remove |

See Also

FormatCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


ICollection(IFormat).Add Method

[image]

LinkOne WebView API
FormatCollection..::.ICollection<(Of <(IFormat>)>)..::.Add Method
FormatCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<IFormat>.Add(
    IFormat item
)
Visual Basic (Declaration)
Private Sub Add ( _
    item As IFormat _
) Implements ICollection(Of IFormat).Add
Visual C++
private:
virtual void Add(
    IFormat^ item
) sealed = ICollection<IFormat^>::Add

Parameters

item
Type: Mincom.LinkOne.Dom.Layouts..::.IFormat

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

FormatCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


ICollection(IFormat).Contains Method

[image]

LinkOne WebView API
FormatCollection..::.ICollection<(Of <(IFormat>)>)..::.Contains Method
FormatCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<IFormat>.Contains(
    IFormat item
)
Visual Basic (Declaration)
Private Function Contains ( _
    item As IFormat _
) As Boolean Implements ICollection(Of IFormat).Contains
Visual C++
private:
virtual bool Contains(
    IFormat^ item
) sealed = ICollection<IFormat^>::Contains

Parameters

item
Type: Mincom.LinkOne.Dom.Layouts..::.IFormat

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

FormatCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


ICollection(IFormat).CopyTo Method

[image]

LinkOne WebView API
FormatCollection..::.ICollection<(Of <(IFormat>)>)..::.CopyTo Method
FormatCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<IFormat>.CopyTo(
    IFormat[] array,
    int arrayIndex
)
Visual Basic (Declaration)
Private Sub CopyTo ( _
    array As IFormat(), _
    arrayIndex As Integer _
) Implements ICollection(Of IFormat).CopyTo
Visual C++
private:
virtual void CopyTo(
    array<IFormat^>^ array,
    int arrayIndex
) sealed = ICollection<IFormat^>::CopyTo

Parameters

array
Type: array< Mincom.LinkOne.Dom.Layouts..::.IFormat >[]()[]
arrayIndex
Type: System..::.Int32

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

FormatCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


IEnumerable(IFormat).GetEnumerator Method

[image]

LinkOne WebView API
FormatCollection..::.IEnumerable<(Of <(IFormat>)>)..::.GetEnumerator Method
FormatCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator<IFormat> IEnumerable<IFormat>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of IFormat)
    Implements IEnumerable(Of IFormat).GetEnumerator
Visual C++
private:
virtual IEnumerator<IFormat^>^ GetEnumerator() sealed = IEnumerable<IFormat^>::GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

FormatCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


ICollection(IFormat).Remove Method

[image]

LinkOne WebView API
FormatCollection..::.ICollection<(Of <(IFormat>)>)..::.Remove Method
FormatCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<IFormat>.Remove(
    IFormat item
)
Visual Basic (Declaration)
Private Function Remove ( _
    item As IFormat _
) As Boolean Implements ICollection(Of IFormat).Remove
Visual C++
private:
virtual bool Remove(
    IFormat^ item
) sealed = ICollection<IFormat^>::Remove

Parameters

item
Type: Mincom.LinkOne.Dom.Layouts..::.IFormat

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

FormatCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


AddRange Method

[image]

LinkOne WebView API
FormatCollection..::.AddRange Method
FormatCollection Class See Also Send Feedback
Adds the items of the specified collection to the end of the LayoutCollection.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void AddRange(
    IEnumerable<Format> collection
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    collection As IEnumerable(Of Format) _
)
Visual C++
public:
void AddRange(
    IEnumerable<Format^>^ collection
)

Parameters

collection
Type: System.Collections.Generic..::.IEnumerable<(Of <( Format >)>)
The collection whose elements should be added to the LayoutCollection.

See Also

FormatCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


Contains Method

[image] [image]

LinkOne WebView API
FormatCollection..::.Contains Method
FormatCollection Class See Also Send Feedback

Overload List

Name | Description
Contains(T) | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Format >)>).)
Contains(String) | Returns true if a format with the given name is in the collection.

See Also

FormatCollection Class
FormatCollection Members
Mincom.LinkOne.Dom.Layouts Namespace


Contains Method (String)

[image]

LinkOne WebView API
FormatCollection..::.Contains Method (String)
FormatCollection Class See Also Send Feedback
Returns true if a format with the given name is in the collection.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    string formatName
)
Visual Basic (Declaration)
Public Function Contains ( _
    formatName As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ formatName
) sealed

Parameters

formatName
Type: System..::.String

Return Value

Implements

IFormatCollection..::.Contains(String)

See Also

FormatCollection Class
Contains Overload
Mincom.LinkOne.Dom.Layouts Namespace


FormatCollection Properties

[image] [image]

LinkOne WebView API
FormatCollection Properties
FormatCollection Class See Also Send Feedback

The FormatCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Format >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Format >)>).)

Explicit Interface Implementations

Name | Description
IList..::.IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection<(Of <( Format >)>).)
IsReadOnly | Overloaded.
IList..::.IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection<(Of <( Format >)>).)
ICollection..::.IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection<(Of <( Format >)>).)
IList..::.Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( Format >)>).)
IFormatCollection..::.Item |
ICollection..::.SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection<(Of <( Format >)>).)

See Also

FormatCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


IFormatCollection.Item Property

[image]

LinkOne WebView API
FormatCollection..::.IFormatCollection..::.Item Property
FormatCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IFormat IFormatCollection.Item[
    string formatName
] { get; }
Visual Basic (Declaration)
Private ReadOnly Property Item ( _
    formatName As String _
) As IFormat Implements IFormatCollection.Item
Visual C++
private:
virtual property IFormat^ Item[String^ formatName] {
    IFormat^ get (String^ formatName) sealed = IFormatCollection::Item::get;
}

Parameters

formatName
Type: System..::.String

Implements

IFormatCollection..::.Item[([(String])])

See Also

FormatCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


IsReadOnly Property

[image] [image]

LinkOne WebView API
FormatCollection..::.IsReadOnly Property
FormatCollection Class See Also Send Feedback

Overload List

Name | Description
System#Collections#Generic#ICollection{T}#IsReadOnly()()() | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from Collection<(Of <( Format >)>).)
ICollection<(Of <(IFormat>)>)..::.IsReadOnly |

See Also

FormatCollection Class
FormatCollection Members
Mincom.LinkOne.Dom.Layouts Namespace


ICollection(IFormat).IsReadOnly Property

[image]

LinkOne WebView API
FormatCollection..::.ICollection<(Of <(IFormat>)>)..::.IsReadOnly Property
FormatCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<IFormat>.IsReadOnly { get; }
Visual Basic (Declaration)
Private ReadOnly Property IsReadOnly As Boolean
    Implements ICollection(Of IFormat).IsReadOnly
Visual C++
private:
virtual property bool IsReadOnly {
    bool get () sealed = ICollection<IFormat^>::IsReadOnly::get;
}

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

FormatCollection Class
FormatCollection Overload
Mincom.LinkOne.Dom.Layouts Namespace


Item Property

[image] [image]

LinkOne WebView API
FormatCollection..::.Item Property
FormatCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( Format >)>).)
Item[([(String])]) | Gets the format with the given name from the collection.

See Also

FormatCollection Class
FormatCollection Members
Mincom.LinkOne.Dom.Layouts Namespace


Item Property (String)

[image]

LinkOne WebView API
FormatCollection..::.Item Property (String)
FormatCollection Class See Also Send Feedback
Gets the format with the given name from the collection.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Format this[
    string formatName
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    formatName As String _
) As Format
Visual C++
public:
property Format^ default[String^ formatName] {
    Format^ get (String^ formatName);
}

Parameters

formatName
Type: System..::.String
The name of the format.

Return Value

The format with the given name, if found; otherwise, null.

See Also

FormatCollection Class
Item Overload
Mincom.LinkOne.Dom.Layouts Namespace


Heading Class

[image]

LinkOne WebView API
Heading Class
Members See Also Send Feedback
Represents the column headings for a format. Column headings are just a layout table.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public class Heading : LayoutTable, IHeading,
    ILayoutTable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class Heading _
    Inherits LayoutTable _
    Implements IHeading, ILayoutTable
Visual C++
[SerializableAttribute]
public ref class Heading : public LayoutTable,
    IHeading, ILayoutTable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Layouts..::.LayoutTable
Mincom.LinkOne.Dom.Layouts..::.Heading

See Also

Heading Members
Mincom.LinkOne.Dom.Layouts Namespace


Heading Members

[image] [image]

LinkOne WebView API
Heading Members
Heading Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The Heading type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
FormatExpand | Gets or sets the FormatExpand property of the TableFormat. (Inherited from LayoutTable.)
Rows | The collection of rows in the table. (Inherited from LayoutTable.)

Explicit Interface Implementations

Name | Description
ILayoutTable..::.FormatExpand | (Inherited from LayoutTable.)
ILayoutTable..::.Rows | (Inherited from LayoutTable.)

See Also

Heading Class
Mincom.LinkOne.Dom.Layouts Namespace


Heading Methods

[image] [image]

LinkOne WebView API
Heading Methods
Heading Class See Also Send Feedback

The Heading type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Heading Class
Mincom.LinkOne.Dom.Layouts Namespace


Heading Properties

[image] [image]

LinkOne WebView API
Heading Properties
Heading Class See Also Send Feedback

The Heading type exposes the following members.

Properties

Name | Description
FormatExpand | Gets or sets the FormatExpand property of the TableFormat. (Inherited from LayoutTable.)
Rows | The collection of rows in the table. (Inherited from LayoutTable.)

Explicit Interface Implementations

Name | Description
ILayoutTable..::.FormatExpand | (Inherited from LayoutTable.)
ILayoutTable..::.Rows | (Inherited from LayoutTable.)

See Also

Heading Class
Mincom.LinkOne.Dom.Layouts Namespace


HorizontalAlignment Enumeration

[image]

LinkOne WebView API
HorizontalAlignment Enumeration
See Also Send Feedback
Allowed values for horizontal text alignment.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum HorizontalAlignment
Visual Basic (Declaration)
Public Enumeration HorizontalAlignment
Visual C++
public enum class HorizontalAlignment

Members

Member name | Description
Left | The text is aligned to the left of its container.
Center | The text is aligned with the center of its container.
Right | The text is aligned to the right of its container.

See Also

Mincom.LinkOne.Dom.Layouts Namespace


IBookField Interface

[image]

LinkOne WebView API
IBookField Interface
Members See Also Send Feedback
Represents a book field in a layout cell.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IBookField : ICellContents
Visual Basic (Declaration)
Public Interface IBookField _
    Implements ICellContents
Visual C++
public interface class IBookField : ICellContents

See Also

IBookField Members
Mincom.LinkOne.Dom.Layouts Namespace


IBookField Members

[image] [image]

LinkOne WebView API
IBookField Members
IBookField Interface Properties See Also Send Feedback

The IBookField type exposes the following members.

Properties

Name | Description
Name | The name of the book field.

See Also

IBookField Interface
Mincom.LinkOne.Dom.Layouts Namespace


IBookField Properties

[image] [image]

LinkOne WebView API
IBookField Properties
IBookField Interface See Also Send Feedback

The IBookField type exposes the following members.

Properties

Name | Description
Name | The name of the book field.

See Also

IBookField Interface
Mincom.LinkOne.Dom.Layouts Namespace


Name Property

[image]

LinkOne WebView API
IBookField..::.Name Property
IBookField Interface See Also Send Feedback
The name of the book field.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Name { get; set; }
Visual Basic (Declaration)
Property Name As String
Visual C++
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

IBookField Interface
Mincom.LinkOne.Dom.Layouts Namespace


IBorderAttributes Interface

[image]

LinkOne WebView API
IBorderAttributes Interface
Members See Also Send Feedback
Attributes that specify which borders are to be drawn.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IBorderAttributes
Visual Basic (Declaration)
Public Interface IBorderAttributes
Visual C++
public interface class IBorderAttributes

See Also

IBorderAttributes Members
Mincom.LinkOne.Dom.Layouts Namespace


IBorderAttributes Members

[image] [image]

LinkOne WebView API
IBorderAttributes Members
IBorderAttributes Interface Properties See Also Send Feedback

The IBorderAttributes type exposes the following members.

Properties

Name | Description
Border | Gets or sets all of the borders dimensions.
Bottom | Gets or sets the Bottom border dimension.
Left | Gets or sets the Left border dimension.
Right | Gets or sets the Right border dimension.
Top | Gets or sets the Top border dimension.

See Also

IBorderAttributes Interface
Mincom.LinkOne.Dom.Layouts Namespace


IBorderAttributes Properties

[image] [image]

LinkOne WebView API
IBorderAttributes Properties
IBorderAttributes Interface See Also Send Feedback

The IBorderAttributes type exposes the following members.

Properties

Name | Description
Border | Gets or sets all of the borders dimensions.
Bottom | Gets or sets the Bottom border dimension.
Left | Gets or sets the Left border dimension.
Right | Gets or sets the Right border dimension.
Top | Gets or sets the Top border dimension.

See Also

IBorderAttributes Interface
Mincom.LinkOne.Dom.Layouts Namespace


Border Property

[image]

LinkOne WebView API
IBorderAttributes..::.Border Property
IBorderAttributes Interface See Also Send Feedback
Gets or sets all of the borders dimensions.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension Border { get; set; }
Visual Basic (Declaration)
Property Border As IDimension
Visual C++
property IDimension^ Border {
    IDimension^ get ();
    void set (IDimension^ value);
}

See Also

IBorderAttributes Interface
Mincom.LinkOne.Dom.Layouts Namespace


Bottom Property

[image]

LinkOne WebView API
IBorderAttributes..::.Bottom Property
IBorderAttributes Interface See Also Send Feedback
Gets or sets the Bottom border dimension.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension Bottom { get; set; }
Visual Basic (Declaration)
Property Bottom As IDimension
Visual C++
property IDimension^ Bottom {
    IDimension^ get ();
    void set (IDimension^ value);
}

See Also

IBorderAttributes Interface
Mincom.LinkOne.Dom.Layouts Namespace


Left Property

[image]

LinkOne WebView API
IBorderAttributes..::.Left Property
IBorderAttributes Interface See Also Send Feedback
Gets or sets the Left border dimension.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension Left { get; set; }
Visual Basic (Declaration)
Property Left As IDimension
Visual C++
property IDimension^ Left {
    IDimension^ get ();
    void set (IDimension^ value);
}

See Also

IBorderAttributes Interface
Mincom.LinkOne.Dom.Layouts Namespace


Right Property

[image]

LinkOne WebView API
IBorderAttributes..::.Right Property
IBorderAttributes Interface See Also Send Feedback
Gets or sets the Right border dimension.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension Right { get; set; }
Visual Basic (Declaration)
Property Right As IDimension
Visual C++
property IDimension^ Right {
    IDimension^ get ();
    void set (IDimension^ value);
}

See Also

IBorderAttributes Interface
Mincom.LinkOne.Dom.Layouts Namespace


Top Property

[image]

LinkOne WebView API
IBorderAttributes..::.Top Property
IBorderAttributes Interface See Also Send Feedback
Gets or sets the Top border dimension.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension Top { get; set; }
Visual Basic (Declaration)
Property Top As IDimension
Visual C++
property IDimension^ Top {
    IDimension^ get ();
    void set (IDimension^ value);
}

See Also

IBorderAttributes Interface
Mincom.LinkOne.Dom.Layouts Namespace


ICell Interface

[image]

LinkOne WebView API
ICell Interface
Members See Also Send Feedback
Represents a cell in a layout table row.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ICell
Visual Basic (Declaration)
Public Interface ICell
Visual C++
public interface class ICell

See Also

ICell Members
Mincom.LinkOne.Dom.Layouts Namespace


ICell Members

[image] [image]

LinkOne WebView API
ICell Members
ICell Interface Properties See Also Send Feedback

The ICell type exposes the following members.

Properties

Name | Description
Alignment | Gets or sets the cell horizontal alignment property
Blank | Gets or sets the cell blank property
Border | Gets cell border attribute
ColGap | Gets or sets the cell col gap
ColSpan | Gets or sets the cell col span
ColumnCollapse | Gets or sets the column collapse property of the cell
Contents | Gets or sets the cell contents
DecimalAlign | Gets or sets the character used for decimal aligning the cell contents.
Expand | Gets or sets the cell expand property
FirstOnly | Gets or sets the cell first only property
FixedWidth | Gets or sets the cell fixed width property
Font | Gets the cell font attribute
Indent | Gets or sets the cell indent property
LevelIndentString | Gets or sets the level indent string (for assemblies).
MaxLines | Gets or sets the cell maxlines property
MaxWidth | Gets or sets the cell maximum width property
MinWidth | Gets or sets the cell minimum width property
RowSpan | Gets or sets the cell row span
Rules | Gets the cell rule attribute
TextFormat | Gets or sets the text format.
VAlignment | Gets or sets the cell vertical alignment property
Wrap | Gets or sets the cell wrap property

See Also

ICell Interface
Mincom.LinkOne.Dom.Layouts Namespace


ICell Properties

[image] [image]

LinkOne WebView API
ICell Properties
ICell Interface See Also Send Feedback

The ICell type exposes the following members.

Properties

Name | Description
Alignment | Gets or sets the cell horizontal alignment property
Blank | Gets or sets the cell blank property
Border | Gets cell border attribute
ColGap | Gets or sets the cell col gap
ColSpan | Gets or sets the cell col span
ColumnCollapse | Gets or sets the column collapse property of the cell
Contents | Gets or sets the cell contents
DecimalAlign | Gets or sets the character used for decimal aligning the cell contents.
Expand | Gets or sets the cell expand property
FirstOnly | Gets or sets the cell first only property
FixedWidth | Gets or sets the cell fixed width property
Font | Gets the cell font attribute
Indent | Gets or sets the cell indent property
LevelIndentString | Gets or sets the level indent string (for assemblies).
MaxLines | Gets or sets the cell maxlines property
MaxWidth | Gets or sets the cell maximum width property
MinWidth | Gets or sets the cell minimum width property
RowSpan | Gets or sets the cell row span
Rules | Gets the cell rule attribute
TextFormat | Gets or sets the text format.
VAlignment | Gets or sets the cell vertical alignment property
Wrap | Gets or sets the cell wrap property

See Also

ICell Interface
Mincom.LinkOne.Dom.Layouts Namespace


Alignment Property

[image]

LinkOne WebView API
ICell..::.Alignment Property
ICell Interface See Also Send Feedback
Gets or sets the cell horizontal alignment property

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
HorizontalAlignment Alignment { get; set; }
Visual Basic (Declaration)
Property Alignment As HorizontalAlignment
Visual C++
property HorizontalAlignment Alignment {
    HorizontalAlignment get ();
    void set (HorizontalAlignment value);
}

Remarks

Aligns the contents of the cell to the specified edge of the cell.

See Also

ICell Interface
Mincom.LinkOne.Dom.Layouts Namespace


Blank Property

[image]

LinkOne WebView API
ICell..::.Blank Property
ICell Interface See Also Send Feedback
Gets or sets the cell blank property

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool Blank { get; set; }
Visual Basic (Declaration)
Property Blank As Boolean
Visual C++
property bool Blank {
    bool get ();
    void set (bool value);
}

Remarks

Forces the cell to be displayed as blank.

See Also

ICell Interface
Mincom.LinkOne.Dom.Layouts Namespace


Border Property

[image]

LinkOne WebView API
ICell..::.Border Property
ICell Interface See Also Send Feedback
Gets cell border attribute

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IBorderAttributes Border { get; }
Visual Basic (Declaration)
ReadOnly Property Border As IBorderAttributes
Visual C++
property IBorderAttributes^ Border {
    IBorderAttributes^ get ();
}

See Also

ICell Interface
Mincom.LinkOne.Dom.Layouts Namespace


ColGap Property

[image]

LinkOne WebView API
ICell..::.ColGap Property
ICell Interface See Also Send Feedback
Gets or sets the cell col gap

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension ColGap { get; set; }
Visual Basic (Declaration)
Property ColGap As IDimension
Visual C++
property IDimension^ ColGap {
    IDimension^ get ();
    void set (IDimension^ value);
}

Remarks

Attribute will allocate additional space to the left and right of a cell. Half of the specified colgap is placed to the left of the cell and half to the right. The additional space will be inside any borders or rules that the cell has.

See Also

ICell Interface
Mincom.LinkOne.Dom.Layouts Namespace


ColSpan Property

[image]

LinkOne WebView API
ICell..::.ColSpan Property
ICell Interface See Also Send Feedback
Gets or sets the cell col span

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int ColSpan { get; set; }
Visual Basic (Declaration)
Property ColSpan As Integer
Visual C++
property int ColSpan {
    int get ();
    void set (int value);
}

Remarks

Causes the cell to span the specified number of columns in the table.

See Also

ICell Interface
Mincom.LinkOne.Dom.Layouts Namespace


ColumnCollapse Property

[image]

LinkOne WebView API
ICell..::.ColumnCollapse Property
ICell Interface See Also Send Feedback
Gets or sets the column collapse property of the cell

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ColumnCollapse { get; set; }
Visual Basic (Declaration)
Property ColumnCollapse As Boolean
Visual C++
property bool ColumnCollapse {
    bool get ();
    void set (bool value);
}

Remarks

If all cells in a column are blank the column will automatically collapse to 0 width and not be visible. If ColumnCollapse is false on any cell in a column the column will be prevented from collapsing.

See Also

ICell Interface
Mincom.LinkOne.Dom.Layouts Namespace


Contents Property

[image]

LinkOne WebView API
ICell..::.Contents Property
ICell Interface See Also Send Feedback
Gets or sets the cell contents

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ICellContents Contents { get; set; }
Visual Basic (Declaration)
Property Contents As ICellContents
Visual C++
property ICellContents^ Contents {
    ICellContents^ get ();
    void set (ICellContents^ value);
}

See Also

ICell Interface
Mincom.LinkOne.Dom.Layouts Namespace


DecimalAlign Property

[image]

LinkOne WebView API
ICell..::.DecimalAlign Property
ICell Interface See Also Send Feedback
Gets or sets the character used for decimal aligning the cell contents.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string DecimalAlign { get; set; }
Visual Basic (Declaration)
Property DecimalAlign As String
Visual C++
property String^ DecimalAlign {
    String^ get ();
    void set (String^ value);
}

Remarks

Used in parts list entry formats. The cell contents are aligned with all other occurences of the same cell in the parts list. If null, then no aligning takes place, if an empty string then aligning takes place at the first non-numeric character, otherwise aligning takes place at the first occurrance of the first character in the string.

See Also

ICell Interface
Mincom.LinkOne.Dom.Layouts Namespace


Expand Property

[image]

LinkOne WebView API
ICell..::.Expand Property
ICell Interface See Also Send Feedback
Gets or sets the cell expand property

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool Expand { get; set; }
Visual Basic (Declaration)
Property Expand As Boolean
Visual C++
property bool Expand {
    bool get ();
    void set (bool value);
}

Remarks

If the width of the area in which the cell is being displayed is wider than the maximum amount that the cells needs, then the cell will be stretched to fill the entire width.

See Also

ICell Interface
Mincom.LinkOne.Dom.Layouts Namespace


FirstOnly Property

[image]

LinkOne WebView API
ICell..::.FirstOnly Property
ICell Interface See Also Send Feedback
Gets or sets the cell first only property

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool FirstOnly { get; set; }
Visual Basic (Declaration)
Property FirstOnly As Boolean
Visual C++
property bool FirstOnly {
    bool get ();
    void set (bool value);
}

Remarks

Cells with this attribute are displayed as blank except when being displayed in the first parts list entry on a particular printed page. If a parts list spreads across several sheets when printed, a cell will only be visible in the first entry on each sheet.

See Also

ICell Interface
Mincom.LinkOne.Dom.Layouts Namespace


FixedWidth Property

[image]

LinkOne WebView API
ICell..::.FixedWidth Property
ICell Interface See Also Send Feedback
Gets or sets the cell fixed width property

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension FixedWidth { get; set; }
Visual Basic (Declaration)
Property FixedWidth As IDimension
Visual C++
property IDimension^ FixedWidth {
    IDimension^ get ();
    void set (IDimension^ value);
}

Remarks

Specifies how wide the cell will be. The cell cannot be narrower than this width but it may get stretched wider if forced to by wider cells in the same column.

See Also

ICell Interface
Mincom.LinkOne.Dom.Layouts Namespace


Font Property

[image]

LinkOne WebView API
ICell..::.Font Property
ICell Interface See Also Send Feedback
Gets the cell font attribute

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IFontAttributes Font { get; }
Visual Basic (Declaration)
ReadOnly Property Font As IFontAttributes
Visual C++
property IFontAttributes^ Font {
    IFontAttributes^ get ();
}

See Also

ICell Interface
Mincom.LinkOne.Dom.Layouts Namespace


Indent Property

[image]

LinkOne WebView API
ICell..::.Indent Property
ICell Interface See Also Send Feedback
Gets or sets the cell indent property

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension Indent { get; set; }
Visual Basic (Declaration)
Property Indent As IDimension
Visual C++
property IDimension^ Indent {
    IDimension^ get ();
    void set (IDimension^ value);
}

Remarks

Indents the first line of the text in the cell by the specified amount. If a negative number is used, it will produce a hanging indent (i.e. the first line will appear not indented but the remaining lines in the cell will.

See Also

ICell Interface
Mincom.LinkOne.Dom.Layouts Namespace


LevelIndentString Property

[image]

LinkOne WebView API
ICell..::.LevelIndentString Property
ICell Interface See Also Send Feedback
Gets or sets the level indent string (for assemblies).

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string LevelIndentString { get; set; }
Visual Basic (Declaration)
Property LevelIndentString As String
Visual C++
property String^ LevelIndentString {
    String^ get ();
    void set (String^ value);
}

Remarks

This property will cause test in the cell to be indended and preceded by the specified string, repeated once for each assembly level that the entry has.

See Also

ICell Interface
Mincom.LinkOne.Dom.Layouts Namespace


MaxLines Property

[image]

LinkOne WebView API
ICell..::.MaxLines Property
ICell Interface See Also Send Feedback
Gets or sets the cell maxlines property

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int MaxLines { get; set; }
Visual Basic (Declaration)
Property MaxLines As Integer
Visual C++
property int MaxLines {
    int get ();
    void set (int value);
}

Remarks

Applies to text cells that also have the WRAP attribute. The cell can wrap to nomore than the specific number of lines.

See Also

ICell Interface
Mincom.LinkOne.Dom.Layouts Namespace


MaxWidth Property

[image]

LinkOne WebView API
ICell..::.MaxWidth Property
ICell Interface See Also Send Feedback
Gets or sets the cell maximum width property

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension MaxWidth { get; set; }
Visual Basic (Declaration)
Property MaxWidth As IDimension
Visual C++
property IDimension^ MaxWidth {
    IDimension^ get ();
    void set (IDimension^ value);
}

Remarks

Specifies the maximun width that the cell is allowed to have. The cell will not be wider than this unless forced to by wider cell in the same column. The cell may become narrower than the specified width.

See Also

ICell Interface
Mincom.LinkOne.Dom.Layouts Namespace


MinWidth Property

[image]

LinkOne WebView API
ICell..::.MinWidth Property
ICell Interface See Also Send Feedback
Gets or sets the cell minimum width property

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension MinWidth { get; set; }
Visual Basic (Declaration)
Property MinWidth As IDimension
Visual C++
property IDimension^ MinWidth {
    IDimension^ get ();
    void set (IDimension^ value);
}

Remarks

Specifies the minimun width that the cell is allowed to have. The cell will not be narrower than this. The cell may become wider than the specified width.

See Also

ICell Interface
Mincom.LinkOne.Dom.Layouts Namespace


RowSpan Property

[image]

LinkOne WebView API
ICell..::.RowSpan Property
ICell Interface See Also Send Feedback
Gets or sets the cell row span

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int RowSpan { get; set; }
Visual Basic (Declaration)
Property RowSpan As Integer
Visual C++
property int RowSpan {
    int get ();
    void set (int value);
}

Remarks

Causes the cell to span the specified number of rows in the table.

See Also

ICell Interface
Mincom.LinkOne.Dom.Layouts Namespace


Rules Property

[image]

LinkOne WebView API
ICell..::.Rules Property
ICell Interface See Also Send Feedback
Gets the cell rule attribute

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IRuleAttributes Rules { get; }
Visual Basic (Declaration)
ReadOnly Property Rules As IRuleAttributes
Visual C++
property IRuleAttributes^ Rules {
    IRuleAttributes^ get ();
}

See Also

ICell Interface
Mincom.LinkOne.Dom.Layouts Namespace


TextFormat Property

[image]

LinkOne WebView API
ICell..::.TextFormat Property
ICell Interface See Also Send Feedback
Gets or sets the text format.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ITextFormat TextFormat { get; set; }
Visual Basic (Declaration)
Property TextFormat As ITextFormat
Visual C++
property ITextFormat^ TextFormat {
    ITextFormat^ get ();
    void set (ITextFormat^ value);
}

Remarks

Value can be null if no formatting is specified.

See Also

ICell Interface
Mincom.LinkOne.Dom.Layouts Namespace


VAlignment Property

[image]

LinkOne WebView API
ICell..::.VAlignment Property
ICell Interface See Also Send Feedback
Gets or sets the cell vertical alignment property

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
VerticalAlignment VAlignment { get; set; }
Visual Basic (Declaration)
Property VAlignment As VerticalAlignment
Visual C++
property VerticalAlignment VAlignment {
    VerticalAlignment get ();
    void set (VerticalAlignment value);
}

Remarks

Aligns the contents of the cell to the specifed edge of the cell.

See Also

ICell Interface
Mincom.LinkOne.Dom.Layouts Namespace


Wrap Property

[image]

LinkOne WebView API
ICell..::.Wrap Property
ICell Interface See Also Send Feedback
Gets or sets the cell wrap property

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension Wrap { get; set; }
Visual Basic (Declaration)
Property Wrap As IDimension
Visual C++
property IDimension^ Wrap {
    IDimension^ get ();
    void set (IDimension^ value);
}

Remarks

Indicates that the text can be wrapped onto multiple lines if it will not fit in the width available to the cell. The text is split at word breaks only. Will be null if no wrapping is allowed.

See Also

ICell Interface
Mincom.LinkOne.Dom.Layouts Namespace


ICellContents Interface

[image]

LinkOne WebView API
ICellContents Interface
See Also Send Feedback
Represents the contents of a layout cell.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ICellContents
Visual Basic (Declaration)
Public Interface ICellContents
Visual C++
public interface class ICellContents

See Also

Mincom.LinkOne.Dom.Layouts Namespace


IDimension Interface

[image]

LinkOne WebView API
IDimension Interface
Members See Also Send Feedback
Represents a length (or size) value in a layout.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IDimension
Visual Basic (Declaration)
Public Interface IDimension
Visual C++
public interface class IDimension

See Also

IDimension Members
Mincom.LinkOne.Dom.Layouts Namespace


IDimension Members

[image] [image]

LinkOne WebView API
IDimension Members
IDimension Interface Properties See Also Send Feedback

The IDimension type exposes the following members.

Properties

Name | Description
Size | Gets or sets the length of the dimension.
Units | Gets or sets the unit of the dimentsion.

See Also

IDimension Interface
Mincom.LinkOne.Dom.Layouts Namespace


IDimension Properties

[image] [image]

LinkOne WebView API
IDimension Properties
IDimension Interface See Also Send Feedback

The IDimension type exposes the following members.

Properties

Name | Description
Size | Gets or sets the length of the dimension.
Units | Gets or sets the unit of the dimentsion.

See Also

IDimension Interface
Mincom.LinkOne.Dom.Layouts Namespace


Size Property

[image]

LinkOne WebView API
IDimension..::.Size Property
IDimension Interface See Also Send Feedback
Gets or sets the length of the dimension.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
float Size { get; set; }
Visual Basic (Declaration)
Property Size As Single
Visual C++
property float Size {
    float get ();
    void set (float value);
}

See Also

IDimension Interface
Mincom.LinkOne.Dom.Layouts Namespace


Units Property

[image]

LinkOne WebView API
IDimension..::.Units Property
IDimension Interface See Also Send Feedback
Gets or sets the unit of the dimentsion.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
DimensionUnit Units { get; set; }
Visual Basic (Declaration)
Property Units As DimensionUnit
Visual C++
property DimensionUnit Units {
    DimensionUnit get ();
    void set (DimensionUnit value);
}

See Also

IDimension Interface
Mincom.LinkOne.Dom.Layouts Namespace


IEntryField Interface

[image]

LinkOne WebView API
IEntryField Interface
Members See Also Send Feedback
Represents a parts list entry field in a layout cell.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IEntryField : ICellContents
Visual Basic (Declaration)
Public Interface IEntryField _
    Implements ICellContents
Visual C++
public interface class IEntryField : ICellContents

See Also

IEntryField Members
Mincom.LinkOne.Dom.Layouts Namespace


IEntryField Members

[image] [image]

LinkOne WebView API
IEntryField Members
IEntryField Interface Properties See Also Send Feedback

The IEntryField type exposes the following members.

Properties

Name | Description
IsLinkIcon | Gets true if the cell is a link icon field.
IsNoteIcon | Gets true if the cell is a note icon field.
IsSelectionIcon | Gets true if the cell is a selection icon field.
Name | Gets or sets the name of the entry field.

See Also

IEntryField Interface
Mincom.LinkOne.Dom.Layouts Namespace


IEntryField Properties

[image] [image]

LinkOne WebView API
IEntryField Properties
IEntryField Interface See Also Send Feedback

The IEntryField type exposes the following members.

Properties

Name | Description
IsLinkIcon | Gets true if the cell is a link icon field.
IsNoteIcon | Gets true if the cell is a note icon field.
IsSelectionIcon | Gets true if the cell is a selection icon field.
Name | Gets or sets the name of the entry field.

See Also

IEntryField Interface
Mincom.LinkOne.Dom.Layouts Namespace


IsLinkIcon Property

[image]

LinkOne WebView API
IEntryField..::.IsLinkIcon Property
IEntryField Interface See Also Send Feedback
Gets true if the cell is a link icon field.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IsLinkIcon { get; }
Visual Basic (Declaration)
ReadOnly Property IsLinkIcon As Boolean
Visual C++
property bool IsLinkIcon {
    bool get ();
}

See Also

IEntryField Interface
Mincom.LinkOne.Dom.Layouts Namespace


IsNoteIcon Property

[image]

LinkOne WebView API
IEntryField..::.IsNoteIcon Property
IEntryField Interface See Also Send Feedback
Gets true if the cell is a note icon field.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IsNoteIcon { get; }
Visual Basic (Declaration)
ReadOnly Property IsNoteIcon As Boolean
Visual C++
property bool IsNoteIcon {
    bool get ();
}

See Also

IEntryField Interface
Mincom.LinkOne.Dom.Layouts Namespace


IsSelectionIcon Property

[image]

LinkOne WebView API
IEntryField..::.IsSelectionIcon Property
IEntryField Interface See Also Send Feedback
Gets true if the cell is a selection icon field.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IsSelectionIcon { get; }
Visual Basic (Declaration)
ReadOnly Property IsSelectionIcon As Boolean
Visual C++
property bool IsSelectionIcon {
    bool get ();
}

See Also

IEntryField Interface
Mincom.LinkOne.Dom.Layouts Namespace


Name Property

[image]

LinkOne WebView API
IEntryField..::.Name Property
IEntryField Interface See Also Send Feedback
Gets or sets the name of the entry field.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Name { get; set; }
Visual Basic (Declaration)
Property Name As String
Visual C++
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

IEntryField Interface
Mincom.LinkOne.Dom.Layouts Namespace


IFontAttributes Interface

[image]

LinkOne WebView API
IFontAttributes Interface
Members See Also Send Feedback
Specifies text font attributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IFontAttributes
Visual Basic (Declaration)
Public Interface IFontAttributes
Visual C++
public interface class IFontAttributes

See Also

IFontAttributes Members
Mincom.LinkOne.Dom.Layouts Namespace


IFontAttributes Members

[image] [image]

LinkOne WebView API
IFontAttributes Members
IFontAttributes Interface Properties See Also Send Feedback

The IFontAttributes type exposes the following members.

Properties

Name | Description
CharacterSet | Gets or sets the CharacterSet of the FontAttributes.
Family | Gets or sets the Font family of the FontAttributes.
Height | Gets or sets the Height Dimension of the FontAttributes.
Italic | Gets or sets the Italic property of the FontAttributes.
Name | Gets or sets the Name property of the FontAttributes.
Pitch | Gets or sets the Pitch property of the FontAttributes.
Strikeout | Gets or sets the Strikeout property of the FontAttributes.
Underline | Gets or sets the Underline property of the FontAttributes.
Weight | Gets or sets the Weight property of the FontAttributes.
Width | Gets or sets the Width property of the FontAttributes.

See Also

IFontAttributes Interface
Mincom.LinkOne.Dom.Layouts Namespace


IFontAttributes Properties

[image] [image]

LinkOne WebView API
IFontAttributes Properties
IFontAttributes Interface See Also Send Feedback

The IFontAttributes type exposes the following members.

Properties

Name | Description
CharacterSet | Gets or sets the CharacterSet of the FontAttributes.
Family | Gets or sets the Font family of the FontAttributes.
Height | Gets or sets the Height Dimension of the FontAttributes.
Italic | Gets or sets the Italic property of the FontAttributes.
Name | Gets or sets the Name property of the FontAttributes.
Pitch | Gets or sets the Pitch property of the FontAttributes.
Strikeout | Gets or sets the Strikeout property of the FontAttributes.
Underline | Gets or sets the Underline property of the FontAttributes.
Weight | Gets or sets the Weight property of the FontAttributes.
Width | Gets or sets the Width property of the FontAttributes.

See Also

IFontAttributes Interface
Mincom.LinkOne.Dom.Layouts Namespace


CharacterSet Property

[image]

LinkOne WebView API
IFontAttributes..::.CharacterSet Property
IFontAttributes Interface See Also Send Feedback
Gets or sets the CharacterSet of the FontAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string CharacterSet { get; set; }
Visual Basic (Declaration)
Property CharacterSet As String
Visual C++
property String^ CharacterSet {
    String^ get ();
    void set (String^ value);
}

See Also

IFontAttributes Interface
Mincom.LinkOne.Dom.Layouts Namespace


Family Property

[image]

LinkOne WebView API
IFontAttributes..::.Family Property
IFontAttributes Interface See Also Send Feedback
Gets or sets the Font family of the FontAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Family { get; set; }
Visual Basic (Declaration)
Property Family As String
Visual C++
property String^ Family {
    String^ get ();
    void set (String^ value);
}

See Also

IFontAttributes Interface
Mincom.LinkOne.Dom.Layouts Namespace


Height Property

[image]

LinkOne WebView API
IFontAttributes..::.Height Property
IFontAttributes Interface See Also Send Feedback
Gets or sets the Height Dimension of the FontAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension Height { get; set; }
Visual Basic (Declaration)
Property Height As IDimension
Visual C++
property IDimension^ Height {
    IDimension^ get ();
    void set (IDimension^ value);
}

See Also

IFontAttributes Interface
Mincom.LinkOne.Dom.Layouts Namespace


Italic Property

[image]

LinkOne WebView API
IFontAttributes..::.Italic Property
IFontAttributes Interface See Also Send Feedback
Gets or sets the Italic property of the FontAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool Italic { get; set; }
Visual Basic (Declaration)
Property Italic As Boolean
Visual C++
property bool Italic {
    bool get ();
    void set (bool value);
}

See Also

IFontAttributes Interface
Mincom.LinkOne.Dom.Layouts Namespace


Name Property

[image]

LinkOne WebView API
IFontAttributes..::.Name Property
IFontAttributes Interface See Also Send Feedback
Gets or sets the Name property of the FontAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Name { get; set; }
Visual Basic (Declaration)
Property Name As String
Visual C++
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

IFontAttributes Interface
Mincom.LinkOne.Dom.Layouts Namespace


Pitch Property

[image]

LinkOne WebView API
IFontAttributes..::.Pitch Property
IFontAttributes Interface See Also Send Feedback
Gets or sets the Pitch property of the FontAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
Pitch Pitch { get; set; }
Visual Basic (Declaration)
Property Pitch As Pitch
Visual C++
property Pitch Pitch {
    Pitch get ();
    void set (Pitch value);
}

See Also

IFontAttributes Interface
Mincom.LinkOne.Dom.Layouts Namespace


Strikeout Property

[image]

LinkOne WebView API
IFontAttributes..::.Strikeout Property
IFontAttributes Interface See Also Send Feedback
Gets or sets the Strikeout property of the FontAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool Strikeout { get; set; }
Visual Basic (Declaration)
Property Strikeout As Boolean
Visual C++
property bool Strikeout {
    bool get ();
    void set (bool value);
}

See Also

IFontAttributes Interface
Mincom.LinkOne.Dom.Layouts Namespace


Underline Property

[image]

LinkOne WebView API
IFontAttributes..::.Underline Property
IFontAttributes Interface See Also Send Feedback
Gets or sets the Underline property of the FontAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool Underline { get; set; }
Visual Basic (Declaration)
Property Underline As Boolean
Visual C++
property bool Underline {
    bool get ();
    void set (bool value);
}

See Also

IFontAttributes Interface
Mincom.LinkOne.Dom.Layouts Namespace


Weight Property

[image]

LinkOne WebView API
IFontAttributes..::.Weight Property
IFontAttributes Interface See Also Send Feedback
Gets or sets the Weight property of the FontAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
Weight Weight { get; set; }
Visual Basic (Declaration)
Property Weight As Weight
Visual C++
property Weight Weight {
    Weight get ();
    void set (Weight value);
}

See Also

IFontAttributes Interface
Mincom.LinkOne.Dom.Layouts Namespace


Width Property

[image]

LinkOne WebView API
IFontAttributes..::.Width Property
IFontAttributes Interface See Also Send Feedback
Gets or sets the Width property of the FontAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension Width { get; set; }
Visual Basic (Declaration)
Property Width As IDimension
Visual C++
property IDimension^ Width {
    IDimension^ get ();
    void set (IDimension^ value);
}

See Also

IFontAttributes Interface
Mincom.LinkOne.Dom.Layouts Namespace


IFormat Interface

[image]

LinkOne WebView API
IFormat Interface
Members See Also Send Feedback
Represents a format in a layout. Formats consist of a layout table, and optional column headings.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IFormat : ILayoutTable
Visual Basic (Declaration)
Public Interface IFormat _
    Implements ILayoutTable
Visual C++
public interface class IFormat : ILayoutTable

See Also

IFormat Members
Mincom.LinkOne.Dom.Layouts Namespace


IFormat Members

[image] [image]

LinkOne WebView API
IFormat Members
IFormat Interface Properties See Also Send Feedback

The IFormat type exposes the following members.

Properties

Name | Description
ClassName | Gets or sets the ClassName of the Format.
DefaultItemNoteColumn | Obsolete. Gets or sets the DefaultItemNoteColumn.
Description | Gets or sets the Description of the Format.
EntryGap | Gets or sets the EntryGap dimension of the Format.
FormatExpand | Gets or sets the FormatExpand property of the TableFormat. (Inherited from ILayoutTable.)
Heading | Gets the optional column headings for the Format.
HideRepeatItemIDs | Gets or sets the HideRepeatItemIDs property of the Format.
Name | Gets or sets the Name of the Format.
Rows | The collection of rows in the table. (Inherited from ILayoutTable.)
ShowDefaultNoteIconColumn | Gets or sets a value indicating whether or note to show the default note icon column.

See Also

IFormat Interface
Mincom.LinkOne.Dom.Layouts Namespace


IFormat Properties

[image] [image]

LinkOne WebView API
IFormat Properties
IFormat Interface See Also Send Feedback

The IFormat type exposes the following members.

Properties

Name | Description
ClassName | Gets or sets the ClassName of the Format.
DefaultItemNoteColumn | Obsolete. Gets or sets the DefaultItemNoteColumn.
Description | Gets or sets the Description of the Format.
EntryGap | Gets or sets the EntryGap dimension of the Format.
FormatExpand | Gets or sets the FormatExpand property of the TableFormat. (Inherited from ILayoutTable.)
Heading | Gets the optional column headings for the Format.
HideRepeatItemIDs | Gets or sets the HideRepeatItemIDs property of the Format.
Name | Gets or sets the Name of the Format.
Rows | The collection of rows in the table. (Inherited from ILayoutTable.)
ShowDefaultNoteIconColumn | Gets or sets a value indicating whether or note to show the default note icon column.

See Also

IFormat Interface
Mincom.LinkOne.Dom.Layouts Namespace


ClassName Property

[image]

LinkOne WebView API
IFormat..::.ClassName Property
IFormat Interface See Also Send Feedback
Gets or sets the ClassName of the Format.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string ClassName { get; set; }
Visual Basic (Declaration)
Property ClassName As String
Visual C++
property String^ ClassName {
    String^ get ();
    void set (String^ value);
}

See Also

IFormat Interface
Mincom.LinkOne.Dom.Layouts Namespace


DefaultItemNoteColumn Property

[image]

LinkOne WebView API
IFormat..::.DefaultItemNoteColumn Property
IFormat Interface See Also Send Feedback
Gets or sets the DefaultItemNoteColumn.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[ObsoleteAttribute("DefaultItemNoteColumn is obsolete and may be removed in future versions. Use ShowDefaultNoteIconColumn instead.",
    true)]
bool DefaultItemNoteColumn { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("DefaultItemNoteColumn is obsolete and may be removed in future versions. Use ShowDefaultNoteIconColumn instead.",  _
    True)> _
Property DefaultItemNoteColumn As Boolean
Visual C++
[ObsoleteAttribute(L"DefaultItemNoteColumn is obsolete and may be removed in future versions. Use ShowDefaultNoteIconColumn instead.",
    true)]
property bool DefaultItemNoteColumn {
    bool get ();
    void set (bool value);
}

See Also

IFormat Interface
Mincom.LinkOne.Dom.Layouts Namespace


Description Property

[image]

LinkOne WebView API
IFormat..::.Description Property
IFormat Interface See Also Send Feedback
Gets or sets the Description of the Format.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Description { get; set; }
Visual Basic (Declaration)
Property Description As String
Visual C++
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

IFormat Interface
Mincom.LinkOne.Dom.Layouts Namespace


EntryGap Property

[image]

LinkOne WebView API
IFormat..::.EntryGap Property
IFormat Interface See Also Send Feedback
Gets or sets the EntryGap dimension of the Format.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension EntryGap { get; set; }
Visual Basic (Declaration)
Property EntryGap As IDimension
Visual C++
property IDimension^ EntryGap {
    IDimension^ get ();
    void set (IDimension^ value);
}

See Also

IFormat Interface
Mincom.LinkOne.Dom.Layouts Namespace


Heading Property

[image]

LinkOne WebView API
IFormat..::.Heading Property
IFormat Interface See Also Send Feedback
Gets the optional column headings for the Format.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IHeading Heading { get; }
Visual Basic (Declaration)
ReadOnly Property Heading As IHeading
Visual C++
property IHeading^ Heading {
    IHeading^ get ();
}

See Also

IFormat Interface
Mincom.LinkOne.Dom.Layouts Namespace


HideRepeatItemIDs Property

[image]

LinkOne WebView API
IFormat..::.HideRepeatItemIDs Property
IFormat Interface See Also Send Feedback
Gets or sets the HideRepeatItemIDs property of the Format.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool HideRepeatItemIDs { get; set; }
Visual Basic (Declaration)
Property HideRepeatItemIDs As Boolean
Visual C++
property bool HideRepeatItemIDs {
    bool get ();
    void set (bool value);
}

See Also

IFormat Interface
Mincom.LinkOne.Dom.Layouts Namespace


Name Property

[image]

LinkOne WebView API
IFormat..::.Name Property
IFormat Interface See Also Send Feedback
Gets or sets the Name of the Format.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Name { get; set; }
Visual Basic (Declaration)
Property Name As String
Visual C++
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

IFormat Interface
Mincom.LinkOne.Dom.Layouts Namespace


ShowDefaultNoteIconColumn Property

[image]

LinkOne WebView API
IFormat..::.ShowDefaultNoteIconColumn Property
IFormat Interface See Also Send Feedback
Gets or sets a value indicating whether or note to show the default note icon column.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ShowDefaultNoteIconColumn { get; set; }
Visual Basic (Declaration)
Property ShowDefaultNoteIconColumn As Boolean
Visual C++
property bool ShowDefaultNoteIconColumn {
    bool get ();
    void set (bool value);
}

See Also

IFormat Interface
Mincom.LinkOne.Dom.Layouts Namespace


IFormatCollection Interface

[image]

LinkOne WebView API
IFormatCollection Interface
Members See Also Send Feedback
Represents a collection of IFormat objects that can be accessed by index.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IFormatCollection : ICollection<IFormat>,
    IEnumerable<IFormat>, IEnumerable
Visual Basic (Declaration)
Public Interface IFormatCollection _
    Implements ICollection(Of IFormat), IEnumerable(Of IFormat),  _
    IEnumerable
Visual C++
public interface class IFormatCollection : ICollection<IFormat^>,
    IEnumerable<IFormat^>, IEnumerable

See Also

IFormatCollection Members
Mincom.LinkOne.Dom.Layouts Namespace


IFormatCollection Members

[image] [image]

LinkOne WebView API
IFormatCollection Members
IFormatCollection Interface Methods Properties See Also Send Feedback

The IFormatCollection type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IFormat >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IFormat >)>).)
Contains | Overloaded.
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( IFormat >)>).)
GetEnumerator | Overloaded.
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IFormat >)>).)

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IFormat >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( IFormat >)>).)
Item | Gets the format with the given name from the collection.

See Also

IFormatCollection Interface
Mincom.LinkOne.Dom.Layouts Namespace


IFormatCollection Methods

[image] [image]

LinkOne WebView API
IFormatCollection Methods
IFormatCollection Interface See Also Send Feedback

The IFormatCollection type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IFormat >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IFormat >)>).)
Contains | Overloaded.
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( IFormat >)>).)
GetEnumerator | Overloaded.
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IFormat >)>).)

See Also

IFormatCollection Interface
Mincom.LinkOne.Dom.Layouts Namespace


Contains Method

[image] [image]

LinkOne WebView API
IFormatCollection..::.Contains Method
IFormatCollection Interface See Also Send Feedback

Overload List

Name | Description
Contains(T) | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from ICollection<(Of <( IFormat >)>).)
Contains(String) | Returns true if a format with the given name is in the collection.

See Also

IFormatCollection Interface
IFormatCollection Members
Mincom.LinkOne.Dom.Layouts Namespace


Contains Method (String)

[image]

LinkOne WebView API
IFormatCollection..::.Contains Method (String)
IFormatCollection Interface See Also Send Feedback
Returns true if a format with the given name is in the collection.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool Contains(
    string formatName
)
Visual Basic (Declaration)
Function Contains ( _
    formatName As String _
) As Boolean
Visual C++
bool Contains(
    String^ formatName
)

Parameters

formatName
Type: System..::.String
Name of the format.

Return Value

true if this contains the specified format name; otherwise, false.

See Also

IFormatCollection Interface
Contains Overload
Mincom.LinkOne.Dom.Layouts Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
IFormatCollection..::.GetEnumerator Method
IFormatCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( IFormat >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IFormatCollection Interface
IFormatCollection Members
Mincom.LinkOne.Dom.Layouts Namespace


IFormatCollection Properties

[image] [image]

LinkOne WebView API
IFormatCollection Properties
IFormatCollection Interface See Also Send Feedback

The IFormatCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IFormat >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( IFormat >)>).)
Item | Gets the format with the given name from the collection.

See Also

IFormatCollection Interface
Mincom.LinkOne.Dom.Layouts Namespace


Item Property

[image]

LinkOne WebView API
IFormatCollection..::.Item Property
IFormatCollection Interface See Also Send Feedback
Gets the format with the given name from the collection.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IFormat this[
    string formatName
] { get; }
Visual Basic (Declaration)
ReadOnly Default Property Item ( _
    formatName As String _
) As IFormat
Visual C++
property IFormat^ default[String^ formatName] {
    IFormat^ get (String^ formatName);
}

Parameters

formatName
Type: System..::.String
The name of the format.

Return Value

The format with the given name, if found; otherwise, null.

See Also

IFormatCollection Interface
Mincom.LinkOne.Dom.Layouts Namespace


IHeading Interface

[image]

LinkOne WebView API
IHeading Interface
Members See Also Send Feedback
Represents the column headings for a format. Column headings are just a layout table.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IHeading : ILayoutTable
Visual Basic (Declaration)
Public Interface IHeading _
    Implements ILayoutTable
Visual C++
public interface class IHeading : ILayoutTable

See Also

IHeading Members
Mincom.LinkOne.Dom.Layouts Namespace


IHeading Members

[image] [image]

LinkOne WebView API
IHeading Members
IHeading Interface Properties See Also Send Feedback

The IHeading type exposes the following members.

Properties

Name | Description
FormatExpand | Gets or sets the FormatExpand property of the TableFormat. (Inherited from ILayoutTable.)
Rows | The collection of rows in the table. (Inherited from ILayoutTable.)

See Also

IHeading Interface
Mincom.LinkOne.Dom.Layouts Namespace


IHeading Properties

[image] [image]

LinkOne WebView API
IHeading Properties
IHeading Interface See Also Send Feedback

The IHeading type exposes the following members.

Properties

Name | Description
FormatExpand | Gets or sets the FormatExpand property of the TableFormat. (Inherited from ILayoutTable.)
Rows | The collection of rows in the table. (Inherited from ILayoutTable.)

See Also

IHeading Interface
Mincom.LinkOne.Dom.Layouts Namespace


ILayout Interface

[image]

LinkOne WebView API
ILayout Interface
Members See Also Send Feedback
A LinkOne Layout, defines the format of the parts list for screen and printing.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ILayout
Visual Basic (Declaration)
Public Interface ILayout
Visual C++
public interface class ILayout

See Also

ILayout Members
Mincom.LinkOne.Dom.Layouts Namespace


ILayout Members

[image] [image]

LinkOne WebView API
ILayout Members
ILayout Interface Properties See Also Send Feedback

The ILayout type exposes the following members.

Properties

Name | Description
BlankPageMessage | Gets the message string to be dispalyed on a blank print page.
Description | Gets or sets the layout Description.
DisplayName | Gets the display text of the layout.
Errors | A list of exceptions from loading this layout.
Formats | Returns an enumerator that can iterate through the collection of formats contained within the layout.
Id | Gets or sets Gets the layout Id.
LanguageCode | Gets or sets the layout ISO639 language code.
ListFirstMargins | Gets or sets the list margins for the first list page.
ListMargins | Gets sets the list margins
ListSheetFacing | Gets or sets the ListSheetFacing attribute.
Margins | Gets or sets the base margins for the layout.
PageOrder | Gets or sets the Page Order attribute.
PictureFirstMargins | Gets or sets the picture margins for the first picture page.
PictureMargins | Gets or sets the picture margins.
PictureSheetFacing | Gets or sets the PicSheetFacing attribute.
PictureTitlesField | Gets or sets the Picture Titles Field layout attribute.
PreferredListTitle | Gets or sets the Preferred List Title layout attribute.
PreferredSearchSet | Gets or sets the Preferred Search Set layout attribute.
RepeatSheet | Gets or sets the Repeat Sheet attribute.
SecurityLock | Gets or sets the layout Security Lock.
SheetFacing | Gets or sets the layout Sheet Facing attribute.
Source | Gets the source of the layout.

See Also

ILayout Interface
Mincom.LinkOne.Dom.Layouts Namespace


ILayout Properties

[image] [image]

LinkOne WebView API
ILayout Properties
ILayout Interface See Also Send Feedback

The ILayout type exposes the following members.

Properties

Name | Description
BlankPageMessage | Gets the message string to be dispalyed on a blank print page.
Description | Gets or sets the layout Description.
DisplayName | Gets the display text of the layout.
Errors | A list of exceptions from loading this layout.
Formats | Returns an enumerator that can iterate through the collection of formats contained within the layout.
Id | Gets or sets Gets the layout Id.
LanguageCode | Gets or sets the layout ISO639 language code.
ListFirstMargins | Gets or sets the list margins for the first list page.
ListMargins | Gets sets the list margins
ListSheetFacing | Gets or sets the ListSheetFacing attribute.
Margins | Gets or sets the base margins for the layout.
PageOrder | Gets or sets the Page Order attribute.
PictureFirstMargins | Gets or sets the picture margins for the first picture page.
PictureMargins | Gets or sets the picture margins.
PictureSheetFacing | Gets or sets the PicSheetFacing attribute.
PictureTitlesField | Gets or sets the Picture Titles Field layout attribute.
PreferredListTitle | Gets or sets the Preferred List Title layout attribute.
PreferredSearchSet | Gets or sets the Preferred Search Set layout attribute.
RepeatSheet | Gets or sets the Repeat Sheet attribute.
SecurityLock | Gets or sets the layout Security Lock.
SheetFacing | Gets or sets the layout Sheet Facing attribute.
Source | Gets the source of the layout.

See Also

ILayout Interface
Mincom.LinkOne.Dom.Layouts Namespace


BlankPageMessage Property

[image]

LinkOne WebView API
ILayout..::.BlankPageMessage Property
ILayout Interface See Also Send Feedback
Gets the message string to be dispalyed on a blank print page.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string BlankPageMessage { get; set; }
Visual Basic (Declaration)
Property BlankPageMessage As String
Visual C++
property String^ BlankPageMessage {
    String^ get ();
    void set (String^ value);
}

See Also

ILayout Interface
Mincom.LinkOne.Dom.Layouts Namespace


Description Property

[image]

LinkOne WebView API
ILayout..::.Description Property
ILayout Interface See Also Send Feedback
Gets or sets the layout Description.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Description { get; set; }
Visual Basic (Declaration)
Property Description As String
Visual C++
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

ILayout Interface
Mincom.LinkOne.Dom.Layouts Namespace


DisplayName Property

[image]

LinkOne WebView API
ILayout..::.DisplayName Property
ILayout Interface See Also Send Feedback
Gets the display text of the layout.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string DisplayName { get; }
Visual Basic (Declaration)
ReadOnly Property DisplayName As String
Visual C++
property String^ DisplayName {
    String^ get ();
}

See Also

ILayout Interface
Mincom.LinkOne.Dom.Layouts Namespace


Errors Property

[image]

LinkOne WebView API
ILayout..::.Errors Property
ILayout Interface See Also Send Feedback
A list of exceptions from loading this layout.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IExceptionCollection Errors { get; }
Visual Basic (Declaration)
ReadOnly Property Errors As IExceptionCollection
Visual C++
property IExceptionCollection^ Errors {
    IExceptionCollection^ get ();
}

See Also

ILayout Interface
Mincom.LinkOne.Dom.Layouts Namespace


Formats Property

[image]

LinkOne WebView API
ILayout..::.Formats Property
ILayout Interface See Also Send Feedback
Returns an enumerator that can iterate through the collection of formats contained within the layout.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IFormatCollection Formats { get; }
Visual Basic (Declaration)
ReadOnly Property Formats As IFormatCollection
Visual C++
property IFormatCollection^ Formats {
    IFormatCollection^ get ();
}

See Also

ILayout Interface
Mincom.LinkOne.Dom.Layouts Namespace


Id Property

[image]

LinkOne WebView API
ILayout..::.Id Property
ILayout Interface See Also Send Feedback
Gets or sets Gets the layout Id.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Id { get; set; }
Visual Basic (Declaration)
Property Id As String
Visual C++
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

ILayout Interface
Mincom.LinkOne.Dom.Layouts Namespace


LanguageCode Property

[image]

LinkOne WebView API
ILayout..::.LanguageCode Property
ILayout Interface See Also Send Feedback
Gets or sets the layout ISO639 language code.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string LanguageCode { get; set; }
Visual Basic (Declaration)
Property LanguageCode As String
Visual C++
property String^ LanguageCode {
    String^ get ();
    void set (String^ value);
}

See Also

ILayout Interface
Mincom.LinkOne.Dom.Layouts Namespace


ListFirstMargins Property

[image]

LinkOne WebView API
ILayout..::.ListFirstMargins Property
ILayout Interface See Also Send Feedback
Gets or sets the list margins for the first list page.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IMargins ListFirstMargins { get; set; }
Visual Basic (Declaration)
Property ListFirstMargins As IMargins
Visual C++
property IMargins^ ListFirstMargins {
    IMargins^ get ();
    void set (IMargins^ value);
}

See Also

ILayout Interface
Mincom.LinkOne.Dom.Layouts Namespace


ListMargins Property

[image]

LinkOne WebView API
ILayout..::.ListMargins Property
ILayout Interface See Also Send Feedback
Gets sets the list margins

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IMargins ListMargins { get; set; }
Visual Basic (Declaration)
Property ListMargins As IMargins
Visual C++
property IMargins^ ListMargins {
    IMargins^ get ();
    void set (IMargins^ value);
}

See Also

ILayout Interface
Mincom.LinkOne.Dom.Layouts Namespace


ListSheetFacing Property

[image]

LinkOne WebView API
ILayout..::.ListSheetFacing Property
ILayout Interface See Also Send Feedback
Gets or sets the ListSheetFacing attribute.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
LayoutFacing ListSheetFacing { get; set; }
Visual Basic (Declaration)
Property ListSheetFacing As LayoutFacing
Visual C++
property LayoutFacing ListSheetFacing {
    LayoutFacing get ();
    void set (LayoutFacing value);
}

See Also

ILayout Interface
Mincom.LinkOne.Dom.Layouts Namespace


Margins Property

[image]

LinkOne WebView API
ILayout..::.Margins Property
ILayout Interface See Also Send Feedback
Gets or sets the base margins for the layout.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IMargins Margins { get; set; }
Visual Basic (Declaration)
Property Margins As IMargins
Visual C++
property IMargins^ Margins {
    IMargins^ get ();
    void set (IMargins^ value);
}

See Also

ILayout Interface
Mincom.LinkOne.Dom.Layouts Namespace


PageOrder Property

[image]

LinkOne WebView API
ILayout..::.PageOrder Property
ILayout Interface See Also Send Feedback
Gets or sets the Page Order attribute.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
LayoutPageOrderCode PageOrder { get; set; }
Visual Basic (Declaration)
Property PageOrder As LayoutPageOrderCode
Visual C++
property LayoutPageOrderCode PageOrder {
    LayoutPageOrderCode get ();
    void set (LayoutPageOrderCode value);
}

See Also

ILayout Interface
Mincom.LinkOne.Dom.Layouts Namespace


PictureFirstMargins Property

[image]

LinkOne WebView API
ILayout..::.PictureFirstMargins Property
ILayout Interface See Also Send Feedback
Gets or sets the picture margins for the first picture page.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IMargins PictureFirstMargins { get; set; }
Visual Basic (Declaration)
Property PictureFirstMargins As IMargins
Visual C++
property IMargins^ PictureFirstMargins {
    IMargins^ get ();
    void set (IMargins^ value);
}

See Also

ILayout Interface
Mincom.LinkOne.Dom.Layouts Namespace


PictureMargins Property

[image]

LinkOne WebView API
ILayout..::.PictureMargins Property
ILayout Interface See Also Send Feedback
Gets or sets the picture margins.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IMargins PictureMargins { get; set; }
Visual Basic (Declaration)
Property PictureMargins As IMargins
Visual C++
property IMargins^ PictureMargins {
    IMargins^ get ();
    void set (IMargins^ value);
}

See Also

ILayout Interface
Mincom.LinkOne.Dom.Layouts Namespace


PictureSheetFacing Property

[image]

LinkOne WebView API
ILayout..::.PictureSheetFacing Property
ILayout Interface See Also Send Feedback
Gets or sets the PicSheetFacing attribute.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
LayoutFacing PictureSheetFacing { get; set; }
Visual Basic (Declaration)
Property PictureSheetFacing As LayoutFacing
Visual C++
property LayoutFacing PictureSheetFacing {
    LayoutFacing get ();
    void set (LayoutFacing value);
}

See Also

ILayout Interface
Mincom.LinkOne.Dom.Layouts Namespace


PictureTitlesField Property

[image]

LinkOne WebView API
ILayout..::.PictureTitlesField Property
ILayout Interface See Also Send Feedback
Gets or sets the Picture Titles Field layout attribute.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string PictureTitlesField { get; set; }
Visual Basic (Declaration)
Property PictureTitlesField As String
Visual C++
property String^ PictureTitlesField {
    String^ get ();
    void set (String^ value);
}

See Also

ILayout Interface
Mincom.LinkOne.Dom.Layouts Namespace


PreferredListTitle Property

[image]

LinkOne WebView API
ILayout..::.PreferredListTitle Property
ILayout Interface See Also Send Feedback
Gets or sets the Preferred List Title layout attribute.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string PreferredListTitle { get; set; }
Visual Basic (Declaration)
Property PreferredListTitle As String
Visual C++
property String^ PreferredListTitle {
    String^ get ();
    void set (String^ value);
}

See Also

ILayout Interface
Mincom.LinkOne.Dom.Layouts Namespace


PreferredSearchSet Property

[image]

LinkOne WebView API
ILayout..::.PreferredSearchSet Property
ILayout Interface See Also Send Feedback
Gets or sets the Preferred Search Set layout attribute.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string PreferredSearchSet { get; set; }
Visual Basic (Declaration)
Property PreferredSearchSet As String
Visual C++
property String^ PreferredSearchSet {
    String^ get ();
    void set (String^ value);
}

See Also

ILayout Interface
Mincom.LinkOne.Dom.Layouts Namespace


RepeatSheet Property

[image]

LinkOne WebView API
ILayout..::.RepeatSheet Property
ILayout Interface See Also Send Feedback
Gets or sets the Repeat Sheet attribute.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
LayoutRepeatSheetCode RepeatSheet { get; set; }
Visual Basic (Declaration)
Property RepeatSheet As LayoutRepeatSheetCode
Visual C++
property LayoutRepeatSheetCode RepeatSheet {
    LayoutRepeatSheetCode get ();
    void set (LayoutRepeatSheetCode value);
}

See Also

ILayout Interface
Mincom.LinkOne.Dom.Layouts Namespace


SecurityLock Property

[image]

LinkOne WebView API
ILayout..::.SecurityLock Property
ILayout Interface See Also Send Feedback
Gets or sets the layout Security Lock.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string SecurityLock { get; set; }
Visual Basic (Declaration)
Property SecurityLock As String
Visual C++
property String^ SecurityLock {
    String^ get ();
    void set (String^ value);
}

See Also

ILayout Interface
Mincom.LinkOne.Dom.Layouts Namespace


SheetFacing Property

[image]

LinkOne WebView API
ILayout..::.SheetFacing Property
ILayout Interface See Also Send Feedback
Gets or sets the layout Sheet Facing attribute.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
LayoutFacing SheetFacing { get; set; }
Visual Basic (Declaration)
Property SheetFacing As LayoutFacing
Visual C++
property LayoutFacing SheetFacing {
    LayoutFacing get ();
    void set (LayoutFacing value);
}

See Also

ILayout Interface
Mincom.LinkOne.Dom.Layouts Namespace


Source Property

[image]

LinkOne WebView API
ILayout..::.Source Property
ILayout Interface See Also Send Feedback
Gets the source of the layout.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
LayoutSourceType Source { get; }
Visual Basic (Declaration)
ReadOnly Property Source As LayoutSourceType
Visual C++
property LayoutSourceType Source {
    LayoutSourceType get ();
}

See Also

ILayout Interface
Mincom.LinkOne.Dom.Layouts Namespace


ILayoutCollection Interface

[image]

LinkOne WebView API
ILayoutCollection Interface
Members See Also Send Feedback
Represents a collection of ILayout objects that can be accessed by index.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ILayoutCollection : ICollection<ILayout>,
    IEnumerable<ILayout>, IEnumerable
Visual Basic (Declaration)
Public Interface ILayoutCollection _
    Implements ICollection(Of ILayout), IEnumerable(Of ILayout),  _
    IEnumerable
Visual C++
public interface class ILayoutCollection : ICollection<ILayout^>,
    IEnumerable<ILayout^>, IEnumerable

See Also

ILayoutCollection Members
Mincom.LinkOne.Dom.Layouts Namespace


ILayoutCollection Members

[image] [image]

LinkOne WebView API
ILayoutCollection Members
ILayoutCollection Interface Methods Properties See Also Send Feedback

The ILayoutCollection type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ILayout >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ILayout >)>).)
Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from ICollection<(Of <( ILayout >)>).)
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( ILayout >)>).)
GetEnumerator | Overloaded.
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ILayout >)>).)

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ILayout >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( ILayout >)>).)

See Also

ILayoutCollection Interface
Mincom.LinkOne.Dom.Layouts Namespace


ILayoutCollection Methods

[image] [image]

LinkOne WebView API
ILayoutCollection Methods
ILayoutCollection Interface See Also Send Feedback

The ILayoutCollection type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ILayout >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ILayout >)>).)
Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from ICollection<(Of <( ILayout >)>).)
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( ILayout >)>).)
GetEnumerator | Overloaded.
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ILayout >)>).)

See Also

ILayoutCollection Interface
Mincom.LinkOne.Dom.Layouts Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
ILayoutCollection..::.GetEnumerator Method
ILayoutCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( ILayout >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

ILayoutCollection Interface
ILayoutCollection Members
Mincom.LinkOne.Dom.Layouts Namespace


ILayoutCollection Properties

[image] [image]

LinkOne WebView API
ILayoutCollection Properties
ILayoutCollection Interface See Also Send Feedback

The ILayoutCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ILayout >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( ILayout >)>).)

See Also

ILayoutCollection Interface
Mincom.LinkOne.Dom.Layouts Namespace


ILayoutTable Interface

[image]

LinkOne WebView API
ILayoutTable Interface
Members See Also Send Feedback
Represents a table (such as a format, column headings, embedded tables, etc) in a layout. A layout table consists of a collection of rows.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ILayoutTable
Visual Basic (Declaration)
Public Interface ILayoutTable
Visual C++
public interface class ILayoutTable

See Also

ILayoutTable Members
Mincom.LinkOne.Dom.Layouts Namespace


ILayoutTable Members

[image] [image]

LinkOne WebView API
ILayoutTable Members
ILayoutTable Interface Properties See Also Send Feedback

The ILayoutTable type exposes the following members.

Properties

Name | Description
FormatExpand | Gets or sets the FormatExpand property of the TableFormat.
Rows | The collection of rows in the table.

See Also

ILayoutTable Interface
Mincom.LinkOne.Dom.Layouts Namespace


ILayoutTable Properties

[image] [image]

LinkOne WebView API
ILayoutTable Properties
ILayoutTable Interface See Also Send Feedback

The ILayoutTable type exposes the following members.

Properties

Name | Description
FormatExpand | Gets or sets the FormatExpand property of the TableFormat.
Rows | The collection of rows in the table.

See Also

ILayoutTable Interface
Mincom.LinkOne.Dom.Layouts Namespace


FormatExpand Property

[image]

LinkOne WebView API
ILayoutTable..::.FormatExpand Property
ILayoutTable Interface See Also Send Feedback
Gets or sets the FormatExpand property of the TableFormat.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool FormatExpand { get; set; }
Visual Basic (Declaration)
Property FormatExpand As Boolean
Visual C++
property bool FormatExpand {
    bool get ();
    void set (bool value);
}

See Also

ILayoutTable Interface
Mincom.LinkOne.Dom.Layouts Namespace


Rows Property

[image]

LinkOne WebView API
ILayoutTable..::.Rows Property
ILayoutTable Interface See Also Send Feedback
The collection of rows in the table.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ICollection<IRow> Rows { get; }
Visual Basic (Declaration)
ReadOnly Property Rows As ICollection(Of IRow)
Visual C++
property ICollection<IRow^>^ Rows {
    ICollection<IRow^>^ get ();
}

See Also

ILayoutTable Interface
Mincom.LinkOne.Dom.Layouts Namespace


IListField Interface

[image]

LinkOne WebView API
IListField Interface
Members See Also Send Feedback
Represents a parts list field in a layout cell.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IListField : ICellContents
Visual Basic (Declaration)
Public Interface IListField _
    Implements ICellContents
Visual C++
public interface class IListField : ICellContents

See Also

IListField Members
Mincom.LinkOne.Dom.Layouts Namespace


IListField Members

[image] [image]

LinkOne WebView API
IListField Members
IListField Interface Properties See Also Send Feedback

The IListField type exposes the following members.

Properties

Name | Description
Name | The name of the list field.

See Also

IListField Interface
Mincom.LinkOne.Dom.Layouts Namespace


IListField Properties

[image] [image]

LinkOne WebView API
IListField Properties
IListField Interface See Also Send Feedback

The IListField type exposes the following members.

Properties

Name | Description
Name | The name of the list field.

See Also

IListField Interface
Mincom.LinkOne.Dom.Layouts Namespace


Name Property

[image]

LinkOne WebView API
IListField..::.Name Property
IListField Interface See Also Send Feedback
The name of the list field.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Name { get; set; }
Visual Basic (Declaration)
Property Name As String
Visual C++
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

IListField Interface
Mincom.LinkOne.Dom.Layouts Namespace


ILiteralText Interface

[image]

LinkOne WebView API
ILiteralText Interface
Members See Also Send Feedback
Represents a constant text field in a layout cell.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ILiteralText : ICellContents
Visual Basic (Declaration)
Public Interface ILiteralText _
    Implements ICellContents
Visual C++
public interface class ILiteralText : ICellContents

See Also

ILiteralText Members
Mincom.LinkOne.Dom.Layouts Namespace


ILiteralText Members

[image] [image]

LinkOne WebView API
ILiteralText Members
ILiteralText Interface Properties See Also Send Feedback

The ILiteralText type exposes the following members.

Properties

Name | Description
Text | The text inside the cell.

See Also

ILiteralText Interface
Mincom.LinkOne.Dom.Layouts Namespace


ILiteralText Properties

[image] [image]

LinkOne WebView API
ILiteralText Properties
ILiteralText Interface See Also Send Feedback

The ILiteralText type exposes the following members.

Properties

Name | Description
Text | The text inside the cell.

See Also

ILiteralText Interface
Mincom.LinkOne.Dom.Layouts Namespace


Text Property

[image]

LinkOne WebView API
ILiteralText..::.Text Property
ILiteralText Interface See Also Send Feedback
The text inside the cell.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Text { get; set; }
Visual Basic (Declaration)
Property Text As String
Visual C++
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

ILiteralText Interface
Mincom.LinkOne.Dom.Layouts Namespace


IMargins Interface

[image]

LinkOne WebView API
IMargins Interface
Members See Also Send Feedback
Describe the border margins for a layout object.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IMargins
Visual Basic (Declaration)
Public Interface IMargins
Visual C++
public interface class IMargins

See Also

IMargins Members
Mincom.LinkOne.Dom.Layouts Namespace


IMargins Members

[image] [image]

LinkOne WebView API
IMargins Members
IMargins Interface Properties See Also Send Feedback

The IMargins type exposes the following members.

Properties

Name | Description
BottomMargin | Gets or sets the dimension of the bottom margin.
LeftMargin | Gets or sets the dimension of the left margin.
RightMargin | Gets or sets the dimension of the right margin.
TopMargin | Gets or sets the dimension of the top margin.

See Also

IMargins Interface
Mincom.LinkOne.Dom.Layouts Namespace


IMargins Properties

[image] [image]

LinkOne WebView API
IMargins Properties
IMargins Interface See Also Send Feedback

The IMargins type exposes the following members.

Properties

Name | Description
BottomMargin | Gets or sets the dimension of the bottom margin.
LeftMargin | Gets or sets the dimension of the left margin.
RightMargin | Gets or sets the dimension of the right margin.
TopMargin | Gets or sets the dimension of the top margin.

See Also

IMargins Interface
Mincom.LinkOne.Dom.Layouts Namespace


BottomMargin Property

[image]

LinkOne WebView API
IMargins..::.BottomMargin Property
IMargins Interface See Also Send Feedback
Gets or sets the dimension of the bottom margin.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension BottomMargin { get; set; }
Visual Basic (Declaration)
Property BottomMargin As IDimension
Visual C++
property IDimension^ BottomMargin {
    IDimension^ get ();
    void set (IDimension^ value);
}

See Also

IMargins Interface
Mincom.LinkOne.Dom.Layouts Namespace


LeftMargin Property

[image]

LinkOne WebView API
IMargins..::.LeftMargin Property
IMargins Interface See Also Send Feedback
Gets or sets the dimension of the left margin.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension LeftMargin { get; set; }
Visual Basic (Declaration)
Property LeftMargin As IDimension
Visual C++
property IDimension^ LeftMargin {
    IDimension^ get ();
    void set (IDimension^ value);
}

See Also

IMargins Interface
Mincom.LinkOne.Dom.Layouts Namespace


RightMargin Property

[image]

LinkOne WebView API
IMargins..::.RightMargin Property
IMargins Interface See Also Send Feedback
Gets or sets the dimension of the right margin.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension RightMargin { get; set; }
Visual Basic (Declaration)
Property RightMargin As IDimension
Visual C++
property IDimension^ RightMargin {
    IDimension^ get ();
    void set (IDimension^ value);
}

See Also

IMargins Interface
Mincom.LinkOne.Dom.Layouts Namespace


TopMargin Property

[image]

LinkOne WebView API
IMargins..::.TopMargin Property
IMargins Interface See Also Send Feedback
Gets or sets the dimension of the top margin.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension TopMargin { get; set; }
Visual Basic (Declaration)
Property TopMargin As IDimension
Visual C++
property IDimension^ TopMargin {
    IDimension^ get ();
    void set (IDimension^ value);
}

See Also

IMargins Interface
Mincom.LinkOne.Dom.Layouts Namespace


IPicture Interface

[image]

LinkOne WebView API
IPicture Interface
Members See Also Send Feedback
Represents a picture in a layout cell.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IPicture : ICellContents
Visual Basic (Declaration)
Public Interface IPicture _
    Implements ICellContents
Visual C++
public interface class IPicture : ICellContents

See Also

IPicture Members
Mincom.LinkOne.Dom.Layouts Namespace


IPicture Members

[image] [image]

LinkOne WebView API
IPicture Members
IPicture Interface Properties See Also Send Feedback

The IPicture type exposes the following members.

Properties

Name | Description
Height | The height of the picture.
Location | The name of the picture.
Width | The width of the picture.

See Also

IPicture Interface
Mincom.LinkOne.Dom.Layouts Namespace


IPicture Properties

[image] [image]

LinkOne WebView API
IPicture Properties
IPicture Interface See Also Send Feedback

The IPicture type exposes the following members.

Properties

Name | Description
Height | The height of the picture.
Location | The name of the picture.
Width | The width of the picture.

See Also

IPicture Interface
Mincom.LinkOne.Dom.Layouts Namespace


Height Property

[image]

LinkOne WebView API
IPicture..::.Height Property
IPicture Interface See Also Send Feedback
The height of the picture.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension Height { get; set; }
Visual Basic (Declaration)
Property Height As IDimension
Visual C++
property IDimension^ Height {
    IDimension^ get ();
    void set (IDimension^ value);
}

See Also

IPicture Interface
Mincom.LinkOne.Dom.Layouts Namespace


Location Property

[image]

LinkOne WebView API
IPicture..::.Location Property
IPicture Interface See Also Send Feedback
The name of the picture.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ICellContents Location { get; set; }
Visual Basic (Declaration)
Property Location As ICellContents
Visual C++
property ICellContents^ Location {
    ICellContents^ get ();
    void set (ICellContents^ value);
}

See Also

IPicture Interface
Mincom.LinkOne.Dom.Layouts Namespace


Width Property

[image]

LinkOne WebView API
IPicture..::.Width Property
IPicture Interface See Also Send Feedback
The width of the picture.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension Width { get; set; }
Visual Basic (Declaration)
Property Width As IDimension
Visual C++
property IDimension^ Width {
    IDimension^ get ();
    void set (IDimension^ value);
}

See Also

IPicture Interface
Mincom.LinkOne.Dom.Layouts Namespace


IPictureField Interface

[image]

LinkOne WebView API
IPictureField Interface
Members See Also Send Feedback
Represents a picture field in a layout cell.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IPictureField : ICellContents
Visual Basic (Declaration)
Public Interface IPictureField _
    Implements ICellContents
Visual C++
public interface class IPictureField : ICellContents

See Also

IPictureField Members
Mincom.LinkOne.Dom.Layouts Namespace


IPictureField Members

[image] [image]

LinkOne WebView API
IPictureField Members
IPictureField Interface Properties See Also Send Feedback

The IPictureField type exposes the following members.

Properties

Name | Description
Name | The name of the picture field.

See Also

IPictureField Interface
Mincom.LinkOne.Dom.Layouts Namespace


IPictureField Properties

[image] [image]

LinkOne WebView API
IPictureField Properties
IPictureField Interface See Also Send Feedback

The IPictureField type exposes the following members.

Properties

Name | Description
Name | The name of the picture field.

See Also

IPictureField Interface
Mincom.LinkOne.Dom.Layouts Namespace


Name Property

[image]

LinkOne WebView API
IPictureField..::.Name Property
IPictureField Interface See Also Send Feedback
The name of the picture field.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Name { get; set; }
Visual Basic (Declaration)
Property Name As String
Visual C++
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

IPictureField Interface
Mincom.LinkOne.Dom.Layouts Namespace


IPreferred Interface

[image]

LinkOne WebView API
IPreferred Interface
Members See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IPreferred
Visual Basic (Declaration)
Public Interface IPreferred
Visual C++
public interface class IPreferred

See Also

IPreferred Members
Mincom.LinkOne.Dom.Layouts Namespace


IPreferred Members

[image] [image]

LinkOne WebView API
IPreferred Members
IPreferred Interface Properties See Also Send Feedback

The IPreferred type exposes the following members.

Properties

Name | Description
BookCode |
Key |
PublisherCode |
Type |

See Also

IPreferred Interface
Mincom.LinkOne.Dom.Layouts Namespace


IPreferred Properties

[image] [image]

LinkOne WebView API
IPreferred Properties
IPreferred Interface See Also Send Feedback

The IPreferred type exposes the following members.

Properties

Name | Description
BookCode |
Key |
PublisherCode |
Type |

See Also

IPreferred Interface
Mincom.LinkOne.Dom.Layouts Namespace


BookCode Property

[image]

LinkOne WebView API
IPreferred..::.BookCode Property
IPreferred Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string BookCode { get; set; }
Visual Basic (Declaration)
Property BookCode As String
Visual C++
property String^ BookCode {
    String^ get ();
    void set (String^ value);
}

See Also

IPreferred Interface
Mincom.LinkOne.Dom.Layouts Namespace


Key Property

[image]

LinkOne WebView API
IPreferred..::.Key Property
IPreferred Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Key { get; set; }
Visual Basic (Declaration)
Property Key As String
Visual C++
property String^ Key {
    String^ get ();
    void set (String^ value);
}

See Also

IPreferred Interface
Mincom.LinkOne.Dom.Layouts Namespace


PublisherCode Property

[image]

LinkOne WebView API
IPreferred..::.PublisherCode Property
IPreferred Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string PublisherCode { get; set; }
Visual Basic (Declaration)
Property PublisherCode As String
Visual C++
property String^ PublisherCode {
    String^ get ();
    void set (String^ value);
}

See Also

IPreferred Interface
Mincom.LinkOne.Dom.Layouts Namespace


Type Property

[image]

LinkOne WebView API
IPreferred..::.Type Property
IPreferred Interface See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Type { get; set; }
Visual Basic (Declaration)
Property Type As String
Visual C++
property String^ Type {
    String^ get ();
    void set (String^ value);
}

See Also

IPreferred Interface
Mincom.LinkOne.Dom.Layouts Namespace


IPreferredCollection Interface

[image]

LinkOne WebView API
IPreferredCollection Interface
Members See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IPreferredCollection : ICollection<IPreferred>,
    IEnumerable<IPreferred>, IEnumerable
Visual Basic (Declaration)
Public Interface IPreferredCollection _
    Implements ICollection(Of IPreferred), IEnumerable(Of IPreferred),  _
    IEnumerable
Visual C++
public interface class IPreferredCollection : ICollection<IPreferred^>,
    IEnumerable<IPreferred^>, IEnumerable

See Also

IPreferredCollection Members
Mincom.LinkOne.Dom.Layouts Namespace


IPreferredCollection Members

[image] [image]

LinkOne WebView API
IPreferredCollection Members
IPreferredCollection Interface Methods Properties See Also Send Feedback

The IPreferredCollection type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPreferred >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPreferred >)>).)
Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from ICollection<(Of <( IPreferred >)>).)
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( IPreferred >)>).)
GetEnumerator | Overloaded.
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPreferred >)>).)

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPreferred >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( IPreferred >)>).)

See Also

IPreferredCollection Interface
Mincom.LinkOne.Dom.Layouts Namespace


IPreferredCollection Methods

[image] [image]

LinkOne WebView API
IPreferredCollection Methods
IPreferredCollection Interface See Also Send Feedback

The IPreferredCollection type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPreferred >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPreferred >)>).)
Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from ICollection<(Of <( IPreferred >)>).)
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( IPreferred >)>).)
GetEnumerator | Overloaded.
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPreferred >)>).)

See Also

IPreferredCollection Interface
Mincom.LinkOne.Dom.Layouts Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
IPreferredCollection..::.GetEnumerator Method
IPreferredCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( IPreferred >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IPreferredCollection Interface
IPreferredCollection Members
Mincom.LinkOne.Dom.Layouts Namespace


IPreferredCollection Properties

[image] [image]

LinkOne WebView API
IPreferredCollection Properties
IPreferredCollection Interface See Also Send Feedback

The IPreferredCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPreferred >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( IPreferred >)>).)

See Also

IPreferredCollection Interface
Mincom.LinkOne.Dom.Layouts Namespace


IRow Interface

[image]

LinkOne WebView API
IRow Interface
Members See Also Send Feedback
Represents a row in a layout table. Layout table rows consist of cells.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IRow
Visual Basic (Declaration)
Public Interface IRow
Visual C++
public interface class IRow

See Also

IRow Members
Mincom.LinkOne.Dom.Layouts Namespace


IRow Members

[image] [image]

LinkOne WebView API
IRow Members
IRow Interface Properties See Also Send Feedback

The IRow type exposes the following members.

Properties

Name | Description
Border | Gets the Border property of the RowAttributes.
Cells | Gets the collection of cells in this row.
RowCollapse | Gets or sets the RowCollapse property of the RowAttributes.
RowGap | Gets or sets the RowGap property of the RowAttributes.
Rules | Gets or sets the Rules of the RowAttributes.

See Also

IRow Interface
Mincom.LinkOne.Dom.Layouts Namespace


IRow Properties

[image] [image]

LinkOne WebView API
IRow Properties
IRow Interface See Also Send Feedback

The IRow type exposes the following members.

Properties

Name | Description
Border | Gets the Border property of the RowAttributes.
Cells | Gets the collection of cells in this row.
RowCollapse | Gets or sets the RowCollapse property of the RowAttributes.
RowGap | Gets or sets the RowGap property of the RowAttributes.
Rules | Gets or sets the Rules of the RowAttributes.

See Also

IRow Interface
Mincom.LinkOne.Dom.Layouts Namespace


Border Property

[image]

LinkOne WebView API
IRow..::.Border Property
IRow Interface See Also Send Feedback
Gets the Border property of the RowAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IBorderAttributes Border { get; }
Visual Basic (Declaration)
ReadOnly Property Border As IBorderAttributes
Visual C++
property IBorderAttributes^ Border {
    IBorderAttributes^ get ();
}

See Also

IRow Interface
Mincom.LinkOne.Dom.Layouts Namespace


Cells Property

[image]

LinkOne WebView API
IRow..::.Cells Property
IRow Interface See Also Send Feedback
Gets the collection of cells in this row.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ICollection<ICell> Cells { get; }
Visual Basic (Declaration)
ReadOnly Property Cells As ICollection(Of ICell)
Visual C++
property ICollection<ICell^>^ Cells {
    ICollection<ICell^>^ get ();
}

Field Value

The collection of cells in the row.

See Also

IRow Interface
Mincom.LinkOne.Dom.Layouts Namespace


RowCollapse Property

[image]

LinkOne WebView API
IRow..::.RowCollapse Property
IRow Interface See Also Send Feedback
Gets or sets the RowCollapse property of the RowAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool RowCollapse { get; set; }
Visual Basic (Declaration)
Property RowCollapse As Boolean
Visual C++
property bool RowCollapse {
    bool get ();
    void set (bool value);
}

See Also

IRow Interface
Mincom.LinkOne.Dom.Layouts Namespace


RowGap Property

[image]

LinkOne WebView API
IRow..::.RowGap Property
IRow Interface See Also Send Feedback
Gets or sets the RowGap property of the RowAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension RowGap { get; set; }
Visual Basic (Declaration)
Property RowGap As IDimension
Visual C++
property IDimension^ RowGap {
    IDimension^ get ();
    void set (IDimension^ value);
}

See Also

IRow Interface
Mincom.LinkOne.Dom.Layouts Namespace


Rules Property

[image]

LinkOne WebView API
IRow..::.Rules Property
IRow Interface See Also Send Feedback
Gets or sets the Rules of the RowAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IRuleAttributes Rules { get; }
Visual Basic (Declaration)
ReadOnly Property Rules As IRuleAttributes
Visual C++
property IRuleAttributes^ Rules {
    IRuleAttributes^ get ();
}

See Also

IRow Interface
Mincom.LinkOne.Dom.Layouts Namespace


IRuleAttributes Interface

[image]

LinkOne WebView API
IRuleAttributes Interface
Members See Also Send Feedback
Attributes that specify which rules are to be drawn.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IRuleAttributes
Visual Basic (Declaration)
Public Interface IRuleAttributes
Visual C++
public interface class IRuleAttributes

See Also

IRuleAttributes Members
Mincom.LinkOne.Dom.Layouts Namespace


IRuleAttributes Members

[image] [image]

LinkOne WebView API
IRuleAttributes Members
IRuleAttributes Interface Properties See Also Send Feedback

The IRuleAttributes type exposes the following members.

Properties

Name | Description
Bottom | Gets or sets the Bottom rule dimension.
Left | Gets or sets the Left rule dimension.
Right | Gets or sets the Right rule dimension.
Top | Gets or sets the Top rule dimension.

See Also

IRuleAttributes Interface
Mincom.LinkOne.Dom.Layouts Namespace


IRuleAttributes Properties

[image] [image]

LinkOne WebView API
IRuleAttributes Properties
IRuleAttributes Interface See Also Send Feedback

The IRuleAttributes type exposes the following members.

Properties

Name | Description
Bottom | Gets or sets the Bottom rule dimension.
Left | Gets or sets the Left rule dimension.
Right | Gets or sets the Right rule dimension.
Top | Gets or sets the Top rule dimension.

See Also

IRuleAttributes Interface
Mincom.LinkOne.Dom.Layouts Namespace


Bottom Property

[image]

LinkOne WebView API
IRuleAttributes..::.Bottom Property
IRuleAttributes Interface See Also Send Feedback
Gets or sets the Bottom rule dimension.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension Bottom { get; set; }
Visual Basic (Declaration)
Property Bottom As IDimension
Visual C++
property IDimension^ Bottom {
    IDimension^ get ();
    void set (IDimension^ value);
}

See Also

IRuleAttributes Interface
Mincom.LinkOne.Dom.Layouts Namespace


Left Property

[image]

LinkOne WebView API
IRuleAttributes..::.Left Property
IRuleAttributes Interface See Also Send Feedback
Gets or sets the Left rule dimension.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension Left { get; set; }
Visual Basic (Declaration)
Property Left As IDimension
Visual C++
property IDimension^ Left {
    IDimension^ get ();
    void set (IDimension^ value);
}

See Also

IRuleAttributes Interface
Mincom.LinkOne.Dom.Layouts Namespace


Right Property

[image]

LinkOne WebView API
IRuleAttributes..::.Right Property
IRuleAttributes Interface See Also Send Feedback
Gets or sets the Right rule dimension.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension Right { get; set; }
Visual Basic (Declaration)
Property Right As IDimension
Visual C++
property IDimension^ Right {
    IDimension^ get ();
    void set (IDimension^ value);
}

See Also

IRuleAttributes Interface
Mincom.LinkOne.Dom.Layouts Namespace


Top Property

[image]

LinkOne WebView API
IRuleAttributes..::.Top Property
IRuleAttributes Interface See Also Send Feedback
Gets or sets the Top rule dimension.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension Top { get; set; }
Visual Basic (Declaration)
Property Top As IDimension
Visual C++
property IDimension^ Top {
    IDimension^ get ();
    void set (IDimension^ value);
}

See Also

IRuleAttributes Interface
Mincom.LinkOne.Dom.Layouts Namespace


ITable Interface

[image]

LinkOne WebView API
ITable Interface
Members See Also Send Feedback
Represents a table in a layout cell.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ITable : ILayoutTable, ICellContents
Visual Basic (Declaration)
Public Interface ITable _
    Implements ILayoutTable, ICellContents
Visual C++
public interface class ITable : ILayoutTable,
    ICellContents

See Also

ITable Members
Mincom.LinkOne.Dom.Layouts Namespace


ITable Members

[image] [image]

LinkOne WebView API
ITable Members
ITable Interface Properties See Also Send Feedback

The ITable type exposes the following members.

Properties

Name | Description
FormatExpand | Gets or sets the FormatExpand property of the TableFormat. (Inherited from ILayoutTable.)
Rows | The collection of rows in the table. (Inherited from ILayoutTable.)

See Also

ITable Interface
Mincom.LinkOne.Dom.Layouts Namespace


ITable Properties

[image] [image]

LinkOne WebView API
ITable Properties
ITable Interface See Also Send Feedback

The ITable type exposes the following members.

Properties

Name | Description
FormatExpand | Gets or sets the FormatExpand property of the TableFormat. (Inherited from ILayoutTable.)
Rows | The collection of rows in the table. (Inherited from ILayoutTable.)

See Also

ITable Interface
Mincom.LinkOne.Dom.Layouts Namespace


ITextFormat Interface

[image]

LinkOne WebView API
ITextFormat Interface
Members See Also Send Feedback
Encapsulates the components of a format string.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ITextFormat
Visual Basic (Declaration)
Public Interface ITextFormat
Visual C++
public interface class ITextFormat

See Also

ITextFormat Members
Mincom.LinkOne.Dom.Layouts Namespace


ITextFormat Members

[image] [image]

LinkOne WebView API
ITextFormat Members
ITextFormat Interface Properties See Also Send Feedback

The ITextFormat type exposes the following members.

Properties

Name | Description
FormatSpecifier | Gets the format specifier.
Precision | Gets the precision; or null if not applicable to the TextFormatSpecifier.

See Also

ITextFormat Interface
Mincom.LinkOne.Dom.Layouts Namespace


ITextFormat Properties

[image] [image]

LinkOne WebView API
ITextFormat Properties
ITextFormat Interface See Also Send Feedback

The ITextFormat type exposes the following members.

Properties

Name | Description
FormatSpecifier | Gets the format specifier.
Precision | Gets the precision; or null if not applicable to the TextFormatSpecifier.

See Also

ITextFormat Interface
Mincom.LinkOne.Dom.Layouts Namespace


FormatSpecifier Property

[image]

LinkOne WebView API
ITextFormat..::.FormatSpecifier Property
ITextFormat Interface See Also Send Feedback
Gets the format specifier.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
TextFormatSpecifier FormatSpecifier { get; }
Visual Basic (Declaration)
ReadOnly Property FormatSpecifier As TextFormatSpecifier
Visual C++
property TextFormatSpecifier FormatSpecifier {
    TextFormatSpecifier get ();
}

See Also

ITextFormat Interface
Mincom.LinkOne.Dom.Layouts Namespace


Precision Property

[image]

LinkOne WebView API
ITextFormat..::.Precision Property
ITextFormat Interface See Also Send Feedback
Gets the precision; or null if not applicable to the TextFormatSpecifier.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
Nullable<int> Precision { get; }
Visual Basic (Declaration)
ReadOnly Property Precision As Nullable(Of Integer)
Visual C++
property Nullable<int> Precision {
    Nullable<int> get ();
}

See Also

ITextFormat Interface
Mincom.LinkOne.Dom.Layouts Namespace


IValueNote Interface

[image]

LinkOne WebView API
IValueNote Interface
Members See Also Send Feedback
Represents a value note in a layout cell.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IValueNote : ICellContents
Visual Basic (Declaration)
Public Interface IValueNote _
    Implements ICellContents
Visual C++
public interface class IValueNote : ICellContents

See Also

IValueNote Members
Mincom.LinkOne.Dom.Layouts Namespace


IValueNote Members

[image] [image]

LinkOne WebView API
IValueNote Members
IValueNote Interface Properties See Also Send Feedback

The IValueNote type exposes the following members.

Properties

Name | Description
Name | The name of the value note.

See Also

IValueNote Interface
Mincom.LinkOne.Dom.Layouts Namespace


IValueNote Properties

[image] [image]

LinkOne WebView API
IValueNote Properties
IValueNote Interface See Also Send Feedback

The IValueNote type exposes the following members.

Properties

Name | Description
Name | The name of the value note.

See Also

IValueNote Interface
Mincom.LinkOne.Dom.Layouts Namespace


Name Property

[image]

LinkOne WebView API
IValueNote..::.Name Property
IValueNote Interface See Also Send Feedback
The name of the value note.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Name { get; set; }
Visual Basic (Declaration)
Property Name As String
Visual C++
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

IValueNote Interface
Mincom.LinkOne.Dom.Layouts Namespace


Layout Class

[image]

LinkOne WebView API
Layout Class
Members See Also Send Feedback
A LinkOne Layout, defines the format of the parts list for screen and printing.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class Layout : ILayout
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class Layout _
    Implements ILayout
Visual C++
[SerializableAttribute]
public ref class Layout sealed : ILayout

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Layouts..::.Layout

See Also

Layout Members
Mincom.LinkOne.Dom.Layouts Namespace


Layout Members

[image] [image]

LinkOne WebView API
Layout Members
Layout Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The Layout type exposes the following members.

Constructors

Name | Description
Layout | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
BlankPageMessage | Gets the message string to be dispalyed on a blank print page.
Description | Gets or sets the layout Description.
DisplayName | Gets the display text of the layout.
Errors | A list of exceptions from loading this layout.
Formats | Returns an enumerator that can iterate through the collection of formats contained within the layout.
Id | Gets or sets the layout Id.
Key | Gets a key representing the layout.
LanguageCode | Gets or sets the layout ISO639 language code.
ListFirstMargins | Gets the list margins for the first list page.
ListMargins | Gets sets the list margins
ListSheetFacing | Gets or sets the ListSheetFacing attribute.
Location | Gets the file name of the layout.
Margins | Gets the base margins for the layout.
PageOrder | Gets the Page Order attribute.
PictureFirstMargins | Gets the picture margins for the first picture page.
PictureMargins | Gets the picture margins.
PictureSheetFacing | Gets the PicSheetFacing attribute.
PictureTitlesField | Gets or sets the Picture Titles Field layout attribute.
PreferredListTitle | Gets or sets the Preferred List Title layout attribute.
PreferredSearchSet | Gets or sets the Preferred Search Set layout attribute.
RepeatSheet | Gets the Repeat Sheet attribute.
SecurityLock | Gets or sets the layout Security Lock.
SheetFacing | Gets or sets the layout Sheet Facing attribute.
Source | Gets the source of the layout.

Explicit Interface Implementations

Name | Description
ILayout..::.Errors |
ILayout..::.Formats |
ILayout..::.ListFirstMargins |
ILayout..::.ListMargins |
ILayout..::.Margins |
ILayout..::.PictureFirstMargins |
ILayout..::.PictureMargins |

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


Layout Constructor

[image] [image]

LinkOne WebView API
Layout Constructor
Layout Class See Also Send Feedback

Overload List

Name | Description
Layout()()() | Initializes a new instance of the Layout class.
Layout(IDomReader) | Initializes a new instance of the Layout class.

See Also

Layout Class
Layout Members
Mincom.LinkOne.Dom.Layouts Namespace


Layout Constructor

[image]

LinkOne WebView API
Layout Constructor
Layout Class See Also Send Feedback
Initializes a new instance of the Layout class.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Layout()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Layout()

See Also

Layout Class
Layout Overload
Mincom.LinkOne.Dom.Layouts Namespace


Layout Constructor ()

[image]

LinkOne WebView API
Layout Constructor ()
Layout Class See Also Send Feedback
Initializes a new instance of the Layout class.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Layout(
    IDomReader domReader
)
Visual Basic (Declaration)
Public Sub New ( _
    domReader As IDomReader _
)
Visual C++
public:
Layout(
    IDomReader^ domReader
)

Parameters

domReader
Type: IDomReader
The layout reader object providing the initialisation data.

See Also

Layout Class
Layout Overload
Mincom.LinkOne.Dom.Layouts Namespace


Layout Methods

[image] [image]

LinkOne WebView API
Layout Methods
Layout Class See Also Send Feedback

The Layout type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


Layout Properties

[image] [image]

LinkOne WebView API
Layout Properties
Layout Class See Also Send Feedback

The Layout type exposes the following members.

Properties

Name | Description
BlankPageMessage | Gets the message string to be dispalyed on a blank print page.
Description | Gets or sets the layout Description.
DisplayName | Gets the display text of the layout.
Errors | A list of exceptions from loading this layout.
Formats | Returns an enumerator that can iterate through the collection of formats contained within the layout.
Id | Gets or sets the layout Id.
Key | Gets a key representing the layout.
LanguageCode | Gets or sets the layout ISO639 language code.
ListFirstMargins | Gets the list margins for the first list page.
ListMargins | Gets sets the list margins
ListSheetFacing | Gets or sets the ListSheetFacing attribute.
Location | Gets the file name of the layout.
Margins | Gets the base margins for the layout.
PageOrder | Gets the Page Order attribute.
PictureFirstMargins | Gets the picture margins for the first picture page.
PictureMargins | Gets the picture margins.
PictureSheetFacing | Gets the PicSheetFacing attribute.
PictureTitlesField | Gets or sets the Picture Titles Field layout attribute.
PreferredListTitle | Gets or sets the Preferred List Title layout attribute.
PreferredSearchSet | Gets or sets the Preferred Search Set layout attribute.
RepeatSheet | Gets the Repeat Sheet attribute.
SecurityLock | Gets or sets the layout Security Lock.
SheetFacing | Gets or sets the layout Sheet Facing attribute.
Source | Gets the source of the layout.

Explicit Interface Implementations

Name | Description
ILayout..::.Errors |
ILayout..::.Formats |
ILayout..::.ListFirstMargins |
ILayout..::.ListMargins |
ILayout..::.Margins |
ILayout..::.PictureFirstMargins |
ILayout..::.PictureMargins |

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


BlankPageMessage Property

[image]

LinkOne WebView API
Layout..::.BlankPageMessage Property
Layout Class See Also Send Feedback
Gets the message string to be dispalyed on a blank print page.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string BlankPageMessage { get; set; }
Visual Basic (Declaration)
Public Property BlankPageMessage As String
Visual C++
public:
virtual property String^ BlankPageMessage {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ILayout..::.BlankPageMessage

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


Description Property

[image]

LinkOne WebView API
Layout..::.Description Property
Layout Class See Also Send Feedback
Gets or sets the layout Description.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
virtual property String^ Description {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ILayout..::.Description

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


DisplayName Property

[image]

LinkOne WebView API
Layout..::.DisplayName Property
Layout Class See Also Send Feedback
Gets the display text of the layout.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string DisplayName { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayName As String
Visual C++
public:
virtual property String^ DisplayName {
    String^ get () sealed;
}

Implements

ILayout..::.DisplayName

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


Errors Property

[image]

LinkOne WebView API
Layout..::.Errors Property
Layout Class See Also Send Feedback
A list of exceptions from loading this layout.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ExceptionCollection Errors { get; }
Visual Basic (Declaration)
Public ReadOnly Property Errors As ExceptionCollection
Visual C++
public:
property ExceptionCollection^ Errors {
    ExceptionCollection^ get ();
}

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


Formats Property

[image]

LinkOne WebView API
Layout..::.Formats Property
Layout Class See Also Send Feedback
Returns an enumerator that can iterate through the collection of formats contained within the layout.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public FormatCollection Formats { get; }
Visual Basic (Declaration)
Public ReadOnly Property Formats As FormatCollection
Visual C++
public:
property FormatCollection^ Formats {
    FormatCollection^ get ();
}

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


Id Property

[image]

LinkOne WebView API
Layout..::.Id Property
Layout Class See Also Send Feedback
Gets or sets the layout Id.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Id { get; set; }
Visual Basic (Declaration)
Public Property Id As String
Visual C++
public:
virtual property String^ Id {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ILayout..::.Id

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


ILayout.Errors Property

[image]

LinkOne WebView API
Layout..::.ILayout..::.Errors Property
Layout Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IExceptionCollection ILayout.Errors { get; }
Visual Basic (Declaration)
Private ReadOnly Property Errors As IExceptionCollection
    Implements ILayout.Errors
Visual C++
private:
virtual property IExceptionCollection^ Errors {
    IExceptionCollection^ get () sealed = ILayout::Errors::get;
}

Implements

ILayout..::.Errors

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


ILayout.Formats Property

[image]

LinkOne WebView API
Layout..::.ILayout..::.Formats Property
Layout Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IFormatCollection ILayout.Formats { get; }
Visual Basic (Declaration)
Private ReadOnly Property Formats As IFormatCollection
    Implements ILayout.Formats
Visual C++
private:
virtual property IFormatCollection^ Formats {
    IFormatCollection^ get () sealed = ILayout::Formats::get;
}

Implements

ILayout..::.Formats

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


ILayout.ListFirstMargins Property

[image]

LinkOne WebView API
Layout..::.ILayout..::.ListFirstMargins Property
Layout Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IMargins ILayout.ListFirstMargins { get; set; }
Visual Basic (Declaration)
Private Property ListFirstMargins As IMargins
    Implements ILayout.ListFirstMargins
Visual C++
private:
virtual property IMargins^ ListFirstMargins {
    IMargins^ get () sealed = ILayout::ListFirstMargins::get;
    void set (IMargins^ value) sealed = ILayout::ListFirstMargins::set;
}

Implements

ILayout..::.ListFirstMargins

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


ILayout.ListMargins Property

[image]

LinkOne WebView API
Layout..::.ILayout..::.ListMargins Property
Layout Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IMargins ILayout.ListMargins { get; set; }
Visual Basic (Declaration)
Private Property ListMargins As IMargins
    Implements ILayout.ListMargins
Visual C++
private:
virtual property IMargins^ ListMargins {
    IMargins^ get () sealed = ILayout::ListMargins::get;
    void set (IMargins^ value) sealed = ILayout::ListMargins::set;
}

Implements

ILayout..::.ListMargins

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


ILayout.Margins Property

[image]

LinkOne WebView API
Layout..::.ILayout..::.Margins Property
Layout Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IMargins ILayout.Margins { get; set; }
Visual Basic (Declaration)
Private Property Margins As IMargins
    Implements ILayout.Margins
Visual C++
private:
virtual property IMargins^ Margins {
    IMargins^ get () sealed = ILayout::Margins::get;
    void set (IMargins^ value) sealed = ILayout::Margins::set;
}

Implements

ILayout..::.Margins

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


ILayout.PictureFirstMargins Property

[image]

LinkOne WebView API
Layout..::.ILayout..::.PictureFirstMargins Property
Layout Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IMargins ILayout.PictureFirstMargins { get; set; }
Visual Basic (Declaration)
Private Property PictureFirstMargins As IMargins
    Implements ILayout.PictureFirstMargins
Visual C++
private:
virtual property IMargins^ PictureFirstMargins {
    IMargins^ get () sealed = ILayout::PictureFirstMargins::get;
    void set (IMargins^ value) sealed = ILayout::PictureFirstMargins::set;
}

Implements

ILayout..::.PictureFirstMargins

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


ILayout.PictureMargins Property

[image]

LinkOne WebView API
Layout..::.ILayout..::.PictureMargins Property
Layout Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IMargins ILayout.PictureMargins { get; set; }
Visual Basic (Declaration)
Private Property PictureMargins As IMargins
    Implements ILayout.PictureMargins
Visual C++
private:
virtual property IMargins^ PictureMargins {
    IMargins^ get () sealed = ILayout::PictureMargins::get;
    void set (IMargins^ value) sealed = ILayout::PictureMargins::set;
}

Implements

ILayout..::.PictureMargins

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


Key Property

[image]

LinkOne WebView API
Layout..::.Key Property
Layout Class See Also Send Feedback
Gets a key representing the layout.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Key { get; }
Visual Basic (Declaration)
Public ReadOnly Property Key As String
Visual C++
public:
property String^ Key {
    String^ get ();
}

Remarks

The format is in LanguageCode:FileName! if the layout is a user layout, or LanguageCode:Id if it is a book layout, otherwise it is a blank string because the layout is predefined.

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


LanguageCode Property

[image]

LinkOne WebView API
Layout..::.LanguageCode Property
Layout Class See Also Send Feedback
Gets or sets the layout ISO639 language code.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string LanguageCode { get; set; }
Visual Basic (Declaration)
Public Property LanguageCode As String
Visual C++
public:
virtual property String^ LanguageCode {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ILayout..::.LanguageCode

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


ListFirstMargins Property

[image]

LinkOne WebView API
Layout..::.ListFirstMargins Property
Layout Class See Also Send Feedback
Gets the list margins for the first list page.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Margins ListFirstMargins { get; set; }
Visual Basic (Declaration)
Public Property ListFirstMargins As Margins
Visual C++
public:
property Margins^ ListFirstMargins {
    Margins^ get ();
    void set (Margins^ value);
}

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


ListMargins Property

[image]

LinkOne WebView API
Layout..::.ListMargins Property
Layout Class See Also Send Feedback
Gets sets the list margins

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Margins ListMargins { get; set; }
Visual Basic (Declaration)
Public Property ListMargins As Margins
Visual C++
public:
property Margins^ ListMargins {
    Margins^ get ();
    void set (Margins^ value);
}

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


ListSheetFacing Property

[image]

LinkOne WebView API
Layout..::.ListSheetFacing Property
Layout Class See Also Send Feedback
Gets or sets the ListSheetFacing attribute.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LayoutFacing ListSheetFacing { get; set; }
Visual Basic (Declaration)
Public Property ListSheetFacing As LayoutFacing
Visual C++
public:
virtual property LayoutFacing ListSheetFacing {
    LayoutFacing get () sealed;
    void set (LayoutFacing value) sealed;
}

Implements

ILayout..::.ListSheetFacing

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


Location Property

[image]

LinkOne WebView API
Layout..::.Location Property
Layout Class See Also Send Feedback
Gets the file name of the layout.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Location { get; set; }
Visual Basic (Declaration)
Public Property Location As String
Visual C++
public:
property String^ Location {
    String^ get ();
    void set (String^ value);
}

Remarks

The file name only applies to external layout files. Internal layout do not have a file name.

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


Margins Property

[image]

LinkOne WebView API
Layout..::.Margins Property
Layout Class See Also Send Feedback
Gets the base margins for the layout.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Margins Margins { get; set; }
Visual Basic (Declaration)
Public Property Margins As Margins
Visual C++
public:
property Margins^ Margins {
    Margins^ get ();
    void set (Margins^ value);
}

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


PageOrder Property

[image]

LinkOne WebView API
Layout..::.PageOrder Property
Layout Class See Also Send Feedback
Gets the Page Order attribute.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LayoutPageOrderCode PageOrder { get; set; }
Visual Basic (Declaration)
Public Property PageOrder As LayoutPageOrderCode
Visual C++
public:
virtual property LayoutPageOrderCode PageOrder {
    LayoutPageOrderCode get () sealed;
    void set (LayoutPageOrderCode value) sealed;
}

Implements

ILayout..::.PageOrder

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


PictureFirstMargins Property

[image]

LinkOne WebView API
Layout..::.PictureFirstMargins Property
Layout Class See Also Send Feedback
Gets the picture margins for the first picture page.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Margins PictureFirstMargins { get; set; }
Visual Basic (Declaration)
Public Property PictureFirstMargins As Margins
Visual C++
public:
property Margins^ PictureFirstMargins {
    Margins^ get ();
    void set (Margins^ value);
}

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


PictureMargins Property

[image]

LinkOne WebView API
Layout..::.PictureMargins Property
Layout Class See Also Send Feedback
Gets the picture margins.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Margins PictureMargins { get; set; }
Visual Basic (Declaration)
Public Property PictureMargins As Margins
Visual C++
public:
property Margins^ PictureMargins {
    Margins^ get ();
    void set (Margins^ value);
}

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


PictureSheetFacing Property

[image]

LinkOne WebView API
Layout..::.PictureSheetFacing Property
Layout Class See Also Send Feedback
Gets the PicSheetFacing attribute.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LayoutFacing PictureSheetFacing { get; set; }
Visual Basic (Declaration)
Public Property PictureSheetFacing As LayoutFacing
Visual C++
public:
virtual property LayoutFacing PictureSheetFacing {
    LayoutFacing get () sealed;
    void set (LayoutFacing value) sealed;
}

Implements

ILayout..::.PictureSheetFacing

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


PictureTitlesField Property

[image]

LinkOne WebView API
Layout..::.PictureTitlesField Property
Layout Class See Also Send Feedback
Gets or sets the Picture Titles Field layout attribute.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PictureTitlesField { get; set; }
Visual Basic (Declaration)
Public Property PictureTitlesField As String
Visual C++
public:
virtual property String^ PictureTitlesField {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ILayout..::.PictureTitlesField

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


PreferredListTitle Property

[image]

LinkOne WebView API
Layout..::.PreferredListTitle Property
Layout Class See Also Send Feedback
Gets or sets the Preferred List Title layout attribute.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PreferredListTitle { get; set; }
Visual Basic (Declaration)
Public Property PreferredListTitle As String
Visual C++
public:
virtual property String^ PreferredListTitle {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ILayout..::.PreferredListTitle

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


PreferredSearchSet Property

[image]

LinkOne WebView API
Layout..::.PreferredSearchSet Property
Layout Class See Also Send Feedback
Gets or sets the Preferred Search Set layout attribute.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PreferredSearchSet { get; set; }
Visual Basic (Declaration)
Public Property PreferredSearchSet As String
Visual C++
public:
virtual property String^ PreferredSearchSet {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ILayout..::.PreferredSearchSet

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


RepeatSheet Property

[image]

LinkOne WebView API
Layout..::.RepeatSheet Property
Layout Class See Also Send Feedback
Gets the Repeat Sheet attribute.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LayoutRepeatSheetCode RepeatSheet { get; set; }
Visual Basic (Declaration)
Public Property RepeatSheet As LayoutRepeatSheetCode
Visual C++
public:
virtual property LayoutRepeatSheetCode RepeatSheet {
    LayoutRepeatSheetCode get () sealed;
    void set (LayoutRepeatSheetCode value) sealed;
}

Implements

ILayout..::.RepeatSheet

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


SecurityLock Property

[image]

LinkOne WebView API
Layout..::.SecurityLock Property
Layout Class See Also Send Feedback
Gets or sets the layout Security Lock.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string SecurityLock { get; set; }
Visual Basic (Declaration)
Public Property SecurityLock As String
Visual C++
public:
virtual property String^ SecurityLock {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ILayout..::.SecurityLock

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


SheetFacing Property

[image]

LinkOne WebView API
Layout..::.SheetFacing Property
Layout Class See Also Send Feedback
Gets or sets the layout Sheet Facing attribute.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LayoutFacing SheetFacing { get; set; }
Visual Basic (Declaration)
Public Property SheetFacing As LayoutFacing
Visual C++
public:
virtual property LayoutFacing SheetFacing {
    LayoutFacing get () sealed;
    void set (LayoutFacing value) sealed;
}

Implements

ILayout..::.SheetFacing

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


Source Property

[image]

LinkOne WebView API
Layout..::.Source Property
Layout Class See Also Send Feedback
Gets the source of the layout.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LayoutSourceType Source { get; internal set; }
Visual Basic (Declaration)
Public Property Source As LayoutSourceType
Visual C++
public:
virtual property LayoutSourceType Source {
    LayoutSourceType get () sealed;
    void set (LayoutSourceType value) sealed;
}

Implements

ILayout..::.Source

See Also

Layout Class
Mincom.LinkOne.Dom.Layouts Namespace


LayoutCollection Class

[image]

LinkOne WebView API
LayoutCollection Class
Members See Also Send Feedback
Represents a collection of Layout objects that can be accessed by index.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class LayoutCollection : ICollection<Layout>,
    IEnumerable<Layout>, ILayoutCollection, ICollection<ILayout>,
    IEnumerable<ILayout>, IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class LayoutCollection _
    Implements ICollection(Of Layout), IEnumerable(Of Layout),  _
    ILayoutCollection, ICollection(Of ILayout), IEnumerable(Of ILayout),  _
    IEnumerable
Visual C++
[SerializableAttribute]
public ref class LayoutCollection sealed : ICollection<Layout^>,
    IEnumerable<Layout^>, ILayoutCollection, ICollection<ILayout^>,
    IEnumerable<ILayout^>, IEnumerable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Layouts..::.LayoutCollection

See Also

LayoutCollection Members
Mincom.LinkOne.Dom.Layouts Namespace


LayoutCollection Members

[image] [image]

LinkOne WebView API
LayoutCollection Members
LayoutCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The LayoutCollection type exposes the following members.

Constructors

Name | Description
LayoutCollection | Initializes a new instance of the LayoutCollection class.

Methods

Name | Description
Add | Adds the specified layout.
AddRange | Adds the items of the specified collection to the end of the LayoutCollection.
Clear | Removes all items from the ICollection<(Of <(T>)>).
ClearUserLayouts | Clears all user layouts.
Contains | Determines whether an layout is in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetCalloutToolTipFormat | Returns the format with the given name.
GetEnumerator | Returns an enumerator that iterates through the collection.
GetFormat | Returns the format with the given name.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHeaderOrFooterFormat | Returns the format with the given name.
GetLayout | Gets the Layout with the specified ID and language code, of a default layout if a layout with the specified ID was not found.
GetPartsFormat | Gets a format for a parts list based on the sheets facing value and sheet number.
GetPicturesFormat | Gets a format for a picture based on the sheets facing value and sheet number.
GetSortedForLanguage | Returns a sorted sub collection of the layouts in the collection based on the given language code.
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given layout object.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the specified layout.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements in the collection.
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.
Item | Gets the Layout at the specified index.

Explicit Interface Implementations

Name | Description
ICollection<(Of <(ILayout>)>)..::.Add |
ICollection<(Of <(ILayout>)>)..::.Contains |
CopyTo | Overloaded.
IEnumerable<(Of <(ILayout>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.
ICollection<(Of <(ILayout>)>)..::.Remove |

See Also

LayoutCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


LayoutCollection Constructor

[image]

LinkOne WebView API
LayoutCollection Constructor
LayoutCollection Class See Also Send Feedback
Initializes a new instance of the LayoutCollection class.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LayoutCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LayoutCollection()

See Also

LayoutCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


LayoutCollection Methods

[image] [image]

LinkOne WebView API
LayoutCollection Methods
LayoutCollection Class See Also Send Feedback

The LayoutCollection type exposes the following members.

Methods

Name | Description
Add | Adds the specified layout.
AddRange | Adds the items of the specified collection to the end of the LayoutCollection.
Clear | Removes all items from the ICollection<(Of <(T>)>).
ClearUserLayouts | Clears all user layouts.
Contains | Determines whether an layout is in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetCalloutToolTipFormat | Returns the format with the given name.
GetEnumerator | Returns an enumerator that iterates through the collection.
GetFormat | Returns the format with the given name.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHeaderOrFooterFormat | Returns the format with the given name.
GetLayout | Gets the Layout with the specified ID and language code, of a default layout if a layout with the specified ID was not found.
GetPartsFormat | Gets a format for a parts list based on the sheets facing value and sheet number.
GetPicturesFormat | Gets a format for a picture based on the sheets facing value and sheet number.
GetSortedForLanguage | Returns a sorted sub collection of the layouts in the collection based on the given language code.
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given layout object.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the specified layout.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ICollection<(Of <(ILayout>)>)..::.Add |
ICollection<(Of <(ILayout>)>)..::.Contains |
CopyTo | Overloaded.
IEnumerable<(Of <(ILayout>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.
ICollection<(Of <(ILayout>)>)..::.Remove |

See Also

LayoutCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


ICollection(ILayout).Add Method

[image]

LinkOne WebView API
LayoutCollection..::.ICollection<(Of <(ILayout>)>)..::.Add Method
LayoutCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<ILayout>.Add(
    ILayout item
)
Visual Basic (Declaration)
Private Sub Add ( _
    item As ILayout _
) Implements ICollection(Of ILayout).Add
Visual C++
private:
virtual void Add(
    ILayout^ item
) sealed = ICollection<ILayout^>::Add

Parameters

item
Type: Mincom.LinkOne.Dom.Layouts..::.ILayout

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

LayoutCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


ICollection(ILayout).Contains Method

[image]

LinkOne WebView API
LayoutCollection..::.ICollection<(Of <(ILayout>)>)..::.Contains Method
LayoutCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<ILayout>.Contains(
    ILayout item
)
Visual Basic (Declaration)
Private Function Contains ( _
    item As ILayout _
) As Boolean Implements ICollection(Of ILayout).Contains
Visual C++
private:
virtual bool Contains(
    ILayout^ item
) sealed = ICollection<ILayout^>::Contains

Parameters

item
Type: Mincom.LinkOne.Dom.Layouts..::.ILayout

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

LayoutCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


IEnumerable(ILayout).GetEnumerator Method

[image]

LinkOne WebView API
LayoutCollection..::.IEnumerable<(Of <(ILayout>)>)..::.GetEnumerator Method
LayoutCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator<ILayout> IEnumerable<ILayout>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of ILayout)
    Implements IEnumerable(Of ILayout).GetEnumerator
Visual C++
private:
virtual IEnumerator<ILayout^>^ GetEnumerator() sealed = IEnumerable<ILayout^>::GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

LayoutCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
LayoutCollection..::.IEnumerable..::.GetEnumerator Method
LayoutCollection Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

LayoutCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


ICollection(ILayout).Remove Method

[image]

LinkOne WebView API
LayoutCollection..::.ICollection<(Of <(ILayout>)>)..::.Remove Method
LayoutCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<ILayout>.Remove(
    ILayout item
)
Visual Basic (Declaration)
Private Function Remove ( _
    item As ILayout _
) As Boolean Implements ICollection(Of ILayout).Remove
Visual C++
private:
virtual bool Remove(
    ILayout^ item
) sealed = ICollection<ILayout^>::Remove

Parameters

item
Type: Mincom.LinkOne.Dom.Layouts..::.ILayout

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

LayoutCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


Add Method

[image]

LinkOne WebView API
LayoutCollection..::.Add Method
LayoutCollection Class See Also Send Feedback
Adds the specified layout.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Add(
    Layout item
)
Visual Basic (Declaration)
Public Sub Add ( _
    item As Layout _
)
Visual C++
public:
virtual void Add(
    Layout^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Dom.Layouts..::.Layout
The layout.

Implements

ICollection<(Of <(T>)>)..::.Add(T)

Remarks

Layouts in the collection are uniquely identified by the combination of Layout Id, Description, Language Code and Filename. If layout in the collection has the same combination of Id, Description, Language Code and Filename as the layout being added, then layout in the collection is first removed, and then the new layout added, effectively replacing the previous layout in the collection.

See Also

LayoutCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


AddRange Method

[image]

LinkOne WebView API
LayoutCollection..::.AddRange Method
LayoutCollection Class See Also Send Feedback
Adds the items of the specified collection to the end of the LayoutCollection.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void AddRange(
    IEnumerable<Layout> layouts
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    layouts As IEnumerable(Of Layout) _
)
Visual C++
public:
void AddRange(
    IEnumerable<Layout^>^ layouts
)

Parameters

layouts
Type: System.Collections.Generic..::.IEnumerable<(Of <( Layout >)>)
The collection whose elements should be added to the LayoutCollection.

See Also

LayoutCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


Clear Method

[image]

LinkOne WebView API
LayoutCollection..::.Clear Method
LayoutCollection Class See Also Send Feedback
Removes all items from the ICollection<(Of <(T>)>).

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
virtual void Clear() sealed

Implements

ICollection<(Of <(T>)>)..::.Clear()()()
ICollection<(Of <(T>)>)..::.Clear()()()

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

LayoutCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


ClearUserLayouts Method

[image]

LinkOne WebView API
LayoutCollection..::.ClearUserLayouts Method
LayoutCollection Class See Also Send Feedback
Clears all user layouts.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void ClearUserLayouts()
Visual Basic (Declaration)
Public Sub ClearUserLayouts
Visual C++
public:
void ClearUserLayouts()

See Also

LayoutCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


Contains Method

[image]

LinkOne WebView API
LayoutCollection..::.Contains Method
LayoutCollection Class See Also Send Feedback
Determines whether an layout is in the collection.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    Layout item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As Layout _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Layout^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Dom.Layouts..::.Layout
The domObject object to search for.

Return Value

true if found in the collection, otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

LayoutCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


CopyTo Method

[image] [image]

LinkOne WebView API
LayoutCollection..::.CopyTo Method
LayoutCollection Class See Also Send Feedback

Overload List

Name | Description
ICollection<(Of <(ILayout>)>)..::.CopyTo(array<ILayout>[]()[], Int32) |
ICollection<(Of <(Layout>)>)..::.CopyTo(array<Layout>[]()[], Int32) |

See Also

LayoutCollection Class
LayoutCollection Members
Mincom.LinkOne.Dom.Layouts Namespace


ICollection(ILayout).CopyTo Method (ILayout[], Int32)

[image]

LinkOne WebView API
LayoutCollection..::.ICollection<(Of <(ILayout>)>)..::.CopyTo Method (array<ILayout>[]()[], Int32)
LayoutCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<ILayout>.CopyTo(
    ILayout[] array,
    int arrayIndex
)
Visual Basic (Declaration)
Private Sub CopyTo ( _
    array As ILayout(), _
    arrayIndex As Integer _
) Implements ICollection(Of ILayout).CopyTo
Visual C++
private:
virtual void CopyTo(
    array<ILayout^>^ array,
    int arrayIndex
) sealed = ICollection<ILayout^>::CopyTo

Parameters

array
Type: array< Mincom.LinkOne.Dom.Layouts..::.ILayout >[]()[]
arrayIndex
Type: System..::.Int32

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

LayoutCollection Class
LayoutCollection Overload
Mincom.LinkOne.Dom.Layouts Namespace


ICollection(Layout).CopyTo Method (Layout[], Int32)

[image]

LinkOne WebView API
LayoutCollection..::.ICollection<(Of <(Layout>)>)..::.CopyTo Method (array<Layout>[]()[], Int32)
LayoutCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<Layout>.CopyTo(
    Layout[] array,
    int arrayIndex
)
Visual Basic (Declaration)
Private Sub CopyTo ( _
    array As Layout(), _
    arrayIndex As Integer _
) Implements ICollection(Of Layout).CopyTo
Visual C++
private:
virtual void CopyTo(
    array<Layout^>^ array,
    int arrayIndex
) sealed = ICollection<Layout^>::CopyTo

Parameters

array
Type: array< Mincom.LinkOne.Dom.Layouts..::.Layout >[]()[]
arrayIndex
Type: System..::.Int32

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

LayoutCollection Class
LayoutCollection Overload
Mincom.LinkOne.Dom.Layouts Namespace


GetCalloutToolTipFormat Method

[image]

LinkOne WebView API
LayoutCollection..::.GetCalloutToolTipFormat Method
LayoutCollection Class See Also Send Feedback
Returns the format with the given name.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Format GetCalloutToolTipFormat(
    Layout layout,
    string formatName
)
Visual Basic (Declaration)
Public Function GetCalloutToolTipFormat ( _
    layout As Layout, _
    formatName As String _
) As Format
Visual C++
public:
Format^ GetCalloutToolTipFormat(
    Layout^ layout,
    String^ formatName
)

Parameters

layout
Type: Mincom.LinkOne.Dom.Layouts..::.Layout
The layout containing the format.
formatName
Type: System..::.String
The name of the wanted format.

Return Value

The format with the given name.

Remarks

The format is looked up in the following order:
  1. The named format in the given layout.
  2. The "callout_tooltip" format from the predefined layout.

See Also

LayoutCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


GetEnumerator Method

[image]

LinkOne WebView API
LayoutCollection..::.GetEnumerator Method
LayoutCollection Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IEnumerator<Layout> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of Layout)
Visual C++
public:
virtual IEnumerator<Layout^>^ GetEnumerator() sealed

Return Value

A IEnumerator<(Of <(T>)>) that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

LayoutCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


GetFormat Method

[image]

LinkOne WebView API
LayoutCollection..::.GetFormat Method
LayoutCollection Class See Also Send Feedback
Returns the format with the given name.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Format GetFormat(
    Layout layout,
    string formatName
)
Visual Basic (Declaration)
Public Function GetFormat ( _
    layout As Layout, _
    formatName As String _
) As Format
Visual C++
public:
Format^ GetFormat(
    Layout^ layout,
    String^ formatName
)

Parameters

layout
Type: Mincom.LinkOne.Dom.Layouts..::.Layout
The layout containing the format.
formatName
Type: System..::.String
The name of the wanted format.

Return Value

The format with the given name, or null if the collection has no default layout.

Remarks

This method should only be used to obtain a format for the parts list body.
The format is looked up in the following order:
  1. The named format in the given layout.
  2. The named format in the default (unnamed) layout of the collection.
  3. The default (unnamed) format in the given layout.
  4. The default (unnamed) format in the default (unnamed) layout of the collection.

See Also

LayoutCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


GetHeaderOrFooterFormat Method

[image]

LinkOne WebView API
LayoutCollection..::.GetHeaderOrFooterFormat Method
LayoutCollection Class See Also Send Feedback
Returns the format with the given name.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Format GetHeaderOrFooterFormat(
    Layout layout,
    string formatName
)
Visual Basic (Declaration)
Public Function GetHeaderOrFooterFormat ( _
    layout As Layout, _
    formatName As String _
) As Format
Visual C++
public:
Format^ GetHeaderOrFooterFormat(
    Layout^ layout,
    String^ formatName
)

Parameters

layout
Type: Mincom.LinkOne.Dom.Layouts..::.Layout
The layout containing the format.
formatName
Type: System..::.String
The name of the wanted format.

Return Value

The format with the given name, or null if the collection has no default layout.

Remarks

This method should only be used to obtain a format for the parts list header or footer.
The format is looked up in the following order:
  1. The named format in the given layout.
  2. The named format in the default (unnamed) layout of the collection.
  3. The "empty" format from the predefined layout.

See Also

LayoutCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


GetLayout Method

[image]

LinkOne WebView API
LayoutCollection..::.GetLayout Method
LayoutCollection Class See Also Send Feedback
Gets the Layout with the specified ID and language code, of a default layout if a layout with the specified ID was not found.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Layout GetLayout(
    string id,
    string languageCode
)
Visual Basic (Declaration)
Public Function GetLayout ( _
    id As String, _
    languageCode As String _
) As Layout
Visual C++
public:
Layout^ GetLayout(
    String^ id,
    String^ languageCode
)

Parameters

id
Type: System..::.String
The ID of the required layout.
languageCode
Type: System..::.String
The language code that the required layout is associated with.

Return Value

The requested layout.

Remarks

Gets the wanted layout, or the intrinsic layout if the layout was not found.

See Also

LayoutCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


GetPartsFormat Method

[image]

LinkOne WebView API
LayoutCollection..::.GetPartsFormat Method
LayoutCollection Class See Also Send Feedback
Gets a format for a parts list based on the sheets facing value and sheet number.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static Format GetPartsFormat(
    Page page,
    Layout layout,
    SheetFacing facing,
    int sheetNumber,
    bool isHeader
)
Visual Basic (Declaration)
Public Shared Function GetPartsFormat ( _
    page As Page, _
    layout As Layout, _
    facing As SheetFacing, _
    sheetNumber As Integer, _
    isHeader As Boolean _
) As Format
Visual C++
public:
static Format^ GetPartsFormat(
    Page^ page,
    Layout^ layout,
    SheetFacing facing,
    int sheetNumber,
    bool isHeader
)

Parameters

page
Type: Mincom.LinkOne.Dom..::.Page
The page containing the content to be displayed or printed.
layout
Type: Mincom.LinkOne.Dom.Layouts..::.Layout
The preferred layout to find format in.
facing
Type: Mincom.LinkOne.Dom.Layouts..::.SheetFacing
The current sheetfacing value of the content.
sheetNumber
Type: System..::.Int32
The current sheet number of the page.
isHeader
Type: System..::.Boolean
True if this is for a header, false if for a footer.

Return Value

The most appropriate format given the pages context.

Remarks

This routine will find the most appropriate layout based on book and page string attributes to find initial/first, left/right, odd/even, header/footer formats.

See Also

LayoutCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


GetPicturesFormat Method

[image]

LinkOne WebView API
LayoutCollection..::.GetPicturesFormat Method
LayoutCollection Class See Also Send Feedback
Gets a format for a picture based on the sheets facing value and sheet number.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static Format GetPicturesFormat(
    Page page,
    Layout layout,
    SheetFacing facing,
    int sheetNumber,
    bool isHeader
)
Visual Basic (Declaration)
Public Shared Function GetPicturesFormat ( _
    page As Page, _
    layout As Layout, _
    facing As SheetFacing, _
    sheetNumber As Integer, _
    isHeader As Boolean _
) As Format
Visual C++
public:
static Format^ GetPicturesFormat(
    Page^ page,
    Layout^ layout,
    SheetFacing facing,
    int sheetNumber,
    bool isHeader
)

Parameters

page
Type: Mincom.LinkOne.Dom..::.Page
The page containing the content to be displayed or printed.
layout
Type: Mincom.LinkOne.Dom.Layouts..::.Layout
The preferred layout to find format in.
facing
Type: Mincom.LinkOne.Dom.Layouts..::.SheetFacing
The current sheetfacing value of the content.
sheetNumber
Type: System..::.Int32
The current sheet number of the page.
isHeader
Type: System..::.Boolean
True if this is for a header, false if for a footer.

Return Value

The most appropriate format given the pages context.

Remarks

This routine will find the most appropriate layout based on book and page string attributes to find initial/first, left/right, odd/even, header/footer formats.

See Also

LayoutCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


GetSortedForLanguage Method

[image]

LinkOne WebView API
LayoutCollection..::.GetSortedForLanguage Method
LayoutCollection Class See Also Send Feedback
Returns a sorted sub collection of the layouts in the collection based on the given language code.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LayoutCollection GetSortedForLanguage(
    string languageCode
)
Visual Basic (Declaration)
Public Function GetSortedForLanguage ( _
    languageCode As String _
) As LayoutCollection
Visual C++
public:
LayoutCollection^ GetSortedForLanguage(
    String^ languageCode
)

Parameters

languageCode
Type: System..::.String
The language code to filter the layouts on.

Return Value

A sorted sub collection of the layouts in the collection based on the given language code.

Remarks

The returned subcollection includes one layout per layout id for each of those layouts that match the given language, and those layouts that have no language defined. Results are sorted by their source first, then their description.

See Also

LayoutCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


IndexOf Method

[image]

LinkOne WebView API
LayoutCollection..::.IndexOf Method
LayoutCollection Class See Also Send Feedback
Searches the collection and returns the zero-based index of the first occurence of the given layout object.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int IndexOf(
    Layout layout
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    layout As Layout _
) As Integer
Visual C++
public:
int IndexOf(
    Layout^ layout
)

Parameters

layout
Type: Mincom.LinkOne.Dom.Layouts..::.Layout
The layout object to search for.

Return Value

The zero-based index of the layout object in the collection, if found; otherwise, -1.

See Also

LayoutCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


Remove Method

[image]

LinkOne WebView API
LayoutCollection..::.Remove Method
LayoutCollection Class See Also Send Feedback
Removes the specified layout.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Remove(
    Layout item
)
Visual Basic (Declaration)
Public Function Remove ( _
    item As Layout _
) As Boolean
Visual C++
public:
virtual bool Remove(
    Layout^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Dom.Layouts..::.Layout
The layout to remove.

Return Value

A value indicating whether the layout was removed.

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

LayoutCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


LayoutCollection Properties

[image] [image]

LinkOne WebView API
LayoutCollection Properties
LayoutCollection Class See Also Send Feedback

The LayoutCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection.
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.
Item | Gets the Layout at the specified index.

See Also

LayoutCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


Count Property

[image]

LinkOne WebView API
LayoutCollection..::.Count Property
LayoutCollection Class See Also Send Feedback
Gets the number of elements in the collection.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollection<(Of <(T>)>)..::.Count
ICollection<(Of <(T>)>)..::.Count

See Also

LayoutCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


IsReadOnly Property

[image]

LinkOne WebView API
LayoutCollection..::.IsReadOnly Property
LayoutCollection Class See Also Send Feedback
Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Return Value

true if the ICollection<(Of <(T>)>) is read-only; otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly
ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

LayoutCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


Item Property

[image]

LinkOne WebView API
LayoutCollection..::.Item Property
LayoutCollection Class See Also Send Feedback
Gets the Layout at the specified index.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Layout this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Layout
Visual C++
public:
property Layout^ default[int index] {
    Layout^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

LayoutCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


LayoutFacing Enumeration

[image]

LinkOne WebView API
LayoutFacing Enumeration
See Also Send Feedback
Values for specifying which side sheet are facing.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum LayoutFacing
Visual Basic (Declaration)
Public Enumeration LayoutFacing
Visual C++
public enum class LayoutFacing

Members

Member name | Description
None | No sheetfacing specified.
Any | Each sheet will be opposite of the previous sheet.
Left | All sheets will be printed as left hand sheets.
FirstLeft | First sheet will be left hand, and the remainder will alternate.
Right | All sheets are right hand sheets.
FirstRight | First sheet will be right hand, and the remainder will alternate.

See Also

Mincom.LinkOne.Dom.Layouts Namespace


LayoutPageOrderCode Enumeration

[image]

LinkOne WebView API
LayoutPageOrderCode Enumeration
See Also Send Feedback
Values for specifying the page order of a printed sheet.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum LayoutPageOrderCode
Visual Basic (Declaration)
Public Enumeration LayoutPageOrderCode
Visual C++
public enum class LayoutPageOrderCode

Members

Member name | Description
AllPicsFirst | All pictures pages are printed first.
AllListFirst | All list pages are printed first.
InterleavedPicFirst | Interleaved picture and part pages with the picture page shown first.
InterleavedListFirst | Interleaved picture and part pages with the parts page shown first.

See Also

Mincom.LinkOne.Dom.Layouts Namespace


LayoutRepeatSheetCode Enumeration

[image]

LinkOne WebView API
LayoutRepeatSheetCode Enumeration
See Also Send Feedback
Values for specifying how blank sheets are used when page order is interleaved.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum LayoutRepeatSheetCode
Visual Basic (Declaration)
Public Enumeration LayoutRepeatSheetCode
Visual C++
public enum class LayoutRepeatSheetCode

Members

Member name | Description
UseDefault | Uses the default sheet.
Blank | Repeat blank sheets.
All | Repeat all sheets in place of blank sheets.
First | Repeat the first sheet in place of blank sheets.
Last | Repeat the last sheet in place of blank sheets.

See Also

Mincom.LinkOne.Dom.Layouts Namespace


LayoutSourceType Enumeration

[image]

LinkOne WebView API
LayoutSourceType Enumeration
See Also Send Feedback
The source of the layout.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum LayoutSourceType
Visual Basic (Declaration)
Public Enumeration LayoutSourceType
Visual C++
public enum class LayoutSourceType

Members

Member name | Description
Predefined | The layout is predefined by LinkOne.
Automatic | The layout is predefined by LinkOne and based on the current selection list fields.
Book | The layout is from the book.
User | The layout is from the user.

See Also

Mincom.LinkOne.Dom.Layouts Namespace


LayoutTable Class

[image]

LinkOne WebView API
LayoutTable Class
Members See Also Send Feedback
Represents a table (such as a format, column headings, embedded tables, etc) in a layout. A layout table consists of a collection of rows.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public class LayoutTable : ILayoutTable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class LayoutTable _
    Implements ILayoutTable
Visual C++
[SerializableAttribute]
public ref class LayoutTable : ILayoutTable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Layouts..::.LayoutTable
Mincom.LinkOne.Dom.Layouts..::.Format
Mincom.LinkOne.Dom.Layouts..::.Heading
Mincom.LinkOne.Dom.Layouts..::.Table

See Also

LayoutTable Members
Mincom.LinkOne.Dom.Layouts Namespace


LayoutTable Members

[image] [image]

LinkOne WebView API
LayoutTable Members
LayoutTable Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The LayoutTable type exposes the following members.

Constructors

Name | Description
LayoutTable | Initializes a new instance of the LayoutTable class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
FormatExpand | Gets or sets the FormatExpand property of the TableFormat.
Rows | The collection of rows in the table.

Explicit Interface Implementations

Name | Description
ILayoutTable..::.FormatExpand |
ILayoutTable..::.Rows |

See Also

LayoutTable Class
Mincom.LinkOne.Dom.Layouts Namespace


LayoutTable Constructor

[image]

LinkOne WebView API
LayoutTable Constructor
LayoutTable Class See Also Send Feedback
Initializes a new instance of the LayoutTable class

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LayoutTable()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LayoutTable()

See Also

LayoutTable Class
Mincom.LinkOne.Dom.Layouts Namespace


LayoutTable Methods

[image] [image]

LinkOne WebView API
LayoutTable Methods
LayoutTable Class See Also Send Feedback

The LayoutTable type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LayoutTable Class
Mincom.LinkOne.Dom.Layouts Namespace


LayoutTable Properties

[image] [image]

LinkOne WebView API
LayoutTable Properties
LayoutTable Class See Also Send Feedback

The LayoutTable type exposes the following members.

Properties

Name | Description
FormatExpand | Gets or sets the FormatExpand property of the TableFormat.
Rows | The collection of rows in the table.

Explicit Interface Implementations

Name | Description
ILayoutTable..::.FormatExpand |
ILayoutTable..::.Rows |

See Also

LayoutTable Class
Mincom.LinkOne.Dom.Layouts Namespace


FormatExpand Property

[image]

LinkOne WebView API
LayoutTable..::.FormatExpand Property
LayoutTable Class See Also Send Feedback
Gets or sets the FormatExpand property of the TableFormat.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool FormatExpand { get; set; }
Visual Basic (Declaration)
Public Property FormatExpand As Boolean
Visual C++
public:
property bool FormatExpand {
    bool get ();
    void set (bool value);
}

See Also

LayoutTable Class
Mincom.LinkOne.Dom.Layouts Namespace


ILayoutTable.FormatExpand Property

[image]

LinkOne WebView API
LayoutTable..::.ILayoutTable..::.FormatExpand Property
LayoutTable Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ILayoutTable.FormatExpand { get; set; }
Visual Basic (Declaration)
Private Property FormatExpand As Boolean
    Implements ILayoutTable.FormatExpand
Visual C++
private:
virtual property bool FormatExpand {
    bool get () sealed = ILayoutTable::FormatExpand::get;
    void set (bool value) sealed = ILayoutTable::FormatExpand::set;
}

Implements

ILayoutTable..::.FormatExpand

See Also

LayoutTable Class
Mincom.LinkOne.Dom.Layouts Namespace


ILayoutTable.Rows Property

[image]

LinkOne WebView API
LayoutTable..::.ILayoutTable..::.Rows Property
LayoutTable Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ICollection<IRow> ILayoutTable.Rows { get; }
Visual Basic (Declaration)
Private ReadOnly Property Rows As ICollection(Of IRow)
    Implements ILayoutTable.Rows
Visual C++
private:
virtual property ICollection<IRow^>^ Rows {
    ICollection<IRow^>^ get () sealed = ILayoutTable::Rows::get;
}

Implements

ILayoutTable..::.Rows

See Also

LayoutTable Class
Mincom.LinkOne.Dom.Layouts Namespace


Rows Property

[image]

LinkOne WebView API
LayoutTable..::.Rows Property
LayoutTable Class See Also Send Feedback
The collection of rows in the table.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IList<Row> Rows { get; }
Visual Basic (Declaration)
Public ReadOnly Property Rows As IList(Of Row)
Visual C++
public:
property IList<Row^>^ Rows {
    IList<Row^>^ get ();
}

See Also

LayoutTable Class
Mincom.LinkOne.Dom.Layouts Namespace


LayoutType Enumeration

[image]

LinkOne WebView API
LayoutType Enumeration
See Also Send Feedback
Values for the type of layout to use.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum LayoutType
Visual Basic (Declaration)
Public Enumeration LayoutType
Visual C++
public enum class LayoutType

Members

Member name | Description
Screen | Inidicates a screen layout
Print | Inidicates a print layout

See Also

Mincom.LinkOne.Dom.Layouts Namespace


ListField Class

[image]

LinkOne WebView API
ListField Class
Members See Also Send Feedback
Represents a parts list field in a layout cell.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public class ListField : IListField, ICellContents
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ListField _
    Implements IListField, ICellContents
Visual C++
[SerializableAttribute]
public ref class ListField : IListField,
    ICellContents

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Layouts..::.ListField

See Also

ListField Members
Mincom.LinkOne.Dom.Layouts Namespace


ListField Members

[image] [image]

LinkOne WebView API
ListField Members
ListField Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ListField type exposes the following members.

Constructors

Name | Description
ListField | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Name | The name of the list field.

Explicit Interface Implementations

Name | Description
IListField..::.Name |

See Also

ListField Class
Mincom.LinkOne.Dom.Layouts Namespace


ListField Constructor

[image] [image]

LinkOne WebView API
ListField Constructor
ListField Class See Also Send Feedback

Overload List

Name | Description
ListField()()() | Initializes a new instance of the ListField class.
ListField(String) | Initializes a new instance of the ListField class.

See Also

ListField Class
ListField Members
Mincom.LinkOne.Dom.Layouts Namespace


ListField Constructor

[image]

LinkOne WebView API
ListField Constructor
ListField Class See Also Send Feedback
Initializes a new instance of the ListField class.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ListField()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ListField()

See Also

ListField Class
ListField Overload
Mincom.LinkOne.Dom.Layouts Namespace


ListField Constructor (String)

[image]

LinkOne WebView API
ListField Constructor (String)
ListField Class See Also Send Feedback
Initializes a new instance of the ListField class.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ListField(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)
Visual C++
public:
ListField(
    String^ name
)

Parameters

name
Type: System..::.String
The name fo the list field.

See Also

ListField Class
ListField Overload
Mincom.LinkOne.Dom.Layouts Namespace


ListField Methods

[image] [image]

LinkOne WebView API
ListField Methods
ListField Class See Also Send Feedback

The ListField type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ListField Class
Mincom.LinkOne.Dom.Layouts Namespace


ListField Properties

[image] [image]

LinkOne WebView API
ListField Properties
ListField Class See Also Send Feedback

The ListField type exposes the following members.

Properties

Name | Description
Name | The name of the list field.

Explicit Interface Implementations

Name | Description
IListField..::.Name |

See Also

ListField Class
Mincom.LinkOne.Dom.Layouts Namespace


IListField.Name Property

[image]

LinkOne WebView API
ListField..::.IListField..::.Name Property
ListField Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string IListField.Name { get; set; }
Visual Basic (Declaration)
Private Property Name As String Implements IListField.Name
Visual C++
private:
virtual property String^ Name {
    String^ get () sealed = IListField::Name::get;
    void set (String^ value) sealed = IListField::Name::set;
}

Implements

IListField..::.Name

See Also

ListField Class
Mincom.LinkOne.Dom.Layouts Namespace


Name Property

[image]

LinkOne WebView API
ListField..::.Name Property
ListField Class See Also Send Feedback
The name of the list field.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The list field name.

See Also

ListField Class
Mincom.LinkOne.Dom.Layouts Namespace


LiteralText Class

[image]

LinkOne WebView API
LiteralText Class
Members See Also Send Feedback
Represents a constant text field in a layout cell.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public class LiteralText : ILiteralText,
    ICellContents
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class LiteralText _
    Implements ILiteralText, ICellContents
Visual C++
[SerializableAttribute]
public ref class LiteralText : ILiteralText,
    ICellContents

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Layouts..::.LiteralText

See Also

LiteralText Members
Mincom.LinkOne.Dom.Layouts Namespace


LiteralText Members

[image] [image]

LinkOne WebView API
LiteralText Members
LiteralText Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The LiteralText type exposes the following members.

Constructors

Name | Description
LiteralText | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Text | The text inside the cell.

Explicit Interface Implementations

Name | Description
ILiteralText..::.Text |

See Also

LiteralText Class
Mincom.LinkOne.Dom.Layouts Namespace


LiteralText Constructor

[image] [image]

LinkOne WebView API
LiteralText Constructor
LiteralText Class See Also Send Feedback

Overload List

Name | Description
LiteralText()()() | Initializes a new instance of the LiteralText class.
LiteralText(String) | Initializes a new instance of the LiteralText class.

See Also

LiteralText Class
LiteralText Members
Mincom.LinkOne.Dom.Layouts Namespace


LiteralText Constructor

[image]

LinkOne WebView API
LiteralText Constructor
LiteralText Class See Also Send Feedback
Initializes a new instance of the LiteralText class.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LiteralText()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LiteralText()

See Also

LiteralText Class
LiteralText Overload
Mincom.LinkOne.Dom.Layouts Namespace


LiteralText Constructor (String)

[image]

LinkOne WebView API
LiteralText Constructor (String)
LiteralText Class See Also Send Feedback
Initializes a new instance of the LiteralText class.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LiteralText(
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    text As String _
)
Visual C++
public:
LiteralText(
    String^ text
)

Parameters

text
Type: System..::.String
The text inside the cell.

See Also

LiteralText Class
LiteralText Overload
Mincom.LinkOne.Dom.Layouts Namespace


LiteralText Methods

[image] [image]

LinkOne WebView API
LiteralText Methods
LiteralText Class See Also Send Feedback

The LiteralText type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LiteralText Class
Mincom.LinkOne.Dom.Layouts Namespace


LiteralText Properties

[image] [image]

LinkOne WebView API
LiteralText Properties
LiteralText Class See Also Send Feedback

The LiteralText type exposes the following members.

Properties

Name | Description
Text | The text inside the cell.

Explicit Interface Implementations

Name | Description
ILiteralText..::.Text |

See Also

LiteralText Class
Mincom.LinkOne.Dom.Layouts Namespace


ILiteralText.Text Property

[image]

LinkOne WebView API
LiteralText..::.ILiteralText..::.Text Property
LiteralText Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string ILiteralText.Text { get; set; }
Visual Basic (Declaration)
Private Property Text As String Implements ILiteralText.Text
Visual C++
private:
virtual property String^ Text {
    String^ get () sealed = ILiteralText::Text::get;
    void set (String^ value) sealed = ILiteralText::Text::set;
}

Implements

ILiteralText..::.Text

See Also

LiteralText Class
Mincom.LinkOne.Dom.Layouts Namespace


Text Property

[image]

LinkOne WebView API
LiteralText..::.Text Property
LiteralText Class See Also Send Feedback
The text inside the cell.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Field Value

The cell text.

See Also

LiteralText Class
Mincom.LinkOne.Dom.Layouts Namespace


Margins Class

[image]

LinkOne WebView API
Margins Class
Members See Also Send Feedback
Describe the border margins for a layout object.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class Margins : IMargins
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class Margins _
    Implements IMargins
Visual C++
[SerializableAttribute]
public ref class Margins sealed : IMargins

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Layouts..::.Margins

See Also

Margins Members
Mincom.LinkOne.Dom.Layouts Namespace


Margins Members

[image] [image]

LinkOne WebView API
Margins Members
Margins Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The Margins type exposes the following members.

Constructors

Name | Description
Margins | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
BottomMargin | Gets or sets the dimension of the bottom margin.
LeftMargin | Gets or sets the dimension of the left margin.
RightMargin | Gets or sets the dimension of the right margin.
TopMargin | Gets or sets the dimension of the top margin.

Explicit Interface Implementations

Name | Description
IMargins..::.BottomMargin |
IMargins..::.LeftMargin |
IMargins..::.RightMargin |
IMargins..::.TopMargin |

See Also

Margins Class
Mincom.LinkOne.Dom.Layouts Namespace


Margins Constructor

[image] [image]

LinkOne WebView API
Margins Constructor
Margins Class See Also Send Feedback

Overload List

Name | Description
Margins()()() | Constructor.
Margins(Dimension, Dimension, Dimension, Dimension) | Constructor.

See Also

Margins Class
Margins Members
Mincom.LinkOne.Dom.Layouts Namespace


Margins Constructor

[image]

LinkOne WebView API
Margins Constructor
Margins Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Margins()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Margins()

See Also

Margins Class
Margins Overload
Mincom.LinkOne.Dom.Layouts Namespace


Margins Constructor (Dimension, Dimension, Dimension, Dimension)

[image]

LinkOne WebView API
Margins Constructor (Dimension, Dimension, Dimension, Dimension)
Margins Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Margins(
    Dimension top,
    Dimension bottom,
    Dimension left,
    Dimension right
)
Visual Basic (Declaration)
Public Sub New ( _
    top As Dimension, _
    bottom As Dimension, _
    left As Dimension, _
    right As Dimension _
)
Visual C++
public:
Margins(
    Dimension^ top,
    Dimension^ bottom,
    Dimension^ left,
    Dimension^ right
)

Parameters

top
Type: Mincom.LinkOne.Dom.Layouts..::.Dimension
The dimension of the top margin.
bottom
Type: Mincom.LinkOne.Dom.Layouts..::.Dimension
The dimension of the bottom margin.
left
Type: Mincom.LinkOne.Dom.Layouts..::.Dimension
The Dimension of the left margin
right
Type: Mincom.LinkOne.Dom.Layouts..::.Dimension
The dimensions of the right margin

See Also

Margins Class
Margins Overload
Mincom.LinkOne.Dom.Layouts Namespace


Margins Methods

[image] [image]

LinkOne WebView API
Margins Methods
Margins Class See Also Send Feedback

The Margins type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Margins Class
Mincom.LinkOne.Dom.Layouts Namespace


Margins Properties

[image] [image]

LinkOne WebView API
Margins Properties
Margins Class See Also Send Feedback

The Margins type exposes the following members.

Properties

Name | Description
BottomMargin | Gets or sets the dimension of the bottom margin.
LeftMargin | Gets or sets the dimension of the left margin.
RightMargin | Gets or sets the dimension of the right margin.
TopMargin | Gets or sets the dimension of the top margin.

Explicit Interface Implementations

Name | Description
IMargins..::.BottomMargin |
IMargins..::.LeftMargin |
IMargins..::.RightMargin |
IMargins..::.TopMargin |

See Also

Margins Class
Mincom.LinkOne.Dom.Layouts Namespace


BottomMargin Property

[image]

LinkOne WebView API
Margins..::.BottomMargin Property
Margins Class See Also Send Feedback
Gets or sets the dimension of the bottom margin.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Dimension BottomMargin { get; set; }
Visual Basic (Declaration)
Public Property BottomMargin As Dimension
Visual C++
public:
property Dimension^ BottomMargin {
    Dimension^ get ();
    void set (Dimension^ value);
}

See Also

Margins Class
Mincom.LinkOne.Dom.Layouts Namespace


IMargins.BottomMargin Property

[image]

LinkOne WebView API
Margins..::.IMargins..::.BottomMargin Property
Margins Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension IMargins.BottomMargin { get; set; }
Visual Basic (Declaration)
Private Property BottomMargin As IDimension
    Implements IMargins.BottomMargin
Visual C++
private:
virtual property IDimension^ BottomMargin {
    IDimension^ get () sealed = IMargins::BottomMargin::get;
    void set (IDimension^ value) sealed = IMargins::BottomMargin::set;
}

Implements

IMargins..::.BottomMargin

See Also

Margins Class
Mincom.LinkOne.Dom.Layouts Namespace


IMargins.LeftMargin Property

[image]

LinkOne WebView API
Margins..::.IMargins..::.LeftMargin Property
Margins Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension IMargins.LeftMargin { get; set; }
Visual Basic (Declaration)
Private Property LeftMargin As IDimension
    Implements IMargins.LeftMargin
Visual C++
private:
virtual property IDimension^ LeftMargin {
    IDimension^ get () sealed = IMargins::LeftMargin::get;
    void set (IDimension^ value) sealed = IMargins::LeftMargin::set;
}

Implements

IMargins..::.LeftMargin

See Also

Margins Class
Mincom.LinkOne.Dom.Layouts Namespace


IMargins.RightMargin Property

[image]

LinkOne WebView API
Margins..::.IMargins..::.RightMargin Property
Margins Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension IMargins.RightMargin { get; set; }
Visual Basic (Declaration)
Private Property RightMargin As IDimension
    Implements IMargins.RightMargin
Visual C++
private:
virtual property IDimension^ RightMargin {
    IDimension^ get () sealed = IMargins::RightMargin::get;
    void set (IDimension^ value) sealed = IMargins::RightMargin::set;
}

Implements

IMargins..::.RightMargin

See Also

Margins Class
Mincom.LinkOne.Dom.Layouts Namespace


IMargins.TopMargin Property

[image]

LinkOne WebView API
Margins..::.IMargins..::.TopMargin Property
Margins Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension IMargins.TopMargin { get; set; }
Visual Basic (Declaration)
Private Property TopMargin As IDimension
    Implements IMargins.TopMargin
Visual C++
private:
virtual property IDimension^ TopMargin {
    IDimension^ get () sealed = IMargins::TopMargin::get;
    void set (IDimension^ value) sealed = IMargins::TopMargin::set;
}

Implements

IMargins..::.TopMargin

See Also

Margins Class
Mincom.LinkOne.Dom.Layouts Namespace


LeftMargin Property

[image]

LinkOne WebView API
Margins..::.LeftMargin Property
Margins Class See Also Send Feedback
Gets or sets the dimension of the left margin.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Dimension LeftMargin { get; set; }
Visual Basic (Declaration)
Public Property LeftMargin As Dimension
Visual C++
public:
property Dimension^ LeftMargin {
    Dimension^ get ();
    void set (Dimension^ value);
}

See Also

Margins Class
Mincom.LinkOne.Dom.Layouts Namespace


RightMargin Property

[image]

LinkOne WebView API
Margins..::.RightMargin Property
Margins Class See Also Send Feedback
Gets or sets the dimension of the right margin.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Dimension RightMargin { get; set; }
Visual Basic (Declaration)
Public Property RightMargin As Dimension
Visual C++
public:
property Dimension^ RightMargin {
    Dimension^ get ();
    void set (Dimension^ value);
}

See Also

Margins Class
Mincom.LinkOne.Dom.Layouts Namespace


TopMargin Property

[image]

LinkOne WebView API
Margins..::.TopMargin Property
Margins Class See Also Send Feedback
Gets or sets the dimension of the top margin.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Dimension TopMargin { get; set; }
Visual Basic (Declaration)
Public Property TopMargin As Dimension
Visual C++
public:
property Dimension^ TopMargin {
    Dimension^ get ();
    void set (Dimension^ value);
}

See Also

Margins Class
Mincom.LinkOne.Dom.Layouts Namespace


Picture Class

[image]

LinkOne WebView API
Picture Class
Members See Also Send Feedback
Represents a picture in a layout cell.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public class Picture : IPicture, ICellContents
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class Picture _
    Implements IPicture, ICellContents
Visual C++
[SerializableAttribute]
public ref class Picture : IPicture,
    ICellContents

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Layouts..::.Picture

See Also

Picture Members
Mincom.LinkOne.Dom.Layouts Namespace


Picture Members

[image] [image]

LinkOne WebView API
Picture Members
Picture Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The Picture type exposes the following members.

Constructors

Name | Description
Picture | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Height | The height of the picture.
Location | The name of the picture.
Width | The width of the picture.

Explicit Interface Implementations

Name | Description
IPicture..::.Height |
IPicture..::.Location |
IPicture..::.Width |

See Also

Picture Class
Mincom.LinkOne.Dom.Layouts Namespace


Picture Constructor

[image] [image]

LinkOne WebView API
Picture Constructor
Picture Class See Also Send Feedback

Overload List

Name | Description
Picture()()() | Initializes a new instance of the Picture class.
Picture(ICellContents, Dimension, Dimension) | Initializes a new instance of the Picture class.

See Also

Picture Class
Picture Members
Mincom.LinkOne.Dom.Layouts Namespace


Picture Constructor

[image]

LinkOne WebView API
Picture Constructor
Picture Class See Also Send Feedback
Initializes a new instance of the Picture class.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Picture()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Picture()

See Also

Picture Class
Picture Overload
Mincom.LinkOne.Dom.Layouts Namespace


Picture Constructor (ICellContents, Dimension, Dimension)

[image]

LinkOne WebView API
Picture Constructor (ICellContents, Dimension, Dimension)
Picture Class See Also Send Feedback
Initializes a new instance of the Picture class.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Picture(
    ICellContents location,
    Dimension width,
    Dimension height
)
Visual Basic (Declaration)
Public Sub New ( _
    location As ICellContents, _
    width As Dimension, _
    height As Dimension _
)
Visual C++
public:
Picture(
    ICellContents^ location,
    Dimension^ width,
    Dimension^ height
)

Parameters

location
Type: Mincom.LinkOne.Dom.Layouts..::.ICellContents
The location of the picture.
width
Type: Mincom.LinkOne.Dom.Layouts..::.Dimension
The width of the picture.
height
Type: Mincom.LinkOne.Dom.Layouts..::.Dimension
The height of the picture.

See Also

Picture Class
Picture Overload
Mincom.LinkOne.Dom.Layouts Namespace


Picture Methods

[image] [image]

LinkOne WebView API
Picture Methods
Picture Class See Also Send Feedback

The Picture type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Picture Class
Mincom.LinkOne.Dom.Layouts Namespace


Picture Properties

[image] [image]

LinkOne WebView API
Picture Properties
Picture Class See Also Send Feedback

The Picture type exposes the following members.

Properties

Name | Description
Height | The height of the picture.
Location | The name of the picture.
Width | The width of the picture.

Explicit Interface Implementations

Name | Description
IPicture..::.Height |
IPicture..::.Location |
IPicture..::.Width |

See Also

Picture Class
Mincom.LinkOne.Dom.Layouts Namespace


Height Property

[image]

LinkOne WebView API
Picture..::.Height Property
Picture Class See Also Send Feedback
The height of the picture.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Dimension Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Dimension
Visual C++
public:
property Dimension^ Height {
    Dimension^ get ();
    void set (Dimension^ value);
}

Field Value

The picture height.

See Also

Picture Class
Mincom.LinkOne.Dom.Layouts Namespace


IPicture.Height Property

[image]

LinkOne WebView API
Picture..::.IPicture..::.Height Property
Picture Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension IPicture.Height { get; set; }
Visual Basic (Declaration)
Private Property Height As IDimension Implements IPicture.Height
Visual C++
private:
virtual property IDimension^ Height {
    IDimension^ get () sealed = IPicture::Height::get;
    void set (IDimension^ value) sealed = IPicture::Height::set;
}

Implements

IPicture..::.Height

See Also

Picture Class
Mincom.LinkOne.Dom.Layouts Namespace


IPicture.Location Property

[image]

LinkOne WebView API
Picture..::.IPicture..::.Location Property
Picture Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ICellContents IPicture.Location { get; set; }
Visual Basic (Declaration)
Private Property Location As ICellContents
    Implements IPicture.Location
Visual C++
private:
virtual property ICellContents^ Location {
    ICellContents^ get () sealed = IPicture::Location::get;
    void set (ICellContents^ value) sealed = IPicture::Location::set;
}

Implements

IPicture..::.Location

See Also

Picture Class
Mincom.LinkOne.Dom.Layouts Namespace


IPicture.Width Property

[image]

LinkOne WebView API
Picture..::.IPicture..::.Width Property
Picture Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension IPicture.Width { get; set; }
Visual Basic (Declaration)
Private Property Width As IDimension Implements IPicture.Width
Visual C++
private:
virtual property IDimension^ Width {
    IDimension^ get () sealed = IPicture::Width::get;
    void set (IDimension^ value) sealed = IPicture::Width::set;
}

Implements

IPicture..::.Width

See Also

Picture Class
Mincom.LinkOne.Dom.Layouts Namespace


Location Property

[image]

LinkOne WebView API
Picture..::.Location Property
Picture Class See Also Send Feedback
The name of the picture.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ICellContents Location { get; set; }
Visual Basic (Declaration)
Public Property Location As ICellContents
Visual C++
public:
property ICellContents^ Location {
    ICellContents^ get ();
    void set (ICellContents^ value);
}

Field Value

The picture name.

See Also

Picture Class
Mincom.LinkOne.Dom.Layouts Namespace


Width Property

[image]

LinkOne WebView API
Picture..::.Width Property
Picture Class See Also Send Feedback
The width of the picture.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Dimension Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Dimension
Visual C++
public:
property Dimension^ Width {
    Dimension^ get ();
    void set (Dimension^ value);
}

Field Value

The the picture width.

See Also

Picture Class
Mincom.LinkOne.Dom.Layouts Namespace


PictureField Class

[image]

LinkOne WebView API
PictureField Class
Members See Also Send Feedback
Represents a picture field in a layout cell.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public class PictureField : IPictureField,
    ICellContents
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class PictureField _
    Implements IPictureField, ICellContents
Visual C++
[SerializableAttribute]
public ref class PictureField : IPictureField,
    ICellContents

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Layouts..::.PictureField

See Also

PictureField Members
Mincom.LinkOne.Dom.Layouts Namespace


PictureField Members

[image] [image]

LinkOne WebView API
PictureField Members
PictureField Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The PictureField type exposes the following members.

Constructors

Name | Description
PictureField | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Name | The name of the picture field.

Explicit Interface Implementations

Name | Description
IPictureField..::.Name |

See Also

PictureField Class
Mincom.LinkOne.Dom.Layouts Namespace


PictureField Constructor

[image] [image]

LinkOne WebView API
PictureField Constructor
PictureField Class See Also Send Feedback

Overload List

Name | Description
PictureField()()() | Initializes a new instance of the PictureField class.
PictureField(String) | Initializes a new instance of the PictureField class.

See Also

PictureField Class
PictureField Members
Mincom.LinkOne.Dom.Layouts Namespace


PictureField Constructor

[image]

LinkOne WebView API
PictureField Constructor
PictureField Class See Also Send Feedback
Initializes a new instance of the PictureField class.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PictureField()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PictureField()

See Also

PictureField Class
PictureField Overload
Mincom.LinkOne.Dom.Layouts Namespace


PictureField Constructor (String)

[image]

LinkOne WebView API
PictureField Constructor (String)
PictureField Class See Also Send Feedback
Initializes a new instance of the PictureField class.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PictureField(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)
Visual C++
public:
PictureField(
    String^ name
)

Parameters

name
Type: System..::.String
The name fo the name field.

See Also

PictureField Class
PictureField Overload
Mincom.LinkOne.Dom.Layouts Namespace


PictureField Methods

[image] [image]

LinkOne WebView API
PictureField Methods
PictureField Class See Also Send Feedback

The PictureField type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PictureField Class
Mincom.LinkOne.Dom.Layouts Namespace


PictureField Properties

[image] [image]

LinkOne WebView API
PictureField Properties
PictureField Class See Also Send Feedback

The PictureField type exposes the following members.

Properties

Name | Description
Name | The name of the picture field.

Explicit Interface Implementations

Name | Description
IPictureField..::.Name |

See Also

PictureField Class
Mincom.LinkOne.Dom.Layouts Namespace


IPictureField.Name Property

[image]

LinkOne WebView API
PictureField..::.IPictureField..::.Name Property
PictureField Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string IPictureField.Name { get; set; }
Visual Basic (Declaration)
Private Property Name As String Implements IPictureField.Name
Visual C++
private:
virtual property String^ Name {
    String^ get () sealed = IPictureField::Name::get;
    void set (String^ value) sealed = IPictureField::Name::set;
}

Implements

IPictureField..::.Name

See Also

PictureField Class
Mincom.LinkOne.Dom.Layouts Namespace


Name Property

[image]

LinkOne WebView API
PictureField..::.Name Property
PictureField Class See Also Send Feedback
The name of the picture field.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The picture field name.

See Also

PictureField Class
Mincom.LinkOne.Dom.Layouts Namespace


Pitch Enumeration

[image]

LinkOne WebView API
Pitch Enumeration
See Also Send Feedback
Values for specifying whether cell text is fixed or variable pitch.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum Pitch
Visual Basic (Declaration)
Public Enumeration Pitch
Visual C++
public enum class Pitch

Members

Member name | Description
NotSpecified | No pitch was specified.
Fixed | All characters have the same width.
Variable | Characters have variable widths.

See Also

Mincom.LinkOne.Dom.Layouts Namespace


Preferred Class

[image]

LinkOne WebView API
Preferred Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public sealed class Preferred : IPreferred
Visual Basic (Declaration)
Public NotInheritable Class Preferred _
    Implements IPreferred
Visual C++
public ref class Preferred sealed : IPreferred

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Layouts..::.Preferred

See Also

Preferred Members
Mincom.LinkOne.Dom.Layouts Namespace


Preferred Members

[image] [image]

LinkOne WebView API
Preferred Members
Preferred Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The Preferred type exposes the following members.

Constructors

Name | Description
Preferred | Initializes a new instance of the Preferred class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
PrintLayout |
ScreenLayout |

Properties

Name | Description
BookCode |
Key |
PublisherCode |
Type |

Explicit Interface Implementations

Name | Description
IPreferred..::.BookCode |
IPreferred..::.Key |
IPreferred..::.PublisherCode |
IPreferred..::.Type |

See Also

Preferred Class
Mincom.LinkOne.Dom.Layouts Namespace


Preferred Constructor

[image]

LinkOne WebView API
Preferred Constructor
Preferred Class See Also Send Feedback
Initializes a new instance of the Preferred class

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Preferred()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Preferred()

See Also

Preferred Class
Mincom.LinkOne.Dom.Layouts Namespace


Preferred Fields

[image] [image]

LinkOne WebView API
Preferred Fields
Preferred Class See Also Send Feedback

The Preferred type exposes the following members.

Fields

Name | Description
PrintLayout |
ScreenLayout |

See Also

Preferred Class
Mincom.LinkOne.Dom.Layouts Namespace


PrintLayout Field

[image]

LinkOne WebView API
Preferred..::.PrintLayout Field
Preferred Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string PrintLayout
Visual Basic (Declaration)
Public Const PrintLayout As String
Visual C++
public:
literal String^ PrintLayout

See Also

Preferred Class
Mincom.LinkOne.Dom.Layouts Namespace


ScreenLayout Field

[image]

LinkOne WebView API
Preferred..::.ScreenLayout Field
Preferred Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string ScreenLayout
Visual Basic (Declaration)
Public Const ScreenLayout As String
Visual C++
public:
literal String^ ScreenLayout

See Also

Preferred Class
Mincom.LinkOne.Dom.Layouts Namespace


Preferred Methods

[image] [image]

LinkOne WebView API
Preferred Methods
Preferred Class See Also Send Feedback

The Preferred type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Preferred Class
Mincom.LinkOne.Dom.Layouts Namespace


Preferred Properties

[image] [image]

LinkOne WebView API
Preferred Properties
Preferred Class See Also Send Feedback

The Preferred type exposes the following members.

Properties

Name | Description
BookCode |
Key |
PublisherCode |
Type |

Explicit Interface Implementations

Name | Description
IPreferred..::.BookCode |
IPreferred..::.Key |
IPreferred..::.PublisherCode |
IPreferred..::.Type |

See Also

Preferred Class
Mincom.LinkOne.Dom.Layouts Namespace


BookCode Property

[image]

LinkOne WebView API
Preferred..::.BookCode Property
Preferred Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string BookCode { get; set; }
Visual Basic (Declaration)
Public Property BookCode As String
Visual C++
public:
property String^ BookCode {
    String^ get ();
    void set (String^ value);
}

See Also

Preferred Class
Mincom.LinkOne.Dom.Layouts Namespace


IPreferred.BookCode Property

[image]

LinkOne WebView API
Preferred..::.IPreferred..::.BookCode Property
Preferred Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string IPreferred.BookCode { get; set; }
Visual Basic (Declaration)
Private Property BookCode As String
    Implements IPreferred.BookCode
Visual C++
private:
virtual property String^ BookCode {
    String^ get () sealed = IPreferred::BookCode::get;
    void set (String^ value) sealed = IPreferred::BookCode::set;
}

Implements

IPreferred..::.BookCode

See Also

Preferred Class
Mincom.LinkOne.Dom.Layouts Namespace


IPreferred.Key Property

[image]

LinkOne WebView API
Preferred..::.IPreferred..::.Key Property
Preferred Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string IPreferred.Key { get; set; }
Visual Basic (Declaration)
Private Property Key As String Implements IPreferred.Key
Visual C++
private:
virtual property String^ Key {
    String^ get () sealed = IPreferred::Key::get;
    void set (String^ value) sealed = IPreferred::Key::set;
}

Implements

IPreferred..::.Key

See Also

Preferred Class
Mincom.LinkOne.Dom.Layouts Namespace


IPreferred.PublisherCode Property

[image]

LinkOne WebView API
Preferred..::.IPreferred..::.PublisherCode Property
Preferred Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string IPreferred.PublisherCode { get; set; }
Visual Basic (Declaration)
Private Property PublisherCode As String
    Implements IPreferred.PublisherCode
Visual C++
private:
virtual property String^ PublisherCode {
    String^ get () sealed = IPreferred::PublisherCode::get;
    void set (String^ value) sealed = IPreferred::PublisherCode::set;
}

Implements

IPreferred..::.PublisherCode

See Also

Preferred Class
Mincom.LinkOne.Dom.Layouts Namespace


IPreferred.Type Property

[image]

LinkOne WebView API
Preferred..::.IPreferred..::.Type Property
Preferred Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string IPreferred.Type { get; set; }
Visual Basic (Declaration)
Private Property Type As String Implements IPreferred.Type
Visual C++
private:
virtual property String^ Type {
    String^ get () sealed = IPreferred::Type::get;
    void set (String^ value) sealed = IPreferred::Type::set;
}

Implements

IPreferred..::.Type

See Also

Preferred Class
Mincom.LinkOne.Dom.Layouts Namespace


Key Property

[image]

LinkOne WebView API
Preferred..::.Key Property
Preferred Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Key { get; set; }
Visual Basic (Declaration)
Public Property Key As String
Visual C++
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}

See Also

Preferred Class
Mincom.LinkOne.Dom.Layouts Namespace


PublisherCode Property

[image]

LinkOne WebView API
Preferred..::.PublisherCode Property
Preferred Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PublisherCode { get; set; }
Visual Basic (Declaration)
Public Property PublisherCode As String
Visual C++
public:
property String^ PublisherCode {
    String^ get ();
    void set (String^ value);
}

See Also

Preferred Class
Mincom.LinkOne.Dom.Layouts Namespace


Type Property

[image]

LinkOne WebView API
Preferred..::.Type Property
Preferred Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Type { get; set; }
Visual Basic (Declaration)
Public Property Type As String
Visual C++
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}

See Also

Preferred Class
Mincom.LinkOne.Dom.Layouts Namespace


PreferredCollection Class

[image]

LinkOne WebView API
PreferredCollection Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class PreferredCollection : ICollection<Preferred>,
    IEnumerable<Preferred>, IPreferredCollection, ICollection<IPreferred>,
    IEnumerable<IPreferred>, IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class PreferredCollection _
    Implements ICollection(Of Preferred), IEnumerable(Of Preferred),  _
    IPreferredCollection, ICollection(Of IPreferred), IEnumerable(Of IPreferred),  _
    IEnumerable
Visual C++
[SerializableAttribute]
public ref class PreferredCollection sealed : ICollection<Preferred^>,
    IEnumerable<Preferred^>, IPreferredCollection, ICollection<IPreferred^>,
    IEnumerable<IPreferred^>, IEnumerable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Layouts..::.PreferredCollection

See Also

PreferredCollection Members
Mincom.LinkOne.Dom.Layouts Namespace


PreferredCollection Members

[image] [image]

LinkOne WebView API
PreferredCollection Members
PreferredCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The PreferredCollection type exposes the following members.

Constructors

Name | Description
PreferredCollection | Initializes a new instance of the PreferredCollection class

Methods

Name | Description
Add |
AddRange |
Clear |
Contains |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove |
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count |
IsReadOnly |
Item |

Explicit Interface Implementations

Name | Description
ICollection<(Of <(IPreferred>)>)..::.Add |
ICollection<(Of <(IPreferred>)>)..::.Contains |
CopyTo | Overloaded.
IEnumerable<(Of <(IPreferred>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator |
ICollection<(Of <(IPreferred>)>)..::.Remove |

See Also

PreferredCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


PreferredCollection Constructor

[image]

LinkOne WebView API
PreferredCollection Constructor
PreferredCollection Class See Also Send Feedback
Initializes a new instance of the PreferredCollection class

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PreferredCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PreferredCollection()

See Also

PreferredCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


PreferredCollection Methods

[image] [image]

LinkOne WebView API
PreferredCollection Methods
PreferredCollection Class See Also Send Feedback

The PreferredCollection type exposes the following members.

Methods

Name | Description
Add |
AddRange |
Clear |
Contains |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove |
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ICollection<(Of <(IPreferred>)>)..::.Add |
ICollection<(Of <(IPreferred>)>)..::.Contains |
CopyTo | Overloaded.
IEnumerable<(Of <(IPreferred>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator |
ICollection<(Of <(IPreferred>)>)..::.Remove |

See Also

PreferredCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


ICollection(IPreferred).Add Method

[image]

LinkOne WebView API
PreferredCollection..::.ICollection<(Of <(IPreferred>)>)..::.Add Method
PreferredCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<IPreferred>.Add(
    IPreferred item
)
Visual Basic (Declaration)
Private Sub Add ( _
    item As IPreferred _
) Implements ICollection(Of IPreferred).Add
Visual C++
private:
virtual void Add(
    IPreferred^ item
) sealed = ICollection<IPreferred^>::Add

Parameters

item
Type: Mincom.LinkOne.Dom.Layouts..::.IPreferred

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

PreferredCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


ICollection(IPreferred).Contains Method

[image]

LinkOne WebView API
PreferredCollection..::.ICollection<(Of <(IPreferred>)>)..::.Contains Method
PreferredCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<IPreferred>.Contains(
    IPreferred item
)
Visual Basic (Declaration)
Private Function Contains ( _
    item As IPreferred _
) As Boolean Implements ICollection(Of IPreferred).Contains
Visual C++
private:
virtual bool Contains(
    IPreferred^ item
) sealed = ICollection<IPreferred^>::Contains

Parameters

item
Type: Mincom.LinkOne.Dom.Layouts..::.IPreferred

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

PreferredCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


IEnumerable(IPreferred).GetEnumerator Method

[image]

LinkOne WebView API
PreferredCollection..::.IEnumerable<(Of <(IPreferred>)>)..::.GetEnumerator Method
PreferredCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator<IPreferred> IEnumerable<IPreferred>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of IPreferred)
    Implements IEnumerable(Of IPreferred).GetEnumerator
Visual C++
private:
virtual IEnumerator<IPreferred^>^ GetEnumerator() sealed = IEnumerable<IPreferred^>::GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

PreferredCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
PreferredCollection..::.IEnumerable..::.GetEnumerator Method
PreferredCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Implements

IEnumerable..::.GetEnumerator()()()

See Also

PreferredCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


ICollection(IPreferred).Remove Method

[image]

LinkOne WebView API
PreferredCollection..::.ICollection<(Of <(IPreferred>)>)..::.Remove Method
PreferredCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<IPreferred>.Remove(
    IPreferred item
)
Visual Basic (Declaration)
Private Function Remove ( _
    item As IPreferred _
) As Boolean Implements ICollection(Of IPreferred).Remove
Visual C++
private:
virtual bool Remove(
    IPreferred^ item
) sealed = ICollection<IPreferred^>::Remove

Parameters

item
Type: Mincom.LinkOne.Dom.Layouts..::.IPreferred

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

PreferredCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


Add Method

[image]

LinkOne WebView API
PreferredCollection..::.Add Method
PreferredCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Add(
    Preferred item
)
Visual Basic (Declaration)
Public Sub Add ( _
    item As Preferred _
)
Visual C++
public:
virtual void Add(
    Preferred^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Dom.Layouts..::.Preferred

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

PreferredCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


AddRange Method

[image]

LinkOne WebView API
PreferredCollection..::.AddRange Method
PreferredCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void AddRange(
    IEnumerable<Preferred> preferredLayouts
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    preferredLayouts As IEnumerable(Of Preferred) _
)
Visual C++
public:
void AddRange(
    IEnumerable<Preferred^>^ preferredLayouts
)

Parameters

preferredLayouts
Type: System.Collections.Generic..::.IEnumerable<(Of <( Preferred >)>)

See Also

PreferredCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


Clear Method

[image]

LinkOne WebView API
PreferredCollection..::.Clear Method
PreferredCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
virtual void Clear() sealed

Implements

ICollection<(Of <(T>)>)..::.Clear()()()
ICollection<(Of <(T>)>)..::.Clear()()()

See Also

PreferredCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


Contains Method

[image]

LinkOne WebView API
PreferredCollection..::.Contains Method
PreferredCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    Preferred item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As Preferred _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Preferred^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Dom.Layouts..::.Preferred

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

PreferredCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


CopyTo Method

[image] [image]

LinkOne WebView API
PreferredCollection..::.CopyTo Method
PreferredCollection Class See Also Send Feedback

Overload List

Name | Description
ICollection<(Of <(IPreferred>)>)..::.CopyTo(array<IPreferred>[]()[], Int32) |
ICollection<(Of <(Preferred>)>)..::.CopyTo(array<Preferred>[]()[], Int32) |

See Also

PreferredCollection Class
PreferredCollection Members
Mincom.LinkOne.Dom.Layouts Namespace


ICollection(IPreferred).CopyTo Method (IPreferred[], Int32)

[image]

LinkOne WebView API
PreferredCollection..::.ICollection<(Of <(IPreferred>)>)..::.CopyTo Method (array<IPreferred>[]()[], Int32)
PreferredCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<IPreferred>.CopyTo(
    IPreferred[] array,
    int arrayIndex
)
Visual Basic (Declaration)
Private Sub CopyTo ( _
    array As IPreferred(), _
    arrayIndex As Integer _
) Implements ICollection(Of IPreferred).CopyTo
Visual C++
private:
virtual void CopyTo(
    array<IPreferred^>^ array,
    int arrayIndex
) sealed = ICollection<IPreferred^>::CopyTo

Parameters

array
Type: array< Mincom.LinkOne.Dom.Layouts..::.IPreferred >[]()[]
arrayIndex
Type: System..::.Int32

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

PreferredCollection Class
PreferredCollection Overload
Mincom.LinkOne.Dom.Layouts Namespace


ICollection(Preferred).CopyTo Method (Preferred[], Int32)

[image]

LinkOne WebView API
PreferredCollection..::.ICollection<(Of <(Preferred>)>)..::.CopyTo Method (array<Preferred>[]()[], Int32)
PreferredCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<Preferred>.CopyTo(
    Preferred[] array,
    int arrayIndex
)
Visual Basic (Declaration)
Private Sub CopyTo ( _
    array As Preferred(), _
    arrayIndex As Integer _
) Implements ICollection(Of Preferred).CopyTo
Visual C++
private:
virtual void CopyTo(
    array<Preferred^>^ array,
    int arrayIndex
) sealed = ICollection<Preferred^>::CopyTo

Parameters

array
Type: array< Mincom.LinkOne.Dom.Layouts..::.Preferred >[]()[]
arrayIndex
Type: System..::.Int32

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

PreferredCollection Class
PreferredCollection Overload
Mincom.LinkOne.Dom.Layouts Namespace


GetEnumerator Method

[image]

LinkOne WebView API
PreferredCollection..::.GetEnumerator Method
PreferredCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IEnumerator<Preferred> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of Preferred)
Visual C++
public:
virtual IEnumerator<Preferred^>^ GetEnumerator() sealed

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

PreferredCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


IndexOf Method

[image]

LinkOne WebView API
PreferredCollection..::.IndexOf Method
PreferredCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int IndexOf(
    Preferred preferredLayout
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    preferredLayout As Preferred _
) As Integer
Visual C++
public:
int IndexOf(
    Preferred^ preferredLayout
)

Parameters

preferredLayout
Type: Mincom.LinkOne.Dom.Layouts..::.Preferred

See Also

PreferredCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


Remove Method

[image]

LinkOne WebView API
PreferredCollection..::.Remove Method
PreferredCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Remove(
    Preferred item
)
Visual Basic (Declaration)
Public Function Remove ( _
    item As Preferred _
) As Boolean
Visual C++
public:
virtual bool Remove(
    Preferred^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Dom.Layouts..::.Preferred

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

PreferredCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


PreferredCollection Properties

[image] [image]

LinkOne WebView API
PreferredCollection Properties
PreferredCollection Class See Also Send Feedback

The PreferredCollection type exposes the following members.

Properties

Name | Description
Count |
IsReadOnly |
Item |

See Also

PreferredCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


Count Property

[image]

LinkOne WebView API
PreferredCollection..::.Count Property
PreferredCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollection<(Of <(T>)>)..::.Count
ICollection<(Of <(T>)>)..::.Count

See Also

PreferredCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


IsReadOnly Property

[image]

LinkOne WebView API
PreferredCollection..::.IsReadOnly Property
PreferredCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly
ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

PreferredCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


Item Property

[image]

LinkOne WebView API
PreferredCollection..::.Item Property
PreferredCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Preferred this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Preferred
Visual C++
public:
property Preferred^ default[int index] {
    Preferred^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

PreferredCollection Class
Mincom.LinkOne.Dom.Layouts Namespace


Row Class

[image]

LinkOne WebView API
Row Class
Members See Also Send Feedback
Represents a row in a layout table. Layout table rows consist of cells.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public class Row : IRow
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class Row _
    Implements IRow
Visual C++
[SerializableAttribute]
public ref class Row : IRow

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Layouts..::.Row

See Also

Row Members
Mincom.LinkOne.Dom.Layouts Namespace


Row Members

[image] [image]

LinkOne WebView API
Row Members
Row Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The Row type exposes the following members.

Constructors

Name | Description
Row | Initializes a new instance of the Row class

Methods

Name | Description
AddCell | Adds a cell to the row.
CreateCell | Creates a new cell object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetCell | Retrieves a cell given an integral index.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
InsertCell | Adds a cell to the row.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RemoveCell | Removes a cell from the row.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Border | Gets or sets the Border property of the RowAttributes.
Cells | The collection of cells in this row.
NumberOfCells | The number of cells in this row.
RowCollapse | Gets or sets the RowCollapse property of the RowAttributes.
RowGap | Gets or sets the RowGap property of the RowAttributes.
Rules | Gets or sets the Rules of the RowAttributes.

Explicit Interface Implementations

Name | Description
IRow..::.Border |
IRow..::.Cells |
IRow..::.RowGap |
IRow..::.Rules |

See Also

Row Class
Mincom.LinkOne.Dom.Layouts Namespace


Row Constructor

[image]

LinkOne WebView API
Row Constructor
Row Class See Also Send Feedback
Initializes a new instance of the Row class

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Row()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Row()

See Also

Row Class
Mincom.LinkOne.Dom.Layouts Namespace


Row Methods

[image] [image]

LinkOne WebView API
Row Methods
Row Class See Also Send Feedback

The Row type exposes the following members.

Methods

Name | Description
AddCell | Adds a cell to the row.
CreateCell | Creates a new cell object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetCell | Retrieves a cell given an integral index.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
InsertCell | Adds a cell to the row.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RemoveCell | Removes a cell from the row.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Row Class
Mincom.LinkOne.Dom.Layouts Namespace


AddCell Method

[image]

LinkOne WebView API
Row..::.AddCell Method
Row Class See Also Send Feedback
Adds a cell to the row.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void AddCell(
    Cell cell
)
Visual Basic (Declaration)
Public Sub AddCell ( _
    cell As Cell _
)
Visual C++
public:
void AddCell(
    Cell^ cell
)

Parameters

cell
Type: Mincom.LinkOne.Dom.Layouts..::.Cell
The cell to be added.

See Also

Row Class
Mincom.LinkOne.Dom.Layouts Namespace


CreateCell Method

[image]

LinkOne WebView API
Row..::.CreateCell Method
Row Class See Also Send Feedback
Creates a new cell object.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static Cell CreateCell()
Visual Basic (Declaration)
Public Shared Function CreateCell As Cell
Visual C++
public:
static Cell^ CreateCell()

Return Value

The newly created cell object (not added to the row).

See Also

Row Class
Mincom.LinkOne.Dom.Layouts Namespace


GetCell Method

[image]

LinkOne WebView API
Row..::.GetCell Method
Row Class See Also Send Feedback
Retrieves a cell given an integral index.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Cell GetCell(
    int cell
)
Visual Basic (Declaration)
Public Function GetCell ( _
    cell As Integer _
) As Cell
Visual C++
public:
Cell^ GetCell(
    int cell
)

Parameters

cell
Type: System..::.Int32
The 0-based index of the cell to retrieve.

Return Value

The requested cell.

See Also

Row Class
Mincom.LinkOne.Dom.Layouts Namespace


InsertCell Method

[image]

LinkOne WebView API
Row..::.InsertCell Method
Row Class See Also Send Feedback
Adds a cell to the row.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void InsertCell(
    int index,
    Cell cell
)
Visual Basic (Declaration)
Public Sub InsertCell ( _
    index As Integer, _
    cell As Cell _
)
Visual C++
public:
void InsertCell(
    int index,
    Cell^ cell
)

Parameters

index
Type: System..::.Int32
The zero-based index position to insert at
cell
Type: Mincom.LinkOne.Dom.Layouts..::.Cell
The cell to be added.

See Also

Row Class
Mincom.LinkOne.Dom.Layouts Namespace


RemoveCell Method

[image]

LinkOne WebView API
Row..::.RemoveCell Method
Row Class See Also Send Feedback
Removes a cell from the row.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void RemoveCell(
    Cell cell
)
Visual Basic (Declaration)
Public Sub RemoveCell ( _
    cell As Cell _
)
Visual C++
public:
void RemoveCell(
    Cell^ cell
)

Parameters

cell
Type: Mincom.LinkOne.Dom.Layouts..::.Cell
The cell to be removed.

See Also

Row Class
Mincom.LinkOne.Dom.Layouts Namespace


Row Properties

[image] [image]

LinkOne WebView API
Row Properties
Row Class See Also Send Feedback

The Row type exposes the following members.

Properties

Name | Description
Border | Gets or sets the Border property of the RowAttributes.
Cells | The collection of cells in this row.
NumberOfCells | The number of cells in this row.
RowCollapse | Gets or sets the RowCollapse property of the RowAttributes.
RowGap | Gets or sets the RowGap property of the RowAttributes.
Rules | Gets or sets the Rules of the RowAttributes.

Explicit Interface Implementations

Name | Description
IRow..::.Border |
IRow..::.Cells |
IRow..::.RowGap |
IRow..::.Rules |

See Also

Row Class
Mincom.LinkOne.Dom.Layouts Namespace


Border Property

[image]

LinkOne WebView API
Row..::.Border Property
Row Class See Also Send Feedback
Gets or sets the Border property of the RowAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BorderAttributes Border { get; }
Visual Basic (Declaration)
Public ReadOnly Property Border As BorderAttributes
Visual C++
public:
property BorderAttributes^ Border {
    BorderAttributes^ get ();
}

See Also

Row Class
Mincom.LinkOne.Dom.Layouts Namespace


Cells Property

[image]

LinkOne WebView API
Row..::.Cells Property
Row Class See Also Send Feedback
The collection of cells in this row.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IList<Cell> Cells { get; }
Visual Basic (Declaration)
Public ReadOnly Property Cells As IList(Of Cell)
Visual C++
public:
property IList<Cell^>^ Cells {
    IList<Cell^>^ get ();
}

Field Value

The collection of cells in the row.

See Also

Row Class
Mincom.LinkOne.Dom.Layouts Namespace


IRow.Border Property

[image]

LinkOne WebView API
Row..::.IRow..::.Border Property
Row Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IBorderAttributes IRow.Border { get; }
Visual Basic (Declaration)
Private ReadOnly Property Border As IBorderAttributes
    Implements IRow.Border
Visual C++
private:
virtual property IBorderAttributes^ Border {
    IBorderAttributes^ get () sealed = IRow::Border::get;
}

Implements

IRow..::.Border

See Also

Row Class
Mincom.LinkOne.Dom.Layouts Namespace


IRow.Cells Property

[image]

LinkOne WebView API
Row..::.IRow..::.Cells Property
Row Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ICollection<ICell> IRow.Cells { get; }
Visual Basic (Declaration)
Private ReadOnly Property Cells As ICollection(Of ICell)
    Implements IRow.Cells
Visual C++
private:
virtual property ICollection<ICell^>^ Cells {
    ICollection<ICell^>^ get () sealed = IRow::Cells::get;
}

Implements

IRow..::.Cells

See Also

Row Class
Mincom.LinkOne.Dom.Layouts Namespace


IRow.RowGap Property

[image]

LinkOne WebView API
Row..::.IRow..::.RowGap Property
Row Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension IRow.RowGap { get; set; }
Visual Basic (Declaration)
Private Property RowGap As IDimension Implements IRow.RowGap
Visual C++
private:
virtual property IDimension^ RowGap {
    IDimension^ get () sealed = IRow::RowGap::get;
    void set (IDimension^ value) sealed = IRow::RowGap::set;
}

Implements

IRow..::.RowGap

See Also

Row Class
Mincom.LinkOne.Dom.Layouts Namespace


IRow.Rules Property

[image]

LinkOne WebView API
Row..::.IRow..::.Rules Property
Row Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IRuleAttributes IRow.Rules { get; }
Visual Basic (Declaration)
Private ReadOnly Property Rules As IRuleAttributes
    Implements IRow.Rules
Visual C++
private:
virtual property IRuleAttributes^ Rules {
    IRuleAttributes^ get () sealed = IRow::Rules::get;
}

Implements

IRow..::.Rules

See Also

Row Class
Mincom.LinkOne.Dom.Layouts Namespace


NumberOfCells Property

[image]

LinkOne WebView API
Row..::.NumberOfCells Property
Row Class See Also Send Feedback
The number of cells in this row.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int NumberOfCells { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumberOfCells As Integer
Visual C++
public:
property int NumberOfCells {
    int get ();
}

Field Value

The number of cell in the row.

See Also

Row Class
Mincom.LinkOne.Dom.Layouts Namespace


RowCollapse Property

[image]

LinkOne WebView API
Row..::.RowCollapse Property
Row Class See Also Send Feedback
Gets or sets the RowCollapse property of the RowAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool RowCollapse { get; set; }
Visual Basic (Declaration)
Public Property RowCollapse As Boolean
Visual C++
public:
virtual property bool RowCollapse {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IRow..::.RowCollapse

See Also

Row Class
Mincom.LinkOne.Dom.Layouts Namespace


RowGap Property

[image]

LinkOne WebView API
Row..::.RowGap Property
Row Class See Also Send Feedback
Gets or sets the RowGap property of the RowAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Dimension RowGap { get; set; }
Visual Basic (Declaration)
Public Property RowGap As Dimension
Visual C++
public:
property Dimension^ RowGap {
    Dimension^ get ();
    void set (Dimension^ value);
}

See Also

Row Class
Mincom.LinkOne.Dom.Layouts Namespace


Rules Property

[image]

LinkOne WebView API
Row..::.Rules Property
Row Class See Also Send Feedback
Gets or sets the Rules of the RowAttributes.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public RuleAttributes Rules { get; }
Visual Basic (Declaration)
Public ReadOnly Property Rules As RuleAttributes
Visual C++
public:
property RuleAttributes^ Rules {
    RuleAttributes^ get ();
}

See Also

Row Class
Mincom.LinkOne.Dom.Layouts Namespace


RuleAttributes Class

[image]

LinkOne WebView API
RuleAttributes Class
Members See Also Send Feedback
Attributes that specify which rules are to be drawn.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public class RuleAttributes : IRuleAttributes
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class RuleAttributes _
    Implements IRuleAttributes
Visual C++
[SerializableAttribute]
public ref class RuleAttributes : IRuleAttributes

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Layouts..::.RuleAttributes

See Also

RuleAttributes Members
Mincom.LinkOne.Dom.Layouts Namespace


RuleAttributes Members

[image] [image]

LinkOne WebView API
RuleAttributes Members
RuleAttributes Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The RuleAttributes type exposes the following members.

Constructors

Name | Description
RuleAttributes | Initializes a new instance of the RuleAttributes class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Bottom | Gets or sets the Bottom rule dimension.
Left | Gets or sets the Left rule dimension.
Right | Gets or sets the Right rule dimension.
Top | Gets or sets the Top rule dimension.

Explicit Interface Implementations

Name | Description
IRuleAttributes..::.Bottom |
IRuleAttributes..::.Left |
IRuleAttributes..::.Right |
IRuleAttributes..::.Top |

See Also

RuleAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


RuleAttributes Constructor

[image]

LinkOne WebView API
RuleAttributes Constructor
RuleAttributes Class See Also Send Feedback
Initializes a new instance of the RuleAttributes class

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public RuleAttributes()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RuleAttributes()

See Also

RuleAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


RuleAttributes Methods

[image] [image]

LinkOne WebView API
RuleAttributes Methods
RuleAttributes Class See Also Send Feedback

The RuleAttributes type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RuleAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


RuleAttributes Properties

[image] [image]

LinkOne WebView API
RuleAttributes Properties
RuleAttributes Class See Also Send Feedback

The RuleAttributes type exposes the following members.

Properties

Name | Description
Bottom | Gets or sets the Bottom rule dimension.
Left | Gets or sets the Left rule dimension.
Right | Gets or sets the Right rule dimension.
Top | Gets or sets the Top rule dimension.

Explicit Interface Implementations

Name | Description
IRuleAttributes..::.Bottom |
IRuleAttributes..::.Left |
IRuleAttributes..::.Right |
IRuleAttributes..::.Top |

See Also

RuleAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


Bottom Property

[image]

LinkOne WebView API
RuleAttributes..::.Bottom Property
RuleAttributes Class See Also Send Feedback
Gets or sets the Bottom rule dimension.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Dimension Bottom { get; set; }
Visual Basic (Declaration)
Public Property Bottom As Dimension
Visual C++
public:
property Dimension^ Bottom {
    Dimension^ get ();
    void set (Dimension^ value);
}

See Also

RuleAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


IRuleAttributes.Bottom Property

[image]

LinkOne WebView API
RuleAttributes..::.IRuleAttributes..::.Bottom Property
RuleAttributes Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension IRuleAttributes.Bottom { get; set; }
Visual Basic (Declaration)
Private Property Bottom As IDimension Implements IRuleAttributes.Bottom
Visual C++
private:
virtual property IDimension^ Bottom {
    IDimension^ get () sealed = IRuleAttributes::Bottom::get;
    void set (IDimension^ value) sealed = IRuleAttributes::Bottom::set;
}

Implements

IRuleAttributes..::.Bottom

See Also

RuleAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


IRuleAttributes.Left Property

[image]

LinkOne WebView API
RuleAttributes..::.IRuleAttributes..::.Left Property
RuleAttributes Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension IRuleAttributes.Left { get; set; }
Visual Basic (Declaration)
Private Property Left As IDimension Implements IRuleAttributes.Left
Visual C++
private:
virtual property IDimension^ Left {
    IDimension^ get () sealed = IRuleAttributes::Left::get;
    void set (IDimension^ value) sealed = IRuleAttributes::Left::set;
}

Implements

IRuleAttributes..::.Left

See Also

RuleAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


IRuleAttributes.Right Property

[image]

LinkOne WebView API
RuleAttributes..::.IRuleAttributes..::.Right Property
RuleAttributes Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension IRuleAttributes.Right { get; set; }
Visual Basic (Declaration)
Private Property Right As IDimension Implements IRuleAttributes.Right
Visual C++
private:
virtual property IDimension^ Right {
    IDimension^ get () sealed = IRuleAttributes::Right::get;
    void set (IDimension^ value) sealed = IRuleAttributes::Right::set;
}

Implements

IRuleAttributes..::.Right

See Also

RuleAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


IRuleAttributes.Top Property

[image]

LinkOne WebView API
RuleAttributes..::.IRuleAttributes..::.Top Property
RuleAttributes Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDimension IRuleAttributes.Top { get; set; }
Visual Basic (Declaration)
Private Property Top As IDimension Implements IRuleAttributes.Top
Visual C++
private:
virtual property IDimension^ Top {
    IDimension^ get () sealed = IRuleAttributes::Top::get;
    void set (IDimension^ value) sealed = IRuleAttributes::Top::set;
}

Implements

IRuleAttributes..::.Top

See Also

RuleAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


Left Property

[image]

LinkOne WebView API
RuleAttributes..::.Left Property
RuleAttributes Class See Also Send Feedback
Gets or sets the Left rule dimension.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Dimension Left { get; set; }
Visual Basic (Declaration)
Public Property Left As Dimension
Visual C++
public:
property Dimension^ Left {
    Dimension^ get ();
    void set (Dimension^ value);
}

See Also

RuleAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


Right Property

[image]

LinkOne WebView API
RuleAttributes..::.Right Property
RuleAttributes Class See Also Send Feedback
Gets or sets the Right rule dimension.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Dimension Right { get; set; }
Visual Basic (Declaration)
Public Property Right As Dimension
Visual C++
public:
property Dimension^ Right {
    Dimension^ get ();
    void set (Dimension^ value);
}

See Also

RuleAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


Top Property

[image]

LinkOne WebView API
RuleAttributes..::.Top Property
RuleAttributes Class See Also Send Feedback
Gets or sets the Top rule dimension.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Dimension Top { get; set; }
Visual Basic (Declaration)
Public Property Top As Dimension
Visual C++
public:
property Dimension^ Top {
    Dimension^ get ();
    void set (Dimension^ value);
}

See Also

RuleAttributes Class
Mincom.LinkOne.Dom.Layouts Namespace


SheetFacing Enumeration

[image]

LinkOne WebView API
SheetFacing Enumeration
See Also Send Feedback
Represents the side of the sheet the layout is for.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum SheetFacing
Visual Basic (Declaration)
Public Enumeration SheetFacing
Visual C++
public enum class SheetFacing

Members

Member name | Description
None | The layout will not be printed but is for display on a screen.
Left | The layout will be printed on the left side of the sheet.
Right | The layout will be printed on the right side of the sheet.

See Also

Mincom.LinkOne.Dom.Layouts Namespace


Table Class

[image]

LinkOne WebView API
Table Class
Members See Also Send Feedback
Represents an embedded table in a layout cell.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public class Table : LayoutTable, ITable,
    ILayoutTable, ICellContents
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class Table _
    Inherits LayoutTable _
    Implements ITable, ILayoutTable, ICellContents
Visual C++
[SerializableAttribute]
public ref class Table : public LayoutTable,
    ITable, ILayoutTable, ICellContents

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Layouts..::.LayoutTable
Mincom.LinkOne.Dom.Layouts..::.Table

See Also

Table Members
Mincom.LinkOne.Dom.Layouts Namespace


Table Members

[image] [image]

LinkOne WebView API
Table Members
Table Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The Table type exposes the following members.

Constructors

Name | Description
Table | Initializes a new instance of the Table class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
FormatExpand | Gets or sets the FormatExpand property of the TableFormat. (Inherited from LayoutTable.)
Rows | The collection of rows in the table. (Inherited from LayoutTable.)

Explicit Interface Implementations

Name | Description
ILayoutTable..::.FormatExpand | (Inherited from LayoutTable.)
ILayoutTable..::.Rows | (Inherited from LayoutTable.)

See Also

Table Class
Mincom.LinkOne.Dom.Layouts Namespace


Table Constructor

[image]

LinkOne WebView API
Table Constructor
Table Class See Also Send Feedback
Initializes a new instance of the Table class

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Table()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Table()

See Also

Table Class
Mincom.LinkOne.Dom.Layouts Namespace


Table Methods

[image] [image]

LinkOne WebView API
Table Methods
Table Class See Also Send Feedback

The Table type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Table Class
Mincom.LinkOne.Dom.Layouts Namespace


Table Properties

[image] [image]

LinkOne WebView API
Table Properties
Table Class See Also Send Feedback

The Table type exposes the following members.

Properties

Name | Description
FormatExpand | Gets or sets the FormatExpand property of the TableFormat. (Inherited from LayoutTable.)
Rows | The collection of rows in the table. (Inherited from LayoutTable.)

Explicit Interface Implementations

Name | Description
ILayoutTable..::.FormatExpand | (Inherited from LayoutTable.)
ILayoutTable..::.Rows | (Inherited from LayoutTable.)

See Also

Table Class
Mincom.LinkOne.Dom.Layouts Namespace


TextFormat Class

[image]

LinkOne WebView API
TextFormat Class
Members See Also Send Feedback
Encapsulates the components of a format string.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public class TextFormat : ITextFormat
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class TextFormat _
    Implements ITextFormat
Visual C++
[SerializableAttribute]
public ref class TextFormat : ITextFormat

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Layouts..::.TextFormat

See Also

TextFormat Members
Mincom.LinkOne.Dom.Layouts Namespace


TextFormat Members

[image] [image]

LinkOne WebView API
TextFormat Members
TextFormat Class Constructors Methods Fields Properties See Also Send Feedback

The TextFormat type exposes the following members.

Constructors

Name | Description
TextFormat | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetFormattedValue | Formats the specified text.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Gets a string representation of the TextFormat. (Overrides Object..::.ToString()()().)

Fields

Name | Description
MaxPrecision | The maximum precision that can be specified for a format.
MinPrecision | The minimum precision that can be specified for a format.

Properties

Name | Description
FormatSpecifier | Gets the format specifier.
None | Predefined TextFormat that represents None formatting.
Precision | Gets the precision; or null if not applicable to the TextFormatSpecifier.

See Also

TextFormat Class
Mincom.LinkOne.Dom.Layouts Namespace


TextFormat Constructor

[image] [image]

LinkOne WebView API
TextFormat Constructor
TextFormat Class See Also Send Feedback

Overload List

Name | Description
TextFormat(TextFormatSpecifier) | Creates an instance of the TextFormat class with the specified format.
TextFormat(TextFormatSpecifier, Nullable<(Of <(Int32>)>)) | Creates an instance of the TextFormat class with the specified format and precision.

See Also

TextFormat Class
TextFormat Members
Mincom.LinkOne.Dom.Layouts Namespace


TextFormat Constructor (TextFormatSpecifier)

[image]

LinkOne WebView API
TextFormat Constructor (TextFormatSpecifier)
TextFormat Class See Also Send Feedback
Creates an instance of the TextFormat class with the specified format.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public TextFormat(
    TextFormatSpecifier formatSpecifier
)
Visual Basic (Declaration)
Public Sub New ( _
    formatSpecifier As TextFormatSpecifier _
)
Visual C++
public:
TextFormat(
    TextFormatSpecifier formatSpecifier
)

Parameters

formatSpecifier
Type: Mincom.LinkOne.Dom.Layouts..::.TextFormatSpecifier
The TextFormatSpecifier.

See Also

TextFormat Class
TextFormat Overload
Mincom.LinkOne.Dom.Layouts Namespace


TextFormat Constructor (TextFormatSpecifier, Nullable(Int32))

[image]

LinkOne WebView API
TextFormat Constructor (TextFormatSpecifier, Nullable<(Of <(Int32>)>))
TextFormat Class See Also Send Feedback
Creates an instance of the TextFormat class with the specified format and precision.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public TextFormat(
    TextFormatSpecifier formatSpecifier,
    Nullable<int> precision
)
Visual Basic (Declaration)
Public Sub New ( _
    formatSpecifier As TextFormatSpecifier, _
    precision As Nullable(Of Integer) _
)
Visual C++
public:
TextFormat(
    TextFormatSpecifier formatSpecifier,
    Nullable<int> precision
)

Parameters

formatSpecifier
Type: Mincom.LinkOne.Dom.Layouts..::.TextFormatSpecifier
The TextFormatSpecifier.
precision
Type: System..::.Nullable<(Of <(Int32>)>)
The level of precision; -1 if not applicable to the format.

See Also

TextFormat Class
TextFormat Overload
Mincom.LinkOne.Dom.Layouts Namespace


TextFormat Fields

[image] [image]

LinkOne WebView API
TextFormat Fields
TextFormat Class See Also Send Feedback

The TextFormat type exposes the following members.

Fields

Name | Description
MaxPrecision | The maximum precision that can be specified for a format.
MinPrecision | The minimum precision that can be specified for a format.

See Also

TextFormat Class
Mincom.LinkOne.Dom.Layouts Namespace


MaxPrecision Field

[image]

LinkOne WebView API
TextFormat..::.MaxPrecision Field
TextFormat Class See Also Send Feedback
The maximum precision that can be specified for a format.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const int MaxPrecision
Visual Basic (Declaration)
Public Const MaxPrecision As Integer
Visual C++
public:
literal int MaxPrecision

See Also

TextFormat Class
Mincom.LinkOne.Dom.Layouts Namespace


MinPrecision Field

[image]

LinkOne WebView API
TextFormat..::.MinPrecision Field
TextFormat Class See Also Send Feedback
The minimum precision that can be specified for a format.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const int MinPrecision
Visual Basic (Declaration)
Public Const MinPrecision As Integer
Visual C++
public:
literal int MinPrecision

See Also

TextFormat Class
Mincom.LinkOne.Dom.Layouts Namespace


TextFormat Methods

[image] [image]

LinkOne WebView API
TextFormat Methods
TextFormat Class See Also Send Feedback

The TextFormat type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetFormattedValue | Formats the specified text.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Gets a string representation of the TextFormat. (Overrides Object..::.ToString()()().)

See Also

TextFormat Class
Mincom.LinkOne.Dom.Layouts Namespace


GetFormattedValue Method

[image]

LinkOne WebView API
TextFormat..::.GetFormattedValue Method
TextFormat Class See Also Send Feedback
Formats the specified text.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string GetFormattedValue(
    string text
)
Visual Basic (Declaration)
Public Function GetFormattedValue ( _
    text As String _
) As String
Visual C++
public:
String^ GetFormattedValue(
    String^ text
)

Parameters

text
Type: System..::.String
The text to format.

Return Value

The formatted text.

Remarks

If the format cannot be applied the text is returned unformatted.

See Also

TextFormat Class
Mincom.LinkOne.Dom.Layouts Namespace


ToString Method

[image]

LinkOne WebView API
TextFormat..::.ToString Method
TextFormat Class See Also Send Feedback
Gets a string representation of the TextFormat.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The format string; Empty()()() if there is no formatting to apply.

See Also

TextFormat Class
Mincom.LinkOne.Dom.Layouts Namespace


TextFormat Properties

[image] [image]

LinkOne WebView API
TextFormat Properties
TextFormat Class See Also Send Feedback

The TextFormat type exposes the following members.

Properties

Name | Description
FormatSpecifier | Gets the format specifier.
None | Predefined TextFormat that represents None formatting.
Precision | Gets the precision; or null if not applicable to the TextFormatSpecifier.

See Also

TextFormat Class
Mincom.LinkOne.Dom.Layouts Namespace


FormatSpecifier Property

[image]

LinkOne WebView API
TextFormat..::.FormatSpecifier Property
TextFormat Class See Also Send Feedback
Gets the format specifier.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public TextFormatSpecifier FormatSpecifier { get; }
Visual Basic (Declaration)
Public ReadOnly Property FormatSpecifier As TextFormatSpecifier
Visual C++
public:
virtual property TextFormatSpecifier FormatSpecifier {
    TextFormatSpecifier get () sealed;
}

Implements

ITextFormat..::.FormatSpecifier

See Also

TextFormat Class
Mincom.LinkOne.Dom.Layouts Namespace


None Property

[image]

LinkOne WebView API
TextFormat..::.None Property
TextFormat Class See Also Send Feedback
Predefined TextFormat that represents None formatting.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static TextFormat None { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property None As TextFormat
Visual C++
public:
static property TextFormat^ None {
    TextFormat^ get ();
}

See Also

TextFormat Class
Mincom.LinkOne.Dom.Layouts Namespace


Precision Property

[image]

LinkOne WebView API
TextFormat..::.Precision Property
TextFormat Class See Also Send Feedback
Gets the precision; or null if not applicable to the TextFormatSpecifier.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Nullable<int> Precision { get; }
Visual Basic (Declaration)
Public ReadOnly Property Precision As Nullable(Of Integer)
Visual C++
public:
virtual property Nullable<int> Precision {
    Nullable<int> get () sealed;
}

Implements

ITextFormat..::.Precision

See Also

TextFormat Class
Mincom.LinkOne.Dom.Layouts Namespace


TextFormatSpecifier Enumeration

[image]

LinkOne WebView API
TextFormatSpecifier Enumeration
See Also Send Feedback
Specifies formatting for numeric fields.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum TextFormatSpecifier
Visual Basic (Declaration)
Public Enumeration TextFormatSpecifier
Visual C++
public enum class TextFormatSpecifier

Members

Member name | Description
None | Do not format the text.
Number | Format numeric fields as a number string of the form: nn,nnn,nnn.nn.
Currency | Format numeric fields as a currency of the form: $nnn.nn.
FixedPoint | Format numeric fields as a fixed point number of the form: nnn.aa, where aa is the precision.
Decimal | Format numeric fields as a zero padded decimal of the form: aaann, where aaa is the precision.

See Also

Mincom.LinkOne.Dom.Layouts Namespace


ValueNote Class

[image]

LinkOne WebView API
ValueNote Class
Members See Also Send Feedback
Represents a value note in a layout cell.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public class ValueNote : IValueNote, ICellContents
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ValueNote _
    Implements IValueNote, ICellContents
Visual C++
[SerializableAttribute]
public ref class ValueNote : IValueNote,
    ICellContents

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Layouts..::.ValueNote

See Also

ValueNote Members
Mincom.LinkOne.Dom.Layouts Namespace


ValueNote Members

[image] [image]

LinkOne WebView API
ValueNote Members
ValueNote Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ValueNote type exposes the following members.

Constructors

Name | Description
ValueNote | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Name | The name of the value note.

Explicit Interface Implementations

Name | Description
IValueNote..::.Name |

See Also

ValueNote Class
Mincom.LinkOne.Dom.Layouts Namespace


ValueNote Constructor

[image] [image]

LinkOne WebView API
ValueNote Constructor
ValueNote Class See Also Send Feedback

Overload List

Name | Description
ValueNote()()() | Initializes a new instance of the ValueNote class.
ValueNote(String) | Initializes a new instance of the ValueNote class.

See Also

ValueNote Class
ValueNote Members
Mincom.LinkOne.Dom.Layouts Namespace


ValueNote Constructor

[image]

LinkOne WebView API
ValueNote Constructor
ValueNote Class See Also Send Feedback
Initializes a new instance of the ValueNote class.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ValueNote()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ValueNote()

See Also

ValueNote Class
ValueNote Overload
Mincom.LinkOne.Dom.Layouts Namespace


ValueNote Constructor (String)

[image]

LinkOne WebView API
ValueNote Constructor (String)
ValueNote Class See Also Send Feedback
Initializes a new instance of the ValueNote class.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ValueNote(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)
Visual C++
public:
ValueNote(
    String^ name
)

Parameters

name
Type: System..::.String
The name fo the value note.

See Also

ValueNote Class
ValueNote Overload
Mincom.LinkOne.Dom.Layouts Namespace


ValueNote Methods

[image] [image]

LinkOne WebView API
ValueNote Methods
ValueNote Class See Also Send Feedback

The ValueNote type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ValueNote Class
Mincom.LinkOne.Dom.Layouts Namespace


ValueNote Properties

[image] [image]

LinkOne WebView API
ValueNote Properties
ValueNote Class See Also Send Feedback

The ValueNote type exposes the following members.

Properties

Name | Description
Name | The name of the value note.

Explicit Interface Implementations

Name | Description
IValueNote..::.Name |

See Also

ValueNote Class
Mincom.LinkOne.Dom.Layouts Namespace


IValueNote.Name Property

[image]

LinkOne WebView API
ValueNote..::.IValueNote..::.Name Property
ValueNote Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string IValueNote.Name { get; set; }
Visual Basic (Declaration)
Private Property Name As String Implements IValueNote.Name
Visual C++
private:
virtual property String^ Name {
    String^ get () sealed = IValueNote::Name::get;
    void set (String^ value) sealed = IValueNote::Name::set;
}

Implements

IValueNote..::.Name

See Also

ValueNote Class
Mincom.LinkOne.Dom.Layouts Namespace


Name Property

[image]

LinkOne WebView API
ValueNote..::.Name Property
ValueNote Class See Also Send Feedback
The name of the value note.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The value note name.

See Also

ValueNote Class
Mincom.LinkOne.Dom.Layouts Namespace


VerticalAlignment Enumeration

[image]

LinkOne WebView API
VerticalAlignment Enumeration
See Also Send Feedback
Allowed values for vertical text alignment.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum VerticalAlignment
Visual Basic (Declaration)
Public Enumeration VerticalAlignment
Visual C++
public enum class VerticalAlignment

Members

Member name | Description
Top | The text is aligned to the top of its container.
Middle | The text is aligned to the middle of its container.
Bottom | The text is aligned to the bottom of its container.

See Also

Mincom.LinkOne.Dom.Layouts Namespace


Weight Enumeration

[image]

LinkOne WebView API
Weight Enumeration
See Also Send Feedback
Values for specifying the font weight.

Namespace: Mincom.LinkOne.Dom.Layouts
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum Weight
Visual Basic (Declaration)
Public Enumeration Weight
Visual C++
public enum class Weight

Members

Member name | Description
NotSpecified | No weight was specified.
Normal | Normal font weight.
Thin | Thin font weight.
ExtraLight | Extra light font weight.
Light | Light font weight.
Medium | Medium font weight.
SemiBold | Semi-bold font weight.
Bold | Bold font weight.
ExtraBold | Extra bold font weight.
Heavy | Heavy font weight.

See Also

Mincom.LinkOne.Dom.Layouts Namespace


Mincom.LinkOne.Dom.Licensing Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.Dom.Licensing Namespace
Send Feedback
The Mincom.LinkOne.Dom.Licensing namespace contains classes that identify the various LinkOne licenses.

Classes

Class | Description
LinkOneLicense | Extends System.ComponentModel.License to provide a base class for all LinkOne licenses.
LinkOneLicenseCollection | Represents a collection of LinkOne licenses.
LockLicense | Represents a LinkOne security lock license.
PluginLicense | Represents a LinkOne runtime plugin license.
ReadOnlyLinkOneLicenseCollection | Represents a collection of LinkOne licenses that cannot be modified.
ViewerLicense | Represents a LinkOne viewer license.
WebViewLicense | Represents a LinkOne WebView license.

Enumerations

Enumeration | Description
PluginLicense..::.LicenseRestrictionType | This enum defines the various restricted types of Plugin license
ViewerLicense..::.LicenseRestrictionType | This enum defines the various restricted types of Viewer license
WebViewLicense..::.LicenseRestrictionType | This enum defines the various restricted types of WebView license.


LinkOneLicense Class

[image]

LinkOne WebView API
LinkOneLicense Class
Members See Also Send Feedback
Extends System.ComponentModel.License to provide a base class for all LinkOne licenses.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public abstract class LinkOneLicense : License
Visual Basic (Declaration)
Public MustInherit Class LinkOneLicense _
    Inherits License
Visual C++
public ref class LinkOneLicense abstract : public License

Remarks

A LinkOne license is represented as an XML element commencing with the <license/> tag.
The License XML is authenticated via a 2048 bit RSA digital signature.
Each license supports a common set of mandatory or optional attributes as listed below. If a mandatory attribute is omitted the license code is invalid.
licenseid | MANDATORY | A unique identifier for the license.
licensee | MANDATORY | A unique identifier for the licensee or customer to whom the license has been issued.
issued | MANDATORY | The date on which the license was issued, in the format YYYYMMDD.
version | MANDATORY | Identifies the object version the license applies to.
expires | OPTIONAL | Defaults to DateTime.MaxValue.
signature | MANDATORY | A digital signature guaranteeing the license authenticity.

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.License
Mincom.LinkOne.Dom.Licensing..::.LinkOneLicense
Mincom.LinkOne.Dom.Licensing..::.LockLicense
Mincom.LinkOne.Dom.Licensing..::.PluginLicense
Mincom.LinkOne.Dom.Licensing..::.ViewerLicense
Mincom.LinkOne.Dom.Licensing..::.WebViewLicense

See Also

LinkOneLicense Members
Mincom.LinkOne.Dom.Licensing Namespace


LinkOneLicense Members

[image] [image]

LinkOne WebView API
LinkOneLicense Members
LinkOneLicense Class Methods Properties See Also Send Feedback

The LinkOneLicense type exposes the following members.

Methods

Name | Description
Create | Creates a license given the license string.
Dispose | Overrides System.ComponentModel.License.Dispose (Overrides License..::.Dispose()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Sign | Sign this license with the supplied key.
ToString | Gets an Xml representation of the license (Overrides Object..::.ToString()()().)

Properties

Name | Description
DaysRemaining | Gets the days remaining if the license will expire.
Expires | Gets or sets the license expiry date.
HasExpired | Gets true if the license has expired.
HasExpires | Gets true if the license will expire.
IsDecoded | Gets true if the license has decoded corectly.
Issued | Gets or sets the license issue date.
Licensee | Gets or sets the Licensee.
LicenseId | Gets or sets the LicenseId.
LicenseKey | Supplies a unique string that describes the license (Overrides License..::.LicenseKey.)
Signature | Gets the licenses digital signature.
Version | Gets or sets the license version specification.

See Also

LinkOneLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


LinkOneLicense Methods

[image] [image]

LinkOne WebView API
LinkOneLicense Methods
LinkOneLicense Class See Also Send Feedback

The LinkOneLicense type exposes the following members.

Methods

Name | Description
Create | Creates a license given the license string.
Dispose | Overrides System.ComponentModel.License.Dispose (Overrides License..::.Dispose()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Sign | Sign this license with the supplied key.
ToString | Gets an Xml representation of the license (Overrides Object..::.ToString()()().)

See Also

LinkOneLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


Create Method

[image]

LinkOne WebView API
LinkOneLicense..::.Create Method
LinkOneLicense Class See Also Send Feedback
Creates a license given the license string.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static LinkOneLicense Create(
    string value
)
Visual Basic (Declaration)
Public Shared Function Create ( _
    value As String _
) As LinkOneLicense
Visual C++
public:
static LinkOneLicense^ Create(
    String^ value
)

Parameters

value
Type: System..::.String
The license value to parse into a license.

Return Value

A license from the license string.

See Also

LinkOneLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


Dispose Method

[image]

LinkOne WebView API
LinkOneLicense..::.Dispose Method
LinkOneLicense Class See Also Send Feedback
Overrides System.ComponentModel.License.Dispose

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override void Dispose()
Visual Basic (Declaration)
Public Overrides Sub Dispose
Visual C++
public:
virtual void Dispose() override

Implements

IDisposable..::.Dispose()()()

See Also

LinkOneLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


Sign Method

[image]

LinkOne WebView API
LinkOneLicense..::.Sign Method
LinkOneLicense Class See Also Send Feedback
Sign this license with the supplied key.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public virtual void Sign(
    string key
)
Visual Basic (Declaration)
Public Overridable Sub Sign ( _
    key As String _
)
Visual C++
public:
virtual void Sign(
    String^ key
)

Parameters

key
Type: System..::.String
The key to sign the license with.

See Also

LinkOneLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


ToString Method

[image]

LinkOne WebView API
LinkOneLicense..::.ToString Method
LinkOneLicense Class See Also Send Feedback
Gets an Xml representation of the license

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

See Also

LinkOneLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


LinkOneLicense Properties

[image] [image]

LinkOne WebView API
LinkOneLicense Properties
LinkOneLicense Class See Also Send Feedback

The LinkOneLicense type exposes the following members.

Properties

Name | Description
DaysRemaining | Gets the days remaining if the license will expire.
Expires | Gets or sets the license expiry date.
HasExpired | Gets true if the license has expired.
HasExpires | Gets true if the license will expire.
IsDecoded | Gets true if the license has decoded corectly.
Issued | Gets or sets the license issue date.
Licensee | Gets or sets the Licensee.
LicenseId | Gets or sets the LicenseId.
LicenseKey | Supplies a unique string that describes the license (Overrides License..::.LicenseKey.)
Signature | Gets the licenses digital signature.
Version | Gets or sets the license version specification.

See Also

LinkOneLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


DaysRemaining Property

[image]

LinkOne WebView API
LinkOneLicense..::.DaysRemaining Property
LinkOneLicense Class See Also Send Feedback
Gets the days remaining if the license will expire.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int DaysRemaining { get; }
Visual Basic (Declaration)
Public ReadOnly Property DaysRemaining As Integer
Visual C++
public:
property int DaysRemaining {
    int get ();
}

See Also

LinkOneLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


Expires Property

[image]

LinkOne WebView API
LinkOneLicense..::.Expires Property
LinkOneLicense Class See Also Send Feedback
Gets or sets the license expiry date.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public DateTime Expires { get; set; }
Visual Basic (Declaration)
Public Property Expires As DateTime
Visual C++
public:
property DateTime Expires {
    DateTime get ();
    void set (DateTime value);
}

See Also

LinkOneLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


HasExpired Property

[image]

LinkOne WebView API
LinkOneLicense..::.HasExpired Property
LinkOneLicense Class See Also Send Feedback
Gets true if the license has expired.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool HasExpired { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasExpired As Boolean
Visual C++
public:
property bool HasExpired {
    bool get ();
}

See Also

LinkOneLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


HasExpires Property

[image]

LinkOne WebView API
LinkOneLicense..::.HasExpires Property
LinkOneLicense Class See Also Send Feedback
Gets true if the license will expire.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool HasExpires { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasExpires As Boolean
Visual C++
public:
property bool HasExpires {
    bool get ();
}

See Also

LinkOneLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


IsDecoded Property

[image]

LinkOne WebView API
LinkOneLicense..::.IsDecoded Property
LinkOneLicense Class See Also Send Feedback
Gets true if the license has decoded corectly.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public virtual bool IsDecoded { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsDecoded As Boolean
Visual C++
public:
virtual property bool IsDecoded {
    bool get ();
}

See Also

LinkOneLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


Issued Property

[image]

LinkOne WebView API
LinkOneLicense..::.Issued Property
LinkOneLicense Class See Also Send Feedback
Gets or sets the license issue date.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public DateTime Issued { get; set; }
Visual Basic (Declaration)
Public Property Issued As DateTime
Visual C++
public:
property DateTime Issued {
    DateTime get ();
    void set (DateTime value);
}

See Also

LinkOneLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


Licensee Property

[image]

LinkOne WebView API
LinkOneLicense..::.Licensee Property
LinkOneLicense Class See Also Send Feedback
Gets or sets the Licensee.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Licensee { get; set; }
Visual Basic (Declaration)
Public Property Licensee As String
Visual C++
public:
property String^ Licensee {
    String^ get ();
    void set (String^ value);
}

See Also

LinkOneLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


LicenseId Property

[image]

LinkOne WebView API
LinkOneLicense..::.LicenseId Property
LinkOneLicense Class See Also Send Feedback
Gets or sets the LicenseId.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string LicenseId { get; set; }
Visual Basic (Declaration)
Public Property LicenseId As String
Visual C++
public:
property String^ LicenseId {
    String^ get ();
    void set (String^ value);
}

See Also

LinkOneLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


LicenseKey Property

[image]

LinkOne WebView API
LinkOneLicense..::.LicenseKey Property
LinkOneLicense Class See Also Send Feedback
Supplies a unique string that describes the license

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string LicenseKey { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LicenseKey As String
Visual C++
public:
virtual property String^ LicenseKey {
    String^ get () override;
}

See Also

LinkOneLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


Signature Property

[image]

LinkOne WebView API
LinkOneLicense..::.Signature Property
LinkOneLicense Class See Also Send Feedback
Gets the licenses digital signature.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Signature { get; }
Visual Basic (Declaration)
Public ReadOnly Property Signature As String
Visual C++
public:
property String^ Signature {
    String^ get ();
}

See Also

LinkOneLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


Version Property

[image]

LinkOne WebView API
LinkOneLicense..::.Version Property
LinkOneLicense Class See Also Send Feedback
Gets or sets the license version specification.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Version { get; set; }
Visual Basic (Declaration)
Public Property Version As String
Visual C++
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}

See Also

LinkOneLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


LinkOneLicenseCollection Class

[image]

LinkOne WebView API
LinkOneLicenseCollection Class
Members See Also Send Feedback
Represents a collection of LinkOne licenses.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class LinkOneLicenseCollection : LiveCollection<string>
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class LinkOneLicenseCollection _
    Inherits LiveCollection(Of String)
Visual C++
[SerializableAttribute]
public ref class LinkOneLicenseCollection sealed : public LiveCollection<String^>

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection<(Of <(String>)>)
LiveCollection<(Of <(String>)>)
Mincom.LinkOne.Dom.Licensing..::.LinkOneLicenseCollection

See Also

LinkOneLicenseCollection Members
Mincom.LinkOne.Dom.Licensing Namespace


LinkOneLicenseCollection Members

[image] [image]

LinkOne WebView API
LinkOneLicenseCollection Members
LinkOneLicenseCollection Class Constructors Methods Properties Events Explicit Interface Implementations See Also Send Feedback

The LinkOneLicenseCollection type exposes the following members.

Constructors

Name | Description
LinkOneLicenseCollection | Overloaded.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <(String>)>).)
AddRange | Adds the given licenses to the collection, ignoring duplicates.
AsReadOnly | Returns a read-only copy of this collection.
AsStringCollection | Gets the string collection represented by this LicenseCollection.
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <(String>)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <(String>)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <(String>)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <(String>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <(String>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <(String>)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <(String>)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <(String>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <(String>)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <(String>)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <(String>)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <(String>)>).)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <(String>)>).)
DecodedLicenses | Gets the decoded licenses.
Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <(String>)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <(String>)>).)

Events

Name | Description
Changed | Occurs when the collection has changed.

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds an item to the IList. (Inherited from Collection<(Of <(String>)>).)
IList..::.Contains | Determines whether the IList contains a specific value. (Inherited from Collection<(Of <(String>)>).)
ICollection..::.CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection<(Of <(String>)>).)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection<(Of <(String>)>).)
IList..::.IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection<(Of <(String>)>).)
IList..::.Insert | Inserts an item into the IList at the specified index. (Inherited from Collection<(Of <(String>)>).)
IList..::.IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection<(Of <(String>)>).)
System#Collections#Generic#ICollection{T}#IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from Collection<(Of <(String>)>).)
IList..::.IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection<(Of <(String>)>).)
ICollection..::.IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection<(Of <(String>)>).)
IList..::.Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <(String>)>).)
IList..::.Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection<(Of <(String>)>).)
ICollection..::.SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection<(Of <(String>)>).)

See Also

LinkOneLicenseCollection Class
Mincom.LinkOne.Dom.Licensing Namespace


LinkOneLicenseCollection Constructor

[image] [image]

LinkOne WebView API
LinkOneLicenseCollection Constructor
LinkOneLicenseCollection Class See Also Send Feedback

Overload List

Name | Description
LinkOneLicenseCollection()()() | Initializes a new instance of the LinkOneLicenseCollection class.
LinkOneLicenseCollection(IEnumerable<(Of <(String>)>)) | Initializes a new instance of the LinkOneLicenseCollection class.
LinkOneLicenseCollection(StringCollection) | Initializes a new instance of the LinkOneLicenseCollection class.
LinkOneLicenseCollection(array<String>[]()[]) | Initializes a new instance of the LinkOneLicenseCollection class.
LinkOneLicenseCollection(XmlElement) | Initializes a new instance of the LinkOneLicenseCollection class.

See Also

LinkOneLicenseCollection Class
LinkOneLicenseCollection Members
Mincom.LinkOne.Dom.Licensing Namespace


LinkOneLicenseCollection Constructor

[image]

LinkOne WebView API
LinkOneLicenseCollection Constructor
LinkOneLicenseCollection Class See Also Send Feedback
Initializes a new instance of the LinkOneLicenseCollection class.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LinkOneLicenseCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LinkOneLicenseCollection()

See Also

LinkOneLicenseCollection Class
LinkOneLicenseCollection Overload
Mincom.LinkOne.Dom.Licensing Namespace


LinkOneLicenseCollection Constructor (IEnumerable(String))

[image]

LinkOne WebView API
LinkOneLicenseCollection Constructor (IEnumerable<(Of <(String>)>))
LinkOneLicenseCollection Class See Also Send Feedback
Initializes a new instance of the LinkOneLicenseCollection class.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LinkOneLicenseCollection(
    IEnumerable<string> licenses
)
Visual Basic (Declaration)
Public Sub New ( _
    licenses As IEnumerable(Of String) _
)
Visual C++
public:
LinkOneLicenseCollection(
    IEnumerable<String^>^ licenses
)

Parameters

licenses
Type: System.Collections.Generic..::.IEnumerable<(Of <(String>)>)
The licenses to initialize the collection with.

See Also

LinkOneLicenseCollection Class
LinkOneLicenseCollection Overload
Mincom.LinkOne.Dom.Licensing Namespace


LinkOneLicenseCollection Constructor (StringCollection)

[image]

LinkOne WebView API
LinkOneLicenseCollection Constructor (StringCollection)
LinkOneLicenseCollection Class See Also Send Feedback
Initializes a new instance of the LinkOneLicenseCollection class.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LinkOneLicenseCollection(
    StringCollection licenses
)
Visual Basic (Declaration)
Public Sub New ( _
    licenses As StringCollection _
)
Visual C++
public:
LinkOneLicenseCollection(
    StringCollection^ licenses
)

Parameters

licenses
Type: System.Collections.Specialized..::.StringCollection
The licenses to initialize the collection with.

See Also

LinkOneLicenseCollection Class
LinkOneLicenseCollection Overload
Mincom.LinkOne.Dom.Licensing Namespace


LinkOneLicenseCollection Constructor (String[])

[image]

LinkOne WebView API
LinkOneLicenseCollection Constructor (array<String>[]()[])
LinkOneLicenseCollection Class See Also Send Feedback
Initializes a new instance of the LinkOneLicenseCollection class.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LinkOneLicenseCollection(
    params string[] licenses
)
Visual Basic (Declaration)
Public Sub New ( _
    ParamArray licenses As String() _
)
Visual C++
public:
LinkOneLicenseCollection(
    ... array<String^>^ licenses
)

Parameters

licenses
Type: array< System..::.String >[]()[]
The licenses to initialize the collection with.

See Also

LinkOneLicenseCollection Class
LinkOneLicenseCollection Overload
Mincom.LinkOne.Dom.Licensing Namespace


LinkOneLicenseCollection Constructor (XmlElement)

[image]

LinkOne WebView API
LinkOneLicenseCollection Constructor (XmlElement)
LinkOneLicenseCollection Class See Also Send Feedback
Initializes a new instance of the LinkOneLicenseCollection class.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LinkOneLicenseCollection(
    XmlElement licenses
)
Visual Basic (Declaration)
Public Sub New ( _
    licenses As XmlElement _
)
Visual C++
public:
LinkOneLicenseCollection(
    XmlElement^ licenses
)

Parameters

licenses
Type: System.Xml..::.XmlElement
The licenses.

See Also

LinkOneLicenseCollection Class
LinkOneLicenseCollection Overload
Mincom.LinkOne.Dom.Licensing Namespace


LinkOneLicenseCollection Methods

[image] [image]

LinkOne WebView API
LinkOneLicenseCollection Methods
LinkOneLicenseCollection Class See Also Send Feedback

The LinkOneLicenseCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <(String>)>).)
AddRange | Adds the given licenses to the collection, ignoring duplicates.
AsReadOnly | Returns a read-only copy of this collection.
AsStringCollection | Gets the string collection represented by this LicenseCollection.
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <(String>)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <(String>)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <(String>)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <(String>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <(String>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <(String>)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <(String>)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <(String>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <(String>)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <(String>)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <(String>)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <(String>)>).)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds an item to the IList. (Inherited from Collection<(Of <(String>)>).)
IList..::.Contains | Determines whether the IList contains a specific value. (Inherited from Collection<(Of <(String>)>).)
ICollection..::.CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection<(Of <(String>)>).)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection<(Of <(String>)>).)
IList..::.IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection<(Of <(String>)>).)
IList..::.Insert | Inserts an item into the IList at the specified index. (Inherited from Collection<(Of <(String>)>).)
IList..::.Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection<(Of <(String>)>).)

See Also

LinkOneLicenseCollection Class
Mincom.LinkOne.Dom.Licensing Namespace


AddRange Method

[image]

LinkOne WebView API
LinkOneLicenseCollection..::.AddRange Method
LinkOneLicenseCollection Class See Also Send Feedback
Adds the given licenses to the collection, ignoring duplicates.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void AddRange(
    IEnumerable<string> licenses
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    licenses As IEnumerable(Of String) _
)
Visual C++
public:
void AddRange(
    IEnumerable<String^>^ licenses
)

Parameters

licenses
Type: System.Collections.Generic..::.IEnumerable<(Of <(String>)>)
The licenses to add.

Remarks

Duplicate licenses are not added if they already exist in the collection.

See Also

LinkOneLicenseCollection Class
Mincom.LinkOne.Dom.Licensing Namespace


AsReadOnly Method

[image]

LinkOne WebView API
LinkOneLicenseCollection..::.AsReadOnly Method
LinkOneLicenseCollection Class See Also Send Feedback
Returns a read-only copy of this collection.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ReadOnlyLinkOneLicenseCollection AsReadOnly()
Visual Basic (Declaration)
Public Function AsReadOnly As ReadOnlyLinkOneLicenseCollection
Visual C++
public:
ReadOnlyLinkOneLicenseCollection^ AsReadOnly()

Return Value

A read-only wrapper for this LinkOneLicenseCollection.

See Also

LinkOneLicenseCollection Class
Mincom.LinkOne.Dom.Licensing Namespace


AsStringCollection Method

[image]

LinkOne WebView API
LinkOneLicenseCollection..::.AsStringCollection Method
LinkOneLicenseCollection Class See Also Send Feedback
Gets the string collection represented by this LicenseCollection.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public StringCollection AsStringCollection()
Visual Basic (Declaration)
Public Function AsStringCollection As StringCollection
Visual C++
public:
StringCollection^ AsStringCollection()

Return Value

A StringCollection of the licenses.

See Also

LinkOneLicenseCollection Class
Mincom.LinkOne.Dom.Licensing Namespace


LinkOneLicenseCollection Properties

[image] [image]

LinkOne WebView API
LinkOneLicenseCollection Properties
LinkOneLicenseCollection Class See Also Send Feedback

The LinkOneLicenseCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <(String>)>).)
DecodedLicenses | Gets the decoded licenses.
Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <(String>)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <(String>)>).)

Explicit Interface Implementations

Name | Description
IList..::.IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection<(Of <(String>)>).)
System#Collections#Generic#ICollection{T}#IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from Collection<(Of <(String>)>).)
IList..::.IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection<(Of <(String>)>).)
ICollection..::.IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection<(Of <(String>)>).)
IList..::.Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <(String>)>).)
ICollection..::.SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection<(Of <(String>)>).)

See Also

LinkOneLicenseCollection Class
Mincom.LinkOne.Dom.Licensing Namespace


DecodedLicenses Property

[image]

LinkOne WebView API
LinkOneLicenseCollection..::.DecodedLicenses Property
LinkOneLicenseCollection Class See Also Send Feedback
Gets the decoded licenses.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public List<LinkOneLicense> DecodedLicenses { get; }
Visual Basic (Declaration)
Public ReadOnly Property DecodedLicenses As List(Of LinkOneLicense)
Visual C++
public:
property List<LinkOneLicense^>^ DecodedLicenses {
    List<LinkOneLicense^>^ get ();
}

See Also

LinkOneLicenseCollection Class
Mincom.LinkOne.Dom.Licensing Namespace


LinkOneLicenseCollection Events

[image] [image]

LinkOne WebView API
LinkOneLicenseCollection Events
LinkOneLicenseCollection Class See Also Send Feedback

The LinkOneLicenseCollection type exposes the following members.

Events

Name | Description
Changed | Occurs when the collection has changed.

See Also

LinkOneLicenseCollection Class
Mincom.LinkOne.Dom.Licensing Namespace


Changed Event

[image]

LinkOne WebView API
LinkOneLicenseCollection..::.Changed Event
LinkOneLicenseCollection Class See Also Send Feedback
Occurs when the collection has changed.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public event EventHandler Changed
Visual Basic (Declaration)
Public Event Changed As EventHandler
Visual C++
public:
 event EventHandler^ Changed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

LinkOneLicenseCollection Class
Mincom.LinkOne.Dom.Licensing Namespace


LockLicense Class

[image]

LinkOne WebView API
LockLicense Class
Members See Also Send Feedback
Represents a LinkOne security lock license.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public sealed class LockLicense : LinkOneLicense
Visual Basic (Declaration)
Public NotInheritable Class LockLicense _
    Inherits LinkOneLicense
Visual C++
public ref class LockLicense sealed : public LinkOneLicense

Remarks

This type of license is issued by publishers.
For a LockLicense to validate a lock, the following conditions must be true:
  • The PublisherCode must match the lock publisher code.
  • The LockNumber must match the lock number.

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.License
Mincom.LinkOne.Dom.Licensing..::.LinkOneLicense
Mincom.LinkOne.Dom.Licensing..::.LockLicense

See Also

LockLicense Members
Mincom.LinkOne.Dom.Licensing Namespace


LockLicense Members

[image] [image]

LinkOne WebView API
LockLicense Members
LockLicense Class Constructors Methods Properties See Also Send Feedback

The LockLicense type exposes the following members.

Constructors

Name | Description
LockLicense | Constructor.

Methods

Name | Description
Dispose | Overrides System.ComponentModel.License.Dispose (Inherited from LinkOneLicense.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Sign | Sign this license with the supplied key. (Overrides LinkOneLicense..::.Sign(String).)
ToString | Gets an Xml representation of the license (Inherited from LinkOneLicense.)
TryValidate | Returns true if a valid license for the given conditions is found.
Validate | Validates a correct license for the given conditions.

Properties

Name | Description
DaysRemaining | Gets the days remaining if the license will expire. (Inherited from LinkOneLicense.)
Expires | Gets or sets the license expiry date. (Inherited from LinkOneLicense.)
HasExpired | Gets true if the license has expired. (Inherited from LinkOneLicense.)
HasExpires | Gets true if the license will expire. (Inherited from LinkOneLicense.)
IsDecoded | Gets true if the license has decoded corectly. (Overrides LinkOneLicense..::.IsDecoded.)
Issued | Gets or sets the license issue date. (Inherited from LinkOneLicense.)
Licensee | Gets or sets the Licensee. (Inherited from LinkOneLicense.)
LicenseId | Gets or sets the LicenseId. (Inherited from LinkOneLicense.)
LicenseKey | Supplies a unique string that describes the license (Overrides LinkOneLicense..::.LicenseKey.)
LockNumber | Gets or sets the license lock number.
PublisherCode | Gets or sets the license publisher code.
Signature | Gets the licenses digital signature. (Inherited from LinkOneLicense.)
Version | Gets or sets the license version specification. (Inherited from LinkOneLicense.)

See Also

LockLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


LockLicense Constructor

[image]

LinkOne WebView API
LockLicense Constructor
LockLicense Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LockLicense()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LockLicense()

See Also

LockLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


LockLicense Methods

[image] [image]

LinkOne WebView API
LockLicense Methods
LockLicense Class See Also Send Feedback

The LockLicense type exposes the following members.

Methods

Name | Description
Dispose | Overrides System.ComponentModel.License.Dispose (Inherited from LinkOneLicense.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Sign | Sign this license with the supplied key. (Overrides LinkOneLicense..::.Sign(String).)
ToString | Gets an Xml representation of the license (Inherited from LinkOneLicense.)
TryValidate | Returns true if a valid license for the given conditions is found.
Validate | Validates a correct license for the given conditions.

See Also

LockLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


Sign Method

[image]

LinkOne WebView API
LockLicense..::.Sign Method
LockLicense Class See Also Send Feedback
Sign this license with the supplied key.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override void Sign(
    string key
)
Visual Basic (Declaration)
Public Overrides Sub Sign ( _
    key As String _
)
Visual C++
public:
virtual void Sign(
    String^ key
) override

Parameters

key
Type: System..::.String
The key to sign the license with.

Remarks

The key is the publisher or contractor license which is used to generate the correct key.

See Also

LockLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


TryValidate Method

[image]

LinkOne WebView API
LockLicense..::.TryValidate Method
LockLicense Class See Also Send Feedback
Returns true if a valid license for the given conditions is found.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static bool TryValidate(
    string publisherCode,
    int lockNumber,
    LinkOneLicenseCollection licenses
)
Visual Basic (Declaration)
Public Shared Function TryValidate ( _
    publisherCode As String, _
    lockNumber As Integer, _
    licenses As LinkOneLicenseCollection _
) As Boolean
Visual C++
public:
static bool TryValidate(
    String^ publisherCode,
    int lockNumber,
    LinkOneLicenseCollection^ licenses
)

Parameters

publisherCode
Type: System..::.String
The publisher code to validate against.
lockNumber
Type: System..::.Int32
The lock number to validate against.
licenses
Type: Mincom.LinkOne.Dom.Licensing..::.LinkOneLicenseCollection
The licenses to validate against.

Return Value

True if a valid license for the given conditions is found.

See Also

LockLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


Validate Method

[image]

LinkOne WebView API
LockLicense..::.Validate Method
LockLicense Class See Also Send Feedback
Validates a correct license for the given conditions.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static void Validate(
    string publisherCode,
    int lockNumber,
    LinkOneLicenseCollection licenses
)
Visual Basic (Declaration)
Public Shared Sub Validate ( _
    publisherCode As String, _
    lockNumber As Integer, _
    licenses As LinkOneLicenseCollection _
)
Visual C++
public:
static void Validate(
    String^ publisherCode,
    int lockNumber,
    LinkOneLicenseCollection^ licenses
)

Parameters

publisherCode
Type: System..::.String
The publisher code to validate against.
lockNumber
Type: System..::.Int32
The lock number to validate against.
licenses
Type: Mincom.LinkOne.Dom.Licensing..::.LinkOneLicenseCollection
The licenses to validate against.

See Also

LockLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


LockLicense Properties

[image] [image]

LinkOne WebView API
LockLicense Properties
LockLicense Class See Also Send Feedback

The LockLicense type exposes the following members.

Properties

Name | Description
DaysRemaining | Gets the days remaining if the license will expire. (Inherited from LinkOneLicense.)
Expires | Gets or sets the license expiry date. (Inherited from LinkOneLicense.)
HasExpired | Gets true if the license has expired. (Inherited from LinkOneLicense.)
HasExpires | Gets true if the license will expire. (Inherited from LinkOneLicense.)
IsDecoded | Gets true if the license has decoded corectly. (Overrides LinkOneLicense..::.IsDecoded.)
Issued | Gets or sets the license issue date. (Inherited from LinkOneLicense.)
Licensee | Gets or sets the Licensee. (Inherited from LinkOneLicense.)
LicenseId | Gets or sets the LicenseId. (Inherited from LinkOneLicense.)
LicenseKey | Supplies a unique string that describes the license (Overrides LinkOneLicense..::.LicenseKey.)
LockNumber | Gets or sets the license lock number.
PublisherCode | Gets or sets the license publisher code.
Signature | Gets the licenses digital signature. (Inherited from LinkOneLicense.)
Version | Gets or sets the license version specification. (Inherited from LinkOneLicense.)

See Also

LockLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


IsDecoded Property

[image]

LinkOne WebView API
LockLicense..::.IsDecoded Property
LockLicense Class See Also Send Feedback
Gets true if the license has decoded corectly.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override bool IsDecoded { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsDecoded As Boolean
Visual C++
public:
virtual property bool IsDecoded {
    bool get () override;
}

See Also

LockLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


LicenseKey Property

[image]

LinkOne WebView API
LockLicense..::.LicenseKey Property
LockLicense Class See Also Send Feedback
Supplies a unique string that describes the license

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string LicenseKey { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LicenseKey As String
Visual C++
public:
virtual property String^ LicenseKey {
    String^ get () override;
}

See Also

LockLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


LockNumber Property

[image]

LinkOne WebView API
LockLicense..::.LockNumber Property
LockLicense Class See Also Send Feedback
Gets or sets the license lock number.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int LockNumber { get; set; }
Visual Basic (Declaration)
Public Property LockNumber As Integer
Visual C++
public:
property int LockNumber {
    int get ();
    void set (int value);
}

See Also

LockLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


PublisherCode Property

[image]

LinkOne WebView API
LockLicense..::.PublisherCode Property
LockLicense Class See Also Send Feedback
Gets or sets the license publisher code.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PublisherCode { get; set; }
Visual Basic (Declaration)
Public Property PublisherCode As String
Visual C++
public:
property String^ PublisherCode {
    String^ get ();
    void set (String^ value);
}

See Also

LockLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


PluginLicense Class

[image]

LinkOne WebView API
PluginLicense Class
Members See Also Send Feedback
Represents a LinkOne runtime plugin license.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public sealed class PluginLicense : LinkOneLicense
Visual Basic (Declaration)
Public NotInheritable Class PluginLicense _
    Inherits LinkOneLicense
Visual C++
public ref class PluginLicense sealed : public LinkOneLicense

Remarks

This type of license is issued by Mincom.
For a PluginLicense to validate a plugin, the following conditions must be true:
  • The PublicKey must match the plugin public key.
  • There must also be a valid Media Linked or Publisher Linked viewer license installed for the same PublisherCode.
  • There must NOT be an Open viewer license installed, or a Media Linked or Publisher Linked license installed from a different publisher code.
or
  • The PublicKey must match the plugin public key.
  • There must also be valid Media Linked or Publisher Linked viewer license installed for the same PluginLicense PublisherCode.
  • There must NOT be an Open viewer license installed, or a Media Linked or Publisher Linked license installed from a different publisher code.
or
  • The plugin is signed by Mincom.

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.License
Mincom.LinkOne.Dom.Licensing..::.LinkOneLicense
Mincom.LinkOne.Dom.Licensing..::.PluginLicense

See Also

PluginLicense Members
Mincom.LinkOne.Dom.Licensing Namespace


PluginLicense Members

[image] [image]

LinkOne WebView API
PluginLicense Members
PluginLicense Class Constructors Methods Properties See Also Send Feedback

The PluginLicense type exposes the following members.

Constructors

Name | Description
PluginLicense | Constructor.

Methods

Name | Description
Dispose | Overrides System.ComponentModel.License.Dispose (Inherited from LinkOneLicense.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Sign | Sign this license with the supplied key. (Inherited from LinkOneLicense.)
ToString | Gets an Xml representation of the license (Inherited from LinkOneLicense.)
TryValidate | Returns true if a valid license for the given conditions is found.
Validate | Validates a correct license for the given conditions.

Properties

Name | Description
DaysRemaining | Gets the days remaining if the license will expire. (Inherited from LinkOneLicense.)
Expires | Gets or sets the license expiry date. (Inherited from LinkOneLicense.)
HasExpired | Gets true if the license has expired. (Inherited from LinkOneLicense.)
HasExpires | Gets true if the license will expire. (Inherited from LinkOneLicense.)
IsDecoded | Gets true if the license has decoded corectly. (Inherited from LinkOneLicense.)
Issued | Gets or sets the license issue date. (Inherited from LinkOneLicense.)
Licensee | Gets or sets the Licensee. (Inherited from LinkOneLicense.)
LicenseId | Gets or sets the LicenseId. (Inherited from LinkOneLicense.)
LicenseKey | Supplies a unique string that describes the license (Overrides LinkOneLicense..::.LicenseKey.)
LicenseRestriction | Gets or sets the license restriction type.
PublicKey | Gets or sets the license public key.
PublisherCode | Gets or sets the license publisher code.
Signature | Gets the licenses digital signature. (Inherited from LinkOneLicense.)
Version | Gets or sets the license version specification. (Inherited from LinkOneLicense.)

See Also

PluginLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


PluginLicense Constructor

[image]

LinkOne WebView API
PluginLicense Constructor
PluginLicense Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PluginLicense()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PluginLicense()

See Also

PluginLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


PluginLicense Methods

[image] [image]

LinkOne WebView API
PluginLicense Methods
PluginLicense Class See Also Send Feedback

The PluginLicense type exposes the following members.

Methods

Name | Description
Dispose | Overrides System.ComponentModel.License.Dispose (Inherited from LinkOneLicense.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Sign | Sign this license with the supplied key. (Inherited from LinkOneLicense.)
ToString | Gets an Xml representation of the license (Inherited from LinkOneLicense.)
TryValidate | Returns true if a valid license for the given conditions is found.
Validate | Validates a correct license for the given conditions.

See Also

PluginLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


TryValidate Method

[image]

LinkOne WebView API
PluginLicense..::.TryValidate Method
PluginLicense Class See Also Send Feedback
Returns true if a valid license for the given conditions is found.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static bool TryValidate(
    IComponent pluginInstance,
    string pluginLicense,
    LinkOneLicenseCollection licenses
)
Visual Basic (Declaration)
Public Shared Function TryValidate ( _
    pluginInstance As IComponent, _
    pluginLicense As String, _
    licenses As LinkOneLicenseCollection _
) As Boolean
Visual C++
public:
static bool TryValidate(
    IComponent^ pluginInstance,
    String^ pluginLicense,
    LinkOneLicenseCollection^ licenses
)

Parameters

pluginInstance
Type: System.ComponentModel..::.IComponent
The plugin.
pluginLicense
Type: System..::.String
The plugin license (if not in licenses).
licenses
Type: Mincom.LinkOne.Dom.Licensing..::.LinkOneLicenseCollection
The licenses to validate against.

Return Value

Returns true if a valid license for the given conditions is found.

See Also

PluginLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


Validate Method

[image]

LinkOne WebView API
PluginLicense..::.Validate Method
PluginLicense Class See Also Send Feedback
Validates a correct license for the given conditions.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static void Validate(
    IComponent pluginInstance,
    string pluginLicense,
    LinkOneLicenseCollection licenses
)
Visual Basic (Declaration)
Public Shared Sub Validate ( _
    pluginInstance As IComponent, _
    pluginLicense As String, _
    licenses As LinkOneLicenseCollection _
)
Visual C++
public:
static void Validate(
    IComponent^ pluginInstance,
    String^ pluginLicense,
    LinkOneLicenseCollection^ licenses
)

Parameters

pluginInstance
Type: System.ComponentModel..::.IComponent
The plugin.
pluginLicense
Type: System..::.String
The plugin license (if not in licenses).
licenses
Type: Mincom.LinkOne.Dom.Licensing..::.LinkOneLicenseCollection
The licenses to validate against.

See Also

PluginLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


PluginLicense Properties

[image] [image]

LinkOne WebView API
PluginLicense Properties
PluginLicense Class See Also Send Feedback

The PluginLicense type exposes the following members.

Properties

Name | Description
DaysRemaining | Gets the days remaining if the license will expire. (Inherited from LinkOneLicense.)
Expires | Gets or sets the license expiry date. (Inherited from LinkOneLicense.)
HasExpired | Gets true if the license has expired. (Inherited from LinkOneLicense.)
HasExpires | Gets true if the license will expire. (Inherited from LinkOneLicense.)
IsDecoded | Gets true if the license has decoded corectly. (Inherited from LinkOneLicense.)
Issued | Gets or sets the license issue date. (Inherited from LinkOneLicense.)
Licensee | Gets or sets the Licensee. (Inherited from LinkOneLicense.)
LicenseId | Gets or sets the LicenseId. (Inherited from LinkOneLicense.)
LicenseKey | Supplies a unique string that describes the license (Overrides LinkOneLicense..::.LicenseKey.)
LicenseRestriction | Gets or sets the license restriction type.
PublicKey | Gets or sets the license public key.
PublisherCode | Gets or sets the license publisher code.
Signature | Gets the licenses digital signature. (Inherited from LinkOneLicense.)
Version | Gets or sets the license version specification. (Inherited from LinkOneLicense.)

See Also

PluginLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


LicenseKey Property

[image]

LinkOne WebView API
PluginLicense..::.LicenseKey Property
PluginLicense Class See Also Send Feedback
Supplies a unique string that describes the license

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string LicenseKey { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LicenseKey As String
Visual C++
public:
virtual property String^ LicenseKey {
    String^ get () override;
}

See Also

PluginLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


LicenseRestriction Property

[image]

LinkOne WebView API
PluginLicense..::.LicenseRestriction Property
PluginLicense Class See Also Send Feedback
Gets or sets the license restriction type.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PluginLicense..::.LicenseRestrictionType LicenseRestriction { get; set; }
Visual Basic (Declaration)
Public Property LicenseRestriction As PluginLicense..::.LicenseRestrictionType
Visual C++
public:
property PluginLicense..::.LicenseRestrictionType LicenseRestriction {
    PluginLicense..::.LicenseRestrictionType get ();
    void set (PluginLicense..::.LicenseRestrictionType value);
}

See Also

PluginLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


PublicKey Property

[image]

LinkOne WebView API
PluginLicense..::.PublicKey Property
PluginLicense Class See Also Send Feedback
Gets or sets the license public key.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PublicKey { get; set; }
Visual Basic (Declaration)
Public Property PublicKey As String
Visual C++
public:
property String^ PublicKey {
    String^ get ();
    void set (String^ value);
}

See Also

PluginLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


PublisherCode Property

[image]

LinkOne WebView API
PluginLicense..::.PublisherCode Property
PluginLicense Class See Also Send Feedback
Gets or sets the license publisher code.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PublisherCode { get; set; }
Visual Basic (Declaration)
Public Property PublisherCode As String
Visual C++
public:
property String^ PublisherCode {
    String^ get ();
    void set (String^ value);
}

See Also

PluginLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


PluginLicense.LicenseRestrictionType Enumeration

[image]

LinkOne WebView API
PluginLicense..::.LicenseRestrictionType Enumeration
PluginLicense Class See Also Send Feedback
This enum defines the various restricted types of Plugin license

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum LicenseRestrictionType
Visual Basic (Declaration)
Public Enumeration LicenseRestrictionType
Visual C++
public enum class LicenseRestrictionType

Members

Member name | Description
Open | An Open license will always plugin.
PublisherLinked | A Publisher-Linked license restricts the plugin to running only with the associated viewer license.

See Also

Mincom.LinkOne.Dom.Licensing Namespace


ReadOnlyLinkOneLicenseCollection Class

[image]

LinkOne WebView API
ReadOnlyLinkOneLicenseCollection Class
Members See Also Send Feedback
Represents a collection of LinkOne licenses that cannot be modified.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class ReadOnlyLinkOneLicenseCollection : ReadOnlyCollection<string>
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class ReadOnlyLinkOneLicenseCollection _
    Inherits ReadOnlyCollection(Of String)
Visual C++
[SerializableAttribute]
public ref class ReadOnlyLinkOneLicenseCollection sealed : public ReadOnlyCollection<String^>

Remarks

If changes are made to the underlying LinkOneLicenseCollection, the ReadOnlyLinkOneLicenseCollection reflects those changes.

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.ReadOnlyCollection<(Of <(String>)>)
Mincom.LinkOne.Dom.Licensing..::.ReadOnlyLinkOneLicenseCollection

See Also

ReadOnlyLinkOneLicenseCollection Members
Mincom.LinkOne.Dom.Licensing Namespace


ReadOnlyLinkOneLicenseCollection Members

[image] [image]

LinkOne WebView API
ReadOnlyLinkOneLicenseCollection Members
ReadOnlyLinkOneLicenseCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ReadOnlyLinkOneLicenseCollection type exposes the following members.

Constructors

Name | Description
ReadOnlyLinkOneLicenseCollection | Initializes a new instance of the ReadOnlyLinkOneLicenseCollection class.

Methods

Name | Description
Contains | Determines whether an element is in the ReadOnlyCollection<(Of <(T>)>). (Inherited from ReadOnlyCollection<(Of <(String>)>).)
CopyTo | Copies the entire ReadOnlyCollection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection<(Of <(T>)>). (Inherited from ReadOnlyCollection<(Of <(String>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection<(Of <(T>)>). (Inherited from ReadOnlyCollection<(Of <(String>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection<(Of <(T>)>) instance. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
Item | Gets the element at the specified index. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
Items | Returns the IList<(Of <(T>)>) that the ReadOnlyCollection<(Of <(T>)>) wraps. (Inherited from ReadOnlyCollection<(Of <(String>)>).)

Explicit Interface Implementations

Name | Description
System#Collections#Generic#ICollection{T}#Add | Adds an item to the ICollection<(Of <(T>)>). This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
IList..::.Add | Adds an item to the IList. This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
System#Collections#Generic#ICollection{T}#Clear | Removes all items from the ICollection<(Of <(T>)>). This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
IList..::.Clear | Removes all items from the IList. This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
IList..::.Contains | Determines whether the IList contains a specific value. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
ICollection..::.CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
IList..::.IndexOf | Determines the index of a specific item in the IList. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
System#Collections#Generic#IList{T}#Insert | Inserts an item to the IList<(Of <(T>)>) at the specified index. This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
IList..::.Insert | Inserts an item to the IList at the specified index. This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
IList..::.IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
System#Collections#Generic#ICollection{T}#IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
IList..::.IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
ICollection..::.IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from ReadOnlyCollection<(Of <(String>)>).)
System#Collections#Generic#IList{T}#Item | Gets or sets the element at the specified index. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
IList..::.Item | Gets or sets the element at the specified index. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
System#Collections#Generic#ICollection{T}#Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
IList..::.Remove | Removes the first occurrence of a specific object from the IList. This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
System#Collections#Generic#IList{T}#RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index. This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
IList..::.RemoveAt | Removes the IList item at the specified index. This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
ICollection..::.SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from ReadOnlyCollection<(Of <(String>)>).)

See Also

ReadOnlyLinkOneLicenseCollection Class
Mincom.LinkOne.Dom.Licensing Namespace


ReadOnlyLinkOneLicenseCollection Constructor

[image]

LinkOne WebView API
ReadOnlyLinkOneLicenseCollection Constructor
ReadOnlyLinkOneLicenseCollection Class See Also Send Feedback
Initializes a new instance of the ReadOnlyLinkOneLicenseCollection class.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ReadOnlyLinkOneLicenseCollection(
    LinkOneLicenseCollection licenses
)
Visual Basic (Declaration)
Public Sub New ( _
    licenses As LinkOneLicenseCollection _
)
Visual C++
public:
ReadOnlyLinkOneLicenseCollection(
    LinkOneLicenseCollection^ licenses
)

Parameters

licenses
Type: Mincom.LinkOne.Dom.Licensing..::.LinkOneLicenseCollection
The licenses that this collection wraps.

See Also

ReadOnlyLinkOneLicenseCollection Class
Mincom.LinkOne.Dom.Licensing Namespace


ReadOnlyLinkOneLicenseCollection Methods

[image] [image]

LinkOne WebView API
ReadOnlyLinkOneLicenseCollection Methods
ReadOnlyLinkOneLicenseCollection Class See Also Send Feedback

The ReadOnlyLinkOneLicenseCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the ReadOnlyCollection<(Of <(T>)>). (Inherited from ReadOnlyCollection<(Of <(String>)>).)
CopyTo | Copies the entire ReadOnlyCollection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection<(Of <(T>)>). (Inherited from ReadOnlyCollection<(Of <(String>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection<(Of <(T>)>). (Inherited from ReadOnlyCollection<(Of <(String>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
System#Collections#Generic#ICollection{T}#Add | Adds an item to the ICollection<(Of <(T>)>). This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
IList..::.Add | Adds an item to the IList. This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
System#Collections#Generic#ICollection{T}#Clear | Removes all items from the ICollection<(Of <(T>)>). This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
IList..::.Clear | Removes all items from the IList. This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
IList..::.Contains | Determines whether the IList contains a specific value. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
ICollection..::.CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
IList..::.IndexOf | Determines the index of a specific item in the IList. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
System#Collections#Generic#IList{T}#Insert | Inserts an item to the IList<(Of <(T>)>) at the specified index. This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
IList..::.Insert | Inserts an item to the IList at the specified index. This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
System#Collections#Generic#ICollection{T}#Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
IList..::.Remove | Removes the first occurrence of a specific object from the IList. This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
System#Collections#Generic#IList{T}#RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index. This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
IList..::.RemoveAt | Removes the IList item at the specified index. This implementation always throws NotSupportedException. (Inherited from ReadOnlyCollection<(Of <(String>)>).)

See Also

ReadOnlyLinkOneLicenseCollection Class
Mincom.LinkOne.Dom.Licensing Namespace


ReadOnlyLinkOneLicenseCollection Properties

[image] [image]

LinkOne WebView API
ReadOnlyLinkOneLicenseCollection Properties
ReadOnlyLinkOneLicenseCollection Class See Also Send Feedback

The ReadOnlyLinkOneLicenseCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection<(Of <(T>)>) instance. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
Item | Gets the element at the specified index. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
Items | Returns the IList<(Of <(T>)>) that the ReadOnlyCollection<(Of <(T>)>) wraps. (Inherited from ReadOnlyCollection<(Of <(String>)>).)

Explicit Interface Implementations

Name | Description
IList..::.IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
System#Collections#Generic#ICollection{T}#IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
IList..::.IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
ICollection..::.IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from ReadOnlyCollection<(Of <(String>)>).)
System#Collections#Generic#IList{T}#Item | Gets or sets the element at the specified index. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
IList..::.Item | Gets or sets the element at the specified index. (Inherited from ReadOnlyCollection<(Of <(String>)>).)
ICollection..::.SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from ReadOnlyCollection<(Of <(String>)>).)

See Also

ReadOnlyLinkOneLicenseCollection Class
Mincom.LinkOne.Dom.Licensing Namespace


ViewerLicense Class

[image]

LinkOne WebView API
ViewerLicense Class
Members See Also Send Feedback
Represents a LinkOne viewer license.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public sealed class ViewerLicense : LinkOneLicense
Visual Basic (Declaration)
Public NotInheritable Class ViewerLicense _
    Inherits LinkOneLicense
Visual C++
public ref class ViewerLicense sealed : public LinkOneLicense

Remarks

This type of license is issued by Mincom.
For a ViewerLicense to validate a book, the following conditions must be true:
  • The PublicKey must match the plugin public key.
  • There must also be valid Media Linked or Publisher Linked viewer license installed for the same PluginLicense PublisherCode.
  • There must NOT be an Open viewer license installed, or a Media Linked or Publisher Linked license installed from a different publisher code.
or
  • The plugin decorated with a license.
or
  • The plugin is signed by Mincom.

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.License
Mincom.LinkOne.Dom.Licensing..::.LinkOneLicense
Mincom.LinkOne.Dom.Licensing..::.ViewerLicense

See Also

ViewerLicense Members
Mincom.LinkOne.Dom.Licensing Namespace


ViewerLicense Members

[image] [image]

LinkOne WebView API
ViewerLicense Members
ViewerLicense Class Constructors Methods Properties See Also Send Feedback

The ViewerLicense type exposes the following members.

Constructors

Name | Description
ViewerLicense | Constructor.

Methods

Name | Description
Dispose | Overrides System.ComponentModel.License.Dispose (Inherited from LinkOneLicense.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Sign | Sign this license with the supplied key. (Inherited from LinkOneLicense.)
ToString | Gets an Xml representation of the license (Inherited from LinkOneLicense.)
TryValidate | Returns true if a valid license for the given conditions is found.
Validate | Validates a correct license for the given conditions.

Properties

Name | Description
DaysRemaining | Gets the days remaining if the license will expire. (Inherited from LinkOneLicense.)
Expires | Gets or sets the license expiry date. (Inherited from LinkOneLicense.)
HasExpired | Gets true if the license has expired. (Inherited from LinkOneLicense.)
HasExpires | Gets true if the license will expire. (Inherited from LinkOneLicense.)
IsDecoded | Gets true if the license has decoded corectly. (Inherited from LinkOneLicense.)
Issued | Gets or sets the license issue date. (Inherited from LinkOneLicense.)
Licensee | Gets or sets the Licensee. (Inherited from LinkOneLicense.)
LicenseId | Gets or sets the LicenseId. (Inherited from LinkOneLicense.)
LicenseKey | Supplies a unique string that describes the license (Overrides LinkOneLicense..::.LicenseKey.)
LicenseRestriction | Gets or sets the license restriction type.
PublisherCode | Gets or sets the license publisher code.
Signature | Gets the licenses digital signature. (Inherited from LinkOneLicense.)
Version | Gets or sets the license version specification. (Inherited from LinkOneLicense.)

See Also

ViewerLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


ViewerLicense Constructor

[image]

LinkOne WebView API
ViewerLicense Constructor
ViewerLicense Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ViewerLicense()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewerLicense()

See Also

ViewerLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


ViewerLicense Methods

[image] [image]

LinkOne WebView API
ViewerLicense Methods
ViewerLicense Class See Also Send Feedback

The ViewerLicense type exposes the following members.

Methods

Name | Description
Dispose | Overrides System.ComponentModel.License.Dispose (Inherited from LinkOneLicense.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Sign | Sign this license with the supplied key. (Inherited from LinkOneLicense.)
ToString | Gets an Xml representation of the license (Inherited from LinkOneLicense.)
TryValidate | Returns true if a valid license for the given conditions is found.
Validate | Validates a correct license for the given conditions.

See Also

ViewerLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


TryValidate Method

[image]

LinkOne WebView API
ViewerLicense..::.TryValidate Method
ViewerLicense Class See Also Send Feedback
Returns true if a valid license for the given conditions is found.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static bool TryValidate(
    string publisherCode,
    string contractorCode,
    string serialNumber,
    string contentPath,
    string version,
    LinkOneLicenseCollection licenses
)
Visual Basic (Declaration)
Public Shared Function TryValidate ( _
    publisherCode As String, _
    contractorCode As String, _
    serialNumber As String, _
    contentPath As String, _
    version As String, _
    licenses As LinkOneLicenseCollection _
) As Boolean
Visual C++
public:
static bool TryValidate(
    String^ publisherCode,
    String^ contractorCode,
    String^ serialNumber,
    String^ contentPath,
    String^ version,
    LinkOneLicenseCollection^ licenses
)

Parameters

publisherCode
Type: System..::.String
Publisher code of the LinkOne content.
contractorCode
Type: System..::.String
Contractor code of the LinkOne content.
serialNumber
Type: System..::.String
The publisher serial number of the LinkOne content.
contentPath
Type: System..::.String
Path of the folder containing LinkOne content.
version
Type: System..::.String
The version to validate against.
licenses
Type: Mincom.LinkOne.Dom.Licensing..::.LinkOneLicenseCollection
The licenses to validate against.

Remarks

True if a valid license for the given conditions is found.

See Also

ViewerLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


Validate Method

[image]

LinkOne WebView API
ViewerLicense..::.Validate Method
ViewerLicense Class See Also Send Feedback
Validates a correct license for the given conditions.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static void Validate(
    string publisherCode,
    string contractorCode,
    string serialNumber,
    string contentPath,
    string version,
    LinkOneLicenseCollection licenses
)
Visual Basic (Declaration)
Public Shared Sub Validate ( _
    publisherCode As String, _
    contractorCode As String, _
    serialNumber As String, _
    contentPath As String, _
    version As String, _
    licenses As LinkOneLicenseCollection _
)
Visual C++
public:
static void Validate(
    String^ publisherCode,
    String^ contractorCode,
    String^ serialNumber,
    String^ contentPath,
    String^ version,
    LinkOneLicenseCollection^ licenses
)

Parameters

publisherCode
Type: System..::.String
Publisher code of the LinkOne content.
contractorCode
Type: System..::.String
Contractor code of the LinkOne content.
serialNumber
Type: System..::.String
The publisher serial number of the LinkOne content.
contentPath
Type: System..::.String
Path of the folder containing LinkOne content.
version
Type: System..::.String
The version to validate against.
licenses
Type: Mincom.LinkOne.Dom.Licensing..::.LinkOneLicenseCollection
The licenses to validate against.

See Also

ViewerLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


ViewerLicense Properties

[image] [image]

LinkOne WebView API
ViewerLicense Properties
ViewerLicense Class See Also Send Feedback

The ViewerLicense type exposes the following members.

Properties

Name | Description
DaysRemaining | Gets the days remaining if the license will expire. (Inherited from LinkOneLicense.)
Expires | Gets or sets the license expiry date. (Inherited from LinkOneLicense.)
HasExpired | Gets true if the license has expired. (Inherited from LinkOneLicense.)
HasExpires | Gets true if the license will expire. (Inherited from LinkOneLicense.)
IsDecoded | Gets true if the license has decoded corectly. (Inherited from LinkOneLicense.)
Issued | Gets or sets the license issue date. (Inherited from LinkOneLicense.)
Licensee | Gets or sets the Licensee. (Inherited from LinkOneLicense.)
LicenseId | Gets or sets the LicenseId. (Inherited from LinkOneLicense.)
LicenseKey | Supplies a unique string that describes the license (Overrides LinkOneLicense..::.LicenseKey.)
LicenseRestriction | Gets or sets the license restriction type.
PublisherCode | Gets or sets the license publisher code.
Signature | Gets the licenses digital signature. (Inherited from LinkOneLicense.)
Version | Gets or sets the license version specification. (Inherited from LinkOneLicense.)

See Also

ViewerLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


LicenseKey Property

[image]

LinkOne WebView API
ViewerLicense..::.LicenseKey Property
ViewerLicense Class See Also Send Feedback
Supplies a unique string that describes the license

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string LicenseKey { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LicenseKey As String
Visual C++
public:
virtual property String^ LicenseKey {
    String^ get () override;
}

See Also

ViewerLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


LicenseRestriction Property

[image]

LinkOne WebView API
ViewerLicense..::.LicenseRestriction Property
ViewerLicense Class See Also Send Feedback
Gets or sets the license restriction type.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ViewerLicense..::.LicenseRestrictionType LicenseRestriction { get; set; }
Visual Basic (Declaration)
Public Property LicenseRestriction As ViewerLicense..::.LicenseRestrictionType
Visual C++
public:
property ViewerLicense..::.LicenseRestrictionType LicenseRestriction {
    ViewerLicense..::.LicenseRestrictionType get ();
    void set (ViewerLicense..::.LicenseRestrictionType value);
}

See Also

ViewerLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


PublisherCode Property

[image]

LinkOne WebView API
ViewerLicense..::.PublisherCode Property
ViewerLicense Class See Also Send Feedback
Gets or sets the license publisher code.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PublisherCode { get; set; }
Visual Basic (Declaration)
Public Property PublisherCode As String
Visual C++
public:
property String^ PublisherCode {
    String^ get ();
    void set (String^ value);
}

See Also

ViewerLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


ViewerLicense.LicenseRestrictionType Enumeration

[image]

LinkOne WebView API
ViewerLicense..::.LicenseRestrictionType Enumeration
ViewerLicense Class See Also Send Feedback
This enum defines the various restricted types of Viewer license

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum LicenseRestrictionType
Visual Basic (Declaration)
Public Enumeration LicenseRestrictionType
Visual C++
public enum class LicenseRestrictionType

Members

Member name | Description
Open | An Open license can view content from all publishers.
PublisherLinked | A Publisher-Linked license restricts the viewer to content from a specific publisher code.
MediaLinked | A Media-Linked license restricts the viewer to content from a specific publisher code and also enforces that the content resides on the same read-only media as the Viewer executable.
Mincom | For internal use only.

See Also

Mincom.LinkOne.Dom.Licensing Namespace


WebViewLicense Class

[image]

LinkOne WebView API
WebViewLicense Class
Members See Also Send Feedback
Represents a LinkOne WebView license.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public sealed class WebViewLicense : LinkOneLicense
Visual Basic (Declaration)
Public NotInheritable Class WebViewLicense _
    Inherits LinkOneLicense
Visual C++
public ref class WebViewLicense sealed : public LinkOneLicense

Remarks

This type of license is issued by Mincom.

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.License
Mincom.LinkOne.Dom.Licensing..::.LinkOneLicense
Mincom.LinkOne.Dom.Licensing..::.WebViewLicense

See Also

WebViewLicense Members
Mincom.LinkOne.Dom.Licensing Namespace


WebViewLicense Members

[image] [image]

LinkOne WebView API
WebViewLicense Members
WebViewLicense Class Constructors Methods Properties See Also Send Feedback

The WebViewLicense type exposes the following members.

Constructors

Name | Description
WebViewLicense | Initializes a new instance of the WebViewLicense class.

Methods

Name | Description
Dispose | Overrides System.ComponentModel.License.Dispose (Inherited from LinkOneLicense.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Sign | Sign this license with the supplied key. (Inherited from LinkOneLicense.)
ToString | Gets an Xml representation of the license (Inherited from LinkOneLicense.)
TryValidate | Overloaded.
Validate | Overloaded.

Properties

Name | Description
DaysRemaining | Gets the days remaining if the license will expire. (Inherited from LinkOneLicense.)
Expires | Gets or sets the license expiry date. (Inherited from LinkOneLicense.)
HasExpired | Gets true if the license has expired. (Inherited from LinkOneLicense.)
HasExpires | Gets true if the license will expire. (Inherited from LinkOneLicense.)
IsDecoded | Gets true if the license has decoded corectly. (Inherited from LinkOneLicense.)
Issued | Gets or sets the license issue date. (Inherited from LinkOneLicense.)
Licensee | Gets or sets the Licensee. (Inherited from LinkOneLicense.)
LicenseId | Gets or sets the LicenseId. (Inherited from LinkOneLicense.)
LicenseKey | Supplies a unique string that describes the license (Overrides LinkOneLicense..::.LicenseKey.)
LicenseRestriction | Gets or sets the license restriction type.
Signature | Gets the licenses digital signature. (Inherited from LinkOneLicense.)
Tokens | Gets or sets the license token limit.
Version | Gets or sets the license version specification. (Inherited from LinkOneLicense.)
Website | Gets or sets the license web site.

See Also

WebViewLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


WebViewLicense Constructor

[image]

LinkOne WebView API
WebViewLicense Constructor
WebViewLicense Class See Also Send Feedback
Initializes a new instance of the WebViewLicense class.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public WebViewLicense()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WebViewLicense()

See Also

WebViewLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


WebViewLicense Methods

[image] [image]

LinkOne WebView API
WebViewLicense Methods
WebViewLicense Class See Also Send Feedback

The WebViewLicense type exposes the following members.

Methods

Name | Description
Dispose | Overrides System.ComponentModel.License.Dispose (Inherited from LinkOneLicense.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Sign | Sign this license with the supplied key. (Inherited from LinkOneLicense.)
ToString | Gets an Xml representation of the license (Inherited from LinkOneLicense.)
TryValidate | Overloaded.
Validate | Overloaded.

See Also

WebViewLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


TryValidate Method

[image] [image]

LinkOne WebView API
WebViewLicense..::.TryValidate Method
WebViewLicense Class See Also Send Feedback

Overload List

Name | Description
TryValidate(String, LinkOneLicenseCollection) | Returns true if a valid license for the given conditions is found.
TryValidate(String, String, LinkOneLicenseCollection) | Returns true if a valid license for the given conditions is found.

See Also

WebViewLicense Class
WebViewLicense Members
Mincom.LinkOne.Dom.Licensing Namespace


TryValidate Method (String, LinkOneLicenseCollection)

[image]

LinkOne WebView API
WebViewLicense..::.TryValidate Method (String, LinkOneLicenseCollection)
WebViewLicense Class See Also Send Feedback
Returns true if a valid license for the given conditions is found.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static bool TryValidate(
    string credentials,
    LinkOneLicenseCollection licenses
)
Visual Basic (Declaration)
Public Shared Function TryValidate ( _
    credentials As String, _
    licenses As LinkOneLicenseCollection _
) As Boolean
Visual C++
public:
static bool TryValidate(
    String^ credentials,
    LinkOneLicenseCollection^ licenses
)

Parameters

credentials
Type: System..::.String
The credentials to validate against, which is in the format: "version;website".
licenses
Type: Mincom.LinkOne.Dom.Licensing..::.LinkOneLicenseCollection
The licenses to validate against.

Remarks

True if a valid license for the given conditions is found.

See Also

WebViewLicense Class
TryValidate Overload
Mincom.LinkOne.Dom.Licensing Namespace


TryValidate Method (String, String, LinkOneLicenseCollection)

[image]

LinkOne WebView API
WebViewLicense..::.TryValidate Method (String, String, LinkOneLicenseCollection)
WebViewLicense Class See Also Send Feedback
Returns true if a valid license for the given conditions is found.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static bool TryValidate(
    string website,
    string version,
    LinkOneLicenseCollection licenses
)
Visual Basic (Declaration)
Public Shared Function TryValidate ( _
    website As String, _
    version As String, _
    licenses As LinkOneLicenseCollection _
) As Boolean
Visual C++
public:
static bool TryValidate(
    String^ website,
    String^ version,
    LinkOneLicenseCollection^ licenses
)

Parameters

website
Type: System..::.String
The web site to validate against.
version
Type: System..::.String
The version to validate against.
licenses
Type: Mincom.LinkOne.Dom.Licensing..::.LinkOneLicenseCollection
The licenses to validate against.

Remarks

True if a valid license for the given conditions is found.

See Also

WebViewLicense Class
TryValidate Overload
Mincom.LinkOne.Dom.Licensing Namespace


Validate Method

[image] [image]

LinkOne WebView API
WebViewLicense..::.Validate Method
WebViewLicense Class See Also Send Feedback

Overload List

Name | Description
Validate(String, LinkOneLicenseCollection) | Validates a correct license for the given conditions.
Validate(String, String, LinkOneLicenseCollection) | Validates a correct license for the given conditions.

See Also

WebViewLicense Class
WebViewLicense Members
Mincom.LinkOne.Dom.Licensing Namespace


Validate Method (String, LinkOneLicenseCollection)

[image]

LinkOne WebView API
WebViewLicense..::.Validate Method (String, LinkOneLicenseCollection)
WebViewLicense Class See Also Send Feedback
Validates a correct license for the given conditions.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static void Validate(
    string credentials,
    LinkOneLicenseCollection licenses
)
Visual Basic (Declaration)
Public Shared Sub Validate ( _
    credentials As String, _
    licenses As LinkOneLicenseCollection _
)
Visual C++
public:
static void Validate(
    String^ credentials,
    LinkOneLicenseCollection^ licenses
)

Parameters

credentials
Type: System..::.String
The credentials to validate against, which is in the format: "version;website".
licenses
Type: Mincom.LinkOne.Dom.Licensing..::.LinkOneLicenseCollection
The licenses to validate against.

See Also

WebViewLicense Class
Validate Overload
Mincom.LinkOne.Dom.Licensing Namespace


Validate Method (String, String, LinkOneLicenseCollection)

[image]

LinkOne WebView API
WebViewLicense..::.Validate Method (String, String, LinkOneLicenseCollection)
WebViewLicense Class See Also Send Feedback
Validates a correct license for the given conditions.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static void Validate(
    string website,
    string version,
    LinkOneLicenseCollection licenses
)
Visual Basic (Declaration)
Public Shared Sub Validate ( _
    website As String, _
    version As String, _
    licenses As LinkOneLicenseCollection _
)
Visual C++
public:
static void Validate(
    String^ website,
    String^ version,
    LinkOneLicenseCollection^ licenses
)

Parameters

website
Type: System..::.String
The web site to validate agains.
version
Type: System..::.String
The version to validate against.
licenses
Type: Mincom.LinkOne.Dom.Licensing..::.LinkOneLicenseCollection
The licenses to validate against.

See Also

WebViewLicense Class
Validate Overload
Mincom.LinkOne.Dom.Licensing Namespace


WebViewLicense Properties

[image] [image]

LinkOne WebView API
WebViewLicense Properties
WebViewLicense Class See Also Send Feedback

The WebViewLicense type exposes the following members.

Properties

Name | Description
DaysRemaining | Gets the days remaining if the license will expire. (Inherited from LinkOneLicense.)
Expires | Gets or sets the license expiry date. (Inherited from LinkOneLicense.)
HasExpired | Gets true if the license has expired. (Inherited from LinkOneLicense.)
HasExpires | Gets true if the license will expire. (Inherited from LinkOneLicense.)
IsDecoded | Gets true if the license has decoded corectly. (Inherited from LinkOneLicense.)
Issued | Gets or sets the license issue date. (Inherited from LinkOneLicense.)
Licensee | Gets or sets the Licensee. (Inherited from LinkOneLicense.)
LicenseId | Gets or sets the LicenseId. (Inherited from LinkOneLicense.)
LicenseKey | Supplies a unique string that describes the license (Overrides LinkOneLicense..::.LicenseKey.)
LicenseRestriction | Gets or sets the license restriction type.
Signature | Gets the licenses digital signature. (Inherited from LinkOneLicense.)
Tokens | Gets or sets the license token limit.
Version | Gets or sets the license version specification. (Inherited from LinkOneLicense.)
Website | Gets or sets the license web site.

See Also

WebViewLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


LicenseKey Property

[image]

LinkOne WebView API
WebViewLicense..::.LicenseKey Property
WebViewLicense Class See Also Send Feedback
Supplies a unique string that describes the license

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string LicenseKey { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property LicenseKey As String
Visual C++
public:
virtual property String^ LicenseKey {
    String^ get () override;
}

See Also

WebViewLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


LicenseRestriction Property

[image]

LinkOne WebView API
WebViewLicense..::.LicenseRestriction Property
WebViewLicense Class See Also Send Feedback
Gets or sets the license restriction type.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public WebViewLicense..::.LicenseRestrictionType LicenseRestriction { get; set; }
Visual Basic (Declaration)
Public Property LicenseRestriction As WebViewLicense..::.LicenseRestrictionType
Visual C++
public:
property WebViewLicense..::.LicenseRestrictionType LicenseRestriction {
    WebViewLicense..::.LicenseRestrictionType get ();
    void set (WebViewLicense..::.LicenseRestrictionType value);
}

See Also

WebViewLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


Tokens Property

[image]

LinkOne WebView API
WebViewLicense..::.Tokens Property
WebViewLicense Class See Also Send Feedback
Gets or sets the license token limit.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Tokens { get; set; }
Visual Basic (Declaration)
Public Property Tokens As Integer
Visual C++
public:
property int Tokens {
    int get ();
    void set (int value);
}

See Also

WebViewLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


Website Property

[image]

LinkOne WebView API
WebViewLicense..::.Website Property
WebViewLicense Class See Also Send Feedback
Gets or sets the license web site.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Website { get; set; }
Visual Basic (Declaration)
Public Property Website As String
Visual C++
public:
property String^ Website {
    String^ get ();
    void set (String^ value);
}

See Also

WebViewLicense Class
Mincom.LinkOne.Dom.Licensing Namespace


WebViewLicense.LicenseRestrictionType Enumeration

[image]

LinkOne WebView API
WebViewLicense..::.LicenseRestrictionType Enumeration
WebViewLicense Class See Also Send Feedback
This enum defines the various restricted types of WebView license.

Namespace: Mincom.LinkOne.Dom.Licensing
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum LicenseRestrictionType
Visual Basic (Declaration)
Public Enumeration LicenseRestrictionType
Visual C++
public enum class LicenseRestrictionType

Members

Member name | Description
Open | An Open license can view content from all publishers.
Mincom | For internal use only.

See Also

Mincom.LinkOne.Dom.Licensing Namespace


Mincom.LinkOne.Dom.Notes Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.Dom.Notes Namespace
Send Feedback
The Mincom.LinkOne.Dom.Notes namespace contains classes that provide read/write access to LinkOne notes.

Classes

Class | Description
Bookmark | Represents a LinkOne Bookmark.
CategorizedNote | The base class for a categorized LinkOne note.
Category | Initialises a new instance of a Category.
CategoryCollection | Represents a collection of categories.
CategoryCollection..::.CategoryCollectionWriteState | Implements WriteState<(Of <(T>)>) for NoteCollection.
CrossReferenceNote | A Cross Reference note.
FieldMapping | A class which represents a selection list field mapping note.
FilterNote | A class which represents a Filter note.
Hyperlink | A class which represents a hyperlink on a hyperlink note.
HyperlinkNote | A class which represents a Hyperlink note.
ListNote | The base class for a listable LinkOne note.
MacroNote | A class which represents a Macro note.
Note | The base class for a LinkOne note.
NoteCollection | Represents a collection of notes.
NoteCollection..::.NoteCollectionWriteState | Implements WriteState<(Of <(T>)>) for NoteCollection.
ProgramNote | A class which represents a Program note.
RedlineNote | A class which represents a redline note.
TextNote | A class which represents a Text note.
TranslatedNote | The base class for a translated LinkOne note.
UnknownNote | A class which represents a Unknown note.
ValueNote | A class which represents a Value note.
WriteState<(Of <(T>)>) | Caches the current write state information for the generic type.
WriteStateEvaluator<(Of <(T>)>) | This class is the base class for delayed write determination. See remarks for more details.

Interfaces

Interface | Description
IBookmark | Represents a LinkOne Bookmark.
ICategorizedNote | Represents a note that can be grouped into a category.
ICategory | Represents a category for grouping notes.
ICategoryCollection | Represents a collection of categories.
ICrossReferenceNote | Represents a cross reference note.
IFieldMapping | Represents a selection list field mapping note.
IFilterNote | Represents a filter note.
IHyperlinkNote | Represents a hyperlink note.
IListNote | Represents a list note, a note that can be shown in the notes list.
INote | Represents a LinkOne note.
INoteCollection | Represents a collection of notes.
IProgramNote | Represents a program note.
IRedlineNote | Represents a redline note.
ITextNote | Represents a text note.
ITranslatedNote | Represents a note that is translatable.
IValueNote | Represents a value note.

Enumerations

Enumeration | Description
Access | The visibility of a note or category.
Association | The note association.
FieldMappingSourceType | Defines the source type of a selection list field mapping.
FieldMappingType | Defines the types a selection list field can be mapped to.
NoteBehaviour | The behaviour of a note.
Scope | The scope a note covers.
Status | The state of a note or category.


Access Enumeration

[image]

LinkOne WebView API
Access Enumeration
See Also Send Feedback
The visibility of a note or category.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum Access
Visual Basic (Declaration)
Public Enumeration Access
Visual C++
public enum class Access

Members

Member name | Description
Private | Created by a user and visible only to that user.
Public | Created by a user and visible to all users.
Supplied | Supplied by the publisher and visible to all users.

See Also

Mincom.LinkOne.Dom.Notes Namespace


Association Enumeration

[image]

LinkOne WebView API
Association Enumeration
See Also Send Feedback
The note association.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum Association
Visual Basic (Declaration)
Public Enumeration Association
Visual C++
public enum class Association

Members

Member name | Description
Item | The note is associated with a specific item
PartNumber | The note is associated with a specific part number
Picture | The note is associated with a specific picture.
None | The note has no association

See Also

Mincom.LinkOne.Dom.Notes Namespace


Bookmark Class

[image]

LinkOne WebView API
Bookmark Class
Members See Also Send Feedback
Represents a LinkOne Bookmark.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class Bookmark : TranslatedNote,
    IBookmark, ITranslatedNote, INote
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class Bookmark _
    Inherits TranslatedNote _
    Implements IBookmark, ITranslatedNote, INote
Visual C++
[SerializableAttribute]
public ref class Bookmark sealed : public TranslatedNote,
    IBookmark, ITranslatedNote, INote

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Notes..::.Note
Mincom.LinkOne.Dom.Notes..::.TranslatedNote
Mincom.LinkOne.Dom.Notes..::.Bookmark

See Also

Bookmark Members
Mincom.LinkOne.Dom.Notes Namespace


Bookmark Members

[image] [image]

LinkOne WebView API
Bookmark Members
Bookmark Class Constructors Methods Properties See Also Send Feedback

The Bookmark type exposes the following members.

Constructors

Name | Description
Bookmark | Creates an instance of the Bookmark.

Methods

Name | Description
CanSetAccess | Determines whether this Note instance can set the Access to the specified value. (Inherited from Note.)
CanSetAssociation | Determines whether this Note instance can set Association to the specified value. (Inherited from Note.)
CanSetScope | Determines whether this Note instance can set Scope to the the specified value. (Inherited from Note.)
Clone | Gets a clone of the this. (Inherited from Note.)
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the hash code for the object. (Inherited from Note.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanging | Sets the note status to changed. (Inherited from Note.)
Remove | Sets the note status to Deleted. (Inherited from Note.)
ResolveBookmark | Resolves the bookmark if it refers to another bookmark.
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Overloaded.

Properties

Name | Description
Access | Gets or sets the note access. (Inherited from Note.)
Association | Gets what the note is associated with. (Inherited from Note.)
BookCode | Gets or sets the book code of the note. (Inherited from Note.)
Comment | Gets or sets the comment associated with the bookmark.
DisplayName | See DisplayName for more information. (Overrides Note..::.DisplayName.)
Group | Gets or sets the group identifier of the note. (Inherited from TranslatedNote.)
Id | Gets or sets the unique ID of the note. (Inherited from Note.)
ItemId | See Validate(String) for more information. (Overrides Note..::.ItemId.)
Key | Gets a key that uniquely defines the note. (Inherited from TranslatedNote.)
LanguageCode | Gets or sets the language code. (Inherited from TranslatedNote.)
Name | Gets or sets the name of the bookmark.
OriginalNote | Gets or the original note; or null if the note hasn't changed. (Inherited from Note.)
PageReference | See Validate(String) for more information. (Overrides Note..::.PageReference.)
PartNumber | Gets or sets the part number of the note. (Inherited from Note.)
PictureNumber | Gets or sets the picture number of the redline note. (Inherited from Note.)
PublisherCode | Gets or sets the publisher code of the note. (Inherited from Note.)
Scope | Gets the note scope. (Inherited from Note.)
Status | Gets or sets the status of the note in relation to the copy saved in persistent storage. (Inherited from Note.)
TargetBookCode | Gets or sets the target book code for the Bookmark.
TargetBookmark | Gets or sets the target bookmark for the Bookmark.
TargetItemId | Gets or sets the target item Id for the Bookmark.
TargetPageReference | Gets or sets the target page reference code for the Bookmark.
TargetPublisherCode | Gets or sets the target publisher code for the Bookmark.
TimeStamp | Gets or sets the date and time when the note was last written. (Inherited from Note.)
Translation | See Translation for more information. (Overrides TranslatedNote..::.Translation.)
Xml | Gets the XML representing the note. (Inherited from Note.)

See Also

Bookmark Class
Mincom.LinkOne.Dom.Notes Namespace


Bookmark Constructor

[image]

LinkOne WebView API
Bookmark Constructor
Bookmark Class See Also Send Feedback
Creates an instance of the Bookmark.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Bookmark()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Bookmark()

See Also

Bookmark Class
Mincom.LinkOne.Dom.Notes Namespace


Bookmark Methods

[image] [image]

LinkOne WebView API
Bookmark Methods
Bookmark Class See Also Send Feedback

The Bookmark type exposes the following members.

Methods

Name | Description
CanSetAccess | Determines whether this Note instance can set the Access to the specified value. (Inherited from Note.)
CanSetAssociation | Determines whether this Note instance can set Association to the specified value. (Inherited from Note.)
CanSetScope | Determines whether this Note instance can set Scope to the the specified value. (Inherited from Note.)
Clone | Gets a clone of the this. (Inherited from Note.)
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the hash code for the object. (Inherited from Note.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanging | Sets the note status to changed. (Inherited from Note.)
Remove | Sets the note status to Deleted. (Inherited from Note.)
ResolveBookmark | Resolves the bookmark if it refers to another bookmark.
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Overloaded.

See Also

Bookmark Class
Mincom.LinkOne.Dom.Notes Namespace


Equals Method

[image] [image]

LinkOne WebView API
Bookmark..::.Equals Method
Bookmark Class See Also Send Feedback

Overload List

Name | Description
Equals(Note) | Determines whether the specified note is equal to the current note. (Inherited from Note.)
Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Note.)

See Also

Bookmark Class
Bookmark Members
Mincom.LinkOne.Dom.Notes Namespace


ResolveBookmark Method

[image]

LinkOne WebView API
Bookmark..::.ResolveBookmark Method
Bookmark Class See Also Send Feedback
Resolves the bookmark if it refers to another bookmark.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Bookmark ResolveBookmark(
    NoteCollection notes
)
Visual Basic (Declaration)
Public Function ResolveBookmark ( _
    notes As NoteCollection _
) As Bookmark
Visual C++
public:
Bookmark^ ResolveBookmark(
    NoteCollection^ notes
)

Parameters

notes
Type: Mincom.LinkOne.Dom.Notes..::.NoteCollection
The NoteCollection from which the Bookmark will be located.

Return Value

The resolved bookmark, or null if if the bookmark chain is circular or the bookmark doesn't exist.

Remarks

A Bookmark may reference other Bookmarks via the "TargetBookmark" property. This function returns the Bookmark that is ultimately referred to by this bookmark, containing a publisher/book/page reference.
If no bookmark can be located, or if the bookmark references are recursive then null will be returned.

See Also

Bookmark Class
Mincom.LinkOne.Dom.Notes Namespace


Validate Method

[image] [image]

LinkOne WebView API
Bookmark..::.Validate Method
Bookmark Class See Also Send Feedback

Overload List

Name | Description
Validate(String) | See Validate(String) for more information. (Overrides Note..::.Validate(String).)
Validate(Access, String, String, String, String, String, Int32) | Validates the given properties for a note. (Inherited from Note.)

See Also

Bookmark Class
Bookmark Members
Mincom.LinkOne.Dom.Notes Namespace


Validate Method (String)

[image]

LinkOne WebView API
Bookmark..::.Validate Method (String)
Bookmark Class See Also Send Feedback
See Validate(String) for more information.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override bool Validate(
    string propertyName
)
Visual Basic (Declaration)
Public Overrides Function Validate ( _
    propertyName As String _
) As Boolean
Visual C++
public:
virtual bool Validate(
    String^ propertyName
) override

Parameters

propertyName
Type: System..::.String

See Also

Bookmark Class
Validate Overload
Mincom.LinkOne.Dom.Notes Namespace


Bookmark Properties

[image] [image]

LinkOne WebView API
Bookmark Properties
Bookmark Class See Also Send Feedback

The Bookmark type exposes the following members.

Properties

Name | Description
Access | Gets or sets the note access. (Inherited from Note.)
Association | Gets what the note is associated with. (Inherited from Note.)
BookCode | Gets or sets the book code of the note. (Inherited from Note.)
Comment | Gets or sets the comment associated with the bookmark.
DisplayName | See DisplayName for more information. (Overrides Note..::.DisplayName.)
Group | Gets or sets the group identifier of the note. (Inherited from TranslatedNote.)
Id | Gets or sets the unique ID of the note. (Inherited from Note.)
ItemId | See Validate(String) for more information. (Overrides Note..::.ItemId.)
Key | Gets a key that uniquely defines the note. (Inherited from TranslatedNote.)
LanguageCode | Gets or sets the language code. (Inherited from TranslatedNote.)
Name | Gets or sets the name of the bookmark.
OriginalNote | Gets or the original note; or null if the note hasn't changed. (Inherited from Note.)
PageReference | See Validate(String) for more information. (Overrides Note..::.PageReference.)
PartNumber | Gets or sets the part number of the note. (Inherited from Note.)
PictureNumber | Gets or sets the picture number of the redline note. (Inherited from Note.)
PublisherCode | Gets or sets the publisher code of the note. (Inherited from Note.)
Scope | Gets the note scope. (Inherited from Note.)
Status | Gets or sets the status of the note in relation to the copy saved in persistent storage. (Inherited from Note.)
TargetBookCode | Gets or sets the target book code for the Bookmark.
TargetBookmark | Gets or sets the target bookmark for the Bookmark.
TargetItemId | Gets or sets the target item Id for the Bookmark.
TargetPageReference | Gets or sets the target page reference code for the Bookmark.
TargetPublisherCode | Gets or sets the target publisher code for the Bookmark.
TimeStamp | Gets or sets the date and time when the note was last written. (Inherited from Note.)
Translation | See Translation for more information. (Overrides TranslatedNote..::.Translation.)
Xml | Gets the XML representing the note. (Inherited from Note.)

See Also

Bookmark Class
Mincom.LinkOne.Dom.Notes Namespace


Comment Property

[image]

LinkOne WebView API
Bookmark..::.Comment Property
Bookmark Class See Also Send Feedback
Gets or sets the comment associated with the bookmark.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Comment { get; set; }
Visual Basic (Declaration)
Public Property Comment As String
Visual C++
public:
virtual property String^ Comment {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IBookmark..::.Comment

See Also

Bookmark Class
Mincom.LinkOne.Dom.Notes Namespace


DisplayName Property

[image]

LinkOne WebView API
Bookmark..::.DisplayName Property
Bookmark Class See Also Send Feedback
See DisplayName for more information.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string DisplayName { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DisplayName As String
Visual C++
public:
virtual property String^ DisplayName {
    String^ get () override;
}

See Also

Bookmark Class
Mincom.LinkOne.Dom.Notes Namespace


ItemId Property

[image]

LinkOne WebView API
Bookmark..::.ItemId Property
Bookmark Class See Also Send Feedback
See Validate(String) for more information.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string ItemId { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property ItemId As String
Visual C++
public:
virtual property String^ ItemId {
    void set (String^ value) override;
}

Implements

INote..::.ItemId
INote..::.ItemId

Remarks

A Bookmark is not permitted to have an Item Id.

See Also

Bookmark Class
Mincom.LinkOne.Dom.Notes Namespace


Name Property

[image]

LinkOne WebView API
Bookmark..::.Name Property
Bookmark Class See Also Send Feedback
Gets or sets the name of the bookmark.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IBookmark..::.Name

See Also

Bookmark Class
Mincom.LinkOne.Dom.Notes Namespace


PageReference Property

[image]

LinkOne WebView API
Bookmark..::.PageReference Property
Bookmark Class See Also Send Feedback
See Validate(String) for more information.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string PageReference { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property PageReference As String
Visual C++
public:
virtual property String^ PageReference {
    void set (String^ value) override;
}

Implements

INote..::.PageReference
INote..::.PageReference

Remarks

A Bookmark is not permitted to have a page reference.

See Also

Bookmark Class
Mincom.LinkOne.Dom.Notes Namespace


TargetBookCode Property

[image]

LinkOne WebView API
Bookmark..::.TargetBookCode Property
Bookmark Class See Also Send Feedback
Gets or sets the target book code for the Bookmark.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string TargetBookCode { get; set; }
Visual Basic (Declaration)
Public Property TargetBookCode As String
Visual C++
public:
virtual property String^ TargetBookCode {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Field Value

The target book code.

Implements

IBookmark..::.TargetBookCode

See Also

Bookmark Class
Mincom.LinkOne.Dom.Notes Namespace


TargetBookmark Property

[image]

LinkOne WebView API
Bookmark..::.TargetBookmark Property
Bookmark Class See Also Send Feedback
Gets or sets the target bookmark for the Bookmark.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string TargetBookmark { get; set; }
Visual Basic (Declaration)
Public Property TargetBookmark As String
Visual C++
public:
virtual property String^ TargetBookmark {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Field Value

The bookmark for the Bookmark.

Implements

IBookmark..::.TargetBookmark

Remarks

If the TargetBookmark is not blank, then the TargetPageReference and TargetItemId properties are ignored.

See Also

Bookmark Class
Mincom.LinkOne.Dom.Notes Namespace


TargetItemId Property

[image]

LinkOne WebView API
Bookmark..::.TargetItemId Property
Bookmark Class See Also Send Feedback
Gets or sets the target item Id for the Bookmark.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string TargetItemId { get; set; }
Visual Basic (Declaration)
Public Property TargetItemId As String
Visual C++
public:
virtual property String^ TargetItemId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Field Value

The target item Id for the Bookmark.

Implements

IBookmark..::.TargetItemId

Remarks

If the TargetBookmark is set to a non blank value, then the TargetItemId property is ignored.

See Also

Bookmark Class
Mincom.LinkOne.Dom.Notes Namespace


TargetPageReference Property

[image]

LinkOne WebView API
Bookmark..::.TargetPageReference Property
Bookmark Class See Also Send Feedback
Gets or sets the target page reference code for the Bookmark.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string TargetPageReference { get; set; }
Visual Basic (Declaration)
Public Property TargetPageReference As String
Visual C++
public:
virtual property String^ TargetPageReference {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Field Value

The target page reference for the Bookmark.

Implements

IBookmark..::.TargetPageReference

Remarks

If the TargetBookmark is set to a non blank value, then the TargetPageReference property is ignored.

See Also

Bookmark Class
Mincom.LinkOne.Dom.Notes Namespace


TargetPublisherCode Property

[image]

LinkOne WebView API
Bookmark..::.TargetPublisherCode Property
Bookmark Class See Also Send Feedback
Gets or sets the target publisher code for the Bookmark.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string TargetPublisherCode { get; set; }
Visual Basic (Declaration)
Public Property TargetPublisherCode As String
Visual C++
public:
virtual property String^ TargetPublisherCode {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Field Value

The target publisher code.

Implements

IBookmark..::.TargetPublisherCode

See Also

Bookmark Class
Mincom.LinkOne.Dom.Notes Namespace


Translation Property

[image]

LinkOne WebView API
Bookmark..::.Translation Property
Bookmark Class See Also Send Feedback
See Translation for more information.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string Translation { get; set; }
Visual Basic (Declaration)
Public Overrides Property Translation As String
Visual C++
public:
virtual property String^ Translation {
    String^ get () override;
    void set (String^ value) override;
}

Implements

ITranslatedNote..::.Translation
ITranslatedNote..::.Translation

See Also

Bookmark Class
Mincom.LinkOne.Dom.Notes Namespace


CategorizedNote Class

[image]

LinkOne WebView API
CategorizedNote Class
Members See Also Send Feedback
The base class for a categorized LinkOne note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public abstract class CategorizedNote : TranslatedNote,
    ICategorizedNote, ITranslatedNote, INote
Visual Basic (Declaration)
<SerializableAttribute> _
Public MustInherit Class CategorizedNote _
    Inherits TranslatedNote _
    Implements ICategorizedNote, ITranslatedNote, INote
Visual C++
[SerializableAttribute]
public ref class CategorizedNote abstract : public TranslatedNote,
    ICategorizedNote, ITranslatedNote, INote

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Notes..::.Note
Mincom.LinkOne.Dom.Notes..::.TranslatedNote
Mincom.LinkOne.Dom.Notes..::.CategorizedNote
Mincom.LinkOne.Dom.Notes..::.ListNote
Mincom.LinkOne.Dom.Notes..::.RedlineNote

See Also

CategorizedNote Members
Mincom.LinkOne.Dom.Notes Namespace


CategorizedNote Members

[image] [image]

LinkOne WebView API
CategorizedNote Members
CategorizedNote Class Constructors Methods Properties See Also Send Feedback

The CategorizedNote type exposes the following members.

Constructors

Name | Description
CategorizedNote | Creates an instance of the CategorizedNote.

Methods

Name | Description
CanSetAccess | Determines whether this Note instance can set the Access to the specified value. (Inherited from Note.)
CanSetAssociation | Determines whether this Note instance can set Association to the specified value. (Inherited from Note.)
CanSetScope | Determines whether this Note instance can set Scope to the the specified value. (Inherited from Note.)
Clone | Gets a clone of the this. (Inherited from Note.)
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the hash code for the object. (Inherited from Note.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanging | Sets the note status to changed. (Inherited from Note.)
Remove | Sets the note status to Deleted. (Inherited from Note.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Overloaded.

Properties

Name | Description
Access | Gets or sets the note access. (Inherited from Note.)
Association | Gets what the note is associated with. (Inherited from Note.)
BookCode | Gets or sets the book code of the note. (Inherited from Note.)
Category | Gets or sets the note category.
Description | Gets or sets the description of the note.
DisplayName | See DisplayName for more information. (Overrides Note..::.DisplayName.)
Group | Gets or sets the group identifier of the note. (Inherited from TranslatedNote.)
Id | Gets or sets the unique ID of the note. (Inherited from Note.)
ItemId | Gets or sets the item ID of the note. (Inherited from Note.)
Key | Gets a key that uniquely defines the note. (Overrides TranslatedNote..::.Key.)
LanguageCode | Gets or sets the language code. (Inherited from TranslatedNote.)
OriginalNote | Gets or the original note; or null if the note hasn't changed. (Inherited from Note.)
PageReference | Gets or sets the page reference of the note. (Inherited from Note.)
PartNumber | Gets or sets the part number of the note. (Inherited from Note.)
PictureNumber | Gets or sets the picture number of the redline note. (Inherited from Note.)
PublisherCode | Gets or sets the publisher code of the note. (Inherited from Note.)
Scope | Gets the note scope. (Inherited from Note.)
Status | Gets or sets the status of the note in relation to the copy saved in persistent storage. (Inherited from Note.)
TimeStamp | Gets or sets the date and time when the note was last written. (Inherited from Note.)
Translation | Gets or sets the translation of the note. (Inherited from TranslatedNote.)
Xml | Gets the XML representing the note. (Inherited from Note.)

See Also

CategorizedNote Class
Mincom.LinkOne.Dom.Notes Namespace


CategorizedNote Constructor

[image]

LinkOne WebView API
CategorizedNote Constructor
CategorizedNote Class See Also Send Feedback
Creates an instance of the CategorizedNote.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected CategorizedNote()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
CategorizedNote()

See Also

CategorizedNote Class
Mincom.LinkOne.Dom.Notes Namespace


CategorizedNote Methods

[image] [image]

LinkOne WebView API
CategorizedNote Methods
CategorizedNote Class See Also Send Feedback

The CategorizedNote type exposes the following members.

Methods

Name | Description
CanSetAccess | Determines whether this Note instance can set the Access to the specified value. (Inherited from Note.)
CanSetAssociation | Determines whether this Note instance can set Association to the specified value. (Inherited from Note.)
CanSetScope | Determines whether this Note instance can set Scope to the the specified value. (Inherited from Note.)
Clone | Gets a clone of the this. (Inherited from Note.)
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the hash code for the object. (Inherited from Note.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanging | Sets the note status to changed. (Inherited from Note.)
Remove | Sets the note status to Deleted. (Inherited from Note.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Overloaded.

See Also

CategorizedNote Class
Mincom.LinkOne.Dom.Notes Namespace


Equals Method

[image] [image]

LinkOne WebView API
CategorizedNote..::.Equals Method
CategorizedNote Class See Also Send Feedback

Overload List

Name | Description
Equals(Note) | Determines whether the specified note is equal to the current note. (Inherited from Note.)
Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Note.)

See Also

CategorizedNote Class
CategorizedNote Members
Mincom.LinkOne.Dom.Notes Namespace


Validate Method

[image] [image]

LinkOne WebView API
CategorizedNote..::.Validate Method
CategorizedNote Class See Also Send Feedback

Overload List

Name | Description
Validate(String) | Gets the validity of the given named property. (Inherited from Note.)
Validate(Access, String, String, String, String, String, Int32) | Validates the given properties for a note. (Inherited from Note.)

See Also

CategorizedNote Class
CategorizedNote Members
Mincom.LinkOne.Dom.Notes Namespace


CategorizedNote Properties

[image] [image]

LinkOne WebView API
CategorizedNote Properties
CategorizedNote Class See Also Send Feedback

The CategorizedNote type exposes the following members.

Properties

Name | Description
Access | Gets or sets the note access. (Inherited from Note.)
Association | Gets what the note is associated with. (Inherited from Note.)
BookCode | Gets or sets the book code of the note. (Inherited from Note.)
Category | Gets or sets the note category.
Description | Gets or sets the description of the note.
DisplayName | See DisplayName for more information. (Overrides Note..::.DisplayName.)
Group | Gets or sets the group identifier of the note. (Inherited from TranslatedNote.)
Id | Gets or sets the unique ID of the note. (Inherited from Note.)
ItemId | Gets or sets the item ID of the note. (Inherited from Note.)
Key | Gets a key that uniquely defines the note. (Overrides TranslatedNote..::.Key.)
LanguageCode | Gets or sets the language code. (Inherited from TranslatedNote.)
OriginalNote | Gets or the original note; or null if the note hasn't changed. (Inherited from Note.)
PageReference | Gets or sets the page reference of the note. (Inherited from Note.)
PartNumber | Gets or sets the part number of the note. (Inherited from Note.)
PictureNumber | Gets or sets the picture number of the redline note. (Inherited from Note.)
PublisherCode | Gets or sets the publisher code of the note. (Inherited from Note.)
Scope | Gets the note scope. (Inherited from Note.)
Status | Gets or sets the status of the note in relation to the copy saved in persistent storage. (Inherited from Note.)
TimeStamp | Gets or sets the date and time when the note was last written. (Inherited from Note.)
Translation | Gets or sets the translation of the note. (Inherited from TranslatedNote.)
Xml | Gets the XML representing the note. (Inherited from Note.)

See Also

CategorizedNote Class
Mincom.LinkOne.Dom.Notes Namespace


Category Property

[image]

LinkOne WebView API
CategorizedNote..::.Category Property
CategorizedNote Class See Also Send Feedback
Gets or sets the note category.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Category { get; set; }
Visual Basic (Declaration)
Public Property Category As String
Visual C++
public:
virtual property String^ Category {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ICategorizedNote..::.Category

See Also

CategorizedNote Class
Mincom.LinkOne.Dom.Notes Namespace


Description Property

[image]

LinkOne WebView API
CategorizedNote..::.Description Property
CategorizedNote Class See Also Send Feedback
Gets or sets the description of the note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
virtual property String^ Description {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ICategorizedNote..::.Description

See Also

CategorizedNote Class
Mincom.LinkOne.Dom.Notes Namespace


DisplayName Property

[image]

LinkOne WebView API
CategorizedNote..::.DisplayName Property
CategorizedNote Class See Also Send Feedback
See DisplayName for more information.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string DisplayName { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DisplayName As String
Visual C++
public:
virtual property String^ DisplayName {
    String^ get () override;
}

See Also

CategorizedNote Class
Mincom.LinkOne.Dom.Notes Namespace


Key Property

[image]

LinkOne WebView API
CategorizedNote..::.Key Property
CategorizedNote Class See Also Send Feedback
Gets a key that uniquely defines the note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected override string Key { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property Key As String
Visual C++
protected:
virtual property String^ Key {
    String^ get () override;
}

See Also

CategorizedNote Class
Mincom.LinkOne.Dom.Notes Namespace


Category Class

[image]

LinkOne WebView API
Category Class
Members See Also Send Feedback
Initialises a new instance of a Category.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class Category : ICategory
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class Category _
    Implements ICategory
Visual C++
[SerializableAttribute]
public ref class Category sealed : ICategory

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Notes..::.Category

See Also

Category Members
Mincom.LinkOne.Dom.Notes Namespace


Category Members

[image] [image]

LinkOne WebView API
Category Members
Category Class Constructors Methods Properties See Also Send Feedback

The Category type exposes the following members.

Constructors

Name | Description
Category | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetDisplayNameForLanguage | Gets the display name of the category.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Sets the category status to Deleted.
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Gets the validity of the given named property.

Properties

Name | Description
Access | Gets or sets the access.
Code | Gets or sets the category code.
ImageId | Gets or sets the image id.
IsPredefinedImage | Gets or sets the value whether the image chosen is a predefined image.
LanguageCode | Gets or sets the language code.
OriginalCategory | Gets or the original category; or null if the category hasn't changed.
PublisherCode | Gets or sets the publisher code for a supplied category.
Scope | Gets the scope of the category.
Status | Gets or sets the status of the category in relation to the copy saved in persistent storage.
TimeStamp | Gets or sets the date and time when the category was last written.
Translation | Gets or sets the translation.
Visible | Gets or sets the visibility.

See Also

Category Class
Mincom.LinkOne.Dom.Notes Namespace


Category Constructor

[image] [image]

LinkOne WebView API
Category Constructor
Category Class See Also Send Feedback

Overload List

Name | Description
Category()()() | Initializes a new instance of the Category class.
Category(Access, String, String, String, Boolean, Boolean, String, String, DateTime) | Initializes a new instance of the Category class.

See Also

Category Class
Category Members
Mincom.LinkOne.Dom.Notes Namespace


Category Constructor

[image]

LinkOne WebView API
Category Constructor
Category Class See Also Send Feedback
Initializes a new instance of the Category class.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Category()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Category()

See Also

Category Class
Category Overload
Mincom.LinkOne.Dom.Notes Namespace


Category Constructor (Access, String, String, String, Boolean, Boolean, String, String, DateTime)

[image]

LinkOne WebView API
Category Constructor (Access, String, String, String, Boolean, Boolean, String, String, DateTime)
Category Class See Also Send Feedback
Initializes a new instance of the Category class.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Category(
    Access access,
    string code,
    string publisherCode,
    string imageId,
    bool isPredefinedImage,
    bool visibility,
    string languageCode,
    string translation,
    DateTime timestamp
)
Visual Basic (Declaration)
Public Sub New ( _
    access As Access, _
    code As String, _
    publisherCode As String, _
    imageId As String, _
    isPredefinedImage As Boolean, _
    visibility As Boolean, _
    languageCode As String, _
    translation As String, _
    timestamp As DateTime _
)
Visual C++
public:
Category(
    Access access,
    String^ code,
    String^ publisherCode,
    String^ imageId,
    bool isPredefinedImage,
    bool visibility,
    String^ languageCode,
    String^ translation,
    DateTime timestamp
)

Parameters

access
Type: Mincom.LinkOne.Dom.Notes..::.Access
The access type of the category. Can be private/public/supplied.
code
Type: System..::.String
The category code.
publisherCode
Type: System..::.String
The publisher code if a supplied category.
imageId
Type: System..::.String
The image id associated with the category.
isPredefinedImage
Type: System..::.Boolean
The value that determines whether the image chosen for the category is a predefined image.
visibility
Type: System..::.Boolean
The value that determines of the category is visible or not.
languageCode
Type: System..::.String
The language code associated with the category.
translation
Type: System..::.String
The translation associated with the category.
timestamp
Type: System..::.DateTime
The time stamp this category was last edited.

See Also

Category Class
Category Overload
Mincom.LinkOne.Dom.Notes Namespace


Category Methods

[image] [image]

LinkOne WebView API
Category Methods
Category Class See Also Send Feedback

The Category type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetDisplayNameForLanguage | Gets the display name of the category.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Sets the category status to Deleted.
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Gets the validity of the given named property.

See Also

Category Class
Mincom.LinkOne.Dom.Notes Namespace


GetDisplayNameForLanguage Method

[image]

LinkOne WebView API
Category..::.GetDisplayNameForLanguage Method
Category Class See Also Send Feedback
Gets the display name of the category.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string GetDisplayNameForLanguage(
    string languageCode
)
Visual Basic (Declaration)
Public Function GetDisplayNameForLanguage ( _
    languageCode As String _
) As String
Visual C++
public:
String^ GetDisplayNameForLanguage(
    String^ languageCode
)

Parameters

languageCode
Type: System..::.String

See Also

Category Class
Mincom.LinkOne.Dom.Notes Namespace


Remove Method

[image]

LinkOne WebView API
Category..::.Remove Method
Category Class See Also Send Feedback
Sets the category status to Deleted.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Remove()
Visual Basic (Declaration)
Public Sub Remove
Visual C++
public:
virtual void Remove() sealed

Implements

ICategory..::.Remove()()()

See Also

Category Class
Mincom.LinkOne.Dom.Notes Namespace


Validate Method

[image]

LinkOne WebView API
Category..::.Validate Method
Category Class See Also Send Feedback
Gets the validity of the given named property.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Validate(
    string property
)
Visual Basic (Declaration)
Public Function Validate ( _
    property As String _
) As Boolean
Visual C++
public:
bool Validate(
    String^ property
)

Parameters

property
Type: System..::.String
The name of the property to validate.

Return Value

True if the given named property is valid; otherwise False.

See Also

Category Class
Mincom.LinkOne.Dom.Notes Namespace


Category Properties

[image] [image]

LinkOne WebView API
Category Properties
Category Class See Also Send Feedback

The Category type exposes the following members.

Properties

Name | Description
Access | Gets or sets the access.
Code | Gets or sets the category code.
ImageId | Gets or sets the image id.
IsPredefinedImage | Gets or sets the value whether the image chosen is a predefined image.
LanguageCode | Gets or sets the language code.
OriginalCategory | Gets or the original category; or null if the category hasn't changed.
PublisherCode | Gets or sets the publisher code for a supplied category.
Scope | Gets the scope of the category.
Status | Gets or sets the status of the category in relation to the copy saved in persistent storage.
TimeStamp | Gets or sets the date and time when the category was last written.
Translation | Gets or sets the translation.
Visible | Gets or sets the visibility.

See Also

Category Class
Mincom.LinkOne.Dom.Notes Namespace


Access Property

[image]

LinkOne WebView API
Category..::.Access Property
Category Class See Also Send Feedback
Gets or sets the access.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Access Access { get; set; }
Visual Basic (Declaration)
Public Property Access As Access
Visual C++
public:
virtual property Access Access {
    Access get () sealed;
    void set (Access value) sealed;
}

Implements

ICategory..::.Access

See Also

Category Class
Mincom.LinkOne.Dom.Notes Namespace


Code Property

[image]

LinkOne WebView API
Category..::.Code Property
Category Class See Also Send Feedback
Gets or sets the category code.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Code { get; set; }
Visual Basic (Declaration)
Public Property Code As String
Visual C++
public:
virtual property String^ Code {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ICategory..::.Code

See Also

Category Class
Mincom.LinkOne.Dom.Notes Namespace


ImageId Property

[image]

LinkOne WebView API
Category..::.ImageId Property
Category Class See Also Send Feedback
Gets or sets the image id.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string ImageId { get; set; }
Visual Basic (Declaration)
Public Property ImageId As String
Visual C++
public:
virtual property String^ ImageId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ICategory..::.ImageId

See Also

Category Class
Mincom.LinkOne.Dom.Notes Namespace


IsPredefinedImage Property

[image]

LinkOne WebView API
Category..::.IsPredefinedImage Property
Category Class See Also Send Feedback
Gets or sets the value whether the image chosen is a predefined image.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsPredefinedImage { get; set; }
Visual Basic (Declaration)
Public Property IsPredefinedImage As Boolean
Visual C++
public:
property bool IsPredefinedImage {
    bool get ();
    void set (bool value);
}

See Also

Category Class
Mincom.LinkOne.Dom.Notes Namespace


LanguageCode Property

[image]

LinkOne WebView API
Category..::.LanguageCode Property
Category Class See Also Send Feedback
Gets or sets the language code.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string LanguageCode { get; set; }
Visual Basic (Declaration)
Public Property LanguageCode As String
Visual C++
public:
virtual property String^ LanguageCode {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ICategory..::.LanguageCode

See Also

Category Class
Mincom.LinkOne.Dom.Notes Namespace


OriginalCategory Property

[image]

LinkOne WebView API
Category..::.OriginalCategory Property
Category Class See Also Send Feedback
Gets or the original category; or null if the category hasn't changed.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Category OriginalCategory { get; }
Visual Basic (Declaration)
Public ReadOnly Property OriginalCategory As Category
Visual C++
public:
property Category^ OriginalCategory {
    Category^ get ();
}

See Also

Category Class
Mincom.LinkOne.Dom.Notes Namespace


PublisherCode Property

[image]

LinkOne WebView API
Category..::.PublisherCode Property
Category Class See Also Send Feedback
Gets or sets the publisher code for a supplied category.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PublisherCode { get; set; }
Visual Basic (Declaration)
Public Property PublisherCode As String
Visual C++
public:
virtual property String^ PublisherCode {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ICategory..::.PublisherCode

See Also

Category Class
Mincom.LinkOne.Dom.Notes Namespace


Scope Property

[image]

LinkOne WebView API
Category..::.Scope Property
Category Class See Also Send Feedback
Gets the scope of the category.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Scope Scope { get; }
Visual Basic (Declaration)
Public ReadOnly Property Scope As Scope
Visual C++
public:
virtual property Scope Scope {
    Scope get () sealed;
}

Implements

ICategory..::.Scope

See Also

Category Class
Mincom.LinkOne.Dom.Notes Namespace


Status Property

[image]

LinkOne WebView API
Category..::.Status Property
Category Class See Also Send Feedback
Gets or sets the status of the category in relation to the copy saved in persistent storage.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Status Status { get; set; }
Visual Basic (Declaration)
Public Property Status As Status
Visual C++
public:
virtual property Status Status {
    Status get () sealed;
    void set (Status value) sealed;
}

Implements

ICategory..::.Status

See Also

Category Class
Mincom.LinkOne.Dom.Notes Namespace


TimeStamp Property

[image]

LinkOne WebView API
Category..::.TimeStamp Property
Category Class See Also Send Feedback
Gets or sets the date and time when the category was last written.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public DateTime TimeStamp { get; set; }
Visual Basic (Declaration)
Public Property TimeStamp As DateTime
Visual C++
public:
virtual property DateTime TimeStamp {
    DateTime get () sealed;
    void set (DateTime value) sealed;
}

Implements

ICategory..::.TimeStamp

See Also

Category Class
Mincom.LinkOne.Dom.Notes Namespace


Translation Property

[image]

LinkOne WebView API
Category..::.Translation Property
Category Class See Also Send Feedback
Gets or sets the translation.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Translation { get; set; }
Visual Basic (Declaration)
Public Property Translation As String
Visual C++
public:
virtual property String^ Translation {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ICategory..::.Translation

See Also

Category Class
Mincom.LinkOne.Dom.Notes Namespace


Visible Property

[image]

LinkOne WebView API
Category..::.Visible Property
Category Class See Also Send Feedback
Gets or sets the visibility.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

See Also

Category Class
Mincom.LinkOne.Dom.Notes Namespace


CategoryCollection Class

[image]

LinkOne WebView API
CategoryCollection Class
Members See Also Send Feedback
Represents a collection of categories.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class CategoryCollection : ICollection<Category>,
    IEnumerable<Category>, ICategoryCollection, ICollection<ICategory>,
    IEnumerable<ICategory>, IEnumerable, IPersist
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class CategoryCollection _
    Implements ICollection(Of Category), IEnumerable(Of Category),  _
    ICategoryCollection, ICollection(Of ICategory), IEnumerable(Of ICategory),  _
    IEnumerable, IPersist
Visual C++
[SerializableAttribute]
public ref class CategoryCollection sealed : ICollection<Category^>,
    IEnumerable<Category^>, ICategoryCollection, ICollection<ICategory^>,
    IEnumerable<ICategory^>, IEnumerable, IPersist

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Notes..::.CategoryCollection

See Also

CategoryCollection Members
Mincom.LinkOne.Dom.Notes Namespace


CategoryCollection Members

[image] [image]

LinkOne WebView API
CategoryCollection Members
CategoryCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The CategoryCollection type exposes the following members.

Constructors

Name | Description
CategoryCollection | Initializes a new instance of the CategoryCollection class.

Methods

Name | Description
Add | Adds the specified category.
AddUnique |
CanWrite | Determines if a Category can be written in the context of the current collection.
Clear | Removes all items from the collection.
Contains | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetCategories | Returns a new collection of categories from the collection that match the given language.
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTranslations | Returns a collection of translated categories from the collection that are for the given category.
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given category.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Merge | Merges a collection of categories to the collection.
MergeUnique |
Remove | Removes the specified category.
SetCanWrite | Sets the can create status of a specific category access in the context of the current category collection.
SetCreationAccessAndScope | Sets the most restrictive scope available in the collection for creation of the given category.
SetWriteStateEvaluator | Set the delayed write permissions evaluator for this collection.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements contained in the collection.
HasChanged | Gets true if the any of the categories in the collection have been changed.
IsReadOnly | Gets a value indicating whether the collection is read-only, always returns false.
Item | Overloaded.
PrivateIcons |
PrivateImages | Gets or sets the private images or null if none found.
SuppliedIcons |
SuppliedImages | Gets or sets the supplied publisher images or null if none found.

Explicit Interface Implementations

Name | Description
ICollection<(Of <(ICategory>)>)..::.Add |
ICollection<(Of <(ICategory>)>)..::.Clear |
ICategoryCollection..::.Contains |
ICollection<(Of <(ICategory>)>)..::.Contains |
CopyTo | Overloaded.
ICollection<(Of <(ICategory>)>)..::.Count |
ICategoryCollection..::.Create |
IEnumerable<(Of <(ICategory>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.
ICollection<(Of <(ICategory>)>)..::.IsReadOnly |
ICategoryCollection..::.Item |
ICollection<(Of <(ICategory>)>)..::.Remove |

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


CategoryCollection Constructor

[image]

LinkOne WebView API
CategoryCollection Constructor
CategoryCollection Class See Also Send Feedback
Initializes a new instance of the CategoryCollection class.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public CategoryCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CategoryCollection()

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


CategoryCollection Methods

[image] [image]

LinkOne WebView API
CategoryCollection Methods
CategoryCollection Class See Also Send Feedback

The CategoryCollection type exposes the following members.

Methods

Name | Description
Add | Adds the specified category.
AddUnique |
CanWrite | Determines if a Category can be written in the context of the current collection.
Clear | Removes all items from the collection.
Contains | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetCategories | Returns a new collection of categories from the collection that match the given language.
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTranslations | Returns a collection of translated categories from the collection that are for the given category.
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given category.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Merge | Merges a collection of categories to the collection.
MergeUnique |
Remove | Removes the specified category.
SetCanWrite | Sets the can create status of a specific category access in the context of the current category collection.
SetCreationAccessAndScope | Sets the most restrictive scope available in the collection for creation of the given category.
SetWriteStateEvaluator | Set the delayed write permissions evaluator for this collection.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ICollection<(Of <(ICategory>)>)..::.Add |
ICollection<(Of <(ICategory>)>)..::.Clear |
ICategoryCollection..::.Contains |
ICollection<(Of <(ICategory>)>)..::.Contains |
CopyTo | Overloaded.
ICategoryCollection..::.Create |
IEnumerable<(Of <(ICategory>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.
ICollection<(Of <(ICategory>)>)..::.Remove |

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


ICollection(ICategory).Add Method

[image]

LinkOne WebView API
CategoryCollection..::.ICollection<(Of <(ICategory>)>)..::.Add Method
CategoryCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<ICategory>.Add(
    ICategory item
)
Visual Basic (Declaration)
Private Sub Add ( _
    item As ICategory _
) Implements ICollection(Of ICategory).Add
Visual C++
private:
virtual void Add(
    ICategory^ item
) sealed = ICollection<ICategory^>::Add

Parameters

item
Type: Mincom.LinkOne.Dom.Notes..::.ICategory

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


ICollection(ICategory).Clear Method

[image]

LinkOne WebView API
CategoryCollection..::.ICollection<(Of <(ICategory>)>)..::.Clear Method
CategoryCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<ICategory>.Clear()
Visual Basic (Declaration)
Private Sub Clear Implements ICollection(Of ICategory).Clear
Visual C++
private:
virtual void Clear() sealed = ICollection<ICategory^>::Clear

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


ICollection(ICategory).Contains Method

[image]

LinkOne WebView API
CategoryCollection..::.ICollection<(Of <(ICategory>)>)..::.Contains Method
CategoryCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<ICategory>.Contains(
    ICategory item
)
Visual Basic (Declaration)
Private Function Contains ( _
    item As ICategory _
) As Boolean Implements ICollection(Of ICategory).Contains
Visual C++
private:
virtual bool Contains(
    ICategory^ item
) sealed = ICollection<ICategory^>::Contains

Parameters

item
Type: Mincom.LinkOne.Dom.Notes..::.ICategory

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


IEnumerable(ICategory).GetEnumerator Method

[image]

LinkOne WebView API
CategoryCollection..::.IEnumerable<(Of <(ICategory>)>)..::.GetEnumerator Method
CategoryCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator<ICategory> IEnumerable<ICategory>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of ICategory)
    Implements IEnumerable(Of ICategory).GetEnumerator
Visual C++
private:
virtual IEnumerator<ICategory^>^ GetEnumerator() sealed = IEnumerable<ICategory^>::GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
CategoryCollection..::.IEnumerable..::.GetEnumerator Method
CategoryCollection Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


ICollection(ICategory).Remove Method

[image]

LinkOne WebView API
CategoryCollection..::.ICollection<(Of <(ICategory>)>)..::.Remove Method
CategoryCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<ICategory>.Remove(
    ICategory item
)
Visual Basic (Declaration)
Private Function Remove ( _
    item As ICategory _
) As Boolean Implements ICollection(Of ICategory).Remove
Visual C++
private:
virtual bool Remove(
    ICategory^ item
) sealed = ICollection<ICategory^>::Remove

Parameters

item
Type: Mincom.LinkOne.Dom.Notes..::.ICategory

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


Add Method

[image]

LinkOne WebView API
CategoryCollection..::.Add Method
CategoryCollection Class See Also Send Feedback
Adds the specified category.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Add(
    Category item
)
Visual Basic (Declaration)
Public Sub Add ( _
    item As Category _
)
Visual C++
public:
virtual void Add(
    Category^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Dom.Notes..::.Category
The category to add.

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


AddUnique Method

[image]

LinkOne WebView API
CategoryCollection..::.AddUnique Method
CategoryCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void AddUnique(
    Category item
)
Visual Basic (Declaration)
Public Sub AddUnique ( _
    item As Category _
)
Visual C++
public:
void AddUnique(
    Category^ item
)

Parameters

item
Type: Mincom.LinkOne.Dom.Notes..::.Category

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


CanWrite Method

[image]

LinkOne WebView API
CategoryCollection..::.CanWrite Method
CategoryCollection Class See Also Send Feedback
Determines if a Category can be written in the context of the current collection.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool CanWrite(
    Access access
)
Visual Basic (Declaration)
Public Function CanWrite ( _
    access As Access _
) As Boolean
Visual C++
public:
bool CanWrite(
    Access access
)

Parameters

access
Type: Mincom.LinkOne.Dom.Notes..::.Access
The access type of the category.

Return Value

True if a category can be written for the collection, otherwise false.

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


Clear Method

[image]

LinkOne WebView API
CategoryCollection..::.Clear Method
CategoryCollection Class See Also Send Feedback
Removes all items from the collection.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
virtual void Clear() sealed

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


Contains Method

[image] [image]

LinkOne WebView API
CategoryCollection..::.Contains Method
CategoryCollection Class See Also Send Feedback

Overload List

Name | Description
Contains(Category) | Determines whether the specified category is in the collection.
Contains(String) | Returns true if the given category code is present in the collection.
Contains(String, String) |

See Also

CategoryCollection Class
CategoryCollection Members
Mincom.LinkOne.Dom.Notes Namespace


Contains Method (Category)

[image]

LinkOne WebView API
CategoryCollection..::.Contains Method (Category)
CategoryCollection Class See Also Send Feedback
Determines whether the specified category is in the collection.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    Category item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As Category _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Category^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Dom.Notes..::.Category
The category to search for.

Return Value

true if found in the collection, otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

CategoryCollection Class
Contains Overload
Mincom.LinkOne.Dom.Notes Namespace


Contains Method (String)

[image]

LinkOne WebView API
CategoryCollection..::.Contains Method (String)
CategoryCollection Class See Also Send Feedback
Returns true if the given category code is present in the collection.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    string categoryCode
)
Visual Basic (Declaration)
Public Function Contains ( _
    categoryCode As String _
) As Boolean
Visual C++
public:
bool Contains(
    String^ categoryCode
)

Parameters

categoryCode
Type: System..::.String
The category code to check for.

Return Value

True if the given category code is present in the collection.

See Also

CategoryCollection Class
Contains Overload
Mincom.LinkOne.Dom.Notes Namespace


Contains Method (String, String)

[image]

LinkOne WebView API
CategoryCollection..::.Contains Method (String, String)
CategoryCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    string categoryCode,
    string languageCode
)
Visual Basic (Declaration)
Public Function Contains ( _
    categoryCode As String, _
    languageCode As String _
) As Boolean
Visual C++
public:
bool Contains(
    String^ categoryCode,
    String^ languageCode
)

Parameters

categoryCode
Type: System..::.String
languageCode
Type: System..::.String

See Also

CategoryCollection Class
Contains Overload
Mincom.LinkOne.Dom.Notes Namespace


CopyTo Method

[image] [image]

LinkOne WebView API
CategoryCollection..::.CopyTo Method
CategoryCollection Class See Also Send Feedback

Overload List

Name | Description
ICollection<(Of <(Category>)>)..::.CopyTo(array<Category>[]()[], Int32) |
ICollection<(Of <(ICategory>)>)..::.CopyTo(array<ICategory>[]()[], Int32) |

See Also

CategoryCollection Class
CategoryCollection Members
Mincom.LinkOne.Dom.Notes Namespace


ICollection(Category).CopyTo Method (Category[], Int32)

[image]

LinkOne WebView API
CategoryCollection..::.ICollection<(Of <(Category>)>)..::.CopyTo Method (array<Category>[]()[], Int32)
CategoryCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<Category>.CopyTo(
    Category[] array,
    int arrayIndex
)
Visual Basic (Declaration)
Private Sub CopyTo ( _
    array As Category(), _
    arrayIndex As Integer _
) Implements ICollection(Of Category).CopyTo
Visual C++
private:
virtual void CopyTo(
    array<Category^>^ array,
    int arrayIndex
) sealed = ICollection<Category^>::CopyTo

Parameters

array
Type: array< Mincom.LinkOne.Dom.Notes..::.Category >[]()[]
arrayIndex
Type: System..::.Int32

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

CategoryCollection Class
CategoryCollection Overload
Mincom.LinkOne.Dom.Notes Namespace


ICollection(ICategory).CopyTo Method (ICategory[], Int32)

[image]

LinkOne WebView API
CategoryCollection..::.ICollection<(Of <(ICategory>)>)..::.CopyTo Method (array<ICategory>[]()[], Int32)
CategoryCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<ICategory>.CopyTo(
    ICategory[] array,
    int arrayIndex
)
Visual Basic (Declaration)
Private Sub CopyTo ( _
    array As ICategory(), _
    arrayIndex As Integer _
) Implements ICollection(Of ICategory).CopyTo
Visual C++
private:
virtual void CopyTo(
    array<ICategory^>^ array,
    int arrayIndex
) sealed = ICollection<ICategory^>::CopyTo

Parameters

array
Type: array< Mincom.LinkOne.Dom.Notes..::.ICategory >[]()[]
arrayIndex
Type: System..::.Int32

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

CategoryCollection Class
CategoryCollection Overload
Mincom.LinkOne.Dom.Notes Namespace


GetCategories Method

[image]

LinkOne WebView API
CategoryCollection..::.GetCategories Method
CategoryCollection Class See Also Send Feedback
Returns a new collection of categories from the collection that match the given language.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public CategoryCollection GetCategories(
    string languageCode
)
Visual Basic (Declaration)
Public Function GetCategories ( _
    languageCode As String _
) As CategoryCollection
Visual C++
public:
CategoryCollection^ GetCategories(
    String^ languageCode
)

Parameters

languageCode
Type: System..::.String
The language code of the wanted categories.

Return Value

A new collection of categories from the collection that match the given language code.

Remarks

A category that exactly matches the language has precedence, otherwise the first category found for a code is included.

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


GetEnumerator Method

[image]

LinkOne WebView API
CategoryCollection..::.GetEnumerator Method
CategoryCollection Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IEnumerator<Category> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of Category)
Visual C++
public:
virtual IEnumerator<Category^>^ GetEnumerator() sealed

Return Value

A IEnumerator<(Of <(T>)>) that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


GetTranslations Method

[image]

LinkOne WebView API
CategoryCollection..::.GetTranslations Method
CategoryCollection Class See Also Send Feedback
Returns a collection of translated categories from the collection that are for the given category.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public CategoryCollection GetTranslations(
    Category category
)
Visual Basic (Declaration)
Public Function GetTranslations ( _
    category As Category _
) As CategoryCollection
Visual C++
public:
CategoryCollection^ GetTranslations(
    Category^ category
)

Parameters

category
Type: Mincom.LinkOne.Dom.Notes..::.Category
The category to get the tanslations for.

Return Value

A collection of translated categories from the collection that match the given category code.

Remarks

Any categories that match the category code but have no translation will not be in the returned collection.
The result collection will not include the given category.

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


ICategoryCollection.Contains Method

[image]

LinkOne WebView API
CategoryCollection..::.ICategoryCollection..::.Contains Method
CategoryCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICategoryCollection.Contains(
    string categoryCode
)
Visual Basic (Declaration)
Private Function Contains ( _
    categoryCode As String _
) As Boolean Implements ICategoryCollection.Contains
Visual C++
private:
virtual bool Contains(
    String^ categoryCode
) sealed = ICategoryCollection::Contains

Parameters

categoryCode
Type: System..::.String

Implements

ICategoryCollection..::.Contains(String)

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


ICategoryCollection.Create Method

[image]

LinkOne WebView API
CategoryCollection..::.ICategoryCollection..::.Create Method
CategoryCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ICategory ICategoryCollection.Create()
Visual Basic (Declaration)
Private Function Create As ICategory Implements ICategoryCollection.Create
Visual C++
private:
virtual ICategory^ Create() sealed = ICategoryCollection::Create

Implements

ICategoryCollection..::.Create()()()

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


IndexOf Method

[image]

LinkOne WebView API
CategoryCollection..::.IndexOf Method
CategoryCollection Class See Also Send Feedback
Searches the collection and returns the zero-based index of the first occurence of the given category.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int IndexOf(
    Category category
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    category As Category _
) As Integer
Visual C++
public:
int IndexOf(
    Category^ category
)

Parameters

category
Type: Mincom.LinkOne.Dom.Notes..::.Category
The category to search for.

Return Value

The zero-based index of the category in the collection, if found; otherwise, -1.

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


Merge Method

[image]

LinkOne WebView API
CategoryCollection..::.Merge Method
CategoryCollection Class See Also Send Feedback
Merges a collection of categories to the collection.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Merge(
    CategoryCollection categories
)
Visual Basic (Declaration)
Public Sub Merge ( _
    categories As CategoryCollection _
)
Visual C++
public:
void Merge(
    CategoryCollection^ categories
)

Parameters

categories
Type: Mincom.LinkOne.Dom.Notes..::.CategoryCollection
The collection of categories to be merged with the collection.

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


MergeUnique Method

[image]

LinkOne WebView API
CategoryCollection..::.MergeUnique Method
CategoryCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void MergeUnique(
    CategoryCollection categories
)
Visual Basic (Declaration)
Public Sub MergeUnique ( _
    categories As CategoryCollection _
)
Visual C++
public:
void MergeUnique(
    CategoryCollection^ categories
)

Parameters

categories
Type: Mincom.LinkOne.Dom.Notes..::.CategoryCollection

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


Remove Method

[image]

LinkOne WebView API
CategoryCollection..::.Remove Method
CategoryCollection Class See Also Send Feedback
Removes the specified category.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Remove(
    Category item
)
Visual Basic (Declaration)
Public Function Remove ( _
    item As Category _
) As Boolean
Visual C++
public:
virtual bool Remove(
    Category^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Dom.Notes..::.Category
The category.

Return Value

true if item is successfully removed; otherwise, false. This method also returns false if item was not found in the ICategoryCollection.

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


SetCanWrite Method

[image]

LinkOne WebView API
CategoryCollection..::.SetCanWrite Method
CategoryCollection Class See Also Send Feedback
Sets the can create status of a specific category access in the context of the current category collection.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void SetCanWrite(
    Access access,
    bool state
)
Visual Basic (Declaration)
Public Sub SetCanWrite ( _
    access As Access, _
    state As Boolean _
)
Visual C++
public:
void SetCanWrite(
    Access access,
    bool state
)

Parameters

access
Type: Mincom.LinkOne.Dom.Notes..::.Access
The category access type.
state
Type: System..::.Boolean
Whether or not the category file is writeable.

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


SetCreationAccessAndScope Method

[image]

LinkOne WebView API
CategoryCollection..::.SetCreationAccessAndScope Method
CategoryCollection Class See Also Send Feedback
Sets the most restrictive scope available in the collection for creation of the given category.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool SetCreationAccessAndScope(
    Category category,
    string publisherCode
)
Visual Basic (Declaration)
Public Function SetCreationAccessAndScope ( _
    category As Category, _
    publisherCode As String _
) As Boolean
Visual C++
public:
bool SetCreationAccessAndScope(
    Category^ category,
    String^ publisherCode
)

Parameters

category
Type: Mincom.LinkOne.Dom.Notes..::.Category
The category to set the scope on.
publisherCode
Type: System..::.String
The publisher code wanting to store the category at.

Return Value

True if access and scope were set, or false if no access and scope available for creation.

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


SetWriteStateEvaluator Method

[image]

LinkOne WebView API
CategoryCollection..::.SetWriteStateEvaluator Method
CategoryCollection Class See Also Send Feedback
Set the delayed write permissions evaluator for this collection.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void SetWriteStateEvaluator(
    WriteStateEvaluator<CategoryCollection> evaluator
)
Visual Basic (Declaration)
Public Sub SetWriteStateEvaluator ( _
    evaluator As WriteStateEvaluator(Of CategoryCollection) _
)
Visual C++
public:
void SetWriteStateEvaluator(
    WriteStateEvaluator<CategoryCollection^>^ evaluator
)

Parameters

evaluator
Type: Mincom.LinkOne.Dom.Notes..::.WriteStateEvaluator <(Of <( CategoryCollection >)>)
The permissions evaluator.

Remarks

This method allows write permission evaluation to be delayed until actually read and required.

If there is an existing evalutor, it is invoked before setting the new one.

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace
Mincom.LinkOne.Dom.Notes..::.WriteStateEvaluator<(Of <(T>)>)


CategoryCollection Properties

[image] [image]

LinkOne WebView API
CategoryCollection Properties
CategoryCollection Class See Also Send Feedback

The CategoryCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements contained in the collection.
HasChanged | Gets true if the any of the categories in the collection have been changed.
IsReadOnly | Gets a value indicating whether the collection is read-only, always returns false.
Item | Overloaded.
PrivateIcons |
PrivateImages | Gets or sets the private images or null if none found.
SuppliedIcons |
SuppliedImages | Gets or sets the supplied publisher images or null if none found.

Explicit Interface Implementations

Name | Description
ICollection<(Of <(ICategory>)>)..::.Count |
ICollection<(Of <(ICategory>)>)..::.IsReadOnly |
ICategoryCollection..::.Item |

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


ICollection(ICategory).Count Property

[image]

LinkOne WebView API
CategoryCollection..::.ICollection<(Of <(ICategory>)>)..::.Count Property
CategoryCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int ICollection<ICategory>.Count { get; }
Visual Basic (Declaration)
Private ReadOnly Property Count As Integer
    Implements ICollection(Of ICategory).Count
Visual C++
private:
virtual property int Count {
    int get () sealed = ICollection<ICategory^>::Count::get;
}

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


ICollection(ICategory).IsReadOnly Property

[image]

LinkOne WebView API
CategoryCollection..::.ICollection<(Of <(ICategory>)>)..::.IsReadOnly Property
CategoryCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<ICategory>.IsReadOnly { get; }
Visual Basic (Declaration)
Private ReadOnly Property IsReadOnly As Boolean
    Implements ICollection(Of ICategory).IsReadOnly
Visual C++
private:
virtual property bool IsReadOnly {
    bool get () sealed = ICollection<ICategory^>::IsReadOnly::get;
}

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


Count Property

[image]

LinkOne WebView API
CategoryCollection..::.Count Property
CategoryCollection Class See Also Send Feedback
Gets the number of elements contained in the collection.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Return Value

The number of elements contained in the collection.

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


HasChanged Property

[image]

LinkOne WebView API
CategoryCollection..::.HasChanged Property
CategoryCollection Class See Also Send Feedback
Gets true if the any of the categories in the collection have been changed.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool HasChanged { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasChanged As Boolean
Visual C++
public:
property bool HasChanged {
    bool get ();
}

Remarks

Changed categories include new categories and categories which have been marked for deletion.

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


ICategoryCollection.Item Property

[image]

LinkOne WebView API
CategoryCollection..::.ICategoryCollection..::.Item Property
CategoryCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ICategory ICategoryCollection.Item[
    string categoryCode
] { get; }
Visual Basic (Declaration)
Private ReadOnly Property Item ( _
    categoryCode As String _
) As ICategory Implements ICategoryCollection.Item
Visual C++
private:
virtual property ICategory^ Item[String^ categoryCode] {
    ICategory^ get (String^ categoryCode) sealed = ICategoryCollection::Item::get;
}

Parameters

categoryCode
Type: System..::.String

Implements

ICategoryCollection..::.Item[([(String])])

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


IsReadOnly Property

[image]

LinkOne WebView API
CategoryCollection..::.IsReadOnly Property
CategoryCollection Class See Also Send Feedback
Gets a value indicating whether the collection is read-only, always returns false.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


Item Property

[image] [image]

LinkOne WebView API
CategoryCollection..::.Item Property
CategoryCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Gets the Category at the specified index.
Item[([(String])]) | Gets the first Category with the specified category code.

See Also

CategoryCollection Class
CategoryCollection Members
Mincom.LinkOne.Dom.Notes Namespace


Item Property (Int32)

[image]

LinkOne WebView API
CategoryCollection..::.Item Property (Int32)
CategoryCollection Class See Also Send Feedback
Gets the Category at the specified index.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Category this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Category
Visual C++
public:
property Category^ default[int index] {
    Category^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

CategoryCollection Class
Item Overload
Mincom.LinkOne.Dom.Notes Namespace


Item Property (String)

[image]

LinkOne WebView API
CategoryCollection..::.Item Property (String)
CategoryCollection Class See Also Send Feedback
Gets the first Category with the specified category code.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Category this[
    string categoryCode
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    categoryCode As String _
) As Category
Visual C++
public:
property Category^ default[String^ categoryCode] {
    Category^ get (String^ categoryCode);
}

Parameters

categoryCode
Type: System..::.String
The category code to check for.

See Also

CategoryCollection Class
Item Overload
Mincom.LinkOne.Dom.Notes Namespace


PrivateIcons Property

[image]

LinkOne WebView API
CategoryCollection..::.PrivateIcons Property
CategoryCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public List<string> PrivateIcons { get; set; }
Visual Basic (Declaration)
Public Property PrivateIcons As List(Of String)
Visual C++
public:
property List<String^>^ PrivateIcons {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


PrivateImages Property

[image]

LinkOne WebView API
CategoryCollection..::.PrivateImages Property
CategoryCollection Class See Also Send Feedback
Gets or sets the private images or null if none found.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Image PrivateImages { get; set; }
Visual Basic (Declaration)
Public Property PrivateImages As Image
Visual C++
public:
property Image^ PrivateImages {
    Image^ get ();
    void set (Image^ value);
}

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


SuppliedIcons Property

[image]

LinkOne WebView API
CategoryCollection..::.SuppliedIcons Property
CategoryCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public List<string> SuppliedIcons { get; set; }
Visual Basic (Declaration)
Public Property SuppliedIcons As List(Of String)
Visual C++
public:
property List<String^>^ SuppliedIcons {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


SuppliedImages Property

[image]

LinkOne WebView API
CategoryCollection..::.SuppliedImages Property
CategoryCollection Class See Also Send Feedback
Gets or sets the supplied publisher images or null if none found.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Image SuppliedImages { get; set; }
Visual Basic (Declaration)
Public Property SuppliedImages As Image
Visual C++
public:
property Image^ SuppliedImages {
    Image^ get ();
    void set (Image^ value);
}

See Also

CategoryCollection Class
Mincom.LinkOne.Dom.Notes Namespace


CategoryCollection.CategoryCollectionWriteState Class

[image]

LinkOne WebView API
CategoryCollection..::.CategoryCollectionWriteState Class
CategoryCollection Class Members See Also Send Feedback
Implements WriteState<(Of <(T>)>) for NoteCollection.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public class CategoryCollectionWriteState : WriteState<CategoryCollection>
Visual Basic (Declaration)
Public Class CategoryCollectionWriteState _
    Inherits WriteState(Of CategoryCollection)
Visual C++
public ref class CategoryCollectionWriteState : public WriteState<CategoryCollection^>

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Notes..::.WriteState <(Of <( CategoryCollection >)>)
Mincom.LinkOne.Dom.Notes..::.CategoryCollection..::.CategoryCollectionWriteState

See Also

CategoryCollection..::.CategoryCollectionWriteState Members
Mincom.LinkOne.Dom.Notes Namespace


CategoryCollection.CategoryCollectionWriteState Members

[image] [image]

LinkOne WebView API
CategoryCollection..::.CategoryCollectionWriteState Members
CategoryCollection..::.CategoryCollectionWriteState Class Constructors Methods See Also Send Feedback

Represents a collection of categories.

The CategoryCollection..::.CategoryCollectionWriteState type exposes the following members.

Constructors

Name | Description
CategoryCollection..::.CategoryCollectionWriteState | Initializes a new instance of the CategoryCollection..::.CategoryCollectionWriteState class

Methods

Name | Description
ApplyState | Sets to write flags from internal values. (Overrides WriteState<(Of <(T>)>)..::.ApplyState(T).)
CacheState | Stores write flags from from. (Overrides WriteState<(Of <(T>)>)..::.CacheState(T).)
Clear | Clears internal write flags to None()()(). (Overrides WriteState<(Of <(T>)>)..::.Clear()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Merge | Merges mergeFrom write flags with internal values. (Overrides WriteState<(Of <(T>)>)..::.Merge(T).)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CategoryCollection..::.CategoryCollectionWriteState Class
Mincom.LinkOne.Dom.Notes Namespace


CategoryCollection.CategoryCollectionWriteState Constructor

[image]

LinkOne WebView API
CategoryCollection..::.CategoryCollectionWriteState Constructor
CategoryCollection..::.CategoryCollectionWriteState Class See Also Send Feedback
Initializes a new instance of the CategoryCollection..::.CategoryCollectionWriteState class

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public CategoryCollectionWriteState()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CategoryCollectionWriteState()

See Also

CategoryCollection..::.CategoryCollectionWriteState Class
Mincom.LinkOne.Dom.Notes Namespace


CategoryCollection.CategoryCollectionWriteState Methods

[image] [image]

LinkOne WebView API
CategoryCollection..::.CategoryCollectionWriteState Methods
CategoryCollection..::.CategoryCollectionWriteState Class See Also Send Feedback

The CategoryCollection..::.CategoryCollectionWriteState type exposes the following members.

Methods

Name | Description
ApplyState | Sets to write flags from internal values. (Overrides WriteState<(Of <(T>)>)..::.ApplyState(T).)
CacheState | Stores write flags from from. (Overrides WriteState<(Of <(T>)>)..::.CacheState(T).)
Clear | Clears internal write flags to None()()(). (Overrides WriteState<(Of <(T>)>)..::.Clear()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Merge | Merges mergeFrom write flags with internal values. (Overrides WriteState<(Of <(T>)>)..::.Merge(T).)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CategoryCollection..::.CategoryCollectionWriteState Class
Mincom.LinkOne.Dom.Notes Namespace


ApplyState Method

[image]

LinkOne WebView API
CategoryCollection..::.CategoryCollectionWriteState..::.ApplyState Method
CategoryCollection..::.CategoryCollectionWriteState Class See Also Send Feedback
Sets to write flags from internal values.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override void ApplyState(
    CategoryCollection to
)
Visual Basic (Declaration)
Public Overrides Sub ApplyState ( _
    to As CategoryCollection _
)
Visual C++
public:
virtual void ApplyState(
    CategoryCollection^ to
) override

Parameters

to
Type: Mincom.LinkOne.Dom.Notes..::.CategoryCollection
To write to.

See Also

CategoryCollection..::.CategoryCollectionWriteState Class
Mincom.LinkOne.Dom.Notes Namespace


CacheState Method

[image]

LinkOne WebView API
CategoryCollection..::.CategoryCollectionWriteState..::.CacheState Method
CategoryCollection..::.CategoryCollectionWriteState Class See Also Send Feedback
Stores write flags from from.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override void CacheState(
    CategoryCollection from
)
Visual Basic (Declaration)
Public Overrides Sub CacheState ( _
    from As CategoryCollection _
)
Visual C++
public:
virtual void CacheState(
    CategoryCollection^ from
) override

Parameters

from
Type: Mincom.LinkOne.Dom.Notes..::.CategoryCollection
To cache from.

See Also

CategoryCollection..::.CategoryCollectionWriteState Class
Mincom.LinkOne.Dom.Notes Namespace


Clear Method

[image]

LinkOne WebView API
CategoryCollection..::.CategoryCollectionWriteState..::.Clear Method
CategoryCollection..::.CategoryCollectionWriteState Class See Also Send Feedback
Clears internal write flags to None()()().

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override void Clear()
Visual Basic (Declaration)
Public Overrides Sub Clear
Visual C++
public:
virtual void Clear() override

See Also

CategoryCollection..::.CategoryCollectionWriteState Class
Mincom.LinkOne.Dom.Notes Namespace


Merge Method

[image]

LinkOne WebView API
CategoryCollection..::.CategoryCollectionWriteState..::.Merge Method
CategoryCollection..::.CategoryCollectionWriteState Class See Also Send Feedback
Merges mergeFrom write flags with internal values.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override void Merge(
    CategoryCollection mergeFrom
)
Visual Basic (Declaration)
Public Overrides Sub Merge ( _
    mergeFrom As CategoryCollection _
)
Visual C++
public:
virtual void Merge(
    CategoryCollection^ mergeFrom
) override

Parameters

mergeFrom
Type: Mincom.LinkOne.Dom.Notes..::.CategoryCollection
To merge from.

See Also

CategoryCollection..::.CategoryCollectionWriteState Class
Mincom.LinkOne.Dom.Notes Namespace


CrossReferenceNote Class

[image]

LinkOne WebView API
CrossReferenceNote Class
Members See Also Send Feedback
A Cross Reference note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class CrossReferenceNote : ListNote,
    ICrossReferenceNote, ICategorizedNote, ITranslatedNote, INote
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class CrossReferenceNote _
    Inherits ListNote _
    Implements ICrossReferenceNote, ICategorizedNote, ITranslatedNote, INote
Visual C++
[SerializableAttribute]
public ref class CrossReferenceNote sealed : public ListNote,
    ICrossReferenceNote, ICategorizedNote, ITranslatedNote, INote

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Notes..::.Note
Mincom.LinkOne.Dom.Notes..::.TranslatedNote
Mincom.LinkOne.Dom.Notes..::.CategorizedNote
Mincom.LinkOne.Dom.Notes..::.ListNote
Mincom.LinkOne.Dom.Notes..::.CrossReferenceNote

See Also

CrossReferenceNote Members
Mincom.LinkOne.Dom.Notes Namespace


CrossReferenceNote Members

[image] [image]

LinkOne WebView API
CrossReferenceNote Members
CrossReferenceNote Class Constructors Methods Properties See Also Send Feedback

The CrossReferenceNote type exposes the following members.

Constructors

Name | Description
CrossReferenceNote | Creates an instance of the CrossReferenceNote.

Methods

Name | Description
CanSetAccess | Determines whether this Note instance can set the Access to the specified value. (Inherited from Note.)
CanSetAssociation | Determines whether this Note instance can set Association to the specified value. (Inherited from Note.)
CanSetScope | Determines whether this Note instance can set Scope to the the specified value. (Inherited from Note.)
Clone | Gets a clone of the this. (Inherited from Note.)
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the hash code for the object. (Inherited from Note.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanging | Sets the note status to changed. (Inherited from Note.)
Remove | Sets the note status to Deleted. (Inherited from Note.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Overloaded.

Properties

Name | Description
Access | Gets or sets the note access. (Inherited from Note.)
Association | Gets what the note is associated with. (Inherited from Note.)
Behaviour | Gets or sets the note behaviour. (Inherited from ListNote.)
BookCode | Gets or sets the book code of the note. (Inherited from Note.)
Category | Gets or sets the note category. (Inherited from CategorizedNote.)
Description | Gets or sets the description of the note. (Inherited from CategorizedNote.)
DisplayName | See DisplayName for more information. (Inherited from CategorizedNote.)
Group | Gets or sets the group identifier of the note. (Inherited from TranslatedNote.)
Id | Gets or sets the unique ID of the note. (Inherited from Note.)
IsListNote | Gets or sets whether the note appears in the notes list. (Inherited from ListNote.)
ItemId | Gets or sets the item ID of the note. (Inherited from Note.)
Key | Gets a key that uniquely defines the note. (Inherited from ListNote.)
LanguageCode | Gets or sets the language code. (Inherited from TranslatedNote.)
OriginalNote | Gets or the original note; or null if the note hasn't changed. (Inherited from Note.)
PageReference | Gets or sets the page reference of the note. (Inherited from Note.)
PartNumber | Gets or sets the part number of the note. (Inherited from Note.)
PictureNumber | Gets or sets the picture number of the redline note. (Inherited from Note.)
Prompt | Gets or sets the prompt for the cross reference note.
PublisherCode | Gets or sets the publisher code of the note. (Inherited from Note.)
Scope | Gets the note scope. (Inherited from Note.)
Status | Gets or sets the status of the note in relation to the copy saved in persistent storage. (Inherited from Note.)
TargetBookCode | Gets or sets the target book code for the cross reference note.
TargetBookmark | Gets or sets the target bookmark for the cross reference note.
TargetItemId | Gets or sets the target item Id for the cross reference note.
TargetPageReference | Gets or sets the target page reference code for the cross reference note.
TargetPublisherCode | Gets or sets the target publisher code for the cross reference note.
TimeStamp | Gets or sets the date and time when the note was last written. (Inherited from Note.)
Translation | See Translation for more information. (Overrides TranslatedNote..::.Translation.)
Xml | Gets the XML representing the note. (Inherited from Note.)

See Also

CrossReferenceNote Class
Mincom.LinkOne.Dom.Notes Namespace


CrossReferenceNote Constructor

[image]

LinkOne WebView API
CrossReferenceNote Constructor
CrossReferenceNote Class See Also Send Feedback
Creates an instance of the CrossReferenceNote.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public CrossReferenceNote()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CrossReferenceNote()

See Also

CrossReferenceNote Class
Mincom.LinkOne.Dom.Notes Namespace


CrossReferenceNote Methods

[image] [image]

LinkOne WebView API
CrossReferenceNote Methods
CrossReferenceNote Class See Also Send Feedback

The CrossReferenceNote type exposes the following members.

Methods

Name | Description
CanSetAccess | Determines whether this Note instance can set the Access to the specified value. (Inherited from Note.)
CanSetAssociation | Determines whether this Note instance can set Association to the specified value. (Inherited from Note.)
CanSetScope | Determines whether this Note instance can set Scope to the the specified value. (Inherited from Note.)
Clone | Gets a clone of the this. (Inherited from Note.)
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the hash code for the object. (Inherited from Note.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanging | Sets the note status to changed. (Inherited from Note.)
Remove | Sets the note status to Deleted. (Inherited from Note.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Overloaded.

See Also

CrossReferenceNote Class
Mincom.LinkOne.Dom.Notes Namespace


Equals Method

[image] [image]

LinkOne WebView API
CrossReferenceNote..::.Equals Method
CrossReferenceNote Class See Also Send Feedback

Overload List

Name | Description
Equals(Note) | Determines whether the specified note is equal to the current note. (Inherited from Note.)
Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Note.)

See Also

CrossReferenceNote Class
CrossReferenceNote Members
Mincom.LinkOne.Dom.Notes Namespace


Validate Method

[image] [image]

LinkOne WebView API
CrossReferenceNote..::.Validate Method
CrossReferenceNote Class See Also Send Feedback

Overload List

Name | Description
Validate(String) | See Validate(String) for more information. (Overrides Note..::.Validate(String).)
Validate(Access, String, String, String, String, String, Int32) | Validates the given properties for a note. (Inherited from Note.)

See Also

CrossReferenceNote Class
CrossReferenceNote Members
Mincom.LinkOne.Dom.Notes Namespace


Validate Method (String)

[image]

LinkOne WebView API
CrossReferenceNote..::.Validate Method (String)
CrossReferenceNote Class See Also Send Feedback
See Validate(String) for more information.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override bool Validate(
    string propertyName
)
Visual Basic (Declaration)
Public Overrides Function Validate ( _
    propertyName As String _
) As Boolean
Visual C++
public:
virtual bool Validate(
    String^ propertyName
) override

Parameters

propertyName
Type: System..::.String

See Also

CrossReferenceNote Class
Validate Overload
Mincom.LinkOne.Dom.Notes Namespace


CrossReferenceNote Properties

[image] [image]

LinkOne WebView API
CrossReferenceNote Properties
CrossReferenceNote Class See Also Send Feedback

The CrossReferenceNote type exposes the following members.

Properties

Name | Description
Access | Gets or sets the note access. (Inherited from Note.)
Association | Gets what the note is associated with. (Inherited from Note.)
Behaviour | Gets or sets the note behaviour. (Inherited from ListNote.)
BookCode | Gets or sets the book code of the note. (Inherited from Note.)
Category | Gets or sets the note category. (Inherited from CategorizedNote.)
Description | Gets or sets the description of the note. (Inherited from CategorizedNote.)
DisplayName | See DisplayName for more information. (Inherited from CategorizedNote.)
Group | Gets or sets the group identifier of the note. (Inherited from TranslatedNote.)
Id | Gets or sets the unique ID of the note. (Inherited from Note.)
IsListNote | Gets or sets whether the note appears in the notes list. (Inherited from ListNote.)
ItemId | Gets or sets the item ID of the note. (Inherited from Note.)
Key | Gets a key that uniquely defines the note. (Inherited from ListNote.)
LanguageCode | Gets or sets the language code. (Inherited from TranslatedNote.)
OriginalNote | Gets or the original note; or null if the note hasn't changed. (Inherited from Note.)
PageReference | Gets or sets the page reference of the note. (Inherited from Note.)
PartNumber | Gets or sets the part number of the note. (Inherited from Note.)
PictureNumber | Gets or sets the picture number of the redline note. (Inherited from Note.)
Prompt | Gets or sets the prompt for the cross reference note.
PublisherCode | Gets or sets the publisher code of the note. (Inherited from Note.)
Scope | Gets the note scope. (Inherited from Note.)
Status | Gets or sets the status of the note in relation to the copy saved in persistent storage. (Inherited from Note.)
TargetBookCode | Gets or sets the target book code for the cross reference note.
TargetBookmark | Gets or sets the target bookmark for the cross reference note.
TargetItemId | Gets or sets the target item Id for the cross reference note.
TargetPageReference | Gets or sets the target page reference code for the cross reference note.
TargetPublisherCode | Gets or sets the target publisher code for the cross reference note.
TimeStamp | Gets or sets the date and time when the note was last written. (Inherited from Note.)
Translation | See Translation for more information. (Overrides TranslatedNote..::.Translation.)
Xml | Gets the XML representing the note. (Inherited from Note.)

See Also

CrossReferenceNote Class
Mincom.LinkOne.Dom.Notes Namespace


Prompt Property

[image]

LinkOne WebView API
CrossReferenceNote..::.Prompt Property
CrossReferenceNote Class See Also Send Feedback
Gets or sets the prompt for the cross reference note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Prompt { get; set; }
Visual Basic (Declaration)
Public Property Prompt As String
Visual C++
public:
virtual property String^ Prompt {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Field Value

The prompt for the cross reference note.

Implements

ICrossReferenceNote..::.Prompt

See Also

CrossReferenceNote Class
Mincom.LinkOne.Dom.Notes Namespace


TargetBookCode Property

[image]

LinkOne WebView API
CrossReferenceNote..::.TargetBookCode Property
CrossReferenceNote Class See Also Send Feedback
Gets or sets the target book code for the cross reference note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string TargetBookCode { get; set; }
Visual Basic (Declaration)
Public Property TargetBookCode As String
Visual C++
public:
virtual property String^ TargetBookCode {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Field Value

The target book code.

Implements

ICrossReferenceNote..::.TargetBookCode

See Also

CrossReferenceNote Class
Mincom.LinkOne.Dom.Notes Namespace


TargetBookmark Property

[image]

LinkOne WebView API
CrossReferenceNote..::.TargetBookmark Property
CrossReferenceNote Class See Also Send Feedback
Gets or sets the target bookmark for the cross reference note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string TargetBookmark { get; set; }
Visual Basic (Declaration)
Public Property TargetBookmark As String
Visual C++
public:
virtual property String^ TargetBookmark {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Field Value

The bookmark for the cross reference note.

Implements

ICrossReferenceNote..::.TargetBookmark

Remarks

If the TargetBookmark is not blank, then the TargetPageReference and TargetItemId properties are ignored.

See Also

CrossReferenceNote Class
Mincom.LinkOne.Dom.Notes Namespace


TargetItemId Property

[image]

LinkOne WebView API
CrossReferenceNote..::.TargetItemId Property
CrossReferenceNote Class See Also Send Feedback
Gets or sets the target item Id for the cross reference note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string TargetItemId { get; set; }
Visual Basic (Declaration)
Public Property TargetItemId As String
Visual C++
public:
virtual property String^ TargetItemId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Field Value

The target item Id for the cross reference note.

Implements

ICrossReferenceNote..::.TargetItemId

Remarks

If the TargetBookmark is set to a non blank value, then the TargetItemId property is ignored.

See Also

CrossReferenceNote Class
Mincom.LinkOne.Dom.Notes Namespace


TargetPageReference Property

[image]

LinkOne WebView API
CrossReferenceNote..::.TargetPageReference Property
CrossReferenceNote Class See Also Send Feedback
Gets or sets the target page reference code for the cross reference note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string TargetPageReference { get; set; }
Visual Basic (Declaration)
Public Property TargetPageReference As String
Visual C++
public:
virtual property String^ TargetPageReference {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Field Value

The target page reference for the cross reference note.

Implements

ICrossReferenceNote..::.TargetPageReference

Remarks

If the TargetBookmark is set to a non blank value, then the TargetPageReference property is ignored.

See Also

CrossReferenceNote Class
Mincom.LinkOne.Dom.Notes Namespace


TargetPublisherCode Property

[image]

LinkOne WebView API
CrossReferenceNote..::.TargetPublisherCode Property
CrossReferenceNote Class See Also Send Feedback
Gets or sets the target publisher code for the cross reference note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string TargetPublisherCode { get; set; }
Visual Basic (Declaration)
Public Property TargetPublisherCode As String
Visual C++
public:
virtual property String^ TargetPublisherCode {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Field Value

The target publisher code.

Implements

ICrossReferenceNote..::.TargetPublisherCode

See Also

CrossReferenceNote Class
Mincom.LinkOne.Dom.Notes Namespace


Translation Property

[image]

LinkOne WebView API
CrossReferenceNote..::.Translation Property
CrossReferenceNote Class See Also Send Feedback
See Translation for more information.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string Translation { get; set; }
Visual Basic (Declaration)
Public Overrides Property Translation As String
Visual C++
public:
virtual property String^ Translation {
    String^ get () override;
    void set (String^ value) override;
}

Implements

ITranslatedNote..::.Translation
ITranslatedNote..::.Translation

See Also

CrossReferenceNote Class
Mincom.LinkOne.Dom.Notes Namespace


FieldMapping Class

[image]

LinkOne WebView API
FieldMapping Class
Members See Also Send Feedback
A class which represents a selection list field mapping note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class FieldMapping : TranslatedNote,
    IFieldMapping, ITranslatedNote, INote
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class FieldMapping _
    Inherits TranslatedNote _
    Implements IFieldMapping, ITranslatedNote, INote
Visual C++
[SerializableAttribute]
public ref class FieldMapping sealed : public TranslatedNote,
    IFieldMapping, ITranslatedNote, INote

Remarks

A field mapping note relates a field in a selection list to other fields, such as a book or entry fields.

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Notes..::.Note
Mincom.LinkOne.Dom.Notes..::.TranslatedNote
Mincom.LinkOne.Dom.Notes..::.FieldMapping

See Also

FieldMapping Members
Mincom.LinkOne.Dom.Notes Namespace


FieldMapping Members

[image] [image]

LinkOne WebView API
FieldMapping Members
FieldMapping Class Constructors Methods Properties See Also Send Feedback

The FieldMapping type exposes the following members.

Constructors

Name | Description
FieldMapping | Creates an instance of the FieldMapping.

Methods

Name | Description
CanSetAccess | Determines whether this Note instance can set the Access to the specified value. (Inherited from Note.)
CanSetAssociation | Determines whether this Note instance can set Association to the specified value. (Inherited from Note.)
CanSetScope | Determines whether this Note instance can set Scope to the the specified value. (Inherited from Note.)
Clone | Gets a clone of the this. (Inherited from Note.)
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the hash code for the object. (Inherited from Note.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanging | Sets the note status to changed. (Inherited from Note.)
Remove | Sets the note status to Deleted. (Inherited from Note.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Overloaded.

Properties

Name | Description
Access | Gets or sets the note access. (Inherited from Note.)
Association | Gets what the note is associated with. (Inherited from Note.)
BookCode | Gets or sets the book code of the note. (Inherited from Note.)
DisplayName | See DisplayName for more information. (Overrides Note..::.DisplayName.)
Group | Gets or sets the group identifier of the note. (Inherited from TranslatedNote.)
Id | Gets or sets the unique ID of the note. (Inherited from Note.)
ItemId | See Validate(String) for more information. (Overrides Note..::.ItemId.)
Key | Gets a key that uniquely defines the note. (Inherited from TranslatedNote.)
LanguageCode | Gets or sets the language code. (Inherited from TranslatedNote.)
MappedFrom | Gets or sets the field name or value that the field mapping is mapped from.
Name | Gets or sets the name of the selection list field.
OriginalNote | Gets or the original note; or null if the note hasn't changed. (Inherited from Note.)
PageReference | See Validate(String) for more information. (Overrides Note..::.PageReference.)
PartNumber | Gets or sets the part number of the note. (Inherited from Note.)
PictureNumber | Gets or sets the picture number of the redline note. (Inherited from Note.)
PublisherCode | Gets or sets the publisher code of the note. (Inherited from Note.)
Scope | Gets the note scope. (Inherited from Note.)
Source | Gets or sets the source of the field mapping.
Status | Gets or sets the status of the note in relation to the copy saved in persistent storage. (Inherited from Note.)
TimeStamp | Gets or sets the date and time when the note was last written. (Inherited from Note.)
Translation | See Translation for more information. (Overrides TranslatedNote..::.Translation.)
Type | Gets or sets the field mapping type.
Xml | Gets the XML representing the note. (Inherited from Note.)

See Also

FieldMapping Class
Mincom.LinkOne.Dom.Notes Namespace


FieldMapping Constructor

[image]

LinkOne WebView API
FieldMapping Constructor
FieldMapping Class See Also Send Feedback
Creates an instance of the FieldMapping.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public FieldMapping()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FieldMapping()

See Also

FieldMapping Class
Mincom.LinkOne.Dom.Notes Namespace


FieldMapping Methods

[image] [image]

LinkOne WebView API
FieldMapping Methods
FieldMapping Class See Also Send Feedback

The FieldMapping type exposes the following members.

Methods

Name | Description
CanSetAccess | Determines whether this Note instance can set the Access to the specified value. (Inherited from Note.)
CanSetAssociation | Determines whether this Note instance can set Association to the specified value. (Inherited from Note.)
CanSetScope | Determines whether this Note instance can set Scope to the the specified value. (Inherited from Note.)
Clone | Gets a clone of the this. (Inherited from Note.)
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the hash code for the object. (Inherited from Note.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanging | Sets the note status to changed. (Inherited from Note.)
Remove | Sets the note status to Deleted. (Inherited from Note.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Overloaded.

See Also

FieldMapping Class
Mincom.LinkOne.Dom.Notes Namespace


Equals Method

[image] [image]

LinkOne WebView API
FieldMapping..::.Equals Method
FieldMapping Class See Also Send Feedback

Overload List

Name | Description
Equals(Note) | Determines whether the specified note is equal to the current note. (Inherited from Note.)
Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Note.)

See Also

FieldMapping Class
FieldMapping Members
Mincom.LinkOne.Dom.Notes Namespace


Validate Method

[image] [image]

LinkOne WebView API
FieldMapping..::.Validate Method
FieldMapping Class See Also Send Feedback

Overload List

Name | Description
Validate(String) | See Validate(String) for more information. (Overrides Note..::.Validate(String).)
Validate(Access, String, String, String, String, String, Int32) | Validates the given properties for a note. (Inherited from Note.)

See Also

FieldMapping Class
FieldMapping Members
Mincom.LinkOne.Dom.Notes Namespace


Validate Method (String)

[image]

LinkOne WebView API
FieldMapping..::.Validate Method (String)
FieldMapping Class See Also Send Feedback
See Validate(String) for more information.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override bool Validate(
    string propertyName
)
Visual Basic (Declaration)
Public Overrides Function Validate ( _
    propertyName As String _
) As Boolean
Visual C++
public:
virtual bool Validate(
    String^ propertyName
) override

Parameters

propertyName
Type: System..::.String

See Also

FieldMapping Class
Validate Overload
Mincom.LinkOne.Dom.Notes Namespace


FieldMapping Properties

[image] [image]

LinkOne WebView API
FieldMapping Properties
FieldMapping Class See Also Send Feedback

The FieldMapping type exposes the following members.

Properties

Name | Description
Access | Gets or sets the note access. (Inherited from Note.)
Association | Gets what the note is associated with. (Inherited from Note.)
BookCode | Gets or sets the book code of the note. (Inherited from Note.)
DisplayName | See DisplayName for more information. (Overrides Note..::.DisplayName.)
Group | Gets or sets the group identifier of the note. (Inherited from TranslatedNote.)
Id | Gets or sets the unique ID of the note. (Inherited from Note.)
ItemId | See Validate(String) for more information. (Overrides Note..::.ItemId.)
Key | Gets a key that uniquely defines the note. (Inherited from TranslatedNote.)
LanguageCode | Gets or sets the language code. (Inherited from TranslatedNote.)
MappedFrom | Gets or sets the field name or value that the field mapping is mapped from.
Name | Gets or sets the name of the selection list field.
OriginalNote | Gets or the original note; or null if the note hasn't changed. (Inherited from Note.)
PageReference | See Validate(String) for more information. (Overrides Note..::.PageReference.)
PartNumber | Gets or sets the part number of the note. (Inherited from Note.)
PictureNumber | Gets or sets the picture number of the redline note. (Inherited from Note.)
PublisherCode | Gets or sets the publisher code of the note. (Inherited from Note.)
Scope | Gets the note scope. (Inherited from Note.)
Source | Gets or sets the source of the field mapping.
Status | Gets or sets the status of the note in relation to the copy saved in persistent storage. (Inherited from Note.)
TimeStamp | Gets or sets the date and time when the note was last written. (Inherited from Note.)
Translation | See Translation for more information. (Overrides TranslatedNote..::.Translation.)
Type | Gets or sets the field mapping type.
Xml | Gets the XML representing the note. (Inherited from Note.)

See Also

FieldMapping Class
Mincom.LinkOne.Dom.Notes Namespace


DisplayName Property

[image]

LinkOne WebView API
FieldMapping..::.DisplayName Property
FieldMapping Class See Also Send Feedback
See DisplayName for more information.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string DisplayName { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DisplayName As String
Visual C++
public:
virtual property String^ DisplayName {
    String^ get () override;
}

See Also

FieldMapping Class
Mincom.LinkOne.Dom.Notes Namespace


ItemId Property

[image]

LinkOne WebView API
FieldMapping..::.ItemId Property
FieldMapping Class See Also Send Feedback
See Validate(String) for more information.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string ItemId { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property ItemId As String
Visual C++
public:
virtual property String^ ItemId {
    void set (String^ value) override;
}

Implements

INote..::.ItemId
INote..::.ItemId

Remarks

A FieldMapping is not permitted to have an Item Id.

See Also

FieldMapping Class
Mincom.LinkOne.Dom.Notes Namespace


MappedFrom Property

[image]

LinkOne WebView API
FieldMapping..::.MappedFrom Property
FieldMapping Class See Also Send Feedback
Gets or sets the field name or value that the field mapping is mapped from.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string MappedFrom { get; set; }
Visual Basic (Declaration)
Public Property MappedFrom As String
Visual C++
public:
virtual property String^ MappedFrom {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Field Value

The field name or value that the field mapping is mapped from.

Implements

IFieldMapping..::.MappedFrom

See Also

FieldMapping Class
Mincom.LinkOne.Dom.Notes Namespace


Name Property

[image]

LinkOne WebView API
FieldMapping..::.Name Property
FieldMapping Class See Also Send Feedback
Gets or sets the name of the selection list field.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IFieldMapping..::.Name

See Also

FieldMapping Class
Mincom.LinkOne.Dom.Notes Namespace


PageReference Property

[image]

LinkOne WebView API
FieldMapping..::.PageReference Property
FieldMapping Class See Also Send Feedback
See Validate(String) for more information.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string PageReference { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property PageReference As String
Visual C++
public:
virtual property String^ PageReference {
    void set (String^ value) override;
}

Implements

INote..::.PageReference
INote..::.PageReference

Remarks

A FieldMapping is not permitted to have a page reference.

See Also

FieldMapping Class
Mincom.LinkOne.Dom.Notes Namespace


Source Property

[image]

LinkOne WebView API
FieldMapping..::.Source Property
FieldMapping Class See Also Send Feedback
Gets or sets the source of the field mapping.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public FieldMappingSourceType Source { get; internal set; }
Visual Basic (Declaration)
Public Property Source As FieldMappingSourceType
Visual C++
public:
virtual property FieldMappingSourceType Source {
    FieldMappingSourceType get () sealed;
    void set (FieldMappingSourceType value) sealed;
}

Implements

IFieldMapping..::.Source

See Also

FieldMapping Class
Mincom.LinkOne.Dom.Notes Namespace


Translation Property

[image]

LinkOne WebView API
FieldMapping..::.Translation Property
FieldMapping Class See Also Send Feedback
See Translation for more information.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string Translation { get; set; }
Visual Basic (Declaration)
Public Overrides Property Translation As String
Visual C++
public:
virtual property String^ Translation {
    String^ get () override;
    void set (String^ value) override;
}

Implements

ITranslatedNote..::.Translation
ITranslatedNote..::.Translation

See Also

FieldMapping Class
Mincom.LinkOne.Dom.Notes Namespace


Type Property

[image]

LinkOne WebView API
FieldMapping..::.Type Property
FieldMapping Class See Also Send Feedback
Gets or sets the field mapping type.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public FieldMappingType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As FieldMappingType
Visual C++
public:
virtual property FieldMappingType Type {
    FieldMappingType get () sealed;
    void set (FieldMappingType value) sealed;
}

Implements

IFieldMapping..::.Type

See Also

FieldMapping Class
Mincom.LinkOne.Dom.Notes Namespace


FieldMappingSourceType Enumeration

[image]

LinkOne WebView API
FieldMappingSourceType Enumeration
See Also Send Feedback
Defines the source type of a selection list field mapping.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum FieldMappingSourceType
Visual Basic (Declaration)
Public Enumeration FieldMappingSourceType
Visual C++
public enum class FieldMappingSourceType

Members

Member name | Description
User | Field mapping is user defined.
Predefined | Field mapping is a predefined by LinkOne.

See Also

Mincom.LinkOne.Dom.Notes Namespace


FieldMappingType Enumeration

[image]

LinkOne WebView API
FieldMappingType Enumeration
See Also Send Feedback
Defines the types a selection list field can be mapped to.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum FieldMappingType
Visual Basic (Declaration)
Public Enumeration FieldMappingType
Visual C++
public enum class FieldMappingType

Members

Member name | Description
Empty | Selection list field is not mapped.
EntryField | Selection list field is mapped from an entry field.
ListField | Selection list field is mapped from a list field.
BookField | Selection list field is mapped from a book field.
PictureField | Selection list field is mapped from a picture field.
Literal | Selection list field is mapped to literal.
Value | Selection list field is mapped to value.

See Also

Mincom.LinkOne.Dom.Notes Namespace


FilterNote Class

[image]

LinkOne WebView API
FilterNote Class
Members See Also Send Feedback
A class which represents a Filter note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class FilterNote : Note,
    IFilterNote, INote
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class FilterNote _
    Inherits Note _
    Implements IFilterNote, INote
Visual C++
[SerializableAttribute]
public ref class FilterNote sealed : public Note,
    IFilterNote, INote

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Notes..::.Note
Mincom.LinkOne.Dom.Notes..::.FilterNote

See Also

FilterNote Members
Mincom.LinkOne.Dom.Notes Namespace


FilterNote Members

[image] [image]

LinkOne WebView API
FilterNote Members
FilterNote Class Constructors Methods Properties See Also Send Feedback

The FilterNote type exposes the following members.

Constructors

Name | Description
FilterNote | Creates an instance of the FilterNote.

Methods

Name | Description
CanSetAccess | Determines whether this Note instance can set the Access to the specified value. (Inherited from Note.)
CanSetAssociation | Determines whether this Note instance can set Association to the specified value. (Inherited from Note.)
CanSetScope | Determines whether this Note instance can set Scope to the the specified value. (Inherited from Note.)
Clone | Gets a clone of the this. (Inherited from Note.)
CreateFilter | Creates and returns a Filter based on this.
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the hash code for the object. (Inherited from Note.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanging | Sets the note status to changed. (Inherited from Note.)
Remove | Sets the note status to Deleted. (Inherited from Note.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Overloaded.

Properties

Name | Description
Access | Gets or sets the note access. (Inherited from Note.)
Association | Gets what the note is associated with. (Inherited from Note.)
BookCode | Gets or sets the book code of the note. (Inherited from Note.)
Comment | Gets or sets the comment of the filter note.
DisplayName | See DisplayName for more information. (Overrides Note..::.DisplayName.)
Id | Gets or sets the unique ID of the note. (Inherited from Note.)
ItemId | See Validate(String) for more information. (Overrides Note..::.ItemId.)
Key | Gets a key that uniquely defines the note. (Inherited from Note.)
Name | Gets the option filter name.
OriginalNote | Gets or the original note; or null if the note hasn't changed. (Inherited from Note.)
PageReference | Gets or sets the page reference of the note. (Inherited from Note.)
PartNumber | Gets or sets the part number of the note. (Inherited from Note.)
PictureNumber | Gets or sets the picture number of the redline note. (Inherited from Note.)
PublisherCode | Gets or sets the publisher code of the note. (Inherited from Note.)
Scope | Gets the note scope. (Inherited from Note.)
Status | Gets or sets the status of the note in relation to the copy saved in persistent storage. (Inherited from Note.)
TimeStamp | Gets or sets the date and time when the note was last written. (Inherited from Note.)
Value | Gets and sets the filter value.
Xml | Gets the XML representing the note. (Inherited from Note.)

See Also

FilterNote Class
Mincom.LinkOne.Dom.Notes Namespace


FilterNote Constructor

[image]

LinkOne WebView API
FilterNote Constructor
FilterNote Class See Also Send Feedback
Creates an instance of the FilterNote.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public FilterNote()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FilterNote()

See Also

FilterNote Class
Mincom.LinkOne.Dom.Notes Namespace


FilterNote Methods

[image] [image]

LinkOne WebView API
FilterNote Methods
FilterNote Class See Also Send Feedback

The FilterNote type exposes the following members.

Methods

Name | Description
CanSetAccess | Determines whether this Note instance can set the Access to the specified value. (Inherited from Note.)
CanSetAssociation | Determines whether this Note instance can set Association to the specified value. (Inherited from Note.)
CanSetScope | Determines whether this Note instance can set Scope to the the specified value. (Inherited from Note.)
Clone | Gets a clone of the this. (Inherited from Note.)
CreateFilter | Creates and returns a Filter based on this.
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the hash code for the object. (Inherited from Note.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanging | Sets the note status to changed. (Inherited from Note.)
Remove | Sets the note status to Deleted. (Inherited from Note.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Overloaded.

See Also

FilterNote Class
Mincom.LinkOne.Dom.Notes Namespace


CreateFilter Method

[image]

LinkOne WebView API
FilterNote..::.CreateFilter Method
FilterNote Class See Also Send Feedback
Creates and returns a Filter based on this.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Filter CreateFilter()
Visual Basic (Declaration)
Public Function CreateFilter As Filter
Visual C++
public:
Filter^ CreateFilter()

Return Value

The Filter based on this.

See Also

FilterNote Class
Mincom.LinkOne.Dom.Notes Namespace


Equals Method

[image] [image]

LinkOne WebView API
FilterNote..::.Equals Method
FilterNote Class See Also Send Feedback

Overload List

Name | Description
Equals(Note) | Determines whether the specified note is equal to the current note. (Inherited from Note.)
Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Note.)

See Also

FilterNote Class
FilterNote Members
Mincom.LinkOne.Dom.Notes Namespace


Validate Method

[image] [image]

LinkOne WebView API
FilterNote..::.Validate Method
FilterNote Class See Also Send Feedback

Overload List

Name | Description
Validate(String) | See Validate(String) for more information. (Overrides Note..::.Validate(String).)
Validate(Access, String, String, String, String, String, Int32) | Validates the given properties for a note. (Inherited from Note.)

See Also

FilterNote Class
FilterNote Members
Mincom.LinkOne.Dom.Notes Namespace


Validate Method (String)

[image]

LinkOne WebView API
FilterNote..::.Validate Method (String)
FilterNote Class See Also Send Feedback
See Validate(String) for more information.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override bool Validate(
    string propertyName
)
Visual Basic (Declaration)
Public Overrides Function Validate ( _
    propertyName As String _
) As Boolean
Visual C++
public:
virtual bool Validate(
    String^ propertyName
) override

Parameters

propertyName
Type: System..::.String

See Also

FilterNote Class
Validate Overload
Mincom.LinkOne.Dom.Notes Namespace


FilterNote Properties

[image] [image]

LinkOne WebView API
FilterNote Properties
FilterNote Class See Also Send Feedback

The FilterNote type exposes the following members.

Properties

Name | Description
Access | Gets or sets the note access. (Inherited from Note.)
Association | Gets what the note is associated with. (Inherited from Note.)
BookCode | Gets or sets the book code of the note. (Inherited from Note.)
Comment | Gets or sets the comment of the filter note.
DisplayName | See DisplayName for more information. (Overrides Note..::.DisplayName.)
Id | Gets or sets the unique ID of the note. (Inherited from Note.)
ItemId | See Validate(String) for more information. (Overrides Note..::.ItemId.)
Key | Gets a key that uniquely defines the note. (Inherited from Note.)
Name | Gets the option filter name.
OriginalNote | Gets or the original note; or null if the note hasn't changed. (Inherited from Note.)
PageReference | Gets or sets the page reference of the note. (Inherited from Note.)
PartNumber | Gets or sets the part number of the note. (Inherited from Note.)
PictureNumber | Gets or sets the picture number of the redline note. (Inherited from Note.)
PublisherCode | Gets or sets the publisher code of the note. (Inherited from Note.)
Scope | Gets the note scope. (Inherited from Note.)
Status | Gets or sets the status of the note in relation to the copy saved in persistent storage. (Inherited from Note.)
TimeStamp | Gets or sets the date and time when the note was last written. (Inherited from Note.)
Value | Gets and sets the filter value.
Xml | Gets the XML representing the note. (Inherited from Note.)

See Also

FilterNote Class
Mincom.LinkOne.Dom.Notes Namespace


Comment Property

[image]

LinkOne WebView API
FilterNote..::.Comment Property
FilterNote Class See Also Send Feedback
Gets or sets the comment of the filter note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Comment { get; set; }
Visual Basic (Declaration)
Public Property Comment As String
Visual C++
public:
virtual property String^ Comment {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Field Value

The comment for the filter note.

Implements

IFilterNote..::.Comment

See Also

FilterNote Class
Mincom.LinkOne.Dom.Notes Namespace


DisplayName Property

[image]

LinkOne WebView API
FilterNote..::.DisplayName Property
FilterNote Class See Also Send Feedback
See DisplayName for more information.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string DisplayName { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DisplayName As String
Visual C++
public:
virtual property String^ DisplayName {
    String^ get () override;
}

See Also

FilterNote Class
Mincom.LinkOne.Dom.Notes Namespace


ItemId Property

[image]

LinkOne WebView API
FilterNote..::.ItemId Property
FilterNote Class See Also Send Feedback
See Validate(String) for more information.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string ItemId { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property ItemId As String
Visual C++
public:
virtual property String^ ItemId {
    void set (String^ value) override;
}

Implements

INote..::.ItemId
INote..::.ItemId

Remarks

A FilterNote is not permitted to have an Item Id.

See Also

FilterNote Class
Mincom.LinkOne.Dom.Notes Namespace


Name Property

[image]

LinkOne WebView API
FilterNote..::.Name Property
FilterNote Class See Also Send Feedback
Gets the option filter name.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IFilterNote..::.Name

See Also

FilterNote Class
Mincom.LinkOne.Dom.Notes Namespace


Value Property

[image]

LinkOne WebView API
FilterNote..::.Value Property
FilterNote Class See Also Send Feedback
Gets and sets the filter value.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String
Visual C++
public:
virtual property String^ Value {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IFilterNote..::.Value

See Also

FilterNote Class
Mincom.LinkOne.Dom.Notes Namespace


Hyperlink Class

[image]

LinkOne WebView API
Hyperlink Class
Members See Also Send Feedback
A class which represents a hyperlink on a hyperlink note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class Hyperlink
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class Hyperlink
Visual C++
[SerializableAttribute]
public ref class Hyperlink sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Notes..::.Hyperlink

See Also

Hyperlink Members
Mincom.LinkOne.Dom.Notes Namespace


Hyperlink Members

[image] [image]

LinkOne WebView API
Hyperlink Members
Hyperlink Class Constructors Methods Properties See Also Send Feedback

The Hyperlink type exposes the following members.

Constructors

Name | Description
Hyperlink | Constructor.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Address | Gets the hyperlink address.
BookCode | Gets the book code for the LinkOne address.
Bookmark | Gets the bookmark for the LinkOne address.
Command | Gets the command for the LinkOne address.
IsInternetAddress | Gets true if an Internet address.
IsLinkOneAddress | Gets true if a LinkOne address.
ItemId | Gets the item id for the LinkOne address.
PageReference | Gets the page reference for the LinkOne address.
PublisherCode | Gets the publisher code for the LinkOne address.

See Also

Hyperlink Class
Mincom.LinkOne.Dom.Notes Namespace


Hyperlink Constructor

[image]

LinkOne WebView API
Hyperlink Constructor
Hyperlink Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Hyperlink(
    string address
)
Visual Basic (Declaration)
Public Sub New ( _
    address As String _
)
Visual C++
public:
Hyperlink(
    String^ address
)

Parameters

address
Type: System..::.String
The hyperlink address.

See Also

Hyperlink Class
Mincom.LinkOne.Dom.Notes Namespace


Hyperlink Methods

[image] [image]

LinkOne WebView API
Hyperlink Methods
Hyperlink Class See Also Send Feedback

The Hyperlink type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Hyperlink Class
Mincom.LinkOne.Dom.Notes Namespace


Hyperlink Properties

[image] [image]

LinkOne WebView API
Hyperlink Properties
Hyperlink Class See Also Send Feedback

The Hyperlink type exposes the following members.

Properties

Name | Description
Address | Gets the hyperlink address.
BookCode | Gets the book code for the LinkOne address.
Bookmark | Gets the bookmark for the LinkOne address.
Command | Gets the command for the LinkOne address.
IsInternetAddress | Gets true if an Internet address.
IsLinkOneAddress | Gets true if a LinkOne address.
ItemId | Gets the item id for the LinkOne address.
PageReference | Gets the page reference for the LinkOne address.
PublisherCode | Gets the publisher code for the LinkOne address.

See Also

Hyperlink Class
Mincom.LinkOne.Dom.Notes Namespace


Address Property

[image]

LinkOne WebView API
Hyperlink..::.Address Property
Hyperlink Class See Also Send Feedback
Gets the hyperlink address.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Address { get; }
Visual Basic (Declaration)
Public ReadOnly Property Address As String
Visual C++
public:
property String^ Address {
    String^ get ();
}

See Also

Hyperlink Class
Mincom.LinkOne.Dom.Notes Namespace


BookCode Property

[image]

LinkOne WebView API
Hyperlink..::.BookCode Property
Hyperlink Class See Also Send Feedback
Gets the book code for the LinkOne address.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string BookCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property BookCode As String
Visual C++
public:
property String^ BookCode {
    String^ get ();
}

See Also

Hyperlink Class
Mincom.LinkOne.Dom.Notes Namespace


Bookmark Property

[image]

LinkOne WebView API
Hyperlink..::.Bookmark Property
Hyperlink Class See Also Send Feedback
Gets the bookmark for the LinkOne address.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Bookmark { get; }
Visual Basic (Declaration)
Public ReadOnly Property Bookmark As String
Visual C++
public:
property String^ Bookmark {
    String^ get ();
}

See Also

Hyperlink Class
Mincom.LinkOne.Dom.Notes Namespace


Command Property

[image]

LinkOne WebView API
Hyperlink..::.Command Property
Hyperlink Class See Also Send Feedback
Gets the command for the LinkOne address.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Command { get; }
Visual Basic (Declaration)
Public ReadOnly Property Command As String
Visual C++
public:
property String^ Command {
    String^ get ();
}

See Also

Hyperlink Class
Mincom.LinkOne.Dom.Notes Namespace


IsInternetAddress Property

[image]

LinkOne WebView API
Hyperlink..::.IsInternetAddress Property
Hyperlink Class See Also Send Feedback
Gets true if an Internet address.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsInternetAddress { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsInternetAddress As Boolean
Visual C++
public:
property bool IsInternetAddress {
    bool get ();
}

See Also

Hyperlink Class
Mincom.LinkOne.Dom.Notes Namespace


IsLinkOneAddress Property

[image]

LinkOne WebView API
Hyperlink..::.IsLinkOneAddress Property
Hyperlink Class See Also Send Feedback
Gets true if a LinkOne address.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsLinkOneAddress { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsLinkOneAddress As Boolean
Visual C++
public:
property bool IsLinkOneAddress {
    bool get ();
}

See Also

Hyperlink Class
Mincom.LinkOne.Dom.Notes Namespace


ItemId Property

[image]

LinkOne WebView API
Hyperlink..::.ItemId Property
Hyperlink Class See Also Send Feedback
Gets the item id for the LinkOne address.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string ItemId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemId As String
Visual C++
public:
property String^ ItemId {
    String^ get ();
}

See Also

Hyperlink Class
Mincom.LinkOne.Dom.Notes Namespace


PageReference Property

[image]

LinkOne WebView API
Hyperlink..::.PageReference Property
Hyperlink Class See Also Send Feedback
Gets the page reference for the LinkOne address.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PageReference { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageReference As String
Visual C++
public:
property String^ PageReference {
    String^ get ();
}

See Also

Hyperlink Class
Mincom.LinkOne.Dom.Notes Namespace


PublisherCode Property

[image]

LinkOne WebView API
Hyperlink..::.PublisherCode Property
Hyperlink Class See Also Send Feedback
Gets the publisher code for the LinkOne address.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PublisherCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublisherCode As String
Visual C++
public:
property String^ PublisherCode {
    String^ get ();
}

See Also

Hyperlink Class
Mincom.LinkOne.Dom.Notes Namespace


HyperlinkNote Class

[image]

LinkOne WebView API
HyperlinkNote Class
Members See Also Send Feedback
A class which represents a Hyperlink note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class HyperlinkNote : ListNote,
    IHyperlinkNote, IListNote, ICategorizedNote, ITranslatedNote, INote
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class HyperlinkNote _
    Inherits ListNote _
    Implements IHyperlinkNote, IListNote, ICategorizedNote, ITranslatedNote,  _
    INote
Visual C++
[SerializableAttribute]
public ref class HyperlinkNote sealed : public ListNote,
    IHyperlinkNote, IListNote, ICategorizedNote, ITranslatedNote, INote

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Notes..::.Note
Mincom.LinkOne.Dom.Notes..::.TranslatedNote
Mincom.LinkOne.Dom.Notes..::.CategorizedNote
Mincom.LinkOne.Dom.Notes..::.ListNote
Mincom.LinkOne.Dom.Notes..::.HyperlinkNote

See Also

HyperlinkNote Members
Mincom.LinkOne.Dom.Notes Namespace


HyperlinkNote Members

[image] [image]

LinkOne WebView API
HyperlinkNote Members
HyperlinkNote Class Constructors Methods Properties See Also Send Feedback

The HyperlinkNote type exposes the following members.

Constructors

Name | Description
HyperlinkNote | Creates an instance of the HyperlinkNote.

Methods

Name | Description
CanSetAccess | Determines whether this Note instance can set the Access to the specified value. (Inherited from Note.)
CanSetAssociation | Determines whether this Note instance can set Association to the specified value. (Inherited from Note.)
CanSetScope | Determines whether this Note instance can set Scope to the the specified value. (Inherited from Note.)
Clone | Gets a clone of the this. (Inherited from Note.)
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the hash code for the object. (Inherited from Note.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanging | Sets the note status to changed. (Inherited from Note.)
Remove | Sets the note status to Deleted. (Inherited from Note.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Overloaded.

Properties

Name | Description
Access | Gets or sets the note access. (Inherited from Note.)
Association | Gets what the note is associated with. (Inherited from Note.)
Behaviour | Gets or sets the note behaviour. (Inherited from ListNote.)
BookCode | Gets or sets the book code of the note. (Inherited from Note.)
Category | Gets or sets the note category. (Inherited from CategorizedNote.)
Description | Gets or sets the description of the note. (Inherited from CategorizedNote.)
DisplayName | See DisplayName for more information. (Inherited from CategorizedNote.)
Group | Gets or sets the group identifier of the note. (Inherited from TranslatedNote.)
Hyperlink | Gets the hyperlink for the note.
Id | Gets or sets the unique ID of the note. (Inherited from Note.)
IsListNote | Gets or sets whether the note appears in the notes list. (Inherited from ListNote.)
ItemId | Gets or sets the item ID of the note. (Inherited from Note.)
Key | Gets a key that uniquely defines the note. (Inherited from ListNote.)
LanguageCode | Gets or sets the language code. (Inherited from TranslatedNote.)
Link | Gets or sets the link for the hyperlink address note.
OriginalNote | Gets or the original note; or null if the note hasn't changed. (Inherited from Note.)
PageReference | Gets or sets the page reference of the note. (Inherited from Note.)
PartNumber | Gets or sets the part number of the note. (Inherited from Note.)
PictureNumber | Gets or sets the picture number of the redline note. (Inherited from Note.)
Prompt | Gets or sets the prompt for the hyperlink note.
PublisherCode | Gets or sets the publisher code of the note. (Inherited from Note.)
Scope | Gets the note scope. (Inherited from Note.)
Status | Gets or sets the status of the note in relation to the copy saved in persistent storage. (Inherited from Note.)
TimeStamp | Gets or sets the date and time when the note was last written. (Inherited from Note.)
Translation | See Translation for more information. (Overrides TranslatedNote..::.Translation.)
Xml | Gets the XML representing the note. (Inherited from Note.)

See Also

HyperlinkNote Class
Mincom.LinkOne.Dom.Notes Namespace


HyperlinkNote Constructor

[image]

LinkOne WebView API
HyperlinkNote Constructor
HyperlinkNote Class See Also Send Feedback
Creates an instance of the HyperlinkNote.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public HyperlinkNote()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
HyperlinkNote()

See Also

HyperlinkNote Class
Mincom.LinkOne.Dom.Notes Namespace


HyperlinkNote Methods

[image] [image]

LinkOne WebView API
HyperlinkNote Methods
HyperlinkNote Class See Also Send Feedback

The HyperlinkNote type exposes the following members.

Methods

Name | Description
CanSetAccess | Determines whether this Note instance can set the Access to the specified value. (Inherited from Note.)
CanSetAssociation | Determines whether this Note instance can set Association to the specified value. (Inherited from Note.)
CanSetScope | Determines whether this Note instance can set Scope to the the specified value. (Inherited from Note.)
Clone | Gets a clone of the this. (Inherited from Note.)
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the hash code for the object. (Inherited from Note.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanging | Sets the note status to changed. (Inherited from Note.)
Remove | Sets the note status to Deleted. (Inherited from Note.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Overloaded.

See Also

HyperlinkNote Class
Mincom.LinkOne.Dom.Notes Namespace


Equals Method

[image] [image]

LinkOne WebView API
HyperlinkNote..::.Equals Method
HyperlinkNote Class See Also Send Feedback

Overload List

Name | Description
Equals(Note) | Determines whether the specified note is equal to the current note. (Inherited from Note.)
Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Note.)

See Also

HyperlinkNote Class
HyperlinkNote Members
Mincom.LinkOne.Dom.Notes Namespace


Validate Method

[image] [image]

LinkOne WebView API
HyperlinkNote..::.Validate Method
HyperlinkNote Class See Also Send Feedback

Overload List

Name | Description
Validate(String) | See Validate(String) for more information. (Overrides Note..::.Validate(String).)
Validate(Access, String, String, String, String, String, Int32) | Validates the given properties for a note. (Inherited from Note.)

See Also

HyperlinkNote Class
HyperlinkNote Members
Mincom.LinkOne.Dom.Notes Namespace


Validate Method (String)

[image]

LinkOne WebView API
HyperlinkNote..::.Validate Method (String)
HyperlinkNote Class See Also Send Feedback
See Validate(String) for more information.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override bool Validate(
    string propertyName
)
Visual Basic (Declaration)
Public Overrides Function Validate ( _
    propertyName As String _
) As Boolean
Visual C++
public:
virtual bool Validate(
    String^ propertyName
) override

Parameters

propertyName
Type: System..::.String

See Also

HyperlinkNote Class
Validate Overload
Mincom.LinkOne.Dom.Notes Namespace


HyperlinkNote Properties

[image] [image]

LinkOne WebView API
HyperlinkNote Properties
HyperlinkNote Class See Also Send Feedback

The HyperlinkNote type exposes the following members.

Properties

Name | Description
Access | Gets or sets the note access. (Inherited from Note.)
Association | Gets what the note is associated with. (Inherited from Note.)
Behaviour | Gets or sets the note behaviour. (Inherited from ListNote.)
BookCode | Gets or sets the book code of the note. (Inherited from Note.)
Category | Gets or sets the note category. (Inherited from CategorizedNote.)
Description | Gets or sets the description of the note. (Inherited from CategorizedNote.)
DisplayName | See DisplayName for more information. (Inherited from CategorizedNote.)
Group | Gets or sets the group identifier of the note. (Inherited from TranslatedNote.)
Hyperlink | Gets the hyperlink for the note.
Id | Gets or sets the unique ID of the note. (Inherited from Note.)
IsListNote | Gets or sets whether the note appears in the notes list. (Inherited from ListNote.)
ItemId | Gets or sets the item ID of the note. (Inherited from Note.)
Key | Gets a key that uniquely defines the note. (Inherited from ListNote.)
LanguageCode | Gets or sets the language code. (Inherited from TranslatedNote.)
Link | Gets or sets the link for the hyperlink address note.
OriginalNote | Gets or the original note; or null if the note hasn't changed. (Inherited from Note.)
PageReference | Gets or sets the page reference of the note. (Inherited from Note.)
PartNumber | Gets or sets the part number of the note. (Inherited from Note.)
PictureNumber | Gets or sets the picture number of the redline note. (Inherited from Note.)
Prompt | Gets or sets the prompt for the hyperlink note.
PublisherCode | Gets or sets the publisher code of the note. (Inherited from Note.)
Scope | Gets the note scope. (Inherited from Note.)
Status | Gets or sets the status of the note in relation to the copy saved in persistent storage. (Inherited from Note.)
TimeStamp | Gets or sets the date and time when the note was last written. (Inherited from Note.)
Translation | See Translation for more information. (Overrides TranslatedNote..::.Translation.)
Xml | Gets the XML representing the note. (Inherited from Note.)

See Also

HyperlinkNote Class
Mincom.LinkOne.Dom.Notes Namespace


Hyperlink Property

[image]

LinkOne WebView API
HyperlinkNote..::.Hyperlink Property
HyperlinkNote Class See Also Send Feedback
Gets the hyperlink for the note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Hyperlink Hyperlink { get; }
Visual Basic (Declaration)
Public ReadOnly Property Hyperlink As Hyperlink
Visual C++
public:
property Hyperlink^ Hyperlink {
    Hyperlink^ get ();
}

See Also

HyperlinkNote Class
Mincom.LinkOne.Dom.Notes Namespace


Link Property

[image]

LinkOne WebView API
HyperlinkNote..::.Link Property
HyperlinkNote Class See Also Send Feedback
Gets or sets the link for the hyperlink address note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Link { get; set; }
Visual Basic (Declaration)
Public Property Link As String
Visual C++
public:
virtual property String^ Link {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Field Value

The link.

Implements

IHyperlinkNote..::.Link

See Also

HyperlinkNote Class
Mincom.LinkOne.Dom.Notes Namespace


Prompt Property

[image]

LinkOne WebView API
HyperlinkNote..::.Prompt Property
HyperlinkNote Class See Also Send Feedback
Gets or sets the prompt for the hyperlink note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Prompt { get; set; }
Visual Basic (Declaration)
Public Property Prompt As String
Visual C++
public:
virtual property String^ Prompt {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Field Value

The prompt for the hyperlink note.

Implements

IHyperlinkNote..::.Prompt

See Also

HyperlinkNote Class
Mincom.LinkOne.Dom.Notes Namespace


Translation Property

[image]

LinkOne WebView API
HyperlinkNote..::.Translation Property
HyperlinkNote Class See Also Send Feedback
See Translation for more information.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string Translation { get; set; }
Visual Basic (Declaration)
Public Overrides Property Translation As String
Visual C++
public:
virtual property String^ Translation {
    String^ get () override;
    void set (String^ value) override;
}

Implements

ITranslatedNote..::.Translation
ITranslatedNote..::.Translation

See Also

HyperlinkNote Class
Mincom.LinkOne.Dom.Notes Namespace


IBookmark Interface

[image]

LinkOne WebView API
IBookmark Interface
Members See Also Send Feedback
Represents a LinkOne Bookmark.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IBookmark : ITranslatedNote,
    INote
Visual Basic (Declaration)
Public Interface IBookmark _
    Implements ITranslatedNote, INote
Visual C++
public interface class IBookmark : ITranslatedNote,
    INote

See Also

IBookmark Members
Mincom.LinkOne.Dom.Notes Namespace


IBookmark Members

[image] [image]

LinkOne WebView API
IBookmark Members
IBookmark Interface Methods Properties See Also Send Feedback

The IBookmark type exposes the following members.

Methods

Name | Description
Remove | Flags this note for deletion (the notes must be written for this to take effect, ). (Inherited from INote.)

Properties

Name | Description
Access | Gets or sets the access of the note. (Inherited from INote.)
Association | Gets the note association. (Inherited from INote.)
BookCode | Gets or sets the book code that this note is associatd with. (Inherited from INote.)
Comment | Gets or sets the comments for the bookmark.
Group | Gets or sets the group of this translated note. (Inherited from ITranslatedNote.)
Id | Gets the unique ID of the note. (Inherited from INote.)
ItemId | Gets or sets the item id that this note is associated with. (Inherited from INote.)
LanguageCode | Gets or sets the ISO-639 compliant language code of the note. (Inherited from ITranslatedNote.)
Name | Gets or sets the name of the bookmark.
PageReference | Gets or sets the page reference that this note is associated with. (Inherited from INote.)
PartNumber | Gets or sets the part number that this note is associated with. (Inherited from INote.)
PictureNumber | Gets or sets the picture number that this note is associated with. (Inherited from INote.)
PublisherCode | Gets or sets the publisher code that this note is associated with. (Inherited from INote.)
Scope | Gets the scope of the note. (Inherited from INote.)
Status | Gets the Status of the note. (Inherited from INote.)
TargetBookCode | Gets or sets the target book code.
TargetBookmark | Gets or sets the target bookmark.
TargetItemId | Gets or sets the target item id.
TargetPageReference | Gets or sets the target page reference.
TargetPublisherCode | Gets or sets the target publisher code.
TimeStamp | Gets the time stamp that indicates when the category was last written. (Inherited from INote.)
Translation | Gets or sets the description translation. (Inherited from ITranslatedNote.)

See Also

IBookmark Interface
Mincom.LinkOne.Dom.Notes Namespace


IBookmark Methods

[image] [image]

LinkOne WebView API
IBookmark Methods
IBookmark Interface See Also Send Feedback

The IBookmark type exposes the following members.

Methods

Name | Description
Remove | Flags this note for deletion (the notes must be written for this to take effect, ). (Inherited from INote.)

See Also

IBookmark Interface
Mincom.LinkOne.Dom.Notes Namespace


IBookmark Properties

[image] [image]

LinkOne WebView API
IBookmark Properties
IBookmark Interface See Also Send Feedback

The IBookmark type exposes the following members.

Properties

Name | Description
Access | Gets or sets the access of the note. (Inherited from INote.)
Association | Gets the note association. (Inherited from INote.)
BookCode | Gets or sets the book code that this note is associatd with. (Inherited from INote.)
Comment | Gets or sets the comments for the bookmark.
Group | Gets or sets the group of this translated note. (Inherited from ITranslatedNote.)
Id | Gets the unique ID of the note. (Inherited from INote.)
ItemId | Gets or sets the item id that this note is associated with. (Inherited from INote.)
LanguageCode | Gets or sets the ISO-639 compliant language code of the note. (Inherited from ITranslatedNote.)
Name | Gets or sets the name of the bookmark.
PageReference | Gets or sets the page reference that this note is associated with. (Inherited from INote.)
PartNumber | Gets or sets the part number that this note is associated with. (Inherited from INote.)
PictureNumber | Gets or sets the picture number that this note is associated with. (Inherited from INote.)
PublisherCode | Gets or sets the publisher code that this note is associated with. (Inherited from INote.)
Scope | Gets the scope of the note. (Inherited from INote.)
Status | Gets the Status of the note. (Inherited from INote.)
TargetBookCode | Gets or sets the target book code.
TargetBookmark | Gets or sets the target bookmark.
TargetItemId | Gets or sets the target item id.
TargetPageReference | Gets or sets the target page reference.
TargetPublisherCode | Gets or sets the target publisher code.
TimeStamp | Gets the time stamp that indicates when the category was last written. (Inherited from INote.)
Translation | Gets or sets the description translation. (Inherited from ITranslatedNote.)

See Also

IBookmark Interface
Mincom.LinkOne.Dom.Notes Namespace


Comment Property

[image]

LinkOne WebView API
IBookmark..::.Comment Property
IBookmark Interface See Also Send Feedback
Gets or sets the comments for the bookmark.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Comment { get; set; }
Visual Basic (Declaration)
Property Comment As String
Visual C++
property String^ Comment {
    String^ get ();
    void set (String^ value);
}

See Also

IBookmark Interface
Mincom.LinkOne.Dom.Notes Namespace


Name Property

[image]

LinkOne WebView API
IBookmark..::.Name Property
IBookmark Interface See Also Send Feedback
Gets or sets the name of the bookmark.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Name { get; set; }
Visual Basic (Declaration)
Property Name As String
Visual C++
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The name.

See Also

IBookmark Interface
Mincom.LinkOne.Dom.Notes Namespace


TargetBookCode Property

[image]

LinkOne WebView API
IBookmark..::.TargetBookCode Property
IBookmark Interface See Also Send Feedback
Gets or sets the target book code.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string TargetBookCode { get; set; }
Visual Basic (Declaration)
Property TargetBookCode As String
Visual C++
property String^ TargetBookCode {
    String^ get ();
    void set (String^ value);
}

See Also

IBookmark Interface
Mincom.LinkOne.Dom.Notes Namespace


TargetBookmark Property

[image]

LinkOne WebView API
IBookmark..::.TargetBookmark Property
IBookmark Interface See Also Send Feedback
Gets or sets the target bookmark.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string TargetBookmark { get; set; }
Visual Basic (Declaration)
Property TargetBookmark As String
Visual C++
property String^ TargetBookmark {
    String^ get ();
    void set (String^ value);
}

See Also

IBookmark Interface
Mincom.LinkOne.Dom.Notes Namespace


TargetItemId Property

[image]

LinkOne WebView API
IBookmark..::.TargetItemId Property
IBookmark Interface See Also Send Feedback
Gets or sets the target item id.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string TargetItemId { get; set; }
Visual Basic (Declaration)
Property TargetItemId As String
Visual C++
property String^ TargetItemId {
    String^ get ();
    void set (String^ value);
}

See Also

IBookmark Interface
Mincom.LinkOne.Dom.Notes Namespace


TargetPageReference Property

[image]

LinkOne WebView API
IBookmark..::.TargetPageReference Property
IBookmark Interface See Also Send Feedback
Gets or sets the target page reference.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string TargetPageReference { get; set; }
Visual Basic (Declaration)
Property TargetPageReference As String
Visual C++
property String^ TargetPageReference {
    String^ get ();
    void set (String^ value);
}

See Also

IBookmark Interface
Mincom.LinkOne.Dom.Notes Namespace


TargetPublisherCode Property

[image]

LinkOne WebView API
IBookmark..::.TargetPublisherCode Property
IBookmark Interface See Also Send Feedback
Gets or sets the target publisher code.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string TargetPublisherCode { get; set; }
Visual Basic (Declaration)
Property TargetPublisherCode As String
Visual C++
property String^ TargetPublisherCode {
    String^ get ();
    void set (String^ value);
}

See Also

IBookmark Interface
Mincom.LinkOne.Dom.Notes Namespace


ICategorizedNote Interface

[image]

LinkOne WebView API
ICategorizedNote Interface
Members See Also Send Feedback
Represents a note that can be grouped into a category.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ICategorizedNote : ITranslatedNote,
    INote
Visual Basic (Declaration)
Public Interface ICategorizedNote _
    Implements ITranslatedNote, INote
Visual C++
public interface class ICategorizedNote : ITranslatedNote,
    INote

See Also

ICategorizedNote Members
Mincom.LinkOne.Dom.Notes Namespace


ICategorizedNote Members

[image] [image]

LinkOne WebView API
ICategorizedNote Members
ICategorizedNote Interface Methods Properties See Also Send Feedback

The ICategorizedNote type exposes the following members.

Methods

Name | Description
Remove | Flags this note for deletion (the notes must be written for this to take effect, ). (Inherited from INote.)

Properties

Name | Description
Access | Gets or sets the access of the note. (Inherited from INote.)
Association | Gets the note association. (Inherited from INote.)
BookCode | Gets or sets the book code that this note is associatd with. (Inherited from INote.)
Category | Gets or sets the note category, Code.
Description | Gets or sets the note description.
Group | Gets or sets the group of this translated note. (Inherited from ITranslatedNote.)
Id | Gets the unique ID of the note. (Inherited from INote.)
ItemId | Gets or sets the item id that this note is associated with. (Inherited from INote.)
LanguageCode | Gets or sets the ISO-639 compliant language code of the note. (Inherited from ITranslatedNote.)
PageReference | Gets or sets the page reference that this note is associated with. (Inherited from INote.)
PartNumber | Gets or sets the part number that this note is associated with. (Inherited from INote.)
PictureNumber | Gets or sets the picture number that this note is associated with. (Inherited from INote.)
PublisherCode | Gets or sets the publisher code that this note is associated with. (Inherited from INote.)
Scope | Gets the scope of the note. (Inherited from INote.)
Status | Gets the Status of the note. (Inherited from INote.)
TimeStamp | Gets the time stamp that indicates when the category was last written. (Inherited from INote.)
Translation | Gets or sets the description translation. (Inherited from ITranslatedNote.)

See Also

ICategorizedNote Interface
Mincom.LinkOne.Dom.Notes Namespace


ICategorizedNote Methods

[image] [image]

LinkOne WebView API
ICategorizedNote Methods
ICategorizedNote Interface See Also Send Feedback

The ICategorizedNote type exposes the following members.

Methods

Name | Description
Remove | Flags this note for deletion (the notes must be written for this to take effect, ). (Inherited from INote.)

See Also

ICategorizedNote Interface
Mincom.LinkOne.Dom.Notes Namespace


ICategorizedNote Properties

[image] [image]

LinkOne WebView API
ICategorizedNote Properties
ICategorizedNote Interface See Also Send Feedback

The ICategorizedNote type exposes the following members.

Properties

Name | Description
Access | Gets or sets the access of the note. (Inherited from INote.)
Association | Gets the note association. (Inherited from INote.)
BookCode | Gets or sets the book code that this note is associatd with. (Inherited from INote.)
Category | Gets or sets the note category, Code.
Description | Gets or sets the note description.
Group | Gets or sets the group of this translated note. (Inherited from ITranslatedNote.)
Id | Gets the unique ID of the note. (Inherited from INote.)
ItemId | Gets or sets the item id that this note is associated with. (Inherited from INote.)
LanguageCode | Gets or sets the ISO-639 compliant language code of the note. (Inherited from ITranslatedNote.)
PageReference | Gets or sets the page reference that this note is associated with. (Inherited from INote.)
PartNumber | Gets or sets the part number that this note is associated with. (Inherited from INote.)
PictureNumber | Gets or sets the picture number that this note is associated with. (Inherited from INote.)
PublisherCode | Gets or sets the publisher code that this note is associated with. (Inherited from INote.)
Scope | Gets the scope of the note. (Inherited from INote.)
Status | Gets the Status of the note. (Inherited from INote.)
TimeStamp | Gets the time stamp that indicates when the category was last written. (Inherited from INote.)
Translation | Gets or sets the description translation. (Inherited from ITranslatedNote.)

See Also

ICategorizedNote Interface
Mincom.LinkOne.Dom.Notes Namespace


Category Property

[image]

LinkOne WebView API
ICategorizedNote..::.Category Property
ICategorizedNote Interface See Also Send Feedback
Gets or sets the note category, Code.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Category { get; set; }
Visual Basic (Declaration)
Property Category As String
Visual C++
property String^ Category {
    String^ get ();
    void set (String^ value);
}

See Also

ICategorizedNote Interface
Mincom.LinkOne.Dom.Notes Namespace


Description Property

[image]

LinkOne WebView API
ICategorizedNote..::.Description Property
ICategorizedNote Interface See Also Send Feedback
Gets or sets the note description.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Description { get; set; }
Visual Basic (Declaration)
Property Description As String
Visual C++
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

ICategorizedNote Interface
Mincom.LinkOne.Dom.Notes Namespace


ICategory Interface

[image]

LinkOne WebView API
ICategory Interface
Members See Also Send Feedback
Represents a category for grouping notes.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ICategory
Visual Basic (Declaration)
Public Interface ICategory
Visual C++
public interface class ICategory

See Also

ICategory Members
Mincom.LinkOne.Dom.Notes Namespace


ICategory Members

[image] [image]

LinkOne WebView API
ICategory Members
ICategory Interface Methods Properties See Also Send Feedback

The ICategory type exposes the following members.

Methods

Name | Description
Remove | Flags this category for deletion (the categories must be written for this to take effect, ).

Properties

Name | Description
Access | Gets or sets the access.
Code | Gets or sets the category code.
ImageId | Gets or sets the image id.
LanguageCode | Gets or sets the ISO-639 compliant language code.
PublisherCode | Gets or sets the publisher code, PublisherCode.
Scope | Gets the scope of the category.
Status | Gets the status of the ICategory in relation to the copy saved in persistent storage.
TimeStamp | Gets the time stamp that indicates when the category was last written.
Translation | Gets or sets the translation.

See Also

ICategory Interface
Mincom.LinkOne.Dom.Notes Namespace


ICategory Methods

[image] [image]

LinkOne WebView API
ICategory Methods
ICategory Interface See Also Send Feedback

The ICategory type exposes the following members.

Methods

Name | Description
Remove | Flags this category for deletion (the categories must be written for this to take effect, ).

See Also

ICategory Interface
Mincom.LinkOne.Dom.Notes Namespace


Remove Method

[image]

LinkOne WebView API
ICategory..::.Remove Method
ICategory Interface See Also Send Feedback
Flags this category for deletion (the categories must be written for this to take effect, ).

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void Remove()
Visual Basic (Declaration)
Sub Remove
Visual C++
void Remove()

See Also

ICategory Interface
Mincom.LinkOne.Dom.Notes Namespace
ILibrary..::.Write(IPersist)


ICategory Properties

[image] [image]

LinkOne WebView API
ICategory Properties
ICategory Interface See Also Send Feedback

The ICategory type exposes the following members.

Properties

Name | Description
Access | Gets or sets the access.
Code | Gets or sets the category code.
ImageId | Gets or sets the image id.
LanguageCode | Gets or sets the ISO-639 compliant language code.
PublisherCode | Gets or sets the publisher code, PublisherCode.
Scope | Gets the scope of the category.
Status | Gets the status of the ICategory in relation to the copy saved in persistent storage.
TimeStamp | Gets the time stamp that indicates when the category was last written.
Translation | Gets or sets the translation.

See Also

ICategory Interface
Mincom.LinkOne.Dom.Notes Namespace


Access Property

[image]

LinkOne WebView API
ICategory..::.Access Property
ICategory Interface See Also Send Feedback
Gets or sets the access.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
Access Access { get; set; }
Visual Basic (Declaration)
Property Access As Access
Visual C++
property Access Access {
    Access get ();
    void set (Access value);
}

See Also

ICategory Interface
Mincom.LinkOne.Dom.Notes Namespace


Code Property

[image]

LinkOne WebView API
ICategory..::.Code Property
ICategory Interface See Also Send Feedback
Gets or sets the category code.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Code { get; set; }
Visual Basic (Declaration)
Property Code As String
Visual C++
property String^ Code {
    String^ get ();
    void set (String^ value);
}

See Also

ICategory Interface
Mincom.LinkOne.Dom.Notes Namespace


ImageId Property

[image]

LinkOne WebView API
ICategory..::.ImageId Property
ICategory Interface See Also Send Feedback
Gets or sets the image id.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string ImageId { get; set; }
Visual Basic (Declaration)
Property ImageId As String
Visual C++
property String^ ImageId {
    String^ get ();
    void set (String^ value);
}

See Also

ICategory Interface
Mincom.LinkOne.Dom.Notes Namespace


LanguageCode Property

[image]

LinkOne WebView API
ICategory..::.LanguageCode Property
ICategory Interface See Also Send Feedback
Gets or sets the ISO-639 compliant language code.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string LanguageCode { get; set; }
Visual Basic (Declaration)
Property LanguageCode As String
Visual C++
property String^ LanguageCode {
    String^ get ();
    void set (String^ value);
}

See Also

ICategory Interface
Mincom.LinkOne.Dom.Notes Namespace


PublisherCode Property

[image]

LinkOne WebView API
ICategory..::.PublisherCode Property
ICategory Interface See Also Send Feedback
Gets or sets the publisher code, PublisherCode.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string PublisherCode { get; set; }
Visual Basic (Declaration)
Property PublisherCode As String
Visual C++
property String^ PublisherCode {
    String^ get ();
    void set (String^ value);
}

See Also

ICategory Interface
Mincom.LinkOne.Dom.Notes Namespace


Scope Property

[image]

LinkOne WebView API
ICategory..::.Scope Property
ICategory Interface See Also Send Feedback
Gets the scope of the category.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
Scope Scope { get; }
Visual Basic (Declaration)
ReadOnly Property Scope As Scope
Visual C++
property Scope Scope {
    Scope get ();
}

See Also

ICategory Interface
Mincom.LinkOne.Dom.Notes Namespace


Status Property

[image]

LinkOne WebView API
ICategory..::.Status Property
ICategory Interface See Also Send Feedback
Gets the status of the ICategory in relation to the copy saved in persistent storage.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
Status Status { get; }
Visual Basic (Declaration)
ReadOnly Property Status As Status
Visual C++
property Status Status {
    Status get ();
}

See Also

ICategory Interface
Mincom.LinkOne.Dom.Notes Namespace


TimeStamp Property

[image]

LinkOne WebView API
ICategory..::.TimeStamp Property
ICategory Interface See Also Send Feedback
Gets the time stamp that indicates when the category was last written.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
DateTime TimeStamp { get; }
Visual Basic (Declaration)
ReadOnly Property TimeStamp As DateTime
Visual C++
property DateTime TimeStamp {
    DateTime get ();
}

See Also

ICategory Interface
Mincom.LinkOne.Dom.Notes Namespace


Translation Property

[image]

LinkOne WebView API
ICategory..::.Translation Property
ICategory Interface See Also Send Feedback
Gets or sets the translation.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Translation { get; set; }
Visual Basic (Declaration)
Property Translation As String
Visual C++
property String^ Translation {
    String^ get ();
    void set (String^ value);
}

See Also

ICategory Interface
Mincom.LinkOne.Dom.Notes Namespace


ICategoryCollection Interface

[image]

LinkOne WebView API
ICategoryCollection Interface
Members See Also Send Feedback
Represents a collection of categories.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ICategoryCollection : ICollection<ICategory>,
    IEnumerable<ICategory>, IEnumerable, IPersist
Visual Basic (Declaration)
Public Interface ICategoryCollection _
    Implements ICollection(Of ICategory), IEnumerable(Of ICategory),  _
    IEnumerable, IPersist
Visual C++
public interface class ICategoryCollection : ICollection<ICategory^>,
    IEnumerable<ICategory^>, IEnumerable, IPersist

See Also

ICategoryCollection Members
Mincom.LinkOne.Dom.Notes Namespace


ICategoryCollection Members

[image] [image]

LinkOne WebView API
ICategoryCollection Members
ICategoryCollection Interface Methods Properties See Also Send Feedback

The ICategoryCollection type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ICategory >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ICategory >)>).)
Contains | Overloaded.
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( ICategory >)>).)
Create | Creates a new category object.
GetEnumerator | Overloaded.
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ICategory >)>).)

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ICategory >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( ICategory >)>).)
Item | Gets the ICategory with the specified category code.

See Also

ICategoryCollection Interface
Mincom.LinkOne.Dom.Notes Namespace


ICategoryCollection Methods

[image] [image]

LinkOne WebView API
ICategoryCollection Methods
ICategoryCollection Interface See Also Send Feedback

The ICategoryCollection type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ICategory >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ICategory >)>).)
Contains | Overloaded.
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( ICategory >)>).)
Create | Creates a new category object.
GetEnumerator | Overloaded.
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ICategory >)>).)

See Also

ICategoryCollection Interface
Mincom.LinkOne.Dom.Notes Namespace


Contains Method

[image] [image]

LinkOne WebView API
ICategoryCollection..::.Contains Method
ICategoryCollection Interface See Also Send Feedback

Overload List

Name | Description
Contains(T) | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from ICollection<(Of <( ICategory >)>).)
Contains(String) | Checks whether the ICategoryCollection contains the given category code.

See Also

ICategoryCollection Interface
ICategoryCollection Members
Mincom.LinkOne.Dom.Notes Namespace


Contains Method (String)

[image]

LinkOne WebView API
ICategoryCollection..::.Contains Method (String)
ICategoryCollection Interface See Also Send Feedback
Checks whether the ICategoryCollection contains the given category code.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool Contains(
    string categoryCode
)
Visual Basic (Declaration)
Function Contains ( _
    categoryCode As String _
) As Boolean
Visual C++
bool Contains(
    String^ categoryCode
)

Parameters

categoryCode
Type: System..::.String
The category code to check

Return Value

True if the ICategoryCollection contains the given category code; otherwise false.

See Also

ICategoryCollection Interface
Contains Overload
Mincom.LinkOne.Dom.Notes Namespace


Create Method

[image]

LinkOne WebView API
ICategoryCollection..::.Create Method
ICategoryCollection Interface See Also Send Feedback
Creates a new category object.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ICategory Create()
Visual Basic (Declaration)
Function Create As ICategory
Visual C++
ICategory^ Create()

Return Value

A new ICategory.

See Also

ICategoryCollection Interface
Mincom.LinkOne.Dom.Notes Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
ICategoryCollection..::.GetEnumerator Method
ICategoryCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( ICategory >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

ICategoryCollection Interface
ICategoryCollection Members
Mincom.LinkOne.Dom.Notes Namespace


ICategoryCollection Properties

[image] [image]

LinkOne WebView API
ICategoryCollection Properties
ICategoryCollection Interface See Also Send Feedback

The ICategoryCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ICategory >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( ICategory >)>).)
Item | Gets the ICategory with the specified category code.

See Also

ICategoryCollection Interface
Mincom.LinkOne.Dom.Notes Namespace


Item Property

[image]

LinkOne WebView API
ICategoryCollection..::.Item Property
ICategoryCollection Interface See Also Send Feedback
Gets the ICategory with the specified category code.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ICategory this[
    string categoryCode
] { get; }
Visual Basic (Declaration)
ReadOnly Default Property Item ( _
    categoryCode As String _
) As ICategory
Visual C++
property ICategory^ default[String^ categoryCode] {
    ICategory^ get (String^ categoryCode);
}

Parameters

categoryCode
Type: System..::.String

See Also

ICategoryCollection Interface
Mincom.LinkOne.Dom.Notes Namespace


ICrossReferenceNote Interface

[image]

LinkOne WebView API
ICrossReferenceNote Interface
Members See Also Send Feedback
Represents a cross reference note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ICrossReferenceNote : ICategorizedNote,
    ITranslatedNote, INote
Visual Basic (Declaration)
Public Interface ICrossReferenceNote _
    Implements ICategorizedNote, ITranslatedNote, INote
Visual C++
public interface class ICrossReferenceNote : ICategorizedNote,
    ITranslatedNote, INote

See Also

ICrossReferenceNote Members
Mincom.LinkOne.Dom.Notes Namespace


ICrossReferenceNote Members

[image] [image]

LinkOne WebView API
ICrossReferenceNote Members
ICrossReferenceNote Interface Methods Properties See Also Send Feedback

The ICrossReferenceNote type exposes the following members.

Methods

Name | Description
Remove | Flags this note for deletion (the notes must be written for this to take effect, ). (Inherited from INote.)

Properties

Name | Description
Access | Gets or sets the access of the note. (Inherited from INote.)
Association | Gets the note association. (Inherited from INote.)
BookCode | Gets or sets the book code that this note is associatd with. (Inherited from INote.)
Category | Gets or sets the note category, Code. (Inherited from ICategorizedNote.)
Description | Gets or sets the note description. (Inherited from ICategorizedNote.)
Group | Gets or sets the group of this translated note. (Inherited from ITranslatedNote.)
Id | Gets the unique ID of the note. (Inherited from INote.)
ItemId | Gets or sets the item id that this note is associated with. (Inherited from INote.)
LanguageCode | Gets or sets the ISO-639 compliant language code of the note. (Inherited from ITranslatedNote.)
PageReference | Gets or sets the page reference that this note is associated with. (Inherited from INote.)
PartNumber | Gets or sets the part number that this note is associated with. (Inherited from INote.)
PictureNumber | Gets or sets the picture number that this note is associated with. (Inherited from INote.)
Prompt | Gets or sets the prompt for the cross reference note.
PublisherCode | Gets or sets the publisher code that this note is associated with. (Inherited from INote.)
Scope | Gets the scope of the note. (Inherited from INote.)
Status | Gets the Status of the note. (Inherited from INote.)
TargetBookCode | Gets or sets the target book code.
TargetBookmark | Gets or sets the target bookmark.
TargetItemId | Gets or sets the target item id.
TargetPageReference | Gets or sets the target page reference.
TargetPublisherCode | Gets or sets the target publisher code.
TimeStamp | Gets the time stamp that indicates when the category was last written. (Inherited from INote.)
Translation | Gets or sets the description translation. (Inherited from ITranslatedNote.)

See Also

ICrossReferenceNote Interface
Mincom.LinkOne.Dom.Notes Namespace


ICrossReferenceNote Methods

[image] [image]

LinkOne WebView API
ICrossReferenceNote Methods
ICrossReferenceNote Interface See Also Send Feedback

The ICrossReferenceNote type exposes the following members.

Methods

Name | Description
Remove | Flags this note for deletion (the notes must be written for this to take effect, ). (Inherited from INote.)

See Also

ICrossReferenceNote Interface
Mincom.LinkOne.Dom.Notes Namespace


ICrossReferenceNote Properties

[image] [image]

LinkOne WebView API
ICrossReferenceNote Properties
ICrossReferenceNote Interface See Also Send Feedback

The ICrossReferenceNote type exposes the following members.

Properties

Name | Description
Access | Gets or sets the access of the note. (Inherited from INote.)
Association | Gets the note association. (Inherited from INote.)
BookCode | Gets or sets the book code that this note is associatd with. (Inherited from INote.)
Category | Gets or sets the note category, Code. (Inherited from ICategorizedNote.)
Description | Gets or sets the note description. (Inherited from ICategorizedNote.)
Group | Gets or sets the group of this translated note. (Inherited from ITranslatedNote.)
Id | Gets the unique ID of the note. (Inherited from INote.)
ItemId | Gets or sets the item id that this note is associated with. (Inherited from INote.)
LanguageCode | Gets or sets the ISO-639 compliant language code of the note. (Inherited from ITranslatedNote.)
PageReference | Gets or sets the page reference that this note is associated with. (Inherited from INote.)
PartNumber | Gets or sets the part number that this note is associated with. (Inherited from INote.)
PictureNumber | Gets or sets the picture number that this note is associated with. (Inherited from INote.)
Prompt | Gets or sets the prompt for the cross reference note.
PublisherCode | Gets or sets the publisher code that this note is associated with. (Inherited from INote.)
Scope | Gets the scope of the note. (Inherited from INote.)
Status | Gets the Status of the note. (Inherited from INote.)
TargetBookCode | Gets or sets the target book code.
TargetBookmark | Gets or sets the target bookmark.
TargetItemId | Gets or sets the target item id.
TargetPageReference | Gets or sets the target page reference.
TargetPublisherCode | Gets or sets the target publisher code.
TimeStamp | Gets the time stamp that indicates when the category was last written. (Inherited from INote.)
Translation | Gets or sets the description translation. (Inherited from ITranslatedNote.)

See Also

ICrossReferenceNote Interface
Mincom.LinkOne.Dom.Notes Namespace


Prompt Property

[image]

LinkOne WebView API
ICrossReferenceNote..::.Prompt Property
ICrossReferenceNote Interface See Also Send Feedback
Gets or sets the prompt for the cross reference note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Prompt { get; set; }
Visual Basic (Declaration)
Property Prompt As String
Visual C++
property String^ Prompt {
    String^ get ();
    void set (String^ value);
}

See Also

ICrossReferenceNote Interface
Mincom.LinkOne.Dom.Notes Namespace


TargetBookCode Property

[image]

LinkOne WebView API
ICrossReferenceNote..::.TargetBookCode Property
ICrossReferenceNote Interface See Also Send Feedback
Gets or sets the target book code.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string TargetBookCode { get; set; }
Visual Basic (Declaration)
Property TargetBookCode As String
Visual C++
property String^ TargetBookCode {
    String^ get ();
    void set (String^ value);
}

See Also

ICrossReferenceNote Interface
Mincom.LinkOne.Dom.Notes Namespace


TargetBookmark Property

[image]

LinkOne WebView API
ICrossReferenceNote..::.TargetBookmark Property
ICrossReferenceNote Interface See Also Send Feedback
Gets or sets the target bookmark.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string TargetBookmark { get; set; }
Visual Basic (Declaration)
Property TargetBookmark As String
Visual C++
property String^ TargetBookmark {
    String^ get ();
    void set (String^ value);
}

See Also

ICrossReferenceNote Interface
Mincom.LinkOne.Dom.Notes Namespace


TargetItemId Property

[image]

LinkOne WebView API
ICrossReferenceNote..::.TargetItemId Property
ICrossReferenceNote Interface See Also Send Feedback
Gets or sets the target item id.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string TargetItemId { get; set; }
Visual Basic (Declaration)
Property TargetItemId As String
Visual C++
property String^ TargetItemId {
    String^ get ();
    void set (String^ value);
}

See Also

ICrossReferenceNote Interface
Mincom.LinkOne.Dom.Notes Namespace


TargetPageReference Property

[image]

LinkOne WebView API
ICrossReferenceNote..::.TargetPageReference Property
ICrossReferenceNote Interface See Also Send Feedback
Gets or sets the target page reference.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string TargetPageReference { get; set; }
Visual Basic (Declaration)
Property TargetPageReference As String
Visual C++
property String^ TargetPageReference {
    String^ get ();
    void set (String^ value);
}

See Also

ICrossReferenceNote Interface
Mincom.LinkOne.Dom.Notes Namespace


TargetPublisherCode Property

[image]

LinkOne WebView API
ICrossReferenceNote..::.TargetPublisherCode Property
ICrossReferenceNote Interface See Also Send Feedback
Gets or sets the target publisher code.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string TargetPublisherCode { get; set; }
Visual Basic (Declaration)
Property TargetPublisherCode As String
Visual C++
property String^ TargetPublisherCode {
    String^ get ();
    void set (String^ value);
}

See Also

ICrossReferenceNote Interface
Mincom.LinkOne.Dom.Notes Namespace


IFieldMapping Interface

[image]

LinkOne WebView API
IFieldMapping Interface
Members See Also Send Feedback
Represents a selection list field mapping note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IFieldMapping : ITranslatedNote,
    INote
Visual Basic (Declaration)
Public Interface IFieldMapping _
    Implements ITranslatedNote, INote
Visual C++
public interface class IFieldMapping : ITranslatedNote,
    INote

Remarks

A field mapping note relates a field in a selection list to other fields, such as a book or entry fields.

See Also

IFieldMapping Members
Mincom.LinkOne.Dom.Notes Namespace


IFieldMapping Members

[image] [image]

LinkOne WebView API
IFieldMapping Members
IFieldMapping Interface Methods Properties See Also Send Feedback

The IFieldMapping type exposes the following members.

Methods

Name | Description
Remove | Flags this note for deletion (the notes must be written for this to take effect, ). (Inherited from INote.)

Properties

Name | Description
Access | Gets or sets the access of the note. (Inherited from INote.)
Association | Gets the note association. (Inherited from INote.)
BookCode | Gets or sets the book code that this note is associatd with. (Inherited from INote.)
Group | Gets or sets the group of this translated note. (Inherited from ITranslatedNote.)
Id | Gets the unique ID of the note. (Inherited from INote.)
ItemId | Gets or sets the item id that this note is associated with. (Inherited from INote.)
LanguageCode | Gets or sets the ISO-639 compliant language code of the note. (Inherited from ITranslatedNote.)
MappedFrom | Gets or sets the field name or value that the field mapping is mapped from.
Name | Gets or sets the name of the field mapping.
PageReference | Gets or sets the page reference that this note is associated with. (Inherited from INote.)
PartNumber | Gets or sets the part number that this note is associated with. (Inherited from INote.)
PictureNumber | Gets or sets the picture number that this note is associated with. (Inherited from INote.)
PublisherCode | Gets or sets the publisher code that this note is associated with. (Inherited from INote.)
Scope | Gets the scope of the note. (Inherited from INote.)
Source | Gets the source of the field mapping.
Status | Gets the Status of the note. (Inherited from INote.)
TimeStamp | Gets the time stamp that indicates when the category was last written. (Inherited from INote.)
Translation | Gets or sets the description translation. (Inherited from ITranslatedNote.)
Type | Gets or sets the type of field mapping.

See Also

IFieldMapping Interface
Mincom.LinkOne.Dom.Notes Namespace


IFieldMapping Methods

[image] [image]

LinkOne WebView API
IFieldMapping Methods
IFieldMapping Interface See Also Send Feedback

The IFieldMapping type exposes the following members.

Methods

Name | Description
Remove | Flags this note for deletion (the notes must be written for this to take effect, ). (Inherited from INote.)

See Also

IFieldMapping Interface
Mincom.LinkOne.Dom.Notes Namespace


IFieldMapping Properties

[image] [image]

LinkOne WebView API
IFieldMapping Properties
IFieldMapping Interface See Also Send Feedback

The IFieldMapping type exposes the following members.

Properties

Name | Description
Access | Gets or sets the access of the note. (Inherited from INote.)
Association | Gets the note association. (Inherited from INote.)
BookCode | Gets or sets the book code that this note is associatd with. (Inherited from INote.)
Group | Gets or sets the group of this translated note. (Inherited from ITranslatedNote.)
Id | Gets the unique ID of the note. (Inherited from INote.)
ItemId | Gets or sets the item id that this note is associated with. (Inherited from INote.)
LanguageCode | Gets or sets the ISO-639 compliant language code of the note. (Inherited from ITranslatedNote.)
MappedFrom | Gets or sets the field name or value that the field mapping is mapped from.
Name | Gets or sets the name of the field mapping.
PageReference | Gets or sets the page reference that this note is associated with. (Inherited from INote.)
PartNumber | Gets or sets the part number that this note is associated with. (Inherited from INote.)
PictureNumber | Gets or sets the picture number that this note is associated with. (Inherited from INote.)
PublisherCode | Gets or sets the publisher code that this note is associated with. (Inherited from INote.)
Scope | Gets the scope of the note. (Inherited from INote.)
Source | Gets the source of the field mapping.
Status | Gets the Status of the note. (Inherited from INote.)
TimeStamp | Gets the time stamp that indicates when the category was last written. (Inherited from INote.)
Translation | Gets or sets the description translation. (Inherited from ITranslatedNote.)
Type | Gets or sets the type of field mapping.

See Also

IFieldMapping Interface
Mincom.LinkOne.Dom.Notes Namespace


MappedFrom Property

[image]

LinkOne WebView API
IFieldMapping..::.MappedFrom Property
IFieldMapping Interface See Also Send Feedback
Gets or sets the field name or value that the field mapping is mapped from.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string MappedFrom { get; set; }
Visual Basic (Declaration)
Property MappedFrom As String
Visual C++
property String^ MappedFrom {
    String^ get ();
    void set (String^ value);
}

See Also

IFieldMapping Interface
Mincom.LinkOne.Dom.Notes Namespace


Name Property

[image]

LinkOne WebView API
IFieldMapping..::.Name Property
IFieldMapping Interface See Also Send Feedback
Gets or sets the name of the field mapping.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Name { get; set; }
Visual Basic (Declaration)
Property Name As String
Visual C++
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

IFieldMapping Interface
Mincom.LinkOne.Dom.Notes Namespace


Source Property

[image]

LinkOne WebView API
IFieldMapping..::.Source Property
IFieldMapping Interface See Also Send Feedback
Gets the source of the field mapping.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
FieldMappingSourceType Source { get; }
Visual Basic (Declaration)
ReadOnly Property Source As FieldMappingSourceType
Visual C++
property FieldMappingSourceType Source {
    FieldMappingSourceType get ();
}

See Also

IFieldMapping Interface
Mincom.LinkOne.Dom.Notes Namespace


Type Property

[image]

LinkOne WebView API
IFieldMapping..::.Type Property
IFieldMapping Interface See Also Send Feedback
Gets or sets the type of field mapping.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
FieldMappingType Type { get; set; }
Visual Basic (Declaration)
Property Type As FieldMappingType
Visual C++
property FieldMappingType Type {
    FieldMappingType get ();
    void set (FieldMappingType value);
}

See Also

IFieldMapping Interface
Mincom.LinkOne.Dom.Notes Namespace


IFilterNote Interface

[image]

LinkOne WebView API
IFilterNote Interface
Members See Also Send Feedback
Represents a filter note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IFilterNote : INote
Visual Basic (Declaration)
Public Interface IFilterNote _
    Implements INote
Visual C++
public interface class IFilterNote : INote

See Also

IFilterNote Members
Mincom.LinkOne.Dom.Notes Namespace


IFilterNote Members

[image] [image]

LinkOne WebView API
IFilterNote Members
IFilterNote Interface Methods Properties See Also Send Feedback

The IFilterNote type exposes the following members.

Methods

Name | Description
Remove | Flags this note for deletion (the notes must be written for this to take effect, ). (Inherited from INote.)

Properties

Name | Description
Access | Gets or sets the access of the note. (Inherited from INote.)
Association | Gets the note association. (Inherited from INote.)
BookCode | Gets or sets the book code that this note is associatd with. (Inherited from INote.)
Comment | Gets or sets the comment of the filter note.
Id | Gets the unique ID of the note. (Inherited from INote.)
ItemId | Gets or sets the item id that this note is associated with. (Inherited from INote.)
Name | Gets or sets the name of the filter note.
PageReference | Gets or sets the page reference that this note is associated with. (Inherited from INote.)
PartNumber | Gets or sets the part number that this note is associated with. (Inherited from INote.)
PictureNumber | Gets or sets the picture number that this note is associated with. (Inherited from INote.)
PublisherCode | Gets or sets the publisher code that this note is associated with. (Inherited from INote.)
Scope | Gets the scope of the note. (Inherited from INote.)
Status | Gets the Status of the note. (Inherited from INote.)
TimeStamp | Gets the time stamp that indicates when the category was last written. (Inherited from INote.)
Value | Gets or sets the value of the filter note.

See Also

IFilterNote Interface
Mincom.LinkOne.Dom.Notes Namespace


IFilterNote Methods

[image] [image]

LinkOne WebView API
IFilterNote Methods
IFilterNote Interface See Also Send Feedback

The IFilterNote type exposes the following members.

Methods

Name | Description
Remove | Flags this note for deletion (the notes must be written for this to take effect, ). (Inherited from INote.)

See Also

IFilterNote Interface
Mincom.LinkOne.Dom.Notes Namespace


IFilterNote Properties

[image] [image]

LinkOne WebView API
IFilterNote Properties
IFilterNote Interface See Also Send Feedback

The IFilterNote type exposes the following members.

Properties

Name | Description
Access | Gets or sets the access of the note. (Inherited from INote.)
Association | Gets the note association. (Inherited from INote.)
BookCode | Gets or sets the book code that this note is associatd with. (Inherited from INote.)
Comment | Gets or sets the comment of the filter note.
Id | Gets the unique ID of the note. (Inherited from INote.)
ItemId | Gets or sets the item id that this note is associated with. (Inherited from INote.)
Name | Gets or sets the name of the filter note.
PageReference | Gets or sets the page reference that this note is associated with. (Inherited from INote.)
PartNumber | Gets or sets the part number that this note is associated with. (Inherited from INote.)
PictureNumber | Gets or sets the picture number that this note is associated with. (Inherited from INote.)
PublisherCode | Gets or sets the publisher code that this note is associated with. (Inherited from INote.)
Scope | Gets the scope of the note. (Inherited from INote.)
Status | Gets the Status of the note. (Inherited from INote.)
TimeStamp | Gets the time stamp that indicates when the category was last written. (Inherited from INote.)
Value | Gets or sets the value of the filter note.

See Also

IFilterNote Interface
Mincom.LinkOne.Dom.Notes Namespace


Comment Property

[image]

LinkOne WebView API
IFilterNote..::.Comment Property
IFilterNote Interface See Also Send Feedback
Gets or sets the comment of the filter note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Comment { get; set; }
Visual Basic (Declaration)
Property Comment As String
Visual C++
property String^ Comment {
    String^ get ();
    void set (String^ value);
}

See Also

IFilterNote Interface
Mincom.LinkOne.Dom.Notes Namespace


Name Property

[image]

LinkOne WebView API
IFilterNote..::.Name Property
IFilterNote Interface See Also Send Feedback
Gets or sets the name of the filter note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Name { get; set; }
Visual Basic (Declaration)
Property Name As String
Visual C++
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

IFilterNote Interface
Mincom.LinkOne.Dom.Notes Namespace


Value Property

[image]

LinkOne WebView API
IFilterNote..::.Value Property
IFilterNote Interface See Also Send Feedback
Gets or sets the value of the filter note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Value { get; set; }
Visual Basic (Declaration)
Property Value As String
Visual C++
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

IFilterNote Interface
Mincom.LinkOne.Dom.Notes Namespace


IHyperlinkNote Interface

[image]

LinkOne WebView API
IHyperlinkNote Interface
Members See Also Send Feedback
Represents a hyperlink note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IHyperlinkNote : IListNote,
    ICategorizedNote, ITranslatedNote, INote
Visual Basic (Declaration)
Public Interface IHyperlinkNote _
    Implements IListNote, ICategorizedNote, ITranslatedNote, INote
Visual C++
public interface class IHyperlinkNote : IListNote,
    ICategorizedNote, ITranslatedNote, INote

See Also

IHyperlinkNote Members
Mincom.LinkOne.Dom.Notes Namespace


IHyperlinkNote Members

[image] [image]

LinkOne WebView API
IHyperlinkNote Members
IHyperlinkNote Interface Methods Properties See Also Send Feedback

The IHyperlinkNote type exposes the following members.

Methods

Name | Description
Remove | Flags this note for deletion (the notes must be written for this to take effect, ). (Inherited from INote.)

Properties

Name | Description
Access | Gets or sets the access of the note. (Inherited from INote.)
Association | Gets the note association. (Inherited from INote.)
Behaviour | Gets or sets the behaviour of the list note. (Inherited from IListNote.)
BookCode | Gets or sets the book code that this note is associatd with. (Inherited from INote.)
Category | Gets or sets the note category, Code. (Inherited from ICategorizedNote.)
Description | Gets or sets the note description. (Inherited from ICategorizedNote.)
Group | Gets or sets the group of this translated note. (Inherited from ITranslatedNote.)
Id | Gets the unique ID of the note. (Inherited from INote.)
IsListNote | Gets or sets a value indicating whether this note should show in the notes list. (Inherited from IListNote.)
ItemId | Gets or sets the item id that this note is associated with. (Inherited from INote.)
LanguageCode | Gets or sets the ISO-639 compliant language code of the note. (Inherited from ITranslatedNote.)
Link | Gets or sets the link that this hyperlink note represents.
PageReference | Gets or sets the page reference that this note is associated with. (Inherited from INote.)
PartNumber | Gets or sets the part number that this note is associated with. (Inherited from INote.)
PictureNumber | Gets or sets the picture number that this note is associated with. (Inherited from INote.)
Prompt | Gets or sets the prompt for the hyperlink note.
PublisherCode | Gets or sets the publisher code that this note is associated with. (Inherited from INote.)
Scope | Gets the scope of the note. (Inherited from INote.)
Status | Gets the Status of the note. (Inherited from INote.)
TimeStamp | Gets the time stamp that indicates when the category was last written. (Inherited from INote.)
Translation | Gets or sets the description translation. (Inherited from ITranslatedNote.)

See Also

IHyperlinkNote Interface
Mincom.LinkOne.Dom.Notes Namespace


IHyperlinkNote Methods

[image] [image]

LinkOne WebView API
IHyperlinkNote Methods
IHyperlinkNote Interface See Also Send Feedback

The IHyperlinkNote type exposes the following members.

Methods

Name | Description
Remove | Flags this note for deletion (the notes must be written for this to take effect, ). (Inherited from INote.)

See Also

IHyperlinkNote Interface
Mincom.LinkOne.Dom.Notes Namespace


IHyperlinkNote Properties

[image] [image]

LinkOne WebView API
IHyperlinkNote Properties
IHyperlinkNote Interface See Also Send Feedback

The IHyperlinkNote type exposes the following members.

Properties

Name | Description
Access | Gets or sets the access of the note. (Inherited from INote.)
Association | Gets the note association. (Inherited from INote.)
Behaviour | Gets or sets the behaviour of the list note. (Inherited from IListNote.)
BookCode | Gets or sets the book code that this note is associatd with. (Inherited from INote.)
Category | Gets or sets the note category, Code. (Inherited from ICategorizedNote.)
Description | Gets or sets the note description. (Inherited from ICategorizedNote.)
Group | Gets or sets the group of this translated note. (Inherited from ITranslatedNote.)
Id | Gets the unique ID of the note. (Inherited from INote.)
IsListNote | Gets or sets a value indicating whether this note should show in the notes list. (Inherited from IListNote.)
ItemId | Gets or sets the item id that this note is associated with. (Inherited from INote.)
LanguageCode | Gets or sets the ISO-639 compliant language code of the note. (Inherited from ITranslatedNote.)
Link | Gets or sets the link that this hyperlink note represents.
PageReference | Gets or sets the page reference that this note is associated with. (Inherited from INote.)
PartNumber | Gets or sets the part number that this note is associated with. (Inherited from INote.)
PictureNumber | Gets or sets the picture number that this note is associated with. (Inherited from INote.)
Prompt | Gets or sets the prompt for the hyperlink note.
PublisherCode | Gets or sets the publisher code that this note is associated with. (Inherited from INote.)
Scope | Gets the scope of the note. (Inherited from INote.)
Status | Gets the Status of the note. (Inherited from INote.)
TimeStamp | Gets the time stamp that indicates when the category was last written. (Inherited from INote.)
Translation | Gets or sets the description translation. (Inherited from ITranslatedNote.)

See Also

IHyperlinkNote Interface
Mincom.LinkOne.Dom.Notes Namespace


Link Property

[image]

LinkOne WebView API
IHyperlinkNote..::.Link Property
IHyperlinkNote Interface See Also Send Feedback
Gets or sets the link that this hyperlink note represents.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Link { get; set; }
Visual Basic (Declaration)
Property Link As String
Visual C++
property String^ Link {
    String^ get ();
    void set (String^ value);
}

See Also

IHyperlinkNote Interface
Mincom.LinkOne.Dom.Notes Namespace


Prompt Property

[image]

LinkOne WebView API
IHyperlinkNote..::.Prompt Property
IHyperlinkNote Interface See Also Send Feedback
Gets or sets the prompt for the hyperlink note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Prompt { get; set; }
Visual Basic (Declaration)
Property Prompt As String
Visual C++
property String^ Prompt {
    String^ get ();
    void set (String^ value);
}

See Also

IHyperlinkNote Interface
Mincom.LinkOne.Dom.Notes Namespace


IListNote Interface

[image]

LinkOne WebView API
IListNote Interface
Members See Also Send Feedback
Represents a list note, a note that can be shown in the notes list.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IListNote : ICategorizedNote,
    ITranslatedNote, INote
Visual Basic (Declaration)
Public Interface IListNote _
    Implements ICategorizedNote, ITranslatedNote, INote
Visual C++
public interface class IListNote : ICategorizedNote,
    ITranslatedNote, INote

See Also

IListNote Members
Mincom.LinkOne.Dom.Notes Namespace


IListNote Members

[image] [image]

LinkOne WebView API
IListNote Members
IListNote Interface Methods Properties See Also Send Feedback

The IListNote type exposes the following members.

Methods

Name | Description
Remove | Flags this note for deletion (the notes must be written for this to take effect, ). (Inherited from INote.)

Properties

Name | Description
Access | Gets or sets the access of the note. (Inherited from INote.)
Association | Gets the note association. (Inherited from INote.)
Behaviour | Gets or sets the behaviour of the list note.
BookCode | Gets or sets the book code that this note is associatd with. (Inherited from INote.)
Category | Gets or sets the note category, Code. (Inherited from ICategorizedNote.)
Description | Gets or sets the note description. (Inherited from ICategorizedNote.)
Group | Gets or sets the group of this translated note. (Inherited from ITranslatedNote.)
Id | Gets the unique ID of the note. (Inherited from INote.)
IsListNote | Gets or sets a value indicating whether this note should show in the notes list.
ItemId | Gets or sets the item id that this note is associated with. (Inherited from INote.)
LanguageCode | Gets or sets the ISO-639 compliant language code of the note. (Inherited from ITranslatedNote.)
PageReference | Gets or sets the page reference that this note is associated with. (Inherited from INote.)
PartNumber | Gets or sets the part number that this note is associated with. (Inherited from INote.)
PictureNumber | Gets or sets the picture number that this note is associated with. (Inherited from INote.)
PublisherCode | Gets or sets the publisher code that this note is associated with. (Inherited from INote.)
Scope | Gets the scope of the note. (Inherited from INote.)
Status | Gets the Status of the note. (Inherited from INote.)
TimeStamp | Gets the time stamp that indicates when the category was last written. (Inherited from INote.)
Translation | Gets or sets the description translation. (Inherited from ITranslatedNote.)

See Also

IListNote Interface
Mincom.LinkOne.Dom.Notes Namespace


IListNote Methods

[image] [image]

LinkOne WebView API
IListNote Methods
IListNote Interface See Also Send Feedback

The IListNote type exposes the following members.

Methods

Name | Description
Remove | Flags this note for deletion (the notes must be written for this to take effect, ). (Inherited from INote.)

See Also

IListNote Interface
Mincom.LinkOne.Dom.Notes Namespace


IListNote Properties

[image] [image]

LinkOne WebView API
IListNote Properties
IListNote Interface See Also Send Feedback

The IListNote type exposes the following members.

Properties

Name | Description
Access | Gets or sets the access of the note. (Inherited from INote.)
Association | Gets the note association. (Inherited from INote.)
Behaviour | Gets or sets the behaviour of the list note.
BookCode | Gets or sets the book code that this note is associatd with. (Inherited from INote.)
Category | Gets or sets the note category, Code. (Inherited from ICategorizedNote.)
Description | Gets or sets the note description. (Inherited from ICategorizedNote.)
Group | Gets or sets the group of this translated note. (Inherited from ITranslatedNote.)
Id | Gets the unique ID of the note. (Inherited from INote.)
IsListNote | Gets or sets a value indicating whether this note should show in the notes list.
ItemId | Gets or sets the item id that this note is associated with. (Inherited from INote.)
LanguageCode | Gets or sets the ISO-639 compliant language code of the note. (Inherited from ITranslatedNote.)
PageReference | Gets or sets the page reference that this note is associated with. (Inherited from INote.)
PartNumber | Gets or sets the part number that this note is associated with. (Inherited from INote.)
PictureNumber | Gets or sets the picture number that this note is associated with. (Inherited from INote.)
PublisherCode | Gets or sets the publisher code that this note is associated with. (Inherited from INote.)
Scope | Gets the scope of the note. (Inherited from INote.)
Status | Gets the Status of the note. (Inherited from INote.)
TimeStamp | Gets the time stamp that indicates when the category was last written. (Inherited from INote.)
Translation | Gets or sets the description translation. (Inherited from ITranslatedNote.)

See Also

IListNote Interface
Mincom.LinkOne.Dom.Notes Namespace


Behaviour Property

[image]

LinkOne WebView API
IListNote..::.Behaviour Property
IListNote Interface See Also Send Feedback
Gets or sets the behaviour of the list note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
NoteBehaviour Behaviour { get; set; }
Visual Basic (Declaration)
Property Behaviour As NoteBehaviour
Visual C++
property NoteBehaviour Behaviour {
    NoteBehaviour get ();
    void set (NoteBehaviour value);
}

See Also

IListNote Interface
Mincom.LinkOne.Dom.Notes Namespace


IsListNote Property

[image]

LinkOne WebView API
IListNote..::.IsListNote Property
IListNote Interface See Also Send Feedback
Gets or sets a value indicating whether this note should show in the notes list.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IsListNote { get; set; }
Visual Basic (Declaration)
Property IsListNote As Boolean
Visual C++
property bool IsListNote {
    bool get ();
    void set (bool value);
}

See Also

IListNote Interface
Mincom.LinkOne.Dom.Notes Namespace


INote Interface

[image]

LinkOne WebView API
INote Interface
Members See Also Send Feedback
Represents a LinkOne note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface INote
Visual Basic (Declaration)
Public Interface INote
Visual C++
public interface class INote

See Also

INote Members
Mincom.LinkOne.Dom.Notes Namespace


INote Members

[image] [image]

LinkOne WebView API
INote Members
INote Interface Methods Properties See Also Send Feedback

The INote type exposes the following members.

Methods

Name | Description
Remove | Flags this note for deletion (the notes must be written for this to take effect, ).

Properties

Name | Description
Access | Gets or sets the access of the note.
Association | Gets the note association.
BookCode | Gets or sets the book code that this note is associatd with.
Id | Gets the unique ID of the note.
ItemId | Gets or sets the item id that this note is associated with.
PageReference | Gets or sets the page reference that this note is associated with.
PartNumber | Gets or sets the part number that this note is associated with.
PictureNumber | Gets or sets the picture number that this note is associated with.
PublisherCode | Gets or sets the publisher code that this note is associated with.
Scope | Gets the scope of the note.
Status | Gets the Status of the note.
TimeStamp | Gets the time stamp that indicates when the category was last written.

See Also

INote Interface
Mincom.LinkOne.Dom.Notes Namespace


INote Methods

[image] [image]

LinkOne WebView API
INote Methods
INote Interface See Also Send Feedback

The INote type exposes the following members.

Methods

Name | Description
Remove | Flags this note for deletion (the notes must be written for this to take effect, ).

See Also

INote Interface
Mincom.LinkOne.Dom.Notes Namespace


Remove Method

[image]

LinkOne WebView API
INote..::.Remove Method
INote Interface See Also Send Feedback
Flags this note for deletion (the notes must be written for this to take effect, ).

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void Remove()
Visual Basic (Declaration)
Sub Remove
Visual C++
void Remove()

See Also

INote Interface
Mincom.LinkOne.Dom.Notes Namespace
ILibrary..::.Write(IPersist)


INote Properties

[image] [image]

LinkOne WebView API
INote Properties
INote Interface See Also Send Feedback

The INote type exposes the following members.

Properties

Name | Description
Access | Gets or sets the access of the note.
Association | Gets the note association.
BookCode | Gets or sets the book code that this note is associatd with.
Id | Gets the unique ID of the note.
ItemId | Gets or sets the item id that this note is associated with.
PageReference | Gets or sets the page reference that this note is associated with.
PartNumber | Gets or sets the part number that this note is associated with.
PictureNumber | Gets or sets the picture number that this note is associated with.
PublisherCode | Gets or sets the publisher code that this note is associated with.
Scope | Gets the scope of the note.
Status | Gets the Status of the note.
TimeStamp | Gets the time stamp that indicates when the category was last written.

See Also

INote Interface
Mincom.LinkOne.Dom.Notes Namespace


Access Property

[image]

LinkOne WebView API
INote..::.Access Property
INote Interface See Also Send Feedback
Gets or sets the access of the note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
Access Access { get; set; }
Visual Basic (Declaration)
Property Access As Access
Visual C++
property Access Access {
    Access get ();
    void set (Access value);
}

See Also

INote Interface
Mincom.LinkOne.Dom.Notes Namespace


Association Property

[image]

LinkOne WebView API
INote..::.Association Property
INote Interface See Also Send Feedback
Gets the note association.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
Association Association { get; }
Visual Basic (Declaration)
ReadOnly Property Association As Association
Visual C++
property Association Association {
    Association get ();
}

See Also

INote Interface
Mincom.LinkOne.Dom.Notes Namespace


BookCode Property

[image]

LinkOne WebView API
INote..::.BookCode Property
INote Interface See Also Send Feedback
Gets or sets the book code that this note is associatd with.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string BookCode { get; set; }
Visual Basic (Declaration)
Property BookCode As String
Visual C++
property String^ BookCode {
    String^ get ();
    void set (String^ value);
}

See Also

INote Interface
Mincom.LinkOne.Dom.Notes Namespace


Id Property

[image]

LinkOne WebView API
INote..::.Id Property
INote Interface See Also Send Feedback
Gets the unique ID of the note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int Id { get; }
Visual Basic (Declaration)
ReadOnly Property Id As Integer
Visual C++
property int Id {
    int get ();
}

See Also

INote Interface
Mincom.LinkOne.Dom.Notes Namespace


ItemId Property

[image]

LinkOne WebView API
INote..::.ItemId Property
INote Interface See Also Send Feedback
Gets or sets the item id that this note is associated with.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string ItemId { get; set; }
Visual Basic (Declaration)
Property ItemId As String
Visual C++
property String^ ItemId {
    String^ get ();
    void set (String^ value);
}

See Also

INote Interface
Mincom.LinkOne.Dom.Notes Namespace


PageReference Property

[image]

LinkOne WebView API
INote..::.PageReference Property
INote Interface See Also Send Feedback
Gets or sets the page reference that this note is associated with.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string PageReference { get; set; }
Visual Basic (Declaration)
Property PageReference As String
Visual C++
property String^ PageReference {
    String^ get ();
    void set (String^ value);
}

See Also

INote Interface
Mincom.LinkOne.Dom.Notes Namespace


PartNumber Property

[image]

LinkOne WebView API
INote..::.PartNumber Property
INote Interface See Also Send Feedback
Gets or sets the part number that this note is associated with.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string PartNumber { get; set; }
Visual Basic (Declaration)
Property PartNumber As String
Visual C++
property String^ PartNumber {
    String^ get ();
    void set (String^ value);
}

See Also

INote Interface
Mincom.LinkOne.Dom.Notes Namespace


PictureNumber Property

[image]

LinkOne WebView API
INote..::.PictureNumber Property
INote Interface See Also Send Feedback
Gets or sets the picture number that this note is associated with.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int PictureNumber { get; set; }
Visual Basic (Declaration)
Property PictureNumber As Integer
Visual C++
property int PictureNumber {
    int get ();
    void set (int value);
}

See Also

INote Interface
Mincom.LinkOne.Dom.Notes Namespace


PublisherCode Property

[image]

LinkOne WebView API
INote..::.PublisherCode Property
INote Interface See Also Send Feedback
Gets or sets the publisher code that this note is associated with.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string PublisherCode { get; set; }
Visual Basic (Declaration)
Property PublisherCode As String
Visual C++
property String^ PublisherCode {
    String^ get ();
    void set (String^ value);
}

See Also

INote Interface
Mincom.LinkOne.Dom.Notes Namespace


Scope Property

[image]

LinkOne WebView API
INote..::.Scope Property
INote Interface See Also Send Feedback
Gets the scope of the note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
Scope Scope { get; }
Visual Basic (Declaration)
ReadOnly Property Scope As Scope
Visual C++
property Scope Scope {
    Scope get ();
}

See Also

INote Interface
Mincom.LinkOne.Dom.Notes Namespace


Status Property

[image]

LinkOne WebView API
INote..::.Status Property
INote Interface See Also Send Feedback
Gets the Status of the note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
Status Status { get; }
Visual Basic (Declaration)
ReadOnly Property Status As Status
Visual C++
property Status Status {
    Status get ();
}

See Also

INote Interface
Mincom.LinkOne.Dom.Notes Namespace


TimeStamp Property

[image]

LinkOne WebView API
INote..::.TimeStamp Property
INote Interface See Also Send Feedback
Gets the time stamp that indicates when the category was last written.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
DateTime TimeStamp { get; }
Visual Basic (Declaration)
ReadOnly Property TimeStamp As DateTime
Visual C++
property DateTime TimeStamp {
    DateTime get ();
}

See Also

INote Interface
Mincom.LinkOne.Dom.Notes Namespace


INoteCollection Interface

[image]

LinkOne WebView API
INoteCollection Interface
Members See Also Send Feedback
Represents a collection of notes.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface INoteCollection : ICollection<INote>,
    IEnumerable<INote>, IEnumerable, IPersist
Visual Basic (Declaration)
Public Interface INoteCollection _
    Implements ICollection(Of INote), IEnumerable(Of INote),  _
    IEnumerable, IPersist
Visual C++
public interface class INoteCollection : ICollection<INote^>,
    IEnumerable<INote^>, IEnumerable, IPersist

See Also

INoteCollection Members
Mincom.LinkOne.Dom.Notes Namespace


INoteCollection Members

[image] [image]

LinkOne WebView API
INoteCollection Members
INoteCollection Interface Methods Properties See Also Send Feedback

The INoteCollection type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( INote >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( INote >)>).)
Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from ICollection<(Of <( INote >)>).)
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( INote >)>).)
Create | Creates a new note object.
GetEnumerator | Overloaded.
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( INote >)>).)

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( INote >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( INote >)>).)

See Also

INoteCollection Interface
Mincom.LinkOne.Dom.Notes Namespace


INoteCollection Methods

[image] [image]

LinkOne WebView API
INoteCollection Methods
INoteCollection Interface See Also Send Feedback

The INoteCollection type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( INote >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( INote >)>).)
Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from ICollection<(Of <( INote >)>).)
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( INote >)>).)
Create | Creates a new note object.
GetEnumerator | Overloaded.
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( INote >)>).)

See Also

INoteCollection Interface
Mincom.LinkOne.Dom.Notes Namespace


Create Method

[image]

LinkOne WebView API
INoteCollection..::.Create Method
INoteCollection Interface See Also Send Feedback
Creates a new note object.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
INote Create(
    Type noteType
)
Visual Basic (Declaration)
Function Create ( _
    noteType As Type _
) As INote
Visual C++
INote^ Create(
    Type^ noteType
)

Parameters

noteType
Type: System..::.Type
Type of the note.

Return Value

A new note of the specified type, noteType.

Remarks

The following notes defined in the notes namespace can be instantiated:
Bookmark Cross reference note Field mapping Filter note Hyperlink note Program note Redline note Text note Value note

Exceptions

Exception | Condition
System..::.NotSupportedException | A note cannot be created for the specified type, see remarks.

See Also

INoteCollection Interface
Mincom.LinkOne.Dom.Notes Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
INoteCollection..::.GetEnumerator Method
INoteCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( INote >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

INoteCollection Interface
INoteCollection Members
Mincom.LinkOne.Dom.Notes Namespace


INoteCollection Properties

[image] [image]

LinkOne WebView API
INoteCollection Properties
INoteCollection Interface See Also Send Feedback

The INoteCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( INote >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( INote >)>).)

See Also

INoteCollection Interface
Mincom.LinkOne.Dom.Notes Namespace


IProgramNote Interface

[image]

LinkOne WebView API
IProgramNote Interface
Members See Also Send Feedback
Represents a program note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IProgramNote : IListNote,
    ICategorizedNote, ITranslatedNote, INote
Visual Basic (Declaration)
Public Interface IProgramNote _
    Implements IListNote, ICategorizedNote, ITranslatedNote, INote
Visual C++
public interface class IProgramNote : IListNote,
    ICategorizedNote, ITranslatedNote, INote

See Also

IProgramNote Members
Mincom.LinkOne.Dom.Notes Namespace


IProgramNote Members

[image] [image]

LinkOne WebView API
IProgramNote Members
IProgramNote Interface Methods Properties See Also Send Feedback

The IProgramNote type exposes the following members.

Methods

Name | Description
Remove | Flags this note for deletion (the notes must be written for this to take effect, ). (Inherited from INote.)

Properties

Name | Description
Access | Gets or sets the access of the note. (Inherited from INote.)
Association | Gets the note association. (Inherited from INote.)
Behaviour | Gets or sets the behaviour of the list note. (Inherited from IListNote.)
BookCode | Gets or sets the book code that this note is associatd with. (Inherited from INote.)
Category | Gets or sets the note category, Code. (Inherited from ICategorizedNote.)
CommandLine | Gets or sets the command line of the program note.
DdeCommandLine | Gets or sets the DDE command line of the program note.
DdeServiceName | Gets or sets the name of the DDE service of the program note.
DdeTopicName | Gets or sets the name of the DDE topic of the program note.
Description | Gets or sets the note description. (Inherited from ICategorizedNote.)
Group | Gets or sets the group of this translated note. (Inherited from ITranslatedNote.)
Id | Gets the unique ID of the note. (Inherited from INote.)
IsListNote | Gets or sets a value indicating whether this note should show in the notes list. (Inherited from IListNote.)
ItemId | Gets or sets the item id that this note is associated with. (Inherited from INote.)
LanguageCode | Gets or sets the ISO-639 compliant language code of the note. (Inherited from ITranslatedNote.)
PageReference | Gets or sets the page reference that this note is associated with. (Inherited from INote.)
PartNumber | Gets or sets the part number that this note is associated with. (Inherited from INote.)
PictureNumber | Gets or sets the picture number that this note is associated with. (Inherited from INote.)
PublisherCode | Gets or sets the publisher code that this note is associated with. (Inherited from INote.)
Scope | Gets the scope of the note. (Inherited from INote.)
Status | Gets the Status of the note. (Inherited from INote.)
TimeStamp | Gets the time stamp that indicates when the category was last written. (Inherited from INote.)
Translation | Gets or sets the description translation. (Inherited from ITranslatedNote.)

See Also

IProgramNote Interface
Mincom.LinkOne.Dom.Notes Namespace


IProgramNote Methods

[image] [image]

LinkOne WebView API
IProgramNote Methods
IProgramNote Interface See Also Send Feedback

The IProgramNote type exposes the following members.

Methods

Name | Description
Remove | Flags this note for deletion (the notes must be written for this to take effect, ). (Inherited from INote.)

See Also

IProgramNote Interface
Mincom.LinkOne.Dom.Notes Namespace


IProgramNote Properties

[image] [image]

LinkOne WebView API
IProgramNote Properties
IProgramNote Interface See Also Send Feedback

The IProgramNote type exposes the following members.

Properties

Name | Description
Access | Gets or sets the access of the note. (Inherited from INote.)
Association | Gets the note association. (Inherited from INote.)
Behaviour | Gets or sets the behaviour of the list note. (Inherited from IListNote.)
BookCode | Gets or sets the book code that this note is associatd with. (Inherited from INote.)
Category | Gets or sets the note category, Code. (Inherited from ICategorizedNote.)
CommandLine | Gets or sets the command line of the program note.
DdeCommandLine | Gets or sets the DDE command line of the program note.
DdeServiceName | Gets or sets the name of the DDE service of the program note.
DdeTopicName | Gets or sets the name of the DDE topic of the program note.
Description | Gets or sets the note description. (Inherited from ICategorizedNote.)
Group | Gets or sets the group of this translated note. (Inherited from ITranslatedNote.)
Id | Gets the unique ID of the note. (Inherited from INote.)
IsListNote | Gets or sets a value indicating whether this note should show in the notes list. (Inherited from IListNote.)
ItemId | Gets or sets the item id that this note is associated with. (Inherited from INote.)
LanguageCode | Gets or sets the ISO-639 compliant language code of the note. (Inherited from ITranslatedNote.)
PageReference | Gets or sets the page reference that this note is associated with. (Inherited from INote.)
PartNumber | Gets or sets the part number that this note is associated with. (Inherited from INote.)
PictureNumber | Gets or sets the picture number that this note is associated with. (Inherited from INote.)
PublisherCode | Gets or sets the publisher code that this note is associated with. (Inherited from INote.)
Scope | Gets the scope of the note. (Inherited from INote.)
Status | Gets the Status of the note. (Inherited from INote.)
TimeStamp | Gets the time stamp that indicates when the category was last written. (Inherited from INote.)
Translation | Gets or sets the description translation. (Inherited from ITranslatedNote.)

See Also

IProgramNote Interface
Mincom.LinkOne.Dom.Notes Namespace


CommandLine Property

[image]

LinkOne WebView API
IProgramNote..::.CommandLine Property
IProgramNote Interface See Also Send Feedback
Gets or sets the command line of the program note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string CommandLine { get; set; }
Visual Basic (Declaration)
Property CommandLine As String
Visual C++
property String^ CommandLine {
    String^ get ();
    void set (String^ value);
}

See Also

IProgramNote Interface
Mincom.LinkOne.Dom.Notes Namespace


DdeCommandLine Property

[image]

LinkOne WebView API
IProgramNote..::.DdeCommandLine Property
IProgramNote Interface See Also Send Feedback
Gets or sets the DDE command line of the program note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string DdeCommandLine { get; set; }
Visual Basic (Declaration)
Property DdeCommandLine As String
Visual C++
property String^ DdeCommandLine {
    String^ get ();
    void set (String^ value);
}

See Also

IProgramNote Interface
Mincom.LinkOne.Dom.Notes Namespace


DdeServiceName Property

[image]

LinkOne WebView API
IProgramNote..::.DdeServiceName Property
IProgramNote Interface See Also Send Feedback
Gets or sets the name of the DDE service of the program note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string DdeServiceName { get; set; }
Visual Basic (Declaration)
Property DdeServiceName As String
Visual C++
property String^ DdeServiceName {
    String^ get ();
    void set (String^ value);
}

See Also

IProgramNote Interface
Mincom.LinkOne.Dom.Notes Namespace


DdeTopicName Property

[image]

LinkOne WebView API
IProgramNote..::.DdeTopicName Property
IProgramNote Interface See Also Send Feedback
Gets or sets the name of the DDE topic of the program note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string DdeTopicName { get; set; }
Visual Basic (Declaration)
Property DdeTopicName As String
Visual C++
property String^ DdeTopicName {
    String^ get ();
    void set (String^ value);
}

See Also

IProgramNote Interface
Mincom.LinkOne.Dom.Notes Namespace


IRedlineNote Interface

[image]

LinkOne WebView API
IRedlineNote Interface
Members See Also Send Feedback
Represents a redline note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IRedlineNote : ICategorizedNote,
    ITranslatedNote, INote
Visual Basic (Declaration)
Public Interface IRedlineNote _
    Implements ICategorizedNote, ITranslatedNote, INote
Visual C++
public interface class IRedlineNote : ICategorizedNote,
    ITranslatedNote, INote

See Also

IRedlineNote Members
Mincom.LinkOne.Dom.Notes Namespace


IRedlineNote Members

[image] [image]

LinkOne WebView API
IRedlineNote Members
IRedlineNote Interface Methods Properties See Also Send Feedback

The IRedlineNote type exposes the following members.

Methods

Name | Description
Remove | Flags this note for deletion (the notes must be written for this to take effect, ). (Inherited from INote.)

Properties

Name | Description
Access | Gets or sets the access of the note. (Inherited from INote.)
Association | Gets the note association. (Inherited from INote.)
BookCode | Gets or sets the book code that this note is associatd with. (Inherited from INote.)
Category | Gets or sets the note category, Code. (Inherited from ICategorizedNote.)
Description | Gets or sets the note description. (Inherited from ICategorizedNote.)
DrawingElements | Gets or sets the drawing elements.
Group | Gets or sets the group of this translated note. (Inherited from ITranslatedNote.)
Id | Gets the unique ID of the note. (Inherited from INote.)
ItemId | Gets or sets the item id that this note is associated with. (Inherited from INote.)
LanguageCode | Gets or sets the ISO-639 compliant language code of the note. (Inherited from ITranslatedNote.)
PageReference | Gets or sets the page reference that this note is associated with. (Inherited from INote.)
PartNumber | Gets or sets the part number that this note is associated with. (Inherited from INote.)
PictureNumber | Gets or sets the picture number that this note is associated with. (Inherited from INote.)
PublisherCode | Gets or sets the publisher code that this note is associated with. (Inherited from INote.)
Scope | Gets the scope of the note. (Inherited from INote.)
Status | Gets the Status of the note. (Inherited from INote.)
TimeStamp | Gets the time stamp that indicates when the category was last written. (Inherited from INote.)
Translation | Gets or sets the description translation. (Inherited from ITranslatedNote.)

See Also

IRedlineNote Interface
Mincom.LinkOne.Dom.Notes Namespace


IRedlineNote Methods

[image] [image]

LinkOne WebView API
IRedlineNote Methods
IRedlineNote Interface See Also Send Feedback

The IRedlineNote type exposes the following members.

Methods

Name | Description
Remove | Flags this note for deletion (the notes must be written for this to take effect, ). (Inherited from INote.)

See Also

IRedlineNote Interface
Mincom.LinkOne.Dom.Notes Namespace


IRedlineNote Properties

[image] [image]

LinkOne WebView API
IRedlineNote Properties
IRedlineNote Interface See Also Send Feedback

The IRedlineNote type exposes the following members.

Properties

Name | Description
Access | Gets or sets the access of the note. (Inherited from INote.)
Association | Gets the note association. (Inherited from INote.)
BookCode | Gets or sets the book code that this note is associatd with. (Inherited from INote.)
Category | Gets or sets the note category, Code. (Inherited from ICategorizedNote.)
Description | Gets or sets the note description. (Inherited from ICategorizedNote.)
DrawingElements | Gets or sets the drawing elements.
Group | Gets or sets the group of this translated note. (Inherited from ITranslatedNote.)
Id | Gets the unique ID of the note. (Inherited from INote.)
ItemId | Gets or sets the item id that this note is associated with. (Inherited from INote.)
LanguageCode | Gets or sets the ISO-639 compliant language code of the note. (Inherited from ITranslatedNote.)
PageReference | Gets or sets the page reference that this note is associated with. (Inherited from INote.)
PartNumber | Gets or sets the part number that this note is associated with. (Inherited from INote.)
PictureNumber | Gets or sets the picture number that this note is associated with. (Inherited from INote.)
PublisherCode | Gets or sets the publisher code that this note is associated with. (Inherited from INote.)
Scope | Gets the scope of the note. (Inherited from INote.)
Status | Gets the Status of the note. (Inherited from INote.)
TimeStamp | Gets the time stamp that indicates when the category was last written. (Inherited from INote.)
Translation | Gets or sets the description translation. (Inherited from ITranslatedNote.)

See Also

IRedlineNote Interface
Mincom.LinkOne.Dom.Notes Namespace


DrawingElements Property

[image]

LinkOne WebView API
IRedlineNote..::.DrawingElements Property
IRedlineNote Interface See Also Send Feedback
Gets or sets the drawing elements.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDrawingElementCollection DrawingElements { get; set; }
Visual Basic (Declaration)
Property DrawingElements As IDrawingElementCollection
Visual C++
property IDrawingElementCollection^ DrawingElements {
    IDrawingElementCollection^ get ();
    void set (IDrawingElementCollection^ value);
}

See Also

IRedlineNote Interface
Mincom.LinkOne.Dom.Notes Namespace


ITextNote Interface

[image]

LinkOne WebView API
ITextNote Interface
Members See Also Send Feedback
Represents a text note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ITextNote : IListNote,
    ICategorizedNote, ITranslatedNote, INote
Visual Basic (Declaration)
Public Interface ITextNote _
    Implements IListNote, ICategorizedNote, ITranslatedNote, INote
Visual C++
public interface class ITextNote : IListNote,
    ICategorizedNote, ITranslatedNote, INote

See Also

ITextNote Members
Mincom.LinkOne.Dom.Notes Namespace


ITextNote Members

[image] [image]

LinkOne WebView API
ITextNote Members
ITextNote Interface Methods Properties See Also Send Feedback

The ITextNote type exposes the following members.

Methods

Name | Description
Remove | Flags this note for deletion (the notes must be written for this to take effect, ). (Inherited from INote.)

Properties

Name | Description
Access | Gets or sets the access of the note. (Inherited from INote.)
Annotation | Gets or sets the annotation.
Association | Gets the note association. (Inherited from INote.)
Behaviour | Gets or sets the behaviour of the list note. (Inherited from IListNote.)
BookCode | Gets or sets the book code that this note is associatd with. (Inherited from INote.)
Category | Gets or sets the note category, Code. (Inherited from ICategorizedNote.)
Description | Gets or sets the note description. (Inherited from ICategorizedNote.)
Group | Gets or sets the group of this translated note. (Inherited from ITranslatedNote.)
Height | Gets or sets the height of the text note.
HideCaption | Gets or sets a value indicating whether the caption is hidden.
Id | Gets the unique ID of the note. (Inherited from INote.)
IsListNote | Gets or sets a value indicating whether this note should show in the notes list. (Inherited from IListNote.)
ItemId | Gets or sets the item id that this note is associated with. (Inherited from INote.)
LanguageCode | Gets or sets the ISO-639 compliant language code of the note. (Inherited from ITranslatedNote.)
PageReference | Gets or sets the page reference that this note is associated with. (Inherited from INote.)
PartNumber | Gets or sets the part number that this note is associated with. (Inherited from INote.)
PictureNumber | Gets or sets the picture number that this note is associated with. (Inherited from INote.)
PublisherCode | Gets or sets the publisher code that this note is associated with. (Inherited from INote.)
Scope | Gets the scope of the note. (Inherited from INote.)
Status | Gets the Status of the note. (Inherited from INote.)
TimeStamp | Gets the time stamp that indicates when the category was last written. (Inherited from INote.)
Translation | Gets or sets the description translation. (Inherited from ITranslatedNote.)
Width | Gets or sets the width of the text note.

See Also

ITextNote Interface
Mincom.LinkOne.Dom.Notes Namespace


ITextNote Methods

[image] [image]

LinkOne WebView API
ITextNote Methods
ITextNote Interface See Also Send Feedback

The ITextNote type exposes the following members.

Methods

Name | Description
Remove | Flags this note for deletion (the notes must be written for this to take effect, ). (Inherited from INote.)

See Also

ITextNote Interface
Mincom.LinkOne.Dom.Notes Namespace


ITextNote Properties

[image] [image]

LinkOne WebView API
ITextNote Properties
ITextNote Interface See Also Send Feedback

The ITextNote type exposes the following members.

Properties

Name | Description
Access | Gets or sets the access of the note. (Inherited from INote.)
Annotation | Gets or sets the annotation.
Association | Gets the note association. (Inherited from INote.)
Behaviour | Gets or sets the behaviour of the list note. (Inherited from IListNote.)
BookCode | Gets or sets the book code that this note is associatd with. (Inherited from INote.)
Category | Gets or sets the note category, Code. (Inherited from ICategorizedNote.)
Description | Gets or sets the note description. (Inherited from ICategorizedNote.)
Group | Gets or sets the group of this translated note. (Inherited from ITranslatedNote.)
Height | Gets or sets the height of the text note.
HideCaption | Gets or sets a value indicating whether the caption is hidden.
Id | Gets the unique ID of the note. (Inherited from INote.)
IsListNote | Gets or sets a value indicating whether this note should show in the notes list. (Inherited from IListNote.)
ItemId | Gets or sets the item id that this note is associated with. (Inherited from INote.)
LanguageCode | Gets or sets the ISO-639 compliant language code of the note. (Inherited from ITranslatedNote.)
PageReference | Gets or sets the page reference that this note is associated with. (Inherited from INote.)
PartNumber | Gets or sets the part number that this note is associated with. (Inherited from INote.)
PictureNumber | Gets or sets the picture number that this note is associated with. (Inherited from INote.)
PublisherCode | Gets or sets the publisher code that this note is associated with. (Inherited from INote.)
Scope | Gets the scope of the note. (Inherited from INote.)
Status | Gets the Status of the note. (Inherited from INote.)
TimeStamp | Gets the time stamp that indicates when the category was last written. (Inherited from INote.)
Translation | Gets or sets the description translation. (Inherited from ITranslatedNote.)
Width | Gets or sets the width of the text note.

See Also

ITextNote Interface
Mincom.LinkOne.Dom.Notes Namespace


Annotation Property

[image]

LinkOne WebView API
ITextNote..::.Annotation Property
ITextNote Interface See Also Send Feedback
Gets or sets the annotation.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Annotation { get; set; }
Visual Basic (Declaration)
Property Annotation As String
Visual C++
property String^ Annotation {
    String^ get ();
    void set (String^ value);
}

See Also

ITextNote Interface
Mincom.LinkOne.Dom.Notes Namespace


Height Property

[image]

LinkOne WebView API
ITextNote..::.Height Property
ITextNote Interface See Also Send Feedback
Gets or sets the height of the text note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int Height { get; set; }
Visual Basic (Declaration)
Property Height As Integer
Visual C++
property int Height {
    int get ();
    void set (int value);
}

See Also

ITextNote Interface
Mincom.LinkOne.Dom.Notes Namespace


HideCaption Property

[image]

LinkOne WebView API
ITextNote..::.HideCaption Property
ITextNote Interface See Also Send Feedback
Gets or sets a value indicating whether the caption is hidden.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool HideCaption { get; set; }
Visual Basic (Declaration)
Property HideCaption As Boolean
Visual C++
property bool HideCaption {
    bool get ();
    void set (bool value);
}

See Also

ITextNote Interface
Mincom.LinkOne.Dom.Notes Namespace


Width Property

[image]

LinkOne WebView API
ITextNote..::.Width Property
ITextNote Interface See Also Send Feedback
Gets or sets the width of the text note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int Width { get; set; }
Visual Basic (Declaration)
Property Width As Integer
Visual C++
property int Width {
    int get ();
    void set (int value);
}

See Also

ITextNote Interface
Mincom.LinkOne.Dom.Notes Namespace


ITranslatedNote Interface

[image]

LinkOne WebView API
ITranslatedNote Interface
Members See Also Send Feedback
Represents a note that is translatable.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ITranslatedNote : INote
Visual Basic (Declaration)
Public Interface ITranslatedNote _
    Implements INote
Visual C++
public interface class ITranslatedNote : INote

See Also

ITranslatedNote Members
Mincom.LinkOne.Dom.Notes Namespace


ITranslatedNote Members

[image] [image]

LinkOne WebView API
ITranslatedNote Members
ITranslatedNote Interface Methods Properties See Also Send Feedback

The ITranslatedNote type exposes the following members.

Methods

Name | Description
Remove | Flags this note for deletion (the notes must be written for this to take effect, ). (Inherited from INote.)

Properties

Name | Description
Access | Gets or sets the access of the note. (Inherited from INote.)
Association | Gets the note association. (Inherited from INote.)
BookCode | Gets or sets the book code that this note is associatd with. (Inherited from INote.)
Group | Gets or sets the group of this translated note.
Id | Gets the unique ID of the note. (Inherited from INote.)
ItemId | Gets or sets the item id that this note is associated with. (Inherited from INote.)
LanguageCode | Gets or sets the ISO-639 compliant language code of the note.
PageReference | Gets or sets the page reference that this note is associated with. (Inherited from INote.)
PartNumber | Gets or sets the part number that this note is associated with. (Inherited from INote.)
PictureNumber | Gets or sets the picture number that this note is associated with. (Inherited from INote.)
PublisherCode | Gets or sets the publisher code that this note is associated with. (Inherited from INote.)
Scope | Gets the scope of the note. (Inherited from INote.)
Status | Gets the Status of the note. (Inherited from INote.)
TimeStamp | Gets the time stamp that indicates when the category was last written. (Inherited from INote.)
Translation | Gets or sets the description translation.

See Also

ITranslatedNote Interface
Mincom.LinkOne.Dom.Notes Namespace


ITranslatedNote Methods

[image] [image]

LinkOne WebView API
ITranslatedNote Methods
ITranslatedNote Interface See Also Send Feedback

The ITranslatedNote type exposes the following members.

Methods

Name | Description
Remove | Flags this note for deletion (the notes must be written for this to take effect, ). (Inherited from INote.)

See Also

ITranslatedNote Interface
Mincom.LinkOne.Dom.Notes Namespace


ITranslatedNote Properties

[image] [image]

LinkOne WebView API
ITranslatedNote Properties
ITranslatedNote Interface See Also Send Feedback

The ITranslatedNote type exposes the following members.

Properties

Name | Description
Access | Gets or sets the access of the note. (Inherited from INote.)
Association | Gets the note association. (Inherited from INote.)
BookCode | Gets or sets the book code that this note is associatd with. (Inherited from INote.)
Group | Gets or sets the group of this translated note.
Id | Gets the unique ID of the note. (Inherited from INote.)
ItemId | Gets or sets the item id that this note is associated with. (Inherited from INote.)
LanguageCode | Gets or sets the ISO-639 compliant language code of the note.
PageReference | Gets or sets the page reference that this note is associated with. (Inherited from INote.)
PartNumber | Gets or sets the part number that this note is associated with. (Inherited from INote.)
PictureNumber | Gets or sets the picture number that this note is associated with. (Inherited from INote.)
PublisherCode | Gets or sets the publisher code that this note is associated with. (Inherited from INote.)
Scope | Gets the scope of the note. (Inherited from INote.)
Status | Gets the Status of the note. (Inherited from INote.)
TimeStamp | Gets the time stamp that indicates when the category was last written. (Inherited from INote.)
Translation | Gets or sets the description translation.

See Also

ITranslatedNote Interface
Mincom.LinkOne.Dom.Notes Namespace


Group Property

[image]

LinkOne WebView API
ITranslatedNote..::.Group Property
ITranslatedNote Interface See Also Send Feedback
Gets or sets the group of this translated note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Group { get; set; }
Visual Basic (Declaration)
Property Group As String
Visual C++
property String^ Group {
    String^ get ();
    void set (String^ value);
}

See Also

ITranslatedNote Interface
Mincom.LinkOne.Dom.Notes Namespace


LanguageCode Property

[image]

LinkOne WebView API
ITranslatedNote..::.LanguageCode Property
ITranslatedNote Interface See Also Send Feedback
Gets or sets the ISO-639 compliant language code of the note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string LanguageCode { get; set; }
Visual Basic (Declaration)
Property LanguageCode As String
Visual C++
property String^ LanguageCode {
    String^ get ();
    void set (String^ value);
}

See Also

ITranslatedNote Interface
Mincom.LinkOne.Dom.Notes Namespace


Translation Property

[image]

LinkOne WebView API
ITranslatedNote..::.Translation Property
ITranslatedNote Interface See Also Send Feedback
Gets or sets the description translation.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Translation { get; set; }
Visual Basic (Declaration)
Property Translation As String
Visual C++
property String^ Translation {
    String^ get ();
    void set (String^ value);
}

See Also

ITranslatedNote Interface
Mincom.LinkOne.Dom.Notes Namespace


IValueNote Interface

[image]

LinkOne WebView API
IValueNote Interface
Members See Also Send Feedback
Represents a value note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IValueNote : INote
Visual Basic (Declaration)
Public Interface IValueNote _
    Implements INote
Visual C++
public interface class IValueNote : INote

See Also

IValueNote Members
Mincom.LinkOne.Dom.Notes Namespace


IValueNote Members

[image] [image]

LinkOne WebView API
IValueNote Members
IValueNote Interface Methods Properties See Also Send Feedback

The IValueNote type exposes the following members.

Methods

Name | Description
Remove | Flags this note for deletion (the notes must be written for this to take effect, ). (Inherited from INote.)

Properties

Name | Description
Access | Gets or sets the access of the note. (Inherited from INote.)
Association | Gets the note association. (Inherited from INote.)
BookCode | Gets or sets the book code that this note is associatd with. (Inherited from INote.)
Id | Gets the unique ID of the note. (Inherited from INote.)
ItemId | Gets or sets the item id that this note is associated with. (Inherited from INote.)
Name | Gets or sets the name of the value note.
PageReference | Gets or sets the page reference that this note is associated with. (Inherited from INote.)
PartNumber | Gets or sets the part number that this note is associated with. (Inherited from INote.)
PictureNumber | Gets or sets the picture number that this note is associated with. (Inherited from INote.)
PublisherCode | Gets or sets the publisher code that this note is associated with. (Inherited from INote.)
Scope | Gets the scope of the note. (Inherited from INote.)
Status | Gets the Status of the note. (Inherited from INote.)
TimeStamp | Gets the time stamp that indicates when the category was last written. (Inherited from INote.)
Value | Gets or sets the value of the value note.

See Also

IValueNote Interface
Mincom.LinkOne.Dom.Notes Namespace


IValueNote Methods

[image] [image]

LinkOne WebView API
IValueNote Methods
IValueNote Interface See Also Send Feedback

The IValueNote type exposes the following members.

Methods

Name | Description
Remove | Flags this note for deletion (the notes must be written for this to take effect, ). (Inherited from INote.)

See Also

IValueNote Interface
Mincom.LinkOne.Dom.Notes Namespace


IValueNote Properties

[image] [image]

LinkOne WebView API
IValueNote Properties
IValueNote Interface See Also Send Feedback

The IValueNote type exposes the following members.

Properties

Name | Description
Access | Gets or sets the access of the note. (Inherited from INote.)
Association | Gets the note association. (Inherited from INote.)
BookCode | Gets or sets the book code that this note is associatd with. (Inherited from INote.)
Id | Gets the unique ID of the note. (Inherited from INote.)
ItemId | Gets or sets the item id that this note is associated with. (Inherited from INote.)
Name | Gets or sets the name of the value note.
PageReference | Gets or sets the page reference that this note is associated with. (Inherited from INote.)
PartNumber | Gets or sets the part number that this note is associated with. (Inherited from INote.)
PictureNumber | Gets or sets the picture number that this note is associated with. (Inherited from INote.)
PublisherCode | Gets or sets the publisher code that this note is associated with. (Inherited from INote.)
Scope | Gets the scope of the note. (Inherited from INote.)
Status | Gets the Status of the note. (Inherited from INote.)
TimeStamp | Gets the time stamp that indicates when the category was last written. (Inherited from INote.)
Value | Gets or sets the value of the value note.

See Also

IValueNote Interface
Mincom.LinkOne.Dom.Notes Namespace


Name Property

[image]

LinkOne WebView API
IValueNote..::.Name Property
IValueNote Interface See Also Send Feedback
Gets or sets the name of the value note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Name { get; set; }
Visual Basic (Declaration)
Property Name As String
Visual C++
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

IValueNote Interface
Mincom.LinkOne.Dom.Notes Namespace


Value Property

[image]

LinkOne WebView API
IValueNote..::.Value Property
IValueNote Interface See Also Send Feedback
Gets or sets the value of the value note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Value { get; set; }
Visual Basic (Declaration)
Property Value As String
Visual C++
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

IValueNote Interface
Mincom.LinkOne.Dom.Notes Namespace


ListNote Class

[image]

LinkOne WebView API
ListNote Class
Members See Also Send Feedback
The base class for a listable LinkOne note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public abstract class ListNote : CategorizedNote,
    IListNote, ICategorizedNote, ITranslatedNote, INote
Visual Basic (Declaration)
<SerializableAttribute> _
Public MustInherit Class ListNote _
    Inherits CategorizedNote _
    Implements IListNote, ICategorizedNote, ITranslatedNote, INote
Visual C++
[SerializableAttribute]
public ref class ListNote abstract : public CategorizedNote,
    IListNote, ICategorizedNote, ITranslatedNote, INote

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Notes..::.Note
Mincom.LinkOne.Dom.Notes..::.TranslatedNote
Mincom.LinkOne.Dom.Notes..::.CategorizedNote
Mincom.LinkOne.Dom.Notes..::.ListNote
Mincom.LinkOne.Dom.Notes..::.CrossReferenceNote
Mincom.LinkOne.Dom.Notes..::.HyperlinkNote
Mincom.LinkOne.Dom.Notes..::.MacroNote
Mincom.LinkOne.Dom.Notes..::.ProgramNote
Mincom.LinkOne.Dom.Notes..::.TextNote

See Also

ListNote Members
Mincom.LinkOne.Dom.Notes Namespace


ListNote Members

[image] [image]

LinkOne WebView API
ListNote Members
ListNote Class Constructors Methods Properties See Also Send Feedback

The ListNote type exposes the following members.

Constructors

Name | Description
ListNote | Creates an instance of the ListNote.

Methods

Name | Description
CanSetAccess | Determines whether this Note instance can set the Access to the specified value. (Inherited from Note.)
CanSetAssociation | Determines whether this Note instance can set Association to the specified value. (Inherited from Note.)
CanSetScope | Determines whether this Note instance can set Scope to the the specified value. (Inherited from Note.)
Clone | Gets a clone of the this. (Inherited from Note.)
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the hash code for the object. (Inherited from Note.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanging | Sets the note status to changed. (Inherited from Note.)
Remove | Sets the note status to Deleted. (Inherited from Note.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Overloaded.

Properties

Name | Description
Access | Gets or sets the note access. (Inherited from Note.)
Association | Gets what the note is associated with. (Inherited from Note.)
Behaviour | Gets or sets the note behaviour.
BookCode | Gets or sets the book code of the note. (Inherited from Note.)
Category | Gets or sets the note category. (Inherited from CategorizedNote.)
Description | Gets or sets the description of the note. (Inherited from CategorizedNote.)
DisplayName | See DisplayName for more information. (Inherited from CategorizedNote.)
Group | Gets or sets the group identifier of the note. (Inherited from TranslatedNote.)
Id | Gets or sets the unique ID of the note. (Inherited from Note.)
IsListNote | Gets or sets whether the note appears in the notes list.
ItemId | Gets or sets the item ID of the note. (Inherited from Note.)
Key | Gets a key that uniquely defines the note. (Overrides CategorizedNote..::.Key.)
LanguageCode | Gets or sets the language code. (Inherited from TranslatedNote.)
OriginalNote | Gets or the original note; or null if the note hasn't changed. (Inherited from Note.)
PageReference | Gets or sets the page reference of the note. (Inherited from Note.)
PartNumber | Gets or sets the part number of the note. (Inherited from Note.)
PictureNumber | Gets or sets the picture number of the redline note. (Inherited from Note.)
PublisherCode | Gets or sets the publisher code of the note. (Inherited from Note.)
Scope | Gets the note scope. (Inherited from Note.)
Status | Gets or sets the status of the note in relation to the copy saved in persistent storage. (Inherited from Note.)
TimeStamp | Gets or sets the date and time when the note was last written. (Inherited from Note.)
Translation | Gets or sets the translation of the note. (Inherited from TranslatedNote.)
Xml | Gets the XML representing the note. (Inherited from Note.)

See Also

ListNote Class
Mincom.LinkOne.Dom.Notes Namespace


ListNote Constructor

[image]

LinkOne WebView API
ListNote Constructor
ListNote Class See Also Send Feedback
Creates an instance of the ListNote.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected ListNote()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
ListNote()

See Also

ListNote Class
Mincom.LinkOne.Dom.Notes Namespace


ListNote Methods

[image] [image]

LinkOne WebView API
ListNote Methods
ListNote Class See Also Send Feedback

The ListNote type exposes the following members.

Methods

Name | Description
CanSetAccess | Determines whether this Note instance can set the Access to the specified value. (Inherited from Note.)
CanSetAssociation | Determines whether this Note instance can set Association to the specified value. (Inherited from Note.)
CanSetScope | Determines whether this Note instance can set Scope to the the specified value. (Inherited from Note.)
Clone | Gets a clone of the this. (Inherited from Note.)
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the hash code for the object. (Inherited from Note.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanging | Sets the note status to changed. (Inherited from Note.)
Remove | Sets the note status to Deleted. (Inherited from Note.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Overloaded.

See Also

ListNote Class
Mincom.LinkOne.Dom.Notes Namespace


Equals Method

[image] [image]

LinkOne WebView API
ListNote..::.Equals Method
ListNote Class See Also Send Feedback

Overload List

Name | Description
Equals(Note) | Determines whether the specified note is equal to the current note. (Inherited from Note.)
Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Note.)

See Also

ListNote Class
ListNote Members
Mincom.LinkOne.Dom.Notes Namespace


Validate Method

[image] [image]

LinkOne WebView API
ListNote..::.Validate Method
ListNote Class See Also Send Feedback

Overload List

Name | Description
Validate(String) | Gets the validity of the given named property. (Inherited from Note.)
Validate(Access, String, String, String, String, String, Int32) | Validates the given properties for a note. (Inherited from Note.)

See Also

ListNote Class
ListNote Members
Mincom.LinkOne.Dom.Notes Namespace


ListNote Properties

[image] [image]

LinkOne WebView API
ListNote Properties
ListNote Class See Also Send Feedback

The ListNote type exposes the following members.

Properties

Name | Description
Access | Gets or sets the note access. (Inherited from Note.)
Association | Gets what the note is associated with. (Inherited from Note.)
Behaviour | Gets or sets the note behaviour.
BookCode | Gets or sets the book code of the note. (Inherited from Note.)
Category | Gets or sets the note category. (Inherited from CategorizedNote.)
Description | Gets or sets the description of the note. (Inherited from CategorizedNote.)
DisplayName | See DisplayName for more information. (Inherited from CategorizedNote.)
Group | Gets or sets the group identifier of the note. (Inherited from TranslatedNote.)
Id | Gets or sets the unique ID of the note. (Inherited from Note.)
IsListNote | Gets or sets whether the note appears in the notes list.
ItemId | Gets or sets the item ID of the note. (Inherited from Note.)
Key | Gets a key that uniquely defines the note. (Overrides CategorizedNote..::.Key.)
LanguageCode | Gets or sets the language code. (Inherited from TranslatedNote.)
OriginalNote | Gets or the original note; or null if the note hasn't changed. (Inherited from Note.)
PageReference | Gets or sets the page reference of the note. (Inherited from Note.)
PartNumber | Gets or sets the part number of the note. (Inherited from Note.)
PictureNumber | Gets or sets the picture number of the redline note. (Inherited from Note.)
PublisherCode | Gets or sets the publisher code of the note. (Inherited from Note.)
Scope | Gets the note scope. (Inherited from Note.)
Status | Gets or sets the status of the note in relation to the copy saved in persistent storage. (Inherited from Note.)
TimeStamp | Gets or sets the date and time when the note was last written. (Inherited from Note.)
Translation | Gets or sets the translation of the note. (Inherited from TranslatedNote.)
Xml | Gets the XML representing the note. (Inherited from Note.)

See Also

ListNote Class
Mincom.LinkOne.Dom.Notes Namespace


Behaviour Property

[image]

LinkOne WebView API
ListNote..::.Behaviour Property
ListNote Class See Also Send Feedback
Gets or sets the note behaviour.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public NoteBehaviour Behaviour { get; set; }
Visual Basic (Declaration)
Public Property Behaviour As NoteBehaviour
Visual C++
public:
virtual property NoteBehaviour Behaviour {
    NoteBehaviour get () sealed;
    void set (NoteBehaviour value) sealed;
}

Implements

IListNote..::.Behaviour

See Also

ListNote Class
Mincom.LinkOne.Dom.Notes Namespace


IsListNote Property

[image]

LinkOne WebView API
ListNote..::.IsListNote Property
ListNote Class See Also Send Feedback
Gets or sets whether the note appears in the notes list.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsListNote { get; set; }
Visual Basic (Declaration)
Public Property IsListNote As Boolean
Visual C++
public:
virtual property bool IsListNote {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IListNote..::.IsListNote

See Also

ListNote Class
Mincom.LinkOne.Dom.Notes Namespace


Key Property

[image]

LinkOne WebView API
ListNote..::.Key Property
ListNote Class See Also Send Feedback
Gets a key that uniquely defines the note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected override string Key { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property Key As String
Visual C++
protected:
virtual property String^ Key {
    String^ get () override;
}

See Also

ListNote Class
Mincom.LinkOne.Dom.Notes Namespace


MacroNote Class

[image]

LinkOne WebView API
MacroNote Class
Members See Also Send Feedback
A class which represents a Macro note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class MacroNote : ListNote,
    IListNote, ICategorizedNote, ITranslatedNote, INote
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class MacroNote _
    Inherits ListNote _
    Implements IListNote, ICategorizedNote, ITranslatedNote, INote
Visual C++
[SerializableAttribute]
public ref class MacroNote sealed : public ListNote,
    IListNote, ICategorizedNote, ITranslatedNote, INote

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Notes..::.Note
Mincom.LinkOne.Dom.Notes..::.TranslatedNote
Mincom.LinkOne.Dom.Notes..::.CategorizedNote
Mincom.LinkOne.Dom.Notes..::.ListNote
Mincom.LinkOne.Dom.Notes..::.MacroNote

See Also

MacroNote Members
Mincom.LinkOne.Dom.Notes Namespace


MacroNote Members

[image] [image]

LinkOne WebView API
MacroNote Members
MacroNote Class Constructors Methods Properties See Also Send Feedback

The MacroNote type exposes the following members.

Constructors

Name | Description
MacroNote | Creates an instance of the MacroNote.

Methods

Name | Description
CanSetAccess | Determines whether this Note instance can set the Access to the specified value. (Inherited from Note.)
CanSetAssociation | Determines whether this Note instance can set Association to the specified value. (Inherited from Note.)
CanSetScope | Determines whether this Note instance can set Scope to the the specified value. (Inherited from Note.)
Clone | Gets a clone of the this. (Inherited from Note.)
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the hash code for the object. (Inherited from Note.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanging | Sets the note status to changed. (Inherited from Note.)
Remove | Sets the note status to Deleted. (Inherited from Note.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Overloaded.

Properties

Name | Description
Access | Gets or sets the note access. (Inherited from Note.)
Association | Gets what the note is associated with. (Inherited from Note.)
Behaviour | Gets or sets the note behaviour. (Inherited from ListNote.)
BookCode | Gets or sets the book code of the note. (Inherited from Note.)
Category | Gets or sets the note category. (Inherited from CategorizedNote.)
Description | Gets or sets the description of the note. (Inherited from CategorizedNote.)
DisplayName | See DisplayName for more information. (Inherited from CategorizedNote.)
Group | Gets or sets the group identifier of the note. (Inherited from TranslatedNote.)
Id | Gets or sets the unique ID of the note. (Inherited from Note.)
IsListNote | Gets or sets whether the note appears in the notes list. (Inherited from ListNote.)
ItemId | Gets or sets the item ID of the note. (Inherited from Note.)
Key | Gets a key that uniquely defines the note. (Inherited from ListNote.)
LanguageCode | Gets or sets the language code. (Inherited from TranslatedNote.)
OriginalNote | Gets or the original note; or null if the note hasn't changed. (Inherited from Note.)
PageReference | Gets or sets the page reference of the note. (Inherited from Note.)
PartNumber | Gets or sets the part number of the note. (Inherited from Note.)
PictureNumber | Gets or sets the picture number of the redline note. (Inherited from Note.)
PublisherCode | Gets or sets the publisher code of the note. (Inherited from Note.)
Scope | Gets the note scope. (Inherited from Note.)
Script | Gets or sets the script of the macro note.
ScriptType | Gets or sets the script type of the macro note.
Status | Gets or sets the status of the note in relation to the copy saved in persistent storage. (Inherited from Note.)
TimeStamp | Gets or sets the date and time when the note was last written. (Inherited from Note.)
Translation | See Translation for more information. (Overrides TranslatedNote..::.Translation.)
Xml | Gets the XML representing the note. (Inherited from Note.)

See Also

MacroNote Class
Mincom.LinkOne.Dom.Notes Namespace


MacroNote Constructor

[image]

LinkOne WebView API
MacroNote Constructor
MacroNote Class See Also Send Feedback
Creates an instance of the MacroNote.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public MacroNote()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MacroNote()

See Also

MacroNote Class
Mincom.LinkOne.Dom.Notes Namespace


MacroNote Methods

[image] [image]

LinkOne WebView API
MacroNote Methods
MacroNote Class See Also Send Feedback

The MacroNote type exposes the following members.

Methods

Name | Description
CanSetAccess | Determines whether this Note instance can set the Access to the specified value. (Inherited from Note.)
CanSetAssociation | Determines whether this Note instance can set Association to the specified value. (Inherited from Note.)
CanSetScope | Determines whether this Note instance can set Scope to the the specified value. (Inherited from Note.)
Clone | Gets a clone of the this. (Inherited from Note.)
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the hash code for the object. (Inherited from Note.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanging | Sets the note status to changed. (Inherited from Note.)
Remove | Sets the note status to Deleted. (Inherited from Note.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Overloaded.

See Also

MacroNote Class
Mincom.LinkOne.Dom.Notes Namespace


Equals Method

[image] [image]

LinkOne WebView API
MacroNote..::.Equals Method
MacroNote Class See Also Send Feedback

Overload List

Name | Description
Equals(Note) | Determines whether the specified note is equal to the current note. (Inherited from Note.)
Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Note.)

See Also

MacroNote Class
MacroNote Members
Mincom.LinkOne.Dom.Notes Namespace


Validate Method

[image] [image]

LinkOne WebView API
MacroNote..::.Validate Method
MacroNote Class See Also Send Feedback

Overload List

Name | Description
Validate(String) | See Validate(String) for more information. (Overrides Note..::.Validate(String).)
Validate(Access, String, String, String, String, String, Int32) | Validates the given properties for a note. (Inherited from Note.)

See Also

MacroNote Class
MacroNote Members
Mincom.LinkOne.Dom.Notes Namespace


Validate Method (String)

[image]

LinkOne WebView API
MacroNote..::.Validate Method (String)
MacroNote Class See Also Send Feedback
See Validate(String) for more information.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override bool Validate(
    string propertyName
)
Visual Basic (Declaration)
Public Overrides Function Validate ( _
    propertyName As String _
) As Boolean
Visual C++
public:
virtual bool Validate(
    String^ propertyName
) override

Parameters

propertyName
Type: System..::.String

See Also

MacroNote Class
Validate Overload
Mincom.LinkOne.Dom.Notes Namespace


MacroNote Properties

[image] [image]

LinkOne WebView API
MacroNote Properties
MacroNote Class See Also Send Feedback

The MacroNote type exposes the following members.

Properties

Name | Description
Access | Gets or sets the note access. (Inherited from Note.)
Association | Gets what the note is associated with. (Inherited from Note.)
Behaviour | Gets or sets the note behaviour. (Inherited from ListNote.)
BookCode | Gets or sets the book code of the note. (Inherited from Note.)
Category | Gets or sets the note category. (Inherited from CategorizedNote.)
Description | Gets or sets the description of the note. (Inherited from CategorizedNote.)
DisplayName | See DisplayName for more information. (Inherited from CategorizedNote.)
Group | Gets or sets the group identifier of the note. (Inherited from TranslatedNote.)
Id | Gets or sets the unique ID of the note. (Inherited from Note.)
IsListNote | Gets or sets whether the note appears in the notes list. (Inherited from ListNote.)
ItemId | Gets or sets the item ID of the note. (Inherited from Note.)
Key | Gets a key that uniquely defines the note. (Inherited from ListNote.)
LanguageCode | Gets or sets the language code. (Inherited from TranslatedNote.)
OriginalNote | Gets or the original note; or null if the note hasn't changed. (Inherited from Note.)
PageReference | Gets or sets the page reference of the note. (Inherited from Note.)
PartNumber | Gets or sets the part number of the note. (Inherited from Note.)
PictureNumber | Gets or sets the picture number of the redline note. (Inherited from Note.)
PublisherCode | Gets or sets the publisher code of the note. (Inherited from Note.)
Scope | Gets the note scope. (Inherited from Note.)
Script | Gets or sets the script of the macro note.
ScriptType | Gets or sets the script type of the macro note.
Status | Gets or sets the status of the note in relation to the copy saved in persistent storage. (Inherited from Note.)
TimeStamp | Gets or sets the date and time when the note was last written. (Inherited from Note.)
Translation | See Translation for more information. (Overrides TranslatedNote..::.Translation.)
Xml | Gets the XML representing the note. (Inherited from Note.)

See Also

MacroNote Class
Mincom.LinkOne.Dom.Notes Namespace


Script Property

[image]

LinkOne WebView API
MacroNote..::.Script Property
MacroNote Class See Also Send Feedback
Gets or sets the script of the macro note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Script { get; set; }
Visual Basic (Declaration)
Public Property Script As String
Visual C++
public:
property String^ Script {
    String^ get ();
    void set (String^ value);
}

Field Value

The script for the macro note.

See Also

MacroNote Class
Mincom.LinkOne.Dom.Notes Namespace


ScriptType Property

[image]

LinkOne WebView API
MacroNote..::.ScriptType Property
MacroNote Class See Also Send Feedback
Gets or sets the script type of the macro note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string ScriptType { get; set; }
Visual Basic (Declaration)
Public Property ScriptType As String
Visual C++
public:
property String^ ScriptType {
    String^ get ();
    void set (String^ value);
}

Field Value

The script type for the macro note.

See Also

MacroNote Class
Mincom.LinkOne.Dom.Notes Namespace


Translation Property

[image]

LinkOne WebView API
MacroNote..::.Translation Property
MacroNote Class See Also Send Feedback
See Translation for more information.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string Translation { get; set; }
Visual Basic (Declaration)
Public Overrides Property Translation As String
Visual C++
public:
virtual property String^ Translation {
    String^ get () override;
    void set (String^ value) override;
}

Implements

ITranslatedNote..::.Translation
ITranslatedNote..::.Translation

See Also

MacroNote Class
Mincom.LinkOne.Dom.Notes Namespace


Note Class

[image]

LinkOne WebView API
Note Class
Members See Also Send Feedback
The base class for a LinkOne note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public abstract class Note : INote,
    IEquatable<Note>, IPersist
Visual Basic (Declaration)
<SerializableAttribute> _
Public MustInherit Class Note _
    Implements INote, IEquatable(Of Note),  _
    IPersist
Visual C++
[SerializableAttribute]
public ref class Note abstract : INote,
    IEquatable<Note^>, IPersist

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Notes..::.Note
Mincom.LinkOne.Dom.Notes..::.FilterNote
Mincom.LinkOne.Dom.Notes..::.TranslatedNote
Mincom.LinkOne.Dom.Notes..::.UnknownNote
Mincom.LinkOne.Dom.Notes..::.ValueNote

See Also

Note Members
Mincom.LinkOne.Dom.Notes Namespace


Note Members

[image] [image]

LinkOne WebView API
Note Members
Note Class Constructors Methods Properties See Also Send Feedback

The Note type exposes the following members.

Constructors

Name | Description
Note | Initializes the Note.

Methods

Name | Description
CanSetAccess | Determines whether this Note instance can set the Access to the specified value.
CanSetAccessScopeAssociation | Determines whether this Note instance can set Access, Scope and Association to the specified values.
CanSetAssociation | Determines whether this Note instance can set Association to the specified value.
CanSetScope | Determines whether this Note instance can set Scope to the the specified value.
Clone | Gets a clone of the this.
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetAssociation | Gets the assocation for a note given the note properties
GetHashCode | Gets the hash code for the object. (Overrides Object..::.GetHashCode()()().)
GetScope | Calculates the note scope based on the specified parameters.
GetType | Gets the type of the current instance. (Inherited from Object.)
LoadXml | Creates a note from xml representing the note.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanging | Sets the note status to changed.
Remove | Sets the note status to Deleted.
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Overloaded.

Properties

Name | Description
Access | Gets or sets the note access.
Association | Gets what the note is associated with.
BookCode | Gets or sets the book code of the note.
DisplayName | Gets the display name of the note.
Id | Gets or sets the unique ID of the note.
ItemId | Gets or sets the item ID of the note.
Key | Gets a key that uniquely defines the note.
OriginalNote | Gets or the original note; or null if the note hasn't changed.
PageReference | Gets or sets the page reference of the note.
PartNumber | Gets or sets the part number of the note.
PictureNumber | Gets or sets the picture number of the redline note.
PublisherCode | Gets or sets the publisher code of the note.
Scope | Gets the note scope.
Status | Gets or sets the status of the note in relation to the copy saved in persistent storage.
TimeStamp | Gets or sets the date and time when the note was last written.
Xml | Gets the XML representing the note.

See Also

Note Class
Mincom.LinkOne.Dom.Notes Namespace


Note Constructor

[image]

LinkOne WebView API
Note Constructor
Note Class See Also Send Feedback
Initializes the Note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected Note()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
Note()

See Also

Note Class
Mincom.LinkOne.Dom.Notes Namespace


Note Methods

[image] [image]

LinkOne WebView API
Note Methods
Note Class See Also Send Feedback

The Note type exposes the following members.

Methods

Name | Description
CanSetAccess | Determines whether this Note instance can set the Access to the specified value.
CanSetAccessScopeAssociation | Determines whether this Note instance can set Access, Scope and Association to the specified values.
CanSetAssociation | Determines whether this Note instance can set Association to the specified value.
CanSetScope | Determines whether this Note instance can set Scope to the the specified value.
Clone | Gets a clone of the this.
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetAssociation | Gets the assocation for a note given the note properties
GetHashCode | Gets the hash code for the object. (Overrides Object..::.GetHashCode()()().)
GetScope | Calculates the note scope based on the specified parameters.
GetType | Gets the type of the current instance. (Inherited from Object.)
LoadXml | Creates a note from xml representing the note.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanging | Sets the note status to changed.
Remove | Sets the note status to Deleted.
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Overloaded.

See Also

Note Class
Mincom.LinkOne.Dom.Notes Namespace


CanSetAccess Method

[image]

LinkOne WebView API
Note..::.CanSetAccess Method
Note Class See Also Send Feedback
Determines whether this Note instance can set the Access to the specified value.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool CanSetAccess(
    Access access
)
Visual Basic (Declaration)
Public Function CanSetAccess ( _
    access As Access _
) As Boolean
Visual C++
public:
bool CanSetAccess(
    Access access
)

Parameters

access
Type: Mincom.LinkOne.Dom.Notes..::.Access
The access.

Return Value

true if this Note instance can set the Access to the specified Access ; otherwise, false.

See Also

Note Class
Mincom.LinkOne.Dom.Notes Namespace


CanSetAccessScopeAssociation Method

[image]

LinkOne WebView API
Note..::.CanSetAccessScopeAssociation Method
Note Class See Also Send Feedback
Determines whether this Note instance can set Access, Scope and Association to the specified values.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static bool CanSetAccessScopeAssociation(
    Access access,
    Scope scope,
    Association association
)
Visual Basic (Declaration)
Public Shared Function CanSetAccessScopeAssociation ( _
    access As Access, _
    scope As Scope, _
    association As Association _
) As Boolean
Visual C++
public:
static bool CanSetAccessScopeAssociation(
    Access access,
    Scope scope,
    Association association
)

Parameters

access
Type: Mincom.LinkOne.Dom.Notes..::.Access
The access.
scope
Type: Mincom.LinkOne.Dom.Notes..::.Scope
The scope.
association
Type: Mincom.LinkOne.Dom.Notes..::.Association
The association.

Return Value

true if this Note instance can set Access, Scope and Association to the specified values.; otherwise, false.

See Also

Note Class
Mincom.LinkOne.Dom.Notes Namespace


CanSetAssociation Method

[image]

LinkOne WebView API
Note..::.CanSetAssociation Method
Note Class See Also Send Feedback
Determines whether this Note instance can set Association to the specified value.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool CanSetAssociation(
    Association association
)
Visual Basic (Declaration)
Public Function CanSetAssociation ( _
    association As Association _
) As Boolean
Visual C++
public:
bool CanSetAssociation(
    Association association
)

Parameters

association
Type: Mincom.LinkOne.Dom.Notes..::.Association
The association.

Return Value

true if this Note instance can set Association to the specified Association.; otherwise, false.

See Also

Note Class
Mincom.LinkOne.Dom.Notes Namespace


CanSetScope Method

[image]

LinkOne WebView API
Note..::.CanSetScope Method
Note Class See Also Send Feedback
Determines whether this Note instance can set Scope to the the specified value.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool CanSetScope(
    Scope scope
)
Visual Basic (Declaration)
Public Function CanSetScope ( _
    scope As Scope _
) As Boolean
Visual C++
public:
bool CanSetScope(
    Scope scope
)

Parameters

scope
Type: Mincom.LinkOne.Dom.Notes..::.Scope
The scope.

Return Value

True if this Note instance can set Scope to the the specified Scope.; otherwise, false.

See Also

Note Class
Mincom.LinkOne.Dom.Notes Namespace


Clone Method

[image]

LinkOne WebView API
Note..::.Clone Method
Note Class See Also Send Feedback
Gets a clone of the this.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IPersist Clone()
Visual Basic (Declaration)
Public Function Clone As IPersist
Visual C++
public:
IPersist^ Clone()

Return Value

An cloned instance of this.

See Also

Note Class
Mincom.LinkOne.Dom.Notes Namespace


Equals Method

[image] [image]

LinkOne WebView API
Note..::.Equals Method
Note Class See Also Send Feedback

Overload List

Name | Description
Equals(Note) | Determines whether the specified note is equal to the current note.
Equals(Object) | Determines whether the specified object is equal to the current object. (Overrides Object..::.Equals(Object).)

See Also

Note Class
Note Members
Mincom.LinkOne.Dom.Notes Namespace


Equals Method (Note)

[image]

LinkOne WebView API
Note..::.Equals Method (Note)
Note Class See Also Send Feedback
Determines whether the specified note is equal to the current note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Equals(
    Note other
)
Visual Basic (Declaration)
Public Function Equals ( _
    other As Note _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Note^ other
) sealed

Parameters

other
Type: Mincom.LinkOne.Dom.Notes..::.Note
The note to compare with the current note.

Return Value

True if the specified note is equal to the current note; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

Note Class
Equals Overload
Mincom.LinkOne.Dom.Notes Namespace


Equals Method (Object)

[image]

LinkOne WebView API
Note..::.Equals Method (Object)
Note Class See Also Send Feedback
Determines whether the specified object is equal to the current object.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The object to compare with the current note.

Return Value

True if the specified object is equal to the current note; otherwise, false.

See Also

Note Class
Equals Overload
Mincom.LinkOne.Dom.Notes Namespace


GetAssociation Method

[image]

LinkOne WebView API
Note..::.GetAssociation Method
Note Class See Also Send Feedback
Gets the assocation for a note given the note properties

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static Association GetAssociation(
    string publisherCode,
    string bookCode,
    string pageReference,
    string itemId,
    string partNumber,
    int pictureNumber
)
Visual Basic (Declaration)
Public Shared Function GetAssociation ( _
    publisherCode As String, _
    bookCode As String, _
    pageReference As String, _
    itemId As String, _
    partNumber As String, _
    pictureNumber As Integer _
) As Association
Visual C++
public:
static Association GetAssociation(
    String^ publisherCode,
    String^ bookCode,
    String^ pageReference,
    String^ itemId,
    String^ partNumber,
    int pictureNumber
)

Parameters

publisherCode
Type: System..::.String
The publisher code of the note whose association is required, or null, or blank.
bookCode
Type: System..::.String
The book code of the note whose association is required, or null, or blank.
pageReference
Type: System..::.String
The page reference of the note whose association is required, or null, or blank.
itemId
Type: System..::.String
The item id of the note whose association is required, or null, or blank.
partNumber
Type: System..::.String
The part number of the note whose association is required, or null, or blank.
pictureNumber
Type: System..::.Int32
The picture number of the note whose association is required, or 0.

Return Value

The note association based on the specified parameters.

See Also

Note Class
Mincom.LinkOne.Dom.Notes Namespace


GetHashCode Method

[image]

LinkOne WebView API
Note..::.GetHashCode Method
Note Class See Also Send Feedback
Gets the hash code for the object.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

See Also

Note Class
Mincom.LinkOne.Dom.Notes Namespace


GetScope Method

[image]

LinkOne WebView API
Note..::.GetScope Method
Note Class See Also Send Feedback
Calculates the note scope based on the specified parameters.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static Scope GetScope(
    string publisherCode,
    string bookCode,
    string pageReference
)
Visual Basic (Declaration)
Public Shared Function GetScope ( _
    publisherCode As String, _
    bookCode As String, _
    pageReference As String _
) As Scope
Visual C++
public:
static Scope GetScope(
    String^ publisherCode,
    String^ bookCode,
    String^ pageReference
)

Parameters

publisherCode
Type: System..::.String
The publisher code of the note whose scope is required, or null, or blank.
bookCode
Type: System..::.String
The book code of the note whose scope is required, or null, or blank.
pageReference
Type: System..::.String
The page reference of the note whose scope is required, or null, or blank.

Return Value

The note scope based on the specified parameters.

Remarks

To get global scope, specify publisher code, book code, page reference and item Id as nulls.
To get publisher scope, supply the publisher code and specify book code, page reference and item Id as nulls.
To get book scope, supply the publisher code and book code, and specify the page reference and item Id as nulls.
To get page scope, supply the publisher code, book code, page reference, and specify the item Id as null.
To get item scope, supply the publisher code, book code, page reference, and item Id.
If a book code is specified, then a publisher code is required, otherwise a ArgumentException is thrown.
If a page reference is specified, then a publisher code and book code are required, otherwise a ArgumentException is thrown.
If an item Id is specified, then a publisher code, book code and page reference are required, otherwise a ArgumentException is thrown.

See Also

Note Class
Mincom.LinkOne.Dom.Notes Namespace


LoadXml Method

[image]

LinkOne WebView API
Note..::.LoadXml Method
Note Class See Also Send Feedback
Creates a note from xml representing the note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static Note LoadXml(
    string noteXml
)
Visual Basic (Declaration)
Public Shared Function LoadXml ( _
    noteXml As String _
) As Note
Visual C++
public:
static Note^ LoadXml(
    String^ noteXml
)

Parameters

noteXml
Type: System..::.String
The note content in XML format.

Return Value

A note from the xml representing the note.

See Also

Note Class
Mincom.LinkOne.Dom.Notes Namespace


OnChanging Method

[image]

LinkOne WebView API
Note..::.OnChanging Method
Note Class See Also Send Feedback
Sets the note status to changed.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected void OnChanging()
Visual Basic (Declaration)
Protected Sub OnChanging
Visual C++
protected:
void OnChanging()

See Also

Note Class
Mincom.LinkOne.Dom.Notes Namespace


Remove Method

[image]

LinkOne WebView API
Note..::.Remove Method
Note Class See Also Send Feedback
Sets the note status to Deleted.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Remove()
Visual Basic (Declaration)
Public Sub Remove
Visual C++
public:
virtual void Remove() sealed

Implements

INote..::.Remove()()()

See Also

Note Class
Mincom.LinkOne.Dom.Notes Namespace


Validate Method

[image] [image]

LinkOne WebView API
Note..::.Validate Method
Note Class See Also Send Feedback

Overload List

Name | Description
Validate(String) | Gets the validity of the given named property.
Validate(Access, String, String, String, String, String, Int32) | Validates the given properties for a note.

See Also

Note Class
Note Members
Mincom.LinkOne.Dom.Notes Namespace


Validate Method (String)

[image]

LinkOne WebView API
Note..::.Validate Method (String)
Note Class See Also Send Feedback
Gets the validity of the given named property.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public virtual bool Validate(
    string propertyName
)
Visual Basic (Declaration)
Public Overridable Function Validate ( _
    propertyName As String _
) As Boolean
Visual C++
public:
virtual bool Validate(
    String^ propertyName
)

Parameters

propertyName
Type: System..::.String
The name of the property to validate.

Return Value

True if the given named property is valid; otherwise False.

See Also

Note Class
Validate Overload
Mincom.LinkOne.Dom.Notes Namespace


Validate Method (Access, String, String, String, String, String, Int32)

[image]

LinkOne WebView API
Note..::.Validate Method (Access, String, String, String, String, String, Int32)
Note Class See Also Send Feedback
Validates the given properties for a note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected virtual void Validate(
    Access access,
    string publisherCode,
    string bookCode,
    string pageReference,
    string itemId,
    string partNumber,
    int pictureNumber
)
Visual Basic (Declaration)
Protected Overridable Sub Validate ( _
    access As Access, _
    publisherCode As String, _
    bookCode As String, _
    pageReference As String, _
    itemId As String, _
    partNumber As String, _
    pictureNumber As Integer _
)
Visual C++
protected:
virtual void Validate(
    Access access,
    String^ publisherCode,
    String^ bookCode,
    String^ pageReference,
    String^ itemId,
    String^ partNumber,
    int pictureNumber
)

Parameters

access
Type: Mincom.LinkOne.Dom.Notes..::.Access
The required access.
publisherCode
Type: System..::.String
The publisher code to imply the required scope.
bookCode
Type: System..::.String
The book code to imply the required scope.
pageReference
Type: System..::.String
The page reference to imply the required scope.
itemId
Type: System..::.String
The item id to imply the required association.
partNumber
Type: System..::.String
The part number to imply the required association.
pictureNumber
Type: System..::.Int32
The picture number to imply the required association.

Exceptions

Exception | Condition
System..::.ArgumentException | One of the parameters is given that will imply an invalid access, scope, or association

See Also

Note Class
Validate Overload
Mincom.LinkOne.Dom.Notes Namespace


Note Properties

[image] [image]

LinkOne WebView API
Note Properties
Note Class See Also Send Feedback

The Note type exposes the following members.

Properties

Name | Description
Access | Gets or sets the note access.
Association | Gets what the note is associated with.
BookCode | Gets or sets the book code of the note.
DisplayName | Gets the display name of the note.
Id | Gets or sets the unique ID of the note.
ItemId | Gets or sets the item ID of the note.
Key | Gets a key that uniquely defines the note.
OriginalNote | Gets or the original note; or null if the note hasn't changed.
PageReference | Gets or sets the page reference of the note.
PartNumber | Gets or sets the part number of the note.
PictureNumber | Gets or sets the picture number of the redline note.
PublisherCode | Gets or sets the publisher code of the note.
Scope | Gets the note scope.
Status | Gets or sets the status of the note in relation to the copy saved in persistent storage.
TimeStamp | Gets or sets the date and time when the note was last written.
Xml | Gets the XML representing the note.

See Also

Note Class
Mincom.LinkOne.Dom.Notes Namespace


Access Property

[image]

LinkOne WebView API
Note..::.Access Property
Note Class See Also Send Feedback
Gets or sets the note access.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Access Access { get; set; }
Visual Basic (Declaration)
Public Property Access As Access
Visual C++
public:
virtual property Access Access {
    Access get () sealed;
    void set (Access value) sealed;
}

Implements

INote..::.Access

Exceptions

Exception | Condition
System..::.ArgumentException | PublisherCode is empty and the new Access is set to Supplied.

See Also

Note Class
Mincom.LinkOne.Dom.Notes Namespace


Association Property

[image]

LinkOne WebView API
Note..::.Association Property
Note Class See Also Send Feedback
Gets what the note is associated with.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Association Association { get; }
Visual Basic (Declaration)
Public ReadOnly Property Association As Association
Visual C++
public:
virtual property Association Association {
    Association get () sealed;
}

Implements

INote..::.Association

See Also

Note Class
Mincom.LinkOne.Dom.Notes Namespace


BookCode Property

[image]

LinkOne WebView API
Note..::.BookCode Property
Note Class See Also Send Feedback
Gets or sets the book code of the note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string BookCode { get; set; }
Visual Basic (Declaration)
Public Property BookCode As String
Visual C++
public:
virtual property String^ BookCode {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

INote..::.BookCode

Exceptions

Exception | Condition
System..::.ArgumentException | PublisherCode has not been set.

See Also

Note Class
Mincom.LinkOne.Dom.Notes Namespace


DisplayName Property

[image]

LinkOne WebView API
Note..::.DisplayName Property
Note Class See Also Send Feedback
Gets the display name of the note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public abstract string DisplayName { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property DisplayName As String
Visual C++
public:
virtual property String^ DisplayName {
    String^ get () abstract;
}

See Also

Note Class
Mincom.LinkOne.Dom.Notes Namespace


Id Property

[image]

LinkOne WebView API
Note..::.Id Property
Note Class See Also Send Feedback
Gets or sets the unique ID of the note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Id { get; set; }
Visual Basic (Declaration)
Public Property Id As Integer
Visual C++
public:
virtual property int Id {
    int get () sealed;
    void set (int value) sealed;
}

Implements

INote..::.Id

See Also

Note Class
Mincom.LinkOne.Dom.Notes Namespace


ItemId Property

[image]

LinkOne WebView API
Note..::.ItemId Property
Note Class See Also Send Feedback
Gets or sets the item ID of the note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public virtual string ItemId { get; set; }
Visual Basic (Declaration)
Public Overridable Property ItemId As String
Visual C++
public:
virtual property String^ ItemId {
    String^ get ();
    void set (String^ value);
}

Implements

INote..::.ItemId

Exceptions

Exception | Condition
System..::.ArgumentException | PublisherCode and BookCode and PageReference have not been set.

See Also

Note Class
Mincom.LinkOne.Dom.Notes Namespace


Key Property

[image]

LinkOne WebView API
Note..::.Key Property
Note Class See Also Send Feedback
Gets a key that uniquely defines the note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected virtual string Key { get; }
Visual Basic (Declaration)
Protected Overridable ReadOnly Property Key As String
Visual C++
protected:
virtual property String^ Key {
    String^ get ();
}

See Also

Note Class
Mincom.LinkOne.Dom.Notes Namespace


OriginalNote Property

[image]

LinkOne WebView API
Note..::.OriginalNote Property
Note Class See Also Send Feedback
Gets or the original note; or null if the note hasn't changed.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Note OriginalNote { get; }
Visual Basic (Declaration)
Public ReadOnly Property OriginalNote As Note
Visual C++
public:
property Note^ OriginalNote {
    Note^ get ();
}

See Also

Note Class
Mincom.LinkOne.Dom.Notes Namespace


PageReference Property

[image]

LinkOne WebView API
Note..::.PageReference Property
Note Class See Also Send Feedback
Gets or sets the page reference of the note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public virtual string PageReference { get; set; }
Visual Basic (Declaration)
Public Overridable Property PageReference As String
Visual C++
public:
virtual property String^ PageReference {
    String^ get ();
    void set (String^ value);
}

Implements

INote..::.PageReference

Exceptions

Exception | Condition
System..::.ArgumentException | PublisherCode and BookCode have not been set.

See Also

Note Class
Mincom.LinkOne.Dom.Notes Namespace


PartNumber Property

[image]

LinkOne WebView API
Note..::.PartNumber Property
Note Class See Also Send Feedback
Gets or sets the part number of the note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public virtual string PartNumber { get; set; }
Visual Basic (Declaration)
Public Overridable Property PartNumber As String
Visual C++
public:
virtual property String^ PartNumber {
    String^ get ();
    void set (String^ value);
}

Implements

INote..::.PartNumber

Exceptions

Exception | Condition
System..::.ArgumentException | PublisherCode has not been set.

See Also

Note Class
Mincom.LinkOne.Dom.Notes Namespace


PictureNumber Property

[image]

LinkOne WebView API
Note..::.PictureNumber Property
Note Class See Also Send Feedback
Gets or sets the picture number of the redline note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int PictureNumber { get; set; }
Visual Basic (Declaration)
Public Property PictureNumber As Integer
Visual C++
public:
virtual property int PictureNumber {
    int get () sealed;
    void set (int value) sealed;
}

Implements

INote..::.PictureNumber

Exceptions

Exception | Condition
System..::.ArgumentException | PublisherCode and BookCode and PageReference have not been set.

See Also

Note Class
Mincom.LinkOne.Dom.Notes Namespace


PublisherCode Property

[image]

LinkOne WebView API
Note..::.PublisherCode Property
Note Class See Also Send Feedback
Gets or sets the publisher code of the note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PublisherCode { get; set; }
Visual Basic (Declaration)
Public Property PublisherCode As String
Visual C++
public:
virtual property String^ PublisherCode {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

INote..::.PublisherCode

Exceptions

Exception | Condition
System..::.ArgumentException | Access is set to Supplied and the new PublisherCode is empty.

See Also

Note Class
Mincom.LinkOne.Dom.Notes Namespace


Scope Property

[image]

LinkOne WebView API
Note..::.Scope Property
Note Class See Also Send Feedback
Gets the note scope.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Scope Scope { get; }
Visual Basic (Declaration)
Public ReadOnly Property Scope As Scope
Visual C++
public:
virtual property Scope Scope {
    Scope get () sealed;
}

Implements

INote..::.Scope

See Also

Note Class
Mincom.LinkOne.Dom.Notes Namespace


Status Property

[image]

LinkOne WebView API
Note..::.Status Property
Note Class See Also Send Feedback
Gets or sets the status of the note in relation to the copy saved in persistent storage.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Status Status { get; set; }
Visual Basic (Declaration)
Public Property Status As Status
Visual C++
public:
virtual property Status Status {
    Status get () sealed;
    void set (Status value) sealed;
}

Implements

INote..::.Status

See Also

Note Class
Mincom.LinkOne.Dom.Notes Namespace


TimeStamp Property

[image]

LinkOne WebView API
Note..::.TimeStamp Property
Note Class See Also Send Feedback
Gets or sets the date and time when the note was last written.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public DateTime TimeStamp { get; set; }
Visual Basic (Declaration)
Public Property TimeStamp As DateTime
Visual C++
public:
virtual property DateTime TimeStamp {
    DateTime get () sealed;
    void set (DateTime value) sealed;
}

Implements

INote..::.TimeStamp

See Also

Note Class
Mincom.LinkOne.Dom.Notes Namespace


Xml Property

[image]

LinkOne WebView API
Note..::.Xml Property
Note Class See Also Send Feedback
Gets the XML representing the note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Xml { get; }
Visual Basic (Declaration)
Public ReadOnly Property Xml As String
Visual C++
public:
property String^ Xml {
    String^ get ();
}

See Also

Note Class
Mincom.LinkOne.Dom.Notes Namespace


NoteBehaviour Enumeration

[image]

LinkOne WebView API
NoteBehaviour Enumeration
See Also Send Feedback
The behaviour of a note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum NoteBehaviour
Visual Basic (Declaration)
Public Enumeration NoteBehaviour
Visual C++
public enum class NoteBehaviour

Members

Member name | Description
CategoryMenu | Causes the notes category menu to become active.
PopupEveryPage | Causes the notes category menu to become active, and displays the note on every page when it is within scope.
PopupOnce | Causes the notes category menu to become active, and displays the note on the first time the page is viewed and is within scope.
MenuButton | Causes the notes category menu to become active, and if the note is the category, then selecting the category menu will displays the note.
NoBehaviour | This note will not cause the category menu to become active.

See Also

Mincom.LinkOne.Dom.Notes Namespace


NoteCollection Class

[image]

LinkOne WebView API
NoteCollection Class
Members See Also Send Feedback
Represents a collection of notes.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class NoteCollection : ICollection<Note>,
    IEnumerable<Note>, INoteCollection, ICollection<INote>,
    IEnumerable<INote>, IEnumerable, IPersist
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class NoteCollection _
    Implements ICollection(Of Note), IEnumerable(Of Note),  _
    INoteCollection, ICollection(Of INote), IEnumerable(Of INote),  _
    IEnumerable, IPersist
Visual C++
[SerializableAttribute]
public ref class NoteCollection sealed : ICollection<Note^>,
    IEnumerable<Note^>, INoteCollection, ICollection<INote^>,
    IEnumerable<INote^>, IEnumerable, IPersist

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Notes..::.NoteCollection

See Also

NoteCollection Members
Mincom.LinkOne.Dom.Notes Namespace


NoteCollection Members

[image] [image]

LinkOne WebView API
NoteCollection Members
NoteCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The NoteCollection type exposes the following members.

Constructors

Name | Description
NoteCollection | Overloaded.

Methods

Name | Description
Add | Adds the specified note to the collection.
CanCreate | Overloaded.
CanEdit | Determines if a note can be edited in the context of the current note collection.
Clear | Removes all items from the ICollection<(Of <(T>)>).
Contains | Determines whether an note is in the collection.
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.
CreateNote<(Of <(T>)>) | Creates the note.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
FindBookmark | Finds the first bookmark of bookmarkName for the given publisher and book.
GetEntryNotes | Returns a new collection of all item and part notes that are for the given item or part number.
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItemNotes | Returns a new collection of all item notes that are for the given item.
GetMultilingualNotes | Returns the first note from each group in the collection that preferably have the given language or have no language.
GetNotes | Overloaded.
GetPartNotes | Returns a new collection of all part notes that are for the given part number.
GetTranslations | Returns a new collection of translated notes from the collection that are for the given note, or null if the given note is not translateable.
GetType | Gets the type of the current instance. (Inherited from Object.)
GetValueNotes | Returns a new collection of notes, containing all the ValueNote in the collection.
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given note object.
InitializeNote | Initializes the note access and scope so the note can be added to the note collection.
LoadXml | Populates the collection with the given XML.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Merge | Overloaded.
Remove | Removes the specified note.
SetCanCreate | Sets the can create status of a specific note access and scope in the context of the current note collection.
SetWriteStateEvaluator | Set the delayed write permissions evaluator for this collection.
Sort | Sorts the elements in the collection using the specified comparer.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
BookCode | Gets the book code that this collection is associated with.
Count | Gets the number of notes contained in the ICollection<(Of <(T>)>).
HasChanged | Gets true if the any of the notes in the collection have been changed; that is, if any Status does not equal Unchanged.
Item | Gets the Note at the specified index.
LanguageCode | Gets the language code that the notes in the collection are associated with.
MasterBookCode | Gets the master book code that this collection is associated with.
PageReference | Gets the page reference that this collection is associated with.
PublisherCode | Gets the publisher code that this collection is associated with.

Explicit Interface Implementations

Name | Description
System#Collections#Generic#ICollection{T}#IsReadOnly |
ICollection<(Of <(INote>)>)..::.Add |
ICollection<(Of <(INote>)>)..::.Clear |
ICollection<(Of <(INote>)>)..::.Contains |
ICollection<(Of <(INote>)>)..::.CopyTo |
ICollection<(Of <(INote>)>)..::.Count |
INoteCollection..::.Create |
IEnumerable<(Of <(INote>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator |
ICollection<(Of <(INote>)>)..::.Remove |

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


NoteCollection Constructor

[image] [image]

LinkOne WebView API
NoteCollection Constructor
NoteCollection Class See Also Send Feedback

Overload List

Name | Description
NoteCollection(String) | Constructor.
NoteCollection(String, String, String, String, String) | Constructor.

See Also

NoteCollection Class
NoteCollection Members
Mincom.LinkOne.Dom.Notes Namespace


NoteCollection Constructor (String)

[image]

LinkOne WebView API
NoteCollection Constructor (String)
NoteCollection Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public NoteCollection(
    string languageCode
)
Visual Basic (Declaration)
Public Sub New ( _
    languageCode As String _
)
Visual C++
public:
NoteCollection(
    String^ languageCode
)

Parameters

languageCode
Type: System..::.String
The language code to use for multi-language notes. If null, all notes are accepted regardless of group.

See Also

NoteCollection Class
NoteCollection Overload
Mincom.LinkOne.Dom.Notes Namespace


NoteCollection Constructor (String, String, String, String, String)

[image]

LinkOne WebView API
NoteCollection Constructor (String, String, String, String, String)
NoteCollection Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public NoteCollection(
    string languageCode,
    string publisherCode,
    string bookCode,
    string masterBookCode,
    string pageReference
)
Visual Basic (Declaration)
Public Sub New ( _
    languageCode As String, _
    publisherCode As String, _
    bookCode As String, _
    masterBookCode As String, _
    pageReference As String _
)
Visual C++
public:
NoteCollection(
    String^ languageCode,
    String^ publisherCode,
    String^ bookCode,
    String^ masterBookCode,
    String^ pageReference
)

Parameters

languageCode
Type: System..::.String
The language code to use for multi-language notes. If null, all notes are accepted regardless of group.
publisherCode
Type: System..::.String
Publisher code of the notes.
bookCode
Type: System..::.String
Book code of the notes.
masterBookCode
Type: System..::.String
Master Book code of the notes.
pageReference
Type: System..::.String
Page reference of the notes.

See Also

NoteCollection Class
NoteCollection Overload
Mincom.LinkOne.Dom.Notes Namespace


NoteCollection Methods

[image] [image]

LinkOne WebView API
NoteCollection Methods
NoteCollection Class See Also Send Feedback

The NoteCollection type exposes the following members.

Methods

Name | Description
Add | Adds the specified note to the collection.
CanCreate | Overloaded.
CanEdit | Determines if a note can be edited in the context of the current note collection.
Clear | Removes all items from the ICollection<(Of <(T>)>).
Contains | Determines whether an note is in the collection.
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.
CreateNote<(Of <(T>)>) | Creates the note.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
FindBookmark | Finds the first bookmark of bookmarkName for the given publisher and book.
GetEntryNotes | Returns a new collection of all item and part notes that are for the given item or part number.
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItemNotes | Returns a new collection of all item notes that are for the given item.
GetMultilingualNotes | Returns the first note from each group in the collection that preferably have the given language or have no language.
GetNotes | Overloaded.
GetPartNotes | Returns a new collection of all part notes that are for the given part number.
GetTranslations | Returns a new collection of translated notes from the collection that are for the given note, or null if the given note is not translateable.
GetType | Gets the type of the current instance. (Inherited from Object.)
GetValueNotes | Returns a new collection of notes, containing all the ValueNote in the collection.
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given note object.
InitializeNote | Initializes the note access and scope so the note can be added to the note collection.
LoadXml | Populates the collection with the given XML.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Merge | Overloaded.
Remove | Removes the specified note.
SetCanCreate | Sets the can create status of a specific note access and scope in the context of the current note collection.
SetWriteStateEvaluator | Set the delayed write permissions evaluator for this collection.
Sort | Sorts the elements in the collection using the specified comparer.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ICollection<(Of <(INote>)>)..::.Add |
ICollection<(Of <(INote>)>)..::.Clear |
ICollection<(Of <(INote>)>)..::.Contains |
ICollection<(Of <(INote>)>)..::.CopyTo |
INoteCollection..::.Create |
IEnumerable<(Of <(INote>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator |
ICollection<(Of <(INote>)>)..::.Remove |

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


ICollection(INote).Add Method

[image]

LinkOne WebView API
NoteCollection..::.ICollection<(Of <(INote>)>)..::.Add Method
NoteCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<INote>.Add(
    INote item
)
Visual Basic (Declaration)
Private Sub Add ( _
    item As INote _
) Implements ICollection(Of INote).Add
Visual C++
private:
virtual void Add(
    INote^ item
) sealed = ICollection<INote^>::Add

Parameters

item
Type: Mincom.LinkOne.Dom.Notes..::.INote

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


ICollection(INote).Clear Method

[image]

LinkOne WebView API
NoteCollection..::.ICollection<(Of <(INote>)>)..::.Clear Method
NoteCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<INote>.Clear()
Visual Basic (Declaration)
Private Sub Clear Implements ICollection(Of INote).Clear
Visual C++
private:
virtual void Clear() sealed = ICollection<INote^>::Clear

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


ICollection(INote).Contains Method

[image]

LinkOne WebView API
NoteCollection..::.ICollection<(Of <(INote>)>)..::.Contains Method
NoteCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<INote>.Contains(
    INote item
)
Visual Basic (Declaration)
Private Function Contains ( _
    item As INote _
) As Boolean Implements ICollection(Of INote).Contains
Visual C++
private:
virtual bool Contains(
    INote^ item
) sealed = ICollection<INote^>::Contains

Parameters

item
Type: Mincom.LinkOne.Dom.Notes..::.INote

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


ICollection(INote).CopyTo Method

[image]

LinkOne WebView API
NoteCollection..::.ICollection<(Of <(INote>)>)..::.CopyTo Method
NoteCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<INote>.CopyTo(
    INote[] array,
    int arrayIndex
)
Visual Basic (Declaration)
Private Sub CopyTo ( _
    array As INote(), _
    arrayIndex As Integer _
) Implements ICollection(Of INote).CopyTo
Visual C++
private:
virtual void CopyTo(
    array<INote^>^ array,
    int arrayIndex
) sealed = ICollection<INote^>::CopyTo

Parameters

array
Type: array< Mincom.LinkOne.Dom.Notes..::.INote >[]()[]
arrayIndex
Type: System..::.Int32

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


IEnumerable(INote).GetEnumerator Method

[image]

LinkOne WebView API
NoteCollection..::.IEnumerable<(Of <(INote>)>)..::.GetEnumerator Method
NoteCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator<INote> IEnumerable<INote>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of INote)
    Implements IEnumerable(Of INote).GetEnumerator
Visual C++
private:
virtual IEnumerator<INote^>^ GetEnumerator() sealed = IEnumerable<INote^>::GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
NoteCollection..::.IEnumerable..::.GetEnumerator Method
NoteCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Implements

IEnumerable..::.GetEnumerator()()()

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


ICollection(INote).Remove Method

[image]

LinkOne WebView API
NoteCollection..::.ICollection<(Of <(INote>)>)..::.Remove Method
NoteCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<INote>.Remove(
    INote item
)
Visual Basic (Declaration)
Private Function Remove ( _
    item As INote _
) As Boolean Implements ICollection(Of INote).Remove
Visual C++
private:
virtual bool Remove(
    INote^ item
) sealed = ICollection<INote^>::Remove

Parameters

item
Type: Mincom.LinkOne.Dom.Notes..::.INote

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


Add Method

[image]

LinkOne WebView API
NoteCollection..::.Add Method
NoteCollection Class See Also Send Feedback
Adds the specified note to the collection.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Add(
    Note item
)
Visual Basic (Declaration)
Public Sub Add ( _
    item As Note _
)
Visual C++
public:
virtual void Add(
    Note^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Dom.Notes..::.Note
The note to add.

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


CanCreate Method

[image] [image]

LinkOne WebView API
NoteCollection..::.CanCreate Method
NoteCollection Class See Also Send Feedback

Overload List

Name | Description
CanCreate()()() | Returns true if a note can be created in the note collection.
CanCreate(Access, Scope) | Returns true if a note can be created with the given access and scope in the note collection.

See Also

NoteCollection Class
NoteCollection Members
Mincom.LinkOne.Dom.Notes Namespace


CanCreate Method

[image]

LinkOne WebView API
NoteCollection..::.CanCreate Method
NoteCollection Class See Also Send Feedback
Returns true if a note can be created in the note collection.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool CanCreate()
Visual Basic (Declaration)
Public Function CanCreate As Boolean
Visual C++
public:
bool CanCreate()

Return Value

True of a note can be added to the collection.

Remarks

Only derived book notes can be created.

See Also

NoteCollection Class
CanCreate Overload
Mincom.LinkOne.Dom.Notes Namespace


CanCreate Method (Access, Scope)

[image]

LinkOne WebView API
NoteCollection..::.CanCreate Method (Access, Scope)
NoteCollection Class See Also Send Feedback
Returns true if a note can be created with the given access and scope in the note collection.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool CanCreate(
    Access access,
    Scope scope
)
Visual Basic (Declaration)
Public Function CanCreate ( _
    access As Access, _
    scope As Scope _
) As Boolean
Visual C++
public:
bool CanCreate(
    Access access,
    Scope scope
)

Parameters

access
Type: Mincom.LinkOne.Dom.Notes..::.Access
The accessibility of the note to be created.
scope
Type: Mincom.LinkOne.Dom.Notes..::.Scope
The scope of the note to be created.

Return Value

True if a note can be created for the collection, otherwise false.

Remarks

This tests only if notes can be created for the book, and not the master book.

Remarks

Only derived book notes can be created.

See Also

NoteCollection Class
CanCreate Overload
Mincom.LinkOne.Dom.Notes Namespace


CanEdit Method

[image]

LinkOne WebView API
NoteCollection..::.CanEdit Method
NoteCollection Class See Also Send Feedback
Determines if a note can be edited in the context of the current note collection.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool CanEdit(
    string bookCode,
    Access access,
    Scope scope
)
Visual Basic (Declaration)
Public Function CanEdit ( _
    bookCode As String, _
    access As Access, _
    scope As Scope _
) As Boolean
Visual C++
public:
bool CanEdit(
    String^ bookCode,
    Access access,
    Scope scope
)

Parameters

bookCode
Type: System..::.String
The book code. This must be either the book code or master book code of the note collection that the note will be associated with. This is ignored when scope is global or publisher.
access
Type: Mincom.LinkOne.Dom.Notes..::.Access
The accessibility of the note to be created.
scope
Type: Mincom.LinkOne.Dom.Notes..::.Scope
The scope of the note to be created.

Return Value

True if a note can be edited for the collection, otherwise false.

Remarks

Both master and derived book notes can be edited, hence the need to pass the bookCode to determine which of the two books is to be edited.

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


Clear Method

[image]

LinkOne WebView API
NoteCollection..::.Clear Method
NoteCollection Class See Also Send Feedback
Removes all items from the ICollection<(Of <(T>)>).

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
virtual void Clear() sealed

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


Contains Method

[image]

LinkOne WebView API
NoteCollection..::.Contains Method
NoteCollection Class See Also Send Feedback
Determines whether an note is in the collection.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    Note item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As Note _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Note^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Dom.Notes..::.Note
The note object to search for.

Return Value

true if found in the collection, otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


CopyTo Method

[image]

LinkOne WebView API
NoteCollection..::.CopyTo Method
NoteCollection Class See Also Send Feedback
Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void CopyTo(
    Note[] array,
    int arrayIndex
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As Note(), _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    array<Note^>^ array,
    int arrayIndex
) sealed

Parameters

array
Type: array< Mincom.LinkOne.Dom.Notes..::.Note >[]()[]
The one-dimensional Array that is the destination of the elements copied from ICollection<(Of <(T>)>). The Array must have zero-based indexing.
arrayIndex
Type: System..::.Int32
The zero-based index in array at which copying begins.

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

Exceptions

Exception | Condition
System..::.ArgumentNullException | array is null.
System..::.ArgumentOutOfRangeException | arrayIndex is less than 0.
System..::.ArgumentException | array is multidimensional.-or-arrayIndex is equal to or greater than the length of array.-or-The number of elements in the source ICollection<(Of <(T>)>) is greater than the available space from arrayIndex to the end of the destination array cannot be cast automatically to the type of the destination array.

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


CreateNote(T) Method

[image]

LinkOne WebView API
NoteCollection..::.CreateNote<(Of <(T>)>) Method
NoteCollection Class See Also Send Feedback
Creates the note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public T CreateNote<T>(
    Scope preferredNoteScope,
    Access preferredNoteAccess,
    Association preferredAssociation,
    bool canCreatePublicNotes,
    bool canCreatePrivateNotes,
    bool canCreateSuppliedNotes,
    string publisherCode,
    string bookCode,
    string pageReference,
    string itemId,
    string partNumber,
    int pictureNumber
)
where T : new(), Note
Visual Basic (Declaration)
Public Function CreateNote(Of T As {New, Note}) ( _
    preferredNoteScope As Scope, _
    preferredNoteAccess As Access, _
    preferredAssociation As Association, _
    canCreatePublicNotes As Boolean, _
    canCreatePrivateNotes As Boolean, _
    canCreateSuppliedNotes As Boolean, _
    publisherCode As String, _
    bookCode As String, _
    pageReference As String, _
    itemId As String, _
    partNumber As String, _
    pictureNumber As Integer _
) As T
Visual C++
public:
generic<typename T>
where T : gcnew(), Note
T CreateNote(
    Scope preferredNoteScope,
    Access preferredNoteAccess,
    Association preferredAssociation,
    bool canCreatePublicNotes,
    bool canCreatePrivateNotes,
    bool canCreateSuppliedNotes,
    String^ publisherCode,
    String^ bookCode,
    String^ pageReference,
    String^ itemId,
    String^ partNumber,
    int pictureNumber
)

Parameters

preferredNoteScope
Type: Mincom.LinkOne.Dom.Notes..::.Scope
The preferred note scope.
preferredNoteAccess
Type: Mincom.LinkOne.Dom.Notes..::.Access
The preferred note access.
preferredAssociation
Type: Mincom.LinkOne.Dom.Notes..::.Association
The preferred association.
canCreatePublicNotes
Type: System..::.Boolean
Whether or not public notes can be created.
canCreatePrivateNotes
Type: System..::.Boolean
Whether or note private notes can be created.
canCreateSuppliedNotes
Type: System..::.Boolean
Whether or note supplied notes can be created.
publisherCode
Type: System..::.String
The publisher code, or Empty()()() if no publisher .
bookCode
Type: System..::.String
The book code, or Empty()()() if no book.
pageReference
Type: System..::.String
The page reference, or Empty()()() if no page reference.
itemId
Type: System..::.String
The item id to create the note for, or Empty()()() if no item id .
partNumber
Type: System..::.String
The part number to create the note for, or Empty()()() if no partnumber
pictureNumber
Type: System..::.Int32
The picture number to create the note for, or 0 if no picture

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Mincom.LinkOne.Dom.Notes.NoteCollection.CreateNote``1(Mincom.LinkOne.Dom.Notes.Scope,Mincom.LinkOne.Dom.Notes.Access,Mincom.LinkOne.Dom.Notes.Association,System.Boolean,System.Boolean,System.Boolean,System.String,System.String,System.String,System.String,System.String,System.Int32)"]

Return Value

The created note, or null if a note can't be created.

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


FindBookmark Method

[image]

LinkOne WebView API
NoteCollection..::.FindBookmark Method
NoteCollection Class See Also Send Feedback
Finds the first bookmark of bookmarkName for the given publisher and book.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Bookmark FindBookmark(
    string publisherCode,
    string bookCode,
    string bookmarkName
)
Visual Basic (Declaration)
Public Function FindBookmark ( _
    publisherCode As String, _
    bookCode As String, _
    bookmarkName As String _
) As Bookmark
Visual C++
public:
Bookmark^ FindBookmark(
    String^ publisherCode,
    String^ bookCode,
    String^ bookmarkName
)

Parameters

publisherCode
Type: System..::.String
The publisher code that the note belongs to.
bookCode
Type: System..::.String
The book code that the note belongs to.
bookmarkName
Type: System..::.String
The bookmark name to match.

Return Value

The first bookmark of bookmarkName for the given publisher, book.

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


GetEntryNotes Method

[image]

LinkOne WebView API
NoteCollection..::.GetEntryNotes Method
NoteCollection Class See Also Send Feedback
Returns a new collection of all item and part notes that are for the given item or part number.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public NoteCollection GetEntryNotes(
    string itemId,
    string partNumber
)
Visual Basic (Declaration)
Public Function GetEntryNotes ( _
    itemId As String, _
    partNumber As String _
) As NoteCollection
Visual C++
public:
NoteCollection^ GetEntryNotes(
    String^ itemId,
    String^ partNumber
)

Parameters

itemId
Type: System..::.String
The item id of the wanted notes.
partNumber
Type: System..::.String
The part number of the wanted notes.

Return Value

A Collection of part notes.

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


GetEnumerator Method

[image]

LinkOne WebView API
NoteCollection..::.GetEnumerator Method
NoteCollection Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IEnumerator<Note> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of Note)
Visual C++
public:
virtual IEnumerator<Note^>^ GetEnumerator() sealed

Return Value

A IEnumerator<(Of <(T>)>) that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


GetItemNotes Method

[image]

LinkOne WebView API
NoteCollection..::.GetItemNotes Method
NoteCollection Class See Also Send Feedback
Returns a new collection of all item notes that are for the given item.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public NoteCollection GetItemNotes(
    string itemId
)
Visual Basic (Declaration)
Public Function GetItemNotes ( _
    itemId As String _
) As NoteCollection
Visual C++
public:
NoteCollection^ GetItemNotes(
    String^ itemId
)

Parameters

itemId
Type: System..::.String
The item id of the wanted notes.

Return Value

A Collection of item notes.

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


GetMultilingualNotes Method

[image]

LinkOne WebView API
NoteCollection..::.GetMultilingualNotes Method
NoteCollection Class See Also Send Feedback
Returns the first note from each group in the collection that preferably have the given language or have no language.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public NoteCollection GetMultilingualNotes(
    string languageCode
)
Visual Basic (Declaration)
Public Function GetMultilingualNotes ( _
    languageCode As String _
) As NoteCollection
Visual C++
public:
NoteCollection^ GetMultilingualNotes(
    String^ languageCode
)

Parameters

languageCode
Type: System..::.String
The language code of the wanted notes.

Return Value

A list of the first note from each note group in the collection.

Remarks

All ungrouped notes and the best language-matched note from each group will be returned. The first grouped note found with matching language takes precedence over other notes in the same group. The first grouped note found with a blank language takes precedence over other notes with a mismatching language in the same group.

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


GetNotes Method

[image] [image]

LinkOne WebView API
NoteCollection..::.GetNotes Method
NoteCollection Class See Also Send Feedback

Overload List

Name | Description
GetNotes(Scope) | Gets the notes in the collection for the given scope.
GetNotes(String) | Returns the first note from each group in the collection that must match the given language or have no language.

See Also

NoteCollection Class
NoteCollection Members
Mincom.LinkOne.Dom.Notes Namespace


GetNotes Method (Scope)

[image]

LinkOne WebView API
NoteCollection..::.GetNotes Method (Scope)
NoteCollection Class See Also Send Feedback
Gets the notes in the collection for the given scope.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public NoteCollection GetNotes(
    Scope scope
)
Visual Basic (Declaration)
Public Function GetNotes ( _
    scope As Scope _
) As NoteCollection
Visual C++
public:
NoteCollection^ GetNotes(
    Scope scope
)

Parameters

scope
Type: Mincom.LinkOne.Dom.Notes..::.Scope
The scope to get.

Return Value

The notes in the collection for the given scope.

See Also

NoteCollection Class
GetNotes Overload
Mincom.LinkOne.Dom.Notes Namespace


GetNotes Method (String)

[image]

LinkOne WebView API
NoteCollection..::.GetNotes Method (String)
NoteCollection Class See Also Send Feedback
Returns the first note from each group in the collection that must match the given language or have no language.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public NoteCollection GetNotes(
    string languageCode
)
Visual Basic (Declaration)
Public Function GetNotes ( _
    languageCode As String _
) As NoteCollection
Visual C++
public:
NoteCollection^ GetNotes(
    String^ languageCode
)

Parameters

languageCode
Type: System..::.String
The language code of the wanted notes.

Return Value

A collection of the first note from each note group in the collection that match the given language or have no language.

Remarks

Any ungrouped notes that mismatch the language or aren't blank, and all groups with mismatched notes are ignored. The first grouped note found with matching language takes precedence over notes in the same group with a blank language.

See Also

NoteCollection Class
GetNotes Overload
Mincom.LinkOne.Dom.Notes Namespace


GetPartNotes Method

[image]

LinkOne WebView API
NoteCollection..::.GetPartNotes Method
NoteCollection Class See Also Send Feedback
Returns a new collection of all part notes that are for the given part number.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public NoteCollection GetPartNotes(
    string partNumber
)
Visual Basic (Declaration)
Public Function GetPartNotes ( _
    partNumber As String _
) As NoteCollection
Visual C++
public:
NoteCollection^ GetPartNotes(
    String^ partNumber
)

Parameters

partNumber
Type: System..::.String
The part number of the wanted notes.

Return Value

A Collection of part notes.

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


GetTranslations Method

[image]

LinkOne WebView API
NoteCollection..::.GetTranslations Method
NoteCollection Class See Also Send Feedback
Returns a new collection of translated notes from the collection that are for the given note, or null if the given note is not translateable.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public NoteCollection GetTranslations(
    Note note
)
Visual Basic (Declaration)
Public Function GetTranslations ( _
    note As Note _
) As NoteCollection
Visual C++
public:
NoteCollection^ GetTranslations(
    Note^ note
)

Parameters

note
Type: Mincom.LinkOne.Dom.Notes..::.Note
The note to get translations for.

Return Value

A collection of translated notes from the collection that are for the given note.

Remarks

The result collection will not include the given note.

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


GetValueNotes Method

[image]

LinkOne WebView API
NoteCollection..::.GetValueNotes Method
NoteCollection Class See Also Send Feedback
Returns a new collection of notes, containing all the ValueNote in the collection.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public NoteCollection GetValueNotes()
Visual Basic (Declaration)
Public Function GetValueNotes As NoteCollection
Visual C++
public:
NoteCollection^ GetValueNotes()

Return Value

A new collection of notes, containing all the ValueNote in the collection.

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


IndexOf Method

[image]

LinkOne WebView API
NoteCollection..::.IndexOf Method
NoteCollection Class See Also Send Feedback
Searches the collection and returns the zero-based index of the first occurence of the given note object.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int IndexOf(
    Note note
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    note As Note _
) As Integer
Visual C++
public:
int IndexOf(
    Note^ note
)

Parameters

note
Type: Mincom.LinkOne.Dom.Notes..::.Note
The note object to search for.

Return Value

The zero-based index of the note object in the collection, if found; otherwise, -1.

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


InitializeNote Method

[image]

LinkOne WebView API
NoteCollection..::.InitializeNote Method
NoteCollection Class See Also Send Feedback
Initializes the note access and scope so the note can be added to the note collection.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool InitializeNote(
    Note note
)
Visual Basic (Declaration)
Public Function InitializeNote ( _
    note As Note _
) As Boolean
Visual C++
public:
bool InitializeNote(
    Note^ note
)

Parameters

note
Type: Mincom.LinkOne.Dom.Notes..::.Note
The note to set the scope on.

Return Value

True if access and scope were set, or false if no access and scope available for creation.

Remarks

Sets the most restrictive scope available in the collection for creation of the given note. The note should have its publisher code, book code, page reference and association set before InitializeNote(Note) is called.

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


INoteCollection.Create Method

[image]

LinkOne WebView API
NoteCollection..::.INoteCollection..::.Create Method
NoteCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
INote INoteCollection.Create(
    Type noteType
)
Visual Basic (Declaration)
Private Function Create ( _
    noteType As Type _
) As INote Implements INoteCollection.Create
Visual C++
private:
virtual INote^ Create(
    Type^ noteType
) sealed = INoteCollection::Create

Parameters

noteType
Type: System..::.Type

Implements

INoteCollection..::.Create(Type)

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


LoadXml Method

[image]

LinkOne WebView API
NoteCollection..::.LoadXml Method
NoteCollection Class See Also Send Feedback
Populates the collection with the given XML.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void LoadXml(
    string xml
)
Visual Basic (Declaration)
Public Sub LoadXml ( _
    xml As String _
)
Visual C++
public:
void LoadXml(
    String^ xml
)

Parameters

xml
Type: System..::.String
The note content in XML format.

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


Merge Method

[image] [image]

LinkOne WebView API
NoteCollection..::.Merge Method
NoteCollection Class See Also Send Feedback

Overload List

Name | Description
Merge(NoteCollection) | Merges a collection of notes to the collection.
Merge(ICollection<(Of <(Note>)>)) | Merges a collection of notes to the collection.

See Also

NoteCollection Class
NoteCollection Members
Mincom.LinkOne.Dom.Notes Namespace


Merge Method (NoteCollection)

[image]

LinkOne WebView API
NoteCollection..::.Merge Method (NoteCollection)
NoteCollection Class See Also Send Feedback
Merges a collection of notes to the collection.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Merge(
    NoteCollection notes
)
Visual Basic (Declaration)
Public Sub Merge ( _
    notes As NoteCollection _
)
Visual C++
public:
void Merge(
    NoteCollection^ notes
)

Parameters

notes
Type: Mincom.LinkOne.Dom.Notes..::.NoteCollection
The collection of notes to be merged with the collection.

See Also

NoteCollection Class
Merge Overload
Mincom.LinkOne.Dom.Notes Namespace


Merge Method (ICollection(Note))

[image]

LinkOne WebView API
NoteCollection..::.Merge Method (ICollection<(Of <(Note>)>))
NoteCollection Class See Also Send Feedback
Merges a collection of notes to the collection.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Merge(
    ICollection<Note> notes
)
Visual Basic (Declaration)
Public Sub Merge ( _
    notes As ICollection(Of Note) _
)
Visual C++
public:
void Merge(
    ICollection<Note^>^ notes
)

Parameters

notes
Type: System.Collections.Generic..::.ICollection<(Of <( Note >)>)
The collection of notes to be merged with the collection.

Remarks

Notewriter flags are ignored.

See Also

NoteCollection Class
Merge Overload
Mincom.LinkOne.Dom.Notes Namespace


Remove Method

[image]

LinkOne WebView API
NoteCollection..::.Remove Method
NoteCollection Class See Also Send Feedback
Removes the specified note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Remove(
    Note item
)
Visual Basic (Declaration)
Public Function Remove ( _
    item As Note _
) As Boolean
Visual C++
public:
virtual bool Remove(
    Note^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Dom.Notes..::.Note
The note to remove.

Return Value

A value indicating whether the note was removed.

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


SetCanCreate Method

[image]

LinkOne WebView API
NoteCollection..::.SetCanCreate Method
NoteCollection Class See Also Send Feedback
Sets the can create status of a specific note access and scope in the context of the current note collection.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void SetCanCreate(
    Access access,
    Scope scope,
    string bookCode,
    bool state
)
Visual Basic (Declaration)
Public Sub SetCanCreate ( _
    access As Access, _
    scope As Scope, _
    bookCode As String, _
    state As Boolean _
)
Visual C++
public:
void SetCanCreate(
    Access access,
    Scope scope,
    String^ bookCode,
    bool state
)

Parameters

access
Type: Mincom.LinkOne.Dom.Notes..::.Access
The accessibility of the note to be created.
scope
Type: Mincom.LinkOne.Dom.Notes..::.Scope
The scope of the note to be created.
bookCode
Type: System..::.String
The book code for the note.
state
Type: System..::.Boolean
Whether or not the note file is writeable.

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


SetWriteStateEvaluator Method

[image]

LinkOne WebView API
NoteCollection..::.SetWriteStateEvaluator Method
NoteCollection Class See Also Send Feedback
Set the delayed write permissions evaluator for this collection.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void SetWriteStateEvaluator(
    WriteStateEvaluator<NoteCollection> evaluator
)
Visual Basic (Declaration)
Public Sub SetWriteStateEvaluator ( _
    evaluator As WriteStateEvaluator(Of NoteCollection) _
)
Visual C++
public:
void SetWriteStateEvaluator(
    WriteStateEvaluator<NoteCollection^>^ evaluator
)

Parameters

evaluator
Type: Mincom.LinkOne.Dom.Notes..::.WriteStateEvaluator <(Of <( NoteCollection >)>)
The permissions evaluator.

Remarks

This method allows write permission evaluation to be delayed until actually read and required.

If there is an existing evalutor, it is invoked before setting the new one.

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace
Mincom.LinkOne.Dom.Notes..::.WriteStateEvaluator<(Of <(T>)>)


Sort Method

[image]

LinkOne WebView API
NoteCollection..::.Sort Method
NoteCollection Class See Also Send Feedback
Sorts the elements in the collection using the specified comparer.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Sort(
    IComparer<Note> comparer
)
Visual Basic (Declaration)
Public Sub Sort ( _
    comparer As IComparer(Of Note) _
)
Visual C++
public:
void Sort(
    IComparer<Note^>^ comparer
)

Parameters

comparer
Type: System.Collections.Generic..::.IComparer<(Of <( Note >)>)
The IComparer<(Of <(T>)>) implementation to use when comparing
elements, or null to use the default comparer Default.

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


NoteCollection Properties

[image] [image]

LinkOne WebView API
NoteCollection Properties
NoteCollection Class See Also Send Feedback

The NoteCollection type exposes the following members.

Properties

Name | Description
BookCode | Gets the book code that this collection is associated with.
Count | Gets the number of notes contained in the ICollection<(Of <(T>)>).
HasChanged | Gets true if the any of the notes in the collection have been changed; that is, if any Status does not equal Unchanged.
Item | Gets the Note at the specified index.
LanguageCode | Gets the language code that the notes in the collection are associated with.
MasterBookCode | Gets the master book code that this collection is associated with.
PageReference | Gets the page reference that this collection is associated with.
PublisherCode | Gets the publisher code that this collection is associated with.

Explicit Interface Implementations

Name | Description
System#Collections#Generic#ICollection{T}#IsReadOnly |
ICollection<(Of <(INote>)>)..::.Count |

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


ICollection(INote).Count Property

[image]

LinkOne WebView API
NoteCollection..::.ICollection<(Of <(INote>)>)..::.Count Property
NoteCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int ICollection<INote>.Count { get; }
Visual Basic (Declaration)
Private ReadOnly Property Count As Integer
    Implements ICollection(Of INote).Count
Visual C++
private:
virtual property int Count {
    int get () sealed = ICollection<INote^>::Count::get;
}

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


BookCode Property

[image]

LinkOne WebView API
NoteCollection..::.BookCode Property
NoteCollection Class See Also Send Feedback
Gets the book code that this collection is associated with.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string BookCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property BookCode As String
Visual C++
public:
property String^ BookCode {
    String^ get ();
}

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


Count Property

[image]

LinkOne WebView API
NoteCollection..::.Count Property
NoteCollection Class See Also Send Feedback
Gets the number of notes contained in the ICollection<(Of <(T>)>).

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Return Value

The number of elements contained in the ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


HasChanged Property

[image]

LinkOne WebView API
NoteCollection..::.HasChanged Property
NoteCollection Class See Also Send Feedback
Gets true if the any of the notes in the collection have been changed; that is, if any Status does not equal Unchanged.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool HasChanged { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasChanged As Boolean
Visual C++
public:
property bool HasChanged {
    bool get ();
}

Remarks

Changed notes include new notes and notes which have been marked for deletion.

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


Item Property

[image]

LinkOne WebView API
NoteCollection..::.Item Property
NoteCollection Class See Also Send Feedback
Gets the Note at the specified index.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Note this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Note
Visual C++
public:
property Note^ default[int index] {
    Note^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


LanguageCode Property

[image]

LinkOne WebView API
NoteCollection..::.LanguageCode Property
NoteCollection Class See Also Send Feedback
Gets the language code that the notes in the collection are associated with.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string LanguageCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property LanguageCode As String
Visual C++
public:
property String^ LanguageCode {
    String^ get ();
}

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


MasterBookCode Property

[image]

LinkOne WebView API
NoteCollection..::.MasterBookCode Property
NoteCollection Class See Also Send Feedback
Gets the master book code that this collection is associated with.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string MasterBookCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property MasterBookCode As String
Visual C++
public:
property String^ MasterBookCode {
    String^ get ();
}

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


PageReference Property

[image]

LinkOne WebView API
NoteCollection..::.PageReference Property
NoteCollection Class See Also Send Feedback
Gets the page reference that this collection is associated with.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PageReference { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageReference As String
Visual C++
public:
property String^ PageReference {
    String^ get ();
}

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


PublisherCode Property

[image]

LinkOne WebView API
NoteCollection..::.PublisherCode Property
NoteCollection Class See Also Send Feedback
Gets the publisher code that this collection is associated with.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PublisherCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublisherCode As String
Visual C++
public:
property String^ PublisherCode {
    String^ get ();
}

See Also

NoteCollection Class
Mincom.LinkOne.Dom.Notes Namespace


NoteCollection.NoteCollectionWriteState Class

[image]

LinkOne WebView API
NoteCollection..::.NoteCollectionWriteState Class
NoteCollection Class Members See Also Send Feedback
Implements WriteState<(Of <(T>)>) for NoteCollection.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public class NoteCollectionWriteState : WriteState<NoteCollection>
Visual Basic (Declaration)
Public Class NoteCollectionWriteState _
    Inherits WriteState(Of NoteCollection)
Visual C++
public ref class NoteCollectionWriteState : public WriteState<NoteCollection^>

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Notes..::.WriteState <(Of <( NoteCollection >)>)
Mincom.LinkOne.Dom.Notes..::.NoteCollection..::.NoteCollectionWriteState

See Also

NoteCollection..::.NoteCollectionWriteState Members
Mincom.LinkOne.Dom.Notes Namespace


NoteCollection.NoteCollectionWriteState Members

[image] [image]

LinkOne WebView API
NoteCollection..::.NoteCollectionWriteState Members
NoteCollection..::.NoteCollectionWriteState Class Constructors Methods See Also Send Feedback

Represents a collection of notes.

The NoteCollection..::.NoteCollectionWriteState type exposes the following members.

Constructors

Name | Description
NoteCollection..::.NoteCollectionWriteState | Initializes a new instance of the NoteCollection..::.NoteCollectionWriteState class

Methods

Name | Description
ApplyState | Sets to book/master book write flags from internal values. (Overrides WriteState<(Of <(T>)>)..::.ApplyState(T).)
CacheState | Stores book/master book write flags from from. (Overrides WriteState<(Of <(T>)>)..::.CacheState(T).)
Clear | Clears internal write flags to None()()(). (Overrides WriteState<(Of <(T>)>)..::.Clear()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Merge | Merges mergeFrom book/master book write flags with internal values. (Overrides WriteState<(Of <(T>)>)..::.Merge(T).)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

NoteCollection..::.NoteCollectionWriteState Class
Mincom.LinkOne.Dom.Notes Namespace


NoteCollection.NoteCollectionWriteState Constructor

[image]

LinkOne WebView API
NoteCollection..::.NoteCollectionWriteState Constructor
NoteCollection..::.NoteCollectionWriteState Class See Also Send Feedback
Initializes a new instance of the NoteCollection..::.NoteCollectionWriteState class

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public NoteCollectionWriteState()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NoteCollectionWriteState()

See Also

NoteCollection..::.NoteCollectionWriteState Class
Mincom.LinkOne.Dom.Notes Namespace


NoteCollection.NoteCollectionWriteState Methods

[image] [image]

LinkOne WebView API
NoteCollection..::.NoteCollectionWriteState Methods
NoteCollection..::.NoteCollectionWriteState Class See Also Send Feedback

The NoteCollection..::.NoteCollectionWriteState type exposes the following members.

Methods

Name | Description
ApplyState | Sets to book/master book write flags from internal values. (Overrides WriteState<(Of <(T>)>)..::.ApplyState(T).)
CacheState | Stores book/master book write flags from from. (Overrides WriteState<(Of <(T>)>)..::.CacheState(T).)
Clear | Clears internal write flags to None()()(). (Overrides WriteState<(Of <(T>)>)..::.Clear()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Merge | Merges mergeFrom book/master book write flags with internal values. (Overrides WriteState<(Of <(T>)>)..::.Merge(T).)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

NoteCollection..::.NoteCollectionWriteState Class
Mincom.LinkOne.Dom.Notes Namespace


ApplyState Method

[image]

LinkOne WebView API
NoteCollection..::.NoteCollectionWriteState..::.ApplyState Method
NoteCollection..::.NoteCollectionWriteState Class See Also Send Feedback
Sets to book/master book write flags from internal values.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override void ApplyState(
    NoteCollection to
)
Visual Basic (Declaration)
Public Overrides Sub ApplyState ( _
    to As NoteCollection _
)
Visual C++
public:
virtual void ApplyState(
    NoteCollection^ to
) override

Parameters

to
Type: Mincom.LinkOne.Dom.Notes..::.NoteCollection
To write to.

See Also

NoteCollection..::.NoteCollectionWriteState Class
Mincom.LinkOne.Dom.Notes Namespace


CacheState Method

[image]

LinkOne WebView API
NoteCollection..::.NoteCollectionWriteState..::.CacheState Method
NoteCollection..::.NoteCollectionWriteState Class See Also Send Feedback
Stores book/master book write flags from from.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override void CacheState(
    NoteCollection from
)
Visual Basic (Declaration)
Public Overrides Sub CacheState ( _
    from As NoteCollection _
)
Visual C++
public:
virtual void CacheState(
    NoteCollection^ from
) override

Parameters

from
Type: Mincom.LinkOne.Dom.Notes..::.NoteCollection
To cache from.

See Also

NoteCollection..::.NoteCollectionWriteState Class
Mincom.LinkOne.Dom.Notes Namespace


Clear Method

[image]

LinkOne WebView API
NoteCollection..::.NoteCollectionWriteState..::.Clear Method
NoteCollection..::.NoteCollectionWriteState Class See Also Send Feedback
Clears internal write flags to None()()().

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override void Clear()
Visual Basic (Declaration)
Public Overrides Sub Clear
Visual C++
public:
virtual void Clear() override

See Also

NoteCollection..::.NoteCollectionWriteState Class
Mincom.LinkOne.Dom.Notes Namespace


Merge Method

[image]

LinkOne WebView API
NoteCollection..::.NoteCollectionWriteState..::.Merge Method
NoteCollection..::.NoteCollectionWriteState Class See Also Send Feedback
Merges mergeFrom book/master book write flags with internal values.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override void Merge(
    NoteCollection mergeFrom
)
Visual Basic (Declaration)
Public Overrides Sub Merge ( _
    mergeFrom As NoteCollection _
)
Visual C++
public:
virtual void Merge(
    NoteCollection^ mergeFrom
) override

Parameters

mergeFrom
Type: Mincom.LinkOne.Dom.Notes..::.NoteCollection
To merge from.

See Also

NoteCollection..::.NoteCollectionWriteState Class
Mincom.LinkOne.Dom.Notes Namespace


ProgramNote Class

[image]

LinkOne WebView API
ProgramNote Class
Members See Also Send Feedback
A class which represents a Program note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class ProgramNote : ListNote,
    IProgramNote, IListNote, ICategorizedNote, ITranslatedNote, INote
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class ProgramNote _
    Inherits ListNote _
    Implements IProgramNote, IListNote, ICategorizedNote, ITranslatedNote,  _
    INote
Visual C++
[SerializableAttribute]
public ref class ProgramNote sealed : public ListNote,
    IProgramNote, IListNote, ICategorizedNote, ITranslatedNote, INote

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Notes..::.Note
Mincom.LinkOne.Dom.Notes..::.TranslatedNote
Mincom.LinkOne.Dom.Notes..::.CategorizedNote
Mincom.LinkOne.Dom.Notes..::.ListNote
Mincom.LinkOne.Dom.Notes..::.ProgramNote

See Also

ProgramNote Members
Mincom.LinkOne.Dom.Notes Namespace


ProgramNote Members

[image] [image]

LinkOne WebView API
ProgramNote Members
ProgramNote Class Constructors Methods Properties See Also Send Feedback

The ProgramNote type exposes the following members.

Constructors

Name | Description
ProgramNote | Creates an instance of the ProgramNote.

Methods

Name | Description
CanSetAccess | Determines whether this Note instance can set the Access to the specified value. (Inherited from Note.)
CanSetAssociation | Determines whether this Note instance can set Association to the specified value. (Inherited from Note.)
CanSetScope | Determines whether this Note instance can set Scope to the the specified value. (Inherited from Note.)
Clone | Gets a clone of the this. (Inherited from Note.)
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the hash code for the object. (Inherited from Note.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanging | Sets the note status to changed. (Inherited from Note.)
Remove | Sets the note status to Deleted. (Inherited from Note.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Overloaded.

Properties

Name | Description
Access | Gets or sets the note access. (Inherited from Note.)
Association | Gets what the note is associated with. (Inherited from Note.)
Behaviour | Gets or sets the note behaviour. (Inherited from ListNote.)
BookCode | Gets or sets the book code of the note. (Inherited from Note.)
Category | Gets or sets the note category. (Inherited from CategorizedNote.)
CommandLine | Gets or sets the command line of the program note.
DdeCommandLine | Gets or sets the DDE command line of the program note.
DdeServiceName | Gets or sets the DDE service name of the program note.
DdeTopicName | Gets or sets the DDE topic name of the program note.
Description | Gets or sets the description of the note. (Inherited from CategorizedNote.)
DisplayName | See DisplayName for more information. (Inherited from CategorizedNote.)
Group | Gets or sets the group identifier of the note. (Inherited from TranslatedNote.)
Id | Gets or sets the unique ID of the note. (Inherited from Note.)
IsListNote | Gets or sets whether the note appears in the notes list. (Inherited from ListNote.)
ItemId | Gets or sets the item ID of the note. (Inherited from Note.)
Key | Gets a key that uniquely defines the note. (Inherited from ListNote.)
LanguageCode | Gets or sets the language code. (Inherited from TranslatedNote.)
OriginalNote | Gets or the original note; or null if the note hasn't changed. (Inherited from Note.)
PageReference | Gets or sets the page reference of the note. (Inherited from Note.)
PartNumber | Gets or sets the part number of the note. (Inherited from Note.)
PictureNumber | Gets or sets the picture number of the redline note. (Inherited from Note.)
PublisherCode | Gets or sets the publisher code of the note. (Inherited from Note.)
Scope | Gets the note scope. (Inherited from Note.)
Status | Gets or sets the status of the note in relation to the copy saved in persistent storage. (Inherited from Note.)
TimeStamp | Gets or sets the date and time when the note was last written. (Inherited from Note.)
Translation | See Translation for more information. (Overrides TranslatedNote..::.Translation.)
Xml | Gets the XML representing the note. (Inherited from Note.)

See Also

ProgramNote Class
Mincom.LinkOne.Dom.Notes Namespace


ProgramNote Constructor

[image]

LinkOne WebView API
ProgramNote Constructor
ProgramNote Class See Also Send Feedback
Creates an instance of the ProgramNote.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ProgramNote()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ProgramNote()

See Also

ProgramNote Class
Mincom.LinkOne.Dom.Notes Namespace


ProgramNote Methods

[image] [image]

LinkOne WebView API
ProgramNote Methods
ProgramNote Class See Also Send Feedback

The ProgramNote type exposes the following members.

Methods

Name | Description
CanSetAccess | Determines whether this Note instance can set the Access to the specified value. (Inherited from Note.)
CanSetAssociation | Determines whether this Note instance can set Association to the specified value. (Inherited from Note.)
CanSetScope | Determines whether this Note instance can set Scope to the the specified value. (Inherited from Note.)
Clone | Gets a clone of the this. (Inherited from Note.)
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the hash code for the object. (Inherited from Note.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanging | Sets the note status to changed. (Inherited from Note.)
Remove | Sets the note status to Deleted. (Inherited from Note.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Overloaded.

See Also

ProgramNote Class
Mincom.LinkOne.Dom.Notes Namespace


Equals Method

[image] [image]

LinkOne WebView API
ProgramNote..::.Equals Method
ProgramNote Class See Also Send Feedback

Overload List

Name | Description
Equals(Note) | Determines whether the specified note is equal to the current note. (Inherited from Note.)
Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Note.)

See Also

ProgramNote Class
ProgramNote Members
Mincom.LinkOne.Dom.Notes Namespace


Validate Method

[image] [image]

LinkOne WebView API
ProgramNote..::.Validate Method
ProgramNote Class See Also Send Feedback

Overload List

Name | Description
Validate(String) | See Validate(String) for more information. (Overrides Note..::.Validate(String).)
Validate(Access, String, String, String, String, String, Int32) | Validates the given properties for a note. (Inherited from Note.)

See Also

ProgramNote Class
ProgramNote Members
Mincom.LinkOne.Dom.Notes Namespace


Validate Method (String)

[image]

LinkOne WebView API
ProgramNote..::.Validate Method (String)
ProgramNote Class See Also Send Feedback
See Validate(String) for more information.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override bool Validate(
    string propertyName
)
Visual Basic (Declaration)
Public Overrides Function Validate ( _
    propertyName As String _
) As Boolean
Visual C++
public:
virtual bool Validate(
    String^ propertyName
) override

Parameters

propertyName
Type: System..::.String

See Also

ProgramNote Class
Validate Overload
Mincom.LinkOne.Dom.Notes Namespace


ProgramNote Properties

[image] [image]

LinkOne WebView API
ProgramNote Properties
ProgramNote Class See Also Send Feedback

The ProgramNote type exposes the following members.

Properties

Name | Description
Access | Gets or sets the note access. (Inherited from Note.)
Association | Gets what the note is associated with. (Inherited from Note.)
Behaviour | Gets or sets the note behaviour. (Inherited from ListNote.)
BookCode | Gets or sets the book code of the note. (Inherited from Note.)
Category | Gets or sets the note category. (Inherited from CategorizedNote.)
CommandLine | Gets or sets the command line of the program note.
DdeCommandLine | Gets or sets the DDE command line of the program note.
DdeServiceName | Gets or sets the DDE service name of the program note.
DdeTopicName | Gets or sets the DDE topic name of the program note.
Description | Gets or sets the description of the note. (Inherited from CategorizedNote.)
DisplayName | See DisplayName for more information. (Inherited from CategorizedNote.)
Group | Gets or sets the group identifier of the note. (Inherited from TranslatedNote.)
Id | Gets or sets the unique ID of the note. (Inherited from Note.)
IsListNote | Gets or sets whether the note appears in the notes list. (Inherited from ListNote.)
ItemId | Gets or sets the item ID of the note. (Inherited from Note.)
Key | Gets a key that uniquely defines the note. (Inherited from ListNote.)
LanguageCode | Gets or sets the language code. (Inherited from TranslatedNote.)
OriginalNote | Gets or the original note; or null if the note hasn't changed. (Inherited from Note.)
PageReference | Gets or sets the page reference of the note. (Inherited from Note.)
PartNumber | Gets or sets the part number of the note. (Inherited from Note.)
PictureNumber | Gets or sets the picture number of the redline note. (Inherited from Note.)
PublisherCode | Gets or sets the publisher code of the note. (Inherited from Note.)
Scope | Gets the note scope. (Inherited from Note.)
Status | Gets or sets the status of the note in relation to the copy saved in persistent storage. (Inherited from Note.)
TimeStamp | Gets or sets the date and time when the note was last written. (Inherited from Note.)
Translation | See Translation for more information. (Overrides TranslatedNote..::.Translation.)
Xml | Gets the XML representing the note. (Inherited from Note.)

See Also

ProgramNote Class
Mincom.LinkOne.Dom.Notes Namespace


CommandLine Property

[image]

LinkOne WebView API
ProgramNote..::.CommandLine Property
ProgramNote Class See Also Send Feedback
Gets or sets the command line of the program note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string CommandLine { get; set; }
Visual Basic (Declaration)
Public Property CommandLine As String
Visual C++
public:
virtual property String^ CommandLine {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Field Value

The command line for the program note.

Implements

IProgramNote..::.CommandLine

See Also

ProgramNote Class
Mincom.LinkOne.Dom.Notes Namespace


DdeCommandLine Property

[image]

LinkOne WebView API
ProgramNote..::.DdeCommandLine Property
ProgramNote Class See Also Send Feedback
Gets or sets the DDE command line of the program note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string DdeCommandLine { get; set; }
Visual Basic (Declaration)
Public Property DdeCommandLine As String
Visual C++
public:
virtual property String^ DdeCommandLine {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Field Value

The DDE command line for the program note.

Implements

IProgramNote..::.DdeCommandLine

See Also

ProgramNote Class
Mincom.LinkOne.Dom.Notes Namespace


DdeServiceName Property

[image]

LinkOne WebView API
ProgramNote..::.DdeServiceName Property
ProgramNote Class See Also Send Feedback
Gets or sets the DDE service name of the program note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string DdeServiceName { get; set; }
Visual Basic (Declaration)
Public Property DdeServiceName As String
Visual C++
public:
virtual property String^ DdeServiceName {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Field Value

The DDE service name for the program note.

Implements

IProgramNote..::.DdeServiceName

See Also

ProgramNote Class
Mincom.LinkOne.Dom.Notes Namespace


DdeTopicName Property

[image]

LinkOne WebView API
ProgramNote..::.DdeTopicName Property
ProgramNote Class See Also Send Feedback
Gets or sets the DDE topic name of the program note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string DdeTopicName { get; set; }
Visual Basic (Declaration)
Public Property DdeTopicName As String
Visual C++
public:
virtual property String^ DdeTopicName {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Field Value

The DDE topic name for the program note.

Implements

IProgramNote..::.DdeTopicName

See Also

ProgramNote Class
Mincom.LinkOne.Dom.Notes Namespace


Translation Property

[image]

LinkOne WebView API
ProgramNote..::.Translation Property
ProgramNote Class See Also Send Feedback
See Translation for more information.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string Translation { get; set; }
Visual Basic (Declaration)
Public Overrides Property Translation As String
Visual C++
public:
virtual property String^ Translation {
    String^ get () override;
    void set (String^ value) override;
}

Implements

ITranslatedNote..::.Translation
ITranslatedNote..::.Translation

See Also

ProgramNote Class
Mincom.LinkOne.Dom.Notes Namespace


RedlineNote Class

[image]

LinkOne WebView API
RedlineNote Class
Members See Also Send Feedback
A class which represents a redline note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class RedlineNote : CategorizedNote,
    IRedlineNote, ICategorizedNote, ITranslatedNote, INote
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class RedlineNote _
    Inherits CategorizedNote _
    Implements IRedlineNote, ICategorizedNote, ITranslatedNote, INote
Visual C++
[SerializableAttribute]
public ref class RedlineNote sealed : public CategorizedNote,
    IRedlineNote, ICategorizedNote, ITranslatedNote, INote

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Notes..::.Note
Mincom.LinkOne.Dom.Notes..::.TranslatedNote
Mincom.LinkOne.Dom.Notes..::.CategorizedNote
Mincom.LinkOne.Dom.Notes..::.RedlineNote

See Also

RedlineNote Members
Mincom.LinkOne.Dom.Notes Namespace


RedlineNote Members

[image] [image]

LinkOne WebView API
RedlineNote Members
RedlineNote Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The RedlineNote type exposes the following members.

Constructors

Name | Description
RedlineNote | Initializes a new instance of the RedlineNote class.

Methods

Name | Description
CanSetAccess | Determines whether this Note instance can set the Access to the specified value. (Inherited from Note.)
CanSetAssociation | Determines whether this Note instance can set Association to the specified value. (Inherited from Note.)
CanSetScope | Determines whether this Note instance can set Scope to the the specified value. (Inherited from Note.)
Clone | Gets a clone of the this. (Inherited from Note.)
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the hash code for the object. (Inherited from Note.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanging | Sets the note status to changed. (Inherited from Note.)
Remove | Sets the note status to Deleted. (Inherited from Note.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Overloaded.

Properties

Name | Description
Access | Gets or sets the note access. (Inherited from Note.)
Association | Gets what the note is associated with. (Inherited from Note.)
BookCode | Gets or sets the book code of the note. (Inherited from Note.)
Category | Gets or sets the note category. (Inherited from CategorizedNote.)
Description | Gets or sets the description of the note. (Inherited from CategorizedNote.)
DisplayName | See DisplayName for more information. (Inherited from CategorizedNote.)
DrawingElements | Gets the drawing elements.
Group | Gets or sets the group identifier of the note. (Inherited from TranslatedNote.)
Id | Gets or sets the unique ID of the note. (Inherited from Note.)
ItemId | Gets or sets the item ID of the note. (Inherited from Note.)
Key | Gets a key that uniquely defines the note. (Inherited from CategorizedNote.)
LanguageCode | Gets or sets the language code. (Inherited from TranslatedNote.)
OriginalNote | Gets or the original note; or null if the note hasn't changed. (Inherited from Note.)
PageReference | Gets or sets the page reference of the note. (Inherited from Note.)
PartNumber | Gets or sets the part number of the note. (Inherited from Note.)
PictureNumber | Gets or sets the picture number of the redline note. (Inherited from Note.)
PublisherCode | Gets or sets the publisher code of the note. (Inherited from Note.)
Scope | Gets the note scope. (Inherited from Note.)
Status | Gets or sets the status of the note in relation to the copy saved in persistent storage. (Inherited from Note.)
TimeStamp | Gets or sets the date and time when the note was last written. (Inherited from Note.)
Translation | See Translation for more information. (Overrides TranslatedNote..::.Translation.)
Xml | Gets the XML representing the note. (Inherited from Note.)

Explicit Interface Implementations

Name | Description
IRedlineNote..::.DrawingElements |

See Also

RedlineNote Class
Mincom.LinkOne.Dom.Notes Namespace


RedlineNote Constructor

[image]

LinkOne WebView API
RedlineNote Constructor
RedlineNote Class See Also Send Feedback
Initializes a new instance of the RedlineNote class.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public RedlineNote()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RedlineNote()

See Also

RedlineNote Class
Mincom.LinkOne.Dom.Notes Namespace


RedlineNote Methods

[image] [image]

LinkOne WebView API
RedlineNote Methods
RedlineNote Class See Also Send Feedback

The RedlineNote type exposes the following members.

Methods

Name | Description
CanSetAccess | Determines whether this Note instance can set the Access to the specified value. (Inherited from Note.)
CanSetAssociation | Determines whether this Note instance can set Association to the specified value. (Inherited from Note.)
CanSetScope | Determines whether this Note instance can set Scope to the the specified value. (Inherited from Note.)
Clone | Gets a clone of the this. (Inherited from Note.)
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the hash code for the object. (Inherited from Note.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanging | Sets the note status to changed. (Inherited from Note.)
Remove | Sets the note status to Deleted. (Inherited from Note.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Overloaded.

See Also

RedlineNote Class
Mincom.LinkOne.Dom.Notes Namespace


Equals Method

[image] [image]

LinkOne WebView API
RedlineNote..::.Equals Method
RedlineNote Class See Also Send Feedback

Overload List

Name | Description
Equals(Note) | Determines whether the specified note is equal to the current note. (Inherited from Note.)
Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Note.)

See Also

RedlineNote Class
RedlineNote Members
Mincom.LinkOne.Dom.Notes Namespace


Validate Method

[image] [image]

LinkOne WebView API
RedlineNote..::.Validate Method
RedlineNote Class See Also Send Feedback

Overload List

Name | Description
Validate(String) | See Validate(String) for more information. (Overrides Note..::.Validate(String).)
Validate(Access, String, String, String, String, String, Int32) | Validates the given properties for a note. (Inherited from Note.)

See Also

RedlineNote Class
RedlineNote Members
Mincom.LinkOne.Dom.Notes Namespace


Validate Method (String)

[image]

LinkOne WebView API
RedlineNote..::.Validate Method (String)
RedlineNote Class See Also Send Feedback
See Validate(String) for more information.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override bool Validate(
    string propertyName
)
Visual Basic (Declaration)
Public Overrides Function Validate ( _
    propertyName As String _
) As Boolean
Visual C++
public:
virtual bool Validate(
    String^ propertyName
) override

Parameters

propertyName
Type: System..::.String

See Also

RedlineNote Class
Validate Overload
Mincom.LinkOne.Dom.Notes Namespace


RedlineNote Properties

[image] [image]

LinkOne WebView API
RedlineNote Properties
RedlineNote Class See Also Send Feedback

The RedlineNote type exposes the following members.

Properties

Name | Description
Access | Gets or sets the note access. (Inherited from Note.)
Association | Gets what the note is associated with. (Inherited from Note.)
BookCode | Gets or sets the book code of the note. (Inherited from Note.)
Category | Gets or sets the note category. (Inherited from CategorizedNote.)
Description | Gets or sets the description of the note. (Inherited from CategorizedNote.)
DisplayName | See DisplayName for more information. (Inherited from CategorizedNote.)
DrawingElements | Gets the drawing elements.
Group | Gets or sets the group identifier of the note. (Inherited from TranslatedNote.)
Id | Gets or sets the unique ID of the note. (Inherited from Note.)
ItemId | Gets or sets the item ID of the note. (Inherited from Note.)
Key | Gets a key that uniquely defines the note. (Inherited from CategorizedNote.)
LanguageCode | Gets or sets the language code. (Inherited from TranslatedNote.)
OriginalNote | Gets or the original note; or null if the note hasn't changed. (Inherited from Note.)
PageReference | Gets or sets the page reference of the note. (Inherited from Note.)
PartNumber | Gets or sets the part number of the note. (Inherited from Note.)
PictureNumber | Gets or sets the picture number of the redline note. (Inherited from Note.)
PublisherCode | Gets or sets the publisher code of the note. (Inherited from Note.)
Scope | Gets the note scope. (Inherited from Note.)
Status | Gets or sets the status of the note in relation to the copy saved in persistent storage. (Inherited from Note.)
TimeStamp | Gets or sets the date and time when the note was last written. (Inherited from Note.)
Translation | See Translation for more information. (Overrides TranslatedNote..::.Translation.)
Xml | Gets the XML representing the note. (Inherited from Note.)

Explicit Interface Implementations

Name | Description
IRedlineNote..::.DrawingElements |

See Also

RedlineNote Class
Mincom.LinkOne.Dom.Notes Namespace


DrawingElements Property

[image]

LinkOne WebView API
RedlineNote..::.DrawingElements Property
RedlineNote Class See Also Send Feedback
Gets the drawing elements.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public DrawingElementCollection DrawingElements { get; set; }
Visual Basic (Declaration)
Public Property DrawingElements As DrawingElementCollection
Visual C++
public:
property DrawingElementCollection^ DrawingElements {
    DrawingElementCollection^ get ();
    void set (DrawingElementCollection^ value);
}

See Also

RedlineNote Class
Mincom.LinkOne.Dom.Notes Namespace


IRedlineNote.DrawingElements Property

[image]

LinkOne WebView API
RedlineNote..::.IRedlineNote..::.DrawingElements Property
RedlineNote Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDrawingElementCollection IRedlineNote.DrawingElements { get; set; }
Visual Basic (Declaration)
Private Property DrawingElements As IDrawingElementCollection
    Implements IRedlineNote.DrawingElements
Visual C++
private:
virtual property IDrawingElementCollection^ DrawingElements {
    IDrawingElementCollection^ get () sealed = IRedlineNote::DrawingElements::get;
    void set (IDrawingElementCollection^ value) sealed = IRedlineNote::DrawingElements::set;
}

Implements

IRedlineNote..::.DrawingElements

See Also

RedlineNote Class
Mincom.LinkOne.Dom.Notes Namespace


Translation Property

[image]

LinkOne WebView API
RedlineNote..::.Translation Property
RedlineNote Class See Also Send Feedback
See Translation for more information.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string Translation { get; set; }
Visual Basic (Declaration)
Public Overrides Property Translation As String
Visual C++
public:
virtual property String^ Translation {
    String^ get () override;
    void set (String^ value) override;
}

Implements

ITranslatedNote..::.Translation
ITranslatedNote..::.Translation

See Also

RedlineNote Class
Mincom.LinkOne.Dom.Notes Namespace


Scope Enumeration

[image]

LinkOne WebView API
Scope Enumeration
See Also Send Feedback
The scope a note covers.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum Scope
Visual Basic (Declaration)
Public Enumeration Scope
Visual C++
public enum class Scope

Members

Member name | Description
Global | The note is globally accessible.
Publisher | The note is associated with a specific publisher.
Book | The note is associated with a specific book.
Page | The note is associated with a specific page.

See Also

Mincom.LinkOne.Dom.Notes Namespace


Status Enumeration

[image]

LinkOne WebView API
Status Enumeration
See Also Send Feedback
The state of a note or category.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum Status
Visual Basic (Declaration)
Public Enumeration Status
Visual C++
public enum class Status

Members

Member name | Description
New | The note or category is new and must be added to persistent storage.
Unchanged | The note or category is unchanged, and is already in persistent storage.
Changed | The note or category has been changed, and must be updated in persistent storage.
Deleted | The note or category is deleted and must be deleted from persistent storage.

Remarks

State is used when persisting a note or category.

See Also

Mincom.LinkOne.Dom.Notes Namespace


TextNote Class

[image]

LinkOne WebView API
TextNote Class
Members See Also Send Feedback
A class which represents a Text note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class TextNote : ListNote,
    ITextNote, IListNote, ICategorizedNote, ITranslatedNote, INote
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class TextNote _
    Inherits ListNote _
    Implements ITextNote, IListNote, ICategorizedNote, ITranslatedNote,  _
    INote
Visual C++
[SerializableAttribute]
public ref class TextNote sealed : public ListNote,
    ITextNote, IListNote, ICategorizedNote, ITranslatedNote, INote

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Notes..::.Note
Mincom.LinkOne.Dom.Notes..::.TranslatedNote
Mincom.LinkOne.Dom.Notes..::.CategorizedNote
Mincom.LinkOne.Dom.Notes..::.ListNote
Mincom.LinkOne.Dom.Notes..::.TextNote

See Also

TextNote Members
Mincom.LinkOne.Dom.Notes Namespace


TextNote Members

[image] [image]

LinkOne WebView API
TextNote Members
TextNote Class Constructors Methods Properties See Also Send Feedback

The TextNote type exposes the following members.

Constructors

Name | Description
TextNote | Creates an instance of the TextNote.

Methods

Name | Description
CanSetAccess | Determines whether this Note instance can set the Access to the specified value. (Inherited from Note.)
CanSetAssociation | Determines whether this Note instance can set Association to the specified value. (Inherited from Note.)
CanSetScope | Determines whether this Note instance can set Scope to the the specified value. (Inherited from Note.)
Clone | Gets a clone of the this. (Inherited from Note.)
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the hash code for the object. (Inherited from Note.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanging | Sets the note status to changed. (Inherited from Note.)
Remove | Sets the note status to Deleted. (Inherited from Note.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Overloaded.

Properties

Name | Description
Access | Gets or sets the note access. (Inherited from Note.)
Annotation | Gets or sets the annotation of the text note.
Association | Gets what the note is associated with. (Inherited from Note.)
Behaviour | Gets or sets the note behaviour. (Inherited from ListNote.)
BookCode | Gets or sets the book code of the note. (Inherited from Note.)
Category | Gets or sets the note category. (Inherited from CategorizedNote.)
Description | Gets or sets the description of the note. (Inherited from CategorizedNote.)
DisplayName | See DisplayName for more information. (Inherited from CategorizedNote.)
Group | Gets or sets the group identifier of the note. (Inherited from TranslatedNote.)
Height | Gets or sets the note dialog height.
HideCaption | Gets or sets whether the note caption should be displayed with the note.
Id | Gets or sets the unique ID of the note. (Inherited from Note.)
IsListNote | Gets or sets whether the note appears in the notes list. (Inherited from ListNote.)
ItemId | Gets or sets the item ID of the note. (Inherited from Note.)
Key | Gets a key that uniquely defines the note. (Inherited from ListNote.)
LanguageCode | Gets or sets the language code. (Inherited from TranslatedNote.)
OriginalNote | Gets or the original note; or null if the note hasn't changed. (Inherited from Note.)
PageReference | Gets or sets the page reference of the note. (Inherited from Note.)
PartNumber | Gets or sets the part number of the note. (Inherited from Note.)
PictureNumber | Gets or sets the picture number of the redline note. (Inherited from Note.)
PublisherCode | Gets or sets the publisher code of the note. (Inherited from Note.)
Scope | Gets the note scope. (Inherited from Note.)
Status | Gets or sets the status of the note in relation to the copy saved in persistent storage. (Inherited from Note.)
TimeStamp | Gets or sets the date and time when the note was last written. (Inherited from Note.)
Translation | See Translation for more information. (Overrides TranslatedNote..::.Translation.)
Width | Gets or sets the note dialog width.
Xml | Gets the XML representing the note. (Inherited from Note.)

See Also

TextNote Class
Mincom.LinkOne.Dom.Notes Namespace


TextNote Constructor

[image]

LinkOne WebView API
TextNote Constructor
TextNote Class See Also Send Feedback
Creates an instance of the TextNote.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public TextNote()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextNote()

See Also

TextNote Class
Mincom.LinkOne.Dom.Notes Namespace


TextNote Methods

[image] [image]

LinkOne WebView API
TextNote Methods
TextNote Class See Also Send Feedback

The TextNote type exposes the following members.

Methods

Name | Description
CanSetAccess | Determines whether this Note instance can set the Access to the specified value. (Inherited from Note.)
CanSetAssociation | Determines whether this Note instance can set Association to the specified value. (Inherited from Note.)
CanSetScope | Determines whether this Note instance can set Scope to the the specified value. (Inherited from Note.)
Clone | Gets a clone of the this. (Inherited from Note.)
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the hash code for the object. (Inherited from Note.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanging | Sets the note status to changed. (Inherited from Note.)
Remove | Sets the note status to Deleted. (Inherited from Note.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Overloaded.

See Also

TextNote Class
Mincom.LinkOne.Dom.Notes Namespace


Equals Method

[image] [image]

LinkOne WebView API
TextNote..::.Equals Method
TextNote Class See Also Send Feedback

Overload List

Name | Description
Equals(Note) | Determines whether the specified note is equal to the current note. (Inherited from Note.)
Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Note.)

See Also

TextNote Class
TextNote Members
Mincom.LinkOne.Dom.Notes Namespace


Validate Method

[image] [image]

LinkOne WebView API
TextNote..::.Validate Method
TextNote Class See Also Send Feedback

Overload List

Name | Description
Validate(String) | See Validate(String) for more information. (Overrides Note..::.Validate(String).)
Validate(Access, String, String, String, String, String, Int32) | Validates the given properties for a note. (Inherited from Note.)

See Also

TextNote Class
TextNote Members
Mincom.LinkOne.Dom.Notes Namespace


Validate Method (String)

[image]

LinkOne WebView API
TextNote..::.Validate Method (String)
TextNote Class See Also Send Feedback
See Validate(String) for more information.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override bool Validate(
    string propertyName
)
Visual Basic (Declaration)
Public Overrides Function Validate ( _
    propertyName As String _
) As Boolean
Visual C++
public:
virtual bool Validate(
    String^ propertyName
) override

Parameters

propertyName
Type: System..::.String

See Also

TextNote Class
Validate Overload
Mincom.LinkOne.Dom.Notes Namespace


TextNote Properties

[image] [image]

LinkOne WebView API
TextNote Properties
TextNote Class See Also Send Feedback

The TextNote type exposes the following members.

Properties

Name | Description
Access | Gets or sets the note access. (Inherited from Note.)
Annotation | Gets or sets the annotation of the text note.
Association | Gets what the note is associated with. (Inherited from Note.)
Behaviour | Gets or sets the note behaviour. (Inherited from ListNote.)
BookCode | Gets or sets the book code of the note. (Inherited from Note.)
Category | Gets or sets the note category. (Inherited from CategorizedNote.)
Description | Gets or sets the description of the note. (Inherited from CategorizedNote.)
DisplayName | See DisplayName for more information. (Inherited from CategorizedNote.)
Group | Gets or sets the group identifier of the note. (Inherited from TranslatedNote.)
Height | Gets or sets the note dialog height.
HideCaption | Gets or sets whether the note caption should be displayed with the note.
Id | Gets or sets the unique ID of the note. (Inherited from Note.)
IsListNote | Gets or sets whether the note appears in the notes list. (Inherited from ListNote.)
ItemId | Gets or sets the item ID of the note. (Inherited from Note.)
Key | Gets a key that uniquely defines the note. (Inherited from ListNote.)
LanguageCode | Gets or sets the language code. (Inherited from TranslatedNote.)
OriginalNote | Gets or the original note; or null if the note hasn't changed. (Inherited from Note.)
PageReference | Gets or sets the page reference of the note. (Inherited from Note.)
PartNumber | Gets or sets the part number of the note. (Inherited from Note.)
PictureNumber | Gets or sets the picture number of the redline note. (Inherited from Note.)
PublisherCode | Gets or sets the publisher code of the note. (Inherited from Note.)
Scope | Gets the note scope. (Inherited from Note.)
Status | Gets or sets the status of the note in relation to the copy saved in persistent storage. (Inherited from Note.)
TimeStamp | Gets or sets the date and time when the note was last written. (Inherited from Note.)
Translation | See Translation for more information. (Overrides TranslatedNote..::.Translation.)
Width | Gets or sets the note dialog width.
Xml | Gets the XML representing the note. (Inherited from Note.)

See Also

TextNote Class
Mincom.LinkOne.Dom.Notes Namespace


Annotation Property

[image]

LinkOne WebView API
TextNote..::.Annotation Property
TextNote Class See Also Send Feedback
Gets or sets the annotation of the text note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Annotation { get; set; }
Visual Basic (Declaration)
Public Property Annotation As String
Visual C++
public:
virtual property String^ Annotation {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Field Value

The annotation for the text note.

Implements

ITextNote..::.Annotation

See Also

TextNote Class
Mincom.LinkOne.Dom.Notes Namespace


Height Property

[image]

LinkOne WebView API
TextNote..::.Height Property
TextNote Class See Also Send Feedback
Gets or sets the note dialog height.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Integer
Visual C++
public:
virtual property int Height {
    int get () sealed;
    void set (int value) sealed;
}

Implements

ITextNote..::.Height

See Also

TextNote Class
Mincom.LinkOne.Dom.Notes Namespace


HideCaption Property

[image]

LinkOne WebView API
TextNote..::.HideCaption Property
TextNote Class See Also Send Feedback
Gets or sets whether the note caption should be displayed with the note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool HideCaption { get; set; }
Visual Basic (Declaration)
Public Property HideCaption As Boolean
Visual C++
public:
virtual property bool HideCaption {
    bool get () sealed;
    void set (bool value) sealed;
}

Field Value

True to indicate that the note caption should not be displayed with the note; False to show the caption.

Implements

ITextNote..::.HideCaption

See Also

TextNote Class
Mincom.LinkOne.Dom.Notes Namespace


Translation Property

[image]

LinkOne WebView API
TextNote..::.Translation Property
TextNote Class See Also Send Feedback
See Translation for more information.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string Translation { get; set; }
Visual Basic (Declaration)
Public Overrides Property Translation As String
Visual C++
public:
virtual property String^ Translation {
    String^ get () override;
    void set (String^ value) override;
}

Implements

ITranslatedNote..::.Translation
ITranslatedNote..::.Translation

See Also

TextNote Class
Mincom.LinkOne.Dom.Notes Namespace


Width Property

[image]

LinkOne WebView API
TextNote..::.Width Property
TextNote Class See Also Send Feedback
Gets or sets the note dialog width.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Integer
Visual C++
public:
virtual property int Width {
    int get () sealed;
    void set (int value) sealed;
}

Implements

ITextNote..::.Width

See Also

TextNote Class
Mincom.LinkOne.Dom.Notes Namespace


TranslatedNote Class

[image]

LinkOne WebView API
TranslatedNote Class
Members See Also Send Feedback
The base class for a translated LinkOne note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public abstract class TranslatedNote : Note,
    ITranslatedNote, INote
Visual Basic (Declaration)
<SerializableAttribute> _
Public MustInherit Class TranslatedNote _
    Inherits Note _
    Implements ITranslatedNote, INote
Visual C++
[SerializableAttribute]
public ref class TranslatedNote abstract : public Note,
    ITranslatedNote, INote

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Notes..::.Note
Mincom.LinkOne.Dom.Notes..::.TranslatedNote
Mincom.LinkOne.Dom.Notes..::.Bookmark
Mincom.LinkOne.Dom.Notes..::.CategorizedNote
Mincom.LinkOne.Dom.Notes..::.FieldMapping

See Also

TranslatedNote Members
Mincom.LinkOne.Dom.Notes Namespace


TranslatedNote Members

[image] [image]

LinkOne WebView API
TranslatedNote Members
TranslatedNote Class Constructors Methods Properties See Also Send Feedback

The TranslatedNote type exposes the following members.

Constructors

Name | Description
TranslatedNote | Creates an instance of the TranslatedNote.

Methods

Name | Description
CanSetAccess | Determines whether this Note instance can set the Access to the specified value. (Inherited from Note.)
CanSetAssociation | Determines whether this Note instance can set Association to the specified value. (Inherited from Note.)
CanSetScope | Determines whether this Note instance can set Scope to the the specified value. (Inherited from Note.)
Clone | Gets a clone of the this. (Inherited from Note.)
CreateGroupIdentifier | Gets a unique group identifier.
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the hash code for the object. (Inherited from Note.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanging | Sets the note status to changed. (Inherited from Note.)
Remove | Sets the note status to Deleted. (Inherited from Note.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Overloaded.

Properties

Name | Description
Access | Gets or sets the note access. (Inherited from Note.)
Association | Gets what the note is associated with. (Inherited from Note.)
BookCode | Gets or sets the book code of the note. (Inherited from Note.)
DisplayName | Gets the display name of the note. (Inherited from Note.)
Group | Gets or sets the group identifier of the note.
Id | Gets or sets the unique ID of the note. (Inherited from Note.)
ItemId | Gets or sets the item ID of the note. (Inherited from Note.)
Key | Gets a key that uniquely defines the note. (Overrides Note..::.Key.)
LanguageCode | Gets or sets the language code.
OriginalNote | Gets or the original note; or null if the note hasn't changed. (Inherited from Note.)
PageReference | Gets or sets the page reference of the note. (Inherited from Note.)
PartNumber | Gets or sets the part number of the note. (Inherited from Note.)
PictureNumber | Gets or sets the picture number of the redline note. (Inherited from Note.)
PublisherCode | Gets or sets the publisher code of the note. (Inherited from Note.)
Scope | Gets the note scope. (Inherited from Note.)
Status | Gets or sets the status of the note in relation to the copy saved in persistent storage. (Inherited from Note.)
TimeStamp | Gets or sets the date and time when the note was last written. (Inherited from Note.)
Translation | Gets or sets the translation of the note.
Xml | Gets the XML representing the note. (Inherited from Note.)

See Also

TranslatedNote Class
Mincom.LinkOne.Dom.Notes Namespace


TranslatedNote Constructor

[image]

LinkOne WebView API
TranslatedNote Constructor
TranslatedNote Class See Also Send Feedback
Creates an instance of the TranslatedNote.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected TranslatedNote()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
TranslatedNote()

See Also

TranslatedNote Class
Mincom.LinkOne.Dom.Notes Namespace


TranslatedNote Methods

[image] [image]

LinkOne WebView API
TranslatedNote Methods
TranslatedNote Class See Also Send Feedback

The TranslatedNote type exposes the following members.

Methods

Name | Description
CanSetAccess | Determines whether this Note instance can set the Access to the specified value. (Inherited from Note.)
CanSetAssociation | Determines whether this Note instance can set Association to the specified value. (Inherited from Note.)
CanSetScope | Determines whether this Note instance can set Scope to the the specified value. (Inherited from Note.)
Clone | Gets a clone of the this. (Inherited from Note.)
CreateGroupIdentifier | Gets a unique group identifier.
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the hash code for the object. (Inherited from Note.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanging | Sets the note status to changed. (Inherited from Note.)
Remove | Sets the note status to Deleted. (Inherited from Note.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Overloaded.

See Also

TranslatedNote Class
Mincom.LinkOne.Dom.Notes Namespace


CreateGroupIdentifier Method

[image]

LinkOne WebView API
TranslatedNote..::.CreateGroupIdentifier Method
TranslatedNote Class See Also Send Feedback
Gets a unique group identifier.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static string CreateGroupIdentifier()
Visual Basic (Declaration)
Public Shared Function CreateGroupIdentifier As String
Visual C++
public:
static String^ CreateGroupIdentifier()

See Also

TranslatedNote Class
Mincom.LinkOne.Dom.Notes Namespace


Equals Method

[image] [image]

LinkOne WebView API
TranslatedNote..::.Equals Method
TranslatedNote Class See Also Send Feedback

Overload List

Name | Description
Equals(Note) | Determines whether the specified note is equal to the current note. (Inherited from Note.)
Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Note.)

See Also

TranslatedNote Class
TranslatedNote Members
Mincom.LinkOne.Dom.Notes Namespace


Validate Method

[image] [image]

LinkOne WebView API
TranslatedNote..::.Validate Method
TranslatedNote Class See Also Send Feedback

Overload List

Name | Description
Validate(String) | Gets the validity of the given named property. (Inherited from Note.)
Validate(Access, String, String, String, String, String, Int32) | Validates the given properties for a note. (Inherited from Note.)

See Also

TranslatedNote Class
TranslatedNote Members
Mincom.LinkOne.Dom.Notes Namespace


TranslatedNote Properties

[image] [image]

LinkOne WebView API
TranslatedNote Properties
TranslatedNote Class See Also Send Feedback

The TranslatedNote type exposes the following members.

Properties

Name | Description
Access | Gets or sets the note access. (Inherited from Note.)
Association | Gets what the note is associated with. (Inherited from Note.)
BookCode | Gets or sets the book code of the note. (Inherited from Note.)
DisplayName | Gets the display name of the note. (Inherited from Note.)
Group | Gets or sets the group identifier of the note.
Id | Gets or sets the unique ID of the note. (Inherited from Note.)
ItemId | Gets or sets the item ID of the note. (Inherited from Note.)
Key | Gets a key that uniquely defines the note. (Overrides Note..::.Key.)
LanguageCode | Gets or sets the language code.
OriginalNote | Gets or the original note; or null if the note hasn't changed. (Inherited from Note.)
PageReference | Gets or sets the page reference of the note. (Inherited from Note.)
PartNumber | Gets or sets the part number of the note. (Inherited from Note.)
PictureNumber | Gets or sets the picture number of the redline note. (Inherited from Note.)
PublisherCode | Gets or sets the publisher code of the note. (Inherited from Note.)
Scope | Gets the note scope. (Inherited from Note.)
Status | Gets or sets the status of the note in relation to the copy saved in persistent storage. (Inherited from Note.)
TimeStamp | Gets or sets the date and time when the note was last written. (Inherited from Note.)
Translation | Gets or sets the translation of the note.
Xml | Gets the XML representing the note. (Inherited from Note.)

See Also

TranslatedNote Class
Mincom.LinkOne.Dom.Notes Namespace


Group Property

[image]

LinkOne WebView API
TranslatedNote..::.Group Property
TranslatedNote Class See Also Send Feedback
Gets or sets the group identifier of the note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Group { get; set; }
Visual Basic (Declaration)
Public Property Group As String
Visual C++
public:
virtual property String^ Group {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ITranslatedNote..::.Group

Remarks

See Also

TranslatedNote Class
Mincom.LinkOne.Dom.Notes Namespace


Key Property

[image]

LinkOne WebView API
TranslatedNote..::.Key Property
TranslatedNote Class See Also Send Feedback
Gets a key that uniquely defines the note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected override string Key { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property Key As String
Visual C++
protected:
virtual property String^ Key {
    String^ get () override;
}

See Also

TranslatedNote Class
Mincom.LinkOne.Dom.Notes Namespace


LanguageCode Property

[image]

LinkOne WebView API
TranslatedNote..::.LanguageCode Property
TranslatedNote Class See Also Send Feedback
Gets or sets the language code.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string LanguageCode { get; set; }
Visual Basic (Declaration)
Public Property LanguageCode As String
Visual C++
public:
virtual property String^ LanguageCode {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ITranslatedNote..::.LanguageCode

Remarks

This is an ISO-639 language code.

See Also

TranslatedNote Class
Mincom.LinkOne.Dom.Notes Namespace


Translation Property

[image]

LinkOne WebView API
TranslatedNote..::.Translation Property
TranslatedNote Class See Also Send Feedback
Gets or sets the translation of the note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public abstract string Translation { get; set; }
Visual Basic (Declaration)
Public MustOverride Property Translation As String
Visual C++
public:
virtual property String^ Translation {
    String^ get () abstract;
    void set (String^ value) abstract;
}

Implements

ITranslatedNote..::.Translation

See Also

TranslatedNote Class
Mincom.LinkOne.Dom.Notes Namespace


UnknownNote Class

[image]

LinkOne WebView API
UnknownNote Class
Members See Also Send Feedback
A class which represents a Unknown note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class UnknownNote : Note,
    INote
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class UnknownNote _
    Inherits Note _
    Implements INote
Visual C++
[SerializableAttribute]
public ref class UnknownNote sealed : public Note,
    INote

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Notes..::.Note
Mincom.LinkOne.Dom.Notes..::.UnknownNote

See Also

UnknownNote Members
Mincom.LinkOne.Dom.Notes Namespace


UnknownNote Members

[image] [image]

LinkOne WebView API
UnknownNote Members
UnknownNote Class Constructors Methods Properties See Also Send Feedback

The UnknownNote type exposes the following members.

Constructors

Name | Description
UnknownNote | Creates an instance of the UnknownNote.

Methods

Name | Description
CanSetAccess | Determines whether this Note instance can set the Access to the specified value. (Inherited from Note.)
CanSetAssociation | Determines whether this Note instance can set Association to the specified value. (Inherited from Note.)
CanSetScope | Determines whether this Note instance can set Scope to the the specified value. (Inherited from Note.)
Clone | Gets a clone of the this. (Inherited from Note.)
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the hash code for the object. (Inherited from Note.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanging | Sets the note status to changed. (Inherited from Note.)
Remove | Sets the note status to Deleted. (Inherited from Note.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Overloaded.

Properties

Name | Description
Access | Gets or sets the note access. (Inherited from Note.)
Association | Gets what the note is associated with. (Inherited from Note.)
BookCode | Gets or sets the book code of the note. (Inherited from Note.)
DataRecords | Gets the collection of data records of the unknown string.
DisplayName | See DisplayName for more information. (Overrides Note..::.DisplayName.)
HeaderRecord | Gets or sets the header record string of the unknown note.
Id | Gets or sets the unique ID of the note. (Inherited from Note.)
ItemId | Gets or sets the item ID of the note. (Inherited from Note.)
Key | Gets a key that uniquely defines the note. (Inherited from Note.)
OriginalNote | Gets or the original note; or null if the note hasn't changed. (Inherited from Note.)
PageReference | Gets or sets the page reference of the note. (Inherited from Note.)
PartNumber | Gets or sets the part number of the note. (Inherited from Note.)
PictureNumber | Gets or sets the picture number of the redline note. (Inherited from Note.)
PublisherCode | Gets or sets the publisher code of the note. (Inherited from Note.)
Scope | Gets the note scope. (Inherited from Note.)
Status | Gets or sets the status of the note in relation to the copy saved in persistent storage. (Inherited from Note.)
SupplementaryRecord | Gets or sets the supplementary record string of the unknown note.
TimeStamp | Gets or sets the date and time when the note was last written. (Inherited from Note.)
Xml | Gets the XML representing the note. (Inherited from Note.)

See Also

UnknownNote Class
Mincom.LinkOne.Dom.Notes Namespace


UnknownNote Constructor

[image]

LinkOne WebView API
UnknownNote Constructor
UnknownNote Class See Also Send Feedback
Creates an instance of the UnknownNote.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public UnknownNote()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UnknownNote()

See Also

UnknownNote Class
Mincom.LinkOne.Dom.Notes Namespace


UnknownNote Methods

[image] [image]

LinkOne WebView API
UnknownNote Methods
UnknownNote Class See Also Send Feedback

The UnknownNote type exposes the following members.

Methods

Name | Description
CanSetAccess | Determines whether this Note instance can set the Access to the specified value. (Inherited from Note.)
CanSetAssociation | Determines whether this Note instance can set Association to the specified value. (Inherited from Note.)
CanSetScope | Determines whether this Note instance can set Scope to the the specified value. (Inherited from Note.)
Clone | Gets a clone of the this. (Inherited from Note.)
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the hash code for the object. (Inherited from Note.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanging | Sets the note status to changed. (Inherited from Note.)
Remove | Sets the note status to Deleted. (Inherited from Note.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Overloaded.

See Also

UnknownNote Class
Mincom.LinkOne.Dom.Notes Namespace


Equals Method

[image] [image]

LinkOne WebView API
UnknownNote..::.Equals Method
UnknownNote Class See Also Send Feedback

Overload List

Name | Description
Equals(Note) | Determines whether the specified note is equal to the current note. (Inherited from Note.)
Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Note.)

See Also

UnknownNote Class
UnknownNote Members
Mincom.LinkOne.Dom.Notes Namespace


Validate Method

[image] [image]

LinkOne WebView API
UnknownNote..::.Validate Method
UnknownNote Class See Also Send Feedback

Overload List

Name | Description
Validate(String) | Gets the validity of the given named property. (Inherited from Note.)
Validate(Access, String, String, String, String, String, Int32) | Validates the given properties for a note. (Inherited from Note.)

See Also

UnknownNote Class
UnknownNote Members
Mincom.LinkOne.Dom.Notes Namespace


UnknownNote Properties

[image] [image]

LinkOne WebView API
UnknownNote Properties
UnknownNote Class See Also Send Feedback

The UnknownNote type exposes the following members.

Properties

Name | Description
Access | Gets or sets the note access. (Inherited from Note.)
Association | Gets what the note is associated with. (Inherited from Note.)
BookCode | Gets or sets the book code of the note. (Inherited from Note.)
DataRecords | Gets the collection of data records of the unknown string.
DisplayName | See DisplayName for more information. (Overrides Note..::.DisplayName.)
HeaderRecord | Gets or sets the header record string of the unknown note.
Id | Gets or sets the unique ID of the note. (Inherited from Note.)
ItemId | Gets or sets the item ID of the note. (Inherited from Note.)
Key | Gets a key that uniquely defines the note. (Inherited from Note.)
OriginalNote | Gets or the original note; or null if the note hasn't changed. (Inherited from Note.)
PageReference | Gets or sets the page reference of the note. (Inherited from Note.)
PartNumber | Gets or sets the part number of the note. (Inherited from Note.)
PictureNumber | Gets or sets the picture number of the redline note. (Inherited from Note.)
PublisherCode | Gets or sets the publisher code of the note. (Inherited from Note.)
Scope | Gets the note scope. (Inherited from Note.)
Status | Gets or sets the status of the note in relation to the copy saved in persistent storage. (Inherited from Note.)
SupplementaryRecord | Gets or sets the supplementary record string of the unknown note.
TimeStamp | Gets or sets the date and time when the note was last written. (Inherited from Note.)
Xml | Gets the XML representing the note. (Inherited from Note.)

See Also

UnknownNote Class
Mincom.LinkOne.Dom.Notes Namespace


DataRecords Property

[image]

LinkOne WebView API
UnknownNote..::.DataRecords Property
UnknownNote Class See Also Send Feedback
Gets the collection of data records of the unknown string.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IList<string> DataRecords { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataRecords As IList(Of String)
Visual C++
public:
property IList<String^>^ DataRecords {
    IList<String^>^ get ();
}

Remarks

If any changes are made to the data records in an Unknown note, then it will be necessary to also set the status to changed for a unchanged note. Failure to do so will mean that the note may not be saved.

See Also

UnknownNote Class
Mincom.LinkOne.Dom.Notes Namespace


DisplayName Property

[image]

LinkOne WebView API
UnknownNote..::.DisplayName Property
UnknownNote Class See Also Send Feedback
See DisplayName for more information.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string DisplayName { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DisplayName As String
Visual C++
public:
virtual property String^ DisplayName {
    String^ get () override;
}

See Also

UnknownNote Class
Mincom.LinkOne.Dom.Notes Namespace


HeaderRecord Property

[image]

LinkOne WebView API
UnknownNote..::.HeaderRecord Property
UnknownNote Class See Also Send Feedback
Gets or sets the header record string of the unknown note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string HeaderRecord { get; set; }
Visual Basic (Declaration)
Public Property HeaderRecord As String
Visual C++
public:
property String^ HeaderRecord {
    String^ get ();
    void set (String^ value);
}

Field Value

The header record string.

See Also

UnknownNote Class
Mincom.LinkOne.Dom.Notes Namespace


SupplementaryRecord Property

[image]

LinkOne WebView API
UnknownNote..::.SupplementaryRecord Property
UnknownNote Class See Also Send Feedback
Gets or sets the supplementary record string of the unknown note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string SupplementaryRecord { get; set; }
Visual Basic (Declaration)
Public Property SupplementaryRecord As String
Visual C++
public:
property String^ SupplementaryRecord {
    String^ get ();
    void set (String^ value);
}

Field Value

The supplementary record string.

See Also

UnknownNote Class
Mincom.LinkOne.Dom.Notes Namespace


ValueNote Class

[image]

LinkOne WebView API
ValueNote Class
Members See Also Send Feedback
A class which represents a Value note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class ValueNote : Note,
    IValueNote, INote
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class ValueNote _
    Inherits Note _
    Implements IValueNote, INote
Visual C++
[SerializableAttribute]
public ref class ValueNote sealed : public Note,
    IValueNote, INote

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Notes..::.Note
Mincom.LinkOne.Dom.Notes..::.ValueNote

See Also

ValueNote Members
Mincom.LinkOne.Dom.Notes Namespace


ValueNote Members

[image] [image]

LinkOne WebView API
ValueNote Members
ValueNote Class Constructors Methods Fields Properties See Also Send Feedback

The ValueNote type exposes the following members.

Constructors

Name | Description
ValueNote | Creates an instance of the ValueNote.

Methods

Name | Description
CanSetAccess | Determines whether this Note instance can set the Access to the specified value. (Inherited from Note.)
CanSetAssociation | Determines whether this Note instance can set Association to the specified value. (Inherited from Note.)
CanSetScope | Determines whether this Note instance can set Scope to the the specified value. (Inherited from Note.)
Clone | Gets a clone of the this. (Inherited from Note.)
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the hash code for the object. (Inherited from Note.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanging | Sets the note status to changed. (Inherited from Note.)
Remove | Sets the note status to Deleted. (Inherited from Note.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Overloaded.

Fields

Name | Description
PrintLayout | The name for print layout value notes.
ScreenLayout | The name for screen layout value notes.
SearchSet | The name for search set value notes.

Properties

Name | Description
Access | Gets or sets the note access. (Inherited from Note.)
Association | Gets what the note is associated with. (Inherited from Note.)
BookCode | Gets or sets the book code of the note. (Inherited from Note.)
DisplayName | See DisplayName for more information. (Overrides Note..::.DisplayName.)
Id | Gets or sets the unique ID of the note. (Inherited from Note.)
IsPredefinedValue | Gets a value indicating whether this instance is predefined value.
ItemId | Gets or sets the item ID of the note. (Inherited from Note.)
Key | Gets a key that uniquely defines the note. (Inherited from Note.)
Name | Gets or sets the name of the value note.
OriginalNote | Gets or the original note; or null if the note hasn't changed. (Inherited from Note.)
PageReference | Gets or sets the page reference of the note. (Inherited from Note.)
PartNumber | Gets or sets the part number of the note. (Inherited from Note.)
PictureNumber | Gets or sets the picture number of the redline note. (Inherited from Note.)
PublisherCode | Gets or sets the publisher code of the note. (Inherited from Note.)
Scope | Gets the note scope. (Inherited from Note.)
Status | Gets or sets the status of the note in relation to the copy saved in persistent storage. (Inherited from Note.)
TimeStamp | Gets or sets the date and time when the note was last written. (Inherited from Note.)
Value | Gets or sets the value of the value note.
Xml | Gets the XML representing the note. (Inherited from Note.)

See Also

ValueNote Class
Mincom.LinkOne.Dom.Notes Namespace


ValueNote Constructor

[image]

LinkOne WebView API
ValueNote Constructor
ValueNote Class See Also Send Feedback
Creates an instance of the ValueNote.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ValueNote()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ValueNote()

See Also

ValueNote Class
Mincom.LinkOne.Dom.Notes Namespace


ValueNote Fields

[image] [image]

LinkOne WebView API
ValueNote Fields
ValueNote Class See Also Send Feedback

The ValueNote type exposes the following members.

Fields

Name | Description
PrintLayout | The name for print layout value notes.
ScreenLayout | The name for screen layout value notes.
SearchSet | The name for search set value notes.

See Also

ValueNote Class
Mincom.LinkOne.Dom.Notes Namespace


PrintLayout Field

[image]

LinkOne WebView API
ValueNote..::.PrintLayout Field
ValueNote Class See Also Send Feedback
The name for print layout value notes.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string PrintLayout
Visual Basic (Declaration)
Public Const PrintLayout As String
Visual C++
public:
literal String^ PrintLayout

See Also

ValueNote Class
Mincom.LinkOne.Dom.Notes Namespace


ScreenLayout Field

[image]

LinkOne WebView API
ValueNote..::.ScreenLayout Field
ValueNote Class See Also Send Feedback
The name for screen layout value notes.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string ScreenLayout
Visual Basic (Declaration)
Public Const ScreenLayout As String
Visual C++
public:
literal String^ ScreenLayout

See Also

ValueNote Class
Mincom.LinkOne.Dom.Notes Namespace


SearchSet Field

[image]

LinkOne WebView API
ValueNote..::.SearchSet Field
ValueNote Class See Also Send Feedback
The name for search set value notes.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const string SearchSet
Visual Basic (Declaration)
Public Const SearchSet As String
Visual C++
public:
literal String^ SearchSet

See Also

ValueNote Class
Mincom.LinkOne.Dom.Notes Namespace


ValueNote Methods

[image] [image]

LinkOne WebView API
ValueNote Methods
ValueNote Class See Also Send Feedback

The ValueNote type exposes the following members.

Methods

Name | Description
CanSetAccess | Determines whether this Note instance can set the Access to the specified value. (Inherited from Note.)
CanSetAssociation | Determines whether this Note instance can set Association to the specified value. (Inherited from Note.)
CanSetScope | Determines whether this Note instance can set Scope to the the specified value. (Inherited from Note.)
Clone | Gets a clone of the this. (Inherited from Note.)
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets the hash code for the object. (Inherited from Note.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanging | Sets the note status to changed. (Inherited from Note.)
Remove | Sets the note status to Deleted. (Inherited from Note.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
Validate | Overloaded.

See Also

ValueNote Class
Mincom.LinkOne.Dom.Notes Namespace


Equals Method

[image] [image]

LinkOne WebView API
ValueNote..::.Equals Method
ValueNote Class See Also Send Feedback

Overload List

Name | Description
Equals(Note) | Determines whether the specified note is equal to the current note. (Inherited from Note.)
Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Note.)

See Also

ValueNote Class
ValueNote Members
Mincom.LinkOne.Dom.Notes Namespace


Validate Method

[image] [image]

LinkOne WebView API
ValueNote..::.Validate Method
ValueNote Class See Also Send Feedback

Overload List

Name | Description
Validate(String) | See Validate(String) for more information. (Overrides Note..::.Validate(String).)
Validate(Access, String, String, String, String, String, Int32) | Validates the given properties for a note. (Inherited from Note.)

See Also

ValueNote Class
ValueNote Members
Mincom.LinkOne.Dom.Notes Namespace


Validate Method (String)

[image]

LinkOne WebView API
ValueNote..::.Validate Method (String)
ValueNote Class See Also Send Feedback
See Validate(String) for more information.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override bool Validate(
    string propertyName
)
Visual Basic (Declaration)
Public Overrides Function Validate ( _
    propertyName As String _
) As Boolean
Visual C++
public:
virtual bool Validate(
    String^ propertyName
) override

Parameters

propertyName
Type: System..::.String

See Also

ValueNote Class
Validate Overload
Mincom.LinkOne.Dom.Notes Namespace


ValueNote Properties

[image] [image]

LinkOne WebView API
ValueNote Properties
ValueNote Class See Also Send Feedback

The ValueNote type exposes the following members.

Properties

Name | Description
Access | Gets or sets the note access. (Inherited from Note.)
Association | Gets what the note is associated with. (Inherited from Note.)
BookCode | Gets or sets the book code of the note. (Inherited from Note.)
DisplayName | See DisplayName for more information. (Overrides Note..::.DisplayName.)
Id | Gets or sets the unique ID of the note. (Inherited from Note.)
IsPredefinedValue | Gets a value indicating whether this instance is predefined value.
ItemId | Gets or sets the item ID of the note. (Inherited from Note.)
Key | Gets a key that uniquely defines the note. (Inherited from Note.)
Name | Gets or sets the name of the value note.
OriginalNote | Gets or the original note; or null if the note hasn't changed. (Inherited from Note.)
PageReference | Gets or sets the page reference of the note. (Inherited from Note.)
PartNumber | Gets or sets the part number of the note. (Inherited from Note.)
PictureNumber | Gets or sets the picture number of the redline note. (Inherited from Note.)
PublisherCode | Gets or sets the publisher code of the note. (Inherited from Note.)
Scope | Gets the note scope. (Inherited from Note.)
Status | Gets or sets the status of the note in relation to the copy saved in persistent storage. (Inherited from Note.)
TimeStamp | Gets or sets the date and time when the note was last written. (Inherited from Note.)
Value | Gets or sets the value of the value note.
Xml | Gets the XML representing the note. (Inherited from Note.)

See Also

ValueNote Class
Mincom.LinkOne.Dom.Notes Namespace


DisplayName Property

[image]

LinkOne WebView API
ValueNote..::.DisplayName Property
ValueNote Class See Also Send Feedback
See DisplayName for more information.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string DisplayName { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DisplayName As String
Visual C++
public:
virtual property String^ DisplayName {
    String^ get () override;
}

See Also

ValueNote Class
Mincom.LinkOne.Dom.Notes Namespace


IsPredefinedValue Property

[image]

LinkOne WebView API
ValueNote..::.IsPredefinedValue Property
ValueNote Class See Also Send Feedback
Gets a value indicating whether this instance is predefined value.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsPredefinedValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPredefinedValue As Boolean
Visual C++
public:
property bool IsPredefinedValue {
    bool get ();
}

See Also

ValueNote Class
Mincom.LinkOne.Dom.Notes Namespace


Name Property

[image]

LinkOne WebView API
ValueNote..::.Name Property
ValueNote Class See Also Send Feedback
Gets or sets the name of the value note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Field Value

The name for the value note.

Implements

IValueNote..::.Name

See Also

ValueNote Class
Mincom.LinkOne.Dom.Notes Namespace


Value Property

[image]

LinkOne WebView API
ValueNote..::.Value Property
ValueNote Class See Also Send Feedback
Gets or sets the value of the value note.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String
Visual C++
public:
virtual property String^ Value {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Field Value

The value for the value note.

Implements

IValueNote..::.Value

See Also

ValueNote Class
Mincom.LinkOne.Dom.Notes Namespace


WriteState(T) Class

[image]

LinkOne WebView API
WriteState<(Of <(T>)>) Class
Members See Also Send Feedback
Caches the current write state information for the generic type.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public abstract class WriteState<T>
Visual Basic (Declaration)
Public MustInherit Class WriteState(Of T)
Visual C++
generic<typename T>
public ref class WriteState abstract

Type Parameters

T
The NoteCollection or CategoryCollection.

Remarks

This allows the state of the generic type to be modified, merged and restored during the overall write state determiniation.

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Notes..::.WriteState<(Of <(T>)>)
Mincom.LinkOne.Dom.Notes..::.CategoryCollection..::.CategoryCollectionWriteState
Mincom.LinkOne.Dom.Notes..::.NoteCollection..::.NoteCollectionWriteState

See Also

WriteState<(Of <(T>)>) Members
Mincom.LinkOne.Dom.Notes Namespace


WriteState(T) Members

[image] [image]

LinkOne WebView API
WriteState<(Of <(T>)>) Members
WriteState<(Of <(T>)>) Class Constructors Methods See Also Send Feedback

The WriteState<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
WriteState<(Of <(T>)>) | Initializes a new instance of the WriteState<(Of <(T>)>) class

Methods

Name | Description
ApplyState | Applies the cached state within this object to to. This overwrites the state stored in applyTo.
CacheState | Caches the write state of from into this instance.
Clear | Clears the write state information back to a valid initial state.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Merge | Merges the write state information in mergeFrom with that stored in this instance. This instance is modified.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

WriteState<(Of <(T>)>) Class
Mincom.LinkOne.Dom.Notes Namespace


WriteState(T) Constructor

[image]

LinkOne WebView API
WriteState<(Of <(T>)>) Constructor
WriteState<(Of <(T>)>) Class See Also Send Feedback
Initializes a new instance of the WriteState<(Of <(T>)>) class

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected WriteState()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
WriteState()

See Also

WriteState<(Of <(T>)>) Class
Mincom.LinkOne.Dom.Notes Namespace


WriteState(T) Methods

[image] [image]

LinkOne WebView API
WriteState<(Of <(T>)>) Methods
WriteState<(Of <(T>)>) Class See Also Send Feedback

The WriteState<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
ApplyState | Applies the cached state within this object to to. This overwrites the state stored in applyTo.
CacheState | Caches the write state of from into this instance.
Clear | Clears the write state information back to a valid initial state.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Merge | Merges the write state information in mergeFrom with that stored in this instance. This instance is modified.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

WriteState<(Of <(T>)>) Class
Mincom.LinkOne.Dom.Notes Namespace


ApplyState Method

[image]

LinkOne WebView API
WriteState<(Of <(T>)>)..::.ApplyState Method
WriteState<(Of <(T>)>) Class See Also Send Feedback
Applies the cached state within this object to to. This overwrites the state stored in applyTo.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public abstract void ApplyState(
    T applyTo
)
Visual Basic (Declaration)
Public MustOverride Sub ApplyState ( _
    applyTo As T _
)
Visual C++
public:
virtual void ApplyState(
    T applyTo
) abstract

Parameters

applyTo
Type: T
The object to modify the write state for.

See Also

WriteState<(Of <(T>)>) Class
Mincom.LinkOne.Dom.Notes Namespace


CacheState Method

[image]

LinkOne WebView API
WriteState<(Of <(T>)>)..::.CacheState Method
WriteState<(Of <(T>)>) Class See Also Send Feedback
Caches the write state of from into this instance.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public abstract void CacheState(
    T from
)
Visual Basic (Declaration)
Public MustOverride Sub CacheState ( _
    from As T _
)
Visual C++
public:
virtual void CacheState(
    T from
) abstract

Parameters

from
Type: T
Object to cache state for.

See Also

WriteState<(Of <(T>)>) Class
Mincom.LinkOne.Dom.Notes Namespace


Clear Method

[image]

LinkOne WebView API
WriteState<(Of <(T>)>)..::.Clear Method
WriteState<(Of <(T>)>) Class See Also Send Feedback
Clears the write state information back to a valid initial state.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public abstract void Clear()
Visual Basic (Declaration)
Public MustOverride Sub Clear
Visual C++
public:
virtual void Clear() abstract

See Also

WriteState<(Of <(T>)>) Class
Mincom.LinkOne.Dom.Notes Namespace


Merge Method

[image]

LinkOne WebView API
WriteState<(Of <(T>)>)..::.Merge Method
WriteState<(Of <(T>)>) Class See Also Send Feedback
Merges the write state information in mergeFrom with that stored in this instance. This instance is modified.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public abstract void Merge(
    T mergeFrom
)
Visual Basic (Declaration)
Public MustOverride Sub Merge ( _
    mergeFrom As T _
)
Visual C++
public:
virtual void Merge(
    T mergeFrom
) abstract

Parameters

mergeFrom
Type: T
Object to merge write state from.

See Also

WriteState<(Of <(T>)>) Class
Mincom.LinkOne.Dom.Notes Namespace


WriteStateEvaluator(T) Class

[image]

LinkOne WebView API
WriteStateEvaluator<(Of <(T>)>) Class
Members See Also Send Feedback
This class is the base class for delayed write determination. See remarks for more details.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public abstract class WriteStateEvaluator<T>
Visual Basic (Declaration)
<SerializableAttribute> _
Public MustInherit Class WriteStateEvaluator(Of T)
Visual C++
[SerializableAttribute]
generic<typename T>
public ref class WriteStateEvaluator abstract

Type Parameters

T
The NoteCollection or CategoryCollection.

Remarks

This class aims to facilitate delaying the calculation of notes creation and editing permissions, and by extension permissions for note category modification.

CategoryCollection and NoteCollection both have a method used to set the write permissions for the current user (SetCanWrite(Access, Boolean) and or SetCanCreate(Access, Scope, String, Boolean) respectively). This method is used to determine whether a user has permissions to create and edit notes and note cateogries. This permission determinition involes file IO to confirm that the user has on disk permissions to write. This deternimation can consume a fair degree of file IO to ensure on disk permissions.

Previously this work was all done at creation time of the notes collection and resulted in a lot of repeated IO to make the same determiniations. This IO can be very slow when dealing with network paths, particularly UNC paths. Network file IO requires additional authorisation packets and is susseptible to network load. 50ms was a reasonable figure in this configuration, but 100+ms can easily be optained on some networks. This is particularly troublesome as the paths being tested are often the same.

In WebView, this problem is excacerbated in the way that WebView cannot easily maintain notes data. As notes collections are often created, cloned and extracted, the overall IO becomes excessive and has a huge impact on performance.

Caching of tested directories may be possible to reduce this IO load, but still requires WebView to maintain this cache in session data. This cache management would require a fair amount of code to implement.

Analysis revealed that this IO is only required to determine the note creation and editing permissions. This information can be reduce to only be required when a user actually attempts to do so. Thus the approach to delay the calculation of permissions to this time has been taken.

Delayed write determiniation instances can be chained together for hierarchical determination.

Impelemntations of this must implement the abstract methods and provide a concrete implementation of the internal class WriteState<(Of <(T>)>).

Derivations must not maintain internal state data relating to the instance they were created for. An instance may be associated with another collection instance

Derivations must include the Serializable attribute.

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Notes..::.WriteStateEvaluator<(Of <(T>)>)

See Also

WriteStateEvaluator<(Of <(T>)>) Members
Mincom.LinkOne.Dom.Notes Namespace


WriteStateEvaluator(T) Members

[image] [image]

LinkOne WebView API
WriteStateEvaluator<(Of <(T>)>) Members
WriteStateEvaluator<(Of <(T>)>) Class Constructors Methods Properties See Also Send Feedback

The WriteStateEvaluator<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
WriteStateEvaluator<(Of <(T>)>) | Creates a new delayed write state calculation.

Methods

Name | Description
Chain | Adds the given delayed write determinination into the chain. This instance becomes dependent on item.
CreateWriteState | This utility method creates a WriteState<(Of <(T>)>) instance for use in permission evaluation.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Called to evaluate the write state for the current instance.
Execute | Executes the write state calculation. This modifies collection. After execution, this instance may be disassociated from collection.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IsEquivalentTo | Evaluates equivalence of this instance with another. Used in duplicate removal.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetPermissions | This method applies the calculated permissions to collection.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Access | The visibility of the note or category. Public, private, etc.

See Also

WriteStateEvaluator<(Of <(T>)>) Class
Mincom.LinkOne.Dom.Notes Namespace


WriteStateEvaluator(T) Constructor

[image]

LinkOne WebView API
WriteStateEvaluator<(Of <(T>)>) Constructor
WriteStateEvaluator<(Of <(T>)>) Class See Also Send Feedback
Creates a new delayed write state calculation.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected WriteStateEvaluator(
    Access access
)
Visual Basic (Declaration)
Protected Sub New ( _
    access As Access _
)
Visual C++
protected:
WriteStateEvaluator(
    Access access
)

Parameters

access
Type: Mincom.LinkOne.Dom.Notes..::.Access
The visibility the note or category.

See Also

WriteStateEvaluator<(Of <(T>)>) Class
Mincom.LinkOne.Dom.Notes Namespace


WriteStateEvaluator(T) Methods

[image] [image]

LinkOne WebView API
WriteStateEvaluator<(Of <(T>)>) Methods
WriteStateEvaluator<(Of <(T>)>) Class See Also Send Feedback

The WriteStateEvaluator<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Chain | Adds the given delayed write determinination into the chain. This instance becomes dependent on item.
CreateWriteState | This utility method creates a WriteState<(Of <(T>)>) instance for use in permission evaluation.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Called to evaluate the write state for the current instance.
Execute | Executes the write state calculation. This modifies collection. After execution, this instance may be disassociated from collection.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IsEquivalentTo | Evaluates equivalence of this instance with another. Used in duplicate removal.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetPermissions | This method applies the calculated permissions to collection.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

WriteStateEvaluator<(Of <(T>)>) Class
Mincom.LinkOne.Dom.Notes Namespace


Chain Method

[image]

LinkOne WebView API
WriteStateEvaluator<(Of <(T>)>)..::.Chain Method
WriteStateEvaluator<(Of <(T>)>) Class See Also Send Feedback
Adds the given delayed write determinination into the chain. This instance becomes dependent on item.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Chain(
    WriteStateEvaluator<T> item
)
Visual Basic (Declaration)
Public Sub Chain ( _
    item As WriteStateEvaluator(Of T) _
)
Visual C++
public:
void Chain(
    WriteStateEvaluator<T>^ item
)

Parameters

item
Type: Mincom.LinkOne.Dom.Notes..::.WriteStateEvaluator <(Of <( T >)>)
The item to add into the chain.

Remarks

Each item in the chain is evalulated spearately and the results merged using Merge(T).

See Also

WriteStateEvaluator<(Of <(T>)>) Class
Mincom.LinkOne.Dom.Notes Namespace


CreateWriteState Method

[image]

LinkOne WebView API
WriteStateEvaluator<(Of <(T>)>)..::.CreateWriteState Method
WriteStateEvaluator<(Of <(T>)>) Class See Also Send Feedback
This utility method creates a WriteState<(Of <(T>)>) instance for use in permission evaluation.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected abstract WriteState<T> CreateWriteState()
Visual Basic (Declaration)
Protected MustOverride Function CreateWriteState As WriteState(Of T)
Visual C++
protected:
virtual WriteState<T>^ CreateWriteState() abstract

Return Value

A new instance of WriteState<(Of <(T>)>).

See Also

WriteStateEvaluator<(Of <(T>)>) Class
Mincom.LinkOne.Dom.Notes Namespace


Evaluate Method

[image]

LinkOne WebView API
WriteStateEvaluator<(Of <(T>)>)..::.Evaluate Method
WriteStateEvaluator<(Of <(T>)>) Class See Also Send Feedback
Called to evaluate the write state for the current instance.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected abstract bool Evaluate(
    T collection
)
Visual Basic (Declaration)
Protected MustOverride Function Evaluate ( _
    collection As T _
) As Boolean
Visual C++
protected:
virtual bool Evaluate(
    T collection
) abstract

Parameters

collection
Type: T
The collection to evaluate permissions for.

Return Value

The calculated write permissions.

Remarks

This value is to be passed as the bool value to SetCanCreate(Access, Scope, String, Boolean) or SetCanWrite(Access, Boolean).

Any required file IO should be performed only in this method.

See Also

WriteStateEvaluator<(Of <(T>)>) Class
Mincom.LinkOne.Dom.Notes Namespace


Execute Method

[image]

LinkOne WebView API
WriteStateEvaluator<(Of <(T>)>)..::.Execute Method
WriteStateEvaluator<(Of <(T>)>) Class See Also Send Feedback
Executes the write state calculation. This modifies collection. After execution, this instance may be disassociated from collection.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Execute(
    T collection
)
Visual Basic (Declaration)
Public Sub Execute ( _
    collection As T _
)
Visual C++
public:
void Execute(
    T collection
)

Parameters

collection
Type: T
The note or category collection to modify.

Remarks

Permission evaluation follows this pattern: Flatten the delayed write dependency chains into a single list. Remove duplicates from the list to attempt to reduce redundant re-evaluation. Evaluate each item in the list. For each item cache the initial write state, modify it with the evaluated state, then restore. Overall state is merged and applied at the end.

See Also

WriteStateEvaluator<(Of <(T>)>) Class
Mincom.LinkOne.Dom.Notes Namespace


IsEquivalentTo Method

[image]

LinkOne WebView API
WriteStateEvaluator<(Of <(T>)>)..::.IsEquivalentTo Method
WriteStateEvaluator<(Of <(T>)>) Class See Also Send Feedback
Evaluates equivalence of this instance with another. Used in duplicate removal.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected virtual bool IsEquivalentTo(
    WriteStateEvaluator<T> other
)
Visual Basic (Declaration)
Protected Overridable Function IsEquivalentTo ( _
    other As WriteStateEvaluator(Of T) _
) As Boolean
Visual C++
protected:
virtual bool IsEquivalentTo(
    WriteStateEvaluator<T>^ other
)

Parameters

other
Type: Mincom.LinkOne.Dom.Notes..::.WriteStateEvaluator <(Of <( T >)>)
Instance to compare against.

Return Value

True if this is equivalent to other.

Remarks

This base implementation returns true if the access is exactly equal.

See Also

WriteStateEvaluator<(Of <(T>)>) Class
Mincom.LinkOne.Dom.Notes Namespace


SetPermissions Method

[image]

LinkOne WebView API
WriteStateEvaluator<(Of <(T>)>)..::.SetPermissions Method
WriteStateEvaluator<(Of <(T>)>) Class See Also Send Feedback
This method applies the calculated permissions to collection.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected abstract void SetPermissions(
    WriteStateEvaluator<T> item,
    T collection,
    bool state
)
Visual Basic (Declaration)
Protected MustOverride Sub SetPermissions ( _
    item As WriteStateEvaluator(Of T), _
    collection As T, _
    state As Boolean _
)
Visual C++
protected:
virtual void SetPermissions(
    WriteStateEvaluator<T>^ item,
    T collection,
    bool state
) abstract

Parameters

item
Type: Mincom.LinkOne.Dom.Notes..::.WriteStateEvaluator <(Of <( T >)>)
The instance currently calculating permissions.
collection
Type: T
The collection to modify.
state
Type: System..::.Boolean
The permissions state to apply.

Remarks

This method maps to either SetCanCreate(Access, Scope, String, Boolean) or SetCanWrite(Access, Boolean).

This can be called several times during evaluation when working with chained evaluations.

The evaluator being applied is provided in item. Members of

CopyC#
this
object should not be accessed.

See Also

WriteStateEvaluator<(Of <(T>)>) Class
Mincom.LinkOne.Dom.Notes Namespace


WriteStateEvaluator(T) Properties

[image] [image]

LinkOne WebView API
WriteStateEvaluator<(Of <(T>)>) Properties
WriteStateEvaluator<(Of <(T>)>) Class See Also Send Feedback

The WriteStateEvaluator<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Access | The visibility of the note or category. Public, private, etc.

See Also

WriteStateEvaluator<(Of <(T>)>) Class
Mincom.LinkOne.Dom.Notes Namespace


Access Property

[image]

LinkOne WebView API
WriteStateEvaluator<(Of <(T>)>)..::.Access Property
WriteStateEvaluator<(Of <(T>)>) Class See Also Send Feedback
The visibility of the note or category. Public, private, etc.

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Access Access { get; private set; }
Visual Basic (Declaration)
Public Property Access As Access
Visual C++
public:
property Access Access {
    Access get ();
    void set (Access value);
}

See Also

WriteStateEvaluator<(Of <(T>)>) Class
Mincom.LinkOne.Dom.Notes Namespace


Mincom.LinkOne.Dom.Notes.DrawingElements Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace
Send Feedback
The Mincom.LinkOne.Dom.Notes.DrawingElements namespace contains classes that describe the drawn elements in a redline note.

Classes

Class | Description
DrawingElement | Provides the abstract base class for elements that can be added to an RedlineNote.
DrawingElementCollection | Represents a dynamic collection of drawing elements.
Ellipse | Represents an ellipse.
PointCollection | Represents a collection of Point objects that can be accessed by index.
Polyline | Represents a line.
Rectangle | Represents a rectangle.
Strokes | Represents a series of freeform strokes.
Text | Represents text.

Structures

Structure | Description
Point | Represents a pair of double values.

Interfaces

Interface | Description
IDrawingElement | Represents a drawing on a redline note.
IDrawingElementCollection | Represents a collection of drawing elements that can be individually accessed by index.


DrawingElement Class

[image]

LinkOne WebView API
DrawingElement Class
Members See Also Send Feedback
Provides the abstract base class for elements that can be added to an RedlineNote.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public abstract class DrawingElement : IDrawingElement,
    IEquatable<DrawingElement>
Visual Basic (Declaration)
<SerializableAttribute> _
Public MustInherit Class DrawingElement _
    Implements IDrawingElement, IEquatable(Of DrawingElement)
Visual C++
[SerializableAttribute]
public ref class DrawingElement abstract : IDrawingElement,
    IEquatable<DrawingElement^>

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Notes.DrawingElements..::.DrawingElement
Mincom.LinkOne.Dom.Notes.DrawingElements..::.Ellipse
Mincom.LinkOne.Dom.Notes.DrawingElements..::.Polyline
Mincom.LinkOne.Dom.Notes.DrawingElements..::.Rectangle
Mincom.LinkOne.Dom.Notes.DrawingElements..::.Strokes
Mincom.LinkOne.Dom.Notes.DrawingElements..::.Text

See Also

DrawingElement Members
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


DrawingElement Members

[image] [image]

LinkOne WebView API
DrawingElement Members
DrawingElement Class Methods Properties See Also Send Feedback

The DrawingElement type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overriden. Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Fill | Gets or sets the color of the stroke as an argb hexidecimal or named color.
Position | Gets the position relative to the top-left of the drawing surface. Element1 represents the x coordinate, Element2 represents the y coordinate.
Size | Gets or sets the size of the DrawingElement where Element1 represents the width, and Element2 represents the height.
Stroke | Gets or sets the color of the stroke as an argb hexidecimal or named color.
StrokeThickness | Gets or sets the thickness of the stroke.

See Also

DrawingElement Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


DrawingElement Methods

[image] [image]

LinkOne WebView API
DrawingElement Methods
DrawingElement Class See Also Send Feedback

The DrawingElement type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overriden. Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DrawingElement Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Equals Method

[image] [image]

LinkOne WebView API
DrawingElement..::.Equals Method
DrawingElement Class See Also Send Feedback

Overload List

Name | Description
Equals(DrawingElement) | Indicates whether the current object is equal to another object of the same type.
Equals(Object) | Overriden. Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)

See Also

DrawingElement Class
DrawingElement Members
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Equals Method (DrawingElement)

[image]

LinkOne WebView API
DrawingElement..::.Equals Method (DrawingElement)
DrawingElement Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Equals(
    DrawingElement other
)
Visual Basic (Declaration)
Public Function Equals ( _
    other As DrawingElement _
) As Boolean
Visual C++
public:
virtual bool Equals(
    DrawingElement^ other
) sealed

Parameters

other
Type: Mincom.LinkOne.Dom.Notes.DrawingElements..::.DrawingElement
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

DrawingElement Class
Equals Overload
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Equals Method (Object)

[image]

LinkOne WebView API
DrawingElement..::.Equals Method (Object)
DrawingElement Class See Also Send Feedback
Overriden. Determines whether the specified Object is equal to the current Object.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

DrawingElement Class
Equals Overload
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


GetHashCode Method

[image]

LinkOne WebView API
DrawingElement..::.GetHashCode Method
DrawingElement Class See Also Send Feedback
Overriden. Serves as a hash function for a particular type.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for the current DrawingElement.

See Also

DrawingElement Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


DrawingElement Properties

[image] [image]

LinkOne WebView API
DrawingElement Properties
DrawingElement Class See Also Send Feedback

The DrawingElement type exposes the following members.

Properties

Name | Description
Fill | Gets or sets the color of the stroke as an argb hexidecimal or named color.
Position | Gets the position relative to the top-left of the drawing surface. Element1 represents the x coordinate, Element2 represents the y coordinate.
Size | Gets or sets the size of the DrawingElement where Element1 represents the width, and Element2 represents the height.
Stroke | Gets or sets the color of the stroke as an argb hexidecimal or named color.
StrokeThickness | Gets or sets the thickness of the stroke.

See Also

DrawingElement Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Fill Property

[image]

LinkOne WebView API
DrawingElement..::.Fill Property
DrawingElement Class See Also Send Feedback
Gets or sets the color of the stroke as an argb hexidecimal or named color.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As String
Visual C++
public:
virtual property String^ Fill {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IDrawingElement..::.Fill

See Also

DrawingElement Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Position Property

[image]

LinkOne WebView API
DrawingElement..::.Position Property
DrawingElement Class See Also Send Feedback
Gets the position relative to the top-left of the drawing surface. Element1 represents the x coordinate, Element2 represents the y coordinate.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Point Position { get; set; }
Visual Basic (Declaration)
Public Property Position As Point
Visual C++
public:
virtual property Point Position {
    Point get () sealed;
    void set (Point value) sealed;
}

Implements

IDrawingElement..::.Position

See Also

DrawingElement Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Size Property

[image]

LinkOne WebView API
DrawingElement..::.Size Property
DrawingElement Class See Also Send Feedback
Gets or sets the size of the DrawingElement where Element1 represents the width, and Element2 represents the height.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Point Size { get; set; }
Visual Basic (Declaration)
Public Property Size As Point
Visual C++
public:
virtual property Point Size {
    Point get () sealed;
    void set (Point value) sealed;
}

Implements

IDrawingElement..::.Size

See Also

DrawingElement Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Stroke Property

[image]

LinkOne WebView API
DrawingElement..::.Stroke Property
DrawingElement Class See Also Send Feedback
Gets or sets the color of the stroke as an argb hexidecimal or named color.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Stroke { get; set; }
Visual Basic (Declaration)
Public Property Stroke As String
Visual C++
public:
virtual property String^ Stroke {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IDrawingElement..::.Stroke

See Also

DrawingElement Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


StrokeThickness Property

[image]

LinkOne WebView API
DrawingElement..::.StrokeThickness Property
DrawingElement Class See Also Send Feedback
Gets or sets the thickness of the stroke.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public double StrokeThickness { get; set; }
Visual Basic (Declaration)
Public Property StrokeThickness As Double
Visual C++
public:
virtual property double StrokeThickness {
    double get () sealed;
    void set (double value) sealed;
}

Implements

IDrawingElement..::.StrokeThickness

See Also

DrawingElement Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


DrawingElementCollection Class

[image]

LinkOne WebView API
DrawingElementCollection Class
Members See Also Send Feedback
Represents a dynamic collection of drawing elements.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class DrawingElementCollection : LiveCollection<DrawingElement>,
    IDrawingElementCollection, ICollection<IDrawingElement>, IEnumerable<IDrawingElement>,
    IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class DrawingElementCollection _
    Inherits LiveCollection(Of DrawingElement) _
    Implements IDrawingElementCollection, ICollection(Of IDrawingElement),  _
    IEnumerable(Of IDrawingElement), IEnumerable
Visual C++
[SerializableAttribute]
public ref class DrawingElementCollection sealed : public LiveCollection<DrawingElement^>,
    IDrawingElementCollection, ICollection<IDrawingElement^>, IEnumerable<IDrawingElement^>,
    IEnumerable

Remarks

The DrawingElementCollection provides a change notification when items get added, removed, or when the whole collection refreshes.

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection<(Of <( DrawingElement >)>)
LiveCollection<(Of <( DrawingElement >)>)
Mincom.LinkOne.Dom.Notes.DrawingElements..::.DrawingElementCollection

See Also

DrawingElementCollection Members
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


DrawingElementCollection Members

[image] [image]

LinkOne WebView API
DrawingElementCollection Members
DrawingElementCollection Class Constructors Methods Properties Events Explicit Interface Implementations See Also Send Feedback

The DrawingElementCollection type exposes the following members.

Constructors

Name | Description
DrawingElementCollection | Initializes a new instance of the DrawingElementCollection class

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DrawingElement >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DrawingElement >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DrawingElement >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DrawingElement >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( DrawingElement >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DrawingElement >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DrawingElement >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( DrawingElement >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( DrawingElement >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DrawingElement >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DrawingElement >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DrawingElement >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( DrawingElement >)>).)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DrawingElement >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( DrawingElement >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DrawingElement >)>).)

Events

Name | Description
Changed | Occurs when an item is added, removed, or the entire collection is cleared.

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds an item to the IList. (Inherited from Collection<(Of <( DrawingElement >)>).)
ICollection<(Of <(IDrawingElement>)>)..::.Add |
ICollection<(Of <(IDrawingElement>)>)..::.Clear |
IList..::.Contains | Determines whether the IList contains a specific value. (Inherited from Collection<(Of <( DrawingElement >)>).)
ICollection<(Of <(IDrawingElement>)>)..::.Contains |
ICollection..::.CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection<(Of <( DrawingElement >)>).)
ICollection<(Of <(IDrawingElement>)>)..::.CopyTo |
ICollection<(Of <(IDrawingElement>)>)..::.Count |
IEnumerable<(Of <(IDrawingElement>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator |
IList..::.IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection<(Of <( DrawingElement >)>).)
IList..::.Insert | Inserts an item into the IList at the specified index. (Inherited from Collection<(Of <( DrawingElement >)>).)
IList..::.IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection<(Of <( DrawingElement >)>).)
IsReadOnly | Overloaded.
IList..::.IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection<(Of <( DrawingElement >)>).)
ICollection..::.IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection<(Of <( DrawingElement >)>).)
IList..::.Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( DrawingElement >)>).)
IList..::.Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection<(Of <( DrawingElement >)>).)
ICollection<(Of <(IDrawingElement>)>)..::.Remove |
ICollection..::.SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection<(Of <( DrawingElement >)>).)

See Also

DrawingElementCollection Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


DrawingElementCollection Constructor

[image]

LinkOne WebView API
DrawingElementCollection Constructor
DrawingElementCollection Class See Also Send Feedback
Initializes a new instance of the DrawingElementCollection class

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public DrawingElementCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DrawingElementCollection()

See Also

DrawingElementCollection Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


DrawingElementCollection Methods

[image] [image]

LinkOne WebView API
DrawingElementCollection Methods
DrawingElementCollection Class See Also Send Feedback

The DrawingElementCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DrawingElement >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DrawingElement >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DrawingElement >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DrawingElement >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( DrawingElement >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DrawingElement >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DrawingElement >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( DrawingElement >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( DrawingElement >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DrawingElement >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DrawingElement >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DrawingElement >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( DrawingElement >)>).)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds an item to the IList. (Inherited from Collection<(Of <( DrawingElement >)>).)
ICollection<(Of <(IDrawingElement>)>)..::.Add |
ICollection<(Of <(IDrawingElement>)>)..::.Clear |
IList..::.Contains | Determines whether the IList contains a specific value. (Inherited from Collection<(Of <( DrawingElement >)>).)
ICollection<(Of <(IDrawingElement>)>)..::.Contains |
ICollection..::.CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection<(Of <( DrawingElement >)>).)
ICollection<(Of <(IDrawingElement>)>)..::.CopyTo |
IEnumerable<(Of <(IDrawingElement>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator |
IList..::.IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection<(Of <( DrawingElement >)>).)
IList..::.Insert | Inserts an item into the IList at the specified index. (Inherited from Collection<(Of <( DrawingElement >)>).)
IList..::.Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection<(Of <( DrawingElement >)>).)
ICollection<(Of <(IDrawingElement>)>)..::.Remove |

See Also

DrawingElementCollection Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


ICollection(IDrawingElement).Add Method

[image]

LinkOne WebView API
DrawingElementCollection..::.ICollection<(Of <(IDrawingElement>)>)..::.Add Method
DrawingElementCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<IDrawingElement>.Add(
    IDrawingElement item
)
Visual Basic (Declaration)
Private Sub Add ( _
    item As IDrawingElement _
) Implements ICollection(Of IDrawingElement).Add
Visual C++
private:
virtual void Add(
    IDrawingElement^ item
) sealed = ICollection<IDrawingElement^>::Add

Parameters

item
Type: Mincom.LinkOne.Dom.Notes.DrawingElements..::.IDrawingElement

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

DrawingElementCollection Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


ICollection(IDrawingElement).Clear Method

[image]

LinkOne WebView API
DrawingElementCollection..::.ICollection<(Of <(IDrawingElement>)>)..::.Clear Method
DrawingElementCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<IDrawingElement>.Clear()
Visual Basic (Declaration)
Private Sub Clear Implements ICollection(Of IDrawingElement).Clear
Visual C++
private:
virtual void Clear() sealed = ICollection<IDrawingElement^>::Clear

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

See Also

DrawingElementCollection Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


ICollection(IDrawingElement).Contains Method

[image]

LinkOne WebView API
DrawingElementCollection..::.ICollection<(Of <(IDrawingElement>)>)..::.Contains Method
DrawingElementCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<IDrawingElement>.Contains(
    IDrawingElement item
)
Visual Basic (Declaration)
Private Function Contains ( _
    item As IDrawingElement _
) As Boolean Implements ICollection(Of IDrawingElement).Contains
Visual C++
private:
virtual bool Contains(
    IDrawingElement^ item
) sealed = ICollection<IDrawingElement^>::Contains

Parameters

item
Type: Mincom.LinkOne.Dom.Notes.DrawingElements..::.IDrawingElement

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

DrawingElementCollection Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


ICollection(IDrawingElement).CopyTo Method

[image]

LinkOne WebView API
DrawingElementCollection..::.ICollection<(Of <(IDrawingElement>)>)..::.CopyTo Method
DrawingElementCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<IDrawingElement>.CopyTo(
    IDrawingElement[] array,
    int arrayIndex
)
Visual Basic (Declaration)
Private Sub CopyTo ( _
    array As IDrawingElement(), _
    arrayIndex As Integer _
) Implements ICollection(Of IDrawingElement).CopyTo
Visual C++
private:
virtual void CopyTo(
    array<IDrawingElement^>^ array,
    int arrayIndex
) sealed = ICollection<IDrawingElement^>::CopyTo

Parameters

array
Type: array< Mincom.LinkOne.Dom.Notes.DrawingElements..::.IDrawingElement >[]()[]
arrayIndex
Type: System..::.Int32

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

DrawingElementCollection Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


IEnumerable(IDrawingElement).GetEnumerator Method

[image]

LinkOne WebView API
DrawingElementCollection..::.IEnumerable<(Of <(IDrawingElement>)>)..::.GetEnumerator Method
DrawingElementCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator<IDrawingElement> IEnumerable<IDrawingElement>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of IDrawingElement)
    Implements IEnumerable(Of IDrawingElement).GetEnumerator
Visual C++
private:
virtual IEnumerator<IDrawingElement^>^ GetEnumerator() sealed = IEnumerable<IDrawingElement^>::GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

DrawingElementCollection Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
DrawingElementCollection..::.IEnumerable..::.GetEnumerator Method
DrawingElementCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Implements

IEnumerable..::.GetEnumerator()()()

See Also

DrawingElementCollection Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


ICollection(IDrawingElement).Remove Method

[image]

LinkOne WebView API
DrawingElementCollection..::.ICollection<(Of <(IDrawingElement>)>)..::.Remove Method
DrawingElementCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<IDrawingElement>.Remove(
    IDrawingElement item
)
Visual Basic (Declaration)
Private Function Remove ( _
    item As IDrawingElement _
) As Boolean Implements ICollection(Of IDrawingElement).Remove
Visual C++
private:
virtual bool Remove(
    IDrawingElement^ item
) sealed = ICollection<IDrawingElement^>::Remove

Parameters

item
Type: Mincom.LinkOne.Dom.Notes.DrawingElements..::.IDrawingElement

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

DrawingElementCollection Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


DrawingElementCollection Properties

[image] [image]

LinkOne WebView API
DrawingElementCollection Properties
DrawingElementCollection Class See Also Send Feedback

The DrawingElementCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DrawingElement >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( DrawingElement >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DrawingElement >)>).)

Explicit Interface Implementations

Name | Description
ICollection<(Of <(IDrawingElement>)>)..::.Count |
IList..::.IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection<(Of <( DrawingElement >)>).)
IsReadOnly | Overloaded.
IList..::.IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection<(Of <( DrawingElement >)>).)
ICollection..::.IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection<(Of <( DrawingElement >)>).)
IList..::.Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( DrawingElement >)>).)
ICollection..::.SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection<(Of <( DrawingElement >)>).)

See Also

DrawingElementCollection Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


ICollection(IDrawingElement).Count Property

[image]

LinkOne WebView API
DrawingElementCollection..::.ICollection<(Of <(IDrawingElement>)>)..::.Count Property
DrawingElementCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int ICollection<IDrawingElement>.Count { get; }
Visual Basic (Declaration)
Private ReadOnly Property Count As Integer
    Implements ICollection(Of IDrawingElement).Count
Visual C++
private:
virtual property int Count {
    int get () sealed = ICollection<IDrawingElement^>::Count::get;
}

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

DrawingElementCollection Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


IsReadOnly Property

[image] [image]

LinkOne WebView API
DrawingElementCollection..::.IsReadOnly Property
DrawingElementCollection Class See Also Send Feedback

Overload List

Name | Description
System#Collections#Generic#ICollection{T}#IsReadOnly()()() | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from Collection<(Of <( DrawingElement >)>).)
ICollection<(Of <(IDrawingElement>)>)..::.IsReadOnly |

See Also

DrawingElementCollection Class
DrawingElementCollection Members
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


ICollection(IDrawingElement).IsReadOnly Property

[image]

LinkOne WebView API
DrawingElementCollection..::.ICollection<(Of <(IDrawingElement>)>)..::.IsReadOnly Property
DrawingElementCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<IDrawingElement>.IsReadOnly { get; }
Visual Basic (Declaration)
Private ReadOnly Property IsReadOnly As Boolean
    Implements ICollection(Of IDrawingElement).IsReadOnly
Visual C++
private:
virtual property bool IsReadOnly {
    bool get () sealed = ICollection<IDrawingElement^>::IsReadOnly::get;
}

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

DrawingElementCollection Class
DrawingElementCollection Overload
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


DrawingElementCollection Events

[image] [image]

LinkOne WebView API
DrawingElementCollection Events
DrawingElementCollection Class See Also Send Feedback

The DrawingElementCollection type exposes the following members.

Events

Name | Description
Changed | Occurs when an item is added, removed, or the entire collection is cleared.

See Also

DrawingElementCollection Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Changed Event

[image]

LinkOne WebView API
DrawingElementCollection..::.Changed Event
DrawingElementCollection Class See Also Send Feedback
Occurs when an item is added, removed, or the entire collection is cleared.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public event EventHandler Changed
Visual Basic (Declaration)
Public Event Changed As EventHandler
Visual C++
public:
 event EventHandler^ Changed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

DrawingElementCollection Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Ellipse Class

[image]

LinkOne WebView API
Ellipse Class
Members See Also Send Feedback
Represents an ellipse.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class Ellipse : DrawingElement
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class Ellipse _
    Inherits DrawingElement
Visual C++
[SerializableAttribute]
public ref class Ellipse sealed : public DrawingElement

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Notes.DrawingElements..::.DrawingElement
Mincom.LinkOne.Dom.Notes.DrawingElements..::.Ellipse

See Also

Ellipse Members
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Ellipse Members

[image] [image]

LinkOne WebView API
Ellipse Members
Ellipse Class Constructors Methods Properties See Also Send Feedback

The Ellipse type exposes the following members.

Constructors

Name | Description
Ellipse | Initializes a new instance of the Ellipse class

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overriden. Serves as a hash function for a particular type. (Inherited from DrawingElement.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Fill | Gets or sets the color of the stroke as an argb hexidecimal or named color. (Inherited from DrawingElement.)
Position | Gets the position relative to the top-left of the drawing surface. Element1 represents the x coordinate, Element2 represents the y coordinate. (Inherited from DrawingElement.)
Size | Gets or sets the size of the DrawingElement where Element1 represents the width, and Element2 represents the height. (Inherited from DrawingElement.)
Stroke | Gets or sets the color of the stroke as an argb hexidecimal or named color. (Inherited from DrawingElement.)
StrokeThickness | Gets or sets the thickness of the stroke. (Inherited from DrawingElement.)

See Also

Ellipse Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Ellipse Constructor

[image]

LinkOne WebView API
Ellipse Constructor
Ellipse Class See Also Send Feedback
Initializes a new instance of the Ellipse class

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Ellipse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Ellipse()

See Also

Ellipse Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Ellipse Methods

[image] [image]

LinkOne WebView API
Ellipse Methods
Ellipse Class See Also Send Feedback

The Ellipse type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overriden. Serves as a hash function for a particular type. (Inherited from DrawingElement.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Ellipse Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Equals Method

[image] [image]

LinkOne WebView API
Ellipse..::.Equals Method
Ellipse Class See Also Send Feedback

Overload List

Name | Description
Equals(DrawingElement) | Indicates whether the current object is equal to another object of the same type. (Inherited from DrawingElement.)
Equals(Object) | Overriden. Determines whether the specified Object is equal to the current Object. (Inherited from DrawingElement.)

See Also

Ellipse Class
Ellipse Members
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Ellipse Properties

[image] [image]

LinkOne WebView API
Ellipse Properties
Ellipse Class See Also Send Feedback

The Ellipse type exposes the following members.

Properties

Name | Description
Fill | Gets or sets the color of the stroke as an argb hexidecimal or named color. (Inherited from DrawingElement.)
Position | Gets the position relative to the top-left of the drawing surface. Element1 represents the x coordinate, Element2 represents the y coordinate. (Inherited from DrawingElement.)
Size | Gets or sets the size of the DrawingElement where Element1 represents the width, and Element2 represents the height. (Inherited from DrawingElement.)
Stroke | Gets or sets the color of the stroke as an argb hexidecimal or named color. (Inherited from DrawingElement.)
StrokeThickness | Gets or sets the thickness of the stroke. (Inherited from DrawingElement.)

See Also

Ellipse Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


IDrawingElement Interface

[image]

LinkOne WebView API
IDrawingElement Interface
Members See Also Send Feedback
Represents a drawing on a redline note.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IDrawingElement
Visual Basic (Declaration)
Public Interface IDrawingElement
Visual C++
public interface class IDrawingElement

See Also

IDrawingElement Members
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


IDrawingElement Members

[image] [image]

LinkOne WebView API
IDrawingElement Members
IDrawingElement Interface Properties See Also Send Feedback

The IDrawingElement type exposes the following members.

Properties

Name | Description
Fill | Gets or sets the color of the stroke as an argb hexidecimal or named color.
Position | Gets or sets the position relative to the top-left of the drawing surface. Element1 represents the x coordinate, Element2 represents the y coordinate.
Size | Gets or sets the size of the IDrawingElement where Element1 represents the width, and Element2 represents the height.
Stroke | Gets or sets the color of the stroke as an argb hexidecimal or named color.
StrokeThickness | Gets or sets the thickness of the stroke.

See Also

IDrawingElement Interface
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


IDrawingElement Properties

[image] [image]

LinkOne WebView API
IDrawingElement Properties
IDrawingElement Interface See Also Send Feedback

The IDrawingElement type exposes the following members.

Properties

Name | Description
Fill | Gets or sets the color of the stroke as an argb hexidecimal or named color.
Position | Gets or sets the position relative to the top-left of the drawing surface. Element1 represents the x coordinate, Element2 represents the y coordinate.
Size | Gets or sets the size of the IDrawingElement where Element1 represents the width, and Element2 represents the height.
Stroke | Gets or sets the color of the stroke as an argb hexidecimal or named color.
StrokeThickness | Gets or sets the thickness of the stroke.

See Also

IDrawingElement Interface
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Fill Property

[image]

LinkOne WebView API
IDrawingElement..::.Fill Property
IDrawingElement Interface See Also Send Feedback
Gets or sets the color of the stroke as an argb hexidecimal or named color.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Fill { get; set; }
Visual Basic (Declaration)
Property Fill As String
Visual C++
property String^ Fill {
    String^ get ();
    void set (String^ value);
}

See Also

IDrawingElement Interface
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Position Property

[image]

LinkOne WebView API
IDrawingElement..::.Position Property
IDrawingElement Interface See Also Send Feedback
Gets or sets the position relative to the top-left of the drawing surface. Element1 represents the x coordinate, Element2 represents the y coordinate.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
Point Position { get; set; }
Visual Basic (Declaration)
Property Position As Point
Visual C++
property Point Position {
    Point get ();
    void set (Point value);
}

See Also

IDrawingElement Interface
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Size Property

[image]

LinkOne WebView API
IDrawingElement..::.Size Property
IDrawingElement Interface See Also Send Feedback
Gets or sets the size of the IDrawingElement where Element1 represents the width, and Element2 represents the height.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
Point Size { get; set; }
Visual Basic (Declaration)
Property Size As Point
Visual C++
property Point Size {
    Point get ();
    void set (Point value);
}

See Also

IDrawingElement Interface
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Stroke Property

[image]

LinkOne WebView API
IDrawingElement..::.Stroke Property
IDrawingElement Interface See Also Send Feedback
Gets or sets the color of the stroke as an argb hexidecimal or named color.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Stroke { get; set; }
Visual Basic (Declaration)
Property Stroke As String
Visual C++
property String^ Stroke {
    String^ get ();
    void set (String^ value);
}

See Also

IDrawingElement Interface
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


StrokeThickness Property

[image]

LinkOne WebView API
IDrawingElement..::.StrokeThickness Property
IDrawingElement Interface See Also Send Feedback
Gets or sets the thickness of the stroke.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
double StrokeThickness { get; set; }
Visual Basic (Declaration)
Property StrokeThickness As Double
Visual C++
property double StrokeThickness {
    double get ();
    void set (double value);
}

See Also

IDrawingElement Interface
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


IDrawingElementCollection Interface

[image]

LinkOne WebView API
IDrawingElementCollection Interface
Members See Also Send Feedback
Represents a collection of drawing elements that can be individually accessed by index.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IDrawingElementCollection : ICollection<IDrawingElement>,
    IEnumerable<IDrawingElement>, IEnumerable
Visual Basic (Declaration)
Public Interface IDrawingElementCollection _
    Implements ICollection(Of IDrawingElement), IEnumerable(Of IDrawingElement),  _
    IEnumerable
Visual C++
public interface class IDrawingElementCollection : ICollection<IDrawingElement^>,
    IEnumerable<IDrawingElement^>, IEnumerable

See Also

IDrawingElementCollection Members
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


IDrawingElementCollection Members

[image] [image]

LinkOne WebView API
IDrawingElementCollection Members
IDrawingElementCollection Interface Methods Properties See Also Send Feedback

The IDrawingElementCollection type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IDrawingElement >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IDrawingElement >)>).)
Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from ICollection<(Of <( IDrawingElement >)>).)
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( IDrawingElement >)>).)
GetEnumerator | Overloaded.
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IDrawingElement >)>).)

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IDrawingElement >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( IDrawingElement >)>).)

See Also

IDrawingElementCollection Interface
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


IDrawingElementCollection Methods

[image] [image]

LinkOne WebView API
IDrawingElementCollection Methods
IDrawingElementCollection Interface See Also Send Feedback

The IDrawingElementCollection type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IDrawingElement >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IDrawingElement >)>).)
Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from ICollection<(Of <( IDrawingElement >)>).)
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( IDrawingElement >)>).)
GetEnumerator | Overloaded.
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IDrawingElement >)>).)

See Also

IDrawingElementCollection Interface
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
IDrawingElementCollection..::.GetEnumerator Method
IDrawingElementCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( IDrawingElement >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IDrawingElementCollection Interface
IDrawingElementCollection Members
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


IDrawingElementCollection Properties

[image] [image]

LinkOne WebView API
IDrawingElementCollection Properties
IDrawingElementCollection Interface See Also Send Feedback

The IDrawingElementCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IDrawingElement >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( IDrawingElement >)>).)

See Also

IDrawingElementCollection Interface
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Point Structure

[image]

LinkOne WebView API
Point Structure
Members See Also Send Feedback
Represents a pair of double values.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public struct Point
Visual Basic (Declaration)
<SerializableAttribute> _
Public Structure Point
Visual C++
[SerializableAttribute]
public value class Point

See Also

Point Members
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Point Members

[image] [image]

LinkOne WebView API
Point Members
Point Structure Constructors Methods Properties See Also Send Feedback

The Point type exposes the following members.

Constructors

Name | Description
Point | Initializes a new instance of the Point struct.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overriden. Gets a string representation of this point as a comma seperated value. For example: 7,9 represents Element1 = 7, Element2 = 9. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Implements the operator ==.
Inequality | Implements the operator !=.

Properties

Name | Description
Element1 | Gets or sets the first value.
Element2 | Gets or sets the second value.

See Also

Point Structure
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Point Constructor

[image]

LinkOne WebView API
Point Constructor
Point Structure See Also Send Feedback
Initializes a new instance of the Point struct.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Point(
    double element1,
    double element2
)
Visual Basic (Declaration)
Public Sub New ( _
    element1 As Double, _
    element2 As Double _
)
Visual C++
public:
Point(
    double element1,
    double element2
)

Parameters

element1
Type: System..::.Double
The first value.
element2
Type: System..::.Double
The second value.

See Also

Point Structure
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Point Methods

[image] [image]

LinkOne WebView API
Point Methods
Point Structure See Also Send Feedback

The Point type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overriden. Gets a string representation of this point as a comma seperated value. For example: 7,9 represents Element1 = 7, Element2 = 9. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Implements the operator ==.
Inequality | Implements the operator !=.

See Also

Point Structure
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Equality Operator

[image]

LinkOne WebView API
Point..::.Equality Operator
Point Structure See Also Send Feedback
Implements the operator ==.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static bool operator ==(
    Point point1,
    Point point2
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    point1 As Point, _
    point2 As Point _
) As Boolean
Visual C++
public:
static bool operator ==(
    Point point1,
    Point point2
)

Parameters

point1
Type: Mincom.LinkOne.Dom.Notes.DrawingElements..::.Point
The point 1.
point2
Type: Mincom.LinkOne.Dom.Notes.DrawingElements..::.Point
The point 2.

Return Value

The result of the operator.

See Also

Point Structure
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Equals Method

[image]

LinkOne WebView API
Point..::.Equals Method
Point Structure See Also Send Feedback
Indicates whether this instance and a specified object are equal.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
Another object to compare to.

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

See Also

Point Structure
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


GetHashCode Method

[image]

LinkOne WebView API
Point..::.GetHashCode Method
Point Structure See Also Send Feedback
Returns the hash code for this instance.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A 32-bit signed integer that is the hash code for this instance.

See Also

Point Structure
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Inequality Operator

[image]

LinkOne WebView API
Point..::.Inequality Operator
Point Structure See Also Send Feedback
Implements the operator !=.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static bool operator !=(
    Point tuple1,
    Point tuple2
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    tuple1 As Point, _
    tuple2 As Point _
) As Boolean
Visual C++
public:
static bool operator !=(
    Point tuple1,
    Point tuple2
)

Parameters

tuple1
Type: Mincom.LinkOne.Dom.Notes.DrawingElements..::.Point
The tuple1.
tuple2
Type: Mincom.LinkOne.Dom.Notes.DrawingElements..::.Point
The tuple2.

Return Value

The result of the operator.

See Also

Point Structure
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


ToString Method

[image]

LinkOne WebView API
Point..::.ToString Method
Point Structure See Also Send Feedback
Overriden. Gets a string representation of this point as a comma seperated value. For example: 7,9 represents Element1 = 7, Element2 = 9.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

Returns a comma seperated string that represents this point.

See Also

Point Structure
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Point Properties

[image] [image]

LinkOne WebView API
Point Properties
Point Structure See Also Send Feedback

The Point type exposes the following members.

Properties

Name | Description
Element1 | Gets or sets the first value.
Element2 | Gets or sets the second value.

See Also

Point Structure
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Element1 Property

[image]

LinkOne WebView API
Point..::.Element1 Property
Point Structure See Also Send Feedback
Gets or sets the first value.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public double Element1 { get; set; }
Visual Basic (Declaration)
Public Property Element1 As Double
Visual C++
public:
property double Element1 {
    double get ();
    void set (double value);
}

See Also

Point Structure
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Element2 Property

[image]

LinkOne WebView API
Point..::.Element2 Property
Point Structure See Also Send Feedback
Gets or sets the second value.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public double Element2 { get; set; }
Visual Basic (Declaration)
Public Property Element2 As Double
Visual C++
public:
property double Element2 {
    double get ();
    void set (double value);
}

See Also

Point Structure
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


PointCollection Class

[image]

LinkOne WebView API
PointCollection Class
Members See Also Send Feedback
Represents a collection of Point objects that can be accessed by index.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class PointCollection : Collection<Point>
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class PointCollection _
    Inherits Collection(Of Point)
Visual C++
[SerializableAttribute]
public ref class PointCollection sealed : public Collection<Point>

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection<(Of <( Point >)>)
Mincom.LinkOne.Dom.Notes.DrawingElements..::.PointCollection

See Also

PointCollection Members
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


PointCollection Members

[image] [image]

LinkOne WebView API
PointCollection Members
PointCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The PointCollection type exposes the following members.

Constructors

Name | Description
PointCollection | Initializes a new instance of the PointCollection class

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Point >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Point >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Point >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Point >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( Point >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Point >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Point >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Point >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Point >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Point >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Point >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Point >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( Point >)>).)
ToString | Overriden. Gets a string representation of all the Point objects in this collection. (Overrides Object..::.ToString()()().)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Point >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( Point >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Point >)>).)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds an item to the IList. (Inherited from Collection<(Of <( Point >)>).)
IList..::.Contains | Determines whether the IList contains a specific value. (Inherited from Collection<(Of <( Point >)>).)
ICollection..::.CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection<(Of <( Point >)>).)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection<(Of <( Point >)>).)
IList..::.IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection<(Of <( Point >)>).)
IList..::.Insert | Inserts an item into the IList at the specified index. (Inherited from Collection<(Of <( Point >)>).)
IList..::.IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection<(Of <( Point >)>).)
System#Collections#Generic#ICollection{T}#IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from Collection<(Of <( Point >)>).)
IList..::.IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection<(Of <( Point >)>).)
ICollection..::.IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection<(Of <( Point >)>).)
IList..::.Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( Point >)>).)
IList..::.Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection<(Of <( Point >)>).)
ICollection..::.SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection<(Of <( Point >)>).)

See Also

PointCollection Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


PointCollection Constructor

[image]

LinkOne WebView API
PointCollection Constructor
PointCollection Class See Also Send Feedback
Initializes a new instance of the PointCollection class

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PointCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PointCollection()

See Also

PointCollection Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


PointCollection Methods

[image] [image]

LinkOne WebView API
PointCollection Methods
PointCollection Class See Also Send Feedback

The PointCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Point >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Point >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Point >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Point >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( Point >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Point >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Point >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Point >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Point >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Point >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Point >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Point >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( Point >)>).)
ToString | Overriden. Gets a string representation of all the Point objects in this collection. (Overrides Object..::.ToString()()().)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds an item to the IList. (Inherited from Collection<(Of <( Point >)>).)
IList..::.Contains | Determines whether the IList contains a specific value. (Inherited from Collection<(Of <( Point >)>).)
ICollection..::.CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection<(Of <( Point >)>).)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection<(Of <( Point >)>).)
IList..::.IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection<(Of <( Point >)>).)
IList..::.Insert | Inserts an item into the IList at the specified index. (Inherited from Collection<(Of <( Point >)>).)
IList..::.Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection<(Of <( Point >)>).)

See Also

PointCollection Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


ToString Method

[image]

LinkOne WebView API
PointCollection..::.ToString Method
PointCollection Class See Also Send Feedback
Overriden. Gets a string representation of all the Point objects in this collection.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A comma seperated string of all Point objects in the PointCollection.

See Also

PointCollection Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


PointCollection Properties

[image] [image]

LinkOne WebView API
PointCollection Properties
PointCollection Class See Also Send Feedback

The PointCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Point >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( Point >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Point >)>).)

Explicit Interface Implementations

Name | Description
IList..::.IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection<(Of <( Point >)>).)
System#Collections#Generic#ICollection{T}#IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from Collection<(Of <( Point >)>).)
IList..::.IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection<(Of <( Point >)>).)
ICollection..::.IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection<(Of <( Point >)>).)
IList..::.Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( Point >)>).)
ICollection..::.SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection<(Of <( Point >)>).)

See Also

PointCollection Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Polyline Class

[image]

LinkOne WebView API
Polyline Class
Members See Also Send Feedback
Represents a line.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class Polyline : DrawingElement
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class Polyline _
    Inherits DrawingElement
Visual C++
[SerializableAttribute]
public ref class Polyline sealed : public DrawingElement

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Notes.DrawingElements..::.DrawingElement
Mincom.LinkOne.Dom.Notes.DrawingElements..::.Polyline

See Also

Polyline Members
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Polyline Members

[image] [image]

LinkOne WebView API
Polyline Members
Polyline Class Constructors Methods Properties See Also Send Feedback

The Polyline type exposes the following members.

Constructors

Name | Description
Polyline | Initializes a new instance of the Polyline class.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overriden. Serves as a hash function for a particular type. (Inherited from DrawingElement.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Fill | Gets or sets the color of the stroke as an argb hexidecimal or named color. (Inherited from DrawingElement.)
Points | Gets or sets the points in the line.
Position | Gets the position relative to the top-left of the drawing surface. Element1 represents the x coordinate, Element2 represents the y coordinate. (Inherited from DrawingElement.)
Size | Gets or sets the size of the DrawingElement where Element1 represents the width, and Element2 represents the height. (Inherited from DrawingElement.)
Stroke | Gets or sets the color of the stroke as an argb hexidecimal or named color. (Inherited from DrawingElement.)
StrokeThickness | Gets or sets the thickness of the stroke. (Inherited from DrawingElement.)

See Also

Polyline Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Polyline Constructor

[image]

LinkOne WebView API
Polyline Constructor
Polyline Class See Also Send Feedback
Initializes a new instance of the Polyline class.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Polyline(
    PointCollection points
)
Visual Basic (Declaration)
Public Sub New ( _
    points As PointCollection _
)
Visual C++
public:
Polyline(
    PointCollection^ points
)

Parameters

points
Type: Mincom.LinkOne.Dom.Notes.DrawingElements..::.PointCollection
The points to initialize from.

See Also

Polyline Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Polyline Methods

[image] [image]

LinkOne WebView API
Polyline Methods
Polyline Class See Also Send Feedback

The Polyline type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overriden. Serves as a hash function for a particular type. (Inherited from DrawingElement.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Polyline Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Equals Method

[image] [image]

LinkOne WebView API
Polyline..::.Equals Method
Polyline Class See Also Send Feedback

Overload List

Name | Description
Equals(DrawingElement) | Indicates whether the current object is equal to another object of the same type. (Inherited from DrawingElement.)
Equals(Object) | Overriden. Determines whether the specified Object is equal to the current Object. (Inherited from DrawingElement.)

See Also

Polyline Class
Polyline Members
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Polyline Properties

[image] [image]

LinkOne WebView API
Polyline Properties
Polyline Class See Also Send Feedback

The Polyline type exposes the following members.

Properties

Name | Description
Fill | Gets or sets the color of the stroke as an argb hexidecimal or named color. (Inherited from DrawingElement.)
Points | Gets or sets the points in the line.
Position | Gets the position relative to the top-left of the drawing surface. Element1 represents the x coordinate, Element2 represents the y coordinate. (Inherited from DrawingElement.)
Size | Gets or sets the size of the DrawingElement where Element1 represents the width, and Element2 represents the height. (Inherited from DrawingElement.)
Stroke | Gets or sets the color of the stroke as an argb hexidecimal or named color. (Inherited from DrawingElement.)
StrokeThickness | Gets or sets the thickness of the stroke. (Inherited from DrawingElement.)

See Also

Polyline Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Points Property

[image]

LinkOne WebView API
Polyline..::.Points Property
Polyline Class See Also Send Feedback
Gets or sets the points in the line.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PointCollection Points { get; }
Visual Basic (Declaration)
Public ReadOnly Property Points As PointCollection
Visual C++
public:
property PointCollection^ Points {
    PointCollection^ get ();
}

See Also

Polyline Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Rectangle Class

[image]

LinkOne WebView API
Rectangle Class
Members See Also Send Feedback
Represents a rectangle.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class Rectangle : DrawingElement
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class Rectangle _
    Inherits DrawingElement
Visual C++
[SerializableAttribute]
public ref class Rectangle sealed : public DrawingElement

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Notes.DrawingElements..::.DrawingElement
Mincom.LinkOne.Dom.Notes.DrawingElements..::.Rectangle

See Also

Rectangle Members
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Rectangle Members

[image] [image]

LinkOne WebView API
Rectangle Members
Rectangle Class Constructors Methods Properties See Also Send Feedback

The Rectangle type exposes the following members.

Constructors

Name | Description
Rectangle | Initializes a new instance of the Rectangle class

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overriden. Serves as a hash function for a particular type. (Inherited from DrawingElement.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Fill | Gets or sets the color of the stroke as an argb hexidecimal or named color. (Inherited from DrawingElement.)
Position | Gets the position relative to the top-left of the drawing surface. Element1 represents the x coordinate, Element2 represents the y coordinate. (Inherited from DrawingElement.)
Size | Gets or sets the size of the DrawingElement where Element1 represents the width, and Element2 represents the height. (Inherited from DrawingElement.)
Stroke | Gets or sets the color of the stroke as an argb hexidecimal or named color. (Inherited from DrawingElement.)
StrokeThickness | Gets or sets the thickness of the stroke. (Inherited from DrawingElement.)

See Also

Rectangle Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Rectangle Constructor

[image]

LinkOne WebView API
Rectangle Constructor
Rectangle Class See Also Send Feedback
Initializes a new instance of the Rectangle class

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Rectangle()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Rectangle()

See Also

Rectangle Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Rectangle Methods

[image] [image]

LinkOne WebView API
Rectangle Methods
Rectangle Class See Also Send Feedback

The Rectangle type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overriden. Serves as a hash function for a particular type. (Inherited from DrawingElement.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Rectangle Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Equals Method

[image] [image]

LinkOne WebView API
Rectangle..::.Equals Method
Rectangle Class See Also Send Feedback

Overload List

Name | Description
Equals(DrawingElement) | Indicates whether the current object is equal to another object of the same type. (Inherited from DrawingElement.)
Equals(Object) | Overriden. Determines whether the specified Object is equal to the current Object. (Inherited from DrawingElement.)

See Also

Rectangle Class
Rectangle Members
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Rectangle Properties

[image] [image]

LinkOne WebView API
Rectangle Properties
Rectangle Class See Also Send Feedback

The Rectangle type exposes the following members.

Properties

Name | Description
Fill | Gets or sets the color of the stroke as an argb hexidecimal or named color. (Inherited from DrawingElement.)
Position | Gets the position relative to the top-left of the drawing surface. Element1 represents the x coordinate, Element2 represents the y coordinate. (Inherited from DrawingElement.)
Size | Gets or sets the size of the DrawingElement where Element1 represents the width, and Element2 represents the height. (Inherited from DrawingElement.)
Stroke | Gets or sets the color of the stroke as an argb hexidecimal or named color. (Inherited from DrawingElement.)
StrokeThickness | Gets or sets the thickness of the stroke. (Inherited from DrawingElement.)

See Also

Rectangle Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Strokes Class

[image]

LinkOne WebView API
Strokes Class
Members See Also Send Feedback
Represents a series of freeform strokes.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class Strokes : DrawingElement
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class Strokes _
    Inherits DrawingElement
Visual C++
[SerializableAttribute]
public ref class Strokes sealed : public DrawingElement

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Notes.DrawingElements..::.DrawingElement
Mincom.LinkOne.Dom.Notes.DrawingElements..::.Strokes

See Also

Strokes Members
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Strokes Members

[image] [image]

LinkOne WebView API
Strokes Members
Strokes Class Constructors Methods Properties See Also Send Feedback

The Strokes type exposes the following members.

Constructors

Name | Description
Strokes | Initializes a new instance of the Strokes class

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overriden. Serves as a hash function for a particular type. (Inherited from DrawingElement.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Data | Gets or sets the strokes data as Ink Serialized Format (ISF), a base64 encoded string.
Fill | Gets or sets the color of the stroke as an argb hexidecimal or named color. (Inherited from DrawingElement.)
Position | Gets the position relative to the top-left of the drawing surface. Element1 represents the x coordinate, Element2 represents the y coordinate. (Inherited from DrawingElement.)
Size | Gets or sets the size of the DrawingElement where Element1 represents the width, and Element2 represents the height. (Inherited from DrawingElement.)
Stroke | Gets or sets the color of the stroke as an argb hexidecimal or named color. (Inherited from DrawingElement.)
StrokeThickness | Gets or sets the thickness of the stroke. (Inherited from DrawingElement.)

See Also

Strokes Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Strokes Constructor

[image]

LinkOne WebView API
Strokes Constructor
Strokes Class See Also Send Feedback
Initializes a new instance of the Strokes class

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Strokes()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Strokes()

See Also

Strokes Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Strokes Methods

[image] [image]

LinkOne WebView API
Strokes Methods
Strokes Class See Also Send Feedback

The Strokes type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overriden. Serves as a hash function for a particular type. (Inherited from DrawingElement.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Strokes Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Equals Method

[image] [image]

LinkOne WebView API
Strokes..::.Equals Method
Strokes Class See Also Send Feedback

Overload List

Name | Description
Equals(DrawingElement) | Indicates whether the current object is equal to another object of the same type. (Inherited from DrawingElement.)
Equals(Object) | Overriden. Determines whether the specified Object is equal to the current Object. (Inherited from DrawingElement.)

See Also

Strokes Class
Strokes Members
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Strokes Properties

[image] [image]

LinkOne WebView API
Strokes Properties
Strokes Class See Also Send Feedback

The Strokes type exposes the following members.

Properties

Name | Description
Data | Gets or sets the strokes data as Ink Serialized Format (ISF), a base64 encoded string.
Fill | Gets or sets the color of the stroke as an argb hexidecimal or named color. (Inherited from DrawingElement.)
Position | Gets the position relative to the top-left of the drawing surface. Element1 represents the x coordinate, Element2 represents the y coordinate. (Inherited from DrawingElement.)
Size | Gets or sets the size of the DrawingElement where Element1 represents the width, and Element2 represents the height. (Inherited from DrawingElement.)
Stroke | Gets or sets the color of the stroke as an argb hexidecimal or named color. (Inherited from DrawingElement.)
StrokeThickness | Gets or sets the thickness of the stroke. (Inherited from DrawingElement.)

See Also

Strokes Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Data Property

[image]

LinkOne WebView API
Strokes..::.Data Property
Strokes Class See Also Send Feedback
Gets or sets the strokes data as Ink Serialized Format (ISF), a base64 encoded string.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Data { get; set; }
Visual Basic (Declaration)
Public Property Data As String
Visual C++
public:
property String^ Data {
    String^ get ();
    void set (String^ value);
}

See Also

Strokes Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Text Class

[image]

LinkOne WebView API
Text Class
Members See Also Send Feedback
Represents text.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class Text : DrawingElement
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class Text _
    Inherits DrawingElement
Visual C++
[SerializableAttribute]
public ref class Text sealed : public DrawingElement

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Notes.DrawingElements..::.DrawingElement
Mincom.LinkOne.Dom.Notes.DrawingElements..::.Text

See Also

Text Members
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Text Members

[image] [image]

LinkOne WebView API
Text Members
Text Class Constructors Methods Properties See Also Send Feedback

The Text type exposes the following members.

Constructors

Name | Description
Text | Initializes a new instance of the Text class

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overriden. Serves as a hash function for a particular type. (Inherited from DrawingElement.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Fill | Gets or sets the color of the stroke as an argb hexidecimal or named color. (Inherited from DrawingElement.)
FontFamily | Gets or sets the font family. You can specify fallback fonts by seperating each font family with a comma.
FontSize | Gets or sets the size of the font.
FontStroke | Gets or sets the color of the font as an argb hexidecimal or named color.
Position | Gets the position relative to the top-left of the drawing surface. Element1 represents the x coordinate, Element2 represents the y coordinate. (Inherited from DrawingElement.)
Size | Gets or sets the size of the DrawingElement where Element1 represents the width, and Element2 represents the height. (Inherited from DrawingElement.)
Stroke | Gets or sets the color of the stroke as an argb hexidecimal or named color. (Inherited from DrawingElement.)
StrokeThickness | Gets or sets the thickness of the stroke. (Inherited from DrawingElement.)
Value | Gets or sets the value.

See Also

Text Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Text Constructor

[image]

LinkOne WebView API
Text Constructor
Text Class See Also Send Feedback
Initializes a new instance of the Text class

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Text()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Text()

See Also

Text Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Text Methods

[image] [image]

LinkOne WebView API
Text Methods
Text Class See Also Send Feedback

The Text type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overriden. Serves as a hash function for a particular type. (Inherited from DrawingElement.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Text Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Equals Method

[image] [image]

LinkOne WebView API
Text..::.Equals Method
Text Class See Also Send Feedback

Overload List

Name | Description
Equals(DrawingElement) | Indicates whether the current object is equal to another object of the same type. (Inherited from DrawingElement.)
Equals(Object) | Overriden. Determines whether the specified Object is equal to the current Object. (Inherited from DrawingElement.)

See Also

Text Class
Text Members
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Text Properties

[image] [image]

LinkOne WebView API
Text Properties
Text Class See Also Send Feedback

The Text type exposes the following members.

Properties

Name | Description
Fill | Gets or sets the color of the stroke as an argb hexidecimal or named color. (Inherited from DrawingElement.)
FontFamily | Gets or sets the font family. You can specify fallback fonts by seperating each font family with a comma.
FontSize | Gets or sets the size of the font.
FontStroke | Gets or sets the color of the font as an argb hexidecimal or named color.
Position | Gets the position relative to the top-left of the drawing surface. Element1 represents the x coordinate, Element2 represents the y coordinate. (Inherited from DrawingElement.)
Size | Gets or sets the size of the DrawingElement where Element1 represents the width, and Element2 represents the height. (Inherited from DrawingElement.)
Stroke | Gets or sets the color of the stroke as an argb hexidecimal or named color. (Inherited from DrawingElement.)
StrokeThickness | Gets or sets the thickness of the stroke. (Inherited from DrawingElement.)
Value | Gets or sets the value.

See Also

Text Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


FontFamily Property

[image]

LinkOne WebView API
Text..::.FontFamily Property
Text Class Example See Also Send Feedback
Gets or sets the font family. You can specify fallback fonts by seperating each font family with a comma.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string FontFamily { get; set; }
Visual Basic (Declaration)
Public Property FontFamily As String
Visual C++
public:
property String^ FontFamily {
    String^ get ();
    void set (String^ value);
}

Examples

The following string specifies Calibri as the first choice font, if the font is not available on the user's system, it will fallback to Arial, and Consolas in that order:
Text text = new Text();
text.FontFamily = "Calibri,Arial,Consolas"

See Also

Text Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


FontSize Property

[image]

LinkOne WebView API
Text..::.FontSize Property
Text Class See Also Send Feedback
Gets or sets the size of the font.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public double FontSize { get; set; }
Visual Basic (Declaration)
Public Property FontSize As Double
Visual C++
public:
property double FontSize {
    double get ();
    void set (double value);
}

See Also

Text Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


FontStroke Property

[image]

LinkOne WebView API
Text..::.FontStroke Property
Text Class See Also Send Feedback
Gets or sets the color of the font as an argb hexidecimal or named color.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string FontStroke { get; set; }
Visual Basic (Declaration)
Public Property FontStroke As String
Visual C++
public:
property String^ FontStroke {
    String^ get ();
    void set (String^ value);
}

See Also

Text Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Value Property

[image]

LinkOne WebView API
Text..::.Value Property
Text Class See Also Send Feedback
Gets or sets the value.

Namespace: Mincom.LinkOne.Dom.Notes.DrawingElements
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

Text Class
Mincom.LinkOne.Dom.Notes.DrawingElements Namespace


Mincom.LinkOne.Dom.Searching Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.Dom.Searching Namespace
Send Feedback
The Mincom.LinkOne.Dom.Searching namespace contains classes that provide searching functionality.

Classes

Class | Description
Search | Represents a LinkOne search definition.
SearchCollection | Represents a collection of Search objects.
SearchDisplayField | Represents a display field definition in a LinkOne search.
SearchEntryFieldMap |
SearchEntryMap | A map of entry field searches.
SearchField | A search field in a LinkOne SearchKey. There may be more than one per key.
SearchFieldCollection | Represents a collection of SearchField objects that can be accessed by index.
SearchFieldMap | A map of list item identifiers and page references.
SearchKey | A search key in a LinkOne Search. There may be up-to two in a search definition.
SearchKeyCollection | Represents a collection of SearchKey objects that can be accessed by index.
SearchPageFieldMap | A map of page fields and page references.
SearchPageFieldMapOverBook | A map of page fields and page references created over the indexes existing within a book.
SearchPageMap | A map of page field searches.
SearchParameter | Represents a Linkone search parameter.
SearchParameterCollection | Represents a collection of search parameters that can be accessed by index.
SearchProgressEventArgs | Provides data for the SearchProgressEventHandler handler.
SearchResult | The result row for a matching entry for a particular search.
SearchResultCollection | Represents a collection of SearchResult objects.
SearchResultFieldMatch | This class represents the matching fields in a SearchResult.
SearchSet | Represents a LinkOne Search Set Definition.
SearchSetCollection | Represents a collection of Search Set definitions.
SearchWordMap | A searcher of words from embedded documents.

Structures

Structure | Description
SearchIndexPosition | The position of the search result in the index.
SearchLimit | Because it is possible for a LinkOne search to return large amounts of data, the LinkOne search allows a user to specify a limit for search results so that only records from the lower limit to the upper limit are returned.

Interfaces

Interface | Description
ISearch | Represents a LinkOne search.
ISearchCollection | Represents a collection of searches that can be individually accessed by index.
ISearchKey | Represents a search key for a LinkOne search.
ISearchKeyCollection | Represents a collection of search keys that can be individually accessed by index.
ISearchOverField | Implemented by classes that can supply search results.
ISearchParameter | Represents a search parameter for a LinkOne search.
ISearchParameterCollection | Represents a collection of search parameters that can be accessed by index.
ISearchResult | Represents a search result that can be used for matching back to a location in a LinkOne book.
ISearchResultCollection | Represents a collection of search results.
ISearchSet | Represents a LinkOne Search Set Definition.
ISearchSetCollection | Represents a collection of search sets that can be individually accessed by index.

Delegates

Delegate | Description
SearchProgressEventHandler | Delegate for SearchProgress events.

Enumerations

Enumeration | Description
Search..::.SearchLogic | Types of search logic.
Search..::.SearchSaveMode | Types of save mode.
Search..::.SearchSource | Types of search source.
SearchFieldMap..::.SpecialProcessingType | Defines the types of special processing that the LinkOne Book Builder can perform on a field before it is added to a search index.
SearchFieldType | The type of field to search on.
SearchResultCollection..::.SearchCompletionStatus | Describes how complete the search was, or if it was aborted.
SearchResultCollection..::.SearchWriteFlags | The available write flags that can be associated with a SearchResultCollection.
SearchResultScope | Specifies the type of search result.
SearchSetSourceType | The source of the search set.


ISearch Interface

[image]

LinkOne WebView API
ISearch Interface
Members See Also Send Feedback
Represents a LinkOne search.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ISearch
Visual Basic (Declaration)
Public Interface ISearch
Visual C++
public interface class ISearch

See Also

ISearch Members
Mincom.LinkOne.Dom.Searching Namespace


ISearch Members

[image] [image]

LinkOne WebView API
ISearch Members
ISearch Interface Methods Properties Events See Also Send Feedback

The ISearch type exposes the following members.

Methods

Name | Description
CreateSearchParameters | Creates an empty search parameter collection.
Execute | Executes the search with the given search parameters.

Properties

Name | Description
Description | Gets the description of the search.
Disabled | Gets a value indicating whether this ISearch is disabled.
Name | Gets the name of the search.
SearchKeys | Gets the collection of search key definitions associated with this search. A search may have 1 or 2 search keys associated with it.

Events

Name | Description
SearchProgress | Occurs as the search progresses.

See Also

ISearch Interface
Mincom.LinkOne.Dom.Searching Namespace


ISearch Methods

[image] [image]

LinkOne WebView API
ISearch Methods
ISearch Interface See Also Send Feedback

The ISearch type exposes the following members.

Methods

Name | Description
CreateSearchParameters | Creates an empty search parameter collection.
Execute | Executes the search with the given search parameters.

See Also

ISearch Interface
Mincom.LinkOne.Dom.Searching Namespace


CreateSearchParameters Method

[image]

LinkOne WebView API
ISearch..::.CreateSearchParameters Method
ISearch Interface See Also Send Feedback
Creates an empty search parameter collection.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ISearchParameterCollection CreateSearchParameters()
Visual Basic (Declaration)
Function CreateSearchParameters As ISearchParameterCollection
Visual C++
ISearchParameterCollection^ CreateSearchParameters()

Return Value

A new ISearchParameterCollection.

See Also

ISearch Interface
Mincom.LinkOne.Dom.Searching Namespace


Execute Method

[image]

LinkOne WebView API
ISearch..::.Execute Method
ISearch Interface See Also Send Feedback
Executes the search with the given search parameters.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ISearchResultCollection Execute(
    ICollection<IBook> books,
    ISearchParameterCollection searchParameters
)
Visual Basic (Declaration)
Function Execute ( _
    books As ICollection(Of IBook), _
    searchParameters As ISearchParameterCollection _
) As ISearchResultCollection
Visual C++
ISearchResultCollection^ Execute(
    ICollection<IBook^>^ books,
    ISearchParameterCollection^ searchParameters
)

Parameters

books
Type: System.Collections.Generic..::.ICollection<(Of <( IBook >)>)
The books to search.
searchParameters
Type: Mincom.LinkOne.Dom.Searching..::.ISearchParameterCollection
The search parameters.

Return Value

An ISearchResultCollection that contains the search results.

See Also

ISearch Interface
Mincom.LinkOne.Dom.Searching Namespace


ISearch Properties

[image] [image]

LinkOne WebView API
ISearch Properties
ISearch Interface See Also Send Feedback

The ISearch type exposes the following members.

Properties

Name | Description
Description | Gets the description of the search.
Disabled | Gets a value indicating whether this ISearch is disabled.
Name | Gets the name of the search.
SearchKeys | Gets the collection of search key definitions associated with this search. A search may have 1 or 2 search keys associated with it.

See Also

ISearch Interface
Mincom.LinkOne.Dom.Searching Namespace


Description Property

[image]

LinkOne WebView API
ISearch..::.Description Property
ISearch Interface See Also Send Feedback
Gets the description of the search.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Description { get; }
Visual Basic (Declaration)
ReadOnly Property Description As String
Visual C++
property String^ Description {
    String^ get ();
}

See Also

ISearch Interface
Mincom.LinkOne.Dom.Searching Namespace


Disabled Property

[image]

LinkOne WebView API
ISearch..::.Disabled Property
ISearch Interface See Also Send Feedback
Gets a value indicating whether this ISearch is disabled.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool Disabled { get; }
Visual Basic (Declaration)
ReadOnly Property Disabled As Boolean
Visual C++
property bool Disabled {
    bool get ();
}

See Also

ISearch Interface
Mincom.LinkOne.Dom.Searching Namespace


Name Property

[image]

LinkOne WebView API
ISearch..::.Name Property
ISearch Interface See Also Send Feedback
Gets the name of the search.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

ISearch Interface
Mincom.LinkOne.Dom.Searching Namespace


SearchKeys Property

[image]

LinkOne WebView API
ISearch..::.SearchKeys Property
ISearch Interface See Also Send Feedback
Gets the collection of search key definitions associated with this search. A search may have 1 or 2 search keys associated with it.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ISearchKeyCollection SearchKeys { get; }
Visual Basic (Declaration)
ReadOnly Property SearchKeys As ISearchKeyCollection
Visual C++
property ISearchKeyCollection^ SearchKeys {
    ISearchKeyCollection^ get ();
}

See Also

ISearch Interface
Mincom.LinkOne.Dom.Searching Namespace


ISearch Events

[image] [image]

LinkOne WebView API
ISearch Events
ISearch Interface See Also Send Feedback

The ISearch type exposes the following members.

Events

Name | Description
SearchProgress | Occurs as the search progresses.

See Also

ISearch Interface
Mincom.LinkOne.Dom.Searching Namespace


SearchProgress Event

[image]

LinkOne WebView API
ISearch..::.SearchProgress Event
ISearch Interface See Also Send Feedback
Occurs as the search progresses.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
event SearchProgressEventHandler SearchProgress
Visual Basic (Declaration)
Event SearchProgress As SearchProgressEventHandler
Visual C++
 event SearchProgressEventHandler^ SearchProgress {
    void add (SearchProgressEventHandler^ value);
    void remove (SearchProgressEventHandler^ value);
}

See Also

ISearch Interface
Mincom.LinkOne.Dom.Searching Namespace


ISearchCollection Interface

[image]

LinkOne WebView API
ISearchCollection Interface
Members See Also Send Feedback
Represents a collection of searches that can be individually accessed by index.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ISearchCollection : IReadOnlyKeyedCollection<string, ISearch>,
    IReadOnlyCollection<ISearch>, IEnumerable<ISearch>, IEnumerable
Visual Basic (Declaration)
Public Interface ISearchCollection _
    Implements IReadOnlyKeyedCollection(Of String, ISearch),  _
    IReadOnlyCollection(Of ISearch), IEnumerable(Of ISearch), IEnumerable
Visual C++
public interface class ISearchCollection : IReadOnlyKeyedCollection<String^, ISearch^>,
    IReadOnlyCollection<ISearch^>, IEnumerable<ISearch^>, IEnumerable

See Also

ISearchCollection Members
Mincom.LinkOne.Dom.Searching Namespace


ISearchCollection Members

[image] [image]

LinkOne WebView API
ISearchCollection Members
ISearchCollection Interface Methods Properties See Also Send Feedback

The ISearchCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
GetEnumerator | Overloaded.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item with the specified key. (Inherited from IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>).)

See Also

ISearchCollection Interface
Mincom.LinkOne.Dom.Searching Namespace


ISearchCollection Methods

[image] [image]

LinkOne WebView API
ISearchCollection Methods
ISearchCollection Interface See Also Send Feedback

Methods

Name | Description
Contains | Overloaded.
GetEnumerator | Overloaded.

See Also

ISearchCollection Interface
Mincom.LinkOne.Dom.Searching Namespace


Contains Method

[image] [image]

LinkOne WebView API
ISearchCollection..::.Contains Method
ISearchCollection Interface See Also Send Feedback

Overload List

Name | Description
Contains(T) | Determines whether an element is in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Contains(TKey) | Determines whether an element with the given key is in the collection. (Inherited from IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>).)

See Also

ISearchCollection Interface
ISearchCollection Members
Mincom.LinkOne.Dom.Searching Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
ISearchCollection..::.GetEnumerator Method
ISearchCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( ISearch >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

ISearchCollection Interface
ISearchCollection Members
Mincom.LinkOne.Dom.Searching Namespace


ISearchCollection Properties

[image] [image]

LinkOne WebView API
ISearchCollection Properties
ISearchCollection Interface See Also Send Feedback

The ISearchCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item with the specified key. (Inherited from IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>).)

See Also

ISearchCollection Interface
Mincom.LinkOne.Dom.Searching Namespace


ISearchKey Interface

[image]

LinkOne WebView API
ISearchKey Interface
Members See Also Send Feedback
Represents a search key for a LinkOne search.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ISearchKey
Visual Basic (Declaration)
Public Interface ISearchKey
Visual C++
public interface class ISearchKey

See Also

ISearchKey Members
Mincom.LinkOne.Dom.Searching Namespace


ISearchKey Members

[image] [image]

LinkOne WebView API
ISearchKey Members
ISearchKey Interface Properties See Also Send Feedback

The ISearchKey type exposes the following members.

Properties

Name | Description
Caption | Gets the caption of the search key.

See Also

ISearchKey Interface
Mincom.LinkOne.Dom.Searching Namespace


ISearchKey Properties

[image] [image]

LinkOne WebView API
ISearchKey Properties
ISearchKey Interface See Also Send Feedback

The ISearchKey type exposes the following members.

Properties

Name | Description
Caption | Gets the caption of the search key.

See Also

ISearchKey Interface
Mincom.LinkOne.Dom.Searching Namespace


Caption Property

[image]

LinkOne WebView API
ISearchKey..::.Caption Property
ISearchKey Interface See Also Send Feedback
Gets the caption of the search key.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Caption { get; }
Visual Basic (Declaration)
ReadOnly Property Caption As String
Visual C++
property String^ Caption {
    String^ get ();
}

See Also

ISearchKey Interface
Mincom.LinkOne.Dom.Searching Namespace


ISearchKeyCollection Interface

[image]

LinkOne WebView API
ISearchKeyCollection Interface
Members See Also Send Feedback
Represents a collection of search keys that can be individually accessed by index.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ISearchKeyCollection : IReadOnlyList<ISearchKey>,
    IReadOnlyCollection<ISearchKey>, IEnumerable<ISearchKey>, IEnumerable
Visual Basic (Declaration)
Public Interface ISearchKeyCollection _
    Implements IReadOnlyList(Of ISearchKey), IReadOnlyCollection(Of ISearchKey),  _
    IEnumerable(Of ISearchKey), IEnumerable
Visual C++
public interface class ISearchKeyCollection : IReadOnlyList<ISearchKey^>,
    IReadOnlyCollection<ISearchKey^>, IEnumerable<ISearchKey^>, IEnumerable

See Also

ISearchKeyCollection Members
Mincom.LinkOne.Dom.Searching Namespace


ISearchKeyCollection Members

[image] [image]

LinkOne WebView API
ISearchKeyCollection Members
ISearchKeyCollection Interface Methods Properties See Also Send Feedback

The ISearchKeyCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
GetEnumerator | Overloaded.
IndexOf | Searches the collection and returns the zero-based index of the first occurrence of the given item. (Inherited from IReadOnlyList<(Of <(T>)>).)

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from IReadOnlyList<(Of <(T>)>).)

See Also

ISearchKeyCollection Interface
Mincom.LinkOne.Dom.Searching Namespace


ISearchKeyCollection Methods

[image] [image]

LinkOne WebView API
ISearchKeyCollection Methods
ISearchKeyCollection Interface See Also Send Feedback

The ISearchKeyCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
GetEnumerator | Overloaded.
IndexOf | Searches the collection and returns the zero-based index of the first occurrence of the given item. (Inherited from IReadOnlyList<(Of <(T>)>).)

See Also

ISearchKeyCollection Interface
Mincom.LinkOne.Dom.Searching Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
ISearchKeyCollection..::.GetEnumerator Method
ISearchKeyCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( ISearchKey >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

ISearchKeyCollection Interface
ISearchKeyCollection Members
Mincom.LinkOne.Dom.Searching Namespace


ISearchKeyCollection Properties

[image] [image]

LinkOne WebView API
ISearchKeyCollection Properties
ISearchKeyCollection Interface See Also Send Feedback

The ISearchKeyCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from IReadOnlyList<(Of <(T>)>).)

See Also

ISearchKeyCollection Interface
Mincom.LinkOne.Dom.Searching Namespace


ISearchOverField Interface

[image]

LinkOne WebView API
ISearchOverField Interface
Members See Also Send Feedback
Implemented by classes that can supply search results.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ISearchOverField
Visual Basic (Declaration)
Public Interface ISearchOverField
Visual C++
public interface class ISearchOverField

See Also

ISearchOverField Members
Mincom.LinkOne.Dom.Searching Namespace


ISearchOverField Members

[image] [image]

LinkOne WebView API
ISearchOverField Members
ISearchOverField Interface Methods Events See Also Send Feedback

The ISearchOverField type exposes the following members.

Methods

Name | Description
Find | Returns the collection of search results that match the given value.

Events

Name | Description
SearchProgress | This event provides updates on the progress of a search.

See Also

ISearchOverField Interface
Mincom.LinkOne.Dom.Searching Namespace


ISearchOverField Methods

[image] [image]

LinkOne WebView API
ISearchOverField Methods
ISearchOverField Interface See Also Send Feedback

The ISearchOverField type exposes the following members.

Methods

Name | Description
Find | Returns the collection of search results that match the given value.

See Also

ISearchOverField Interface
Mincom.LinkOne.Dom.Searching Namespace


Find Method

[image]

LinkOne WebView API
ISearchOverField..::.Find Method
ISearchOverField Interface See Also Send Feedback
Returns the collection of search results that match the given value.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
SearchResultCollection Find(
    string value,
    bool matchCase,
    bool exactMatch,
    Regex noiseFilter,
    string displayField,
    string preferredListTitle,
    string languageCode
)
Visual Basic (Declaration)
Function Find ( _
    value As String, _
    matchCase As Boolean, _
    exactMatch As Boolean, _
    noiseFilter As Regex, _
    displayField As String, _
    preferredListTitle As String, _
    languageCode As String _
) As SearchResultCollection
Visual C++
SearchResultCollection^ Find(
    String^ value,
    bool matchCase,
    bool exactMatch,
    Regex^ noiseFilter,
    String^ displayField,
    String^ preferredListTitle,
    String^ languageCode
)

Parameters

value
Type: System..::.String
The value to search for.
matchCase
Type: System..::.Boolean
True to match the case during the search.
exactMatch
Type: System..::.Boolean
True to match the full value length.
noiseFilter
Type: System.Text.RegularExpressions..::.Regex
Regular expression to apply to the searched string prior to searching it.
displayField
Type: System..::.String
The display field to choose for each result.
preferredListTitle
Type: System..::.String
The preferred list title.
languageCode
Type: System..::.String
The language code.

Return Value

The collection of search results that match the given value.

See Also

ISearchOverField Interface
Mincom.LinkOne.Dom.Searching Namespace


ISearchOverField Events

[image] [image]

LinkOne WebView API
ISearchOverField Events
ISearchOverField Interface See Also Send Feedback

The ISearchOverField type exposes the following members.

Events

Name | Description
SearchProgress | This event provides updates on the progress of a search.

See Also

ISearchOverField Interface
Mincom.LinkOne.Dom.Searching Namespace


SearchProgress Event

[image]

LinkOne WebView API
ISearchOverField..::.SearchProgress Event
ISearchOverField Interface See Also Send Feedback
This event provides updates on the progress of a search.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
event SearchProgressEventHandler SearchProgress
Visual Basic (Declaration)
Event SearchProgress As SearchProgressEventHandler
Visual C++
 event SearchProgressEventHandler^ SearchProgress {
    void add (SearchProgressEventHandler^ value);
    void remove (SearchProgressEventHandler^ value);
}

See Also

ISearchOverField Interface
Mincom.LinkOne.Dom.Searching Namespace


ISearchParameter Interface

[image]

LinkOne WebView API
ISearchParameter Interface
Members See Also Send Feedback
Represents a search parameter for a LinkOne search.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ISearchParameter
Visual Basic (Declaration)
Public Interface ISearchParameter
Visual C++
public interface class ISearchParameter

See Also

ISearchParameter Members
Mincom.LinkOne.Dom.Searching Namespace


ISearchParameter Members

[image] [image]

LinkOne WebView API
ISearchParameter Members
ISearchParameter Interface Properties See Also Send Feedback

The ISearchParameter type exposes the following members.

Properties

Name | Description
ExactMatch | Gets or sets a value indicating the value must be an exact match.
MatchCase | Gets or sets whether the value is case sensitive.
Value | Gets or sets the value to search for.

See Also

ISearchParameter Interface
Mincom.LinkOne.Dom.Searching Namespace


ISearchParameter Properties

[image] [image]

LinkOne WebView API
ISearchParameter Properties
ISearchParameter Interface See Also Send Feedback

The ISearchParameter type exposes the following members.

Properties

Name | Description
ExactMatch | Gets or sets a value indicating the value must be an exact match.
MatchCase | Gets or sets whether the value is case sensitive.
Value | Gets or sets the value to search for.

See Also

ISearchParameter Interface
Mincom.LinkOne.Dom.Searching Namespace


ExactMatch Property

[image]

LinkOne WebView API
ISearchParameter..::.ExactMatch Property
ISearchParameter Interface See Also Send Feedback
Gets or sets a value indicating the value must be an exact match.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ExactMatch { get; set; }
Visual Basic (Declaration)
Property ExactMatch As Boolean
Visual C++
property bool ExactMatch {
    bool get ();
    void set (bool value);
}

See Also

ISearchParameter Interface
Mincom.LinkOne.Dom.Searching Namespace


MatchCase Property

[image]

LinkOne WebView API
ISearchParameter..::.MatchCase Property
ISearchParameter Interface See Also Send Feedback
Gets or sets whether the value is case sensitive.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool MatchCase { get; set; }
Visual Basic (Declaration)
Property MatchCase As Boolean
Visual C++
property bool MatchCase {
    bool get ();
    void set (bool value);
}

See Also

ISearchParameter Interface
Mincom.LinkOne.Dom.Searching Namespace


Value Property

[image]

LinkOne WebView API
ISearchParameter..::.Value Property
ISearchParameter Interface See Also Send Feedback
Gets or sets the value to search for.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Value { get; set; }
Visual Basic (Declaration)
Property Value As String
Visual C++
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

ISearchParameter Interface
Mincom.LinkOne.Dom.Searching Namespace


ISearchParameterCollection Interface

[image]

LinkOne WebView API
ISearchParameterCollection Interface
Members See Also Send Feedback
Represents a collection of search parameters that can be accessed by index.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ISearchParameterCollection : IList<ISearchParameter>,
    ICollection<ISearchParameter>, IEnumerable<ISearchParameter>, IEnumerable
Visual Basic (Declaration)
Public Interface ISearchParameterCollection _
    Implements IList(Of ISearchParameter), ICollection(Of ISearchParameter),  _
    IEnumerable(Of ISearchParameter), IEnumerable
Visual C++
public interface class ISearchParameterCollection : IList<ISearchParameter^>,
    ICollection<ISearchParameter^>, IEnumerable<ISearchParameter^>, IEnumerable

See Also

ISearchParameterCollection Members
Mincom.LinkOne.Dom.Searching Namespace


ISearchParameterCollection Members

[image] [image]

LinkOne WebView API
ISearchParameterCollection Members
ISearchParameterCollection Interface Methods Properties See Also Send Feedback

The ISearchParameterCollection type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ISearchParameter >)>).)
Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from ICollection<(Of <( ISearchParameter >)>).)
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( ISearchParameter >)>).)
GetEnumerator | Overloaded.
IndexOf | Determines the index of a specific item in the IList<(Of <(T>)>). (Inherited from IList<(Of <( ISearchParameter >)>).)
Insert | Inserts an item to the IList<(Of <(T>)>) at the specified index. (Inherited from IList<(Of <( ISearchParameter >)>).)
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ISearchParameter >)>).)
RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index. (Inherited from IList<(Of <( ISearchParameter >)>).)

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ISearchParameter >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( ISearchParameter >)>).)
Item | Gets or sets the element at the specified index. (Inherited from IList<(Of <( ISearchParameter >)>).)
LanguageCode | Gets or sets the ISO-639 language code of the search.
PreferredListTitle | Gets or sets the preferred list title to use when displaying search results.

See Also

ISearchParameterCollection Interface
Mincom.LinkOne.Dom.Searching Namespace


ISearchParameterCollection Methods

[image] [image]

LinkOne WebView API
ISearchParameterCollection Methods
ISearchParameterCollection Interface See Also Send Feedback

The ISearchParameterCollection type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ISearchParameter >)>).)
Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from ICollection<(Of <( ISearchParameter >)>).)
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( ISearchParameter >)>).)
GetEnumerator | Overloaded.
IndexOf | Determines the index of a specific item in the IList<(Of <(T>)>). (Inherited from IList<(Of <( ISearchParameter >)>).)
Insert | Inserts an item to the IList<(Of <(T>)>) at the specified index. (Inherited from IList<(Of <( ISearchParameter >)>).)
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ISearchParameter >)>).)
RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index. (Inherited from IList<(Of <( ISearchParameter >)>).)

See Also

ISearchParameterCollection Interface
Mincom.LinkOne.Dom.Searching Namespace


Add Method

[image] [image]

LinkOne WebView API
ISearchParameterCollection..::.Add Method
ISearchParameterCollection Interface See Also Send Feedback

Overload List

Name | Description
Add(T) | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ISearchParameter >)>).)
Add(String, Boolean, Boolean) | Adds a search parameter initialized with the given values.

See Also

ISearchParameterCollection Interface
ISearchParameterCollection Members
Mincom.LinkOne.Dom.Searching Namespace


Add Method (String, Boolean, Boolean)

[image]

LinkOne WebView API
ISearchParameterCollection..::.Add Method (String, Boolean, Boolean)
ISearchParameterCollection Interface See Also Send Feedback
Adds a search parameter initialized with the given values.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void Add(
    string value,
    bool matchCase,
    bool exactMatch
)
Visual Basic (Declaration)
Sub Add ( _
    value As String, _
    matchCase As Boolean, _
    exactMatch As Boolean _
)
Visual C++
void Add(
    String^ value,
    bool matchCase,
    bool exactMatch
)

Parameters

value
Type: System..::.String
The value.
matchCase
Type: System..::.Boolean
Whether the value is case-sensitive.
exactMatch
Type: System..::.Boolean
Whether the value should be matched exactly.

See Also

ISearchParameterCollection Interface
Add Overload
Mincom.LinkOne.Dom.Searching Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
ISearchParameterCollection..::.GetEnumerator Method
ISearchParameterCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( ISearchParameter >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

ISearchParameterCollection Interface
ISearchParameterCollection Members
Mincom.LinkOne.Dom.Searching Namespace


ISearchParameterCollection Properties

[image] [image]

LinkOne WebView API
ISearchParameterCollection Properties
ISearchParameterCollection Interface See Also Send Feedback

The ISearchParameterCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ISearchParameter >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( ISearchParameter >)>).)
Item | Gets or sets the element at the specified index. (Inherited from IList<(Of <( ISearchParameter >)>).)
LanguageCode | Gets or sets the ISO-639 language code of the search.
PreferredListTitle | Gets or sets the preferred list title to use when displaying search results.

See Also

ISearchParameterCollection Interface
Mincom.LinkOne.Dom.Searching Namespace


LanguageCode Property

[image]

LinkOne WebView API
ISearchParameterCollection..::.LanguageCode Property
ISearchParameterCollection Interface See Also Send Feedback
Gets or sets the ISO-639 language code of the search.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string LanguageCode { get; set; }
Visual Basic (Declaration)
Property LanguageCode As String
Visual C++
property String^ LanguageCode {
    String^ get ();
    void set (String^ value);
}

See Also

ISearchParameterCollection Interface
Mincom.LinkOne.Dom.Searching Namespace


PreferredListTitle Property

[image]

LinkOne WebView API
ISearchParameterCollection..::.PreferredListTitle Property
ISearchParameterCollection Interface See Also Send Feedback
Gets or sets the preferred list title to use when displaying search results.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string PreferredListTitle { get; set; }
Visual Basic (Declaration)
Property PreferredListTitle As String
Visual C++
property String^ PreferredListTitle {
    String^ get ();
    void set (String^ value);
}

See Also

ISearchParameterCollection Interface
Mincom.LinkOne.Dom.Searching Namespace


ISearchResult Interface

[image]

LinkOne WebView API
ISearchResult Interface
Members See Also Send Feedback
Represents a search result that can be used for matching back to a location in a LinkOne book.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ISearchResult
Visual Basic (Declaration)
Public Interface ISearchResult
Visual C++
public interface class ISearchResult

See Also

ISearchResult Members
Mincom.LinkOne.Dom.Searching Namespace


ISearchResult Members

[image] [image]

LinkOne WebView API
ISearchResult Members
ISearchResult Interface Properties See Also Send Feedback

The ISearchResult type exposes the following members.

Properties

Name | Description
BookCode | Gets the book code.
BookTitle | Gets the book title.
DisplayedItemId | Gets the display version of the Item Id that has ignored content filtered out.
DisplayValue | Gets the display value.
ItemId | Gets the item identifier.
ItemTag | Gets the item tag.
PageNumber | Gets the page number.
PageReference | Gets the page reference.
PageTitle | Gets the page title.
PublisherCode | Gets the publisher code.

See Also

ISearchResult Interface
Mincom.LinkOne.Dom.Searching Namespace


ISearchResult Properties

[image] [image]

LinkOne WebView API
ISearchResult Properties
ISearchResult Interface See Also Send Feedback

The ISearchResult type exposes the following members.

Properties

Name | Description
BookCode | Gets the book code.
BookTitle | Gets the book title.
DisplayedItemId | Gets the display version of the Item Id that has ignored content filtered out.
DisplayValue | Gets the display value.
ItemId | Gets the item identifier.
ItemTag | Gets the item tag.
PageNumber | Gets the page number.
PageReference | Gets the page reference.
PageTitle | Gets the page title.
PublisherCode | Gets the publisher code.

See Also

ISearchResult Interface
Mincom.LinkOne.Dom.Searching Namespace


BookCode Property

[image]

LinkOne WebView API
ISearchResult..::.BookCode Property
ISearchResult Interface See Also Send Feedback
Gets the book code.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string BookCode { get; }
Visual Basic (Declaration)
ReadOnly Property BookCode As String
Visual C++
property String^ BookCode {
    String^ get ();
}

See Also

ISearchResult Interface
Mincom.LinkOne.Dom.Searching Namespace


BookTitle Property

[image]

LinkOne WebView API
ISearchResult..::.BookTitle Property
ISearchResult Interface See Also Send Feedback
Gets the book title.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string BookTitle { get; }
Visual Basic (Declaration)
ReadOnly Property BookTitle As String
Visual C++
property String^ BookTitle {
    String^ get ();
}

See Also

ISearchResult Interface
Mincom.LinkOne.Dom.Searching Namespace


DisplayedItemId Property

[image]

LinkOne WebView API
ISearchResult..::.DisplayedItemId Property
ISearchResult Interface See Also Send Feedback
Gets the display version of the Item Id that has ignored content filtered out.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string DisplayedItemId { get; }
Visual Basic (Declaration)
ReadOnly Property DisplayedItemId As String
Visual C++
property String^ DisplayedItemId {
    String^ get ();
}

See Also

ISearchResult Interface
Mincom.LinkOne.Dom.Searching Namespace


DisplayValue Property

[image]

LinkOne WebView API
ISearchResult..::.DisplayValue Property
ISearchResult Interface See Also Send Feedback
Gets the display value.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string DisplayValue { get; }
Visual Basic (Declaration)
ReadOnly Property DisplayValue As String
Visual C++
property String^ DisplayValue {
    String^ get ();
}

See Also

ISearchResult Interface
Mincom.LinkOne.Dom.Searching Namespace


ItemId Property

[image]

LinkOne WebView API
ISearchResult..::.ItemId Property
ISearchResult Interface See Also Send Feedback
Gets the item identifier.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string ItemId { get; }
Visual Basic (Declaration)
ReadOnly Property ItemId As String
Visual C++
property String^ ItemId {
    String^ get ();
}

See Also

ISearchResult Interface
Mincom.LinkOne.Dom.Searching Namespace


ItemTag Property

[image]

LinkOne WebView API
ISearchResult..::.ItemTag Property
ISearchResult Interface See Also Send Feedback
Gets the item tag.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int ItemTag { get; }
Visual Basic (Declaration)
ReadOnly Property ItemTag As Integer
Visual C++
property int ItemTag {
    int get ();
}

See Also

ISearchResult Interface
Mincom.LinkOne.Dom.Searching Namespace


PageNumber Property

[image]

LinkOne WebView API
ISearchResult..::.PageNumber Property
ISearchResult Interface See Also Send Feedback
Gets the page number.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string PageNumber { get; }
Visual Basic (Declaration)
ReadOnly Property PageNumber As String
Visual C++
property String^ PageNumber {
    String^ get ();
}

See Also

ISearchResult Interface
Mincom.LinkOne.Dom.Searching Namespace


PageReference Property

[image]

LinkOne WebView API
ISearchResult..::.PageReference Property
ISearchResult Interface See Also Send Feedback
Gets the page reference.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string PageReference { get; }
Visual Basic (Declaration)
ReadOnly Property PageReference As String
Visual C++
property String^ PageReference {
    String^ get ();
}

See Also

ISearchResult Interface
Mincom.LinkOne.Dom.Searching Namespace


PageTitle Property

[image]

LinkOne WebView API
ISearchResult..::.PageTitle Property
ISearchResult Interface See Also Send Feedback
Gets the page title.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string PageTitle { get; }
Visual Basic (Declaration)
ReadOnly Property PageTitle As String
Visual C++
property String^ PageTitle {
    String^ get ();
}

See Also

ISearchResult Interface
Mincom.LinkOne.Dom.Searching Namespace


PublisherCode Property

[image]

LinkOne WebView API
ISearchResult..::.PublisherCode Property
ISearchResult Interface See Also Send Feedback
Gets the publisher code.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string PublisherCode { get; }
Visual Basic (Declaration)
ReadOnly Property PublisherCode As String
Visual C++
property String^ PublisherCode {
    String^ get ();
}

See Also

ISearchResult Interface
Mincom.LinkOne.Dom.Searching Namespace


ISearchResultCollection Interface

[image]

LinkOne WebView API
ISearchResultCollection Interface
Members See Also Send Feedback
Represents a collection of search results.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ISearchResultCollection : IReadOnlyList<ISearchResult>,
    IReadOnlyCollection<ISearchResult>, IEnumerable<ISearchResult>, IEnumerable,
    IPersist
Visual Basic (Declaration)
Public Interface ISearchResultCollection _
    Implements IReadOnlyList(Of ISearchResult), IReadOnlyCollection(Of ISearchResult),  _
    IEnumerable(Of ISearchResult), IEnumerable, IPersist
Visual C++
public interface class ISearchResultCollection : IReadOnlyList<ISearchResult^>,
    IReadOnlyCollection<ISearchResult^>, IEnumerable<ISearchResult^>, IEnumerable,
    IPersist

See Also

ISearchResultCollection Members
Mincom.LinkOne.Dom.Searching Namespace


ISearchResultCollection Members

[image] [image]

LinkOne WebView API
ISearchResultCollection Members
ISearchResultCollection Interface Methods Properties See Also Send Feedback

The ISearchResultCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
GetEnumerator | Overloaded.
IndexOf | Searches the collection and returns the zero-based index of the first occurrence of the given item. (Inherited from IReadOnlyList<(Of <(T>)>).)

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from IReadOnlyList<(Of <(T>)>).)

See Also

ISearchResultCollection Interface
Mincom.LinkOne.Dom.Searching Namespace


ISearchResultCollection Methods

[image] [image]

LinkOne WebView API
ISearchResultCollection Methods
ISearchResultCollection Interface See Also Send Feedback

The ISearchResultCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
GetEnumerator | Overloaded.
IndexOf | Searches the collection and returns the zero-based index of the first occurrence of the given item. (Inherited from IReadOnlyList<(Of <(T>)>).)

See Also

ISearchResultCollection Interface
Mincom.LinkOne.Dom.Searching Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
ISearchResultCollection..::.GetEnumerator Method
ISearchResultCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( ISearchResult >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

ISearchResultCollection Interface
ISearchResultCollection Members
Mincom.LinkOne.Dom.Searching Namespace


ISearchResultCollection Properties

[image] [image]

LinkOne WebView API
ISearchResultCollection Properties
ISearchResultCollection Interface See Also Send Feedback

The ISearchResultCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from IReadOnlyList<(Of <(T>)>).)

See Also

ISearchResultCollection Interface
Mincom.LinkOne.Dom.Searching Namespace


ISearchSet Interface

[image]

LinkOne WebView API
ISearchSet Interface
Members See Also Send Feedback
Represents a LinkOne Search Set Definition.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ISearchSet
Visual Basic (Declaration)
Public Interface ISearchSet
Visual C++
public interface class ISearchSet

See Also

ISearchSet Members
Mincom.LinkOne.Dom.Searching Namespace


ISearchSet Members

[image] [image]

LinkOne WebView API
ISearchSet Members
ISearchSet Interface Properties See Also Send Feedback

The ISearchSet type exposes the following members.

Properties

Name | Description
Description | Gets the search set description.
LanguageCode | Gets the ISO-639 compliant language code of the search set.
Name | Gets the name of the search set.
Searches | Gets the searches that belong to the search set.
SecurityLock | Gets the security lock.
Source | Gets the search set source type.

See Also

ISearchSet Interface
Mincom.LinkOne.Dom.Searching Namespace


ISearchSet Properties

[image] [image]

LinkOne WebView API
ISearchSet Properties
ISearchSet Interface See Also Send Feedback

The ISearchSet type exposes the following members.

Properties

Name | Description
Description | Gets the search set description.
LanguageCode | Gets the ISO-639 compliant language code of the search set.
Name | Gets the name of the search set.
Searches | Gets the searches that belong to the search set.
SecurityLock | Gets the security lock.
Source | Gets the search set source type.

See Also

ISearchSet Interface
Mincom.LinkOne.Dom.Searching Namespace


Description Property

[image]

LinkOne WebView API
ISearchSet..::.Description Property
ISearchSet Interface See Also Send Feedback
Gets the search set description.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Description { get; }
Visual Basic (Declaration)
ReadOnly Property Description As String
Visual C++
property String^ Description {
    String^ get ();
}

See Also

ISearchSet Interface
Mincom.LinkOne.Dom.Searching Namespace


LanguageCode Property

[image]

LinkOne WebView API
ISearchSet..::.LanguageCode Property
ISearchSet Interface See Also Send Feedback
Gets the ISO-639 compliant language code of the search set.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string LanguageCode { get; }
Visual Basic (Declaration)
ReadOnly Property LanguageCode As String
Visual C++
property String^ LanguageCode {
    String^ get ();
}

See Also

ISearchSet Interface
Mincom.LinkOne.Dom.Searching Namespace


Name Property

[image]

LinkOne WebView API
ISearchSet..::.Name Property
ISearchSet Interface See Also Send Feedback
Gets the name of the search set.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

ISearchSet Interface
Mincom.LinkOne.Dom.Searching Namespace


Searches Property

[image]

LinkOne WebView API
ISearchSet..::.Searches Property
ISearchSet Interface See Also Send Feedback
Gets the searches that belong to the search set.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ISearchCollection Searches { get; }
Visual Basic (Declaration)
ReadOnly Property Searches As ISearchCollection
Visual C++
property ISearchCollection^ Searches {
    ISearchCollection^ get ();
}

See Also

ISearchSet Interface
Mincom.LinkOne.Dom.Searching Namespace


SecurityLock Property

[image]

LinkOne WebView API
ISearchSet..::.SecurityLock Property
ISearchSet Interface See Also Send Feedback
Gets the security lock.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string SecurityLock { get; }
Visual Basic (Declaration)
ReadOnly Property SecurityLock As String
Visual C++
property String^ SecurityLock {
    String^ get ();
}

See Also

ISearchSet Interface
Mincom.LinkOne.Dom.Searching Namespace


Source Property

[image]

LinkOne WebView API
ISearchSet..::.Source Property
ISearchSet Interface See Also Send Feedback
Gets the search set source type.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
SearchSetSourceType Source { get; }
Visual Basic (Declaration)
ReadOnly Property Source As SearchSetSourceType
Visual C++
property SearchSetSourceType Source {
    SearchSetSourceType get ();
}

See Also

ISearchSet Interface
Mincom.LinkOne.Dom.Searching Namespace


ISearchSetCollection Interface

[image]

LinkOne WebView API
ISearchSetCollection Interface
Members See Also Send Feedback
Represents a collection of search sets that can be individually accessed by index.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ISearchSetCollection : IReadOnlyList<ISearchSet>,
    IReadOnlyCollection<ISearchSet>, IEnumerable<ISearchSet>, IEnumerable
Visual Basic (Declaration)
Public Interface ISearchSetCollection _
    Implements IReadOnlyList(Of ISearchSet), IReadOnlyCollection(Of ISearchSet),  _
    IEnumerable(Of ISearchSet), IEnumerable
Visual C++
public interface class ISearchSetCollection : IReadOnlyList<ISearchSet^>,
    IReadOnlyCollection<ISearchSet^>, IEnumerable<ISearchSet^>, IEnumerable

See Also

ISearchSetCollection Members
Mincom.LinkOne.Dom.Searching Namespace


ISearchSetCollection Members

[image] [image]

LinkOne WebView API
ISearchSetCollection Members
ISearchSetCollection Interface Methods Properties See Also Send Feedback

The ISearchSetCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
GetEnumerator | Overloaded.
IndexOf | Searches the collection and returns the zero-based index of the first occurrence of the given item. (Inherited from IReadOnlyList<(Of <(T>)>).)

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from IReadOnlyList<(Of <(T>)>).)

See Also

ISearchSetCollection Interface
Mincom.LinkOne.Dom.Searching Namespace


ISearchSetCollection Methods

[image] [image]

LinkOne WebView API
ISearchSetCollection Methods
ISearchSetCollection Interface See Also Send Feedback

The ISearchSetCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
GetEnumerator | Overloaded.
IndexOf | Searches the collection and returns the zero-based index of the first occurrence of the given item. (Inherited from IReadOnlyList<(Of <(T>)>).)

See Also

ISearchSetCollection Interface
Mincom.LinkOne.Dom.Searching Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
ISearchSetCollection..::.GetEnumerator Method
ISearchSetCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( ISearchSet >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

ISearchSetCollection Interface
ISearchSetCollection Members
Mincom.LinkOne.Dom.Searching Namespace


ISearchSetCollection Properties

[image] [image]

LinkOne WebView API
ISearchSetCollection Properties
ISearchSetCollection Interface See Also Send Feedback

The ISearchSetCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from IReadOnlyCollection<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from IReadOnlyList<(Of <(T>)>).)

See Also

ISearchSetCollection Interface
Mincom.LinkOne.Dom.Searching Namespace


Search Class

[image]

LinkOne WebView API
Search Class
Members See Also Send Feedback
Represents a LinkOne search definition.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class Search : ISearch
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class Search _
    Implements ISearch
Visual C++
[SerializableAttribute]
public ref class Search sealed : ISearch

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Searching..::.Search

See Also

Search Members
Mincom.LinkOne.Dom.Searching Namespace


Search Members

[image] [image]

LinkOne WebView API
Search Members
Search Class Constructors Methods Properties Events Explicit Interface Implementations See Also Send Feedback

The Search type exposes the following members.

Constructors

Name | Description
Search | Initializes a new instance of the Search class.

Methods

Name | Description
CreateSearchParameters | Creates an empty search parameter collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IsEquivalent | Determines whether the specified search is equivalent.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Description | Gets or sets the search description.
Disabled | Gets or sets the Search Disabled property.
DisplayField | Gets the display field.
DisplayFieldItemDescription | Gets the description for the matching value of a search result item component.
Logic | Gets or sets the search logic.
MenuEntry | Gets or sets the menu entry text.
Name | Gets or sets the search name.
ResultsCaption | Gets or sets the search results caption.
SaveMode | Gets or sets the serch save mode.
SearchKeys | Gets the collection of search key definitions associated with this search. A search may have 1 or 2 search keys associated with it.
Source | Gets or sets the search source.

Events

Name | Description
SearchProgress | Occurs as the search progresses.

Explicit Interface Implementations

Name | Description
ISearch..::.Execute |
ISearch..::.SearchKeys |

See Also

Search Class
Mincom.LinkOne.Dom.Searching Namespace


Search Constructor

[image]

LinkOne WebView API
Search Constructor
Search Class See Also Send Feedback
Initializes a new instance of the Search class.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Search(
    IDomReader domReader
)
Visual Basic (Declaration)
Public Sub New ( _
    domReader As IDomReader _
)
Visual C++
public:
Search(
    IDomReader^ domReader
)

Parameters

domReader
Type: IDomReader
The search reader object providing the initialisation data.

See Also

Search Class
Mincom.LinkOne.Dom.Searching Namespace


Search Methods

[image] [image]

LinkOne WebView API
Search Methods
Search Class See Also Send Feedback

The Search type exposes the following members.

Methods

Name | Description
CreateSearchParameters | Creates an empty search parameter collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IsEquivalent | Determines whether the specified search is equivalent.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ISearch..::.Execute |

See Also

Search Class
Mincom.LinkOne.Dom.Searching Namespace


CreateSearchParameters Method

[image]

LinkOne WebView API
Search..::.CreateSearchParameters Method
Search Class See Also Send Feedback
Creates an empty search parameter collection.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ISearchParameterCollection CreateSearchParameters()
Visual Basic (Declaration)
Public Function CreateSearchParameters As ISearchParameterCollection
Visual C++
public:
virtual ISearchParameterCollection^ CreateSearchParameters() sealed

Return Value

A new ISearchParameterCollection.

Implements

ISearch..::.CreateSearchParameters()()()

See Also

Search Class
Mincom.LinkOne.Dom.Searching Namespace


Execute Method

[image] [image]

LinkOne WebView API
Search..::.Execute Method
Search Class See Also Send Feedback

Overload List

Name | Description
Execute(ICollection<(Of <(Book>)>), SearchParameterCollection) | Execute the search on the given book collection.
Execute(ICollection<(Of <(Book>)>), SearchParameterCollection, SearchLimit) | Execute the search on the given book collection.

See Also

Search Class
Search Members
Mincom.LinkOne.Dom.Searching Namespace


Execute Method (ICollection(Book), SearchParameterCollection)

[image]

LinkOne WebView API
Search..::.Execute Method (ICollection<(Of <(Book>)>), SearchParameterCollection)
Search Class See Also Send Feedback
Execute the search on the given book collection.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchResultCollection Execute(
    ICollection<Book> books,
    SearchParameterCollection searchParameters
)
Visual Basic (Declaration)
Public Function Execute ( _
    books As ICollection(Of Book), _
    searchParameters As SearchParameterCollection _
) As SearchResultCollection
Visual C++
public:
SearchResultCollection^ Execute(
    ICollection<Book^>^ books,
    SearchParameterCollection^ searchParameters
)

Parameters

books
Type: System.Collections.Generic..::.ICollection<(Of <( Book >)>)
The books to run the search on.
searchParameters
Type: Mincom.LinkOne.Dom.Searching..::.SearchParameterCollection
The search parameters.

Return Value

The collection of search results.

Exceptions

Exception | Condition
System..::.ArgumentNullException | searchParameters is null. -or- books is null.
System..::.ArgumentException | There were fewer searchParametersi> than SearchKeys.
Mincom.LinkOne.Exceptions..::.SearchDisabledException | The search is disabled.
System..::.NotSupportedException | The search set has defined less than 1 key, or more than 2 keys.

See Also

Search Class
Execute Overload
Mincom.LinkOne.Dom.Searching Namespace


Execute Method (ICollection(Book), SearchParameterCollection, SearchLimit)

[image]

LinkOne WebView API
Search..::.Execute Method (ICollection<(Of <(Book>)>), SearchParameterCollection, SearchLimit)
Search Class See Also Send Feedback
Execute the search on the given book collection.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchResultCollection Execute(
    ICollection<Book> books,
    SearchParameterCollection searchParameters,
    SearchLimit limit
)
Visual Basic (Declaration)
Public Function Execute ( _
    books As ICollection(Of Book), _
    searchParameters As SearchParameterCollection, _
    limit As SearchLimit _
) As SearchResultCollection
Visual C++
public:
SearchResultCollection^ Execute(
    ICollection<Book^>^ books,
    SearchParameterCollection^ searchParameters,
    SearchLimit limit
)

Parameters

books
Type: System.Collections.Generic..::.ICollection<(Of <( Book >)>)
The books to run the search on.
searchParameters
Type: Mincom.LinkOne.Dom.Searching..::.SearchParameterCollection
The search parameters.
limit
Type: Mincom.LinkOne.Dom.Searching..::.SearchLimit
The limit for the search results to be returned

Return Value

The collection of search results.

Exceptions

Exception | Condition
System..::.ArgumentNullException | searchParameters is null. -or- books is null.
System..::.ArgumentException | There were fewer searchParametersi> than SearchKeys.
Mincom.LinkOne.Exceptions..::.SearchDisabledException | The search is disabled.
System..::.NotSupportedException | The search set has defined less than 1 key, or more than 2 keys.

See Also

Search Class
Execute Overload
Mincom.LinkOne.Dom.Searching Namespace


ISearch.Execute Method

[image]

LinkOne WebView API
Search..::.ISearch..::.Execute Method
Search Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ISearchResultCollection ISearch.Execute(
    ICollection<IBook> books,
    ISearchParameterCollection searchParameters
)
Visual Basic (Declaration)
Private Function Execute ( _
    books As ICollection(Of IBook), _
    searchParameters As ISearchParameterCollection _
) As ISearchResultCollection Implements ISearch.Execute
Visual C++
private:
virtual ISearchResultCollection^ Execute(
    ICollection<IBook^>^ books,
    ISearchParameterCollection^ searchParameters
) sealed = ISearch::Execute

Parameters

books
Type: System.Collections.Generic..::.ICollection<(Of <( IBook >)>)
searchParameters
Type: Mincom.LinkOne.Dom.Searching..::.ISearchParameterCollection

Implements

ISearch..::.Execute(ICollection<(Of <(IBook>)>), ISearchParameterCollection)

See Also

Search Class
Mincom.LinkOne.Dom.Searching Namespace


IsEquivalent Method

[image]

LinkOne WebView API
Search..::.IsEquivalent Method
Search Class See Also Send Feedback
Determines whether the specified search is equivalent.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsEquivalent(
    Search search
)
Visual Basic (Declaration)
Public Function IsEquivalent ( _
    search As Search _
) As Boolean
Visual C++
public:
bool IsEquivalent(
    Search^ search
)

Parameters

search
Type: Mincom.LinkOne.Dom.Searching..::.Search
The search to test.

Return Value

tru if the specified search is equivalent.

See Also

Search Class
Mincom.LinkOne.Dom.Searching Namespace


Search Properties

[image] [image]

LinkOne WebView API
Search Properties
Search Class See Also Send Feedback

The Search type exposes the following members.

Properties

Name | Description
Description | Gets or sets the search description.
Disabled | Gets or sets the Search Disabled property.
DisplayField | Gets the display field.
DisplayFieldItemDescription | Gets the description for the matching value of a search result item component.
Logic | Gets or sets the search logic.
MenuEntry | Gets or sets the menu entry text.
Name | Gets or sets the search name.
ResultsCaption | Gets or sets the search results caption.
SaveMode | Gets or sets the serch save mode.
SearchKeys | Gets the collection of search key definitions associated with this search. A search may have 1 or 2 search keys associated with it.
Source | Gets or sets the search source.

Explicit Interface Implementations

Name | Description
ISearch..::.SearchKeys |

See Also

Search Class
Mincom.LinkOne.Dom.Searching Namespace


Description Property

[image]

LinkOne WebView API
Search..::.Description Property
Search Class See Also Send Feedback
Gets or sets the search description.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Description { get; internal set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
virtual property String^ Description {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ISearch..::.Description

See Also

Search Class
Mincom.LinkOne.Dom.Searching Namespace


Disabled Property

[image]

LinkOne WebView API
Search..::.Disabled Property
Search Class See Also Send Feedback
Gets or sets the Search Disabled property.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Disabled { get; internal set; }
Visual Basic (Declaration)
Public Property Disabled As Boolean
Visual C++
public:
virtual property bool Disabled {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

ISearch..::.Disabled

Remarks

Disabled is used to remove standard searches from a search set.

See Also

Search Class
Mincom.LinkOne.Dom.Searching Namespace


DisplayField Property

[image]

LinkOne WebView API
Search..::.DisplayField Property
Search Class See Also Send Feedback
Gets the display field.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchDisplayField DisplayField { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayField As SearchDisplayField
Visual C++
public:
property SearchDisplayField^ DisplayField {
    SearchDisplayField^ get ();
}

See Also

Search Class
Mincom.LinkOne.Dom.Searching Namespace


DisplayFieldItemDescription Property

[image]

LinkOne WebView API
Search..::.DisplayFieldItemDescription Property
Search Class See Also Send Feedback
Gets the description for the matching value of a search result item component.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string DisplayFieldItemDescription { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayFieldItemDescription As String
Visual C++
public:
property String^ DisplayFieldItemDescription {
    String^ get ();
}

Remarks

Also see GetDisplayFieldName(SearchKey).

See Also

Search Class
Mincom.LinkOne.Dom.Searching Namespace


ISearch.SearchKeys Property

[image]

LinkOne WebView API
Search..::.ISearch..::.SearchKeys Property
Search Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ISearchKeyCollection ISearch.SearchKeys { get; }
Visual Basic (Declaration)
Private ReadOnly Property SearchKeys As ISearchKeyCollection
    Implements ISearch.SearchKeys
Visual C++
private:
virtual property ISearchKeyCollection^ SearchKeys {
    ISearchKeyCollection^ get () sealed = ISearch::SearchKeys::get;
}

Implements

ISearch..::.SearchKeys

See Also

Search Class
Mincom.LinkOne.Dom.Searching Namespace


Logic Property

[image]

LinkOne WebView API
Search..::.Logic Property
Search Class See Also Send Feedback
Gets or sets the search logic.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Search..::.SearchLogic Logic { get; internal set; }
Visual Basic (Declaration)
Public Property Logic As Search..::.SearchLogic
Visual C++
public:
property Search..::.SearchLogic Logic {
    Search..::.SearchLogic get ();
    void set (Search..::.SearchLogic value);
}

Remarks

This is only applicable for a two key search, the default value is NonPaired.

See Also

Search Class
Mincom.LinkOne.Dom.Searching Namespace


MenuEntry Property

[image]

LinkOne WebView API
Search..::.MenuEntry Property
Search Class See Also Send Feedback
Gets or sets the menu entry text.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string MenuEntry { get; internal set; }
Visual Basic (Declaration)
Public Property MenuEntry As String
Visual C++
public:
property String^ MenuEntry {
    String^ get ();
    void set (String^ value);
}

Remarks

Specifies the text that is shown in the search menu for this search. If empty, then the search will not be listed in the search menu.

See Also

Search Class
Mincom.LinkOne.Dom.Searching Namespace


Name Property

[image]

LinkOne WebView API
Search..::.Name Property
Search Class See Also Send Feedback
Gets or sets the search name.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Name { get; internal set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ISearch..::.Name

See Also

Search Class
Mincom.LinkOne.Dom.Searching Namespace


ResultsCaption Property

[image]

LinkOne WebView API
Search..::.ResultsCaption Property
Search Class See Also Send Feedback
Gets or sets the search results caption.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string ResultsCaption { get; internal set; }
Visual Basic (Declaration)
Public Property ResultsCaption As String
Visual C++
public:
property String^ ResultsCaption {
    String^ get ();
    void set (String^ value);
}

See Also

Search Class
Mincom.LinkOne.Dom.Searching Namespace


SaveMode Property

[image]

LinkOne WebView API
Search..::.SaveMode Property
Search Class See Also Send Feedback
Gets or sets the serch save mode.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Search..::.SearchSaveMode SaveMode { get; }
Visual Basic (Declaration)
Public ReadOnly Property SaveMode As Search..::.SearchSaveMode
Visual C++
public:
property Search..::.SearchSaveMode SaveMode {
    Search..::.SearchSaveMode get ();
}

See Also

Search Class
Mincom.LinkOne.Dom.Searching Namespace


SearchKeys Property

[image]

LinkOne WebView API
Search..::.SearchKeys Property
Search Class See Also Send Feedback
Gets the collection of search key definitions associated with this search. A search may have 1 or 2 search keys associated with it.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchKeyCollection SearchKeys { get; }
Visual Basic (Declaration)
Public ReadOnly Property SearchKeys As SearchKeyCollection
Visual C++
public:
property SearchKeyCollection^ SearchKeys {
    SearchKeyCollection^ get ();
}

See Also

Search Class
Mincom.LinkOne.Dom.Searching Namespace


Source Property

[image]

LinkOne WebView API
Search..::.Source Property
Search Class See Also Send Feedback
Gets or sets the search source.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Search..::.SearchSource Source { get; internal set; }
Visual Basic (Declaration)
Public Property Source As Search..::.SearchSource
Visual C++
public:
property Search..::.SearchSource Source {
    Search..::.SearchSource get ();
    void set (Search..::.SearchSource value);
}

See Also

Search Class
Mincom.LinkOne.Dom.Searching Namespace


Search Events

[image] [image]

LinkOne WebView API
Search Events
Search Class See Also Send Feedback

The Search type exposes the following members.

Events

Name | Description
SearchProgress | Occurs as the search progresses.

See Also

Search Class
Mincom.LinkOne.Dom.Searching Namespace


SearchProgress Event

[image]

LinkOne WebView API
Search..::.SearchProgress Event
Search Class See Also Send Feedback
Occurs as the search progresses.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public event SearchProgressEventHandler SearchProgress
Visual Basic (Declaration)
Public Event SearchProgress As SearchProgressEventHandler
Visual C++
public:
virtual  event SearchProgressEventHandler^ SearchProgress {
    void add (SearchProgressEventHandler^ value);
    void remove (SearchProgressEventHandler^ value);
}

Implements

ISearch..::.SearchProgress

See Also

Search Class
Mincom.LinkOne.Dom.Searching Namespace


Search.SearchLogic Enumeration

[image]

LinkOne WebView API
Search..::.SearchLogic Enumeration
Search Class See Also Send Feedback
Types of search logic.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum SearchLogic
Visual Basic (Declaration)
Public Enumeration SearchLogic
Visual C++
public enum class SearchLogic

Members

Member name | Description
Paired | SearchLogic is paired.
NonPaired | SearchLogic is not paired.

See Also

Mincom.LinkOne.Dom.Searching Namespace


Search.SearchSaveMode Enumeration

[image]

LinkOne WebView API
Search..::.SearchSaveMode Enumeration
Search Class See Also Send Feedback
Types of save mode.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum SearchSaveMode
Visual Basic (Declaration)
Public Enumeration SearchSaveMode
Visual C++
public enum class SearchSaveMode

Members

Member name | Description
Entry | Save the selected entry of the search results.
List | Save the complete list of search results.

See Also

Mincom.LinkOne.Dom.Searching Namespace


Search.SearchSource Enumeration

[image]

LinkOne WebView API
Search..::.SearchSource Enumeration
Search Class See Also Send Feedback
Types of search source.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum SearchSource
Visual Basic (Declaration)
Public Enumeration SearchSource
Visual C++
public enum class SearchSource

Members

Member name | Description
Predefined | Predefined search.
Book | Book supplied search.
Override | Book supplied search that is overriding a predefined searh.

See Also

Mincom.LinkOne.Dom.Searching Namespace


SearchCollection Class

[image]

LinkOne WebView API
SearchCollection Class
Members See Also Send Feedback
Represents a collection of Search objects.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class SearchCollection : IReadOnlyKeyedCollection<string, Search>,
    IReadOnlyCollection<Search>, IEnumerable<Search>, ISearchCollection,
    IReadOnlyKeyedCollection<string, ISearch>, IReadOnlyCollection<ISearch>, IEnumerable<ISearch>,
    IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class SearchCollection _
    Implements IReadOnlyKeyedCollection(Of String, Search),  _
    IReadOnlyCollection(Of Search), IEnumerable(Of Search), ISearchCollection,  _
    IReadOnlyKeyedCollection(Of String, ISearch), IReadOnlyCollection(Of ISearch),  _
    IEnumerable(Of ISearch), IEnumerable
Visual C++
[SerializableAttribute]
public ref class SearchCollection sealed : IReadOnlyKeyedCollection<String^, Search^>,
    IReadOnlyCollection<Search^>, IEnumerable<Search^>, ISearchCollection,
    IReadOnlyKeyedCollection<String^, ISearch^>, IReadOnlyCollection<ISearch^>,
    IEnumerable<ISearch^>, IEnumerable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Searching..::.SearchCollection

See Also

SearchCollection Members
Mincom.LinkOne.Dom.Searching Namespace


SearchCollection Members

[image] [image]

LinkOne WebView API
SearchCollection Members
SearchCollection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The SearchCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements in the collection.
Item | Gets the Search with the specifed name.

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(ISearch>)>)..::.Contains |
IEnumerable<(Of <(ISearch>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.
IReadOnlyKeyedCollection<(Of <(String, ISearch>)>)..::.Item |

See Also

SearchCollection Class
Mincom.LinkOne.Dom.Searching Namespace


SearchCollection Methods

[image] [image]

LinkOne WebView API
SearchCollection Methods
SearchCollection Class See Also Send Feedback

The SearchCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(ISearch>)>)..::.Contains |
IEnumerable<(Of <(ISearch>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.

See Also

SearchCollection Class
Mincom.LinkOne.Dom.Searching Namespace


IEnumerable(ISearch).GetEnumerator Method

[image]

LinkOne WebView API
SearchCollection..::.IEnumerable<(Of <(ISearch>)>)..::.GetEnumerator Method
SearchCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator<ISearch> IEnumerable<ISearch>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of ISearch)
    Implements IEnumerable(Of ISearch).GetEnumerator
Visual C++
private:
virtual IEnumerator<ISearch^>^ GetEnumerator() sealed = IEnumerable<ISearch^>::GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

SearchCollection Class
Mincom.LinkOne.Dom.Searching Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
SearchCollection..::.IEnumerable..::.GetEnumerator Method
SearchCollection Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

SearchCollection Class
Mincom.LinkOne.Dom.Searching Namespace


Contains Method

[image] [image]

LinkOne WebView API
SearchCollection..::.Contains Method
SearchCollection Class See Also Send Feedback

Overload List

Name | Description
Contains(Search) | Determines whether the search is in the collection.
Contains(String) | Determines whether the SearchCollection contains an Search with the specified name.

See Also

SearchCollection Class
SearchCollection Members
Mincom.LinkOne.Dom.Searching Namespace


Contains Method (Search)

[image]

LinkOne WebView API
SearchCollection..::.Contains Method (Search)
SearchCollection Class See Also Send Feedback
Determines whether the search is in the collection.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    Search item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As Search _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Search^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Dom.Searching..::.Search
The Search to search for.

Return Value

true if found in the collection, otherwise, false.

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Contains(T)

See Also

SearchCollection Class
Contains Overload
Mincom.LinkOne.Dom.Searching Namespace


Contains Method (String)

[image]

LinkOne WebView API
SearchCollection..::.Contains Method (String)
SearchCollection Class See Also Send Feedback
Determines whether the SearchCollection contains an Search with the specified name.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    string key
)
Visual Basic (Declaration)
Public Function Contains ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ key
) sealed

Parameters

key
Type: System..::.String
The search to locate.

Return Value

true if the SearchCollection contains a Search with the name; otherwise, false.

Implements

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Contains(TKey)
IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Contains(TKey)

Exceptions

Exception | Condition
System..::.ArgumentNullException | name is null.

See Also

SearchCollection Class
Contains Overload
Mincom.LinkOne.Dom.Searching Namespace


GetEnumerator Method

[image]

LinkOne WebView API
SearchCollection..::.GetEnumerator Method
SearchCollection Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IEnumerator<Search> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of Search)
Visual C++
public:
virtual IEnumerator<Search^>^ GetEnumerator() sealed

Return Value

A IEnumerator<(Of <(T>)>) that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

SearchCollection Class
Mincom.LinkOne.Dom.Searching Namespace


IReadOnlyCollection(ISearch).Contains Method

[image]

LinkOne WebView API
SearchCollection..::.IReadOnlyCollection<(Of <(ISearch>)>)..::.Contains Method
SearchCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IReadOnlyCollection<ISearch>.Contains(
    ISearch domObject
)
Visual Basic (Declaration)
Private Function Contains ( _
    domObject As ISearch _
) As Boolean Implements IReadOnlyCollection(Of ISearch).Contains
Visual C++
private:
virtual bool Contains(
    ISearch^ domObject
) sealed = IReadOnlyCollection<ISearch^>::Contains

Parameters

domObject
Type: Mincom.LinkOne.Dom.Searching..::.ISearch

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Contains(T)

See Also

SearchCollection Class
Mincom.LinkOne.Dom.Searching Namespace


SearchCollection Properties

[image] [image]

LinkOne WebView API
SearchCollection Properties
SearchCollection Class See Also Send Feedback

The SearchCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection.
Item | Gets the Search with the specifed name.

Explicit Interface Implementations

Name | Description
IReadOnlyKeyedCollection<(Of <(String, ISearch>)>)..::.Item |

See Also

SearchCollection Class
Mincom.LinkOne.Dom.Searching Namespace


Count Property

[image]

LinkOne WebView API
SearchCollection..::.Count Property
SearchCollection Class See Also Send Feedback
Gets the number of elements in the collection.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Count
IReadOnlyCollection<(Of <(T>)>)..::.Count

See Also

SearchCollection Class
Mincom.LinkOne.Dom.Searching Namespace


IReadOnlyKeyedCollection(String, ISearch).Item Property

[image]

LinkOne WebView API
SearchCollection..::.IReadOnlyKeyedCollection<(Of <(String, ISearch>)>)..::.Item Property
SearchCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ISearch IReadOnlyKeyedCollection<string, ISearch>.Item[
    string domObjectKey
] { get; }
Visual Basic (Declaration)
Private ReadOnly Property Item ( _
    domObjectKey As String _
) As ISearch Implements IReadOnlyKeyedCollection(Of String, ISearch).Item
Visual C++
private:
virtual property ISearch^ Item[String^ domObjectKey] {
    ISearch^ get (String^ domObjectKey) sealed = IReadOnlyKeyedCollection<String^, ISearch^>::Item::get;
}

Parameters

domObjectKey
Type: System..::.String

Implements

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Item[([(TKey])])

See Also

SearchCollection Class
Mincom.LinkOne.Dom.Searching Namespace


Item Property

[image]

LinkOne WebView API
SearchCollection..::.Item Property
SearchCollection Class See Also Send Feedback
Gets the Search with the specifed name.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Search this[
    string key
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    key As String _
) As Search
Visual C++
public:
virtual property Search^ default[String^ key] {
    Search^ get (String^ key) sealed;
}

Parameters

key
Type: System..::.String

Return Value

The search with the given name, if found; otherwise, null.

Implements

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Item[([(TKey])])

Exceptions

Exception | Condition
System..::.ArgumentNullException | name is null.

See Also

SearchCollection Class
Mincom.LinkOne.Dom.Searching Namespace


SearchDisplayField Class

[image]

LinkOne WebView API
SearchDisplayField Class
Members See Also Send Feedback
Represents a display field definition in a LinkOne search.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class SearchDisplayField
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class SearchDisplayField
Visual C++
[SerializableAttribute]
public ref class SearchDisplayField sealed

Remarks

The display field is optional. If included it gives the name, description and type of a data field that is to be displayed along with the ItemIDs in the search results lists.

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Searching..::.SearchDisplayField

See Also

SearchDisplayField Members
Mincom.LinkOne.Dom.Searching Namespace


SearchDisplayField Members

[image] [image]

LinkOne WebView API
SearchDisplayField Members
SearchDisplayField Class Methods Properties See Also Send Feedback

The SearchDisplayField type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Description | Gets or sets the description of the display field.
FieldType | Gets or sets the field type of the display field.
Name | Gets or sets the name of the display field.

See Also

SearchDisplayField Class
Mincom.LinkOne.Dom.Searching Namespace


SearchDisplayField Methods

[image] [image]

LinkOne WebView API
SearchDisplayField Methods
SearchDisplayField Class See Also Send Feedback

The SearchDisplayField type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SearchDisplayField Class
Mincom.LinkOne.Dom.Searching Namespace


SearchDisplayField Properties

[image] [image]

LinkOne WebView API
SearchDisplayField Properties
SearchDisplayField Class See Also Send Feedback

The SearchDisplayField type exposes the following members.

Properties

Name | Description
Description | Gets or sets the description of the display field.
FieldType | Gets or sets the field type of the display field.
Name | Gets or sets the name of the display field.

See Also

SearchDisplayField Class
Mincom.LinkOne.Dom.Searching Namespace


Description Property

[image]

LinkOne WebView API
SearchDisplayField..::.Description Property
SearchDisplayField Class See Also Send Feedback
Gets or sets the description of the display field.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Description { get; internal set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

SearchDisplayField Class
Mincom.LinkOne.Dom.Searching Namespace


FieldType Property

[image]

LinkOne WebView API
SearchDisplayField..::.FieldType Property
SearchDisplayField Class See Also Send Feedback
Gets or sets the field type of the display field.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchFieldType FieldType { get; internal set; }
Visual Basic (Declaration)
Public Property FieldType As SearchFieldType
Visual C++
public:
property SearchFieldType FieldType {
    SearchFieldType get ();
    void set (SearchFieldType value);
}

See Also

SearchDisplayField Class
Mincom.LinkOne.Dom.Searching Namespace


Name Property

[image]

LinkOne WebView API
SearchDisplayField..::.Name Property
SearchDisplayField Class See Also Send Feedback
Gets or sets the name of the display field.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Name { get; internal set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

SearchDisplayField Class
Mincom.LinkOne.Dom.Searching Namespace


SearchEntryFieldMap Class

[image]

LinkOne WebView API
SearchEntryFieldMap Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public sealed class SearchEntryFieldMap : ISearchOverField
Visual Basic (Declaration)
Public NotInheritable Class SearchEntryFieldMap _
    Implements ISearchOverField
Visual C++
public ref class SearchEntryFieldMap sealed : ISearchOverField

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Searching..::.SearchEntryFieldMap

See Also

SearchEntryFieldMap Members
Mincom.LinkOne.Dom.Searching Namespace


SearchEntryFieldMap Members

[image] [image]

LinkOne WebView API
SearchEntryFieldMap Members
SearchEntryFieldMap Class Methods Events See Also Send Feedback

The SearchEntryFieldMap type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Find | Returns the collection of search results that match the given value.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Events

Name | Description
SearchProgress | This event provides updates on the progress of a search.

See Also

SearchEntryFieldMap Class
Mincom.LinkOne.Dom.Searching Namespace


SearchEntryFieldMap Methods

[image] [image]

LinkOne WebView API
SearchEntryFieldMap Methods
SearchEntryFieldMap Class See Also Send Feedback

The SearchEntryFieldMap type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Find | Returns the collection of search results that match the given value.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SearchEntryFieldMap Class
Mincom.LinkOne.Dom.Searching Namespace


Find Method

[image]

LinkOne WebView API
SearchEntryFieldMap..::.Find Method
SearchEntryFieldMap Class See Also Send Feedback
Returns the collection of search results that match the given value.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchResultCollection Find(
    string value,
    bool matchCase,
    bool exactMatch,
    Regex noiseFilter,
    string displayField,
    string preferredListTitle,
    string languageCode
)
Visual Basic (Declaration)
Public Function Find ( _
    value As String, _
    matchCase As Boolean, _
    exactMatch As Boolean, _
    noiseFilter As Regex, _
    displayField As String, _
    preferredListTitle As String, _
    languageCode As String _
) As SearchResultCollection
Visual C++
public:
virtual SearchResultCollection^ Find(
    String^ value,
    bool matchCase,
    bool exactMatch,
    Regex^ noiseFilter,
    String^ displayField,
    String^ preferredListTitle,
    String^ languageCode
) sealed

Parameters

value
Type: System..::.String
The value to search for.
matchCase
Type: System..::.Boolean
True to match the case during the search.
exactMatch
Type: System..::.Boolean
True to match the full value length.
noiseFilter
Type: System.Text.RegularExpressions..::.Regex
Regular expression to apply to the searched string prior to searching it.
displayField
Type: System..::.String
The display field to choose for each result.
preferredListTitle
Type: System..::.String
The preferred list title.
languageCode
Type: System..::.String
The language code.

Return Value

The collection of search results that match the given value.

Implements

ISearchOverField..::.Find(String, Boolean, Boolean, Regex, String, String, String)

See Also

SearchEntryFieldMap Class
Mincom.LinkOne.Dom.Searching Namespace


SearchEntryFieldMap Events

[image] [image]

LinkOne WebView API
SearchEntryFieldMap Events
SearchEntryFieldMap Class See Also Send Feedback

The SearchEntryFieldMap type exposes the following members.

Events

Name | Description
SearchProgress | This event provides updates on the progress of a search.

See Also

SearchEntryFieldMap Class
Mincom.LinkOne.Dom.Searching Namespace


SearchProgress Event

[image]

LinkOne WebView API
SearchEntryFieldMap..::.SearchProgress Event
SearchEntryFieldMap Class See Also Send Feedback
This event provides updates on the progress of a search.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public event SearchProgressEventHandler SearchProgress
Visual Basic (Declaration)
Public Event SearchProgress As SearchProgressEventHandler
Visual C++
public:
virtual  event SearchProgressEventHandler^ SearchProgress {
    void add (SearchProgressEventHandler^ value);
    void remove (SearchProgressEventHandler^ value);
}

Implements

ISearchOverField..::.SearchProgress

See Also

SearchEntryFieldMap Class
Mincom.LinkOne.Dom.Searching Namespace


SearchEntryMap Class

[image]

LinkOne WebView API
SearchEntryMap Class
Members See Also Send Feedback
A map of entry field searches.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public sealed class SearchEntryMap
Visual Basic (Declaration)
Public NotInheritable Class SearchEntryMap
Visual C++
public ref class SearchEntryMap sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Searching..::.SearchEntryMap

See Also

SearchEntryMap Members
Mincom.LinkOne.Dom.Searching Namespace


SearchEntryMap Members

[image] [image]

LinkOne WebView API
SearchEntryMap Members
SearchEntryMap Class Methods Properties See Also Send Feedback

The SearchEntryMap type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Item | Gets the map for the given field.

See Also

SearchEntryMap Class
Mincom.LinkOne.Dom.Searching Namespace


SearchEntryMap Methods

[image] [image]

LinkOne WebView API
SearchEntryMap Methods
SearchEntryMap Class See Also Send Feedback

The SearchEntryMap type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SearchEntryMap Class
Mincom.LinkOne.Dom.Searching Namespace


SearchEntryMap Properties

[image] [image]

LinkOne WebView API
SearchEntryMap Properties
SearchEntryMap Class See Also Send Feedback

The SearchEntryMap type exposes the following members.

Properties

Name | Description
Item | Gets the map for the given field.

See Also

SearchEntryMap Class
Mincom.LinkOne.Dom.Searching Namespace


Item Property

[image]

LinkOne WebView API
SearchEntryMap..::.Item Property
SearchEntryMap Class See Also Send Feedback
Gets the map for the given field.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ISearchOverField this[
    string field
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    field As String _
) As ISearchOverField
Visual C++
public:
property ISearchOverField^ default[String^ field] {
    ISearchOverField^ get (String^ field);
}

Parameters

field
Type: System..::.String

See Also

SearchEntryMap Class
Mincom.LinkOne.Dom.Searching Namespace


SearchField Class

[image]

LinkOne WebView API
SearchField Class
Members See Also Send Feedback
A search field in a LinkOne SearchKey. There may be more than one per key.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class SearchField
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class SearchField
Visual C++
[SerializableAttribute]
public ref class SearchField sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Searching..::.SearchField

See Also

SearchField Members
Mincom.LinkOne.Dom.Searching Namespace


SearchField Members

[image] [image]

LinkOne WebView API
SearchField Members
SearchField Class Methods Properties See Also Send Feedback

The SearchField type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Description | Gets the description of the search field.
Name | Gets the name of the search field.

See Also

SearchField Class
Mincom.LinkOne.Dom.Searching Namespace


SearchField Methods

[image] [image]

LinkOne WebView API
SearchField Methods
SearchField Class See Also Send Feedback

The SearchField type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SearchField Class
Mincom.LinkOne.Dom.Searching Namespace


SearchField Properties

[image] [image]

LinkOne WebView API
SearchField Properties
SearchField Class See Also Send Feedback

The SearchField type exposes the following members.

Properties

Name | Description
Description | Gets the description of the search field.
Name | Gets the name of the search field.

See Also

SearchField Class
Mincom.LinkOne.Dom.Searching Namespace


Description Property

[image]

LinkOne WebView API
SearchField..::.Description Property
SearchField Class See Also Send Feedback
Gets the description of the search field.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Description { get; internal set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

SearchField Class
Mincom.LinkOne.Dom.Searching Namespace


Name Property

[image]

LinkOne WebView API
SearchField..::.Name Property
SearchField Class See Also Send Feedback
Gets the name of the search field.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

SearchField Class
Mincom.LinkOne.Dom.Searching Namespace


SearchFieldCollection Class

[image]

LinkOne WebView API
SearchFieldCollection Class
Members See Also Send Feedback
Represents a collection of SearchField objects that can be accessed by index.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class SearchFieldCollection : ReadOnlyList<SearchField>
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class SearchFieldCollection _
    Inherits ReadOnlyList(Of SearchField)
Visual C++
[SerializableAttribute]
public ref class SearchFieldCollection sealed : public ReadOnlyList<SearchField^>

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.ReadOnlyList <(Of <( SearchField >)>)
Mincom.LinkOne.Dom.Searching..::.SearchFieldCollection

See Also

SearchFieldCollection Members
Mincom.LinkOne.Dom.Searching Namespace


SearchFieldCollection Members

[image] [image]

LinkOne WebView API
SearchFieldCollection Members
SearchFieldCollection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The SearchFieldCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given object. (Inherited from ReadOnlyList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
InnerList | Gets the inner list. (Inherited from ReadOnlyList<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from ReadOnlyList<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(T>)>).)

See Also

SearchFieldCollection Class
Mincom.LinkOne.Dom.Searching Namespace


SearchFieldCollection Methods

[image] [image]

LinkOne WebView API
SearchFieldCollection Methods
SearchFieldCollection Class See Also Send Feedback

The SearchFieldCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given object. (Inherited from ReadOnlyList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(T>)>).)

See Also

SearchFieldCollection Class
Mincom.LinkOne.Dom.Searching Namespace


SearchFieldCollection Properties

[image] [image]

LinkOne WebView API
SearchFieldCollection Properties
SearchFieldCollection Class See Also Send Feedback

The SearchFieldCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
InnerList | Gets the inner list. (Inherited from ReadOnlyList<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from ReadOnlyList<(Of <(T>)>).)

See Also

SearchFieldCollection Class
Mincom.LinkOne.Dom.Searching Namespace


SearchFieldMap Class

[image]

LinkOne WebView API
SearchFieldMap Class
Members See Also Send Feedback
A map of list item identifiers and page references.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public class SearchFieldMap : IPersist
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class SearchFieldMap _
    Implements IPersist
Visual C++
[SerializableAttribute]
public ref class SearchFieldMap : IPersist

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Searching..::.SearchFieldMap

See Also

SearchFieldMap Members
Mincom.LinkOne.Dom.Searching Namespace


SearchFieldMap Members

[image] [image]

LinkOne WebView API
SearchFieldMap Members
SearchFieldMap Class Constructors Methods Properties See Also Send Feedback

The SearchFieldMap type exposes the following members.

Constructors

Name | Description
SearchFieldMap | Constructs a new Dom SearchFieldMap object from a DomReader object.

Methods

Name | Description
Clone | Gets a copy of the SearchFieldMap object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetIntValue | Gets the integer value for the given index.
GetKey | Gets the key for the given index.
GetStringValue | Gets the string value for the given index.
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
BookCode | Gets the book code for the index.
FieldName | Gets or sets the field name for the index.
FieldType | Gets the field type for the index.
Length | Gets the length of the map.
Location | Gets or sets the index location.
PublishedDate | Gets the date the search was published.
PublisherCode | Gets the publisher code for the index.
SpecialProcessing | Gets or sets the special processing attribute associated with this search field map. True to indicate special processing for this search field map.

See Also

SearchFieldMap Class
Mincom.LinkOne.Dom.Searching Namespace


SearchFieldMap Constructor

[image]

LinkOne WebView API
SearchFieldMap Constructor
SearchFieldMap Class See Also Send Feedback
Constructs a new Dom SearchFieldMap object from a DomReader object.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchFieldMap(
    IDomReader domReader
)
Visual Basic (Declaration)
Public Sub New ( _
    domReader As IDomReader _
)
Visual C++
public:
SearchFieldMap(
    IDomReader^ domReader
)

Parameters

domReader
Type: IDomReader
The search field map reader object providing the initialisation data.

See Also

SearchFieldMap Class
Mincom.LinkOne.Dom.Searching Namespace


SearchFieldMap Methods

[image] [image]

LinkOne WebView API
SearchFieldMap Methods
SearchFieldMap Class See Also Send Feedback

The SearchFieldMap type exposes the following members.

Methods

Name | Description
Clone | Gets a copy of the SearchFieldMap object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetIntValue | Gets the integer value for the given index.
GetKey | Gets the key for the given index.
GetStringValue | Gets the string value for the given index.
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SearchFieldMap Class
Mincom.LinkOne.Dom.Searching Namespace


Clone Method

[image]

LinkOne WebView API
SearchFieldMap..::.Clone Method
SearchFieldMap Class See Also Send Feedback
Gets a copy of the SearchFieldMap object.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IPersist Clone()
Visual Basic (Declaration)
Public Function Clone As IPersist
Visual C++
public:
IPersist^ Clone()

Return Value

A cloned SearchFieldMap object.

See Also

SearchFieldMap Class
Mincom.LinkOne.Dom.Searching Namespace


GetIntValue Method

[image]

LinkOne WebView API
SearchFieldMap..::.GetIntValue Method
SearchFieldMap Class See Also Send Feedback
Gets the integer value for the given index.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int GetIntValue(
    int index
)
Visual Basic (Declaration)
Public Function GetIntValue ( _
    index As Integer _
) As Integer
Visual C++
public:
int GetIntValue(
    int index
)

Parameters

index
Type: System..::.Int32
The index of the key to get.

Return Value

The value of the integer associated with the specified index.

See Also

SearchFieldMap Class
Mincom.LinkOne.Dom.Searching Namespace


GetKey Method

[image]

LinkOne WebView API
SearchFieldMap..::.GetKey Method
SearchFieldMap Class See Also Send Feedback
Gets the key for the given index.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string GetKey(
    int index
)
Visual Basic (Declaration)
Public Function GetKey ( _
    index As Integer _
) As String
Visual C++
public:
String^ GetKey(
    int index
)

Parameters

index
Type: System..::.Int32
The index of the key to get.

Return Value

The value of the key associated with the specified index.

See Also

SearchFieldMap Class
Mincom.LinkOne.Dom.Searching Namespace


GetStringValue Method

[image]

LinkOne WebView API
SearchFieldMap..::.GetStringValue Method
SearchFieldMap Class See Also Send Feedback
Gets the string value for the given index.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string GetStringValue(
    int index
)
Visual Basic (Declaration)
Public Function GetStringValue ( _
    index As Integer _
) As String
Visual C++
public:
String^ GetStringValue(
    int index
)

Parameters

index
Type: System..::.Int32
The index of the key to get.

Return Value

The value of the string associated with the specified index.

See Also

SearchFieldMap Class
Mincom.LinkOne.Dom.Searching Namespace


SearchFieldMap Properties

[image] [image]

LinkOne WebView API
SearchFieldMap Properties
SearchFieldMap Class See Also Send Feedback

The SearchFieldMap type exposes the following members.

Properties

Name | Description
BookCode | Gets the book code for the index.
FieldName | Gets or sets the field name for the index.
FieldType | Gets the field type for the index.
Length | Gets the length of the map.
Location | Gets or sets the index location.
PublishedDate | Gets the date the search was published.
PublisherCode | Gets the publisher code for the index.
SpecialProcessing | Gets or sets the special processing attribute associated with this search field map. True to indicate special processing for this search field map.

See Also

SearchFieldMap Class
Mincom.LinkOne.Dom.Searching Namespace


BookCode Property

[image]

LinkOne WebView API
SearchFieldMap..::.BookCode Property
SearchFieldMap Class See Also Send Feedback
Gets the book code for the index.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string BookCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property BookCode As String
Visual C++
public:
property String^ BookCode {
    String^ get ();
}

See Also

SearchFieldMap Class
Mincom.LinkOne.Dom.Searching Namespace


FieldName Property

[image]

LinkOne WebView API
SearchFieldMap..::.FieldName Property
SearchFieldMap Class See Also Send Feedback
Gets or sets the field name for the index.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string FieldName { get; internal set; }
Visual Basic (Declaration)
Public Property FieldName As String
Visual C++
public:
property String^ FieldName {
    String^ get ();
    void set (String^ value);
}

See Also

SearchFieldMap Class
Mincom.LinkOne.Dom.Searching Namespace


FieldType Property

[image]

LinkOne WebView API
SearchFieldMap..::.FieldType Property
SearchFieldMap Class See Also Send Feedback
Gets the field type for the index.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchFieldType FieldType { get; internal set; }
Visual Basic (Declaration)
Public Property FieldType As SearchFieldType
Visual C++
public:
property SearchFieldType FieldType {
    SearchFieldType get ();
    void set (SearchFieldType value);
}

See Also

SearchFieldMap Class
Mincom.LinkOne.Dom.Searching Namespace


Length Property

[image]

LinkOne WebView API
SearchFieldMap..::.Length Property
SearchFieldMap Class See Also Send Feedback
Gets the length of the map.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Length { get; }
Visual Basic (Declaration)
Public ReadOnly Property Length As Integer
Visual C++
public:
property int Length {
    int get ();
}

See Also

SearchFieldMap Class
Mincom.LinkOne.Dom.Searching Namespace


Location Property

[image]

LinkOne WebView API
SearchFieldMap..::.Location Property
SearchFieldMap Class See Also Send Feedback
Gets or sets the index location.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Location { get; internal set; }
Visual Basic (Declaration)
Public Property Location As String
Visual C++
public:
property String^ Location {
    String^ get ();
    void set (String^ value);
}

See Also

SearchFieldMap Class
Mincom.LinkOne.Dom.Searching Namespace


PublishedDate Property

[image]

LinkOne WebView API
SearchFieldMap..::.PublishedDate Property
SearchFieldMap Class See Also Send Feedback
Gets the date the search was published.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public DateTime PublishedDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublishedDate As DateTime
Visual C++
public:
property DateTime PublishedDate {
    DateTime get ();
}

See Also

SearchFieldMap Class
Mincom.LinkOne.Dom.Searching Namespace


PublisherCode Property

[image]

LinkOne WebView API
SearchFieldMap..::.PublisherCode Property
SearchFieldMap Class See Also Send Feedback
Gets the publisher code for the index.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PublisherCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublisherCode As String
Visual C++
public:
property String^ PublisherCode {
    String^ get ();
}

See Also

SearchFieldMap Class
Mincom.LinkOne.Dom.Searching Namespace


SpecialProcessing Property

[image]

LinkOne WebView API
SearchFieldMap..::.SpecialProcessing Property
SearchFieldMap Class See Also Send Feedback
Gets or sets the special processing attribute associated with this search field map. True to indicate special processing for this search field map.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchFieldMap..::.SpecialProcessingType SpecialProcessing { get; internal set; }
Visual Basic (Declaration)
Public Property SpecialProcessing As SearchFieldMap..::.SpecialProcessingType
Visual C++
public:
property SearchFieldMap..::.SpecialProcessingType SpecialProcessing {
    SearchFieldMap..::.SpecialProcessingType get ();
    void set (SearchFieldMap..::.SpecialProcessingType value);
}

See Also

SearchFieldMap Class
Mincom.LinkOne.Dom.Searching Namespace


SearchFieldMap.SpecialProcessingType Enumeration

[image]

LinkOne WebView API
SearchFieldMap..::.SpecialProcessingType Enumeration
SearchFieldMap Class See Also Send Feedback
Defines the types of special processing that the LinkOne Book Builder can perform on a field before it is added to a search index.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum SpecialProcessingType
Visual Basic (Declaration)
Public Enumeration SpecialProcessingType
Visual C++
public enum class SpecialProcessingType

Members

Member name | Description
StripBracketedData | Any text in the field surrounded by brackets will be removed.
StripOuterBrackets | Any outer brackets surrounding the text of the field will be removed.
None | The field will remain unchanged.

See Also

Mincom.LinkOne.Dom.Searching Namespace


SearchFieldType Enumeration

[image]

LinkOne WebView API
SearchFieldType Enumeration
See Also Send Feedback
The type of field to search on.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum SearchFieldType
Visual Basic (Declaration)
Public Enumeration SearchFieldType
Visual C++
public enum class SearchFieldType

Members

Member name | Description
EntryItem | Search field is associated with an item list.
ListField | Search field is associated with a page.
EntryField | Search field is associated with an entry.
WordList | Search field is associated with a word list.
PartsIndex | The parts index that associates fields with tag numbers and option filters.

See Also

Mincom.LinkOne.Dom.Searching Namespace


SearchIndexPosition Structure

[image]

LinkOne WebView API
SearchIndexPosition Structure
Members See Also Send Feedback
The position of the search result in the index.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public struct SearchIndexPosition
Visual Basic (Declaration)
<SerializableAttribute> _
Public Structure SearchIndexPosition
Visual C++
[SerializableAttribute]
public value class SearchIndexPosition

See Also

SearchIndexPosition Members
Mincom.LinkOne.Dom.Searching Namespace


SearchIndexPosition Members

[image] [image]

LinkOne WebView API
SearchIndexPosition Members
SearchIndexPosition Structure Methods Properties See Also Send Feedback

The SearchIndexPosition type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
Empty | Represents a null position.
EntryPosition | The index of the entry in the field map.
PageIndex | The index of the page.

See Also

SearchIndexPosition Structure
Mincom.LinkOne.Dom.Searching Namespace


SearchIndexPosition Methods

[image] [image]

LinkOne WebView API
SearchIndexPosition Methods
SearchIndexPosition Structure See Also Send Feedback

The SearchIndexPosition type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

SearchIndexPosition Structure
Mincom.LinkOne.Dom.Searching Namespace


SearchIndexPosition Properties

[image] [image]

LinkOne WebView API
SearchIndexPosition Properties
SearchIndexPosition Structure See Also Send Feedback

The SearchIndexPosition type exposes the following members.

Properties

Name | Description
Empty | Represents a null position.
EntryPosition | The index of the entry in the field map.
PageIndex | The index of the page.

See Also

SearchIndexPosition Structure
Mincom.LinkOne.Dom.Searching Namespace


Empty Property

[image]

LinkOne WebView API
SearchIndexPosition..::.Empty Property
SearchIndexPosition Structure See Also Send Feedback
Represents a null position.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static SearchIndexPosition Empty { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Empty As SearchIndexPosition
Visual C++
public:
static property SearchIndexPosition Empty {
    SearchIndexPosition get ();
}

Field Value

The empty.

See Also

SearchIndexPosition Structure
Mincom.LinkOne.Dom.Searching Namespace


EntryPosition Property

[image]

LinkOne WebView API
SearchIndexPosition..::.EntryPosition Property
SearchIndexPosition Structure See Also Send Feedback
The index of the entry in the field map.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int EntryPosition { get; }
Visual Basic (Declaration)
Public ReadOnly Property EntryPosition As Integer
Visual C++
public:
property int EntryPosition {
    int get ();
}

See Also

SearchIndexPosition Structure
Mincom.LinkOne.Dom.Searching Namespace


PageIndex Property

[image]

LinkOne WebView API
SearchIndexPosition..::.PageIndex Property
SearchIndexPosition Structure See Also Send Feedback
The index of the page.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int PageIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageIndex As Integer
Visual C++
public:
property int PageIndex {
    int get ();
}

See Also

SearchIndexPosition Structure
Mincom.LinkOne.Dom.Searching Namespace


SearchKey Class

[image]

LinkOne WebView API
SearchKey Class
Members See Also Send Feedback
A search key in a LinkOne Search. There may be up-to two in a search definition.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class SearchKey : ICloneable,
    ISearchKey
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class SearchKey _
    Implements ICloneable, ISearchKey
Visual C++
[SerializableAttribute]
public ref class SearchKey sealed : ICloneable,
    ISearchKey

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Searching..::.SearchKey

See Also

SearchKey Members
Mincom.LinkOne.Dom.Searching Namespace


SearchKey Members

[image] [image]

LinkOne WebView API
SearchKey Members
SearchKey Class Constructors Methods Properties See Also Send Feedback

The SearchKey type exposes the following members.

Constructors

Name | Description
SearchKey | Constructs a new Dom Search object from a DomReader object.

Methods

Name | Description
Clone | Gets a copy of the SearchKey object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Caption | Gets or sets the caption of the search key.
FieldType | Gets or sets the SearchFieldType of the search key.
NoiseFilter | Gets the regular expression which can be applied to a string to strip out noise characters.
NonNoiseCharacters | Gets or sets the set of characters that are not noise characters in the search key.
SearchFields | Gets the collection of search fields associated with the search key.

See Also

SearchKey Class
Mincom.LinkOne.Dom.Searching Namespace


SearchKey Constructor

[image]

LinkOne WebView API
SearchKey Constructor
SearchKey Class See Also Send Feedback
Constructs a new Dom Search object from a DomReader object.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchKey(
    IDomReader domReader
)
Visual Basic (Declaration)
Public Sub New ( _
    domReader As IDomReader _
)
Visual C++
public:
SearchKey(
    IDomReader^ domReader
)

Parameters

domReader
Type: IDomReader
The search reader object providing the initialisation data.

See Also

SearchKey Class
Mincom.LinkOne.Dom.Searching Namespace


SearchKey Methods

[image] [image]

LinkOne WebView API
SearchKey Methods
SearchKey Class See Also Send Feedback

The SearchKey type exposes the following members.

Methods

Name | Description
Clone | Gets a copy of the SearchKey object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SearchKey Class
Mincom.LinkOne.Dom.Searching Namespace


Clone Method

[image]

LinkOne WebView API
SearchKey..::.Clone Method
SearchKey Class See Also Send Feedback
Gets a copy of the SearchKey object.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Return Value

A cloned SearchKey object.

Implements

ICloneable..::.Clone()()()

See Also

SearchKey Class
Mincom.LinkOne.Dom.Searching Namespace


SearchKey Properties

[image] [image]

LinkOne WebView API
SearchKey Properties
SearchKey Class See Also Send Feedback

The SearchKey type exposes the following members.

Properties

Name | Description
Caption | Gets or sets the caption of the search key.
FieldType | Gets or sets the SearchFieldType of the search key.
NoiseFilter | Gets the regular expression which can be applied to a string to strip out noise characters.
NonNoiseCharacters | Gets or sets the set of characters that are not noise characters in the search key.
SearchFields | Gets the collection of search fields associated with the search key.

See Also

SearchKey Class
Mincom.LinkOne.Dom.Searching Namespace


Caption Property

[image]

LinkOne WebView API
SearchKey..::.Caption Property
SearchKey Class See Also Send Feedback
Gets or sets the caption of the search key.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Caption { get; internal set; }
Visual Basic (Declaration)
Public Property Caption As String
Visual C++
public:
virtual property String^ Caption {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ISearchKey..::.Caption

Remarks

The key caption is the text that will appear abouve the key entry field on the search dialog.

See Also

SearchKey Class
Mincom.LinkOne.Dom.Searching Namespace


FieldType Property

[image]

LinkOne WebView API
SearchKey..::.FieldType Property
SearchKey Class See Also Send Feedback
Gets or sets the SearchFieldType of the search key.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchFieldType FieldType { get; internal set; }
Visual Basic (Declaration)
Public Property FieldType As SearchFieldType
Visual C++
public:
property SearchFieldType FieldType {
    SearchFieldType get ();
    void set (SearchFieldType value);
}

Remarks

The field type defines the type of fields that this key will search, it can be LIST or ENTRY. If none is specified, then ENTRY is assumed.

See Also

SearchKey Class
Mincom.LinkOne.Dom.Searching Namespace


NoiseFilter Property

[image]

LinkOne WebView API
SearchKey..::.NoiseFilter Property
SearchKey Class See Also Send Feedback
Gets the regular expression which can be applied to a string to strip out noise characters.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Regex NoiseFilter { get; }
Visual Basic (Declaration)
Public ReadOnly Property NoiseFilter As Regex
Visual C++
public:
property Regex^ NoiseFilter {
    Regex^ get ();
}

See Also

SearchKey Class
Mincom.LinkOne.Dom.Searching Namespace


NonNoiseCharacters Property

[image]

LinkOne WebView API
SearchKey..::.NonNoiseCharacters Property
SearchKey Class See Also Send Feedback
Gets or sets the set of characters that are not noise characters in the search key.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string NonNoiseCharacters { get; internal set; }
Visual Basic (Declaration)
Public Property NonNoiseCharacters As String
Visual C++
public:
property String^ NonNoiseCharacters {
    String^ get ();
    void set (String^ value);
}

Remarks

If non noise characters are not specified, then any character other than letters and digits will be ignored by LinkOne when it looks for a match for the key. If non noise characters are specified then those characters will also be used when looking for a match in addition to letters and digits. The value that is specified for non noise characters is a sequence of characters. Each character specified is added to the default set of non noise characters. A range of characters can also be specified by using the special construction: [ first - last ] where first is the first character in the range and last is the last character in the range. The range is based on the standard ASCII sequence.

See Also

SearchKey Class
Mincom.LinkOne.Dom.Searching Namespace


SearchFields Property

[image]

LinkOne WebView API
SearchKey..::.SearchFields Property
SearchKey Class See Also Send Feedback
Gets the collection of search fields associated with the search key.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchFieldCollection SearchFields { get; }
Visual Basic (Declaration)
Public ReadOnly Property SearchFields As SearchFieldCollection
Visual C++
public:
property SearchFieldCollection^ SearchFields {
    SearchFieldCollection^ get ();
}

Remarks

The search field collection specifies which data fields each key will be compared to when searching. There may be any number of search fields associated with a search key. For each entry or page the key will be compared to each of the fields listed. If a match is found in any of those fields, then the entry or page is considered a match for that key.

See Also

SearchKey Class
Mincom.LinkOne.Dom.Searching Namespace


SearchKeyCollection Class

[image]

LinkOne WebView API
SearchKeyCollection Class
Members See Also Send Feedback
Represents a collection of SearchKey objects that can be accessed by index.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class SearchKeyCollection : ReadOnlyList<SearchKey>,
    ISearchKeyCollection, IReadOnlyList<ISearchKey>, IReadOnlyCollection<ISearchKey>,
    IEnumerable<ISearchKey>, IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class SearchKeyCollection _
    Inherits ReadOnlyList(Of SearchKey) _
    Implements ISearchKeyCollection, IReadOnlyList(Of ISearchKey),  _
    IReadOnlyCollection(Of ISearchKey), IEnumerable(Of ISearchKey), IEnumerable
Visual C++
[SerializableAttribute]
public ref class SearchKeyCollection sealed : public ReadOnlyList<SearchKey^>,
    ISearchKeyCollection, IReadOnlyList<ISearchKey^>, IReadOnlyCollection<ISearchKey^>,
    IEnumerable<ISearchKey^>, IEnumerable

Remarks

WinView only supports 2 search keys per search definition, which is supported by the BookLoader. This may be removed in the future.

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.ReadOnlyList <(Of <( SearchKey >)>)
Mincom.LinkOne.Dom.Searching..::.SearchKeyCollection

See Also

SearchKeyCollection Members
Mincom.LinkOne.Dom.Searching Namespace


SearchKeyCollection Members

[image] [image]

LinkOne WebView API
SearchKeyCollection Members
SearchKeyCollection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The SearchKeyCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given object. (Inherited from ReadOnlyList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
InnerList | Gets the inner list. (Inherited from ReadOnlyList<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from ReadOnlyList<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(ISearchKey>)>)..::.Contains |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
IEnumerable<(Of <(ISearchKey>)>)..::.GetEnumerator |
IReadOnlyList<(Of <(ISearchKey>)>)..::.IndexOf |
IReadOnlyList<(Of <(ISearchKey>)>)..::.Item |

See Also

SearchKeyCollection Class
Mincom.LinkOne.Dom.Searching Namespace


SearchKeyCollection Methods

[image] [image]

LinkOne WebView API
SearchKeyCollection Methods
SearchKeyCollection Class See Also Send Feedback

The SearchKeyCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given object. (Inherited from ReadOnlyList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(ISearchKey>)>)..::.Contains |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
IEnumerable<(Of <(ISearchKey>)>)..::.GetEnumerator |
IReadOnlyList<(Of <(ISearchKey>)>)..::.IndexOf |

See Also

SearchKeyCollection Class
Mincom.LinkOne.Dom.Searching Namespace


IEnumerable(ISearchKey).GetEnumerator Method

[image]

LinkOne WebView API
SearchKeyCollection..::.IEnumerable<(Of <(ISearchKey>)>)..::.GetEnumerator Method
SearchKeyCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator<ISearchKey> IEnumerable<ISearchKey>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of ISearchKey)
    Implements IEnumerable(Of ISearchKey).GetEnumerator
Visual C++
private:
virtual IEnumerator<ISearchKey^>^ GetEnumerator() sealed = IEnumerable<ISearchKey^>::GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

SearchKeyCollection Class
Mincom.LinkOne.Dom.Searching Namespace


IReadOnlyCollection(ISearchKey).Contains Method

[image]

LinkOne WebView API
SearchKeyCollection..::.IReadOnlyCollection<(Of <(ISearchKey>)>)..::.Contains Method
SearchKeyCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IReadOnlyCollection<ISearchKey>.Contains(
    ISearchKey domObject
)
Visual Basic (Declaration)
Private Function Contains ( _
    domObject As ISearchKey _
) As Boolean Implements IReadOnlyCollection(Of ISearchKey).Contains
Visual C++
private:
virtual bool Contains(
    ISearchKey^ domObject
) sealed = IReadOnlyCollection<ISearchKey^>::Contains

Parameters

domObject
Type: Mincom.LinkOne.Dom.Searching..::.ISearchKey

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Contains(T)

See Also

SearchKeyCollection Class
Mincom.LinkOne.Dom.Searching Namespace


IReadOnlyList(ISearchKey).IndexOf Method

[image]

LinkOne WebView API
SearchKeyCollection..::.IReadOnlyList<(Of <(ISearchKey>)>)..::.IndexOf Method
SearchKeyCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int IReadOnlyList<ISearchKey>.IndexOf(
    ISearchKey domObject
)
Visual Basic (Declaration)
Private Function IndexOf ( _
    domObject As ISearchKey _
) As Integer Implements IReadOnlyList(Of ISearchKey).IndexOf
Visual C++
private:
virtual int IndexOf(
    ISearchKey^ domObject
) sealed = IReadOnlyList<ISearchKey^>::IndexOf

Parameters

domObject
Type: Mincom.LinkOne.Dom.Searching..::.ISearchKey

Implements

IReadOnlyList<(Of <(T>)>)..::.IndexOf(T)

See Also

SearchKeyCollection Class
Mincom.LinkOne.Dom.Searching Namespace


SearchKeyCollection Properties

[image] [image]

LinkOne WebView API
SearchKeyCollection Properties
SearchKeyCollection Class See Also Send Feedback

The SearchKeyCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
InnerList | Gets the inner list. (Inherited from ReadOnlyList<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from ReadOnlyList<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IReadOnlyList<(Of <(ISearchKey>)>)..::.Item |

See Also

SearchKeyCollection Class
Mincom.LinkOne.Dom.Searching Namespace


IReadOnlyList(ISearchKey).Item Property

[image]

LinkOne WebView API
SearchKeyCollection..::.IReadOnlyList<(Of <(ISearchKey>)>)..::.Item Property
SearchKeyCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ISearchKey IReadOnlyList<ISearchKey>.Item[
    int index
] { get; }
Visual Basic (Declaration)
Private ReadOnly Property Item ( _
    index As Integer _
) As ISearchKey Implements IReadOnlyList(Of ISearchKey).Item
Visual C++
private:
virtual property ISearchKey^ Item[int index] {
    ISearchKey^ get (int index) sealed = IReadOnlyList<ISearchKey^>::Item::get;
}

Parameters

index
Type: System..::.Int32

Implements

IReadOnlyList<(Of <(T>)>)..::.Item[([(Int32])])

See Also

SearchKeyCollection Class
Mincom.LinkOne.Dom.Searching Namespace


SearchLimit Structure

[image]

LinkOne WebView API
SearchLimit Structure
Members See Also Send Feedback
Because it is possible for a LinkOne search to return large amounts of data, the LinkOne search allows a user to specify a limit for search results so that only records from the lower limit to the upper limit are returned.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public struct SearchLimit
Visual Basic (Declaration)
<SerializableAttribute> _
Public Structure SearchLimit
Visual C++
[SerializableAttribute]
public value class SearchLimit

See Also

SearchLimit Members
Mincom.LinkOne.Dom.Searching Namespace


SearchLimit Members

[image] [image]

LinkOne WebView API
SearchLimit Members
SearchLimit Structure Constructors Methods Fields Properties See Also Send Feedback

The SearchLimit type exposes the following members.

Constructors

Name | Description
SearchLimit | Overloaded.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

Name | Description
DefaultTotal | Gets the default total.
MaximumUpperBound | Gets the maximum upper bound of the SearchLimit object.

Properties

Name | Description
LowerBound | Gets the lower bound for this search limit.
Total | Gets the total number of search results.
UpperBound | Gets the upper bound for this search limit.

See Also

SearchLimit Structure
Mincom.LinkOne.Dom.Searching Namespace


SearchLimit Constructor

[image] [image]

LinkOne WebView API
SearchLimit Constructor
SearchLimit Structure See Also Send Feedback

Overload List

Name | Description
SearchLimit(Int32, Int32) | Initalizes a new instance of the SearchLimit class.
SearchLimit(Int32, Int32, Int32) | Initalizes a new instance of the SearchLimit class.

See Also

SearchLimit Structure
SearchLimit Members
Mincom.LinkOne.Dom.Searching Namespace


SearchLimit Constructor (Int32, Int32)

[image]

LinkOne WebView API
SearchLimit Constructor (Int32, Int32)
SearchLimit Structure See Also Send Feedback
Initalizes a new instance of the SearchLimit class.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchLimit(
    int lowerBound,
    int upperBound
)
Visual Basic (Declaration)
Public Sub New ( _
    lowerBound As Integer, _
    upperBound As Integer _
)
Visual C++
public:
SearchLimit(
    int lowerBound,
    int upperBound
)

Parameters

lowerBound
Type: System..::.Int32
The lower bound of the search limit.
upperBound
Type: System..::.Int32
The upper bound of the search limit.

Remarks

lowerBound must be less than upperBound, and upperBound must be less than Total.

See Also

SearchLimit Structure
SearchLimit Overload
Mincom.LinkOne.Dom.Searching Namespace


SearchLimit Constructor (Int32, Int32, Int32)

[image]

LinkOne WebView API
SearchLimit Constructor (Int32, Int32, Int32)
SearchLimit Structure See Also Send Feedback
Initalizes a new instance of the SearchLimit class.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchLimit(
    int lowerBound,
    int upperBound,
    int total
)
Visual Basic (Declaration)
Public Sub New ( _
    lowerBound As Integer, _
    upperBound As Integer, _
    total As Integer _
)
Visual C++
public:
SearchLimit(
    int lowerBound,
    int upperBound,
    int total
)

Parameters

lowerBound
Type: System..::.Int32
The lower bound of the search limit.
upperBound
Type: System..::.Int32
The upper bound of the search limit.
total
Type: System..::.Int32
The total number of records.

Remarks

lowerBound must be less than upperBound, and upperBound must be less than total.

See Also

SearchLimit Structure
SearchLimit Overload
Mincom.LinkOne.Dom.Searching Namespace


SearchLimit Fields

[image] [image]

LinkOne WebView API
SearchLimit Fields
SearchLimit Structure See Also Send Feedback

The SearchLimit type exposes the following members.

Fields

Name | Description
DefaultTotal | Gets the default total.
MaximumUpperBound | Gets the maximum upper bound of the SearchLimit object.

See Also

SearchLimit Structure
Mincom.LinkOne.Dom.Searching Namespace


DefaultTotal Field

[image]

LinkOne WebView API
SearchLimit..::.DefaultTotal Field
SearchLimit Structure See Also Send Feedback
Gets the default total.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const int DefaultTotal
Visual Basic (Declaration)
Public Const DefaultTotal As Integer
Visual C++
public:
literal int DefaultTotal

See Also

SearchLimit Structure
Mincom.LinkOne.Dom.Searching Namespace


MaximumUpperBound Field

[image]

LinkOne WebView API
SearchLimit..::.MaximumUpperBound Field
SearchLimit Structure See Also Send Feedback
Gets the maximum upper bound of the SearchLimit object.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const int MaximumUpperBound
Visual Basic (Declaration)
Public Const MaximumUpperBound As Integer
Visual C++
public:
literal int MaximumUpperBound

See Also

SearchLimit Structure
Mincom.LinkOne.Dom.Searching Namespace


SearchLimit Methods

[image] [image]

LinkOne WebView API
SearchLimit Methods
SearchLimit Structure See Also Send Feedback

The SearchLimit type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

SearchLimit Structure
Mincom.LinkOne.Dom.Searching Namespace


SearchLimit Properties

[image] [image]

LinkOne WebView API
SearchLimit Properties
SearchLimit Structure See Also Send Feedback

The SearchLimit type exposes the following members.

Properties

Name | Description
LowerBound | Gets the lower bound for this search limit.
Total | Gets the total number of search results.
UpperBound | Gets the upper bound for this search limit.

See Also

SearchLimit Structure
Mincom.LinkOne.Dom.Searching Namespace


LowerBound Property

[image]

LinkOne WebView API
SearchLimit..::.LowerBound Property
SearchLimit Structure See Also Send Feedback
Gets the lower bound for this search limit.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int LowerBound { get; }
Visual Basic (Declaration)
Public ReadOnly Property LowerBound As Integer
Visual C++
public:
property int LowerBound {
    int get ();
}

See Also

SearchLimit Structure
Mincom.LinkOne.Dom.Searching Namespace


Total Property

[image]

LinkOne WebView API
SearchLimit..::.Total Property
SearchLimit Structure See Also Send Feedback
Gets the total number of search results.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Total { get; }
Visual Basic (Declaration)
Public ReadOnly Property Total As Integer
Visual C++
public:
property int Total {
    int get ();
}

See Also

SearchLimit Structure
Mincom.LinkOne.Dom.Searching Namespace


UpperBound Property

[image]

LinkOne WebView API
SearchLimit..::.UpperBound Property
SearchLimit Structure See Also Send Feedback
Gets the upper bound for this search limit.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int UpperBound { get; }
Visual Basic (Declaration)
Public ReadOnly Property UpperBound As Integer
Visual C++
public:
property int UpperBound {
    int get ();
}

See Also

SearchLimit Structure
Mincom.LinkOne.Dom.Searching Namespace


SearchPageFieldMap Class

[image]

LinkOne WebView API
SearchPageFieldMap Class
Members See Also Send Feedback
A map of page fields and page references.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public sealed class SearchPageFieldMap : ISearchOverField
Visual Basic (Declaration)
Public NotInheritable Class SearchPageFieldMap _
    Implements ISearchOverField
Visual C++
public ref class SearchPageFieldMap sealed : ISearchOverField

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Searching..::.SearchPageFieldMap

See Also

SearchPageFieldMap Members
Mincom.LinkOne.Dom.Searching Namespace


SearchPageFieldMap Members

[image] [image]

LinkOne WebView API
SearchPageFieldMap Members
SearchPageFieldMap Class Methods Events See Also Send Feedback

The SearchPageFieldMap type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Find | Returns the collection of search results that match the given value.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Events

Name | Description
SearchProgress | This event provides updates on the progress of a search.

See Also

SearchPageFieldMap Class
Mincom.LinkOne.Dom.Searching Namespace


SearchPageFieldMap Methods

[image] [image]

LinkOne WebView API
SearchPageFieldMap Methods
SearchPageFieldMap Class See Also Send Feedback

The SearchPageFieldMap type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Find | Returns the collection of search results that match the given value.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SearchPageFieldMap Class
Mincom.LinkOne.Dom.Searching Namespace


Find Method

[image]

LinkOne WebView API
SearchPageFieldMap..::.Find Method
SearchPageFieldMap Class See Also Send Feedback
Returns the collection of search results that match the given value.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchResultCollection Find(
    string value,
    bool matchCase,
    bool exactMatch,
    Regex noiseFilter,
    string displayField,
    string preferredListTitle,
    string languageCode
)
Visual Basic (Declaration)
Public Function Find ( _
    value As String, _
    matchCase As Boolean, _
    exactMatch As Boolean, _
    noiseFilter As Regex, _
    displayField As String, _
    preferredListTitle As String, _
    languageCode As String _
) As SearchResultCollection
Visual C++
public:
virtual SearchResultCollection^ Find(
    String^ value,
    bool matchCase,
    bool exactMatch,
    Regex^ noiseFilter,
    String^ displayField,
    String^ preferredListTitle,
    String^ languageCode
) sealed

Parameters

value
Type: System..::.String
The value to search for.
matchCase
Type: System..::.Boolean
True to match the case during the search.
exactMatch
Type: System..::.Boolean
True to match the full value length.
noiseFilter
Type: System.Text.RegularExpressions..::.Regex
Regular expression to apply to the searched string prior to searching it.
displayField
Type: System..::.String
The display field to choose for each result.
preferredListTitle
Type: System..::.String
The preferred list title.
languageCode
Type: System..::.String
The language code.

Return Value

The collection of search results that match the given value.

Implements

ISearchOverField..::.Find(String, Boolean, Boolean, Regex, String, String, String)

See Also

SearchPageFieldMap Class
Mincom.LinkOne.Dom.Searching Namespace


SearchPageFieldMap Events

[image] [image]

LinkOne WebView API
SearchPageFieldMap Events
SearchPageFieldMap Class See Also Send Feedback

The SearchPageFieldMap type exposes the following members.

Events

Name | Description
SearchProgress | This event provides updates on the progress of a search.

See Also

SearchPageFieldMap Class
Mincom.LinkOne.Dom.Searching Namespace


SearchProgress Event

[image]

LinkOne WebView API
SearchPageFieldMap..::.SearchProgress Event
SearchPageFieldMap Class See Also Send Feedback
This event provides updates on the progress of a search.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public event SearchProgressEventHandler SearchProgress
Visual Basic (Declaration)
Public Event SearchProgress As SearchProgressEventHandler
Visual C++
public:
virtual  event SearchProgressEventHandler^ SearchProgress {
    void add (SearchProgressEventHandler^ value);
    void remove (SearchProgressEventHandler^ value);
}

Implements

ISearchOverField..::.SearchProgress

See Also

SearchPageFieldMap Class
Mincom.LinkOne.Dom.Searching Namespace


SearchPageFieldMapOverBook Class

[image]

LinkOne WebView API
SearchPageFieldMapOverBook Class
Members See Also Send Feedback
A map of page fields and page references created over the indexes existing within a book.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public sealed class SearchPageFieldMapOverBook : ISearchOverField
Visual Basic (Declaration)
Public NotInheritable Class SearchPageFieldMapOverBook _
    Implements ISearchOverField
Visual C++
public ref class SearchPageFieldMapOverBook sealed : ISearchOverField

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Searching..::.SearchPageFieldMapOverBook

See Also

SearchPageFieldMapOverBook Members
Mincom.LinkOne.Dom.Searching Namespace


SearchPageFieldMapOverBook Members

[image] [image]

LinkOne WebView API
SearchPageFieldMapOverBook Members
SearchPageFieldMapOverBook Class Methods Events See Also Send Feedback

The SearchPageFieldMapOverBook type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Find | Returns the collection of search results that match the given value.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Events

Name | Description
SearchProgress | This event provides updates on the progress of a search.

See Also

SearchPageFieldMapOverBook Class
Mincom.LinkOne.Dom.Searching Namespace


SearchPageFieldMapOverBook Methods

[image] [image]

LinkOne WebView API
SearchPageFieldMapOverBook Methods
SearchPageFieldMapOverBook Class See Also Send Feedback

The SearchPageFieldMapOverBook type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Find | Returns the collection of search results that match the given value.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SearchPageFieldMapOverBook Class
Mincom.LinkOne.Dom.Searching Namespace


Find Method

[image]

LinkOne WebView API
SearchPageFieldMapOverBook..::.Find Method
SearchPageFieldMapOverBook Class See Also Send Feedback
Returns the collection of search results that match the given value.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchResultCollection Find(
    string value,
    bool matchCase,
    bool exactMatch,
    Regex noiseFilter,
    string displayField,
    string preferredListTitle,
    string languageCode
)
Visual Basic (Declaration)
Public Function Find ( _
    value As String, _
    matchCase As Boolean, _
    exactMatch As Boolean, _
    noiseFilter As Regex, _
    displayField As String, _
    preferredListTitle As String, _
    languageCode As String _
) As SearchResultCollection
Visual C++
public:
virtual SearchResultCollection^ Find(
    String^ value,
    bool matchCase,
    bool exactMatch,
    Regex^ noiseFilter,
    String^ displayField,
    String^ preferredListTitle,
    String^ languageCode
) sealed

Parameters

value
Type: System..::.String
The value to search for.
matchCase
Type: System..::.Boolean
True to match the case during the search.
exactMatch
Type: System..::.Boolean
True to match the full value length.
noiseFilter
Type: System.Text.RegularExpressions..::.Regex
Regular expression to apply to the searched string prior to searching it.
displayField
Type: System..::.String
The display field to choose for each result.
preferredListTitle
Type: System..::.String
The preferred list title.
languageCode
Type: System..::.String
The language code.

Return Value

The collection of search results that match the given value.

Implements

ISearchOverField..::.Find(String, Boolean, Boolean, Regex, String, String, String)

See Also

SearchPageFieldMapOverBook Class
Mincom.LinkOne.Dom.Searching Namespace


SearchPageFieldMapOverBook Events

[image] [image]

LinkOne WebView API
SearchPageFieldMapOverBook Events
SearchPageFieldMapOverBook Class See Also Send Feedback

The SearchPageFieldMapOverBook type exposes the following members.

Events

Name | Description
SearchProgress | This event provides updates on the progress of a search.

See Also

SearchPageFieldMapOverBook Class
Mincom.LinkOne.Dom.Searching Namespace


SearchProgress Event

[image]

LinkOne WebView API
SearchPageFieldMapOverBook..::.SearchProgress Event
SearchPageFieldMapOverBook Class See Also Send Feedback
This event provides updates on the progress of a search.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public event SearchProgressEventHandler SearchProgress
Visual Basic (Declaration)
Public Event SearchProgress As SearchProgressEventHandler
Visual C++
public:
virtual  event SearchProgressEventHandler^ SearchProgress {
    void add (SearchProgressEventHandler^ value);
    void remove (SearchProgressEventHandler^ value);
}

Implements

ISearchOverField..::.SearchProgress

See Also

SearchPageFieldMapOverBook Class
Mincom.LinkOne.Dom.Searching Namespace


SearchPageMap Class

[image]

LinkOne WebView API
SearchPageMap Class
Members See Also Send Feedback
A map of page field searches.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public sealed class SearchPageMap
Visual Basic (Declaration)
Public NotInheritable Class SearchPageMap
Visual C++
public ref class SearchPageMap sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Searching..::.SearchPageMap

See Also

SearchPageMap Members
Mincom.LinkOne.Dom.Searching Namespace


SearchPageMap Members

[image] [image]

LinkOne WebView API
SearchPageMap Members
SearchPageMap Class Methods Properties See Also Send Feedback

The SearchPageMap type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Item | Gets the map for the given field.

See Also

SearchPageMap Class
Mincom.LinkOne.Dom.Searching Namespace


SearchPageMap Methods

[image] [image]

LinkOne WebView API
SearchPageMap Methods
SearchPageMap Class See Also Send Feedback

The SearchPageMap type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SearchPageMap Class
Mincom.LinkOne.Dom.Searching Namespace


SearchPageMap Properties

[image] [image]

LinkOne WebView API
SearchPageMap Properties
SearchPageMap Class See Also Send Feedback

The SearchPageMap type exposes the following members.

Properties

Name | Description
Item | Gets the map for the given field.

See Also

SearchPageMap Class
Mincom.LinkOne.Dom.Searching Namespace


Item Property

[image]

LinkOne WebView API
SearchPageMap..::.Item Property
SearchPageMap Class See Also Send Feedback
Gets the map for the given field.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ISearchOverField this[
    string field
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    field As String _
) As ISearchOverField
Visual C++
public:
property ISearchOverField^ default[String^ field] {
    ISearchOverField^ get (String^ field);
}

Parameters

field
Type: System..::.String

See Also

SearchPageMap Class
Mincom.LinkOne.Dom.Searching Namespace


SearchParameter Class

[image]

LinkOne WebView API
SearchParameter Class
Members See Also Send Feedback
Represents a Linkone search parameter.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class SearchParameter : ISearchParameter
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class SearchParameter _
    Implements ISearchParameter
Visual C++
[SerializableAttribute]
public ref class SearchParameter sealed : ISearchParameter

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Searching..::.SearchParameter

See Also

SearchParameter Members
Mincom.LinkOne.Dom.Searching Namespace


SearchParameter Members

[image] [image]

LinkOne WebView API
SearchParameter Members
SearchParameter Class Constructors Methods Properties See Also Send Feedback

The SearchParameter type exposes the following members.

Constructors

Name | Description
SearchParameter | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
ExactMatch | Gets or sets the flag for exact matching.
MatchCase | Gets or sets the flag for matching case.
Value | Gets and sets the search value.

See Also

SearchParameter Class
Mincom.LinkOne.Dom.Searching Namespace


SearchParameter Constructor

[image] [image]

LinkOne WebView API
SearchParameter Constructor
SearchParameter Class See Also Send Feedback

Overload List

Name | Description
SearchParameter()()() | Initialises a new instance of the SearchParameter class.
SearchParameter(String, Boolean, Boolean) | Initialises a new instance of the SearchParameter class.

See Also

SearchParameter Class
SearchParameter Members
Mincom.LinkOne.Dom.Searching Namespace


SearchParameter Constructor

[image]

LinkOne WebView API
SearchParameter Constructor
SearchParameter Class See Also Send Feedback
Initialises a new instance of the SearchParameter class.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchParameter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SearchParameter()

See Also

SearchParameter Class
SearchParameter Overload
Mincom.LinkOne.Dom.Searching Namespace


SearchParameter Constructor (String, Boolean, Boolean)

[image]

LinkOne WebView API
SearchParameter Constructor (String, Boolean, Boolean)
SearchParameter Class See Also Send Feedback
Initialises a new instance of the SearchParameter class.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchParameter(
    string value,
    bool matchCase,
    bool exactMatch
)
Visual Basic (Declaration)
Public Sub New ( _
    value As String, _
    matchCase As Boolean, _
    exactMatch As Boolean _
)
Visual C++
public:
SearchParameter(
    String^ value,
    bool matchCase,
    bool exactMatch
)

Parameters

value
Type: System..::.String
Value to search for.
matchCase
Type: System..::.Boolean
True to match the case during searching.
exactMatch
Type: System..::.Boolean
True to exactly match the value length.

See Also

SearchParameter Class
SearchParameter Overload
Mincom.LinkOne.Dom.Searching Namespace


SearchParameter Methods

[image] [image]

LinkOne WebView API
SearchParameter Methods
SearchParameter Class See Also Send Feedback

The SearchParameter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SearchParameter Class
Mincom.LinkOne.Dom.Searching Namespace


SearchParameter Properties

[image] [image]

LinkOne WebView API
SearchParameter Properties
SearchParameter Class See Also Send Feedback

The SearchParameter type exposes the following members.

Properties

Name | Description
ExactMatch | Gets or sets the flag for exact matching.
MatchCase | Gets or sets the flag for matching case.
Value | Gets and sets the search value.

See Also

SearchParameter Class
Mincom.LinkOne.Dom.Searching Namespace


ExactMatch Property

[image]

LinkOne WebView API
SearchParameter..::.ExactMatch Property
SearchParameter Class See Also Send Feedback
Gets or sets the flag for exact matching.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool ExactMatch { get; set; }
Visual Basic (Declaration)
Public Property ExactMatch As Boolean
Visual C++
public:
virtual property bool ExactMatch {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

ISearchParameter..::.ExactMatch

See Also

SearchParameter Class
Mincom.LinkOne.Dom.Searching Namespace


MatchCase Property

[image]

LinkOne WebView API
SearchParameter..::.MatchCase Property
SearchParameter Class See Also Send Feedback
Gets or sets the flag for matching case.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool MatchCase { get; set; }
Visual Basic (Declaration)
Public Property MatchCase As Boolean
Visual C++
public:
virtual property bool MatchCase {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

ISearchParameter..::.MatchCase

See Also

SearchParameter Class
Mincom.LinkOne.Dom.Searching Namespace


Value Property

[image]

LinkOne WebView API
SearchParameter..::.Value Property
SearchParameter Class See Also Send Feedback
Gets and sets the search value.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String
Visual C++
public:
virtual property String^ Value {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ISearchParameter..::.Value

See Also

SearchParameter Class
Mincom.LinkOne.Dom.Searching Namespace


SearchParameterCollection Class

[image]

LinkOne WebView API
SearchParameterCollection Class
Members See Also Send Feedback
Represents a collection of search parameters that can be accessed by index.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class SearchParameterCollection : Collection<SearchParameter>,
    IReadOnlyList<SearchParameter>, IReadOnlyCollection<SearchParameter>, IEnumerable<SearchParameter>,
    ISearchParameterCollection, IList<ISearchParameter>, ICollection<ISearchParameter>,
    IEnumerable<ISearchParameter>, IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class SearchParameterCollection _
    Inherits Collection(Of SearchParameter) _
    Implements IReadOnlyList(Of SearchParameter), IReadOnlyCollection(Of SearchParameter),  _
    IEnumerable(Of SearchParameter), ISearchParameterCollection, IList(Of ISearchParameter),  _
    ICollection(Of ISearchParameter), IEnumerable(Of ISearchParameter), IEnumerable
Visual C++
[SerializableAttribute]
public ref class SearchParameterCollection sealed : public Collection<SearchParameter^>,
    IReadOnlyList<SearchParameter^>, IReadOnlyCollection<SearchParameter^>, IEnumerable<SearchParameter^>,
    ISearchParameterCollection, IList<ISearchParameter^>, ICollection<ISearchParameter^>,
    IEnumerable<ISearchParameter^>, IEnumerable

Remarks

nulls are not allowed.

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection<(Of <( SearchParameter >)>)
Mincom.LinkOne.Dom.Searching..::.SearchParameterCollection

See Also

SearchParameterCollection Members
Mincom.LinkOne.Dom.Searching Namespace


SearchParameterCollection Members

[image] [image]

LinkOne WebView API
SearchParameterCollection Members
SearchParameterCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The SearchParameterCollection type exposes the following members.

Constructors

Name | Description
SearchParameterCollection | Initializes a new instance of the SearchParameterCollection class

Methods

Name | Description
Add | Overloaded.
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SearchParameter >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SearchParameter >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SearchParameter >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( SearchParameter >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SearchParameter >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SearchParameter >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( SearchParameter >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( SearchParameter >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SearchParameter >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SearchParameter >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SearchParameter >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( SearchParameter >)>).)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SearchParameter >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( SearchParameter >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SearchParameter >)>).)
LanguageCode | Gets or sets the ISO-639 language code.
PreferredListTitle | Gets or sets the preferred list title.

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds an item to the IList. (Inherited from Collection<(Of <( SearchParameter >)>).)
ICollection<(Of <(ISearchParameter>)>)..::.Add |
ICollection<(Of <(ISearchParameter>)>)..::.Clear |
IList..::.Contains | Determines whether the IList contains a specific value. (Inherited from Collection<(Of <( SearchParameter >)>).)
ICollection<(Of <(ISearchParameter>)>)..::.Contains |
ICollection..::.CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection<(Of <( SearchParameter >)>).)
ICollection<(Of <(ISearchParameter>)>)..::.CopyTo |
ICollection<(Of <(ISearchParameter>)>)..::.Count |
IEnumerable<(Of <(ISearchParameter>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator |
IList..::.IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection<(Of <( SearchParameter >)>).)
IList<(Of <(ISearchParameter>)>)..::.IndexOf |
IList..::.Insert | Inserts an item into the IList at the specified index. (Inherited from Collection<(Of <( SearchParameter >)>).)
IList<(Of <(ISearchParameter>)>)..::.Insert |
IList..::.IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection<(Of <( SearchParameter >)>).)
IsReadOnly | Overloaded.
IList..::.IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection<(Of <( SearchParameter >)>).)
ICollection..::.IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection<(Of <( SearchParameter >)>).)
IList..::.Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( SearchParameter >)>).)
IList<(Of <(ISearchParameter>)>)..::.Item |
IList..::.Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection<(Of <( SearchParameter >)>).)
ICollection<(Of <(ISearchParameter>)>)..::.Remove |
IList<(Of <(ISearchParameter>)>)..::.RemoveAt |
ICollection..::.SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection<(Of <( SearchParameter >)>).)

See Also

SearchParameterCollection Class
Mincom.LinkOne.Dom.Searching Namespace


SearchParameterCollection Constructor

[image]

LinkOne WebView API
SearchParameterCollection Constructor
SearchParameterCollection Class See Also Send Feedback
Initializes a new instance of the SearchParameterCollection class

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchParameterCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SearchParameterCollection()

See Also

SearchParameterCollection Class
Mincom.LinkOne.Dom.Searching Namespace


SearchParameterCollection Methods

[image] [image]

LinkOne WebView API
SearchParameterCollection Methods
SearchParameterCollection Class See Also Send Feedback

The SearchParameterCollection type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SearchParameter >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SearchParameter >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SearchParameter >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( SearchParameter >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SearchParameter >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SearchParameter >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( SearchParameter >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( SearchParameter >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SearchParameter >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SearchParameter >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SearchParameter >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( SearchParameter >)>).)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds an item to the IList. (Inherited from Collection<(Of <( SearchParameter >)>).)
ICollection<(Of <(ISearchParameter>)>)..::.Add |
ICollection<(Of <(ISearchParameter>)>)..::.Clear |
IList..::.Contains | Determines whether the IList contains a specific value. (Inherited from Collection<(Of <( SearchParameter >)>).)
ICollection<(Of <(ISearchParameter>)>)..::.Contains |
ICollection..::.CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection<(Of <( SearchParameter >)>).)
ICollection<(Of <(ISearchParameter>)>)..::.CopyTo |
IEnumerable<(Of <(ISearchParameter>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator |
IList..::.IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection<(Of <( SearchParameter >)>).)
IList<(Of <(ISearchParameter>)>)..::.IndexOf |
IList..::.Insert | Inserts an item into the IList at the specified index. (Inherited from Collection<(Of <( SearchParameter >)>).)
IList<(Of <(ISearchParameter>)>)..::.Insert |
IList..::.Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection<(Of <( SearchParameter >)>).)
ICollection<(Of <(ISearchParameter>)>)..::.Remove |
IList<(Of <(ISearchParameter>)>)..::.RemoveAt |

See Also

SearchParameterCollection Class
Mincom.LinkOne.Dom.Searching Namespace


ICollection(ISearchParameter).Add Method

[image]

LinkOne WebView API
SearchParameterCollection..::.ICollection<(Of <(ISearchParameter>)>)..::.Add Method
SearchParameterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<ISearchParameter>.Add(
    ISearchParameter item
)
Visual Basic (Declaration)
Private Sub Add ( _
    item As ISearchParameter _
) Implements ICollection(Of ISearchParameter).Add
Visual C++
private:
virtual void Add(
    ISearchParameter^ item
) sealed = ICollection<ISearchParameter^>::Add

Parameters

item
Type: Mincom.LinkOne.Dom.Searching..::.ISearchParameter

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

SearchParameterCollection Class
Mincom.LinkOne.Dom.Searching Namespace


ICollection(ISearchParameter).Clear Method

[image]

LinkOne WebView API
SearchParameterCollection..::.ICollection<(Of <(ISearchParameter>)>)..::.Clear Method
SearchParameterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<ISearchParameter>.Clear()
Visual Basic (Declaration)
Private Sub Clear Implements ICollection(Of ISearchParameter).Clear
Visual C++
private:
virtual void Clear() sealed = ICollection<ISearchParameter^>::Clear

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

See Also

SearchParameterCollection Class
Mincom.LinkOne.Dom.Searching Namespace


ICollection(ISearchParameter).Contains Method

[image]

LinkOne WebView API
SearchParameterCollection..::.ICollection<(Of <(ISearchParameter>)>)..::.Contains Method
SearchParameterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<ISearchParameter>.Contains(
    ISearchParameter item
)
Visual Basic (Declaration)
Private Function Contains ( _
    item As ISearchParameter _
) As Boolean Implements ICollection(Of ISearchParameter).Contains
Visual C++
private:
virtual bool Contains(
    ISearchParameter^ item
) sealed = ICollection<ISearchParameter^>::Contains

Parameters

item
Type: Mincom.LinkOne.Dom.Searching..::.ISearchParameter

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

SearchParameterCollection Class
Mincom.LinkOne.Dom.Searching Namespace


ICollection(ISearchParameter).CopyTo Method

[image]

LinkOne WebView API
SearchParameterCollection..::.ICollection<(Of <(ISearchParameter>)>)..::.CopyTo Method
SearchParameterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<ISearchParameter>.CopyTo(
    ISearchParameter[] array,
    int arrayIndex
)
Visual Basic (Declaration)
Private Sub CopyTo ( _
    array As ISearchParameter(), _
    arrayIndex As Integer _
) Implements ICollection(Of ISearchParameter).CopyTo
Visual C++
private:
virtual void CopyTo(
    array<ISearchParameter^>^ array,
    int arrayIndex
) sealed = ICollection<ISearchParameter^>::CopyTo

Parameters

array
Type: array< Mincom.LinkOne.Dom.Searching..::.ISearchParameter >[]()[]
arrayIndex
Type: System..::.Int32

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

SearchParameterCollection Class
Mincom.LinkOne.Dom.Searching Namespace


IEnumerable(ISearchParameter).GetEnumerator Method

[image]

LinkOne WebView API
SearchParameterCollection..::.IEnumerable<(Of <(ISearchParameter>)>)..::.GetEnumerator Method
SearchParameterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator<ISearchParameter> IEnumerable<ISearchParameter>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of ISearchParameter)
    Implements IEnumerable(Of ISearchParameter).GetEnumerator
Visual C++
private:
virtual IEnumerator<ISearchParameter^>^ GetEnumerator() sealed = IEnumerable<ISearchParameter^>::GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

SearchParameterCollection Class
Mincom.LinkOne.Dom.Searching Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
SearchParameterCollection..::.IEnumerable..::.GetEnumerator Method
SearchParameterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Implements

IEnumerable..::.GetEnumerator()()()

See Also

SearchParameterCollection Class
Mincom.LinkOne.Dom.Searching Namespace


IList(ISearchParameter).IndexOf Method

[image]

LinkOne WebView API
SearchParameterCollection..::.IList<(Of <(ISearchParameter>)>)..::.IndexOf Method
SearchParameterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int IList<ISearchParameter>.IndexOf(
    ISearchParameter item
)
Visual Basic (Declaration)
Private Function IndexOf ( _
    item As ISearchParameter _
) As Integer Implements IList(Of ISearchParameter).IndexOf
Visual C++
private:
virtual int IndexOf(
    ISearchParameter^ item
) sealed = IList<ISearchParameter^>::IndexOf

Parameters

item
Type: Mincom.LinkOne.Dom.Searching..::.ISearchParameter

Implements

IList<(Of <(T>)>)..::.IndexOf(T)

See Also

SearchParameterCollection Class
Mincom.LinkOne.Dom.Searching Namespace


IList(ISearchParameter).Insert Method

[image]

LinkOne WebView API
SearchParameterCollection..::.IList<(Of <(ISearchParameter>)>)..::.Insert Method
SearchParameterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void IList<ISearchParameter>.Insert(
    int index,
    ISearchParameter item
)
Visual Basic (Declaration)
Private Sub Insert ( _
    index As Integer, _
    item As ISearchParameter _
) Implements IList(Of ISearchParameter).Insert
Visual C++
private:
virtual void Insert(
    int index,
    ISearchParameter^ item
) sealed = IList<ISearchParameter^>::Insert

Parameters

index
Type: System..::.Int32
item
Type: Mincom.LinkOne.Dom.Searching..::.ISearchParameter

Implements

IList<(Of <(T>)>)..::.Insert(Int32, T)

See Also

SearchParameterCollection Class
Mincom.LinkOne.Dom.Searching Namespace


ICollection(ISearchParameter).Remove Method

[image]

LinkOne WebView API
SearchParameterCollection..::.ICollection<(Of <(ISearchParameter>)>)..::.Remove Method
SearchParameterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<ISearchParameter>.Remove(
    ISearchParameter item
)
Visual Basic (Declaration)
Private Function Remove ( _
    item As ISearchParameter _
) As Boolean Implements ICollection(Of ISearchParameter).Remove
Visual C++
private:
virtual bool Remove(
    ISearchParameter^ item
) sealed = ICollection<ISearchParameter^>::Remove

Parameters

item
Type: Mincom.LinkOne.Dom.Searching..::.ISearchParameter

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

SearchParameterCollection Class
Mincom.LinkOne.Dom.Searching Namespace


IList(ISearchParameter).RemoveAt Method

[image]

LinkOne WebView API
SearchParameterCollection..::.IList<(Of <(ISearchParameter>)>)..::.RemoveAt Method
SearchParameterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void IList<ISearchParameter>.RemoveAt(
    int index
)
Visual Basic (Declaration)
Private Sub RemoveAt ( _
    index As Integer _
) Implements IList(Of ISearchParameter).RemoveAt
Visual C++
private:
virtual void RemoveAt(
    int index
) sealed = IList<ISearchParameter^>::RemoveAt

Parameters

index
Type: System..::.Int32

Implements

IList<(Of <(T>)>)..::.RemoveAt(Int32)

See Also

SearchParameterCollection Class
Mincom.LinkOne.Dom.Searching Namespace


Add Method

[image] [image]

LinkOne WebView API
SearchParameterCollection..::.Add Method
SearchParameterCollection Class See Also Send Feedback

Overload List

Name | Description
Add(T) | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SearchParameter >)>).)
Add(String, Boolean, Boolean) | Adds a search parameter initialized with the given values.

See Also

SearchParameterCollection Class
SearchParameterCollection Members
Mincom.LinkOne.Dom.Searching Namespace


Add Method (String, Boolean, Boolean)

[image]

LinkOne WebView API
SearchParameterCollection..::.Add Method (String, Boolean, Boolean)
SearchParameterCollection Class See Also Send Feedback
Adds a search parameter initialized with the given values.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Add(
    string value,
    bool matchCase,
    bool exactMatch
)
Visual Basic (Declaration)
Public Sub Add ( _
    value As String, _
    matchCase As Boolean, _
    exactMatch As Boolean _
)
Visual C++
public:
virtual void Add(
    String^ value,
    bool matchCase,
    bool exactMatch
) sealed

Parameters

value
Type: System..::.String
The value.
matchCase
Type: System..::.Boolean
Whether the value is case-sensitive.
exactMatch
Type: System..::.Boolean
Whether the value should be matched exactly.

Implements

ISearchParameterCollection..::.Add(String, Boolean, Boolean)

See Also

SearchParameterCollection Class
Add Overload
Mincom.LinkOne.Dom.Searching Namespace


SearchParameterCollection Properties

[image] [image]

LinkOne WebView API
SearchParameterCollection Properties
SearchParameterCollection Class See Also Send Feedback

The SearchParameterCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SearchParameter >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( SearchParameter >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SearchParameter >)>).)
LanguageCode | Gets or sets the ISO-639 language code.
PreferredListTitle | Gets or sets the preferred list title.

Explicit Interface Implementations

Name | Description
ICollection<(Of <(ISearchParameter>)>)..::.Count |
IList..::.IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection<(Of <( SearchParameter >)>).)
IsReadOnly | Overloaded.
IList..::.IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection<(Of <( SearchParameter >)>).)
ICollection..::.IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection<(Of <( SearchParameter >)>).)
IList..::.Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( SearchParameter >)>).)
IList<(Of <(ISearchParameter>)>)..::.Item |
ICollection..::.SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection<(Of <( SearchParameter >)>).)

See Also

SearchParameterCollection Class
Mincom.LinkOne.Dom.Searching Namespace


ICollection(ISearchParameter).Count Property

[image]

LinkOne WebView API
SearchParameterCollection..::.ICollection<(Of <(ISearchParameter>)>)..::.Count Property
SearchParameterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int ICollection<ISearchParameter>.Count { get; }
Visual Basic (Declaration)
Private ReadOnly Property Count As Integer
    Implements ICollection(Of ISearchParameter).Count
Visual C++
private:
virtual property int Count {
    int get () sealed = ICollection<ISearchParameter^>::Count::get;
}

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

SearchParameterCollection Class
Mincom.LinkOne.Dom.Searching Namespace


IList(ISearchParameter).Item Property

[image]

LinkOne WebView API
SearchParameterCollection..::.IList<(Of <(ISearchParameter>)>)..::.Item Property
SearchParameterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ISearchParameter IList<ISearchParameter>.Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Private Property Item ( _
    index As Integer _
) As ISearchParameter Implements IList(Of ISearchParameter).Item
Visual C++
private:
virtual property ISearchParameter^ Item[int index] {
    ISearchParameter^ get (int index) sealed = IList<ISearchParameter^>::Item::get;
    void set (int index, ISearchParameter^ value) sealed = IList<ISearchParameter^>::Item::set;
}

Parameters

index
Type: System..::.Int32

Implements

IList<(Of <(T>)>)..::.Item[([(Int32])])

See Also

SearchParameterCollection Class
Mincom.LinkOne.Dom.Searching Namespace


IsReadOnly Property

[image] [image]

LinkOne WebView API
SearchParameterCollection..::.IsReadOnly Property
SearchParameterCollection Class See Also Send Feedback

Overload List

Name | Description
System#Collections#Generic#ICollection{T}#IsReadOnly()()() | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from Collection<(Of <( SearchParameter >)>).)
ICollection<(Of <(ISearchParameter>)>)..::.IsReadOnly |

See Also

SearchParameterCollection Class
SearchParameterCollection Members
Mincom.LinkOne.Dom.Searching Namespace


ICollection(ISearchParameter).IsReadOnly Property

[image]

LinkOne WebView API
SearchParameterCollection..::.ICollection<(Of <(ISearchParameter>)>)..::.IsReadOnly Property
SearchParameterCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<ISearchParameter>.IsReadOnly { get; }
Visual Basic (Declaration)
Private ReadOnly Property IsReadOnly As Boolean
    Implements ICollection(Of ISearchParameter).IsReadOnly
Visual C++
private:
virtual property bool IsReadOnly {
    bool get () sealed = ICollection<ISearchParameter^>::IsReadOnly::get;
}

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

SearchParameterCollection Class
SearchParameterCollection Overload
Mincom.LinkOne.Dom.Searching Namespace


LanguageCode Property

[image]

LinkOne WebView API
SearchParameterCollection..::.LanguageCode Property
SearchParameterCollection Class See Also Send Feedback
Gets or sets the ISO-639 language code.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string LanguageCode { get; set; }
Visual Basic (Declaration)
Public Property LanguageCode As String
Visual C++
public:
virtual property String^ LanguageCode {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ISearchParameterCollection..::.LanguageCode

See Also

SearchParameterCollection Class
Mincom.LinkOne.Dom.Searching Namespace


PreferredListTitle Property

[image]

LinkOne WebView API
SearchParameterCollection..::.PreferredListTitle Property
SearchParameterCollection Class See Also Send Feedback
Gets or sets the preferred list title.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PreferredListTitle { get; set; }
Visual Basic (Declaration)
Public Property PreferredListTitle As String
Visual C++
public:
virtual property String^ PreferredListTitle {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ISearchParameterCollection..::.PreferredListTitle

See Also

SearchParameterCollection Class
Mincom.LinkOne.Dom.Searching Namespace


SearchProgressEventArgs Class

[image]

LinkOne WebView API
SearchProgressEventArgs Class
Members See Also Send Feedback
Provides data for the SearchProgressEventHandler handler.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public sealed class SearchProgressEventArgs : CancelEventArgs
Visual Basic (Declaration)
Public NotInheritable Class SearchProgressEventArgs _
    Inherits CancelEventArgs
Visual C++
public ref class SearchProgressEventArgs sealed : public CancelEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.CancelEventArgs
Mincom.LinkOne.Dom.Searching..::.SearchProgressEventArgs

See Also

SearchProgressEventArgs Members
Mincom.LinkOne.Dom.Searching Namespace


SearchProgressEventArgs Members

[image] [image]

LinkOne WebView API
SearchProgressEventArgs Members
SearchProgressEventArgs Class Constructors Methods Properties See Also Send Feedback

The SearchProgressEventArgs type exposes the following members.

Constructors

Name | Description
SearchProgressEventArgs | Constructor.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Completed | The number of books that have been searched.
Title | The title of the book we are searching.
Total | The total number of books we are searching.

See Also

SearchProgressEventArgs Class
Mincom.LinkOne.Dom.Searching Namespace


SearchProgressEventArgs Constructor

[image]

LinkOne WebView API
SearchProgressEventArgs Constructor
SearchProgressEventArgs Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchProgressEventArgs(
    int completed,
    int total,
    string title
)
Visual Basic (Declaration)
Public Sub New ( _
    completed As Integer, _
    total As Integer, _
    title As String _
)
Visual C++
public:
SearchProgressEventArgs(
    int completed,
    int total,
    String^ title
)

Parameters

completed
Type: System..::.Int32
The number of books that have been searched.
total
Type: System..::.Int32
The total number of books being searching.
title
Type: System..::.String
The title of the book being searched.

See Also

SearchProgressEventArgs Class
Mincom.LinkOne.Dom.Searching Namespace


SearchProgressEventArgs Methods

[image] [image]

LinkOne WebView API
SearchProgressEventArgs Methods
SearchProgressEventArgs Class See Also Send Feedback

The SearchProgressEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SearchProgressEventArgs Class
Mincom.LinkOne.Dom.Searching Namespace


SearchProgressEventArgs Properties

[image] [image]

LinkOne WebView API
SearchProgressEventArgs Properties
SearchProgressEventArgs Class See Also Send Feedback

The SearchProgressEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Completed | The number of books that have been searched.
Title | The title of the book we are searching.
Total | The total number of books we are searching.

See Also

SearchProgressEventArgs Class
Mincom.LinkOne.Dom.Searching Namespace


Completed Property

[image]

LinkOne WebView API
SearchProgressEventArgs..::.Completed Property
SearchProgressEventArgs Class See Also Send Feedback
The number of books that have been searched.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Completed { get; }
Visual Basic (Declaration)
Public ReadOnly Property Completed As Integer
Visual C++
public:
property int Completed {
    int get ();
}

See Also

SearchProgressEventArgs Class
Mincom.LinkOne.Dom.Searching Namespace


Title Property

[image]

LinkOne WebView API
SearchProgressEventArgs..::.Title Property
SearchProgressEventArgs Class See Also Send Feedback
The title of the book we are searching.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Title { get; }
Visual Basic (Declaration)
Public ReadOnly Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
}

See Also

SearchProgressEventArgs Class
Mincom.LinkOne.Dom.Searching Namespace


Total Property

[image]

LinkOne WebView API
SearchProgressEventArgs..::.Total Property
SearchProgressEventArgs Class See Also Send Feedback
The total number of books we are searching.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Total { get; }
Visual Basic (Declaration)
Public ReadOnly Property Total As Integer
Visual C++
public:
property int Total {
    int get ();
}

See Also

SearchProgressEventArgs Class
Mincom.LinkOne.Dom.Searching Namespace


SearchProgressEventHandler Delegate

[image]

LinkOne WebView API
SearchProgressEventHandler Delegate
See Also Send Feedback
Delegate for SearchProgress events.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public delegate void SearchProgressEventHandler(
    Object sender,
    SearchProgressEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub SearchProgressEventHandler ( _
    sender As Object, _
    e As SearchProgressEventArgs _
)
Visual C++
public delegate void SearchProgressEventHandler(
    Object^ sender,
    SearchProgressEventArgs^ e
)

Parameters

sender
Type: System..::.Object
e
Type: Mincom.LinkOne.Dom.Searching..::.SearchProgressEventArgs

Remarks

This is a cancellable event.

See Also

Mincom.LinkOne.Dom.Searching Namespace


SearchResult Class

[image]

LinkOne WebView API
SearchResult Class
Members See Also Send Feedback
The result row for a matching entry for a particular search.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class SearchResult : ISearchResult
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class SearchResult _
    Implements ISearchResult
Visual C++
[SerializableAttribute]
public ref class SearchResult sealed : ISearchResult

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Searching..::.SearchResult

See Also

SearchResult Members
Mincom.LinkOne.Dom.Searching Namespace


SearchResult Members

[image] [image]

LinkOne WebView API
SearchResult Members
SearchResult Class Methods Properties See Also Send Feedback

The SearchResult type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
BookCode | Gets the book code.
BookTitle | Gets the book title.
DisplayedItemId | Gets the display version of the Item Id that has ignored content filtered out.
DisplayValue | Gets the display value.
ItemId | Gets the item identifier.
ItemTag | Gets the item tag.
MatchingField | Gets the matching field(s).
PageNumber | Gets the page number.
PageReference | Gets the page reference.
PageTitle | Gets the page title.
PublisherCode | Gets the publisher code.
SearchIndexPosition | Gets the search index position.
VisiblePageNumber | Gets the visible page number, taking into account any special page number visibility processing.

See Also

SearchResult Class
Mincom.LinkOne.Dom.Searching Namespace


SearchResult Methods

[image] [image]

LinkOne WebView API
SearchResult Methods
SearchResult Class See Also Send Feedback

The SearchResult type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SearchResult Class
Mincom.LinkOne.Dom.Searching Namespace


SearchResult Properties

[image] [image]

LinkOne WebView API
SearchResult Properties
SearchResult Class See Also Send Feedback

The SearchResult type exposes the following members.

Properties

Name | Description
BookCode | Gets the book code.
BookTitle | Gets the book title.
DisplayedItemId | Gets the display version of the Item Id that has ignored content filtered out.
DisplayValue | Gets the display value.
ItemId | Gets the item identifier.
ItemTag | Gets the item tag.
MatchingField | Gets the matching field(s).
PageNumber | Gets the page number.
PageReference | Gets the page reference.
PageTitle | Gets the page title.
PublisherCode | Gets the publisher code.
SearchIndexPosition | Gets the search index position.
VisiblePageNumber | Gets the visible page number, taking into account any special page number visibility processing.

See Also

SearchResult Class
Mincom.LinkOne.Dom.Searching Namespace


BookCode Property

[image]

LinkOne WebView API
SearchResult..::.BookCode Property
SearchResult Class See Also Send Feedback
Gets the book code.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string BookCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property BookCode As String
Visual C++
public:
virtual property String^ BookCode {
    String^ get () sealed;
}

Implements

ISearchResult..::.BookCode

See Also

SearchResult Class
Mincom.LinkOne.Dom.Searching Namespace


BookTitle Property

[image]

LinkOne WebView API
SearchResult..::.BookTitle Property
SearchResult Class See Also Send Feedback
Gets the book title.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string BookTitle { get; }
Visual Basic (Declaration)
Public ReadOnly Property BookTitle As String
Visual C++
public:
virtual property String^ BookTitle {
    String^ get () sealed;
}

Implements

ISearchResult..::.BookTitle

See Also

SearchResult Class
Mincom.LinkOne.Dom.Searching Namespace


DisplayedItemId Property

[image]

LinkOne WebView API
SearchResult..::.DisplayedItemId Property
SearchResult Class See Also Send Feedback
Gets the display version of the Item Id that has ignored content filtered out.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string DisplayedItemId { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayedItemId As String
Visual C++
public:
virtual property String^ DisplayedItemId {
    String^ get () sealed;
}

Implements

ISearchResult..::.DisplayedItemId

See Also

SearchResult Class
Mincom.LinkOne.Dom.Searching Namespace


DisplayValue Property

[image]

LinkOne WebView API
SearchResult..::.DisplayValue Property
SearchResult Class See Also Send Feedback
Gets the display value.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string DisplayValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayValue As String
Visual C++
public:
virtual property String^ DisplayValue {
    String^ get () sealed;
}

Implements

ISearchResult..::.DisplayValue

See Also

SearchResult Class
Mincom.LinkOne.Dom.Searching Namespace


ItemId Property

[image]

LinkOne WebView API
SearchResult..::.ItemId Property
SearchResult Class See Also Send Feedback
Gets the item identifier.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string ItemId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemId As String
Visual C++
public:
virtual property String^ ItemId {
    String^ get () sealed;
}

Implements

ISearchResult..::.ItemId

See Also

SearchResult Class
Mincom.LinkOne.Dom.Searching Namespace


ItemTag Property

[image]

LinkOne WebView API
SearchResult..::.ItemTag Property
SearchResult Class See Also Send Feedback
Gets the item tag.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int ItemTag { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemTag As Integer
Visual C++
public:
virtual property int ItemTag {
    int get () sealed;
}

Implements

ISearchResult..::.ItemTag

See Also

SearchResult Class
Mincom.LinkOne.Dom.Searching Namespace


MatchingField Property

[image]

LinkOne WebView API
SearchResult..::.MatchingField Property
SearchResult Class See Also Send Feedback
Gets the matching field(s).

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchResultFieldMatch MatchingField { get; }
Visual Basic (Declaration)
Public ReadOnly Property MatchingField As SearchResultFieldMatch
Visual C++
public:
property SearchResultFieldMatch^ MatchingField {
    SearchResultFieldMatch^ get ();
}

See Also

SearchResult Class
Mincom.LinkOne.Dom.Searching Namespace


PageNumber Property

[image]

LinkOne WebView API
SearchResult..::.PageNumber Property
SearchResult Class See Also Send Feedback
Gets the page number.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PageNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageNumber As String
Visual C++
public:
virtual property String^ PageNumber {
    String^ get () sealed;
}

Implements

ISearchResult..::.PageNumber

See Also

SearchResult Class
Mincom.LinkOne.Dom.Searching Namespace


PageReference Property

[image]

LinkOne WebView API
SearchResult..::.PageReference Property
SearchResult Class See Also Send Feedback
Gets the page reference.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PageReference { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageReference As String
Visual C++
public:
virtual property String^ PageReference {
    String^ get () sealed;
}

Implements

ISearchResult..::.PageReference

See Also

SearchResult Class
Mincom.LinkOne.Dom.Searching Namespace


PageTitle Property

[image]

LinkOne WebView API
SearchResult..::.PageTitle Property
SearchResult Class See Also Send Feedback
Gets the page title.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PageTitle { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageTitle As String
Visual C++
public:
virtual property String^ PageTitle {
    String^ get () sealed;
}

Implements

ISearchResult..::.PageTitle

See Also

SearchResult Class
Mincom.LinkOne.Dom.Searching Namespace


PublisherCode Property

[image]

LinkOne WebView API
SearchResult..::.PublisherCode Property
SearchResult Class See Also Send Feedback
Gets the publisher code.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PublisherCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublisherCode As String
Visual C++
public:
virtual property String^ PublisherCode {
    String^ get () sealed;
}

Implements

ISearchResult..::.PublisherCode

See Also

SearchResult Class
Mincom.LinkOne.Dom.Searching Namespace


SearchIndexPosition Property

[image]

LinkOne WebView API
SearchResult..::.SearchIndexPosition Property
SearchResult Class See Also Send Feedback
Gets the search index position.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchIndexPosition SearchIndexPosition { get; }
Visual Basic (Declaration)
Public ReadOnly Property SearchIndexPosition As SearchIndexPosition
Visual C++
public:
property SearchIndexPosition SearchIndexPosition {
    SearchIndexPosition get ();
}

See Also

SearchResult Class
Mincom.LinkOne.Dom.Searching Namespace


VisiblePageNumber Property

[image]

LinkOne WebView API
SearchResult..::.VisiblePageNumber Property
SearchResult Class See Also Send Feedback
Gets the visible page number, taking into account any special page number visibility processing.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string VisiblePageNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property VisiblePageNumber As String
Visual C++
public:
property String^ VisiblePageNumber {
    String^ get ();
}

See Also

SearchResult Class
Mincom.LinkOne.Dom.Searching Namespace


SearchResultCollection Class

[image]

LinkOne WebView API
SearchResultCollection Class
Members See Also Send Feedback
Represents a collection of SearchResult objects.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class SearchResultCollection : ReadOnlyList<SearchResult>,
    ISearchResultCollection, IReadOnlyList<ISearchResult>, IReadOnlyCollection<ISearchResult>,
    IEnumerable<ISearchResult>, IEnumerable, IPersist
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class SearchResultCollection _
    Inherits ReadOnlyList(Of SearchResult) _
    Implements ISearchResultCollection, IReadOnlyList(Of ISearchResult),  _
    IReadOnlyCollection(Of ISearchResult), IEnumerable(Of ISearchResult), IEnumerable,  _
    IPersist
Visual C++
[SerializableAttribute]
public ref class SearchResultCollection sealed : public ReadOnlyList<SearchResult^>,
    ISearchResultCollection, IReadOnlyList<ISearchResult^>, IReadOnlyCollection<ISearchResult^>,
    IEnumerable<ISearchResult^>, IEnumerable, IPersist

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.ReadOnlyList <(Of <( SearchResult >)>)
Mincom.LinkOne.Dom.Searching..::.SearchResultCollection

See Also

SearchResultCollection Members
Mincom.LinkOne.Dom.Searching Namespace


SearchResultCollection Members

[image] [image]

LinkOne WebView API
SearchResultCollection Members
SearchResultCollection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The SearchResultCollection type exposes the following members.

Methods

Name | Description
AllBookItems | Returns all items which match a specific book.
AllMatchedItems | Returns all items which match a specific book item.
Books | Returns a SearchResultCollection containing a unique entry for each PublisherCode/BookCode.
Contains | Determines whether an element is in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSaveSearchLevel | Gets the save search level.
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given object. (Inherited from ReadOnlyList<(Of <(T>)>).)
Items | Returns the search results sorted on their items, but only the results for the given book/match/page.
MatchCount | Returns the number of matches found in a given book
Matches | Returns the search results sorted on their matching field values, but only the results for the given book.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Pages | Returns the search results sorted on their page numbers, but only the results for the given book/match.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
CanSaveAll | Gets a value indicating whether a user can save all search results.
CompletionStatus | Gets the completion status.
Count | Gets the number of elements in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
InnerList | Gets the inner list. (Inherited from ReadOnlyList<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from ReadOnlyList<(Of <(T>)>).)
Location | Gets or sets the filename for writing.
ResultCount | Gets the total number of results in the SearchResultCollection. When the collection is Truncated the ResultCount is preserved.
WriteCriteria | Gets or sets the criteria for writing.
WriteFlags | Gets or set the

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(ISearchResult>)>)..::.Contains |
IReadOnlyCollection<(Of <(ISearchResult>)>)..::.Count |
IEnumerable<(Of <(ISearchResult>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator |
IReadOnlyList<(Of <(ISearchResult>)>)..::.IndexOf |
IReadOnlyList<(Of <(ISearchResult>)>)..::.Item |

See Also

SearchResultCollection Class
Mincom.LinkOne.Dom.Searching Namespace


SearchResultCollection Methods

[image] [image]

LinkOne WebView API
SearchResultCollection Methods
SearchResultCollection Class See Also Send Feedback

The SearchResultCollection type exposes the following members.

Methods

Name | Description
AllBookItems | Returns all items which match a specific book.
AllMatchedItems | Returns all items which match a specific book item.
Books | Returns a SearchResultCollection containing a unique entry for each PublisherCode/BookCode.
Contains | Determines whether an element is in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSaveSearchLevel | Gets the save search level.
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given object. (Inherited from ReadOnlyList<(Of <(T>)>).)
Items | Returns the search results sorted on their items, but only the results for the given book/match/page.
MatchCount | Returns the number of matches found in a given book
Matches | Returns the search results sorted on their matching field values, but only the results for the given book.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Pages | Returns the search results sorted on their page numbers, but only the results for the given book/match.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(ISearchResult>)>)..::.Contains |
IEnumerable<(Of <(ISearchResult>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator |
IReadOnlyList<(Of <(ISearchResult>)>)..::.IndexOf |

See Also

SearchResultCollection Class
Mincom.LinkOne.Dom.Searching Namespace


IEnumerable(ISearchResult).GetEnumerator Method

[image]

LinkOne WebView API
SearchResultCollection..::.IEnumerable<(Of <(ISearchResult>)>)..::.GetEnumerator Method
SearchResultCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator<ISearchResult> IEnumerable<ISearchResult>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of ISearchResult)
    Implements IEnumerable(Of ISearchResult).GetEnumerator
Visual C++
private:
virtual IEnumerator<ISearchResult^>^ GetEnumerator() sealed = IEnumerable<ISearchResult^>::GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

SearchResultCollection Class
Mincom.LinkOne.Dom.Searching Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
SearchResultCollection..::.IEnumerable..::.GetEnumerator Method
SearchResultCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Implements

IEnumerable..::.GetEnumerator()()()

See Also

SearchResultCollection Class
Mincom.LinkOne.Dom.Searching Namespace


AllBookItems Method

[image]

LinkOne WebView API
SearchResultCollection..::.AllBookItems Method
SearchResultCollection Class See Also Send Feedback
Returns all items which match a specific book.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchResultCollection AllBookItems(
    SearchResult criteria
)
Visual Basic (Declaration)
Public Function AllBookItems ( _
    criteria As SearchResult _
) As SearchResultCollection
Visual C++
public:
SearchResultCollection^ AllBookItems(
    SearchResult^ criteria
)

Parameters

criteria
Type: Mincom.LinkOne.Dom.Searching..::.SearchResult
The criteria which identifies the book to match.

Return Value

A search results collection of all items for the matching book.

See Also

SearchResultCollection Class
Mincom.LinkOne.Dom.Searching Namespace


AllMatchedItems Method

[image]

LinkOne WebView API
SearchResultCollection..::.AllMatchedItems Method
SearchResultCollection Class See Also Send Feedback
Returns all items which match a specific book item.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchResultCollection AllMatchedItems(
    SearchResult criteria
)
Visual Basic (Declaration)
Public Function AllMatchedItems ( _
    criteria As SearchResult _
) As SearchResultCollection
Visual C++
public:
SearchResultCollection^ AllMatchedItems(
    SearchResult^ criteria
)

Parameters

criteria
Type: Mincom.LinkOne.Dom.Searching..::.SearchResult
The criteria which identifies the book and item to match.

Return Value

A search results collection of all items for the matching book item.

See Also

SearchResultCollection Class
Mincom.LinkOne.Dom.Searching Namespace


Books Method

[image]

LinkOne WebView API
SearchResultCollection..::.Books Method
SearchResultCollection Class See Also Send Feedback
Returns a SearchResultCollection containing a unique entry for each PublisherCode/BookCode.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchResultCollection Books()
Visual Basic (Declaration)
Public Function Books As SearchResultCollection
Visual C++
public:
SearchResultCollection^ Books()

Return Value

A search result collection sorted on their books.

See Also

SearchResultCollection Class
Mincom.LinkOne.Dom.Searching Namespace


GetSaveSearchLevel Method

[image]

LinkOne WebView API
SearchResultCollection..::.GetSaveSearchLevel Method
SearchResultCollection Class See Also Send Feedback
Gets the save search level.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SaveSearchLevelOption GetSaveSearchLevel(
    SearchResult searchResult
)
Visual Basic (Declaration)
Public Function GetSaveSearchLevel ( _
    searchResult As SearchResult _
) As SaveSearchLevelOption
Visual C++
public:
SaveSearchLevelOption GetSaveSearchLevel(
    SearchResult^ searchResult
)

Parameters

searchResult
Type: Mincom.LinkOne.Dom.Searching..::.SearchResult
The search result to use for security checks.

Return Value

An SaveSearchLevelOption that is what the user can save.

Remarks

This is security checked up to the publisher, see CanSaveAll to determine what can be saved for cross publisher searching.

Exceptions

Exception | Condition
System..::.ArgumentNullException | The search result is null.

See Also

SearchResultCollection Class
Mincom.LinkOne.Dom.Searching Namespace


IReadOnlyCollection(ISearchResult).Contains Method

[image]

LinkOne WebView API
SearchResultCollection..::.IReadOnlyCollection<(Of <(ISearchResult>)>)..::.Contains Method
SearchResultCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IReadOnlyCollection<ISearchResult>.Contains(
    ISearchResult domObject
)
Visual Basic (Declaration)
Private Function Contains ( _
    domObject As ISearchResult _
) As Boolean Implements IReadOnlyCollection(Of ISearchResult).Contains
Visual C++
private:
virtual bool Contains(
    ISearchResult^ domObject
) sealed = IReadOnlyCollection<ISearchResult^>::Contains

Parameters

domObject
Type: Mincom.LinkOne.Dom.Searching..::.ISearchResult

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Contains(T)

See Also

SearchResultCollection Class
Mincom.LinkOne.Dom.Searching Namespace


IReadOnlyList(ISearchResult).IndexOf Method

[image]

LinkOne WebView API
SearchResultCollection..::.IReadOnlyList<(Of <(ISearchResult>)>)..::.IndexOf Method
SearchResultCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int IReadOnlyList<ISearchResult>.IndexOf(
    ISearchResult domObject
)
Visual Basic (Declaration)
Private Function IndexOf ( _
    domObject As ISearchResult _
) As Integer Implements IReadOnlyList(Of ISearchResult).IndexOf
Visual C++
private:
virtual int IndexOf(
    ISearchResult^ domObject
) sealed = IReadOnlyList<ISearchResult^>::IndexOf

Parameters

domObject
Type: Mincom.LinkOne.Dom.Searching..::.ISearchResult

Implements

IReadOnlyList<(Of <(T>)>)..::.IndexOf(T)

See Also

SearchResultCollection Class
Mincom.LinkOne.Dom.Searching Namespace


Items Method

[image]

LinkOne WebView API
SearchResultCollection..::.Items Method
SearchResultCollection Class See Also Send Feedback
Returns the search results sorted on their items, but only the results for the given book/match/page.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchResultCollection Items(
    SearchResult matchResult
)
Visual Basic (Declaration)
Public Function Items ( _
    matchResult As SearchResult _
) As SearchResultCollection
Visual C++
public:
SearchResultCollection^ Items(
    SearchResult^ matchResult
)

Parameters

matchResult
Type: Mincom.LinkOne.Dom.Searching..::.SearchResult
The match result to limit the items to.

Return Value

A search result collection sorted on their matches.

See Also

SearchResultCollection Class
Mincom.LinkOne.Dom.Searching Namespace


MatchCount Method

[image]

LinkOne WebView API
SearchResultCollection..::.MatchCount Method
SearchResultCollection Class See Also Send Feedback
Returns the number of matches found in a given book

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int MatchCount(
    string bookCode
)
Visual Basic (Declaration)
Public Function MatchCount ( _
    bookCode As String _
) As Integer
Visual C++
public:
int MatchCount(
    String^ bookCode
)

Parameters

bookCode
Type: System..::.String
The book that contains matches.

Return Value

The number of matches found.

See Also

SearchResultCollection Class
Mincom.LinkOne.Dom.Searching Namespace


Matches Method

[image]

LinkOne WebView API
SearchResultCollection..::.Matches Method
SearchResultCollection Class See Also Send Feedback
Returns the search results sorted on their matching field values, but only the results for the given book.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchResultCollection Matches(
    SearchResult matchResult
)
Visual Basic (Declaration)
Public Function Matches ( _
    matchResult As SearchResult _
) As SearchResultCollection
Visual C++
public:
SearchResultCollection^ Matches(
    SearchResult^ matchResult
)

Parameters

matchResult
Type: Mincom.LinkOne.Dom.Searching..::.SearchResult
The match result to limit the matches to.

Return Value

A search result collection sorted on their matching field values.

See Also

SearchResultCollection Class
Mincom.LinkOne.Dom.Searching Namespace


Pages Method

[image]

LinkOne WebView API
SearchResultCollection..::.Pages Method
SearchResultCollection Class See Also Send Feedback
Returns the search results sorted on their page numbers, but only the results for the given book/match.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchResultCollection Pages(
    SearchResult matchResult
)
Visual Basic (Declaration)
Public Function Pages ( _
    matchResult As SearchResult _
) As SearchResultCollection
Visual C++
public:
SearchResultCollection^ Pages(
    SearchResult^ matchResult
)

Parameters

matchResult
Type: Mincom.LinkOne.Dom.Searching..::.SearchResult
The match result to limit the pages to.

Return Value

A search result collection sorted on their page numbers.

See Also

SearchResultCollection Class
Mincom.LinkOne.Dom.Searching Namespace


SearchResultCollection Properties

[image] [image]

LinkOne WebView API
SearchResultCollection Properties
SearchResultCollection Class See Also Send Feedback

The SearchResultCollection type exposes the following members.

Properties

Name | Description
CanSaveAll | Gets a value indicating whether a user can save all search results.
CompletionStatus | Gets the completion status.
Count | Gets the number of elements in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
InnerList | Gets the inner list. (Inherited from ReadOnlyList<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from ReadOnlyList<(Of <(T>)>).)
Location | Gets or sets the filename for writing.
ResultCount | Gets the total number of results in the SearchResultCollection. When the collection is Truncated the ResultCount is preserved.
WriteCriteria | Gets or sets the criteria for writing.
WriteFlags | Gets or set the

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(ISearchResult>)>)..::.Count |
IReadOnlyList<(Of <(ISearchResult>)>)..::.Item |

See Also

SearchResultCollection Class
Mincom.LinkOne.Dom.Searching Namespace


CanSaveAll Property

[image]

LinkOne WebView API
SearchResultCollection..::.CanSaveAll Property
SearchResultCollection Class See Also Send Feedback
Gets a value indicating whether a user can save all search results.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool CanSaveAll { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanSaveAll As Boolean
Visual C++
public:
property bool CanSaveAll {
    bool get ();
}

Field Value

true if this instance can save all; otherwise, false.

See Also

SearchResultCollection Class
Mincom.LinkOne.Dom.Searching Namespace


CompletionStatus Property

[image]

LinkOne WebView API
SearchResultCollection..::.CompletionStatus Property
SearchResultCollection Class See Also Send Feedback
Gets the completion status.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchResultCollection..::.SearchCompletionStatus CompletionStatus { get; internal set; }
Visual Basic (Declaration)
Public Property CompletionStatus As SearchResultCollection..::.SearchCompletionStatus
Visual C++
public:
property SearchResultCollection..::.SearchCompletionStatus CompletionStatus {
    SearchResultCollection..::.SearchCompletionStatus get ();
    void set (SearchResultCollection..::.SearchCompletionStatus value);
}

See Also

SearchResultCollection Class
Mincom.LinkOne.Dom.Searching Namespace


IReadOnlyCollection(ISearchResult).Count Property

[image]

LinkOne WebView API
SearchResultCollection..::.IReadOnlyCollection<(Of <(ISearchResult>)>)..::.Count Property
SearchResultCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int IReadOnlyCollection<ISearchResult>.Count { get; }
Visual Basic (Declaration)
Private ReadOnly Property Count As Integer
    Implements IReadOnlyCollection(Of ISearchResult).Count
Visual C++
private:
virtual property int Count {
    int get () sealed = IReadOnlyCollection<ISearchResult^>::Count::get;
}

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Count

See Also

SearchResultCollection Class
Mincom.LinkOne.Dom.Searching Namespace


IReadOnlyList(ISearchResult).Item Property

[image]

LinkOne WebView API
SearchResultCollection..::.IReadOnlyList<(Of <(ISearchResult>)>)..::.Item Property
SearchResultCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ISearchResult IReadOnlyList<ISearchResult>.Item[
    int index
] { get; }
Visual Basic (Declaration)
Private ReadOnly Property Item ( _
    index As Integer _
) As ISearchResult Implements IReadOnlyList(Of ISearchResult).Item
Visual C++
private:
virtual property ISearchResult^ Item[int index] {
    ISearchResult^ get (int index) sealed = IReadOnlyList<ISearchResult^>::Item::get;
}

Parameters

index
Type: System..::.Int32

Implements

IReadOnlyList<(Of <(T>)>)..::.Item[([(Int32])])

See Also

SearchResultCollection Class
Mincom.LinkOne.Dom.Searching Namespace


Location Property

[image]

LinkOne WebView API
SearchResultCollection..::.Location Property
SearchResultCollection Class See Also Send Feedback
Gets or sets the filename for writing.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Location { get; set; }
Visual Basic (Declaration)
Public Property Location As String
Visual C++
public:
property String^ Location {
    String^ get ();
    void set (String^ value);
}

See Also

SearchResultCollection Class
Mincom.LinkOne.Dom.Searching Namespace


ResultCount Property

[image]

LinkOne WebView API
SearchResultCollection..::.ResultCount Property
SearchResultCollection Class See Also Send Feedback
Gets the total number of results in the SearchResultCollection. When the collection is Truncated the ResultCount is preserved.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int ResultCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property ResultCount As Integer
Visual C++
public:
property int ResultCount {
    int get ();
}

See Also

SearchResultCollection Class
Mincom.LinkOne.Dom.Searching Namespace


WriteCriteria Property

[image]

LinkOne WebView API
SearchResultCollection..::.WriteCriteria Property
SearchResultCollection Class See Also Send Feedback
Gets or sets the criteria for writing.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchResult WriteCriteria { get; set; }
Visual Basic (Declaration)
Public Property WriteCriteria As SearchResult
Visual C++
public:
property SearchResult^ WriteCriteria {
    SearchResult^ get ();
    void set (SearchResult^ value);
}

See Also

SearchResultCollection Class
Mincom.LinkOne.Dom.Searching Namespace


WriteFlags Property

[image]

LinkOne WebView API
SearchResultCollection..::.WriteFlags Property
SearchResultCollection Class See Also Send Feedback
Gets or set the

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchResultCollection..::.SearchWriteFlags WriteFlags { get; set; }
Visual Basic (Declaration)
Public Property WriteFlags As SearchResultCollection..::.SearchWriteFlags
Visual C++
public:
property SearchResultCollection..::.SearchWriteFlags WriteFlags {
    SearchResultCollection..::.SearchWriteFlags get ();
    void set (SearchResultCollection..::.SearchWriteFlags value);
}

See Also

SearchResultCollection Class
Mincom.LinkOne.Dom.Searching Namespace


SearchResultCollection.SearchCompletionStatus Enumeration

[image]

LinkOne WebView API
SearchResultCollection..::.SearchCompletionStatus Enumeration
SearchResultCollection Class See Also Send Feedback
Describes how complete the search was, or if it was aborted.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum SearchCompletionStatus
Visual Basic (Declaration)
Public Enumeration SearchCompletionStatus
Visual C++
public enum class SearchCompletionStatus

Members

Member name | Description
New | No search has been performed.
Complete | Search completed and all results returned.
UserAbort | Search was aborted with partial results because it was instructed to stop externally.
TooManyResults | Search was aborted with partial results because there were too many results.

See Also

Mincom.LinkOne.Dom.Searching Namespace


SearchResultCollection.SearchWriteFlags Enumeration

[image]

LinkOne WebView API
SearchResultCollection..::.SearchWriteFlags Enumeration
SearchResultCollection Class See Also Send Feedback
The available write flags that can be associated with a SearchResultCollection.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[FlagsAttribute]
public enum SearchWriteFlags
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration SearchWriteFlags
Visual C++
[FlagsAttribute]
public enum class SearchWriteFlags

Members

Member name | Description
None | No flags specified.
MultibookSearch | Indicate if the search result releate to a multi-book search. If not specified, then a single book search is assumed.
IncludeLocations | Include the location information of each match item written.
AppendData | Append the search results to any existing data. If not specified, then existing data is overwritten with the current search results.

See Also

Mincom.LinkOne.Dom.Searching Namespace


SearchResultFieldMatch Class

[image]

LinkOne WebView API
SearchResultFieldMatch Class
Members See Also Send Feedback
This class represents the matching fields in a SearchResult.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class SearchResultFieldMatch
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class SearchResultFieldMatch
Visual C++
[SerializableAttribute]
public ref class SearchResultFieldMatch sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Searching..::.SearchResultFieldMatch

See Also

SearchResultFieldMatch Members
Mincom.LinkOne.Dom.Searching Namespace


SearchResultFieldMatch Members

[image] [image]

LinkOne WebView API
SearchResultFieldMatch Members
SearchResultFieldMatch Class Methods Properties See Also Send Feedback

The SearchResultFieldMatch type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FieldName | Gets the name of the matching field at the given index.
FieldType | Gets the FieldType of the matching field at the given index.
FieldValue | Gets the value of the matching field at the given index.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of matching fields.
Values | Gets all the field values.
ValueString | Gets a string representation of the combined field values.

See Also

SearchResultFieldMatch Class
Mincom.LinkOne.Dom.Searching Namespace


SearchResultFieldMatch Methods

[image] [image]

LinkOne WebView API
SearchResultFieldMatch Methods
SearchResultFieldMatch Class See Also Send Feedback

The SearchResultFieldMatch type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FieldName | Gets the name of the matching field at the given index.
FieldType | Gets the FieldType of the matching field at the given index.
FieldValue | Gets the value of the matching field at the given index.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SearchResultFieldMatch Class
Mincom.LinkOne.Dom.Searching Namespace


FieldName Method

[image]

LinkOne WebView API
SearchResultFieldMatch..::.FieldName Method
SearchResultFieldMatch Class See Also Send Feedback
Gets the name of the matching field at the given index.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string FieldName(
    int index
)
Visual Basic (Declaration)
Public Function FieldName ( _
    index As Integer _
) As String
Visual C++
public:
String^ FieldName(
    int index
)

Parameters

index
Type: System..::.Int32
The index of the field

See Also

SearchResultFieldMatch Class
Mincom.LinkOne.Dom.Searching Namespace


FieldType Method

[image]

LinkOne WebView API
SearchResultFieldMatch..::.FieldType Method
SearchResultFieldMatch Class See Also Send Feedback
Gets the FieldType of the matching field at the given index.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchFieldType FieldType(
    int index
)
Visual Basic (Declaration)
Public Function FieldType ( _
    index As Integer _
) As SearchFieldType
Visual C++
public:
SearchFieldType FieldType(
    int index
)

Parameters

index
Type: System..::.Int32
The index of the field

See Also

SearchResultFieldMatch Class
Mincom.LinkOne.Dom.Searching Namespace


FieldValue Method

[image]

LinkOne WebView API
SearchResultFieldMatch..::.FieldValue Method
SearchResultFieldMatch Class See Also Send Feedback
Gets the value of the matching field at the given index.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string FieldValue(
    int index
)
Visual Basic (Declaration)
Public Function FieldValue ( _
    index As Integer _
) As String
Visual C++
public:
String^ FieldValue(
    int index
)

Parameters

index
Type: System..::.Int32
The index of the field

See Also

SearchResultFieldMatch Class
Mincom.LinkOne.Dom.Searching Namespace


SearchResultFieldMatch Properties

[image] [image]

LinkOne WebView API
SearchResultFieldMatch Properties
SearchResultFieldMatch Class See Also Send Feedback

The SearchResultFieldMatch type exposes the following members.

Properties

Name | Description
Count | Gets the number of matching fields.
Values | Gets all the field values.
ValueString | Gets a string representation of the combined field values.

See Also

SearchResultFieldMatch Class
Mincom.LinkOne.Dom.Searching Namespace


Count Property

[image]

LinkOne WebView API
SearchResultFieldMatch..::.Count Property
SearchResultFieldMatch Class See Also Send Feedback
Gets the number of matching fields.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
property int Count {
    int get ();
}

See Also

SearchResultFieldMatch Class
Mincom.LinkOne.Dom.Searching Namespace


Values Property

[image]

LinkOne WebView API
SearchResultFieldMatch..::.Values Property
SearchResultFieldMatch Class See Also Send Feedback
Gets all the field values.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string[] Values { get; }
Visual Basic (Declaration)
Public ReadOnly Property Values As String()
Visual C++
public:
property array<String^>^ Values {
    array<String^>^ get ();
}

Return Value

The field values.

See Also

SearchResultFieldMatch Class
Mincom.LinkOne.Dom.Searching Namespace


ValueString Property

[image]

LinkOne WebView API
SearchResultFieldMatch..::.ValueString Property
SearchResultFieldMatch Class See Also Send Feedback
Gets a string representation of the combined field values.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string ValueString { get; }
Visual Basic (Declaration)
Public ReadOnly Property ValueString As String
Visual C++
public:
property String^ ValueString {
    String^ get ();
}

See Also

SearchResultFieldMatch Class
Mincom.LinkOne.Dom.Searching Namespace


SearchResultScope Enumeration

[image]

LinkOne WebView API
SearchResultScope Enumeration
See Also Send Feedback
Specifies the type of search result.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum SearchResultScope
Visual Basic (Declaration)
Public Enumeration SearchResultScope
Visual C++
public enum class SearchResultScope

Members

Member name | Description
Entry | The selected search result.
Page | All search results for a page.
Book | All search results for a book.
Publisher | All search results for a publisher.
Global | All search results.

See Also

Mincom.LinkOne.Dom.Searching Namespace


SearchSet Class

[image]

LinkOne WebView API
SearchSet Class
Members See Also Send Feedback
Represents a LinkOne Search Set Definition.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class SearchSet : ISearchSet
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class SearchSet _
    Implements ISearchSet
Visual C++
[SerializableAttribute]
public ref class SearchSet sealed : ISearchSet

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Searching..::.SearchSet

See Also

SearchSet Members
Mincom.LinkOne.Dom.Searching Namespace


SearchSet Members

[image] [image]

LinkOne WebView API
SearchSet Members
SearchSet Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The SearchSet type exposes the following members.

Constructors

Name | Description
SearchSet | Initializes a new instance of the SearchSet class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Description | Gets the search set description.
Key | Gets a key representing the search set.
LanguageCode | Gets the language code.
Name | Gets the search set name.
Searches | Gets the collection of searches contained within this search set.
SecurityLock | Gets the security lock.
Source | Gets the search set source.

Explicit Interface Implementations

Name | Description
ISearchSet..::.Searches |

See Also

SearchSet Class
Mincom.LinkOne.Dom.Searching Namespace


SearchSet Constructor

[image]

LinkOne WebView API
SearchSet Constructor
SearchSet Class See Also Send Feedback
Initializes a new instance of the SearchSet class.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchSet(
    IDomReader domReader
)
Visual Basic (Declaration)
Public Sub New ( _
    domReader As IDomReader _
)
Visual C++
public:
SearchSet(
    IDomReader^ domReader
)

Parameters

domReader
Type: IDomReader
The search set reader object providing the initialisation data.

See Also

SearchSet Class
Mincom.LinkOne.Dom.Searching Namespace


SearchSet Methods

[image] [image]

LinkOne WebView API
SearchSet Methods
SearchSet Class See Also Send Feedback

The SearchSet type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SearchSet Class
Mincom.LinkOne.Dom.Searching Namespace


SearchSet Properties

[image] [image]

LinkOne WebView API
SearchSet Properties
SearchSet Class See Also Send Feedback

The SearchSet type exposes the following members.

Properties

Name | Description
Description | Gets the search set description.
Key | Gets a key representing the search set.
LanguageCode | Gets the language code.
Name | Gets the search set name.
Searches | Gets the collection of searches contained within this search set.
SecurityLock | Gets the security lock.
Source | Gets the search set source.

Explicit Interface Implementations

Name | Description
ISearchSet..::.Searches |

See Also

SearchSet Class
Mincom.LinkOne.Dom.Searching Namespace


Description Property

[image]

LinkOne WebView API
SearchSet..::.Description Property
SearchSet Class See Also Send Feedback
Gets the search set description.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Description { get; internal set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
virtual property String^ Description {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ISearchSet..::.Description

See Also

SearchSet Class
Mincom.LinkOne.Dom.Searching Namespace


ISearchSet.Searches Property

[image]

LinkOne WebView API
SearchSet..::.ISearchSet..::.Searches Property
SearchSet Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ISearchCollection ISearchSet.Searches { get; }
Visual Basic (Declaration)
Private ReadOnly Property Searches As ISearchCollection
    Implements ISearchSet.Searches
Visual C++
private:
virtual property ISearchCollection^ Searches {
    ISearchCollection^ get () sealed = ISearchSet::Searches::get;
}

Implements

ISearchSet..::.Searches

See Also

SearchSet Class
Mincom.LinkOne.Dom.Searching Namespace


Key Property

[image]

LinkOne WebView API
SearchSet..::.Key Property
SearchSet Class See Also Send Feedback
Gets a key representing the search set.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Key { get; }
Visual Basic (Declaration)
Public ReadOnly Property Key As String
Visual C++
public:
property String^ Key {
    String^ get ();
}

Remarks

The format is in LanguageCode:Name.

See Also

SearchSet Class
Mincom.LinkOne.Dom.Searching Namespace


LanguageCode Property

[image]

LinkOne WebView API
SearchSet..::.LanguageCode Property
SearchSet Class See Also Send Feedback
Gets the language code.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string LanguageCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property LanguageCode As String
Visual C++
public:
virtual property String^ LanguageCode {
    String^ get () sealed;
}

Implements

ISearchSet..::.LanguageCode

See Also

SearchSet Class
Mincom.LinkOne.Dom.Searching Namespace


Name Property

[image]

LinkOne WebView API
SearchSet..::.Name Property
SearchSet Class See Also Send Feedback
Gets the search set name.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Name { get; internal set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ISearchSet..::.Name

See Also

SearchSet Class
Mincom.LinkOne.Dom.Searching Namespace


Searches Property

[image]

LinkOne WebView API
SearchSet..::.Searches Property
SearchSet Class See Also Send Feedback
Gets the collection of searches contained within this search set.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchCollection Searches { get; }
Visual Basic (Declaration)
Public ReadOnly Property Searches As SearchCollection
Visual C++
public:
property SearchCollection^ Searches {
    SearchCollection^ get ();
}

See Also

SearchSet Class
Mincom.LinkOne.Dom.Searching Namespace


SecurityLock Property

[image]

LinkOne WebView API
SearchSet..::.SecurityLock Property
SearchSet Class See Also Send Feedback
Gets the security lock.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string SecurityLock { get; }
Visual Basic (Declaration)
Public ReadOnly Property SecurityLock As String
Visual C++
public:
virtual property String^ SecurityLock {
    String^ get () sealed;
}

Implements

ISearchSet..::.SecurityLock

See Also

SearchSet Class
Mincom.LinkOne.Dom.Searching Namespace


Source Property

[image]

LinkOne WebView API
SearchSet..::.Source Property
SearchSet Class See Also Send Feedback
Gets the search set source.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchSetSourceType Source { get; internal set; }
Visual Basic (Declaration)
Public Property Source As SearchSetSourceType
Visual C++
public:
virtual property SearchSetSourceType Source {
    SearchSetSourceType get () sealed;
    void set (SearchSetSourceType value) sealed;
}

Implements

ISearchSet..::.Source

See Also

SearchSet Class
Mincom.LinkOne.Dom.Searching Namespace


SearchSetCollection Class

[image]

LinkOne WebView API
SearchSetCollection Class
Members See Also Send Feedback
Represents a collection of Search Set definitions.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class SearchSetCollection : ReadOnlyList<SearchSet>,
    ISearchSetCollection, IReadOnlyList<ISearchSet>, IReadOnlyCollection<ISearchSet>,
    IEnumerable<ISearchSet>, IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class SearchSetCollection _
    Inherits ReadOnlyList(Of SearchSet) _
    Implements ISearchSetCollection, IReadOnlyList(Of ISearchSet),  _
    IReadOnlyCollection(Of ISearchSet), IEnumerable(Of ISearchSet), IEnumerable
Visual C++
[SerializableAttribute]
public ref class SearchSetCollection sealed : public ReadOnlyList<SearchSet^>,
    ISearchSetCollection, IReadOnlyList<ISearchSet^>, IReadOnlyCollection<ISearchSet^>,
    IEnumerable<ISearchSet^>, IEnumerable

Remarks

The search set collection always has the predefined search set as it's first entry.

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.ReadOnlyList <(Of <( SearchSet >)>)
Mincom.LinkOne.Dom.Searching..::.SearchSetCollection

See Also

SearchSetCollection Members
Mincom.LinkOne.Dom.Searching Namespace


SearchSetCollection Members

[image] [image]

LinkOne WebView API
SearchSetCollection Members
SearchSetCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The SearchSetCollection type exposes the following members.

Constructors

Name | Description
SearchSetCollection | Initializes a new instance of the SearchSetCollection class.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSearchSet | Gets the SearchSet with the specified Name and language code, or the predefined
GetSortedForLanguage | Returns a sorted sub collection of the search sets in the collection based on the given language code.
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given object. (Inherited from ReadOnlyList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
InnerList | Gets the inner list. (Inherited from ReadOnlyList<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(ISearchSet>)>)..::.Contains |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
IEnumerable<(Of <(ISearchSet>)>)..::.GetEnumerator |
IReadOnlyList<(Of <(ISearchSet>)>)..::.IndexOf |
IReadOnlyList<(Of <(ISearchSet>)>)..::.Item |

See Also

SearchSetCollection Class
Mincom.LinkOne.Dom.Searching Namespace


SearchSetCollection Constructor

[image]

LinkOne WebView API
SearchSetCollection Constructor
SearchSetCollection Class See Also Send Feedback
Initializes a new instance of the SearchSetCollection class.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchSetCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SearchSetCollection()

See Also

SearchSetCollection Class
Mincom.LinkOne.Dom.Searching Namespace


SearchSetCollection Methods

[image] [image]

LinkOne WebView API
SearchSetCollection Methods
SearchSetCollection Class See Also Send Feedback

The SearchSetCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSearchSet | Gets the SearchSet with the specified Name and language code, or the predefined
GetSortedForLanguage | Returns a sorted sub collection of the search sets in the collection based on the given language code.
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given object. (Inherited from ReadOnlyList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IReadOnlyCollection<(Of <(ISearchSet>)>)..::.Contains |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
IEnumerable<(Of <(ISearchSet>)>)..::.GetEnumerator |
IReadOnlyList<(Of <(ISearchSet>)>)..::.IndexOf |

See Also

SearchSetCollection Class
Mincom.LinkOne.Dom.Searching Namespace


IEnumerable(ISearchSet).GetEnumerator Method

[image]

LinkOne WebView API
SearchSetCollection..::.IEnumerable<(Of <(ISearchSet>)>)..::.GetEnumerator Method
SearchSetCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator<ISearchSet> IEnumerable<ISearchSet>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of ISearchSet)
    Implements IEnumerable(Of ISearchSet).GetEnumerator
Visual C++
private:
virtual IEnumerator<ISearchSet^>^ GetEnumerator() sealed = IEnumerable<ISearchSet^>::GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

SearchSetCollection Class
Mincom.LinkOne.Dom.Searching Namespace


GetSearchSet Method

[image]

LinkOne WebView API
SearchSetCollection..::.GetSearchSet Method
SearchSetCollection Class See Also Send Feedback
Gets the SearchSet with the specified Name and language code, or the predefined

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchSet GetSearchSet(
    string name,
    string languageCode
)
Visual Basic (Declaration)
Public Function GetSearchSet ( _
    name As String, _
    languageCode As String _
) As SearchSet
Visual C++
public:
SearchSet^ GetSearchSet(
    String^ name,
    String^ languageCode
)

Parameters

name
Type: System..::.String
The name of the required search set.
languageCode
Type: System..::.String
The language code that the required search set is associated with.

Return Value

The requested search set.

Remarks

Gets the wanted search set.

See Also

SearchSetCollection Class
Mincom.LinkOne.Dom.Searching Namespace


GetSortedForLanguage Method

[image]

LinkOne WebView API
SearchSetCollection..::.GetSortedForLanguage Method
SearchSetCollection Class See Also Send Feedback
Returns a sorted sub collection of the search sets in the collection based on the given language code.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchSetCollection GetSortedForLanguage(
    string languageCode
)
Visual Basic (Declaration)
Public Function GetSortedForLanguage ( _
    languageCode As String _
) As SearchSetCollection
Visual C++
public:
SearchSetCollection^ GetSortedForLanguage(
    String^ languageCode
)

Parameters

languageCode
Type: System..::.String
The language code to filter the search sets on.

Return Value

A sorted sub collection of the search sets in the collection based on the given language code.

Remarks

The returned subcollection includes one search set per search set name for each of those search sets that match the given language, and those search sets that have no language defined. Results are sorted by their source first, then their description.

See Also

SearchSetCollection Class
Mincom.LinkOne.Dom.Searching Namespace


IReadOnlyCollection(ISearchSet).Contains Method

[image]

LinkOne WebView API
SearchSetCollection..::.IReadOnlyCollection<(Of <(ISearchSet>)>)..::.Contains Method
SearchSetCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IReadOnlyCollection<ISearchSet>.Contains(
    ISearchSet domObject
)
Visual Basic (Declaration)
Private Function Contains ( _
    domObject As ISearchSet _
) As Boolean Implements IReadOnlyCollection(Of ISearchSet).Contains
Visual C++
private:
virtual bool Contains(
    ISearchSet^ domObject
) sealed = IReadOnlyCollection<ISearchSet^>::Contains

Parameters

domObject
Type: Mincom.LinkOne.Dom.Searching..::.ISearchSet

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Contains(T)

See Also

SearchSetCollection Class
Mincom.LinkOne.Dom.Searching Namespace


IReadOnlyList(ISearchSet).IndexOf Method

[image]

LinkOne WebView API
SearchSetCollection..::.IReadOnlyList<(Of <(ISearchSet>)>)..::.IndexOf Method
SearchSetCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int IReadOnlyList<ISearchSet>.IndexOf(
    ISearchSet domObject
)
Visual Basic (Declaration)
Private Function IndexOf ( _
    domObject As ISearchSet _
) As Integer Implements IReadOnlyList(Of ISearchSet).IndexOf
Visual C++
private:
virtual int IndexOf(
    ISearchSet^ domObject
) sealed = IReadOnlyList<ISearchSet^>::IndexOf

Parameters

domObject
Type: Mincom.LinkOne.Dom.Searching..::.ISearchSet

Implements

IReadOnlyList<(Of <(T>)>)..::.IndexOf(T)

See Also

SearchSetCollection Class
Mincom.LinkOne.Dom.Searching Namespace


SearchSetCollection Properties

[image] [image]

LinkOne WebView API
SearchSetCollection Properties
SearchSetCollection Class See Also Send Feedback

The SearchSetCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
InnerList | Gets the inner list. (Inherited from ReadOnlyList<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IReadOnlyList<(Of <(ISearchSet>)>)..::.Item |

See Also

SearchSetCollection Class
Mincom.LinkOne.Dom.Searching Namespace


IReadOnlyList(ISearchSet).Item Property

[image]

LinkOne WebView API
SearchSetCollection..::.IReadOnlyList<(Of <(ISearchSet>)>)..::.Item Property
SearchSetCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ISearchSet IReadOnlyList<ISearchSet>.Item[
    int index
] { get; }
Visual Basic (Declaration)
Private ReadOnly Property Item ( _
    index As Integer _
) As ISearchSet Implements IReadOnlyList(Of ISearchSet).Item
Visual C++
private:
virtual property ISearchSet^ Item[int index] {
    ISearchSet^ get (int index) sealed = IReadOnlyList<ISearchSet^>::Item::get;
}

Parameters

index
Type: System..::.Int32

Implements

IReadOnlyList<(Of <(T>)>)..::.Item[([(Int32])])

See Also

SearchSetCollection Class
Mincom.LinkOne.Dom.Searching Namespace


Item Property

[image] [image]

LinkOne WebView API
SearchSetCollection..::.Item Property
SearchSetCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Gets the item at the specified index. (Inherited from ReadOnlyList<(Of <(T>)>).)
Item[([(String])]) | Gets the first occurance of a SearchSet with the specified name.

See Also

SearchSetCollection Class
SearchSetCollection Members
Mincom.LinkOne.Dom.Searching Namespace


Item Property (String)

[image]

LinkOne WebView API
SearchSetCollection..::.Item Property (String)
SearchSetCollection Class See Also Send Feedback
Gets the first occurance of a SearchSet with the specified name.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchSet this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As SearchSet
Visual C++
public:
property SearchSet^ default[String^ name] {
    SearchSet^ get (String^ name);
}

Parameters

name
Type: System..::.String

See Also

SearchSetCollection Class
Item Overload
Mincom.LinkOne.Dom.Searching Namespace


SearchSetSourceType Enumeration

[image]

LinkOne WebView API
SearchSetSourceType Enumeration
See Also Send Feedback
The source of the search set.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum SearchSetSourceType
Visual Basic (Declaration)
Public Enumeration SearchSetSourceType
Visual C++
public enum class SearchSetSourceType

Members

Member name | Description
Predefined | The search set is predefined by LinkOne.
Book | The search set is from the book.

See Also

Mincom.LinkOne.Dom.Searching Namespace


SearchWordMap Class

[image]

LinkOne WebView API
SearchWordMap Class
Members See Also Send Feedback
A searcher of words from embedded documents.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public sealed class SearchWordMap : ISearchOverField
Visual Basic (Declaration)
Public NotInheritable Class SearchWordMap _
    Implements ISearchOverField
Visual C++
public ref class SearchWordMap sealed : ISearchOverField

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Searching..::.SearchWordMap

See Also

SearchWordMap Members
Mincom.LinkOne.Dom.Searching Namespace


SearchWordMap Members

[image] [image]

LinkOne WebView API
SearchWordMap Members
SearchWordMap Class Methods Properties Events See Also Send Feedback

The SearchWordMap type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Find | Returns the collection of search results that match the given value.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPage | Gets the page at the given index.
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Map | Gets the word map.

Events

Name | Description
SearchProgress | This event provides updates on the progress of a search.

See Also

SearchWordMap Class
Mincom.LinkOne.Dom.Searching Namespace


SearchWordMap Methods

[image] [image]

LinkOne WebView API
SearchWordMap Methods
SearchWordMap Class See Also Send Feedback

The SearchWordMap type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Find | Returns the collection of search results that match the given value.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPage | Gets the page at the given index.
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SearchWordMap Class
Mincom.LinkOne.Dom.Searching Namespace


Find Method

[image]

LinkOne WebView API
SearchWordMap..::.Find Method
SearchWordMap Class See Also Send Feedback
Returns the collection of search results that match the given value.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchResultCollection Find(
    string value,
    bool matchCase,
    bool exactMatch,
    Regex noiseFilter,
    string displayField,
    string preferredListTitle,
    string languageCode
)
Visual Basic (Declaration)
Public Function Find ( _
    value As String, _
    matchCase As Boolean, _
    exactMatch As Boolean, _
    noiseFilter As Regex, _
    displayField As String, _
    preferredListTitle As String, _
    languageCode As String _
) As SearchResultCollection
Visual C++
public:
virtual SearchResultCollection^ Find(
    String^ value,
    bool matchCase,
    bool exactMatch,
    Regex^ noiseFilter,
    String^ displayField,
    String^ preferredListTitle,
    String^ languageCode
) sealed

Parameters

value
Type: System..::.String
The value to search for.
matchCase
Type: System..::.Boolean
True to match the case during the search.
exactMatch
Type: System..::.Boolean
True to match the full value length.
noiseFilter
Type: System.Text.RegularExpressions..::.Regex
Regular expression to apply to the searched string prior to searching it.
displayField
Type: System..::.String
The display field to choose for each result.
preferredListTitle
Type: System..::.String
The preferred list title.
languageCode
Type: System..::.String
The language code.

Return Value

The collection of search results that match the given value.

Implements

ISearchOverField..::.Find(String, Boolean, Boolean, Regex, String, String, String)

See Also

SearchWordMap Class
Mincom.LinkOne.Dom.Searching Namespace


GetPage Method

[image]

LinkOne WebView API
SearchWordMap..::.GetPage Method
SearchWordMap Class See Also Send Feedback
Gets the page at the given index.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Page GetPage(
    int pageIndex
)
Visual Basic (Declaration)
Public Function GetPage ( _
    pageIndex As Integer _
) As Page
Visual C++
public:
Page^ GetPage(
    int pageIndex
)

Parameters

pageIndex
Type: System..::.Int32
Index of the page.

Return Value

The page at the given index, or null if the page can't be found or is filtered.

See Also

SearchWordMap Class
Mincom.LinkOne.Dom.Searching Namespace


SearchWordMap Properties

[image] [image]

LinkOne WebView API
SearchWordMap Properties
SearchWordMap Class See Also Send Feedback

The SearchWordMap type exposes the following members.

Properties

Name | Description
Map | Gets the word map.

See Also

SearchWordMap Class
Mincom.LinkOne.Dom.Searching Namespace


Map Property

[image]

LinkOne WebView API
SearchWordMap..::.Map Property
SearchWordMap Class See Also Send Feedback
Gets the word map.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchFieldMap Map { get; }
Visual Basic (Declaration)
Public ReadOnly Property Map As SearchFieldMap
Visual C++
public:
property SearchFieldMap^ Map {
    SearchFieldMap^ get ();
}

See Also

SearchWordMap Class
Mincom.LinkOne.Dom.Searching Namespace


SearchWordMap Events

[image] [image]

LinkOne WebView API
SearchWordMap Events
SearchWordMap Class See Also Send Feedback

The SearchWordMap type exposes the following members.

Events

Name | Description
SearchProgress | This event provides updates on the progress of a search.

See Also

SearchWordMap Class
Mincom.LinkOne.Dom.Searching Namespace


SearchProgress Event

[image]

LinkOne WebView API
SearchWordMap..::.SearchProgress Event
SearchWordMap Class See Also Send Feedback
This event provides updates on the progress of a search.

Namespace: Mincom.LinkOne.Dom.Searching
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public event SearchProgressEventHandler SearchProgress
Visual Basic (Declaration)
Public Event SearchProgress As SearchProgressEventHandler
Visual C++
public:
virtual  event SearchProgressEventHandler^ SearchProgress {
    void add (SearchProgressEventHandler^ value);
    void remove (SearchProgressEventHandler^ value);
}

Implements

ISearchOverField..::.SearchProgress

See Also

SearchWordMap Class
Mincom.LinkOne.Dom.Searching Namespace


Mincom.LinkOne.Dom.SelectionList Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.Dom.SelectionList Namespace
Send Feedback
The Mincom.LinkOne.Dom.SelectionList namespace contains classes that provide read/write access to LinkOne selection lists. Generally this is used to exchange parts information with other applications.

Classes

Class | Description
Column | Represents a SelectionList column.
ColumnCollection | Represents a collection of Column objects.
Field | Represents a SelectionList data field.
FieldCollection | Represents a collection of Field objects.
FieldMapper | Provides selection list field mapping information.
FieldMappingDetail | Contains detail information about a field mapping..
Part | Represents a SelectionList part.
PartCollection | Represents a collection of IPart objects.
PartEventArgs | Provides data for the PartEventHandler events.
SelectionList | Represents a simple selection list class.
SelectionListCollection | Represents a collection of SelectionList objects.

Interfaces

Interface | Description
IColumn | Represents a column in a LinkOne selection list.
IColumnCollection | Represents the columns in a LinkOne selection list.
IField | Represents a field in a column for LinkOne selection list.
IFieldCollection | Represents the fields for a column in a LinkOne selection list.
IFieldMapper | Provides field mapping information for a LinkOne selection list.
IPart | Defines the publisher code, book code, page reference, item tag and set of fields for a part that has been added to the LinkOne selection list.
IPartCollection | Represents a collection of parts in a LinkOne selection list.
ISelectionList | Represents a LinkOne selection list.
ISelectionList2 | Extended Representation of a LinkOne selection list.
ISelectionListCollection | Represents a collection of selection lists.

Delegates

Delegate | Description
PartEventHandler | Delegate for part events.

Enumerations

Enumeration | Description
FieldMapDetailType | Defines a read-only field mapping detail object.
NewLineProcessing | Determines how selection list data with line breaks will be handled.
SelectionList..::.SourceType | The source of the selection list.


Column Class

[image]

LinkOne WebView API
Column Class
Members See Also Send Feedback
Represents a SelectionList column.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public class Column : IColumn, INotifyChanged
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class Column _
    Implements IColumn, INotifyChanged
Visual C++
[SerializableAttribute]
public ref class Column : IColumn, INotifyChanged

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.SelectionList..::.Column

See Also

Column Members
Mincom.LinkOne.Dom.SelectionList Namespace


Column Members

[image] [image]

LinkOne WebView API
Column Members
Column Class Constructors Methods Properties Events See Also Send Feedback

The Column type exposes the following members.

Constructors

Name | Description
Column | Constructor.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | Fires the Changed event.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Description | Gets or sets the description of the column.
ExportTag | Gets or sets the ExportTag name of the column.
IgnoreBracketedText | Gets or sets the ignore bracketed text flag of the column.
IsCriteria | Gets or sets the criteria flag of the column.
IsDescription | Gets or sets the description flag of the column.
IsEditable | Gets or sets the editable state of the column.
IsHidden | Gets or sets true if the column is hidden.
IsOptions | Gets or sets the options flag of the column.
IsRequestedQuantity | Gets or sets the requested quantity flag of the column.
Name | Gets the name for the column.
NewLineProcessing | Gets or sets the type of new line processing for this field.

Events

Name | Description
Changed | Occurs when the column has changed.

See Also

Column Class
Mincom.LinkOne.Dom.SelectionList Namespace


Column Constructor

[image]

LinkOne WebView API
Column Constructor
Column Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Column(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)
Visual C++
public:
Column(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the column.

See Also

Column Class
Mincom.LinkOne.Dom.SelectionList Namespace


Column Methods

[image] [image]

LinkOne WebView API
Column Methods
Column Class See Also Send Feedback

The Column type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | Fires the Changed event.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Column Class
Mincom.LinkOne.Dom.SelectionList Namespace


OnChanged Method

[image]

LinkOne WebView API
Column..::.OnChanged Method
Column Class See Also Send Feedback
Fires the Changed event.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected virtual void OnChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnChanged
Visual C++
protected:
virtual void OnChanged()

See Also

Column Class
Mincom.LinkOne.Dom.SelectionList Namespace


Column Properties

[image] [image]

LinkOne WebView API
Column Properties
Column Class See Also Send Feedback

The Column type exposes the following members.

Properties

Name | Description
Description | Gets or sets the description of the column.
ExportTag | Gets or sets the ExportTag name of the column.
IgnoreBracketedText | Gets or sets the ignore bracketed text flag of the column.
IsCriteria | Gets or sets the criteria flag of the column.
IsDescription | Gets or sets the description flag of the column.
IsEditable | Gets or sets the editable state of the column.
IsHidden | Gets or sets true if the column is hidden.
IsOptions | Gets or sets the options flag of the column.
IsRequestedQuantity | Gets or sets the requested quantity flag of the column.
Name | Gets the name for the column.
NewLineProcessing | Gets or sets the type of new line processing for this field.

See Also

Column Class
Mincom.LinkOne.Dom.SelectionList Namespace


Description Property

[image]

LinkOne WebView API
Column..::.Description Property
Column Class See Also Send Feedback
Gets or sets the description of the column.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
virtual property String^ Description {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IColumn..::.Description

Remarks

The description is either that set by the user, or is the predefined translated description if a predefined column name, or is the column name if the column name is not predefined.

See Also

Column Class
Mincom.LinkOne.Dom.SelectionList Namespace


ExportTag Property

[image]

LinkOne WebView API
Column..::.ExportTag Property
Column Class See Also Send Feedback
Gets or sets the ExportTag name of the column.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string ExportTag { get; set; }
Visual Basic (Declaration)
Public Property ExportTag As String
Visual C++
public:
virtual property String^ ExportTag {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IColumn..::.ExportTag

Remarks

The export tag is used when the selection list is exported in a tagged format. If not specified, field name is used as the export tag.

See Also

Column Class
Mincom.LinkOne.Dom.SelectionList Namespace


IgnoreBracketedText Property

[image]

LinkOne WebView API
Column..::.IgnoreBracketedText Property
Column Class See Also Send Feedback
Gets or sets the ignore bracketed text flag of the column.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IgnoreBracketedText { get; set; }
Visual Basic (Declaration)
Public Property IgnoreBracketedText As Boolean
Visual C++
public:
virtual property bool IgnoreBracketedText {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IColumn..::.IgnoreBracketedText

Remarks

When true, any text which is enclosed by brackets () will be removed when the text is added to the selection list field.

See Also

Column Class
Mincom.LinkOne.Dom.SelectionList Namespace


IsCriteria Property

[image]

LinkOne WebView API
Column..::.IsCriteria Property
Column Class See Also Send Feedback
Gets or sets the criteria flag of the column.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsCriteria { get; set; }
Visual Basic (Declaration)
Public Property IsCriteria As Boolean
Visual C++
public:
virtual property bool IsCriteria {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IColumn..::.IsCriteria

Remarks

This identifies the field as being one of the fields that determines if a parts list entry may be selected. If, when a parts list entry is added to the Selection List, any of the fields marked as Criteria would contain some data, then the parts list entry is considered selectable and will have a check box displayed next to it.

See Also

Column Class
Mincom.LinkOne.Dom.SelectionList Namespace


IsDescription Property

[image]

LinkOne WebView API
Column..::.IsDescription Property
Column Class See Also Send Feedback
Gets or sets the description flag of the column.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsDescription { get; set; }
Visual Basic (Declaration)
Public Property IsDescription As Boolean
Visual C++
public:
virtual property bool IsDescription {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IColumn..::.IsDescription

Remarks

The description state indicates if the column data will hold the description.

See Also

Column Class
Mincom.LinkOne.Dom.SelectionList Namespace


IsEditable Property

[image]

LinkOne WebView API
Column..::.IsEditable Property
Column Class See Also Send Feedback
Gets or sets the editable state of the column.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsEditable { get; set; }
Visual Basic (Declaration)
Public Property IsEditable As Boolean
Visual C++
public:
virtual property bool IsEditable {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IColumn..::.IsEditable

See Also

Column Class
Mincom.LinkOne.Dom.SelectionList Namespace


IsHidden Property

[image]

LinkOne WebView API
Column..::.IsHidden Property
Column Class See Also Send Feedback
Gets or sets true if the column is hidden.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsHidden { get; set; }
Visual Basic (Declaration)
Public Property IsHidden As Boolean
Visual C++
public:
virtual property bool IsHidden {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IColumn..::.IsHidden

See Also

Column Class
Mincom.LinkOne.Dom.SelectionList Namespace


IsOptions Property

[image]

LinkOne WebView API
Column..::.IsOptions Property
Column Class See Also Send Feedback
Gets or sets the options flag of the column.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsOptions { get; set; }
Visual Basic (Declaration)
Public Property IsOptions As Boolean
Visual C++
public:
virtual property bool IsOptions {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IColumn..::.IsOptions

Remarks

When true, indicates that the field contains the Option Codes that will be used when determining the filtering of this selection list entry. Only one SelectionListFieldDefinition within a SelectionListFieldDefinitionCollection, can be marked as an options field. Setting this property to true in a column within a column collection, sets all other columns in the column collection to false.

See Also

Column Class
Mincom.LinkOne.Dom.SelectionList Namespace


IsRequestedQuantity Property

[image]

LinkOne WebView API
Column..::.IsRequestedQuantity Property
Column Class See Also Send Feedback
Gets or sets the requested quantity flag of the column.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsRequestedQuantity { get; set; }
Visual Basic (Declaration)
Public Property IsRequestedQuantity As Boolean
Visual C++
public:
virtual property bool IsRequestedQuantity {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IColumn..::.IsRequestedQuantity

Remarks

The requested quantity state indicates if the column data will hold the requested quantity.

See Also

Column Class
Mincom.LinkOne.Dom.SelectionList Namespace


Name Property

[image]

LinkOne WebView API
Column..::.Name Property
Column Class See Also Send Feedback
Gets the name for the column.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
}

Implements

IColumn..::.Name

Remarks

The Name is used as the column header by the Automatic Layout, and will be used as the export-tag if no export-tag is specified. The Name will also be used to match the Selection List fields to the corresponding parts Entry field when a selection is made. To make this matching easier it is recommended that names match the standard parts list entry fields, whenever possible.

See Also

Column Class
Mincom.LinkOne.Dom.SelectionList Namespace


NewLineProcessing Property

[image]

LinkOne WebView API
Column..::.NewLineProcessing Property
Column Class See Also Send Feedback
Gets or sets the type of new line processing for this field.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public NewLineProcessing NewLineProcessing { get; set; }
Visual Basic (Declaration)
Public Property NewLineProcessing As NewLineProcessing
Visual C++
public:
virtual property NewLineProcessing NewLineProcessing {
    NewLineProcessing get () sealed;
    void set (NewLineProcessing value) sealed;
}

Implements

IColumn..::.NewLineProcessing

Remarks

The newline processing option determines how newline characters are treated when data is mapped into the selection list.

See Also

Column Class
Mincom.LinkOne.Dom.SelectionList Namespace


Column Events

[image] [image]

LinkOne WebView API
Column Events
Column Class See Also Send Feedback

The Column type exposes the following members.

Events

Name | Description
Changed | Occurs when the column has changed.

See Also

Column Class
Mincom.LinkOne.Dom.SelectionList Namespace


Changed Event

[image]

LinkOne WebView API
Column..::.Changed Event
Column Class See Also Send Feedback
Occurs when the column has changed.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public event EventHandler Changed
Visual Basic (Declaration)
Public Event Changed As EventHandler
Visual C++
public:
virtual  event EventHandler^ Changed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Implements

INotifyChanged..::.Changed

See Also

Column Class
Mincom.LinkOne.Dom.SelectionList Namespace


ColumnCollection Class

[image]

LinkOne WebView API
ColumnCollection Class
Members See Also Send Feedback
Represents a collection of Column objects.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class ColumnCollection : KeyedLiveCollection<string, Column>,
    IColumnCollection, IKeyedCollection<string, IColumn>, ICollection<IColumn>,
    IEnumerable<IColumn>, IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class ColumnCollection _
    Inherits KeyedLiveCollection(Of String, Column) _
    Implements IColumnCollection, IKeyedCollection(Of String, IColumn),  _
    ICollection(Of IColumn), IEnumerable(Of IColumn), IEnumerable
Visual C++
[SerializableAttribute]
public ref class ColumnCollection sealed : public KeyedLiveCollection<String^, Column^>,
    IColumnCollection, IKeyedCollection<String^, IColumn^>, ICollection<IColumn^>,
    IEnumerable<IColumn^>, IEnumerable

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection<(Of <( Column >)>)
LiveCollection<(Of <( Column >)>)
KeyedLiveCollection<(Of <(String, Column >)>)
Mincom.LinkOne.Dom.SelectionList..::.ColumnCollection

See Also

ColumnCollection Members
Mincom.LinkOne.Dom.SelectionList Namespace


ColumnCollection Members

[image] [image]

LinkOne WebView API
ColumnCollection Members
ColumnCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ColumnCollection type exposes the following members.

Constructors

Name | Description
ColumnCollection | Initializes a new instance of the ColumnCollection class.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Column >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Column >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Column >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Column >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( Column >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Column >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Column >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Column >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Column >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Column >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Column >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Column >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( Column >)>).)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Column >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Column >)>).)
OptionsColumn | Gets the column flagged to contain options.

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds an item to the IList. (Inherited from Collection<(Of <( Column >)>).)
ICollection<(Of <(IColumn>)>)..::.Add |
ICollection<(Of <(IColumn>)>)..::.Clear |
IList..::.Contains | Determines whether the IList contains a specific value. (Inherited from Collection<(Of <( Column >)>).)
IKeyedCollection<(Of <(String, IColumn>)>)..::.Contains |
ICollection<(Of <(IColumn>)>)..::.Contains |
ICollection..::.CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection<(Of <( Column >)>).)
ICollection<(Of <(IColumn>)>)..::.CopyTo |
ICollection<(Of <(IColumn>)>)..::.Count |
IColumnCollection..::.Create | Creates a column.
IEnumerable<(Of <(IColumn>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator |
IList..::.IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection<(Of <( Column >)>).)
IList..::.Insert | Inserts an item into the IList at the specified index. (Inherited from Collection<(Of <( Column >)>).)
IList..::.IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection<(Of <( Column >)>).)
IsReadOnly | Overloaded.
IList..::.IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection<(Of <( Column >)>).)
ICollection..::.IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection<(Of <( Column >)>).)
IList..::.Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( Column >)>).)
IKeyedCollection<(Of <(String, IColumn>)>)..::.Item |
IList..::.Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection<(Of <( Column >)>).)
ICollection<(Of <(IColumn>)>)..::.Remove |
ICollection..::.SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection<(Of <( Column >)>).)

See Also

ColumnCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


ColumnCollection Constructor

[image]

LinkOne WebView API
ColumnCollection Constructor
ColumnCollection Class See Also Send Feedback
Initializes a new instance of the ColumnCollection class.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ColumnCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ColumnCollection()

See Also

ColumnCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


ColumnCollection Methods

[image] [image]

LinkOne WebView API
ColumnCollection Methods
ColumnCollection Class See Also Send Feedback

The ColumnCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Column >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Column >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Column >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Column >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( Column >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Column >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Column >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Column >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Column >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Column >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Column >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Column >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( Column >)>).)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds an item to the IList. (Inherited from Collection<(Of <( Column >)>).)
ICollection<(Of <(IColumn>)>)..::.Add |
ICollection<(Of <(IColumn>)>)..::.Clear |
IList..::.Contains | Determines whether the IList contains a specific value. (Inherited from Collection<(Of <( Column >)>).)
IKeyedCollection<(Of <(String, IColumn>)>)..::.Contains |
ICollection<(Of <(IColumn>)>)..::.Contains |
ICollection..::.CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection<(Of <( Column >)>).)
ICollection<(Of <(IColumn>)>)..::.CopyTo |
IColumnCollection..::.Create | Creates a column.
IEnumerable<(Of <(IColumn>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator |
IList..::.IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection<(Of <( Column >)>).)
IList..::.Insert | Inserts an item into the IList at the specified index. (Inherited from Collection<(Of <( Column >)>).)
IList..::.Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection<(Of <( Column >)>).)
ICollection<(Of <(IColumn>)>)..::.Remove |

See Also

ColumnCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


ICollection(IColumn).Add Method

[image]

LinkOne WebView API
ColumnCollection..::.ICollection<(Of <(IColumn>)>)..::.Add Method
ColumnCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<IColumn>.Add(
    IColumn item
)
Visual Basic (Declaration)
Private Sub Add ( _
    item As IColumn _
) Implements ICollection(Of IColumn).Add
Visual C++
private:
virtual void Add(
    IColumn^ item
) sealed = ICollection<IColumn^>::Add

Parameters

item
Type: Mincom.LinkOne.Dom.SelectionList..::.IColumn

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

ColumnCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


ICollection(IColumn).Clear Method

[image]

LinkOne WebView API
ColumnCollection..::.ICollection<(Of <(IColumn>)>)..::.Clear Method
ColumnCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<IColumn>.Clear()
Visual Basic (Declaration)
Private Sub Clear Implements ICollection(Of IColumn).Clear
Visual C++
private:
virtual void Clear() sealed = ICollection<IColumn^>::Clear

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

See Also

ColumnCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


ICollection(IColumn).Contains Method

[image]

LinkOne WebView API
ColumnCollection..::.ICollection<(Of <(IColumn>)>)..::.Contains Method
ColumnCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<IColumn>.Contains(
    IColumn item
)
Visual Basic (Declaration)
Private Function Contains ( _
    item As IColumn _
) As Boolean Implements ICollection(Of IColumn).Contains
Visual C++
private:
virtual bool Contains(
    IColumn^ item
) sealed = ICollection<IColumn^>::Contains

Parameters

item
Type: Mincom.LinkOne.Dom.SelectionList..::.IColumn

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

ColumnCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


ICollection(IColumn).CopyTo Method

[image]

LinkOne WebView API
ColumnCollection..::.ICollection<(Of <(IColumn>)>)..::.CopyTo Method
ColumnCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<IColumn>.CopyTo(
    IColumn[] array,
    int arrayIndex
)
Visual Basic (Declaration)
Private Sub CopyTo ( _
    array As IColumn(), _
    arrayIndex As Integer _
) Implements ICollection(Of IColumn).CopyTo
Visual C++
private:
virtual void CopyTo(
    array<IColumn^>^ array,
    int arrayIndex
) sealed = ICollection<IColumn^>::CopyTo

Parameters

array
Type: array< Mincom.LinkOne.Dom.SelectionList..::.IColumn >[]()[]
arrayIndex
Type: System..::.Int32

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

ColumnCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


IEnumerable(IColumn).GetEnumerator Method

[image]

LinkOne WebView API
ColumnCollection..::.IEnumerable<(Of <(IColumn>)>)..::.GetEnumerator Method
ColumnCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator<IColumn> IEnumerable<IColumn>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of IColumn)
    Implements IEnumerable(Of IColumn).GetEnumerator
Visual C++
private:
virtual IEnumerator<IColumn^>^ GetEnumerator() sealed = IEnumerable<IColumn^>::GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

ColumnCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
ColumnCollection..::.IEnumerable..::.GetEnumerator Method
ColumnCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ColumnCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


ICollection(IColumn).Remove Method

[image]

LinkOne WebView API
ColumnCollection..::.ICollection<(Of <(IColumn>)>)..::.Remove Method
ColumnCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<IColumn>.Remove(
    IColumn item
)
Visual Basic (Declaration)
Private Function Remove ( _
    item As IColumn _
) As Boolean Implements ICollection(Of IColumn).Remove
Visual C++
private:
virtual bool Remove(
    IColumn^ item
) sealed = ICollection<IColumn^>::Remove

Parameters

item
Type: Mincom.LinkOne.Dom.SelectionList..::.IColumn

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

ColumnCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


IColumnCollection.Create Method

[image]

LinkOne WebView API
ColumnCollection..::.IColumnCollection..::.Create Method
ColumnCollection Class See Also Send Feedback
Creates a column.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IColumn IColumnCollection.Create(
    string name
)
Visual Basic (Declaration)
Private Function Create ( _
    name As String _
) As IColumn Implements IColumnCollection.Create
Visual C++
private:
virtual IColumn^ Create(
    String^ name
) sealed = IColumnCollection::Create

Parameters

name
Type: System..::.String
The name of the column.

Return Value

A new IColumn.

Implements

IColumnCollection..::.Create(String)

See Also

ColumnCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


IKeyedCollection(String, IColumn).Contains Method

[image]

LinkOne WebView API
ColumnCollection..::.IKeyedCollection<(Of <(String, IColumn>)>)..::.Contains Method
ColumnCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IKeyedCollection<string, IColumn>.Contains(
    string domObjectKey
)
Visual Basic (Declaration)
Private Function Contains ( _
    domObjectKey As String _
) As Boolean Implements IKeyedCollection(Of String, IColumn).Contains
Visual C++
private:
virtual bool Contains(
    String^ domObjectKey
) sealed = IKeyedCollection<String^, IColumn^>::Contains

Parameters

domObjectKey
Type: System..::.String

Implements

IKeyedCollection<(Of <(TKey, TItem>)>)..::.Contains(TKey)

See Also

ColumnCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


ColumnCollection Properties

[image] [image]

LinkOne WebView API
ColumnCollection Properties
ColumnCollection Class See Also Send Feedback

The ColumnCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Column >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Column >)>).)
OptionsColumn | Gets the column flagged to contain options.

Explicit Interface Implementations

Name | Description
ICollection<(Of <(IColumn>)>)..::.Count |
IList..::.IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection<(Of <( Column >)>).)
IsReadOnly | Overloaded.
IList..::.IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection<(Of <( Column >)>).)
ICollection..::.IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection<(Of <( Column >)>).)
IList..::.Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( Column >)>).)
IKeyedCollection<(Of <(String, IColumn>)>)..::.Item |
ICollection..::.SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection<(Of <( Column >)>).)

See Also

ColumnCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


ICollection(IColumn).Count Property

[image]

LinkOne WebView API
ColumnCollection..::.ICollection<(Of <(IColumn>)>)..::.Count Property
ColumnCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int ICollection<IColumn>.Count { get; }
Visual Basic (Declaration)
Private ReadOnly Property Count As Integer
    Implements ICollection(Of IColumn).Count
Visual C++
private:
virtual property int Count {
    int get () sealed = ICollection<IColumn^>::Count::get;
}

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

ColumnCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


IKeyedCollection(String, IColumn).Item Property

[image]

LinkOne WebView API
ColumnCollection..::.IKeyedCollection<(Of <(String, IColumn>)>)..::.Item Property
ColumnCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IColumn IKeyedCollection<string, IColumn>.Item[
    string domObjectKey
] { get; set; }
Visual Basic (Declaration)
Private Property Item ( _
    domObjectKey As String _
) As IColumn Implements IKeyedCollection(Of String, IColumn).Item
Visual C++
private:
virtual property IColumn^ Item[String^ domObjectKey] {
    IColumn^ get (String^ domObjectKey) sealed = IKeyedCollection<String^, IColumn^>::Item::get;
    void set (String^ domObjectKey, IColumn^ value) sealed = IKeyedCollection<String^, IColumn^>::Item::set;
}

Parameters

domObjectKey
Type: System..::.String

Implements

IKeyedCollection<(Of <(TKey, TItem>)>)..::.Item[([(TKey])])

See Also

ColumnCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


IsReadOnly Property

[image] [image]

LinkOne WebView API
ColumnCollection..::.IsReadOnly Property
ColumnCollection Class See Also Send Feedback

Overload List

Name | Description
System#Collections#Generic#ICollection{T}#IsReadOnly()()() | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from Collection<(Of <( Column >)>).)
ICollection<(Of <(IColumn>)>)..::.IsReadOnly |

See Also

ColumnCollection Class
ColumnCollection Members
Mincom.LinkOne.Dom.SelectionList Namespace


ICollection(IColumn).IsReadOnly Property

[image]

LinkOne WebView API
ColumnCollection..::.ICollection<(Of <(IColumn>)>)..::.IsReadOnly Property
ColumnCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<IColumn>.IsReadOnly { get; }
Visual Basic (Declaration)
Private ReadOnly Property IsReadOnly As Boolean
    Implements ICollection(Of IColumn).IsReadOnly
Visual C++
private:
virtual property bool IsReadOnly {
    bool get () sealed = ICollection<IColumn^>::IsReadOnly::get;
}

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

ColumnCollection Class
ColumnCollection Overload
Mincom.LinkOne.Dom.SelectionList Namespace


Item Property

[image] [image]

LinkOne WebView API
ColumnCollection..::.Item Property
ColumnCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( Column >)>).)
Item[([(String])]) | Overriden. Gets the Column with the specified name, if it exists. If the column does not exist it is created, and added to the collection.

See Also

ColumnCollection Class
ColumnCollection Members
Mincom.LinkOne.Dom.SelectionList Namespace


Item Property (String)

[image]

LinkOne WebView API
ColumnCollection..::.Item Property (String)
ColumnCollection Class See Also Send Feedback
Overriden. Gets the Column with the specified name, if it exists. If the column does not exist it is created, and added to the collection.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Column this[
    string name
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    name As String _
) As Column
Visual C++
public:
property Column^ default[String^ name] {
    Column^ get (String^ name);
    void set (String^ name, Column^ value);
}

Parameters

name
Type: System..::.String

See Also

ColumnCollection Class
Item Overload
Mincom.LinkOne.Dom.SelectionList Namespace


OptionsColumn Property

[image]

LinkOne WebView API
ColumnCollection..::.OptionsColumn Property
ColumnCollection Class See Also Send Feedback
Gets the column flagged to contain options.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Column OptionsColumn { get; }
Visual Basic (Declaration)
Public ReadOnly Property OptionsColumn As Column
Visual C++
public:
property Column^ OptionsColumn {
    Column^ get ();
}

See Also

ColumnCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


Field Class

[image]

LinkOne WebView API
Field Class
Members See Also Send Feedback
Represents a SelectionList data field.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public class Field : IField, INotifyChanged
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class Field _
    Implements IField, INotifyChanged
Visual C++
[SerializableAttribute]
public ref class Field : IField, INotifyChanged

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.SelectionList..::.Field

See Also

Field Members
Mincom.LinkOne.Dom.SelectionList Namespace


Field Members

[image] [image]

LinkOne WebView API
Field Members
Field Class Constructors Methods Properties Events See Also Send Feedback

The Field type exposes the following members.

Constructors

Name | Description
Field | Initializes a new instance of the Field class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | Fires the Changed event.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
ColumnName | Gets the field column name.
Value | Gets or sets the field value.

Events

Name | Description
Changed | Occurs when the field has changed.

See Also

Field Class
Mincom.LinkOne.Dom.SelectionList Namespace


Field Constructor

[image]

LinkOne WebView API
Field Constructor
Field Class See Also Send Feedback
Initializes a new instance of the Field class.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Field(
    string columnName,
    string value
)
Visual Basic (Declaration)
Public Sub New ( _
    columnName As String, _
    value As String _
)
Visual C++
public:
Field(
    String^ columnName,
    String^ value
)

Parameters

columnName
Type: System..::.String
The column name associated with the field.
value
Type: System..::.String
The value of the field.

See Also

Field Class
Mincom.LinkOne.Dom.SelectionList Namespace


Field Methods

[image] [image]

LinkOne WebView API
Field Methods
Field Class See Also Send Feedback

The Field type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | Fires the Changed event.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Field Class
Mincom.LinkOne.Dom.SelectionList Namespace


OnChanged Method

[image]

LinkOne WebView API
Field..::.OnChanged Method
Field Class See Also Send Feedback
Fires the Changed event.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected virtual void OnChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnChanged
Visual C++
protected:
virtual void OnChanged()

See Also

Field Class
Mincom.LinkOne.Dom.SelectionList Namespace


Field Properties

[image] [image]

LinkOne WebView API
Field Properties
Field Class See Also Send Feedback

The Field type exposes the following members.

Properties

Name | Description
ColumnName | Gets the field column name.
Value | Gets or sets the field value.

See Also

Field Class
Mincom.LinkOne.Dom.SelectionList Namespace


ColumnName Property

[image]

LinkOne WebView API
Field..::.ColumnName Property
Field Class See Also Send Feedback
Gets the field column name.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string ColumnName { get; }
Visual Basic (Declaration)
Public ReadOnly Property ColumnName As String
Visual C++
public:
virtual property String^ ColumnName {
    String^ get () sealed;
}

Implements

IField..::.ColumnName

See Also

Field Class
Mincom.LinkOne.Dom.SelectionList Namespace


Value Property

[image]

LinkOne WebView API
Field..::.Value Property
Field Class See Also Send Feedback
Gets or sets the field value.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String
Visual C++
public:
virtual property String^ Value {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IField..::.Value

See Also

Field Class
Mincom.LinkOne.Dom.SelectionList Namespace


Field Events

[image] [image]

LinkOne WebView API
Field Events
Field Class See Also Send Feedback

The Field type exposes the following members.

Events

Name | Description
Changed | Occurs when the field has changed.

See Also

Field Class
Mincom.LinkOne.Dom.SelectionList Namespace


Changed Event

[image]

LinkOne WebView API
Field..::.Changed Event
Field Class See Also Send Feedback
Occurs when the field has changed.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public event EventHandler Changed
Visual Basic (Declaration)
Public Event Changed As EventHandler
Visual C++
public:
virtual  event EventHandler^ Changed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Implements

INotifyChanged..::.Changed

See Also

Field Class
Mincom.LinkOne.Dom.SelectionList Namespace


FieldCollection Class

[image]

LinkOne WebView API
FieldCollection Class
Members See Also Send Feedback
Represents a collection of Field objects.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class FieldCollection : KeyedLiveCollection<string, Field>,
    IFieldCollection, IKeyedCollection<string, IField>, ICollection<IField>,
    IEnumerable<IField>, IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class FieldCollection _
    Inherits KeyedLiveCollection(Of String, Field) _
    Implements IFieldCollection, IKeyedCollection(Of String, IField),  _
    ICollection(Of IField), IEnumerable(Of IField), IEnumerable
Visual C++
[SerializableAttribute]
public ref class FieldCollection sealed : public KeyedLiveCollection<String^, Field^>,
    IFieldCollection, IKeyedCollection<String^, IField^>, ICollection<IField^>,
    IEnumerable<IField^>, IEnumerable

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection<(Of <( Field >)>)
LiveCollection<(Of <( Field >)>)
KeyedLiveCollection<(Of <(String, Field >)>)
Mincom.LinkOne.Dom.SelectionList..::.FieldCollection

See Also

FieldCollection Members
Mincom.LinkOne.Dom.SelectionList Namespace


FieldCollection Members

[image] [image]

LinkOne WebView API
FieldCollection Members
FieldCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The FieldCollection type exposes the following members.

Constructors

Name | Description
FieldCollection | Initializes a new instance of the FieldCollection class.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Field >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Field >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Field >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Field >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( Field >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Field >)>).)
GetFieldText | Gets the value of a field with the specified name from the collecion.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Field >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Field >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Field >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Field >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Field >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Field >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( Field >)>).)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Field >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Field >)>).)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds an item to the IList. (Inherited from Collection<(Of <( Field >)>).)
ICollection<(Of <(IField>)>)..::.Add |
ICollection<(Of <(IField>)>)..::.Clear |
IList..::.Contains | Determines whether the IList contains a specific value. (Inherited from Collection<(Of <( Field >)>).)
IKeyedCollection<(Of <(String, IField>)>)..::.Contains |
ICollection<(Of <(IField>)>)..::.Contains |
ICollection..::.CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection<(Of <( Field >)>).)
ICollection<(Of <(IField>)>)..::.CopyTo |
ICollection<(Of <(IField>)>)..::.Count |
IEnumerable<(Of <(IField>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator |
IList..::.IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection<(Of <( Field >)>).)
IList..::.Insert | Inserts an item into the IList at the specified index. (Inherited from Collection<(Of <( Field >)>).)
IList..::.IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection<(Of <( Field >)>).)
IsReadOnly | Overloaded.
IList..::.IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection<(Of <( Field >)>).)
ICollection..::.IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection<(Of <( Field >)>).)
IList..::.Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( Field >)>).)
IKeyedCollection<(Of <(String, IField>)>)..::.Item |
IList..::.Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection<(Of <( Field >)>).)
ICollection<(Of <(IField>)>)..::.Remove |
ICollection..::.SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection<(Of <( Field >)>).)

See Also

FieldCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


FieldCollection Constructor

[image]

LinkOne WebView API
FieldCollection Constructor
FieldCollection Class See Also Send Feedback
Initializes a new instance of the FieldCollection class.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public FieldCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FieldCollection()

See Also

FieldCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


FieldCollection Methods

[image] [image]

LinkOne WebView API
FieldCollection Methods
FieldCollection Class See Also Send Feedback

The FieldCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Field >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Field >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Field >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Field >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( Field >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Field >)>).)
GetFieldText | Gets the value of a field with the specified name from the collecion.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Field >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Field >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Field >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Field >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Field >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Field >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( Field >)>).)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds an item to the IList. (Inherited from Collection<(Of <( Field >)>).)
ICollection<(Of <(IField>)>)..::.Add |
ICollection<(Of <(IField>)>)..::.Clear |
IList..::.Contains | Determines whether the IList contains a specific value. (Inherited from Collection<(Of <( Field >)>).)
IKeyedCollection<(Of <(String, IField>)>)..::.Contains |
ICollection<(Of <(IField>)>)..::.Contains |
ICollection..::.CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection<(Of <( Field >)>).)
ICollection<(Of <(IField>)>)..::.CopyTo |
IEnumerable<(Of <(IField>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator |
IList..::.IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection<(Of <( Field >)>).)
IList..::.Insert | Inserts an item into the IList at the specified index. (Inherited from Collection<(Of <( Field >)>).)
IList..::.Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection<(Of <( Field >)>).)
ICollection<(Of <(IField>)>)..::.Remove |

See Also

FieldCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


ICollection(IField).Add Method

[image]

LinkOne WebView API
FieldCollection..::.ICollection<(Of <(IField>)>)..::.Add Method
FieldCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<IField>.Add(
    IField item
)
Visual Basic (Declaration)
Private Sub Add ( _
    item As IField _
) Implements ICollection(Of IField).Add
Visual C++
private:
virtual void Add(
    IField^ item
) sealed = ICollection<IField^>::Add

Parameters

item
Type: Mincom.LinkOne.Dom.SelectionList..::.IField

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

FieldCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


ICollection(IField).Clear Method

[image]

LinkOne WebView API
FieldCollection..::.ICollection<(Of <(IField>)>)..::.Clear Method
FieldCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<IField>.Clear()
Visual Basic (Declaration)
Private Sub Clear Implements ICollection(Of IField).Clear
Visual C++
private:
virtual void Clear() sealed = ICollection<IField^>::Clear

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

See Also

FieldCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


ICollection(IField).Contains Method

[image]

LinkOne WebView API
FieldCollection..::.ICollection<(Of <(IField>)>)..::.Contains Method
FieldCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<IField>.Contains(
    IField item
)
Visual Basic (Declaration)
Private Function Contains ( _
    item As IField _
) As Boolean Implements ICollection(Of IField).Contains
Visual C++
private:
virtual bool Contains(
    IField^ item
) sealed = ICollection<IField^>::Contains

Parameters

item
Type: Mincom.LinkOne.Dom.SelectionList..::.IField

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

FieldCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


ICollection(IField).CopyTo Method

[image]

LinkOne WebView API
FieldCollection..::.ICollection<(Of <(IField>)>)..::.CopyTo Method
FieldCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<IField>.CopyTo(
    IField[] array,
    int arrayIndex
)
Visual Basic (Declaration)
Private Sub CopyTo ( _
    array As IField(), _
    arrayIndex As Integer _
) Implements ICollection(Of IField).CopyTo
Visual C++
private:
virtual void CopyTo(
    array<IField^>^ array,
    int arrayIndex
) sealed = ICollection<IField^>::CopyTo

Parameters

array
Type: array< Mincom.LinkOne.Dom.SelectionList..::.IField >[]()[]
arrayIndex
Type: System..::.Int32

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

FieldCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


IEnumerable(IField).GetEnumerator Method

[image]

LinkOne WebView API
FieldCollection..::.IEnumerable<(Of <(IField>)>)..::.GetEnumerator Method
FieldCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator<IField> IEnumerable<IField>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of IField)
    Implements IEnumerable(Of IField).GetEnumerator
Visual C++
private:
virtual IEnumerator<IField^>^ GetEnumerator() sealed = IEnumerable<IField^>::GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

FieldCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
FieldCollection..::.IEnumerable..::.GetEnumerator Method
FieldCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Implements

IEnumerable..::.GetEnumerator()()()

See Also

FieldCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


ICollection(IField).Remove Method

[image]

LinkOne WebView API
FieldCollection..::.ICollection<(Of <(IField>)>)..::.Remove Method
FieldCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<IField>.Remove(
    IField item
)
Visual Basic (Declaration)
Private Function Remove ( _
    item As IField _
) As Boolean Implements ICollection(Of IField).Remove
Visual C++
private:
virtual bool Remove(
    IField^ item
) sealed = ICollection<IField^>::Remove

Parameters

item
Type: Mincom.LinkOne.Dom.SelectionList..::.IField

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

FieldCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


GetFieldText Method

[image]

LinkOne WebView API
FieldCollection..::.GetFieldText Method
FieldCollection Class See Also Send Feedback
Gets the value of a field with the specified name from the collecion.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string GetFieldText(
    string name
)
Visual Basic (Declaration)
Public Function GetFieldText ( _
    name As String _
) As String
Visual C++
public:
virtual String^ GetFieldText(
    String^ name
) sealed

Parameters

name
Type: System..::.String
The field name to get.

Return Value

The field value or empty string if no field is found.

Implements

IFieldCollection..::.GetFieldText(String)

See Also

FieldCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


IKeyedCollection(String, IField).Contains Method

[image]

LinkOne WebView API
FieldCollection..::.IKeyedCollection<(Of <(String, IField>)>)..::.Contains Method
FieldCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IKeyedCollection<string, IField>.Contains(
    string domObjectKey
)
Visual Basic (Declaration)
Private Function Contains ( _
    domObjectKey As String _
) As Boolean Implements IKeyedCollection(Of String, IField).Contains
Visual C++
private:
virtual bool Contains(
    String^ domObjectKey
) sealed = IKeyedCollection<String^, IField^>::Contains

Parameters

domObjectKey
Type: System..::.String

Implements

IKeyedCollection<(Of <(TKey, TItem>)>)..::.Contains(TKey)

See Also

FieldCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


FieldCollection Properties

[image] [image]

LinkOne WebView API
FieldCollection Properties
FieldCollection Class See Also Send Feedback

The FieldCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Field >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Field >)>).)

Explicit Interface Implementations

Name | Description
ICollection<(Of <(IField>)>)..::.Count |
IList..::.IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection<(Of <( Field >)>).)
IsReadOnly | Overloaded.
IList..::.IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection<(Of <( Field >)>).)
ICollection..::.IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection<(Of <( Field >)>).)
IList..::.Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( Field >)>).)
IKeyedCollection<(Of <(String, IField>)>)..::.Item |
ICollection..::.SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection<(Of <( Field >)>).)

See Also

FieldCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


ICollection(IField).Count Property

[image]

LinkOne WebView API
FieldCollection..::.ICollection<(Of <(IField>)>)..::.Count Property
FieldCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int ICollection<IField>.Count { get; }
Visual Basic (Declaration)
Private ReadOnly Property Count As Integer
    Implements ICollection(Of IField).Count
Visual C++
private:
virtual property int Count {
    int get () sealed = ICollection<IField^>::Count::get;
}

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

FieldCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


IKeyedCollection(String, IField).Item Property

[image]

LinkOne WebView API
FieldCollection..::.IKeyedCollection<(Of <(String, IField>)>)..::.Item Property
FieldCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IField IKeyedCollection<string, IField>.Item[
    string domObjectKey
] { get; set; }
Visual Basic (Declaration)
Private Property Item ( _
    domObjectKey As String _
) As IField Implements IKeyedCollection(Of String, IField).Item
Visual C++
private:
virtual property IField^ Item[String^ domObjectKey] {
    IField^ get (String^ domObjectKey) sealed = IKeyedCollection<String^, IField^>::Item::get;
    void set (String^ domObjectKey, IField^ value) sealed = IKeyedCollection<String^, IField^>::Item::set;
}

Parameters

domObjectKey
Type: System..::.String

Implements

IKeyedCollection<(Of <(TKey, TItem>)>)..::.Item[([(TKey])])

See Also

FieldCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


IsReadOnly Property

[image] [image]

LinkOne WebView API
FieldCollection..::.IsReadOnly Property
FieldCollection Class See Also Send Feedback

Overload List

Name | Description
System#Collections#Generic#ICollection{T}#IsReadOnly()()() | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from Collection<(Of <( Field >)>).)
ICollection<(Of <(IField>)>)..::.IsReadOnly |

See Also

FieldCollection Class
FieldCollection Members
Mincom.LinkOne.Dom.SelectionList Namespace


ICollection(IField).IsReadOnly Property

[image]

LinkOne WebView API
FieldCollection..::.ICollection<(Of <(IField>)>)..::.IsReadOnly Property
FieldCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<IField>.IsReadOnly { get; }
Visual Basic (Declaration)
Private ReadOnly Property IsReadOnly As Boolean
    Implements ICollection(Of IField).IsReadOnly
Visual C++
private:
virtual property bool IsReadOnly {
    bool get () sealed = ICollection<IField^>::IsReadOnly::get;
}

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

FieldCollection Class
FieldCollection Overload
Mincom.LinkOne.Dom.SelectionList Namespace


Item Property

[image] [image]

LinkOne WebView API
FieldCollection..::.Item Property
FieldCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( Field >)>).)
Item[([(String])]) | Overriden. Gets the Field with the specified name, if it exists. If the Field does not exist it is created, and added to the collection.

See Also

FieldCollection Class
FieldCollection Members
Mincom.LinkOne.Dom.SelectionList Namespace


Item Property (String)

[image]

LinkOne WebView API
FieldCollection..::.Item Property (String)
FieldCollection Class See Also Send Feedback
Overriden. Gets the Field with the specified name, if it exists. If the Field does not exist it is created, and added to the collection.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Field this[
    string name
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    name As String _
) As Field
Visual C++
public:
property Field^ default[String^ name] {
    Field^ get (String^ name);
    void set (String^ name, Field^ value);
}

Parameters

name
Type: System..::.String

See Also

FieldCollection Class
Item Overload
Mincom.LinkOne.Dom.SelectionList Namespace


FieldMapDetailType Enumeration

[image]

LinkOne WebView API
FieldMapDetailType Enumeration
See Also Send Feedback
Defines a read-only field mapping detail object.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum FieldMapDetailType
Visual Basic (Declaration)
Public Enumeration FieldMapDetailType
Visual C++
public enum class FieldMapDetailType

Members

Member name | Description
None | There is no field mapping.
Implicit | The field mapping detail relates to an implied mapping.
Explicit | The field mapping detail relates to an explicit mapping.
RequestedQuantity | The field mapping detail relates to a requested quantity selection list column.
Option | The field mapping detail relates to an option column.

See Also

Mincom.LinkOne.Dom.SelectionList Namespace


FieldMapper Class

[image]

LinkOne WebView API
FieldMapper Class
Members See Also Send Feedback
Provides selection list field mapping information.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public class FieldMapper : IFieldMapper
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class FieldMapper _
    Implements IFieldMapper
Visual C++
[SerializableAttribute]
public ref class FieldMapper : IFieldMapper

Remarks

A field mapping note relates a field in a selection list to other fields, such as a book or entry fields.

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.SelectionList..::.FieldMapper

See Also

FieldMapper Members
Mincom.LinkOne.Dom.SelectionList Namespace


FieldMapper Members

[image] [image]

LinkOne WebView API
FieldMapper Members
FieldMapper Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The FieldMapper type exposes the following members.

Constructors

Name | Description
FieldMapper | Overloaded.

Methods

Name | Description
AddFieldMapping | Adds a FieldMapping object.
CanWriteMapping | Determines if a field mapping of a specific access and scope can be written.
Commit | Update forces any changes made to the FieldMapper to get committed to the original note collection.
CreatePart | Creates the part.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetFieldMappingDetail | Gets the FieldMappingDetail for a specified column name.
GetFieldNames | Gets the names of the predefined fields associated with a specific field mapping type.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
Initialize | Initializes the FieldMapper instance with the new field mapping of the specified note collection.
MapPart | Creates a mapped part from a book view.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RemoveFieldMapping | Removes a FieldMapping object.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Columns | Gets the collection of columns that the field mappings relate to.
FieldMappings | Gets an array of FieldMapping notes.
HasChanged | Gets true if the field mappings have changed.

Explicit Interface Implementations

Name | Description
IFieldMapper..::.FieldMappings |
IFieldMapper..::.MapPart |

See Also

FieldMapper Class
Mincom.LinkOne.Dom.SelectionList Namespace


FieldMapper Constructor

[image] [image]

LinkOne WebView API
FieldMapper Constructor
FieldMapper Class See Also Send Feedback

Overload List

Name | Description
FieldMapper()()() | Initializes a new instance of the FieldMapper class that has no configured mappings.
FieldMapper(ColumnCollection, NoteCollection, String, IList<(Of <(String>)>)) | Initializes a new instance of the FieldMapper class.

See Also

FieldMapper Class
FieldMapper Members
Mincom.LinkOne.Dom.SelectionList Namespace


FieldMapper Constructor

[image]

LinkOne WebView API
FieldMapper Constructor
FieldMapper Class See Also Send Feedback
Initializes a new instance of the FieldMapper class that has no configured mappings.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public FieldMapper()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FieldMapper()

See Also

FieldMapper Class
FieldMapper Overload
Mincom.LinkOne.Dom.SelectionList Namespace


FieldMapper Constructor (ColumnCollection, NoteCollection, String, IList(String))

[image]

LinkOne WebView API
FieldMapper Constructor (ColumnCollection, NoteCollection, String, IList<(Of <(String>)>))
FieldMapper Class See Also Send Feedback
Initializes a new instance of the FieldMapper class.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public FieldMapper(
    ColumnCollection columns,
    NoteCollection notes,
    string languageCode,
    IList<string> entryFieldDefinitions
)
Visual Basic (Declaration)
Public Sub New ( _
    columns As ColumnCollection, _
    notes As NoteCollection, _
    languageCode As String, _
    entryFieldDefinitions As IList(Of String) _
)
Visual C++
public:
FieldMapper(
    ColumnCollection^ columns,
    NoteCollection^ notes,
    String^ languageCode,
    IList<String^>^ entryFieldDefinitions
)

Parameters

columns
Type: Mincom.LinkOne.Dom.SelectionList..::.ColumnCollection
The collection of selection list Columns.
notes
Type: Mincom.LinkOne.Dom.Notes..::.NoteCollection
The note collection which contains the FieldMappings.
languageCode
Type: System..::.String
The language code.
entryFieldDefinitions
Type: System.Collections.Generic..::.IList<(Of <(String>)>)
The collection of custom entry field definitions.

See Also

FieldMapper Class
FieldMapper Overload
Mincom.LinkOne.Dom.SelectionList Namespace


FieldMapper Methods

[image] [image]

LinkOne WebView API
FieldMapper Methods
FieldMapper Class See Also Send Feedback

The FieldMapper type exposes the following members.

Methods

Name | Description
AddFieldMapping | Adds a FieldMapping object.
CanWriteMapping | Determines if a field mapping of a specific access and scope can be written.
Commit | Update forces any changes made to the FieldMapper to get committed to the original note collection.
CreatePart | Creates the part.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetFieldMappingDetail | Gets the FieldMappingDetail for a specified column name.
GetFieldNames | Gets the names of the predefined fields associated with a specific field mapping type.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
Initialize | Initializes the FieldMapper instance with the new field mapping of the specified note collection.
MapPart | Creates a mapped part from a book view.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RemoveFieldMapping | Removes a FieldMapping object.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IFieldMapper..::.MapPart |

See Also

FieldMapper Class
Mincom.LinkOne.Dom.SelectionList Namespace


AddFieldMapping Method

[image]

LinkOne WebView API
FieldMapper..::.AddFieldMapping Method
FieldMapper Class See Also Send Feedback
Adds a FieldMapping object.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void AddFieldMapping(
    FieldMapping fieldMapping
)
Visual Basic (Declaration)
Public Sub AddFieldMapping ( _
    fieldMapping As FieldMapping _
)
Visual C++
public:
void AddFieldMapping(
    FieldMapping^ fieldMapping
)

Parameters

fieldMapping
Type: Mincom.LinkOne.Dom.Notes..::.FieldMapping
The FieldMapping object to add.

See Also

FieldMapper Class
Mincom.LinkOne.Dom.SelectionList Namespace


CanWriteMapping Method

[image]

LinkOne WebView API
FieldMapper..::.CanWriteMapping Method
FieldMapper Class See Also Send Feedback
Determines if a field mapping of a specific access and scope can be written.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool CanWriteMapping(
    Access access,
    Scope scope
)
Visual Basic (Declaration)
Public Function CanWriteMapping ( _
    access As Access, _
    scope As Scope _
) As Boolean
Visual C++
public:
bool CanWriteMapping(
    Access access,
    Scope scope
)

Parameters

access
Type: Mincom.LinkOne.Dom.Notes..::.Access
The field mapping note access.
scope
Type: Mincom.LinkOne.Dom.Notes..::.Scope
The field mapping note scope.

Return Value

True if the field mapping note can be written, otherwise false.

See Also

FieldMapper Class
Mincom.LinkOne.Dom.SelectionList Namespace


Commit Method

[image]

LinkOne WebView API
FieldMapper..::.Commit Method
FieldMapper Class See Also Send Feedback
Update forces any changes made to the FieldMapper to get committed to the original note collection.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public virtual NoteCollection Commit()
Visual Basic (Declaration)
Public Overridable Function Commit As NoteCollection
Visual C++
public:
virtual NoteCollection^ Commit()

Return Value

The original collection of notes with field mapping updates applied to it.

See Also

FieldMapper Class
Mincom.LinkOne.Dom.SelectionList Namespace


CreatePart Method

[image]

LinkOne WebView API
FieldMapper..::.CreatePart Method
FieldMapper Class See Also Send Feedback
Creates the part.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected virtual IPart CreatePart(
    string specificObject,
    string publisherCode,
    string masterBookCode,
    string bookCode,
    string pageReference,
    string entryItemId,
    int tagNumber,
    int pictureNumber,
    string gotoItemId,
    string checkCode
)
Visual Basic (Declaration)
Protected Overridable Function CreatePart ( _
    specificObject As String, _
    publisherCode As String, _
    masterBookCode As String, _
    bookCode As String, _
    pageReference As String, _
    entryItemId As String, _
    tagNumber As Integer, _
    pictureNumber As Integer, _
    gotoItemId As String, _
    checkCode As String _
) As IPart
Visual C++
protected:
virtual IPart^ CreatePart(
    String^ specificObject,
    String^ publisherCode,
    String^ masterBookCode,
    String^ bookCode,
    String^ pageReference,
    String^ entryItemId,
    int tagNumber,
    int pictureNumber,
    String^ gotoItemId,
    String^ checkCode
)

Parameters

specificObject
Type: System..::.String
The specific object.
publisherCode
Type: System..::.String
The publisher code.
masterBookCode
Type: System..::.String
The master book code.
bookCode
Type: System..::.String
The book code.
pageReference
Type: System..::.String
The page reference.
entryItemId
Type: System..::.String
The entry item id.
tagNumber
Type: System..::.Int32
The tag number.
pictureNumber
Type: System..::.Int32
The picture number.
gotoItemId
Type: System..::.String
The goto entry item id.
checkCode
Type: System..::.String
The check code.

Return Value

The new part.

See Also

FieldMapper Class
Mincom.LinkOne.Dom.SelectionList Namespace


GetFieldMappingDetail Method

[image]

LinkOne WebView API
FieldMapper..::.GetFieldMappingDetail Method
FieldMapper Class See Also Send Feedback
Gets the FieldMappingDetail for a specified column name.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public FieldMappingDetail GetFieldMappingDetail(
    Column column
)
Visual Basic (Declaration)
Public Function GetFieldMappingDetail ( _
    column As Column _
) As FieldMappingDetail
Visual C++
public:
FieldMappingDetail^ GetFieldMappingDetail(
    Column^ column
)

Parameters

column
Type: Mincom.LinkOne.Dom.SelectionList..::.Column
The column whose FieldMappingDetail is required.

Return Value

The field mapping detail for the column, or null if the column does not exist.

Remarks

The array of FieldMappingDetail objects being returned, only includes FieldMapping's that directly participate in resolving the target field mapping, and is based on the current language. It does not include FieldMapping's for other languages.

See Also

FieldMapper Class
Mincom.LinkOne.Dom.SelectionList Namespace


GetFieldNames Method

[image]

LinkOne WebView API
FieldMapper..::.GetFieldNames Method
FieldMapper Class See Also Send Feedback
Gets the names of the predefined fields associated with a specific field mapping type.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static IList<string> GetFieldNames(
    FieldMappingType fieldMappingType
)
Visual Basic (Declaration)
Public Shared Function GetFieldNames ( _
    fieldMappingType As FieldMappingType _
) As IList(Of String)
Visual C++
public:
static IList<String^>^ GetFieldNames(
    FieldMappingType fieldMappingType
)

Parameters

fieldMappingType
Type: Mincom.LinkOne.Dom.Notes..::.FieldMappingType
The field mapping type to get the field names for.

Return Value

A read-only list of field names.

See Also

FieldMapper Class
Mincom.LinkOne.Dom.SelectionList Namespace


IFieldMapper.MapPart Method

[image]

LinkOne WebView API
FieldMapper..::.IFieldMapper..::.MapPart Method
FieldMapper Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPart IFieldMapper.MapPart(
    IEntry entry,
    IPicture picture,
    bool isQuantityFitted
)
Visual Basic (Declaration)
Private Function MapPart ( _
    entry As IEntry, _
    picture As IPicture, _
    isQuantityFitted As Boolean _
) As IPart Implements IFieldMapper.MapPart
Visual C++
private:
virtual IPart^ MapPart(
    IEntry^ entry,
    IPicture^ picture,
    bool isQuantityFitted
) sealed = IFieldMapper::MapPart

Parameters

entry
Type: Mincom.LinkOne.Dom..::.IEntry
picture
Type: Mincom.LinkOne.Dom..::.IPicture
isQuantityFitted
Type: System..::.Boolean

Implements

IFieldMapper..::.MapPart(IEntry, IPicture, Boolean)

See Also

FieldMapper Class
Mincom.LinkOne.Dom.SelectionList Namespace


Initialize Method

[image]

LinkOne WebView API
FieldMapper..::.Initialize Method
FieldMapper Class See Also Send Feedback
Initializes the FieldMapper instance with the new field mapping of the specified note collection.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Initialize(
    NoteCollection notes
)
Visual Basic (Declaration)
Public Sub Initialize ( _
    notes As NoteCollection _
)
Visual C++
public:
void Initialize(
    NoteCollection^ notes
)

Parameters

notes
Type: Mincom.LinkOne.Dom.Notes..::.NoteCollection
The note collection to use during the reset.

Remarks

The note collection may contain all types of note, including Field Mapping notes.

See Also

FieldMapper Class
Mincom.LinkOne.Dom.SelectionList Namespace


MapPart Method

[image]

LinkOne WebView API
FieldMapper..::.MapPart Method
FieldMapper Class See Also Send Feedback
Creates a mapped part from a book view.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public virtual IPart MapPart(
    Entry entry,
    Picture picture,
    bool isQuantityFitted
)
Visual Basic (Declaration)
Public Overridable Function MapPart ( _
    entry As Entry, _
    picture As Picture, _
    isQuantityFitted As Boolean _
) As IPart
Visual C++
public:
virtual IPart^ MapPart(
    Entry^ entry,
    Picture^ picture,
    bool isQuantityFitted
)

Parameters

entry
Type: Mincom.LinkOne.Dom..::.Entry
The entry to be mapped.
picture
Type: Mincom.LinkOne.Dom..::.Picture
The picture to be mapped.
isQuantityFitted
Type: System..::.Boolean
The boolean value that determines how the requested quantity is set in the selection list.

Return Value

A mapped part.

See Also

FieldMapper Class
Mincom.LinkOne.Dom.SelectionList Namespace


RemoveFieldMapping Method

[image]

LinkOne WebView API
FieldMapper..::.RemoveFieldMapping Method
FieldMapper Class See Also Send Feedback
Removes a FieldMapping object.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void RemoveFieldMapping(
    FieldMapping fieldMapping
)
Visual Basic (Declaration)
Public Sub RemoveFieldMapping ( _
    fieldMapping As FieldMapping _
)
Visual C++
public:
void RemoveFieldMapping(
    FieldMapping^ fieldMapping
)

Parameters

fieldMapping
Type: Mincom.LinkOne.Dom.Notes..::.FieldMapping
The FieldMapping object to remove.

Remarks

Throws an ArgumentOutOfRangeException if attempting to remove a predefined field mapping.

See Also

FieldMapper Class
Mincom.LinkOne.Dom.SelectionList Namespace


FieldMapper Properties

[image] [image]

LinkOne WebView API
FieldMapper Properties
FieldMapper Class See Also Send Feedback

The FieldMapper type exposes the following members.

Properties

Name | Description
Columns | Gets the collection of columns that the field mappings relate to.
FieldMappings | Gets an array of FieldMapping notes.
HasChanged | Gets true if the field mappings have changed.

Explicit Interface Implementations

Name | Description
IFieldMapper..::.FieldMappings |

See Also

FieldMapper Class
Mincom.LinkOne.Dom.SelectionList Namespace


Columns Property

[image]

LinkOne WebView API
FieldMapper..::.Columns Property
FieldMapper Class See Also Send Feedback
Gets the collection of columns that the field mappings relate to.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ColumnCollection Columns { get; }
Visual Basic (Declaration)
Public ReadOnly Property Columns As ColumnCollection
Visual C++
public:
property ColumnCollection^ Columns {
    ColumnCollection^ get ();
}

See Also

FieldMapper Class
Mincom.LinkOne.Dom.SelectionList Namespace


FieldMappings Property

[image]

LinkOne WebView API
FieldMapper..::.FieldMappings Property
FieldMapper Class See Also Send Feedback
Gets an array of FieldMapping notes.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public FieldMapping[] FieldMappings { get; }
Visual Basic (Declaration)
Public ReadOnly Property FieldMappings As FieldMapping()
Visual C++
public:
property array<FieldMapping^>^ FieldMappings {
    array<FieldMapping^>^ get ();
}

Remarks

The array of FieldMapping note objects being returned, is all the FieldMapping notes for all the columns, and is based on the current language. It does not include FieldMapping's for other languages.

See Also

FieldMapper Class
Mincom.LinkOne.Dom.SelectionList Namespace


HasChanged Property

[image]

LinkOne WebView API
FieldMapper..::.HasChanged Property
FieldMapper Class See Also Send Feedback
Gets true if the field mappings have changed.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool HasChanged { get; protected set; }
Visual Basic (Declaration)
Public Property HasChanged As Boolean
Visual C++
public:
property bool HasChanged {
    bool get ();
    void set (bool value);
}

See Also

FieldMapper Class
Mincom.LinkOne.Dom.SelectionList Namespace


IFieldMapper.FieldMappings Property

[image]

LinkOne WebView API
FieldMapper..::.IFieldMapper..::.FieldMappings Property
FieldMapper Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IList<IFieldMapping> IFieldMapper.FieldMappings { get; }
Visual Basic (Declaration)
Private ReadOnly Property FieldMappings As IList(Of IFieldMapping)
    Implements IFieldMapper.FieldMappings
Visual C++
private:
virtual property IList<IFieldMapping^>^ FieldMappings {
    IList<IFieldMapping^>^ get () sealed = IFieldMapper::FieldMappings::get;
}

Implements

IFieldMapper..::.FieldMappings

See Also

FieldMapper Class
Mincom.LinkOne.Dom.SelectionList Namespace


FieldMappingDetail Class

[image]

LinkOne WebView API
FieldMappingDetail Class
Members See Also Send Feedback
Contains detail information about a field mapping..

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class FieldMappingDetail
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class FieldMappingDetail
Visual C++
[SerializableAttribute]
public ref class FieldMappingDetail sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.SelectionList..::.FieldMappingDetail

See Also

FieldMappingDetail Members
Mincom.LinkOne.Dom.SelectionList Namespace


FieldMappingDetail Members

[image] [image]

LinkOne WebView API
FieldMappingDetail Members
FieldMappingDetail Class Constructors Methods Properties See Also Send Feedback

The FieldMappingDetail type exposes the following members.

Constructors

Name | Description
FieldMappingDetail | Constructor.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Column | Gets the column.
MapDetailType | Gets the map detail type.
MappedFromName | Gets the mapped from name.
MappedFromType | Gets the mapped from type.
RelatedMappings | Gets a read-only list of mappings which are used to resolve the mapping.

See Also

FieldMappingDetail Class
Mincom.LinkOne.Dom.SelectionList Namespace


FieldMappingDetail Constructor

[image]

LinkOne WebView API
FieldMappingDetail Constructor
FieldMappingDetail Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public FieldMappingDetail(
    Column column,
    FieldMapDetailType mapDetailType,
    FieldMappingType mappedFromType,
    string mappedFromName,
    List<FieldMapping> relatedMappings
)
Visual Basic (Declaration)
Public Sub New ( _
    column As Column, _
    mapDetailType As FieldMapDetailType, _
    mappedFromType As FieldMappingType, _
    mappedFromName As String, _
    relatedMappings As List(Of FieldMapping) _
)
Visual C++
public:
FieldMappingDetail(
    Column^ column,
    FieldMapDetailType mapDetailType,
    FieldMappingType mappedFromType,
    String^ mappedFromName,
    List<FieldMapping^>^ relatedMappings
)

Parameters

column
Type: Mincom.LinkOne.Dom.SelectionList..::.Column
The column assocated with the field mapping detail.
mapDetailType
Type: Mincom.LinkOne.Dom.SelectionList..::.FieldMapDetailType
The field mapping detail type.
mappedFromType
Type: Mincom.LinkOne.Dom.Notes..::.FieldMappingType
The mapped from type of the field mapping.
mappedFromName
Type: System..::.String
The mapped from name of the field mapping.
relatedMappings
Type: System.Collections.Generic..::.List<(Of <( FieldMapping >)>)
The list of related field mappings.

See Also

FieldMappingDetail Class
Mincom.LinkOne.Dom.SelectionList Namespace


FieldMappingDetail Methods

[image] [image]

LinkOne WebView API
FieldMappingDetail Methods
FieldMappingDetail Class See Also Send Feedback

The FieldMappingDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FieldMappingDetail Class
Mincom.LinkOne.Dom.SelectionList Namespace


FieldMappingDetail Properties

[image] [image]

LinkOne WebView API
FieldMappingDetail Properties
FieldMappingDetail Class See Also Send Feedback

The FieldMappingDetail type exposes the following members.

Properties

Name | Description
Column | Gets the column.
MapDetailType | Gets the map detail type.
MappedFromName | Gets the mapped from name.
MappedFromType | Gets the mapped from type.
RelatedMappings | Gets a read-only list of mappings which are used to resolve the mapping.

See Also

FieldMappingDetail Class
Mincom.LinkOne.Dom.SelectionList Namespace


Column Property

[image]

LinkOne WebView API
FieldMappingDetail..::.Column Property
FieldMappingDetail Class See Also Send Feedback
Gets the column.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Column Column { get; }
Visual Basic (Declaration)
Public ReadOnly Property Column As Column
Visual C++
public:
property Column^ Column {
    Column^ get ();
}

See Also

FieldMappingDetail Class
Mincom.LinkOne.Dom.SelectionList Namespace


MapDetailType Property

[image]

LinkOne WebView API
FieldMappingDetail..::.MapDetailType Property
FieldMappingDetail Class See Also Send Feedback
Gets the map detail type.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public FieldMapDetailType MapDetailType { get; }
Visual Basic (Declaration)
Public ReadOnly Property MapDetailType As FieldMapDetailType
Visual C++
public:
property FieldMapDetailType MapDetailType {
    FieldMapDetailType get ();
}

See Also

FieldMappingDetail Class
Mincom.LinkOne.Dom.SelectionList Namespace


MappedFromName Property

[image]

LinkOne WebView API
FieldMappingDetail..::.MappedFromName Property
FieldMappingDetail Class See Also Send Feedback
Gets the mapped from name.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string MappedFromName { get; }
Visual Basic (Declaration)
Public ReadOnly Property MappedFromName As String
Visual C++
public:
property String^ MappedFromName {
    String^ get ();
}

See Also

FieldMappingDetail Class
Mincom.LinkOne.Dom.SelectionList Namespace


MappedFromType Property

[image]

LinkOne WebView API
FieldMappingDetail..::.MappedFromType Property
FieldMappingDetail Class See Also Send Feedback
Gets the mapped from type.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public FieldMappingType MappedFromType { get; }
Visual Basic (Declaration)
Public ReadOnly Property MappedFromType As FieldMappingType
Visual C++
public:
property FieldMappingType MappedFromType {
    FieldMappingType get ();
}

See Also

FieldMappingDetail Class
Mincom.LinkOne.Dom.SelectionList Namespace


RelatedMappings Property

[image]

LinkOne WebView API
FieldMappingDetail..::.RelatedMappings Property
FieldMappingDetail Class See Also Send Feedback
Gets a read-only list of mappings which are used to resolve the mapping.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IList<FieldMapping> RelatedMappings { get; }
Visual Basic (Declaration)
Public ReadOnly Property RelatedMappings As IList(Of FieldMapping)
Visual C++
public:
property IList<FieldMapping^>^ RelatedMappings {
    IList<FieldMapping^>^ get ();
}

See Also

FieldMappingDetail Class
Mincom.LinkOne.Dom.SelectionList Namespace


IColumn Interface

[image]

LinkOne WebView API
IColumn Interface
Members See Also Send Feedback
Represents a column in a LinkOne selection list.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IColumn : INotifyChanged
Visual Basic (Declaration)
Public Interface IColumn _
    Implements INotifyChanged
Visual C++
public interface class IColumn : INotifyChanged

See Also

IColumn Members
Mincom.LinkOne.Dom.SelectionList Namespace


IColumn Members

[image] [image]

LinkOne WebView API
IColumn Members
IColumn Interface Properties Events See Also Send Feedback

The IColumn type exposes the following members.

Properties

Name | Description
Description | Gets the description of the column.
ExportTag | Gets the ExportTag name of the column.
IgnoreBracketedText | Gets the ignore bracketed text flag of the column.
IsCriteria | Gets the criteria flag of the column.
IsDescription | Gets the description flag of the column.
IsEditable | Gets a value indicating whether the fields in the column can be edited.
IsHidden | Gets true if the column is hidden.
IsOptions | Gets the options flag of the column.
IsRequestedQuantity | Gets the requested quantity flag of the column.
Name | Gets the name of the column.
NewLineProcessing | Gets the type of new line processing for this field.

Events

Name | Description
Changed | Occurs when a property value changes. (Inherited from INotifyChanged.)

See Also

IColumn Interface
Mincom.LinkOne.Dom.SelectionList Namespace


IColumn Properties

[image] [image]

LinkOne WebView API
IColumn Properties
IColumn Interface See Also Send Feedback

The IColumn type exposes the following members.

Properties

Name | Description
Description | Gets the description of the column.
ExportTag | Gets the ExportTag name of the column.
IgnoreBracketedText | Gets the ignore bracketed text flag of the column.
IsCriteria | Gets the criteria flag of the column.
IsDescription | Gets the description flag of the column.
IsEditable | Gets a value indicating whether the fields in the column can be edited.
IsHidden | Gets true if the column is hidden.
IsOptions | Gets the options flag of the column.
IsRequestedQuantity | Gets the requested quantity flag of the column.
Name | Gets the name of the column.
NewLineProcessing | Gets the type of new line processing for this field.

See Also

IColumn Interface
Mincom.LinkOne.Dom.SelectionList Namespace


Description Property

[image]

LinkOne WebView API
IColumn..::.Description Property
IColumn Interface See Also Send Feedback
Gets the description of the column.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Description { get; }
Visual Basic (Declaration)
ReadOnly Property Description As String
Visual C++
property String^ Description {
    String^ get ();
}

See Also

IColumn Interface
Mincom.LinkOne.Dom.SelectionList Namespace


ExportTag Property

[image]

LinkOne WebView API
IColumn..::.ExportTag Property
IColumn Interface See Also Send Feedback
Gets the ExportTag name of the column.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string ExportTag { get; }
Visual Basic (Declaration)
ReadOnly Property ExportTag As String
Visual C++
property String^ ExportTag {
    String^ get ();
}

Remarks

The export tag is used when the selection list is exported in a tagged format. If not specified, field name is used as the export tag.

See Also

IColumn Interface
Mincom.LinkOne.Dom.SelectionList Namespace


IgnoreBracketedText Property

[image]

LinkOne WebView API
IColumn..::.IgnoreBracketedText Property
IColumn Interface See Also Send Feedback
Gets the ignore bracketed text flag of the column.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IgnoreBracketedText { get; }
Visual Basic (Declaration)
ReadOnly Property IgnoreBracketedText As Boolean
Visual C++
property bool IgnoreBracketedText {
    bool get ();
}

Remarks

When true, any text which is enclosed by brackets () will be removed when the text is added to the selection list field.

See Also

IColumn Interface
Mincom.LinkOne.Dom.SelectionList Namespace


IsCriteria Property

[image]

LinkOne WebView API
IColumn..::.IsCriteria Property
IColumn Interface See Also Send Feedback
Gets the criteria flag of the column.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IsCriteria { get; }
Visual Basic (Declaration)
ReadOnly Property IsCriteria As Boolean
Visual C++
property bool IsCriteria {
    bool get ();
}

Remarks

This identifies the field as being one of the fields that determines if a parts list entry may be selected. If, when a parts list entry is added to the Selection List, any of the fields marked as Criteria would contain some data, then the parts list entry is considered selectable and will have a check box displayed next to it.

See Also

IColumn Interface
Mincom.LinkOne.Dom.SelectionList Namespace


IsDescription Property

[image]

LinkOne WebView API
IColumn..::.IsDescription Property
IColumn Interface See Also Send Feedback
Gets the description flag of the column.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IsDescription { get; }
Visual Basic (Declaration)
ReadOnly Property IsDescription As Boolean
Visual C++
property bool IsDescription {
    bool get ();
}

Remarks

The description state indicates if the column data will hold the description.

See Also

IColumn Interface
Mincom.LinkOne.Dom.SelectionList Namespace


IsEditable Property

[image]

LinkOne WebView API
IColumn..::.IsEditable Property
IColumn Interface See Also Send Feedback
Gets a value indicating whether the fields in the column can be edited.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IsEditable { get; }
Visual Basic (Declaration)
ReadOnly Property IsEditable As Boolean
Visual C++
property bool IsEditable {
    bool get ();
}

See Also

IColumn Interface
Mincom.LinkOne.Dom.SelectionList Namespace


IsHidden Property

[image]

LinkOne WebView API
IColumn..::.IsHidden Property
IColumn Interface See Also Send Feedback
Gets true if the column is hidden.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IsHidden { get; }
Visual Basic (Declaration)
ReadOnly Property IsHidden As Boolean
Visual C++
property bool IsHidden {
    bool get ();
}

See Also

IColumn Interface
Mincom.LinkOne.Dom.SelectionList Namespace


IsOptions Property

[image]

LinkOne WebView API
IColumn..::.IsOptions Property
IColumn Interface See Also Send Feedback
Gets the options flag of the column.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IsOptions { get; }
Visual Basic (Declaration)
ReadOnly Property IsOptions As Boolean
Visual C++
property bool IsOptions {
    bool get ();
}

Remarks

When true, indicates that the field contains the Option Codes that will be used when determining the filtering of this selection list entry. Only one SelectionListFieldDefinition within a SelectionListFieldDefinitionCollection, can be marked as an options field. Setting this property to true in a column within a column collection, sets all other columns in the column collection to false.

See Also

IColumn Interface
Mincom.LinkOne.Dom.SelectionList Namespace


IsRequestedQuantity Property

[image]

LinkOne WebView API
IColumn..::.IsRequestedQuantity Property
IColumn Interface See Also Send Feedback
Gets the requested quantity flag of the column.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IsRequestedQuantity { get; }
Visual Basic (Declaration)
ReadOnly Property IsRequestedQuantity As Boolean
Visual C++
property bool IsRequestedQuantity {
    bool get ();
}

Remarks

The requested quantity state indicates if the column data will hold the requested quantity.

See Also

IColumn Interface
Mincom.LinkOne.Dom.SelectionList Namespace


Name Property

[image]

LinkOne WebView API
IColumn..::.Name Property
IColumn Interface See Also Send Feedback
Gets the name of the column.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IColumn Interface
Mincom.LinkOne.Dom.SelectionList Namespace


NewLineProcessing Property

[image]

LinkOne WebView API
IColumn..::.NewLineProcessing Property
IColumn Interface See Also Send Feedback
Gets the type of new line processing for this field.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
NewLineProcessing NewLineProcessing { get; }
Visual Basic (Declaration)
ReadOnly Property NewLineProcessing As NewLineProcessing
Visual C++
property NewLineProcessing NewLineProcessing {
    NewLineProcessing get ();
}

Remarks

The newline processing option determines how newline characters are treated when data is mapped into the selection list.

See Also

IColumn Interface
Mincom.LinkOne.Dom.SelectionList Namespace


IColumn Events

[image] [image]

LinkOne WebView API
IColumn Events
IColumn Interface See Also Send Feedback

The IColumn type exposes the following members.

Events

Name | Description
Changed | Occurs when a property value changes. (Inherited from INotifyChanged.)

See Also

IColumn Interface
Mincom.LinkOne.Dom.SelectionList Namespace


IColumnCollection Interface

[image]

LinkOne WebView API
IColumnCollection Interface
Members See Also Send Feedback
Represents the columns in a LinkOne selection list.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IColumnCollection : IKeyedCollection<string, IColumn>,
    ICollection<IColumn>, IEnumerable<IColumn>, IEnumerable
Visual Basic (Declaration)
Public Interface IColumnCollection _
    Implements IKeyedCollection(Of String, IColumn),  _
    ICollection(Of IColumn), IEnumerable(Of IColumn), IEnumerable
Visual C++
public interface class IColumnCollection : IKeyedCollection<String^, IColumn^>,
    ICollection<IColumn^>, IEnumerable<IColumn^>, IEnumerable

See Also

IColumnCollection Members
Mincom.LinkOne.Dom.SelectionList Namespace


IColumnCollection Members

[image] [image]

LinkOne WebView API
IColumnCollection Members
IColumnCollection Interface Methods Properties See Also Send Feedback

The IColumnCollection type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IColumn >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IColumn >)>).)
Contains | Overloaded.
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( IColumn >)>).)
Create | Creates a new column object.
GetEnumerator | Overloaded.
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IColumn >)>).)

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IColumn >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( IColumn >)>).)
Item | Gets or sets the item with the specified key. (Inherited from IKeyedCollection<(Of <(TKey, TItem>)>).)

See Also

IColumnCollection Interface
Mincom.LinkOne.Dom.SelectionList Namespace


IColumnCollection Methods

[image] [image]

LinkOne WebView API
IColumnCollection Methods
IColumnCollection Interface See Also Send Feedback

The IColumnCollection type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IColumn >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IColumn >)>).)
Contains | Overloaded.
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( IColumn >)>).)
Create | Creates a new column object.
GetEnumerator | Overloaded.
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IColumn >)>).)

See Also

IColumnCollection Interface
Mincom.LinkOne.Dom.SelectionList Namespace


Contains Method

[image] [image]

LinkOne WebView API
IColumnCollection..::.Contains Method
IColumnCollection Interface See Also Send Feedback

Overload List

Name | Description
Contains(TKey) | Determines whether an element with the given key is in the collection. (Inherited from IKeyedCollection<(Of <(TKey, TItem>)>).)
Contains(T) | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from ICollection<(Of <( IColumn >)>).)

See Also

IColumnCollection Interface
IColumnCollection Members
Mincom.LinkOne.Dom.SelectionList Namespace


Create Method

[image]

LinkOne WebView API
IColumnCollection..::.Create Method
IColumnCollection Interface See Also Send Feedback
Creates a new column object.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IColumn Create(
    string name
)
Visual Basic (Declaration)
Function Create ( _
    name As String _
) As IColumn
Visual C++
IColumn^ Create(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the column.

Return Value

A new IColumn.

See Also

IColumnCollection Interface
Mincom.LinkOne.Dom.SelectionList Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
IColumnCollection..::.GetEnumerator Method
IColumnCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( IColumn >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IColumnCollection Interface
IColumnCollection Members
Mincom.LinkOne.Dom.SelectionList Namespace


IColumnCollection Properties

[image] [image]

LinkOne WebView API
IColumnCollection Properties
IColumnCollection Interface See Also Send Feedback

The IColumnCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IColumn >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( IColumn >)>).)
Item | Gets or sets the item with the specified key. (Inherited from IKeyedCollection<(Of <(TKey, TItem>)>).)

See Also

IColumnCollection Interface
Mincom.LinkOne.Dom.SelectionList Namespace


IField Interface

[image]

LinkOne WebView API
IField Interface
Members See Also Send Feedback
Represents a field in a column for LinkOne selection list.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IField : INotifyChanged
Visual Basic (Declaration)
Public Interface IField _
    Implements INotifyChanged
Visual C++
public interface class IField : INotifyChanged

See Also

IField Members
Mincom.LinkOne.Dom.SelectionList Namespace


IField Members

[image] [image]

LinkOne WebView API
IField Members
IField Interface Properties Events See Also Send Feedback

The IField type exposes the following members.

Properties

Name | Description
ColumnName | Gets the name of the column.
Value | Gets or sets the value of the field.

Events

Name | Description
Changed | Occurs when a property value changes. (Inherited from INotifyChanged.)

See Also

IField Interface
Mincom.LinkOne.Dom.SelectionList Namespace


IField Properties

[image] [image]

LinkOne WebView API
IField Properties
IField Interface See Also Send Feedback

The IField type exposes the following members.

Properties

Name | Description
ColumnName | Gets the name of the column.
Value | Gets or sets the value of the field.

See Also

IField Interface
Mincom.LinkOne.Dom.SelectionList Namespace


ColumnName Property

[image]

LinkOne WebView API
IField..::.ColumnName Property
IField Interface See Also Send Feedback
Gets the name of the column.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string ColumnName { get; }
Visual Basic (Declaration)
ReadOnly Property ColumnName As String
Visual C++
property String^ ColumnName {
    String^ get ();
}

See Also

IField Interface
Mincom.LinkOne.Dom.SelectionList Namespace


Value Property

[image]

LinkOne WebView API
IField..::.Value Property
IField Interface See Also Send Feedback
Gets or sets the value of the field.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Value { get; set; }
Visual Basic (Declaration)
Property Value As String
Visual C++
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

IField Interface
Mincom.LinkOne.Dom.SelectionList Namespace


IField Events

[image] [image]

LinkOne WebView API
IField Events
IField Interface See Also Send Feedback

The IField type exposes the following members.

Events

Name | Description
Changed | Occurs when a property value changes. (Inherited from INotifyChanged.)

See Also

IField Interface
Mincom.LinkOne.Dom.SelectionList Namespace


IFieldCollection Interface

[image]

LinkOne WebView API
IFieldCollection Interface
Members See Also Send Feedback
Represents the fields for a column in a LinkOne selection list.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IFieldCollection : IKeyedCollection<string, IField>,
    ICollection<IField>, IEnumerable<IField>, IEnumerable
Visual Basic (Declaration)
Public Interface IFieldCollection _
    Implements IKeyedCollection(Of String, IField),  _
    ICollection(Of IField), IEnumerable(Of IField), IEnumerable
Visual C++
public interface class IFieldCollection : IKeyedCollection<String^, IField^>,
    ICollection<IField^>, IEnumerable<IField^>, IEnumerable

See Also

IFieldCollection Members
Mincom.LinkOne.Dom.SelectionList Namespace


IFieldCollection Members

[image] [image]

LinkOne WebView API
IFieldCollection Members
IFieldCollection Interface Methods Properties See Also Send Feedback

The IFieldCollection type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IField >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IField >)>).)
Contains | Overloaded.
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( IField >)>).)
GetEnumerator | Overloaded.
GetFieldText | Gets the value of the field.
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IField >)>).)

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IField >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( IField >)>).)
Item | Gets or sets the item with the specified key. (Inherited from IKeyedCollection<(Of <(TKey, TItem>)>).)

See Also

IFieldCollection Interface
Mincom.LinkOne.Dom.SelectionList Namespace


IFieldCollection Methods

[image] [image]

LinkOne WebView API
IFieldCollection Methods
IFieldCollection Interface See Also Send Feedback

The IFieldCollection type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IField >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IField >)>).)
Contains | Overloaded.
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( IField >)>).)
GetEnumerator | Overloaded.
GetFieldText | Gets the value of the field.
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IField >)>).)

See Also

IFieldCollection Interface
Mincom.LinkOne.Dom.SelectionList Namespace


Contains Method

[image] [image]

LinkOne WebView API
IFieldCollection..::.Contains Method
IFieldCollection Interface See Also Send Feedback

Overload List

Name | Description
Contains(TKey) | Determines whether an element with the given key is in the collection. (Inherited from IKeyedCollection<(Of <(TKey, TItem>)>).)
Contains(T) | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from ICollection<(Of <( IField >)>).)

See Also

IFieldCollection Interface
IFieldCollection Members
Mincom.LinkOne.Dom.SelectionList Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
IFieldCollection..::.GetEnumerator Method
IFieldCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( IField >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IFieldCollection Interface
IFieldCollection Members
Mincom.LinkOne.Dom.SelectionList Namespace


GetFieldText Method

[image]

LinkOne WebView API
IFieldCollection..::.GetFieldText Method
IFieldCollection Interface See Also Send Feedback
Gets the value of the field.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string GetFieldText(
    string name
)
Visual Basic (Declaration)
Function GetFieldText ( _
    name As String _
) As String
Visual C++
String^ GetFieldText(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the field.

Return Value

The value of the wanted field; otherwise, the default value for the field.

See Also

IFieldCollection Interface
Mincom.LinkOne.Dom.SelectionList Namespace


IFieldCollection Properties

[image] [image]

LinkOne WebView API
IFieldCollection Properties
IFieldCollection Interface See Also Send Feedback

The IFieldCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IField >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( IField >)>).)
Item | Gets or sets the item with the specified key. (Inherited from IKeyedCollection<(Of <(TKey, TItem>)>).)

See Also

IFieldCollection Interface
Mincom.LinkOne.Dom.SelectionList Namespace


IFieldMapper Interface

[image]

LinkOne WebView API
IFieldMapper Interface
Members See Also Send Feedback
Provides field mapping information for a LinkOne selection list.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IFieldMapper
Visual Basic (Declaration)
Public Interface IFieldMapper
Visual C++
public interface class IFieldMapper

See Also

IFieldMapper Members
Mincom.LinkOne.Dom.SelectionList Namespace


IFieldMapper Members

[image] [image]

LinkOne WebView API
IFieldMapper Members
IFieldMapper Interface Methods Properties See Also Send Feedback

The IFieldMapper type exposes the following members.

Methods

Name | Description
MapPart | Creates a mapped part from a book view.

Properties

Name | Description
FieldMappings | Gets a readonly collection of all field mapping notes.

See Also

IFieldMapper Interface
Mincom.LinkOne.Dom.SelectionList Namespace


IFieldMapper Methods

[image] [image]

LinkOne WebView API
IFieldMapper Methods
IFieldMapper Interface See Also Send Feedback

The IFieldMapper type exposes the following members.

Methods

Name | Description
MapPart | Creates a mapped part from a book view.

See Also

IFieldMapper Interface
Mincom.LinkOne.Dom.SelectionList Namespace


MapPart Method

[image]

LinkOne WebView API
IFieldMapper..::.MapPart Method
IFieldMapper Interface See Also Send Feedback
Creates a mapped part from a book view.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPart MapPart(
    IEntry entry,
    IPicture picture,
    bool isQuantityFitted
)
Visual Basic (Declaration)
Function MapPart ( _
    entry As IEntry, _
    picture As IPicture, _
    isQuantityFitted As Boolean _
) As IPart
Visual C++
IPart^ MapPart(
    IEntry^ entry,
    IPicture^ picture,
    bool isQuantityFitted
)

Parameters

entry
Type: Mincom.LinkOne.Dom..::.IEntry
The entry to be mapped.
picture
Type: Mincom.LinkOne.Dom..::.IPicture
The picture to be mapped.
isQuantityFitted
Type: System..::.Boolean
The boolean value that determines how the requested quantity is set in the selection list.

Return Value

A mapped part.

See Also

IFieldMapper Interface
Mincom.LinkOne.Dom.SelectionList Namespace


IFieldMapper Properties

[image] [image]

LinkOne WebView API
IFieldMapper Properties
IFieldMapper Interface See Also Send Feedback

The IFieldMapper type exposes the following members.

Properties

Name | Description
FieldMappings | Gets a readonly collection of all field mapping notes.

See Also

IFieldMapper Interface
Mincom.LinkOne.Dom.SelectionList Namespace


FieldMappings Property

[image]

LinkOne WebView API
IFieldMapper..::.FieldMappings Property
IFieldMapper Interface See Also Send Feedback
Gets a readonly collection of all field mapping notes.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IList<IFieldMapping> FieldMappings { get; }
Visual Basic (Declaration)
ReadOnly Property FieldMappings As IList(Of IFieldMapping)
Visual C++
property IList<IFieldMapping^>^ FieldMappings {
    IList<IFieldMapping^>^ get ();
}

Return Value

A collection of field mapping notes that represents all field mapping notes for all columns based on the current language.

See Also

IFieldMapper Interface
Mincom.LinkOne.Dom.SelectionList Namespace


IPart Interface

[image]

LinkOne WebView API
IPart Interface
Members See Also Send Feedback
Defines the publisher code, book code, page reference, item tag and set of fields for a part that has been added to the LinkOne selection list.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IPart : INotifyChanged
Visual Basic (Declaration)
Public Interface IPart _
    Implements INotifyChanged
Visual C++
public interface class IPart : INotifyChanged

See Also

IPart Members
Mincom.LinkOne.Dom.SelectionList Namespace


IPart Members

[image] [image]

LinkOne WebView API
IPart Members
IPart Interface Properties Events See Also Send Feedback

The IPart type exposes the following members.

Properties

Name | Description
BaseBookCode | Gets the base book code if the part was added from a derived book.
BookCode | Gets the book code for the book that contained the part.
CheckCode | Gets the check code used to verify the identification of entries.
Fields | Gets the collection of fields that are associated with the part.
GotoItemId | Gets the GotoItemId value for this part.
IsBookPart | Gets true if the part is a part in a book
IsUserPart | Gets true if the part is a user added part.
ItemId | Gets the item Id for the parts list entry that contained the part.
ItemIndex | Gets the item index value for this part.
PageRef | Gets the page reference for the page that contained the part.
PictureIndex | Gets the picture index of the picture showing when the part was added.
PublisherCode | Gets the publisher code for the book that contained the part.
SpecificObject | Gets the specific object value for this part.

Events

Name | Description
Changed | Occurs when a property value changes. (Inherited from INotifyChanged.)

See Also

IPart Interface
Mincom.LinkOne.Dom.SelectionList Namespace


IPart Properties

[image] [image]

LinkOne WebView API
IPart Properties
IPart Interface See Also Send Feedback

The IPart type exposes the following members.

Properties

Name | Description
BaseBookCode | Gets the base book code if the part was added from a derived book.
BookCode | Gets the book code for the book that contained the part.
CheckCode | Gets the check code used to verify the identification of entries.
Fields | Gets the collection of fields that are associated with the part.
GotoItemId | Gets the GotoItemId value for this part.
IsBookPart | Gets true if the part is a part in a book
IsUserPart | Gets true if the part is a user added part.
ItemId | Gets the item Id for the parts list entry that contained the part.
ItemIndex | Gets the item index value for this part.
PageRef | Gets the page reference for the page that contained the part.
PictureIndex | Gets the picture index of the picture showing when the part was added.
PublisherCode | Gets the publisher code for the book that contained the part.
SpecificObject | Gets the specific object value for this part.

See Also

IPart Interface
Mincom.LinkOne.Dom.SelectionList Namespace


BaseBookCode Property

[image]

LinkOne WebView API
IPart..::.BaseBookCode Property
IPart Interface See Also Send Feedback
Gets the base book code if the part was added from a derived book.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string BaseBookCode { get; }
Visual Basic (Declaration)
ReadOnly Property BaseBookCode As String
Visual C++
property String^ BaseBookCode {
    String^ get ();
}

See Also

IPart Interface
Mincom.LinkOne.Dom.SelectionList Namespace


BookCode Property

[image]

LinkOne WebView API
IPart..::.BookCode Property
IPart Interface See Also Send Feedback
Gets the book code for the book that contained the part.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string BookCode { get; }
Visual Basic (Declaration)
ReadOnly Property BookCode As String
Visual C++
property String^ BookCode {
    String^ get ();
}

See Also

IPart Interface
Mincom.LinkOne.Dom.SelectionList Namespace


CheckCode Property

[image]

LinkOne WebView API
IPart..::.CheckCode Property
IPart Interface See Also Send Feedback
Gets the check code used to verify the identification of entries.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string CheckCode { get; }
Visual Basic (Declaration)
ReadOnly Property CheckCode As String
Visual C++
property String^ CheckCode {
    String^ get ();
}

See Also

IPart Interface
Mincom.LinkOne.Dom.SelectionList Namespace


Fields Property

[image]

LinkOne WebView API
IPart..::.Fields Property
IPart Interface See Also Send Feedback
Gets the collection of fields that are associated with the part.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IFieldCollection Fields { get; }
Visual Basic (Declaration)
ReadOnly Property Fields As IFieldCollection
Visual C++
property IFieldCollection^ Fields {
    IFieldCollection^ get ();
}

See Also

IPart Interface
Mincom.LinkOne.Dom.SelectionList Namespace


GotoItemId Property

[image]

LinkOne WebView API
IPart..::.GotoItemId Property
IPart Interface See Also Send Feedback
Gets the GotoItemId value for this part.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string GotoItemId { get; }
Visual Basic (Declaration)
ReadOnly Property GotoItemId As String
Visual C++
property String^ GotoItemId {
    String^ get ();
}

See Also

IPart Interface
Mincom.LinkOne.Dom.SelectionList Namespace


IsBookPart Property

[image]

LinkOne WebView API
IPart..::.IsBookPart Property
IPart Interface See Also Send Feedback
Gets true if the part is a part in a book

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IsBookPart { get; }
Visual Basic (Declaration)
ReadOnly Property IsBookPart As Boolean
Visual C++
property bool IsBookPart {
    bool get ();
}

Remarks

A book part is one where the publisher code, book code, or page reference are specified.

See Also

IPart Interface
Mincom.LinkOne.Dom.SelectionList Namespace


IsUserPart Property

[image]

LinkOne WebView API
IPart..::.IsUserPart Property
IPart Interface See Also Send Feedback
Gets true if the part is a user added part.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool IsUserPart { get; }
Visual Basic (Declaration)
ReadOnly Property IsUserPart As Boolean
Visual C++
property bool IsUserPart {
    bool get ();
}

Remarks

A user part is one where there is no publisher code.

See Also

IPart Interface
Mincom.LinkOne.Dom.SelectionList Namespace


ItemId Property

[image]

LinkOne WebView API
IPart..::.ItemId Property
IPart Interface See Also Send Feedback
Gets the item Id for the parts list entry that contained the part.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string ItemId { get; }
Visual Basic (Declaration)
ReadOnly Property ItemId As String
Visual C++
property String^ ItemId {
    String^ get ();
}

See Also

IPart Interface
Mincom.LinkOne.Dom.SelectionList Namespace


ItemIndex Property

[image]

LinkOne WebView API
IPart..::.ItemIndex Property
IPart Interface See Also Send Feedback
Gets the item index value for this part.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int ItemIndex { get; }
Visual Basic (Declaration)
ReadOnly Property ItemIndex As Integer
Visual C++
property int ItemIndex {
    int get ();
}

See Also

IPart Interface
Mincom.LinkOne.Dom.SelectionList Namespace


PageRef Property

[image]

LinkOne WebView API
IPart..::.PageRef Property
IPart Interface See Also Send Feedback
Gets the page reference for the page that contained the part.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string PageRef { get; }
Visual Basic (Declaration)
ReadOnly Property PageRef As String
Visual C++
property String^ PageRef {
    String^ get ();
}

See Also

IPart Interface
Mincom.LinkOne.Dom.SelectionList Namespace


PictureIndex Property

[image]

LinkOne WebView API
IPart..::.PictureIndex Property
IPart Interface See Also Send Feedback
Gets the picture index of the picture showing when the part was added.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int PictureIndex { get; }
Visual Basic (Declaration)
ReadOnly Property PictureIndex As Integer
Visual C++
property int PictureIndex {
    int get ();
}

See Also

IPart Interface
Mincom.LinkOne.Dom.SelectionList Namespace


PublisherCode Property

[image]

LinkOne WebView API
IPart..::.PublisherCode Property
IPart Interface See Also Send Feedback
Gets the publisher code for the book that contained the part.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string PublisherCode { get; }
Visual Basic (Declaration)
ReadOnly Property PublisherCode As String
Visual C++
property String^ PublisherCode {
    String^ get ();
}

See Also

IPart Interface
Mincom.LinkOne.Dom.SelectionList Namespace


SpecificObject Property

[image]

LinkOne WebView API
IPart..::.SpecificObject Property
IPart Interface See Also Send Feedback
Gets the specific object value for this part.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string SpecificObject { get; }
Visual Basic (Declaration)
ReadOnly Property SpecificObject As String
Visual C++
property String^ SpecificObject {
    String^ get ();
}

See Also

IPart Interface
Mincom.LinkOne.Dom.SelectionList Namespace


IPart Events

[image] [image]

LinkOne WebView API
IPart Events
IPart Interface See Also Send Feedback

The IPart type exposes the following members.

Events

Name | Description
Changed | Occurs when a property value changes. (Inherited from INotifyChanged.)

See Also

IPart Interface
Mincom.LinkOne.Dom.SelectionList Namespace


IPartCollection Interface

[image]

LinkOne WebView API
IPartCollection Interface
Members See Also Send Feedback
Represents a collection of parts in a LinkOne selection list.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IPartCollection : IList<IPart>,
    ICollection<IPart>, IEnumerable<IPart>, IEnumerable
Visual Basic (Declaration)
Public Interface IPartCollection _
    Implements IList(Of IPart), ICollection(Of IPart),  _
    IEnumerable(Of IPart), IEnumerable
Visual C++
public interface class IPartCollection : IList<IPart^>,
    ICollection<IPart^>, IEnumerable<IPart^>, IEnumerable

See Also

IPartCollection Members
Mincom.LinkOne.Dom.SelectionList Namespace


IPartCollection Members

[image] [image]

LinkOne WebView API
IPartCollection Members
IPartCollection Interface Methods Properties See Also Send Feedback

The IPartCollection type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPart >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPart >)>).)
Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from ICollection<(Of <( IPart >)>).)
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( IPart >)>).)
GetEnumerator | Overloaded.
IndexOf | Determines the index of a specific item in the IList<(Of <(T>)>). (Inherited from IList<(Of <( IPart >)>).)
Insert | Inserts an item to the IList<(Of <(T>)>) at the specified index. (Inherited from IList<(Of <( IPart >)>).)
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPart >)>).)
RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index. (Inherited from IList<(Of <( IPart >)>).)

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPart >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( IPart >)>).)
Item | Gets or sets the element at the specified index. (Inherited from IList<(Of <( IPart >)>).)

See Also

IPartCollection Interface
Mincom.LinkOne.Dom.SelectionList Namespace


IPartCollection Methods

[image] [image]

LinkOne WebView API
IPartCollection Methods
IPartCollection Interface See Also Send Feedback

The IPartCollection type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPart >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPart >)>).)
Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from ICollection<(Of <( IPart >)>).)
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( IPart >)>).)
GetEnumerator | Overloaded.
IndexOf | Determines the index of a specific item in the IList<(Of <(T>)>). (Inherited from IList<(Of <( IPart >)>).)
Insert | Inserts an item to the IList<(Of <(T>)>) at the specified index. (Inherited from IList<(Of <( IPart >)>).)
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPart >)>).)
RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index. (Inherited from IList<(Of <( IPart >)>).)

See Also

IPartCollection Interface
Mincom.LinkOne.Dom.SelectionList Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
IPartCollection..::.GetEnumerator Method
IPartCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( IPart >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IPartCollection Interface
IPartCollection Members
Mincom.LinkOne.Dom.SelectionList Namespace


IPartCollection Properties

[image] [image]

LinkOne WebView API
IPartCollection Properties
IPartCollection Interface See Also Send Feedback

The IPartCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPart >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( IPart >)>).)
Item | Gets or sets the element at the specified index. (Inherited from IList<(Of <( IPart >)>).)

See Also

IPartCollection Interface
Mincom.LinkOne.Dom.SelectionList Namespace


ISelectionList Interface

[image]

LinkOne WebView API
ISelectionList Interface
Members See Also Send Feedback
Represents a LinkOne selection list.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ISelectionList : INotifyChanged
Visual Basic (Declaration)
Public Interface ISelectionList _
    Implements INotifyChanged
Visual C++
public interface class ISelectionList : INotifyChanged

See Also

ISelectionList Members
Mincom.LinkOne.Dom.SelectionList Namespace


ISelectionList Members

[image] [image]

LinkOne WebView API
ISelectionList Members
ISelectionList Interface Methods Properties Events See Also Send Feedback

The ISelectionList type exposes the following members.

Methods

Name | Description
CreatePart | Creates the part mapped to the specified LinkOne Book location.

Properties

Name | Description
Columns | Gets the columns defined by the selection list.
Errors | Gets any errors reading this object from persistant storage.
Filtered | Gets or sets a value indicating whether this ISelectionList is filtered.
FilteredLock | Gets or sets the lock for the filtered state.
HasChanged | Gets or sets a value indicating whether this ISelectionList has changed.
Layouts | Gets the default layouts for the selection list.
Location | Gets or sets the selection list location.
Name | Gets or sets the name of the selection list.
Parts | Gets the parts that have been added to the selection list.

Events

Name | Description
Changed | Occurs when a property value changes. (Inherited from INotifyChanged.)

See Also

ISelectionList Interface
Mincom.LinkOne.Dom.SelectionList Namespace


ISelectionList Methods

[image] [image]

LinkOne WebView API
ISelectionList Methods
ISelectionList Interface See Also Send Feedback

The ISelectionList type exposes the following members.

Methods

Name | Description
CreatePart | Creates the part mapped to the specified LinkOne Book location.

See Also

ISelectionList Interface
Mincom.LinkOne.Dom.SelectionList Namespace


CreatePart Method

[image]

LinkOne WebView API
ISelectionList..::.CreatePart Method
ISelectionList Interface See Also Send Feedback
Creates the part mapped to the specified LinkOne Book location.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPart CreatePart(
    IBook book,
    IPage page,
    IEntry entry
)
Visual Basic (Declaration)
Function CreatePart ( _
    book As IBook, _
    page As IPage, _
    entry As IEntry _
) As IPart
Visual C++
IPart^ CreatePart(
    IBook^ book,
    IPage^ page,
    IEntry^ entry
)

Parameters

book
Type: Mincom.LinkOne.Dom..::.IBook
The book containing the part.
page
Type: Mincom.LinkOne.Dom..::.IPage
The page containing the part.
entry
Type: Mincom.LinkOne.Dom..::.IEntry
The parts list entry that represents the part.

Return Value

A new part for the specified criteria.

See Also

ISelectionList Interface
Mincom.LinkOne.Dom.SelectionList Namespace


ISelectionList Properties

[image] [image]

LinkOne WebView API
ISelectionList Properties
ISelectionList Interface See Also Send Feedback

The ISelectionList type exposes the following members.

Properties

Name | Description
Columns | Gets the columns defined by the selection list.
Errors | Gets any errors reading this object from persistant storage.
Filtered | Gets or sets a value indicating whether this ISelectionList is filtered.
FilteredLock | Gets or sets the lock for the filtered state.
HasChanged | Gets or sets a value indicating whether this ISelectionList has changed.
Layouts | Gets the default layouts for the selection list.
Location | Gets or sets the selection list location.
Name | Gets or sets the name of the selection list.
Parts | Gets the parts that have been added to the selection list.

See Also

ISelectionList Interface
Mincom.LinkOne.Dom.SelectionList Namespace


Columns Property

[image]

LinkOne WebView API
ISelectionList..::.Columns Property
ISelectionList Interface See Also Send Feedback
Gets the columns defined by the selection list.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IColumnCollection Columns { get; }
Visual Basic (Declaration)
ReadOnly Property Columns As IColumnCollection
Visual C++
property IColumnCollection^ Columns {
    IColumnCollection^ get ();
}

See Also

ISelectionList Interface
Mincom.LinkOne.Dom.SelectionList Namespace


Errors Property

[image]

LinkOne WebView API
ISelectionList..::.Errors Property
ISelectionList Interface See Also Send Feedback
Gets any errors reading this object from persistant storage.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IList<Exception> Errors { get; }
Visual Basic (Declaration)
ReadOnly Property Errors As IList(Of Exception)
Visual C++
property IList<Exception^>^ Errors {
    IList<Exception^>^ get ();
}

See Also

ISelectionList Interface
Mincom.LinkOne.Dom.SelectionList Namespace


Filtered Property

[image]

LinkOne WebView API
ISelectionList..::.Filtered Property
ISelectionList Interface See Also Send Feedback
Gets or sets a value indicating whether this ISelectionList is filtered.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool Filtered { get; set; }
Visual Basic (Declaration)
Property Filtered As Boolean
Visual C++
property bool Filtered {
    bool get ();
    void set (bool value);
}

See Also

ISelectionList Interface
Mincom.LinkOne.Dom.SelectionList Namespace


FilteredLock Property

[image]

LinkOne WebView API
ISelectionList..::.FilteredLock Property
ISelectionList Interface See Also Send Feedback
Gets or sets the lock for the filtered state.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool FilteredLock { get; set; }
Visual Basic (Declaration)
Property FilteredLock As Boolean
Visual C++
property bool FilteredLock {
    bool get ();
    void set (bool value);
}

See Also

ISelectionList Interface
Mincom.LinkOne.Dom.SelectionList Namespace


HasChanged Property

[image]

LinkOne WebView API
ISelectionList..::.HasChanged Property
ISelectionList Interface See Also Send Feedback
Gets or sets a value indicating whether this ISelectionList has changed.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool HasChanged { get; set; }
Visual Basic (Declaration)
Property HasChanged As Boolean
Visual C++
property bool HasChanged {
    bool get ();
    void set (bool value);
}

See Also

ISelectionList Interface
Mincom.LinkOne.Dom.SelectionList Namespace


Layouts Property

[image]

LinkOne WebView API
ISelectionList..::.Layouts Property
ISelectionList Interface See Also Send Feedback
Gets the default layouts for the selection list.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ILayoutCollection Layouts { get; }
Visual Basic (Declaration)
ReadOnly Property Layouts As ILayoutCollection
Visual C++
property ILayoutCollection^ Layouts {
    ILayoutCollection^ get ();
}

See Also

ISelectionList Interface
Mincom.LinkOne.Dom.SelectionList Namespace


Location Property

[image]

LinkOne WebView API
ISelectionList..::.Location Property
ISelectionList Interface See Also Send Feedback
Gets or sets the selection list location.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Location { get; set; }
Visual Basic (Declaration)
Property Location As String
Visual C++
property String^ Location {
    String^ get ();
    void set (String^ value);
}

See Also

ISelectionList Interface
Mincom.LinkOne.Dom.SelectionList Namespace


Name Property

[image]

LinkOne WebView API
ISelectionList..::.Name Property
ISelectionList Interface See Also Send Feedback
Gets or sets the name of the selection list.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string Name { get; set; }
Visual Basic (Declaration)
Property Name As String
Visual C++
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

ISelectionList Interface
Mincom.LinkOne.Dom.SelectionList Namespace


Parts Property

[image]

LinkOne WebView API
ISelectionList..::.Parts Property
ISelectionList Interface See Also Send Feedback
Gets the parts that have been added to the selection list.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPartCollection Parts { get; }
Visual Basic (Declaration)
ReadOnly Property Parts As IPartCollection
Visual C++
property IPartCollection^ Parts {
    IPartCollection^ get ();
}

See Also

ISelectionList Interface
Mincom.LinkOne.Dom.SelectionList Namespace


ISelectionList Events

[image] [image]

LinkOne WebView API
ISelectionList Events
ISelectionList Interface See Also Send Feedback

The ISelectionList type exposes the following members.

Events

Name | Description
Changed | Occurs when a property value changes. (Inherited from INotifyChanged.)

See Also

ISelectionList Interface
Mincom.LinkOne.Dom.SelectionList Namespace


ISelectionList2 Interface

[image]

LinkOne WebView API
ISelectionList2 Interface
Members See Also Send Feedback
Extended Representation of a LinkOne selection list.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ISelectionList2 : ISelectionList,
    INotifyChanged
Visual Basic (Declaration)
Public Interface ISelectionList2 _
    Implements ISelectionList, INotifyChanged
Visual C++
public interface class ISelectionList2 : ISelectionList,
    INotifyChanged

See Also

ISelectionList2 Members
Mincom.LinkOne.Dom.SelectionList Namespace


ISelectionList2 Members

[image] [image]

LinkOne WebView API
ISelectionList2 Members
ISelectionList2 Interface Methods Properties Events See Also Send Feedback

The ISelectionList2 type exposes the following members.

Methods

Name | Description
CreatePart | Creates the part mapped to the specified LinkOne Book location. (Inherited from ISelectionList.)

Properties

Name | Description
Attributes | Gets the selection list attributes.
Columns | Gets the columns defined by the selection list. (Inherited from ISelectionList.)
Errors | Gets any errors reading this object from persistant storage. (Inherited from ISelectionList.)
Filtered | Gets or sets a value indicating whether this ISelectionList is filtered. (Inherited from ISelectionList.)
FilteredLock | Gets or sets the lock for the filtered state. (Inherited from ISelectionList.)
HasChanged | Gets or sets a value indicating whether this ISelectionList has changed. (Inherited from ISelectionList.)
Layouts | Gets the default layouts for the selection list. (Inherited from ISelectionList.)
Location | Gets or sets the selection list location. (Inherited from ISelectionList.)
Name | Gets or sets the name of the selection list. (Inherited from ISelectionList.)
Parts | Gets the parts that have been added to the selection list. (Inherited from ISelectionList.)

Events

Name | Description
Changed | Occurs when a property value changes. (Inherited from INotifyChanged.)

See Also

ISelectionList2 Interface
Mincom.LinkOne.Dom.SelectionList Namespace


ISelectionList2 Methods

[image] [image]

LinkOne WebView API
ISelectionList2 Methods
ISelectionList2 Interface See Also Send Feedback

The ISelectionList2 type exposes the following members.

Methods

Name | Description
CreatePart | Creates the part mapped to the specified LinkOne Book location. (Inherited from ISelectionList.)

See Also

ISelectionList2 Interface
Mincom.LinkOne.Dom.SelectionList Namespace


ISelectionList2 Properties

[image] [image]

LinkOne WebView API
ISelectionList2 Properties
ISelectionList2 Interface See Also Send Feedback

The ISelectionList2 type exposes the following members.

Properties

Name | Description
Attributes | Gets the selection list attributes.
Columns | Gets the columns defined by the selection list. (Inherited from ISelectionList.)
Errors | Gets any errors reading this object from persistant storage. (Inherited from ISelectionList.)
Filtered | Gets or sets a value indicating whether this ISelectionList is filtered. (Inherited from ISelectionList.)
FilteredLock | Gets or sets the lock for the filtered state. (Inherited from ISelectionList.)
HasChanged | Gets or sets a value indicating whether this ISelectionList has changed. (Inherited from ISelectionList.)
Layouts | Gets the default layouts for the selection list. (Inherited from ISelectionList.)
Location | Gets or sets the selection list location. (Inherited from ISelectionList.)
Name | Gets or sets the name of the selection list. (Inherited from ISelectionList.)
Parts | Gets the parts that have been added to the selection list. (Inherited from ISelectionList.)

See Also

ISelectionList2 Interface
Mincom.LinkOne.Dom.SelectionList Namespace


Attributes Property

[image]

LinkOne WebView API
ISelectionList2..::.Attributes Property
ISelectionList2 Interface See Also Send Feedback
Gets the selection list attributes.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
Dictionary<string, string> Attributes { get; }
Visual Basic (Declaration)
ReadOnly Property Attributes As Dictionary(Of String, String)
Visual C++
property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get ();
}

Remarks

Adding, removing or editing attributes does not trigger the Changed event

See Also

ISelectionList2 Interface
Mincom.LinkOne.Dom.SelectionList Namespace


ISelectionList2 Events

[image] [image]

LinkOne WebView API
ISelectionList2 Events
ISelectionList2 Interface See Also Send Feedback

The ISelectionList2 type exposes the following members.

Events

Name | Description
Changed | Occurs when a property value changes. (Inherited from INotifyChanged.)

See Also

ISelectionList2 Interface
Mincom.LinkOne.Dom.SelectionList Namespace


ISelectionListCollection Interface

[image]

LinkOne WebView API
ISelectionListCollection Interface
Members See Also Send Feedback
Represents a collection of selection lists.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface ISelectionListCollection : IList<ISelectionList>,
    ICollection<ISelectionList>, IEnumerable<ISelectionList>, IEnumerable
Visual Basic (Declaration)
Public Interface ISelectionListCollection _
    Implements IList(Of ISelectionList), ICollection(Of ISelectionList),  _
    IEnumerable(Of ISelectionList), IEnumerable
Visual C++
public interface class ISelectionListCollection : IList<ISelectionList^>,
    ICollection<ISelectionList^>, IEnumerable<ISelectionList^>, IEnumerable

See Also

ISelectionListCollection Members
Mincom.LinkOne.Dom.SelectionList Namespace


ISelectionListCollection Members

[image] [image]

LinkOne WebView API
ISelectionListCollection Members
ISelectionListCollection Interface Methods Properties See Also Send Feedback

The ISelectionListCollection type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ISelectionList >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ISelectionList >)>).)
Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from ICollection<(Of <( ISelectionList >)>).)
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( ISelectionList >)>).)
Create | Creates a new empty selection list.
GetEnumerator | Overloaded.
IndexOf | Determines the index of a specific item in the IList<(Of <(T>)>). (Inherited from IList<(Of <( ISelectionList >)>).)
Insert | Inserts an item to the IList<(Of <(T>)>) at the specified index. (Inherited from IList<(Of <( ISelectionList >)>).)
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ISelectionList >)>).)
RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index. (Inherited from IList<(Of <( ISelectionList >)>).)

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ISelectionList >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( ISelectionList >)>).)
Item | Gets or sets the element at the specified index. (Inherited from IList<(Of <( ISelectionList >)>).)

See Also

ISelectionListCollection Interface
Mincom.LinkOne.Dom.SelectionList Namespace


ISelectionListCollection Methods

[image] [image]

LinkOne WebView API
ISelectionListCollection Methods
ISelectionListCollection Interface See Also Send Feedback

The ISelectionListCollection type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ISelectionList >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ISelectionList >)>).)
Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from ICollection<(Of <( ISelectionList >)>).)
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( ISelectionList >)>).)
Create | Creates a new empty selection list.
GetEnumerator | Overloaded.
IndexOf | Determines the index of a specific item in the IList<(Of <(T>)>). (Inherited from IList<(Of <( ISelectionList >)>).)
Insert | Inserts an item to the IList<(Of <(T>)>) at the specified index. (Inherited from IList<(Of <( ISelectionList >)>).)
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ISelectionList >)>).)
RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index. (Inherited from IList<(Of <( ISelectionList >)>).)

See Also

ISelectionListCollection Interface
Mincom.LinkOne.Dom.SelectionList Namespace


Create Method

[image]

LinkOne WebView API
ISelectionListCollection..::.Create Method
ISelectionListCollection Interface See Also Send Feedback
Creates a new empty selection list.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ISelectionList Create()
Visual Basic (Declaration)
Function Create As ISelectionList
Visual C++
ISelectionList^ Create()

Return Value

A new ISelectionList.

See Also

ISelectionListCollection Interface
Mincom.LinkOne.Dom.SelectionList Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
ISelectionListCollection..::.GetEnumerator Method
ISelectionListCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( ISelectionList >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

ISelectionListCollection Interface
ISelectionListCollection Members
Mincom.LinkOne.Dom.SelectionList Namespace


ISelectionListCollection Properties

[image] [image]

LinkOne WebView API
ISelectionListCollection Properties
ISelectionListCollection Interface See Also Send Feedback

The ISelectionListCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( ISelectionList >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( ISelectionList >)>).)
Item | Gets or sets the element at the specified index. (Inherited from IList<(Of <( ISelectionList >)>).)

See Also

ISelectionListCollection Interface
Mincom.LinkOne.Dom.SelectionList Namespace


NewLineProcessing Enumeration

[image]

LinkOne WebView API
NewLineProcessing Enumeration
See Also Send Feedback
Determines how selection list data with line breaks will be handled.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum NewLineProcessing
Visual Basic (Declaration)
Public Enumeration NewLineProcessing
Visual C++
public enum class NewLineProcessing

Members

Member name | Description
Default | Same as Terminates, but as this is the default, it is not written out.
Terminates | The field text is truncated at the first newline.
Kept | Newlines in the field are kept in the selection list
Removed | Newlines in the field are removed by the selection list
Blanked | Newlines in the field are replaced with spaces.

See Also

Mincom.LinkOne.Dom.SelectionList Namespace


Part Class

[image]

LinkOne WebView API
Part Class
Members See Also Send Feedback
Represents a SelectionList part.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public class Part : IPart, INotifyChanged
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class Part _
    Implements IPart, INotifyChanged
Visual C++
[SerializableAttribute]
public ref class Part : IPart, INotifyChanged

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.SelectionList..::.Part

See Also

Part Members
Mincom.LinkOne.Dom.SelectionList Namespace


Part Members

[image] [image]

LinkOne WebView API
Part Members
Part Class Constructors Methods Properties Events Explicit Interface Implementations See Also Send Feedback

The Part type exposes the following members.

Constructors

Name | Description
Part | Overloaded.

Methods

Name | Description
AddField | Adds a field with the given name and value.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | Fires the Changed event.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
BaseBookCode | Gets the base book code if the part was added from a derived book.
BookCode | Gets the book code for the book that contained the part.
CheckCode | Gets the check code used to verify the identification of entries.
Fields | Gets the collection of fields that are associated with the part.
GotoItemId | Gets the GotoItemId value for this part.
IsBookPart | Gets true if the part is a part in a book
IsUserPart | Gets true if the part is a user added part.
ItemId | Gets the item Id for the parts list entry that contained the part.
ItemIndex | Gets the item index value for this part.
PageRef | Gets the page reference for the page that contained the part.
PictureIndex | Gets the picture index of the picture showing when the part was added.
PublisherCode | Gets the publisher code for the book that contained the part.
SpecificObject | Gets the specific object value for this part.

Events

Name | Description
Changed | Occurs when the part has changed.

Explicit Interface Implementations

Name | Description
IPart..::.Fields |

See Also

Part Class
Mincom.LinkOne.Dom.SelectionList Namespace


Part Constructor

[image] [image]

LinkOne WebView API
Part Constructor
Part Class See Also Send Feedback

Overload List

Name | Description
Part()()() | Constructor.
Part(String, String, String, String, String, String, Int32, Int32, String, String) | Constructor.
Part(String, String, String, String, Int32) | Constructor.

See Also

Part Class
Part Members
Mincom.LinkOne.Dom.SelectionList Namespace


Part Constructor

[image]

LinkOne WebView API
Part Constructor
Part Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Part()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Part()

Remarks

Creates an empty part, not associated with any book.

See Also

Part Class
Part Overload
Mincom.LinkOne.Dom.SelectionList Namespace


Part Constructor (String, String, String, String, String, String, Int32, Int32, String, String)

[image]

LinkOne WebView API
Part Constructor (String, String, String, String, String, String, Int32, Int32, String, String)
Part Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Part(
    string specificObject,
    string publisherCode,
    string baseBookCode,
    string bookCode,
    string pageRef,
    string itemId,
    int itemIndex,
    int pictureIndex,
    string gotoItemId,
    string checkCode
)
Visual Basic (Declaration)
Public Sub New ( _
    specificObject As String, _
    publisherCode As String, _
    baseBookCode As String, _
    bookCode As String, _
    pageRef As String, _
    itemId As String, _
    itemIndex As Integer, _
    pictureIndex As Integer, _
    gotoItemId As String, _
    checkCode As String _
)
Visual C++
public:
Part(
    String^ specificObject,
    String^ publisherCode,
    String^ baseBookCode,
    String^ bookCode,
    String^ pageRef,
    String^ itemId,
    int itemIndex,
    int pictureIndex,
    String^ gotoItemId,
    String^ checkCode
)

Parameters

specificObject
Type: System..::.String
The specific object code that was active at the time, if any.
publisherCode
Type: System..::.String
The pubisherer than part belongs to.
baseBookCode
Type: System..::.String
The bas book code which contains the part.
bookCode
Type: System..::.String
The book which contains the part.
pageRef
Type: System..::.String
The page reference where part is located.
itemId
Type: System..::.String
The item ID number associated with the part.
itemIndex
Type: System..::.Int32
The item index associated with the part.
pictureIndex
Type: System..::.Int32
The picture index associated with the part.
gotoItemId
Type: System..::.String
Used this as the item ID for goto purposes.
checkCode
Type: System..::.String
The part number from the original entry (used as verification).

See Also

Part Class
Part Overload
Mincom.LinkOne.Dom.SelectionList Namespace


Part Constructor (String, String, String, String, Int32)

[image]

LinkOne WebView API
Part Constructor (String, String, String, String, Int32)
Part Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Part(
    string publisherCode,
    string bookCode,
    string pageRef,
    string itemId,
    int itemIndex
)
Visual Basic (Declaration)
Public Sub New ( _
    publisherCode As String, _
    bookCode As String, _
    pageRef As String, _
    itemId As String, _
    itemIndex As Integer _
)
Visual C++
public:
Part(
    String^ publisherCode,
    String^ bookCode,
    String^ pageRef,
    String^ itemId,
    int itemIndex
)

Parameters

publisherCode
Type: System..::.String
The pubisherer than part belongs to.
bookCode
Type: System..::.String
The book which contains the part.
pageRef
Type: System..::.String
The page reference where part is located.
itemId
Type: System..::.String
The item ID number associated with the part.
itemIndex
Type: System..::.Int32
The index of the item.

Remarks

Creates a part associated with the given book item.

See Also

Part Class
Part Overload
Mincom.LinkOne.Dom.SelectionList Namespace


Part Methods

[image] [image]

LinkOne WebView API
Part Methods
Part Class See Also Send Feedback

The Part type exposes the following members.

Methods

Name | Description
AddField | Adds a field with the given name and value.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | Fires the Changed event.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Part Class
Mincom.LinkOne.Dom.SelectionList Namespace


AddField Method

[image]

LinkOne WebView API
Part..::.AddField Method
Part Class See Also Send Feedback
Adds a field with the given name and value.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void AddField(
    string columnName,
    string fieldValue
)
Visual Basic (Declaration)
Public Sub AddField ( _
    columnName As String, _
    fieldValue As String _
)
Visual C++
public:
void AddField(
    String^ columnName,
    String^ fieldValue
)

Parameters

columnName
Type: System..::.String
The name of the field.
fieldValue
Type: System..::.String
The value of the field.

See Also

Part Class
Mincom.LinkOne.Dom.SelectionList Namespace


OnChanged Method

[image]

LinkOne WebView API
Part..::.OnChanged Method
Part Class See Also Send Feedback
Fires the Changed event.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected virtual void OnChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnChanged
Visual C++
protected:
virtual void OnChanged()

See Also

Part Class
Mincom.LinkOne.Dom.SelectionList Namespace


Part Properties

[image] [image]

LinkOne WebView API
Part Properties
Part Class See Also Send Feedback

The Part type exposes the following members.

Properties

Name | Description
BaseBookCode | Gets the base book code if the part was added from a derived book.
BookCode | Gets the book code for the book that contained the part.
CheckCode | Gets the check code used to verify the identification of entries.
Fields | Gets the collection of fields that are associated with the part.
GotoItemId | Gets the GotoItemId value for this part.
IsBookPart | Gets true if the part is a part in a book
IsUserPart | Gets true if the part is a user added part.
ItemId | Gets the item Id for the parts list entry that contained the part.
ItemIndex | Gets the item index value for this part.
PageRef | Gets the page reference for the page that contained the part.
PictureIndex | Gets the picture index of the picture showing when the part was added.
PublisherCode | Gets the publisher code for the book that contained the part.
SpecificObject | Gets the specific object value for this part.

Explicit Interface Implementations

Name | Description
IPart..::.Fields |

See Also

Part Class
Mincom.LinkOne.Dom.SelectionList Namespace


BaseBookCode Property

[image]

LinkOne WebView API
Part..::.BaseBookCode Property
Part Class See Also Send Feedback
Gets the base book code if the part was added from a derived book.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string BaseBookCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property BaseBookCode As String
Visual C++
public:
virtual property String^ BaseBookCode {
    String^ get () sealed;
}

Implements

IPart..::.BaseBookCode

See Also

Part Class
Mincom.LinkOne.Dom.SelectionList Namespace


BookCode Property

[image]

LinkOne WebView API
Part..::.BookCode Property
Part Class See Also Send Feedback
Gets the book code for the book that contained the part.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string BookCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property BookCode As String
Visual C++
public:
virtual property String^ BookCode {
    String^ get () sealed;
}

Implements

IPart..::.BookCode

See Also

Part Class
Mincom.LinkOne.Dom.SelectionList Namespace


CheckCode Property

[image]

LinkOne WebView API
Part..::.CheckCode Property
Part Class See Also Send Feedback
Gets the check code used to verify the identification of entries.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string CheckCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property CheckCode As String
Visual C++
public:
virtual property String^ CheckCode {
    String^ get () sealed;
}

Implements

IPart..::.CheckCode

See Also

Part Class
Mincom.LinkOne.Dom.SelectionList Namespace


Fields Property

[image]

LinkOne WebView API
Part..::.Fields Property
Part Class See Also Send Feedback
Gets the collection of fields that are associated with the part.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public FieldCollection Fields { get; }
Visual Basic (Declaration)
Public ReadOnly Property Fields As FieldCollection
Visual C++
public:
property FieldCollection^ Fields {
    FieldCollection^ get ();
}

See Also

Part Class
Mincom.LinkOne.Dom.SelectionList Namespace


GotoItemId Property

[image]

LinkOne WebView API
Part..::.GotoItemId Property
Part Class See Also Send Feedback
Gets the GotoItemId value for this part.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string GotoItemId { get; }
Visual Basic (Declaration)
Public ReadOnly Property GotoItemId As String
Visual C++
public:
virtual property String^ GotoItemId {
    String^ get () sealed;
}

Implements

IPart..::.GotoItemId

See Also

Part Class
Mincom.LinkOne.Dom.SelectionList Namespace


IPart.Fields Property

[image]

LinkOne WebView API
Part..::.IPart..::.Fields Property
Part Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IFieldCollection IPart.Fields { get; }
Visual Basic (Declaration)
Private ReadOnly Property Fields As IFieldCollection
    Implements IPart.Fields
Visual C++
private:
virtual property IFieldCollection^ Fields {
    IFieldCollection^ get () sealed = IPart::Fields::get;
}

Implements

IPart..::.Fields

See Also

Part Class
Mincom.LinkOne.Dom.SelectionList Namespace


IsBookPart Property

[image]

LinkOne WebView API
Part..::.IsBookPart Property
Part Class See Also Send Feedback
Gets true if the part is a part in a book

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsBookPart { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsBookPart As Boolean
Visual C++
public:
virtual property bool IsBookPart {
    bool get () sealed;
}

Implements

IPart..::.IsBookPart

Remarks

A book part is one where the publisher code, book code, or page reference are specified.

Remarks

To be a book part a part must contain:
  • A publisher code and a book code, or,
  • A book code, if not publisher code, the current publisher is assumed
  • A page reference, if not book code the current book is assumed.

See Also

Part Class
Mincom.LinkOne.Dom.SelectionList Namespace


IsUserPart Property

[image]

LinkOne WebView API
Part..::.IsUserPart Property
Part Class See Also Send Feedback
Gets true if the part is a user added part.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsUserPart { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsUserPart As Boolean
Visual C++
public:
virtual property bool IsUserPart {
    bool get () sealed;
}

Implements

IPart..::.IsUserPart

Remarks

A user part is one where there is no publisher code.

See Also

Part Class
Mincom.LinkOne.Dom.SelectionList Namespace


ItemId Property

[image]

LinkOne WebView API
Part..::.ItemId Property
Part Class See Also Send Feedback
Gets the item Id for the parts list entry that contained the part.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string ItemId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemId As String
Visual C++
public:
virtual property String^ ItemId {
    String^ get () sealed;
}

Implements

IPart..::.ItemId

See Also

Part Class
Mincom.LinkOne.Dom.SelectionList Namespace


ItemIndex Property

[image]

LinkOne WebView API
Part..::.ItemIndex Property
Part Class See Also Send Feedback
Gets the item index value for this part.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int ItemIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemIndex As Integer
Visual C++
public:
virtual property int ItemIndex {
    int get () sealed;
}

Implements

IPart..::.ItemIndex

See Also

Part Class
Mincom.LinkOne.Dom.SelectionList Namespace


PageRef Property

[image]

LinkOne WebView API
Part..::.PageRef Property
Part Class See Also Send Feedback
Gets the page reference for the page that contained the part.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PageRef { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageRef As String
Visual C++
public:
virtual property String^ PageRef {
    String^ get () sealed;
}

Implements

IPart..::.PageRef

See Also

Part Class
Mincom.LinkOne.Dom.SelectionList Namespace


PictureIndex Property

[image]

LinkOne WebView API
Part..::.PictureIndex Property
Part Class See Also Send Feedback
Gets the picture index of the picture showing when the part was added.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int PictureIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property PictureIndex As Integer
Visual C++
public:
virtual property int PictureIndex {
    int get () sealed;
}

Implements

IPart..::.PictureIndex

See Also

Part Class
Mincom.LinkOne.Dom.SelectionList Namespace


PublisherCode Property

[image]

LinkOne WebView API
Part..::.PublisherCode Property
Part Class See Also Send Feedback
Gets the publisher code for the book that contained the part.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PublisherCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublisherCode As String
Visual C++
public:
virtual property String^ PublisherCode {
    String^ get () sealed;
}

Implements

IPart..::.PublisherCode

See Also

Part Class
Mincom.LinkOne.Dom.SelectionList Namespace


SpecificObject Property

[image]

LinkOne WebView API
Part..::.SpecificObject Property
Part Class See Also Send Feedback
Gets the specific object value for this part.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string SpecificObject { get; }
Visual Basic (Declaration)
Public ReadOnly Property SpecificObject As String
Visual C++
public:
virtual property String^ SpecificObject {
    String^ get () sealed;
}

Implements

IPart..::.SpecificObject

See Also

Part Class
Mincom.LinkOne.Dom.SelectionList Namespace


Part Events

[image] [image]

LinkOne WebView API
Part Events
Part Class See Also Send Feedback

The Part type exposes the following members.

Events

Name | Description
Changed | Occurs when the part has changed.

See Also

Part Class
Mincom.LinkOne.Dom.SelectionList Namespace


Changed Event

[image]

LinkOne WebView API
Part..::.Changed Event
Part Class See Also Send Feedback
Occurs when the part has changed.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public event EventHandler Changed
Visual Basic (Declaration)
Public Event Changed As EventHandler
Visual C++
public:
virtual  event EventHandler^ Changed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Implements

INotifyChanged..::.Changed

See Also

Part Class
Mincom.LinkOne.Dom.SelectionList Namespace


PartCollection Class

[image]

LinkOne WebView API
PartCollection Class
Members See Also Send Feedback
Represents a collection of IPart objects.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class PartCollection : LiveCollection<IPart>,
    IPartCollection, IList<IPart>, ICollection<IPart>,
    IEnumerable<IPart>, IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class PartCollection _
    Inherits LiveCollection(Of IPart) _
    Implements IPartCollection, IList(Of IPart),  _
    ICollection(Of IPart), IEnumerable(Of IPart), IEnumerable
Visual C++
[SerializableAttribute]
public ref class PartCollection sealed : public LiveCollection<IPart^>,
    IPartCollection, IList<IPart^>, ICollection<IPart^>,
    IEnumerable<IPart^>, IEnumerable

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection<(Of <( IPart >)>)
LiveCollection<(Of <( IPart >)>)
Mincom.LinkOne.Dom.SelectionList..::.PartCollection

See Also

PartCollection Members
Mincom.LinkOne.Dom.SelectionList Namespace


PartCollection Members

[image] [image]

LinkOne WebView API
PartCollection Members
PartCollection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The PartCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IPart >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IPart >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IPart >)>).)
Contains | Overloaded.
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( IPart >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
FindPart | Finds the first occurance of a part that matches the publisher code, book code, page reference, item id and item index.
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IPart >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IPart >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( IPart >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( IPart >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IPart >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IPart >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IPart >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( IPart >)>).)
Sort | Sorts the parts and returns a new collection with the same parts.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IPart >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( IPart >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IPart >)>).)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds an item to the IList. (Inherited from Collection<(Of <( IPart >)>).)
IList..::.Contains | Determines whether the IList contains a specific value. (Inherited from Collection<(Of <( IPart >)>).)
ICollection..::.CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection<(Of <( IPart >)>).)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection<(Of <( IPart >)>).)
IList..::.IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection<(Of <( IPart >)>).)
IList..::.Insert | Inserts an item into the IList at the specified index. (Inherited from Collection<(Of <( IPart >)>).)
IList..::.IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection<(Of <( IPart >)>).)
System#Collections#Generic#ICollection{T}#IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from Collection<(Of <( IPart >)>).)
IList..::.IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection<(Of <( IPart >)>).)
ICollection..::.IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection<(Of <( IPart >)>).)
IList..::.Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( IPart >)>).)
IList..::.Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection<(Of <( IPart >)>).)
ICollection..::.SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection<(Of <( IPart >)>).)

See Also

PartCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


PartCollection Methods

[image] [image]

LinkOne WebView API
PartCollection Methods
PartCollection Class See Also Send Feedback

The PartCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IPart >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IPart >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IPart >)>).)
Contains | Overloaded.
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( IPart >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
FindPart | Finds the first occurance of a part that matches the publisher code, book code, page reference, item id and item index.
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IPart >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IPart >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( IPart >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( IPart >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IPart >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IPart >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IPart >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( IPart >)>).)
Sort | Sorts the parts and returns a new collection with the same parts.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds an item to the IList. (Inherited from Collection<(Of <( IPart >)>).)
IList..::.Contains | Determines whether the IList contains a specific value. (Inherited from Collection<(Of <( IPart >)>).)
ICollection..::.CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection<(Of <( IPart >)>).)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection<(Of <( IPart >)>).)
IList..::.IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection<(Of <( IPart >)>).)
IList..::.Insert | Inserts an item into the IList at the specified index. (Inherited from Collection<(Of <( IPart >)>).)
IList..::.Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection<(Of <( IPart >)>).)

See Also

PartCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


Contains Method

[image] [image]

LinkOne WebView API
PartCollection..::.Contains Method
PartCollection Class See Also Send Feedback

Overload List

Name | Description
Contains(T) | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IPart >)>).)
Contains(String, String, String, String) | Returns true if a part with the given codes is present in the collection.

See Also

PartCollection Class
PartCollection Members
Mincom.LinkOne.Dom.SelectionList Namespace


Contains Method (String, String, String, String)

[image]

LinkOne WebView API
PartCollection..::.Contains Method (String, String, String, String)
PartCollection Class See Also Send Feedback
Returns true if a part with the given codes is present in the collection.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    string publisherCode,
    string bookCode,
    string pageReference,
    string itemId
)
Visual Basic (Declaration)
Public Function Contains ( _
    publisherCode As String, _
    bookCode As String, _
    pageReference As String, _
    itemId As String _
) As Boolean
Visual C++
public:
bool Contains(
    String^ publisherCode,
    String^ bookCode,
    String^ pageReference,
    String^ itemId
)

Parameters

publisherCode
Type: System..::.String
The publisher code of the part to check for.
bookCode
Type: System..::.String
The book code of the part to check for.
pageReference
Type: System..::.String
The page reference of the part to check for.
itemId
Type: System..::.String
The item id of the part to check for.

Return Value

true if a part with the given codes is present in the collection.

See Also

PartCollection Class
Contains Overload
Mincom.LinkOne.Dom.SelectionList Namespace


FindPart Method

[image]

LinkOne WebView API
PartCollection..::.FindPart Method
PartCollection Class See Also Send Feedback
Finds the first occurance of a part that matches the publisher code, book code, page reference, item id and item index.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IPart FindPart(
    string publisherCode,
    string bookCode,
    string pageReference,
    string itemId,
    int itemIndex
)
Visual Basic (Declaration)
Public Function FindPart ( _
    publisherCode As String, _
    bookCode As String, _
    pageReference As String, _
    itemId As String, _
    itemIndex As Integer _
) As IPart
Visual C++
public:
IPart^ FindPart(
    String^ publisherCode,
    String^ bookCode,
    String^ pageReference,
    String^ itemId,
    int itemIndex
)

Parameters

publisherCode
Type: System..::.String
The publisher code.
bookCode
Type: System..::.String
The book code.
pageReference
Type: System..::.String
The page reference.
itemId
Type: System..::.String
The item id.
itemIndex
Type: System..::.Int32
Index of the item.

Return Value

The first occurance of a part that matches the publisher code, book code, page reference, item id and item index, or null if not found.

See Also

PartCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


Sort Method

[image]

LinkOne WebView API
PartCollection..::.Sort Method
PartCollection Class See Also Send Feedback
Sorts the parts and returns a new collection with the same parts.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PartCollection Sort(
    string fieldName,
    bool ascending
)
Visual Basic (Declaration)
Public Function Sort ( _
    fieldName As String, _
    ascending As Boolean _
) As PartCollection
Visual C++
public:
PartCollection^ Sort(
    String^ fieldName,
    bool ascending
)

Parameters

fieldName
Type: System..::.String
The field name to sort on
ascending
Type: System..::.Boolean
true to sort asending; false to sort descending.

Return Value

The sorted collection of parts.

See Also

PartCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


PartCollection Properties

[image] [image]

LinkOne WebView API
PartCollection Properties
PartCollection Class See Also Send Feedback

The PartCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IPart >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( IPart >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IPart >)>).)

Explicit Interface Implementations

Name | Description
IList..::.IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection<(Of <( IPart >)>).)
System#Collections#Generic#ICollection{T}#IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from Collection<(Of <( IPart >)>).)
IList..::.IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection<(Of <( IPart >)>).)
ICollection..::.IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection<(Of <( IPart >)>).)
IList..::.Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( IPart >)>).)
ICollection..::.SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection<(Of <( IPart >)>).)

See Also

PartCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


PartEventArgs Class

[image]

LinkOne WebView API
PartEventArgs Class
Members See Also Send Feedback
Provides data for the PartEventHandler events.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public sealed class PartEventArgs : EventArgs
Visual Basic (Declaration)
Public NotInheritable Class PartEventArgs _
    Inherits EventArgs
Visual C++
public ref class PartEventArgs sealed : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Mincom.LinkOne.Dom.SelectionList..::.PartEventArgs

See Also

PartEventArgs Members
Mincom.LinkOne.Dom.SelectionList Namespace


PartEventArgs Members

[image] [image]

LinkOne WebView API
PartEventArgs Members
PartEventArgs Class Constructors Methods Properties See Also Send Feedback

The PartEventArgs type exposes the following members.

Constructors

Name | Description
PartEventArgs | Constructor.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Part | Gets the part associated with the event.

See Also

PartEventArgs Class
Mincom.LinkOne.Dom.SelectionList Namespace


PartEventArgs Constructor

[image]

LinkOne WebView API
PartEventArgs Constructor
PartEventArgs Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PartEventArgs(
    IPart part
)
Visual Basic (Declaration)
Public Sub New ( _
    part As IPart _
)
Visual C++
public:
PartEventArgs(
    IPart^ part
)

Parameters

part
Type: Mincom.LinkOne.Dom.SelectionList..::.IPart
The part that relates to the event.

See Also

PartEventArgs Class
Mincom.LinkOne.Dom.SelectionList Namespace


PartEventArgs Methods

[image] [image]

LinkOne WebView API
PartEventArgs Methods
PartEventArgs Class See Also Send Feedback

The PartEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PartEventArgs Class
Mincom.LinkOne.Dom.SelectionList Namespace


PartEventArgs Properties

[image] [image]

LinkOne WebView API
PartEventArgs Properties
PartEventArgs Class See Also Send Feedback

The PartEventArgs type exposes the following members.

Properties

Name | Description
Part | Gets the part associated with the event.

See Also

PartEventArgs Class
Mincom.LinkOne.Dom.SelectionList Namespace


Part Property

[image]

LinkOne WebView API
PartEventArgs..::.Part Property
PartEventArgs Class See Also Send Feedback
Gets the part associated with the event.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IPart Part { get; }
Visual Basic (Declaration)
Public ReadOnly Property Part As IPart
Visual C++
public:
property IPart^ Part {
    IPart^ get ();
}

See Also

PartEventArgs Class
Mincom.LinkOne.Dom.SelectionList Namespace


PartEventHandler Delegate

[image]

LinkOne WebView API
PartEventHandler Delegate
See Also Send Feedback
Delegate for part events.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public delegate void PartEventHandler(
    Object sender,
    PartEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub PartEventHandler ( _
    sender As Object, _
    e As PartEventArgs _
)
Visual C++
public delegate void PartEventHandler(
    Object^ sender,
    PartEventArgs^ e
)

Parameters

sender
Type: System..::.Object
e
Type: Mincom.LinkOne.Dom.SelectionList..::.PartEventArgs

See Also

Mincom.LinkOne.Dom.SelectionList Namespace


SelectionList Class

[image]

LinkOne WebView API
SelectionList Class
Members See Also Send Feedback
Represents a simple selection list class.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public class SelectionList : ISelectionList2,
    ISelectionList, INotifyChanged
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class SelectionList _
    Implements ISelectionList2, ISelectionList, INotifyChanged
Visual C++
[SerializableAttribute]
public ref class SelectionList : ISelectionList2,
    ISelectionList, INotifyChanged

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.SelectionList..::.SelectionList

See Also

SelectionList Members
Mincom.LinkOne.Dom.SelectionList Namespace


SelectionList Members

[image] [image]

LinkOne WebView API
SelectionList Members
SelectionList Class Constructors Methods Properties Events Explicit Interface Implementations See Also Send Feedback

The SelectionList type exposes the following members.

Constructors

Name | Description
SelectionList | Overloaded.

Methods

Name | Description
CreatePart | Create a new instance of IPart, mapped to the specified LinkOne book location.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
Initialize | Initialises any properties on the instance.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | Fires the Changed event.
Preserve |
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Attributes | Gets the selection list attributes.
Columns | Gets the collection of Column objects that define columns in the selection list.
Errors | A list of exceptions from loading this selection list.
Filtered | Gets or sets the filtered state of the selection list.
FilteredLock | Gets or sets the lock on the filtered state of the selection list.
HasChanged | Gets or sets true if the selection list has changed.
Key | Gets a key representing the selection list.
Layouts | Gets the default layout for the selection list.
Location | Gets or sets the selection list location.
Name | Gets or sets the name of the selection list.
Parts | Gets the collection of IPart objects that have been added to the selection list.
Source | Gets the source of the selection list.
Status | Gets or sets the status of the selection list for use in any workflow processing.

Events

Name | Description
Changed | Occurs when the selection list has changed.

Explicit Interface Implementations

Name | Description
ISelectionList..::.Columns |
ISelectionList..::.CreatePart |
ISelectionList..::.Errors |
ISelectionList..::.Layouts |
ISelectionList..::.Parts |

See Also

SelectionList Class
Mincom.LinkOne.Dom.SelectionList Namespace


SelectionList Constructor

[image] [image]

LinkOne WebView API
SelectionList Constructor
SelectionList Class See Also Send Feedback

Overload List

Name | Description
SelectionList()()() | Initializes a new instance of SelectionList.
SelectionList(Boolean) | Initializes a new instance of SelectionList.

See Also

SelectionList Class
SelectionList Members
Mincom.LinkOne.Dom.SelectionList Namespace


SelectionList Constructor

[image]

LinkOne WebView API
SelectionList Constructor
SelectionList Class See Also Send Feedback
Initializes a new instance of SelectionList.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SelectionList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SelectionList()

See Also

SelectionList Class
SelectionList Overload
Mincom.LinkOne.Dom.SelectionList Namespace


SelectionList Constructor (Boolean)

[image]

LinkOne WebView API
SelectionList Constructor (Boolean)
SelectionList Class See Also Send Feedback
Initializes a new instance of SelectionList.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected SelectionList(
    bool WithEvents
)
Visual Basic (Declaration)
Protected Sub New ( _
    WithEvents As Boolean _
)
Visual C++
protected:
SelectionList(
    bool WithEvents
)

Parameters

WithEvents
Type: System..::.Boolean

See Also

SelectionList Class
SelectionList Overload
Mincom.LinkOne.Dom.SelectionList Namespace


SelectionList Methods

[image] [image]

LinkOne WebView API
SelectionList Methods
SelectionList Class See Also Send Feedback

The SelectionList type exposes the following members.

Methods

Name | Description
CreatePart | Create a new instance of IPart, mapped to the specified LinkOne book location.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
Initialize | Initialises any properties on the instance.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | Fires the Changed event.
Preserve |
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ISelectionList..::.CreatePart |

See Also

SelectionList Class
Mincom.LinkOne.Dom.SelectionList Namespace


CreatePart Method

[image]

LinkOne WebView API
SelectionList..::.CreatePart Method
SelectionList Class See Also Send Feedback
Create a new instance of IPart, mapped to the specified LinkOne book location.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public virtual IPart CreatePart(
    Book book,
    Page page,
    Entry entry
)
Visual Basic (Declaration)
Public Overridable Function CreatePart ( _
    book As Book, _
    page As Page, _
    entry As Entry _
) As IPart
Visual C++
public:
virtual IPart^ CreatePart(
    Book^ book,
    Page^ page,
    Entry^ entry
)

Parameters

book
Type: Mincom.LinkOne.Dom..::.Book
The book containg the part. Can be null if page and entry are null.
page
Type: Mincom.LinkOne.Dom..::.Page
The page containing the part. Can be null if entry is null.
entry
Type: Mincom.LinkOne.Dom..::.Entry
The parts list entry that contains the part. Can be null.

Return Value

A new instance of IPart.

See Also

SelectionList Class
Mincom.LinkOne.Dom.SelectionList Namespace


Initialize Method

[image]

LinkOne WebView API
SelectionList..::.Initialize Method
SelectionList Class See Also Send Feedback
Initialises any properties on the instance.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected virtual void Initialize()
Visual Basic (Declaration)
Protected Overridable Sub Initialize
Visual C++
protected:
virtual void Initialize()

Remarks

Thisi is essentially for derived classes to initialise themselves so that the base class can use its content.

See Also

SelectionList Class
Mincom.LinkOne.Dom.SelectionList Namespace


ISelectionList.CreatePart Method

[image]

LinkOne WebView API
SelectionList..::.ISelectionList..::.CreatePart Method
SelectionList Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPart ISelectionList.CreatePart(
    IBook book,
    IPage page,
    IEntry entry
)
Visual Basic (Declaration)
Private Function CreatePart ( _
    book As IBook, _
    page As IPage, _
    entry As IEntry _
) As IPart Implements ISelectionList.CreatePart
Visual C++
private:
virtual IPart^ CreatePart(
    IBook^ book,
    IPage^ page,
    IEntry^ entry
) sealed = ISelectionList::CreatePart

Parameters

book
Type: Mincom.LinkOne.Dom..::.IBook
page
Type: Mincom.LinkOne.Dom..::.IPage
entry
Type: Mincom.LinkOne.Dom..::.IEntry

Implements

ISelectionList..::.CreatePart(IBook, IPage, IEntry)

See Also

SelectionList Class
Mincom.LinkOne.Dom.SelectionList Namespace


OnChanged Method

[image]

LinkOne WebView API
SelectionList..::.OnChanged Method
SelectionList Class See Also Send Feedback
Fires the Changed event.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected virtual void OnChanged(
    SelectionList initialList
)
Visual Basic (Declaration)
Protected Overridable Sub OnChanged ( _
    initialList As SelectionList _
)
Visual C++
protected:
virtual void OnChanged(
    SelectionList^ initialList
)

Parameters

initialList
Type: Mincom.LinkOne.Dom.SelectionList..::.SelectionList

See Also

SelectionList Class
Mincom.LinkOne.Dom.SelectionList Namespace


Preserve Method

[image]

LinkOne WebView API
SelectionList..::.Preserve Method
SelectionList Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Preserve()
Visual Basic (Declaration)
Public Sub Preserve
Visual C++
public:
void Preserve()

See Also

SelectionList Class
Mincom.LinkOne.Dom.SelectionList Namespace


SelectionList Properties

[image] [image]

LinkOne WebView API
SelectionList Properties
SelectionList Class See Also Send Feedback

The SelectionList type exposes the following members.

Properties

Name | Description
Attributes | Gets the selection list attributes.
Columns | Gets the collection of Column objects that define columns in the selection list.
Errors | A list of exceptions from loading this selection list.
Filtered | Gets or sets the filtered state of the selection list.
FilteredLock | Gets or sets the lock on the filtered state of the selection list.
HasChanged | Gets or sets true if the selection list has changed.
Key | Gets a key representing the selection list.
Layouts | Gets the default layout for the selection list.
Location | Gets or sets the selection list location.
Name | Gets or sets the name of the selection list.
Parts | Gets the collection of IPart objects that have been added to the selection list.
Source | Gets the source of the selection list.
Status | Gets or sets the status of the selection list for use in any workflow processing.

Explicit Interface Implementations

Name | Description
ISelectionList..::.Columns |
ISelectionList..::.Errors |
ISelectionList..::.Layouts |
ISelectionList..::.Parts |

See Also

SelectionList Class
Mincom.LinkOne.Dom.SelectionList Namespace


Attributes Property

[image]

LinkOne WebView API
SelectionList..::.Attributes Property
SelectionList Class See Also Send Feedback
Gets the selection list attributes.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Dictionary<string, string> Attributes { get; }
Visual Basic (Declaration)
Public ReadOnly Property Attributes As Dictionary(Of String, String)
Visual C++
public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () sealed;
}

Implements

ISelectionList2..::.Attributes

Remarks

Adding, removing or editing attributes does not trigger the Changed event

See Also

SelectionList Class
Mincom.LinkOne.Dom.SelectionList Namespace


Columns Property

[image]

LinkOne WebView API
SelectionList..::.Columns Property
SelectionList Class See Also Send Feedback
Gets the collection of Column objects that define columns in the selection list.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public virtual ColumnCollection Columns { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Columns As ColumnCollection
Visual C++
public:
virtual property ColumnCollection^ Columns {
    ColumnCollection^ get ();
}

See Also

SelectionList Class
Mincom.LinkOne.Dom.SelectionList Namespace


Errors Property

[image]

LinkOne WebView API
SelectionList..::.Errors Property
SelectionList Class See Also Send Feedback
A list of exceptions from loading this selection list.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IList<Exception> Errors { get; }
Visual Basic (Declaration)
Public ReadOnly Property Errors As IList(Of Exception)
Visual C++
public:
property IList<Exception^>^ Errors {
    IList<Exception^>^ get ();
}

See Also

SelectionList Class
Mincom.LinkOne.Dom.SelectionList Namespace


Filtered Property

[image]

LinkOne WebView API
SelectionList..::.Filtered Property
SelectionList Class See Also Send Feedback
Gets or sets the filtered state of the selection list.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Filtered { get; set; }
Visual Basic (Declaration)
Public Property Filtered As Boolean
Visual C++
public:
virtual property bool Filtered {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

ISelectionList..::.Filtered

See Also

SelectionList Class
Mincom.LinkOne.Dom.SelectionList Namespace


FilteredLock Property

[image]

LinkOne WebView API
SelectionList..::.FilteredLock Property
SelectionList Class See Also Send Feedback
Gets or sets the lock on the filtered state of the selection list.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool FilteredLock { get; set; }
Visual Basic (Declaration)
Public Property FilteredLock As Boolean
Visual C++
public:
virtual property bool FilteredLock {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

ISelectionList..::.FilteredLock

See Also

SelectionList Class
Mincom.LinkOne.Dom.SelectionList Namespace


HasChanged Property

[image]

LinkOne WebView API
SelectionList..::.HasChanged Property
SelectionList Class See Also Send Feedback
Gets or sets true if the selection list has changed.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool HasChanged { get; set; }
Visual Basic (Declaration)
Public Property HasChanged As Boolean
Visual C++
public:
virtual property bool HasChanged {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

ISelectionList..::.HasChanged

Remarks

This property is set true whenever the selection list or it's columns or parts or a part's fields are changed.

See Also

SelectionList Class
Mincom.LinkOne.Dom.SelectionList Namespace


ISelectionList.Columns Property

[image]

LinkOne WebView API
SelectionList..::.ISelectionList..::.Columns Property
SelectionList Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IColumnCollection ISelectionList.Columns { get; }
Visual Basic (Declaration)
Private ReadOnly Property Columns As IColumnCollection
    Implements ISelectionList.Columns
Visual C++
private:
virtual property IColumnCollection^ Columns {
    IColumnCollection^ get () sealed = ISelectionList::Columns::get;
}

Implements

ISelectionList..::.Columns

See Also

SelectionList Class
Mincom.LinkOne.Dom.SelectionList Namespace


ISelectionList.Errors Property

[image]

LinkOne WebView API
SelectionList..::.ISelectionList..::.Errors Property
SelectionList Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IList<Exception> ISelectionList.Errors { get; }
Visual Basic (Declaration)
Private ReadOnly Property Errors As IList(Of Exception)
    Implements ISelectionList.Errors
Visual C++
private:
virtual property IList<Exception^>^ Errors {
    IList<Exception^>^ get () sealed = ISelectionList::Errors::get;
}

Implements

ISelectionList..::.Errors

See Also

SelectionList Class
Mincom.LinkOne.Dom.SelectionList Namespace


ISelectionList.Layouts Property

[image]

LinkOne WebView API
SelectionList..::.ISelectionList..::.Layouts Property
SelectionList Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ILayoutCollection ISelectionList.Layouts { get; }
Visual Basic (Declaration)
Private ReadOnly Property Layouts As ILayoutCollection
    Implements ISelectionList.Layouts
Visual C++
private:
virtual property ILayoutCollection^ Layouts {
    ILayoutCollection^ get () sealed = ISelectionList::Layouts::get;
}

Implements

ISelectionList..::.Layouts

See Also

SelectionList Class
Mincom.LinkOne.Dom.SelectionList Namespace


ISelectionList.Parts Property

[image]

LinkOne WebView API
SelectionList..::.ISelectionList..::.Parts Property
SelectionList Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPartCollection ISelectionList.Parts { get; }
Visual Basic (Declaration)
Private ReadOnly Property Parts As IPartCollection
    Implements ISelectionList.Parts
Visual C++
private:
virtual property IPartCollection^ Parts {
    IPartCollection^ get () sealed = ISelectionList::Parts::get;
}

Implements

ISelectionList..::.Parts

See Also

SelectionList Class
Mincom.LinkOne.Dom.SelectionList Namespace


Key Property

[image]

LinkOne WebView API
SelectionList..::.Key Property
SelectionList Class See Also Send Feedback
Gets a key representing the selection list.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Key { get; }
Visual Basic (Declaration)
Public ReadOnly Property Key As String
Visual C++
public:
property String^ Key {
    String^ get ();
}

Remarks

The format is FileName if the layout is a user selection list, otherwise it is a blank string because the selection list is predefined.

See Also

SelectionList Class
Mincom.LinkOne.Dom.SelectionList Namespace


Layouts Property

[image]

LinkOne WebView API
SelectionList..::.Layouts Property
SelectionList Class See Also Send Feedback
Gets the default layout for the selection list.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LayoutCollection Layouts { get; }
Visual Basic (Declaration)
Public ReadOnly Property Layouts As LayoutCollection
Visual C++
public:
property LayoutCollection^ Layouts {
    LayoutCollection^ get ();
}

See Also

SelectionList Class
Mincom.LinkOne.Dom.SelectionList Namespace


Location Property

[image]

LinkOne WebView API
SelectionList..::.Location Property
SelectionList Class See Also Send Feedback
Gets or sets the selection list location.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Location { get; set; }
Visual Basic (Declaration)
Public Property Location As String
Visual C++
public:
virtual property String^ Location {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ISelectionList..::.Location

See Also

SelectionList Class
Mincom.LinkOne.Dom.SelectionList Namespace


Name Property

[image]

LinkOne WebView API
SelectionList..::.Name Property
SelectionList Class See Also Send Feedback
Gets or sets the name of the selection list.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ISelectionList..::.Name

See Also

SelectionList Class
Mincom.LinkOne.Dom.SelectionList Namespace


Parts Property

[image]

LinkOne WebView API
SelectionList..::.Parts Property
SelectionList Class See Also Send Feedback
Gets the collection of IPart objects that have been added to the selection list.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public virtual PartCollection Parts { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Parts As PartCollection
Visual C++
public:
virtual property PartCollection^ Parts {
    PartCollection^ get ();
}

See Also

SelectionList Class
Mincom.LinkOne.Dom.SelectionList Namespace


Source Property

[image]

LinkOne WebView API
SelectionList..::.Source Property
SelectionList Class See Also Send Feedback
Gets the source of the selection list.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SelectionList..::.SourceType Source { get; internal set; }
Visual Basic (Declaration)
Public Property Source As SelectionList..::.SourceType
Visual C++
public:
property SelectionList..::.SourceType Source {
    SelectionList..::.SourceType get ();
    void set (SelectionList..::.SourceType value);
}

See Also

SelectionList Class
Mincom.LinkOne.Dom.SelectionList Namespace


Status Property

[image]

LinkOne WebView API
SelectionList..::.Status Property
SelectionList Class See Also Send Feedback
Gets or sets the status of the selection list for use in any workflow processing.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Status { get; set; }
Visual Basic (Declaration)
Public Property Status As String
Visual C++
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}

Remarks

This is a status only for external business logic and does not directly affect the selection list behavior.

See Also

SelectionList Class
Mincom.LinkOne.Dom.SelectionList Namespace


SelectionList Events

[image] [image]

LinkOne WebView API
SelectionList Events
SelectionList Class See Also Send Feedback

The SelectionList type exposes the following members.

Events

Name | Description
Changed | Occurs when the selection list has changed.

See Also

SelectionList Class
Mincom.LinkOne.Dom.SelectionList Namespace


Changed Event

[image]

LinkOne WebView API
SelectionList..::.Changed Event
SelectionList Class See Also Send Feedback
Occurs when the selection list has changed.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public event EventHandler Changed
Visual Basic (Declaration)
Public Event Changed As EventHandler
Visual C++
public:
virtual  event EventHandler^ Changed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Implements

INotifyChanged..::.Changed

See Also

SelectionList Class
Mincom.LinkOne.Dom.SelectionList Namespace


SelectionList.SourceType Enumeration

[image]

LinkOne WebView API
SelectionList..::.SourceType Enumeration
SelectionList Class See Also Send Feedback
The source of the selection list.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum SourceType
Visual Basic (Declaration)
Public Enumeration SourceType
Visual C++
public enum class SourceType

Members

Member name | Description
Predefined | The selection list is predefined by LinkOne.
User | The selection list is from the user.

See Also

Mincom.LinkOne.Dom.SelectionList Namespace


SelectionListCollection Class

[image]

LinkOne WebView API
SelectionListCollection Class
Members See Also Send Feedback
Represents a collection of SelectionList objects.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class SelectionListCollection : LiveCollection<SelectionList>,
    IList<SelectionList>, ICollection<SelectionList>, IEnumerable<SelectionList>,
    ISelectionListCollection, IList<ISelectionList>, ICollection<ISelectionList>,
    IEnumerable<ISelectionList>, IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class SelectionListCollection _
    Inherits LiveCollection(Of SelectionList) _
    Implements IList(Of SelectionList), ICollection(Of SelectionList),  _
    IEnumerable(Of SelectionList), ISelectionListCollection, IList(Of ISelectionList),  _
    ICollection(Of ISelectionList), IEnumerable(Of ISelectionList), IEnumerable
Visual C++
[SerializableAttribute]
public ref class SelectionListCollection sealed : public LiveCollection<SelectionList^>,
    IList<SelectionList^>, ICollection<SelectionList^>, IEnumerable<SelectionList^>,
    ISelectionListCollection, IList<ISelectionList^>, ICollection<ISelectionList^>,
    IEnumerable<ISelectionList^>, IEnumerable

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection<(Of <( SelectionList >)>)
LiveCollection<(Of <( SelectionList >)>)
Mincom.LinkOne.Dom.SelectionList..::.SelectionListCollection

See Also

SelectionListCollection Members
Mincom.LinkOne.Dom.SelectionList Namespace


SelectionListCollection Members

[image] [image]

LinkOne WebView API
SelectionListCollection Members
SelectionListCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The SelectionListCollection type exposes the following members.

Constructors

Name | Description
SelectionListCollection | Initializes a new instance of the SelectionListCollection class.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SelectionList >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SelectionList >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SelectionList >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SelectionList >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( SelectionList >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SelectionList >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSelectionList | Gets the selection list with the given id, or the predefined selection list if an exact match is not found.
GetSorted | Returns a sorted collection of the selection lists.
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SelectionList >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( SelectionList >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( SelectionList >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SelectionList >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SelectionList >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SelectionList >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( SelectionList >)>).)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SelectionList >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( SelectionList >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SelectionList >)>).)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds an item to the IList. (Inherited from Collection<(Of <( SelectionList >)>).)
ICollection<(Of <(ISelectionList>)>)..::.Add |
ICollection<(Of <(ISelectionList>)>)..::.Clear |
IList..::.Contains | Determines whether the IList contains a specific value. (Inherited from Collection<(Of <( SelectionList >)>).)
ICollection<(Of <(ISelectionList>)>)..::.Contains |
ICollection..::.CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection<(Of <( SelectionList >)>).)
ICollection<(Of <(ISelectionList>)>)..::.CopyTo |
ICollection<(Of <(ISelectionList>)>)..::.Count |
ISelectionListCollection..::.Create | Creates a selection list.
IEnumerable<(Of <(ISelectionList>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator |
IList..::.IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection<(Of <( SelectionList >)>).)
IList<(Of <(ISelectionList>)>)..::.IndexOf |
IList..::.Insert | Inserts an item into the IList at the specified index. (Inherited from Collection<(Of <( SelectionList >)>).)
IList<(Of <(ISelectionList>)>)..::.Insert |
IList..::.IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection<(Of <( SelectionList >)>).)
IsReadOnly | Overloaded.
IList..::.IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection<(Of <( SelectionList >)>).)
ICollection..::.IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection<(Of <( SelectionList >)>).)
IList..::.Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( SelectionList >)>).)
IList<(Of <(ISelectionList>)>)..::.Item |
IList..::.Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection<(Of <( SelectionList >)>).)
ICollection<(Of <(ISelectionList>)>)..::.Remove |
IList<(Of <(ISelectionList>)>)..::.RemoveAt |
ICollection..::.SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection<(Of <( SelectionList >)>).)

See Also

SelectionListCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


SelectionListCollection Constructor

[image]

LinkOne WebView API
SelectionListCollection Constructor
SelectionListCollection Class See Also Send Feedback
Initializes a new instance of the SelectionListCollection class.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SelectionListCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SelectionListCollection()

See Also

SelectionListCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


SelectionListCollection Methods

[image] [image]

LinkOne WebView API
SelectionListCollection Methods
SelectionListCollection Class See Also Send Feedback

The SelectionListCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SelectionList >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SelectionList >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SelectionList >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SelectionList >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( SelectionList >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SelectionList >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSelectionList | Gets the selection list with the given id, or the predefined selection list if an exact match is not found.
GetSorted | Returns a sorted collection of the selection lists.
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SelectionList >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( SelectionList >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( SelectionList >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SelectionList >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SelectionList >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SelectionList >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( SelectionList >)>).)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds an item to the IList. (Inherited from Collection<(Of <( SelectionList >)>).)
ICollection<(Of <(ISelectionList>)>)..::.Add |
ICollection<(Of <(ISelectionList>)>)..::.Clear |
IList..::.Contains | Determines whether the IList contains a specific value. (Inherited from Collection<(Of <( SelectionList >)>).)
ICollection<(Of <(ISelectionList>)>)..::.Contains |
ICollection..::.CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection<(Of <( SelectionList >)>).)
ICollection<(Of <(ISelectionList>)>)..::.CopyTo |
ISelectionListCollection..::.Create | Creates a selection list.
IEnumerable<(Of <(ISelectionList>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator |
IList..::.IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection<(Of <( SelectionList >)>).)
IList<(Of <(ISelectionList>)>)..::.IndexOf |
IList..::.Insert | Inserts an item into the IList at the specified index. (Inherited from Collection<(Of <( SelectionList >)>).)
IList<(Of <(ISelectionList>)>)..::.Insert |
IList..::.Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection<(Of <( SelectionList >)>).)
ICollection<(Of <(ISelectionList>)>)..::.Remove |
IList<(Of <(ISelectionList>)>)..::.RemoveAt |

See Also

SelectionListCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


ICollection(ISelectionList).Add Method

[image]

LinkOne WebView API
SelectionListCollection..::.ICollection<(Of <(ISelectionList>)>)..::.Add Method
SelectionListCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<ISelectionList>.Add(
    ISelectionList item
)
Visual Basic (Declaration)
Private Sub Add ( _
    item As ISelectionList _
) Implements ICollection(Of ISelectionList).Add
Visual C++
private:
virtual void Add(
    ISelectionList^ item
) sealed = ICollection<ISelectionList^>::Add

Parameters

item
Type: Mincom.LinkOne.Dom.SelectionList..::.ISelectionList

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

SelectionListCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


ICollection(ISelectionList).Clear Method

[image]

LinkOne WebView API
SelectionListCollection..::.ICollection<(Of <(ISelectionList>)>)..::.Clear Method
SelectionListCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<ISelectionList>.Clear()
Visual Basic (Declaration)
Private Sub Clear Implements ICollection(Of ISelectionList).Clear
Visual C++
private:
virtual void Clear() sealed = ICollection<ISelectionList^>::Clear

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

See Also

SelectionListCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


ICollection(ISelectionList).Contains Method

[image]

LinkOne WebView API
SelectionListCollection..::.ICollection<(Of <(ISelectionList>)>)..::.Contains Method
SelectionListCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<ISelectionList>.Contains(
    ISelectionList item
)
Visual Basic (Declaration)
Private Function Contains ( _
    item As ISelectionList _
) As Boolean Implements ICollection(Of ISelectionList).Contains
Visual C++
private:
virtual bool Contains(
    ISelectionList^ item
) sealed = ICollection<ISelectionList^>::Contains

Parameters

item
Type: Mincom.LinkOne.Dom.SelectionList..::.ISelectionList

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

SelectionListCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


ICollection(ISelectionList).CopyTo Method

[image]

LinkOne WebView API
SelectionListCollection..::.ICollection<(Of <(ISelectionList>)>)..::.CopyTo Method
SelectionListCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void ICollection<ISelectionList>.CopyTo(
    ISelectionList[] array,
    int arrayIndex
)
Visual Basic (Declaration)
Private Sub CopyTo ( _
    array As ISelectionList(), _
    arrayIndex As Integer _
) Implements ICollection(Of ISelectionList).CopyTo
Visual C++
private:
virtual void CopyTo(
    array<ISelectionList^>^ array,
    int arrayIndex
) sealed = ICollection<ISelectionList^>::CopyTo

Parameters

array
Type: array< Mincom.LinkOne.Dom.SelectionList..::.ISelectionList >[]()[]
arrayIndex
Type: System..::.Int32

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

SelectionListCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


IEnumerable(ISelectionList).GetEnumerator Method

[image]

LinkOne WebView API
SelectionListCollection..::.IEnumerable<(Of <(ISelectionList>)>)..::.GetEnumerator Method
SelectionListCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator<ISelectionList> IEnumerable<ISelectionList>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of ISelectionList)
    Implements IEnumerable(Of ISelectionList).GetEnumerator
Visual C++
private:
virtual IEnumerator<ISelectionList^>^ GetEnumerator() sealed = IEnumerable<ISelectionList^>::GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

SelectionListCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
SelectionListCollection..::.IEnumerable..::.GetEnumerator Method
SelectionListCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Implements

IEnumerable..::.GetEnumerator()()()

See Also

SelectionListCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


IList(ISelectionList).IndexOf Method

[image]

LinkOne WebView API
SelectionListCollection..::.IList<(Of <(ISelectionList>)>)..::.IndexOf Method
SelectionListCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int IList<ISelectionList>.IndexOf(
    ISelectionList item
)
Visual Basic (Declaration)
Private Function IndexOf ( _
    item As ISelectionList _
) As Integer Implements IList(Of ISelectionList).IndexOf
Visual C++
private:
virtual int IndexOf(
    ISelectionList^ item
) sealed = IList<ISelectionList^>::IndexOf

Parameters

item
Type: Mincom.LinkOne.Dom.SelectionList..::.ISelectionList

Implements

IList<(Of <(T>)>)..::.IndexOf(T)

See Also

SelectionListCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


IList(ISelectionList).Insert Method

[image]

LinkOne WebView API
SelectionListCollection..::.IList<(Of <(ISelectionList>)>)..::.Insert Method
SelectionListCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void IList<ISelectionList>.Insert(
    int index,
    ISelectionList item
)
Visual Basic (Declaration)
Private Sub Insert ( _
    index As Integer, _
    item As ISelectionList _
) Implements IList(Of ISelectionList).Insert
Visual C++
private:
virtual void Insert(
    int index,
    ISelectionList^ item
) sealed = IList<ISelectionList^>::Insert

Parameters

index
Type: System..::.Int32
item
Type: Mincom.LinkOne.Dom.SelectionList..::.ISelectionList

Implements

IList<(Of <(T>)>)..::.Insert(Int32, T)

See Also

SelectionListCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


ICollection(ISelectionList).Remove Method

[image]

LinkOne WebView API
SelectionListCollection..::.ICollection<(Of <(ISelectionList>)>)..::.Remove Method
SelectionListCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<ISelectionList>.Remove(
    ISelectionList item
)
Visual Basic (Declaration)
Private Function Remove ( _
    item As ISelectionList _
) As Boolean Implements ICollection(Of ISelectionList).Remove
Visual C++
private:
virtual bool Remove(
    ISelectionList^ item
) sealed = ICollection<ISelectionList^>::Remove

Parameters

item
Type: Mincom.LinkOne.Dom.SelectionList..::.ISelectionList

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

SelectionListCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


IList(ISelectionList).RemoveAt Method

[image]

LinkOne WebView API
SelectionListCollection..::.IList<(Of <(ISelectionList>)>)..::.RemoveAt Method
SelectionListCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
void IList<ISelectionList>.RemoveAt(
    int index
)
Visual Basic (Declaration)
Private Sub RemoveAt ( _
    index As Integer _
) Implements IList(Of ISelectionList).RemoveAt
Visual C++
private:
virtual void RemoveAt(
    int index
) sealed = IList<ISelectionList^>::RemoveAt

Parameters

index
Type: System..::.Int32

Implements

IList<(Of <(T>)>)..::.RemoveAt(Int32)

See Also

SelectionListCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


GetSelectionList Method

[image]

LinkOne WebView API
SelectionListCollection..::.GetSelectionList Method
SelectionListCollection Class See Also Send Feedback
Gets the selection list with the given id, or the predefined selection list if an exact match is not found.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SelectionList GetSelectionList(
    string id
)
Visual Basic (Declaration)
Public Function GetSelectionList ( _
    id As String _
) As SelectionList
Visual C++
public:
SelectionList^ GetSelectionList(
    String^ id
)

Parameters

id
Type: System..::.String
The id of the required selection list.

Return Value

The wanted selection list, or the predefined selection list if the selection list was not found.

See Also

SelectionListCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


GetSorted Method

[image]

LinkOne WebView API
SelectionListCollection..::.GetSorted Method
SelectionListCollection Class See Also Send Feedback
Returns a sorted collection of the selection lists.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SelectionListCollection GetSorted()
Visual Basic (Declaration)
Public Function GetSorted As SelectionListCollection
Visual C++
public:
SelectionListCollection^ GetSorted()

Return Value

A sorted collection of the selection lists.

See Also

SelectionListCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


ISelectionListCollection.Create Method

[image]

LinkOne WebView API
SelectionListCollection..::.ISelectionListCollection..::.Create Method
SelectionListCollection Class See Also Send Feedback
Creates a selection list.

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ISelectionList ISelectionListCollection.Create()
Visual Basic (Declaration)
Private Function Create As ISelectionList Implements ISelectionListCollection.Create
Visual C++
private:
virtual ISelectionList^ Create() sealed = ISelectionListCollection::Create

Return Value

A new ISelectionList.

Implements

ISelectionListCollection..::.Create()()()

See Also

SelectionListCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


SelectionListCollection Properties

[image] [image]

LinkOne WebView API
SelectionListCollection Properties
SelectionListCollection Class See Also Send Feedback

The SelectionListCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SelectionList >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( SelectionList >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( SelectionList >)>).)

Explicit Interface Implementations

Name | Description
ICollection<(Of <(ISelectionList>)>)..::.Count |
IList..::.IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection<(Of <( SelectionList >)>).)
IsReadOnly | Overloaded.
IList..::.IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection<(Of <( SelectionList >)>).)
ICollection..::.IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection<(Of <( SelectionList >)>).)
IList..::.Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( SelectionList >)>).)
IList<(Of <(ISelectionList>)>)..::.Item |
ICollection..::.SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection<(Of <( SelectionList >)>).)

See Also

SelectionListCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


ICollection(ISelectionList).Count Property

[image]

LinkOne WebView API
SelectionListCollection..::.ICollection<(Of <(ISelectionList>)>)..::.Count Property
SelectionListCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
int ICollection<ISelectionList>.Count { get; }
Visual Basic (Declaration)
Private ReadOnly Property Count As Integer
    Implements ICollection(Of ISelectionList).Count
Visual C++
private:
virtual property int Count {
    int get () sealed = ICollection<ISelectionList^>::Count::get;
}

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

SelectionListCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


IList(ISelectionList).Item Property

[image]

LinkOne WebView API
SelectionListCollection..::.IList<(Of <(ISelectionList>)>)..::.Item Property
SelectionListCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
ISelectionList IList<ISelectionList>.Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Private Property Item ( _
    index As Integer _
) As ISelectionList Implements IList(Of ISelectionList).Item
Visual C++
private:
virtual property ISelectionList^ Item[int index] {
    ISelectionList^ get (int index) sealed = IList<ISelectionList^>::Item::get;
    void set (int index, ISelectionList^ value) sealed = IList<ISelectionList^>::Item::set;
}

Parameters

index
Type: System..::.Int32

Implements

IList<(Of <(T>)>)..::.Item[([(Int32])])

See Also

SelectionListCollection Class
Mincom.LinkOne.Dom.SelectionList Namespace


IsReadOnly Property

[image] [image]

LinkOne WebView API
SelectionListCollection..::.IsReadOnly Property
SelectionListCollection Class See Also Send Feedback

Overload List

Name | Description
System#Collections#Generic#ICollection{T}#IsReadOnly()()() | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from Collection<(Of <( SelectionList >)>).)
ICollection<(Of <(ISelectionList>)>)..::.IsReadOnly |

See Also

SelectionListCollection Class
SelectionListCollection Members
Mincom.LinkOne.Dom.SelectionList Namespace


ICollection(ISelectionList).IsReadOnly Property

[image]

LinkOne WebView API
SelectionListCollection..::.ICollection<(Of <(ISelectionList>)>)..::.IsReadOnly Property
SelectionListCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.SelectionList
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<ISelectionList>.IsReadOnly { get; }
Visual Basic (Declaration)
Private ReadOnly Property IsReadOnly As Boolean
    Implements ICollection(Of ISelectionList).IsReadOnly
Visual C++
private:
virtual property bool IsReadOnly {
    bool get () sealed = ICollection<ISelectionList^>::IsReadOnly::get;
}

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

SelectionListCollection Class
SelectionListCollection Overload
Mincom.LinkOne.Dom.SelectionList Namespace


Mincom.LinkOne.Dom.Zones Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.Dom.Zones Namespace
Send Feedback
The Mincom.LinkOne.Dom.Zones namespaces contains classes and interfaces for reading zoning data embedded in LinkOne graphical content.

Classes

Class | Description
CircularZone | A circular shaped callout zone.
LinearZone | A callout zone consisting of a sequence of line segments.
Point | Represents an ordered pair of integer x- and y-coordinates that defines a point in a two-dimensional plane.
PointCollection | Represents a collection of Point objects that can be accessed by index.
RectangularZone | A rectangular shaped callout zone.
Zone | The base class for a LinkOne Zone.
ZoneCollection | Represents a collection of Zone objects that can be accessed by index.
ZoneConstants | Constants for zone objects.
ZoneItem | A zone item.
ZoneItemCollection | Represents a collection of ZoneItem objects keyed on Id.

Interfaces

Interface | Description
IZoneDisplayedItemId | Implemented by classes that have a DisplayedItemID property

Enumerations

Enumeration | Description
LineStyle | Allowable line styles.
ZoneTextAngle | Permissable angles for zoned text.
ZoneType | Defines the type of a Callout zone has specified by the LinkOne publisher


CircularZone Class

[image]

LinkOne WebView API
CircularZone Class
Members See Also Send Feedback
A circular shaped callout zone.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class CircularZone : Zone,
    IZoneDisplayedItemId
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class CircularZone _
    Inherits Zone _
    Implements IZoneDisplayedItemId
Visual C++
[SerializableAttribute]
public ref class CircularZone sealed : public Zone,
    IZoneDisplayedItemId

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Zones..::.Zone
Mincom.LinkOne.Dom.Zones..::.CircularZone

See Also

CircularZone Members
Mincom.LinkOne.Dom.Zones Namespace


CircularZone Members

[image] [image]

LinkOne WebView API
CircularZone Members
CircularZone Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The CircularZone type exposes the following members.

Constructors

Name | Description
CircularZone | Construct a CircularZone from the supplied IDomReader.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Class | Gets the class of the zone. (Inherited from Zone.)
Diameter | Gets the diameter of the zone.
DisplayedItemId | Gets or sets the item id to display.
Left | Gets the left coordinate of the zone. (Inherited from Zone.)
Options | Gets the options associated with this object. (Inherited from Zone.)
TextAngle | Gets the rotation angle for the text.
Top | Gets top coordinate of the zone. (Inherited from Zone.)
ZoneType | Gets the ZoneType of this Zone (Inherited from Zone.)

Explicit Interface Implementations

Name | Description
IFilterable..::.Options | Gets the options collection associated with the zone. (Inherited from Zone.)

See Also

CircularZone Class
Mincom.LinkOne.Dom.Zones Namespace


CircularZone Constructor

[image]

LinkOne WebView API
CircularZone Constructor
CircularZone Class See Also Send Feedback
Construct a CircularZone from the supplied IDomReader.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public CircularZone(
    IDomReader domReader
)
Visual Basic (Declaration)
Public Sub New ( _
    domReader As IDomReader _
)
Visual C++
public:
CircularZone(
    IDomReader^ domReader
)

Parameters

domReader
Type: IDomReader
The IDomLoader must implement IZoneReader

See Also

CircularZone Class
Mincom.LinkOne.Dom.Zones Namespace


CircularZone Methods

[image] [image]

LinkOne WebView API
CircularZone Methods
CircularZone Class See Also Send Feedback

The CircularZone type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CircularZone Class
Mincom.LinkOne.Dom.Zones Namespace


CircularZone Properties

[image] [image]

LinkOne WebView API
CircularZone Properties
CircularZone Class See Also Send Feedback

The CircularZone type exposes the following members.

Properties

Name | Description
Class | Gets the class of the zone. (Inherited from Zone.)
Diameter | Gets the diameter of the zone.
DisplayedItemId | Gets or sets the item id to display.
Left | Gets the left coordinate of the zone. (Inherited from Zone.)
Options | Gets the options associated with this object. (Inherited from Zone.)
TextAngle | Gets the rotation angle for the text.
Top | Gets top coordinate of the zone. (Inherited from Zone.)
ZoneType | Gets the ZoneType of this Zone (Inherited from Zone.)

Explicit Interface Implementations

Name | Description
IFilterable..::.Options | Gets the options collection associated with the zone. (Inherited from Zone.)

See Also

CircularZone Class
Mincom.LinkOne.Dom.Zones Namespace


Diameter Property

[image]

LinkOne WebView API
CircularZone..::.Diameter Property
CircularZone Class See Also Send Feedback
Gets the diameter of the zone.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Diameter { get; }
Visual Basic (Declaration)
Public ReadOnly Property Diameter As Integer
Visual C++
public:
property int Diameter {
    int get ();
}

See Also

CircularZone Class
Mincom.LinkOne.Dom.Zones Namespace


DisplayedItemId Property

[image]

LinkOne WebView API
CircularZone..::.DisplayedItemId Property
CircularZone Class See Also Send Feedback
Gets or sets the item id to display.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string DisplayedItemId { get; internal set; }
Visual Basic (Declaration)
Public Property DisplayedItemId As String
Visual C++
public:
virtual property String^ DisplayedItemId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IZoneDisplayedItemId..::.DisplayedItemId

See Also

CircularZone Class
Mincom.LinkOne.Dom.Zones Namespace


TextAngle Property

[image]

LinkOne WebView API
CircularZone..::.TextAngle Property
CircularZone Class See Also Send Feedback
Gets the rotation angle for the text.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ZoneTextAngle TextAngle { get; }
Visual Basic (Declaration)
Public ReadOnly Property TextAngle As ZoneTextAngle
Visual C++
public:
property ZoneTextAngle TextAngle {
    ZoneTextAngle get ();
}

See Also

CircularZone Class
Mincom.LinkOne.Dom.Zones Namespace


IZoneDisplayedItemId Interface

[image]

LinkOne WebView API
IZoneDisplayedItemId Interface
Members See Also Send Feedback
Implemented by classes that have a DisplayedItemID property

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public interface IZoneDisplayedItemId
Visual Basic (Declaration)
Public Interface IZoneDisplayedItemId
Visual C++
public interface class IZoneDisplayedItemId

See Also

IZoneDisplayedItemId Members
Mincom.LinkOne.Dom.Zones Namespace


IZoneDisplayedItemId Members

[image] [image]

LinkOne WebView API
IZoneDisplayedItemId Members
IZoneDisplayedItemId Interface Properties See Also Send Feedback

The IZoneDisplayedItemId type exposes the following members.

Properties

Name | Description
DisplayedItemId | Gets the DisplayedItemId of the zone.

See Also

IZoneDisplayedItemId Interface
Mincom.LinkOne.Dom.Zones Namespace


IZoneDisplayedItemId Properties

[image] [image]

LinkOne WebView API
IZoneDisplayedItemId Properties
IZoneDisplayedItemId Interface See Also Send Feedback

The IZoneDisplayedItemId type exposes the following members.

Properties

Name | Description
DisplayedItemId | Gets the DisplayedItemId of the zone.

See Also

IZoneDisplayedItemId Interface
Mincom.LinkOne.Dom.Zones Namespace


DisplayedItemId Property

[image]

LinkOne WebView API
IZoneDisplayedItemId..::.DisplayedItemId Property
IZoneDisplayedItemId Interface See Also Send Feedback
Gets the DisplayedItemId of the zone.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
string DisplayedItemId { get; }
Visual Basic (Declaration)
ReadOnly Property DisplayedItemId As String
Visual C++
property String^ DisplayedItemId {
    String^ get ();
}

Field Value

The DisplayedItemId value of the zone.

See Also

IZoneDisplayedItemId Interface
Mincom.LinkOne.Dom.Zones Namespace


LinearZone Class

[image]

LinkOne WebView API
LinearZone Class
Members See Also Send Feedback
A callout zone consisting of a sequence of line segments.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class LinearZone : Zone
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class LinearZone _
    Inherits Zone
Visual C++
[SerializableAttribute]
public ref class LinearZone sealed : public Zone

Remarks

Also referred to as a POLYZONE.

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Zones..::.Zone
Mincom.LinkOne.Dom.Zones..::.LinearZone

See Also

LinearZone Members
Mincom.LinkOne.Dom.Zones Namespace


LinearZone Members

[image] [image]

LinkOne WebView API
LinearZone Members
LinearZone Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The LinearZone type exposes the following members.

Constructors

Name | Description
LinearZone | Construct a LinearZone from the supplied IDomReader.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Class | Gets the class of the zone. (Inherited from Zone.)
Height | Gets the height of the zone.
Left | Gets the left coordinate of the zone. (Inherited from Zone.)
Options | Gets the options associated with this object. (Inherited from Zone.)
Points | Gets the collection of points describing the line.
Style | Gets the style of the line.
Thickness | Gets the thickness of the line.
Top | Gets top coordinate of the zone. (Inherited from Zone.)
Width | Gets the widfth of the zone.
ZoneType | Gets the ZoneType of this Zone (Inherited from Zone.)

Explicit Interface Implementations

Name | Description
IFilterable..::.Options | Gets the options collection associated with the zone. (Inherited from Zone.)

See Also

LinearZone Class
Mincom.LinkOne.Dom.Zones Namespace


LinearZone Constructor

[image]

LinkOne WebView API
LinearZone Constructor
LinearZone Class See Also Send Feedback
Construct a LinearZone from the supplied IDomReader.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LinearZone(
    IDomReader domReader
)
Visual Basic (Declaration)
Public Sub New ( _
    domReader As IDomReader _
)
Visual C++
public:
LinearZone(
    IDomReader^ domReader
)

Parameters

domReader
Type: IDomReader
The IDomLoader must implement IZoneReader

See Also

LinearZone Class
Mincom.LinkOne.Dom.Zones Namespace


LinearZone Methods

[image] [image]

LinkOne WebView API
LinearZone Methods
LinearZone Class See Also Send Feedback

The LinearZone type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LinearZone Class
Mincom.LinkOne.Dom.Zones Namespace


LinearZone Properties

[image] [image]

LinkOne WebView API
LinearZone Properties
LinearZone Class See Also Send Feedback

The LinearZone type exposes the following members.

Properties

Name | Description
Class | Gets the class of the zone. (Inherited from Zone.)
Height | Gets the height of the zone.
Left | Gets the left coordinate of the zone. (Inherited from Zone.)
Options | Gets the options associated with this object. (Inherited from Zone.)
Points | Gets the collection of points describing the line.
Style | Gets the style of the line.
Thickness | Gets the thickness of the line.
Top | Gets top coordinate of the zone. (Inherited from Zone.)
Width | Gets the widfth of the zone.
ZoneType | Gets the ZoneType of this Zone (Inherited from Zone.)

Explicit Interface Implementations

Name | Description
IFilterable..::.Options | Gets the options collection associated with the zone. (Inherited from Zone.)

See Also

LinearZone Class
Mincom.LinkOne.Dom.Zones Namespace


Height Property

[image]

LinkOne WebView API
LinearZone..::.Height Property
LinearZone Class See Also Send Feedback
Gets the height of the zone.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Height { get; }
Visual Basic (Declaration)
Public ReadOnly Property Height As Integer
Visual C++
public:
property int Height {
    int get ();
}

See Also

LinearZone Class
Mincom.LinkOne.Dom.Zones Namespace


Points Property

[image]

LinkOne WebView API
LinearZone..::.Points Property
LinearZone Class See Also Send Feedback
Gets the collection of points describing the line.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PointCollection Points { get; }
Visual Basic (Declaration)
Public ReadOnly Property Points As PointCollection
Visual C++
public:
property PointCollection^ Points {
    PointCollection^ get ();
}

See Also

LinearZone Class
Mincom.LinkOne.Dom.Zones Namespace


Style Property

[image]

LinkOne WebView API
LinearZone..::.Style Property
LinearZone Class See Also Send Feedback
Gets the style of the line.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LineStyle Style { get; }
Visual Basic (Declaration)
Public ReadOnly Property Style As LineStyle
Visual C++
public:
property LineStyle Style {
    LineStyle get ();
}

See Also

LinearZone Class
Mincom.LinkOne.Dom.Zones Namespace


Thickness Property

[image]

LinkOne WebView API
LinearZone..::.Thickness Property
LinearZone Class See Also Send Feedback
Gets the thickness of the line.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Thickness { get; }
Visual Basic (Declaration)
Public ReadOnly Property Thickness As Integer
Visual C++
public:
property int Thickness {
    int get ();
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Thrown when the thickness of the line is outside the range of 0 to 255.

See Also

LinearZone Class
Mincom.LinkOne.Dom.Zones Namespace


Width Property

[image]

LinkOne WebView API
LinearZone..::.Width Property
LinearZone Class See Also Send Feedback
Gets the widfth of the zone.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Width { get; }
Visual Basic (Declaration)
Public ReadOnly Property Width As Integer
Visual C++
public:
property int Width {
    int get ();
}

See Also

LinearZone Class
Mincom.LinkOne.Dom.Zones Namespace


LineStyle Enumeration

[image]

LinkOne WebView API
LineStyle Enumeration
See Also Send Feedback
Allowable line styles.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum LineStyle
Visual Basic (Declaration)
Public Enumeration LineStyle
Visual C++
public enum class LineStyle

Members

Member name | Description
Solid | A solid line.
Dashed | A dashed line.
Dotted | A dotted line.
DashDot | A dash - dot line.
DashDotDot | A dash - dot - dot line.

See Also

Mincom.LinkOne.Dom.Zones Namespace


Point Class

[image]

LinkOne WebView API
Point Class
Members See Also Send Feedback
Represents an ordered pair of integer x- and y-coordinates that defines a point in a two-dimensional plane.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class Point
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class Point
Visual C++
[SerializableAttribute]
public ref class Point sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Zones..::.Point

See Also

Point Members
Mincom.LinkOne.Dom.Zones Namespace


Point Members

[image] [image]

LinkOne WebView API
Point Members
Point Class Methods Properties See Also Send Feedback

The Point type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
X | Gets or sets the X coordinate.
Y | Gets or sets the Y coordinate.

See Also

Point Class
Mincom.LinkOne.Dom.Zones Namespace


Point Methods

[image] [image]

LinkOne WebView API
Point Methods
Point Class See Also Send Feedback

The Point type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Point Class
Mincom.LinkOne.Dom.Zones Namespace


Point Properties

[image] [image]

LinkOne WebView API
Point Properties
Point Class See Also Send Feedback

The Point type exposes the following members.

Properties

Name | Description
X | Gets or sets the X coordinate.
Y | Gets or sets the Y coordinate.

See Also

Point Class
Mincom.LinkOne.Dom.Zones Namespace


X Property

[image]

LinkOne WebView API
Point..::.X Property
Point Class See Also Send Feedback
Gets or sets the X coordinate.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int X { get; }
Visual Basic (Declaration)
Public ReadOnly Property X As Integer
Visual C++
public:
property int X {
    int get ();
}

See Also

Point Class
Mincom.LinkOne.Dom.Zones Namespace


Y Property

[image]

LinkOne WebView API
Point..::.Y Property
Point Class See Also Send Feedback
Gets or sets the Y coordinate.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Y { get; }
Visual Basic (Declaration)
Public ReadOnly Property Y As Integer
Visual C++
public:
property int Y {
    int get ();
}

See Also

Point Class
Mincom.LinkOne.Dom.Zones Namespace


PointCollection Class

[image]

LinkOne WebView API
PointCollection Class
Members See Also Send Feedback
Represents a collection of Point objects that can be accessed by index.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class PointCollection : ReadOnlyList<Point>
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class PointCollection _
    Inherits ReadOnlyList(Of Point)
Visual C++
[SerializableAttribute]
public ref class PointCollection sealed : public ReadOnlyList<Point^>

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.ReadOnlyList <(Of <( Point >)>)
Mincom.LinkOne.Dom.Zones..::.PointCollection

See Also

PointCollection Members
Mincom.LinkOne.Dom.Zones Namespace


PointCollection Members

[image] [image]

LinkOne WebView API
PointCollection Members
PointCollection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The PointCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given object. (Inherited from ReadOnlyList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
InnerList | Gets the inner list. (Inherited from ReadOnlyList<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from ReadOnlyList<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(T>)>).)

See Also

PointCollection Class
Mincom.LinkOne.Dom.Zones Namespace


PointCollection Methods

[image] [image]

LinkOne WebView API
PointCollection Methods
PointCollection Class See Also Send Feedback

The PointCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given object. (Inherited from ReadOnlyList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(T>)>).)

See Also

PointCollection Class
Mincom.LinkOne.Dom.Zones Namespace


PointCollection Properties

[image] [image]

LinkOne WebView API
PointCollection Properties
PointCollection Class See Also Send Feedback

The PointCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
InnerList | Gets the inner list. (Inherited from ReadOnlyList<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from ReadOnlyList<(Of <(T>)>).)

See Also

PointCollection Class
Mincom.LinkOne.Dom.Zones Namespace


RectangularZone Class

[image]

LinkOne WebView API
RectangularZone Class
Members See Also Send Feedback
A rectangular shaped callout zone.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class RectangularZone : Zone,
    IZoneDisplayedItemId
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class RectangularZone _
    Inherits Zone _
    Implements IZoneDisplayedItemId
Visual C++
[SerializableAttribute]
public ref class RectangularZone sealed : public Zone,
    IZoneDisplayedItemId

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Zones..::.Zone
Mincom.LinkOne.Dom.Zones..::.RectangularZone

See Also

RectangularZone Members
Mincom.LinkOne.Dom.Zones Namespace


RectangularZone Members

[image] [image]

LinkOne WebView API
RectangularZone Members
RectangularZone Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The RectangularZone type exposes the following members.

Constructors

Name | Description
RectangularZone | Construct a RectangularZone from the supplied IDomReader

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Class | Gets the class of the zone. (Inherited from Zone.)
DisplayedItemId | Gets or sets the item id to display.
Height | Gets the height of the zone.
Left | Gets the left coordinate of the zone. (Inherited from Zone.)
Options | Gets the options associated with this object. (Inherited from Zone.)
TextAngle | Gets the rotation angle for the text.
Top | Gets top coordinate of the zone. (Inherited from Zone.)
Width | Gets the widfth of the zone.
ZoneType | Gets the ZoneType of this Zone (Inherited from Zone.)

Explicit Interface Implementations

Name | Description
IFilterable..::.Options | Gets the options collection associated with the zone. (Inherited from Zone.)

See Also

RectangularZone Class
Mincom.LinkOne.Dom.Zones Namespace


RectangularZone Constructor

[image]

LinkOne WebView API
RectangularZone Constructor
RectangularZone Class See Also Send Feedback
Construct a RectangularZone from the supplied IDomReader

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public RectangularZone(
    IDomReader domReader
)
Visual Basic (Declaration)
Public Sub New ( _
    domReader As IDomReader _
)
Visual C++
public:
RectangularZone(
    IDomReader^ domReader
)

Parameters

domReader
Type: IDomReader
The IDomLoader must implement IZoneReader

See Also

RectangularZone Class
Mincom.LinkOne.Dom.Zones Namespace


RectangularZone Methods

[image] [image]

LinkOne WebView API
RectangularZone Methods
RectangularZone Class See Also Send Feedback

The RectangularZone type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RectangularZone Class
Mincom.LinkOne.Dom.Zones Namespace


RectangularZone Properties

[image] [image]

LinkOne WebView API
RectangularZone Properties
RectangularZone Class See Also Send Feedback

The RectangularZone type exposes the following members.

Properties

Name | Description
Class | Gets the class of the zone. (Inherited from Zone.)
DisplayedItemId | Gets or sets the item id to display.
Height | Gets the height of the zone.
Left | Gets the left coordinate of the zone. (Inherited from Zone.)
Options | Gets the options associated with this object. (Inherited from Zone.)
TextAngle | Gets the rotation angle for the text.
Top | Gets top coordinate of the zone. (Inherited from Zone.)
Width | Gets the widfth of the zone.
ZoneType | Gets the ZoneType of this Zone (Inherited from Zone.)

Explicit Interface Implementations

Name | Description
IFilterable..::.Options | Gets the options collection associated with the zone. (Inherited from Zone.)

See Also

RectangularZone Class
Mincom.LinkOne.Dom.Zones Namespace


DisplayedItemId Property

[image]

LinkOne WebView API
RectangularZone..::.DisplayedItemId Property
RectangularZone Class See Also Send Feedback
Gets or sets the item id to display.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string DisplayedItemId { get; internal set; }
Visual Basic (Declaration)
Public Property DisplayedItemId As String
Visual C++
public:
virtual property String^ DisplayedItemId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IZoneDisplayedItemId..::.DisplayedItemId

See Also

RectangularZone Class
Mincom.LinkOne.Dom.Zones Namespace


Height Property

[image]

LinkOne WebView API
RectangularZone..::.Height Property
RectangularZone Class See Also Send Feedback
Gets the height of the zone.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Height { get; }
Visual Basic (Declaration)
Public ReadOnly Property Height As Integer
Visual C++
public:
property int Height {
    int get ();
}

See Also

RectangularZone Class
Mincom.LinkOne.Dom.Zones Namespace


TextAngle Property

[image]

LinkOne WebView API
RectangularZone..::.TextAngle Property
RectangularZone Class See Also Send Feedback
Gets the rotation angle for the text.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ZoneTextAngle TextAngle { get; }
Visual Basic (Declaration)
Public ReadOnly Property TextAngle As ZoneTextAngle
Visual C++
public:
property ZoneTextAngle TextAngle {
    ZoneTextAngle get ();
}

See Also

RectangularZone Class
Mincom.LinkOne.Dom.Zones Namespace


Width Property

[image]

LinkOne WebView API
RectangularZone..::.Width Property
RectangularZone Class See Also Send Feedback
Gets the widfth of the zone.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Width { get; }
Visual Basic (Declaration)
Public ReadOnly Property Width As Integer
Visual C++
public:
property int Width {
    int get ();
}

See Also

RectangularZone Class
Mincom.LinkOne.Dom.Zones Namespace


Zone Class

[image]

LinkOne WebView API
Zone Class
Members See Also Send Feedback
The base class for a LinkOne Zone.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public abstract class Zone : IFilterable
Visual Basic (Declaration)
<SerializableAttribute> _
Public MustInherit Class Zone _
    Implements IFilterable
Visual C++
[SerializableAttribute]
public ref class Zone abstract : IFilterable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Zones..::.Zone
Mincom.LinkOne.Dom.Zones..::.CircularZone
Mincom.LinkOne.Dom.Zones..::.LinearZone
Mincom.LinkOne.Dom.Zones..::.RectangularZone

See Also

Zone Members
Mincom.LinkOne.Dom.Zones Namespace


Zone Members

[image] [image]

LinkOne WebView API
Zone Members
Zone Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The Zone type exposes the following members.

Constructors

Name | Description
Zone | Construct a Zone from the supplied IDomReader

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Class | Gets the class of the zone.
Left | Gets the left coordinate of the zone.
Options | Gets the options associated with this object.
Top | Gets top coordinate of the zone.
ZoneType | Gets the ZoneType of this Zone

Explicit Interface Implementations

Name | Description
IFilterable..::.Options | Gets the options collection associated with the zone.

See Also

Zone Class
Mincom.LinkOne.Dom.Zones Namespace


Zone Constructor

[image]

LinkOne WebView API
Zone Constructor
Zone Class See Also Send Feedback
Construct a Zone from the supplied IDomReader

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected internal Zone(
    IDomReader domReader
)
Visual Basic (Declaration)
Protected Friend Sub New ( _
    domReader As IDomReader _
)
Visual C++
protected public:
Zone(
    IDomReader^ domReader
)

Parameters

domReader
Type: IDomReader
The IDomLoader must implement IZoneReader

See Also

Zone Class
Mincom.LinkOne.Dom.Zones Namespace


Zone Methods

[image] [image]

LinkOne WebView API
Zone Methods
Zone Class See Also Send Feedback

The Zone type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Zone Class
Mincom.LinkOne.Dom.Zones Namespace


Zone Properties

[image] [image]

LinkOne WebView API
Zone Properties
Zone Class See Also Send Feedback

The Zone type exposes the following members.

Properties

Name | Description
Class | Gets the class of the zone.
Left | Gets the left coordinate of the zone.
Options | Gets the options associated with this object.
Top | Gets top coordinate of the zone.
ZoneType | Gets the ZoneType of this Zone

Explicit Interface Implementations

Name | Description
IFilterable..::.Options | Gets the options collection associated with the zone.

See Also

Zone Class
Mincom.LinkOne.Dom.Zones Namespace


Class Property

[image]

LinkOne WebView API
Zone..::.Class Property
Zone Class See Also Send Feedback
Gets the class of the zone.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Class { get; }
Visual Basic (Declaration)
Public ReadOnly Property Class As Integer
Visual C++
public:
property int Class {
    int get ();
}

Field Value

The class of the zone.

See Also

Zone Class
Mincom.LinkOne.Dom.Zones Namespace


IFilterable.Options Property

[image]

LinkOne WebView API
Zone..::.IFilterable..::.Options Property
Zone Class See Also Send Feedback
Gets the options collection associated with the zone.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IOptionCollection IFilterable.Options { get; }
Visual Basic (Declaration)
Private ReadOnly Property Options As IOptionCollection
    Implements IFilterable.Options
Visual C++
private:
virtual property IOptionCollection^ Options {
    IOptionCollection^ get () sealed = IFilterable::Options::get;
}

Field Value

The OptionCollection that contains the options for the Zone.

Implements

IFilterable..::.Options

See Also

Zone Class
Mincom.LinkOne.Dom.Zones Namespace


Left Property

[image]

LinkOne WebView API
Zone..::.Left Property
Zone Class See Also Send Feedback
Gets the left coordinate of the zone.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Left { get; }
Visual Basic (Declaration)
Public ReadOnly Property Left As Integer
Visual C++
public:
property int Left {
    int get ();
}

Field Value

The left most coordinte of the zone.

See Also

Zone Class
Mincom.LinkOne.Dom.Zones Namespace


Options Property

[image]

LinkOne WebView API
Zone..::.Options Property
Zone Class See Also Send Feedback
Gets the options associated with this object.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public OptionCollection Options { get; }
Visual Basic (Declaration)
Public ReadOnly Property Options As OptionCollection
Visual C++
public:
property OptionCollection^ Options {
    OptionCollection^ get ();
}

Field Value

See Also

Zone Class
Mincom.LinkOne.Dom.Zones Namespace


Top Property

[image]

LinkOne WebView API
Zone..::.Top Property
Zone Class See Also Send Feedback
Gets top coordinate of the zone.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Top { get; }
Visual Basic (Declaration)
Public ReadOnly Property Top As Integer
Visual C++
public:
property int Top {
    int get ();
}

Field Value

The top most coordinate of the zone.

See Also

Zone Class
Mincom.LinkOne.Dom.Zones Namespace


ZoneType Property

[image]

LinkOne WebView API
Zone..::.ZoneType Property
Zone Class See Also Send Feedback
Gets the ZoneType of this Zone

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ZoneType ZoneType { get; }
Visual Basic (Declaration)
Public ReadOnly Property ZoneType As ZoneType
Visual C++
public:
property ZoneType ZoneType {
    ZoneType get ();
}

See Also

Zone Class
Mincom.LinkOne.Dom.Zones Namespace


ZoneCollection Class

[image]

LinkOne WebView API
ZoneCollection Class
Members See Also Send Feedback
Represents a collection of Zone objects that can be accessed by index.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class ZoneCollection : ReadOnlyList<Zone>
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class ZoneCollection _
    Inherits ReadOnlyList(Of Zone)
Visual C++
[SerializableAttribute]
public ref class ZoneCollection sealed : public ReadOnlyList<Zone^>

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom..::.ReadOnlyList <(Of <( Zone >)>)
Mincom.LinkOne.Dom.Zones..::.ZoneCollection

See Also

ZoneCollection Members
Mincom.LinkOne.Dom.Zones Namespace


ZoneCollection Members

[image] [image]

LinkOne WebView API
ZoneCollection Members
ZoneCollection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The ZoneCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given object. (Inherited from ReadOnlyList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
InnerList | Gets the inner list. (Inherited from ReadOnlyList<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from ReadOnlyList<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(T>)>).)

See Also

ZoneCollection Class
Mincom.LinkOne.Dom.Zones Namespace


ZoneCollection Methods

[image] [image]

LinkOne WebView API
ZoneCollection Methods
ZoneCollection Class See Also Send Feedback

The ZoneCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Searches the collection and returns the zero-based index of the first occurence of the given object. (Inherited from ReadOnlyList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(T>)>).)

See Also

ZoneCollection Class
Mincom.LinkOne.Dom.Zones Namespace


ZoneCollection Properties

[image] [image]

LinkOne WebView API
ZoneCollection Properties
ZoneCollection Class See Also Send Feedback

The ZoneCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection. (Inherited from ReadOnlyList<(Of <(T>)>).)
InnerList | Gets the inner list. (Inherited from ReadOnlyList<(Of <(T>)>).)
Item | Gets the item at the specified index. (Inherited from ReadOnlyList<(Of <(T>)>).)

See Also

ZoneCollection Class
Mincom.LinkOne.Dom.Zones Namespace


ZoneConstants Class

[image]

LinkOne WebView API
ZoneConstants Class
Members See Also Send Feedback
Constants for zone objects.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public sealed class ZoneConstants
Visual Basic (Declaration)
Public NotInheritable Class ZoneConstants
Visual C++
public ref class ZoneConstants sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Zones..::.ZoneConstants

See Also

ZoneConstants Members
Mincom.LinkOne.Dom.Zones Namespace


ZoneConstants Members

[image] [image]

LinkOne WebView API
ZoneConstants Members
ZoneConstants Class Methods Fields See Also Send Feedback

The ZoneConstants type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
UnspecifiedClassNumber | Unspecified class number.

See Also

ZoneConstants Class
Mincom.LinkOne.Dom.Zones Namespace


ZoneConstants Fields

[image] [image]

LinkOne WebView API
ZoneConstants Fields
ZoneConstants Class See Also Send Feedback

The ZoneConstants type exposes the following members.

Fields

Name | Description
UnspecifiedClassNumber | Unspecified class number.

See Also

ZoneConstants Class
Mincom.LinkOne.Dom.Zones Namespace


UnspecifiedClassNumber Field

[image]

LinkOne WebView API
ZoneConstants..::.UnspecifiedClassNumber Field
ZoneConstants Class See Also Send Feedback
Unspecified class number.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public const int UnspecifiedClassNumber
Visual Basic (Declaration)
Public Const UnspecifiedClassNumber As Integer
Visual C++
public:
literal int UnspecifiedClassNumber

See Also

ZoneConstants Class
Mincom.LinkOne.Dom.Zones Namespace


ZoneConstants Methods

[image] [image]

LinkOne WebView API
ZoneConstants Methods
ZoneConstants Class See Also Send Feedback

The ZoneConstants type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ZoneConstants Class
Mincom.LinkOne.Dom.Zones Namespace


ZoneItem Class

[image]

LinkOne WebView API
ZoneItem Class
Members See Also Send Feedback
A zone item.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class ZoneItem
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class ZoneItem
Visual C++
[SerializableAttribute]
public ref class ZoneItem sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Zones..::.ZoneItem

See Also

ZoneItem Members
Mincom.LinkOne.Dom.Zones Namespace


ZoneItem Members

[image] [image]

LinkOne WebView API
ZoneItem Members
ZoneItem Class Methods Properties See Also Send Feedback

The ZoneItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Id | Gets or sets the list entry Id this zone item to.
Zones | The collection of zones this zone item represents.

See Also

ZoneItem Class
Mincom.LinkOne.Dom.Zones Namespace


ZoneItem Methods

[image] [image]

LinkOne WebView API
ZoneItem Methods
ZoneItem Class See Also Send Feedback

The ZoneItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ZoneItem Class
Mincom.LinkOne.Dom.Zones Namespace


ZoneItem Properties

[image] [image]

LinkOne WebView API
ZoneItem Properties
ZoneItem Class See Also Send Feedback

The ZoneItem type exposes the following members.

Properties

Name | Description
Id | Gets or sets the list entry Id this zone item to.
Zones | The collection of zones this zone item represents.

See Also

ZoneItem Class
Mincom.LinkOne.Dom.Zones Namespace


Id Property

[image]

LinkOne WebView API
ZoneItem..::.Id Property
ZoneItem Class See Also Send Feedback
Gets or sets the list entry Id this zone item to.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Id { get; internal set; }
Visual Basic (Declaration)
Public Property Id As String
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

ZoneItem Class
Mincom.LinkOne.Dom.Zones Namespace


Zones Property

[image]

LinkOne WebView API
ZoneItem..::.Zones Property
ZoneItem Class See Also Send Feedback
The collection of zones this zone item represents.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ZoneCollection Zones { get; }
Visual Basic (Declaration)
Public ReadOnly Property Zones As ZoneCollection
Visual C++
public:
property ZoneCollection^ Zones {
    ZoneCollection^ get ();
}

See Also

ZoneItem Class
Mincom.LinkOne.Dom.Zones Namespace


ZoneItemCollection Class

[image]

LinkOne WebView API
ZoneItemCollection Class
Members See Also Send Feedback
Represents a collection of ZoneItem objects keyed on Id.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class ZoneItemCollection : IReadOnlyKeyedCollection<string, ZoneItem>,
    IReadOnlyCollection<ZoneItem>, IEnumerable<ZoneItem>, IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class ZoneItemCollection _
    Implements IReadOnlyKeyedCollection(Of String, ZoneItem),  _
    IReadOnlyCollection(Of ZoneItem), IEnumerable(Of ZoneItem), IEnumerable
Visual C++
[SerializableAttribute]
public ref class ZoneItemCollection sealed : IReadOnlyKeyedCollection<String^, ZoneItem^>,
    IReadOnlyCollection<ZoneItem^>, IEnumerable<ZoneItem^>, IEnumerable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Dom.Zones..::.ZoneItemCollection

See Also

ZoneItemCollection Members
Mincom.LinkOne.Dom.Zones Namespace


ZoneItemCollection Members

[image] [image]

LinkOne WebView API
ZoneItemCollection Members
ZoneItemCollection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The ZoneItemCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements in the collection.
Item | Gets the ZoneItem with the given id.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.

See Also

ZoneItemCollection Class
Mincom.LinkOne.Dom.Zones Namespace


ZoneItemCollection Methods

[image] [image]

LinkOne WebView API
ZoneItemCollection Methods
ZoneItemCollection Class See Also Send Feedback

The ZoneItemCollection type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection.

See Also

ZoneItemCollection Class
Mincom.LinkOne.Dom.Zones Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
ZoneItemCollection..::.IEnumerable..::.GetEnumerator Method
ZoneItemCollection Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ZoneItemCollection Class
Mincom.LinkOne.Dom.Zones Namespace


Contains Method

[image] [image]

LinkOne WebView API
ZoneItemCollection..::.Contains Method
ZoneItemCollection Class See Also Send Feedback

Overload List

Name | Description
Contains(ZoneItem) | Determines whether an zone item is in the collection.
Contains(String) | Determines whether the collection contains a zone item with the given Id.

See Also

ZoneItemCollection Class
ZoneItemCollection Members
Mincom.LinkOne.Dom.Zones Namespace


Contains Method (ZoneItem)

[image]

LinkOne WebView API
ZoneItemCollection..::.Contains Method (ZoneItem)
ZoneItemCollection Class See Also Send Feedback
Determines whether an zone item is in the collection.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    ZoneItem item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As ZoneItem _
) As Boolean
Visual C++
public:
virtual bool Contains(
    ZoneItem^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Dom.Zones..::.ZoneItem
The zone item object to search for.

Return Value

true if found in the collection, otherwise, false.

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Contains(T)

See Also

ZoneItemCollection Class
Contains Overload
Mincom.LinkOne.Dom.Zones Namespace


Contains Method (String)

[image]

LinkOne WebView API
ZoneItemCollection..::.Contains Method (String)
ZoneItemCollection Class See Also Send Feedback
Determines whether the collection contains a zone item with the given Id.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    string key
)
Visual Basic (Declaration)
Public Function Contains ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ key
) sealed

Parameters

key
Type: System..::.String
The id to lookup.

Return Value

true if the collection contains a ZoneItem with the given id; otherwise, false.

Implements

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Contains(TKey)

See Also

ZoneItemCollection Class
Contains Overload
Mincom.LinkOne.Dom.Zones Namespace


GetEnumerator Method

[image]

LinkOne WebView API
ZoneItemCollection..::.GetEnumerator Method
ZoneItemCollection Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IEnumerator<ZoneItem> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of ZoneItem)
Visual C++
public:
virtual IEnumerator<ZoneItem^>^ GetEnumerator() sealed

Return Value

A IEnumerator<(Of <(T>)>) that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

ZoneItemCollection Class
Mincom.LinkOne.Dom.Zones Namespace


ZoneItemCollection Properties

[image] [image]

LinkOne WebView API
ZoneItemCollection Properties
ZoneItemCollection Class See Also Send Feedback

The ZoneItemCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements in the collection.
Item | Gets the ZoneItem with the given id.

See Also

ZoneItemCollection Class
Mincom.LinkOne.Dom.Zones Namespace


Count Property

[image]

LinkOne WebView API
ZoneItemCollection..::.Count Property
ZoneItemCollection Class See Also Send Feedback
Gets the number of elements in the collection.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

IReadOnlyCollection<(Of <(T>)>)..::.Count

See Also

ZoneItemCollection Class
Mincom.LinkOne.Dom.Zones Namespace


Item Property

[image]

LinkOne WebView API
ZoneItemCollection..::.Item Property
ZoneItemCollection Class See Also Send Feedback
Gets the ZoneItem with the given id.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ZoneItem this[
    string key
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    key As String _
) As ZoneItem
Visual C++
public:
virtual property ZoneItem^ default[String^ key] {
    ZoneItem^ get (String^ key) sealed;
}

Parameters

key
Type: System..::.String

Implements

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Item[([(TKey])])

Exceptions

Exception | Condition
System.Collections.Generic..::.KeyNotFoundException | The property is retrieved and id does not exist in the collection.
System..::.ArgumentNullException | Id is a null reference.

See Also

ZoneItemCollection Class
Mincom.LinkOne.Dom.Zones Namespace


ZoneTextAngle Enumeration

[image]

LinkOne WebView API
ZoneTextAngle Enumeration
See Also Send Feedback
Permissable angles for zoned text.

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public enum ZoneTextAngle
Visual Basic (Declaration)
Public Enumeration ZoneTextAngle
Visual C++
public enum class ZoneTextAngle

Members

Member name | Description
Default | Text is at 0 degrees, or 360 degrees. This is the default angle.
Rotate90 | Text is as 90 degrees.
Rotate180 | Text is at 180 degrees.
Rotate270 | Text is at 270 degrees.

See Also

Mincom.LinkOne.Dom.Zones Namespace


ZoneType Enumeration

[image]

LinkOne WebView API
ZoneType Enumeration
See Also Send Feedback
Defines the type of a Callout zone has specified by the LinkOne publisher

Namespace: Mincom.LinkOne.Dom.Zones
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[FlagsAttribute]
public enum ZoneType
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration ZoneType
Visual C++
[FlagsAttribute]
public enum class ZoneType

Members

Member name | Description
Inactive | The callout is inactive
Annotation | The callout is not visible
Callout | The callout is active and visible

See Also

Mincom.LinkOne.Dom.Zones Namespace


Mincom.LinkOne.Exceptions Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.Exceptions Namespace
Send Feedback
The Mincom.LinkOne.Exceptions namespace contains exception classes thrown in LinkOne.

Classes

Class | Description
BaseException | The base exception from which all exceptions are derived.
BookExistsException | This exception is thrown when a book is being installed and it already exists.
BookExpiredException | This exception is thrown from the DOM when a book has expired.
BookNotFoundException | The exception that is thrown when the wanted Mincom.LinkOne.Dom.Book is not found.
BookReadException | This exception is thrown when the book being loaded contains errors.
CancelledException | The exception that is thrown when an operation is cancelled by the user.
ConfigurationManagerBusyException | The exception that is thrown when the configuration manager generates a busy error.
ConfigurationManagerException | The exception that is thrown when the configuration manager generates an error.
ConfiguredObjectNotFoundException | The exception that is thrown when the wanted configured object is not found.
DataChangedException | The exception when underlying data has changed during a read-modify-write operation.
GraphicNotFoundException | The exception that is thrown when the wanted Mincom.LinkOne.Dom.Graphic is not found.
IOException | This exception is thrown from the File class when an IO Exception occurs.
LayoutReadException | This is thrown when a layout reader encounteres a problem.
LicenseException | This exception is thrown from the LinkOne DOM when a security exception occurs.
LicenseExpiredException | This exception is thrown when a license found and expired.
LicenseLockException | This exception is thrown from the DOM when a security lock exception occurs.
LicenseLockExpiredException | This exception is thrown when a license has expired.
MasterBookNotFoundException | This exception is thrown from the LinkOne DOM when the Master Book cannot be located.
MissingConfigurationManagerException | This exception is thrown from the LinkOne DOM when a Configuration Manager is not supplied.
MissingProviderException | This exception is thrown from the LinkOne DOM when an Provider is not supplied.
PageNotFoundException | The exception that is thrown when the wanted Mincom.LinkOne.Dom.Page is not found.
ScriptException | The exception that is thrown when a scriptlet encounters an error.
SearchDisabledException | The exception when executing a disabled search.
SelectionListReadException | This is thrown when a selection list reader encounteres a problem.


BaseException Class

[image]

LinkOne WebView API
BaseException Class
Members See Also Send Feedback
The base exception from which all exceptions are derived.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public abstract class BaseException : Exception
Visual Basic (Declaration)
<SerializableAttribute> _
Public MustInherit Class BaseException _
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class BaseException abstract : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
Mincom.LinkOne.Exceptions..::.BaseException
Mincom.LinkOne.Exceptions..::.BookExistsException
Mincom.LinkOne.Exceptions..::.BookNotFoundException
Mincom.LinkOne.Exceptions..::.BookReadException
Mincom.LinkOne.Exceptions..::.CancelledException
Mincom.LinkOne.Exceptions..::.ConfigurationManagerBusyException
Mincom.LinkOne.Exceptions..::.ConfigurationManagerException
Mincom.LinkOne.Exceptions..::.ConfiguredObjectNotFoundException
Mincom.LinkOne.Exceptions..::.DataChangedException
Mincom.LinkOne.Exceptions..::.GraphicNotFoundException
Mincom.LinkOne.Exceptions..::.IOException
Mincom.LinkOne.Exceptions..::.LayoutReadException
Mincom.LinkOne.Exceptions..::.LicenseException
Mincom.LinkOne.Exceptions..::.MasterBookNotFoundException
Mincom.LinkOne.Exceptions..::.MissingConfigurationManagerException
Mincom.LinkOne.Exceptions..::.MissingProviderException
Mincom.LinkOne.Exceptions..::.PageNotFoundException
Mincom.LinkOne.Exceptions..::.ScriptException
Mincom.LinkOne.Exceptions..::.SearchDisabledException
Mincom.LinkOne.Exceptions..::.SelectionListReadException
Mincom.LinkOne.WebView.WebServer.Exceptions..::.DraftBookException

See Also

BaseException Members
Mincom.LinkOne.Exceptions Namespace


BaseException Members

[image] [image]

LinkOne WebView API
BaseException Members
BaseException Class Constructors Methods Properties See Also Send Feedback

The BaseException type exposes the following members.

Constructors

Name | Description
BaseException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides Exception..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

BaseException Class
Mincom.LinkOne.Exceptions Namespace


BaseException Constructor

[image] [image]

LinkOne WebView API
BaseException Constructor
BaseException Class See Also Send Feedback

Overload List

Name | Description
BaseException()()() | Initializes a new instance of the class.
BaseException(String) | Initializes a new instance of the class with a message.
BaseException(SerializationInfo, StreamingContext) | Initializes a new instance of the class with serialized data.
BaseException(String, Exception) | Initializes a new instance of the class with a simple message and another exception.
BaseException(String, array<Object>[]()[]) | Initializes a new instance of the class with a formatted message.
BaseException(String, Exception, array<Object>[]()[]) | Initializes a new instance of the class with a simple message and another exception.

See Also

BaseException Class
BaseException Members
Mincom.LinkOne.Exceptions Namespace


BaseException Constructor

[image]

LinkOne WebView API
BaseException Constructor
BaseException Class See Also Send Feedback
Initializes a new instance of the class.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected BaseException()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
BaseException()

See Also

BaseException Class
BaseException Overload
Mincom.LinkOne.Exceptions Namespace


BaseException Constructor (String)

[image]

LinkOne WebView API
BaseException Constructor (String)
BaseException Class See Also Send Feedback
Initializes a new instance of the class with a message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected BaseException(
    string message
)
Visual Basic (Declaration)
Protected Sub New ( _
    message As String _
)
Visual C++
protected:
BaseException(
    String^ message
)

Parameters

message
Type: System..::.String
The exception message.

See Also

BaseException Class
BaseException Overload
Mincom.LinkOne.Exceptions Namespace


BaseException Constructor (SerializationInfo, StreamingContext)

[image]

LinkOne WebView API
BaseException Constructor (SerializationInfo, StreamingContext)
BaseException Class See Also Send Feedback
Initializes a new instance of the class with serialized data.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected BaseException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
BaseException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The object that holds the serialized object data.
context
Type: System.Runtime.Serialization..::.StreamingContext
The contextual information about the source or destination.

See Also

BaseException Class
BaseException Overload
Mincom.LinkOne.Exceptions Namespace


BaseException Constructor (String, Exception)

[image]

LinkOne WebView API
BaseException Constructor (String, Exception)
BaseException Class See Also Send Feedback
Initializes a new instance of the class with a simple message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected BaseException(
    string message,
    Exception inner
)
Visual Basic (Declaration)
Protected Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
protected:
BaseException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The exception to wrap.

See Also

BaseException Class
BaseException Overload
Mincom.LinkOne.Exceptions Namespace


BaseException Constructor (String, Object[])

[image]

LinkOne WebView API
BaseException Constructor (String, array<Object>[]()[])
BaseException Class See Also Send Feedback
Initializes a new instance of the class with a formatted message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected BaseException(
    string message,
    params Object[] args
)
Visual Basic (Declaration)
Protected Sub New ( _
    message As String, _
    ParamArray args As Object() _
)
Visual C++
protected:
BaseException(
    String^ message,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

BaseException Class
BaseException Overload
Mincom.LinkOne.Exceptions Namespace


BaseException Constructor (String, Exception, Object[])

[image]

LinkOne WebView API
BaseException Constructor (String, Exception, array<Object>[]()[])
BaseException Class See Also Send Feedback
Initializes a new instance of the class with a simple message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected BaseException(
    string message,
    Exception inner,
    params Object[] args
)
Visual Basic (Declaration)
Protected Sub New ( _
    message As String, _
    inner As Exception, _
    ParamArray args As Object() _
)
Visual C++
protected:
BaseException(
    String^ message,
    Exception^ inner,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
inner
Type: System..::.Exception
The exception to wrap.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

BaseException Class
BaseException Overload
Mincom.LinkOne.Exceptions Namespace


BaseException Methods

[image] [image]

LinkOne WebView API
BaseException Methods
BaseException Class See Also Send Feedback

The BaseException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides Exception..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

BaseException Class
Mincom.LinkOne.Exceptions Namespace


GetObjectData Method

[image]

LinkOne WebView API
BaseException..::.GetObjectData Method
BaseException Class See Also Send Feedback
When overridden in a derived class, sets the SerializationInfo with information about the exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::.StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System..::.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

BaseException Class
Mincom.LinkOne.Exceptions Namespace


BaseException Properties

[image] [image]

LinkOne WebView API
BaseException Properties
BaseException Class See Also Send Feedback

The BaseException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

BaseException Class
Mincom.LinkOne.Exceptions Namespace


BookExistsException Class

[image]

LinkOne WebView API
BookExistsException Class
Members See Also Send Feedback
This exception is thrown when a book is being installed and it already exists.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class BookExistsException : BaseException
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class BookExistsException _
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class BookExistsException sealed : public BaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Mincom.LinkOne.Exceptions..::.BaseException
Mincom.LinkOne.Exceptions..::.BookExistsException

See Also

BookExistsException Members
Mincom.LinkOne.Exceptions Namespace


BookExistsException Members

[image] [image]

LinkOne WebView API
BookExistsException Members
BookExistsException Class Constructors Methods Properties See Also Send Feedback

The BookExistsException type exposes the following members.

Constructors

Name | Description
BookExistsException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides BaseException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
BookCode | Gets the book code.
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
PublisherCode | Gets the publisher code.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

BookExistsException Class
Mincom.LinkOne.Exceptions Namespace


BookExistsException Constructor

[image] [image]

LinkOne WebView API
BookExistsException Constructor
BookExistsException Class See Also Send Feedback

Overload List

Name | Description
BookExistsException()()() | Initializes a new instance of the class.
BookExistsException(String) | Initializes a new instance of the class with a simple message.
BookExistsException(String, Exception) | Initializes a new instance of the class with a message and another exception.
BookExistsException(String, String) | Initializes a new instance of the class.
BookExistsException(String, String, String) | Initializes a new instance of the class with a simple message.
BookExistsException(String, String, String, Exception) | Initializes a new instance of the class with a message and another exception.
BookExistsException(String, String, String, array<Object>[]()[]) | Initializes a new instance of the class with a simple message.
BookExistsException(String, String, String, Exception, array<Object>[]()[]) | Initializes a new instance of the class with a message and another exception.

See Also

BookExistsException Class
BookExistsException Members
Mincom.LinkOne.Exceptions Namespace


BookExistsException Constructor

[image]

LinkOne WebView API
BookExistsException Constructor
BookExistsException Class See Also Send Feedback
Initializes a new instance of the class.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookExistsException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BookExistsException()

See Also

BookExistsException Class
BookExistsException Overload
Mincom.LinkOne.Exceptions Namespace


BookExistsException Constructor (String)

[image]

LinkOne WebView API
BookExistsException Constructor (String)
BookExistsException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookExistsException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
BookExistsException(
    String^ message
)

Parameters

message
Type: System..::.String
The exception message.

See Also

BookExistsException Class
BookExistsException Overload
Mincom.LinkOne.Exceptions Namespace


BookExistsException Constructor (String, Exception)

[image]

LinkOne WebView API
BookExistsException Constructor (String, Exception)
BookExistsException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookExistsException(
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
BookExistsException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The exception to wrap.

See Also

BookExistsException Class
BookExistsException Overload
Mincom.LinkOne.Exceptions Namespace


BookExistsException Constructor (String, String)

[image]

LinkOne WebView API
BookExistsException Constructor (String, String)
BookExistsException Class See Also Send Feedback
Initializes a new instance of the class.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookExistsException(
    string publisherCode,
    string bookCode
)
Visual Basic (Declaration)
Public Sub New ( _
    publisherCode As String, _
    bookCode As String _
)
Visual C++
public:
BookExistsException(
    String^ publisherCode,
    String^ bookCode
)

Parameters

publisherCode
Type: System..::.String
bookCode
Type: System..::.String

See Also

BookExistsException Class
BookExistsException Overload
Mincom.LinkOne.Exceptions Namespace


BookExistsException Constructor (String, String, String)

[image]

LinkOne WebView API
BookExistsException Constructor (String, String, String)
BookExistsException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookExistsException(
    string publisherCode,
    string bookCode,
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    publisherCode As String, _
    bookCode As String, _
    message As String _
)
Visual C++
public:
BookExistsException(
    String^ publisherCode,
    String^ bookCode,
    String^ message
)

Parameters

publisherCode
Type: System..::.String
The publisher code.
bookCode
Type: System..::.String
The book code.
message
Type: System..::.String
The exception message.

See Also

BookExistsException Class
BookExistsException Overload
Mincom.LinkOne.Exceptions Namespace


BookExistsException Constructor (String, String, String, Exception)

[image]

LinkOne WebView API
BookExistsException Constructor (String, String, String, Exception)
BookExistsException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookExistsException(
    string publisherCode,
    string bookCode,
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    publisherCode As String, _
    bookCode As String, _
    message As String, _
    inner As Exception _
)
Visual C++
public:
BookExistsException(
    String^ publisherCode,
    String^ bookCode,
    String^ message,
    Exception^ inner
)

Parameters

publisherCode
Type: System..::.String
The publisher code.
bookCode
Type: System..::.String
The book code.
message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The exception to wrap.

See Also

BookExistsException Class
BookExistsException Overload
Mincom.LinkOne.Exceptions Namespace


BookExistsException Constructor (String, String, String, Object[])

[image]

LinkOne WebView API
BookExistsException Constructor (String, String, String, array<Object>[]()[])
BookExistsException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookExistsException(
    string publisherCode,
    string bookCode,
    string message,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    publisherCode As String, _
    bookCode As String, _
    message As String, _
    ParamArray args As Object() _
)
Visual C++
public:
BookExistsException(
    String^ publisherCode,
    String^ bookCode,
    String^ message,
    ... array<Object^>^ args
)

Parameters

publisherCode
Type: System..::.String
The publisher code.
bookCode
Type: System..::.String
The book code.
message
Type: System..::.String
The exception message with formatting escape sequences.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

BookExistsException Class
BookExistsException Overload
Mincom.LinkOne.Exceptions Namespace


BookExistsException Constructor (String, String, String, Exception, Object[])

[image]

LinkOne WebView API
BookExistsException Constructor (String, String, String, Exception, array<Object>[]()[])
BookExistsException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookExistsException(
    string publisherCode,
    string bookCode,
    string message,
    Exception inner,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    publisherCode As String, _
    bookCode As String, _
    message As String, _
    inner As Exception, _
    ParamArray args As Object() _
)
Visual C++
public:
BookExistsException(
    String^ publisherCode,
    String^ bookCode,
    String^ message,
    Exception^ inner,
    ... array<Object^>^ args
)

Parameters

publisherCode
Type: System..::.String
The publisher code.
bookCode
Type: System..::.String
The book code.
message
Type: System..::.String
The exception message with formatting escape sequences.
inner
Type: System..::.Exception
The exception to wrap.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

BookExistsException Class
BookExistsException Overload
Mincom.LinkOne.Exceptions Namespace


BookExistsException Methods

[image] [image]

LinkOne WebView API
BookExistsException Methods
BookExistsException Class See Also Send Feedback

The BookExistsException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides BaseException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

BookExistsException Class
Mincom.LinkOne.Exceptions Namespace


GetObjectData Method

[image]

LinkOne WebView API
BookExistsException..::.GetObjectData Method
BookExistsException Class See Also Send Feedback
When overridden in a derived class, sets the SerializationInfo with information about the exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::.StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System..::.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

BookExistsException Class
Mincom.LinkOne.Exceptions Namespace


BookExistsException Properties

[image] [image]

LinkOne WebView API
BookExistsException Properties
BookExistsException Class See Also Send Feedback

The BookExistsException type exposes the following members.

Properties

Name | Description
BookCode | Gets the book code.
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
PublisherCode | Gets the publisher code.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

BookExistsException Class
Mincom.LinkOne.Exceptions Namespace


BookCode Property

[image]

LinkOne WebView API
BookExistsException..::.BookCode Property
BookExistsException Class See Also Send Feedback
Gets the book code.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string BookCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property BookCode As String
Visual C++
public:
property String^ BookCode {
    String^ get ();
}

See Also

BookExistsException Class
Mincom.LinkOne.Exceptions Namespace


PublisherCode Property

[image]

LinkOne WebView API
BookExistsException..::.PublisherCode Property
BookExistsException Class See Also Send Feedback
Gets the publisher code.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PublisherCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublisherCode As String
Visual C++
public:
property String^ PublisherCode {
    String^ get ();
}

See Also

BookExistsException Class
Mincom.LinkOne.Exceptions Namespace


BookExpiredException Class

[image]

LinkOne WebView API
BookExpiredException Class
Members See Also Send Feedback
This exception is thrown from the DOM when a book has expired.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class BookExpiredException : LicenseException
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class BookExpiredException _
    Inherits LicenseException
Visual C++
[SerializableAttribute]
public ref class BookExpiredException sealed : public LicenseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Mincom.LinkOne.Exceptions..::.BaseException
Mincom.LinkOne.Exceptions..::.LicenseException
Mincom.LinkOne.Exceptions..::.BookExpiredException

See Also

BookExpiredException Members
Mincom.LinkOne.Exceptions Namespace


BookExpiredException Members

[image] [image]

LinkOne WebView API
BookExpiredException Members
BookExpiredException Class Constructors Methods Properties See Also Send Feedback

The BookExpiredException type exposes the following members.

Constructors

Name | Description
BookExpiredException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides LicenseException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
BookCode | Gets the book code.
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
PublisherCode | Gets the publisher code.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

BookExpiredException Class
Mincom.LinkOne.Exceptions Namespace


BookExpiredException Constructor

[image] [image]

LinkOne WebView API
BookExpiredException Constructor
BookExpiredException Class See Also Send Feedback

Overload List

Name | Description
BookExpiredException()()() | Initializes a new instance of the class.
BookExpiredException(String) | Initializes a new instance of the class with a simple message.
BookExpiredException(String, Exception) | Initializes a new instance of the class with a message and another exception.
BookExpiredException(String, String) | Initializes a new instance of the class.
BookExpiredException(String, String, String) | Initializes a new instance of the class with a simple message.
BookExpiredException(String, String, String, Exception) | Initializes a new instance of the class with a message and another exception.
BookExpiredException(String, String, String, array<Object>[]()[]) | Initializes a new instance of the class with a simple message.
BookExpiredException(String, String, String, Exception, array<Object>[]()[]) | Initializes a new instance of the class with a message and another exception.

See Also

BookExpiredException Class
BookExpiredException Members
Mincom.LinkOne.Exceptions Namespace


BookExpiredException Constructor

[image]

LinkOne WebView API
BookExpiredException Constructor
BookExpiredException Class See Also Send Feedback
Initializes a new instance of the class.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookExpiredException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BookExpiredException()

See Also

BookExpiredException Class
BookExpiredException Overload
Mincom.LinkOne.Exceptions Namespace


BookExpiredException Constructor (String)

[image]

LinkOne WebView API
BookExpiredException Constructor (String)
BookExpiredException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookExpiredException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
BookExpiredException(
    String^ message
)

Parameters

message
Type: System..::.String
The exception message.

See Also

BookExpiredException Class
BookExpiredException Overload
Mincom.LinkOne.Exceptions Namespace


BookExpiredException Constructor (String, Exception)

[image]

LinkOne WebView API
BookExpiredException Constructor (String, Exception)
BookExpiredException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookExpiredException(
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
BookExpiredException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The exception to wrap.

See Also

BookExpiredException Class
BookExpiredException Overload
Mincom.LinkOne.Exceptions Namespace


BookExpiredException Constructor (String, String)

[image]

LinkOne WebView API
BookExpiredException Constructor (String, String)
BookExpiredException Class See Also Send Feedback
Initializes a new instance of the class.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookExpiredException(
    string publisherCode,
    string bookCode
)
Visual Basic (Declaration)
Public Sub New ( _
    publisherCode As String, _
    bookCode As String _
)
Visual C++
public:
BookExpiredException(
    String^ publisherCode,
    String^ bookCode
)

Parameters

publisherCode
Type: System..::.String
bookCode
Type: System..::.String

See Also

BookExpiredException Class
BookExpiredException Overload
Mincom.LinkOne.Exceptions Namespace


BookExpiredException Constructor (String, String, String)

[image]

LinkOne WebView API
BookExpiredException Constructor (String, String, String)
BookExpiredException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookExpiredException(
    string publisherCode,
    string bookCode,
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    publisherCode As String, _
    bookCode As String, _
    message As String _
)
Visual C++
public:
BookExpiredException(
    String^ publisherCode,
    String^ bookCode,
    String^ message
)

Parameters

publisherCode
Type: System..::.String
The publisher code.
bookCode
Type: System..::.String
The book code.
message
Type: System..::.String
The exception message.

See Also

BookExpiredException Class
BookExpiredException Overload
Mincom.LinkOne.Exceptions Namespace


BookExpiredException Constructor (String, String, String, Exception)

[image]

LinkOne WebView API
BookExpiredException Constructor (String, String, String, Exception)
BookExpiredException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookExpiredException(
    string publisherCode,
    string bookCode,
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    publisherCode As String, _
    bookCode As String, _
    message As String, _
    inner As Exception _
)
Visual C++
public:
BookExpiredException(
    String^ publisherCode,
    String^ bookCode,
    String^ message,
    Exception^ inner
)

Parameters

publisherCode
Type: System..::.String
The publisher code.
bookCode
Type: System..::.String
The book code.
message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The exception to wrap.

See Also

BookExpiredException Class
BookExpiredException Overload
Mincom.LinkOne.Exceptions Namespace


BookExpiredException Constructor (String, String, String, Object[])

[image]

LinkOne WebView API
BookExpiredException Constructor (String, String, String, array<Object>[]()[])
BookExpiredException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookExpiredException(
    string publisherCode,
    string bookCode,
    string message,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    publisherCode As String, _
    bookCode As String, _
    message As String, _
    ParamArray args As Object() _
)
Visual C++
public:
BookExpiredException(
    String^ publisherCode,
    String^ bookCode,
    String^ message,
    ... array<Object^>^ args
)

Parameters

publisherCode
Type: System..::.String
The publisher code.
bookCode
Type: System..::.String
The book code.
message
Type: System..::.String
The exception message with formatting escape sequences.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

BookExpiredException Class
BookExpiredException Overload
Mincom.LinkOne.Exceptions Namespace


BookExpiredException Constructor (String, String, String, Exception, Object[])

[image]

LinkOne WebView API
BookExpiredException Constructor (String, String, String, Exception, array<Object>[]()[])
BookExpiredException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookExpiredException(
    string publisherCode,
    string bookCode,
    string message,
    Exception inner,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    publisherCode As String, _
    bookCode As String, _
    message As String, _
    inner As Exception, _
    ParamArray args As Object() _
)
Visual C++
public:
BookExpiredException(
    String^ publisherCode,
    String^ bookCode,
    String^ message,
    Exception^ inner,
    ... array<Object^>^ args
)

Parameters

publisherCode
Type: System..::.String
The publisher code.
bookCode
Type: System..::.String
The book code.
message
Type: System..::.String
The exception message with formatting escape sequences.
inner
Type: System..::.Exception
The exception to wrap.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

BookExpiredException Class
BookExpiredException Overload
Mincom.LinkOne.Exceptions Namespace


BookExpiredException Methods

[image] [image]

LinkOne WebView API
BookExpiredException Methods
BookExpiredException Class See Also Send Feedback

The BookExpiredException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides LicenseException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

BookExpiredException Class
Mincom.LinkOne.Exceptions Namespace


GetObjectData Method

[image]

LinkOne WebView API
BookExpiredException..::.GetObjectData Method
BookExpiredException Class See Also Send Feedback
When overridden in a derived class, sets the SerializationInfo with information about the exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::.StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System..::.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

BookExpiredException Class
Mincom.LinkOne.Exceptions Namespace


BookExpiredException Properties

[image] [image]

LinkOne WebView API
BookExpiredException Properties
BookExpiredException Class See Also Send Feedback

The BookExpiredException type exposes the following members.

Properties

Name | Description
BookCode | Gets the book code.
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
PublisherCode | Gets the publisher code.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

BookExpiredException Class
Mincom.LinkOne.Exceptions Namespace


BookCode Property

[image]

LinkOne WebView API
BookExpiredException..::.BookCode Property
BookExpiredException Class See Also Send Feedback
Gets the book code.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string BookCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property BookCode As String
Visual C++
public:
property String^ BookCode {
    String^ get ();
}

See Also

BookExpiredException Class
Mincom.LinkOne.Exceptions Namespace


PublisherCode Property

[image]

LinkOne WebView API
BookExpiredException..::.PublisherCode Property
BookExpiredException Class See Also Send Feedback
Gets the publisher code.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PublisherCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublisherCode As String
Visual C++
public:
property String^ PublisherCode {
    String^ get ();
}

See Also

BookExpiredException Class
Mincom.LinkOne.Exceptions Namespace


BookNotFoundException Class

[image]

LinkOne WebView API
BookNotFoundException Class
Members See Also Send Feedback
The exception that is thrown when the wanted Mincom.LinkOne.Dom.Book is not found.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class BookNotFoundException : BaseException
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class BookNotFoundException _
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class BookNotFoundException sealed : public BaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Mincom.LinkOne.Exceptions..::.BaseException
Mincom.LinkOne.Exceptions..::.BookNotFoundException

See Also

BookNotFoundException Members
Mincom.LinkOne.Exceptions Namespace


BookNotFoundException Members

[image] [image]

LinkOne WebView API
BookNotFoundException Members
BookNotFoundException Class Constructors Methods Properties See Also Send Feedback

The BookNotFoundException type exposes the following members.

Constructors

Name | Description
BookNotFoundException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides BaseException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
BookCode | Gets the book code.
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
PublisherCode | Gets the publisher code.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

BookNotFoundException Class
Mincom.LinkOne.Exceptions Namespace


BookNotFoundException Constructor

[image] [image]

LinkOne WebView API
BookNotFoundException Constructor
BookNotFoundException Class See Also Send Feedback

Overload List

Name | Description
BookNotFoundException()()() | Initializes a new instance of the class.
BookNotFoundException(String) | Initializes a new instance of the class with a simple message.
BookNotFoundException(String, Exception) | Initializes a new instance of the class with a simple message and another exception.
BookNotFoundException(String, String) | Initializes a new instance of the class.
BookNotFoundException(String, String, String) | Initializes a new instance of the class with a simple message.
BookNotFoundException(String, String, String, Exception) | Initializes a new instance of the class with a simple message and another exception.
BookNotFoundException(String, String, String, array<Object>[]()[]) | Initializes a new instance of the class with a simple message.
BookNotFoundException(String, String, String, Exception, array<Object>[]()[]) | Initializes a new instance of the class with a simple message and another exception.

See Also

BookNotFoundException Class
BookNotFoundException Members
Mincom.LinkOne.Exceptions Namespace


BookNotFoundException Constructor

[image]

LinkOne WebView API
BookNotFoundException Constructor
BookNotFoundException Class See Also Send Feedback
Initializes a new instance of the class.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookNotFoundException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BookNotFoundException()

See Also

BookNotFoundException Class
BookNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


BookNotFoundException Constructor (String)

[image]

LinkOne WebView API
BookNotFoundException Constructor (String)
BookNotFoundException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookNotFoundException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
BookNotFoundException(
    String^ message
)

Parameters

message
Type: System..::.String
The exception message.

See Also

BookNotFoundException Class
BookNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


BookNotFoundException Constructor (String, Exception)

[image]

LinkOne WebView API
BookNotFoundException Constructor (String, Exception)
BookNotFoundException Class See Also Send Feedback
Initializes a new instance of the class with a simple message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookNotFoundException(
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
BookNotFoundException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The exception to wrap.

See Also

BookNotFoundException Class
BookNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


BookNotFoundException Constructor (String, String)

[image]

LinkOne WebView API
BookNotFoundException Constructor (String, String)
BookNotFoundException Class See Also Send Feedback
Initializes a new instance of the class.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookNotFoundException(
    string publisherCode,
    string bookCode
)
Visual Basic (Declaration)
Public Sub New ( _
    publisherCode As String, _
    bookCode As String _
)
Visual C++
public:
BookNotFoundException(
    String^ publisherCode,
    String^ bookCode
)

Parameters

publisherCode
Type: System..::.String
The publisher code.
bookCode
Type: System..::.String
The book code.

See Also

BookNotFoundException Class
BookNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


BookNotFoundException Constructor (String, String, String)

[image]

LinkOne WebView API
BookNotFoundException Constructor (String, String, String)
BookNotFoundException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookNotFoundException(
    string publisherCode,
    string bookCode,
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    publisherCode As String, _
    bookCode As String, _
    message As String _
)
Visual C++
public:
BookNotFoundException(
    String^ publisherCode,
    String^ bookCode,
    String^ message
)

Parameters

publisherCode
Type: System..::.String
The publisher code.
bookCode
Type: System..::.String
The book code.
message
Type: System..::.String
The exception message.

See Also

BookNotFoundException Class
BookNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


BookNotFoundException Constructor (String, String, String, Exception)

[image]

LinkOne WebView API
BookNotFoundException Constructor (String, String, String, Exception)
BookNotFoundException Class See Also Send Feedback
Initializes a new instance of the class with a simple message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookNotFoundException(
    string publisherCode,
    string bookCode,
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    publisherCode As String, _
    bookCode As String, _
    message As String, _
    inner As Exception _
)
Visual C++
public:
BookNotFoundException(
    String^ publisherCode,
    String^ bookCode,
    String^ message,
    Exception^ inner
)

Parameters

publisherCode
Type: System..::.String
The publisher code.
bookCode
Type: System..::.String
The book code.
message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The exception to wrap.

See Also

BookNotFoundException Class
BookNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


BookNotFoundException Constructor (String, String, String, Object[])

[image]

LinkOne WebView API
BookNotFoundException Constructor (String, String, String, array<Object>[]()[])
BookNotFoundException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookNotFoundException(
    string publisherCode,
    string bookCode,
    string message,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    publisherCode As String, _
    bookCode As String, _
    message As String, _
    ParamArray args As Object() _
)
Visual C++
public:
BookNotFoundException(
    String^ publisherCode,
    String^ bookCode,
    String^ message,
    ... array<Object^>^ args
)

Parameters

publisherCode
Type: System..::.String
The publisher code.
bookCode
Type: System..::.String
The book code.
message
Type: System..::.String
The exception message with formatting escape sequences.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

BookNotFoundException Class
BookNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


BookNotFoundException Constructor (String, String, String, Exception, Object[])

[image]

LinkOne WebView API
BookNotFoundException Constructor (String, String, String, Exception, array<Object>[]()[])
BookNotFoundException Class See Also Send Feedback
Initializes a new instance of the class with a simple message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookNotFoundException(
    string publisherCode,
    string bookCode,
    string message,
    Exception inner,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    publisherCode As String, _
    bookCode As String, _
    message As String, _
    inner As Exception, _
    ParamArray args As Object() _
)
Visual C++
public:
BookNotFoundException(
    String^ publisherCode,
    String^ bookCode,
    String^ message,
    Exception^ inner,
    ... array<Object^>^ args
)

Parameters

publisherCode
Type: System..::.String
The publisher code.
bookCode
Type: System..::.String
The book code.
message
Type: System..::.String
The exception message with formatting escape sequences.
inner
Type: System..::.Exception
The exception to wrap.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

BookNotFoundException Class
BookNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


BookNotFoundException Methods

[image] [image]

LinkOne WebView API
BookNotFoundException Methods
BookNotFoundException Class See Also Send Feedback

The BookNotFoundException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides BaseException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

BookNotFoundException Class
Mincom.LinkOne.Exceptions Namespace


GetObjectData Method

[image]

LinkOne WebView API
BookNotFoundException..::.GetObjectData Method
BookNotFoundException Class See Also Send Feedback
When overridden in a derived class, sets the SerializationInfo with information about the exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::.StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System..::.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

BookNotFoundException Class
Mincom.LinkOne.Exceptions Namespace


BookNotFoundException Properties

[image] [image]

LinkOne WebView API
BookNotFoundException Properties
BookNotFoundException Class See Also Send Feedback

The BookNotFoundException type exposes the following members.

Properties

Name | Description
BookCode | Gets the book code.
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
PublisherCode | Gets the publisher code.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

BookNotFoundException Class
Mincom.LinkOne.Exceptions Namespace


BookCode Property

[image]

LinkOne WebView API
BookNotFoundException..::.BookCode Property
BookNotFoundException Class See Also Send Feedback
Gets the book code.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string BookCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property BookCode As String
Visual C++
public:
property String^ BookCode {
    String^ get ();
}

See Also

BookNotFoundException Class
Mincom.LinkOne.Exceptions Namespace


PublisherCode Property

[image]

LinkOne WebView API
BookNotFoundException..::.PublisherCode Property
BookNotFoundException Class See Also Send Feedback
Gets the publisher code.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PublisherCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublisherCode As String
Visual C++
public:
property String^ PublisherCode {
    String^ get ();
}

See Also

BookNotFoundException Class
Mincom.LinkOne.Exceptions Namespace


BookReadException Class

[image]

LinkOne WebView API
BookReadException Class
Members See Also Send Feedback
This exception is thrown when the book being loaded contains errors.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class BookReadException : BaseException
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class BookReadException _
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class BookReadException sealed : public BaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Mincom.LinkOne.Exceptions..::.BaseException
Mincom.LinkOne.Exceptions..::.BookReadException

See Also

BookReadException Members
Mincom.LinkOne.Exceptions Namespace


BookReadException Members

[image] [image]

LinkOne WebView API
BookReadException Members
BookReadException Class Constructors Methods Properties See Also Send Feedback

The BookReadException type exposes the following members.

Constructors

Name | Description
BookReadException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

BookReadException Class
Mincom.LinkOne.Exceptions Namespace


BookReadException Constructor

[image] [image]

LinkOne WebView API
BookReadException Constructor
BookReadException Class See Also Send Feedback

Overload List

Name | Description
BookReadException()()() | Initializes a new instance of the class.
BookReadException(String) | Initializes a new instance of the class with a simple message.
BookReadException(String, Exception) | Initializes a new instance of the class with a message and another exception.
BookReadException(String, array<Object>[]()[]) | Initializes a new instance of the class with a simple message.
BookReadException(String, Exception, array<Object>[]()[]) | Initializes a new instance of the class with a message and another exception.

See Also

BookReadException Class
BookReadException Members
Mincom.LinkOne.Exceptions Namespace


BookReadException Constructor

[image]

LinkOne WebView API
BookReadException Constructor
BookReadException Class See Also Send Feedback
Initializes a new instance of the class.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookReadException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BookReadException()

See Also

BookReadException Class
BookReadException Overload
Mincom.LinkOne.Exceptions Namespace


BookReadException Constructor (String)

[image]

LinkOne WebView API
BookReadException Constructor (String)
BookReadException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookReadException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
BookReadException(
    String^ message
)

Parameters

message
Type: System..::.String
The exception message.

See Also

BookReadException Class
BookReadException Overload
Mincom.LinkOne.Exceptions Namespace


BookReadException Constructor (String, Exception)

[image]

LinkOne WebView API
BookReadException Constructor (String, Exception)
BookReadException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookReadException(
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
BookReadException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The exception to wrap.

See Also

BookReadException Class
BookReadException Overload
Mincom.LinkOne.Exceptions Namespace


BookReadException Constructor (String, Object[])

[image]

LinkOne WebView API
BookReadException Constructor (String, array<Object>[]()[])
BookReadException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookReadException(
    string message,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    ParamArray args As Object() _
)
Visual C++
public:
BookReadException(
    String^ message,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

BookReadException Class
BookReadException Overload
Mincom.LinkOne.Exceptions Namespace


BookReadException Constructor (String, Exception, Object[])

[image]

LinkOne WebView API
BookReadException Constructor (String, Exception, array<Object>[]()[])
BookReadException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public BookReadException(
    string message,
    Exception inner,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception, _
    ParamArray args As Object() _
)
Visual C++
public:
BookReadException(
    String^ message,
    Exception^ inner,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
inner
Type: System..::.Exception
The exception to wrap.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

BookReadException Class
BookReadException Overload
Mincom.LinkOne.Exceptions Namespace


BookReadException Methods

[image] [image]

LinkOne WebView API
BookReadException Methods
BookReadException Class See Also Send Feedback

The BookReadException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

BookReadException Class
Mincom.LinkOne.Exceptions Namespace


BookReadException Properties

[image] [image]

LinkOne WebView API
BookReadException Properties
BookReadException Class See Also Send Feedback

The BookReadException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

BookReadException Class
Mincom.LinkOne.Exceptions Namespace


CancelledException Class

[image]

LinkOne WebView API
CancelledException Class
Members See Also Send Feedback
The exception that is thrown when an operation is cancelled by the user.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class CancelledException : BaseException
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class CancelledException _
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class CancelledException sealed : public BaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Mincom.LinkOne.Exceptions..::.BaseException
Mincom.LinkOne.Exceptions..::.CancelledException

See Also

CancelledException Members
Mincom.LinkOne.Exceptions Namespace


CancelledException Members

[image] [image]

LinkOne WebView API
CancelledException Members
CancelledException Class Constructors Methods Properties See Also Send Feedback

The CancelledException type exposes the following members.

Constructors

Name | Description
CancelledException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CancelledException Class
Mincom.LinkOne.Exceptions Namespace


CancelledException Constructor

[image] [image]

LinkOne WebView API
CancelledException Constructor
CancelledException Class See Also Send Feedback

Overload List

Name | Description
CancelledException()()() | Initializes a new instance of the class.
CancelledException(String) | Initializes a new instance of the class with a message.
CancelledException(String, Exception) | Initializes a new instance of the class with a simple message and another exception.
CancelledException(String, array<Object>[]()[]) | Initializes a new instance of the class with a message.
CancelledException(String, Exception, array<Object>[]()[]) | Initializes a new instance of the class with a simple message and another exception.

See Also

CancelledException Class
CancelledException Members
Mincom.LinkOne.Exceptions Namespace


CancelledException Constructor

[image]

LinkOne WebView API
CancelledException Constructor
CancelledException Class See Also Send Feedback
Initializes a new instance of the class.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public CancelledException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CancelledException()

See Also

CancelledException Class
CancelledException Overload
Mincom.LinkOne.Exceptions Namespace


CancelledException Constructor (String)

[image]

LinkOne WebView API
CancelledException Constructor (String)
CancelledException Class See Also Send Feedback
Initializes a new instance of the class with a message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public CancelledException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
CancelledException(
    String^ message
)

Parameters

message
Type: System..::.String
The exception message.

See Also

CancelledException Class
CancelledException Overload
Mincom.LinkOne.Exceptions Namespace


CancelledException Constructor (String, Exception)

[image]

LinkOne WebView API
CancelledException Constructor (String, Exception)
CancelledException Class See Also Send Feedback
Initializes a new instance of the class with a simple message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public CancelledException(
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
CancelledException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The exception to wrap.

See Also

CancelledException Class
CancelledException Overload
Mincom.LinkOne.Exceptions Namespace


CancelledException Constructor (String, Object[])

[image]

LinkOne WebView API
CancelledException Constructor (String, array<Object>[]()[])
CancelledException Class See Also Send Feedback
Initializes a new instance of the class with a message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public CancelledException(
    string message,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    ParamArray args As Object() _
)
Visual C++
public:
CancelledException(
    String^ message,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

CancelledException Class
CancelledException Overload
Mincom.LinkOne.Exceptions Namespace


CancelledException Constructor (String, Exception, Object[])

[image]

LinkOne WebView API
CancelledException Constructor (String, Exception, array<Object>[]()[])
CancelledException Class See Also Send Feedback
Initializes a new instance of the class with a simple message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public CancelledException(
    string message,
    Exception inner,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception, _
    ParamArray args As Object() _
)
Visual C++
public:
CancelledException(
    String^ message,
    Exception^ inner,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
inner
Type: System..::.Exception
The exception to wrap.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

CancelledException Class
CancelledException Overload
Mincom.LinkOne.Exceptions Namespace


CancelledException Methods

[image] [image]

LinkOne WebView API
CancelledException Methods
CancelledException Class See Also Send Feedback

The CancelledException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

CancelledException Class
Mincom.LinkOne.Exceptions Namespace


CancelledException Properties

[image] [image]

LinkOne WebView API
CancelledException Properties
CancelledException Class See Also Send Feedback

The CancelledException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CancelledException Class
Mincom.LinkOne.Exceptions Namespace


ConfigurationManagerBusyException Class

[image]

LinkOne WebView API
ConfigurationManagerBusyException Class
Members See Also Send Feedback
The exception that is thrown when the configuration manager generates a busy error.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class ConfigurationManagerBusyException : BaseException
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class ConfigurationManagerBusyException _
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class ConfigurationManagerBusyException sealed : public BaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Mincom.LinkOne.Exceptions..::.BaseException
Mincom.LinkOne.Exceptions..::.ConfigurationManagerBusyException

See Also

ConfigurationManagerBusyException Members
Mincom.LinkOne.Exceptions Namespace


ConfigurationManagerBusyException Members

[image] [image]

LinkOne WebView API
ConfigurationManagerBusyException Members
ConfigurationManagerBusyException Class Constructors Methods Properties See Also Send Feedback

The ConfigurationManagerBusyException type exposes the following members.

Constructors

Name | Description
ConfigurationManagerBusyException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ConfigurationManagerBusyException Class
Mincom.LinkOne.Exceptions Namespace


ConfigurationManagerBusyException Constructor

[image] [image]

LinkOne WebView API
ConfigurationManagerBusyException Constructor
ConfigurationManagerBusyException Class See Also Send Feedback

Overload List

Name | Description
ConfigurationManagerBusyException()()() | Initializes a new instance of the class.
ConfigurationManagerBusyException(String) | Initializes a new instance of the class with a simple message.
ConfigurationManagerBusyException(String, Exception) | Initializes a new instance of the class with a simple message and another exception.
ConfigurationManagerBusyException(String, array<Object>[]()[]) | Initializes a new instance of the class with a simple message.
ConfigurationManagerBusyException(String, Exception, array<Object>[]()[]) | Initializes a new instance of the class with a simple message and another exception.

See Also

ConfigurationManagerBusyException Class
ConfigurationManagerBusyException Members
Mincom.LinkOne.Exceptions Namespace


ConfigurationManagerBusyException Constructor

[image]

LinkOne WebView API
ConfigurationManagerBusyException Constructor
ConfigurationManagerBusyException Class See Also Send Feedback
Initializes a new instance of the class.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ConfigurationManagerBusyException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConfigurationManagerBusyException()

See Also

ConfigurationManagerBusyException Class
ConfigurationManagerBusyException Overload
Mincom.LinkOne.Exceptions Namespace


ConfigurationManagerBusyException Constructor (String)

[image]

LinkOne WebView API
ConfigurationManagerBusyException Constructor (String)
ConfigurationManagerBusyException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ConfigurationManagerBusyException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
ConfigurationManagerBusyException(
    String^ message
)

Parameters

message
Type: System..::.String
The exception message.

See Also

ConfigurationManagerBusyException Class
ConfigurationManagerBusyException Overload
Mincom.LinkOne.Exceptions Namespace


ConfigurationManagerBusyException Constructor (String, Exception)

[image]

LinkOne WebView API
ConfigurationManagerBusyException Constructor (String, Exception)
ConfigurationManagerBusyException Class See Also Send Feedback
Initializes a new instance of the class with a simple message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ConfigurationManagerBusyException(
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
ConfigurationManagerBusyException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The exception to wrap.

See Also

ConfigurationManagerBusyException Class
ConfigurationManagerBusyException Overload
Mincom.LinkOne.Exceptions Namespace


ConfigurationManagerBusyException Constructor (String, Object[])

[image]

LinkOne WebView API
ConfigurationManagerBusyException Constructor (String, array<Object>[]()[])
ConfigurationManagerBusyException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ConfigurationManagerBusyException(
    string message,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    ParamArray args As Object() _
)
Visual C++
public:
ConfigurationManagerBusyException(
    String^ message,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

ConfigurationManagerBusyException Class
ConfigurationManagerBusyException Overload
Mincom.LinkOne.Exceptions Namespace


ConfigurationManagerBusyException Constructor (String, Exception, Object[])

[image]

LinkOne WebView API
ConfigurationManagerBusyException Constructor (String, Exception, array<Object>[]()[])
ConfigurationManagerBusyException Class See Also Send Feedback
Initializes a new instance of the class with a simple message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ConfigurationManagerBusyException(
    string message,
    Exception inner,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception, _
    ParamArray args As Object() _
)
Visual C++
public:
ConfigurationManagerBusyException(
    String^ message,
    Exception^ inner,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
inner
Type: System..::.Exception
The exception to wrap.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

ConfigurationManagerBusyException Class
ConfigurationManagerBusyException Overload
Mincom.LinkOne.Exceptions Namespace


ConfigurationManagerBusyException Methods

[image] [image]

LinkOne WebView API
ConfigurationManagerBusyException Methods
ConfigurationManagerBusyException Class See Also Send Feedback

The ConfigurationManagerBusyException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ConfigurationManagerBusyException Class
Mincom.LinkOne.Exceptions Namespace


ConfigurationManagerBusyException Properties

[image] [image]

LinkOne WebView API
ConfigurationManagerBusyException Properties
ConfigurationManagerBusyException Class See Also Send Feedback

The ConfigurationManagerBusyException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ConfigurationManagerBusyException Class
Mincom.LinkOne.Exceptions Namespace


ConfigurationManagerException Class

[image]

LinkOne WebView API
ConfigurationManagerException Class
Members See Also Send Feedback
The exception that is thrown when the configuration manager generates an error.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class ConfigurationManagerException : BaseException
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class ConfigurationManagerException _
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class ConfigurationManagerException sealed : public BaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Mincom.LinkOne.Exceptions..::.BaseException
Mincom.LinkOne.Exceptions..::.ConfigurationManagerException

See Also

ConfigurationManagerException Members
Mincom.LinkOne.Exceptions Namespace


ConfigurationManagerException Members

[image] [image]

LinkOne WebView API
ConfigurationManagerException Members
ConfigurationManagerException Class Constructors Methods Properties See Also Send Feedback

The ConfigurationManagerException type exposes the following members.

Constructors

Name | Description
ConfigurationManagerException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ConfigurationManagerException Class
Mincom.LinkOne.Exceptions Namespace


ConfigurationManagerException Constructor

[image] [image]

LinkOne WebView API
ConfigurationManagerException Constructor
ConfigurationManagerException Class See Also Send Feedback

Overload List

Name | Description
ConfigurationManagerException()()() | Initializes a new instance of the class.
ConfigurationManagerException(String) | Initializes a new instance of the class with a simple message.
ConfigurationManagerException(String, Exception) | Initializes a new instance of the class with a simple message and another exception.
ConfigurationManagerException(String, array<Object>[]()[]) | Initializes a new instance of the class with a simple message.
ConfigurationManagerException(String, Exception, array<Object>[]()[]) | Initializes a new instance of the class with a simple message and another exception.

See Also

ConfigurationManagerException Class
ConfigurationManagerException Members
Mincom.LinkOne.Exceptions Namespace


ConfigurationManagerException Constructor

[image]

LinkOne WebView API
ConfigurationManagerException Constructor
ConfigurationManagerException Class See Also Send Feedback
Initializes a new instance of the class.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ConfigurationManagerException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConfigurationManagerException()

See Also

ConfigurationManagerException Class
ConfigurationManagerException Overload
Mincom.LinkOne.Exceptions Namespace


ConfigurationManagerException Constructor (String)

[image]

LinkOne WebView API
ConfigurationManagerException Constructor (String)
ConfigurationManagerException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ConfigurationManagerException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
ConfigurationManagerException(
    String^ message
)

Parameters

message
Type: System..::.String
The exception message.

See Also

ConfigurationManagerException Class
ConfigurationManagerException Overload
Mincom.LinkOne.Exceptions Namespace


ConfigurationManagerException Constructor (String, Exception)

[image]

LinkOne WebView API
ConfigurationManagerException Constructor (String, Exception)
ConfigurationManagerException Class See Also Send Feedback
Initializes a new instance of the class with a simple message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ConfigurationManagerException(
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
ConfigurationManagerException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The exception to wrap.

See Also

ConfigurationManagerException Class
ConfigurationManagerException Overload
Mincom.LinkOne.Exceptions Namespace


ConfigurationManagerException Constructor (String, Object[])

[image]

LinkOne WebView API
ConfigurationManagerException Constructor (String, array<Object>[]()[])
ConfigurationManagerException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ConfigurationManagerException(
    string message,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    ParamArray args As Object() _
)
Visual C++
public:
ConfigurationManagerException(
    String^ message,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

ConfigurationManagerException Class
ConfigurationManagerException Overload
Mincom.LinkOne.Exceptions Namespace


ConfigurationManagerException Constructor (String, Exception, Object[])

[image]

LinkOne WebView API
ConfigurationManagerException Constructor (String, Exception, array<Object>[]()[])
ConfigurationManagerException Class See Also Send Feedback
Initializes a new instance of the class with a simple message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ConfigurationManagerException(
    string message,
    Exception inner,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception, _
    ParamArray args As Object() _
)
Visual C++
public:
ConfigurationManagerException(
    String^ message,
    Exception^ inner,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
inner
Type: System..::.Exception
The exception to wrap.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

ConfigurationManagerException Class
ConfigurationManagerException Overload
Mincom.LinkOne.Exceptions Namespace


ConfigurationManagerException Methods

[image] [image]

LinkOne WebView API
ConfigurationManagerException Methods
ConfigurationManagerException Class See Also Send Feedback

The ConfigurationManagerException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ConfigurationManagerException Class
Mincom.LinkOne.Exceptions Namespace


ConfigurationManagerException Properties

[image] [image]

LinkOne WebView API
ConfigurationManagerException Properties
ConfigurationManagerException Class See Also Send Feedback

The ConfigurationManagerException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ConfigurationManagerException Class
Mincom.LinkOne.Exceptions Namespace


ConfiguredObjectNotFoundException Class

[image]

LinkOne WebView API
ConfiguredObjectNotFoundException Class
Members See Also Send Feedback
The exception that is thrown when the wanted configured object is not found.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class ConfiguredObjectNotFoundException : BaseException
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class ConfiguredObjectNotFoundException _
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class ConfiguredObjectNotFoundException sealed : public BaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Mincom.LinkOne.Exceptions..::.BaseException
Mincom.LinkOne.Exceptions..::.ConfiguredObjectNotFoundException

See Also

ConfiguredObjectNotFoundException Members
Mincom.LinkOne.Exceptions Namespace


ConfiguredObjectNotFoundException Members

[image] [image]

LinkOne WebView API
ConfiguredObjectNotFoundException Members
ConfiguredObjectNotFoundException Class Constructors Methods Properties See Also Send Feedback

The ConfiguredObjectNotFoundException type exposes the following members.

Constructors

Name | Description
ConfiguredObjectNotFoundException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ConfiguredObjectNotFoundException Class
Mincom.LinkOne.Exceptions Namespace


ConfiguredObjectNotFoundException Constructor

[image] [image]

LinkOne WebView API
ConfiguredObjectNotFoundException Constructor
ConfiguredObjectNotFoundException Class See Also Send Feedback

Overload List

Name | Description
ConfiguredObjectNotFoundException()()() | Initializes a new instance of the class.
ConfiguredObjectNotFoundException(String) | Initializes a new instance of the class with a simple message.
ConfiguredObjectNotFoundException(String, Exception) | Initializes a new instance of the class with a simple message and another exception.
ConfiguredObjectNotFoundException(String, array<Object>[]()[]) | Initializes a new instance of the class with a simple message.
ConfiguredObjectNotFoundException(String, Exception, array<Object>[]()[]) | Initializes a new instance of the class with a simple message and another exception.

See Also

ConfiguredObjectNotFoundException Class
ConfiguredObjectNotFoundException Members
Mincom.LinkOne.Exceptions Namespace


ConfiguredObjectNotFoundException Constructor

[image]

LinkOne WebView API
ConfiguredObjectNotFoundException Constructor
ConfiguredObjectNotFoundException Class See Also Send Feedback
Initializes a new instance of the class.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ConfiguredObjectNotFoundException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConfiguredObjectNotFoundException()

See Also

ConfiguredObjectNotFoundException Class
ConfiguredObjectNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


ConfiguredObjectNotFoundException Constructor (String)

[image]

LinkOne WebView API
ConfiguredObjectNotFoundException Constructor (String)
ConfiguredObjectNotFoundException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ConfiguredObjectNotFoundException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
ConfiguredObjectNotFoundException(
    String^ message
)

Parameters

message
Type: System..::.String
The exception message.

See Also

ConfiguredObjectNotFoundException Class
ConfiguredObjectNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


ConfiguredObjectNotFoundException Constructor (String, Exception)

[image]

LinkOne WebView API
ConfiguredObjectNotFoundException Constructor (String, Exception)
ConfiguredObjectNotFoundException Class See Also Send Feedback
Initializes a new instance of the class with a simple message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ConfiguredObjectNotFoundException(
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
ConfiguredObjectNotFoundException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The exception to wrap.

See Also

ConfiguredObjectNotFoundException Class
ConfiguredObjectNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


ConfiguredObjectNotFoundException Constructor (String, Object[])

[image]

LinkOne WebView API
ConfiguredObjectNotFoundException Constructor (String, array<Object>[]()[])
ConfiguredObjectNotFoundException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ConfiguredObjectNotFoundException(
    string message,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    ParamArray args As Object() _
)
Visual C++
public:
ConfiguredObjectNotFoundException(
    String^ message,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

ConfiguredObjectNotFoundException Class
ConfiguredObjectNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


ConfiguredObjectNotFoundException Constructor (String, Exception, Object[])

[image]

LinkOne WebView API
ConfiguredObjectNotFoundException Constructor (String, Exception, array<Object>[]()[])
ConfiguredObjectNotFoundException Class See Also Send Feedback
Initializes a new instance of the class with a simple message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ConfiguredObjectNotFoundException(
    string message,
    Exception inner,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception, _
    ParamArray args As Object() _
)
Visual C++
public:
ConfiguredObjectNotFoundException(
    String^ message,
    Exception^ inner,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
inner
Type: System..::.Exception
The exception to wrap.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

ConfiguredObjectNotFoundException Class
ConfiguredObjectNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


ConfiguredObjectNotFoundException Methods

[image] [image]

LinkOne WebView API
ConfiguredObjectNotFoundException Methods
ConfiguredObjectNotFoundException Class See Also Send Feedback

The ConfiguredObjectNotFoundException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ConfiguredObjectNotFoundException Class
Mincom.LinkOne.Exceptions Namespace


ConfiguredObjectNotFoundException Properties

[image] [image]

LinkOne WebView API
ConfiguredObjectNotFoundException Properties
ConfiguredObjectNotFoundException Class See Also Send Feedback

The ConfiguredObjectNotFoundException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ConfiguredObjectNotFoundException Class
Mincom.LinkOne.Exceptions Namespace


DataChangedException Class

[image]

LinkOne WebView API
DataChangedException Class
Members See Also Send Feedback
The exception when underlying data has changed during a read-modify-write operation.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class DataChangedException : BaseException
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class DataChangedException _
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class DataChangedException sealed : public BaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Mincom.LinkOne.Exceptions..::.BaseException
Mincom.LinkOne.Exceptions..::.DataChangedException

See Also

DataChangedException Members
Mincom.LinkOne.Exceptions Namespace


DataChangedException Members

[image] [image]

LinkOne WebView API
DataChangedException Members
DataChangedException Class Constructors Methods Properties See Also Send Feedback

The DataChangedException type exposes the following members.

Constructors

Name | Description
DataChangedException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DataChangedException Class
Mincom.LinkOne.Exceptions Namespace


DataChangedException Constructor

[image] [image]

LinkOne WebView API
DataChangedException Constructor
DataChangedException Class See Also Send Feedback

Overload List

Name | Description
DataChangedException()()() | Initializes a new instance of the class.
DataChangedException(String) | Initializes a new instance of the class with a simple message.
DataChangedException(String, Exception) | Initializes a new instance of the class with a simple message and another exception.
DataChangedException(String, array<Object>[]()[]) | Initializes a new instance of the class with a simple message.
DataChangedException(String, Exception, array<Object>[]()[]) | Initializes a new instance of the class with a simple message and another exception.

See Also

DataChangedException Class
DataChangedException Members
Mincom.LinkOne.Exceptions Namespace


DataChangedException Constructor

[image]

LinkOne WebView API
DataChangedException Constructor
DataChangedException Class See Also Send Feedback
Initializes a new instance of the class.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public DataChangedException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataChangedException()

See Also

DataChangedException Class
DataChangedException Overload
Mincom.LinkOne.Exceptions Namespace


DataChangedException Constructor (String)

[image]

LinkOne WebView API
DataChangedException Constructor (String)
DataChangedException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public DataChangedException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
DataChangedException(
    String^ message
)

Parameters

message
Type: System..::.String
The exception message.

See Also

DataChangedException Class
DataChangedException Overload
Mincom.LinkOne.Exceptions Namespace


DataChangedException Constructor (String, Exception)

[image]

LinkOne WebView API
DataChangedException Constructor (String, Exception)
DataChangedException Class See Also Send Feedback
Initializes a new instance of the class with a simple message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public DataChangedException(
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
DataChangedException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The exception to wrap.

See Also

DataChangedException Class
DataChangedException Overload
Mincom.LinkOne.Exceptions Namespace


DataChangedException Constructor (String, Object[])

[image]

LinkOne WebView API
DataChangedException Constructor (String, array<Object>[]()[])
DataChangedException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public DataChangedException(
    string message,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    ParamArray args As Object() _
)
Visual C++
public:
DataChangedException(
    String^ message,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

DataChangedException Class
DataChangedException Overload
Mincom.LinkOne.Exceptions Namespace


DataChangedException Constructor (String, Exception, Object[])

[image]

LinkOne WebView API
DataChangedException Constructor (String, Exception, array<Object>[]()[])
DataChangedException Class See Also Send Feedback
Initializes a new instance of the class with a simple message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public DataChangedException(
    string message,
    Exception inner,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception, _
    ParamArray args As Object() _
)
Visual C++
public:
DataChangedException(
    String^ message,
    Exception^ inner,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
inner
Type: System..::.Exception
The exception to wrap.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

DataChangedException Class
DataChangedException Overload
Mincom.LinkOne.Exceptions Namespace


DataChangedException Methods

[image] [image]

LinkOne WebView API
DataChangedException Methods
DataChangedException Class See Also Send Feedback

The DataChangedException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DataChangedException Class
Mincom.LinkOne.Exceptions Namespace


DataChangedException Properties

[image] [image]

LinkOne WebView API
DataChangedException Properties
DataChangedException Class See Also Send Feedback

The DataChangedException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DataChangedException Class
Mincom.LinkOne.Exceptions Namespace


GraphicNotFoundException Class

[image]

LinkOne WebView API
GraphicNotFoundException Class
Members See Also Send Feedback
The exception that is thrown when the wanted Mincom.LinkOne.Dom.Graphic is not found.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class GraphicNotFoundException : BaseException
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class GraphicNotFoundException _
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class GraphicNotFoundException sealed : public BaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Mincom.LinkOne.Exceptions..::.BaseException
Mincom.LinkOne.Exceptions..::.GraphicNotFoundException

See Also

GraphicNotFoundException Members
Mincom.LinkOne.Exceptions Namespace


GraphicNotFoundException Members

[image] [image]

LinkOne WebView API
GraphicNotFoundException Members
GraphicNotFoundException Class Constructors Methods Properties See Also Send Feedback

The GraphicNotFoundException type exposes the following members.

Constructors

Name | Description
GraphicNotFoundException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

GraphicNotFoundException Class
Mincom.LinkOne.Exceptions Namespace


GraphicNotFoundException Constructor

[image] [image]

LinkOne WebView API
GraphicNotFoundException Constructor
GraphicNotFoundException Class See Also Send Feedback

Overload List

Name | Description
GraphicNotFoundException()()() | Initializes a new instance of the class.
GraphicNotFoundException(String) | Initializes a new instance of the class with a message.
GraphicNotFoundException(String, Exception) | Initializes a new instance of the class with a simple message and another exception.
GraphicNotFoundException(String, array<Object>[]()[]) | Initializes a new instance of the class with a message.
GraphicNotFoundException(String, Exception, array<Object>[]()[]) | Initializes a new instance of the class with a simple message and another exception.

See Also

GraphicNotFoundException Class
GraphicNotFoundException Members
Mincom.LinkOne.Exceptions Namespace


GraphicNotFoundException Constructor

[image]

LinkOne WebView API
GraphicNotFoundException Constructor
GraphicNotFoundException Class See Also Send Feedback
Initializes a new instance of the class.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public GraphicNotFoundException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GraphicNotFoundException()

See Also

GraphicNotFoundException Class
GraphicNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


GraphicNotFoundException Constructor (String)

[image]

LinkOne WebView API
GraphicNotFoundException Constructor (String)
GraphicNotFoundException Class See Also Send Feedback
Initializes a new instance of the class with a message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public GraphicNotFoundException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
GraphicNotFoundException(
    String^ message
)

Parameters

message
Type: System..::.String
The exception message.

See Also

GraphicNotFoundException Class
GraphicNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


GraphicNotFoundException Constructor (String, Exception)

[image]

LinkOne WebView API
GraphicNotFoundException Constructor (String, Exception)
GraphicNotFoundException Class See Also Send Feedback
Initializes a new instance of the class with a simple message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public GraphicNotFoundException(
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
GraphicNotFoundException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The exception to wrap.

See Also

GraphicNotFoundException Class
GraphicNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


GraphicNotFoundException Constructor (String, Object[])

[image]

LinkOne WebView API
GraphicNotFoundException Constructor (String, array<Object>[]()[])
GraphicNotFoundException Class See Also Send Feedback
Initializes a new instance of the class with a message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public GraphicNotFoundException(
    string message,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    ParamArray args As Object() _
)
Visual C++
public:
GraphicNotFoundException(
    String^ message,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

GraphicNotFoundException Class
GraphicNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


GraphicNotFoundException Constructor (String, Exception, Object[])

[image]

LinkOne WebView API
GraphicNotFoundException Constructor (String, Exception, array<Object>[]()[])
GraphicNotFoundException Class See Also Send Feedback
Initializes a new instance of the class with a simple message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public GraphicNotFoundException(
    string message,
    Exception inner,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception, _
    ParamArray args As Object() _
)
Visual C++
public:
GraphicNotFoundException(
    String^ message,
    Exception^ inner,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
inner
Type: System..::.Exception
The exception to wrap.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

GraphicNotFoundException Class
GraphicNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


GraphicNotFoundException Methods

[image] [image]

LinkOne WebView API
GraphicNotFoundException Methods
GraphicNotFoundException Class See Also Send Feedback

The GraphicNotFoundException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

GraphicNotFoundException Class
Mincom.LinkOne.Exceptions Namespace


GraphicNotFoundException Properties

[image] [image]

LinkOne WebView API
GraphicNotFoundException Properties
GraphicNotFoundException Class See Also Send Feedback

The GraphicNotFoundException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

GraphicNotFoundException Class
Mincom.LinkOne.Exceptions Namespace


IOException Class

[image]

LinkOne WebView API
IOException Class
Members See Also Send Feedback
This exception is thrown from the File class when an IO Exception occurs.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class IOException : BaseException
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class IOException _
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class IOException sealed : public BaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Mincom.LinkOne.Exceptions..::.BaseException
Mincom.LinkOne.Exceptions..::.IOException

See Also

IOException Members
Mincom.LinkOne.Exceptions Namespace


IOException Members

[image] [image]

LinkOne WebView API
IOException Members
IOException Class Constructors Methods Properties See Also Send Feedback

The IOException type exposes the following members.

Constructors

Name | Description
IOException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

IOException Class
Mincom.LinkOne.Exceptions Namespace


IOException Constructor

[image] [image]

LinkOne WebView API
IOException Constructor
IOException Class See Also Send Feedback

Overload List

Name | Description
IOException()()() | Initializes a new instance of the class.
IOException(String) | Initializes a new instance of the class with a message.
IOException(String, Exception) | Initializes a new instance of the class with a message and another exception.
IOException(String, array<Object>[]()[]) | Initializes a new instance of the class with a message.
IOException(String, Exception, array<Object>[]()[]) | Initializes a new instance of the class with a message and another exception.

See Also

IOException Class
IOException Members
Mincom.LinkOne.Exceptions Namespace


IOException Constructor

[image]

LinkOne WebView API
IOException Constructor
IOException Class See Also Send Feedback
Initializes a new instance of the class.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IOException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
IOException()

See Also

IOException Class
IOException Overload
Mincom.LinkOne.Exceptions Namespace


IOException Constructor (String)

[image]

LinkOne WebView API
IOException Constructor (String)
IOException Class See Also Send Feedback
Initializes a new instance of the class with a message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IOException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
IOException(
    String^ message
)

Parameters

message
Type: System..::.String
The exception message.

See Also

IOException Class
IOException Overload
Mincom.LinkOne.Exceptions Namespace


IOException Constructor (String, Exception)

[image]

LinkOne WebView API
IOException Constructor (String, Exception)
IOException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IOException(
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
IOException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The exception to wrap.

See Also

IOException Class
IOException Overload
Mincom.LinkOne.Exceptions Namespace


IOException Constructor (String, Object[])

[image]

LinkOne WebView API
IOException Constructor (String, array<Object>[]()[])
IOException Class See Also Send Feedback
Initializes a new instance of the class with a message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IOException(
    string message,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    ParamArray args As Object() _
)
Visual C++
public:
IOException(
    String^ message,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

IOException Class
IOException Overload
Mincom.LinkOne.Exceptions Namespace


IOException Constructor (String, Exception, Object[])

[image]

LinkOne WebView API
IOException Constructor (String, Exception, array<Object>[]()[])
IOException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IOException(
    string message,
    Exception inner,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception, _
    ParamArray args As Object() _
)
Visual C++
public:
IOException(
    String^ message,
    Exception^ inner,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
inner
Type: System..::.Exception
The exception to wrap.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

IOException Class
IOException Overload
Mincom.LinkOne.Exceptions Namespace


IOException Methods

[image] [image]

LinkOne WebView API
IOException Methods
IOException Class See Also Send Feedback

The IOException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

IOException Class
Mincom.LinkOne.Exceptions Namespace


IOException Properties

[image] [image]

LinkOne WebView API
IOException Properties
IOException Class See Also Send Feedback

The IOException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

IOException Class
Mincom.LinkOne.Exceptions Namespace


LayoutReadException Class

[image]

LinkOne WebView API
LayoutReadException Class
Members See Also Send Feedback
This is thrown when a layout reader encounteres a problem.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class LayoutReadException : BaseException
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class LayoutReadException _
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class LayoutReadException sealed : public BaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Mincom.LinkOne.Exceptions..::.BaseException
Mincom.LinkOne.Exceptions..::.LayoutReadException

See Also

LayoutReadException Members
Mincom.LinkOne.Exceptions Namespace


LayoutReadException Members

[image] [image]

LinkOne WebView API
LayoutReadException Members
LayoutReadException Class Constructors Methods Properties See Also Send Feedback

The LayoutReadException type exposes the following members.

Constructors

Name | Description
LayoutReadException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LayoutReadException Class
Mincom.LinkOne.Exceptions Namespace


LayoutReadException Constructor

[image] [image]

LinkOne WebView API
LayoutReadException Constructor
LayoutReadException Class See Also Send Feedback

Overload List

Name | Description
LayoutReadException()()() | Initializes a new instance of the class.
LayoutReadException(String) | Initializes a new instance of the class with a simple message.
LayoutReadException(String, Exception) | Initializes a new instance of the class with a message and another exception.
LayoutReadException(String, array<Object>[]()[]) | Initializes a new instance of the class with a simple message.
LayoutReadException(String, Exception, array<Object>[]()[]) | Initializes a new instance of the class with a message and another exception.

See Also

LayoutReadException Class
LayoutReadException Members
Mincom.LinkOne.Exceptions Namespace


LayoutReadException Constructor

[image]

LinkOne WebView API
LayoutReadException Constructor
LayoutReadException Class See Also Send Feedback
Initializes a new instance of the class.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LayoutReadException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LayoutReadException()

See Also

LayoutReadException Class
LayoutReadException Overload
Mincom.LinkOne.Exceptions Namespace


LayoutReadException Constructor (String)

[image]

LinkOne WebView API
LayoutReadException Constructor (String)
LayoutReadException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LayoutReadException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
LayoutReadException(
    String^ message
)

Parameters

message
Type: System..::.String
The exception message.

See Also

LayoutReadException Class
LayoutReadException Overload
Mincom.LinkOne.Exceptions Namespace


LayoutReadException Constructor (String, Exception)

[image]

LinkOne WebView API
LayoutReadException Constructor (String, Exception)
LayoutReadException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LayoutReadException(
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
LayoutReadException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The exception to wrap.

See Also

LayoutReadException Class
LayoutReadException Overload
Mincom.LinkOne.Exceptions Namespace


LayoutReadException Constructor (String, Object[])

[image]

LinkOne WebView API
LayoutReadException Constructor (String, array<Object>[]()[])
LayoutReadException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LayoutReadException(
    string message,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    ParamArray args As Object() _
)
Visual C++
public:
LayoutReadException(
    String^ message,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

LayoutReadException Class
LayoutReadException Overload
Mincom.LinkOne.Exceptions Namespace


LayoutReadException Constructor (String, Exception, Object[])

[image]

LinkOne WebView API
LayoutReadException Constructor (String, Exception, array<Object>[]()[])
LayoutReadException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LayoutReadException(
    string message,
    Exception inner,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception, _
    ParamArray args As Object() _
)
Visual C++
public:
LayoutReadException(
    String^ message,
    Exception^ inner,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
inner
Type: System..::.Exception
The exception to wrap.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

LayoutReadException Class
LayoutReadException Overload
Mincom.LinkOne.Exceptions Namespace


LayoutReadException Methods

[image] [image]

LinkOne WebView API
LayoutReadException Methods
LayoutReadException Class See Also Send Feedback

The LayoutReadException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

LayoutReadException Class
Mincom.LinkOne.Exceptions Namespace


LayoutReadException Properties

[image] [image]

LinkOne WebView API
LayoutReadException Properties
LayoutReadException Class See Also Send Feedback

The LayoutReadException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LayoutReadException Class
Mincom.LinkOne.Exceptions Namespace


LicenseException Class

[image]

LinkOne WebView API
LicenseException Class
Members See Also Send Feedback
This exception is thrown from the LinkOne DOM when a security exception occurs.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public class LicenseException : BaseException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class LicenseException _
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class LicenseException : public BaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Mincom.LinkOne.Exceptions..::.BaseException
Mincom.LinkOne.Exceptions..::.LicenseException
Mincom.LinkOne.Exceptions..::.BookExpiredException
Mincom.LinkOne.Exceptions..::.LicenseExpiredException
Mincom.LinkOne.Exceptions..::.LicenseLockException

See Also

LicenseException Members
Mincom.LinkOne.Exceptions Namespace


LicenseException Members

[image] [image]

LinkOne WebView API
LicenseException Members
LicenseException Class Constructors Methods Properties See Also Send Feedback

The LicenseException type exposes the following members.

Constructors

Name | Description
LicenseException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides BaseException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LicenseException Class
Mincom.LinkOne.Exceptions Namespace


LicenseException Constructor

[image] [image]

LinkOne WebView API
LicenseException Constructor
LicenseException Class See Also Send Feedback

Overload List

Name | Description
LicenseException()()() | Initializes a new instance of the class.
LicenseException(String) | Initializes a new instance of the class with a message.
LicenseException(SerializationInfo, StreamingContext) | Initializes a new instance of the class with serialized data.
LicenseException(String, Exception) | Initializes a new instance of the class with a message and another exception.
LicenseException(String, array<Object>[]()[]) | Initializes a new instance of the class with a message.
LicenseException(String, Exception, array<Object>[]()[]) | Initializes a new instance of the class with a message and another exception.

See Also

LicenseException Class
LicenseException Members
Mincom.LinkOne.Exceptions Namespace


LicenseException Constructor

[image]

LinkOne WebView API
LicenseException Constructor
LicenseException Class See Also Send Feedback
Initializes a new instance of the class.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LicenseException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LicenseException()

See Also

LicenseException Class
LicenseException Overload
Mincom.LinkOne.Exceptions Namespace


LicenseException Constructor (String)

[image]

LinkOne WebView API
LicenseException Constructor (String)
LicenseException Class See Also Send Feedback
Initializes a new instance of the class with a message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LicenseException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
LicenseException(
    String^ message
)

Parameters

message
Type: System..::.String
The exception message.

See Also

LicenseException Class
LicenseException Overload
Mincom.LinkOne.Exceptions Namespace


LicenseException Constructor (SerializationInfo, StreamingContext)

[image]

LinkOne WebView API
LicenseException Constructor (SerializationInfo, StreamingContext)
LicenseException Class See Also Send Feedback
Initializes a new instance of the class with serialized data.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected LicenseException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
LicenseException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The object that holds the serialized object data.
context
Type: System.Runtime.Serialization..::.StreamingContext
The contextual information about the source or destination.

See Also

LicenseException Class
LicenseException Overload
Mincom.LinkOne.Exceptions Namespace


LicenseException Constructor (String, Exception)

[image]

LinkOne WebView API
LicenseException Constructor (String, Exception)
LicenseException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LicenseException(
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
LicenseException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The exception to wrap.

See Also

LicenseException Class
LicenseException Overload
Mincom.LinkOne.Exceptions Namespace


LicenseException Constructor (String, Object[])

[image]

LinkOne WebView API
LicenseException Constructor (String, array<Object>[]()[])
LicenseException Class See Also Send Feedback
Initializes a new instance of the class with a message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LicenseException(
    string message,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    ParamArray args As Object() _
)
Visual C++
public:
LicenseException(
    String^ message,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

LicenseException Class
LicenseException Overload
Mincom.LinkOne.Exceptions Namespace


LicenseException Constructor (String, Exception, Object[])

[image]

LinkOne WebView API
LicenseException Constructor (String, Exception, array<Object>[]()[])
LicenseException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LicenseException(
    string message,
    Exception inner,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception, _
    ParamArray args As Object() _
)
Visual C++
public:
LicenseException(
    String^ message,
    Exception^ inner,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
inner
Type: System..::.Exception
The exception to wrap.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

LicenseException Class
LicenseException Overload
Mincom.LinkOne.Exceptions Namespace


LicenseException Methods

[image] [image]

LinkOne WebView API
LicenseException Methods
LicenseException Class See Also Send Feedback

The LicenseException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides BaseException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

LicenseException Class
Mincom.LinkOne.Exceptions Namespace


GetObjectData Method

[image]

LinkOne WebView API
LicenseException..::.GetObjectData Method
LicenseException Class See Also Send Feedback
When overridden in a derived class, sets the SerializationInfo with information about the exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::.StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System..::.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

LicenseException Class
Mincom.LinkOne.Exceptions Namespace


LicenseException Properties

[image] [image]

LinkOne WebView API
LicenseException Properties
LicenseException Class See Also Send Feedback

The LicenseException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LicenseException Class
Mincom.LinkOne.Exceptions Namespace


LicenseExpiredException Class

[image]

LinkOne WebView API
LicenseExpiredException Class
Members See Also Send Feedback
This exception is thrown when a license found and expired.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class LicenseExpiredException : LicenseException
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class LicenseExpiredException _
    Inherits LicenseException
Visual C++
[SerializableAttribute]
public ref class LicenseExpiredException sealed : public LicenseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Mincom.LinkOne.Exceptions..::.BaseException
Mincom.LinkOne.Exceptions..::.LicenseException
Mincom.LinkOne.Exceptions..::.LicenseExpiredException

See Also

LicenseExpiredException Members
Mincom.LinkOne.Exceptions Namespace


LicenseExpiredException Members

[image] [image]

LinkOne WebView API
LicenseExpiredException Members
LicenseExpiredException Class Constructors Methods Properties See Also Send Feedback

The LicenseExpiredException type exposes the following members.

Constructors

Name | Description
LicenseExpiredException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from LicenseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LicenseExpiredException Class
Mincom.LinkOne.Exceptions Namespace


LicenseExpiredException Constructor

[image] [image]

LinkOne WebView API
LicenseExpiredException Constructor
LicenseExpiredException Class See Also Send Feedback

Overload List

Name | Description
LicenseExpiredException()()() | Initializes a new instance of the class.
LicenseExpiredException(String) | Initializes a new instance of the class with a message.
LicenseExpiredException(String, Exception) | Initializes a new instance of the class with a message and another exception.
LicenseExpiredException(String, array<Object>[]()[]) | Initializes a new instance of the class with a message.
LicenseExpiredException(String, Exception, array<Object>[]()[]) | Initializes a new instance of the class with a message and another exception.

See Also

LicenseExpiredException Class
LicenseExpiredException Members
Mincom.LinkOne.Exceptions Namespace


LicenseExpiredException Constructor

[image]

LinkOne WebView API
LicenseExpiredException Constructor
LicenseExpiredException Class See Also Send Feedback
Initializes a new instance of the class.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LicenseExpiredException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LicenseExpiredException()

See Also

LicenseExpiredException Class
LicenseExpiredException Overload
Mincom.LinkOne.Exceptions Namespace


LicenseExpiredException Constructor (String)

[image]

LinkOne WebView API
LicenseExpiredException Constructor (String)
LicenseExpiredException Class See Also Send Feedback
Initializes a new instance of the class with a message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LicenseExpiredException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
LicenseExpiredException(
    String^ message
)

Parameters

message
Type: System..::.String
The exception message.

See Also

LicenseExpiredException Class
LicenseExpiredException Overload
Mincom.LinkOne.Exceptions Namespace


LicenseExpiredException Constructor (String, Exception)

[image]

LinkOne WebView API
LicenseExpiredException Constructor (String, Exception)
LicenseExpiredException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LicenseExpiredException(
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
LicenseExpiredException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The exception to wrap.

See Also

LicenseExpiredException Class
LicenseExpiredException Overload
Mincom.LinkOne.Exceptions Namespace


LicenseExpiredException Constructor (String, Object[])

[image]

LinkOne WebView API
LicenseExpiredException Constructor (String, array<Object>[]()[])
LicenseExpiredException Class See Also Send Feedback
Initializes a new instance of the class with a message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LicenseExpiredException(
    string message,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    ParamArray args As Object() _
)
Visual C++
public:
LicenseExpiredException(
    String^ message,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

LicenseExpiredException Class
LicenseExpiredException Overload
Mincom.LinkOne.Exceptions Namespace


LicenseExpiredException Constructor (String, Exception, Object[])

[image]

LinkOne WebView API
LicenseExpiredException Constructor (String, Exception, array<Object>[]()[])
LicenseExpiredException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LicenseExpiredException(
    string message,
    Exception inner,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception, _
    ParamArray args As Object() _
)
Visual C++
public:
LicenseExpiredException(
    String^ message,
    Exception^ inner,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
inner
Type: System..::.Exception
The exception to wrap.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

LicenseExpiredException Class
LicenseExpiredException Overload
Mincom.LinkOne.Exceptions Namespace


LicenseExpiredException Methods

[image] [image]

LinkOne WebView API
LicenseExpiredException Methods
LicenseExpiredException Class See Also Send Feedback

The LicenseExpiredException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from LicenseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

LicenseExpiredException Class
Mincom.LinkOne.Exceptions Namespace


LicenseExpiredException Properties

[image] [image]

LinkOne WebView API
LicenseExpiredException Properties
LicenseExpiredException Class See Also Send Feedback

The LicenseExpiredException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LicenseExpiredException Class
Mincom.LinkOne.Exceptions Namespace


LicenseLockException Class

[image]

LinkOne WebView API
LicenseLockException Class
Members See Also Send Feedback
This exception is thrown from the DOM when a security lock exception occurs.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public class LicenseLockException : LicenseException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class LicenseLockException _
    Inherits LicenseException
Visual C++
[SerializableAttribute]
public ref class LicenseLockException : public LicenseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Mincom.LinkOne.Exceptions..::.BaseException
Mincom.LinkOne.Exceptions..::.LicenseException
Mincom.LinkOne.Exceptions..::.LicenseLockException
Mincom.LinkOne.Exceptions..::.LicenseLockExpiredException

See Also

LicenseLockException Members
Mincom.LinkOne.Exceptions Namespace


LicenseLockException Members

[image] [image]

LinkOne WebView API
LicenseLockException Members
LicenseLockException Class Constructors Methods Properties See Also Send Feedback

The LicenseLockException type exposes the following members.

Constructors

Name | Description
LicenseLockException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides LicenseException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
EntityName | Gets the name of the locked entity.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LicenseLockException Class
Mincom.LinkOne.Exceptions Namespace


LicenseLockException Constructor

[image] [image]

LinkOne WebView API
LicenseLockException Constructor
LicenseLockException Class See Also Send Feedback

Overload List

Name | Description
LicenseLockException()()() | Initializes a new instance of the class.
LicenseLockException(String) | Initializes a new instance of the class.
LicenseLockException(SerializationInfo, StreamingContext) | Initializes a new instance of the class with serialized data.
LicenseLockException(String, Exception) | Initializes a new instance of the class with a message and another exception.
LicenseLockException(String, String) | Initializes a new instance of the class with a simple message.
LicenseLockException(String, String, Exception) | Initializes a new instance of the class with a message and another exception.
LicenseLockException(String, String, array<Object>[]()[]) | Initializes a new instance of the class with a simple message.
LicenseLockException(String, String, Exception, array<Object>[]()[]) | Initializes a new instance of the class with a message and another exception.

See Also

LicenseLockException Class
LicenseLockException Members
Mincom.LinkOne.Exceptions Namespace


LicenseLockException Constructor

[image]

LinkOne WebView API
LicenseLockException Constructor
LicenseLockException Class See Also Send Feedback
Initializes a new instance of the class.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LicenseLockException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LicenseLockException()

See Also

LicenseLockException Class
LicenseLockException Overload
Mincom.LinkOne.Exceptions Namespace


LicenseLockException Constructor (String)

[image]

LinkOne WebView API
LicenseLockException Constructor (String)
LicenseLockException Class See Also Send Feedback
Initializes a new instance of the class.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LicenseLockException(
    string entityName
)
Visual Basic (Declaration)
Public Sub New ( _
    entityName As String _
)
Visual C++
public:
LicenseLockException(
    String^ entityName
)

Parameters

entityName
Type: System..::.String

See Also

LicenseLockException Class
LicenseLockException Overload
Mincom.LinkOne.Exceptions Namespace


LicenseLockException Constructor (SerializationInfo, StreamingContext)

[image]

LinkOne WebView API
LicenseLockException Constructor (SerializationInfo, StreamingContext)
LicenseLockException Class See Also Send Feedback
Initializes a new instance of the class with serialized data.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
protected LicenseLockException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
LicenseLockException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The object that holds the serialized object data.
context
Type: System.Runtime.Serialization..::.StreamingContext
The contextual information about the source or destination.

See Also

LicenseLockException Class
LicenseLockException Overload
Mincom.LinkOne.Exceptions Namespace


LicenseLockException Constructor (String, Exception)

[image]

LinkOne WebView API
LicenseLockException Constructor (String, Exception)
LicenseLockException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LicenseLockException(
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
LicenseLockException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The exception to wrap.

See Also

LicenseLockException Class
LicenseLockException Overload
Mincom.LinkOne.Exceptions Namespace


LicenseLockException Constructor (String, String)

[image]

LinkOne WebView API
LicenseLockException Constructor (String, String)
LicenseLockException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LicenseLockException(
    string entityName,
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    entityName As String, _
    message As String _
)
Visual C++
public:
LicenseLockException(
    String^ entityName,
    String^ message
)

Parameters

entityName
Type: System..::.String
Name of the locked entity.
message
Type: System..::.String
The exception message.

See Also

LicenseLockException Class
LicenseLockException Overload
Mincom.LinkOne.Exceptions Namespace


LicenseLockException Constructor (String, String, Exception)

[image]

LinkOne WebView API
LicenseLockException Constructor (String, String, Exception)
LicenseLockException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LicenseLockException(
    string entityName,
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    entityName As String, _
    message As String, _
    inner As Exception _
)
Visual C++
public:
LicenseLockException(
    String^ entityName,
    String^ message,
    Exception^ inner
)

Parameters

entityName
Type: System..::.String
Name of the locked entity.
message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The exception to wrap.

See Also

LicenseLockException Class
LicenseLockException Overload
Mincom.LinkOne.Exceptions Namespace


LicenseLockException Constructor (String, String, Object[])

[image]

LinkOne WebView API
LicenseLockException Constructor (String, String, array<Object>[]()[])
LicenseLockException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LicenseLockException(
    string entityName,
    string message,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    entityName As String, _
    message As String, _
    ParamArray args As Object() _
)
Visual C++
public:
LicenseLockException(
    String^ entityName,
    String^ message,
    ... array<Object^>^ args
)

Parameters

entityName
Type: System..::.String
Name of the locked entity.
message
Type: System..::.String
The exception message with formatting escape sequences.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

LicenseLockException Class
LicenseLockException Overload
Mincom.LinkOne.Exceptions Namespace


LicenseLockException Constructor (String, String, Exception, Object[])

[image]

LinkOne WebView API
LicenseLockException Constructor (String, String, Exception, array<Object>[]()[])
LicenseLockException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LicenseLockException(
    string entityName,
    string message,
    Exception inner,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    entityName As String, _
    message As String, _
    inner As Exception, _
    ParamArray args As Object() _
)
Visual C++
public:
LicenseLockException(
    String^ entityName,
    String^ message,
    Exception^ inner,
    ... array<Object^>^ args
)

Parameters

entityName
Type: System..::.String
Name of the locked entity.
message
Type: System..::.String
The exception message with formatting escape sequences.
inner
Type: System..::.Exception
The exception to wrap.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

LicenseLockException Class
LicenseLockException Overload
Mincom.LinkOne.Exceptions Namespace


LicenseLockException Methods

[image] [image]

LinkOne WebView API
LicenseLockException Methods
LicenseLockException Class See Also Send Feedback

The LicenseLockException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides LicenseException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

LicenseLockException Class
Mincom.LinkOne.Exceptions Namespace


GetObjectData Method

[image]

LinkOne WebView API
LicenseLockException..::.GetObjectData Method
LicenseLockException Class See Also Send Feedback
When overridden in a derived class, sets the SerializationInfo with information about the exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::.StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System..::.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

LicenseLockException Class
Mincom.LinkOne.Exceptions Namespace


LicenseLockException Properties

[image] [image]

LinkOne WebView API
LicenseLockException Properties
LicenseLockException Class See Also Send Feedback

The LicenseLockException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
EntityName | Gets the name of the locked entity.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LicenseLockException Class
Mincom.LinkOne.Exceptions Namespace


EntityName Property

[image]

LinkOne WebView API
LicenseLockException..::.EntityName Property
LicenseLockException Class See Also Send Feedback
Gets the name of the locked entity.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string EntityName { get; }
Visual Basic (Declaration)
Public ReadOnly Property EntityName As String
Visual C++
public:
property String^ EntityName {
    String^ get ();
}

See Also

LicenseLockException Class
Mincom.LinkOne.Exceptions Namespace


LicenseLockExpiredException Class

[image]

LinkOne WebView API
LicenseLockExpiredException Class
Members See Also Send Feedback
This exception is thrown when a license has expired.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class LicenseLockExpiredException : LicenseLockException
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class LicenseLockExpiredException _
    Inherits LicenseLockException
Visual C++
[SerializableAttribute]
public ref class LicenseLockExpiredException sealed : public LicenseLockException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Mincom.LinkOne.Exceptions..::.BaseException
Mincom.LinkOne.Exceptions..::.LicenseException
Mincom.LinkOne.Exceptions..::.LicenseLockException
Mincom.LinkOne.Exceptions..::.LicenseLockExpiredException

See Also

LicenseLockExpiredException Members
Mincom.LinkOne.Exceptions Namespace


LicenseLockExpiredException Members

[image] [image]

LinkOne WebView API
LicenseLockExpiredException Members
LicenseLockExpiredException Class Constructors Methods Properties See Also Send Feedback

The LicenseLockExpiredException type exposes the following members.

Constructors

Name | Description
LicenseLockExpiredException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides LicenseLockException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
EntityName | Gets the name of the locked entity. (Inherited from LicenseLockException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
LockNumber | Gets the lock number.
Message | Gets a message that describes the current exception. (Inherited from Exception.)
PublisherCode | Gets the publisher code.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LicenseLockExpiredException Class
Mincom.LinkOne.Exceptions Namespace


LicenseLockExpiredException Constructor

[image] [image]

LinkOne WebView API
LicenseLockExpiredException Constructor
LicenseLockExpiredException Class See Also Send Feedback

Overload List

Name | Description
LicenseLockExpiredException()()() | Initializes a new instance of the class.
LicenseLockExpiredException(String) | Initializes a new instance of the class with a message.
LicenseLockExpiredException(String, Exception) | Initializes a new instance of the class with a message and another exception.
LicenseLockExpiredException(String, Int32) | Initializes a new instance of the class.
LicenseLockExpiredException(String, Int32, String) | Initializes a new instance of the class with a message.
LicenseLockExpiredException(String, Int32, String, Exception) | Initializes a new instance of the class with a message and another exception.
LicenseLockExpiredException(String, Int32, String, array<Object>[]()[]) | Initializes a new instance of the class with a message.
LicenseLockExpiredException(String, Int32, String, Exception, array<Object>[]()[]) | Initializes a new instance of the class with a message and another exception.

See Also

LicenseLockExpiredException Class
LicenseLockExpiredException Members
Mincom.LinkOne.Exceptions Namespace


LicenseLockExpiredException Constructor

[image]

LinkOne WebView API
LicenseLockExpiredException Constructor
LicenseLockExpiredException Class See Also Send Feedback
Initializes a new instance of the class.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LicenseLockExpiredException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LicenseLockExpiredException()

See Also

LicenseLockExpiredException Class
LicenseLockExpiredException Overload
Mincom.LinkOne.Exceptions Namespace


LicenseLockExpiredException Constructor (String)

[image]

LinkOne WebView API
LicenseLockExpiredException Constructor (String)
LicenseLockExpiredException Class See Also Send Feedback
Initializes a new instance of the class with a message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LicenseLockExpiredException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
LicenseLockExpiredException(
    String^ message
)

Parameters

message
Type: System..::.String
The exception message.

See Also

LicenseLockExpiredException Class
LicenseLockExpiredException Overload
Mincom.LinkOne.Exceptions Namespace


LicenseLockExpiredException Constructor (String, Exception)

[image]

LinkOne WebView API
LicenseLockExpiredException Constructor (String, Exception)
LicenseLockExpiredException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LicenseLockExpiredException(
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
LicenseLockExpiredException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The exception to wrap.

See Also

LicenseLockExpiredException Class
LicenseLockExpiredException Overload
Mincom.LinkOne.Exceptions Namespace


LicenseLockExpiredException Constructor (String, Int32)

[image]

LinkOne WebView API
LicenseLockExpiredException Constructor (String, Int32)
LicenseLockExpiredException Class See Also Send Feedback
Initializes a new instance of the class.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LicenseLockExpiredException(
    string publisherCode,
    int lockNumber
)
Visual Basic (Declaration)
Public Sub New ( _
    publisherCode As String, _
    lockNumber As Integer _
)
Visual C++
public:
LicenseLockExpiredException(
    String^ publisherCode,
    int lockNumber
)

Parameters

publisherCode
Type: System..::.String
The publisher code.
lockNumber
Type: System..::.Int32
The lock number.

See Also

LicenseLockExpiredException Class
LicenseLockExpiredException Overload
Mincom.LinkOne.Exceptions Namespace


LicenseLockExpiredException Constructor (String, Int32, String)

[image]

LinkOne WebView API
LicenseLockExpiredException Constructor (String, Int32, String)
LicenseLockExpiredException Class See Also Send Feedback
Initializes a new instance of the class with a message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LicenseLockExpiredException(
    string publisherCode,
    int lockNumber,
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    publisherCode As String, _
    lockNumber As Integer, _
    message As String _
)
Visual C++
public:
LicenseLockExpiredException(
    String^ publisherCode,
    int lockNumber,
    String^ message
)

Parameters

publisherCode
Type: System..::.String
The publisher code.
lockNumber
Type: System..::.Int32
The lock number.
message
Type: System..::.String
The exception message.

See Also

LicenseLockExpiredException Class
LicenseLockExpiredException Overload
Mincom.LinkOne.Exceptions Namespace


LicenseLockExpiredException Constructor (String, Int32, String, Exception)

[image]

LinkOne WebView API
LicenseLockExpiredException Constructor (String, Int32, String, Exception)
LicenseLockExpiredException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LicenseLockExpiredException(
    string publisherCode,
    int lockNumber,
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    publisherCode As String, _
    lockNumber As Integer, _
    message As String, _
    inner As Exception _
)
Visual C++
public:
LicenseLockExpiredException(
    String^ publisherCode,
    int lockNumber,
    String^ message,
    Exception^ inner
)

Parameters

publisherCode
Type: System..::.String
The publisher code.
lockNumber
Type: System..::.Int32
The lock number.
message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The exception to wrap.

See Also

LicenseLockExpiredException Class
LicenseLockExpiredException Overload
Mincom.LinkOne.Exceptions Namespace


LicenseLockExpiredException Constructor (String, Int32, String, Object[])

[image]

LinkOne WebView API
LicenseLockExpiredException Constructor (String, Int32, String, array<Object>[]()[])
LicenseLockExpiredException Class See Also Send Feedback
Initializes a new instance of the class with a message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LicenseLockExpiredException(
    string publisherCode,
    int lockNumber,
    string message,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    publisherCode As String, _
    lockNumber As Integer, _
    message As String, _
    ParamArray args As Object() _
)
Visual C++
public:
LicenseLockExpiredException(
    String^ publisherCode,
    int lockNumber,
    String^ message,
    ... array<Object^>^ args
)

Parameters

publisherCode
Type: System..::.String
The publisher code.
lockNumber
Type: System..::.Int32
The lock number.
message
Type: System..::.String
The exception message with formatting escape sequences.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

LicenseLockExpiredException Class
LicenseLockExpiredException Overload
Mincom.LinkOne.Exceptions Namespace


LicenseLockExpiredException Constructor (String, Int32, String, Exception, Object[])

[image]

LinkOne WebView API
LicenseLockExpiredException Constructor (String, Int32, String, Exception, array<Object>[]()[])
LicenseLockExpiredException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LicenseLockExpiredException(
    string publisherCode,
    int lockNumber,
    string message,
    Exception inner,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    publisherCode As String, _
    lockNumber As Integer, _
    message As String, _
    inner As Exception, _
    ParamArray args As Object() _
)
Visual C++
public:
LicenseLockExpiredException(
    String^ publisherCode,
    int lockNumber,
    String^ message,
    Exception^ inner,
    ... array<Object^>^ args
)

Parameters

publisherCode
Type: System..::.String
The publisher code.
lockNumber
Type: System..::.Int32
The lock number.
message
Type: System..::.String
The exception message with formatting escape sequences.
inner
Type: System..::.Exception
The exception to wrap.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

LicenseLockExpiredException Class
LicenseLockExpiredException Overload
Mincom.LinkOne.Exceptions Namespace


LicenseLockExpiredException Methods

[image] [image]

LinkOne WebView API
LicenseLockExpiredException Methods
LicenseLockExpiredException Class See Also Send Feedback

The LicenseLockExpiredException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides LicenseLockException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

LicenseLockExpiredException Class
Mincom.LinkOne.Exceptions Namespace


GetObjectData Method

[image]

LinkOne WebView API
LicenseLockExpiredException..::.GetObjectData Method
LicenseLockExpiredException Class See Also Send Feedback
When overridden in a derived class, sets the SerializationInfo with information about the exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::.StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System..::.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

LicenseLockExpiredException Class
Mincom.LinkOne.Exceptions Namespace


LicenseLockExpiredException Properties

[image] [image]

LinkOne WebView API
LicenseLockExpiredException Properties
LicenseLockExpiredException Class See Also Send Feedback

The LicenseLockExpiredException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
EntityName | Gets the name of the locked entity. (Inherited from LicenseLockException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
LockNumber | Gets the lock number.
Message | Gets a message that describes the current exception. (Inherited from Exception.)
PublisherCode | Gets the publisher code.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LicenseLockExpiredException Class
Mincom.LinkOne.Exceptions Namespace


LockNumber Property

[image]

LinkOne WebView API
LicenseLockExpiredException..::.LockNumber Property
LicenseLockExpiredException Class See Also Send Feedback
Gets the lock number.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int LockNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property LockNumber As Integer
Visual C++
public:
property int LockNumber {
    int get ();
}

See Also

LicenseLockExpiredException Class
Mincom.LinkOne.Exceptions Namespace


PublisherCode Property

[image]

LinkOne WebView API
LicenseLockExpiredException..::.PublisherCode Property
LicenseLockExpiredException Class See Also Send Feedback
Gets the publisher code.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PublisherCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublisherCode As String
Visual C++
public:
property String^ PublisherCode {
    String^ get ();
}

See Also

LicenseLockExpiredException Class
Mincom.LinkOne.Exceptions Namespace


MasterBookNotFoundException Class

[image]

LinkOne WebView API
MasterBookNotFoundException Class
Members See Also Send Feedback
This exception is thrown from the LinkOne DOM when the Master Book cannot be located.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class MasterBookNotFoundException : BaseException
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class MasterBookNotFoundException _
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class MasterBookNotFoundException sealed : public BaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Mincom.LinkOne.Exceptions..::.BaseException
Mincom.LinkOne.Exceptions..::.MasterBookNotFoundException

See Also

MasterBookNotFoundException Members
Mincom.LinkOne.Exceptions Namespace


MasterBookNotFoundException Members

[image] [image]

LinkOne WebView API
MasterBookNotFoundException Members
MasterBookNotFoundException Class Constructors Methods Properties See Also Send Feedback

The MasterBookNotFoundException type exposes the following members.

Constructors

Name | Description
MasterBookNotFoundException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MasterBookNotFoundException Class
Mincom.LinkOne.Exceptions Namespace


MasterBookNotFoundException Constructor

[image] [image]

LinkOne WebView API
MasterBookNotFoundException Constructor
MasterBookNotFoundException Class See Also Send Feedback

Overload List

Name | Description
MasterBookNotFoundException()()() | Initializes a new instance of the class.
MasterBookNotFoundException(String) | Initializes a new instance of the class with a simple message.
MasterBookNotFoundException(String, Exception) | Initializes a new instance of the class with a message and another exception.
MasterBookNotFoundException(String, array<Object>[]()[]) | Initializes a new instance of the class with a simple message.
MasterBookNotFoundException(String, Exception, array<Object>[]()[]) | Initializes a new instance of the class with a message and another exception.

See Also

MasterBookNotFoundException Class
MasterBookNotFoundException Members
Mincom.LinkOne.Exceptions Namespace


MasterBookNotFoundException Constructor

[image]

LinkOne WebView API
MasterBookNotFoundException Constructor
MasterBookNotFoundException Class See Also Send Feedback
Initializes a new instance of the class.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public MasterBookNotFoundException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MasterBookNotFoundException()

See Also

MasterBookNotFoundException Class
MasterBookNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


MasterBookNotFoundException Constructor (String)

[image]

LinkOne WebView API
MasterBookNotFoundException Constructor (String)
MasterBookNotFoundException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public MasterBookNotFoundException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
MasterBookNotFoundException(
    String^ message
)

Parameters

message
Type: System..::.String
The exception message.

See Also

MasterBookNotFoundException Class
MasterBookNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


MasterBookNotFoundException Constructor (String, Exception)

[image]

LinkOne WebView API
MasterBookNotFoundException Constructor (String, Exception)
MasterBookNotFoundException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public MasterBookNotFoundException(
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
MasterBookNotFoundException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The exception to wrap.

See Also

MasterBookNotFoundException Class
MasterBookNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


MasterBookNotFoundException Constructor (String, Object[])

[image]

LinkOne WebView API
MasterBookNotFoundException Constructor (String, array<Object>[]()[])
MasterBookNotFoundException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public MasterBookNotFoundException(
    string message,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    ParamArray args As Object() _
)
Visual C++
public:
MasterBookNotFoundException(
    String^ message,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

MasterBookNotFoundException Class
MasterBookNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


MasterBookNotFoundException Constructor (String, Exception, Object[])

[image]

LinkOne WebView API
MasterBookNotFoundException Constructor (String, Exception, array<Object>[]()[])
MasterBookNotFoundException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public MasterBookNotFoundException(
    string message,
    Exception inner,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception, _
    ParamArray args As Object() _
)
Visual C++
public:
MasterBookNotFoundException(
    String^ message,
    Exception^ inner,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
inner
Type: System..::.Exception
The exception to wrap.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

MasterBookNotFoundException Class
MasterBookNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


MasterBookNotFoundException Methods

[image] [image]

LinkOne WebView API
MasterBookNotFoundException Methods
MasterBookNotFoundException Class See Also Send Feedback

The MasterBookNotFoundException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MasterBookNotFoundException Class
Mincom.LinkOne.Exceptions Namespace


MasterBookNotFoundException Properties

[image] [image]

LinkOne WebView API
MasterBookNotFoundException Properties
MasterBookNotFoundException Class See Also Send Feedback

The MasterBookNotFoundException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MasterBookNotFoundException Class
Mincom.LinkOne.Exceptions Namespace


MissingConfigurationManagerException Class

[image]

LinkOne WebView API
MissingConfigurationManagerException Class
Members See Also Send Feedback
This exception is thrown from the LinkOne DOM when a Configuration Manager is not supplied.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class MissingConfigurationManagerException : BaseException
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class MissingConfigurationManagerException _
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class MissingConfigurationManagerException sealed : public BaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Mincom.LinkOne.Exceptions..::.BaseException
Mincom.LinkOne.Exceptions..::.MissingConfigurationManagerException

See Also

MissingConfigurationManagerException Members
Mincom.LinkOne.Exceptions Namespace


MissingConfigurationManagerException Members

[image] [image]

LinkOne WebView API
MissingConfigurationManagerException Members
MissingConfigurationManagerException Class Constructors Methods Properties See Also Send Feedback

The MissingConfigurationManagerException type exposes the following members.

Constructors

Name | Description
MissingConfigurationManagerException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MissingConfigurationManagerException Class
Mincom.LinkOne.Exceptions Namespace


MissingConfigurationManagerException Constructor

[image] [image]

LinkOne WebView API
MissingConfigurationManagerException Constructor
MissingConfigurationManagerException Class See Also Send Feedback

Overload List

Name | Description
MissingConfigurationManagerException()()() | Initializes a new instance of the class.
MissingConfigurationManagerException(String) | Initializes a new instance of the class with a simple message.
MissingConfigurationManagerException(String, Exception) | Initializes a new instance of the class with a message and another exception.
MissingConfigurationManagerException(String, array<Object>[]()[]) | Initializes a new instance of the class with a simple message.
MissingConfigurationManagerException(String, Exception, array<Object>[]()[]) | Initializes a new instance of the class with a message and another exception.

See Also

MissingConfigurationManagerException Class
MissingConfigurationManagerException Members
Mincom.LinkOne.Exceptions Namespace


MissingConfigurationManagerException Constructor

[image]

LinkOne WebView API
MissingConfigurationManagerException Constructor
MissingConfigurationManagerException Class See Also Send Feedback
Initializes a new instance of the class.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public MissingConfigurationManagerException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MissingConfigurationManagerException()

See Also

MissingConfigurationManagerException Class
MissingConfigurationManagerException Overload
Mincom.LinkOne.Exceptions Namespace


MissingConfigurationManagerException Constructor (String)

[image]

LinkOne WebView API
MissingConfigurationManagerException Constructor (String)
MissingConfigurationManagerException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public MissingConfigurationManagerException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
MissingConfigurationManagerException(
    String^ message
)

Parameters

message
Type: System..::.String
The exception message.

See Also

MissingConfigurationManagerException Class
MissingConfigurationManagerException Overload
Mincom.LinkOne.Exceptions Namespace


MissingConfigurationManagerException Constructor (String, Exception)

[image]

LinkOne WebView API
MissingConfigurationManagerException Constructor (String, Exception)
MissingConfigurationManagerException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public MissingConfigurationManagerException(
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
MissingConfigurationManagerException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The exception to wrap.

See Also

MissingConfigurationManagerException Class
MissingConfigurationManagerException Overload
Mincom.LinkOne.Exceptions Namespace


MissingConfigurationManagerException Constructor (String, Object[])

[image]

LinkOne WebView API
MissingConfigurationManagerException Constructor (String, array<Object>[]()[])
MissingConfigurationManagerException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public MissingConfigurationManagerException(
    string message,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    ParamArray args As Object() _
)
Visual C++
public:
MissingConfigurationManagerException(
    String^ message,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

MissingConfigurationManagerException Class
MissingConfigurationManagerException Overload
Mincom.LinkOne.Exceptions Namespace


MissingConfigurationManagerException Constructor (String, Exception, Object[])

[image]

LinkOne WebView API
MissingConfigurationManagerException Constructor (String, Exception, array<Object>[]()[])
MissingConfigurationManagerException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public MissingConfigurationManagerException(
    string message,
    Exception inner,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception, _
    ParamArray args As Object() _
)
Visual C++
public:
MissingConfigurationManagerException(
    String^ message,
    Exception^ inner,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
inner
Type: System..::.Exception
The exception to wrap.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

MissingConfigurationManagerException Class
MissingConfigurationManagerException Overload
Mincom.LinkOne.Exceptions Namespace


MissingConfigurationManagerException Methods

[image] [image]

LinkOne WebView API
MissingConfigurationManagerException Methods
MissingConfigurationManagerException Class See Also Send Feedback

The MissingConfigurationManagerException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MissingConfigurationManagerException Class
Mincom.LinkOne.Exceptions Namespace


MissingConfigurationManagerException Properties

[image] [image]

LinkOne WebView API
MissingConfigurationManagerException Properties
MissingConfigurationManagerException Class See Also Send Feedback

The MissingConfigurationManagerException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MissingConfigurationManagerException Class
Mincom.LinkOne.Exceptions Namespace


MissingProviderException Class

[image]

LinkOne WebView API
MissingProviderException Class
Members See Also Send Feedback
This exception is thrown from the LinkOne DOM when an Provider is not supplied.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class MissingProviderException : BaseException
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class MissingProviderException _
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class MissingProviderException sealed : public BaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Mincom.LinkOne.Exceptions..::.BaseException
Mincom.LinkOne.Exceptions..::.MissingProviderException

See Also

MissingProviderException Members
Mincom.LinkOne.Exceptions Namespace


MissingProviderException Members

[image] [image]

LinkOne WebView API
MissingProviderException Members
MissingProviderException Class Constructors Methods Properties See Also Send Feedback

The MissingProviderException type exposes the following members.

Constructors

Name | Description
MissingProviderException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MissingProviderException Class
Mincom.LinkOne.Exceptions Namespace


MissingProviderException Constructor

[image] [image]

LinkOne WebView API
MissingProviderException Constructor
MissingProviderException Class See Also Send Feedback

Overload List

Name | Description
MissingProviderException()()() | Initializes a new instance of the class.
MissingProviderException(String) | Initializes a new instance of the class with a simple message.
MissingProviderException(String, Exception) | Initializes a new instance of the class with a message and another exception.
MissingProviderException(String, array<Object>[]()[]) | Initializes a new instance of the class with a simple message.
MissingProviderException(String, Exception, array<Object>[]()[]) | Initializes a new instance of the class with a message and another exception.

See Also

MissingProviderException Class
MissingProviderException Members
Mincom.LinkOne.Exceptions Namespace


MissingProviderException Constructor

[image]

LinkOne WebView API
MissingProviderException Constructor
MissingProviderException Class See Also Send Feedback
Initializes a new instance of the class.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public MissingProviderException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MissingProviderException()

See Also

MissingProviderException Class
MissingProviderException Overload
Mincom.LinkOne.Exceptions Namespace


MissingProviderException Constructor (String)

[image]

LinkOne WebView API
MissingProviderException Constructor (String)
MissingProviderException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public MissingProviderException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
MissingProviderException(
    String^ message
)

Parameters

message
Type: System..::.String
The exception message.

See Also

MissingProviderException Class
MissingProviderException Overload
Mincom.LinkOne.Exceptions Namespace


MissingProviderException Constructor (String, Exception)

[image]

LinkOne WebView API
MissingProviderException Constructor (String, Exception)
MissingProviderException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public MissingProviderException(
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
MissingProviderException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The exception to wrap.

See Also

MissingProviderException Class
MissingProviderException Overload
Mincom.LinkOne.Exceptions Namespace


MissingProviderException Constructor (String, Object[])

[image]

LinkOne WebView API
MissingProviderException Constructor (String, array<Object>[]()[])
MissingProviderException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public MissingProviderException(
    string message,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    ParamArray args As Object() _
)
Visual C++
public:
MissingProviderException(
    String^ message,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

MissingProviderException Class
MissingProviderException Overload
Mincom.LinkOne.Exceptions Namespace


MissingProviderException Constructor (String, Exception, Object[])

[image]

LinkOne WebView API
MissingProviderException Constructor (String, Exception, array<Object>[]()[])
MissingProviderException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public MissingProviderException(
    string message,
    Exception inner,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception, _
    ParamArray args As Object() _
)
Visual C++
public:
MissingProviderException(
    String^ message,
    Exception^ inner,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
inner
Type: System..::.Exception
The exception to wrap.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

MissingProviderException Class
MissingProviderException Overload
Mincom.LinkOne.Exceptions Namespace


MissingProviderException Methods

[image] [image]

LinkOne WebView API
MissingProviderException Methods
MissingProviderException Class See Also Send Feedback

The MissingProviderException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MissingProviderException Class
Mincom.LinkOne.Exceptions Namespace


MissingProviderException Properties

[image] [image]

LinkOne WebView API
MissingProviderException Properties
MissingProviderException Class See Also Send Feedback

The MissingProviderException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MissingProviderException Class
Mincom.LinkOne.Exceptions Namespace


PageNotFoundException Class

[image]

LinkOne WebView API
PageNotFoundException Class
Members See Also Send Feedback
The exception that is thrown when the wanted Mincom.LinkOne.Dom.Page is not found.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class PageNotFoundException : BaseException
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class PageNotFoundException _
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class PageNotFoundException sealed : public BaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Mincom.LinkOne.Exceptions..::.BaseException
Mincom.LinkOne.Exceptions..::.PageNotFoundException

See Also

PageNotFoundException Members
Mincom.LinkOne.Exceptions Namespace


PageNotFoundException Members

[image] [image]

LinkOne WebView API
PageNotFoundException Members
PageNotFoundException Class Constructors Methods Properties See Also Send Feedback

The PageNotFoundException type exposes the following members.

Constructors

Name | Description
PageNotFoundException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides BaseException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
BookCode | Gets the book code.
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
PageReference | Gets the page reference.
PublisherCode | Gets the publisher code.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

PageNotFoundException Class
Mincom.LinkOne.Exceptions Namespace


PageNotFoundException Constructor

[image] [image]

LinkOne WebView API
PageNotFoundException Constructor
PageNotFoundException Class See Also Send Feedback

Overload List

Name | Description
PageNotFoundException()()() | Initializes a new instance of the class.
PageNotFoundException(String) | Initializes a new instance of the class with a simple message.
PageNotFoundException(String, Exception) | Initializes a new instance of the class with a simple message and another exception.
PageNotFoundException(String, array<Object>[]()[]) | Initializes a new instance of the class with a simple message.
PageNotFoundException(String, Exception, array<Object>[]()[]) | Initializes a new instance of the class with a simple message and another exception.
PageNotFoundException(String, String, String) | Initializes a new instance of the class.
PageNotFoundException(String, String, String, String) | Initializes a new instance of the class with a simple message.
PageNotFoundException(String, String, String, String, Exception) | Initializes a new instance of the class with a simple message and another exception.
PageNotFoundException(String, String, String, String, array<Object>[]()[]) | Initializes a new instance of the class with a simple message.
PageNotFoundException(String, String, String, String, Exception, array<Object>[]()[]) | Initializes a new instance of the class with a simple message and another exception.

See Also

PageNotFoundException Class
PageNotFoundException Members
Mincom.LinkOne.Exceptions Namespace


PageNotFoundException Constructor

[image]

LinkOne WebView API
PageNotFoundException Constructor
PageNotFoundException Class See Also Send Feedback
Initializes a new instance of the class.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PageNotFoundException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PageNotFoundException()

See Also

PageNotFoundException Class
PageNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


PageNotFoundException Constructor (String)

[image]

LinkOne WebView API
PageNotFoundException Constructor (String)
PageNotFoundException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PageNotFoundException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
PageNotFoundException(
    String^ message
)

Parameters

message
Type: System..::.String
The exception message.

See Also

PageNotFoundException Class
PageNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


PageNotFoundException Constructor (String, Exception)

[image]

LinkOne WebView API
PageNotFoundException Constructor (String, Exception)
PageNotFoundException Class See Also Send Feedback
Initializes a new instance of the class with a simple message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PageNotFoundException(
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
PageNotFoundException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The exception to wrap.

See Also

PageNotFoundException Class
PageNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


PageNotFoundException Constructor (String, Object[])

[image]

LinkOne WebView API
PageNotFoundException Constructor (String, array<Object>[]()[])
PageNotFoundException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PageNotFoundException(
    string message,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    ParamArray args As Object() _
)
Visual C++
public:
PageNotFoundException(
    String^ message,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

PageNotFoundException Class
PageNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


PageNotFoundException Constructor (String, Exception, Object[])

[image]

LinkOne WebView API
PageNotFoundException Constructor (String, Exception, array<Object>[]()[])
PageNotFoundException Class See Also Send Feedback
Initializes a new instance of the class with a simple message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PageNotFoundException(
    string message,
    Exception inner,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception, _
    ParamArray args As Object() _
)
Visual C++
public:
PageNotFoundException(
    String^ message,
    Exception^ inner,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
inner
Type: System..::.Exception
The exception to wrap.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

PageNotFoundException Class
PageNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


PageNotFoundException Constructor (String, String, String)

[image]

LinkOne WebView API
PageNotFoundException Constructor (String, String, String)
PageNotFoundException Class See Also Send Feedback
Initializes a new instance of the class.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PageNotFoundException(
    string publisherCode,
    string bookCode,
    string pageReference
)
Visual Basic (Declaration)
Public Sub New ( _
    publisherCode As String, _
    bookCode As String, _
    pageReference As String _
)
Visual C++
public:
PageNotFoundException(
    String^ publisherCode,
    String^ bookCode,
    String^ pageReference
)

Parameters

publisherCode
Type: System..::.String
The publisher code.
bookCode
Type: System..::.String
The book code.
pageReference
Type: System..::.String
The page reference.

See Also

PageNotFoundException Class
PageNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


PageNotFoundException Constructor (String, String, String, String)

[image]

LinkOne WebView API
PageNotFoundException Constructor (String, String, String, String)
PageNotFoundException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PageNotFoundException(
    string publisherCode,
    string bookCode,
    string pageReference,
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    publisherCode As String, _
    bookCode As String, _
    pageReference As String, _
    message As String _
)
Visual C++
public:
PageNotFoundException(
    String^ publisherCode,
    String^ bookCode,
    String^ pageReference,
    String^ message
)

Parameters

publisherCode
Type: System..::.String
The publisher code.
bookCode
Type: System..::.String
The book code.
pageReference
Type: System..::.String
The page reference.
message
Type: System..::.String
The exception message.

See Also

PageNotFoundException Class
PageNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


PageNotFoundException Constructor (String, String, String, String, Exception)

[image]

LinkOne WebView API
PageNotFoundException Constructor (String, String, String, String, Exception)
PageNotFoundException Class See Also Send Feedback
Initializes a new instance of the class with a simple message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PageNotFoundException(
    string publisherCode,
    string bookCode,
    string pageReference,
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    publisherCode As String, _
    bookCode As String, _
    pageReference As String, _
    message As String, _
    inner As Exception _
)
Visual C++
public:
PageNotFoundException(
    String^ publisherCode,
    String^ bookCode,
    String^ pageReference,
    String^ message,
    Exception^ inner
)

Parameters

publisherCode
Type: System..::.String
The publisher code.
bookCode
Type: System..::.String
The book code.
pageReference
Type: System..::.String
The page reference.
message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The exception to wrap.

See Also

PageNotFoundException Class
PageNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


PageNotFoundException Constructor (String, String, String, String, Object[])

[image]

LinkOne WebView API
PageNotFoundException Constructor (String, String, String, String, array<Object>[]()[])
PageNotFoundException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PageNotFoundException(
    string publisherCode,
    string bookCode,
    string pageReference,
    string message,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    publisherCode As String, _
    bookCode As String, _
    pageReference As String, _
    message As String, _
    ParamArray args As Object() _
)
Visual C++
public:
PageNotFoundException(
    String^ publisherCode,
    String^ bookCode,
    String^ pageReference,
    String^ message,
    ... array<Object^>^ args
)

Parameters

publisherCode
Type: System..::.String
The publisher code.
bookCode
Type: System..::.String
The book code.
pageReference
Type: System..::.String
The page reference.
message
Type: System..::.String
The exception message with formatting escape sequences.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

PageNotFoundException Class
PageNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


PageNotFoundException Constructor (String, String, String, String, Exception, Object[])

[image]

LinkOne WebView API
PageNotFoundException Constructor (String, String, String, String, Exception, array<Object>[]()[])
PageNotFoundException Class See Also Send Feedback
Initializes a new instance of the class with a simple message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PageNotFoundException(
    string publisherCode,
    string bookCode,
    string pageReference,
    string message,
    Exception inner,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    publisherCode As String, _
    bookCode As String, _
    pageReference As String, _
    message As String, _
    inner As Exception, _
    ParamArray args As Object() _
)
Visual C++
public:
PageNotFoundException(
    String^ publisherCode,
    String^ bookCode,
    String^ pageReference,
    String^ message,
    Exception^ inner,
    ... array<Object^>^ args
)

Parameters

publisherCode
Type: System..::.String
The publisher code.
bookCode
Type: System..::.String
The book code.
pageReference
Type: System..::.String
The page reference.
message
Type: System..::.String
The exception message with formatting escape sequences.
inner
Type: System..::.Exception
The exception to wrap.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

PageNotFoundException Class
PageNotFoundException Overload
Mincom.LinkOne.Exceptions Namespace


PageNotFoundException Methods

[image] [image]

LinkOne WebView API
PageNotFoundException Methods
PageNotFoundException Class See Also Send Feedback

The PageNotFoundException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides BaseException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

PageNotFoundException Class
Mincom.LinkOne.Exceptions Namespace


GetObjectData Method

[image]

LinkOne WebView API
PageNotFoundException..::.GetObjectData Method
PageNotFoundException Class See Also Send Feedback
When overridden in a derived class, sets the SerializationInfo with information about the exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::.StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System..::.ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

PageNotFoundException Class
Mincom.LinkOne.Exceptions Namespace


PageNotFoundException Properties

[image] [image]

LinkOne WebView API
PageNotFoundException Properties
PageNotFoundException Class See Also Send Feedback

The PageNotFoundException type exposes the following members.

Properties

Name | Description
BookCode | Gets the book code.
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
PageReference | Gets the page reference.
PublisherCode | Gets the publisher code.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

PageNotFoundException Class
Mincom.LinkOne.Exceptions Namespace


BookCode Property

[image]

LinkOne WebView API
PageNotFoundException..::.BookCode Property
PageNotFoundException Class See Also Send Feedback
Gets the book code.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string BookCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property BookCode As String
Visual C++
public:
property String^ BookCode {
    String^ get ();
}

See Also

PageNotFoundException Class
Mincom.LinkOne.Exceptions Namespace


PageReference Property

[image]

LinkOne WebView API
PageNotFoundException..::.PageReference Property
PageNotFoundException Class See Also Send Feedback
Gets the page reference.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PageReference { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageReference As String
Visual C++
public:
property String^ PageReference {
    String^ get ();
}

See Also

PageNotFoundException Class
Mincom.LinkOne.Exceptions Namespace


PublisherCode Property

[image]

LinkOne WebView API
PageNotFoundException..::.PublisherCode Property
PageNotFoundException Class See Also Send Feedback
Gets the publisher code.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PublisherCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublisherCode As String
Visual C++
public:
property String^ PublisherCode {
    String^ get ();
}

See Also

PageNotFoundException Class
Mincom.LinkOne.Exceptions Namespace


ScriptException Class

[image]

LinkOne WebView API
ScriptException Class
Members See Also Send Feedback
The exception that is thrown when a scriptlet encounters an error.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class ScriptException : BaseException
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class ScriptException _
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class ScriptException sealed : public BaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Mincom.LinkOne.Exceptions..::.BaseException
Mincom.LinkOne.Exceptions..::.ScriptException

See Also

ScriptException Members
Mincom.LinkOne.Exceptions Namespace


ScriptException Members

[image] [image]

LinkOne WebView API
ScriptException Members
ScriptException Class Constructors Methods Properties See Also Send Feedback

The ScriptException type exposes the following members.

Constructors

Name | Description
ScriptException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ScriptException Class
Mincom.LinkOne.Exceptions Namespace


ScriptException Constructor

[image] [image]

LinkOne WebView API
ScriptException Constructor
ScriptException Class See Also Send Feedback

Overload List

Name | Description
ScriptException()()() | Initializes a new instance of the class.
ScriptException(String) | Initializes a new instance of the class with a message.
ScriptException(String, Exception) | Initializes a new instance of the class with a message and another exception.
ScriptException(String, array<Object>[]()[]) | Initializes a new instance of the class with a message.
ScriptException(String, Exception, array<Object>[]()[]) | Initializes a new instance of the class with a message and another exception.

See Also

ScriptException Class
ScriptException Members
Mincom.LinkOne.Exceptions Namespace


ScriptException Constructor

[image]

LinkOne WebView API
ScriptException Constructor
ScriptException Class See Also Send Feedback
Initializes a new instance of the class.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ScriptException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ScriptException()

See Also

ScriptException Class
ScriptException Overload
Mincom.LinkOne.Exceptions Namespace


ScriptException Constructor (String)

[image]

LinkOne WebView API
ScriptException Constructor (String)
ScriptException Class See Also Send Feedback
Initializes a new instance of the class with a message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ScriptException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
ScriptException(
    String^ message
)

Parameters

message
Type: System..::.String
The exception message.

See Also

ScriptException Class
ScriptException Overload
Mincom.LinkOne.Exceptions Namespace


ScriptException Constructor (String, Exception)

[image]

LinkOne WebView API
ScriptException Constructor (String, Exception)
ScriptException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ScriptException(
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
ScriptException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The exception to wrap.

See Also

ScriptException Class
ScriptException Overload
Mincom.LinkOne.Exceptions Namespace


ScriptException Constructor (String, Object[])

[image]

LinkOne WebView API
ScriptException Constructor (String, array<Object>[]()[])
ScriptException Class See Also Send Feedback
Initializes a new instance of the class with a message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ScriptException(
    string message,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    ParamArray args As Object() _
)
Visual C++
public:
ScriptException(
    String^ message,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

ScriptException Class
ScriptException Overload
Mincom.LinkOne.Exceptions Namespace


ScriptException Constructor (String, Exception, Object[])

[image]

LinkOne WebView API
ScriptException Constructor (String, Exception, array<Object>[]()[])
ScriptException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ScriptException(
    string message,
    Exception inner,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception, _
    ParamArray args As Object() _
)
Visual C++
public:
ScriptException(
    String^ message,
    Exception^ inner,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
inner
Type: System..::.Exception
The exception to wrap.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

ScriptException Class
ScriptException Overload
Mincom.LinkOne.Exceptions Namespace


ScriptException Methods

[image] [image]

LinkOne WebView API
ScriptException Methods
ScriptException Class See Also Send Feedback

The ScriptException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ScriptException Class
Mincom.LinkOne.Exceptions Namespace


ScriptException Properties

[image] [image]

LinkOne WebView API
ScriptException Properties
ScriptException Class See Also Send Feedback

The ScriptException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ScriptException Class
Mincom.LinkOne.Exceptions Namespace


SearchDisabledException Class

[image]

LinkOne WebView API
SearchDisabledException Class
Members See Also Send Feedback
The exception when executing a disabled search.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class SearchDisabledException : BaseException
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class SearchDisabledException _
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class SearchDisabledException sealed : public BaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Mincom.LinkOne.Exceptions..::.BaseException
Mincom.LinkOne.Exceptions..::.SearchDisabledException

See Also

SearchDisabledException Members
Mincom.LinkOne.Exceptions Namespace


SearchDisabledException Members

[image] [image]

LinkOne WebView API
SearchDisabledException Members
SearchDisabledException Class Constructors Methods Properties See Also Send Feedback

The SearchDisabledException type exposes the following members.

Constructors

Name | Description
SearchDisabledException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SearchDisabledException Class
Mincom.LinkOne.Exceptions Namespace


SearchDisabledException Constructor

[image] [image]

LinkOne WebView API
SearchDisabledException Constructor
SearchDisabledException Class See Also Send Feedback

Overload List

Name | Description
SearchDisabledException()()() | Initializes a new instance of the class.
SearchDisabledException(String) | Initializes a new instance of the class with a message.
SearchDisabledException(String, Exception) | Initializes a new instance of the class with a message and another exception.
SearchDisabledException(String, array<Object>[]()[]) | Initializes a new instance of the class with a message.
SearchDisabledException(String, Exception, array<Object>[]()[]) | Initializes a new instance of the class with a message and another exception.

See Also

SearchDisabledException Class
SearchDisabledException Members
Mincom.LinkOne.Exceptions Namespace


SearchDisabledException Constructor

[image]

LinkOne WebView API
SearchDisabledException Constructor
SearchDisabledException Class See Also Send Feedback
Initializes a new instance of the class.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchDisabledException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SearchDisabledException()

See Also

SearchDisabledException Class
SearchDisabledException Overload
Mincom.LinkOne.Exceptions Namespace


SearchDisabledException Constructor (String)

[image]

LinkOne WebView API
SearchDisabledException Constructor (String)
SearchDisabledException Class See Also Send Feedback
Initializes a new instance of the class with a message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchDisabledException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
SearchDisabledException(
    String^ message
)

Parameters

message
Type: System..::.String
The exception message.

See Also

SearchDisabledException Class
SearchDisabledException Overload
Mincom.LinkOne.Exceptions Namespace


SearchDisabledException Constructor (String, Exception)

[image]

LinkOne WebView API
SearchDisabledException Constructor (String, Exception)
SearchDisabledException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchDisabledException(
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
SearchDisabledException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The exception to wrap.

See Also

SearchDisabledException Class
SearchDisabledException Overload
Mincom.LinkOne.Exceptions Namespace


SearchDisabledException Constructor (String, Object[])

[image]

LinkOne WebView API
SearchDisabledException Constructor (String, array<Object>[]()[])
SearchDisabledException Class See Also Send Feedback
Initializes a new instance of the class with a message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchDisabledException(
    string message,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    ParamArray args As Object() _
)
Visual C++
public:
SearchDisabledException(
    String^ message,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

SearchDisabledException Class
SearchDisabledException Overload
Mincom.LinkOne.Exceptions Namespace


SearchDisabledException Constructor (String, Exception, Object[])

[image]

LinkOne WebView API
SearchDisabledException Constructor (String, Exception, array<Object>[]()[])
SearchDisabledException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SearchDisabledException(
    string message,
    Exception inner,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception, _
    ParamArray args As Object() _
)
Visual C++
public:
SearchDisabledException(
    String^ message,
    Exception^ inner,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
inner
Type: System..::.Exception
The exception to wrap.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

SearchDisabledException Class
SearchDisabledException Overload
Mincom.LinkOne.Exceptions Namespace


SearchDisabledException Methods

[image] [image]

LinkOne WebView API
SearchDisabledException Methods
SearchDisabledException Class See Also Send Feedback

The SearchDisabledException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

SearchDisabledException Class
Mincom.LinkOne.Exceptions Namespace


SearchDisabledException Properties

[image] [image]

LinkOne WebView API
SearchDisabledException Properties
SearchDisabledException Class See Also Send Feedback

The SearchDisabledException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SearchDisabledException Class
Mincom.LinkOne.Exceptions Namespace


SelectionListReadException Class

[image]

LinkOne WebView API
SelectionListReadException Class
Members See Also Send Feedback
This is thrown when a selection list reader encounteres a problem.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
[SerializableAttribute]
public sealed class SelectionListReadException : BaseException
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class SelectionListReadException _
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class SelectionListReadException sealed : public BaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Mincom.LinkOne.Exceptions..::.BaseException
Mincom.LinkOne.Exceptions..::.SelectionListReadException

See Also

SelectionListReadException Members
Mincom.LinkOne.Exceptions Namespace


SelectionListReadException Members

[image] [image]

LinkOne WebView API
SelectionListReadException Members
SelectionListReadException Class Constructors Methods Properties See Also Send Feedback

The SelectionListReadException type exposes the following members.

Constructors

Name | Description
SelectionListReadException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SelectionListReadException Class
Mincom.LinkOne.Exceptions Namespace


SelectionListReadException Constructor

[image] [image]

LinkOne WebView API
SelectionListReadException Constructor
SelectionListReadException Class See Also Send Feedback

Overload List

Name | Description
SelectionListReadException()()() | Initializes a new instance of the class.
SelectionListReadException(String) | Initializes a new instance of the class with a simple message.
SelectionListReadException(String, Exception) | Initializes a new instance of the class with a message and another exception.
SelectionListReadException(String, array<Object>[]()[]) | Initializes a new instance of the class with a simple message.
SelectionListReadException(String, Exception, array<Object>[]()[]) | Initializes a new instance of the class with a message and another exception.

See Also

SelectionListReadException Class
SelectionListReadException Members
Mincom.LinkOne.Exceptions Namespace


SelectionListReadException Constructor

[image]

LinkOne WebView API
SelectionListReadException Constructor
SelectionListReadException Class See Also Send Feedback
Initializes a new instance of the class.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SelectionListReadException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SelectionListReadException()

See Also

SelectionListReadException Class
SelectionListReadException Overload
Mincom.LinkOne.Exceptions Namespace


SelectionListReadException Constructor (String)

[image]

LinkOne WebView API
SelectionListReadException Constructor (String)
SelectionListReadException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SelectionListReadException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
SelectionListReadException(
    String^ message
)

Parameters

message
Type: System..::.String
The exception message.

See Also

SelectionListReadException Class
SelectionListReadException Overload
Mincom.LinkOne.Exceptions Namespace


SelectionListReadException Constructor (String, Exception)

[image]

LinkOne WebView API
SelectionListReadException Constructor (String, Exception)
SelectionListReadException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SelectionListReadException(
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
SelectionListReadException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The exception to wrap.

See Also

SelectionListReadException Class
SelectionListReadException Overload
Mincom.LinkOne.Exceptions Namespace


SelectionListReadException Constructor (String, Object[])

[image]

LinkOne WebView API
SelectionListReadException Constructor (String, array<Object>[]()[])
SelectionListReadException Class See Also Send Feedback
Initializes a new instance of the class with a simple message.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SelectionListReadException(
    string message,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    ParamArray args As Object() _
)
Visual C++
public:
SelectionListReadException(
    String^ message,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

SelectionListReadException Class
SelectionListReadException Overload
Mincom.LinkOne.Exceptions Namespace


SelectionListReadException Constructor (String, Exception, Object[])

[image]

LinkOne WebView API
SelectionListReadException Constructor (String, Exception, array<Object>[]()[])
SelectionListReadException Class See Also Send Feedback
Initializes a new instance of the class with a message and another exception.

Namespace: Mincom.LinkOne.Exceptions
Assembly: Mincom.LinkOne.Api (in Mincom.LinkOne.Api.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SelectionListReadException(
    string message,
    Exception inner,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception, _
    ParamArray args As Object() _
)
Visual C++
public:
SelectionListReadException(
    String^ message,
    Exception^ inner,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
inner
Type: System..::.Exception
The exception to wrap.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

SelectionListReadException Class
SelectionListReadException Overload
Mincom.LinkOne.Exceptions Namespace


SelectionListReadException Methods

[image] [image]

LinkOne WebView API
SelectionListReadException Methods
SelectionListReadException Class See Also Send Feedback

The SelectionListReadException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

SelectionListReadException Class
Mincom.LinkOne.Exceptions Namespace


SelectionListReadException Properties

[image] [image]

LinkOne WebView API
SelectionListReadException Properties
SelectionListReadException Class See Also Send Feedback

The SelectionListReadException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SelectionListReadException Class
Mincom.LinkOne.Exceptions Namespace


Mincom.LinkOne.Provider Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.Provider Namespace
Send Feedback
The Mincom.LinkOne.Provider namespace contains classes that provide book reading and writing for LinkOne book content.

Classes

Class | Description
ConfigureBookEventArgs | Provides data for the ConfigureBook event.
DownloadRequestEventArgs | Provides data for the download request events.
FileProvider | This class provides LinkOne WinView data objects.
InstallBooksProgressEventArgs | Provides data for book install events.
LibraryProgressEventArgs | Provides data for the library progress events.
Tracing | Trace switch for the assembly.

Interfaces

Interface | Description
IPersistService | Implemented by a component to provide books.

Delegates

Delegate | Description
ConfigureBookEventHandler | Represents the method that will handle the configure book event.
DownloadRequestEventHandler | Represents the method that will handle download request events.
InstallBooksProgressEventHandler | Represents the method that will handle book installation events.
LibraryProgressEventHandler | Represents the method that will handle library progress events.


ConfigureBookEventArgs Class

[image]

LinkOne WebView API
ConfigureBookEventArgs Class
Members See Also Send Feedback
Provides data for the ConfigureBook event.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
[SerializableAttribute]
public sealed class ConfigureBookEventArgs : EventArgs
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class ConfigureBookEventArgs _
    Inherits EventArgs
Visual C++
[SerializableAttribute]
public ref class ConfigureBookEventArgs sealed : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Mincom.LinkOne.Provider..::.ConfigureBookEventArgs

See Also

ConfigureBookEventArgs Members
Mincom.LinkOne.Provider Namespace


ConfigureBookEventArgs Members

[image] [image]

LinkOne WebView API
ConfigureBookEventArgs Members
ConfigureBookEventArgs Class Constructors Methods Properties See Also Send Feedback

The ConfigureBookEventArgs type exposes the following members.

Constructors

Name | Description
ConfigureBookEventArgs | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
BookCode | Gets or sets the wanted book code.
Configured | Gets or sets whether the configure event args are configured.
CurrentBookCode | Gets or sets the current book code.
CurrentPublisherCode | Gets or sets the current publisher code.
Filters | Gets or sets the current filters.
ItemId | Gets or sets the wanted item id.
LanguageCode | Gets or sets the current language code.
PageReference | Gets or sets the wanted page reference.
PublisherCode | Gets or sets the wanted publisher code.

See Also

ConfigureBookEventArgs Class
Mincom.LinkOne.Provider Namespace


ConfigureBookEventArgs Constructor

[image] [image]

LinkOne WebView API
ConfigureBookEventArgs Constructor
ConfigureBookEventArgs Class See Also Send Feedback

Overload List

Name | Description
ConfigureBookEventArgs()()() | Constructor.
ConfigureBookEventArgs(String, String, String) | Constructor.

See Also

ConfigureBookEventArgs Class
ConfigureBookEventArgs Members
Mincom.LinkOne.Provider Namespace


ConfigureBookEventArgs Constructor

[image]

LinkOne WebView API
ConfigureBookEventArgs Constructor
ConfigureBookEventArgs Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public ConfigureBookEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConfigureBookEventArgs()

See Also

ConfigureBookEventArgs Class
ConfigureBookEventArgs Overload
Mincom.LinkOne.Provider Namespace


ConfigureBookEventArgs Constructor (String, String, String)

[image]

LinkOne WebView API
ConfigureBookEventArgs Constructor (String, String, String)
ConfigureBookEventArgs Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public ConfigureBookEventArgs(
    string publisherCode,
    string bookCode,
    string languageCode
)
Visual Basic (Declaration)
Public Sub New ( _
    publisherCode As String, _
    bookCode As String, _
    languageCode As String _
)
Visual C++
public:
ConfigureBookEventArgs(
    String^ publisherCode,
    String^ bookCode,
    String^ languageCode
)

Parameters

publisherCode
Type: System..::.String
The publisher code of the book to configure for.
bookCode
Type: System..::.String
The book code of the book to configure for.
languageCode
Type: System..::.String
The current language code.

See Also

ConfigureBookEventArgs Class
ConfigureBookEventArgs Overload
Mincom.LinkOne.Provider Namespace


ConfigureBookEventArgs Methods

[image] [image]

LinkOne WebView API
ConfigureBookEventArgs Methods
ConfigureBookEventArgs Class See Also Send Feedback

The ConfigureBookEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ConfigureBookEventArgs Class
Mincom.LinkOne.Provider Namespace


ConfigureBookEventArgs Properties

[image] [image]

LinkOne WebView API
ConfigureBookEventArgs Properties
ConfigureBookEventArgs Class See Also Send Feedback

The ConfigureBookEventArgs type exposes the following members.

Properties

Name | Description
BookCode | Gets or sets the wanted book code.
Configured | Gets or sets whether the configure event args are configured.
CurrentBookCode | Gets or sets the current book code.
CurrentPublisherCode | Gets or sets the current publisher code.
Filters | Gets or sets the current filters.
ItemId | Gets or sets the wanted item id.
LanguageCode | Gets or sets the current language code.
PageReference | Gets or sets the wanted page reference.
PublisherCode | Gets or sets the wanted publisher code.

See Also

ConfigureBookEventArgs Class
Mincom.LinkOne.Provider Namespace


BookCode Property

[image]

LinkOne WebView API
ConfigureBookEventArgs..::.BookCode Property
ConfigureBookEventArgs Class See Also Send Feedback
Gets or sets the wanted book code.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public string BookCode { get; set; }
Visual Basic (Declaration)
Public Property BookCode As String
Visual C++
public:
property String^ BookCode {
    String^ get ();
    void set (String^ value);
}

See Also

ConfigureBookEventArgs Class
Mincom.LinkOne.Provider Namespace


Configured Property

[image]

LinkOne WebView API
ConfigureBookEventArgs..::.Configured Property
ConfigureBookEventArgs Class See Also Send Feedback
Gets or sets whether the configure event args are configured.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public bool Configured { get; set; }
Visual Basic (Declaration)
Public Property Configured As Boolean
Visual C++
public:
property bool Configured {
    bool get ();
    void set (bool value);
}

See Also

ConfigureBookEventArgs Class
Mincom.LinkOne.Provider Namespace


CurrentBookCode Property

[image]

LinkOne WebView API
ConfigureBookEventArgs..::.CurrentBookCode Property
ConfigureBookEventArgs Class See Also Send Feedback
Gets or sets the current book code.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public string CurrentBookCode { get; set; }
Visual Basic (Declaration)
Public Property CurrentBookCode As String
Visual C++
public:
property String^ CurrentBookCode {
    String^ get ();
    void set (String^ value);
}

See Also

ConfigureBookEventArgs Class
Mincom.LinkOne.Provider Namespace


CurrentPublisherCode Property

[image]

LinkOne WebView API
ConfigureBookEventArgs..::.CurrentPublisherCode Property
ConfigureBookEventArgs Class See Also Send Feedback
Gets or sets the current publisher code.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public string CurrentPublisherCode { get; set; }
Visual Basic (Declaration)
Public Property CurrentPublisherCode As String
Visual C++
public:
property String^ CurrentPublisherCode {
    String^ get ();
    void set (String^ value);
}

See Also

ConfigureBookEventArgs Class
Mincom.LinkOne.Provider Namespace


Filters Property

[image]

LinkOne WebView API
ConfigureBookEventArgs..::.Filters Property
ConfigureBookEventArgs Class See Also Send Feedback
Gets or sets the current filters.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public IFilterCollection Filters { get; set; }
Visual Basic (Declaration)
Public Property Filters As IFilterCollection
Visual C++
public:
property IFilterCollection^ Filters {
    IFilterCollection^ get ();
    void set (IFilterCollection^ value);
}

See Also

ConfigureBookEventArgs Class
Mincom.LinkOne.Provider Namespace


ItemId Property

[image]

LinkOne WebView API
ConfigureBookEventArgs..::.ItemId Property
ConfigureBookEventArgs Class See Also Send Feedback
Gets or sets the wanted item id.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public string ItemId { get; set; }
Visual Basic (Declaration)
Public Property ItemId As String
Visual C++
public:
property String^ ItemId {
    String^ get ();
    void set (String^ value);
}

See Also

ConfigureBookEventArgs Class
Mincom.LinkOne.Provider Namespace


LanguageCode Property

[image]

LinkOne WebView API
ConfigureBookEventArgs..::.LanguageCode Property
ConfigureBookEventArgs Class See Also Send Feedback
Gets or sets the current language code.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public string LanguageCode { get; set; }
Visual Basic (Declaration)
Public Property LanguageCode As String
Visual C++
public:
property String^ LanguageCode {
    String^ get ();
    void set (String^ value);
}

See Also

ConfigureBookEventArgs Class
Mincom.LinkOne.Provider Namespace


PageReference Property

[image]

LinkOne WebView API
ConfigureBookEventArgs..::.PageReference Property
ConfigureBookEventArgs Class See Also Send Feedback
Gets or sets the wanted page reference.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public string PageReference { get; set; }
Visual Basic (Declaration)
Public Property PageReference As String
Visual C++
public:
property String^ PageReference {
    String^ get ();
    void set (String^ value);
}

See Also

ConfigureBookEventArgs Class
Mincom.LinkOne.Provider Namespace


PublisherCode Property

[image]

LinkOne WebView API
ConfigureBookEventArgs..::.PublisherCode Property
ConfigureBookEventArgs Class See Also Send Feedback
Gets or sets the wanted publisher code.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public string PublisherCode { get; set; }
Visual Basic (Declaration)
Public Property PublisherCode As String
Visual C++
public:
property String^ PublisherCode {
    String^ get ();
    void set (String^ value);
}

See Also

ConfigureBookEventArgs Class
Mincom.LinkOne.Provider Namespace


ConfigureBookEventHandler Delegate

[image]

LinkOne WebView API
ConfigureBookEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the configure book event.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public delegate void ConfigureBookEventHandler(
    Object sender,
    ConfigureBookEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub ConfigureBookEventHandler ( _
    sender As Object, _
    e As ConfigureBookEventArgs _
)
Visual C++
public delegate void ConfigureBookEventHandler(
    Object^ sender,
    ConfigureBookEventArgs^ e
)

Parameters

sender
Type: System..::.Object
e
Type: Mincom.LinkOne.Provider..::.ConfigureBookEventArgs

See Also

Mincom.LinkOne.Provider Namespace


DownloadRequestEventArgs Class

[image]

LinkOne WebView API
DownloadRequestEventArgs Class
Members See Also Send Feedback
Provides data for the download request events.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public sealed class DownloadRequestEventArgs : EventArgs
Visual Basic (Declaration)
Public NotInheritable Class DownloadRequestEventArgs _
    Inherits EventArgs
Visual C++
public ref class DownloadRequestEventArgs sealed : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Mincom.LinkOne.Provider..::.DownloadRequestEventArgs

See Also

DownloadRequestEventArgs Members
Mincom.LinkOne.Provider Namespace


DownloadRequestEventArgs Members

[image] [image]

LinkOne WebView API
DownloadRequestEventArgs Members
DownloadRequestEventArgs Class Constructors Methods Properties See Also Send Feedback

The DownloadRequestEventArgs type exposes the following members.

Constructors

Name | Description
DownloadRequestEventArgs | Initializes a new instance of the DownloadRequestEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Request | Gets the request for the event.

See Also

DownloadRequestEventArgs Class
Mincom.LinkOne.Provider Namespace


DownloadRequestEventArgs Constructor

[image]

LinkOne WebView API
DownloadRequestEventArgs Constructor
DownloadRequestEventArgs Class See Also Send Feedback
Initializes a new instance of the DownloadRequestEventArgs class.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public DownloadRequestEventArgs(
    WebRequest request
)
Visual Basic (Declaration)
Public Sub New ( _
    request As WebRequest _
)
Visual C++
public:
DownloadRequestEventArgs(
    WebRequest^ request
)

Parameters

request
Type: System.Net..::.WebRequest
The request.

See Also

DownloadRequestEventArgs Class
Mincom.LinkOne.Provider Namespace


DownloadRequestEventArgs Methods

[image] [image]

LinkOne WebView API
DownloadRequestEventArgs Methods
DownloadRequestEventArgs Class See Also Send Feedback

The DownloadRequestEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DownloadRequestEventArgs Class
Mincom.LinkOne.Provider Namespace


DownloadRequestEventArgs Properties

[image] [image]

LinkOne WebView API
DownloadRequestEventArgs Properties
DownloadRequestEventArgs Class See Also Send Feedback

The DownloadRequestEventArgs type exposes the following members.

Properties

Name | Description
Request | Gets the request for the event.

See Also

DownloadRequestEventArgs Class
Mincom.LinkOne.Provider Namespace


Request Property

[image]

LinkOne WebView API
DownloadRequestEventArgs..::.Request Property
DownloadRequestEventArgs Class See Also Send Feedback
Gets the request for the event.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public WebRequest Request { get; }
Visual Basic (Declaration)
Public ReadOnly Property Request As WebRequest
Visual C++
public:
property WebRequest^ Request {
    WebRequest^ get ();
}

See Also

DownloadRequestEventArgs Class
Mincom.LinkOne.Provider Namespace


DownloadRequestEventHandler Delegate

[image]

LinkOne WebView API
DownloadRequestEventHandler Delegate
See Also Send Feedback
Represents the method that will handle download request events.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public delegate void DownloadRequestEventHandler(
    Object sender,
    DownloadRequestEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub DownloadRequestEventHandler ( _
    sender As Object, _
    e As DownloadRequestEventArgs _
)
Visual C++
public delegate void DownloadRequestEventHandler(
    Object^ sender,
    DownloadRequestEventArgs^ e
)

Parameters

sender
Type: System..::.Object
The source of the event.
e
Type: Mincom.LinkOne.Provider..::.DownloadRequestEventArgs
The DownloadRequestEventArgs instance that contains the event data.

See Also

Mincom.LinkOne.Provider Namespace


FileProvider Class

[image]

LinkOne WebView API
FileProvider Class
Members See Also Send Feedback
This class provides LinkOne WinView data objects.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public sealed class FileProvider : IPersistService,
    IPersistProvider, IDisposable, INotifyPropertyChanged
Visual Basic (Declaration)
Public NotInheritable Class FileProvider _
    Implements IPersistService, IPersistProvider, IDisposable, INotifyPropertyChanged
Visual C++
public ref class FileProvider sealed : IPersistService,
    IPersistProvider, IDisposable, INotifyPropertyChanged

Remarks

Reading an object from the FileProvider will always return a non-null value or throw an exception.
Reading a collection will always return the collection or an empty collection (it will absorb any errors on any element).

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Provider..::.FileProvider

See Also

FileProvider Members
Mincom.LinkOne.Provider Namespace


FileProvider Members

[image] [image]

LinkOne WebView API
FileProvider Members
FileProvider Class Constructors Methods Properties Events See Also Send Feedback

The FileProvider type exposes the following members.

Constructors

Name | Description
FileProvider | Constructor.

Methods

Name | Description
Cancel | Cancels the current download.
Dispose | Dispose of components.
Download | Returns the content of the given file.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetManager | Overloaded.
GetType | Gets the type of the current instance. (Inherited from Object.)
Initialize | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Read | Read the wanted object from storage.
ReadIgnoreLangOption |
Refresh | clear the wanted object from storage then attempt to read the wanted object i.e. refresh it.
SetManager | Sets the IPersistManager.
ToString | Returns a string that represents the current object. (Inherited from Object.)
Write | Write the given IPersist item into persistent storage.

Properties

Name | Description
BookDefFileSizeLimit |
Cancelled | Gets or sets whether the current synchronous action is cancelled or if the last synchronous action was cancelled.
CodePage | Gets or sets the codepage to parse the libraries in.
DefaultLibraryType | Gets or sets the default library type for when no type is specified for a library.
DownloadCredentials | Gets or sets the download credentials.
DownloadProxyCredentials | Gets or sets the download proxy credentials.
Encoding | Gets the encoding of the library
ForceDefaultLibraryType | Gets or sets a value indicating whether or not to force the default library type upon all libraries.
InactivityTimeoutSeconds | Gets or sets the timeout in seconds for aborting an inactive download connection.
IsOffline | Gets a value indicating whether the provider has internet access.
LanguageCode | Gets or sets the two letter ISO 639-1 preferred book language code.
Libraries | Gets or sets the list of managed libraries in formatted XML.
Password | Sets the protected download password.
PlainTextPassword | Sets the plain text download password.
PrivateDocumentsDirectory | Gets or sets the private documents directory.
PrivateNotesDirectory | Gets or sets the directory to store private notes in.
ProxyPassword | Sets the protected proxy password.
ProxyPlainTextPassword | Sets the plain text proxy password.
ProxyUserName | Gets or sets the proxy user name.
PublicDocumentsDirectory | Gets or sets the public documents directory.
PublicNotesDirectory | Gets or sets the directory to store public notes in.
SaveNotesAsUnicode | Gets or sets a boolean indicating if notes to be saved as Unicode.
UseDefaultCredentials | Gets or sets a value indicating whether to use default download credentials.
UseDefaultProxyCredentials | Gets or sets a value indicating whether to use default proxy credentials.
UserName | Gets or sets the download user name.
UseUnicodeListings | Gets or sets a value indicating whether or not to use Unicode listings for publishers and books.
ViewerVersion | Made public as seems to need to be set for License check by Library Indexer.
WorkOffline | Gets or sets a value indicating whether the provider should access the internet to update Libraries, Publishers and Books.
WorkOfflineOnStartup |

Events

Name | Description
CompressProgress | Occurs when the provider is reporting compression progress.
ConfigureBook | Occurs when the provider requests configuration information for a dynamic derived book.
DownloadBegin | Occurs when the provider is reporting a download beginning.
DownloadProgress | Occurs when the provider is reporting download progress.
ExpandProgress | Occurs when the provider is reporting expansion progress.
InstallProgress | Occurs when the provider is reporting install progress.
LibraryChanged | Occurs when the library has changed.
PrepareProgress | Occurs when the provider is reporting prepare progress.
PropertyChanged | Occurs when a property value changes.
SyncProgress | Occurs when the provider is reporting synchronization progress.

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


FileProvider Constructor

[image]

LinkOne WebView API
FileProvider Constructor
FileProvider Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public FileProvider()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FileProvider()

Remarks

After constructing a FileProvider class, call FileProvider.Initialize( Assembly ) to pass in the credentials.

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


FileProvider Methods

[image] [image]

LinkOne WebView API
FileProvider Methods
FileProvider Class See Also Send Feedback

The FileProvider type exposes the following members.

Methods

Name | Description
Cancel | Cancels the current download.
Dispose | Dispose of components.
Download | Returns the content of the given file.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetManager | Overloaded.
GetType | Gets the type of the current instance. (Inherited from Object.)
Initialize | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Read | Read the wanted object from storage.
ReadIgnoreLangOption |
Refresh | clear the wanted object from storage then attempt to read the wanted object i.e. refresh it.
SetManager | Sets the IPersistManager.
ToString | Returns a string that represents the current object. (Inherited from Object.)
Write | Write the given IPersist item into persistent storage.

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


Cancel Method

[image]

LinkOne WebView API
FileProvider..::.Cancel Method
FileProvider Class See Also Send Feedback
Cancels the current download.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Cancel()
Visual Basic (Declaration)
Public Sub Cancel
Visual C++
public:
virtual void Cancel() sealed

Implements

IPersistService..::.Cancel()()()

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


Dispose Method

[image]

LinkOne WebView API
FileProvider..::.Dispose Method
FileProvider Class See Also Send Feedback
Dispose of components.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


Download Method

[image]

LinkOne WebView API
FileProvider..::.Download Method
FileProvider Class See Also Send Feedback
Returns the content of the given file.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public byte[] Download(
    Uri fileName
)
Visual Basic (Declaration)
Public Function Download ( _
    fileName As Uri _
) As Byte()
Visual C++
public:
array<unsigned char>^ Download(
    Uri^ fileName
)

Parameters

fileName
Type: System..::.Uri
Name of the file to get.

Return Value

The content of the given file.

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


GetManager Method

[image] [image]

LinkOne WebView API
FileProvider..::.GetManager Method
FileProvider Class See Also Send Feedback

Overload List

Name | Description
GetManager()()() | Returns a new instance of an IPersistManager with the provider's libraries.
GetManager(array<String>[]()[]) | Returns a new instance of an IPersistManager for the given libraries.

See Also

FileProvider Class
FileProvider Members
Mincom.LinkOne.Provider Namespace


GetManager Method

[image]

LinkOne WebView API
FileProvider..::.GetManager Method
FileProvider Class See Also Send Feedback
Returns a new instance of an IPersistManager with the provider's libraries.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IPersistManager GetManager()
Visual Basic (Declaration)
Public Function GetManager As IPersistManager
Visual C++
public:
virtual IPersistManager^ GetManager() sealed

Return Value

A new instance of an IPersistManager with the provider's libraries.

Implements

IPersistService..::.GetManager()()()

See Also

FileProvider Class
GetManager Overload
Mincom.LinkOne.Provider Namespace


GetManager Method (String[])

[image]

LinkOne WebView API
FileProvider..::.GetManager Method (array<String>[]()[])
FileProvider Class See Also Send Feedback
Returns a new instance of an IPersistManager for the given libraries.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IPersistManager GetManager(
    params string[] libraryDirectories
)
Visual Basic (Declaration)
Public Function GetManager ( _
    ParamArray libraryDirectories As String() _
) As IPersistManager
Visual C++
public:
virtual IPersistManager^ GetManager(
    ... array<String^>^ libraryDirectories
) sealed

Parameters

libraryDirectories
Type: array< System..::.String >[]()[]
The library directories for the new manager.

Return Value

A new instance of an IPersistManager.

Implements

IPersistService..::.GetManager(array<String>[]()[])

See Also

FileProvider Class
GetManager Overload
Mincom.LinkOne.Provider Namespace


Initialize Method

[image] [image]

LinkOne WebView API
FileProvider..::.Initialize Method
FileProvider Class See Also Send Feedback

Overload List

Name | Description
Initialize(Assembly) | Initializes the provider with the credentials of the specified assembly, allowing it to validate licenses.
Initialize(String) | Initializes the provider with the specified credentials, allowing it to validate licenses.

See Also

FileProvider Class
FileProvider Members
Mincom.LinkOne.Provider Namespace


Initialize Method (Assembly)

[image]

LinkOne WebView API
FileProvider..::.Initialize Method (Assembly)
FileProvider Class See Also Send Feedback
Initializes the provider with the credentials of the specified assembly, allowing it to validate licenses.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Initialize(
    Assembly credentials
)
Visual Basic (Declaration)
Public Sub Initialize ( _
    credentials As Assembly _
)
Visual C++
public:
void Initialize(
    Assembly^ credentials
)

Parameters

credentials
Type: System.Reflection..::.Assembly
The assembly with credentials.

See Also

FileProvider Class
Initialize Overload
Mincom.LinkOne.Provider Namespace


Initialize Method (String)

[image]

LinkOne WebView API
FileProvider..::.Initialize Method (String)
FileProvider Class See Also Send Feedback
Initializes the provider with the specified credentials, allowing it to validate licenses.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Initialize(
    string credentials
)
Visual Basic (Declaration)
Public Sub Initialize ( _
    credentials As String _
)
Visual C++
public:
void Initialize(
    String^ credentials
)

Parameters

credentials
Type: System..::.String
The credentials.

See Also

FileProvider Class
Initialize Overload
Mincom.LinkOne.Provider Namespace


Read Method

[image]

LinkOne WebView API
FileProvider..::.Read Method
FileProvider Class See Also Send Feedback
Read the wanted object from storage.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IPersist Read(
    IPersistIdentity identity
)
Visual Basic (Declaration)
Public Function Read ( _
    identity As IPersistIdentity _
) As IPersist
Visual C++
public:
virtual IPersist^ Read(
    IPersistIdentity^ identity
) sealed

Parameters

identity
Type: Mincom.LinkOne.Dom..::.IPersistIdentity
Identifies the object to read.

Return Value

The wanted object identified by identity.

Implements

IPersistProvider..::.Read(IPersistIdentity)

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurs.

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


ReadIgnoreLangOption Method

[image]

LinkOne WebView API
FileProvider..::.ReadIgnoreLangOption Method
FileProvider Class See Also Send Feedback

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IPersist ReadIgnoreLangOption(
    IPersistIdentity identity
)
Visual Basic (Declaration)
Public Function ReadIgnoreLangOption ( _
    identity As IPersistIdentity _
) As IPersist
Visual C++
public:
virtual IPersist^ ReadIgnoreLangOption(
    IPersistIdentity^ identity
) sealed

Parameters

identity
Type: Mincom.LinkOne.Dom..::.IPersistIdentity

Implements

IPersistProvider..::.ReadIgnoreLangOption(IPersistIdentity)

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


Refresh Method

[image]

LinkOne WebView API
FileProvider..::.Refresh Method
FileProvider Class See Also Send Feedback
clear the wanted object from storage then attempt to read the wanted object i.e. refresh it.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IPersist Refresh(
    IPersistIdentity identity
)
Visual Basic (Declaration)
Public Function Refresh ( _
    identity As IPersistIdentity _
) As IPersist
Visual C++
public:
virtual IPersist^ Refresh(
    IPersistIdentity^ identity
) sealed

Parameters

identity
Type: Mincom.LinkOne.Dom..::.IPersistIdentity
Identifies the object to read.

Return Value

The wanted object identified by identity.

Implements

IPersistProvider..::.Refresh(IPersistIdentity)

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurs.

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


SetManager Method

[image]

LinkOne WebView API
FileProvider..::.SetManager Method
FileProvider Class See Also Send Feedback
Sets the IPersistManager.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void SetManager(
    IPersistManager manager
)
Visual Basic (Declaration)
Public Sub SetManager ( _
    manager As IPersistManager _
)
Visual C++
public:
virtual void SetManager(
    IPersistManager^ manager
) sealed

Parameters

manager
Type: Mincom.LinkOne.Provider.Persist..::.IPersistManager
The manager to set back onto the IBooksProvider.

Implements

IPersistService..::.SetManager(IPersistManager)

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


Write Method

[image]

LinkOne WebView API
FileProvider..::.Write Method
FileProvider Class See Also Send Feedback
Write the given IPersist item into persistent storage.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IPersist Write(
    IPrincipal principal,
    IPersist element
)
Visual Basic (Declaration)
Public Function Write ( _
    principal As IPrincipal, _
    element As IPersist _
) As IPersist
Visual C++
public:
virtual IPersist^ Write(
    IPrincipal^ principal,
    IPersist^ element
) sealed

Parameters

principal
Type: Mincom.LinkOne.Dom..::.IPrincipal
The owner of the object.
element
Type: Mincom.LinkOne.Dom..::.IPersist
The object to persist.

Return Value

The object, possibly changed during the write, or possibly null. This depends on the object being written.

Implements

IPersistProvider..::.Write(IPrincipal, IPersist)

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurs.

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


FileProvider Properties

[image] [image]

LinkOne WebView API
FileProvider Properties
FileProvider Class See Also Send Feedback

The FileProvider type exposes the following members.

Properties

Name | Description
BookDefFileSizeLimit |
Cancelled | Gets or sets whether the current synchronous action is cancelled or if the last synchronous action was cancelled.
CodePage | Gets or sets the codepage to parse the libraries in.
DefaultLibraryType | Gets or sets the default library type for when no type is specified for a library.
DownloadCredentials | Gets or sets the download credentials.
DownloadProxyCredentials | Gets or sets the download proxy credentials.
Encoding | Gets the encoding of the library
ForceDefaultLibraryType | Gets or sets a value indicating whether or not to force the default library type upon all libraries.
InactivityTimeoutSeconds | Gets or sets the timeout in seconds for aborting an inactive download connection.
IsOffline | Gets a value indicating whether the provider has internet access.
LanguageCode | Gets or sets the two letter ISO 639-1 preferred book language code.
Libraries | Gets or sets the list of managed libraries in formatted XML.
Password | Sets the protected download password.
PlainTextPassword | Sets the plain text download password.
PrivateDocumentsDirectory | Gets or sets the private documents directory.
PrivateNotesDirectory | Gets or sets the directory to store private notes in.
ProxyPassword | Sets the protected proxy password.
ProxyPlainTextPassword | Sets the plain text proxy password.
ProxyUserName | Gets or sets the proxy user name.
PublicDocumentsDirectory | Gets or sets the public documents directory.
PublicNotesDirectory | Gets or sets the directory to store public notes in.
SaveNotesAsUnicode | Gets or sets a boolean indicating if notes to be saved as Unicode.
UseDefaultCredentials | Gets or sets a value indicating whether to use default download credentials.
UseDefaultProxyCredentials | Gets or sets a value indicating whether to use default proxy credentials.
UserName | Gets or sets the download user name.
UseUnicodeListings | Gets or sets a value indicating whether or not to use Unicode listings for publishers and books.
ViewerVersion | Made public as seems to need to be set for License check by Library Indexer.
WorkOffline | Gets or sets a value indicating whether the provider should access the internet to update Libraries, Publishers and Books.
WorkOfflineOnStartup |

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


BookDefFileSizeLimit Property

[image]

LinkOne WebView API
FileProvider..::.BookDefFileSizeLimit Property
FileProvider Class See Also Send Feedback

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int BookDefFileSizeLimit { get; set; }
Visual Basic (Declaration)
Public Property BookDefFileSizeLimit As Integer
Visual C++
public:
property int BookDefFileSizeLimit {
    int get ();
    void set (int value);
}

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


Cancelled Property

[image]

LinkOne WebView API
FileProvider..::.Cancelled Property
FileProvider Class See Also Send Feedback
Gets or sets whether the current synchronous action is cancelled or if the last synchronous action was cancelled.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Cancelled { get; set; }
Visual Basic (Declaration)
Public Property Cancelled As Boolean
Visual C++
public:
property bool Cancelled {
    bool get ();
    void set (bool value);
}

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


CodePage Property

[image]

LinkOne WebView API
FileProvider..::.CodePage Property
FileProvider Class See Also Send Feedback
Gets or sets the codepage to parse the libraries in.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int CodePage { get; set; }
Visual Basic (Declaration)
Public Property CodePage As Integer
Visual C++
public:
virtual property int CodePage {
    int get () sealed;
    void set (int value) sealed;
}

Implements

IPersistService..::.CodePage

Remarks

If 0 is specified, the code page is made the current user's system code page.

Setting the code page also affects the Encoding property.

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


DefaultLibraryType Property

[image]

LinkOne WebView API
FileProvider..::.DefaultLibraryType Property
FileProvider Class See Also Send Feedback
Gets or sets the default library type for when no type is specified for a library.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LibraryType DefaultLibraryType { get; set; }
Visual Basic (Declaration)
Public Property DefaultLibraryType As LibraryType
Visual C++
public:
property LibraryType DefaultLibraryType {
    LibraryType get ();
    void set (LibraryType value);
}

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


DownloadCredentials Property

[image]

LinkOne WebView API
FileProvider..::.DownloadCredentials Property
FileProvider Class See Also Send Feedback
Gets or sets the download credentials.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ICredentials DownloadCredentials { get; set; }
Visual Basic (Declaration)
Public Property DownloadCredentials As ICredentials
Visual C++
public:
property ICredentials^ DownloadCredentials {
    ICredentials^ get ();
    void set (ICredentials^ value);
}

Remarks

Setting this property does not fire the PropertyChanged event.

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


DownloadProxyCredentials Property

[image]

LinkOne WebView API
FileProvider..::.DownloadProxyCredentials Property
FileProvider Class See Also Send Feedback
Gets or sets the download proxy credentials.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ICredentials DownloadProxyCredentials { get; set; }
Visual Basic (Declaration)
Public Property DownloadProxyCredentials As ICredentials
Visual C++
public:
property ICredentials^ DownloadProxyCredentials {
    ICredentials^ get ();
    void set (ICredentials^ value);
}

Remarks

Setting this property does not fire the PropertyChanged event.

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


Encoding Property

[image]

LinkOne WebView API
FileProvider..::.Encoding Property
FileProvider Class See Also Send Feedback
Gets the encoding of the library

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Encoding Encoding { get; }
Visual Basic (Declaration)
Public ReadOnly Property Encoding As Encoding
Visual C++
public:
property Encoding^ Encoding {
    Encoding^ get ();
}

Remarks

The encoding is set with the CodePage property.

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


ForceDefaultLibraryType Property

[image]

LinkOne WebView API
FileProvider..::.ForceDefaultLibraryType Property
FileProvider Class See Also Send Feedback
Gets or sets a value indicating whether or not to force the default library type upon all libraries.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool ForceDefaultLibraryType { get; set; }
Visual Basic (Declaration)
Public Property ForceDefaultLibraryType As Boolean
Visual C++
public:
property bool ForceDefaultLibraryType {
    bool get ();
    void set (bool value);
}

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


InactivityTimeoutSeconds Property

[image]

LinkOne WebView API
FileProvider..::.InactivityTimeoutSeconds Property
FileProvider Class See Also Send Feedback
Gets or sets the timeout in seconds for aborting an inactive download connection.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int InactivityTimeoutSeconds { get; set; }
Visual Basic (Declaration)
Public Property InactivityTimeoutSeconds As Integer
Visual C++
public:
property int InactivityTimeoutSeconds {
    int get ();
    void set (int value);
}

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


IsOffline Property

[image]

LinkOne WebView API
FileProvider..::.IsOffline Property
FileProvider Class See Also Send Feedback
Gets a value indicating whether the provider has internet access.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsOffline { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsOffline As Boolean
Visual C++
public:
property bool IsOffline {
    bool get ();
}

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


LanguageCode Property

[image]

LinkOne WebView API
FileProvider..::.LanguageCode Property
FileProvider Class See Also Send Feedback
Gets or sets the two letter ISO 639-1 preferred book language code.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string LanguageCode { get; set; }
Visual Basic (Declaration)
Public Property LanguageCode As String
Visual C++
public:
virtual property String^ LanguageCode {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IPersistService..::.LanguageCode

Remarks

If null or empty is specified, the language code is made the current language.

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


Libraries Property

[image]

LinkOne WebView API
FileProvider..::.Libraries Property
FileProvider Class See Also Send Feedback
Gets or sets the list of managed libraries in formatted XML.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public XmlElement Libraries { get; set; }
Visual Basic (Declaration)
Public Property Libraries As XmlElement
Visual C++
public:
property XmlElement^ Libraries {
    XmlElement^ get ();
    void set (XmlElement^ value);
}

Remarks

If null or badly formed XML is specified, then the list of managed libraries is cleared.

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


Password Property

[image]

LinkOne WebView API
FileProvider..::.Password Property
FileProvider Class See Also Send Feedback
Sets the protected download password.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Password { get; set; }
Visual Basic (Declaration)
Public Property Password As String
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


PlainTextPassword Property

[image]

LinkOne WebView API
FileProvider..::.PlainTextPassword Property
FileProvider Class See Also Send Feedback
Sets the plain text download password.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PlainTextPassword { set; }
Visual Basic (Declaration)
Public WriteOnly Property PlainTextPassword As String
Visual C++
public:
property String^ PlainTextPassword {
    void set (String^ value);
}

Remarks

Setting this property does not fire the PropertyChanged event.

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


PrivateDocumentsDirectory Property

[image]

LinkOne WebView API
FileProvider..::.PrivateDocumentsDirectory Property
FileProvider Class See Also Send Feedback
Gets or sets the private documents directory.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PrivateDocumentsDirectory { get; set; }
Visual Basic (Declaration)
Public Property PrivateDocumentsDirectory As String
Visual C++
public:
virtual property String^ PrivateDocumentsDirectory {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IPersistService..::.PrivateDocumentsDirectory

Remarks

If null or empty is specified, the directory is set to the default private documents folder.

Setting this property does not fire the PropertyChanged event.

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


PrivateNotesDirectory Property

[image]

LinkOne WebView API
FileProvider..::.PrivateNotesDirectory Property
FileProvider Class See Also Send Feedback
Gets or sets the directory to store private notes in.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PrivateNotesDirectory { get; set; }
Visual Basic (Declaration)
Public Property PrivateNotesDirectory As String
Visual C++
public:
virtual property String^ PrivateNotesDirectory {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IPersistService..::.PrivateNotesDirectory

Remarks

If null or empty is specified, the directory is set to the default location off the private documents folder.

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


ProxyPassword Property

[image]

LinkOne WebView API
FileProvider..::.ProxyPassword Property
FileProvider Class See Also Send Feedback
Sets the protected proxy password.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string ProxyPassword { get; set; }
Visual Basic (Declaration)
Public Property ProxyPassword As String
Visual C++
public:
property String^ ProxyPassword {
    String^ get ();
    void set (String^ value);
}

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


ProxyPlainTextPassword Property

[image]

LinkOne WebView API
FileProvider..::.ProxyPlainTextPassword Property
FileProvider Class See Also Send Feedback
Sets the plain text proxy password.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string ProxyPlainTextPassword { set; }
Visual Basic (Declaration)
Public WriteOnly Property ProxyPlainTextPassword As String
Visual C++
public:
property String^ ProxyPlainTextPassword {
    void set (String^ value);
}

Remarks

Setting this property does not fire the PropertyChanged event.

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


ProxyUserName Property

[image]

LinkOne WebView API
FileProvider..::.ProxyUserName Property
FileProvider Class See Also Send Feedback
Gets or sets the proxy user name.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string ProxyUserName { get; set; }
Visual Basic (Declaration)
Public Property ProxyUserName As String
Visual C++
public:
property String^ ProxyUserName {
    String^ get ();
    void set (String^ value);
}

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


PublicDocumentsDirectory Property

[image]

LinkOne WebView API
FileProvider..::.PublicDocumentsDirectory Property
FileProvider Class See Also Send Feedback
Gets or sets the public documents directory.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PublicDocumentsDirectory { get; set; }
Visual Basic (Declaration)
Public Property PublicDocumentsDirectory As String
Visual C++
public:
virtual property String^ PublicDocumentsDirectory {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IPersistService..::.PublicDocumentsDirectory

Remarks

If null or empty is specified, the directory is set to the default public documents folder.

Setting this property does not fire the PropertyChanged event.

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


PublicNotesDirectory Property

[image]

LinkOne WebView API
FileProvider..::.PublicNotesDirectory Property
FileProvider Class See Also Send Feedback
Gets or sets the directory to store public notes in.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PublicNotesDirectory { get; set; }
Visual Basic (Declaration)
Public Property PublicNotesDirectory As String
Visual C++
public:
virtual property String^ PublicNotesDirectory {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IPersistService..::.PublicNotesDirectory

Remarks

If null or empty is specified, the directory is set to the default location off the public documents folder.

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


SaveNotesAsUnicode Property

[image]

LinkOne WebView API
FileProvider..::.SaveNotesAsUnicode Property
FileProvider Class See Also Send Feedback
Gets or sets a boolean indicating if notes to be saved as Unicode.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool SaveNotesAsUnicode { get; set; }
Visual Basic (Declaration)
Public Property SaveNotesAsUnicode As Boolean
Visual C++
public:
property bool SaveNotesAsUnicode {
    bool get ();
    void set (bool value);
}

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


UseDefaultCredentials Property

[image]

LinkOne WebView API
FileProvider..::.UseDefaultCredentials Property
FileProvider Class See Also Send Feedback
Gets or sets a value indicating whether to use default download credentials.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool UseDefaultCredentials { get; set; }
Visual Basic (Declaration)
Public Property UseDefaultCredentials As Boolean
Visual C++
public:
property bool UseDefaultCredentials {
    bool get ();
    void set (bool value);
}

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


UseDefaultProxyCredentials Property

[image]

LinkOne WebView API
FileProvider..::.UseDefaultProxyCredentials Property
FileProvider Class See Also Send Feedback
Gets or sets a value indicating whether to use default proxy credentials.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool UseDefaultProxyCredentials { get; set; }
Visual Basic (Declaration)
Public Property UseDefaultProxyCredentials As Boolean
Visual C++
public:
property bool UseDefaultProxyCredentials {
    bool get ();
    void set (bool value);
}

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


UserName Property

[image]

LinkOne WebView API
FileProvider..::.UserName Property
FileProvider Class See Also Send Feedback
Gets or sets the download user name.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string UserName { get; set; }
Visual Basic (Declaration)
Public Property UserName As String
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


UseUnicodeListings Property

[image]

LinkOne WebView API
FileProvider..::.UseUnicodeListings Property
FileProvider Class See Also Send Feedback
Gets or sets a value indicating whether or not to use Unicode listings for publishers and books.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool UseUnicodeListings { get; set; }
Visual Basic (Declaration)
Public Property UseUnicodeListings As Boolean
Visual C++
public:
property bool UseUnicodeListings {
    bool get ();
    void set (bool value);
}

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


ViewerVersion Property

[image]

LinkOne WebView API
FileProvider..::.ViewerVersion Property
FileProvider Class See Also Send Feedback
Made public as seems to need to be set for License check by Library Indexer.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string ViewerVersion { get; set; }
Visual Basic (Declaration)
Public Property ViewerVersion As String
Visual C++
public:
property String^ ViewerVersion {
    String^ get ();
    void set (String^ value);
}

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


WorkOffline Property

[image]

LinkOne WebView API
FileProvider..::.WorkOffline Property
FileProvider Class See Also Send Feedback
Gets or sets a value indicating whether the provider should access the internet to update Libraries, Publishers and Books.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool WorkOffline { get; set; }
Visual Basic (Declaration)
Public Property WorkOffline As Boolean
Visual C++
public:
virtual property bool WorkOffline {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IPersistService..::.WorkOffline

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


WorkOfflineOnStartup Property

[image]

LinkOne WebView API
FileProvider..::.WorkOfflineOnStartup Property
FileProvider Class See Also Send Feedback

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool WorkOfflineOnStartup { get; set; }
Visual Basic (Declaration)
Public Property WorkOfflineOnStartup As Boolean
Visual C++
public:
property bool WorkOfflineOnStartup {
    bool get ();
    void set (bool value);
}

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


FileProvider Events

[image] [image]

LinkOne WebView API
FileProvider Events
FileProvider Class See Also Send Feedback

The FileProvider type exposes the following members.

Events

Name | Description
CompressProgress | Occurs when the provider is reporting compression progress.
ConfigureBook | Occurs when the provider requests configuration information for a dynamic derived book.
DownloadBegin | Occurs when the provider is reporting a download beginning.
DownloadProgress | Occurs when the provider is reporting download progress.
ExpandProgress | Occurs when the provider is reporting expansion progress.
InstallProgress | Occurs when the provider is reporting install progress.
LibraryChanged | Occurs when the library has changed.
PrepareProgress | Occurs when the provider is reporting prepare progress.
PropertyChanged | Occurs when a property value changes.
SyncProgress | Occurs when the provider is reporting synchronization progress.

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


CompressProgress Event

[image]

LinkOne WebView API
FileProvider..::.CompressProgress Event
FileProvider Class See Also Send Feedback
Occurs when the provider is reporting compression progress.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public event LibraryProgressEventHandler CompressProgress
Visual Basic (Declaration)
Public Event CompressProgress As LibraryProgressEventHandler
Visual C++
public:
virtual  event LibraryProgressEventHandler^ CompressProgress {
    void add (LibraryProgressEventHandler^ value);
    void remove (LibraryProgressEventHandler^ value);
}

Implements

IPersistService..::.CompressProgress

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


ConfigureBook Event

[image]

LinkOne WebView API
FileProvider..::.ConfigureBook Event
FileProvider Class See Also Send Feedback
Occurs when the provider requests configuration information for a dynamic derived book.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public event ConfigureBookEventHandler ConfigureBook
Visual Basic (Declaration)
Public Event ConfigureBook As ConfigureBookEventHandler
Visual C++
public:
virtual  event ConfigureBookEventHandler^ ConfigureBook {
    void add (ConfigureBookEventHandler^ value);
    void remove (ConfigureBookEventHandler^ value);
}

Implements

IPersistService..::.ConfigureBook

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


DownloadBegin Event

[image]

LinkOne WebView API
FileProvider..::.DownloadBegin Event
FileProvider Class See Also Send Feedback
Occurs when the provider is reporting a download beginning.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public event DownloadRequestEventHandler DownloadBegin
Visual Basic (Declaration)
Public Event DownloadBegin As DownloadRequestEventHandler
Visual C++
public:
 event DownloadRequestEventHandler^ DownloadBegin {
    void add (DownloadRequestEventHandler^ value);
    void remove (DownloadRequestEventHandler^ value);
}

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


DownloadProgress Event

[image]

LinkOne WebView API
FileProvider..::.DownloadProgress Event
FileProvider Class See Also Send Feedback
Occurs when the provider is reporting download progress.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public event LibraryProgressEventHandler DownloadProgress
Visual Basic (Declaration)
Public Event DownloadProgress As LibraryProgressEventHandler
Visual C++
public:
virtual  event LibraryProgressEventHandler^ DownloadProgress {
    void add (LibraryProgressEventHandler^ value);
    void remove (LibraryProgressEventHandler^ value);
}

Implements

IPersistService..::.DownloadProgress

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


ExpandProgress Event

[image]

LinkOne WebView API
FileProvider..::.ExpandProgress Event
FileProvider Class See Also Send Feedback
Occurs when the provider is reporting expansion progress.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public event LibraryProgressEventHandler ExpandProgress
Visual Basic (Declaration)
Public Event ExpandProgress As LibraryProgressEventHandler
Visual C++
public:
virtual  event LibraryProgressEventHandler^ ExpandProgress {
    void add (LibraryProgressEventHandler^ value);
    void remove (LibraryProgressEventHandler^ value);
}

Implements

IPersistService..::.ExpandProgress

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


InstallProgress Event

[image]

LinkOne WebView API
FileProvider..::.InstallProgress Event
FileProvider Class See Also Send Feedback
Occurs when the provider is reporting install progress.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public event InstallBooksProgressEventHandler InstallProgress
Visual Basic (Declaration)
Public Event InstallProgress As InstallBooksProgressEventHandler
Visual C++
public:
virtual  event InstallBooksProgressEventHandler^ InstallProgress {
    void add (InstallBooksProgressEventHandler^ value);
    void remove (InstallBooksProgressEventHandler^ value);
}

Implements

IPersistService..::.InstallProgress

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


LibraryChanged Event

[image]

LinkOne WebView API
FileProvider..::.LibraryChanged Event
FileProvider Class See Also Send Feedback
Occurs when the library has changed.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public event EventHandler LibraryChanged
Visual Basic (Declaration)
Public Event LibraryChanged As EventHandler
Visual C++
public:
virtual  event EventHandler^ LibraryChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Implements

IPersistService..::.LibraryChanged

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


PrepareProgress Event

[image]

LinkOne WebView API
FileProvider..::.PrepareProgress Event
FileProvider Class See Also Send Feedback
Occurs when the provider is reporting prepare progress.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public event LibraryProgressEventHandler PrepareProgress
Visual Basic (Declaration)
Public Event PrepareProgress As LibraryProgressEventHandler
Visual C++
public:
virtual  event LibraryProgressEventHandler^ PrepareProgress {
    void add (LibraryProgressEventHandler^ value);
    void remove (LibraryProgressEventHandler^ value);
}

Implements

IPersistService..::.PrepareProgress

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


PropertyChanged Event

[image]

LinkOne WebView API
FileProvider..::.PropertyChanged Event
FileProvider Class See Also Send Feedback
Occurs when a property value changes.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


SyncProgress Event

[image]

LinkOne WebView API
FileProvider..::.SyncProgress Event
FileProvider Class See Also Send Feedback
Occurs when the provider is reporting synchronization progress.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public event LibraryProgressEventHandler SyncProgress
Visual Basic (Declaration)
Public Event SyncProgress As LibraryProgressEventHandler
Visual C++
public:
virtual  event LibraryProgressEventHandler^ SyncProgress {
    void add (LibraryProgressEventHandler^ value);
    void remove (LibraryProgressEventHandler^ value);
}

Implements

IPersistService..::.SyncProgress

See Also

FileProvider Class
Mincom.LinkOne.Provider Namespace


InstallBooksProgressEventArgs Class

[image]

LinkOne WebView API
InstallBooksProgressEventArgs Class
Members See Also Send Feedback
Provides data for book install events.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public sealed class InstallBooksProgressEventArgs : LibraryProgressEventArgs
Visual Basic (Declaration)
Public NotInheritable Class InstallBooksProgressEventArgs _
    Inherits LibraryProgressEventArgs
Visual C++
public ref class InstallBooksProgressEventArgs sealed : public LibraryProgressEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Mincom.LinkOne.Provider..::.LibraryProgressEventArgs
Mincom.LinkOne.Provider..::.InstallBooksProgressEventArgs

See Also

InstallBooksProgressEventArgs Members
Mincom.LinkOne.Provider Namespace


InstallBooksProgressEventArgs Members

[image] [image]

LinkOne WebView API
InstallBooksProgressEventArgs Members
InstallBooksProgressEventArgs Class Constructors Methods Properties See Also Send Feedback

The InstallBooksProgressEventArgs type exposes the following members.

Constructors

Name | Description
InstallBooksProgressEventArgs | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
BookCode | Gets the book code.
BookDescription | Gets the book description.
BookExists | Gets whether this event was caused by attempting to install over an existing book.
Cancel | Gets or sets the flag to cancel the action cauing the event. (Inherited from LibraryProgressEventArgs.)
DestinationLocation | Gets the destination book location.
Exception | Gets the exception causing the event. (Inherited from LibraryProgressEventArgs.)
ProgressPercentage | Gets the progress as a percentage. (Inherited from LibraryProgressEventArgs.)
PublisherCode | Gets the publisher code.
PublisherDescription | Gets the publisher description.
Retry | Gets or sets the flag ot retry after an exception caused event. (Inherited from LibraryProgressEventArgs.)
SourceLocation | Gets the source book location.
Status | Gets the status for the event. (Inherited from LibraryProgressEventArgs.)

See Also

InstallBooksProgressEventArgs Class
Mincom.LinkOne.Provider Namespace


InstallBooksProgressEventArgs Constructor

[image] [image]

LinkOne WebView API
InstallBooksProgressEventArgs Constructor
InstallBooksProgressEventArgs Class See Also Send Feedback

Overload List

Name | Description
InstallBooksProgressEventArgs(Exception) | Initializes a new instance of the InstallBooksProgressEventArgs class.
InstallBooksProgressEventArgs(Int32) | Initializes a new instance of the InstallBooksProgressEventArgs class.
InstallBooksProgressEventArgs(Int32, String, array<Object>[]()[]) | Initializes a new instance of the InstallBooksProgressEventArgs class.
InstallBooksProgressEventArgs(Int32, String, String, String, String, String, String) | Initializes a new instance of the InstallBooksProgressEventArgs class.
InstallBooksProgressEventArgs(Int32, String, String, String, String, String, String, Boolean) | Initializes a new instance of the InstallBooksProgressEventArgs class.

See Also

InstallBooksProgressEventArgs Class
InstallBooksProgressEventArgs Members
Mincom.LinkOne.Provider Namespace


InstallBooksProgressEventArgs Constructor (Exception)

[image]

LinkOne WebView API
InstallBooksProgressEventArgs Constructor (Exception)
InstallBooksProgressEventArgs Class See Also Send Feedback
Initializes a new instance of the InstallBooksProgressEventArgs class.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public InstallBooksProgressEventArgs(
    Exception exception
)
Visual Basic (Declaration)
Public Sub New ( _
    exception As Exception _
)
Visual C++
public:
InstallBooksProgressEventArgs(
    Exception^ exception
)

Parameters

exception
Type: System..::.Exception
The exception.

Remarks

The Cancel property is set true by default.

See Also

InstallBooksProgressEventArgs Class
InstallBooksProgressEventArgs Overload
Mincom.LinkOne.Provider Namespace


InstallBooksProgressEventArgs Constructor (Int32)

[image]

LinkOne WebView API
InstallBooksProgressEventArgs Constructor (Int32)
InstallBooksProgressEventArgs Class See Also Send Feedback
Initializes a new instance of the InstallBooksProgressEventArgs class.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public InstallBooksProgressEventArgs(
    int progressPercentage
)
Visual Basic (Declaration)
Public Sub New ( _
    progressPercentage As Integer _
)
Visual C++
public:
InstallBooksProgressEventArgs(
    int progressPercentage
)

Parameters

progressPercentage
Type: System..::.Int32
A value indicating the progress of the install, as a percentage of 100.

See Also

InstallBooksProgressEventArgs Class
InstallBooksProgressEventArgs Overload
Mincom.LinkOne.Provider Namespace


InstallBooksProgressEventArgs Constructor (Int32, String, Object[])

[image]

LinkOne WebView API
InstallBooksProgressEventArgs Constructor (Int32, String, array<Object>[]()[])
InstallBooksProgressEventArgs Class See Also Send Feedback
Initializes a new instance of the InstallBooksProgressEventArgs class.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public InstallBooksProgressEventArgs(
    int progressPercentage,
    string status,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    progressPercentage As Integer, _
    status As String, _
    ParamArray args As Object() _
)
Visual C++
public:
InstallBooksProgressEventArgs(
    int progressPercentage,
    String^ status,
    ... array<Object^>^ args
)

Parameters

progressPercentage
Type: System..::.Int32
A value indicating the progress of the install, as a percentage of 100.
status
Type: System..::.String
The status.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the status.

See Also

InstallBooksProgressEventArgs Class
InstallBooksProgressEventArgs Overload
Mincom.LinkOne.Provider Namespace


InstallBooksProgressEventArgs Constructor (Int32, String, String, String, String, String, String)

[image]

LinkOne WebView API
InstallBooksProgressEventArgs Constructor (Int32, String, String, String, String, String, String)
InstallBooksProgressEventArgs Class See Also Send Feedback
Initializes a new instance of the InstallBooksProgressEventArgs class.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public InstallBooksProgressEventArgs(
    int progressPercentage,
    string publisherCode,
    string publisherDescription,
    string bookCode,
    string bookDescription,
    string sourceLocation,
    string destinationLocation
)
Visual Basic (Declaration)
Public Sub New ( _
    progressPercentage As Integer, _
    publisherCode As String, _
    publisherDescription As String, _
    bookCode As String, _
    bookDescription As String, _
    sourceLocation As String, _
    destinationLocation As String _
)
Visual C++
public:
InstallBooksProgressEventArgs(
    int progressPercentage,
    String^ publisherCode,
    String^ publisherDescription,
    String^ bookCode,
    String^ bookDescription,
    String^ sourceLocation,
    String^ destinationLocation
)

Parameters

progressPercentage
Type: System..::.Int32
A value indicating the progress of the install, as a percentage of 100.
publisherCode
Type: System..::.String
The publisher code.
publisherDescription
Type: System..::.String
The publisher description.
bookCode
Type: System..::.String
The book code.
bookDescription
Type: System..::.String
The book description.
sourceLocation
Type: System..::.String
The source location.
destinationLocation
Type: System..::.String
The destination location.

See Also

InstallBooksProgressEventArgs Class
InstallBooksProgressEventArgs Overload
Mincom.LinkOne.Provider Namespace


InstallBooksProgressEventArgs Constructor (Int32, String, String, String, String, String, String, Boolean)

[image]

LinkOne WebView API
InstallBooksProgressEventArgs Constructor (Int32, String, String, String, String, String, String, Boolean)
InstallBooksProgressEventArgs Class See Also Send Feedback
Initializes a new instance of the InstallBooksProgressEventArgs class.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public InstallBooksProgressEventArgs(
    int progressPercentage,
    string publisherCode,
    string publisherDescription,
    string bookCode,
    string bookDescription,
    string sourceLocation,
    string destinationLocation,
    bool bookExists
)
Visual Basic (Declaration)
Public Sub New ( _
    progressPercentage As Integer, _
    publisherCode As String, _
    publisherDescription As String, _
    bookCode As String, _
    bookDescription As String, _
    sourceLocation As String, _
    destinationLocation As String, _
    bookExists As Boolean _
)
Visual C++
public:
InstallBooksProgressEventArgs(
    int progressPercentage,
    String^ publisherCode,
    String^ publisherDescription,
    String^ bookCode,
    String^ bookDescription,
    String^ sourceLocation,
    String^ destinationLocation,
    bool bookExists
)

Parameters

progressPercentage
Type: System..::.Int32
A value indicating the progress of the install, as a percentage of 100.
publisherCode
Type: System..::.String
The publisher code.
publisherDescription
Type: System..::.String
The publisher description.
bookCode
Type: System..::.String
The book code.
bookDescription
Type: System..::.String
The book description.
sourceLocation
Type: System..::.String
The source location.
destinationLocation
Type: System..::.String
The destination location.
bookExists
Type: System..::.Boolean
Whether there is already a book in the destination library with the same book code. If this is true, the Cancel property is set true by default.

See Also

InstallBooksProgressEventArgs Class
InstallBooksProgressEventArgs Overload
Mincom.LinkOne.Provider Namespace


InstallBooksProgressEventArgs Methods

[image] [image]

LinkOne WebView API
InstallBooksProgressEventArgs Methods
InstallBooksProgressEventArgs Class See Also Send Feedback

The InstallBooksProgressEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

InstallBooksProgressEventArgs Class
Mincom.LinkOne.Provider Namespace


InstallBooksProgressEventArgs Properties

[image] [image]

LinkOne WebView API
InstallBooksProgressEventArgs Properties
InstallBooksProgressEventArgs Class See Also Send Feedback

The InstallBooksProgressEventArgs type exposes the following members.

Properties

Name | Description
BookCode | Gets the book code.
BookDescription | Gets the book description.
BookExists | Gets whether this event was caused by attempting to install over an existing book.
Cancel | Gets or sets the flag to cancel the action cauing the event. (Inherited from LibraryProgressEventArgs.)
DestinationLocation | Gets the destination book location.
Exception | Gets the exception causing the event. (Inherited from LibraryProgressEventArgs.)
ProgressPercentage | Gets the progress as a percentage. (Inherited from LibraryProgressEventArgs.)
PublisherCode | Gets the publisher code.
PublisherDescription | Gets the publisher description.
Retry | Gets or sets the flag ot retry after an exception caused event. (Inherited from LibraryProgressEventArgs.)
SourceLocation | Gets the source book location.
Status | Gets the status for the event. (Inherited from LibraryProgressEventArgs.)

See Also

InstallBooksProgressEventArgs Class
Mincom.LinkOne.Provider Namespace


BookCode Property

[image]

LinkOne WebView API
InstallBooksProgressEventArgs..::.BookCode Property
InstallBooksProgressEventArgs Class See Also Send Feedback
Gets the book code.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public string BookCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property BookCode As String
Visual C++
public:
property String^ BookCode {
    String^ get ();
}

Field Value

The book code.

See Also

InstallBooksProgressEventArgs Class
Mincom.LinkOne.Provider Namespace


BookDescription Property

[image]

LinkOne WebView API
InstallBooksProgressEventArgs..::.BookDescription Property
InstallBooksProgressEventArgs Class See Also Send Feedback
Gets the book description.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public string BookDescription { get; }
Visual Basic (Declaration)
Public ReadOnly Property BookDescription As String
Visual C++
public:
property String^ BookDescription {
    String^ get ();
}

Field Value

The book description.

See Also

InstallBooksProgressEventArgs Class
Mincom.LinkOne.Provider Namespace


BookExists Property

[image]

LinkOne WebView API
InstallBooksProgressEventArgs..::.BookExists Property
InstallBooksProgressEventArgs Class See Also Send Feedback
Gets whether this event was caused by attempting to install over an existing book.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public bool BookExists { get; }
Visual Basic (Declaration)
Public ReadOnly Property BookExists As Boolean
Visual C++
public:
property bool BookExists {
    bool get ();
}

See Also

InstallBooksProgressEventArgs Class
Mincom.LinkOne.Provider Namespace


DestinationLocation Property

[image]

LinkOne WebView API
InstallBooksProgressEventArgs..::.DestinationLocation Property
InstallBooksProgressEventArgs Class See Also Send Feedback
Gets the destination book location.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public string DestinationLocation { get; }
Visual Basic (Declaration)
Public ReadOnly Property DestinationLocation As String
Visual C++
public:
property String^ DestinationLocation {
    String^ get ();
}

Field Value

The destination book location.

See Also

InstallBooksProgressEventArgs Class
Mincom.LinkOne.Provider Namespace


PublisherCode Property

[image]

LinkOne WebView API
InstallBooksProgressEventArgs..::.PublisherCode Property
InstallBooksProgressEventArgs Class See Also Send Feedback
Gets the publisher code.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public string PublisherCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublisherCode As String
Visual C++
public:
property String^ PublisherCode {
    String^ get ();
}

Field Value

The publisher code.

See Also

InstallBooksProgressEventArgs Class
Mincom.LinkOne.Provider Namespace


PublisherDescription Property

[image]

LinkOne WebView API
InstallBooksProgressEventArgs..::.PublisherDescription Property
InstallBooksProgressEventArgs Class See Also Send Feedback
Gets the publisher description.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public string PublisherDescription { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublisherDescription As String
Visual C++
public:
property String^ PublisherDescription {
    String^ get ();
}

Field Value

The publisher description.

See Also

InstallBooksProgressEventArgs Class
Mincom.LinkOne.Provider Namespace


SourceLocation Property

[image]

LinkOne WebView API
InstallBooksProgressEventArgs..::.SourceLocation Property
InstallBooksProgressEventArgs Class See Also Send Feedback
Gets the source book location.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public string SourceLocation { get; }
Visual Basic (Declaration)
Public ReadOnly Property SourceLocation As String
Visual C++
public:
property String^ SourceLocation {
    String^ get ();
}

Field Value

The source book location.

See Also

InstallBooksProgressEventArgs Class
Mincom.LinkOne.Provider Namespace


InstallBooksProgressEventHandler Delegate

[image]

LinkOne WebView API
InstallBooksProgressEventHandler Delegate
See Also Send Feedback
Represents the method that will handle book installation events.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public delegate void InstallBooksProgressEventHandler(
    Object sender,
    InstallBooksProgressEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub InstallBooksProgressEventHandler ( _
    sender As Object, _
    e As InstallBooksProgressEventArgs _
)
Visual C++
public delegate void InstallBooksProgressEventHandler(
    Object^ sender,
    InstallBooksProgressEventArgs^ e
)

Parameters

sender
Type: System..::.Object
The source of the event.
e
Type: Mincom.LinkOne.Provider..::.InstallBooksProgressEventArgs
The InstallBooksProgressEventArgs instance that contains the event data.

See Also

Mincom.LinkOne.Provider Namespace


IPersistService Interface

[image]

LinkOne WebView API
IPersistService Interface
Members See Also Send Feedback
Implemented by a component to provide books.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public interface IPersistService : IPersistProvider
Visual Basic (Declaration)
Public Interface IPersistService _
    Implements IPersistProvider
Visual C++
public interface class IPersistService : IPersistProvider

See Also

IPersistService Members
Mincom.LinkOne.Provider Namespace


IPersistService Members

[image] [image]

LinkOne WebView API
IPersistService Members
IPersistService Interface Methods Properties Events See Also Send Feedback

The IPersistService type exposes the following members.

Methods

Name | Description
Cancel | Cancels the current call.
GetManager | Overloaded.
Read | Read the wanted object from storage. (Inherited from IPersistProvider.)
ReadIgnoreLangOption | (Inherited from IPersistProvider.)
Refresh | Refresh the wanted object into storage. (Inherited from IPersistProvider.)
SetManager | Sets a new IPersistManager for the provider to use.
Write | Write the given object to storage. (Inherited from IPersistProvider.)

Properties

Name | Description
CodePage | Gets or sets the codepage to parse the libraries in.
LanguageCode | Gets or sets the two letter ISO 639-1 preferred book language code.
PrivateDocumentsDirectory | Gets or sets the private documents directory.
PrivateNotesDirectory | Gets or sets the directory to store private notes in.
PublicDocumentsDirectory | Gets or sets the public documents directory.
PublicNotesDirectory | Gets or sets the directory to store public notes in.
WorkOffline | Gets or sets whether the IBooksProvider can access the internet to download books.

Events

Name | Description
CompressProgress | Occurs when the provider is reporting compression progress.
ConfigureBook | Occurs when the provider requests configuration information for a dynamic derived book.
DownloadProgress | Occurs when the provider is reporting download progress.
ExpandProgress | Occurs when the provider is reporting expansion progress.
InstallProgress | Occurs when the provider is reporting installation progress.
LibraryChanged | Occurs when the library has changed.
PrepareProgress | Occurs when the provider is reporting preparation progress.
SyncProgress | Occurs when the provider is reporting synchronization progress.

See Also

IPersistService Interface
Mincom.LinkOne.Provider Namespace


IPersistService Methods

[image] [image]

LinkOne WebView API
IPersistService Methods
IPersistService Interface See Also Send Feedback

The IPersistService type exposes the following members.

Methods

Name | Description
Cancel | Cancels the current call.
GetManager | Overloaded.
Read | Read the wanted object from storage. (Inherited from IPersistProvider.)
ReadIgnoreLangOption | (Inherited from IPersistProvider.)
Refresh | Refresh the wanted object into storage. (Inherited from IPersistProvider.)
SetManager | Sets a new IPersistManager for the provider to use.
Write | Write the given object to storage. (Inherited from IPersistProvider.)

See Also

IPersistService Interface
Mincom.LinkOne.Provider Namespace


Cancel Method

[image]

LinkOne WebView API
IPersistService..::.Cancel Method
IPersistService Interface See Also Send Feedback
Cancels the current call.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
void Cancel()
Visual Basic (Declaration)
Sub Cancel
Visual C++
void Cancel()

See Also

IPersistService Interface
Mincom.LinkOne.Provider Namespace


GetManager Method

[image] [image]

LinkOne WebView API
IPersistService..::.GetManager Method
IPersistService Interface See Also Send Feedback

Overload List

Name | Description
GetManager()()() | Returns a new instance of an IPersistManager with the provider's libraries.
GetManager(array<String>[]()[]) | Returns a new instance of an IPersistManager for the given libraries.

See Also

IPersistService Interface
IPersistService Members
Mincom.LinkOne.Provider Namespace


GetManager Method

[image]

LinkOne WebView API
IPersistService..::.GetManager Method
IPersistService Interface See Also Send Feedback
Returns a new instance of an IPersistManager with the provider's libraries.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
IPersistManager GetManager()
Visual Basic (Declaration)
Function GetManager As IPersistManager
Visual C++
IPersistManager^ GetManager()

Return Value

A new instance of an IPersistManager with the provider's libraries.

See Also

IPersistService Interface
GetManager Overload
Mincom.LinkOne.Provider Namespace


GetManager Method (String[])

[image]

LinkOne WebView API
IPersistService..::.GetManager Method (array<String>[]()[])
IPersistService Interface See Also Send Feedback
Returns a new instance of an IPersistManager for the given libraries.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
IPersistManager GetManager(
    params string[] libraryDirectories
)
Visual Basic (Declaration)
Function GetManager ( _
    ParamArray libraryDirectories As String() _
) As IPersistManager
Visual C++
IPersistManager^ GetManager(
    ... array<String^>^ libraryDirectories
)

Parameters

libraryDirectories
Type: array< System..::.String >[]()[]
The library directories for the new manager.

Return Value

A new instance of an IPersistManager.

See Also

IPersistService Interface
GetManager Overload
Mincom.LinkOne.Provider Namespace


SetManager Method

[image]

LinkOne WebView API
IPersistService..::.SetManager Method
IPersistService Interface See Also Send Feedback
Sets a new IPersistManager for the provider to use.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
void SetManager(
    IPersistManager manager
)
Visual Basic (Declaration)
Sub SetManager ( _
    manager As IPersistManager _
)
Visual C++
void SetManager(
    IPersistManager^ manager
)

Parameters

manager
Type: Mincom.LinkOne.Provider.Persist..::.IPersistManager
The manager to set onto the IBooksProvider.

See Also

IPersistService Interface
Mincom.LinkOne.Provider Namespace


IPersistService Properties

[image] [image]

LinkOne WebView API
IPersistService Properties
IPersistService Interface See Also Send Feedback

The IPersistService type exposes the following members.

Properties

Name | Description
CodePage | Gets or sets the codepage to parse the libraries in.
LanguageCode | Gets or sets the two letter ISO 639-1 preferred book language code.
PrivateDocumentsDirectory | Gets or sets the private documents directory.
PrivateNotesDirectory | Gets or sets the directory to store private notes in.
PublicDocumentsDirectory | Gets or sets the public documents directory.
PublicNotesDirectory | Gets or sets the directory to store public notes in.
WorkOffline | Gets or sets whether the IBooksProvider can access the internet to download books.

See Also

IPersistService Interface
Mincom.LinkOne.Provider Namespace


CodePage Property

[image]

LinkOne WebView API
IPersistService..::.CodePage Property
IPersistService Interface See Also Send Feedback
Gets or sets the codepage to parse the libraries in.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
int CodePage { get; set; }
Visual Basic (Declaration)
Property CodePage As Integer
Visual C++
property int CodePage {
    int get ();
    void set (int value);
}

See Also

IPersistService Interface
Mincom.LinkOne.Provider Namespace


LanguageCode Property

[image]

LinkOne WebView API
IPersistService..::.LanguageCode Property
IPersistService Interface See Also Send Feedback
Gets or sets the two letter ISO 639-1 preferred book language code.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
string LanguageCode { get; set; }
Visual Basic (Declaration)
Property LanguageCode As String
Visual C++
property String^ LanguageCode {
    String^ get ();
    void set (String^ value);
}

See Also

IPersistService Interface
Mincom.LinkOne.Provider Namespace


PrivateDocumentsDirectory Property

[image]

LinkOne WebView API
IPersistService..::.PrivateDocumentsDirectory Property
IPersistService Interface See Also Send Feedback
Gets or sets the private documents directory.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
string PrivateDocumentsDirectory { get; set; }
Visual Basic (Declaration)
Property PrivateDocumentsDirectory As String
Visual C++
property String^ PrivateDocumentsDirectory {
    String^ get ();
    void set (String^ value);
}

See Also

IPersistService Interface
Mincom.LinkOne.Provider Namespace


PrivateNotesDirectory Property

[image]

LinkOne WebView API
IPersistService..::.PrivateNotesDirectory Property
IPersistService Interface See Also Send Feedback
Gets or sets the directory to store private notes in.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
string PrivateNotesDirectory { get; set; }
Visual Basic (Declaration)
Property PrivateNotesDirectory As String
Visual C++
property String^ PrivateNotesDirectory {
    String^ get ();
    void set (String^ value);
}

See Also

IPersistService Interface
Mincom.LinkOne.Provider Namespace


PublicDocumentsDirectory Property

[image]

LinkOne WebView API
IPersistService..::.PublicDocumentsDirectory Property
IPersistService Interface See Also Send Feedback
Gets or sets the public documents directory.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
string PublicDocumentsDirectory { get; set; }
Visual Basic (Declaration)
Property PublicDocumentsDirectory As String
Visual C++
property String^ PublicDocumentsDirectory {
    String^ get ();
    void set (String^ value);
}

See Also

IPersistService Interface
Mincom.LinkOne.Provider Namespace


PublicNotesDirectory Property

[image]

LinkOne WebView API
IPersistService..::.PublicNotesDirectory Property
IPersistService Interface See Also Send Feedback
Gets or sets the directory to store public notes in.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
string PublicNotesDirectory { get; set; }
Visual Basic (Declaration)
Property PublicNotesDirectory As String
Visual C++
property String^ PublicNotesDirectory {
    String^ get ();
    void set (String^ value);
}

See Also

IPersistService Interface
Mincom.LinkOne.Provider Namespace


WorkOffline Property

[image]

LinkOne WebView API
IPersistService..::.WorkOffline Property
IPersistService Interface See Also Send Feedback
Gets or sets whether the IBooksProvider can access the internet to download books.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool WorkOffline { get; set; }
Visual Basic (Declaration)
Property WorkOffline As Boolean
Visual C++
property bool WorkOffline {
    bool get ();
    void set (bool value);
}

See Also

IPersistService Interface
Mincom.LinkOne.Provider Namespace


IPersistService Events

[image] [image]

LinkOne WebView API
IPersistService Events
IPersistService Interface See Also Send Feedback

The IPersistService type exposes the following members.

Events

Name | Description
CompressProgress | Occurs when the provider is reporting compression progress.
ConfigureBook | Occurs when the provider requests configuration information for a dynamic derived book.
DownloadProgress | Occurs when the provider is reporting download progress.
ExpandProgress | Occurs when the provider is reporting expansion progress.
InstallProgress | Occurs when the provider is reporting installation progress.
LibraryChanged | Occurs when the library has changed.
PrepareProgress | Occurs when the provider is reporting preparation progress.
SyncProgress | Occurs when the provider is reporting synchronization progress.

See Also

IPersistService Interface
Mincom.LinkOne.Provider Namespace


CompressProgress Event

[image]

LinkOne WebView API
IPersistService..::.CompressProgress Event
IPersistService Interface See Also Send Feedback
Occurs when the provider is reporting compression progress.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
event LibraryProgressEventHandler CompressProgress
Visual Basic (Declaration)
Event CompressProgress As LibraryProgressEventHandler
Visual C++
 event LibraryProgressEventHandler^ CompressProgress {
    void add (LibraryProgressEventHandler^ value);
    void remove (LibraryProgressEventHandler^ value);
}

See Also

IPersistService Interface
Mincom.LinkOne.Provider Namespace


ConfigureBook Event

[image]

LinkOne WebView API
IPersistService..::.ConfigureBook Event
IPersistService Interface See Also Send Feedback
Occurs when the provider requests configuration information for a dynamic derived book.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
event ConfigureBookEventHandler ConfigureBook
Visual Basic (Declaration)
Event ConfigureBook As ConfigureBookEventHandler
Visual C++
 event ConfigureBookEventHandler^ ConfigureBook {
    void add (ConfigureBookEventHandler^ value);
    void remove (ConfigureBookEventHandler^ value);
}

See Also

IPersistService Interface
Mincom.LinkOne.Provider Namespace


DownloadProgress Event

[image]

LinkOne WebView API
IPersistService..::.DownloadProgress Event
IPersistService Interface See Also Send Feedback
Occurs when the provider is reporting download progress.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
event LibraryProgressEventHandler DownloadProgress
Visual Basic (Declaration)
Event DownloadProgress As LibraryProgressEventHandler
Visual C++
 event LibraryProgressEventHandler^ DownloadProgress {
    void add (LibraryProgressEventHandler^ value);
    void remove (LibraryProgressEventHandler^ value);
}

See Also

IPersistService Interface
Mincom.LinkOne.Provider Namespace


ExpandProgress Event

[image]

LinkOne WebView API
IPersistService..::.ExpandProgress Event
IPersistService Interface See Also Send Feedback
Occurs when the provider is reporting expansion progress.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
event LibraryProgressEventHandler ExpandProgress
Visual Basic (Declaration)
Event ExpandProgress As LibraryProgressEventHandler
Visual C++
 event LibraryProgressEventHandler^ ExpandProgress {
    void add (LibraryProgressEventHandler^ value);
    void remove (LibraryProgressEventHandler^ value);
}

See Also

IPersistService Interface
Mincom.LinkOne.Provider Namespace


InstallProgress Event

[image]

LinkOne WebView API
IPersistService..::.InstallProgress Event
IPersistService Interface See Also Send Feedback
Occurs when the provider is reporting installation progress.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
event InstallBooksProgressEventHandler InstallProgress
Visual Basic (Declaration)
Event InstallProgress As InstallBooksProgressEventHandler
Visual C++
 event InstallBooksProgressEventHandler^ InstallProgress {
    void add (InstallBooksProgressEventHandler^ value);
    void remove (InstallBooksProgressEventHandler^ value);
}

See Also

IPersistService Interface
Mincom.LinkOne.Provider Namespace


LibraryChanged Event

[image]

LinkOne WebView API
IPersistService..::.LibraryChanged Event
IPersistService Interface See Also Send Feedback
Occurs when the library has changed.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
event EventHandler LibraryChanged
Visual Basic (Declaration)
Event LibraryChanged As EventHandler
Visual C++
 event EventHandler^ LibraryChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

IPersistService Interface
Mincom.LinkOne.Provider Namespace


PrepareProgress Event

[image]

LinkOne WebView API
IPersistService..::.PrepareProgress Event
IPersistService Interface See Also Send Feedback
Occurs when the provider is reporting preparation progress.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
event LibraryProgressEventHandler PrepareProgress
Visual Basic (Declaration)
Event PrepareProgress As LibraryProgressEventHandler
Visual C++
 event LibraryProgressEventHandler^ PrepareProgress {
    void add (LibraryProgressEventHandler^ value);
    void remove (LibraryProgressEventHandler^ value);
}

See Also

IPersistService Interface
Mincom.LinkOne.Provider Namespace


SyncProgress Event

[image]

LinkOne WebView API
IPersistService..::.SyncProgress Event
IPersistService Interface See Also Send Feedback
Occurs when the provider is reporting synchronization progress.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
event LibraryProgressEventHandler SyncProgress
Visual Basic (Declaration)
Event SyncProgress As LibraryProgressEventHandler
Visual C++
 event LibraryProgressEventHandler^ SyncProgress {
    void add (LibraryProgressEventHandler^ value);
    void remove (LibraryProgressEventHandler^ value);
}

See Also

IPersistService Interface
Mincom.LinkOne.Provider Namespace


LibraryProgressEventArgs Class

[image]

LinkOne WebView API
LibraryProgressEventArgs Class
Members See Also Send Feedback
Provides data for the library progress events.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public class LibraryProgressEventArgs : EventArgs
Visual Basic (Declaration)
Public Class LibraryProgressEventArgs _
    Inherits EventArgs
Visual C++
public ref class LibraryProgressEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Mincom.LinkOne.Provider..::.LibraryProgressEventArgs
Mincom.LinkOne.Provider..::.InstallBooksProgressEventArgs

See Also

LibraryProgressEventArgs Members
Mincom.LinkOne.Provider Namespace


LibraryProgressEventArgs Members

[image] [image]

LinkOne WebView API
LibraryProgressEventArgs Members
LibraryProgressEventArgs Class Constructors Methods Properties See Also Send Feedback

The LibraryProgressEventArgs type exposes the following members.

Constructors

Name | Description
LibraryProgressEventArgs | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Cancel | Gets or sets the flag to cancel the action cauing the event.
Exception | Gets the exception causing the event.
ProgressPercentage | Gets the progress as a percentage.
Retry | Gets or sets the flag ot retry after an exception caused event.
Status | Gets the status for the event.

See Also

LibraryProgressEventArgs Class
Mincom.LinkOne.Provider Namespace


LibraryProgressEventArgs Constructor

[image] [image]

LinkOne WebView API
LibraryProgressEventArgs Constructor
LibraryProgressEventArgs Class See Also Send Feedback

Overload List

Name | Description
LibraryProgressEventArgs(Exception) | Initializes a new instance of the LibraryProgressEventArgs class.
LibraryProgressEventArgs(Int32) | Initializes a new instance of the LibraryProgressEventArgs class.
LibraryProgressEventArgs(Exception, String) | Initializes a new instance of the LibraryProgressEventArgs class.
LibraryProgressEventArgs(String, array<Object>[]()[]) | Initializes a new instance of the LibraryProgressEventArgs class.
LibraryProgressEventArgs(Int32, String, array<Object>[]()[]) | Initializes a new instance of the LibraryProgressEventArgs class.

See Also

LibraryProgressEventArgs Class
LibraryProgressEventArgs Members
Mincom.LinkOne.Provider Namespace


LibraryProgressEventArgs Constructor (Exception)

[image]

LinkOne WebView API
LibraryProgressEventArgs Constructor (Exception)
LibraryProgressEventArgs Class See Also Send Feedback
Initializes a new instance of the LibraryProgressEventArgs class.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public LibraryProgressEventArgs(
    Exception exception
)
Visual Basic (Declaration)
Public Sub New ( _
    exception As Exception _
)
Visual C++
public:
LibraryProgressEventArgs(
    Exception^ exception
)

Parameters

exception
Type: System..::.Exception
The exception.

Remarks

The Cancel property is set true by default.

See Also

LibraryProgressEventArgs Class
LibraryProgressEventArgs Overload
Mincom.LinkOne.Provider Namespace


LibraryProgressEventArgs Constructor (Int32)

[image]

LinkOne WebView API
LibraryProgressEventArgs Constructor (Int32)
LibraryProgressEventArgs Class See Also Send Feedback
Initializes a new instance of the LibraryProgressEventArgs class.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public LibraryProgressEventArgs(
    int progressPercentage
)
Visual Basic (Declaration)
Public Sub New ( _
    progressPercentage As Integer _
)
Visual C++
public:
LibraryProgressEventArgs(
    int progressPercentage
)

Parameters

progressPercentage
Type: System..::.Int32
A value indicating the progress of the install, as a percentage of 100.

See Also

LibraryProgressEventArgs Class
LibraryProgressEventArgs Overload
Mincom.LinkOne.Provider Namespace


LibraryProgressEventArgs Constructor (Exception, String)

[image]

LinkOne WebView API
LibraryProgressEventArgs Constructor (Exception, String)
LibraryProgressEventArgs Class See Also Send Feedback
Initializes a new instance of the LibraryProgressEventArgs class.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public LibraryProgressEventArgs(
    Exception exception,
    string status
)
Visual Basic (Declaration)
Public Sub New ( _
    exception As Exception, _
    status As String _
)
Visual C++
public:
LibraryProgressEventArgs(
    Exception^ exception,
    String^ status
)

Parameters

exception
Type: System..::.Exception
The exception.
status
Type: System..::.String
The status.

Remarks

The Cancel property is set true by default.

See Also

LibraryProgressEventArgs Class
LibraryProgressEventArgs Overload
Mincom.LinkOne.Provider Namespace


LibraryProgressEventArgs Constructor (String, Object[])

[image]

LinkOne WebView API
LibraryProgressEventArgs Constructor (String, array<Object>[]()[])
LibraryProgressEventArgs Class See Also Send Feedback
Initializes a new instance of the LibraryProgressEventArgs class.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public LibraryProgressEventArgs(
    string status,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    status As String, _
    ParamArray args As Object() _
)
Visual C++
public:
LibraryProgressEventArgs(
    String^ status,
    ... array<Object^>^ args
)

Parameters

status
Type: System..::.String
The status.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the status.

See Also

LibraryProgressEventArgs Class
LibraryProgressEventArgs Overload
Mincom.LinkOne.Provider Namespace


LibraryProgressEventArgs Constructor (Int32, String, Object[])

[image]

LinkOne WebView API
LibraryProgressEventArgs Constructor (Int32, String, array<Object>[]()[])
LibraryProgressEventArgs Class See Also Send Feedback
Initializes a new instance of the LibraryProgressEventArgs class.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public LibraryProgressEventArgs(
    int progressPercentage,
    string status,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    progressPercentage As Integer, _
    status As String, _
    ParamArray args As Object() _
)
Visual C++
public:
LibraryProgressEventArgs(
    int progressPercentage,
    String^ status,
    ... array<Object^>^ args
)

Parameters

progressPercentage
Type: System..::.Int32
A value indicating the progress of the install, as a percentage of 100.
status
Type: System..::.String
The status.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the status.

See Also

LibraryProgressEventArgs Class
LibraryProgressEventArgs Overload
Mincom.LinkOne.Provider Namespace


LibraryProgressEventArgs Methods

[image] [image]

LinkOne WebView API
LibraryProgressEventArgs Methods
LibraryProgressEventArgs Class See Also Send Feedback

The LibraryProgressEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LibraryProgressEventArgs Class
Mincom.LinkOne.Provider Namespace


LibraryProgressEventArgs Properties

[image] [image]

LinkOne WebView API
LibraryProgressEventArgs Properties
LibraryProgressEventArgs Class See Also Send Feedback

The LibraryProgressEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Gets or sets the flag to cancel the action cauing the event.
Exception | Gets the exception causing the event.
ProgressPercentage | Gets the progress as a percentage.
Retry | Gets or sets the flag ot retry after an exception caused event.
Status | Gets the status for the event.

See Also

LibraryProgressEventArgs Class
Mincom.LinkOne.Provider Namespace


Cancel Property

[image]

LinkOne WebView API
LibraryProgressEventArgs..::.Cancel Property
LibraryProgressEventArgs Class See Also Send Feedback
Gets or sets the flag to cancel the action cauing the event.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public bool Cancel { get; set; }
Visual Basic (Declaration)
Public Property Cancel As Boolean
Visual C++
public:
property bool Cancel {
    bool get ();
    void set (bool value);
}

See Also

LibraryProgressEventArgs Class
Mincom.LinkOne.Provider Namespace


Exception Property

[image]

LinkOne WebView API
LibraryProgressEventArgs..::.Exception Property
LibraryProgressEventArgs Class See Also Send Feedback
Gets the exception causing the event.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public Exception Exception { get; }
Visual Basic (Declaration)
Public ReadOnly Property Exception As Exception
Visual C++
public:
property Exception^ Exception {
    Exception^ get ();
}

See Also

LibraryProgressEventArgs Class
Mincom.LinkOne.Provider Namespace


ProgressPercentage Property

[image]

LinkOne WebView API
LibraryProgressEventArgs..::.ProgressPercentage Property
LibraryProgressEventArgs Class See Also Send Feedback
Gets the progress as a percentage.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public int ProgressPercentage { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProgressPercentage As Integer
Visual C++
public:
property int ProgressPercentage {
    int get ();
}

See Also

LibraryProgressEventArgs Class
Mincom.LinkOne.Provider Namespace


Retry Property

[image]

LinkOne WebView API
LibraryProgressEventArgs..::.Retry Property
LibraryProgressEventArgs Class See Also Send Feedback
Gets or sets the flag ot retry after an exception caused event.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public bool Retry { get; set; }
Visual Basic (Declaration)
Public Property Retry As Boolean
Visual C++
public:
property bool Retry {
    bool get ();
    void set (bool value);
}

See Also

LibraryProgressEventArgs Class
Mincom.LinkOne.Provider Namespace


Status Property

[image]

LinkOne WebView API
LibraryProgressEventArgs..::.Status Property
LibraryProgressEventArgs Class See Also Send Feedback
Gets the status for the event.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public string Status { get; }
Visual Basic (Declaration)
Public ReadOnly Property Status As String
Visual C++
public:
property String^ Status {
    String^ get ();
}

See Also

LibraryProgressEventArgs Class
Mincom.LinkOne.Provider Namespace


LibraryProgressEventHandler Delegate

[image]

LinkOne WebView API
LibraryProgressEventHandler Delegate
See Also Send Feedback
Represents the method that will handle library progress events.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public delegate void LibraryProgressEventHandler(
    Object sender,
    LibraryProgressEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub LibraryProgressEventHandler ( _
    sender As Object, _
    e As LibraryProgressEventArgs _
)
Visual C++
public delegate void LibraryProgressEventHandler(
    Object^ sender,
    LibraryProgressEventArgs^ e
)

Parameters

sender
Type: System..::.Object
e
Type: Mincom.LinkOne.Provider..::.LibraryProgressEventArgs

See Also

Mincom.LinkOne.Provider Namespace


Tracing Class

[image]

LinkOne WebView API
Tracing Class
Members See Also Send Feedback
Trace switch for the assembly.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static class Tracing
Visual Basic (Declaration)
Public NotInheritable Class Tracing
Visual C++
public ref class Tracing abstract sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Provider..::.Tracing

See Also

Tracing Members
Mincom.LinkOne.Provider Namespace


Tracing Members

[image] [image]

LinkOne WebView API
Tracing Members
Tracing Class Fields See Also Send Feedback

The Tracing type exposes the following members.

Fields

Name | Description
TraceSwitch | Trace switch for the assembly.

See Also

Tracing Class
Mincom.LinkOne.Provider Namespace


Tracing Fields

[image] [image]

LinkOne WebView API
Tracing Fields
Tracing Class See Also Send Feedback

The Tracing type exposes the following members.

Fields

Name | Description
TraceSwitch | Trace switch for the assembly.

See Also

Tracing Class
Mincom.LinkOne.Provider Namespace


TraceSwitch Field

[image]

LinkOne WebView API
Tracing..::.TraceSwitch Field
Tracing Class See Also Send Feedback
Trace switch for the assembly.

Namespace: Mincom.LinkOne.Provider
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static readonly TraceSwitch TraceSwitch
Visual Basic (Declaration)
Public Shared ReadOnly TraceSwitch As TraceSwitch
Visual C++
public:
static initonly TraceSwitch^ TraceSwitch

Remarks

Enable by:
CopyC#
<configuration>
    <system.diagnostics>
        <switches>
            <add name="Mincom.LinkOne.Provider" value="Info"/>
        <switches/>
    <system.diagnostics/>
<configuration/>

See Also

Tracing Class
Mincom.LinkOne.Provider Namespace


Mincom.LinkOne.Provider.Persist Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.Provider.Persist Namespace
Send Feedback
The Mincom.LinkOne.Provider.Persist namespace contains classes that provide persistence management.

Classes

Class | Description
Book | Represents a book in a Publisher()()().
BookCollection | Represents a collection of Book objects.
Catalog | Represents a catalog of books and book categories in a publisher.
Category | Represents a book category.
CategoryBookCollection | Represents a collection of books in a category.
CategoryCollection | Represents a collection of Category objects.
Library | Represents a libray of LinkOne Publishers.
LibraryCollection | Represents a collection of Library objects.
Manager | Represents the manager of Library objects.
Publisher | Represents a Publisher in a Library()()().
PublisherCollection | Represents a collection of Publisher objects.

Interfaces

Interface | Description
IPersistBook | Implemented by a class to manage book persistence.
IPersistBookCollection | Implemented by a class to manage book collection persistence.
IPersistCatalog | Implemented by a class to manage catalog persistence.
IPersistCategory | Implemented by a class to manage category persistence.
IPersistCategoryCollection | Implemented by a class to manage category collection persistence.
IPersistLibrary | Implemented by a class to manage library persistence.
IPersistLibraryCollection | Implemented by a class to manage library collection persistence.
IPersistManager | Implemented by a class to manage persistence.
IPersistPublisher | Implemented by a class to manage publisher persistence.
IPersistPublisherCollection | Implemented by a class to manage publisher collection persistence.

Enumerations

Enumeration | Description
LibraryType | Represents the type of Library.
ReportingLevel | The reporting level detail.
SyncType | Represents the types of Library synchronization.


Book Class

[image]

LinkOne WebView API
Book Class
Members See Also Send Feedback
Represents a book in a Publisher()()().

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public sealed class Book : IPersistBook
Visual Basic (Declaration)
Public NotInheritable Class Book _
    Implements IPersistBook
Visual C++
public ref class Book sealed : IPersistBook

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Provider.Persist..::.Book

See Also

Book Members
Mincom.LinkOne.Provider.Persist Namespace


Book Members

[image] [image]

LinkOne WebView API
Book Members
Book Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The Book type exposes the following members.

Methods

Name | Description
Compress | Compresses the book into a single file book.
CreateAliasBook | Creates a new alias book with the given book code and book description. The current book is used as the master book.
DownloadBBI |
DownloadBBIorSFB |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Expand | Expands a single file book into seperate files.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBookVersion | Returns book version string from .bbi file or the .sfb file
GetBookVersionNumber | Returns book version number from .bbi file or the .sfb file
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Prepare | Prepares the book for internet delivery.
Remove | Removes the book from the filing system.
Sync | Synchronizes the book from any configured synchronization location.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
BookCode | Gets the book code for the book.
BookDescription | Gets the book description for the book.
BookDescriptionTranslations | Gets the description translations for this book.
CategoryCodes | Gets the a list of category codes for the book.
IsSingleFileBook | Gets true if the manifest belongs to a single file book.
Location | Gets the book location.
PublisherCode | Gets the book publisher code.
PublisherDescription | Gets the book publisher description.
Version | Gets the book version string for the book. NB: major.minor.patch style
VersionNumber | Gets the internal book version number for the book. NB: 0 to whatever, NOT major.minor.patch style

Explicit Interface Implementations

Name | Description
IPersistBook..::.BookDescriptionTranslations | Gets the book description translations.
IPersistBook..::.Publisher | Gets the publisher.

See Also

Book Class
Mincom.LinkOne.Provider.Persist Namespace


Book Methods

[image] [image]

LinkOne WebView API
Book Methods
Book Class See Also Send Feedback

The Book type exposes the following members.

Methods

Name | Description
Compress | Compresses the book into a single file book.
CreateAliasBook | Creates a new alias book with the given book code and book description. The current book is used as the master book.
DownloadBBI |
DownloadBBIorSFB |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Expand | Expands a single file book into seperate files.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBookVersion | Returns book version string from .bbi file or the .sfb file
GetBookVersionNumber | Returns book version number from .bbi file or the .sfb file
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Prepare | Prepares the book for internet delivery.
Remove | Removes the book from the filing system.
Sync | Synchronizes the book from any configured synchronization location.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Book Class
Mincom.LinkOne.Provider.Persist Namespace


Compress Method

[image]

LinkOne WebView API
Book..::.Compress Method
Book Class See Also Send Feedback
Compresses the book into a single file book.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Compress()
Visual Basic (Declaration)
Public Function Compress As Boolean
Visual C++
public:
virtual bool Compress() sealed

Return Value

true if successful, or false if an error or if cancelled.

Implements

IPersistBook..::.Compress()()()

See Also

Book Class
Mincom.LinkOne.Provider.Persist Namespace


CreateAliasBook Method

[image]

LinkOne WebView API
Book..::.CreateAliasBook Method
Book Class See Also Send Feedback
Creates a new alias book with the given book code and book description. The current book is used as the master book.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void CreateAliasBook(
    string bookCode,
    string bookDescription,
    string location
)
Visual Basic (Declaration)
Public Sub CreateAliasBook ( _
    bookCode As String, _
    bookDescription As String, _
    location As String _
)
Visual C++
public:
virtual void CreateAliasBook(
    String^ bookCode,
    String^ bookDescription,
    String^ location
) sealed

Parameters

bookCode
Type: System..::.String
The book code to be used for the new alias book
bookDescription
Type: System..::.String
The book description to be used for the new alias book
location
Type: System..::.String
The location of the library where the book will be created.

Implements

IPersistBook..::.CreateAliasBook(String, String, String)

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurs.

See Also

Book Class
Mincom.LinkOne.Provider.Persist Namespace


DownloadBBI Method

[image]

LinkOne WebView API
Book..::.DownloadBBI Method
Book Class See Also Send Feedback

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool DownloadBBI(
    string location,
    out string bookFilePath
)
Visual Basic (Declaration)
Public Function DownloadBBI ( _
    location As String, _
    <OutAttribute> ByRef bookFilePath As String _
) As Boolean
Visual C++
public:
bool DownloadBBI(
    String^ location,
    [OutAttribute] String^% bookFilePath
)

Parameters

location
Type: System..::.String
bookFilePath
Type: System..::.String %

See Also

Book Class
Mincom.LinkOne.Provider.Persist Namespace


DownloadBBIorSFB Method

[image]

LinkOne WebView API
Book..::.DownloadBBIorSFB Method
Book Class See Also Send Feedback

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool DownloadBBIorSFB(
    string location,
    out string bookFilePath
)
Visual Basic (Declaration)
Public Function DownloadBBIorSFB ( _
    location As String, _
    <OutAttribute> ByRef bookFilePath As String _
) As Boolean
Visual C++
public:
bool DownloadBBIorSFB(
    String^ location,
    [OutAttribute] String^% bookFilePath
)

Parameters

location
Type: System..::.String
bookFilePath
Type: System..::.String %

See Also

Book Class
Mincom.LinkOne.Provider.Persist Namespace


Expand Method

[image]

LinkOne WebView API
Book..::.Expand Method
Book Class See Also Send Feedback
Expands a single file book into seperate files.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Expand()
Visual Basic (Declaration)
Public Function Expand As Boolean
Visual C++
public:
virtual bool Expand() sealed

Return Value

true if successful, or false if an error or if cancelled.

Implements

IPersistBook..::.Expand()()()

See Also

Book Class
Mincom.LinkOne.Provider.Persist Namespace


GetBookVersion Method

[image]

LinkOne WebView API
Book..::.GetBookVersion Method
Book Class See Also Send Feedback
Returns book version string from .bbi file or the .sfb file

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string GetBookVersion()
Visual Basic (Declaration)
Public Function GetBookVersion As String
Visual C++
public:
String^ GetBookVersion()

See Also

Book Class
Mincom.LinkOne.Provider.Persist Namespace


GetBookVersionNumber Method

[image]

LinkOne WebView API
Book..::.GetBookVersionNumber Method
Book Class See Also Send Feedback
Returns book version number from .bbi file or the .sfb file

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int GetBookVersionNumber()
Visual Basic (Declaration)
Public Function GetBookVersionNumber As Integer
Visual C++
public:
int GetBookVersionNumber()

See Also

Book Class
Mincom.LinkOne.Provider.Persist Namespace


Prepare Method

[image]

LinkOne WebView API
Book..::.Prepare Method
Book Class See Also Send Feedback
Prepares the book for internet delivery.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Prepare()
Visual Basic (Declaration)
Public Function Prepare As Boolean
Visual C++
public:
virtual bool Prepare() sealed

Return Value

true if successful, or false if an error or if cancelled.

Implements

IPersistBook..::.Prepare()()()

Remarks

Recreates the book's book.cat from the book's files including note files.

See Also

Book Class
Mincom.LinkOne.Provider.Persist Namespace


Remove Method

[image]

LinkOne WebView API
Book..::.Remove Method
Book Class See Also Send Feedback
Removes the book from the filing system.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Remove()
Visual Basic (Declaration)
Public Sub Remove
Visual C++
public:
virtual void Remove() sealed

Implements

IPersistBook..::.Remove()()()

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | If the book directory could not be deleted.

See Also

Book Class
Mincom.LinkOne.Provider.Persist Namespace


Sync Method

[image]

LinkOne WebView API
Book..::.Sync Method
Book Class See Also Send Feedback
Synchronizes the book from any configured synchronization location.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Sync()
Visual Basic (Declaration)
Public Function Sync As Boolean
Visual C++
public:
virtual bool Sync() sealed

Return Value

true if successful, or false if an error or if cancelled.

Implements

IPersistBook..::.Sync()()()

See Also

Book Class
Mincom.LinkOne.Provider.Persist Namespace


Book Properties

[image] [image]

LinkOne WebView API
Book Properties
Book Class See Also Send Feedback

The Book type exposes the following members.

Properties

Name | Description
BookCode | Gets the book code for the book.
BookDescription | Gets the book description for the book.
BookDescriptionTranslations | Gets the description translations for this book.
CategoryCodes | Gets the a list of category codes for the book.
IsSingleFileBook | Gets true if the manifest belongs to a single file book.
Location | Gets the book location.
PublisherCode | Gets the book publisher code.
PublisherDescription | Gets the book publisher description.
Version | Gets the book version string for the book. NB: major.minor.patch style
VersionNumber | Gets the internal book version number for the book. NB: 0 to whatever, NOT major.minor.patch style

Explicit Interface Implementations

Name | Description
IPersistBook..::.BookDescriptionTranslations | Gets the book description translations.
IPersistBook..::.Publisher | Gets the publisher.

See Also

Book Class
Mincom.LinkOne.Provider.Persist Namespace


BookCode Property

[image]

LinkOne WebView API
Book..::.BookCode Property
Book Class See Also Send Feedback
Gets the book code for the book.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string BookCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property BookCode As String
Visual C++
public:
virtual property String^ BookCode {
    String^ get () sealed;
}

Implements

IPersistBook..::.BookCode

See Also

Book Class
Mincom.LinkOne.Provider.Persist Namespace


BookDescription Property

[image]

LinkOne WebView API
Book..::.BookDescription Property
Book Class See Also Send Feedback
Gets the book description for the book.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string BookDescription { get; }
Visual Basic (Declaration)
Public ReadOnly Property BookDescription As String
Visual C++
public:
virtual property String^ BookDescription {
    String^ get () sealed;
}

Implements

IPersistBook..::.BookDescription

See Also

Book Class
Mincom.LinkOne.Provider.Persist Namespace


BookDescriptionTranslations Property

[image]

LinkOne WebView API
Book..::.BookDescriptionTranslations Property
Book Class See Also Send Feedback
Gets the description translations for this book.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public TranslationCollection BookDescriptionTranslations { get; }
Visual Basic (Declaration)
Public ReadOnly Property BookDescriptionTranslations As TranslationCollection
Visual C++
public:
property TranslationCollection^ BookDescriptionTranslations {
    TranslationCollection^ get ();
}

See Also

Book Class
Mincom.LinkOne.Provider.Persist Namespace


CategoryCodes Property

[image]

LinkOne WebView API
Book..::.CategoryCodes Property
Book Class See Also Send Feedback
Gets the a list of category codes for the book.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IList<string> CategoryCodes { get; }
Visual Basic (Declaration)
Public ReadOnly Property CategoryCodes As IList(Of String)
Visual C++
public:
virtual property IList<String^>^ CategoryCodes {
    IList<String^>^ get () sealed;
}

Implements

IPersistBook..::.CategoryCodes

See Also

Book Class
Mincom.LinkOne.Provider.Persist Namespace


IPersistBook.BookDescriptionTranslations Property

[image]

LinkOne WebView API
Book..::.IPersistBook..::.BookDescriptionTranslations Property
Book Class See Also Send Feedback
Gets the book description translations.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDictionary<string, string> IPersistBook.BookDescriptionTranslations { get; }
Visual Basic (Declaration)
Private ReadOnly Property BookDescriptionTranslations As IDictionary(Of String, String)
    Implements IPersistBook.BookDescriptionTranslations
Visual C++
private:
virtual property IDictionary<String^, String^>^ BookDescriptionTranslations {
    IDictionary<String^, String^>^ get () sealed = IPersistBook::BookDescriptionTranslations::get;
}

Field Value

Implements

IPersistBook..::.BookDescriptionTranslations

See Also

Book Class
Mincom.LinkOne.Provider.Persist Namespace


IPersistBook.Publisher Property

[image]

LinkOne WebView API
Book..::.IPersistBook..::.Publisher Property
Book Class See Also Send Feedback
Gets the publisher.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPersistPublisher IPersistBook.Publisher { get; }
Visual Basic (Declaration)
Private ReadOnly Property Publisher As IPersistPublisher
    Implements IPersistBook.Publisher
Visual C++
private:
virtual property IPersistPublisher^ Publisher {
    IPersistPublisher^ get () sealed = IPersistBook::Publisher::get;
}

Field Value

Implements

IPersistBook..::.Publisher

See Also

Book Class
Mincom.LinkOne.Provider.Persist Namespace


IsSingleFileBook Property

[image]

LinkOne WebView API
Book..::.IsSingleFileBook Property
Book Class See Also Send Feedback
Gets true if the manifest belongs to a single file book.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsSingleFileBook { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSingleFileBook As Boolean
Visual C++
public:
virtual property bool IsSingleFileBook {
    bool get () sealed;
}

Implements

IPersistBook..::.IsSingleFileBook

See Also

Book Class
Mincom.LinkOne.Provider.Persist Namespace


Location Property

[image]

LinkOne WebView API
Book..::.Location Property
Book Class See Also Send Feedback
Gets the book location.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Location { get; }
Visual Basic (Declaration)
Public ReadOnly Property Location As String
Visual C++
public:
virtual property String^ Location {
    String^ get () sealed;
}

Implements

IPersistBook..::.Location

See Also

Book Class
Mincom.LinkOne.Provider.Persist Namespace


PublisherCode Property

[image]

LinkOne WebView API
Book..::.PublisherCode Property
Book Class See Also Send Feedback
Gets the book publisher code.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PublisherCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublisherCode As String
Visual C++
public:
property String^ PublisherCode {
    String^ get ();
}

See Also

Book Class
Mincom.LinkOne.Provider.Persist Namespace


PublisherDescription Property

[image]

LinkOne WebView API
Book..::.PublisherDescription Property
Book Class See Also Send Feedback
Gets the book publisher description.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PublisherDescription { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublisherDescription As String
Visual C++
public:
property String^ PublisherDescription {
    String^ get ();
}

See Also

Book Class
Mincom.LinkOne.Provider.Persist Namespace


Version Property

[image]

LinkOne WebView API
Book..::.Version Property
Book Class See Also Send Feedback
Gets the book version string for the book. NB: major.minor.patch style

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Version { get; }
Visual Basic (Declaration)
Public ReadOnly Property Version As String
Visual C++
public:
property String^ Version {
    String^ get ();
}

See Also

Book Class
Mincom.LinkOne.Provider.Persist Namespace


VersionNumber Property

[image]

LinkOne WebView API
Book..::.VersionNumber Property
Book Class See Also Send Feedback
Gets the internal book version number for the book. NB: 0 to whatever, NOT major.minor.patch style

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int VersionNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property VersionNumber As Integer
Visual C++
public:
property int VersionNumber {
    int get ();
}

See Also

Book Class
Mincom.LinkOne.Provider.Persist Namespace


BookCollection Class

[image]

LinkOne WebView API
BookCollection Class
Members See Also Send Feedback
Represents a collection of Book objects.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public sealed class BookCollection : IPersistBookCollection,
    ICollection<IPersistBook>, IEnumerable<IPersistBook>, IEnumerable
Visual Basic (Declaration)
Public NotInheritable Class BookCollection _
    Implements IPersistBookCollection, ICollection(Of IPersistBook),  _
    IEnumerable(Of IPersistBook), IEnumerable
Visual C++
public ref class BookCollection sealed : IPersistBookCollection,
    ICollection<IPersistBook^>, IEnumerable<IPersistBook^>, IEnumerable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Provider.Persist..::.BookCollection

See Also

BookCollection Members
Mincom.LinkOne.Provider.Persist Namespace


BookCollection Members

[image] [image]

LinkOne WebView API
BookCollection Members
BookCollection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The BookCollection type exposes the following members.

Methods

Name | Description
Add | See Add(T) for more information.
Clear | See Clear()()() for more information.
Contains | Overloaded.
CopyTo | See Clear()()() for more information.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | See GetEnumerator()()() for more information.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | See Remove(T) for more information.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | See Count for more information.
IsReadOnly | See IsReadOnly for more information.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | See GetEnumerator()()() for more information.
IPersistBookCollection..::.GetSortedForLanguage | Gets the books sorted by description for the given language.
IPersistBookCollection..::.Item |

See Also

BookCollection Class
Mincom.LinkOne.Provider.Persist Namespace


BookCollection Methods

[image] [image]

LinkOne WebView API
BookCollection Methods
BookCollection Class See Also Send Feedback

The BookCollection type exposes the following members.

Methods

Name | Description
Add | See Add(T) for more information.
Clear | See Clear()()() for more information.
Contains | Overloaded.
CopyTo | See Clear()()() for more information.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | See GetEnumerator()()() for more information.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | See Remove(T) for more information.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | See GetEnumerator()()() for more information.
IPersistBookCollection..::.GetSortedForLanguage | Gets the books sorted by description for the given language.

See Also

BookCollection Class
Mincom.LinkOne.Provider.Persist Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
BookCollection..::.IEnumerable..::.GetEnumerator Method
BookCollection Class See Also Send Feedback
See GetEnumerator()()() for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Implements

IEnumerable..::.GetEnumerator()()()

See Also

BookCollection Class
Mincom.LinkOne.Provider.Persist Namespace


Add Method

[image]

LinkOne WebView API
BookCollection..::.Add Method
BookCollection Class See Also Send Feedback
See Add(T) for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Add(
    IPersistBook item
)
Visual Basic (Declaration)
Public Sub Add ( _
    item As IPersistBook _
)
Visual C++
public:
virtual void Add(
    IPersistBook^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Provider.Persist..::.IPersistBook

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

BookCollection Class
Mincom.LinkOne.Provider.Persist Namespace


Clear Method

[image]

LinkOne WebView API
BookCollection..::.Clear Method
BookCollection Class See Also Send Feedback
See Clear()()() for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
virtual void Clear() sealed

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

See Also

BookCollection Class
Mincom.LinkOne.Provider.Persist Namespace


Contains Method

[image] [image]

LinkOne WebView API
BookCollection..::.Contains Method
BookCollection Class See Also Send Feedback

Overload List

Name | Description
Contains(IPersistBook) | See Contains(T) for more information.
Contains(String) | Gets whether or not the collection contains the specified book code.

See Also

BookCollection Class
BookCollection Members
Mincom.LinkOne.Provider.Persist Namespace


Contains Method (IPersistBook)

[image]

LinkOne WebView API
BookCollection..::.Contains Method (IPersistBook)
BookCollection Class See Also Send Feedback
See Contains(T) for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    IPersistBook item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As IPersistBook _
) As Boolean
Visual C++
public:
virtual bool Contains(
    IPersistBook^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Provider.Persist..::.IPersistBook

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

BookCollection Class
Contains Overload
Mincom.LinkOne.Provider.Persist Namespace


Contains Method (String)

[image]

LinkOne WebView API
BookCollection..::.Contains Method (String)
BookCollection Class See Also Send Feedback
Gets whether or not the collection contains the specified book code.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    string bookCode
)
Visual Basic (Declaration)
Public Function Contains ( _
    bookCode As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ bookCode
) sealed

Parameters

bookCode
Type: System..::.String
The book code to check.

Return Value

true if the collection contains the book code, false otherwise.

Implements

IPersistBookCollection..::.Contains(String)

See Also

BookCollection Class
Contains Overload
Mincom.LinkOne.Provider.Persist Namespace


CopyTo Method

[image]

LinkOne WebView API
BookCollection..::.CopyTo Method
BookCollection Class See Also Send Feedback
See Clear()()() for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void CopyTo(
    IPersistBook[] array,
    int arrayIndex
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As IPersistBook(), _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    array<IPersistBook^>^ array,
    int arrayIndex
) sealed

Parameters

array
Type: array< Mincom.LinkOne.Provider.Persist..::.IPersistBook >[]()[]
arrayIndex
Type: System..::.Int32

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

BookCollection Class
Mincom.LinkOne.Provider.Persist Namespace


GetEnumerator Method

[image]

LinkOne WebView API
BookCollection..::.GetEnumerator Method
BookCollection Class See Also Send Feedback
See GetEnumerator()()() for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IEnumerator<IPersistBook> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of IPersistBook)
Visual C++
public:
virtual IEnumerator<IPersistBook^>^ GetEnumerator() sealed

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

BookCollection Class
Mincom.LinkOne.Provider.Persist Namespace


IPersistBookCollection.GetSortedForLanguage Method

[image]

LinkOne WebView API
BookCollection..::.IPersistBookCollection..::.GetSortedForLanguage Method
BookCollection Class See Also Send Feedback
Gets the books sorted by description for the given language.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerable<IPersistBook> IPersistBookCollection.GetSortedForLanguage(
    string languageCode
)
Visual Basic (Declaration)
Private Function GetSortedForLanguage ( _
    languageCode As String _
) As IEnumerable(Of IPersistBook) Implements IPersistBookCollection.GetSortedForLanguage
Visual C++
private:
virtual IEnumerable<IPersistBook^>^ GetSortedForLanguage(
    String^ languageCode
) sealed = IPersistBookCollection::GetSortedForLanguage

Parameters

languageCode
Type: System..::.String
The language code.

Return Value

The books sorted by description for the given language.

Implements

IPersistBookCollection..::.GetSortedForLanguage(String)

See Also

BookCollection Class
Mincom.LinkOne.Provider.Persist Namespace


Remove Method

[image]

LinkOne WebView API
BookCollection..::.Remove Method
BookCollection Class See Also Send Feedback
See Remove(T) for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Remove(
    IPersistBook item
)
Visual Basic (Declaration)
Public Function Remove ( _
    item As IPersistBook _
) As Boolean
Visual C++
public:
virtual bool Remove(
    IPersistBook^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Provider.Persist..::.IPersistBook

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

BookCollection Class
Mincom.LinkOne.Provider.Persist Namespace


BookCollection Properties

[image] [image]

LinkOne WebView API
BookCollection Properties
BookCollection Class See Also Send Feedback

The BookCollection type exposes the following members.

Properties

Name | Description
Count | See Count for more information.
IsReadOnly | See IsReadOnly for more information.

Explicit Interface Implementations

Name | Description
IPersistBookCollection..::.Item |

See Also

BookCollection Class
Mincom.LinkOne.Provider.Persist Namespace


Count Property

[image]

LinkOne WebView API
BookCollection..::.Count Property
BookCollection Class See Also Send Feedback
See Count for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

BookCollection Class
Mincom.LinkOne.Provider.Persist Namespace


IPersistBookCollection.Item Property

[image]

LinkOne WebView API
BookCollection..::.IPersistBookCollection..::.Item Property
BookCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPersistBook IPersistBookCollection.Item[
    string bookCode
] { get; }
Visual Basic (Declaration)
Private ReadOnly Property Item ( _
    bookCode As String _
) As IPersistBook Implements IPersistBookCollection.Item
Visual C++
private:
virtual property IPersistBook^ Item[String^ bookCode] {
    IPersistBook^ get (String^ bookCode) sealed = IPersistBookCollection::Item::get;
}

Parameters

bookCode
Type: System..::.String

Implements

IPersistBookCollection..::.Item[([(String])])

See Also

BookCollection Class
Mincom.LinkOne.Provider.Persist Namespace


IsReadOnly Property

[image]

LinkOne WebView API
BookCollection..::.IsReadOnly Property
BookCollection Class See Also Send Feedback
See IsReadOnly for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

BookCollection Class
Mincom.LinkOne.Provider.Persist Namespace


Catalog Class

[image]

LinkOne WebView API
Catalog Class
Members See Also Send Feedback
Represents a catalog of books and book categories in a publisher.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public class Catalog : IPersistCatalog
Visual Basic (Declaration)
Public Class Catalog _
    Implements IPersistCatalog
Visual C++
public ref class Catalog : IPersistCatalog

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Provider.Persist..::.Catalog
Mincom.LinkOne.Provider.Persist..::.Category

See Also

Catalog Members
Mincom.LinkOne.Provider.Persist Namespace


Catalog Members

[image] [image]

LinkOne WebView API
Catalog Members
Catalog Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The Catalog type exposes the following members.

Methods

Name | Description
Compress | Compresses the category.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Expand | Expands the category.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Prepare | Prepares the category for internet delivery.
Remove | Removes the book catalog, including all books and child categories from the filing system.
Sync | Synchronizes the category from any configured synchronization location.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Books | Gets the collection of books under the catalog.
Categories | Gets the collection of categories under this catalog.

Explicit Interface Implementations

Name | Description
IPersistCatalog..::.Books | Gets the read only collection of books under the catalog.
IPersistCatalog..::.Categories | Gets the collection of categories under this catalog.

See Also

Catalog Class
Mincom.LinkOne.Provider.Persist Namespace


Catalog Methods

[image] [image]

LinkOne WebView API
Catalog Methods
Catalog Class See Also Send Feedback

The Catalog type exposes the following members.

Methods

Name | Description
Compress | Compresses the category.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Expand | Expands the category.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Prepare | Prepares the category for internet delivery.
Remove | Removes the book catalog, including all books and child categories from the filing system.
Sync | Synchronizes the category from any configured synchronization location.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Catalog Class
Mincom.LinkOne.Provider.Persist Namespace


Compress Method

[image]

LinkOne WebView API
Catalog..::.Compress Method
Catalog Class See Also Send Feedback
Compresses the category.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Compress()
Visual Basic (Declaration)
Public Function Compress As Boolean
Visual C++
public:
virtual bool Compress() sealed

Return Value

true if successful, or false if an error or if cancelled.

See Also

Catalog Class
Mincom.LinkOne.Provider.Persist Namespace


Expand Method

[image]

LinkOne WebView API
Catalog..::.Expand Method
Catalog Class See Also Send Feedback
Expands the category.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Expand()
Visual Basic (Declaration)
Public Function Expand As Boolean
Visual C++
public:
virtual bool Expand() sealed

Return Value

true if successful, or false if an error or if cancelled.

See Also

Catalog Class
Mincom.LinkOne.Provider.Persist Namespace


Prepare Method

[image]

LinkOne WebView API
Catalog..::.Prepare Method
Catalog Class See Also Send Feedback
Prepares the category for internet delivery.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Prepare()
Visual Basic (Declaration)
Public Function Prepare As Boolean
Visual C++
public:
virtual bool Prepare() sealed

Return Value

true if successful, or false if an error or if cancelled.

See Also

Catalog Class
Mincom.LinkOne.Provider.Persist Namespace


Remove Method

[image]

LinkOne WebView API
Catalog..::.Remove Method
Catalog Class See Also Send Feedback
Removes the book catalog, including all books and child categories from the filing system.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Remove()
Visual Basic (Declaration)
Public Sub Remove
Visual C++
public:
virtual void Remove() sealed

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | If the book category could not be deleted.

See Also

Catalog Class
Mincom.LinkOne.Provider.Persist Namespace


Sync Method

[image]

LinkOne WebView API
Catalog..::.Sync Method
Catalog Class See Also Send Feedback
Synchronizes the category from any configured synchronization location.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Sync()
Visual Basic (Declaration)
Public Function Sync As Boolean
Visual C++
public:
virtual bool Sync() sealed

Return Value

true if successful, or false if an error or if cancelled.

See Also

Catalog Class
Mincom.LinkOne.Provider.Persist Namespace


Catalog Properties

[image] [image]

LinkOne WebView API
Catalog Properties
Catalog Class See Also Send Feedback

The Catalog type exposes the following members.

Properties

Name | Description
Books | Gets the collection of books under the catalog.
Categories | Gets the collection of categories under this catalog.

Explicit Interface Implementations

Name | Description
IPersistCatalog..::.Books | Gets the read only collection of books under the catalog.
IPersistCatalog..::.Categories | Gets the collection of categories under this catalog.

See Also

Catalog Class
Mincom.LinkOne.Provider.Persist Namespace


Books Property

[image]

LinkOne WebView API
Catalog..::.Books Property
Catalog Class See Also Send Feedback
Gets the collection of books under the catalog.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public CategoryBookCollection Books { get; }
Visual Basic (Declaration)
Public ReadOnly Property Books As CategoryBookCollection
Visual C++
public:
property CategoryBookCollection^ Books {
    CategoryBookCollection^ get ();
}

See Also

Catalog Class
Mincom.LinkOne.Provider.Persist Namespace


Categories Property

[image]

LinkOne WebView API
Catalog..::.Categories Property
Catalog Class See Also Send Feedback
Gets the collection of categories under this catalog.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public CategoryCollection Categories { get; }
Visual Basic (Declaration)
Public ReadOnly Property Categories As CategoryCollection
Visual C++
public:
property CategoryCollection^ Categories {
    CategoryCollection^ get ();
}

See Also

Catalog Class
Mincom.LinkOne.Provider.Persist Namespace


IPersistCatalog.Books Property

[image]

LinkOne WebView API
Catalog..::.IPersistCatalog..::.Books Property
Catalog Class See Also Send Feedback
Gets the read only collection of books under the catalog.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPersistBookCollection IPersistCatalog.Books { get; }
Visual Basic (Declaration)
Private ReadOnly Property Books As IPersistBookCollection
    Implements IPersistCatalog.Books
Visual C++
private:
virtual property IPersistBookCollection^ Books {
    IPersistBookCollection^ get () sealed = IPersistCatalog::Books::get;
}

Field Value

Implements

IPersistCatalog..::.Books

See Also

Catalog Class
Mincom.LinkOne.Provider.Persist Namespace


IPersistCatalog.Categories Property

[image]

LinkOne WebView API
Catalog..::.IPersistCatalog..::.Categories Property
Catalog Class See Also Send Feedback
Gets the collection of categories under this catalog.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPersistCategoryCollection IPersistCatalog.Categories { get; }
Visual Basic (Declaration)
Private ReadOnly Property Categories As IPersistCategoryCollection
    Implements IPersistCatalog.Categories
Visual C++
private:
virtual property IPersistCategoryCollection^ Categories {
    IPersistCategoryCollection^ get () sealed = IPersistCatalog::Categories::get;
}

Field Value

Implements

IPersistCatalog..::.Categories

See Also

Catalog Class
Mincom.LinkOne.Provider.Persist Namespace


Category Class

[image]

LinkOne WebView API
Category Class
Members See Also Send Feedback
Represents a book category.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public sealed class Category : Catalog,
    IPersistCategory, IPersistCatalog
Visual Basic (Declaration)
Public NotInheritable Class Category _
    Inherits Catalog _
    Implements IPersistCategory, IPersistCatalog
Visual C++
public ref class Category sealed : public Catalog,
    IPersistCategory, IPersistCatalog

Remarks

The book category is organised as a heirachical catalog of categories.

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Provider.Persist..::.Catalog
Mincom.LinkOne.Provider.Persist..::.Category

See Also

Category Members
Mincom.LinkOne.Provider.Persist Namespace


Category Members

[image] [image]

LinkOne WebView API
Category Members
Category Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The Category type exposes the following members.

Methods

Name | Description
Compress | Compresses the category. (Inherited from Catalog.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Expand | Expands the category. (Inherited from Catalog.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Prepare | Prepares the category for internet delivery. (Inherited from Catalog.)
Remove | Removes the book catalog, including all books and child categories from the filing system. (Inherited from Catalog.)
Sync | Synchronizes the category from any configured synchronization location. (Inherited from Catalog.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Books | Gets the collection of books under the catalog. (Inherited from Catalog.)
Categories | Gets the collection of categories under this catalog. (Inherited from Catalog.)
CategoryCode | Gets the category code for the category.
CategoryDescription | Gets the description for the category.
CategoryDescriptionTranslations | Gets the description translations for the category.

Explicit Interface Implementations

Name | Description
IPersistCatalog..::.Books | Gets the read only collection of books under the catalog. (Inherited from Catalog.)
IPersistCatalog..::.Categories | Gets the collection of categories under this catalog. (Inherited from Catalog.)

See Also

Category Class
Mincom.LinkOne.Provider.Persist Namespace


Category Methods

[image] [image]

LinkOne WebView API
Category Methods
Category Class See Also Send Feedback

The Category type exposes the following members.

Methods

Name | Description
Compress | Compresses the category. (Inherited from Catalog.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Expand | Expands the category. (Inherited from Catalog.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Prepare | Prepares the category for internet delivery. (Inherited from Catalog.)
Remove | Removes the book catalog, including all books and child categories from the filing system. (Inherited from Catalog.)
Sync | Synchronizes the category from any configured synchronization location. (Inherited from Catalog.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Category Class
Mincom.LinkOne.Provider.Persist Namespace


Category Properties

[image] [image]

LinkOne WebView API
Category Properties
Category Class See Also Send Feedback

The Category type exposes the following members.

Properties

Name | Description
Books | Gets the collection of books under the catalog. (Inherited from Catalog.)
Categories | Gets the collection of categories under this catalog. (Inherited from Catalog.)
CategoryCode | Gets the category code for the category.
CategoryDescription | Gets the description for the category.
CategoryDescriptionTranslations | Gets the description translations for the category.

Explicit Interface Implementations

Name | Description
IPersistCatalog..::.Books | Gets the read only collection of books under the catalog. (Inherited from Catalog.)
IPersistCatalog..::.Categories | Gets the collection of categories under this catalog. (Inherited from Catalog.)

See Also

Category Class
Mincom.LinkOne.Provider.Persist Namespace


CategoryCode Property

[image]

LinkOne WebView API
Category..::.CategoryCode Property
Category Class See Also Send Feedback
Gets the category code for the category.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string CategoryCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property CategoryCode As String
Visual C++
public:
virtual property String^ CategoryCode {
    String^ get () sealed;
}

Implements

IPersistCategory..::.CategoryCode

See Also

Category Class
Mincom.LinkOne.Provider.Persist Namespace


CategoryDescription Property

[image]

LinkOne WebView API
Category..::.CategoryDescription Property
Category Class See Also Send Feedback
Gets the description for the category.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string CategoryDescription { get; }
Visual Basic (Declaration)
Public ReadOnly Property CategoryDescription As String
Visual C++
public:
virtual property String^ CategoryDescription {
    String^ get () sealed;
}

Implements

IPersistCategory..::.CategoryDescription

See Also

Category Class
Mincom.LinkOne.Provider.Persist Namespace


CategoryDescriptionTranslations Property

[image]

LinkOne WebView API
Category..::.CategoryDescriptionTranslations Property
Category Class See Also Send Feedback
Gets the description translations for the category.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IDictionary<string, string> CategoryDescriptionTranslations { get; }
Visual Basic (Declaration)
Public ReadOnly Property CategoryDescriptionTranslations As IDictionary(Of String, String)
Visual C++
public:
virtual property IDictionary<String^, String^>^ CategoryDescriptionTranslations {
    IDictionary<String^, String^>^ get () sealed;
}

Implements

IPersistCategory..::.CategoryDescriptionTranslations

See Also

Category Class
Mincom.LinkOne.Provider.Persist Namespace


CategoryBookCollection Class

[image]

LinkOne WebView API
CategoryBookCollection Class
Members See Also Send Feedback
Represents a collection of books in a category.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public class CategoryBookCollection : IPersistBookCollection,
    ICollection<IPersistBook>, IEnumerable<IPersistBook>, IEnumerable
Visual Basic (Declaration)
Public Class CategoryBookCollection _
    Implements IPersistBookCollection, ICollection(Of IPersistBook),  _
    IEnumerable(Of IPersistBook), IEnumerable
Visual C++
public ref class CategoryBookCollection : IPersistBookCollection,
    ICollection<IPersistBook^>, IEnumerable<IPersistBook^>, IEnumerable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Provider.Persist..::.CategoryBookCollection

See Also

CategoryBookCollection Members
Mincom.LinkOne.Provider.Persist Namespace


CategoryBookCollection Members

[image] [image]

LinkOne WebView API
CategoryBookCollection Members
CategoryBookCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The CategoryBookCollection type exposes the following members.

Constructors

Name | Description
CategoryBookCollection | Initializes a new instance of the CategoryBookCollection class.

Methods

Name | Description
Add | See Add(T) for more information.
Clear | See Clear()()() for more information.
Contains | Overloaded.
CopyTo | See Clear()()() for more information.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | See GetEnumerator()()() for more information.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSortedForLanguage | Gets the books sorted by description for the given language.
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | See Remove(T) for more information.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | See Count for more information.
IsReadOnly | See IsReadOnly for more information.
Item | Gets the IPersistBook with the specified book code.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | See GetEnumerator()()() for more information.

See Also

CategoryBookCollection Class
Mincom.LinkOne.Provider.Persist Namespace


CategoryBookCollection Constructor

[image]

LinkOne WebView API
CategoryBookCollection Constructor
CategoryBookCollection Class See Also Send Feedback
Initializes a new instance of the CategoryBookCollection class.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public CategoryBookCollection(
    Publisher publisher,
    ICollection<string> bookCodes
)
Visual Basic (Declaration)
Public Sub New ( _
    publisher As Publisher, _
    bookCodes As ICollection(Of String) _
)
Visual C++
public:
CategoryBookCollection(
    Publisher^ publisher,
    ICollection<String^>^ bookCodes
)

Parameters

publisher
Type: Mincom.LinkOne.Provider.Persist..::.Publisher
The publisher to retrieve the book objects for this collection from.
bookCodes
Type: System.Collections.Generic..::.ICollection<(Of <(String>)>)
The book codes that determine the subset of publisher books for this collection.

See Also

CategoryBookCollection Class
Mincom.LinkOne.Provider.Persist Namespace


CategoryBookCollection Methods

[image] [image]

LinkOne WebView API
CategoryBookCollection Methods
CategoryBookCollection Class See Also Send Feedback

The CategoryBookCollection type exposes the following members.

Methods

Name | Description
Add | See Add(T) for more information.
Clear | See Clear()()() for more information.
Contains | Overloaded.
CopyTo | See Clear()()() for more information.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | See GetEnumerator()()() for more information.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSortedForLanguage | Gets the books sorted by description for the given language.
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | See Remove(T) for more information.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | See GetEnumerator()()() for more information.

See Also

CategoryBookCollection Class
Mincom.LinkOne.Provider.Persist Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
CategoryBookCollection..::.IEnumerable..::.GetEnumerator Method
CategoryBookCollection Class See Also Send Feedback
See GetEnumerator()()() for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Implements

IEnumerable..::.GetEnumerator()()()

See Also

CategoryBookCollection Class
Mincom.LinkOne.Provider.Persist Namespace


Add Method

[image]

LinkOne WebView API
CategoryBookCollection..::.Add Method
CategoryBookCollection Class See Also Send Feedback
See Add(T) for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Add(
    IPersistBook item
)
Visual Basic (Declaration)
Public Sub Add ( _
    item As IPersistBook _
)
Visual C++
public:
virtual void Add(
    IPersistBook^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Provider.Persist..::.IPersistBook

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

CategoryBookCollection Class
Mincom.LinkOne.Provider.Persist Namespace


Clear Method

[image]

LinkOne WebView API
CategoryBookCollection..::.Clear Method
CategoryBookCollection Class See Also Send Feedback
See Clear()()() for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
virtual void Clear() sealed

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

See Also

CategoryBookCollection Class
Mincom.LinkOne.Provider.Persist Namespace


Contains Method

[image] [image]

LinkOne WebView API
CategoryBookCollection..::.Contains Method
CategoryBookCollection Class See Also Send Feedback

Overload List

Name | Description
Contains(IPersistBook) | See Contains(T) for more information.
Contains(String) | Gets whether or not the collection contains the specified book code.

See Also

CategoryBookCollection Class
CategoryBookCollection Members
Mincom.LinkOne.Provider.Persist Namespace


Contains Method (IPersistBook)

[image]

LinkOne WebView API
CategoryBookCollection..::.Contains Method (IPersistBook)
CategoryBookCollection Class See Also Send Feedback
See Contains(T) for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    IPersistBook item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As IPersistBook _
) As Boolean
Visual C++
public:
virtual bool Contains(
    IPersistBook^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Provider.Persist..::.IPersistBook

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

CategoryBookCollection Class
Contains Overload
Mincom.LinkOne.Provider.Persist Namespace


Contains Method (String)

[image]

LinkOne WebView API
CategoryBookCollection..::.Contains Method (String)
CategoryBookCollection Class See Also Send Feedback
Gets whether or not the collection contains the specified book code.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    string bookCode
)
Visual Basic (Declaration)
Public Function Contains ( _
    bookCode As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ bookCode
) sealed

Parameters

bookCode
Type: System..::.String
The book code to check.

Return Value

true if the collection contains the book code, false otherwise.

Implements

IPersistBookCollection..::.Contains(String)

See Also

CategoryBookCollection Class
Contains Overload
Mincom.LinkOne.Provider.Persist Namespace


CopyTo Method

[image]

LinkOne WebView API
CategoryBookCollection..::.CopyTo Method
CategoryBookCollection Class See Also Send Feedback
See Clear()()() for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void CopyTo(
    IPersistBook[] array,
    int arrayIndex
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As IPersistBook(), _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    array<IPersistBook^>^ array,
    int arrayIndex
) sealed

Parameters

array
Type: array< Mincom.LinkOne.Provider.Persist..::.IPersistBook >[]()[]
arrayIndex
Type: System..::.Int32

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

CategoryBookCollection Class
Mincom.LinkOne.Provider.Persist Namespace


GetEnumerator Method

[image]

LinkOne WebView API
CategoryBookCollection..::.GetEnumerator Method
CategoryBookCollection Class See Also Send Feedback
See GetEnumerator()()() for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IEnumerator<IPersistBook> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of IPersistBook)
Visual C++
public:
virtual IEnumerator<IPersistBook^>^ GetEnumerator() sealed

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

CategoryBookCollection Class
Mincom.LinkOne.Provider.Persist Namespace


GetSortedForLanguage Method

[image]

LinkOne WebView API
CategoryBookCollection..::.GetSortedForLanguage Method
CategoryBookCollection Class See Also Send Feedback
Gets the books sorted by description for the given language.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IEnumerable<IPersistBook> GetSortedForLanguage(
    string languageCode
)
Visual Basic (Declaration)
Public Function GetSortedForLanguage ( _
    languageCode As String _
) As IEnumerable(Of IPersistBook)
Visual C++
public:
virtual IEnumerable<IPersistBook^>^ GetSortedForLanguage(
    String^ languageCode
) sealed

Parameters

languageCode
Type: System..::.String
The language code.

Return Value

The books sorted by description for the given language.

Implements

IPersistBookCollection..::.GetSortedForLanguage(String)

See Also

CategoryBookCollection Class
Mincom.LinkOne.Provider.Persist Namespace


Remove Method

[image]

LinkOne WebView API
CategoryBookCollection..::.Remove Method
CategoryBookCollection Class See Also Send Feedback
See Remove(T) for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Remove(
    IPersistBook item
)
Visual Basic (Declaration)
Public Function Remove ( _
    item As IPersistBook _
) As Boolean
Visual C++
public:
virtual bool Remove(
    IPersistBook^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Provider.Persist..::.IPersistBook

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

CategoryBookCollection Class
Mincom.LinkOne.Provider.Persist Namespace


CategoryBookCollection Properties

[image] [image]

LinkOne WebView API
CategoryBookCollection Properties
CategoryBookCollection Class See Also Send Feedback

The CategoryBookCollection type exposes the following members.

Properties

Name | Description
Count | See Count for more information.
IsReadOnly | See IsReadOnly for more information.
Item | Gets the IPersistBook with the specified book code.

See Also

CategoryBookCollection Class
Mincom.LinkOne.Provider.Persist Namespace


Count Property

[image]

LinkOne WebView API
CategoryBookCollection..::.Count Property
CategoryBookCollection Class See Also Send Feedback
See Count for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

CategoryBookCollection Class
Mincom.LinkOne.Provider.Persist Namespace


IsReadOnly Property

[image]

LinkOne WebView API
CategoryBookCollection..::.IsReadOnly Property
CategoryBookCollection Class See Also Send Feedback
See IsReadOnly for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

CategoryBookCollection Class
Mincom.LinkOne.Provider.Persist Namespace


Item Property

[image]

LinkOne WebView API
CategoryBookCollection..::.Item Property
CategoryBookCollection Class See Also Send Feedback
Gets the IPersistBook with the specified book code.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IPersistBook this[
    string bookCode
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    bookCode As String _
) As IPersistBook
Visual C++
public:
virtual property IPersistBook^ default[String^ bookCode] {
    IPersistBook^ get (String^ bookCode) sealed;
}

Parameters

bookCode
Type: System..::.String

Implements

IPersistBookCollection..::.Item[([(String])])

See Also

CategoryBookCollection Class
Mincom.LinkOne.Provider.Persist Namespace


CategoryCollection Class

[image]

LinkOne WebView API
CategoryCollection Class
Members See Also Send Feedback
Represents a collection of Category objects.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public sealed class CategoryCollection : IPersistCategoryCollection,
    ICollection<IPersistCategory>, IEnumerable<IPersistCategory>, IEnumerable
Visual Basic (Declaration)
Public NotInheritable Class CategoryCollection _
    Implements IPersistCategoryCollection, ICollection(Of IPersistCategory),  _
    IEnumerable(Of IPersistCategory), IEnumerable
Visual C++
public ref class CategoryCollection sealed : IPersistCategoryCollection,
    ICollection<IPersistCategory^>, IEnumerable<IPersistCategory^>, IEnumerable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Provider.Persist..::.CategoryCollection

See Also

CategoryCollection Members
Mincom.LinkOne.Provider.Persist Namespace


CategoryCollection Members

[image] [image]

LinkOne WebView API
CategoryCollection Members
CategoryCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The CategoryCollection type exposes the following members.

Constructors

Name | Description
CategoryCollection | Initializes a new instance of the CategoryCollection class

Methods

Name | Description
Add | See Add(T) for more information.
Clear | See Clear()()() for more information.
Contains | Overloaded.
CopyTo | See Clear()()() for more information.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | See GetEnumerator()()() for more information.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSortedForLanguage | Returns the categories sorted by the translations for the given language.
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | See Remove(T) for more information.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | See Count for more information.
IsReadOnly | See IsReadOnly for more information.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | See GetEnumerator()()() for more information.
IPersistCategoryCollection..::.GetSortedForLanguage | Gets the categories sorted by description for the given language.
IPersistCategoryCollection..::.Item | Gets the IPersistCategory with the specified category code.

See Also

CategoryCollection Class
Mincom.LinkOne.Provider.Persist Namespace


CategoryCollection Constructor

[image]

LinkOne WebView API
CategoryCollection Constructor
CategoryCollection Class See Also Send Feedback
Initializes a new instance of the CategoryCollection class

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public CategoryCollection(
    [T:] categories
)
Visual Basic (Declaration)
Public Sub New ( _
    categories As [T:] _
)
Visual C++
public:
CategoryCollection(
    [T:]^ categories
)

Parameters

categories
Type: [T:]

See Also

CategoryCollection Class
Mincom.LinkOne.Provider.Persist Namespace


CategoryCollection Methods

[image] [image]

LinkOne WebView API
CategoryCollection Methods
CategoryCollection Class See Also Send Feedback

The CategoryCollection type exposes the following members.

Methods

Name | Description
Add | See Add(T) for more information.
Clear | See Clear()()() for more information.
Contains | Overloaded.
CopyTo | See Clear()()() for more information.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | See GetEnumerator()()() for more information.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSortedForLanguage | Returns the categories sorted by the translations for the given language.
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | See Remove(T) for more information.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | See GetEnumerator()()() for more information.
IPersistCategoryCollection..::.GetSortedForLanguage | Gets the categories sorted by description for the given language.

See Also

CategoryCollection Class
Mincom.LinkOne.Provider.Persist Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
CategoryCollection..::.IEnumerable..::.GetEnumerator Method
CategoryCollection Class See Also Send Feedback
See GetEnumerator()()() for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Implements

IEnumerable..::.GetEnumerator()()()

See Also

CategoryCollection Class
Mincom.LinkOne.Provider.Persist Namespace


Add Method

[image]

LinkOne WebView API
CategoryCollection..::.Add Method
CategoryCollection Class See Also Send Feedback
See Add(T) for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Add(
    IPersistCategory item
)
Visual Basic (Declaration)
Public Sub Add ( _
    item As IPersistCategory _
)
Visual C++
public:
virtual void Add(
    IPersistCategory^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Provider.Persist..::.IPersistCategory

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

CategoryCollection Class
Mincom.LinkOne.Provider.Persist Namespace


Clear Method

[image]

LinkOne WebView API
CategoryCollection..::.Clear Method
CategoryCollection Class See Also Send Feedback
See Clear()()() for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
virtual void Clear() sealed

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

See Also

CategoryCollection Class
Mincom.LinkOne.Provider.Persist Namespace


Contains Method

[image] [image]

LinkOne WebView API
CategoryCollection..::.Contains Method
CategoryCollection Class See Also Send Feedback

Overload List

Name | Description
Contains(IPersistCategory) | See Contains(T) for more information.
Contains(String) | Gets whether or not the collection contains the specified category code.

See Also

CategoryCollection Class
CategoryCollection Members
Mincom.LinkOne.Provider.Persist Namespace


Contains Method (IPersistCategory)

[image]

LinkOne WebView API
CategoryCollection..::.Contains Method (IPersistCategory)
CategoryCollection Class See Also Send Feedback
See Contains(T) for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    IPersistCategory item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As IPersistCategory _
) As Boolean
Visual C++
public:
virtual bool Contains(
    IPersistCategory^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Provider.Persist..::.IPersistCategory

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

CategoryCollection Class
Contains Overload
Mincom.LinkOne.Provider.Persist Namespace


Contains Method (String)

[image]

LinkOne WebView API
CategoryCollection..::.Contains Method (String)
CategoryCollection Class See Also Send Feedback
Gets whether or not the collection contains the specified category code.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    string categoryCode
)
Visual Basic (Declaration)
Public Function Contains ( _
    categoryCode As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ categoryCode
) sealed

Parameters

categoryCode
Type: System..::.String
The category code to check.

Return Value

true if the collection contains the book code, false otherwise.

Implements

IPersistCategoryCollection..::.Contains(String)

See Also

CategoryCollection Class
Contains Overload
Mincom.LinkOne.Provider.Persist Namespace


CopyTo Method

[image]

LinkOne WebView API
CategoryCollection..::.CopyTo Method
CategoryCollection Class See Also Send Feedback
See Clear()()() for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void CopyTo(
    IPersistCategory[] array,
    int arrayIndex
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As IPersistCategory(), _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    array<IPersistCategory^>^ array,
    int arrayIndex
) sealed

Parameters

array
Type: array< Mincom.LinkOne.Provider.Persist..::.IPersistCategory >[]()[]
arrayIndex
Type: System..::.Int32

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

CategoryCollection Class
Mincom.LinkOne.Provider.Persist Namespace


GetEnumerator Method

[image]

LinkOne WebView API
CategoryCollection..::.GetEnumerator Method
CategoryCollection Class See Also Send Feedback
See GetEnumerator()()() for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IEnumerator<IPersistCategory> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of IPersistCategory)
Visual C++
public:
virtual IEnumerator<IPersistCategory^>^ GetEnumerator() sealed

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

CategoryCollection Class
Mincom.LinkOne.Provider.Persist Namespace


GetSortedForLanguage Method

[image]

LinkOne WebView API
CategoryCollection..::.GetSortedForLanguage Method
CategoryCollection Class See Also Send Feedback
Returns the categories sorted by the translations for the given language.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IEnumerable<Category> GetSortedForLanguage(
    string languageCode
)
Visual Basic (Declaration)
Public Function GetSortedForLanguage ( _
    languageCode As String _
) As IEnumerable(Of Category)
Visual C++
public:
IEnumerable<Category^>^ GetSortedForLanguage(
    String^ languageCode
)

Parameters

languageCode
Type: System..::.String
The language code to sort by.

Return Value

The categories sorted by the translations for the given language.

See Also

CategoryCollection Class
Mincom.LinkOne.Provider.Persist Namespace


IPersistCategoryCollection.GetSortedForLanguage Method

[image]

LinkOne WebView API
CategoryCollection..::.IPersistCategoryCollection..::.GetSortedForLanguage Method
CategoryCollection Class See Also Send Feedback
Gets the categories sorted by description for the given language.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerable<IPersistCategory> IPersistCategoryCollection.GetSortedForLanguage(
    string languageCode
)
Visual Basic (Declaration)
Private Function GetSortedForLanguage ( _
    languageCode As String _
) As IEnumerable(Of IPersistCategory) Implements IPersistCategoryCollection.GetSortedForLanguage
Visual C++
private:
virtual IEnumerable<IPersistCategory^>^ GetSortedForLanguage(
    String^ languageCode
) sealed = IPersistCategoryCollection::GetSortedForLanguage

Parameters

languageCode
Type: System..::.String
The language code.

Return Value

The categories sorted by description for the given language.

Implements

IPersistCategoryCollection..::.GetSortedForLanguage(String)

See Also

CategoryCollection Class
Mincom.LinkOne.Provider.Persist Namespace


Remove Method

[image]

LinkOne WebView API
CategoryCollection..::.Remove Method
CategoryCollection Class See Also Send Feedback
See Remove(T) for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Remove(
    IPersistCategory item
)
Visual Basic (Declaration)
Public Function Remove ( _
    item As IPersistCategory _
) As Boolean
Visual C++
public:
virtual bool Remove(
    IPersistCategory^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Provider.Persist..::.IPersistCategory

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

CategoryCollection Class
Mincom.LinkOne.Provider.Persist Namespace


CategoryCollection Properties

[image] [image]

LinkOne WebView API
CategoryCollection Properties
CategoryCollection Class See Also Send Feedback

The CategoryCollection type exposes the following members.

Properties

Name | Description
Count | See Count for more information.
IsReadOnly | See IsReadOnly for more information.

Explicit Interface Implementations

Name | Description
IPersistCategoryCollection..::.Item | Gets the IPersistCategory with the specified category code.

See Also

CategoryCollection Class
Mincom.LinkOne.Provider.Persist Namespace


Count Property

[image]

LinkOne WebView API
CategoryCollection..::.Count Property
CategoryCollection Class See Also Send Feedback
See Count for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

CategoryCollection Class
Mincom.LinkOne.Provider.Persist Namespace


IPersistCategoryCollection.Item Property

[image]

LinkOne WebView API
CategoryCollection..::.IPersistCategoryCollection..::.Item Property
CategoryCollection Class See Also Send Feedback
Gets the IPersistCategory with the specified category code.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPersistCategory IPersistCategoryCollection.Item[
    string categoryCode
] { get; }
Visual Basic (Declaration)
Private ReadOnly Property Item ( _
    categoryCode As String _
) As IPersistCategory Implements IPersistCategoryCollection.Item
Visual C++
private:
virtual property IPersistCategory^ Item[String^ categoryCode] {
    IPersistCategory^ get (String^ categoryCode) sealed = IPersistCategoryCollection::Item::get;
}

Parameters

categoryCode
Type: System..::.String

Implements

IPersistCategoryCollection..::.Item[([(String])])

See Also

CategoryCollection Class
Mincom.LinkOne.Provider.Persist Namespace


IsReadOnly Property

[image]

LinkOne WebView API
CategoryCollection..::.IsReadOnly Property
CategoryCollection Class See Also Send Feedback
See IsReadOnly for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

CategoryCollection Class
Mincom.LinkOne.Provider.Persist Namespace


IPersistBook Interface

[image]

LinkOne WebView API
IPersistBook Interface
Members See Also Send Feedback
Implemented by a class to manage book persistence.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public interface IPersistBook
Visual Basic (Declaration)
Public Interface IPersistBook
Visual C++
public interface class IPersistBook

See Also

IPersistBook Members
Mincom.LinkOne.Provider.Persist Namespace


IPersistBook Members

[image] [image]

LinkOne WebView API
IPersistBook Members
IPersistBook Interface Methods Properties See Also Send Feedback

The IPersistBook type exposes the following members.

Methods

Name | Description
Compress | Compresses the book into a single file book.
CreateAliasBook | Creates a new alias book with the given book code and book description. The current book is used as the master book.
Expand | Expands a single file book into seperate files.
Prepare | Prepares the book for internet delivery.
Remove | Removes the book from the filing system.
Sync | Synchronizes the book from any configured synchronization location.

Properties

Name | Description
BookCode | Gets the book code for the book.
BookDescription | Gets the book description for the book.
BookDescriptionTranslations | Gets the book description translations.
CategoryCodes | Gets a read-only list of category codes for the book.
IsSingleFileBook | Gets true if the book is a single file book.
Location | Gets the book location.
Publisher | Gets the publisher.

See Also

IPersistBook Interface
Mincom.LinkOne.Provider.Persist Namespace


IPersistBook Methods

[image] [image]

LinkOne WebView API
IPersistBook Methods
IPersistBook Interface See Also Send Feedback

The IPersistBook type exposes the following members.

Methods

Name | Description
Compress | Compresses the book into a single file book.
CreateAliasBook | Creates a new alias book with the given book code and book description. The current book is used as the master book.
Expand | Expands a single file book into seperate files.
Prepare | Prepares the book for internet delivery.
Remove | Removes the book from the filing system.
Sync | Synchronizes the book from any configured synchronization location.

See Also

IPersistBook Interface
Mincom.LinkOne.Provider.Persist Namespace


Compress Method

[image]

LinkOne WebView API
IPersistBook..::.Compress Method
IPersistBook Interface See Also Send Feedback
Compresses the book into a single file book.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool Compress()
Visual Basic (Declaration)
Function Compress As Boolean
Visual C++
bool Compress()

Return Value

true if successful, or false if an error or if cancelled.

See Also

IPersistBook Interface
Mincom.LinkOne.Provider.Persist Namespace


CreateAliasBook Method

[image]

LinkOne WebView API
IPersistBook..::.CreateAliasBook Method
IPersistBook Interface See Also Send Feedback
Creates a new alias book with the given book code and book description. The current book is used as the master book.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
void CreateAliasBook(
    string bookCode,
    string bookDescription,
    string location
)
Visual Basic (Declaration)
Sub CreateAliasBook ( _
    bookCode As String, _
    bookDescription As String, _
    location As String _
)
Visual C++
void CreateAliasBook(
    String^ bookCode,
    String^ bookDescription,
    String^ location
)

Parameters

bookCode
Type: System..::.String
The book code to be used for the new alias book
bookDescription
Type: System..::.String
The book description to be used for the new alias book
location
Type: System..::.String
The location of the library where the book will be created.

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | An I/O error occurs.

See Also

IPersistBook Interface
Mincom.LinkOne.Provider.Persist Namespace


Expand Method

[image]

LinkOne WebView API
IPersistBook..::.Expand Method
IPersistBook Interface See Also Send Feedback
Expands a single file book into seperate files.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool Expand()
Visual Basic (Declaration)
Function Expand As Boolean
Visual C++
bool Expand()

Return Value

true if successful, or false if an error or if cancelled.

See Also

IPersistBook Interface
Mincom.LinkOne.Provider.Persist Namespace


Prepare Method

[image]

LinkOne WebView API
IPersistBook..::.Prepare Method
IPersistBook Interface See Also Send Feedback
Prepares the book for internet delivery.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool Prepare()
Visual Basic (Declaration)
Function Prepare As Boolean
Visual C++
bool Prepare()

Return Value

true if successful, or false if an error or if cancelled.

Remarks

Recreates the book's book.cat from the book's files including note files.

See Also

IPersistBook Interface
Mincom.LinkOne.Provider.Persist Namespace


Remove Method

[image]

LinkOne WebView API
IPersistBook..::.Remove Method
IPersistBook Interface See Also Send Feedback
Removes the book from the filing system.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
void Remove()
Visual Basic (Declaration)
Sub Remove
Visual C++
void Remove()

See Also

IPersistBook Interface
Mincom.LinkOne.Provider.Persist Namespace


Sync Method

[image]

LinkOne WebView API
IPersistBook..::.Sync Method
IPersistBook Interface See Also Send Feedback
Synchronizes the book from any configured synchronization location.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool Sync()
Visual Basic (Declaration)
Function Sync As Boolean
Visual C++
bool Sync()

Return Value

true if successful, or false if an error or if cancelled.

See Also

IPersistBook Interface
Mincom.LinkOne.Provider.Persist Namespace


IPersistBook Properties

[image] [image]

LinkOne WebView API
IPersistBook Properties
IPersistBook Interface See Also Send Feedback

The IPersistBook type exposes the following members.

Properties

Name | Description
BookCode | Gets the book code for the book.
BookDescription | Gets the book description for the book.
BookDescriptionTranslations | Gets the book description translations.
CategoryCodes | Gets a read-only list of category codes for the book.
IsSingleFileBook | Gets true if the book is a single file book.
Location | Gets the book location.
Publisher | Gets the publisher.

See Also

IPersistBook Interface
Mincom.LinkOne.Provider.Persist Namespace


BookCode Property

[image]

LinkOne WebView API
IPersistBook..::.BookCode Property
IPersistBook Interface See Also Send Feedback
Gets the book code for the book.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
string BookCode { get; }
Visual Basic (Declaration)
ReadOnly Property BookCode As String
Visual C++
property String^ BookCode {
    String^ get ();
}

See Also

IPersistBook Interface
Mincom.LinkOne.Provider.Persist Namespace


BookDescription Property

[image]

LinkOne WebView API
IPersistBook..::.BookDescription Property
IPersistBook Interface See Also Send Feedback
Gets the book description for the book.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
string BookDescription { get; }
Visual Basic (Declaration)
ReadOnly Property BookDescription As String
Visual C++
property String^ BookDescription {
    String^ get ();
}

See Also

IPersistBook Interface
Mincom.LinkOne.Provider.Persist Namespace


BookDescriptionTranslations Property

[image]

LinkOne WebView API
IPersistBook..::.BookDescriptionTranslations Property
IPersistBook Interface See Also Send Feedback
Gets the book description translations.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
IDictionary<string, string> BookDescriptionTranslations { get; }
Visual Basic (Declaration)
ReadOnly Property BookDescriptionTranslations As IDictionary(Of String, String)
Visual C++
property IDictionary<String^, String^>^ BookDescriptionTranslations {
    IDictionary<String^, String^>^ get ();
}

Field Value

See Also

IPersistBook Interface
Mincom.LinkOne.Provider.Persist Namespace


CategoryCodes Property

[image]

LinkOne WebView API
IPersistBook..::.CategoryCodes Property
IPersistBook Interface See Also Send Feedback
Gets a read-only list of category codes for the book.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
IList<string> CategoryCodes { get; }
Visual Basic (Declaration)
ReadOnly Property CategoryCodes As IList(Of String)
Visual C++
property IList<String^>^ CategoryCodes {
    IList<String^>^ get ();
}

See Also

IPersistBook Interface
Mincom.LinkOne.Provider.Persist Namespace


IsSingleFileBook Property

[image]

LinkOne WebView API
IPersistBook..::.IsSingleFileBook Property
IPersistBook Interface See Also Send Feedback
Gets true if the book is a single file book.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool IsSingleFileBook { get; }
Visual Basic (Declaration)
ReadOnly Property IsSingleFileBook As Boolean
Visual C++
property bool IsSingleFileBook {
    bool get ();
}

See Also

IPersistBook Interface
Mincom.LinkOne.Provider.Persist Namespace


Location Property

[image]

LinkOne WebView API
IPersistBook..::.Location Property
IPersistBook Interface See Also Send Feedback
Gets the book location.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
string Location { get; }
Visual Basic (Declaration)
ReadOnly Property Location As String
Visual C++
property String^ Location {
    String^ get ();
}

See Also

IPersistBook Interface
Mincom.LinkOne.Provider.Persist Namespace


Publisher Property

[image]

LinkOne WebView API
IPersistBook..::.Publisher Property
IPersistBook Interface See Also Send Feedback
Gets the publisher.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
IPersistPublisher Publisher { get; }
Visual Basic (Declaration)
ReadOnly Property Publisher As IPersistPublisher
Visual C++
property IPersistPublisher^ Publisher {
    IPersistPublisher^ get ();
}

See Also

IPersistBook Interface
Mincom.LinkOne.Provider.Persist Namespace


IPersistBookCollection Interface

[image]

LinkOne WebView API
IPersistBookCollection Interface
Members See Also Send Feedback
Implemented by a class to manage book collection persistence.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public interface IPersistBookCollection : ICollection<IPersistBook>,
    IEnumerable<IPersistBook>, IEnumerable
Visual Basic (Declaration)
Public Interface IPersistBookCollection _
    Implements ICollection(Of IPersistBook), IEnumerable(Of IPersistBook),  _
    IEnumerable
Visual C++
public interface class IPersistBookCollection : ICollection<IPersistBook^>,
    IEnumerable<IPersistBook^>, IEnumerable

See Also

IPersistBookCollection Members
Mincom.LinkOne.Provider.Persist Namespace


IPersistBookCollection Members

[image] [image]

LinkOne WebView API
IPersistBookCollection Members
IPersistBookCollection Interface Methods Properties See Also Send Feedback

The IPersistBookCollection type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPersistBook >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPersistBook >)>).)
Contains | Overloaded.
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( IPersistBook >)>).)
GetEnumerator | Overloaded.
GetSortedForLanguage | Gets the books sorted by description for the given language.
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPersistBook >)>).)

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPersistBook >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( IPersistBook >)>).)
Item | Gets the IPersistBook with the specified code, or null if not found.

See Also

IPersistBookCollection Interface
Mincom.LinkOne.Provider.Persist Namespace


IPersistBookCollection Methods

[image] [image]

LinkOne WebView API
IPersistBookCollection Methods
IPersistBookCollection Interface See Also Send Feedback

The IPersistBookCollection type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPersistBook >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPersistBook >)>).)
Contains | Overloaded.
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( IPersistBook >)>).)
GetEnumerator | Overloaded.
GetSortedForLanguage | Gets the books sorted by description for the given language.
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPersistBook >)>).)

See Also

IPersistBookCollection Interface
Mincom.LinkOne.Provider.Persist Namespace


Contains Method

[image] [image]

LinkOne WebView API
IPersistBookCollection..::.Contains Method
IPersistBookCollection Interface See Also Send Feedback

Overload List

Name | Description
Contains(T) | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from ICollection<(Of <( IPersistBook >)>).)
Contains(String) | Gets whether or not the collection contains the book code.

See Also

IPersistBookCollection Interface
IPersistBookCollection Members
Mincom.LinkOne.Provider.Persist Namespace


Contains Method (String)

[image]

LinkOne WebView API
IPersistBookCollection..::.Contains Method (String)
IPersistBookCollection Interface See Also Send Feedback
Gets whether or not the collection contains the book code.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool Contains(
    string bookCode
)
Visual Basic (Declaration)
Function Contains ( _
    bookCode As String _
) As Boolean
Visual C++
bool Contains(
    String^ bookCode
)

Parameters

bookCode
Type: System..::.String
The book code to check.

Return Value

true if the collection contains the book code, false otherwise.

See Also

IPersistBookCollection Interface
Contains Overload
Mincom.LinkOne.Provider.Persist Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
IPersistBookCollection..::.GetEnumerator Method
IPersistBookCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( IPersistBook >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IPersistBookCollection Interface
IPersistBookCollection Members
Mincom.LinkOne.Provider.Persist Namespace


GetSortedForLanguage Method

[image]

LinkOne WebView API
IPersistBookCollection..::.GetSortedForLanguage Method
IPersistBookCollection Interface See Also Send Feedback
Gets the books sorted by description for the given language.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
IEnumerable<IPersistBook> GetSortedForLanguage(
    string languageCode
)
Visual Basic (Declaration)
Function GetSortedForLanguage ( _
    languageCode As String _
) As IEnumerable(Of IPersistBook)
Visual C++
IEnumerable<IPersistBook^>^ GetSortedForLanguage(
    String^ languageCode
)

Parameters

languageCode
Type: System..::.String
The language code.

Return Value

The books sorted by description for the given language.

See Also

IPersistBookCollection Interface
Mincom.LinkOne.Provider.Persist Namespace


IPersistBookCollection Properties

[image] [image]

LinkOne WebView API
IPersistBookCollection Properties
IPersistBookCollection Interface See Also Send Feedback

The IPersistBookCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPersistBook >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( IPersistBook >)>).)
Item | Gets the IPersistBook with the specified code, or null if not found.

See Also

IPersistBookCollection Interface
Mincom.LinkOne.Provider.Persist Namespace


Item Property

[image]

LinkOne WebView API
IPersistBookCollection..::.Item Property
IPersistBookCollection Interface See Also Send Feedback
Gets the IPersistBook with the specified code, or null if not found.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
IPersistBook this[
    string bookCode
] { get; }
Visual Basic (Declaration)
ReadOnly Default Property Item ( _
    bookCode As String _
) As IPersistBook
Visual C++
property IPersistBook^ default[String^ bookCode] {
    IPersistBook^ get (String^ bookCode);
}

Parameters

bookCode
Type: System..::.String

See Also

IPersistBookCollection Interface
Mincom.LinkOne.Provider.Persist Namespace


IPersistCatalog Interface

[image]

LinkOne WebView API
IPersistCatalog Interface
Members See Also Send Feedback
Implemented by a class to manage catalog persistence.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public interface IPersistCatalog
Visual Basic (Declaration)
Public Interface IPersistCatalog
Visual C++
public interface class IPersistCatalog

See Also

IPersistCatalog Members
Mincom.LinkOne.Provider.Persist Namespace


IPersistCatalog Members

[image] [image]

LinkOne WebView API
IPersistCatalog Members
IPersistCatalog Interface Properties See Also Send Feedback

The IPersistCatalog type exposes the following members.

Properties

Name | Description
Books | Gets the collection of books with no category.
Categories | Gets the collection of categories with no parent category.

See Also

IPersistCatalog Interface
Mincom.LinkOne.Provider.Persist Namespace


IPersistCatalog Properties

[image] [image]

LinkOne WebView API
IPersistCatalog Properties
IPersistCatalog Interface See Also Send Feedback

The IPersistCatalog type exposes the following members.

Properties

Name | Description
Books | Gets the collection of books with no category.
Categories | Gets the collection of categories with no parent category.

See Also

IPersistCatalog Interface
Mincom.LinkOne.Provider.Persist Namespace


Books Property

[image]

LinkOne WebView API
IPersistCatalog..::.Books Property
IPersistCatalog Interface See Also Send Feedback
Gets the collection of books with no category.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
IPersistBookCollection Books { get; }
Visual Basic (Declaration)
ReadOnly Property Books As IPersistBookCollection
Visual C++
property IPersistBookCollection^ Books {
    IPersistBookCollection^ get ();
}

See Also

IPersistCatalog Interface
Mincom.LinkOne.Provider.Persist Namespace


Categories Property

[image]

LinkOne WebView API
IPersistCatalog..::.Categories Property
IPersistCatalog Interface See Also Send Feedback
Gets the collection of categories with no parent category.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
IPersistCategoryCollection Categories { get; }
Visual Basic (Declaration)
ReadOnly Property Categories As IPersistCategoryCollection
Visual C++
property IPersistCategoryCollection^ Categories {
    IPersistCategoryCollection^ get ();
}

See Also

IPersistCatalog Interface
Mincom.LinkOne.Provider.Persist Namespace


IPersistCategory Interface

[image]

LinkOne WebView API
IPersistCategory Interface
Members See Also Send Feedback
Implemented by a class to manage category persistence.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public interface IPersistCategory : IPersistCatalog
Visual Basic (Declaration)
Public Interface IPersistCategory _
    Implements IPersistCatalog
Visual C++
public interface class IPersistCategory : IPersistCatalog

See Also

IPersistCategory Members
Mincom.LinkOne.Provider.Persist Namespace


IPersistCategory Members

[image] [image]

LinkOne WebView API
IPersistCategory Members
IPersistCategory Interface Methods Properties See Also Send Feedback

The IPersistCategory type exposes the following members.

Methods

Name | Description
Compress | Compresses the category.
Expand | Expands the category.
Prepare | Prepares the category for internet delivery.
Remove | Removes the category, including all books and child categories from the filing system.
Sync | Synchronizes the category from any configured synchronization location.

Properties

Name | Description
Books | Gets the collection of books with no category. (Inherited from IPersistCatalog.)
Categories | Gets the collection of categories with no parent category. (Inherited from IPersistCatalog.)
CategoryCode | Gets the category code for the category.
CategoryDescription | Gets the description for the category.
CategoryDescriptionTranslations | Gets the category description translations.

See Also

IPersistCategory Interface
Mincom.LinkOne.Provider.Persist Namespace


IPersistCategory Methods

[image] [image]

LinkOne WebView API
IPersistCategory Methods
IPersistCategory Interface See Also Send Feedback

The IPersistCategory type exposes the following members.

Methods

Name | Description
Compress | Compresses the category.
Expand | Expands the category.
Prepare | Prepares the category for internet delivery.
Remove | Removes the category, including all books and child categories from the filing system.
Sync | Synchronizes the category from any configured synchronization location.

See Also

IPersistCategory Interface
Mincom.LinkOne.Provider.Persist Namespace


Compress Method

[image]

LinkOne WebView API
IPersistCategory..::.Compress Method
IPersistCategory Interface See Also Send Feedback
Compresses the category.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool Compress()
Visual Basic (Declaration)
Function Compress As Boolean
Visual C++
bool Compress()

Return Value

true if successful, or false if an error or if cancelled.

See Also

IPersistCategory Interface
Mincom.LinkOne.Provider.Persist Namespace


Expand Method

[image]

LinkOne WebView API
IPersistCategory..::.Expand Method
IPersistCategory Interface See Also Send Feedback
Expands the category.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool Expand()
Visual Basic (Declaration)
Function Expand As Boolean
Visual C++
bool Expand()

Return Value

true if successful, or false if an error or if cancelled.

See Also

IPersistCategory Interface
Mincom.LinkOne.Provider.Persist Namespace


Prepare Method

[image]

LinkOne WebView API
IPersistCategory..::.Prepare Method
IPersistCategory Interface See Also Send Feedback
Prepares the category for internet delivery.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool Prepare()
Visual Basic (Declaration)
Function Prepare As Boolean
Visual C++
bool Prepare()

Return Value

true if successful, or false if an error or if cancelled.

See Also

IPersistCategory Interface
Mincom.LinkOne.Provider.Persist Namespace


Remove Method

[image]

LinkOne WebView API
IPersistCategory..::.Remove Method
IPersistCategory Interface See Also Send Feedback
Removes the category, including all books and child categories from the filing system.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
void Remove()
Visual Basic (Declaration)
Sub Remove
Visual C++
void Remove()

See Also

IPersistCategory Interface
Mincom.LinkOne.Provider.Persist Namespace


Sync Method

[image]

LinkOne WebView API
IPersistCategory..::.Sync Method
IPersistCategory Interface See Also Send Feedback
Synchronizes the category from any configured synchronization location.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool Sync()
Visual Basic (Declaration)
Function Sync As Boolean
Visual C++
bool Sync()

Return Value

true if successful, or false if an error or if cancelled.

See Also

IPersistCategory Interface
Mincom.LinkOne.Provider.Persist Namespace


IPersistCategory Properties

[image] [image]

LinkOne WebView API
IPersistCategory Properties
IPersistCategory Interface See Also Send Feedback

The IPersistCategory type exposes the following members.

Properties

Name | Description
Books | Gets the collection of books with no category. (Inherited from IPersistCatalog.)
Categories | Gets the collection of categories with no parent category. (Inherited from IPersistCatalog.)
CategoryCode | Gets the category code for the category.
CategoryDescription | Gets the description for the category.
CategoryDescriptionTranslations | Gets the category description translations.

See Also

IPersistCategory Interface
Mincom.LinkOne.Provider.Persist Namespace


CategoryCode Property

[image]

LinkOne WebView API
IPersistCategory..::.CategoryCode Property
IPersistCategory Interface See Also Send Feedback
Gets the category code for the category.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
string CategoryCode { get; }
Visual Basic (Declaration)
ReadOnly Property CategoryCode As String
Visual C++
property String^ CategoryCode {
    String^ get ();
}

See Also

IPersistCategory Interface
Mincom.LinkOne.Provider.Persist Namespace


CategoryDescription Property

[image]

LinkOne WebView API
IPersistCategory..::.CategoryDescription Property
IPersistCategory Interface See Also Send Feedback
Gets the description for the category.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
string CategoryDescription { get; }
Visual Basic (Declaration)
ReadOnly Property CategoryDescription As String
Visual C++
property String^ CategoryDescription {
    String^ get ();
}

See Also

IPersistCategory Interface
Mincom.LinkOne.Provider.Persist Namespace


CategoryDescriptionTranslations Property

[image]

LinkOne WebView API
IPersistCategory..::.CategoryDescriptionTranslations Property
IPersistCategory Interface See Also Send Feedback
Gets the category description translations.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
IDictionary<string, string> CategoryDescriptionTranslations { get; }
Visual Basic (Declaration)
ReadOnly Property CategoryDescriptionTranslations As IDictionary(Of String, String)
Visual C++
property IDictionary<String^, String^>^ CategoryDescriptionTranslations {
    IDictionary<String^, String^>^ get ();
}

See Also

IPersistCategory Interface
Mincom.LinkOne.Provider.Persist Namespace


IPersistCategoryCollection Interface

[image]

LinkOne WebView API
IPersistCategoryCollection Interface
Members See Also Send Feedback
Implemented by a class to manage category collection persistence.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public interface IPersistCategoryCollection : ICollection<IPersistCategory>,
    IEnumerable<IPersistCategory>, IEnumerable
Visual Basic (Declaration)
Public Interface IPersistCategoryCollection _
    Implements ICollection(Of IPersistCategory), IEnumerable(Of IPersistCategory),  _
    IEnumerable
Visual C++
public interface class IPersistCategoryCollection : ICollection<IPersistCategory^>,
    IEnumerable<IPersistCategory^>, IEnumerable

See Also

IPersistCategoryCollection Members
Mincom.LinkOne.Provider.Persist Namespace


IPersistCategoryCollection Members

[image] [image]

LinkOne WebView API
IPersistCategoryCollection Members
IPersistCategoryCollection Interface Methods Properties See Also Send Feedback

The IPersistCategoryCollection type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPersistCategory >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPersistCategory >)>).)
Contains | Overloaded.
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( IPersistCategory >)>).)
GetEnumerator | Overloaded.
GetSortedForLanguage | Gets the categories sorted by description for the given language.
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPersistCategory >)>).)

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPersistCategory >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( IPersistCategory >)>).)
Item | Gets the IPersistCategory with the specified code, or null if not found.

See Also

IPersistCategoryCollection Interface
Mincom.LinkOne.Provider.Persist Namespace


IPersistCategoryCollection Methods

[image] [image]

LinkOne WebView API
IPersistCategoryCollection Methods
IPersistCategoryCollection Interface See Also Send Feedback

The IPersistCategoryCollection type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPersistCategory >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPersistCategory >)>).)
Contains | Overloaded.
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( IPersistCategory >)>).)
GetEnumerator | Overloaded.
GetSortedForLanguage | Gets the categories sorted by description for the given language.
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPersistCategory >)>).)

See Also

IPersistCategoryCollection Interface
Mincom.LinkOne.Provider.Persist Namespace


Contains Method

[image] [image]

LinkOne WebView API
IPersistCategoryCollection..::.Contains Method
IPersistCategoryCollection Interface See Also Send Feedback

Overload List

Name | Description
Contains(T) | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from ICollection<(Of <( IPersistCategory >)>).)
Contains(String) | Gets whether or not the collection contains the category code.

See Also

IPersistCategoryCollection Interface
IPersistCategoryCollection Members
Mincom.LinkOne.Provider.Persist Namespace


Contains Method (String)

[image]

LinkOne WebView API
IPersistCategoryCollection..::.Contains Method (String)
IPersistCategoryCollection Interface See Also Send Feedback
Gets whether or not the collection contains the category code.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool Contains(
    string categoryCode
)
Visual Basic (Declaration)
Function Contains ( _
    categoryCode As String _
) As Boolean
Visual C++
bool Contains(
    String^ categoryCode
)

Parameters

categoryCode
Type: System..::.String
The category code to check.

Return Value

true if the collection contains the category code, false otherwise.

See Also

IPersistCategoryCollection Interface
Contains Overload
Mincom.LinkOne.Provider.Persist Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
IPersistCategoryCollection..::.GetEnumerator Method
IPersistCategoryCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( IPersistCategory >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IPersistCategoryCollection Interface
IPersistCategoryCollection Members
Mincom.LinkOne.Provider.Persist Namespace


GetSortedForLanguage Method

[image]

LinkOne WebView API
IPersistCategoryCollection..::.GetSortedForLanguage Method
IPersistCategoryCollection Interface See Also Send Feedback
Gets the categories sorted by description for the given language.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
IEnumerable<IPersistCategory> GetSortedForLanguage(
    string languageCode
)
Visual Basic (Declaration)
Function GetSortedForLanguage ( _
    languageCode As String _
) As IEnumerable(Of IPersistCategory)
Visual C++
IEnumerable<IPersistCategory^>^ GetSortedForLanguage(
    String^ languageCode
)

Parameters

languageCode
Type: System..::.String
The language code.

Return Value

The categories sorted by description for the given language.

See Also

IPersistCategoryCollection Interface
Mincom.LinkOne.Provider.Persist Namespace


IPersistCategoryCollection Properties

[image] [image]

LinkOne WebView API
IPersistCategoryCollection Properties
IPersistCategoryCollection Interface See Also Send Feedback

The IPersistCategoryCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPersistCategory >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( IPersistCategory >)>).)
Item | Gets the IPersistCategory with the specified code, or null if not found.

See Also

IPersistCategoryCollection Interface
Mincom.LinkOne.Provider.Persist Namespace


Item Property

[image]

LinkOne WebView API
IPersistCategoryCollection..::.Item Property
IPersistCategoryCollection Interface See Also Send Feedback
Gets the IPersistCategory with the specified code, or null if not found.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
IPersistCategory this[
    string categoryCode
] { get; }
Visual Basic (Declaration)
ReadOnly Default Property Item ( _
    categoryCode As String _
) As IPersistCategory
Visual C++
property IPersistCategory^ default[String^ categoryCode] {
    IPersistCategory^ get (String^ categoryCode);
}

Parameters

categoryCode
Type: System..::.String

See Also

IPersistCategoryCollection Interface
Mincom.LinkOne.Provider.Persist Namespace


IPersistLibrary Interface

[image]

LinkOne WebView API
IPersistLibrary Interface
Members See Also Send Feedback
Implemented by a class to manage library persistence.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public interface IPersistLibrary
Visual Basic (Declaration)
Public Interface IPersistLibrary
Visual C++
public interface class IPersistLibrary

See Also

IPersistLibrary Members
Mincom.LinkOne.Provider.Persist Namespace


IPersistLibrary Members

[image] [image]

LinkOne WebView API
IPersistLibrary Members
IPersistLibrary Interface Methods Properties See Also Send Feedback

The IPersistLibrary type exposes the following members.

Methods

Name | Description
CanInstallBooks | Determines whether this instance can install the specified source books.
ClearCache | Clears any cached book content in the library.
Compress | Compresses the library.
DecreasePriority | Decreases the lbrary priority by moving it one position after in the managed library collection.
Expand | Expands the library.
IncreasePriority | Increases the lbrary priority by moving it one position before in the managed library collection.
InstallBooks | Installs the specified source books, .
Prepare | Prepares the library for internet delivery.
Refresh | Refreshes the library.
Remove | Removes the library from the managed library collection.
Save | Saves the library if it has changed. Also saves the publishers in the library.
Sync | Synchronizes the library from any configured synchronization location.

Properties

Name | Description
Disabled | Gets or sets whether this library is disabled.
LibraryType | Gets or sets the type of the library.
Location | Gets the unresolved directory location of the library.
Manager | Gets the manager of the library.
Offline | Gets whether or not this library is online or offline.
Publishers | Gets the list of publishers for this library.
PurgeIntervalMinutes | Gets or sets the purge interval in minutes.
ResolvedLocation | Gets the resolved directory location of the library.
SyncLocation | Gets or sets the location to synchronize this library to.
SyncType | Gets or sets the type of the Sync()()() performed.
UpdateIntervalMinutes | Gets or sets the update interval in minutes.
VersionNumber | Gets the Library's Version Number. -1 means there are 1 or books with invalid book versions 0 means it is a mix of pre 5.1 and 5.1/post 5.1 books 6 means it is all 5.1/post 5.1 books otherwise we don't care and it returns the last book version checked.

See Also

IPersistLibrary Interface
Mincom.LinkOne.Provider.Persist Namespace


IPersistLibrary Methods

[image] [image]

LinkOne WebView API
IPersistLibrary Methods
IPersistLibrary Interface See Also Send Feedback

The IPersistLibrary type exposes the following members.

Methods

Name | Description
CanInstallBooks | Determines whether this instance can install the specified source books.
ClearCache | Clears any cached book content in the library.
Compress | Compresses the library.
DecreasePriority | Decreases the lbrary priority by moving it one position after in the managed library collection.
Expand | Expands the library.
IncreasePriority | Increases the lbrary priority by moving it one position before in the managed library collection.
InstallBooks | Installs the specified source books, .
Prepare | Prepares the library for internet delivery.
Refresh | Refreshes the library.
Remove | Removes the library from the managed library collection.
Save | Saves the library if it has changed. Also saves the publishers in the library.
Sync | Synchronizes the library from any configured synchronization location.

See Also

IPersistLibrary Interface
Mincom.LinkOne.Provider.Persist Namespace


CanInstallBooks Method

[image]

LinkOne WebView API
IPersistLibrary..::.CanInstallBooks Method
IPersistLibrary Interface See Also Send Feedback
Determines whether this instance can install the specified source books.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool CanInstallBooks(
    IEnumerable<IPersistBook> sourceBooks
)
Visual Basic (Declaration)
Function CanInstallBooks ( _
    sourceBooks As IEnumerable(Of IPersistBook) _
) As Boolean
Visual C++
bool CanInstallBooks(
    IEnumerable<IPersistBook^>^ sourceBooks
)

Parameters

sourceBooks
Type: System.Collections.Generic..::.IEnumerable<(Of <( IPersistBook >)>)
The source books.

Return Value

true if this instance can install the specified source books; otherwise, false.

Remarks

The following checks are performed before attemping to install books:
soureBooks is not null sourceBooks are from the same library
If the above passes, the next level of validation checks the LibraryType of this instance. Books cannot be installed to a Remote. If the LibraryType is an Updated, the source LibraryType must not be a Local library, and the source must be from the same Uri as this instance.

See Also

IPersistLibrary Interface
Mincom.LinkOne.Provider.Persist Namespace


ClearCache Method

[image]

LinkOne WebView API
IPersistLibrary..::.ClearCache Method
IPersistLibrary Interface See Also Send Feedback
Clears any cached book content in the library.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
void ClearCache()
Visual Basic (Declaration)
Sub ClearCache
Visual C++
void ClearCache()

See Also

IPersistLibrary Interface
Mincom.LinkOne.Provider.Persist Namespace


Compress Method

[image]

LinkOne WebView API
IPersistLibrary..::.Compress Method
IPersistLibrary Interface See Also Send Feedback
Compresses the library.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool Compress()
Visual Basic (Declaration)
Function Compress As Boolean
Visual C++
bool Compress()

Return Value

true if successful, or false if an error or if cancelled.

See Also

IPersistLibrary Interface
Mincom.LinkOne.Provider.Persist Namespace


DecreasePriority Method

[image]

LinkOne WebView API
IPersistLibrary..::.DecreasePriority Method
IPersistLibrary Interface See Also Send Feedback
Decreases the lbrary priority by moving it one position after in the managed library collection.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
void DecreasePriority()
Visual Basic (Declaration)
Sub DecreasePriority
Visual C++
void DecreasePriority()

See Also

IPersistLibrary Interface
Mincom.LinkOne.Provider.Persist Namespace


Expand Method

[image]

LinkOne WebView API
IPersistLibrary..::.Expand Method
IPersistLibrary Interface See Also Send Feedback
Expands the library.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool Expand()
Visual Basic (Declaration)
Function Expand As Boolean
Visual C++
bool Expand()

Return Value

true if successful, or false if an error or if cancelled.

See Also

IPersistLibrary Interface
Mincom.LinkOne.Provider.Persist Namespace


IncreasePriority Method

[image]

LinkOne WebView API
IPersistLibrary..::.IncreasePriority Method
IPersistLibrary Interface See Also Send Feedback
Increases the lbrary priority by moving it one position before in the managed library collection.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
void IncreasePriority()
Visual Basic (Declaration)
Sub IncreasePriority
Visual C++
void IncreasePriority()

See Also

IPersistLibrary Interface
Mincom.LinkOne.Provider.Persist Namespace


InstallBooks Method

[image]

LinkOne WebView API
IPersistLibrary..::.InstallBooks Method
IPersistLibrary Interface See Also Send Feedback
Installs the specified source books, .

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool InstallBooks(
    string sourceLibraryLocation,
    IList<KeyValuePair<string, string>> sourceBooks,
    bool fullDownload
)
Visual Basic (Declaration)
Function InstallBooks ( _
    sourceLibraryLocation As String, _
    sourceBooks As IList(Of KeyValuePair(Of String, String)), _
    fullDownload As Boolean _
) As Boolean
Visual C++
bool InstallBooks(
    String^ sourceLibraryLocation,
    IList<KeyValuePair<String^, String^>>^ sourceBooks,
    bool fullDownload
)

Parameters

sourceLibraryLocation
Type: System..::.String
The source library location.
sourceBooks
Type: System.Collections.Generic..::.IList<(Of <(KeyValuePair<(Of <(String, String>)>)>)>)
The source books.
fullDownload
Type: System..::.Boolean
false for a minimum install when the library is an Updated library; otherwise always a full download.

Return Value

True if successful, or false if an error or if cancelled.

See Also

IPersistLibrary Interface
Mincom.LinkOne.Provider.Persist Namespace
IPersistLibrary..::.CanInstallBooks(IEnumerable<(Of <(IPersistBook>)>))


Prepare Method

[image]

LinkOne WebView API
IPersistLibrary..::.Prepare Method
IPersistLibrary Interface See Also Send Feedback
Prepares the library for internet delivery.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool Prepare(
    bool includeBookContent
)
Visual Basic (Declaration)
Function Prepare ( _
    includeBookContent As Boolean _
) As Boolean
Visual C++
bool Prepare(
    bool includeBookContent
)

Parameters

includeBookContent
Type: System..::.Boolean
true to also prepare book content.

Return Value

true if successful, or false if an error or if cancelled.

See Also

IPersistLibrary Interface
Mincom.LinkOne.Provider.Persist Namespace


Refresh Method

[image]

LinkOne WebView API
IPersistLibrary..::.Refresh Method
IPersistLibrary Interface See Also Send Feedback
Refreshes the library.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
void Refresh()
Visual Basic (Declaration)
Sub Refresh
Visual C++
void Refresh()

See Also

IPersistLibrary Interface
Mincom.LinkOne.Provider.Persist Namespace


Remove Method

[image]

LinkOne WebView API
IPersistLibrary..::.Remove Method
IPersistLibrary Interface See Also Send Feedback
Removes the library from the managed library collection.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
void Remove()
Visual Basic (Declaration)
Sub Remove
Visual C++
void Remove()

See Also

IPersistLibrary Interface
Mincom.LinkOne.Provider.Persist Namespace


Save Method

[image]

LinkOne WebView API
IPersistLibrary..::.Save Method
IPersistLibrary Interface See Also Send Feedback
Saves the library if it has changed. Also saves the publishers in the library.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
void Save()
Visual Basic (Declaration)
Sub Save
Visual C++
void Save()

See Also

IPersistLibrary Interface
Mincom.LinkOne.Provider.Persist Namespace


Sync Method

[image]

LinkOne WebView API
IPersistLibrary..::.Sync Method
IPersistLibrary Interface See Also Send Feedback
Synchronizes the library from any configured synchronization location.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool Sync()
Visual Basic (Declaration)
Function Sync As Boolean
Visual C++
bool Sync()

Return Value

true if successful, or false if an error or if cancelled.

See Also

IPersistLibrary Interface
Mincom.LinkOne.Provider.Persist Namespace


IPersistLibrary Properties

[image] [image]

LinkOne WebView API
IPersistLibrary Properties
IPersistLibrary Interface See Also Send Feedback

The IPersistLibrary type exposes the following members.

Properties

Name | Description
Disabled | Gets or sets whether this library is disabled.
LibraryType | Gets or sets the type of the library.
Location | Gets the unresolved directory location of the library.
Manager | Gets the manager of the library.
Offline | Gets whether or not this library is online or offline.
Publishers | Gets the list of publishers for this library.
PurgeIntervalMinutes | Gets or sets the purge interval in minutes.
ResolvedLocation | Gets the resolved directory location of the library.
SyncLocation | Gets or sets the location to synchronize this library to.
SyncType | Gets or sets the type of the Sync()()() performed.
UpdateIntervalMinutes | Gets or sets the update interval in minutes.
VersionNumber | Gets the Library's Version Number. -1 means there are 1 or books with invalid book versions 0 means it is a mix of pre 5.1 and 5.1/post 5.1 books 6 means it is all 5.1/post 5.1 books otherwise we don't care and it returns the last book version checked.

See Also

IPersistLibrary Interface
Mincom.LinkOne.Provider.Persist Namespace


Disabled Property

[image]

LinkOne WebView API
IPersistLibrary..::.Disabled Property
IPersistLibrary Interface See Also Send Feedback
Gets or sets whether this library is disabled.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool Disabled { get; set; }
Visual Basic (Declaration)
Property Disabled As Boolean
Visual C++
property bool Disabled {
    bool get ();
    void set (bool value);
}

See Also

IPersistLibrary Interface
Mincom.LinkOne.Provider.Persist Namespace


LibraryType Property

[image]

LinkOne WebView API
IPersistLibrary..::.LibraryType Property
IPersistLibrary Interface See Also Send Feedback
Gets or sets the type of the library.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
LibraryType LibraryType { get; set; }
Visual Basic (Declaration)
Property LibraryType As LibraryType
Visual C++
property LibraryType LibraryType {
    LibraryType get ();
    void set (LibraryType value);
}

See Also

IPersistLibrary Interface
Mincom.LinkOne.Provider.Persist Namespace


Location Property

[image]

LinkOne WebView API
IPersistLibrary..::.Location Property
IPersistLibrary Interface See Also Send Feedback
Gets the unresolved directory location of the library.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
string Location { get; }
Visual Basic (Declaration)
ReadOnly Property Location As String
Visual C++
property String^ Location {
    String^ get ();
}

See Also

IPersistLibrary Interface
Mincom.LinkOne.Provider.Persist Namespace


Manager Property

[image]

LinkOne WebView API
IPersistLibrary..::.Manager Property
IPersistLibrary Interface See Also Send Feedback
Gets the manager of the library.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
IPersistManager Manager { get; }
Visual Basic (Declaration)
ReadOnly Property Manager As IPersistManager
Visual C++
property IPersistManager^ Manager {
    IPersistManager^ get ();
}

See Also

IPersistLibrary Interface
Mincom.LinkOne.Provider.Persist Namespace


Offline Property

[image]

LinkOne WebView API
IPersistLibrary..::.Offline Property
IPersistLibrary Interface See Also Send Feedback
Gets whether or not this library is online or offline.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool Offline { get; }
Visual Basic (Declaration)
ReadOnly Property Offline As Boolean
Visual C++
property bool Offline {
    bool get ();
}

Remarks

A library is offline if its directory can't be resolved. For example if a library on a CD has the CD removed from the drive the library will become "offline".
A library is assumed to be online untill it is loaded.

See Also

IPersistLibrary Interface
Mincom.LinkOne.Provider.Persist Namespace


Publishers Property

[image]

LinkOne WebView API
IPersistLibrary..::.Publishers Property
IPersistLibrary Interface See Also Send Feedback
Gets the list of publishers for this library.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
IPersistPublisherCollection Publishers { get; }
Visual Basic (Declaration)
ReadOnly Property Publishers As IPersistPublisherCollection
Visual C++
property IPersistPublisherCollection^ Publishers {
    IPersistPublisherCollection^ get ();
}

See Also

IPersistLibrary Interface
Mincom.LinkOne.Provider.Persist Namespace


PurgeIntervalMinutes Property

[image]

LinkOne WebView API
IPersistLibrary..::.PurgeIntervalMinutes Property
IPersistLibrary Interface See Also Send Feedback
Gets or sets the purge interval in minutes.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
int PurgeIntervalMinutes { get; set; }
Visual Basic (Declaration)
Property PurgeIntervalMinutes As Integer
Visual C++
property int PurgeIntervalMinutes {
    int get ();
    void set (int value);
}

Remarks

A value of 0 means that books / publishers which are no longer on the server will be purged immediately.
A value < 0 means that publishers / books which are no longer on the server will not be purged.

See Also

IPersistLibrary Interface
Mincom.LinkOne.Provider.Persist Namespace


ResolvedLocation Property

[image]

LinkOne WebView API
IPersistLibrary..::.ResolvedLocation Property
IPersistLibrary Interface See Also Send Feedback
Gets the resolved directory location of the library.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
string ResolvedLocation { get; }
Visual Basic (Declaration)
ReadOnly Property ResolvedLocation As String
Visual C++
property String^ ResolvedLocation {
    String^ get ();
}

See Also

IPersistLibrary Interface
Mincom.LinkOne.Provider.Persist Namespace


SyncLocation Property

[image]

LinkOne WebView API
IPersistLibrary..::.SyncLocation Property
IPersistLibrary Interface See Also Send Feedback
Gets or sets the location to synchronize this library to.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
string SyncLocation { get; set; }
Visual Basic (Declaration)
Property SyncLocation As String
Visual C++
property String^ SyncLocation {
    String^ get ();
    void set (String^ value);
}

See Also

IPersistLibrary Interface
Mincom.LinkOne.Provider.Persist Namespace


SyncType Property

[image]

LinkOne WebView API
IPersistLibrary..::.SyncType Property
IPersistLibrary Interface See Also Send Feedback
Gets or sets the type of the Sync()()() performed.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
SyncType SyncType { get; set; }
Visual Basic (Declaration)
Property SyncType As SyncType
Visual C++
property SyncType SyncType {
    SyncType get ();
    void set (SyncType value);
}

See Also

IPersistLibrary Interface
Mincom.LinkOne.Provider.Persist Namespace


UpdateIntervalMinutes Property

[image]

LinkOne WebView API
IPersistLibrary..::.UpdateIntervalMinutes Property
IPersistLibrary Interface See Also Send Feedback
Gets or sets the update interval in minutes.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
int UpdateIntervalMinutes { get; set; }
Visual Basic (Declaration)
Property UpdateIntervalMinutes As Integer
Visual C++
property int UpdateIntervalMinutes {
    int get ();
    void set (int value);
}

See Also

IPersistLibrary Interface
Mincom.LinkOne.Provider.Persist Namespace


VersionNumber Property

[image]

LinkOne WebView API
IPersistLibrary..::.VersionNumber Property
IPersistLibrary Interface See Also Send Feedback
Gets the Library's Version Number. -1 means there are 1 or books with invalid book versions 0 means it is a mix of pre 5.1 and 5.1/post 5.1 books 6 means it is all 5.1/post 5.1 books otherwise we don't care and it returns the last book version checked.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
int VersionNumber { get; }
Visual Basic (Declaration)
ReadOnly Property VersionNumber As Integer
Visual C++
property int VersionNumber {
    int get ();
}

See Also

IPersistLibrary Interface
Mincom.LinkOne.Provider.Persist Namespace


IPersistLibraryCollection Interface

[image]

LinkOne WebView API
IPersistLibraryCollection Interface
Members See Also Send Feedback
Implemented by a class to manage library collection persistence.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public interface IPersistLibraryCollection : ICollection<IPersistLibrary>,
    IEnumerable<IPersistLibrary>, IEnumerable
Visual Basic (Declaration)
Public Interface IPersistLibraryCollection _
    Implements ICollection(Of IPersistLibrary), IEnumerable(Of IPersistLibrary),  _
    IEnumerable
Visual C++
public interface class IPersistLibraryCollection : ICollection<IPersistLibrary^>,
    IEnumerable<IPersistLibrary^>, IEnumerable

See Also

IPersistLibraryCollection Members
Mincom.LinkOne.Provider.Persist Namespace


IPersistLibraryCollection Members

[image] [image]

LinkOne WebView API
IPersistLibraryCollection Members
IPersistLibraryCollection Interface Methods Properties See Also Send Feedback

The IPersistLibraryCollection type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPersistLibrary >)>).)
Contains | Overloaded.
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( IPersistLibrary >)>).)
GetEnumerator | Overloaded.
Remove | Overloaded.

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPersistLibrary >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( IPersistLibrary >)>).)
Item | Gets the IPersistLibrary with the specified location, or null if not found.

See Also

IPersistLibraryCollection Interface
Mincom.LinkOne.Provider.Persist Namespace


IPersistLibraryCollection Methods

[image] [image]

LinkOne WebView API
IPersistLibraryCollection Methods
IPersistLibraryCollection Interface See Also Send Feedback

The IPersistLibraryCollection type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPersistLibrary >)>).)
Contains | Overloaded.
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( IPersistLibrary >)>).)
GetEnumerator | Overloaded.
Remove | Overloaded.

See Also

IPersistLibraryCollection Interface
Mincom.LinkOne.Provider.Persist Namespace


Add Method

[image] [image]

LinkOne WebView API
IPersistLibraryCollection..::.Add Method
IPersistLibraryCollection Interface See Also Send Feedback

Overload List

Name | Description
Add(T) | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPersistLibrary >)>).)
Add(String) | Adds a Library for the given location.

See Also

IPersistLibraryCollection Interface
IPersistLibraryCollection Members
Mincom.LinkOne.Provider.Persist Namespace


Add Method (String)

[image]

LinkOne WebView API
IPersistLibraryCollection..::.Add Method (String)
IPersistLibraryCollection Interface See Also Send Feedback
Adds a Library for the given location.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
IPersistLibrary Add(
    string location
)
Visual Basic (Declaration)
Function Add ( _
    location As String _
) As IPersistLibrary
Visual C++
IPersistLibrary^ Add(
    String^ location
)

Parameters

location
Type: System..::.String
The location of the library

Return Value

The added library.

See Also

IPersistLibraryCollection Interface
Add Overload
Mincom.LinkOne.Provider.Persist Namespace


Contains Method

[image] [image]

LinkOne WebView API
IPersistLibraryCollection..::.Contains Method
IPersistLibraryCollection Interface See Also Send Feedback

Overload List

Name | Description
Contains(T) | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from ICollection<(Of <( IPersistLibrary >)>).)
Contains(String) | Gets whether or not the collection contains the library location.

See Also

IPersistLibraryCollection Interface
IPersistLibraryCollection Members
Mincom.LinkOne.Provider.Persist Namespace


Contains Method (String)

[image]

LinkOne WebView API
IPersistLibraryCollection..::.Contains Method (String)
IPersistLibraryCollection Interface See Also Send Feedback
Gets whether or not the collection contains the library location.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool Contains(
    string location
)
Visual Basic (Declaration)
Function Contains ( _
    location As String _
) As Boolean
Visual C++
bool Contains(
    String^ location
)

Parameters

location
Type: System..::.String
The library location to check.

Return Value

true if the collection contains the library location, false otherwise.

See Also

IPersistLibraryCollection Interface
Contains Overload
Mincom.LinkOne.Provider.Persist Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
IPersistLibraryCollection..::.GetEnumerator Method
IPersistLibraryCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( IPersistLibrary >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IPersistLibraryCollection Interface
IPersistLibraryCollection Members
Mincom.LinkOne.Provider.Persist Namespace


Remove Method

[image] [image]

LinkOne WebView API
IPersistLibraryCollection..::.Remove Method
IPersistLibraryCollection Interface See Also Send Feedback

Overload List

Name | Description
Remove(T) | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPersistLibrary >)>).)
Remove(String) | Removes a lbrary at the given location.

See Also

IPersistLibraryCollection Interface
IPersistLibraryCollection Members
Mincom.LinkOne.Provider.Persist Namespace


Remove Method (String)

[image]

LinkOne WebView API
IPersistLibraryCollection..::.Remove Method (String)
IPersistLibraryCollection Interface See Also Send Feedback
Removes a lbrary at the given location.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool Remove(
    string location
)
Visual Basic (Declaration)
Function Remove ( _
    location As String _
) As Boolean
Visual C++
bool Remove(
    String^ location
)

Parameters

location
Type: System..::.String
The location of the library to remove.

Return Value

true if the library was removed, false otherwise.

See Also

IPersistLibraryCollection Interface
Remove Overload
Mincom.LinkOne.Provider.Persist Namespace


IPersistLibraryCollection Properties

[image] [image]

LinkOne WebView API
IPersistLibraryCollection Properties
IPersistLibraryCollection Interface See Also Send Feedback

The IPersistLibraryCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPersistLibrary >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( IPersistLibrary >)>).)
Item | Gets the IPersistLibrary with the specified location, or null if not found.

See Also

IPersistLibraryCollection Interface
Mincom.LinkOne.Provider.Persist Namespace


Item Property

[image]

LinkOne WebView API
IPersistLibraryCollection..::.Item Property
IPersistLibraryCollection Interface See Also Send Feedback
Gets the IPersistLibrary with the specified location, or null if not found.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
IPersistLibrary this[
    string location
] { get; }
Visual Basic (Declaration)
ReadOnly Default Property Item ( _
    location As String _
) As IPersistLibrary
Visual C++
property IPersistLibrary^ default[String^ location] {
    IPersistLibrary^ get (String^ location);
}

Parameters

location
Type: System..::.String

See Also

IPersistLibraryCollection Interface
Mincom.LinkOne.Provider.Persist Namespace


IPersistManager Interface

[image]

LinkOne WebView API
IPersistManager Interface
Members See Also Send Feedback
Implemented by a class to manage persistence.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public interface IPersistManager
Visual Basic (Declaration)
Public Interface IPersistManager
Visual C++
public interface class IPersistManager

See Also

IPersistManager Members
Mincom.LinkOne.Provider.Persist Namespace


IPersistManager Members

[image] [image]

LinkOne WebView API
IPersistManager Members
IPersistManager Interface Methods Properties See Also Send Feedback

The IPersistManager type exposes the following members.

Methods

Name | Description
Compress | Compresses all content in the provider.
Expand | Expands all content in the provider.
InstallBooks | Installs the given books to the destination library.
Prepare | Prepares all libraries, publishers and books.
Refresh | Refreshes all libraries.
Save | Saves any changes made.
Sync | Synchronizes all libraries, publishers and books.

Properties

Name | Description
Libraries | Gets the libraries.
Provider | Gets the provider.
ReportingLevel | Get or sets the reporting level for updates and prepares.
Syncing | Gets or sets the manager is used for synncing or not.

See Also

IPersistManager Interface
Mincom.LinkOne.Provider.Persist Namespace


IPersistManager Methods

[image] [image]

LinkOne WebView API
IPersistManager Methods
IPersistManager Interface See Also Send Feedback

The IPersistManager type exposes the following members.

Methods

Name | Description
Compress | Compresses all content in the provider.
Expand | Expands all content in the provider.
InstallBooks | Installs the given books to the destination library.
Prepare | Prepares all libraries, publishers and books.
Refresh | Refreshes all libraries.
Save | Saves any changes made.
Sync | Synchronizes all libraries, publishers and books.

See Also

IPersistManager Interface
Mincom.LinkOne.Provider.Persist Namespace


Compress Method

[image]

LinkOne WebView API
IPersistManager..::.Compress Method
IPersistManager Interface See Also Send Feedback
Compresses all content in the provider.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool Compress()
Visual Basic (Declaration)
Function Compress As Boolean
Visual C++
bool Compress()

Return Value

true if successful, or false if an error or if cancelled.

See Also

IPersistManager Interface
Mincom.LinkOne.Provider.Persist Namespace


Expand Method

[image]

LinkOne WebView API
IPersistManager..::.Expand Method
IPersistManager Interface See Also Send Feedback
Expands all content in the provider.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool Expand()
Visual Basic (Declaration)
Function Expand As Boolean
Visual C++
bool Expand()

Return Value

true if successful, or false if an error or if cancelled.

See Also

IPersistManager Interface
Mincom.LinkOne.Provider.Persist Namespace


InstallBooks Method

[image]

LinkOne WebView API
IPersistManager..::.InstallBooks Method
IPersistManager Interface See Also Send Feedback
Installs the given books to the destination library.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool InstallBooks(
    string sourceLibraryLocation,
    string destinationLibraryLocation,
    IList<KeyValuePair<string, string>> sourceBooks,
    bool fullDownload
)
Visual Basic (Declaration)
Function InstallBooks ( _
    sourceLibraryLocation As String, _
    destinationLibraryLocation As String, _
    sourceBooks As IList(Of KeyValuePair(Of String, String)), _
    fullDownload As Boolean _
) As Boolean
Visual C++
bool InstallBooks(
    String^ sourceLibraryLocation,
    String^ destinationLibraryLocation,
    IList<KeyValuePair<String^, String^>>^ sourceBooks,
    bool fullDownload
)

Parameters

sourceLibraryLocation
Type: System..::.String
The source library location.
destinationLibraryLocation
Type: System..::.String
The destination library location.
sourceBooks
Type: System.Collections.Generic..::.IList<(Of <(KeyValuePair<(Of <(String, String>)>)>)>)
The source books.
fullDownload
Type: System..::.Boolean
false for a minimum install when the destination library is an Updated library; otherwise always a full download.

Return Value

true if successful, or false if an error or if cancelled.

Exceptions

Exception | Condition
System..::.ArgumentException | The source or destination libraries are null, or Empty()()().
System..::.NotSupportedException | The books are not valid for the destination library.

See Also

IPersistManager Interface
Mincom.LinkOne.Provider.Persist Namespace


Prepare Method

[image]

LinkOne WebView API
IPersistManager..::.Prepare Method
IPersistManager Interface See Also Send Feedback
Prepares all libraries, publishers and books.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool Prepare(
    bool includeBookContent
)
Visual Basic (Declaration)
Function Prepare ( _
    includeBookContent As Boolean _
) As Boolean
Visual C++
bool Prepare(
    bool includeBookContent
)

Parameters

includeBookContent
Type: System..::.Boolean
true to also prepare book content.

Return Value

true if successful, or false if an error or if cancelled.

See Also

IPersistManager Interface
Mincom.LinkOne.Provider.Persist Namespace


Refresh Method

[image]

LinkOne WebView API
IPersistManager..::.Refresh Method
IPersistManager Interface See Also Send Feedback
Refreshes all libraries.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
void Refresh()
Visual Basic (Declaration)
Sub Refresh
Visual C++
void Refresh()

See Also

IPersistManager Interface
Mincom.LinkOne.Provider.Persist Namespace


Save Method

[image]

LinkOne WebView API
IPersistManager..::.Save Method
IPersistManager Interface See Also Send Feedback
Saves any changes made.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
void Save()
Visual Basic (Declaration)
Sub Save
Visual C++
void Save()

See Also

IPersistManager Interface
Mincom.LinkOne.Provider.Persist Namespace


Sync Method

[image]

LinkOne WebView API
IPersistManager..::.Sync Method
IPersistManager Interface See Also Send Feedback
Synchronizes all libraries, publishers and books.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool Sync()
Visual Basic (Declaration)
Function Sync As Boolean
Visual C++
bool Sync()

Return Value

true if successful, or false if an error or if cancelled.

See Also

IPersistManager Interface
Mincom.LinkOne.Provider.Persist Namespace


IPersistManager Properties

[image] [image]

LinkOne WebView API
IPersistManager Properties
IPersistManager Interface See Also Send Feedback

The IPersistManager type exposes the following members.

Properties

Name | Description
Libraries | Gets the libraries.
Provider | Gets the provider.
ReportingLevel | Get or sets the reporting level for updates and prepares.
Syncing | Gets or sets the manager is used for synncing or not.

See Also

IPersistManager Interface
Mincom.LinkOne.Provider.Persist Namespace


Libraries Property

[image]

LinkOne WebView API
IPersistManager..::.Libraries Property
IPersistManager Interface See Also Send Feedback
Gets the libraries.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
IPersistLibraryCollection Libraries { get; }
Visual Basic (Declaration)
ReadOnly Property Libraries As IPersistLibraryCollection
Visual C++
property IPersistLibraryCollection^ Libraries {
    IPersistLibraryCollection^ get ();
}

See Also

IPersistManager Interface
Mincom.LinkOne.Provider.Persist Namespace


Provider Property

[image]

LinkOne WebView API
IPersistManager..::.Provider Property
IPersistManager Interface See Also Send Feedback
Gets the provider.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
IPersistService Provider { get; }
Visual Basic (Declaration)
ReadOnly Property Provider As IPersistService
Visual C++
property IPersistService^ Provider {
    IPersistService^ get ();
}

Field Value

See Also

IPersistManager Interface
Mincom.LinkOne.Provider.Persist Namespace


ReportingLevel Property

[image]

LinkOne WebView API
IPersistManager..::.ReportingLevel Property
IPersistManager Interface See Also Send Feedback
Get or sets the reporting level for updates and prepares.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
ReportingLevel ReportingLevel { get; set; }
Visual Basic (Declaration)
Property ReportingLevel As ReportingLevel
Visual C++
property ReportingLevel ReportingLevel {
    ReportingLevel get ();
    void set (ReportingLevel value);
}

See Also

IPersistManager Interface
Mincom.LinkOne.Provider.Persist Namespace


Syncing Property

[image]

LinkOne WebView API
IPersistManager..::.Syncing Property
IPersistManager Interface See Also Send Feedback
Gets or sets the manager is used for synncing or not.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool Syncing { get; set; }
Visual Basic (Declaration)
Property Syncing As Boolean
Visual C++
property bool Syncing {
    bool get ();
    void set (bool value);
}

See Also

IPersistManager Interface
Mincom.LinkOne.Provider.Persist Namespace


IPersistPublisher Interface

[image]

LinkOne WebView API
IPersistPublisher Interface
Members See Also Send Feedback
Implemented by a class to manage publisher persistence.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public interface IPersistPublisher
Visual Basic (Declaration)
Public Interface IPersistPublisher
Visual C++
public interface class IPersistPublisher

See Also

IPersistPublisher Members
Mincom.LinkOne.Provider.Persist Namespace


IPersistPublisher Members

[image] [image]

LinkOne WebView API
IPersistPublisher Members
IPersistPublisher Interface Methods Properties See Also Send Feedback

The IPersistPublisher type exposes the following members.

Methods

Name | Description
Compress | Compresses all content in the publisher.
Expand | Expands all content in the publisher.
Prepare | Prepares the publisher for internet delivery.
Remove | Removes the publisher from the filing system.
Sync | Synchronizes the publisher from any configured synchronization location.

Properties

Name | Description
Books | Gets the list of books for this publisher.
Catalog | Gets the book catalog for this publisher.
Library | Gets the publisher library.
Location | Gets the directory location of the publisher.
PublisherCode | Gets the publisher code.
PublisherDescription | Gets the publisher description.
PublisherDescriptionTranslations | Gets the publisher description tranlsations.

See Also

IPersistPublisher Interface
Mincom.LinkOne.Provider.Persist Namespace


IPersistPublisher Methods

[image] [image]

LinkOne WebView API
IPersistPublisher Methods
IPersistPublisher Interface See Also Send Feedback

The IPersistPublisher type exposes the following members.

Methods

Name | Description
Compress | Compresses all content in the publisher.
Expand | Expands all content in the publisher.
Prepare | Prepares the publisher for internet delivery.
Remove | Removes the publisher from the filing system.
Sync | Synchronizes the publisher from any configured synchronization location.

See Also

IPersistPublisher Interface
Mincom.LinkOne.Provider.Persist Namespace


Compress Method

[image]

LinkOne WebView API
IPersistPublisher..::.Compress Method
IPersistPublisher Interface See Also Send Feedback
Compresses all content in the publisher.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool Compress()
Visual Basic (Declaration)
Function Compress As Boolean
Visual C++
bool Compress()

Return Value

true if successful, or false if an error or if cancelled.

See Also

IPersistPublisher Interface
Mincom.LinkOne.Provider.Persist Namespace


Expand Method

[image]

LinkOne WebView API
IPersistPublisher..::.Expand Method
IPersistPublisher Interface See Also Send Feedback
Expands all content in the publisher.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool Expand()
Visual Basic (Declaration)
Function Expand As Boolean
Visual C++
bool Expand()

Return Value

true if successful, or false if an error or if cancelled.

See Also

IPersistPublisher Interface
Mincom.LinkOne.Provider.Persist Namespace


Prepare Method

[image]

LinkOne WebView API
IPersistPublisher..::.Prepare Method
IPersistPublisher Interface See Also Send Feedback
Prepares the publisher for internet delivery.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool Prepare(
    bool includeBookContent
)
Visual Basic (Declaration)
Function Prepare ( _
    includeBookContent As Boolean _
) As Boolean
Visual C++
bool Prepare(
    bool includeBookContent
)

Parameters

includeBookContent
Type: System..::.Boolean
true to also prepare book content.

Return Value

true if successful, or false if an error or if cancelled.

See Also

IPersistPublisher Interface
Mincom.LinkOne.Provider.Persist Namespace


Remove Method

[image]

LinkOne WebView API
IPersistPublisher..::.Remove Method
IPersistPublisher Interface See Also Send Feedback
Removes the publisher from the filing system.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
void Remove()
Visual Basic (Declaration)
Sub Remove
Visual C++
void Remove()

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | If the publisher directory could not be deleted.

See Also

IPersistPublisher Interface
Mincom.LinkOne.Provider.Persist Namespace


Sync Method

[image]

LinkOne WebView API
IPersistPublisher..::.Sync Method
IPersistPublisher Interface See Also Send Feedback
Synchronizes the publisher from any configured synchronization location.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool Sync()
Visual Basic (Declaration)
Function Sync As Boolean
Visual C++
bool Sync()

Return Value

true if successful, or false if an error or if cancelled.

See Also

IPersistPublisher Interface
Mincom.LinkOne.Provider.Persist Namespace


IPersistPublisher Properties

[image] [image]

LinkOne WebView API
IPersistPublisher Properties
IPersistPublisher Interface See Also Send Feedback

The IPersistPublisher type exposes the following members.

Properties

Name | Description
Books | Gets the list of books for this publisher.
Catalog | Gets the book catalog for this publisher.
Library | Gets the publisher library.
Location | Gets the directory location of the publisher.
PublisherCode | Gets the publisher code.
PublisherDescription | Gets the publisher description.
PublisherDescriptionTranslations | Gets the publisher description tranlsations.

See Also

IPersistPublisher Interface
Mincom.LinkOne.Provider.Persist Namespace


Books Property

[image]

LinkOne WebView API
IPersistPublisher..::.Books Property
IPersistPublisher Interface See Also Send Feedback
Gets the list of books for this publisher.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
IPersistBookCollection Books { get; }
Visual Basic (Declaration)
ReadOnly Property Books As IPersistBookCollection
Visual C++
property IPersistBookCollection^ Books {
    IPersistBookCollection^ get ();
}

See Also

IPersistPublisher Interface
Mincom.LinkOne.Provider.Persist Namespace


Catalog Property

[image]

LinkOne WebView API
IPersistPublisher..::.Catalog Property
IPersistPublisher Interface See Also Send Feedback
Gets the book catalog for this publisher.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
IPersistCatalog Catalog { get; }
Visual Basic (Declaration)
ReadOnly Property Catalog As IPersistCatalog
Visual C++
property IPersistCatalog^ Catalog {
    IPersistCatalog^ get ();
}

See Also

IPersistPublisher Interface
Mincom.LinkOne.Provider.Persist Namespace


Library Property

[image]

LinkOne WebView API
IPersistPublisher..::.Library Property
IPersistPublisher Interface See Also Send Feedback
Gets the publisher library.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
IPersistLibrary Library { get; }
Visual Basic (Declaration)
ReadOnly Property Library As IPersistLibrary
Visual C++
property IPersistLibrary^ Library {
    IPersistLibrary^ get ();
}

See Also

IPersistPublisher Interface
Mincom.LinkOne.Provider.Persist Namespace


Location Property

[image]

LinkOne WebView API
IPersistPublisher..::.Location Property
IPersistPublisher Interface See Also Send Feedback
Gets the directory location of the publisher.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
string Location { get; }
Visual Basic (Declaration)
ReadOnly Property Location As String
Visual C++
property String^ Location {
    String^ get ();
}

See Also

IPersistPublisher Interface
Mincom.LinkOne.Provider.Persist Namespace


PublisherCode Property

[image]

LinkOne WebView API
IPersistPublisher..::.PublisherCode Property
IPersistPublisher Interface See Also Send Feedback
Gets the publisher code.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
string PublisherCode { get; }
Visual Basic (Declaration)
ReadOnly Property PublisherCode As String
Visual C++
property String^ PublisherCode {
    String^ get ();
}

See Also

IPersistPublisher Interface
Mincom.LinkOne.Provider.Persist Namespace


PublisherDescription Property

[image]

LinkOne WebView API
IPersistPublisher..::.PublisherDescription Property
IPersistPublisher Interface See Also Send Feedback
Gets the publisher description.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
string PublisherDescription { get; }
Visual Basic (Declaration)
ReadOnly Property PublisherDescription As String
Visual C++
property String^ PublisherDescription {
    String^ get ();
}

See Also

IPersistPublisher Interface
Mincom.LinkOne.Provider.Persist Namespace


PublisherDescriptionTranslations Property

[image]

LinkOne WebView API
IPersistPublisher..::.PublisherDescriptionTranslations Property
IPersistPublisher Interface See Also Send Feedback
Gets the publisher description tranlsations.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
IDictionary<string, string> PublisherDescriptionTranslations { get; }
Visual Basic (Declaration)
ReadOnly Property PublisherDescriptionTranslations As IDictionary(Of String, String)
Visual C++
property IDictionary<String^, String^>^ PublisherDescriptionTranslations {
    IDictionary<String^, String^>^ get ();
}

See Also

IPersistPublisher Interface
Mincom.LinkOne.Provider.Persist Namespace


IPersistPublisherCollection Interface

[image]

LinkOne WebView API
IPersistPublisherCollection Interface
Members See Also Send Feedback
Implemented by a class to manage publisher collection persistence.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public interface IPersistPublisherCollection : ICollection<IPersistPublisher>,
    IEnumerable<IPersistPublisher>, IEnumerable
Visual Basic (Declaration)
Public Interface IPersistPublisherCollection _
    Implements ICollection(Of IPersistPublisher), IEnumerable(Of IPersistPublisher),  _
    IEnumerable
Visual C++
public interface class IPersistPublisherCollection : ICollection<IPersistPublisher^>,
    IEnumerable<IPersistPublisher^>, IEnumerable

See Also

IPersistPublisherCollection Members
Mincom.LinkOne.Provider.Persist Namespace


IPersistPublisherCollection Members

[image] [image]

LinkOne WebView API
IPersistPublisherCollection Members
IPersistPublisherCollection Interface Methods Properties See Also Send Feedback

The IPersistPublisherCollection type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPersistPublisher >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPersistPublisher >)>).)
Contains | Overloaded.
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( IPersistPublisher >)>).)
GetEnumerator | Overloaded.
GetSortedForLanguage | Gets the publishers sorted by description for the given language.
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPersistPublisher >)>).)

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPersistPublisher >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( IPersistPublisher >)>).)
Item | Gets the IPersistPublisher with the specified code, or null if not found.

See Also

IPersistPublisherCollection Interface
Mincom.LinkOne.Provider.Persist Namespace


IPersistPublisherCollection Methods

[image] [image]

LinkOne WebView API
IPersistPublisherCollection Methods
IPersistPublisherCollection Interface See Also Send Feedback

The IPersistPublisherCollection type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPersistPublisher >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPersistPublisher >)>).)
Contains | Overloaded.
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection<(Of <( IPersistPublisher >)>).)
GetEnumerator | Overloaded.
GetSortedForLanguage | Gets the publishers sorted by description for the given language.
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPersistPublisher >)>).)

See Also

IPersistPublisherCollection Interface
Mincom.LinkOne.Provider.Persist Namespace


Contains Method

[image] [image]

LinkOne WebView API
IPersistPublisherCollection..::.Contains Method
IPersistPublisherCollection Interface See Also Send Feedback

Overload List

Name | Description
Contains(T) | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from ICollection<(Of <( IPersistPublisher >)>).)
Contains(String) | Gets whether or not the collection contains the publisher code.

See Also

IPersistPublisherCollection Interface
IPersistPublisherCollection Members
Mincom.LinkOne.Provider.Persist Namespace


Contains Method (String)

[image]

LinkOne WebView API
IPersistPublisherCollection..::.Contains Method (String)
IPersistPublisherCollection Interface See Also Send Feedback
Gets whether or not the collection contains the publisher code.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
bool Contains(
    string publisherCode
)
Visual Basic (Declaration)
Function Contains ( _
    publisherCode As String _
) As Boolean
Visual C++
bool Contains(
    String^ publisherCode
)

Parameters

publisherCode
Type: System..::.String
The publisher code to check.

Return Value

true if the collection contains the publisher code, false otherwise.

See Also

IPersistPublisherCollection Interface
Contains Overload
Mincom.LinkOne.Provider.Persist Namespace


GetEnumerator Method

[image] [image]

LinkOne WebView API
IPersistPublisherCollection..::.GetEnumerator Method
IPersistPublisherCollection Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( IPersistPublisher >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IPersistPublisherCollection Interface
IPersistPublisherCollection Members
Mincom.LinkOne.Provider.Persist Namespace


GetSortedForLanguage Method

[image]

LinkOne WebView API
IPersistPublisherCollection..::.GetSortedForLanguage Method
IPersistPublisherCollection Interface See Also Send Feedback
Gets the publishers sorted by description for the given language.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
IEnumerable<IPersistPublisher> GetSortedForLanguage(
    string languageCode
)
Visual Basic (Declaration)
Function GetSortedForLanguage ( _
    languageCode As String _
) As IEnumerable(Of IPersistPublisher)
Visual C++
IEnumerable<IPersistPublisher^>^ GetSortedForLanguage(
    String^ languageCode
)

Parameters

languageCode
Type: System..::.String
The language code.

Return Value

The publishers sorted by description for the given language.

See Also

IPersistPublisherCollection Interface
Mincom.LinkOne.Provider.Persist Namespace


IPersistPublisherCollection Properties

[image] [image]

LinkOne WebView API
IPersistPublisherCollection Properties
IPersistPublisherCollection Interface See Also Send Feedback

The IPersistPublisherCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection<(Of <( IPersistPublisher >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection<(Of <( IPersistPublisher >)>).)
Item | Gets the IPersistPublisher with the specified code, or null if not found.

See Also

IPersistPublisherCollection Interface
Mincom.LinkOne.Provider.Persist Namespace


Item Property

[image]

LinkOne WebView API
IPersistPublisherCollection..::.Item Property
IPersistPublisherCollection Interface See Also Send Feedback
Gets the IPersistPublisher with the specified code, or null if not found.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
IPersistPublisher this[
    string publisherCode
] { get; }
Visual Basic (Declaration)
ReadOnly Default Property Item ( _
    publisherCode As String _
) As IPersistPublisher
Visual C++
property IPersistPublisher^ default[String^ publisherCode] {
    IPersistPublisher^ get (String^ publisherCode);
}

Parameters

publisherCode
Type: System..::.String

See Also

IPersistPublisherCollection Interface
Mincom.LinkOne.Provider.Persist Namespace


Library Class

[image]

LinkOne WebView API
Library Class
Members See Also Send Feedback
Represents a libray of LinkOne Publishers.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public sealed class Library : IPersistLibrary
Visual Basic (Declaration)
Public NotInheritable Class Library _
    Implements IPersistLibrary
Visual C++
public ref class Library sealed : IPersistLibrary

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Provider.Persist..::.Library

See Also

Library Members
Mincom.LinkOne.Provider.Persist Namespace


Library Members

[image] [image]

LinkOne WebView API
Library Members
Library Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The Library type exposes the following members.

Constructors

Name | Description
Library | Initializes a new instance of the Library class for browsing only.

Methods

Name | Description
CanInstallBooks | Determines whether this instance can install the specified source books.
ClearCache | Clears any cached book content in the library.
Compress | Compresses the library.
DecreasePriority | Decreases the lbrary priority by moving it one position after in the managed library collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Expand | Expands the library.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLibraryVersionNumber | check all Publishers in library, if they are -- all the same version number return it, eg ver 6, return 6. -- if one or more publishers are ver 6 and the rest are not, return 0 -- otherwise return -1 (error)
GetType | Gets the type of the current instance. (Inherited from Object.)
IncreasePriority | Increases the lbrary priority by moving it one position before in the managed library collection.
InstallBooks | Installs the specified source books, .
IsValidIndexedLibrary | Determines whether library at the specified path is a valid Indexed library.
IsValidLibrary | Determines if the given directory references a valid library.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Prepare | Prepares the library for internet delivery.
Refresh | Refreshes the library content.
Remove | Removes the library from the managed library collection.
Save | Saves the library if it has changed. Also saves the publishers in the library.
Sync | Synchronizes the library from any configured synchronization location.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Disabled | Gets or sets whether this library is disabled.
Indexed | Gets whether or not this library is indexed.
LibraryType | Gets or sets the type of the library.
Location | Gets the unresolved directory location of the library.
Offline | Gets whether or not this library is online or offline.
Publishers | Gets the list of publishers for this library or null if there is a problem loading the publishers.
PurgeIntervalMinutes | Gets or sets the purge interval in minutes.
ResolvedLocation | Gets the resolved directory location of the library.
SyncLocation | Gets the location to synchronize this library to.
SyncType | Gets or sets the type of the sync.
SyncUri | Gets the Uri of the sync location.
UpdateIntervalMinutes | Gets or sets the update interval in minutes.
Version | Gets the version string for the library. NB: major.minor.patch style
VersionNumber | Gets the internal version number for the library. NB: -1 to whatever, NOT major.minor.patch style

Explicit Interface Implementations

Name | Description
IPersistLibrary..::.Manager | Gets the manager of the library.
IPersistLibrary..::.Publishers | Gets the list of publishers for this library.

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


Library Constructor

[image]

LinkOne WebView API
Library Constructor
Library Class See Also Send Feedback
Initializes a new instance of the Library class for browsing only.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Library(
    string libraryDirectory,
    FileProvider provider
)
Visual Basic (Declaration)
Public Sub New ( _
    libraryDirectory As String, _
    provider As FileProvider _
)
Visual C++
public:
Library(
    String^ libraryDirectory,
    FileProvider^ provider
)

Parameters

libraryDirectory
Type: System..::.String
The unresolved library directory.
provider
Type: Mincom.LinkOne.Provider..::.FileProvider
The provider.

Remarks

This implicitly gets the minimum catalogue information for the library.

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


Library Methods

[image] [image]

LinkOne WebView API
Library Methods
Library Class See Also Send Feedback

The Library type exposes the following members.

Methods

Name | Description
CanInstallBooks | Determines whether this instance can install the specified source books.
ClearCache | Clears any cached book content in the library.
Compress | Compresses the library.
DecreasePriority | Decreases the lbrary priority by moving it one position after in the managed library collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Expand | Expands the library.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLibraryVersionNumber | check all Publishers in library, if they are -- all the same version number return it, eg ver 6, return 6. -- if one or more publishers are ver 6 and the rest are not, return 0 -- otherwise return -1 (error)
GetType | Gets the type of the current instance. (Inherited from Object.)
IncreasePriority | Increases the lbrary priority by moving it one position before in the managed library collection.
InstallBooks | Installs the specified source books, .
IsValidIndexedLibrary | Determines whether library at the specified path is a valid Indexed library.
IsValidLibrary | Determines if the given directory references a valid library.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Prepare | Prepares the library for internet delivery.
Refresh | Refreshes the library content.
Remove | Removes the library from the managed library collection.
Save | Saves the library if it has changed. Also saves the publishers in the library.
Sync | Synchronizes the library from any configured synchronization location.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


CanInstallBooks Method

[image]

LinkOne WebView API
Library..::.CanInstallBooks Method
Library Class See Also Send Feedback
Determines whether this instance can install the specified source books.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool CanInstallBooks(
    IEnumerable<IPersistBook> sourceBooks
)
Visual Basic (Declaration)
Public Function CanInstallBooks ( _
    sourceBooks As IEnumerable(Of IPersistBook) _
) As Boolean
Visual C++
public:
virtual bool CanInstallBooks(
    IEnumerable<IPersistBook^>^ sourceBooks
) sealed

Parameters

sourceBooks
Type: System.Collections.Generic..::.IEnumerable<(Of <( IPersistBook >)>)
The source books.

Return Value

True if this instance can install the specified source books; otherwise, false.

Implements

IPersistLibrary..::.CanInstallBooks(IEnumerable<(Of <(IPersistBook>)>))

Remarks

The following checks are performed before attemping to install books:
soureBooks is not null sourceBooks are from the same library
If the above passes, the next level of validation checks the LibraryType of this instance. Books cannot be installed to a Remote. If the LibraryType is an Updated, the source LibraryType must not be a Local library, and the source must be from the same Uri as this instance.

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


ClearCache Method

[image]

LinkOne WebView API
Library..::.ClearCache Method
Library Class See Also Send Feedback
Clears any cached book content in the library.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void ClearCache()
Visual Basic (Declaration)
Public Sub ClearCache
Visual C++
public:
virtual void ClearCache() sealed

Implements

IPersistLibrary..::.ClearCache()()()

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


Compress Method

[image]

LinkOne WebView API
Library..::.Compress Method
Library Class See Also Send Feedback
Compresses the library.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Compress()
Visual Basic (Declaration)
Public Function Compress As Boolean
Visual C++
public:
virtual bool Compress() sealed

Return Value

true if successful, or false if an error or if cancelled.

Implements

IPersistLibrary..::.Compress()()()

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


DecreasePriority Method

[image]

LinkOne WebView API
Library..::.DecreasePriority Method
Library Class See Also Send Feedback
Decreases the lbrary priority by moving it one position after in the managed library collection.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void DecreasePriority()
Visual Basic (Declaration)
Public Sub DecreasePriority
Visual C++
public:
virtual void DecreasePriority() sealed

Implements

IPersistLibrary..::.DecreasePriority()()()

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


Expand Method

[image]

LinkOne WebView API
Library..::.Expand Method
Library Class See Also Send Feedback
Expands the library.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Expand()
Visual Basic (Declaration)
Public Function Expand As Boolean
Visual C++
public:
virtual bool Expand() sealed

Return Value

true if successful, or false if an error or if cancelled.

Implements

IPersistLibrary..::.Expand()()()

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


GetLibraryVersionNumber Method

[image]

LinkOne WebView API
Library..::.GetLibraryVersionNumber Method
Library Class See Also Send Feedback
check all Publishers in library, if they are -- all the same version number return it, eg ver 6, return 6. -- if one or more publishers are ver 6 and the rest are not, return 0 -- otherwise return -1 (error)

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int GetLibraryVersionNumber()
Visual Basic (Declaration)
Public Function GetLibraryVersionNumber As Integer
Visual C++
public:
int GetLibraryVersionNumber()

Return Value

The Library Version Number: -1 if a Publisher has no VerNum, 0 if a mix of 5.1 and pre 5.1 Publishers, otherwise the last Publisher VerNum read.

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


IncreasePriority Method

[image]

LinkOne WebView API
Library..::.IncreasePriority Method
Library Class See Also Send Feedback
Increases the lbrary priority by moving it one position before in the managed library collection.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void IncreasePriority()
Visual Basic (Declaration)
Public Sub IncreasePriority
Visual C++
public:
virtual void IncreasePriority() sealed

Implements

IPersistLibrary..::.IncreasePriority()()()

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


InstallBooks Method

[image]

LinkOne WebView API
Library..::.InstallBooks Method
Library Class See Also Send Feedback
Installs the specified source books, .

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool InstallBooks(
    string sourceLibraryLocation,
    IList<KeyValuePair<string, string>> sourceBooks,
    bool fullDownload
)
Visual Basic (Declaration)
Public Function InstallBooks ( _
    sourceLibraryLocation As String, _
    sourceBooks As IList(Of KeyValuePair(Of String, String)), _
    fullDownload As Boolean _
) As Boolean
Visual C++
public:
virtual bool InstallBooks(
    String^ sourceLibraryLocation,
    IList<KeyValuePair<String^, String^>>^ sourceBooks,
    bool fullDownload
) sealed

Parameters

sourceLibraryLocation
Type: System..::.String
The source library location.
sourceBooks
Type: System.Collections.Generic..::.IList<(Of <(KeyValuePair<(Of <(String, String>)>)>)>)
The source books.
fullDownload
Type: System..::.Boolean
false for a minimum install when the library is an Updated library; otherwise always a full download.

Return Value

True if successful, or false if an error or if cancelled.

Implements

IPersistLibrary..::.InstallBooks(String, IList<(Of <(KeyValuePair<(Of <(String, String>)>)>)>), Boolean)

Remarks

Source Book KeyValuePairs are of the form <[PublisherCode],[BookCode]>.

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace
Library..::.CanInstallBooks(IEnumerable<(Of <(IPersistBook>)>))


IsValidIndexedLibrary Method

[image]

LinkOne WebView API
Library..::.IsValidIndexedLibrary Method
Library Class See Also Send Feedback
Determines whether library at the specified path is a valid Indexed library.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static bool IsValidIndexedLibrary(
    string directory
)
Visual Basic (Declaration)
Public Shared Function IsValidIndexedLibrary ( _
    directory As String _
) As Boolean
Visual C++
public:
static bool IsValidIndexedLibrary(
    String^ directory
)

Parameters

directory
Type: System..::.String
The directory of the library to test.

Return Value

true if the library at the specified path is a valid Indexed library.; otherwise, false.

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


IsValidLibrary Method

[image]

LinkOne WebView API
Library..::.IsValidLibrary Method
Library Class See Also Send Feedback
Determines if the given directory references a valid library.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public static bool IsValidLibrary(
    string directory
)
Visual Basic (Declaration)
Public Shared Function IsValidLibrary ( _
    directory As String _
) As Boolean
Visual C++
public:
static bool IsValidLibrary(
    String^ directory
)

Parameters

directory
Type: System..::.String
The directory to validate as a library.

Return Value

True if the given directory references a valid library.

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


Prepare Method

[image]

LinkOne WebView API
Library..::.Prepare Method
Library Class See Also Send Feedback
Prepares the library for internet delivery.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Prepare(
    bool includeBookContent
)
Visual Basic (Declaration)
Public Function Prepare ( _
    includeBookContent As Boolean _
) As Boolean
Visual C++
public:
virtual bool Prepare(
    bool includeBookContent
) sealed

Parameters

includeBookContent
Type: System..::.Boolean
true to also prepare book content.

Return Value

true if successful, or false if an error or if cancelled.

Implements

IPersistLibrary..::.Prepare(Boolean)

Remarks

Recreates the library's man.lst from the library publishers' man.def files.

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


Refresh Method

[image]

LinkOne WebView API
Library..::.Refresh Method
Library Class See Also Send Feedback
Refreshes the library content.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Refresh()
Visual Basic (Declaration)
Public Sub Refresh
Visual C++
public:
virtual void Refresh() sealed

Implements

IPersistLibrary..::.Refresh()()()

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


Remove Method

[image]

LinkOne WebView API
Library..::.Remove Method
Library Class See Also Send Feedback
Removes the library from the managed library collection.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Remove()
Visual Basic (Declaration)
Public Sub Remove
Visual C++
public:
virtual void Remove() sealed

Implements

IPersistLibrary..::.Remove()()()

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


Save Method

[image]

LinkOne WebView API
Library..::.Save Method
Library Class See Also Send Feedback
Saves the library if it has changed. Also saves the publishers in the library.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Save()
Visual Basic (Declaration)
Public Sub Save
Visual C++
public:
virtual void Save() sealed

Implements

IPersistLibrary..::.Save()()()

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


Sync Method

[image]

LinkOne WebView API
Library..::.Sync Method
Library Class See Also Send Feedback
Synchronizes the library from any configured synchronization location.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Sync()
Visual Basic (Declaration)
Public Function Sync As Boolean
Visual C++
public:
virtual bool Sync() sealed

Return Value

true if successful, or false if an error or if cancelled.

Implements

IPersistLibrary..::.Sync()()()

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


Library Properties

[image] [image]

LinkOne WebView API
Library Properties
Library Class See Also Send Feedback

The Library type exposes the following members.

Properties

Name | Description
Disabled | Gets or sets whether this library is disabled.
Indexed | Gets whether or not this library is indexed.
LibraryType | Gets or sets the type of the library.
Location | Gets the unresolved directory location of the library.
Offline | Gets whether or not this library is online or offline.
Publishers | Gets the list of publishers for this library or null if there is a problem loading the publishers.
PurgeIntervalMinutes | Gets or sets the purge interval in minutes.
ResolvedLocation | Gets the resolved directory location of the library.
SyncLocation | Gets the location to synchronize this library to.
SyncType | Gets or sets the type of the sync.
SyncUri | Gets the Uri of the sync location.
UpdateIntervalMinutes | Gets or sets the update interval in minutes.
Version | Gets the version string for the library. NB: major.minor.patch style
VersionNumber | Gets the internal version number for the library. NB: -1 to whatever, NOT major.minor.patch style

Explicit Interface Implementations

Name | Description
IPersistLibrary..::.Manager | Gets the manager of the library.
IPersistLibrary..::.Publishers | Gets the list of publishers for this library.

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


Disabled Property

[image]

LinkOne WebView API
Library..::.Disabled Property
Library Class See Also Send Feedback
Gets or sets whether this library is disabled.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Disabled { get; set; }
Visual Basic (Declaration)
Public Property Disabled As Boolean
Visual C++
public:
virtual property bool Disabled {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IPersistLibrary..::.Disabled

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


Indexed Property

[image]

LinkOne WebView API
Library..::.Indexed Property
Library Class See Also Send Feedback
Gets whether or not this library is indexed.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Indexed { get; }
Visual Basic (Declaration)
Public ReadOnly Property Indexed As Boolean
Visual C++
public:
property bool Indexed {
    bool get ();
}

Remarks

This is not an indication that the library index is up to date.

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


IPersistLibrary.Manager Property

[image]

LinkOne WebView API
Library..::.IPersistLibrary..::.Manager Property
Library Class See Also Send Feedback
Gets the manager of the library.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPersistManager IPersistLibrary.Manager { get; }
Visual Basic (Declaration)
Private ReadOnly Property Manager As IPersistManager
    Implements IPersistLibrary.Manager
Visual C++
private:
virtual property IPersistManager^ Manager {
    IPersistManager^ get () sealed = IPersistLibrary::Manager::get;
}

Field Value

Implements

IPersistLibrary..::.Manager

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


IPersistLibrary.Publishers Property

[image]

LinkOne WebView API
Library..::.IPersistLibrary..::.Publishers Property
Library Class See Also Send Feedback
Gets the list of publishers for this library.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPersistPublisherCollection IPersistLibrary.Publishers { get; }
Visual Basic (Declaration)
Private ReadOnly Property Publishers As IPersistPublisherCollection
    Implements IPersistLibrary.Publishers
Visual C++
private:
virtual property IPersistPublisherCollection^ Publishers {
    IPersistPublisherCollection^ get () sealed = IPersistLibrary::Publishers::get;
}

Field Value

Implements

IPersistLibrary..::.Publishers

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


LibraryType Property

[image]

LinkOne WebView API
Library..::.LibraryType Property
Library Class See Also Send Feedback
Gets or sets the type of the library.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LibraryType LibraryType { get; set; }
Visual Basic (Declaration)
Public Property LibraryType As LibraryType
Visual C++
public:
virtual property LibraryType LibraryType {
    LibraryType get () sealed;
    void set (LibraryType value) sealed;
}

Implements

IPersistLibrary..::.LibraryType

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


Location Property

[image]

LinkOne WebView API
Library..::.Location Property
Library Class See Also Send Feedback
Gets the unresolved directory location of the library.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Location { get; }
Visual Basic (Declaration)
Public ReadOnly Property Location As String
Visual C++
public:
virtual property String^ Location {
    String^ get () sealed;
}

Implements

IPersistLibrary..::.Location

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


Offline Property

[image]

LinkOne WebView API
Library..::.Offline Property
Library Class See Also Send Feedback
Gets whether or not this library is online or offline.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Offline { get; internal set; }
Visual Basic (Declaration)
Public Property Offline As Boolean
Visual C++
public:
virtual property bool Offline {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IPersistLibrary..::.Offline

Remarks

A library is offline if its directory can't be resolved. For example if a library on a CD has the CD removed from the drive the library will become "offline".
A library is assumed to be online untill it is loaded,

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


Publishers Property

[image]

LinkOne WebView API
Library..::.Publishers Property
Library Class See Also Send Feedback
Gets the list of publishers for this library or null if there is a problem loading the publishers.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public PublisherCollection Publishers { get; }
Visual Basic (Declaration)
Public ReadOnly Property Publishers As PublisherCollection
Visual C++
public:
property PublisherCollection^ Publishers {
    PublisherCollection^ get ();
}

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


PurgeIntervalMinutes Property

[image]

LinkOne WebView API
Library..::.PurgeIntervalMinutes Property
Library Class See Also Send Feedback
Gets or sets the purge interval in minutes.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int PurgeIntervalMinutes { get; set; }
Visual Basic (Declaration)
Public Property PurgeIntervalMinutes As Integer
Visual C++
public:
virtual property int PurgeIntervalMinutes {
    int get () sealed;
    void set (int value) sealed;
}

Implements

IPersistLibrary..::.PurgeIntervalMinutes

Remarks

A value of 0 means that books / publishers no longer on the server will be purged immediatly.
A value < 0 means that publishers / books no lonber on the server will not be purged.

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


ResolvedLocation Property

[image]

LinkOne WebView API
Library..::.ResolvedLocation Property
Library Class See Also Send Feedback
Gets the resolved directory location of the library.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string ResolvedLocation { get; }
Visual Basic (Declaration)
Public ReadOnly Property ResolvedLocation As String
Visual C++
public:
virtual property String^ ResolvedLocation {
    String^ get () sealed;
}

Implements

IPersistLibrary..::.ResolvedLocation

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


SyncLocation Property

[image]

LinkOne WebView API
Library..::.SyncLocation Property
Library Class See Also Send Feedback
Gets the location to synchronize this library to.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string SyncLocation { get; set; }
Visual Basic (Declaration)
Public Property SyncLocation As String
Visual C++
public:
virtual property String^ SyncLocation {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IPersistLibrary..::.SyncLocation

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


SyncType Property

[image]

LinkOne WebView API
Library..::.SyncType Property
Library Class See Also Send Feedback
Gets or sets the type of the sync.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public SyncType SyncType { get; set; }
Visual Basic (Declaration)
Public Property SyncType As SyncType
Visual C++
public:
virtual property SyncType SyncType {
    SyncType get () sealed;
    void set (SyncType value) sealed;
}

Implements

IPersistLibrary..::.SyncType

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


SyncUri Property

[image]

LinkOne WebView API
Library..::.SyncUri Property
Library Class See Also Send Feedback
Gets the Uri of the sync location.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Uri SyncUri { get; }
Visual Basic (Declaration)
Public ReadOnly Property SyncUri As Uri
Visual C++
public:
property Uri^ SyncUri {
    Uri^ get ();
}

Remarks

A Uri is generated from the SyncLocation property. If this value is null or if the generated value is not a validUri the returned value is null.

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


UpdateIntervalMinutes Property

[image]

LinkOne WebView API
Library..::.UpdateIntervalMinutes Property
Library Class See Also Send Feedback
Gets or sets the update interval in minutes.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int UpdateIntervalMinutes { get; set; }
Visual Basic (Declaration)
Public Property UpdateIntervalMinutes As Integer
Visual C++
public:
virtual property int UpdateIntervalMinutes {
    int get () sealed;
    void set (int value) sealed;
}

Implements

IPersistLibrary..::.UpdateIntervalMinutes

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


Version Property

[image]

LinkOne WebView API
Library..::.Version Property
Library Class See Also Send Feedback
Gets the version string for the library. NB: major.minor.patch style

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Version { get; }
Visual Basic (Declaration)
Public ReadOnly Property Version As String
Visual C++
public:
property String^ Version {
    String^ get ();
}

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


VersionNumber Property

[image]

LinkOne WebView API
Library..::.VersionNumber Property
Library Class See Also Send Feedback
Gets the internal version number for the library. NB: -1 to whatever, NOT major.minor.patch style

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int VersionNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property VersionNumber As Integer
Visual C++
public:
virtual property int VersionNumber {
    int get () sealed;
}

Implements

IPersistLibrary..::.VersionNumber

See Also

Library Class
Mincom.LinkOne.Provider.Persist Namespace


LibraryCollection Class

[image]

LinkOne WebView API
LibraryCollection Class
Members See Also Send Feedback
Represents a collection of Library objects.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public sealed class LibraryCollection : IPersistLibraryCollection,
    ICollection<IPersistLibrary>, IEnumerable<IPersistLibrary>, IEnumerable
Visual Basic (Declaration)
Public NotInheritable Class LibraryCollection _
    Implements IPersistLibraryCollection, ICollection(Of IPersistLibrary),  _
    IEnumerable(Of IPersistLibrary), IEnumerable
Visual C++
public ref class LibraryCollection sealed : IPersistLibraryCollection,
    ICollection<IPersistLibrary^>, IEnumerable<IPersistLibrary^>, IEnumerable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Provider.Persist..::.LibraryCollection

See Also

LibraryCollection Members
Mincom.LinkOne.Provider.Persist Namespace


LibraryCollection Members

[image] [image]

LinkOne WebView API
LibraryCollection Members
LibraryCollection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The LibraryCollection type exposes the following members.

Methods

Name | Description
Add | See Add(T) for more information.
Clear | See Clear()()() for more information.
Contains | Overloaded.
CopyTo | See CopyTo(array<T>[]()[], Int32) for more information.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | See GetEnumerator()()() for more information.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | See Count for more information.
IsReadOnly | See IsReadOnly for more information.

Explicit Interface Implementations

Name | Description
IPersistLibraryCollection..::.Add | Adds a Library for the given location.
IEnumerable..::.GetEnumerator | See GetEnumerator()()() for more information.
IPersistLibraryCollection..::.Item | Gets the IPersistLibrary with the specified location.

See Also

LibraryCollection Class
Mincom.LinkOne.Provider.Persist Namespace


LibraryCollection Methods

[image] [image]

LinkOne WebView API
LibraryCollection Methods
LibraryCollection Class See Also Send Feedback

The LibraryCollection type exposes the following members.

Methods

Name | Description
Add | See Add(T) for more information.
Clear | See Clear()()() for more information.
Contains | Overloaded.
CopyTo | See CopyTo(array<T>[]()[], Int32) for more information.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | See GetEnumerator()()() for more information.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IPersistLibraryCollection..::.Add | Adds a Library for the given location.
IEnumerable..::.GetEnumerator | See GetEnumerator()()() for more information.

See Also

LibraryCollection Class
Mincom.LinkOne.Provider.Persist Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
LibraryCollection..::.IEnumerable..::.GetEnumerator Method
LibraryCollection Class See Also Send Feedback
See GetEnumerator()()() for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Implements

IEnumerable..::.GetEnumerator()()()

See Also

LibraryCollection Class
Mincom.LinkOne.Provider.Persist Namespace


Add Method

[image]

LinkOne WebView API
LibraryCollection..::.Add Method
LibraryCollection Class See Also Send Feedback
See Add(T) for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Add(
    IPersistLibrary item
)
Visual Basic (Declaration)
Public Sub Add ( _
    item As IPersistLibrary _
)
Visual C++
public:
virtual void Add(
    IPersistLibrary^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Provider.Persist..::.IPersistLibrary

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

LibraryCollection Class
Mincom.LinkOne.Provider.Persist Namespace


Clear Method

[image]

LinkOne WebView API
LibraryCollection..::.Clear Method
LibraryCollection Class See Also Send Feedback
See Clear()()() for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
virtual void Clear() sealed

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

See Also

LibraryCollection Class
Mincom.LinkOne.Provider.Persist Namespace


Contains Method

[image] [image]

LinkOne WebView API
LibraryCollection..::.Contains Method
LibraryCollection Class See Also Send Feedback

Overload List

Name | Description
Contains(IPersistLibrary) | See Contains(T) for more information.
Contains(String) | Gets whether or not the collection contains the library location.

See Also

LibraryCollection Class
LibraryCollection Members
Mincom.LinkOne.Provider.Persist Namespace


Contains Method (IPersistLibrary)

[image]

LinkOne WebView API
LibraryCollection..::.Contains Method (IPersistLibrary)
LibraryCollection Class See Also Send Feedback
See Contains(T) for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    IPersistLibrary item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As IPersistLibrary _
) As Boolean
Visual C++
public:
virtual bool Contains(
    IPersistLibrary^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Provider.Persist..::.IPersistLibrary

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

LibraryCollection Class
Contains Overload
Mincom.LinkOne.Provider.Persist Namespace


Contains Method (String)

[image]

LinkOne WebView API
LibraryCollection..::.Contains Method (String)
LibraryCollection Class See Also Send Feedback
Gets whether or not the collection contains the library location.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    string location
)
Visual Basic (Declaration)
Public Function Contains ( _
    location As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ location
) sealed

Parameters

location
Type: System..::.String
The location to check.

Return Value

true if the collection contains the location, false otherwise.

Implements

IPersistLibraryCollection..::.Contains(String)

See Also

LibraryCollection Class
Contains Overload
Mincom.LinkOne.Provider.Persist Namespace


CopyTo Method

[image]

LinkOne WebView API
LibraryCollection..::.CopyTo Method
LibraryCollection Class See Also Send Feedback
See CopyTo(array<T>[]()[], Int32) for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void CopyTo(
    IPersistLibrary[] array,
    int arrayIndex
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As IPersistLibrary(), _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    array<IPersistLibrary^>^ array,
    int arrayIndex
) sealed

Parameters

array
Type: array< Mincom.LinkOne.Provider.Persist..::.IPersistLibrary >[]()[]
arrayIndex
Type: System..::.Int32

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

LibraryCollection Class
Mincom.LinkOne.Provider.Persist Namespace


GetEnumerator Method

[image]

LinkOne WebView API
LibraryCollection..::.GetEnumerator Method
LibraryCollection Class See Also Send Feedback
See GetEnumerator()()() for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IEnumerator<IPersistLibrary> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of IPersistLibrary)
Visual C++
public:
virtual IEnumerator<IPersistLibrary^>^ GetEnumerator() sealed

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

LibraryCollection Class
Mincom.LinkOne.Provider.Persist Namespace


IPersistLibraryCollection.Add Method

[image]

LinkOne WebView API
LibraryCollection..::.IPersistLibraryCollection..::.Add Method
LibraryCollection Class See Also Send Feedback
Adds a Library for the given location.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPersistLibrary IPersistLibraryCollection.Add(
    string location
)
Visual Basic (Declaration)
Private Function Add ( _
    location As String _
) As IPersistLibrary Implements IPersistLibraryCollection.Add
Visual C++
private:
virtual IPersistLibrary^ Add(
    String^ location
) sealed = IPersistLibraryCollection::Add

Parameters

location
Type: System..::.String
The location of the library

Return Value

The added library.

Implements

IPersistLibraryCollection..::.Add(String)

See Also

LibraryCollection Class
Mincom.LinkOne.Provider.Persist Namespace


Remove Method

[image] [image]

LinkOne WebView API
LibraryCollection..::.Remove Method
LibraryCollection Class See Also Send Feedback

Overload List

Name | Description
Remove(IPersistLibrary) | See Remove(T) for more information.
Remove(String) | Removes a library at the specified location from the collection.

See Also

LibraryCollection Class
LibraryCollection Members
Mincom.LinkOne.Provider.Persist Namespace


Remove Method (IPersistLibrary)

[image]

LinkOne WebView API
LibraryCollection..::.Remove Method (IPersistLibrary)
LibraryCollection Class See Also Send Feedback
See Remove(T) for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Remove(
    IPersistLibrary item
)
Visual Basic (Declaration)
Public Function Remove ( _
    item As IPersistLibrary _
) As Boolean
Visual C++
public:
virtual bool Remove(
    IPersistLibrary^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Provider.Persist..::.IPersistLibrary

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

LibraryCollection Class
Remove Overload
Mincom.LinkOne.Provider.Persist Namespace


Remove Method (String)

[image]

LinkOne WebView API
LibraryCollection..::.Remove Method (String)
LibraryCollection Class See Also Send Feedback
Removes a library at the specified location from the collection.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Remove(
    string location
)
Visual Basic (Declaration)
Public Function Remove ( _
    location As String _
) As Boolean
Visual C++
public:
virtual bool Remove(
    String^ location
) sealed

Parameters

location
Type: System..::.String
The location of the library to remove.

Return Value

true if the library was removed, false otherwise.

Implements

IPersistLibraryCollection..::.Remove(String)

See Also

LibraryCollection Class
Remove Overload
Mincom.LinkOne.Provider.Persist Namespace


LibraryCollection Properties

[image] [image]

LinkOne WebView API
LibraryCollection Properties
LibraryCollection Class See Also Send Feedback

The LibraryCollection type exposes the following members.

Properties

Name | Description
Count | See Count for more information.
IsReadOnly | See IsReadOnly for more information.

Explicit Interface Implementations

Name | Description
IPersistLibraryCollection..::.Item | Gets the IPersistLibrary with the specified location.

See Also

LibraryCollection Class
Mincom.LinkOne.Provider.Persist Namespace


Count Property

[image]

LinkOne WebView API
LibraryCollection..::.Count Property
LibraryCollection Class See Also Send Feedback
See Count for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

LibraryCollection Class
Mincom.LinkOne.Provider.Persist Namespace


IPersistLibraryCollection.Item Property

[image]

LinkOne WebView API
LibraryCollection..::.IPersistLibraryCollection..::.Item Property
LibraryCollection Class See Also Send Feedback
Gets the IPersistLibrary with the specified location.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPersistLibrary IPersistLibraryCollection.Item[
    string location
] { get; }
Visual Basic (Declaration)
Private ReadOnly Property Item ( _
    location As String _
) As IPersistLibrary Implements IPersistLibraryCollection.Item
Visual C++
private:
virtual property IPersistLibrary^ Item[String^ location] {
    IPersistLibrary^ get (String^ location) sealed = IPersistLibraryCollection::Item::get;
}

Parameters

location
Type: System..::.String

Field Value

The library for the specified location.

Implements

IPersistLibraryCollection..::.Item[([(String])])

See Also

LibraryCollection Class
Mincom.LinkOne.Provider.Persist Namespace


IsReadOnly Property

[image]

LinkOne WebView API
LibraryCollection..::.IsReadOnly Property
LibraryCollection Class See Also Send Feedback
See IsReadOnly for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

LibraryCollection Class
Mincom.LinkOne.Provider.Persist Namespace


LibraryType Enumeration

[image]

LinkOne WebView API
LibraryType Enumeration
See Also Send Feedback
Represents the type of Library.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public enum LibraryType
Visual Basic (Declaration)
Public Enumeration LibraryType
Visual C++
public enum class LibraryType

Members

Member name | Description
Local | Standared local library.
Remote | Synchronized remote library.
Updated | Synchronized installed books.
Indexed | Local library that uses only list files to catalog publishers and books.

See Also

Mincom.LinkOne.Provider.Persist Namespace


Manager Class

[image]

LinkOne WebView API
Manager Class
Members See Also Send Feedback
Represents the manager of Library objects.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public sealed class Manager : IPersistManager
Visual Basic (Declaration)
Public NotInheritable Class Manager _
    Implements IPersistManager
Visual C++
public ref class Manager sealed : IPersistManager

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Provider.Persist..::.Manager

See Also

Manager Members
Mincom.LinkOne.Provider.Persist Namespace


Manager Members

[image] [image]

LinkOne WebView API
Manager Members
Manager Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The Manager type exposes the following members.

Constructors

Name | Description
Manager | Constructor.

Methods

Name | Description
Compress | Compresses the library.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Expand | Expands the library.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
InstallBooks | Installs the given books to the destination library.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Prepare | Prepares the library for internet delivery.
Refresh | Refreshes all libraries.
Save | Saves any changes made.
Sync | Synchronizes the library from any configured synchronization location.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Libraries | Gets the sub library collection for the master library.
ReportingLevel | Get or sets the reporting level for updates and prepares.
Syncing | Gets a value indicating whether this Manager is for syncing.

Explicit Interface Implementations

Name | Description
IPersistManager..::.Libraries | Gets the libraries.
IPersistManager..::.Provider | Gets the provider.

See Also

Manager Class
Mincom.LinkOne.Provider.Persist Namespace


Manager Constructor

[image]

LinkOne WebView API
Manager Constructor
Manager Class See Also Send Feedback
Constructor.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Manager(
    FileProvider provider,
    XmlElement librariesXml
)
Visual Basic (Declaration)
Public Sub New ( _
    provider As FileProvider, _
    librariesXml As XmlElement _
)
Visual C++
public:
Manager(
    FileProvider^ provider,
    XmlElement^ librariesXml
)

Parameters

provider
Type: Mincom.LinkOne.Provider..::.FileProvider
The Provider()()().
librariesXml
Type: System.Xml..::.XmlElement
The XML representing the enabled and disabled libraries.

See Also

Manager Class
Mincom.LinkOne.Provider.Persist Namespace


Manager Methods

[image] [image]

LinkOne WebView API
Manager Methods
Manager Class See Also Send Feedback

The Manager type exposes the following members.

Methods

Name | Description
Compress | Compresses the library.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Expand | Expands the library.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
InstallBooks | Installs the given books to the destination library.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Prepare | Prepares the library for internet delivery.
Refresh | Refreshes all libraries.
Save | Saves any changes made.
Sync | Synchronizes the library from any configured synchronization location.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Manager Class
Mincom.LinkOne.Provider.Persist Namespace


Compress Method

[image]

LinkOne WebView API
Manager..::.Compress Method
Manager Class See Also Send Feedback
Compresses the library.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Compress()
Visual Basic (Declaration)
Public Function Compress As Boolean
Visual C++
public:
virtual bool Compress() sealed

Return Value

true if successful, or false if an error or if cancelled.

Implements

IPersistManager..::.Compress()()()

See Also

Manager Class
Mincom.LinkOne.Provider.Persist Namespace


Expand Method

[image]

LinkOne WebView API
Manager..::.Expand Method
Manager Class See Also Send Feedback
Expands the library.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Expand()
Visual Basic (Declaration)
Public Function Expand As Boolean
Visual C++
public:
virtual bool Expand() sealed

Return Value

true if successful, or false if an error or if cancelled.

Implements

IPersistManager..::.Expand()()()

See Also

Manager Class
Mincom.LinkOne.Provider.Persist Namespace


InstallBooks Method

[image]

LinkOne WebView API
Manager..::.InstallBooks Method
Manager Class See Also Send Feedback
Installs the given books to the destination library.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool InstallBooks(
    string sourceLibraryLocation,
    string destinationLibraryLocation,
    IList<KeyValuePair<string, string>> sourceBooks,
    bool fullDownload
)
Visual Basic (Declaration)
Public Function InstallBooks ( _
    sourceLibraryLocation As String, _
    destinationLibraryLocation As String, _
    sourceBooks As IList(Of KeyValuePair(Of String, String)), _
    fullDownload As Boolean _
) As Boolean
Visual C++
public:
virtual bool InstallBooks(
    String^ sourceLibraryLocation,
    String^ destinationLibraryLocation,
    IList<KeyValuePair<String^, String^>>^ sourceBooks,
    bool fullDownload
) sealed

Parameters

sourceLibraryLocation
Type: System..::.String
The source library location.
destinationLibraryLocation
Type: System..::.String
The destination library location.
sourceBooks
Type: System.Collections.Generic..::.IList<(Of <(KeyValuePair<(Of <(String, String>)>)>)>)
The source books.
fullDownload
Type: System..::.Boolean
false for a minimum install when the destination library is an Updated library; otherwise always a full download.

Return Value

true if successful, or false if an error or if cancelled.

Implements

IPersistManager..::.InstallBooks(String, String, IList<(Of <(KeyValuePair<(Of <(String, String>)>)>)>), Boolean)

Exceptions

Exception | Condition
System..::.ArgumentException | The source or destination libraries are null, or Empty()()().
System..::.NotSupportedException | The books are not valid for the destination library.

See Also

Manager Class
Mincom.LinkOne.Provider.Persist Namespace


Prepare Method

[image]

LinkOne WebView API
Manager..::.Prepare Method
Manager Class See Also Send Feedback
Prepares the library for internet delivery.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Prepare(
    bool includeBookContent
)
Visual Basic (Declaration)
Public Function Prepare ( _
    includeBookContent As Boolean _
) As Boolean
Visual C++
public:
virtual bool Prepare(
    bool includeBookContent
) sealed

Parameters

includeBookContent
Type: System..::.Boolean
true to also prepare book content.

Return Value

true if successful, or false if an error or if cancelled.

Implements

IPersistManager..::.Prepare(Boolean)

Remarks

Recreates the library's man.lst from the library publishers' man.def files.

See Also

Manager Class
Mincom.LinkOne.Provider.Persist Namespace


Refresh Method

[image]

LinkOne WebView API
Manager..::.Refresh Method
Manager Class See Also Send Feedback
Refreshes all libraries.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Refresh()
Visual Basic (Declaration)
Public Sub Refresh
Visual C++
public:
virtual void Refresh() sealed

Implements

IPersistManager..::.Refresh()()()

See Also

Manager Class
Mincom.LinkOne.Provider.Persist Namespace


Save Method

[image]

LinkOne WebView API
Manager..::.Save Method
Manager Class See Also Send Feedback
Saves any changes made.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Save()
Visual Basic (Declaration)
Public Sub Save
Visual C++
public:
virtual void Save() sealed

Implements

IPersistManager..::.Save()()()

See Also

Manager Class
Mincom.LinkOne.Provider.Persist Namespace


Sync Method

[image]

LinkOne WebView API
Manager..::.Sync Method
Manager Class See Also Send Feedback
Synchronizes the library from any configured synchronization location.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Sync()
Visual Basic (Declaration)
Public Function Sync As Boolean
Visual C++
public:
virtual bool Sync() sealed

Return Value

true if successful, or false if an error or if cancelled.

Implements

IPersistManager..::.Sync()()()

See Also

Manager Class
Mincom.LinkOne.Provider.Persist Namespace


Manager Properties

[image] [image]

LinkOne WebView API
Manager Properties
Manager Class See Also Send Feedback

The Manager type exposes the following members.

Properties

Name | Description
Libraries | Gets the sub library collection for the master library.
ReportingLevel | Get or sets the reporting level for updates and prepares.
Syncing | Gets a value indicating whether this Manager is for syncing.

Explicit Interface Implementations

Name | Description
IPersistManager..::.Libraries | Gets the libraries.
IPersistManager..::.Provider | Gets the provider.

See Also

Manager Class
Mincom.LinkOne.Provider.Persist Namespace


IPersistManager.Libraries Property

[image]

LinkOne WebView API
Manager..::.IPersistManager..::.Libraries Property
Manager Class See Also Send Feedback
Gets the libraries.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPersistLibraryCollection IPersistManager.Libraries { get; }
Visual Basic (Declaration)
Private ReadOnly Property Libraries As IPersistLibraryCollection
    Implements IPersistManager.Libraries
Visual C++
private:
virtual property IPersistLibraryCollection^ Libraries {
    IPersistLibraryCollection^ get () sealed = IPersistManager::Libraries::get;
}

Field Value

Implements

IPersistManager..::.Libraries

See Also

Manager Class
Mincom.LinkOne.Provider.Persist Namespace


IPersistManager.Provider Property

[image]

LinkOne WebView API
Manager..::.IPersistManager..::.Provider Property
Manager Class See Also Send Feedback
Gets the provider.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPersistService IPersistManager.Provider { get; }
Visual Basic (Declaration)
Private ReadOnly Property Provider As IPersistService
    Implements IPersistManager.Provider
Visual C++
private:
virtual property IPersistService^ Provider {
    IPersistService^ get () sealed = IPersistManager::Provider::get;
}

Field Value

Implements

IPersistManager..::.Provider

See Also

Manager Class
Mincom.LinkOne.Provider.Persist Namespace


Libraries Property

[image]

LinkOne WebView API
Manager..::.Libraries Property
Manager Class See Also Send Feedback
Gets the sub library collection for the master library.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public LibraryCollection Libraries { get; }
Visual Basic (Declaration)
Public ReadOnly Property Libraries As LibraryCollection
Visual C++
public:
property LibraryCollection^ Libraries {
    LibraryCollection^ get ();
}

See Also

Manager Class
Mincom.LinkOne.Provider.Persist Namespace


ReportingLevel Property

[image]

LinkOne WebView API
Manager..::.ReportingLevel Property
Manager Class See Also Send Feedback
Get or sets the reporting level for updates and prepares.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public ReportingLevel ReportingLevel { get; set; }
Visual Basic (Declaration)
Public Property ReportingLevel As ReportingLevel
Visual C++
public:
virtual property ReportingLevel ReportingLevel {
    ReportingLevel get () sealed;
    void set (ReportingLevel value) sealed;
}

Implements

IPersistManager..::.ReportingLevel

See Also

Manager Class
Mincom.LinkOne.Provider.Persist Namespace


Syncing Property

[image]

LinkOne WebView API
Manager..::.Syncing Property
Manager Class See Also Send Feedback
Gets a value indicating whether this Manager is for syncing.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Syncing { get; set; }
Visual Basic (Declaration)
Public Property Syncing As Boolean
Visual C++
public:
virtual property bool Syncing {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IPersistManager..::.Syncing

See Also

Manager Class
Mincom.LinkOne.Provider.Persist Namespace


Publisher Class

[image]

LinkOne WebView API
Publisher Class
Members See Also Send Feedback
Represents a Publisher in a Library()()().

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public sealed class Publisher : IPersistPublisher
Visual Basic (Declaration)
Public NotInheritable Class Publisher _
    Implements IPersistPublisher
Visual C++
public ref class Publisher sealed : IPersistPublisher

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Provider.Persist..::.Publisher

See Also

Publisher Members
Mincom.LinkOne.Provider.Persist Namespace


Publisher Members

[image] [image]

LinkOne WebView API
Publisher Members
Publisher Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The Publisher type exposes the following members.

Methods

Name | Description
Compress | Compresses all content in the publisher.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Expand | Expands all content in the publisher.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPublisherVersion | check all books in publisher, if they are -- all the same internal version number return it, eg ver 6, return 6. -- if one or more books are ver 6 and the rest are not, return 0 -- otherwise return -1 (error)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Prepare | Prepares the publisher for internet delivery.
Remove | Removes the publisher from the filing system.
Sync | Synchronizes the publisher from any configured synchronization location.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
BookCategoryTranslations | Gets the book category translations.
Catalog | Gets the book catalog for this publisher.
Location | Gets the directory location of the publisher.
PublisherCode | Gets the publisher code.
PublisherDescription | Gets the publisher description.
PublisherDescriptionTranslations | Gets the description translations for this publisher.
Version | Gets the version string for the publisher. NB: major.minor.patch style
VersionNumber | Gets the internal version number for the publisher. NB: -1 to whatever, NOT major.minor.patch style

Explicit Interface Implementations

Name | Description
IPersistPublisher..::.Books | Gets the list of books for this publisher.
IPersistPublisher..::.Catalog | Gets the book catalog for this publisher.
IPersistPublisher..::.Library | Gets the publisher library.
IPersistPublisher..::.PublisherDescriptionTranslations | Gets the publisher description tranlsations.

See Also

Publisher Class
Mincom.LinkOne.Provider.Persist Namespace


Publisher Methods

[image] [image]

LinkOne WebView API
Publisher Methods
Publisher Class See Also Send Feedback

The Publisher type exposes the following members.

Methods

Name | Description
Compress | Compresses all content in the publisher.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Expand | Expands all content in the publisher.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPublisherVersion | check all books in publisher, if they are -- all the same internal version number return it, eg ver 6, return 6. -- if one or more books are ver 6 and the rest are not, return 0 -- otherwise return -1 (error)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Prepare | Prepares the publisher for internet delivery.
Remove | Removes the publisher from the filing system.
Sync | Synchronizes the publisher from any configured synchronization location.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Publisher Class
Mincom.LinkOne.Provider.Persist Namespace


Compress Method

[image]

LinkOne WebView API
Publisher..::.Compress Method
Publisher Class See Also Send Feedback
Compresses all content in the publisher.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Compress()
Visual Basic (Declaration)
Public Function Compress As Boolean
Visual C++
public:
virtual bool Compress() sealed

Return Value

true if successful, or false if an error or if cancelled.

Implements

IPersistPublisher..::.Compress()()()

See Also

Publisher Class
Mincom.LinkOne.Provider.Persist Namespace


Expand Method

[image]

LinkOne WebView API
Publisher..::.Expand Method
Publisher Class See Also Send Feedback
Expands all content in the publisher.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Expand()
Visual Basic (Declaration)
Public Function Expand As Boolean
Visual C++
public:
virtual bool Expand() sealed

Return Value

true if successful, or false if an error or if cancelled.

Implements

IPersistPublisher..::.Expand()()()

See Also

Publisher Class
Mincom.LinkOne.Provider.Persist Namespace


GetPublisherVersion Method

[image]

LinkOne WebView API
Publisher..::.GetPublisherVersion Method
Publisher Class See Also Send Feedback
check all books in publisher, if they are -- all the same internal version number return it, eg ver 6, return 6. -- if one or more books are ver 6 and the rest are not, return 0 -- otherwise return -1 (error)

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void GetPublisherVersion(
    out int versionNumber,
    out string version
)
Visual Basic (Declaration)
Public Sub GetPublisherVersion ( _
    <OutAttribute> ByRef versionNumber As Integer, _
    <OutAttribute> ByRef version As String _
)
Visual C++
public:
void GetPublisherVersion(
    [OutAttribute] int% versionNumber,
    [OutAttribute] String^% version
)

Parameters

versionNumber
Type: System..::.Int32 %
version
Type: System..::.String %

Return Value

The Publisher Version Number: -1 if a book has no VerNum, 0 if a mix of 5.1 and pre 5.1 books, otherwise the last book VerNum read.

See Also

Publisher Class
Mincom.LinkOne.Provider.Persist Namespace


Prepare Method

[image]

LinkOne WebView API
Publisher..::.Prepare Method
Publisher Class See Also Send Feedback
Prepares the publisher for internet delivery.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Prepare(
    bool includeBookContent
)
Visual Basic (Declaration)
Public Function Prepare ( _
    includeBookContent As Boolean _
) As Boolean
Visual C++
public:
virtual bool Prepare(
    bool includeBookContent
) sealed

Parameters

includeBookContent
Type: System..::.Boolean
true to also prepare book content.

Return Value

true if successful, or false if an error or if cancelled.

Implements

IPersistPublisher..::.Prepare(Boolean)

Remarks

Recreates the publisher's book.lst from the publisher books' book.def files.

See Also

Publisher Class
Mincom.LinkOne.Provider.Persist Namespace


Remove Method

[image]

LinkOne WebView API
Publisher..::.Remove Method
Publisher Class See Also Send Feedback
Removes the publisher from the filing system.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Remove()
Visual Basic (Declaration)
Public Sub Remove
Visual C++
public:
virtual void Remove() sealed

Implements

IPersistPublisher..::.Remove()()()

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.IOException | If the publisher directory could not be deleted.

See Also

Publisher Class
Mincom.LinkOne.Provider.Persist Namespace


Sync Method

[image]

LinkOne WebView API
Publisher..::.Sync Method
Publisher Class See Also Send Feedback
Synchronizes the publisher from any configured synchronization location.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Sync()
Visual Basic (Declaration)
Public Function Sync As Boolean
Visual C++
public:
virtual bool Sync() sealed

Return Value

true if successful, or false if an error or if cancelled.

Implements

IPersistPublisher..::.Sync()()()

See Also

Publisher Class
Mincom.LinkOne.Provider.Persist Namespace


Publisher Properties

[image] [image]

LinkOne WebView API
Publisher Properties
Publisher Class See Also Send Feedback

The Publisher type exposes the following members.

Properties

Name | Description
BookCategoryTranslations | Gets the book category translations.
Catalog | Gets the book catalog for this publisher.
Location | Gets the directory location of the publisher.
PublisherCode | Gets the publisher code.
PublisherDescription | Gets the publisher description.
PublisherDescriptionTranslations | Gets the description translations for this publisher.
Version | Gets the version string for the publisher. NB: major.minor.patch style
VersionNumber | Gets the internal version number for the publisher. NB: -1 to whatever, NOT major.minor.patch style

Explicit Interface Implementations

Name | Description
IPersistPublisher..::.Books | Gets the list of books for this publisher.
IPersistPublisher..::.Catalog | Gets the book catalog for this publisher.
IPersistPublisher..::.Library | Gets the publisher library.
IPersistPublisher..::.PublisherDescriptionTranslations | Gets the publisher description tranlsations.

See Also

Publisher Class
Mincom.LinkOne.Provider.Persist Namespace


BookCategoryTranslations Property

[image]

LinkOne WebView API
Publisher..::.BookCategoryTranslations Property
Publisher Class See Also Send Feedback
Gets the book category translations.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IDictionary<string, TranslationCollection> BookCategoryTranslations { get; }
Visual Basic (Declaration)
Public ReadOnly Property BookCategoryTranslations As IDictionary(Of String, TranslationCollection)
Visual C++
public:
property IDictionary<String^, TranslationCollection^>^ BookCategoryTranslations {
    IDictionary<String^, TranslationCollection^>^ get ();
}

See Also

Publisher Class
Mincom.LinkOne.Provider.Persist Namespace


Catalog Property

[image]

LinkOne WebView API
Publisher..::.Catalog Property
Publisher Class See Also Send Feedback
Gets the book catalog for this publisher.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public Catalog Catalog { get; }
Visual Basic (Declaration)
Public ReadOnly Property Catalog As Catalog
Visual C++
public:
property Catalog^ Catalog {
    Catalog^ get ();
}

See Also

Publisher Class
Mincom.LinkOne.Provider.Persist Namespace


IPersistPublisher.Books Property

[image]

LinkOne WebView API
Publisher..::.IPersistPublisher..::.Books Property
Publisher Class See Also Send Feedback
Gets the list of books for this publisher.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPersistBookCollection IPersistPublisher.Books { get; }
Visual Basic (Declaration)
Private ReadOnly Property Books As IPersistBookCollection
    Implements IPersistPublisher.Books
Visual C++
private:
virtual property IPersistBookCollection^ Books {
    IPersistBookCollection^ get () sealed = IPersistPublisher::Books::get;
}

Field Value

Implements

IPersistPublisher..::.Books

See Also

Publisher Class
Mincom.LinkOne.Provider.Persist Namespace


IPersistPublisher.Catalog Property

[image]

LinkOne WebView API
Publisher..::.IPersistPublisher..::.Catalog Property
Publisher Class See Also Send Feedback
Gets the book catalog for this publisher.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPersistCatalog IPersistPublisher.Catalog { get; }
Visual Basic (Declaration)
Private ReadOnly Property Catalog As IPersistCatalog
    Implements IPersistPublisher.Catalog
Visual C++
private:
virtual property IPersistCatalog^ Catalog {
    IPersistCatalog^ get () sealed = IPersistPublisher::Catalog::get;
}

Field Value

Implements

IPersistPublisher..::.Catalog

See Also

Publisher Class
Mincom.LinkOne.Provider.Persist Namespace


IPersistPublisher.Library Property

[image]

LinkOne WebView API
Publisher..::.IPersistPublisher..::.Library Property
Publisher Class See Also Send Feedback
Gets the publisher library.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPersistLibrary IPersistPublisher.Library { get; }
Visual Basic (Declaration)
Private ReadOnly Property Library As IPersistLibrary
    Implements IPersistPublisher.Library
Visual C++
private:
virtual property IPersistLibrary^ Library {
    IPersistLibrary^ get () sealed = IPersistPublisher::Library::get;
}

Implements

IPersistPublisher..::.Library

See Also

Publisher Class
Mincom.LinkOne.Provider.Persist Namespace


IPersistPublisher.PublisherDescriptionTranslations Property

[image]

LinkOne WebView API
Publisher..::.IPersistPublisher..::.PublisherDescriptionTranslations Property
Publisher Class See Also Send Feedback
Gets the publisher description tranlsations.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IDictionary<string, string> IPersistPublisher.PublisherDescriptionTranslations { get; }
Visual Basic (Declaration)
Private ReadOnly Property PublisherDescriptionTranslations As IDictionary(Of String, String)
    Implements IPersistPublisher.PublisherDescriptionTranslations
Visual C++
private:
virtual property IDictionary<String^, String^>^ PublisherDescriptionTranslations {
    IDictionary<String^, String^>^ get () sealed = IPersistPublisher::PublisherDescriptionTranslations::get;
}

Implements

IPersistPublisher..::.PublisherDescriptionTranslations

See Also

Publisher Class
Mincom.LinkOne.Provider.Persist Namespace


Location Property

[image]

LinkOne WebView API
Publisher..::.Location Property
Publisher Class See Also Send Feedback
Gets the directory location of the publisher.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Location { get; }
Visual Basic (Declaration)
Public ReadOnly Property Location As String
Visual C++
public:
virtual property String^ Location {
    String^ get () sealed;
}

Implements

IPersistPublisher..::.Location

See Also

Publisher Class
Mincom.LinkOne.Provider.Persist Namespace


PublisherCode Property

[image]

LinkOne WebView API
Publisher..::.PublisherCode Property
Publisher Class See Also Send Feedback
Gets the publisher code.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PublisherCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublisherCode As String
Visual C++
public:
virtual property String^ PublisherCode {
    String^ get () sealed;
}

Implements

IPersistPublisher..::.PublisherCode

See Also

Publisher Class
Mincom.LinkOne.Provider.Persist Namespace


PublisherDescription Property

[image]

LinkOne WebView API
Publisher..::.PublisherDescription Property
Publisher Class See Also Send Feedback
Gets the publisher description.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string PublisherDescription { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublisherDescription As String
Visual C++
public:
virtual property String^ PublisherDescription {
    String^ get () sealed;
}

Implements

IPersistPublisher..::.PublisherDescription

See Also

Publisher Class
Mincom.LinkOne.Provider.Persist Namespace


PublisherDescriptionTranslations Property

[image]

LinkOne WebView API
Publisher..::.PublisherDescriptionTranslations Property
Publisher Class See Also Send Feedback
Gets the description translations for this publisher.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public TranslationCollection PublisherDescriptionTranslations { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublisherDescriptionTranslations As TranslationCollection
Visual C++
public:
property TranslationCollection^ PublisherDescriptionTranslations {
    TranslationCollection^ get ();
}

See Also

Publisher Class
Mincom.LinkOne.Provider.Persist Namespace


Version Property

[image]

LinkOne WebView API
Publisher..::.Version Property
Publisher Class See Also Send Feedback
Gets the version string for the publisher. NB: major.minor.patch style

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public string Version { get; }
Visual Basic (Declaration)
Public ReadOnly Property Version As String
Visual C++
public:
property String^ Version {
    String^ get ();
}

See Also

Publisher Class
Mincom.LinkOne.Provider.Persist Namespace


VersionNumber Property

[image]

LinkOne WebView API
Publisher..::.VersionNumber Property
Publisher Class See Also Send Feedback
Gets the internal version number for the publisher. NB: -1 to whatever, NOT major.minor.patch style

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int VersionNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property VersionNumber As Integer
Visual C++
public:
property int VersionNumber {
    int get ();
}

See Also

Publisher Class
Mincom.LinkOne.Provider.Persist Namespace


PublisherCollection Class

[image]

LinkOne WebView API
PublisherCollection Class
Members See Also Send Feedback
Represents a collection of Publisher objects.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public sealed class PublisherCollection : IPersistPublisherCollection,
    ICollection<IPersistPublisher>, IEnumerable<IPersistPublisher>, IEnumerable
Visual Basic (Declaration)
Public NotInheritable Class PublisherCollection _
    Implements IPersistPublisherCollection, ICollection(Of IPersistPublisher),  _
    IEnumerable(Of IPersistPublisher), IEnumerable
Visual C++
public ref class PublisherCollection sealed : IPersistPublisherCollection,
    ICollection<IPersistPublisher^>, IEnumerable<IPersistPublisher^>, IEnumerable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.Provider.Persist..::.PublisherCollection

See Also

PublisherCollection Members
Mincom.LinkOne.Provider.Persist Namespace


PublisherCollection Members

[image] [image]

LinkOne WebView API
PublisherCollection Members
PublisherCollection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The PublisherCollection type exposes the following members.

Methods

Name | Description
Add | See Add(T) for more information.
Clear | See Clear()()() for more information.
Contains | Overloaded.
CopyTo | See CopyTo(array<T>[]()[], Int32) for more information.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | See GetEnumerator()()() for more information.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSortedForLanguage | Returns the collection sorted by the translations for the given language.
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | See Remove(T) for more information.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | See Count for more information.
IsReadOnly | See IsReadOnly for more information.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | See GetEnumerator()()() for more information.
IPersistPublisherCollection..::.GetSortedForLanguage | Gets the publishers sorted by description for the given language.
IPersistPublisherCollection..::.Item | Gets the IPersistPublisher with the specified publisher code.

See Also

PublisherCollection Class
Mincom.LinkOne.Provider.Persist Namespace


PublisherCollection Methods

[image] [image]

LinkOne WebView API
PublisherCollection Methods
PublisherCollection Class See Also Send Feedback

The PublisherCollection type exposes the following members.

Methods

Name | Description
Add | See Add(T) for more information.
Clear | See Clear()()() for more information.
Contains | Overloaded.
CopyTo | See CopyTo(array<T>[]()[], Int32) for more information.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | See GetEnumerator()()() for more information.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSortedForLanguage | Returns the collection sorted by the translations for the given language.
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | See Remove(T) for more information.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | See GetEnumerator()()() for more information.
IPersistPublisherCollection..::.GetSortedForLanguage | Gets the publishers sorted by description for the given language.

See Also

PublisherCollection Class
Mincom.LinkOne.Provider.Persist Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
PublisherCollection..::.IEnumerable..::.GetEnumerator Method
PublisherCollection Class See Also Send Feedback
See GetEnumerator()()() for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Implements

IEnumerable..::.GetEnumerator()()()

See Also

PublisherCollection Class
Mincom.LinkOne.Provider.Persist Namespace


Add Method

[image]

LinkOne WebView API
PublisherCollection..::.Add Method
PublisherCollection Class See Also Send Feedback
See Add(T) for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Add(
    IPersistPublisher item
)
Visual Basic (Declaration)
Public Sub Add ( _
    item As IPersistPublisher _
)
Visual C++
public:
virtual void Add(
    IPersistPublisher^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Provider.Persist..::.IPersistPublisher

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

PublisherCollection Class
Mincom.LinkOne.Provider.Persist Namespace


Clear Method

[image]

LinkOne WebView API
PublisherCollection..::.Clear Method
PublisherCollection Class See Also Send Feedback
See Clear()()() for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
virtual void Clear() sealed

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

See Also

PublisherCollection Class
Mincom.LinkOne.Provider.Persist Namespace


Contains Method

[image] [image]

LinkOne WebView API
PublisherCollection..::.Contains Method
PublisherCollection Class See Also Send Feedback

Overload List

Name | Description
Contains(IPersistPublisher) | See Contains(T) for more information.
Contains(String) | Gets whether or not the collection contains the publisher code.

See Also

PublisherCollection Class
PublisherCollection Members
Mincom.LinkOne.Provider.Persist Namespace


Contains Method (IPersistPublisher)

[image]

LinkOne WebView API
PublisherCollection..::.Contains Method (IPersistPublisher)
PublisherCollection Class See Also Send Feedback
See Contains(T) for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    IPersistPublisher item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As IPersistPublisher _
) As Boolean
Visual C++
public:
virtual bool Contains(
    IPersistPublisher^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Provider.Persist..::.IPersistPublisher

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

PublisherCollection Class
Contains Overload
Mincom.LinkOne.Provider.Persist Namespace


Contains Method (String)

[image]

LinkOne WebView API
PublisherCollection..::.Contains Method (String)
PublisherCollection Class See Also Send Feedback
Gets whether or not the collection contains the publisher code.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Contains(
    string publisherCode
)
Visual Basic (Declaration)
Public Function Contains ( _
    publisherCode As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ publisherCode
) sealed

Parameters

publisherCode
Type: System..::.String
The pubilsher code to check.

Return Value

true if the collection contains the publisher code, false otherwise.

Implements

IPersistPublisherCollection..::.Contains(String)

See Also

PublisherCollection Class
Contains Overload
Mincom.LinkOne.Provider.Persist Namespace


CopyTo Method

[image]

LinkOne WebView API
PublisherCollection..::.CopyTo Method
PublisherCollection Class See Also Send Feedback
See CopyTo(array<T>[]()[], Int32) for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public void CopyTo(
    IPersistPublisher[] array,
    int arrayIndex
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As IPersistPublisher(), _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    array<IPersistPublisher^>^ array,
    int arrayIndex
) sealed

Parameters

array
Type: array< Mincom.LinkOne.Provider.Persist..::.IPersistPublisher >[]()[]
arrayIndex
Type: System..::.Int32

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

PublisherCollection Class
Mincom.LinkOne.Provider.Persist Namespace


GetEnumerator Method

[image]

LinkOne WebView API
PublisherCollection..::.GetEnumerator Method
PublisherCollection Class See Also Send Feedback
See GetEnumerator()()() for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IEnumerator<IPersistPublisher> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of IPersistPublisher)
Visual C++
public:
virtual IEnumerator<IPersistPublisher^>^ GetEnumerator() sealed

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

PublisherCollection Class
Mincom.LinkOne.Provider.Persist Namespace


GetSortedForLanguage Method

[image]

LinkOne WebView API
PublisherCollection..::.GetSortedForLanguage Method
PublisherCollection Class See Also Send Feedback
Returns the collection sorted by the translations for the given language.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public IEnumerable<Publisher> GetSortedForLanguage(
    string languageCode
)
Visual Basic (Declaration)
Public Function GetSortedForLanguage ( _
    languageCode As String _
) As IEnumerable(Of Publisher)
Visual C++
public:
IEnumerable<Publisher^>^ GetSortedForLanguage(
    String^ languageCode
)

Parameters

languageCode
Type: System..::.String
The language code to sort by.

Return Value

The collection sorted by the translations for the given language.

See Also

PublisherCollection Class
Mincom.LinkOne.Provider.Persist Namespace


IPersistPublisherCollection.GetSortedForLanguage Method

[image]

LinkOne WebView API
PublisherCollection..::.IPersistPublisherCollection..::.GetSortedForLanguage Method
PublisherCollection Class See Also Send Feedback
Gets the publishers sorted by description for the given language.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IEnumerable<IPersistPublisher> IPersistPublisherCollection.GetSortedForLanguage(
    string languageCode
)
Visual Basic (Declaration)
Private Function GetSortedForLanguage ( _
    languageCode As String _
) As IEnumerable(Of IPersistPublisher) Implements IPersistPublisherCollection.GetSortedForLanguage
Visual C++
private:
virtual IEnumerable<IPersistPublisher^>^ GetSortedForLanguage(
    String^ languageCode
) sealed = IPersistPublisherCollection::GetSortedForLanguage

Parameters

languageCode
Type: System..::.String
The language code.

Return Value

The publishers sorted by description for the given language.

Implements

IPersistPublisherCollection..::.GetSortedForLanguage(String)

See Also

PublisherCollection Class
Mincom.LinkOne.Provider.Persist Namespace


Remove Method

[image]

LinkOne WebView API
PublisherCollection..::.Remove Method
PublisherCollection Class See Also Send Feedback
See Remove(T) for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool Remove(
    IPersistPublisher item
)
Visual Basic (Declaration)
Public Function Remove ( _
    item As IPersistPublisher _
) As Boolean
Visual C++
public:
virtual bool Remove(
    IPersistPublisher^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.Provider.Persist..::.IPersistPublisher

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

PublisherCollection Class
Mincom.LinkOne.Provider.Persist Namespace


PublisherCollection Properties

[image] [image]

LinkOne WebView API
PublisherCollection Properties
PublisherCollection Class See Also Send Feedback

The PublisherCollection type exposes the following members.

Properties

Name | Description
Count | See Count for more information.
IsReadOnly | See IsReadOnly for more information.

Explicit Interface Implementations

Name | Description
IPersistPublisherCollection..::.Item | Gets the IPersistPublisher with the specified publisher code.

See Also

PublisherCollection Class
Mincom.LinkOne.Provider.Persist Namespace


Count Property

[image]

LinkOne WebView API
PublisherCollection..::.Count Property
PublisherCollection Class See Also Send Feedback
See Count for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

PublisherCollection Class
Mincom.LinkOne.Provider.Persist Namespace


IPersistPublisherCollection.Item Property

[image]

LinkOne WebView API
PublisherCollection..::.IPersistPublisherCollection..::.Item Property
PublisherCollection Class See Also Send Feedback
Gets the IPersistPublisher with the specified publisher code.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
IPersistPublisher IPersistPublisherCollection.Item[
    string publisherCode
] { get; }
Visual Basic (Declaration)
Private ReadOnly Property Item ( _
    publisherCode As String _
) As IPersistPublisher Implements IPersistPublisherCollection.Item
Visual C++
private:
virtual property IPersistPublisher^ Item[String^ publisherCode] {
    IPersistPublisher^ get (String^ publisherCode) sealed = IPersistPublisherCollection::Item::get;
}

Parameters

publisherCode
Type: System..::.String

Implements

IPersistPublisherCollection..::.Item[([(String])])

See Also

PublisherCollection Class
Mincom.LinkOne.Provider.Persist Namespace


IsReadOnly Property

[image]

LinkOne WebView API
PublisherCollection..::.IsReadOnly Property
PublisherCollection Class See Also Send Feedback
See IsReadOnly for more information.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider (in Mincom.LinkOne.Provider.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

PublisherCollection Class
Mincom.LinkOne.Provider.Persist Namespace


ReportingLevel Enumeration

[image]

LinkOne WebView API
ReportingLevel Enumeration
See Also Send Feedback
The reporting level detail.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public enum ReportingLevel
Visual Basic (Declaration)
Public Enumeration ReportingLevel
Visual C++
public enum class ReportingLevel

Members

Member name | Description
None | Report nothing.
Errors | Report errors only.
Summary | Provide only summary reporting.
Detailed | Provide detailed reporting.

See Also

Mincom.LinkOne.Provider.Persist Namespace


SyncType Enumeration

[image]

LinkOne WebView API
SyncType Enumeration
See Also Send Feedback
Represents the types of Library synchronization.

Namespace: Mincom.LinkOne.Provider.Persist
Assembly: Mincom.LinkOne.Provider.Api (in Mincom.LinkOne.Provider.Api.dll) Version: 3.58.5361.0

Syntax

C#
public enum SyncType
Visual Basic (Declaration)
Public Enumeration SyncType
Visual C++
public enum class SyncType

Members

Member name | Description
None | Library is not synchronized.
SyncUsed | Synchronize used files.
SyncAll | Synchronize all books.
SyncInstalled | Synchronize all installed books

See Also

Mincom.LinkOne.Provider.Persist Namespace


Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace
Send Feedback

Classes

Class | Description
Brush |
DIB |
Font |
Metafile |
Object |
Pen |
State |

Structures

Structure | Description
DIB..::.BITMAPINFOHEADER |

Enumerations

Enumeration | Description
State..::.MapModes |
State..::.MixMode |
State..::.ModifyWorldTransformModes |
State..::.PolyFillModes |
State..::.StockObject |
State..::.TextAlignmentModes |


Brush Class

[image]

LinkOne WebView API
Brush Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class Brush : Object
Visual Basic (Declaration)
Public Class Brush _
    Inherits Object
Visual C++
public ref class Brush : public Object

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.Printer.EmfToPdf..::.Object
Mincom.LinkOne.WebView.Printer.EmfToPdf..::.Brush

See Also

Brush Members
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Brush Members

[image] [image]

LinkOne WebView API
Brush Members
Brush Class Constructors Methods Properties See Also Send Feedback

The Brush type exposes the following members.

Constructors

Name | Description
Brush | Initializes a new instance of the Brush class

Methods

Name | Description
Apply | (Overrides Object..::.Apply(State).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
BrushHatch |
BrushStyle |
Color |

See Also

Brush Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Brush Constructor

[image]

LinkOne WebView API
Brush Constructor
Brush Class See Also Send Feedback
Initializes a new instance of the Brush class

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Brush(
    ref BinaryReader reader
)
Visual Basic (Declaration)
Public Sub New ( _
    ByRef reader As BinaryReader _
)
Visual C++
public:
Brush(
    BinaryReader^% reader
)

Parameters

reader
Type: System.IO..::.BinaryReader %

See Also

Brush Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Brush Methods

[image] [image]

LinkOne WebView API
Brush Methods
Brush Class See Also Send Feedback

The Brush type exposes the following members.

Methods

Name | Description
Apply | (Overrides Object..::.Apply(State).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Brush Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Apply Method

[image]

LinkOne WebView API
Brush..::.Apply Method
Brush Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public override void Apply(
    State state
)
Visual Basic (Declaration)
Public Overrides Sub Apply ( _
    state As State _
)
Visual C++
public:
virtual void Apply(
    State^ state
) override

Parameters

state
Type: Mincom.LinkOne.WebView.Printer.EmfToPdf..::.State

See Also

Brush Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Brush Properties

[image] [image]

LinkOne WebView API
Brush Properties
Brush Class See Also Send Feedback

The Brush type exposes the following members.

Properties

Name | Description
BrushHatch |
BrushStyle |
Color |

See Also

Brush Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


BrushHatch Property

[image]

LinkOne WebView API
Brush..::.BrushHatch Property
Brush Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public uint BrushHatch { get; set; }
Visual Basic (Declaration)
Public Property BrushHatch As UInteger
Visual C++
public:
property unsigned int BrushHatch {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Brush Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


BrushStyle Property

[image]

LinkOne WebView API
Brush..::.BrushStyle Property
Brush Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public uint BrushStyle { get; set; }
Visual Basic (Declaration)
Public Property BrushStyle As UInteger
Visual C++
public:
property unsigned int BrushStyle {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Brush Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Color Property

[image]

LinkOne WebView API
Brush..::.Color Property
Brush Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

See Also

Brush Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


DIB Class

[image]

LinkOne WebView API
DIB Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public static class DIB
Visual Basic (Declaration)
Public NotInheritable Class DIB
Visual C++
public ref class DIB abstract sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.Printer.EmfToPdf..::.DIB

See Also

DIB Members
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


DIB Members

[image] [image]

LinkOne WebView API
DIB Members
DIB Class Methods See Also Send Feedback

Methods

Name | Description
ConvertToBitmap | Overloaded.

See Also

DIB Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


DIB Methods

[image] [image]

LinkOne WebView API
DIB Methods
DIB Class See Also Send Feedback

Methods

Name | Description
ConvertToBitmap | Overloaded.

See Also

DIB Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


ConvertToBitmap Method

[image] [image]

LinkOne WebView API
DIB..::.ConvertToBitmap Method
DIB Class See Also Send Feedback

Overload List

Name | Description
ConvertToBitmap(array<Byte>[]()[]) |
ConvertToBitmap(array<Byte>[]()[], UInt32, UInt32) |

See Also

DIB Class
DIB Members
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


ConvertToBitmap Method (Byte[])

[image]

LinkOne WebView API
DIB..::.ConvertToBitmap Method (array<Byte>[]()[])
DIB Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public static Bitmap ConvertToBitmap(
    byte[] dibBytes
)
Visual Basic (Declaration)
Public Shared Function ConvertToBitmap ( _
    dibBytes As Byte() _
) As Bitmap
Visual C++
public:
static Bitmap^ ConvertToBitmap(
    array<unsigned char>^ dibBytes
)

Parameters

dibBytes
Type: array< System..::.Byte >[]()[]

See Also

DIB Class
ConvertToBitmap Overload
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


ConvertToBitmap Method (Byte[], UInt32, UInt32)

[image]

LinkOne WebView API
DIB..::.ConvertToBitmap Method (array<Byte>[]()[], UInt32, UInt32)
DIB Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public static Bitmap ConvertToBitmap(
    byte[] dibBytes,
    uint bitsOffset,
    uint usage
)
Visual Basic (Declaration)
Public Shared Function ConvertToBitmap ( _
    dibBytes As Byte(), _
    bitsOffset As UInteger, _
    usage As UInteger _
) As Bitmap
Visual C++
public:
static Bitmap^ ConvertToBitmap(
    array<unsigned char>^ dibBytes,
    unsigned int bitsOffset,
    unsigned int usage
)

Parameters

dibBytes
Type: array< System..::.Byte >[]()[]
bitsOffset
Type: System..::.UInt32
usage
Type: System..::.UInt32

See Also

DIB Class
ConvertToBitmap Overload
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


DIB.BITMAPINFOHEADER Structure

[image]

LinkOne WebView API
DIB..::.BITMAPINFOHEADER Structure
DIB Class Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public struct BITMAPINFOHEADER
Visual Basic (Declaration)
Public Structure BITMAPINFOHEADER
Visual C++
public value class BITMAPINFOHEADER

See Also

DIB..::.BITMAPINFOHEADER Members
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


DIB.BITMAPINFOHEADER Members

[image] [image]

LinkOne WebView API
DIB..::.BITMAPINFOHEADER Members
DIB..::.BITMAPINFOHEADER Structure Methods Fields See Also Send Feedback

The DIB..::.BITMAPINFOHEADER type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

Name | Description
biBitCount |
biClrImportant |
biClrUsed |
biCompression |
biHeight |
biPlanes |
biSize |
biSizeImage |
biWidth |
biXPelsPerMeter |
biYPelsPerMeter |

See Also

DIB..::.BITMAPINFOHEADER Structure
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


DIB.BITMAPINFOHEADER Fields

[image] [image]

LinkOne WebView API
DIB..::.BITMAPINFOHEADER Fields
DIB..::.BITMAPINFOHEADER Structure See Also Send Feedback

The DIB..::.BITMAPINFOHEADER type exposes the following members.

Fields

Name | Description
biBitCount |
biClrImportant |
biClrUsed |
biCompression |
biHeight |
biPlanes |
biSize |
biSizeImage |
biWidth |
biXPelsPerMeter |
biYPelsPerMeter |

See Also

DIB..::.BITMAPINFOHEADER Structure
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


biBitCount Field

[image]

LinkOne WebView API
DIB..::.BITMAPINFOHEADER..::.biBitCount Field
DIB..::.BITMAPINFOHEADER Structure See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public ushort biBitCount
Visual Basic (Declaration)
Public biBitCount As UShort
Visual C++
public:
unsigned short biBitCount

See Also

DIB..::.BITMAPINFOHEADER Structure
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


biClrImportant Field

[image]

LinkOne WebView API
DIB..::.BITMAPINFOHEADER..::.biClrImportant Field
DIB..::.BITMAPINFOHEADER Structure See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public uint biClrImportant
Visual Basic (Declaration)
Public biClrImportant As UInteger
Visual C++
public:
unsigned int biClrImportant

See Also

DIB..::.BITMAPINFOHEADER Structure
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


biClrUsed Field

[image]

LinkOne WebView API
DIB..::.BITMAPINFOHEADER..::.biClrUsed Field
DIB..::.BITMAPINFOHEADER Structure See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public uint biClrUsed
Visual Basic (Declaration)
Public biClrUsed As UInteger
Visual C++
public:
unsigned int biClrUsed

See Also

DIB..::.BITMAPINFOHEADER Structure
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


biCompression Field

[image]

LinkOne WebView API
DIB..::.BITMAPINFOHEADER..::.biCompression Field
DIB..::.BITMAPINFOHEADER Structure See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public uint biCompression
Visual Basic (Declaration)
Public biCompression As UInteger
Visual C++
public:
unsigned int biCompression

See Also

DIB..::.BITMAPINFOHEADER Structure
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


biHeight Field

[image]

LinkOne WebView API
DIB..::.BITMAPINFOHEADER..::.biHeight Field
DIB..::.BITMAPINFOHEADER Structure See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int biHeight
Visual Basic (Declaration)
Public biHeight As Integer
Visual C++
public:
int biHeight

See Also

DIB..::.BITMAPINFOHEADER Structure
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


biPlanes Field

[image]

LinkOne WebView API
DIB..::.BITMAPINFOHEADER..::.biPlanes Field
DIB..::.BITMAPINFOHEADER Structure See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public ushort biPlanes
Visual Basic (Declaration)
Public biPlanes As UShort
Visual C++
public:
unsigned short biPlanes

See Also

DIB..::.BITMAPINFOHEADER Structure
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


biSize Field

[image]

LinkOne WebView API
DIB..::.BITMAPINFOHEADER..::.biSize Field
DIB..::.BITMAPINFOHEADER Structure See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public uint biSize
Visual Basic (Declaration)
Public biSize As UInteger
Visual C++
public:
unsigned int biSize

See Also

DIB..::.BITMAPINFOHEADER Structure
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


biSizeImage Field

[image]

LinkOne WebView API
DIB..::.BITMAPINFOHEADER..::.biSizeImage Field
DIB..::.BITMAPINFOHEADER Structure See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public uint biSizeImage
Visual Basic (Declaration)
Public biSizeImage As UInteger
Visual C++
public:
unsigned int biSizeImage

See Also

DIB..::.BITMAPINFOHEADER Structure
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


biWidth Field

[image]

LinkOne WebView API
DIB..::.BITMAPINFOHEADER..::.biWidth Field
DIB..::.BITMAPINFOHEADER Structure See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int biWidth
Visual Basic (Declaration)
Public biWidth As Integer
Visual C++
public:
int biWidth

See Also

DIB..::.BITMAPINFOHEADER Structure
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


biXPelsPerMeter Field

[image]

LinkOne WebView API
DIB..::.BITMAPINFOHEADER..::.biXPelsPerMeter Field
DIB..::.BITMAPINFOHEADER Structure See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int biXPelsPerMeter
Visual Basic (Declaration)
Public biXPelsPerMeter As Integer
Visual C++
public:
int biXPelsPerMeter

See Also

DIB..::.BITMAPINFOHEADER Structure
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


biYPelsPerMeter Field

[image]

LinkOne WebView API
DIB..::.BITMAPINFOHEADER..::.biYPelsPerMeter Field
DIB..::.BITMAPINFOHEADER Structure See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int biYPelsPerMeter
Visual Basic (Declaration)
Public biYPelsPerMeter As Integer
Visual C++
public:
int biYPelsPerMeter

See Also

DIB..::.BITMAPINFOHEADER Structure
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


DIB.BITMAPINFOHEADER Methods

[image] [image]

LinkOne WebView API
DIB..::.BITMAPINFOHEADER Methods
DIB..::.BITMAPINFOHEADER Structure See Also Send Feedback

The DIB..::.BITMAPINFOHEADER type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

DIB..::.BITMAPINFOHEADER Structure
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Font Class

[image]

LinkOne WebView API
Font Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class Font : Object
Visual Basic (Declaration)
Public Class Font _
    Inherits Object
Visual C++
public ref class Font : public Object

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.Printer.EmfToPdf..::.Object
Mincom.LinkOne.WebView.Printer.EmfToPdf..::.Font

See Also

Font Members
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Font Members

[image] [image]

LinkOne WebView API
Font Members
Font Class Constructors Methods Properties See Also Send Feedback

The Font type exposes the following members.

Constructors

Name | Description
Font | Initializes a new instance of the Font class

Methods

Name | Description
Apply | (Overrides Object..::.Apply(State).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
CharSet |
ClipPrecision |
Escapement |
FaceName |
FullName |
Height |
Italic |
NumAxes |
Orientation |
OutPrecision |
PitchAndFamily |
Quality |
ScriptName |
Signature |
StrikeOut |
StyleName |
StyleSize |
Underline |
Values |
Weight |
Width |

See Also

Font Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Font Constructor

[image]

LinkOne WebView API
Font Constructor
Font Class See Also Send Feedback
Initializes a new instance of the Font class

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Font(
    uint recordSize,
    ref BinaryReader reader
)
Visual Basic (Declaration)
Public Sub New ( _
    recordSize As UInteger, _
    ByRef reader As BinaryReader _
)
Visual C++
public:
Font(
    unsigned int recordSize,
    BinaryReader^% reader
)

Parameters

recordSize
Type: System..::.UInt32
reader
Type: System.IO..::.BinaryReader %

See Also

Font Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Font Methods

[image] [image]

LinkOne WebView API
Font Methods
Font Class See Also Send Feedback

The Font type exposes the following members.

Methods

Name | Description
Apply | (Overrides Object..::.Apply(State).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Font Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Apply Method

[image]

LinkOne WebView API
Font..::.Apply Method
Font Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public override void Apply(
    State state
)
Visual Basic (Declaration)
Public Overrides Sub Apply ( _
    state As State _
)
Visual C++
public:
virtual void Apply(
    State^ state
) override

Parameters

state
Type: Mincom.LinkOne.WebView.Printer.EmfToPdf..::.State

See Also

Font Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Font Properties

[image] [image]

LinkOne WebView API
Font Properties
Font Class See Also Send Feedback

The Font type exposes the following members.

Properties

Name | Description
CharSet |
ClipPrecision |
Escapement |
FaceName |
FullName |
Height |
Italic |
NumAxes |
Orientation |
OutPrecision |
PitchAndFamily |
Quality |
ScriptName |
Signature |
StrikeOut |
StyleName |
StyleSize |
Underline |
Values |
Weight |
Width |

See Also

Font Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


CharSet Property

[image]

LinkOne WebView API
Font..::.CharSet Property
Font Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public byte CharSet { get; set; }
Visual Basic (Declaration)
Public Property CharSet As Byte
Visual C++
public:
property unsigned char CharSet {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

Font Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


ClipPrecision Property

[image]

LinkOne WebView API
Font..::.ClipPrecision Property
Font Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public byte ClipPrecision { get; set; }
Visual Basic (Declaration)
Public Property ClipPrecision As Byte
Visual C++
public:
property unsigned char ClipPrecision {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

Font Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Escapement Property

[image]

LinkOne WebView API
Font..::.Escapement Property
Font Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int Escapement { get; set; }
Visual Basic (Declaration)
Public Property Escapement As Integer
Visual C++
public:
property int Escapement {
    int get ();
    void set (int value);
}

See Also

Font Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


FaceName Property

[image]

LinkOne WebView API
Font..::.FaceName Property
Font Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string FaceName { get; set; }
Visual Basic (Declaration)
Public Property FaceName As String
Visual C++
public:
property String^ FaceName {
    String^ get ();
    void set (String^ value);
}

See Also

Font Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


FullName Property

[image]

LinkOne WebView API
Font..::.FullName Property
Font Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string FullName { get; set; }
Visual Basic (Declaration)
Public Property FullName As String
Visual C++
public:
property String^ FullName {
    String^ get ();
    void set (String^ value);
}

See Also

Font Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Height Property

[image]

LinkOne WebView API
Font..::.Height Property
Font Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Integer
Visual C++
public:
property int Height {
    int get ();
    void set (int value);
}

See Also

Font Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Italic Property

[image]

LinkOne WebView API
Font..::.Italic Property
Font Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public byte Italic { get; set; }
Visual Basic (Declaration)
Public Property Italic As Byte
Visual C++
public:
property unsigned char Italic {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

Font Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


NumAxes Property

[image]

LinkOne WebView API
Font..::.NumAxes Property
Font Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public uint NumAxes { get; set; }
Visual Basic (Declaration)
Public Property NumAxes As UInteger
Visual C++
public:
property unsigned int NumAxes {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Font Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Orientation Property

[image]

LinkOne WebView API
Font..::.Orientation Property
Font Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int Orientation { get; set; }
Visual Basic (Declaration)
Public Property Orientation As Integer
Visual C++
public:
property int Orientation {
    int get ();
    void set (int value);
}

See Also

Font Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


OutPrecision Property

[image]

LinkOne WebView API
Font..::.OutPrecision Property
Font Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public byte OutPrecision { get; set; }
Visual Basic (Declaration)
Public Property OutPrecision As Byte
Visual C++
public:
property unsigned char OutPrecision {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

Font Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


PitchAndFamily Property

[image]

LinkOne WebView API
Font..::.PitchAndFamily Property
Font Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public byte PitchAndFamily { get; set; }
Visual Basic (Declaration)
Public Property PitchAndFamily As Byte
Visual C++
public:
property unsigned char PitchAndFamily {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

Font Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Quality Property

[image]

LinkOne WebView API
Font..::.Quality Property
Font Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public byte Quality { get; set; }
Visual Basic (Declaration)
Public Property Quality As Byte
Visual C++
public:
property unsigned char Quality {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

Font Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


ScriptName Property

[image]

LinkOne WebView API
Font..::.ScriptName Property
Font Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string ScriptName { get; set; }
Visual Basic (Declaration)
Public Property ScriptName As String
Visual C++
public:
property String^ ScriptName {
    String^ get ();
    void set (String^ value);
}

See Also

Font Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Signature Property

[image]

LinkOne WebView API
Font..::.Signature Property
Font Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public uint Signature { get; set; }
Visual Basic (Declaration)
Public Property Signature As UInteger
Visual C++
public:
property unsigned int Signature {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Font Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


StrikeOut Property

[image]

LinkOne WebView API
Font..::.StrikeOut Property
Font Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public byte StrikeOut { get; set; }
Visual Basic (Declaration)
Public Property StrikeOut As Byte
Visual C++
public:
property unsigned char StrikeOut {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

Font Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


StyleName Property

[image]

LinkOne WebView API
Font..::.StyleName Property
Font Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string StyleName { get; set; }
Visual Basic (Declaration)
Public Property StyleName As String
Visual C++
public:
property String^ StyleName {
    String^ get ();
    void set (String^ value);
}

See Also

Font Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


StyleSize Property

[image]

LinkOne WebView API
Font..::.StyleSize Property
Font Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public uint StyleSize { get; set; }
Visual Basic (Declaration)
Public Property StyleSize As UInteger
Visual C++
public:
property unsigned int StyleSize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Font Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Underline Property

[image]

LinkOne WebView API
Font..::.Underline Property
Font Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public byte Underline { get; set; }
Visual Basic (Declaration)
Public Property Underline As Byte
Visual C++
public:
property unsigned char Underline {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

Font Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Values Property

[image]

LinkOne WebView API
Font..::.Values Property
Font Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int[] Values { get; set; }
Visual Basic (Declaration)
Public Property Values As Integer()
Visual C++
public:
property array<int>^ Values {
    array<int>^ get ();
    void set (array<int>^ value);
}

See Also

Font Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Weight Property

[image]

LinkOne WebView API
Font..::.Weight Property
Font Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int Weight { get; set; }
Visual Basic (Declaration)
Public Property Weight As Integer
Visual C++
public:
property int Weight {
    int get ();
    void set (int value);
}

See Also

Font Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Width Property

[image]

LinkOne WebView API
Font..::.Width Property
Font Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Integer
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

See Also

Font Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Metafile Class

[image]

LinkOne WebView API
Metafile Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class Metafile
Visual Basic (Declaration)
Public Class Metafile
Visual C++
public ref class Metafile

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.Printer.EmfToPdf..::.Metafile

See Also

Metafile Members
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Metafile Members

[image] [image]

LinkOne WebView API
Metafile Members
Metafile Class Constructors Methods See Also Send Feedback

The Metafile type exposes the following members.

Constructors

Name | Description
Metafile | Initializes a new instance of the Metafile class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PlayMetafile |
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Metafile Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Metafile Constructor

[image]

LinkOne WebView API
Metafile Constructor
Metafile Class See Also Send Feedback
Initializes a new instance of the Metafile class

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Metafile(
    Stream stream
)
Visual Basic (Declaration)
Public Sub New ( _
    stream As Stream _
)
Visual C++
public:
Metafile(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream

See Also

Metafile Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Metafile Methods

[image] [image]

LinkOne WebView API
Metafile Methods
Metafile Class See Also Send Feedback

The Metafile type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PlayMetafile |
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Metafile Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


PlayMetafile Method

[image]

LinkOne WebView API
Metafile..::.PlayMetafile Method
Metafile Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void PlayMetafile(
    PdfPage page
)
Visual Basic (Declaration)
Public Sub PlayMetafile ( _
    page As PdfPage _
)
Visual C++
public:
void PlayMetafile(
    PdfPage^ page
)

Parameters

page
Type: PdfPage

See Also

Metafile Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Object Class

[image]

LinkOne WebView API
Object Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class Object
Visual Basic (Declaration)
Public Class Object
Visual C++
public ref class Object

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.Printer.EmfToPdf..::.Object
Mincom.LinkOne.WebView.Printer.EmfToPdf..::.Brush
Mincom.LinkOne.WebView.Printer.EmfToPdf..::.Font
Mincom.LinkOne.WebView.Printer.EmfToPdf..::.Pen

See Also

Object Members
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Object Members

[image] [image]

LinkOne WebView API
Object Members
Object Class Constructors Methods See Also Send Feedback

The Object type exposes the following members.

Constructors

Name | Description
Object | Initializes a new instance of the Object class

Methods

Name | Description
Apply |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Object Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Object Constructor

[image]

LinkOne WebView API
Object Constructor
Object Class See Also Send Feedback
Initializes a new instance of the Object class

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Object()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Object()

See Also

Object Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Object Methods

[image] [image]

LinkOne WebView API
Object Methods
Object Class See Also Send Feedback

The Object type exposes the following members.

Methods

Name | Description
Apply |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Object Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Apply Method

[image]

LinkOne WebView API
Object..::.Apply Method
Object Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public virtual void Apply(
    State state
)
Visual Basic (Declaration)
Public Overridable Sub Apply ( _
    state As State _
)
Visual C++
public:
virtual void Apply(
    State^ state
)

Parameters

state
Type: Mincom.LinkOne.WebView.Printer.EmfToPdf..::.State

See Also

Object Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Pen Class

[image]

LinkOne WebView API
Pen Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class Pen : Object
Visual Basic (Declaration)
Public Class Pen _
    Inherits Object
Visual C++
public ref class Pen : public Object

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.Printer.EmfToPdf..::.Object
Mincom.LinkOne.WebView.Printer.EmfToPdf..::.Pen

See Also

Pen Members
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Pen Members

[image] [image]

LinkOne WebView API
Pen Members
Pen Class Constructors Methods Properties See Also Send Feedback

The Pen type exposes the following members.

Constructors

Name | Description
Pen | Overloaded.

Methods

Name | Description
Apply | (Overrides Object..::.Apply(State).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Color |
PenStyle |
Width |

See Also

Pen Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Pen Constructor

[image] [image]

LinkOne WebView API
Pen Constructor
Pen Class See Also Send Feedback

Overload List

Name | Description
Pen(BinaryReader%) | Initializes a new instance of the Pen class
Pen(BinaryReader%, Boolean) | Initializes a new instance of the Pen class

See Also

Pen Class
Pen Members
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Pen Constructor (BinaryReader)

[image]

LinkOne WebView API
Pen Constructor (BinaryReader%)
Pen Class See Also Send Feedback
Initializes a new instance of the Pen class

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Pen(
    ref BinaryReader reader
)
Visual Basic (Declaration)
Public Sub New ( _
    ByRef reader As BinaryReader _
)
Visual C++
public:
Pen(
    BinaryReader^% reader
)

Parameters

reader
Type: System.IO..::.BinaryReader %

See Also

Pen Class
Pen Overload
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Pen Constructor (BinaryReader, Boolean)

[image]

LinkOne WebView API
Pen Constructor (BinaryReader%, Boolean)
Pen Class See Also Send Feedback
Initializes a new instance of the Pen class

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Pen(
    ref BinaryReader reader,
    bool extended
)
Visual Basic (Declaration)
Public Sub New ( _
    ByRef reader As BinaryReader, _
    extended As Boolean _
)
Visual C++
public:
Pen(
    BinaryReader^% reader,
    bool extended
)

Parameters

reader
Type: System.IO..::.BinaryReader %
extended
Type: System..::.Boolean

See Also

Pen Class
Pen Overload
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Pen Methods

[image] [image]

LinkOne WebView API
Pen Methods
Pen Class See Also Send Feedback

The Pen type exposes the following members.

Methods

Name | Description
Apply | (Overrides Object..::.Apply(State).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Pen Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Apply Method

[image]

LinkOne WebView API
Pen..::.Apply Method
Pen Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public override void Apply(
    State state
)
Visual Basic (Declaration)
Public Overrides Sub Apply ( _
    state As State _
)
Visual C++
public:
virtual void Apply(
    State^ state
) override

Parameters

state
Type: Mincom.LinkOne.WebView.Printer.EmfToPdf..::.State

See Also

Pen Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Pen Properties

[image] [image]

LinkOne WebView API
Pen Properties
Pen Class See Also Send Feedback

The Pen type exposes the following members.

Properties

Name | Description
Color |
PenStyle |
Width |

See Also

Pen Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Color Property

[image]

LinkOne WebView API
Pen..::.Color Property
Pen Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

See Also

Pen Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


PenStyle Property

[image]

LinkOne WebView API
Pen..::.PenStyle Property
Pen Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public uint PenStyle { get; set; }
Visual Basic (Declaration)
Public Property PenStyle As UInteger
Visual C++
public:
property unsigned int PenStyle {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Pen Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Width Property

[image]

LinkOne WebView API
Pen..::.Width Property
Pen Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Integer
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

See Also

Pen Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


State Class

[image]

LinkOne WebView API
State Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class State
Visual Basic (Declaration)
Public Class State
Visual C++
public ref class State

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.Printer.EmfToPdf..::.State

See Also

State Members
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


State Members

[image] [image]

LinkOne WebView API
State Members
State Class Constructors Methods Fields Properties See Also Send Feedback

The State type exposes the following members.

Constructors

Name | Description
State | Overloaded.

Methods

Name | Description
AddBrush |
AddFont |
AddObject |
AddPen |
CopyFrom |
DeleteObject |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetStringFormat | Overloaded.
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RestoreState |
SaveState |
ScaleHeight |
ScaleWidth |
SelectObject |
ToString | Returns a string that represents the current object. (Inherited from Object.)
TransformX |
TransformY |

Fields

Name | Description
MM_PER_INCH |
POINTS_PER_INCH |
TWIPS_PER_INCH |

Properties

Name | Description
BkColor |
BkMode |
Bounds |
CurrentBrush |
CurrentFont |
CurrentPath |
CurrentPen |
DeviceSizeMillimeters |
DeviceSizePixels |
Inch |
MapMode |
PDFPageSizePt |
PolyFillMode |
TextAlignmentMode |
TextColor |
TextOrientation |
WindowExtentX |
WindowExtentY |
WindowOffsetX |
WindowOffsetY |
WorldTransform |
X |
Y |

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


State Constructor

[image] [image]

LinkOne WebView API
State Constructor
State Class See Also Send Feedback

Overload List

Name | Description
State()()() | Initializes a new instance of the State class
State(State) | Initializes a new instance of the State class

See Also

State Class
State Members
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


State Constructor

[image]

LinkOne WebView API
State Constructor
State Class See Also Send Feedback
Initializes a new instance of the State class

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public State()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
State()

See Also

State Class
State Overload
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


State Constructor (State)

[image]

LinkOne WebView API
State Constructor (State)
State Class See Also Send Feedback
Initializes a new instance of the State class

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public State(
    State state
)
Visual Basic (Declaration)
Public Sub New ( _
    state As State _
)
Visual C++
public:
State(
    State^ state
)

Parameters

state
Type: Mincom.LinkOne.WebView.Printer.EmfToPdf..::.State

See Also

State Class
State Overload
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


State Fields

[image] [image]

LinkOne WebView API
State Fields
State Class See Also Send Feedback

The State type exposes the following members.

Fields

Name | Description
MM_PER_INCH |
POINTS_PER_INCH |
TWIPS_PER_INCH |

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


MM_PER_INCH Field

[image]

LinkOne WebView API
State..::.MM_PER_INCH Field
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public const double MM_PER_INCH
Visual Basic (Declaration)
Public Const MM_PER_INCH As Double
Visual C++
public:
literal double MM_PER_INCH

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


POINTS_PER_INCH Field

[image]

LinkOne WebView API
State..::.POINTS_PER_INCH Field
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public const int POINTS_PER_INCH
Visual Basic (Declaration)
Public Const POINTS_PER_INCH As Integer
Visual C++
public:
literal int POINTS_PER_INCH

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


TWIPS_PER_INCH Field

[image]

LinkOne WebView API
State..::.TWIPS_PER_INCH Field
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public const int TWIPS_PER_INCH
Visual Basic (Declaration)
Public Const TWIPS_PER_INCH As Integer
Visual C++
public:
literal int TWIPS_PER_INCH

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


State Methods

[image] [image]

LinkOne WebView API
State Methods
State Class See Also Send Feedback

The State type exposes the following members.

Methods

Name | Description
AddBrush |
AddFont |
AddObject |
AddPen |
CopyFrom |
DeleteObject |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetStringFormat | Overloaded.
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RestoreState |
SaveState |
ScaleHeight |
ScaleWidth |
SelectObject |
ToString | Returns a string that represents the current object. (Inherited from Object.)
TransformX |
TransformY |

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


AddBrush Method

[image]

LinkOne WebView API
State..::.AddBrush Method
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void AddBrush(
    uint objectIndex,
    Brush brush
)
Visual Basic (Declaration)
Public Sub AddBrush ( _
    objectIndex As UInteger, _
    brush As Brush _
)
Visual C++
public:
void AddBrush(
    unsigned int objectIndex,
    Brush^ brush
)

Parameters

objectIndex
Type: System..::.UInt32
brush
Type: Mincom.LinkOne.WebView.Printer.EmfToPdf..::.Brush

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


AddFont Method

[image]

LinkOne WebView API
State..::.AddFont Method
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void AddFont(
    uint objectIndex,
    Font font
)
Visual Basic (Declaration)
Public Sub AddFont ( _
    objectIndex As UInteger, _
    font As Font _
)
Visual C++
public:
void AddFont(
    unsigned int objectIndex,
    Font^ font
)

Parameters

objectIndex
Type: System..::.UInt32
font
Type: Mincom.LinkOne.WebView.Printer.EmfToPdf..::.Font

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


AddObject Method

[image]

LinkOne WebView API
State..::.AddObject Method
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void AddObject(
    uint objectIndex
)
Visual Basic (Declaration)
Public Sub AddObject ( _
    objectIndex As UInteger _
)
Visual C++
public:
void AddObject(
    unsigned int objectIndex
)

Parameters

objectIndex
Type: System..::.UInt32

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


AddPen Method

[image]

LinkOne WebView API
State..::.AddPen Method
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void AddPen(
    uint objectIndex,
    Pen pen
)
Visual Basic (Declaration)
Public Sub AddPen ( _
    objectIndex As UInteger, _
    pen As Pen _
)
Visual C++
public:
void AddPen(
    unsigned int objectIndex,
    Pen^ pen
)

Parameters

objectIndex
Type: System..::.UInt32
pen
Type: Mincom.LinkOne.WebView.Printer.EmfToPdf..::.Pen

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


CopyFrom Method

[image]

LinkOne WebView API
State..::.CopyFrom Method
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void CopyFrom(
    State state
)
Visual Basic (Declaration)
Public Sub CopyFrom ( _
    state As State _
)
Visual C++
public:
void CopyFrom(
    State^ state
)

Parameters

state
Type: Mincom.LinkOne.WebView.Printer.EmfToPdf..::.State

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


DeleteObject Method

[image]

LinkOne WebView API
State..::.DeleteObject Method
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void DeleteObject(
    uint objectIndex
)
Visual Basic (Declaration)
Public Sub DeleteObject ( _
    objectIndex As UInteger _
)
Visual C++
public:
void DeleteObject(
    unsigned int objectIndex
)

Parameters

objectIndex
Type: System..::.UInt32

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


GetStringFormat Method

[image] [image]

LinkOne WebView API
State..::.GetStringFormat Method
State Class See Also Send Feedback

Overload List

Name | Description
GetStringFormat()()() |
GetStringFormat(Boolean) |

See Also

State Class
State Members
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


GetStringFormat Method

[image]

LinkOne WebView API
State..::.GetStringFormat Method
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public XStringFormat GetStringFormat()
Visual Basic (Declaration)
Public Function GetStringFormat As XStringFormat
Visual C++
public:
XStringFormat^ GetStringFormat()

See Also

State Class
GetStringFormat Overload
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


GetStringFormat Method (Boolean)

[image]

LinkOne WebView API
State..::.GetStringFormat Method (Boolean)
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public XStringFormat GetStringFormat(
    bool vertical
)
Visual Basic (Declaration)
Public Function GetStringFormat ( _
    vertical As Boolean _
) As XStringFormat
Visual C++
public:
XStringFormat^ GetStringFormat(
    bool vertical
)

Parameters

vertical
Type: System..::.Boolean

See Also

State Class
GetStringFormat Overload
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


RestoreState Method

[image]

LinkOne WebView API
State..::.RestoreState Method
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void RestoreState(
    int nSavedDC,
    XGraphics graphics
)
Visual Basic (Declaration)
Public Sub RestoreState ( _
    nSavedDC As Integer, _
    graphics As XGraphics _
)
Visual C++
public:
void RestoreState(
    int nSavedDC,
    XGraphics^ graphics
)

Parameters

nSavedDC
Type: System..::.Int32
graphics
Type: XGraphics

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


SaveState Method

[image]

LinkOne WebView API
State..::.SaveState Method
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void SaveState(
    XGraphics graphics
)
Visual Basic (Declaration)
Public Sub SaveState ( _
    graphics As XGraphics _
)
Visual C++
public:
void SaveState(
    XGraphics^ graphics
)

Parameters

graphics
Type: XGraphics

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


ScaleHeight Method

[image]

LinkOne WebView API
State..::.ScaleHeight Method
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public double ScaleHeight(
    int height
)
Visual Basic (Declaration)
Public Function ScaleHeight ( _
    height As Integer _
) As Double
Visual C++
public:
double ScaleHeight(
    int height
)

Parameters

height
Type: System..::.Int32

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


ScaleWidth Method

[image]

LinkOne WebView API
State..::.ScaleWidth Method
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public double ScaleWidth(
    int width
)
Visual Basic (Declaration)
Public Function ScaleWidth ( _
    width As Integer _
) As Double
Visual C++
public:
double ScaleWidth(
    int width
)

Parameters

width
Type: System..::.Int32

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


SelectObject Method

[image]

LinkOne WebView API
State..::.SelectObject Method
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void SelectObject(
    uint objectIndex
)
Visual Basic (Declaration)
Public Sub SelectObject ( _
    objectIndex As UInteger _
)
Visual C++
public:
void SelectObject(
    unsigned int objectIndex
)

Parameters

objectIndex
Type: System..::.UInt32

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


TransformX Method

[image]

LinkOne WebView API
State..::.TransformX Method
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public double TransformX(
    int x
)
Visual Basic (Declaration)
Public Function TransformX ( _
    x As Integer _
) As Double
Visual C++
public:
double TransformX(
    int x
)

Parameters

x
Type: System..::.Int32

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


TransformY Method

[image]

LinkOne WebView API
State..::.TransformY Method
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public double TransformY(
    int y
)
Visual Basic (Declaration)
Public Function TransformY ( _
    y As Integer _
) As Double
Visual C++
public:
double TransformY(
    int y
)

Parameters

y
Type: System..::.Int32

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


State Properties

[image] [image]

LinkOne WebView API
State Properties
State Class See Also Send Feedback

The State type exposes the following members.

Properties

Name | Description
BkColor |
BkMode |
Bounds |
CurrentBrush |
CurrentFont |
CurrentPath |
CurrentPen |
DeviceSizeMillimeters |
DeviceSizePixels |
Inch |
MapMode |
PDFPageSizePt |
PolyFillMode |
TextAlignmentMode |
TextColor |
TextOrientation |
WindowExtentX |
WindowExtentY |
WindowOffsetX |
WindowOffsetY |
WorldTransform |
X |
Y |

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


BkColor Property

[image]

LinkOne WebView API
State..::.BkColor Property
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Color BkColor { get; set; }
Visual Basic (Declaration)
Public Property BkColor As Color
Visual C++
public:
property Color BkColor {
    Color get ();
    void set (Color value);
}

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


BkMode Property

[image]

LinkOne WebView API
State..::.BkMode Property
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public uint BkMode { get; set; }
Visual Basic (Declaration)
Public Property BkMode As UInteger
Visual C++
public:
property unsigned int BkMode {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Bounds Property

[image]

LinkOne WebView API
State..::.Bounds Property
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public RectangleF Bounds { get; set; }
Visual Basic (Declaration)
Public Property Bounds As RectangleF
Visual C++
public:
property RectangleF Bounds {
    RectangleF get ();
    void set (RectangleF value);
}

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


CurrentBrush Property

[image]

LinkOne WebView API
State..::.CurrentBrush Property
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public XBrush CurrentBrush { get; set; }
Visual Basic (Declaration)
Public Property CurrentBrush As XBrush
Visual C++
public:
property XBrush^ CurrentBrush {
    XBrush^ get ();
    void set (XBrush^ value);
}

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


CurrentFont Property

[image]

LinkOne WebView API
State..::.CurrentFont Property
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public XFont CurrentFont { get; set; }
Visual Basic (Declaration)
Public Property CurrentFont As XFont
Visual C++
public:
property XFont^ CurrentFont {
    XFont^ get ();
    void set (XFont^ value);
}

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


CurrentPath Property

[image]

LinkOne WebView API
State..::.CurrentPath Property
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public XGraphicsPath CurrentPath { get; set; }
Visual Basic (Declaration)
Public Property CurrentPath As XGraphicsPath
Visual C++
public:
property XGraphicsPath^ CurrentPath {
    XGraphicsPath^ get ();
    void set (XGraphicsPath^ value);
}

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


CurrentPen Property

[image]

LinkOne WebView API
State..::.CurrentPen Property
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public XPen CurrentPen { get; set; }
Visual Basic (Declaration)
Public Property CurrentPen As XPen
Visual C++
public:
property XPen^ CurrentPen {
    XPen^ get ();
    void set (XPen^ value);
}

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


DeviceSizeMillimeters Property

[image]

LinkOne WebView API
State..::.DeviceSizeMillimeters Property
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Size DeviceSizeMillimeters { get; set; }
Visual Basic (Declaration)
Public Property DeviceSizeMillimeters As Size
Visual C++
public:
property Size DeviceSizeMillimeters {
    Size get ();
    void set (Size value);
}

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


DeviceSizePixels Property

[image]

LinkOne WebView API
State..::.DeviceSizePixels Property
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Size DeviceSizePixels { get; set; }
Visual Basic (Declaration)
Public Property DeviceSizePixels As Size
Visual C++
public:
property Size DeviceSizePixels {
    Size get ();
    void set (Size value);
}

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Inch Property

[image]

LinkOne WebView API
State..::.Inch Property
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public double Inch { get; set; }
Visual Basic (Declaration)
Public Property Inch As Double
Visual C++
public:
property double Inch {
    double get ();
    void set (double value);
}

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


MapMode Property

[image]

LinkOne WebView API
State..::.MapMode Property
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public uint MapMode { get; set; }
Visual Basic (Declaration)
Public Property MapMode As UInteger
Visual C++
public:
property unsigned int MapMode {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


PDFPageSizePt Property

[image]

LinkOne WebView API
State..::.PDFPageSizePt Property
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public SizeF PDFPageSizePt { get; set; }
Visual Basic (Declaration)
Public Property PDFPageSizePt As SizeF
Visual C++
public:
property SizeF PDFPageSizePt {
    SizeF get ();
    void set (SizeF value);
}

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


PolyFillMode Property

[image]

LinkOne WebView API
State..::.PolyFillMode Property
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public uint PolyFillMode { get; set; }
Visual Basic (Declaration)
Public Property PolyFillMode As UInteger
Visual C++
public:
property unsigned int PolyFillMode {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


TextAlignmentMode Property

[image]

LinkOne WebView API
State..::.TextAlignmentMode Property
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public uint TextAlignmentMode { get; set; }
Visual Basic (Declaration)
Public Property TextAlignmentMode As UInteger
Visual C++
public:
property unsigned int TextAlignmentMode {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


TextColor Property

[image]

LinkOne WebView API
State..::.TextColor Property
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Color TextColor { get; set; }
Visual Basic (Declaration)
Public Property TextColor As Color
Visual C++
public:
property Color TextColor {
    Color get ();
    void set (Color value);
}

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


TextOrientation Property

[image]

LinkOne WebView API
State..::.TextOrientation Property
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int TextOrientation { get; set; }
Visual Basic (Declaration)
Public Property TextOrientation As Integer
Visual C++
public:
property int TextOrientation {
    int get ();
    void set (int value);
}

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


WindowExtentX Property

[image]

LinkOne WebView API
State..::.WindowExtentX Property
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public uint WindowExtentX { get; set; }
Visual Basic (Declaration)
Public Property WindowExtentX As UInteger
Visual C++
public:
property unsigned int WindowExtentX {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


WindowExtentY Property

[image]

LinkOne WebView API
State..::.WindowExtentY Property
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public uint WindowExtentY { get; set; }
Visual Basic (Declaration)
Public Property WindowExtentY As UInteger
Visual C++
public:
property unsigned int WindowExtentY {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


WindowOffsetX Property

[image]

LinkOne WebView API
State..::.WindowOffsetX Property
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int WindowOffsetX { get; set; }
Visual Basic (Declaration)
Public Property WindowOffsetX As Integer
Visual C++
public:
property int WindowOffsetX {
    int get ();
    void set (int value);
}

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


WindowOffsetY Property

[image]

LinkOne WebView API
State..::.WindowOffsetY Property
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int WindowOffsetY { get; set; }
Visual Basic (Declaration)
Public Property WindowOffsetY As Integer
Visual C++
public:
property int WindowOffsetY {
    int get ();
    void set (int value);
}

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


WorldTransform Property

[image]

LinkOne WebView API
State..::.WorldTransform Property
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Matrix WorldTransform { get; set; }
Visual Basic (Declaration)
Public Property WorldTransform As Matrix
Visual C++
public:
property Matrix^ WorldTransform {
    Matrix^ get ();
    void set (Matrix^ value);
}

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


X Property

[image]

LinkOne WebView API
State..::.X Property
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public double X { get; set; }
Visual Basic (Declaration)
Public Property X As Double
Visual C++
public:
property double X {
    double get ();
    void set (double value);
}

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Y Property

[image]

LinkOne WebView API
State..::.Y Property
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public double Y { get; set; }
Visual Basic (Declaration)
Public Property Y As Double
Visual C++
public:
property double Y {
    double get ();
    void set (double value);
}

See Also

State Class
Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


State.MapModes Enumeration

[image]

LinkOne WebView API
State..::.MapModes Enumeration
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public enum MapModes
Visual Basic (Declaration)
Public Enumeration MapModes
Visual C++
public enum class MapModes

Members

Member name | Description
MM_TEXT |
MM_LOMETRIC |
MM_HIMETRIC |
MM_LOENGLISH |
MM_HIENGLISH |
MM_TWIPS |
MM_ISOTROPIC |
MM_ANISOTROPIC |

See Also

Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


State.MixMode Enumeration

[image]

LinkOne WebView API
State..::.MixMode Enumeration
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public enum MixMode
Visual Basic (Declaration)
Public Enumeration MixMode
Visual C++
public enum class MixMode

Members

Member name | Description
TRANSPARENT |
OPAQUE |

See Also

Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


State.ModifyWorldTransformModes Enumeration

[image]

LinkOne WebView API
State..::.ModifyWorldTransformModes Enumeration
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public enum ModifyWorldTransformModes
Visual Basic (Declaration)
Public Enumeration ModifyWorldTransformModes
Visual C++
public enum class ModifyWorldTransformModes

Members

Member name | Description
MWT_IDENTITY |
MWT_LEFTMULTIPLY |
MWT_RIGHTMULTIPLY |
MWT_SET |

See Also

Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


State.PolyFillModes Enumeration

[image]

LinkOne WebView API
State..::.PolyFillModes Enumeration
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public enum PolyFillModes
Visual Basic (Declaration)
Public Enumeration PolyFillModes
Visual C++
public enum class PolyFillModes

Members

Member name | Description
ALTERNATE |
WINDING |

See Also

Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


State.StockObject Enumeration

[image]

LinkOne WebView API
State..::.StockObject Enumeration
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public enum StockObject
Visual Basic (Declaration)
Public Enumeration StockObject
Visual C++
public enum class StockObject

Members

Member name | Description
WHITE_BRUSH |
LTGRAY_BRUSH |
GRAY_BRUSH |
DKGRAY_BRUSH |
BLACK_BRUSH |
NULL_BRUSH |
WHITE_PEN |
BLACK_PEN |
NULL_PEN |
OEM_FIXED_FONT |
ANSI_FIXED_FONT |
ANSI_VAR_FONT |
SYSTEM_FONT |
DEVICE_DEFAULT_FONT |
DEFAULT_PALETTE |
SYSTEM_FIXED_FONT |
DEFAULT_GUI_FONT |
DC_BRUSH |
DC_PEN |

See Also

Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


State.TextAlignmentModes Enumeration

[image]

LinkOne WebView API
State..::.TextAlignmentModes Enumeration
State Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.Printer.EmfToPdf
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public enum TextAlignmentModes
Visual Basic (Declaration)
Public Enumeration TextAlignmentModes
Visual C++
public enum class TextAlignmentModes

Members

Member name | Description
TA_NOUPDATECP |
TA_LEFT |
TA_TOP |
TA_UPDATECP |
TA_RIGHT |
TA_CENTER |
TA_BOTTOM |
TA_BASELINE |
TA_RTLREADING |

See Also

Mincom.LinkOne.WebView.Printer.EmfToPdf Namespace


Mincom.LinkOne.WebView.WebServer.Cache Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.WebView.WebServer.Cache Namespace
Send Feedback

Classes

Class | Description
PrintOptions |


PrintOptions Class

[image]

LinkOne WebView API
PrintOptions Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.Cache
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class PrintOptions
Visual Basic (Declaration)
Public Class PrintOptions
Visual C++
public ref class PrintOptions

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.Cache..::.PrintOptions

See Also

PrintOptions Members
Mincom.LinkOne.WebView.WebServer.Cache Namespace


PrintOptions Members

[image] [image]

LinkOne WebView API
PrintOptions Members
PrintOptions Class Constructors Methods Properties See Also Send Feedback

The PrintOptions type exposes the following members.

Constructors

Name | Description
PrintOptions | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Landscape | Gets the paper orientation
PaperHeight | Gets the paper height in postscript points (1/72 inch)
PaperWidth | Gets the paper width in postscript points (1/72 inch)
Resolution | Gets the print resolution in dots per inch

See Also

PrintOptions Class
Mincom.LinkOne.WebView.WebServer.Cache Namespace


PrintOptions Constructor

[image] [image]

LinkOne WebView API
PrintOptions Constructor
PrintOptions Class See Also Send Feedback

Overload List

Name | Description
PrintOptions(String, String) | Constructor for PrintOptions
PrintOptions(Int32, Int32, Boolean, Int32) | Constructor for PrintOptions

See Also

PrintOptions Class
PrintOptions Members
Mincom.LinkOne.WebView.WebServer.Cache Namespace


PrintOptions Constructor (String, String)

[image]

LinkOne WebView API
PrintOptions Constructor (String, String)
PrintOptions Class See Also Send Feedback
Constructor for PrintOptions

Namespace: Mincom.LinkOne.WebView.WebServer.Cache
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public PrintOptions(
    string paperSize,
    string landscape
)
Visual Basic (Declaration)
Public Sub New ( _
    paperSize As String, _
    landscape As String _
)
Visual C++
public:
PrintOptions(
    String^ paperSize,
    String^ landscape
)

Parameters

paperSize
Type: System..::.String
string of the format WIDTHxHEIGHT, where WIDTH and HEIGHT are integers in postscript point (1/72 inch)
landscape
Type: System..::.String
string representation of a boolean indicating whether to use landscape or portrait

See Also

PrintOptions Class
PrintOptions Overload
Mincom.LinkOne.WebView.WebServer.Cache Namespace


PrintOptions Constructor (Int32, Int32, Boolean, Int32)

[image]

LinkOne WebView API
PrintOptions Constructor (Int32, Int32, Boolean, Int32)
PrintOptions Class See Also Send Feedback
Constructor for PrintOptions

Namespace: Mincom.LinkOne.WebView.WebServer.Cache
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public PrintOptions(
    int paperWidth,
    int paperHeight,
    bool landscape,
    int resolution
)
Visual Basic (Declaration)
Public Sub New ( _
    paperWidth As Integer, _
    paperHeight As Integer, _
    landscape As Boolean, _
    resolution As Integer _
)
Visual C++
public:
PrintOptions(
    int paperWidth,
    int paperHeight,
    bool landscape,
    int resolution
)

Parameters

paperWidth
Type: System..::.Int32
paperHeight
Type: System..::.Int32
landscape
Type: System..::.Boolean
Flag to indicate whether the page is landscape or portrait
resolution
Type: System..::.Int32
The print resolution in dots per inch

See Also

PrintOptions Class
PrintOptions Overload
Mincom.LinkOne.WebView.WebServer.Cache Namespace


PrintOptions Methods

[image] [image]

LinkOne WebView API
PrintOptions Methods
PrintOptions Class See Also Send Feedback

The PrintOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PrintOptions Class
Mincom.LinkOne.WebView.WebServer.Cache Namespace


PrintOptions Properties

[image] [image]

LinkOne WebView API
PrintOptions Properties
PrintOptions Class See Also Send Feedback

The PrintOptions type exposes the following members.

Properties

Name | Description
Landscape | Gets the paper orientation
PaperHeight | Gets the paper height in postscript points (1/72 inch)
PaperWidth | Gets the paper width in postscript points (1/72 inch)
Resolution | Gets the print resolution in dots per inch

See Also

PrintOptions Class
Mincom.LinkOne.WebView.WebServer.Cache Namespace


Landscape Property

[image]

LinkOne WebView API
PrintOptions..::.Landscape Property
PrintOptions Class See Also Send Feedback
Gets the paper orientation

Namespace: Mincom.LinkOne.WebView.WebServer.Cache
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool Landscape { get; }
Visual Basic (Declaration)
Public ReadOnly Property Landscape As Boolean
Visual C++
public:
property bool Landscape {
    bool get ();
}

See Also

PrintOptions Class
Mincom.LinkOne.WebView.WebServer.Cache Namespace


PaperHeight Property

[image]

LinkOne WebView API
PrintOptions..::.PaperHeight Property
PrintOptions Class See Also Send Feedback
Gets the paper height in postscript points (1/72 inch)

Namespace: Mincom.LinkOne.WebView.WebServer.Cache
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int PaperHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property PaperHeight As Integer
Visual C++
public:
property int PaperHeight {
    int get ();
}

See Also

PrintOptions Class
Mincom.LinkOne.WebView.WebServer.Cache Namespace


PaperWidth Property

[image]

LinkOne WebView API
PrintOptions..::.PaperWidth Property
PrintOptions Class See Also Send Feedback
Gets the paper width in postscript points (1/72 inch)

Namespace: Mincom.LinkOne.WebView.WebServer.Cache
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int PaperWidth { get; }
Visual Basic (Declaration)
Public ReadOnly Property PaperWidth As Integer
Visual C++
public:
property int PaperWidth {
    int get ();
}

See Also

PrintOptions Class
Mincom.LinkOne.WebView.WebServer.Cache Namespace


Resolution Property

[image]

LinkOne WebView API
PrintOptions..::.Resolution Property
PrintOptions Class See Also Send Feedback
Gets the print resolution in dots per inch

Namespace: Mincom.LinkOne.WebView.WebServer.Cache
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int Resolution { get; set; }
Visual Basic (Declaration)
Public Property Resolution As Integer
Visual C++
public:
property int Resolution {
    int get ();
    void set (int value);
}

See Also

PrintOptions Class
Mincom.LinkOne.WebView.WebServer.Cache Namespace


Mincom.LinkOne.WebView.WebServer.Configuration Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.WebView.WebServer.Configuration Namespace
Send Feedback
The Mincom.LinkOne.WebView.WebServer.Configuration namespace supplies classes that describe how selection lists behave, such as what fields are mapped when adding parts, and where the user interface originate from.

Classes

Class | Description
SelectionListConfiguration | Encapsulates the configuration information about a selection list.
SelectionListDefinition | Represents a selection list definition that describes columns and field mappings, per language, publisher, and book.


SelectionListConfiguration Class

[image]

LinkOne WebView API
SelectionListConfiguration Class
Members See Also Send Feedback
Encapsulates the configuration information about a selection list.

Namespace: Mincom.LinkOne.WebView.WebServer.Configuration
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public sealed class SelectionListConfiguration
Visual Basic (Declaration)
Public NotInheritable Class SelectionListConfiguration
Visual C++
public ref class SelectionListConfiguration sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.Configuration..::.SelectionListConfiguration

See Also

SelectionListConfiguration Members
Mincom.LinkOne.WebView.WebServer.Configuration Namespace


SelectionListConfiguration Members

[image] [image]

LinkOne WebView API
SelectionListConfiguration Members
SelectionListConfiguration Class Constructors Methods Properties See Also Send Feedback

The SelectionListConfiguration type exposes the following members.

Constructors

Name | Description
SelectionListConfiguration | Initializes a new instance of the SelectionListConfiguration class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
IsPersistent | Gets or sets whether the selection list is persisted between sessions.
Location | Gets or sets the website-relative location of the selection list.
LocationURL |
Name | Gets the unique name of this selection list configuration.

See Also

SelectionListConfiguration Class
Mincom.LinkOne.WebView.WebServer.Configuration Namespace


SelectionListConfiguration Constructor

[image]

LinkOne WebView API
SelectionListConfiguration Constructor
SelectionListConfiguration Class See Also Send Feedback
Initializes a new instance of the SelectionListConfiguration class.

Namespace: Mincom.LinkOne.WebView.WebServer.Configuration
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public SelectionListConfiguration(
    string name,
    string location,
    bool isPersistent
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    location As String, _
    isPersistent As Boolean _
)
Visual C++
public:
SelectionListConfiguration(
    String^ name,
    String^ location,
    bool isPersistent
)

Parameters

name
Type: System..::.String
The name of the selection list configuration.
location
Type: System..::.String
The website-relative location of the selection list definition.
isPersistent
Type: System..::.Boolean
True if the selection list is persistent.

See Also

SelectionListConfiguration Class
Mincom.LinkOne.WebView.WebServer.Configuration Namespace


SelectionListConfiguration Methods

[image] [image]

LinkOne WebView API
SelectionListConfiguration Methods
SelectionListConfiguration Class See Also Send Feedback

The SelectionListConfiguration type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SelectionListConfiguration Class
Mincom.LinkOne.WebView.WebServer.Configuration Namespace


SelectionListConfiguration Properties

[image] [image]

LinkOne WebView API
SelectionListConfiguration Properties
SelectionListConfiguration Class See Also Send Feedback

The SelectionListConfiguration type exposes the following members.

Properties

Name | Description
IsPersistent | Gets or sets whether the selection list is persisted between sessions.
Location | Gets or sets the website-relative location of the selection list.
LocationURL |
Name | Gets the unique name of this selection list configuration.

See Also

SelectionListConfiguration Class
Mincom.LinkOne.WebView.WebServer.Configuration Namespace


IsPersistent Property

[image]

LinkOne WebView API
SelectionListConfiguration..::.IsPersistent Property
SelectionListConfiguration Class See Also Send Feedback
Gets or sets whether the selection list is persisted between sessions.

Namespace: Mincom.LinkOne.WebView.WebServer.Configuration
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool IsPersistent { get; set; }
Visual Basic (Declaration)
Public Property IsPersistent As Boolean
Visual C++
public:
property bool IsPersistent {
    bool get ();
    void set (bool value);
}

See Also

SelectionListConfiguration Class
Mincom.LinkOne.WebView.WebServer.Configuration Namespace


Location Property

[image]

LinkOne WebView API
SelectionListConfiguration..::.Location Property
SelectionListConfiguration Class See Also Send Feedback
Gets or sets the website-relative location of the selection list.

Namespace: Mincom.LinkOne.WebView.WebServer.Configuration
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Location { get; set; }
Visual Basic (Declaration)
Public Property Location As String
Visual C++
public:
property String^ Location {
    String^ get ();
    void set (String^ value);
}

See Also

SelectionListConfiguration Class
Mincom.LinkOne.WebView.WebServer.Configuration Namespace


LocationURL Property

[image]

LinkOne WebView API
SelectionListConfiguration..::.LocationURL Property
SelectionListConfiguration Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.Configuration
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string LocationURL { get; }
Visual Basic (Declaration)
Public ReadOnly Property LocationURL As String
Visual C++
public:
property String^ LocationURL {
    String^ get ();
}

See Also

SelectionListConfiguration Class
Mincom.LinkOne.WebView.WebServer.Configuration Namespace


Name Property

[image]

LinkOne WebView API
SelectionListConfiguration..::.Name Property
SelectionListConfiguration Class See Also Send Feedback
Gets the unique name of this selection list configuration.

Namespace: Mincom.LinkOne.WebView.WebServer.Configuration
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Name { get; private set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

SelectionListConfiguration Class
Mincom.LinkOne.WebView.WebServer.Configuration Namespace


SelectionListDefinition Class

[image]

LinkOne WebView API
SelectionListDefinition Class
Members See Also Send Feedback
Represents a selection list definition that describes columns and field mappings, per language, publisher, and book.

Namespace: Mincom.LinkOne.WebView.WebServer.Configuration
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class SelectionListDefinition
Visual Basic (Declaration)
Public Class SelectionListDefinition
Visual C++
public ref class SelectionListDefinition

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.Configuration..::.SelectionListDefinition

See Also

SelectionListDefinition Members
Mincom.LinkOne.WebView.WebServer.Configuration Namespace


SelectionListDefinition Members

[image] [image]

LinkOne WebView API
SelectionListDefinition Members
SelectionListDefinition Class Constructors Methods Properties See Also Send Feedback

The SelectionListDefinition type exposes the following members.

Constructors

Name | Description
SelectionListDefinition | Initializes a new instance of the SelectionListDefinition class.

Methods

Name | Description
CreateSelectionList | Creates a new selection list, based on the FieldMapper columns.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
BookCode | Gets the book code that this definition is targeted at.
Columns | Gets the columns in the definition.
FieldMapper | Gets the field mapper that maps entries to the selection list that list definition describes.
LanguageCode | Gets the language code that this definition is targeted at.
PublisherCode | Gets the publisher code that this definition is targeted at.

See Also

SelectionListDefinition Class
Mincom.LinkOne.WebView.WebServer.Configuration Namespace


SelectionListDefinition Constructor

[image]

LinkOne WebView API
SelectionListDefinition Constructor
SelectionListDefinition Class See Also Send Feedback
Initializes a new instance of the SelectionListDefinition class.

Namespace: Mincom.LinkOne.WebView.WebServer.Configuration
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public SelectionListDefinition(
    string languageCode,
    string publisherCode,
    string bookCode,
    ColumnCollection columns,
    List<FieldMapping> fieldMappings
)
Visual Basic (Declaration)
Public Sub New ( _
    languageCode As String, _
    publisherCode As String, _
    bookCode As String, _
    columns As ColumnCollection, _
    fieldMappings As List(Of FieldMapping) _
)
Visual C++
public:
SelectionListDefinition(
    String^ languageCode,
    String^ publisherCode,
    String^ bookCode,
    ColumnCollection^ columns,
    List<FieldMapping^>^ fieldMappings
)

Parameters

languageCode
Type: System..::.String
The language code.
publisherCode
Type: System..::.String
The publisher code.
bookCode
Type: System..::.String
The book code.
columns
Type: Mincom.LinkOne.Dom.SelectionList..::.ColumnCollection
The columns.
fieldMappings
Type: System.Collections.Generic..::.List<(Of <( FieldMapping >)>)
The field mappings.

See Also

SelectionListDefinition Class
Mincom.LinkOne.WebView.WebServer.Configuration Namespace


SelectionListDefinition Methods

[image] [image]

LinkOne WebView API
SelectionListDefinition Methods
SelectionListDefinition Class See Also Send Feedback

The SelectionListDefinition type exposes the following members.

Methods

Name | Description
CreateSelectionList | Creates a new selection list, based on the FieldMapper columns.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SelectionListDefinition Class
Mincom.LinkOne.WebView.WebServer.Configuration Namespace


CreateSelectionList Method

[image]

LinkOne WebView API
SelectionListDefinition..::.CreateSelectionList Method
SelectionListDefinition Class See Also Send Feedback
Creates a new selection list, based on the FieldMapper columns.

Namespace: Mincom.LinkOne.WebView.WebServer.Configuration
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public virtual SelectionList CreateSelectionList()
Visual Basic (Declaration)
Public Overridable Function CreateSelectionList As SelectionList
Visual C++
public:
virtual SelectionList^ CreateSelectionList()

Return Value

A new selection list

See Also

SelectionListDefinition Class
Mincom.LinkOne.WebView.WebServer.Configuration Namespace


SelectionListDefinition Properties

[image] [image]

LinkOne WebView API
SelectionListDefinition Properties
SelectionListDefinition Class See Also Send Feedback

The SelectionListDefinition type exposes the following members.

Properties

Name | Description
BookCode | Gets the book code that this definition is targeted at.
Columns | Gets the columns in the definition.
FieldMapper | Gets the field mapper that maps entries to the selection list that list definition describes.
LanguageCode | Gets the language code that this definition is targeted at.
PublisherCode | Gets the publisher code that this definition is targeted at.

See Also

SelectionListDefinition Class
Mincom.LinkOne.WebView.WebServer.Configuration Namespace


BookCode Property

[image]

LinkOne WebView API
SelectionListDefinition..::.BookCode Property
SelectionListDefinition Class See Also Send Feedback
Gets the book code that this definition is targeted at.

Namespace: Mincom.LinkOne.WebView.WebServer.Configuration
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string BookCode { get; private set; }
Visual Basic (Declaration)
Public Property BookCode As String
Visual C++
public:
property String^ BookCode {
    String^ get ();
    void set (String^ value);
}

See Also

SelectionListDefinition Class
Mincom.LinkOne.WebView.WebServer.Configuration Namespace


Columns Property

[image]

LinkOne WebView API
SelectionListDefinition..::.Columns Property
SelectionListDefinition Class See Also Send Feedback
Gets the columns in the definition.

Namespace: Mincom.LinkOne.WebView.WebServer.Configuration
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public ColumnCollection Columns { get; private set; }
Visual Basic (Declaration)
Public Property Columns As ColumnCollection
Visual C++
public:
property ColumnCollection^ Columns {
    ColumnCollection^ get ();
    void set (ColumnCollection^ value);
}

See Also

SelectionListDefinition Class
Mincom.LinkOne.WebView.WebServer.Configuration Namespace


FieldMapper Property

[image]

LinkOne WebView API
SelectionListDefinition..::.FieldMapper Property
SelectionListDefinition Class See Also Send Feedback
Gets the field mapper that maps entries to the selection list that list definition describes.

Namespace: Mincom.LinkOne.WebView.WebServer.Configuration
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public virtual FieldMapper FieldMapper { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property FieldMapper As FieldMapper
Visual C++
public:
virtual property FieldMapper^ FieldMapper {
    FieldMapper^ get ();
}

See Also

SelectionListDefinition Class
Mincom.LinkOne.WebView.WebServer.Configuration Namespace


LanguageCode Property

[image]

LinkOne WebView API
SelectionListDefinition..::.LanguageCode Property
SelectionListDefinition Class See Also Send Feedback
Gets the language code that this definition is targeted at.

Namespace: Mincom.LinkOne.WebView.WebServer.Configuration
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string LanguageCode { get; private set; }
Visual Basic (Declaration)
Public Property LanguageCode As String
Visual C++
public:
property String^ LanguageCode {
    String^ get ();
    void set (String^ value);
}

Field Value

See Also

SelectionListDefinition Class
Mincom.LinkOne.WebView.WebServer.Configuration Namespace


PublisherCode Property

[image]

LinkOne WebView API
SelectionListDefinition..::.PublisherCode Property
SelectionListDefinition Class See Also Send Feedback
Gets the publisher code that this definition is targeted at.

Namespace: Mincom.LinkOne.WebView.WebServer.Configuration
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PublisherCode { get; private set; }
Visual Basic (Declaration)
Public Property PublisherCode As String
Visual C++
public:
property String^ PublisherCode {
    String^ get ();
    void set (String^ value);
}

Field Value

See Also

SelectionListDefinition Class
Mincom.LinkOne.WebView.WebServer.Configuration Namespace


Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient Namespace
Send Feedback

Classes

Class | Description
LinkOneSqlConnection |


LinkOneSqlConnection Class

[image]

LinkOne WebView API
LinkOneSqlConnection Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class LinkOneSqlConnection
Visual Basic (Declaration)
Public Class LinkOneSqlConnection
Visual C++
public ref class LinkOneSqlConnection

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient..::.LinkOneSqlConnection

See Also

LinkOneSqlConnection Members
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient Namespace


LinkOneSqlConnection Members

[image] [image]

LinkOne WebView API
LinkOneSqlConnection Members
LinkOneSqlConnection Class Constructors Methods Fields See Also Send Feedback

The LinkOneSqlConnection type exposes the following members.

Constructors

Name | Description
LinkOneSqlConnection | Initializes a new instance of the LinkOneSqlConnection class

Methods

Name | Description
CreateConnection | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
LINKONE_SQL_CONNECTION_NAME |

See Also

LinkOneSqlConnection Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient Namespace


LinkOneSqlConnection Constructor

[image]

LinkOne WebView API
LinkOneSqlConnection Constructor
LinkOneSqlConnection Class See Also Send Feedback
Initializes a new instance of the LinkOneSqlConnection class

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public LinkOneSqlConnection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LinkOneSqlConnection()

See Also

LinkOneSqlConnection Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient Namespace


LinkOneSqlConnection Fields

[image] [image]

LinkOne WebView API
LinkOneSqlConnection Fields
LinkOneSqlConnection Class See Also Send Feedback

The LinkOneSqlConnection type exposes the following members.

Fields

Name | Description
LINKONE_SQL_CONNECTION_NAME |

See Also

LinkOneSqlConnection Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient Namespace


LINKONE_SQL_CONNECTION_NAME Field

[image]

LinkOne WebView API
LinkOneSqlConnection..::.LINKONE_SQL_CONNECTION_NAME Field
LinkOneSqlConnection Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public const string LINKONE_SQL_CONNECTION_NAME
Visual Basic (Declaration)
Public Const LINKONE_SQL_CONNECTION_NAME As String
Visual C++
public:
literal String^ LINKONE_SQL_CONNECTION_NAME

See Also

LinkOneSqlConnection Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient Namespace


LinkOneSqlConnection Methods

[image] [image]

LinkOne WebView API
LinkOneSqlConnection Methods
LinkOneSqlConnection Class See Also Send Feedback

The LinkOneSqlConnection type exposes the following members.

Methods

Name | Description
CreateConnection | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LinkOneSqlConnection Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient Namespace


CreateConnection Method

[image] [image]

LinkOne WebView API
LinkOneSqlConnection..::.CreateConnection Method
LinkOneSqlConnection Class See Also Send Feedback

Overload List

Name | Description
CreateConnection()()() |
CreateConnection(String) |

See Also

LinkOneSqlConnection Class
LinkOneSqlConnection Members
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient Namespace


CreateConnection Method

[image]

LinkOne WebView API
LinkOneSqlConnection..::.CreateConnection Method
LinkOneSqlConnection Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public static SqlConnection CreateConnection()
Visual Basic (Declaration)
Public Shared Function CreateConnection As SqlConnection
Visual C++
public:
static SqlConnection^ CreateConnection()

See Also

LinkOneSqlConnection Class
CreateConnection Overload
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient Namespace


CreateConnection Method (String)

[image]

LinkOne WebView API
LinkOneSqlConnection..::.CreateConnection Method (String)
LinkOneSqlConnection Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public static SqlConnection CreateConnection(
    string connectionName
)
Visual Basic (Declaration)
Public Shared Function CreateConnection ( _
    connectionName As String _
) As SqlConnection
Visual C++
public:
static SqlConnection^ CreateConnection(
    String^ connectionName
)

Parameters

connectionName
Type: System..::.String

See Also

LinkOneSqlConnection Class
CreateConnection Overload
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient Namespace


Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace
Send Feedback

Classes

Class | Description
DownloadReport |
DownloadReportDetail |
OfflineAuditDownload |
OfflineBook |
OfflineBrowserDetail |
OfflinePage |
OfflinePicture |
OfflineSelectionList |
OfflineUser |


DownloadReport Class

[image]

LinkOne WebView API
DownloadReport Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class DownloadReport
Visual Basic (Declaration)
Public Class DownloadReport
Visual C++
public ref class DownloadReport

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities..::.DownloadReport

See Also

DownloadReport Members
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


DownloadReport Members

[image] [image]

LinkOne WebView API
DownloadReport Members
DownloadReport Class Constructors Methods Properties See Also Send Feedback

The DownloadReport type exposes the following members.

Constructors

Name | Description
DownloadReport | Initializes a new instance of the DownloadReport class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Book |
LastDownloaded |
PagesDownloaded |

See Also

DownloadReport Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


DownloadReport Constructor

[image]

LinkOne WebView API
DownloadReport Constructor
DownloadReport Class See Also Send Feedback
Initializes a new instance of the DownloadReport class

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public DownloadReport()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DownloadReport()

See Also

DownloadReport Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


DownloadReport Methods

[image] [image]

LinkOne WebView API
DownloadReport Methods
DownloadReport Class See Also Send Feedback

The DownloadReport type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DownloadReport Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


DownloadReport Properties

[image] [image]

LinkOne WebView API
DownloadReport Properties
DownloadReport Class See Also Send Feedback

The DownloadReport type exposes the following members.

Properties

Name | Description
Book |
LastDownloaded |
PagesDownloaded |

See Also

DownloadReport Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


Book Property

[image]

LinkOne WebView API
DownloadReport..::.Book Property
DownloadReport Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Book { get; set; }
Visual Basic (Declaration)
Public Property Book As String
Visual C++
public:
property String^ Book {
    String^ get ();
    void set (String^ value);
}

See Also

DownloadReport Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


LastDownloaded Property

[image]

LinkOne WebView API
DownloadReport..::.LastDownloaded Property
DownloadReport Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public DateTime LastDownloaded { get; set; }
Visual Basic (Declaration)
Public Property LastDownloaded As DateTime
Visual C++
public:
property DateTime LastDownloaded {
    DateTime get ();
    void set (DateTime value);
}

See Also

DownloadReport Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


PagesDownloaded Property

[image]

LinkOne WebView API
DownloadReport..::.PagesDownloaded Property
DownloadReport Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int PagesDownloaded { get; set; }
Visual Basic (Declaration)
Public Property PagesDownloaded As Integer
Visual C++
public:
property int PagesDownloaded {
    int get ();
    void set (int value);
}

See Also

DownloadReport Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


DownloadReportDetail Class

[image]

LinkOne WebView API
DownloadReportDetail Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class DownloadReportDetail
Visual Basic (Declaration)
Public Class DownloadReportDetail
Visual C++
public ref class DownloadReportDetail

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities..::.DownloadReportDetail

See Also

DownloadReportDetail Members
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


DownloadReportDetail Members

[image] [image]

LinkOne WebView API
DownloadReportDetail Members
DownloadReportDetail Class Constructors Methods Properties See Also Send Feedback

The DownloadReportDetail type exposes the following members.

Constructors

Name | Description
DownloadReportDetail | Initializes a new instance of the DownloadReportDetail class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
BookCode |
BrowserName |
MachineIP |
MachineName |
No |
PageReference |
PublisherCode |
TimeStamp |
UserName |

See Also

DownloadReportDetail Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


DownloadReportDetail Constructor

[image]

LinkOne WebView API
DownloadReportDetail Constructor
DownloadReportDetail Class See Also Send Feedback
Initializes a new instance of the DownloadReportDetail class

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public DownloadReportDetail()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DownloadReportDetail()

See Also

DownloadReportDetail Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


DownloadReportDetail Methods

[image] [image]

LinkOne WebView API
DownloadReportDetail Methods
DownloadReportDetail Class See Also Send Feedback

The DownloadReportDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DownloadReportDetail Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


DownloadReportDetail Properties

[image] [image]

LinkOne WebView API
DownloadReportDetail Properties
DownloadReportDetail Class See Also Send Feedback

The DownloadReportDetail type exposes the following members.

Properties

Name | Description
BookCode |
BrowserName |
MachineIP |
MachineName |
No |
PageReference |
PublisherCode |
TimeStamp |
UserName |

See Also

DownloadReportDetail Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


BookCode Property

[image]

LinkOne WebView API
DownloadReportDetail..::.BookCode Property
DownloadReportDetail Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string BookCode { get; set; }
Visual Basic (Declaration)
Public Property BookCode As String
Visual C++
public:
property String^ BookCode {
    String^ get ();
    void set (String^ value);
}

See Also

DownloadReportDetail Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


BrowserName Property

[image]

LinkOne WebView API
DownloadReportDetail..::.BrowserName Property
DownloadReportDetail Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string BrowserName { get; set; }
Visual Basic (Declaration)
Public Property BrowserName As String
Visual C++
public:
property String^ BrowserName {
    String^ get ();
    void set (String^ value);
}

See Also

DownloadReportDetail Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


MachineIP Property

[image]

LinkOne WebView API
DownloadReportDetail..::.MachineIP Property
DownloadReportDetail Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string MachineIP { get; set; }
Visual Basic (Declaration)
Public Property MachineIP As String
Visual C++
public:
property String^ MachineIP {
    String^ get ();
    void set (String^ value);
}

See Also

DownloadReportDetail Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


MachineName Property

[image]

LinkOne WebView API
DownloadReportDetail..::.MachineName Property
DownloadReportDetail Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string MachineName { get; set; }
Visual Basic (Declaration)
Public Property MachineName As String
Visual C++
public:
property String^ MachineName {
    String^ get ();
    void set (String^ value);
}

See Also

DownloadReportDetail Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


No Property

[image]

LinkOne WebView API
DownloadReportDetail..::.No Property
DownloadReportDetail Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public long No { get; set; }
Visual Basic (Declaration)
Public Property No As Long
Visual C++
public:
property long long No {
    long long get ();
    void set (long long value);
}

See Also

DownloadReportDetail Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


PageReference Property

[image]

LinkOne WebView API
DownloadReportDetail..::.PageReference Property
DownloadReportDetail Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PageReference { get; set; }
Visual Basic (Declaration)
Public Property PageReference As String
Visual C++
public:
property String^ PageReference {
    String^ get ();
    void set (String^ value);
}

See Also

DownloadReportDetail Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


PublisherCode Property

[image]

LinkOne WebView API
DownloadReportDetail..::.PublisherCode Property
DownloadReportDetail Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PublisherCode { get; set; }
Visual Basic (Declaration)
Public Property PublisherCode As String
Visual C++
public:
property String^ PublisherCode {
    String^ get ();
    void set (String^ value);
}

See Also

DownloadReportDetail Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


TimeStamp Property

[image]

LinkOne WebView API
DownloadReportDetail..::.TimeStamp Property
DownloadReportDetail Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public DateTime TimeStamp { get; set; }
Visual Basic (Declaration)
Public Property TimeStamp As DateTime
Visual C++
public:
property DateTime TimeStamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

DownloadReportDetail Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


UserName Property

[image]

LinkOne WebView API
DownloadReportDetail..::.UserName Property
DownloadReportDetail Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string UserName { get; set; }
Visual Basic (Declaration)
Public Property UserName As String
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

DownloadReportDetail Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflineAuditDownload Class

[image]

LinkOne WebView API
OfflineAuditDownload Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class OfflineAuditDownload
Visual Basic (Declaration)
Public Class OfflineAuditDownload
Visual C++
public ref class OfflineAuditDownload

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities..::.OfflineAuditDownload

See Also

OfflineAuditDownload Members
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflineAuditDownload Members

[image] [image]

LinkOne WebView API
OfflineAuditDownload Members
OfflineAuditDownload Class Constructors Methods Properties See Also Send Feedback

The OfflineAuditDownload type exposes the following members.

Constructors

Name | Description
OfflineAuditDownload | Initializes a new instance of the OfflineAuditDownload class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Audit_Download_Id |
Browser_Id |
Page_Id |
TimeStamp |
User_Id |

See Also

OfflineAuditDownload Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflineAuditDownload Constructor

[image]

LinkOne WebView API
OfflineAuditDownload Constructor
OfflineAuditDownload Class See Also Send Feedback
Initializes a new instance of the OfflineAuditDownload class

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public OfflineAuditDownload()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OfflineAuditDownload()

See Also

OfflineAuditDownload Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflineAuditDownload Methods

[image] [image]

LinkOne WebView API
OfflineAuditDownload Methods
OfflineAuditDownload Class See Also Send Feedback

The OfflineAuditDownload type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

OfflineAuditDownload Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflineAuditDownload Properties

[image] [image]

LinkOne WebView API
OfflineAuditDownload Properties
OfflineAuditDownload Class See Also Send Feedback

The OfflineAuditDownload type exposes the following members.

Properties

Name | Description
Audit_Download_Id |
Browser_Id |
Page_Id |
TimeStamp |
User_Id |

See Also

OfflineAuditDownload Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


Audit_Download_Id Property

[image]

LinkOne WebView API
OfflineAuditDownload..::.Audit_Download_Id Property
OfflineAuditDownload Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int Audit_Download_Id { get; set; }
Visual Basic (Declaration)
Public Property Audit_Download_Id As Integer
Visual C++
public:
property int Audit_Download_Id {
    int get ();
    void set (int value);
}

See Also

OfflineAuditDownload Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


Browser_Id Property

[image]

LinkOne WebView API
OfflineAuditDownload..::.Browser_Id Property
OfflineAuditDownload Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int Browser_Id { get; set; }
Visual Basic (Declaration)
Public Property Browser_Id As Integer
Visual C++
public:
property int Browser_Id {
    int get ();
    void set (int value);
}

See Also

OfflineAuditDownload Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


Page_Id Property

[image]

LinkOne WebView API
OfflineAuditDownload..::.Page_Id Property
OfflineAuditDownload Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int Page_Id { get; set; }
Visual Basic (Declaration)
Public Property Page_Id As Integer
Visual C++
public:
property int Page_Id {
    int get ();
    void set (int value);
}

See Also

OfflineAuditDownload Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


TimeStamp Property

[image]

LinkOne WebView API
OfflineAuditDownload..::.TimeStamp Property
OfflineAuditDownload Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public DateTime TimeStamp { get; set; }
Visual Basic (Declaration)
Public Property TimeStamp As DateTime
Visual C++
public:
property DateTime TimeStamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

OfflineAuditDownload Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


User_Id Property

[image]

LinkOne WebView API
OfflineAuditDownload..::.User_Id Property
OfflineAuditDownload Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int User_Id { get; set; }
Visual Basic (Declaration)
Public Property User_Id As Integer
Visual C++
public:
property int User_Id {
    int get ();
    void set (int value);
}

See Also

OfflineAuditDownload Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflineBook Class

[image]

LinkOne WebView API
OfflineBook Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class OfflineBook
Visual Basic (Declaration)
Public Class OfflineBook
Visual C++
public ref class OfflineBook

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities..::.OfflineBook

See Also

OfflineBook Members
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflineBook Members

[image] [image]

LinkOne WebView API
OfflineBook Members
OfflineBook Class Constructors Methods Properties See Also Send Feedback

The OfflineBook type exposes the following members.

Constructors

Name | Description
OfflineBook | Initializes a new instance of the OfflineBook class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Book_Id |
BookCode |
BookDescription |
PublisherCode |

See Also

OfflineBook Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflineBook Constructor

[image]

LinkOne WebView API
OfflineBook Constructor
OfflineBook Class See Also Send Feedback
Initializes a new instance of the OfflineBook class

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public OfflineBook()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OfflineBook()

See Also

OfflineBook Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflineBook Methods

[image] [image]

LinkOne WebView API
OfflineBook Methods
OfflineBook Class See Also Send Feedback

The OfflineBook type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

OfflineBook Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflineBook Properties

[image] [image]

LinkOne WebView API
OfflineBook Properties
OfflineBook Class See Also Send Feedback

The OfflineBook type exposes the following members.

Properties

Name | Description
Book_Id |
BookCode |
BookDescription |
PublisherCode |

See Also

OfflineBook Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


Book_Id Property

[image]

LinkOne WebView API
OfflineBook..::.Book_Id Property
OfflineBook Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int Book_Id { get; set; }
Visual Basic (Declaration)
Public Property Book_Id As Integer
Visual C++
public:
property int Book_Id {
    int get ();
    void set (int value);
}

See Also

OfflineBook Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


BookCode Property

[image]

LinkOne WebView API
OfflineBook..::.BookCode Property
OfflineBook Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string BookCode { get; set; }
Visual Basic (Declaration)
Public Property BookCode As String
Visual C++
public:
property String^ BookCode {
    String^ get ();
    void set (String^ value);
}

See Also

OfflineBook Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


BookDescription Property

[image]

LinkOne WebView API
OfflineBook..::.BookDescription Property
OfflineBook Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string BookDescription { get; set; }
Visual Basic (Declaration)
Public Property BookDescription As String
Visual C++
public:
property String^ BookDescription {
    String^ get ();
    void set (String^ value);
}

See Also

OfflineBook Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


PublisherCode Property

[image]

LinkOne WebView API
OfflineBook..::.PublisherCode Property
OfflineBook Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PublisherCode { get; set; }
Visual Basic (Declaration)
Public Property PublisherCode As String
Visual C++
public:
property String^ PublisherCode {
    String^ get ();
    void set (String^ value);
}

See Also

OfflineBook Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflineBrowserDetail Class

[image]

LinkOne WebView API
OfflineBrowserDetail Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class OfflineBrowserDetail
Visual Basic (Declaration)
Public Class OfflineBrowserDetail
Visual C++
public ref class OfflineBrowserDetail

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities..::.OfflineBrowserDetail

See Also

OfflineBrowserDetail Members
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflineBrowserDetail Members

[image] [image]

LinkOne WebView API
OfflineBrowserDetail Members
OfflineBrowserDetail Class Constructors Methods Properties See Also Send Feedback

The OfflineBrowserDetail type exposes the following members.

Constructors

Name | Description
OfflineBrowserDetail | Initializes a new instance of the OfflineBrowserDetail class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Browser_Id |
BrowserName |
MachineIP |
MachineName |

See Also

OfflineBrowserDetail Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflineBrowserDetail Constructor

[image]

LinkOne WebView API
OfflineBrowserDetail Constructor
OfflineBrowserDetail Class See Also Send Feedback
Initializes a new instance of the OfflineBrowserDetail class

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public OfflineBrowserDetail()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OfflineBrowserDetail()

See Also

OfflineBrowserDetail Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflineBrowserDetail Methods

[image] [image]

LinkOne WebView API
OfflineBrowserDetail Methods
OfflineBrowserDetail Class See Also Send Feedback

The OfflineBrowserDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

OfflineBrowserDetail Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflineBrowserDetail Properties

[image] [image]

LinkOne WebView API
OfflineBrowserDetail Properties
OfflineBrowserDetail Class See Also Send Feedback

The OfflineBrowserDetail type exposes the following members.

Properties

Name | Description
Browser_Id |
BrowserName |
MachineIP |
MachineName |

See Also

OfflineBrowserDetail Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


Browser_Id Property

[image]

LinkOne WebView API
OfflineBrowserDetail..::.Browser_Id Property
OfflineBrowserDetail Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int Browser_Id { get; set; }
Visual Basic (Declaration)
Public Property Browser_Id As Integer
Visual C++
public:
property int Browser_Id {
    int get ();
    void set (int value);
}

See Also

OfflineBrowserDetail Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


BrowserName Property

[image]

LinkOne WebView API
OfflineBrowserDetail..::.BrowserName Property
OfflineBrowserDetail Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string BrowserName { get; set; }
Visual Basic (Declaration)
Public Property BrowserName As String
Visual C++
public:
property String^ BrowserName {
    String^ get ();
    void set (String^ value);
}

See Also

OfflineBrowserDetail Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


MachineIP Property

[image]

LinkOne WebView API
OfflineBrowserDetail..::.MachineIP Property
OfflineBrowserDetail Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string MachineIP { get; set; }
Visual Basic (Declaration)
Public Property MachineIP As String
Visual C++
public:
property String^ MachineIP {
    String^ get ();
    void set (String^ value);
}

See Also

OfflineBrowserDetail Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


MachineName Property

[image]

LinkOne WebView API
OfflineBrowserDetail..::.MachineName Property
OfflineBrowserDetail Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string MachineName { get; set; }
Visual Basic (Declaration)
Public Property MachineName As String
Visual C++
public:
property String^ MachineName {
    String^ get ();
    void set (String^ value);
}

See Also

OfflineBrowserDetail Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflinePage Class

[image]

LinkOne WebView API
OfflinePage Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class OfflinePage
Visual Basic (Declaration)
Public Class OfflinePage
Visual C++
public ref class OfflinePage

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities..::.OfflinePage

See Also

OfflinePage Members
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflinePage Members

[image] [image]

LinkOne WebView API
OfflinePage Members
OfflinePage Class Constructors Methods Properties See Also Send Feedback

The OfflinePage type exposes the following members.

Constructors

Name | Description
OfflinePage | Initializes a new instance of the OfflinePage class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Book_Id |
EmbeddedFileUri |
Page_Id |
PageEmbeddedFileInfoJson |
PageHtml |
PageReference |
Type |

See Also

OfflinePage Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflinePage Constructor

[image]

LinkOne WebView API
OfflinePage Constructor
OfflinePage Class See Also Send Feedback
Initializes a new instance of the OfflinePage class

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public OfflinePage()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OfflinePage()

See Also

OfflinePage Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflinePage Methods

[image] [image]

LinkOne WebView API
OfflinePage Methods
OfflinePage Class See Also Send Feedback

The OfflinePage type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

OfflinePage Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflinePage Properties

[image] [image]

LinkOne WebView API
OfflinePage Properties
OfflinePage Class See Also Send Feedback

The OfflinePage type exposes the following members.

Properties

Name | Description
Book_Id |
EmbeddedFileUri |
Page_Id |
PageEmbeddedFileInfoJson |
PageHtml |
PageReference |
Type |

See Also

OfflinePage Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


Book_Id Property

[image]

LinkOne WebView API
OfflinePage..::.Book_Id Property
OfflinePage Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int Book_Id { get; set; }
Visual Basic (Declaration)
Public Property Book_Id As Integer
Visual C++
public:
property int Book_Id {
    int get ();
    void set (int value);
}

See Also

OfflinePage Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


EmbeddedFileUri Property

[image]

LinkOne WebView API
OfflinePage..::.EmbeddedFileUri Property
OfflinePage Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string EmbeddedFileUri { get; set; }
Visual Basic (Declaration)
Public Property EmbeddedFileUri As String
Visual C++
public:
property String^ EmbeddedFileUri {
    String^ get ();
    void set (String^ value);
}

See Also

OfflinePage Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


Page_Id Property

[image]

LinkOne WebView API
OfflinePage..::.Page_Id Property
OfflinePage Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int Page_Id { get; set; }
Visual Basic (Declaration)
Public Property Page_Id As Integer
Visual C++
public:
property int Page_Id {
    int get ();
    void set (int value);
}

See Also

OfflinePage Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


PageEmbeddedFileInfoJson Property

[image]

LinkOne WebView API
OfflinePage..::.PageEmbeddedFileInfoJson Property
OfflinePage Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PageEmbeddedFileInfoJson { get; set; }
Visual Basic (Declaration)
Public Property PageEmbeddedFileInfoJson As String
Visual C++
public:
property String^ PageEmbeddedFileInfoJson {
    String^ get ();
    void set (String^ value);
}

See Also

OfflinePage Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


PageHtml Property

[image]

LinkOne WebView API
OfflinePage..::.PageHtml Property
OfflinePage Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PageHtml { get; set; }
Visual Basic (Declaration)
Public Property PageHtml As String
Visual C++
public:
property String^ PageHtml {
    String^ get ();
    void set (String^ value);
}

See Also

OfflinePage Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


PageReference Property

[image]

LinkOne WebView API
OfflinePage..::.PageReference Property
OfflinePage Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PageReference { get; set; }
Visual Basic (Declaration)
Public Property PageReference As String
Visual C++
public:
property String^ PageReference {
    String^ get ();
    void set (String^ value);
}

See Also

OfflinePage Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


Type Property

[image]

LinkOne WebView API
OfflinePage..::.Type Property
OfflinePage Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int Type { get; set; }
Visual Basic (Declaration)
Public Property Type As Integer
Visual C++
public:
property int Type {
    int get ();
    void set (int value);
}

See Also

OfflinePage Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflinePicture Class

[image]

LinkOne WebView API
OfflinePicture Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class OfflinePicture
Visual Basic (Declaration)
Public Class OfflinePicture
Visual C++
public ref class OfflinePicture

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities..::.OfflinePicture

See Also

OfflinePicture Members
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflinePicture Members

[image] [image]

LinkOne WebView API
OfflinePicture Members
OfflinePicture Class Constructors Methods Properties See Also Send Feedback

The OfflinePicture type exposes the following members.

Constructors

Name | Description
OfflinePicture | Initializes a new instance of the OfflinePicture class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
ImageUri |
Number |
Page_Id |
PagePictureInfoJson |
Picture_Id |
ThumbnailUri |

See Also

OfflinePicture Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflinePicture Constructor

[image]

LinkOne WebView API
OfflinePicture Constructor
OfflinePicture Class See Also Send Feedback
Initializes a new instance of the OfflinePicture class

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public OfflinePicture()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OfflinePicture()

See Also

OfflinePicture Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflinePicture Methods

[image] [image]

LinkOne WebView API
OfflinePicture Methods
OfflinePicture Class See Also Send Feedback

The OfflinePicture type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

OfflinePicture Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflinePicture Properties

[image] [image]

LinkOne WebView API
OfflinePicture Properties
OfflinePicture Class See Also Send Feedback

The OfflinePicture type exposes the following members.

Properties

Name | Description
ImageUri |
Number |
Page_Id |
PagePictureInfoJson |
Picture_Id |
ThumbnailUri |

See Also

OfflinePicture Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


ImageUri Property

[image]

LinkOne WebView API
OfflinePicture..::.ImageUri Property
OfflinePicture Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string ImageUri { get; set; }
Visual Basic (Declaration)
Public Property ImageUri As String
Visual C++
public:
property String^ ImageUri {
    String^ get ();
    void set (String^ value);
}

See Also

OfflinePicture Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


Number Property

[image]

LinkOne WebView API
OfflinePicture..::.Number Property
OfflinePicture Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int Number { get; set; }
Visual Basic (Declaration)
Public Property Number As Integer
Visual C++
public:
property int Number {
    int get ();
    void set (int value);
}

See Also

OfflinePicture Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


Page_Id Property

[image]

LinkOne WebView API
OfflinePicture..::.Page_Id Property
OfflinePicture Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int Page_Id { get; set; }
Visual Basic (Declaration)
Public Property Page_Id As Integer
Visual C++
public:
property int Page_Id {
    int get ();
    void set (int value);
}

See Also

OfflinePicture Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


PagePictureInfoJson Property

[image]

LinkOne WebView API
OfflinePicture..::.PagePictureInfoJson Property
OfflinePicture Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PagePictureInfoJson { get; set; }
Visual Basic (Declaration)
Public Property PagePictureInfoJson As String
Visual C++
public:
property String^ PagePictureInfoJson {
    String^ get ();
    void set (String^ value);
}

See Also

OfflinePicture Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


Picture_Id Property

[image]

LinkOne WebView API
OfflinePicture..::.Picture_Id Property
OfflinePicture Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int Picture_Id { get; set; }
Visual Basic (Declaration)
Public Property Picture_Id As Integer
Visual C++
public:
property int Picture_Id {
    int get ();
    void set (int value);
}

See Also

OfflinePicture Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


ThumbnailUri Property

[image]

LinkOne WebView API
OfflinePicture..::.ThumbnailUri Property
OfflinePicture Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string ThumbnailUri { get; set; }
Visual Basic (Declaration)
Public Property ThumbnailUri As String
Visual C++
public:
property String^ ThumbnailUri {
    String^ get ();
    void set (String^ value);
}

See Also

OfflinePicture Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflineSelectionList Class

[image]

LinkOne WebView API
OfflineSelectionList Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class OfflineSelectionList
Visual Basic (Declaration)
Public Class OfflineSelectionList
Visual C++
public ref class OfflineSelectionList

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities..::.OfflineSelectionList

See Also

OfflineSelectionList Members
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflineSelectionList Members

[image] [image]

LinkOne WebView API
OfflineSelectionList Members
OfflineSelectionList Class Constructors Methods Properties See Also Send Feedback

The OfflineSelectionList type exposes the following members.

Constructors

Name | Description
OfflineSelectionList | Initializes a new instance of the OfflineSelectionList class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
ConfigurationName |
SelectionListName |
UserName |
Xml |

See Also

OfflineSelectionList Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflineSelectionList Constructor

[image]

LinkOne WebView API
OfflineSelectionList Constructor
OfflineSelectionList Class See Also Send Feedback
Initializes a new instance of the OfflineSelectionList class

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public OfflineSelectionList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OfflineSelectionList()

See Also

OfflineSelectionList Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflineSelectionList Methods

[image] [image]

LinkOne WebView API
OfflineSelectionList Methods
OfflineSelectionList Class See Also Send Feedback

The OfflineSelectionList type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

OfflineSelectionList Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflineSelectionList Properties

[image] [image]

LinkOne WebView API
OfflineSelectionList Properties
OfflineSelectionList Class See Also Send Feedback

The OfflineSelectionList type exposes the following members.

Properties

Name | Description
ConfigurationName |
SelectionListName |
UserName |
Xml |

See Also

OfflineSelectionList Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


ConfigurationName Property

[image]

LinkOne WebView API
OfflineSelectionList..::.ConfigurationName Property
OfflineSelectionList Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string ConfigurationName { get; set; }
Visual Basic (Declaration)
Public Property ConfigurationName As String
Visual C++
public:
property String^ ConfigurationName {
    String^ get ();
    void set (String^ value);
}

See Also

OfflineSelectionList Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


SelectionListName Property

[image]

LinkOne WebView API
OfflineSelectionList..::.SelectionListName Property
OfflineSelectionList Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string SelectionListName { get; set; }
Visual Basic (Declaration)
Public Property SelectionListName As String
Visual C++
public:
property String^ SelectionListName {
    String^ get ();
    void set (String^ value);
}

See Also

OfflineSelectionList Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


UserName Property

[image]

LinkOne WebView API
OfflineSelectionList..::.UserName Property
OfflineSelectionList Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string UserName { get; set; }
Visual Basic (Declaration)
Public Property UserName As String
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

OfflineSelectionList Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


Xml Property

[image]

LinkOne WebView API
OfflineSelectionList..::.Xml Property
OfflineSelectionList Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Xml { get; set; }
Visual Basic (Declaration)
Public Property Xml As String
Visual C++
public:
property String^ Xml {
    String^ get ();
    void set (String^ value);
}

See Also

OfflineSelectionList Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflineUser Class

[image]

LinkOne WebView API
OfflineUser Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class OfflineUser
Visual Basic (Declaration)
Public Class OfflineUser
Visual C++
public ref class OfflineUser

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities..::.OfflineUser

See Also

OfflineUser Members
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflineUser Members

[image] [image]

LinkOne WebView API
OfflineUser Members
OfflineUser Class Constructors Methods Properties See Also Send Feedback

The OfflineUser type exposes the following members.

Constructors

Name | Description
OfflineUser | Initializes a new instance of the OfflineUser class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
User_Id |
UserName |

See Also

OfflineUser Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflineUser Constructor

[image]

LinkOne WebView API
OfflineUser Constructor
OfflineUser Class See Also Send Feedback
Initializes a new instance of the OfflineUser class

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public OfflineUser()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OfflineUser()

See Also

OfflineUser Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflineUser Methods

[image] [image]

LinkOne WebView API
OfflineUser Methods
OfflineUser Class See Also Send Feedback

The OfflineUser type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

OfflineUser Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


OfflineUser Properties

[image] [image]

LinkOne WebView API
OfflineUser Properties
OfflineUser Class See Also Send Feedback

The OfflineUser type exposes the following members.

Properties

Name | Description
User_Id |
UserName |

See Also

OfflineUser Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


User_Id Property

[image]

LinkOne WebView API
OfflineUser..::.User_Id Property
OfflineUser Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int User_Id { get; set; }
Visual Basic (Declaration)
Public Property User_Id As Integer
Visual C++
public:
property int User_Id {
    int get ();
    void set (int value);
}

See Also

OfflineUser Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


UserName Property

[image]

LinkOne WebView API
OfflineUser..::.UserName Property
OfflineUser Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string UserName { get; set; }
Visual Basic (Declaration)
Public Property UserName As String
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

OfflineUser Class
Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities Namespace


Mincom.LinkOne.WebView.WebServer.Exceptions Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.WebView.WebServer.Exceptions Namespace
Send Feedback
The Mincom.LinkOne.WebView.WebServer.Exceptions namespace supplies exceptions that are explicit to LinkOne WebView.

Classes

Class | Description
DraftBookException | This exception is thrown when a Draft Book Exception occurs.


DraftBookException Class

[image]

LinkOne WebView API
DraftBookException Class
Members See Also Send Feedback
This exception is thrown when a Draft Book Exception occurs.

Namespace: Mincom.LinkOne.WebView.WebServer.Exceptions
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
[SerializableAttribute]
public class DraftBookException : BaseException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class DraftBookException _
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class DraftBookException : public BaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Mincom.LinkOne.Exceptions..::.BaseException
Mincom.LinkOne.WebView.WebServer.Exceptions..::.DraftBookException

See Also

DraftBookException Members
Mincom.LinkOne.WebView.WebServer.Exceptions Namespace


DraftBookException Members

[image] [image]

LinkOne WebView API
DraftBookException Members
DraftBookException Class Constructors Methods Properties See Also Send Feedback

The DraftBookException type exposes the following members.

Constructors

Name | Description
DraftBookException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DraftBookException Class
Mincom.LinkOne.WebView.WebServer.Exceptions Namespace


DraftBookException Constructor

[image] [image]

LinkOne WebView API
DraftBookException Constructor
DraftBookException Class See Also Send Feedback

Overload List

Name | Description
DraftBookException()()() | Initializes a new instance of the DraftBookException class.
DraftBookException(String) | Initializes a new instance of the DraftBookException class.
DraftBookException(SerializationInfo, StreamingContext) | Initializes a new instance of the DraftBookException class.
DraftBookException(String, Exception) | Initializes a new instance of the DraftBookException class.
DraftBookException(String, array<Object>[]()[]) | Initializes a new instance of the DraftBookException class.
DraftBookException(String, Exception, array<Object>[]()[]) | Initializes a new instance of the DraftBookException class.

See Also

DraftBookException Class
DraftBookException Members
Mincom.LinkOne.WebView.WebServer.Exceptions Namespace


DraftBookException Constructor

[image]

LinkOne WebView API
DraftBookException Constructor
DraftBookException Class See Also Send Feedback
Initializes a new instance of the DraftBookException class.

Namespace: Mincom.LinkOne.WebView.WebServer.Exceptions
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public DraftBookException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DraftBookException()

See Also

DraftBookException Class
DraftBookException Overload
Mincom.LinkOne.WebView.WebServer.Exceptions Namespace


DraftBookException Constructor (String)

[image]

LinkOne WebView API
DraftBookException Constructor (String)
DraftBookException Class See Also Send Feedback
Initializes a new instance of the DraftBookException class.

Namespace: Mincom.LinkOne.WebView.WebServer.Exceptions
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public DraftBookException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
DraftBookException(
    String^ message
)

Parameters

message
Type: System..::.String
The exception message.

See Also

DraftBookException Class
DraftBookException Overload
Mincom.LinkOne.WebView.WebServer.Exceptions Namespace


DraftBookException Constructor (SerializationInfo, StreamingContext)

[image]

LinkOne WebView API
DraftBookException Constructor (SerializationInfo, StreamingContext)
DraftBookException Class See Also Send Feedback
Initializes a new instance of the DraftBookException class.

Namespace: Mincom.LinkOne.WebView.WebServer.Exceptions
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
protected DraftBookException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
DraftBookException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The object that holds the serialized object data.
context
Type: System.Runtime.Serialization..::.StreamingContext
The contextual information about the source or destination.

See Also

DraftBookException Class
DraftBookException Overload
Mincom.LinkOne.WebView.WebServer.Exceptions Namespace


DraftBookException Constructor (String, Exception)

[image]

LinkOne WebView API
DraftBookException Constructor (String, Exception)
DraftBookException Class See Also Send Feedback
Initializes a new instance of the DraftBookException class.

Namespace: Mincom.LinkOne.WebView.WebServer.Exceptions
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public DraftBookException(
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
DraftBookException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The exception to wrap.

See Also

DraftBookException Class
DraftBookException Overload
Mincom.LinkOne.WebView.WebServer.Exceptions Namespace


DraftBookException Constructor (String, Object[])

[image]

LinkOne WebView API
DraftBookException Constructor (String, array<Object>[]()[])
DraftBookException Class See Also Send Feedback
Initializes a new instance of the DraftBookException class.

Namespace: Mincom.LinkOne.WebView.WebServer.Exceptions
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public DraftBookException(
    string message,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    ParamArray args As Object() _
)
Visual C++
public:
DraftBookException(
    String^ message,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

DraftBookException Class
DraftBookException Overload
Mincom.LinkOne.WebView.WebServer.Exceptions Namespace


DraftBookException Constructor (String, Exception, Object[])

[image]

LinkOne WebView API
DraftBookException Constructor (String, Exception, array<Object>[]()[])
DraftBookException Class See Also Send Feedback
Initializes a new instance of the DraftBookException class.

Namespace: Mincom.LinkOne.WebView.WebServer.Exceptions
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public DraftBookException(
    string message,
    Exception inner,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception, _
    ParamArray args As Object() _
)
Visual C++
public:
DraftBookException(
    String^ message,
    Exception^ inner,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::.String
The exception message with formatting escape sequences.
inner
Type: System..::.Exception
The exception to wrap.
args
Type: array< System..::.Object >[]()[]
Arguments for the formatting of the message.

See Also

DraftBookException Class
DraftBookException Overload
Mincom.LinkOne.WebView.WebServer.Exceptions Namespace


DraftBookException Methods

[image] [image]

LinkOne WebView API
DraftBookException Methods
DraftBookException Class See Also Send Feedback

The DraftBookException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from BaseException.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DraftBookException Class
Mincom.LinkOne.WebView.WebServer.Exceptions Namespace


DraftBookException Properties

[image] [image]

LinkOne WebView API
DraftBookException Properties
DraftBookException Class See Also Send Feedback

The DraftBookException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DraftBookException Class
Mincom.LinkOne.WebView.WebServer.Exceptions Namespace


Mincom.LinkOne.WebView.WebServer.Handlers Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.WebView.WebServer.Handlers Namespace
Send Feedback

Classes

Class | Description
BookStylesheetHandler | This IHttpHandler serves picture tiles
PictureHandler | This IHttpHandler serves picture tiles
PrintHandler | This handler allows printing.


BookStylesheetHandler Class

[image]

LinkOne WebView API
BookStylesheetHandler Class
Members See Also Send Feedback
This IHttpHandler serves picture tiles

Namespace: Mincom.LinkOne.WebView.WebServer.Handlers
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class BookStylesheetHandler : IHttpHandler,
    IReadOnlySessionState, IRequiresSessionState
Visual Basic (Declaration)
Public Class BookStylesheetHandler _
    Implements IHttpHandler, IReadOnlySessionState, IRequiresSessionState
Visual C++
public ref class BookStylesheetHandler : IHttpHandler,
    IReadOnlySessionState, IRequiresSessionState

Remarks

Implements IReadOnlySessionState to allow asynchronous operation (simultaneous executions for a session)

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.Handlers..::.BookStylesheetHandler

See Also

BookStylesheetHandler Members
Mincom.LinkOne.WebView.WebServer.Handlers Namespace


BookStylesheetHandler Members

[image] [image]

LinkOne WebView API
BookStylesheetHandler Members
BookStylesheetHandler Class Constructors Methods Properties See Also Send Feedback

The BookStylesheetHandler type exposes the following members.

Constructors

Name | Description
BookStylesheetHandler | Initializes a new instance of the BookStylesheetHandler class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ProcessRequest | Processes the stylesheet request, decoding QueryString values to fetch the desired stylesheet.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
IsReusable | Returns true as the handler maintains no state.

See Also

BookStylesheetHandler Class
Mincom.LinkOne.WebView.WebServer.Handlers Namespace


BookStylesheetHandler Constructor

[image]

LinkOne WebView API
BookStylesheetHandler Constructor
BookStylesheetHandler Class See Also Send Feedback
Initializes a new instance of the BookStylesheetHandler class

Namespace: Mincom.LinkOne.WebView.WebServer.Handlers
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public BookStylesheetHandler()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BookStylesheetHandler()

See Also

BookStylesheetHandler Class
Mincom.LinkOne.WebView.WebServer.Handlers Namespace


BookStylesheetHandler Methods

[image] [image]

LinkOne WebView API
BookStylesheetHandler Methods
BookStylesheetHandler Class See Also Send Feedback

The BookStylesheetHandler type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ProcessRequest | Processes the stylesheet request, decoding QueryString values to fetch the desired stylesheet.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BookStylesheetHandler Class
Mincom.LinkOne.WebView.WebServer.Handlers Namespace


ProcessRequest Method

[image]

LinkOne WebView API
BookStylesheetHandler..::.ProcessRequest Method
BookStylesheetHandler Class See Also Send Feedback
Processes the stylesheet request, decoding QueryString values to fetch the desired stylesheet.

Namespace: Mincom.LinkOne.WebView.WebServer.Handlers
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void ProcessRequest(
    HttpContext context
)
Visual Basic (Declaration)
Public Sub ProcessRequest ( _
    context As HttpContext _
)
Visual C++
public:
virtual void ProcessRequest(
    HttpContext^ context
) sealed

Parameters

context
Type: System.Web..::.HttpContext
HttpContext being operated in.

Implements

IHttpHandler..::.ProcessRequest(HttpContext)

See Also

BookStylesheetHandler Class
Mincom.LinkOne.WebView.WebServer.Handlers Namespace


BookStylesheetHandler Properties

[image] [image]

LinkOne WebView API
BookStylesheetHandler Properties
BookStylesheetHandler Class See Also Send Feedback

The BookStylesheetHandler type exposes the following members.

Properties

Name | Description
IsReusable | Returns true as the handler maintains no state.

See Also

BookStylesheetHandler Class
Mincom.LinkOne.WebView.WebServer.Handlers Namespace


IsReusable Property

[image]

LinkOne WebView API
BookStylesheetHandler..::.IsReusable Property
BookStylesheetHandler Class See Also Send Feedback
Returns true as the handler maintains no state.

Namespace: Mincom.LinkOne.WebView.WebServer.Handlers
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool IsReusable { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReusable As Boolean
Visual C++
public:
virtual property bool IsReusable {
    bool get () sealed;
}

Implements

IHttpHandler..::.IsReusable

See Also

BookStylesheetHandler Class
Mincom.LinkOne.WebView.WebServer.Handlers Namespace


PictureHandler Class

[image]

LinkOne WebView API
PictureHandler Class
Members See Also Send Feedback
This IHttpHandler serves picture tiles

Namespace: Mincom.LinkOne.WebView.WebServer.Handlers
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class PictureHandler : IHttpHandler,
    IReadOnlySessionState, IRequiresSessionState
Visual Basic (Declaration)
Public Class PictureHandler _
    Implements IHttpHandler, IReadOnlySessionState, IRequiresSessionState
Visual C++
public ref class PictureHandler : IHttpHandler,
    IReadOnlySessionState, IRequiresSessionState

Remarks

Implements IReadOnlySessionState to allow asynchronous operation (simultaneous executions for a session)

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.Handlers..::.PictureHandler

See Also

PictureHandler Members
Mincom.LinkOne.WebView.WebServer.Handlers Namespace


PictureHandler Members

[image] [image]

LinkOne WebView API
PictureHandler Members
PictureHandler Class Constructors Methods Properties See Also Send Feedback

The PictureHandler type exposes the following members.

Constructors

Name | Description
PictureHandler | Initializes a new instance of the PictureHandler class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ProcessRequest | Processes the image request, decoding QueryString values to fetch the desired picture.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
IsReusable | Returns true as the handler maintains no state.

See Also

PictureHandler Class
Mincom.LinkOne.WebView.WebServer.Handlers Namespace


PictureHandler Constructor

[image]

LinkOne WebView API
PictureHandler Constructor
PictureHandler Class See Also Send Feedback
Initializes a new instance of the PictureHandler class

Namespace: Mincom.LinkOne.WebView.WebServer.Handlers
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public PictureHandler()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PictureHandler()

See Also

PictureHandler Class
Mincom.LinkOne.WebView.WebServer.Handlers Namespace


PictureHandler Methods

[image] [image]

LinkOne WebView API
PictureHandler Methods
PictureHandler Class See Also Send Feedback

The PictureHandler type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ProcessRequest | Processes the image request, decoding QueryString values to fetch the desired picture.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PictureHandler Class
Mincom.LinkOne.WebView.WebServer.Handlers Namespace


ProcessRequest Method

[image]

LinkOne WebView API
PictureHandler..::.ProcessRequest Method
PictureHandler Class See Also Send Feedback
Processes the image request, decoding QueryString values to fetch the desired picture.

Namespace: Mincom.LinkOne.WebView.WebServer.Handlers
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void ProcessRequest(
    HttpContext context
)
Visual Basic (Declaration)
Public Sub ProcessRequest ( _
    context As HttpContext _
)
Visual C++
public:
virtual void ProcessRequest(
    HttpContext^ context
) sealed

Parameters

context
Type: System.Web..::.HttpContext
HttpContext being operated in.

Implements

IHttpHandler..::.ProcessRequest(HttpContext)

Remarks

Query string parameters: pictureidentityThe identity of the picture to fetch. Generally a picture number. Available from the picture metadata Url. tileLevelDefines the tile level at which to fetch picture data. tilePositionXX position (column) of the tile to fetch. tilePositionYY position (row) of the tile to fetch.

See Also

PictureHandler Class
Mincom.LinkOne.WebView.WebServer.Handlers Namespace


PictureHandler Properties

[image] [image]

LinkOne WebView API
PictureHandler Properties
PictureHandler Class See Also Send Feedback

The PictureHandler type exposes the following members.

Properties

Name | Description
IsReusable | Returns true as the handler maintains no state.

See Also

PictureHandler Class
Mincom.LinkOne.WebView.WebServer.Handlers Namespace


IsReusable Property

[image]

LinkOne WebView API
PictureHandler..::.IsReusable Property
PictureHandler Class See Also Send Feedback
Returns true as the handler maintains no state.

Namespace: Mincom.LinkOne.WebView.WebServer.Handlers
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool IsReusable { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReusable As Boolean
Visual C++
public:
virtual property bool IsReusable {
    bool get () sealed;
}

Implements

IHttpHandler..::.IsReusable

See Also

PictureHandler Class
Mincom.LinkOne.WebView.WebServer.Handlers Namespace


PrintHandler Class

[image]

LinkOne WebView API
PrintHandler Class
Members See Also Send Feedback
This handler allows printing.

Namespace: Mincom.LinkOne.WebView.WebServer.Handlers
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class PrintHandler : Page,
    IHttpAsyncHandler, IHttpHandler, IRequiresSessionState
Visual Basic (Declaration)
Public Class PrintHandler _
    Inherits Page _
    Implements IHttpAsyncHandler, IHttpHandler, IRequiresSessionState
Visual C++
public ref class PrintHandler : public Page,
    IHttpAsyncHandler, IHttpHandler, IRequiresSessionState

Remarks

Implements IRequiresSessionState to ensure session data is available and Page to implement STA as required by embedded HTML printing.

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI..::.TemplateControl
System.Web.UI..::.Page
Mincom.LinkOne.WebView.WebServer.Handlers..::.PrintHandler

See Also

PrintHandler Members
Mincom.LinkOne.WebView.WebServer.Handlers Namespace


PrintHandler Members

[image] [image]

LinkOne WebView API
PrintHandler Members
PrintHandler Class Constructors Methods Properties Events Explicit Interface Implementations See Also Send Feedback

The PrintHandler type exposes the following members.

Constructors

Name | Description
PrintHandler | Initializes a new instance of the PrintHandler class

Methods

Name | Description
BeginProcessRequest |
Construct | Performs design-time logic. (Inherited from TemplateControl.)
CreateResourceBasedLiteralControl | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
EndProcessRequest |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Eval | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
FrameworkInitialize | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
GetGlobalResourceObject | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLocalResourceObject | Overloaded.
GetType | Gets the type of the current instance. (Inherited from Object.)
LoadControl | Overloaded.
LoadTemplate | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAbortTransaction | Raises the AbortTransaction event. (Inherited from TemplateControl.)
OnCommitTransaction | Raises the CommitTransaction event. (Inherited from TemplateControl.)
OnError | Raises the Error event. (Inherited from TemplateControl.)
OnInit | Processes the print request, decoding QueryString values as parameters.
ParseControl | Overloaded.
ReadStringResource | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
SetStringResourcePointer | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
TestDeviceFilter | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
WriteUTF8ResourceString | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
XPath | Overloaded.
XPathSelect | Overloaded.

Properties

Name | Description
AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)

Events

Name | Description
AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)

Explicit Interface Implementations

Name | Description
IFilterResolutionService..::.CompareFilters | Returns a value that indicates whether a parent/child relationship exists between two specified device filters. (Inherited from TemplateControl.)
IFilterResolutionService..::.EvaluateFilter | Returns a value that indicates whether the specified filter is a type of the current filter object. (Inherited from TemplateControl.)

See Also

PrintHandler Class
Mincom.LinkOne.WebView.WebServer.Handlers Namespace


PrintHandler Constructor

[image]

LinkOne WebView API
PrintHandler Constructor
PrintHandler Class See Also Send Feedback
Initializes a new instance of the PrintHandler class

Namespace: Mincom.LinkOne.WebView.WebServer.Handlers
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public PrintHandler()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PrintHandler()

See Also

PrintHandler Class
Mincom.LinkOne.WebView.WebServer.Handlers Namespace


PrintHandler Methods

[image] [image]

LinkOne WebView API
PrintHandler Methods
PrintHandler Class See Also Send Feedback

The PrintHandler type exposes the following members.

Methods

Name | Description
BeginProcessRequest |
Construct | Performs design-time logic. (Inherited from TemplateControl.)
CreateResourceBasedLiteralControl | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
EndProcessRequest |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Eval | Overloaded.
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
FrameworkInitialize | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
GetGlobalResourceObject | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLocalResourceObject | Overloaded.
GetType | Gets the type of the current instance. (Inherited from Object.)
LoadControl | Overloaded.
LoadTemplate | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAbortTransaction | Raises the AbortTransaction event. (Inherited from TemplateControl.)
OnCommitTransaction | Raises the CommitTransaction event. (Inherited from TemplateControl.)
OnError | Raises the Error event. (Inherited from TemplateControl.)
OnInit | Processes the print request, decoding QueryString values as parameters.
ParseControl | Overloaded.
ReadStringResource | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
SetStringResourcePointer | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
TestDeviceFilter | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
WriteUTF8ResourceString | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
XPath | Overloaded.
XPathSelect | Overloaded.

Explicit Interface Implementations

Name | Description
IFilterResolutionService..::.CompareFilters | Returns a value that indicates whether a parent/child relationship exists between two specified device filters. (Inherited from TemplateControl.)
IFilterResolutionService..::.EvaluateFilter | Returns a value that indicates whether the specified filter is a type of the current filter object. (Inherited from TemplateControl.)

See Also

PrintHandler Class
Mincom.LinkOne.WebView.WebServer.Handlers Namespace


BeginProcessRequest Method

[image]

LinkOne WebView API
PrintHandler..::.BeginProcessRequest Method
PrintHandler Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.Handlers
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public IAsyncResult BeginProcessRequest(
    HttpContext context,
    AsyncCallback cb,
    Object extraData
)
Visual Basic (Declaration)
Public Function BeginProcessRequest ( _
    context As HttpContext, _
    cb As AsyncCallback, _
    extraData As Object _
) As IAsyncResult
Visual C++
public:
virtual IAsyncResult^ BeginProcessRequest(
    HttpContext^ context,
    AsyncCallback^ cb,
    Object^ extraData
) sealed

Parameters

context
Type: System.Web..::.HttpContext
cb
Type: System..::.AsyncCallback
extraData
Type: System..::.Object

Implements

IHttpAsyncHandler..::.BeginProcessRequest(HttpContext, AsyncCallback, Object)

See Also

PrintHandler Class
Mincom.LinkOne.WebView.WebServer.Handlers Namespace


EndProcessRequest Method

[image]

LinkOne WebView API
PrintHandler..::.EndProcessRequest Method
PrintHandler Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.Handlers
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void EndProcessRequest(
    IAsyncResult result
)
Visual Basic (Declaration)
Public Sub EndProcessRequest ( _
    result As IAsyncResult _
)
Visual C++
public:
virtual void EndProcessRequest(
    IAsyncResult^ result
) sealed

Parameters

result
Type: System..::.IAsyncResult

Implements

IHttpAsyncHandler..::.EndProcessRequest(IAsyncResult)

See Also

PrintHandler Class
Mincom.LinkOne.WebView.WebServer.Handlers Namespace


Eval Method

[image] [image]

LinkOne WebView API
PrintHandler..::.Eval Method
PrintHandler Class See Also Send Feedback

Overload List

Name | Description
Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)

See Also

PrintHandler Class
PrintHandler Members
Mincom.LinkOne.WebView.WebServer.Handlers Namespace


GetGlobalResourceObject Method

[image] [image]

LinkOne WebView API
PrintHandler..::.GetGlobalResourceObject Method
PrintHandler Class See Also Send Feedback

Overload List

Name | Description
GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)

See Also

PrintHandler Class
PrintHandler Members
Mincom.LinkOne.WebView.WebServer.Handlers Namespace


GetLocalResourceObject Method

[image] [image]

LinkOne WebView API
PrintHandler..::.GetLocalResourceObject Method
PrintHandler Class See Also Send Feedback

Overload List

Name | Description
GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)

See Also

PrintHandler Class
PrintHandler Members
Mincom.LinkOne.WebView.WebServer.Handlers Namespace


LoadControl Method

[image] [image]

LinkOne WebView API
PrintHandler..::.LoadControl Method
PrintHandler Class See Also Send Feedback

Overload List

Name | Description
LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)

See Also

PrintHandler Class
PrintHandler Members
Mincom.LinkOne.WebView.WebServer.Handlers Namespace


OnInit Method

[image]

LinkOne WebView API
PrintHandler..::.OnInit Method
PrintHandler Class See Also Send Feedback
Processes the print request, decoding QueryString values as parameters.

Namespace: Mincom.LinkOne.WebView.WebServer.Handlers
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
protected virtual void OnInit(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnInit ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnInit(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs
EventArgs.

Remarks

Query string parameters: publisherCodeThe publisher code of the book to print. bookCodeThe book code of the book to print. printScopeThe print scope to print.

See Also

PrintHandler Class
Mincom.LinkOne.WebView.WebServer.Handlers Namespace


ParseControl Method

[image] [image]

LinkOne WebView API
PrintHandler..::.ParseControl Method
PrintHandler Class See Also Send Feedback

Overload List

Name | Description
ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)

See Also

PrintHandler Class
PrintHandler Members
Mincom.LinkOne.WebView.WebServer.Handlers Namespace


XPath Method

[image] [image]

LinkOne WebView API
PrintHandler..::.XPath Method
PrintHandler Class See Also Send Feedback

Overload List

Name | Description
XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)

See Also

PrintHandler Class
PrintHandler Members
Mincom.LinkOne.WebView.WebServer.Handlers Namespace


XPathSelect Method

[image] [image]

LinkOne WebView API
PrintHandler..::.XPathSelect Method
PrintHandler Class See Also Send Feedback

Overload List

Name | Description
XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)

See Also

PrintHandler Class
PrintHandler Members
Mincom.LinkOne.WebView.WebServer.Handlers Namespace


PrintHandler Properties

[image] [image]

LinkOne WebView API
PrintHandler Properties
PrintHandler Class See Also Send Feedback

The PrintHandler type exposes the following members.

Properties

Name | Description
AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)

See Also

PrintHandler Class
Mincom.LinkOne.WebView.WebServer.Handlers Namespace


PrintHandler Events

[image] [image]

LinkOne WebView API
PrintHandler Events
PrintHandler Class See Also Send Feedback

The PrintHandler type exposes the following members.

Events

Name | Description
AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)

See Also

PrintHandler Class
Mincom.LinkOne.WebView.WebServer.Handlers Namespace


Mincom.LinkOne.WebView.WebServer.Html Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.WebView.WebServer.Html Namespace
Send Feedback
The Mincom.LinkOne.WebView.WebServer.Html namespace supplies classes that implement custom ASP.Net custom controls that are used to build the LinkOne WebView user interface. Each class may be referenced in an aspx page as <LinkOne:class>.

Classes

Class | Description
Catalog | Renders the catalog of books from the library.
Parts | Renders the parts content when there are parts for the current page.
Toc | Renders the table of contents for the current book.


Catalog Class

[image]

LinkOne WebView API
Catalog Class
Members Example See Also Send Feedback
Renders the catalog of books from the library.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public sealed class Catalog : WebControl
Visual Basic (Declaration)
Public NotInheritable Class Catalog _
    Inherits WebControl
Visual C++
public ref class Catalog sealed : public WebControl

Remarks

This tag can render an entire catalog tree, or just a catalog entry. An entry can be a publisher, a category or a book.

Rendering can occur for the top level entries, and then the tag can be called as needed to render sub entries as the user expands any entry.

Rendering sub entries requires the argument expand=? in the requesting URL, where ? is the identifier of the entry to expand.

Rendering the top level entries occurs when no expand=? is present.

This tag supports the following attributes:
Attribute | Purpose | Default
rootdepth | Controls the initial depth of the rendered tree. | blank

When rendering the top level entries initially, the depth of the rendered tree can be controlled with the rootdepth attribute:
RootDepth | Purpose
not given | Renders only one level of the tree.
blank | Renders only one level of the tree.
0 | Renders only one level of the tree.
positive integer | Renders the tree to the specified depth.
all | Renders the entire tree.
negative integer | Renders the entire tree.

Examples

To initially render the top level of catalog entries, with no entries expanded:
CopyC#
<LinkOne:catalog runat="server"/>
 To initially render the top level of catalog entries, with each top level entry expanded:
CopyC#
<LinkOne:catalog rootdepth="1" runat="server"/>
 To initially render the entire catalog:
CopyC#
<LinkOne:catalog rootdepth="all" runat="server"/>

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI.WebControls..::.WebControl
Mincom.LinkOne.WebView.WebServer.Html..::.Catalog

See Also

Catalog Members
Mincom.LinkOne.WebView.WebServer.Html Namespace


Catalog Members

[image] [image]

LinkOne WebView API
Catalog Members
Catalog Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The Catalog type exposes the following members.

Constructors

Name | Description
Catalog | Initializes a new instance of the Catalog class

Methods

Name | Description
AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
CanAccessBook |
CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBookListForCatalogPaths | Get the absolute list of books for a list of catalog paths in one of the following formats: *\* PublisherCode\* PublisherCode\CategoryCode\CategoryCode\* PublisherCode\BookCode
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTagForBook | Get the tag for the publisher and categories that contain the specified book
GetType | Gets the type of the current instance. (Inherited from Object.)
LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
Render | Renders the control to the specified HTML writer. (Inherited from WebControl.)
RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
SaveViewState | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)

Properties

Name | Description
AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
AllowMultiSelect | Gets or sets the state of multi-select functionality which renders checkboxes adjacent to each node.
AllowSelectAll | Gets or sets whether the All Books checkbox is displayed.
Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
BookImageUrl | Gets or sets the book image URL.
BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
Expand | The identifier of the node to expand.
FolderClosedImageUrl | Gets or sets the folder closed image URL.
FolderOpenImageUrl | Gets or sets the folder open image URL.
FolderOpeningImageUrl | Gets or sets the folder opening image URL.
Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
HideCategoryCheckBoxes | Gets or sets the state of category-select functionality which renders checkboxes adjacent to each category. If AllowMultiSelect is false then this setting has no effect.
IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
RootDepth | The depth of nodes expanded off the root node when initially rendered.
ShowHiddenBooks | Gets or sets whether to show hidden books or not.
SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
SpecifiedRole | The Username to determine the Principal; if not supplied then the SecurityService.Current.Principal will be used.
SpecifiedUser | The Username to determine the Principal; if not supplied then the SecurityService.Current.Principal will be used.
Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
SupportsDisabledAttribute | (Inherited from WebControl.)
TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)

Explicit Interface Implementations

Name | Description
IAttributeAccessor..::.GetAttribute | Gets an attribute of the Web control with the specified name. (Inherited from WebControl.)
IAttributeAccessor..::.SetAttribute | Sets an attribute of the Web control to the specified name and value. (Inherited from WebControl.)

See Also

Catalog Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


Catalog Constructor

[image]

LinkOne WebView API
Catalog Constructor
Catalog Class See Also Send Feedback
Initializes a new instance of the Catalog class

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Catalog()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Catalog()

See Also

Catalog Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


Catalog Methods

[image] [image]

LinkOne WebView API
Catalog Methods
Catalog Class See Also Send Feedback

The Catalog type exposes the following members.

Methods

Name | Description
AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
CanAccessBook |
CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBookListForCatalogPaths | Get the absolute list of books for a list of catalog paths in one of the following formats: *\* PublisherCode\* PublisherCode\CategoryCode\CategoryCode\* PublisherCode\BookCode
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTagForBook | Get the tag for the publisher and categories that contain the specified book
GetType | Gets the type of the current instance. (Inherited from Object.)
LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
Render | Renders the control to the specified HTML writer. (Inherited from WebControl.)
RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
SaveViewState | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)

Explicit Interface Implementations

Name | Description
IAttributeAccessor..::.GetAttribute | Gets an attribute of the Web control with the specified name. (Inherited from WebControl.)
IAttributeAccessor..::.SetAttribute | Sets an attribute of the Web control to the specified name and value. (Inherited from WebControl.)

See Also

Catalog Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


CanAccessBook Method

[image]

LinkOne WebView API
Catalog..::.CanAccessBook Method
Catalog Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public static bool CanAccessBook(
    string code,
    string userOrRoleId,
    string publisherCode,
    string bookCode,
    IList<string> categories
)
Visual Basic (Declaration)
Public Shared Function CanAccessBook ( _
    code As String, _
    userOrRoleId As String, _
    publisherCode As String, _
    bookCode As String, _
    categories As IList(Of String) _
) As Boolean
Visual C++
public:
static bool CanAccessBook(
    String^ code,
    String^ userOrRoleId,
    String^ publisherCode,
    String^ bookCode,
    IList<String^>^ categories
)

Parameters

code
Type: System..::.String
userOrRoleId
Type: System..::.String
publisherCode
Type: System..::.String
bookCode
Type: System..::.String
categories
Type: System.Collections.Generic..::.IList<(Of <(String>)>)

See Also

Catalog Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


GetBookListForCatalogPaths Method

[image]

LinkOne WebView API
Catalog..::.GetBookListForCatalogPaths Method
Catalog Class See Also Send Feedback
Get the absolute list of books for a list of catalog paths in one of the following formats: *\* PublisherCode\* PublisherCode\CategoryCode\CategoryCode\* PublisherCode\BookCode

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public static List<KeyValuePair<string, string>> GetBookListForCatalogPaths(
    params string[] catalogPaths
)
Visual Basic (Declaration)
Public Shared Function GetBookListForCatalogPaths ( _
    ParamArray catalogPaths As String() _
) As List(Of KeyValuePair(Of String, String))
Visual C++
public:
static List<KeyValuePair<String^, String^>>^ GetBookListForCatalogPaths(
    ... array<String^>^ catalogPaths
)

Parameters

catalogPaths
Type: array< System..::.String >[]()[]
the catalog paths to construct the book list from

Return Value

a list of KeyValuePairs where the key is the publisher code and the value is the book code

See Also

Catalog Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


GetTagForBook Method

[image]

LinkOne WebView API
Catalog..::.GetTagForBook Method
Catalog Class See Also Send Feedback
Get the tag for the publisher and categories that contain the specified book

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string GetTagForBook(
    string publisherCode,
    string bookCode
)
Visual Basic (Declaration)
Public Function GetTagForBook ( _
    publisherCode As String, _
    bookCode As String _
) As String
Visual C++
public:
String^ GetTagForBook(
    String^ publisherCode,
    String^ bookCode
)

Parameters

publisherCode
Type: System..::.String
the publisher code
bookCode
Type: System..::.String
the book code

Return Value

the tag for the book

See Also

Catalog Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


Catalog Properties

[image] [image]

LinkOne WebView API
Catalog Properties
Catalog Class See Also Send Feedback

The Catalog type exposes the following members.

Properties

Name | Description
AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
AllowMultiSelect | Gets or sets the state of multi-select functionality which renders checkboxes adjacent to each node.
AllowSelectAll | Gets or sets whether the All Books checkbox is displayed.
Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
BookImageUrl | Gets or sets the book image URL.
BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
Expand | The identifier of the node to expand.
FolderClosedImageUrl | Gets or sets the folder closed image URL.
FolderOpenImageUrl | Gets or sets the folder open image URL.
FolderOpeningImageUrl | Gets or sets the folder opening image URL.
Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
HideCategoryCheckBoxes | Gets or sets the state of category-select functionality which renders checkboxes adjacent to each category. If AllowMultiSelect is false then this setting has no effect.
IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
RootDepth | The depth of nodes expanded off the root node when initially rendered.
ShowHiddenBooks | Gets or sets whether to show hidden books or not.
SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
SpecifiedRole | The Username to determine the Principal; if not supplied then the SecurityService.Current.Principal will be used.
SpecifiedUser | The Username to determine the Principal; if not supplied then the SecurityService.Current.Principal will be used.
Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
SupportsDisabledAttribute | (Inherited from WebControl.)
TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)

See Also

Catalog Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


AllowMultiSelect Property

[image]

LinkOne WebView API
Catalog..::.AllowMultiSelect Property
Catalog Class See Also Send Feedback
Gets or sets the state of multi-select functionality which renders checkboxes adjacent to each node.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool AllowMultiSelect { get; set; }
Visual Basic (Declaration)
Public Property AllowMultiSelect As Boolean
Visual C++
public:
property bool AllowMultiSelect {
    bool get ();
    void set (bool value);
}

See Also

Catalog Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


AllowSelectAll Property

[image]

LinkOne WebView API
Catalog..::.AllowSelectAll Property
Catalog Class See Also Send Feedback
Gets or sets whether the All Books checkbox is displayed.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool AllowSelectAll { get; set; }
Visual Basic (Declaration)
Public Property AllowSelectAll As Boolean
Visual C++
public:
property bool AllowSelectAll {
    bool get ();
    void set (bool value);
}

See Also

Catalog Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


BookImageUrl Property

[image]

LinkOne WebView API
Catalog..::.BookImageUrl Property
Catalog Class See Also Send Feedback
Gets or sets the book image URL.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string BookImageUrl { get; set; }
Visual Basic (Declaration)
Public Property BookImageUrl As String
Visual C++
public:
property String^ BookImageUrl {
    String^ get ();
    void set (String^ value);
}

See Also

Catalog Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


Expand Property

[image]

LinkOne WebView API
Catalog..::.Expand Property
Catalog Class See Also Send Feedback
The identifier of the node to expand.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Expand { get; set; }
Visual Basic (Declaration)
Public Property Expand As String
Visual C++
public:
property String^ Expand {
    String^ get ();
    void set (String^ value);
}

Remarks

The expand value is looked for in the incoming request URL by the argument "expand=?". Where ? is the identifier of the entry to expand. The value can be set programmatically only if it is not specified in the URL.

See Also

Catalog Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


FolderClosedImageUrl Property

[image]

LinkOne WebView API
Catalog..::.FolderClosedImageUrl Property
Catalog Class See Also Send Feedback
Gets or sets the folder closed image URL.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string FolderClosedImageUrl { get; set; }
Visual Basic (Declaration)
Public Property FolderClosedImageUrl As String
Visual C++
public:
property String^ FolderClosedImageUrl {
    String^ get ();
    void set (String^ value);
}

See Also

Catalog Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


FolderOpenImageUrl Property

[image]

LinkOne WebView API
Catalog..::.FolderOpenImageUrl Property
Catalog Class See Also Send Feedback
Gets or sets the folder open image URL.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string FolderOpenImageUrl { get; set; }
Visual Basic (Declaration)
Public Property FolderOpenImageUrl As String
Visual C++
public:
property String^ FolderOpenImageUrl {
    String^ get ();
    void set (String^ value);
}

See Also

Catalog Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


FolderOpeningImageUrl Property

[image]

LinkOne WebView API
Catalog..::.FolderOpeningImageUrl Property
Catalog Class See Also Send Feedback
Gets or sets the folder opening image URL.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string FolderOpeningImageUrl { get; set; }
Visual Basic (Declaration)
Public Property FolderOpeningImageUrl As String
Visual C++
public:
property String^ FolderOpeningImageUrl {
    String^ get ();
    void set (String^ value);
}

See Also

Catalog Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


HideCategoryCheckBoxes Property

[image]

LinkOne WebView API
Catalog..::.HideCategoryCheckBoxes Property
Catalog Class See Also Send Feedback
Gets or sets the state of category-select functionality which renders checkboxes adjacent to each category. If AllowMultiSelect is false then this setting has no effect.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool HideCategoryCheckBoxes { get; set; }
Visual Basic (Declaration)
Public Property HideCategoryCheckBoxes As Boolean
Visual C++
public:
property bool HideCategoryCheckBoxes {
    bool get ();
    void set (bool value);
}

See Also

Catalog Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


RootDepth Property

[image]

LinkOne WebView API
Catalog..::.RootDepth Property
Catalog Class See Also Send Feedback
The depth of nodes expanded off the root node when initially rendered.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string RootDepth { get; set; }
Visual Basic (Declaration)
Public Property RootDepth As String
Visual C++
public:
property String^ RootDepth {
    String^ get ();
    void set (String^ value);
}

Remarks

This is either the word "all" or a negative integer to expand all publishers and categories, or a positive integer to indicate the depth of the tree expanded. Setting no value or using zero will show no root nodes expanded.

See Also

Catalog Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


ShowHiddenBooks Property

[image]

LinkOne WebView API
Catalog..::.ShowHiddenBooks Property
Catalog Class See Also Send Feedback
Gets or sets whether to show hidden books or not.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool ShowHiddenBooks { get; set; }
Visual Basic (Declaration)
Public Property ShowHiddenBooks As Boolean
Visual C++
public:
property bool ShowHiddenBooks {
    bool get ();
    void set (bool value);
}

See Also

Catalog Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


SpecifiedRole Property

[image]

LinkOne WebView API
Catalog..::.SpecifiedRole Property
Catalog Class See Also Send Feedback
The Username to determine the Principal; if not supplied then the SecurityService.Current.Principal will be used.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string SpecifiedRole { get; set; }
Visual Basic (Declaration)
Public Property SpecifiedRole As String
Visual C++
public:
property String^ SpecifiedRole {
    String^ get ();
    void set (String^ value);
}

See Also

Catalog Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


SpecifiedUser Property

[image]

LinkOne WebView API
Catalog..::.SpecifiedUser Property
Catalog Class See Also Send Feedback
The Username to determine the Principal; if not supplied then the SecurityService.Current.Principal will be used.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string SpecifiedUser { get; set; }
Visual Basic (Declaration)
Public Property SpecifiedUser As String
Visual C++
public:
property String^ SpecifiedUser {
    String^ get ();
    void set (String^ value);
}

See Also

Catalog Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


Parts Class

[image]

LinkOne WebView API
Parts Class
Members Example See Also Send Feedback
Renders the parts content when there are parts for the current page.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public sealed class Parts : WebControl
Visual Basic (Declaration)
Public NotInheritable Class Parts _
    Inherits WebControl
Visual C++
public ref class Parts sealed : public WebControl

Remarks

The current page is determined by the arguments book=? and page=? in the requesting URL.

This tag may optionally enclose HTML within sub-tags that alter the rendered HTML. These tags are:
Sub Tag | Purpose | Default
Empty | The HTML when a page is specified, but there are no parts in the page. | blank
Selection | The HTML to render for the selection list icon. | A checkbox

Examples

Example of standard usage:
CopyC#
<LinkOne:parts runat="server">
    <empty>No Parts</empty>
</LinkOne:parts>
 Example of usage with customised selection HTML
CopyC#
<LinkOne:parts runat="server">
    <selection>
        <img src="images/buy.gif" onclick="doSelectionsAdd(this)" style="cursor:hand" alt="Add to selection list"/>
    </selection>
</LinkOne:parts>

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI.WebControls..::.WebControl
Mincom.LinkOne.WebView.WebServer.Html..::.Parts

See Also

Parts Members
Mincom.LinkOne.WebView.WebServer.Html Namespace


Parts Members

[image] [image]

LinkOne WebView API
Parts Members
Parts Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The Parts type exposes the following members.

Constructors

Name | Description
Parts | Initializes a new instance of the Parts class

Methods

Name | Description
AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
Render | Renders the control to the specified HTML writer. (Inherited from WebControl.)
RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
SaveViewState | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)

Properties

Name | Description
AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
BookExpiredMessageText | Gets or sets the book expired message text.
BookExpiredWarningMessageText | Gets or sets the book expired warning message text.
BookReviewExpiryMessageText | Gets or sets the review expiry message text.
BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
DraftBookMessageText | Gets or sets the draft book message text.
Empty | Gets/sets the HTML when a page is specified, but there are no parts in the page.
Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
Selection | Gets/sets the HTML to render for the basket selection column. The default HTML renders a checkbox.
SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
SupportsDisabledAttribute | (Inherited from WebControl.)
TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)

Explicit Interface Implementations

Name | Description
IAttributeAccessor..::.GetAttribute | Gets an attribute of the Web control with the specified name. (Inherited from WebControl.)
IAttributeAccessor..::.SetAttribute | Sets an attribute of the Web control to the specified name and value. (Inherited from WebControl.)

See Also

Parts Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


Parts Constructor

[image]

LinkOne WebView API
Parts Constructor
Parts Class See Also Send Feedback
Initializes a new instance of the Parts class

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Parts()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Parts()

See Also

Parts Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


Parts Methods

[image] [image]

LinkOne WebView API
Parts Methods
Parts Class See Also Send Feedback

The Parts type exposes the following members.

Methods

Name | Description
AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
Render | Renders the control to the specified HTML writer. (Inherited from WebControl.)
RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
SaveViewState | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)

Explicit Interface Implementations

Name | Description
IAttributeAccessor..::.GetAttribute | Gets an attribute of the Web control with the specified name. (Inherited from WebControl.)
IAttributeAccessor..::.SetAttribute | Sets an attribute of the Web control to the specified name and value. (Inherited from WebControl.)

See Also

Parts Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


Parts Properties

[image] [image]

LinkOne WebView API
Parts Properties
Parts Class See Also Send Feedback

The Parts type exposes the following members.

Properties

Name | Description
AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
BookExpiredMessageText | Gets or sets the book expired message text.
BookExpiredWarningMessageText | Gets or sets the book expired warning message text.
BookReviewExpiryMessageText | Gets or sets the review expiry message text.
BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
DraftBookMessageText | Gets or sets the draft book message text.
Empty | Gets/sets the HTML when a page is specified, but there are no parts in the page.
Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
Selection | Gets/sets the HTML to render for the basket selection column. The default HTML renders a checkbox.
SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
SupportsDisabledAttribute | (Inherited from WebControl.)
TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)

See Also

Parts Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


BookExpiredMessageText Property

[image]

LinkOne WebView API
Parts..::.BookExpiredMessageText Property
Parts Class See Also Send Feedback
Gets or sets the book expired message text.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string BookExpiredMessageText { get; set; }
Visual Basic (Declaration)
Public Property BookExpiredMessageText As String
Visual C++
public:
property String^ BookExpiredMessageText {
    String^ get ();
    void set (String^ value);
}

Field Value

The book expired message text.

See Also

Parts Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


BookExpiredWarningMessageText Property

[image]

LinkOne WebView API
Parts..::.BookExpiredWarningMessageText Property
Parts Class See Also Send Feedback
Gets or sets the book expired warning message text.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string BookExpiredWarningMessageText { get; set; }
Visual Basic (Declaration)
Public Property BookExpiredWarningMessageText As String
Visual C++
public:
property String^ BookExpiredWarningMessageText {
    String^ get ();
    void set (String^ value);
}

Field Value

The book expired warning message text.

See Also

Parts Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


BookReviewExpiryMessageText Property

[image]

LinkOne WebView API
Parts..::.BookReviewExpiryMessageText Property
Parts Class See Also Send Feedback
Gets or sets the review expiry message text.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string BookReviewExpiryMessageText { get; set; }
Visual Basic (Declaration)
Public Property BookReviewExpiryMessageText As String
Visual C++
public:
property String^ BookReviewExpiryMessageText {
    String^ get ();
    void set (String^ value);
}

Field Value

The review expiry message text.

See Also

Parts Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


DraftBookMessageText Property

[image]

LinkOne WebView API
Parts..::.DraftBookMessageText Property
Parts Class See Also Send Feedback
Gets or sets the draft book message text.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string DraftBookMessageText { get; set; }
Visual Basic (Declaration)
Public Property DraftBookMessageText As String
Visual C++
public:
property String^ DraftBookMessageText {
    String^ get ();
    void set (String^ value);
}

Field Value

The draft book message text.

See Also

Parts Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


Empty Property

[image]

LinkOne WebView API
Parts..::.Empty Property
Parts Class See Also Send Feedback
Gets/sets the HTML when a page is specified, but there are no parts in the page.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Control Empty { get; set; }
Visual Basic (Declaration)
Public Property Empty As Control
Visual C++
public:
property Control^ Empty {
    Control^ get ();
    void set (Control^ value);
}

See Also

Parts Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


Selection Property

[image]

LinkOne WebView API
Parts..::.Selection Property
Parts Class See Also Send Feedback
Gets/sets the HTML to render for the basket selection column. The default HTML renders a checkbox.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Control Selection { get; set; }
Visual Basic (Declaration)
Public Property Selection As Control
Visual C++
public:
property Control^ Selection {
    Control^ get ();
    void set (Control^ value);
}

See Also

Parts Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


Toc Class

[image]

LinkOne WebView API
Toc Class
Members Example See Also Send Feedback
Renders the table of contents for the current book.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public sealed class Toc : WebControl
Visual Basic (Declaration)
Public NotInheritable Class Toc _
    Inherits WebControl
Visual C++
public ref class Toc sealed : public WebControl

Remarks

This tag can render an entire table of contents tree, or just an entry.

Rendering can occur for the top level entries, and then the tag can be called as needed to render sub entries as the user expands any entry.

Rendering sub entries requires the argument expand=? in the requesting URL, where ? is the identifier of the entry to expand.

Rendering the top level entries occurs when no expand=? is present.

The current book is determined by the argument book=? in the requesting URL.

Examples

Example of standard usage:
CopyC#
<LinkOne:toc runat="server">

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI.WebControls..::.WebControl
Mincom.LinkOne.WebView.WebServer.Html..::.Toc

See Also

Toc Members
Mincom.LinkOne.WebView.WebServer.Html Namespace


Toc Members

[image] [image]

LinkOne WebView API
Toc Members
Toc Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The Toc type exposes the following members.

Constructors

Name | Description
Toc | Initializes a new instance of the Toc class

Methods

Name | Description
AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
Render | Renders the control to the specified HTML writer. (Inherited from WebControl.)
RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
SaveViewState | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)

Properties

Name | Description
AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
BrokenImageUrl | Gets or sets the broken image URL.
CircularImageUrl | Gets or sets the circular image URL.
CollapseImageUrl | Gets or sets the collapse image URL.
ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
Expand | The identifier of the node to expand.
ExpandImageUrl | Gets or sets the expand image URL.
ExpandingImageUrl | Gets or sets the expanding image URL.
Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
PageColumnHeaderText | Gets or sets the page column header text.
PageImageUrl | Gets or sets the page image URL.
PageShadowImageUrl | Gets or sets the page shadow image URL.
ReferenceColumnHeaderText | Gets or sets the reference column header text.
SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
SpacerImageUrl | Gets or sets the spacer image URL.
Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
SupportsDisabledAttribute | (Inherited from WebControl.)
TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
TitleColumnHeaderText | Gets or sets the title column header text.
ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)

Explicit Interface Implementations

Name | Description
IAttributeAccessor..::.GetAttribute | Gets an attribute of the Web control with the specified name. (Inherited from WebControl.)
IAttributeAccessor..::.SetAttribute | Sets an attribute of the Web control to the specified name and value. (Inherited from WebControl.)

See Also

Toc Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


Toc Constructor

[image]

LinkOne WebView API
Toc Constructor
Toc Class See Also Send Feedback
Initializes a new instance of the Toc class

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Toc()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Toc()

See Also

Toc Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


Toc Methods

[image] [image]

LinkOne WebView API
Toc Methods
Toc Class See Also Send Feedback

The Toc type exposes the following members.

Methods

Name | Description
AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
Render | Renders the control to the specified HTML writer. (Inherited from WebControl.)
RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
SaveViewState | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)

Explicit Interface Implementations

Name | Description
IAttributeAccessor..::.GetAttribute | Gets an attribute of the Web control with the specified name. (Inherited from WebControl.)
IAttributeAccessor..::.SetAttribute | Sets an attribute of the Web control to the specified name and value. (Inherited from WebControl.)

See Also

Toc Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


Toc Properties

[image] [image]

LinkOne WebView API
Toc Properties
Toc Class See Also Send Feedback

The Toc type exposes the following members.

Properties

Name | Description
AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
BrokenImageUrl | Gets or sets the broken image URL.
CircularImageUrl | Gets or sets the circular image URL.
CollapseImageUrl | Gets or sets the collapse image URL.
ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
Expand | The identifier of the node to expand.
ExpandImageUrl | Gets or sets the expand image URL.
ExpandingImageUrl | Gets or sets the expanding image URL.
Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
PageColumnHeaderText | Gets or sets the page column header text.
PageImageUrl | Gets or sets the page image URL.
PageShadowImageUrl | Gets or sets the page shadow image URL.
ReferenceColumnHeaderText | Gets or sets the reference column header text.
SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
SpacerImageUrl | Gets or sets the spacer image URL.
Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
SupportsDisabledAttribute | (Inherited from WebControl.)
TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
TitleColumnHeaderText | Gets or sets the title column header text.
ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)

See Also

Toc Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


BrokenImageUrl Property

[image]

LinkOne WebView API
Toc..::.BrokenImageUrl Property
Toc Class See Also Send Feedback
Gets or sets the broken image URL.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string BrokenImageUrl { get; set; }
Visual Basic (Declaration)
Public Property BrokenImageUrl As String
Visual C++
public:
property String^ BrokenImageUrl {
    String^ get ();
    void set (String^ value);
}

See Also

Toc Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


CircularImageUrl Property

[image]

LinkOne WebView API
Toc..::.CircularImageUrl Property
Toc Class See Also Send Feedback
Gets or sets the circular image URL.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string CircularImageUrl { get; set; }
Visual Basic (Declaration)
Public Property CircularImageUrl As String
Visual C++
public:
property String^ CircularImageUrl {
    String^ get ();
    void set (String^ value);
}

See Also

Toc Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


CollapseImageUrl Property

[image]

LinkOne WebView API
Toc..::.CollapseImageUrl Property
Toc Class See Also Send Feedback
Gets or sets the collapse image URL.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string CollapseImageUrl { get; set; }
Visual Basic (Declaration)
Public Property CollapseImageUrl As String
Visual C++
public:
property String^ CollapseImageUrl {
    String^ get ();
    void set (String^ value);
}

See Also

Toc Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


Expand Property

[image]

LinkOne WebView API
Toc..::.Expand Property
Toc Class See Also Send Feedback
The identifier of the node to expand.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Expand { get; set; }
Visual Basic (Declaration)
Public Property Expand As String
Visual C++
public:
property String^ Expand {
    String^ get ();
    void set (String^ value);
}

Remarks

The expand value is looked for in the incoming request URL by the argument "expand=?". Where ? is the identifier of the entry to expand. The value can be set programmatically only if it is not specified in the URL.

See Also

Toc Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


ExpandImageUrl Property

[image]

LinkOne WebView API
Toc..::.ExpandImageUrl Property
Toc Class See Also Send Feedback
Gets or sets the expand image URL.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string ExpandImageUrl { get; set; }
Visual Basic (Declaration)
Public Property ExpandImageUrl As String
Visual C++
public:
property String^ ExpandImageUrl {
    String^ get ();
    void set (String^ value);
}

See Also

Toc Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


ExpandingImageUrl Property

[image]

LinkOne WebView API
Toc..::.ExpandingImageUrl Property
Toc Class See Also Send Feedback
Gets or sets the expanding image URL.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string ExpandingImageUrl { get; set; }
Visual Basic (Declaration)
Public Property ExpandingImageUrl As String
Visual C++
public:
property String^ ExpandingImageUrl {
    String^ get ();
    void set (String^ value);
}

See Also

Toc Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


PageColumnHeaderText Property

[image]

LinkOne WebView API
Toc..::.PageColumnHeaderText Property
Toc Class See Also Send Feedback
Gets or sets the page column header text.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PageColumnHeaderText { get; set; }
Visual Basic (Declaration)
Public Property PageColumnHeaderText As String
Visual C++
public:
property String^ PageColumnHeaderText {
    String^ get ();
    void set (String^ value);
}

Field Value

The page column header text.

See Also

Toc Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


PageImageUrl Property

[image]

LinkOne WebView API
Toc..::.PageImageUrl Property
Toc Class See Also Send Feedback
Gets or sets the page image URL.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PageImageUrl { get; set; }
Visual Basic (Declaration)
Public Property PageImageUrl As String
Visual C++
public:
property String^ PageImageUrl {
    String^ get ();
    void set (String^ value);
}

See Also

Toc Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


PageShadowImageUrl Property

[image]

LinkOne WebView API
Toc..::.PageShadowImageUrl Property
Toc Class See Also Send Feedback
Gets or sets the page shadow image URL.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PageShadowImageUrl { get; set; }
Visual Basic (Declaration)
Public Property PageShadowImageUrl As String
Visual C++
public:
property String^ PageShadowImageUrl {
    String^ get ();
    void set (String^ value);
}

See Also

Toc Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


ReferenceColumnHeaderText Property

[image]

LinkOne WebView API
Toc..::.ReferenceColumnHeaderText Property
Toc Class See Also Send Feedback
Gets or sets the reference column header text.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string ReferenceColumnHeaderText { get; set; }
Visual Basic (Declaration)
Public Property ReferenceColumnHeaderText As String
Visual C++
public:
property String^ ReferenceColumnHeaderText {
    String^ get ();
    void set (String^ value);
}

Field Value

The reference column header text.

See Also

Toc Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


SpacerImageUrl Property

[image]

LinkOne WebView API
Toc..::.SpacerImageUrl Property
Toc Class See Also Send Feedback
Gets or sets the spacer image URL.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string SpacerImageUrl { get; set; }
Visual Basic (Declaration)
Public Property SpacerImageUrl As String
Visual C++
public:
property String^ SpacerImageUrl {
    String^ get ();
    void set (String^ value);
}

See Also

Toc Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


TitleColumnHeaderText Property

[image]

LinkOne WebView API
Toc..::.TitleColumnHeaderText Property
Toc Class See Also Send Feedback
Gets or sets the title column header text.

Namespace: Mincom.LinkOne.WebView.WebServer.Html
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string TitleColumnHeaderText { get; set; }
Visual Basic (Declaration)
Public Property TitleColumnHeaderText As String
Visual C++
public:
property String^ TitleColumnHeaderText {
    String^ get ();
    void set (String^ value);
}

Field Value

The title column header text.

See Also

Toc Class
Mincom.LinkOne.WebView.WebServer.Html Namespace


Mincom.LinkOne.WebView.WebServer.Modules Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.WebView.WebServer.Modules Namespace
Send Feedback

Classes

Class | Description
BasicAuthenticationModule | Supports basic Http authentication for specific pages in the web site.
TimingModule | This debug module provided timing information for all incoming requests.


BasicAuthenticationModule Class

[image]

LinkOne WebView API
BasicAuthenticationModule Class
Members See Also Send Feedback
Supports basic Http authentication for specific pages in the web site.

Namespace: Mincom.LinkOne.WebView.WebServer.Modules
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class BasicAuthenticationModule : IHttpModule
Visual Basic (Declaration)
Public Class BasicAuthenticationModule _
    Implements IHttpModule
Visual C++
public ref class BasicAuthenticationModule : IHttpModule

Remarks

Pages supporting basic Http authentication are specified in the web.config file, using the <appSettings> section. The following key is expected in this section:

CopyC#
<add key="basicAuthenticationPages" value="[page1],[page2],...[pageN]" />

Pages are specified using application relative paths. For example, the following section enables basic Http authorisation for the Picture.aspx and Toc.aspx pages:

CopyC#
<add key="basicAuthenticationPages" value="~/Viewer/Picture.aspx,~/Viewer/Toc.aspx" />

Page references are case insenstive.

This module was added primarily in order to support Ellipse fetching pictures using the Picture.aspx page.

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.Modules..::.BasicAuthenticationModule

See Also

BasicAuthenticationModule Members
Mincom.LinkOne.WebView.WebServer.Modules Namespace


BasicAuthenticationModule Members

[image] [image]

LinkOne WebView API
BasicAuthenticationModule Members
BasicAuthenticationModule Class Constructors Methods See Also Send Feedback

The BasicAuthenticationModule type exposes the following members.

Constructors

Name | Description
BasicAuthenticationModule | Initializes a new instance of the BasicAuthenticationModule class

Methods

Name | Description
AuthenticateRequest | Performs authentication for the current request validating the given user name and password. The current request is authenticated if the user name and password are valid.
Dispose | From IHttpModule. Empty.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
Init | Initialises the module, reading the allowed list of pages.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BasicAuthenticationModule Class
Mincom.LinkOne.WebView.WebServer.Modules Namespace


BasicAuthenticationModule Constructor

[image]

LinkOne WebView API
BasicAuthenticationModule Constructor
BasicAuthenticationModule Class See Also Send Feedback
Initializes a new instance of the BasicAuthenticationModule class

Namespace: Mincom.LinkOne.WebView.WebServer.Modules
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public BasicAuthenticationModule()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BasicAuthenticationModule()

See Also

BasicAuthenticationModule Class
Mincom.LinkOne.WebView.WebServer.Modules Namespace


BasicAuthenticationModule Methods

[image] [image]

LinkOne WebView API
BasicAuthenticationModule Methods
BasicAuthenticationModule Class See Also Send Feedback

The BasicAuthenticationModule type exposes the following members.

Methods

Name | Description
AuthenticateRequest | Performs authentication for the current request validating the given user name and password. The current request is authenticated if the user name and password are valid.
Dispose | From IHttpModule. Empty.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
Init | Initialises the module, reading the allowed list of pages.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BasicAuthenticationModule Class
Mincom.LinkOne.WebView.WebServer.Modules Namespace


AuthenticateRequest Method

[image]

LinkOne WebView API
BasicAuthenticationModule..::.AuthenticateRequest Method
BasicAuthenticationModule Class See Also Send Feedback
Performs authentication for the current request validating the given user name and password. The current request is authenticated if the user name and password are valid.

Namespace: Mincom.LinkOne.WebView.WebServer.Modules
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
protected static void AuthenticateRequest(
    HttpContext context,
    string userName,
    string password
)
Visual Basic (Declaration)
Protected Shared Sub AuthenticateRequest ( _
    context As HttpContext, _
    userName As String, _
    password As String _
)
Visual C++
protected:
static void AuthenticateRequest(
    HttpContext^ context,
    String^ userName,
    String^ password
)

Parameters

context
Type: System.Web..::.HttpContext
Current HttpContext to authenticate the request for.
userName
Type: System..::.String
password
Type: System..::.String
The password specified in the request.

See Also

BasicAuthenticationModule Class
Mincom.LinkOne.WebView.WebServer.Modules Namespace


Dispose Method

[image]

LinkOne WebView API
BasicAuthenticationModule..::.Dispose Method
BasicAuthenticationModule Class See Also Send Feedback
From IHttpModule. Empty.

Namespace: Mincom.LinkOne.WebView.WebServer.Modules
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IHttpModule..::.Dispose()()()

See Also

BasicAuthenticationModule Class
Mincom.LinkOne.WebView.WebServer.Modules Namespace


Init Method

[image]

LinkOne WebView API
BasicAuthenticationModule..::.Init Method
BasicAuthenticationModule Class See Also Send Feedback
Initialises the module, reading the allowed list of pages.

Namespace: Mincom.LinkOne.WebView.WebServer.Modules
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void Init(
    HttpApplication context
)
Visual Basic (Declaration)
Public Sub Init ( _
    context As HttpApplication _
)
Visual C++
public:
virtual void Init(
    HttpApplication^ context
) sealed

Parameters

context
Type: System.Web..::.HttpApplication
Http application reference.

Implements

IHttpModule..::.Init(HttpApplication)

See Also

BasicAuthenticationModule Class
Mincom.LinkOne.WebView.WebServer.Modules Namespace


TimingModule Class

[image]

LinkOne WebView API
TimingModule Class
Members See Also Send Feedback
This debug module provided timing information for all incoming requests.

Namespace: Mincom.LinkOne.WebView.WebServer.Modules
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class TimingModule : IHttpModule
Visual Basic (Declaration)
Public Class TimingModule _
    Implements IHttpModule
Visual C++
public ref class TimingModule : IHttpModule

Remarks

This module observes all HttpApplication events, and logs the following information:

<eventName> <url> <requestTime> <msSinceLastRequest>

Logging is performed using System.Diagnostis.Debug or Trace in non-debug builds.

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.Modules..::.TimingModule

See Also

TimingModule Members
Mincom.LinkOne.WebView.WebServer.Modules Namespace


TimingModule Members

[image] [image]

LinkOne WebView API
TimingModule Members
TimingModule Class Constructors Methods See Also Send Feedback

The TimingModule type exposes the following members.

Constructors

Name | Description
TimingModule | Initializes a new instance of the TimingModule class

Methods

Name | Description
Dispose | From IHttpModule. Empty.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
Init | Adds overservation of all HttpApplication events.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TimingModule Class
Mincom.LinkOne.WebView.WebServer.Modules Namespace


TimingModule Constructor

[image]

LinkOne WebView API
TimingModule Constructor
TimingModule Class See Also Send Feedback
Initializes a new instance of the TimingModule class

Namespace: Mincom.LinkOne.WebView.WebServer.Modules
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public TimingModule()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TimingModule()

See Also

TimingModule Class
Mincom.LinkOne.WebView.WebServer.Modules Namespace


TimingModule Methods

[image] [image]

LinkOne WebView API
TimingModule Methods
TimingModule Class See Also Send Feedback

The TimingModule type exposes the following members.

Methods

Name | Description
Dispose | From IHttpModule. Empty.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
Init | Adds overservation of all HttpApplication events.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TimingModule Class
Mincom.LinkOne.WebView.WebServer.Modules Namespace


Dispose Method

[image]

LinkOne WebView API
TimingModule..::.Dispose Method
TimingModule Class See Also Send Feedback
From IHttpModule. Empty.

Namespace: Mincom.LinkOne.WebView.WebServer.Modules
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IHttpModule..::.Dispose()()()

See Also

TimingModule Class
Mincom.LinkOne.WebView.WebServer.Modules Namespace


Init Method

[image]

LinkOne WebView API
TimingModule..::.Init Method
TimingModule Class See Also Send Feedback
Adds overservation of all HttpApplication events.

Namespace: Mincom.LinkOne.WebView.WebServer.Modules
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void Init(
    HttpApplication context
)
Visual Basic (Declaration)
Public Sub Init ( _
    context As HttpApplication _
)
Visual C++
public:
virtual void Init(
    HttpApplication^ context
) sealed

Parameters

context
Type: System.Web..::.HttpApplication

Implements

IHttpModule..::.Init(HttpApplication)

See Also

TimingModule Class
Mincom.LinkOne.WebView.WebServer.Modules Namespace


Mincom.LinkOne.WebView.WebServer.Notifications Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.WebView.WebServer.Notifications Namespace
Send Feedback

Classes

Class | Description
EmailNotification | Notification class for Emails
NotifySubsBook | Represents the codes describing a collection of subscriptions for books.
NotifySubsBookCollection | Represents a collection of NotifySubsBook objects.


EmailNotification Class

[image]

LinkOne WebView API
EmailNotification Class
Members See Also Send Feedback
Notification class for Emails

Namespace: Mincom.LinkOne.WebView.WebServer.Notifications
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class EmailNotification
Visual Basic (Declaration)
Public Class EmailNotification
Visual C++
public ref class EmailNotification

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.Notifications..::.EmailNotification

See Also

EmailNotification Members
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


EmailNotification Members

[image] [image]

LinkOne WebView API
EmailNotification Members
EmailNotification Class Constructors Methods See Also Send Feedback

The EmailNotification type exposes the following members.

Constructors

Name | Description
EmailNotification | Initializes a new instance of the EmailNotification class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMediumDataForCurrentUser | Retrieves the TO address for the email medium from the storage area.
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SaveMediumDataForCurrentUser | Saves the TO address for the email medium into the storage area.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EmailNotification Class
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


EmailNotification Constructor

[image]

LinkOne WebView API
EmailNotification Constructor
EmailNotification Class See Also Send Feedback
Initializes a new instance of the EmailNotification class

Namespace: Mincom.LinkOne.WebView.WebServer.Notifications
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public EmailNotification(
    string linkOneWebSitePath
)
Visual Basic (Declaration)
Public Sub New ( _
    linkOneWebSitePath As String _
)
Visual C++
public:
EmailNotification(
    String^ linkOneWebSitePath
)

Parameters

linkOneWebSitePath
Type: System..::.String

See Also

EmailNotification Class
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


EmailNotification Methods

[image] [image]

LinkOne WebView API
EmailNotification Methods
EmailNotification Class See Also Send Feedback

The EmailNotification type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMediumDataForCurrentUser | Retrieves the TO address for the email medium from the storage area.
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SaveMediumDataForCurrentUser | Saves the TO address for the email medium into the storage area.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EmailNotification Class
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


GetMediumDataForCurrentUser Method

[image]

LinkOne WebView API
EmailNotification..::.GetMediumDataForCurrentUser Method
EmailNotification Class See Also Send Feedback
Retrieves the TO address for the email medium from the storage area.

Namespace: Mincom.LinkOne.WebView.WebServer.Notifications
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string GetMediumDataForCurrentUser()
Visual Basic (Declaration)
Public Function GetMediumDataForCurrentUser As String
Visual C++
public:
virtual String^ GetMediumDataForCurrentUser() sealed

Return Value

See Also

EmailNotification Class
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


SaveMediumDataForCurrentUser Method

[image]

LinkOne WebView API
EmailNotification..::.SaveMediumDataForCurrentUser Method
EmailNotification Class See Also Send Feedback
Saves the TO address for the email medium into the storage area.

Namespace: Mincom.LinkOne.WebView.WebServer.Notifications
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void SaveMediumDataForCurrentUser(
    string mediumAddress
)
Visual Basic (Declaration)
Public Sub SaveMediumDataForCurrentUser ( _
    mediumAddress As String _
)
Visual C++
public:
virtual void SaveMediumDataForCurrentUser(
    String^ mediumAddress
) sealed

Parameters

mediumAddress
Type: System..::.String

See Also

EmailNotification Class
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


NotifySubsBook Class

[image]

LinkOne WebView API
NotifySubsBook Class
Members See Also Send Feedback
Represents the codes describing a collection of subscriptions for books.

Namespace: Mincom.LinkOne.WebView.WebServer.Notifications
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public sealed class NotifySubsBook
Visual Basic (Declaration)
Public NotInheritable Class NotifySubsBook
Visual C++
public ref class NotifySubsBook sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.Notifications..::.NotifySubsBook

See Also

NotifySubsBook Members
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


NotifySubsBook Members

[image] [image]

LinkOne WebView API
NotifySubsBook Members
NotifySubsBook Class Constructors Methods Properties See Also Send Feedback

The NotifySubsBook type exposes the following members.

Constructors

Name | Description
NotifySubsBook | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPath | Gets the descriptive path of the allowed book
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current NotifySubsBook. (Overrides Object..::.ToString()()().)

Properties

Name | Description
Book | Gets or sets the book.
Publisher | Gets or sets the publisher.

See Also

NotifySubsBook Class
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


NotifySubsBook Constructor

[image] [image]

LinkOne WebView API
NotifySubsBook Constructor
NotifySubsBook Class See Also Send Feedback

Overload List

Name | Description
NotifySubsBook()()() | Initializes a new instance of the NotifySubsBook class.
NotifySubsBook(String, String) | Initializes a new instance of the NotifySubsBook class.

See Also

NotifySubsBook Class
NotifySubsBook Members
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


NotifySubsBook Constructor

[image]

LinkOne WebView API
NotifySubsBook Constructor
NotifySubsBook Class See Also Send Feedback
Initializes a new instance of the NotifySubsBook class.

Namespace: Mincom.LinkOne.WebView.WebServer.Notifications
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public NotifySubsBook()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NotifySubsBook()

See Also

NotifySubsBook Class
NotifySubsBook Overload
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


NotifySubsBook Constructor (String, String)

[image]

LinkOne WebView API
NotifySubsBook Constructor (String, String)
NotifySubsBook Class See Also Send Feedback
Initializes a new instance of the NotifySubsBook class.

Namespace: Mincom.LinkOne.WebView.WebServer.Notifications
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public NotifySubsBook(
    string publisher,
    string book
)
Visual Basic (Declaration)
Public Sub New ( _
    publisher As String, _
    book As String _
)
Visual C++
public:
NotifySubsBook(
    String^ publisher,
    String^ book
)

Parameters

publisher
Type: System..::.String
The publisher code.
book
Type: System..::.String
The book code.

See Also

NotifySubsBook Class
NotifySubsBook Overload
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


NotifySubsBook Methods

[image] [image]

LinkOne WebView API
NotifySubsBook Methods
NotifySubsBook Class See Also Send Feedback

The NotifySubsBook type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPath | Gets the descriptive path of the allowed book
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current NotifySubsBook. (Overrides Object..::.ToString()()().)

See Also

NotifySubsBook Class
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


GetPath Method

[image]

LinkOne WebView API
NotifySubsBook..::.GetPath Method
NotifySubsBook Class See Also Send Feedback
Gets the descriptive path of the allowed book

Namespace: Mincom.LinkOne.WebView.WebServer.Notifications
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string GetPath()
Visual Basic (Declaration)
Public Function GetPath As String
Visual C++
public:
String^ GetPath()

Return Value

The book path.

See Also

NotifySubsBook Class
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


ToString Method

[image]

LinkOne WebView API
NotifySubsBook..::.ToString Method
NotifySubsBook Class See Also Send Feedback
Returns a String that represents the current NotifySubsBook.

Namespace: Mincom.LinkOne.WebView.WebServer.Notifications
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current NotifySubsBook.

See Also

NotifySubsBook Class
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


NotifySubsBook Properties

[image] [image]

LinkOne WebView API
NotifySubsBook Properties
NotifySubsBook Class See Also Send Feedback

The NotifySubsBook type exposes the following members.

Properties

Name | Description
Book | Gets or sets the book.
Publisher | Gets or sets the publisher.

See Also

NotifySubsBook Class
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


Book Property

[image]

LinkOne WebView API
NotifySubsBook..::.Book Property
NotifySubsBook Class See Also Send Feedback
Gets or sets the book.

Namespace: Mincom.LinkOne.WebView.WebServer.Notifications
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Book { get; set; }
Visual Basic (Declaration)
Public Property Book As String
Visual C++
public:
property String^ Book {
    String^ get ();
    void set (String^ value);
}

Remarks

Setting a book code that has any length will clear the category.

See Also

NotifySubsBook Class
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


Publisher Property

[image]

LinkOne WebView API
NotifySubsBook..::.Publisher Property
NotifySubsBook Class See Also Send Feedback
Gets or sets the publisher.

Namespace: Mincom.LinkOne.WebView.WebServer.Notifications
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Publisher { get; set; }
Visual Basic (Declaration)
Public Property Publisher As String
Visual C++
public:
property String^ Publisher {
    String^ get ();
    void set (String^ value);
}

See Also

NotifySubsBook Class
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


NotifySubsBookCollection Class

[image]

LinkOne WebView API
NotifySubsBookCollection Class
Members See Also Send Feedback
Represents a collection of NotifySubsBook objects.

Namespace: Mincom.LinkOne.WebView.WebServer.Notifications
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
[SerializableAttribute]
public sealed class NotifySubsBookCollection : ICollection<NotifySubsBook>,
    IEnumerable<NotifySubsBook>, IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class NotifySubsBookCollection _
    Implements ICollection(Of NotifySubsBook), IEnumerable(Of NotifySubsBook),  _
    IEnumerable
Visual C++
[SerializableAttribute]
public ref class NotifySubsBookCollection sealed : ICollection<NotifySubsBook^>,
    IEnumerable<NotifySubsBook^>, IEnumerable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.Notifications..::.NotifySubsBookCollection

See Also

NotifySubsBookCollection Members
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


NotifySubsBookCollection Members

[image] [image]

LinkOne WebView API
NotifySubsBookCollection Members
NotifySubsBookCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The NotifySubsBookCollection type exposes the following members.

Constructors

Name | Description
NotifySubsBookCollection | Overloaded.

Methods

Name | Description
Add | Adds an NotifySubsBook item to the NotifySubsBookCollection.
Clear | Removes all items from the NotifySubsBookCollection.
Contains | Determines whether the NotifySubsBookCollection contains a specific NotifySubsBook value.
CopyTo | Copies the NotifySubsBook elements of the NotifySubsBookCollection to an NotifySubsBook array, starting at a particular array index.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the NotifySubsBookCollection.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of NotifySubsBook elements contained in the NotifySubsBookCollection.
IsReadOnly | Gets a value indicating whether the NotifySubsBookCollection is read-only.

Explicit Interface Implementations

Name | Description
IEnumerable<(Of <(NotifySubsBook>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through the NotifySubsBookCollection.

See Also

NotifySubsBookCollection Class
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


NotifySubsBookCollection Constructor

[image] [image]

LinkOne WebView API
NotifySubsBookCollection Constructor
NotifySubsBookCollection Class See Also Send Feedback

Overload List

Name | Description
NotifySubsBookCollection()()() | Initializes a new instance of the NotifySubsBookCollection class.
NotifySubsBookCollection(StringCollection) | Initializes a new instance of the NotifySubsBookCollection class.

See Also

NotifySubsBookCollection Class
NotifySubsBookCollection Members
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


NotifySubsBookCollection Constructor

[image]

LinkOne WebView API
NotifySubsBookCollection Constructor
NotifySubsBookCollection Class See Also Send Feedback
Initializes a new instance of the NotifySubsBookCollection class.

Namespace: Mincom.LinkOne.WebView.WebServer.Notifications
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public NotifySubsBookCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NotifySubsBookCollection()

See Also

NotifySubsBookCollection Class
NotifySubsBookCollection Overload
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


NotifySubsBookCollection Constructor (StringCollection)

[image]

LinkOne WebView API
NotifySubsBookCollection Constructor (StringCollection)
NotifySubsBookCollection Class See Also Send Feedback
Initializes a new instance of the NotifySubsBookCollection class.

Namespace: Mincom.LinkOne.WebView.WebServer.Notifications
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public NotifySubsBookCollection(
    StringCollection notifySubsBooks
)
Visual Basic (Declaration)
Public Sub New ( _
    notifySubsBooks As StringCollection _
)
Visual C++
public:
NotifySubsBookCollection(
    StringCollection^ notifySubsBooks
)

Parameters

notifySubsBooks
Type: System.Collections.Specialized..::.StringCollection

See Also

NotifySubsBookCollection Class
NotifySubsBookCollection Overload
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


NotifySubsBookCollection Methods

[image] [image]

LinkOne WebView API
NotifySubsBookCollection Methods
NotifySubsBookCollection Class See Also Send Feedback

The NotifySubsBookCollection type exposes the following members.

Methods

Name | Description
Add | Adds an NotifySubsBook item to the NotifySubsBookCollection.
Clear | Removes all items from the NotifySubsBookCollection.
Contains | Determines whether the NotifySubsBookCollection contains a specific NotifySubsBook value.
CopyTo | Copies the NotifySubsBook elements of the NotifySubsBookCollection to an NotifySubsBook array, starting at a particular array index.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the NotifySubsBookCollection.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable<(Of <(NotifySubsBook>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through the NotifySubsBookCollection.

See Also

NotifySubsBookCollection Class
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


IEnumerable(NotifySubsBook).GetEnumerator Method

[image]

LinkOne WebView API
NotifySubsBookCollection..::.IEnumerable<(Of <(NotifySubsBook>)>)..::.GetEnumerator Method
NotifySubsBookCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.Notifications
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
IEnumerator<NotifySubsBook> IEnumerable<NotifySubsBook>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of NotifySubsBook)
    Implements IEnumerable(Of NotifySubsBook).GetEnumerator
Visual C++
private:
virtual IEnumerator<NotifySubsBook^>^ GetEnumerator() sealed = IEnumerable<NotifySubsBook^>::GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

NotifySubsBookCollection Class
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
NotifySubsBookCollection..::.IEnumerable..::.GetEnumerator Method
NotifySubsBookCollection Class See Also Send Feedback
Returns an enumerator that iterates through the NotifySubsBookCollection.

Namespace: Mincom.LinkOne.WebView.WebServer.Notifications
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

NotifySubsBookCollection Class
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


Add Method

[image]

LinkOne WebView API
NotifySubsBookCollection..::.Add Method
NotifySubsBookCollection Class See Also Send Feedback
Adds an NotifySubsBook item to the NotifySubsBookCollection.

Namespace: Mincom.LinkOne.WebView.WebServer.Notifications
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void Add(
    NotifySubsBook item
)
Visual Basic (Declaration)
Public Sub Add ( _
    item As NotifySubsBook _
)
Visual C++
public:
virtual void Add(
    NotifySubsBook^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.WebView.WebServer.Notifications..::.NotifySubsBook
The NotifySubsBook object to add to the NotifySubsBookCollection.

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

NotifySubsBookCollection Class
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


Clear Method

[image]

LinkOne WebView API
NotifySubsBookCollection..::.Clear Method
NotifySubsBookCollection Class See Also Send Feedback
Removes all items from the NotifySubsBookCollection.

Namespace: Mincom.LinkOne.WebView.WebServer.Notifications
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
virtual void Clear() sealed

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

See Also

NotifySubsBookCollection Class
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


Contains Method

[image]

LinkOne WebView API
NotifySubsBookCollection..::.Contains Method
NotifySubsBookCollection Class See Also Send Feedback
Determines whether the NotifySubsBookCollection contains a specific NotifySubsBook value.

Namespace: Mincom.LinkOne.WebView.WebServer.Notifications
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool Contains(
    NotifySubsBook item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As NotifySubsBook _
) As Boolean
Visual C++
public:
virtual bool Contains(
    NotifySubsBook^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.WebView.WebServer.Notifications..::.NotifySubsBook
The NotifySubsBook to locate in the NotifySubsBookCollection.

Return Value

True if item is found in the NotifySubsBookCollection; otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

NotifySubsBookCollection Class
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


CopyTo Method

[image]

LinkOne WebView API
NotifySubsBookCollection..::.CopyTo Method
NotifySubsBookCollection Class See Also Send Feedback
Copies the NotifySubsBook elements of the NotifySubsBookCollection to an NotifySubsBook array, starting at a particular array index.

Namespace: Mincom.LinkOne.WebView.WebServer.Notifications
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void CopyTo(
    NotifySubsBook[] array,
    int arrayIndex
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As NotifySubsBook(), _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    array<NotifySubsBook^>^ array,
    int arrayIndex
) sealed

Parameters

array
Type: array< Mincom.LinkOne.WebView.WebServer.Notifications..::.NotifySubsBook >[]()[]
The one-dimensional NotifySubsBook array that is the destination of the elements copied from NotifySubsBookCollection. The NotifySubsBook array must have zero-based indexing.
arrayIndex
Type: System..::.Int32
The zero-based index in array at which copying begins.

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

NotifySubsBookCollection Class
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


Remove Method

[image]

LinkOne WebView API
NotifySubsBookCollection..::.Remove Method
NotifySubsBookCollection Class See Also Send Feedback
Removes the first occurrence of a specific object from the NotifySubsBookCollection.

Namespace: Mincom.LinkOne.WebView.WebServer.Notifications
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool Remove(
    NotifySubsBook item
)
Visual Basic (Declaration)
Public Function Remove ( _
    item As NotifySubsBook _
) As Boolean
Visual C++
public:
virtual bool Remove(
    NotifySubsBook^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.WebView.WebServer.Notifications..::.NotifySubsBook
The NotifySubsBook object to remove from the NotifySubsBookCollection.

Return Value

true if item was successfully removed from the NotifySubsBookCollection; otherwise, false. This method also returns false if item is not found in the original NotifySubsBookCollection.

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

NotifySubsBookCollection Class
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


NotifySubsBookCollection Properties

[image] [image]

LinkOne WebView API
NotifySubsBookCollection Properties
NotifySubsBookCollection Class See Also Send Feedback

The NotifySubsBookCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of NotifySubsBook elements contained in the NotifySubsBookCollection.
IsReadOnly | Gets a value indicating whether the NotifySubsBookCollection is read-only.

See Also

NotifySubsBookCollection Class
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


Count Property

[image]

LinkOne WebView API
NotifySubsBookCollection..::.Count Property
NotifySubsBookCollection Class See Also Send Feedback
Gets the number of NotifySubsBook elements contained in the NotifySubsBookCollection.

Namespace: Mincom.LinkOne.WebView.WebServer.Notifications
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Return Value

The number of NotifySubsBook elements contained in the NotifySubsBookCollection.

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

NotifySubsBookCollection Class
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


IsReadOnly Property

[image]

LinkOne WebView API
NotifySubsBookCollection..::.IsReadOnly Property
NotifySubsBookCollection Class See Also Send Feedback
Gets a value indicating whether the NotifySubsBookCollection is read-only.

Namespace: Mincom.LinkOne.WebView.WebServer.Notifications
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Field Value

Return Value

true if the NotifySubsBookCollection is read-only; otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

NotifySubsBookCollection Class
Mincom.LinkOne.WebView.WebServer.Notifications Namespace


Mincom.LinkOne.WebView.WebServer.Security Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.WebView.WebServer.Security Namespace
Send Feedback
The Mincom.LinkOne.WebView.WebServer.Security namespace supplies classes that control what each user can access.

Classes

Class | Description
AllowedBook | Represents the codes describing a collection of allowable books.
AllowedBookCollection | Represents a collection of AllowedBook objects.
AllowedNote | Represents the codes describing a collection of allowable notes.
AllowedNoteCollection | Represents a collection of AllowedNote objects.
Principal | This class identifies the current user and their access rights for LinkOne books.


AllowedBook Class

[image]

LinkOne WebView API
AllowedBook Class
Members See Also Send Feedback
Represents the codes describing a collection of allowable books.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public sealed class AllowedBook
Visual Basic (Declaration)
Public NotInheritable Class AllowedBook
Visual C++
public ref class AllowedBook sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.Security..::.AllowedBook

See Also

AllowedBook Members
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllowedBook Members

[image] [image]

LinkOne WebView API
AllowedBook Members
AllowedBook Class Constructors Methods Properties See Also Send Feedback

The AllowedBook type exposes the following members.

Constructors

Name | Description
AllowedBook | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPath | Gets the descriptive path of the allowed book
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current AllowedBook. (Overrides Object..::.ToString()()().)

Properties

Name | Description
AssignedToRole | Gets whether this allowed book is assigned to a role.
Book | Gets or sets the book.
Category | Gets or sets the category.
Publisher | Gets or sets the publisher.

See Also

AllowedBook Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllowedBook Constructor

[image] [image]

LinkOne WebView API
AllowedBook Constructor
AllowedBook Class See Also Send Feedback

Overload List

Name | Description
AllowedBook()()() | Initializes a new instance of the AllowedBook class.
AllowedBook(String, String, String) | Initializes a new instance of the AllowedBook class.

See Also

AllowedBook Class
AllowedBook Members
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllowedBook Constructor

[image]

LinkOne WebView API
AllowedBook Constructor
AllowedBook Class See Also Send Feedback
Initializes a new instance of the AllowedBook class.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public AllowedBook()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AllowedBook()

See Also

AllowedBook Class
AllowedBook Overload
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllowedBook Constructor (String, String, String)

[image]

LinkOne WebView API
AllowedBook Constructor (String, String, String)
AllowedBook Class See Also Send Feedback
Initializes a new instance of the AllowedBook class.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public AllowedBook(
    string publisher,
    string book,
    string category
)
Visual Basic (Declaration)
Public Sub New ( _
    publisher As String, _
    book As String, _
    category As String _
)
Visual C++
public:
AllowedBook(
    String^ publisher,
    String^ book,
    String^ category
)

Parameters

publisher
Type: System..::.String
The publisher code.
book
Type: System..::.String
The book code.
category
Type: System..::.String
The category codes, in the format category-code-segment/.../category-code-segment.

See Also

AllowedBook Class
AllowedBook Overload
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllowedBook Methods

[image] [image]

LinkOne WebView API
AllowedBook Methods
AllowedBook Class See Also Send Feedback

The AllowedBook type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPath | Gets the descriptive path of the allowed book
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current AllowedBook. (Overrides Object..::.ToString()()().)

See Also

AllowedBook Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


GetPath Method

[image]

LinkOne WebView API
AllowedBook..::.GetPath Method
AllowedBook Class See Also Send Feedback
Gets the descriptive path of the allowed book

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string GetPath()
Visual Basic (Declaration)
Public Function GetPath As String
Visual C++
public:
String^ GetPath()

Return Value

The book path.

See Also

AllowedBook Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


ToString Method

[image]

LinkOne WebView API
AllowedBook..::.ToString Method
AllowedBook Class See Also Send Feedback
Returns a String that represents the current AllowedBook.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current AllowedBook.

See Also

AllowedBook Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllowedBook Properties

[image] [image]

LinkOne WebView API
AllowedBook Properties
AllowedBook Class See Also Send Feedback

The AllowedBook type exposes the following members.

Properties

Name | Description
AssignedToRole | Gets whether this allowed book is assigned to a role.
Book | Gets or sets the book.
Category | Gets or sets the category.
Publisher | Gets or sets the publisher.

See Also

AllowedBook Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


AssignedToRole Property

[image]

LinkOne WebView API
AllowedBook..::.AssignedToRole Property
AllowedBook Class See Also Send Feedback
Gets whether this allowed book is assigned to a role.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool AssignedToRole { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssignedToRole As Boolean
Visual C++
public:
property bool AssignedToRole {
    bool get ();
}

See Also

AllowedBook Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


Book Property

[image]

LinkOne WebView API
AllowedBook..::.Book Property
AllowedBook Class See Also Send Feedback
Gets or sets the book.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Book { get; set; }
Visual Basic (Declaration)
Public Property Book As String
Visual C++
public:
property String^ Book {
    String^ get ();
    void set (String^ value);
}

Remarks

Setting a book code that has any length will clear the category.

See Also

AllowedBook Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


Category Property

[image]

LinkOne WebView API
AllowedBook..::.Category Property
AllowedBook Class See Also Send Feedback
Gets or sets the category.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Category { get; set; }
Visual Basic (Declaration)
Public Property Category As String
Visual C++
public:
property String^ Category {
    String^ get ();
    void set (String^ value);
}

Remarks

Setting a category that has any length will clear the book.

See Also

AllowedBook Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


Publisher Property

[image]

LinkOne WebView API
AllowedBook..::.Publisher Property
AllowedBook Class See Also Send Feedback
Gets or sets the publisher.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Publisher { get; set; }
Visual Basic (Declaration)
Public Property Publisher As String
Visual C++
public:
property String^ Publisher {
    String^ get ();
    void set (String^ value);
}

See Also

AllowedBook Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllowedBookCollection Class

[image]

LinkOne WebView API
AllowedBookCollection Class
Members See Also Send Feedback
Represents a collection of AllowedBook objects.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
[SerializableAttribute]
public sealed class AllowedBookCollection : ICollection<AllowedBook>,
    IEnumerable<AllowedBook>, IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class AllowedBookCollection _
    Implements ICollection(Of AllowedBook), IEnumerable(Of AllowedBook),  _
    IEnumerable
Visual C++
[SerializableAttribute]
public ref class AllowedBookCollection sealed : ICollection<AllowedBook^>,
    IEnumerable<AllowedBook^>, IEnumerable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.Security..::.AllowedBookCollection

See Also

AllowedBookCollection Members
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllowedBookCollection Members

[image] [image]

LinkOne WebView API
AllowedBookCollection Members
AllowedBookCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The AllowedBookCollection type exposes the following members.

Constructors

Name | Description
AllowedBookCollection | Overloaded.

Methods

Name | Description
Add | Adds an AllowedBook item to the AllowedBookCollection.
Clear | Removes all items from the AllowedBookCollection.
Contains | Determines whether the AllowedBookCollection contains a specific AllowedBook value.
CopyTo | Copies the AllowedBook elements of the AllowedBookCollection to an AllowedBook array, starting at a particular array index.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the AllowedBookCollection.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
AllBooks | Gets or sets a value indicating whether all books are available.
Count | Gets the number of AllowedBook elements contained in the AllowedBookCollection.
IsReadOnly | Gets a value indicating whether the AllowedBookCollection is read-only.

Explicit Interface Implementations

Name | Description
IEnumerable<(Of <(AllowedBook>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through the AllowedBookCollection.

See Also

AllowedBookCollection Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllowedBookCollection Constructor

[image] [image]

LinkOne WebView API
AllowedBookCollection Constructor
AllowedBookCollection Class See Also Send Feedback

Overload List

Name | Description
AllowedBookCollection()()() | Initializes a new instance of the AllowedBookCollection class.
AllowedBookCollection(StringCollection) | Initializes a new instance of the AllowedBookCollection class.
AllowedBookCollection(StringCollection, Boolean) | Initializes a new instance of the AllowedBookCollection class.

See Also

AllowedBookCollection Class
AllowedBookCollection Members
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllowedBookCollection Constructor

[image]

LinkOne WebView API
AllowedBookCollection Constructor
AllowedBookCollection Class See Also Send Feedback
Initializes a new instance of the AllowedBookCollection class.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public AllowedBookCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AllowedBookCollection()

See Also

AllowedBookCollection Class
AllowedBookCollection Overload
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllowedBookCollection Constructor (StringCollection)

[image]

LinkOne WebView API
AllowedBookCollection Constructor (StringCollection)
AllowedBookCollection Class See Also Send Feedback
Initializes a new instance of the AllowedBookCollection class.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public AllowedBookCollection(
    StringCollection allowedBooks
)
Visual Basic (Declaration)
Public Sub New ( _
    allowedBooks As StringCollection _
)
Visual C++
public:
AllowedBookCollection(
    StringCollection^ allowedBooks
)

Parameters

allowedBooks
Type: System.Collections.Specialized..::.StringCollection
The allowed books to add to the collection.

See Also

AllowedBookCollection Class
AllowedBookCollection Overload
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllowedBookCollection Constructor (StringCollection, Boolean)

[image]

LinkOne WebView API
AllowedBookCollection Constructor (StringCollection, Boolean)
AllowedBookCollection Class See Also Send Feedback
Initializes a new instance of the AllowedBookCollection class.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public AllowedBookCollection(
    StringCollection allowedBooks,
    bool assignedToRole
)
Visual Basic (Declaration)
Public Sub New ( _
    allowedBooks As StringCollection, _
    assignedToRole As Boolean _
)
Visual C++
public:
AllowedBookCollection(
    StringCollection^ allowedBooks,
    bool assignedToRole
)

Parameters

allowedBooks
Type: System.Collections.Specialized..::.StringCollection
The allowed books to add to the collection.
assignedToRole
Type: System..::.Boolean

See Also

AllowedBookCollection Class
AllowedBookCollection Overload
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllowedBookCollection Methods

[image] [image]

LinkOne WebView API
AllowedBookCollection Methods
AllowedBookCollection Class See Also Send Feedback

The AllowedBookCollection type exposes the following members.

Methods

Name | Description
Add | Adds an AllowedBook item to the AllowedBookCollection.
Clear | Removes all items from the AllowedBookCollection.
Contains | Determines whether the AllowedBookCollection contains a specific AllowedBook value.
CopyTo | Copies the AllowedBook elements of the AllowedBookCollection to an AllowedBook array, starting at a particular array index.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the AllowedBookCollection.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable<(Of <(AllowedBook>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through the AllowedBookCollection.

See Also

AllowedBookCollection Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


IEnumerable(AllowedBook).GetEnumerator Method

[image]

LinkOne WebView API
AllowedBookCollection..::.IEnumerable<(Of <(AllowedBook>)>)..::.GetEnumerator Method
AllowedBookCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
IEnumerator<AllowedBook> IEnumerable<AllowedBook>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of AllowedBook)
    Implements IEnumerable(Of AllowedBook).GetEnumerator
Visual C++
private:
virtual IEnumerator<AllowedBook^>^ GetEnumerator() sealed = IEnumerable<AllowedBook^>::GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

AllowedBookCollection Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
AllowedBookCollection..::.IEnumerable..::.GetEnumerator Method
AllowedBookCollection Class See Also Send Feedback
Returns an enumerator that iterates through the AllowedBookCollection.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

AllowedBookCollection Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


Add Method

[image]

LinkOne WebView API
AllowedBookCollection..::.Add Method
AllowedBookCollection Class See Also Send Feedback
Adds an AllowedBook item to the AllowedBookCollection.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void Add(
    AllowedBook item
)
Visual Basic (Declaration)
Public Sub Add ( _
    item As AllowedBook _
)
Visual C++
public:
virtual void Add(
    AllowedBook^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.WebView.WebServer.Security..::.AllowedBook
The AllowedBook object to add to the AllowedBookCollection.

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

AllowedBookCollection Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


Clear Method

[image]

LinkOne WebView API
AllowedBookCollection..::.Clear Method
AllowedBookCollection Class See Also Send Feedback
Removes all items from the AllowedBookCollection.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
virtual void Clear() sealed

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

See Also

AllowedBookCollection Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


Contains Method

[image]

LinkOne WebView API
AllowedBookCollection..::.Contains Method
AllowedBookCollection Class See Also Send Feedback
Determines whether the AllowedBookCollection contains a specific AllowedBook value.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool Contains(
    AllowedBook item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As AllowedBook _
) As Boolean
Visual C++
public:
virtual bool Contains(
    AllowedBook^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.WebView.WebServer.Security..::.AllowedBook
The AllowedBook to locate in the AllowedBookCollection.

Return Value

True if item is found in the AllowedBookCollection; otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

AllowedBookCollection Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


CopyTo Method

[image]

LinkOne WebView API
AllowedBookCollection..::.CopyTo Method
AllowedBookCollection Class See Also Send Feedback
Copies the AllowedBook elements of the AllowedBookCollection to an AllowedBook array, starting at a particular array index.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void CopyTo(
    AllowedBook[] array,
    int arrayIndex
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As AllowedBook(), _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    array<AllowedBook^>^ array,
    int arrayIndex
) sealed

Parameters

array
Type: array< Mincom.LinkOne.WebView.WebServer.Security..::.AllowedBook >[]()[]
The one-dimensional AllowedBook array that is the destination of the elements copied from AllowedBookCollection. The AllowedBook array must have zero-based indexing.
arrayIndex
Type: System..::.Int32
The zero-based index in array at which copying begins.

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

AllowedBookCollection Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


Remove Method

[image]

LinkOne WebView API
AllowedBookCollection..::.Remove Method
AllowedBookCollection Class See Also Send Feedback
Removes the first occurrence of a specific object from the AllowedBookCollection.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool Remove(
    AllowedBook item
)
Visual Basic (Declaration)
Public Function Remove ( _
    item As AllowedBook _
) As Boolean
Visual C++
public:
virtual bool Remove(
    AllowedBook^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.WebView.WebServer.Security..::.AllowedBook
The AllowedBook object to remove from the AllowedBookCollection.

Return Value

true if item was successfully removed from the AllowedBookCollection; otherwise, false. This method also returns false if item is not found in the original AllowedBookCollection.

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

AllowedBookCollection Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllowedBookCollection Properties

[image] [image]

LinkOne WebView API
AllowedBookCollection Properties
AllowedBookCollection Class See Also Send Feedback

The AllowedBookCollection type exposes the following members.

Properties

Name | Description
AllBooks | Gets or sets a value indicating whether all books are available.
Count | Gets the number of AllowedBook elements contained in the AllowedBookCollection.
IsReadOnly | Gets a value indicating whether the AllowedBookCollection is read-only.

See Also

AllowedBookCollection Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllBooks Property

[image]

LinkOne WebView API
AllowedBookCollection..::.AllBooks Property
AllowedBookCollection Class See Also Send Feedback
Gets or sets a value indicating whether all books are available.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool AllBooks { get; set; }
Visual Basic (Declaration)
Public Property AllBooks As Boolean
Visual C++
public:
property bool AllBooks {
    bool get ();
    void set (bool value);
}

Field Value

true if all books are available; otherwise, false.

See Also

AllowedBookCollection Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


Count Property

[image]

LinkOne WebView API
AllowedBookCollection..::.Count Property
AllowedBookCollection Class See Also Send Feedback
Gets the number of AllowedBook elements contained in the AllowedBookCollection.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Return Value

The number of AllowedBook elements contained in the AllowedBookCollection.

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

AllowedBookCollection Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


IsReadOnly Property

[image]

LinkOne WebView API
AllowedBookCollection..::.IsReadOnly Property
AllowedBookCollection Class See Also Send Feedback
Gets a value indicating whether the AllowedBookCollection is read-only.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Field Value

Return Value

true if the AllowedBookCollection is read-only; otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

AllowedBookCollection Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllowedNote Class

[image]

LinkOne WebView API
AllowedNote Class
Members See Also Send Feedback
Represents the codes describing a collection of allowable notes.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public sealed class AllowedNote
Visual Basic (Declaration)
Public NotInheritable Class AllowedNote
Visual C++
public ref class AllowedNote sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.Security..::.AllowedNote

See Also

AllowedNote Members
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllowedNote Members

[image] [image]

LinkOne WebView API
AllowedNote Members
AllowedNote Class Constructors Methods Properties See Also Send Feedback

The AllowedNote type exposes the following members.

Constructors

Name | Description
AllowedNote | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current AllowedBook. (Overrides Object..::.ToString()()().)

Properties

Name | Description
AssignedToRole | Gets whether this allowed note category is assigned to a role.
Category | Gets or sets the category.

See Also

AllowedNote Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllowedNote Constructor

[image] [image]

LinkOne WebView API
AllowedNote Constructor
AllowedNote Class See Also Send Feedback

Overload List

Name | Description
AllowedNote()()() | Initializes a new instance of the AllowedNote class.
AllowedNote(String) | Initializes a new instance of the AllowedNote class.
AllowedNote(String, Boolean) | Initializes a new instance of the AllowedNote class.

See Also

AllowedNote Class
AllowedNote Members
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllowedNote Constructor

[image]

LinkOne WebView API
AllowedNote Constructor
AllowedNote Class See Also Send Feedback
Initializes a new instance of the AllowedNote class.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public AllowedNote()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AllowedNote()

See Also

AllowedNote Class
AllowedNote Overload
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllowedNote Constructor (String)

[image]

LinkOne WebView API
AllowedNote Constructor (String)
AllowedNote Class See Also Send Feedback
Initializes a new instance of the AllowedNote class.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public AllowedNote(
    string category
)
Visual Basic (Declaration)
Public Sub New ( _
    category As String _
)
Visual C++
public:
AllowedNote(
    String^ category
)

Parameters

category
Type: System..::.String
The note category.

See Also

AllowedNote Class
AllowedNote Overload
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllowedNote Constructor (String, Boolean)

[image]

LinkOne WebView API
AllowedNote Constructor (String, Boolean)
AllowedNote Class See Also Send Feedback
Initializes a new instance of the AllowedNote class.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public AllowedNote(
    string category,
    bool assignedToRole
)
Visual Basic (Declaration)
Public Sub New ( _
    category As String, _
    assignedToRole As Boolean _
)
Visual C++
public:
AllowedNote(
    String^ category,
    bool assignedToRole
)

Parameters

category
Type: System..::.String
The note category.
assignedToRole
Type: System..::.Boolean

See Also

AllowedNote Class
AllowedNote Overload
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllowedNote Methods

[image] [image]

LinkOne WebView API
AllowedNote Methods
AllowedNote Class See Also Send Feedback

The AllowedNote type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current AllowedBook. (Overrides Object..::.ToString()()().)

See Also

AllowedNote Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


ToString Method

[image]

LinkOne WebView API
AllowedNote..::.ToString Method
AllowedNote Class See Also Send Feedback
Returns a String that represents the current AllowedBook.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current AllowedBook.

See Also

AllowedNote Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllowedNote Properties

[image] [image]

LinkOne WebView API
AllowedNote Properties
AllowedNote Class See Also Send Feedback

The AllowedNote type exposes the following members.

Properties

Name | Description
AssignedToRole | Gets whether this allowed note category is assigned to a role.
Category | Gets or sets the category.

See Also

AllowedNote Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


AssignedToRole Property

[image]

LinkOne WebView API
AllowedNote..::.AssignedToRole Property
AllowedNote Class See Also Send Feedback
Gets whether this allowed note category is assigned to a role.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool AssignedToRole { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssignedToRole As Boolean
Visual C++
public:
property bool AssignedToRole {
    bool get ();
}

See Also

AllowedNote Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


Category Property

[image]

LinkOne WebView API
AllowedNote..::.Category Property
AllowedNote Class See Also Send Feedback
Gets or sets the category.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Category { get; set; }
Visual Basic (Declaration)
Public Property Category As String
Visual C++
public:
property String^ Category {
    String^ get ();
    void set (String^ value);
}

See Also

AllowedNote Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllowedNoteCollection Class

[image]

LinkOne WebView API
AllowedNoteCollection Class
Members See Also Send Feedback
Represents a collection of AllowedNote objects.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public sealed class AllowedNoteCollection : ICollection<AllowedNote>,
    IEnumerable<AllowedNote>, IEnumerable
Visual Basic (Declaration)
Public NotInheritable Class AllowedNoteCollection _
    Implements ICollection(Of AllowedNote), IEnumerable(Of AllowedNote),  _
    IEnumerable
Visual C++
public ref class AllowedNoteCollection sealed : ICollection<AllowedNote^>,
    IEnumerable<AllowedNote^>, IEnumerable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.Security..::.AllowedNoteCollection

See Also

AllowedNoteCollection Members
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllowedNoteCollection Members

[image] [image]

LinkOne WebView API
AllowedNoteCollection Members
AllowedNoteCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The AllowedNoteCollection type exposes the following members.

Constructors

Name | Description
AllowedNoteCollection | Overloaded.

Methods

Name | Description
Add | Adds an AllowedNote item to the AllowedNoteCollection.
Clear | Removes all items from the AllowedNoteCollection.
Contains | Determines whether the AllowedNoteCollection contains a specific AllowedNote value.
CopyTo | Copies the AllowedNote elements of the AllowedNoteCollection to an AllowedNote array, starting at a particular array index.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the AllowedNoteCollection.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
AllNotes | Gets or sets a value indicating whether all notes are available.
Count | Gets the number of AllowedNote elements contained in the AllowedNoteCollection.
IsReadOnly | Gets a value indicating whether the AllowedNoteCollection is read-only.

Explicit Interface Implementations

Name | Description
IEnumerable<(Of <(AllowedNote>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through the AllowedNoteCollection.

See Also

AllowedNoteCollection Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllowedNoteCollection Constructor

[image] [image]

LinkOne WebView API
AllowedNoteCollection Constructor
AllowedNoteCollection Class See Also Send Feedback

Overload List

Name | Description
AllowedNoteCollection()()() | Initializes a new instance of the AllowedNoteCollection class.
AllowedNoteCollection(StringCollection) | Initializes a new instance of the AllowedNoteCollection class.
AllowedNoteCollection(StringCollection, Boolean) | Initializes a new instance of the AllowedNoteCollection class.

See Also

AllowedNoteCollection Class
AllowedNoteCollection Members
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllowedNoteCollection Constructor

[image]

LinkOne WebView API
AllowedNoteCollection Constructor
AllowedNoteCollection Class See Also Send Feedback
Initializes a new instance of the AllowedNoteCollection class.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public AllowedNoteCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AllowedNoteCollection()

See Also

AllowedNoteCollection Class
AllowedNoteCollection Overload
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllowedNoteCollection Constructor (StringCollection)

[image]

LinkOne WebView API
AllowedNoteCollection Constructor (StringCollection)
AllowedNoteCollection Class See Also Send Feedback
Initializes a new instance of the AllowedNoteCollection class.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public AllowedNoteCollection(
    StringCollection allowedNotes
)
Visual Basic (Declaration)
Public Sub New ( _
    allowedNotes As StringCollection _
)
Visual C++
public:
AllowedNoteCollection(
    StringCollection^ allowedNotes
)

Parameters

allowedNotes
Type: System.Collections.Specialized..::.StringCollection
The allowed notes to add to the collection.

See Also

AllowedNoteCollection Class
AllowedNoteCollection Overload
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllowedNoteCollection Constructor (StringCollection, Boolean)

[image]

LinkOne WebView API
AllowedNoteCollection Constructor (StringCollection, Boolean)
AllowedNoteCollection Class See Also Send Feedback
Initializes a new instance of the AllowedNoteCollection class.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public AllowedNoteCollection(
    StringCollection allowedNotes,
    bool assignedToRole
)
Visual Basic (Declaration)
Public Sub New ( _
    allowedNotes As StringCollection, _
    assignedToRole As Boolean _
)
Visual C++
public:
AllowedNoteCollection(
    StringCollection^ allowedNotes,
    bool assignedToRole
)

Parameters

allowedNotes
Type: System.Collections.Specialized..::.StringCollection
The allowed notes to add to the collection.
assignedToRole
Type: System..::.Boolean

See Also

AllowedNoteCollection Class
AllowedNoteCollection Overload
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllowedNoteCollection Methods

[image] [image]

LinkOne WebView API
AllowedNoteCollection Methods
AllowedNoteCollection Class See Also Send Feedback

The AllowedNoteCollection type exposes the following members.

Methods

Name | Description
Add | Adds an AllowedNote item to the AllowedNoteCollection.
Clear | Removes all items from the AllowedNoteCollection.
Contains | Determines whether the AllowedNoteCollection contains a specific AllowedNote value.
CopyTo | Copies the AllowedNote elements of the AllowedNoteCollection to an AllowedNote array, starting at a particular array index.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the AllowedNoteCollection.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable<(Of <(AllowedNote>)>)..::.GetEnumerator |
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through the AllowedNoteCollection.

See Also

AllowedNoteCollection Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


IEnumerable(AllowedNote).GetEnumerator Method

[image]

LinkOne WebView API
AllowedNoteCollection..::.IEnumerable<(Of <(AllowedNote>)>)..::.GetEnumerator Method
AllowedNoteCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
IEnumerator<AllowedNote> IEnumerable<AllowedNote>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of AllowedNote)
    Implements IEnumerable(Of AllowedNote).GetEnumerator
Visual C++
private:
virtual IEnumerator<AllowedNote^>^ GetEnumerator() sealed = IEnumerable<AllowedNote^>::GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

AllowedNoteCollection Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


IEnumerable.GetEnumerator Method

[image]

LinkOne WebView API
AllowedNoteCollection..::.IEnumerable..::.GetEnumerator Method
AllowedNoteCollection Class See Also Send Feedback
Returns an enumerator that iterates through the AllowedNoteCollection.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

AllowedNoteCollection Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


Add Method

[image]

LinkOne WebView API
AllowedNoteCollection..::.Add Method
AllowedNoteCollection Class See Also Send Feedback
Adds an AllowedNote item to the AllowedNoteCollection.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void Add(
    AllowedNote item
)
Visual Basic (Declaration)
Public Sub Add ( _
    item As AllowedNote _
)
Visual C++
public:
virtual void Add(
    AllowedNote^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.WebView.WebServer.Security..::.AllowedNote
The AllowedNote object to add to the AllowedNoteCollection.

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

AllowedNoteCollection Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


Clear Method

[image]

LinkOne WebView API
AllowedNoteCollection..::.Clear Method
AllowedNoteCollection Class See Also Send Feedback
Removes all items from the AllowedNoteCollection.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
virtual void Clear() sealed

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

See Also

AllowedNoteCollection Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


Contains Method

[image]

LinkOne WebView API
AllowedNoteCollection..::.Contains Method
AllowedNoteCollection Class See Also Send Feedback
Determines whether the AllowedNoteCollection contains a specific AllowedNote value.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool Contains(
    AllowedNote item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As AllowedNote _
) As Boolean
Visual C++
public:
virtual bool Contains(
    AllowedNote^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.WebView.WebServer.Security..::.AllowedNote
The AllowedNote to locate in the AllowedNoteCollection.

Return Value

True if item is found in the AllowedNoteCollection; otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

AllowedNoteCollection Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


CopyTo Method

[image]

LinkOne WebView API
AllowedNoteCollection..::.CopyTo Method
AllowedNoteCollection Class See Also Send Feedback
Copies the AllowedNote elements of the AllowedNoteCollection to an AllowedNote array, starting at a particular array index.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void CopyTo(
    AllowedNote[] array,
    int arrayIndex
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As AllowedNote(), _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    array<AllowedNote^>^ array,
    int arrayIndex
) sealed

Parameters

array
Type: array< Mincom.LinkOne.WebView.WebServer.Security..::.AllowedNote >[]()[]
The one-dimensional AllowedNote array that is the destination of the elements copied from AllowedNoteCollection. The AllowedNote array must have zero-based indexing.
arrayIndex
Type: System..::.Int32
The zero-based index in array at which copying begins.

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

AllowedNoteCollection Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


Remove Method

[image]

LinkOne WebView API
AllowedNoteCollection..::.Remove Method
AllowedNoteCollection Class See Also Send Feedback
Removes the first occurrence of a specific object from the AllowedNoteCollection.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool Remove(
    AllowedNote item
)
Visual Basic (Declaration)
Public Function Remove ( _
    item As AllowedNote _
) As Boolean
Visual C++
public:
virtual bool Remove(
    AllowedNote^ item
) sealed

Parameters

item
Type: Mincom.LinkOne.WebView.WebServer.Security..::.AllowedNote
The AllowedNote object to remove from the AllowedNoteCollection.

Return Value

true if item was successfully removed from the AllowedNoteCollection; otherwise, false. This method also returns false if item is not found in the original AllowedNoteCollection.

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

AllowedNoteCollection Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllowedNoteCollection Properties

[image] [image]

LinkOne WebView API
AllowedNoteCollection Properties
AllowedNoteCollection Class See Also Send Feedback

The AllowedNoteCollection type exposes the following members.

Properties

Name | Description
AllNotes | Gets or sets a value indicating whether all notes are available.
Count | Gets the number of AllowedNote elements contained in the AllowedNoteCollection.
IsReadOnly | Gets a value indicating whether the AllowedNoteCollection is read-only.

See Also

AllowedNoteCollection Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


AllNotes Property

[image]

LinkOne WebView API
AllowedNoteCollection..::.AllNotes Property
AllowedNoteCollection Class See Also Send Feedback
Gets or sets a value indicating whether all notes are available.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool AllNotes { get; set; }
Visual Basic (Declaration)
Public Property AllNotes As Boolean
Visual C++
public:
property bool AllNotes {
    bool get ();
    void set (bool value);
}

Field Value

true if all notes are available; otherwise, false.

See Also

AllowedNoteCollection Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


Count Property

[image]

LinkOne WebView API
AllowedNoteCollection..::.Count Property
AllowedNoteCollection Class See Also Send Feedback
Gets the number of AllowedNote elements contained in the AllowedNoteCollection.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Return Value

The number of AllowedNote elements contained in the AllowedNoteCollection.

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

AllowedNoteCollection Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


IsReadOnly Property

[image]

LinkOne WebView API
AllowedNoteCollection..::.IsReadOnly Property
AllowedNoteCollection Class See Also Send Feedback
Gets a value indicating whether the AllowedNoteCollection is read-only.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Field Value

Return Value

true if the AllowedNoteCollection is read-only; otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

AllowedNoteCollection Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


Principal Class

[image]

LinkOne WebView API
Principal Class
Members See Also Send Feedback
This class identifies the current user and their access rights for LinkOne books.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class Principal : IPrincipal3, IPrincipal2,
    IPrincipal
Visual Basic (Declaration)
Public Class Principal _
    Implements IPrincipal3, IPrincipal2, IPrincipal
Visual C++
public ref class Principal : IPrincipal3,
    IPrincipal2, IPrincipal

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.Security..::.Principal

See Also

Principal Members
Mincom.LinkOne.WebView.WebServer.Security Namespace


Principal Members

[image] [image]

LinkOne WebView API
Principal Members
Principal Class Constructors Methods Properties See Also Send Feedback

The Principal type exposes the following members.

Constructors

Name | Description
Principal | Initializes a new instance of the Principal class.

Methods

Name | Description
CanAccessBook | Returns true if the wanted book can be accessed by the user.
CanAccessCategory | Returns true if the wanted category can be accessed by the user.
CanAccessNote | Returns true if the wanted note can be accessed by the user.
DrawPrintingOverLay |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IsPolicyAllowed | Returns true if the wanted policy is granted to the user.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
CacheKey | Gets a value that can be used as a caching key that identifies objects that can be shared between principals.
Licenses | Gets the licenses for the user.
PrivateNotesDirectory | Gets the private notes directory.
PublicNotesDirectory | Gets the public notes directory.
Security | Gets the provider associated with providing security for the user.
UserId | Gets the principal user id.

See Also

Principal Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


Principal Constructor

[image]

LinkOne WebView API
Principal Constructor
Principal Class See Also Send Feedback
Initializes a new instance of the Principal class.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Principal()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Principal()

See Also

Principal Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


Principal Methods

[image] [image]

LinkOne WebView API
Principal Methods
Principal Class See Also Send Feedback

The Principal type exposes the following members.

Methods

Name | Description
CanAccessBook | Returns true if the wanted book can be accessed by the user.
CanAccessCategory | Returns true if the wanted category can be accessed by the user.
CanAccessNote | Returns true if the wanted note can be accessed by the user.
DrawPrintingOverLay |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
IsPolicyAllowed | Returns true if the wanted policy is granted to the user.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Principal Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


CanAccessBook Method

[image]

LinkOne WebView API
Principal..::.CanAccessBook Method
Principal Class See Also Send Feedback
Returns true if the wanted book can be accessed by the user.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool CanAccessBook(
    string publisherCode,
    string bookCode,
    IList<string> categories
)
Visual Basic (Declaration)
Public Function CanAccessBook ( _
    publisherCode As String, _
    bookCode As String, _
    categories As IList(Of String) _
) As Boolean
Visual C++
public:
virtual bool CanAccessBook(
    String^ publisherCode,
    String^ bookCode,
    IList<String^>^ categories
) sealed

Parameters

publisherCode
Type: System..::.String
The publisher code of the book to test.
bookCode
Type: System..::.String
The book code of the book to test.
categories
Type: System.Collections.Generic..::.IList<(Of <(String>)>)
The category codes of the book to test.

Return Value

True if the wanted book can be accessed by the user.

Implements

IPrincipal..::.CanAccessBook(String, String, IList<(Of <(String>)>))

See Also

Principal Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


CanAccessCategory Method

[image]

LinkOne WebView API
Principal..::.CanAccessCategory Method
Principal Class See Also Send Feedback
Returns true if the wanted category can be accessed by the user.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool CanAccessCategory(
    ICategory category
)
Visual Basic (Declaration)
Public Function CanAccessCategory ( _
    category As ICategory _
) As Boolean
Visual C++
public:
virtual bool CanAccessCategory(
    ICategory^ category
) sealed

Parameters

category
Type: Mincom.LinkOne.Dom.Notes..::.ICategory
The category to test.

Return Value

True if the wanted category can be accessed by the user.

Implements

IPrincipal..::.CanAccessCategory(ICategory)

See Also

Principal Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


CanAccessNote Method

[image]

LinkOne WebView API
Principal..::.CanAccessNote Method
Principal Class See Also Send Feedback
Returns true if the wanted note can be accessed by the user.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool CanAccessNote(
    INote note
)
Visual Basic (Declaration)
Public Function CanAccessNote ( _
    note As INote _
) As Boolean
Visual C++
public:
virtual bool CanAccessNote(
    INote^ note
) sealed

Parameters

note
Type: Mincom.LinkOne.Dom.Notes..::.INote
The note to test.

Return Value

True if the wanted note can be accessed by the user.

Implements

IPrincipal..::.CanAccessNote(INote)

See Also

Principal Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


DrawPrintingOverLay Method

[image]

LinkOne WebView API
Principal..::.DrawPrintingOverLay Method
Principal Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void DrawPrintingOverLay(
    Graphics graphics
)
Visual Basic (Declaration)
Public Sub DrawPrintingOverLay ( _
    graphics As Graphics _
)
Visual C++
public:
virtual void DrawPrintingOverLay(
    Graphics^ graphics
) sealed

Parameters

graphics
Type: System.Drawing..::.Graphics

See Also

Principal Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


IsPolicyAllowed Method

[image]

LinkOne WebView API
Principal..::.IsPolicyAllowed Method
Principal Class See Also Send Feedback
Returns true if the wanted policy is granted to the user.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool IsPolicyAllowed(
    string policy
)
Visual Basic (Declaration)
Public Function IsPolicyAllowed ( _
    policy As String _
) As Boolean
Visual C++
public:
virtual bool IsPolicyAllowed(
    String^ policy
) sealed

Parameters

policy
Type: System..::.String
The policy to test.

Return Value

True if the wanted policy is granted to the user or a role the user is in.

Implements

IPrincipal..::.IsPolicyAllowed(String)

See Also

Principal Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


Principal Properties

[image] [image]

LinkOne WebView API
Principal Properties
Principal Class See Also Send Feedback

The Principal type exposes the following members.

Properties

Name | Description
CacheKey | Gets a value that can be used as a caching key that identifies objects that can be shared between principals.
Licenses | Gets the licenses for the user.
PrivateNotesDirectory | Gets the private notes directory.
PublicNotesDirectory | Gets the public notes directory.
Security | Gets the provider associated with providing security for the user.
UserId | Gets the principal user id.

See Also

Principal Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


CacheKey Property

[image]

LinkOne WebView API
Principal..::.CacheKey Property
Principal Class See Also Send Feedback
Gets a value that can be used as a caching key that identifies objects that can be shared between principals.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string CacheKey { get; }
Visual Basic (Declaration)
Public ReadOnly Property CacheKey As String
Visual C++
public:
virtual property String^ CacheKey {
    String^ get () sealed;
}

Implements

IPrincipal..::.CacheKey

See Also

Principal Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


Licenses Property

[image]

LinkOne WebView API
Principal..::.Licenses Property
Principal Class See Also Send Feedback
Gets the licenses for the user.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public IList<string> Licenses { get; }
Visual Basic (Declaration)
Public ReadOnly Property Licenses As IList(Of String)
Visual C++
public:
virtual property IList<String^>^ Licenses {
    IList<String^>^ get () sealed;
}

Implements

IPrincipal..::.Licenses

See Also

Principal Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


PrivateNotesDirectory Property

[image]

LinkOne WebView API
Principal..::.PrivateNotesDirectory Property
Principal Class See Also Send Feedback
Gets the private notes directory.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PrivateNotesDirectory { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrivateNotesDirectory As String
Visual C++
public:
virtual property String^ PrivateNotesDirectory {
    String^ get () sealed;
}

Implements

IPrincipal2..::.PrivateNotesDirectory

See Also

Principal Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


PublicNotesDirectory Property

[image]

LinkOne WebView API
Principal..::.PublicNotesDirectory Property
Principal Class See Also Send Feedback
Gets the public notes directory.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PublicNotesDirectory { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublicNotesDirectory As String
Visual C++
public:
virtual property String^ PublicNotesDirectory {
    String^ get () sealed;
}

Field Value

The public notes directory.

Implements

IPrincipal2..::.PublicNotesDirectory

See Also

Principal Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


Security Property

[image]

LinkOne WebView API
Principal..::.Security Property
Principal Class See Also Send Feedback
Gets the provider associated with providing security for the user.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Object Security { get; }
Visual Basic (Declaration)
Public ReadOnly Property Security As Object
Visual C++
public:
virtual property Object^ Security {
    Object^ get () sealed;
}

Implements

IPrincipal..::.Security

See Also

Principal Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


UserId Property

[image]

LinkOne WebView API
Principal..::.UserId Property
Principal Class See Also Send Feedback
Gets the principal user id.

Namespace: Mincom.LinkOne.WebView.WebServer.Security
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string UserId { get; }
Visual Basic (Declaration)
Public ReadOnly Property UserId As String
Visual C++
public:
virtual property String^ UserId {
    String^ get () sealed;
}

Implements

IPrincipal..::.UserId

See Also

Principal Class
Mincom.LinkOne.WebView.WebServer.Security Namespace


Mincom.LinkOne.WebView.WebServer.Services Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.WebView.WebServer.Services Namespace
Send Feedback
The Mincom.LinkOne.WebView.WebServer.Services namespace supplies classes that provide services for accessing and modifying state information on the LinkOne WebView web server.

Classes

Class | Description
BookService | This service provides access to all book resources.
ConfigurationManagerService | This service provides functionality for the configuration manager.
ErrorService | This service provides error handling and reporting functionality.
NoteService | This service provides access to all note resources.
OfflineDBService |
PrintService | This service provides access to all print resources.
ReportService | This service provides access to all reporting.
SearchService | This service provides search facilities.
SecurityService | This service provides access to the security settings.
SelectionListService | This service provides access to the user's selection list.
ServiceBase | Provides a base implementation for all services.
TokenService | Manages the website licensing and tokens.
WebConfigReader |
WebViewErrorLogEntry | Implements ErrorLogEntry for general error reporting within Web View services.


BookService Class

[image]

LinkOne WebView API
BookService Class
Members See Also Send Feedback
This service provides access to all book resources.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public sealed class BookService : ServiceBase
Visual Basic (Declaration)
Public NotInheritable Class BookService _
    Inherits ServiceBase
Visual C++
public ref class BookService sealed : public ServiceBase

Remarks

The service works on only one book, page, or resource at a time, based on the book, page, or resource specified in the current URL.

A book is expected to be specified with the argument book=?. Where ? is in the form publishercode/bookCode.

A page is expected to be specified with the argument page=?. Where ? is in the form pageReference.
Specifying a page also requires the book to be specified with the book argument.

A resource or picture is expected to be specified with the argument page=?. Where ? is in the form pageReference/resourceReference.
Specifying a resource also requires the book to be specified with the book argument.

Alternatively, a complete book, book and page, or book and page and resource, can be specified trailing the current page URL that is executing. For example, if the service is used from within the page example.aspx, then example.aspx/publisherCode/bookCode, or example.aspx/publisherCode/bookCode/pageReference, or example.aspx/publisherCode/bookCode/pageReference/resourceReference are all valid.

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.Services..::.ServiceBase
Mincom.LinkOne.WebView.WebServer.Services..::.BookService

See Also

BookService Members
Mincom.LinkOne.WebView.WebServer.Services Namespace


BookService Members

[image] [image]

LinkOne WebView API
BookService Members
BookService Class Constructors Methods Fields Properties See Also Send Feedback

The BookService type exposes the following members.

Constructors

Name | Description
BookService | Initializes a new instance of the BookService class.

Methods

Name | Description
AddLibrary | Adds a library.
ClearBookObjectCache |
DecreaseLibraryPriority | Decreases the library priority by moving it one position after in the managed library collection.
DeleteLibrary | Deletes a library.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBooksCount | Gets the count of installed books.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLibraries | Overloaded.
GetLibrariesCount | Gets the count of installed libraries.
GetOptionDefinitions | Gets the option definitions found in the current book.
GetParentPages | Gets the parent pages of the current page.
GetPublishersCount | Gets the count of installed publishers.
GetReferenceFromBookmark | Resolve the bookmark to it's final destination and return it as reference
GetRelatedLists | Gets the related pages of the current page.
GetType | Gets the type of the current instance. (Inherited from Object.)
GetValue | See [!:IBookService.GetValue] for more information.
IncreaseLibraryPriority | Increases the library priority by moving it one position before in the managed library collection.
IsBookExistInConfigManager |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrimeBookCache | Queues background loading of the given book. This primes the book cache in case the book is accessed soon afterwards. This is an experimental feature.
ReindexLibrary | Reindexes a library.
ResolveValues | Resolves the given string, replacing $value$ segments with the applicable value note.
SetReferenceFromBookmark | Resolve the bookmark to it's final destination and set it as the current reference
SyncLibrary | Sync a library.
ToString | Returns a string that represents the current object. (Inherited from Object.)
UpdateLibrary | Updates a library.
WriteBookResource | Writes the book resource specified in the request to the response.
WritePageResource | Writes the page resource specified in the request to the response.

Fields

Name | Description
KeyConfigLibraries |

Properties

Name | Description
BookCacheWindow | Controls the sliding duration for which books are cached in the Http cache (seconds).
BookCode | Gets or sets the book code request argument.
BookLocation | Gets or sets the book location for the current request.
BookObject | Gets the Book object for the current request.
BookResourceObject | Gets the book Resource object specified in the request.
BookResourceReference | Gets or sets the book resource reference request argument.
CacheAgeMinutes | Gets the time in minutes to cache written responses.
CacheDirectory | Gets or sets the cache directory.
CmsEnabled | Returns config setting that tell if CMS integration is enabled
Current | Gets the Book service for the current request.
DefaultCodePage | Gets or sets the default code page used for decoding book content.
EnableBackgroundBookCache | Gets or sets whether background book caching is enabled (during book browsing).
EntryObject | Gets the Entry object for the current request.
ExpandedNodes | Gets the expanded nodes dictionary.
FeedbackEmailFrom | Gets or sets the Feedback Email To.
FeedbackEmailTo | Gets or sets the Feedback Email To.
FeedbackEnabled | Gets Feedback enable config.
FeedbackEnableSSL | Gets or sets the Enable SSL.
FeedbackSMTPPassword | Gets or sets the SMTP Password.
FeedbackSMTPPort | Gets or sets the SMTP Port.
FeedbackSMTPServer | Gets or sets the SMTP Server.
FeedbackSMTPUserID | Gets or sets the SMTP UserID.
FeedbackTypesOfChange | Gets or sets the Feedback Types Of Change.
Filters | Gets the filters in use by the request.
GlobalPrintLayoutObject | Gets the global print Layout object for the current request.
GlobalScreenLayoutObject | Gets the global screen Layout object for the current request.
InkscapeApplicationPath |
InternalWebsiteHostName |
ItemId | Gets or sets the item id request argument.
LibraryObject | Gets the Library object for the current request.
MaximumConcurrentPictureConversions | Gets or sets the maximum concurrent picture conversions.
MaximumRasterPicturePixelDimension | Gets or sets the maximum raster picture pixel dimension.
MaximumVectorPicturePixelDimension | Gets or sets the maximum vector picture pixel dimension.
MinimumPictureZoomLevel | Gets the minimum picture zoom level.
NotificationsEnabled | Returns config setting that tells if Notifications is enabled
ObjectIdentifier | Gets or sets the configuration manager object identifier request argument
PageObject | Gets the Page object for the current request.
PageReference | Gets or sets the page reference request argument.
PageResourceObject | Gets the page Resource object specified in the request.
PhysicalCacheDirectory | Gets the physical location of the cache directory.
PhysicalUserLayoutsDirectory | Gets the physical location of the user layouts directory.
PictureNumber | Gets or sets the picture index request argument.
PictureObject | Gets the Picture object specified in the request.
PictureTileSize | Gets or sets the size of the picture tile.
PositionFormat | Gets or sets the required book position format for the clipboard.
PreferredGlobalPrintLayout |
PreferredGlobalScreenLayout |
PreferredLayoutCollection |
PreferredPrintLayout | Gets or sets the preferred print layout for the book for the current request.
PreferredPublisherPrintLayout | Gets or sets the preferred global print layout
PreferredPublisherScreenLayout | Gets or sets the preferred screen layout for the publisher
PreferredScreenLayout | Gets or sets the preferred screen layout for the book for the current request.
PrimeBookCacheWindow | Controls the sliding duration for which books are cached in the Http cache when loading via a prime cache call (seconds).
PrintLayoutObject | Gets the print Layout object for the current request.
PrintLayouts | Gets the collection of print layouts for the current view and language code.
PrintPictureResolution | Gets or sets the print resolution used when printing only pictures.
PrintResolution | Gets or sets the print resolution.
Provider | Gets the provider.
PublisherBookCode | Gets or sets the publisher/book code request argument.
PublisherCode | Gets or sets the publisher code request argument.
PublisherObject | Gets the Publisher object for the current request.
PublisherPrintLayoutObject | Gets the publisher print Layout object for the current request.
PublisherScreenLayoutObject | Gets the publisher screen Layout object for the current request.
Reference | Gets or sets the publisher/book/page/resource|itemid reference request argument.
ResourceReference | Gets or sets the resource reference request argument.
ScreenLayoutObject | Gets the screen Layout object for the current request.
ScreenLayouts | Gets the collection of screen layouts for the current view and language code.
UseJpegTilesForHighColourImages | Gets or sets whether to use jpeg tiles for high colour images
UserLayouts | Gets any user layouts.
UserLayoutsDirectory | Gets or sets the user layouts directory.
VectorToRasterConverterParameters | Gets the external vector to raster converter parameters to fix problems like in LO-165
VectorToRasterConverterPath | Gets the external vector to raster converter path to fix problems like in LO-165

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


BookService Constructor

[image]

LinkOne WebView API
BookService Constructor
BookService Class See Also Send Feedback
Initializes a new instance of the BookService class.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public BookService()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BookService()

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


BookService Fields

[image] [image]

LinkOne WebView API
BookService Fields
BookService Class See Also Send Feedback

The BookService type exposes the following members.

Fields

Name | Description
KeyConfigLibraries |

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


KeyConfigLibraries Field

[image]

LinkOne WebView API
BookService..::.KeyConfigLibraries Field
BookService Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public const string KeyConfigLibraries
Visual Basic (Declaration)
Public Const KeyConfigLibraries As String
Visual C++
public:
literal String^ KeyConfigLibraries

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


BookService Methods

[image] [image]

LinkOne WebView API
BookService Methods
BookService Class See Also Send Feedback

The BookService type exposes the following members.

Methods

Name | Description
AddLibrary | Adds a library.
ClearBookObjectCache |
DecreaseLibraryPriority | Decreases the library priority by moving it one position after in the managed library collection.
DeleteLibrary | Deletes a library.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBooksCount | Gets the count of installed books.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLibraries | Overloaded.
GetLibrariesCount | Gets the count of installed libraries.
GetOptionDefinitions | Gets the option definitions found in the current book.
GetParentPages | Gets the parent pages of the current page.
GetPublishersCount | Gets the count of installed publishers.
GetReferenceFromBookmark | Resolve the bookmark to it's final destination and return it as reference
GetRelatedLists | Gets the related pages of the current page.
GetType | Gets the type of the current instance. (Inherited from Object.)
GetValue | See [!:IBookService.GetValue] for more information.
IncreaseLibraryPriority | Increases the library priority by moving it one position before in the managed library collection.
IsBookExistInConfigManager |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrimeBookCache | Queues background loading of the given book. This primes the book cache in case the book is accessed soon afterwards. This is an experimental feature.
ReindexLibrary | Reindexes a library.
ResolveValues | Resolves the given string, replacing $value$ segments with the applicable value note.
SetReferenceFromBookmark | Resolve the bookmark to it's final destination and set it as the current reference
SyncLibrary | Sync a library.
ToString | Returns a string that represents the current object. (Inherited from Object.)
UpdateLibrary | Updates a library.
WriteBookResource | Writes the book resource specified in the request to the response.
WritePageResource | Writes the page resource specified in the request to the response.

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


AddLibrary Method

[image]

LinkOne WebView API
BookService..::.AddLibrary Method
BookService Class See Also Send Feedback
Adds a library.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void AddLibrary(
    string location
)
Visual Basic (Declaration)
Public Sub AddLibrary ( _
    location As String _
)
Visual C++
public:
void AddLibrary(
    String^ location
)

Parameters

location
Type: System..::.String
The library folder.

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ClearBookObjectCache Method

[image]

LinkOne WebView API
BookService..::.ClearBookObjectCache Method
BookService Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void ClearBookObjectCache()
Visual Basic (Declaration)
Public Sub ClearBookObjectCache
Visual C++
public:
void ClearBookObjectCache()

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


DecreaseLibraryPriority Method

[image]

LinkOne WebView API
BookService..::.DecreaseLibraryPriority Method
BookService Class See Also Send Feedback
Decreases the library priority by moving it one position after in the managed library collection.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void DecreaseLibraryPriority(
    string location
)
Visual Basic (Declaration)
Public Sub DecreaseLibraryPriority ( _
    location As String _
)
Visual C++
public:
void DecreaseLibraryPriority(
    String^ location
)

Parameters

location
Type: System..::.String
The path to the IPersistLibrary to index.

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


DeleteLibrary Method

[image]

LinkOne WebView API
BookService..::.DeleteLibrary Method
BookService Class See Also Send Feedback
Deletes a library.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool DeleteLibrary(
    string location
)
Visual Basic (Declaration)
Public Function DeleteLibrary ( _
    location As String _
) As Boolean
Visual C++
public:
bool DeleteLibrary(
    String^ location
)

Parameters

location
Type: System..::.String
The library location.

Return Value

A value indicating whether the library path was removed.

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


GetBooksCount Method

[image]

LinkOne WebView API
BookService..::.GetBooksCount Method
BookService Class See Also Send Feedback
Gets the count of installed books.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int GetBooksCount()
Visual Basic (Declaration)
Public Function GetBooksCount As Integer
Visual C++
public:
int GetBooksCount()

Return Value

The count of installed books.

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


GetLibraries Method

[image] [image]

LinkOne WebView API
BookService..::.GetLibraries Method
BookService Class See Also Send Feedback

Overload List

Name | Description
GetLibraries()()() | Gets an enumeration of installed libraries.
GetLibraries(String) | Gets an enumeration of installed libraries.

See Also

BookService Class
BookService Members
Mincom.LinkOne.WebView.WebServer.Services Namespace


GetLibraries Method

[image]

LinkOne WebView API
BookService..::.GetLibraries Method
BookService Class See Also Send Feedback
Gets an enumeration of installed libraries.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public IPersistLibrary[] GetLibraries()
Visual Basic (Declaration)
Public Function GetLibraries As IPersistLibrary()
Visual C++
public:
array<IPersistLibrary^>^ GetLibraries()

See Also

BookService Class
GetLibraries Overload
Mincom.LinkOne.WebView.WebServer.Services Namespace


GetLibraries Method (String)

[image]

LinkOne WebView API
BookService..::.GetLibraries Method (String)
BookService Class See Also Send Feedback
Gets an enumeration of installed libraries.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public IPersistLibrary[] GetLibraries(
    string filterText
)
Visual Basic (Declaration)
Public Function GetLibraries ( _
    filterText As String _
) As IPersistLibrary()
Visual C++
public:
array<IPersistLibrary^>^ GetLibraries(
    String^ filterText
)

Parameters

filterText
Type: System..::.String

See Also

BookService Class
GetLibraries Overload
Mincom.LinkOne.WebView.WebServer.Services Namespace


GetLibrariesCount Method

[image]

LinkOne WebView API
BookService..::.GetLibrariesCount Method
BookService Class See Also Send Feedback
Gets the count of installed libraries.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int GetLibrariesCount()
Visual Basic (Declaration)
Public Function GetLibrariesCount As Integer
Visual C++
public:
int GetLibrariesCount()

Return Value

The count of installed libraries.

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


GetOptionDefinitions Method

[image]

LinkOne WebView API
BookService..::.GetOptionDefinitions Method
BookService Class See Also Send Feedback
Gets the option definitions found in the current book.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public IEnumerable<OptionDefinition> GetOptionDefinitions()
Visual Basic (Declaration)
Public Function GetOptionDefinitions As IEnumerable(Of OptionDefinition)
Visual C++
public:
IEnumerable<OptionDefinition^>^ GetOptionDefinitions()

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


GetParentPages Method

[image]

LinkOne WebView API
BookService..::.GetParentPages Method
BookService Class See Also Send Feedback
Gets the parent pages of the current page.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public IEnumerable<Page> GetParentPages()
Visual Basic (Declaration)
Public Function GetParentPages As IEnumerable(Of Page)
Visual C++
public:
IEnumerable<Page^>^ GetParentPages()

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


GetPublishersCount Method

[image]

LinkOne WebView API
BookService..::.GetPublishersCount Method
BookService Class See Also Send Feedback
Gets the count of installed publishers.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int GetPublishersCount()
Visual Basic (Declaration)
Public Function GetPublishersCount As Integer
Visual C++
public:
int GetPublishersCount()

Return Value

The count of installed publishers.

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


GetReferenceFromBookmark Method

[image]

LinkOne WebView API
BookService..::.GetReferenceFromBookmark Method
BookService Class See Also Send Feedback
Resolve the bookmark to it's final destination and return it as reference

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string GetReferenceFromBookmark(
    string publisherCode,
    string bookCode,
    string bookmarkName
)
Visual Basic (Declaration)
Public Function GetReferenceFromBookmark ( _
    publisherCode As String, _
    bookCode As String, _
    bookmarkName As String _
) As String
Visual C++
public:
String^ GetReferenceFromBookmark(
    String^ publisherCode,
    String^ bookCode,
    String^ bookmarkName
)

Parameters

publisherCode
Type: System..::.String
bookCode
Type: System..::.String
bookmarkName
Type: System..::.String

Return Value

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


GetRelatedLists Method

[image]

LinkOne WebView API
BookService..::.GetRelatedLists Method
BookService Class See Also Send Feedback
Gets the related pages of the current page.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public IEnumerable<Page> GetRelatedLists()
Visual Basic (Declaration)
Public Function GetRelatedLists As IEnumerable(Of Page)
Visual C++
public:
IEnumerable<Page^>^ GetRelatedLists()

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


GetValue Method

[image]

LinkOne WebView API
BookService..::.GetValue Method
BookService Class See Also Send Feedback
See [!:IBookService.GetValue] for more information.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string GetValue(
    string name
)
Visual Basic (Declaration)
Public Function GetValue ( _
    name As String _
) As String
Visual C++
public:
String^ GetValue(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


IncreaseLibraryPriority Method

[image]

LinkOne WebView API
BookService..::.IncreaseLibraryPriority Method
BookService Class See Also Send Feedback
Increases the library priority by moving it one position before in the managed library collection.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void IncreaseLibraryPriority(
    string location
)
Visual Basic (Declaration)
Public Sub IncreaseLibraryPriority ( _
    location As String _
)
Visual C++
public:
void IncreaseLibraryPriority(
    String^ location
)

Parameters

location
Type: System..::.String
The path to the IPersistLibrary to index.

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


IsBookExistInConfigManager Method

[image]

LinkOne WebView API
BookService..::.IsBookExistInConfigManager Method
BookService Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool IsBookExistInConfigManager()
Visual Basic (Declaration)
Public Function IsBookExistInConfigManager As Boolean
Visual C++
public:
bool IsBookExistInConfigManager()

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PrimeBookCache Method

[image]

LinkOne WebView API
BookService..::.PrimeBookCache Method
BookService Class See Also Send Feedback
Queues background loading of the given book. This primes the book cache in case the book is accessed soon afterwards. This is an experimental feature.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void PrimeBookCache(
    string publisherCode,
    string bookCode,
    string languageCode
)
Visual Basic (Declaration)
Public Sub PrimeBookCache ( _
    publisherCode As String, _
    bookCode As String, _
    languageCode As String _
)
Visual C++
public:
void PrimeBookCache(
    String^ publisherCode,
    String^ bookCode,
    String^ languageCode
)

Parameters

publisherCode
Type: System..::.String
Publisher code of the book to load.
bookCode
Type: System..::.String
Book code of the book to load.
languageCode
Type: System..::.String
Language code to load the book with. Can be retrieved from [!:BookService.Current.LanguageCode].

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ReindexLibrary Method

[image]

LinkOne WebView API
BookService..::.ReindexLibrary Method
BookService Class See Also Send Feedback
Reindexes a library.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool ReindexLibrary(
    string location
)
Visual Basic (Declaration)
Public Function ReindexLibrary ( _
    location As String _
) As Boolean
Visual C++
public:
bool ReindexLibrary(
    String^ location
)

Parameters

location
Type: System..::.String
The library path.

Return Value

true if the reindex succeeded, false otherwise

Exceptions

Exception | Condition
System..::.ArgumentException | If the requested library is not found.

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ResolveValues Method

[image]

LinkOne WebView API
BookService..::.ResolveValues Method
BookService Class See Also Send Feedback
Resolves the given string, replacing $value$ segments with the applicable value note.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string ResolveValues(
    string unresolved
)
Visual Basic (Declaration)
Public Function ResolveValues ( _
    unresolved As String _
) As String
Visual C++
public:
String^ ResolveValues(
    String^ unresolved
)

Parameters

unresolved
Type: System..::.String
The unresolved string to resolve.

Return Value

The resolved string.

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


SetReferenceFromBookmark Method

[image]

LinkOne WebView API
BookService..::.SetReferenceFromBookmark Method
BookService Class See Also Send Feedback
Resolve the bookmark to it's final destination and set it as the current reference

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool SetReferenceFromBookmark(
    string publisherCode,
    string bookCode,
    string bookmarkName
)
Visual Basic (Declaration)
Public Function SetReferenceFromBookmark ( _
    publisherCode As String, _
    bookCode As String, _
    bookmarkName As String _
) As Boolean
Visual C++
public:
bool SetReferenceFromBookmark(
    String^ publisherCode,
    String^ bookCode,
    String^ bookmarkName
)

Parameters

publisherCode
Type: System..::.String
the publisher the bookmark is in
bookCode
Type: System..::.String
the book the bookmark is in
bookmarkName
Type: System..::.String
the name of the bookmark

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


SyncLibrary Method

[image]

LinkOne WebView API
BookService..::.SyncLibrary Method
BookService Class See Also Send Feedback
Sync a library.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void SyncLibrary(
    string location,
    string syncLocation
)
Visual Basic (Declaration)
Public Sub SyncLibrary ( _
    location As String, _
    syncLocation As String _
)
Visual C++
public:
void SyncLibrary(
    String^ location,
    String^ syncLocation
)

Parameters

location
Type: System..::.String
The library path.
syncLocation
Type: System..::.String
The optional location of the library to synchronise with.

Exceptions

Exception | Condition
System..::.ArgumentException | If the requested library is not found.

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


UpdateLibrary Method

[image]

LinkOne WebView API
BookService..::.UpdateLibrary Method
BookService Class See Also Send Feedback
Updates a library.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void UpdateLibrary(
    string location,
    bool enabled
)
Visual Basic (Declaration)
Public Sub UpdateLibrary ( _
    location As String, _
    enabled As Boolean _
)
Visual C++
public:
void UpdateLibrary(
    String^ location,
    bool enabled
)

Parameters

location
Type: System..::.String
The library path.
enabled
Type: System..::.Boolean
Whether the library is enabled.

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


WriteBookResource Method

[image]

LinkOne WebView API
BookService..::.WriteBookResource Method
BookService Class See Also Send Feedback
Writes the book resource specified in the request to the response.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public HttpStatusCode WriteBookResource()
Visual Basic (Declaration)
Public Function WriteBookResource As HttpStatusCode
Visual C++
public:
HttpStatusCode WriteBookResource()

Return Value

The HTTP response code for the written content.

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


WritePageResource Method

[image]

LinkOne WebView API
BookService..::.WritePageResource Method
BookService Class See Also Send Feedback
Writes the page resource specified in the request to the response.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public HttpStatusCode WritePageResource()
Visual Basic (Declaration)
Public Function WritePageResource As HttpStatusCode
Visual C++
public:
HttpStatusCode WritePageResource()

Return Value

The HTTP response code for the written content.

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


BookService Properties

[image] [image]

LinkOne WebView API
BookService Properties
BookService Class See Also Send Feedback

The BookService type exposes the following members.

Properties

Name | Description
BookCacheWindow | Controls the sliding duration for which books are cached in the Http cache (seconds).
BookCode | Gets or sets the book code request argument.
BookLocation | Gets or sets the book location for the current request.
BookObject | Gets the Book object for the current request.
BookResourceObject | Gets the book Resource object specified in the request.
BookResourceReference | Gets or sets the book resource reference request argument.
CacheAgeMinutes | Gets the time in minutes to cache written responses.
CacheDirectory | Gets or sets the cache directory.
CmsEnabled | Returns config setting that tell if CMS integration is enabled
Current | Gets the Book service for the current request.
DefaultCodePage | Gets or sets the default code page used for decoding book content.
EnableBackgroundBookCache | Gets or sets whether background book caching is enabled (during book browsing).
EntryObject | Gets the Entry object for the current request.
ExpandedNodes | Gets the expanded nodes dictionary.
FeedbackEmailFrom | Gets or sets the Feedback Email To.
FeedbackEmailTo | Gets or sets the Feedback Email To.
FeedbackEnabled | Gets Feedback enable config.
FeedbackEnableSSL | Gets or sets the Enable SSL.
FeedbackSMTPPassword | Gets or sets the SMTP Password.
FeedbackSMTPPort | Gets or sets the SMTP Port.
FeedbackSMTPServer | Gets or sets the SMTP Server.
FeedbackSMTPUserID | Gets or sets the SMTP UserID.
FeedbackTypesOfChange | Gets or sets the Feedback Types Of Change.
Filters | Gets the filters in use by the request.
GlobalPrintLayoutObject | Gets the global print Layout object for the current request.
GlobalScreenLayoutObject | Gets the global screen Layout object for the current request.
InkscapeApplicationPath |
InternalWebsiteHostName |
ItemId | Gets or sets the item id request argument.
LibraryObject | Gets the Library object for the current request.
MaximumConcurrentPictureConversions | Gets or sets the maximum concurrent picture conversions.
MaximumRasterPicturePixelDimension | Gets or sets the maximum raster picture pixel dimension.
MaximumVectorPicturePixelDimension | Gets or sets the maximum vector picture pixel dimension.
MinimumPictureZoomLevel | Gets the minimum picture zoom level.
NotificationsEnabled | Returns config setting that tells if Notifications is enabled
ObjectIdentifier | Gets or sets the configuration manager object identifier request argument
PageObject | Gets the Page object for the current request.
PageReference | Gets or sets the page reference request argument.
PageResourceObject | Gets the page Resource object specified in the request.
PhysicalCacheDirectory | Gets the physical location of the cache directory.
PhysicalUserLayoutsDirectory | Gets the physical location of the user layouts directory.
PictureNumber | Gets or sets the picture index request argument.
PictureObject | Gets the Picture object specified in the request.
PictureTileSize | Gets or sets the size of the picture tile.
PositionFormat | Gets or sets the required book position format for the clipboard.
PreferredGlobalPrintLayout |
PreferredGlobalScreenLayout |
PreferredLayoutCollection |
PreferredPrintLayout | Gets or sets the preferred print layout for the book for the current request.
PreferredPublisherPrintLayout | Gets or sets the preferred global print layout
PreferredPublisherScreenLayout | Gets or sets the preferred screen layout for the publisher
PreferredScreenLayout | Gets or sets the preferred screen layout for the book for the current request.
PrimeBookCacheWindow | Controls the sliding duration for which books are cached in the Http cache when loading via a prime cache call (seconds).
PrintLayoutObject | Gets the print Layout object for the current request.
PrintLayouts | Gets the collection of print layouts for the current view and language code.
PrintPictureResolution | Gets or sets the print resolution used when printing only pictures.
PrintResolution | Gets or sets the print resolution.
Provider | Gets the provider.
PublisherBookCode | Gets or sets the publisher/book code request argument.
PublisherCode | Gets or sets the publisher code request argument.
PublisherObject | Gets the Publisher object for the current request.
PublisherPrintLayoutObject | Gets the publisher print Layout object for the current request.
PublisherScreenLayoutObject | Gets the publisher screen Layout object for the current request.
Reference | Gets or sets the publisher/book/page/resource|itemid reference request argument.
ResourceReference | Gets or sets the resource reference request argument.
ScreenLayoutObject | Gets the screen Layout object for the current request.
ScreenLayouts | Gets the collection of screen layouts for the current view and language code.
UseJpegTilesForHighColourImages | Gets or sets whether to use jpeg tiles for high colour images
UserLayouts | Gets any user layouts.
UserLayoutsDirectory | Gets or sets the user layouts directory.
VectorToRasterConverterParameters | Gets the external vector to raster converter parameters to fix problems like in LO-165
VectorToRasterConverterPath | Gets the external vector to raster converter path to fix problems like in LO-165

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


BookCacheWindow Property

[image]

LinkOne WebView API
BookService..::.BookCacheWindow Property
BookService Class See Also Send Feedback
Controls the sliding duration for which books are cached in the Http cache (seconds).

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public double BookCacheWindow { get; set; }
Visual Basic (Declaration)
Public Property BookCacheWindow As Double
Visual C++
public:
property double BookCacheWindow {
    double get ();
    void set (double value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


BookCode Property

[image]

LinkOne WebView API
BookService..::.BookCode Property
BookService Class See Also Send Feedback
Gets or sets the book code request argument.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string BookCode { get; set; }
Visual Basic (Declaration)
Public Property BookCode As String
Visual C++
public:
property String^ BookCode {
    String^ get ();
    void set (String^ value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


BookLocation Property

[image]

LinkOne WebView API
BookService..::.BookLocation Property
BookService Class See Also Send Feedback
Gets or sets the book location for the current request.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string BookLocation { get; }
Visual Basic (Declaration)
Public ReadOnly Property BookLocation As String
Visual C++
public:
property String^ BookLocation {
    String^ get ();
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


BookObject Property

[image]

LinkOne WebView API
BookService..::.BookObject Property
BookService Class See Also Send Feedback
Gets the Book object for the current request.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Book BookObject { get; }
Visual Basic (Declaration)
Public ReadOnly Property BookObject As Book
Visual C++
public:
property Book^ BookObject {
    Book^ get ();
}

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.BookNotFoundException | If the reguested book is not found.
[!:BookDraftException] | If the reguested book is in draft mode and a suitable licence (Mincom Open Viewer) is not found.

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


BookResourceObject Property

[image]

LinkOne WebView API
BookService..::.BookResourceObject Property
BookService Class See Also Send Feedback
Gets the book Resource object specified in the request.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Resource BookResourceObject { get; }
Visual Basic (Declaration)
Public ReadOnly Property BookResourceObject As Resource
Visual C++
public:
property Resource^ BookResourceObject {
    Resource^ get ();
}

Remarks

Access to this property requires Authorized to be true.

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


BookResourceReference Property

[image]

LinkOne WebView API
BookService..::.BookResourceReference Property
BookService Class See Also Send Feedback
Gets or sets the book resource reference request argument.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string BookResourceReference { get; set; }
Visual Basic (Declaration)
Public Property BookResourceReference As String
Visual C++
public:
property String^ BookResourceReference {
    String^ get ();
    void set (String^ value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


CacheAgeMinutes Property

[image]

LinkOne WebView API
BookService..::.CacheAgeMinutes Property
BookService Class See Also Send Feedback
Gets the time in minutes to cache written responses.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int CacheAgeMinutes { get; set; }
Visual Basic (Declaration)
Public Property CacheAgeMinutes As Integer
Visual C++
public:
property int CacheAgeMinutes {
    int get ();
    void set (int value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


CacheDirectory Property

[image]

LinkOne WebView API
BookService..::.CacheDirectory Property
BookService Class See Also Send Feedback
Gets or sets the cache directory.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string CacheDirectory { get; set; }
Visual Basic (Declaration)
Public Property CacheDirectory As String
Visual C++
public:
property String^ CacheDirectory {
    String^ get ();
    void set (String^ value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


CmsEnabled Property

[image]

LinkOne WebView API
BookService..::.CmsEnabled Property
BookService Class See Also Send Feedback
Returns config setting that tell if CMS integration is enabled

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool CmsEnabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property CmsEnabled As Boolean
Visual C++
public:
property bool CmsEnabled {
    bool get ();
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


Current Property

[image]

LinkOne WebView API
BookService..::.Current Property
BookService Class See Also Send Feedback
Gets the Book service for the current request.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public static BookService Current { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Current As BookService
Visual C++
public:
static property BookService^ Current {
    BookService^ get ();
}

Return Value

The Book service for the current request.

Remarks

A Book service object is automatically associated with each request to the web server, and may be obtained by calling this static method.

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


DefaultCodePage Property

[image]

LinkOne WebView API
BookService..::.DefaultCodePage Property
BookService Class See Also Send Feedback
Gets or sets the default code page used for decoding book content.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int DefaultCodePage { get; set; }
Visual Basic (Declaration)
Public Property DefaultCodePage As Integer
Visual C++
public:
property int DefaultCodePage {
    int get ();
    void set (int value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


EnableBackgroundBookCache Property

[image]

LinkOne WebView API
BookService..::.EnableBackgroundBookCache Property
BookService Class See Also Send Feedback
Gets or sets whether background book caching is enabled (during book browsing).

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool EnableBackgroundBookCache { get; set; }
Visual Basic (Declaration)
Public Property EnableBackgroundBookCache As Boolean
Visual C++
public:
property bool EnableBackgroundBookCache {
    bool get ();
    void set (bool value);
}

Remarks

This is used in PrimeBookCache(String, String, String), which should be called in the book browser and elsewhere when a small set of books which the user may open is available.

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


EntryObject Property

[image]

LinkOne WebView API
BookService..::.EntryObject Property
BookService Class See Also Send Feedback
Gets the Entry object for the current request.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Entry EntryObject { get; }
Visual Basic (Declaration)
Public ReadOnly Property EntryObject As Entry
Visual C++
public:
property Entry^ EntryObject {
    Entry^ get ();
}

Remarks

Access to this property requires Authorized to be true.

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ExpandedNodes Property

[image]

LinkOne WebView API
BookService..::.ExpandedNodes Property
BookService Class See Also Send Feedback
Gets the expanded nodes dictionary.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public IDictionary<string, IList<string>> ExpandedNodes { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExpandedNodes As IDictionary(Of String, IList(Of String))
Visual C++
public:
property IDictionary<String^, IList<String^>^>^ ExpandedNodes {
    IDictionary<String^, IList<String^>^>^ get ();
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


FeedbackEmailFrom Property

[image]

LinkOne WebView API
BookService..::.FeedbackEmailFrom Property
BookService Class See Also Send Feedback
Gets or sets the Feedback Email To.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string FeedbackEmailFrom { get; set; }
Visual Basic (Declaration)
Public Property FeedbackEmailFrom As String
Visual C++
public:
property String^ FeedbackEmailFrom {
    String^ get ();
    void set (String^ value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


FeedbackEmailTo Property

[image]

LinkOne WebView API
BookService..::.FeedbackEmailTo Property
BookService Class See Also Send Feedback
Gets or sets the Feedback Email To.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string FeedbackEmailTo { get; set; }
Visual Basic (Declaration)
Public Property FeedbackEmailTo As String
Visual C++
public:
property String^ FeedbackEmailTo {
    String^ get ();
    void set (String^ value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


FeedbackEnabled Property

[image]

LinkOne WebView API
BookService..::.FeedbackEnabled Property
BookService Class See Also Send Feedback
Gets Feedback enable config.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool FeedbackEnabled { get; set; }
Visual Basic (Declaration)
Public Property FeedbackEnabled As Boolean
Visual C++
public:
property bool FeedbackEnabled {
    bool get ();
    void set (bool value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


FeedbackEnableSSL Property

[image]

LinkOne WebView API
BookService..::.FeedbackEnableSSL Property
BookService Class See Also Send Feedback
Gets or sets the Enable SSL.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool FeedbackEnableSSL { get; set; }
Visual Basic (Declaration)
Public Property FeedbackEnableSSL As Boolean
Visual C++
public:
property bool FeedbackEnableSSL {
    bool get ();
    void set (bool value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


FeedbackSMTPPassword Property

[image]

LinkOne WebView API
BookService..::.FeedbackSMTPPassword Property
BookService Class See Also Send Feedback
Gets or sets the SMTP Password.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string FeedbackSMTPPassword { get; set; }
Visual Basic (Declaration)
Public Property FeedbackSMTPPassword As String
Visual C++
public:
property String^ FeedbackSMTPPassword {
    String^ get ();
    void set (String^ value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


FeedbackSMTPPort Property

[image]

LinkOne WebView API
BookService..::.FeedbackSMTPPort Property
BookService Class See Also Send Feedback
Gets or sets the SMTP Port.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string FeedbackSMTPPort { get; set; }
Visual Basic (Declaration)
Public Property FeedbackSMTPPort As String
Visual C++
public:
property String^ FeedbackSMTPPort {
    String^ get ();
    void set (String^ value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


FeedbackSMTPServer Property

[image]

LinkOne WebView API
BookService..::.FeedbackSMTPServer Property
BookService Class See Also Send Feedback
Gets or sets the SMTP Server.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string FeedbackSMTPServer { get; set; }
Visual Basic (Declaration)
Public Property FeedbackSMTPServer As String
Visual C++
public:
property String^ FeedbackSMTPServer {
    String^ get ();
    void set (String^ value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


FeedbackSMTPUserID Property

[image]

LinkOne WebView API
BookService..::.FeedbackSMTPUserID Property
BookService Class See Also Send Feedback
Gets or sets the SMTP UserID.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string FeedbackSMTPUserID { get; set; }
Visual Basic (Declaration)
Public Property FeedbackSMTPUserID As String
Visual C++
public:
property String^ FeedbackSMTPUserID {
    String^ get ();
    void set (String^ value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


FeedbackTypesOfChange Property

[image]

LinkOne WebView API
BookService..::.FeedbackTypesOfChange Property
BookService Class See Also Send Feedback
Gets or sets the Feedback Types Of Change.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string FeedbackTypesOfChange { get; set; }
Visual Basic (Declaration)
Public Property FeedbackTypesOfChange As String
Visual C++
public:
property String^ FeedbackTypesOfChange {
    String^ get ();
    void set (String^ value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


Filters Property

[image]

LinkOne WebView API
BookService..::.Filters Property
BookService Class See Also Send Feedback
Gets the filters in use by the request.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public FilterCollection Filters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Filters As FilterCollection
Visual C++
public:
property FilterCollection^ Filters {
    FilterCollection^ get ();
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


GlobalPrintLayoutObject Property

[image]

LinkOne WebView API
BookService..::.GlobalPrintLayoutObject Property
BookService Class See Also Send Feedback
Gets the global print Layout object for the current request.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Layout GlobalPrintLayoutObject { get; }
Visual Basic (Declaration)
Public ReadOnly Property GlobalPrintLayoutObject As Layout
Visual C++
public:
property Layout^ GlobalPrintLayoutObject {
    Layout^ get ();
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


GlobalScreenLayoutObject Property

[image]

LinkOne WebView API
BookService..::.GlobalScreenLayoutObject Property
BookService Class See Also Send Feedback
Gets the global screen Layout object for the current request.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Layout GlobalScreenLayoutObject { get; }
Visual Basic (Declaration)
Public ReadOnly Property GlobalScreenLayoutObject As Layout
Visual C++
public:
property Layout^ GlobalScreenLayoutObject {
    Layout^ get ();
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


InkscapeApplicationPath Property

[image]

LinkOne WebView API
BookService..::.InkscapeApplicationPath Property
BookService Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string InkscapeApplicationPath { get; set; }
Visual Basic (Declaration)
Public Property InkscapeApplicationPath As String
Visual C++
public:
property String^ InkscapeApplicationPath {
    String^ get ();
    void set (String^ value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


InternalWebsiteHostName Property

[image]

LinkOne WebView API
BookService..::.InternalWebsiteHostName Property
BookService Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string InternalWebsiteHostName { get; set; }
Visual Basic (Declaration)
Public Property InternalWebsiteHostName As String
Visual C++
public:
property String^ InternalWebsiteHostName {
    String^ get ();
    void set (String^ value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ItemId Property

[image]

LinkOne WebView API
BookService..::.ItemId Property
BookService Class See Also Send Feedback
Gets or sets the item id request argument.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string ItemId { get; set; }
Visual Basic (Declaration)
Public Property ItemId As String
Visual C++
public:
property String^ ItemId {
    String^ get ();
    void set (String^ value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


LibraryObject Property

[image]

LinkOne WebView API
BookService..::.LibraryObject Property
BookService Class See Also Send Feedback
Gets the Library object for the current request.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Library LibraryObject { get; }
Visual Basic (Declaration)
Public ReadOnly Property LibraryObject As Library
Visual C++
public:
property Library^ LibraryObject {
    Library^ get ();
}

Remarks

Access to this property requires Authorized to be true.

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


MaximumConcurrentPictureConversions Property

[image]

LinkOne WebView API
BookService..::.MaximumConcurrentPictureConversions Property
BookService Class See Also Send Feedback
Gets or sets the maximum concurrent picture conversions.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int MaximumConcurrentPictureConversions { get; set; }
Visual Basic (Declaration)
Public Property MaximumConcurrentPictureConversions As Integer
Visual C++
public:
property int MaximumConcurrentPictureConversions {
    int get ();
    void set (int value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


MaximumRasterPicturePixelDimension Property

[image]

LinkOne WebView API
BookService..::.MaximumRasterPicturePixelDimension Property
BookService Class See Also Send Feedback
Gets or sets the maximum raster picture pixel dimension.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int MaximumRasterPicturePixelDimension { get; set; }
Visual Basic (Declaration)
Public Property MaximumRasterPicturePixelDimension As Integer
Visual C++
public:
property int MaximumRasterPicturePixelDimension {
    int get ();
    void set (int value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


MaximumVectorPicturePixelDimension Property

[image]

LinkOne WebView API
BookService..::.MaximumVectorPicturePixelDimension Property
BookService Class See Also Send Feedback
Gets or sets the maximum vector picture pixel dimension.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int MaximumVectorPicturePixelDimension { get; set; }
Visual Basic (Declaration)
Public Property MaximumVectorPicturePixelDimension As Integer
Visual C++
public:
property int MaximumVectorPicturePixelDimension {
    int get ();
    void set (int value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


MinimumPictureZoomLevel Property

[image]

LinkOne WebView API
BookService..::.MinimumPictureZoomLevel Property
BookService Class See Also Send Feedback
Gets the minimum picture zoom level.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int MinimumPictureZoomLevel { get; }
Visual Basic (Declaration)
Public ReadOnly Property MinimumPictureZoomLevel As Integer
Visual C++
public:
property int MinimumPictureZoomLevel {
    int get ();
}

Field Value

The minimum picture zoom level.

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


NotificationsEnabled Property

[image]

LinkOne WebView API
BookService..::.NotificationsEnabled Property
BookService Class See Also Send Feedback
Returns config setting that tells if Notifications is enabled

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool NotificationsEnabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property NotificationsEnabled As Boolean
Visual C++
public:
property bool NotificationsEnabled {
    bool get ();
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ObjectIdentifier Property

[image]

LinkOne WebView API
BookService..::.ObjectIdentifier Property
BookService Class See Also Send Feedback
Gets or sets the configuration manager object identifier request argument

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string ObjectIdentifier { get; set; }
Visual Basic (Declaration)
Public Property ObjectIdentifier As String
Visual C++
public:
property String^ ObjectIdentifier {
    String^ get ();
    void set (String^ value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PageObject Property

[image]

LinkOne WebView API
BookService..::.PageObject Property
BookService Class See Also Send Feedback
Gets the Page object for the current request.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Page PageObject { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageObject As Page
Visual C++
public:
property Page^ PageObject {
    Page^ get ();
}

Remarks

Access to this property requires Authorized to be true.

Exceptions

Exception | Condition
Mincom.LinkOne.Exceptions..::.PageNotFoundException | If the reguested page is not found.

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PageReference Property

[image]

LinkOne WebView API
BookService..::.PageReference Property
BookService Class See Also Send Feedback
Gets or sets the page reference request argument.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PageReference { get; set; }
Visual Basic (Declaration)
Public Property PageReference As String
Visual C++
public:
property String^ PageReference {
    String^ get ();
    void set (String^ value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PageResourceObject Property

[image]

LinkOne WebView API
BookService..::.PageResourceObject Property
BookService Class See Also Send Feedback
Gets the page Resource object specified in the request.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Resource PageResourceObject { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageResourceObject As Resource
Visual C++
public:
property Resource^ PageResourceObject {
    Resource^ get ();
}

Remarks

Access to this property requires Authorized to be true.

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PhysicalCacheDirectory Property

[image]

LinkOne WebView API
BookService..::.PhysicalCacheDirectory Property
BookService Class See Also Send Feedback
Gets the physical location of the cache directory.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PhysicalCacheDirectory { get; }
Visual Basic (Declaration)
Public ReadOnly Property PhysicalCacheDirectory As String
Visual C++
public:
property String^ PhysicalCacheDirectory {
    String^ get ();
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PhysicalUserLayoutsDirectory Property

[image]

LinkOne WebView API
BookService..::.PhysicalUserLayoutsDirectory Property
BookService Class See Also Send Feedback
Gets the physical location of the user layouts directory.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PhysicalUserLayoutsDirectory { get; }
Visual Basic (Declaration)
Public ReadOnly Property PhysicalUserLayoutsDirectory As String
Visual C++
public:
property String^ PhysicalUserLayoutsDirectory {
    String^ get ();
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PictureNumber Property

[image]

LinkOne WebView API
BookService..::.PictureNumber Property
BookService Class See Also Send Feedback
Gets or sets the picture index request argument.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int PictureNumber { get; set; }
Visual Basic (Declaration)
Public Property PictureNumber As Integer
Visual C++
public:
property int PictureNumber {
    int get ();
    void set (int value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PictureObject Property

[image]

LinkOne WebView API
BookService..::.PictureObject Property
BookService Class See Also Send Feedback
Gets the Picture object specified in the request.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Picture PictureObject { get; }
Visual Basic (Declaration)
Public ReadOnly Property PictureObject As Picture
Visual C++
public:
property Picture^ PictureObject {
    Picture^ get ();
}

Remarks

Access to this property requires Authorized to be true.

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PictureTileSize Property

[image]

LinkOne WebView API
BookService..::.PictureTileSize Property
BookService Class See Also Send Feedback
Gets or sets the size of the picture tile.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int PictureTileSize { get; set; }
Visual Basic (Declaration)
Public Property PictureTileSize As Integer
Visual C++
public:
property int PictureTileSize {
    int get ();
    void set (int value);
}

Field Value

The size of the picture tile.

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PositionFormat Property

[image]

LinkOne WebView API
BookService..::.PositionFormat Property
BookService Class See Also Send Feedback
Gets or sets the required book position format for the clipboard.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PositionFormat { get; set; }
Visual Basic (Declaration)
Public Property PositionFormat As String
Visual C++
public:
property String^ PositionFormat {
    String^ get ();
    void set (String^ value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PreferredGlobalPrintLayout Property

[image]

LinkOne WebView API
BookService..::.PreferredGlobalPrintLayout Property
BookService Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PreferredGlobalPrintLayout { get; set; }
Visual Basic (Declaration)
Public Property PreferredGlobalPrintLayout As String
Visual C++
public:
property String^ PreferredGlobalPrintLayout {
    String^ get ();
    void set (String^ value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PreferredGlobalScreenLayout Property

[image]

LinkOne WebView API
BookService..::.PreferredGlobalScreenLayout Property
BookService Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PreferredGlobalScreenLayout { get; set; }
Visual Basic (Declaration)
Public Property PreferredGlobalScreenLayout As String
Visual C++
public:
property String^ PreferredGlobalScreenLayout {
    String^ get ();
    void set (String^ value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PreferredLayoutCollection Property

[image]

LinkOne WebView API
BookService..::.PreferredLayoutCollection Property
BookService Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public PreferredCollection PreferredLayoutCollection { get; }
Visual Basic (Declaration)
Public ReadOnly Property PreferredLayoutCollection As PreferredCollection
Visual C++
public:
property PreferredCollection^ PreferredLayoutCollection {
    PreferredCollection^ get ();
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PreferredPrintLayout Property

[image]

LinkOne WebView API
BookService..::.PreferredPrintLayout Property
BookService Class See Also Send Feedback
Gets or sets the preferred print layout for the book for the current request.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PreferredPrintLayout { get; set; }
Visual Basic (Declaration)
Public Property PreferredPrintLayout As String
Visual C++
public:
property String^ PreferredPrintLayout {
    String^ get ();
    void set (String^ value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PreferredPublisherPrintLayout Property

[image]

LinkOne WebView API
BookService..::.PreferredPublisherPrintLayout Property
BookService Class See Also Send Feedback
Gets or sets the preferred global print layout

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PreferredPublisherPrintLayout { get; set; }
Visual Basic (Declaration)
Public Property PreferredPublisherPrintLayout As String
Visual C++
public:
property String^ PreferredPublisherPrintLayout {
    String^ get ();
    void set (String^ value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PreferredPublisherScreenLayout Property

[image]

LinkOne WebView API
BookService..::.PreferredPublisherScreenLayout Property
BookService Class See Also Send Feedback
Gets or sets the preferred screen layout for the publisher

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PreferredPublisherScreenLayout { get; set; }
Visual Basic (Declaration)
Public Property PreferredPublisherScreenLayout As String
Visual C++
public:
property String^ PreferredPublisherScreenLayout {
    String^ get ();
    void set (String^ value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PreferredScreenLayout Property

[image]

LinkOne WebView API
BookService..::.PreferredScreenLayout Property
BookService Class See Also Send Feedback
Gets or sets the preferred screen layout for the book for the current request.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PreferredScreenLayout { get; set; }
Visual Basic (Declaration)
Public Property PreferredScreenLayout As String
Visual C++
public:
property String^ PreferredScreenLayout {
    String^ get ();
    void set (String^ value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PrimeBookCacheWindow Property

[image]

LinkOne WebView API
BookService..::.PrimeBookCacheWindow Property
BookService Class See Also Send Feedback
Controls the sliding duration for which books are cached in the Http cache when loading via a prime cache call (seconds).

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public double PrimeBookCacheWindow { get; set; }
Visual Basic (Declaration)
Public Property PrimeBookCacheWindow As Double
Visual C++
public:
property double PrimeBookCacheWindow {
    double get ();
    void set (double value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PrintLayoutObject Property

[image]

LinkOne WebView API
BookService..::.PrintLayoutObject Property
BookService Class See Also Send Feedback
Gets the print Layout object for the current request.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Layout PrintLayoutObject { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrintLayoutObject As Layout
Visual C++
public:
property Layout^ PrintLayoutObject {
    Layout^ get ();
}

Remarks

Access to this property requires Authorized to be true.

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PrintLayouts Property

[image]

LinkOne WebView API
BookService..::.PrintLayouts Property
BookService Class See Also Send Feedback
Gets the collection of print layouts for the current view and language code.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public LayoutCollection PrintLayouts { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrintLayouts As LayoutCollection
Visual C++
public:
property LayoutCollection^ PrintLayouts {
    LayoutCollection^ get ();
}

Remarks

The returned layouts include all supplied layouts from the current book having the current language. If there are no layouts having the current language, then all layouts without a language are returned. User layouts are ignored.

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PrintPictureResolution Property

[image]

LinkOne WebView API
BookService..::.PrintPictureResolution Property
BookService Class See Also Send Feedback
Gets or sets the print resolution used when printing only pictures.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int PrintPictureResolution { get; set; }
Visual Basic (Declaration)
Public Property PrintPictureResolution As Integer
Visual C++
public:
property int PrintPictureResolution {
    int get ();
    void set (int value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PrintResolution Property

[image]

LinkOne WebView API
BookService..::.PrintResolution Property
BookService Class See Also Send Feedback
Gets or sets the print resolution.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int PrintResolution { get; set; }
Visual Basic (Declaration)
Public Property PrintResolution As Integer
Visual C++
public:
property int PrintResolution {
    int get ();
    void set (int value);
}

Remarks

Note: changing this property to a value higher then the default DefaultPrintResolution()()() may effect the speed of parts list printing.

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


Provider Property

[image]

LinkOne WebView API
BookService..::.Provider Property
BookService Class See Also Send Feedback
Gets the provider.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public IPersistProvider Provider { get; }
Visual Basic (Declaration)
Public ReadOnly Property Provider As IPersistProvider
Visual C++
public:
property IPersistProvider^ Provider {
    IPersistProvider^ get ();
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PublisherBookCode Property

[image]

LinkOne WebView API
BookService..::.PublisherBookCode Property
BookService Class See Also Send Feedback
Gets or sets the publisher/book code request argument.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PublisherBookCode { get; set; }
Visual Basic (Declaration)
Public Property PublisherBookCode As String
Visual C++
public:
property String^ PublisherBookCode {
    String^ get ();
    void set (String^ value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PublisherCode Property

[image]

LinkOne WebView API
BookService..::.PublisherCode Property
BookService Class See Also Send Feedback
Gets or sets the publisher code request argument.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PublisherCode { get; set; }
Visual Basic (Declaration)
Public Property PublisherCode As String
Visual C++
public:
property String^ PublisherCode {
    String^ get ();
    void set (String^ value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PublisherObject Property

[image]

LinkOne WebView API
BookService..::.PublisherObject Property
BookService Class See Also Send Feedback
Gets the Publisher object for the current request.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Publisher PublisherObject { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublisherObject As Publisher
Visual C++
public:
property Publisher^ PublisherObject {
    Publisher^ get ();
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PublisherPrintLayoutObject Property

[image]

LinkOne WebView API
BookService..::.PublisherPrintLayoutObject Property
BookService Class See Also Send Feedback
Gets the publisher print Layout object for the current request.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Layout PublisherPrintLayoutObject { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublisherPrintLayoutObject As Layout
Visual C++
public:
property Layout^ PublisherPrintLayoutObject {
    Layout^ get ();
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PublisherScreenLayoutObject Property

[image]

LinkOne WebView API
BookService..::.PublisherScreenLayoutObject Property
BookService Class See Also Send Feedback
Gets the publisher screen Layout object for the current request.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Layout PublisherScreenLayoutObject { get; }
Visual Basic (Declaration)
Public ReadOnly Property PublisherScreenLayoutObject As Layout
Visual C++
public:
property Layout^ PublisherScreenLayoutObject {
    Layout^ get ();
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


Reference Property

[image]

LinkOne WebView API
BookService..::.Reference Property
BookService Class See Also Send Feedback
Gets or sets the publisher/book/page/resource|itemid reference request argument.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Reference { get; set; }
Visual Basic (Declaration)
Public Property Reference As String
Visual C++
public:
property String^ Reference {
    String^ get ();
    void set (String^ value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ResourceReference Property

[image]

LinkOne WebView API
BookService..::.ResourceReference Property
BookService Class See Also Send Feedback
Gets or sets the resource reference request argument.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string ResourceReference { get; set; }
Visual Basic (Declaration)
Public Property ResourceReference As String
Visual C++
public:
property String^ ResourceReference {
    String^ get ();
    void set (String^ value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ScreenLayoutObject Property

[image]

LinkOne WebView API
BookService..::.ScreenLayoutObject Property
BookService Class See Also Send Feedback
Gets the screen Layout object for the current request.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Layout ScreenLayoutObject { get; }
Visual Basic (Declaration)
Public ReadOnly Property ScreenLayoutObject As Layout
Visual C++
public:
property Layout^ ScreenLayoutObject {
    Layout^ get ();
}

Remarks

Access to this property requires Authorized to be true.

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ScreenLayouts Property

[image]

LinkOne WebView API
BookService..::.ScreenLayouts Property
BookService Class See Also Send Feedback
Gets the collection of screen layouts for the current view and language code.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public LayoutCollection ScreenLayouts { get; }
Visual Basic (Declaration)
Public ReadOnly Property ScreenLayouts As LayoutCollection
Visual C++
public:
property LayoutCollection^ ScreenLayouts {
    LayoutCollection^ get ();
}

Remarks

The returned layouts include all supplied layouts from the current book having the current language. If there are no layouts having the current language, then all layouts without a language are returned. User layouts are ignored.

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


UseJpegTilesForHighColourImages Property

[image]

LinkOne WebView API
BookService..::.UseJpegTilesForHighColourImages Property
BookService Class See Also Send Feedback
Gets or sets whether to use jpeg tiles for high colour images

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool UseJpegTilesForHighColourImages { get; set; }
Visual Basic (Declaration)
Public Property UseJpegTilesForHighColourImages As Boolean
Visual C++
public:
property bool UseJpegTilesForHighColourImages {
    bool get ();
    void set (bool value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


UserLayouts Property

[image]

LinkOne WebView API
BookService..::.UserLayouts Property
BookService Class See Also Send Feedback
Gets any user layouts.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public LayoutCollection UserLayouts { get; }
Visual Basic (Declaration)
Public ReadOnly Property UserLayouts As LayoutCollection
Visual C++
public:
property LayoutCollection^ UserLayouts {
    LayoutCollection^ get ();
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


UserLayoutsDirectory Property

[image]

LinkOne WebView API
BookService..::.UserLayoutsDirectory Property
BookService Class See Also Send Feedback
Gets or sets the user layouts directory.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string UserLayoutsDirectory { get; set; }
Visual Basic (Declaration)
Public Property UserLayoutsDirectory As String
Visual C++
public:
property String^ UserLayoutsDirectory {
    String^ get ();
    void set (String^ value);
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


VectorToRasterConverterParameters Property

[image]

LinkOne WebView API
BookService..::.VectorToRasterConverterParameters Property
BookService Class See Also Send Feedback
Gets the external vector to raster converter parameters to fix problems like in LO-165

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string VectorToRasterConverterParameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property VectorToRasterConverterParameters As String
Visual C++
public:
property String^ VectorToRasterConverterParameters {
    String^ get ();
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


VectorToRasterConverterPath Property

[image]

LinkOne WebView API
BookService..::.VectorToRasterConverterPath Property
BookService Class See Also Send Feedback
Gets the external vector to raster converter path to fix problems like in LO-165

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string VectorToRasterConverterPath { get; }
Visual Basic (Declaration)
Public ReadOnly Property VectorToRasterConverterPath As String
Visual C++
public:
property String^ VectorToRasterConverterPath {
    String^ get ();
}

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ConfigurationManagerService Class

[image]

LinkOne WebView API
ConfigurationManagerService Class
Members See Also Send Feedback
This service provides functionality for the configuration manager.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public sealed class ConfigurationManagerService : ServiceBase
Visual Basic (Declaration)
Public NotInheritable Class ConfigurationManagerService _
    Inherits ServiceBase
Visual C++
public ref class ConfigurationManagerService sealed : public ServiceBase

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.Services..::.ServiceBase
Mincom.LinkOne.WebView.WebServer.Services..::.ConfigurationManagerService

See Also

ConfigurationManagerService Members
Mincom.LinkOne.WebView.WebServer.Services Namespace


ConfigurationManagerService Members

[image] [image]

LinkOne WebView API
ConfigurationManagerService Members
ConfigurationManagerService Class Methods Properties See Also Send Feedback

The ConfigurationManagerService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
ConfigurationManagerAssembly | Gets or sets the name of the configuration manager assembly.
ConfigurationManagerConnectionString | Gets or sets the configuration manager connection string.
ConfigurationManagerEnabled | Gets or sets a value indicating whether the configuration manager is enabled.
ConfigurationManagerInstance | Gets an instance of the configuration manager if a valid assembly name is provided. If the assembly name is invalid, or enabled is false, this property will return null;
Current | Gets the ConfigurationManager service for the current request.

See Also

ConfigurationManagerService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ConfigurationManagerService Methods

[image] [image]

LinkOne WebView API
ConfigurationManagerService Methods
ConfigurationManagerService Class See Also Send Feedback

The ConfigurationManagerService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ConfigurationManagerService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ConfigurationManagerService Properties

[image] [image]

LinkOne WebView API
ConfigurationManagerService Properties
ConfigurationManagerService Class See Also Send Feedback

The ConfigurationManagerService type exposes the following members.

Properties

Name | Description
ConfigurationManagerAssembly | Gets or sets the name of the configuration manager assembly.
ConfigurationManagerConnectionString | Gets or sets the configuration manager connection string.
ConfigurationManagerEnabled | Gets or sets a value indicating whether the configuration manager is enabled.
ConfigurationManagerInstance | Gets an instance of the configuration manager if a valid assembly name is provided. If the assembly name is invalid, or enabled is false, this property will return null;
Current | Gets the ConfigurationManager service for the current request.

See Also

ConfigurationManagerService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ConfigurationManagerAssembly Property

[image]

LinkOne WebView API
ConfigurationManagerService..::.ConfigurationManagerAssembly Property
ConfigurationManagerService Class See Also Send Feedback
Gets or sets the name of the configuration manager assembly.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string ConfigurationManagerAssembly { get; set; }
Visual Basic (Declaration)
Public Property ConfigurationManagerAssembly As String
Visual C++
public:
property String^ ConfigurationManagerAssembly {
    String^ get ();
    void set (String^ value);
}

Field Value

The fully qualified name of the configuration manager assembly.

See Also

ConfigurationManagerService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ConfigurationManagerConnectionString Property

[image]

LinkOne WebView API
ConfigurationManagerService..::.ConfigurationManagerConnectionString Property
ConfigurationManagerService Class See Also Send Feedback
Gets or sets the configuration manager connection string.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string ConfigurationManagerConnectionString { get; set; }
Visual Basic (Declaration)
Public Property ConfigurationManagerConnectionString As String
Visual C++
public:
property String^ ConfigurationManagerConnectionString {
    String^ get ();
    void set (String^ value);
}

See Also

ConfigurationManagerService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ConfigurationManagerEnabled Property

[image]

LinkOne WebView API
ConfigurationManagerService..::.ConfigurationManagerEnabled Property
ConfigurationManagerService Class See Also Send Feedback
Gets or sets a value indicating whether the configuration manager is enabled.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool ConfigurationManagerEnabled { get; set; }
Visual Basic (Declaration)
Public Property ConfigurationManagerEnabled As Boolean
Visual C++
public:
property bool ConfigurationManagerEnabled {
    bool get ();
    void set (bool value);
}

Field Value

true if the configuration manager is enabled; otherwise, false.

See Also

ConfigurationManagerService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ConfigurationManagerInstance Property

[image]

LinkOne WebView API
ConfigurationManagerService..::.ConfigurationManagerInstance Property
ConfigurationManagerService Class See Also Send Feedback
Gets an instance of the configuration manager if a valid assembly name is provided. If the assembly name is invalid, or enabled is false, this property will return null;

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public IConfigurationManager ConfigurationManagerInstance { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConfigurationManagerInstance As IConfigurationManager
Visual C++
public:
property IConfigurationManager^ ConfigurationManagerInstance {
    IConfigurationManager^ get ();
}

See Also

ConfigurationManagerService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


Current Property

[image]

LinkOne WebView API
ConfigurationManagerService..::.Current Property
ConfigurationManagerService Class See Also Send Feedback
Gets the ConfigurationManager service for the current request.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public static ConfigurationManagerService Current { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Current As ConfigurationManagerService
Visual C++
public:
static property ConfigurationManagerService^ Current {
    ConfigurationManagerService^ get ();
}

Return Value

The ConfigurationManager service for the current request.

Remarks

A ConfigurationManager service object is automatically associated with each request to the web server, and may be obtained by calling this static method.

See Also

ConfigurationManagerService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ErrorService Class

[image]

LinkOne WebView API
ErrorService Class
Members See Also Send Feedback
This service provides error handling and reporting functionality.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public sealed class ErrorService : ServiceBase
Visual Basic (Declaration)
Public NotInheritable Class ErrorService _
    Inherits ServiceBase
Visual C++
public ref class ErrorService sealed : public ServiceBase

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.Services..::.ServiceBase
Mincom.LinkOne.WebView.WebServer.Services..::.ErrorService

See Also

ErrorService Members
Mincom.LinkOne.WebView.WebServer.Services Namespace


ErrorService Members

[image] [image]

LinkOne WebView API
ErrorService Members
ErrorService Class Constructors Methods Properties See Also Send Feedback

The ErrorService type exposes the following members.

Constructors

Name | Description
ErrorService | Initializes a new instance of the ErrorService class.

Methods

Name | Description
ClearLog | Clears the errors in the log path.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReportError | Generates a report on the last error that occured, and places it in the log data folder.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Current | Gets the current ErrorService.
LogDirectory | Gets or sets the log directory to where error log files are saved.
PhysicalLogDirectory | Gets the physical log directory.

See Also

ErrorService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ErrorService Constructor

[image]

LinkOne WebView API
ErrorService Constructor
ErrorService Class See Also Send Feedback
Initializes a new instance of the ErrorService class.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public ErrorService()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ErrorService()

See Also

ErrorService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ErrorService Methods

[image] [image]

LinkOne WebView API
ErrorService Methods
ErrorService Class See Also Send Feedback

The ErrorService type exposes the following members.

Methods

Name | Description
ClearLog | Clears the errors in the log path.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReportError | Generates a report on the last error that occured, and places it in the log data folder.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ErrorService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ClearLog Method

[image]

LinkOne WebView API
ErrorService..::.ClearLog Method
ErrorService Class See Also Send Feedback
Clears the errors in the log path.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void ClearLog()
Visual Basic (Declaration)
Public Sub ClearLog
Visual C++
public:
void ClearLog()

See Also

ErrorService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ReportError Method

[image]

LinkOne WebView API
ErrorService..::.ReportError Method
ErrorService Class See Also Send Feedback
Generates a report on the last error that occured, and places it in the log data folder.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string ReportError(
    Exception exception
)
Visual Basic (Declaration)
Public Function ReportError ( _
    exception As Exception _
) As String
Visual C++
public:
String^ ReportError(
    Exception^ exception
)

Parameters

exception
Type: System..::.Exception
The exception to report.

Return Value

The name of the log file which contains the error information.

See Also

ErrorService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ErrorService Properties

[image] [image]

LinkOne WebView API
ErrorService Properties
ErrorService Class See Also Send Feedback

The ErrorService type exposes the following members.

Properties

Name | Description
Current | Gets the current ErrorService.
LogDirectory | Gets or sets the log directory to where error log files are saved.
PhysicalLogDirectory | Gets the physical log directory.

See Also

ErrorService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


Current Property

[image]

LinkOne WebView API
ErrorService..::.Current Property
ErrorService Class See Also Send Feedback
Gets the current ErrorService.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public static ErrorService Current { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Current As ErrorService
Visual C++
public:
static property ErrorService^ Current {
    ErrorService^ get ();
}

See Also

ErrorService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


LogDirectory Property

[image]

LinkOne WebView API
ErrorService..::.LogDirectory Property
ErrorService Class See Also Send Feedback
Gets or sets the log directory to where error log files are saved.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string LogDirectory { get; set; }
Visual Basic (Declaration)
Public Property LogDirectory As String
Visual C++
public:
property String^ LogDirectory {
    String^ get ();
    void set (String^ value);
}

Remarks

The directory must conform to the supported formats described in GetPhysicalPath(String, array<String>[]()[]).

See Also

ErrorService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PhysicalLogDirectory Property

[image]

LinkOne WebView API
ErrorService..::.PhysicalLogDirectory Property
ErrorService Class See Also Send Feedback
Gets the physical log directory.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PhysicalLogDirectory { get; }
Visual Basic (Declaration)
Public ReadOnly Property PhysicalLogDirectory As String
Visual C++
public:
property String^ PhysicalLogDirectory {
    String^ get ();
}

See Also

ErrorService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


NoteService Class

[image]

LinkOne WebView API
NoteService Class
Members See Also Send Feedback
This service provides access to all note resources.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public sealed class NoteService : ServiceBase,
    IDisposable
Visual Basic (Declaration)
Public NotInheritable Class NoteService _
    Inherits ServiceBase _
    Implements IDisposable
Visual C++
public ref class NoteService sealed : public ServiceBase,
    IDisposable

Remarks

The service works on one note, or all notes and categories for a given context, based on the current request URL.

A single note is specified with the arguments:
Argument | Purpose
note=? | ? is the identifier for the note.
All notes are specified by a context, which consists of the arguments:
Argument | Purpose
note=? | ? is in the form publishercode/bookCode/pagereference/noteid.
item=? | ? is the item identifier.
Notes for a book or page need only supply the note argument.
Notes for an item must supply all arguments.

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.Services..::.ServiceBase
Mincom.LinkOne.WebView.WebServer.Services..::.NoteService

See Also

NoteService Members
Mincom.LinkOne.WebView.WebServer.Services Namespace


NoteService Members

[image] [image]

LinkOne WebView API
NoteService Members
NoteService Class Methods See Also Send Feedback

The NoteService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

NoteService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


NoteService Methods

[image] [image]

LinkOne WebView API
NoteService Methods
NoteService Class See Also Send Feedback

The NoteService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

NoteService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


OfflineDBService Class

[image]

LinkOne WebView API
OfflineDBService Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class OfflineDBService : ServiceBase
Visual Basic (Declaration)
Public Class OfflineDBService _
    Inherits ServiceBase
Visual C++
public ref class OfflineDBService : public ServiceBase

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.Services..::.ServiceBase
Mincom.LinkOne.WebView.WebServer.Services..::.OfflineDBService

See Also

OfflineDBService Members
Mincom.LinkOne.WebView.WebServer.Services Namespace


OfflineDBService Members

[image] [image]

LinkOne WebView API
OfflineDBService Members
OfflineDBService Class Constructors Methods Properties See Also Send Feedback

The OfflineDBService type exposes the following members.

Constructors

Name | Description
OfflineDBService | /// Initializes a new instance of the OfflineDBService class.

Methods

Name | Description
CreateAuditDownload | Create an offline audit download
CreateBook | Create an offline book
createBrowserDetail | Create an offline browser detail
CreatePage | Create an offline page
CreatePicture | Create an offline picture
CreateSelectionList | Create an offline Selection List
CreateUser | Create an offline user
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBook | Get an offline book by publisher and book codes
GetBrowserDetail | Get an offline browser detail by Machine IP, Machine Name, and Browser Name
GetDownloadDetailLogCsv | Gets the detail of download activity in csv format
GetDownloadLog | Gets the summary of download activity as a list of records with properties of Book, PagesDownloaded, LastDownloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOfflineUsers | Gets the offline users
GetPage | Get an offline page by Book Id and Page Reference
GetPicture | Get an offline picture by Page Id and Number
GetPictures | Get a list of offline pictures by Page Id
GetSelectionList | Get an offline selection list
GetType | Gets the type of the current instance. (Inherited from Object.)
GetUser | Get offline user by UserName
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
UpdatePage | Update an offline page
UpdatePicture | Update an existing picture data
UpdateSelectionList | Update an offline selection list

Properties

Name | Description
Current | Gets the Offline service for the current request.

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


OfflineDBService Constructor

[image]

LinkOne WebView API
OfflineDBService Constructor
OfflineDBService Class See Also Send Feedback
///
Initializes a new instance of the OfflineDBService class.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public OfflineDBService()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OfflineDBService()

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


OfflineDBService Methods

[image] [image]

LinkOne WebView API
OfflineDBService Methods
OfflineDBService Class See Also Send Feedback

The OfflineDBService type exposes the following members.

Methods

Name | Description
CreateAuditDownload | Create an offline audit download
CreateBook | Create an offline book
createBrowserDetail | Create an offline browser detail
CreatePage | Create an offline page
CreatePicture | Create an offline picture
CreateSelectionList | Create an offline Selection List
CreateUser | Create an offline user
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBook | Get an offline book by publisher and book codes
GetBrowserDetail | Get an offline browser detail by Machine IP, Machine Name, and Browser Name
GetDownloadDetailLogCsv | Gets the detail of download activity in csv format
GetDownloadLog | Gets the summary of download activity as a list of records with properties of Book, PagesDownloaded, LastDownloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOfflineUsers | Gets the offline users
GetPage | Get an offline page by Book Id and Page Reference
GetPicture | Get an offline picture by Page Id and Number
GetPictures | Get a list of offline pictures by Page Id
GetSelectionList | Get an offline selection list
GetType | Gets the type of the current instance. (Inherited from Object.)
GetUser | Get offline user by UserName
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
UpdatePage | Update an offline page
UpdatePicture | Update an existing picture data
UpdateSelectionList | Update an offline selection list

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


CreateAuditDownload Method

[image]

LinkOne WebView API
OfflineDBService..::.CreateAuditDownload Method
OfflineDBService Class See Also Send Feedback
Create an offline audit download

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void CreateAuditDownload(
    OfflineAuditDownload auditDownload
)
Visual Basic (Declaration)
Public Sub CreateAuditDownload ( _
    auditDownload As OfflineAuditDownload _
)
Visual C++
public:
void CreateAuditDownload(
    OfflineAuditDownload^ auditDownload
)

Parameters

auditDownload
Type: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities..::.OfflineAuditDownload

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


CreateBook Method

[image]

LinkOne WebView API
OfflineDBService..::.CreateBook Method
OfflineDBService Class See Also Send Feedback
Create an offline book

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void CreateBook(
    OfflineBook book
)
Visual Basic (Declaration)
Public Sub CreateBook ( _
    book As OfflineBook _
)
Visual C++
public:
void CreateBook(
    OfflineBook^ book
)

Parameters

book
Type: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities..::.OfflineBook
the book object

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


createBrowserDetail Method

[image]

LinkOne WebView API
OfflineDBService..::.createBrowserDetail Method
OfflineDBService Class See Also Send Feedback
Create an offline browser detail

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void createBrowserDetail(
    OfflineBrowserDetail browserDetail
)
Visual Basic (Declaration)
Public Sub createBrowserDetail ( _
    browserDetail As OfflineBrowserDetail _
)
Visual C++
public:
void createBrowserDetail(
    OfflineBrowserDetail^ browserDetail
)

Parameters

browserDetail
Type: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities..::.OfflineBrowserDetail
the browser detail object

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


CreatePage Method

[image]

LinkOne WebView API
OfflineDBService..::.CreatePage Method
OfflineDBService Class See Also Send Feedback
Create an offline page

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void CreatePage(
    OfflinePage page
)
Visual Basic (Declaration)
Public Sub CreatePage ( _
    page As OfflinePage _
)
Visual C++
public:
void CreatePage(
    OfflinePage^ page
)

Parameters

page
Type: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities..::.OfflinePage
the page object

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


CreatePicture Method

[image]

LinkOne WebView API
OfflineDBService..::.CreatePicture Method
OfflineDBService Class See Also Send Feedback
Create an offline picture

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void CreatePicture(
    OfflinePicture picture
)
Visual Basic (Declaration)
Public Sub CreatePicture ( _
    picture As OfflinePicture _
)
Visual C++
public:
void CreatePicture(
    OfflinePicture^ picture
)

Parameters

picture
Type: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities..::.OfflinePicture
the picture object

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


CreateSelectionList Method

[image]

LinkOne WebView API
OfflineDBService..::.CreateSelectionList Method
OfflineDBService Class See Also Send Feedback
Create an offline Selection List

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void CreateSelectionList(
    OfflineSelectionList selectionList
)
Visual Basic (Declaration)
Public Sub CreateSelectionList ( _
    selectionList As OfflineSelectionList _
)
Visual C++
public:
void CreateSelectionList(
    OfflineSelectionList^ selectionList
)

Parameters

selectionList
Type: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities..::.OfflineSelectionList

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


CreateUser Method

[image]

LinkOne WebView API
OfflineDBService..::.CreateUser Method
OfflineDBService Class See Also Send Feedback
Create an offline user

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void CreateUser(
    OfflineUser user
)
Visual Basic (Declaration)
Public Sub CreateUser ( _
    user As OfflineUser _
)
Visual C++
public:
void CreateUser(
    OfflineUser^ user
)

Parameters

user
Type: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities..::.OfflineUser
the user object

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


GetBook Method

[image]

LinkOne WebView API
OfflineDBService..::.GetBook Method
OfflineDBService Class See Also Send Feedback
Get an offline book by publisher and book codes

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public OfflineBook GetBook(
    string publisherCode,
    string bookCode
)
Visual Basic (Declaration)
Public Function GetBook ( _
    publisherCode As String, _
    bookCode As String _
) As OfflineBook
Visual C++
public:
OfflineBook^ GetBook(
    String^ publisherCode,
    String^ bookCode
)

Parameters

publisherCode
Type: System..::.String
the publisher code
bookCode
Type: System..::.String
the book code

Return Value

an OfflineBook object

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


GetBrowserDetail Method

[image]

LinkOne WebView API
OfflineDBService..::.GetBrowserDetail Method
OfflineDBService Class See Also Send Feedback
Get an offline browser detail by Machine IP, Machine Name, and Browser Name

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public OfflineBrowserDetail GetBrowserDetail(
    string machineIP,
    string machineName,
    string browserName
)
Visual Basic (Declaration)
Public Function GetBrowserDetail ( _
    machineIP As String, _
    machineName As String, _
    browserName As String _
) As OfflineBrowserDetail
Visual C++
public:
OfflineBrowserDetail^ GetBrowserDetail(
    String^ machineIP,
    String^ machineName,
    String^ browserName
)

Parameters

machineIP
Type: System..::.String
the machine IP
machineName
Type: System..::.String
the machine name
browserName
Type: System..::.String
the browser name

Return Value

an OfflineBrowserDetail object

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


GetDownloadDetailLogCsv Method

[image]

LinkOne WebView API
OfflineDBService..::.GetDownloadDetailLogCsv Method
OfflineDBService Class See Also Send Feedback
Gets the detail of download activity in csv format

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string GetDownloadDetailLogCsv(
    DateTime historyFrom,
    DateTime historyTo,
    string userName
)
Visual Basic (Declaration)
Public Function GetDownloadDetailLogCsv ( _
    historyFrom As DateTime, _
    historyTo As DateTime, _
    userName As String _
) As String
Visual C++
public:
String^ GetDownloadDetailLogCsv(
    DateTime historyFrom,
    DateTime historyTo,
    String^ userName
)

Parameters

historyFrom
Type: System..::.DateTime
historyTo
Type: System..::.DateTime
userName
Type: System..::.String

Return Value

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


GetDownloadLog Method

[image]

LinkOne WebView API
OfflineDBService..::.GetDownloadLog Method
OfflineDBService Class See Also Send Feedback
Gets the summary of download activity as a list of records with properties of Book, PagesDownloaded, LastDownloaded.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public IEnumerable GetDownloadLog(
    DateTime historyFrom,
    DateTime historyTo,
    string userName
)
Visual Basic (Declaration)
Public Function GetDownloadLog ( _
    historyFrom As DateTime, _
    historyTo As DateTime, _
    userName As String _
) As IEnumerable
Visual C++
public:
IEnumerable^ GetDownloadLog(
    DateTime historyFrom,
    DateTime historyTo,
    String^ userName
)

Parameters

historyFrom
Type: System..::.DateTime
historyTo
Type: System..::.DateTime
userName
Type: System..::.String

Return Value

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


GetOfflineUsers Method

[image]

LinkOne WebView API
OfflineDBService..::.GetOfflineUsers Method
OfflineDBService Class See Also Send Feedback
Gets the offline users

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public IEnumerable GetOfflineUsers()
Visual Basic (Declaration)
Public Function GetOfflineUsers As IEnumerable
Visual C++
public:
IEnumerable^ GetOfflineUsers()

Return Value

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


GetPage Method

[image]

LinkOne WebView API
OfflineDBService..::.GetPage Method
OfflineDBService Class See Also Send Feedback
Get an offline page by Book Id and Page Reference

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public OfflinePage GetPage(
    int bookId,
    string pageReference
)
Visual Basic (Declaration)
Public Function GetPage ( _
    bookId As Integer, _
    pageReference As String _
) As OfflinePage
Visual C++
public:
OfflinePage^ GetPage(
    int bookId,
    String^ pageReference
)

Parameters

bookId
Type: System..::.Int32
the Book Id
pageReference
Type: System..::.String
the Page Reference

Return Value

an OfflinePage object

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


GetPicture Method

[image]

LinkOne WebView API
OfflineDBService..::.GetPicture Method
OfflineDBService Class See Also Send Feedback
Get an offline picture by Page Id and Number

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public OfflinePicture GetPicture(
    int pageId,
    int number
)
Visual Basic (Declaration)
Public Function GetPicture ( _
    pageId As Integer, _
    number As Integer _
) As OfflinePicture
Visual C++
public:
OfflinePicture^ GetPicture(
    int pageId,
    int number
)

Parameters

pageId
Type: System..::.Int32
the Page Id
number
Type: System..::.Int32
the Number

Return Value

a list of OfflinePicture object

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


GetPictures Method

[image]

LinkOne WebView API
OfflineDBService..::.GetPictures Method
OfflineDBService Class See Also Send Feedback
Get a list of offline pictures by Page Id

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public List<OfflinePicture> GetPictures(
    int pageId
)
Visual Basic (Declaration)
Public Function GetPictures ( _
    pageId As Integer _
) As List(Of OfflinePicture)
Visual C++
public:
List<OfflinePicture^>^ GetPictures(
    int pageId
)

Parameters

pageId
Type: System..::.Int32
the Page Id

Return Value

an OfflinePicture object

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


GetSelectionList Method

[image]

LinkOne WebView API
OfflineDBService..::.GetSelectionList Method
OfflineDBService Class See Also Send Feedback
Get an offline selection list

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public OfflineSelectionList GetSelectionList(
    string userName,
    string configurationName,
    string selectionListName
)
Visual Basic (Declaration)
Public Function GetSelectionList ( _
    userName As String, _
    configurationName As String, _
    selectionListName As String _
) As OfflineSelectionList
Visual C++
public:
OfflineSelectionList^ GetSelectionList(
    String^ userName,
    String^ configurationName,
    String^ selectionListName
)

Parameters

userName
Type: System..::.String
configurationName
Type: System..::.String
selectionListName
Type: System..::.String

Return Value

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


GetUser Method

[image]

LinkOne WebView API
OfflineDBService..::.GetUser Method
OfflineDBService Class See Also Send Feedback
Get offline user by UserName

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public OfflineUser GetUser(
    string userName
)
Visual Basic (Declaration)
Public Function GetUser ( _
    userName As String _
) As OfflineUser
Visual C++
public:
OfflineUser^ GetUser(
    String^ userName
)

Parameters

userName
Type: System..::.String
the username

Return Value

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


UpdatePage Method

[image]

LinkOne WebView API
OfflineDBService..::.UpdatePage Method
OfflineDBService Class See Also Send Feedback
Update an offline page

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void UpdatePage(
    OfflinePage page
)
Visual Basic (Declaration)
Public Sub UpdatePage ( _
    page As OfflinePage _
)
Visual C++
public:
void UpdatePage(
    OfflinePage^ page
)

Parameters

page
Type: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities..::.OfflinePage
the page object

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


UpdatePicture Method

[image]

LinkOne WebView API
OfflineDBService..::.UpdatePicture Method
OfflineDBService Class See Also Send Feedback
Update an existing picture data

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void UpdatePicture(
    OfflinePicture picture
)
Visual Basic (Declaration)
Public Sub UpdatePicture ( _
    picture As OfflinePicture _
)
Visual C++
public:
void UpdatePicture(
    OfflinePicture^ picture
)

Parameters

picture
Type: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities..::.OfflinePicture
the picture object

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


UpdateSelectionList Method

[image]

LinkOne WebView API
OfflineDBService..::.UpdateSelectionList Method
OfflineDBService Class See Also Send Feedback
Update an offline selection list

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void UpdateSelectionList(
    OfflineSelectionList selectionList
)
Visual Basic (Declaration)
Public Sub UpdateSelectionList ( _
    selectionList As OfflineSelectionList _
)
Visual C++
public:
void UpdateSelectionList(
    OfflineSelectionList^ selectionList
)

Parameters

selectionList
Type: Mincom.LinkOne.WebView.WebServer.DataAccess.SqlClient.Entities..::.OfflineSelectionList

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


OfflineDBService Properties

[image] [image]

LinkOne WebView API
OfflineDBService Properties
OfflineDBService Class See Also Send Feedback

The OfflineDBService type exposes the following members.

Properties

Name | Description
Current | Gets the Offline service for the current request.

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


Current Property

[image]

LinkOne WebView API
OfflineDBService..::.Current Property
OfflineDBService Class See Also Send Feedback
Gets the Offline service for the current request.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public static OfflineDBService Current { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Current As OfflineDBService
Visual C++
public:
static property OfflineDBService^ Current {
    OfflineDBService^ get ();
}

Return Value

The Offline service for the current request.

Remarks

An Offline service object is automatically associated with each request to the web server, and may be obtained by calling this static method.

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PrintService Class

[image]

LinkOne WebView API
PrintService Class
Members See Also Send Feedback
This service provides access to all print resources.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public sealed class PrintService : ServiceBase,
    IDisposable
Visual Basic (Declaration)
Public NotInheritable Class PrintService _
    Inherits ServiceBase _
    Implements IDisposable
Visual C++
public ref class PrintService sealed : public ServiceBase,
    IDisposable

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.Services..::.ServiceBase
Mincom.LinkOne.WebView.WebServer.Services..::.PrintService

See Also

PrintService Members
Mincom.LinkOne.WebView.WebServer.Services Namespace


PrintService Members

[image] [image]

LinkOne WebView API
PrintService Members
PrintService Class Constructors Methods Fields Properties See Also Send Feedback

The PrintService type exposes the following members.

Constructors

Name | Description
PrintService | Initializes a new instance of the PrintService class.

Methods

Name | Description
CanPrint | Determines whether the service can print ths specified print scope.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaperSizes | Gets the list of print paper sizes
GetPrepareDocumentProgress | Get the status of the current document prepare job
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrepareDocument | Prepares the current document.
ToString | Returns a string that represents the current object. (Inherited from Object.)
WriteDocument | Writes the current document to the current response.

Fields

Name | Description
SIMULTANEOUS_BOOK_PRINT_SEMAPHORE_NAME |

Properties

Name | Description
CalloutFontName | Gets or sets the name of the callout font.
CalloutFontStyle | Gets or sets the callout font style.
Current | Gets the Book service for the current request.
IsZoomedPicture | Gets a value indicating whether the current picture is zoomed.
LockPrintedPDFs | Gets whether to lock printed pdf's or not
NormalCalloutColor | Gets or sets the normal callout colour information.
PartsListFont | Gets or sets the parts list font.
PrintedPDFPassword | Gets the printed PDF password for locked printed pdf's
PrintScope | Gets or sets the print scope for the current request.
ShowPrintBookOption | Gets or sets whether or not to display the Print Current Book option.
SimultaneousBookPrintCount | Gets the maximum number of simultaneous book prints to allow
ZoomedArea | Gets or sets the picture zoomed area for the current request.

See Also

PrintService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PrintService Constructor

[image]

LinkOne WebView API
PrintService Constructor
PrintService Class See Also Send Feedback
Initializes a new instance of the PrintService class.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public PrintService()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PrintService()

See Also

PrintService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PrintService Fields

[image] [image]

LinkOne WebView API
PrintService Fields
PrintService Class See Also Send Feedback

The PrintService type exposes the following members.

Fields

Name | Description
SIMULTANEOUS_BOOK_PRINT_SEMAPHORE_NAME |

See Also

PrintService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


SIMULTANEOUS_BOOK_PRINT_SEMAPHORE_NAME Field

[image]

LinkOne WebView API
PrintService..::.SIMULTANEOUS_BOOK_PRINT_SEMAPHORE_NAME Field
PrintService Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public const string SIMULTANEOUS_BOOK_PRINT_SEMAPHORE_NAME
Visual Basic (Declaration)
Public Const SIMULTANEOUS_BOOK_PRINT_SEMAPHORE_NAME As String
Visual C++
public:
literal String^ SIMULTANEOUS_BOOK_PRINT_SEMAPHORE_NAME

See Also

PrintService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PrintService Methods

[image] [image]

LinkOne WebView API
PrintService Methods
PrintService Class See Also Send Feedback

The PrintService type exposes the following members.

Methods

Name | Description
CanPrint | Determines whether the service can print ths specified print scope.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaperSizes | Gets the list of print paper sizes
GetPrepareDocumentProgress | Get the status of the current document prepare job
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrepareDocument | Prepares the current document.
ToString | Returns a string that represents the current object. (Inherited from Object.)
WriteDocument | Writes the current document to the current response.

See Also

PrintService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


CanPrint Method

[image]

LinkOne WebView API
PrintService..::.CanPrint Method
PrintService Class See Also Send Feedback
Determines whether the service can print ths specified print scope.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public static bool CanPrint(
    PrintScope printScope
)
Visual Basic (Declaration)
Public Shared Function CanPrint ( _
    printScope As PrintScope _
) As Boolean
Visual C++
public:
static bool CanPrint(
    PrintScope printScope
)

Parameters

printScope
Type: PrintScope
The print scope.

Return Value

true if this service can print the specified print scope; otherwise, false.

See Also

PrintService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


Dispose Method

[image]

LinkOne WebView API
PrintService..::.Dispose Method
PrintService Class See Also Send Feedback
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

PrintService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


GetPaperSizes Method

[image]

LinkOne WebView API
PrintService..::.GetPaperSizes Method
PrintService Class See Also Send Feedback
Gets the list of print paper sizes

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public List<ListItem> GetPaperSizes()
Visual Basic (Declaration)
Public Function GetPaperSizes As List(Of ListItem)
Visual C++
public:
List<ListItem^>^ GetPaperSizes()

See Also

PrintService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


GetPrepareDocumentProgress Method

[image]

LinkOne WebView API
PrintService..::.GetPrepareDocumentProgress Method
PrintService Class See Also Send Feedback
Get the status of the current document prepare job

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public KeyValuePair<int, string> GetPrepareDocumentProgress(
    PrintScope printScope,
    PrintOptions printOptions
)
Visual Basic (Declaration)
Public Function GetPrepareDocumentProgress ( _
    printScope As PrintScope, _
    printOptions As PrintOptions _
) As KeyValuePair(Of Integer, String)
Visual C++
public:
KeyValuePair<int, String^> GetPrepareDocumentProgress(
    PrintScope printScope,
    PrintOptions^ printOptions
)

Parameters

printScope
Type: PrintScope
The print scope of the document to get the status for.
printOptions
Type: Mincom.LinkOne.WebView.WebServer.Cache..::.PrintOptions
The print options of the document to get the status for.

Return Value

A PrintResult.

See Also

PrintService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PrepareDocument Method

[image]

LinkOne WebView API
PrintService..::.PrepareDocument Method
PrintService Class See Also Send Feedback
Prepares the current document.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public PrintResult PrepareDocument(
    PrintScope printScope,
    PrintOptions printOptions,
    out string documentFilePath
)
Visual Basic (Declaration)
Public Function PrepareDocument ( _
    printScope As PrintScope, _
    printOptions As PrintOptions, _
    <OutAttribute> ByRef documentFilePath As String _
) As PrintResult
Visual C++
public:
PrintResult PrepareDocument(
    PrintScope printScope,
    PrintOptions^ printOptions,
    [OutAttribute] String^% documentFilePath
)

Parameters

printScope
Type: PrintScope
The print scope of the current document to prepare.
printOptions
Type: Mincom.LinkOne.WebView.WebServer.Cache..::.PrintOptions
The print options of the current document to prepare.
documentFilePath
Type: System..::.String %
An out pararmeter which specifies the path to the prepared document.

Return Value

A PrintResult.

See Also

PrintService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


WriteDocument Method

[image]

LinkOne WebView API
PrintService..::.WriteDocument Method
PrintService Class See Also Send Feedback
Writes the current document to the current response.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public HttpStatusCode WriteDocument()
Visual Basic (Declaration)
Public Function WriteDocument As HttpStatusCode
Visual C++
public:
HttpStatusCode WriteDocument()

Return Value

The response code.

Remarks

A prior call to PrepareDocument(PrintScope, PrintOptions, String%) will yield a faster response to WriteDocument()()().

See Also

PrintService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PrintService Properties

[image] [image]

LinkOne WebView API
PrintService Properties
PrintService Class See Also Send Feedback

The PrintService type exposes the following members.

Properties

Name | Description
CalloutFontName | Gets or sets the name of the callout font.
CalloutFontStyle | Gets or sets the callout font style.
Current | Gets the Book service for the current request.
IsZoomedPicture | Gets a value indicating whether the current picture is zoomed.
LockPrintedPDFs | Gets whether to lock printed pdf's or not
NormalCalloutColor | Gets or sets the normal callout colour information.
PartsListFont | Gets or sets the parts list font.
PrintedPDFPassword | Gets the printed PDF password for locked printed pdf's
PrintScope | Gets or sets the print scope for the current request.
ShowPrintBookOption | Gets or sets whether or not to display the Print Current Book option.
SimultaneousBookPrintCount | Gets the maximum number of simultaneous book prints to allow
ZoomedArea | Gets or sets the picture zoomed area for the current request.

See Also

PrintService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


CalloutFontName Property

[image]

LinkOne WebView API
PrintService..::.CalloutFontName Property
PrintService Class See Also Send Feedback
Gets or sets the name of the callout font.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string CalloutFontName { get; set; }
Visual Basic (Declaration)
Public Property CalloutFontName As String
Visual C++
public:
property String^ CalloutFontName {
    String^ get ();
    void set (String^ value);
}

See Also

PrintService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


CalloutFontStyle Property

[image]

LinkOne WebView API
PrintService..::.CalloutFontStyle Property
PrintService Class See Also Send Feedback
Gets or sets the callout font style.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public FontStyle CalloutFontStyle { get; set; }
Visual Basic (Declaration)
Public Property CalloutFontStyle As FontStyle
Visual C++
public:
property FontStyle CalloutFontStyle {
    FontStyle get ();
    void set (FontStyle value);
}

See Also

PrintService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


Current Property

[image]

LinkOne WebView API
PrintService..::.Current Property
PrintService Class See Also Send Feedback
Gets the Book service for the current request.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public static PrintService Current { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Current As PrintService
Visual C++
public:
static property PrintService^ Current {
    PrintService^ get ();
}

Return Value

The Book service for the current request.

Remarks

A Book service object is automatically associated with each request to the web server, and may be obtained by calling this static method.

See Also

PrintService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


IsZoomedPicture Property

[image]

LinkOne WebView API
PrintService..::.IsZoomedPicture Property
PrintService Class See Also Send Feedback
Gets a value indicating whether the current picture is zoomed.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool IsZoomedPicture { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsZoomedPicture As Boolean
Visual C++
public:
property bool IsZoomedPicture {
    bool get ();
}

See Also

PrintService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


LockPrintedPDFs Property

[image]

LinkOne WebView API
PrintService..::.LockPrintedPDFs Property
PrintService Class See Also Send Feedback
Gets whether to lock printed pdf's or not

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool LockPrintedPDFs { get; }
Visual Basic (Declaration)
Public ReadOnly Property LockPrintedPDFs As Boolean
Visual C++
public:
property bool LockPrintedPDFs {
    bool get ();
}

See Also

PrintService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


NormalCalloutColor Property

[image]

LinkOne WebView API
PrintService..::.NormalCalloutColor Property
PrintService Class See Also Send Feedback
Gets or sets the normal callout colour information.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Color NormalCalloutColor { get; set; }
Visual Basic (Declaration)
Public Property NormalCalloutColor As Color
Visual C++
public:
property Color NormalCalloutColor {
    Color get ();
    void set (Color value);
}

See Also

PrintService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PartsListFont Property

[image]

LinkOne WebView API
PrintService..::.PartsListFont Property
PrintService Class See Also Send Feedback
Gets or sets the parts list font.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Font PartsListFont { get; set; }
Visual Basic (Declaration)
Public Property PartsListFont As Font
Visual C++
public:
property Font^ PartsListFont {
    Font^ get ();
    void set (Font^ value);
}

Field Value

The parts list font.

See Also

PrintService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PrintedPDFPassword Property

[image]

LinkOne WebView API
PrintService..::.PrintedPDFPassword Property
PrintService Class See Also Send Feedback
Gets the printed PDF password for locked printed pdf's

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PrintedPDFPassword { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrintedPDFPassword As String
Visual C++
public:
property String^ PrintedPDFPassword {
    String^ get ();
}

See Also

PrintService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


PrintScope Property

[image]

LinkOne WebView API
PrintService..::.PrintScope Property
PrintService Class See Also Send Feedback
Gets or sets the print scope for the current request.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public PrintScope PrintScope { get; set; }
Visual Basic (Declaration)
Public Property PrintScope As PrintScope
Visual C++
public:
property PrintScope PrintScope {
    PrintScope get ();
    void set (PrintScope value);
}

See Also

PrintService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ShowPrintBookOption Property

[image]

LinkOne WebView API
PrintService..::.ShowPrintBookOption Property
PrintService Class See Also Send Feedback
Gets or sets whether or not to display the Print Current Book option.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool ShowPrintBookOption { get; }
Visual Basic (Declaration)
Public ReadOnly Property ShowPrintBookOption As Boolean
Visual C++
public:
property bool ShowPrintBookOption {
    bool get ();
}

See Also

PrintService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


SimultaneousBookPrintCount Property

[image]

LinkOne WebView API
PrintService..::.SimultaneousBookPrintCount Property
PrintService Class See Also Send Feedback
Gets the maximum number of simultaneous book prints to allow

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int SimultaneousBookPrintCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property SimultaneousBookPrintCount As Integer
Visual C++
public:
property int SimultaneousBookPrintCount {
    int get ();
}

See Also

PrintService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ZoomedArea Property

[image]

LinkOne WebView API
PrintService..::.ZoomedArea Property
PrintService Class See Also Send Feedback
Gets or sets the picture zoomed area for the current request.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Rectangle ZoomedArea { get; set; }
Visual Basic (Declaration)
Public Property ZoomedArea As Rectangle
Visual C++
public:
property Rectangle ZoomedArea {
    Rectangle get ();
    void set (Rectangle value);
}

See Also

PrintService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ReportService Class

[image]

LinkOne WebView API
ReportService Class
Members See Also Send Feedback
This service provides access to all reporting.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public sealed class ReportService : ServiceBase
Visual Basic (Declaration)
Public NotInheritable Class ReportService _
    Inherits ServiceBase
Visual C++
public ref class ReportService sealed : public ServiceBase

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.Services..::.ServiceBase
Mincom.LinkOne.WebView.WebServer.Services..::.ReportService

See Also

ReportService Members
Mincom.LinkOne.WebView.WebServer.Services Namespace


ReportService Members

[image] [image]

LinkOne WebView API
ReportService Members
ReportService Class Constructors Methods Properties See Also Send Feedback

The ReportService type exposes the following members.

Constructors

Name | Description
ReportService | Initializes a new instance of the ReportService class.

Methods

Name | Description
ClearLog | Clears the view log of all entries older then LogExpiresDays.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
ForceReportView | Records the viewing of a page.
GetBookLog | Gets the book activity log as a list of records with properties of Book, PagesViewed, LastViewed.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLogCsv | Gets the log in CSV format for the given date range.
GetType | Gets the type of the current instance. (Inherited from Object.)
GetUserLog | Gets the user activity log as a list of records with properties of UserName, Logins, PagesViewed.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReportLogin | Report a login.
ReportView | Report a viewed page the first time this is called for a session.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Current | Gets the Report service for the current request.
LogExpiresDays | Gets or sets the log expires days.

See Also

ReportService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ReportService Constructor

[image]

LinkOne WebView API
ReportService Constructor
ReportService Class See Also Send Feedback
Initializes a new instance of the ReportService class.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public ReportService()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportService()

See Also

ReportService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ReportService Methods

[image] [image]

LinkOne WebView API
ReportService Methods
ReportService Class See Also Send Feedback

The ReportService type exposes the following members.

Methods

Name | Description
ClearLog | Clears the view log of all entries older then LogExpiresDays.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
ForceReportView | Records the viewing of a page.
GetBookLog | Gets the book activity log as a list of records with properties of Book, PagesViewed, LastViewed.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLogCsv | Gets the log in CSV format for the given date range.
GetType | Gets the type of the current instance. (Inherited from Object.)
GetUserLog | Gets the user activity log as a list of records with properties of UserName, Logins, PagesViewed.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReportLogin | Report a login.
ReportView | Report a viewed page the first time this is called for a session.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ReportService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ClearLog Method

[image]

LinkOne WebView API
ReportService..::.ClearLog Method
ReportService Class See Also Send Feedback
Clears the view log of all entries older then LogExpiresDays.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void ClearLog()
Visual Basic (Declaration)
Public Sub ClearLog
Visual C++
public:
void ClearLog()

Remarks

If the value of LogExpiresDays is less then or equal to 0 then the log data does not expire and should not be cleaned.

See Also

ReportService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ForceReportView Method

[image]

LinkOne WebView API
ReportService..::.ForceReportView Method
ReportService Class See Also Send Feedback
Records the viewing of a page.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void ForceReportView(
    string bookLanguage,
    string publisherCode,
    string bookCode,
    string pageReference
)
Visual Basic (Declaration)
Public Sub ForceReportView ( _
    bookLanguage As String, _
    publisherCode As String, _
    bookCode As String, _
    pageReference As String _
)
Visual C++
public:
void ForceReportView(
    String^ bookLanguage,
    String^ publisherCode,
    String^ bookCode,
    String^ pageReference
)

Parameters

bookLanguage
Type: System..::.String
The viewed book language.
publisherCode
Type: System..::.String
The viewed publisher code.
bookCode
Type: System..::.String
The viewed book code.
pageReference
Type: System..::.String
The viewed page reference.

Remarks

This is similar to ReportView(String, String, String, String) except that it does not rely on session state and records the viewing every time it is called. Only if pageReference is not specified will this method do nothing.

See Also

ReportService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


GetBookLog Method

[image]

LinkOne WebView API
ReportService..::.GetBookLog Method
ReportService Class See Also Send Feedback
Gets the book activity log as a list of records with properties of Book, PagesViewed, LastViewed.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public IEnumerable GetBookLog(
    DateTime historyFrom,
    DateTime historyTo
)
Visual Basic (Declaration)
Public Function GetBookLog ( _
    historyFrom As DateTime, _
    historyTo As DateTime _
) As IEnumerable
Visual C++
public:
IEnumerable^ GetBookLog(
    DateTime historyFrom,
    DateTime historyTo
)

Parameters

historyFrom
Type: System..::.DateTime
The period to start the report at.
historyTo
Type: System..::.DateTime
The period to stop the report at.

Return Value

The report.

See Also

ReportService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


GetLogCsv Method

[image]

LinkOne WebView API
ReportService..::.GetLogCsv Method
ReportService Class See Also Send Feedback
Gets the log in CSV format for the given date range.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string GetLogCsv(
    DateTime fromDate,
    DateTime toDate
)
Visual Basic (Declaration)
Public Function GetLogCsv ( _
    fromDate As DateTime, _
    toDate As DateTime _
) As String
Visual C++
public:
String^ GetLogCsv(
    DateTime fromDate,
    DateTime toDate
)

Parameters

fromDate
Type: System..::.DateTime
The date to start the CSV from.
toDate
Type: System..::.DateTime
The date to end the CSV at.

Return Value

The log in CSV format for the given date range.

See Also

ReportService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


GetUserLog Method

[image]

LinkOne WebView API
ReportService..::.GetUserLog Method
ReportService Class See Also Send Feedback
Gets the user activity log as a list of records with properties of UserName, Logins, PagesViewed.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public IEnumerable GetUserLog(
    DateTime historyFrom,
    DateTime historyTo
)
Visual Basic (Declaration)
Public Function GetUserLog ( _
    historyFrom As DateTime, _
    historyTo As DateTime _
) As IEnumerable
Visual C++
public:
IEnumerable^ GetUserLog(
    DateTime historyFrom,
    DateTime historyTo
)

Parameters

historyFrom
Type: System..::.DateTime
The period to start the report at.
historyTo
Type: System..::.DateTime
The period to stop the report at.

Return Value

The report.

See Also

ReportService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ReportLogin Method

[image]

LinkOne WebView API
ReportService..::.ReportLogin Method
ReportService Class See Also Send Feedback
Report a login.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void ReportLogin()
Visual Basic (Declaration)
Public Sub ReportLogin
Visual C++
public:
void ReportLogin()

See Also

ReportService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ReportView Method

[image]

LinkOne WebView API
ReportService..::.ReportView Method
ReportService Class See Also Send Feedback
Report a viewed page the first time this is called for a session.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void ReportView(
    string bookLanguage,
    string publisherCode,
    string bookCode,
    string pageReference
)
Visual Basic (Declaration)
Public Sub ReportView ( _
    bookLanguage As String, _
    publisherCode As String, _
    bookCode As String, _
    pageReference As String _
)
Visual C++
public:
void ReportView(
    String^ bookLanguage,
    String^ publisherCode,
    String^ bookCode,
    String^ pageReference
)

Parameters

bookLanguage
Type: System..::.String
The viewed book language.
publisherCode
Type: System..::.String
The viewed publisher code.
bookCode
Type: System..::.String
The viewed book code.
pageReference
Type: System..::.String
The viewed page reference.

Remarks

Aborts if there is no session state data, it is read only or a page reference is not given.

See Also

ReportService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace
HttpContext..::.Session


ReportService Properties

[image] [image]

LinkOne WebView API
ReportService Properties
ReportService Class See Also Send Feedback

The ReportService type exposes the following members.

Properties

Name | Description
Current | Gets the Report service for the current request.
LogExpiresDays | Gets or sets the log expires days.

See Also

ReportService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


Current Property

[image]

LinkOne WebView API
ReportService..::.Current Property
ReportService Class See Also Send Feedback
Gets the Report service for the current request.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public static ReportService Current { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Current As ReportService
Visual C++
public:
static property ReportService^ Current {
    ReportService^ get ();
}

Return Value

The Report service for the current request.

Remarks

A Report service object is automatically associated with each request to the web server, and may be obtained by calling this static method.

See Also

ReportService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


LogExpiresDays Property

[image]

LinkOne WebView API
ReportService..::.LogExpiresDays Property
ReportService Class See Also Send Feedback
Gets or sets the log expires days.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int LogExpiresDays { get; set; }
Visual Basic (Declaration)
Public Property LogExpiresDays As Integer
Visual C++
public:
property int LogExpiresDays {
    int get ();
    void set (int value);
}

Remarks

A value of less then or equal to 0 implies the the log data never expires.

See Also

ReportService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


SearchService Class

[image]

LinkOne WebView API
SearchService Class
Members See Also Send Feedback
This service provides search facilities.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public sealed class SearchService : ServiceBase
Visual Basic (Declaration)
Public NotInheritable Class SearchService _
    Inherits ServiceBase
Visual C++
public ref class SearchService sealed : public ServiceBase

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.Services..::.ServiceBase
Mincom.LinkOne.WebView.WebServer.Services..::.SearchService

See Also

SearchService Members
Mincom.LinkOne.WebView.WebServer.Services Namespace


SearchService Members

[image] [image]

LinkOne WebView API
SearchService Members
SearchService Class Methods See Also Send Feedback

The SearchService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SearchService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


SearchService Methods

[image] [image]

LinkOne WebView API
SearchService Methods
SearchService Class See Also Send Feedback

The SearchService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SearchService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


SecurityService Class

[image]

LinkOne WebView API
SecurityService Class
Members See Also Send Feedback
This service provides access to the security settings.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public sealed class SecurityService : ServiceBase,
    ISecurityService
Visual Basic (Declaration)
Public NotInheritable Class SecurityService _
    Inherits ServiceBase _
    Implements ISecurityService
Visual C++
public ref class SecurityService sealed : public ServiceBase,
    ISecurityService

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.Services..::.ServiceBase
Mincom.LinkOne.WebView.WebServer.Services..::.SecurityService

See Also

SecurityService Members
Mincom.LinkOne.WebView.WebServer.Services Namespace


SecurityService Members

[image] [image]

LinkOne WebView API
SecurityService Members
SecurityService Class Methods See Also Send Feedback

The SecurityService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SecurityService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


SecurityService Methods

[image] [image]

LinkOne WebView API
SecurityService Methods
SecurityService Class See Also Send Feedback

The SecurityService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SecurityService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


SelectionListService Class

[image]

LinkOne WebView API
SelectionListService Class
Members Example See Also Send Feedback
This service provides access to the user's selection list.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public sealed class SelectionListService : ServiceBase
Visual Basic (Declaration)
Public NotInheritable Class SelectionListService _
    Inherits ServiceBase
Visual C++
public ref class SelectionListService sealed : public ServiceBase

Remarks

The currently active selection list is determined by the selection list Name()()() and the selection list ConfigurationName()()().

Examples

[C#]
CopyC#
/// Get the current Service.SelectionList
Mincom.LinkOne.WebView.WebServer.Services.SelectionListService selectionListService = Mincom.LinkOne.WebView.WebServer.Services.SelectionListService.Current;

/// Clear the selection List
selectionListService.Clear();

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.Services..::.ServiceBase
Mincom.LinkOne.WebView.WebServer.Services..::.SelectionListService

See Also

SelectionListService Members
Mincom.LinkOne.WebView.WebServer.Services Namespace


SelectionListService Members

[image] [image]

LinkOne WebView API
SelectionListService Members
SelectionListService Class Methods See Also Send Feedback

The SelectionListService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SelectionListService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


SelectionListService Methods

[image] [image]

LinkOne WebView API
SelectionListService Methods
SelectionListService Class See Also Send Feedback

The SelectionListService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SelectionListService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ServiceBase Class

[image]

LinkOne WebView API
ServiceBase Class
Members See Also Send Feedback
Provides a base implementation for all services.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class ServiceBase
Visual Basic (Declaration)
Public Class ServiceBase
Visual C++
public ref class ServiceBase

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.Services..::.ServiceBase
Mincom.LinkOne.WebView.WebServer.Services..::.BookService
Mincom.LinkOne.WebView.WebServer.Services..::.ConfigurationManagerService
Mincom.LinkOne.WebView.WebServer.Services..::.ErrorService
Mincom.LinkOne.WebView.WebServer.Services..::.NoteService
Mincom.LinkOne.WebView.WebServer.Services..::.OfflineDBService
Mincom.LinkOne.WebView.WebServer.Services..::.PrintService
Mincom.LinkOne.WebView.WebServer.Services..::.ReportService
Mincom.LinkOne.WebView.WebServer.Services..::.SearchService
Mincom.LinkOne.WebView.WebServer.Services..::.SecurityService
Mincom.LinkOne.WebView.WebServer.Services..::.SelectionListService
Mincom.LinkOne.WebView.WebServer.Services..::.TokenService
Mincom.LinkOne.WebView.WebServer.Services..::.WebConfigReader

See Also

ServiceBase Members
Mincom.LinkOne.WebView.WebServer.Services Namespace


ServiceBase Members

[image] [image]

LinkOne WebView API
ServiceBase Members
ServiceBase Class Methods See Also Send Feedback

The ServiceBase type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ServiceBase Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ServiceBase Methods

[image] [image]

LinkOne WebView API
ServiceBase Methods
ServiceBase Class See Also Send Feedback

The ServiceBase type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ServiceBase Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


TokenService Class

[image]

LinkOne WebView API
TokenService Class
Members See Also Send Feedback
Manages the website licensing and tokens.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public sealed class TokenService : ServiceBase
Visual Basic (Declaration)
Public NotInheritable Class TokenService _
    Inherits ServiceBase
Visual C++
public ref class TokenService sealed : public ServiceBase

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.Services..::.ServiceBase
Mincom.LinkOne.WebView.WebServer.Services..::.TokenService

See Also

TokenService Members
Mincom.LinkOne.WebView.WebServer.Services Namespace


TokenService Members

[image] [image]

LinkOne WebView API
TokenService Members
TokenService Class Constructors Methods Fields Properties See Also Send Feedback

The TokenService type exposes the following members.

Constructors

Name | Description
TokenService | Initializes a new instance of the TokenService class.

Methods

Name | Description
AddSiteLicense | Adds a site license.
ClearLog | Clears the token log of all entries older then LogExpiresDays.
DeleteSiteLicense | Deletes a site license.
EndSession | Tries to end a session.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSiteLicenses | Gets an enumeration of installed site licenses.
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryRemoveMyToken | Tries to remove the current users token.
TryRemoveToken | Tries to remove a token.
webTokenCount | Gets the current number of tokens in use by the application (for Login Activity report)
webTokenLimit | Gets the maximum number of tokens available to the application (also used for Login Activity report).

Fields

Name | Description
KeyConfigSiteLicenses |

Properties

Name | Description
Authorized | Gets true if this request is authorized.
Current | Gets a singleton for the Token.
LogExpiresDays | Gets or sets the log expires days.
TokenCount | Gets the current number of tokens in use by the application.
TokenLimit | Gets the maximum number of tokens available to the application.

See Also

TokenService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


TokenService Constructor

[image]

LinkOne WebView API
TokenService Constructor
TokenService Class See Also Send Feedback
Initializes a new instance of the TokenService class.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public TokenService()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TokenService()

See Also

TokenService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


TokenService Fields

[image] [image]

LinkOne WebView API
TokenService Fields
TokenService Class See Also Send Feedback

The TokenService type exposes the following members.

Fields

Name | Description
KeyConfigSiteLicenses |

See Also

TokenService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


KeyConfigSiteLicenses Field

[image]

LinkOne WebView API
TokenService..::.KeyConfigSiteLicenses Field
TokenService Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public const string KeyConfigSiteLicenses
Visual Basic (Declaration)
Public Const KeyConfigSiteLicenses As String
Visual C++
public:
literal String^ KeyConfigSiteLicenses

See Also

TokenService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


TokenService Methods

[image] [image]

LinkOne WebView API
TokenService Methods
TokenService Class See Also Send Feedback

The TokenService type exposes the following members.

Methods

Name | Description
AddSiteLicense | Adds a site license.
ClearLog | Clears the token log of all entries older then LogExpiresDays.
DeleteSiteLicense | Deletes a site license.
EndSession | Tries to end a session.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSiteLicenses | Gets an enumeration of installed site licenses.
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TryRemoveMyToken | Tries to remove the current users token.
TryRemoveToken | Tries to remove a token.
webTokenCount | Gets the current number of tokens in use by the application (for Login Activity report)
webTokenLimit | Gets the maximum number of tokens available to the application (also used for Login Activity report).

See Also

TokenService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


AddSiteLicense Method

[image]

LinkOne WebView API
TokenService..::.AddSiteLicense Method
TokenService Class See Also Send Feedback
Adds a site license.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void AddSiteLicense(
    string licenseXml
)
Visual Basic (Declaration)
Public Sub AddSiteLicense ( _
    licenseXml As String _
)
Visual C++
public:
void AddSiteLicense(
    String^ licenseXml
)

Parameters

licenseXml
Type: System..::.String
The license XML.

See Also

TokenService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


ClearLog Method

[image]

LinkOne WebView API
TokenService..::.ClearLog Method
TokenService Class See Also Send Feedback
Clears the token log of all entries older then LogExpiresDays.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void ClearLog()
Visual Basic (Declaration)
Public Sub ClearLog
Visual C++
public:
void ClearLog()

Remarks

If the value of LogExpiresDays is less then or equal to 0 then the log data does not expire and should not be cleaned.

See Also

TokenService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


DeleteSiteLicense Method

[image]

LinkOne WebView API
TokenService..::.DeleteSiteLicense Method
TokenService Class See Also Send Feedback
Deletes a site license.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool DeleteSiteLicense(
    string licenseId
)
Visual Basic (Declaration)
Public Function DeleteSiteLicense ( _
    licenseId As String _
) As Boolean
Visual C++
public:
bool DeleteSiteLicense(
    String^ licenseId
)

Parameters

licenseId
Type: System..::.String
The license identifier.

Return Value

A value indicating whether the site license was removed.

See Also

TokenService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


EndSession Method

[image]

LinkOne WebView API
TokenService..::.EndSession Method
TokenService Class See Also Send Feedback
Tries to end a session.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void EndSession()
Visual Basic (Declaration)
Public Sub EndSession
Visual C++
public:
void EndSession()

See Also

TokenService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


GetSiteLicenses Method

[image]

LinkOne WebView API
TokenService..::.GetSiteLicenses Method
TokenService Class See Also Send Feedback
Gets an enumeration of installed site licenses.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public ICollection<LinkOneLicense> GetSiteLicenses()
Visual Basic (Declaration)
Public Function GetSiteLicenses As ICollection(Of LinkOneLicense)
Visual C++
public:
ICollection<LinkOneLicense^>^ GetSiteLicenses()

See Also

TokenService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


TryRemoveMyToken Method

[image]

LinkOne WebView API
TokenService..::.TryRemoveMyToken Method
TokenService Class See Also Send Feedback
Tries to remove the current users token.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool TryRemoveMyToken()
Visual Basic (Declaration)
Public Function TryRemoveMyToken As Boolean
Visual C++
public:
bool TryRemoveMyToken()

Return Value

A value indicating whether the token was removed. If the token was not valid, then this method also returns false.

See Also

TokenService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


TryRemoveToken Method

[image]

LinkOne WebView API
TokenService..::.TryRemoveToken Method
TokenService Class See Also Send Feedback
Tries to remove a token.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool TryRemoveToken(
    Guid tokenId
)
Visual Basic (Declaration)
Public Function TryRemoveToken ( _
    tokenId As Guid _
) As Boolean
Visual C++
public:
bool TryRemoveToken(
    Guid tokenId
)

Parameters

tokenId
Type: System..::.Guid
The token id to be removed.

Return Value

A value indicating whether a token was removed. If the token was not valid, then this method also returns false.

See Also

TokenService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


webTokenCount Method

[image]

LinkOne WebView API
TokenService..::.webTokenCount Method
TokenService Class See Also Send Feedback
Gets the current number of tokens in use by the application (for Login Activity report)

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int webTokenCount(
    string webSite
)
Visual Basic (Declaration)
Public Function webTokenCount ( _
    webSite As String _
) As Integer
Visual C++
public:
int webTokenCount(
    String^ webSite
)

Parameters

webSite
Type: System..::.String

See Also

TokenService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


webTokenLimit Method

[image]

LinkOne WebView API
TokenService..::.webTokenLimit Method
TokenService Class See Also Send Feedback
Gets the maximum number of tokens available to the application (also used for Login Activity report).

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int webTokenLimit(
    string webSite
)
Visual Basic (Declaration)
Public Function webTokenLimit ( _
    webSite As String _
) As Integer
Visual C++
public:
int webTokenLimit(
    String^ webSite
)

Parameters

webSite
Type: System..::.String

See Also

TokenService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


TokenService Properties

[image] [image]

LinkOne WebView API
TokenService Properties
TokenService Class See Also Send Feedback

The TokenService type exposes the following members.

Properties

Name | Description
Authorized | Gets true if this request is authorized.
Current | Gets a singleton for the Token.
LogExpiresDays | Gets or sets the log expires days.
TokenCount | Gets the current number of tokens in use by the application.
TokenLimit | Gets the maximum number of tokens available to the application.

See Also

TokenService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


Authorized Property

[image]

LinkOne WebView API
TokenService..::.Authorized Property
TokenService Class See Also Send Feedback
Gets true if this request is authorized.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool Authorized { get; internal set; }
Visual Basic (Declaration)
Public Property Authorized As Boolean
Visual C++
public:
property bool Authorized {
    bool get ();
    void set (bool value);
}

See Also

TokenService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


Current Property

[image]

LinkOne WebView API
TokenService..::.Current Property
TokenService Class See Also Send Feedback
Gets a singleton for the Token.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public static TokenService Current { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Current As TokenService
Visual C++
public:
static property TokenService^ Current {
    TokenService^ get ();
}

See Also

TokenService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


LogExpiresDays Property

[image]

LinkOne WebView API
TokenService..::.LogExpiresDays Property
TokenService Class See Also Send Feedback
Gets or sets the log expires days.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int LogExpiresDays { get; set; }
Visual Basic (Declaration)
Public Property LogExpiresDays As Integer
Visual C++
public:
property int LogExpiresDays {
    int get ();
    void set (int value);
}

Remarks

A value of less then or equal to 0 implies the the log data never expires.

See Also

TokenService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


TokenCount Property

[image]

LinkOne WebView API
TokenService..::.TokenCount Property
TokenService Class See Also Send Feedback
Gets the current number of tokens in use by the application.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int TokenCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property TokenCount As Integer
Visual C++
public:
property int TokenCount {
    int get ();
}

See Also

TokenService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


TokenLimit Property

[image]

LinkOne WebView API
TokenService..::.TokenLimit Property
TokenService Class See Also Send Feedback
Gets the maximum number of tokens available to the application.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int TokenLimit { get; }
Visual Basic (Declaration)
Public ReadOnly Property TokenLimit As Integer
Visual C++
public:
property int TokenLimit {
    int get ();
}

See Also

TokenService Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


WebConfigReader Class

[image]

LinkOne WebView API
WebConfigReader Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class WebConfigReader : ServiceBase
Visual Basic (Declaration)
Public Class WebConfigReader _
    Inherits ServiceBase
Visual C++
public ref class WebConfigReader : public ServiceBase

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.Services..::.ServiceBase
Mincom.LinkOne.WebView.WebServer.Services..::.WebConfigReader

See Also

WebConfigReader Members
Mincom.LinkOne.WebView.WebServer.Services Namespace


WebConfigReader Members

[image] [image]

LinkOne WebView API
WebConfigReader Members
WebConfigReader Class Constructors Methods Properties See Also Send Feedback

The WebConfigReader type exposes the following members.

Constructors

Name | Description
WebConfigReader | Constructor for WebConfigReader with a parameter of the location of the LinkOne web site

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
LibraryPaths | Property to return the Library Paths for all the configured LinkOne libraries defined by the user. If the Library paths has not been retrieved, the current WebView config file is read to obtain the value before returning to the caller.
LinkOneDBSQLConnectionString | Property to return the LinkOneDb SQL Connection String which is retrieved from the web.config. If the property does not have a value, the value is retrieved before returning to the caller.

See Also

WebConfigReader Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


WebConfigReader Constructor

[image]

LinkOne WebView API
WebConfigReader Constructor
WebConfigReader Class See Also Send Feedback
Constructor for WebConfigReader with a parameter of the location of the LinkOne web site

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public WebConfigReader(
    string linkOneWebDir
)
Visual Basic (Declaration)
Public Sub New ( _
    linkOneWebDir As String _
)
Visual C++
public:
WebConfigReader(
    String^ linkOneWebDir
)

Parameters

linkOneWebDir
Type: System..::.String

See Also

WebConfigReader Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


WebConfigReader Methods

[image] [image]

LinkOne WebView API
WebConfigReader Methods
WebConfigReader Class See Also Send Feedback

The WebConfigReader type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

WebConfigReader Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


WebConfigReader Properties

[image] [image]

LinkOne WebView API
WebConfigReader Properties
WebConfigReader Class See Also Send Feedback

The WebConfigReader type exposes the following members.

Properties

Name | Description
LibraryPaths | Property to return the Library Paths for all the configured LinkOne libraries defined by the user. If the Library paths has not been retrieved, the current WebView config file is read to obtain the value before returning to the caller.
LinkOneDBSQLConnectionString | Property to return the LinkOneDb SQL Connection String which is retrieved from the web.config. If the property does not have a value, the value is retrieved before returning to the caller.

See Also

WebConfigReader Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


LibraryPaths Property

[image]

LinkOne WebView API
WebConfigReader..::.LibraryPaths Property
WebConfigReader Class See Also Send Feedback
Property to return the Library Paths for all the configured LinkOne libraries defined by the user. If the Library paths has not been retrieved, the current WebView config file is read to obtain the value before returning to the caller.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public List<string> LibraryPaths { get; }
Visual Basic (Declaration)
Public ReadOnly Property LibraryPaths As List(Of String)
Visual C++
public:
property List<String^>^ LibraryPaths {
    List<String^>^ get ();
}

See Also

WebConfigReader Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


LinkOneDBSQLConnectionString Property

[image]

LinkOne WebView API
WebConfigReader..::.LinkOneDBSQLConnectionString Property
WebConfigReader Class See Also Send Feedback
Property to return the LinkOneDb SQL Connection String which is retrieved from the web.config. If the property does not have a value, the value is retrieved before returning to the caller.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string LinkOneDBSQLConnectionString { get; }
Visual Basic (Declaration)
Public ReadOnly Property LinkOneDBSQLConnectionString As String
Visual C++
public:
property String^ LinkOneDBSQLConnectionString {
    String^ get ();
}

See Also

WebConfigReader Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


WebViewErrorLogEntry Class

[image]

LinkOne WebView API
WebViewErrorLogEntry Class
Members See Also Send Feedback
Implements ErrorLogEntry for general error reporting within Web View services.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class WebViewErrorLogEntry : ErrorLogEntry
Visual Basic (Declaration)
Public Class WebViewErrorLogEntry _
    Inherits ErrorLogEntry
Visual C++
public ref class WebViewErrorLogEntry : public ErrorLogEntry

Remarks

This implementation adds the following data sections to the error log:
Section Name | Description
SessionVariables | Details of the current connection variables: [user, theme, language code, selection list name].
Filters | The active page filters.
Licences | The installed Web View licences.
This information is not readily available without accessing services.

Inheritance Hierarchy

System..::.Object
ErrorLogEntry
Mincom.LinkOne.WebView.WebServer.Services..::.WebViewErrorLogEntry

See Also

WebViewErrorLogEntry Members
Mincom.LinkOne.WebView.WebServer.Services Namespace


WebViewErrorLogEntry Members

[image] [image]

LinkOne WebView API
WebViewErrorLogEntry Members
WebViewErrorLogEntry Class Constructors Methods See Also Send Feedback

The WebViewErrorLogEntry type exposes the following members.

Constructors

Name | Description
WebViewErrorLogEntry | Initializes a new instance of the WebViewErrorLogEntry class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSections | (Overrides ErrorLogEntryGetSections()()().)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
WriteSection | Writes additional sections. See class remarks. (Overrides ErrorLogEntryWriteSection(String, XmlElement).)

See Also

WebViewErrorLogEntry Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


WebViewErrorLogEntry Constructor

[image]

LinkOne WebView API
WebViewErrorLogEntry Constructor
WebViewErrorLogEntry Class See Also Send Feedback
Initializes a new instance of the WebViewErrorLogEntry class

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public WebViewErrorLogEntry()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WebViewErrorLogEntry()

See Also

WebViewErrorLogEntry Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


WebViewErrorLogEntry Methods

[image] [image]

LinkOne WebView API
WebViewErrorLogEntry Methods
WebViewErrorLogEntry Class See Also Send Feedback

The WebViewErrorLogEntry type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSections | (Overrides ErrorLogEntryGetSections()()().)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
WriteSection | Writes additional sections. See class remarks. (Overrides ErrorLogEntryWriteSection(String, XmlElement).)

See Also

WebViewErrorLogEntry Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


GetSections Method

[image]

LinkOne WebView API
WebViewErrorLogEntry..::.GetSections Method
WebViewErrorLogEntry Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public override string[] GetSections()
Visual Basic (Declaration)
Public Overrides Function GetSections As String()
Visual C++
public:
virtual array<String^>^ GetSections() override

See Also

WebViewErrorLogEntry Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


WriteSection Method

[image]

LinkOne WebView API
WebViewErrorLogEntry..::.WriteSection Method
WebViewErrorLogEntry Class See Also Send Feedback
Writes additional sections. See class remarks.

Namespace: Mincom.LinkOne.WebView.WebServer.Services
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public override void WriteSection(
    string sectionName,
    XmlElement element
)
Visual Basic (Declaration)
Public Overrides Sub WriteSection ( _
    sectionName As String, _
    element As XmlElement _
)
Visual C++
public:
virtual void WriteSection(
    String^ sectionName,
    XmlElement^ element
) override

Parameters

sectionName
Type: System..::.String
The name of the section to write.
element
Type: System.Xml..::.XmlElement
Xml element to write to.

See Also

WebViewErrorLogEntry Class
Mincom.LinkOne.WebView.WebServer.Services Namespace


Mincom.LinkOne.WebView.WebServer.WebServices Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.WebView.WebServer.WebServices Namespace
Send Feedback
The Mincom.LinkOne.WebView.WebServer.WebServices namespace supplies classes that provide web services for accessing and modifying state information on the LinkOne WebView web server.

Classes

Class | Description
BookService | This service provides access to all picture resources.
NoteService |
OfflineDBService |
PictureControlService |
PrintService | This service provides searching functionality.
SearchService | This service provides searching functionality.
SecurityService | This service provides access to website security.
SelectionListService | This service provides access to selection list data.

Interfaces

Interface | Description
IBookService | This service provides access to all picture resources.
INoteService |
IOfflineDBService |
IPictureControlService |
IPrintService | This service provides searching functionality.
ISearchService | This service provides searching functionality.
ISecurityService | This service provides access to website security.
ISelectionListService | This service provides access to selection list data.


BookService Class

[image]

LinkOne WebView API
BookService Class
Members See Also Send Feedback
This service provides access to all picture resources.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class BookService : IBookService
Visual Basic (Declaration)
Public Class BookService _
    Implements IBookService
Visual C++
public ref class BookService : IBookService

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices..::.BookService

See Also

BookService Members
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


BookService Members

[image] [image]

LinkOne WebView API
BookService Members
BookService Class Methods See Also Send Feedback

The BookService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


BookService Methods

[image] [image]

LinkOne WebView API
BookService Methods
BookService Class See Also Send Feedback

The BookService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BookService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


IBookService Interface

[image]

LinkOne WebView API
IBookService Interface
Members See Also Send Feedback
This service provides access to all picture resources.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public interface IBookService
Visual Basic (Declaration)
Public Interface IBookService
Visual C++
public interface class IBookService

See Also

IBookService Members
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


IBookService Members

[image] [image]

LinkOne WebView API
IBookService Members
IBookService Interface Methods See Also Send Feedback

The IBookService type exposes the following members.

Methods

Name | Description
GetAllPublishers | Get all publishers that are allowed for offline view
GetAllPublishersAndBooks | Get all publishers and their respective books that are allowed for offline view
GetBookCategories | Get categories of a given book
GetBookInfos | Gets bookinfos (containing book and publisher code and descriptions) for all available books.
GetCategoriesAndBooks | Get all categories and books of a given publisher and category
GetFileVersion | Gets the webview file version
GetLanguageCode | Gets the current language code.
GetLanguageCodes | Gets the available language codes.
GetLibraries | Gets the configured library locations.
GetNotes | Fetches a list of notes for a particular book and optional page reference.
GetPageEmbeddedFileInfo | Gets the embedded file information of the page corresponding to the publisher, book and page reference.
GetPageEntries | Gets the entries from the parts list of the page corresponding to the publisher, book and page code/reference.
GetPageReferences | Gets the available page references for a book.
GetPicture | Gets the picture for the given page.
GetPictures | Gets the pictures meta data for the given page.
GetProductVersion | Gets the webview product version
GetPublisherAndBookCodes | Gets publisher/book code pairs for all available books.
Initialize | Initializes the specified book language code.
ReindexLibrary | Reindexes the given library.
ReindexLibraryEx | Reindexes the given library and returns result.
SyncLibrary | Synchronises the given library.

See Also

IBookService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


IBookService Methods

[image] [image]

LinkOne WebView API
IBookService Methods
IBookService Interface See Also Send Feedback

The IBookService type exposes the following members.

Methods

Name | Description
GetAllPublishers | Get all publishers that are allowed for offline view
GetAllPublishersAndBooks | Get all publishers and their respective books that are allowed for offline view
GetBookCategories | Get categories of a given book
GetBookInfos | Gets bookinfos (containing book and publisher code and descriptions) for all available books.
GetCategoriesAndBooks | Get all categories and books of a given publisher and category
GetFileVersion | Gets the webview file version
GetLanguageCode | Gets the current language code.
GetLanguageCodes | Gets the available language codes.
GetLibraries | Gets the configured library locations.
GetNotes | Fetches a list of notes for a particular book and optional page reference.
GetPageEmbeddedFileInfo | Gets the embedded file information of the page corresponding to the publisher, book and page reference.
GetPageEntries | Gets the entries from the parts list of the page corresponding to the publisher, book and page code/reference.
GetPageReferences | Gets the available page references for a book.
GetPicture | Gets the picture for the given page.
GetPictures | Gets the pictures meta data for the given page.
GetProductVersion | Gets the webview product version
GetPublisherAndBookCodes | Gets publisher/book code pairs for all available books.
Initialize | Initializes the specified book language code.
ReindexLibrary | Reindexes the given library.
ReindexLibraryEx | Reindexes the given library and returns result.
SyncLibrary | Synchronises the given library.

See Also

IBookService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetAllPublishers Method

[image]

LinkOne WebView API
IBookService..::.GetAllPublishers Method
IBookService Interface See Also Send Feedback
Get all publishers that are allowed for offline view

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
Node[] GetAllPublishers()
Visual Basic (Declaration)
Function GetAllPublishers As Node()
Visual C++
array<Node^>^ GetAllPublishers()

Return Value

See Also

IBookService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetAllPublishersAndBooks Method

[image]

LinkOne WebView API
IBookService..::.GetAllPublishersAndBooks Method
IBookService Interface See Also Send Feedback
Get all publishers and their respective books that are allowed for offline view

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
Node[] GetAllPublishersAndBooks(
    bool includePages
)
Visual Basic (Declaration)
Function GetAllPublishersAndBooks ( _
    includePages As Boolean _
) As Node()
Visual C++
array<Node^>^ GetAllPublishersAndBooks(
    bool includePages
)

Parameters

includePages
Type: System..::.Boolean

Return Value

See Also

IBookService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetBookCategories Method

[image]

LinkOne WebView API
IBookService..::.GetBookCategories Method
IBookService Interface See Also Send Feedback
Get categories of a given book

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
string[] GetBookCategories(
    string publisherCode,
    string bookCode
)
Visual Basic (Declaration)
Function GetBookCategories ( _
    publisherCode As String, _
    bookCode As String _
) As String()
Visual C++
array<String^>^ GetBookCategories(
    String^ publisherCode,
    String^ bookCode
)

Parameters

publisherCode
Type: System..::.String
bookCode
Type: System..::.String

Return Value

See Also

IBookService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetBookInfos Method

[image]

LinkOne WebView API
IBookService..::.GetBookInfos Method
IBookService Interface See Also Send Feedback
Gets bookinfos (containing book and publisher code and descriptions) for all available books.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
BookInfo[] GetBookInfos()
Visual Basic (Declaration)
Function GetBookInfos As BookInfo()
Visual C++
array<BookInfo^>^ GetBookInfos()

Return Value

The bookinfos for available books.

See Also

IBookService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetCategoriesAndBooks Method

[image]

LinkOne WebView API
IBookService..::.GetCategoriesAndBooks Method
IBookService Interface See Also Send Feedback
Get all categories and books of a given publisher and category

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
Node[] GetCategoriesAndBooks(
    string publisherCode,
    string tag
)
Visual Basic (Declaration)
Function GetCategoriesAndBooks ( _
    publisherCode As String, _
    tag As String _
) As Node()
Visual C++
array<Node^>^ GetCategoriesAndBooks(
    String^ publisherCode,
    String^ tag
)

Parameters

publisherCode
Type: System..::.String
tag
Type: System..::.String

Return Value

See Also

IBookService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetFileVersion Method

[image]

LinkOne WebView API
IBookService..::.GetFileVersion Method
IBookService Interface See Also Send Feedback
Gets the webview file version

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
string GetFileVersion()
Visual Basic (Declaration)
Function GetFileVersion As String
Visual C++
String^ GetFileVersion()

Return Value

the version string

See Also

IBookService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetLanguageCode Method

[image]

LinkOne WebView API
IBookService..::.GetLanguageCode Method
IBookService Interface See Also Send Feedback
Gets the current language code.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
string GetLanguageCode()
Visual Basic (Declaration)
Function GetLanguageCode As String
Visual C++
String^ GetLanguageCode()

Return Value

See Also

IBookService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetLanguageCodes Method

[image]

LinkOne WebView API
IBookService..::.GetLanguageCodes Method
IBookService Interface See Also Send Feedback
Gets the available language codes.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
KeyValuePair<string, string>[] GetLanguageCodes()
Visual Basic (Declaration)
Function GetLanguageCodes As KeyValuePair(Of String, String)()
Visual C++
array<KeyValuePair<String^, String^>>^ GetLanguageCodes()

Return Value

See Also

IBookService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetLibraries Method

[image]

LinkOne WebView API
IBookService..::.GetLibraries Method
IBookService Interface See Also Send Feedback
Gets the configured library locations.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
string[] GetLibraries()
Visual Basic (Declaration)
Function GetLibraries As String()
Visual C++
array<String^>^ GetLibraries()

Return Value

The configured library locations

See Also

IBookService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetNotes Method

[image]

LinkOne WebView API
IBookService..::.GetNotes Method
IBookService Interface See Also Send Feedback
Fetches a list of notes for a particular book and optional page reference.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
XmlNode[] GetNotes(
    string objectIdentifier,
    string publisherCode,
    string bookCode,
    string pageReference
)
Visual Basic (Declaration)
Function GetNotes ( _
    objectIdentifier As String, _
    publisherCode As String, _
    bookCode As String, _
    pageReference As String _
) As XmlNode()
Visual C++
array<XmlNode^>^ GetNotes(
    String^ objectIdentifier,
    String^ publisherCode,
    String^ bookCode,
    String^ pageReference
)

Parameters

objectIdentifier
Type: System..::.String
The object identifier. Identifiers the caller.
publisherCode
Type: System..::.String
Publisher code for the specified book.
bookCode
Type: System..::.String
Book code to fetch notes for.
pageReference
Type: System..::.String
Optional page reference (may be an empty string) to fetch notes for.

Return Value

An array of notes for the identified context. Only list notes and book marks are returned.

Remarks

The resulting notes list is a collection of all notes visible to the authorised user within the given context. Thus the list may contain public and private notes, publisher supplied notes, global, book and page specific notes as long as the user is authorised to see such notes. Note specific to parts or page items are only returned when a page reference is specified. Omitting the page reference returns no page specific notes, not even for the index/default page.

The results are deliberately returned as an array of XmlNodes rather than any notes class instances. This is to support SOAP requests. The XmlNodes serialise nicely whereas notes classes are many and varied and would require a set of serialisation code paths. All notes have an Xml property which provides an Xml string representation of the note data.

See Also

IBookService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetPageEmbeddedFileInfo Method

[image]

LinkOne WebView API
IBookService..::.GetPageEmbeddedFileInfo Method
IBookService Interface See Also Send Feedback
Gets the embedded file information of the page corresponding to the publisher, book and page reference.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
EmbeddedFileInfo GetPageEmbeddedFileInfo(
    string publisherCode,
    string bookCode,
    string pageReference
)
Visual Basic (Declaration)
Function GetPageEmbeddedFileInfo ( _
    publisherCode As String, _
    bookCode As String, _
    pageReference As String _
) As EmbeddedFileInfo
Visual C++
EmbeddedFileInfo^ GetPageEmbeddedFileInfo(
    String^ publisherCode,
    String^ bookCode,
    String^ pageReference
)

Parameters

publisherCode
Type: System..::.String
Publisher code for the book from which to retrieve the embedded file info.
bookCode
Type: System..::.String
Book code for the book from which to retrieve the embedded file info.
pageReference
Type: System..::.String
Page reference from which to retrieve the embedded file info.

Return Value

The embedded file info from the page identified by publisherCode, bookCode and pageReference.

See Also

IBookService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetPageEntries Method

[image]

LinkOne WebView API
IBookService..::.GetPageEntries Method
IBookService Interface See Also Send Feedback
Gets the entries from the parts list of the page corresponding to the publisher, book and page code/reference.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
PageEntry[] GetPageEntries(
    string publisherCode,
    string bookCode,
    string pageReference
)
Visual Basic (Declaration)
Function GetPageEntries ( _
    publisherCode As String, _
    bookCode As String, _
    pageReference As String _
) As PageEntry()
Visual C++
array<PageEntry^>^ GetPageEntries(
    String^ publisherCode,
    String^ bookCode,
    String^ pageReference
)

Parameters

publisherCode
Type: System..::.String
Publisher code for the book from which to retrieve the parts list.
bookCode
Type: System..::.String
Book code for the book from which to retrieve the parts list.
pageReference
Type: System..::.String
Page reference from which to retrieve the parts list.

Return Value

The parts list entries from the page identified by publisherCode, bookCode and pageReference.

See Also

IBookService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetPageReferences Method

[image]

LinkOne WebView API
IBookService..::.GetPageReferences Method
IBookService Interface See Also Send Feedback
Gets the available page references for a book.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
Page[] GetPageReferences(
    string publisherCode,
    string bookCode
)
Visual Basic (Declaration)
Function GetPageReferences ( _
    publisherCode As String, _
    bookCode As String _
) As Page()
Visual C++
array<Page^>^ GetPageReferences(
    String^ publisherCode,
    String^ bookCode
)

Parameters

publisherCode
Type: System..::.String
Publisher code for the book from which to retrieve a page.
bookCode
Type: System..::.String
Book code for the book from which to retrieve a page.

Return Value

The available page references for the given book.

See Also

IBookService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetPicture Method

[image]

LinkOne WebView API
IBookService..::.GetPicture Method
IBookService Interface See Also Send Feedback
Gets the picture for the given page.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
Picture GetPicture(
    string objectIdentifier,
    string publisherCode,
    string bookCode,
    string pageReference,
    int pictureNumber
)
Visual Basic (Declaration)
Function GetPicture ( _
    objectIdentifier As String, _
    publisherCode As String, _
    bookCode As String, _
    pageReference As String, _
    pictureNumber As Integer _
) As Picture
Visual C++
Picture^ GetPicture(
    String^ objectIdentifier,
    String^ publisherCode,
    String^ bookCode,
    String^ pageReference,
    int pictureNumber
)

Parameters

objectIdentifier
Type: System..::.String
The object identifer.
publisherCode
Type: System..::.String
The publisher code.
bookCode
Type: System..::.String
The book code.
pageReference
Type: System..::.String
The page reference.
pictureNumber
Type: System..::.Int32
The of the picture to get.

Return Value

The data for the wanted picture.

See Also

IBookService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetPictures Method

[image]

LinkOne WebView API
IBookService..::.GetPictures Method
IBookService Interface See Also Send Feedback
Gets the pictures meta data for the given page.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
PictureMetadata[] GetPictures(
    string objectIdentifier,
    string publisherCode,
    string bookCode,
    string pageReference
)
Visual Basic (Declaration)
Function GetPictures ( _
    objectIdentifier As String, _
    publisherCode As String, _
    bookCode As String, _
    pageReference As String _
) As PictureMetadata()
Visual C++
array<PictureMetadata^>^ GetPictures(
    String^ objectIdentifier,
    String^ publisherCode,
    String^ bookCode,
    String^ pageReference
)

Parameters

objectIdentifier
Type: System..::.String
The object identifier.
publisherCode
Type: System..::.String
The publisher code.
bookCode
Type: System..::.String
The book code.
pageReference
Type: System..::.String
The page reference.

Return Value

The data for the wanted picture.

See Also

IBookService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetProductVersion Method

[image]

LinkOne WebView API
IBookService..::.GetProductVersion Method
IBookService Interface See Also Send Feedback
Gets the webview product version

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
string GetProductVersion()
Visual Basic (Declaration)
Function GetProductVersion As String
Visual C++
String^ GetProductVersion()

Return Value

the version string

See Also

IBookService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetPublisherAndBookCodes Method

[image]

LinkOne WebView API
IBookService..::.GetPublisherAndBookCodes Method
IBookService Interface See Also Send Feedback
Gets publisher/book code pairs for all available books.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
KeyValuePair<string, string>[] GetPublisherAndBookCodes()
Visual Basic (Declaration)
Function GetPublisherAndBookCodes As KeyValuePair(Of String, String)()
Visual C++
array<KeyValuePair<String^, String^>>^ GetPublisherAndBookCodes()

Return Value

The publisher and book codes for available books.

See Also

IBookService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


Initialize Method

[image]

LinkOne WebView API
IBookService..::.Initialize Method
IBookService Interface See Also Send Feedback
Initializes the specified book language code.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
void Initialize(
    string languageCode
)
Visual Basic (Declaration)
Sub Initialize ( _
    languageCode As String _
)
Visual C++
void Initialize(
    String^ languageCode
)

Parameters

languageCode
Type: System..::.String
The book language code.

See Also

IBookService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


ReindexLibrary Method

[image]

LinkOne WebView API
IBookService..::.ReindexLibrary Method
IBookService Interface See Also Send Feedback
Reindexes the given library.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
void ReindexLibrary(
    string library
)
Visual Basic (Declaration)
Sub ReindexLibrary ( _
    library As String _
)
Visual C++
void ReindexLibrary(
    String^ library
)

Parameters

library
Type: System..::.String
The library location to re-index.

See Also

IBookService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


ReindexLibraryEx Method

[image]

LinkOne WebView API
IBookService..::.ReindexLibraryEx Method
IBookService Interface See Also Send Feedback
Reindexes the given library and returns result.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
bool ReindexLibraryEx(
    string library
)
Visual Basic (Declaration)
Function ReindexLibraryEx ( _
    library As String _
) As Boolean
Visual C++
bool ReindexLibraryEx(
    String^ library
)

Parameters

library
Type: System..::.String
The library location to re-index.

Return Value

true if the reindex succeeded, false otherwise

See Also

IBookService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


SyncLibrary Method

[image]

LinkOne WebView API
IBookService..::.SyncLibrary Method
IBookService Interface See Also Send Feedback
Synchronises the given library.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
void SyncLibrary(
    string library,
    string syncLocation
)
Visual Basic (Declaration)
Sub SyncLibrary ( _
    library As String, _
    syncLocation As String _
)
Visual C++
void SyncLibrary(
    String^ library,
    String^ syncLocation
)

Parameters

library
Type: System..::.String
The server library to synchronise.
syncLocation
Type: System..::.String
The location of the library to synchronise with. If null or blank, then the location is read from the remote.config file in the library folder.

Remarks

A detailed log file named BookSync.Log is always created in the library folder.

See Also

IBookService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


INoteService Interface

[image]

LinkOne WebView API
INoteService Interface
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public interface INoteService
Visual Basic (Declaration)
Public Interface INoteService
Visual C++
public interface class INoteService

See Also

INoteService Members
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


INoteService Members

[image] [image]

LinkOne WebView API
INoteService Members
INoteService Interface Methods See Also Send Feedback

The INoteService type exposes the following members.

Methods

Name | Description
GetNoteInfo | Get note based on the given note key
GetNotesInfo | Get notes info based on the given publisher, book, and page reference
GetReferenceFromBookmark | Resolve the bookmark to it's final destination and return it as reference

See Also

INoteService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


INoteService Methods

[image] [image]

LinkOne WebView API
INoteService Methods
INoteService Interface See Also Send Feedback

The INoteService type exposes the following members.

Methods

Name | Description
GetNoteInfo | Get note based on the given note key
GetNotesInfo | Get notes info based on the given publisher, book, and page reference
GetReferenceFromBookmark | Resolve the bookmark to it's final destination and return it as reference

See Also

INoteService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetNoteInfo Method

[image]

LinkOne WebView API
INoteService..::.GetNoteInfo Method
INoteService Interface See Also Send Feedback
Get note based on the given note key

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
NoteInfo GetNoteInfo(
    string noteKey,
    string scopeReference
)
Visual Basic (Declaration)
Function GetNoteInfo ( _
    noteKey As String, _
    scopeReference As String _
) As NoteInfo
Visual C++
NoteInfo^ GetNoteInfo(
    String^ noteKey,
    String^ scopeReference
)

Parameters

noteKey
Type: System..::.String
scopeReference
Type: System..::.String

See Also

INoteService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetNotesInfo Method

[image]

LinkOne WebView API
INoteService..::.GetNotesInfo Method
INoteService Interface See Also Send Feedback
Get notes info based on the given publisher, book, and page reference

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
NotesInfo GetNotesInfo(
    string publisherCode,
    string bookCode,
    string pageReference
)
Visual Basic (Declaration)
Function GetNotesInfo ( _
    publisherCode As String, _
    bookCode As String, _
    pageReference As String _
) As NotesInfo
Visual C++
NotesInfo^ GetNotesInfo(
    String^ publisherCode,
    String^ bookCode,
    String^ pageReference
)

Parameters

publisherCode
Type: System..::.String
bookCode
Type: System..::.String
pageReference
Type: System..::.String

Return Value

See Also

INoteService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetReferenceFromBookmark Method

[image]

LinkOne WebView API
INoteService..::.GetReferenceFromBookmark Method
INoteService Interface See Also Send Feedback
Resolve the bookmark to it's final destination and return it as reference

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
string GetReferenceFromBookmark(
    string publisherCode,
    string bookCode,
    string bookmarkName
)
Visual Basic (Declaration)
Function GetReferenceFromBookmark ( _
    publisherCode As String, _
    bookCode As String, _
    bookmarkName As String _
) As String
Visual C++
String^ GetReferenceFromBookmark(
    String^ publisherCode,
    String^ bookCode,
    String^ bookmarkName
)

Parameters

publisherCode
Type: System..::.String
bookCode
Type: System..::.String
bookmarkName
Type: System..::.String

Return Value

See Also

INoteService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


IOfflineDBService Interface

[image]

LinkOne WebView API
IOfflineDBService Interface
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public interface IOfflineDBService
Visual Basic (Declaration)
Public Interface IOfflineDBService
Visual C++
public interface class IOfflineDBService

See Also

IOfflineDBService Members
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


IOfflineDBService Members

[image] [image]

LinkOne WebView API
IOfflineDBService Members
IOfflineDBService Interface Methods See Also Send Feedback

The IOfflineDBService type exposes the following members.

Methods

Name | Description
CreateAuditDownload | Create an offline audit download
CreateBook | Create an offline book
CreateBrowserDetail | Create an offline browser detail
CreatePage | Create an offline page
CreatePicture | Create an offline picture
CreateSelectionList | Create an offline selection list
CreateUser | Create an offline user
GetBook | Get an offline book
GetBrowserDetail | Get an offline browser detail
GetPage | Get an offline Page
GetPicture | Get an offline picture
GetPictures | Get a list of offline pictures
GetSelectionList | Get an offline selection list
GetUser | Get an offline user
UpdatePage | Update an offline page
UpdatePicture | Update an existing picture data
UpdateSelectionList | Update an offline selection list

See Also

IOfflineDBService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


IOfflineDBService Methods

[image] [image]

LinkOne WebView API
IOfflineDBService Methods
IOfflineDBService Interface See Also Send Feedback

The IOfflineDBService type exposes the following members.

Methods

Name | Description
CreateAuditDownload | Create an offline audit download
CreateBook | Create an offline book
CreateBrowserDetail | Create an offline browser detail
CreatePage | Create an offline page
CreatePicture | Create an offline picture
CreateSelectionList | Create an offline selection list
CreateUser | Create an offline user
GetBook | Get an offline book
GetBrowserDetail | Get an offline browser detail
GetPage | Get an offline Page
GetPicture | Get an offline picture
GetPictures | Get a list of offline pictures
GetSelectionList | Get an offline selection list
GetUser | Get an offline user
UpdatePage | Update an offline page
UpdatePicture | Update an existing picture data
UpdateSelectionList | Update an offline selection list

See Also

IOfflineDBService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


CreateAuditDownload Method

[image]

LinkOne WebView API
IOfflineDBService..::.CreateAuditDownload Method
IOfflineDBService Interface See Also Send Feedback
Create an offline audit download

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
int CreateAuditDownload(
    int userId,
    int browserId,
    int pageId,
    DateTime timeStamp
)
Visual Basic (Declaration)
Function CreateAuditDownload ( _
    userId As Integer, _
    browserId As Integer, _
    pageId As Integer, _
    timeStamp As DateTime _
) As Integer
Visual C++
int CreateAuditDownload(
    int userId,
    int browserId,
    int pageId,
    DateTime timeStamp
)

Parameters

userId
Type: System..::.Int32
browserId
Type: System..::.Int32
pageId
Type: System..::.Int32
timeStamp
Type: System..::.DateTime

Return Value

See Also

IOfflineDBService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


CreateBook Method

[image]

LinkOne WebView API
IOfflineDBService..::.CreateBook Method
IOfflineDBService Interface See Also Send Feedback
Create an offline book

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
int CreateBook(
    string bookCode,
    string publisherCode,
    string bookDescription
)
Visual Basic (Declaration)
Function CreateBook ( _
    bookCode As String, _
    publisherCode As String, _
    bookDescription As String _
) As Integer
Visual C++
int CreateBook(
    String^ bookCode,
    String^ publisherCode,
    String^ bookDescription
)

Parameters

bookCode
Type: System..::.String
publisherCode
Type: System..::.String
bookDescription
Type: System..::.String

Return Value

See Also

IOfflineDBService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


CreateBrowserDetail Method

[image]

LinkOne WebView API
IOfflineDBService..::.CreateBrowserDetail Method
IOfflineDBService Interface See Also Send Feedback
Create an offline browser detail

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
int CreateBrowserDetail(
    string machineIP,
    string machineName,
    string browserName
)
Visual Basic (Declaration)
Function CreateBrowserDetail ( _
    machineIP As String, _
    machineName As String, _
    browserName As String _
) As Integer
Visual C++
int CreateBrowserDetail(
    String^ machineIP,
    String^ machineName,
    String^ browserName
)

Parameters

machineIP
Type: System..::.String
machineName
Type: System..::.String
browserName
Type: System..::.String

Return Value

See Also

IOfflineDBService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


CreatePage Method

[image]

LinkOne WebView API
IOfflineDBService..::.CreatePage Method
IOfflineDBService Interface See Also Send Feedback
Create an offline page

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
int CreatePage(
    int bookId,
    string pageReference,
    int type,
    string embeddedFileUri,
    string pageEmbeddedFileInfoJson,
    string pageHtml
)
Visual Basic (Declaration)
Function CreatePage ( _
    bookId As Integer, _
    pageReference As String, _
    type As Integer, _
    embeddedFileUri As String, _
    pageEmbeddedFileInfoJson As String, _
    pageHtml As String _
) As Integer
Visual C++
int CreatePage(
    int bookId,
    String^ pageReference,
    int type,
    String^ embeddedFileUri,
    String^ pageEmbeddedFileInfoJson,
    String^ pageHtml
)

Parameters

bookId
Type: System..::.Int32
pageReference
Type: System..::.String
type
Type: System..::.Int32
embeddedFileUri
Type: System..::.String
pageEmbeddedFileInfoJson
Type: System..::.String
pageHtml
Type: System..::.String

Return Value

See Also

IOfflineDBService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


CreatePicture Method

[image]

LinkOne WebView API
IOfflineDBService..::.CreatePicture Method
IOfflineDBService Interface See Also Send Feedback
Create an offline picture

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
int CreatePicture(
    int pageId,
    string imageUri,
    string thumbnailUri,
    string pagePictureInfoJson,
    int number
)
Visual Basic (Declaration)
Function CreatePicture ( _
    pageId As Integer, _
    imageUri As String, _
    thumbnailUri As String, _
    pagePictureInfoJson As String, _
    number As Integer _
) As Integer
Visual C++
int CreatePicture(
    int pageId,
    String^ imageUri,
    String^ thumbnailUri,
    String^ pagePictureInfoJson,
    int number
)

Parameters

pageId
Type: System..::.Int32
imageUri
Type: System..::.String
thumbnailUri
Type: System..::.String
pagePictureInfoJson
Type: System..::.String
number
Type: System..::.Int32

Return Value

See Also

IOfflineDBService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


CreateSelectionList Method

[image]

LinkOne WebView API
IOfflineDBService..::.CreateSelectionList Method
IOfflineDBService Interface See Also Send Feedback
Create an offline selection list

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
void CreateSelectionList(
    string userName,
    string configurationName,
    string selectionListName,
    string xml
)
Visual Basic (Declaration)
Sub CreateSelectionList ( _
    userName As String, _
    configurationName As String, _
    selectionListName As String, _
    xml As String _
)
Visual C++
void CreateSelectionList(
    String^ userName,
    String^ configurationName,
    String^ selectionListName,
    String^ xml
)

Parameters

userName
Type: System..::.String
configurationName
Type: System..::.String
selectionListName
Type: System..::.String
xml
Type: System..::.String

See Also

IOfflineDBService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


CreateUser Method

[image]

LinkOne WebView API
IOfflineDBService..::.CreateUser Method
IOfflineDBService Interface See Also Send Feedback
Create an offline user

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
int CreateUser(
    string userName
)
Visual Basic (Declaration)
Function CreateUser ( _
    userName As String _
) As Integer
Visual C++
int CreateUser(
    String^ userName
)

Parameters

userName
Type: System..::.String

Return Value

See Also

IOfflineDBService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetBook Method

[image]

LinkOne WebView API
IOfflineDBService..::.GetBook Method
IOfflineDBService Interface See Also Send Feedback
Get an offline book

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
OfflineBook GetBook(
    string publisherCode,
    string bookCode
)
Visual Basic (Declaration)
Function GetBook ( _
    publisherCode As String, _
    bookCode As String _
) As OfflineBook
Visual C++
OfflineBook^ GetBook(
    String^ publisherCode,
    String^ bookCode
)

Parameters

publisherCode
Type: System..::.String
bookCode
Type: System..::.String

Return Value

See Also

IOfflineDBService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetBrowserDetail Method

[image]

LinkOne WebView API
IOfflineDBService..::.GetBrowserDetail Method
IOfflineDBService Interface See Also Send Feedback
Get an offline browser detail

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
OfflineBrowserDetail GetBrowserDetail(
    string machineIP,
    string machineName,
    string browserName
)
Visual Basic (Declaration)
Function GetBrowserDetail ( _
    machineIP As String, _
    machineName As String, _
    browserName As String _
) As OfflineBrowserDetail
Visual C++
OfflineBrowserDetail^ GetBrowserDetail(
    String^ machineIP,
    String^ machineName,
    String^ browserName
)

Parameters

machineIP
Type: System..::.String
machineName
Type: System..::.String
browserName
Type: System..::.String

Return Value

See Also

IOfflineDBService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetPage Method

[image]

LinkOne WebView API
IOfflineDBService..::.GetPage Method
IOfflineDBService Interface See Also Send Feedback
Get an offline Page

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
OfflinePage GetPage(
    int bookId,
    string pageReference
)
Visual Basic (Declaration)
Function GetPage ( _
    bookId As Integer, _
    pageReference As String _
) As OfflinePage
Visual C++
OfflinePage^ GetPage(
    int bookId,
    String^ pageReference
)

Parameters

bookId
Type: System..::.Int32
pageReference
Type: System..::.String

Return Value

See Also

IOfflineDBService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetPicture Method

[image]

LinkOne WebView API
IOfflineDBService..::.GetPicture Method
IOfflineDBService Interface See Also Send Feedback
Get an offline picture

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
OfflinePicture GetPicture(
    int pageId,
    int number
)
Visual Basic (Declaration)
Function GetPicture ( _
    pageId As Integer, _
    number As Integer _
) As OfflinePicture
Visual C++
OfflinePicture^ GetPicture(
    int pageId,
    int number
)

Parameters

pageId
Type: System..::.Int32
number
Type: System..::.Int32

Return Value

See Also

IOfflineDBService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetPictures Method

[image]

LinkOne WebView API
IOfflineDBService..::.GetPictures Method
IOfflineDBService Interface See Also Send Feedback
Get a list of offline pictures

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
List<OfflinePicture> GetPictures(
    int pageId
)
Visual Basic (Declaration)
Function GetPictures ( _
    pageId As Integer _
) As List(Of OfflinePicture)
Visual C++
List<OfflinePicture^>^ GetPictures(
    int pageId
)

Parameters

pageId
Type: System..::.Int32

Return Value

See Also

IOfflineDBService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetSelectionList Method

[image]

LinkOne WebView API
IOfflineDBService..::.GetSelectionList Method
IOfflineDBService Interface See Also Send Feedback
Get an offline selection list

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
OfflineSelectionList GetSelectionList(
    string userName,
    string configurationName,
    string selectionListName
)
Visual Basic (Declaration)
Function GetSelectionList ( _
    userName As String, _
    configurationName As String, _
    selectionListName As String _
) As OfflineSelectionList
Visual C++
OfflineSelectionList^ GetSelectionList(
    String^ userName,
    String^ configurationName,
    String^ selectionListName
)

Parameters

userName
Type: System..::.String
configurationName
Type: System..::.String
selectionListName
Type: System..::.String

Return Value

See Also

IOfflineDBService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetUser Method

[image]

LinkOne WebView API
IOfflineDBService..::.GetUser Method
IOfflineDBService Interface See Also Send Feedback
Get an offline user

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
OfflineUser GetUser(
    string userName
)
Visual Basic (Declaration)
Function GetUser ( _
    userName As String _
) As OfflineUser
Visual C++
OfflineUser^ GetUser(
    String^ userName
)

Parameters

userName
Type: System..::.String

Return Value

See Also

IOfflineDBService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


UpdatePage Method

[image]

LinkOne WebView API
IOfflineDBService..::.UpdatePage Method
IOfflineDBService Interface See Also Send Feedback
Update an offline page

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
void UpdatePage(
    int pageId,
    int bookId,
    string pageReference,
    int type,
    string embeddedFileUri,
    string pageEmbeddedFileInfoJson,
    string pageHtml
)
Visual Basic (Declaration)
Sub UpdatePage ( _
    pageId As Integer, _
    bookId As Integer, _
    pageReference As String, _
    type As Integer, _
    embeddedFileUri As String, _
    pageEmbeddedFileInfoJson As String, _
    pageHtml As String _
)
Visual C++
void UpdatePage(
    int pageId,
    int bookId,
    String^ pageReference,
    int type,
    String^ embeddedFileUri,
    String^ pageEmbeddedFileInfoJson,
    String^ pageHtml
)

Parameters

pageId
Type: System..::.Int32
bookId
Type: System..::.Int32
pageReference
Type: System..::.String
type
Type: System..::.Int32
embeddedFileUri
Type: System..::.String
pageEmbeddedFileInfoJson
Type: System..::.String
pageHtml
Type: System..::.String

See Also

IOfflineDBService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


UpdatePicture Method

[image]

LinkOne WebView API
IOfflineDBService..::.UpdatePicture Method
IOfflineDBService Interface See Also Send Feedback
Update an existing picture data

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
void UpdatePicture(
    int pictureId,
    int pageId,
    string imageUri,
    string thumbnailUri,
    string pagePictureInfoJson,
    int number
)
Visual Basic (Declaration)
Sub UpdatePicture ( _
    pictureId As Integer, _
    pageId As Integer, _
    imageUri As String, _
    thumbnailUri As String, _
    pagePictureInfoJson As String, _
    number As Integer _
)
Visual C++
void UpdatePicture(
    int pictureId,
    int pageId,
    String^ imageUri,
    String^ thumbnailUri,
    String^ pagePictureInfoJson,
    int number
)

Parameters

pictureId
Type: System..::.Int32
pageId
Type: System..::.Int32
imageUri
Type: System..::.String
thumbnailUri
Type: System..::.String
pagePictureInfoJson
Type: System..::.String
number
Type: System..::.Int32

See Also

IOfflineDBService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


UpdateSelectionList Method

[image]

LinkOne WebView API
IOfflineDBService..::.UpdateSelectionList Method
IOfflineDBService Interface See Also Send Feedback
Update an offline selection list

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
void UpdateSelectionList(
    string userName,
    string configurationName,
    string selectionListName,
    string xml
)
Visual Basic (Declaration)
Sub UpdateSelectionList ( _
    userName As String, _
    configurationName As String, _
    selectionListName As String, _
    xml As String _
)
Visual C++
void UpdateSelectionList(
    String^ userName,
    String^ configurationName,
    String^ selectionListName,
    String^ xml
)

Parameters

userName
Type: System..::.String
configurationName
Type: System..::.String
selectionListName
Type: System..::.String
xml
Type: System..::.String

See Also

IOfflineDBService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


IPictureControlService Interface

[image]

LinkOne WebView API
IPictureControlService Interface
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public interface IPictureControlService
Visual Basic (Declaration)
Public Interface IPictureControlService
Visual C++
public interface class IPictureControlService

See Also

IPictureControlService Members
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


IPictureControlService Members

[image] [image]

LinkOne WebView API
IPictureControlService Members
IPictureControlService Interface Methods See Also Send Feedback

The IPictureControlService type exposes the following members.

Methods

Name | Description
GetPagePictureInfo |
GetPictureInfo |
GetSelectionListParts |

See Also

IPictureControlService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


IPictureControlService Methods

[image] [image]

LinkOne WebView API
IPictureControlService Methods
IPictureControlService Interface See Also Send Feedback

The IPictureControlService type exposes the following members.

Methods

Name | Description
GetPagePictureInfo |
GetPictureInfo |
GetSelectionListParts |

See Also

IPictureControlService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetPagePictureInfo Method

[image]

LinkOne WebView API
IPictureControlService..::.GetPagePictureInfo Method
IPictureControlService Interface See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
PagePictureInfo GetPagePictureInfo(
    string objectIdentifier,
    string publisherCode,
    string bookCode,
    string bookmarkName,
    string pageReference,
    string itemId,
    int pictureNumber
)
Visual Basic (Declaration)
Function GetPagePictureInfo ( _
    objectIdentifier As String, _
    publisherCode As String, _
    bookCode As String, _
    bookmarkName As String, _
    pageReference As String, _
    itemId As String, _
    pictureNumber As Integer _
) As PagePictureInfo
Visual C++
PagePictureInfo^ GetPagePictureInfo(
    String^ objectIdentifier,
    String^ publisherCode,
    String^ bookCode,
    String^ bookmarkName,
    String^ pageReference,
    String^ itemId,
    int pictureNumber
)

Parameters

objectIdentifier
Type: System..::.String
publisherCode
Type: System..::.String
bookCode
Type: System..::.String
bookmarkName
Type: System..::.String
pageReference
Type: System..::.String
itemId
Type: System..::.String
pictureNumber
Type: System..::.Int32

See Also

IPictureControlService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetPictureInfo Method

[image]

LinkOne WebView API
IPictureControlService..::.GetPictureInfo Method
IPictureControlService Interface See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
PictureInfo GetPictureInfo(
    string objectIdentifier,
    string publisherCode,
    string bookCode,
    string pageReference,
    int pictureNumber
)
Visual Basic (Declaration)
Function GetPictureInfo ( _
    objectIdentifier As String, _
    publisherCode As String, _
    bookCode As String, _
    pageReference As String, _
    pictureNumber As Integer _
) As PictureInfo
Visual C++
PictureInfo^ GetPictureInfo(
    String^ objectIdentifier,
    String^ publisherCode,
    String^ bookCode,
    String^ pageReference,
    int pictureNumber
)

Parameters

objectIdentifier
Type: System..::.String
publisherCode
Type: System..::.String
bookCode
Type: System..::.String
pageReference
Type: System..::.String
pictureNumber
Type: System..::.Int32

See Also

IPictureControlService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetSelectionListParts Method

[image]

LinkOne WebView API
IPictureControlService..::.GetSelectionListParts Method
IPictureControlService Interface See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
List<Part> GetSelectionListParts()
Visual Basic (Declaration)
Function GetSelectionListParts As List(Of Part)
Visual C++
List<Part^>^ GetSelectionListParts()

See Also

IPictureControlService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


IPrintService Interface

[image]

LinkOne WebView API
IPrintService Interface
Members See Also Send Feedback
This service provides searching functionality.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public interface IPrintService
Visual Basic (Declaration)
Public Interface IPrintService
Visual C++
public interface class IPrintService

See Also

IPrintService Members
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


IPrintService Members

[image] [image]

LinkOne WebView API
IPrintService Members
IPrintService Interface Methods See Also Send Feedback

The IPrintService type exposes the following members.

Methods

Name | Description
GetPrintScopes |

See Also

IPrintService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


IPrintService Methods

[image] [image]

LinkOne WebView API
IPrintService Methods
IPrintService Interface See Also Send Feedback

The IPrintService type exposes the following members.

Methods

Name | Description
GetPrintScopes |

See Also

IPrintService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetPrintScopes Method

[image]

LinkOne WebView API
IPrintService..::.GetPrintScopes Method
IPrintService Interface See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
List<PrintScope> GetPrintScopes(
    string publisherCode,
    string bookCode,
    string pageReference
)
Visual Basic (Declaration)
Function GetPrintScopes ( _
    publisherCode As String, _
    bookCode As String, _
    pageReference As String _
) As List(Of PrintScope)
Visual C++
List<PrintScope>^ GetPrintScopes(
    String^ publisherCode,
    String^ bookCode,
    String^ pageReference
)

Parameters

publisherCode
Type: System..::.String
bookCode
Type: System..::.String
pageReference
Type: System..::.String

See Also

IPrintService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


ISearchService Interface

[image]

LinkOne WebView API
ISearchService Interface
Members See Also Send Feedback
This service provides searching functionality.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public interface ISearchService
Visual Basic (Declaration)
Public Interface ISearchService
Visual C++
public interface class ISearchService

See Also

ISearchService Members
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


ISearchService Members

[image] [image]

LinkOne WebView API
ISearchService Members
ISearchService Interface Methods See Also Send Feedback

The ISearchService type exposes the following members.

Methods

Name | Description
GetSearchSets |
Search |
SearchAdvanced |

See Also

ISearchService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


ISearchService Methods

[image] [image]

LinkOne WebView API
ISearchService Methods
ISearchService Interface See Also Send Feedback

The ISearchService type exposes the following members.

Methods

Name | Description
GetSearchSets |
Search |
SearchAdvanced |

See Also

ISearchService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetSearchSets Method

[image]

LinkOne WebView API
ISearchService..::.GetSearchSets Method
ISearchService Interface See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
List<SearchSet> GetSearchSets(
    string publisherCode,
    string bookCode
)
Visual Basic (Declaration)
Function GetSearchSets ( _
    publisherCode As String, _
    bookCode As String _
) As List(Of SearchSet)
Visual C++
List<SearchSet^>^ GetSearchSets(
    String^ publisherCode,
    String^ bookCode
)

Parameters

publisherCode
Type: System..::.String
bookCode
Type: System..::.String

See Also

ISearchService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


Search Method

[image]

LinkOne WebView API
ISearchService..::.Search Method
ISearchService Interface See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
List<SearchResult> Search(
    SearchSet searchSetDC,
    Search searchDC,
    SearchParameter searchParameter1DC,
    SearchParameter searchParameter2DC,
    KeyValuePair<string, string>[] publisherAndBookCodes,
    int maximumSearchResults
)
Visual Basic (Declaration)
Function Search ( _
    searchSetDC As SearchSet, _
    searchDC As Search, _
    searchParameter1DC As SearchParameter, _
    searchParameter2DC As SearchParameter, _
    publisherAndBookCodes As KeyValuePair(Of String, String)(), _
    maximumSearchResults As Integer _
) As List(Of SearchResult)
Visual C++
List<SearchResult^>^ Search(
    SearchSet^ searchSetDC,
    Search^ searchDC,
    SearchParameter^ searchParameter1DC,
    SearchParameter^ searchParameter2DC,
    array<KeyValuePair<String^, String^>>^ publisherAndBookCodes,
    int maximumSearchResults
)

Parameters

searchSetDC
Type: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.SearchSet
searchDC
Type: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.Search
searchParameter1DC
Type: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.SearchParameter
searchParameter2DC
Type: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.SearchParameter
publisherAndBookCodes
Type: array< System.Collections.Generic..::.KeyValuePair<(Of <(String, String>)>) >[]()[]
maximumSearchResults
Type: System..::.Int32

See Also

ISearchService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


SearchAdvanced Method

[image]

LinkOne WebView API
ISearchService..::.SearchAdvanced Method
ISearchService Interface See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
SolrSearchResults SearchAdvanced(
    Dictionary<string, string> searchKeyFieldNamesAndValues,
    bool orSearch,
    KeyValuePair<string, string>[] publisherAndBookCodes,
    Dictionary<string, string> facetFilterFieldNamesAndValues,
    int resultsPerPage
)
Visual Basic (Declaration)
Function SearchAdvanced ( _
    searchKeyFieldNamesAndValues As Dictionary(Of String, String), _
    orSearch As Boolean, _
    publisherAndBookCodes As KeyValuePair(Of String, String)(), _
    facetFilterFieldNamesAndValues As Dictionary(Of String, String), _
    resultsPerPage As Integer _
) As SolrSearchResults
Visual C++
SolrSearchResults^ SearchAdvanced(
    Dictionary<String^, String^>^ searchKeyFieldNamesAndValues,
    bool orSearch,
    array<KeyValuePair<String^, String^>>^ publisherAndBookCodes,
    Dictionary<String^, String^>^ facetFilterFieldNamesAndValues,
    int resultsPerPage
)

Parameters

searchKeyFieldNamesAndValues
Type: System.Collections.Generic..::.Dictionary<(Of <(String, String>)>)
orSearch
Type: System..::.Boolean
publisherAndBookCodes
Type: array< System.Collections.Generic..::.KeyValuePair<(Of <(String, String>)>) >[]()[]
facetFilterFieldNamesAndValues
Type: System.Collections.Generic..::.Dictionary<(Of <(String, String>)>)
resultsPerPage
Type: System..::.Int32

See Also

ISearchService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


ISecurityService Interface

[image]

LinkOne WebView API
ISecurityService Interface
Members See Also Send Feedback
This service provides access to website security.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public interface ISecurityService
Visual Basic (Declaration)
Public Interface ISecurityService
Visual C++
public interface class ISecurityService

See Also

ISecurityService Members
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


ISecurityService Members

[image] [image]

LinkOne WebView API
ISecurityService Members
ISecurityService Interface Methods See Also Send Feedback

The ISecurityService type exposes the following members.

Methods

Name | Description
FindUsers | Finds users starting with the given prefix.
GetCurrentToken | Gets the current login token As of now, this method is used by the offline web via web service call This is a different seperated token from the main Webview session
GetCurrentUser | Gets the current user.
GetLoginHistory | Gets the login history for the given time range.
GetUserPolicyResolved | Gets the resolved policy setting for a user.
IsTokenValid | Check if the given token is valid Used by Webview offline, token is passed via header

See Also

ISecurityService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


ISecurityService Methods

[image] [image]

LinkOne WebView API
ISecurityService Methods
ISecurityService Interface See Also Send Feedback

The ISecurityService type exposes the following members.

Methods

Name | Description
FindUsers | Finds users starting with the given prefix.
GetCurrentToken | Gets the current login token As of now, this method is used by the offline web via web service call This is a different seperated token from the main Webview session
GetCurrentUser | Gets the current user.
GetLoginHistory | Gets the login history for the given time range.
GetUserPolicyResolved | Gets the resolved policy setting for a user.
IsTokenValid | Check if the given token is valid Used by Webview offline, token is passed via header

See Also

ISecurityService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


FindUsers Method

[image]

LinkOne WebView API
ISecurityService..::.FindUsers Method
ISecurityService Interface See Also Send Feedback
Finds users starting with the given prefix.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
ICollection<string> FindUsers(
    string prefixText,
    int count
)
Visual Basic (Declaration)
Function FindUsers ( _
    prefixText As String, _
    count As Integer _
) As ICollection(Of String)
Visual C++
ICollection<String^>^ FindUsers(
    String^ prefixText,
    int count
)

Parameters

prefixText
Type: System..::.String
The prefix text.
count
Type: System..::.Int32
The maximum count of users to find.

Return Value

The found users.

See Also

ISecurityService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetCurrentToken Method

[image]

LinkOne WebView API
ISecurityService..::.GetCurrentToken Method
ISecurityService Interface See Also Send Feedback
Gets the current login token As of now, this method is used by the offline web via web service call This is a different seperated token from the main Webview session

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
string GetCurrentToken()
Visual Basic (Declaration)
Function GetCurrentToken As String
Visual C++
String^ GetCurrentToken()

Return Value

The current login token

See Also

ISecurityService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetCurrentUser Method

[image]

LinkOne WebView API
ISecurityService..::.GetCurrentUser Method
ISecurityService Interface See Also Send Feedback
Gets the current user.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
string GetCurrentUser()
Visual Basic (Declaration)
Function GetCurrentUser As String
Visual C++
String^ GetCurrentUser()

Return Value

The current username.

See Also

ISecurityService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetLoginHistory Method

[image]

LinkOne WebView API
ISecurityService..::.GetLoginHistory Method
ISecurityService Interface See Also Send Feedback
Gets the login history for the given time range.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
ICollection<TokenLog> GetLoginHistory(
    TokenLogType historyType,
    DateTime historyFrom,
    DateTime historyTo,
    int samplePoints
)
Visual Basic (Declaration)
Function GetLoginHistory ( _
    historyType As TokenLogType, _
    historyFrom As DateTime, _
    historyTo As DateTime, _
    samplePoints As Integer _
) As ICollection(Of TokenLog)
Visual C++
ICollection<TokenLog^>^ GetLoginHistory(
    TokenLogType historyType,
    DateTime historyFrom,
    DateTime historyTo,
    int samplePoints
)

Parameters

historyType
Type: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.TokenLogType
Type of history to return.
historyFrom
Type: System..::.DateTime
The from time.
historyTo
Type: System..::.DateTime
The to time.
samplePoints
Type: System..::.Int32
The maximum number of sample points to take, or <= 0 to return all.

Return Value

The login history.

See Also

ISecurityService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetUserPolicyResolved Method

[image]

LinkOne WebView API
ISecurityService..::.GetUserPolicyResolved Method
ISecurityService Interface See Also Send Feedback
Gets the resolved policy setting for a user.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
bool GetUserPolicyResolved(
    string userName,
    string policyName
)
Visual Basic (Declaration)
Function GetUserPolicyResolved ( _
    userName As String, _
    policyName As String _
) As Boolean
Visual C++
bool GetUserPolicyResolved(
    String^ userName,
    String^ policyName
)

Parameters

userName
Type: System..::.String
Name of the user.
policyName
Type: System..::.String
Name of the policy.

Return Value

The policy setting for the user and policy.

See Also

ISecurityService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


IsTokenValid Method

[image]

LinkOne WebView API
ISecurityService..::.IsTokenValid Method
ISecurityService Interface See Also Send Feedback
Check if the given token is valid Used by Webview offline, token is passed via header

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
bool IsTokenValid()
Visual Basic (Declaration)
Function IsTokenValid As Boolean
Visual C++
bool IsTokenValid()

Return Value

return true if valid, and false if not

See Also

ISecurityService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


ISelectionListService Interface

[image]

LinkOne WebView API
ISelectionListService Interface
Members See Also Send Feedback
This service provides access to selection list data.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public interface ISelectionListService
Visual Basic (Declaration)
Public Interface ISelectionListService
Visual C++
public interface class ISelectionListService

See Also

ISelectionListService Members
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


ISelectionListService Members

[image] [image]

LinkOne WebView API
ISelectionListService Members
ISelectionListService Interface Methods See Also Send Feedback

The ISelectionListService type exposes the following members.

Methods

Name | Description
AddBlankPart | Adds a blank part to the selection list.
AddPart | Adds the part to the selection list.
ClearParts | Clears the parts from the selection list.
DeletePart | Deletes the part at the specified index.
GetConfigurationName | Gets the name of the selection list configuration.
GetConfigurationNames | Gets the configuration names.
GetParts | Gets the parts on the current selection list.
GetPartsFieldsData | Gets the parts fields data.
GetSelectionListName | Gets the name of the selection list.
GetSelectionListNames | Gets the selection list names.
Initialize | Initializes the specified configuration name.
Open | Opens the selection list with the specified name.
SaveAs | Saves the selection list at the specified name.

See Also

ISelectionListService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


ISelectionListService Methods

[image] [image]

LinkOne WebView API
ISelectionListService Methods
ISelectionListService Interface See Also Send Feedback

The ISelectionListService type exposes the following members.

Methods

Name | Description
AddBlankPart | Adds a blank part to the selection list.
AddPart | Adds the part to the selection list.
ClearParts | Clears the parts from the selection list.
DeletePart | Deletes the part at the specified index.
GetConfigurationName | Gets the name of the selection list configuration.
GetConfigurationNames | Gets the configuration names.
GetParts | Gets the parts on the current selection list.
GetPartsFieldsData | Gets the parts fields data.
GetSelectionListName | Gets the name of the selection list.
GetSelectionListNames | Gets the selection list names.
Initialize | Initializes the specified configuration name.
Open | Opens the selection list with the specified name.
SaveAs | Saves the selection list at the specified name.

See Also

ISelectionListService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


AddBlankPart Method

[image]

LinkOne WebView API
ISelectionListService..::.AddBlankPart Method
ISelectionListService Interface See Also Send Feedback
Adds a blank part to the selection list.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
void AddBlankPart()
Visual Basic (Declaration)
Sub AddBlankPart
Visual C++
void AddBlankPart()

See Also

ISelectionListService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


AddPart Method

[image]

LinkOne WebView API
ISelectionListService..::.AddPart Method
ISelectionListService Interface See Also Send Feedback
Adds the part to the selection list.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
void AddPart(
    string publisherCode,
    string bookCode,
    string pageReference,
    int itemTag
)
Visual Basic (Declaration)
Sub AddPart ( _
    publisherCode As String, _
    bookCode As String, _
    pageReference As String, _
    itemTag As Integer _
)
Visual C++
void AddPart(
    String^ publisherCode,
    String^ bookCode,
    String^ pageReference,
    int itemTag
)

Parameters

publisherCode
Type: System..::.String
The publisher code.
bookCode
Type: System..::.String
The book code.
pageReference
Type: System..::.String
The page reference.
itemTag
Type: System..::.Int32
The item tag.

See Also

ISelectionListService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


ClearParts Method

[image]

LinkOne WebView API
ISelectionListService..::.ClearParts Method
ISelectionListService Interface See Also Send Feedback
Clears the parts from the selection list.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
void ClearParts()
Visual Basic (Declaration)
Sub ClearParts
Visual C++
void ClearParts()

See Also

ISelectionListService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


DeletePart Method

[image]

LinkOne WebView API
ISelectionListService..::.DeletePart Method
ISelectionListService Interface See Also Send Feedback
Deletes the part at the specified index.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
void DeletePart(
    int partIndex
)
Visual Basic (Declaration)
Sub DeletePart ( _
    partIndex As Integer _
)
Visual C++
void DeletePart(
    int partIndex
)

Parameters

partIndex
Type: System..::.Int32
Index of the part.

See Also

ISelectionListService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetConfigurationName Method

[image]

LinkOne WebView API
ISelectionListService..::.GetConfigurationName Method
ISelectionListService Interface See Also Send Feedback
Gets the name of the selection list configuration.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
string GetConfigurationName()
Visual Basic (Declaration)
Function GetConfigurationName As String
Visual C++
String^ GetConfigurationName()

Return Value

The name of the selection list configuration.

See Also

ISelectionListService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetConfigurationNames Method

[image]

LinkOne WebView API
ISelectionListService..::.GetConfigurationNames Method
ISelectionListService Interface See Also Send Feedback
Gets the configuration names.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
string[] GetConfigurationNames()
Visual Basic (Declaration)
Function GetConfigurationNames As String()
Visual C++
array<String^>^ GetConfigurationNames()

Return Value

The configuration names.

See Also

ISelectionListService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetParts Method

[image]

LinkOne WebView API
ISelectionListService..::.GetParts Method
ISelectionListService Interface See Also Send Feedback
Gets the parts on the current selection list.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
Part[] GetParts()
Visual Basic (Declaration)
Function GetParts As Part()
Visual C++
array<Part^>^ GetParts()

Return Value

See Also

ISelectionListService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetPartsFieldsData Method

[image]

LinkOne WebView API
ISelectionListService..::.GetPartsFieldsData Method
ISelectionListService Interface See Also Send Feedback
Gets the parts fields data.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
string GetPartsFieldsData(
    string publisherCode,
    string bookCode,
    string pageReference
)
Visual Basic (Declaration)
Function GetPartsFieldsData ( _
    publisherCode As String, _
    bookCode As String, _
    pageReference As String _
) As String
Visual C++
String^ GetPartsFieldsData(
    String^ publisherCode,
    String^ bookCode,
    String^ pageReference
)

Parameters

publisherCode
Type: System..::.String
bookCode
Type: System..::.String
pageReference
Type: System..::.String

Return Value

The fields data of the parts

See Also

ISelectionListService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetSelectionListName Method

[image]

LinkOne WebView API
ISelectionListService..::.GetSelectionListName Method
ISelectionListService Interface See Also Send Feedback
Gets the name of the selection list.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
string GetSelectionListName()
Visual Basic (Declaration)
Function GetSelectionListName As String
Visual C++
String^ GetSelectionListName()

Return Value

The name of the selection list.

See Also

ISelectionListService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetSelectionListNames Method

[image]

LinkOne WebView API
ISelectionListService..::.GetSelectionListNames Method
ISelectionListService Interface See Also Send Feedback
Gets the selection list names.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
string[] GetSelectionListNames()
Visual Basic (Declaration)
Function GetSelectionListNames As String()
Visual C++
array<String^>^ GetSelectionListNames()

Return Value

The selection list names.

See Also

ISelectionListService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


Initialize Method

[image]

LinkOne WebView API
ISelectionListService..::.Initialize Method
ISelectionListService Interface See Also Send Feedback
Initializes the specified configuration name.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
void Initialize(
    string configurationName,
    string selectionListName
)
Visual Basic (Declaration)
Sub Initialize ( _
    configurationName As String, _
    selectionListName As String _
)
Visual C++
void Initialize(
    String^ configurationName,
    String^ selectionListName
)

Parameters

configurationName
Type: System..::.String
Name of the configuration.
selectionListName
Type: System..::.String
Name of the selection list.

See Also

ISelectionListService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


Open Method

[image]

LinkOne WebView API
ISelectionListService..::.Open Method
ISelectionListService Interface See Also Send Feedback
Opens the selection list with the specified name.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
void Open(
    string selectionListName
)
Visual Basic (Declaration)
Sub Open ( _
    selectionListName As String _
)
Visual C++
void Open(
    String^ selectionListName
)

Parameters

selectionListName
Type: System..::.String
Name of the selection list.

See Also

ISelectionListService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


SaveAs Method

[image]

LinkOne WebView API
ISelectionListService..::.SaveAs Method
ISelectionListService Interface See Also Send Feedback
Saves the selection list at the specified name.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
void SaveAs(
    string selectionListName
)
Visual Basic (Declaration)
Sub SaveAs ( _
    selectionListName As String _
)
Visual C++
void SaveAs(
    String^ selectionListName
)

Parameters

selectionListName
Type: System..::.String
Name to save the selection list as.

See Also

ISelectionListService Interface
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


NoteService Class

[image]

LinkOne WebView API
NoteService Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class NoteService : INoteService
Visual Basic (Declaration)
Public Class NoteService _
    Implements INoteService
Visual C++
public ref class NoteService : INoteService

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices..::.NoteService

See Also

NoteService Members
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


NoteService Members

[image] [image]

LinkOne WebView API
NoteService Members
NoteService Class Constructors Methods See Also Send Feedback

The NoteService type exposes the following members.

Constructors

Name | Description
NoteService | Initializes a new instance of the NoteService class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetNoteInfo | Get note info based on the given note key
GetNotesInfo | Get notes info based on the given publisher, book, and page reference
GetReferenceFromBookmark | Resolve the bookmark to it's final destination and return it as reference
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

NoteService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


NoteService Constructor

[image]

LinkOne WebView API
NoteService Constructor
NoteService Class See Also Send Feedback
Initializes a new instance of the NoteService class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public NoteService()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NoteService()

See Also

NoteService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


NoteService Methods

[image] [image]

LinkOne WebView API
NoteService Methods
NoteService Class See Also Send Feedback

The NoteService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetNoteInfo | Get note info based on the given note key
GetNotesInfo | Get notes info based on the given publisher, book, and page reference
GetReferenceFromBookmark | Resolve the bookmark to it's final destination and return it as reference
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

NoteService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetNoteInfo Method

[image]

LinkOne WebView API
NoteService..::.GetNoteInfo Method
NoteService Class See Also Send Feedback
Get note info based on the given note key

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public NoteInfo GetNoteInfo(
    string noteKey,
    string scopeReference
)
Visual Basic (Declaration)
Public Function GetNoteInfo ( _
    noteKey As String, _
    scopeReference As String _
) As NoteInfo
Visual C++
public:
virtual NoteInfo^ GetNoteInfo(
    String^ noteKey,
    String^ scopeReference
) sealed

Parameters

noteKey
Type: System..::.String
scopeReference
Type: System..::.String

Implements

INoteService..::.GetNoteInfo(String, String)

See Also

NoteService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetNotesInfo Method

[image]

LinkOne WebView API
NoteService..::.GetNotesInfo Method
NoteService Class See Also Send Feedback
Get notes info based on the given publisher, book, and page reference

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public NotesInfo GetNotesInfo(
    string publisherCode,
    string bookCode,
    string pageReference
)
Visual Basic (Declaration)
Public Function GetNotesInfo ( _
    publisherCode As String, _
    bookCode As String, _
    pageReference As String _
) As NotesInfo
Visual C++
public:
virtual NotesInfo^ GetNotesInfo(
    String^ publisherCode,
    String^ bookCode,
    String^ pageReference
) sealed

Parameters

publisherCode
Type: System..::.String
bookCode
Type: System..::.String
pageReference
Type: System..::.String

Return Value

Implements

INoteService..::.GetNotesInfo(String, String, String)

See Also

NoteService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetReferenceFromBookmark Method

[image]

LinkOne WebView API
NoteService..::.GetReferenceFromBookmark Method
NoteService Class See Also Send Feedback
Resolve the bookmark to it's final destination and return it as reference

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string GetReferenceFromBookmark(
    string publisherCode,
    string bookCode,
    string bookmarkName
)
Visual Basic (Declaration)
Public Function GetReferenceFromBookmark ( _
    publisherCode As String, _
    bookCode As String, _
    bookmarkName As String _
) As String
Visual C++
public:
virtual String^ GetReferenceFromBookmark(
    String^ publisherCode,
    String^ bookCode,
    String^ bookmarkName
) sealed

Parameters

publisherCode
Type: System..::.String
bookCode
Type: System..::.String
bookmarkName
Type: System..::.String

Return Value

Implements

INoteService..::.GetReferenceFromBookmark(String, String, String)

See Also

NoteService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


OfflineDBService Class

[image]

LinkOne WebView API
OfflineDBService Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class OfflineDBService : IOfflineDBService
Visual Basic (Declaration)
Public Class OfflineDBService _
    Implements IOfflineDBService
Visual C++
public ref class OfflineDBService : IOfflineDBService

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices..::.OfflineDBService

See Also

OfflineDBService Members
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


OfflineDBService Members

[image] [image]

LinkOne WebView API
OfflineDBService Members
OfflineDBService Class Constructors Methods See Also Send Feedback

The OfflineDBService type exposes the following members.

Constructors

Name | Description
OfflineDBService | Initializes a new instance of the OfflineDBService class

Methods

Name | Description
CreateAuditDownload | see CreateAuditDownload(Int32, Int32, Int32, DateTime)
CreateBook | see [!:IOfflineDBService.CreateBook(string, string, string, string)]
CreateBrowserDetail | see CreateBrowserDetail(String, String, String)
CreatePage | see [!:IOfflineDBService.CreatePage(int, string, int, string, string, string, string)]
CreatePicture | see [!:IOfflineDBService.CreatePicture(int, string, string, int)]
CreateSelectionList | see CreateSelectionList(String, String, String, String)
CreateUser | see CreateUser(String)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBook | see GetBook(String, String)
GetBrowserDetail | see GetBrowserDetail(String, String, String)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPage | see GetPage(Int32, String)
GetPicture | see GetPicture(Int32, Int32)
GetPictures | see GetPictures(Int32)
GetSelectionList | see GetSelectionList(String, String, String)
GetType | Gets the type of the current instance. (Inherited from Object.)
GetUser | see GetUser(String)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
UpdatePage | see [!:IOfflineDBService.UpdatePage(int, int, string, int, string, string, string, string)]
UpdatePicture | see [!:IOfflineDBService.UpdatePicture(int, int, string, string, int)]
UpdateSelectionList | see UpdateSelectionList(String, String, String, String)

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


OfflineDBService Constructor

[image]

LinkOne WebView API
OfflineDBService Constructor
OfflineDBService Class See Also Send Feedback
Initializes a new instance of the OfflineDBService class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public OfflineDBService()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OfflineDBService()

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


OfflineDBService Methods

[image] [image]

LinkOne WebView API
OfflineDBService Methods
OfflineDBService Class See Also Send Feedback

The OfflineDBService type exposes the following members.

Methods

Name | Description
CreateAuditDownload | see CreateAuditDownload(Int32, Int32, Int32, DateTime)
CreateBook | see [!:IOfflineDBService.CreateBook(string, string, string, string)]
CreateBrowserDetail | see CreateBrowserDetail(String, String, String)
CreatePage | see [!:IOfflineDBService.CreatePage(int, string, int, string, string, string, string)]
CreatePicture | see [!:IOfflineDBService.CreatePicture(int, string, string, int)]
CreateSelectionList | see CreateSelectionList(String, String, String, String)
CreateUser | see CreateUser(String)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetBook | see GetBook(String, String)
GetBrowserDetail | see GetBrowserDetail(String, String, String)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPage | see GetPage(Int32, String)
GetPicture | see GetPicture(Int32, Int32)
GetPictures | see GetPictures(Int32)
GetSelectionList | see GetSelectionList(String, String, String)
GetType | Gets the type of the current instance. (Inherited from Object.)
GetUser | see GetUser(String)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)
UpdatePage | see [!:IOfflineDBService.UpdatePage(int, int, string, int, string, string, string, string)]
UpdatePicture | see [!:IOfflineDBService.UpdatePicture(int, int, string, string, int)]
UpdateSelectionList | see UpdateSelectionList(String, String, String, String)

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


CreateAuditDownload Method

[image]

LinkOne WebView API
OfflineDBService..::.CreateAuditDownload Method
OfflineDBService Class See Also Send Feedback
see CreateAuditDownload(Int32, Int32, Int32, DateTime)

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int CreateAuditDownload(
    int userId,
    int browserId,
    int pageId,
    DateTime timeStamp
)
Visual Basic (Declaration)
Public Function CreateAuditDownload ( _
    userId As Integer, _
    browserId As Integer, _
    pageId As Integer, _
    timeStamp As DateTime _
) As Integer
Visual C++
public:
virtual int CreateAuditDownload(
    int userId,
    int browserId,
    int pageId,
    DateTime timeStamp
) sealed

Parameters

userId
Type: System..::.Int32
browserId
Type: System..::.Int32
pageId
Type: System..::.Int32
timeStamp
Type: System..::.DateTime

Return Value

Implements

IOfflineDBService..::.CreateAuditDownload(Int32, Int32, Int32, DateTime)

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


CreateBook Method

[image]

LinkOne WebView API
OfflineDBService..::.CreateBook Method
OfflineDBService Class See Also Send Feedback
see [!:IOfflineDBService.CreateBook(string, string, string, string)]

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int CreateBook(
    string bookCode,
    string publisherCode,
    string bookDescription
)
Visual Basic (Declaration)
Public Function CreateBook ( _
    bookCode As String, _
    publisherCode As String, _
    bookDescription As String _
) As Integer
Visual C++
public:
virtual int CreateBook(
    String^ bookCode,
    String^ publisherCode,
    String^ bookDescription
) sealed

Parameters

bookCode
Type: System..::.String
publisherCode
Type: System..::.String
bookDescription
Type: System..::.String

Return Value

Implements

IOfflineDBService..::.CreateBook(String, String, String)

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


CreateBrowserDetail Method

[image]

LinkOne WebView API
OfflineDBService..::.CreateBrowserDetail Method
OfflineDBService Class See Also Send Feedback
see CreateBrowserDetail(String, String, String)

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int CreateBrowserDetail(
    string machineIP,
    string machineName,
    string browserName
)
Visual Basic (Declaration)
Public Function CreateBrowserDetail ( _
    machineIP As String, _
    machineName As String, _
    browserName As String _
) As Integer
Visual C++
public:
virtual int CreateBrowserDetail(
    String^ machineIP,
    String^ machineName,
    String^ browserName
) sealed

Parameters

machineIP
Type: System..::.String
machineName
Type: System..::.String
browserName
Type: System..::.String

Return Value

Implements

IOfflineDBService..::.CreateBrowserDetail(String, String, String)

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


CreatePage Method

[image]

LinkOne WebView API
OfflineDBService..::.CreatePage Method
OfflineDBService Class See Also Send Feedback
see [!:IOfflineDBService.CreatePage(int, string, int, string, string, string, string)]

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int CreatePage(
    int bookId,
    string pageReference,
    int type,
    string embeddedFileUri,
    string pageEmbeddedFileInfoJson,
    string pageHtml
)
Visual Basic (Declaration)
Public Function CreatePage ( _
    bookId As Integer, _
    pageReference As String, _
    type As Integer, _
    embeddedFileUri As String, _
    pageEmbeddedFileInfoJson As String, _
    pageHtml As String _
) As Integer
Visual C++
public:
virtual int CreatePage(
    int bookId,
    String^ pageReference,
    int type,
    String^ embeddedFileUri,
    String^ pageEmbeddedFileInfoJson,
    String^ pageHtml
) sealed

Parameters

bookId
Type: System..::.Int32
pageReference
Type: System..::.String
type
Type: System..::.Int32
embeddedFileUri
Type: System..::.String
pageEmbeddedFileInfoJson
Type: System..::.String
pageHtml
Type: System..::.String

Return Value

Implements

IOfflineDBService..::.CreatePage(Int32, String, Int32, String, String, String)

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


CreatePicture Method

[image]

LinkOne WebView API
OfflineDBService..::.CreatePicture Method
OfflineDBService Class See Also Send Feedback
see [!:IOfflineDBService.CreatePicture(int, string, string, int)]

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int CreatePicture(
    int pageId,
    string imageUri,
    string thumbnailUri,
    string pagePictureInfoJson,
    int number
)
Visual Basic (Declaration)
Public Function CreatePicture ( _
    pageId As Integer, _
    imageUri As String, _
    thumbnailUri As String, _
    pagePictureInfoJson As String, _
    number As Integer _
) As Integer
Visual C++
public:
virtual int CreatePicture(
    int pageId,
    String^ imageUri,
    String^ thumbnailUri,
    String^ pagePictureInfoJson,
    int number
) sealed

Parameters

pageId
Type: System..::.Int32
imageUri
Type: System..::.String
thumbnailUri
Type: System..::.String
pagePictureInfoJson
Type: System..::.String
number
Type: System..::.Int32

Return Value

Implements

IOfflineDBService..::.CreatePicture(Int32, String, String, String, Int32)

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


CreateSelectionList Method

[image]

LinkOne WebView API
OfflineDBService..::.CreateSelectionList Method
OfflineDBService Class See Also Send Feedback
see CreateSelectionList(String, String, String, String)

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void CreateSelectionList(
    string userName,
    string configurationName,
    string selectionListName,
    string xml
)
Visual Basic (Declaration)
Public Sub CreateSelectionList ( _
    userName As String, _
    configurationName As String, _
    selectionListName As String, _
    xml As String _
)
Visual C++
public:
virtual void CreateSelectionList(
    String^ userName,
    String^ configurationName,
    String^ selectionListName,
    String^ xml
) sealed

Parameters

userName
Type: System..::.String
configurationName
Type: System..::.String
selectionListName
Type: System..::.String
xml
Type: System..::.String

Implements

IOfflineDBService..::.CreateSelectionList(String, String, String, String)

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


CreateUser Method

[image]

LinkOne WebView API
OfflineDBService..::.CreateUser Method
OfflineDBService Class See Also Send Feedback
see CreateUser(String)

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int CreateUser(
    string userName
)
Visual Basic (Declaration)
Public Function CreateUser ( _
    userName As String _
) As Integer
Visual C++
public:
virtual int CreateUser(
    String^ userName
) sealed

Parameters

userName
Type: System..::.String

Return Value

Implements

IOfflineDBService..::.CreateUser(String)

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetBook Method

[image]

LinkOne WebView API
OfflineDBService..::.GetBook Method
OfflineDBService Class See Also Send Feedback
see GetBook(String, String)

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public OfflineBook GetBook(
    string publisherCode,
    string bookCode
)
Visual Basic (Declaration)
Public Function GetBook ( _
    publisherCode As String, _
    bookCode As String _
) As OfflineBook
Visual C++
public:
virtual OfflineBook^ GetBook(
    String^ publisherCode,
    String^ bookCode
) sealed

Parameters

publisherCode
Type: System..::.String
bookCode
Type: System..::.String

Return Value

Implements

IOfflineDBService..::.GetBook(String, String)

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetBrowserDetail Method

[image]

LinkOne WebView API
OfflineDBService..::.GetBrowserDetail Method
OfflineDBService Class See Also Send Feedback
see GetBrowserDetail(String, String, String)

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public OfflineBrowserDetail GetBrowserDetail(
    string machineIP,
    string machineName,
    string browserName
)
Visual Basic (Declaration)
Public Function GetBrowserDetail ( _
    machineIP As String, _
    machineName As String, _
    browserName As String _
) As OfflineBrowserDetail
Visual C++
public:
virtual OfflineBrowserDetail^ GetBrowserDetail(
    String^ machineIP,
    String^ machineName,
    String^ browserName
) sealed

Parameters

machineIP
Type: System..::.String
machineName
Type: System..::.String
browserName
Type: System..::.String

Return Value

Implements

IOfflineDBService..::.GetBrowserDetail(String, String, String)

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetPage Method

[image]

LinkOne WebView API
OfflineDBService..::.GetPage Method
OfflineDBService Class See Also Send Feedback
see GetPage(Int32, String)

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public OfflinePage GetPage(
    int bookId,
    string pageReference
)
Visual Basic (Declaration)
Public Function GetPage ( _
    bookId As Integer, _
    pageReference As String _
) As OfflinePage
Visual C++
public:
virtual OfflinePage^ GetPage(
    int bookId,
    String^ pageReference
) sealed

Parameters

bookId
Type: System..::.Int32
pageReference
Type: System..::.String

Return Value

Implements

IOfflineDBService..::.GetPage(Int32, String)

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetPicture Method

[image]

LinkOne WebView API
OfflineDBService..::.GetPicture Method
OfflineDBService Class See Also Send Feedback
see GetPicture(Int32, Int32)

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public OfflinePicture GetPicture(
    int pageId,
    int number
)
Visual Basic (Declaration)
Public Function GetPicture ( _
    pageId As Integer, _
    number As Integer _
) As OfflinePicture
Visual C++
public:
virtual OfflinePicture^ GetPicture(
    int pageId,
    int number
) sealed

Parameters

pageId
Type: System..::.Int32
number
Type: System..::.Int32

Return Value

Implements

IOfflineDBService..::.GetPicture(Int32, Int32)

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetPictures Method

[image]

LinkOne WebView API
OfflineDBService..::.GetPictures Method
OfflineDBService Class See Also Send Feedback
see GetPictures(Int32)

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public List<OfflinePicture> GetPictures(
    int pageId
)
Visual Basic (Declaration)
Public Function GetPictures ( _
    pageId As Integer _
) As List(Of OfflinePicture)
Visual C++
public:
virtual List<OfflinePicture^>^ GetPictures(
    int pageId
) sealed

Parameters

pageId
Type: System..::.Int32

Return Value

Implements

IOfflineDBService..::.GetPictures(Int32)

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetSelectionList Method

[image]

LinkOne WebView API
OfflineDBService..::.GetSelectionList Method
OfflineDBService Class See Also Send Feedback
see GetSelectionList(String, String, String)

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public OfflineSelectionList GetSelectionList(
    string userName,
    string configurationName,
    string selectionListName
)
Visual Basic (Declaration)
Public Function GetSelectionList ( _
    userName As String, _
    configurationName As String, _
    selectionListName As String _
) As OfflineSelectionList
Visual C++
public:
virtual OfflineSelectionList^ GetSelectionList(
    String^ userName,
    String^ configurationName,
    String^ selectionListName
) sealed

Parameters

userName
Type: System..::.String
configurationName
Type: System..::.String
selectionListName
Type: System..::.String

Return Value

Implements

IOfflineDBService..::.GetSelectionList(String, String, String)

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetUser Method

[image]

LinkOne WebView API
OfflineDBService..::.GetUser Method
OfflineDBService Class See Also Send Feedback
see GetUser(String)

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public OfflineUser GetUser(
    string userName
)
Visual Basic (Declaration)
Public Function GetUser ( _
    userName As String _
) As OfflineUser
Visual C++
public:
virtual OfflineUser^ GetUser(
    String^ userName
) sealed

Parameters

userName
Type: System..::.String

Return Value

Implements

IOfflineDBService..::.GetUser(String)

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


UpdatePage Method

[image]

LinkOne WebView API
OfflineDBService..::.UpdatePage Method
OfflineDBService Class See Also Send Feedback
see [!:IOfflineDBService.UpdatePage(int, int, string, int, string, string, string, string)]

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void UpdatePage(
    int pageId,
    int bookId,
    string pageReference,
    int type,
    string embeddedFileUri,
    string pageEmbeddedFileInfoJson,
    string pageHtml
)
Visual Basic (Declaration)
Public Sub UpdatePage ( _
    pageId As Integer, _
    bookId As Integer, _
    pageReference As String, _
    type As Integer, _
    embeddedFileUri As String, _
    pageEmbeddedFileInfoJson As String, _
    pageHtml As String _
)
Visual C++
public:
virtual void UpdatePage(
    int pageId,
    int bookId,
    String^ pageReference,
    int type,
    String^ embeddedFileUri,
    String^ pageEmbeddedFileInfoJson,
    String^ pageHtml
) sealed

Parameters

pageId
Type: System..::.Int32
bookId
Type: System..::.Int32
pageReference
Type: System..::.String
type
Type: System..::.Int32
embeddedFileUri
Type: System..::.String
pageEmbeddedFileInfoJson
Type: System..::.String
pageHtml
Type: System..::.String

Implements

IOfflineDBService..::.UpdatePage(Int32, Int32, String, Int32, String, String, String)

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


UpdatePicture Method

[image]

LinkOne WebView API
OfflineDBService..::.UpdatePicture Method
OfflineDBService Class See Also Send Feedback
see [!:IOfflineDBService.UpdatePicture(int, int, string, string, int)]

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void UpdatePicture(
    int pictureId,
    int pageId,
    string imageUri,
    string thumbnailUri,
    string pagePictureInfoJson,
    int number
)
Visual Basic (Declaration)
Public Sub UpdatePicture ( _
    pictureId As Integer, _
    pageId As Integer, _
    imageUri As String, _
    thumbnailUri As String, _
    pagePictureInfoJson As String, _
    number As Integer _
)
Visual C++
public:
virtual void UpdatePicture(
    int pictureId,
    int pageId,
    String^ imageUri,
    String^ thumbnailUri,
    String^ pagePictureInfoJson,
    int number
) sealed

Parameters

pictureId
Type: System..::.Int32
pageId
Type: System..::.Int32
imageUri
Type: System..::.String
thumbnailUri
Type: System..::.String
pagePictureInfoJson
Type: System..::.String
number
Type: System..::.Int32

Implements

IOfflineDBService..::.UpdatePicture(Int32, Int32, String, String, String, Int32)

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


UpdateSelectionList Method

[image]

LinkOne WebView API
OfflineDBService..::.UpdateSelectionList Method
OfflineDBService Class See Also Send Feedback
see UpdateSelectionList(String, String, String, String)

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public void UpdateSelectionList(
    string userName,
    string configurationName,
    string selectionListName,
    string xml
)
Visual Basic (Declaration)
Public Sub UpdateSelectionList ( _
    userName As String, _
    configurationName As String, _
    selectionListName As String, _
    xml As String _
)
Visual C++
public:
virtual void UpdateSelectionList(
    String^ userName,
    String^ configurationName,
    String^ selectionListName,
    String^ xml
) sealed

Parameters

userName
Type: System..::.String
configurationName
Type: System..::.String
selectionListName
Type: System..::.String
xml
Type: System..::.String

Implements

IOfflineDBService..::.UpdateSelectionList(String, String, String, String)

See Also

OfflineDBService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


PictureControlService Class

[image]

LinkOne WebView API
PictureControlService Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class PictureControlService : IPictureControlService
Visual Basic (Declaration)
Public Class PictureControlService _
    Implements IPictureControlService
Visual C++
public ref class PictureControlService : IPictureControlService

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices..::.PictureControlService

See Also

PictureControlService Members
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


PictureControlService Members

[image] [image]

LinkOne WebView API
PictureControlService Members
PictureControlService Class Methods See Also Send Feedback

The PictureControlService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PictureControlService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


PictureControlService Methods

[image] [image]

LinkOne WebView API
PictureControlService Methods
PictureControlService Class See Also Send Feedback

The PictureControlService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PictureControlService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


PrintService Class

[image]

LinkOne WebView API
PrintService Class
Members See Also Send Feedback
This service provides searching functionality.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class PrintService : IPrintService
Visual Basic (Declaration)
Public Class PrintService _
    Implements IPrintService
Visual C++
public ref class PrintService : IPrintService

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices..::.PrintService

See Also

PrintService Members
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


PrintService Members

[image] [image]

LinkOne WebView API
PrintService Members
PrintService Class Constructors Methods See Also Send Feedback

The PrintService type exposes the following members.

Constructors

Name | Description
PrintService | Initializes a new instance of the PrintService class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPrintScopes |
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PrintService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


PrintService Constructor

[image]

LinkOne WebView API
PrintService Constructor
PrintService Class See Also Send Feedback
Initializes a new instance of the PrintService class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public PrintService()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PrintService()

See Also

PrintService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


PrintService Methods

[image] [image]

LinkOne WebView API
PrintService Methods
PrintService Class See Also Send Feedback

The PrintService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPrintScopes |
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PrintService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetPrintScopes Method

[image]

LinkOne WebView API
PrintService..::.GetPrintScopes Method
PrintService Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public List<PrintScope> GetPrintScopes(
    string publisherCode,
    string bookCode,
    string pageReference
)
Visual Basic (Declaration)
Public Function GetPrintScopes ( _
    publisherCode As String, _
    bookCode As String, _
    pageReference As String _
) As List(Of PrintScope)
Visual C++
public:
virtual List<PrintScope>^ GetPrintScopes(
    String^ publisherCode,
    String^ bookCode,
    String^ pageReference
) sealed

Parameters

publisherCode
Type: System..::.String
bookCode
Type: System..::.String
pageReference
Type: System..::.String

Implements

IPrintService..::.GetPrintScopes(String, String, String)

See Also

PrintService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


SearchService Class

[image]

LinkOne WebView API
SearchService Class
Members See Also Send Feedback
This service provides searching functionality.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class SearchService : ISearchService
Visual Basic (Declaration)
Public Class SearchService _
    Implements ISearchService
Visual C++
public ref class SearchService : ISearchService

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices..::.SearchService

See Also

SearchService Members
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


SearchService Members

[image] [image]

LinkOne WebView API
SearchService Members
SearchService Class Constructors Methods See Also Send Feedback

The SearchService type exposes the following members.

Constructors

Name | Description
SearchService | Initializes a new instance of the SearchService class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSearchSets |
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Search |
SearchAdvanced |
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SearchService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


SearchService Constructor

[image]

LinkOne WebView API
SearchService Constructor
SearchService Class See Also Send Feedback
Initializes a new instance of the SearchService class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public SearchService()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SearchService()

See Also

SearchService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


SearchService Methods

[image] [image]

LinkOne WebView API
SearchService Methods
SearchService Class See Also Send Feedback

The SearchService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSearchSets |
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Search |
SearchAdvanced |
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SearchService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetSearchSets Method

[image]

LinkOne WebView API
SearchService..::.GetSearchSets Method
SearchService Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public List<SearchSet> GetSearchSets(
    string publisherCode,
    string bookCode
)
Visual Basic (Declaration)
Public Function GetSearchSets ( _
    publisherCode As String, _
    bookCode As String _
) As List(Of SearchSet)
Visual C++
public:
virtual List<SearchSet^>^ GetSearchSets(
    String^ publisherCode,
    String^ bookCode
) sealed

Parameters

publisherCode
Type: System..::.String
bookCode
Type: System..::.String

Implements

ISearchService..::.GetSearchSets(String, String)

See Also

SearchService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


Search Method

[image]

LinkOne WebView API
SearchService..::.Search Method
SearchService Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public List<SearchResult> Search(
    SearchSet searchSetDC,
    Search searchDC,
    SearchParameter searchParameter1DC,
    SearchParameter searchParameter2DC,
    KeyValuePair<string, string>[] publisherAndBookCodes,
    int maximumSearchResults
)
Visual Basic (Declaration)
Public Function Search ( _
    searchSetDC As SearchSet, _
    searchDC As Search, _
    searchParameter1DC As SearchParameter, _
    searchParameter2DC As SearchParameter, _
    publisherAndBookCodes As KeyValuePair(Of String, String)(), _
    maximumSearchResults As Integer _
) As List(Of SearchResult)
Visual C++
public:
virtual List<SearchResult^>^ Search(
    SearchSet^ searchSetDC,
    Search^ searchDC,
    SearchParameter^ searchParameter1DC,
    SearchParameter^ searchParameter2DC,
    array<KeyValuePair<String^, String^>>^ publisherAndBookCodes,
    int maximumSearchResults
) sealed

Parameters

searchSetDC
Type: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.SearchSet
searchDC
Type: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.Search
searchParameter1DC
Type: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.SearchParameter
searchParameter2DC
Type: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.SearchParameter
publisherAndBookCodes
Type: array< System.Collections.Generic..::.KeyValuePair<(Of <(String, String>)>) >[]()[]
maximumSearchResults
Type: System..::.Int32

Implements

ISearchService..::.Search(SearchSet, Search, SearchParameter, SearchParameter, array<KeyValuePair<(Of <(String, String>)>)>[]()[], Int32)

See Also

SearchService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


SearchAdvanced Method

[image]

LinkOne WebView API
SearchService..::.SearchAdvanced Method
SearchService Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public SolrSearchResults SearchAdvanced(
    Dictionary<string, string> searchKeyFieldNamesAndValues,
    bool orSearch,
    KeyValuePair<string, string>[] publisherAndBookCodes,
    Dictionary<string, string> facetFilterFieldNamesAndValues,
    int resultsPerPage
)
Visual Basic (Declaration)
Public Function SearchAdvanced ( _
    searchKeyFieldNamesAndValues As Dictionary(Of String, String), _
    orSearch As Boolean, _
    publisherAndBookCodes As KeyValuePair(Of String, String)(), _
    facetFilterFieldNamesAndValues As Dictionary(Of String, String), _
    resultsPerPage As Integer _
) As SolrSearchResults
Visual C++
public:
virtual SolrSearchResults^ SearchAdvanced(
    Dictionary<String^, String^>^ searchKeyFieldNamesAndValues,
    bool orSearch,
    array<KeyValuePair<String^, String^>>^ publisherAndBookCodes,
    Dictionary<String^, String^>^ facetFilterFieldNamesAndValues,
    int resultsPerPage
) sealed

Parameters

searchKeyFieldNamesAndValues
Type: System.Collections.Generic..::.Dictionary<(Of <(String, String>)>)
orSearch
Type: System..::.Boolean
publisherAndBookCodes
Type: array< System.Collections.Generic..::.KeyValuePair<(Of <(String, String>)>) >[]()[]
facetFilterFieldNamesAndValues
Type: System.Collections.Generic..::.Dictionary<(Of <(String, String>)>)
resultsPerPage
Type: System..::.Int32

Implements

ISearchService..::.SearchAdvanced(Dictionary<(Of <(String, String>)>), Boolean, array<KeyValuePair<(Of <(String, String>)>)>[]()[], Dictionary<(Of <(String, String>)>), Int32)

See Also

SearchService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


SecurityService Class

[image]

LinkOne WebView API
SecurityService Class
Members See Also Send Feedback
This service provides access to website security.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class SecurityService : ISecurityService
Visual Basic (Declaration)
Public Class SecurityService _
    Implements ISecurityService
Visual C++
public ref class SecurityService : ISecurityService

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices..::.SecurityService

See Also

SecurityService Members
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


SecurityService Members

[image] [image]

LinkOne WebView API
SecurityService Members
SecurityService Class Constructors Methods See Also Send Feedback

The SecurityService type exposes the following members.

Constructors

Name | Description
SecurityService | Initializes a new instance of the SecurityService class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
FindUsers | Finds users starting with the given prefix.
GetCurrentToken | Gets the current login token As of now, this method is used by the offline web via web service call This is a different seperated token from the main Webview session
GetCurrentUser | Gets the current user.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLoginHistory | Gets the login history for the given time range.
GetType | Gets the type of the current instance. (Inherited from Object.)
GetUserPolicyResolved | Gets the resolved policy setting for a user.
IsTokenValid | Check if the given token is valid Used by Webview offline, token is passed via header
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SecurityService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


SecurityService Constructor

[image]

LinkOne WebView API
SecurityService Constructor
SecurityService Class See Also Send Feedback
Initializes a new instance of the SecurityService class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public SecurityService()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SecurityService()

See Also

SecurityService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


SecurityService Methods

[image] [image]

LinkOne WebView API
SecurityService Methods
SecurityService Class See Also Send Feedback

The SecurityService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
FindUsers | Finds users starting with the given prefix.
GetCurrentToken | Gets the current login token As of now, this method is used by the offline web via web service call This is a different seperated token from the main Webview session
GetCurrentUser | Gets the current user.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLoginHistory | Gets the login history for the given time range.
GetType | Gets the type of the current instance. (Inherited from Object.)
GetUserPolicyResolved | Gets the resolved policy setting for a user.
IsTokenValid | Check if the given token is valid Used by Webview offline, token is passed via header
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SecurityService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


FindUsers Method

[image]

LinkOne WebView API
SecurityService..::.FindUsers Method
SecurityService Class See Also Send Feedback
Finds users starting with the given prefix.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public ICollection<string> FindUsers(
    string prefixText,
    int count
)
Visual Basic (Declaration)
Public Function FindUsers ( _
    prefixText As String, _
    count As Integer _
) As ICollection(Of String)
Visual C++
public:
virtual ICollection<String^>^ FindUsers(
    String^ prefixText,
    int count
) sealed

Parameters

prefixText
Type: System..::.String
The prefix text.
count
Type: System..::.Int32
The maximum count of users to find.

Return Value

The found users.

Implements

ISecurityService..::.FindUsers(String, Int32)

See Also

SecurityService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetCurrentToken Method

[image]

LinkOne WebView API
SecurityService..::.GetCurrentToken Method
SecurityService Class See Also Send Feedback
Gets the current login token As of now, this method is used by the offline web via web service call This is a different seperated token from the main Webview session

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string GetCurrentToken()
Visual Basic (Declaration)
Public Function GetCurrentToken As String
Visual C++
public:
virtual String^ GetCurrentToken() sealed

Return Value

The current login token

Implements

ISecurityService..::.GetCurrentToken()()()

See Also

SecurityService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetCurrentUser Method

[image]

LinkOne WebView API
SecurityService..::.GetCurrentUser Method
SecurityService Class See Also Send Feedback
Gets the current user.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string GetCurrentUser()
Visual Basic (Declaration)
Public Function GetCurrentUser As String
Visual C++
public:
virtual String^ GetCurrentUser() sealed

Return Value

The current username.

Implements

ISecurityService..::.GetCurrentUser()()()

See Also

SecurityService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetLoginHistory Method

[image]

LinkOne WebView API
SecurityService..::.GetLoginHistory Method
SecurityService Class See Also Send Feedback
Gets the login history for the given time range.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public ICollection<TokenLog> GetLoginHistory(
    TokenLogType historyType,
    DateTime historyFrom,
    DateTime historyTo,
    int samplePoints
)
Visual Basic (Declaration)
Public Function GetLoginHistory ( _
    historyType As TokenLogType, _
    historyFrom As DateTime, _
    historyTo As DateTime, _
    samplePoints As Integer _
) As ICollection(Of TokenLog)
Visual C++
public:
virtual ICollection<TokenLog^>^ GetLoginHistory(
    TokenLogType historyType,
    DateTime historyFrom,
    DateTime historyTo,
    int samplePoints
) sealed

Parameters

historyType
Type: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.TokenLogType
Type of history to return.
historyFrom
Type: System..::.DateTime
The from time.
historyTo
Type: System..::.DateTime
The to time.
samplePoints
Type: System..::.Int32
The maximum number of sample points to take, or <= 0 to return all.

Return Value

The login history.

Implements

ISecurityService..::.GetLoginHistory(TokenLogType, DateTime, DateTime, Int32)

See Also

SecurityService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


GetUserPolicyResolved Method

[image]

LinkOne WebView API
SecurityService..::.GetUserPolicyResolved Method
SecurityService Class See Also Send Feedback
Gets the resolved policy setting for a user.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool GetUserPolicyResolved(
    string userName,
    string policyName
)
Visual Basic (Declaration)
Public Function GetUserPolicyResolved ( _
    userName As String, _
    policyName As String _
) As Boolean
Visual C++
public:
virtual bool GetUserPolicyResolved(
    String^ userName,
    String^ policyName
) sealed

Parameters

userName
Type: System..::.String
Name of the user.
policyName
Type: System..::.String
Name of the policy.

Return Value

The policy setting for the user and policy.

Implements

ISecurityService..::.GetUserPolicyResolved(String, String)

See Also

SecurityService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


IsTokenValid Method

[image]

LinkOne WebView API
SecurityService..::.IsTokenValid Method
SecurityService Class See Also Send Feedback
Check if the given token is valid Used by Webview offline, token is passed via header

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool IsTokenValid()
Visual Basic (Declaration)
Public Function IsTokenValid As Boolean
Visual C++
public:
virtual bool IsTokenValid() sealed

Return Value

return true if valid, and false if not

Implements

ISecurityService..::.IsTokenValid()()()

See Also

SecurityService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


SelectionListService Class

[image]

LinkOne WebView API
SelectionListService Class
Members See Also Send Feedback
This service provides access to selection list data.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class SelectionListService : ISelectionListService
Visual Basic (Declaration)
Public Class SelectionListService _
    Implements ISelectionListService
Visual C++
public ref class SelectionListService : ISelectionListService

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices..::.SelectionListService

See Also

SelectionListService Members
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


SelectionListService Members

[image] [image]

LinkOne WebView API
SelectionListService Members
SelectionListService Class Methods See Also Send Feedback

The SelectionListService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SelectionListService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


SelectionListService Methods

[image] [image]

LinkOne WebView API
SelectionListService Methods
SelectionListService Class See Also Send Feedback

The SelectionListService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SelectionListService Class
Mincom.LinkOne.WebView.WebServer.WebServices Namespace


Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace
Send Feedback
The Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts namespace supplies classes that are used as data containers in web services.

Classes

Class | Description
AllNote |
BookInfo |
Callout | Represents a callout on a LinkOne picture.
CircularCallout | Represents a callout that is rendered as an Ellipse.
EmbeddedFileInfo | Represents the information about an embedded file on a page.
LinearCallout | Represents a callout that is rendered as a line.
Node |
NoteInfo |
NotesInfo |
Page | Represents a page in a LinkOne book.
PageEntry | Represents a parts list item from a page.
PagePictureInfo |
Part | Represents a part in a LinkOne book.
Picture | Represents a LinkOne picture.
PictureInfo |
PictureMetadata | Represents metadata for a LinkOne picture.
PictureTile | Represents the data for an image tile requested from the IBookService.
PopupNote |
RectangularCallout | Represents a callout that is rendered as a Rectangle.
Search |
SearchKey |
SearchParameter | Represents the data for a search parameter send to the ISearchService.
SearchResult |
SearchSet | Represents the data for a search set requested from the ISearchService.
SolrSearchResults |
TargetBookmark |
TokenLog | Represents a token log entry.
ViewLog | Represents a view log entry.

Structures

Structure | Description
Point | Represents an x- and y-coordinate pair in two-dimensional space.
Size | Implements a structure that is used to store the size of an object.

Enumerations

Enumeration | Description
TokenLogType | Defines the token log types.


AllNote Class

[image]

LinkOne WebView API
AllNote Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class AllNote
Visual Basic (Declaration)
Public Class AllNote
Visual C++
public ref class AllNote

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.AllNote

See Also

AllNote Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


AllNote Members

[image] [image]

LinkOne WebView API
AllNote Members
AllNote Class Constructors Methods Properties See Also Send Feedback

The AllNote type exposes the following members.

Constructors

Name | Description
AllNote | Initializes a new instance of the AllNote class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Behaviour |
IsUsingValues |
NoteKey |

See Also

AllNote Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


AllNote Constructor

[image]

LinkOne WebView API
AllNote Constructor
AllNote Class See Also Send Feedback
Initializes a new instance of the AllNote class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public AllNote()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AllNote()

See Also

AllNote Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


AllNote Methods

[image] [image]

LinkOne WebView API
AllNote Methods
AllNote Class See Also Send Feedback

The AllNote type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AllNote Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


AllNote Properties

[image] [image]

LinkOne WebView API
AllNote Properties
AllNote Class See Also Send Feedback

The AllNote type exposes the following members.

Properties

Name | Description
Behaviour |
IsUsingValues |
NoteKey |

See Also

AllNote Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Behaviour Property

[image]

LinkOne WebView API
AllNote..::.Behaviour Property
AllNote Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Behaviour { get; set; }
Visual Basic (Declaration)
Public Property Behaviour As String
Visual C++
public:
property String^ Behaviour {
    String^ get ();
    void set (String^ value);
}

See Also

AllNote Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


IsUsingValues Property

[image]

LinkOne WebView API
AllNote..::.IsUsingValues Property
AllNote Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool IsUsingValues { get; set; }
Visual Basic (Declaration)
Public Property IsUsingValues As Boolean
Visual C++
public:
property bool IsUsingValues {
    bool get ();
    void set (bool value);
}

See Also

AllNote Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


NoteKey Property

[image]

LinkOne WebView API
AllNote..::.NoteKey Property
AllNote Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string NoteKey { get; set; }
Visual Basic (Declaration)
Public Property NoteKey As String
Visual C++
public:
property String^ NoteKey {
    String^ get ();
    void set (String^ value);
}

See Also

AllNote Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


BookInfo Class

[image]

LinkOne WebView API
BookInfo Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class BookInfo
Visual Basic (Declaration)
Public Class BookInfo
Visual C++
public ref class BookInfo

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.BookInfo

See Also

BookInfo Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


BookInfo Members

[image] [image]

LinkOne WebView API
BookInfo Members
BookInfo Class Constructors Methods Properties See Also Send Feedback

The BookInfo type exposes the following members.

Constructors

Name | Description
BookInfo | Initializes a new instance of the BookInfo class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
BookCode | The book code for the book info.
BookDescription | The book title for the book info.
Pages |
PublisherCode | The publisher code for the book info.
PublisherDescription | The publisher name for the book info.

See Also

BookInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


BookInfo Constructor

[image]

LinkOne WebView API
BookInfo Constructor
BookInfo Class See Also Send Feedback
Initializes a new instance of the BookInfo class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public BookInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BookInfo()

See Also

BookInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


BookInfo Methods

[image] [image]

LinkOne WebView API
BookInfo Methods
BookInfo Class See Also Send Feedback

The BookInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BookInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


BookInfo Properties

[image] [image]

LinkOne WebView API
BookInfo Properties
BookInfo Class See Also Send Feedback

The BookInfo type exposes the following members.

Properties

Name | Description
BookCode | The book code for the book info.
BookDescription | The book title for the book info.
Pages |
PublisherCode | The publisher code for the book info.
PublisherDescription | The publisher name for the book info.

See Also

BookInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


BookCode Property

[image]

LinkOne WebView API
BookInfo..::.BookCode Property
BookInfo Class See Also Send Feedback
The book code for the book info.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string BookCode { get; set; }
Visual Basic (Declaration)
Public Property BookCode As String
Visual C++
public:
property String^ BookCode {
    String^ get ();
    void set (String^ value);
}

See Also

BookInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


BookDescription Property

[image]

LinkOne WebView API
BookInfo..::.BookDescription Property
BookInfo Class See Also Send Feedback
The book title for the book info.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string BookDescription { get; set; }
Visual Basic (Declaration)
Public Property BookDescription As String
Visual C++
public:
property String^ BookDescription {
    String^ get ();
    void set (String^ value);
}

See Also

BookInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Pages Property

[image]

LinkOne WebView API
BookInfo..::.Pages Property
BookInfo Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public List<Page> Pages { get; set; }
Visual Basic (Declaration)
Public Property Pages As List(Of Page)
Visual C++
public:
property List<Page^>^ Pages {
    List<Page^>^ get ();
    void set (List<Page^>^ value);
}

See Also

BookInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PublisherCode Property

[image]

LinkOne WebView API
BookInfo..::.PublisherCode Property
BookInfo Class See Also Send Feedback
The publisher code for the book info.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PublisherCode { get; set; }
Visual Basic (Declaration)
Public Property PublisherCode As String
Visual C++
public:
property String^ PublisherCode {
    String^ get ();
    void set (String^ value);
}

See Also

BookInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PublisherDescription Property

[image]

LinkOne WebView API
BookInfo..::.PublisherDescription Property
BookInfo Class See Also Send Feedback
The publisher name for the book info.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PublisherDescription { get; set; }
Visual Basic (Declaration)
Public Property PublisherDescription As String
Visual C++
public:
property String^ PublisherDescription {
    String^ get ();
    void set (String^ value);
}

See Also

BookInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Callout Class

[image]

LinkOne WebView API
Callout Class
Members See Also Send Feedback
Represents a callout on a LinkOne picture.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public abstract class Callout
Visual Basic (Declaration)
Public MustInherit Class Callout
Visual C++
public ref class Callout abstract

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.Callout
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.CircularCallout
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.LinearCallout
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.RectangularCallout

See Also

Callout Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Callout Members

[image] [image]

LinkOne WebView API
Callout Members
Callout Class Constructors Methods Properties See Also Send Feedback

The Callout type exposes the following members.

Constructors

Name | Description
Callout | Initializes a new instance of the Callout class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
CanAddPart | Gets a value indicating whether this instance can add part.
Description | Gets or sets the description.
DisplayItemId | Gets the the display item id.
FontSize | Gets the size of the font.
IsLink | Gets a value indicating whether this callout is a link.
IsSelectable | A callout is selectable if if has a matching part in the parts list, or if it is a linear callout.
ItemId | Gets the item id.
LinkBookCode | Gets the link book code for the callout's matching part, if the part is a link and the book link is set.
LinkItemId | Gets the link item id for the callout's matching part, if the part is a link and the item link is set.
LinkObjectIdentifier | Gets the link object identifier for the callout's matching part, if the part is a link and the object link is set.
LinkPageReference | Gets the link page reference for the callout's matching part, if the part is a link and the page link is set.
LinkPublisherCode | Gets the link publisher code for the callout's matching part, if the part is a link and the publisher link is set.
PartNumber | Gets or sets the part number.
Position | Gets the position.
TextAngle | Gets the angle to render text.
TooltipHtml | Gets or sets the tooltip html.
ZoneType | Gets or sets the type of the zone.

See Also

Callout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Callout Constructor

[image]

LinkOne WebView API
Callout Constructor
Callout Class See Also Send Feedback
Initializes a new instance of the Callout class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
protected Callout()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
Callout()

See Also

Callout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Callout Methods

[image] [image]

LinkOne WebView API
Callout Methods
Callout Class See Also Send Feedback

The Callout type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Callout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Callout Properties

[image] [image]

LinkOne WebView API
Callout Properties
Callout Class See Also Send Feedback

The Callout type exposes the following members.

Properties

Name | Description
CanAddPart | Gets a value indicating whether this instance can add part.
Description | Gets or sets the description.
DisplayItemId | Gets the the display item id.
FontSize | Gets the size of the font.
IsLink | Gets a value indicating whether this callout is a link.
IsSelectable | A callout is selectable if if has a matching part in the parts list, or if it is a linear callout.
ItemId | Gets the item id.
LinkBookCode | Gets the link book code for the callout's matching part, if the part is a link and the book link is set.
LinkItemId | Gets the link item id for the callout's matching part, if the part is a link and the item link is set.
LinkObjectIdentifier | Gets the link object identifier for the callout's matching part, if the part is a link and the object link is set.
LinkPageReference | Gets the link page reference for the callout's matching part, if the part is a link and the page link is set.
LinkPublisherCode | Gets the link publisher code for the callout's matching part, if the part is a link and the publisher link is set.
PartNumber | Gets or sets the part number.
Position | Gets the position.
TextAngle | Gets the angle to render text.
TooltipHtml | Gets or sets the tooltip html.
ZoneType | Gets or sets the type of the zone.

See Also

Callout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


CanAddPart Property

[image]

LinkOne WebView API
Callout..::.CanAddPart Property
Callout Class See Also Send Feedback
Gets a value indicating whether this instance can add part.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool CanAddPart { get; set; }
Visual Basic (Declaration)
Public Property CanAddPart As Boolean
Visual C++
public:
property bool CanAddPart {
    bool get ();
    void set (bool value);
}

See Also

Callout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Description Property

[image]

LinkOne WebView API
Callout..::.Description Property
Callout Class See Also Send Feedback
Gets or sets the description.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

Callout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


DisplayItemId Property

[image]

LinkOne WebView API
Callout..::.DisplayItemId Property
Callout Class See Also Send Feedback
Gets the the display item id.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string DisplayItemId { get; set; }
Visual Basic (Declaration)
Public Property DisplayItemId As String
Visual C++
public:
property String^ DisplayItemId {
    String^ get ();
    void set (String^ value);
}

See Also

Callout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


FontSize Property

[image]

LinkOne WebView API
Callout..::.FontSize Property
Callout Class See Also Send Feedback
Gets the size of the font.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public double FontSize { get; set; }
Visual Basic (Declaration)
Public Property FontSize As Double
Visual C++
public:
property double FontSize {
    double get ();
    void set (double value);
}

See Also

Callout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


IsLink Property

[image]

LinkOne WebView API
Callout..::.IsLink Property
Callout Class See Also Send Feedback
Gets a value indicating whether this callout is a link.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool IsLink { get; set; }
Visual Basic (Declaration)
Public Property IsLink As Boolean
Visual C++
public:
property bool IsLink {
    bool get ();
    void set (bool value);
}

See Also

Callout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


IsSelectable Property

[image]

LinkOne WebView API
Callout..::.IsSelectable Property
Callout Class See Also Send Feedback
A callout is selectable if if has a matching part in the parts list, or if it is a linear callout.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool IsSelectable { get; set; }
Visual Basic (Declaration)
Public Property IsSelectable As Boolean
Visual C++
public:
property bool IsSelectable {
    bool get ();
    void set (bool value);
}

See Also

Callout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


ItemId Property

[image]

LinkOne WebView API
Callout..::.ItemId Property
Callout Class See Also Send Feedback
Gets the item id.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string ItemId { get; set; }
Visual Basic (Declaration)
Public Property ItemId As String
Visual C++
public:
property String^ ItemId {
    String^ get ();
    void set (String^ value);
}

See Also

Callout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


LinkBookCode Property

[image]

LinkOne WebView API
Callout..::.LinkBookCode Property
Callout Class See Also Send Feedback
Gets the link book code for the callout's matching part, if the part is a link and the book link is set.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string LinkBookCode { get; set; }
Visual Basic (Declaration)
Public Property LinkBookCode As String
Visual C++
public:
property String^ LinkBookCode {
    String^ get ();
    void set (String^ value);
}

See Also

Callout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


LinkItemId Property

[image]

LinkOne WebView API
Callout..::.LinkItemId Property
Callout Class See Also Send Feedback
Gets the link item id for the callout's matching part, if the part is a link and the item link is set.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string LinkItemId { get; set; }
Visual Basic (Declaration)
Public Property LinkItemId As String
Visual C++
public:
property String^ LinkItemId {
    String^ get ();
    void set (String^ value);
}

See Also

Callout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


LinkObjectIdentifier Property

[image]

LinkOne WebView API
Callout..::.LinkObjectIdentifier Property
Callout Class See Also Send Feedback
Gets the link object identifier for the callout's matching part, if the part is a link and the object link is set.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string LinkObjectIdentifier { get; set; }
Visual Basic (Declaration)
Public Property LinkObjectIdentifier As String
Visual C++
public:
property String^ LinkObjectIdentifier {
    String^ get ();
    void set (String^ value);
}

See Also

Callout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


LinkPageReference Property

[image]

LinkOne WebView API
Callout..::.LinkPageReference Property
Callout Class See Also Send Feedback
Gets the link page reference for the callout's matching part, if the part is a link and the page link is set.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string LinkPageReference { get; set; }
Visual Basic (Declaration)
Public Property LinkPageReference As String
Visual C++
public:
property String^ LinkPageReference {
    String^ get ();
    void set (String^ value);
}

See Also

Callout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


LinkPublisherCode Property

[image]

LinkOne WebView API
Callout..::.LinkPublisherCode Property
Callout Class See Also Send Feedback
Gets the link publisher code for the callout's matching part, if the part is a link and the publisher link is set.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string LinkPublisherCode { get; set; }
Visual Basic (Declaration)
Public Property LinkPublisherCode As String
Visual C++
public:
property String^ LinkPublisherCode {
    String^ get ();
    void set (String^ value);
}

See Also

Callout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PartNumber Property

[image]

LinkOne WebView API
Callout..::.PartNumber Property
Callout Class See Also Send Feedback
Gets or sets the part number.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PartNumber { get; set; }
Visual Basic (Declaration)
Public Property PartNumber As String
Visual C++
public:
property String^ PartNumber {
    String^ get ();
    void set (String^ value);
}

See Also

Callout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Position Property

[image]

LinkOne WebView API
Callout..::.Position Property
Callout Class See Also Send Feedback
Gets the position.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Point Position { get; set; }
Visual Basic (Declaration)
Public Property Position As Point
Visual C++
public:
property Point Position {
    Point get ();
    void set (Point value);
}

See Also

Callout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


TextAngle Property

[image]

LinkOne WebView API
Callout..::.TextAngle Property
Callout Class See Also Send Feedback
Gets the angle to render text.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public double TextAngle { get; set; }
Visual Basic (Declaration)
Public Property TextAngle As Double
Visual C++
public:
property double TextAngle {
    double get ();
    void set (double value);
}

See Also

Callout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


TooltipHtml Property

[image]

LinkOne WebView API
Callout..::.TooltipHtml Property
Callout Class See Also Send Feedback
Gets or sets the tooltip html.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string TooltipHtml { get; set; }
Visual Basic (Declaration)
Public Property TooltipHtml As String
Visual C++
public:
property String^ TooltipHtml {
    String^ get ();
    void set (String^ value);
}

See Also

Callout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


ZoneType Property

[image]

LinkOne WebView API
Callout..::.ZoneType Property
Callout Class See Also Send Feedback
Gets or sets the type of the zone.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public ZoneType ZoneType { get; set; }
Visual Basic (Declaration)
Public Property ZoneType As ZoneType
Visual C++
public:
property ZoneType ZoneType {
    ZoneType get ();
    void set (ZoneType value);
}

Remarks

Not passed via WCF to clients.

See Also

Callout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


CircularCallout Class

[image]

LinkOne WebView API
CircularCallout Class
Members See Also Send Feedback
Represents a callout that is rendered as an Ellipse.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public sealed class CircularCallout : Callout
Visual Basic (Declaration)
Public NotInheritable Class CircularCallout _
    Inherits Callout
Visual C++
public ref class CircularCallout sealed : public Callout

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.Callout
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.CircularCallout

See Also

CircularCallout Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


CircularCallout Members

[image] [image]

LinkOne WebView API
CircularCallout Members
CircularCallout Class Constructors Methods Properties See Also Send Feedback

The CircularCallout type exposes the following members.

Constructors

Name | Description
CircularCallout | Initializes a new instance of the CircularCallout class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
CanAddPart | Gets a value indicating whether this instance can add part. (Inherited from Callout.)
Description | Gets or sets the description. (Inherited from Callout.)
DisplayItemId | Gets the the display item id. (Inherited from Callout.)
FontSize | Gets the size of the font. (Inherited from Callout.)
IsLink | Gets a value indicating whether this callout is a link. (Inherited from Callout.)
IsSelectable | A callout is selectable if if has a matching part in the parts list, or if it is a linear callout. (Inherited from Callout.)
ItemId | Gets the item id. (Inherited from Callout.)
LinkBookCode | Gets the link book code for the callout's matching part, if the part is a link and the book link is set. (Inherited from Callout.)
LinkItemId | Gets the link item id for the callout's matching part, if the part is a link and the item link is set. (Inherited from Callout.)
LinkObjectIdentifier | Gets the link object identifier for the callout's matching part, if the part is a link and the object link is set. (Inherited from Callout.)
LinkPageReference | Gets the link page reference for the callout's matching part, if the part is a link and the page link is set. (Inherited from Callout.)
LinkPublisherCode | Gets the link publisher code for the callout's matching part, if the part is a link and the publisher link is set. (Inherited from Callout.)
PartNumber | Gets or sets the part number. (Inherited from Callout.)
Position | Gets the position. (Inherited from Callout.)
TextAngle | Gets the angle to render text. (Inherited from Callout.)
TooltipHtml | Gets or sets the tooltip html. (Inherited from Callout.)
ZoneType | Gets or sets the type of the zone. (Inherited from Callout.)

See Also

CircularCallout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


CircularCallout Constructor

[image]

LinkOne WebView API
CircularCallout Constructor
CircularCallout Class See Also Send Feedback
Initializes a new instance of the CircularCallout class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public CircularCallout()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CircularCallout()

See Also

CircularCallout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


CircularCallout Methods

[image] [image]

LinkOne WebView API
CircularCallout Methods
CircularCallout Class See Also Send Feedback

The CircularCallout type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CircularCallout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


CircularCallout Properties

[image] [image]

LinkOne WebView API
CircularCallout Properties
CircularCallout Class See Also Send Feedback

The CircularCallout type exposes the following members.

Properties

Name | Description
CanAddPart | Gets a value indicating whether this instance can add part. (Inherited from Callout.)
Description | Gets or sets the description. (Inherited from Callout.)
DisplayItemId | Gets the the display item id. (Inherited from Callout.)
FontSize | Gets the size of the font. (Inherited from Callout.)
IsLink | Gets a value indicating whether this callout is a link. (Inherited from Callout.)
IsSelectable | A callout is selectable if if has a matching part in the parts list, or if it is a linear callout. (Inherited from Callout.)
ItemId | Gets the item id. (Inherited from Callout.)
LinkBookCode | Gets the link book code for the callout's matching part, if the part is a link and the book link is set. (Inherited from Callout.)
LinkItemId | Gets the link item id for the callout's matching part, if the part is a link and the item link is set. (Inherited from Callout.)
LinkObjectIdentifier | Gets the link object identifier for the callout's matching part, if the part is a link and the object link is set. (Inherited from Callout.)
LinkPageReference | Gets the link page reference for the callout's matching part, if the part is a link and the page link is set. (Inherited from Callout.)
LinkPublisherCode | Gets the link publisher code for the callout's matching part, if the part is a link and the publisher link is set. (Inherited from Callout.)
PartNumber | Gets or sets the part number. (Inherited from Callout.)
Position | Gets the position. (Inherited from Callout.)
TextAngle | Gets the angle to render text. (Inherited from Callout.)
TooltipHtml | Gets or sets the tooltip html. (Inherited from Callout.)
ZoneType | Gets or sets the type of the zone. (Inherited from Callout.)

See Also

CircularCallout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


EmbeddedFileInfo Class

[image]

LinkOne WebView API
EmbeddedFileInfo Class
Members See Also Send Feedback
Represents the information about an embedded file on a page.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class EmbeddedFileInfo
Visual Basic (Declaration)
Public Class EmbeddedFileInfo
Visual C++
public ref class EmbeddedFileInfo

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.EmbeddedFileInfo

See Also

EmbeddedFileInfo Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


EmbeddedFileInfo Members

[image] [image]

LinkOne WebView API
EmbeddedFileInfo Members
EmbeddedFileInfo Class Constructors Methods Properties See Also Send Feedback

The EmbeddedFileInfo type exposes the following members.

Constructors

Name | Description
EmbeddedFileInfo | Initializes a new instance of the EmbeddedFileInfo class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
FooterHtmlSnippet |
HeaderHtmlSnippet |
Url |

See Also

EmbeddedFileInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


EmbeddedFileInfo Constructor

[image]

LinkOne WebView API
EmbeddedFileInfo Constructor
EmbeddedFileInfo Class See Also Send Feedback
Initializes a new instance of the EmbeddedFileInfo class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public EmbeddedFileInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EmbeddedFileInfo()

See Also

EmbeddedFileInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


EmbeddedFileInfo Methods

[image] [image]

LinkOne WebView API
EmbeddedFileInfo Methods
EmbeddedFileInfo Class See Also Send Feedback

The EmbeddedFileInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EmbeddedFileInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


EmbeddedFileInfo Properties

[image] [image]

LinkOne WebView API
EmbeddedFileInfo Properties
EmbeddedFileInfo Class See Also Send Feedback

The EmbeddedFileInfo type exposes the following members.

Properties

Name | Description
FooterHtmlSnippet |
HeaderHtmlSnippet |
Url |

See Also

EmbeddedFileInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


FooterHtmlSnippet Property

[image]

LinkOne WebView API
EmbeddedFileInfo..::.FooterHtmlSnippet Property
EmbeddedFileInfo Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string FooterHtmlSnippet { get; set; }
Visual Basic (Declaration)
Public Property FooterHtmlSnippet As String
Visual C++
public:
property String^ FooterHtmlSnippet {
    String^ get ();
    void set (String^ value);
}

See Also

EmbeddedFileInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


HeaderHtmlSnippet Property

[image]

LinkOne WebView API
EmbeddedFileInfo..::.HeaderHtmlSnippet Property
EmbeddedFileInfo Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string HeaderHtmlSnippet { get; set; }
Visual Basic (Declaration)
Public Property HeaderHtmlSnippet As String
Visual C++
public:
property String^ HeaderHtmlSnippet {
    String^ get ();
    void set (String^ value);
}

See Also

EmbeddedFileInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Url Property

[image]

LinkOne WebView API
EmbeddedFileInfo..::.Url Property
EmbeddedFileInfo Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Url { get; set; }
Visual Basic (Declaration)
Public Property Url As String
Visual C++
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}

See Also

EmbeddedFileInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


LinearCallout Class

[image]

LinkOne WebView API
LinearCallout Class
Members See Also Send Feedback
Represents a callout that is rendered as a line.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public sealed class LinearCallout : Callout
Visual Basic (Declaration)
Public NotInheritable Class LinearCallout _
    Inherits Callout
Visual C++
public ref class LinearCallout sealed : public Callout

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.Callout
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.LinearCallout

See Also

LinearCallout Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


LinearCallout Members

[image] [image]

LinkOne WebView API
LinearCallout Members
LinearCallout Class Constructors Methods Properties See Also Send Feedback

The LinearCallout type exposes the following members.

Constructors

Name | Description
LinearCallout | Initializes a new instance of the LinearCallout class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
CanAddPart | Gets a value indicating whether this instance can add part. (Inherited from Callout.)
Description | Gets or sets the description. (Inherited from Callout.)
DisplayItemId | Gets the the display item id. (Inherited from Callout.)
FontSize | Gets the size of the font. (Inherited from Callout.)
IsLink | Gets a value indicating whether this callout is a link. (Inherited from Callout.)
IsSelectable | A callout is selectable if if has a matching part in the parts list, or if it is a linear callout. (Inherited from Callout.)
ItemId | Gets the item id. (Inherited from Callout.)
LineStyle | Gets or sets the line style.
LinkBookCode | Gets the link book code for the callout's matching part, if the part is a link and the book link is set. (Inherited from Callout.)
LinkItemId | Gets the link item id for the callout's matching part, if the part is a link and the item link is set. (Inherited from Callout.)
LinkObjectIdentifier | Gets the link object identifier for the callout's matching part, if the part is a link and the object link is set. (Inherited from Callout.)
LinkPageReference | Gets the link page reference for the callout's matching part, if the part is a link and the page link is set. (Inherited from Callout.)
LinkPublisherCode | Gets the link publisher code for the callout's matching part, if the part is a link and the publisher link is set. (Inherited from Callout.)
PartNumber | Gets or sets the part number. (Inherited from Callout.)
Points | Gets or sets the points.
Position | Gets the position. (Inherited from Callout.)
StrokeThickness | Gets or sets the stroke thickness.
TextAngle | Gets the angle to render text. (Inherited from Callout.)
TooltipHtml | Gets or sets the tooltip html. (Inherited from Callout.)
ZoneType | Gets or sets the type of the zone. (Inherited from Callout.)

See Also

LinearCallout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


LinearCallout Constructor

[image]

LinkOne WebView API
LinearCallout Constructor
LinearCallout Class See Also Send Feedback
Initializes a new instance of the LinearCallout class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public LinearCallout()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LinearCallout()

See Also

LinearCallout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


LinearCallout Methods

[image] [image]

LinkOne WebView API
LinearCallout Methods
LinearCallout Class See Also Send Feedback

The LinearCallout type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LinearCallout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


LinearCallout Properties

[image] [image]

LinkOne WebView API
LinearCallout Properties
LinearCallout Class See Also Send Feedback

The LinearCallout type exposes the following members.

Properties

Name | Description
CanAddPart | Gets a value indicating whether this instance can add part. (Inherited from Callout.)
Description | Gets or sets the description. (Inherited from Callout.)
DisplayItemId | Gets the the display item id. (Inherited from Callout.)
FontSize | Gets the size of the font. (Inherited from Callout.)
IsLink | Gets a value indicating whether this callout is a link. (Inherited from Callout.)
IsSelectable | A callout is selectable if if has a matching part in the parts list, or if it is a linear callout. (Inherited from Callout.)
ItemId | Gets the item id. (Inherited from Callout.)
LineStyle | Gets or sets the line style.
LinkBookCode | Gets the link book code for the callout's matching part, if the part is a link and the book link is set. (Inherited from Callout.)
LinkItemId | Gets the link item id for the callout's matching part, if the part is a link and the item link is set. (Inherited from Callout.)
LinkObjectIdentifier | Gets the link object identifier for the callout's matching part, if the part is a link and the object link is set. (Inherited from Callout.)
LinkPageReference | Gets the link page reference for the callout's matching part, if the part is a link and the page link is set. (Inherited from Callout.)
LinkPublisherCode | Gets the link publisher code for the callout's matching part, if the part is a link and the publisher link is set. (Inherited from Callout.)
PartNumber | Gets or sets the part number. (Inherited from Callout.)
Points | Gets or sets the points.
Position | Gets the position. (Inherited from Callout.)
StrokeThickness | Gets or sets the stroke thickness.
TextAngle | Gets the angle to render text. (Inherited from Callout.)
TooltipHtml | Gets or sets the tooltip html. (Inherited from Callout.)
ZoneType | Gets or sets the type of the zone. (Inherited from Callout.)

See Also

LinearCallout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


LineStyle Property

[image]

LinkOne WebView API
LinearCallout..::.LineStyle Property
LinearCallout Class See Also Send Feedback
Gets or sets the line style.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public LineStyle LineStyle { get; set; }
Visual Basic (Declaration)
Public Property LineStyle As LineStyle
Visual C++
public:
property LineStyle LineStyle {
    LineStyle get ();
    void set (LineStyle value);
}

See Also

LinearCallout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Points Property

[image]

LinkOne WebView API
LinearCallout..::.Points Property
LinearCallout Class See Also Send Feedback
Gets or sets the points.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Point[] Points { get; set; }
Visual Basic (Declaration)
Public Property Points As Point()
Visual C++
public:
property array<Point>^ Points {
    array<Point>^ get ();
    void set (array<Point>^ value);
}

See Also

LinearCallout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


StrokeThickness Property

[image]

LinkOne WebView API
LinearCallout..::.StrokeThickness Property
LinearCallout Class See Also Send Feedback
Gets or sets the stroke thickness.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public double StrokeThickness { get; set; }
Visual Basic (Declaration)
Public Property StrokeThickness As Double
Visual C++
public:
property double StrokeThickness {
    double get ();
    void set (double value);
}

See Also

LinearCallout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Node Class

[image]

LinkOne WebView API
Node Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class Node
Visual Basic (Declaration)
Public Class Node
Visual C++
public ref class Node

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.Node

See Also

Node Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Node Members

[image] [image]

LinkOne WebView API
Node Members
Node Class Constructors Methods Properties See Also Send Feedback

The Node type exposes the following members.

Constructors

Name | Description
Node | Initializes a new instance of the Node class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
CategoryCodes |
Children |
Code | The code of the node
Description | The description of the node
Pages |
PublisherCode |
PublisherName |
Tag | The tag of the node. Used to determine the depth and index of a category node
Type | The type of the node: "P for Publisher", "C for Category", "B for Book"

See Also

Node Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Node Constructor

[image]

LinkOne WebView API
Node Constructor
Node Class See Also Send Feedback
Initializes a new instance of the Node class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Node()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Node()

See Also

Node Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Node Methods

[image] [image]

LinkOne WebView API
Node Methods
Node Class See Also Send Feedback

The Node type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Node Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Node Properties

[image] [image]

LinkOne WebView API
Node Properties
Node Class See Also Send Feedback

The Node type exposes the following members.

Properties

Name | Description
CategoryCodes |
Children |
Code | The code of the node
Description | The description of the node
Pages |
PublisherCode |
PublisherName |
Tag | The tag of the node. Used to determine the depth and index of a category node
Type | The type of the node: "P for Publisher", "C for Category", "B for Book"

See Also

Node Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


CategoryCodes Property

[image]

LinkOne WebView API
Node..::.CategoryCodes Property
Node Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public List<string> CategoryCodes { get; set; }
Visual Basic (Declaration)
Public Property CategoryCodes As List(Of String)
Visual C++
public:
property List<String^>^ CategoryCodes {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

See Also

Node Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Children Property

[image]

LinkOne WebView API
Node..::.Children Property
Node Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public List<Node> Children { get; set; }
Visual Basic (Declaration)
Public Property Children As List(Of Node)
Visual C++
public:
property List<Node^>^ Children {
    List<Node^>^ get ();
    void set (List<Node^>^ value);
}

See Also

Node Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Code Property

[image]

LinkOne WebView API
Node..::.Code Property
Node Class See Also Send Feedback
The code of the node

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Code { get; set; }
Visual Basic (Declaration)
Public Property Code As String
Visual C++
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}

See Also

Node Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Description Property

[image]

LinkOne WebView API
Node..::.Description Property
Node Class See Also Send Feedback
The description of the node

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

Node Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Pages Property

[image]

LinkOne WebView API
Node..::.Pages Property
Node Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public List<Page> Pages { get; set; }
Visual Basic (Declaration)
Public Property Pages As List(Of Page)
Visual C++
public:
property List<Page^>^ Pages {
    List<Page^>^ get ();
    void set (List<Page^>^ value);
}

See Also

Node Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PublisherCode Property

[image]

LinkOne WebView API
Node..::.PublisherCode Property
Node Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PublisherCode { get; set; }
Visual Basic (Declaration)
Public Property PublisherCode As String
Visual C++
public:
property String^ PublisherCode {
    String^ get ();
    void set (String^ value);
}

See Also

Node Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PublisherName Property

[image]

LinkOne WebView API
Node..::.PublisherName Property
Node Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PublisherName { get; set; }
Visual Basic (Declaration)
Public Property PublisherName As String
Visual C++
public:
property String^ PublisherName {
    String^ get ();
    void set (String^ value);
}

See Also

Node Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Tag Property

[image]

LinkOne WebView API
Node..::.Tag Property
Node Class See Also Send Feedback
The tag of the node. Used to determine the depth and index of a category node

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Tag { get; set; }
Visual Basic (Declaration)
Public Property Tag As String
Visual C++
public:
property String^ Tag {
    String^ get ();
    void set (String^ value);
}

See Also

Node Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Type Property

[image]

LinkOne WebView API
Node..::.Type Property
Node Class See Also Send Feedback
The type of the node: "P for Publisher", "C for Category", "B for Book"

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Type { get; set; }
Visual Basic (Declaration)
Public Property Type As String
Visual C++
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}

See Also

Node Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


NoteInfo Class

[image]

LinkOne WebView API
NoteInfo Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class NoteInfo
Visual Basic (Declaration)
Public Class NoteInfo
Visual C++
public ref class NoteInfo

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.NoteInfo

See Also

NoteInfo Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


NoteInfo Members

[image] [image]

LinkOne WebView API
NoteInfo Members
NoteInfo Class Constructors Methods Properties See Also Send Feedback

The NoteInfo type exposes the following members.

Constructors

Name | Description
NoteInfo | Initializes a new instance of the NoteInfo class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
DisplayName |
IsLinkedNote |
LinkedNoteTarget |
NoteText |

See Also

NoteInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


NoteInfo Constructor

[image]

LinkOne WebView API
NoteInfo Constructor
NoteInfo Class See Also Send Feedback
Initializes a new instance of the NoteInfo class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public NoteInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NoteInfo()

See Also

NoteInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


NoteInfo Methods

[image] [image]

LinkOne WebView API
NoteInfo Methods
NoteInfo Class See Also Send Feedback

The NoteInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

NoteInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


NoteInfo Properties

[image] [image]

LinkOne WebView API
NoteInfo Properties
NoteInfo Class See Also Send Feedback

The NoteInfo type exposes the following members.

Properties

Name | Description
DisplayName |
IsLinkedNote |
LinkedNoteTarget |
NoteText |

See Also

NoteInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


DisplayName Property

[image]

LinkOne WebView API
NoteInfo..::.DisplayName Property
NoteInfo Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string DisplayName { get; set; }
Visual Basic (Declaration)
Public Property DisplayName As String
Visual C++
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}

See Also

NoteInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


IsLinkedNote Property

[image]

LinkOne WebView API
NoteInfo..::.IsLinkedNote Property
NoteInfo Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool IsLinkedNote { get; set; }
Visual Basic (Declaration)
Public Property IsLinkedNote As Boolean
Visual C++
public:
property bool IsLinkedNote {
    bool get ();
    void set (bool value);
}

See Also

NoteInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


LinkedNoteTarget Property

[image]

LinkOne WebView API
NoteInfo..::.LinkedNoteTarget Property
NoteInfo Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string LinkedNoteTarget { get; set; }
Visual Basic (Declaration)
Public Property LinkedNoteTarget As String
Visual C++
public:
property String^ LinkedNoteTarget {
    String^ get ();
    void set (String^ value);
}

See Also

NoteInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


NoteText Property

[image]

LinkOne WebView API
NoteInfo..::.NoteText Property
NoteInfo Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string NoteText { get; set; }
Visual Basic (Declaration)
Public Property NoteText As String
Visual C++
public:
property String^ NoteText {
    String^ get ();
    void set (String^ value);
}

See Also

NoteInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


NotesInfo Class

[image]

LinkOne WebView API
NotesInfo Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class NotesInfo
Visual Basic (Declaration)
Public Class NotesInfo
Visual C++
public ref class NotesInfo

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.NotesInfo

See Also

NotesInfo Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


NotesInfo Members

[image] [image]

LinkOne WebView API
NotesInfo Members
NotesInfo Class Constructors Methods Properties See Also Send Feedback

The NotesInfo type exposes the following members.

Constructors

Name | Description
NotesInfo | Initializes a new instance of the NotesInfo class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
AllNotes |
PopupNotes |
TargetBookmarks |

See Also

NotesInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


NotesInfo Constructor

[image]

LinkOne WebView API
NotesInfo Constructor
NotesInfo Class See Also Send Feedback
Initializes a new instance of the NotesInfo class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public NotesInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NotesInfo()

See Also

NotesInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


NotesInfo Methods

[image] [image]

LinkOne WebView API
NotesInfo Methods
NotesInfo Class See Also Send Feedback

The NotesInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

NotesInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


NotesInfo Properties

[image] [image]

LinkOne WebView API
NotesInfo Properties
NotesInfo Class See Also Send Feedback

The NotesInfo type exposes the following members.

Properties

Name | Description
AllNotes |
PopupNotes |
TargetBookmarks |

See Also

NotesInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


AllNotes Property

[image]

LinkOne WebView API
NotesInfo..::.AllNotes Property
NotesInfo Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public List<AllNote> AllNotes { get; set; }
Visual Basic (Declaration)
Public Property AllNotes As List(Of AllNote)
Visual C++
public:
property List<AllNote^>^ AllNotes {
    List<AllNote^>^ get ();
    void set (List<AllNote^>^ value);
}

See Also

NotesInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PopupNotes Property

[image]

LinkOne WebView API
NotesInfo..::.PopupNotes Property
NotesInfo Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public List<PopupNote> PopupNotes { get; set; }
Visual Basic (Declaration)
Public Property PopupNotes As List(Of PopupNote)
Visual C++
public:
property List<PopupNote^>^ PopupNotes {
    List<PopupNote^>^ get ();
    void set (List<PopupNote^>^ value);
}

See Also

NotesInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


TargetBookmarks Property

[image]

LinkOne WebView API
NotesInfo..::.TargetBookmarks Property
NotesInfo Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public List<TargetBookmark> TargetBookmarks { get; set; }
Visual Basic (Declaration)
Public Property TargetBookmarks As List(Of TargetBookmark)
Visual C++
public:
property List<TargetBookmark^>^ TargetBookmarks {
    List<TargetBookmark^>^ get ();
    void set (List<TargetBookmark^>^ value);
}

See Also

NotesInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Page Class

[image]

LinkOne WebView API
Page Class
Members See Also Send Feedback
Represents a page in a LinkOne book.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class Page
Visual Basic (Declaration)
Public Class Page
Visual C++
public ref class Page

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.Page

See Also

Page Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Page Members

[image] [image]

LinkOne WebView API
Page Members
Page Class Constructors Methods Properties See Also Send Feedback

The Page type exposes the following members.

Constructors

Name | Description
Page | Initializes a new instance of the Page class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
BookCode | Provides access to the book code of the book this page belongs to.
Number |
PageReference | Provides access to the referenced code for this page.
ParentPageReference | Provides access to the reference code of the page parenting this one in the table of contents. Null or empty for no parent.
PublisherCode | Provides access to the publisher code for this page.
Title | Returns the title string for this page.
Type |

See Also

Page Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Page Constructor

[image]

LinkOne WebView API
Page Constructor
Page Class See Also Send Feedback
Initializes a new instance of the Page class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Page()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Page()

See Also

Page Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Page Methods

[image] [image]

LinkOne WebView API
Page Methods
Page Class See Also Send Feedback

The Page type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Page Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Page Properties

[image] [image]

LinkOne WebView API
Page Properties
Page Class See Also Send Feedback

The Page type exposes the following members.

Properties

Name | Description
BookCode | Provides access to the book code of the book this page belongs to.
Number |
PageReference | Provides access to the referenced code for this page.
ParentPageReference | Provides access to the reference code of the page parenting this one in the table of contents. Null or empty for no parent.
PublisherCode | Provides access to the publisher code for this page.
Title | Returns the title string for this page.
Type |

See Also

Page Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


BookCode Property

[image]

LinkOne WebView API
Page..::.BookCode Property
Page Class See Also Send Feedback
Provides access to the book code of the book this page belongs to.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string BookCode { get; set; }
Visual Basic (Declaration)
Public Property BookCode As String
Visual C++
public:
property String^ BookCode {
    String^ get ();
    void set (String^ value);
}

See Also

Page Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Number Property

[image]

LinkOne WebView API
Page..::.Number Property
Page Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Number { get; set; }
Visual Basic (Declaration)
Public Property Number As String
Visual C++
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}

See Also

Page Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PageReference Property

[image]

LinkOne WebView API
Page..::.PageReference Property
Page Class See Also Send Feedback
Provides access to the referenced code for this page.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PageReference { get; set; }
Visual Basic (Declaration)
Public Property PageReference As String
Visual C++
public:
property String^ PageReference {
    String^ get ();
    void set (String^ value);
}

See Also

Page Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


ParentPageReference Property

[image]

LinkOne WebView API
Page..::.ParentPageReference Property
Page Class See Also Send Feedback
Provides access to the reference code of the page parenting this one in the table of contents. Null or empty for no parent.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string ParentPageReference { get; set; }
Visual Basic (Declaration)
Public Property ParentPageReference As String
Visual C++
public:
property String^ ParentPageReference {
    String^ get ();
    void set (String^ value);
}

See Also

Page Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PublisherCode Property

[image]

LinkOne WebView API
Page..::.PublisherCode Property
Page Class See Also Send Feedback
Provides access to the publisher code for this page.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PublisherCode { get; set; }
Visual Basic (Declaration)
Public Property PublisherCode As String
Visual C++
public:
property String^ PublisherCode {
    String^ get ();
    void set (String^ value);
}

See Also

Page Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Title Property

[image]

LinkOne WebView API
Page..::.Title Property
Page Class See Also Send Feedback
Returns the title string for this page.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Title { get; set; }
Visual Basic (Declaration)
Public Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

See Also

Page Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Type Property

[image]

LinkOne WebView API
Page..::.Type Property
Page Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public PageType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As PageType
Visual C++
public:
property PageType Type {
    PageType get ();
    void set (PageType value);
}

See Also

Page Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PageEntry Class

[image]

LinkOne WebView API
PageEntry Class
Members See Also Send Feedback
Represents a parts list item from a page.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class PageEntry
Visual Basic (Declaration)
Public Class PageEntry
Visual C++
public ref class PageEntry

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.PageEntry

See Also

PageEntry Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PageEntry Members

[image] [image]

LinkOne WebView API
PageEntry Members
PageEntry Class Constructors Methods Properties See Also Send Feedback

The PageEntry type exposes the following members.

Constructors

Name | Description
PageEntry | Initializes a new instance of the PageEntry class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
BookCode | Book code of the book this entry belongs to.
Description | The description text for this entry.
ItemId | The item Id for this entry.
LinkBookCode | Book code for cross reference link entries.
LinkPageReference | Page reference code for cross reference link entries.
LinkPublisherCode | Publisher code for cross reference link entries.
PageReference | Page reference code of the page this entry belongs to.
PartNo | The part number for this entry.
PublisherCode | Publisher code for the page this entry belongs to.
Quantity | The quantity required for this entry.

See Also

PageEntry Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PageEntry Constructor

[image]

LinkOne WebView API
PageEntry Constructor
PageEntry Class See Also Send Feedback
Initializes a new instance of the PageEntry class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public PageEntry()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PageEntry()

See Also

PageEntry Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PageEntry Methods

[image] [image]

LinkOne WebView API
PageEntry Methods
PageEntry Class See Also Send Feedback

The PageEntry type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PageEntry Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PageEntry Properties

[image] [image]

LinkOne WebView API
PageEntry Properties
PageEntry Class See Also Send Feedback

The PageEntry type exposes the following members.

Properties

Name | Description
BookCode | Book code of the book this entry belongs to.
Description | The description text for this entry.
ItemId | The item Id for this entry.
LinkBookCode | Book code for cross reference link entries.
LinkPageReference | Page reference code for cross reference link entries.
LinkPublisherCode | Publisher code for cross reference link entries.
PageReference | Page reference code of the page this entry belongs to.
PartNo | The part number for this entry.
PublisherCode | Publisher code for the page this entry belongs to.
Quantity | The quantity required for this entry.

See Also

PageEntry Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


BookCode Property

[image]

LinkOne WebView API
PageEntry..::.BookCode Property
PageEntry Class See Also Send Feedback
Book code of the book this entry belongs to.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string BookCode { get; set; }
Visual Basic (Declaration)
Public Property BookCode As String
Visual C++
public:
property String^ BookCode {
    String^ get ();
    void set (String^ value);
}

See Also

PageEntry Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Description Property

[image]

LinkOne WebView API
PageEntry..::.Description Property
PageEntry Class See Also Send Feedback
The description text for this entry.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

PageEntry Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


ItemId Property

[image]

LinkOne WebView API
PageEntry..::.ItemId Property
PageEntry Class See Also Send Feedback
The item Id for this entry.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string ItemId { get; set; }
Visual Basic (Declaration)
Public Property ItemId As String
Visual C++
public:
property String^ ItemId {
    String^ get ();
    void set (String^ value);
}

See Also

PageEntry Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


LinkBookCode Property

[image]

LinkOne WebView API
PageEntry..::.LinkBookCode Property
PageEntry Class See Also Send Feedback
Book code for cross reference link entries.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string LinkBookCode { get; set; }
Visual Basic (Declaration)
Public Property LinkBookCode As String
Visual C++
public:
property String^ LinkBookCode {
    String^ get ();
    void set (String^ value);
}

See Also

PageEntry Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


LinkPageReference Property

[image]

LinkOne WebView API
PageEntry..::.LinkPageReference Property
PageEntry Class See Also Send Feedback
Page reference code for cross reference link entries.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string LinkPageReference { get; set; }
Visual Basic (Declaration)
Public Property LinkPageReference As String
Visual C++
public:
property String^ LinkPageReference {
    String^ get ();
    void set (String^ value);
}

See Also

PageEntry Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


LinkPublisherCode Property

[image]

LinkOne WebView API
PageEntry..::.LinkPublisherCode Property
PageEntry Class See Also Send Feedback
Publisher code for cross reference link entries.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string LinkPublisherCode { get; set; }
Visual Basic (Declaration)
Public Property LinkPublisherCode As String
Visual C++
public:
property String^ LinkPublisherCode {
    String^ get ();
    void set (String^ value);
}

See Also

PageEntry Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PageReference Property

[image]

LinkOne WebView API
PageEntry..::.PageReference Property
PageEntry Class See Also Send Feedback
Page reference code of the page this entry belongs to.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PageReference { get; set; }
Visual Basic (Declaration)
Public Property PageReference As String
Visual C++
public:
property String^ PageReference {
    String^ get ();
    void set (String^ value);
}

See Also

PageEntry Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PartNo Property

[image]

LinkOne WebView API
PageEntry..::.PartNo Property
PageEntry Class See Also Send Feedback
The part number for this entry.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PartNo { get; set; }
Visual Basic (Declaration)
Public Property PartNo As String
Visual C++
public:
property String^ PartNo {
    String^ get ();
    void set (String^ value);
}

See Also

PageEntry Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PublisherCode Property

[image]

LinkOne WebView API
PageEntry..::.PublisherCode Property
PageEntry Class See Also Send Feedback
Publisher code for the page this entry belongs to.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PublisherCode { get; set; }
Visual Basic (Declaration)
Public Property PublisherCode As String
Visual C++
public:
property String^ PublisherCode {
    String^ get ();
    void set (String^ value);
}

See Also

PageEntry Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Quantity Property

[image]

LinkOne WebView API
PageEntry..::.Quantity Property
PageEntry Class See Also Send Feedback
The quantity required for this entry.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Quantity { get; set; }
Visual Basic (Declaration)
Public Property Quantity As String
Visual C++
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

See Also

PageEntry Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PagePictureInfo Class

[image]

LinkOne WebView API
PagePictureInfo Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class PagePictureInfo : PictureInfo
Visual Basic (Declaration)
Public Class PagePictureInfo _
    Inherits PictureInfo
Visual C++
public ref class PagePictureInfo : public PictureInfo

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.PictureInfo
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.PagePictureInfo

See Also

PagePictureInfo Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PagePictureInfo Members

[image] [image]

LinkOne WebView API
PagePictureInfo Members
PagePictureInfo Class Constructors Methods Properties See Also Send Feedback

The PagePictureInfo type exposes the following members.

Constructors

Name | Description
PagePictureInfo | Initializes a new instance of the PagePictureInfo class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
BookCode |
ItemId |
PageReference |
Picture | The picture to display (Inherited from PictureInfo.)
PictureMetadatas | List of information about all pictures
PublisherCode |
SelectionListParts | Current Selection List contents (Inherited from PictureInfo.)

See Also

PagePictureInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PagePictureInfo Constructor

[image]

LinkOne WebView API
PagePictureInfo Constructor
PagePictureInfo Class See Also Send Feedback
Initializes a new instance of the PagePictureInfo class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public PagePictureInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PagePictureInfo()

See Also

PagePictureInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PagePictureInfo Methods

[image] [image]

LinkOne WebView API
PagePictureInfo Methods
PagePictureInfo Class See Also Send Feedback

The PagePictureInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PagePictureInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PagePictureInfo Properties

[image] [image]

LinkOne WebView API
PagePictureInfo Properties
PagePictureInfo Class See Also Send Feedback

The PagePictureInfo type exposes the following members.

Properties

Name | Description
BookCode |
ItemId |
PageReference |
Picture | The picture to display (Inherited from PictureInfo.)
PictureMetadatas | List of information about all pictures
PublisherCode |
SelectionListParts | Current Selection List contents (Inherited from PictureInfo.)

See Also

PagePictureInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


BookCode Property

[image]

LinkOne WebView API
PagePictureInfo..::.BookCode Property
PagePictureInfo Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string BookCode { get; set; }
Visual Basic (Declaration)
Public Property BookCode As String
Visual C++
public:
property String^ BookCode {
    String^ get ();
    void set (String^ value);
}

See Also

PagePictureInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


ItemId Property

[image]

LinkOne WebView API
PagePictureInfo..::.ItemId Property
PagePictureInfo Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string ItemId { get; set; }
Visual Basic (Declaration)
Public Property ItemId As String
Visual C++
public:
property String^ ItemId {
    String^ get ();
    void set (String^ value);
}

See Also

PagePictureInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PageReference Property

[image]

LinkOne WebView API
PagePictureInfo..::.PageReference Property
PagePictureInfo Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PageReference { get; set; }
Visual Basic (Declaration)
Public Property PageReference As String
Visual C++
public:
property String^ PageReference {
    String^ get ();
    void set (String^ value);
}

See Also

PagePictureInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PictureMetadatas Property

[image]

LinkOne WebView API
PagePictureInfo..::.PictureMetadatas Property
PagePictureInfo Class See Also Send Feedback
List of information about all pictures

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public List<PictureMetadata> PictureMetadatas { get; set; }
Visual Basic (Declaration)
Public Property PictureMetadatas As List(Of PictureMetadata)
Visual C++
public:
property List<PictureMetadata^>^ PictureMetadatas {
    List<PictureMetadata^>^ get ();
    void set (List<PictureMetadata^>^ value);
}

See Also

PagePictureInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PublisherCode Property

[image]

LinkOne WebView API
PagePictureInfo..::.PublisherCode Property
PagePictureInfo Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PublisherCode { get; set; }
Visual Basic (Declaration)
Public Property PublisherCode As String
Visual C++
public:
property String^ PublisherCode {
    String^ get ();
    void set (String^ value);
}

See Also

PagePictureInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Part Class

[image]

LinkOne WebView API
Part Class
Members See Also Send Feedback
Represents a part in a LinkOne book.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class Part
Visual Basic (Declaration)
Public Class Part
Visual C++
public ref class Part

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.Part

See Also

Part Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Part Members

[image] [image]

LinkOne WebView API
Part Members
Part Class Constructors Methods Properties See Also Send Feedback

The Part type exposes the following members.

Constructors

Name | Description
Part | Initializes a new instance of the Part class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
BookCode | Gets or sets the book code.
ItemId | Gets or sets the item id.
PageReference | Gets or sets the page reference.
PublisherCode | Gets or sets the publisher code.

See Also

Part Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Part Constructor

[image]

LinkOne WebView API
Part Constructor
Part Class See Also Send Feedback
Initializes a new instance of the Part class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Part()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Part()

See Also

Part Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Part Methods

[image] [image]

LinkOne WebView API
Part Methods
Part Class See Also Send Feedback

The Part type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Part Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Part Properties

[image] [image]

LinkOne WebView API
Part Properties
Part Class See Also Send Feedback

The Part type exposes the following members.

Properties

Name | Description
BookCode | Gets or sets the book code.
ItemId | Gets or sets the item id.
PageReference | Gets or sets the page reference.
PublisherCode | Gets or sets the publisher code.

See Also

Part Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


BookCode Property

[image]

LinkOne WebView API
Part..::.BookCode Property
Part Class See Also Send Feedback
Gets or sets the book code.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string BookCode { get; set; }
Visual Basic (Declaration)
Public Property BookCode As String
Visual C++
public:
property String^ BookCode {
    String^ get ();
    void set (String^ value);
}

See Also

Part Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


ItemId Property

[image]

LinkOne WebView API
Part..::.ItemId Property
Part Class See Also Send Feedback
Gets or sets the item id.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string ItemId { get; set; }
Visual Basic (Declaration)
Public Property ItemId As String
Visual C++
public:
property String^ ItemId {
    String^ get ();
    void set (String^ value);
}

See Also

Part Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PageReference Property

[image]

LinkOne WebView API
Part..::.PageReference Property
Part Class See Also Send Feedback
Gets or sets the page reference.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PageReference { get; set; }
Visual Basic (Declaration)
Public Property PageReference As String
Visual C++
public:
property String^ PageReference {
    String^ get ();
    void set (String^ value);
}

See Also

Part Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PublisherCode Property

[image]

LinkOne WebView API
Part..::.PublisherCode Property
Part Class See Also Send Feedback
Gets or sets the publisher code.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PublisherCode { get; set; }
Visual Basic (Declaration)
Public Property PublisherCode As String
Visual C++
public:
property String^ PublisherCode {
    String^ get ();
    void set (String^ value);
}

See Also

Part Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Picture Class

[image]

LinkOne WebView API
Picture Class
Members See Also Send Feedback
Represents a LinkOne picture.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class Picture
Visual Basic (Declaration)
Public Class Picture
Visual C++
public ref class Picture

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.Picture

See Also

Picture Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Picture Members

[image] [image]

LinkOne WebView API
Picture Members
Picture Class Constructors Methods Properties See Also Send Feedback

The Picture type exposes the following members.

Constructors

Name | Description
Picture | Initializes a new instance of the Picture class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Height | Gets or sets the physical picture height.
IsRightHemisphere | Gets or sets the right hemisphere flag
IsSvgGenerated | Gets or sets the is svg generated flag
MaximumTileLevel | Gets or sets the maximum tile level.
MinimumTileLevel | Gets or sets the minimum tile level.
TiledHeight | Gets or sets the combined height of the all tiles.
TiledWidth | Gets or sets the combined width of the all tiles.
TileSize | Gets or sets the size of the picture tile.
TileSourceUri | Gets or sets the source URI of the picture data stream.
Width | Gets or sets the physical picture width.

See Also

Picture Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Picture Constructor

[image]

LinkOne WebView API
Picture Constructor
Picture Class See Also Send Feedback
Initializes a new instance of the Picture class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Picture()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Picture()

See Also

Picture Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Picture Methods

[image] [image]

LinkOne WebView API
Picture Methods
Picture Class See Also Send Feedback

The Picture type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Picture Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Picture Properties

[image] [image]

LinkOne WebView API
Picture Properties
Picture Class See Also Send Feedback

The Picture type exposes the following members.

Properties

Name | Description
Height | Gets or sets the physical picture height.
IsRightHemisphere | Gets or sets the right hemisphere flag
IsSvgGenerated | Gets or sets the is svg generated flag
MaximumTileLevel | Gets or sets the maximum tile level.
MinimumTileLevel | Gets or sets the minimum tile level.
TiledHeight | Gets or sets the combined height of the all tiles.
TiledWidth | Gets or sets the combined width of the all tiles.
TileSize | Gets or sets the size of the picture tile.
TileSourceUri | Gets or sets the source URI of the picture data stream.
Width | Gets or sets the physical picture width.

See Also

Picture Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Height Property

[image]

LinkOne WebView API
Picture..::.Height Property
Picture Class See Also Send Feedback
Gets or sets the physical picture height.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Integer
Visual C++
public:
property int Height {
    int get ();
    void set (int value);
}

See Also

Picture Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


IsRightHemisphere Property

[image]

LinkOne WebView API
Picture..::.IsRightHemisphere Property
Picture Class See Also Send Feedback
Gets or sets the right hemisphere flag

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool IsRightHemisphere { get; set; }
Visual Basic (Declaration)
Public Property IsRightHemisphere As Boolean
Visual C++
public:
property bool IsRightHemisphere {
    bool get ();
    void set (bool value);
}

See Also

Picture Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


IsSvgGenerated Property

[image]

LinkOne WebView API
Picture..::.IsSvgGenerated Property
Picture Class See Also Send Feedback
Gets or sets the is svg generated flag

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool IsSvgGenerated { get; set; }
Visual Basic (Declaration)
Public Property IsSvgGenerated As Boolean
Visual C++
public:
property bool IsSvgGenerated {
    bool get ();
    void set (bool value);
}

See Also

Picture Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


MaximumTileLevel Property

[image]

LinkOne WebView API
Picture..::.MaximumTileLevel Property
Picture Class See Also Send Feedback
Gets or sets the maximum tile level.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int MaximumTileLevel { get; set; }
Visual Basic (Declaration)
Public Property MaximumTileLevel As Integer
Visual C++
public:
property int MaximumTileLevel {
    int get ();
    void set (int value);
}

See Also

Picture Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


MinimumTileLevel Property

[image]

LinkOne WebView API
Picture..::.MinimumTileLevel Property
Picture Class See Also Send Feedback
Gets or sets the minimum tile level.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int MinimumTileLevel { get; set; }
Visual Basic (Declaration)
Public Property MinimumTileLevel As Integer
Visual C++
public:
property int MinimumTileLevel {
    int get ();
    void set (int value);
}

See Also

Picture Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


TiledHeight Property

[image]

LinkOne WebView API
Picture..::.TiledHeight Property
Picture Class See Also Send Feedback
Gets or sets the combined height of the all tiles.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int TiledHeight { get; set; }
Visual Basic (Declaration)
Public Property TiledHeight As Integer
Visual C++
public:
property int TiledHeight {
    int get ();
    void set (int value);
}

See Also

Picture Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


TiledWidth Property

[image]

LinkOne WebView API
Picture..::.TiledWidth Property
Picture Class See Also Send Feedback
Gets or sets the combined width of the all tiles.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int TiledWidth { get; set; }
Visual Basic (Declaration)
Public Property TiledWidth As Integer
Visual C++
public:
property int TiledWidth {
    int get ();
    void set (int value);
}

See Also

Picture Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


TileSize Property

[image]

LinkOne WebView API
Picture..::.TileSize Property
Picture Class See Also Send Feedback
Gets or sets the size of the picture tile.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int TileSize { get; set; }
Visual Basic (Declaration)
Public Property TileSize As Integer
Visual C++
public:
property int TileSize {
    int get ();
    void set (int value);
}

See Also

Picture Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


TileSourceUri Property

[image]

LinkOne WebView API
Picture..::.TileSourceUri Property
Picture Class See Also Send Feedback
Gets or sets the source URI of the picture data stream.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string TileSourceUri { get; set; }
Visual Basic (Declaration)
Public Property TileSourceUri As String
Visual C++
public:
property String^ TileSourceUri {
    String^ get ();
    void set (String^ value);
}

See Also

Picture Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Width Property

[image]

LinkOne WebView API
Picture..::.Width Property
Picture Class See Also Send Feedback
Gets or sets the physical picture width.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Integer
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

See Also

Picture Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PictureInfo Class

[image]

LinkOne WebView API
PictureInfo Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class PictureInfo
Visual Basic (Declaration)
Public Class PictureInfo
Visual C++
public ref class PictureInfo

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.PictureInfo
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.PagePictureInfo

See Also

PictureInfo Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PictureInfo Members

[image] [image]

LinkOne WebView API
PictureInfo Members
PictureInfo Class Constructors Methods Properties See Also Send Feedback

The PictureInfo type exposes the following members.

Constructors

Name | Description
PictureInfo | Initializes a new instance of the PictureInfo class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Picture | The picture to display
SelectionListParts | Current Selection List contents

See Also

PictureInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PictureInfo Constructor

[image]

LinkOne WebView API
PictureInfo Constructor
PictureInfo Class See Also Send Feedback
Initializes a new instance of the PictureInfo class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public PictureInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PictureInfo()

See Also

PictureInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PictureInfo Methods

[image] [image]

LinkOne WebView API
PictureInfo Methods
PictureInfo Class See Also Send Feedback

The PictureInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PictureInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PictureInfo Properties

[image] [image]

LinkOne WebView API
PictureInfo Properties
PictureInfo Class See Also Send Feedback

The PictureInfo type exposes the following members.

Properties

Name | Description
Picture | The picture to display
SelectionListParts | Current Selection List contents

See Also

PictureInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Picture Property

[image]

LinkOne WebView API
PictureInfo..::.Picture Property
PictureInfo Class See Also Send Feedback
The picture to display

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Picture Picture { get; set; }
Visual Basic (Declaration)
Public Property Picture As Picture
Visual C++
public:
property Picture^ Picture {
    Picture^ get ();
    void set (Picture^ value);
}

See Also

PictureInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


SelectionListParts Property

[image]

LinkOne WebView API
PictureInfo..::.SelectionListParts Property
PictureInfo Class See Also Send Feedback
Current Selection List contents

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public List<Part> SelectionListParts { get; set; }
Visual Basic (Declaration)
Public Property SelectionListParts As List(Of Part)
Visual C++
public:
property List<Part^>^ SelectionListParts {
    List<Part^>^ get ();
    void set (List<Part^>^ value);
}

See Also

PictureInfo Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PictureMetadata Class

[image]

LinkOne WebView API
PictureMetadata Class
Members See Also Send Feedback
Represents metadata for a LinkOne picture.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class PictureMetadata
Visual Basic (Declaration)
Public Class PictureMetadata
Visual C++
public ref class PictureMetadata

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.PictureMetadata

See Also

PictureMetadata Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PictureMetadata Members

[image] [image]

LinkOne WebView API
PictureMetadata Members
PictureMetadata Class Constructors Methods Properties See Also Send Feedback

The PictureMetadata type exposes the following members.

Constructors

Name | Description
PictureMetadata | Initializes a new instance of the PictureMetadata class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Callouts | Gets or sets the callouts for the picture.
Number | Gets or sets the number.
Title | Gets the title.

See Also

PictureMetadata Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PictureMetadata Constructor

[image]

LinkOne WebView API
PictureMetadata Constructor
PictureMetadata Class See Also Send Feedback
Initializes a new instance of the PictureMetadata class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public PictureMetadata()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PictureMetadata()

See Also

PictureMetadata Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PictureMetadata Methods

[image] [image]

LinkOne WebView API
PictureMetadata Methods
PictureMetadata Class See Also Send Feedback

The PictureMetadata type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PictureMetadata Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PictureMetadata Properties

[image] [image]

LinkOne WebView API
PictureMetadata Properties
PictureMetadata Class See Also Send Feedback

The PictureMetadata type exposes the following members.

Properties

Name | Description
Callouts | Gets or sets the callouts for the picture.
Number | Gets or sets the number.
Title | Gets the title.

See Also

PictureMetadata Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Callouts Property

[image]

LinkOne WebView API
PictureMetadata..::.Callouts Property
PictureMetadata Class See Also Send Feedback
Gets or sets the callouts for the picture.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Callout[] Callouts { get; set; }
Visual Basic (Declaration)
Public Property Callouts As Callout()
Visual C++
public:
property array<Callout^>^ Callouts {
    array<Callout^>^ get ();
    void set (array<Callout^>^ value);
}

See Also

PictureMetadata Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Number Property

[image]

LinkOne WebView API
PictureMetadata..::.Number Property
PictureMetadata Class See Also Send Feedback
Gets or sets the number.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int Number { get; set; }
Visual Basic (Declaration)
Public Property Number As Integer
Visual C++
public:
property int Number {
    int get ();
    void set (int value);
}

See Also

PictureMetadata Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Title Property

[image]

LinkOne WebView API
PictureMetadata..::.Title Property
PictureMetadata Class See Also Send Feedback
Gets the title.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Title { get; set; }
Visual Basic (Declaration)
Public Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

See Also

PictureMetadata Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PictureTile Class

[image]

LinkOne WebView API
PictureTile Class
Members See Also Send Feedback
Represents the data for an image tile requested from the IBookService.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class PictureTile
Visual Basic (Declaration)
Public Class PictureTile
Visual C++
public ref class PictureTile

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.PictureTile

See Also

PictureTile Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PictureTile Members

[image] [image]

LinkOne WebView API
PictureTile Members
PictureTile Class Constructors Methods Properties See Also Send Feedback

The PictureTile type exposes the following members.

Constructors

Name | Description
PictureTile | Initializes a new instance of the PictureTile class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
ContentType | Defines the MIME/type of the image tile, e.g., "image/png".
TileData | Defines the data for the tile.

See Also

PictureTile Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PictureTile Constructor

[image]

LinkOne WebView API
PictureTile Constructor
PictureTile Class See Also Send Feedback
Initializes a new instance of the PictureTile class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public PictureTile()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PictureTile()

See Also

PictureTile Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PictureTile Methods

[image] [image]

LinkOne WebView API
PictureTile Methods
PictureTile Class See Also Send Feedback

The PictureTile type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PictureTile Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PictureTile Properties

[image] [image]

LinkOne WebView API
PictureTile Properties
PictureTile Class See Also Send Feedback

The PictureTile type exposes the following members.

Properties

Name | Description
ContentType | Defines the MIME/type of the image tile, e.g., "image/png".
TileData | Defines the data for the tile.

See Also

PictureTile Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


ContentType Property

[image]

LinkOne WebView API
PictureTile..::.ContentType Property
PictureTile Class See Also Send Feedback
Defines the MIME/type of the image tile, e.g., "image/png".

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string ContentType { get; set; }
Visual Basic (Declaration)
Public Property ContentType As String
Visual C++
public:
property String^ ContentType {
    String^ get ();
    void set (String^ value);
}

Field Value

Image type MIME/type.

See Also

PictureTile Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


TileData Property

[image]

LinkOne WebView API
PictureTile..::.TileData Property
PictureTile Class See Also Send Feedback
Defines the data for the tile.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public byte[] TileData { get; set; }
Visual Basic (Declaration)
Public Property TileData As Byte()
Visual C++
public:
property array<unsigned char>^ TileData {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Field Value

Image tile data.

Remarks

This data is effectively a raw memory stream. For example, if the ContentType is "image/png" then this data can be loaded into a Bitmap instance.

See Also

PictureTile Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Point Structure

[image]

LinkOne WebView API
Point Structure
Members See Also Send Feedback
Represents an x- and y-coordinate pair in two-dimensional space.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public struct Point
Visual Basic (Declaration)
Public Structure Point
Visual C++
public value class Point

See Also

Point Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Point Members

[image] [image]

LinkOne WebView API
Point Members
Point Structure Methods Properties See Also Send Feedback

The Point type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
X | Gets the x-coordinate.
Y | Gets the y-coordinate.

See Also

Point Structure
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Point Methods

[image] [image]

LinkOne WebView API
Point Methods
Point Structure See Also Send Feedback

The Point type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

Point Structure
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Point Properties

[image] [image]

LinkOne WebView API
Point Properties
Point Structure See Also Send Feedback

The Point type exposes the following members.

Properties

Name | Description
X | Gets the x-coordinate.
Y | Gets the y-coordinate.

See Also

Point Structure
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


X Property

[image]

LinkOne WebView API
Point..::.X Property
Point Structure See Also Send Feedback
Gets the x-coordinate.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public double X { get; set; }
Visual Basic (Declaration)
Public Property X As Double
Visual C++
public:
property double X {
    double get ();
    void set (double value);
}

See Also

Point Structure
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Y Property

[image]

LinkOne WebView API
Point..::.Y Property
Point Structure See Also Send Feedback
Gets the y-coordinate.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public double Y { get; set; }
Visual Basic (Declaration)
Public Property Y As Double
Visual C++
public:
property double Y {
    double get ();
    void set (double value);
}

See Also

Point Structure
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PopupNote Class

[image]

LinkOne WebView API
PopupNote Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class PopupNote
Visual Basic (Declaration)
Public Class PopupNote
Visual C++
public ref class PopupNote

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.PopupNote

See Also

PopupNote Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PopupNote Members

[image] [image]

LinkOne WebView API
PopupNote Members
PopupNote Class Constructors Methods Properties See Also Send Feedback

The PopupNote type exposes the following members.

Constructors

Name | Description
PopupNote | Initializes a new instance of the PopupNote class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
HasPopped |
IsPopupEveryPage |
NoteKey |

See Also

PopupNote Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PopupNote Constructor

[image]

LinkOne WebView API
PopupNote Constructor
PopupNote Class See Also Send Feedback
Initializes a new instance of the PopupNote class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public PopupNote()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PopupNote()

See Also

PopupNote Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PopupNote Methods

[image] [image]

LinkOne WebView API
PopupNote Methods
PopupNote Class See Also Send Feedback

The PopupNote type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PopupNote Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PopupNote Properties

[image] [image]

LinkOne WebView API
PopupNote Properties
PopupNote Class See Also Send Feedback

The PopupNote type exposes the following members.

Properties

Name | Description
HasPopped |
IsPopupEveryPage |
NoteKey |

See Also

PopupNote Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


HasPopped Property

[image]

LinkOne WebView API
PopupNote..::.HasPopped Property
PopupNote Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool HasPopped { get; set; }
Visual Basic (Declaration)
Public Property HasPopped As Boolean
Visual C++
public:
property bool HasPopped {
    bool get ();
    void set (bool value);
}

See Also

PopupNote Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


IsPopupEveryPage Property

[image]

LinkOne WebView API
PopupNote..::.IsPopupEveryPage Property
PopupNote Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool IsPopupEveryPage { get; set; }
Visual Basic (Declaration)
Public Property IsPopupEveryPage As Boolean
Visual C++
public:
property bool IsPopupEveryPage {
    bool get ();
    void set (bool value);
}

See Also

PopupNote Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


NoteKey Property

[image]

LinkOne WebView API
PopupNote..::.NoteKey Property
PopupNote Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string NoteKey { get; set; }
Visual Basic (Declaration)
Public Property NoteKey As String
Visual C++
public:
property String^ NoteKey {
    String^ get ();
    void set (String^ value);
}

See Also

PopupNote Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


RectangularCallout Class

[image]

LinkOne WebView API
RectangularCallout Class
Members See Also Send Feedback
Represents a callout that is rendered as a Rectangle.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public sealed class RectangularCallout : Callout
Visual Basic (Declaration)
Public NotInheritable Class RectangularCallout _
    Inherits Callout
Visual C++
public ref class RectangularCallout sealed : public Callout

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.Callout
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.RectangularCallout

See Also

RectangularCallout Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


RectangularCallout Members

[image] [image]

LinkOne WebView API
RectangularCallout Members
RectangularCallout Class Constructors Methods Properties See Also Send Feedback

The RectangularCallout type exposes the following members.

Constructors

Name | Description
RectangularCallout | Initializes a new instance of the RectangularCallout class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
CanAddPart | Gets a value indicating whether this instance can add part. (Inherited from Callout.)
Description | Gets or sets the description. (Inherited from Callout.)
DisplayItemId | Gets the the display item id. (Inherited from Callout.)
FontSize | Gets the size of the font. (Inherited from Callout.)
IsLink | Gets a value indicating whether this callout is a link. (Inherited from Callout.)
IsSelectable | A callout is selectable if if has a matching part in the parts list, or if it is a linear callout. (Inherited from Callout.)
ItemId | Gets the item id. (Inherited from Callout.)
LinkBookCode | Gets the link book code for the callout's matching part, if the part is a link and the book link is set. (Inherited from Callout.)
LinkItemId | Gets the link item id for the callout's matching part, if the part is a link and the item link is set. (Inherited from Callout.)
LinkObjectIdentifier | Gets the link object identifier for the callout's matching part, if the part is a link and the object link is set. (Inherited from Callout.)
LinkPageReference | Gets the link page reference for the callout's matching part, if the part is a link and the page link is set. (Inherited from Callout.)
LinkPublisherCode | Gets the link publisher code for the callout's matching part, if the part is a link and the publisher link is set. (Inherited from Callout.)
PartNumber | Gets or sets the part number. (Inherited from Callout.)
Position | Gets the position. (Inherited from Callout.)
TextAngle | Gets the angle to render text. (Inherited from Callout.)
TooltipHtml | Gets or sets the tooltip html. (Inherited from Callout.)
ZoneType | Gets or sets the type of the zone. (Inherited from Callout.)

See Also

RectangularCallout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


RectangularCallout Constructor

[image]

LinkOne WebView API
RectangularCallout Constructor
RectangularCallout Class See Also Send Feedback
Initializes a new instance of the RectangularCallout class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public RectangularCallout()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RectangularCallout()

See Also

RectangularCallout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


RectangularCallout Methods

[image] [image]

LinkOne WebView API
RectangularCallout Methods
RectangularCallout Class See Also Send Feedback

The RectangularCallout type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RectangularCallout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


RectangularCallout Properties

[image] [image]

LinkOne WebView API
RectangularCallout Properties
RectangularCallout Class See Also Send Feedback

The RectangularCallout type exposes the following members.

Properties

Name | Description
CanAddPart | Gets a value indicating whether this instance can add part. (Inherited from Callout.)
Description | Gets or sets the description. (Inherited from Callout.)
DisplayItemId | Gets the the display item id. (Inherited from Callout.)
FontSize | Gets the size of the font. (Inherited from Callout.)
IsLink | Gets a value indicating whether this callout is a link. (Inherited from Callout.)
IsSelectable | A callout is selectable if if has a matching part in the parts list, or if it is a linear callout. (Inherited from Callout.)
ItemId | Gets the item id. (Inherited from Callout.)
LinkBookCode | Gets the link book code for the callout's matching part, if the part is a link and the book link is set. (Inherited from Callout.)
LinkItemId | Gets the link item id for the callout's matching part, if the part is a link and the item link is set. (Inherited from Callout.)
LinkObjectIdentifier | Gets the link object identifier for the callout's matching part, if the part is a link and the object link is set. (Inherited from Callout.)
LinkPageReference | Gets the link page reference for the callout's matching part, if the part is a link and the page link is set. (Inherited from Callout.)
LinkPublisherCode | Gets the link publisher code for the callout's matching part, if the part is a link and the publisher link is set. (Inherited from Callout.)
PartNumber | Gets or sets the part number. (Inherited from Callout.)
Position | Gets the position. (Inherited from Callout.)
TextAngle | Gets the angle to render text. (Inherited from Callout.)
TooltipHtml | Gets or sets the tooltip html. (Inherited from Callout.)
ZoneType | Gets or sets the type of the zone. (Inherited from Callout.)

See Also

RectangularCallout Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Search Class

[image]

LinkOne WebView API
Search Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class Search
Visual Basic (Declaration)
Public Class Search
Visual C++
public ref class Search

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.Search

See Also

Search Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Search Members

[image] [image]

LinkOne WebView API
Search Members
Search Class Constructors Methods Properties See Also Send Feedback

The Search type exposes the following members.

Constructors

Name | Description
Search | Initializes a new instance of the Search class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Description | Gets the search description.
DisplayFieldItemDescription | Gets the search display field item description.
Name | Gets the search description.
SearchKeys | Gets the search keys.

See Also

Search Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Search Constructor

[image]

LinkOne WebView API
Search Constructor
Search Class See Also Send Feedback
Initializes a new instance of the Search class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public Search()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Search()

See Also

Search Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Search Methods

[image] [image]

LinkOne WebView API
Search Methods
Search Class See Also Send Feedback

The Search type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Search Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Search Properties

[image] [image]

LinkOne WebView API
Search Properties
Search Class See Also Send Feedback

The Search type exposes the following members.

Properties

Name | Description
Description | Gets the search description.
DisplayFieldItemDescription | Gets the search display field item description.
Name | Gets the search description.
SearchKeys | Gets the search keys.

See Also

Search Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Description Property

[image]

LinkOne WebView API
Search..::.Description Property
Search Class See Also Send Feedback
Gets the search description.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

Search Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


DisplayFieldItemDescription Property

[image]

LinkOne WebView API
Search..::.DisplayFieldItemDescription Property
Search Class See Also Send Feedback
Gets the search display field item description.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string DisplayFieldItemDescription { get; set; }
Visual Basic (Declaration)
Public Property DisplayFieldItemDescription As String
Visual C++
public:
property String^ DisplayFieldItemDescription {
    String^ get ();
    void set (String^ value);
}

See Also

Search Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Name Property

[image]

LinkOne WebView API
Search..::.Name Property
Search Class See Also Send Feedback
Gets the search description.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

Search Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


SearchKeys Property

[image]

LinkOne WebView API
Search..::.SearchKeys Property
Search Class See Also Send Feedback
Gets the search keys.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public List<SearchKey> SearchKeys { get; set; }
Visual Basic (Declaration)
Public Property SearchKeys As List(Of SearchKey)
Visual C++
public:
property List<SearchKey^>^ SearchKeys {
    List<SearchKey^>^ get ();
    void set (List<SearchKey^>^ value);
}

See Also

Search Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


SearchKey Class

[image]

LinkOne WebView API
SearchKey Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class SearchKey
Visual Basic (Declaration)
Public Class SearchKey
Visual C++
public ref class SearchKey

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.SearchKey

See Also

SearchKey Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


SearchKey Members

[image] [image]

LinkOne WebView API
SearchKey Members
SearchKey Class Constructors Methods Properties See Also Send Feedback

The SearchKey type exposes the following members.

Constructors

Name | Description
SearchKey | Initializes a new instance of the SearchKey class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Caption | Gets the searchkey caption.
FieldType | Gets the searchkey field type.
SearchFields | Gets the searchkey search fields.

See Also

SearchKey Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


SearchKey Constructor

[image]

LinkOne WebView API
SearchKey Constructor
SearchKey Class See Also Send Feedback
Initializes a new instance of the SearchKey class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public SearchKey()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SearchKey()

See Also

SearchKey Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


SearchKey Methods

[image] [image]

LinkOne WebView API
SearchKey Methods
SearchKey Class See Also Send Feedback

The SearchKey type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SearchKey Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


SearchKey Properties

[image] [image]

LinkOne WebView API
SearchKey Properties
SearchKey Class See Also Send Feedback

The SearchKey type exposes the following members.

Properties

Name | Description
Caption | Gets the searchkey caption.
FieldType | Gets the searchkey field type.
SearchFields | Gets the searchkey search fields.

See Also

SearchKey Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Caption Property

[image]

LinkOne WebView API
SearchKey..::.Caption Property
SearchKey Class See Also Send Feedback
Gets the searchkey caption.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Caption { get; set; }
Visual Basic (Declaration)
Public Property Caption As String
Visual C++
public:
property String^ Caption {
    String^ get ();
    void set (String^ value);
}

Remarks

The key caption is the text that will appear abouve the key entry field on the search dialog.

See Also

SearchKey Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


FieldType Property

[image]

LinkOne WebView API
SearchKey..::.FieldType Property
SearchKey Class See Also Send Feedback
Gets the searchkey field type.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public SearchFieldType FieldType { get; set; }
Visual Basic (Declaration)
Public Property FieldType As SearchFieldType
Visual C++
public:
property SearchFieldType FieldType {
    SearchFieldType get ();
    void set (SearchFieldType value);
}

Remarks

The field type defines the type of fields that this key will search, it can be LIST or ENTRY. If none is specified, then ENTRY is assumed.

See Also

SearchKey Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


SearchFields Property

[image]

LinkOne WebView API
SearchKey..::.SearchFields Property
SearchKey Class See Also Send Feedback
Gets the searchkey search fields.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public List<SearchField> SearchFields { get; set; }
Visual Basic (Declaration)
Public Property SearchFields As List(Of SearchField)
Visual C++
public:
property List<SearchField^>^ SearchFields {
    List<SearchField^>^ get ();
    void set (List<SearchField^>^ value);
}

Remarks

The search field collection specifies which data fields each key will be compared to when searching. There may be any number of search fields associated with a search key. For each entry or page the key will be compared to each of the fields listed. If a match is found in any of those fields, then the entry or page is considered a match for that key.

See Also

SearchKey Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


SearchParameter Class

[image]

LinkOne WebView API
SearchParameter Class
Members See Also Send Feedback
Represents the data for a search parameter send to the ISearchService.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class SearchParameter
Visual Basic (Declaration)
Public Class SearchParameter
Visual C++
public ref class SearchParameter

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.SearchParameter

See Also

SearchParameter Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


SearchParameter Members

[image] [image]

LinkOne WebView API
SearchParameter Members
SearchParameter Class Constructors Methods Properties See Also Send Feedback

The SearchParameter type exposes the following members.

Constructors

Name | Description
SearchParameter | Initializes a new instance of the SearchParameter class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
ExactMatch | Gets or sets the flag for exact matching.
MatchCase | Gets or sets the flag for matching case.
Value | Gets and sets the search value.

See Also

SearchParameter Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


SearchParameter Constructor

[image]

LinkOne WebView API
SearchParameter Constructor
SearchParameter Class See Also Send Feedback
Initializes a new instance of the SearchParameter class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public SearchParameter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SearchParameter()

See Also

SearchParameter Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


SearchParameter Methods

[image] [image]

LinkOne WebView API
SearchParameter Methods
SearchParameter Class See Also Send Feedback

The SearchParameter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SearchParameter Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


SearchParameter Properties

[image] [image]

LinkOne WebView API
SearchParameter Properties
SearchParameter Class See Also Send Feedback

The SearchParameter type exposes the following members.

Properties

Name | Description
ExactMatch | Gets or sets the flag for exact matching.
MatchCase | Gets or sets the flag for matching case.
Value | Gets and sets the search value.

See Also

SearchParameter Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


ExactMatch Property

[image]

LinkOne WebView API
SearchParameter..::.ExactMatch Property
SearchParameter Class See Also Send Feedback
Gets or sets the flag for exact matching.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool ExactMatch { get; set; }
Visual Basic (Declaration)
Public Property ExactMatch As Boolean
Visual C++
public:
property bool ExactMatch {
    bool get ();
    void set (bool value);
}

See Also

SearchParameter Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


MatchCase Property

[image]

LinkOne WebView API
SearchParameter..::.MatchCase Property
SearchParameter Class See Also Send Feedback
Gets or sets the flag for matching case.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public bool MatchCase { get; set; }
Visual Basic (Declaration)
Public Property MatchCase As Boolean
Visual C++
public:
property bool MatchCase {
    bool get ();
    void set (bool value);
}

See Also

SearchParameter Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Value Property

[image]

LinkOne WebView API
SearchParameter..::.Value Property
SearchParameter Class See Also Send Feedback
Gets and sets the search value.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

SearchParameter Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


SearchResult Class

[image]

LinkOne WebView API
SearchResult Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class SearchResult
Visual Basic (Declaration)
Public Class SearchResult
Visual C++
public ref class SearchResult

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.SearchResult

See Also

SearchResult Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


SearchResult Members

[image] [image]

LinkOne WebView API
SearchResult Members
SearchResult Class Constructors Methods Properties See Also Send Feedback

The SearchResult type exposes the following members.

Constructors

Name | Description
SearchResult | Initializes a new instance of the SearchResult class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
BookCode | Gets the book code.
BookTitle | Gets the book title.
DisplayedItemId | Gets the display version of the Item Id that has ignored content filtered
DisplayValue | Gets the display value.
ItemId | Gets the item identifier.
ItemTag | Gets the item tag.
MatchingField | Gets the matching field(s).
PageNumber | Gets the page number.
PageReference | Gets the page reference.
PageTitle | Gets the page title.
PublisherCode | Gets the publisher code.
SearchIndexPosition | Gets the search index position.
VisiblePageNumber | Gets the visible page number, taking into account any special page number visibility processing.

See Also

SearchResult Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


SearchResult Constructor

[image]

LinkOne WebView API
SearchResult Constructor
SearchResult Class See Also Send Feedback
Initializes a new instance of the SearchResult class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public SearchResult()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SearchResult()

See Also

SearchResult Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


SearchResult Methods

[image] [image]

LinkOne WebView API
SearchResult Methods
SearchResult Class See Also Send Feedback

The SearchResult type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SearchResult Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


SearchResult Properties

[image] [image]

LinkOne WebView API
SearchResult Properties
SearchResult Class See Also Send Feedback

The SearchResult type exposes the following members.

Properties

Name | Description
BookCode | Gets the book code.
BookTitle | Gets the book title.
DisplayedItemId | Gets the display version of the Item Id that has ignored content filtered
DisplayValue | Gets the display value.
ItemId | Gets the item identifier.
ItemTag | Gets the item tag.
MatchingField | Gets the matching field(s).
PageNumber | Gets the page number.
PageReference | Gets the page reference.
PageTitle | Gets the page title.
PublisherCode | Gets the publisher code.
SearchIndexPosition | Gets the search index position.
VisiblePageNumber | Gets the visible page number, taking into account any special page number visibility processing.

See Also

SearchResult Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


BookCode Property

[image]

LinkOne WebView API
SearchResult..::.BookCode Property
SearchResult Class See Also Send Feedback
Gets the book code.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string BookCode { get; set; }
Visual Basic (Declaration)
Public Property BookCode As String
Visual C++
public:
property String^ BookCode {
    String^ get ();
    void set (String^ value);
}

See Also

SearchResult Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


BookTitle Property

[image]

LinkOne WebView API
SearchResult..::.BookTitle Property
SearchResult Class See Also Send Feedback
Gets the book title.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string BookTitle { get; set; }
Visual Basic (Declaration)
Public Property BookTitle As String
Visual C++
public:
property String^ BookTitle {
    String^ get ();
    void set (String^ value);
}

See Also

SearchResult Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


DisplayedItemId Property

[image]

LinkOne WebView API
SearchResult..::.DisplayedItemId Property
SearchResult Class See Also Send Feedback
Gets the display version of the Item Id that has ignored content filtered

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string DisplayedItemId { get; set; }
Visual Basic (Declaration)
Public Property DisplayedItemId As String
Visual C++
public:
property String^ DisplayedItemId {
    String^ get ();
    void set (String^ value);
}

See Also

SearchResult Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


DisplayValue Property

[image]

LinkOne WebView API
SearchResult..::.DisplayValue Property
SearchResult Class See Also Send Feedback
Gets the display value.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string DisplayValue { get; set; }
Visual Basic (Declaration)
Public Property DisplayValue As String
Visual C++
public:
property String^ DisplayValue {
    String^ get ();
    void set (String^ value);
}

See Also

SearchResult Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


ItemId Property

[image]

LinkOne WebView API
SearchResult..::.ItemId Property
SearchResult Class See Also Send Feedback
Gets the item identifier.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string ItemId { get; set; }
Visual Basic (Declaration)
Public Property ItemId As String
Visual C++
public:
property String^ ItemId {
    String^ get ();
    void set (String^ value);
}

See Also

SearchResult Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


ItemTag Property

[image]

LinkOne WebView API
SearchResult..::.ItemTag Property
SearchResult Class See Also Send Feedback
Gets the item tag.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int ItemTag { get; set; }
Visual Basic (Declaration)
Public Property ItemTag As Integer
Visual C++
public:
property int ItemTag {
    int get ();
    void set (int value);
}

See Also

SearchResult Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


MatchingField Property

[image]

LinkOne WebView API
SearchResult..::.MatchingField Property
SearchResult Class See Also Send Feedback
Gets the matching field(s).

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public SearchResultFieldMatch MatchingField { get; set; }
Visual Basic (Declaration)
Public Property MatchingField As SearchResultFieldMatch
Visual C++
public:
property SearchResultFieldMatch^ MatchingField {
    SearchResultFieldMatch^ get ();
    void set (SearchResultFieldMatch^ value);
}

See Also

SearchResult Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PageNumber Property

[image]

LinkOne WebView API
SearchResult..::.PageNumber Property
SearchResult Class See Also Send Feedback
Gets the page number.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PageNumber { get; set; }
Visual Basic (Declaration)
Public Property PageNumber As String
Visual C++
public:
property String^ PageNumber {
    String^ get ();
    void set (String^ value);
}

See Also

SearchResult Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PageReference Property

[image]

LinkOne WebView API
SearchResult..::.PageReference Property
SearchResult Class See Also Send Feedback
Gets the page reference.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PageReference { get; set; }
Visual Basic (Declaration)
Public Property PageReference As String
Visual C++
public:
property String^ PageReference {
    String^ get ();
    void set (String^ value);
}

See Also

SearchResult Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PageTitle Property

[image]

LinkOne WebView API
SearchResult..::.PageTitle Property
SearchResult Class See Also Send Feedback
Gets the page title.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PageTitle { get; set; }
Visual Basic (Declaration)
Public Property PageTitle As String
Visual C++
public:
property String^ PageTitle {
    String^ get ();
    void set (String^ value);
}

See Also

SearchResult Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PublisherCode Property

[image]

LinkOne WebView API
SearchResult..::.PublisherCode Property
SearchResult Class See Also Send Feedback
Gets the publisher code.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PublisherCode { get; set; }
Visual Basic (Declaration)
Public Property PublisherCode As String
Visual C++
public:
property String^ PublisherCode {
    String^ get ();
    void set (String^ value);
}

See Also

SearchResult Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


SearchIndexPosition Property

[image]

LinkOne WebView API
SearchResult..::.SearchIndexPosition Property
SearchResult Class See Also Send Feedback
Gets the search index position.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public SearchIndexPosition SearchIndexPosition { get; set; }
Visual Basic (Declaration)
Public Property SearchIndexPosition As SearchIndexPosition
Visual C++
public:
property SearchIndexPosition SearchIndexPosition {
    SearchIndexPosition get ();
    void set (SearchIndexPosition value);
}

See Also

SearchResult Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


VisiblePageNumber Property

[image]

LinkOne WebView API
SearchResult..::.VisiblePageNumber Property
SearchResult Class See Also Send Feedback
Gets the visible page number, taking into account any special page number visibility processing.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string VisiblePageNumber { get; set; }
Visual Basic (Declaration)
Public Property VisiblePageNumber As String
Visual C++
public:
property String^ VisiblePageNumber {
    String^ get ();
    void set (String^ value);
}

See Also

SearchResult Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


SearchSet Class

[image]

LinkOne WebView API
SearchSet Class
Members See Also Send Feedback
Represents the data for a search set requested from the ISearchService.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class SearchSet
Visual Basic (Declaration)
Public Class SearchSet
Visual C++
public ref class SearchSet

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.SearchSet

See Also

SearchSet Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


SearchSet Members

[image] [image]

LinkOne WebView API
SearchSet Members
SearchSet Class Constructors Methods Properties See Also Send Feedback

The SearchSet type exposes the following members.

Constructors

Name | Description
SearchSet | Initializes a new instance of the SearchSet class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Description | Gets the search set description.
Key | Gets a key representing the search set.
LanguageCode | Gets the language code.
Name | Gets the search set name.
Searches | Gets the collection of searches contained within this search set.
SecurityLock | Gets the security lock.
Source | Gets the search set source.

See Also

SearchSet Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


SearchSet Constructor

[image]

LinkOne WebView API
SearchSet Constructor
SearchSet Class See Also Send Feedback
Initializes a new instance of the SearchSet class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public SearchSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SearchSet()

See Also

SearchSet Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


SearchSet Methods

[image] [image]

LinkOne WebView API
SearchSet Methods
SearchSet Class See Also Send Feedback

The SearchSet type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SearchSet Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


SearchSet Properties

[image] [image]

LinkOne WebView API
SearchSet Properties
SearchSet Class See Also Send Feedback

The SearchSet type exposes the following members.

Properties

Name | Description
Description | Gets the search set description.
Key | Gets a key representing the search set.
LanguageCode | Gets the language code.
Name | Gets the search set name.
Searches | Gets the collection of searches contained within this search set.
SecurityLock | Gets the security lock.
Source | Gets the search set source.

See Also

SearchSet Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Description Property

[image]

LinkOne WebView API
SearchSet..::.Description Property
SearchSet Class See Also Send Feedback
Gets the search set description.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

SearchSet Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Key Property

[image]

LinkOne WebView API
SearchSet..::.Key Property
SearchSet Class See Also Send Feedback
Gets a key representing the search set.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Key { get; set; }
Visual Basic (Declaration)
Public Property Key As String
Visual C++
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}

Remarks

The format is in LanguageCode:Name.

See Also

SearchSet Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


LanguageCode Property

[image]

LinkOne WebView API
SearchSet..::.LanguageCode Property
SearchSet Class See Also Send Feedback
Gets the language code.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string LanguageCode { get; set; }
Visual Basic (Declaration)
Public Property LanguageCode As String
Visual C++
public:
property String^ LanguageCode {
    String^ get ();
    void set (String^ value);
}

See Also

SearchSet Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Name Property

[image]

LinkOne WebView API
SearchSet..::.Name Property
SearchSet Class See Also Send Feedback
Gets the search set name.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

SearchSet Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Searches Property

[image]

LinkOne WebView API
SearchSet..::.Searches Property
SearchSet Class See Also Send Feedback
Gets the collection of searches contained within this search set.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public List<Search> Searches { get; set; }
Visual Basic (Declaration)
Public Property Searches As List(Of Search)
Visual C++
public:
property List<Search^>^ Searches {
    List<Search^>^ get ();
    void set (List<Search^>^ value);
}

See Also

SearchSet Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


SecurityLock Property

[image]

LinkOne WebView API
SearchSet..::.SecurityLock Property
SearchSet Class See Also Send Feedback
Gets the security lock.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string SecurityLock { get; set; }
Visual Basic (Declaration)
Public Property SecurityLock As String
Visual C++
public:
property String^ SecurityLock {
    String^ get ();
    void set (String^ value);
}

See Also

SearchSet Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Source Property

[image]

LinkOne WebView API
SearchSet..::.Source Property
SearchSet Class See Also Send Feedback
Gets the search set source.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public SearchSetSourceType Source { get; set; }
Visual Basic (Declaration)
Public Property Source As SearchSetSourceType
Visual C++
public:
property SearchSetSourceType Source {
    SearchSetSourceType get ();
    void set (SearchSetSourceType value);
}

See Also

SearchSet Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Size Structure

[image]

LinkOne WebView API
Size Structure
Members See Also Send Feedback
Implements a structure that is used to store the size of an object.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public struct Size
Visual Basic (Declaration)
Public Structure Size
Visual C++
public value class Size

See Also

Size Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Size Members

[image] [image]

LinkOne WebView API
Size Members
Size Structure Methods Properties See Also Send Feedback

The Size type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
Height | Gets the height of the object.
Width | Gets the width of the object.

See Also

Size Structure
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Size Methods

[image] [image]

LinkOne WebView API
Size Methods
Size Structure See Also Send Feedback

The Size type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

Size Structure
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Size Properties

[image] [image]

LinkOne WebView API
Size Properties
Size Structure See Also Send Feedback

The Size type exposes the following members.

Properties

Name | Description
Height | Gets the height of the object.
Width | Gets the width of the object.

See Also

Size Structure
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Height Property

[image]

LinkOne WebView API
Size..::.Height Property
Size Structure See Also Send Feedback
Gets the height of the object.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public double Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Double
Visual C++
public:
property double Height {
    double get ();
    void set (double value);
}

See Also

Size Structure
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Width Property

[image]

LinkOne WebView API
Size..::.Width Property
Size Structure See Also Send Feedback
Gets the width of the object.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public double Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Double
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

See Also

Size Structure
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


SolrSearchResults Class

[image]

LinkOne WebView API
SolrSearchResults Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class SolrSearchResults : List<SolrResultDocument>
Visual Basic (Declaration)
Public Class SolrSearchResults _
    Inherits List(Of SolrResultDocument)
Visual C++
public ref class SolrSearchResults : public List<SolrResultDocument^>

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.List<(Of <(SolrResultDocument>)>)
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.SolrSearchResults

See Also

SolrSearchResults Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


SolrSearchResults Members

[image] [image]

LinkOne WebView API
SolrSearchResults Members
SolrSearchResults Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The SolrSearchResults type exposes the following members.

Constructors

Name | Description
SolrSearchResults | Initializes a new instance of the SolrSearchResults class

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List<(Of <(SolrResultDocument>)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List<(Of <(SolrResultDocument>)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <(SolrResultDocument>)>).)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <(SolrResultDocument>)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List<(Of <(SolrResultDocument>)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List<(Of <(SolrResultDocument>)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <(SolrResultDocument>)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List<(Of <(SolrResultDocument>)>).)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List<(Of <(SolrResultDocument>)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List<(Of <(SolrResultDocument>)>).)

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List<(Of <(SolrResultDocument>)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
Item | Gets or sets the element at the specified index. (Inherited from List<(Of <(SolrResultDocument>)>).)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds an item to the IList. (Inherited from List<(Of <(SolrResultDocument>)>).)
IList..::.Contains | Determines whether the IList contains a specific value. (Inherited from List<(Of <(SolrResultDocument>)>).)
ICollection..::.CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from List<(Of <(SolrResultDocument>)>).)
System#Collections#Generic#IEnumerable{T}#GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from List<(Of <(SolrResultDocument>)>).)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from List<(Of <(SolrResultDocument>)>).)
IList..::.IndexOf | Determines the index of a specific item in the IList. (Inherited from List<(Of <(SolrResultDocument>)>).)
IList..::.Insert | Inserts an item to the IList at the specified index. (Inherited from List<(Of <(SolrResultDocument>)>).)
IList..::.IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from List<(Of <(SolrResultDocument>)>).)
System#Collections#Generic#ICollection{T}#IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from List<(Of <(SolrResultDocument>)>).)
IList..::.IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from List<(Of <(SolrResultDocument>)>).)
ICollection..::.IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from List<(Of <(SolrResultDocument>)>).)
IList..::.Item | Gets or sets the element at the specified index. (Inherited from List<(Of <(SolrResultDocument>)>).)
IList..::.Remove | Removes the first occurrence of a specific object from the IList. (Inherited from List<(Of <(SolrResultDocument>)>).)
ICollection..::.SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from List<(Of <(SolrResultDocument>)>).)

See Also

SolrSearchResults Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


SolrSearchResults Constructor

[image]

LinkOne WebView API
SolrSearchResults Constructor
SolrSearchResults Class See Also Send Feedback
Initializes a new instance of the SolrSearchResults class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public SolrSearchResults()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SolrSearchResults()

See Also

SolrSearchResults Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


SolrSearchResults Methods

[image] [image]

LinkOne WebView API
SolrSearchResults Methods
SolrSearchResults Class See Also Send Feedback

The SolrSearchResults type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List<(Of <(SolrResultDocument>)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List<(Of <(SolrResultDocument>)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <(SolrResultDocument>)>).)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <(SolrResultDocument>)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
GetType | Gets the type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List<(Of <(SolrResultDocument>)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List<(Of <(SolrResultDocument>)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <(SolrResultDocument>)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List<(Of <(SolrResultDocument>)>).)
ToString | Returns a string that represents the current object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List<(Of <(SolrResultDocument>)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List<(Of <(SolrResultDocument>)>).)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds an item to the IList. (Inherited from List<(Of <(SolrResultDocument>)>).)
IList..::.Contains | Determines whether the IList contains a specific value. (Inherited from List<(Of <(SolrResultDocument>)>).)
ICollection..::.CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from List<(Of <(SolrResultDocument>)>).)
System#Collections#Generic#IEnumerable{T}#GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from List<(Of <(SolrResultDocument>)>).)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from List<(Of <(SolrResultDocument>)>).)
IList..::.IndexOf | Determines the index of a specific item in the IList. (Inherited from List<(Of <(SolrResultDocument>)>).)
IList..::.Insert | Inserts an item to the IList at the specified index. (Inherited from List<(Of <(SolrResultDocument>)>).)
IList..::.Remove | Removes the first occurrence of a specific object from the IList. (Inherited from List<(Of <(SolrResultDocument>)>).)

See Also

SolrSearchResults Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


BinarySearch Method

[image] [image]

LinkOne WebView API
SolrSearchResults..::.BinarySearch Method
SolrSearchResults Class See Also Send Feedback

Overload List

Name | Description
BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List<(Of <(SolrResultDocument>)>).)
BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List<(Of <(SolrResultDocument>)>).)
BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List<(Of <(SolrResultDocument>)>).)

See Also

SolrSearchResults Class
SolrSearchResults Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


CopyTo Method

[image] [image]

LinkOne WebView API
SolrSearchResults..::.CopyTo Method
SolrSearchResults Class See Also Send Feedback

Overload List

Name | Description
CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List<(Of <(SolrResultDocument>)>).)
CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List<(Of <(SolrResultDocument>)>).)
CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List<(Of <(SolrResultDocument>)>).)

See Also

SolrSearchResults Class
SolrSearchResults Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


FindIndex Method

[image] [image]

LinkOne WebView API
SolrSearchResults..::.FindIndex Method
SolrSearchResults Class See Also Send Feedback

Overload List

Name | Description
FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List<(Of <(SolrResultDocument>)>).)
FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List<(Of <(SolrResultDocument>)>).)

See Also

SolrSearchResults Class
SolrSearchResults Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


FindLastIndex Method

[image] [image]

LinkOne WebView API
SolrSearchResults..::.FindLastIndex Method
SolrSearchResults Class See Also Send Feedback

Overload List

Name | Description
FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List<(Of <(SolrResultDocument>)>).)
FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List<(Of <(SolrResultDocument>)>).)

See Also

SolrSearchResults Class
SolrSearchResults Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


IndexOf Method

[image] [image]

LinkOne WebView API
SolrSearchResults..::.IndexOf Method
SolrSearchResults Class See Also Send Feedback

Overload List

Name | Description
IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List<(Of <(SolrResultDocument>)>).)
IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List<(Of <(SolrResultDocument>)>).)

See Also

SolrSearchResults Class
SolrSearchResults Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


LastIndexOf Method

[image] [image]

LinkOne WebView API
SolrSearchResults..::.LastIndexOf Method
SolrSearchResults Class See Also Send Feedback

Overload List

Name | Description
LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List<(Of <(SolrResultDocument>)>).)
LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List<(Of <(SolrResultDocument>)>).)

See Also

SolrSearchResults Class
SolrSearchResults Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Reverse Method

[image] [image]

LinkOne WebView API
SolrSearchResults..::.Reverse Method
SolrSearchResults Class See Also Send Feedback

Overload List

Name | Description
Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List<(Of <(SolrResultDocument>)>).)

See Also

SolrSearchResults Class
SolrSearchResults Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Sort Method

[image] [image]

LinkOne WebView API
SolrSearchResults..::.Sort Method
SolrSearchResults Class See Also Send Feedback

Overload List

Name | Description
Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List<(Of <(SolrResultDocument>)>).)
Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List<(Of <(SolrResultDocument>)>).)
Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List<(Of <(SolrResultDocument>)>).)

See Also

SolrSearchResults Class
SolrSearchResults Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


SolrSearchResults Properties

[image] [image]

LinkOne WebView API
SolrSearchResults Properties
SolrSearchResults Class See Also Send Feedback

The SolrSearchResults type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List<(Of <(SolrResultDocument>)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List<(Of <(SolrResultDocument>)>).)
Item | Gets or sets the element at the specified index. (Inherited from List<(Of <(SolrResultDocument>)>).)

Explicit Interface Implementations

Name | Description
IList..::.IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from List<(Of <(SolrResultDocument>)>).)
System#Collections#Generic#ICollection{T}#IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from List<(Of <(SolrResultDocument>)>).)
IList..::.IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from List<(Of <(SolrResultDocument>)>).)
ICollection..::.IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from List<(Of <(SolrResultDocument>)>).)
IList..::.Item | Gets or sets the element at the specified index. (Inherited from List<(Of <(SolrResultDocument>)>).)
ICollection..::.SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from List<(Of <(SolrResultDocument>)>).)

See Also

SolrSearchResults Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


TargetBookmark Class

[image]

LinkOne WebView API
TargetBookmark Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public class TargetBookmark
Visual Basic (Declaration)
Public Class TargetBookmark
Visual C++
public ref class TargetBookmark

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.TargetBookmark

See Also

TargetBookmark Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


TargetBookmark Members

[image] [image]

LinkOne WebView API
TargetBookmark Members
TargetBookmark Class Constructors Methods Properties See Also Send Feedback

The TargetBookmark type exposes the following members.

Constructors

Name | Description
TargetBookmark | Initializes a new instance of the TargetBookmark class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
BookCode |
BookmarkName |
PublisherCode |

See Also

TargetBookmark Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


TargetBookmark Constructor

[image]

LinkOne WebView API
TargetBookmark Constructor
TargetBookmark Class See Also Send Feedback
Initializes a new instance of the TargetBookmark class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public TargetBookmark()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TargetBookmark()

See Also

TargetBookmark Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


TargetBookmark Methods

[image] [image]

LinkOne WebView API
TargetBookmark Methods
TargetBookmark Class See Also Send Feedback

The TargetBookmark type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TargetBookmark Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


TargetBookmark Properties

[image] [image]

LinkOne WebView API
TargetBookmark Properties
TargetBookmark Class See Also Send Feedback

The TargetBookmark type exposes the following members.

Properties

Name | Description
BookCode |
BookmarkName |
PublisherCode |

See Also

TargetBookmark Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


BookCode Property

[image]

LinkOne WebView API
TargetBookmark..::.BookCode Property
TargetBookmark Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string BookCode { get; set; }
Visual Basic (Declaration)
Public Property BookCode As String
Visual C++
public:
property String^ BookCode {
    String^ get ();
    void set (String^ value);
}

See Also

TargetBookmark Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


BookmarkName Property

[image]

LinkOne WebView API
TargetBookmark..::.BookmarkName Property
TargetBookmark Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string BookmarkName { get; set; }
Visual Basic (Declaration)
Public Property BookmarkName As String
Visual C++
public:
property String^ BookmarkName {
    String^ get ();
    void set (String^ value);
}

See Also

TargetBookmark Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PublisherCode Property

[image]

LinkOne WebView API
TargetBookmark..::.PublisherCode Property
TargetBookmark Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PublisherCode { get; set; }
Visual Basic (Declaration)
Public Property PublisherCode As String
Visual C++
public:
property String^ PublisherCode {
    String^ get ();
    void set (String^ value);
}

See Also

TargetBookmark Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


TokenLog Class

[image]

LinkOne WebView API
TokenLog Class
Members See Also Send Feedback
Represents a token log entry.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public sealed class TokenLog
Visual Basic (Declaration)
Public NotInheritable Class TokenLog
Visual C++
public ref class TokenLog sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.TokenLog

See Also

TokenLog Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


TokenLog Members

[image] [image]

LinkOne WebView API
TokenLog Members
TokenLog Class Constructors Methods Properties See Also Send Feedback

The TokenLog type exposes the following members.

Constructors

Name | Description
TokenLog | Initializes a new instance of the TokenLog class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Time | Gets or sets the time.
Tokens | Gets or sets the tokens.
Website | Gets or sets the website.

See Also

TokenLog Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


TokenLog Constructor

[image]

LinkOne WebView API
TokenLog Constructor
TokenLog Class See Also Send Feedback
Initializes a new instance of the TokenLog class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public TokenLog()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TokenLog()

See Also

TokenLog Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


TokenLog Methods

[image] [image]

LinkOne WebView API
TokenLog Methods
TokenLog Class See Also Send Feedback

The TokenLog type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TokenLog Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


TokenLog Properties

[image] [image]

LinkOne WebView API
TokenLog Properties
TokenLog Class See Also Send Feedback

The TokenLog type exposes the following members.

Properties

Name | Description
Time | Gets or sets the time.
Tokens | Gets or sets the tokens.
Website | Gets or sets the website.

See Also

TokenLog Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Time Property

[image]

LinkOne WebView API
TokenLog..::.Time Property
TokenLog Class See Also Send Feedback
Gets or sets the time.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public DateTime Time { get; set; }
Visual Basic (Declaration)
Public Property Time As DateTime
Visual C++
public:
property DateTime Time {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The time.

See Also

TokenLog Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Tokens Property

[image]

LinkOne WebView API
TokenLog..::.Tokens Property
TokenLog Class See Also Send Feedback
Gets or sets the tokens.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public int Tokens { get; set; }
Visual Basic (Declaration)
Public Property Tokens As Integer
Visual C++
public:
property int Tokens {
    int get ();
    void set (int value);
}

Field Value

The tokens.

See Also

TokenLog Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Website Property

[image]

LinkOne WebView API
TokenLog..::.Website Property
TokenLog Class See Also Send Feedback
Gets or sets the website.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string Website { get; set; }
Visual Basic (Declaration)
Public Property Website As String
Visual C++
public:
property String^ Website {
    String^ get ();
    void set (String^ value);
}

Field Value

The website.

See Also

TokenLog Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


TokenLogType Enumeration

[image]

LinkOne WebView API
TokenLogType Enumeration
See Also Send Feedback
Defines the token log types.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public enum TokenLogType
Visual Basic (Declaration)
Public Enumeration TokenLogType
Visual C++
public enum class TokenLogType

Members

Member name | Description
TokensInUse | Indicates that the log type relates to tokens that were in use.
TokensRejected | Indicates that the log type relates to tokens that were rejected.
MaximumTokensAvailable | Indicates the maximum number of tokens available.

See Also

Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


ViewLog Class

[image]

LinkOne WebView API
ViewLog Class
Members See Also Send Feedback
Represents a view log entry.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public sealed class ViewLog
Visual Basic (Declaration)
Public NotInheritable Class ViewLog
Visual C++
public ref class ViewLog sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.ViewLog

See Also

ViewLog Members
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


ViewLog Members

[image] [image]

LinkOne WebView API
ViewLog Members
ViewLog Class Constructors Methods Properties See Also Send Feedback

The ViewLog type exposes the following members.

Constructors

Name | Description
ViewLog | Initializes a new instance of the ViewLog class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
BookCode | Gets or sets the book code.
BookLanguage | Gets or sets the book language.
PageReference | Gets or sets the page reference.
PublisherCode | Gets or sets the publisher code.
Time | Gets or sets the time.
UserName | Gets or sets the name of the user.

See Also

ViewLog Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


ViewLog Constructor

[image]

LinkOne WebView API
ViewLog Constructor
ViewLog Class See Also Send Feedback
Initializes a new instance of the ViewLog class

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public ViewLog()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewLog()

See Also

ViewLog Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


ViewLog Methods

[image] [image]

LinkOne WebView API
ViewLog Methods
ViewLog Class See Also Send Feedback

The ViewLog type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ViewLog Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


ViewLog Properties

[image] [image]

LinkOne WebView API
ViewLog Properties
ViewLog Class See Also Send Feedback

The ViewLog type exposes the following members.

Properties

Name | Description
BookCode | Gets or sets the book code.
BookLanguage | Gets or sets the book language.
PageReference | Gets or sets the page reference.
PublisherCode | Gets or sets the publisher code.
Time | Gets or sets the time.
UserName | Gets or sets the name of the user.

See Also

ViewLog Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


BookCode Property

[image]

LinkOne WebView API
ViewLog..::.BookCode Property
ViewLog Class See Also Send Feedback
Gets or sets the book code.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string BookCode { get; set; }
Visual Basic (Declaration)
Public Property BookCode As String
Visual C++
public:
property String^ BookCode {
    String^ get ();
    void set (String^ value);
}

See Also

ViewLog Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


BookLanguage Property

[image]

LinkOne WebView API
ViewLog..::.BookLanguage Property
ViewLog Class See Also Send Feedback
Gets or sets the book language.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string BookLanguage { get; set; }
Visual Basic (Declaration)
Public Property BookLanguage As String
Visual C++
public:
property String^ BookLanguage {
    String^ get ();
    void set (String^ value);
}

See Also

ViewLog Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PageReference Property

[image]

LinkOne WebView API
ViewLog..::.PageReference Property
ViewLog Class See Also Send Feedback
Gets or sets the page reference.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PageReference { get; set; }
Visual Basic (Declaration)
Public Property PageReference As String
Visual C++
public:
property String^ PageReference {
    String^ get ();
    void set (String^ value);
}

See Also

ViewLog Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


PublisherCode Property

[image]

LinkOne WebView API
ViewLog..::.PublisherCode Property
ViewLog Class See Also Send Feedback
Gets or sets the publisher code.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string PublisherCode { get; set; }
Visual Basic (Declaration)
Public Property PublisherCode As String
Visual C++
public:
property String^ PublisherCode {
    String^ get ();
    void set (String^ value);
}

See Also

ViewLog Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Time Property

[image]

LinkOne WebView API
ViewLog..::.Time Property
ViewLog Class See Also Send Feedback
Gets or sets the time.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public DateTime Time { get; set; }
Visual Basic (Declaration)
Public Property Time As DateTime
Visual C++
public:
property DateTime Time {
    DateTime get ();
    void set (DateTime value);
}

See Also

ViewLog Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


UserName Property

[image]

LinkOne WebView API
ViewLog..::.UserName Property
ViewLog Class See Also Send Feedback
Gets or sets the name of the user.

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public string UserName { get; set; }
Visual Basic (Declaration)
Public Property UserName As String
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

ViewLog Class
Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts Namespace


Mincom.LinkOne.WebView.WebServer.WebServices.Translators Namespace

[image]

LinkOne WebView API
Mincom.LinkOne.WebView.WebServer.WebServices.Translators Namespace
Send Feedback

Classes

Class | Description
SearchTranslator |


SearchTranslator Class

[image]

LinkOne WebView API
SearchTranslator Class
Members See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.Translators
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public static class SearchTranslator
Visual Basic (Declaration)
Public NotInheritable Class SearchTranslator
Visual C++
public ref class SearchTranslator abstract sealed

Inheritance Hierarchy

System..::.Object
Mincom.LinkOne.WebView.WebServer.WebServices.Translators..::.SearchTranslator

See Also

SearchTranslator Members
Mincom.LinkOne.WebView.WebServer.WebServices.Translators Namespace


SearchTranslator Members

[image] [image]

LinkOne WebView API
SearchTranslator Members
SearchTranslator Class Methods See Also Send Feedback

The SearchTranslator type exposes the following members.

Methods

Name | Description
TranslateSearch |
TranslateSearches |
TranslateSearchFields |
TranslateSearchKey |
TranslateSearchKeys |
TranslateSearchParameter |
TranslateSearchResult |
TranslateSearchResults |
TranslateSearchSet |
TranslateSearchSets |

See Also

SearchTranslator Class
Mincom.LinkOne.WebView.WebServer.WebServices.Translators Namespace


SearchTranslator Methods

[image] [image]

LinkOne WebView API
SearchTranslator Methods
SearchTranslator Class See Also Send Feedback

The SearchTranslator type exposes the following members.

Methods

Name | Description
TranslateSearch |
TranslateSearches |
TranslateSearchFields |
TranslateSearchKey |
TranslateSearchKeys |
TranslateSearchParameter |
TranslateSearchResult |
TranslateSearchResults |
TranslateSearchSet |
TranslateSearchSets |

See Also

SearchTranslator Class
Mincom.LinkOne.WebView.WebServer.WebServices.Translators Namespace


TranslateSearch Method

[image]

LinkOne WebView API
SearchTranslator..::.TranslateSearch Method
SearchTranslator Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.Translators
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public static Search TranslateSearch(
    Search search
)
Visual Basic (Declaration)
Public Shared Function TranslateSearch ( _
    search As Search _
) As Search
Visual C++
public:
static Search^ TranslateSearch(
    Search^ search
)

Parameters

search
Type: Mincom.LinkOne.Dom.Searching..::.Search

See Also

SearchTranslator Class
Mincom.LinkOne.WebView.WebServer.WebServices.Translators Namespace


TranslateSearches Method

[image]

LinkOne WebView API
SearchTranslator..::.TranslateSearches Method
SearchTranslator Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.Translators
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public static List<Search> TranslateSearches(
    SearchCollection searchCollection
)
Visual Basic (Declaration)
Public Shared Function TranslateSearches ( _
    searchCollection As SearchCollection _
) As List(Of Search)
Visual C++
public:
static List<Search^>^ TranslateSearches(
    SearchCollection^ searchCollection
)

Parameters

searchCollection
Type: Mincom.LinkOne.Dom.Searching..::.SearchCollection

See Also

SearchTranslator Class
Mincom.LinkOne.WebView.WebServer.WebServices.Translators Namespace


TranslateSearchFields Method

[image]

LinkOne WebView API
SearchTranslator..::.TranslateSearchFields Method
SearchTranslator Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.Translators
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public static List<SearchField> TranslateSearchFields(
    SearchFieldCollection searchFieldCollection
)
Visual Basic (Declaration)
Public Shared Function TranslateSearchFields ( _
    searchFieldCollection As SearchFieldCollection _
) As List(Of SearchField)
Visual C++
public:
static List<SearchField^>^ TranslateSearchFields(
    SearchFieldCollection^ searchFieldCollection
)

Parameters

searchFieldCollection
Type: Mincom.LinkOne.Dom.Searching..::.SearchFieldCollection

See Also

SearchTranslator Class
Mincom.LinkOne.WebView.WebServer.WebServices.Translators Namespace


TranslateSearchKey Method

[image]

LinkOne WebView API
SearchTranslator..::.TranslateSearchKey Method
SearchTranslator Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.Translators
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public static SearchKey TranslateSearchKey(
    SearchKey searchKey
)
Visual Basic (Declaration)
Public Shared Function TranslateSearchKey ( _
    searchKey As SearchKey _
) As SearchKey
Visual C++
public:
static SearchKey^ TranslateSearchKey(
    SearchKey^ searchKey
)

Parameters

searchKey
Type: Mincom.LinkOne.Dom.Searching..::.SearchKey

See Also

SearchTranslator Class
Mincom.LinkOne.WebView.WebServer.WebServices.Translators Namespace


TranslateSearchKeys Method

[image]

LinkOne WebView API
SearchTranslator..::.TranslateSearchKeys Method
SearchTranslator Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.Translators
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public static List<SearchKey> TranslateSearchKeys(
    SearchKeyCollection searchKeyCollection
)
Visual Basic (Declaration)
Public Shared Function TranslateSearchKeys ( _
    searchKeyCollection As SearchKeyCollection _
) As List(Of SearchKey)
Visual C++
public:
static List<SearchKey^>^ TranslateSearchKeys(
    SearchKeyCollection^ searchKeyCollection
)

Parameters

searchKeyCollection
Type: Mincom.LinkOne.Dom.Searching..::.SearchKeyCollection

See Also

SearchTranslator Class
Mincom.LinkOne.WebView.WebServer.WebServices.Translators Namespace


TranslateSearchParameter Method

[image]

LinkOne WebView API
SearchTranslator..::.TranslateSearchParameter Method
SearchTranslator Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.Translators
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public static SearchParameter TranslateSearchParameter(
    SearchParameter searchParameter
)
Visual Basic (Declaration)
Public Shared Function TranslateSearchParameter ( _
    searchParameter As SearchParameter _
) As SearchParameter
Visual C++
public:
static SearchParameter^ TranslateSearchParameter(
    SearchParameter^ searchParameter
)

Parameters

searchParameter
Type: Mincom.LinkOne.WebView.WebServer.WebServices.DataContracts..::.SearchParameter

See Also

SearchTranslator Class
Mincom.LinkOne.WebView.WebServer.WebServices.Translators Namespace


TranslateSearchResult Method

[image]

LinkOne WebView API
SearchTranslator..::.TranslateSearchResult Method
SearchTranslator Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.Translators
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public static SearchResult TranslateSearchResult(
    SearchResult searchResult
)
Visual Basic (Declaration)
Public Shared Function TranslateSearchResult ( _
    searchResult As SearchResult _
) As SearchResult
Visual C++
public:
static SearchResult^ TranslateSearchResult(
    SearchResult^ searchResult
)

Parameters

searchResult
Type: Mincom.LinkOne.Dom.Searching..::.SearchResult

See Also

SearchTranslator Class
Mincom.LinkOne.WebView.WebServer.WebServices.Translators Namespace


TranslateSearchResults Method

[image]

LinkOne WebView API
SearchTranslator..::.TranslateSearchResults Method
SearchTranslator Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.Translators
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public static List<SearchResult> TranslateSearchResults(
    SearchResultCollection searchResultCollection
)
Visual Basic (Declaration)
Public Shared Function TranslateSearchResults ( _
    searchResultCollection As SearchResultCollection _
) As List(Of SearchResult)
Visual C++
public:
static List<SearchResult^>^ TranslateSearchResults(
    SearchResultCollection^ searchResultCollection
)

Parameters

searchResultCollection
Type: Mincom.LinkOne.Dom.Searching..::.SearchResultCollection

See Also

SearchTranslator Class
Mincom.LinkOne.WebView.WebServer.WebServices.Translators Namespace


TranslateSearchSet Method

[image]

LinkOne WebView API
SearchTranslator..::.TranslateSearchSet Method
SearchTranslator Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.Translators
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public static SearchSet TranslateSearchSet(
    SearchSet searchSet
)
Visual Basic (Declaration)
Public Shared Function TranslateSearchSet ( _
    searchSet As SearchSet _
) As SearchSet
Visual C++
public:
static SearchSet^ TranslateSearchSet(
    SearchSet^ searchSet
)

Parameters

searchSet
Type: Mincom.LinkOne.Dom.Searching..::.SearchSet

See Also

SearchTranslator Class
Mincom.LinkOne.WebView.WebServer.WebServices.Translators Namespace


TranslateSearchSets Method

[image]

LinkOne WebView API
SearchTranslator..::.TranslateSearchSets Method
SearchTranslator Class See Also Send Feedback

Namespace: Mincom.LinkOne.WebView.WebServer.WebServices.Translators
Assembly: Mincom.LinkOne.WebView.WebServer (in Mincom.LinkOne.WebView.WebServer.dll) Version: 3.30.5386.0 (3.30.5386.0)

Syntax

C#
public static List<SearchSet> TranslateSearchSets(
    List<SearchSet> searchSets
)
Visual Basic (Declaration)
Public Shared Function TranslateSearchSets ( _
    searchSets As List(Of SearchSet) _
) As List(Of SearchSet)
Visual C++
public:
static List<SearchSet^>^ TranslateSearchSets(
    List<SearchSet^>^ searchSets
)

Parameters

searchSets
Type: System.Collections.Generic..::.List<(Of <( SearchSet >)>)

See Also

SearchTranslator Class
Mincom.LinkOne.WebView.WebServer.WebServices.Translators Namespace


Property

[image]

LinkOne WebView API
LayoutReader..::. Property
LayoutReader Class See Also Send Feedback
Gets the source.

Namespace: Mincom.LinkOne.Content.Layout
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
private LayoutSourceType Source { get; }
Visual Basic (Declaration)
Private ReadOnly Property Source As LayoutSourceType
Visual C++
private:
virtual property LayoutSourceType Source {
    LayoutSourceType get () sealed;
}

See Also

LayoutReader Class
Mincom.LinkOne.Content.Layout Namespace


Property

[image]

LinkOne WebView API
LayoutReader..::. Property
LayoutReader Class See Also Send Feedback
Gets the layout ID.

Namespace: Mincom.LinkOne.Content.Layout
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
private string Id { get; }
Visual Basic (Declaration)
Private ReadOnly Property Id As String
Visual C++
private:
virtual property String^ Id {
    String^ get () sealed;
}

See Also

LayoutReader Class
Mincom.LinkOne.Content.Layout Namespace


Property

[image]

LinkOne WebView API
LayoutReader..::. Property
LayoutReader Class See Also Send Feedback
Gets the XML layout definition.

Namespace: Mincom.LinkOne.Content.Layout
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
private string XmlLayoutDefinition { get; }
Visual Basic (Declaration)
Private ReadOnly Property XmlLayoutDefinition As String
Visual C++
private:
virtual property String^ XmlLayoutDefinition {
    String^ get () sealed;
}

See Also

LayoutReader Class
Mincom.LinkOne.Content.Layout Namespace


IReadOnlyList(Entry).Item Property (Int32)

[image]

LinkOne WebView API
EntryCollection..::.IReadOnlyList<(Of <(Entry>)>)..::.Item Property (Int32)
EntryCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
Entry IReadOnlyList<Entry>.Item[
    int index
] { get; }
Visual Basic (Declaration)
Private ReadOnly Property Item ( _
    index As Integer _
) As Entry Implements IReadOnlyList(Of Entry).Item
Visual C++
private:
virtual property Entry^ Item[int index] {
    Entry^ get (int index) sealed = IReadOnlyList<Entry^>::Item::get;
}

Parameters

index
Type: System..::.Int32

Implements

IReadOnlyList<(Of <(T>)>)..::.Item[([(Int32])])

See Also

EntryCollection Class
EntryCollection Overload
Mincom.LinkOne.Dom Namespace


ICollection(INote).IsReadOnly Property

[image]

LinkOne WebView API
NoteCollection..::.ICollection<(Of <(INote>)>)..::.IsReadOnly Property
NoteCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom.Notes
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
bool ICollection<INote>.IsReadOnly { get; }
Visual Basic (Declaration)
Private ReadOnly Property IsReadOnly As Boolean
    Implements ICollection(Of INote).IsReadOnly
Visual C++
private:
virtual property bool IsReadOnly {
    bool get () sealed = ICollection<INote^>::IsReadOnly::get;
}

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

NoteCollection Class
NoteCollection Overload
Mincom.LinkOne.Dom.Notes Namespace


Property

[image]

LinkOne WebView API
LayoutReader..::. Property
LayoutReader Class See Also Send Feedback
Gets the file name without the extension.

Namespace: Mincom.LinkOne.Content.Layout
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
private string Location { get; }
Visual Basic (Declaration)
Private ReadOnly Property Location As String
Visual C++
private:
virtual property String^ Location {
    String^ get () sealed;
}

Remarks

Returns an empty string for internal layouts.

See Also

LayoutReader Class
Mincom.LinkOne.Content.Layout Namespace


Property

[image]

LinkOne WebView API
LayoutReader..::. Property
LayoutReader Class See Also Send Feedback
Gets the language code of the layout.

Namespace: Mincom.LinkOne.Content.Layout
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
private string LanguageCode { get; }
Visual Basic (Declaration)
Private ReadOnly Property LanguageCode As String
Visual C++
private:
virtual property String^ LanguageCode {
    String^ get () sealed;
}

See Also

LayoutReader Class
Mincom.LinkOne.Content.Layout Namespace


Property

[image]

LinkOne WebView API
LayoutReader..::. Property
LayoutReader Class See Also Send Feedback
Gets the layout description.

Namespace: Mincom.LinkOne.Content.Layout
Assembly: Mincom.LinkOne.Content (in Mincom.LinkOne.Content.dll) Version: 3.58.5361.0

Syntax

C#
private string Description { get; }
Visual Basic (Declaration)
Private ReadOnly Property Description As String
Visual C++
private:
virtual property String^ Description {
    String^ get () sealed;
}

See Also

LayoutReader Class
Mincom.LinkOne.Content.Layout Namespace


IReadOnlyKeyedCollection(Int32, Entry).Item Property (Int32)

[image]

LinkOne WebView API
EntryCollection..::.IReadOnlyKeyedCollection<(Of <(Int32, Entry>)>)..::.Item Property (Int32)
EntryCollection Class See Also Send Feedback

Namespace: Mincom.LinkOne.Dom
Assembly: Mincom.LinkOne.Dom (in Mincom.LinkOne.Dom.dll) Version: 3.58.5361.0 (3.58.5361.0)

Syntax

C#
Entry IReadOnlyKeyedCollection<int, Entry>.Item[
    int tagNumber
] { get; }
Visual Basic (Declaration)
Private ReadOnly Property Item ( _
    tagNumber As Integer _
) As Entry Implements IReadOnlyKeyedCollection(Of Integer, Entry).Item
Visual C++
private:
virtual property Entry^ Item[int tagNumber] {
    Entry^ get (int tagNumber) sealed = IReadOnlyKeyedCollection<int, Entry^>::Item::get;
}

Parameters

tagNumber
Type: System..::.Int32

Implements

IReadOnlyKeyedCollection<(Of <(TKey, TItem>)>)..::.Item[([(TKey])])

See Also

EntryCollection Class
EntryCollection Overload
Mincom.LinkOne.Dom Namespace